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1.  Copyright Notice
© Copyright 2022 Esko Software BV, Gent, Belgium

All rights reserved. This material, information and instructions for use contained herein are the
property of Esko Software BV. The material, information and instructions are provided on an AS IS
basis without warranty of any kind. There are no warranties granted or extended by this document.
Furthermore Esko Software BV does not warrant, guarantee or make any representations regarding
the use, or the results of the use of the software or the information contained herein. Esko Software
BV shall not be liable for any direct, indirect, consequential or incidental damages arising out of the use
or inability to use the software or the information contained herein.

The information contained herein is subject to change without notice. Revisions may be issued from
time to time to advise of such changes and/or additions.

No part of this document may be reproduced, stored in a data base or retrieval system, or published, in
any form or in any way, electronically, mechanically, by print, photoprint, microfilm or any other means
without prior written permission from Esko Software BV.

This document supersedes all previous dated versions.

PANTONE
®

 Colors displayed in the software application or in the user documentation may not match
PANTONE-identified standards. Consult current PANTONE Color Publications for accurate color.
PANTONE

®
 and other Pantone trademarks are the property of Pantone LLC. © Pantone LLC, 2015

Pantone is the copyright owner of color data and/or software which are licensed to Esko to distribute
for use only in combination with Studio Visualizer. PANTONE Color Data and/or Software shall not be
copied onto another disk or into memory unless as part of the execution of Studio Visualizer.

This software is based in part on the work of the Independent JPEG Group.

Portions of this software are copyright © 1996-2002 The FreeType Project (www.freetype.org). All
rights reserved.

Portions of this software are copyright 2006 Feeling Software, copyright 2005-2006 Autodesk Media
Entertainment.

Portions of this software are copyright ©1998-2003 Daniel Veillard. All rights reserved.

Portions of this software are copyright ©1999-2006 The Botan Project. All rights reserved.

Part of the software embedded in this product is gSOAP software. Portions created by gSOAP are
Copyright ©2001-2004 Robert A. van Engelen, Genivia inc. All rights reserved.

Portions of this software are copyright ©1998-2008 The OpenSSL Project and ©1995-1998 Eric Young
(eay@cryptsoft.com). All rights reserved.

This product includes software developed by the Apache Software Foundation (http://
www.apache.org/).

Adobe, the Adobe logo, Acrobat, the Acrobat logo, Adobe Creative Suite, Illustrator, InDesign, PDF,
Photoshop, PostScript, XMP and the Powered by XMP logo are either registered trademarks or
trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Microsoft and the Microsoft logo are registered trademarks of Microsoft Corporation in the United
States and other countries.

SolidWorks is a registered trademark of SolidWorks Corporation.

Portions of this software are owned by Spatial Corp. 1986 2003. All Rights Reserved.
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JDF and the JDF logo are trademarks of the CIP4 Organisation. Copyright 2001 The International
Cooperation for the Integration of Processes in Prepress, Press and Postpress (CIP4). All rights
reserved.

The Esko software contains the RSA Data Security, Inc. MD5 Message-Digest Algorithm.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun
Microsystems in the U.S. and other countries.

Part of this software uses technology by Best Color Technology (EFI). EFI and Bestcolor are registered
trademarks of Electronics For Imaging GmbH in the U.S. Patent and Trademark Oce.

Contains PowerNest library Copyrighted and Licensed by Alma, 2005 – 2007.

Part of this software uses technology by GlobalVision. ArtProof and ScanProof are registered
trademarks of GlobalVision Inc.

Part of this software uses technology by Qoppa Software. Copyright © 2002-Present. All Rights
Reserved.

All other product names are trademarks or registered trademarks of their respective owners.

Correspondence regarding this publication should be forwarded to:

Esko Software BV

Raymonde de Larochelaan 13

B – 9051 Gent

info.eur@esko.com
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2.  WebCenter Connector Plug-In
WebCenter Connector opens various file types stored in WebCenter in Adobe

®
 Illustrator

®
. It also

exports files back to WebCenter.

Access WebCenter Connector using the commands on the File menu in Adobe Illustrator.
 

 

Note:

For using WebCenter Connector in combination with Studio, please refer to the Studio
documentation.

2.1.  Starting WebCenter Connector

1. Click File > WebCenter > Open.
2. In the WebCenter Connector dialog box:

a) Make sure there is a valid WebCenter address in the Address field. To save an address for future
use, enter one and click Add.

b) Enter the username and password given to you by your WebCenter administrator.
c) Click Login.

The Open from WebCenter dialog box appears.

2.2.  Browser window elements

The browser has 3 main areas.
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Area Function

1 The menu bar, toolbar, and display bar, where you use commands and tools,
search for Projects and documents, control what is shown in the document list,
and log out of WebCenter.

2 Tree control where you select which Project or folder to view, or which saved
search to perform. The browser also shows search results here. Drag the bar
between the tree and the document list to adjust the size as desired.

3 List of documents in the selected Project or folder, or search results or recent
Projects depending on the node you select in the tree. Scroll to the right to see
all the available columns.

Open becomes available when you select a file.

The browser uses the color choice you set in Illustrator's preferences.

2.2.1.  The Browser Toolbar

The browser toolbar, shown below, lets you move between Project views, change the icon size, refresh
the view, and log out of WebCenter. Clicking Logout also closes the browser.
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Button Tool Active When

Back You have viewed at least two
Projects or folders and have a
previous view

Forward You are seeing a previous view and
can go forward to another view

     

List Style Always active.

Refresh A Project is selected. This
requeries the database for updated
information about the Project.

Version History Information A document is selected.

Logout Always active.

     

2.2.2.  Search Controls

Use the search controls to search for Projects and documents.
 

 

Area Function

1 Search Type drop-down list box with which you choose what to search for

2 Keyword entry field where you enter the terms to search for

3 Search button that starts the keyword search
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Performing searches is covered later in this chapter.

2.2.3.  Document Display Control

The document display control filters the list of shown documents. Choose the type of documents the
browser shows from the drop-down list.
 

 

When you select Graphic Images, WebCenter Connector shows the following types of files:

• *.ai
• *.ap
• *.bmp
• *.ct
• *.dcs
• *.epf
• *.eps
• *.grs
• *.jpeg
• *.jpg
• *.len
• *.lp
• *.paf
• *.pdfpla
• *.pla
• *.png
• *.ps
• *.psd
• *.tga
• *.tif
• *.tiff
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Note:

THIS CONTROL DETERMINES THE DOCUMENTS YOU SEE IN THE DOCUMENT LIST. IF YOU
ARE LOOKING FOR A DOCUMENT AND CANNOT FIND IT, MAKE SURE THIS CONTROL IS SET
PROPERLY.

2.2.4.  Paging Controls

The paging controls let you navigate search results. The browser displays 25 documents per page of
search results. Click Read More to show more lines.
 

 

2.2.5.  Tree Control

The tree control lets you work with Projects, folders, searches, and documents.
 

 

The tree has two top-level nodes:

• Projects

• Search

When you select a Project, WebCenter Connector displays a count after the Project name of the
number of documents in the root folder of the Project and then the total number of documents in the
Project. When you select a folder within a Project, it displays the number of documents in the folder
after the folder name.
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Projects Node
The Projects node of the tree control contains several nodes itself.
 

 

Recent Projects shows the four most recent Projects from which you have opened or placed a
document, or to which you have exported a document. The most recent Project is at the top of the list.
WebCenter Connector remembers recent Projects from up to 3 different WebCenter servers.

Favorite Projects shows those Projects you have designed as favorites in WebCenter or ArtiosCAD
Enterprise.

Projects I Manage shows Projects you manage. If you are not a Project Manager, this node is empty.

Projects I Am Invited To shows those Projects of which you are a member.

Projects on My Computer shows those Projects which are stored in the local database cache on your
computer. WebCenter Connector stores a copy of each Project you explicitly look in or open files from
in the local database cache. If you need to reduce the size of the database cache to make more disc
space available, right-click a Project in this node and click Remove Project from My Computer to
delete your local copy. You may also right-click Projects on My Computer itself and click Remove All to
remove all the cached Projects at once.
 

 
Please note that if you take your computer oine, you will not be able to access a Project if you delete
it from your local database cache.

All Projects shows all Projects you have permission to see.

Search Node
The Search node shows the results of the current search and also shows saved searches you can run
when desired.
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Searching is covered later in this chapter.

2.2.6.  Customizing the Columns in the Document List

You can customize the columns WebCenter Connector shows in the document list by right-clicking on a
column header and clicking Customize to open the Column Customization dialog box.
 

 

Select the checkboxes for the columns to display and deselect the checkboxes of the columns to hide.
All columns are selected by default. Click OK when done to return to the browser.
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2.3.  Using the WebCenter Palette in Adobe Illustrator

The WebCenter palette in Adobe Illustrator shows information about the current document if it
contains links to WebCenter. To show or hide this palette, click Window > Esko > WebCenter.
 

 

The top pane of the palette shows information about your connection to the WebCenter server. The
bottom pane shows information about the current file and can be collapsed if desired.

 Use Synchronize to get the latest details of a linked CAD file from the WebCenter server. It also
updates the name and location of the document if you have changed it within the same Project.

 Use Login to connect to WebCenter without having to open or place a file.

 Use Logout to break the connection to WebCenter.

Click the filename to launch a browser and open the file in WebCenter. Since you are already logged in,
you go directly to the file.

Depending on your login state and what you have open, the palette displays varying amounts of
information.

The Attributes table lists the Attributes for the document. Double-click an Attribute to show more
information about it or to change its value.
 

12



2WebCenter Connector

 
Click inside the Value field to change it. Use the arrows to move between Attributes. Click OK to save
the changes. If the document does not have any Attributes, the palette does not show the table.

2.4.  Searching

Keyword searching lets you search the names of Projects and documents for a specific word or part of
a word.

1. Click the Search Type drop down-list box and choose the type of object to search for.
2. In the keyword entry field, enter the word to search for. To search on part of a word, use an asterisk

to replace the other part(s) of the word.
3. Click the magnifying glass button to start the search.
4. Depending on what you searched for, results will appear in the node tree, the document list, or both.

Note:  Make sure that you set the filetype selector appropriately after performing a search. The
browser may list a number of search results, but if the filetype selector is set incorrectly, you
may not see the results you were expecting.

2.4.1.  Using a Saved Search

1. In the tree control of the browser, expand the Search node.
2. Expand the Saved Searches catalog.
3. Expand either Project Searches or Document Searches.
4. Expand either Global or Personal.
5. Click the desired saved search. It will run automatically.

Depending on what you searched for, results will appear in the node tree, the document list, or both.
Make sure to set the filetype selector appropriately so that you see the results you expect.
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2.5.  Opening or Placing a Document from WebCenter

1. Click File > WebCenter > Open (or Place) to open the WebCenter Connector dialog box.
2. Choose a server and log in with your username and password.
3. Use the browser to navigate to the Project containing the desired document, or search for it. Make

sure to set the Files of Type selector appropriately.
4. Select the document to open or place.
5. Click Open or Place.
6. WebCenter Connector downloads the file and opens or places it in Adobe Illustrator.

 

 
7. Work on the file as desired.

Use the instructions in other sections to export this document back to WebCenter.

Note:  You may place as many ArtiosCAD structural design documents from WebCenter as
desired.
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Note:  If the original structural design file changes, WebCenter Connector warns you and asks
if you want to download the updated version. Click Yes to download and update the file or No to
keep working with the current version.
 

 
WebCenter Connector checks every 5 minutes for changes unless you check Do not show this
message again, in which case it stops checking and does not show you if there are further
changes until the next time you open the Adobe Illustrator document.

If a native Illustrator document you open contains a link to a WebCenter document, and you are
not logged in to that server, WebCenter Connector may prompt you to log in to that server for error
checking to occur.

If you have multiple documents open from different WebCenter servers, and switch to working in a
document from a server that you are not currently logged in to, WebCenter Connector may prompt you
to log in to that server for error checking to occur.

2.5.1.  Working with Annotations

If the file has annotations added to it in the WebCenter Viewer, WebCenter Connector displays them
and opens the Annotations palette.
 

15



2 WebCenter Connector

 

Click an annotation in the palette to emphasize it on the art board.

In the Annotations palette, use Zoom to zoom in on the selected annotation on the art board. Show
only selected annotation hides the non-selected annotations.
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Click Update Annotations on the palette's menu to synchronize the annotations with those in
WebCenter.

2.6.  Opening or Placing an Earlier Version of a Document

The document list in WebCenter Connector shows the latest version of the document. To open or place
an earlier version of the document, do the following:

1. Open WebCenter Connector by clicking File > WebCenter > Open or Place.
2. Either:

a) Right-click a document in the document list and click Select Version on the context menu.
 

 
b)

 Select the document in the list and click Version History Information on the toolbar.
3. WebCenter Connector opens the Document History dialog box.
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4. Select the desired version of the document and click Open or Place.
5. WebCenter Connector opens or places the document in the Illustrator document.

Note:  You can also view the version history of a CHILI package this way, but you cannot open
or place it. To work with earlier versions of a CHILI package, use the Dynamic Content plug-in.

2.7.  Opening a Document in a Web Browser

1. Right-click a document in the document list and click Open in Web Browser on the context menu.
 

 
2. WebCenter Connector launches the default Web browser, connects to WebCenter, and opens the

Action History tab of the Document Details page for the selected document.
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3. Work on the document in WebCenter as desired.

2.8.  Exporting a Native Adobe Illustrator Document to
WebCenter

To export a non-normalized PDF file from Adobe Illustrator into WebCenter, do the following:

1. When you are done working on the document in Adobe Illustrator, click File > WebCenter > Export >
Adobe Illustrator (ai).

2. In the Illustrator Options dialog box, set the options as desired and click OK.
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3. Use the browser to navigate to the location where you want to save the file.
4. The filename is seeded to the name of the workspace. Change it if desired.
5. If this is a new version of an existing file, enter a comment for this version.
6. Click Export. WebCenter Connector uploads the Adobe Illustrator file.

Note:

If the document contains external links, WebCenter Connector preserves the links but does not
additionally export their targets.
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2.9.  Exporting an Adobe PDF document to WebCenter

To export a non-normalized PDF file from Adobe Illustrator into WebCenter, do the following:

1. When you are done working on the document in Adobe Illustrator, click File > WebCenter > Export >
Adobe PDF.

2. In the Save Adobe PDF dialog box, set the options as desired and click Save PDF.
 

 
3. Use the browser to navigate to the location where you want to save the file.
4. The filename is seeded to the name of the workspace. Change it if desired.
5. If this is a new version of an existing file, enter a comment for this version.
6. Click Export. WebCenter Connector uploads the PDF file.
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2.10.  Exporting an Esko PDF document to WebCenter

An Esko PDF document is a PDF with additional metadata useful to Esko applications. There are two
types, PDF+ with processing steps functionality, and Normalized PDF for compatibility with older
software. Select the format of Esko PDF document to use in the Preferences panel of the Ink Manager
plug-in, part of the Data Exchange plug-in.

1. When you are done working on the document in Adobe Illustrator, click File > WebCenter > Export >
Esko PDF.

2. Use the browser to navigate to the location where you want to save the file.
3. The filename is seeded to the name of the workspace. Change it if desired.
4. If this is a new version of an existing file, enter a comment for this version.
5. Click Export. WebCenter Connector uploads the PDF file.

2.11.  Structural Design Files and WebCenter

2.11.1.  Exporting Structural Designs to WebCenter

The Structural Design Export saves a copy of the selected structural design file to WebCenter. The
Illustrator file will link to the newly saved structural design file.

Note:  .BAG files are not supported

1. Choose File > Structural Design > Export to WebCenter and select the Structural Design you want
to export.

2. Use the browser to navigate to the location where you want to save the file.
3. The filename is seeded to the name of the workspace. Change it if desired.
4. If this is a new version of an existing file, enter a comment for this version.
5. Click Export. WebCenter Connector uploads the PDF file.

2.11.2.  Replacing a Structural Design from WebCenter

If you want to replace the placed printable parts of a structural design file while preserving the
alignment between the technical drawing and the artwork, you can replace a structural design file.

1. Choose File > Structural Design > Replace from WebCenter and select the name of the structural
design file you want to replace

2. Choose a server and log in with your username and password.
3. Use the browser to navigate to the Project containing the desired document, or search for it. Make

sure to set the Files of Type selector appropriately.
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4. Select the document to place.
5. Click Place.

2.11.3.  Exporting Selected Objects to ArtiosCAD File in WebCenter

If you have the Structural Design plug-in installed as well as WebCenter Connector, you can export a
placed ArtiosCAD document with its changed art to WebCenter instead of a file.

1. Open the Adobe Illustrator workspace containing the placed ArtiosCAD document.
2. Make the desired changes in Adobe Illustrator and select them.
3. Click File > Structural Design > Export Selected Objects to ArtiosCAD File.

 

 
4. Set the options as desired and click Export to WebCenter.
5. The upload creates a copy by default by appending _copy to the filename. Change it if desired and

click Export.
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6. WebCenter Connector uploads the file to WebCenter.

If you selected both Include a copy of ... and Place this ArtiosCAD file in the document, WebCenter
Connector then replaces the currently placed ArtiosCAD document with the new version. Use this
combination with caution as you could lose graphics in Adobe Illustrator and resizability in ArtiosCAD.

2.12.  Exporting as a CHILI Package

To export an Adobe Illustrator document as a CHILI package to WebCenter, do the following.

1. Click File > WebCenter > Export > CHILI Package.
2. Set the options in the Export to CHILI Publisher Options dialog box. To look at the variable settings,

click Review Variables to Export, and click Close when done. Click OK.
 

 
3. Use the browser to navigate to the location where you want to save the file.
4. The filename is seeded to the name of the workspace. Change it if desired.
5. If this is a new version of an existing file, enter a comment for this version.
6. Click Export. WebCenter Connector displays a progress bar.
7. Illustrator displays a status message when the upload finishes. Click OK.
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2.13.  Setting WebCenter Connector Preferences

In the WebCenter Connector Preferences dialog box, you can set file download locations, automatic
cache clearing, and on the Macintosh, network proxy settings. On computers using Microsoft Windows,
WebCenter Connector uses the system-wide proxy settings.

To set WebCenter Connector preferences, do the following in Adobe Illustrator:

• On the PC, click Edit > Preferences > Esko > WebCenter Connector Preferences.

• On the Macintosh, click Illustrator > Preferences > Esko > WebCenter Connector Preferences.

2.13.1.  Setting the Download Location for Adobe Illustrator Packages and
Graphics Files

To set the default locations WebCenter Connector uses to store Adobe Illustrator compressed
packages and graphics files, do the following:

1. Open the WebCenter Connector Preferences dialog box as described in Setting WebCenter
Connector Preferences on page 25.

2. For both AI Packages and Graphics Files, either type a location in the field, or click Select and use
the Choose Download Location dialog box to select the desired location. Once the desired locations
are in the fields, click OK.
 

 
3. If either location does not exist, WebCenter Connector prompts to create it.
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4. WebCenter Connector will put the AI packages or graphics files you download from now on in the
location you specified.

2.13.2.  Automatically Controlling the Size of the Download Cache

As you download content from WebCenter, WebCenter Connector stores it in the locations you set in
the WebCenter Connector Preferences dialog box. You can choose to automatically delete files of the
following types from the cache when it reaches 100 megabytes in size.

• ArtiosCAD documents (.ARD files)

• Collada self-contained archives (.ZAE files)

• CHILI packages (.CHP files)
• Portable Document Format files (.PDF files)

1. Open the WebCenter Connector Preferences dialog box as described in Setting WebCenter
Connector Preferences on page 25.

2. Select Auto clear cache when the size exceeds 100MB.
3. Click OK.

WebCenter Connector deletes the oldest files first until the cache size is beneath 100 MB.

2.13.3.  Configuring Network Proxy Support on the Apple Macintosh

If you are using a Macintosh, the WebCenter Connector Preferences dialog box has a Network Settings
group.
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The default setting in WebCenter Connector is Automatically detect system proxy settings.

To use a different proxy, or to specify a username and password to use with the proxy, select Use
manual proxy settings.
 

 
The two options are mutually exclusive. Deselect both options to disable the use a network proxy.

In the Proxy Server field, enter the address of the proxy server, starting with either http:// or https:// as
appropriate for the protocol, such as https://proxy.mydomain.com. Enter the port number for the proxy
in the field after the colon.

If the proxy server requires a username and password, check Proxy server requires password, and
enter the username and password in the fields provided.

Click OK when done to activate the proxy settings.
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Note:  On systems using Microsoft Windows, WebCenter Connector reads the system proxy
settings automatically and does not need additional configuration.
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