Contents

1. Copyright Notice................................................................................................................. 4

2. What is Shuttle?.................................................................................................................. 6
   2.1 Shuttle Client/Server Configuration........................................................................... 6
   2.2 Shuttle Setup Overview............................................................................................ 6

3. Automation Engine Setup for Shuttle.............................................................................. 8
   3.1 Making Your Ticket Public....................................................................................... 9
   3.2 Using Public Parameters in Automation Engine.................................................... 10
      3.2.1 Making a Parameter Public............................................................................... 10
      3.2.2 Managing Public Parameters in Your Ticket.................................................... 11
      3.2.3 SmartNames in Public Parameters.................................................................... 15
   3.3 Setting Up Operator Routing in Your Workflow..................................................... 16

4. Odystar Setup for Shuttle.................................................................................................. 19
   4.1 Connection Setup...................................................................................................... 19
      4.1.1 Creating an Odystar Spool Folder................................................................... 20
   4.2 License Expiry Notification Setup............................................................................. 21
   4.3 Access Rights Setup.................................................................................................. 21
   4.4 Parameter Assistant Setup......................................................................................... 22
      4.4.1 Setting up a Database for the Parameter Assistant........................................... 24
   4.5 Shuttle Parameters in Odystar Receive Process Folders.......................................... 25
   4.6 Making Parameters Public for Shuttle in Odystar................................................... 27
   4.7 Setting up the Hold Process Folder for Shuttle....................................................... 28

5. Nexus Setup for Shuttle..................................................................................................... 30
   5.1 Setting up the NexusSOAPServer.......................................................................... 30
      5.1.1 Setting up a Shared Folder or a HotFolder for Shuttle...................................... 32
      5.1.2 Making Nexus Broadcast over Bonjour........................................................... 32
      5.1.3 Setting up a Database for the Parameter Assistant.......................................... 33
      5.1.4 Connecting Nexus to your Database................................................................ 33
   5.2 Enabling Shuttle in a Nexus Hot Folder..................................................................... 34
   5.3 Making Parameters Public for Shuttle in Nexus....................................................... 35
   5.4 Setting up the Wait for OK Activity for Shuttle......................................................... 37
   5.5 Setting up the Decision Activity for Shuttle............................................................. 39

6. Shuttle Clients Setup.......................................................................................................... 42
   6.1 Connecting your Shuttle Client to your Workflow Server....................................... 42
      6.1.1 Shuttle Clients Connecting to Any Server......................................................... 42
      6.1.2 Shuttle Clients Connecting only to Automation Engine.................................... 44
   6.2 Defining Preferences................................................................................................. 45
6.2.1 Display Preferences.................................................................................................................. 45
6.2.2 Public Parameters Preferences.................................................................................................. 46
6.2.3 Filtering Preferences.................................................................................................................. 47
6.2.4 Workflow Units Preferences...................................................................................................... 47

7. Launching Files into a Workflow....................................................................................................... 49
   7.1 Launching Files from the Shuttle Plug-in...................................................................................... 49
   7.2 Launching Files from ArtPro.......................................................................................................... 50
   7.3 Launching Files from Neo............................................................................................................. 52
   7.4 Launching Files from PackEdge or Plato.................................................................................... 53
   7.5 Launching Files from FastImpose................................................................................................. 54

8. Monitoring Files..................................................................................................................................... 56
   8.1 The Shuttle Window....................................................................................................................... 56
      8.1.1 The Shuttle Window Buttons.................................................................................................. 56
      8.1.2 The Connection to Workflow Servers..................................................................................... 57
      8.1.3 The Shuttle Window Filter..................................................................................................... 58
      8.1.4 The Files List.......................................................................................................................... 58
      8.1.5 The Context Menu.................................................................................................................. 59
      8.1.6 The Inspector Panel................................................................................................................ 61
      8.1.7 Showing Only Your Files / Everybody's Files......................................................................... 62

9. Working with Shuttle when your File is Processing........................................................................ 63
   9.1 Opening Files / the Enclosing Folder............................................................................................ 63
   9.2 Changing a File's Public Parameters............................................................................................ 64
   9.3 Holding or Releasing a File.......................................................................................................... 64
   9.4 Changing a File's Priority............................................................................................................. 65
   9.5 Opening the Log............................................................................................................................ 66
   9.6 Routing Files that Need a Decision............................................................................................. 66
   9.7 Deleting a File from your Workflow............................................................................................ 67
1. Copyright Notice

© Copyright 2012 Esko Software BVBA, Gent, Belgium

All rights reserved. This material, information and instructions for use contained herein are the property of Esko Software BVBA. The material, information and instructions are provided on an AS IS basis without warranty of any kind. There are no warranties granted or extended by this document. Furthermore Esko Software BVBA does not warrant, guarantee or make any representations regarding the use, or the results of the use of the software or the information contained herein. Esko Software BVBA shall not be liable for any direct, indirect, consequential or incidental damages arising out of the use or inability to use the software or the information contained herein.

The information contained herein is subject to change without notice. Revisions may be issued from time to time to advise of such changes and/or additions.

No part of this document may be reproduced, stored in a data base or retrieval system, or published, in any form or in any way, electronically, mechanically, by print, photoprint, microfilm or any other means without prior written permission from Esko Software BVBA.

This document supersedes all previous dated versions.

PANTONE®, PantoneLIVE and other Pantone trademarks are the property of Pantone LLC. All other trademarks or registered trademarks are the property of their respective owners. Pantone is a wholly owned subsidiary of X-Rite, Incorporated. © Pantone LLC, 2012. All rights reserved.

This software is based in part on the work of the Independent JPEG Group.

Portions of this software are copyright © 1996-2002 The FreeType Project (www.freetype.org). All rights reserved.

Portions of this software are copyright 2006 Feeling Software, copyright 2005-2006 Autodesk Media Entertainment.

Portions of this software are copyright ©1998-2003 Daniel Veillard. All rights reserved.

Portions of this software are copyright ©1999-2006 The Botan Project. All rights reserved.

Part of the software embedded in this product is gSOAP software. Portions created by gSOAP are Copyright ©2001-2004 Robert A. van Engelen, Genivia inc. All rights reserved.

Portions of this software are copyright ©1998-2008 The OpenSSL Project and ©1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

Adobe, the Adobe logo, Acrobat, the Acrobat logo, Adobe Creative Suite, Illustrator, InDesign, PDF, Photoshop, PostScript, XMP and the Powered by XMP logo are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Microsoft and the Microsoft logo are registered trademarks of Microsoft Corporation in the United States and other countries.

SolidWorks is a registered trademark of SolidWorks Corporation.

Portions of this software are owned by Spatial Corp. 1986 2003. All Rights Reserved.

JDF and the JDF logo are trademarks of the CIP4 Organisation. Copyright 2001 The International Cooperation for the Integration of Processes in Prepress, Press and Postpress (CIP4). All rights reserved.
The Esko software contains the RSA Data Security, Inc. MD5 Message-Digest Algorithm.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems in the U.S. and other countries.

Part of this software uses technology by BestTM Color Technology (EFI). EFI and Bestcolor are registered trademarks of Electronics For Imaging GmbH in the U.S. Patent and Trademark Office.


All other product names are trademarks or registered trademarks of their respective owners.

Correspondence regarding this publication should be forwarded to:

Esko Software BVBA
Kortrikssesteenweg 1095
B – 9051 Gent
info.eur@esko.com
2. What is Shuttle?

Shuttle enables you to submit files to Automation Engine tasks or workflows, Odystar canvases, and Nexus workflows, and monitor their progress. You can use Shuttle to connect to several servers.

The Shuttle functionality is integrated in ArtPro, Neo, PackEdge, Plato, FastImpose and in Adobe Illustrator as a DeskPack plug-in.

2.1 Shuttle Client/Server Configuration

<table>
<thead>
<tr>
<th>You can submit files to...</th>
<th>with those Shuttle clients...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automation Engine</td>
<td>• Shuttle plug-in&lt;br&gt;• Shuttle in Neo&lt;br&gt;• Shuttle in ArtPro&lt;br&gt;• Shuttle in PackEdge&lt;br&gt;• Shuttle in Plato&lt;br&gt;• Shuttle in FastImpose Server or Standalone</td>
</tr>
<tr>
<td>Odystar</td>
<td>• Shuttle plug-in&lt;br&gt;• Shuttle in Neo&lt;br&gt;• Shuttle in ArtPro&lt;br&gt;• Shuttle in FastImpose Standalone</td>
</tr>
<tr>
<td>Nexus</td>
<td>• Shuttle plug-in&lt;br&gt;• Shuttle in Neo&lt;br&gt;• Shuttle in ArtPro&lt;br&gt;• Shuttle in FastImpose Standalone</td>
</tr>
</tbody>
</table>

2.2 Shuttle Setup Overview

To use Shuttle to monitor and submit files to your workflow server, you need to set up your server, your Shuttle client, and make sure they can exchange files via a shared folder.

**Workflow Server Setup**

Set up your workflow server for Shuttle in either:

- the Odystar Hub (see *Odystar Setup for Shuttle*),
- the NexusSOAPServer (see *Nexus Setup for Shuttle*),
- Automation Engine’s Configure tool (see *Automation Engine Setup for Shuttle*).

**Shuttle Client Setup**

Set up your Shuttle client in the applications you use. See *Shuttle Clients Setup*.
Shared Folder Setup

You also need to make sure that the relevant servers’ shared folders are mounted on the Shuttle clients machines, with the appropriate Read and Write permissions.

- For Odystar, see Creating an Odystar Spool Folder.
- For Nexus, see Setting a Shared Folder or a HotFolder for Shuttle.
- For Automation Engine, the shared folder is either an Automation Engine Container, or an Upload Folder you set up in Configure. See Automation Engine Setup for Shuttle.
3. Automation Engine Setup for Shuttle

1. In the Pilot, go to Tools > Configure.
2. Select Shuttle in the left pane.

3. Enter the Port to use for communication between your Automation Engine server and the Shuttle clients.

   **Note:** By default this is port 5182, but if this port is already used by other processes, you should enter the next available port.

4. Choose an **Upload Folder** using the **Browse...** button.

   This is where Shuttle clients will upload files that are not located in a container (except the Shuttle plug-in, that will always upload files to the **DeskPackContainer**).

   **Note:** The **Upload Folder** must be located on a container.

5. Select **Start Shuttle server automatically when Automation Engine is started** if you plan to make frequent use of the Shuttle technology.

6. Click the **Start** button to start Shuttle server.

   Shuttle server makes Automation Engine’s workflows, tasks and files accessible to the Shuttle clients.

7. Save your settings.

   **Note:** If you need to make changes to this Setup, you must **Stop** the Shuttle server first.
3.1 Making Your Ticket Public

**Important:** With Shuttle, you can submit files to any Automation Engine task, task chain or workflow that has a custom ticket. To do this, you need to make the ticket public.

You can either:

- Select the Public option when creating the ticket.

  ![Save As dialog box](image)

  - Ticket Name: Trap_nestedWF
  - Scope: Global
  - Add to Favorites: None
  - Public: Selected

- Select your ticket in the Ticket view, click ![Information icon](image) and select Public.

  ![Ticket view](image)

  - Task Type: Workflow
  - Description: None
  - Public: Selected

- Right-click your ticket in the Ticket view and select Public Ticket.

**Note:** Public tickets have a mark in the Public column.
3.2 Using Public Parameters in Automation Engine

Public parameters are ticket parameters that operators can define when submitting files through Shuttle.

For each public parameter, you can either:

- enter a list of predefined values the operator will choose from,
- let the operator enter a value himself.

### 3.2.1 Making a Parameter Public

**Note:** You need to define which parameters are public before files are submitted to your workflow.

In the ticket containing the parameter to make public:

1. Right-click the parameter and select **Make Parameter Public**.
2. Right-click it again and select **Modify Public Parameter**...
3. In the **Modify Public Parameter** dialog that opens:
   a) If necessary, change the way the parameter will be called in Shuttle in **Prompt as**.
   b) Choose either:
      - **Allow the user to set the value** if you want Shuttle users to be able to freely enter a value for that parameter.
      - **Let the user select a predefined value** if you want Shuttle users to choose from a list of values that you define.
If that parameter already has a list of values to choose from in the Ticket, they will be displayed here. You can Add or Remove values.

**Note:** Shuttle operators will see (and choose from) the Predefined Settings but not the associated Values.

c) If you have chosen *Let the user select a predefined value:* in Default Predefined Setting, choose the setting that will be selected by default when submitting files from Shuttle (if the operator doesn’t select another setting, this one will be used for processing).

4. Don’t forget to save your ticket.

This is how your public parameter will look to Shuttle operators:

<table>
<thead>
<tr>
<th>If you chose <em>Allow the user to set the value</em></th>
<th>If you chose <em>Let the user select a predefined value</em></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Custom Resolution 150ppi" /></td>
<td><img src="image" alt="Custom Resolution" /></td>
</tr>
</tbody>
</table>

### 3.2.2 Managing Public Parameters in Your Ticket

Once you have made parameters public in your ticket, you can have an overview of your public parameters and edit them at the ticket level.

1. In your ticket, go to **Advanced > Manage Public Parameters**...

   The **Manage Public Parameters** dialog that opens contains all of your ticket’s public parameters.
The left pane shows all parameters that can be made public for that ticket (the ones you have made public are greyed out).

The right pane shows the parameters you have made public, with their settings (predefined values, etc.).

2. You can:
   - drag parameters from left to right to make them public;
   - click a public parameter's cross X if you don’t want it to be public anymore;
   - rearrange the order of your public parameters (drag them up or down);
   - change public parameters’ settings (Prompt as, Predefined Settings, etc.);
   - group public parameters under a header (click Add Group, click ☮ to edit the header, and drag parameters from the left);
• use presets to simplify operators’ choices (see *Using Presets to Simplify Operators’ Choices*).

**Using Presets to Simplify Operators’ Choices**

You can use presets to minimize the amount of public parameters your operators have to choose from, and make it simpler for them.

For example, you want operators to use different trapping settings for printing with offset or dry offset. You can define those trapping settings in a preset, so that operators will only have to choose between offset and dry offset.

In the *Manage Public Parameters* dialog:

1. Click the *Add Preset* button.
2. Enter what your operators will see:
   a) in *Prompt as*, enter the name to give the preset parameter in Shuttle,
   b) enter the values that operators will choose from (replacing *Type a value here*).

   Click *Add* if you need to add extra values.
3. Drag parameters from the dialog's left pane into the preset.

You can drag as many parameters as you want. They will appear under each value (here both under Offset and Dry Offset).
4. Define the parameters values for each preset value.
   For example, define normal trapping, 50% opacity and object dependant end caps for Offset, and reverse trapping, 100% opacity and round end caps for Dry Offset.

5. Don’t forget to save your ticket.
   This is how your preset will look to Shuttle operators:

3.2.3 SmartNames in Public Parameters

You can use SmartNames in your public parameters (for parameters taking SmartNames as input).
In Shuttle, use square brackets around SmartNames when submitting a file with public parameters.
3.3 Setting Up Operator Routing in Your Workflow

You can build your workflow so that operators will route your files based on their expertise. They will get a notification, and the processing will be paused until they decide where to send the file. To use this in your workflow:

1. Add the **Wait for Action (Checkpoint)** step to your workflow.
2. Double-click the step to open its settings.
3. Create the notification that will be sent:
   a) choose which user you want to send it to,
   b) enter a **Subject**,
   c) add a **Message** if desired.
4. Choose a **Due date**. Either:
• choose one of the predefined due dates (from Immediate to Next sunday),
• choose Other... in the Due date list and pick the due date yourself.

5. In Output states, define the output possibilities you want for your checkpoint.

By default, this step has two outputs: Completed and Aborted.

To add an output:
  a) click Add,
  b) enter the output’s name.

Add as many outputs as you like.

6. If necessary, use the Move Up and Move Down buttons to display your outputs in a different order.

Note: You can Remove the default outputs if you don’t need them.

7. If you want your file to be automatically sent through one of the outputs if no action is taken by the operator after a period of time:
  a) select Release automatically,
  b) enter the time delay after which the file should be released,
  c) choose the output to release the file to.

8. Click OK to apply your settings.
9. On your canvas, the Checkpoint step has the outputs you defined. Connect each output to the appropriate step.

Operators will be able to route files gone through the Checkpoint from the Pilot's Tasks pane, the workflow editor, or Shuttle.
4. Odystar Setup for Shuttle

Odystar’s Hub application makes the Odystar Canvases and jobs accessible to the Shuttle clients.

4.1 Connection Setup

1. On your Odystar server, launch the Hub application. You can find it in Odystar’s Server Software folder.

2. Go to Hub > Preferences.
   You can also use the shortcut Command + , (comma).

3. In the Shuttle tab, configure the Server parameters (that you will use to find your Hub from Shuttle or Shuttle plug-in).
   a) Enter the IP Address of the server running your Hub, and the port to use for SOAP communication between Shuttle and Hub (in Shuttle Port).
      
      Note: By default this is port 5182, but if this port is already used by other processes, you should enter the next available port.

   b) If you want to broadcast your Odystar server over the Apple Bonjour™ network, enter a Bonjour Name for it.

4. Create a Spool Folder with appropriate permissions for Shuttle users. See Creating an Odystar Spool Folder.

5. Browse to your Spool Folder.

6. Define how Shuttle applications on client machines can access your Spool Folder: in Spool Folder URLs, click the + button. This opens the following popup:
If your Spool Folder is located... | Then you should...
---|---
... on the server running your Hub: | 1. Choose Automatic.<br>2. Select your Spool Folder in the **Shared Folder** menu (which contains all shared folders on your server).<br>3. Choose the **Protocol** you want to use: choose `afp` to access the Spool Folder from Shuttles on Mac machines, or `smb` to access it from Shuttles on Windows machines.

... somewhere else in your network - or if it is on the server running your Hub but you need to define its URL manually: | 1. Choose **Manual**.<br>2. Enter the **URL** of your Spool Folder, including the protocol. Your URL should look like `afp://<server>/<spool folder path>` or `smb://<server>/<spool folder path>`.

**Note:** Add both an `afp` and a `smb` URL if some Shuttle users have Mac machines and other have Windows machines. You can only define one `afp` and one `smb` URL.

### 4.1.1 Creating an Odystar Spool Folder

The **Spool Folder** is used to submit jobs from Shuttle applications to Odystar Canvases. Shuttle or the Shuttle plug-in copy jobs to the Spool Folder, and Odystar Receive Gateways pick them up for processing.

1. Create the folder you want to use as a Spool Folder.<br>We strongly recommend you create your Spool Folder on the machine running your Odystar Hub.
2. Share your Spool Folder, and give all Shuttle users Read and Write permissions for it.
   * If your Odystar server is a Mac OS 10.5.x, go to **System Preferences > Sharing** to share your Spool Folder.
• If your Odystar server is a Mac OS 10.4.x, you need to use the SharePoints application to share your Spool Folder. You can download this application for free from http://www.hornware.com/sharepoints/.

3. If the Spool Folder has the required permissions, your Shuttle applications can auto-mount it when you submit a job to a workflow.

If Shuttle fails to auto-mount your spool folder, mount it manually on your Shuttle client machine(s).

4.2 License Expiry Notification Setup

At the bottom of the Shuttle tab, choose how to notify Shuttle users of the expiry of Odystar licenses.

Choose between:

• No users are notified through Shuttle,
• All users are notified through Shuttle,
• Only specified users are notified through Shuttle. In this case, enter the Users to notify, separating their names by commas.

4.3 Access Rights Setup

1. In the Hub’s Preferences, go to the Access Rights tab.
2. Choose which users can delete which jobs:
   - Users can only delete their own jobs,
   - All users can delete all jobs,
   - Only specified users can delete all jobs. In this case, enter the Users that can delete all jobs, separating their names by commas.

3. Choose which users can change the priority of which jobs:
   a) Choose if users can change the priority of their own jobs or not (Allow user to change priority of his jobs).
   b) Choose who can change the priority of all jobs:
      - No users can change priority of all jobs,
      - All users can change priority of all jobs,
      - Only specified users can change priority of all jobs. In this case, enter the Users that can change the priority of all jobs, separating their names by commas.

4. Choose which users can hold or release which jobs:
   - Users can only hold or release their own jobs,
   - All users can hold or release all jobs,
   - Only specified users can hold or release all jobs. In this case, enter the Users that can hold or release all jobs, separating their names by commas.

4.4 Parameter Assistant Setup

The Parameter Assistant stores public parameters you defined when submitting jobs, and allows you to re-use these parameters when submitting the same job to the same workflow. It works with a SQL database.
1. Install and configure a MySQL or PostGreSQL database (see Setting up a Database for the Parameter Assistant).

2. In the Hub’s Preferences, go to the Parameter Assistant tab.

3. Choose your Database Type: MySQL or PostGreSQL.

4. Enter the name or the address of the server hosting your database in Host. This can be your Odystar server or another server.

5. Enter the Port used by your database. This is generally Server Default.

6. Click OK.

In the Hub Statistics window (Window > Hub Statistics), the SQL Server indicator is green, meaning the Hub is connected to the SQL database.

You will now be able to use the Parameter Assistant in Shuttle.
For more information about using the Parameter Assistant in Shuttle, see The Parameter Assistant.

4.4.1 Setting up a Database for the Parameter Assistant

Download the PostgreSQL, MySQL in ArtPro, Nexus, Odystar, Neo technote from the Download Center. It contains important information about how to install and set up your SQL database.

The Technote SQL.zip folder you download also contains setup scripts for using MySQL with Nexus (see below).

1. Download and install MySQL or PostgreSQL (see http://mysql.com or http://www.postgresql.org for more information).

2. Set up a database user for Librarian and the Parameter Assistant, with a supplied script or manually:

<table>
<thead>
<tr>
<th>If you are using...</th>
<th>Do this on your database server...</th>
</tr>
</thead>
<tbody>
<tr>
<td>A MySQL database and an Odystar workflow.</td>
<td>Run the MySQL Permissions Setup.command script, located in your Odystar 4.0/Configuration folder.</td>
</tr>
<tr>
<td>A MySQL database and a Nexus workflow.</td>
<td>Use one of the scripts located in the Technote SQL.zip folder you downloaded from the Download Center:</td>
</tr>
<tr>
<td></td>
<td>• If you installed your database on a Windows system, use the UserScript.bat script.</td>
</tr>
</tbody>
</table>
If you are using... | Do this on your database server...
---|---
• If you installed your database on a Macintosh system, use the UserScript.command script.
A PostgreSQL database and an Odystar or a Nexus workflow. | You need to set up the user manually.

4.5 Shuttle Parameters in Odystar Receive Process Folders

1. Double-click on the Receive Process Folder of your Odystar Canvas to open its parameters.

2. In the Shuttle tab, click Enable Shuttle Queue.
This shows a workflow queue for that Process Folder in Shuttle’s Launch window.
3. Enter a Queue Type (for example Proofing Workflows) to be able to filter the workflow queues you see in the Launch window. To set up the workflow queue type filter in Shuttle, see Filtering Preferences.

4. If your canvas has a main and an auxiliary input, enter the name of the auxiliary Receive Process Folder as it appears on the canvas in Auxiliary Queue.

   For example, the following workflow has a main Receive Process Folder for RunLists and an auxiliary Receive Process Folder for single page PDF files.

   ![Workflow Diagram](image)

   In this case, you should enter Receive Pages as Auxiliary Queue name.

5. Choose the way you want to submit files from Shuttle to this Receive Process Folder:

   - Choose No Support For Multiple Files to be able to only submit individual files through Shuttle.
   - Choose Accept Multiple Files to be able to submit several files at once through Shuttle, either as one or as several jobs.
   - Choose Main and Support Files to be able to submit several files at once through Shuttle, as one or as several jobs, and to be able to determine which files are main or support files when submitting.

   **Note:** For more information about submitting multiple files, or a main and support files, see Submitting Multiple Files and Submitting a Main and Support Files.
6. Use the Main File Filter when submitting Multiple Files or Main and Support Files through Shuttle. Enter a part of the main file’s name (e.g., “*.odrlst” if your main file is a RunList) so that Shuttle can identify it automatically as the main file.

7. To only show your Shuttle queue to certain users, enable Limit Visibility Only to Predefined Users, and enter their Username(s) in Predefined Users.

4.6 Making Parameters Public for Shuttle in Odystar

Making parameters public in Odystar allows you to fill those parameters in from Shuttle, when you submit files to the Odystar canvas.

1. On your canvas, double-click the gateway whose parameter(s) you want to make public.
2. In the Parameters window that opens, right-click on the parameter you want to make public and select Public Parameter.

![Public Parameter Icon]

This shows the public parameter icon beside it in the Parameters window.

![Folder Name Input]

When you submit a file to your workflow through Shuttle, you will see a pop-up with the public parameter(s) for you to fill in.
Attention:

If you make a parameter using a Naming Template public, only the first fixed text field in the Naming Template will become public.

If the Naming Template doesn’t contain any fixed text, that public parameter will not be visible in Shuttle.

For more information about Naming Templates, please see the Odystar documentation.

4.7 Setting up the Hold Process Folder for Shuttle

When your job is in a Hold Gateway in an Odystar workflow, you can do several things from Shuttle:

- route the job towards one of several possible workflow paths,
- open the job as it is at that point of the workflow,
- edit the job’s public parameters for the rest of the workflow.

1. In the Hold Gateway’s Parameters dialog, click the Shuttle tab.
2. Enable Require Attention.
3. Enter a Message to help operators decide on how to route the job. This message will be shown in Shuttle.
4. In the Output Options List parameter group, enter a Message for each choice.
Those messages will be shown in Shuttle.

These choices correspond to different outputs of the Hold Gateway, taking different routes in the workflow.

5. If needed, you can also set the Gateway to change the Status of the job when selecting a choice in Shuttle.

You can assign one of the following statuses to the job:

- Don’t Modify,
- OK,
- Warning,
- Error.
5. Nexus Setup for Shuttle

The NexusSOAPServer makes the Nexus workflows and jobs accessible to the Shuttle clients.

5.1 Setting up the NexusSOAPServer

To set up the NexusSOAPServer, you need to use the NexusManager application to connect to your Nexus server. You can run it on any machine.

1. Do the following to open the NexusSOAPServer's Preferences:
   a) Launch the NexusManager application.
   b) Connect to a Nexus server.
   c) Still in NexusManager, go to View > Modules, or use the Command + 5 shortcut.
   d) In the Modules dialog, double click on NexusSOAPServer.

This opens the NexusSOAPServer's Preferences.
2. Enter the port to use for SOAP communication with Shuttle in Listening Port.
   By default this is port 5182, but if this port is already used by other processes, you should enter
   the next available port.

3. Enable the Parameter Assistant option if you want to be able to re-submit jobs to Nexus using
   the same parameters. For more information on the Parameter Assistant, see The Parameter
   Assistant.
   
   **Note**: This option is only available if Nexus is connected to a MySQL database set up for Librarian
   and the Parameter Assistant. For more information, see Setting up a Database for the Parameter
   Assistant and Connecting Nexus to your Database.

4. Enable User Management if you want to restrict the workflows users see in Shuttle to those they
   have access to in NexusManager.
   
   **Note**: In this case, make sure that the Shuttle user name and the NexusManager user name are
   the same. See Shuttle Clients Connecting to Any Server on page 42 to know how to define
   your Shuttle user name.

5. Choose between Direct File Access and Shared Folder.
   
   • Choose Direct File Access for Shuttle to open files directly from the server, without copying
     them to a temporary folder.
   
   **Note**: Choose Direct File Access if you want to be able to open files from ArtPro’s Shuttle.
   
   • Choose Shared Folder to use a temporary folder (use the browse button to select it). Nexus
     will copy files to that folder, and Shuttle will open them from there.
   
   **Note**: Your shared folder needs to have the correct permissions and to be accessible from the
   Nexus server and all Shuttle clients. See Setting up a Shared Folder or a HotFolder for Shuttle.
5. Click OK.

5.1.1 Setting up a Shared Folder or a HotFolder for Shuttle

1. Create a folder either on your Nexus server or on another server.
2. If you created your folder on another server:
   a) Give it read and write permissions for the user under which you installed Nexus on your Nexus server.
   b) Mount it on your Nexus server.
3. Give your folder read and write permissions for all Shuttle users.
4. If the Spool Folder has the required permissions, your Shuttle applications can auto-mount it when you submit a job to a workflow.

   If Shuttle fails to auto-mount your spool folder, mount it manually on your Shuttle client machine(s).

5.1.2 Making Nexus Broadcast over Bonjour

You can set your Nexus server to broadcast over the Apple Bonjour network, so you can connect to it from Shuttle without needing to know its IP address.

1. On your Nexus server, launch the NexusConfig application.
2. In the Nexus tab, select Broadcast on the Local Network using Bonjour.
5. Click Apply Changes.

5.1.3 Setting up a Database for the Parameter Assistant

Download the PostgreSQL, MySQL in ArtPro, Nexus, Odystar, Neo technote from the Download Center. It contains important information about how to install and set up your SQL database.

The Technote SQL.zip folder you download also contains setup scripts for using MySQL with Nexus (see below).

1. Download and install MySQL or PostgreSQL (see http://mysql.com or http://www.postgresql.org for more information).
2. Set up a database user for Librarian and the Parameter Assistant, with a supplied script or manually:

<table>
<thead>
<tr>
<th>If you are using...</th>
<th>Do this on your database server...</th>
</tr>
</thead>
<tbody>
<tr>
<td>A MySQL database and an Odystar workflow.</td>
<td>Run the MySQL Permissions Setup.command script, located in your Odystar 4.0/Configuration folder.</td>
</tr>
<tr>
<td>A MySQL database and a Nexus workflow.</td>
<td>Use one of the scripts located in the Technote SQL.zip folder you downloaded from the Download Center:</td>
</tr>
<tr>
<td></td>
<td>• If you installed your database on a Windows system, use the UserScript.bat script.</td>
</tr>
<tr>
<td></td>
<td>• If you installed your database on a Macintosh system, use the UserScript.command script.</td>
</tr>
<tr>
<td>A PostgreSQL database and an Odystar or a Nexus workflow.</td>
<td>You need to set up the user manually.</td>
</tr>
</tbody>
</table>

5.1.4 Connecting Nexus to your Database

1. On your Nexus server, launch the NexusConfig application.
2. In the Librarian tab, choose the type of database you are using.
3. If you are using a MySQL or PostgreSQL database:
   a) enter the database Server Address,
   b) click Test... to test the connection to the database server.
4. Click Apply Changes.

5.2 Enabling Shuttle in a Nexus Hot Folder

1. When creating a Nexus workflow, choose Hot Folder as Input Type.

2. In the dialog that opens, browse to your Hot Folder (or use the default one).
Your Hot Folder needs to have the correct permissions and to be accessible from the Nexus server and all Shuttle clients. See Setting up a Shared Folder or a HotFolder for Shuttle.

3. In the Settings tab, enable Show in Shuttle.

This shows a workflow queue for that Hot Folder in Shuttle's Launch window.

5.3 Making Parameters Public for Shuttle in Nexus

Making parameters public in Nexus allows you to fill those parameters in from Shuttle, when you submit files to the Nexus workflow.

1. In your workflow, double-click the activity whose parameter(s) you want to make public.
2. In the settings window that opens, right-click the parameter to make public and select **Public**.

3. Click **OK**.

4. Go to **View > Monitors** or use **Command + 3**.

5. Double-click your Hot Folder's name to opens its parameters.
6. In the NeXML tab, click the Upload Public Parameters button. This creates a PublicParameters.xml file containing your public parameters.

7. If necessary, click the Edit... button to edit your public parameters (for example to change your public parameters' names or their default value).

8. Click OK to save your public parameters in your workflow Hot Folder.

When you submit a file to your workflow through Shuttle, you will see a pop-up with the public parameter(s) for you to fill in.

5.4 Setting up the Wait for OK Activity for Shuttle

When your job is in a Wait for OK Activity in a Nexus workflow, you can do several things from Shuttle:

- Release the job to the rest of the workflow or Abort (stop) it,
- open the job as it is at that point of the workflow,
- edit the job's public parameters for the rest of the workflow.
- To be able to identify and open the files that are in the Wait for OK Activity from Shuttle, give this Activity a label in your workflow.

To do this, select the Wait for OK Activity and enter a Label at the bottom left of the Nexus Workflow Editor window.

This label will be visible to the Shuttle operator when he has to release or abort the job...

or when he wants to open one of the job files.
5.5 Setting up the Decision Activity for Shuttle

When your job is in a Decision Activity in a Nexus workflow, you can do several things from Shuttle:

- route the job towards one of several possible workflow paths,
- open the job as it is at that point of the workflow,
- edit the job's public parameters for the rest of the workflow.

1. In your workflow, give a label to the Decision Activity.
   
   To do this, select the Decision Activity and enter a Label at the bottom left of the Nexus Workflow Editor window.

2. Give a label to each of the Activities that you can route the job to.
3. Double-click your Decision Activity to open the Decision window.

4. Drag the arrow of the first Activity you can route your job to (PDF Trapper in the example) in the Decision window. Do the same thing for every other Activity you can route your job to (Rasterise Separations in the example).

   Your Activities' labels are listed under Option Name.

5. You can modify every Option Name by double-clicking it.

6. If needed, you can choose a Default Activity and give a Timeout for the decision. This way, the job will be released automatically to the Default Activity if the operator hasn't routed it within the time specified.

7. Click OK.

   The Shuttle operator will see the Decision Activity’s label and the Option Names of the Activities following it when he has to route the job to one of the possible workflow paths.
He will also be able to open the file in the Decision Activity based on its label.
6. Shuttle Clients Setup

6.1 Connecting your Shuttle Client to your Workflow Server

6.1.1 Shuttle Clients Connecting to Any Server

The Shuttle plug-in and the Shuttle clients in ArtPro, Neo and FastImpose Standalone can connect to a number of Odystar, Nexus and Automation Engine servers.

1. Launch your application.
2. Open the Preferences.

<table>
<thead>
<tr>
<th>In...</th>
<th>go to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Illustrator</td>
<td>• Illustrator &gt; Preferences &gt; EskoArtwork &gt; Shuttle Preferences... on Mac</td>
</tr>
<tr>
<td></td>
<td>• Edit &gt; Preferences &gt; EskoArtwork &gt; Shuttle Preferences... on Windows</td>
</tr>
<tr>
<td>ArtPro</td>
<td>ArtPro &gt; Preferences... or use Command + K</td>
</tr>
<tr>
<td>Neo</td>
<td>Neo &gt; Preferences... or use Command + , (comma)</td>
</tr>
<tr>
<td>FastImpose Standalone</td>
<td>Tools &gt; Shuttle Preferences...</td>
</tr>
</tbody>
</table>

3. In the Servers tab (Advanced tab for Neo), click the button at the bottom of the Servers list.

This opens the following pop-up:
4. Enter your User Name and Password.
   
   • When connecting to an Automation Engine server, enter the User Name and Password you use to login to the Pilot (the password can be blank if your server is configured to accept this).
   
   You will have the same access rights (for example, the right to set processing priorities or not) in Shuttle as you have in the Pilot.
   
   • When connecting to a Nexus server, enter the User Name and Password you use to login to the NexusManager if your Nexus server has User Management enabled (see Setting up the NexusSOAPServer).
   
   You will be able to access the same workflows as from NexusManager.

   **Note:** If User Management is not enabled, you will be able to access any workflow on your server. In this case, you can enter any user name you like (without a password): it will only be used for filtering files in the Shuttle window.

   • When connecting to an Odystar server, you will be able to access any workflow on your server. You can enter any user name you like (without a password): it will only be used for filtering files in the Shuttle window.

   **Note:** If you don’t know which User Name and Password to use, contact your system administrator.

5. To connect to a server broadcasting over the Bonjour network (Odystar servers or Bonjour-enabled Nexus servers):
   
   a) select Bonjour in the Browse Method list,
   b) select your server’s name in the Bonjour list.

   **Note:** You don’t have to enter the server address and server port manually.

6. To connect to a server not broadcasting over the Bonjour network (Automation Engine servers or non-Bonjour-enabled Nexus servers):
   
   a) select Manual in the Browse Method list,
   b) enter your server’s name or IP address in Server Address,
   c) fill in the Server Port used by your server.
Note:
When connecting to an Odystar server, enter the port used for SOAP communication between Shuttle and your Odystar Hub (see Connection Setup).

When connecting to a Nexus server, enter the Listening Port of the NexusSOAPServer (see Setting up the NexusSOAPServer).

When connecting to an Automation Engine server, enter the port you defined in Configure (see Automation Engine Setup for Shuttle).

7. Click the Add button.

This adds a connection to your server in the Servers list.

- To remove the connection to a server, select it in the Servers list and click the button.
- To check or edit a server’s settings, double-click it in the Servers list.

Note:
If you are using the Shuttle plug-in with other Deskpack plug-ins, and you have setup a server connection with the Server Connection Assistant, you will see this connection in bold in the Shuttle plug-in’s Servers list (after restarting Illustrator).

You will be able to change the user name and password if necessary, but you will not be able to remove this connection from the Shuttle plug-in.

See the Adobe Illustrator Client documentation for more information on the Server Connection Assistant.

6.1.2 Shuttle Clients Connecting only to Automation Engine

The Shuttle clients in PackEdge, Plato and FastImpose Server can only connect to one Automation Engine server.

1. Launch your application.

2. Open the Preferences.

   - In PackEdge or Plato, go to Edit > Preferences or use Ctrl+Alt+Shift+P.
   - In FastImpose Server, go to Tools > Options...

3. In the Server&Resources tab (the Server tab for FastImpose Server):
   a) Select Connect to Automation Engine Server.
   b) Enter the Automation Engine Server Name and click Check.
      You should see a message saying the server is up and running.
   c) Select Login with the following user account settings, and fill in the User Name and Password you use to login to the Pilot.
      If the connection is successful, you will see a green dot and the message Connected as user ...
6.2 Defining Preferences

You can define Shuttle-specific preferences in the Shuttle plug-in.

6.2.1 Display Preferences

You can choose how to display your workflows in the Shuttle plug-in.

1. In the Preferences dialog, click the General tab.

2. Choose how to display the workflow names in the Launch window:

<table>
<thead>
<tr>
<th>Set the Workflow Name Format this way:</th>
<th>to display the workflow name like this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include Workflow Entry</td>
<td>Receive</td>
</tr>
<tr>
<td>Include Server Name</td>
<td></td>
</tr>
<tr>
<td>Include Workflow Entry</td>
<td>Receive@preflight</td>
</tr>
<tr>
<td>Include Server Name</td>
<td></td>
</tr>
<tr>
<td>Include Workflow Entry</td>
<td>Receive@preflight@macpro</td>
</tr>
</tbody>
</table>
3. Choose how to sort the workflows in Shuttle’s Launch window:
   - Choose **By Workflow Name** to display all the entry points (Receive Gateway, Hot Folder...) of a same workflow together.
   - Choose **By Workflow Entry** to display all the entry points in alphabetical order, regardless of the workflow they belong to.

### 6.2.2 Public Parameters Preferences

When you have to select some or all of the file’s inks for a public parameter, the public parameters window shows an ink list.

- To add one of your file’s inks, click ![add ink](add_icon) then select it in the drop-down list.
- To add all of your file’s inks, right-click the ink list and select **Expand Ink List**.
- To remove one of your file’s inks, click ![remove ink](remove_icon) beside it in the inks list.

By default, the ink list is expanded when it is the most used case for that public parameter (for example, for Proof, RIP or Export workflow steps).

In the Shuttle standalone and plug-in preferences, you can choose to have the ink list expanded or not.

To do this, select or deselect **Automatically Expand Ink Lists** in the **General** tab of the preferences.
Note: This is only applied when it makes sense to add all of your file's inks by default (for example, it is not applied for parameters removing inks from your file).

6.2.3 Filtering Preferences

If you connect to several servers or to a server with many canvases or workflows, you may want to only display certain canvases / workflows when submitting files from the Shuttle plug-in.

Note: This is only supported for Nexus and Odystar workflows.

1. In the Servers tab of Shuttle's Preferences dialog, enable Filter On Workflow Type.
2. At the bottom of the Workflow Types To Show list, click the button and enter the workflow type you want to show in the Launch window.
   - For Odystar canvases, you need to define workflow types in the Receive Process Folders' parameters. See Shuttle Parameters in Odystar Receive Process Folders.
   - For Nexus workflows, the workflow type is the name of the workflow.
     The workflow name format to use here doesn't depend on what you have set in the Workflow Name Format parameter in the General Preferences. It is always [hotfolder name]@[workflow name].
3. Click the button again if you want to add more workflow types to the list.

   To remove a workflow type from the Workflow Types To Show list, select it and click the button.

Note:

The Shuttle plug-in filters only on the workflow name, for Odystar, Nexus or Automation Engine servers.

For example, add (DeskPack Only) in the filter to only show DeskPack-related workflows on your Automation Engine server (whose name contain "(DeskPack Only)").

6.2.4 Workflow Units Preferences

Use the Units tab of the Shuttle plug-in Preferences to define the units you want to use when launching workflows on your file(s).

1. Choose to define the Resolution in Pixels Per Millimeter or Pixels Per Inch.
2. Choose to define the Screen Ruling in Lines Per Millimeter or Lines Per Inch.

These units will be used when you submit a file to a workflow with public parameters.

For example, if you chose a Lines Per Inch Screen Ruling and you submit a file to an Odystar RIP workflow with the Ruling as a public parameter, the public parameters pop-up will show the Ruling in Lines Per Inch.
7. Launching Files into a Workflow

7.1 Launching Files from the Shuttle Plug-in

To launch a file into a workflow through the Shuttle plug-in, it needs to be the current file in Illustrator (open and at the front).

1. Go to File > Launch Workflow... or use Option + Command + Z.
   
   This opens the Launch window.

2. When launching to Automation Engine, choose Normalized PDF in Launch As.
   
   This copies the Normalized PDF version of your file onto the DeskPack Container.

   **Note:** This uses the PDF Export plug-in to convert your Illustrator file to Normalized PDF. To refine the conversion, click Settings... and edit the PDF Export Preferences.

3. If you want to link your file to an existing Automation Engine job, fill in the Job ID and/or Job Sub ID.
Note:

- You must enter a Job ID / Job Sub ID that already exists on your Automation Engine server. The Shuttle plug-in cannot create jobs.
- The Normalized PDF that you launch with a Job ID / Job Sub ID will be linked to that job, so that tasks and workflows processing that file can use the job parameters.
- If you are launching a file that was already in an Automation Engine job, the Job ID and/or Job Sub ID will be filled automatically.

4. Select the workflow you want to launch your file to in Launch To Workflow.
5. If your workflow has public parameters, you can fill them in in the same window.
6. Click Launch to launch your file.

7.2 Launching Files from ArtPro

1. To launch your current file to Shuttle, go to File > Launch Workflow...
   This opens the Launch Workflow window.
2. Choose what file type you want to launch your file as.

<table>
<thead>
<tr>
<th>If your workflow is...</th>
<th>you can launch the file as...</th>
<th>with...</th>
</tr>
</thead>
<tbody>
<tr>
<td>a Nexus workflow</td>
<td>PDF</td>
<td>any of the available PDF flavors</td>
</tr>
<tr>
<td>accepting PDF files as input</td>
<td></td>
<td></td>
</tr>
<tr>
<td>a Nexus workflow</td>
<td>ArtPro</td>
<td>with the included images (TIFF, EPS...) or without (only the ArtPro and the ArtPro CT file)</td>
</tr>
<tr>
<td>accepting ArtPro files as input</td>
<td></td>
<td></td>
</tr>
<tr>
<td>a Nexus workflow</td>
<td>PS for Nexus</td>
<td>settings that you need to define in the Print dialog</td>
</tr>
<tr>
<td>accepting PS files as input</td>
<td></td>
<td></td>
</tr>
<tr>
<td>an Odystar workflow</td>
<td>PDF</td>
<td>PDF for Press only</td>
</tr>
<tr>
<td>an Automation Engine workflow accepting Normalized PDF files as input</td>
<td>Normalized PDF</td>
<td>either Normalized PDF or Normalized PDF (embedded)</td>
</tr>
<tr>
<td>an Automation Engine workflow accepting PDF files as input</td>
<td>PDF</td>
<td>any of the available PDF flavors</td>
</tr>
<tr>
<td>an Automation Engine workflow accepting ArtPro files as input</td>
<td>ArtPro</td>
<td>with the included images (TIFF, EPS...) or without (only the ArtPro and the ArtPro CT file)</td>
</tr>
</tbody>
</table>

**Note:** For more information about PDF flavors or PS options in the ArtPro Print dialog, please see the ArtPro documentation.

3. If you want to add your file to an Automation Engine job, select it in the Job list or fill in the Job ID and/or Job Part ID.
4. If you want to add your file to an Automation Engine product, select it in the Product list or fill in the Job ID and/or Job Part ID.

Note: Use the Search... button to see a list of your server’s products.

5. Select the workflow you want to launch your file to.

6. If your workflow has public parameters, you can fill them in in the same window.

7. Click the Launch button.

7.3 Launching Files from Neo

1. Go to File > Launch Workflow...

   This opens the Launch Workflow window.
2. Select the workflow you want to launch on your file in the workflow list.

3. If your workflow has public parameters, you can fill them in the same window.

   For more information on public parameters, see:
   - Using Public Parameters in Automation Engine,
   - Making Parameters Public for Shuttle in Odystar,
   - Making Parameters Public for Shuttle in Nexus.

   **Note:** If you want to go back to the default parameters values after changing them, use the Reset To Defaults button.

4. Click Launch to launch the workflow on your file.

### 7.4 Launching Files from PackEdge or Plato

**Attention:** You must save your file on an Automation Engine container before you can launch it into a workflow from PackEdge or Plato.

1. Go to File > Launch Workflow...

   This opens the Launch Workflow window.
2. Select the workflow you want to launch on your file in the workflow list.

3. If your workflow has public parameters, you can fill them in in the same window.

   **Note:** For more information on public parameters, see *Using Public Parameters in Automation Engine*.

4. Click **Launch** to launch the workflow on your file.

**Tip:**
To access Shuttle easily in the future (without using the menus):
1. Go to **Window > Toolbars > Shuttle** to open the Shuttle palette.
2. Drag it into your application’s toolbar.
3. Click **Settings** to open the **Launch Workflow** window, or **Shuttle** to open the Shuttle window.

### 7.5 Launching Files from FastImpose

When working with FastImpose Server, you must save your file on an Automation Engine container before you can launch it.

1. Go to **File > Launch Workflow...**
This opens the **Launch Workflow** window.

2. Choose what file type you want to launch your file as.
   - When working with FastImpose Server, you can only launch your file as an IMP file.
   - When working with FastImpose Standalone, you can launch your file either as a JDF or a PDF file.

   Click the **Settings...** button to set JDF or PDF Export Preferences (see the FastImpose manual for more information).

3. Select the workflow you want to launch on your file in the workflow list.

4. If your workflow has public parameters, you can fill them in in the same window.

5. Click **Launch** to launch the workflow on your file.
8. Monitoring Files

8.1 The Shuttle Window

The Shuttle window shows all files belonging to you or to all users, in all workflows your Shuttle is connected to.

To open a Shuttle window:

<table>
<thead>
<tr>
<th>In...</th>
<th>go to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Illustrator</td>
<td>Window &gt; Esko &gt; Show Shuttle</td>
</tr>
<tr>
<td>ArtPro, Neo, PackEdge and Plato</td>
<td>Window &gt; Shuttle</td>
</tr>
<tr>
<td>FastImpose</td>
<td>View &gt; Shuttle</td>
</tr>
</tbody>
</table>

The Shuttle window shows each file’s name, status, the workflow the file is in, etc.

It has several areas: buttons, a filter to view files, the file list, and the Inspector panel that shows more information.

8.1.1 The Shuttle Window Buttons

With those buttons you can perform basic tasks on the file selected in the Shuttle window.

**Note:** You can also access these tasks in each file’s context menu.
With the **Hold** button you can put a file on hold from Shuttle.

With the **Release** button you can release a file that is on hold from Shuttle.

With the **Delete** button you can delete a file.

With the **Abort** button you can cancel your workflow’s processing from Shuttle.

With the **Users** button you can choose to show only your files, or all users’ files.

With the **Inspector** button you can open (or close) the Inspector panel to see more information.

See also:

* **Holding or Releasing a File**,  
* **Deleting a File from your Workflow**,  
* **Showing Only Your Files / Everybody’s Files**.  
* **The Inspector Panel**.

### 8.1.2 The Connection to Workflow Servers

In case of a connection problem with one or more server(s) you added in the Preferences, the **Shuttle** window shows a connection status:

- If at least one of the servers isn’t running, it shows: ![Connection to some servers failed]
- If none of the servers are running, it shows: ![No connection to servers]

Go to the Preferences and check the servers’ list.

**Tip:** In the Shuttle plug-in, you can click the colored dot to open the Servers Preferences.
To edit the connection to a server which is not running anymore, see *Shuttle Clients Connecting to Any Server* on page 42.

### 8.1.3 The Shuttle Window Filter

In the **Shuttle** Window, you can set criteria to filter files.

Use the filter to show only certain files, e.g. files for a specific user, for a specific workflow or process, by status, based on the file name...

You can set extra criteria by clicking the + button, and remove criteria by clicking the - button.

### 8.1.4 The Files List

The files list shows all files in the selected server belonging to either just you or all users.

It shows:
- the file's Run Status and File Status (see below),
- its name,
- the Workflow (Canvas for Odystar) processing the file,
- the Process Folder the file is in (for Odystar), the percentage of processing completed (Nexus) or workflow/task type (Automation Engine),
- the user it belongs to,
- the time the file entered the workflow,
- the job ID (if any),
- the job Part ID (if any),
- the server name (if you are connected to several servers).

**Note:** Click on the column headers to rearrange the files by file status, name, workflow, starting time...

### Run Status

The Run Status shows you how the processing is going so far.

<table>
<thead>
<tr>
<th>Run Status</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File finished.</strong></td>
</tr>
<tr>
<td>Status</td>
</tr>
<tr>
<td>--------</td>
</tr>
<tr>
<td>⚠️</td>
</tr>
<tr>
<td>🔗</td>
</tr>
<tr>
<td>🔄</td>
</tr>
<tr>
<td>⚔️</td>
</tr>
<tr>
<td>✗</td>
</tr>
<tr>
<td>✗</td>
</tr>
</tbody>
</table>

**File Status**
The File Status shows you the final processing state of the file.

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✅</td>
<td>OK.</td>
</tr>
<tr>
<td>📰</td>
<td>Info: more information on the file is available.</td>
</tr>
<tr>
<td>⚠️</td>
<td>Warning.</td>
</tr>
<tr>
<td>✗</td>
<td>Error.</td>
</tr>
<tr>
<td>✗</td>
<td>Fatal error: The file could not be processed.</td>
</tr>
</tbody>
</table>

For example, ⚠️ means that the file is on hold and that it generated a warning.

### 8.1.5 The Context Menu

Each file’s context menu allows you to perform several actions on the file, or to get more information about the file.
<table>
<thead>
<tr>
<th><strong>Use this...</strong></th>
<th><strong>to...</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>open either:</td>
</tr>
<tr>
<td></td>
<td>• the main file,</td>
</tr>
<tr>
<td></td>
<td>• another file (that has a tag in an Odystar canvas or a label in a Nexus workflow),</td>
</tr>
<tr>
<td></td>
<td>• all the files,</td>
</tr>
<tr>
<td></td>
<td>• the file folder.</td>
</tr>
<tr>
<td>Preview (QuickLook)</td>
<td>show one of the files in QuickLook (main file, another file...).</td>
</tr>
<tr>
<td></td>
<td>You can also use the Space shortcut to open the main file.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This is only available on Mac OS X 10.5 (Leopard) and newer.</td>
</tr>
<tr>
<td>Edit Parameters...</td>
<td>edit the file’s public parameters for the remainder of the workflow (after a Hold Gateway or a Decision or Wait for OK Activity).</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This is only available for files with public parameters that are in a Hold Gateway in Odystar, or in a Decision or Wait for OK Activity in Nexus.</td>
</tr>
<tr>
<td>Hold</td>
<td>put a file on hold from Shuttle.</td>
</tr>
<tr>
<td>Release</td>
<td>release a file that is on hold from Shuttle.</td>
</tr>
<tr>
<td>Priority</td>
<td>increase or decrease a file’s priority rank.</td>
</tr>
<tr>
<td>Show Log...</td>
<td>open the log of the selected file.</td>
</tr>
<tr>
<td>Open Relations...</td>
<td>open the relations of the selected file.</td>
</tr>
<tr>
<td>Attention</td>
<td>route a file that needs attention.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This shows the message and choices set in your Hold Gateway in Odystar, your Decision or Wait for OK Activity in Nexus or your Wait for Action (Checkpoint) workflow step in Automation Engine.</td>
</tr>
</tbody>
</table>
### 8.1.6 The Inspector Panel

The **Inspector** panel shows information about the file you selected.
In the More Info area, you can raise or lower the file's priority. If you have sent several files at once to your workflow, the Files area will list them all. The Messages area shows any messages generated by the workflow during processing.

8.1.7 Showing Only Your Files / Everybody's Files

- Click to only show your files in the Shuttle window.
- Click to show all users' files.
9. Working with Shuttle when your File is Processing

9.1 Opening Files / the Enclosing Folder

You can open any file that has a tag (from an Odystar canvas) or a label (from a Nexus workflow) from Shuttle. You can also open the enclosing folder (for Nexus workflows).

- To open the main file, double-click it in the Shuttle window list.
- To open another related file:
  a) right-click the main file in the Shuttle window list,
  b) select Open in the context menu,
  c) click the name (files in Automation Engine workflows), tag (files in Odystar workflows) or label (files in Nexus workflows) of the file you want to open.

Depending on your workflow type and on where your job is in your workflow, opening the main file has different results:

<table>
<thead>
<tr>
<th>For...</th>
<th>if your job is...</th>
<th>opening the “main” file opens...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Odystar workflows</td>
<td>paused in a Hold Process Folder</td>
<td>the file as it is in the Hold Process Folder (modified by the previous Gateways in the workflow).</td>
</tr>
<tr>
<td></td>
<td>running anywhere else in the workflow</td>
<td>the file as it is before entering the current Process Folder (modified by the previous Gateways in the workflow).</td>
</tr>
<tr>
<td>Nexus workflows</td>
<td>paused in a Decision or Wait for OK Activity</td>
<td>the file as it is in the Decision or Wait for OK Activity (modified by the previous Activities in the workflow).</td>
</tr>
<tr>
<td></td>
<td>running anywhere else in the workflow</td>
<td>the input file (unmodified by the workflow).</td>
</tr>
<tr>
<td>Automation Engine workflows</td>
<td>paused in a Wait for Action (CheckPoint) step</td>
<td>the input file of the Wait for Action (CheckPoint) step.</td>
</tr>
<tr>
<td></td>
<td>running anywhere else in the workflow</td>
<td>the output file of the last workflow step completed.</td>
</tr>
</tbody>
</table>
9.2 Changing a File's Public Parameters

When a file is in a Hold Gateway in Odystar, or in a Decision or Wait for OK Activity in Nexus, in a workflow that has public parameters, you can edit the file’s public parameters for the remainder of the workflow (after the Hold Gateway or the Decision / Wait for OK Activity).

- To do this, right-click it and select Edit Parameters...

**Note:** This is only available for files with public parameters that are in a Hold Gateway in Odystar, or in a Decision or Wait for OK Activity in Nexus.

This opens the public parameters pop-up for you to edit the public parameters.

![Public Parameters Pop-up](image)

9.3 Holding or Releasing a File

Check which files you can hold or release:

<table>
<thead>
<tr>
<th>For.</th>
<th>you can hold or release...</th>
<th>when...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Nexus workflows</td>
<td>your own files only</td>
<td>always</td>
</tr>
<tr>
<td>Odystar canvases</td>
<td>your own files only</td>
<td>by default</td>
</tr>
<tr>
<td></td>
<td>everybody’s files</td>
<td></td>
</tr>
</tbody>
</table>

- All users can hold or release all files is enabled in the Hub’s Preferences. See Access Rights Setup.
- your user name is in the list of users that can hold or release all files in the Hub's
9.4 Changing a File’s Priority

Check which files’ priority you can change:

<table>
<thead>
<tr>
<th>For.</th>
<th>you can change the priority of...</th>
<th>when...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Nexus workflows</td>
<td>your own files only</td>
<td>always</td>
</tr>
<tr>
<td>Odystar canvases</td>
<td>no files</td>
<td>by default</td>
</tr>
<tr>
<td></td>
<td>your own files only</td>
<td>Allow user to change priority of his files is enabled in the Hub’s Preferences. See Access Rights Setup.</td>
</tr>
<tr>
<td></td>
<td>everybody’s files</td>
<td>your user name is in the list of users that can change the priority of all files in the Hub’s Preferences. See Access Rights Setup.</td>
</tr>
<tr>
<td>Automation Engine tickets</td>
<td>everybody’s files</td>
<td>your user has sufficient privileges in the Automation Engine Pilot.</td>
</tr>
</tbody>
</table>

To change the priority of a file, you can either:

- right-click it and select **Priority > Increase** or **Priority > Decrease** in the context menu.
- select it and click either ± or − beside Priority in the More Info area of the Inspector (to either increase or decrease the file’s priority).
9.5 Opening the Log

- To open a file’s log, right-click it and select **Show Log**...

9.6 Routing Files that Need a Decision

When your file is paused in a workflow and needs a user decision to take one of several workflow paths, you can route it from Shuttle.

This is the case for files in a **Hold** Gateway in Odystar, in a **Decision** or **Wait for OK** Activity in Nexus, or in a **Wait for Action (Checkpoint)** workflow step in Automation Engine.

**Note:**
The user name used in the **Checkpoint** step settings and the user name used in Shuttle to connect to Automation Engine must match.

If they don’t, you can still see the file(s) to route, but only when displaying everybody’s files in Shuttle (in Show All mode).

In the Shuttle window, you see an icon (_circle) indicating that the file needs attention.

The **Inspector** panel also shows an attention icon, and the notification defined in your workflow.

To route the file, you can either use:

1. the Shuttle processing list:
   a) Right-click the entry that requires attention (the exact workflow step and not the main workflow entry) and select **Attention** in the context menu.
This shows the message and output options set in your Hold Gateway, Decision or Wait for OK Activity, or Checkpoint step.

b) Select one of the output options to route the file.

2. the Inspector panel:
   a) Select the file with the attention icon in the list to show it in the Inspector panel.
   b) Click and select one of the output options to route the file.

9.7 Deleting a File from your Workflow

Check which files you can delete:

| For..              | you can delete...            | when...
|--------------------|-------------------------------|--------
| Nexus workflows    | your own files only           | always |
| Odystar canvases   | your own files only           | by default |
|                    | everybody's files             |        |
|                    | • All users can delete all files is enabled in the Hub’s Preferences. See Access Rights Setup. |
|                    | • your user name is in the list of users that can delete all files in the Hub’s |
For.. | you can delete... | when...
---|---|---
|  |  | Preferences. See Access Rights Setup.
Automation Engine tickets | everybody's files | your user has sufficient privileges in the Automation Engine Pilot.

- To delete a file, you can either:
  - select it and click the **Delete** button,
  - right-click it and select **Delete**.