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1 Licensing and Activation

1.  Copyright Notice
© Copyright 2021 Esko Software BV, Gent, Belgium

All rights reserved. This material, information and instructions for use contained herein are the
property of Esko Software BV. The material, information and instructions are provided on an AS IS
basis without warranty of any kind. There are no warranties granted or extended by this document.
Furthermore Esko Software BV does not warrant, guarantee or make any representations regarding
the use, or the results of the use of the software or the information contained herein. Esko Software
BV shall not be liable for any direct, indirect, consequential or incidental damages arising out of the use
or inability to use the software or the information contained herein.

The information contained herein is subject to change without notice. Revisions may be issued from
time to time to advise of such changes and/or additions.

No part of this document may be reproduced, stored in a data base or retrieval system, or published, in
any form or in any way, electronically, mechanically, by print, photoprint, microfilm or any other means
without prior written permission from Esko Software BV.

This document supersedes all previous dated versions.

PANTONE
®

 Colors displayed in the software application or in the user documentation may not match
PANTONE-identified standards. Consult current PANTONE Color Publications for accurate color.
PANTONE

®
 and other Pantone trademarks are the property of Pantone LLC. © Pantone LLC, 2015

Pantone is the copyright owner of color data and/or software which are licensed to Esko to distribute
for use only in combination with Studio Visualizer. PANTONE Color Data and/or Software shall not be
copied onto another disk or into memory unless as part of the execution of Studio Visualizer.

This software is based in part on the work of the Independent JPEG Group.

Portions of this software are copyright © 1996-2002 The FreeType Project (www.freetype.org). All
rights reserved.

Portions of this software are copyright 2006 Feeling Software, copyright 2005-2006 Autodesk Media
Entertainment.

Portions of this software are copyright ©1998-2003 Daniel Veillard. All rights reserved.

Portions of this software are copyright ©1999-2006 The Botan Project. All rights reserved.

Part of the software embedded in this product is gSOAP software. Portions created by gSOAP are
Copyright ©2001-2004 Robert A. van Engelen, Genivia inc. All rights reserved.

Portions of this software are copyright ©1998-2008 The OpenSSL Project and ©1995-1998 Eric Young
(eay@cryptsoft.com). All rights reserved.

This product includes software developed by the Apache Software Foundation (http://
www.apache.org/).

Adobe, the Adobe logo, Acrobat, the Acrobat logo, Adobe Creative Suite, Illustrator, InDesign, PDF,
Photoshop, PostScript, XMP and the Powered by XMP logo are either registered trademarks or
trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Microsoft and the Microsoft logo are registered trademarks of Microsoft Corporation in the United
States and other countries.

SolidWorks is a registered trademark of SolidWorks Corporation.

Portions of this software are owned by Spatial Corp. 1986 2003. All Rights Reserved.
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1Licensing and Activation

JDF and the JDF logo are trademarks of the CIP4 Organisation. Copyright 2001 The International
Cooperation for the Integration of Processes in Prepress, Press and Postpress (CIP4). All rights
reserved.

The Esko software contains the RSA Data Security, Inc. MD5 Message-Digest Algorithm.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun
Microsystems in the U.S. and other countries.

Part of this software uses technology by Best Color Technology (EFI). EFI and Bestcolor are registered
trademarks of Electronics For Imaging GmbH in the U.S. Patent and Trademark Oce.

Contains PowerNest library Copyrighted and Licensed by Alma, 2005 – 2007.

Part of this software uses technology by Global Vision. ArtProof and ScanProof are registered
trademarks of Global Vision Inc.

Part of this software uses technology by Qoppa Software. Copyright © 2002-Present. All Rights
Reserved.

All other product names are trademarks or registered trademarks of their respective owners.

Correspondence regarding this publication should be forwarded to:

Esko Software BV

Kortrksesteenweg 1095

B – 9051 Gent

info.eur@esko.com
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2 Licensing and Activation

2.  Getting Started
This documentation will give you an overview on how to activate or manage licenses.

In most cases, when your licenses need your attention, you will automatically be warned about it, and
the on screen instructions can guide you through the process.

For more information on how you can activate licenses, take a look at How to activate your software on
page 8

If you want to change or review your licensing settings or information from within your application, you
can take a look at Where to find licensing information in your Esko application on page 7

For information on how to manage licenses in the Local License Manager or the Network License
Manager, see Managing Licenses in the Local or Network License Manager on page 11

2.1.  Creating an Esko ID

Esko ID is the new single sign-on account mechanism that Esko has introduced in 2014.
More information can be found in this Knowledge Base article: https://wiki.esko.com/pages/
viewpage.action?pageId=93521717

1. Go to the activation website:

• If your computer is connected to the internet, go to http://esko.com/licensing/CreateAccount or
click the Esko ID hyperlink in the Esko  License Manager ’s main window.
 

 
• If your computer is not connected to the internet, go to http://esko.com/licensing/

CreateAccount on another computer.
2. Enter the appropriate information in the fields. If you're an existing Esko customer, you need to fill

in your Company Code.

You can find your Company Code on any Esko quotation, invoice or e-mail you get from our online
Support Portal.

3. Click Create my Esko ID.
4. After a few minutes, check your e-mail program for a new message from Esko regarding activating

your new Esko ID.
5. Once it arrives, open the message and click the link to confirm your e-mail address.
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2Licensing and Activation

You should receive a message that your Esko ID was confirmed successfully in your default Web
browser.

2.2.  Where to find licensing information in your Esko
application

If the licensing of your software needs your attention (e.g. you have no license for your software, or the
license is about to expire), a licensing window will open automatically.

However, you can at all times see and manage your licenses from within your application. How to
access this depends on the application:

ArtiosCAD Choose Help > License Location

ArtPro Choose ArtPro > Preferences, and in the General tab,
click the Show Licenses button

ArtPro+ Choose Help > License Info

DeskPack  Plugins in Adobe Illustrator In Adobe Illustrator, choose Help > Esko > Plug-ins... or
Help > Subscriptions

DeskPack Plug-ins in Adobe Photoshop In Adobe Photoshop, choose File > Automate > Esko
Setup...

PackEdge Choose Edit > Preferences and select the Licenses tab

Plato Choose Edit > Preferences and select the Licenses tab

Studio In Adobe Illustrator, choose Help > Esko > Plug-ins... or
Help > Subscriptions

Studio Toolkit Choose Help > Network License Setup or Help > Sign In/
Out
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3 Licensing and Activation

3.  How to activate your software
Esko software may be licensed in different license models.

1. Some products have a trial version available. When installing the trial software a 30 day time limited
license will be activated during the installation process.

2. Most products also support a perpetual license.
a) If you received an HTML file with a Product Key, you can activate a Local License. See Activating

a Local License on page 8
b) If a License Server is set up containing your licenses, you can connect to this License Server to

use a Network License. See Activate a Network License on page 8
3. Some products also have the Named User Subscription license model. The application will enable

the license when you sign in for the application. See Activate a Named User Subscription on page
9

Note:  If the application you are launching doesn't have a valid license (e.g. first time launch, the
activated license is expired, the network license isn't available., ...), a welcome dialog will pop up,
allowing you to choose the licensing method.

3.1.  Activating a Local License

A Local License is a perpetual license activated through an Activation wizard in the application, or in
the Local License Manager on the same computer as you want to use the software on. The license can
only be used on this computer, unless you deactivate the license on one computer, and then activate it
on another.

The Local License Manager is installed automatically when you install your Esko Software. You can
reach it from the Licensing panel in your Esko software, or by launching the application itself.

For information on how to manage licenses in the Local License Manager, see Managing Licenses in the
Local or Network License Manager on page 11

3.2.  Activate a Network License

A Network License is a license activated in the Network License Manager on the Licensing Server. It
is a perpetual license that supports sharing the license across your local network.

From any computer in the LAN you want to use the software on, you connect to the License Server. A
Network License can have multiple licenses for a product, which is the number of computers that can
use this product at the same time.

1. As a first step, an Administrator should activate the necessary licenses in the Network License
Manager on the License Server. For information on how to manage licenses in the Network License
Manager, see Managing Licenses in the Local or Network License Manager on page 11
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3Licensing and Activation

2. On the client computer you set up the connection to the License Server. See Connecting to the
License Server on page 9

3.2.1.  Connecting to the License Server

To use a License from a Network License Manager, you need to set up a connection to the License
Server.

In ArtPro, ArtPro+, Studio and DeskPack, you can set up this connection from within the application
itself, by entering the License Server name or address. For more information, see the corresponding
documentation.

Note:  For DeskPack and Studio, you can also define what modules or plug-ins can use a Network
License. Other plug-ins or modules will either use a local license, or remain unlicensed. In the
Preferences of ArtPro+ you can decide whether you want to use an ArtPro+ Advanced license.

For other applications such as PackEdge, Imaging Engine and Automation engine, you need to install
the Network License Manager on the local computer, and use the License Client Configuration tool.

Note:

In this situation, you will have the Network License Manager installed at two locations:

• On the License Server, to activate and manage the licenses.
• On the computer running the software, where you use the License Client Configuration tool to

connect to the License Server

To set up the License Client Configuration tool:

1. Log in as user Administrator
2. Open the Network License Manager. Depending on your operating system, you can do this by:

• selecting Start > Programs > Esko > Network License Manager
• clicking Network Licence Manager on your Apps screen.

3. In the Network Licence Manager, go to Tools > License Client Configuration
4. In the License Client Configuration dialog:

a) Enter the name of the server that you are using as a license server
You can use localhost to use the computer you are working on

b) Enter the Port number of the License Server to use, or leave it blank to use the default port
27000.

c) Click Apply
d) Click Exit

5. Close the Network License Manager
6. Stop and Restart the Esko Application(s) for the changes to be effective.

3.3.  Activate a Named User Subscription

A Named User Subscription is managed online and, unlike local licenses, linked to a specific user, using
his Esko ID.
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3 Licensing and Activation

1. On http://MySoftware.esko.com, an Administrator can manage all subscriptions of his company and
assign them to the different users. See Manage the subscriptions for your team on page 30

You will receive an e-mail when a subscription is assigned to you. This e-mail contains a link to
install the desktop application (in case you haven't done that already) or to the cloud application.
If you did not have an Esko ID yet, the e-mail also contains an invitation to create one. You must
complete the Esko ID creation process, including the confirmation, before you can start using the
application.

2. You can sign in to use a Named User Subscription, by entering your Esko ID and password.

Once signed in, you remain signed in, even when turning off the computer. You will only be signed
out:

• when you sign out manually
• when you sign in using the same Esko ID on another computer, since this will remotely sign you

out on the first computer
• when your computer is oine for more than 30 days
• when another user signs in on the same computer, and on the same operating system account.

Different users can sign in on the same computer if they log in on the computer as a different
user.

• when the subscription becomes invalid (eg. it expires), or when the Administrator assigns it to
another Esko ID

10
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4Licensing and Activation

4.  Managing Licenses in the Local or Network
License Manager

Attention:  Most of the information in this documentation is also available as an Esko
Knowledge Base article: KB 73059246. This KB article contains many videos that illustrate
many of the below procedures.

The Esko  License Manager  allows to activate and deactivate licenses for your Esko software. It works
on both Mac and Windows.

Licenses managed this way no longer rely on physical dongles connected to the computer. Instead,
they license your software using a combination of unique identification numbers, based on your
hardware and the product keys of your software.

For easiest configuration, the machine on which you are using the Esko  License Manager  should be
online with full Internet access.

However, if the machine you are using does not have full Internet access, you can perform an oine
activation if you:

• have access to Internet e-mail and use of a Web browser on another machine,

• can copy a file received in an Internet e-mail message to the machine you are using (for example
using a USB memory drive, or an internal network...).

Before you can activate or deactivate licenses, you need to set up an Esko ID using the Esko Web site.
The URL of the site is shown on the main screen of the Esko  License Manager .

4.1.  Activating Licenses

Attention:  Most of the information in this documentation is also available as an Esko
Knowledge Base article: KB 73059246. This KB article contains many videos that illustrate
many of the below procedures.

Once you have created and confirmed your Esko ID (see Creating an Esko ID on page 6), you can start
activating your licenses using your software's product keys.

A product key looks like this: XXXXXX-XXXXXX-XXXXXX-XXXXXX-XXXXXX

Esko will normally send your product keys via e-mail. If you have multiple product keys, they will be
bundled in a single HTML-file. You can double-click the HTML file to see what product keys it contains.

Note:  Product key files are HTML files. You can double-click them to see what product keys they
contain.

• If the computer running the Esko  License Manager  is connected to the Internet, you can get
licenses for the product keys and activate them from that machine.

See Online Activation on page 12.

• Otherwise, you must create an activation request file and use a computer that is connected to the
Internet to upload it to an activation server.
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See Oine Activation on page 13.

You can choose between Online and Oine activation in the License Manager Preferences. See
License Manager Preferences on page 28

4.1.1.  Online Activation

You can activate your product key(s) online if the computer where you will use your software is
connected to the internet.

To activate a product key online, you can drop the license file(s) on the License Manager, or you can
select your licenses during the activation process.

1. If you have an HTML file, drag and drop it on the Esko  License Manager ’s main window, or click the
Activate... button.

This opens the Activate License Wizard (on PC) or the Activate License Assistant (on Mac). Click
Next (on PC) or Continue (on Mac)

2. Select I am aware that the Esko Network License Services will be restarted and click Next /
Continue. Only applicable for Network License Manager.

3. Select how you received your product key(s) and click Next / Continue.
4. Enter your product key or HTML file

a) If you dropped your HTML file on the License Manager, the file will already be selected. Click
Next / Continue.

b) If you chose I have received an HTML file containing my Product Keys, browse for the file and
click Next / Continue.

c) If you chose I have only one Product Key looking like [...], enter the product key in the fields
provided. The cursor automatically advances to the next field as you type. Leave the License
Count field empty. Only applicable for Network License Manager.

d) Click Next / Continue.
5. Enter the name and password of your Esko ID and click Next / Continue.

• You should have created this Esko ID in Creating an Esko ID on page 6. If you haven’t yet, click
the Create a new Esko ID link in the wizard/assistant and see Creating an Esko ID on page 6 for
instructions.

• If you forgot your password, Click the Forgot your password link. You can then reset your
password and receive it by mail.

• By default, your credentials are stored and will be remembered for your next activation. If you
don't want them to be stored, deselect the Remember me option.

After you click Next / Continue, a status bar appears while the system communicates with the
activation server.

This may take several minutes if you have a lot of product keys to activate (for example during an
Automation Engine or FlexRip activation). During that time you cannot cancel or close the wizard/
assistant.

A message will appear saying that the activation was completed successfully and that you can now
use the product(s) on your computer.

6. Click Finish / Done.
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4Licensing and Activation

The product and its license will appear in the  License Manager  as shown below. Select a license to
see its details in the Details pane.

 

 

Tip:  If you don't see the activated license immediately, click the Refresh link.

4.1.2.  Oine Activation

If the computer where you will use your software is NOT connected to the internet or if your
preferences are set to activate via another online computer, you need to activate your product key(s)
oine.

To activate a product key oine, do the following:

1. You create the activation request file using the Activate License Wizard / Assistant, and copy it to
a machine with full Internet access.
See Creating an Activation Request on page 14.

2. You upload the activation request file to the activation server and download the response file.
See Uploading the Request and Downloading the Response on page 14.

3. You copy that response file to the machine with the Esko  License Manager  and load it into the 
License Manager .
See Loading the Activation Response File on page 15.

Note:  Oine activation is not available for Subscription Licenses.

13
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Creating an Activation Request
To create an activation request file, do the following:

1. If you have an HTML file, drag and drop it on the Esko  License Manager ’s main window, or click the
Activate... button.

This opens the Activate License Wizard (on PC) or the Activate License Assistant (on Mac). Click
Next (on PC) or Continue (on Mac)

2. Select I am aware that the Esko Network License Services will be restarted and click Next /
Continue. Only applicable for Network License Manager.

3. Leave Step 1: generate your request file selected and click Next / Continue.
4. Select how you received your product key(s) and click Next / Continue.
5. Enter your product key or HTML file

a) If you dropped your HTML file on the License Manager, the file will already be selected. Click
Next / Continue.

b) If you chose I have received an HTML file containing my Product Keys, browse for the file and
click Next / Continue.

c) If you chose I have only one Product Key looking like [...], enter the product key in the fields
provided. The cursor automatically advances to the next field as you type. Leave the License
Count field empty. Only applicable for Network License Manager.

d) Click Next / Continue.
6. Enter the name of your Esko ID and click Next / Continue.

You should have created this Esko ID in Creating an Esko ID on page 6.

If you haven't created an Esko ID yet, go to http://esko.com/licensing/CreateAccount on a computer
connected to the internet, and see Creating an Esko ID on page 6 for instructions.

7. Save the activation request file created.

Note:  By default, the activation request file is called requestactivate.xml.

8. A message will appear saying that Step 1 of the oine activation has been completed successfully.
Click Finish / Done.

9. Copy the activation request file to a computer with Internet access using whatever method you
have available - USB drive, internal network...

Uploading the Request and Downloading the Response
Once you have copied the activation request file to a machine with full Internet access, do the
following:

1. Start a web browser on that machine and go to https://www.esko.com/en/support/
downloadsandlicenses/activation.

2. On the web page, click the Choose File button.
3. Browse for the activation request file you copied to this machine (called requestactivate.xml

by default) and click Continue.
4. Enter your Esko ID password in the Password: field (your Esko ID should be filled in automatically)

and click Continue.
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4Licensing and Activation

5. Verify that the product information contained in the activation request file is correct and click
Continue.

Note:  If you have many licenses (for example for Automation Engine or FlexRip), the licenses
generation may take a few minutes.

6. Click the Download button to download the response file generated by the website (activation-
response.xml).

Important:  You will need to use this response file to activate your licence(s). Requesting a
response file again from another browser session may cause an error.

7. Copy the response file back to the machine running the Esko  License Manager  and go to that
machine.

Loading the Activation Response File
Once you are back at the machine running the Esko  License Manager , do the following to load the
activation response file:

1. Drag and drop your response file on the Esko  License Manager ’s main window, or click the
Activate... button.

This opens the Activate License Wizard (on PC) or the Activate License Assistant (on Mac). Click
Next (on PC) or Continue (on Mac)

2. Select I am aware that the Esko Network License will be restarted and click Next / Continue. Only
applicable for Network License Manager.

3. Select Step 2: Load your response file and click Next / Continue. In case you dropped your
activation response on the License Manager, this step will be skipped.

4. Select the response file you copied from the machine with full Internet access.
a) If you dropped your response file on the License Manager, the file will already be selected. Click

Next / Continue.
b) If not, browse to the response file you copied from the machine with full Internet access and

click Next / Continue.

Attention:  Select the response file you downloaded from the website (activation-
response.xml) and not the activation request file you uploaded.

A status bar will appear while the system processes the response file, and then a message will
appear that the activation completed successfully and that you can now use the product(s) on your
computer.

5. Click Finish / Done.

The product and its license will appear in the  License Manager  as shown below. Select a license to
see its details in the Details pane.
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Tip:  If you don't see the activated license immediately, click the Refresh link.

4.1.3.  Activating an Upgrade License

An upgrade license is a license for a newer version of an application that you already have. For example,
if you have ArtPro 9.5 licensed on your system (base license), you can buy an upgrade license for ArtPro
9.6.

Important:

When you activate an upgrade license, make sure that:

• you are activating it on the computer holding the base license,

• the base license is available (not disabled, broken or expired).

• you have the latest version of the  License Manager . Installing the latest version of your software
will automatically install the latest version of the Local License Manager as well.

Activating an Upgrade License is done in the same way as activating any other license. See:

• Online Activation on page 12.

• Oine Activation on page 13.
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4.2.  Viewing Your Licenses

All your licenses are shown in the License Manager's main window.

 

 

Groups, Products and Product Keys
Licenses for a same product are grouped together, so if you have a lot of similar licenses, you can see
them at a glance.

They are organized as follows: each group (for example "Studio") contains products (for example "Studio
Advanced 16"), which contain product keys.

 

 

Details
For each product, you can see:

• its product key (one or many),

17
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• its Status: this can be Active, Disabled, Broken, Expired or Mixed (for products containing product
keys with different statuses),

• the License Period: this can be Permanent, Time-limited, Trial, Subscription(see Subscription
Licensing) or Mixed (for products containing product keys with different license periods).

For Time-limited and Trial licenses, you can see the number of Remaining Days (for Permanent
licenses, this is Unlimited).

For a Subscription license, the Remaining Days will show Unlimited if the Renewel date hasn't
been reached yet. If the Renewel date was reached, and the License couldn't be renewed yet (e.g.
because of internet connection issues, or payment delay), the Remaining Days will indicate how
long the License will remain active (the "grace period").

If a product contains several product keys with different numbers of remaining days , you will see a
range (for example "0 to 146" Remaining Days).

• the Total number of individual licenses for that product (which is the number of computers that can
use this product at the same time). Only applicable for Network License Manager.

If a product contains several product keys with different numbers of licenses, you will see the grand
total.

• In Use shows the number of applications running in the network using license from this license
server for this specific product. Clicking the value will open a dialog showing a list of the computer
names where these licenses are allocated, as well as the user name and when the license was
allocated. Only applicable for Network License Manager.
 

 

Note:

• Active licenses that are Time-limited or valid only for a Trial period have a warning icon .

Disabled, Broken or Expired licenses have a red icon .

• By default, expired licenses are not shown. Select Show expired licenses if you want to see them.

• Named User Subscriptions (see Activate a Named User Subscription on page 9) are not visible in the
License Manager. Named User Subscriptions are only available for a user signed in using his Esko
ID. Older 'unnamed' subscrptions however can be used for all lapplications, and are visible in the
Local License Manager.

You can select a license to see more details in the Details pane.

Sorting

You can sort license groups in ascending  or descending  alphabetical order by clicking the
Products column.

18
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You can sort the contents of those groups (the products and the product keys in them) by clicking the
other columns ( , Status, License Period...).

Note:  The "group>product>product key" structure will always be kept.

For example, doing an ascending sort on Remaining Days sorts the licenses from the least to the most
number of days remaining.

Note:  When one of the values is a range (for example "0 to 146" Remaining Days), the smallest number
is used for sorting.

4.3.  Deactivating Licenses

Attention:  Most of the information in this documentation is also available as an Esko
Knowledge Base article: KB 73059246. This KB article contains many videos that illustrate
many of the below procedures.

Just as with activating licenses, deactivating licenses can be done both online and oine.

You can choose between Online and Oine activation in the License Manager Preferences. See
License Manager Preferences on page 28

You must deactivate a license before moving it to another computer.

4.3.1.  Online Deactivation

To deactivate a license online, do the following:

1. Launch the Esko  License Manager .
2. In the Esko  License Manager  window, click the license to deactivate.

Note:  When selecting a product, all product keys for this product are selected. If you want to
deactivate a particular product key, open the product and select this specific product key from the
list.

Tip:

To select several licenses, hold Command (on Mac) or Ctrl (on PC) while clicking them.

To select them all, use Command+A or Ctrl+A.

3. Click Deactivate... to open the Deactivate License Wizard/Assistant dialog box.
4. Click Next / Continue in the first screen of the Deactivate License Wizard/Assistant dialog box.
5. Select I am aware that the Esko Network License Services will be restarted and click Next /

Continue. Only applicable for Network License Manager.
6. A product key file (HTML) is created. You will need this file to activate the license for this product

key on another computer.
a) Click Save As / Select... to save the file.
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b) In the Save As dialog box, navigate to the desired location, enter a name for the file, and click
Save.

Make sure to note the location and name for future reference.
7. Back in the Save the Product Key dialog box, click Next / Continue.
8. A message appears saying the deactivation was completed successfully. Click Finish / Done.

The license will no longer appear in the Esko  License Manager . If you notice that it is still displayed,
click the Refresh link.

4.3.2.  Oine Deactivation

Oine deactivation works just like oine activation:

1. You create an oine deactivation request and copy it to a machine with internet access.

See Creating a Deactivation Request on page 20.
2. You upload that request to the activation server and download a deactivation response file.

See Uploading the Request and Downloading the Response on page 21.
3. You copy that response file to the machine with the Esko  License Manager  and load it into the 

License Manager .

See Loading the Deactivation Response on page 21.

Creating a Deactivation Request
To create a deactivation request file, do the following:

1. Launch the Esko  License Manager .
2. In the Esko  License Manager , click the license to deactivate.

Note:  When selecting a product, all product keys for this product are selected. If you want to
deactivate a particular product key, open the product and select this specific product key from the
list.

Tip:

To select several licenses, hold Command (on Mac) or Ctrl (on PC) while clicking them.

To select them all, use Command+A or Ctrl+A.

3. Click Deactivate...
4. Click Next / Continue in the first screen of the Deactivate License Wizard/Assistant dialog box.
5. Select I am aware that the Esko Network License Services will be restarted and click Next /

Continue. Only applicable for Network License Manager.
6. Leave Step 1: generate your request file selected and click Next / Continue.
7. Read the warnings in the next screen, make sure all the conditions are met for oine deactivation,

and click Next / Continue.
8. Save the deactivation request file created.

a) Click Save As (PC) / Save... (Mac).
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b) In the pop-up that opens, browse to the desired location and click Save.

Note:  By default, the activation request file is called requestdeactivate.xml.

9. A product key (HTML) file is created. You will need this file to activate the license for this product
key on another computer.
a) Click Save As  / Save... to save the file.
b) In the Save As dialog box, navigate to the desired location, enter a name for the file, and click

Save.

Make sure to note the location and name for future reference.
10. A message will appear saying that Step 1 of the oine deactivation has been completed

successfully. Click Finish / Done.

The selected licenses will change to status Disabled in the  License Manager  until the deactivation
procedure is completed and the licenses are removed. You can no longer use disabled licenses.

 

 
11. Copy the deactivation request file to a computer with Internet access using whatever method you

have available - USB drive, internal network...

Uploading the Request and Downloading the Response
Once you have copied the deactivation request file to a machine with full Internet access, do the
following:

1. Start a web browser on that machine and go to http://www.esko.com/licensing/Activation.
2. On the web page, click the Choose File button.
3. Browse for the deactivation request file you copied to this machine (called

requestdeactivate.xml by default) and click Continue.
4. Verify that the product information contained in the deactivation request file is correct and click

Continue.
5. Click the Download button to download the response file generated by the website

(deactivation-response.xml).
6. Copy the response file back to the machine running the Esko  License Manager  and go to that

machine.

Loading the Deactivation Response
Once you are back at the machine running the Esko  License Manager , do the following to load the
deactivation response file:

1. Drag and drop your response file on the Esko  License Manager ’s main window, or select the
licenses to deactivate and click the Deactivate... button.

Note:  It doesn't matter which disabled licenses you select in this step: the list of licenses to be
deactivated is defined in the deactivation response file (as selected when creating the deactivation
request file).
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This opens the Deactivate License Wizard (on PC) or the Deactivate License Assistant (on Mac).
Click Next (on PC) or Continue (on Mac)

2. Select I am aware that the Esko Network License Services will be restarted and click Next /
Continue. Only applicable for Network License Manager.

3. Select Step 2: Load your response file and click Next / Continue. In case you dropped your
activation response on the License Manager, this step will be skipped.

4. Select the response file you copied from the machine with full Internet access.
a) If you dropped your response file on the License Manager, the file will already be selected. Click

Next / Continue.
b) If not, browse to the response file you copied from the machine with full Internet access and

click Next / Continue.

Attention:  Select the response file you downloaded from the website (deactivation-
response.xml) and not the deactivation request file you uploaded.

A status bar will appear while the system processes the response file.
5. Click Next / Continue.

A message will appear that the deactivation was completed successfully.
6. Click Finish / Done.

The license will no longer appear in the Esko  License Manager . If you notice that it is still displayed,
click the Refresh link.

4.4.  Repairing Licenses

Licenses are tied to identifying characteristics of the hardware inside your computer. Licenses may
break if you change the hardware significantly (e.g. you change different parts of your hardware at
the same time), upgrade the operating system or restore from system backup.

If multiple hardware components of the computer change simultaneously, the licenses can be
invalidated and declared broken. You can use the repair procedure to try to enable the licenses again,
but this is not guaranteed.

Note:  If you plan to change computer characteristics or even plan an update of the operating system,
Esko strongly advise to Sign out any Named User Subscription and to Deactivate all perpetual licenses
on this computer, in advance.After the change, you can Sign In again or activate your perpetual
licenses.

As with activating and deactivating licenses, the repair procedure may be done online or oine.

You can choose between Online and Oine activation in the License Manager Preferences. See
License Manager Preferences on page 28
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Note:  If repairing a license doesn't work, please contact Customer Support.

4.4.1.  Online Repair

To repair your broken license(s) online, do the following:

1. Launch the Esko  License Manager .
2. In the Esko  License Manager ’s window:

• If only one license is broken, select it and click Repair...
• If many licenses are broken, select one and click Repair All...

3. Click Next / Continue in the first screen of the Repair License Wizard/Assistant dialog box.
4. Select I am aware that the Esko Network License Services will be restarted and click Next /

Continue. Only applicable for Network License Manager.

A status bar will appear while the system communicates with the activation server. After that, a
message will appear that the repair completed successfully and that you can now use the product(s)
on your computer.

 

 
5. Click Finish / Done.
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6. When asked to confirm restarting the licensing services (on PC only), click Yes. Access to licenses
will be interrupted temporarily while the services restart. Only applicable for Network License
Manager.

4.4.2.  Oine Repair

To repair broken licenses on a machine without Internet access, follow the same general procedure as
when performing an oine activation or deactivation.

Creating a Repair Request
To create the repair request, do the following:

1. Launch the Esko  License Manager .
2. In the Esko  License Manager ’s window:

• If only one license is broken, select it and click Repair...
• If many licenses are broken, select one and click Repair All...

3. Click Next / Continue in the first screen of the Repair License Wizard/Assistant dialog box.
4. Select I am aware that the Esko Network License Services will be restarted and click Next /

Continue. Only applicable for Network License Manager.
5. LeaveStep 1: generate your request file selected and click Next / Continue.
6. Save the repair request file created.

a) Click Save As (PC) / Save... (Mac).
b) In the pop-up that opens, browse to the desired location and click Save.

Note:  By default, the activation request file is called requestrepair.xml.

7. A message will appear saying that Step 1 of the oine repair has been completed successfully. Click
Finish / Done.

8. Copy that file to a computer with Internet access using whatever method you have available - USB
drive, internal network...

Uploading the Request and Downloading the Response
Once you have copied the repair request file to a machine with full Internet access, do the following:

1. Start a web browser on that machine and go to http://www.esko.com/licensing/Activation.
2. On the web page, click the Choose File button.
3. Browse for the repair request file you copied to this machine (called requestrepair.xml by

default) and click Continue.
4. Verify that the product information contained in the repair request file is correct and click

Continue.
5. Click the Download button to download the response file generated by the website (repair-

response.xml).

6. Copy the response file back to the machine running the Esko  License Manager  and go to that
machine.
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Loading the Repair Response
Once you are back at the machine running the Esko  License Manager , do the following to load the
deactivation response file:

1. Drag and drop your response file on the Esko  License Manager ’s main window, or click the Repair...
button.

This opens the Repair License Wizard (on PC) or the Repair License Assistant (on Mac). Click Next
(on PC) or Continue (on Mac)

2. Select I am aware that the Esko Network License Services will be restarted and click Next /
Continue. Only applicable for Network License Manager.

3. Select Step 2: Load your response file and click Next / Continue. In case you dropped your
activation response on the License Manager, this step will be skipped.

4. Select the response file you copied from the machine with full Internet access.
a) If you dropped your response file on the License Manager, the file will already be selected. Click

Next / Continue.
b) If not, browse to the response file you copied from the machine with full Internet access and

click Next / Continue.

Attention:  Select the response file you downloaded from the website (repair-
response.xml) and not the repair request file you uploaded.

A status bar will appear while the system processes the response file. After that, a message will
appear that the repair completed successfully.

5. Click Finish.
6. When asked to confirm restarting the licensing services (on PC only), click Yes. Access to licenses

will be interrupted temporarily while the services restart. Only applicable for Network License
Manager.

4.5.  Cleaning Up Licenses

When you have expired or disabled licenses, you can delete them from the License Manager database.

1. In the Esko  License Manager  window, choose Show Expired Licenses in the filter dropdown.
2. Select all license(s) to delete and click the Delete... button.

This opens the Delete License Wizard (on PC) or the Delete License Assistant (on Mac).
3. Click Next (on PC) or Continue (on Mac) in the first screen of the Delete License Wizard/Assistant

dialog box.
4. Select I am aware that the Esko Network License Services will be restarted and click Next /

Continue. Only applicable for Network License Manager.
5. In the next screen, check the name of the product whose license you want to delete, then click Next

/ Continue to delete it.
6. Click Finish / Done.
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4.6.  Saving Product Keys

Using the Save Product Keys button, you can save all your active Product Keys in one single file. This
file can be useful in case your computer crashes or is stolen. To save all your product keys, do the
following:

1. Launch the Esko  License Manager .
2. In the Esko  License Manager  window, select Save product keys...
3. In the Save As dialog box, navigate to the desired folder in which to save the file, enter a different

name in the File name: field if the one supplied is not sucient, and click Save.
4. Store the Product Keys file it in a safe place.

Note:  Every time you activate, deactivate or repair licenses using the License Manager Activation
Wizard resulting in a changed license setup, a backup file is written

4.7.  Saving a License Report

A License Report stores information about all your licenses on this computer. This information can be
useful in case your computer crashes or is stolen, or for inspection. To save a License Report, do the
following:

1. Launch the Esko  License Manager .
2. In the Esko  License Manager , select Help > Save License Report...
3. In the Save As dialog box, navigate to the desired folder in which to save the file, enter a different

name in the File name: field if the one supplied is not sucient, and click Save.
4. Open the file in a text editor such as Notepad, print it, and store it in a safe place.

4.8.  Enabling network licenses on the network

When setting up Network Licenses, besides the Esko Network License Manager to manage your
licenses, you also need a utility to make these licenses available to the users on the network.

On a PC this is done by the FlexLM License Manager windows service. This service is configured to
start automatically, after a reboot of the computer.

on a Mac this is done by the Server Start application.

• To launch the Esko Network License Manager on a Mac:
a) Log in to the server that has the Esko Network License Manager installed.
b) Go to Applications/Esko License Server and double-click Server Start.app.

The Server Start window opens.
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c) When you see The License Server has been started, click Quit to close the window.
d) Still in Applications/Esko License Server, double-click Esko Network License

Manager.app.

This opens the Esko Network License Manager’s main window.

 

 

The Network License Manager application status bar (at the bottom of the application window) should
not show a red error message "Cannot connect to License Server. Please check your network set up."
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4.9.  License Manager Preferences

In the License Manager Preferences, you can set the default way to activate, deactivate and repair
licenses.

To open the Preferences:

• On Mac, choose Local / Network License Manager > License Manager Preferences or use the
shortcut Cmd+,

• On Windows, choose Help > License Manager Preferences

 

 

• Use System Settings (the default setting): If Automatic Proxy Configuration (PAC) is set in your
operating system, the application will use this Proxy settings. Otherwise, the application will
connect to the internet without Proxy.

• Select Connect without a proxy server if you are connected directly to the internet, or choose Use
a proxy server if you are connected to the internet through a proxy server. Both options enable
online activation, deactivation and repairing.

• Online Activation: see Online Activation on page 12

• Online Deactivation: see Online Deactivation on page 19

• Online Repair: see Online Repair on page 23
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• Select Activate via another online computer to only enable oine activation, deactivation and
repairing

• Oine Activation: see Oine Activation on page 13

• Oine Deactivation: see Oine Deactivation on page 20

• Oine Repair: see Oine Repair on page 24

Note:  If you choose online activation in the Preferences, but no network connection is found, you
will still be prompted to add Proxy server details, and get the option to choose oine activation,
deactivation or repair.

Attention:  Esko Subscription licenses require online connection on this computer. Whereas
oine activation is possible for perpetual licensing, this is not supported for Subscription
licensing.
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5.  Manage the subscriptions for your team
As an administrator, you can manage the subscriptions of your team online on http://
MySoftware.esko.com/subscriptions. You need to sign in with your Esko ID.

Note:  By default, the person who ordered the subscriptions can access the management portal. If
someone else will manage the subscriptions, contact Esko Support to change access.

The management portal contains two tabs:

• The Unassigned subscriptions view shows for what product subscriptions are available, and how
much.

• The Assigned subscriptions view shows per user which subscriptions are assigned, since when,
whether the user is signed in, and on what computer.

1. To assign a subscription to a user:
a) Go to the Unassigned Subscriptions view
b) Select the product and click Assign
c) Enter the e-mail address of the user and a comment (not mandatory), and click Assign
The user will receive an e-mail with the download link, and you will see that the user is added to the
Assigned Subscriptions view.

Note:  If the user doesn't have an Esko ID yet, the invitation e-mail will also contain the instructions
to create one. This Esko ID will automatically be linked to your Company Code.

2. To unassign a subscription:
a) Go to the Assigned Subscriptions view
b) Select the user, and click Unassign
The user will receive an e-mail that his subscription is unassigned, and the subscription is
automatically removed from his computer. You can immediately assign the subscription to another
user.

5.1.  Subscription renewal

You can purchase subscriptions, and the involved licenses are valid for a limited time, in most cases
one year.

When you renew the subscription, the licenses will be reset on the local computer automatically
by the Esko Subscription Service. This service, running in the background on the local computer,
checks three time per day online if the licenses are approaching the payment due date, and if there is a
possible update available in the Esko licensing store.

In order to stay signed in and to be able to keep on using the application, the computer must be able to
connect to the Internet at least once a month.

The Esko Subscription Service uses the settings in the Local License Manager Preferences to connect
to the internet. See License Manager Preferences on page 28
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5.2.  Forced Sign Out

When you try to sign in on a computer while still being signed in on another, you can choose to force
sign out on the other computer. You will be signed in on this computer, while the subscription will be
removed from the other computer.

This Force Sign Out operation is done by the Esko Subscription Service. See also Subscription renewal
on page 30

The Esko Subscription Service uses the settings in the Local License Manager Preferences to connect
to the internet. See License Manager Preferences on page 28
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6.  Tips and Troubleshooting
In this section are tips and troubleshooting information designed to help you use the software if there
are unexpected results.

6.1.  Log files

The License Manager activation wizard/assistant creates a log file for every session. The log file is
saved in the following folders:

Operating
System

File location

Mac OS X [user]/Library/Logs/
Esko_Server_License_Manager_yyyymmdd_hhmmss.log or [user]/
Library/Logs/Esko_Local_License_Manager_yyyymmdd_hhmmss.log

Windows [user]\esko\Esko_Server_License_Manager_yyyymmdd_hhmmss.log or
[user]\esko\Esko_Local_License_Manager_yyyymmdd_hhmmss.log

You can also view the logs by selecting Help > Show License Manager Log

The Esko Subscription Service is a service running in the background and executes for Named User
Subscription renewal and Forced Sign Out operations. See Subscription renewal on page 30 and Forced
Sign Out on page 31. This service also has some logging available

Operating System Log location

Mac OS X file /var/log/com.esko.SubscriptionService.log or
use the Console application to open this file

Windows Use windows Eventviewer. Click Windows Logs >
Application.

Look for messages with "Esko Subscription
Service" as Source.

Use 'Save All Events As...." to create a text file
when asked.

Tip:  You can use Save License Report to make a
LicenseSupport.txt file in Local License Manager
containing all the licenses (including the licenses
attached to your signed in subscription). See
Saving a License Report on page 26
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6.2.  Changing the Language

The Esko  License Manager  user interface will adapt itself to the language of your operating system.
Or, if not available, the default language (English) will be used.

If you wish to change the language, proceed as following:

• In the Esko  License Manager  window, select your desired language from the language list.

6.3.  Function Keys

You can use the following keys to perform specific checks in the Esko  License Manager . You
generally won’t need to perform these checks unless instructed to do so by your Customer Support
representative, in case of a problem.

Key Function

F1 (Windows) or
fn+F1 (Mac OS X)

Shows the version of the Esko  License Manager  you are using.

F4 (Windows) or
fn+F4 (Mac OS X)

Allows you to see if a license for a particular module is available (for example a
license for a trapping module).

See Checking the Availability of a Feature License on page 33 for details.

F5 (Windows) or
Cmd+R (Mac OS X)

Refreshes the licenses list. You will only need to do this in specific cases as the
licenses list normally auto-refreshes.

6.3.1.  Checking the Availability of a Feature License

If you can’t access a function or module in an application, for which you believe you have a license
(for example a Trapping, RIP or Step&Repeat module), you can check if a license is available for this
feature.

1. Press F4 while in the Esko  License Manager  window.

This opens the Feature Key dialog.
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2. In that dialog, enter the feature license you are looking for, the application version and the server
name (for Network License Manager only) and click OK.

For example, enter “artpro_srautomatic 9.5” for the Automatic Step&Repeat module of
ArtPro 9.5, or enter “artpro_srautomatic 9.5 @server1” for the Automatic Step&Repeat
module of ArtPro 9.5 located on “server1”.

If you are not sure how to enter the name of the feature license you are looking for, please contact
your Customer Service Representative.

If a local license was found, you will see:
 

 

If a network license was found, you will see:
 

 

If the requested license was not found, you will see:
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Note:

If you have both the Esko Local License Manager and the Esko Network License Manager running on
your computer, both databases (“trusted storages”) will be checked.

If the Network License Manager’s FlexLM License Manager service is not running, you may get an error
message. In that case, restart the computer or start theFlexLM License Manager and try again.

6.4.  Characters in the Computer Name

Make sure your computer name only contains regular ASCII characters (for example, no ü).

6.5.  Activating a product key file containing many licenses

Some product key files, e.g. a typical Automation Engine server file, can have over a hundred licenses.

When manipulating the licenses, it can take a long time, and appear as if the Esko Network License
Manager is hanging, when it is not. It will probably take several minutes to activate or deactivate the
licenses for an Automation Engine server.

Do not cancel or close the program when you work with Automation Engine licenses.

6.6.  Using File System Monitoring Utilities

The licensing server software stores its critical configuration information in a special area of the file
system called trusted storage.

If you are using a file system monitoring utility such as anti-virus software, it can delete the
configuration in the trusted storage area. Make sure in the monitoring utility to exclude those
directories from monitoring / cleanup / replacing.

Operating System Trusted Storage location

OS X on a Macintosh /Library/Preferences/FLEXnet Publisher/FLEXnet

Windows 7 and higher on a
PC

\ProgramData\FLEXnet

6.7.  Connection Issues during Online Activation

When performing an online activation, if the Esko  License Manager  cannot access the Internet, it will
prompt for proxy server information.

You can also edit the proxy settings in the License Manager Preferences. See License Manager
Preferences on page 28.
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• If you have a proxy server, enter the required information and click Next / Continue.
 

 

If this does not work, ask your IT manager to:

1. increase the proxy server time-out to 10 minutes,
2. make the proxy server or firewall allow HTTP and HTTPS access to the website *.esko.com

over ports 80 and 443,
3. review the proxy server / firewall log files for possible errors.

• If you do not have a proxy server, and are still unable to connect, you might want to try connecting
to a website using a regular browser, to check if something else is wrong with your connection.

6.8.  If the Activation Fails

• If the activation of an important number of product keys fails (for example when activating a
product key file containing Automation Engine or FlexRip licenses), some of the product keys may
still have been activated.

If the Activated Product list is blank, scroll down to check any error messages about the failed
activation of specific license keys.
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• If these messages contain an Incident ID, there was a problem on the server side. Note this incident
ID and contact your Esko Customer Service Representative for help with the failed activations.

6.9.  If the Deactivation Fails

If the deactivation of your licenses fails (for example if there is a problem with the network connection
during the deactivation), your licenses will be disabled, but not deactivated.

To fix this, select them and deactivate them again.

6.10.  If the Program Hangs

If the Esko  License Manager  hangs when you launch it, or other Esko applications that use managed
licenses hang when you launch them, it could be because:

• the local system on which the Esko application was launched was not rebooted when it should have
been. If you are prompted to reboot during installation, make sure to do so.

• another program using licenses managed by the Esko  License Manager  may have crashed, or
otherwise locked the license system. This may happen only if the license manager is misconfigured.
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6.11.  Issues with Adobe Licenses

When you are experiencing issues with Adobe licenses (you get the message "Licensing for this
product has stopped working" on startup), the Adobe FAQ will sometimes instruct you to delete
the FlexNet preferences folder.

 

 

Do not do this, as this can compromise your Esko licenses.

If your Esko licenses have been compromised, call your Esko Customer Service Representative for
help.

6.12.  Issues with Network License Manager

If a license activation, deactivation or repair fails and the Finish page shows a message "Cannot
connect to License Server.", then the actual activation/deactivation or repair part may be processed
correctly, but only the restart of the licensing service failed. There may be many reasons for this, and
you may be able resolve by rebooting the computer.
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7.  Glossary
Esko ID
A free account that enables you to activate and perform some other actions related to licensing.

Activation Request file
A file that is created in the License Manager during oine activation, that needs to be uploaded to
esko.com/licensing.

Active
A license is Active if it is activated and available for using.

Broken
A license is Broken if, due to for example changes in hardware configuration, a license became
unusable.

Disabled
A license is Disabled after creating a Deactivation Request but before processing the Deactivation
Response.

Expired
A license is Expired after the expiry date of a Time-limited or Trial license.

Feature key
A string with a certain version that is used in the software to perform license checks.

License
The legal right to use a particular product under the terms of the license agreement (EULA).

License server (computer)
A computer where the Network License Manager is installed.

License server service
Software that serves the licenses to client applications.

Local License
A Local license is activated on the computer on which the application is going to be used.

Local License Manager
A utility program used to manage local licenses (activating, deactivating, repairing...).

Mixed
A license is Mixed if it contains licenses with different statuses.

Network License
A Network License is activated on a License Server. Network licenses can float between the different
computers connected to the license server.

Network License Manager
A utility program used to manage network licenses (activating, deactivating, repairing, viewing
licenses in use...).

Oine activation
The process to get the licenses corresponding to the provided product keys on a computer without an
internet connection.
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Oine deactivation
The process to return licenses from a computer without an internet connection in order to activate
them again on a new computer.

Online Activation
The process to get the licenses corresponding to the provided product keys on a computer with an
internet connection.

Online deactivation
The process to return licenses from a computer with an internet connection in order to activate them
again on a new computer.

Permanent
A license is Permanent if it doesn't have an expiration date.

Product key
A unique string of 5 sextets with numbers and letters that represent the license for a product or an
option.

Product key file
A HTML file that bundles multiple product keys.

Repair
The process to repair a broken license.

Response file
A file that is received from esko.com/licensing during oine activation or deactivation and that needs
to be uploaded in the License Manager.

Time-limited
A license is Time-limited if the license has an expiry date.

Trial
A Trial is a license for 30 days, available on downloadable software only, that doesn't need any product
key.

Trusted Storage
The secure repository files containing the license information, located on the computer where the
software is licensed.

Upgrade key file
A HTML file that is used to upgrade activated licenses on a specific computer to a newer version.
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