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1.  Copyright Notice
© Copyright 2022 Esko Software BV, Gent, Belgium

All rights reserved. This material, information and instructions for use contained herein are the
property of Esko Software BV. The material, information and instructions are provided on an AS IS
basis without warranty of any kind. There are no warranties granted or extended by this document.
Furthermore Esko Software BV does not warrant, guarantee or make any representations regarding
the use, or the results of the use of the software or the information contained herein. Esko Software
BV shall not be liable for any direct, indirect, consequential or incidental damages arising out of the use
or inability to use the software or the information contained herein.

The information contained herein is subject to change without notice. Revisions may be issued from
time to time to advise of such changes and/or additions.

No part of this document may be reproduced, stored in a data base or retrieval system, or published, in
any form or in any way, electronically, mechanically, by print, photoprint, microfilm or any other means
without prior written permission from Esko Software BV.

This document supersedes all previous dated versions.

PANTONE
®

 Colors displayed in the software application or in the user documentation may not match
PANTONE-identified standards. Consult current PANTONE Color Publications for accurate color.
PANTONE

®
 and other Pantone trademarks are the property of Pantone LLC. © Pantone LLC, 2015

Pantone is the copyright owner of color data and/or software which are licensed to Esko to distribute
for use only in combination with Studio Visualizer. PANTONE Color Data and/or Software shall not be
copied onto another disk or into memory unless as part of the execution of Studio Visualizer.

This software is based in part on the work of the Independent JPEG Group.

Portions of this software are copyright © 1996-2002 The FreeType Project (www.freetype.org). All
rights reserved.

Portions of this software are copyright 2006 Feeling Software, copyright 2005-2006 Autodesk Media
Entertainment.

Portions of this software are copyright ©1998-2003 Daniel Veillard. All rights reserved.

Portions of this software are copyright ©1999-2006 The Botan Project. All rights reserved.

Part of the software embedded in this product is gSOAP software. Portions created by gSOAP are
Copyright ©2001-2004 Robert A. van Engelen, Genivia inc. All rights reserved.

Portions of this software are copyright ©1998-2008 The OpenSSL Project and ©1995-1998 Eric Young
(eay@cryptsoft.com). All rights reserved.

This product includes software developed by the Apache Software Foundation (http://
www.apache.org/).

Adobe, the Adobe logo, Acrobat, the Acrobat logo, Adobe Creative Suite, Illustrator, InDesign, PDF,
Photoshop, PostScript, XMP and the Powered by XMP logo are either registered trademarks or
trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Microsoft and the Microsoft logo are registered trademarks of Microsoft Corporation in the United
States and other countries.

SolidWorks is a registered trademark of SolidWorks Corporation.

Portions of this software are owned by Spatial Corp. 1986 2003. All Rights Reserved.
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JDF and the JDF logo are trademarks of the CIP4 Organisation. Copyright 2001 The International
Cooperation for the Integration of Processes in Prepress, Press and Postpress (CIP4). All rights
reserved.

The Esko software contains the RSA Data Security, Inc. MD5 Message-Digest Algorithm.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun
Microsystems in the U.S. and other countries.

Part of this software uses technology by Best Color Technology (EFI). EFI and Bestcolor are registered
trademarks of Electronics For Imaging GmbH in the U.S. Patent and Trademark Oce.

Contains PowerNest library Copyrighted and Licensed by Alma, 2005 – 2007.

Part of this software uses technology by GlobalVision. ArtProof and ScanProof are registered
trademarks of GlobalVision Inc.

Part of this software uses technology by Qoppa Software. Copyright © 2002-Present. All Rights
Reserved.

All other product names are trademarks or registered trademarks of their respective owners.

Correspondence regarding this publication should be forwarded to:

Esko Software BV

Raymonde de Larochelaan 13

B – 9051 Gent

info.eur@esko.com

1.1.  Third party license information

This product includes zlib.

 (C) 1995-2017 Jean-loup Gailly and Mark Adler

  This software is provided 'as-is', without any express or implied
  warranty.  In no event will the authors be held liable for any damages
  arising from the use of this software.

  Permission is granted to anyone to use this software for any purpose,
  including commercial applications, and to alter it and redistribute it
  freely, subject to the following restrictions:

  1. The origin of this software must not be misrepresented; you must not
     claim that you wrote the original software. If you use this software
     in a product, an acknowledgment in the product documentation would be
     appreciated but is not required.
  2. Altered source versions must be plainly marked as such, and must not be
     misrepresented as being the original software.
  3. This notice may not be removed or altered from any source distribution.

  Jean-loup Gailly        Mark Adler
  jloup@gzip.org          madler@alumni.caltech.edu
    
------------------------------------------------------------

This product includes curl.

      Copyright (c) 1996 - 2015, Daniel Stenberg, <daniel@haxx.se>.
      All rights reserved.

      Permission to use, copy, modify, and distribute this software for any purpose
      with or without fee is hereby granted, provided that the above copyright
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      notice and this permission notice appear in all copies.

      THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
      IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
      FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN
      NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
      DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
      OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
      OR OTHER DEALINGS IN THE SOFTWARE.

      Except as contained in this notice, the name of a copyright holder shall not
      be used in advertising or otherwise to promote the sale, use or other dealings
      in this Software without prior written authorization of the copyright holder.
    
------------------------------------------------------------

This product includes curl.

      COPYRIGHT AND PERMISSION NOTICE

      Copyright (c) 1996 - 2020, Daniel Stenberg, <daniel@haxx.se>, and many
      contributors, see the THANKS file.

      All rights reserved.

      Permission to use, copy, modify, and distribute this software for any purpose
      with or without fee is hereby granted, provided that the above copyright
      notice and this permission notice appear in all copies.

      THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
      IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
      FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN
      NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
      DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
      OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
      OR OTHER DEALINGS IN THE SOFTWARE.

      Except as contained in this notice, the name of a copyright holder shall not
      be used in advertising or otherwise to promote the sale, use or other dealings
      in this Software without prior written authorization of the copyright holder.
    
------------------------------------------------------------

This product includes patented technology.

      This product and use of this product is under license from Markzware
      under U.S. Patent No. 5,963,641.
    
------------------------------------------------------------

This product includes lzw-ab.

    Copyright (c) David Bryant
    All rights reserved.

    Redistribution and use in source and binary forms, with or without
    modification, are permitted provided that the following conditions are met:

    * Redistributions of source code must retain the above copyright notice,
      this list of conditions and the following disclaimer.
    * Redistributions in binary form must reproduce the above copyright notice,
      this list of conditions and the following disclaimer in the
      documentation and/or other materials provided with the distribution.
    * Neither the name of Conifer Software nor the names of its contributors
      may be used to endorse or promote products derived from this software
      without specific prior written permission.

    THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
    AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
    IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
    ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR
    ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
    DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
    SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
    CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
    OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
    OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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------------------------------------------------------------

This product includes OpenJPEG.

        The copyright in this software is being made available under the 2-clauses
        BSD License, included below. This software may be subject to other third
        party and contributor rights, including patent rights, and no such rights
        are granted under this license.
       
        Copyright (c) 2002-2014, Universite catholique de Louvain (UCL), Belgium
        Copyright (c) 2002-2014, Professor Benoit Macq
        Copyright (c) 2003-2014, Antonin Descampe
        Copyright (c) 2003-2009, Francois-Olivier Devaux
        Copyright (c) 2005, Herve Drolon, FreeImage Team
        Copyright (c) 2002-2003, Yannick Verschueren
        Copyright (c) 2001-2003, David Janssens
        Copyright (c) 2011-2012, Centre National d'Etudes Spatiales (CNES), France
        Copyright (c) 2012, CS Systemes d'Information, France
       
        All rights reserved.
       
        Redistribution and use in source and binary forms, with or without
        modification, are permitted provided that the following conditions
        are met:
        1. Redistributions of source code must retain the above copyright
           notice, this list of conditions and the following disclaimer.
        2. Redistributions in binary form must reproduce the above copyright
           notice, this list of conditions and the following disclaimer in the
           documentation and/or other materials provided with the distribution.
       
        THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS `AS IS'
        AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
        IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
        ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
        LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
        CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
        SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
        INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
        CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
        ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
        POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes FreeType.

    Portions of this software are copyright (C) 2014 The FreeType
    Project (www.freetype.org) licensed under the Freetype License.
    All rights reserved.
    
------------------------------------------------------------

This product includes QtCopyDialog.

      Copyright (c) 2009 Nokia Corporation and/or its subsidiary(-ies).
      All rights reserved.

      BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO
      WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW.
      EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR
      OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY OF ANY
      KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
      PURPOSE.  THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE
      LIBRARY IS WITH YOU.  SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME
      THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.
    
------------------------------------------------------------

This product includes QtMigration.

        Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).

        Redistribution and use in source and binary forms, with or without
        modification, are permitted provided that the following conditions are
        met:
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          * Redistributions of source code must retain the above copyright
            notice, this list of conditions and the following disclaimer.
          * Redistributions in binary form must reproduce the above copyright
            notice, this list of conditions and the following disclaimer in
            the documentation and/or other materials provided with the
            distribution.
          * Neither the name of Digia Plc and its Subsidiary(-ies) nor the names
            of its contributors may be used to endorse or promote products derived
            from this software without specific prior written permission.

        THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
        "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
        LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
        A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
        OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
        SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
        LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
        DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
        THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
        (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
        OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE."
    
------------------------------------------------------------

This product includes QtService.

        Copyright (C) 2010 Nokia Corporation and/or its subsidiary(-ies).

        Redistribution and use in source and binary forms, with or without
        modification, are permitted provided that the following conditions are
        met:
          * Redistributions of source code must retain the above copyright
            notice, this list of conditions and the following disclaimer.
          * Redistributions in binary form must reproduce the above copyright
            notice, this list of conditions and the following disclaimer in
            the documentation and/or other materials provided with the
            distribution.
          * Neither the name of Nokia Corporation and its Subsidiary(-ies) nor
            the names of its contributors may be used to endorse or promote
            products derived from this software without specific prior written
            permission.

        THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
        "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
        LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
        A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
        OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
        SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
        LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
        DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
        THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
        (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
        OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes QtSingleApplication.

        Copyright (C) 2010 Nokia Corporation and/or its subsidiary(-ies). All rights
 reserved.

        Redistribution and use in source and binary forms, with or without
        modification, are permitted provided that the following conditions are
        met:
          * Redistributions of source code must retain the above copyright
            notice, this list of conditions and the following disclaimer.
          * Redistributions in binary form must reproduce the above copyright
            notice, this list of conditions and the following disclaimer in
            the documentation and/or other materials provided with the
            distribution.
          * Neither the name of Nokia Corporation and its Subsidiary(-ies) nor
            the names of its contributors may be used to endorse or promote
            products derived from this software without specific prior written
            permission.

        THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
        "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
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        LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
        A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
        OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
        SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
        LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
        DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
        THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
        (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
        OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

    
------------------------------------------------------------

This product includes QtSql.

      Copyright (c) 2009 Nokia Corporation and/or its subsidiary(-ies).

      BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO
      WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW.
      EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR
      OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY OF ANY
      KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
      PURPOSE.  THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE
      LIBRARY IS WITH YOU.  SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME
      THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.
    
------------------------------------------------------------

This product includes svgio.

 Copyright Oleg Maximenko 2014.
 Distributed under the Boost Software License, Version 1.0.
    
------------------------------------------------------------

This product includes QtSvg.

      The Qt Toolkit is Copyright (C) 2019 The Qt Company Ltd.
    
------------------------------------------------------------

This product includes appleseed.
The MIT License (MIT)

Copyright (c) 2010-2013 Francois Beaune, Jupiter Jazz Limited
Copyright (c) 2014-2019 The appleseedhq Organization

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.
    
------------------------------------------------------------

This product includes bcd.
        
    Copyright (c) 2017 Malik Boughida and Tamy Boubekeur. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this
   list of conditions and the following disclaimer.

12



1DeskPack Essentials

2. Redistributions in binary form must reproduce the above copyright notice,
   this list of conditions and the following disclaimer in the documentation
   and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its contributors
   may be used to endorse or promote products derived from this software
   without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

You are under no obligation whatsoever to provide any bug fixes, patches, or
upgrades to the features, functionality or performance of the source code
("Enhancements") to anyone; however, if you choose to make your Enhancements
available either publicly, or directly to the authors of this software, without
imposing a separate written license agreement for such Enhancements, then you
hereby grant the following license: a non-exclusive, royalty-free perpetual
license to install, use, modify, prepare derivative works, incorporate into
other computer software, distribute, and sublicense such enhancements or
derivative works thereof, in binary and source code form.
    
------------------------------------------------------------

This product includes glad.

        The MIT License (MIT)

Copyright (c) 2013-2018 David Herberth

Permission is hereby granted, free of charge, to any person obtaining a copy of
this software and associated documentation files (the "Software"), to deal in
the Software without restriction, including without limitation the rights to
use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of
the Software, and to permit persons to whom the Software is furnished to do so,
subject to the following conditions:

The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
    
------------------------------------------------------------

This product includes murmurhash3.
MurmurHash3 was written by Austin Appleby, and is placed in the public domain. The author
 hereby disclaims copyright to this source code.
------------------------------------------------------------

This product includes Botan.

      Copyright (C) 1999-2020 The Botan Authors
      All rights reserved.

      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions are met:

      1. Redistributions of source code must retain the above copyright notice,
        this list of conditions, and the following disclaimer.

      2. Redistributions in binary form must reproduce the above copyright
        notice, this list of conditions, and the following disclaimer in the
        documentation and/or other materials provided with the distribution.
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      THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
      AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
      ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
      LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
      CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
      SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
      INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
      CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
      ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
      POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes pugixml.

      MIT License

      Copyright (c) 2006-2019 Arseny Kapoulkine

      Permission is hereby granted, free of charge, to any person
      obtaining a copy of this software and associated documentation
      files (the "Software"), to deal in the Software without
      restriction, including without limitation the rights to use,
      copy, modify, merge, publish, distribute, sublicense, and/or sell
      copies of the Software, and to permit persons to whom the
      Software is furnished to do so, subject to the following
      conditions:

      The above copyright notice and this permission notice shall be
      included in all copies or substantial portions of the Software.

      THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
      EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
      OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
      NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
      HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
      WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
      FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
      OTHER DEALINGS IN THE SOFTWARE.
    
------------------------------------------------------------

This product includes GLEW: The OpenGL Extension Wrangler Library.

The OpenGL Extension Wrangler Library
Copyright (C) 2002-2007, Milan Ikits <milan ikits[]ieee org>
Copyright (C) 2002-2007, Marcelo E. Magallon <mmagallo[]debian org>
Copyright (C) 2002, Lev Povalahev
All rights reserved.

Redistribution and use in source and binary forms, with or without 
modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, 
  this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright notice, 
  this list of conditions and the following disclaimer in the documentation 
  and/or other materials provided with the distribution.
* The name of the author may be used to endorse or promote products 
  derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" 
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE 
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
THE POSSIBILITY OF SUCH DAMAGE.

Mesa 3-D graphics library
Version:  7.0
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Copyright (C) 1999-2007  Brian Paul   All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the "Software"),
to deal in the Software without restriction, including without limitation
the rights to use, copy, modify, merge, publish, distribute, sublicense,
and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Copyright (c) 2007 The Khronos Group Inc.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and/or associated documentation files (the
"Materials"), to deal in the Materials without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Materials, and to
permit persons to whom the Materials are furnished to do so, subject to
the following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Materials.

THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS.
  
------------------------------------------------------------

This product includes OpenSSL.

      Copyright (c) 1998-2017 The OpenSSL Project.  All rights reserved.

      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions
      are met:

      1. Redistributions of source code must retain the above copyright
         notice, this list of conditions and the following disclaimer.

      2. Redistributions in binary form must reproduce the above copyright
         notice, this list of conditions and the following disclaimer in
         the documentation and/or other materials provided with the
         distribution.

      3. All advertising materials mentioning features or use of this
         software must display the following acknowledgment:
         "This product includes software developed by the OpenSSL Project
         for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

      4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to
         endorse or promote products derived from this software without
         prior written permission. For written permission, please contact
         openssl-core@openssl.org.

      5. Products derived from this software may not be called "OpenSSL"
         nor may "OpenSSL" appear in their names without prior written
         permission of the OpenSSL Project.

      6. Redistributions of any form whatsoever must retain the following
         acknowledgment:
         "This product includes software developed by the OpenSSL Project
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         for use in the OpenSSL Toolkit (http://www.openssl.org/)"

      THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY
      EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
      PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE OpenSSL PROJECT OR
      ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
      SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
      NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
      LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
      HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
      STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
      ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
      OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes OpenSSL.

      Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)
      All rights reserved.

      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions
      are met:
      1. Redistributions of source code must retain the copyright
         notice, this list of conditions and the following disclaimer.
      2. Redistributions in binary form must reproduce the above copyright
         notice, this list of conditions and the following disclaimer in the
         documentation and/or other materials provided with the distribution.
      3. All advertising materials mentioning features or use of this software
         must display the following acknowledgement:
         "This product includes cryptographic software written by
         Eric Young (eay@cryptsoft.com)"
         The word 'cryptographic' can be left out if the rouines from the library
         being used are not cryptographic related :-).
      4. If you include any Windows specific code (or a derivative thereof) from
         the apps directory (application code) you must include an acknowledgement:
         "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

      THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND
      ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
      ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
      FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
      DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
      OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
      HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
      LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
      OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
      SUCH DAMAGE.
    
------------------------------------------------------------

This product includes JPEGLib.
This software is copyright (C) 1991-2016, Thomas G. Lane, Guido Vollbeding.
      All Rights Reserved.
      
      This software is based in part on the work of the Independent JPEG Group.
------------------------------------------------------------

This product includes tesseract.

  Copyright (C) 2016 Google, Inc. Licensed under the Apache License, Version 2.0
    
------------------------------------------------------------

This product includes robin-map.

    MIT License

    Copyright (c) 2017 Tessil

    Permission is hereby granted, free of charge, to any person obtaining a copy
    of this software and associated documentation files (the "Software"), to deal
    in the Software without restriction, including without limitation the rights
    to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
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    copies of the Software, and to permit persons to whom the Software is
    furnished to do so, subject to the following conditions:

    The above copyright notice and this permission notice shall be included in all
    copies or substantial portions of the Software.

    THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
    IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
    FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
    AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
    LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
    OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
    SOFTWARE. 
    
------------------------------------------------------------

This product includes LibTIFF.

      Copyright (c) 1988-1997 Sam Leffler
      Copyright (c) 1991-1997 Silicon Graphics, Inc.

      Permission to use, copy, modify, distribute, and sell this software and
      its documentation for any purpose is hereby granted without fee, provided
      that (i) the above copyright notices and this permission notice appear in
      all copies of the software and related documentation, and (ii) the names of
      Sam Leffler and Silicon Graphics may not be used in any advertising or
      publicity relating to the software without the specific, prior written
      permission of Sam Leffler and Silicon Graphics.

      THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,
      EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
      WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

      IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR
      ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND,
      OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
      WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF
      LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
      OF THIS SOFTWARE.
    
------------------------------------------------------------

This product includes libpng.

      Copyright (c) 2000-2002 Glenn Randers-Pehrson

      The PNG Reference Library is supplied "AS IS".  The Contributing Authors
      and Group 42, Inc. disclaim all warranties, expressed or implied,
      including, without limitation, the warranties of merchantability and of
      fitness for any purpose.  The Contributing Authors and Group 42, Inc.
      assume no liability for direct, indirect, incidental, special, exemplary,
      or consequential damages, which may result from the use of the PNG
      Reference Library, even if advised of the possibility of such damage.
      There is no warranty against interference with your enjoyment of the
      library or against infringement.  There is no warranty that our
      efforts or the library will fulfill any of your particular purposes
      or needs.  This library is provided with all faults, and the entire
      risk of satisfactory quality, performance, accuracy, and effort is with
      the user.
    
------------------------------------------------------------

This product includes libxml2.

    Copyright (C) 1998-2012 Daniel Veillard.  All Rights Reserved.

    Permission is hereby granted, free of charge, to any person obtaining a copy
    of this software and associated documentation files (the "Software"), to deal
    in the Software without restriction, including without limitation the rights
    to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
    copies of the Software, and to permit persons to whom the Software is fur-
    nished to do so, subject to the following conditions:

    The above copyright notice and this permission notice shall be included in
    all copies or substantial portions of the Software.

    THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
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    IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FIT-
    NESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL THE
    AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
    LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
    OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
    THE SOFTWARE.
    
------------------------------------------------------------

This product includes cereal.

    Copyright (c) 2014, Randolph Voorhies, Shane Grant
    All rights reserved.

    Redistribution and use in source and binary forms, with or without
    modification, are permitted provided that the following conditions are met:
        * Redistributions of source code must retain the above copyright
        notice, this list of conditions and the following disclaimer.
        * Redistributions in binary form must reproduce the above copyright
        notice, this list of conditions and the following disclaimer in the
        documentation and/or other materials provided with the distribution.
        * Neither the name of cereal nor the
        names of its contributors may be used to endorse or promote products
        derived from this software without specific prior written permission.

    THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
    ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
    WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
    DISCLAIMED. IN NO EVENT SHALL RANDOLPH VOORHIES OR SHANE GRANT BE LIABLE FOR ANY
    DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
    (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
    LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
    ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
    (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
    SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  
------------------------------------------------------------

This product includes OpenJDK.
 
The GNU General Public License (GPL)

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA

Everyone is permitted to copy and distribute verbatim copies of this license
document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share
and change it.  By contrast, the GNU General Public License is intended to
guarantee your freedom to share and change free software--to make sure the
software is free for all its users.  This General Public License applies to
most of the Free Software Foundation's software and to any other program whose
authors commit to using it.  (Some other Free Software Foundation software is
covered by the GNU Library General Public License instead.) You can apply it to
your programs, too.

When we speak of free software, we are referring to freedom, not price.  Our
General Public Licenses are designed to make sure that you have the freedom to
distribute copies of free software (and charge for this service if you wish),
that you receive source code or can get it if you want it, that you can change
the software or use pieces of it in new free programs; and that you know you
can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny
you these rights or to ask you to surrender the rights.  These restrictions
translate to certain responsibilities for you if you distribute copies of the
software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for
a fee, you must give the recipients all the rights that you have.  You must
make sure that they, too, receive or can get the source code.  And you must
show them these terms so they know their rights.
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We protect your rights with two steps: (1) copyright the software, and (2)
offer you this license which gives you legal permission to copy, distribute
and/or modify the software.

Also, for each author's protection and ours, we want to make certain that
everyone understands that there is no warranty for this free software.  If the
software is modified by someone else and passed on, we want its recipients to
know that what they have is not the original, so that any problems introduced
by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents.  We
wish to avoid the danger that redistributors of a free program will
individually obtain patent licenses, in effect making the program proprietary.
To prevent this, we have made it clear that any patent must be licensed for
everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification
follow.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice
placed by the copyright holder saying it may be distributed under the terms of
this General Public License.  The "Program", below, refers to any such program
or work, and a "work based on the Program" means either the Program or any
derivative work under copyright law: that is to say, a work containing the
Program or a portion of it, either verbatim or with modifications and/or
translated into another language.  (Hereinafter, translation is included
without limitation in the term "modification".) Each licensee is addressed as
"you".

Activities other than copying, distribution and modification are not covered by
this License; they are outside its scope.  The act of running the Program is
not restricted, and the output from the Program is covered only if its contents
constitute a work based on the Program (independent of having been made by
running the Program).  Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program's source code as
you receive it, in any medium, provided that you conspicuously and
appropriately publish on each copy an appropriate copyright notice and
disclaimer of warranty; keep intact all the notices that refer to this License
and to the absence of any warranty; and give any other recipients of the
Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may
at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus
forming a work based on the Program, and copy and distribute such modifications
or work under the terms of Section 1 above, provided that you also meet all of
these conditions:

    a) You must cause the modified files to carry prominent notices stating
    that you changed the files and the date of any change.

    b) You must cause any work that you distribute or publish, that in whole or
    in part contains or is derived from the Program or any part thereof, to be
    licensed as a whole at no charge to all third parties under the terms of
    this License.

    c) If the modified program normally reads commands interactively when run,
    you must cause it, when started running for such interactive use in the
    most ordinary way, to print or display an announcement including an
    appropriate copyright notice and a notice that there is no warranty (or
    else, saying that you provide a warranty) and that users may redistribute
    the program under these conditions, and telling the user how to view a copy
    of this License.  (Exception: if the Program itself is interactive but does
    not normally print such an announcement, your work based on the Program is
    not required to print an announcement.)

These requirements apply to the modified work as a whole.  If identifiable
sections of that work are not derived from the Program, and can be reasonably
considered independent and separate works in themselves, then this License, and
its terms, do not apply to those sections when you distribute them as separate
works.  But when you distribute the same sections as part of a whole which is a
work based on the Program, the distribution of the whole must be on the terms
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of this License, whose permissions for other licensees extend to the entire
whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your
rights to work written entirely by you; rather, the intent is to exercise the
right to control the distribution of derivative or collective works based on
the Program.

In addition, mere aggregation of another work not based on the Program with the
Program (or with a work based on the Program) on a volume of a storage or
distribution medium does not bring the other work under the scope of this
License.

3. You may copy and distribute the Program (or a work based on it, under
Section 2) in object code or executable form under the terms of Sections 1 and
2 above provided that you also do one of the following:

    a) Accompany it with the complete corresponding machine-readable source
    code, which must be distributed under the terms of Sections 1 and 2 above
    on a medium customarily used for software interchange; or,

    b) Accompany it with a written offer, valid for at least three years, to
    give any third party, for a charge no more than your cost of physically
    performing source distribution, a complete machine-readable copy of the
    corresponding source code, to be distributed under the terms of Sections 1
    and 2 above on a medium customarily used for software interchange; or,

    c) Accompany it with the information you received as to the offer to
    distribute corresponding source code.  (This alternative is allowed only
    for noncommercial distribution and only if you received the program in
    object code or executable form with such an offer, in accord with
    Subsection b above.)

The source code for a work means the preferred form of the work for making
modifications to it.  For an executable work, complete source code means all
the source code for all modules it contains, plus any associated interface
definition files, plus the scripts used to control compilation and installation
of the executable.  However, as a special exception, the source code
distributed need not include anything that is normally distributed (in either
source or binary form) with the major components (compiler, kernel, and so on)
of the operating system on which the executable runs, unless that component
itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy
from a designated place, then offering equivalent access to copy the source
code from the same place counts as distribution of the source code, even though
third parties are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as
expressly provided under this License.  Any attempt otherwise to copy, modify,
sublicense or distribute the Program is void, and will automatically terminate
your rights under this License.  However, parties who have received copies, or
rights, from you under this License will not have their licenses terminated so
long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it.
However, nothing else grants you permission to modify or distribute the Program
or its derivative works.  These actions are prohibited by law if you do not
accept this License.  Therefore, by modifying or distributing the Program (or
any work based on the Program), you indicate your acceptance of this License to
do so, and all its terms and conditions for copying, distributing or modifying
the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program),
the recipient automatically receives a license from the original licensor to
copy, distribute or modify the Program subject to these terms and conditions.
You may not impose any further restrictions on the recipients' exercise of the
rights granted herein.  You are not responsible for enforcing compliance by
third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent
infringement or for any other reason (not limited to patent issues), conditions
are imposed on you (whether by court order, agreement or otherwise) that
contradict the conditions of this License, they do not excuse you from the
conditions of this License.  If you cannot distribute so as to satisfy
simultaneously your obligations under this License and any other pertinent
obligations, then as a consequence you may not distribute the Program at all.
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For example, if a patent license would not permit royalty-free redistribution
of the Program by all those who receive copies directly or indirectly through
you, then the only way you could satisfy both it and this License would be to
refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any
particular circumstance, the balance of the section is intended to apply and
the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or
other property right claims or to contest validity of any such claims; this
section has the sole purpose of protecting the integrity of the free software
distribution system, which is implemented by public license practices.  Many
people have made generous contributions to the wide range of software
distributed through that system in reliance on consistent application of that
system; it is up to the author/donor to decide if he or she is willing to
distribute software through any other system and a licensee cannot impose that
choice.

This section is intended to make thoroughly clear what is believed to be a
consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain
countries either by patents or by copyrighted interfaces, the original
copyright holder who places the Program under this License may add an explicit
geographical distribution limitation excluding those countries, so that
distribution is permitted only in or among countries not thus excluded.  In
such case, this License incorporates the limitation as if written in the body
of this License.

9. The Free Software Foundation may publish revised and/or new versions of the
General Public License from time to time.  Such new versions will be similar in
spirit to the present version, but may differ in detail to address new problems
or concerns.

Each version is given a distinguishing version number.  If the Program
specifies a version number of this License which applies to it and "any later
version", you have the option of following the terms and conditions either of
that version or of any later version published by the Free Software Foundation.
If the Program does not specify a version number of this License, you may
choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs
whose distribution conditions are different, write to the author to ask for
permission.  For software which is copyrighted by the Free Software Foundation,
write to the Free Software Foundation; we sometimes make exceptions for this.
Our decision will be guided by the two goals of preserving the free status of
all derivatives of our free software and of promoting the sharing and reuse of
software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR
THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW.  EXCEPT WHEN OTHERWISE
STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE
PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE.  THE ENTIRE RISK AS TO THE QUALITY AND
PERFORMANCE OF THE PROGRAM IS WITH YOU.  SHOULD THE PROGRAM PROVE DEFECTIVE,
YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL
ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE
PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY
GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR
INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA
BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A
FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER
OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible
use to the public, the best way to achieve this is to make it free software
which everyone can redistribute and change under these terms.
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To do so, attach the following notices to the program.  It is safest to attach
them to the start of each source file to most effectively convey the exclusion
of warranty; and each file should have at least the "copyright" line and a
pointer to where the full notice is found.

    One line to give the program's name and a brief idea of what it does.

    Copyright (C) <year> <name of author>

    This program is free software; you can redistribute it and/or modify it
    under the terms of the GNU General Public License as published by the Free
    Software Foundation; either version 2 of the License, or (at your option)
    any later version.

    This program is distributed in the hope that it will be useful, but WITHOUT
    ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
    FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
    more details.

    You should have received a copy of the GNU General Public License along
    with this program; if not, write to the Free Software Foundation, Inc.,
    51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it
starts in an interactive mode:

    Gnomovision version 69, Copyright (C) year name of author Gnomovision comes
    with ABSOLUTELY NO WARRANTY; for details type 'show w'.  This is free
    software, and you are welcome to redistribute it under certain conditions;
    type 'show c' for details.

The hypothetical commands 'show w' and 'show c' should show the appropriate
parts of the General Public License.  Of course, the commands you use may be
called something other than 'show w' and 'show c'; they could even be
mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school,
if any, to sign a "copyright disclaimer" for the program, if necessary.  Here
is a sample; alter the names:

    Yoyodyne, Inc., hereby disclaims all copyright interest in the program
    'Gnomovision' (which makes passes at compilers) written by James Hacker.

    signature of Ty Coon, 1 April 1989

    Ty Coon, President of Vice

This General Public License does not permit incorporating your program into
proprietary programs.  If your program is a subroutine library, you may
consider it more useful to permit linking proprietary applications with the
library.  If this is what you want to do, use the GNU Library General Public
License instead of this License.

"CLASSPATH" EXCEPTION TO THE GPL

Certain source files distributed by Oracle America and/or its affiliates are
subject to the following clarification and special exception to the GPL, but
only where Oracle has expressly included in the particular source file's header
the words "Oracle designates this particular file as subject to the "Classpath"
exception as provided by Oracle in the LICENSE file that accompanied this code."

    Linking this library statically or dynamically with other modules is making
    a combined work based on this library.  Thus, the terms and conditions of
    the GNU General Public License cover the whole combination.

    As a special exception, the copyright holders of this library give you
    permission to link this library with independent modules to produce an
    executable, regardless of the license terms of these independent modules,
    and to copy and distribute the resulting executable under terms of your
    choice, provided that you also meet, for each linked independent module,
    the terms and conditions of the license of that module.  An independent
    module is a module which is not derived from or based on this library.  If
    you modify this library, you may extend this exception to your version of
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    the library, but you are not obligated to do so.  If you do not wish to do
    so, delete this exception statement from your version.
    
------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC Profiles were created by FFEI Ltd. (www.ffei.co.uk) using Fujifilm
    ColourKit Profiler Suite (www.colourprofiling.com)
    
------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC profiles are copyright (C) by European Color Initiative, www.eci.org
    
------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC profiles are copyright (C) of WAN-IFRA, www.wan-ifra.org
    
------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC profiles are copyright (C) IDEAlliance(R). G7(R), GRACol(R) and
    SWOP(R) are all registered trademarks of IDEAlliance(C).
    
------------------------------------------------------------

This product includes PANTONE Color Libraries.

    PANTONE® and other Pantone trademarks are the property of Pantone LLC.
    Pantone is a wholly owned subsidiary of X-Rite, Incorporated.
    
------------------------------------------------------------

This product includes gSOAP.

      EXHIBIT B.
      
      Part of the software embedded in this product is gSOAP software.
      Portions created by gSOAP are Copyright (C) 2001-2007 Robert A. van Engelen,
 Genivia inc. All Rights Reserved.

      THE SOFTWARE IN THIS PRODUCT WAS IN PART PROVIDED BY GENIVIA INC AND ANY EXPRESS
 OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
 MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
 THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
 CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
 OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
 ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
 ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes LibTIFF.

      Copyright (c) 1988-1997 Sam Leffler
      Copyright (c) 1991-1997 Silicon Graphics, Inc.

      Permission to use, copy, modify, distribute, and sell this software and
      its documentation for any purpose is hereby granted without fee, provided
      that (i) the above copyright notices and this permission notice appear in
      all copies of the software and related documentation, and (ii) the names of
      Sam Leffler and Silicon Graphics may not be used in any advertising or
      publicity relating to the software without the specific, prior written
      permission of Sam Leffler and Silicon Graphics.

      THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,
      EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
      WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

      IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR
      ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND,
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      OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
      WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF
      LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
      OF THIS SOFTWARE.
    
------------------------------------------------------------

This product includes llvm.

      University of Illinois/NCSA
      Open Source License

      Copyright (c) 2003-2019 University of Illinois at Urbana-Champaign.
      All rights reserved.

      Developed by:

          LLVM Team

          University of Illinois at Urbana-Champaign

          http://llvm.org

      Permission is hereby granted, free of charge, to any person obtaining a copy of
      this software and associated documentation files (the "Software"), to deal with
      the Software without restriction, including without limitation the rights to
      use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
      of the Software, and to permit persons to whom the Software is furnished to do
      so, subject to the following conditions:

          * Redistributions of source code must retain the above copyright notice,
            this list of conditions and the following disclaimers.

          * Redistributions in binary form must reproduce the above copyright notice,
            this list of conditions and the following disclaimers in the
            documentation and/or other materials provided with the distribution.

          * Neither the names of the LLVM Team, University of Illinois at
            Urbana-Champaign, nor the names of its contributors may be used to
            endorse or promote products derived from this Software without specific
            prior written permission.

      THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
      IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
      FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL THE
      CONTRIBUTORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
      LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
      OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS WITH THE
      SOFTWARE.
    
------------------------------------------------------------

This product includes OpenSSL.

      Copyright (c) 1998-2017 The OpenSSL Project.  All rights reserved.

      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions
      are met:

      1. Redistributions of source code must retain the above copyright
         notice, this list of conditions and the following disclaimer.

      2. Redistributions in binary form must reproduce the above copyright
         notice, this list of conditions and the following disclaimer in
         the documentation and/or other materials provided with the
         distribution.

      3. All advertising materials mentioning features or use of this
         software must display the following acknowledgment:
         "This product includes software developed by the OpenSSL Project
         for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

      4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to
         endorse or promote products derived from this software without
         prior written permission. For written permission, please contact
         openssl-core@openssl.org.
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      5. Products derived from this software may not be called "OpenSSL"
         nor may "OpenSSL" appear in their names without prior written
         permission of the OpenSSL Project.

      6. Redistributions of any form whatsoever must retain the following
         acknowledgment:
         "This product includes software developed by the OpenSSL Project
         for use in the OpenSSL Toolkit (http://www.openssl.org/)"

      THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY
      EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
      PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE OpenSSL PROJECT OR
      ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
      SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
      NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
      LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
      HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
      STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
      ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
      OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes OpenSSL.

      Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)
      All rights reserved.

      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions
      are met:
      1. Redistributions of source code must retain the copyright
         notice, this list of conditions and the following disclaimer.
      2. Redistributions in binary form must reproduce the above copyright
         notice, this list of conditions and the following disclaimer in the
         documentation and/or other materials provided with the distribution.
      3. All advertising materials mentioning features or use of this software
         must display the following acknowledgement:
         "This product includes cryptographic software written by
         Eric Young (eay@cryptsoft.com)"
         The word 'cryptographic' can be left out if the rouines from the library
         being used are not cryptographic related :-).
      4. If you include any Windows specific code (or a derivative thereof) from
         the apps directory (application code) you must include an acknowledgement:
         "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

      THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND
      ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
      ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
      FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
      DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
      OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
      HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
      LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
      OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
      SUCH DAMAGE.
    
------------------------------------------------------------

This product includes xxHash.

    xxHash Library
    Copyright (c) 2012-2014, Yann Collet
    All rights reserved.

    Redistribution and use in source and binary forms, with or without modification,
    are permitted provided that the following conditions are met:

    * Redistributions of source code must retain the above copyright notice, this
    list of conditions and the following disclaimer.

    * Redistributions in binary form must reproduce the above copyright notice, this
    list of conditions and the following disclaimer in the documentation and/or
    other materials provided with the distribution.
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    THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
    ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
    WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
    DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR
    ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
    (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
    LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
    ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
    (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
    SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  
------------------------------------------------------------

This product includes lz4.

        Copyright (C) 2011-present, Yann Collet.

        BSD 2-Clause License (http://www.opensource.org/licenses/bsd-license.php)

        Redistribution and use in source and binary forms, with or without
        modification, are permitted provided that the following conditions are
        met:

            * Redistributions of source code must retain the above copyright
        notice, this list of conditions and the following disclaimer.
            * Redistributions in binary form must reproduce the above
        copyright notice, this list of conditions and the following disclaimer
        in the documentation and/or other materials provided with the
        distribution.

        THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
        "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
        LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
        A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
        OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
        SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
        LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
        DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
        THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
        (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
        OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes ICU.

      Copyright (c) 1995-2014 International Business Machines Corporation and others
      All rights reserved.

      Permission is hereby granted, free of charge, to any person obtaining a copy of
      this software and associated documentation files (the "Software"), to deal in the
      Software without restriction, including without limitation the rights to use,
      copy, modify, merge, publish, distribute, and/or sell copies of the Software, and
      to permit persons to whom the Software is furnished to do so, provided that the
      above copyright notice(s) and this permission notice appear in all copies of the
      Software and that both the above copyright notice(s) and this permission notice
      appear in supporting documentation.

      THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
      IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
      FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT
      SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY
      CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES
      WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF
      CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION
      WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
    
------------------------------------------------------------

This product includes XByak.
   
Copyright (c) 2007 MITSUNARI Shigeo
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
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Redistributions of source code must retain the above copyright notice, this
list of conditions and the following disclaimer.
Redistributions in binary form must reproduce the above copyright notice,
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.
Neither the name of the copyright owner nor the names of its contributors may
be used to endorse or promote products derived from this software without
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
THE POSSIBILITY OF SUCH DAMAGE.
-----------------------------------------------------------------------------
#######################################
#######################

#######################################
#######
#######################################
##########################
#######################################
###################################
#######################################
#######################################
######################################
########################### ###########
#######################################
######################################
######################################
#######################################
######################################
################
    
------------------------------------------------------------

This product includes ittnotify.
   
Copyright (c) 2011, Intel Corporation
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this
   list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice,
   this list of conditions and the following disclaimer in the documentation
   and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its
   contributors may be used to endorse or promote products derived from
   this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes JBIG2Lib.
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    Portions of this product copyrights (C) 2002 Glyph & Cog, LLC.
    
------------------------------------------------------------

This product includes PCRE.

  Copyright (c) 1997-2016 University of Cambridge
  All rights reserved.

  Copyright(c) 2010-2016 Zoltan Herczeg
  All rights reserved.

  Copyright(c) 2009-2016 Zoltan Herczeg
  All rights reserved.

  Redistribution and use in source and binary forms, with or without
  modification, are permitted provided that the following conditions are met:

      * Redistributions of source code must retain the above copyright notice,
        this list of conditions and the following disclaimer.

      * Redistributions in binary form must reproduce the above copyright
        notice, this list of conditions and the following disclaimer in the
        documentation and/or other materials provided with the distribution.

      * Neither the name of the University of Cambridge nor the names of any
        contributors may be used to endorse or promote products derived from this
        software without specific prior written permission.

  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
  AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
  IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
  ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
  LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
  CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
  SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
  INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
  CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
  ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
  POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes Little CMS.

    Little CMS
    Copyright (c) 1998-2011 Marti Maria Saguer

    Permission is hereby granted, free of charge, to any person obtaining a copy
    of this software and associated documentation files (the "Software"), to deal
    in the Software without restriction, including without limitation the rights
    to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
    copies of the Software, and to permit persons to whom the Software is
    furnished to do so, subject to the following conditions:

    The above copyright notice and this permission notice shall be included in
    all copies or substantial portions of the Software.

    THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
    IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
    FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
    AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
    LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
    OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
    THE SOFTWARE.
    
------------------------------------------------------------

This product includes ZXing C++ Library.

      --------------------------------------------------------------------------------
      NOTICES FOR C++ Big Integer Library
      --------------------------------------------------------------------------------

      I, Matt McCutchen, the sole author of the original Big Integer
      Library, waive my copyright to it, placing it in the public domain.
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      The library comes with absolutely no warranty.
  
------------------------------------------------------------

This product includes XercesC.

    NOTICE file corresponding to section 4(d) of the Apache License, Version 2.0, in this
 case for the Apache Xerces distribution.

    This product includes software developed by
    The Apache Software Foundation (http://www.apache.org/).

    Portions of this software were originally based on the following:
     - software copyright (c) 1999, IBM Corporation., http://www.ibm.com.
    
------------------------------------------------------------

This product includes OpenShadingLanguage.

BSD 3-Clause License

Copyright (c) 2009-2019 Sony Pictures Imageworks Inc., et al.
All Rights Reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this
   list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice,
   this list of conditions and the following disclaimer in the documentation
   and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its
   contributors may be used to endorse or promote products derived from
   this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes leptonica.

 -  Copyright (C) 2001-2016 Leptonica.  All rights reserved.
 -
 -  Redistribution and use in source and binary forms, with or without
 -  modification, are permitted provided that the following conditions
 -  are met:
 -  1. Redistributions of source code must retain the above copyright
 -     notice, this list of conditions and the following disclaimer.
 -  2. Redistributions in binary form must reproduce the above
 -     copyright notice, this list of conditions and the following
 -     disclaimer in the documentation and/or other materials
 -     provided with the distribution.
 -
 -  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
 -  ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
 -  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
 -  A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL ANY
 -  CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 -  EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 -  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 -  PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
 -  OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 -  NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 -  SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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------------------------------------------------------------

This product includes FCollada.

      Copyright 2006 Feeling Software. All rights reserved.

      Copyright 2005-2006 Feeling Software and
      Copyright 2005-2006 Autodesk Media Entertainment.

      Copyright (C) 1998-2003 Daniel Veillard. All Rights Reserved.

      Permission is hereby granted, free of charge, to any person obtaining a copy
      of this software and associated documentation files (the "Software"), to deal
      in the Software without restriction, including without limitation the rights
      to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
      copies of the Software, and to permit persons to whom the Software is fur-
      nished to do so, subject to the following conditions:

      The above copyright notice and this permission notice shall be included in
      all copies or substantial portions of the Software.

      THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
      IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FIT-
      NESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL THE
      AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
      LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
      OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
      THE SOFTWARE.
    
------------------------------------------------------------

This product includes OpenImageIO.
    
        BSD 3-Clause License

Copyright (c) 2008-present by Contributors to the OpenImageIO project. All Rights
 Reserved.

Redistribution and use in source and binary forms, with or without modification, are
 permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of
 conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of
 conditions and the following disclaimer in the documentation and/or other materials
 provided with the distribution.

Neither the name of the copyright holder nor the names of its contributors may be used to
 endorse or promote products derived from this software without specific prior written
 permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
 EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
 OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
 SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
 INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
 INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
 LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
 OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

------------------------------------------------------------

This product includes tessdata.

 Inc. Licensed under the Apache License, Version 2.0
    
------------------------------------------------------------

This product includes XMP Toolkit.

      Copyright (c) 1999 - 2010, Adobe Systems Incorporated
      All rights reserved.

      Redistribution and use in source and binary forms, with or
      without modification, are permitted provided that the following
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      conditions are met:

      * Redistributions of source code must retain the above copyright notice,
      this list of conditions and the following disclaimer.
      * Redistributions in binary form must reproduce the above copyright notice,
      this list of conditions and the following disclaimer in the documentation
      and/or other materials provided with the distribution.
      * Neither the name of Adobe Systems Incorporated, nor the names of its
      contributors may be used to endorse or promote products derived from this
      software without specific prior written permission.

      THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
      "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
      LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
      A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
      CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
      EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
      PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
      PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
      LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
      NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
      SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes openexr.

      Copyright Contributors to the OpenEXR Project. All rights reserved.

      Redistribution and use in source and binary forms, with or without modification,
 are permitted provided that the following conditions are met:

          * Redistributions of source code must retain the above copyright notice, this
 list of conditions and the following disclaimer.

          * Redistributions in binary form must reproduce the above copyright notice,
 this list of conditions and the following disclaimer 
            in the documentation and/or other materials provided with the distribution.

          * Neither the name of the copyright holder nor the names of its contributors
 may be used to endorse or promote products derived from this software 
            without specific prior written permission.

      THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
 EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, 
      THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
 DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS 
      BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
 CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE 
      GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
 CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 
      LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
 THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    
    
------------------------------------------------------------

This product includes Bonjour SDK.

   Copyright (c) 2003-2004, Apple Computer, Inc. All rights reserved.
  
   Redistribution and use in source and binary forms, with or without 
   modification, are permitted provided that the following conditions are met:
  
   1.  Redistributions of source code must retain the above copyright notice, 
       this list of conditions and the following disclaimer. 
   2.  Redistributions in binary form must reproduce the above copyright notice, 
       this list of conditions and the following disclaimer in the documentation 
       and/or other materials provided with the distribution. 
   3.  Neither the name of Apple Computer, Inc. ("Apple") nor the names of its 
       contributors may be used to endorse or promote products derived from this 
       software without specific prior written permission. 
  
   THIS SOFTWARE IS PROVIDED BY APPLE AND ITS CONTRIBUTORS "AS IS" AND ANY 
   EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
   WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 
   DISCLAIMED. IN NO EVENT SHALL APPLE OR ITS CONTRIBUTORS BE LIABLE FOR ANY 
   DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
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   (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; 
   LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND 
   ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
   (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS 
   SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes Qt.

      The software uses Qt, licensed under LGPL v3. The Qt Toolkit is Copyright (C) 2020
 The Qt Company Ltd.

      Portions of this software are copyright (C) 2006-2015 The FreeType Project
 (www.freetype.org). All rights reserved.
      
      Copyright (C) 1991-2011, Thomas G. Lane, Guido Vollbeding.
      This software is based in part on the work of the Independent JPEG Group.
      
      Secure Hash Algorithm SHA-3 - brg_endian
      Copyright (c) 1998-2013, Brian Gladman, Worcester, UK. All rights reserved.

      LICENSE TERMS

      The redistribution and use of this software (with or without changes)
      is allowed without the payment of fees or royalties provided that:

       1. source code distributions include the above copyright notice, this
          list of conditions and the following disclaimer;

       2. binary distributions include the above copyright notice, this list
          of conditions and the following disclaimer in their documentation;

       3. the name of the copyright holder is not used to endorse products
          built using this software without specific written permission.

      DISCLAIMER

      This software is provided 'as is' with no explicit or implied warranties
      in respect of its properties, including, but not limited to, correctness
      and/or fitness for purpose.
    
------------------------------------------------------------
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2.  About DeskPack Essentials
The ‘DeskPack Essentials for Illustrator’ bundle offers essential prepress functionality: adding
barcodes, do preflighting, import PDF files, adding white underprint, view your artwork.

It combines the following plug-ins:

• Data Exchange on page 34 (Free)

• boostX on page 97

• Dynamic Barcodes on page 124

• PDF Import on page 214

• Preflight on page 222

• Viewer on page 248

• White Underprint on page 276
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3.  Data Exchange

3.1.  Introduction to Data Exchange

The Esko Data Exchange plug-in for Adobe Illustrator combines several plug-ins into one package for
easier installation. The combined plug-ins are:

• The PDF Export Plug-In on page 34
• The Ink Manager Plug-in on page 43
• The Structural Design Plug-in on page 59
• The Page Box Plug-in on page 79
• The Inspection Setup Plug-In on page 84
• Messages on page 87
• Esko Document Setup on page 89
• Annotations on page 90

3.1.1.  Data Exchange Preferences

The option Update XMP on Document Savedefines if the document’s XMP data is updated when the
document is saved  in the .AI format or as Adobe PDF with preserved Illustrator editing capabilities.

The option can be found in Illustrator > Preferences > Esko and is turned on by default. Deselecting
this option results in slightly faster document saves.

3.2.  The PDF Export Plug-In

3.2.1.  Introduction

The PDF Export plug-in allows you to directly export your Illustrator files to Normalized PDF or to PDF+,
depending on the setting in the Ink Manager: see Normalized PDF or PDF+ on page 43

3.2.2.  Saving a File as Normalized PDF or PDF+

To save your Illustrator file as Normalized PDF or PDF+ using PDF Export:

1. Go to File > Export... > Export As...
2. In the dialog that opens, choose your file’s name and location, and choose the Esko PDF (pdf)

format.
3. Click Export.
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4. In the PDF Export Settings dialog that opens, fill in the export settings (see PDF Export Settings on
page 35).

5. Click OK to export the file.

3.2.3.  PDF Export Settings

When exporting your files to Normalized PDF or PDF+ format, you need to set the PDF Export Settings.
The settings are different when exporting Normalized PDF (left) or PDF+ (right), and depend on the
setting in the Ink Manager. See Normalized PDF or PDF+ on page 43

 

 

Preset
Using Presets you can store and reuse the settings for the PDF Export dialog.

You can save the current settings as a Preset by selecting Save... and entering a name. The location for
the Presets is defined in the PDF Export Preferences. See PDF Export Preferences on page 42

You can load a Preset by selecting it in the dropdown.

If you set the Preset to Default, the parameters as set in the PDF Export Preferences will be used. See
PDF Export Preferences on page 42.

If the current settings are not saved as a setting, the Preset dropdown will show "Custom".
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Images and Linked Files (only for Normalized PDF)
1. In the Images and Linked Files group, choose to either Embed Images in the Normalized PDF, or

Save Links to the images.

• If you choose to embed the images, you don’t have any more preferences to fill in and you can
just click OK.

Note:  This doesn’t save the images’ link information (except for linked ArtiosCAD
graphics, see Linked ArtiosCAD Graphics for Normalized PDF export on page 43).

• If you choose to use linked images, fill in the other preferences of the dialog.
2. Enable Add Preview (max 72 DPI) if you want your Normalized PDF to have a low resolution preview

of the linked images.

This preview allows you to view the linked images when opening your file for example in Acrobat.
3. Choose where to copy the linked images:

• Choose Copy Images Next To Output File to copy them next to the folder in which you will save
the Normalized PDF (so other applications like ArtPro or PackEdge can still open them when the
links are broken).

• Choose Use Links And Apply Server Mapping to keep the images where they are but update the
links (for example if the images are in a shared folder located on a different machine).

4. When choosing Use Links And Apply Server Mapping, fill in a Server Mapping if the share names on
the client machine and on the other server do not match.
a) When checked, Copy Links If Not On File Servers verifies if linked images are already on file

servers and if they are not, copies them along with the exported Normalized PDF file. Choosing
this option also enables the File Servers... button where you add the machines that store linked
images so that Esko workflow servers can find them.

For more information, see OPI and Server Mapping (only for Normalized PDF) on page 36

OPI and Server Mapping (only for Normalized PDF)
When you click the OPI and Server Mapping Settings button, either in the PDF Export Settings or in
the PDF Export Preferences, the OPI and Server Mapping dialog appears:
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Note:

This dialog is available only when you have chosen to Save Links in exported Normalized PDF
files. When you export a Normalized PDF, OPI Mapping is applied first and then Server Mapping.

Servers
The top pane of the dialog configures Server Mappings. You need to use Server Mappings when the
Normalized PDF you output:

• has linked images that are located on a different machine (file server),

• will be used on another machine (not your local machine or the file server).

Server Mappings allow you to map the image links from one share name to another automatically
on output. This ensures that the links are not broken when the Normalized PDF is used on another
machine.

For example:

• the linked images are saved on a file server called “Server”, in a shared folder called “Images”,

• your copy of Illustrator with PDF Export is on a Mac, and the shared folder containing the images
is mounted as “Hi-Res_Images”.

• the Normalized PDF you export will be used on a PC, where the shared folder containing the
images is mounted as “Shared_Images”.
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The link to an image called “My_Image.psd” is “Server/Hi-Res_Images/My_Image.psd” on
the Mac, and should be “\\Server\Shared_Images\My_Image.psd” on the PC.

When adding the Server Mapping in the OPI And Server Mapping dialog, you should enter the Share
Details as follows by:

• name of the file server in Server Name,

• name of the shared folder containing the images as seen from your local Mac in Local Share,

• name of the shared folder containing the images as seen from the other PC in Server Share.
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Note:

• You can use subfolders in a Server Mapping.
 

 

• You can also use Server Mappings to replace images (for example to swap low-resolution
for high-resolution images when the low-resolution and high-resolution images have
identical separations).
 

 

To add the Server Mapping, do the following:

1. In the OPI And Server Mapping dialog, click the plus sign button to the lower left of the Servers
pane. This opens the Share Details dialog.

2. Enter or choose the name of the file server containing your linked images in Server Name.
3. Enter or choose the name of the file server’s share containing your linked images as it appears on

your local machine in Local Share.
4. Enter the name of the file server’s share containing your linked images as it appears on the other

machine that will use your Normalized PDF in Server Share.
 

 
5. If you want to add another Server Mapping (to use your Normalized PDF on yet another machine),

repeat steps 1 to 4.

To edit a Server Mapping, double-click it. To remove a Server Mapping, select it and click the minus
button to the lower left of the Servers pane.

39



3 DeskPack Essentials

OPI Mapping
The lower half of the OPI And Server Mapping dialog configures OPI Mapping, which defines the rules
for image substitution when exporting a Normalized PDF in a more specific way than Server Mapping.
OPI stands for Open Press Interface.

To add an OPI mapping, do the following:

1. Click the plus sign to the lower left of the list pane. This opens the OPI Rule Editor dialog.
 

 
2. After the word If, decide how many conditions that must be true for this mapping rule to take

effect: All, Any, or None.
3. For the condition In the top pane of the dialog, choose the element of the image file’s path to

examine in the first field. Image paths are in URI (Uniform Resource Identifier) format, such as
file://mymac/MacHD/images/lowres/tests/Spacebar_CMYK.eps. As you select elements, further
controls appear on the same line to refine the condition. For example, if you choose Full Path Is, you
can click ... to browse for a folder, or click x to revert to the previous folder. To add a condition, click
+; to remove a condition, click -.

4. Once you have defined the conditions, define the changes to the path in the lower pane of the
window. Use the same process to define the changes as you did to define the conditions: choose
the change, then set its options on the same line. To add a change, click +; to remove a change, click
-.

5. Click OK to finish defining the rule.
6. To add another rule, click +; to remove a rule, click -.

Consider again this example URI file name: file://ImageServer/LOWRES/images/lowres/tests/
Spacebar_CMYK.eps.

• The condition Extension, Is Equal To, EPS will match.

• Folder Name, Starts With, lowres/ will match. You can specify the text ending with / to state that
it must be the entire Folder name and to make sure that directories starting with (for example)
lowres plus/ will not match.

• Server Name, Is Equal To, imageserver will also match as the case is not compared.
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When you use more than one condition in a rule, the Replace 1st Matching Part Of Path and Replace
2nd Part Of Matching Path changes become effective.

Consider this file: file://Serv/SharedImg/LORESIMAGES/ANIMALS/LOWRES/myimage.eps

• with conditions of Folder Name, Contains, LORESIMAGES, and Folder Name, Contains, LOWRES.
• and changes of Replace 1st Matching Part Of Path, HIGHRESIMAGES, and Replace 2nd Part Of

Matching Path, HIGHRES.

The first change will replace LOWRESIMAGES with HIGHRESIMAGES (since it was first), and the
second change will replace LOWRES with HIGHRES.

Notes and Restrictions
To copy the OPI settings between computers so they all are the same, copy AE10-
OPISettings.prefs. In Windows, that file can be at C:\Documents and Settings\username
\AppData\Roaming\Adobe\Adobe Illustrator CSx Settings, but its exact location
depends on the type of login (local or domain) and Illustrator version (CSx where x is a number). On the
Mac, this file is normally in Users/username/Library/Preferences/Adobe illustrator
CSx Settings/. Copy the file to the same location on the target machines.

There are a few restrictions when using OPI Mapping:

• The high-resolution images must be accessible from the client workstation.
• Ink Manager will not show extra inks that are present in the high-resolution images.
• When exporting the file using Shuttle, only the inks from Ink Manager are shown, not any extra ones

present in the high-resolution images.
• PDF Export, PowerTrapper Client and PowerTrapper Standalone will use the high-resolution images

and will know about any extra inks.

Trim Box and Other Settings
In the Trim Box (Borders) group of the PDF Export Preferences dialog, the Trim Box (Borders) drop-
down list lets you choose how the edge of the exported PDF file is chosen: using the Trim Box from
Document, using the Current Artboard, or by using the Artwork Bounding Box.

Fit Media Box to Artwork expands or shrinks the Media Box as appropriate.

Outline All Text converts all text to outlines.

Include Hidden Objects and Layers includes hidden objects when the PDF file is exported.

Include Notes allows to include annotations in the PDF. This option is only available in combination
with the PDF Import plug-in.

Copy Structural Design files to Server (only PDF+)
If the Copy Structural Design files to Server option is enabled, when you export your PDF+ to an
Automation Engine server, the Structural Design files used in your document will be exported next to
your PDF+ file.

Other (only Normalized PDF)
If Expand Patterns is selected, patterns will be replaced by actual objects. The path containing the
pattern fill, will then be filled with the objects as defined in the pattern.

Contourize Bitmaps will convert 1-bit images (linked or embedded) into vectors.

Convert Blended Objects to Images will convert blended objects to images. You can set the resolution
for this images to High (600dpi), Medium (300dpi) or Low (150dpi)
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Note:  In case of converting blended objects with different oveprint setting (one is
overprinting, the other is not), the convertion might change the final result. The following
message is shown: "Rasterized Blend combines art in overprint and not in overprint mode.
Rasterization may have caused changed appearance."

3.2.4.  PDF Export Preferences

You can open the PDF Export Preferences by choosing Illustrator > Preferences > Esko > PDF Export
Preferences
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The main part of the Preferences contain the same settings as the PDF Export Settings: the General
tab contains settings used for Normalized PDF and PDF+, the Normalized PDF tab contains settings
only used when exporting Normalized PDF, and the PDF+ tab contains settings only used when
exporting PDF+.

The settings in the Preferences will be used if the "Default" preset is selected. See PDF Export Settings
on page 35

The PDF Export Preset Settings Folder defines the location where the Presets are saved: either the
Default Preference Folder, or a custom folder you can select by clicking the Browse... button. See also
Preset on page 35

3.2.5.  Linked ArtiosCAD Graphics for Normalized PDF export

When you export a document with linked ArtiosCAD graphics to Normalized PDF, the graphics are
treated slightly differently:

When choosing “Embed Images” in the Preferences:
• The ArtiosCAD graphics are embedded in your Normalized PDF.

• The original link information is saved in your Normalized PDF.

When choosing “Save Links” in the Preferences:
• The ArtiosCAD graphics are embedded in your Normalized PDF.

• They are also copied to the location you define: Next To Output File or on another server (according
to a Server Mapping if defined).

• The link to the copied graphics is saved in your Normalized PDF.

3.3.  The Ink Manager Plug-in

The Ink Manager palette is a powerful pre-press color editing and proofing tool. You can easily identify
where Pantone colors are used within a document or where custom spot colors can be found, then
convert these colors to a custom spot color or to process colors.

The Ink Manager palette also allows you to specify crucial ink parameters such as the ink type, angle
and lineature. Once defined, these parameters are saved inside the Illustrator document.

3.3.1.  Normalized PDF or PDF+

In the Ink Manager, you can switch between working in Normalized PDF or PDF+ mode. This mode
determines what type of PDF file you want to export your document to.

If you open a document that contains Technical Inks or Varnish Inks, the mode will be set to Normalized
PDF.

If you open a document that contains Processing Steps, the mode will be set to PDF+

If you open any other document or create a new one, the mode will be set according to the default
setting in the Ink Manager Preferences. See Ink Manager Preferences on page 50 The mode is saved
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in the Adobe Illustrator file, so that the next time you reopen the document, it will be opened in the
same mode.

You can switch freely between Normalized PDF and PDF+ mode. However, if you switch, specific
functionality might get lost. If you for example switch from PDF+ to Normalized PDF, all Processing
Step information will get lost, and switching back to PDF+ will not bring it back.

What is the difference between PDF+, and Normalized PDF
Both PDF+ and Normalized PDF are to a large extent regular PDF files that you can open and edit
in any other PDF editor or reader. However, PDF+ and Normalized PDF files also contain additional
information, available to any Normalized PDF or PDF+ compatible editor. When choosing Normalized
PDF or PDF+ mode in the Ink Manager, the specific limitations and specifications of the chosen PDF
format need to be considered.

What PDF+ Normalized PDF

Ink order stored in file

Non-printing data (Cut, Die, …)
and special processing steps
(varnish, …)

Processing Step Layers Technical Inks & Varnish

Ink Types Normal, Opaque Normal, Opaque, Technical,
Varnish

Document Profile as output
intent

Obligated. If none is present, the
default profile will automatically
be added when saving.

Screening Optional Screen Sets based
screening

Every object has screening.
Optional object based screening

Group and Barcode metadata

Marks PDF+ Marks can be applied in
ArtPro+

ArtPro+ does not support
SmartMarks

Images Images can be

• Embedded

• Linked & Embedded. If a PDF
+ file contains image links,
a full resolution embedded
version of the image will still
be saved in the file.

Images can be

• Embedded

• Linked

Placed Art (PDF)
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What PDF+ Normalized PDF

Structural Design
 Limited to one Structural

Design file, and always using the
default Profile

3.3.2.  Using the Ink Manager palette

To use the Ink Manager palette, choose Window > Esko > Ink Manager. The Ink Manager palette
appears.
 

 

The Ink Manager lists all inks used in the document. For every ink you see a color patch, its name, and
additional information about the ink. You can define what columns you want to see in the Ink Manager
fly-out menu. See The Ink Manager fly-out menu on page 47

You can double-click an Ink to open the Ink Options. See Ink Options on page 46

Mode
In the bottom left corner, you can see if you are working in PDF+ mode or Normalized PDF mode. See
Normalized PDF or PDF+ on page 43

Properties from Job Setup Status Icon
When connected to an Automation Engine, Ink Properties can be retrieved from the Job Setup. This
icon indicates the status of the connection. See Job Setup on page 49

 Refresh
To update the list of inks used within your document, click the Refresh button. After modifying a
document, click the refresh button to update the list of used inks.

 Show Processing Steps Palette
Only available when working in PDF+ mode. This opens the Processing Steps palette. See Processing
Steps on page 54

 Move to Processing Step
Only available when working in PDF+ mode. This moves the objects using a specific ink into a
Processing Step. See Processing Steps on page 54
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 Select
To identify objects containing specific inks within your document, select the ink you wish to search for
and click the Select button. It is possible to select more than one ink at a time.

 Convert to CMYK
To convert a selected Spot Color from your document Ink list to a Process Color Mix, CMYK, click
Convert to CMYK. More than one ink can be selected at a time.

Note:  Convert to Other and Convert to CMYK are only available if you have a license for
boostX, Channel Mapping or Color Engine Plugin.

 Convert to Other
To convert a selected ink from your document Ink list to another ink, click 'Convert to other'. More than
one ink can be selected at a time.

Note:  Converting an ink will affect only line art. However, if you have the Channel Mapping
or Color Engine plug-in installed and licensed, converting an ink will also result in the
corresponding channel mapping for all images. See the Channel Mapping documentation for
more information.

 Delete Ink Variant
When working in Normalized PDF mode, you can use Screening for Adobe Illustrator to create
exceptions to the screening settings for an ink. These exceptions appear in the Ink Manager list as
"Variants". To delete such an Ink Variant, select the ink variant which needs to be removed and click
the 'Delete Ink Variant' button. The objects will get the ink settings of the parent ink. See Screening in
Normalized PDF mode on page 51

Ink Options
Double-click an Ink from the list to open the Ink Options dialog.

If you have multiple inks selected, you can change the properties of all the inks at the same time. The
dialog will show "≠" for settings that have different values.

The Ink Book dropdown contains all Ink Books that have the current ink defined. By default the last
used ink book is shown.

When working in PDF+ mode, the available Ink Types are Normal and Opaque. When working in
Normalized PDF mode, also Varnish and Technical are available.

• The ink type for process inks cannot be changed. The ink type is always normal.
• The following Pantone inks are always opaque inks: Pantone 8003 C, Pantone 8021 C, Pantone 8062

C, Pantone 8100 C, Pantone 8201 C, Pantone 8281 C, Pantone 8321 C, Pantone 871 C, Pantone 872 C,
Pantone 873 C, Pantone 874 C, Pantone 875 C, Pantone 876 C, Pantone 877 C. The ink type of these
inks cannot be changed.

Note:  If you change an Ink to Technical or Opaque, the ink will be moved to the bottom of the
Ink list. If you change the ink order afterwards, this new order will be respected.

When working in Normalized PDF mode, you can set the screening (Ruling, Angle, Dot Shape, DGC
Curve) for the ink. See Screening in Normalized PDF mode on page 51
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For every ink, you can set the Printing Method.

If you are connected to an Automation Engine server, the dropdown will show the server Printing
Methods. If you are not connected to an Automation Engine server, you will see the default Printing
Methods and the local printing methods, saved locally in the Adobe Illustrator Preferences.

You can select a Printing Method in the dropdown, or you can type in a name to create a new Printing
Method. If Save printing method to presets is enabled, the newly created Printing Method will be
stored as a new preset, either on Automation Engine or in the local Printing Methods.

Note:  All these Ink options are stored in the Illustrator document and are used by other
DeskPack plug-ins like PowerTrapper Client, PowerLayout Client, etc. For example,
PowerTrapper Client will ignore varnish and technical inks and will take the opaqueness of inks
in account when determining trap directions.

The Ink Manager fly-out menu
 

 

• Ink Options... opens the ink options dialog.

• Using PDF+ (Processing Steps Support) or Normalized PDF Compatibility you can switch the mode
for the current document. See Normalized PDF or PDF+ on page 43

• Show Processing Steps and Move to Processing Step: Only when working in PDF+ mode. See
Processing Steps on page 54

• Convert Ink to... has the same functionality as the 'Convert to Other' button 

• Convert Ink to CMYK has the same functionality as the 'Convert to CMYK' button 

• Convert all Spot Inks to CMYK converts all the spot inks in the document to their CMYK equivalent.
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Note:

Keep in mind that this function will also convert white objects created by the White
Underprint plugin, using a special spot ink.

• Update Ink list refreshes the ink list.
• Process Inks In Images…  The plug-in uses Illustrator to determine which inks are used in images.

Illustrator has some limitations:

• With linked EPS images it is not possible to detect whether CMYK was used in the linked image.
Ink Manager will assume that CMYK is present in the linked EPS images, unless the user has
specified otherwise.

• TIFF images with spot channels always have CMYK channels, even if those channels are empty.
• Some effects create embedded images with all four CMYK channels, even if some are empty.

So the plug-in doesn’t really know whether CMYK is used in images. “Process Inks in Images” offers a
manual solution. If you click this option, the “Process Inks in Images” dialog box appears:

 

 

By default all toggles are switched on, which means that the plug-in will assume that external
images contain Cyan, Magenta, Yellow and Black.

If you know that there is no Cyan in the externally placed images or you want to avoid an empty
process plate introduced only by an effect, you can switch Process Cyan off. Click 'Apply' and at the
bottom of the Ink Manager the indication “Disabled in Images: C” will appear.

The plug-in will assume that only Magenta, Yellow and Black were used in the externally placed
images. If Cyan is used in other objects of the document, it will be listed in ink manager.

Note:  Other plugins such as PDF Export and PowerTrapper will also take this setting into
account.

• Using Display Columns you can set what columns of the Ink Manager should be shown:

• the Ink Type
• the Ink Book
• the Screening Details (ruling, Angle and dotshape). Only when working in Normalized PDF mode.

See Screening in Normalized PDF mode on page 51
• the DGC Curve. Only when working in Normalized PDF mode. See DGC Curve on page 52),

48



3DeskPack Essentials

• The Printing Method
• The Job Setup (see Job Setup on page 49)

• Reverse Ink Order will turn the order of the inks upside down.

• By default, the process colors are in Cyan - Magenta - Yellow - Black order. If you change this order
and apply Save CMYK Ink Order as Default, the changed order will be used as default order. By
selecting Restore Default CMYK order, the original default order is restored.

• By using Sort Light To Dark or Sort Dark To Light, you can rearrange the order of inks based on the
luminocity. Note that Opaque and Technical inks are placed at the bottom of the list, but also sorted
light to dark or dark to light.

• When working in Normalized PDF mode, if you have to reuse the same Ink Parameters frequently,
you can use Save Ink Preset ... to save all ink parameters, including Ink Name, Type, Ink Book,
Ruling, Angle, Dotshape, DGC and Printing Method. You can Load Ink Preset... to overwrite all ink
parameters in the current document with the parameters you saved earlier. You can set the location
for the saved Ink Presets in the Preferences. See Ink Manager Preferences on page 50

• By enabling Use Properties from Job Setup, the inks and ink parameters defined in the Job Setup
will be enforced. See Job Setup on page 49

Job Setup
When a document is opened from an Automation Engine Job, for example using File > Job Folder
> Open from Job Folder ..., you can force Ink Manager to use the ink parameters defined in the Job
Setup, overwriting the current Ink Parameters, by enabling Use Properties from Job Setup, either

from the fly-out menu or by clicking the button in the Ink Manager palette 

The Job column will appear automatically. You can change its visibility under Display Columns in the
fly-out menu.

The column will give a status icon for every ink:

•
 : the ink is defined in the Job Setup. The parameters defined in the Job Setup will be used.

•
 : the ink is not in the Job Setup but is used in the document

•
 : the ink is defined in the Job Setup but not used in the document. The line will be greyed out,

and have no number.

If Use Properties from Job Setup is enabled, the Ink Options dialog for inks defined in the Job Setup
will show status icons for every parameter:

•
 : the parameter is taken from the Job Setup, so it can't be modified.

•
 : the parameter is not defined in the Job Setup, so it can be set freely.

If the Job Setup defines multiple variants of the same ink, all variants are listed in the Ink Manager.

Note:  Next to the settings for every ink, you can also choose to retrieve the Ink Order from the
Job Setup, by enabling the option in the Ink Manager Preferences. See Ink Manager Preferences
on page 50
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3.3.3.  Ink Manager Preferences

The Ink Manager Preferences can be opened from Illustrator > Preferences > Esko > Ink Manager
Preferences... (Mac) or Edit > Preferences > Esko > Ink Manager Preferences... (Windows).

 

 

With the Default Document Mode you can define if you want to use Normalized PDF mode or PDF+
mode when opening a document created by Esko plug-ins older than version 20, created without Esko
plugins or importing as Adobe PDF. See Normalized PDF or PDF+ on page 43

In the rest of the Ink Manager Preferences, you can set the Default Values (angle and ruling) for CMYK
inks.

You can also set the default angle and ruling to be used for new Spot inks. However, these defaults can
be overruled when using a Spot ink that was used before, with a different Angle and Ruling value. The
Angle and Ruling for all used spot inks are saved in the Preferences file.

You can also define if inks that are only used in non-printable layers or hidden layers should be shown
in the Ink Manager by setting the Show Inks of Non-printable Layers and Show Inks of Hidden Layers
option.

50



3DeskPack Essentials

Note:

The Remap Ink functionallity also takes the Show Inks of Non-printable Layers and Show Inks
of Hidden Layers option into account: When switched off, inks on non-printable or hidden
layers will not be remapped.

Enable Use ClassicColors Ink Book to use the ClassicColors Ink Book. When using a ClassicColors Ink
Book for your HP device, you can enable the Use ClassicColors Ink Book option, to avoid conflicts for
inks using generic names, such as "White".

The Preferred Ink Book is the Ink book shown by default when opening the Add Ink from Ink Book
dialog. It is also used as the preferred ink book when determining the ink book of spot inks manually
added to the document.

You can set the location to store Ink Manager Preset Settings: either in the default presets folder, or in
a custom folder you choose.

In Job Setup Support you can define if you want to use the Ink Order as defined in the Job Setup. See
Job Setup on page 49

3.3.4.  Screening in Normalized PDF mode

When working in Normalized PDF mode, you can set the screening parameters in the Ink Options.

Note:  The other options are explained in Ink Options on page 46

You can set the Ruling and Angle for the ink.

Dotshape shows a list of all dotshapes available for the FlexRip. However, it is possible to enter any dot
that is available on your rip instead of the proposed dotshapes. Only use a dotshape that is installed on
the rip that will be used to expose the document.

Note:  Entering a dotshape is not compatible with Nexus RIP.

You can define a DGC Curve and a DGC percentage. See DGC Curve on page 52
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The screening settings are applied to all objects in your document.

If you have a Screening for Adobe Illustrator license, you can use the Screening for Adobe Illustrator
plugin to make exceptions to these inks parameters for specific objects. See https://www.esko.com/
en/support/product?id=Screening%20for%20Adobe%20Illustrator

DGC Curve
You can set the Dot Gain Compensation (DGC) Curve for every ink.

By default, the DGC Curve column is hidden. By selecting Show DGC Curve in the fly-out menu you can
make it visible.

You can select one of the predefined Dot Gain Curves, or type in the name to use a custom DGC. When
selecting a PressSync curve, you can enter the percentage for the curve in the DGC % field.

Note:  DGC is not a part of the Job Setup. This means using Use Properties from Job Setup
will not change the DGC, nor does changing the DGC influences the status of the job.

3.3.5.  Screening in PDF+ mode

In PDF+ mode, screening is defined using Screen Sets in the Ink Manager. See Manage Screen Sets on
page 53

Note:  You need a Screening for Adobe Illustrator license to assign a Screen Set to an object.
Without the license, you can view the defined Screen Sets and you can change their screening
parameters, but you can't add new Screen Sets, delete Screen Sets or assign a Screen Sets to
objects. You can also Reset to Default Screening or Remove Screening withot a license. See
The Screen Sets Fly-out menu on page 53

Your document can contain a number of Screen Sets, each containing specific ruling, angle, dot shape
and DGC information for each of the defined separations. By assigning a Screen Set to an object, you
can set up object based screening.

Choose Window > Esko > Screen Sets or use its shortcut Cmd+Option+Shift+N (Mac) or Ctrl+Alt
+Shift+N to open the Screen Sets palette.

The Screen Sets palette shows all Screen Sets defined in the document.

The Screen Sets used in the current selection will be highlighted.
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• Click the Screen Set you want to assign to the current selection.
• Click the Select Art Using Screen Set button  to select all objects using that specific Screen

Set.
• Click the Manage Screen Sets button  or choose Manage Screen Sets from the fly-out menu

to create, remove or edit your Screen Sets. See Manage Screen Sets on page 53

Manage Screen Sets
In the Manage Screen Sets dialog you can add, remove and edit Screen Sets.

• In the list on the left, select a Screen Set to see and edit its settings.

• You can set the Ruling and Angle for each ink.
• Dotshape shows a list of all dotshapes available for the FlexRip. However, it is possible to enter

any dot that is available on your rip instead of the proposed dotshapes. Only use a dotshape that
is installed on the rip that will be used to expose the document.

• You can define a DGC Curve and a DGC percentage. See DGC Curve on page 52
• Click + to create a new Screen Set.

The newly created Screen Set is created using the same settings as the currently selected Screen
Set. If no Screen Set is available, a Screen Set with default screening information is created.

• Click - to remove the selected Screen Set.
• Double-click a Screen Set to rename it.
• Click in front of a Screen Set Name to make it the Default Screen Set, indicated by a star.

The Default Screen Set is applied to newly created objects. It is also used in some other specific
situations, e.g. if you remove a Screen Set, or for Mask objects when releasing an Opacity Mask.

• Click Save Preset to save all Screen Sets in a Screen Preset, e.g. to reuse in another document.
• Click Load Preset to load all Screen Sets saved in a Screen Preset. The Screen Sets from the Preset

will be merged with the current Screen Sets. If a Screen Set with the exact same settings already
exists, that Screen Set will not be added.

The Screen Sets Fly-out menu

The Fly-out menu of the Screen Sets palette contains the following functions:

Reset to Default Screening
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This removes all Screen Sets, and adds a new one called "Screen Set 1". The screening information for
this Screen Set is taken from the settings defined in the Ink Manager preferences. See Ink Manager
Preferences on page 50

Remove Screening
This removes all Screen Sets applied to objects in the current document. The Screen Sets palette will
only contain the "None" Screen Set.

Note:  Both functions are available without the Screening plugin installed, and without a
license.

3.3.6.  Processing Steps

Ever since PDF became the preferred file format in the graphic industry, PDF files were used not only
to store the artwork to be printed, but also as a container for information related to the production
process: cutting lines, dimensions, etc.

How the information was stored in the PDF file, depends on the application that was used to generate
the PDF, and the preferences of the user. For example the die cut lines can be in a separation called
"Die", or in a layer named "Cut". Obviously, this leads to a multiple of ad hoc methods, which leads to
interoperability problems, and a complex and error-prone situation.

ISO 19593 defines a new mechanism to store objects and metadata corresponding to such processing
steps in a PDF file in a standardized way.

Based on this ISO norm, the use of Processing Steps was introduced in DeskPack as Processing Steps.

Keep in mind however that these Processing Step Layers are only available when working in PDF+
mode. Normalized PDF mode uses Technical Inks instead. See Normalized PDF or PDF+ on page 43

Objects in Processing Step Layers
Processing Step Layers contain objects in your PDF file (a path, a text object, ...) that are associated
with a specific Processing Step.

The type of Processing Step Layer can influence the properties of the PDF objects. For example, a PDF
object in a Structural Processing Step Layer has to be colored in a spot color (to visualize in viewing
and proofing applications). Because the objects in these Processing Step Layers should not have any
influence on the final printed version (and on the plate making), this spot color should not be used for
"normal" PDF objects, nor should the objects knock out other objects, or participate in transparency
blending with other "normal" artwork objects.

Types of Processing Step Layers
• Structural Data: a collection of contours that describe how the printed product will be finished to

produce a 3D end product from a flat substrate, such as cutting lines, crease lines, etc.
• Braille: braille characters that are applied after printing, e.g. by a die cutter or inkjet device.
• Legend: job related data outside the boundaries of the actual printed products.
• Dimensions: indications of the physical sizes
• Positions: objects that indicate intended, allowed or forbidden positions for certain types of

elements, e.g. allowed positions for content on a flap of a carton.
• White: white ink to be printed on a transparent or metallic substrate.
• Varnish: indicating the application of varnish after printing.
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The Processing Steps palette

You can open the Processing Steps palette by clicking the Show Processing Steps button  or
select Show Processing Steps in the fly-out menu of the Ink Manager palette.

All the Processing Steps appear in the list, grouped per type, along with an "Artwork" entry. You can use
the eye icon to make a processing step visible or invisible.

You can change any layer into a Processing Step Layer, or change the type of a Processing Step Layer
by clicking the Edit Processing Steps button, by selecting Edit Processing Steps... in the fly-out menu,
or by double-clicking an entry in the list.
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You can change any layer into a Processing Step Layer, or change the type of a Processing Step Layer
by selecting a Processing Step type from the dropdown.

You can change a Processing Step Layer into a normal layer by selecting None.

Unlike normal Artwork layers, Processing Step Layers come with a set of restrictions. If one of these
restrictions is not met, a warning is shown in the Processing Steps palette.

You can select the paths causing the warnings in the list. If the Select option is enabled, clicking on
one of the entries will select the corresponding object in the job. If the Zoom option is enabled, clicking
an entry displays the selected object as big as possible in the active window. If the Highlight option is
enabled, the selected objects will be highlighted.

Note:  The list of ISO Standard Violations is not updated automatically. Use the refresh button
to update the list.

You can prevent a number of these issues by using the Move to Processing Step function to create
Processing Step Layers. See Move to Processing Step on page 57

Colorants for Processings
Inks that are only used in Processing Steps are considered "Colorants": they can be used to color
objects in the Processing Step Layers, but are not considered printing inks, as they should not appear
on plates or on the final printed result.

Colorants for Processing Step Layers are represented in the Ink Manager using a round color patch.
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Note:  If an ink is used in at least one "normal" artwork object in an artwork layer, the separation
is shown as a normal printing separation, with a square color patch. Since the use of a
separation both as ink and as colorant usually presents a conflict, it is very likely that a
message will appear in the Messages Side Drawer for any Processing Step Layer using such a
colorant.

Move to Processing Step
Using the Move to Processing Step function, you can move the objects using a specific ink into a
Processing Step.

1. Select a spot color ink in the Ink Manager.
2. Select Move to Processing Step from the fly-out menu or click the Move to Processing Step button

.
3. Select the Processing Step Layer you want to use.
4. All objects using the selected ink will be moved to the selected Processing Step Layer.

• Objects in a flat color, only using the selected separation, will be placed in a Processing Step
Layer, with the same name as the original artwork layer they were in (when available).

• Other objects (e.g. objects in a mixed color, images, ...) will not be moved nor changed.
• If the Ink is only used in the Processing Step Layers, it will become a Colorant. See Colorants for

Processings on page 56

Plate ID Objects
If you are using DeskPack and/or ArtPro+ in combination with Esko's Imaging Engine within the
flexographic printing industry, you can use Plate ID objects to identify Flexo Plates, e.g. for reprint after
being archived, or to be reused in a similar jobs.

Plate ID objects will be exposed by the RIP at "half height". This means the objects are permanently
visible, yet they do not show up on the printed result.

For more information we refer to the chapter on Working with Plate ID in the Automation Engine
documentation here

1. Select the objects you want to create a Plate ID object of.

Note:  Foreign art, mesh, raster, linked image, repeat art and clipping paths are not
supported. Unsupported objects in the selection will be excluded.

2.
In the Processing Steps palette, click the Convert to Plate ID Object button 

• If they don't exist yet, a Plate ID Layer and Plate ID ink are created.

• All (supported) objects in the selection are converted into one Plate ID Object. Marks in the
selection will be expanded and thus no longer be dynamic.

• If the original object has no fill ('none'), the Plate ID Object will also have no fill. In all other cases,
the object is colored in 100% of the Plate ID Processing Step colorant. Gradients and patterns
are changed to 100% flat paint.

• The Plate ID Object is set to overprint, and transparency settings are set to "Normal" at 100%
opacity.
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• The Plate ID Object is moved to the Plate ID layer.
3. Using the Plate ID palette you can define on what plates the Plate ID Object has to be exposed.

 

 
a) Select the Plate ID object you want to edit, and click the Edit Plate ID Object Properties button

b) By default all artwork separations will be enabled, while Processing Step colorants and unused
separations are disabled. You can however manually add or remove separations.

c) Click OK

3.3.7.  Known limitations

Re-mapping process inks to spot inks.
As it is impossible to simply change one of the process inks to the spot ink, the only solution is adding a
new fill to the object with the new spot ink and use overprint to mix these fills together. 

• Adding a brand new fill is not possible on text objects on the character level. Text objects using
various inks on separate characters aren't mapped and an operator is warned.

• Re-mapping of process to spot inks on paths, using Effects on fill or stroke, will raise a warning,
because adding a new fill could change the visual appearance.

Re-mapping inks in gradients
Re-mapping of the process ink to the spot ink generates a new fill due to the same reason as before.

• Let's have an example that the gradient already contains the target spot ink on one of its stops and
another stop contains the process color being transformed. The re-mapping one of the process
inks will add a new fill with the same gradient but with the target spot inks on the place of the
process ink. In other cases the overprint will blend these two fills and produce expected visual
appearance. In this particular case Illustrator will not blend these fills because both contain the
same spot ink and Illustrator then ignores the overprint. An operator is informed about that.

• Similar issue comes when the object already contains two gradient fills. An operator is again
warned.
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3.4.  The Structural Design Plug-in

3.4.1.  Introduction

Introducing Structural Design
Structural Design enables the Adobe Illustrator users to read in an ArtiosCAD ARD or ACD file, an
Esko flexible .bag file and/or a Collada .dae or .zae file. This structural design can then be aligned to
the graphics and this alignment will be maintained in the rest of the Esko workflow (e.g. ArtiosCAD,
Visualizer, PackEdge, ArtPro, Plato, RIPs). On top of that, you can create a varnish plate from the bleed
outline, from the Illustrator artboard or from the bounding box of the structure automatically excluding
the coating free areas.

Structural Design Export allows an Adobe Illustrator user to export contours from Illustrator to native
ArtiosCAD .ard format. It also allows adding and modifying cutout windows to a loaded ArtiosCAD file.

Structural Design files in Normalized PDF or PDF+
When exporting your document to PDF+, a live link is maintained to each of the placed printable parts.

However, if you export to Normalized PDF, only the printable part that is listed first in the layers palette
will be kept live, other placed printable parts will be expanded. If you want to keep a live link to your
printable parts while exporting to Normalized PDF, you should break up your multi-part design in
different documents, so that each document contains one printable part, and the graphics for that
printable part.

For more information on Normalized PDF and PDF+, see Normalized PDF or PDF+ on page 43

Note:

ArtiosCAD ACD files can't be handled by PackEdge, ArtPro, Plato and Esko RIPs, and can't be
preserved in PDF+ or Normalized PDF export.

You can export the ACD file to separate ARD files by choosing File > Structural Design > Export
and selecting the name of the ACD file. If you choose the option "ARD Files (One per part), each
placed printable part of the ACD file will be replaced by a newly created ARD file. See Structural
Design Export on page 69

3.4.2.  Importing Structural Design files

General Principles
The Structural Design plug-in enables you to open or place Structural Design files inside Adobe
Illustrator. The imported Structural Design files are linked to the Adobe Illustrator (.ai) files, but they are
not embedded.
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Structural Design Files and Printable parts
A Structural Design file describes a 3D scene, of which at least one part can be printed: the Printable
Part. Different types of Structural Design files can be used:

• an ARD Structural Design file, created in ArtiosCAD or Studio Toolkit for Boxes, mainly used for
boxes. For an ARD file, the entire box is one single printable part.

• an ACD Canvas file, created in ArtiosCAD, contains one or more printable parts.

Note:  Copies of the 3D Shape in ArtiosCAD will share the same printable part. In order to
apply different graphics on multiple shapes coming from the same ARD file, you should
import this ARD file multiple times into the canvas file. That way, each shape will have its
own printable part.

• .bag files created in older versions of Studio Toolkit for Flexibles. These .bag files are also one
printable part.

• Collada files, containing one or more 3D shapes with at least one printable part (.dae or .zae files).
For Collada files, a printable part is an Esko extension. A collada file can contain one or more
printable parts, such as a flexible bag, one or more labels on a bottle, a shrink sleeve, …. A Collada
file can also contain non-printable parts, such as the glass bottle itself. Collada files with one or
more printable parts can be created in ArtiosCAD or Studio Toolkit.

Note:  More technical information on Printable Parts in Collada files can be found in the white
paper you can find in the Studio documentation: https://www.esko.com/en/support/product?
id=Studio

With the Structural Design Import plug-in, you can place printable part(s) of a Structural Design file in
an Illustrator document.

Structural Design Layer
After opening or placing a structural design file, the file appears in the Adobe Illustrator layer palette.
The Structural Design paths are special paths that cannot be modified accidentally. By default the
Structural Design layer and its sublayers will be locked. You can unlock the Structural Design layers.
This enables you to select individual Structural Design paths and use the illustrator alignment tools to
align graphics to the Structural Design paths.

Open or Place an ARD, ACD, BAG, DAE, ZAE file
A dedicated Place File showing only Structural Design files is found in the File menu. Choose File >
Structural Design > Place File....

In case a Collada file is placed, a check is performed to see if the Collada file has a printable part
defined. See General Principles on page 59

If a Collada file or ACD file contains multiple printable parts, a dialog will ask you to choose one or to
place all. Choose the part(s) of which you want to create the graphics in Adobe Illustrator.
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After opening a Structural Design file, the Structural Design objects are converted to special Illustrator
objects.

The Structural Design layers are converted to locked Illustrator sublayers so they can't be changed
accidentally. You can unlock these layers. They are grouped under a layer that gets the name of the
Structural Design file.

 

 

The different Structural Design line styles (cuts, creases, bleed) are translated to hard-coded custom
colors. All ArtiosCAD line styles are supported.
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Opening an Illustrator file with a placed Structural Design file
When an Illustrator file is opened that contains Structural Design data, two checks are performed.

1. First of all, the plug-in checks whether the Structural Design file still can be found in its original
place. If that is not the case, the plug-in will look for the Structural Design file in the same directory
where the Illustrator file is. If it finds the Structural Design file there, it will use this Structural
Design file instead, otherwise, you will be asked to browse to the new location of the file.

2. A second check is performed to see if the Structural Design file has been modified since it was
originally embedded in this Illustrator file. If so, the Illustrator document will be updated.

See also Update the Structural Design File on page 64

Adding or replacing a Structural Design File
If a Structural Design file is already loaded and you place a new Structural Design file, the new
Structural Design file will be placed next to the already loaded Structural Design file.

If you want to replace an already placed Structural Design file, choose File > Structural Design >
Replace. See Replace the Structural Design File on page 65

Placing or opening
The difference between placing and opening a Structural Design file is that when opening a Structural
Design file, the artboard will adopt the size of the bounding box of the structure. When placing a
Structural Design file, the artboard will not be changed.

Large Canvas mode
In Adobe Illustrator versions before 24.2 (released june 2020), the maximum size of an Adobe Illustrator
document was 5,779 by 5,779 meter or 227,52 by 227,52 inch ("standard size").

In Adobe Illustrator 24.2 and later, when creating an Adobe Illustrator document, you can use larger
sizes. In that case, the document is in "Large Canvas Mode". The maximum size of an Adobe Illustrator
document in Large Canvas mode is 10 times larger: 57,79 by 57,79 meter or 2270 by 2270 inch.
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When opening a Structural Design file, the Adobe Illustrator document is created in regular mode. If
the printable part you place doesn't fit the "standard size" canvas, you can choose to create a document
in "Large Canvas Mode", and place the structural design file in the newly created large-sized Adobe
Illustrator document.

Warning:  When you save or export the artwork created on a large-sized canvas to a legacy
Illustrator document (lower than Illustrator 2020), the artwork will appear ten times smaller.
In this case, the Structural Design Import plug-in will expand all structural design artwork.
This means that the artwork will no longer be tagged as Structural Design objects, and will
become regular Illustrator art. The structural design data will no longer be live in such a legacy
document.

Open or Place from Shapes
The Shapes Store is a constantly growing online collection of quality 3D models in Collada file format.
If you have a subscription or maintenance contract for Studio or ArtiosCAD, you can download all
available models. The section "free samples" are free for anyone with an Esko ID.

You can open files from Shapes directly or place them into existing Illustrator files by using the
commands in File > Structural Design.

Opening and placing a file from Shapes follows the same general workflow. This example will show you
how to place a Shapes file.

1. In an open Illustrator document, click File > Structural Design > Place from Shapes....

In order to access the Shapes store, you need to enter your Esko ID when opening the Shapes
window for the first time. You can also enter it or change to a different Esko ID in the Shapes
Preferences dialog in Preferences > Esko > Shapes Preferences.

 

 

There is a Shapes Store section where you can browse all the models on the cloud, and a Library
section, where you see all the assets that you have downloaded so far. When opening the Shapes
window, the last used section will be active.

2. If you want to use a new Shape, choose it and download it. It gets downloaded to your local
machine’s Shapes Library.

63



3 DeskPack Essentials

3. If you downloaded a new Shape, the Shapes window should switch to the Shapes Library
automatically. To use an existing Shape, click Library in the Shapes window. Select the desired
Shape and click Place.
 

 
4. The Shape is either placed in the open Illustrator document or opened as a new document. Only the

printable area of the Shape is visible in Illustrator. If you have one of the Studio products, use the
Studio palette to view the Shape with the printable area.

Shown below is a bottle from Shapes with the label designed in Illustrator and with the 3D model shown
in the Studio palette.
 

 

Update the Structural Design File
If any of the Structural Design files has been modified while still editing the Illustrator file, an update
of the Structural Design files can be forced. All Structural Design files placed in the current Illustrator
document will be updated. Choose File > Structural Design > Update All
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Replace the Structural Design File
If you want to replace the placed printable parts of a Structural Design file while preserving the
alignment between the technical drawing and the artwork, you can replace a Structural Design file.

Choose File > Structural Design > Replace and select the name of the file you want to replace

Align Structure and Graphics

Interactive Move Structural Design tool

 

 

The Move Structural Design tool has been added underneath the Illustrator select tool. Select this tool
to move the Structural Design interactively without unlocking the Structural Design layers. Hold down
the mouse button and drag to move the Structural Design.

Tip:

If you choose View > Smart Guides, the Structural Design will snap to the graphics.

Structural Design window
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The Structural Design palette provides information on the bleed and structure contours of the selected
printable part. It allows you to rotate or numerically move the contours.

Open the palette by choosing Window > Esko > Structural Design > Show Structural Design Window.

If your document contains multiple printable parts, you can use the dropdown to select the printable
part for which you want to see or change the information.

If your selected printable part contains a bleed contour, you can use the dropdown to choose whether
you want to see the position of the bleed or of the structure bounding box.

The upper part gives you the coordinates of the (left, top) point of the bounding box around the
structure (cut and crease) or bleed contours. The coordinates are relative to the origin of the Illustrator
file. You can choose to see the coordinates of nine points on the bounding box. You can also choose to
see the position of the bounding box around the bleed contour.

By entering a new value in the X and Y entry fields, you move the selected point to the new position.

It is possible to flip the Structural Design so that you can add graphics to the back of the Structural
Design. This feature is enabled for ArtiosCAD files and for Collada files with a placed printable part that
can have graphics applied to the back side.

The lower part of the palette shows the width and height of the Structure and Bleed bounding boxes.
Bleed Offset indicates the offset between the structure and the bleed contour.

The bottom part provides information whether or not fold angles and animation were defined in the
structural design.

Click one of the Rotation icons to rotate the Structural Design contours. Rotation always happens
around the center of the structure contour.
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Create Varnish Plate
Choose Window > Esko > Structural Design > Create Varnish Plate....

 

 

• If you choose Use Bleed Outline then the contour will be created from the bleed outline
minus the coating free areas (if any).

• If you choose Use Artboard, then the contour will be created from the Artboard minus the
coating free areas.

• If you choose Use Bounding Box of Structure, then the contour will be created from the
Bounding Box of the structure minus the coating free areas.

Note:  When using Use Bleed Outline or Use Bounding Box of Structure, a varnish
plate will be created for every printable part in the current Illustrator document.

When choosing Use Artboard or Use Bounding Box of Structure, you can specify a positive
or negative offset. The resulting varnish plate will be enlarged or shrunk with the specified
offset in relation to the artboard or the bounding box.

This tool outputs a contour filled with a light-yellow spot color. This contour will be put in
a new layer named ‘Varnish’. This layer will be inserted directly under the Structural Design
layers.

Note:

Create Varnish Plate will automatically exclude the coating free zones in the
Structural Design file, if any.
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Expand Structural Design Layer
Choose Window > Esko > Structural Design > Expand Structural Design Layer....

 

 

Select the Structural Design layer that you want to expand into a new Illustrator layer. If there
are multiple printable parts with a Structural Design layer with the same name, they will all be
expanded.

All art on the Structural Design layer will be copied to the new Illustrator layer. The art on the
new layer is no longer tagged as Structural Design objects.

In Normalized PDF mode, the resulting objects are in the technical Structural Design inks. In
PDF+ mode they will share the same processing step types of the corresponding layers in the
Structural Design. See also Normalized PDF or PDF+ on page 43 and Processing Steps on
page 54.

One common use where you would use this tool is when you are interested in creating a
clipping path from the bleed outline of the Structural Design file.

Structural Design Preferences
You can open the Structural Design Preferences by choosing Illustrator > Preferences > Esko
> Structural Design Preferences… on MAC or File > Preferences > Esko > Structural Design
Preferences… on PC.
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ArtiosCAD files can contain Dynamic Art placeholders. Using these placeholders, a structural designer
can for example tell the graphics designer where the barcode should be placed on the design. If
the option Import Dynamic Art as Placeholders is enabled, and you have the Dynamic Art plugin
installed, a live Dynamic Art placeholder object will be created for every ArtiosCAD Dynamic Art. These
placeholders can then be filled automatically with their content. For more information, we refer to
the Dynamic Content documentation. See https://www.esko.com/en/support/product?id=Dynamic
%20Content%20Advanced

3.4.3.  Exporting Structural Design files

Structural Design Export
The Structural Design Export saves a copy of the selected Structural Design file to a new location,
The Illustrator file will link to the newly saved Structural Design file. Choose File > Structural Design >
Export and select the Structural Design you want to export.

If you are exporting an Artios Canvas file (.acd) containing multiple printable parts, you can choose to
export the ACD file as a single ACD file, or as multiple individual ARD files, one for each part.

Export Selected Objects to ArtiosCAD File
ArtiosCAD Export adds the item Export Selected Objects to ArtiosCAD File to the Structural Design
menu. Only ARD files can be included when exporting to a new ArtiosCAD file.

Select the contours to export to the ARD file and choose File > Structural Design > Export Selected
Objects to ArtiosCAD File.

The Export Selected Objects to ArtiosCAD File dialog opens.
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Save selected objects in
You can choose to save the selected objects in the Main Design Layer or in Annotation Layers. If you
save them in Annotation Layers, an ARD file will be created with annotation layers with the same name
as the illustrator layers.

Next to this, you can choose Layers based on ArtiosCAD Line Type swatches. If the selected objects
are stroked with a swatch color with an ArtiosCAD line type name (e.g. cut, crease, bleed), then this
option will create layers depending on the stroke color name:

• Cut and crease lines will go to a Main Layer
• Outside Bleed lines will go to an Outside Bleed Layer
• Outside Coating lines will go to an Outside Coating Layer
• Dimensions and text will go to a Dimension Layer
• All other linetypes will go to an Annotation Layer

For convenience, a swatch library ArtiosCAD Line Types is included with the plug-in. You can display
the swatch library by selecting Window > Swatch Libraries > ArtiosCAD Line Types. In this swatch
library, all ArtiosCAD design line types have been predefined.

Include a copy of ****.ARD
You can choose to include a copy of the ARD file that was loaded in the Illustrator document that is
closest to the selected objects. The resulting ARD file will contain the selected objects AND what is in
the CAD layers in Illustrator.

Remove lines
It is possible to remove some lines of the original ArtiosCAD file. This is meant to modify cutout
windows. Do not attempt to remove fold lines with this tool. If you do this, the original fold angles will be
lost.

Place this ArtiosCAD file in the document
If you switch this option on, the resulting ARD file will be placed in the Illustrator document. It will
replace the Structural Design file that was loaded originally.
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Preview
In the preview window, you see a preview of what will be saved. You can highlight the selected contours
by toggling on Highlight Selection. You then see the distinction between the contours that are newly
added to the resulting ARD file and those contours that come from the original ARD file.

If you click Export, you can set the name and location for the file to be saved.

If you have an ArtiosCAD file loaded in your Illustrator document, the software suggests as file name
the name of the loaded ArtiosCAD file followed by _copy.

We recommend you not to overwrite the original ARD file as some functionality of the ARD file will be
lost: graphics layers are not copied and it will not be possible to rebuild the created ARD file and text
will be contourized.

Note:

Placed EPS objects and/or pixel-based objects cannot be copied to an ARD file. The fill color of
the selected contours is not maintained in ArtiosCAD. Rather, the stroke color of the contour
determines the line type in ArtiosCAD. If the selected contour is in the Main Design layer, the
pointage of the contour will be 2. In all other cases, the pointage will be 0.

ArtiosCAD - Copy to Clipboard

Note:

This function is only available on PC.

It can be found on the Edit menu:

ArtiosCAD - Copy to Clipboard copies the selected contours to the Windows Clipboard. They can
directly be pasted into ArtiosCAD. If you have the same ArtiosCAD workspace open in ArtiosCAD
and have not modified it since opening it in Illustrator, when you paste the contents of the clipboard
into ArtiosCAD, they use the same placement as was used in Illustrator. This function is useful for
ArtiosCAD users who need shapes from the graphics to be added to the box design.

Copy to Clipboard also offers you the possibility to add the ARD file that is currently loaded in the
Illustrator document that is closest to the selected objects. Keep in mind that graphics layers are not
copied. The resulting ARD file is also not rebuildable and text will be contourized.
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Note:

Placed EPS objects and/or pixel-based objects cannot be copied to an ARD file. The fill color
of the selected contours is not maintained in ArtiosCAD. The stroke color of the contour
determines the line type in ArtiosCAD. If the selected contour is in the Main Design layer, the
pointage of the contour will be 2. In all other cases, the pointage will be 0.

Relationship between stroke color in Illustrator and line type in ArtiosCAD
If the contours are stroked with a swatch color with an ArtiosCAD line type name (e.g. cut, crease),
then the corresponding items in ArtiosCAD will have the corresponding line type. For example, if you
give your contour a stroke color with as name 'Annotation', the contour will be in line type 'Annotation'
in ArtiosCAD. If the name is not an ArtiosCAD line type name, the contour will be a cut line. For
convenience, a swatch library ArtiosCAD Line Types is included with the plug-in. You can display the
swatch library by selecting Window > Swatch Libraries > ArtiosCAD Line Types. In this swatch library,
all ArtiosCAD design line types have been predefined.

How to add a cutout window to an existing ArtiosCAD file?
1. Open or place an ARD file.

If you also have Studio Designer, you will see a 3D view of your folded box in the Studio window.

 

 
2. Create and select the cutout shape that you want to add to the ArtiosCAD file.
3. Choose File > Structural Design > Export Selected Objects to ArtiosCAD File.

The Export Selected Objects to ArtiosCAD File appears.
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4. Do one or more of the following:

• Save the selected objects in the Main Design Layer.
• Include a copy of the original ARD file.
• Place this ArtiosCAD file in the document.

For more information on the different options, please refer to Export Selected Objects to ArtiosCAD
File on page 69.

5. Click Export.

The selected objects are saved in the Main Design Layer. They get the cut line type (which is
the default if you did not specify a swatch with as name an ArtiosCAD line type). Apart from the
selected objects, the original ARD file is copied in the resulting ARD file and the resulting ARD file is
immediately placed in the Illustrator document. If you have Studio Designer, you will automatically
see the ARD file with the cutout folded in 3D:
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How to modify a cutout window in an ArtiosCAD file?
1. Open or Place an ARD file that already contains a cut-out window.
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If you also have Studio Designer, you will see a 3D view of your folded box in the Studio window.
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2. Create and select the new cutout shape that you want to add to the ARD file.

 

 
3. Choose File > Structural Design > Export Selected Objects to ArtiosCAD File.

The Export Selected Objects to ArtiosCAD File appears.
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In the preview window you notice that you do not get the desired result. We need to remove the
original cutout window.

4. Click Remove Lines.

The Remove Lines dialog appears.

 

 
5. In this dialog, you can select the lines you would like to remove. It will not be possible to select the

new lines. You can choose to hide the new lines by enabling Hide New Lines.
6. Click and drag a rectangle around the original cutout window.

This window will be grayed out. This means that it will be removed in the final ARD file.
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7. Click OK.

This bring you back to the Export Selected Objects to ArtiosCAD File dialog. In the preview window
you notice that the original cutout has been removed.

 

 
8. Click Save As.
9. Specify a file name in the Save As dialog.

The software suggests the name of the loaded ArtiosCAD file followed by _copy.
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10. Click Save.

If you have Studio Designer, you will automatically see the ARD file with the new cutout folded in 3D.

 

 

3.5.  The Page Box Plug-in

3.5.1.  Introduction

Page Boxes are used to define the outside borders and margins of your document, and it is used in the
Esko Software Suite workflow environment.

Page Box definitions are saved as part of the Illustrator file used by the plug-ins Shuttle and
PowerLayout Client.

Page Boxes are not taken into account when printing directly from Adobe Illustrator, nor are they
exported when exporting to a non-native format via standard Adobe plug-ins. They do not appear as
objects in the Layers palette.

You can find the Page Box plug-in in Window > Esko > Trim Box and Media Box

The Page Box plugin can work in two modes:

• Trim Box and Media Box (defining only those two page boxes). See Trim Box and Media Box on page
80

• All Page Boxes. See All Page Boxes on page 83

You can switch mode by selecting Switch to [mode] from the fly-out menu.
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3.5.2.  Trim Box and Media Box

 

 

1. Trim Box Size: Select the size from the dropdown list.
2. Trim Box Width/Length: Enter the Width/Length if you want a custom size.

Tip:

The units are defined in the Illustrator preferences.

3. Trim Box Orientation: Select the orientation: portrait/landscape.

Note:

When the Trim Box is being dragged or Width or Height editboxes edited, the radio buttons
Portrait/Landscape flip automatically so that Landscape is active whenever Width > Height
and Portrait whenever Width < Height.

4. Fit Trim Box to

•
 Fit Trim Box to Artboard

•
 Fit Trim Box to Artwork

•
 Fit Trim Box to Selection

•
 Fit Trim Box to CAD

5. Media Box (Margins) enter the top, bottom, left and right values.
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Tip:

The units are defined in the Illustrator preferences.

6. Fit Media Box to

•
 Fit Media Box to Artboard

•
 Fit Media Box to Artwork

•
 Fit Media Box to Selection

•
 Fit Media Box to Bleed / CAD (when no bleed was defined the cad will be taken as reference)

7. Fit Artboard to

• Fit Artboard to Trim Box
• Fit Artboard to Media Box

8. Show Trim Box and Media Box: To display or hide the trim Box and Media Box, use this toggle.
9. See more page boxes: In case page boxes other than Trim and Media box are defined, this link will

open the All Page Boxes version of the palette. See All Page Boxes on page 83
10. Trim Box and Media Box dropdown menu

• Switch to All Page Boxes. see All Page Boxes on page 83

• Fit Trim Box to Artboard

• Fit Trim Box to Artwork
• Fit Trim Box to Selection
• Fit Trim Box to CAD
• Fit Trim Box to Crop Area
• Fit Media Box to ArtBoard
• Fit Media Box to Artwork
• Fit Media Box to Selection
• Fit Media Box to Bleed / CAD (when no bleed was defined the CAD will be taken as reference)
• Fit Media Box to AI Bleed Box
• Fit Artboard to Trim Box
• Fit Artboard to Media Box
• Use Transform bounds: if this option is enabled, TrimBox/MediaBox will respect as they are

defined in Adobe Illustrator. If disabled, TrimBox/MediaBox will respect visible bounds.
• Move Trim Box and Media Box ... open the 'Move Trim Box and Media Box' interface
• Delete Trim Box and Media Box

The figure below illustrates the Trim Box (borders) and Media Box (margins) of an output document as
interpreted on an Esko system. The full black line represents the borders (corresponding to one of the
above options) while the dotted black line indicates the margins of the document:
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Moving and Scaling Trim Box and Media Box
To move or change the size of the Trim and Media Boxes, you can either

• Select the Trim and Media Box Tool from the AI tool palette.

Use the Trim and Media Box to click and drag the Trim and Media Box.

• Select the Trim and Media Box Tool from the AI tool palette.

• ALT +drag = scale from the center out

• SHIFT + drag = constrained scaling

• ALT + SHIFT + drag = constrained scaling from the center out

 

82



3DeskPack Essentials

 

OR
• Select a preset from the drop down menu. OR
• Use the numeric input field. The numeric input field appears when you select Move Trim Box and

Media Box in the dropdown menu.
 

 

Tip:

Double-clicking Trim and Media Box tool in toolpalette opens the 'Move Trim Box and Media
Box' dialog.

OR
• You could use one of the “fit to” options (to Artboard, artwork, selection, cad or crop area).

Tip:

The units are defined in the Illustrator preferences.

3.5.3.  All Page Boxes

Using the All Page Boxes mode, you can set all 5 page boxes: Media Box, Crop Box, Bleed Box, Trim Box
and Art Box

 

 

1. Media box: this is the page format
2. Crop box: includes the Bleed box and all marks.
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3. Bleed box: defines the trimmed page plus the bleed.
4. Trim box: this is the net document format.
5. Art box: the Art box can be used to specify any section of the page.

You can see the dimensions of all Page Boxes in the Page Box list. You can

1. Select a Page Box in the list. Its details will be shown in the bottom part of the dialog.
2. Enable (or disable) the specific page box by enabling the Set [...] Box option.
3. Enter the offset, width and heigth. You can click the button to swap width and height. In the Size

dropdown, you can select any of the preset sizes.
4. Click one of the Fit to buttons to fit the selected page box respectively to the ArtBoard, Artwork,

Selection or CAD.
5. Use the Show All Page Boxes to show or hide all Page Boxes in your job.

3.6.  The Inspection Setup Plug-In

The Inspection Setup Plug-In allows you to define Inspection points or Inspection boxes in your job.

For each of these Inspection points, you will see the Lab value and DeltaE. For every Inspection box,
you can set the Profile. Inspection points and boxes will be exported, e.g. to be used in an Inspection
System in inline presses. This Inspection System will warn if the values measured at a specific position
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are more different from the entered Lab values than the allowed deltaE, or if the Inspection box or
Dynamic Art box doesn't match the defined profile.

The plug-in consists of

•
the Inspection Setup tool , under the Eyedropper tool in the toolbar

• the Inspection Setup palette, which can be opened by selecting the Inspection Setup tool, or by
adding an Inspection point.

3.6.1.  Adding and changing Inspection points

The Inspection Setup palette shows all the Inspection points, indicating the coordinates (distance
from the top left corner of the trim box), Lab value and default deltaE value.

•
Select the Inspection Setup tool  from the Illustrator toolbar and click in the job to insert a
new Inspection point.

The Inspection point will be visible in the job, with its number next to it.
• Select an Inspection point in the palette to highlight the corresponding Inspection point on the

Illustrator job. You can select multiple Inspection points
•

Select one or more Inspection points and click the delete button  to delete the Inspection
points
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• You can manually change the Lab and deltaE value for every Inspection Point.
•

Click the Refresh button  to update the Inspection Point list.
• You can move an Inspection point in two ways:

• Click within the Inspection point, and drag it to the new location
• In the Inspection Point list, change the coordinates for the Inspection point.

3.6.2.  Adding and changing Inspection boxes

The Inspection Setup palette shows all the Inspection boxes.

•
Select the Inspection Setup tool  from the Illustrator toolbar and click and drag in the job to
insert a new Inspection box.

The Inspection box will be visible in the job, with its number next to it. When creating a new
Inspection box, the Default Profile is used

• Select an Inspection box in the palette to highlight the corresponding Inspection box on the
Illustrator job. You can select multiple Inspection boxes.

•
Select one or more Inspection boxes and click the delete button  to delete the Inspection
boxes

• You can manually change the Profile.
• You can move or change an Inspection box in different ways:

• Click on the center point of the Inspection box, and drag it to move the Inspection box to a new
location

• Click one of the 8 handles on the Inspection box, and drag to modify the Inspection box

3.6.3.  Dynamic Art Placeholders

The Dynamic Art section of the Inspection Setup palette shows all Dynamic Art placeholders defined in
the job.

• Enable the checkbox in front of a Dynamic Art placeholder to use it as an Inspection box.

When adding a Dynamic Art placeholder, the Default Profile is used
• Select a Dynamic Art placeholder in the list to highlight the corresponding Dynamic Art placeholder

on the Illustrator job. You can select multiple Dynamic Art placeholders
• You can manually change the Profile.
• Disable the checkbox in front of a Dynamic Art placeholder to stop using it as an Inspection box.

3.6.4.  Import and Export

When exporting Normalized PDF, Inspection points and boxes added to a job are saved in the PDF file,
and these Inspection points and boxes will be recognized by Packadge and Automation Engine.
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Also, when opening a Normalized PDF from another Esko product (such as PackEdge), the Inspection
points and boxes information stored in the PDF document will be shown in the Inspection Setup
palette.

Note:  Dynamic Art placeholders are not saved as such in Normalized PDF. The selected
Dynamic Art placeholders will be exported as "Inspection Box". If you import the Normalized
PDF in Adobe Illustrator again, or open the Normalized PDF file in e.g. Packedge, these
Dynamic Art placeholders will be shown as Inspection Boxes

3.7.  Messages

The Messages plug-in is included with all Esko DeskPack plug-ins.

It displays the information, warnings and errors from all the other DeskPack plug-ins, and tells you
which plug-in generated them.

You can filter the messages you see when the Messages palette is open, and clear or save all messages
if you need to.

3.7.1.  The Messages Palette

The Messages palette pops up automatically when another DeskPack plug-in generates a warning or
an error.

You can also open it from Window > Esko > Messages.

 

 

This palette shows you:

•
the message’s severity (  information,  warning or  error),

• the message’s text in the Message column,

• which Plugin generated the message,

• the Time the message was generated at.
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Tip:  You can click the column headers to sort the messages, and drag the columns horizontally
to adjust their widths.

You can also use the palette to get extra information and / or select the objects that generated
warnings or errors:

• click a message to display extra information at the bottom of the palette.

 

 
• click the triangle in front of a message to see the list of objects it relates to.

 

 
• click one of the objects in the list to select it in the file.
• double-click that object to select it and zoom in on it in the file.
• double-click the message to select and zoom in on all objects it relates to in the file.

3.7.2.  Filtering the Messages

You can show or hide certain types of messages using the palette’s fly-out menu.

• To hide:

• all informational messages, select Hide Info Messages in the fly-out menu,
• all warnings, select Hide Warning Messages,
• all errors, select Hide Error Messages.

• To show them again, select either:

• Show Info Messages,
• Show Warning Messages,
• Show Error Messages.

• To only show the last message, select Show Last in the fly-out menu.
• To show all messages again, select Show All.

When showing all messages, you can see Show: All at the bottom right of the palette.

When filtering messages (for example filtering out the warning messages, or showing only the last
message), you can see Show: Filtered at the bottom right of the palette.

3.7.3.  Saving the Messages

To save all messages in a text file:
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1. Select Save Messages as... in the fly-out menu.
2. In the browser window that opens, choose the name and location to use for saving your file.

3.7.4.  Clearing the Messages

• To remove all messages from the Messages palette, select Clear in the fly-out menu.

3.8.  Esko Document Setup

By choosing File > Esko Document Setup you can open the Esko Document Setup dialog.

The settings made here are saved in the Esko XMP Document Information.

3.8.1.  Distortion

The vertical and horizontal distortion value is saved with the document and used by Esko RIPs when
generating the final output. It allows to compensate for distortions in certain printing methods, e.g.
flexography. On mounting a flexo plate on the press, it is stretched out in one direction. By making the
output slightly smaller than needed (e.g. 95%), we compensate for this distortion.

Values for vertical and horizontal distortion is limited to 90% - 110%.

3.8.2.  Screen Registration

The Screen Registration parameter allows to choose

•

if the RIP should reset the screening origin for every one-up 

•

or keep the same screening origin for the complete document 

Below a schematic representation of a Repetition with (left) and without (right) resetting the screen
origin for every one-up.
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3.9.  Annotations

With the Annotations plugin, you can view .xfdf annotations generated by Global Vision and
WebCenter.

Since version 16, Global Vision SDK has been integrated in Esko's Automation Engine, allowing several
types of Global Vision Check tasks to be run.

The output of a Global Vision Check is an .xfdf file, highlighting the found errors and problems on the
document.

The .xfdf file can be loaded (see Loading XFDF files on page 90) and the annotations are shown in the
Annotations palette (see The Annotations palette on page 91).

3.9.1.  Loading XFDF files

Whenever a file is opened in Adobe Illustrator, the Annotations plugin will try to find the corresponding
XFDF file to open.

• For GlobalVision annotations, the supported file types are Adobe PDF, Normalized PDF and Adobe
Illustrator file

• For WebCenter annotations, the supported file types are Adobe PDF, Normalized PDF, Adobe
Illustrator file, Adobe Illustrator ZIP file and ARD.

If for example a file "sample.pdf" is opened, the plugin will search for the corresponding .xfdf file in the
following locations, in the specific order shown below.

1. .view/sample.pdf/*.xfdf
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2. .view/sample*.xfdf

3. sample*.xfdf

4. ./sample_wcr.xfdf for WebCenter annotations

3.9.2.  The Annotations palette

The Annotation palette will show all Annotations found in the .xfdf file. You can open the palette by
choosing Window > Esko > Annotations.

 

 

There are different types of annotations: Barcode, Braille, Spell Check, Artwork, Text Compare and
WebCenter annotations.. You can browse to them by clicking the buttons on top of the palette.

Note:  If the document only contains WebCenter annotations, you will not have any filtering
options. If your document only contains Global Vision annotations, the "WebCenter" button will
be hidden.

For every issue found, an entry in the list is shown. Some of these annotations have text content, while
others can have an image preview, showing the difference between the actual artwork and how it
should look.
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If Show only selected annotations is enabled, only the annotations you select in the list will be
highlighted in your job using a colored rectangle. Otherwise, all annotations in the job will be
highlighted.

If Zoom is enabled, selecting an annotation in the list will automatically zoom in on the issue.

3.9.3.  Multipage PDF files with Annotations

An XFDF file can contain annotations for a multipage PDF. Every annotation will have a reference to
what page it belongs to.

If you import a multipage Normalized PDF, the plugin knows what page you imported, and only the
Annotations for that specific page will be shown.

If you import a multipage PDF as Adobe PDF, the plugin can't know what page you imported. In that
case, the Annotation palette will have a dropdown at the bottom of the palette, to decide for what page
you want to load the annotations.

Note:  Multi-page annotations is not supported for WebCenter annotations

3.9.4.  Editing WebCenter annotations

You can edit existing WebCenter annotations or create new annotations, and save them back to
WebCenter.

To create new annotations, you can use the Annotation Tool. See Creating new annotations using the
Annotation Tool on page 93

For every annotation (or reply), you can use the dropdown menu to modify the annotation.
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• Select Accepted. Rejected, Cancelled, Completed, or None to change the status of the annotation
accordingly.

• Select Edit to change the text of an annotation, or to move or resize the annotation.

You can click and drag the annotation to move it, or you can click and drag any of the handles on the
annotation to resize it.

The dialog will be extended, offering text editing options.

 

 

Note:  Clicking the Save button will store your changes in the (local) annotation, but will
NOT save the annotation back to WebCenter. The annotation will be an "unsaved annotation"
until you use Save Annotations from the fly-out menu. See below.

• Select Delete to remove the annotation.

• Select Copy to copy the content of a comment or annotation. This will open the Copy to Clipboard
dialog. Select the text you want to copy, and click Copy.

• Select Reply to add a reply to an annotation.

Note:  You can only reply to an annotation, not to a reply.

• If there are unsaved changes in the annotations, the Annotations palette will show a warning.

Choose Save Annotations from the fly-out menu in the Annotations palette to save the new or
modified annotations back to WebCenter. See Updating and Saving Annotations on page 94

3.9.5.  Creating new annotations using the Annotation Tool

Using the Annotation Tool you can create new annotations.

1. Click the Annotation Tool in Adobe Illustrator's tool box.
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2. Select the type of annotation you want to create.
3. Click or drag where you want to create the annotation.
4. In the Annotations palette, enter the text for the annotation

 

 
5. Click the Save button to store your annotation text, or click Delete to remove the annotation.
6. If necessary, repeat the previous steps to create additional annotations.
7. Choose Save Annotations from the fly-out menu in the Annotations palette to save the new

annotations back to WebCenter. See Updating and Saving Annotations on page 94

3.9.6.  Updating and Saving Annotations

Each annotation contains a time stamp of creation. In case the source file is modified and saved later
than the annotation, a warning icon will be shown on top of the palette, indicating the annotations
might be out of sync with the document.

Also when you edit Annotations (see Editing WebCenter annotations on page 92) or create new
annotations (see Creating new annotations using the Annotation Tool on page 93), a warning icon is
shown, indicating that these annotations are unsaved.

You can use Save Annotations from the fly-out menu to save all unsaved annotations to WebCenter.

You can use Update Annotations from the fly-out menu in the Annotations palette to get the latest
annotations from WebCenter.
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If you select Update Annotations while your document contains unsaved annotations, a warning will
be shown, asking if you wish to save the annotations. You can select Yes to save the annotations to
WebCenter, or click No to ignore the unsaved changes and get the latest annotations from WebCenter.

Note:

In case the annotations can not be loaded or saved (e.g. you are no longer logged in with
WebCenter Connector, there are no annotations available for the document, or the document
no longer exists) you will get a warning message indicating why loading or saving didn't work.

You can not save annotations, edit annotations or reply to an annotation if the Annotations
plugin is older than version 16.1.2, or if the WebCenter Connector plugin or WebCenter server is
not the latest version.

3.10.  Esko Plug-ins Dashboard

On your Esko Plug-ins Dashboard, you can:

• See which features you use, and how often,
• Learn how many files are processed with your Esko plug-ins,
• Get configurable reports for your company.

To build the dashboard, Esko needs to collect data about your plug-ins usage.

1. Open the Dashboard panel by choosing Help > Esko > Dashboard...
2. Click the Yes, I want a dashboard button.
3. Sign in with your Esko ID

More information about Esko ID can be found here

Note:  If you already enabled Dashboard before, you can skip step 2 and 3 steps.

4. Click the Go to my Esko Plug-ins Dashboard link to open the Dashboard

3.10.1.  Opt Out

At any time, you can opt-out and stop the data collection.

1. Open the Dashboard panel by choosing Help > Esko > Dashboard...
2. Click the Opt Out button.

3.10.2.  More about the dashboard and data collection

Insights for you and your team
You will get a dashboard for DeskPack and/or for Studio. With these personalized dashboards you
can check that you are getting the most out of your software investment. You can filter on those
features that are the most valuable to you, and keep track of how often they are used, how many files
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are handled, and by how many people. If your colleagues also opt in, you can choose to combine the
data in a single dashboard for your company.

Your data is protected
Your data will be available only to Esko, to you and to your colleagues (based on the company code of
their Esko IDs). Learn more about Esko ID and check out our privacy policy.

Help us improve our products
Sharing your usage data with Esko allows us to learn about your configuration and your use of our
products. This data enables us to focus on the features that matter the most to you.

What data is collected?
If you enable the dashboard, Esko will collect:

• Basic information about your computer (OS version, language, screen resolution, ...).
• Your version of Adobe Illustrator and which Esko plug-ins are installed.
• Which actions you perform on Esko plug-in, including some of their parameters.

We never record any information that can be used to identify your client or the designs that you work
on (such as text statements, barcodes, separation names or filenames).
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4.  boostX

4.1.  Using boostX

4.1.1.  boostX Preferences

To open the boostX preferences, choose Illustrator > Preferences > Esko > boostX Preferences.
Please refer to the chapter on Working with Crosshair alignment tools  on page 109, for the explanation
on the Crosshair Preferences.

The boostX Tool Layout preference allows you to place the different boostX tools either integrated
with the Illustrator tools, grouped or as individual tools in the Illustrator tool bar.

With the boostX Menu Layout preferences you can choose if the boostX menus should appear in
menus Object > Path and Select > Esko (Integrated) or in Object > Filters > Esko (Single Menu Group).

 

 

4.1.2.  Selecting Objects

Area Select Tool
The Area Select tool allows you to marquee select objects. The objects are only selected if the Marquee
select box is created around the entire object or clicked on directly.

The Area Select tool allows you to select only the objects you wish to work with, in contrast, the Adobe
Illustrator Selection tool will select an object if the Selection tool touches or is drawn through an
object.

With the boostX Area Select tool objects cannot be moved inadvertently.
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The boostX Select Tool can be found in the toolbar under the Adobe Illustrator Select tool.

Create a Marquee Selection box around the object or objects you wish to select. The selection is
highlighted.
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Tip:

Holding down the Option key while making a boostX marquee selection, rotates the selection
from the point of “marquee" origin. Holding down the Shift key will “snap” rotate the marquee
selection in 45 degree increments.
 

 

Tip:

Use shortcut 'v' to switch to the Illustrator select tool.

The boostX Direct Select Tool can be found in the toolbar under the Adobe Illustrator Direct Select
tool.

Create a Marquee Selection box around an object’s compound path or individual objects within a
“Group” of objects. The selection is highlighted.

The boostX Area Direct Select tool allows you to marquee select objects and then edit or modify the
object’s compound path, as in the inside of a “donut like” object. The boostX DirectSelect tool also
works on individual objects within a “Group” of objects.

Using the Adobe Illustrator Direct Select tool only allows you to edit and reposition an object’s
individual node points. Using the boostX Select tool allows you to select “complete” subpaths of
compound or grouped objects.

 

 

Dust Select Tool
The Dust Select tool allows you to select objects of equal or lesser size based on the Marquee Select
box you create. The marquee Select box can be created anywhere on the drawing surface. The Dust
Select tool will calculate the area and search the drawing for other objects of the same size or smaller
and select those objects.
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Note:  The Dust Select tool will take both width and length into account and will not only look at
the surface area.

The Dust Select tool is a useful utility for finding small, dust-like objects. These small objects can be
too small for printing or are artifacts of scanned artwork that need to be removed.

The Dust Select tool can be found in the toolbar under the Adobe Illustrator Select tool.

To create a selection, use your mouse to make a Marquee Selection box of a desired size. The Dust
Select Tool will search the drawing to select the objects of the same size or smaller, all objects
satisfying the size parameters are now highlighted.

The Dust Direct Select tool allows you to marquee select objects or their compound paths to
determine a selection. The Dust Direct Select tool can be found in the toolbar under the Adobe
Illustrator Direct Select tool.

 

 

Tip:

First draw your selection marquee and press CTRL holding the selection to delete everything in
the selection.

To create a selection, use your mouse to make a Marquee Selection box of a desired size. The Dust
Direct Select Tool will search the drawing to select objects, paths of compound objects, or paths of
groups of the same size or smaller.
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Selection tools under Select > Esko

Select Dust

The Dust Select filter searches your document for objects of the same size as the selected object, by
area calculation or smaller. Ideal for scanned artwork clean-up.

Inspect the drawing to determine the biggest object that should be removed, select that object, then
enable the boostX Dust select filter. All objects of the same size or smaller are selected. Now you can
decide to delete these objects or edit them.

To use Select Dust, select the object you want to use as reference, and choose Select > Esko > bX
Select Dust

The filter will search the drawing document and select the objects which are the same size, by area, or
smaller.
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Select Overprinting Objects

The bX Select Overprinting Objects searches your document for objects that are in overprint.

Click Select > Esko > bX Select Overprinting Objects and all objects in overprint will be selected.

Select White Overprinting Objects

The bX Select White Overprinting Objects searches your document for objects which fill or stroke is
white (all inks = 0%) and overprintring.

Click Select > Esko > bX Select White Overprinting Objects and all objects with a fill or stroke that is
white and overprinting will be selected.

Select Uncolored Art

The bX Select Uncolored Art selection filter searches your document for objects that have no fill color
or stroke color assigned to them.

Click Select > Esko > bX Select Uncolored Art and all objects without a fill color and stroke color will be
selected.

Select by Attributes
Select by Attributes opens the Select by Attributes palette, from which you can define a custom
selection filter based on the attributes of the objects in the Illustrator document.

Select By Attribute is both a productivity and a QA tool. It allows you to quickly select all elements in
the file (or sub-select within a selection) that comply with your criteria; color, object type, appearance
and even the shape of the object. Use it as a QA tool to trace elements in your document that are
outside the printing specifications (small text, thin lines, ...).

Click Select > Esko > Select By Attributes, to open the Select By Attributes palette.

Why Select by Attributes?
By combining multiple selection criteria in the Select by Attributes panel, you can create your own
special, tailor-made selection filter.
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The Select By Attributes option comes with four buttons Select, Refine, Deselect and Collect.

• Select: Select all objects in the document that match the criteria that are currently selected .
• Refine: Refine the current selection by adding additional selection criteria. This allows you to

quickly fine tune your result.
• Deselect: Deselect all objects that match the new selection criteria within the current selection.
• Collect: Make a Collection of all the objects in the document that match the criteria that are

curently selected. See Collection on page 106

Selection groups
The following groups of selection criteria are available:

• Object Type
• General Attributes
• Fill and Stroke
• Appearance
• Color

It's good to know that Select By Attributes works differently when combining selections within the
same selection group or when combining selection criteria in different selection groups.

When adding selection criteria in the same selection group, Select by Attributes will simply add the
search criteria, e.g. searching in "Object Type" for a "Path", "Text" and a "Mesh" will result in a selection of
all paths, all text and all mesh objects.

However when combining selections in different selection groups, Select by Attributes will combine
the selection criteria. e.g. searching for "Text" in "Object Type" and "Stroke" in "Fill and Stroke" will only
select text objects colored with a stroke.

Note:  Click on a triangle to collapse or expand the section. Alt-click on an expanded section to
open all the sections. Alt-click on a collapsed section to expand that secttion and collapse all
others.

Object Type

The Object Type group has 11 options:

• Path: Select objects based on the path type: Open, Closed or Compound. Using Any option, the
selection is made between objects which are Open, Closed or Compound.
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• Text: Select all text, or all text smaller than the point size you specify in the Text field.

• Symbol: Select all the objects that are Adobe Illustrator symbols.

• Linked File: Select objects or images which have been linked to (and not embedded into) the Adobe
Illustrator file.

• Image: Selects all placed image files of the file type defined in the list. The image has to be
embedded in the file.

• Mesh: Select all objects that are Adobe Illustrator Mesh objects.

• Dynamic Barcodes: Select dynamic barcode objects generated by the Esko Dynamic Barcodes
plug-in.

• Dynamic Table: Select dynamic table objects generated by the Esko Dynamic Tables plug-in.

• Dynamic Object: Select XML-driven dynamic objects generated by the Esko Dynamic Content plug-
in.

• Thin Part Fix: Select objects created by using the Fix button in the Thin Parts function of the
Preflight For Illustrator plugin.

• Trapping Tags: Select objects that have a Trapping Tag or Reverse Trapping Tag defined, used by
Esko Trapping.

General Attributes

The General Attributes group has three options:

• Name: Select an object by typing its name. The name of an object can be found and modified in the
Illustrator Layer palette. Object names are by default placed between angled brackets (< >). Note
that you do not need to type the brackets, and that object names are case sensitive.

• Size: Select the size of the object (smaller or bigger than the typed size in mm).

• Shape: Select the objects which are of the same shapes as defined in the list. Note that the Similar
as Selected Objects option will only function if an object is selected.

Fill and Stroke

The Fill and Strokes group has two options:
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• Fill: Select the objects with a fill.

• Stroke: Select all strokes, or strokes smaller than the size you specify in the Text field.

Appearance

The Appearence group has seven options:

• Current Style: Select objects similar to the selected object. The selection is tied to the style of the
Illustrator color palette. This means that you can also search for any object with a certain style.

• Fill Type: Select the objects with a certain Fill type. You can choose between Solid, Gradient or
Pattern.

• Opacity: Select the objects that have a fill or a stroke with an opacity level or transparency lower
than a certain percentage.

• Blending: Select objects that have a fill or a stroke set with one of the blending types, for example
darken or multiply . Select a blending mode from the drop down list.

• Overprint: Select the objects set in overprint.

• Opacity Mask: Select any objects with an Opacity mask linked to it. Opacity masks are used to alter
the transparency of objects and can also be selected via the "Opacity" option.

• Effects: Select any object that has an Adobe Illustrator Effect applied to it.

Color

The Color group has several options:
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• Fill Contains Ink: Select an object based on the ink used for its fill. This can be a process color ink or
a spot color ink.

• Use the "Lower than" and "Higher than" options to only select the objects with certain
percentages of the ink.

• Select the No other inks present check box if you only want to select objects with a fill in the
selected ink, but without other additional inks.

• Stroke Contains Ink: Select an object based on the ink used for its stroke. This can be a process
color ink or a spot color ink.

• Use the "Lower than" and "Higher than" options to only select the objects with certain
percentages of the ink.

• Select No other inks present check box if you only want to select objects with a stroke in the
selected ink, but without other additional inks.

• Fill Color is: Select an object based on the color used for its fill. By clicking once the color patch will
take the color of the object currently selected or when no selection is made it takes the Illustrator
current style. When multiple different objects are selected and you click once the default color
black is chosen. Double-clicking the patch will open the Illustrator Color Picker.

• Stroke Color is: Select an object based on the color used for its stroke. By clicking once the color
patch will take the color of the object currently selected or when no selection is made it takes the
Illustrator current style. When multiple different objects are selected and you click once the default
color black is chosen. Double-clicking the patch will open the Illustrator Color Picker.

Tip:  Change your current style for fill or stroke to "None" (see Tools palette or Appearance)
and select all objects with no fill or no stroke.

• White: Select any object with a white fill or stroke.

4.1.3.  Collection

A Collection is a temporary set of objects, based on a selection. It allows to navigate through the
objects in the Collection, automatically zooming in on them.

A collection is temporary, and only kept until it is cleared, or until the document is closed.

1. Select a number of objects.
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You can select objects manually, or by using e.g. Select by Attribute
2. Choose Window > Esko > Collection... to open the Collection dialog

 

 
3. Click the Make Collection button to make a collection based on the selection

Note:  By clicking the Collect button in the Select by Attribute palette, you can skip step
2 and 3, and immediately create a collection based on the properties set in the Select by
Attribute palette . See also Select by Attributes on page 102

4. Browse through the collection
 

 

The Collection dialog will show the number of objects in the Collection

• Use the browse buttons to navigate through the different objects in the collection
• The Info field shows the type of object currently selected
• Select the Zoom option to automatically zoom in on the currently browsed object.
• Select the Select option to automatically select the currently browsed object.

Note:

Selecting or deselecting objects doesn't change the collection. You can still select and/or
edit objects, without loosing your collection.

Modifying a Collection
You can modify the Collection using one of the functions in the fly-out menu of the Collection palette:

• Click the Make New Collection button or select Make Collection from the fly-out menu to "forget"
the current collection, and create a new collection based on the current selection.
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• Select Clear Collection from the fly-out menu to "forget" the current collection.
• Select one or more objects in the job, and select Add Selection from the fly-out menu to add the

selected objects to the collection.
• Browse to an object in the collection, and select Remove Selection from the fly-out menu to

remove the selected objects from the collection.

Note:  Objects that are removed in the job, are automatically removed from the collection.

• Select Select All from the fly-out menu to select all objects in the collection.

4.1.4.  Crosshair Tool

Crosshair Palette
The Crosshair palette allows you to create Origin Guide rules, intersecting 'x' and 'y' guide lines. These
guide lines can be rotated and positioned anywhere within the Adobe Illustrator drawing area. Objects
within the drawing can be snapped to position along the guides.

To select the Crosshair palette Choose Window > Esko > boostX > Crosshair. The boostX Crosshair
palette appears.

 

 

Horizontal Crosshair offset
 

 
Position of the “x’ axis crosshair guide line, positioned from the drawing origin point.

Vertical Crosshair
 

 
offset Position of the “y” axis crosshair guide line, positioned from the drawing origin point.

Crosshair Rotation
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Specify rotation angle of Crosshair Guide lines, - 45 degrees to +45 degrees around the Horizontal and
Vertical intersection point.

1. Align Art: Selected objects will be positioned to Crosshair guides according to Crosshair alignment
options.

2. Align Crosshair: Crosshair guides will be positioned to selected objects according to Crosshair
alignment options.

3. All Directions: Objects will be positioned along both Crosshair guides. Choose a position from the
Alignment Position Window. All 9 Alignment Position Buttons are active.

4. Align Vertical: Objects will be positioned along the vertical crosshair guide. Choose a position from
the Alignment Position Window. Center vertical Alignment Position Buttons are active.

5. Align Horizontal: Objects will be positioned along the horizontal crosshair guide. Choose a position
from the Alignment Position Window. Center Horizontal Alignment Position Buttons are active.

6. Visual Bounds: Objects are aligned along the object’s paint attributes, using the outside of the
stroke width.

7. Transformation Bounds: Objects are aligned using the object’s actual artwork path, ignoring the
paint attributes of the objects.

8. Align Ruler: The drawing’s ruler origin is aligned to the Crosshair origin point.

Note:  In Adobe Illustrator CS5 and CS5.5, only Global Rulers can be aligned to the Crosshair
position. If you are using Artboard rulers, you need to change them first to Global Rulers.

Working with Crosshair alignment tools
To interactively position the Crosshair

Start using the Crosshair tool by clicking the tool in the default toolbox .

The first time you select the Crosshair tool, the blue guide lines will align to the “0,0” Ruler origin.
The Crosshair Guides can be positioned using the mouse to set the Crosshair origin point. Hold down
the Option key and mouse button to set the angle of the Crosshair guide lines. Hold down the Option
key, the Shift key and the mouse button to rotate and Snap the Crosshair Guide lines to 45 degree
increments.

Aligning the Crosshair Guide lines to selected objects

To align the Crosshair Guide lines to selected objects:

1. Select the objects to align to.
2. Click the Align Crosshair button.
3. Select All Directions, Align Vertical, or Align Horizontal to create the alignment configuration you

desire.

Clicking one of the 9 crosshair alignment buttons will align the Crosshair guides to the selected
objects, while maintaining the Crosshair angle. You can use Crosshair alignment tools to change the
angle. As such, you obtain a reference to align objects to, or just to get an accurate readout on the
objects used as a reference.
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Aligning Objects to the Crosshair Guide lines

To align Objects to the Crosshair Guide lines:

1. Select the objects to be aligned.
2. Click on the Align Art button.
3. Select All Directions, Align Vertical, or Align Horizontal to create the alignment configuration you

desire.

 

 

Clicking on one of the 9 art alignment buttons will align the objects to crosshair guides using the
selected settings. The combination of aligning the Crosshair guides to objects, and then objects to the
Crosshair guides, gives you the ability to quickly create objecs that are correctly aligned to each other.

To align the left border of an object A to the right border of an object B while at the same time
keeping the vertical position of object A, do the following:

1. Select object B.
2. Align the crosshair to the right border of object B (set angle to zero first).
3. Select object A.
4. Change the align mode to align Art.
5. Select the Align Horizontal mode.
6. Left align the object A to the Crosshair guides.

Assigning Crosshair Preferences

The Crosshair Preferences dialog allows you to determine crosshair settings across documents.
You can keep the Angle and Position of the Crosshair for all documents when switching between or
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opening documents (by selecting remember for each document) or you can use the same Crosshair
settings across all documents (by deselecting the option). This allows you to align the crosshair in one
document, and align objects to these settings in another document.

To set boostX Crosshair Preferences :

Choose Edit  > Preferences > Esko > boostX Preferences (PC) or Illustrator > Preferences > Esko >
boostX Preferences (Mac).

The boostX Preferences Dialog appears. Select the desired setting for Crosshair Angle + Position and
save the settings.

 

 

Note:  Never put graphics on the boostX cross hair layer. All objects on the boostX layer will be
ignored.

4.1.5.  Crosshair Cut Tool

Using the Crosshair Cut Tool you can cut away parts of an object, based on the position of the
Crosshair.

1. Select the objects you want to cut.
2. Place the Crosshair inside the selection, using the Crosshair Tool. See Crosshair Tool on page 108
3. Select the Crosshair Cut Tool, situated under the Crosshair Tool in the toolbox.

 

 

The cursor will change to a pair of scissors
4. Click in the quadrant you want to be clipped away.
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Using a clipping path, the quadrant you selected will be cut away.

 

 

4.2.  Ink Mix

4.2.1.  Working with Document Inks

The InkMix Palette is a combination of Plug-in filters allowing you to develop and manage your own
custom Ink Base Colors (color swatch palette). These user-defined Base Inks become the basis for
which a commercial printer sets his presses up for your particular print job. It is recommended for you
to work closely together with a commercial printer before your work is press-ready, ensuring the “Base
Inks” are appropriate for the job. InkMix allows you to assign more than one spot color to an object
and to mix process colors and spot colors in the same object. The Ink Mix Plug-in helps answer some
critical print production questions:

• Which colors and special inks do you plan to specify so they can by applied correctly?
• Which colors within your document need special printing instructions?
• How many colors can be printed in one press run?
• Will your job run on a two-color, four-color, or six-color press?
• What color separation instructions does your commercial printer need?

4.2.2.  Using the Ink Mix palette

To use the Ink Mix palette Choose Window > Esko > boostX > InkMix.
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1. Fill or Stroke
2. Add to Graphic Styles
3. Fly-out menu
4. "None" button
5. Ink slider & percentage

Changing the Ink Mix of an object
When selecting an object, the Ink Mix palette will show the actual (Fill or Stroke) color.

You can simply change the color by entering the percentages in the input fields, or by dragging the
sliders for each ink.

You can apply a Swatch color by dragging and dropping a color from the Swatches pallete onto the fill/
stroke icon.

You can erase all inks in the selected object(s) by clicking the None button (4).

Note:

You can also mix the gradient color stops. Simply select the object with the gradient, and click
on one of the color stops.

Inks in the Ink Mix palette
The Ink Mix palette shows all inks currently used in the documents.

There are several ways to add inks:

• Drag and drop a color from the Swatches palette onto the Ink Mix Palette.

• Select Add Inks of Selected Color Swatch from the fly-out menu to add the inks used in the
selected Color Swatch

• Select one of the Add [...] inks options from the fly-out menu to add Process Inks, Hexachrome
Inks, Opaltone Inks or Process Inks + Orange and Green.
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When removing or converting inks in your document, the Ink Mix will only be updated after selecting
Remove Unused Inks from the Fly-out menu

Adding an Ink Mix to Graphic Styles
You can add the current Ink Mix to the Graphic Styles, by clicing the Add to Graphic Styles button, or by
selecting "Add to Graphic Styles" from the Fly-out menu.

Handling ink mixes from previous versions
Ink Mixes made in earlier versions of boostX use special BG inks. These ink mixes can still be read, but
are no longer created.

Using Upgrade to Appearances will upgrade BG inks used in the selected objects to appearances.

Restrictions
Please keep in mind that Ink Mix is not available in these situations:

• if the selection contains multiple objects with different colors (fill or stroke)
• if the selection contains multiple objects with a different stroke width
• if any effectis applied on a single fill or stroke in the Appearance palette. An effect on the complete

object is ok
• if a stroke with "Arrowhead" or "Profile" is selected (Uniform is ok)
• if an object with an "Appearance" with reversed order is selected: Fill - Stroke instead of Stroke -

Fill.
• if a mix of gradient and non gradient objects are selected
• if the "Appearance" palette has fills or strokes, but not all of them are in overprint. Only the last fill or

stroke can be overprinting or not.
• if the gradient sliders are not in the exact same position in the selection or in the multiple fills in the

Appearance palette.

4.3.  Split / Join Fill & Stroke

The Split Fill & Stroke filter separates a selected object’s Fill from its Stroke. This filter can be used for
modifying trapping options and working with chokes and spreads for printer color registration.

To use Split Fill & Stroke

Select an object with a fill and stroke. Choose Object > Path > boostX Split Fill & Stroke

The filter will separate the object’s fill and stroke into two distinct objects, one with a fill, no stroke and
the other with a stroke, no fill.

Using the Join Fill & Stroke Filter

The Join Fill & Stroke filter combines previously Split Fill and Stroke of an object.

To use Join Fill & Stroke Choose Object > Path > boostX Join Fill & Stroke

The Join Fill & Stroke filter will search the document for split objects. The filter then joins the objects’
fill and stroke into one object, having one stroke and one fill.
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The Fill & Stroke filters work on all objects including text, as in our example. Applying the Split Fill &
Stroke filter will separate the text object into two independent text objects. The result is one “text
object” with only a fill and another “text object” with only a stroke.

 

 

4.4.  Replacing Contour

The Replace Contour Tool allows you to create new objects by combining two objects, a closed path
object with an open path.

 

 

To use boostX Replace Contour, choose Window > Esko > boostX > Replace Contour. The Replace
Contour Palette appears.

1. Select a closed path object and an open path
2. Click the Keep Biggest button to create a single merged shape excluding the large closed path. The

new shape is the larger of the two objects calculated by area.
3. Click the Keep Smallest button to create a single merged shape excluding the small closed path.

The new shape is the smaller of the two objects calculated by area.
4. Click the Keep Both button to create two shapes. The new shape is the combination of both the

larger and smaller area objects.
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4.5.  Inner Outer Stroke

The Inner / Outer Stroke allows to create strokes with a different width on the inside and outside of the
object.

You can open the dialog by choosing Window > Esko > boostX > Inner Outer Strokes

Note:  Inner Outer Stroke is disabled if the selected object doesn't allow Inner/Outer Stroke,
such as an image object or text.

The Inner Width sets the distance from the original object to the inside, the Outer Width to the
outside.

The Corner buttons option allows you to change how the stroke’s sharp corners will be handled.

•
Round  (default): a round cap will be placed at all corners.

•
Beveled : this will cut sharp corners off.
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•
Mitered : this option works with a miter ratio.

The miter ratio serves to limit the length of the sharp corner (the distance from the base of the
stroke to the corner point).

The default miter ratio value is 4. This means that if the length of the sharp corner is more than 4
times the distance, then the corner will be cut off (beveled). If it is less than 4 times the distance,
the corner will be left as it is.

 

 

The Color allows to define the color for the Inner/Outer Stroke. You can double-click the color to
open the Adobe Illustrator Color Picker, or you can drag and drop a color patch from Adobe Illustrator
Swatch.

You can set the stroke to overprint using the Overprint option.

When selecting a single object with an Inner/Outer Stroke, the Inner/Outer Stroke dialog will reflect the
properties of the Inner/Outer Stroke. If multiple objects are selected, the common settings are shown.
If the objects have different settings, e.g. different Inner/Outer Width, or a different color, the settings
will be empty, or (in case of different colors) show a question mark.

Ink Mix
Inner/Outer Stroke can work with InkMix Colors. The Inner/Outer Palette color patch will get a mixed
color (indicated by a "m" in the patch) which is same as InkMix Palette Stroke color patch.

If you change the Inks value from the InkMix Palette, the Inner/Outer stroke will change automatically. If
the Inner/Outer Stroke color patch is a mixed color, double clicking the color patch will open the Ink Mix
Palette, since mixed inks can only be changed in InkMix.

For more information on Ink Mix, see Ink Mix on page 112

In the example underneath, the star has a Inner Width of 2pt, and an Outer Width of 6pt.
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4.6.  Spread & Choke

Using the Spread / Choke function, you can enlarge (Spread) or reduce (Choke) the selected object(s).

1. Select the objects you want to spread or choke

Note:  Spread / Choke is not supported on images, barcodes, text, PowerLayout Grids,
Dynamic Marks, Esko plugin art and meshes.. If your selection contains unsupported
objects, they will be ignored from the selection, and you will get a warning when spreading /
choking. If your selection only contains unsupported objects, Spread/Choke will be
disabled.

2. Select Object > Path > bX Spread & Choke to open the Spread & Choke dialog.
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3. Using the buttons on the top, choose between Spread  and Choke 
4. Enter the Offset to be used.

The Offset is the distance between the edge of the Spread/Choke object and the edge of the
original object.

5. Select how the sharp corners should be handled:

• Mitered: this option works with a Miter Limit. The Miter Limit serves to limit the length of the
sharp corner (the distance from the base of the trap to the corner point). The default Miter Limit
value is 4. This means that if the length of the sharp corner is more than 4 times the Offset, then
the corner will be cut off (beveled). If it is less than 4 times the Distance, the corner will be left as
it is.

• Round: a round cap will be placed at all corners.
• Beveled: this will cut sharp corners off.

6. Enable Copy if you want to keep the original object as well as the spread / choke.

• Select Behind if you want to place the spread/choke object underneath the original (default for
spreading).

• Select In Front if you want to place the spread/choke object on top of the original (default for
choking).

4.7.  Rotate Document

Using Rotate Document, you can rotate the complete document: the artboard, page boxes and all
objects. All objects and page boxes keep their relative positions.

Choose File > Document Rotation and select the rotation you want to apply.

The options are:

• 90º CW (ClockWise)
• 90º CCW (Counter ClockWise)
• 180º

Note:  In some cases, rotating the complete document is not supported. For example Dynamic
Marks, Adobe Illustrator effects, PowerLayout Standalone Grids etc. are not supported. If this
occurs, a message will be shown.
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4.8.  Dimension Lines

Using the Dimension Lines functionality, you can add dimension lines to your Illustrator file.

Dimension lines can be added to the full document, based on the artboard, trim box or media box.

You can also add dimension lines of subdivisions of the document, either in columns or in rows.

 

 

1. Open the Dimensions palette by choosing Window > Esko > boostX > Dimension Lines
2. Set the general settings:

a) Choose he Units to be used in the dimensions: either the units defined in the Illustrator
preferences, or a specific unit from the dropdown

b) Choose the style for the Arrows and the line thickness
c) Choose the Font Family and font size for the dimensions.

3. Set up the dimension lines for the complete job in the Total Dimensions section
a) Set the Size to put the dimension lines on: either the Artboard, or one of the Page Boxes.

The Width and Height fields will show the dimensions of the currently selected size.
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b) Define where the dimension lines should be placed by setting the Width Position and Height
Position. The Margin defines the distance between the job and the dimensions or between two
dimensions on the same side.

c) Set the Color for the total dimensions. The last used colors will be remembered for each new
document. By default, a technical spot color named "Dimensions and Text" is used.

4. Set up the subdivision lines in the Subdivisions section.
a) Set the Line Style for the Subdivisions: either a dashed line, solid line or no line.
b) Set the Color for the Dimensions and for the dashed lines. The last used colors will be

remembered for each new document. By default, a technical spot color named "Secundary
Dimensions" and "General Structural Lines" is used.

c) Set the Columns by entering a distance in the different fields.

• Click the + button to add a new field. If an input field is selected, the new field is added in
front of it, otherwise it's added at the end.

• Click the - button to remove the currently selected field. If no input field is selected, the last
one is removed.

• In case the size of the columns does not add up to the total size, a yellow warning is shown.
Clicking this button will automatically adjust the columns to match the total width. If the sum
of all columns is lower than the total width, a column is added, using the difference as width.
If the sum of all columns is higher than the total width, any columns completely outside of the
total width are removed, and the last column is reduced to make the sum of all column widths
match the total size.

d) Define where the column dimensions should be placed, either Top or Bottom. The Margin
defines the distance between the job and the dimensions.

e) Set the Rows by entering a distance in the different fields. This works the same way as for
Columns (see above).

f) Define where the row dimensions should be placed, either Left or Right. The Margin defines the
distance between the job and the dimensions or between two dimensions on the same side.

5. Click Create to create the dimension lines and dimensions in a separate locked Dimension Lines
layer.
If you already created dimension lines in the document, the button will change to Modify, allowing
you to change the current dimension lines using different settings.

4.8.1.  Dimension Lines Presets

With Dimension Lines Presets, you can save all your settings as a preset to be able to reuse them on
other documents.

1. Define your settings in the Dimension Lines dialog.
2. In the Presets list, choose Save...
3. Give your preset a name and click OK.

You can now see your preset in the Presets list. To reuse it in the future, just select it in the list.

Note:  The Preset dropdown also contains the Bag Types. See Bag Presets on page 122

• To delete a preset, select it in the Presets list and select Remove.
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• To edit a preset, select it in the Presets list, make your changes in the settings, and save it again
with the same name.

• The location where the Presets are saved, is set in the Dimension Lines Preferences. See Dimension
Lines Preferences on page 123

4.8.2.  Bag Presets

By selecting a Bag Type from the Preset dropdown, you can add the dimensions corresponding to the
selected Bag Type.

1. In the Dimension Lines dialog, select the desired Bag Type in the Preset dropdown.

You can choose from these bag types:

• Pillow Bag - Fin Seal
• Gusseted Bag - Fin Seal
• Gusseted Bag - Block Bottom
• Stand-up Pouch
• Sachet - Horizontal Fold
• Sachet - Vertical Fold

For more information on the different bag types, we refer to the Studio documentation: https://
www.esko.com/en/support/product?id=Studio%20Advanced

Note:  Note that the available Sachet bag types don't match the bag types available in
Studio Toolkit. Sachet - Horizontal Fold should be used for both three-seal four seal
sachets, where the "Orientation" option is set on the left or right side, while Sachet -
Vertical Fold should be used for three-seal and four seal sachets, where the "Orientation"
option is set on the top or bottom.

As soon as you select a bag type, the parameters to be set will change. Changing the Bag Type will
reset all parameters.

2.
Set the Orientation of the dimensions in your document using the orientation buttons 

3. Use the Attach dropdown to define the position of the dimensions. The dimensions will be placed in
the top left corner of the selected page box or the Artboard.

4. Set the dimensions for the bag. The parameters to be set depend on the selected bag type.
5. Click Create to create the Dimension Lines, or Modify to adjust the already created Dimension Lines

4.8.3.  Dimension Lines Options

In the Dimension Lines Options, you can change the appearance of the dimension lines

1. Select Show Options in the fly-out menu of the Dimension Lines dialog.
2. Set the Units: you can either use the units defined in Illustrator, or set the units to be used.
3. Define the Arrows, Line Style and Line Width for the dimension lines.
4. Set the Font Family and Size for the text
5. Set the Position and Margin for the Width, Height, Columns and Rows dimensions.
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6. Set the Color for the total dimensions, the subdivisions dimensions and the lines.
7. Click Create to create the Dimension Lines, or Modify to adjust the already created Dimension Lines
8. Select Hide Options in the fly-out menu of the Dimension Lines dialog to hide the additional

options.

4.8.4.  Dimension Lines Preferences

Open the Dimension Lines Preferences by selecting Illustrator > Preferences > Dimension Line
Preferences

• With Inch Units you can choose if a dimension in inch should be shown using the text (e.g. 12 in) or
the symbol (e.g. 12")

• By setting the Show Decimals, you can define how many decimals should be shown in the
dimension text. When set to Default, the amount of decimals is defined by Adobe Illustrator, based
on the selected unit. When set to 0, 1, 2 or 3, the distances are rounded off when necessary. Ending
zeroes (after rounding) are not shown.

• If the option Overprint Dimension Lines is enabled, all newly created dimension lines will be placed
in overprint.

• Dimension Lines Preset Settings Folder:

When choosing Use default preference folder, Presets are saved in the default "shared users"
folder.

When choosing Use custom folder, Presets are saved in the folder you define by clicking the
Browse button.
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5.  Dynamic Barcodes

5.1.  What is a barcode ?

A barcode is a machine-readable representation of information in a visual format on a surface.
Barcodes can be read by optical scanners, allowing quick and easy identification of all kind of goods.

Originally barcodes stored data in the widths and spacings of printed parallel lines, but today they also
come in patterns of dots, concentric circles, and hidden in images.

The information contained in a barcode varies from numbers to complete ASCII texts. The drive to
encode ever more information in combination with the space requirements of simple barcodes led to
the development of matrix barcodes or 2D barcode, which do not consist of bars but rather a grid of
square cells.

Barcodes are just the visible part of often quite large systems frequently referred to as automated
identification systems. These systems are increasingly proving to be some of the most cost-effective
management tools, since they enable organizations to keep track of their goods and stocks in all kinds
of situations in a fast, accurate and ecient way.

With the Dynamic Barcodes plug-in, you can add a dynamic barcode to your document without leaving
your application. Dynamic means that your barcode settings can be changed later on, even after you
saved, closed and reopened your document.

5.2.  Getting Started with Dynamic Barcodes

To introduce you to Dynamic Barcodes, here is how to make your first barcode in four simple steps.

1. Create a CMYK Illustrator document and go to Windows > Esko > Dynamic Barcodes.

This opens the Dynamic Barcodes dialog.
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2. Define the color of the barcode: in your Illustrator color palette, define a single-color fill style and no

stroke.
 

 
3. Enter the barcode parameters (Barcode Type, numeric Code...) in the Dynamic Barcodes dialog.

For example, for an EAN 13 barcode, select EAN 13 as Barcode Type and enter a 13 digit Code.
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4. Click the Create button and Dynamic Barcodes will generate the barcode in your document.
 

 

5.3.  Using Dynamic Barcodes in Unlicensed Mode

If you don't have a license for the Dynamic Barcodes plug-in, you still use it in unlicensed mode to
perform limited operations. You can:

• Open documents containing barcodes created by Dynamic Barcodes without warning messages.
• Create barcode placeholders (with no data in them) in your design.

See Creating a Barcode Placeholder Quickly on page 132.

You can also use the regular Illustrator functions to:

• change the barcode's position in your document,
• rotate it by multiples of 90 degrees (using Object > Transform > Rotate),

Tip:  You can rotate several barcodes at once.

• change its fill color (it is not possible to apply a stroke),

Attention:

Choose a fill color that is:

• a process or a spot color (other colors might generate trapping problems),

• not too light (or the barcode might be dicult to scan).

• copy and paste it.
• delete it.

5.4.  Dynamic Barcodes Basics
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5.4.1.  Creating a Barcode

1. Create a CMYK Illustrator document and go to Windows > Esko > Dynamic Barcodes.

You can also use the Command + Option + 4 shortcut on Mac, or the CTRL + Alt + 4 shortcut on PC.

This opens the Dynamic Barcodes dialog.
 

 
2. Define the color of the barcode: in your Illustrator color palette, define a single-color fill style and no

stroke.

Dynamic Barcodes creates bars by generating rectangular objects and assigning the current fill
style to them.
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Attention:

Choose a fill color that is:

• a process or a spot color (other colors might generate trapping problems),
• not too light (or the barcode might be dicult to scan).

3. In the Dynamic Barcodes dialog, select your Barcode Type.
4. Enter a Rotation angle for your barcode, or use one of the rotation buttons. Choose the Orientation

of your barcode using one of the buttons or by entering an angle.
5. Enter the barcode's data in the Code field. For most barcodes, you can choose to also show this

data as a (human-readable) number.

Attention:  Make sure the barcode data you enter is valid for the barcode type you chose. If
it isn't, a warning / error will pop up.
 

 

Note:  If you enter a wrong check digit, Dynamic Barcodes can fix it automatically for you.
 

 

6. To fill in other parameters specific to the barcode type you chose, open the Additional parameters
section and see Barcode Types on page 152.
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7. Click the Create button.

• If you have the boostX plug-in installed, Dynamic Barcodes generates your barcode at the
intersection of the boostX crosshair.

• If you don't have the boostX plug-in installed, Dynamic Barcodes generates your barcode in the
center of the view.
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5.4.2.  Editing a Barcode

With Dynamic Barcodes, you can also edit existing barcodes.

1. Open the Dynamic Barcodes.
2. Select the barcode to edit in your Illustrator document.
3. Change its parameters as you wish in the Dynamic Barcodes dialog.

Note:

If you change the Barcode Type and the previous Code is not valid for this barcode type,
Dynamic Barcodes will reset it to the (first) default code for this barcode type.

This is the default code used for placeholder barcodes; you can see it in the preset
barcodes dialog (see Previewing and Creating a Barcode Placeholder on page 133).

You can then either:

• enter your own valid code,

• use this default code to create a placeholder barcode (see Creating a Barcode
Placeholder Quickly on page 132).

4. Click the Apply button to apply your changes to the barcode.

5.4.3.  Setting Barcode Parameters to Default

• To reset all the parameters of the selected barcode to default, click the palette menu  in the
top right corner of the Dynamic Barcodes dialog then click Set Default Parameters.
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Note:  The Bar Width Reduction, Device Compensation and Snap Bars to Output
Resolution parameters are not reverted to the defaults, since these parameters are related
to the press settings, and not related to the selected barcode.

5.4.4.  Barcode Placeholders

If you don't have the exact data to encode in your barcode yet, you can already create a barcode
placeholder in your design.

This placeholder will have the correct symbol type for the barcode type you choose, but will only
contain “empty” or “default” data (for example 0000000000000 for EAN 13).
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Creating a Barcode Placeholder Quickly
1. Open the Dynamic Barcodes dialog from Windows > Esko > Dynamic Barcodes.
2. Define the color of the barcode: in your Illustrator color palette, define a single-color fill style and no

stroke.
 

 

Attention:

Choose a fill color that is:

• a process or a spot color (other colors might generate trapping problems),

• not too light (or the barcode might be dicult to scan).

3. In the Dynamic Barcodes dialog, select your Barcode Type.

The Code field is automatically filled out with a nul / default value that has the correct number of
digits for your Barcode Type (for example 0000000000000 for EAN 13).
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4. Click the Create button to create your barcode placeholder.

 

 

Note:  You can also create a barcode placeholder in unlicensed mode (see Using Dynamic
Barcodes in Unlicensed Mode on page 126).

Previewing and Creating a Barcode Placeholder
You can use Dynamic Barcodes to preview different barcode types before creating your barcode
placeholder.

1. Open the Dynamic Barcodes dialog from Window > Esko > Dynamic Barcodes.
2. Define the color of the barcode: in your Illustrator color palette, define a single-color fill style and no

stroke.
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Attention:

Choose a fill color that is:

• a process or a spot color (other colors might generate trapping problems),

• not too light (or the barcode might be dicult to scan).

3.

In the Dynamic Barcodes dialog, click the Pre-set barcodes icon .

This opens the Select Barcode dialog.

 

 
4. Select your Barcode Type on the right to see a Preview of it on the left.
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Note:  This shows previews of barcode placeholders. Your actual barcode (with data and
specific parameters affecting its size) may look slightly different. For more information on
barcode parameters, see Barcode Types on page 152.

5. If your barcode data can have several possible lengths (for example EAN 13 can have 13, 15 or 18
digits), choose the length you want to preview in Code Preset.
 

 
6. If your barcode can have a Composite Component (some GS1 barcodes), you can choose to preview

it with or without that component.
 

 
7. Click OK to use the preview parameters (Barcode Type, Code Preset and Composite Component as

applicable) in the Dynamic Barcodes dialog and close the Select Barcode dialog.
8. In the Dynamic Barcodes dialog, click the Create button to create your barcode placeholder.

 

 

5.4.5.  Expand

By using the Expand function, you can replace a barcode by regular objects (rectangles, text, …) in a
group, without any barcode information.
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Note:  Adobe Illustrator also contains an "Expand" function. However, since this does not
remove the barcode metadata, the barcode remains editable.

1. Select the barcode you want to expand
2. From the fly-out menu of the Dynamic Barcodes panel, select Expand

Note:  Barcodes used by Dynamic Marks and Dynamic VDP can't be expanded.

5.5.  Dynamic Barcodes Advanced

5.5.1.  Choosing a Font Standard

You can choose between two font standards for the human-readable characters of your barcodes.

1. Go to Illustrator > Preferences > Esko >  Dynamic Barcodes Preferences... to open the Dynamic
Barcodes Preferences dialog.
 

 
2. Choose either OCR-B Standard or OCR-B Bitstream and click OK.

OCR-B Standard fonts are rounder and
typically used in the Western market.

 

 

OCR-B Bitstream fonts are typically used in
the Asian market.
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Note:  If the OCR-B Bitstream font is not installed on your system, the option will be
disabled. Esko does not provide this font.

5.5.2.  Using Dynamic Content with Dynamic Barcodes

You can use the Dynamic Content plug-in to turn barcodes created with Dynamic Barcodes into XML-
driven objects. These barcodes update automatically when the XML files to which they are linked
change.

For more information, see the Dynamic Content documentation.

5.5.3.  Barcode Protection

Once you create a barcode with Dynamic Barcodes, this barcode is protected. This means that it
won't be possible to edit it with most regular Illustrator tools. This protects the barcode against
modifications that might render it invalid, for example distorting it or modifying its size.

The only transformation allowed is moving or rotating the barcode. When rotating the barcode,
a message is shown in the Messages palette, and the barcode's Rotation parameter is adapted
accordingly.

You can still edit the barcode's parameters at any time through the Dynamic Barcodes dialog.

Protecting a Barcode
You can protect a Dynamic Barcodes barcode that has been unprotected, or a barcode made in a
previous version of Dynamic Barcodes.

1. Open the Dynamic Barcodes plug-in.
2. Select the barcode to protect in your Illustrator document.
3. If necessary, change its parameters in the Dynamic Barcodes dialog.
4. Click the Apply button to apply the parameter changes and protect your barcode.

Tip:  You can use this to fix some invalid barcodes.

Handling a Barcode without Dynamic Barcodes

Opening a Document Containing a Dynamic Barcodes Barcode without Dynamic Barcodes

When opening a document containing a Dynamic Barcodes barcode in an Illustrator application that
doesn't have the Dynamic Barcodes plug-in, you will get the following warning:
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This doesn't create any problem in your file, and you can continue to work with this file as you normally
would, without editing the Dynamic Barcodes barcode.

If you need to edit the Dynamic Barcodes barcode with your Illustrator application, see Editing a
Document Containing a Dynamic Barcodes Barcode without Dynamic Barcodes on page 138.

Editing a Document Containing a Dynamic Barcodes Barcode without Dynamic Barcodes
If you don't have the Dynamic Barcodes plug-in, you can still use Illustrator to do the following
operations without rendering your barcode invalid.

If you don't have Dynamic Barcodes installed, you will not be able to

• move or scale the object using the Selection tool
• move or distort it (reflect, shear or scale)
• change a color

You will be able to

• expand the bar code
• Rotate by Selection or Free transform - this can lead to inconsistent results so we recommend not

doing this.
• move, rotate and distort by the Transform Each command - this can lead to inconsistent results so

we recommend not doing this.
• enclose it in the Envelope and distort
• delete it
• copy and paste it

If the Dynamic Barcode plugin is installed, but without a valid license, you will be able to do everything
that is allowed by the plugin, except modifying the content. This means for example moving and
rotating is allowed, but due to the bar code protection, any potentially dangerous operations such as
scale, reflect or shear are not allowed. You will also be able to change the color of the bar code.

Unprotecting a Dynamic Barcodes Barcode for Further Editing
You can expand your Dynamic Barcodes barcode to a regular Illustrator group art to be able to edit it
further, but this is not recommended as it will remove the barcode's protection.

Attention:  It will then be possible to make modifications that might render the barcode
invalid.

1. To do this, go to Object > Expand... in the Illustrator menu.
2. Choose the object's characteristics to expand, then click OK.
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This turns your barcode into a regular Illustrator object. You can now for example edit each bar of the
barcode individually.

5.5.4.  Exporting Documents with Barcodes

If you are using other Esko applications, you can export Illustrator documents containing barcodes to
the Esko Normalized PDF format, preserving the barcodes' information and editability.

Viewing Barcode Information in Other Esko Applications
1. Export your Illustrator document to the Esko Normalized PDF format:

• If you have Automation Engine, use Shuttle to launch the document into your chosen workflow.
This converts it to Normalized PDF automatically.

Note:  See the Adobe Illustrator Client documentation for setup information.

• If you don't have Automation Engine, use File > Export and choose Normalized PDF as the export
format.

2. Select (in Automation Engine) or open (in PackEdge / Acrobat) your document and open the XMP
information as explained below:

If you have... go to...

Automation Engine File > Info.

PackEdge File > XMP Info.

the Esko XMP plug-in in Adobe Acrobat Esko > XMP Document Info...

3. Click Barcodes in the Data type column (as below in PackEdge) to show the barcode information.
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For more information, see the Shuttle, Automation Engine, PackEdge or XMP plug-in documentation.

Editing Barcodes in Other Esko Applications
The Dynamic Barcodes functionality is available both as a DeskPack plug-in and in PackEdge.

• To edit your document containing barcodes in PackEdge:
a) Export your Illustrator document to the Esko Normalized PDF format:

• If you have Automation Engine, use Shuttle to launch the document into your chosen
workflow. This converts it to Normalized PDF automatically.

Note:  See the Adobe Illustrator Client documentation for setup information.

• If you don't have Automation Engine, use File > Export and choose Normalized PDF as the
export format.

b) Open your document in PackEdge.
c) Go to Production > Bar Code... to edit your barcode as you would edit it with Dynamic Barcodes.

For more information, see the Shuttle and PackEdge documentation.

5.6.  Barcode Recognition

Barcode Recognition is a new function in Dynamic Barcodes to convert vectorized (contourized)
barcodes and images (e.g. a scanned in barcode) back into live editable barcodes.

1. Choose Window > Esko > Dynamic Barcodes to open the Dynamic Barcodes palette.
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2. Select the objects (lineart or image) that you want to convert.
3. Click the Extract button.

Dynamic Barcode will analyse the selected objects, and when possible a Dynamic Barcode is
generated replacing the selection.

a) Click and hold Hold to View Original to hide the converted barcode and see the original lineart or
image.

b) Change any of the barcode parameters and click Apply to modify the generated barcode.
c) Enable Compare View to show the newly generated barcode semi transparent on top of the

original objects. This allows you to easily change position and parameters of the new barcode to
match the original.

4. When you're happy with the result, click the Finish button.

This will remove the original objects from the document and close the Barcode Recognition
session, leaving you with a barcode object that you can edit as needed.

Note:  You can not do any other barcode recognition as long as the previous session wasn't
ended, either by clicking the Finish or the Cancel button.

5.6.1.  Supported Barcode Types and known limitations

The barcodes that are currently supported for Barcode Recognition are these:

• Code-128
• Code-128 (long)
• Code-39
• DATAMATRIX
• EAN-13 (including add-ons)
• EAN 13 Swissmedic
• EAN-8
• GS1-128
• GS1 DataMatrix
• GS1-QR
• HIBC-128
• HIBC-39
• Int. 2 of 5
• ITF-14
• ITF-16
• NDC-HRI
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• PZN
• PZN8
• QR
• UPC-A (including add-ons)
• UPC-E (including add-ons)
• UPC-SCS

The barcode parameters that are currently recognized (when possible) are these:

• Barcode type
• Code
• Add-on presence
• Color (only when recognizing line art objects)
• HRI presence (only when recognizing line art objects)
• Height (only when recognizing line art objects)
• Rotation
• Magnification
• BWR (only when recognizing line art objects)
• Characters per unit
• Ratio

Other limitations:

• White Box, Light margin indicators, H gauges for ITF barcodes and HRI text parameters are not
recognized.

• Device Compensation and Bar Width Reduction are both combined in the Bar Width Reduction
• An Int. 2 of 5 needs to have at least 6 digits.
• UPC-SCS with add-on is not recognized.
• If the original is an image, rotation is deduced from the rotation of the image. If the barcode inside

the image is rotated over an angle other than a multiple of 90º, the recognizing will not work.
• Pre-defined barcode sizes for PZN barcodes may not always be recognized.

5.7.  Barcode Types and Parameters

5.7.1.  Supported Barcode Types

General Purpose Barcodes

1D 2D

• Code 39

• Code 93 on page 159

• 2 of 5

• DataMatrix

• QR

• MicroQR
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1D 2D

• Interleaved 2 of 5

• Codabar

• Code 128

• Code 128 (long)

• Klebrand on page 179

• MSI

• SICK Code on page 193

Retail Barcodes

1D 2D

• EAN 13

• EAN 8

• UPC-A

• UPC-E

• GS1 DataBar Omnidirectional

• GS1 DataBar Truncated

• GS1 DataBar Stacked

• GS1 DataBar Stacked Omnidirectional

• GS1 DataBar Limited

• GS1 DataBar Expanded

• GS1 DataBar Expanded Stacked

• GS1 128

• GS1 U.S. Coupon Interim

• M+S 7

• Marks & Spencer

• GS1 DataMatrix
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Pharmaceutical, Healthcare and Cosmetic Barcodes

1D

• Bobst on page 153

• NDC / HRI

• EAN 13 Swissmedic

• Kurandt on page 180

• Laetus Pharma Code

• CLF-8

• HIBC 39

• HIBC 128

• Paraf Italy

• PZN

• PZN8

Shipment Container Barcodes

1D

• ITF-14

• ITF-16

• UPC-SCS

Identity Document Barcode

2D

• PDF417

• MicroPDF417

GS1 Application Identifiers
These are the GS1 Application Identifiers available in Dynamic Barcodes:

AI Data Content Format (*) FNC1 Required
(*****)

00 Serial Shipping Container Code (SSCC) N2+N18
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01 Global Trade Item Number (GTIN) N2+N14

02 GTIN of Contained Trade Items N2+N14

10 Batch or Lot Number N2+X..20 (FNC1)

11 (**) Production Date (YYMMDD) N2+N6

12 (**) Due Date (YYMMDD) N2+N6

13 (**) Packaging Date (YYMMDD) N2+N6

15 (**) Best Before Date (YYMMDD) N2+N6

16 (**) Sell By Date (YYMMDD) N2+N6

17 (**) Expiration Date (YYMMDD) N2+N6

20 Internal product variant N2+N2

21 Serial Number N2+X..20 (FNC1)

22 Consumer product variant N2+X..20 (FNC1)

235 Third Party Controlled, Serialised Extension of
GTIN (TPX)

N3+X..28 (FNC1)

240 Additional Item Identification N3+X..30 (FNC1)

241 Customer Part Number N3+X..30 (FNC1)

242 Made-to-Order Variation Number N3+N..6 (FNC1)

243 Packaging Component Number N3+X..20 (FNC1)

250 Secondary Serial Number N3+X..30 (FNC1)

251 Reference to Source Entity N3+X..30 (FNC1)

253 Global Document Type Identifier (GDTI) N3+N13+X..17 (FNC1)

254 GLN Extension Component N3+X..20 (FNC1)

255 Global Coupon Number (GCN) N3+N13+N..12 (FNC1)

30 Variable Count of Items (Variable Measure
Trade Item)

N2+N..8 (FNC1)

310n (***) Net weight, kilograms (Variable Measure
Trade Item)

N4+N6

311n (***) Length or first dimension, metres (Variable
Measure Trade Item)

N4+N6

312n (***) Width, diameter, or second dimension, metres
(Variable Measure Trade Item)

N4+N6

313n (***) Depth, thickness, height, or third dimension,
metres (Variable Measure Trade Item)

N4+N6

314n (***) Area, square metres (Variable Measure Trade
Item)

N4+N6

315n (***) Net volume, litres (Variable Measure Trade
Item)

N4+N6
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316n (***) Net volume, cubic metres (Variable Measure
Trade Item)

N4+N6

320n (***) Net weight, pounds (Variable Measure Trade
Item)

N4+N6

321n (***) Length or first dimension, inches (Variable
Measure Trade Item)

N4+N6

322n (***) Length or first dimension, feet (Variable
Measure Trade Item)

N4+N6

323n (***) Length or first dimension, yards (Variable
Measure Trade Item)

N4+N6

324n (***) Width, diameter, or second dimension, inches
(Variable Measure Trade Item)

N4+N6

325n (***) Width, diameter, or second dimension, feet
(Variable Measure Trade Item)

N4+N6

326n (***) Width, diameter, or second dimension, yards
(Variable Measure Trade Item)

N4+N6

327n (***) Depth, thickness, height, or third dimension,
inches (Variable Measure Trade Item)

N4+N6

328n (***) Depth, thickness, height, or third dimension,
feet (Variable Measure Trade Item)

N4+N6

329n (***) Depth, thickness, height, or third dimension,
yards (Variable Measure Trade Item)

N4+N6

330n (***) Logistic weight, kilograms N4+N6

331n (***) Length or first dimension, metres N4+N6

332n (***) Width, diameter, or second dimension, metres N4+N6

333n (***) Depth, thickness, height, or third dimension,
metres

N4+N6

334n (***) Area, square metres N4+N6

335n (***) Logistic volume, litres N4+N6

336n (***) Logistic volume, cubic metres N4+N6

337n (***) Kilograms per square metre N4+N6

340n (***) Logistic weight, pounds N4+N6

341n (***) Length or first dimension, inches N4+N6

342n (***) Length or first dimension, feet N4+N6

343n (***) Length or first dimension, yards N4+N6

344n (***) Width, diameter, or second dimension, inches N4+N6

345n (***) Width, diameter, or second dimension, feet N4+N6

346n (***) Width, diameter, or second dimension, yard N4+N6
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347n (***) Depth, thickness, height, or third dimension,
inches

N4+N6

348n (***) Depth, thickness, height, or third dimension,
feet

N4+N6

349n (***) Depth, thickness, height, or third dimension,
yards

N4+N6

350n (***) Area, square inches (Variable Measure Trade
Item)

N4+N6

351n (***) Area, square feet (Variable Measure Trade
Item)

N4+N6

352n (***) Area, square yards (Variable Measure Trade
Item)

N4+N6

353n (***) Area, square inches N4+N6

354n (***) Area, square feet N4+N6

355n (***) Area, square yards N4+N6

356n (***) Net weight, troy ounces (Variable Measure
Trade Item)

N4+N6

357n (***) Net weight (or volume), ounces (Variable
Measure Trade Item)

N4+N6

360n (***) Net volume, quarts (Variable Measure Trade
Item)

N4+N6

361n (***) Net volume, gallons U.S. (Variable Measure
Trade Item)

N4+N6

362n (***) Logistic volume, quarts N4+N6

363n (***) Logistic volume, gallons U.S. N4+N6

364n (***) Net volume, cubic inches (Variable Measure
Trade Item)

N4+N6

365n (***) Net volume, cubic feet (Variable Measure
Trade Item)

N4+N6

366n (***) Net volume, cubic yards (Variable Measure
Trade Item)

N4+N6

367n (***) Logistic volume, cubic inches N4+N6

368n (***) Logistic volume, cubic feet N4+N6

369n (***) Logistic volume, cubic yards N4+N6

37 Count of Trade Items N2+N..8 (FNC1)

390n (***) Applicable Amount Payable or Coupon Value,
local currency

N4+N..15 (FNC1)

391n (***) Applicable Amount Payable with ISO Currency
Code

N4+N3+N..15 (FNC1)
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392n (***) Applicable Amount Payable, single monetary
area (Variable Measure Trade Item)

N4+N..15 (FNC1)

393n (***) Applicable Amount Payable with ISO Currency
Code (Variable Measure Trade Item)

N4+N3+N..15 (FNC1)

394n (***) Percentage discount of a coupon N4+N4 (FNC1)

395n (***) Amount payable per unit of measure single
monetary area (variable measure trade item)

N4+N6 (FNC1)

400 Customer's Purchase Order Number N3+X..30 (FNC1)

401 Global Identification Number for Consignment
(GINC)

N3+X..30 (FNC1)

402 Global Shipment Identification Number (GSIN) N3+N17 (FNC1)

403 Routing Code N3+X..30 (FNC1)

410 Ship to - Deliver to Global Location Number N3+N13

411 Bill to - Invoice to Global Location Number N3+N13

412 Purchased from Global Location Number N3+N13

413 Ship for - Deliver for - Forward to Global
Location Number

N3+N13

414 Identification of a Physical Location - Global
Location Number

N3+N13

415 Global Location Number of the Invoicing Party N3+N13

416 GLN of the production or service location N3+N13

417 Party GLN N3+N13

420 Ship to - Deliver to Postal Code Within a Single
Postal Authority

N3+X..20 (FNC1)

421 Ship to - Deliver to Postal Code with ISO
Country Code

N3+N3+X..9 (FNC1)

422 Country of Origin of a Trade Item N3+N3 (FNC1)

423 Country of Initial Processing N3+N3+N..12 (FNC1)

424 Country of Processing N3+N3 (FNC1)

425 Country of Disassembly N3+N3+N..12 (FNC1)

426 Country Covering full Process Chain N3+N3 (FNC1)

427 Country Subdivision of Origin N3+X..3 (FNC1)

4300 Ship-to / Deliver-to company name N4+X..35 (FNC1)

4301 Ship-to / Deliver-to contact N4+X..35 (FNC1)

4302 Ship-to / Deliver-to address line 1 N4+X..70 (FNC1)

4303 Ship-to / Deliver-to address line 2 N4+X..70 (FNC1)

4304 Ship-to / Deliver-to suburb N4+X..70 (FNC1)
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4305 Ship-to / Deliver-to locality N4+X..70 (FNC1)

4306 Ship-to / Deliver-to region N4+X..70 (FNC1)

4307 Ship-to / Deliver-to country code N4+X2 (FNC1)

4308 Ship-to / Deliver-to telephone number N4+X..30 (FNC1)

4310 Return-to company name N4+X..35 (FNC1)

4311 Return-to contact N4+X..35 (FNC1)

4312 Return-to address line 1 N4+X..70 (FNC1)

4313 Return-to address line 2 N4+X..70 (FNC1)

4314 Return-to suburb N4+X..70 (FNC1)

4315 Return-to locality N4+X..70 (FNC1)

4316 Return-to region N4+X..70 (FNC1)

4317 Return-to country code N4+X2 (FNC1)

4318 Return-to postal code N4+X..20 (FNC1)

4319 Return-to telephone number N4+X..30 (FNC1)

4320 Service code description N4+X..35 (FNC1)

4321 Dangerous goods flag N4+N1 (FNC1)

4322 Authority to leave N4+N1 (FNC1)

4323 Signature required flag N4+N1 (FNC1)

4324 Not before delivery date time N4+N10 (FNC1)

4325 Not after delivery date time N4+N10 (FNC1)

4326 Release date N4+N6 (FNC1)

7001 NATO Stock Number (NSN) N4+N13 (FNC1)

7002 UN/ECE Meat Carcasses and Cuts
Classification

N4+X..30 (FNC1)

7003 Expiration Date and Time N4+N10 (FNC1)

7004 Active Potency N4+N..4 (FNC1)

7005 Catch Area N4+X..12 (FNC1)

7006 First Freeze Date N4+N6

7007 Harvest Date N4+N6..12 (FNC1)

7008 Species for Fishery Purposes N4+X..3 (FNC1)

7009 Fishing Gear Type N4+N..10 (FNC1)

7010 Production Method N4+X..2 (FNC1)

7020 Refurbishment lot ID N4+X..20 (FNC1)

7021 Functional status N4+X..20 (FNC1)

149



5 DeskPack Essentials

7022 Revision status N4+X..20 (FNC1)

7023 Global Individual Asset Identifier (GIAI) of an
assembly

N4+X..30 (FNC1)

703s Number of Processor with ISO Country Code N4+N3+X..27 (FNC1)

7040 GS1 UIC with Extension 1 and Importer index N4+N1X2+X3+X4 (FNC1)

710 National Healthcare Reimbursement Number
(NHRN) – Germany PZN

N3+X..20 (FNC1)

711 National Healthcare Reimbursement Number
(NHRN) – France CIP

N3+X..20 (FNC1)

712 National Healthcare Reimbursement Number
(NHRN) – Spain CN

N3+X..20 (FNC1)

713 National Healthcare Reimbursement Number
(NHRN) – Brasil DRN

N3+X..20 (FNC1)

714 National Healthcare Reimbursement Number
(NHRN) - Portugal AIM

N3+X..20 (FNC1)

715 National Healthcare Reimbursement Number
for US Food & Drug Agency

N3+X..20 (FNC1)

723s (****) Certification reference N4+X2+X...28 (FNC1)

7240 Clinical Trial Protocol ID N4+X..20 (FNC1)

8001 Roll Products (Width, Length, Core Diameter,
Direction, Splices)

N4+N14 (FNC1)

8002 Cellular Mobile Telephone Identifier N4+X..20 (FNC1)

8003 Global Returnable Asset Identifier (GRAI) N4+N14+X..16 (FNC1)

8004 Global Individual Asset Identifier (GIAI) N4+X..30 (FNC1)

8005 Price Per Unit of Measure N4+N6 (FNC1)

8006 Identification of the Components of a Trade
Item

N4+N14+N2+N2 (FNC1)

8007 International Bank Account Number (IBAN) N4+X..34 (FNC1)

8008 Date and Time of Production N4+N8+N..4 (FNC1)

8010 Component / Part Identifier (CPID) N4 + X..30 (FNC1)

8011 Component / Part Identifier Serial Number
(CPID SERIAL)

N4 + N..12 (FNC1)

8012 Software version N4+X..20 (FNC1)

8013 Global Model Number (GMN) N4+X..30 (FNC1)

8017 Global Service Relation Number to identify the
relationship between an organisation offering
services and the provider of services

N4+N18 (FNC1)
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8018 Global Service Relation Number to identify the
relationship between an organisation offering
services and the recipient of services

N4+N18 (FNC1)

8019 Service Relation Instance Number (SRIN) N4+N..10 (FNC1)

8020 Payment Slip Reference Number N4+X..25 (FNC1)

8026 ITIP of contained pieces N4+N18

8110 Coupon Code Identification for Use in North
America

N4+X..70 (FNC1)

8111 Loyalty points of a coupon N4+N4 (FNC1)

8112 Paperless coupon code identification for use
in North America

N4+X..70 (FNC1)

8200 Extended Packaging URL N4+X..70 (FNC1)

90 Information Mutually Agreed Between Trading
Partners

N2+X..30 (FNC1)

91 to 99 Company Internal Information N2+X..30 (FNC1)

Notes
• *: The first position indicates the length (number of digits) of the GS1 Application Identifier. The

following value refers to the format of the data content.

The following convention is applied:

n implied decimal point position

N numeric digit

X any character

N3 3 numeric digits, fixed length

N..3 up to 3 numeric digits

X..3 up to 3 characters

• **: If only year and month are available, DD must be filled with two zeroes.

• ***: The fourth digit of this GS1 Application Identifier indicates the implied decimal point position.
Example:

• 3100 Net weight in kg without a decimal point
• 3102 Net weight in kg with two decimal points

• FNC1: All GS1 Application Identifiers indicated with (FNC1) are defined as of variable length and shall
be delimited unless this Element String is the last one to be encoded in the symbol. The delimiter
shall be a Function 1 Symbol Character in GS1-128 Symbology, GS1 DataBar Expanded Versions and
GS1 Composite Symbology and should be a Function 1 Symbol Character in GS1 DataMatrix and GS1
QR Code Symbology.

• ****: The fourth digit of this AI indicates the sequence number, allowing multiple occurrences of
this AI

• *****: All GS1 Application Identifiers indicated with (FNC1) are defined as of variable length and shall
be delimited unless this Element String is the last one to be encoded in the symbol. The delimiter

151



5 DeskPack Essentials

shall be a Function 1 Symbol Character in GS1-128 Symbology, GS1 DataBar Expanded Versions and
GS1 Composite Symbology and should be a Function 1 Symbol Character in GS1 DataMatrix and GS1
QR Code Symbology.

5.7.2.  Barcode Types

To create a barcode of a specific type, select it in the Barcode Type parameter. This displays
parameters specific to this barcode type in the Dynamic Barcodes dialog.

2 of 5

About this Barcode...
2 of 5 is a numeric self-checking barcode, which can have a variable length. This barcode only encodes
data in the bars. It is used for industrial applications, article numbering, photo development and
ticketing.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Characters per unit on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Box on page 208

• Stroke Weight: Bearer Bars on page 209
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Bobst

About this Barcode...
The Bobst barcode is part of the same "binary" barcode family as the Laetus Pharma Code, Kurandt and
CLF-8. It is used in the pharmaceutical industry.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Wide Bar on page 204

• Gap on page 204

• Decimal Input on page 205

• Box on page 208

CIP 39

About this Barcode...
Code 39 is a barcode based on the standard Code 39 barcode, used by the French pharma industry. The
barcode accepts 7 (CIP7) or 13 (CIP13) digits. The last digit is a check digit; if 6 or 12 digits are entered,
the check digit is added automatically. The CIP13 code must start with 340.
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Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Narrow Bar on page 204

• Box on page 208

CLF-8

About this Barcode...
The CLF-8 barcode is part of the same "binary" barcode family as the Laetus Pharma Code, Kurandt and
Bobst barcode. It is used in the pharmaceutical industry.

 

 

Parameters
General Parameters
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• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Wide Bar on page 204

• Gap on page 204

• Decimal Input on page 205

Codabar

About this Barcode...
The Codabar barcode is commonly used in libraries, blood banks, and the air parcel business. It can
encode up to 126 characters of data and two control characters, using digits and the “-”, “$”, “:”, “/” and
“+” characters.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200
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• Vertical Offset on page 200

Additional Parameters

• Rational (Constant Bar Width): By enabling this option, you can create a "Rational" Codabar bar
code.

• Use “992” Prod. Family in UPC on page 200

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Characters per unit on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Box on page 208

Code 128

About this Barcode...
Code 128 is a variable length, high density, alphanumeric barcode. It has the second highest density of
all the 1D barcodes (after the GS1 Databar Expanded).

It can contain a set of control characters. These control characters can change the character encoding
type. In the absence of control characters, the encoding type is chosen automatically, to optimize the
content encoding.

To force the usage of the code-set A, precede your data with the [a] control character. To force
the usage of the code-set B, precede your data with the [b] control character. To obtain an optimal
utilization of the code-sets A and B but prevent the usage of the space saving code-set C, use the Code
128 (long) barcode type instead.

You can include FNC characters in your code by entering [F1] for FNC1, [F2] for FNC2 or [F3] for
FNC3

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Light Margin Indicator on page 199
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• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Characters per unit on page 202

• Narrow Bar on page 204

• Width on page 204

• Box on page 208

• Stroke Weight: Bearer Bars on page 209

Code 128 (long)

About this Barcode...
Code 128 (long) is a version of Code 128 that doesn't use the space-saving “C” character set. This makes
Code 128 (long) barcodes generally longer.

You can include FNC characters in your code by entering [F1] for FNC1, [F2] for FNC2 or [F3] for
FNC3

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Light Margin Indicator on page 199

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201
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• Device Compensation on page 201

• Height on page 202

• Characters per unit on page 202

• Narrow Bar on page 204

• Width on page 204

• Box on page 208

• Stroke Weight: Bearer Bars on page 209

Code 39

About this Barcode...
Code 39 is a popular barcode in industrial barcoding systems, mainly in the U.S.A. It is used in the
non-retail industry, particularly in the manufacturing, military, and health sectors. It can encode
alphanumeric data.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Characters per unit on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Add Check Digit on page 206
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• Box on page 208

Code 93

About this Barcode...
Code 93 is a variable length, high density, alphanumeric barcode. It's an enhancement of the Code 93
using spaces as well as bars as a data carrier. It contains two check characters for higher data security.
The Code 93 barcode allows encoding the first 128 characters of the ASCII table.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Characters per unit on page 202

• Narrow Bar on page 204

• Box on page 208

• Stroke Weight: Bearer Bars on page 209

DataMatrix

About this Barcode...
DataMatrix is used for encoding large amounts of alphanumeric data and / or marking small objects. It
can encode all the standard ASCII and extended ASCII characters.

The DataMatrix symbol size can adjust automatically depending on the amount of data.
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Dynamic Barcodes doesn't generate human readable characters for DataMatrix symbols. The data to be
encoded in a DataMatrix symbol can contain an FNC1 character but only at the beginning of the data.

Note:  Dynamic Barcodes always generates DataMatrix symbols with the recommended
ECC200 error correction scheme.

 

 

DataMatrix Macro functions
Using DataMatrix Macro sequences, you can reduce the amount of data to encode by omiting obvious
headers and trailers. The structured data uses control characters, entered using their standard
abbreviations between "<" and ">"

The Macro sequence contains different parts:

• The optional Macro header: [)>. This is optional, and can be omited

• One of the starting sequences: <RS>05<GS> or <RS>06<GS>

• The macro content in a structured format

• The ending sequence: <RS><EOT>

Here are a few examples of a valid Macro function:

• [)><RS>05<GS>PAP16559-2<GS>S0<72>017<GS>IPWP4511<RS><EOT>

• <RS>05<GS>PAP16559-2<GS>S0<72>017<GS>IPWP4511<RS><EOT>

Note that apart from the Macro functions, you can enter all control characters to a DataMatrix code.
These are all accepted codes:

<NUL><SOH><STX><ETX><EOT><ENQ><ACK><BEL><BS><HT><LF><VT><FF><CR><SO><SI><DLE><DC1><DC2><DC3><DC4><NAK><SYN><ETB><CAN><EM><SUB><ESC><FS><GS><RS><US>

Note:  If you want to use one of the control character substitutions literally (e.g. "<EOT>") it can
be escaped by doubling the first character: <<EOT>

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Symbol Type on page 206

• Cell Size or Cell Width/Height on page 206

• Width / Total Height on page 207
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• Box on page 208

EAN 8

About this Barcode...
EAN 8 is an abbreviated version of EAN 13, for use on smaller packages. It can encode eight digits, and
can have two or five additional digits.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Light Margin Indicator on page 199

• Add-on Text On Top on page 200

• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Magnification on page 201

• Height on page 202

• Snap Bars to Output Resolution on page 205

• Box on page 208

EAN 13

About this Barcode...
European Article Numbering system or EAN is the standard for article numbering in Europe. It is also
used in Japan where it is called JAN.
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Note:  EAN is the European equivalent of the UPC system in the U.S.A. and Canada. Both
systems use the same size requirements and a similar encoding scheme. This means that most
European and American retail barcode scanners can read both EAN and UPC barcodes. For
more information on UPC, see UPC-A on page 194.

 

 

An EAN 13 is a numeric barcode of thirteen digits, and can have two or five additional digits.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Light Margin Indicator on page 199

• Add-on Text On Top on page 200

• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Magnification on page 201

• Height on page 202

• Snap Bars to Output Resolution on page 205

• Box on page 208
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EAN 13 Swissmedic

About this Barcode...
EAN 13 Swissmedic is an EAN 13 barcode used for items licensed by the Swiss Agency for Theraputic
Products

It always starts with "7680", uses a specific text positioning and adds the text "swissmedic" below the
code.

For EAN 13 Swissmedic barcodes, only the default font settings can be used.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Magnification on page 201

• Height on page 202

• Snap Bars to Output Resolution on page 205

• Box on page 208

Eberle

About this Barcode...
Eberle is a barcode using two bar and two space thicknesess to encode the data. The input can be both
in decimal and quarternal numerical systems. In the quarternal numerical system the barcode allows
numbers up to 30 digits (0, 1, 2 or 3).

In non-decimal mode, the minimal number is "0", while in decimal mode it is 1. Decimal "0" is not
allowed.
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Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Narrow Bar on page 204

• Decimal Input on page 205

• Box on page 208

GS1 128

About this Barcode...
GS1 128 (formerly EAN 128) is a Code 128 barcode designed primarily to identify products.

It contains one or more FNC1 (GS1 Function Code 1) control characters and Application Identifiers. It
shows parentheses around the human readable interpretation of the Application Identifiers, but those
parentheses are not encoded in the barcode.

 

 

It is alphanumeric and can also contain composite symbols.
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Parameters
General Parameters

• Rotation on page 197

• Code on page 197

• Composite Component on page 198

Text Parameters

• Add Human Readable Characters on page 198

• Put on Top on page 199

• Multiple Text Lines on page 199

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Narrow Bar on page 204

• Snap Bars to Output Resolution on page 205

• Box on page 208

• Stroke Weight: Bearer Bars on page 209

GS1 DataBar Omnidirectional

About this Barcode...
Barcodes of the GS1 DataBar family (formerly Reduced Space Symbols or RSS) can identify small items,
and encode more information than the current EAN or UPC barcodes.

They can include GS1 Application Identifiers such as serial numbers, lot numbers, expiration dates...

Note:  GS1 DataBar codes are expected to replace most common EAN and UPC barcodes from
2010.
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GS1 DataBar Omnidirectional encodes Global Trade Item Numbers (GTIN) in a linear symbol that can be
scanned omnidirectionally by suitably programmed slot scanners.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

• Composite Component on page 198

Text Parameters

• Add Human Readable Characters on page 198

• Put on Top on page 199

• Multiple Text Lines on page 199

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Narrow Bar on page 204

• Snap Bars to Output Resolution on page 205

GS1 DataBar Stacked

About this Barcode...
GS1 DataBar Stacked is a variation of the GS1 DataBar barcode, that is stacked in two rows and used
when the normal barcode would be too wide for the product.
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Parameters
General Parameters

• Rotation on page 197

• Code on page 197

• Composite Component on page 198

Text Parameters

• Add Human Readable Characters on page 198

• Multiple Text Lines on page 199

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Narrow Bar on page 204

• Snap Bars to Output Resolution on page 205

GS1 DataBar Stacked Omnidirectional

About this Barcode...
GS1 DataBar14 Stacked Omnidirectional is taller version of GS1 DataBar14 Stacked, that can be read by
omnidirectional scanners.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

• Composite Component on page 198
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Text Parameters

• Add Human Readable Characters on page 198

• Put on Top on page 199

• Multiple Text Lines on page 199

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Narrow Bar on page 204

• Snap Bars to Output Resolution on page 205

GS1 DataBar Truncated

About this Barcode...
GS1 DataBar Truncated (formerly RSS Limited) is similar to GS1 DataBar but the height of its bars is
truncated.

It encodes Global Trade Item Numbers in a smaller symbol for use on small items. It cannot be scanned
omnidirectionally.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

• Composite Component on page 198

Text Parameters

• Add Human Readable Characters on page 198

• Put on Top on page 199

• Multiple Text Lines on page 199

• Font Family, Style and Size on page 200
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• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Narrow Bar on page 204

• Snap Bars to Output Resolution on page 205

GS1 DataBar Expanded

About this Barcode...
GS1 DataBar Expanded (formerly RSS Expanded) encodes regular barcode data (“primary item
identification” data) and Application Identifiers. It can encode alphanumeric characters.

This barcode can be scanned omnidirectionally by suitably programmed slot scanners.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

• Composite Component on page 198

Text Parameters

• Add Human Readable Characters on page 198

• Put on Top on page 199

• Multiple Text Lines on page 199

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Narrow Bar on page 204
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• Snap Bars to Output Resolution on page 205

GS1 DataBar Expanded Stacked

About this Barcode...
GS1 DataBar Expanded Stacked can encode the same amount of data as GS1 DataBar Expanded, but
can also “stack” the barcode into several rows to save space.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

• Composite Component on page 198

Text Parameters

• Add Human Readable Characters on page 198

• Put on Top on page 199

• Multiple Text Lines on page 199

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Max. Row Width on page 200

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Narrow Bar on page 204

• Snap Bars to Output Resolution on page 205
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GS1 DataBar Limited

About this Barcode...
GS1 Databar Limited is smaller than the GS1 DataBar barcode and can only encode Global Trade Item
Numbers whose data part starts with “1”.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

• Composite Component on page 198

Text Parameters

• Add Human Readable Characters on page 198

• Put on Top on page 199

• Multiple Text Lines on page 199

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Narrow Bar on page 204

• Snap Bars to Output Resolution on page 205

GS1 DataMatrix

About this Barcode...
The GS1 Data Matrix barcode is a high density, high capacity, scalable 2D barcode. It is used to
concentrate a lot of (alphanumeric) information in a very small space.
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Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Put on Top on page 199

• Multiple Text Lines on page 199

• Light Margin Indicator on page 199

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Symbol Type on page 206

• Cell Size or Cell Width/Height on page 206

• Width / Total Height on page 207

• Box on page 208

GS1 QR

About this Barcode...
The GS1 QR barcode is a high density, high capacity, scalable 2D barcode. It is used to assembly
multiple GS1 Application Identifiers to a barcode with limited space needs. The GS1 QR barcode can
contain numbers, 0 - 9, upper case letters A -Z, and nine special characters: space $ % * + - . /

For more technical information on the QR code, see QR on page 190

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Put on Top on page 199
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• Multiple Text Lines on page 199

• Light Margin Indicator on page 199

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Symbol Type on page 206

• Cell Size or Cell Width/Height on page 206

• Width / Total Height on page 207

• Box on page 208

Specific Parameters
Minimum Symbol Size

Choose the number of cells to use for your barcode (in the format “horizontal cells x vertical cells”).

Note:  If the number of cells you choose for your symbol is too small to encode the data you
entered in Code, Dynamic Barcodes will use a bigger symbol size automatically.

Error Correction

Error correction adds check sums to the barcode to detect and correct incorrect data. You can
choose one of the following Error correction levels:

• Level L: 7% of codewords can be restored.

• Level M: 15% of codewords can be restored.

• Level Q: 25% of codewords can be restored.

• Level H: 30% of codewords can be restored.

Note:  Keep in mind that a higher correction level makes the barcode bigger (as more check
sums are added to the barcode) and may limit the maximum length of the encoded data.

Width / Height

The Width and Height parameters depend on the Cell Size and the number of cells used for the symbol
(Minimum Symbol Size).

For example, a symbol of 25 x 25 cells where each cell is 2 mm gives a Width and Height of 50 x 50 mm.

GS1 U.S. Coupon Interim

About this Barcode...
GS1 U.S. Coupon Interim is an interim coupon barcode. It is used during the transition between UPC-A
coupons and the new GS1 Databar Expanded Stacked coupons, that can encode more information.
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It is made of both an old UPC-A coupon barcode, and a new Databar Expanded Stacked coupon
barcode, to be readable by both old and new scanners.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

Additional Parameters

• Use “992” Prod. Family in UPC on page 200

• Max. Row Width on page 200

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Magnification on page 201

• Narrow Bar on page 204

• Gap on page 204

• Vertical alignment on page 205

HIBC 128

About this Barcode...
This barcode is based on the Code 128 symbology.

It encodes the organization's primary and / or secondary Labeler Identification Code (LIC). This
encoding begins with the “+” character. If both primary and secondary Labeler Identification Codes are
encoded in one barcode, they are divided by the “/” character.
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Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Characters per unit on page 202

• Narrow Bar on page 204

• Width on page 204

• Box on page 208

• Stroke Weight: Bearer Bars on page 209

HIBC 39

About this Barcode...
This barcode is based on the Code 39 symbology.

It encodes the organization's primary and / or secondary Labeler Identification Code (LIC). This
encoding begins with the “+” character. If both primary and secondary Labeler Identification Codes are
encoded in one barcode, they are divided by the “/” character.

 

 

Parameters
General Parameters

• Rotation on page 197
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• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Characters per unit on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Box on page 208

ITF-14

About this Barcode...
ITF-14 is a standardized version of the Interleaved 2 of 5 barcode, containing 14 digits, the last being a
check digit.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Text Format on page 201
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• Bar Width Reduction on page 201

• Device Compensation on page 201

• Magnification on page 201

• Height on page 202

• Snap Bars to Output Resolution on page 205

• Total Height on page 207

• Smax / Smin on page 207

• Box on page 208

ITF-16

About this Barcode...
ITF-16 is a standardized version of the Interleaved 2 of 5 barcode, containing 16 digits, the last being a
check digit.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Text Format on page 201

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Magnification on page 201
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• Height on page 202

• Snap Bars to Output Resolution on page 205

• Total Height on page 207

• Smax / Smin on page 207

• Box on page 208

Interleaved 2 of 5

About this Barcode...
Interleaved 2 of 5 (or Int. 2 of 5) is a barcode originally used for transportation packaging, that can have
any even number of digits. Since this type of packaging consists mainly of cardboard boxes printed in
low quality, the Interleaved 2 of 5 barcode is more tolerant to distortion than other barcodes.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Characters per unit on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Box on page 208

• Stroke Weight: Bearer Bars on page 209
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Klebrand

About this Barcode...
Klebrand is a barcode used in the packaging industry. It uses four different bar thicknesess to encode
the data. The barcode uses the quarternal numerical system and each bar thickness represents one of
four numbers allowed in the non-decimal input (0, 1, 2 and 3). It can have up to 30 bars. The input can be
both in decimal and quarternal numerical systems.

• In non-decimal (quarternal) mode all digits are encoded, including any leading zeroes. For example
"0031" is encoded to 4 bars.

• In decimal mode you can define the number of bars in total, by enter e.g. "6/4". The first number
(6) defines the total number of bars, the second (4) defines the value to be encoded. If you you
enter a single number without defining the number of bars, the minimal number of bars needed
for the value is used, and the code is adjusted accordingly. If you for example enter "9", the value
will change to "4/9", as you need at least 4 bars to encode this value. The text below the barcode (if
enabled) only shows the decimal value itself.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Wide Bar on page 204

• Gap on page 204

• Decimal Input on page 205
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• Box on page 208

Kurandt

About this Barcode...
The Kurandt barcode is part of the same "binary" barcode family as the Laetus Pharma Code, Bobst and
CLF-8. It is used in the pharmaceutical industry.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Wide Bar on page 204

• Gap on page 204

• Decimal Input on page 205

• Box on page 208

Laetus Pharma Code

About this Barcode...
The Laetus Pharma Code is part of the same barcode family as the Kurandt, Bobst and CLF-8 barcode.
It was developed specifically to meet the requirements of the pharmaceutical packaging process.
It has established itself as the worldwide pharmaceutical industry barcode standard. It can encode
numeric or binary data.
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Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Miniature: Use this option to create a miniature version of the bar code

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Wide Bar on page 204

• Gap on page 204

• Decimal Input on page 205

• Box on page 208

M+S 7

About this Barcode...
The M+S 7 barcode is an EAN 8 barcode modified by Marks & Spencer's, for use on own-brand products
sold in their stores.

To make the M+S 7 barcode, the initial “0” is removed and the extra letters “M” and “S” are added to the
human readable characters.

This means that the human readable characters contain seven digits plus the “M” and “S” letters.

Note:  This doesn't affect the data encoded in the barcode (it still encodes eight digits), so you
should enter eight digits when creating a M+S 7 barcode.
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Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Magnification on page 201

• Height on page 202

• Snap Bars to Output Resolution on page 205

• Box on page 208

MSI

About this Barcode...
MSI, also known as Modified Plessey, was developed by the MSI Data Corporation, based on the original
Plessey Code. It is a numeric barcode used primarily to mark retail shelves for inventory control.

 

 

Parameters
General Parameters
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• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Characters per unit on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Box on page 208

Marks & Spencer's

About this Barcode...
The Marks & Spencer's barcode is also an EAN 8 barcode modified by Marks & Spencer's for use on
own-brand products.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198
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• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Magnification on page 201

• Height on page 202

• Snap Bars to Output Resolution on page 205

• Box on page 208

NDC / HRI

About this Barcode...
The NDC / HRI barcode is a variant of the UPC barcode with special human readable interpretation
formats compliant to the US National Drug Code definition.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Text Format on page 201

• Bar Width Reduction on page 201
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• Device Compensation on page 201

• Magnification on page 201

• Height on page 202

• Snap Bars to Output Resolution on page 205

• Box on page 208

Paraf Italy

About this Barcode...
This barcode is a variant of Code 39 used by the Italian Health and Cosmetics Industry. It is also called
Code 32.

 

 

Use Code Base32 when your barcode data is encoded in the Base 32 format. This format uses case-
insensitive alphanumeric characters to encode data.

Use Code Base10when your barcode data is in decimal format. Paraf Italy barcodes in decimal format
should start with an “A” (included automatically by Dynamic Barcodes), have 8 digits of data and end
with a check digit (calculated automatically by Dynamic Barcodes).

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Narrow Bar on page 204

• Box on page 208

PDF417

About this Barcode...
PDF417 is a 2D barcode mainly used in security printing (passports, identity cards, driving licences...).

It is a “self-checking” barcode that can have different levels of error correction.
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It can encode data using one of three “compaction” modes: Text (to encode all alphanumeric and
punctuation characters in the ISO-8859-1 character set), Numeric (to encode only numeric characters)
or Binary (to encode 8-bit characters).

It can use the three compaction modes in a single barcode if necessary, but you can choose to disable
the Text and/or Numeric compaction modes.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Narrow Bar on page 204

• Box on page 208

Specific Parameters
Columns
You can give your barcode between 1 and 30 Columns. The number of columns corresponds to the
number of PDF417 codewords.

Rows
You can give your barcode between 3 and 90 Rows.

Truncated
Choose Truncated to make the symbol less wide by truncating the end character (which is not part of
the encoded data) and the end pattern. In the example below, the top PDF417 barcode is not truncated,
and the bottom barcode is truncated (but encodes the same data).
 

 

Initialize in Alpha Submode
Choose this option to generate a “shift to Text mode” character at the beginning of the barcode when
using Text compaction mode. This makes the encoding clear for barcode scanners.

Allow Text Compaction
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Choose this to let Dynamic Barcodes switch to Text compaction mode automatically when your
barcode contains text data.

This encodes the text data in your barcode more eciently (it makes that part of your barcode
smaller).

Allow Numeric Compaction

Choose this to let Dynamic Barcodes switch to Numeric compaction mode automatically when your
barcode contains numeric data.

This encodes the numeric data in your barcode more eciently.

Note:

Dynamic Barcodes can always switch to the Binary compaction mode if your barcode
contains binary data.

If you don't enable either Allow Text Compaction or Allow Numeric Compaction, Dynamic
Barcodes will only use Binary compaction mode.

Error Correction Level

Error correction adds check sums to the barcode to detect and correct incorrect data. You can
choose an Error correction level from 0 to 8.

The higher the correction level, the more check sums are added to the barcode and the more incorrect
data can be corrected. Keep in mind that a higher correction level makes the barcode bigger and may
limit the maximum length of the encoded data.

Note:  Level 0 means that there is only one check sum added to the data, so incorrect data
can be detected but not corrected.

You can choose Automatic to let the plug-in pick the best error correction level for the data encoded.

MicroPDF417

About this Barcode...
MicroPDF417 is a 2D multi-row barcode derived from PDF417, for use on smaller areas. It can encode up
to 150 bytes.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201
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• Height on page 202

• Narrow Bar on page 204

• Snap Bars to Output Resolution on page 205

• Box on page 208

Specific Parameters
Columns
You can give your barcode between 1 and 4 Columns.

Rows
You can give your barcode between 4 and 44 Rows.

Allow Text Compaction

Choose this to let Dynamic Barcodes switch to Text compaction mode automatically when your
barcode contains text data.

This encodes the text data in your barcode more eciently (it makes that part of your barcode
smaller).

Allow Numeric Compaction

Choose this to let Dynamic Barcodes switch to Numeric compaction mode automatically when your
barcode contains numeric data.

This encodes the numeric data in your barcode more eciently.

Note:

Dynamic Barcodes can always switch to the Binary compaction mode if your barcode
contains binary data.

If you don't enable either Allow Text Compaction or Allow Numeric Compaction, Dynamic
Barcodes will only use Binary compaction mode.

PZN

About this Barcode...
The PZN (Pharma-Zentral-Nummer) barcode is used for distribution of pharmaceutical and healthcare
products in Germany. The PZN code is written in the format “PZN-nnnnnnn” but only the numeric part
including the leading dash is encoded.

 

 

Parameters
General Parameters
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• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Size on page 202

• Height on page 202

• Characters per unit on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Box on page 208

PZN8

About this Barcode...
The PZN8 (Pharma-Zentral-Nummer) barcode is used for distribution of pharmaceutical and
healthcare products in Germany. The PZN code is written in the format “PZN-nnnnnnnn” but only the
numeric part including the leading dash is encoded.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters
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• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Size on page 202

• Height on page 202

• Characters per unit on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Box on page 208

QR

About this Barcode...
The QR barcode is a 2-dimensional barcode used for commercial tracking and convenience-oriented
applications aimed at mobile phone users (known as "mobile tagging").

QR codes storing addresses and URLs may appear in magazines, on signs, buses, business cards, or
other objects... Users with a camera phone equipped with the correct reader application can scan the
QR code to display text, contact information, connect to a wireless network, or open a web page in the
phone's browser.

 

 

QR codes have the following structure:
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•

 Position pattern (required)

•

 Alignment pattern (required)

•

 Timing pattern (required)

•
 Version information

•
 Format information

•
 Data and error correction keys

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Cell Size or Cell Width/Height on page 206

• Width / Total Height on page 207

• Box on page 208

Specific Parameters
Minimum Symbol Size

Choose the number of cells to use for your barcode (in the format “horizontal cells x vertical cells”).

Note:  If the number of cells you choose for your symbol is too small to encode the data you
entered in Code, Dynamic Barcodes will use a bigger symbol size automatically.

Error Correction

Error correction adds check sums to the barcode to detect and correct incorrect data. You can
choose one of the following Error correction levels:

• Level L: 7% of codewords can be restored.

• Level M: 15% of codewords can be restored.
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• Level Q: 25% of codewords can be restored.

• Level H: 30% of codewords can be restored.

Note:  Keep in mind that a higher correction level makes the barcode bigger (as more check
sums are added to the barcode) and may limit the maximum length of the encoded data.

Width / Height

The Width and Height parameters depend on the Cell Size and the number of cells used for the symbol
(Minimum Symbol Size).

For example, a symbol of 25 x 25 cells where each cell is 2 mm gives a Width and Height of 50 x 50 mm.

MicroQR

About this Barcode...
The Micro QR Code is a very small QR Code for use on smaller spaces (for example to encode the ID of
printed circuit boards and electronics parts).

It works with smaller amounts of data (maximum 35 numeric characters), and uses only one position
pattern.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Cell Size or Cell Width/Height on page 206

• Width / Total Height on page 207

• Box on page 208

Specific Parameters
Minimum Symbol Size

Choose the number of cells to use for your barcode (in the format “horizontal cells x vertical cells”).

Note:  If the number of cells you choose for your symbol is too small to encode the data you
entered in Code, Dynamic Barcodes will use a bigger symbol size automatically.

Error Correction
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Error correction adds check sums to the barcode to detect and correct incorrect data. You can
choose one of the following Error correction levels:

• Level L: 7% of codewords can be restored.

• Level M: 15% of codewords can be restored.

• Level Q: 25% of codewords can be restored.

• Level H: 30% of codewords can be restored.

Note:  Keep in mind that a higher correction level makes the barcode bigger (as more check
sums are added to the barcode) and may limit the maximum length of the encoded data.

Width / Height

The Width and Height parameters depend on the Cell Size and the number of cells used for the symbol
(Minimum Symbol Size).

For example, a symbol of 15 x 15 cells where each cell is 2 mm gives a Width and Height of 30 x 30 mm.

SICK Code

About this Barcode...
SICK is a bar code used in the German packaging industry. It's a binary bar code, using a thick bar for a
0, and a thin bar for a 1. It can have up to 12 bars. It can encode numeric or binary data.

• In binary mode all digits are encoded including leading zeroes, ie. "0001" is encoded as a three thin
and one thick bar.

• In decimal mode you can define the number of bars in total, by enter e.g. "6/4". The first number (6)
defines  the total number of bars, the second (4) defines the valueto be encoded. If you don't define
the number of bars, in other words if you enter a single number, the minimal number of bars needed
for the value is used, and the code is adjusted accordingly. If you for example enter "9", the value will
change to "4/9", as you need at least 4 bars to encode this value.

• The defaults follow the mostly used standard "Codetype A", for generating the "Codetype B" should
be changed the barcode parameters as following: Narrow Bar to 1.25mm (from 0.5mm), Wide Bar to
3.75mm (from 1.5mm) and Gap to 2.5mm (from 1mm)

By default, the values for the Narrow Bar (0.5mm), Wide Bar (1.5mm) and Gap (1mm) are set for the
mostly used standard "Codetype A". If you want to generate a SICK code using "Codetype B", you should
set the Narrow Bar to 1.25mm, the Wide Bar to 3.75mm and the Gap to 2.5mm

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters
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• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Alignment on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Height on page 202

• Ratio on page 204

• Narrow Bar on page 204

• Wide Bar on page 204

• Gap on page 204

• Decimal Input on page 205

• Box on page 208

UPC-A

About this Barcode...
Universal Product Code or UPC is the standard for article numbering in the U.S.A. and Canada. It is
similar to the EAN system and compatible with it. For more information on EAN, see EAN 13 on page
161.

 

 

UPC-A is a numeric barcode of up to twelve digits, plus two or five additional digits.
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Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Magnification on page 201

• Height on page 202

• Snap Bars to Output Resolution on page 205

• Box on page 208

UPC-E

About this Barcode...
UPC-E is an abbreviated version of UPC-A, for use on smaller packages. It is a numeric barcode of
eight digits, with an optional 2 or 5 digits add-on. You can also directly enter the 12-digit code of UPC-A
codes that can be represented in 8 digits.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200
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• Vertical Offset on page 200

Additional Parameters

• Bar Width Reduction on page 201

• Device Compensation on page 201

• Magnification on page 201

• Height on page 202

• Snap Bars to Output Resolution on page 205

• Box on page 208

UPC-SCS

About this Barcode...
The UPC–SCS (Shipping Container Symbol) barcode is a version of the Interleaved 2 of 5 barcode that
has a structure very similar to the Universal Product Code's (UPC) and specific formatting of the human
readable interpretation.

 

 

Parameters
General Parameters

• Rotation on page 197

• Code on page 197

Text Parameters

• Add Human Readable Characters on page 198

• Font Family, Style and Size on page 200

• Vertical Offset on page 200

Additional Parameters

• Text Format on page 201

• Bar Width Reduction on page 201
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• Device Compensation on page 201

• Magnification on page 201

• Height on page 202

• Snap Bars to Output Resolution on page 205

• Total Height on page 207

• Box on page 208

• Stroke Weight: Bearer Bars on page 209

5.7.3.  Barcode Parameters

Rotation
To rotate your barcode by 90, 180 or 270 degrees, use the Rotation buttons.

 

 

To rotate it by any other angle, enter that angle in the Rotation field.

Code
Enter the data to encode in your bar code.

Dynamic Barcodes checks that the data you have entered is valid for your chosen Barcode Type. If it
isn't, a warning / error will pop up.

Code for GS1 Bar Codes
When entering data to be encoded in GS1 bar codes, you can either enter Application Identifiers (AI)
including the brackets, or you can enter the code without brackets, using FNC1 code at the end of
each variable-length element in the data. The FNC1 code will be represented by [F1] when entering the
code (with an exception for the GS1 DataMatrix barcode, which also allows the ASCII 29 <GS> control
character as a seprator).While entering GS1 data, following remarks should be taken into account:

• Do not add the mandatory FNC1 character at the beginning of the data. Dynamic Barcodes will add it
automatically.

• For GS1 bar codes intended for encoding AI (01) only, AI has to be omitted, i.e. don't enter '01' at the
beginning. It doesn't matter if entered with or without brackets.

• The Composite Component can be created using the same rules for using brackets and [F1]. It's not
necessary to keep the same way of entering the Composite Component and the main code.

• If you don't use brackets for entering AI, type [F1] at the end of each variable-length element in the
data, to represent a FNC1 terminating character, except when the variable-length element is placed
at the end of the whole code.
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• You don't need to type [F1] at the end of fixed-length elements.

• Do not mix using [F1] as terminators of variable AI and entering brackets around the AI.

 

 

Dynamic Barcodes also checks the validity of the Application Identifiers you enter in the Code and / or
in the Composite Component of GS1 bar codes.

Composite Component
A Composite Component is a 2D symbol placed on top of a GS1 barcode, that encodes extra
information (batch number, expiration date...).

If you want your barcode to have a Composite Component, enter the (alphanumeric) data to encode in
this field.

Note:  Dynamic Barcodes checks the data you enter for the Composite Component (for
example to see if the Application Identifiers you entered are correct), and displays a warning if
it is invalid.
 

 

Add Human Readable Characters
This parameter adds “human readable” characters (numeric or alphanumeric characters) under your
barcode.

This is the same barcode with and without human readable characters:
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Put on Top
This parameter allows you to put the Human Readable Characters above instead of below the barcode
bars.

Multiple Text Lines
Select this parameter if you want the human readable characters to be printed on multiple lines below
the barcode. Dynamic Barcodes will start a new line for every element of the barcode data (starting
with the Application Identifier).

 

 

Note:  When opening your document in PackEdge, the characters will be placed back on a
single line.

Light Margin Indicator
This parameter adds “<“ and “>” signs (or only “>” depending on the barcode type) at the bottom of your
barcode. This indicates the width the barcode should have for optimal reading.

 

 

Note:  When creating a bar code, the current Light Margin Indicator setting is stored for the
specific barcode type. This means that the next time you select the same barcode type (e.g.
when creating a new barcode of that same type) the Light Margin Indicator setting will be
adjusted.
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Add-on Text On Top
This parameter allows you to put the add-on HRI text above instead of below the barcode bars. By
default, this option is enabled.

Font Family, Style and Size
These options can be used to define the font family, style and size to be used for the human readable
characters. By choosing [default font], all other Text Parameters are disabled, as the default values
are used.

Note:  If the font used in a bar code is not available when opening the file, Adobe Illustrator will
warn about a missing font. You can however only fix the problem using the Dynamic Barcode
palette, since Adobe Illustrator's "Find Font" feature can not be used.

Alignment
When using human readable characters, in combination with custom font settings, you can set text
alignment to Left, Center or Right.

Vertical Offset
This parameter allows you to add extra space between your barcode bars and the human readable
characters.

 

 

Note:  When opening your document in PackEdge, the characters will be placed just below the
bars again.

Use “992” Prod. Family in UPC
Enable this parameter to use the special “992” product family in your barcode (for specific offers like
discounts on the customer's next purchase or on variable weight items...).

Max. Row Width
Use this parameter to define how many segments of data (groups of bars encoding several digits) can
fit in one row. If the barcode contains more segments, they will be stacked.

In the example below, the first barcode has a Max. Row Width of 8 segments. When reducing this to
4 segments, the segments that don't fit in the row width anymore are stacked, forming a second row
(second barcode).
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The GS1 Max Row Width parameter applies to the GS1 Databar Expanded Stacked component of the GS1
U.S. Coupon Interim barcode.

Text Format
Choose a text format for the human readable characters of your barcode.

For NDC/HRI barcodes, you can choose a variant of the U.S. National Drug Code.

For ITF-14, ITF-16 and UPC-SCS barcodes, you can choose a variant of the Shipping Container Symbol.

Bar Width Reduction
Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Your printer or customer will usually provide you with the value to use. For example if your printer tells
you that the line width will increase by 0.01mm, you should use a Bar Width Reduction value of 0.01
mm.

You can enter the Bar Width Reduction in microns, milliinches (“mil”), millimeters or inches.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation
Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

You can enter the Device Compensation in microns, milliinches (“mil”), millimeters or inches.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, Dynamic
Barcodes will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Magnification
Use this parameter to increase or decrease the barcode size proportionally.

In the example below, you can see the same barcode at 80%, 100% and 120% magnification.
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Size
Choose to give your PZN barcode a Small, Normal or Large size. Those are predefined sizes for this
barcode. The actual Height, Characters per unit, Ratio and Narrow Bar values are shown underneath.

By selecting Custom, you can manually edit these four parameters.

Height
Enter the height to give to your barcode's bars. They need to be tall enough to be read easily by barcode
scanners.

Code 128
In Dynamic Barcodes, you can create Code 128 barcodes shorter than the minimum height. Dynamic
Barcodes will just display a warning, but if you export the document to EPF and open it in PackEdge,
PackEdge will extend the barcode to its minimum required height.

 

 

Bars and Digits
For:

• EAN 8 & 13
• HIBC 128 and 39
• M+S 7, and Marks & Spencer's
• NDC / HRI
• UPC-A and UPC-E

For the bar codes listed above, the height you enter is the combined height of the bars and the human
readable characters). Your barcode needs to be tall enough to be read easily by barcode scanners.

Attention:  Do not change the Height of the barcode before entering a Magnification value.
The Height will change again according to the Magnification factor you define.

Characters per unit
This parameter allows you to define your barcode's width based on the encoding of (numeric or
alphanumeric) characters.

You can choose the unit to use: micron, mil (milliinches), mm or inch.
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For example, choose mm and use 1 Character per unit in the Dynamic Barcodes dialog if you want the
bars needed to encode one character to take up 1 mm.

 

 

Increase the Characters per unit value to make the barcode narrower, or decrease it to make the
barcode wider. For example, if you choose 0.5 Character per unit, the bars needed to encode one
character will take up 2 mm.

 

 

Note:  Barcodes like Interleaved 2 of 5 encode two characters together in a group of black and
white bars. For these barcodes, Dynamic Barcodes takes half of the group of black and white
bars to measure one character.
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Ratio
The Ratio is the factor between the width of the narrow bar and the width of the wide bar in your
barcode. For example, enter 3 if you want your wide bar to be three times as wide as your narrow bar.

Narrow Bar
This parameter determines the width of the narrowest bar of your barcode. In some cases (for example
GS1 DataBar barcodes) this affects the size (height and width) of your barcode proportionally.

Width
This parameter determines the width of the barcode from the leftmost bar to the rightmost bar.
Changing the Width will update the Narrow Bar and Characters per unit settings to achieve the desired
size.

The Light Margin Indicators and Box are not included.

Wide Bar
This parameter determines the width of the widest bar of your barcode.

Gap
Enter the width of the white space between the bars.

Note:  The Ratio influences the Gap size: increasing the Ratio also increases the Gap size.
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Vertical alignment
Dynamic Barcodes allows you to resize either the UPC-A or the GS1 Databar Expanded Stacked coupon
barcode, so they are aligned vertically with each other. You can choose:

• None to keep the original size of both the UPC and the GS1 barcodes,
 

 

• Resize UPC to GS1 to resize the UPC barcode so it has the same height as the GS1 barcode,
 

 

• Resize GS1 to UPC to resize the GS1 barcode so it has the same height as the UPC barcode.
 

 

Snap Bars to Output Resolution
Use this to adjust the barcode size parameters (Bar Width Reduction, Device Compensation and
Magnification) so that the bars' width and height take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi.

Decimal Input
Use this parameter to change the type of data you can enter in the Code field.

• Disable it to enter the data to encode in binary or quaternal format.

• Enable it to enter the data in decimal instead of binary/quaternal format.
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Note:  When using binary format for the Laetus Pharma Code, CLF-8, Bobst or Kurandt barcode
data, you need to use a special "Pharma" binary format.

To convert a decimal number into a Pharma binary number, do the following:

1. Add 1 to your decimal number.
2. Convert the result to a binary number using a regular binary conversion algorithm.
3. Remove the first digit (which is 1).

You now have your Pharma binary input for the Laetus Pharma Code, CLF-8, Bobst or Kurandt
barcode.

For example, you want to encode the number 3.

1. 3+1=4
2. 4 in binary is 100.
3. Without the first digit, it's 00.

Enter 00 in the Code field of your Laetus Pharma Code, CLF-8, Bobst or Kurandt barcode.

Add Check Digit
Use this parameter to add a check digit to your barcode data.

Note:  Code 39 doesn't usually contain a check digit but it can be required in some cases.

Symbol Type
Choose the number of cells to use for your barcode (in the format “horizontal cells x vertical cells”).

Note:  If the number of cells you choose for your symbol is too small to encode the data you
entered in Code, Dynamic Barcodes will display an error.
 

 

You can choose Best Fit to make Dynamic Barcodes automatically adapt the number of cells to the
amount of data you entered in Code.

Cell Size or Cell Width/Height
Enter the size you want to give to each cell of the symbol. Cell Size defines both the width and height of
the cell, while with Cell Width and Cell Heigth you can set these parameters separately.
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The unit used is the one you chose as Illustrator's General unit in the Units & Display Performance
Preferences.

In the example below, the first symbol has a 1 mm cell size (cells sides are 1 mm), and the second one a 2
mm cell size.

 

 

Width / Total Height
The Width and Total Height parameters depend on the Cell Size and the number of cells used for the
symbol (Symbol Type).

In the example below, a symbol of 10 x 10 cells where each cell is 3 mm gives a Width and Total Height of
30 x 30 mm.

 

 

Total Height
Enter the total height you want to give to your barcode. This is the combined height of the bars, the
human readable characters and the box. If your barcode doesn't contain human readable characters or
a box, the Total Height is the same as the bars' Height.

Smax / Smin
Use these parameters to define the width of the printability gauges (“H” marks) either side of your
barcode. Smax defines the width of the left “H”, Smin defines the width of the right “H”. Enter 0 in both
fields if you don't want printability gauges.

In the example below, the top barcode has a value of 0 for both Smax and Smin, the middle one has a
value of 4 and the bottom one has a value of 8 (the maximum).
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Box
Use this parameter to create an opaque white box under your barcode.

 

 

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger.
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By default, Dynamic Barcodes links the four margins' values so that when you change one of them, the
other ones are updated automatically.

 

 

If you want to change them independently, click the link symbol to make it look detached  .

For ITF, UCP and UPC-SCS bar codes, the box will be transparent.

Note:  When creating a bar code, the current Box parameters are stored for the specific
barcode type. This means that the next time you select the same barcode type (e.g. when
creating a new barcode of that type) the Box parameters will be adjusted.

Stroke Weight: Bearer Bars
For ITF-14, ITF-16 and UPC-SCS barcodes, enabling the Box option will create a transparent box, always
with bearer bars around it. The Stroke Weight parameter defines the width of the bearer bars. In this
case, it can't be set to zero.

For 2 of 5, Code 128,Code 128 long, Code 93,GS1 128, HIBC 128 and Int 2 of 5 barcodes, the Stroke
Weight defines the width of the bearer bars, but also define if bearer bars should be added: if the value
is set to zero, no bearer bars are added, even if Box is enabled. If the value is not zero, bearer bars will
be added, even if the Box option is disabled.

The bearer bars are positioned at the outside of the defined box, taking into account the margins (even
if the box option is disabled for the barcode types mentioned above). See also Box on page 208.

The option Only Top and Bottom Bars limits the bearer bars to only the top and bottom line.

5.8.  Barcode Parameters from the Job Folder

Automation Engine stores information related to the printing jobs within the Job Folder. Each Job
Folder can hold various job-related technical information, including barcode parameters.

The following barcode parameters can be set in Automation Engine Pilot:

Parameter Note Link

Type The type of barcode. You can't have two different
bar codes of the same type in one job.

Sub Type The size of the symbol for Datamatrix barcodes. Symbol Type on page
206

Code The encoded value including check digits. Code on page 197
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Parameter Note Link

Composite Code For barcodes with a Composite Component -
mainly GS1 Databar codes

Composite Component
on page 198

Output Resolution Snap Bars to Output
Resolution on page 205

Bar Width Reduction Bar Width Reduction on
page 201

Device Compensation Device Compensation on
page 201

Narrow Bar Main size parameter for Code 128, Code 39,
Interleaved 2 of 5, Codabar or MSI based
barcodes, for GS1 DataBar barcodes, and for
binary barcodes. For 2D barcodes such as
DataMatrix, the parameter is used to set the Cell
Size.

Narrow Bar on page
204 and Cell Size or Cell
Width/Height on page
206

Magnification Main proportional size parameter for EAN and UPC
based barcodes

Magnification on page
201

Ratio Used for Int2of5 barcodes Ratio on page 204

Important:  Automation Engine does not check the parameters. All listed parameters are
available for all barcode types, even if they are not valid for the given barcode type. Make sure
you're entering the valid inputs, including a correct Code with its check digit.

Note:  It is not necessary to have the parameters already set on the Job Setup when creating
barcodes: as soon as the Job Setup contains the settings for connected barcodes, these
barcode parameters will be applied. This allows you to create templates or placeholders before
the actual data (code for the barcode, etc) is available.

5.8.1.  Connecting to a Job Folder

In order to take parameters from an Automation Engine Job Folder, you need to be connected to an
Automation Engine, and open the file from the Automation Engine Job Folder. For easy locating the file
on the server, you can use File > Job Folder > Open from Job folder
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For more information on how to connect to Automation Engine, and on opening from a Job Folder, we
refer to the Esko DataExchange documentation. See http://help.esko.com/products/Esko%20Data
%20Exchange%20for%20Adobe%20Illustrator

5.8.2.  Connect Dynamic Barcodes to Job Setup

To use the Barcode properties from the Job Folder, enable the Get Properties from Job Setup.

When enabled, the icon on the right will indicate the status:

• Gray: the feature is disabled
• Green: the connection is established
• Red: the file is not in a Job Folder, or the connection is down.

5.8.3.  Use Barcode parameters from Job Setup

To use the barcode parameters from Job Setup, select a barcode type from the Barcode Type list that
is defined in the Job setup. You can recognize these barcode types by the green icon in front.

211

http://help.esko.com/products/Esko%20Data%20Exchange%20for%20Adobe%20Illustrator
http://help.esko.com/products/Esko%20Data%20Exchange%20for%20Adobe%20Illustrator


5 DeskPack Essentials

As soon as you select one of the barcode types defined in the Job Setup, all parameters that are
defined in the job setup will be entered (and no longer be editable), indicated by the same green icon.
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In the example above, only the Code is defined in the Job Setup. All other parameters can be entered
freely.

5.8.4.  Updating barcode parameters from Job Setup

If a barcode is connected to the Job Setup, any changes to the barcode parameters in the Job Setup,
whether it is a changed parameter or a newly added parameter, will automatically and immediately be
taken into account in Dynamic Barcodes.

When opening a file, all barcodes with the Get Properties from Job Setup option enabled will be
updated automatically

If a barcode type is removed from the Job Setup, the corresponding barcodes in the job will no longer
be connected, so the Get Properties from Job Setup option is disabled.

A barcode will also be disconnected and the Get Properties from Job Setup option will be disabled
in case the barcode parameters in the Job Setup are invalid for the given barcode type. You will need
to change the parameters in the Job Setup. Note that after correcting the parameters, you need to
manually reconnect the barcode by enabling Get Properties from Job Setup.

213



6 DeskPack Essentials

6.  PDF Import

6.1.  The PDF Import plug-in

The PDF Import  plug-in allows opening Esko PDF files in Adobe Illustrator. Almost every PDF object
or construction that can be present in an Esko PDF is supported, and non-native art (also known as
foreign art) is created only for free-form gradients and very complex meshes..

In addition to the artwork content, various high-level information or metadata  is preserved.

It also improves speed and memory allocation of Adobe Illustrator when a single raster file is linked
multiple times into the Illustrator document,even when PDF Import is not directly used to import the
document.

Errors and warnings generated during the import are logged to the Messages  palette.

Known limitations:
Gradients of type Conical, Rectangle and Parallellogramic created by PackEdge cannot be imported in
Adobe Illustrator, because Adobe Illustrator doesn't support those types of gradients

6.2.  Opening a PDF file

The behavior of the PDF Import plug-in and Illustrator depends on the type of file being opened:

• .inpdf : When the file being opened has the sux .inpdf, it is automatically opened by PDF
Import.

• .pdf  with Illustrator data: When the file being opened is an Adobe PDF with preserved Illustrator
editability, it is opened as Illustrator document.

• Regular .pdf : For all other PDF files, the following dialog is shown. PDF Import is used when the
first option (Esko PDF) is chosen. Adobe Illustrator shows this dialog automatically when multiple
file import filters support the file being opened.

 

214



6DeskPack Essentials

 

When the PDF file has multiple pages, a dialog will pop up, allowing you to specify the page you want to
import

 

 

If you enter a page number that is not in the PDF file, the nearest possible page number will be taken.

6.3.  High-level information preserved by PDF Import

6.3.1.  Layers

All Layer names are preserved, as well as the locked status and the printability flag.
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Note:

The Normalized PDF format does not support the hidden/visible flag, therefore all layers (and
artwork) present in the PDF file are imported as visible.

6.3.2.  Named objects

For named objects, the names of the artwork are preserved.

6.3.3.  Inks

Esko screenings, ink types, ink books, ink order and Printing Method as shown in the Ink Manager are
preserved.

6.3.4.  Object based screening

Object based Esko screening is preserved and shown in the InkManager. The Screening plug-in is not
needed for this functionality.

6.3.5.  Structural Design (CAD) data

The original structural design file is reimported using the Structural Design plug-in that is part of Esko
Data Exchange .

The original placement origin, rotation angle, front/back side, and printable part selection are
preserved. When the structural design file cannot be found, the user is asked to browse for it. When it
still can’t be found or importing fails, the original Structural Design layer is imported in expanded state
and the link to the external file is lost.

6.3.6.  Page boxes

All page boxes (Media Box, Trim Box, Crop Box, Art Box and Bleed Box) are imported and shown by the
Trim Box and Media Box plug-in.

6.3.7.  Text and fonts

PDF+
When importing a PDF+, text box and paragraph parameters are retrieved from the PDF+ metadata.
This information is used to set the text in Adobe Illustrator's text engine, to preserve the text box,
alignment, tracking, kerning, etc. However, there might be a slight offset between the characters in the
PDF file, and the result in Adobe Illustrator's text engine.
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In the PDF Import Preferences, you can set the Offset Tolerance

1. Choose Illustrator > Preferences > PDF Import Preferences.
 

 
2. Set the Offset Tolerance. By default this is set to 0.06 pt. A higher tolerance results in more

editability, while a lower tolerance results in more exact text positioning. The Preview shows the
maximum visual offset difference for text at 12pt.

3. Click OK

When opening a PDF where the difference between the glyphs in the PDF and the glyphs in Adobe
Illustrator's text boxes is bigger than the Offset Tolerance, a message will be shown:

 

 

• Click Use Point Type to keep the glyphs at their exact position. This will reduce editability of the
text. Enable the option to always use Point Type in the future.

• Click Open Preference... to open the PDF Import Preferences, where you can increase the Offset
Tolerance and continue open the file.

Normalized PDF
When importing a Normalized PDF, PDF Import will try to reassemble text objects into paragraph
and restore high-level typesetting information, so that you can edit these text objects as native
text in Adobe Illustrator. If this reassembly doesn't work, it may happen that text is split into several
text objects, where each object has a constant font style. In very rare circumstances, when it is not
possible to determine the encoding, the text is contourized.
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Fonts
Any font available to Illustrator can be used without any limitations. When a font not available to
Illustrator is used, a substitution is used. However, the original font name is preserved in the Illustrator
document. Illustrator will give a warning in such cases.

When such a document is saved and reopened on a system with the font installed, it will be correctly
rendered without any warning.

6.3.8.  Linework with mixed (DeviceN) colors

Adobe Illustrator does not support mixing multiple inks (combinations of multiple spot inks or process
inks and a spot ink) in a single fill or stroke. Instead, they are simulated by multiple fills resp. strokes
visible in the Appearance palette.

When PDF Import encounters a path object with a DeviceN fill or stroke, it is imported as multiple
appearances with additional fills resp. strokes put into overprint. Such appearances are supported by
boostX Ink Mix which can work with them further. However, the Ink Mix plug-in is not needed for this
functionality of PDF Import.

6.3.9.  Linked images

PDF Import supports links to external images. The links are preserved.

Some file formats for external images are supported in a (Normalized) PDF, but are not supported by
Adobe Illustrator. For example multichannel PSD files can be placed in PackEdge or ArtPro, but it is not
possible to open such Normalized PDF using this plugin because Adobe Illustrator does not support
this variant of PSD. A workaround is to embed the PSD in PackEdge or ArtPro first. The following error
is shown by Adobe Illustrator in such cases:

 

 

The Image Extractor  plug-in is used for linked Esko CT/LP files. This is a free (non-licensed)
functionality of Image Extractor.

Linked files with remapped inks are imported as Channel Mapped images. The visual representation
will be correct, however a valid license for the Channel Mapping plug-in is needed to edit the channel
mapping.

Adobe Illustrator has performance problems when a single document contains many linked rasters, or
few linked files are referenced many times. It may sometimes cause that only Outline preview can be
used. The PDF Import plug-in improves the handling of such documents.
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Note:

This optimization works also for non-Normalized PDF files, including native Adobe Illustrator
documents, but only as long as the PDF Import is installed.

Missing images
It sometimes happens that the referenced file is not found. Then the following dialog pops up:

 

 

There are 3 options:

• Leave Unresolved : Only a single-pixel placeholder is embedded.

The link to the original file is lost. The Links  palette can be used to relink to the original file when it
becomes available (or to any other file).

• Use Embedded : The image preview embedded in the PDF is used. Normalized PDF often contains a
preview with a low resolution (up to 72 dpi). However, often there is just a single-pixel placeholder.

The link to the original file is lost. The Links  palette can be used to relink to the original file when it
becomes available (or to any other file).

• Relink : the standard file dialog opens, asking the user to find the missing linked file. When this
option is selected, the Use path for the rest of missing images  option becomes enabled.

6.3.10.  Dynamic Barcodes

Barcodes in Normalized PDF, created by PackEdge or an Automation Engine server task, are preserved
and recognised as barcode objects. If the Dynamic Barcode plug-in is installed and licensed, it allows
user to modify parameters of the barcodes supported by the Dynamic Barcode plugin.

As from version 16, also live Bar Codes created by ArtPro+, saved in PDF+ format, will be imported.

6.3.11.  Notes

Notes written by PackEdge, Plato or using the Notes plug-in in Adobe Illustrator, will be imported.
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For more information on working with notes, see Working with Notes on page 220

6.3.12.  Inspection Points

Inspection Points and Inspection Boxes written by PackEdge, Plato or the Inspection Setup Plug-in in
Adobe Illustrator, will be imported.

For more information we refer to the Inspection Setup Plug-in documentation, which is part of the
Esko Data Exchange documentation. See https://www.esko.com/en/Support/Product?id=Esko%20Data
%20Exchange%20for%20Adobe%20Illustrator

6.4.  Working with Notes

Using the Notes tool, you can add and edit notes in your document.

Importing and saving notes
Notes are saved in the Normalized PDF file as regular PDF Comments, and will show up as "Sticky
notes" in Adobe Acrobat. Sticky notes created in Acrobat will also show up in Adobe Illustrator, while
other types of comments (text corrections, highlights, ...), and note properties or statusses are
disregarded when opening a PDF file in Adobe Illustrator.

When importing a Normalized PDF containing notes created in ArtPro, PackEdge, Plato or DeskPack,
these notes will also show up in Adobe Illustrator.
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Notes in Adobe Illustrator

When selecting the Notes tool from the toolbox, all Notes become visible in the document.

A note consists of two parts: the Note itself, the yellow balloon indicating the location of the note, and
the Note Pop-up, containing text, the name of the user that created it, and the time of creation.

When hovering over a note, the Note Pop-up is temporarily shown. When clicking the note, the Note
Pop-up is opened, and you can edit its content. It will stay open until you close it using the X button.

Adding and editing notes
• To create a note, select the Note tool and click in your document.

• To move a note, click and drag the note.

• Select another tool to hide all notes and note pop-ups. Selecting the Note tool will make all notes
visible again. The note pop-ups that were open before will be reopened.

• To delete a note, hover over the note, and click the red cross.
• To hide a note pop-up, click the X in the top right corner. This doesn't affect the note itself, it only

hides the pop-up
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7.  Preflight

7.1.  The Preflight for Illustrator Concept

7.1.1.  What is Preflight for Illustrator ?

Preflight for Illustrator is a plug-in designed to evaluate the contents of your Adobe Illustrator
document by comparing each object attribute to a user-defined set of design or print specifications.
After checking, Preflight for Illustrator locates every problem object and allows you to edit. Validation
can be done interactively.

Another feature of Preflight for Illustrator lets you collect all items related to the job, which makes it
the ideal companion plug-in if you regularly transfer files to printshops.

7.1.2.  Import/Export of parameter sets

A pre press shop could create some parameter sets, which are distributed to all the design houses they
work with. These companies can check their designs with these parameter sets. This will reduce costs
at both sides: the design houses deliver better artwork (avoiding potential additional costs for fixing
problems in the print shop), and the print shop knows upfront if a job is good quality or not.

7.1.3.  Units

Note:

Preflight for Illustrator adapts the Units and Undo settings from the AI preferences menu.

7.2.  The Preflight menu items

Preflight for Illustrator adds a new submenu: Window > Esko > Preflight, containing the following
entries:

• Collect Files... opens a preferences dialog box which lets you collect all external files of the current
job, and write them to a separate directory. External files include images, fonts and ICC profiles.
See Collect Files... on page 223

• The Font List tool is used to manage the classification of used fonts. See The Font List on page
223
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• Preflight Parameters shows the palette for editing parameters that will be used when checking.
See The Preflight Parameters on page 227

• Thin Parts allows to search for areas where objects are thinner than a given minimum width. See
Thin parts on page 234

• Validator shows the check palette which is used for checking and selecting objects that do not
match the specified values. See The Validator palette on page 239

Note:  If you have Packaging Preflight for Adobe Illustrator installed, the Preflight menu will
also contain PitStop Preflight Profiles and PitStop Preflight Report. See the Packaging
Preflight for Adobe Illustrator documentation for more information.

7.3.  Collect Files...

This function will collect all necessary items needed to successfully open the current job on a remote
site.

Collected files include:

• The actual Illustrator file.
• External referenced objects (images, imported linework EPS...)
• Fonts used in the design

• Used ICC profiles

The collected items can be saved in a folder as native files, or they can be packed in a zip file.

The collection of files will be successful if all linked objects are found (images, fonts), and if the target
disk has enough free space.

Collection fails if Preflight for Illustrator cannot locate the external files or used fonts. If collection
fails, every item collected so far will be removed again.

Note:  A frequently occurring situation for failed collection is when an Illustrator file is opened,
and a warning about missing fonts is ignored.

Caution:  Collection will not work with multi file DCS2 files.

7.4.  The Font List

You can open the Font List by choosing Window > Esko > Preflight > Font List

7.4.1.  Why would you use font classification?
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Some font families are less printable than others when it comes to small font sizes. “Serif” fonts, like
e.g. Times Roman, have small decorative extensions at corners or extremities of each character. These
extensions tend to disappear or fade in print when using extremely small font sizes. Not every printing
process suffers equally from this phenomenon. The “bold” font family members, on the other hand,
facilitate the printing of small, thus allowing smaller font sizes than normal typefaces.

The information on which characteristics a specific typeface has, is not consistently stored in the
fontdata, making it impossible to automatically detect the nature of the font. The Font List brings a
solution to this, allowing the user to manually classify typefaces. This may seem to be a tedious job at
first, but after initial classification, the font database can gradually be updated when more fonts are
added.

However, this classification is not compulsory. If there is no need to distinguish between bold, serif
and normal fonts in the workflow, assigning a minimum value for normal fonts only will work in most
cases, every type instance will be compared to this value only, which can be an average for bold, serif
and normal fonts.

Also bear in mind that not every “sans serif” font (a font without these decorative extensions) is easier
to print than a serif font, since some font types have both thin and thick parts, which makes it more
logical to classify them as “serif” fonts than as “sans serif”.

The assigned values will be stored locally, allowing Preflight for Illustrator to use this database for every
job to be checked. This database can be exported for use at other sites where Preflight for Illustrator is
applied.

7.4.2.  Parameter Fonts

Each font family member occupies one line in the Font List. Next to the font name, 2 checkboxes allow
you to classify the typeface with a single click.
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For serif fonts, enable the S checkbox. For bold fonts, enable the B checkbox. The combination of the
two is also possible of course.

When Illustrator is launched, your system is scanned for active fonts. These can be fonts residing in
your system folder, or fonts activated with a font management tool like ATM, Suitcase or others. If new
fonts are active at that moment, they will be added to the Preflight for Illustrator Font List.

Depending on the availability and the state of classification of the font, each font entry can have one of
four different colors:

1. White: the font is classified and available on your system.
2. Blue: the font is NOT classified yet, but detected as active on your system.
3. Yellow: The font has been classified before, but is now unavailable on your system.
4. Purple: The font has not been classified yet and is currently unavailable on your system.

The latter case will happen only rarely, but it may occur in a situation in which a font scan is done on
one system, without assigning some fonts, then exporting the font list to another site where the font is
currently not unavailable.

7.4.3.  Font List fly-out menu

The fly-out menu of the Font List palette contains additional options:
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• Accept All Fonts will change the state of every unclassified font entry to ‘classified’.

• Import Font File allows you to import a font classification database generated on another system.
See Importing a Font File on page 226

• Export Font File will export the current font list settings into an external file.

• Revert Font List will revert any change made in the Font List to the last Save version of the Font
List.

• Save Font Listwill save the current Font List settings on your hard disk.

• Scan for changed fonts refreshes the font list.

Importing a Font File
When choosing Import Font File in the fly-out menu of the Font List, you first browse to the Font File
you want to import. When you click Open, an import control dialog opens.

 

 

It prompts the action Preflight for Illustrator should perform if the imported list contains other
classification parameters for the same fonts than those in the current font List. The options are:

• Completely Replace Font Database: this option specifies that all entries in the current Font List
will be removed, and the parameters from the imported file will be kept.
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• Accept New Attributes on Conflicts: the imported entries are merged with the current Font List,
and if there are conflicts, the settings from the import are assigned.

• Maintain Original Attributes on Conflicts: the imported font classification entries are merged with
the current font list, and if there are conflicts, the settings from the original font list are assigned.

• Ask on Each Conflict: the imported entries are merged with the current font list, and in case of
conflicts, the user will be prompted to assign the desired classification.

If the last option is selected, a dialog appears when a conflict occurs:

For every conflicting classification, the name of the font is displayed, followed by the original (local)
classification, and the new (imported) classification.

Following options can be selected:

• Keep Original: leaves the classification for this font face as defined on this machine.

• Use New: will assign the classification from the imported file.

• Always Use Original: stops prompting the user, keeping the local classification for every conflicting
font face.

• Always Use New: stops prompting the user, assigning the classification from the imported file for
every conflicting font face.

7.5.  The Preflight Parameters

The Preflight for Illustrator Preflight Parameters palette can be opened by choosing Window > Esko
> Preflight > Preflight Parameters. It contains all parameters that can be specified for checking. The
window is divided in tabs:

• Color on page 228: color and/or ink related settings

• Image on page 229: external image settings

• Line on page 230: line width and other line settings

• Font on page 231: text setttings

• Other on page 232: miscellaneous settings.

Each tab can be enabled/disabled.

The bottom of the dialog shows the name of the current parameter set, and an indication whether this
set has been modified or not: if modified, the name is suxed with a ‘+’ sign. The Revert button at the
bottom right restores the saved parameter settings from the current set.

Info
Many parameters or parameter groups have an info button at the right side of the dialog box. Clicking
this button opens a text entry dialog, where you can enter user information related to that particular
parameter.

You can click inside the text window to add or edit text.

Clicking OK stores the text to the current parameter set, while clicking Cancel disregards the changes.

The info can be seen either by clicking the info button, or in the info window of the Validator when the
appropriate rule is selected.
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The Info Dialog Box can be particularly useful for explaining non-experienced users why certain
parameters require specific values. It helps you to understand the printing process and, therefore, to
avoid more mistakes.

7.5.1.  Color

The Color tab allows you to define parameters regarding color and ink usage in a job.

Following parameters can be set:

• Maximum Number of Allowed Process Inks determines how many process inks can be used in the
job.

• Maximum Number of Allowed Spot Colors determines how many spot colors can be used.
• Maximum Number of Allowed Inks determines how many inks can be used altogether.
• Always Include in Ink Count: determines the process colors that must be counted as a used ink

even when not used in the job. This can be important if changing an ink in a printing tower is not
allowed. Some printers always keep all process colors on their press because changing an ink
comes too expensive. This means that, for example on a five color press, only 1 spot color can be
used on that press.

• Warn on RGB Inks Usage: Preflight for Illustrator will report all objects that use an RGB color
specification. Only RGB colors defined in Illustrator are considered, if e.g. an RGB image is
imported, Illustrator does not generate extra colors.

• Treat Registration Color as Process Color: When activated, the color “registration” is regarded as
CMYK components, thus counted as 4 inks, even if no or less than 4 process inks are in the job. This
is useful in a composite workflow, where often registration marks are converted to CMYK by default.

 

 

This is a traditional CMYK setup, for a 4 tower press
which only prints process inks. If any spot colors are
defined and used in the job, Preflight for Illustrator
will report this and request to convert to CMYK.
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In this setup, the 4 process colors plus one spot
color may be used. If more than one spot color is
used in the design, Preflight for Illustrator will notify
you.

 

 

This is an example for a 5 tower press, where 3 spot
colors can be used. If the design contains 2 process
inks only, and 3 spot colors, there is a valid situation.
Other valid combinations are: 3 process / 2 spot 4
process / 1 spot.

 

 

In this example the C, M and K ink should always be
counted, even if they are not used. This means that,
if the job contains e.g. black, cyan, yellow and 2 spot
colors, an error will be reported, although only five
inks are used.

7.5.2.  Image

The Image tab allows you to define parameters regarding imported images.

Following parameters can be set:

• Check on EPSF images If any EPSF (EPS) images are referred to in the job, Preflight for Illustrator
will notify you.
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• Check on TIFF images, If any TIFF images are referred to in the job, Preflight for Illustrator will
notify you.

• Check on Other images, this option will invoke notification if the design references external images
which are not EPSF and/or TIFF.

• Check on Embedded images, this option signals if the design contains embedded images (not
linked).

• Check on RGB images, this option signals whether the design uses RGB images of any type.

• Check Resolution of Images when enabled, the resolution of all images will be compared to the
specified values. A minimum and a maximum resolution setting is available for both Contone and
Bitmap images.

7.5.3.  Line

The Line tab sets parameters for linewidths.

Min Width for Negative Line will report a problem for negative lines that are thinner than the specified
width (see Negative Strokes on page 230).The value for “negative “ color can be defined in the Other
tab, with the Color is Negative if Percent Below... parameter.

Min Width for Single Ink Line will report a problem for single color lines that are thinner than the
specified width (single color means that the color of the line only contains one ink component).

Min Width for Multi Ink Line will report a problem for multi ink lines that are thinner than the specified
width (multi ink means that the color of the line contains more than one ink component).

Warn if Line has More Than 1 Ink will report a problem if the design contains stroked objects where the
stroke color contains more than 1 ink.

Caution:

Preflight for Illustrator does not take brushstrokes into account.

Negative Strokes
Preflight for Illustrator compares the values of object attributes to the values stored in a Parameter
Set. This means that relations between objects are ignored.

The above has an impact on the Preflight for Illustrator definition of “NEGATIVE” strokes: A 3% cyan
stroke with a 1 mm width on top of a dark background is regarded as “negative”, while 2 dark rectangles
with a 1 mm gap inbetween on a 3% cyan background do not trigger a “negative” situation. Actually,
the program does not look at the background (since only individual object attributes are regarded), if a
stroke has a color of which the sum of percentages of ink components is below the predefined value,
the stroke will be assigned “negative”, regardless of the underlying color.
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Finally, the detection of a negative line (or color, for “negative fonts”) is based on the sum of all ink
percentages, and so NOT on the luminance of an object. 5% yellow is as negative as 5% black or 2%
cyan plus 3% magenta.

7.5.4.  Font

The Font tab parameters search your job for fonts that may cause diculties in printing because their
size is too small or some parts of the characters are too small.

Also, text which is perceived as ‘negative’ will be more dicult to print in the same small sizes as
‘positive’ characters.

Small text built up with more than one ink can be misregistered and, as a consequence, look fuzzy in
print.

Following parameters can be set regarding Fonts:

 Minimum size for Single Ink text will report a problem if single ink text is found that has
a smaller font size than the specified value (where single ink means that the color of the text only
contains one ink component).

 Minimum size for Negative text will report a problem if negative text is found that has a
smaller font size than the specified value (negative is defined later in this document).

 Minimum size for Multi Ink text will report a problem if negative text is found that has a
smaller font size than the specified value (where multi ink means that the color of the text contains
more than one ink component).

By default, the same settings apply for all types of fonts. However, separate settings can be entered for
Serif fonts and Bold fonts (Serif fonts have a short decorative line at the start or finish of a stroke in a
letter, and are therefore more dicult to print).
 

 

The following logic applies when checking fonts:

• if a font is both Serif and Bold: If Check on Serif Fonts is enabled, the Serif parameter setting is
applied. If Check on Bold Fonts is enabled, the Bold parameter setting is applied. If both items are
enabled, the highest value will apply.

• For Bold fonts: If Check on Bold Fonts is enabled, the Bold parameter is applied. Otherwise the
standard settings are applied.

• For Serif fonts: If Check on Serif Fonts is enabled, the Serif parameter is applied. Otherwise the
standard settings are applied.

• For all other fonts, the standard settings are applied.
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Minimum x-height allows to check for a minimum x-height of the font family. The x-height is the height
of the letter "x"

Build Font List This option will build a list with all fonts available on your system. Clicking this button
has the same result as selecting the Show Font List option in the Window Submenu.

This list is automatically created or updated when launching Illustrator, but in some situations (e.g.
when activating new fonts while working on a job) an update might be necessary.

For more details on this, see The Font List on page 223

7.5.5.  Other

The Other tab contains all parameters that are dicult to be catalogued within one of the other tabs:

Minimum Dot percentage will report a problem, if colors are used that have an ink component using a
density value below the specified percentage. Zero percent will always be ignored.

Maximum Dot percentage will report a problem, if colors are used that have a component using a
density value above the specified percentage. 100% is treated as an exception: if Include Solid is
enabled, 100% components will also report a problem, while if disabled, no problem will be reported.

Minimum Object size will report a problem, if objects are found that have a bounding box that is smaller
than the specified value in horizontal and/or vertical direction.The unit of measurement is adapted
from the current settings in the Illustrator Units & Undo Preferences.

Maximum Total Density will report a problem if the total sum of color components of a color exceeds
the specified value.

Color is Negative determines the total sum of percentages of ink components that still determine
whether a color is negative: if the sum is below the specified value, the color is regarded as negative.

Check for Non-Printing Layers will report a problem if a layer is non-printable.

Note:  A known limitation: Assume the check parameters are set as follows: min: 3%, max 97
%, assume that you have a gradient from 0% to 97%. This gradient will not be flagged as wrong
even though the minima are not respected. This is because white (0%) is always ignored and
because Preflight for Illustrator does not check in between stops, it only checks the actual
stops, in this case: 0% and 97%.

7.5.6.  Preflight Parameters fly-out menu

The Preflight Parameters palette fly-out menu offers a number of additional functions:

Open Parameter Set... allows you to open a previously saved parameter set. There is no need to
browse, Preflight for Illustrator stores its parameter sets in a dedicated directory. If a set is password
protected, the password must be entered in order to load the set.
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Save Parameter Set will save the current parameter set in a predefined Preflight for Illustrator
directory on the BackStage Server or on a DeskPack Container. Enter an appropriate name for the set,
according to company workflow standards. If applicable, enter a password in the password field. It then
will be requested when loading the set.
 

 

Save Parameter Set as... allows you to save the current parameter set with a different name.

New Parameter Set... creates a new parameter set with the default values.

Import Parameter File... allows you to browse to a user-defined folder or location, imports a previously
exported parameter set and adds it to the used parameter set list.

Export Parameter File... allows you to browse to a user defined folder or location and save the
parameter file with the current parameter file name, or allows you to enter a new name, possibly with a
password.
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7.6.  Thin parts

The Thin Parts function allows to search for areas where objects are thinner than a given minimum
width.

The Thin parts dialog can be opened by selecting Window > Esko > Preflight > Thin Parts

 

 

There are two methods to fix Thin Parts.

• You can Expand thin parts. This creates small objects over the areas where thin parts are found.
You can use this method by selecting Expand All Thin Parts or Expand Enclosed Thin Parts. See
Expand Thin Parts on page 235

• You can use Offset Selection, which creates duplicates of the selected objects shifted over a set
(small) distance, hence fixing any thin parts. This gives beter results e.g. for chinese characters.
See Offset Selection on page 238

The image underneath shows:

1. The original
2. The result of fixing using Expand
3. The result of fixing using Offset Selection.
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You can remove all thin part fixes in your selection by selecting Remove Fixes from the fly-out menu.

7.6.1.  Expand Thin Parts

Expanding Thin Parts creates small objects over the areas where thin parts are found. You can use this
method by selecting Expand All Thin Parts or Expand Enclosed Thin Parts

Clicking the Collect button, will create a Collection of all occurrences, showing all locations where
parts of objects are thinner than the entered Minimum Width.

Note:  Keep in mind that strokes are NOT considered.

Note:  Patterns are not supported. Objects with patterns might cause unexpected results
when using the Thin Parts functions.

The Collection palette will open, so you can browse through all occurences found. See Collection on
page 106 for more information on using a Collection.

Be aware that the Collection generated by Thin Parts, unlike normal collections, does NOT contain any
real objects. Instead it contains "occurences", virtual outlines of places where objects are thinner than
the entered Minimum Width, possibly including the suggested fix.

In the example underneath you can see that at the ends, the lines around the logo are smaller than the
Minimum Width. The red (virtual) objects show the suggested fix.

 

 

Note:  Since the Collection doesn't contain real objects, the Select option is disabled in the
Collection palette.
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Fixing all Thin Parts
You can use the Thin Parts function to automatically create fixes:

1. Open the Thin Parts palette and select Expand All Thin Parts or Expand Enclosed Thin Parts
2. Enter the desired Minimum Width
3. Click Collect

In the Collect palette, you can browse through the Thin Parts, and check the suggested fixes.
4.
5. In the Thin Parts palette, click the Fix button.

The Fix function will create objects (as shown in the Collection), immediately on top of the original
objects, fixing all Thin Part occurrences.

6. In the Select By Attribute palette, select "Thin Parts" in the Object Type section.
7. Click the Collect button
8. In the Collection palette, browse through all fixes, and correct or delete them as necessary.

Fix Thin Parts tool
You can use the Thin Part Tool to interactive create fixes:

1. Open the Thin Parts palette and select Expand All Thin Parts or Expand Enclosed Thin Parts
2. Enter the desired Minimum Width
3. Click Collect
4. In the Collect palette, browse through the Thin Parts, and check the suggested fixes.
5.

Select the Fix Thin Part tool 
6. Click the Thin Parts you want to fix

The Fix Thin Parts function will create objects (as shown in the Collection), immediately on top of
the original object.

Thin Part fixes created with the Fix Thin Part tool can also be selected using Select By Attribute. See
Select by Attributes on page 102

Thin Parts settings
Minimum Width: the minimum width below which parts of objects are shown as a "Thin Part"
occurence.

Expand All Thin Parts: If this option is chosen, all thin parts will be flagged. (In the example
underneath: the result on top)

Expand Enclosed Thin Parts: If this option is chosen, parts of objects are only flagged as Thin Parts
if the thin part is in between two parts of the object above the Minimum Width. (In the example below:
the result shown at the bottom)
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Suggest Fixes (in the Fly-out menu): If this option is enabled, Thin Parts will show the suggested fix,
instead of just highlighting the Thin Part itself.

Show Centerline (in the Fly-out menu): If this option is enabled, the centerline of the thin part is shown.

Thin Part fixes with transparency
When fixing Thin Parts on objects with transparency, the Thin Part Fix will have no transparency set.
This is shown in the image underneath, where you see an object with 50% opacity, and the thin part fix
at 100% (1).

Although it seems an easy fix, changing the opacity of the Thin Part Fix to 50% does not give the
expected result (2).

The workaround is to set both the object and the Thin Part fix at 100%, put them in a group and apply
the 50% opacity on the group (3).
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7.6.2.  Offset Selection

Unlike the Expand options, the Offset Selection option will affect the complete selected objects, and
not only the detected thin parts.

It will create a visual offset of the original object, over the Angle, the Horizontal Offset and Vertical
Offset as defined in the Finetuning Options. The image in the palette gives an indication of the result.
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1. Select the object you want to fix
2. Open the Thin Parts palette and select Offset Selection
3. Click the Fix button to create the Offset using the default values
4. In the Finetuning Options you can modify the Angle, Horizontal Offset or Vertical Offset
5. Click the Update button to apply the values you entered.

Note:  The Offset Selection option can only be used in combination with the Fix button. You can
not create a Collection, or use the manual Fix Thin Parts tool.

7.7.  The Validator palette

The parameters to Preflight are set in the Preflight Parameters palette (see The Preflight Parameters
on page 227) but the actual checking is performed using the Validator palette. This dialog contains
an overview of all rules that will be checked.The list can grow or shrink according to the options or tab
sheets that are enabled.

First, a parameter file is selected. This is done either by interactively defining the parameters in the
Preflight Parameters, or by selecting a parameter file in its fly-out menu.
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Parameter sets can also be selected in the Validator tab. A pulldown menu allows you to choose from
sets which were previously imported with the Import Parameter File... option in the Validator fly-out
menu.

The Check button will perform the actual inspection. The list is then updated to reflect the reported
problems and/or occurances.

The Stop at violating rule option determines whether Preflight for Illustrator will perform all tests or
stops at the first one that reports problems.

The indicator on the right, above the list box is the overall status indicator. Whenever one or more rules
indicate irregularities, this icon reflects this, to avoid missing out an error while scrolling the list:

•
 A grey dot means that the job has not been checked yet, or the design was changed after the

latest check, possibly introducing new problems, which makes a new inspection necessary.

•
 A green dot indicates the job has been checked and no problems have been found.

•
 An exclamation sign means that anomalities have been found.

Each rule can be in 4 states:

 

 

1. The rule has not been checked, or the latest check is no longer valid.
2. The rule has been checked successfully.
3. The rule has been checked, and 4 anomalities were found.
4. The rule has been checked, 6 anomalities were found, and the 2nd irregular object is currently

selected in the Illustrator job.

After checking, the dialog changes as follows: If Stop at Violating Rule is enabled, the rule indicators
will turn green upto the one that reports an irregularity. This one shows a yellow exclamation mark. The
following rule indicators will stay grey. If Stop at Violating Rule is disabled, all rule indicators will show
green except for those with a problem, which will be yellow.

In both cases, the Select First button will be enabled after a check. Clicking it will select the first
violating object. The button then changes to Select Next. After every violating object has been
selected, the button is disabled again.

Activating the Select All button selects all violating instances for the currently selected rule. Clicking
Check again will recheck the design, from the selected rule onwards.

Note:

If Adobe Illustrator Units and Undo preferences are set on pixels, the Valdator will provide no
information (e.g. on minimum object size and such.
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7.7.1.  The Validator fly-out menu

The fly-out menu of the Validator palette shows the following options:

Show/Hide Info: This toggle adds or removes an extra info field at the bottom of the Validator window.
After checking your job, selecting individual report lines then shows extra information, like the
parameters used for that particular report line. If the button Show Parameter Values is disabled above
the info field, the text window will only show user defined info.

Import Parameter File... imports a parameter file that was exported with Preflight for Illustrator. The
parameter file is saved automatically in a dedicated directory, and added to the parameter file list in
Preflight for Illustrator

Ignore Invisible Layers This feature will prevent Preflight for Illustrator from analyzing invisible layers,
hereby overruling the setting in the Preflight for Illustrator Parameters palette.

Auto Select First Violation If any, this option automatically selects the first anomalies found after a
check.

Zoom to Selection When activated, the object which reports anomalities will be zoomed into, and
centered in the Document Window.

7.8.  Select by Attributes

Select by Attributes opens the Select by Attributes palette, from which you can define a custom
selection filter based on the attributes of the objects in the Illustrator document.

Select By Attribute is both a productivity and a QA tool. It allows you to quickly select all elements in
the file (or sub-select within a selection) that comply with your criteria; color, object type, appearance
and even the shape of the object. Use it as a QA tool to trace elements in your document that are
outside the printing specifications (small text, thin lines, ...).

Click Select > Esko > Select By Attributes, to open the Select By Attributes palette.

Why Select by Attributes?
By combining multiple selection criteria in the Select by Attributes panel, you can create your own
special, tailor-made selection filter.
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The Select By Attributes option comes with four buttons Select, Refine, Deselect and Collect.

• Select: Select all objects in the document that match the criteria that are currently selected .

• Refine: Refine the current selection by adding additional selection criteria. This allows you to
quickly fine tune your result.

• Deselect: Deselect all objects that match the new selection criteria within the current selection.

• Collect: Make a Collection of all the objects in the document that match the criteria that are
curently selected. See Collection on page 106

Selection groups
The following groups of selection criteria are available:

• Object Type
• General Attributes
• Fill and Stroke
• Appearance
• Color

It's good to know that Select By Attributes works differently when combining selections within the
same selection group or when combining selection criteria in different selection groups.

When adding selection criteria in the same selection group, Select by Attributes will simply add the
search criteria, e.g. searching in "Object Type" for a "Path", "Text" and a "Mesh" will result in a selection of
all paths, all text and all mesh objects.

However when combining selections in different selection groups, Select by Attributes will combine
the selection criteria. e.g. searching for "Text" in "Object Type" and "Stroke" in "Fill and Stroke" will only
select text objects colored with a stroke.

Note:  Click on a triangle to collapse or expand the section. Alt-click on an expanded section to
open all the sections. Alt-click on a collapsed section to expand that secttion and collapse all
others.

7.8.1.  Object Type

The Object Type group has 11 options:
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• Path: Select objects based on the path type: Open, Closed or Compound. Using Any option, the
selection is made between objects which are Open, Closed or Compound.

• Text: Select all text, or all text smaller than the point size you specify in the Text field.
• Symbol: Select all the objects that are Adobe Illustrator symbols.
• Linked File: Select objects or images which have been linked to (and not embedded into) the Adobe

Illustrator file.
• Image: Selects all placed image files of the file type defined in the list. The image has to be

embedded in the file.
• Mesh: Select all objects that are Adobe Illustrator Mesh objects.
• Dynamic Barcodes: Select dynamic barcode objects generated by the Esko Dynamic Barcodes

plug-in.
• Dynamic Table: Select dynamic table objects generated by the Esko Dynamic Tables plug-in.
• Dynamic Object: Select XML-driven dynamic objects generated by the Esko Dynamic Content plug-

in.
• Thin Part Fix: Select objects created by using the Fix button in the Thin Parts function of the

Preflight For Illustrator plugin.
• Trapping Tags: Select objects that have a Trapping Tag or Reverse Trapping Tag defined, used by

Esko Trapping.

7.8.2.  General Attributes

The General Attributes group has three options:
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• Name: Select an object by typing its name. The name of an object can be found and modified in the
Illustrator Layer palette. Object names are by default placed between angled brackets (< >). Note
that you do not need to type the brackets, and that object names are case sensitive.

• Size: Select the size of the object (smaller or bigger than the typed size in mm).

• Shape: Select the objects which are of the same shapes as defined in the list. Note that the Similar
as Selected Objects option will only function if an object is selected.

7.8.3.  Fill and Stroke

The Fill and Strokes group has two options:

• Fill: Select the objects with a fill.

• Stroke: Select all strokes, or strokes smaller than the size you specify in the Text field.

7.8.4.  Appearance

The Appearence group has seven options:

• Current Style: Select objects similar to the selected object. The selection is tied to the style of the
Illustrator color palette. This means that you can also search for any object with a certain style.

• Fill Type: Select the objects with a certain Fill type. You can choose between Solid, Gradient or
Pattern.

244



7DeskPack Essentials

• Opacity: Select the objects that have a fill or a stroke with an opacity level or transparency lower
than a certain percentage.

• Blending: Select objects that have a fill or a stroke set with one of the blending types, for example
darken or multiply . Select a blending mode from the drop down list.

• Overprint: Select the objects set in overprint.

• Opacity Mask: Select any objects with an Opacity mask linked to it. Opacity masks are used to alter
the transparency of objects and can also be selected via the "Opacity" option.

• Effects: Select any object that has an Adobe Illustrator Effect applied to it.

7.8.5.  Color

The Color group has several options:

• Fill Contains Ink: Select an object based on the ink used for its fill. This can be a process color ink or
a spot color ink.

• Use the "Lower than" and "Higher than" options to only select the objects with certain
percentages of the ink.

• Select the No other inks present check box if you only want to select objects with a fill in the
selected ink, but without other additional inks.

• Stroke Contains Ink: Select an object based on the ink used for its stroke. This can be a process
color ink or a spot color ink.

• Use the "Lower than" and "Higher than" options to only select the objects with certain
percentages of the ink.

• Select No other inks present check box if you only want to select objects with a stroke in the
selected ink, but without other additional inks.

• Fill Color is: Select an object based on the color used for its fill. By clicking once the color patch will
take the color of the object currently selected or when no selection is made it takes the Illustrator
current style. When multiple different objects are selected and you click once the default color
black is chosen. Double-clicking the patch will open the Illustrator Color Picker.
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• Stroke Color is: Select an object based on the color used for its stroke. By clicking once the color
patch will take the color of the object currently selected or when no selection is made it takes the
Illustrator current style. When multiple different objects are selected and you click once the default
color black is chosen. Double-clicking the patch will open the Illustrator Color Picker.

Tip:  Change your current style for fill or stroke to "None" (see Tools palette or Appearance)
and select all objects with no fill or no stroke.

• White: Select any object with a white fill or stroke.

7.9.  Collection

A Collection is a temporary set of objects, based on a selection. It allows to navigate through the
objects in the Collection, automatically zooming in on them.

A collection is temporary, and only kept until it is cleared, or until the document is closed.

1. Select a number of objects.

You can select objects manually, or by using e.g. Select by Attribute
2. Choose Window > Esko > Collection... to open the Collection dialog

 

 
3. Click the Make Collection button to make a collection based on the selection

Note:  By clicking the Collect button in the Select by Attribute palette, you can skip step
2 and 3, and immediately create a collection based on the properties set in the Select by
Attribute palette . See also Select by Attributes on page 102

4. Browse through the collection
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The Collection dialog will show the number of objects in the Collection

• Use the browse buttons to navigate through the different objects in the collection
• The Info field shows the type of object currently selected
• Select the Zoom option to automatically zoom in on the currently browsed object.
• Select the Select option to automatically select the currently browsed object.

Note:

Selecting or deselecting objects doesn't change the collection. You can still select and/or
edit objects, without loosing your collection.

7.9.1.  Modifying a Collection

You can modify the Collection using one of the functions in the fly-out menu of the Collection palette:

• Click the Make New Collection button or select Make Collection from the fly-out menu to "forget"
the current collection, and create a new collection based on the current selection.

• Select Clear Collection from the fly-out menu to "forget" the current collection.
• Select one or more objects in the job, and select Add Selection from the fly-out menu to add the

selected objects to the collection.
• Browse to an object in the collection, and select Remove Selection from the fly-out menu to

remove the selected objects from the collection.

Note:  Objects that are removed in the job, are automatically removed from the collection.

• Select Select All from the fly-out menu to select all objects in the collection.
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8.  Viewer

8.1.  Welcome to Viewer

Benefits of using Viewer
Viewer is a very accurate separation viewer with a lot of extra production tools. It eliminates the need
for separated proofs and will help you to avoid bad plate-making.

You can preview the separations of your document as they would be produced by exporting the
document using Launch Workflow, and rasterizing it on an Esko FlexRip.

Note:

Separations shown in Viewer may differ from the final output when an alternative workflow is
used.

Basic concepts
Viewer works with Press Settings. The Press Settings allow you to define press-specific
characteristics such as the first printable dot, dot gain, dot gain curves, and more.

After defining your Press Settings, you can generate an accurate separation preview.

In this preview, you have access to advanced tools such as the Densitometer, TAC Limit Preview, Plate
Preview, Print Preview and Registration Error Preview.

Normalized PDF or PDF+
Certain functions might be slightly different if you are working in Normalized PDF or PDF+. For more
information on Normalized PDF versus PDF+ we refer to the Ink Manager documentation (part of Esko
Data Exchange for Adobe Illustrator) here.

8.1.1.  Viewer and Viewer (deprecated)

In Viewer for Adobe Illustrator 21.07, the Viewer was completely replaced by a new version. This new
Viewer is using native PDF technology, and is based on the Viewer functionality in Esko's ArtPro+
application.

The new Viewer will completely replace the existing Viewer plugin. However, during a transition period
the older version of the Viewer is still available next to the new one, under the "Viewer (deprecated)"
name and menu entrance.
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8.2.  The Viewer window

You can open the Viewer window by selecting Window > Esko > Viewer > Viewer or by its shortcut
Comand-Option-V (Mac) or Control-Option-V (Windows).

8.2.1.  Define Press Settings

Before you can start working with Viewer in a meaningful way, you should define your Press Settings.
Without basic information on the properties of the press you are using, Viewer cannot simulate
accurately.

1. In the fly-out menu of the Viewer window, select Press Settings...

The Press Settings dialog will open.

 

 

• In the list of Press Settings, there is always one Press Setting called Default, which you can edit
but not delete.

• Click New to create a new Press Setting. You can enter its name, and change its parameters. See
The Press Setting parameters on page 250

• Select a Press Setting and click Copy... to create a new Press Setting based on the parameters
of the selected Press Setting. After entering a name, you can edit its parameters. See The Press
Setting parameters on page 250
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• Select a Press Setting and click Edit... to edit its parameters. See The Press Setting parameters
on page 250

• Select a Press Setting and click Remove to delete the Press Setting.
2. Click Close to close the Press Settings dialog.
3. You can select the Press Setting to use using the Press dropdown in the Viewer window

The Press Setting parameters

First Dot (%)
Specifies which minimal gray value (expressed in %) in the file still will yield a dot on the plate, provided
the RIP and platemaking occur under normal conditions.

Note:

Normal conditions indicate that the DGC must have been set up completely. The value does not
correspond with any measurement that has been made prior or during DGC set up, nor does
it correspond with any densitometer measurement on plate or on print. In fact, this value is
(implicitly) chosen by the person who set up the DGC and plate-making. Typical values range
from 0.4% to 1.6%.

Adobe Illustrator uses 8-bit precision, yielding 256 different possible gray values. A single gray value in
an image may make the difference between a dot or no dot on a flexo plate. To allow for this precision,
Viewer uses percentages with one decimal digit.

8-bit gray value in Illustrator Percentage

0 0.0%

1 0.4%

2 0.8%

3 1.2%

... ...

254 99.6%

255 100%

Note:

If you do not specify a first dot, you will not be able to use the following Viewer view modes for
this press setting:

• The Flexo Plate Preview

• The Flexo Print Preview

Dot Gain in Highlights
When you have specified a First Dot job percentage, you can also specify how dark it should actually
print. Enable Dot Gain In Highlights and specify the dot gain parameters:
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• First Dot Prints As: indicates the dot gain for the first dot. Typical values range from 5% to 15%
depending on the substrate. The value is a job percentage, that will print on an ideal reference press
as dark as the first dot prints on this press.

• Range: while the previous value measured the amount of dot gain in the highlights, this value
expresses how far this effect penetrates into the midtones. Typically plate making is configured in
such a way that the mid-tones print like an offset press.

Note:

If you do not specify Dot Gain In Highlights, you will not be able to use the following Viewer
viewing mode: Flexo Print Preview.

Limited Total Area Coverage
The Total Area Coverage is the sum of percentages of the different channels on the same location. A
higher total area coverage means more of the various inks is printed on top of each other.

If you want, you can specify the Maximum Total Area Coverage to specify the maximum amount of ink
that the substrate can take on the same spot on your press.

Note:

Exceeding the Maximum Total Area Coverage for the press may cause drying problems,
unexpected color results, and other problems.

Registration Error
Specifies the average maximum Registration Error on your press.

If you enable this option in the Press Settings, you can use the Registration Errors preview in Viewer to
check whether your trapping is sucient to compensate for possible registration errors on the press.

Moiré Settings
In the Moiré Detection settings of the Press Settings, you can define the default values for the settings
in the Moiré Detection window.

For more info on the different settings, see Moire Detection on page 267

8.2.2.  Generate the Preview

Before you can use Viewer, you have to generate a preview of the current document, based on your
specific Press Settings.

• In the Viewer window, you can click the Generate button.

• In the menu, you can choose Window > Esko > Viewer > Generate. This will also open the Viewer
window if it isn't open yet.

• You can also use the shortcut Command+shift+7 (Mac) or Control+shift+7 (Windows).

The preview is displayed in the Viewer palette once the rendering finishes.

After you make changes to the document, you need to update the preview. This is reflected in the
Viewer window: the Generate button changes to the Update button. You can also choose Window >
Esko > Viewer > Update or use the shortcut Command+shift+7 (Mac) or Control+shift+7 (Windows).
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8.2.3.  Navigating in the Preview

The Viewer window shows the preview of your document in the left pane, and the list of used inks in the
right pane of your Viewer palette.

At the bottom of the palette, you will find:
 

 

1. a zoom-in and zoom-out button and a dropdown menu with several zoom percentages, and two
extra zoom factors: fit artboard and fit graphics.

2. a zoom-link button. When in link mode, the Viewer window will reflect what your Adobe Illustrator
Document window does.

3. a Densitometer (see Measure Ink Densities on page 252), Measure tool (see Measure Tool on page
253) and Zoom tool (see Zoom Tool on page 254).

Note:

You can minimalize the user interface by selecting Hide options from the dropdown menu. You
can choose Show Options to make the full interface visible again.
 

 

Measure Ink Densities
1. Select the Densitometer tool.
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2. Click in the preview pane to measure the density of a specific point, or click and drag a rectangle to
measure the average density of the area

The densitometer will correctly measure through linework and images, even placed DCS2 multichannel
images that normally cannot be measured in Adobe Illustrator.

Viewer is compatible with Xinet fullpress and Helios OPI systems and is able to show the high resolution
images stored on the OPI server.

The densities are shown to the right of each separation. The total density of all inks on the point that is
being measured (the TAC value) is shown at the bottom of the separation list.

 

 

Note:  The percentages of Technical Inks or Processing Step Inks are not included in the TAC.
See also Technical inks and Processing Step Inks in Viewer on page 260

Measure Tool
Measure tool helps you to measure the:

• Horizontal and vertical distance from the Adobe Illustrator axis zero point.
• Horizontal and vertical distance between first and second point.
• The total distance and the angle between first and second point.

To use the Measure Tool:

1.
Click the Measure tool  on the Viewer pallet.

2. Click the first point and then click or drag to the second point on the Preview.

The following details are displayed on the right hand side;

• X: x-axis
• Y: y-axis
• D: Distance between the first and second point.
• W: Width
• H: Height
• A: Angle
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Zoom Tool
To zoom in the preview pane of the Viewer palette, select the zoom tool and just click, and the view will
zoom in using the clicked point as center point.

To zoom out, click while holding the Alt key pressed, and the view will zoom out using the clicked point
as center point.

You can also drag a rectangle to zoom in, and the new viewport will be a closest match to the rectangle
you dragged.

To pan the view, hold down the spacebar and drag a line in the preview pane. The view will move the
direction and the length of the line you drag.

8.2.4.  The Separations list

In the Ink list, you can:

• Click the eye icon in front of a separation/color name to show or hide it.
• Alt-click an eye button to quickly hide all other separations and go in single-separation mode. Alt-

click the same eye button again to show all separations.
• You can use the fly-out menu to decide if you also want to see the Printing Method for every ink.

When working in Normalized PDF, you can also decide if you want to see the Ruling, Angle, Dot
Shape or DGC curve.

• When only one separation is visible, you can use the buttons above the separations list to inspect
the single separation in different modes:
 

 

1. Color: the single separation is shown in its own color
2. Positive film: the single separation is shown in black
3. Negative film: the single separation is shown in black, but negative.

• You can double-click a separation to open the Ink Options. See the Ink Manager documentation
(part of Esko Data Exchange for Adobe Illustrator) here for more information.
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Note:  If Show Technical Inks or Show Processing Step Inks in the fly-out menu of the Viewer
is enabled, Technical Inks or Processing Step Inks are also shown in this list. See also Technical
inks and Processing Step Inks in Viewer on page 260

8.2.5.  Quality Control

In the Quality Control section you can perform some quality control functions.

• Check the Total Area Coverage: see Total Area Coverage on page 255

• Check for highlight Breakout: see Breakout on page 255

• Check your document in Flexo Print Preview: see Flexo Print Preview on page 257

• Check for Moiré: see Moiré Detection on page 257

• Visualize the used Screen Sets. See Object Screening on page 258

• Check your trapping by showing a Registration Errors: see Registration Errors on page 258

The Quality Control section is not availabe in Viewer (deprecated)

Total Area Coverage
The Total Area Coverage (TAC) is the sum of all separation-densities at a certain point in your
document.

To enable the Total Area Coverage preview, select "Total Area Coverage" from the Quality Control
dropdown list and - if no Eye icon is visible yet, click on the "-" icon in front of "Total Area Coverage".

Once the Total Area Coverage preview is enabled, the image in the preview pane will be dimmed and all
areas where the sum of the densities is higher than the TAC limit will be highlighted. You can define the
highlight color in the Preferences: see Viewer Preferences on page 273

The Limit is the maximal Total Area Coverage that your document may contain. This value depends on
the press and the substrate your design will be printed on. Your printer should provide you with the TAC
Limit value to use.

By default, the TAC limit from the current Press Setting is used.

You can click inside the Limit field and change the Limit value, or you can use the arrow up key to
increase the TAC Limit value or the arrow down key to decrease the value. You can set the value up to
500%. You can hold the Shift key to increase or decrease the value 10 times faster. If the Limit matches
the TAC Limit of a Press Setting, the Press dropdown will change to that Press Setting, otherwise it will
show "custom". If you change the Press Setting in the Press dropdown, the TAC Limit will be adjusted to
the value from the Press Preset.

You can use the Densitometer to measure the densities at a specific location. See Measure Ink
Densities on page 252.

Note:  Invisible layers, invisible separations and Technical Inks are not taken into account.

Breakout
A Breakout is an area where the percentage of a single separation is lower than the First Printable Dot
value. This can be used to track areas that won’t show up on print because the values are too low.
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To enable the Breakout preview, select Breakout from the Quality Control dropdown list and - if no Eye
icon is visible yet, click on the "-" icon in front of "Breakout". Once Breakout is selected and enabled,
all areas where a single separation has a value lower than the First Printable Dot value (but higher
than 0%), will be displayed in highlight color. You can define the highlight color in the Preferences: see
Viewer Preferences on page 273.

Your printer should provide you with the First Printable Dot value. The First Printable Dot value is the
same as used in the Flexo Print Preview. See Flexo Print Preview on page 257. The value is always
rounded off to the closest system value (n/255 in %).

By default, the settings from the current Press Setting are used.

You can click inside a field and enter the value, or you can use the arrow up key to increase the value or
the arrow down key to decrease the value. You can hold the Shift key to increase or decrease the value
10 times faster. If you change a value, the Press dropdown will change to "custom". If you change the
Press Setting in the Press dropdown, the settings will be adjusted to the values from the Press Preset.

Note:  Because breakouts are only highlighted if they are lower than (and not equal to) the
Limit value but higher than 0%, and because of the rounding off to the closest system value
(n/255 in %), the minimum value is 0,8%. When this value is entered, any breakouts that are
rounded off to 0,4% will be highlighted. If you also want breakouts of 0,8% to be highlighted,
you should enter the next value, i.e. 1,2%.

You can use the Densitometer to measure the densities at a specific location. See Measure Ink
Densities on page 252.

Note:  Invisible layers, invisible separations and Technical Inks are not taken into account.

Flexo Plate Preview
Flexo Plate Preview shows a single separation as a simulated flexo plate. In the Plate Color dropdown
you can choose the plate color (Cyrel Red, Cyrel Blue, Olive Green or Safran Yellow, or a High Contrast
Blue&White) to match the type of plate you are using.

Going from light to dark, the Preview will display percentages below the first dot percentage as 0%.
The first dot percentage will be shown darker (using the Prints As value). Towards the midtones this
darkening effect will fade out until the Range value. Any percentage larger than Range, is displayed
unchanged

To enable the Flexo Print Preview, select Flexo Print Preview from the Quality Control dropdown list
and - if no Eye icon is visible yet, click on the "-" icon in front of "Breakout".

Your printer should provide you with the First Printable Dot, Prints as and Range values. The First
Printable Dot value is the same as used in Breakout. See Breakout on page 255. The values are always
rounded off to the closest system value (n/255 in %).

By default, the settings from the current Press Setting are used.

You can click inside a field and enter the value, or you can use the arrow up key to increase the value or
the arrow down key to decrease the value. You can hold the Shift key to increase or decrease the value
10 times faster. If you change a value, the Press dropdown will change to "custom". If you change the
Press Setting in the Press dropdown, the settings will be adjusted to the values from the Press Preset.

You can use the Densitometer to measure the densities at a specific location. See Measure Ink
Densities on page 252

Note:  Invisible layers, invisible separations and Technical Inks are not taken into account.
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Flexo Print Preview
Flexo Print Preview shows the effect of highlight dot gain on your document. Going from light to dark,
the Preview will display percentages below the first dot percentage as 0%. The first dot percentage will
be shown darker (using the Prints As value). Towards the midtones this darkening effect will fade out
until the Range value. Any percentage larger than Range, is displayed unchanged

To enable the Flexo Print Preview, select Flexo Print Preview from the Quality Control dropdown list
and - if no Eye icon is visible yet, click on the "-" icon in front of "Breakout".

Your printer should provide you with the First Printable Dot, Prints as and Range values. The First
Printable Dot value is the same as used in Breakout. See Breakout on page 255. The values are always
rounded off to the closest system value (n/255 in %).

By default, the settings from the current Press Setting are used.

You can click inside a field and enter the value, or you can use the arrow up key to increase the value or
the arrow down key to decrease the value. You can hold the Shift key to increase or decrease the value
10 times faster. If you change a value, the Press dropdown will change to "custom". If you change the
Press Setting in the Press dropdown, the settings will be adjusted to the values from the Press Preset.

You can use the Densitometer to measure the densities at a specific location. See Measure Ink
Densities on page 252

Note:  Invisible layers, invisible separations and Technical Inks are not taken into account.

Moiré Detection
Using the Moiré Detection preview, you can detect possible screening problems in your document.

Using the filter, you can choose to only include objects with a density between two values, e.g.
5,1% and 94,9%. By enabling Ignore light separations you can choose to ignore separations with a
luminance higher than the Maximum Luminance.

If you enable Moiré Detection, the document will be shown dimmed, and areas with possible screening
problems are highlighted.

A possible screening problem exists if one of these conditions is met:

• the angles for the separations used in that area are the same
• the angles for the separations used in that area do not differ 30 degrees
• the rulings for the separations used in that area are different
• the dot shapes for the separations used in that area are different

You can enable or disable the toggles to only highlight screening errors matching the selected
conditions.

• If an unscreened object is involved, this is considered matching all of the conditions.

• Angles are considered the same if they differ a multiple of 90º. E.g. an angle of 7,5º and an angle of
97,5º will highlight as "Angles are the same".

• If the angles are the same, this is not highlighted as "Difference between angles is not 30º "

• All visible separations are taken into account. If you want to disregard a separation (e.g. a Technical
ink or a Processing Step Separation) you can hide that separation.

By default, the settings from the current Press Setting are used.
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You can click inside a field and enter the value, or you can use the arrow up key to increase the value or
the arrow down key to decrease the value. You can hold the Shift key to increase or decrease the value
10 times faster. If you change a value, the Press dropdown will change to "custom". If you change the
Press Setting in the Press dropdown, the settings will be adjusted to the values from the Press Preset.

Object Screening
Using the Object Screening Preview, you can get an indication of what Screening Set is used on what
objects.

The Quality Control section will show a list of all Screen Sets used in your file, each with a different
color. Objects using a specific screen set will show in the corresponding color. Areas where multiple
screen sets overlap are shown in red.

Using the eye icons, you can make the objects using the selected Screen sets visible or invisible.

For more information on Screening, we refer to the Ink Manager documentation (part of Esko Data
Exchange for Adobe Illustrator) here.

Registration Errors
The Registration Error Preview is a simulation of a design printed with registration errors. It can be
very helpful to see if trapping is applied suciently and correctly. To enable the Registration Errors
preview, select Registration Errors from the Quality Control dropdown list and - if no Eye icon is visible
yet, click on the "-" icon in front of "Registration Errors".

The Maximum Deviation defines the amount of registration error.

By default, the Registration Error Distance from the current Press Setting is used. If you change
the value, the Press dropdown will change to "custom". If you change the Press Setting in the Press
dropdown, the Maximum Deviation will be adjusted to the values from the Press Preset.

The separations are moved exactly the distance of the Maximum Deviation, but all under a random
angle.

If you want to see another random registration error simulation, press Y

 

 

In the example above, you can see a small area of a job in regular preview (left) and with registration
errors (right). In this case, you can clearly see no trapping was applied, so white lines appear at the
registration shifts.

Compare
Using the Compare function, you can compare the current document with a Reference file

1. To enable Compare, select Compare from the Quality Control dropdown list.
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2. Set a Reference file. You can select any open file from the dropdown list, or select another file by
choosing Browse. If the Reference file contains multiple pages, you can define the page to be used.

3. If the Reference file contains multiple pages, you can define the page to be used.
4. If needed, (re)set the Alignment

Viewer will align the two documents, based on the common visual objects. If you make any edits,
e.g. change the visibility of specific elements, the documents will not be realigned automatically.
You need to click the Align on All button to realign the two jobs based on the new visual objects. If
you want to align the two jobs based on the selected objects, you can use the Align on Selection
button. If not enough common elements are found, the two jobs will be aligned using the bottom left
corner of their trim box. If the Trim Box is missing, the ArtBoard is used instead.

Note:  When nothing is selected, or when the Compare is already aligned on the current
selection, the Align on Selection button will be disabled.

5. Set the Separation Matching

• If all separations of the current document match with a separation in the reference document,
the button will show "Separations Matched"

• If there are separations in the current document that don't match a separation in the reference
document or vice versa, the button will show "Unmatched Separations"

• By clicking the button, you can open the Separation matching dialog
 

 
• Every separation in the current document that is not found in the reference document is

shown as Unmatched - Show Warning. You can match it with a separation from the reference
document by selecting it in the dropdown, or you can set it to Don't Compare

• The Unmatched reference separations at the bottom indicate what separations in the
reference document are not matched to a separation in the current document. You can set
these to Show Warning or Don't Compare
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• As soon as all unmatched separations are matched or set to "Don't Compare", the button will
change to Separations Matched

6. Compare the documents:

Viewer will calculate the visual differences. The job will be shown dimmed, and when Highlight
different pixels is enabled, the difference in pixels is highlighted. You also get an indication on the
number of areas containing visual differences, along with a notification in case the Separations list,
trim box or media box of the two documents don't match.

• Click the eye icon in front of Compare to toggle between differences view and normal view.
• Hold the C key to temporarily show the reference file instead of the current document. By using

this toggle, you can easily see the difference between both documents.

Note:  If any of the two documents is modified, you need to click the Update button to
ensure you are comparing the latest version.

8.2.6.  Technical inks and Processing Step Inks in Viewer

By default, all technical inks (Normalized PDF) or Processing Step Inks (PDF+) are shown in Viewer, and
rendered as opaque inks.

You can disable Show Technical Inks or Show Processing Step Inks in the fly-out menu of the
Viewer. In that case, technical inks or Processing Step Inks will not be shown in the Viewer, nor in the
separation list. However, if a technical ink or Processing Step Ink influences another separation (e.g. if
an object in a technical ink is knocking out the background), this will still be visible.

Even when shown, technical inks and Processing Step Inks have no influence on the Total Area
Coverage, Breakout or Moire Detection.

Technical inks and Processing Step Inks are also not included in the total ink value below the
separation list when measuring a color. See Measure Ink Densities on page 252

8.3.  The Viewer (deprecated) window

You can open the Viewer (deprecated) window by selecting Window > Esko > Viewer (deprecated) >
Viewer.

• Defining Press Settings works the same as in the Viewer window: see Define Press Settings on page
249

• Generating or updating the Preview is also the same as in the Viewer window. See Generate the
Preview on page 251. In Viewer (deprecated) no shortcut is available, and the menu item is
different: Window > Esko > Viewer (deprecated) > Generate/Update

• Navigating in the Preview is the same as for the Viewer window. See Navigating in the Preview on
page 252
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•

8.3.1.  Separations

The first viewing mode, Separations, shows a list of all used inks.

You have the same options as in the Separations List in the Viewer window: see The Separations list on
page 254

Scale Ink Densities
When viewing a document containing very dark overprinting areas (e.g. traps into dark colors) it is
sometimes dicult to examine the color composition of such areas in Viewer.

Therefore the Separations view mode offers a slider control to temporarily dim (= reduce the density
of) one or more selected separations.

For example: setting the density value to 50% will reduce the actual density values of the selected
separations by 50% when computing the composite (RGB) view.

Highlight
Transparency

This will highlight all objects that have an opacity percentage, a blend mode or an opacity mask
(regardless of what is underneath).

Overprint

Highlight Overprint will highlight the areas where an “overprint” setting in the paint style takes effect.

Screening Conflict

The Screening Conflict checkbox highlights areas where a screening conflict can occur. They can
occur if an object with transparency (opacity mask, opacity percentage or blend mode) is overlapping
on an object with another screening. The PDF definition clearly states that screening is always taken
from the topmost object, even if that object is completely transparent in some areas. In most cases,
this is not what you would expect.

In the example underneath, you can see a cyan rectangle, and a circle on top, with an opacity mask. The
objects have a different screening. Where the circle is on top of the cyan rectangle, the cyan will take
the screening of the blended circle. Therefore, as shown on the right, these areas will be highlighted as
Screen Conflict.
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Color

When you enable a Highlight option, the objects are highlighted in the color you chose in the Color
Picker.

8.3.2.  Total Area Coverage

The Total Area Coverage (TAC) is the sum of all separation-densities at a certain point in your
document.

TAC Limit
The TAC Limit is the maximal Total Area Coverage that your document may contain. This value depends
on the press and the substrate your design will be printed on. Your printer should provide you with the
TAC Limit value to use.

Defining the TAC Limit

The TAC limit is defined in the Press settings. See Define Press Settings on page 249). By default the
TAC Limit is set to 270%.

Viewing areas over the TAC Limit

When you switch to the Total Area Coverage preview, the image in the preview pane will be dimmed
and all areas where the sum of the densities is higher than the TAC limit specified in the current Press
Setting will be displayed in the highlight color.
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Note:

You can Alt-Control-click (Windows) or Alt-Command-click (Mac) the black pixels to use the
densitometer tool, and to measure the actual TAC amount in that specific area. See Measure
Ink Densities on page 252.

To quickly see the maximum TAC in your document, use the TAC Limit slider.

Move the slider to the right to use a TAC Limit value higher than that used by your current Press
Setting. The more you move the slider to the right, the less pixels will typically be over the TAC Limit.

Note:  Technical Inks are not taken into account. See also Technical inks and Processing Step
Inks in Viewer on page 260

8.3.3.  Flexo Plate

If you change the Viewer Preview mode to Flexo Plate, a single separation (by default the first in the
list) will be shown as a simulated flexo plate.

Note:

In this Preview mode, only one separation can be viewed at a time.

Note:

Viewer uses the same technology as the Esko Flexo Tools for Photoshop.
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First Visible Dot
The Flexo Plate preview will use the First Visible Dot percentage from the press settings (see The Press
Setting parameters on page 250).

Pixels with a percentage lower than the First Visible Dot percentage will be shown as areas without
dots.

Pixels with a percentage equal or higher than the First Visible Dot percentage will be shown as areas
with dots.

Plate Color
The Flexo Plate preview predicts how clean your flexo plates will be. Especially in very light or very dark
areas, you could end up with isolated dots or holes on the flexo plate, and those areas are dicult to
hold on the plate or the substrate.

You can choose the plate color (Cyrel Red, Blue, Green or Safran Yellow, or a High Contrast Blue&White)
to match the type of plate you are using.

8.3.4.  Flexo Print

This Viewer preview mode shows the effect of highlight dot gain on the image.
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This effect is equivalent to a curve adjustment. To determine this curve, the Flexo Print Preview will
use the First dot and the Dot gain in highlights settings from the Press Settings (see Define Press
Settings on page 249).

Going from light to dark:

• The Flexo Print Preview will display percentages below the First visible dot percentage as 0%.

• The First visible dot percentage will be shown using the First Dot Prints as percentage.

• Percentages above the First visible dot percentage will be shown darker.

• Towards the midtones this darkening effect will fade out until the Range value.

• Percentages above the Range value are displayed unchanged.

8.3.5.  Registration Error

The Registration Error Preview is a simulation of a design printed with registration errors of a specific
press (defined in the Press Settings, see Define Press Settings on page 249). It can be very helpful to
see if trapping is applied suciently and correctly.

The Registration Error value is taken from the Press Setting you selected.

The separations are randomly shifted. In fact, all separations are moved exactly the distance of the
Registration Error, but all under a random angle.

If you want to see another random registration error simulation, click the Simulate Again button.
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In the example above, you can see a small area of a job in regular preview (left) and with registration
errors (right). In this case, you can clearly see no trapping was applied, so white lines appear at the
registration shifts.

8.3.6.  Breakout

A Breakout is an area where the percentage of a single separation is lower than the First Visible Dot
value. This can be used to track areas that won’t show up on print because the values are too low.

Your printer should provide you with the First visible Dot value. The First visible dot is set in the Press
Settings: see Define Press Settings on page 249.When switching to Breakout mode, the preview will
be dimmed and all areas where a single separation has a value lower than the First Visible Dot value
(but higher than 0%), will be displayed in highlight color.

You can measure the actual percentages in that specific area using the densitometer (see Measure Ink
Densities on page 252).
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Note:  Technical Inks are not taken into account. See also Technical inks and Processing Step
Inks in Viewer on page 260

8.3.7.  Moire Detection

Moire Detection allows to detect possible screening problems (Moire) in the file.

Note:  Moire Detection is not available when working in PDF+ mode.

You can set the options to highlight overlapping areas, to detect situations in which Moire might
occur:

• when the two overlapping areas have screening angles that do not differ 30 degrees.
• when the two overlapping areas have the same angle
• when the two overlapping areas have different rulings
• when the two overlapping areas have different dot shapes.

You can use the Ignore inks option to ignore inks that have

• a density lower than a certain value,
• a density higher than a certain value
• a Luminance higher than a certain value

as in all those cases, the Moire patterning will hardly be visible.

All these Moire Detection options are stored in the Press Settings. See Define Press Settings on page
249

Note:  Technical Inks are not taken into account. See also Technical inks and Processing Step
Inks in Viewer on page 260

8.3.8.  Viewer Compare Tool (deprecated)

You can use the Viewer Compare tool to compare the active document with another document.

To compare the active job:

1. Go to Window > Esko > Viewer (deprecated) > Compare...

The Compare dialog opens, and the name for the Current Document is shown.
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2. Select the file you want to compare the active document to:

• If you want to compare it to an open document, select its file name from the dropdown list
• If you want to compare it to a document on disk, click Open from this computer... and select the

file
• If you are connected to an Automation Engine SaaS server, and you want to compare to a

document from My Workspace, click Open from My Workspace and select the file.
3. Define what to compare:

• all artwork
• the current Artboard
• only Trim Box or Media Box (if they are defined)
• only the selected area.

4. Click OK

A Viewer Compare window will open, showing a comparison between the two jobs.

Note:

If you have a Trim Box defined in the Illustrator job, the Viewer Compare tool will only show
what’s inside the trim box.

The Viewer Compare window
The Viewer Compare window shows the two jobs and their differences, and contains a number of tools
and buttons to inspect these differences in various ways.

Move over a button with the cursor and the tooltip will indicate what it stands for.

Buttons with a triangle in the lower right corner contain additional options: Control-click (Windows) or
Command-click (Mac) the button, or click and hold the button to see the extra options.
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Navigating the Viewer Compare window
The Viewer Compare window contains different ways to navigate:

The Inspect tools
 

 

• The Zoom tool. Under the zoom tool you find

• Zoom out

• Fit document in view

• Fit document width / height

• Zoom to 1:1 view

• Show Zoom Options (showing all these options as individual buttons)

• The Zoom out tool
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• The Pan tool

The Navigator
By dragging the red rectangle (when zoomed in), you can navigate through the job.

 

 

The View options
The View options allow to go back to the previous view, or use additional settings, such as rotate,
invert or mirror the view.

 

 

Compare modes
Using the Compare butons, you can choose different Compare modes / views

 

 

• View Current version only
• View Reference version only
• View Both documents on top of each other.

Additional options:

• View Both in their original colors

270



8DeskPack Essentials

• View Both - Show difference: the differences will be shown in the "Added" and "Substracted"
highlight colors.

• View Both - highlight difference: same as above, but the identical parts are dimmed.
• View Both - only difference: same as above, but the identical parts are hidden.
• Change "Added" Highlight Color, Change "Substracted" Highlight Color and Change Both

Highlight Color, to change the colors in which differences are shown
• Reset Difference Highlight Colors to reset the default colors
• Channel Matching, to match corresponding channels/inks for the two documents.

• View Both - side by side shows both versions next to each other. You can choose between

• Automatic tiling
• Horizontal tiling
• Vertical tiling.

• View both - mirror reference shows the current document on top of the mirrored reference
document.

Alignment
Comparing files with different sizes may seem like a challenge as they are not aligned in the Viewer
Compare window, but it provides some tools that make it very easy.

 

 

• Alignment

• on one of 9 corner / center points
• Align From Ruler: see Align from Ruler on page 271
• Auto Align From Ruler: see Auto Align from Ruler on page 272
• Auto Align: see Auto Align on page 273

• Auto Align: see Auto Align on page 273
• Use trim box for alignment
• Offset, Horizontal and Vertical

Align from Ruler
The ruler tool works by defining two points (one in each file) that have to be aligned.

1.

Select the reference version of the file by clicking the  icon.
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2.

Select the Ruler tool 
3. Indicate the ruler anchor point

 

 
4.

Switch to the other version by clicking the  icon (or use Ctrl + S).

The anchor point, here in the red circle, will be in a different location in the second file version.
5. Indicate the point that should be positioned on the ruler anchor point (here in the blue circle)

 

 
6.

Click the Alignment button and select Align From Ruler. The files are now aligned.

Note:  Depending on how precisely you defined the second ruler point, you may have to
zoom in and repeat the alignment procedure to align your files with more precision.

Auto Align from Ruler
Auto Align from Ruler is used the same way as the Align from Ruler tool, but is more accurate at high
resolution.

If the details of the alignment points match, the viewer will be able to increase the alignment precision
(and have a good alignment with fewer iterations).
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Auto Align
Auto Align does not use the ruler, but rather the currently visible view of the two compared images to
attempt an automatic alignment.

For convenience, a separate tool button is available to perform an Auto Align operation without having
to open the Alignment pop-up menu. Clicking this button will perform an Auto Align from Ruler if a ruler
selection is active, otherwise an Auto Align (from view).

Viewer Compare Preferences
You can open the Compare Preferences by choosing Illustrator > Preferences > Esko > Viewer
Compare Preferences (on Mac OS) or Edit > Preferences > Esko > Viewer Compare Preferences (on
Windows).

You can define the resolution for the Viewer Compare previews: either based on the document size, or
at a fixed resolution. "Based on Document Size" will result in a low resolution for big documents, so e.g.
aligning will become more dicult when zooming in. On the other hand, a "Fixed Resolution" can result
in a very heavy preview calculation if the fixed resolution is high and the document is large.

You can define if anti-aliasing should be applied.

8.4.  Viewer Preferences

Open the Viewer Preferences dialog by choosing Preferences > Esko > Viewer Preferences or open
the Viewer (deprecated) Preferences dialog by choosing Preferences > Esko > Viewer Preferences
(deprecated).

You can set one or more of the following options:

Image Display Quality
This allows you to selected the preferred quality for displaying the contone images present in a
document.

• Low: A low resolution preview image (< 72dpi) will be used (if present). When such preview image is
not available, a gray box will be displayed.

• High: A preview image of at least 150dpi will be used. When such preview image is not available, a
gray box will be displayed. This is the default option.

• Very High: If sucient memory is available, the real data (not subsampled) of the image will be
displayed. When the image is too large to fit into memory (typically if the size is larger than 64MB) a
high resolution display image will be shown.

Anti-Aliasing
This preference offers control over the Anti-Aliasing method used to prevent display-artifacts like
rough (“blocky”) edges in rendered artwork.

• Off: Do not perform any anti-aliasing (default value, fastest).
• Low: Some anti-aliasing (slower).
• High: Highly accuracte anti-aliasing (slowest).
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Note:

Setting Anti-Aliasing to “High” will result in high-quality preview at the expense of significantly
slower rendering / viewing speed (up to ten times slower than when Anti-Aliasing is turned off).
It is advised to only use the “High” setting on fast workstations.

Densitometer Mode
This option lets you select the preferred resolution of the densitometer.

• Exact: Ink densities will be measured with an accuracy (resolution) of 1/255 percent. This
corresponds to the (8 bits per pixel) accuracy typically used by a Rip for outputting (unscreened)
separations. In other words what is measured will correspond “exactly” to the digital output of the
Rip.

• Rounded: Ink densities will be measured and presented with an accuracy of 1%. Densities with a
non-integral (e.g. 33.2%) value will be rounded to the nearest integral value (e.g. 33%).

If Densitometer Mode is set to "Rounded", the values shown in the Ink Coverage palette will also be
rounded.

Highlight Color
You can define the Highlight Color to be used for Total Area Coverage, Moire Detection etc. This option
is not availabe in Viewer Preferences (deprecated), as you can set the highlight color in the Viewer
(deprecated) window.

Press Settings Folder
This allows to define the folder from which the Press Settings should be loaded.

If no folder is set up, Viewer will try to use the default location: DeskPack Container/Settings/
Press. If there is no DeskPack Container mounted or available, then it will automatically switch
to Users/Shared/EskoArtwork/Settings/Press on macOS, or C:/Users/Public/
Documents/EskoArtwork/Settings/Press on Windows. The Viewer installer will automatically
create these folders.

If no Press Settings Folder is available (e.g. the defined or default folder has been removed), you will not
be able to change or create Press Settings.

Note:  If the Viewer Preferences and Viewer Preferences (deprecated) have different Press
Settings Folder defined, the Press Settings will not be shared between both Viewers.

8.5.  Ink Coverage

With Ink Coverage, you can calculate the ink usage for every ink.

1. Click Window > Esko > Viewer > Ink Coverage... to open the Ink Coverage dialog.
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2. In the dropdown, select the area you want to scan. By default, Ink Coverage is calculated on the

Current Artboard
3. Click Calculate

For every separation, the size (in square mm or square inch) and percentage of the total surface is
shown.

Note:  By setting the Densitometer Mode to "Rounded" in the Viewer preferences, the
values in the Ink Coverage palette will be rounded off.

4. Click Save as XML... to save the result of the Ink Coverage calculation into an XML file.
5. Click Close to close the Ink Coverage dialog.

Note:  Technical inks will not be presented in the list, nor in the exported XML.
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9.  White Underprint

9.1.  White Underprint

White Underprint allows you to create a white background underneath the selected objects. This white
background can be necessary when printing on transparent or metal material. The White Underprint
plug-in can generate white underprint objects for all kinds of Illustrator objects.

To open the White Underprint palette, click Window > Esko > White Underprint. The White Underprint
palette appears.

9.2.  Adding and Removing White Underprint

White Underprint objects will be created in a top-level "White Underprint" layer, and will be put in
overprint.

A new White Underprint layer will be created:

• If a different White Underprint ink is used
• If the White Underprint layer doesn't exist yet
• If the White Underprint layer was locked, hidden or no longer positioned as top layer.

1. Click Window > Esko > White Underprint to open the White Underprint palette.
2. Select one or more objects in the Illustrator document.
3. Set the White Underprint settings: see White Underprint settings on page 277
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4. In the White Underprint palette:

• Click Add to add White Underprint for the selected artwork: the plug-in will compute the union
of the selected artwork and add the resulting paths at the top of the White Underprint layer

• Click Subtract to subtract the selected artwork from the White Underprint layer. The plug-in will
compute the union of the selected artwork, and put the resulting paths at the top of the White
Underprint layer, in overprint, and at 0% of the selected White Underprint ink.

Note:  If you want the White Underprint to be slightly bigger than the original objects, you
should use a spread (an outward offset) when adding to the White Underprint layer, and a
choke (an inward offset) when subtracting from the White Underprint layer. If the White
Underprint should be slightly smaller, you should do it the other way around.

9.3.  White Underprint settings

To set up White Underprint:

1. Select Window > Esko > White Underprint to open White Underprint dialog box.
2. Define the Offset: the distance between the edge of the White Underprint layer and the edge of

the object under which White Underprint is applied. By default the offset is set to Spread (outward
offset). You can also choose to Choke (inward offset).

3. Set the Miter Limit as you would for trapping. Miter limit determines whether sharp corners in
objects appear pointed or beveled. You can also select Bevel and Round options.

Note:  The Miter Limit option is only available when using mitered corners.

4. Define if White Underprint should be generated only on visible parts of selected objects, by setting
the Only Visible Parts option.

5. In the Gradients section, set how to handle Gradients.

• None: By default objects with a gradient fill will be backed using a 100% solid white
• Choke by distance: a gradient will be added to the White Underprint layer. The gradient will be

choked over the entered distance, and run from the minimum % to 100%.
• Bump minimum %: a gradient will be added to the White Underprint layer. The gradient will

follow the same density as the original object, but values below the minimum % will be bumped
up to the minimum value.

• Clip to minimum %: a gradient will be added to the White Underprint layer. The gradient will
follow the same density as the original object, but values below the minimum % will be clipped to
0%.

9.4.  White Underprint Ink

The Ink used for White Underprint can be defined by selecting Options from the fly-out menu of the
White Underprint palette, and entering the name of the Ink to be used for White Underprint.
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In case the defined ink doesn't exist yet, a new spot color will be added to the swatches, using the Ink
name and the Color patch.

When the name of an existing swatch is entered, this ink will be used for White Underprint.

Note:  White Underprint can only use Spot Colors. If an existing swatch name is entered, and
the swatch is not a spot color, a warning will be generated: "A swatch by this name already
exists but is not defined as a Spot Color".

Multiple White Underprint inks can be used in 1 document. After you've applied White Underprint using
a first ink, just change the name and color patch of the White Underprint ink in the Options dialog. As of
then, any new White Underprint objects will be generated using the new White Underprint ink.

Note:  In order to prevent changes to existing White Underprint objects, be sure not to have
any active selections while changing the White Underprint ink. If you wish to modify the color
values of the existing White Underprint ink, please do so directly in the Swatch library.

9.5.  Include White Objects

The Include White Objects option can be set by selecting Options from the fly-out menu of the White
Underprint palette.

If the option is disabled (default), no White Underprint is generated for white objects (colored with
CMYK 0/0/0/0). By selecting the option, those objects will also get a White Underprint.

Note:  Uncolored objects (i.e. if the fill and the stroke color is set to "none") will never get a
White Underprint, regardless of this option.
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