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1Automation Engine

1.  What is Shuttle?

The Automation Engine Shuttle is a client tool for easy submission of files to Automation Engine
workflows. Shuttle also allows monitoring these workflows.

This Shuttle technology is also integrated in classic Esko editors and in Adobe Illustrator as a DeskPack
plug-in. This enables to launch Automation Engine tasks on the open file from inside these editors.

ArtPro+
Shuttle functionality is used when ArtPro+ is connected to an on-premises Automation Engine server,
and either ArtPro+ or the Automation Engine server is version 22.03 or older. Note that only launching
a workflow is available: there is no Shuttle dialog to show progress of the launched jobs from within
ArtPro+.

Launching the open document to an Automation Engine workflow is handled by "My Workspace" instead
of Shuttle functionality

• when ArtPro+ is connected to an Automation Engine SaaS server, or
• when ArtPro+ is connected to an on-premises Automation Engine server, and both ArtPro+ and

Automation Engine are version 22.07 or higher.

For more information on ArtPro+ and its connection to Automation Engine, we refer to the ArtPro+
documentation here

DeskPack
Connection to an Automation Engine server from Adobe Illustrator is handled by the Adobe Illustrator
Client plugin.

Shuttle functionality is used when Adobe Illustrator Client plugin is connected to an on-premises
Automation Engine server, and either Adobe Illustrator Client plugin or the Automation Engine server
is version 22.03 or older.

Connection to an Automation Engine workflow is handled by "My Workspace" and "Launch Workflow"
instead of Shuttle functionality when both Adobe Illustrator Client plugin and Automation Engine are
version 22.07 or higher.

Note:  When Adobe Illustrator Client plugin version 22.03 or lower is connected to an
Automation Engine SaaS server, you can use the Tasks palette to monitor tasks run on
the Automation Engine server. For more information, see the Adobe Illustrator Client
documentation version 22.03 here

For more information on Adobe Illustrator Client plugin, we refer to its documentation here

For more information on My Workspace, we refer to the Automation Engine documentation here and
the Blended Learning modules here.

Note:  When this documentation was updated in 2020, all information on integrating Shuttle
with legacy applications Nexus and Odystar was removed. If needed, you can still find this
information in older versions of the Shuttle user guide.

3

https://www.esko.com/en/support/product?id=ArtProPlus
https://www.esko.com/en/support/product?id=Adobe%20Illustrator%20Client&ver=22.03
https://www.esko.com/en/support/product?id=Adobe%20Illustrator%20Client
https://www.esko.com/en/Support/Product?id=Automation%20Engine
https://learning.esko.com/course/view.php?id=98
https://www.esko.com/en/support/product?id=Shuttle&ver=18.1


2 Automation Engine

2.  Installing Shuttle
The Shuttle is one of the client tools that you can download from an Automation Engine browser client:

In a browser, go to http://<AEserverName>:9000/#/downloads  .

If the Shuttle application is already installed on your computer, the system will check if you have the
appropriate version and download any updates if necessary.
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3.  Shuttle Setup

3.1.  Configuring Shuttle in Automation Engine

1. In the Pilot, go to Tools > Configure.
2. Select Shuttle.

 

 
3. Enter the Port to use for communication between your Automation Engine server and the Shuttle

clients.

Note:  By default this is port 5182. If this port is already used by other processes, enter the
next available port.

4. Click on  and select an Upload Folder.

This is where Shuttle clients will upload files that were not yet located in a Container, for example a
file that you drag and drop from the desktop of a Mac (except the DeskPack Shuttle plug-in, that will
always upload files to the DeskPackContainer).

Note:  The Upload Folder must be located in a Container.

5. Select 'Start Shuttle server automatically when Automation Engine is started' if you plan to make
frequent use of the Shuttle technology.

6. Select 'Use the task history to re-launch using the same public parameters' if you want Shuttle
to propose to use the same public parameters when you launch a same file on the same workflow.
The Shuttle then checks prior tasks, not just those shown in a Tasks overview pane but also those
present in the Task History tool.

7. Click the Start button to start Shuttle server.
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The Shuttle server then makes Automation Engine’s workflows, tasks and files accessible to the
Shuttle clients.

8. Save your settings.

Note:  To make changes to this setup, you must first Stop the Shuttle server.

3.2.  Making Tickets Public

Only Public tickets (of single tasks or workflows) can be launched from Shuttle (or from the client
applications using Shuttle).

Note:  Default tickets and (blue) Job tickets can not be made public.

3.3.  Shuttle Clients connecting from Editors

1. In the editor, open the Preferences.

In... go to...

ArtPro+ Edit > Options >  Automation Engine

Adobe Illustrator • (Mac) Illustrator > Preferences > Esko > Shuttle Preferences...

• (Windows) Edit > Preferences > Esko > Shuttle Preferences...

ArtPro ArtPro > Preferences... or use Command + K

PackEdge/Plato (Windows) Edit > Preferences >  Server&Resources

FastImpose
Standalone

Tools > Shuttle Preferences...

2. Fill in the name of the Automation Engine server.
3. Enter your User Name and Password.

Enter a User Name and Password that is also valid to sign in to a Pilot.

You will have the same access rights in Shuttle as you have in the Pilot (for example the right to
change processing priorities).

3.4.  Shuttle Application connecting to Automation Engine

1. Launch the Shuttle application.
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2. You will be asked to sign in to an Automation Engine server
Sign in in the same way as you would do for a Pilot.

Tip:  If, on that same computer, you are already signed in to a Pilot or another Shuttle
client (possibly from within an editor), the system will check what you selected in Pilot > 
Configure > Login automatically with user name and password from other application
connected to the server.
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4.  Launching the Automation Engine Shuttle
When you launch the Shuttle application, the window shows a list of launched Tasks and a Launch
Panel where you can define one or multiple drop areas that each launch a specified workflow:

 

 

• To open a new window, go to File  >  New Window. You could use dedicated Shuttle windows for
each of your Workflows.

• Use the View menu to hide or show parts of this window:

• View > Tasks hides/shows the Tasks panel.

• View > Launch Panel hides/shows the Launch panel.

• View > Status Bar hides/shows the Status bar indicating the progress.

• When closing, Shuttle saves the settings of the windows.
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5.  Working with the Automation Engine
Shuttle

Starting the Shuttle will ask you to login to the Automation Engine server.

Note:  Whether this user can also start up a Pilot is decided by a specific User Access Right.
Learn more in Access Rights.

Menu items

• File: To launch one or more files on the one defined workflow (after browsing for files), or to open
and close Shuttle windows.

• Edit: To cut, copy or paste text in the search field. To select and delete tasks. Or to define
Preferences (see below).

• View: To show or hide the Tasks pane, the Launch panel and the Status Bar.

• Task: To open or show the output file of the selected Task, to release or cancel the Task, or to add
Annotations and show the task's Details.

• Tools: To open the To Do List.

• Window: To minimize, zoom or switch between Shuttle windows.

• Help: To see the About window or to access this online documentation.

Setting the Preferences for Shuttle

On Mac, select Preferences... in the Application menu. On Windows, go to Edit > Preferences...

In the Preferences dialog, set the units for Dimension, Resolution, Ruling and the number of Decimals
to use.

Select 'Always show launch dialog' if you want to see the Public Parameter dialog when starting a new
task, even if there aren't any public parameters. This allows you to change these parameters before
launching the task.
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5.1.  The Tasks Panel

The Tasks panel is the part that shows the Automation Engine tasks that were launched both from
Shuttle and Pilot clients. One row represents or a single task or one step of a workflow.

You can filter the displayed list tasks:

• By filtering on a Job context from the Job selected from the drop-down list in the toolbar.

Select Other... if you want to select a Job other than the recently used ones in the list. Select All
Jobs to clear the current filter.

• By typing in a value in the filter. Learn more about creating filters in Using Filters.

Note:  In Shuttle, you cannot open or edit a task. This is only possible in a Pilot.

Tip:  You cannot hide the columns displayed in the Task's pane. However, you can change their
order and width.

Tasks asking for User Intervention

Workflows that including a Wait for Action task will show when they reached this step in the column
Phase. This allows the Shuttle user to intervene and decide how the workflow continues.

 

 

To intervene,

• Click on the User intervention needed link.
• In the resulting To Do window, choose to Forward or Release. Learn more in User Intervention

managed from Shuttle on page 13.

Context menu options

Right-click on a task to access these options:

• Open Output File: To open the task's output file with the appropriate application (if possible).
• Show Output File in Finder / Explorer: To see the folder that contains the output file in (Mac) Finder

or (Windows) Explorer.
• Release: To release a task that is on hold.
• Cancel: To cancel a running task.
• Delete: To delete a finished task. You will be asked to confirm.
• Annotation...: To add or modify an annotation.
• Details: To see a dialog with detailed information about the task (step).
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Tip:  These options are also available via the Task menu.

5.2.  The Launch Panel

The Launch Panel is where you drop one or multiple files as input files for that workflow. Each drop
area is indicated with a large arrow and serves to launches one selected workflow.
 

 

• Click  to add an extra drop area.

Note:  To remove a drop area:

• Click . This changes the user interface in editing mode.

• Click  on the top left corner of the drop area that you want to delete.

• To leave the editing mode, click again on  or press Escape.

• Below each drop area, select the desired workflow from the drop-down list.

Attention:  Only Public tickets are listed.

Note:  The drop areas and their assigned workflow are saved when you close Shuttle.

5.3.  Launching a Workflow from the Automation Engine
Shuttle

1. If the Launch Panel is not visible in the Shuttle window, go to View > Launch Panel.
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2. Submit one or more files in one of these ways:

• Drag and drop the desired file(s) onto a drop area.
• Go to File  > Launch... and select the files.

• Use the keyboard shortcut CMD-L (Mac) or Ctrl-L (Windows) and select the file(s).

Note:

• If a file was previously launched on the same workflow, a dialog will open and ask if you
want to reuse the public parameter values from the previous launch. If you choose to
reuse these values, they will be used as default parameter values. You can still edit these
values if necessary.

• The selected file(s) will be uploaded to the root folder of the selected Job. When no Job
is selected, it will be copied to the Upload Folder defined in the Configure panel.

• If a file with the same name is already present in the upload folder, a dialog will warn you
about overwriting the file. You can then choose to either Replace the existing file, or
Cancel the launch.

3. If the workflow has Public Parameters, the New Task dialog will ask you to fill them in. Learn more in
Using Public Parameters in Workflows.
An example:
 

 
a) Click Task Options to define general task options. You can:

• Set the Priority of the task (Low, Normal, High or Immediate).

• Select Hold to keep the task from being launched until someone releases it (via a right-click
or via the Task menu).

Alternatively, use 'Release at' to hold the task until a specific time, after which it will
automatically be released.

Note:  You can later change this automatic release setting by selecting Release via
the right-click menu in the Tasks panel or via the Task menu.
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• Select 'Launch a separate Task per input file' to launch a separate task or workflow for each
input file.

• You can also set an Annotation for the task.

 

 
4. Click Launch to launch the workflow.

The task will immediately appear in the Tasks panel.

5.4.  User Intervention managed from Shuttle

When the launched workflow contains a Wait for Action (Checkpoint) step, a User intervention needed
link appears in the Tasks panel when that workflow step is reached..

1. Click on the User intervention needed link to open the To Do dialog.
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2. Optionally, select 'I am currently handling this to do item' to mark that you are handling this item

(other users are so also informed).
3. Decide how you want to Release this item. The offered choices are those that were decided in the

ticket of the 'Wait for Action (checkpoint)' task.
Select the wanted output state. The To Do window will close and the workflow will continue
processing.

4. In stead of releasing the item, you could Forward or Delete it.

• Click Forward, choose the user and set other details. The other user then needs to decide how
and when the workflow continues.

• Click Delete to delete this item and also end the processing of the workflow.
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