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1 Automation Engine

1.  Installing Server and Clients
This needs to be done first before you can use Automation Engine from any client (application or
browser):

1. Install the Automation Engine server software, on a central powerful computer.

Important:  Before installing the server software, make sure your IT specialists checked its
system requirements and have read the chapter Pre-Install IT Requirements.

2. Install the Automation Engine client application Pilot and/or Shuttle. Unless you prefer to use the
browser client (see step 3), you typically install these on each computer from where users will want
access to Automation Engine. You can install as many as you want, but your licenses decide how
many users can be signed in to the server at the same time.

Note:  These client applications and other tools can be downloaded from the browser client
(go to http://<AEserverName>:9000/#/downloads ).

3. Daily users may use the browser client. This does not require to install a separate application. The
browser client can offer these 2 workspaces:

• My Workspace: A default, generic interface to launching workflows. Learn more in Workspace
'My Workspace'.

• Roll-Fed Labels: Formerly known as the QuickStart deployment for roll label production. Learn
more in Workspace 'Roll-Fed Labels'.

All steps are documented in detail in the chapter Installation Guide.

4

http://www.esko.com/systemrequirements
http://www.esko.com/systemrequirements


2Automation Engine

2.  Changing the Language used in the Pilot,
Shuttle or browser client

The client applications Pilot and Shuttle are available in several languages (aka "Localization"). This
online KB article describes how you can specify that language.

In the browser client, changing the interface language is a simple choice in the preferences menu.
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3 Automation Engine

3.  Signing In to the Pilot or Shuttle

Note:  Learn about managing users on the page about the Users view. Learn more technical
details in the chapter Pre-Install IT Requirements, on the pages about Users and Groups.

Note:  The Pilot, browser client and Shuttle are available in several languages. Learn more in
Changing the Language used in the Pilot, Shuttle or browser client on page 5.

On the computer where you installed a Pilot or Shuttle:

1. Double-click the application shortcut.

• On macOS: in the folder Applications or in your Dock.

• On Windows: on the desktop or in the task bar. Alternatively, find it under Start > All Programs >
Esko.

2. The Sign In dialog looks different, depending on whether you already used it on this computer or
whether it was already used to sign in to a different Automation Engine server.

• When this is the first time, you will be asked to first enter the name or the IP address of your
Automation Engine server. Do so and press Continue.
 

 
From then on, the drop-down list will list other servers that were signed in to from this client.

• When someone already signed in from this computer, the dialog already assumes the same
Automation Engine server and also fills in the name of that previous user.

You then only need to type the password and click Sign In (or you use another user name and
password).
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3Automation Engine

• Click Forgot Password? to get an e-mail with a link to reset your password. The e-mail is sent
to the e-mail address defined for that user. Learn more in Users View.

Important:  Make sure the e-mail configuration is set up in your Configure tool. This
dialog does not show any error messages when the sending of this e-mail fails.

• Click Change Server if you want to sign in to another Automation Engine server. You then get
the dialog as shown here above.

Note:  Every time you select another server, the dialog also checks whether this
client version matches the version of that server.

• The Advanced... button appears when choosing a server. It allows to define Advanced
Options.
 

 

• Connection:

• By default, when connecting to an Automation Engine server, the Pilot automatically
chooses the connection mode (Auto-Detect).

• When the Automation Engine server has a site-local address (e.g. 10.*.*.* or 192.***
or the range 172.16.0.0.0 - 172.31.255.255) the connection will use TCP/IP, otherwise
HTTPS is used.

• The default behavior assumes that an AE SaaS server has a public IP address and that
an AE server on-premises has a private IP address. The latter will not always be true.
So in that case a Pilot user can manually set the connection mode to TCP/IP. This
forces the Pilot to use a TCP/IP connection even when the IP address of the server is
not a site-local address.

• This setting is remembered for future sign-ins.

3. Possible messages or problems when signing in:

• When the attempt to sign in does not succeed immediately, you will see an extra dialog with a
Cancel button. This button is useful when you noticed that you for example mistyped the server
name, or when you just now remember that this client computer or the server is oine.
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So when you know there is no point in waiting, click Cancel to stop the authentication attempt
immediately.

• When a sign-in fails, you will be told if the problem is a wrong combo of the user name and
password you entered. In other cases, the message will, for security reasons, not add too many
details on the cause. It could be that you just mistyped the server name or any other type of
problem (network, server software not running, etc.)
 

 
When you are sure that your user name and password were correct, click Connection Doctor...
to start a first analysis of the problem. Learn more in the chapter Troubleshooting.

• When the version of the client software (the build nr.) is different from the one on the
Automation Engine server (typically the case right after the server software was updated), this
dialog will pop up:
 

 
Click Install Update to download the update. At the end of the download, the message "Ready
to install" appears. Then click Install and Relaunch to install the update on this client. When
finished, the Sign In dialog will be shown again.

On Mac, you need to enter the credentials of an administrator user to update the Pilot
application.

• When the system can't even find the sign-in options to offer to the client, then the version of the
server software is probably an older major version number. For example: The client software is
v20 but the server is still on v18.1.
 

 

Note:  It is possible to sign in to multiple Automation Engine (master) servers. Administrators
may need this functionality in special cases, like server migrations. To do this, sign in to the
Pilot of server 1, and in the resulting Pilot's File menu, ask a New Connection. This will open an
extra sign-in dialog where you can sign in to an other AE master server.
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4.  The Pilot's Main Window

Note:  The Pilot's user interface and its View modes are introduced in some of the "eLearning
Modules" that you can follow on the Esko Blended Learning platform.

 

 

1. The Pilot offers three View modes:

•
 Containers: This mode allows to access all Containers, which contain the network data that

Automation Engine is allowed to work with. Learn more in Containers.

•
 Job Overview: This mode lists all Jobs existing in the Automation Engine Jobs database.

Learn more in the dedicated chapter on Jobs.

•  Last used Job: This mode shows the last Job you opened, and the data in its Job Folder.
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2. The top tool bar:

•
 Create Job allows you to create a Job in the Jobs database. Learn more in the chapter

Jobs.

•
 New Task allows to launch a new task on the current selection.

•  New Workflow opens the workflow editor to create a new Workflow ticket. Learn more in
the chapter on Workflows.

•
 shows information about the selected Job or file.

• A search field that also allows to create filters.

3. The Views pane allows to focus on specific functionality of Automation Engine. Certain Views are
only shown in specific view modes. Learn more in Pilot Views and Tools.

4. The bottom bar offers this information:

• Left side: info on your current selection (could be files, tasks, jobs, etc.)
• Right side:

• Name of the Location of this server setup. A Location name is used (and here visible) when
several Automation Engines collaborate via Esko Cloud.

• Name of the Server computer.

• Name of the current User that logged on to this Pilot.

• Amount of to-do items for this user. Click  to open the 'To Do List' tool and see all to-dos.

• Amount of Alerts. Click  to open the list of alerts. Learn more in Alerts.

The contents of the central panes depends on the selected view Mode and View.

Using Tabs to enable Multiple Views

Tabs allow you to have multiple Views open in your Pilot.
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In any view, use any of these methods to create a new tab:

• Choose File > New Tab or use the shortcut Ctrl-T (Windows) or CMD-T (Mac).

• Once a tab bar is visible, you can also create a new tab

• by clicking .

• by right-clicking on the tab bar and choosing New Tab.

You can close tabs by using similar tools.

Note:  To close all other tabs but the current one, choose File > Close Other Tabs.

Smart Views

You can use the filter tool to create filters for specific views. When you save such a filter, they are listed
in the Views pane, in the category "Smart Views". so you can easily re-select them from there. Learn
more in Smart Views.
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5.  Concepts of Tasks, Tickets and Workflows

5.1.  Tasks

What is a Task?
A task is a background action executed on one or multiple files, folders or items in an Automation
Engine database. A task can be started by a user, by an external system or be triggered automatically
by Automation Engine itself.

There are many types of tasks:

• Conversion tasks such as Export to PDF, Export to PostScript...

• File Creation tasks such as Step & Repeat, Create 3D file...

• File Editing tasks such as Optimize PDF, Split Pages, Trap...

• Verification tasks such as Preflight, Inspect Braille...

• Administration tasks such as Copy or Move, Upload via FTP, ZIP...

• RIP tasks.

• Device Output tasks, communicating with CDI imagers, Digital presses or Kongsberg cutting tables.

Task Settings
A task are defined by many settings: these are

• the attributes of the task itself (for example its priority and the user who launched it),
• its parameters, usually saved as a task Ticket. These decide the specifics of what is executed in

background (for example a chosen resolution).

Task Progress
When a task is launched, you can monitor its progress and end status. Learn more in Checking the
Status of a Task on page 18.

5.2.  Workflows

A workflow ticket contains multiple steps. Launching a workflow results in multiple tasks. A workflow
step can be

• a single task ticket
• a workflow control

• a subworkflow (included or referenced).

An example:
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Just like single task tickets,

• you can launch workflow tickets from the Pilot, from the Shuttle or from within most Esko editors

• workflows can also be launched automatically, triggered by external signals (files arriving on access
points, commands from external systems, etc.).

You can build and launch workflows in the Workflow Editor. Learn more in the dedicated chapter on
Workflows.

5.2.1.  Task Chains (old workflows)

Task Chains are old workflows from Esko's former workflow server BackStage . They are still supported
in Automation Engine but will need to be migrated.

A Task Chain is a linear succession of tasks, linked together in a Task Chain ticket.

 

 

You can build new Workflows from these old Task Chains, while keeping all your tickets settings. Learn
more in Migrating Old Task Chains, a page in the chapter Workflows.

5.3.  Tickets

What is a Ticket?
A Ticket is a collection of parameters of a specific Task type. When a user (or system) selects files and
launches a Ticket, a Task is executed on the server.

Default and Custom Tickets
There is a default ticket for each task type. You can also create custom tickets. You cannot overwrite or
delete default tickets.
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The Tickets View shows all available tickets (default and custom).

Workflow Tickets

A Workflow Ticket contains the steps and parameters of several tasks. Its is also referred to as "a
Workflow".

Global and Job Tickets
• Global Tickets (  ) can be used on any file inside a Container (network areas that you allow

Automation Engine to work with).

• Job Tickets (  ) can only be used on data inside the Job Folder of the Job you saved them for.
Learn about Jobs in the chapter Jobs.

Public Tickets
Public Tickets are tickets that all Pilot users can see and use. These are also the ones you can launch
from a browser client, from Shuttle or directly from within Esko editors.

Note:  Depending on your User Access Rights, you may only see public tickets, and Public
Parameters inside these tickets.

Learn about making tickets public here.

5.3.1.  General Ticket Functions

A Ticket opened from the Tickets View
 

 

1. The top bar of the dialog shows an icon indicating the type of ticket (  = Global ticket,  = Job
ticket), followed by the name of the ticket and the type of task.

2. Menu items

• File menu (standard functions).
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• The View menu is only relevant when having selected input files first (see below section of this
page).

• The Advanced menu is where you can Manage Public Parameters. Learn more in Using Public
Parameters in Automation Engine on page 30.

3. An icon of the task type.
4. Click  to add Notifications that will be executed when the task is launched (or finished). When a

ticket includes notifications, the icon changes to . Learn more in Task Notifications on page
29.

5. Fields to specify the name and place of the files that this ticket creates. Typically, SmartNames are
used. Learn more in SmartNames.

6. The Parameters for this ticket.
7. Click  to see the online help page for this task type.
8. "Show Steps" is only relevant when you still have old "Task Chains" (a technology used before

"Workflow Tickets". Learn more in Old Task Chains.
9. Click Save to save the ticket and all its parameters. When you opened a default ticket, you will be

asked to Save As another name. Click Cancel to close the ticket without saving.

A Ticket opened after first making a File Selection

When you first selected an input file for a task ticket, the dialog actually shows more than a ticket: You
now see a ticket + input files + all settings to launch it.

This is why the dialog looks slightly different:
 

 

1. The title of the dialog now mentions the way this dialog was opened + the name of the selected
ticket.
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In above example, a user first selected a file in the Files view, then chose 'New Task' and then
selected the default ticket of the task 'Copy or Move File'.

2. Two extra topics in the menu bar:

• Edit: When you are viewing the list of input files (see below item 4), you here find the two
possible actions. Learn more below.

• View

• Show Files: To show or hide the pane that shows the input files. Learn more in below item 4.

• Task Options...: See below item 3.
3. An extra Task related menu bar:

• Launch: Launches this ticket on the selected input files and closes this dialog.

• Task Options: Learn more in the chapter explaining workflow tickets, which mainly offer the
same options: General Workflow Task Options.

• Priority: Choose the general priority with which you want to launch this task. The default is
Normal.

Note:  To choose High or Immediate, you need a special User Access Right.

Attention:  Depending on the current load on Automation Engine's workflow engine, the
request to start immediately and so bypass all other tasks is best only used occasionally.

• Hold: Check this when you want to hold the task when you launch it. The task will start but will
immediately go into 'pause' mode. You can then later decide when to release it, i.e. start it for
real. Learn more in Functionality on items in Tasks View.

• A ticket selector: Exceptionally, you can still select a different ticket for this dialog.
4. The input files. You can still

• Select and delete files from this list (use the delete shortcut or Edit >  Clear).

• Add extra input files to this list. Right-click in this pane to Select File....

Important:  In this dialog, using the Save Ticket (as...) function will still only save the
ticket parameters, just like in the first example on this page. A saved ticket never contains
information on input files or on task related options.
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6.  First Steps in Launching Tasks

6.1.  Launching a Task on a File

There are several ways to launch a tasks: from the Pilot, from Shuttle (plug-in), via Access Points or via
JDF/JMF.

We here describe how to launch a task from the Pilot's Files view.

Note:  Before you can launch RIP or Proofing tasks, you need to configure the matching RIP.
Learn more here.

1. In the Pilot, choose the Containers mode and select the Files view in the Views pane.

Note:  If you don't have any custom Containers yet, simply drag a file from outside the Pilot
onto a folder in your ExampleJobContainer. Learn more in Uploading files using the Pilot
and in Creating a Container.

2. Browse to your chosen file. Right-click it, and select either

• New Task if you want to open the ticket that you will select and check or change some of its
settings before launching the task.

• Launch with to immediately launch the task without opening the selected ticket.

Note:  If you don't have the access right 'Tickets: Show All Tickets and their Parameters
(Public and other)', you will only see 'Launch with'. In this case, you can only select Public
tickets, and only fill in Public Parameters in the ticket.

3. Select the ticket to use.

• If you have launched tasks previously, the most recent task tickets you used are listed. One
ticket is shown per task type. A small arrow indicates there were several tickets launched of this
task type.
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• If you didn't launch tickets yet, or if you need a different ticket, select 'Other'. Then select the
ticket you want to use and click OK.

Note:  This list only shows the tickets of task types that can be launched on the file type
that you selected. You can either choose a Default ticket or a custom ticket that was
created earlier.

4. Now choose one of these launching methods:

• If you chose New Task, the selected ticket opens. Fill in the settings you want to use and click

 Launch.
• If you chose Launch with and you have the access right 'Tickets: Show All Tickets and their

Parameters (Public and other)', the task is launched on the file as soon as you select the ticket.
You don't need to fill in any settings.

• If you chose Launch with and you don't have the access right 'Tickets: Show All Tickets and
their Parameters (Public and other)', the task is launched on the file

• as soon as you select the ticket if the ticket has no Public Parameters.
• If the ticket contains Public Parameters, it will first open for you to fill them in (you will only

see the public parameters). Click Launch when you are done.

Note:  For a description of all of the ticket's parameters for each task type, see the chapter
Tasks and Workflow Controls.

6.2.  Checking the Status of a Task

After launching a task on one or several file(s), you can check its processing status in the Pilot’s Tasks
pane (present in many Views).

 

 

You can see the Progress (in percentage) and the processing State. The state can be:

•  on hold
•  on hold until
•  running (for a Checkpoint task: waiting to be handled)
•  waiting (in the queue)
•  successfully done
•  part of workflow successfully done
•  done with warning
•  failed
•  cancelled

You can also double-click the task's entry in the Tasks pane to open your task ticket and check its
parameters.
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6.3.  Relaunching a Task

You can easily relaunch tasks, even when they are not finished yet.

• To relaunch one or multiple tasks without changing its settings:
a) Select the task(s) in Tasks view or the Tasks pane in another view.
b) Click CTRL-L (CMD-L) or go to Task > Relaunch.

• To first change its settings and then relaunch a task:
a) Select the task to relaunch.
b) Double click the task or go to Task > Open Task.
c) Change the task settings as necessary.
d) Click  Launch.

6.4.  Launching Workflows

How to create and launch workflows is described in the separate chapter Workflows.

6.5.  Creating Task Tickets

6.5.1.  Creating a Custom Ticket from the Tickets View

To create a custom ticket:

1. Open the Default ticket of that task type.

Note:  To create a custom Workflow ticket, see the chapter Workflows.

2. Select the wanted ticket parameters.
3. Go to File > Save As... or use the keyboard shortcut.
4. In the Save As dialog:

 

19



6 Automation Engine

 
a) Enter the name of your new ticket. You can not overwrite a default ticket.

Attention:  Ticket names are case-sensitive.

b) Add one or more Tags. This will help to sort and filter tickets.
c) Decide the Scope of the ticket: only to be seen and used in the (currently selected) Job or set

them Global (possible to use in all Jobs).
d) Select if you want to add the ticket to your Favorites.
e) Select Public if you want to show this ticket to all Pilot users and/or if you want to use it from a

browser client, from Shuttle or from Esko editors.

Note:

• Default tickets and Job tickets can not be made Public.

• In the Tickets view, Public tickets have a mark in the column 'Public'.

Note:  Alternatively, when you do not want to change any ticket parameters (yet), select the

ticket and click on  to duplicate it (and fill in a new name).

6.5.2.  Creating a Custom Ticket after Selecting a File

You can also create a custom ticket while you prepare to launch a task on a file:

1. Right-click your file(s), select New Task then Other...
2. In the Select Ticket dialog, select the Default ticket for the task you want to use.

Note:  If you do not see any Default tickets, check your Pilot Preferences.

3. Fill in the settings you want to use in the ticket.
4. Go to File > Save As... or use Ctrl + Shift + S (Windows) / Shift + Command + S (Mac).
5. In the Save As dialog:

a) Enter a name for this custom ticket.
b) Select if you want to add the ticket to your Favorites.
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c) Select Public if you want to show this ticket to all Pilot users and/or if you want to use it from a
browser client, from Shuttle or from Esko editors.

Note:

• Default tickets and Job tickets can not be made Public.

• In the Tickets view, Public tickets have a mark in the column 'Public'.
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7.  Performing Basic Configuration

7.1.  Creating Favorite Tickets

Tickets that you use a lot can be added to a list of Favorites. It then becomes easier to launch them,
even with only one click.

Favorite tickets are linked to:

• the User logged into the Pilot. Favorites are personal.

• the file type. The favorite tickets you see or add are only those that match the file type you selected.

7.1.1.  Creating a Favorite Ticket in the Files View

In the Files view, follow these steps to create a favorite ticket:

1. In the Containers or Last used Job mode, select a file (remember that you make favorites per file
type).

2. Right-click in the Launch Favorites pane and choose Add Favorite... .
When you have no favorites yet, click this dedicated link:
 

 
3. In the Add Favorite dialog, select the ticket you want to add as a favorite and click OK.
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The drop-down list top-left offers to filter the list of tickets based on filters that you saved in the
Tickets View. Learn about creating filters in Smart Views.

Note:  This dialog only shows the (single and workflow) tickets suitable for the file type that
you selected.

7.1.2.  Creating a Favorite Ticket in the Tickets View

In the Tickets view, you can either:

• Right-click your chosen ticket, select Add to Favorites and choose the group.
• When creating a ticket, select Add to Favorites in the Save As dialog.

 

 

7.1.3.  Using a Favorite Ticket

In any Pilot view where you can make a selection, follow these steps to launch a task by using a favorite
ticket:

1. Select the file(s) you want to launch a task on.

The Launch Favorites pane shows all the favorite tickets for this file type.
2. Click the favorite ticket you want to use.
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Note:  If you want to use another ticket of the same task type (for example another prepare
for Viewer ticket that is not a favorite), click the small arrow on the right side of the favorite
ticket and select one from the list. This helps to avoid making too many favorites.
 

 
Mind that a ticket only appears in this list when it has already been launched at least once.

3. The ticket opens. If necessary, review or edit its parameters.
4. Click Launch.

Attention:  If you do not want to open the ticket, but launch the task immediately, just press Alt
when clicking the ticket.

Learn more in the chapter on Workflows, where we describe extra features in the page Organizing and
Using Favorite Workflow Tickets.

7.1.4.  Organizing Favorites (Sorting and Grouping)

Sorting

In your Files view, right-click the Favorites pane and select Organize Favorites.... The resulting dialog
shows the default group named 'Favorites' and the tickets you already added.
 

 

In this dialog, you can

• Sort them. Just make a selection and use drag-and-drop to define the order in which they appear.
• Add or Remove any favorites from this group.
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You can even use SmartNames to define their name. Learn more in Adding a Favorite based on a
SmartName.

Grouping

Next the default group named 'Favorites', you can create your own groups.

Follow these steps:

1. In the Organize Favorites dialog: click Add Group, type in its name and click OK.
 

 
2. The new group appears in the Organize Favorites dialog.

 

 
3. Select the group name and click Add to start adding favorite tickets.

Attention:  If you do not do this right now, you will create an empty group when clicking OK.
This will make the group disappear again.
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Note:  You can also add a group by first making a selecting tickets:

• In the Organize Favorites dialog, select one or multiple tickets.

• Right-click and choose 'New group from selection'.

• An 'Untitled Group' appears. Rename it at wish.

4. Click OK to close.

You can drag-and-drop groups.

You can fold or un-fold groups.

You can drag-and-drop tickets from one group to another.

You can not create sub-groups.

Right-click the name of a group to Rename it or to Remove it (no confirmation is asked).

Note:  All changes are immediately visualized in your Pilot. This includes whether the
group's content is folded out or not.

Check the result in the Pilot's 'Favorites' pane. Don't forget that what you see there depends on your
selection.

7.2.  Creating Users (Introduction)

Managing Automation Engine Users is described in detail on the page about the Users view (part of the
chapter Pilot Views and Tools).
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7.3.  Configuring RIPs or Proofers

To start making output for devices, you need to configure the related RIPs or proofers.

Automation Engine is optimized to work with Esko Imaging Engine and Esko FlexRip/Proof.

To configure an Imaging Engine RIP, learn more in this page of the chapter "RIP'ing with Imaging Engine".
For FlexRip or FlexProof, see their item in the tool "Configure".

7.4.  Pilot Preferences

Go to Edit > Preferences to define some Pilot preferences.

Pilot preferences are saved for the current user.

7.4.1.  Tickets

• Show default tickets: Deselect this option to hide the default tickets in all lists that show tickets.

Note:  This preference is only available if you have the Access Right 'Tickets: Show All
Tickets and their Parameters (Public and other)'.

• Use bold ticket names in task launching menu: When choosing New Task or Launch with, select
this if you want to see the ticket names for each shown task type in bold.
 

 

• Open public parameter dialog: When selected, opening a ticket will not open the full ticket dialog
but show a dialog that only contains the ticket's public parameters.

This is also (one of) the effect(s) when you do not have the Access Right 'Tickets: Show All Tickets
and their Parameters (Public and other)'.

When administrators are building simplified ticket dialogs, being able to select and deselect this
preference allows them to preview how the dialog will look for users who do not have that access
right.

Note:  This preference is only available if you have the Access Right 'Tickets: Show All
Tickets and their Parameters (Public and other)'.
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Note:  Before v21, this option was named 'Show only Public Parameters in Tickets'.

• When launching, do not open empty public parameter dialog:

Select this when, at the moment you launch the ticket, you do not want to see a public parameter
dialog when there are no public parameters.

• When launching a favorite ticket: These 2 shortcuts are always available but one of them changes
its function depending on an above selected preference:

• Alt-click: Launches task: Holding the Alt key while clicking on a favorite ticket is the standard
shortcut to launch that ticket without opening it.

• Ctrl-click / Cmd-click:

• When the preference Open public parameter dialog is selected, this shortcut opens the task
launch dialog with all ticket options ("Opens task launch dialog").

• When the preference Open public parameter dialog is not selected, this shortcut opens the
public parameter dialog ("Opens public parameter dialog"). This shortcut then overrules that
preference.

This also serves the use case of an administrator that is preparing a set of tickets and their
public parameters. This shortcut prevents that he even has to come back to this Preferences
dialog and (de)select a preference just to check how the dialog will look to the regular user
(who is only using public parameters).

7.4.2.  Units

• Units: Select the units you want to work with for Dimension (mm, cm, mil, inch, point), Resolution
(ppi, ppmm, ppcm) and Ruling (lpi, lpmm, lpcm).

• Enter the number of Decimals you want the system to display.

Note:  Changes that you make here are automatically adopted in the Shuttle and vice versa.

7.4.3.  Files

• Preview Size (Info): This defines the size of the preview in the Info (XMP) dialog (in pixels).

• Open Normalized PDF files with: This defines which application should become the default
application when opening Normalized PDF files from within the Pilot. Learn about 'Normalization' in
Normalized PDF and XMP in Automation Engine.

Normalized PDF files have a .PDF extension. The OS of your client computer will not make a
distinction between Normalized PDF files and regular PDF files.

By default, PDF files will be opened by the OS with Adobe Acrobat Reader (when installed). However,
when working with the Pilot, you may want to open Normalized PDF files in an Esko editor. Because
making this distinction is not possible on OS level, you here have to specify which application you
prefer to use. To do this, choose Other and Browse to the application's program file.
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An example effect is that, if you double-click a PDF file in the Pilot, and it happens to be a
Normalized PDF file, the application that you defined here will open that PDF.

This preference will be taken into account:

• in the Files view, when double-clicking the file or selecting Open from the pop-up menu

• in the Tasks view, when selecting Open Output File from the pop-up menu

• in the To Do List, when clicking a URL link to a PDF.

Tip:  The Pilot also offers 'Open with', which allows you to select a non-default choice.

7.4.4.  Pilot

• Number of recently used jobs in the job selector:

Indicate how many you jobs you want to see in these drop-down lists (10 by default). Changes are
applied when you sign back in to the Pilot.

• When switching views, keep search criteria:

Select this option when you want to keep the search criteria when switching to another View tab (of
the same type of View).

7.4.5.  Jobs

Multi-Job Removal

Select your preferences when you remove multiple Jobs at once:

• Remove Jobs even when they are in use by other users.

• Remove Jobs even when they contain unfinished tasks.

7.5.  Task Notifications

Each task ticket can trigger a Notification. The system will so notify someone by sending an E-mail
when that task finishes in a specified state. A notification can also notify an external system by feeding
it an XML or a TXT file with the same type of content.
 

 

Note:  In workflows, when your goal is to send an E-mail, consider using the separate task
"Send E-mail" instead.

Learn more in the pages on setting up Notifications in the Configure tool.
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8.  Using Public Parameters in Automation
Engine

Concept

Users often do not want or need to see all the parameters of a selected task ticket. You can make them
see and define only the parameters that you decided to make Public. Seeing less options makes it
simpler and helps reduce mistakes.

Ticket parameters that are made Public will be the only parameters visible to users when they want to
launch tasks from:

• Automation Engine client applications: Pilot, Shuttle and browser client workspaces.
• Esko Editors connected to the Automation Engine server: ArtPro+, DeskPack (Adobe Illustrator) and

the legacy editors ArtPro, PackEdge, Plato, FastImpose.

Note:  Only Public Tickets can be launched from these client applications or editors.

For each Public Parameter, you can decide if the user can either:

• select a value from a list,
• enter a value himself.

8.1.  Making a Parameter Public

Note:

• Not all ticket parameters can be made public.
• Parameters need to be made public before you start the workflow that their ticket is part of.

Open the ticket and follow these steps:

1. Right-click the parameter and select Make Parameter Public.
2. Right-click it again and select Modify Public Parameter...
3. In the Modify Public Parameter dialog that opens:

a) Prompt as: If you want, change the way the parameter will be called in the client application.
b) Choose either:

• Allow the user to set the value: Select this if you want users to be able to freely enter a
value.
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• Let the user select a predefined value: Select this if you want users to choose from a list of
values that you define.
 

 

Note:  Users will only see (and choose from) the Predefined Settings. They will not
see the associated Values. So if they need to be aware of the value, just add it to the
name of the setting.

In the above example, this is how the public parameter will look like to the users of
the client application:

If you chose 'Allow the user to set the
value'

If you chose 'Let the user select a
predefined value'

 

 

 

 

If, in the ticket, that parameter already offers a list of values to choose from, they will be
displayed here.

Default Predefined Setting: You can here define the setting that will be used when the user
didn’t select another one.

4. Click OK.

Important:  Settings related to public parameters are saved when you save the ticket.

Important:  Don't forget to save the ticket itself as 'Public' as well.
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8.2.  Managing Public Parameters in a task Ticket

The Manage Public Parameters... dialog of a ticket is where you overview and manage its public
parameters. In this dialog, your goal is to make it as simple as possible for the user that is asked to set
these parameters.

1. In your ticket, go to Advanced > Manage Public Parameters...
 

 

The left pane shows all the parameters in this ticket that can be made public. The ones that were
already made public are greyed out.

The right pane shows the public parameters and their settings.
2. You can:

• drag parameters from left to right to make them public
• click  if you don’t want it to be public anymore
• drag them up or down to rearrange the order that they will be shown to the user.
• change public parameters’ settings (Prompt as, Predefined Settings, etc.)
• group public parameters under a custom header (click Add Group, click  to edit the header

and drag parameters from the left). An example:
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• use Presets to further simplify the users' choices (see Making Presets to Simplify the Users’

Choices on page 33).

8.2.1.  Making Presets to Simplify the Users’ Choices

Presets are customized combinations of parameters. They limit the amount of decisions that users
have to make.

Example

Let's assume you want users to use different trapping settings when printing offset versus dry offset.
You can collect those trapping settings in a Preset, so that users will only have to choose between
'offset' and 'dry offset'.

We start from a dialog of a workflow ticket where the trapping step has 3 public parameters:
 

 

1. Click  to remove the (default) Group named "Trap with PowerTrapper"
2. Click Add Group.

A new "Untitled Group" is created. Click  to change its name.
3. Click Add Preset.

A new "Preset" is created. Click  to change its name.
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By default, two example values will appear. The preset was renamed to 'Choosing Process to
Decide Traps':
 

 
4. Define what the users will see:

a) in Prompt as, enter the text that users will see (replacing 'Type the name of the preset
here (e.g. “Paper Size”)')

b) enter the values that the users will choose from (replacing 'Type a value here (e.g.
A4)'). In our example, we add 'Offset' and 'Dry Offset'.

Click Add if you want to add extra values (not the case in our example).

5. Drag the parameters from the dialog’s middle pane onto one preset item. This will make them
automatically appear under each preset item (here both under Offset and Dry Offset).
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6. Define the parameters values for each preset item.

See the above screenshot for a good example.
7. Use the buttons Move Up / Down to define the order of the Presets in the panel that the end-user

will see.
8. Click OK to confirm and close the dialog.
9. Save your ticket to also save these public parameters.

This is how the resulting dialog will look like to the users of the client applications:
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9.  Uploading Files to Automation Engine
You can work with files that are already stored in your Containers, or with files that you (first) upload to
Automation Engine.

Read below about several techniques to upload files. Some of those also immediately launch a
workflow on the uploaded files.

9.1.  Uploading Files using the Pilot

In the Pilot, in the Container mode or in the Last used Job mode, there are two ways to manually
upload files:

• Drag and drop files or folders from outside the Pilot onto a folder in the Pilot. Or use copy/paste
shortcuts.

• Right-click your destination folder or go to File > Upload Files.... In the dialog that opens, browse to
your files or folders and click Upload.

About multiple uploads and cancelling uploads

When the upload is not immediately finished, an Upload window appears and you can continue working
with the Pilot. You can upload multiple sets of files. When other files are still uploading, they will be
added to this Upload window.
 

 

All uploads can be canceled individually. Click  to stop the upload immediately. Any partially uploaded
files will be deleted.

When all uploads are done, the Upload window automatically closes.

9.2.  Uploading Files from an FTP Server

1. In Containers mode or in Last used Job mode, right-click the folder in which you want to upload
your file, and select Upload Files from FTP Site....
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This opens the Upload from FTP Site dialog, where you first need to enter the settings for the FTP
connection:
 

 
2. In Host, enter the name of the FTP server that hosts your files.

Tip:  To use a port other than the default port, add ' :' and the port number after the host
name. For example: myftpserver:1085

3. Enter a User Name and Password that corresponds to an account on the FTP server.
4. In File Transfer, choose between Binary and ASCII.

Binary will always work, but if you have an ASCII file, the transfer will go a bit faster when selecting
ASCII.

5. By default, the transfer uses Active Connection Mode (where the FTP server opens the data
connection).

If your system is behind a firewall that blocks incoming FTP server connections, select Passive to
use Passive Connection Mode (where the client initiates the connection).

6. Select Secure FTP if you are connecting to a secure FTP server (over FTPS, not SSL or SSH).

Tip:  If you are experiencing problems using secure FTP, try connecting over regular FTP,
and ask your IT administrator to check the security settings of your FTP server.

7. Options: A field for one or more exceptional options, formatted as key-value pairs. For example:
When you experience problems when interfacing to a Rumpus FTP Server, add systemKey=UNIX
in this field and try again.
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8. Select 'Remove remote data after transfer' if you want to delete the files from the FTP site once
they are uploaded to Automation Engine.

This enables the option to 'Backup remote data before removal'. When selected, indicate the
Backup Folder where the files should be copied.

9. When you are done, click Connect to establish the connection.
10. Click Upload to start the file transfer.

9.3.  Using Access Points to Upload Files

Access Points are documented here in the dedicated chapter Integrating with External Systems.

9.4.  Using Shuttle to Upload and Process Files

You can upload and immediately process files from any Mac or Windows client computer using the
Shuttle tool.

Learn more in the chapter Working with Shuttle.
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10.  Launching Tasks from Editors

10.1.  Setup Requirements

For Esko editors and DeskPack (Adobe Illustrator) to be able to connect to an Automation Engine
server, the "Shuttle Server" component needs to be running. Learn more on this page of the
Configuration tool.

In the Preferences menu of the editor, you also need to define which Automation Engine server you
want to connect to.

10.2.  Launching Tasks from ArtPro+

Launch a task from ArtPro+ is described in the chapter Workflows, in the page on Launching a Workflow
with Public Parameters.

10.3.  Launching Tasks from Adobe Illustrator (the Shuttle
Plug-in)

Note:  To launch tasks from Adobe Illustrator, you need to install the Shuttle Plug-in. Download
it from https://mysoftware.esko.com/.

Follow these steps to launch a task or workflow on the file that you have open in Illustrator (and in front
of any other open files):

1. Go to File > Launch Workflow... or use Option + CMD + Z.
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2. In Launch As, choose Esko PDF to copy a Normalized PDF or PDF+ version of your file onto the

DeskPack Container. Choose Adobe PDF to copy the Adobe Illustrator PDF version.

• 'Esko PDF' uses the 'PDF Export' plug-in to convert your Illustrator file to either Normalized PDF
or PDF+, depending on the setting in Ink Manager. To refine the conversion, you can select one
of the PDF Export Presets, or click Settings... and edit the PDF Export Settings. These changes
are not saved.

• 'Adobe PDF' uses the Adobe PDF preset 'Illustrator Default'.

Note:  'Color Conversion' and 'Profile Inclusion Policy' are not part of the preset
'Illustrator Default', but Launch Workflow will apply color conversion with the last
settings used.

3. If you want to link your file to an existing Automation Engine Job, fill in an existing Job ID and/or
Job Sub ID. The task on the Normalized PDF will then run in that Job context, which means it can
use the Job Setup parameters when SmartNames refer to them in the selected workflow..

Note:  If your open file is already saved in an Automation Engine Job folder, the Job ID and/
or Job Sub ID will be filled automatically.

4. Select the task or workflow you want. If it has public parameters, fill them in.
5. Click Launch. If your file was changed since the last save, you can click Save and Launch to first

save your document and then launch the task.

10.4.  Launching Tasks from ArtPro

In Preferences > Servers >  Shuttle, add the name of your Automation Engine server.

Note:  In that same dialog, the tab Automation Engine serves to define other preferences
related to that server. You do not need to fill that one in when you only need this connection to
the "Shuttle Server".
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1. To launch a workflow on the currently open file, go to File > Launch Workflow...

This opens the Launch Workflow dialog.

 

 
2. Launch as: Your open file is an ArtPro file, but you can choose as which file type you will send it to

the selected workflow.

If your workflow is... you can launch the file as... with...

an Automation Engine
workflow accepting Normalized
PDF files as input,

Normalized PDF either Normalized PDF or
Normalized PDF (embedded).

an Automation Engine
workflow accepting PDF files
as input,

PDF any of the available PDF
flavors.

an Automation Engine
workflow accepting ArtPro files
as input,

ArtPro with the included images (TIFF,
EPS...) or without (then only the
ArtPro file and any ArtPro CT
file).
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3. If you want to add your file to the Job Folder of an Automation Engine Job, select it from the Job
list or fill in its Job ID and/or Job Part ID.

Note:  Use the Search... button to see a list of active Jobs, including some of their
metadata.
 

 

4. If you want to add your file to an Automation Engine Product, select it from the Products list or fill
in the Product ID and/or Product Part ID.

Note:  Use the Search... button to see a list of your server's Products.

5. Select the workflow you want to launch.
6. Fill in any of its Public Parameters.

If you want to go back to the default parameters values after changing them, click 'Reset To
Defaults'.

7. Click Launch.

10.5.  Launching Tasks from PackEdge or Plato

Attention:  Before you can launch a task on it from within PackEdge or Plato, you must save
your file on an Automation Engine Container.

1. Go to File > Launch Workflow...

The dialog lists all public tickets. When selected, a ticket shows its Public Parameters.
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Tip:  When you expect tickets to show up here but none do, check if the Shuttle server is
running.

2. Select the task or workflow you want. If it has public parameters, fill them in.
3. Click Launch to launch that workflow on your open file.

Tip:  To access this "Shuttle Server" easily in the future (without using the menus):

1.

Go to Window > Toolbars > Shuttle to open the Shuttle palette. 
2. Drag it into your application's toolbar.
3.

Click  to open the Launch Workflow window. Click  to open the Shuttle window
where you can monitor and manage the launched tasks.

10.6.  Launching Tasks from FastImpose

When working with FastImpose Server, you must save your file on an Automation Engine Container
before you can launch a task or workflow.

1. Go to File > Launch Workflow...
2. Choose what file type you want to launch your file as.

• When working with FastImpose Server, you can only launch your file as an IMP file.
• When working with FastImpose Standalone, you can launch your file either as a JDF or a PDF file.

Click the Settings... button to set JDF or PDF Export Preferences. Learn more in the
FastImpose documentation.

3. Select the workflow you want. If it has public parameters, fill them in.
4. Click Launch to launch the workflow on your file.
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