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1Automation Engine

1.  What is Shuttle?

The Automation Engine Shuttle is a client tool for easy submission of files to Automation
Engine workflows. Shuttle also allows monitoring of the workflows.

The Shuttle functionality is also integrated in ArtPro, Neo, PackEdge, Plato, FastImpose and in
Adobe Illustrator as a DeskPack plug-in. This enables to launch tasks from inside these editors.
This setup is described in this documentation.
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2.  Installing Shuttle
The Shuttle is one of the client tools that you can download with the Automation Engine
Server Web Page.

Open this Server Web Page by entering http://<name of your master server>  or http://<name
of your master server>:9999 in the address field of your browser. You can find this tool in the
section Client Apps, in the page Main.

If the Shuttle application is already installed on your computer, the system will check if you
have the appropriate version and download updates if necessary.
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3.  Shuttle Setup

3.1.  Configuring Shuttle in Automation Engine

1. In the Pilot, go to Tools > Configure.
2. Select Shuttle in the left pane.

 

 
3. Enter the Port to use for communication between your Automation Engine server and the

Shuttle clients.

Note:  By default this is port 5182, but if this port is already used by other processes, you
should enter the next available port.

4. Click on  and select an Upload Folder.

This is where Shuttle clients will upload files that are not located in a Container (except the
Shuttle plug-in, that will always upload files to the DeskPackContainer).

Note:  The Upload Folder must be located in a Container.

5. Select 'Start Shuttle server automatically when Automation Engine is started' if you
plan to make frequent use of the Shuttle technology.

6. Select 'Use the task history to re-launch using the same public parameters' if you want
Shuttle to propose to use the same public parameters when you launch a same file on the
same workflow. The Shuttle then checks prior tasks both in the Tasks Monitor and in the
Task History tool.

7. Click the Start button to start Shuttle server.
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The Shuttle server now makes Automation Engine’s workflows, tasks and files accessible to
the Shuttle clients.

8. Save your settings.

Note:  If you need to make changes to this Setup, you must Stop the Shuttle server first.

3.2.  Making Tickets Public

Only Public tickets (of single tasks or workflows) can be launched from Shuttle (or from the
client applications using Shuttle).

Learn about making (workflow) tickets public here.

Note:  Default tickets and (blue) Job tickets can not be made public.

3.3.  Shuttle Clients Connecting to Any Server
The Shuttle (in all its forms) can connect to one or more Automation Engine servers.

1. Launch Shuttle (standalone or the editor plug-in).
2. Open the Preferences.

In... go to...

Adobe Illustrator • (Mac)Illustrator > Preferences > Esko > Shuttle Preferences...

• (Windows) Edit > Preferences > Esko > Shuttle Preferences...

ArtPro ArtPro > Preferences... or use Command + K

PackEdge/Plato (Windows) Edit > Preferences >  Server&Resources

Neo Neo > Preferences... or use Command + , (comma)

FastImpose
Standalone

Tools > Shuttle Preferences...

3.
In the Servers tab (Advanced tab for Neo), click  at the bottom of the Servers list.
 

 
This dialog opens:
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4. Enter your User Name and Password.

• When connecting to an Automation Engine server, enter the User Name and Password
you use to log in to the Pilot (the password can be blank if your server is configured to
accept this).

You will have the same access rights in Shuttle as you have in the Pilot (for example the
right to set processing priorities or not).

5. To connect to a server not broadcasting over the 'Bonjour' network (Automation Engine
servers or non-Bonjour-enabled Nexus servers):
a) Select Manual in the Browse Method list
b) Enter your server’s name or IP address in Server Address
c) Fill in the Server Port used by your server.

Note:

When connecting to an Automation Engine server, enter the port you defined in
Configure).

6. Click Add.

This adds a connection to your server in the Servers list.

•
To remove the connection to a server, select it in the Servers list and click .

• To check or edit a server’s settings, double-click it in the Servers list.

Note:

If you are using the Shuttle plug-in with other DeskPack plug-ins, and you have set up a server
connection with the Server Connection Assistant, you will see this connection in bold in the
Shuttle plug-in’s Servers list (after restarting Illustrator).

You will be able to change the user name and password if necessary, but you will not be able to
remove this connection from the Shuttle plug-in.

Learn more about the Server Connection Assistant in the Adobe Illustrator Client documentation.
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3.4.  Shuttle Clients Connecting only to Automation
Engine

The Shuttle clients in PackEdge, Plato and FastImpose Server can only connect to one
Automation Engine server.

1. Launch the application.
2. Open the Preferences.

• In PackEdge or Plato, go to Edit > Preferences or use Ctrl+Alt+Shift+P.
• In FastImpose Server, go to Tools > Options...

3. In the Server&Resources tab (the Server tab for FastImpose Server):
a) Select Connect to Automation Engine Server.
b) Enter the Automation Engine Server Name and click Check.

You should see a message saying the server is up and running.
c) Select 'Login with the following user account settings', and fill in the User Name and

Password you use to login to the Pilot.
If the connection is successful, you will see a green dot and the message 'Connected as
user ...'
 

 

Tip:  If you are a Pilot on the same computer, or another Shuttle client (either PackEdge,
Plato or FastImpose Server), you can select 'Login automatically with user name and
password from other application connected to the server'.

This way, if you are already logged in to the Pilot or the other client application, you won't
need to log in when starting PackEdge / Plato / FastImpose Server.

4. Restart your application.
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4.  Launching the Automation Engine
Shuttle

When you launch the Shuttle application, the window shows a list of launched Tasks and a
Launch Panel where you can define one or multiple drop areas that each launch a specified
workflow:

 

 

• To open a new window, go to File  >  New Window. You could use dedicated Shuttle
windows for each of your Workflows.

• Use the View menu to hide or show parts of this window:

• View > Tasks hides/shows the Task monitor.

• View > Launch Panel hides/shows the Launch Panel.

• View > Status Bar hides/shows the Status Bar indicating the progress.

• When closing, Shuttle saves the settings of the windows.
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5.  Working with the Automation Engine
Shuttle

Starting the Shuttle will ask you to login to the Automation Engine Server.

Note:  Whether this user can also start up a Pilot is decided by a specific User Access Right.
Learn more in Access Rights.

Menu items

• File: To launch one or more files on the one defined workflow (after browsing for files), or to
open and close Shuttle windows.

• Edit: To cut, copy or paste text in the search field. To select and delete tasks. Or to define
Preferences.

• View: To show or hide the Task Monitor, the Launch panel and the Status Bar.
• Task: To open or show the output file of the selected Task, to release or cancel the Task, or

to add Annotations and show the task's Details.
• Tools: To open the To Do List.
• Window: To minimize, zoom or switch between Shuttle windows.
• Help: To see the About window or to access this online documentation.

Setting the Preferences for Shuttle

On Mac, select Preferences... in the Application menu. On Windows, go to Edit >
Preferences...

In the Preferences dialog, set the units for Dimension, Resolution, Ruling and the number of
Decimals to use.

Select 'Always show launch dialog' if you want to see the Public Parameter dialog when
starting a new task, even if there aren't any public parameters. This allows you to change these
parameters before launching the task.
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5.1.  The Task Monitor
The Task Monitor is the part that shows the Automation Engine tasks that were launched both
from Shuttle and Pilot clients. One row represents or a single task or one step of a workflow.

You can filter the displayed list tasks:

• By filtering on a Job context from the Job selected from the drop-down list in the toolbar.

Select Other... if you want to select a Job other than the recently used ones in the list. Select
All Jobs to clear the current filter.

• By typing in a value in the filter. Learn more about creating filters in Using Filters.

Note:  In Shuttle, you cannot open or edit a task. This is only possible in a Pilot.

Tip:  You cannot hide the columns displayed in the Task Monitor. However, you can change
their order and width.

Tasks asking for User Intervention

Workflows that including a Wait for Action task will show when they reached this step in
the column Phase. This allows the Shuttle user to intervene and decide how the workflow
continues.

 

 

To intervene,

• Click on the User intervention needed link.
• In the resulting To Do window, choose to Forward or Release. Learn more in User

Intervention from the Shuttle on page 14.

Context menu options

Right-click on a task to access these options:

• Open Output File: To open the task's output file with the appropriate application (if
possible).

• Show Output File in Finder / Explorer: To see the folder that contains the output file in
(Mac) Finder or (Windows) Explorer.

• Release: To release a task that is on hold.
• Cancel: To cancel a running task.
• Delete: To delete a finished task. You will be asked to confirm.
• Annotation...: To add or modify an annotation.
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• Details: To see a dialog with detailed information about the task (step).

Tip:  These options are also available via the Task menu.

5.2.  The Shuttle Launch Panel
The Launch Panel is where you drop one or multiple files as input files for that workflow. Each
drop area launches a specific workflow and is indicated with a large arrow.
 

 

• Click  to add an extra drop area.

Note:  To remove a drop area:

• Click . This changes the user interface in editing mode.
• Click  on the top left corner of the drop area that you want to delete.
• To leave the editing mode, click again on  or press Escape.

• Below each drop area, select the desired workflow from the drop-down list.

Attention:  Only Public tickets are listed.

Note:  The drop areas and their assigned workflow are saved when you close Shuttle.

5.3.  Launching a Workflow from the Automation
Engine Shuttle

1. If the Launch Panel is not visible in the Shuttle window, go to View > Launch Panel.

12



5Automation Engine

2. Submit one or more files in one of these ways:

• Drag and drop the desired file(s) onto a drop area.
• Go to File  > Launch... and select the files.

• Use the keyboard shortcut CMD-L (Mac) or Ctrl-L (Windows) and select the file(s).

Note:

• If a file was previously launched on the same workflow, a dialog will open and ask if you
want to reuse the public parameter values from the previous launch. If you choose to
reuse these values, they will be used as default parameter values. You can still edit these
values if necessary.

• The selected file(s) will be uploaded to the root folder of the selected Job. When no Job is
selected, it will be copied to the Upload Folder defined in the Configure panel.

• If a file with the same name is already present in the upload folder, a dialog will warn
you about overwriting the file. You can then choose to either Replace the existing file, or
Cancel the launch.

3. If the workflow has Public Parameters, the New Task dialog will ask you to fill them in.
Learn more in Using Public Parameters in Workflows.
An example:
 

 
a) Click Task Options to define general task options. You can:

• Set the Priority of the task (Low, Normal, High or Immediate).

• Select Hold to keep the task from being launched until someone releases it (via a
right-click or via the Task menu).

Alternatively, use 'Release at' to hold the task until a specific time, after which it will
automatically be released.

Note:  You can later change this automatic release setting by selecting Release via
the right-click menu in the Task Monitor or via the Task menu.
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• Select 'Launch a separate Task per input file' to launch a separate task or workflow
for each input file.

• You can also set an Annotation for the task.

 

 
4. Click Launch to launch the workflow.

The task will immediately appear in the Task Monitor.

5.4.  User Intervention from the Shuttle

When the launched workflow contains a Wait for Action (Checkpoint) step, a User intervention
needed link appears in the Task monitor when that step is reached..

1. Click on the User intervention needed link to open the To Do dialog.
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2. Optionally, select 'I am currently handling this to do item' to mark that you are handling

this item (other users are so also informed).
3. Decide how you want to Release this item. The offered choices are those that were decided

in the ticket of the 'Wait for Action (checkpoint)' task.
Select the wanted output state. The To Do window will close and the workflow will continue
processing.

4. In stead of releasing the item, you could Forward or Delete it.

• Click Forward, choose the user and set other details. The other user then needs to
decide how and when the workflow continues.

• Click Delete to delete this item and also end the processing of the workflow.
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