Automation Engine

Pilot Views and Tools
Contents

1. Concepts and Overview .......................................................................................................................... 5

2. General Views ............................................................................................................................................ 8
   2.1 The Files View ....................................................................................................................................... 8
   2.2 The To Do List View ............................................................................................................................... 9
      2.2.1 Checking To Dos .............................................................................................................................. 9
      2.2.2 Handling a To Do ............................................................................................................................ 11
      2.2.3 Creating a To Do Message .............................................................................................................. 11
   2.3 The Products View ............................................................................................................................... 12
   2.4 The WebCenter View ........................................................................................................................... 13
   2.5 The Tasks View .................................................................................................................................... 15
      2.5.1 Functionality on items in Tasks View ............................................................................................ 16
   2.6 The Milestones View ............................................................................................................................ 19
   2.7 The SmartNames View ......................................................................................................................... 19
   2.8 The Tickets View .................................................................................................................................. 20
      2.8.1 Functionality on items in Tickets View ......................................................................................... 21
   2.9 The Jobs View ....................................................................................................................................... 24

3. Commercial Print Views .......................................................................................................................... 25

4. Sign & Display Views ............................................................................................................................... 26
   4.1 The Gang Run Printing View ................................................................................................................. 26
   4.2 The Orders View .................................................................................................................................... 26

5. CTP Flexo Views ...................................................................................................................................... 27

6. Cutting Tables Views ................................................................................................................................ 28

7. Smart Views ............................................................................................................................................... 29
   7.1 Using Filters and Creating Smart Views .............................................................................................. 29

8. Setup Views ............................................................................................................................................... 32
   8.1 Devices .................................................................................................................................................. 32
   8.2 FlexRips ............................................................................................................................................... 32
   8.3 Queue Monitor ..................................................................................................................................... 33
   8.4 Containers ........................................................................................................................................... 35
      8.4.1 Creating a Container ....................................................................................................................... 35
      8.4.2 Removing a Container ..................................................................................................................... 36
      8.4.3 Relocating a Container ................................................................................................................... 37
      8.4.4 Refreshing the Containers’ List ....................................................................................................... 38
      8.4.5 Troubleshooting Containers .......................................................................................................... 38
   8.5 Access Points ...................................................................................................................................... 39
9. Tools ........................................................................................................................................... 49
   9.1 To Do List ................................................................................................................................. 49
   9.2 CTP Queues ............................................................................................................................. 49
   9.3 SmartNames .............................................................................................................................. 49
   9.4 Task History .............................................................................................................................. 50
      9.4.1 Task History Menus .......................................................................................................... 51
      9.4.2 Task History Toolbar ....................................................................................................... 52
      9.4.3 Task History List .............................................................................................................. 53
      9.4.4 Why and How To Archive parts of this History .............................................................. 54
   9.5 Devices ..................................................................................................................................... 55
   9.6 FlexRips .................................................................................................................................... 56
   9.7 Queue Monitor .......................................................................................................................... 56
   9.8 Containers ................................................................................................................................ 56
   9.9 Access Points ............................................................................................................................. 56
   9.10 Customers ................................................................................................................................. 56
   9.11 Users ....................................................................................................................................... 56
   9.12 Merger Monitor ........................................................................................................................ 56
   9.13 Configure ................................................................................................................................. 58
      9.13.1 Overview and main functionality .................................................................................... 58
      9.13.2 ArtiosCAD Servers .......................................................................................................... 59
      9.13.3 Automation Engine Database ......................................................................................... 61
      9.13.4 Automation Engine Web Service .................................................................................... 68
      9.13.5 Cloud Storage Services ................................................................................................. 68
      9.13.6 Create DCS Master ......................................................................................................... 71
      9.13.7 Digital Press ...................................................................................................................... 71
      9.13.8 E-Mail Configuration ........................................................................................................ 72
      9.13.9 External Databases .......................................................................................................... 74
      9.13.10 External Web Services ................................................................................................... 76
      9.13.11 FastImpose Site Preferences ......................................................................................... 77
      9.13.12 FlexProof - Image Downloader .................................................................................... 78
      9.13.13 FlexRip - Approval ......................................................................................................... 79
      9.13.14 FlexRip - B ........................................................................................................................ 80
      9.13.15 FlexRip - BI (Barco Imagesetter) .................................................................................... 81
      9.13.16 FlexRip CDI, CDI Spark and CDI Compact .................................................................. 82
      9.13.17 FlexRip - HP Indigo 4000 Series .................................................................................... 83
      9.13.18 FlexRip - Proofer Output ............................................................................................... 84
      9.13.19 FlexRip - Screened Output ............................................................................................. 85
<table>
<thead>
<tr>
<th>Section Code</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>9.13.20</td>
<td>FlexRip - Unscreened Output</td>
<td>87</td>
</tr>
<tr>
<td>9.13.21</td>
<td>Gang Run Printing</td>
<td>88</td>
</tr>
<tr>
<td>9.13.22</td>
<td>Global Vision</td>
<td>89</td>
</tr>
<tr>
<td>9.13.23</td>
<td>Imaging Engines</td>
<td>90</td>
</tr>
<tr>
<td>9.13.24</td>
<td>Jobs</td>
<td>90</td>
</tr>
<tr>
<td>9.13.25</td>
<td>Nexus</td>
<td>97</td>
</tr>
<tr>
<td>9.13.26</td>
<td>Notification</td>
<td>97</td>
</tr>
<tr>
<td>9.13.27</td>
<td>Odystar</td>
<td>100</td>
</tr>
<tr>
<td>9.13.28</td>
<td>Proof Servers</td>
<td>100</td>
</tr>
<tr>
<td>9.13.29</td>
<td>Plate Merger</td>
<td>101</td>
</tr>
<tr>
<td>9.13.30</td>
<td>Preflight Tools</td>
<td>101</td>
</tr>
<tr>
<td>9.13.31</td>
<td>Printing Methods</td>
<td>102</td>
</tr>
<tr>
<td>9.13.32</td>
<td>Processing Preferences</td>
<td>103</td>
</tr>
<tr>
<td>9.13.33</td>
<td>Products</td>
<td>103</td>
</tr>
<tr>
<td>9.13.34</td>
<td>SAP Servers</td>
<td>110</td>
</tr>
<tr>
<td>9.13.35</td>
<td>SFTP sites</td>
<td>110</td>
</tr>
<tr>
<td>9.13.36</td>
<td>Secure Web Proxy</td>
<td>111</td>
</tr>
<tr>
<td>9.13.37</td>
<td>Scripts</td>
<td>111</td>
</tr>
<tr>
<td>9.13.38</td>
<td>Shuttle</td>
<td>111</td>
</tr>
<tr>
<td>9.13.39</td>
<td>Track Edit Session</td>
<td>112</td>
</tr>
<tr>
<td>9.13.40</td>
<td>Viewer</td>
<td>112</td>
</tr>
<tr>
<td>9.13.41</td>
<td>Web Proxy</td>
<td>114</td>
</tr>
<tr>
<td>9.13.42</td>
<td>WebCenter Sites</td>
<td>114</td>
</tr>
<tr>
<td>9.14</td>
<td>Connection Doctor</td>
<td>116</td>
</tr>
</tbody>
</table>
1. Concepts and Overview

Concept

The Pilot's Views offer different functionality or a specific mode to work in. Find an overview below with a short description.

At the end of this chapter, we also describe the Tools. Tools are views or dialogs that you can open in a separate window, next to your Pilot. Most of these are also available as a View.

Automatic Hiding of Views

Depending on the View Mode you are using (Containers, Job Overview or Last used Job), you will have access to different views.

Depending on your access rights, you may not be able to see some of the views.

Manually Selecting Views

Right-click a view and choose Remove from Views bar. To enable that view again later, right-click anywhere in the Views panel, choose Select Views... and select the one(s) you want. This selection is saved per user and remembered the next time you log in to the Pilot.

Overview per Category

• General
  • The Files view offers a view on the files in your Containers or Jobs. You typically use it to open or view them and to launch workflows on them. Learn more in The Files View on page 8.
  • The Jobs view is only visible in Job Overview mode. It lists all or a filtered list of your Automation Engine Jobs database. Learn more in The Job Views.
  • The To Do List view lists all actions that need user intervention. Learn more in The To Do List View.
  • The Products view shows the items in your Products database. This concept is useful when you manage re-prints. Products represent production data that you temporarily link to a Job order. It is the Job order that has the specifications how to output the product this time, possibly together with many other Product items.
    Products are what you keep long term, until you are sure you will not have to produce them again. Jobs however are 'WIP' (Work In Progress), temporary by definition. A Job should be removed when it is finished. Learn more in the dedicated chapter Products.
  • The WebCenter view enables Pilot users to see what documents are inside a WebCenter project without having to open a browser. Learn more in the chapter on Integrating with WebCenter, in its section The WebCenter View in Automation Engine Pilot.
• The **Tasks** view shows all or a filtered list of tasks. It shows their status and offers easy access to log files or input or output files. You can here also relaunch them, with or without opening and changing settings first. You have to clean up this list. Learn more in *The Tasks View* on page 15.

• The **Milestones** view shows the milestones of the selected Job (in *Last used job* mode), or those of all Jobs (in *Job Overview* mode). Learn more in *Milestones: Tracking Job Status*.

• The **SmartNames** view allows to manage SmartNames. Learn more in *The SmartNames View*.

• The **Tickets** view allows to manage tickets. Learn more in *The Tickets View* on page 20.

• **Commercial Print**
  These views only serve page imposition workflows:
  • The **Pages** view shows a page list and details about the page status in its impositions. Learn more in *Working with Pages*.
  • The **Proofs** view shows the sets of imposition proofs and their status. Learn more in *Working with Proofs*.
  • The **Plates** view shows details about all (offset) plates required for that Job. Learn more in *Working with Plates*.

• **Sign and Display**
  These views are described in the dedicated chapter on *Gang Run Printing for Sign & Display*:
  • The **Orders** view shows an overview of what was ordered to be printed on (flat bed or roll fed) digital printers. Learn more in *The Orders View*.
  • The **Gang Run Printing** view shows the substrate queues where submitted graphics wait to be nested on your available sheet or roll substrates. Learn more in *The Gang Run Printing View*.

• **CTP Flexo**
  These views are described in the dedicated chapter on *CDI Platemaking Workflow*. Find their short description in *Introducing CDI related Views and Tasks*.
  • **Plate Merger**.
  • **Press Plates**.
  • **Press Plate Sets**.
  • **Merged Plates**.
  • **CTP Queues**.

• **Cutting Tables**
  These views are described in *Kongsberg related Views*, a section of the dedicated chapter on *using Automation Engine to cut jobs on a Kongsberg table*.
  • **Sheets**.
• **Table Queues.**

• **Smart Views**
Smart Views are custom filters that you saved as a View. Learn more in *Smart Views* on page 29.

• **Setup**
These views serve to set up your configuration.

  • The **Devices** view lists all output devices connected to your Automation Engine server. You can see their status and workload. These devices can be *CDI Imagers* or *Kongsberg Tables*.

  • The **FlexRips** view gives an overview of the "Esko Link" queues to your FlexRip Dispatchers. Learn more [here](#).

• The **Queue Monitor** view.

• The **Containers** view.

• The **Access Points** view.

• The **Customers** view.

• The **Users** view.
2. General Views

The views in this category can be used in most types of workflow.

2.1 The Files View

This view is available in **Containers** and in **Last used Job** mode.

1. The **Folders** pane shows your **Containers**, folders and job folders (in **Containers** mode) or a job folder and its subfolders (in **Job** mode).

   **Note:** When working with Automation Engine Jobs, you typically don't use this view but use the **Last used Job** mode to see only the data of the Job you are working on.

2. The **Contents** pane shows the contents of the folder you selected in the **Folders** pane.

   **Note:** Every time the Pilot shows you the contents of a folder, it automatically checks the real file types and shows those in the column **Type**. This means that the file's extension is less important here. For example a file with an extension .AI initially shows as an "Adobe Illustrator" file but when the file type detection found that it is PDF compatible, it will show as type "PDF File".

3. The **Launch Favorites** pane allows you to add your favorite tickets and allows to launch them with one click. Learn more in **Creating Favorite Tickets**.
4. The **Tasks** pane shows all launched tasks (in **Job** mode, only those for that job). Right-clicking a task offers functionality to delete, open, relaunch etc... Learn more on the page on the separate **Tasks View**.

### 2.2 The To Do List View

The **To Do List** is where you manage all actions that need user intervention. A user intervention is typically a step in an automated workflow where you require a human decision of action.

This view shows several types of actions:

- **Message**: When created in this view, via ![image]. Learn more [here](#).

- **Checkpoint**: When created by a *Wait for Action (CheckPoint) task*.

- **Milestone Action**: When created by the *Manage Milestone task*.

Use the **To Do List** to view, modify, forward or delete these actions. This view can also be opened as a separate window:

- Go to **Tools > To Do List**.

- In the Pilot’s bottom **Status bar**, click on the **To Do List** icon:

![image]

### 2.2.1 Checking To Dos
Filtering

The **Actions** panel shows all actions when in Container mode or only those of the selected Job. You can filter the list by using the search field. Learn more in *Using Filters and Creating Smart Views* on page 29. When you opened the To Do List as a separate window, the filters you saved also appear in the drop-down menu.

When using the To Do List as a View, a number is shown to illustrate how many of the actions are assigned to the user logged in and also those assigned to 'any user...'. In Job view, this is limited to the actions in that Job.

Details

Select an action to see all its **Details** shown in the panel below. Double click the action to open it and also see when and which user created it.
2.2.2 Handling a To Do

To handle a To Do, select it and the following options become available after a right-click (or via the menu) or in the Details pane:

- Select **I am currently handling this to do item** to assign it to yourself and change its state to **In Progress**.

In **Files**, double-click the path to open the related file in the associated application.
- To open that file in the **Viewer**, click **View** next to the file path.
- To 'Explore' the folder of the file path, click on .
- In the **Actions** pane, right-click and choose **Go to Job** to open the Job this action relates to. Alternatively, use Ctrl/Cmd + Alt + O .
- To release the action to one of the output states offered by the **Wait for Action (Checkpoint)** task that created it, right-click or click 🔄 Release and choose the wanted option (by default **Completed** or **Aborted**).
  
  Learn more in **The Wait for Action (Checkpoint) Task**.

- To forward an action to another user, click 🔄 , select the user and possibly change the **Subject**, **Due Date**, **State** or **Message** first.
- To delete actions, select them and click ☐️, or press **Delete** . You will be asked to confirm.

2.2.3 Creating a To Do Message

To create a To Do Action of the type **Message**:

1. Click 🔄 in the tool bar.
2. In the **New Action** dialog that opens:
   a) Enter a **Subject**.
   b) Choose who to assign the action **To**. (mandatory field)
   c) Relate this action to a **Job** if needed.
   d) Choose a **Due Date**.
   e) Choose the To Do **State**.
f) Enter a **Message** if you want.

3. Click **OK** to confirm.

### 2.3 The Products View

This view is available in **Containers** and in **Job** mode.

The **Products** view is a user-friendly, searchable view on the Products database. You can use it to create new Products, search them and link them to Jobs.

You can see the Products in a thumbnail view 📷 or a list view 📚.
Working with Products is documented in the dedicated chapter *Products*.

### 2.4 The WebCenter View

This view is only available in **Last used Job** mode.

Files that have been published on WebCenter (with the *Publish on Web task* or the *Publish imposition on WebCenter Chain task*) will appear in the WebCenter View. Pilot users can so, without having to open a browser, see which documents are inside a WebCenter project and what their status is.
**Attention:**

- First you need to configure connections to WebCenter sites that you want to use in tasks, for example in the Publish on WebCenter task. Learn more in Configuring WebCenter sites.

- Then, when accessing this WebCenter View for the first time, the View will request you to fill in a default configuration for this View (similar as one of those you added in the Configure tool). Click Save to Configuration and click Show Documents to check if the connection works.

- When you want to change this configuration later, right-click in an empty area of this view and choose Configure.

The View also shows the status of the WebCenter documents.

- When a file arrives on the WebCenter site and approval is required, its status will be pending.

- Files that do not require approval are marked with approval is not required.

- After a file is approved or rejected in WebCenter, its status automatically updates in this WebCenter View.

**Tip:**

- Press F5 to update the WebCenter view to the latest information.
- Click the link in the top-left corner to open WebCenter in a browser window.

Learn more in Review and Approval of Page Impositions using WebCenter, a part of the document on Commercial Print (page) workflows.
2.5 The Tasks View

Concept

The Tasks View allows you to monitor, inspect and relaunch all Automation Engine tasks. Each list entry is a separate task or one step of workflow.

- In **Containers** mode, this view shows all launched tasks and workflows.
- In **Last used Job** mode, this view only shows the tasks and workflows for that job.

![Automation Engine Pilot](image)

**Note:** Several other views also show a list of tasks in a **Tasks** pane at the bottom.

**Don't forget to clean up!**

These launched tasks and their options are kept in a database. Although you can keep many thousands of tasks in this view, when you do not clean up this list, the size of this database will eventually cause slow response and even cause the server software to slow down.

There are manual and automatic tools to clean up this list:

- (Filter), select and press **Delete**.
- Set up a set of automatic **Task Cleanup Rules** in the Configure tool.
- Set up a set of automatic rules to **Move Tasks to History**. The **Task History** tool is basically another dedicated database, where you can also search and even relaunch old tasks. Learn more [here](#).
• (Filter), select and press Move to History.
Learn more details in Functionality on items in Tasks View on page 16.

Sorting, Filtering and Managing Columns
As many other views, this view allows to
• Sort, by clicking on the header of the column you want to sort by.
• Show, hide or change the order of columns by going to View > Select Columns in 'Tasks'...

Note: To easily hide a column, right-click its header and choose Hide.
• Filter, by typing in the search field in the tool bar or by specifying a filter. Learn more in Using Filters and Creating Smart Views on page 29.

Details
Select an entry in the Tasks list to show its Details below. This offers you a summary of the log file with information meant for the user. It is also translated.

It can also contain links to related files. See this example of the details of the 'preflight' task that offers a direct link to the preflight report file:

Note: In the Tasks View, you see the Details in a separate pane. In other views that also show a list of tasks, you can request to see the Details in a separate dialog (right-click on a task item and select Details).

2.5.1 Functionality on items in Tasks View
Tip: Most of these functions offer a keyboard shortcut. They are mentioned in their Task menu item.
- **Go to Job:** When this task was launched in the context of an Automation Engine Job, this will open that Job in the Last used Job mode. Learn more about working with Jobs in the chapter Jobs.
- **Open Task:** This opens the task's dialog so you can check the used parameters. You can also relaunch the task, with or without first changing parameters.
- **Open Output File:** This opens the output file in the default application for that file type on your computer. For example: Adobe Acrobat Reader can be assigned to open PDF files. If the task created multiple files, you will be shown a list of files to choose from.
- **Open Output File With:** This allows to chose from applications that you registered by browsing to the locally installed application (on Windows to its .exe file). For example, this is how you register a PackEdge 14.0 from a Pilot on that same client computer:

Select Other... when you want to register a new or a first application.
- **Go to:** This opens the Files or Last used Job view and there selects the (chosen) Output or Input File.
- **Hold:** To put a pending task on hold.
- **Hold until...:** To put a pending task on hold till a specified time.
- **Release:** To release a task that was on hold.
- **Cancel:** To cancel a running task. Depending on the task type and its Phase, this happens instantly or can take several seconds.

**Note:** When it takes longer (for example a minute), right-click the task again and check if the system now offers you the option to Force Quit.

Once the task is successfully cancelled, it will show its new state: ▼.
- **Priority:** To change the priority of a pending task.
- **Relaunch:** To relaunch the task with the same options. When you want to change any task option, first choose Open, make the changes and then click Launch in that dialog.
- **Delete:** To delete the selected task(s) from this view. You will be asked to confirm.
- **Move to History:** To move the selected tasks to the Task History database. This also deletes it from this Tasks view.
- **Annotation:** To see the annotation that was added when launching this task. Or to change or add an annotation even after the task is finished. You can for example use this to explain your colleagues why you used specific parameters or that you already contacted Esko regarding an error in the task.

**Tip:** To easily see if tasks have annotations, switch on the column 'Annotations'.
- **Log Info:** The Log file not only contains the task's Details (see also below) but also a lot of detailed technical information. This level of detail can be interesting when searching for the cause of errors. It is mainly meant for Esko support people.
- **Open...** This shows the log information of the selected task in the Log dialog. When the task is still running, click Refresh to see the latest content.
You can send an E-mail containing this log file and attachments.

- **Open with**: To open the log file in a text editor installed on your client computer. **Register** that application in the same way as you can do for the option 'Open Output File With'.

  **Note:** This requires the Automation Engine client to have access to the network share 'AutomationEngineLogging' on the Automation Engine Server.

- **E-mail...** The **Compose E-mail message** dialog allows to send this log info in an E-mail, using the E-mail configuration as set up in Tools -> Configure. Fill in the E-mail address(es) and change the **Body** message as you wish. By default all relevant files are already attached (remove any if you want to).

  **Note:**
  - Multiple addresses in one field need to be separated by a semicolon "; ".
  - When you here use SmartNames, make sure they resolve to a valid E-mail address.
• **Group by Workflow**: In a view ordered by the time that the tasks were launched, this function groups all steps of a workflow together, even when other tasks happened in the meantime. The first step of the workflow is then shown in bold. Open the bold item to open the whole workflow in stead of only the selected step.

**Note**: This view is overruled when you click on the header of the column 'Launched'.

• **Display Related Tasks**: Select this to only see the tasks that are part of the same workflow. To go back to your previous tasks view, click the button 'All Tasks' 'or Tasks' that appeared on top of the list.

**Note**: This is useful when you are already using a Filter that only shows the tasks where "Task Level = Main Task" (only showing the single tasks and the bold initial steps of workflows). You can then for example select the workflow with an 'error' status and ask to see its related tasks.

• **Display All Tasks**: When viewing only the related tasks, use this to see all tasks.

### 2.6 The Milestones View

The *Milestones View* is documented in the dedicated chapter on *Jobs*.

### 2.7 The SmartNames View

The *SmartNames* View and Tool is documented in the dedicated chapter *SmartNames*. Find a direct link [here](#).
2.8 The Tickets View

Concept

A **Ticket** is a set of **Task** parameters. In this view, you can create, delete, export or import tickets or workflow tickets. You can make them **Public** or add **Tags**. Learn more below in *Functionality in Tickets View*.

- In **Containers** mode, this view shows all **Global Tickets**.
- In **Last used Job** mode, this view shows all **Global** and **Job Tickets** of the selected **Job**.

**Note:** Viewing tickets is also one of the **Access Rights** a user needs to have.

**Note:** Creating tickets and using them to launch tasks is described in *Creating Task Tickets*.

**About 'Modification Date' and 'Modified By'**

When a ticket is opened and saved, the attributes 'Modification Date' and 'Modified By' are updated.

The 'Modification Date' and 'Modified By' attributes stay the same when

- updating the Tags,
- updating the Description,
- making the ticket Public/Private,
• renaming a ticket.

When importing a ticket, only the modification date is taken from the imported ticket. The attribute 'modified by' is updated to the user who imported the ticket.

**Sorting, Filtering and managing Columns**

As many other views, this view allows to

• Sort, by clicking on the header of the column you want to sort by.
• Show, hide or change the order of columns by going to **View > Select Columns in 'Tickets'**...

• Filter, by typing in the search field in the tool bar or by clicking on the arrow in and specifying a filter. An example:

![Filter Example](image.png)

Learn more in *Using Filters and Creating Smart Views* on page 29.

**Tags**

You can add multiple **Tags** to a ticket. This allows to sort and filter based on those **Tags**.

**Preferences**

Go to the Pilot's **Edit > Preferences** for **specific options on viewing Tickets**.

### 2.8.1 Functionality on items in Tickets View

**Note:** Creating tickets and using them to launch tasks is described in *Creating Task Tickets*.

#### Tool bar functions

**Note:** Depending on your **access rights**, you may not be able to create, edit or delete tickets.

• ![Create Ticket](image.png): To create a new workflow ticket. Learn more in the chapter *Workflows*.

• ![Duplicate Ticket](image.png): To duplicate a selected ticket. Learn more [here](#).
• To delete the selected ticket(s). You will be asked to confirm.

• To add a Tag or a Description, or to make the ticket Public.

**Functionality via "Ticket" Menu or via Right-Click**

• **Copy from other Job...** (only via the "Ticket" menu):
  
  This enables copying a (blue) **Job Ticket** from another **Job** to the current **Job**.

• **Export Ticket(s)...**
  
  Use this to export tickets so that they can be imported on another Automation Engine server.

  Select the ticket(s), click **Export Ticket(s)...** and choose the location and file name of the exported data (a ZIP file).

  **Note:** The resulting ZIP file not only contains the selected ticket(s) but also the following resource files that these tickets refer to and require:

  • **SmartNames**
  
  • **Referred** global tickets. Learn more in *The Difference between a Subworkflow and a Referenced Workflow*.

  • **ArtPro Action Lists**
  
  • **PitStop Profiles** and **Action Lists**

  • **SmartMark** sets (as .paf files)

  • **ReportMaker** templates (as .paf files)

  • Tiling templates used in a **Create Tiles** ticket

  • Templates used in a **Step & Repeat Template based** ticket

  • CAD files used in a **Prepare Station** ticket

  • "Compare with" files used in a **Compare PDF** ticket.

  • Scripts used in a **Run Script** ticket

  • Templates used in a **Create Imposition from RunList** ticket

  • .XML files used in a **Create Design (DesignWizard)** ticket.

  • Rule sets used in a **Check Print Rule** ticket

  • .ppd files
Attention: Exporting tickets has these limitations:

- Some "resource" information is not included, such as DGC files and CMS related files like Color Strategies.
- Workflows that include (blue) Job Tickets by reference can not be exported. An error message will appear.
- Plate templates used in a Import JDF Stripping ticket are not included.
- The template used in a Create IMP File ticket is not included.
- In a Expand Variable Data to PPML File ticket, .XML or .CSV database files that define a grid are not included.

Attention: The Automation Engine software version on the server that imports the ZIP may not be on an older version than the Automation Engine server that created the ZIP.

- Import Tickets... (only via the "Ticket" menu):

  Use this to import tickets that were created on another Automation Engine (using the Export Ticket(s)... function).

  Click Import Tickets... and select the ZIP file that contains the ticket(s) and their dependant files and click Import. The newly imported tickets will show up selected in the Tickets view (when not hidden by filters).

  Note: Tickets are imported as Global Tickets and by default keep their original name.

Caution: When dependant files came from a central resources folder (for example SmartMarks sets), they will be written on the central resources folder of the current server.

  Other files (for example ReportMaker templates or ArtPro mark files referred from an ArtPro Action List) will be written in the root of the "ExampleJobContainer", in a folder named after the folder they originally came from. This is why, when importing tickets, the "ExampleJobContainer" must exist and allow writing.

  Note: If the import would overwrite any files, you will be asked to confirm. Click OK to accept that the imported files overwrite the old ones.

- Open: To open the ticket. Alternatively, double click the ticket.

- Make Public: A public ticket is visible to all users. Alternatively, set this attribute the moment you save a ticket. Learn more in Public Tickets.

- Duplicate... (or): To copy a ticket and save it with a different name, without opening the ticket.

- Delete (or): To delete selected tickets. You will be asked to confirm.

Caution: Make sure that the ticket is not used in an Access Point, Configure tool or as referred ticket in a workflow ticket.
Note: Default tickets cannot be deleted.

- **Rename**: To change the name of the selected ticket.

- **Tags...**: To assign one or multiple tags to the selected tickets. In the dialog, click in the input field to see a drop-down list with existing tags to choose from. Type in the input field to add new ones.

- **Add to Favorites**: To add the selected tickets to the list of **Favorite Tickets** of this user. Learn more in *Creating Favorite Tickets*.

### 2.9 The Jobs View

The **Jobs View** shows a list of jobs. It is documented in the dedicated chapter on **Jobs**.
3. Commercial Print Views

These views serve a workflow dedicated to page workflows (approval, imposition, output).

**Note:** These views are only visible in Last used Job mode.

4. Sign & Display Views

These views serve an output workflow that is typically used at sign and display printers.

4.1 The Gang Run Printing View

The Gang Run Printing View is documented in the chapter dedicated to Gang Run Printing for Sign & Display.

4.2 The Orders View

The Orders View is documented in the chapter dedicated to Gang Run Printing for Sign & Display. It is used to track production orders that come out of a Gang Run Substrate Queue and are then cut on a Kongsberg table.
5. CTP Flexo Views

These views are described in the dedicated chapter *CDI Platemaking Workflow*. Find a direct link [here](#).
6. Cutting Tables Views

These views are all described in the dedicated chapter *Kongsberg Production Workflow*. Find a direct link [here](#).
7. Smart Views

Smart Views allow to save a filter as a custom view.

You can create Smart Views for all View types: lists of Tickets, Tasks, Jobs, Products, Milestones etc. Here's an example in Job Overview mode:

Smart Views also make it easier to navigate between views.

**Tip:** Double click a Smart View name to (temporarily) change it's filter settings.

Creating a Smart View is explained below. To remove a Smart View, right-click it and choose Remove from Views Bar.

### 7.1 Using Filters and Creating Smart Views

A Smart View is filter that you save as a custom view.

We will use an example to illustrate this. Follow these steps to create a Smart View that will filter all tasks based on these criteria:

- Launched by a specific operator,
- During the past two days,
- and ended with a status 'Failed'.

1. In the Pilot, choose the Containers mode and go to the Tasks View.
2. Click on the arrow in 🕵️ or press Ctrl/Cmd + F to open the Search bar and see the extra filter options that can help you to refine your search:
3. Add these filters:

- Set the first filter to **Operator + is +** <the operator whose tasks you want to see>. You can click to browse a list of operators (see (1) in the image below).
- Open a second filter line by clicking the + button in the first filter line (see (2) in below image).
- Set these parameters for this second filter: "**Launched date is "within last" 2 "days"**.

4. Click the + sign in the second filter line while holding down the **Alt** key. It changes into a ... sign and allows you to add more criteria to that same filter line.

5. Add these extra filters:

- "**All** of the following are true"
- "**State** is "Failed".

6. Click **Save** to save this filter with an appropriate name.

- **Scope**: Choose if this filter will be visible to **All users** or to **This user only**.
- Select "**Add to my views bar**" to add this filtered view to the **Views** pane, in the category **Smart Views**.

**Note**: If you don't select this, you only save it as a filter that will be available to **Load** again later.
**Note:** Right click a **View** and choose **Manage Filters...** to add or change saved filters.
8. Setup Views

These views offer tools to setup your Automation Engine server.

8.1 Devices

The Devices view shows configured output devices, their status and their workload. You can add these device types:

- **CDI Imagers.**
  Learn more in the chapter *CDI Platemaking Workflow*. Find a direct link to the page on CDI devices [here](#).

- **Kongsberg Cutting tables.**
  Learn more in the chapter *Kongsberg Production Workflow*. Find a direct link to the page on Kongsberg devices [here](#).

- **Esko DFE and HP Production Pro.** Learn more in *Devices (Digital Presses) (Pre-release)*.

  **Attention:** Working with these devices is not yet customer-released in AE v16.1 of November 2017.

8.2 FlexRips

The FlexRips view and tool gives an overview of the activity on your Esko FlexRips.

It shows the FlexRip's **Name**, **Type**, **Rip Node** (PC) name, its **Port** and the state of the **Dispatcher**. The **Queue Name** is the channel within Automation Engine that communicates with the Dispatcher (this name is part of how you configured this FlexRip it in the Configure tool).
The Rip Queue pane shows the queued RIP'ing jobs of the above selected RIP. Go to View > Select Columns in 'Rip queue'... to select the information that you want to see here.

When you stop a Rip Queue, you can still send files to that FlexRip but the communication will be queued up within Automation Engine. This can for example be useful when the Dispatcher is located on another computer that you need to shutdown or reboot. To avoid any communication problems between Automation Engine and that Dispatcher, you can stop this queue, do the intervention on the Dispatcher's computer, and then start the queue again when you are sure that the Dispatcher is back up and running.

Click for quick access to the Configure tool to manage your FlexRip configurations.

8.3 Queue Monitor

Concept

The Queue Monitor shows Automation Engine's processing queues and their content. All tasks are executed within one of these queues.

Automation Engine uses many different queues to process its tasks and can grant priority to some types of activity. For example lighter tasks, that only take a few seconds, always get priority over heavy calculations that typically take many minutes. This is for example why a 'Manage Milestone' task will not have to wait for a 'Trapping' task to finish.

Automation Engine decides internally which types of tasks are executed on which processing queue. Most tasks are executed on the 'CPU' queue. As a user you can not choose in which queue your task will be executed, but you can choose its priority within that queue (a standard option when launching the task).

Queue Types

- **ADMIN** queue. Used for tasks triggered by events, for example the automatic actions configured in the Plate Merger's configuration.
- **Archive & Restore** queue. Used for such tasks.
- **CPU** queue. Used for most tasks. It offers the amount of processing channels as referred to in the Server Admin web page. The more processing channels your Automation Engine server is licensed for, the more tasks it can simultaneously process on this queue ("concurrent running tasks").
- **CPU_GV** queue. Used to run the Global Vision Inspection tasks.
- **CPU_HEAVY** queue. (Rarely) used for heavy calculations.
Note: Since v16.1, this queue is no longer shown in the 'Server Admin' web page.

- **CPU_LIGHT** queue. Used for tasks that are light to process.
  - For example these tasks: Manage Milestone, Link Product to Job, Run Script, Wait for Action (Checkpoint), Track Edit Session, Apply Creep, Change Imposition Layout, Create RunList, Create PDF File from RunList, Add Marks to Imposition, Submit to CDI, etc.
  - Also the FlexRip pre-RIP tasks where the option 'Resolve Transparencies' was not selected.

- **FTP** queue. Used for upload tasks to (S)FTP or cloud storage sites.

- **FlexRip** queues. These are named after the FlexRip and can also be controlled using the FlexRips View or Tool.

- **VDP** queue. Used for expansion tasks in VDP workflows.

- **VIEW_ACC** queue. In older versions, this one was used to prepare view data

Caution: When you open several Queue Monitors as a Tool (to monitor multiple queues), you might reach your maximum of licenses for client connections to the server and so get related "Exception" errors. As an alternative, consider opening several tab's in the same Pilot.

Main Functionality

Use 🔄 🕳️ to start or stop a queue. Use 🕳️ to schedule when a queue can be active (see an example below).

A queue's task entries can be opened, relaunched, etc. Right-click to discover options identical to those in a regular Tasks view.

When is this Tool Useful?

This tool is mostly used by Esko support staff to diagnose CPU load issues. But there are cases where it can also be useful for you:

- The main practical reason to stop one or multiple queues is to help with a controlled shutdown of the server. When queues are stopped, the tasks that would still be launched right before your server intervention then do not risk to fail but stay in this queue "waiting". When you then start the queue again after the intervention, the tasks in that queue will start.
- Some customers only want to start the FTP tasks at night for example. In stead of having to set these "hold-until" times when launching the task, you could for example schedule the FTP queue to be active between 8 PM and 6 AM:
8.4 Containers

A **Container** is a network share that contains data that Automation Engine can work with. These containers can be located on your Automation Engine server or on another computer in the same LAN.

You can create a container by using (part of) an existing network share or you can have Automation Engine create the network share while creating a container.

The installation of Automation Engine by default creates an **ExampleJobContainer** on the disk drive where you installed the server software.

You can add many more containers. You can see and browse though them in the Pilots’ **Containers** mode. An example:

8.4.1 Creating a Container

Follow these steps to create a container:

1. Open the **Containers** view or go to **Tools > Containers** to open it as a separate window.
2. Click or go to File > New.

3. In the Create Container Wizard, click Next and select either:
   - Local Folder on the Server to create a container on your Automation Engine server.
   - Existing Shared Folder to use an existing network share.

4. Click Next.

5. If you selected Local Folder on the Server:
   a) Select the wanted disk drive and click Next.
   Tip: Select a drive to see which containers are already in there.
   b) Enter a name for your new container and click Next.
   c) Click Next to create another container, or Finish to leave the wizard.

6. If you selected Existing Shared Folder:
   a) Enter the Computer Name of the computer where the shared folder is located, or use the Browse... button to select that computer in your network. Then click Next.
   b) The wizard now shows a list of all available shares on that computer. Select the share you want to use as a container and click Next.
   Attention: Shared folders are not shown when their computer does not recognize the user that was chosen to be the System Account for Automation Engine. By default this is the local user BGSYSTEM, but you might have changed this (using the System Account page in the Server Web tool).

Your container is now created.
   c) Click Next to create another container, or Finish to leave the wizard.

8.4.2 Removing a Container

Removing a container makes its contents invisible to your Automation Engine server. This does not delete any data inside that share.

To remove a container, select it and click or press 'Delete' or use File > Remove. You will be asked to confirm.

- If there are active jobs in that container, they will be listed in the confirmation dialog. If you remove the container anyway, the jobs are removed from the database and their blue job folders will become normal yellow folders.
Learn more about removing Jobs here.

- If there are active Products in the container, you cannot remove that container.

### 8.4.3 Relocating a Container

When a container goes offline, this will be shown in the Pilot's Container mode and in the Containers View and Tool:

Here are some possible reasons:

- (Temporary) network problems.
- The Location is no longer valid because the name of the computer or the share changed. For example, the disk was filling up and you decided to move the data to another computer with another name and then remove the old share.
- The disk that hosts this container crashed. When you have a backup of that disk, you can put that data back on another disk or computer.

For whatever reason you need to move data to another network place, you can use the Relocate feature to inform Automation Engine that the container data is now on another Location.

**Attention:** Relocating does not move any data. It only adapts the Automation Engine database by informing it on the new location.

Follow these steps to relocate a container:

1. Select the offline container and right-click or go to Edit > Relocate.
2. Enter the name of the computer that you want to relocate your container on, or browse to it.
3. In the **Select the share** dialog, select the share you want to relocate your container on. Click **OK**.

Your container is now relocated on the share you selected (and has the name of the share).

### 8.4.4 Refreshing the Containers’ List

By default, each container's availability is automatically checked every 5 minutes. Sometimes, you want to check it manually, for example after you solved a network problem. Then choose one of these methods to refresh the connection:

- Go to **Edit > Rescan**.
- Press **Cmd + R** (Mac) or **Ctrl + R** (Windows).
- In the Pilot’s **Files** view, when using the **Container** mode, press **F5** (Windows).

### 8.4.5 Troubleshooting Containers

These messages explain what is wrong with (the creation of) the container:

**Note:** In below examples, the **System Account** for Automation Engine is still the default user BGSYSTEM. This can be a different one if you changed it [here](#).

- Creating a new container fails because the passwords for the user BGSYSTEM don’t match:

![Error](image1)

- A container is no longer accessible because the user BGSYSTEM doesn’t have full access anymore:

![Alert](image2)
• A container is offline. Select it, right-click and choose **Info** to learn why it is offline:

![Information window](image1)

• In the Pilot **Files** view, when the host of the container is down, the warning "**Could not retrieve the list of files**" appears:

![Warning](image2)

8.5 Access Points

The **Access Points** View and Tool is described in the chapter *Integrating with External Systems*. Find a direct link [here](#).

8.6 Customers

**Concept**

This tool allows you to manage the list of customers on Automation Engine.

A customer minimally has an **ID** and a **Name**. You can define many more fields. Go to **View > Columns** to also show those fields as columns.
Ideally, you do not type in this customer data but get it automatically via an integration with your business system. Learn more about such integrations in Integrating with External Systems.

### Fields

Many of these fields are used when you create a job, in its tab ‘Customers’.

Most fields can be used as a SmartName. Learn more in the chapter on SmartNames.

- **Contacts, E-mail** and **Address** fields.

- **Job Folder.** This field can help to automatically create job folders for that customer under the folder that you specify here. Learn more in Smart Job Location.

  **Note:** Make sure the path you specify here ends with a SmartName already.

- **Product Folder.** When new Products are created automatically for this customer, their Data Zone will be created under this folder and a dummy Product file can also be created there. Learn more in Smart Product Location.

- **Upload Folder** is useful to help instruct Access Points where to upload the data to. Learn more, for example, in upload options of an FTP Access Point.

### 8.7 Users

To manage Automation Engine Users, open the **Users** View (category ‘Setup’) or go to **Tools > Users...** to open it as a separate window.
The **Users** dialog can be used from 3 different perspectives:

- Managing **Users**
- Managing **Access Rights**
- Managing user **Groups**.

### 8.7.1 Users Concept and Technical Background

**Concept**

Everything that happens in Automation Engine is done by a specific user. Installing Automation Engine creates some default users after which you can create your own. You grant them **access rights** and maybe arrange them in **groups**, typically to make it easier to manage them.

**Technical Background**

Users in Automation Engine map to Windows users. These Windows users are organized in two local Windows groups on the Automation Engine **master** server.

- **BGUSERS**: normal users
- **BGADMIN**: administrator users

**Attention**: Automation Engine user groups do **not** correspond to Windows user groups.

When you create a new user in Automation Engine, a local Windows user is created with the same name.

You can also add existing Windows “domain users” to become Automation Engine users. Learn more in the chapter **Pre-Install IT requirements**, in the page with **technical details about users and groups**.

The account **BGSYSTEM** is a special user that runs the Automation Engine server software. This is the default **System Account**. You can change this to another account by using the **System Account page in the Server Admin web page**.
8.7.2 Managing Users

In this mode, most of the functionality is available though the top bar buttons or via a right-click after selecting one or multiple users:

- **New User 🔄.** Many of these fields become available as *SmartNames.*

  **Note:** As mentioned above, this tool only creates local users (where the domain name is the name of the Automation Engine server computer).

**Attention:** When creating a user, Automation Engine requests permission from the Windows OS. Therefore, some changes like changing the password require the use of Windows User Administration tools. These changes must also meet the existing domain policies (for example the length and complexity of the password).

Selecting **Allow this user to administer Automation Engine** makes it an Administrator user who can create other users, groups and manage their access rights.

- **New Action....** Use this to create a message for this user that appears as an action in his *To Do List.*

- **Delete 🚧.** You need the access right and you will be asked to confirm.

  **Note:** Deleting a user that is a local user also deletes the local Windows user.

- **Copy / Paste Groups.** When the selected user is part of one or more groups, an administrator user can use this to copy all the group membership properties onto another user (and so make it member of a group or possibly take this membership away).

- **Copy / Paste Favorites, Smart Views, Views** and **Red Alerts.** Use these options to quickly set up a similar Pilot interface for several users.

  **Note:**
  - Normal users can only copy Favorite tickets or Smart Views from another user and paste them to their own user profile.
  - Administrator users can copy and paste **Favorites, Views** and **Red Alerts** as they wish. They can also copy **Favorites** to multiple users.

- **Properties....** Shows a summary of all the user’s attributes. Learn more about all different user fields in *Properties.*

**User Properties**

**General**
The Name is always in lower case. Every user can change his own E-mail Address.

Groups

This tab shows which groups this user is part of. The fields are greyed out for a normal user.

Views

This tab shows which Pilot Views this user can select. Also a normal user can change this selection.

Access Rights

This tab shows which Access Rights this user has. The fields are greyed out for a normal user. Settings are also disabled when the access rights are decided by the group that this user is part of.

Red Alerts

When certain events are detected by the Automation Engine server, a Red Alert is broadcast to users. This can pop up as message box and is also indicated in the bottom right corner of the Pilot with the icon.

This tab shows which Red Alerts this user will see in its Pilot. Also a normal user can change this selection.

Connections

This tab shows from where and with what application this user is connected to the server. A user can have several connections. The tab is empty when the user is logged off.

8.7.3 Managing User Access Rights

To match their roles, you can assign specific access rights per user or per user group.
A typical example is to reserve configuration features only for selected users. You can for example fine-tune roles by allowing some users to only use tickets but not being able to change them.

**Note:** Managing these roles will be easier when you do this *per user group*. A user automatically gets all rights from the group he belongs to.

Some general rules:

- Administrator users always have all user access rights.
- Only Administrator users can change access rights of normal users.

- To change access rights of a single user:
  a) In the **Users** tab, double click the user to see his properties.
  b) In the **Access Rights** tab, make the wanted selection.

- To change access rights of multiple users (that are not part of a group):
  a) In the **Access Rights** tab, (de)select the access right you want to add/remove.
  b) In the **Users** pane, (de)select the users you want to add/remove this access right to/from.
Note: In the above screenshot, notice that the selected users are not part of one of the three groups shown at the bottom.

Access Rights

<table>
<thead>
<tr>
<th>This access right:</th>
<th>is about ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Containers: create / delete</td>
<td>creation and deletion of containers.</td>
</tr>
<tr>
<td>Files: copy / move / delete files on disk</td>
<td>what you can do with files using the Pilot. Note that these users can still use the Copy or Move File and Delete File tasks.</td>
</tr>
<tr>
<td>Job Parameters: create / modify / delete</td>
<td>managing the tab 'Parameters' in a Job setup. Learn more in Creating and Modifying a Custom Job Parameter.</td>
</tr>
<tr>
<td>Jobs: create / modify / delete</td>
<td>managing Jobs. Learn more in Creating a Job and deleting Jobs.</td>
</tr>
<tr>
<td>Monitor: move tasks to trash or history</td>
<td>removing tasks from the Tasks list. See Tasks list and Task History on page 50.</td>
</tr>
<tr>
<td>Pilot: Start the Pilot (in addition to Shuttle)</td>
<td>logging in to a Pilot.</td>
</tr>
<tr>
<td>This access right:</td>
<td>is about ...</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Queues: stop / start device queues</td>
<td>managing queues in the Queue Monitor and the FlexRip Queues.</td>
</tr>
<tr>
<td>Task launching: set priority</td>
<td>setting a higher priority to the tasks this user launches.</td>
</tr>
<tr>
<td>(Immediate / high)</td>
<td></td>
</tr>
<tr>
<td>Tasks: Inkremapping in inks panel</td>
<td>changing ink attributes in FlexRip or Imaging Engine tickets (LPI, angle, dot, remap, merge).</td>
</tr>
<tr>
<td>Tickets: create / modify / delete</td>
<td>managing Global and Job tickets. See Tickets and Tickets View.</td>
</tr>
<tr>
<td>(Global and Job tickets)</td>
<td>Note: This Access Right automatically grants the two below mentioned rights.</td>
</tr>
<tr>
<td>Tickets: create / modify / delete</td>
<td>managing Job tickets. See Tickets View.</td>
</tr>
<tr>
<td>(Job tickets only)</td>
<td></td>
</tr>
<tr>
<td>Tickets: Show All Tickets and their</td>
<td>which tickets and parameters you can see in the Pilot (in the Tickets View, when launching a task or workflow in the Files View, or when opening a task ticket from the Tasks list).</td>
</tr>
<tr>
<td>Parameters (Public and other)</td>
<td>When this is deselected, the user can only use:</td>
</tr>
<tr>
<td></td>
<td>• public tickets (see Tickets)</td>
</tr>
<tr>
<td></td>
<td>• public parameters in those public tickets (see Using Public Parameters)</td>
</tr>
<tr>
<td></td>
<td>• the Launch with option on files (not the New Task option) (see Launching a Task on a File and Launching a Workflow on a File).</td>
</tr>
<tr>
<td>Note:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Without this access right, a user cannot create any ticket.</td>
</tr>
<tr>
<td></td>
<td>• In the Pilot’s Tickets Preferences, you can use the ‘Show only ...’ options to simulate how the Pilot looks without this access right.</td>
</tr>
<tr>
<td></td>
<td>This is useful for an administrator to check which tickets and parameters a user still can see when he takes away this access right from that user.</td>
</tr>
<tr>
<td>Todo's: create / modify / delete</td>
<td>forwarding To Do actions to other users. Learn more in To Do’s.</td>
</tr>
</tbody>
</table>
This access right: | is about ...  
---|---
**Viewer: Deep Zoom** | using a deep zoom, both when viewing unprepared files and prepared files (when zoom is deeper than prepared for).

### 8.7.4 Managing Groups

You can create custom user Groups to easily change access rights for all group members at the same time.

You can not add Administrator users to a custom group. The Administrators group is a default group of all users that are allowed to administer users and to execute tasks that require an administrator right (for example in the Server Admin web page).

#### Creating Groups

**Note:** You need to be logged in as an Administrator user.

1. In the **Users** tool or view, go to the **Groups** tab.
2. Press ⌘ (or go to **File > New Group...** or use **CTRL + N**).
3. In the **New Group** dialog, enter the **Name**, **Description** and select a **Color** for the new Group.
4. Click **OK** to confirm.

See an example of user groups that may also have different access rights:

Selecting a group shows its member users.
Defining Group Access Rights

You can assign relevant access rights to your custom groups.

**Note:** You need to be logged in as an Administrator user.

- In the **Users** tool or view, go to the **Groups** tab.
  a) Double-click a group to open its **Properties** window.
  b) In the **Access Rights** tab, make the selection that you want for this group.
- You can also set a specific access right to several groups/users in one go. To do this, use the **Access Rights** tab (see an example [here](#)).

  **Note:** When a user is part of several custom groups, its access rights are a sum of the access rights assigned to those groups.

Adding Users to Groups

**Note:** You need to be logged in as an Administrator user.

- To add users to a custom **Group**:
  a) Go to the **Groups** tab.
  b) Select on one of the groups. All its users will be listed underneath.
  c) Select the users you want to add to this group and close the dialog.
- To assign one or more **Groups** to a **User**:
  a) In the **Users** tab, double-click the user.
  b) In its **Properties** dialog, go to the **Groups** tab.
  c) Select the groups that you want to add this user to and close the dialog.
9. Tools

Tools are views and dialogs that you can open in a separate window, next to your Pilot. Many of these are also available as a View, in the left pane of the Pilot.

Closing the Pilot also closes all other open Tools.

Note: Mind that every open tool counts as a client-server connection. Depending on your licenses, you might reach the maximum.

9.1 To Do List

The To Do List Tool is also a View, in the category General. It is described here.

9.2 CTP Queues

The Tool CTP Queues is also a View in the category CTP Flexo Views on page 27. It is described in the chapter CDI Platemaking Workflow. Find a direct link here.

9.3 SmartNames

The SmartNames View and Tool is documented in the dedicated chapter SmartNames. Find a direct link here.
9.4 Task History

To keep your Tasks view manageable, you might have to clean the list of tasks. If you do not want to keep some tasks, you can delete them. If you want to keep certain tasks or tickets for later use, you can add them to the **Task History**.

There are 2 ways to have finished tasks move to the Task History:

- In the Pilot, select one or multiple tasks (maybe after first setting a filter) and can click on ☐ to move it to Task History.

- Tasks can also automatically move to this tool by using the Task Cleanup Rules (in the Configure panel > AE Database > Tasks). You can there define which ones should automatically move to Task History. Learn more in Task Cleanup Rules on page 64.

To view the history, choose **Tools > Task History**. Initially none are shown. You only see tasks after clicking **Apply** on a chosen **Search** filter (or press **Enter**)

The Task History has a lot in common with the Tasks View. It lists all 'moved' tasks which you can relaunch, view and save.

You can archive entries in the Task History which you can restore later (learn more in Why and How To Archive parts of this History on page 54). You can make XML reports of the tasks and use them to bill your customers.

The Task History panel has three parts:
1. Task History XML Report
2. Task History Search options
3. Task History List

9.4.1 Task History Menus

File Menu

- **Open Task**: opens the ticket used for the selected task.
- **Export XML Report...**: Writes a report of the current selection. This XML report contains task name, ticket name (whether or not the ticket was modified), the Operator, when it started, when the tasked ended, Status, Priority, job folder...
- **Archive...**: It is possible to archive the data in the database to an XML file. This allows you to put the file on CD or store it somewhere else.
- **Import Archive...**: Restores the data in the selected XML file in the database. A browse window pops up, browse to the archive.XML and click OK. The archive will be restored.
- **Restart History Server**: This will shut down the History Server and reboot it.
- **Close Window** [Ctrl + W]: Closes the window. If only one window is left, this is disabled (use Exit, to close the last window).

Edit Menu

- **Select All** [Ctrl+ A]: Selects all entries in the table.
View Menu

- **Columns**: define which columns you want to see, for more information, please refer to the section on Columns.

- **Customize Current Filter**: Please see filtering.

- **Manage Views** [Ctrl + Shift + F] Here you can save the View Settings or select a previously created view.

- **Related Workflow Tasks**: Some tasks are part of a workflow, use this function to get a list of related tasks.

- **Stop** [Escape] This cancels the current database query and lets you set up a different specification.

- **Refresh** [F5] Perform another database query with the current settings.

### 9.4.2 Task History Toolbar

- **Open Task**: opens the selected task.

- **XML Report...**: Writes a report of the current selection. This XML report contains task name, ticket name (whether or not the ticket was modified), the Operator, when it started, when the tasked ended, Status, Priority, Job folder...

- **Filter**: Opens the Filter Settings dialog. Please see filtering.

- **Views**: use the drop-down list to select ‘Manage Views...’ or an already defined view.

**Filter**

Filter Settings allow specific modification of the way the Tasks View is filtered. There are five tabs.
• **Operator** Define the filter according to the Operator. Tick the ones you want to monitor.

• **State** Define the filter according to the Status of the task. Just tick the ones you’d like to view.

• **Task Type** By default, the Tasks View will show all tasks launched, but you can modify the filter in such a way that the Tasks View shows nothing but the type of tasks you are interested in.

• **Date** Define the Filter according to date and time.
  • in a given time window (between [date and time] and [date and time])
  • during the previous X hour(s)
  • during the previous X day(s)
  • during the previous X month(s)

• **Advanced**

  The Advanced Filter settings allow for precise queries.

  Hit ‘New’ to define a rule. The set up is easy. You define a rule that shows X containing a certain string.

### 9.4.3 Task History List

The Task History list looks a lot like the *Tasks View task list.*

The list lists all tasks that have been moved from the Tasks View to Task History. You define what you want to see. You can define the number of columns (see *View Menu > Columns*), you can click the head of a column to get the list to sort the way you like it, and you can filter the entries (see *View Menu > Filter*).
9.4.4 Why and How To Archive parts of this History

Archiving serves two purposes:

- The Task History is used to make the Tasks View quicker, more user-friendly. All tasks stored in the Task History can be relaunched, it is a so called ‘living archive’. As time goes by, you will end up with a Task History containing a lot of tasks that you may never want to relaunch. You can delete these tasks, but if you think that's not a good idea, you can use the Archive function. so archiving can be a part of the Task History database maintenance.

- Archiving can be used to make a backup of the Task History data for safety reasons. You archive your data frequently, not because you need the space, but because you want to store your XML archive safely elsewhere, so you can easily restore it when problems should arise.

Archiving will store all information of certain tasks in an XML file. This adds the possibility of restoring those XML archives into the Task History. So your information will never be lost.

**Note:**

Archiving only works on selected tasks.

Archiving doesn't delete the archived tasks from the Task History.

1. Select the tasks you want to archive.

   If you want to archive all tasks, press CTRL + A. If you want to make a sub selection, the Task History reacts to the known shortcuts such as CTRL + click and SHIFT + click.

   If you want to make an intelligent selection, and you don't want to lose time, you'd better use the **Filter**. You define what you want to see in the Task History (for example all tasks...
originating from one particular job, or handled by one particular operator, ...), click CTRL + A and you're ready to archive.

2. Click Archive (File Menu > Archive).

3. A dialog pops up, allowing you to browse to the place where you want the archive XML to be stored. Make sure to give the archive XML a meaningful name in order to avoid confusion later on. Confusion might arise if you bear in mind that the Task History also uses the XML language to write an XML report.

4. A 'Confirm' dialog pops up and asks you whether or not you want to delete the archived items:

9.5 Devices

The View Devices is also available as a Tool in a separate window. Both are documented in the dedicated chapter CDI Platemaking Workflow. Find a direct link here.
9.6 FlexRips

The FlexRips Tool is also a View, in the category Setup. It is described here.

9.7 Queue Monitor

The Queue Monitor Tool is also a View, in the category Setup. It is described here.

9.8 Containers

The Containers Tool is also a View, in the category Setup. It is described here.

9.9 Access Points

The Access Points View and Tool is described in the chapter Integrating with External Systems. Find a direct link here.

9.10 Customers

The Customers Tool is also a View, in the category Setup. It is described here.

9.11 Users

The Users Tool is also a View, in the category Setup. It is described here.

9.12 Merger Monitor

If you use a "RIP to ..." FlexRip-ticket to output on a device that has been configured to work with merge queues, you can monitor the merging activities.

Note: This merge tool was mainly used for Computer To Film devices.

Start the Merger Monitor by selecting 'Merger Monitor' from the Tools menu.
The Merger Monitor consists of two panes.

The left pane lists all devices on which files have been merged or are currently waiting to be merged. In the example above there's one device listed example_merge. Every device on which something has been merged stays listed until the server is rebooted.

Select a device to see what is in its merge queue. Files that are to be merged are assembled in pools.

A pool is a group of files with the same characteristics (same plate size, negative or positive, ...). These characteristics are defined by "extract restrictions" (in more recent features this is named 'Grouping Keys'). For example: jobs with a different Dot Gain Compensation setting will not be merged together. They will not belong to the same pool.

Some of these restrictions depend on the setting in the General tab of the ticket you use.

1. **VDistortion** and **HDistortion**: Files must have the same vertical and horizontal distortion before they can be in the same pool.

2. **Reverse**: Files have to be reversed in the same way before they can be in the same pool.

3. **Mirror**: Files have to be mirrored in the same way before they can be in the same pool.

4. **Dot Gain Compensation**: Only files with the same Dot Gain Compensation belong in the same pool.

The other restrictions are defined in the Output tab of the ticket you use.

1. **Conf**: Files need to have the same plate size before they can be in the same pool.

2. **Output path** and **Output File Name**: Files with different Output paths or Output File names will end up in different merge pools.

3. **Resolution**: Files need to have the same resolution before they can be in the same pool.

4. **Compression**: Files need to have the same compression before they can be in the same pool.
Notice that `example_merge` has two pools: 20051128–1 and 20060215–1. When you select the device, but not a pool, you get an overview of all files waiting to be merged. In order to visually indicate that files belong to different pools they have a different background color. White and gray are used consecutively.

The right hand panel provides detailed information on files in the merge queue.

- **Task ID**
- **Priority**: this is the priority you defined in the Expose On ticket, not the priority of the task.
- **Name** of the Job/File
- **Inks** you are exposing, you defined them in the Expose On ... ticket.

**Note:** There are two ways in which the inks are listed. C&M&Y&K or C+M+Y+K. They can be merged on separate films or on the same film.

- **Page number**
- **Size VH (mm)**

**Note:** The symbols used to indicate the size tell you whether or not the file can be rotated in the merger. `<>` (154<>191) indicate that the file can be rotated, an `x` (154x191) indicates that it cannot.

**Rotation** is an option you can set in the Transformations part of General tab of the used task ticket.

- **Fill %**: This is (Job size / Plate size)

These percentages are relative, the overall fill depends on the margins and gap as they are currently defined in your ticket. You cannot simply add the percentages to get a correct idea of the overall fill. There are all kinds of reasons why files cannot be merged together and why the fill percentage is -as a result- not yet reached.

- **State** of the file in this Merger queue

A file can be on hold (it’s an option you can choose in the 'Expose On ticket'). A file can be released, but that does not mean that it will be merged, it still has to wait till the fill percentage is reached. You can Force a file out of the Merger queue. The forced out file will take as many files possible with it, if they have a 'release' status.

### 9.13 Configure

#### 9.13.1 Overview and main functionality

Use the Configure tool to connect to a variety of devices and applications, and define general Automation Engine settings.

To start Configure, go to **Tools > Configure** in the Pilot.

**To Define Settings in Configure**

1. Select the category in the left pane.
2. Go to **File > New**.
3. Click on the default name that appears for that new item and wait a moment till the cursor allows you to change the name.
4. Define your settings on the right.
5. Go to **File > Save**.

**Note:** (Windows) shortcuts:
- 'Insert': to add an item.
- 'Delete': to delete the selected item.
- 'F2': to rename the selected item.

### 9.13.2 ArtiosCAD Servers

To configure a new ArtiosCAD Server in Automation Engine, go to **Tools > Configure > ArtiosCAD Servers**.

![Configure](image)

**Note:** When the database is of the **DBMS Type** "Microsoft SQL Server", you can press ✉️ to select the **Host** and Instance from a list.

**How to configure a Standard Edition ArtiosCAD Server**

1. Set up the ArtiosCAD Database Settings
   a) When using a **Microsoft SQL Server**:
      1. Enter the **Name** of the ArtiosCAD database. Default is ArtiosCADdb.
2. Enter the database **Host** name and the name of the SQL Server Instance when ArtiosCAD is not deployed in the default unnamed instance (typically `<ArtiosCAD Server>\Esko`).

3. Enter the **Port** when not using the default.

b) When using **Oracle**:

**Important:** The **Oracle Client Software** (*ODBC: Additional libraries for enabling ODBC applications*) needs to be installed on the Automation Engine Master and its Assistants. When not installed, the *Create CAD Report from XML task* will not be able to connect to the Oracle ArtiosCAD database.

1. Enter the name of the Oracle TNS **Service name**, for example Oracle X.E

2. Enter the name of the Oracle Database **Driver**.

**Note:** The name of the **Oracle database Driver** can be found in the Drivers tab of the ODBC Control Panel (`%systemdrive%\Windows\SysWoW64\Odbcad32.exe`) after installation of the Oracle Client Software.

3. Enter the database **Host** name.

4. Enter the **Port** when not using the default.

2. Enter the location of the ArtiosCAD **Defaults**.

This should be a **file:** URL, pointing to the ArtiosCAD Defaults., for example `file://MyMachine/ArtiosCAD`.

The Automation Engine Server should be able to reach this folder, and the service account of the BGMD Service should have read access to the folder. This account by default is the System Account "BGSYSTEM" (but can be changed in the *System Account page*).

**Note:** ArtiosCAD Defaults are **version specific**. The version of ArtiosCAD hosting the Defaults must match with the version of CADX installed on the Automation Engine computer (Master and its Assistants).

When no ArtiosCAD Defaults location is specified, the *Create CAD Report from XML task* will use the ArtiosCAD Defaults installed on the Automation Engine computer (Master and its Assistants).

3. Test the connection by clicking the **Test Connection** button.

You will get a message stating "Connection to the database **OK**", or get an **error** message

- when the Automation Engine server can't connect to the database,
- when the Automation Engine server can't get info about the Defaults location. If so, check if the location exists, and if it can be reached from the server.
- when the Defaults location is not a folder.

**How to configure an Enterprise Edition ArtiosCAD Server**

1. Select **Enterprise Edition**.

2. Enter the **WebCenter** location, typically `http://<WebCenterServer>/WebCenter_Inst`.

3. Click **Open** to open the specified location in your default browser.

4. Enter the **User Name** and **Password**.
5. Test the connection by clicking the Test Connection button. You will get a message stating "Connection to the database OK", or get an error message when the Automation Engine can't connect to WebCenter.

9.13.3 Automation Engine Database

These databases are set up automatically when the Automation Engine server software is installed. In this item of the configure panel, you can see their settings, make changes and test their connection.

| Attention: | In the Automation Engine Server Web page, in the section databases, you can also manage databases, but there to make changes after an installation and without the use of a Pilot. |

Standard and Alternative Database Server Choices for Automation Engine

Before going in more detail, we here summarize the choices you have:

- **Standard installation with the standard database server (type).**
  - A standard installation of Automation Engine will install and use an SQL Server Express version.
- **In case you need a (much) more powerful database server.**
  - In case you have reached the limits of the SQL Server Express version, you can make Automation Engine work with a full SQL Server version. Learn more in Databases.
  - Commercial printers with heavy loaded page workflows, can also choose to use an Oracle database, but only for their Application Server database.
- **Or use a small test database server for other special cases.** You can use an "Embedded" database:
  - In exceptional cases on advise of Esko Support, for example to help solve a database problem.
  - When first installing Automation Engine, to avoid that the installation installs the default SQL Server Express, of which you know you will not use it anyway (because you already decided you will use a full SQL Server). This avoids having to uninstall that SQL Server Express version and other peripheral software.

Import: For more information on your options when installing Automation Engine, check the dedicated Installation Guide.

Generic setting (Setup tab): DBMS Type

We here describe the general settings of the Setup tab in the configuration of the various databases. See their own pages for any specific settings.

**Note:** DBMS stands for "DataBase Management System".

**DBMS Type "Microsoft SQL Server"**
These settings will be filled out correctly after installation of the server software. You can however change these settings.

Here is an example of the Jobs database:

- **Database**: Keep the default name or, before initial use of this database, enter a different name.
- **DBMS Type**: Select the driver type Microsoft SQL Server.
  
  **Important**: This type is valid both for an MS SQL Server Express as for a full MS SQL Server.

- You can press 📦 to select the Host and Instance from a list. Here is an example of such a list:

- Enter a correct User name and Password to access that database.

**DBMS Type "Embedded" (only for test purposes)**

This Embedded database engine is built into Automation Engine's installation kit.

**Caution**: This Embedded database type is not suitable for production use! Embedded databases can only be used in very low volume and low load (test) circumstances. Production level performance and stability may not be expected with this configuration. For production use, choose a Microsoft SQL Server (or, in case of the Application Server database, Oracle). Failure to do so may, in a worst case, result in data loss or data corruption.
When the DBMS type is **Embedded**, set the **Folder** to point to the location where the embedded database will be kept on disk (for example "C:\Esko\bg_data_database\APPSRV" for the Application Server database).

Enter a correct **User** name and **Password** for the database user to create or access this database. Enter a blank user name and password when the database or the database user has not yet been created, except for the Application Server database, in which case you need to use the user name "sa".

**DBMS Type "Oracle"**

Learn more about using Oracle as engine for the **Application Server** database in the chapter **Pre-Install IT Requirements**, in the page **Oracle as Database Server for the Application Server component**.

**Generic setting (Setup tab): Testing the Connection and Applying the Config**

Each database configuration has in its **Setup** tab two buttons: **Test Connection** and **Apply**.

**Testing the Connection**

Click the **Test Connection** button to perform these checks:

- **Is the database management system running?** These are possible error messages:
  - When the instance is not running or accessible, you get **Could not connect to the SQL Server instance**.
  - When the user name / password is wrong or when there is no permission to connect, you get **Trying to log in failed**.
  - When the host is not running or not reachable (wrong name), you get **Unknown database host**.
  - When wrong information was typed in, you get **No such instance**.

- **What is the database system version?**
  - An error is shown when **The database system version is not supported (anymore)**. For example: you selected an SQL Server 2000.
  - A warning is shown when **The database system version will soon be outdated**. For example, in version 14.1, an SQL Server 2005.

- **Is the database online?**
  - In case of a wrong user name / password or wrong database privileges, you get **Trying to open database failed**.
  - When the database doesn't exist, you get **Could not find database**.

- **What are the database user roles?**
  - When the user is not a member of required database roles, you get **Insufficient roles**.

- **What about the database system memory?**
• The maximum server memory does not meet the recommendations. This is about the memory of the (SQL) database server. For example, in version 14.1, a server minimally needs +- 4 GB.

• The total physical memory does not meet the recommendations. This is about the memory of the computer. For example, in version 14.1, a server minimally needs +- 4 GB.

• Is the database system speed sufficient?
  • You get a warning when the connection is rather slow. For example, in version 14.1, on average, connecting to the database system and getting version info takes more than 100 ms.

  Note: You can find updated and detailed minimal requirements on http://www.esko.com/systemrequirements.

When all checks return an OK result, an info dialog will tell you that the Database is online and accessible.

Applying the Changed Configuration

After you tested the connection, and solved any errors, click Apply to save and apply this setup.

When you click Apply, Automation Engine restarts parts of its software and then starts accessing the database using the new settings.

Important: When you do not click Apply, but only Save these (and other) changes in the Configure tool, then the changed settings will only be applied the next time the (full) Automation Engine server software is restarted.

Tasks database

Launched tasks are stored in a database with a default name FastLane_TM.

The settings in the Setup tab are generic and described in the DBMS Type and Testing and Applying the Configuration.

Task Cleanup Rules

In the Pilot, you can not keep all your finished tasks in the Tasks overview forever; this would slow down Automation Engine and eventually fill up the tasks database.

You have the choice to

• remove them. In the Pilot tasks view, make a selection, press the Delete button and confirm.

• or move them to the Task History on page 50 tool. You can define Cleanup Rules to automate this cleanup.
**Automation Engine**

**Attention:** Only finished tasks (those with a Successful done, Done with warning, Workflow failed, Failed, or Cancelled) can be either moved to Task History or be deleted. The cleanup rules mechanism will ignore tasks that are still running or waiting.

An example of **Task Cleanup Rules**:

![Image of Task Cleanup Rules](image)

The way to create these rules is very similar to making filters in many Pilot Views. You can learn how to do this from a similar example used in **Job View Filters**.

**Attention:** The rules are executed from top to bottom, so their order is very important. You can use the **Move Up / Move Down** buttons to make sure they are executed in the most productive order. For example: you typically first want to delete tasks and then start moving the rest to history.

**Devices database**

This database stores all the information that is shown in the Devices view, both for **CTP Flexo** and for **Cutting Tables**.

By default, this database uses the same database as for **Jobs**.

- **Tab Setup:**
  
  Learn about these generic settings in the above pages on **DBMS Type** and **Testing and Applying the Configuration**.

- **Tab Maintenance:**
  
  Define after how many days you want to **Automatically delete records** in all the device-related databases. This deletes

  - records in databases that are used in these Pilot Views:
    - (CDI workflow): **Press Plates, Press Plate Sets, Merged Plates**.
    - (Kongsberg workflow): **Sheets** view and (Sign & Display) **Orders** view.

  The time you specified is calculated after the item's **Finished** date.
Automation Engine

- It also deletes the files in the Media Root Folder (see below) older than that specified time.

- Tab **Advanced**: Browse to specify the **Media Root Folder**.
  
  When a job is finished on a Kongsberg **Sheets view**. The JDF and cut file that this (database) item refers to are stored in a unique subfolder of this Media Root Folder.

  **Note**: Files related to the CDI Plate Merger are stored in the folder specified in **the Configure item "Plate Merger"**.

**JDF database**

This database is used when Automation Engine sends or receives JDF commands. For example when jobs are created via JDF or when WebCenter sends workflows to Automation Engine (via JDF).

By default, this database uses the same database as for **Jobs**.

The settings in the **Setup** tab are as described in **Generic setting (Setup tab): DBMS Type** on page 61 and **Generic setting (Setup tab): Testing the Connection and Applying the Config** on page 63.

**Gang Run Printing database**

This database is used by the **Gang Run Printing mode**.

By default, this database uses the same database as for **Jobs**.

The settings in the **Setup** tab are as described in **Generic setting (Setup tab): DBMS Type** on page 61 and **Generic setting (Setup tab): Testing the Connection and Applying the Config** on page 63.

**Task History database**

The **Task History** is a tool that stores old tasks. You keep them there because you may want to look up the settings they used or to relaunch them on same or other files. Learn more in **Task History** on page 50.

The settings in the **Setup** tab are as described in **Generic setting (Setup tab): DBMS Type** on page 61 and **Generic setting (Setup tab): Testing the Connection and Applying the Config** on page 63.

**Maintenance**

In case this database is filling up or when you experienced that you do not need tasks of a certain age, it is advised to clean up.

- **Automatically delete tasks older than X days**. Choose this for an automatic partial cleanup.
- **Clear All Tasks in History**. This deletes everything in this database. You will be asked to confirm.
**Jobs database**

**Setup**

By default the database used for jobs is named BSJobs.

*Note:* The BS in the name BSJobs refers to an old Esko server software application.

The settings in the Setup tab are as described in Generic setting (Setup tab): DBMS Type on page 61 and in Generic setting (Setup tab): Testing the Connection and Applying the Config on page 63.

**Maintenance**

**Dangling Jobs** are active Automation Engine Jobs that have a link to a job folder that is not there, probably because the folder was (re)moved or renamed.

Normally, each active Job relates to one job folder on disk. But it does happen that a user moves or deletes a job folder, for example via Windows Explorer or Macintosh Finder. This causes discrepancies between the information of that Job in the Jobs database and the actual situation on disk. Removing such dangling Jobs brings the database back in sync with the reality on disk.

Click Remove to make the database check, for each Job, whether or not their job folder still exists. You will be asked to confirm. When that folder does not exist, the Job will be removed from the Automation Engine database.

*Note:* This implies that instead of deleting jobs via the Pilot, you are able to delete Jobs by deleting the corresponding folder and then manually cleaning up the dangling Jobs here.

**Application Server database**

This database is used when you use the Pilot Views that are valid for page workflows: Pages, Proofs and Plates (category Commercial Print).

By default, this database uses a database named fasttrack.

The settings in the Setup tab are as described in Generic setting (Setup tab): DBMS Type on page 61 and Generic setting (Setup tab): Testing the Connection and Applying the Config on page 63.
This database can also use the DBMS Type **Oracle**. Learn more about using Oracle as engine for the **Application Server** database in the chapter **Pre-Install IT Requirements**, in the page **Oracle as Database Server for the Application Server component**.

### 9.13.4 Automation Engine Web Service

This setup is documented in the chapter **Integrating with External Systems**, as part of the setup of a **Web Service Access Point**.

### 9.13.5 Cloud Storage Services

This is where you configure cloud storage destinations that the **Upload to Cloud Storage** task can upload files to and where a **Cloud Storage Access Point** can download files from.

**Note:** Any form of SSO (as supported by some Cloud Storage services), is here not supported. Access Points run as user 'BGSystem' on the master Automation Engine server.

#### Configuring Box, Google Drive or OneDrive

Follow these steps to create an account:

1. In **Tools > Configure > Cloud Storage Services**, click **Add** and select the provider (Box, Google Drive or OneDrive).
2. The **Add ... Account** dialog of the selected provider dialog informs you on the process and asks to sign in to that provider.

**Attention:** When your internet browser is already open, an account could already be logged in to that service. To make sure you log in with the right account, close your browser first.

3. Click **Sign In**. Your browser opens a page asking permission for Automation Engine to view and manage files on that storage. When your browser does not auto-remember your credentials, it will first ask you to log in to that provider.

Here's an example using Google Drive (the used account name is shown top right):
4. Click **Allow** to continue. The provider now grants access to the account and calculates a unique code.
   - Google Drive shows this code in a dedicated web page. An example:
     - ![Google Drive Code Example](image)
     - Box and OneDrive display the code as part of the URL that the browser is redirected to. An example:
       - ![Box and OneDrive URL Example](image)

5. • For Google Drive: Select the code and copy it (Ctrl-c / Cmd-c).
   - For Box and OneDrive: Select the full URL (or only the characters in the URL after the 'code=') and copy it (Ctrl-c / Cmd-c).

6. Go back to the **Add <provider> Account** dialog and paste the code or full URL in the **Code** field (Ctrl-v / Cmd-V):
7. Click **Continue** and add an **Account Name** and **Description**.
8. Click **Create**.

   This account is now ready to be used in the tools that use cloud storage services.

**Note:** You can reset the authorization for an account. This is needed when the authorisation token became invalid (it is broken, the administrator of the cloud storage deleted the site, ...). Follow these steps:

- Select the account for which you want to reset the authorization.
- Click **Authenticate**.
- In the dialog that pops up, fill in the required key(s) and press **Authenticate**.

### Configuring Amazon S3

Follow these steps to create an account for Amazon S3:

1. In **Tools > Configure > Cloud Storage Services**, click **Add**, select **Amazon S3** and click **OK**.
2. In the **Add Amazon S3 Account** dialog, fill in the **Access Key ID** and **Secret Access Key** as generated in the IAM module for the user linked to this account. Contact your administrator for more details.

These keys allow Automation Engine the following actions on the **buckets** (root folders) that are linked to this account:

- download, upload and remove files
- create new folders.
**Note:** The IAM-defined user must have sufficient permissions to access the required S3 buckets. Also consider limiting this user's access to one or more specific S3 buckets. Learn more about IAM policies and access to S3 buckets in this online article.

**Attention:** When your internet browser is already open, an account could already be logged in to that service. To make sure you log in with the right account, close your browser first.

3. Click **Continue** and add an **Account Name** and **Description**.
4. Click **Create** to confirm and close the dialog.

**Note:** You can reset the authorization for an account. This is needed when the authorisation token became invalid (it is broken, the administrator of the cloud storage deleted the site, ...). Follow these steps:

- Select the account for which you want to reset the authorization.
- Click **Authenticate**.
- In the dialog that pops up, fill in the required key(s) and press **Authenticate**.

### 9.13.6 Create DCS Master

When you use the Create Master DCS task, you might want to map short names used in plates (that might not mean anything) to full ink names. This is handy for example for plates with international ink definitions. By default, C,M,Y and K are mapped to Cyan, Magenta, Yellow and Black.

To add an ink definition, double-click an input field and start typing. Press 'TAB' to switch fields.

### 9.13.7 Digital Press

Use this to connect Automation Engine to the DFE (Digital Front End) of a digital press.

1. Select **Digital Press** and use **File > New** to create a new digital press connection.
2. Enter the name of your **DFE Server** and click **Connect**.

**Note:** Make sure the DFE server is running and reachable over the network.
If your connection is successful, you will see **Connection OK!** and details about the DFE server.

3. If your DFE server drives several presses, select the **Press** you want to connect to. You will see details about the digital press.

4. Use **File > Save** to save your connection.

### 9.13.8 E-Mail Configuration

Automation Engine can use your E-mail server to send E-mails. These E-mails can be sent by a task **Notification**, by a dedicated **Send E-mail task** or as an extra tool when you opened a log file.
• **Postmaster** is the E-mail address that will receive a warning mail when an E-mail could not be delivered.

• **Use as sender**: Select this to include a "Sender" SMTP header.
  
The purpose of such a header is to indicate that the actual sender of the E-mail is different from the person in the 'From' field of the E-mail. Some E-mail servers refuse to send this E-mail unless this field is specified. Certain E-mail clients will visualise the sender info as "sent by <postmaster> on behalf of <from>".

• **SMTP Server**: Check with your IT department for the correct settings of the SMTP Server and its Port.
  
  • **Use a secure connection**: Select this option if you want to use a secure instead of an unrestricted connection.

• **SMTP server requires password** authentication: When this is the case, select this and fill out the **User Name** and **Password** fields.

<table>
<thead>
<tr>
<th>Note: The following authentication schemes are supported by the Automation Engine mail component: <strong>PLAIN</strong>, <strong>LOGIN</strong> and <strong>DIGEST-MD5</strong>.</th>
</tr>
</thead>
</table>

• **Advanced**: Use this to add generic properties for outgoing SMTP E-mail. Some examples:
  
  • To use office365 as SMTP server for outgoing E-mail, add the **Key** "mail.smtp.starttls.enable" with **Value** "true".
  
  • To get some debug information when there are problems with outgoing E-mails, add the **Key** "mail.debug" with **Value** "true".

• **Send Test E-mail...**: Click the button to send a test E-mail. An example:

  ![Send Test E-mail](image)

  • **From**: Indicates the address you’re using to send the test E-mail. If no address is filled in, the postmaster address is used. You can choose a different sender to test if the mail server allows you to send e-mails on behalf of others. The **Send E-Mail** task relies on this behavior as it tries to send E-mails on behalf of the user that launches the task.

  • **To**: Fill in a valid E-mail address that will receive the test mail.

  • **Subject**: Fill in a subject line.

  • **Message**: You can enter a personal message or leave the default text.

  • When finished, click **Send** to see whether the configuration is working properly. When the E-mail could be sent, an Info message will appear. When it failed, you will get a detailed warning message.
9.13.9 External Databases

External Databases are databases from external systems (not part of Automation Engine).

Automation Engine uses links to such databases in:

- a Database Query SmartName. Learn more [here](#).
- a Database Access Point. Learn more [here](#).
- the Interact with Database task. Learn more [here](#).

**Attention:** When integrating Automation Engine with an external database, make sure you are compliant with the license agreements of that database manufacturer.

**Note:** Configuring these links requires knowledge about database setups. If necessary, contact your IT database administrator to figure out the correct settings.

Configuring External Databases

1. Go to **Tools > Configure > External Databases**.
2. Click **File > New** to configure a new link to a database.
   
   A new database name is created with the name `db_number` (the number is the chronological number of the database).
3. In the left pane, click to select the new database and then click again to enable renaming that new database link. Type the name you want and press **Enter** to confirm.
4. Choose the appropriate **DBMS Type**.
   
   These Database Management Systems (DBMS) are supported:
   
   - Microsoft SQL Server
   - Oracle
   - Other (using a JDBC driver).

   **Attention:** Esko provides the drivers for both SQL and Oracle DBMS types. Not all database drivers can be freely distributed by Esko, and not all drivers have been tested. If you need to connect to Other types, you need to connect using a JDBC driver.

5. Enter the connection details. These are different per type of DBMS. See examples in *Specifics per DBMS* on page 75.
6. If required for the DBMS, enter the name of the **Host**. This is the database server (computer) name.
7. If required for the DBMS, enter the **Port** number.
8. If required for the DBMS, enter the **User** name and **Password** that will be used to access the database.
9. Click **Test Connection** to test if your setup is valid. If it is not valid, the error message might contain details about the problem.
10. **Disclaimer**: Be aware of the risks of direct database queries and of the fact that Esko takes no liability for them. You need to agree before this configuration can be saved.

11. Click **File > Save** to save the configuration.

See the next section for some **specifics per DBMS**.

### Specifics per DBMS

#### Connecting to a Microsoft SQL Server

![Microsoft SQL Server configuration form]

#### Connecting to an Oracle Server

![Oracle Server configuration form]

#### Connecting an "Other" DBMS

**Other** DBMS can be accessed if you can get the necessary drivers and information on how to access the DBMS via standard JDBC technology.

- Download the JDBC driver (a jar file) from the manufacturer's website into a **Container** that is accessible to the Automation Engine (Master) server.
- Enter the required configuration fields. See an example:

  ![JDBC configuration example]

- Check your JDBC driver manual for more details.
### 9.13.10 External Web Services

Using the *Interact with Web Service task*, Automation Engine can communicate with web services from external systems.

To configure such a web service,

1. Go to **Tools > Configure**.
2. In the **Configure** window, select **External Web Services**.
3. Press the **Insert** key or go to **File > New**. Specify a name for the new **External Web Service**.
4. Specify **URL**.
   
   You can use a secure connection via SSL (a URL starting with `https://`) with or without a valid SSL certificate signed by a "Certificate Authority" (CA).
   
   When using a secure connection without a valid certificate, import the certificate into the server **java KeyStore**. Use the following command on the Automation Engine server:

   ```
   keytool -import -alias mydomain -file myfile.crt -keystore C:\Esko\bg_prog_fastserver_v40\jre\lib\security\cacerts
   ```

   Check the **Allow unverified SSL Certificate** option to do this.

   **Warning:** This setting is not secure.

   If you need to pass via a proxy, configure the proxy settings via **Tools > Configure > Web Proxy**.
5. Select the **Authentication** mode from the drop-down options: **None, Basic** or **WebCenter**.
9.13.11 FastImpose Site Preferences

The FastImpose site preferences serve to map ink names to custom names. For example if you want to map 'C' to the French 'bleu' on your plates.

**Ink Names**

Click **Add** to add two initial values to the list: **key** and **value**. Double click the words to edit them.

**Tip:** A black rectangle around the field indicates that you can edit it.

If you want to change 'C' to 'Bleu', then enter **C** in the **Name** column, and 'Bleu' in the **Customized Name** column:

This does not change your file, but if you used marks that would output 'C' on plate, they will now mention that ink as 'Bleu'.

**Surfaces**

When the values that describe front - back printing modes, like **F/B**, Front/Back, Back, **F**, Front, **B** are not conform your language or your way of working, you can here change them.

An example: changing Front/Back to read Recto/Verso:
9.13.12 FlexProof - Image Downloader

Select the item FlexProof - Image Downloader and go to File > New.

**Note:** Don't forget to save your settings. Use File > Save.

**Tab "General"

- **Type:** The type will appear after having synchronized. First fill in the other settings.
  
- **Proofer Node:** Enter the FlexProof computer name.

  **Attention:** The name of the Image Downloader Proof Node is case sensitive. This is not the case for the other devices.

- **Synchronize with Proof Node.** This may take a few seconds, the system will fill out the 'Type' field.

**Tab "Queue"

- **Queue:** A default name is proposed. This field automatically updates when you rename the device.

- **Queue Job Limit:** A FlexRip's Dispatcher EskoLink queue can handle the expose command of 2 jobs at the same time. If you want the Automation Engine queue to allow sending 2
expose commands at the same time, then set the job limit of the Automation Engine queue on 2.

Putting this job limit on 1 will result in each expose command to that EskoLink queue being handled one by one: the second job will be ripped after the first one is completely finished ("First In First Out" principle).

**Note:** Having jobs RIP'ed earlier on the FlexRip does not mean that your output device can output them any earlier.

### Tab "Merge"

- **Merge**: Define if you want merge jobs on output.
- **Unit**: Select a unit for the below fields.
- **Margin**: Define an extra margin around the output.
- **Gap**: When merging, a gap adds an extra zone of empty pixels around each job.
- **Minimum Fill**: When merging, enter what percentage of minimum fill you want in the output. No output is generated before this fill percentage is reached.

### 9.13.13 FlexRip - Approval

Select the item **FlexProof - Approval** and go to **File > New**.

**Note:** Don't forget to save your settings. Use **File > Save**.

### Tab "General"

- **Type**: The type will appear after having synchronized. First fill in the other settings.
- **Rip Node**: Enter the FlexRip/FlexProof computer name.
- **EskoLink Portnr.**: Enter the port number of the Dispatcher’s EskoLink queue.
- Fill out these fields before you click **Synchronize with Rip**. This may take a few seconds.

### Tab "Queue"

- **Queue**: A default name is proposed. This field automatically updates when you rename the device.
- **Queue Job Limit**: A FlexRip’s Dispatcher EskoLink queue can handle the expose command of 2 jobs at the same time. If you want the Automation Engine queue to allow sending 2 expose commands at the same time, then set the job limit of the Automation Engine queue on 2.
Putting this job limit on 1 will result in each expose command to that EskoLink queue being handled one by one; the second job will be ripped after the first one is completely finished ("First In First Out" principle).

**Note:** Having jobs RIP'ed earlier on the FlexRip does not mean that your output device can output them any earlier.

**Tab "Merge"**

- **Merge:** Define if you want merge jobs on output.
- **Unit:** Select a unit for the below fields.
- **Margin:** Define an extra margin around the output.
- **Gap:** When merging, a gap adds an extra zone of empty pixels around each job.
- **Minimum Fill:** When merging, enter what percentage of minimum fill you want in the output. No output is generated before this fill percentage is reached.

**9.13.14 FlexRip - B**

Select the item **FlexRip - B** and go to **File > New**.

**Note:** Don't forget to save your settings. Use **File > Save**.

**Tab "General"**

- **Type:** The type will appear after having synchronized. First fill in the other settings.
- **Rip Node:** Enter the FlexRip computer name.
- **EskoLink Portnr.:** Enter the port number of the Dispatcher's EskoLink queue.
- Fill out these fields before you click **Synchronize with Rip**. This may take a few seconds.

**Tab "Queue"**

- **Queue:** A default name is proposed. This field automatically updates when you rename the device.
- **Queue Job Limit:** A FlexRip's Dispatcher EskoLink queue can handle the expose command of 2 jobs at the same time. If you want the Automation Engine Queue to allow sending 2 expose commands at the same time, then set the job limit of the Automation Engine queue on 2.

Putting this job limit on 1 will result in each expose command to that EskoLink queue being handled one by one; the second job will be ripped after the first one is completely finished ("First In First Out" principle).
Automation Engine

**Note:** Having jobs RIP'ed faster on the FlexRip does not mean that your output device can output them any earlier.

- **Optimize Expose Sequence:** Select this to have all separations RIP'ed in one pass, which normally leads to faster output. For some jobs however, this way of working results in memory problems, when this happens, deselect this option so that all separations will be RIP'ed separately (the RIP will be restarted after every separation).

**Tab "Merge"**

- **Merge:** We advise to set this to **No** as merging will then happen after this pass on the way to the Imagesetter and this gives a higher flexibility in merging (positive and negative can be merged on one film).
- **Unit:** Select a unit for the below fields.
- **Margin:** Define an extra margin around the separations.
- **Gap:** When merging, a gap adds an extra zone of empty pixels around each separation.
- **Minimum Fill:** When merging, enter what percentage of minimum fill you want in the output. No output is generated before this fill percentage is reached.

**9.13.15 FlexRip - BI (Barco Imagesetter)**

Select the item **FlexRip - BI (Barco Imagesetter)** and go to **File > New**.

**Note:** Don't forget to save your settings. Use **File > Save**

**Tab "General"**

- **Type:** The type will appear after having synchronized. First fill in the other settings.
- **Rip Node:** Enter the FlexRip computer name.
- **EskoLink Portnr.:** Enter the port number of the Dispatcher's EskoLink queue.
- **Fill out these fields before you click Synchronize with Rip.** This may take a few seconds.

**Tab "Queue"**

- **Queue:** A default name is proposed. This field automatically updates when you rename the device.
- **Queue Job Limit:** A FlexRip's Dispatcher EskoLink queue can handle the expose command of 2 jobs at the same time. If you want the Automation Engine Queue to allow sending 2 expose commands at the same time, then set the job limit of the Automation Engine queue on 2.
Putting this job limit on 1 will result in each expose command to that EskoLink queue being handled one by one: the second job will be ripped after the first one is completely finished ("First In First Out" principle).

**Note:** Having jobs RIP’ed faster on the FlexRip does not mean that your output device can output them any earlier.

- **Optimize Expose Sequence:** Select this to have all separations RIP’ed in one pass, which normally leads to faster output. For some jobs however, this way of working results in memory problems, when this happens, deselect this option so that all separations will be RIP’ed separately (the RIP will be restarted after every separation).

**Tab "Merge"**

- **Merge:** because this device type cannot merge, this settings is always on 'No'
- Select a **Unit** for the below field.
- **Margin:** Define an extra margin around the separations.

### 9.13.16 FlexRip CDI, CDI Spark and CDI Compact

These three types of devices can be configured in the same way. Select the matching item and go to **File > New**.

**Note:** Don’t forget to save your settings. Use **File > Save**.

**Tab "General"**

- **Type:** The type will appear after having synchronized. First fill in the other settings.
- **Rip Node:** Enter the FlexRip computer name.
- **EskoLink Portnr.:** Enter the port number of the Dispatcher’s EskoLink queue.
- Fill out these fields before you click **Synchronize with Rip**. This may take a few seconds.

**Tab "Queue"**

- **Queue:** A default name is proposed. This field automatically updates when you rename the device.
- **Queue Job Limit:** A FlexRip’s Dispatcher EskoLink queue can handle the expose command of 2 jobs at the same time. If you want the Automation Engine Queue to allow sending 2 expose commands at the same time, then set the job limit of the Automation Engine queue on 2.
Putting this job limit on 1 will result in each expose command to that EskoLink queue being handled one by one: the second job will be ripped after the first one is completely finished ("First In First Out" principle).

**Note:** Having jobs RIP’ed faster on the FlexRip does not mean that your output device can output them any earlier.

- **Optimize Expose Sequence:** Select this to have all separations RIP’ed in one pass, which normally leads to faster output. For some jobs however, this way of working results in memory problems, when this happens, deselect this option so that all separations will be RIP’ed separately (the RIP will be restarted after every separation).

**Tab "Merge"**

- **Merge:** Define if you want merge jobs on output.
- **Unit:** Select a unit for the below fields.
- **Margin:** Define an extra margin around the output.
- **Gap:** When merging, a gap adds an extra zone of empty pixels around each job.
- **Minimum Fill:** When merging, enter what percentage of minimum fill you want in the output. No output is generated before this fill percentage is reached.

**Tab "CDI"**

When the CDI has a recent version of Grapholas software, the **Pixelclock** will here be shown as ‘Automatic’.

Older versions ask you to define the values here:

- **Pixelclock** is set to 360.000.
- **Perimeter:** Define the perimeter of the drum, in the selected unit.

### 9.13.17 FlexRip - HP Indigo 4000 Series

Select the item **FlexRip - HP Indigo 4000 Series** and go to **File > New**.

**Note:** Don’t forget to save your settings. Use **File > Save**.

**Tab "General"**

- **Type:** The type will appear after having synchronized. First fill in the other settings.
- **Rip Node:** Enter the FlexRip computer name.
- **EskoLink Portnr.:** Enter the port number of the Dispatcher’s EskoLink queue.
• Fill out these fields before you click **Synchronize with Rip**. This may take a few seconds.

**Tab "Queue"**

• **Queue**: A default name is proposed. This field automatically updates when you rename the device.

• **Queue Job Limit**: A FlexRip's Dispatcher EskoLink queue can handle the expose command of 2 jobs at the same time. If you want the Automation Engine Queue to allow sending 2 expose commands at the same time, then set the job limit of the Automation Engine queue on 2.

Putting this job limit on 1 will result in each expose command to that EskoLink queue being handled one by one: the second job will be ripped after the first one is completely finished ("First In First Out" principle).

**Note**: Having jobs RIP'ed faster on the FlexRip does not mean that your output device can output them any earlier.

• **Optimize Expose Sequence**: Select this to have all separations RIP'ed in one pass, which normally leads to faster output. For some jobs however, this way of working results in memory problems, when this happens, deselect this option so that all separations will be RIP'ed separately (the RIP will be restarted after every separation).

### 9.13.18 FlexRip - Proofer Output

Select the item **FlexRip - Proofer Output** and go to **File > New**.

**Note**: Don't forget to save your settings. Use **File > Save**.

**Tab "General"**

• **Type**: The type will appear after having synchronized. First fill in the other settings.

• **Rip Node**: Enter the FlexRip computer name.

• **EskoLink Portnr.**: Enter the port number of the Dispatcher's EskoLink queue.

• Fill out these fields before you click **Synchronize with Rip**. This may take a few seconds.

**Tab "Queue"**

• **Queue**: A default name is proposed. This field automatically updates when you rename the device.

• **Queue Job Limit**: A FlexRip's Dispatcher EskoLink queue can handle the expose command of 2 jobs at the same time. If you want the Automation Engine Queue to allow sending 2 expose commands at the same time, then set the job limit of the Automation Engine queue on 2.
Putting this job limit on 1 will result in each expose command to that EskoLink queue being handled one by one: the second job will be ripped after the first one is completely finished ("First In First Out" principle).

**Note:** Having jobs RIP’ed faster on the FlexRip does not mean that your output device can output them any earlier.

### Tab "Proof"

**Recombine Separations:**

You can define this workflow choice: or you choose to let the FlexRip recombine the separations or you choose to add a ‘Proof (FlexProof)’ task.

- **On the FlexRip**, you can add a margin, no merging is possible.
- **By Sequencing A ‘Proof (Image Downloader)’ Task:** You then need to select the ‘FlexProof - Image Downloader’ device from the list.

**Note:** The list only shows those devices that are configured for the same node; the RIP and Proof node must be identical.

### 9.13.19 FlexRip - Screened Output

**Shared Settings for all FlexRip flavors of Screened and Unscreened Output**

- **Tab "General"**
  - **Type:** The type will appear after having synchronized. First fill in the other settings.
  - **Rip Node:** Enter the FlexRip computer name.
  - **EskoLink Portnr.:** Enter the port number of the Dispatcher’s EskoLink queue.
  - Fill out these fields before you click **Synchronize with Rip**. This may take a few seconds.

- **Tab "Queue"**
  - **Queue:** A default name is proposed. This field automatically updates when you rename the device.
  - **Queue Job Limit:** A FlexRip’s Dispatcher EskoLink queue can handle the expose command of 2 jobs at the same time. If you want the Automation Engine Queue to allow sending 2 expose commands at the same time, then set the job limit of the Automation Engine queue on 2.

Putting this job limit on 1 will result in each expose command to that EskoLink queue being handled one by one: the second job will be ripped after the first one is completely finished ("First In First Out" principle).

**Note:** Having jobs RIP’ed faster on the FlexRip does not mean that your output device can output them any earlier.
Automation Engine

•

• **Tab "Merge"**
  • **Merge**: Define if you want merge jobs on output.
  • **Unit**: Select a unit for the below fields.
  • **Margin**: Define an extra margin around the output.
  • **Gap**: When merging, a gap adds an extra zone of empty pixels around each job.
  • **Minimum Fill**: When merging, enter what percentage of minimum fill you want in the output. No output is generated before this fill percentage is reached.

**DCS**

Select the item **DCS** below the item **FlexRip - Screened Output** and go to **File > New**.

*Note:* Don’t forget to save your settings. Use **File > Save**.

All options in the menu tabs are equal to those for other flavors. They are described in the page **FlexRip - Screened Output** on page 85.

**TIFF**

Select the item **TIFF** below the item **FlexRip - Screened Output** and go to **File > New**.

*Note:* Don’t forget to save your settings. Use **File > Save**.

All options in the menu tabs are equal to those for other flavors. They are described in the page **FlexRip - Screened Output** on page 85.

There is one exception for the TIFF flavor: The tab "Queue" offers this extra option:

• **Optimize Expose Sequence**: Select this to have all separations RIP'ed in one pass, which normally leads to faster output. For some jobs however, this way of working results in memory problems, when this happens, deselect this option so that all separations will be RIP'ed separately (the RIP will be restarted after every separation).

**PDF**

Select the item **PDF** below the item **FlexRip - Screened Output** and go to **File > New**.

*Note:* Don’t forget to save your settings. Use **File > Save**.

All options in the menu tabs are equal to those for other flavors. They are described in the page **FlexRip - Screened Output** on page 85.

**PS**

Select the item **PS** below the item **FlexRip - Screened Output** and go to **File > New**.
Note: Don't forget to save your settings. Use File > Save.

All options in the menu tabs are equal to those for other flavors. They are described in the page FlexRip - Screened Output on page 85.

9.13.20 FlexRip - Unscreened Output

DCS
Select the item DCS below the item FlexRip - Unscreened Output and go to File > New.

Note: Don't forget to save your settings. Use File > Save.

All options in the menu tabs are equal to those for other flavors. They are described in the page FlexRip - Screened Output on page 85.

TIFF
Select the item TIFF below the item FlexRip - Unscreened Output and go to File > New.

Note: Don't forget to save your settings. Use File > Save.

All options in the menu tabs are equal to those for other flavors. They are described in the page FlexRip - Screened Output on page 85.

There is one exception for the TIFF flavor: The tab "Queue" offers this extra option:

• **Optimize Expose Sequence**: Select this to have all separations RIP'ed in one pass, which normally leads to faster output. For some jobs however, this way of working results in memory problems, when this happens, deselect this option so that all separations will be RIP'ed separately (the RIP will be restarted after every separation).

PDF
Select the item PDF below the item FlexRip - Unscreened Output and go to File > New.

Note: Don't forget to save your settings. Use File > Save.

All options in the menu tabs are equal to those for other flavors. They are described in the page FlexRip - Screened Output on page 85.

PS
Select the item PS below the item FlexRip - Unscreened Output and go to File > New.

Note: Don't forget to save your settings. Use File > Save.
All options in the menu tabs are equal to those for other flavors. They are described in the page *FlexRip - Screened Output* on page 85.

### 9.13.21 Gang Run Printing

These fields are relevant when you work with the Pilot's Gang Run Printing view.

- **Output Folder**: Define the folder where the substrate queues write their nested layout files. These files are picked up from here as input files for the output workflow (specifically the *Export nested Layouts task*). Normal use of the Gang Run Printing mode does not require you to access these files.

**Note**: We advise to clean up these temp data. This can easily done in your output workflow ticket: See this example:

- The Custom Fields can be given specific names so that they can be used in the 'Extra' tab of the Submit to Gang Run task. They then show up as extra columns in the Gang Run printing view of a specific Substrate Queue.

- If you also confirm that a Custom Field can be Used as grouping key, the value of this field will so help control which files are nested together. Typical attributes to base nesting groups on are Customer, Printing Method, Finishing Method. Learn more about grouping keys in Grouping Certain Graphics Together.

- Select *Use the Customer field as grouping key* if you want a system-wide setting for this feature, in stead of having to control it per ticket of the Submit to Gang Run task.
9.13.22 Global Vision

Concept

Following Automation Engine tasks use technology from the company Global Vision: *Inspect Artwork, Inspect Barcodes, Inspect Braille, Inspect Spelling* and *Inspect Text*.

These tasks require a software license created by Global Vision. You can purchase various subscription packages directly from Global Vision or choose to purchase one via Esko. This configuration item guides you to get that license from Global Vision and activate it on Automation Engine.

How to Request a License

To purchase, activate or check your Global Vision license, click **Request License**... and follow the indicated steps.

**Note:** The registration ID identifies your computer where the Global Vision License Server was installed. This component of the Automation Engine is by default installed on the same computer as the Automation Engine server software.

Global Vision uses this registration ID to generate your license key to run these tasks on Automation Engine. This license key can only be activated on the same Automation Engine server as the one you used to get your registration ID.

The website [https://esko.globalvisioninc.com/](https://esko.globalvisioninc.com/) will ask you if you already purchased such a license from Esko or if you want to purchase a subscription plan from Global Vision.

**Note:** This online video describes this procedure (the case where someone purchased the subscription plan from Esko).

About Remaining Days and Usage Count

When you have a license from Global Vision, the panel mentions a detailed status of this license:

- It shows the number of **used inspections** and the maximum number of inspections that can be run (without being charged extra).

  **Note:** An inspection is "used" each time a Global Vision inspection task has run. Only if the task failed to run completely (for example the task ran out of available memory), this is not counted as "used".

- When the number of used inspections is equal or higher than the maximum (licensed) number of inspections:
  - An active internet connection is required to be able to continue using the Global Vision Inspection tasks without activating a new license, given that the current license is not expired in time.
The Automation Engine master server needs to be able to connect to http://www.globalvisioninc.com/eskolicense/. Connecting through a proxy server is not supported.

Global Vision then bills you the extra used inspections separately.

When no active internet connection is available, any subsequently run Global Vision Inspection tasks will fail.

When you have annual licenses, the number of used inspections is reset each month.

When you have a permanent license, this will be mentioned instead.

Note: You can also request a new license when the license is not expired.

What to do when your Automation Engine Master Server (name) changes

We mentioned above that this license is based on the computer name of your Automation Engine server.

In case of disaster recovery of your server, you might for example promote an Automation Engine Assistant to become the new Automation Engine Master. If you need to do this, you also need to activate the Global Vision license on the new Master.

Note: Learn more about server Assistants in the Pre-Install IT Requirements Guide, specifically the page on Components Glossary.

Follow these steps to move your Global Vision license to the new Master server:

2. On that new server, request a new license as described above.
3. To deactivate the previous license, contact Global Vision support. They will also credit you for the previous license.

9.13.23 Imaging Engines

This is where you configure any Imaging Engine RIPs.

Learn more in the chapter RIP’ing with Imaging Engine, in the page Imaging Engine Configuration.

9.13.24 Jobs

Tip: Working with Automation Engine Jobs is documented in the dedicated chapter Jobs.

Job Setup

You can here define the name of several Custom Fields.

When you enter names in custom fields 3 to 6, an extra tab Categorization will appear in the Job Setup dialog box.
Note: Think carefully about these names because changing their names later creates confusing lists of values for these fields in existing Jobs.

JDF Setup
This item allows to define default settings that are used when (new) Jobs are created via JDF/JMF.

• Tab "Settings for JDF job creation"
  • **Job Name** and **Job Folder**: Use SmartNames to define the name and folder of the resulting Job.
  • **Apply Job Setup**: This option allows to create a same job folder structure for each new Job created via JDF. Select the option and click **Select** the Job of which you want to take over its job folder structure.

You can also indicate what other items should be copied from that Job, apart from the **Folders**. Select **Tickets** to also copy any (blue) Job tickets into the new Job. Select **Parameters** to also copy those defined in the Job's setup tab 'Parameters'.

• **Tab "Custom Fields"**
  This is where you can define how the data in the "Comment" JDF elements is used to populate the custom fields (**Categories**) that appear in the Job Setup dialog.
To do this, type an XPath expression into the field corresponding to the category you want to fill in automatically. To get some help, click **Edit** to open the **XPath builder**.

**Note:**

- The JDF that was loaded in the XPath builder is remembered while the **Configure** dialog is open.
- When editing the next XPath, the same JDF will be automatically used as the example XML in the XPath builder.

---

**XPath Builder**

**Concept**

When you click **Edit** in any field that allows XPath Expressions, the **XPath Builder** opens.

The XPath Builder offers alternative starting points:

- The XPath is not resolved relative to the root node of the XML document, but from another XML element.
- When a proper JDF is used as the example XML, a list of possible starting points is generated.
- While the XPath builder automatically selects the appropriate starting point, it is still possible to manually change the starting point by clicking on another node while holding down **Command** (Mac) or **CTRL** (Windows).

**Example**

See an example where the XPath builder is used to create an XPath for a product part attribute:
The XPath builder automatically uses the first PageData node as starting point. This is visualised by showing the content outside the PageData node in grey.

It is still possible to select nodes outside the PageData node as result node or as predicate node.

When selecting nodes outside the PageData node, the XPath builder will create absolute XPaths.

When you want, you can modify these absolute paths by making them relative to the PageData node using ..

Job Web Page

Concept

In the Pilot, you can right-click a job folder and select Go to Job Web Page. This opens an internet browser and loads a predefined path (URL).

This is typically used to navigate from within an Automation Engine Job to its related WebCenter project.
Configuration

This is where you define the web **Address** for the **Job Web Page**. Obviously, it needs to be a valid URL, so if you use SmartNames, make sure they resolve correctly.

This is the typical structure of such a URL to a WebCenter project:

- The first part of the URL is typically the name of your WebCenter web site. For example `http://MyWebCenterServer/WebCenter_Inst`
- This is followed by `/projdetails.jsp?projectName=`
- You end with a SmartName that resolves as the name of the WebCenter project for that job. For example: when the WebCenter project has the same name as the Job on Automation Engine, then use `[Job Name]`.

Smart Job Location

**Concept**

A **Smart Job Location** uses rules and SmartNames to define the location of a Job's job folder. This avoids having to enter this path manually when creating Jobs.

There are three types of specifications that you can use to set up the Smart Job Location. You can base the location on the **Customer** of that job, or on a custom **Rule** or you can specify (only) the **Container**.

These three methods are checked in a specific order: If no path is found based on the **Customer**, the set of custom rules will be checked. If there is still no valid path found for the job folder, then the **Container** setting will be checked.

The dialogs **'New Job'** and **'Job Setup'** offer the option to **Use the Smart Job Location Rules**. To see a preview of what the folder path will be, click on the button **"Show Job Location"** to see how the current rules create the path for this job. An example:
Configuration

We now have a closer look at the types of specifications:

- **Customers:**
- **Rules:**
- **Container:**

**Tip:** Also when using JDF to create jobs, it is possible to use the concept of Smart Job Location as a SmartName for the indication of the folder for the job in JDF: use `<SJL>`.

**Customers**

You can here define a root location for all jobs of a specific customer. An example:

These settings also become part of the customer definition in **Tools > Customers**. An example:
Rules

When no customer based setting was specified (or no valid location could be found), the systems checks if you did set any custom Rules.

These rules are based on conditions that use Regular Expressions. Click the Help button for a brief tutorial.

Here is an example where job folders are created in a specific root folder based on the number in their job's Order ID:

Container

When the checks on Customers and Rules did not return a valid path for a job folder, then the folder will be created in the here defined Container.
Here are two main use cases for this setting:

- Use it as a "Default Job Location". When you request a Smart Job Location, we always advise to at least here fill in a Container based location. This way, when none of the categories Customers or Rules result in a location, the system will use this setting, and not use a location that you can not control.

- This setting is useful when you have a system where you have all jobs created within one Container (a share on a hard disk) until that share has no more free space. You then create a next Container, change this setting to the new Container and you so use that one until it also fills up, etc.

**9.13.25 Nexus**

This configuration is explained in the dedicated section on *Integrating with Nexus*. Find a direct link [here](#).

**9.13.26 Notification**

Notifications are messages sent by Automation Engine (E-mail, .XML or .TXT files).

**Note:** For E-mail notifications, please check if the *Send E-mail task* is a better alternative.

The two tabs in this Configure item offer more advanced ways:

- **Rules**.
- **Via File**.

You can also use notification Templates to customize their content. Learn more in *Notification Templates*.

**Notification Rules**

Instead of defining notifications per ticket, you can define general notification Rules. You can set a notification rule for all or specific tasks or devices (queues).

You can define such rules for Tasks and for Devices.

For example:

- Writing an XML file every time a Milestone task ends.
- Writing an XML file of all actions on your CDI Compact device. Or have each notification added to the main XML for that CDI.
Note: Note that, for CDI and Kongsberg devices, the specific tools as described in their dedicated chapters may be a better alternative.

Attention: When you set a notification for both a device and for a task using that device, then only the one on task level will be executed.

Creating a Notification Rule

1. Click Add.
   The Notification Rule Editor opens.

2. Define the rule:
   • Condition
     • Select one or multiple of the task statuses and select if this is the status of this single task type or of the whole workflow that this task belongs to as a step.
   • Action
     • Then: Choose the type of notification.

   Tip: If you want multiple types, create multiple notification rules.

   • E-mail: Choose if you send it to the one who launched the task or type in E-mail address (when multiple, use a semicolon as separator). Select any attachments to the E-mail.

   Tip: This is a good place to use SmartNames that pick up the E-mail address of the job's Customer Service Representative (Job setup) or any Customer contacts.

   • XML file: Choose if you want a file per notification or if you want to add the information to an already existing XML file. For example: Adding all notification info related to a TIFF output device to one XML for each day (use SmartName [date] in the name of the XML file).
In the output field, minimally enter a name (use SmartNames). You can also define or browse to a specific folder to write the XML files into or you can leave this field empty and make the system use the default place for these files as defined in the next configuration item "Via File".

- **TXT file**: Same options as for XML files, but now you can also use templates to add custom text.
- **Template**: Templates add custom made texts. Learn more in Notification Templates on page 99.

**Note**: The "Templates" list and the "Edit Templates" button are only shown when at least one template was created before.

3. Click **OK** to confirm and close.

Add more if you want to.

**Via File**

When setting up a notification rule that creates XML or TXT file, you can choose to not enter any output folder for these files, but only specify their name (learn more here). In that case, these files are written in the default place that you define in these tabs.

- **Tab "Text"**
  - **Append the message in a Log File**: When you choose to add the notification information to a same file. Browse to change its location and there create/select an empty file.
  - **Create a new file per message in a folder**: Define the folder where these notification text files will be created.

- **Tab "XML"**

  Same as for TEXT files, but you can also choose to include the tasks messages (that appear in the task's "details") and the ticket parameters it used.

**Notification Templates**

A notification template can add custom text to the notification.

To create, modify or delete templates, click 'Edit Templates...' in the Notification Rule Editor. Alternatively, go to Pilot > Advanced > Edit Notification Templates...

Learn more below in Edit Notification Templates.

**Edit Notification Templates**

**Creating a template**

1. Click **Add**.
2. The **Add** dialog pops up. Enter a name for the template. Click **OK**.
3. The **Edit Template** dialog pops up.
It has dedicated fields for **Subject** and **Message**, SmartName enabled.

The field for **Task Information** is best only changed on advise of Esko support. It includes code-based conditional information that can include the attachments you requested while creating the notification rule.

Here is an example:

![Example of Task Information](image)

**Tip:** You can also Edit Notification Templates in the Configure tool, provided that you already have templates available: go to Configure > Notification > Rules > Task/Device > Add...

### 9.13.27 Odystar

This configuration is explained in the dedicated section on *Integrating with Odystar (soon outdated)*. Find a direct link here.

### 9.13.28 Proof Servers

This configuration is used to connect the Esko Proof Server which is required for

- the **Proof for Contract Approval** task (part of the Pack Proof product). Learn more in the user guide of Pack Proof, in the page on Pack Proof Configuration.
- the **Proof for Content Approval** task (part of the Imaging Engine product). Learn more in [Imaging Engine Configuration](#).

### 9.13.29 Plate Merger

This item is documented in the chapter *CDI Platemaking Workflow*. Find a direct link [here](#).

### 9.13.30 Preflight Tools

This item serves to link Automation Engine to external preflight server software that you can then use in the **Preflight via External Application** task.

**Caution:** In AE v16, the task 'Preflight via External Application' was declared to become 'Soon Outdated'. Learn more about this concept and your alternative in [Concept of (Soon) Outdated Tasks](#).

**Note:** When you want to use Enfocus PitStop, consider using the version that is built into Automation Engine. This is done when you use the task **Preflight with PitStop**.

**Important:**
- This external preflight server software (for example a separate install of PitStop Server) has to run on your Automation Engine server.
- You must share the folder containing the profiles (for example PitStop's C:\Program Files\Enfocus\Enfocus PitStop Server 13) to be able to access it from the Preflight ticket.

![Preflight Tools Configuration](#)

**Tool Name:** Select one of the supported preflight applications.

**Report Language:** Select the language you want the report to be in. For Enfocus PitStop Server, you can set this in the PitStop Server preferences.

**Report Units:** Select the units to be used in the preflight report.

**Report Type:** Select the type of report: PDF, XML or both.

**Executable File:** Enter (browse to) the path to the preflight application's executable file.
Profile Folder: Enter (browse to) the path to the folder where the default profiles for the selected preflight tool are stored.

Action Folder: Enter (browse to) the path to the folder where the action lists for the selected preflight tool are stored. The Preflight task will allow you to select multiple actions from this folder.

9.13.31 Printing Methods

Printing Methods are defined in the Configure tool. You get a list of standard names. You can add custom ones.

You can set an ink to a specific printing method by using the Job setup's Inks tab or by using one of these tasks: Adjust PDF Screening, Extract Inks, Normalize PDF File, Normalize PS / PDF / AI 8.0 File, Optimize PDF Separations, Trap with PowerTrapper, RIP'ing with Imaging Engine.

For example:

These are typical examples of how to make use of a Printing Method:
• In your **Imaging Engine** (RIP) task for a flexo device, you select only the inks of printing method 'flexo'.

• You make a special ReportMaker PDF that focusses on the 'ink' used for embossing. In your workflow, you use the **Extract Inks** task to select the wanted ink type before you start the ReportMaker task.

### 9.13.32 Processing Preferences

**Automatic Normalization**

Tasks that *require Normalized PDF files* as input will automatically normalize any native PDF you launch them on. This hidden and automatic normalization is using the here defined task ticket.

By default, Automation Engine uses the **Normalize PostScript/PDF/Illustrator 8.0 File** task ticket named "**OnDemand**".

From this ticket only the settings in the **Color Management** tab are taken into account.

All other settings of the automatic normalization are forced to fixed default settings. For example, automatic normalization will always embed all images.

** Embedded Images**

Normalized PDF files have the ability to save all their images internally, but this may result in oversized files. You can define the maximum size for internal images here.

Images exceeding the defined size will be saved externally.

### 9.13.33 Products

**Tip:** Automation Engine Products are documented in the dedicated chapter **Products**.

**Product Setup**

In the item **Product Setup**, you can name the custom fields that appear in the **Product Setup** and in the **Product Part Setup**.

---

103
Above example configuration results in this:
JDF Setup

Note: JDF workflows are not documented in this user manual. Learn more about the basics of JDF in the chapter Integrating with External Systems. For more information, contact Esko Solution Services.

General

When you work with JDF, decide here if you want to Enable automatic product creation via JDF.

Data Zone

Note: The Data Zone concept is documented in Products Data Structure.

- Create Data Zone and File when a new Product Part is created from JDF:
  - Data Zone: When the JDF references a non-existing product part, define here where to create the data zone for that product part (the physical folder containing the part’s file).
  - File: When the JDF references a non-existing product part, define here where to create the subfolder and/or file in the data zone.

- Apply Data Zone Structure: Use this option when you want to add a specific substructure to the data zone. Browse to an example data zone (folder with subfolders).

Product (Part) Setup

In the Product Setup and Part Setup tabs, you can add rules to map values from the JDF onto the attributes of the products that the JDF creates.

To do this, type an XPath expression into the field for each attribute that should be overruled by the system value, or click Edit to open the XPath builder.
Note:

• The JDF that was loaded in the XPath builder is remembered while the Configure dialog is open.
• When editing the next XPath, the same JDF will automatically be used as the example XML in the XPath builder.

Learn more about using XPath in XPath Builder on page 92.

Updating

In the Updating tab, indicate what should happen when an existing product is updated over JDF.

Learn more about updating products in The Add to Products task.

XPath Builder

Concept

When you click Edit in any field that allows XPath Expressions, the XPath Builder opens. The XPath Builder offers alternative starting points:

• The XPath is not resolved relative to the root node of the XML document, but from another XML element.
• When a proper JDF is used as the example XML, a list of possible starting points is generated.
• While the XPath builder automatically selects the appropriate starting point, it is still possible to manually change the starting point by clicking on another node while holding down Command (Mac) or CTRL (Windows).

Example

See an example where the XPath builder is used to create an XPath for a product part attribute:

• The XPath builder automatically uses the first PageData node as starting point. This is visualised by showing the content outside the PageData node in grey.
• It is still possible to select nodes outside the PageData node as result node or as predicate node.
• When selecting nodes outside the PageData node, the XPath builder will create absolute XPaths.
• When you want, you can modify these absolute paths by making them relative to the PageData node using ../

Smart Product Location

Smart Product Location allows to automatically decide the location for a new product based on a set of rules defined in Configure > Products > Smart Product Location.
Learn more about creating products in *Creating Products* and about their file location settings in *Product (Part) Properties*.

**Important:** You do not need this tool when your file is already in the right place when you make it a product part.

### Three Ways to Decide the Location

You can use three kinds of specifications to set up the Smart Product Location: based on **Customers**, on custom **Rules** and on a chosen **Container**.

These three ways are checked in a specific order: if the **Customers** check does not return a valid path, then **Rules** will be checked. If this still does not return a valid path, then the **Container** rule will be used.

- **Customers**: This rule allows to specify per customer a SmartName based path where all its products will be created.

- **Rules**: This tab allows to set extensive conditional rules. For example you could create all the products in a structure based on their 
  ```plaintext
  [custom field 1]
  ```
  You can create several rules and they will be checked from top to bottom.

- **Container**: This tab allows to set a smart path in a fixed Container where all products will be created (from now on). For example: All products are created in Container `Data1` and when the disk of that Container is full, you change the configuration so that from now all new products will be created in Container `Data2`.

### Using the Smart Product Location

Smart Product Location is used in these cases:

- When choosing **Uploading As a New Product**. This feature is used for example when your product data is still on a CD or on your desktop.

- When creating products via JDF or when placing products via JDF (a product part URL is already decided but ‘empty’ and the JDF then delivers the file to the URL that expects the file).

When **Uploading a File as a Product**, the panel shows the extra Smart Product Location tool at the bottom:
Click **Show Product Location** to see a preview of where the uploaded file will be placed. An example:

**Product Part Data Zone**

**Note:** Learn about the concept of **Data Zone** and see some examples in *Products Data Structure*.

Every product part has a data zone. It contains the product part file itself and any additional related files.

When you look at a product’s data zone in the Pilot, the depth of the data zone indicates the number of folders that you will see between the root of the data zone and the folder containing the actual product part file.
The **Default Depth** value that you enter here is used when you create or change the product part properties.

### 9.13.34 SAP Servers

Configuring an SAP server is required when integrating with such a system. Learn more in *Interact with SAP task*.

### 9.13.35 SFTP sites

SFTP sites are used in the *Upload via SFTP task* and also by an *SFTP Access Point*. Learn more about SFTP in the documentation pages of those tools or in this online article describing the difference between FTPS and SFTP.

To configure an SFTP site (an SSH server), open the Configure tool, select the topic **SFTP Sites** and choose **File > New**. A default name appears, click and wait to change it. It is good practise to add both the host server and the user in the name.

**Settings**

- **Server**: The name of the SFTP server.
- **User Name**: The name of the user logging in to that SFTP server.
- Authenticating with an SFTP server requires a valid SSH account (*username@host*) and one or both of these authentication methods:
  - a valid password
  - a pair of public-private key files, as generated by an SHH-keygen tool.

  An SHH private key authentication enables a higher level of security (it for example avoids bots trying out all user/passwords). These keys come in pairs, a public and a private key.

**Note**: In the rare case where the SFTP server was set to accept both types of authentication, you can enter both a password and a private key. The system then first checks the password method, and when that fails, it tries the keys.

- When using a **password**, enter the password.
- When (also) using a **Private Key**, use **Select...** to upload the private SSH key file into the Automation Engine database. Optionally, fill in the **Passphrase** (to be able to unlock the key).

**Note**: When the public-private key pair authentication is used, the public key must be added to the authorized keys of the SFTP server and the private key must be selected in this configure tool.

**Clear** serves to remove a prior selected key from the Automation Engine database.
• **Test Connection.** Always test before saving this configuration.

### 9.13.36 Secure Web Proxy

Learn about using web proxy settings in the page on the item Web Proxy. This item is where you add proxy settings when the communication is https (not http).

### 9.13.37 Scripts

*This dedicated chapter about Scripting* explains how Automation Engine can run custom scripts and so help automate desktop applications. Learn more about its configuration in this page on configuring the Script Runner tool.

### 9.13.38 Shuttle

Enter the **Port** to use for communication between your Automation Engine server and the Shuttle clients.

**Note:** By default this is port 5182, but if this port is already used by other processes, you should enter the next available port.

Click `:` to define the **Upload Folder.** This is where Shuttle clients will upload files that are not located in a Container.

**Attention:** However you use Shuttle, it is **mandatory** to specify an upload folder! If not you might get this error:

```
The spool folder does not exist on the server.
```
Note: The upload folder must be located in a Container.

• Select **Start Shuttle server automatically when Automation Engine is started** if you plan to make frequent use of the Shuttle technology.

• Select **Use the task history to re-launch tasks using the same public parameters** if you want Shuttle to remember the public parameter values that were used when submitting a file. If you then re-submit that file, these values will be automatically filled out.

Click the **Start** button to start Shuttle server. This is not required to use the Shuttle application. However, starting the server is required to use Shuttle via applications like ArtPro, PackEdge and Illustrator. Shuttle server makes Automation Engine’s workflows, tasks and files accessible to the Shuttle clients.

Save the settings by clicking **File > Save**.

**Shuttle Server Status**

This shows whether the Shuttle server is running and how many tasks it manages.

### 9.13.39 Track Edit Session

When you open a file that resides in an active Job (folder) in an Esko editor, the **Track Edit Session** task can automatically start logging times and several editing actions. This tracking stops when the file is closed.

You can here select for which editors you want to (automatically) run this task.

Learn more in the page about the **Track Edit Session task**.

**Note:** When changing this configuration, restart the editor to activate this behavior.

### 9.13.40 Viewer

The Viewer offers a range of tools that help guaranteeing optimal viewing details while at the same time limiting the time to prepare the view data. Learn more in **The Automation Engine Viewer**. You can here define some of their settings:
View PDF Files
Define here which normalization ticket will be used when you open non-normalized files (native PDF, AI, (E)PS).

View ArtPro Files
As mentioned in Supported File Types, you can choose to see ArtPro files in the Viewer in either of these ways:

- **As in ArtPro.** This mode is advised for ArtPro users who do not work with normalized PDF files in their workflow.
- **As in PackEdge.** This mode adds a normalization step before the view data are created. It is advised when you want to compare ArtPro files with Normalized PDF files. Some users will prefer this mode because it was used before (it was the default mode before version 14.1).

**Note:** The WebCenter Viewer and the Publish to WebCenter task always use this mode for ArtPro files.

In **External Images** you can define a ticket that has the correct settings to find the external images.

**Viewing Preferences**

- **Anti-Aliasing** smoothenes the staircase effect that you can get when pixels represent line art objects.
- **Merge Similar Inks** merges inks with the same name that have a different ruling or angle.

**Attention:** We strongly advise to enable this option when viewing ArtPro files or Normalized PDF files generated by ArtPro.
'Speed up for Viewing'

Choose the ticket that the "Speed up for Viewing" folders should use. Learn more in *Speed Up For Viewing*.

**9.13.41 Web Proxy**

For tools where Automation Engine uses http communication, you can here configure details of the Web Proxy to use.

- **Web Proxy Server**: Specify the computer name or IP address and port of the proxy server.
- **Proxy server requires a password**: When the proxy server requires authentication, specify the **User Name** and **Password** to use to authenticate.
- **Bypass proxy settings**: Specify a list of patterns separated by '|', The patterns may start or end with a '*'. For wildcards.

⚠ **Attention**: You need to restart Automation Engine before its tools start to use the web proxy for http communication.

These Automation Engine tools use web proxy settings for http communication:

- **Tasks**: *Create or Modify WebCenter Project*, *Download WebCenter Document*, *Integrate with WebCenter*, *Publish on WebCenter*, *Interact with Web Service*.
- **Cloud applications and storage tools**, configured in *External Web Services* on page 76.
- **Connection Doctor**, to troubleshoot the server.
- **In the Server Web page - Server Admin - Server Checks - Network**, the **Online help** check and the **WebCenter Sites** check.
- **Automation Engine's JDF Server (JMF)**, used to communicate with devices and external systems.

**9.13.42 WebCenter Sites**

Go to **Tools > Configure > WebCenter Sites** to configure links from Automation Engine to WebCenter sites.
Website:

Specify the web address of the WebCenter site. After you entered the WebCenter address, click Open... to check if the WebCenter site is up and running. If you are redirected to the login page, it means that the address is correct and that the site is up and running.

Tip: Be aware that this address is also the address that will be included in the notification e-mails when adding links to documents (approval cycle start E-mail). You should therefore make sure that the address can be accessed from the outside. Make sure to not use an internal address, but one that you want your (external) users to use when they use WebCenter.

WebCenter and Automation Engine are in the same LAN

Select this toggle if this is true. This will most likely be the case. Deselect this toggle if WebCenter and Automation Engine are not in the same LAN.

Note: How can you verify if these two systems are in the same LAN? They are in the same LAN when you can connect from WebCenter’s application server, this is the system where JBOSS is installed, to an Automation Engine Job Folder with the credentials of the System Account (by default the user BGSYSTEM or the one you changed it to, using the System Account page in the Server Web page).

WebCenter's Approval Client:

If WebCenter and Automation Engine are not in the same LAN, you first need to create an Automation Engine Approval Client in WebCenter. This is necessary to give Automation Engine permissions to listen to the approval messages that are stored in WebCenter.

Tip: If the Approval Client does not exist yet, follow these steps:

1. In WebCenter, log in as Administrator.
2. Go to the Admin section. In Configurations, select Workflow and Tunnel Approval Clients.
3. Click the link “New Workflow and Tunnel Approval Client”.
4. Enter a User name and a Password for the Automation Engine client. Mind that this is also the user name and password that have to be entered when configuring the WebCenter site in Automation Engine.

Fill out the client Name and Password and click the Check Connection button. This will check if the user can log on successfully.

The Info button displays the following information: “In case Automation Engine and WebCenter are not in the same local area network (LAN), the retrieval of the approval results is secured by a name and password. The name and password specified in Automation Engine must match the name and password specified in WebCenter by the WebCenter administrator. When clicking the ‘Check’ button, the WebCenter version will be checked and the name and password will be validated by WebCenter.”

Check Connection
When you click this button, you should, after a few seconds, get a window saying “Check OK”. The software version of that WebCenter will also be mentioned.

**Note:** The button will check the validity of the user name or password to connect to that WebCenter but not of your WebCenter’s Approval Client.

**Note:** Passwords are encrypted.

**Note:** When you connect to a secured WebCenter site (for example one that uses HTTPS://), then you have to export its security certificate and import it on the Automation Engine server. If this is not done, publishing from Automation Engine to WebCenter will result in an error. Learn more on how to do this in the chapter Install SSL Certificates on the Workflow Production Server of the WebCenter documentation.

**Tip:** After configuring a new WebCenter site, it is recommended to close your Pilot and start it again in order to see the updated list of WebCenter sites in your tickets.

### 9.14 Connection Doctor

The *Connection Doctor* allows you to troubleshoot the Pilot. This is documented in the dedicated chapter *Troubleshooting.*