Contents

1. About Automation Engine ....................................................................................................................... 5
   1.1 Copyright Notice ................................................................................................................................. 5
   1.2 Getting Help ......................................................................................................................................... 7

2. What is Automation Engine ..................................................................................................................... 8
   2.1 The Automation Engine Pilot .............................................................................................................. 10
      2.1.1 The Pilot’s Main Window ............................................................................................................. 10
      2.1.2 Views ........................................................................................................................................... 11
   2.2 Data Management in Automation Engine .............................................................................................. 12
      2.2.1 Containers ...................................................................................................................................... 13
      2.2.2 Jobs ................................................................................................................................................ 13
   2.3 Files Processing in Automation Engine ................................................................................................ 14
      2.3.1 Tasks ............................................................................................................................................. 14
      2.3.2 Task Chains .................................................................................................................................... 15
      2.3.3 Workflows ...................................................................................................................................... 15
      2.3.4 Tickets ............................................................................................................................................ 15

3. Getting Started with Automation Engine ................................................................................................ 17
   3.1 Starting Automation Engine ................................................................................................................ 17
      3.1.1 Starting the Automation Engine Server ....................................................................................... 17
      3.1.2 Starting the Pilot .......................................................................................................................... 18
   3.2 Performing Basic Configuration ........................................................................................................ 19
      3.2.1 Creating Users ............................................................................................................................... 19
      3.2.2 Defining User Access Rights ......................................................................................................... 19
      3.2.3 Configuring Output Devices .......................................................................................................... 21
   3.3 Uploading Files using the Pilot ............................................................................................................. 23
   3.4 Launching a Task on a File .................................................................................................................... 24
   3.5 Checking the Status of the Task ........................................................................................................... 25
   3.6 Checking the Result in the Viewer ........................................................................................................ 26
   3.7 Relaunching the Task ............................................................................................................................ 28
   3.8 Generating Output .................................................................................................................................. 28

4. Uploading Files to Automation Engine .................................................................................................... 29
   4.1 Uploading Files using the Pilot ............................................................................................................. 29
   4.2 Uploading Files from a FTP Server ....................................................................................................... 29
   4.3 Using Hot Folders to Upload and Process Files .................................................................................... 30
      4.3.1 About Hot Folders ......................................................................................................................... 31
      4.3.2 Creating a Task Hot Folder ............................................................................................................ 31
      4.3.3 Modifying Hot Folder Settings ..................................................................................................... 39
      4.3.4 Updating Your Task Hot Folders .................................................................................................... 40
### Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.4 Using Shuttle to Upload and Process Files</td>
<td>41</td>
</tr>
<tr>
<td>4.4.1 What is Shuttle?</td>
<td>41</td>
</tr>
<tr>
<td>4.4.2 Shuttle Setup</td>
<td>42</td>
</tr>
<tr>
<td>4.4.3 Launching Files from Shuttle Standalone</td>
<td>48</td>
</tr>
<tr>
<td>4.4.4 Launching Files from ArtPro</td>
<td>50</td>
</tr>
<tr>
<td>4.4.5 Launching Files from PackEdge or Plato</td>
<td>54</td>
</tr>
<tr>
<td>4.4.6 Launching Files from FastImpose</td>
<td>55</td>
</tr>
<tr>
<td>4.4.7 Launching Files from Neo</td>
<td>57</td>
</tr>
<tr>
<td>4.4.8 Launching Files from the Shuttle Plug-in</td>
<td>57</td>
</tr>
<tr>
<td>5. Running Tasks on Files</td>
<td>60</td>
</tr>
<tr>
<td>5.1 Creating a Task Ticket</td>
<td>60</td>
</tr>
<tr>
<td>5.1.1 Creating a Custom Ticket from the Tickets View</td>
<td>60</td>
</tr>
<tr>
<td>5.1.2 Creating a Custom Ticket when Working with Files</td>
<td>60</td>
</tr>
<tr>
<td>5.1.3 Using Public Parameters</td>
<td>62</td>
</tr>
<tr>
<td>5.1.4 Using SmartNames</td>
<td>70</td>
</tr>
<tr>
<td>5.2 Launching a Task on a File</td>
<td>72</td>
</tr>
<tr>
<td>5.3 Checking the Status of the Task</td>
<td>75</td>
</tr>
<tr>
<td>5.4 Relaunching the Task</td>
<td>76</td>
</tr>
<tr>
<td>6. Running Workflows on Files</td>
<td>77</td>
</tr>
<tr>
<td>6.1 Building Workflows</td>
<td>77</td>
</tr>
<tr>
<td>6.1.1 Building a Workflow from Zero</td>
<td>77</td>
</tr>
<tr>
<td>6.1.2 Building a Workflow using Custom Tickets</td>
<td>81</td>
</tr>
<tr>
<td>6.1.3 Reusing a Task Chain Ticket to Build a Workflow</td>
<td>82</td>
</tr>
<tr>
<td>6.1.4 Nested Workflows</td>
<td>86</td>
</tr>
<tr>
<td>6.1.5 Using Routing in Your Workflow</td>
<td>93</td>
</tr>
<tr>
<td>6.1.6 Using Public Parameters</td>
<td>102</td>
</tr>
<tr>
<td>6.1.7 Adding Sticky Notes to Your Workflow</td>
<td>111</td>
</tr>
<tr>
<td>6.1.8 Checking All the Workflow’s Parameters</td>
<td>112</td>
</tr>
<tr>
<td>6.2 Using Workflows</td>
<td>113</td>
</tr>
<tr>
<td>6.2.1 Launching a Workflow on a File</td>
<td>113</td>
</tr>
<tr>
<td>6.2.2 Building a Workflow and Launching it on a File on the Fly</td>
<td>115</td>
</tr>
<tr>
<td>6.2.3 Pausing or Cancelling Your Workflow</td>
<td>116</td>
</tr>
<tr>
<td>6.3 Checking the Workflow’s Processing Status</td>
<td>117</td>
</tr>
<tr>
<td>6.4 Re-launching Your Workflow with Different Settings</td>
<td>119</td>
</tr>
<tr>
<td>7. Viewing Files in the Automation Engine Viewer</td>
<td>120</td>
</tr>
<tr>
<td>7.1 About the Viewer</td>
<td>120</td>
</tr>
<tr>
<td>7.2 Checking the Result in the Viewer</td>
<td>121</td>
</tr>
<tr>
<td>7.3 Comparing Files</td>
<td>123</td>
</tr>
<tr>
<td>8. Integration with Other Applications</td>
<td>126</td>
</tr>
<tr>
<td>8.1 Integration with WebCenter</td>
<td>126</td>
</tr>
<tr>
<td>8.1.1 WebCenter Setup</td>
<td>126</td>
</tr>
</tbody>
</table>
8.1.2 Automation Engine Setup...........................................................................................................134
8.1.3 Sending an Imposition from Automation Engine to WebCenter...............................................136
8.1.4 Approving the Imposition in WebCenter.....................................................................................141
8.1.5 Checking the Approval Results in Automation Engine.............................................................146
8.1.6 Overruling the WebCenter Approval..........................................................................................150
8.2 Integration with Nexus....................................................................................................................151
8.2.1 Setup on the Nexus Side.............................................................................................................152
8.2.2 Setup on the Automation Engine Side........................................................................................153
8.2.3 Running a Nexus Workflow from the Pilot.................................................................................153
8.3 Integration with Odystar................................................................................................................155
8.3.1 Setup on the Odystar Side.........................................................................................................156
8.3.2 Setup on the Automation Engine Side........................................................................................159
8.3.3 Running an Odystar Workflow from the Pilot.............................................................................160
8.4 Integration with i-cut Suite............................................................................................................162
8.4.1 i-cut Automate Workflow.........................................................................................................162
8.5 Integration with Enfocus PitStop..................................................................................................163
8.6 Integration with third party applications using Hot Folders.........................................................164
8.7 Integration with MIS Systems.........................................................................................................166
8.7.1 About JDF and MIS Integration................................................................................................166
9. Use Case: Setting up a Packaging Workflow......................................................................................169
9.1 Build a Workflow..........................................................................................................................169
9.1.1 Preflight your file.......................................................................................................................169
9.1.2 Normalize your File....................................................................................................................173
9.1.3 Trap your file............................................................................................................................173
9.1.4 View your file...........................................................................................................................175
9.1.5 Generate Step & Repeat.........................................................................................................176
9.1.6 Create Report...........................................................................................................................177
9.2 Use Shuttle in the Workflow..........................................................................................................179
9.2.1 What is Shuttle..........................................................................................................................179
9.2.2 What are Public Parameters.....................................................................................................179
9.2.3 Making Your Tickets Public.....................................................................................................179
9.2.4 Using Public Parameters.........................................................................................................180
9.2.5 Public Parameters in Sample Workflow: Packaging...............................................................187
9.2.6 Launching Files into a Workflow..............................................................................................188
1. About Automation Engine

Maximizing Productivity
Automation Engine doesn’t only enable you to keep track of your files throughout your workflow, it also optimizes and automates this workflow to increase your productivity.

Automation Engine:

- avoids double entry and possible operator errors,
- processes files faster (through digital standardization of production procedures, hot folders automation, smart notifications…).
- frees operators from administrative tasks so they can concentrate on value-adding graphical tasks,
- allows operators to share their expertise through tickets,
- keeps jobs, related files and related customer information organized to facilitate communication and treatment of additional orders.

All this maximizes your efficiency and the quality of your deliverables, while lowering the cost of prepress-related actions.

Integrating with your Existing Systems
Automation Engine can integrate seamlessly with your graphical editors, RIP, file servers, MIS system…

It supports the industry standards (PDF, XML, XMP, SQL queries, JDF communication…).

The Automation Engine client application (the “Pilot”) can be installed on any Macintosh or Windows machine in your network, so all your operators can view files, get information or launch processing tasks as needed.

Growing with You
Automation Engine is very modular and can be tailored to your needs, while always offering growth possibilities.

From a background assistant to Adobe® Illustrator® to a central prepress server to a complete server platform linking to your administrative systems, Automation Engine can grow with you to let you handle larger accounts, accepting more jobs without increasing your costs.

You can find an overview of all Automation Engine modules on the Esco website.

1.1 Copyright Notice

© Copyright 2012 Esko Software BVBA, Gent, Belgium

All rights reserved. This material, information and instructions for use contained herein are the property of Esko Software BVBA. The material, information and instructions are provided on an AS IS basis without warranty of any kind. There are no warranties granted or extended by this document. Furthermore Esko Software BVBA does not warrant, guarantee or make any representations regarding the use, or the results of the use of the software or the information contained herein. Esco
Software BVBA shall not be liable for any direct, indirect, consequential or incidental damages arising out of the use or inability to use the software or the information contained herein.

The information contained herein is subject to change without notice. Revisions may be issued from time to time to advise of such changes and/or additions.

No part of this document may be reproduced, stored in a data base or retrieval system, or published, in any form or in any way, electronically, mechanically, by print, photoprint, microfilm or any other means without prior written permission from Esko Software BVBA.

This document supersedes all previous dated versions.

PANTONE®, PantoneLIVE and other Pantone trademarks are the property of Pantone LLC. All other trademarks or registered trademarks are the property of their respective owners. Pantone is a wholly owned subsidiary of X-Rite, Incorporated. © Pantone LLC, 2012. All rights reserved.

This software is based in part on the work of the Independent JPEG Group.

Portions of this software are copyright © 1996-2002 The FreeType Project (www.freetype.org). All rights reserved.

Portions of this software are copyright 2006 Feeling Software, copyright 2005-2006 Autodesk Media Entertainment.

Portions of this software are copyright ©1998-2003 Daniel Veillard. All rights reserved.

Portions of this software are copyright ©1999-2006 The Botan Project. All rights reserved.

Part of the software embedded in this product is gSOAP software. Portions created by gSOAP are Copyright ©2001-2004 Robert A. van Engelen, Genivia inc. All rights reserved.

Portions of this software are copyright ©1998-2008 The OpenSSL Project and ©1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

Adobe, the Adobe logo, Acrobat, the Acrobat logo, Adobe Creative Suite, Illustrator, InDesign, PDF, Photoshop, PostScript, XMP and the Powered by XMP logo are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Microsoft and the Microsoft logo are registered trademarks of Microsoft Corporation in the United States and other countries.

SolidWorks is a registered trademark of SolidWorks Corporation.

Portions of this software are owned by Spatial Corp. 1986 2003. All Rights Reserved.

JDF and the JDF logo are trademarks of the CIP4 Organisation. Copyright 2001 The International Cooperation for the Integration of Processes in Prepress, Press and Postpress (CIP4). All rights reserved.

The Esko software contains the RSA Data Security, Inc. MD5 Message-Digest Algorithm.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems in the U.S. and other countries.

Part of this software uses technology by BestTM Color Technology (EFI). EFI and Bestcolor are registered trademarks of Electronics For Imaging GmbH in the U.S. Patent and Trademark Office.


All other product names are trademarks or registered trademarks of their respective owners.

Correspondence regarding this publication should be forwarded to:
1.2 Getting Help

You can find the PDF version of this manual on the Automation Engine Documentation DVD.

To get an overview all of the keyboard shortcuts you can use in the Automation Engine Pilot, go to Help > Shortcuts...
2. What is Automation Engine

**Automation Engine Architecture**

Automation Engine is a client/server workflow software, running on Mac and PC. This means that one machine runs the Automation Engine server, to which you can connect from all Mac and PC machines in your network (using the Automation Engine Pilot).

Your Automation Engine server can connect to graphical editing software like ArtPro, PackEdge, Adobe Illustrator (using the DeskPack plug-ins)...

It can also connect to your RIP software to ensure professional output.

You can store your files either on the Automation Engine server, on a dedicated file server, or on different machines over the network (using containers).
Automation Engine Processing

Automation Engine processes your files using Tasks (for example a Trap or RIP task), Task Chains (a succession of tasks, for example normalizing your PDF file, trapping it, then zipping it), and Workflows (more powerful and flexible grouping of tasks, that can take complete care of the file from input to output).
Files and Jobs in Automation Engine

In Automation Engine, your files can be part of jobs (customer orders that contain files and related customer information), that are located in containers (local or remote shared folders that Automation Engine can access).

Depending on how you want to work with Automation Engine, you can link your jobs to customer products, focus on job pages, proofs, plates...

Automation Engine Integration

Automation Engine can not only connect to editing and RIP software, but also to WebCenter (Esko's collaborative web platform) and other Esko workflow software (Nexus and Odystar).

2.1 The Automation Engine Pilot

The Automation Engine server software runs on a Windows server. Every Automation Engine action is performed through the Automation Engine client, called the Pilot.

The Pilot can be installed on any Mac or Windows machine on your local network.

Depending on the user access rights you will set, operators can use the Pilot to:

- organize jobs and files,
- create and modify tickets,
- launch and monitor tasks,
- control workflows and devices,
- administrate users and perform general configuration,
- etc.

2.1.1 The Pilot's Main Window

1. These icons show different modes in the Pilot:
2. The Views highlight different parts of the Automation Engine functionality. Certain views are only accessible in defined workflows. For more information, see Views.


4. The Create Job button allows you to create a job.

5. The New Task button allows you to select a Ticket from the list. The New Workflow button opens the workflow editor and allows you to build a new workflow. For more information see Running tasks on files and Running workflows on files.

The contents of the central panes depends on the view you are in.

2.1.2 Views

The Pilot’s Views highlight different parts of the Automation Engine functionality. You can use them to work with your data in different ways (see Different Ways of Working with Automation Engine).

Note:
- Depending on the mode you are using (Containers, Job Overview or Last used job), you will have access to different views.
- Depending on your access rights, you may not be able to see some of the views.

Files
The Files view allows you to manage your jobs, files, favorites, tasks... See The Files View for more information.

To Do List
The To Do List view lists all actions that need user intervention. For more information, see The To Do List View and To Do List.

Pages
The Pages view is only used in page workflows. It is extremely useful when working with impositions. For more information, see Working with Pages.

Products
The Product view shows the production files associated with your jobs, and allows you to reuse those files for a similar order from the same customer. For more information, see Working with Products.

Proofs
The Proof view is only used in page workflows. It shows the proof sets and the proof details. See Working with Proofs.
WebCenter
Before you can use the WebCenter view, make sure that your WebCenter site is correctly configured. See Integration with WebCenter.

Plates
The Plates view is only used in page workflows. It shows details about all plates associated with a job. It also includes advanced features for managing plates for jobs with multiple versions. See Working with Plates.

CDI
The CDI view shows all the files sent to the Digital Flexo Suite and used to image a flexo plate on a Cyrel Digital Imager. See The CDI View.

Tasks
The Tasks view shows the current state of processing: the running tasks, the tasks waiting for execution and the recently finished tasks. See The Tasks View.

Devices
The Devices view lists all output devices connected to your Automation Engine server. It allows you to monitor, start and stop your devices and device queues.

Milestones
The Milestone view shows all milestones set for your last job (in Last used job mode), or the milestones set for all jobs (in Job Overview mode). See Milestones.

Hot Folders
The Hot Folders view lists all hot folders defined on the server (in Container mode) or all hot folders defined for a job (in Last used job mode). It offers all the necessary tools to create and manage hot folders. See About Hot Folders.

Tickets
The Tickets view shows a list of all tickets available on your server (both the default and your custom tickets). See Tickets.

Jobs
This view is only visible in Job Overview mode. It lists all jobs defined on the server. See The Jobs View.

2.2 Data Management in Automation Engine

Automation Engine works with containers, jobs, files and folders.

In the Pilot, you can view your data (files and folders) inside containers or/and jobs. There are three modes:
• **Containers**: this shows all the data that Automation Engine can access, in the different Containers. For more information, see Containers.

• **Job Overview**: this lists all jobs existing in the Automation Engine Job database. See Jobs.

• **Last used Job**: this shows the last job you worked on, and the job’s data (files and folders).

### 2.2.1 Containers

A container is a special folder containing your files, folders and jobs, that Automation Engine can access. It can be located either on your Automation Engine server or another machine.

By default, you have an empty **ExampleJobContainer**, on the drive Automation Engine was installed on.

You can have many containers, that you can see in the Pilots’ Containers mode.

To create a container, see *Creating a Container* in the Reference Guide.

### 2.2.2 Jobs

**What is a Job?**

A job contains all the files and information relative to a customer job you process in Automation Engine.

It has a blue icon and is stored in the Automation Engine Job Database. The database can hold up to 100 000 jobs.

In the Containers mode, you can see your job in its container.

In the Last used job mode, you can see your job’s subfolders and files.
Job Metadata

You can attach an extended set of metadata to every job: customer information, inks to use, bar codes, impositions...). This metadata is stored in the Automation Engine database, and will be used when launching tasks on the job.

Job Automation

Automation Engine is very job-centric. On top of launching tasks and workflows on the job, you can also have tasks be launched automatically when the job reaches a certain status (for example: a new page has been delivered, the sheet is complete...).

For more information about Jobs, see Working with Jobs in the Reference Guide.

2.3 Files Processing in Automation Engine

In Automation Engine, you can process your files using Tasks, Task Chains (old BackStage workflows), and Workflows.

Each of these has a Ticket, which contains all the parameters for that task, task chain or workflow.

2.3.1 Tasks

What is a Task?

A task is an action executed on a file, a folder or a job on the Automation Engine server.

Types of Tasks

There are seven types of tasks:

1. Conversion tasks such as Export to PDF, Export to PostScript...
2. File Creation tasks such as Create Wrapper File, Create PAF / JPG / XML...
3. File Editing tasks such as Contourize & Clean, Trap...
4. Verification tasks such as Check Job Parameters, Check Print Rules, Preflight...
5. Administration tasks such as Prepare to Archive, Upload via FTP, Zip...
6. RIP tasks.
7. Device Output tasks.

Task Settings

You can define settings for the tasks, and save these settings as Tickets to reuse them (see Tickets).
2 Task Progress
When a task is launched, you can monitor its progress in the Pilot. See *Checking the Status of the Task.*

2.3.2 Task Chains
Old BackStage workflows are still supported in Automation Engine (just as in BackStage), but are now called Task Chains.

A task chain is a succession of tasks, linked together in the task chain ticket.

You can build new workflows from your task chains, while keeping all your tickets settings (see *Reusing a Task Chain Ticket to Build a Workflow*).

2.3.3 Workflows
Automation Engine workflows are more powerful and flexible than the old BackStage workflows.

You can build them and launch them on your files using the workflow editor (see *The Workflow Editor*).

You can also launch them from the Pilot or from Shuttle (see *Using Shuttle to Upload and Process Files*).

2.3.4 Tickets

What is a Ticket?
The settings used when executing a task, task chain or workflow on a file can be saved as a ticket.

Default and Custom Tickets
The Pilot comes with a default ticket for each task, but you can also create custom tickets. You cannot overwrite or delete default tickets.

You can see all the available tickets (default and custom) in the Pilot’s Tickets view.
Global and Job Tickets

Global tickets ( ) can be used on any file you can access through the Automation Engine Pilot, whereas job tickets ( ) are linked to a particular job.

Public Tickets

You can make tickets public if you want to submit files to them from Shuttle. There are several ways to make a ticket public (see Making Your Ticket Public in the User Guide).

Public tickets have a mark in the Public column.

<table>
<thead>
<tr>
<th>Task Type</th>
<th>Ticket Name</th>
<th>Public</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zip</td>
<td>Default</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>WC_Approval</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>WaitForRundirFiles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>TrackAP</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Track_DraftedPDF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>SimpleTrip</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Send2Office</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Note: Depending on your access rights, you may only see public tickets, and public parameters inside the tickets.
3. Getting Started with Automation Engine

3.1 Starting Automation Engine

To start working with Automation Engine you need to:

- Start the Automation Engine server, see Starting the server.
- Start the Automation Engine pilot, see Starting the pilot.

3.1.1 Starting the Automation Engine Server

Automation Engine features a new web tool for server administration. This means you can access the server administration tool from any workstation via http://servername or http://servername:9999/.

On this web server administration tool you will also find the client application(s) such as the Automation Engine Pilot, a diagnostics tool, a back-up tool, ...

To start the Automation Engine server:

1. Open your web browser and go to http://servername or http://servername:9999/.

2. Log in with your user name and password.

3. In the Server administration > Start/Stop Server window, you have access to all administration tasks for the Automation Engine server.
For more information on working with the server, see *Server Administration*.

### 3.1.2 Starting the Pilot

On your Automation Engine client machine:

1. Do one of the following:
   - double-click the Pilot desktop icon,
   - go to *Start > All Programs > Esko > Automation Engine Client 10.0 > Pilot.*

2. In the Logon Information dialog that opens:

   ![Logon Information Dialog]

   a) Enter a User name and Password valid for your Automation Engine server.
3.2 Performing Basic Configuration

3.2.1 Creating Users

1. In the Pilot, go to Tools > Users.
2. In the Users window, do one of the following:
   - go to File > New User,
   - use the CTRL + N shortcut,
   - click the icon.
   The New User dialog opens.
3. Enter the user's Name, Full Name, Password, Description and valid E-mail address.
4. If you want the user to be able to administer Automation Engine, check the toggle.
   This will give all user access rights to that user.
5. Click OK to add your new user to the Users list.

Attention:
Creating a user via Automation Engine means that Automation Engine requests the Windows OS to create that user.
Some changes to that user can then no longer be made through the Automation Engine Pilot, but need to be done via the Windows user administration tools.

3.2.2 Defining User Access Rights

Not all users have the same responsibilities, so you can assign them different access rights in Automation Engine.

To give access rights to a single user:
   a) in the Users window, double the user you want to give access rights to,
b) in the **Access Rights** tab of the **Properties** window, check the access rights you want this user to have.

![Properties window](image)

**Note:** Automation Engine Administrators automatically have all access rights. You cannot change this.

- To give a particular access right to several users:
  a) in the **Users** window, click the **Access Rights** button to switch to the **Access Rights** view,
  b) select the access right you want to give to your users,
  c) check the users you want to give this access right to.
3.2.3 Configuring Output Devices

Automation Engine can output files to a variety of output devices (CDI, HP Indigo, Kodak Approval, etc.).

Automation Engine uses EskoArtwork’s FlexRip engine to RIP the file in preparation for output.

To connect Automation Engine to an output device, you need to connect it to FlexRip.

1. In the Pilot, go to **Tools > Configure**.

   This opens the **Configure** dialog.
2. Select the option corresponding to your output device in the list at left (for example, select FlexRip - Proofer Output to output to a proofer).

3. Go to File > New or use the Insert key (on Windows).
   
   This shows tabs with parameters at right.
4. In the **General** tab:
   a) To output to a RIP, enter the name or IP address of your RIP server in **RIP Node**.
      For a FlexProof output, enter the name / IP address of your proof server in **Proofer Node**.
   b) Enter the EskoLink port number used by the Dispatcher in **EskoLink Portnr**. (only for FlexRip outputs).

   **Note:** You can find that port number by going to **Info > Ports** in the Dispatcher.

   c) Click the **Synchronize with Rip / Synchronize with ProofNode** button.

   After a few seconds, your RIP/proof server is connected to Automation Engine, and you can see its name in the **Type** field.

5. In the **Queue** tab:
   a) Give your queue a name in the **Queue** field.
   b) Choose a **Queue Job Limit**:
      - choose 1 to have the RIP handle one file at a time (this ensures the files are ripped in the order they enter the RIP),
      - choose 2 to have the RIP handle two files at once (the files may not be ripped in the order they enter the RIP if for example you send a big then a small file).

6. Go to **File > Save** to save the configuration.

   You can now see the devices you are connected to in the Pilot’s **Devices** view.

### 3.3 Uploading Files using the Pilot

1. In the Pilot’s **Containers** mode, select the container and folder in which you want to upload your file.
2. Go to **File > Upload**...
3. In the browser dialog that opens, browse to your file and click **Upload**.
3.4 Launching a Task on a File

There are several ways to launch a task on a file (from the Pilot, from Shuttle, via Hot Folders or via JDF/JMF). Here is how to launch a task from the Pilot’s Files View.

1. In the Pilot, select the Files view from the Views bar (or use Go > Files).
2. In the Containers mode, browse to your chosen file.
3. Right-click it, select New Task then More Tickets...

**Note:** If you have launched tasks previously, the most recent task tickets you used are listed above More Tickets...

4. In the Select Ticket dialog that opens, select the task ticket you want to use.

**Note:** This dialog contains all the tickets suitable for the file type you selected. You can choose either a Default ticket, or a custom ticket (saved under a different name) if you have already created one.

5. Click OK.

This opens the task’s ticket.
6. Fill in the settings you want to use in the ticket.

   **Note:** For a description of all of the ticket’s settings for each task, see *The Tasks: an Overview* in the Reference Guide.

7. Click the Launch button.

   You can monitor the tasks progress in the Files View’s Task pane or in the Tasks View. See *Check the Status of the Task*.

### 3.5 Checking the Status of the Task

After launching a task on one or several file(s), you can check its processing status in the Pilot’s Tasks pane. You can see the Tasks pane in the Files, Product or Tasks views.

You can see the progress (in percentage) and the processing state. The state can be:
• starting
• ✓: success
• !: warning
• ✗: failure
• 🔄: processing cancelled

You can also double-click the task entry in the Tasks pane to open your task ticket and check its parameters.

**Note:** Depending on your access rights, you may only see the public parameters.

### 3.6 Checking the Result in the Viewer

The Automation Engine Viewer can open different file types (PDF, AI, PSD...). For a full list, see Supported File Types in the Reference Manual.

In the Files view, do one of the following:

- Click the word View next to your file.
- Right-click your file and select View...
- Select your file and go to File > View.
You can now zoom in on the file, measure distances and densities, view separations individually or together, etc.
3.7 Relaunching the Task

- To relaunch the task without changing the settings:
  a) Select the task to relaunch in the Tasks pane.
  b) Go to Tasks > Relaunch.
- To change the settings and relaunch the task:
  a) Select the task to relaunch in the Tasks pane.
  b) Go to Tasks > Open.
  c) Change the task settings as necessary.
  d) Click the Launch button.

3.8 Generating Output

To output a file, use a task related to the output device you have configured (see Configuring Output Devices).

For example, use the Proof (FlexProof) task if you have configured a proofing device using FlexRip - Proofer Output.

Note: The task related to your output device will only be available once you have correctly configured your output device.
4. Uploading Files to Automation Engine

You can work with files that are already stored in your containers, or upload new files to Automation Engine. You can upload files from the Pilot, using Hot Folders or with the Shuttle application and plug-in.

4.1 Uploading Files using the Pilot

1. In the Pilot’s Containers mode, select the container and folder in which you want to upload your file.
2. Go to File > Upload...
3. In the browser dialog that opens, browse to your file and click Upload.

4.2 Uploading Files from a FTP Server

1. In Containers mode, right-click the folder in which you want to upload your file, and select Upload from FTP Site...
   This opens the Upload from FTP Site dialog, where you can enter the details necessary for the FTP connection.
2. In Host, enter the name of the FTP server that hosts your files.
   Tip: To use a port other than the default port, add : and the port number after the host name. For example: myftpserver:1085
3. Enter the User Name and Password you use to connect to the FTP server.
   Make sure you use a valid User Name and Password corresponding to an account that exists on the FTP server.
4. In File Transfer, choose between Binary and ASCII.
   Binary will always work, but if you have an ASCII file, the transfer will go a bit faster when selecting ASCII.
5. By default, the transfer uses Active Connection Mode (where the FTP server opens the data connection).
   If your system is behind a firewall that blocks incoming FTP server connections, select Passive to use Passive Connection Mode (where the client initiates the connection).
6. Select Secure FTP if you are connecting to a secure FTP server (over FTPS, not SSL or SSH).
   Tip: If you are experiencing problems using secure FTP, try connecting over regular FTP, and ask your IT administrator to check the security settings of your FTP server.
7. If desired, you can delete the files from the FTP site once they are uploaded to the Pilot (select Remove remote data after transfer).
If you do this, you can choose to **Backup remote data before removal.** Select the **Backup Folder** in which to copy the files.  
8. When you are done, click **Connect**.
4.3.1 About Hot Folders

A Hot Folder is a special folder monitored by Automation Engine. When you drop a file into the Hot Folder, Automation Engine will pick it up and process it.

There are two types of Hot Folders:

- **Task Hot Folder**: when you drop a file of the right file type into the Hot Folder, Automation Engine launches a task, task chain or workflow (that you have attached to the Hot Folder), on the file.
  
  See [Creating a Task Hot Folder](#).

- **JDF Hot Folder**: when your MIS system drops a JDF file into the Hot Folder, Automation Engine processes it. When processing is finished, it writes the result into the output folder associated with the JDF Hot Folder.
  
  See [Creating a JDF Hot Folder](#).

4.3.2 Creating a Task Hot Folder

1. Either:
   - click the Hot Folders view in the Views bar,
   - go to Go > Hot Folders,
   - use `CTRL + SHIFT + H`.

2. Click the Create New Hot Folder button 📦.

3. In the dialog that opens, select **Task Hot Folder** and click **OK**.

This opens the **New Hot Folder** dialog.
4. Browse to the folder you want to turn into a Hot Folder.

**Note:**
- You cannot select folders that are already Hot Folders.
- You can create a new folder with a new name.

5. If desired, you can change the responsible Operator.

6. You can also make the Hot Folder Inactive at certain times (to decide when the files will be processed and/or use less resources).

7. Set the Poll Interval (how often Automation Engine will check the Hot Folder for new files).
   - By default, this is set to 5 minutes.

8. Assign a Low, Normal or High processing Priority to the files coming into your Hot Folder.

9. Attach a task or workflow to your Hot Folder.
   - This task/workflow will be launched automatically on files coming into the Hot Folder.
   - You can either:
     - Attach a task or task chain that will process all file types.
     - Attach a workflow that will process all file types.
     - Attach different tasks/workflows to process different file types.

10. When you are done, click OK in the New Hot Folder dialog.
The Hot Folder is now listed in the Pilot’s Hot Folders View. You can see information about the Hot Folder in the Details pane at the bottom.

Attaching a Task for All File Types

1. **Choose A Task (Chain) for all File Types in Automatic Tasks.**
2. **Click Edit... near Task Type and Settings.**
3. **In the Add Step dialog, select the task (or task chain) ticket you want to use and click OK.**
4. In the Select Task Type and Settings dialog, enter your settings and click Save and Close.
### Select Task Type and Settings

<table>
<thead>
<tr>
<th>Save and Close</th>
<th>Tickets:</th>
</tr>
</thead>
</table>

#### Steps:

![Image](image)

#### Settings for Step: Contourize & Clean

- **Output in:**
- **File Name:**

**Contourize**

- **Quality:** Medium (medium)
- **Maximum Deviation:** 0 mm

**Clean**

- **Minimum:** 0 mm
- **Maximum:** 0 mm

> All contours with a size smaller than the minimum size or larger than the maximum size will be removed.

**Check for Copydot data**

The task will fail when Copydot data is found.

**Note:**

- You can add other tasks as steps to create a task chain (for more information, see [Task Chains](#)).
- Task (chain) tickets are copied into the hot folder and lose all relation with the original tickets.
5. Select Grouped Launching if you want the files in the Hot Folder to be processed together (in one workflow) instead of individually.

**Tip:** Use this with a specific Inactive time (for example 08:00 AM to 05:00 PM, so the files are only processed at the end of the day) or a very large Poll Interval.

6. Select a Working Folder (Automation Engine will copy the input files to this folder and start the processing from there).

7. Choose to Delete the input files when the automatic task is finished or not.

8. Add an Annotation if you wish.

**Attaching a Workflow for All File Types**

1. Choose A Workflow for all File Types in Automatic Tasks.

2. If you want to run the workflow in a job context:
   a) Select First, move files (to Job).
   b) Define the Job Folder to move the file(s) into.
   c) Define the name to give to the File.

   You can browse to a location and / or use SmartNames.

   ![Workflow setup interface]

3. Click the Set Up Workflow... button.

4. In the Select a Workflow to Start from dialog, select the workflow ticket you want to use and click OK.

   This opens that workflow in the workflow editor window.
5. Modify your workflow if desired, then save and close it.

Note: The workflow ticket is copied into the hot folder and loses all relation with the original ticket.

6. Select Grouped Launching if you want the files in the Hot Folder to be processed together (in one workflow) instead of individually.

Tip: Use this with a specific Inactive time (for example 08:00 AM to 05:00 PM, so the files are only processed at the end of the day) or a very large Poll Interval.

7. Select a Working Folder (Automation Engine will copy the input files to this folder and start the processing from there).

8. Choose to Delete the input files when the automatic task is finished or not.

9. Add an Annotation if you wish.

Attaching Tasks or Workflows for Different File Types

1. Choose Based on File Type in Automatic Tasks.
2. Click Add...
3. In the Add Step dialog, select the task (or task chain, or workflow) ticket you want to use and click OK.
4. In the Select Task Type and Settings dialog, enter the settings for the task(s), or for each workflow step, and click Save and Close.

Note:
- You can add other tasks as steps to create a task chain (for more information, see Task Chains).
- The tickets you choose are copied into the hot folder and lose all relation with the original tickets.

5. In the dialog that opens:

   a) Select the File Types you want to automatically process with this task, task chain or workflow.
4.3.3 Modifying Hot Folder Settings

If you need to modify a Hot Folder’s settings after creating it, do the following:

1. In the Hot Folders view:
   - double-click the Hot Folder you want to edit,
   - right-click it and select Open Hot Folder...
   - select it and go to File > Open Hot Folder... (or use CTRL + O).

2. In the Open Hot Folder dialog:
   a) change the Hot Folder settings (Hot Folder, Operator, Inactive between...) as necessary,
   b) change the attached task or workflow’s settings as necessary,
   c) click OK.

Note: Some files with external references are not supported (PLA, STA, GRQ, GRI...).

b) Select a Working Folder (Automation Engine will copy the input files to this folder and start
the processing from there).

c) Choose to Delete the input files when the automatic task is finished or not.

d) Add an Annotation if you wish.

e) Click OK.

6. Back in the New Hot Folder dialog, add tasks, task chains or workflows for other files types if
desired.
Tip: You can export the task ticket used for your Hot Folder, to be able to use it throughout Automation Engine. Use the Export Ticket... button and give the ticket a different name.

4.3.4 Updating Your Task Hot Folders

If you have Hot Folders created in Automation Engine 10.0 that launch a task chain containing a workflow ticket (for example Copy Or Move File + Workflow as below), you can use them to make new Hot Folders that launch the workflow directly.

Note: You can only do this if your old Hot Folder was launching a workflow, not a task chain consisting only of task steps.

You don’t need to make new Hot Folders as your old Hot Folders will keep on working, but the advantages of updating your Hot Folders are:

- You don’t need to add a separate Copy Or Move File task to copy the incoming files to a job folder (you can use First, move files (to Job)).
- You can edit the workflow to launch directly from within the New Hot Folder dialog.
- You can set a Poll Interval (how often Automation Engine will check the Hot Folder for new files).
- You can assign a processing Priority to the files coming into your Hot Folder.
- You can use Grouped launching to process the files in the Hot Folder together (in one workflow) instead of individually.

1. Open the old Hot Folder setup and:
   a) Click the workflow icon in the chain.
   b) Select the whole workflow except the Start step.
   c) Right-click the selection and click Copy.
You can also use Ctrl + C (on PC) or Command + C (on Mac).

d) Close the old Hot Folder setup window.

2. Create a new Hot Folder and:
   a) Choose A Workflow for all File Types in Automatic Tasks.
   b) Click the Set Up Workflow... button.
   c) In the Select a Workflow to Start from dialog, select the Default workflow ticket.
   d) In the workflow editor window that opens, paste the workflow you copied from the old Hot Folder and connect it to the Start step.

Do the rest of the Hot Folder setup as explained in Creating a Task Hot Folder on page 31.

4.4 Using Shuttle to Upload and Process Files

You can upload and process files from any Mac or PC client machine using the Shuttle application.

4.4.1 What is Shuttle?

Shuttle is a small stand-alone application that enables you to submit files to Automation Engine tasks or workflows, Odystar canvases, and Nexus workflows, and monitor their progress. You can use Shuttle to connect to several servers.
The Shuttle functionality is also integrated in ArtPro, Neo, PackEdge, Plato, FastImpose and in Adobe Illustrator as a DeskPack plug-in.

### 4.4.2 Shuttle Setup

**Automation Engine Setup for Shuttle**

1. In the **Pilot**, go to **Tools > Configure**.
2. Select **Shuttle** in the left pane.
3. Enter the **Port** to use for communication between your Automation Engine server and the Shuttle clients.

   **Note:** By default this is port 5182, but if this port is already used by other processes, you should enter the next available port.

4. Choose an **Upload Folder** using the **Browse...** button.

   This is where Shuttle clients will upload files that are not located in a container (except the Shuttle plug-in, that will always upload files to the **DeskPackContainer**).
Note: The Upload Folder must be located on a container.

5. Select Start Shuttle server automatically when Automation Engine is started if you plan to make frequent use of the Shuttle technology.

6. Click the Start button to start Shuttle server.

   Shuttle server makes Automation Engine’s workflows, tasks and files accessible to the Shuttle clients.

7. Save your settings.

Note: If you need to make changes to this Setup, you must Stop the Shuttle server first.

Making Your Ticket Public

Important: With Shuttle, you can submit files to any Automation Engine task, task chain or workflow that has a custom ticket. To do this, you need to make the ticket public.

You can either:

- Select the Public option when creating the ticket.

- Select your ticket in the Ticket view, click [i] and select Public.
• Right-click your ticket in the Ticket view and select Public Ticket.

Note: Public tickets have a mark in the Public column.

<table>
<thead>
<tr>
<th>Task Type</th>
<th>Ticket Name</th>
<th>Public</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zip</td>
<td>Default</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>WC_Approval</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>WaitForRunListFiles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>TrackKF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Track_nestedPDF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>SimpleTrap</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Same2Copy</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Shuttle Clients Connecting to Any Server
Shuttle Standalone, the Shuttle plug-in, and the Shuttle clients in ArtPro, Neo and FastImpose Standalone can connect to a number of Odystar, Nexus and Automation Engine servers.

1. Launch your application.
2. Open the Preferences.

<table>
<thead>
<tr>
<th>In...</th>
<th>go to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shuttle Standalone</td>
<td>• Shuttle &gt; Preferences... or use Command + , (comma) on Mac</td>
</tr>
<tr>
<td></td>
<td>• Edit &gt; Preferences... on Windows</td>
</tr>
<tr>
<td>Illustrator</td>
<td>• Illustrator &gt; Preferences &gt; EskoArtwork &gt; Shuttle Preferences... on Mac</td>
</tr>
<tr>
<td></td>
<td>• Edit &gt; Preferences &gt; EskoArtwork &gt; Shuttle Preferences... on Windows</td>
</tr>
<tr>
<td>ArtPro</td>
<td>ArtPro &gt; Preferences... or use Command + K</td>
</tr>
<tr>
<td>Neo</td>
<td>Neo &gt; Preferences... or use Command + , (comma)</td>
</tr>
<tr>
<td>FastImpose Standalone</td>
<td>Tools &gt; Shuttle Preferences...</td>
</tr>
</tbody>
</table>

3. In the Servers tab (Advanced tab for Neo), click the + button at the bottom of the Servers list.
4. Enter your **User Name** and **Password**.

- When connecting to an Automation Engine server, enter the **User Name** and **Password** you use to login to the Pilot (the password can be blank if your server is configured to accept this).

You will have the same access rights (for example, the right to set processing priorities or not) in Shuttle as you have in the Pilot.

**Note:** If you don’t know which **User Name** and **Password** to use, contact your system administrator.

5. To connect to a server not broadcasting over the Bonjour network (Automation Engine servers or non-Bonjour-enabled Nexus servers):
   a) select **Manual** in the **Browse Method** list,
   b) enter your server’s name or IP address in **Server Address**,
   c) fill in the **Server Port** used by your server.
Note:
When connecting to an Automation Engine server, enter the port you defined in Configure (see Automation Engine Setup for Shuttle).

6. Click the Add button.

This adds a connection to your server in the Servers list.

- To remove the connection to a server, select it in the Servers list and click the button.
- To check or edit a server’s settings, double-click it in the Servers list.

Note:
If you are using the Shuttle plug-in with other Deskpack plug-ins, and you have setup a server connection with the Server Connection Assistant, you will see this connection in bold in the Shuttle plug-in’s Servers list (after restarting Illustrator).

You will be able to change the user name and password if necessary, but you will not be able to remove this connection from the Shuttle plug-in.

See the Adobe Illustrator Client documentation for more information on the Server Connection Assistant.

Shuttle Clients Connecting only to Automation Engine

The Shuttle clients in PackEdge, Plato and FastImpose Server can only connect to one Automation Engine server.

1. Launch your application.

2. Open the Preferences.
   - In PackEdge or Plato, go to Edit > Preferences or use Ctrl+Alt+Shift+P.
   - In FastImpose Server, go to Tools > Options...

3. In the Server&Resources tab (the Server tab for FastImpose Server):
   a) Select Connect to Automation Engine Server.
   b) Enter the Automation Engine Server Name and click Check.
      You should see a message saying the server is up and running.
   c) Select Login with the following user account settings, and fill in the User Name and Password you use to login to the Pilot.
      If the connection is successful, you will see a green dot and the message Connected as user ...
Tip:
If you are running an Automation Engine Pilot on the same computer, or another Shuttle client connecting to it (either PackEdge, Plato or FastImpose Server), you can select Login automatically with user name and password from other application connected to the server.
This way, if you are already logged in to the Pilot or the other client application, you won’t need to log in when starting PackEdge / Plato / FastImpose Server.

4. Restart your application.

4.4.3 Launching Files from Shuttle Standalone

1. To assign a Job ID and / or Job Part ID to the files to process in your workflow, go to Window > Context and fill in the Job ID and / or Job Part ID.

   ![Context](image)

   Do this when:
   - you want to add your file(s) to an Automation Engine job,

   **Note:** If the file you are launching is already located in an Automation Engine job, it will automatically be processed within that job’s context (you don’t need to enter the Job ID).

2. Open the Launch window using:
   - File > New Launch Window...
   - Option + Command + N on Mac or Alt + Control + N on PC.

3. Select the Workflow you want to launch on your file.

   ![Launch](image)

   - For Automation Engine workflows, you will see public tickets.
Note:
You can open several Launch windows, and select a different workflow in each.
If you quit and restart Shuttle, your Launch windows will be remembered.

4. Launch your file in one of the following ways:
   - Drag and drop your file on the Drop Files Here arrow.
   - Click the Launch... button and browse to the file you want to launch.
   - Go to File > Launch... and browse to the file you want to launch.
   - Use Command + S (on Mac).

5. If your workflow has public parameters, you will see a pop-up where you can fill them in.
4.4.4 Launching Files from ArtPro

1. To launch your current file to Shuttle, go to File > Launch Workflow...

   This opens the Launch Workflow window.

Note:
For more information on public parameters, see:
- Using Public Parameters,
2. Choose what file type you want to launch your file as.

<table>
<thead>
<tr>
<th>If your workflow is...</th>
<th>you can launch the file as...</th>
<th>with...</th>
</tr>
</thead>
<tbody>
<tr>
<td>an Automation Engine workflow accepting Normalized PDF files as input</td>
<td>Normalized PDF</td>
<td>either Normalized PDF or Normalized PDF (embedded)</td>
</tr>
<tr>
<td>an Automation Engine workflow accepting PDF files as input</td>
<td>PDF</td>
<td>any of the available PDF flavors</td>
</tr>
<tr>
<td>an Automation Engine workflow accepting ArtPro files as input</td>
<td>ArtPro</td>
<td>with the included images (TIFF, EPS...) or without (only the ArtPro and the ArtPro CT file)</td>
</tr>
</tbody>
</table>

3. If you want to add your file to an Automation Engine job, select it in the Job list or fill in the Job ID and/or Job Part ID.
4. If you want to add your file to an Automation Engine product, select it in the Product list or fill in the Job ID and/or Job Part ID.

Note: Use the Search... button to see a list of your server’s products.

5. Select the workflow you want to launch your file to.

6. If your workflow has public parameters, you can fill them in in the same window.
7. Click the Launch button.

### 4.4.5 Launching Files from PackEdge or Plato

**Attention:** You must save your file on an Automation Engine container before you can launch it into a workflow from PackEdge or Plato.

1. Go to File > Launch Workflow...
   
   This opens the Launch Workflow window.

2. Select the workflow you want to launch on your file in the workflow list.
3. If your workflow has public parameters, you can fill them in in the same window.

**Note:** For more information on public parameters, see *Using Public Parameters.*
4. Click **Launch** to launch the workflow on your file.

**Tip:**
To access Shuttle easily in the future (without using the menus):

1. Go to **Window > Toolbars > Shuttle** to open the Shuttle palette.
2. Drag it into your application’s toolbar.
3. Click to open the **Launch Workflow** window, or to open the **Shuttle** window.

### 4.4.6 Launching Files from FastImpose

When working with FastImpose Server, you must save your file on an Automation Engine container before you can launch it.

1. Go to **File > Launch Workflow**...
   
   This opens the **Launch Workflow** window.
2. Choose what file type you want to launch your file as.
   - When working with FastImpose Server, you can only launch your file as an IMP file.
   - When working with FastImpose Standalone, you can launch your file either as a JDF or a PDF file.
     Click the Settings... button to set JDF or PDF Export Preferences (see the FastImpose manual for more information).

3. Select the workflow you want to launch on your file in the workflow list.

4. If your workflow has public parameters, you can fill them in in the same window.
5. Click Launch to launch the workflow on your file.

4.4.7 Launching Files from Neo

1. Go to File > Launch Workflow...

   This opens the Launch Workflow window.

2. Select the workflow you want to launch on your file in the workflow list.

3. If your workflow has public parameters, you can fill them in the same window.

   For more information on public parameters, see:
   * Using Public Parameters,

   **Note:** If you want to go back to the default parameters values after changing them, use the Reset To Defaults button.

4. Click Launch to launch the workflow on your file.

4.4.8 Launching Files from the Shuttle Plug-in

To launch a file into a workflow through the Shuttle plug-in, it needs to be the current file in Illustrator (open and at the front).

1. Go to File > Launch Workflow... or use Option + Command + Z.

   This opens the Launch window.
2. When launching to Automation Engine, choose **Normalized PDF** in **Launch As**. This copies the Normalized PDF version of your file onto the **DeskPack Container**.

   **Note:** This uses the PDF Export plug-in to convert your Illustrator file to Normalized PDF. To refine the conversion, click **Settings...** and edit the **PDF Export Preferences**.

3. If you want to link your file to an existing Automation Engine job, fill in the **Job ID** and/or **Job Sub ID**.
Note:

- You must enter a Job ID / Job Sub ID that already exists on your Automation Engine server. The Shuttle plug-in cannot create jobs.
- The Normalized PDF that you launch with a Job ID / Job Sub ID will be linked to that job, so that tasks and workflows processing that file can use the job parameters.
- If you are launching a file that was already in an Automation Engine job, the Job ID and/or Job Sub ID will be filled automatically.

4. Select the workflow you want to launch your file to in Launch To Workflow.
5. If your workflow has public parameters, you can fill them in in the same window.
6. Click Launch to launch your file.
5. Running Tasks on Files

5.1 Creating a Task Ticket

5.1.1 Creating a Custom Ticket from the Tickets View

To create a ticket with your own parameters, that you will be able to reuse:

1. Open the Default ticket of your chosen task.

   Note: To create a custom workflow ticket, see Building a Workflow from Zero.

2. Fill in your parameters.
3. Go to File > Save As... or use Ctrl + Shift + S (on PC) / Shift + Command + S (on Mac).
4. In the Save As pop-up:

   a) enter the name to give your custom ticket,
   b) add the ticket to your favorites if you like,
   c) make the ticket public if you want to be able to use it from Shuttle (send files to that task using your ticket's parameters).

   Note: The Scope is always Global when creating a custom ticket from the Tickets view.

5.1.2 Creating a Custom Ticket when Working with Files

You can create a custom ticket when launching a task on a file too:
1. Right-click your file, select **New Task** then **More Tickets**.
2. In the **Select Ticket** dialog that opens, select the **Default** ticket for the task you want to use.
3. Fill in the settings you want to use in the ticket.
4. Go to **File > Save As**... or use **Ctrl + Shift + S** (on PC) / **Shift + Command + S** (on Mac).
5. In the **Save As** pop-up:
   a) enter the name to give your custom ticket,
   b) add the ticket to your favorites if you like,
   c) make the ticket public if you want to be able to use it from Shuttle (send files to that task using your ticket's parameters).
Note:

- If you are not in a job context, the **Scope** is always **Global**.

- If you are in a job context, you can choose between **Job** and **Global Scope**. When choosing the job scope (called after your job), you **cannot** make the ticket public.

### 5.1.3 Using Public Parameters

Public parameters are ticket parameters that operators can define when submitting files through Shuttle.

For each public parameter, you can either:
• enter a list of predefined values the operator will choose from,
• let the operator enter a value himself.

Making a Parameter Public

**Note:** You need to define which parameters are public before files are submitted to your workflow.

In the ticket containing the parameter to make public:

1. Right-click the parameter and select **Make Parameter Public**.
2. Right-click it again and select **Modify Public Parameter**...
3. In the **Modify Public Parameter** dialog that opens:
   a) If necessary, change the way the parameter will be called in Shuttle in **Prompt as**.
   b) Choose either:
      • **Allow the user to set the value** if you want Shuttle users to be able to freely enter a value for that parameter.
      • **Let the user select a predefined value** if you want Shuttle users to choose from a list of values that you define.
If that parameter already has a list of values to choose from in the Ticket, they will be displayed here. You can Add or Remove values.

**Note:** Shuttle operators will see (and choose from) the Predefined Settings but not the associated Values.

c) If you have chosen Let the user select a predefined value: in Default Predefined Setting, choose the setting that will be selected by default when submitting files from Shuttle (if the operator doesn’t select another setting, this one will be used for processing).

4. Don’t forget to save your ticket.

This is how your public parameter will look to Shuttle operators:

<table>
<thead>
<tr>
<th>If you chose Allow the user to set the value</th>
<th>If you chose Let the user select a predefined value</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Custom Resolution 150ppi" /></td>
<td><img src="image" alt="Custom Resolution" /></td>
</tr>
</tbody>
</table>

Managing Public Parameters in Your Ticket

Once you have made parameters public in your ticket, you can have an overview of your public parameters and edit them at the ticket level.

1. In your ticket, go to Advanced > Manage Public Parameters...
The Manage Public Parameters dialog that opens contains all of your ticket’s public parameters.

The left pane shows all parameters that can be made public for that ticket (the ones you have made public are greyed out).
The right pane shows the parameters you have made public, with their settings (predefined values, etc.).

2. You can:
   - drag parameters from left to right to make them public;
   - click a public parameter’s cross if you don’t want it to be public anymore;
   - rearrange the order of your public parameters (drag them up or down);
   - change public parameters’ settings (Prompt as, Predefined Settings, etc.);
   - group public parameters under a header (click Add Group, click to edit the header, and drag parameters from the left);
   - use presets to simplify operators’ choices (see Using Presets to Simplify Operators’ Choices).
Using Presets to Simplify Operators’ Choices

You can use presets to minimize the amount of public parameters your operators have to choose from, and make it simpler for them.

For example, you want operators to use different trapping settings for printing with offset or dry offset. You can define those trapping settings in a preset, so that operators will only have to choose between offset and dry offset.

In the Manage Public Parameters dialog:

1. Click the Add Preset button.
2. Enter what your operators will see:
   a) in Prompt as, enter the name to give the preset parameter in Shuttle,
   b) enter the values that operators will choose from (replacing Type a value here).

   Click Add if you need to add extra values.

3. Drag parameters from the dialog’s left pane into the preset.

   You can drag as many parameters as you want. They will appear under each value (here both under Offset and Dry Offset).
4. Define the parameters values for each preset value.
   
   For example, define normal trapping, 50% opacity and object dependant end caps for Offset, and reverse trapping, 100% opacity and round end caps for Dry Offset.

5. Don’t forget to save your ticket.

   This is how your preset will look to Shuttle operators:

Making Your Ticket Public

**Important:** With Shuttle, you can submit files to any Automation Engine task, task chain or workflow that has a **custom ticket**. To do this, you need to make the ticket **public**.

You can either:
• Select the Public option when creating the ticket.

![Save As dialog]

• Select your ticket in the Ticket view, click \(\text{i}\) and select Public.

![Ticket view]

• Right-click your ticket in the Ticket view and select Public Ticket.

**Note:** Public tickets have a mark in the Public column.

<table>
<thead>
<tr>
<th>Task Type</th>
<th>Ticket Name</th>
<th>Public</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zip</td>
<td>Default</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>WC_Approval</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>WaitForPost</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Trap</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Trap_nested</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>SimpleTrap</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Some2Dsky</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**SmartNames in Public Parameters**

You can use SmartNames in your public parameters (for parameters taking SmartNames as input). In Shuttle, use square brackets around SmartNames when submitting a file with public parameters.
5.1.4 Using SmartNames

What is a SmartName?

A SmartName is a variable that refers to a predefined value, for example [File] refers to the name of the input file, and [Date] refers to the current date.

You can use SmartNames to fill in settings all across Automation Engine. They are displayed in green and between square brackets.

You can also combine them with plain text.

Using SmartNames ensures you can use existing information as a setting without having to remember it, and reduces errors.
Using a SmartName

You can use SmartNames anytime you see the SmartName symbol in a text field.

1. Click .
2. In the Insert SmartNames dialog:
   a) browse to your SmartName using the Categories,
   b) select it,
   c) click Insert.
   You can also double-click the SmartName.
Tip:

- You can type the first letters of the SmartName you are looking for to show it in the list.
- The dialog closes automatically after inserting a SmartName. To keep it open (to insert more SmartNames), hold Alt while clicking the Insert button or double-clicking a SmartName.
- If there are several SmartName-enabled text fields (in a ticket for example), keep the Insert SmartNames dialog open and just click on the next SmartName-enabled field to insert SmartNames in it.

5.2 Launching a Task on a File

There are several ways to launch a task on a file (from the Pilot, from Shuttle, via Hot Folders or via JDF/JMF). Here is how to launch a task from the Pilot’s Files View.

1. In the Pilot, select the Files view from the Views bar (or use Go > Files).
2. In the Containers mode, browse to your chosen file.
3. Right-click it, and select either:
   - New Task to fill in the ticket’s settings before launching the task.
   - Launch with to launch the task without changing the ticket’s settings.

Note:

If you don’t have the Tickets: Show All Tickets and their Parameters (Public and other) access right (see Access Rights in the Reference Guide), you will only see Launch with.

In this case, you can only select public tickets, and only fill in public parameters in the ticket.

4. Select the ticket to use.

- If you have launched tasks previously, the most recent task tickets you used are listed.

- If you didn’t, or if you need a different ticket, select More Tickets...

  In the Select Ticket dialog that opens, select the task ticket you want to use and click OK.
Note: This dialog contains all the tickets suitable for the file type you selected. You can choose either a Default ticket, or a custom ticket (saved under a different name) if you have already created one.

5. If:
   - You chose New Task, the task ticket opens. Fill in the settings you want to use in the ticket and click the Launch button.
• You chose Launch with and you have the Tickets: Show All Tickets and their Parameters (Public and other) access right, the task is launched on the file as soon as you selected the ticket. You don’t need to fill in any settings.

• You chose Launch with and you don’t have the Tickets: Show All Tickets and their Parameters (Public and other) access right, the task is launched on the file as soon as you selected the ticket if there are no public parameters. If the ticket contains public parameters, it will open for you to fill them in (you will only see the public parameters). Click Launch when you are done.
5.3 Checking the Status of the Task

After launching a task on one or several file(s), you can check its processing status in the Pilot's Tasks pane. You can see the Tasks pane in the Files, Product or Tasks views.

You can see the progress (in percentage) and the processing state. The state can be:

- starting
• ✔: success
• ⚠️: warning
• ❌: failure
• ☐: processing cancelled

You can also double-click the task entry in the Tasks pane to open your task ticket and check its parameters.

Note: Depending on your access rights, you may only see the public parameters.

5.4 Relaunching the Task

• To relaunch the task without changing the settings:
  a) Select the task to relaunch in the Tasks pane.
  b) Go to Tasks > Relaunch.

• To change the settings and relaunch the task:
  a) Select the task to relaunch in the Tasks pane.
  b) Go to Tasks > Open.
  c) Change the task settings as necessary.
  d) Click the Launch button.
6. Running Workflows on Files

6.1 Building Workflows

You can build workflows from zero or using custom tickets, you can migrate task chains to Automation Engine workflows, and create nested workflows.

You can also choose to have the prepress manager build workflows that operators will use, or let the operators build workflows on the fly while processing files.

6.1.1 Building a Workflow from Zero

1. Click in the Tickets view to open the workflow editor.

The workflow editor window only contains two steps by default (Start and OK).

2. Drag and drop your chosen steps from the workflow step list into the canvas.

**Note:** To find a step quickly, you can either use the step filter or the search field on top of the steps list.

3. If desired, double-click your steps’ names to rename them.
You will still be able to see the original name (the task type or workflow control type) by hovering on the step.

4. Connect your steps with one another.

   To do this, click a step’s green pin and drag it onto the next step. This links the two steps with a green tube.

   **Note:** You can connect a step’s output to several other steps. Automation Engine will automatically check the format of the files going through, and send them to the appropriate step(s) depending on it.
Tip: If you want to align your workflow steps on a grid, hold **Shift** while dragging them.

5. Double-click each step and fill in its parameters in the step ticket.
Edit Ticket of Export ArtPro to Normalized PDF File

Tools

Output in: [Blank]
File Name: [Blank]

Prefered Ink Book: designer

Search for missing images in: [Blank]

Embed all images
Add non-printable layers

Layer Mapping:

<table>
<thead>
<tr>
<th>Object</th>
<th>Server</th>
</tr>
</thead>
</table>

Add | Remove

OK
6. Save your workflow using either:
   - File > Save or Ctrl + S.
   - File > Save As... or Ctrl + Shift + S.

6.1.2 Building a Workflow using Custom Tickets

1. Click in the Tickets view to open the workflow editor.

2. Click the tickets button in the workflow editor’s toolbar to open the Ticket Browser pop-up.

3. Select the custom ticket you want to use and:

<table>
<thead>
<tr>
<th>Do...</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>drag the ticket into your workflow</td>
<td>use a copy of the original ticket.</td>
</tr>
<tr>
<td>hold Ctrl + Shift (on PC or Mac) or Cmd + Alt (on Mac only) and drag it into your workflow</td>
<td>link the original ticket to your workflow (you can see an arrow next to the ticket name).</td>
</tr>
</tbody>
</table>

   **Note:** Changes to the ticket settings will not be reflected in the original ticket.

   **Note:** Settings changed here will also be changed in the original ticket.

4. If desired, double-click your steps’ names to rename them.

5. Connect your steps with one another.

   **Note:** You can connect a step’s output to several other steps. Automation Engine will automatically check the format of the files going through, and send them to the appropriate step(s) depending on it.
Tip:
If you want to reuse part of an existing workflow, you can copy and paste it into your new workflow (using Ctrl + C and Ctrl + V or Edit > Copy and Edit > Paste). This keeps all of the steps’ settings.
You can also use nested workflows if you plan to reuse workflow parts several times (see Nested Workflows).

6. Save your workflow using either:
- File > Save or Ctrl + S.
- File > Save As... or Ctrl + Shift + S.

6.1.3 Reusing a Task Chain Ticket to Build a Workflow

Your old BackStage task chain tickets will still work in Automation Engine.
However, we recommend that you make full use of the new workflow editor’s extended capabilities. To do this, you can gradually migrate from using task chains to using workflows.

Important: You cannot automatically convert task chain tickets to workflow tickets, but you can preserve all your settings while migrating to workflow tickets.

1. In the Pilot’s Tickets view, search for the task chain ticket you want to convert.
2. Open the workflow editor.
3. Drag and drop your task chain ticket into the workflow editor window.
Tip: When dragging the ticket over the canvas, you will see a message telling you where to drop it.

Drop your chain here to extract all compatible steps...

This shows all the steps of your task chain in the canvas.
Note:

- Each step keeps all of its settings in its own ticket (you can double-click on a step to see its ticket).
- The steps are detached so you can optimize your workflow construction (the workflow editor enables you to build workflows in a more flexible and more efficient way than the task chains).
- Deprecated steps (as the Mark File step in the example below) will be displayed in red for three seconds, then disappear. You should replace them with the corresponding workflow controls (for example, replace Mark File by Mark). See Workflow Controls and Deprecated Steps.
4. Turn your existing steps into a workflow:
   a) add tickets or workflow controls if necessary (and fill in their settings),
   b) make sure you have replaced the deprecated steps,
   c) double-click your steps names to rename them if necessary,
   d) connect your steps together.
5. Save your workflow.

### 6.1.4 Nested Workflows

When you need to reuse a part of your workflow in several other workflows, you can make a subworkflow out of it.

You can then integrate this subworkflow as it is (with its settings etc.) in other workflows, creating nested workflows.

Working with nested workflows will also make your workflows look smaller and more streamlined, so you have a better overview of the current processing.

For example, the following workflow can be nested:
Here is the nested workflow:
with the first subworkflow:
and the second subworkflow:
Building a Nested Workflow

To add a subworkflow into your workflow:

1. In the workflow editor, drag the Workflow step into your workflow.
Tip: To find it quickly, select **Workflow** in the step list filter.

2. Double-click the workflow step.

   This shows a new workflow editor window, where you can build your subworkflow.
3. Build your subworkflow:
   a) drag and drop steps into the canvas,
   b) connect your steps with one another,
   c) double-click each step and fill in its parameters in the step ticket.

4. Click your main workflow to go back to it (click in the example).

5. Save your workflow.

**Note:** You can nest several layers of subworkflows.
6.1.5 Using Routing in Your Workflow

The workflow routes files automatically to OK, Warning or Error outputs depending on their processing status.

Within your workflow, you can also route files in different ways.

Simple Processing Routing

When building your workflow, you can use the green tubes to route your files to different workflow steps.

For example, you can use this to create an imposition and a WebCenter project based on your file at the same time.

Note: When a step’s output pin is connected to several other steps, Automation Engine will automatically check the format of the files going through, and send them to the appropriate step(s) depending on it.

Routing in Nested Workflows

When working with nested workflows, the end steps of your subworkflow correspond with the outputs of the workflow step in your main workflow.

For example, the subworkflow below has two OK end steps, named One Up and S & R.
In the main workflow, you can see that they correspond to the two green output pins of the workflow step.

This means that:
- files sent to the One Up step of your subworkflow will go through the One Up output in your main workflow (on to the Zip One Up step),
- files sent to the S & R step of your subworkflow will go through the S & R output in your main workflow (on to the Print S & R step).

Operator Routing

You can build your workflow so that operators will route your files based on their expertise. They will get a notification, and the processing will be paused until they decide where to send the file.

To use this in your workflow:

1. Add the Wait for Action (Checkpoint) step to your workflow.
2. Double-click the step to open its settings.
3. Create the notification that will be sent:
   a) choose which user you want to send it to,
   b) enter a Subject,
   c) add a Message if desired.

4. Choose a Due date. Either:
   - choose one of the predefined due dates (from Immediate to Next sunday),
   - choose Other... in the Due date list and pick the due date yourself.

5. In Output states, define the output possibilities you want for your checkpoint.
   By default, this step has two outputs: Completed and Aborted.
   To add an output:
a) click Add,
b) enter the output's name.

Add as many outputs as you like.

6. If necessary, use the Move Up and Move Down buttons to display your outputs in a different order.

Note: You can Remove the default outputs if you don’t need them.

7. If you want your file to be automatically sent through one of the outputs if no action is taken by the operator after a period of time:
   a) select Release automatically,
   b) enter the time delay after which the file should be released,
   c) choose the output to release the file to.

8. Click OK to apply your settings.

9. On your canvas, the Checkpoint step has the outputs you defined. Connect each output to the appropriate step.
Operators will be able to route files gone through the Checkpoint from the Pilot’s Tasks pane, the workflow editor, or Shuttle.

In the Pilot

In the Pilot, the operator will see User intervention needed in the Tasks list, and one To-Do.

---

Tasks

<table>
<thead>
<tr>
<th>Job Name</th>
<th>File Name</th>
<th>Task Type</th>
<th>Progress</th>
<th>Phase</th>
<th>State</th>
<th>Launch Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>ta_shu_Plugin_Set...</td>
<td>Wait for Action (Checkp...</td>
<td>0%</td>
<td>User intervention needed</td>
<td>11/02/10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ta_shu_Plugin_Set...</td>
<td>Trap - Prepare and Cre...</td>
<td>100%</td>
<td></td>
<td>✓ 11/02/10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ta_shu_Plugin_Set...</td>
<td>Normalize PostScript / P...</td>
<td>100%</td>
<td></td>
<td>✓ 11/02/10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ta_shu_Plugin_S...</td>
<td>Workflow</td>
<td>0%</td>
<td>Running</td>
<td>✓ 11/02/10</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

He/she can:

• Click either of these elements to route the file to one of the outputs defined in the Checkpoint step (and close the To-Do).

---

In the Workflow Editor

In the workflow editor, the operator will see User intervention needed as the file status and the Checkpoint step will jump up and down.
The workflow editor will also show one To-Do.

To route the file and close the To-Do, he/she can:

- Right-click the file icon and select one of the outputs defined in the Checkpoint step.

- or...
  
  a) right-click the file icon and select Open To-Do...
  
  b) select one of the outputs defined in the Checkpoint step.
a) click the To-Do icon, 
b) select Checkpoint Actions in the Actions Filter list, 
c) select one of the outputs defined in the Checkpoint step.

In Shuttle

Note:
The user name you used in the Checkpoint step settings and the user name your operator uses in Shuttle (to connect to Automation Engine) must match.

If they don’t, your operator can still see the file(s) to route, but only in Shuttle’s Show All mode.

For more details, please see the Shuttle manual.

In the Shuttle window, the operator will see an icon indicating that the file needs attention.

<table>
<thead>
<tr>
<th>Name</th>
<th>Workflow</th>
<th>Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Box 10.pdf</td>
<td>Checkpoint</td>
<td>Workflow</td>
</tr>
<tr>
<td>Box 10.pdf</td>
<td>Wait for Action (Checkpoint)</td>
<td>Wait for Action (Checkpoint)</td>
</tr>
<tr>
<td>Box 10.pdf</td>
<td>Trap – Prepare and Create Traps</td>
<td>Trap – Prepare and Create Traps</td>
</tr>
<tr>
<td>Box 10.pdf</td>
<td>Normalize PostScript / PDF /...</td>
<td>Normalize PostScript / PDF /...</td>
</tr>
</tbody>
</table>

Note: This icon is not on the workflow level, but at the Checkpoint step level. Clicking shows the workflow steps.

The Inspector panel also shows an attention icon, and the notification defined in the Checkpoint step.

To route the file (and close the To-Do in Automation Engine), the operator can:

• In the Shuttle processing list:
  a) right-click the file or the attention icon and select Attention in the context menu.
This shows the notification and output states set in the Checkpoint step.
b) Select one of the output states to route the file.

- In the Inspector panel:
  a) Select the step in the processing list to show the notification set in the Checkpoint step.
  b) Click and select one of the output states to route the file.

Automatic Routing

You can use the Router workflow control to route your files automatically.

In the Router's settings, you can choose to automatically route your files based on certain criteria (the file type, the number of separations, the value of a job parameter...).

Files matching your chosen criteria will automatically be sent through the corresponding output.
For example, you can route files on their file type...

... and send each file type to a different step in the workflow.
In the example above, ArtPro files and PDF files are each routed to their own normalization step, while Normalized PDF files are sent directly to the Trap step.

For more information about the routing criteria, please see the Automation Engine Reference Manual.

6.1.6 Using Public Parameters

Public parameters are ticket parameters that operators can define when submitting files through Shuttle.

For each public parameter, you can either:
- enter a list of predefined values the operator will choose from,
- let the operator enter a value himself.

Making a Parameter Public

**Note:** You need to define which parameters are public before files are submitted to your workflow.

In the ticket containing the parameter to make public:

1. Right-click the parameter and select **Make Parameter Public**.
2. Right-click it again and select **Modify Public Parameter**...
3. In the **Modify Public Parameter** dialog that opens:
   a) If necessary, change the way the parameter will be called in Shuttle in Prompt as.
   b) Choose either:
      - **Allow the user to set the value** if you want Shuttle users to be able to freely enter a value for that parameter.
• **Let the user select a predefined value** if you want Shuttle users to choose from a list of values that you define.

If that parameter already has a list of values to choose from in the Ticket, they will be displayed here. You can Add or Remove values.

**Note:** Shuttle operators will see (and choose from) the *Predefined Settings* but not the associated *Values*.

c) If you have chosen **Let the user select a predefined value** in Default Predefined Setting, choose the setting that will be selected by default when submitting files from Shuttle (if the operator doesn’t select another setting, this one will be used for processing).

4. Don’t forget to save your ticket.

This is how your public parameter will look to Shuttle operators:
Managing Public Parameters in Your Workflow

Once you have made parameters public in your workflow steps’ tickets, you can have an overview of your public parameters and edit them at the workflow level.

1. In the workflow editor, go to Advanced > Manage Public Parameters...

   The Manage Public Parameters dialog that opens contains all of your workflow’s public parameters, sorted by workflow step.
The right pane shows the workflow steps for which you have made parameters public.

The middle pane shows the public parameters for the selected workflow step.

The left pane shows all the parameters you have made public, with their settings (predefined values, etc.).

2. You can:
• drag parameters from right to left to make them public;
• click a public parameter's cross \( \times \) if you don't want it to be public anymore;
• rearrange the order of your public parameters (drag them up or down);
• change public parameters’ settings (Prompt as, Predefined Settings, etc.);
• group public parameters under a header (click Add Group, click \( \text{Edit} \) to edit the header, and drag parameters from the right);

Using Presets to Simplify Operators’ Choices

You can use presets to minimize the amount of public parameters your operators have to choose from, and make it simpler for them.
For example, you want operators to use different trapping settings for printing with offset or dry offset. You can define those trapping settings in a preset, so that operators will only have to choose between offset and dry offset.

In the Manage Public Parameters dialog:

1. Click the Add Preset button.
2. Enter what your operators will see:
   a) in Prompt as, enter the name to give the preset parameter in Shuttle,
   b) enter the values that operators will choose from (replacing Type a value here).

   Click Add if you need to add extra values.

3. Drag parameters from the dialog’s left pane into the preset.

   You can drag as many parameters as you want. They will appear under each value (here both under Offset and Dry Offset).
4. Define the parameters values for each preset value.

For example, define normal trapping, 50% opacity and object dependant end caps for Offset, and reverse trapping, 100% opacity and round end caps for Dry Offset.

5. Don’t forget to save your ticket.

This is how your preset will look to Shuttle operators:

Checking All the Workflow’s Public Parameters Values

You can quickly check the public parameters’ values for your whole workflow, without having to go into each workflow step ticket.

You can do this for the default public parameters’ values saved in your workflow ticket, or the public parameter values passed on to your workflow when running a file.
1. In the workflow editor, go to Advanced > Modify Public Parameter Values...

The Modify Public Parameter Values dialog that opens contains all of your workflow’s public parameter values, sorted by workflow step.

![Modify Public Parameter Values](image)

The right pane shows the workflow steps containing public parameters, and the left pane shows the parameter values.

2. Check and edit the values if necessary, and click OK.

Making Your Ticket Public

**Important**: With Shuttle, you can submit files to any Automation Engine task, task chain or workflow that has a custom ticket. To do this, you need to make the ticket public.

You can either:

- Select the Public option when creating the ticket.

![Save As](image)

- Select your ticket in the Ticket view, click ![info](image) and select Public.
• Right-click your ticket in the Ticket view and select Public Ticket.

**Note:** Public tickets have a mark in the Public column.

<table>
<thead>
<tr>
<th>Task Type</th>
<th>Ticket Name</th>
<th>Public</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zip</td>
<td>Default</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>XCL_Accord</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Workflow_RunLists</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zip</td>
<td>Trap</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Trap_nestedPDF</td>
<td>✔</td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>SendPDFtoDec</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**SmartNames in Public Parameters**

You can use SmartNames in your public parameters (for parameters taking SmartNames as input). In Shuttle, use square brackets around SmartNames when submitting a file with public parameters.
6.1.7 Adding Sticky Notes to Your Workflow

If you want to give additional information to the operators using your workflow, you can add sticky notes to it.

To do this, right-click your workflow background and select Add Sticky Note. This creates an empty sticky note where you right-clicked.

To enter text, click 📝 and enter your text. When you are done, click ✓.

You can move the sticky note on the workflow canvas, or resize it by dragging its bottom right corner.

If you want to delete the sticky note, click 🗑.

To hide all of your workflow’s sticky notes, go to View > Hide Sticky Notes. To show them again, go to View > Show Sticky Notes.
6.1.8 Checking All the Workflow's Parameters

You can use the **Parameter Inspector** to quickly go over all your parameters, without having to go into each workflow step ticket.

1. Right-click any workflow step (task or workflow control) and select **Show Parameter Inspector**...

2. The left column shows all of the workflow steps in alphabetical order. Click the task / workflow control whose parameter you want to see. The parameters are shown at right.

3. Change the parameters as you wish. Your changes are applied instantly in the workflow.

4. If you want, you can also:
   - Save the parameters of the task you just edited as a new ticket (using **Save As**...).
   - Edit that task’s public parameters (using **Manage Public Parameters**...).

   See **Using Public Parameters** on page 62 for details on how to use public parameters.

5. Close the **Parameter Inspector** when you are done.
6.2 Using Workflows

After launching a workflow on your file, you can check its processing status, pause the workflow, or relaunch your workflow with different settings.

6.2.1 Launching a Workflow on a File

There are several ways to launch a workflow on a file (from the Pilot, from Shuttle, via Hot Folders or via JDF/JMF). Here is how to launch a workflow from the Pilot’s Files View.

1. In the Files view, right-click the file(s) to process and select either:
   - **New Task** to fill in the workflow’s settings before launching it.
   - **Launch with** to launch the workflow without changing its settings.

   **Note:**
   If you don’t have the Tickets: Show All Tickets and their Parameters (Public and other) access right (see Access Rights in the Reference Guide), you will only see Launch with.
   In this case, you can only select public workflow tickets, and only fill in public parameters for the workflow.

2. Select the workflow ticket to use.
   - If you have launched workflows previously, the most recent workflow tickets you used are listed under Workflow.
   - If you didn’t, or if you need a different ticket, select More Tickets...

   In the Select Ticket dialog that opens, select the workflow ticket you want to use and click OK.
Tip: Workflow tickets have Workflow as task type. You can use the search field in the Select Ticket dialog to find them easily.

3. If:

- You chose New Task, the workflow editor window opens. Fill in the settings you want to use in each workflow step and click the Launch button.

  Tip: Hold Alt while clicking Launch to keep the workflow editor window open to monitor your workflow (the Launch button shows an eye).

- You chose Launch with and you have the Tickets: Show All Tickets and their Parameters (Public and other) access right, the workflow is launched on the file as soon as you selected the workflow ticket. You don’t need to fill in any settings.

- You chose Launch with and you don’t have the Tickets: Show All Tickets and their Parameters (Public and other) access right, the workflow is launched on the file as soon as you selected the workflow ticket if there are no public parameters.

  If the ticket contains public parameters, it will open for you to fill them in (you will only see the public parameters). Click the Launch button when you are done.
You can monitor the workflow’s progress in the Files View’s Task pane or in the Tasks View. See Checking the Workflow’s Processing Status on page 117.

Note: If you send files linked to several jobs to the same workflow at the same time (for example when using the Files view and Shuttle or a Hot Folder), a separate workflow will be started for each job context.

6.2.2 Building a Workflow and Launching it on a File on the Fly

You can build and use workflows at once or separately, depending on who in your company performs it.

- If you want to keep workflow creation and workflow use separated, the Prepress Manager can create workflows in the Tickets view, then Prepress Operators can launch them on files in the Files view.
- If you prefer your users to be able to create and launch workflows on the fly, they can do it all from the Files view:

1. In the Files view, select the file(s) you want to launch your workflow on.
2. Click to open the workflow editor.
3. Build your workflow as described previously (see *Building a Workflow from Zero*, *Building a Workflow using Custom Tickets*, *Reusing a Task Chain Ticket to Build a Workflow*, *Building a Nested Workflow*).

**Note:**

Save your workflow if you want to be able to reuse it later.

Any settings change you make after saving your workflow will only be used on this file and not saved in the ticket.

4. Click the Launch button.

**Tip:** Hold **Alt** while clicking Launch to keep the workflow editor window open to monitor your workflow (the Launch button shows an eye).

### 6.2.3 Pausing or Cancelling Your Workflow

While monitoring your file's progress in the workflow editor window, you can:

- click **pause** to pause your workflow (at the end of the task currently running),
- click **play** to make your workflow run again,
- click **stop** to cancel your workflow’s processing.
6.3 Checking the Workflow’s Processing Status

In the Pilot’s Tasks Pane

After launching a workflow on one or several file(s), you can check the processing status in the Pilot’s Tasks pane. You can see the Tasks pane in the Files, Product or Tasks views.

<table>
<thead>
<tr>
<th>File Name</th>
<th>Task Type</th>
<th>Progress</th>
<th>Phase</th>
<th>State</th>
<th>Launch</th>
</tr>
</thead>
<tbody>
<tr>
<td>testLinks.pdf</td>
<td>Workflow</td>
<td>100%</td>
<td></td>
<td></td>
<td>22/12</td>
</tr>
</tbody>
</table>

You can see the progress (in percentage) and the processing state. The state can be:

- ⌚: starting
- ✅: success
- 🚨: warning
- ❌: failure
- 🔴: processing cancelled

In the Workflow Editor

Double-click the Workflow entry in the Pilot’s Tasks pane to open your workflow in the workflow editor.
You can see your file(s) going from task to task, with the status displayed in blue.

**Note:** The file icon can represent a single file or a collection of related files, depending on your workflow step’s output.

Each task or workflow control indicates the number of files ran successfully (in green) or with an error (in red) through it.
You can also:

- Open a processed file in the Tasks view: right-click the file (if it is still being processed) or the step output widget (if processing is finished) and select Show in Tasks View.
- Open the output of a step in the Files view: right-click the step's output widget and select Show in Files View.
- Check all public parameter values used in this workflow: go to Advanced > Modify Public Parameter Values... (see Checking All the Workflow's Public Parameters Values for details).
- See Details (stranded files...) by clicking .
- See the To-Do list (Checkpoints, Milestone Actions...) associated with the workflow by clicking .

### 6.4 Re-launching Your Workflow with Different Settings

1. Double-click the Workflow entry in the Pilot's Tasks pane to open your workflow in the workflow editor.

2. In the workflow editor window, double-click the task(s) you want to edit and change the settings as necessary.

   **Note:** Save the workflow if you want to keep the new settings in the ticket.

3. Click Launch .
7. Viewing Files in the Automation Engine Viewer

7.1 About the Viewer

What is the Automation Engine Viewer?
The Automation Engine Viewer is a comprehensive, powerful and integrated Viewer and QA tool. It can easily be integrated in your Automation Engine workflow, to view, check and compare graphic production data.

It can be launched directly from within the Automation Engine Pilot, on any Macintosh or Windows PC in your network. Anywhere you can install and log on to an Automation Engine Pilot you can start the Automation Engine Viewer (DTP, prepress, QA department, CSR desk...).

You can use as many Automation Engine Viewers as you have Automation Engine Pilot connections. Opening the Automation Engine Viewer does not allocate an extra Pilot connection.

It is even possible to have two or more Automation Engine Viewers on one workstation by opening a second Automation Engine Pilot (Pilot - File menu - New window) and opening a file in the Automation Engine Viewer from there.

If you are an Esko Bitmap Viewer user, you will notice that the interface and shortcuts are nearly identical.

What does the Viewer offer you?
- Reliability: Showing the data in a correct way. At best in the same way the RIP / Proofer will see them.
- Detail: Unlimited zoom, high detail measuring, measuring traps and exact distances (die objects).
- Speed: Opening files swiftly, even when it concerns large files. Fast zooming.

Prepared View Data
Reliability is a must. Detail can also not be compromised, it is always offered. The challenge lies in opening very large files quickly. That is why the Automation Engine Viewer offers 2 view modes: with or without Prepared View Data.

- In case you do not prepare View Data, the server will stream the data to the Automation Engine Viewer. When a large file has to be opened or compared or when the server is very busy, a delay can be noticed. Deep zoom detail mode is immediately available.
- In case you do opt to prepare View Data in advance, then the Viewer will show you the prepared View Data instantly. Zooming in will of course require object data streaming from the server, but then for a smaller area.

For more information about creating View Data, see Prepare for Viewer (in the Automation Engine Reference Manual).
7.2 Checking the Result in the Viewer

The Automation Engine Viewer can open different file types (PDF, AI, PSD...). For a full list, see Supported File Types in the Reference Manual.

In the Files view, do one of the following:

- Click the word View next to your file.
- Right-click your file and select View...
- Select your file and go to File > View.

<table>
<thead>
<tr>
<th>Name</th>
<th>View</th>
<th>Type</th>
<th>Size</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Celebrity pdf</td>
<td>View</td>
<td>PDF File</td>
<td>41MB</td>
<td>07/04/10...</td>
</tr>
<tr>
<td>CMYK pdf</td>
<td>View</td>
<td>Normalized</td>
<td>32KB</td>
<td>05/01/10...</td>
</tr>
<tr>
<td>Daily_May pdf</td>
<td>View</td>
<td>PDF File</td>
<td>23KB</td>
<td>08/04/10...</td>
</tr>
</tbody>
</table>
You can now zoom in on the file, measure distances and densities, view separations individually or together, etc.
7.3 Comparing Files

The Automation Engine Viewer is not only a powerful viewing tool, but also holds a strong compare tool. It is an ideal way to compare two files and have a close look at the differences, if needed per separation, including changes in images (internal or referenced images).
While comparing you can use other tools like for example "view separations in separate windows", measure, (de)select, rotate, etc...
8. Integration with Other Applications

8.1 Integration with WebCenter

With the Approval Workflow, you can send documents to be approved from Automation Engine to WebCenter, approve them in WebCenter and see the results back in your Pilot.

This allows you to collaborate with your colleagues and customers for maximum efficiency and minimum error.

8.1.1 WebCenter Setup

In WebCenter, you need to set up a Project Template with Approvers.

You will use this template in Automation Engine when sending impositions: it will allow you to create new WebCenter Projects (already containing your Approvers) as needed, directly from Automation Engine.

Note: Alternatively, you can set up a WebCenter Project with Approvers in WebCenter, and send your impositions to it from Automation Engine. But then you will only be able to create new Projects from WebCenter and not from Automation Engine.

1. Create a new Project.
2. Add Members to the project.
3. Choose Approvers from within the Project’s members.
4. Save the Project as a Template.

Creating a New Project

1. Log in to WebCenter as a user who is a Project Manager.
2. Click Projects.
   The Favorite Projects page is shown.
3. Click Create a New Project at the top right of the page.
4. Choose Start from a Blank Project and click Continue.
5. Enter the name for the Project in the Project Name field.
   • To make another user or user group the Project Manager for this project, select his or her name, or the group name, from the Project Manager list.
   • If desired, enter a description in the Description field.
   • To make the Project active, leave the Status as Active.
To specify an optional due date, click the calendar control at the end of the Due On field and select the desired due date. To set the due time, click the drop-down list box to the right of the calendar control.

**Note:** This is not the Approval Due Date. You will set the Approval Due Date when setting the Approval Cycle.

To use a custom thumbnail, click Specify New Thumbnail and enter the complete path and filename in the associated field or Browse for it. To use the default thumbnail, leave that choice selected.

6. Click Finish.

The Project is created.
Adding Members to a Project

1. Once the project is created, click the *Invite members* link.

2. Select the users or groups to add as members and click *Continue*.

The project was successfully created!

- Review General Info
- Define attributes
- Upload a document
- Add tasks
- Add a folder
- **Invite members**
- Create another project

This shows a list of the current WebCenter members.
3. Set the members’ permissions as desired. For Approval tasks, members need at least View permissions (selected by default).

**Note:** The permissions you set here apply to all members you have just added.

4. Click Finish.

5. Once the members are added, click Go back to the project.
Adding Approvers to the Project

Approvers can be either regular users or they can be user groups.

When you add a group as an approver, you must indicate whether:

- all the members of the group (select the group entry labeled as whole group) must approve the document before it gets the approved status, or
- whether the approval of a single group member (select the group entry labeled as one of group) will set the document to approved status.

**Note:** You can only change (add or remove) Approvers when the Approval Cycle is stopped.

1. In the Project Page, click Approvers.
2. Click Add / Delete Approvers.
3. From the Project Members list, select the individual users or the groups you want to add.
   
   **Tip:** Use Ctrl+Click to select multiple members.
4. Click the >> button to add the selected members to the Approvers list.
Note: The Project Manager is not automatically made an Approval User and must be explicitly added to the list of Approvers.

5. Click **Change** to add the selected Approvers to the Project.

Saving a Project as a Template

**Note:** To save a Project as a Template, you need have Administrator permissions.

1. If the user you are logged in with is not an Administrator:
   a) Log out.
   b) Log back in with an Administrator user.
c) Go back to your Project page.

2. In the Project Actions menu on the right, click **Save as Template**.

3. Enter the **Template Name** (different from your **Project Name**) and a **Description**.

   To use a custom thumbnail, click **Specify New Thumbnail** and enter the complete path and filename in the associated field or **Browse** for it. To use the default thumbnail, leave that choice selected.
Create a new template from project

Template name, description and thumbnail

Type in the template’s name and description and select a thumbnail.

Template Name: * Impositions Approval Template
Tip: (* indicates required field)

Approval Template for FastImpose impositions sent from BackStage

Description:

4. Click Finish.
   The Template is created.

8.1.2 Automation Engine Setup

1. In the Automation Engine Pilot, go to Tools > Configure.
2. In the left panel, select Webcenter Sites at the bottom of the list.
3. Go to File > New or use the Insert key (on Windows only).
4. Enter your WebCenter server address in Website.

   **Note:** You can use the Open button to open your WebCenter website.

5. Check if your Webcenter and your Automation Engine servers are on the same Local Area Network:
   - If they are, enable Webcenter and Automation Engine are in the same LAN,

   **Note:** Your Webcenter and Automation Engine servers must be on the same Local Area Network to be able to use the page list approval feature in WebCenter.
• If they are not, enter the **Automation Engine Approval Client’s Name and Password**.

**Note:** The Name and Password you enter here must match the Workflow Approval Client’s Name and Password specified in WebCenter by the WebCenter administrator.

6. Use the **Check Connection** button to check that your Automation Engine server is now connected to your Webcenter server.

7. If you plan to send individual documents as well as impositions to your WebCenter server, fill in the parameters in the **Connect to JDF Processor** area.

   • To connect via Hot Folders, select **Hot Folders** and define an **Upload Folder** and a **Download Folder**.
   • To connect through JMF, select **JMF**. The **URL** of your JDF Processor is filled in by default.

**Note:** You can use the **Check** button to check that the JMF connection is successful.

8. In the left panel, select the WebCenter connection you have just set up and click on it to rename it. You can also use **File > Rename** or **F12** (on Windows).

9. Go to **File > Save** to save your WebCenter connection. You can also use **Ctrl + S** on Windows or **Command + S** on Mac.

**Note:** To remove a WebCenter connection, select it in the left panel and go to **File > Delete** or use the **Delete** key.

### 8.1.3 Sending an Imposition from Automation Engine to WebCenter

#### Preparing the Imposition

1. In the **Files** view, browse to the FastImpose imposition file (***.imp**) you want to upload.

**Note:** The imposition file must be part of a job.

2. Right-click it and select **Add to Imposition Gallery** from the context menu.

When you switch to the **Pages** view, you can see your file in the **Imposition Gallery**.
3. If the imposition doesn’t show the pages preview (as in the example above), add them this way:
   a) Click on the first page’s file name in the Page Gallery. This shows the page’s preview in the Details area at right.
   b) Drag this preview onto the first page of the imposition in the Page list area.
   c) Repeat this for the other pages of your imposition.
Sending the Imposition to WebCenter

If your imposition contains several books, you must send the books one by one to WebCenter. Each book will be shown as a Page List in WebCenter.

1. In the Imposition Gallery, right-click the imposition (or the book) and select New Task > Prepare Imposition for WebCenter Workflow.

   If the Prepare Imposition for WebCenter Workflow task does not appear in the context menu, choose More Tickets and select the task in the Select Ticket dialog.

2. Modify the settings of the Prepare Imposition for WebCenter step (the first step in the chain) if needed.

3. In the Send Imposition to WebCenter step, modify the settings of the Destination tab (you can use SmartNames where indicated by the SmartNames button):
   a) Select your WebCenter Site from the list.
   b) Enter the name to give to your Project. Automation Engine will create this project in WebCenter, from the Project Template you specify below.
Note: You can also send your imposition to a Project already existing in WebCenter. In that case, you don’t need to enter a Project Template. Note that this Project must have Approvers defined in WebCenter.

c) If you want to send your imposition to a subfolder in the project, enter that Folder's name. If this folder doesn’t exist in the template (or project), Automation Engine will create it.

d) Enter the name to give to your imposition Document. This is the name that will be shown in WebCenter. For example you can use [ImpositionName][BookName][LayerName].

e) Enter the Project Template to use to create your WebCenter project.

Important: This Project Template must be defined in WebCenter. See WebCenter Setup.

f) Enter the User Name and Password used to connect to your WebCenter site. You can use an Encrypted password or SmartNames.
4. Modify the settings of the Approval tab:
   a) Enable Start the Approval Cycle.
   b) Select a Due date and time.
5. Click the Launch button in the top left corner to upload the imposition to WebCenter.

**Note:**
If you don’t start the Approval Cycle from Automation Engine, you will still be able to start it from WebCenter, and view the approval results in Automation Engine.
For more information, see the WebCenter manual.

### 8.1.4 Approving the Imposition in WebCenter

In WebCenter 7.1, you can:

- Approve / reject documents sent from Odystar, Nexus or Automation Engine as regular documents (see Approving a Document).
- Approve / reject documents FastImpose impositions added to the Pages View in Automation Engine as regular documents or Page Lists (see About Page Lists and Approving a Page List).

When approving a Page List, you can:

- Approve / reject not only the whole multipage imposition but each individual page.
- Update and have version control not only on the whole multipage imposition but on each individual page.

**Note:** Only FastImpose impositions that have been added to the Pages View in Automation Engine are recognized as Page Lists in WebCenter. Multipage files uploaded from within WebCenter, or from Odystar, Nexus, or even other Automation Engine documents will never be treated as Page Lists. Instead, they are considered regular multipage PDF documents.
When approving a Document, you can:

- If you are an Approval User: Approve the document, Reject it, or leave it Pending to approve / reject it in the future.
- If you are a Project Manager: Approve or Reject the document, leave it Pending, or Force Approve / Force Reject it if you need to overrule the approval status granted by the approval users.

Note:
For more information about Forced Approval or Rejection, see the WebCenter manual.

Approving a Document

Documents waiting for your approval are shown on My To Do List under My Work. If you are an Approval User, do the following to Approve or Reject a document:

Note:
You can also approve or reject documents in the Viewer.

1. Click Approve/Reject at the end of the Approval field in the document header.

Document - dollyBook 1

- **Document:** dollyBook 1 (3.7KB)
- **Pages:** 4
- **Version:** 1
- **Binding:** Left Edge
- **Description:**
- **Project:** Imposition Mr Chen 110409
- **Approval:** Cycle Started - Status Pending Approve/Reject

2. Choose the desired Approval Status from the drop-down list: Approved indicates approval; Pending indicates future Approval or Rejection, and Rejected indicates disapproval.

3. Once you choose Approved or Rejected, you may not change the status later; a view-only version of the page will be shown showing the choice you picked. Only a Pending status allows future changes.

   If desired, you can add a comment in the Comment field. Submitted approvals and comments are shown on the Action History page.

4. Click Finish to change the status of the document.
   
   To cancel the changes, navigate to another page without clicking Finish.

About Page Lists

**What is a Page List document?**

Page Lists are a special type of multipage PDF documents in WebCenter that represent imposed books or magazines. As such they are an important tool for commercial printers.
Page Lists are uploaded from a Automation Engine production server using the **Pages View** in the Automation Engine Pilot.

**Note:** Only **FastImpose** impositions that have been added to the **Pages View** in Automation Engine are recognized as **Page Lists** in WebCenter. Multipage files uploaded from within WebCenter, or from Odystar, Nexus, or even other Automation Engine documents will never be treated as Page Lists. Instead, they are considered regular multipage PDF documents.

Page List documents have two major advantages over other multipage PDF files:

- You can **upload either the complete document, or specific pages** only (for example, pages 6-12);
- **individual pages can be approved or rejected** in WebCenter (for example, you can approve pages 3, 5 and 7-16 of a 16-page Page List).

**Note:** A multipage PDF file can only be approved or rejected as a whole.

### Working with Page Lists

Page List documents are displayed as a single document in document lists. Click the Page List name to view its pages and details in the dedicated Page List views.

**Note:** Page Lists cannot be downloaded.

### Approving a Page List

In order to approve your imposition as a Page List in WebCenter, you need to first login to WebCenter as an approver, then navigate to the document (Page List) to approve, in the project created from Automation Engine.

You can also access this Page List from the link in the approval notification email, if you received one.

Make sure you have the correct permissions to approve documents in WebCenter. For more information, please see your WebCenter manual.

You can choose from a number of different methods to approve the pages in a Page List:

- **Use the WebCenter Viewer:**
  a) In the Project, click on the Page List's thumbnail image. The **Viewer** opens, displaying the Page List.
  b) In the **Approval** area in the sidebar on the right of the Viewer window, select the appropriate approval state (Approved, Rejected, Pending) from the list.

  The **Approval** dialog opens in which you can add approval comments.
c) Enter your comments, provide your password if required and click Commit.

Note: You can approve / reject one page at a time, or all of the document’s pages (using Apply to all pages).

• Use the Page Gallery view:
  a) In the Project, click on the Page List’s name.
     The Document Details page appears.
  b) Select Page Gallery from the menu.
  c) Select the pages you want to approve and then click Approve/Reject. You can also use Approve/Reject all Pages.

d) Enter your comments, provide your password if required and click Commit.
• Use the Page List view:
  a) In the Project, click on the Page List’s name.
     The Document Details page appears.
  b) Select Page List from the menu.
  c) Select the pages you want to approve and then select Approve/Reject from the gearbox menu.
     You can also use Approve/Reject all Pages.

<table>
<thead>
<tr>
<th>Status</th>
<th>Index</th>
<th>Folio</th>
<th>Sheet Name</th>
<th>View</th>
<th>Page Version</th>
<th>List Version</th>
<th>Uploaded Date</th>
<th>Approve/Reject</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
<td>1</td>
<td>sheet1</td>
<td>2</td>
<td>1</td>
<td>1</td>
<td>Apr 10, 2009 3:10 PM</td>
<td></td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>2</td>
<td>sheet1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>Apr 10, 2009 3:10 PM</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>3</td>
<td>sheet1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>Apr 10, 2009 3:10 PM</td>
<td></td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>4</td>
<td>sheet1</td>
<td>2</td>
<td>1</td>
<td>1</td>
<td>Apr 10, 2009 3:10 PM</td>
<td></td>
</tr>
</tbody>
</table>

- d) Enter your comments, provide your password if required and click Commit.
- • Use the Approve/Reject link on the Document properties page to approve all the pages at once.

**Document - dollyBook 1**

- **Document:** dollyBook 1
- **Pages:** 4
- **Version:** 1
- **Binding:** Left Edge
- **Description:**
- **Project:** Imposition MrChen 110403
- **Approval:** Cycle Started - Status pending

**Approve/Reject**
8.1.5 Checking the Approval Results in Automation Engine

- To view the status of documents in a WebCenter Approval Cycle in Automation Engine, you can use either:
  - the Pages View,
  - the Proofs View,
  - the WebCenter View.

**In the Pages and Proofs Views**

- Go to the Pages or Proofs View to view the approval status of each page of the imposition.
  - In the Pages View:
    - In the Proofs View:
Note:
When you try to expose a sheet that contains a rejected page, you will get an error in the Expose task and an error status in the Plates View.
If you really need to expose the sheet anyway, you can overrule the WebCenter approval status from Automation Engine (see Overruling the WebCenter Approval).

In the WebCenter View
In the WebCenter View, you can view the approval status of the whole imposition.

Important: You need to first set up the WebCenter View before you can view all the approved / rejected documents in the WebCenter project you created.

1. Right click the WebCenter View’s background and choose Configure.
2. Enter the URL of your WebCenter site.
3. Enter the User name and Password used to connect to your WebCenter site.
4. In Project Name, enter the name of the WebCenter project you sent your imposition to. You can use SmartNames.

Important: Make sure this matches the Project Name of the project you created (or used) when sending your imposition from Automation Engine to WebCenter. See Sending the Imposition to WebCenter.

5. To check that the information you entered is correct and that the WebCenter server is running, click the Retry Connection button at the bottom of the view.

You can also use the link at the top of the view to open the web page of the WebCenter project.
6. Once you have checked that your configuration is correct, use the Save to Configuration button to save it.
8. Once it is saved, you will be able to return to this configuration using the **Load from Configuration** button after any unwanted change.

7. Click the **Show Documents** button to view the documents in your WebCenter project.
Note: If at least one page of the imposition is rejected, the status of the whole imposition is Rejected.

Possible Document Statuses

<table>
<thead>
<tr>
<th>This icon...</th>
<th>means that...</th>
</tr>
</thead>
</table>
| ![Image](image.png) | the page and the original imposition layout have been approved by all approvers.  
  **Note:** The imposition layout can be approved even if some of its pages are rejected. |
| ![Image](image.png) | the page has been approved by all approvers, but it may have changed the imposition layout, which needs to be checked (for example for a new page replacing a rejected one). |
| ![Image](image.png) | the page or the whole imposition has been rejected by at least one approver. |
| ![Image](image.png) | the page or the whole imposition has yet to be approved or rejected by at least one approver. |
When you hover on the top of a page in the Pages or Proofs View, you can see:

- the approval status,
- any comment entered,
- the date and time of the approval,
- the WebCenter user who approved/rejected the page.

8.1.6 Overruling the WebCenter Approval

After your imposition has been approved or rejected in WebCenter, you can still overrule the approval status of some of the pages in Automation Engine, if necessary.

1. In Automation Engine Pilot, go to either the Pages or the Proofs View and locate your imposition document.
2. You can either:
   - Select a page of your document and use the and buttons in the View’s toolbar to approve/reject the document without entering a comment.
   - Right-click on a page of your document and choose Approve/Reject... to open the Approve/Reject dialog where you can enter a comment.
3. In the Approve/Reject dialog, select Manual as Approval Type.
4. Choose to either:
   - Approve,
   - Approve with warning,
   - Reject the document.

5. Enter a Comment if you wish and click OK.

Note: You can hover on the top of a page to view approval information, whether it has been approved/rejected automatically in WebCenter, or manually in Automation Engine.

### 8.2 Integration with Nexus

**Why run Nexus workflows from the Automation Engine Pilot?**

You can use all the power of Nexus workflows from within a Automation Engine Job. This allows you to bring both Automation Engine and Nexus workflows in line, running them from within a single controlling environment: the Automation Engine Pilot.

**How does it work?**

The Send to Nexus ticket gives you access to the workflows that are available on a specific Nexus server.
Any public parameters that have been defined in the Nexus workflow (NeXML) will show up on the Send to Nexus ticket in Automation Engine. In addition, these public parameters are SmartName-enabled, so you can use Job metadata to drive the Nexus workflows.

On the Nexus side the Copy to BackStage activity allows you to set up workflows that send their resulting files back to Automation Engine.

Behind the scenes, Automation Engine and Nexus communicate via the SOAP protocol, exchanging files and notifying each of other of their progress.

**NeXML**

Setting up public parameters in Nexus requires knowledge of NeXML. Please refer to the NeXML Manual for more information.

### 8.2.1 Setup on the Nexus Side

To enable the Automation Engine Pilot to launch Nexus workflows, you must perform a number of setup tasks on the Nexus server.

#### Mounting Your Containers on the Nexus Server

The Automation Engine containers have to be mounted on the Nexus server.

- If the Nexus server runs on a Windows OS, the container should be mapped to a drive letter on the operating system.
- If the Nexus server runs on a Mac OS, the container has to be mounted over the SMB protocol.

#### Setting up the Nexus SOAP Server and Workflows

1. In the Modules list, double-click the NexusSoapServer module.
2. Enter a port number in the Listening Port field of the NexusSoapServer Module Defaults dialog, and click OK.

   The Nexus SOAP server is now active.

   **Note:**

   The option User Management, which determines the workflows that a particular user can access, is ignored by the Automation Engine Pilot. As a result, Automation Engine Pilot operators automatically have access to all Nexus workflows.

3. Create valid Nexus workflows with the Input Type: Hot Folder.
4. Configure the Hot Folder queues for the workflows. Make sure the option Show in Shuttle is selected.

   Only Hot Folders that have Show in Shuttle enabled are published to the Nexus SOAP server and become accessible to the Automation Engine Pilot.

5. Create the workflows with the Nexus Workflow Editor.
6. Make sure you add the Copy to BackStage activity at the end of the workflow.
Your Nexus workflow is now available for use with the Automation Engine Pilot.

### 8.2.2 Setup on the Automation Engine Side

1. In the Pilot, go to Tools > Configure and select the Nexus category.
2. Click File > New.
3. Enter the name of the Nexus server in the Host field.
4. Enter the Port on which the Nexus server is accessible.
5. Click Test Connection to verify the settings you entered.

**Note:** You can also test whether the Nexus SoapServer is online by browsing to the following url in your favorite web browser: `http://NexusServerName:5182`.

### 8.2.3 Running a Nexus Workflow from the Pilot

To run a Nexus workflow from within the Automation Engine Pilot, you can use the Send to Nexus ticket.

Additional integration features allow you to check the progress of the workflow in the Automation Engine Task Monitor, to jump to the workflow in Nexus Manager, and more.

#### Understanding the Send to Nexus Ticket

The Send to Nexus ticket consists of two parts:

- the top section of the ticket dialog is always the same, and allows you to:
  - select a particular Nexus workflow from the Workflow list;
  - indicate whether you want to launch a new, separate workflow in Nexus for every file you select in the Pilot (Separate Tasks), or whether you want to send all the selected files to one Nexus workflow (One Single Task).
- the bottom section of the ticket dialog contains fields for the public parameters for the workflow you selected. These parameters can be different for every Nexus workflow (they are defined using NeXML).
Launching a Nexus Workflow from the Pilot

1. In the Pilot, select the file(s) you want to process with your Nexus workflow.
2. Launch the Send to Nexus task.
3. Select the Workflow you want to run.
4. If you selected multiple files:
   - select One Single Task to send all the files to a single workflow in Nexus.
   - select Separate Tasks to launch a separate Nexus workflow for every selected file.
5. Provide the required public parameters for the different activities in the workflow.

   Note: You can use SmartNames in all the public parameter fields.

6. Click Launch to send the files to the Nexus workflow.
The **Send to Nexus** task appears in the **Task List**, where you can see the progress of the Nexus workflow. Note that progress is not displayed in real time.

The processed files from Nexus are returned to Automation Engine as the output of the **Send to Nexus** task. In other words, you can include **Send to Nexus** as a step into a more complete workflow.

### Switching Between Automation Engine and Nexus

- **In the Automation Engine Pilot:** in the Task List, right-click on the Send to Nexus task and choose **Go To Job in Nexus Manager** to view the job in Nexus Manager (this command is only available on Mac OS).
- **In Nexus Manager,** double-click the **Copy to BackStage** activity to view the job in the Automation Engine Pilot.

**Note:** In order to jump from the Nexus Manager 9.0 to the Automation Engine Pilot, you must connect to Nexus Manager with a blank user name and the password `awsnexus`.

### 8.3 Integration with Odystar

#### Why Run Odystar Workflows from the Automation Engine Pilot?

You can use all the power of Odystar workflows from within a Automation Engine Job. This allows you to bring both Automation Engine and Odystar workflows in line, running them from within a single controlling environment: the Automation Engine Pilot.

#### How Does it Work?

The **Send to Odystar** ticket gives you access to the workflows that are available on a specific Odystar server. You can use the **Send to Odystar** ticket as a single task or as part of a more complete Automation Engine workflow.

Any public parameters that have been defined in the Odystar workflow will show up in the **Send to Odystar** ticket in Automation Engine. In addition, these public parameters are SmartName-enabled, so you can use Job metadata to drive the Odystar workflows.

On the Odystar side the **Copy File** gateway allows you to set up workflows that send their resulting files back to Automation Engine.

Behind the scenes, Automation Engine and Odystar exchange files and notify each of other of their progress.

#### Example

- The Automation Engine workflow (top) sends the files to Odystar for additional processing before outputting them to a proofer.
- The Odystar workflow (bottom) applies PrePress changes to the files before copying them back to Automation Engine, where they go through the rest of the workflow (Proof step).
Note:
Odystar accepts Normalized PDF files as input, but its changes may render the files non-Normalized. We suggest that you do either (or both) of the following:

- send regular (not Normalized) PDFs to Odystar (add an Export to PDF File step before Send to Odystar),
- re-normalize the files you get back from Odystar (add a Normalize PostScript / PDF / Illustrator 8.0 File step after Send to Odystar).

8.3.1 Setup on the Odystar Side

To enable the Automation Engine Pilot to launch Odystar workflows, you must perform a number of setup tasks on the Odystar server.

Mounting Your Containers on the Odystar Server

- Mount the Automation Engine containers on your Odystar server using the SMB protocol.
Note: Make sure you have Read and Write permissions for those mounted volumes from your Odystar server machine.

Setting up the Hub and Your Odystar Canvases

1. On your Odystar server, launch the Hub application. You can find it in Odystar’s Server Software folder.
2. Go to Hub > Preferences.
   
   You can also use the shortcut Command + , (comma).
3. In the Shuttle tab, enter the IP Address of the server running your Hub, and the port to use for communication between Automation Engine and the Hub (in Shuttle Port).

   ![Server:](server.png)

   **Note:** By default this is port 5182, but if this port is already used by other processes, you should enter the next available port.

4. Create your Odystar workflow using the Inspector.
5. Double-click the Receive Process Folder of your Odystar workflow to open its parameters.
6. In the Shuttle tab, click Enable Shuttle Queue.
7. Make sure you add a Copy File gateway, with the Copy Back To Automation Engine mode selected, at the end of your workflow.
Your Odystar workflow is now available for use from the Automation Engine Pilot.

8.3.2 Setup on the Automation Engine Side

1. In the Pilot, go to Tools > Configure and select the Odystar category.
2. Click File > New.
3. Enter the name or IP address of the Odystar server in the Host field.
4. Enter the Port on which the Odystar server is accessible.
5. Click Test Connection to verify the settings you entered.
8.3.3 Running an Odystar Workflow from the Pilot

To run an Odystar workflow from within the Automation Engine Pilot, you can use the Send to Odystar ticket. You can use it as a single task or as part of a more complete Automation Engine workflow. You can also check the progress of the Odystar workflow in the Automation Engine Task Monitor.

Understanding the Send to Odystar Ticket

The Send to Odystar ticket consists of two parts:

- the top section of the ticket dialog is always the same, and allows you to:
  - select a particular Odystar workflow from the Workflow list;
  - indicate whether you want to launch a new, separate workflow in Odystar for every file you select in the Pilot (Separate Tasks), or whether you want to send all the selected files to one Odystar workflow (One Single Task);
  - the bottom section of the ticket dialog contains fields for the public parameters for the workflow you selected. These parameters can be different for every Odystar workflow (they are defined in the Inspector).

Tip: If you can’t see the workflow you are looking for, use the refresh button.

Note: You can also test whether the Odystar Hub is online by browsing to the following url in your favorite web browser: http://OdystarServerNameorAddress:5182.
Launching an Odystar Workflow with the Send to Odystar Task

1. In the Pilot, select the file(s) you want to process with your Odystar workflow.
2. Launch the Send to Odystar task.
3. Select the Workflow you want to run.
4. If you selected multiple files:
   - select One Single Task to send all the files to a single workflow in Odystar.
   - select Separate Tasks to launch a separate Odystar workflow for every selected file.
5. Provide the required public parameters for the different gateways in the workflow.
   
   **Note:** You can use SmartNames in all the public parameter fields.

6. Click Launch to send the files to the Odystar workflow.

The Send to Odystar task appears in the Task List, where you can see the progress of the Odystar workflow. Note that progress is not displayed in real time.

**Note:** The files processed by Odystar are returned to Automation Engine as the output of the Send to Odystar task (or as the output of the Send to Odystar workflow step when including the Send to Odystar ticket in an Automation Engine workflow - see the workflow example).

### 8.4 Integration with i-cut Suite

The i-cut Automate module in Automation Engine offers similar functionality to i-cut Layout, but in a workflow environment, requiring minimal manual intervention.

It is RIP and device independent.

It consists of four tasks:

- **Prepare Graphics for Nesting**, to extract graphics contours from graphic files using a cut path.
- **Add Parameters for Nesting**, to specify nesting parameters for a particular graphic.
- **Create Nested Layouts**, to nest a set of graphics onto one or more sheets, and create production files.
- **Create Tiles**, to tile very big graphics into smaller graphics to be printed.

See the Reference Guide for a detailed explanation of the tasks' parameters.

### 8.4.1 i-cut Automate Workflow

You can combine the i-cut Automate tasks into a workflow to fit your needs. For example in the workflow below:

1. The input files are copied to your FileStore.
2. In the **Prepare Graphics for Nesting** task, a cut path is created from the contour of the graphics on the white background, and the graphics are extracted from their backgrounds.
3. In the **Add Parameters for Nesting** task, the graphics are set to be repeated to fill the sheet (with the **Maximum fill** option).

4. The **Data Collector** makes sure the graphics arrive to the **Create Nested Layout** task all at once, so they are combined in same set of sheets.

5. The **Create Nested Layout** task creates the nesting on the substrate and with the parameters you define (margins, fill starting point, gutter, etc.).

6. The production files (print files and cut files), and if desired a nesting report, are created and sent to the location you define.

---

### Tip:

If the **Minimum Fill** on the sheet isn't reached on the due date, you can for example send the remaining graphics to another **Create Nested Layout** task with a lower minimum fill percentage (or see **Create Nested Layout** in the Reference Guide for more options).

---

### 8.5 Integration with Enfocus PitStop

You can integrate Enfocus PitStop with Automation Engine, to be able to preflight PDF files from the Pilot.

To preflight a file:
1. Go to Tools > Configure and set up the connection to PitStop (see Preflight Tools in the Reference Guide for more details).
2. Launch the Preflight via External Application task on your file (see Preflight via External Application in the Reference Guide for more details).

8.6 Integration with third party applications using Hot Folders

The Integrate via External Hot Folder task allows you to integrate external prepress applications into your workflow tickets. The only requirement is that the external system works with hot folders.

1. In the Integrate via External Hot Folder ticket, you define the location of the hot folder used by the external application, as well as the Result subfolders in which the external application will output processed jobs (the OK Folder), failed jobs (Error Folder) or jobs that produced warnings (Warnings Folder).
2. When you process a job with this ticket, Automation Engine copies the files to the external hot folder.
3. The external application picks up the files in its hot folder and processes them. The processed files are saved in the subfolder that matches the processing result: OK, Warning or Error.
4. Automation Engine monitors the OK, Warning and Error folders for any files that have been processed.
5. If it detects a file in the OK folder, Automation Engine copies it to the Output folder defined in the Integrate via External Hot Folder ticket, and continues its workflow. Depending on your settings, Error or Warning files might also be copied into the Output folder, or they might be deleted.
8.7 Integration with MIS Systems

Automation Engine supports tight integration with your MIS system.

You can:

- Take advantage of all the information the MIS system can hold (for example, you can retrieve customer information, or link MIS jobs to Automation Engine products to better serve your customers).
- Plan and trigger production through MIS to Automation Engine communication (for example, you can trigger job creation in Automation Engine from the MIS, or plan plates production...).

8.7.1 About JDF and MIS Integration

MIS and Automation Engine communicate via JDF/JMF.

You should set up a JDF hot folder, where:

- the MIS will send JDF files that will automatically start tasks that you defined,
- Automation Engine will write the processing result for the MIS.

Creating a JDF Hot Folder

1. Either:
   - click the Hot Folders view in the Views bar,
   - go to Go > Hot Folders,
   - use CTRL + SHIFT + H.

2. Click the Create New Hot Folder button.

3. In the dialog that opens, select JDF Hot Folder and click OK.
4. In the Select Folder dialog, browse to the folder you want to turn into a Hot Folder (or create a new folder with 📁) and click OK.

![Select Folder dialog]

**Note:** You cannot select folders that are already Hot Folders 📁.

5. In the New Hot Folder dialog, select an Output Folder (where Automation Engine will write the processing result).
6. Click OK.

The JDF Hot Folder is now listed in the Pilot's Hot Folder View.
9. Use Case: Setting up a Packaging Workflow

9.1 Build a Workflow

You can build workflows from zero or using custom tickets, you can migrate task chains to Automation Engine workflows, and create nested workflows.

You can use Smart Names to use predefined values. You can also choose to have the prepress manager build workflows that operators will use, or let the operators build workflows on the fly while processing files. See Building Workflows

The following steps will help you build a Workflow like this:

9.1.1 Preflight your file

Preflight via External Application

The Preflight via External Application step allows you to preflight a PDF file by integrating external (non- Automation Engine) preflight software into Automation Engine.

Attention: To define the preflight settings for Automation Engine go to Tools > Configure and select Preflight Tools

1. From Start connect to the Preflight via External Application workflow step.
2. Double-click on the workflow step to edit its parameters. For more information go to *Preflight via External Application*.

When Preflighting in a workflow, the *Preflight via External Application* workflow step has four output pins:
Note:

- **Preflight OK**: your files will go through this pin if the preflight gave an OK status.
- **Preflight with Warnings**: your files will go through this pin if the preflight gave a warning.
- **Preflight with Errors**: your files will go through this pin if the preflight gave an error.
- **Error**: your files will go through this pin in case of a processing error unrelated to the preflight status.

3. Connect each pin to the appropriate workflow step (for example, files which are “OK” or “Warning” can be normalized depending on your preflight setup, while files with “Error” need to be checked by an operator).

**Wait for Action (Checkpoint)**

Use the **Wait for Action (Checkpoint)** task to make your workflow stop at certain predefined points so that you have time to check and possibly correct something. See **Wait for Action**.

This Workflow is built so that you can route files based on your expertise. You will get a notification (To Do List), when the Preflight detects an error. The processing will be paused until you decide whether to approve the file or not, based on the preflight error report.

1. Add the **Wait for Action (Checkpoint)** step to your workflow.
2. Double-click the step to open its settings.
3. Create the notification that will be sent:
   a) choose which user you want to send it to,
   b) enter a **Subject**,
   c) add a **Message** if desired.
4. Choose a Due date. Either:
   - choose one of the predefined due dates (from Immediate to Next Sunday),
   - choose Other... in the Due date list and pick the due date yourself.

5. In Output states, define the output possibilities you want for your checkpoint.  
   By default, this step has two outputs: Completed and Aborted. 
   To add an output:
   a) click Add,
   b) enter the output’s name.
   Add as many outputs as you like.
6. If necessary, use the Move Up and Move Down buttons to display your outputs in a different order.
   
   **Note:** You can Remove the default outputs if you don’t need them.

7. Click OK to apply your settings.
Tip: After connecting the Output states you can:

- Add an extra Output state to the checkpoint and connect it to the "Preflight via External Application" step, to preflight your file again.
- Relaunch the file from the Task pane or directly in the canvas. Right click and choose Relaunch.

Copy or Move File

This task copies or moves the input file or the marked files to a new location. To mark a file, please insert the Mark file task in your workflow chain. If you don’t want to evaluate an existing file, select the “Fail” task when the file that is to be copied or moved already exists in the output folder. See Copy Move File.

9.1.2 Normalize your File

The Normalize PostScript / PDF / Illustrator 8.0 File generates a Normalized PDF file based on the preflighted file. See Normalize PostScript / PDF / Illustrator 8.0 File.

- Transparencies and Layers check the box to import PDF files as in Scope 3 (and lower). All transparencies and layers will be flattened. If not checked, a normalized PDF file will be created that contains all typical PDF features (like transparencies and layers).

Workflow overview

9.1.3 Trap your file

Trap - Prepare and Create Trap Layer

The trapping process is a safeguard against possible (even likely) fluctuations in the printing process. Minor discrepancies in registration, slight paper shifting can cause inks to mis-register. See What is Trapping?
There are three different Trap tasks;

**Trap – Create Trap Layer**: This task traps the input file according to the settings specified in the Trap Color Pairs file associated with the input file. The output of this task is a trapped Normalized PDF file. This task contains only the output options of the Trap task. All other trapping parameters are stored in the TCP file located in the same folder as the input file.

**Trap – Prepare and Create Trap Layer**: this step selects candidate trap color pairs and executes the trapping. The trapping areas are added in a separate layer on top of the original job.

**Trap – Prepare Trap Pairs**: This scans through the job and suggests a list of candidate trap color pairs.

**Export Trapped File to PDF**

Export your Normalized PDF to generic PDF for storage or approval. See *Export to PDF File*

**Tip:**
- To define the name and location of the output file that will be generated, use SmartNames.
- You can send the output file via mail.
- You can use PDF as SoftProof.
9.1.4 View your file

Prepare for Viewer

The Prepare for Viewer task prepares view data for the Automation Engine Viewer. This view data will help the Viewer to quickly open the file (the Viewer will use the prepared View Data instead of asking the server to make or stream it). See Prepare for Viewer.

Hold for Viewing

Choose a decision maker with experience to approve the trapped file. See Wait for Action. The Automation Engine Viewer is a powerful integrated Viewer and QA tool. The Automation Engine Viewer offers:

- Reliability: Showing the data in a correct way. At best in the same way the RIP/Proofer will see them.
- Detail: Unlimited zoom, high detail measuring, measuring traps and exact distances (die objects).
- Speed: Opening files swiftly, even when it concerns large files. Fast zooming.
- See Automation Engine Viewer.

Workflow Overview
9.1.5 Generate Step & Repeat

**Mark**

Use this to tag files that you will need to select later in the workflow (with the Select workflow control). The file will be tagged as "Label" and after approved in Hold for Viewing, the Select will pickup the original file.

- Give the tag a name.

**Select**

Use this ticket to select files that you have tagged earlier in the workflow (with the Mark workflow control).

- Enter the tag of the file.

---

**Tip:** You could add an extra Output state, "Send to Proof" to the checkpoint, connecting to Proof(FlexProof) to print HardProof.
For an example see *Mark and Select*.

**Step & Repeat Tabular**

This Workflow Step executes all Step and Repeat parameters (number of one-ups vertically and horizontally, gap between one-ups, alignment, SmartMarks...) after which the server will output the sheet layout. The ticket’s input fields also accept SQL queries, so that information stored in a database can be used to drive the sheet layout creation. See *Step & Repeat Tabular*.

**Workflow Overview**

![Workflow Diagram](image)

### 9.1.6 Create Report

**Create Report (ReportMaker)**

The *ReportMaker* task is used to automate the creation of design print cards (in French: fiche technique, in German: Drueck Karten).

The idea is that you generate reports containing all kind of information: file name, used inks, name of the operator, an image of the file. All this information is defined in a report template, then this template
is used to generate a specific report. For more information about templates, see ReportMaker Templates.

**Note:** You need PackEdge 3.0 or higher to make a ReportMaker template.

### Export Report to PDF

*Export to PDF* makes it possible to specify different settings, for example PDF version, Color Management…

**Tip:** You can define the File Name and the, Output location, of the report file that will be generated, by using SmartNames.

### Upload via FTP

*Upload via FTP* is an administration task which allows you to send files to a server. You need an FTP account on that server. For details or how to connect to an FTP server, see *Upload via FTP*.

**Tip:**
- To interact with customers you can also use steps like Publish on Web and Create WebCenter Project.

### Workflow Overview

![Workflow Diagram](image-url)
9.2 Use Shuttle in the Workflow

9.2.1 What is Shuttle

Shuttle is a small stand-alone application that enables you to submit files to Automation Engine tasks or workflows, and monitor their progress. You can use Shuttle to connect to several servers. The Shuttle functionality is also integrated in ArtPro, Neo, PackEdge, Plato, FastImpose and in Adobe Illustrator as a DeskPack plug-in. You can download Shuttle from EskoArtwork’s Download Center (http://download.artwork-systems.com). For more information about Shuttle see the Shuttle User Guide.

Set up Shuttle for Automation Engine

To use Shuttle and submit files to your Automation Engine workflow, you need to set up your server, your Shuttle client, and make sure they can exchange files via a shared folder.

**Workflow Server Setup**


**Shuttle Client Setup**

Set up your Shuttle client in the applications you use. See Shuttle Clients Setup, Automation Engine User Guide.

**Shared Folder Setup**

You also need to make sure that the relevant servers shared folders are mounted on the Shuttle clients machines, with the appropriate Read and Write permissions. For Automation Engine, the shared folder is either an Automation Engine Container, or an Upload Folder you set up in Configure. See Automation Engine Setup for Shuttle, Automation Engine User Guide.

9.2.2 What are Public Parameters

Operators or an administrator of the Automation Engine workflow determines which Public Parameters can be defined for submitting files through Shuttle. A common use case is to avoid mistakes by allowing only a choice of predefined values. Public Parameters reduce the need or predefined tasks. The owner of the ticket can easily change values before submitting new files.

9.2.3 Making Your Tickets Public

With Shuttle, you can submit files to any Automation Engine task, task chain or workflow that has a custom ticket. To do this, you need to make the ticket public. You can either:

- Select the Public option when creating the ticket.
• In the Ticket view, right-click your ticket and select Public Ticket.

Note: Public Tickets have a mark in the Public column.

<table>
<thead>
<tr>
<th>Task Type</th>
<th>Ticket Name</th>
<th>Public</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zip</td>
<td>Trap_nestedMF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>MAC_Approval</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>WaitForRunListFiles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>TrapWF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Trap_nestedMF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>SimpleTrap</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Some2Copy</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

9.2.4 Using Public Parameters

Public parameters are ticket parameters that operators can define for submitting files through Shuttle. For each public parameter, you can either:

- enter a list of predefined values the operator will choose from,
- let the operator enter a value himself.

Making a Parameter Public

Attention: You need to define which parameters are public before files are submitted to your workflow.

In the ticket containing the parameter to make public:

1. Right-click the parameter and select Make Parameter Public.
2. Right-click it again and select Modify Public Parameter...
3. In the Modify Public Parameter dialog that opens:
   a) If necessary, change the way the parameter will be called in Shuttle in Prompt as.
   b) Choose either:
• **Allow the user to set the value** if you want Shuttle users to be able to freely enter a value for that parameter.

![Modify Public Parameter](image)

• **Let the user select a predefined value** if you want Shuttle users to choose from a list of values that you define.

![Modify Public Parameter](image)

If that parameter already has a list of values to choose from in the Ticket, they will be displayed here. You can **Add** or **Remove** values.

**Note:** Shuttle operators will see (and choose from) the **Predefined Settings** but not the associated **Values**.

c) If you have chosen **Let the user select a predefined value** in Default Predefined Setting, choose the setting that will be selected by default when submitting files from Shuttle (if the operator doesn’t select another setting, this one will be used for processing).

4. Don’t forget to save your ticket.
This is how your public parameter will look to Shuttle operators:

<table>
<thead>
<tr>
<th>If you chose Allow the user to set the value</th>
<th>If you chose Let the user select a predefined value</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Custom Resolution 150ppi" /></td>
<td><img src="image2" alt="Custom Resolution" /></td>
</tr>
<tr>
<td>Anti-aliasing</td>
<td>High</td>
</tr>
<tr>
<td></td>
<td>Low</td>
</tr>
</tbody>
</table>

Managing Public Parameters in Your Ticket

Once you have made parameters public in your ticket, you can have an overview of your public parameters and edit them at the ticket level.

1. In your ticket, go to Advanced > Manage Public Parameters...

   The Manage Public Parameters dialog that opens contains all of your ticket’s public parameters.
The left pane shows all parameters that can be made public for that ticket (the ones you have made public are greyed out).

The right pane shows the parameters you have made public, with their settings (predefined values, etc.).
2. You can:
   - drag parameters from left to right to make them public;
   - click a public parameter's cross \(\times\) if you don’t want it to be public anymore;
   - rearrange the order of your public parameters (drag them up or down);
   - change public parameters’ settings (Prompt as, Predefined Settings, etc.);
   - group public parameters under a header (click Add Group, click \(\text{ renegotiate }\) to edit the header, and drag parameters from the left);

Using Presets to Simplify Operators’ Choices

You can use presets to minimize the amount of public parameters your operators have to choose from, and make it simpler for them.
For example, you want operators to use different trapping settings for printing with offset or dry offset. You can define those trapping settings in a preset, so that operators will only have to choose between offset and dry offset.

In the Manage Public Parameters dialog:

1. Click the Add Preset button.
2. Enter what your operators will see:
   a) in Prompt as, enter the name to give the preset parameter in Shuttle,
   b) enter the values that operators will choose from (replacing Type a value here).
      Click Add if you need to add extra values.

3. Drag parameters from the dialog’s left pane into the preset.
   You can drag as many parameters as you want. They will appear under each value (here both under Offset and Dry Offset).
4. Define the parameters values for each preset value.
   For example, define normal trapping, 50% opacity and object dependant end caps for Offset, and reverse trapping, 100% opacity and round end caps for Dry Offset.

5. Don't forget to save your ticket.

   This is how your preset will look to Shuttle operators:

SmartNames in Public Parameters

You can use SmartNames in your public parameters (for parameters taking SmartNames as input).

In Shuttle, use square brackets around SmartNames when submitting a file with public parameters.
9.2.5 Public Parameters in Sample Workflow: Packaging

When choosing which parameters to make public you can keep have in mind end production, different customers, workflow capability etc. Define the parameters so that you can change the production file without having to change the workflow ticket.
9.2.6 Launching Files into a Workflow

Launching Files from Shuttle Standalone

1. To assign a Job ID and / or Job Part ID to the files to process in your workflow, go to Window > Context and fill in the Job ID and / or Job Part ID.
Do this when:

- you want to add your file(s) to an Automation Engine job,

**Note:** If the file you are launching is already located in an Automation Engine job, it will automatically be processed within that job’s context (you don’t need to enter the Job ID).

2. Open the Launch window using:

- File > New Launch Window...,
- Option + Command + N on Mac or Alt + Control + N on PC.

3. Select the Workflow you want to launch on your file.

![Launch window](image)

- For Automation Engine workflows, you will see public tickets.

**Note:**

You can open several Launch windows, and select a different workflow in each.

If you quit and restart Shuttle, your Launch windows will be remembered.

4. Launch your file in one of the following ways:

- Drag and drop your file on the Drop Files Here arrow.
- Click the Launch... button and browse to the file you want to launch.
- Go to File > Launch... and browse to the file you want to launch.
- Use Command + S (on Mac).

5. If your workflow has public parameters, you will see a pop-up where you can fill them in.
Launching Files from PackEdge

**Attention:** You must save your file on an Automation Engine container before you can launch it into a workflow from PackEdge.

1. Go to **File > Launch Workflow...**
   
   This opens the **Launch Workflow** window.
2. Select the workflow you want to launch on your file in the workflow list.

3. If your workflow has public parameters, you can fill them in in the same window.

   **Note:** For more information on public parameters, see *Using Public Parameters*.

4. Click Launch to launch the workflow on your file.
Tip:
To access Shuttle easily in the future (without using the menus):

1. Go to **Window > Toolbars > Shuttle** to open the Shuttle palette.

2. Drag it into your application’s toolbar.

3. Click ![Launch Workflow](image) to open the **Launch Workflow** window, or ![Shuttle](image) to open the **Shuttle** window.