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1.  Introduction

1.1.  Copyright Notice
© Copyright 2024 Esko Software BV, Gent, Belgium

All rights reserved. This material, information and instructions for use contained herein are the
property of Esko Software BV. The material, information and instructions are provided on an AS IS
basis without warranty of any kind. There are no warranties granted or extended by this document.
Furthermore Esko Software BV does not warrant, guarantee or make any representations regarding
the use, or the results of the use of the software or the information contained herein. Esko Software
BV shall not be liable for any direct, indirect, consequential or incidental damages arising out of the use
or inability to use the software or the information contained herein.

The information contained herein is subject to change without notice. Revisions may be issued from
time to time to advise of such changes and/or additions.

No part of this document may be reproduced, stored in a data base or retrieval system, or published, in
any form or in any way, electronically, mechanically, by print, photoprint, microfilm or any other means
without prior written permission from Esko Software BV.

This document supersedes all previous dated versions.

PANTONE
®

 Colors displayed in the software application or in the user documentation may not match
PANTONE-identified standards. Consult current PANTONE Color Publications for accurate color.
PANTONE

®
 and other Pantone trademarks are the property of Pantone LLC. © Pantone LLC, 2015

Pantone is the copyright owner of color data and/or software which are licensed to Esko to distribute
for use only in combination with Studio Visualizer. PANTONE Color Data and/or Software shall not be
copied onto another disk or into memory unless as part of the execution of Studio Visualizer.

This software is based in part on the work of the Independent JPEG Group.

Portions of this software are copyright © 1996-2002 The FreeType Project (www.freetype.org). All
rights reserved.

Portions of this software are copyright 2006 Feeling Software, copyright 2005-2006 Autodesk Media
Entertainment.

Portions of this software are copyright ©1998-2003 Daniel Veillard. All rights reserved.

Portions of this software are copyright ©1999-2006 The Botan Project. All rights reserved.

Part of the software embedded in this product is gSOAP software. Portions created by gSOAP are
Copyright ©2001-2004 Robert A. van Engelen, Genivia inc. All rights reserved.

Portions of this software are copyright ©1998-2008 The OpenSSL Project and ©1995-1998 Eric Young
(eay@cryptsoft.com). All rights reserved.

This product includes software developed by the Apache Software Foundation (http://
www.apache.org/).

Adobe, the Adobe logo, Acrobat, the Acrobat logo, Adobe Creative Suite, Illustrator, InDesign, PDF,
Photoshop, PostScript, XMP and the Powered by XMP logo are either registered trademarks or
trademarks of Adobe Systems Incorporated in the United States and/or other countries.
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Microsoft and the Microsoft logo are registered trademarks of Microsoft Corporation in the United
States and other countries.

SolidWorks is a registered trademark of SolidWorks Corporation.

Portions of this software are owned by Spatial Corp. 1986 2003. All Rights Reserved.

JDF and the JDF logo are trademarks of the CIP4 Organisation. Copyright 2001 The International
Cooperation for the Integration of Processes in Prepress, Press and Postpress (CIP4). All rights
reserved.

The Esko software contains the RSA Data Security, Inc. MD5 Message-Digest Algorithm.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle
corporation in the U.S. and other countries.

Part of this software uses technology by Best Color Technology (EFI). EFI and Bestcolor are registered
trademarks of Electronics For Imaging GmbH in the U.S. Patent and Trademark Oce.

Contains PowerNest library Copyrighted and Licensed by Alma, 2005 – 2007.

Part of this software uses technology by GlobalVision. ArtProof and ScanProof are registered
trademarks of GlobalVision Inc.

Part of this software uses technology by Qoppa Software. Copyright © 2002-Present. All Rights
Reserved.

All other product names are trademarks or registered trademarks of their respective owners.

Correspondence regarding this publication should be forwarded to:

Esko Software BV

Raymonde de Larochelaan 13

B – 9051 Gent

info.eur@esko.com

1.1.1.  Third party license information

This product includes Qt.

      The software uses Qt, licensed under LGPL v3. The Qt Toolkit is Copyright (C) 2019
 The Qt Company Ltd.

      Portions of this software are copyright (C) 2006-2015 The FreeType Project
 (www.freetype.org). All rights reserved.
      
      Copyright (C) 1991-2011, Thomas G. Lane, Guido Vollbeding.
      This software is based in part on the work of the Independent JPEG Group.
      
      Secure Hash Algorithm SHA-3 - brg_endian
      Copyright (c) 1998-2013, Brian Gladman, Worcester, UK. All rights reserved.

      LICENSE TERMS

      The redistribution and use of this software (with or without changes)
      is allowed without the payment of fees or royalties provided that:

       1. source code distributions include the above copyright notice, this
          list of conditions and the following disclaimer;

       2. binary distributions include the above copyright notice, this list
          of conditions and the following disclaimer in their documentation;
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       3. the name of the copyright holder is not used to endorse products
          built using this software without specific written permission.

      DISCLAIMER

      This software is provided 'as is' with no explicit or implied warranties
      in respect of its properties, including, but not limited to, correctness
      and/or fitness for purpose.
    
------------------------------------------------------------

This product includes QtShaderTools.

      The Qt Toolkit is Copyright (C) 2019 The Qt Company Ltd.
    
------------------------------------------------------------

This product includes LibTIFF.

      Copyright (c) 1988-1997 Sam Leffler
      Copyright (c) 1991-1997 Silicon Graphics, Inc.

      Permission to use, copy, modify, distribute, and sell this software and
      its documentation for any purpose is hereby granted without fee, provided
      that (i) the above copyright notices and this permission notice appear in
      all copies of the software and related documentation, and (ii) the names of
      Sam Leffler and Silicon Graphics may not be used in any advertising or
      publicity relating to the software without the specific, prior written
      permission of Sam Leffler and Silicon Graphics.

      THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,
      EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
      WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

      IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR
      ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND,
      OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
      WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF
      LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
      OF THIS SOFTWARE.
    
------------------------------------------------------------

This product includes zlib.

(C) 1995-2013 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or implied
warranty. In no event will the authors be held liable for any damages
arising from the use of this software.

Permission is granted to anyone to use this software for any purpose,
including commercial applications, and to alter it and redistribute it
freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not
   claim that you wrote the original software. If you use this software
   in a product, an acknowledgment in the product documentation would be
   appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be
   misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.
    
------------------------------------------------------------

This product includes svgio.

 Copyright Oleg Maximenko 2014.
 Distributed under the Boost Software License, Version 1.0.
    
------------------------------------------------------------

This product includes xxHash.

      xxHash Library
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      Copyright (c) 2012-2020 Yann Collet
      All rights reserved.

      BSD 2-Clause License (https://www.opensource.org/licenses/bsd-license.php)

      Redistribution and use in source and binary forms, with or without modification,
      are permitted provided that the following conditions are met:

      * Redistributions of source code must retain the above copyright notice, this
      list of conditions and the following disclaimer.

      * Redistributions in binary form must reproduce the above copyright notice, this
      list of conditions and the following disclaimer in the documentation and/or
      other materials provided with the distribution.

      THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
      ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
      WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
      DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR
      ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
      (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
      LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
      ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
      (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
      SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  
------------------------------------------------------------

This product includes OpenJPEG.

        The copyright in this software is being made available under the 2-clauses
        BSD License, included below. This software may be subject to other third
        party and contributor rights, including patent rights, and no such rights
        are granted under this license.
       
        Copyright (c) 2002-2014, Universite catholique de Louvain (UCL), Belgium
        Copyright (c) 2002-2014, Professor Benoit Macq
        Copyright (c) 2003-2014, Antonin Descampe
        Copyright (c) 2003-2009, Francois-Olivier Devaux
        Copyright (c) 2005, Herve Drolon, FreeImage Team
        Copyright (c) 2002-2003, Yannick Verschueren
        Copyright (c) 2001-2003, David Janssens
        Copyright (c) 2011-2012, Centre National d'Etudes Spatiales (CNES), France
        Copyright (c) 2012, CS Systemes d'Information, France
       
        All rights reserved.
       
        Redistribution and use in source and binary forms, with or without
        modification, are permitted provided that the following conditions
        are met:
        1. Redistributions of source code must retain the above copyright
           notice, this list of conditions and the following disclaimer.
        2. Redistributions in binary form must reproduce the above copyright
           notice, this list of conditions and the following disclaimer in the
           documentation and/or other materials provided with the distribution.
       
        THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS `AS IS'
        AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
        IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
        ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
        LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
        CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
        SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
        INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
        CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
        ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
        POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes Micorsoft.Web.WebView2.

Copyright (C) Microsoft Corporation. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:
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   * Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
   * Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following disclaimer
in the documentation and/or other materials provided with the
distribution.
   * The name of Microsoft Corporation, or the names of its contributors 
may not be used to endorse or promote products derived from this
software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes GLEW: The OpenGL Extension Wrangler Library.

The OpenGL Extension Wrangler Library
Copyright (C) 2002-2007, Milan Ikits <milan ikits[]ieee org>
Copyright (C) 2002-2007, Marcelo E. Magallon <mmagallo[]debian org>
Copyright (C) 2002, Lev Povalahev
All rights reserved.

Redistribution and use in source and binary forms, with or without 
modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, 
  this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright notice, 
  this list of conditions and the following disclaimer in the documentation 
  and/or other materials provided with the distribution.
* The name of the author may be used to endorse or promote products 
  derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" 
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE 
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
THE POSSIBILITY OF SUCH DAMAGE.

Mesa 3-D graphics library
Version:  7.0

Copyright (C) 1999-2007  Brian Paul   All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the "Software"),
to deal in the Software without restriction, including without limitation
the rights to use, copy, modify, merge, publish, distribute, sublicense,
and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
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CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Copyright (c) 2007 The Khronos Group Inc.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and/or associated documentation files (the
"Materials"), to deal in the Materials without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Materials, and to
permit persons to whom the Materials are furnished to do so, subject to
the following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Materials.

THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS.
  
------------------------------------------------------------

This product includes OpenEXR.

      Copyright (c) Contributors to the OpenEXR Project. All rights reserved.

      Redistribution and use in source and binary forms, with or without modification,
 are permitted provided that the following conditions are met:
      
      1. Redistributions of source code must retain the above copyright notice, this list
 of conditions and the following disclaimer.
      
      2. Redistributions in binary form must reproduce the above copyright notice,
 this list of conditions and the following disclaimer in the documentation and/or other
 materials provided with the distribution.
      
      3. Neither the name of the copyright holder nor the names of its contributors may
 be used to endorse or promote products derived from this software without specific prior
 written permission.
      
      THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
 AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
 WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN
 NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
 INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
 INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
 LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
 OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.         
    
------------------------------------------------------------

This product includes QtWebChannel.

      The Qt Toolkit is Copyright (C) 2019 The Qt Company Ltd.
    
------------------------------------------------------------

This product includes tesseract.

  Copyright (C) 2016 Google, Inc. Licensed under the Apache License, Version 2.0
    
------------------------------------------------------------

This product includes JPEGLib.
This software is copyright (C) 1991-2016, Thomas G. Lane, Guido Vollbeding.
      All Rights Reserved.
      
      This software is based in part on the work of the Independent JPEG Group.
------------------------------------------------------------

This product includes Little CMS.
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    Little CMS
    Copyright (c) 1998-2020 Marti Maria Saguer

    Permission is hereby granted, free of charge, to any person obtaining
    a copy of this software and associated documentation files (the 
    "Software"), to deal in the Software without restriction, including
    without limitation the rights to use, copy, modify, merge, publish,
    distribute, sublicense, and/or sell copies of the Software, and to 
    permit persons to whom the Software is furnished to do so, subject
    to the following conditions:

    The above copyright notice and this permission notice shall be 
    included in all copies or substantial portions of the Software.

    THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
    EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF 
    MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
    IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
    CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
    TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE 
    SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
    
------------------------------------------------------------

This product includes libxml2.

    Copyright (C) 1998-2012 Daniel Veillard.  All Rights Reserved.

    Permission is hereby granted, free of charge, to any person obtaining a copy
    of this software and associated documentation files (the "Software"), to deal
    in the Software without restriction, including without limitation the rights
    to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
    copies of the Software, and to permit persons to whom the Software is fur-
    nished to do so, subject to the following conditions:

    The above copyright notice and this permission notice shall be included in
    all copies or substantial portions of the Software.

    THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
    IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FIT-
    NESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL THE
    AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
    LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
    OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
    THE SOFTWARE.
    
------------------------------------------------------------

This product includes cereal.

    Copyright (c) 2013-2022, Randolph Voorhies, Shane Grant
    All rights reserved.

    Redistribution and use in source and binary forms, with or without
    modification, are permitted provided that the following conditions are met:
        * Redistributions of source code must retain the above copyright
          notice, this list of conditions and the following disclaimer.
        * Redistributions in binary form must reproduce the above copyright
          notice, this list of conditions and the following disclaimer in the
          documentation and/or other materials provided with the distribution.
        * Neither the name of the copyright holder nor the
          names of its contributors may be used to endorse or promote products
          derived from this software without specific prior written permission.

    THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
    ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
    WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
    DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY
    DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
    (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
    LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
    ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
    (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
    SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  
------------------------------------------------------------
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This product includes GNU FriBidi.

        GNU FriBidi is Free Software; you can redistribute it and/or modify it under the
 terms of the GNU Lesser General Public License as published by the Free Software
        Foundation; either version 2.1 of the License, or (at your option) any later
 version.
        GNU FriBidi is distributed in the hope that it will be useful, but WITHOUT
 ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A
 PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details.
        You should have received a copy of the GNU Lesser General Public License
 along with GNU FriBidi, in a file named COPYING; if not, write to the Free Software
 Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
    
------------------------------------------------------------

This product includes pugixml.

      MIT License

      Copyright (c) 2006-2023 Arseny Kapoulkine
      
      Permission is hereby granted, free of charge, to any person
      obtaining a copy of this software and associated documentation
      files (the "Software"), to deal in the Software without
      restriction, including without limitation the rights to use,
      copy, modify, merge, publish, distribute, sublicense, and/or sell
      copies of the Software, and to permit persons to whom the
      Software is furnished to do so, subject to the following
      conditions:
      
      The above copyright notice and this permission notice shall be
      included in all copies or substantial portions of the Software.
      
      THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
      EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
      OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
      NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
      HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
      WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
      FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
      OTHER DEALINGS IN THE SOFTWARE.
    
------------------------------------------------------------

This product includes QtSingleApplication.

        Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
        Contact: http://www.qt-project.org/legal

        This file is part of the Qt Solutions component.

        You may use this file under the terms of the BSD license as follows:

        Redistribution and use in source and binary forms, with or without
        modification, are permitted provided that the following conditions are
        met:
          * Redistributions of source code must retain the above copyright
            notice, this list of conditions and the following disclaimer.
          * Redistributions in binary form must reproduce the above copyright
            notice, this list of conditions and the following disclaimer in
            the documentation and/or other materials provided with the
            distribution.
          * Neither the name of Digia Plc and its Subsidiary(-ies) nor the names
            of its contributors may be used to endorse or promote products derived
            from this software without specific prior written permission.

        THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
        "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
        LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
        A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
        OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
        SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
        LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
        DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
        THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
        (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
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        OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

    
------------------------------------------------------------

This product includes ICU.

      Copyright (c) 1991-2023 Unicode, Inc. All rights reserved.
      Distributed under the Terms of Use in https://www.unicode.org/copyright.html.
      
      Permission is hereby granted, free of charge, to any person obtaining
      a copy of the Unicode data files and any associated documentation
      (the "Data Files") or Unicode software and any associated documentation
      (the "Software") to deal in the Data Files or Software
      without restriction, including without limitation the rights to use,
      copy, modify, merge, publish, distribute, and/or sell copies of
      the Data Files or Software, and to permit persons to whom the Data Files
      or Software are furnished to do so, provided that either
      (a) this copyright and permission notice appear with all copies
      of the Data Files or Software, or
      (b) this copyright and permission notice appear in associated
      Documentation.
      
      THE DATA FILES AND SOFTWARE ARE PROVIDED "AS IS", WITHOUT WARRANTY OF
      ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
      WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
      NONINFRINGEMENT OF THIRD PARTY RIGHTS.
      IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS
      NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL
      DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
      DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
      TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
      PERFORMANCE OF THE DATA FILES OR SOFTWARE.

      ----------------------------------------------------------------------

      Chinese/Japanese Word Break Dictionary Data (cjdict.txt)
      
       #     The Google Chrome software developed by Google is licensed under
       # the BSD license. Other software included in this distribution is
       # provided under other licenses, as set forth below.
       #
       #  The BSD License
       #  http://opensource.org/licenses/bsd-license.php
       #  Copyright (C) 2006-2008, Google Inc.
       #
       #  All rights reserved.
       #
       #  Redistribution and use in source and binary forms, with or without
       # modification, are permitted provided that the following conditions are met:
       #
       #  Redistributions of source code must retain the above copyright notice,
       # this list of conditions and the following disclaimer.
       #  Redistributions in binary form must reproduce the above
       # copyright notice, this list of conditions and the following
       # disclaimer in the documentation and/or other materials provided with
       # the distribution.
       #  Neither the name of  Google Inc. nor the names of its
       # contributors may be used to endorse or promote products derived from
       # this software without specific prior written permission.
       #
       #
       #  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
       # CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
       # INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
       # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
       # DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
       # LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
       # CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
       # SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
       # BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
       # LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
       # NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
       # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
       #
       #
       #  The word list in cjdict.txt are generated by combining three word lists
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       # listed below with further processing for compound word breaking. The
       # frequency is generated with an iterative training against Google web
       # corpora.
       #
       #  * Libtabe (Chinese)
       #    - https://sourceforge.net/project/?group_id=1519
       #    - Its license terms and conditions are shown below.
       #
       #  * IPADIC (Japanese)
       #    - http://chasen.aist-nara.ac.jp/chasen/distribution.html
       #    - Its license terms and conditions are shown below.
       #
       #  ---------COPYING.libtabe ---- BEGIN--------------------
       #
       #  /*
       #   * Copyright (c) 1999 TaBE Project.
       #   * Copyright (c) 1999 Pai-Hsiang Hsiao.
       #   * All rights reserved.
       #   *
       #   * Redistribution and use in source and binary forms, with or without
       #   * modification, are permitted provided that the following conditions
       #   * are met:
       #   *
       #   * . Redistributions of source code must retain the above copyright
       #   *   notice, this list of conditions and the following disclaimer.
       #   * . Redistributions in binary form must reproduce the above copyright
       #   *   notice, this list of conditions and the following disclaimer in
       #   *   the documentation and/or other materials provided with the
       #   *   distribution.
       #   * . Neither the name of the TaBE Project nor the names of its
       #   *   contributors may be used to endorse or promote products derived
       #   *   from this software without specific prior written permission.
       #   *
       #   * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
       #   * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
       #   * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
       #   * FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
       #   * REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
       #   * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
       #   * (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
       #   * SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
       #   * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
       #   * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
       #   * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
       #   * OF THE POSSIBILITY OF SUCH DAMAGE.
       #   */
       #
       #  /*
       #   * Copyright (c) 1999 Computer Systems and Communication Lab,
       #   *                    Institute of Information Science, Academia
       #       *                    Sinica. All rights reserved.
       #   *
       #   * Redistribution and use in source and binary forms, with or without
       #   * modification, are permitted provided that the following conditions
       #   * are met:
       #   *
       #   * . Redistributions of source code must retain the above copyright
       #   *   notice, this list of conditions and the following disclaimer.
       #   * . Redistributions in binary form must reproduce the above copyright
       #   *   notice, this list of conditions and the following disclaimer in
       #   *   the documentation and/or other materials provided with the
       #   *   distribution.
       #   * . Neither the name of the Computer Systems and Communication Lab
       #   *   nor the names of its contributors may be used to endorse or
       #   *   promote products derived from this software without specific
       #   *   prior written permission.
       #   *
       #   * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
       #   * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
       #   * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
       #   * FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
       #   * REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
       #   * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
       #   * (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
       #   * SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
       #   * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
       #   * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
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       #   * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
       #   * OF THE POSSIBILITY OF SUCH DAMAGE.
       #   */
       #
       #  Copyright 1996 Chih-Hao Tsai @ Beckman Institute,
       #      University of Illinois
       #  c-tsai4@uiuc.edu  http://casper.beckman.uiuc.edu/~c-tsai4
       #
       #  ---------------COPYING.libtabe-----END--------------------------------
       #
       #
       #  ---------------COPYING.ipadic-----BEGIN-------------------------------
       #
       #  Copyright 2000, 2001, 2002, 2003 Nara Institute of Science
       #  and Technology.  All Rights Reserved.
       #
       #  Use, reproduction, and distribution of this software is permitted.
       #  Any copy of this software, whether in its original form or modified,
       #  must include both the above copyright notice and the following
       #  paragraphs.
       #
       #  Nara Institute of Science and Technology (NAIST),
       #  the copyright holders, disclaims all warranties with regard to this
       #  software, including all implied warranties of merchantability and
       #  fitness, in no event shall NAIST be liable for
       #  any special, indirect or consequential damages or any damages
       #  whatsoever resulting from loss of use, data or profits, whether in an
       #  action of contract, negligence or other tortuous action, arising out
       #  of or in connection with the use or performance of this software.
       #
       #  A large portion of the dictionary entries
       #  originate from ICOT Free Software.  The following conditions for ICOT
       #  Free Software applies to the current dictionary as well.
       #
       #  Each User may also freely distribute the Program, whether in its
       #  original form or modified, to any third party or parties, PROVIDED
       #  that the provisions of Section 3 ("NO WARRANTY") will ALWAYS appear
       #  on, or be attached to, the Program, which is distributed substantially
       #  in the same form as set out herein and that such intended
       #  distribution, if actually made, will neither violate or otherwise
       #  contravene any of the laws and regulations of the countries having
       #  jurisdiction over the User or the intended distribution itself.
       #
       #  NO WARRANTY
       #
       #  The program was produced on an experimental basis in the course of the
       #  research and development conducted during the project and is provided
       #  to users as so produced on an experimental basis.  Accordingly, the
       #  program is provided without any warranty whatsoever, whether express,
       #  implied, statutory or otherwise.  The term "warranty" used herein
       #  includes, but is not limited to, any warranty of the quality,
       #  performance, merchantability and fitness for a particular purpose of
       #  the program and the nonexistence of any infringement or violation of
       #  any right of any third party.
       #
       #  Each user of the program will agree and understand, and be deemed to
       #  have agreed and understood, that there is no warranty whatsoever for
       #  the program and, accordingly, the entire risk arising from or
       #  otherwise connected with the program is assumed by the user.
       #
       #  Therefore, neither ICOT, the copyright holder, or any other
       #  organization that participated in or was otherwise related to the
       #  development of the program and their respective officials, directors,
       #  officers and other employees shall be held liable for any and all
       #  damages, including, without limitation, general, special, incidental
       #  and consequential damages, arising out of or otherwise in connection
       #  with the use or inability to use the program or any product, material
       #  or result produced or otherwise obtained by using the program,
       #  regardless of whether they have been advised of, or otherwise had
       #  knowledge of, the possibility of such damages at any time during the
       #  project or thereafter.  Each user will be deemed to have agreed to the
       #  foregoing by his or her commencement of use of the program.  The term
       #  "use" as used herein includes, but is not limited to, the use,
       #  modification, copying and distribution of the program and the
       #  production of secondary products from the program.
       #
       #  In the case where the program, whether in its original form or
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       #  modified, was distributed or delivered to or received by a user from
       #  any person, organization or entity other than ICOT, unless it makes or
       #  grants independently of ICOT any specific warranty to the user in
       #  writing, such person, organization or entity, will also be exempted
       #  from and not be held liable to the user for any such damages as noted
       #  above as far as the program is concerned.
       #
       #  ---------------COPYING.ipadic-----END----------------------------------
      
      ----------------------------------------------------------------------
      
      Lao Word Break Dictionary Data (laodict.txt)
      
       # Copyright (C) 2016 and later: Unicode, Inc. and others.
       # License & terms of use: http://www.unicode.org/copyright.html
       # Copyright (c) 2015 International Business Machines Corporation
       # and others. All Rights Reserved.
       #
       # Project: https://github.com/rober42539/lao-dictionary
       # Dictionary: https://github.com/rober42539/lao-dictionary/laodict.txt
       # License: https://github.com/rober42539/lao-dictionary/LICENSE.txt
       #          (copied below)
       #
       # This file is derived from the above dictionary version of Nov 22, 2020
       #  ----------------------------------------------------------------------
       #  Copyright (C) 2013 Brian Eugene Wilson, Robert Martin Campbell.
       #  All rights reserved.
       #
       #  Redistribution and use in source and binary forms, with or without
       #  modification, are permitted provided that the following conditions are met:
       #
       #  Redistributions of source code must retain the above copyright notice, this
       #  list of conditions and the following disclaimer. Redistributions in binary
       #  form must reproduce the above copyright notice, this list of conditions and
       #  the following disclaimer in the documentation and/or other materials
       #  provided with the distribution.
       #
       # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
       # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
       # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
       # FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
       # COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
       # INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
       # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
       # SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
       # HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
       # STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
       # ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
       # OF THE POSSIBILITY OF SUCH DAMAGE.
       #  --------------------------------------------------------------------------
      
      ----------------------------------------------------------------------
      
      Burmese Word Break Dictionary Data (burmesedict.txt)
      
       #  Copyright (c) 2014 International Business Machines Corporation
       #  and others. All Rights Reserved.
       #
       #  This list is part of a project hosted at:
       #    github.com/kanyawtech/myanmar-karen-word-lists
       #
       #  --------------------------------------------------------------------------
       #  Copyright (c) 2013, LeRoy Benjamin Sharon
       #  All rights reserved.
       #
       #  Redistribution and use in source and binary forms, with or without
       #  modification, are permitted provided that the following conditions
       #  are met: Redistributions of source code must retain the above
       #  copyright notice, this list of conditions and the following
       #  disclaimer.  Redistributions in binary form must reproduce the
       #  above copyright notice, this list of conditions and the following
       #  disclaimer in the documentation and/or other materials provided
       #  with the distribution.
       #
       #    Neither the name Myanmar Karen Word Lists, nor the names of its
       #    contributors may be used to endorse or promote products derived
       #    from this software without specific prior written permission.
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       #
       #  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
       #  CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
       #  INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
       #  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
       #  DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS
       #  BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
       #  EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
       #  TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
       #  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
       #  ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
       #  TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
       #  THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
       #  SUCH DAMAGE.
       #  --------------------------------------------------------------------------
      
      ----------------------------------------------------------------------
      
      Time Zone Database
      
        ICU uses the public domain data and code derived from Time Zone
      Database for its time zone support. The ownership of the TZ database
      is explained in BCP 175: Procedure for Maintaining the Time Zone
      Database section 7.
      
       # 7.  Database Ownership
       #
       #    The TZ database itself is not an IETF Contribution or an IETF
       #    document.  Rather it is a pre-existing and regularly updated work
       #    that is in the public domain, and is intended to remain in the
       #    public domain.  Therefore, BCPs 78 [RFC5378] and 79 [RFC3979] do
       #    not apply to the TZ Database or contributions that individuals make
       #    to it.  Should any claims be made and substantiated against the TZ
       #    Database, the organization that is providing the IANA
       #    Considerations defined in this RFC, under the memorandum of
       #    understanding with the IETF, currently ICANN, may act in accordance
       #    with all competent court orders.  No ownership claims will be made
       #    by ICANN or the IETF Trust on the database or the code.  Any person
       #    making a contribution to the database or code waives all rights to
       #    future claims in that contribution or in the TZ Database.
      
      ----------------------------------------------------------------------
      
      Google double-conversion
      
      Copyright 2006-2011, the V8 project authors. All rights reserved.
      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions are
      met:
      
          * Redistributions of source code must retain the above copyright
            notice, this list of conditions and the following disclaimer.
          * Redistributions in binary form must reproduce the above
            copyright notice, this list of conditions and the following
            disclaimer in the documentation and/or other materials provided
            with the distribution.
          * Neither the name of Google Inc. nor the names of its
            contributors may be used to endorse or promote products derived
            from this software without specific prior written permission.
      
      THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
      "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
      LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
      A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
      OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
      SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
      LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
      DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
      THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
      (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
      OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
      
      ----------------------------------------------------------------------
      
      File: aclocal.m4 (only for ICU4C)
      Section: pkg.m4 - Macros to locate and utilise pkg-config.
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      Copyright (c) 2004 Scott James Remnant <scott@netsplit.com>.
      Copyright (c) 2012-2015 Dan Nicholson <dbn.lists@gmail.com>
      
      This program is free software; you can redistribute it and/or modify
      it under the terms of the GNU General Public License as published by
      the Free Software Foundation; either version 2 of the License, or
      (at your option) any later version.
      
      This program is distributed in the hope that it will be useful, but
      WITHOUT ANY WARRANTY; without even the implied warranty of
      MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
      General Public License for more details.
      
      You should have received a copy of the GNU General Public License
      along with this program; if not, write to the Free Software
      Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
      02111-1307, USA.
      
      As a special exception to the GNU General Public License, if you
      distribute this file as part of a program that contains a
      configuration script generated by Autoconf, you may include it under
      the same distribution terms that you use for the rest of that
      program.
      
      
      (The condition for the exception is fulfilled because
      ICU4C includes a configuration script generated by Autoconf,
      namely the `configure` script.)
      
      ----------------------------------------------------------------------
      
      File: config.guess (only for ICU4C)
      
      
      This file is free software; you can redistribute it and/or modify it
      under the terms of the GNU General Public License as published by
      the Free Software Foundation; either version 3 of the License, or
      (at your option) any later version.
      
      This program is distributed in the hope that it will be useful, but
      WITHOUT ANY WARRANTY; without even the implied warranty of
      MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
      General Public License for more details.
      
      You should have received a copy of the GNU General Public License
      along with this program; if not, see <https://www.gnu.org/licenses/>.
      
      As a special exception to the GNU General Public License, if you
      distribute this file as part of a program that contains a
      configuration script generated by Autoconf, you may include it under
      the same distribution terms that you use for the rest of that
      program.  This Exception is an additional permission under section 7
      of the GNU General Public License, version 3 ("GPLv3").
      
      
      (The condition for the exception is fulfilled because
      ICU4C includes a configuration script generated by Autoconf,
      namely the `configure` script.)
      
      ----------------------------------------------------------------------
      
      File: install-sh (only for ICU4C)
      
      
      Copyright 1991 by the Massachusetts Institute of Technology
      
      Permission to use, copy, modify, distribute, and sell this software and its
      documentation for any purpose is hereby granted without fee, provided that
      the above copyright notice appear in all copies and that both that
      copyright notice and this permission notice appear in supporting
      documentation, and that the name of M.I.T. not be used in advertising or
      publicity pertaining to distribution of the software without specific,
      written prior permission.  M.I.T. makes no representations about the
      suitability of this software for any purpose.  It is provided "as is"
      without express or implied warranty.
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------------------------------------------------------------

This product includes XercesC.

    NOTICE file corresponding to section 4(d) of the Apache License, Version 2.0, in this
 case for the Apache Xerces distribution.

    This product includes software developed by
    The Apache Software Foundation (http://www.apache.org/).

    Portions of this software were originally based on the following:
     - software copyright (c) 1999, IBM Corporation., http://www.ibm.com.
    
------------------------------------------------------------

This product includes OpenSSL.

      Copyright (c) 1998-2019 The OpenSSL Project.  All rights reserved.

      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions
      are met:

      1. Redistributions of source code must retain the above copyright
         notice, this list of conditions and the following disclaimer.

      2. Redistributions in binary form must reproduce the above copyright
         notice, this list of conditions and the following disclaimer in
         the documentation and/or other materials provided with the
         distribution.

      3. All advertising materials mentioning features or use of this
         software must display the following acknowledgment:
         "This product includes software developed by the OpenSSL Project
         for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

      4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to
         endorse or promote products derived from this software without
         prior written permission. For written permission, please contact
         openssl-core@openssl.org.

      5. Products derived from this software may not be called "OpenSSL"
         nor may "OpenSSL" appear in their names without prior written
         permission of the OpenSSL Project.

      6. Redistributions of any form whatsoever must retain the following
         acknowledgment:
         "This product includes software developed by the OpenSSL Project
         for use in the OpenSSL Toolkit (http://www.openssl.org/)"

      THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY
      EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
      PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE OpenSSL PROJECT OR
      ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
      SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
      NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
      LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
      HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
      STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
      ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
      OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes OpenSSL.

      Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)
      All rights reserved.

      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions
      are met:
      1. Redistributions of source code must retain the copyright
         notice, this list of conditions and the following disclaimer.
      2. Redistributions in binary form must reproduce the above copyright
         notice, this list of conditions and the following disclaimer in the
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         documentation and/or other materials provided with the distribution.
      3. All advertising materials mentioning features or use of this software
         must display the following acknowledgement:
         "This product includes cryptographic software written by
         Eric Young (eay@cryptsoft.com)"
         The word 'cryptographic' can be left out if the rouines from the library
         being used are not cryptographic related :-).
      4. If you include any Windows specific code (or a derivative thereof) from
         the apps directory (application code) you must include an acknowledgement:
         "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

      THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND
      ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
      ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
      FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
      DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
      OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
      HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
      LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
      OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
      SUCH DAMAGE.
    
------------------------------------------------------------

This product includes lzw-ab.

    Copyright (c) David Bryant
    All rights reserved.

    Redistribution and use in source and binary forms, with or without
    modification, are permitted provided that the following conditions are met:

    * Redistributions of source code must retain the above copyright notice,
      this list of conditions and the following disclaimer.
    * Redistributions in binary form must reproduce the above copyright notice,
      this list of conditions and the following disclaimer in the
      documentation and/or other materials provided with the distribution.
    * Neither the name of Conifer Software nor the names of its contributors
      may be used to endorse or promote products derived from this software
      without specific prior written permission.

    THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
    AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
    IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
    ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR
    ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
    DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
    SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
    CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
    OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
    OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes LibTIFF.

      Copyright (c) 1988-1997 Sam Leffler
      Copyright (c) 1991-1997 Silicon Graphics, Inc.

      Permission to use, copy, modify, distribute, and sell this software and
      its documentation for any purpose is hereby granted without fee, provided
      that (i) the above copyright notices and this permission notice appear in
      all copies of the software and related documentation, and (ii) the names of
      Sam Leffler and Silicon Graphics may not be used in any advertising or
      publicity relating to the software without the specific, prior written
      permission of Sam Leffler and Silicon Graphics.

      THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,
      EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
      WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

      IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR
      ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND,
      OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
      WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF
      LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
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      OF THIS SOFTWARE.
    
------------------------------------------------------------

This product includes robin-map.

      MIT License

      Copyright (c) 2017 Thibaut Goetghebuer-Planchon <tessil@gmx.com>
      
      Permission is hereby granted, free of charge, to any person obtaining a copy
      of this software and associated documentation files (the "Software"), to deal
      in the Software without restriction, including without limitation the rights
      to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
      copies of the Software, and to permit persons to whom the Software is
      furnished to do so, subject to the following conditions:
      
      The above copyright notice and this permission notice shall be included in all
      copies or substantial portions of the Software.
      
      THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
      IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
      FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
      AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
      LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
      OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
      SOFTWARE.      
    
------------------------------------------------------------

This product includes FreeType.

    Portions of this software are copyright (C) 2014 The FreeType
    Project (www.freetype.org) licensed under the Freetype License.
    All rights reserved.
    
------------------------------------------------------------

This product includes JBIG2Lib.

    Portions of this product copyrights (C) 2002 Glyph & Cog, LLC.
    
------------------------------------------------------------

This product includes ZXing C++ Library.

    Copyright 2016 ZXing authors.
    https://github.com/zxing
    
------------------------------------------------------------

This product includes leptonica.

 -  Copyright (C) 2001-2016 Leptonica.  All rights reserved.
 -
 -  Redistribution and use in source and binary forms, with or without
 -  modification, are permitted provided that the following conditions
 -  are met:
 -  1. Redistributions of source code must retain the above copyright
 -     notice, this list of conditions and the following disclaimer.
 -  2. Redistributions in binary form must reproduce the above
 -     copyright notice, this list of conditions and the following
 -     disclaimer in the documentation and/or other materials
 -     provided with the distribution.
 -
 -  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
 -  ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
 -  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
 -  A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL ANY
 -  CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
 -  EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 -  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 -  PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
 -  OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 -  NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 -  SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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------------------------------------------------------------

This product includes FCollada.

      Copyright 2006 Feeling Software. All rights reserved.

      Copyright 2005-2006 Feeling Software and
      Copyright 2005-2006 Autodesk Media Entertainment.

      Copyright (C) 1998-2003 Daniel Veillard. All Rights Reserved.

      Permission is hereby granted, free of charge, to any person obtaining a copy
      of this software and associated documentation files (the "Software"), to deal
      in the Software without restriction, including without limitation the rights
      to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
      copies of the Software, and to permit persons to whom the Software is fur-
      nished to do so, subject to the following conditions:

      The above copyright notice and this permission notice shall be included in
      all copies or substantial portions of the Software.

      THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
      IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FIT-
      NESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL THE
      AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
      LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
      OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
      THE SOFTWARE.
    
------------------------------------------------------------

This product includes JDFLibC.

   This product includes software developed by the The International Cooperation for the
 Integration of Processes in Prepress, Press and Postpress (www.cip4.org)
   
   Copyright (c) 2001-2020 The International Cooperation for the Integration of Processes
 in Prepress, Press and Postpress (CIP4). All rights reserved.
   
   Licensee of the CIP4 Software expressly acknowledges and agrees that any use of the
 CIP4 Software is at the sole and entire risk of the user. 
   The CIP4 Software is provided "as is" without warranty, upgrades or support of any
 kind. 
   CIP4 expressly disclaims any expressed or implied warranties, including, but not
 limited to, 
   the implied warranties of merchantability, fitness for a particular purpose, and non-
infringement of third party rights. 
   CIP4 does not warrant that the operation of the CIP4 Software will be error-free or
 that defects in the CIP4 Software will be corrected.
 
------------------------------------------------------------

This product includes tessdata.

 Inc. Licensed under the Apache License, Version 2.0
    
------------------------------------------------------------

This product includes XMP Toolkit.
Copyright (c) 2020, Adobe
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this
   list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice,
   this list of conditions and the following disclaimer in the documentation
   and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its
   contributors may be used to endorse or promote products derived from
   this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
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AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
------------------------------------------------------------

This product includes Imath.

      Copyright Contributors to the OpenEXR Project. All rights reserved.

      Redistribution and use in source and binary forms, with or without modification,
 are permitted provided that the following conditions are met:

      1. Redistributions of source code must retain the above copyright notice, this list
 of conditions and the following disclaimer.

      2. Redistributions in binary form must reproduce the above copyright notice,
 this list of conditions and the following disclaimer in the documentation and/or other
 materials provided with the distribution.

      3. Neither the name of the copyright holder nor the names of its contributors may
 be used to endorse or promote products derived from this software without specific prior
 written permission.

      THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
 AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
 WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN
 NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
 INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
 PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
 INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
 LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
 OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes QtWebEngine.

      The software uses QtWebEngine, licensed under LGPL v3. The Qt Toolkit is Copyright
 (C) 2019 The Qt Company Ltd.
    
------------------------------------------------------------

This product includes chromium.

        Copyright 2015 The Chromium Authors. All rights reserved.

        Redistribution and use in source and binary forms, with or without
        modification, are permitted provided that the following conditions are
        met:

           * Redistributions of source code must retain the above copyright
        notice, this list of conditions and the following disclaimer.
           * Redistributions in binary form must reproduce the above
        copyright notice, this list of conditions and the following disclaimer
        in the documentation and/or other materials provided with the
        distribution.
           * Neither the name of Google Inc. nor the names of its
        contributors may be used to endorse or promote products derived from
        this software without specific prior written permission.

        THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
        "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
        LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
        A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
        OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
        SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
        LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
        DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
        THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
        (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
        OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC Profiles were created by FFEI Ltd. (www.ffei.co.uk) using Fujifilm
    ColourKit Profiler Suite (www.colourprofiling.com)
    
------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC profiles are copyright (C) by European Color Initiative, www.eci.org
    
------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC profiles are copyright (C) of WAN-IFRA, www.wan-ifra.org
    
------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC profiles are copyright (C) IDEAlliance(R). G7(R), GRACol(R) and
    SWOP(R) are all registered trademarks of IDEAlliance(C).
    
------------------------------------------------------------

This product includes PANTONE Color Libraries.

    PANTONE® and other Pantone trademarks are the property of Pantone LLC.
    Pantone is a wholly owned subsidiary of X-Rite, Incorporated.
    
------------------------------------------------------------

This product includes curl.

   COPYRIGHT AND PERMISSION NOTICE

   Copyright (c) 1996 - 2023, Daniel Stenberg, <daniel@haxx.se>, and many
   contributors, see the THANKS file.

   All rights reserved.

   Permission to use, copy, modify, and distribute this software for any purpose
   with or without fee is hereby granted, provided that the above copyright
   notice and this permission notice appear in all copies.

   THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
   IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
   FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN
   NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
   DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
   OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
   OR OTHER DEALINGS IN THE SOFTWARE.

   Except as contained in this notice, the name of a copyright holder shall not
   be used in advertising or otherwise to promote the sale, use or other dealings
   in this Software without prior written authorization of the copyright holder.
    
------------------------------------------------------------

This product includes Bonjour SDK.

   Copyright (c) 2003-2004, Apple Computer, Inc. All rights reserved.
  
   Redistribution and use in source and binary forms, with or without 
   modification, are permitted provided that the following conditions are met:
  
   1.  Redistributions of source code must retain the above copyright notice, 
       this list of conditions and the following disclaimer. 
   2.  Redistributions in binary form must reproduce the above copyright notice, 
       this list of conditions and the following disclaimer in the documentation 
       and/or other materials provided with the distribution. 
   3.  Neither the name of Apple Computer, Inc. ("Apple") nor the names of its 
       contributors may be used to endorse or promote products derived from this 
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       software without specific prior written permission. 
  
   THIS SOFTWARE IS PROVIDED BY APPLE AND ITS CONTRIBUTORS "AS IS" AND ANY 
   EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
   WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 
   DISCLAIMED. IN NO EVENT SHALL APPLE OR ITS CONTRIBUTORS BE LIABLE FOR ANY 
   DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
   (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; 
   LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND 
   ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
   (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS 
   SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes QtDeclarative.

      The Qt Toolkit is Copyright (C) 2019 The Qt Company Ltd.
    
------------------------------------------------------------

This product includes Enfocus PitStop.

      "Convert fill to stroke" Action, Patent Pending
 
------------------------------------------------------------

1.2.  Installation

ArtPro+ is only supported on 64-bit operating systems, both on Mac and on Windows. Currently
supported are:

• macOS 11 (on Intel and on Apple Silicon), macOS 12 (Monterey, Intel and Apple Silicon), macOS 13
(Ventura, Intel and Apple Silicon) and macOS 14 (Sonoma, Intel and Apple Silicon).

• Windows 10 and Windows 11.

You can download the installer for ArtPro+ from http://mysoftware.esko.com.

Download the ArtPro+.dmg file for Mac, or the .exe file for Windows.

1.3.  Licensing

You can check the Licenses info by choosing Help > License Info ....

You can run ArtPro+ with a valid local license, by connecting to a license server carrying valid network
licenses, or by signing in to a Named User Subscription or a Dynamic Subscription. More information
on licenses and how to activate them can be found here: https://www.esko.com/en/Support/Product?
id=Licensing%20and%20Activation.

ArtPro+ Essentials, ArtPro+ Layout and ArtPro+ Digital
ArtPro+ always needs one of the base "Edition" licenses: ArtPro+ Essentials, ArtPro+ Layout or ArtPro+
Digital. Additional licenses (see below) can add extra functionality.

With one of the Edition license you can use most of the basic editing and quality control tools. The
table below shows the differences between ArtPro+ Essentials, ArtPro+ Layout and ArtPro+ Digital:
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Funtionality ArtPro+ Essentials ArtPro+ Layout ArtPro+ Digital

Action Lists

• Export to PDF on
page 66

• Export to Gravure
TIFF on page 67

• Export Structural
Design on page 69

• Export to JDF Layout
on page 71

• Export to CIP3 on
page 71

Convert Outlines to Text

• Text in Path

• Text on Path

• Select Same

• Select Advanced on
page 151

Named Objects

Convert to Barcode

Rich Black

Shaper

Manual Trapping

Working with Trap Tags
on page 332

Clean

Trace Image on page
218

• Image Extract and
Link
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Funtionality ArtPro+ Essentials ArtPro+ Layout ArtPro+ Digital
• Replace Placed Art

on page 225

Step & Repeat incl.
opening a Layout file

• Ink Eater Areas on
page 313

• Screening on page
316

• Ink Coverage on
page 119

Recolor: Replace

Quality Control on page
103

Only Compare, Digital
Print and Total Area
Coverage

Warp: Place Warp Grid

Note:  Functionality not specifically mentioned in this table, and not protected by an ArtPro
+ Advanced or other additional license (see below) is available in ArtPro+ Essentials, ArtPro+
Layout and ArtPro+ Digital.

ArtPro+ Advanced
An ArtPro+ Advanced license adds the following functionality (when not yet available in your Edition
license):

• Grid Step & Repeat. See Grid Step & Repeat on page 343

• Open Layout CF2 Files, MFG files, JDF files from Phoenix, Replace Structural Design stations &
Adjust Bleed tool. See Step & Repeat based on an MFG or CF2 file on page 358

• Manual and Automatic Trapping. See Trapping on page 320

• Create Conical Grid from Conical Label Outline on page 337

Note:  Combining an ArtPro+ Essentials and ArtPro+ Layout Edition license will result in the
same functionality as ArtPro+ Essentials and ArtPro+ Advanced. Keep in mind that this does
not make optimal use of your licenses, as certain functionality is licensed twice.

Additional Licenses

Note:  Additional Licenses can be combined with any of the Edition licenses without
restrictions.

• ArtPro+ Plate Cut: You need this license to create Plate Cutting Paths. See Create Automatic Plate
Cutting Paths on page 372

• ArtPro+ GMG OpenColor Connector: You need this license to use the GMG OpenColor Server as
color management tool in ArtPro+. See GMG OpenColor on page 99.
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• ArtPro+ Equinox: You need this license to use the Equinox functionality in the Recolor function.
See Recolor on page 190. Note that this is different from the Equinox module licenses for ArtPro or
PackEdge / Plato.

• ArtPro+ Variable Data Expansion: You need this license to export Variable Data. See Variable Data
on page 481

• Studio Designer: You need this license to get a 3D view of files with a structural design file. See
Studio in ArtPro+ on page 473

• With a Studio Toolkit for Labels license you can revolve a path in Studio Toolkit (see Creating
a revolved shape with labels on page 474), create a label based on its outlines (see Creating a
label from Curves on page 476) and apply predistortion based on the structural design file in the
document (see Predistortion on page 477),

• With a Studio Toolkit for Shrink Sleeves license you can revolve a path in Studio Toolkit (see
Creating a revolved shape with labels on page 474) and apply shrink sleeve warp (see Shrink Sleeve
Warp on page 339).

When launching ArtPro+
• To work with ArtPro+, you need one of the Edition licenses: ArtPro+ Essentials, ArtPro+ Layout or

ArtPro+ Digital. If this base license is missing, you must activate a local license, define a License
Server or work with subscriptions before you can continue.

• If local licenses or subscriptions are found for ArtPro+ Advanced or the additional licenses, they will
always be used.

• If any of the remaining licenses are enabled in the License Info panel, ArtPro+ will search for these
on a defined License Server. If these additional licenses are not found when launching ArtPro+, the
License Info panel will pop up, and you can choose:

• you can disable the license. This means that ArtPro+ will no longer check for that license on the
License Server

• you can continue the ArtPro+ session without the license. Next time you launch ArtPro+, ArtPro+
will search for the license again.

• you can quit the application, e.g. if you first want to ask another operator to release the license.

You can check the license status or change what licenses to check for at any time by going to Help >
License Info. See The ArtPro+ License Info panel on page 32

1.3.1.  The ArtPro+ License Info panel

You can open the ArtPro+ License Info panel by choosing Help > License Info...

The License Info panel will show you information on the current license you are using.
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Types of Licenses
• a Local License: a temporary or perpetual license that is activated in the Local License Manager on

the computer that is running the software.

• a Named User Subscription: a subscription based license that is activated in the cloud. The license
is personal, connected to the Esko ID. To activate a Named User Subscription, you need to sign in
using your Esko ID in the Help > Subscriptions dialog.

Note:  The Subscriptions dialog doesn't provide a Sign In option for the additional Studio
license. To use Studio Subscriptions, you can sign in via the Studio Toolkit application or the
Studio plugins in Adobe Illustrator.

• a Dynamic Subscription: one or more subscription based licenses that are activated in the cloud.
The License Administrator can assign Dynamic Subscriptions to a team or group, based on their
Esko ID. When launching the software, a license from the Dynamic Subscriptions will be used on a
first come first serve base. To activate a Dynamic Subscription, you need to sign in using your Esko
ID in the Help > Subscriptions dialog.

Note:  Dynamic Subscriptions can only be used in ArtPro+ 22.11 and later.

• a Network License: one or more temporary or perpetual licenses activated in the Network License
Manager on a server in your local network. When launching the software, a license from the
Network License Manager will be used, on a first come first serve base. If you don't have a License
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Server set up already, you can click Define a License Server, and enter the name of the License
Server you want to connect to. If you already have a License Server set up, the name of the License
Server is shown here. You can click Change to connect to a different License Server.

ArtPro+ will activate licenses in the order as they are described above. For example, when a Local
License is available, this license will be used, even if a Subscription or Network license is available.
Network Licenses are only used if no Local License or Subscription is available.

For any valid license that is found and used by the application, a green status bullet will be shown. If a
license is requested (enabled) but not found, a red status bullet will be displayed.

(De)activating Licenses
• You can disable additional License Server licenses. ArtPro+ will then no longer try to use it when

starting up. By default, all additional licenses are enabled.
• Local licenses or subscriptions can't be deactivated in the License Info dialog. To manage your local

licenses, use the Local License Manager. You can open the Local License Manager by selecting
Open Local License Manager from the fly-out menu. For more information on activating local
licenses, we refer to the Licensing and Activation documentation: https://www.esko.com/en/
Support/Product?id=Licensing%20and%20Activation

• To sign in on or sign out of your Named User Subscriptions or Dynamic Subscriptions, choose Help
> Subscriptions..., or use the corresponding item from the fly-out menu of the License Info dialog.

Note:  Disabling or enabling a module is effective immediately, so the corresponding menu
items and functions will no longer be available.

1.4.  What's New in ArtPro+ 24.03

Below is a list of changes in ArtPro+ 24.03 and a link to the specific page in the documentation. For
a full overview of bug fixes, you can check the Release Notes. You can also consult the What's New
presentation

• Step & Repeat:

• You can now convert a grid into a Static Grid. This allows you to replace the graphics for a
number of stations. See Convert to Static Grid on page 357

• The "Die Shape" setting has been moved from the Placed Art Inspector to the Grid Inspector. The
Grid Inspector now also shows the "Station Rotation" and the "Cell Size", i.e. the station size. See
The Grid Inspector on page 344

• You can now import Position Placeholders when placing an ARD file. The Position Placeholders
will be included if you use the "Full", "Full (single separation) or the new "Placeholders" profile.
See Structural Design File Inspector on page 229. Position Placeholders can be used to position
a Barcode Mark. See Barcode Mark on page 404

• Quality Control:

• You now have the Flexo Plate Preview option to inspect how the Flexo plates of your document
will look per separation: see Flexo Plate Preview on page 104

• You can now compare the stations of a layout to a 1-up reference file. See Compare Layout
Stations to a One-Up on page 114
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• When doing a Compare, you can now use the Densitometer tool to see the densities of the
reference document when holding C. See Compare on page 110

• White Underprint: You can now decide what separation to use for the White Underprint, and you
can now also apply White Underprint on Dynamic Marks. See White Underprint on page 311.

• When you Add Dimensions, you can now choose to remove trailing zeros, and you can now use a
custom separation. See Add Dimensions on page 308.

• For all objects tagged with a color profile, you will now see the Color Space. See Objects, groups or
pages susceptible to color conversion on page 98

• When creating Plate Cutting Paths, you can now define a Clip at Bleed distance to apply bleed
outside the Plate Cutting Paths. See Create Automatic Plate Cutting Paths on page 372

• You can now apply Smoothen Path settings on any closed path. See Smoothen Path on page 175.
These settings are similar to the settings in the Traced Image inspector.

• The Transform tool now has a new mode: Scale and Rotate. See Scale and Rotate on page 161

• Using Fit to Page Box, you can scale selected objects proportionally to fit the selected page box.
See Fit to Page Box on page 166

Improvements:

• When replacing a Linked Image, you can now choose if you want to keep the channel mapping of the
image. See Replacing an image on page 216

• Automatic Trapping will now create more pullbacks (when enabled) and makes more aesthetic
choices in a chain, as Automatic Trapping now evaluates the context of graphics to decide on the
set of colors to keep. As a result, less manual checking and finetuning will be necessary.

• When copy and pasting text from one text box to another in ArtPro+, the text formatting will be
kept. You can use Paste and Match Style to paste the text in the current style of the caret. See Cut,
Copy and Paste on page 153

• When connected to Share & Approve, you can now download an Annotation and Approval Report.
See Download Annotation and Approval Report on page 82

• Marks:

• When creating a Point Text Mark or Area Text Mark from selection, the Leading value is now
kept. It can be modified in the Text Inspector. See Point Text Mark and Area Text Mark on page
384

• In Smart Text in Marks, you can now choose to Remove trailing zeros at the end of a decimal
number. See Formatting Dynamic Fields on page 388

• Using Select Advanced or the corresponding Action Select Objects by Attribute you can now
select objects with or without applied Screening. See also Select Advanced on page 151 and
Select Objects by Attribute on page 453

Miscellaneous

• Emergency Save: ArtPro+ will automatically create backups for unsaved open documents in a
temporary folder, and will recover these when opening ArtPro+ after a carsh or forced quit. See
Emergency Save on page 65
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• If you open a legacy ArtPro Step & Repeat file, even though the one-ups are embedded, the link to
the one-ups is kept. See Opening ArtPro Step & Repeat Files on page 62. You can use the Replace
Embedded Placed Art action to replace such links by a PDF file with the same name. See Replace
Embedded Placed Art on page 448

Action Lists

• New Action Select Artwork Separations. See Select Artwork Separations on page 451

• New Action Remove Separations from Object. See Remove Separations from Object on page 445

• New Action Remove Color Profiles. See Remove Color Profiles on page 444

• New Action Replace Embedded Placed Art. See Replace Embedded Placed Art on page 448

• New Action Fit to Page Box. See Fit to Page Box on page 438

• In the White Underprint actions, you can now decide what separation to use for the White
Underprint, and you can now also apply White Underprint on Dynamic Marks. See Add White
Underprint on page 428 and Subtract White Underprint on page 464

• In the Action Select Separations by Processing Step you can now define for what Processing Step
the separations should be selected for. See Select Separations by Processing Step on page 455

• You can now use Action List Parameters in Formulas. See Parameters in Action Lists on page 467
and Formulas in Action Lists on page 469

• In Variable Data, you can now check if text fits in its dedicated space. See The Checks Inspector on
page 493

• In the Action Select Separations by Printing Method you can now use wildcards for custom Printing
Methods.

• In the Action Run Existing Action List, used to embed an existing Action List, the description of the
embedded Action List is now shown in the Action List Editor. See Run Existing Action List on page
450

• In the Action Select By Attribute you can now select Dynamic Marks of a specified Mark Type, by
selecting "Object Type", "Is Dynamic Mark"

1.5.  The About palette

You can open the About window by choosing ArtPro+ > About (Mac) or Help > About (Windows).

The About palette contains build information, copyrights and a Legal Notices button.

Clicking Legal Notices will show the legal information. By clicking Done you go back to the default view.

1.6.  Getting help

There are several menu items in the Help menu:
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1. Clicking Getting Started will open a window that gives a quick tour on ArtPro+ tools and a link to the
ArtPro+ eLearning modules. After a first installation, this window will appear automatically when
starting the application.

2. Clicking What's New will open a presentation on the new functions in ArtPro+.
3. Clicking Online Help will open the Online Help page of your current ArtPro+ version in your internet

browser. When available, the online help will open in your currently selected language.
4. Clicking eLearning... takes you to an overview of all ArtPro+ eLearning modules. You need to log in

using your Esko ID for this.
5. Clicking Knowledge Base will open Esko's Knowledge Base in your internet browser, filtering on

articles about ArtPro+.
6. Click Dashboard to open the Dashboard or enable it. See Dashboard on page 37
7. Use License Info to check your license settings. For subscription licenses, there is also a Sign In /

Sign Out option. See Licensing on page 29

1.7.  Languages

ArtPro+ is supported in English, French, Italian, German, Spanish, Japanese, Simplified and Traditional
Chinese and Korean.

There are no application specific preferences to change the language. To see the user interface of
ArtPro+ localized in one of these supported languages:

• On MacOS, go to System Preferences > Language & Region and move your preferred language to
the top of the languages list.

• On Windows 10, go to Control Panel > Clock and Region > Region and change the Format to the
preferred language.

• On Windows 11, go to Control Panel > Time & Language > Language & Region > Region and change
the Regional Format to the preferred language.

1.8.  Dashboard

On your ArtPro+ Dashboard, you can:

• See which features you use, and how often,
• Learn how many files are processed with your ArtPro+,
• Get configurable reports for your company.
• Get personalised suggestions and complimentary training.

To build the dashboard, Esko needs to collect personal data about your ArtPro+ usage.

1. Open the Dashboard panel by choosing Help > Dashboard...
2. Click the Yes, I want a dashboard button.
3. Sign in with your Esko ID

More information about Esko ID can be found here

Note:  If you already enabled Dashboard before, you can skip step 2 and 3.
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4. Click the Go to my Esko ArtPro+ Dashboard link to open the Dashboard

1.8.1.  Opt Out

At any time, you can opt out and stop the personal data collection.

1. Open the Dashboard panel by choosing Help > Dashboard...
2. Click the Opt Out button.
3. If you click Opt Out, Esko stops collecting personal data, but still gathers anonymous usage data to

help us improve the product.

1.8.2.  More about the dashboard and data collection

Insights for you and your team
You will get a dashboard for ArtPro+ where you can check that you are getting the most out of your
software investment. You can filter on those features that are the most valuable to you, and keep track
of how often they are used, how many files are handled, and by how many people across your company.
If your colleagues also opt in, you can also combine the data in a single dashboard for your company.

What data is collected?
We automatically collect your ArtPro+ usage:

• Basic information about your computer (OS version, language, screen resolution, ...).
• Your version of ArtPro+.
• Which actions you perform on ArtPro+, including some of their parameters.

If you opt in to the dashboard, then this usage data is tagged with your EskoID (name and email). If you
do not opt in, then this usage data is anonymous.

Either way, We do not collect information that can be used to identify your client or the designs that
you work on (such as text statements, barcodes, separation names or filenames).

Your data is protected
Your usage data will be available only to Esko and (if you opt-in) to you and to your colleagues (based on
the company code of their Esko IDs). Learn more about Esko ID and check out our privacy policy.

Help us improve our products
Sharing your usage data with Esko allows us to learn about your configuration and your use of our
products. This data enables us to focus on the features that matter the most to you.

Opt out whenever you want
At any time, you can opt out and stop sharing personal data. Just choose Help > Dashboard... and click
the Opt Out button.
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2.  Getting Started

Note:

Besides this user guide, you can also find related documentation and a number of introduction
videos on the ArtPro+ product page on Esko's help pages: https://www.esko.com/en/Support/
Product?id=ArtProPlus

You can also find interactive courses about different subjects on Esko's eLearning pages:
https://www.esko.com/en/support/blendedlearning/artproplus

You can find documentation on Licensing and Activation here: https://www.esko.com/en/
support/product?id=Licensing%20and%20Activation

From within ArtPro+, you can easily access the user guide, what's new presentation, etc., from
the Help menu. See Getting help on page 36

2.1.  The ArtPro+ Workspace

When you launch the application, you get a blank application window (on Windows only), and the ArtPro
+ menu bar.

Once you've opened a document, this is what you can see in the ArtPro+ Workspace:

Note:  Based on the activated licenses, certain functions might be hidden or disabled. See
Licensing on page 29
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1. The menu bar
2. The Side Drawer buttons for Object Browser, Colors, Images, Placed Art, Messages, Action Lists

and Share & Approve. See Using the Side Drawer on page 41
3. The Toolbar, containing

• Clean. See Clean on page 179,

• Select. See Select Same on page 150 and Select Advanced on page 151,

• Recolor. See Recolor on page 190

• Shaper. See Shaper on page 199,

• Barcode. See Barcode

• Screening. See Screening on page 316

• Trapping. See Trapping on page 320

• Warp. See Warp on page 334
4. The 3D button. See 3D View on page 473
5. The View Mode selector. See Preview or Outline mode on page 97
6. The Server Connection indicator. See Automation Engine connection on page 72
7. The Side Panel, containing a Document section (page navigator for multi-page documents,

Crosshair, Page Boxes, layers), Marks section, Separations section and Quality Control section. See
Using the Side Panel on page 42

8. The Selection Breadcrumbs. See Selection Breadcrumbs on page 149
9. The Inspector. See The Inspector on page 42
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10. The document pane

2.1.1.  Using the Side Drawer

The Side Drawer is a panel on the left side, that can show relevant information. You can make it visible
by selecting any of the Side Drawer buttons. Click another button to switch the content of the Side
Drawer, or click the active button to hide the Side Drawer again.

There are different Side Bar modes: Object Browser, Colors Side Drawer, Images Side Drawer, Placed
Art Side Drawer and Messages Side Drawer.

The Object Browser lists all layers, groups and objects in the document. The Object Browser has four
modes: the normal Object Browser, that lists all layers, groups and objects in the document, each with
their thumbnail, the Named Object Browser, that shows all named Objects in the document, the Trap
Tagged Objects, that lists all object with a Trap Tag defined, and the Plate Cutting Tagged Objects, that
lists all object with a Plate Cutting Tag defined. See Object Browser on page 130

The Colors Side Drawer lists all flat colors and gradients used in the current page of the open
document. See The Colors Side Drawer on page 117

The Images Side Drawer gives an overview of all images in the document. See Images Side Drawer on
page 217

The Placed Art Side Drawer shows a list of all placed PDFs used in the document. See Placed Art Side
Drawer on page 226

The Messages Side Drawer lists all errors, warnings and information (in this order) that require you
to take action. It is split up in different sections: Page Boxes, Preflight, Text, Barcodes, Processing
Step Layers and Others. The tooltip of the messages will give more information about the message.
Clicking on one of the entries will select the corresponding object(s) or layer(s) in the job. If the Zoom

to Selection  option is enabled, clicking an entry displays the selected objects as big as possible in
the active window.

If you open a document and active messages are already applicable, the Messages drawer will be
shown automatically.

Note:

Messages that do not require a user action are shown as "toast message", popping up at
the bottom left corner of the document window and automatically disappearing after a few
seconds.

By hovering over the toast message, you can keep the message visible for a longer time. By
right-clicking the toast message, you can choose Copy message to clipboard.

The Action List Side Drawer shows all available action lists, and allows you to run or edit the Action
Lists. See The Action List Side Drawer on page 421

The Share & Approve Side Drawer allows you to integrate ArtPro+ with Share & Approve. See Share &
Approve connection on page 78
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The Variable Data Side Drawer is only available when you're working on a Variable Data Template. See
Variable Data on page 481

2.1.2.  Using the Side Panel

The Side Panel contains several sections

• If you have a multi-page document open, you can use the Page Navigator. See Navigating a multi-
page document on page 121

• In the Document section you can make the Crosshair visible or invisible and set up the Page Boxes .
See The Crosshair on page 95 and Page Boxes on page 122.

• In the Layers part, you can reorder and rename layers, and view or change their visibility or printing
state. See Layers on page 124.

• In the Marks part, you can manage your marks: load and save Mark Sets, create new Marks, etc. See
Marks on page 381. This is not available for Normalized PDF files.

• In the Separations section, you can reorder and rename separations, make specific separations
visible or invisible, add printing separations, remove separations or merge separations. See
Separations on page 132.

• In the Quality Control section you can do some quality control, such as looking for breakouts below
a certain percentage, checking if the maximum Total Area Coverage is exceeded, checking the
used screen sets, detecting possible screening problems (moiré), simulating a registration error or
comparing two files. See Quality Control on page 103.

2.1.3.  The Inspector

The Inspectors, shown in the bar between the Selection Breadcrumbs and the Document Pane show
information and possible actions for the current selection, such as the current Fill and Stroke. Using
the Inspectors, you can change these settings for the current selection.

You can use the shortcut Cmd+i / Cmd+Shift+i (Mac) or Ctrl+i / Ctrl+Shift+i (Windows) to cycle through
all Inspectors, forwards or backwards. If no inspector is open, the first or last inspector will be opened.

Note:  The last opened Inspector is remembered. When you make a new selection, the
Inspector is reopened when applicable. You can close the automatically opened Inspector by
clicking it or using the Esc key.

General inspectors
• Fill Color and Stroke Color Inspector on page 182
• Stroke Inspector on page 188
• Transparency Inspector on page 189
• Transformation Inspector on page 164
• Effects Inspector on page 195
• Screen Set Inspector: see Screening on page 316

Inspectors for Images
• Image Inspector on page 213
• The Channel Mapping Inspector on page 214
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Inspectors for Placed Art & Grids
• Placed Art Separations Inspector on page 222
• Placed Art Inspector on page 223
• Placed Art Layer Types Inspector on page 224
• The Grid Inspector on page 344
• The Layout Inspector on page 347

Inspectors for Structural Design
• Structural Design File Inspector on page 229
• Structural Design Inspector on page 230

Inspectors for Text
• Text Inspector on page 200
• Text Box Transformation Inspector on page 202
• Glyph Inspector on page 204

Inspectors for Barcodes
• Barcode Type Inspector, Barcode Code Inspector, Barcode Inspector, Barcode Font Inspector: see

Barcodes on page 232

Inspectors for Marks
• Mark Inspector. See Mark Types and their properties on page 383

Note:  If the ArtPro+ window is not big enough to show all Inspectors for the current selection,
they can be reduced to an abbreviated version or even just the corresponding icon.

Inspectors for Variable Data
• Variable Data Objects Inspector. See Variable Data on page 481

2.1.4.  Changing tools

There are different ways to select a tool

• Use the tool's shortcut. Using the shortcut multiple times will toggle between related functions,
such as Zoom and Pan.

1. T: Text tool. See Using the Text Tool on page 202
2. R: Crosshair. See Move or rotate the Crosshair on page 95
3. R: Cut on Crosshair. See Cut on Crosshair on page 96
4. V: Group Select. See Group Select on page 146
5. V or A: Object Select. See Object Select on page 146
6. V: Path Select. See Path Select on page 147
7. V or L: Lasso Select. See Lasso Select on page 148
8. D: Densities. See Densities on page 116
9. D: Dimensions. See Dimensions on page 115
10. P: Create & Edit Path. See Create & Edit Path on page 170
11. P: Split & Retrace. See Split and Retrace on page 171
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12. P: Cut Path. See Cut Path on page 172
13. P: Adjust Corners. See Adjust Corners on page 174
14. S: Create a Rectangle. See Create Rectangle / Create Ellipse on page 198
15. S: Create an Ellipse. See Create Rectangle / Create Ellipse on page 198
16. E: Transform. See Transforming manually on page 158
17. E: Scale and Rotate. See Scale and Rotate on page 161
18. E: Align & Distribute. See Align & Distribute on page 165
19. Z: Zoom. See Zoom tool on page 94
20.Z or H: Pan Tool. See Pan tool on page 94

• Using the Tool Switcher: right-click anywhere in your document, and select the tool you want in the
tool switcher wheel, or right-drag in the corresponding direction.

Note:

The quickest way to change tools, is to (briefly) right-drag (or drag while holding the
control key on Mac) in the direction of the tool you need, e.g. up for Text tool Select, left for
Transform, etc. You can save time this way, because you don't have to click exactly on the
tool.

For subtools (such as Zoom and Pan), this will select the default (left) option. To select the
other subtool, you will have to click it.

2.1.5.  Shortcuts overview

Below, you see an overview of the default ArtPro+ shortcuts on Mac and on Windows.
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By enabling the ArtPro Classic Shortcut Set in the Preferences, you can switch to a set of shortcuts
similar to the shortcuts in ArtPro, shown in the right column. All other shortcuts remain unchanged. In
the Preferences, you can also set custom keyboard shortcuts. See Preferences on page 49

The shortcuts mentioned in the rest of the user guide are the default ArtPro+ shortcuts.

Shortcut Mac Windows ArtPro Classic

Select All Cmd+A Ctrl+A

Deselect All Cmd+Shift+A Ctrl+Shift+A

Select Inverse Cmd+Alt+A Ctrl+Alt+A

Run Action List Cmd+Alt+Shift+A Ctrl+Alt+Shift+A

Page Boxes Cmd+B Ctrl+B

Add Barcode Cmd+Shift+B Ctrl+Shift+B

Convert to Barcode Cmd+Alt+Shift+B Ctrl+Alt+Shift+B

Copy Cmd+C Ctrl+C

Clean dialog Cmd+Shift+C Ctrl+Shift+C

Transform Again Cmd+D Ctrl+D

Warp Cmd+Shift+D Ctrl+Shift+D

Warp Using Last
Settings

Cmd+Alt+Shift+D Ctrl+Alt+Shift+D

Shaper Cmd+E Ctrl+E

Paste in Front Cmd+F Ctrl+F Cmd+Alt+F

Paste in Back Cmd+Shift+F Ctrl+Shift+F Cmd+Alt+Shift+F

Make Group Cmd+G Ctrl+G Cmd+Shift+G

Release Group Cmd+Shift+G Ctrl+Shift+G Cmd+Shift+U

Make Step & Repeat
Grid

Cmd+Alt+G Ctrl+Alt+G

Hide ArtPro+ Cmd+H not available

Hide Others Cmd+Alt+H not available

Cycle through
Inspectors (forwards)

Cmd+I Ctrl+I

Cycle through
Inspectors (backwards)

Cmd+Shift+I Ctrl+Shift+I

Select Same Fill Color Cmd+Alt+I Ctrl+Alt+I

Select Same Stroke
Color

Cmd+Alt+Shift+I Ctrl+Alt+Shift+I

Join Paths Cmd+J Ctrl+J

Close Path Cmd+Alt+J Ctrl+Alt+J
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Shortcut Mac Windows ArtPro Classic

Preferences Cmd+, (comma) Ctrl+K

Launch Workflow Cmd+L Ctrl+L Cmd+Alt+L

Add Dimensions Cmd+Shift+L Ctrl+Shift+L

Numeric Transform Cmd+Shift+M Ctrl+Shift+M Cmd+L

New File Cmd+N Ctrl+N

Open File Cmd+O Ctrl+O

Contourize Text Cmd+Shift+O Ctrl+Shift+O

Print Cnd+P Ctrl+P

Place Cmd+Shift+P Ctrl+Shift+P

Place Image Inside Cmd+Shift+Alt+P Ctrl+Shift+Alt+P

Page Boxes Setup Cmd+Alt+P Ctrl+Alt+P Cmd+Alt+J

Quit Cmd+Q Ctrl+Q

Show / Hide Crosshair Cmd+R Ctrl+R

Save Cmd+S Ctrl+S

Save As Cmd+Shift+S Ctrl+Shift+S

Screening window Cmd+Alt+S Ctrl+Alt+S

Update Trapping Layer Cmd+T Ctrl+T

Trapping dialog Cmd+Alt+T Ctrl+Alt+T

Spread / Choke Cmd+Shift+T Ctrl+Shift+T Cmd+0

Export Gravure Tiff Cmd+Alt+T Ctrl+Alt+T

Convert Outlines to Text Cmd+Shift+Alt+T Ctrl+Shift+Alt+T

Select Same /
Advanced

Cmd+U Ctrl+U Cmd+Alt+U

Paste Cmd+V Ctrl+V

Paste with Layer
Structure

Cmd+Shift+V Ctrl+Shift+V

Paste and Match Style Cmd+Shift+Alt+V Ctrl+Shift+Alt+V

Close File Cmd+W Ctrl+W

Close All Files Cmd+Alt+W Ctrl+Alt+W

White Underprint Cmd+Shift+W Ctrl+Shift+W

Cut Cmd+X Ctrl+X

Switch to Preview /
Outline

Cmd+Y Ctrl+Y

Color Managed Preview Cmd+Alt+Y Ctrl+Alt+Y
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Shortcut Mac Windows ArtPro Classic

Undo Cmd+Z Ctrl+Z

Redo Cmd+Shift+Z Ctrl+Shift+Z

Fit in Window / Previous Cmd+0 Ctrl+0 Cmd+F

Zoom to Selection Cmd+Alt+0 Ctrl+Alt+0 Cmd+Shift+F

Actual Size / Previous Cmd+1 Ctrl+1

Synchronize Views Cmd+Alt+1 Ctrl+Alt+1

Lock Cmd+2 Ctrl+2 Cmd+7

Unlock All Cmd+Alt+2 Ctrl+Alt+2 Cmd+8

Hide Cmd+3 Ctrl+3

Show All Cmd+Alt+3 Ctrl+Alt+3

Bring to Front Cmd+5 Ctrl+5

Bring Forward Cmd+Alt+5 Ctrl+Alt+5

Send Backward Cmd+Alt+6 Ctrl+Alt+6

Send to Back Cmd+6 Ctrl+6

Make Clipping Mask Cmd+7 Ctrl+7 Cmd+2

Release Clipping Mask Cmd+Alt+7 Ctrl+Alt+7 Cmd+Alt+2

Make Compound Cmd+9 Ctrl+9 Cmd+G

Release Compound Cmd+Alt+9 Ctrl+Alt+9 Cmd+U

Zoom in Cmd++ (plus) Ctrl++ (plus)

Zoom out Cmd+- (minus) Ctrl+- (minus)

Rotate View Clockwise Cmd+Shift++ (plus
numeric keypad)

Ctrl+Shift++ (plus)

Rotate View
Counterclockwise

Cmd+Shift+- (minus) Ctrl+Shift+- (minus)

Select Next Object Ctrl+Tab Ctrl+Tab

Select Previous Object Ctrl+Shift+Tab Ctrl+Shift+Tab

Cycle through
document windows

Cmd+` Alt+Tab

Go to First Page Cmd + Arrow Up Ctrl + Arrow Up

Go to Previous Page Page Up Page Up

Go to Next Page Page Down Page Down

Go to Last Page Cmd + Page Down Ctrl + Page Down

Show all separations 0 0

Show single separation 1 to 9 1 to 9
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Shortcut Mac Windows ArtPro Classic

Object Select A A

Dimensions / Densities D D

Transform/Scale
and Rotate/Align &
Distribute

E E

Pan H H

Lasso Select L L

Create & Edit Path tool/
Split and Retrace tool/
Cut Path Tool/Adjust
Corners

P P

Crosshair tool / Cut on
Crosshair tool

R R

Create Rectangle /
Create Ellipse

S S

Text tool T T

Group Select tool /
Object Select tool /
Path Select tool / Lasso
Select Tool

V V

Zoom tool / Pan tool Z Z

Switch between tabs Cmd+/ Ctrl+/

Note:  For shortcuts with digits (e.g. Cmd+6) it is advised to use the keys from the numeric
keypad.

Note:  Shortcuts that only apply if a specific function or tool is used are not mentioned in this
list.

2.1.6.  Modifier keys

Modifier Shortcuts only have effect as long as the key (or key combination) is held. Releasing the key
will return to the previously selected tool.

These allow to quickly and temporarily switch from one tool to another.

Modifier Mac Windows

Zoom In Modifier

See Zoom tool on page 94

Space+Cmd Space+Ctrl
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Modifier Mac Windows

Zoom Out Modifier

See Zoom tool on page 94

Space+Alt+Cmd Space+Alt+Ctrl

Zoom in/out using the scroll wheel of your mouse Alt Alt

Select Modifier

• activates Group Select if Object Select is active, and
vice versa

• If another tool is active, the last used Select tool is
activated

Cmd Ctrl

Pan Modifier

See Pan tool on page 94

Space Space

Crosshair Modifier

Note:  When using the Crosshair Modifier,
you can't rotate the Crosshair, nor can you
nudge the Crosshair using the arrow keys: the
Crosshair will snap to the selection or to the
page box.

See The Crosshair on page 95

Cmd+Alt Ctrl+Alt

Transform tool:

• Move: constrain position
• Scale: Proportional Scaling
• Rotate: constrain rotation angle to multiples of 45

degrees

Shift Shift

Transform tool:

• Move: copy
• Rotate: rotate around the object's center

Alt Alt

2.2.  Preferences

You can open the Preferences in two ways:

• By selecting ArtPro+ > Preferences (Mac) or Edit > Options (Windows).

• By its shortcut Cmd+, (Mac) or Ctrl+K (Windows).

The Preferences dialog has different tabs:

• General: see General Preferences on page 50

49



2 ArtPro+

• Keyboard: see Keyboard Preferences on page 52
• Automation Engine: see Automation Engine connection on page 72
• Color Management: see Color Management Preferences on page 53
• Printing Methods: see Printing Methods Preferences on page 54
• Preflight: see Manage Preflight Profiles on page 341
• Action Lists: see Action Lists on page 421
• Normalized PDF: see Normalized PDF Preferences on page 55
• Extensis: see Extensis Universal Type Client on page 205

2.2.1.  General Preferences

• Keyboard Increment: the distance used when moving by using the Arrow keys, e.g. to move the
Crosshair or selected objects. The value can be entered in any of the supported units. Holding the
Shift key while nudging will move the Crosshair or selected objects over 10 times the Keyboard
Increment distance.
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• Define the External Editor to be used when opening an image in an external editor. When set
to Default Image Editor, ArtPro+ will open images for editing in the latest version of Adobe
Photoshop that it can find on your computer. If no Photoshop is found, it will use the system's
default application for editing images. By selecting Other..., you can browse to and select another
application. See Opening images in an external editor on page 215

• Units: the default unit to use for Length, Area, Font, Stroke and Resolution for Gravure. For
Length, Font and Stroke the different units you can choose from are millimeter, centimeter, inch or
points. For Area, the different units you can choose from are millimeter2, centimeter2, decimeter2,
meter2 or inch2. For Resolution for Gravure, you can choose from Pixels per inch, Pixels per cm and
Pixels per mm.

• Numeric Field Display: Show Additional Decimals increases the amount of decimals shown in
Numeric Fields: input fields, dimensions, .… By default ArtPro+ shows a number of decimals
depending on the selected unit (e.g. 2 decimals for mm, 3 decimals for inch, …). Enabling this
option increases this number (e.g. 4 decimals for mm, 6 decimals for inch). Note that this does not
influence the internal accuracy, it is merely a rounding applied on the values as shown.

• Selection Color: the color used to indicate what objects are selected.

• Highlight Color: the color used when objects or areas are highlighted, e.g. when using Total Area
Coverage, Breakout or when in Trapping mode.

• Default Structural Design Profile: the default Profile to use when placing a Structural Design file.
See Structural Design Inspector on page 230

• Font Folder for Text Recognition: When set to "Use System Fonts Only", only activated system fonts
will be suggested when converting outlines to text. When selecting "Other" you can browse to a
folder - locally or a network shared folder - containing other fonts. In that case, Text Recognition will
show the "Best Matching Non-Activated Fonts" based on the fonts in the selected folder. You can
then activate the font(s) and rerun the Text Recognition. See Convert Outlines to Text on page 206

Note:  If you choose a network folder containing a substantial amount of fonts, this might
slow down the first Text Recognition you do.

• "Remember My Choice" Dialogs: A number of settings in specific dialogs can be stored by enabling
the Remember my Choice option. See for example the dialog below.

 

 

By clicking the Reset All button, ArtPro+ will "forget" all these settings, so the next time you will be
asked the question again.
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2.2.2.  Keyboard Preferences

 

 

• Select the set of Shortcut Scheme you want to use: either the default ArtPro+ shortcuts, or
ArtPro Classic, a set of shortcuts similar to the shortcuts in ArtPro. Menu items and shortcuts are
changed immediately. Click the What's in this scheme link to see an overview of the differences.
See Shortcuts overview on page 44.

• You can change, remove or add a shortcut in the list below.

• Select the Category of function or command you want to change

• For the function you want to change, double-click the Shortcut area.

• Click the x button to remove the shortcut, or press the shortcut you want to use for that
function.

• Custom keyboard shortcuts must include at least one function key or a modifier key other than
the Shift key. (You can use Shift in combination with another modifier key, such as Alt)

• If the shortcut you entered is already assigned to another function, both functions will show an
exclamation mark. Resolve this conflict as soon as possible.

• A number of keyboard shortcuts are fixed by the operating system, and can't be changed. For
example Cmd+Q on Mac, or Alt+F4 on Windows. In case you try to set such a keyboard shortcut, a
warning will be shown. Click the link in the warning message to see all non-editable shortcuts for
your operating system.
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• When setting a shortcut for an Action List, you can enable the checkbox in the last column so
that the shortcut will run the Action List "With Options". See Run With Options on page 423

• The scheme will become "Customized". If you change the scheme to ArtPro+ or ArtPro Classic,
custom keyboard shortcuts will be discarded.

Note:  When working on Mac OS, make sure you enable the setting Use F1, F2, etc. keys as
standard function keys in the Keyboard section of your System Preferences if you want to use
the Function keys in custom shortcuts.

2.2.3.  Color Management Preferences

Color Engine Data: by default, ink books are read from the Standard Color Engine Data, installed when
installing ArtPro+.

By selecting From Automation Engine, the CMS from the Automation Engine you're connected to will
be used. If this is an Automation Engine SaaS server, the Color Data from the Automation Engine will be
synced when ArtPro+ is launched.

By selecting Other..., you can browse to a CMS tree on a remote computer (e.g. from PackEdge,
Automation Engine or Color Engine) and use those ink books instead. If connection to this remote
computer is lost, a warning will be shown, and the local CMS is used again.
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Note:  Although the preview can change, changing the CMS (and ink books) doesn't change
the ink information saved in the file for existing inks. The new ink books are only used when
creating a new ink or changing an existing ink.

The Default Document Profile is used for rendering the document when Color Managed Preview is on
and the Document does not have a profile yet. It is also added as output intent to PDF+ files that do not
have a Document Profile yet. See Color Management on page 98

The Preferred Ink Book Order section of the Preferences lets you set up the order of the available
Ink Books. When creating a new ink, or modifying an existing ink, ArtPro+ will suggest inks based on
what you type in the input field. The results will be ordered based on the order of the Ink Books in the
Preferences. See also Adding or changing a separation on page 135

You can change the order of the Ink Books by simply dragging and dropping them.

GMG OpenColor Server: if you want to use a GMG OpenColor Server as Color Management tool, you can
enter the server addresss here. For more information, see GMG OpenColor on page 99

2.2.4.  Printing Methods Preferences

 

 

In this tab you can manage the Printing Methods available in the Separations Setup. See Separations
Setup on page 136.

If you are connected to an Automation Engine server, you will see and manage the server printing
methods. If you are not connected to an Automation Engine server, you can see and manage the local
printing methods, stored on your computer.
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You can click the + button to add a custom printing method, or click the - button to remove the selected
custom printing method. The Printing Methods defined here are available in the dropdown in the
Separations Setup, along with the default Printing Methods as shown in the right column.

2.2.5.  Normalized PDF Preferences

 

 

Normalized PDF does not support Processing Step Layers, while PDF+ does not support technical inks.
Therefore, when placing a Normalized PDF file in a PDF+ file or when converting a Normalized PDF to
PDF+, you can map specific technical inks to specific Processing Step Layers. You can manage rules in
the Normalized PDF section in the Preferences. The defined rules are applied if the Apply rules when
converting Normalized PDF files to PDF+ option is enabled.

Note:  Placing a PDF is currently only possible in a PDF+, not in a Normalized PDF.

You can add a rule:

• Define the technical ink you want to use, based on the exact name or a part of the ink name (equal,
starts with or contains)

• Define to what Processing Step layer the objects should be moved to
• Click Add Rule
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Select a rule and click the minus button to remove the rule.

From the fly-out menu, you can save the rules to your Automation Engine, or you can load the rules
saved on the Automation Engine Server you're connected to. The location of the XML file containing
the saved rules is <your server>\bg_data_custom_v010\dat\PDF rules.

Note:  The rules will be applied from top to bottom. This may result in rules at a lower position
no longer being applicable.

For more information on placing Normalized PDF files, see Placing Normalized PDF files in a PDF+ file on
page 221. For more information on converting a Normalized PDF file to PDF+, see Convert to PDF+ on
page 59

2.3.  Quitting ArtPro+

You can quit the application in two ways:

• By selecting File > Quit (Mac) or File > Exit (Windows).

• By its shortcut Cmd+Q (Mac) or Ctrl+Q (Windows)

• By using Alt-F4 or the red cross button to close the last document window on Windows.
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3.  Working with files

3.1.  PDF, PDF+ and Normalized PDF

In ArtPro+, your open file can be a PDF+ file or a Normalized PDF file. If your current file is a Normalized
PDF file, this will be indicated behind the name of the file in the window title. The file type depends on
the file you open.

If you open ... the document will be...

a Normalized PDF file or PDFPla file Normalized PDF

an ArtPro file (exception: see below) Normalized PDF

an ArtPro file that can't be converted to
Normalized PDF, e.g. because of unsupported
objects such as placed standard PDF files, placed
EPS, PS or RGB images

PDF+

a regular PDF PDF+

a new document PDF+

an ARD, MFG, CF2 or JDF file PDF+

an Image file PDF+

When you save your document in ArtPro+, Normalized PDF will be saved as Normalized PDF, while PDF
+ is saved as PDF+. If a PDF file becomes a PDF+ file, this only means additional information can be
stored in the file. No conversion is done.

Note:  Strictly spoken, a regular PDF, ARD file, CF2 file or Image file doesn't become a PDF+
file until you save it. However, since it follows the specifications and behavior of PDF+ files, we
consider the open document to be a PDF+ file.

You can convert a Normalized PDF to a PDF+ file using Convert to PDF+. This will convert Normalized
PDF information, and PDF+ features become available. See Convert to PDF+ on page 59

There is no way to convert a PDF+ file to Normalized PDF.

What is the difference between regular PDF, PDF+, and Normalized PDF
Both PDF+ and Normalized PDF are to a large extent regular PDF files that you can open and edit
in any other PDF editor or reader. However, PDF+ and Normalized PDF files also contain additional
information, available to any Normalized PDF or PDF+ compatible editor. Both file formats also
implement specific limitations and specifications.

What PDF+ Normalized PDF

Ink order stored in file
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What PDF+ Normalized PDF

Non-printing data (Cut, Die, …)
and special processing steps
(varnish, …)

Processing Step Layers Technical Inks & Varnish

Ink Types Normal, Opaque Normal, Opaque, Technical,
Varnish

Document Profile as output
intent

Obligated. If none is present, the
default profile will automatically
be added when saving.

Screening Optional object based screening Default screening is applied to
all unscreened objects when
saving.

Crosshair position Saved in file

Group and Barcode metadata

Marks PDF+ Marks can be applied in
ArtPro+

ArtPro+ does not support
SmartMarks

Images Images can be

• Embedded

• Linked & Embedded. If a PDF
+ file contains image links,
a full resolution embedded
version of the image will still
be saved in the file.

Images can be

• Embedded

• Linked

Placed Art (PDF)

• If the Placed Art is
Normalized PDF, it is always
embedded.

• When placing a Normalized
PDF, you can map Technical
Inks to specific Processing
Step Layers.

Note:  If you open
a Normalized PDF
containing Placed Art,
this will be recognized
and kept with limited
editability.

Structural Design
 Limited to one Structural

Design file, and always using the
default Profile . Editing Panel
Tags in an ARD or one-up CFF2
is not available in Normalized
PDF.

Preflight Checks and Fixes Only Checks, no Fixes.
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What PDF+ Normalized PDF

Plate Cutting Paths

Plate ID Objects

Printing Units

GMG OpenColor color
management

Effects

When working with PDF+ files...
• When opening a PDF+ file that contains linked images or linked Placed Art that can't be found, you

can choose to browse for them, unlink them or continue to open the file while ignoring the broken
link for now.

• When opening a PDF+ file that contains an out-of-date linked image or Placed Art (the embedded
version doesn't match the linked version), you can choose to update the embedded version to the
linked version, to unlink and keep using the embedded version, or to continue opening the file while
ignoring the out-of-date images for now.

When working with Normalized PDF files...
• You will not be able to save the Page Boxes setup as long as any errors have not been resolved.

• Dimensions and position for each page box need to be the same for all pages of a Normalized PDF,
so if e.g. a trim box is changed on page 1, it is changed on all other pages; if a bleed box is added to
page 2, it is added on all other pages.

• All missing links have to be resolved for the file to be opened
• All objects have to be screened

3.1.1.  Convert to PDF+

When your current document is a Normalized PDF file (indicated behind the name of the file in the
window title) you can use File > Convert to PDF+ to convert your document into a PDF+ file.

During this conversion, several changes are made to the document:

• Technical Inks become opaque inks.
• Protected objects, such as unsupported barcodes, Dynamic Marks, smart text, are expanded. See

also Protected objects on page 178

• Barcodes are regenerated. When a barcode had live text in a font not available on the system, OCR-
B will be used.

• The default color profile is added as Document Profile. An existing profile is kept when it is a
supported format.

• All Normalized PDF XMP data is removed.
• If a linked Normalized PDF is placed in the file, the linked file will be embedded.
• If a linked non-Normalized PDF file is placed in the file, the linked PDF is kept as linked placed art.
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• If a supported Structural Design file is linked in the file (ARD, CF2), the link to the structural design
file is kept.

• If a missing or unsupported Structural Design file is linked in the document (ZAE, DAE, BAG, DXF,
DDES, VLM, …), the structural design object will be expanded.

• If the Normalized PDF contains links to unsupported images (EPS, DCS, …), the conversion to PDF+
will fail.

Saving the document after the conversion will automatically be a "Save As", to avoid overwriting the
original Normalized PDF file.

As soon as your document has been successfully converted to PDF+, the Normalized PDF indication
behind the file name will disappear, and all PDF+ features will become available. You will e.g. be able to
add Dynamic Marks, use Processing Steps, apply Preflight with fixes, etc.

If an ArtPro (Normalized) file is converted to PDF+, the supported multistep gradations will be
converted to Effects when converting to PDF+, and the Effects inspector becomes available. See
Multistep Gradations from ArtPro on page 197

For more information on the difference between Normalized PDF and PDF+, see PDF, PDF+ and
Normalized PDF on page 57

3.2.  New File

File > New or its shortcut Cmd+N (Mac) or Ctrl+N (Windows) will create a new empty document.

The Media box and Trim box will have the same size as the Media box and Trim box of the last opened
document.

If you save such a new document, it will be saved in PDF+ format. See PDF, PDF+ and Normalized PDF on
page 57.

If you have multiple documents open, you can choose File > Close All or the shortcut Cmd + Alt + W
(Mac) or Ctrl + Alt + W to close all documents.

If you have multiple documents open, you can choose File > Close All or the shortcut Cmd + Alt + W
(Mac) or Ctrl + Alt + W to close all documents.

3.3.  Open Files

You can open a file in different ways:

• By selecting File > Open, and browsing to the file you want to open.

• By its shortcut Cmd+O (Mac) or Ctrl+O (Windows), and browsing to the file you want to open.

• By dragging and dropping a supported file onto the already opened document in the application
window, or on the dock icon (Mac only).

ArtPro+ can open PDF and PDF+ files, Normalized PDF files (including PDFPla files) and ArtPro files. If
the opened file is a Normalized PDF or an ArtPro file (opened as Normalized PDF, see below), this will
be indicated behind the name of the file in the window title. See PDF, PDF+ and Normalized PDF on page
57.
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When opening a file that contains linked images or placed PDF files that can't be found, you will get
the possibility to browse for them. For Normalized PDFs and ArtPro files, clicking Cancel will cancel
the Open action. For PDF+ files, you will also have the option to unlink or continue without relinking.
For Normalized PDF files, you can click Open Anyway to open the file with broken links. For more
information, see Missing and out-of-date files on page 62

Notes on opening files
• By default files are opened in the same window size as the last closed document. All artwork

(including artwork outside the media box) and page boxes are fit in the window. By default, page
boxes are hidden.

• If a file takes longer than a second to load, a busy indicator is shown (spinning wheel). Other actions
can still be performed while the file is loading.

• ArtPro+ will never make changes to a document when opening the file . If for example external
variables in a Mark (see Marks on page 381) were changed between saving and reopening the file,
the Marks will only be updated on the first document edit.

• For opening Step & Repeat files from other applications, see also Opening Step&Repeat files from
other applications on page 368

Opening ArtPro Files
• When opening an ArtPro file in ArtPro+, it is opened (and saved) as a Normalized PDF. However, if

conversion to Normalized PDF is not possible, e.g. because of unsupported objects such as placed
standard PDF files, placed EPS, PS or RGB images, the file will be converted to and saved as a PDF+
file.

• When opening an ArtPro file as a Normalized PDF, images in PSD, non-bitmap TIFF and Esko CT
format that were placed in ArtPro ("Place Picture") will be linked. Also, images that were linked in
the ArtPro file as a result of importing a Normalized PDF file with the Keep Esko Links option will
remain linked. All other images will be embedded.

• Colors shown in ArtPro+ match the proofer colors of the separations. Display colors set in ArtPro
are disregarded.

• ArtLink values are not updated.
• When the ArtPro file (opened as Normalized PDF) contains multistep gradations, a warning will

be shown in the Messages drawer to indicate that the Effects editability is at risk. The document
will need to be converted to PDF+ before saving, otherwise the multistep gradations cannot be
converted to Effects and will not be editable anymore. See Multistep Gradations from ArtPro on page
197

• For more information on opening an ArtPro Step&Repeat file, see Opening ArtPro Step & Repeat
Files on page 62

Opening image files or Structural Design files (ARD, CF2)
If you set the dropdown at the bottom of the File Open dialog to "All supported images" or "All supported
Structural Design files", you can also open certain image files or Structural Design files (.ARD or one-
up .CF2). This will result in an empty document, with the selected image file or Structural Design file
placed. The size of the document will be the size of the image or Structural Design file.

See Place on page 210 for more information on placing image files, or Place Structural Design on page
228 for more information on placing Structural Design files.

Opening an MFG file or a Layout CF2 file
If you set the dropdown at the bottom of the File Open dialog to "All supported Structural Design files",
you can open an ArtiosCAD MFG or a Step&Repeat CF2 file. See Step & Repeat based on an MFG or CF2
file on page 358
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Opening a JDF Layout
If you set the dropdown at the bottom of the File Open dialog to "All supported Structural Design
files", you can open a JDF Layout created in Phoenix. After opening the JDF, you can use the Layout
Inspector to set the bleed, create a back page, etc, similar to working on an MFG or CF2 based
Step&Repeat. See Step & Repeat based on an MFG or CF2 file on page 358

3.3.1.  Opening ArtPro Step & Repeat Files

When opening an ArtPro Step & Repeat file, although the one-ups are Embedded Placed Art, ArtPro+
will remember the link to the original ArtPro one-up file. This link is shown in the Placed Art Inspector
as Legacy File Link

 

 

If the name is underlined and blue, the name works as a link to open the file location in Finder (Mac) or
Windows Explorer (Windows). If the name is underlined but gray, it means the link can (temporarily) not
be found.

After converting your document to PDF+, the Placed Art Inspector will also show the Replace button,
allowing you to replace the one-up with a PDF file of your choice.

Note:  After converting to PDF+, you can also use the Replace Embedded Placed Art action in
an Action List. See Replace Embedded Placed Art on page 448

3.3.2.  Missing and out-of-date files

When opening a file containing linked files (images, placed PDF files or Structural Design files), ArtPro+
will try to find the linked file.

If the file you open is a PDF+ file, the file contains both a link and an embedded version of the placed
image, PDF or Structural Design File. ArtPro+ will then also check if the embedded version matches the
linked file.

For more information on:

• Images, see Working with images on page 210
• Placed PDF files, see Working with Placed Art on page 219
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• Structural Design files, see Working with Structural Design files on page 228

When working with a PDF+ file
In case placed files are not up to date or can't be found, you will get a warning, indicating which files
can't be found, or for which files the embedded version doesn't match the linked version.

You can then choose how to handle these files:

• Click Unlink to remove the link to the files on disk, and keep using the embedded version.
• Click Ignore to use the embedded version of the files but remember the link. You can use this option

e.g. if the linked file is temporarily unavailable.
• Click Browse to browse to the missing linked files.
• Click Update to update the outdated embedded version.
• If there are both missing links and out-of-date embedded versions, you can click Browse And

Update to combine both.

This check is only done on the current page. This means that when navigating to a different page
ArtPro+ will check for missing or out of sync placed files, and another message might be shown.

When working with a Normalized PDF file
When opening a Normalized PDF file with links, the file doesn't contain an embedded version, so the
external image or PDF file will be opened. If you are opening a Normalized PDF with missing links, you
will be asked to browse to the missing files.

Alternatively, you can click Open Anyway. This will open the file without resolving the links.

Be aware that when opening a file this way, the missing Placed Art will not contain the real content, and
missing images will not have the high-resolution data. Depending on how the file was saved, depends
on how the Normalized PDF was saved. It will either show a low resolution preview, or no preview at all.

The file opened this way is not ready to be used in production, but can be used e.g. to copy-paste
objects unrelated to the missing artwork. The original links are kept, so if the links are relocated at a
later point in time, the file will be ready for production again.

Note:  Convert to PDF+ is not possible when opening a Normalized PDF without resolving all
links.

For a Structural Design file, the Normalized PDF contains both a link and embedded outlines, but the
Normalized PDF does not contain the information needed to check whether the embedded version
is in sync with the linked version. When opening the Normalized PDF, the embedded version is used,
without any warning about the Structural Design file being missing or out of date. You can still manually
browse and update the structural design file.

When working with a JDF file
When opening a JDF file, the file doesn't contain an embedded version, so the external files will be
opened. In case the file can't be found, the link must be resolved for the JDF file to be opened.

3.3.3.  PDF Signatures and Annotations

When opening a PDF file that contains Signatures or Annotations that will have RIP output, these
annotations will be visible in ArtPro+. A message will be shown in the Message Center.

These annotations can't be selected nor edited, and can't be seen in the object browser.
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You can use a standard Preflight Profile to either remove these Printed Annotations, or expand them
into regular objects. For more information on Preflight, see Preflight on page 339

1. Select Prepress > Preflight
2. From the Standard - Annotations section, select either Remove Printed PDF Annotations or

Expand Printed PDF Annotations
3. Click Preflight.

Note:  The Remove Printed PDF Annotations and Expand Printed PDF Annotations Preflight
Profile only has effect on annotations that will appear on RIP output. Other annotations in the
PDF remain untouched.

3.4.  Open Recent

You can open one of the 10 most recently opened files by choosing it from the list in File > Open
Recent.

If you try to open a file from this list that is no longer available (because it was removed, renamed, or an
external drive is currently not available) you will be warned about this.

Selecting Clear Menu clears all items from the Open Recent list.

3.5.  Close Files

You can close a file:

• By selecting File > Close
• By using the shortcut Cmd+W (Mac) or Ctrl+W (Windows)
• By clicking the top left red button (Mac) or top right red cross (Windows)
• By using Alt+F4 (Windows)

Note:  On Windows, when using Alt+F4 or the top right red cross to close the last document
window, this will also quit ArtPro+

If you have multiple documents open, you can choose File > Close All or the shortcut Cmd + Alt + W
(Mac) or Ctrl + Alt + W to close all documents.

3.6.  Save Files

You can save your document:

• By selecting File > Save.
• By its shortcut Cmd+S (Mac) or Ctrl+S (Windows).

The Save function is always available, even when the document hasn't been edited. If a document was
edited, this is indicated by a dot in the close button on Mac, or an asterisk next to the document name
in the title bar on Windows.
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Note:

If an ArtPro file or PDFPla file was opened, the Save function will save the document as a
(Normalized) PDF file, next to the original file, with "(imported)" added to the file name.

If a JDF file from Phoenix was opened, the Save function will save the document as a PDF+ file,
with "(imported)" added to the file name.

Another option to save the document, is the Save as function, allowing you to save the document with
a new name and/or different location:

• By selecting File > Save as....

• By its shortcut Cmd+Shift+S (Mac) or Ctrl+Shift+S (Windows).

ArtPro+ will save Normalized PDF files (i.e. indicated as Normalized PDF next to the file name) as
Normalized PDF, and will save other documents (including new documents) as PDF+ files. See PDF, PDF
+ and Normalized PDF on page 57

If you opened an ArtPro file, saving it will write a Normalized PDF file. However, if conversion to
Normalized PDF is not possible, e.g. because of unsupported objects such as placed standard PDF
files, placed EPS or PS, the file will be converted to and saved as a PDF+.

3.7.  Emergency Save

ArtPro+ will automatically create backups of unsaved open documents in a temporary folder.

These backup files are created 3 minutes after the first modification of the document, and every 3
minutes after that.

These backup files will be removed when the document is saved in ArtPro+, or if the application is quit
(without saving).

When reopening ArtPro+ after a crash or a forced quit, ArtPro+ will recover these documents, and they
will open in ArtPro+, where you can still save the document.

3.8.  Export

File > Export to combines different Export options:

1. Export to PDF. See Export to PDF on page 66
2. Export to Gravure TIFF. See Export to Gravure TIFF on page 67
3. Export to 3D. See Export to 3D on page 479
4. Export Structural Design. See Export Structural Design on page 69
5. Export Variable Data. See Export Variable Data on page 495
6. Export to JDF Layout. See Export to JDF Layout on page 71
7. Export to CIP3. See Export to CIP3 on page 71
8. Export to Picture List. See Working with Picture Lists on page 90
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Except for Export to Picture List, each of these Export options opens the Export dialog, with the
corresponding option selected. You can switch to one of the other Export options by selecting it in the
list on the left side of the dialog.

3.8.1.  Export to PDF

Unlike saving the document, the Export to PDF function offers you the option to apply an Action List
and some other automatic modificiations to the exported PDF, while keeping the original document as
it is.

1. Select File > Export To > PDF...

The Export dialog will open, with Export to PDF selected.

 

 

Note:  You can click one of the other output options on the left to export to another format.
See Export on page 65

2. Choose the Export Flavor you want.

• For Press: this will export a PDF for printing, as in earlier versions of ArtPro+.

• For Press (PDF 1.3): this will export a PDF that is PDF 1.3 compliant: transparencies are resolved
(i.e. flattened), layers are removed, etc.

• For Viewing: this will export a PDF for viewing, meaning that overprints and opaque inks will be
resolved. Such a file will give the same preview in e.g. Adobe Acrobat as it does in ArtPro+, even
if "Use Overprint Preview" is disabled. It is however not suited for printing.

Based on the flavor you choose, some options will be enabled or disabled, and can't be changed.
3. To run an Action List during the export, select it in the Run Action List dropdown. The dropdown will

show all available Action Lists. See also Managing Action Lists on page 424
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Note:

Marks in your document will be expanded in the state they were in before the included
Action List was run.

If you want the Marks to take into account the Actions from the Action List, you need to run
the Action List before doing the export and not as part of the export.

E.g. if you do a Convert to CMYK as part of the Export, the separations in your Marks will still
reflect the original separations. If you only want CMYK separations in the exported PDF, run
the Convert to CMYK Action List prior to the export.

4. In the Layers section you can decide if you want to include Processing Steps and non-printing
layers in your exported PDF.

5. Images:
a) Enable Downsample to downsample all images to a specified resolution. Bitmap images are

excluded and will not be downsampled.
b) If Crop images to clip mask is enabled, only the parts of the image within the clip mask are

included in the PDF file.
6. Set the Image Compression: Lossless, Low, Medium or High.
7. Outline text will convert all text to outlines in the exported PDF.
8. If Apply distortion is enabled, any distortion factor set in the Document Setup of your document

will be applied to the exported PDF.
9. If Include Document Profile is enabled, the used Document Profile will be embedded in the

exported PDF. Otherwise, the document profile will no longer be present in the PDF. Note that this
can result in a different representation of the colors.

10. If Add single color page per separation is enabled, the exported PDF will not only contain the
document itself, but a single color page is added for every separation.

3.8.2.  Export to Gravure TIFF

Export Gravure Tiff is used to output your document directly as TIFF data for gravure printing. It
creates one TIFF file per selected separation, for the current page.

To open Export Gravure TIFF, select File > Export To > Gravure TIFF....

The Export dialog will open, with Export to Gravure TIFF selected.
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Note:  You can click one of the other output options on the left to export to another format. See
Export on page 65

Select the Output Format: TIFF for HELL Job Ticket, HELL Compatible TIFF, or Separated TIFF.

Separated TIFF is the generic output. HelioDisk users can use the HELL Compatible TIFF output
format to ensure the generated TIFF names are compatible with the HELL workflow. If you have a HELL
Jobticket, you can use TIFF for HELL Job Ticket, and you can browse for the Job Ticket, so settings
(resolution, job size, …) can be retrieved from the Job Ticket.

Note:  Since the job size is retrieved from the Job Ticket, an error will be shown if the media
box of your document doesn't match the defined job size. You will not be able to export until the
media box has been adjusted accordingly.

In the Separations list you can define what separations to output. The list shows all separations in the
document, and by default unused separations will be enabled. If an empty separation is selected, no
output will be generated for that separation.

Note:  When Printing Units are defined, only the separations with a Printing Unit assigned can
be enabled / disabled. See Working with Printing Units on page 141

When using default Separated TIFF output, you can double-click a separation in this list to change
the name of the separation as it will be used in the file name for the TIFF, e.g. if you want the file name
to be "[filename] C.tiff" instead of "[filename] Cyan.tiff". This doesn't change the actual name of the
separation in the document.

When using HELL Compatible TIFF, Separation names can't be renamed, and the TIFF files will be
named: [file name] # [separation index], e.g. Job#1.tif, Job#2.tif, etc.

Note:  When Printing Units are defined, the Printing Unit is used instead of the separation
index in the file name of the exported TIFF for HELL Compatible TIFF and TIFF for HELL Job
Ticket. See Working with Printing Units on page 141
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When you are using HELL Job Ticket, only the separations that have a ticket will be selected. You can
still deselect separations you don't want to output.

The Resolution of the TIFF file is shown in the default unit defined in the Preferences, but can be
defined in Pixels per inch (ppi), Pixels per mm (ppmm) or Pixels per cm (ppcm). The entered value will be
recalculated to the default unit. See Preferences on page 49. When using TIFF for HELL Job Ticket, the
resolution is defined in the Job Ticket and can't be changed.

Anti-aliasing can be set to None, 2, 3 or 4 pixels. The higher the value the smoother the result will be,
but it will also increase calculation time and needed disk space.

By default, Anti-aliasing is set to Apply on One-Ups Only (if possible) placed in a Step & Repeat file. To
apply anti-aliasing on the other content of the S&R file itself (e.g. station numbers or Marks), you can
switch to Apply on all Contents.

Note:  If there is an overlap between the One-Ups, anti-aliasing will always be applied to all
objects, even if the setting Apply on One-Ups Only (if possible) is selected.

Add Noise allows to add a certain percentage of noise to avoid banding.

If Write skip areas to files is enabled, empty areas larger than the Threshold will be skipped, and a Skip
Areas file (.svs) will be written next to the separation file. Using this information, an engraving machine
can skip those areas, increasing the engraving process. When using TIFF for HELL Job Ticket the Skip
Areas are saved in the Job Ticket, so this option is not available.

Note:  Objects in non-printing layers will not be exported, while hidden objects in a printing
layer will be.

When using HELL compatible TIFF output, the generated TIFF files will get a fixed rotation of -90º.

When using HELL Job Tickets, the tickets will be updated when writing the TIFF files. Job information,
Skip Areas, User History, Histogram and Proof Parameters will be written in the tickets.

3.8.3.  Export Structural Design

Using Export Structural Design you can add all selected paths and/or all objects from a Cutting or
Varnish Free Area processing step layer as cutouts or varnish free areas to your structural design file
and save it as an ARD file. The Structural Design in your document will automatically be relinked to the
new ARD file.

Tip:  By first using Extract..., modifying the shape and using Export Structural Design, you can
adjust the cutouts or varnish free areas from an ARD file. See Extract ... on page 231

1. If needed, select the paths you want to use as cutouts or as varnish free areas.
2. To open Export Structural Design, select File > Export To > Structural Design... or click the Export

button in the Structural Design File Inspector.
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Note:  You can click one of the other output options on the left to export to another format.
See Export on page 65

3. In the dropdown, select the Structural Design you want to export.

Note:  You can only export if the selected Structural Design file is an ARD or a one-up CF2
file. In both cases, the output will be an ARD file.

4. In the Export list you can decide what paths to add to the exported ARD file:

• If you had an active selection when opening the Export dialog, the Selected Paths will be
enabled by default. You can choose to add the selected pats as Cut (for cutouts), Outside
Coating for varnish free areas on the front side, or Inside Coating for varnish free areas on the
back side.

• All Processing Step Layers of type "Cutting" are shown in the list, and can be enabled to add all
objects in the Processing Step (selected or not) as Cut (for cutouts).

• All Processing Step Layers of type "Varnish Free" are shown in the list, and can be enabled to add
all objects in the Processing Step (selected or not) as Outside Coating for varnish free areas on
the front side, or Inside Coating for varnish free areas on the back side. (for cutouts).

Note:  If you use the Extract... function, the extracted objects are placed in a Processing
Step Layer of type "Cutting" for cutouts, and "Varnish Free" for Varnish Free Areas. This
allows to easily extract, modify and export cutouts or varnish free areas.

5. Click Export Structural Design...
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6. Specify the name and location for the new ARD file. ArtPro+ will suggest the name of the original
Structural Design file with "(exported)" appended to it.

The newly created ARD file will be placed in your ArtPro+ document, replacing the structural design file
you had selected, and the selected paths will be used as cutout or varnish free areas in the new ARD
file.

• Only the print item that was selected at the time of the export will be exported into the new file. See
Structural Design Inspector on page 230

• Any existing cutouts or varnish free areas in the structural design file will be removed and replaced
by the newly created cutouts or varnish free areas.

• Open paths in the selection will be closed before creating the cutouts or varnish free areas. See
Join Paths on page 173

• A cutout can only be created inside one panel. Cutouts spanning two or more panels are not
supported.

• Overlapping objects can't be used. You can use the Shaper tool prior to creating the cutouts or
varnish free areas. See Shaper on page 199

3.8.4.  Export to JDF Layout

Using Export to JDF Layout you can export a Step & Repeat file to a JDF file, together with a folder by
the same name containing the one-ups and one or more files containing the Marks when present.

If the initial one-ups were Normalized PDFs, they will be converted to PDF+ during Export to JDF
Layout.

1. Select File > Export To > JDF Layout....

The Export dialog will open, with Export to JDF Layout selected.

Note:  You can click one of the other output options on the left to export to another format.
See Export on page 65

2. Set the JDF JobID and JDF JobPartID
3. Click Export JDF Layout

The Marks will be saved as PDF files named Marks_<n>.pdf where <n> is a unique number.

The Station files will be saved as PDF files named Station_<n>-<LinkName>.pdf where <n> is
a unique number, and <LinkName> is only used if the station has a link. In that case, the name of the
linked PDF will be inserted there.

3.8.5.  Export to CIP3

CIP3 is a file format used to transfer data about a specific file through the production process. Besides
a preview, this CIP3 file contains information concerning separations, ink coverage, job dimensions,
etc.

1. Select File > Export To > CIP3....

The Export dialog will open, with Export to CIP3 selected.

Note:  You can click one of the other output options on the left to export to another format.
See Export on page 65
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2. Select the Print Side you want to export
3. Set the Compression to be used
4. Define the Resolution for the preview
5. Set the Anti-aliasing
6. If necessary, enable Add cut data to include cutting path information in the CIP3
7. Click Export CIP3... to save the CIP3 file.

Only used Artwork Separations are exported. Processing Step colorants, technical inks and empty
separations are excluded from the export. Printing Units will be taken into account.

3.9.  Automation Engine connection

To connect your ArtPro+ to an Automation Engine server, you first need to set up the server connection
in the Automation Engine tab of the Preferences.

Open the Preferences, by selecting ArtPro+ > Preferences (Mac) or Edit > Options (Windows), or by its
shortcut Cmd+, (Mac) or Ctrl+K (Windows), and switch to the Automation Engine tab.

You can make a connection to an Automation Engine by entering the Automation Engine Server name
and clicking the Sign In button.

Note:  If you need to connect to your Automation Engine server over a non-default port, you
can specify it here, using the 'servername:portnumber' format, e.g. "AEServer:5183".

The Sign In dialog will open. You can use the Sign In With dropdown to define how to sign in:

• If you have an internal or Windows user account on Automation Engine, you can sign in with a User
Name and Password.

• When available, you can choose to sign in using an identity provider, which will redirect you to the
corresponding webpage to enter your credentials

As security is one of the main aspects of using an identity provider, you will be asked to reconfirm the
sign-in each time you launch ArtPro+

• If you choose Yes, you will be redirected to the web page again.
• If you choose No, you will not be signed in and there will not be an active Automation Engine

connection until you do sign in.
• If you choose More Options... you will be redirected to the Automation Engine Preferences tab.

After signing in, a connection will be made with the server. The Connect button will then be replaced
by a Change User button. If the connection to the Automation Engine Server was lost (e.g. because the
server was temporarily unreachable), the button will be replaced by a Reconnect button, so you can re-
establish the connection.

The toolbar will show a green connection if the connection is up and running . If no connection to the
Automation Engine server is available, a red icon is shown. When no Automation Engine is set, the
connection icon will be hidden.
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Attention:  After launching ArtPro+, it is advised to wait for the message "Now connected to
server […] as user […]" before opening a browse dialog, e.g. to open a job, to ensure that the
browse dialog shows all options for browsing Automation Engine Containers, Jobs or Products.

3.9.1.  Working with an on-premises Automation Engine server

Opening and saving files
When you're connected to an on-premises Automation Engine server (so not an Automation Engine
SaaS server), you can open and save files directly from and to your Automation Engine Server: the
Browse dialog will contain a Recent Server Places dropdown, where you can easily select the latest
server locations where you opened or saved a file, and a Search button, to open the Automation Engine
Search window.

Attention:  After launching ArtPro+, it is advised to wait for the message "Now connected to
server […] as user […]" before opening a browse dialog, e.g. to open a job, to ensure that the
browse dialog shows all options for browsing Automation Engine Containers, Jobs or Products.

• Use the buttons on top of the window to show Jobs or Products.
• Use the Search field to filter Jobs or Products.
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• Select a Job or Product to see its details underneath

• Click OK to close the Automation Engine Search window, and return to the Browse dialog, which will
now automatically show the location of the selected Job or Product.

If an open document resides inside an Automation Engine Job, the job name is displayed next to the
name of the document in the title bar of the document. If the open document is a Part of a Product, it is
the Product name that is displayed instead.

If you are working on a document from an Automation Engine Job, you can use the barcode parameters
defined in the Job Setup. See Barcode properties from Automation Engine on page 304

Launch Workflow
If you have an active connection to an on-premises Automation Engine server (see Automation Engine
connection on page 72) you can launch your document directly into an Automation Engine workflow.

1. Select File > Launch Workflow or use its shortcut Cmd+L (Mac) or Ctrl+L (Windows).

When you are connected to an Automation Engine server version 22.07 or later, Launch Workflow
will use the 'My Workspace' interface for selecting Jobs, Workflows and entering public parameters.
When connecting to an Automation Engine server version 22.03 or older, the Shuttle interface is
used.

Although the interface is different, the functionality remains the same.
2. Select the workflow you want to use from the list of public workflows on the Automation Engine you

are connected to.

Note:  If your Automation Engine is using a non-default port, you will not see any of
the workflows listed, unless you've added the port number to the server name in the
Preferences. See Preferences on page 49

3. Enter any public parameters the workflow requests.
4. Optionally enter a "Order ID" and "SubOrder ID" (for Shuttle) or "Job" (for MyWorkspace). If the file was

opened from an Automation Engine Job, this information will automatically be entered.
5. Click Launch. If the file was modified since the last save, you will be asked to save the file before

launching.

Note:  When launching a file using My Workspace, only the PDF is launched. There is
currently no option to also include linked files.

Note:  If the file you are launching is not located inside an Automation Engine Job yet, the
file will first be uploaded to the server. If you do not specify an Automation Engine Job to
launch the workflow to, the file will be uploaded to a temporary folder inside the Shuttle
Jobs folder, as specified in in Automation Engine Pilot: Tools > Configure > Shuttle. Keep
this in mind for workflows that use an output location relative to the input folder.

There is no Shuttle or My Workspace dialog to show progress of the launched jobs from within ArtPro
+. You can check the progress of the launched job using the Automation Engine Pilot. When connected
to an Automation Engine server version 22.07 or later, you can use Window > My Workspace Activity to
open the My Workspace Activity web page. See My Workspace Activity on page 75
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My Workspace Activity
If you have an active connection to an Automation Engine SaaS server or an on-premises server
version 22.07 or higher, you can select Window > My Workspace Activity ....

This will open the My Workspace web page, showing the Activity view. For more information on My
Workspace, we refer to the Automation Engine documentation here and the Blended Learning modules
here.

3.9.2.  Working with an Automation Engine SaaS server

Opening and saving files
When you're connected to an Automation Engine SaaS server, the Automation Engine Syncer needs
to be installed and running. If this is not the case, an error message will be shown in the Automation
Engine tab of the Preferences, and as a toast message when ArtPro+ is launched.

Important:  The installed Automation Engine Syncer has to be the same version as your
Automation Engine Server for the connection to work.

The Automation Engine Syncer is part of the Esko Editor Connection Tools installer, which you can find
on the Apps & Tools page of your Automation Engine's My Workspace webpage.

Browsing for files

Attention:  After launching ArtPro+, it is advised to wait for the message "Now connected to
server […] as user […]" before opening a browse dialog, e.g. to open a job, to ensure that the
browse dialog shows all options for browsing Automation Engine Containers, Jobs or Products.

When choosing File > Open, you will get the Browse window. Using the button at the bottom of the
dialog, you can choose:

• Browse Local Files (Mac) or Browse This PC (Windows) to browse for local files and files on physical
shares, the same way as you are used to without an Automation Engine SaaS connection

• Browse My Workspace to browse for files on your Automation Engine SaaS server.

The Browse My Workspace browser looks very similar to the My Workspace webpage. For more
information on My Workspace, we refer to the Automation Engine documentation here and the Blended
Learning modules here.
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• Open a folder by single clicking the folder name. To select a folder without opening it, click the icon
in front of its name or the space behind the folder name

• Open a single file by double-clicking it, selecting it and pressing enter, or clicking the Open button.

•
To open multiple files, first enable the Multi-select button 

Browse My Workspace is available for every browse action in ArtPro+ where you have the Jobs and
Products Search option in case of a on-premises Automation Engine server connection, such as Open,
Place, Replace, Save, Extract, Export, browsing for an Input File or Database, ...

The Automation Engine Syncer
When opening a file from My Workspace, the Automation Engine Syncer will download a copy of the
file into the local cache folder.

Related files such as linked images, linked Placed Art, Variable Data External Files, ... will only be
downloaded when needed, e.g. when you want to do an Edit in Editor of a linked image, or when you are
browsing through the records in a Variable Data Template.

In case of a folder selection (e.g. Variable Data External File, Set Root Folder, or Export Gravure TIFF,
HELL Job ticket or HELL-compatible output), the whole folder is being downloaded.

When saving a file, the Syncer will upload it again to the server.

Resources (PitStop data, Custom data = PDF Action Lists and Marks Data) will be synced whenever the
application is launched.

Color data is only synced if a remote CMS tree was set (so when using "from Automation Engine" or
having browsed to an "Other" location), not when Standard Color Engine data is being used.

You can force-sync resources during the session by clicking the Update Server Resources button in
the Automation Engine tab in the Preferences.

For more information on the Automation Engine Syncer, we refer to the Automation Engine
documentation here.
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Tips and tricks
• When launching the application, it is advised to keep an eye for two statuses before starting to

process files: a toast message that indicates the connection to the Automation Engine SaaS server
was established, and the Syncer tray progress icon: as long as it shows a grey icon, resources are
still being synced.

• Watch the Syncer tray progress icon when saving files. If you would e.g. save, close and reopen a file
too quickly, this could result in trying to download the file while it's being uploaded, and the Syncer
may display a synchronisation conflict message.

Warning:  Do not delete files from the local cache folder. Doing so while the Syncer is running
will irreversibly delete the file on the server.

• If an open document resides inside an Automation Engine Job, the job name is displayed next to the
name of the document in the title bar of the document.

• If you are working on a document from an Automation Engine Job, you can use the barcode
parameters defined in the Job Setup. See Barcode properties from Automation Engine on page 304

Launch Workflow
If you have an active connection to an Automation Engine SaaS server version 22.07 or higher,
(see Automation Engine connection on page 72) you can launch your document directly into an
Automation Engine workflow.

1. Select File > Launch Workflow or use its shortcut Cmd+L (Mac) or Ctrl+L (Windows).

This will open a dialog in ArtPro+, using the 'My Workspace' interface for selecting Jobs, Workflows
and entering public parameters.

2. Select the workflow you want to use from the list of public workflows on the Automation Engine you
are connected to.

3. Enter any public parameters the workflow requests.
4. Optionally enter a "Order ID" and "SubOrder ID" (for Shuttle) or "Job" (for MyWorkspace). If the file was

opened from an Automation Engine Job, this information will automatically be entered.
5. Click Launch. If the file was modified since the last save, you will be asked to save the file before

launching.

Note:  When launching a file using My Workspace, only the PDF is launched. There is
currently no option to also include linked files.

Note:  If the file you are launching is not located inside an Automation Engine Job yet, the
file will first be uploaded to the server. If you do not specify an Automation Engine Job to
launch the workflow to, the file will be uploaded to a temporary folder inside the Shuttle
Jobs folder, as specified in in Automation Engine Pilot: Tools > Configure > Shuttle. Keep
this in mind for workflows that use an output location relative to the input folder.

You can use Window > My Workspace Activity to open the My Workspace Activity web page. See My
Workspace Activity on page 75
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Launch My Workspace
If you have an active connection to an Automation Engine SaaS server lower than version 22.07, you
can select File > Launch My Workspace.... This will open the My Workspace web page, where you will
see the folder in which the current file resides.

You can then choose to Launch the file in a workflow there. For more information on My Workspace, we
refer to the Automation Engine documentation here.

Note:  If the file you are launching is not located inside an Automation Engine Job yet, the file
will first be uploaded to the server. If you do not specify an Automation Engine Job to launch
the workflow to, the file will be uploaded to a temporary folder inside the Shuttle Jobs folder,
as specified in in Automation Engine Pilot: Tools > Configure > Shuttle. Keep this in mind for
workflows that use an output location relative to the input folder.

My Workspace Activity
If you have an active connection to an Automation Engine SaaS server or an on-premises server
version 22.07 or higher, you can select Window > My Workspace Activity ....

This will open the My Workspace web page, showing the Activity view. For more information on My
Workspace, we refer to the Automation Engine documentation here and the Blended Learning modules
here.

3.10.  Share & Approve connection

The integration of ArtPro+ with Share & Approve allows you to

• Upload PDF files from within ArtPro+ to the Esko Cloud.
• Share these PDF files with other people, either working in the same company or not.
• Request users to annotate and/or approve (or reject) the document.
• Review the Annotations in ArtPro+
• Add Annotations on the document inside ArtPro+
• Download an Annotation and Approval Report

For more information on Share & Approve, see:

• The Share & Approve Documentation

• The Share & Approve eLearning modules

3.10.1.  Connecting to Share & Approve

The first time you click the Share & Approve button  in ArtPro+ you will be asked
to Sign In.
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1. Enter your Esko ID and Password.
2. If you want to keep the information stored, enable Remember Me
3. Click Sign In
4. If your Esko ID is associated with multiple Esko Cloud Accounts and/or Workspaces, you will be able

to choose the Account or Workspace you want to use from a dropdown.

Note:  These dropdowns are only shown when you connect to Share&Approve for the very
first time. Later, you can switch to another Account or Workspace by clicking the Esko
Cloud Account link.

5. If you don't have an Esko ID yet, or if no Share & Approve account is available for your Esko ID, you
can click the Register button.

6. In case you forgot your password, you can click the Forgot Password link to go through the
password reset procedure.

7. You can open a Knowledge Base article with more information on Share & Approve sign in by
clicking the Help button.

3.10.2.  Uploading the current document to Share & Approve

To upload the current document to Share & Approve:

1.

Click the Share & Approve button. 
2.

Click the Upload button. 
3. Enter the Asset Name. By default, the name of your document is used.
4. Select the Folder on Share & Approve in which you want to upload the file. If necessary, you can

create new subfolders by clicking Create New Folder
5. If your document contains an ARD structural design, you can select Upload Linked ARD to upload

the ARD file along with the PDF. This will make 3D view in the Esko Cloud Viewer possible.
6. Click Upload

The document, along with the topmost structural design file, is uploaded to Share & Approve, as a new
Asset. Your local document will be linked to the Asset on Share & Approve.

If you don't want to create a new asset, you can click the More button  and select Upload to
existing asset. After selecting the Asset you want to add the current document to, you can choose:

• Upload will upload your current document as a new version for the selected asset, and the local
document will be linked to the Asset.

• Link will not upload your current document, but will link the current document to the Asset.
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Note:  Instead of uploading your document, you can click the Share button, to combine two
actions: uploading the document as described here, and sharing. See Sharing the document on
page 81

3.10.3.  Working with an uploaded document

If the active PDF document is uploaded to Share & Approve, the Share & Approve pane looks like this:

 

 

•
Click the Refresh button  to reload the information, e.g. newly added annotations.

•
Click the Upload button  to upload a new version of the document.

•
Click the Unlink button  to break the connection between the local file and the Asset in Share
& Approve.

•
Click the Permissions button  to open a browser window and change the permissions for the
current file.

80



3ArtPro+

•
Click the More button  and select Upload to Existing Asset to upload your document as a new
version for an existing Asset.

•
Click the More button  and select Download Report to Download an Annotation and Approval
Report for the current document. See Download Annotation and Approval Report on page 82

• Click the Share button to share the document to other people, either within or outside your own
organisation. See Sharing the document on page 81

• In the Annotations section you can see and add annotations to the file. See Annotations on page
81

Sharing the document
By sharing a document you can have users inside or outside your organisation to view, check, annotate
and accept or reject your document.

1. In the Share & Approve panel, click the Share button.
2. Enter the e-mail address of the user you want to share the document with. Users that are registered

to the account can be selected from the dropdown by clicking the triangle. You can also enter the
name of a group, defined in Share & Approve.

3.

For unregistered users, you can use the language selector  to specify the language used
in the e-mail notification. For registered users, the language as defined in their profile will be used.

Note:  If the Share & Approve panel is too small, the language selector might be invisible.
Enlarge the panel to make it visible.

4. Enable Request Approval if you want the users to approve or reject the document.
In that case, you can add a Due Date for the approval.

5. When sharing the document with unregistered users, these users will receive a link to access the
file without password. The Expiration date for the link sets how long this link remains valid.

6. The Assets Details display the name and location of the document. This section is read only.
7. Click Share.

An email will be sent to all selected users, containing a link to open the document in the Share &
Approve Viewer.

Annotations
Users with whom a document is shared can view the document in the Share & Approve Viewer, and can
add comments, named "Annotations". In ArtPro+ you can see those annotations and add annotations
yourself.

• The Share & Approve panel will show a list of all annotations, indicating the content and the user
who added the annotation
Using the dropdowns, you can filter the list of annotations based on the user, or based on the review
state of the annotation.

• By default, Show All is selected, so all notes are shown in your document. Use Show Selected to
only show the annotations selected in the list, or Hide All to hide all annotations.

• For every annotation, you can:
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• Enter a reply
• Click the More button  and set a State for the annotation: Accepted, Rejected, Cancelled,

Completed or None.
• Click the More button  and Duplicate, Edit or Delete the annotation.

Note:  Annotations added in the Share & Approve Viewer are not immediately visible in ArtPro+.

To load new annotations, click the Refresh button 

Download Annotation and Approval Report
You can download an Annotation and Approval Report for the current document. The Report can be in
PDF or in CSV format

1.
In the Share & Approve panel, click the More button  and select Download Report
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2. Define the settings for the report.

• Language: Select the language wanted from the drop-down list. The default language is the
language of the user.

• Report Type: you can select Annotation, Approval or both. You can also decide to include the
original PDF
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• Version: Select the version wanted from the drop-down list. You can select a range of versions
with lower and upper bound or can select last or all. The default version set is the last version.

• Zoom ins: Selecting this option displays the clear (zoomed) image of the annotations made.

• Orientation: Landscape or Portrait

• State Filters:: You can choose the state of the annotation before downloading the report. Select
the filter from the drop-down list. The list contains None, Must Contain and Must Not Contain. If
the user chooses either Must Contain or Must Not Contain, a new drop-down list will be displayed
where the user can choose the different states of annotation such as None,Accepted, Rejected,
Cancelled, and Completed.

• Users Filter: Selecting Users Filter from the drop-down list will display a new drop-down list
where you can filter the annotation based on who made the annotations.

3. Click Download Report. Define the name and location for the Report, and click Save

3.11.  Report Template

Using the Create PDF Report task in Automation Engine you can create a Report of a production file.

Note:  This Create PDF Report task is comparable to the older 'Create Report (Reportmaker)'
task.

These file reports typically contain a preview of the design and then list all kinds of information related
to the job, customer, extensive details of graphics and Structural Design file. It can even be extended to
show separations.

A Report is created based on two files:

• a Report Template, created in ArtPro+. This file determines what elements (Marks, graphic
elements, …) are included in the Report.

• the production file that is used as Input file, the subject of the report.
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All Marks in the Report Template (including the specific Input File Mark - see Input File Mark on page
86) will resolve to the Input file. If for example the Report Template contains a Text Point Mark
showing the File Name, this Text Point Mark will show the name of the current Input File.

3.11.1.  Working with a Report Template

1. Create a Report Template:

• start from an empty document by choosing File > New Report Template. The empty A4
document will contain one Input File Mark. See Input File Mark on page 86

• convert your current document to a Report Template by choosing File > Convert to Report
Template

Note:  You can only convert PDF+ files to a Report Template. If you want to convert a
Normalized PDF, you should convert it to PDF+ first. See Convert to PDF+ on page 59

2. Select an Input file.

While creating your Report Template, the selected Input file is used to resolve all Marks

Note:  Since the Input File is embedded in the Report Template file, it is advised to use a
small dummy file, containing all separations etc. as needed to set up the Report Template

3. Set up the Report Template. See Editing a Report Template on page 86
4. Save the Report Template.
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5. In Automation Engine, use a Create PDF Report task to create a Report for a production file (the
Input File) based on the Report Template.

3.11.2.  Editing a Report Template

When editing a Report Template, you can notice a few differences compared to when editing a regular
document:

• The window title will show "(Report Template)" next to the file name.
• The Marks section will be replaced by "Report Marks". See Report Marks on page 87

• All Marks are resolved to the selected Input File. You can change the Input File in the Report Marks
section.

• In a Report Template you can use the Input File Mark, to visualize the Input File. See Input File Mark
on page 86

• Additional Smart Text variables will be available. See Smart Text in a Report Template on page 88

• The Dynamic Marks are in a regular type layer (instead of in a "Legend" layer)

Input File Mark
The Input File Mark is a type of Mark that is only available when editing a Report Template. See Editing a
Report Template on page 86

The Input File Mark places a representation of the Input File.

You can place different Input File Marks using different settings, e.g. to show a preview of the complete
job, a preview of the separations, etc.

Note:

Keep in mind that the Input File is included in the Report Template file. However, placing
multiple Input File Marks does not embed the file multiple times.

Mark Inspector
Use the Mark Inspector to set all parameters.

Use the Clip To dropdown to define how the Input File should be clipped: to one of the page boxes, or to
a named object saved in the Input File.
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Filter: You can indicate what separations to be included in the Mark:

• All Separations
• Artwork Separations
• Processing Step Separations (See Processing Step Layers on page 127)
• Artwork Separations and Varnish
• Custom. This allows you to select separations by combining rules on Printing Method, Processing

Step, Separation Name, Process Separations or Non-Process Separations.

Enable Show only separation [#] to show only one specific separation. You define what separation to
show by entering the index number. Note that only the separations that are in use and that are defined
in the Filter are taken into account. E.g. if set to "Processing Step Separations", entering "1" will show
the first used Processing Step Separation.

Enable the option to Add Cutting and Creasing processing step layers, even if they're not included in
the Filter setting. If the Filter doesn't give any results, the Cutting and Creasing processing step layers
will not be added.

Enable Map to Black to show all visible separations in black. This is mostly used when only one
separation is visible, i.e. in combination with the Show only separation option, or when using a Repeat
Option on the Report Template. See Report Marks on page 87

Transformation
Use the Transformation Inspector to define the position of the Input File Mark. See Mark positioning on
page 411

Note:

You can not use the Scale tool to change the size of the Input File Mark. You can however
include the Input File Mark in a Resize Mark to change its size. See Resize Mark on page 406

Dimensions Mark on Input File Mark

If you attach a Dimensions Mark to an Input File Mark or to a Resize Mark containing an Input File Mark,
the Transformation Inspector of the Dimensions Mark will contain an extra option: Dimensions of:.
Using this dropdown, you can choose what dimensions of the Input File Mark the Dimensions Mark
should show.

Note:  When choosing the Dimensions of a page box of the Input File Mark, the Dimensions
Mark will show the original dimensions of the Input File, even if the Input File Mark was scaled.

Report Marks
When editing a Report Template, the Marks section will be replaced by "Report Marks". It will also
contain some additional settings.
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You can change the Input File using the dropdown. You can select any file that was used as Input File
earlier in the ArtPro+ session in the dropdown, or you can select Browse... to select a different file.

Note:  The Input File can't be a Normalized PDF file. If you want to use a Normalized PDF as
Input File, you should convert it to PDF+ and save it first. See Convert to PDF+ on page 59

Using the Repeat Page you can repeat the selected page in the final output in Automation Engine.

• If you choose Don't repeat this page in output the Report will contain the selected page just one
time

• If you choose Repeat page for all separations, the selected page will be repeated in the Report,
once for every separation in the Input File.

• If you choose Repeat page for all artwork separations, the selected page will be repeated in the
Report, once for every artwork separation in the Input File.

• If you choose Repeat page for custom filter, the selected page will be repeated in the Report,
once for every separation in the Input File that matches the rules you set. This allows you to select
separations by combining rules on Printing Method, Processing Step, Separation Name, Process
Separations or Non-Process Separations.

Note:  This Repeat Page setting still takes into account the "Repeat page" filter of the Input
File Mark, as set in the Marks Inspector.

These settings will have an effect on the Report in Automation Engine, but will not make the Report
Template in ArtPro+ a multipage document.

However, using the Repetition option you can preview each separation page.

Smart Text in a Report Template
When working on a Report Template, by default all Smart Text variables (except for category "System")
will resolve to the Input File. For example the "File Name" will show the name of the Input File. For more
information on Smart Text, see Using Smart Text on page 385

When working on a Report Template, you also have two additional Smart Text variables:

• Report Modification Date will show the modification date of the Report, not of the Input File.

• Marks > Scale Factor will show the Scale Factor applied on the Input File Mark.

Note:  If the document contains multiple Input File Marks, the Scale Factor will be shown of
the Input File Mark that is closest to the Text Mark in the file structure. If you want to ensure
the Scale Factor of the correct Input File Mark is shown, you can put the Text Mark and Input
File Mark in a group.
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3.12.  Insert Content from PDF

Using Insert Content from PDF you can insert the content of a PDF file on your current page.

1. Choose File > Insert Content from PDF...
2. Browse to the PDF document of which you want to insert the content in your current document and

click Insert
3. If the PDF document you selected is a multipage document, you have to select what page you want

to insert. Click Insert

The content of the PDF is inserted in the current page of your open document. The content is
positioned using the Trim Box of the source document: if the Crosshair is enabled, the content
is positioned at the bottom right of the Crosshair, and if the Crosshair is disabled, the content is
positioned centered on the current view.

The layer structure of the inserted (source) content and the open document will be merged, following
these principles:

• If a source layer name matches a layer in the current document (case sensitive), the objects will be
inserted in that layer, on top of all objects in that layer.

Note:  Even if they have the same name, a Processing Step layer and a regular artwork layer
will never be merged. A new Processing Step layer or Artwork layer will be created.

• When inserting in a Normalized PDF, objects from Processing Step layers are inserted into a regular
artwork layer with the same name as the Processing Step layer.

• If a source layer doesn't exist in the current document, it will be created on top of the current layers,
and have the same printing state as the source layer.

• You can't insert into a hidden layer. If the target layer is hidden, you will get the option to cancel or to
make the target layers visible before inserting.

3.13.  Document Setup

Using Document Setup, you can add a Distortion value to your file. This will be applied during ripping,
to compensate for distortions that happen during printing.

Choose File > Document Setup, enter a Vertical Distortion Factor and Horizontal Distortion Factor
and click OK.

Note:  When placing a PDF+ or Normalized PDF in another document, Distortion Factors of the
placed PDF will be ignored.

Distortion factors defined in a Plato PDFPLA file or in a Normalized PDF exported from ArtPro will be
kept when opening the file in ArtPro+.
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3.14.  Working with Picture Lists

A Picture List is an ASCII text file (.picl) containing information on Linked Placed Art: the name, the
position and size of the bounding box, the picture center and the page box.

These Picture List files can be exported in ArtPro or ArtPro+, or can be created in any other
application, as long as the ASCII text file has the correct construction. See Construction of a Picture
List File

Note:  In ArtPro+, Picture Lists is only supported for PDF+ files.

Export to Picture List
To export the information of the Linked Placed Art in your document as a Picture List, choose File >
Export to > Picture List... and define the name and location for the file.

Note:  Only the information of Linked Placed Art is stored in the file. All other objects are
ignored.

Open a Picture List
To open a Picture List, choose File > Open, set the file type to Picture List Files and select the Picture
List file you want to open.

A new document will be generated, using the Size defined in the Picture List File for the Trim Box and
Media Box.

If the files are in the same folder as the picture list, ArtPro+ will place the pictures described in the
Picture List file If not, you will be asked to browse to the file.

Note:  .picl files from ArtPro containing links to .ap files are not supported.

Construction of a Picture List File
• ArtPro Picture File V1.0

• Units; this can be mm or inch

• Size; the job size, in the unit set above.

• The Filename;

• the Position of the bounding box; the position of the top left corner of the bounding box is defined.
The first value is the vertical distance from the top left corner of the job size, the second is the
horizontal distance.

• The Size of the bounding box; the next two values define the vertical and horizontal size of the
bounding box.

• Rotation; the rotation can be 0, 90, 180 or -90 degrees.

• The picture center offset, defining where to center the image, based on the topleft corner of the
bounding box. If no picture center offset is entered, the picture is centered on the bounding box
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• The Page Box to be used. If no page box is defined, the trim box is used.

3.15.  Print

Using File > Print or its shortcut Cmd+P (Mac) or Ctrl+P (Windows), you can send your PDF document to
any of your configured printers.

The document will be clipped by the Media Box.
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4.  Changing the View
• By default files are opened in the same window size as the last closed document, at "Fit in Window"

zoom level. See Fit in Window on page 93. The Page Boxes are shown or hidden depending on the
last saved visibility state.

• Files are always viewed in overprint preview

• Like in all recent Esko applications, technical inks in Normalized PDF documents are rendered as
opaque

Note:  Rotation flags are not taken into account. You can however change the rotation
yourself: see Rotate View on page 96

Changing the view will not change the file itself: all these changes can not be saved in the file.

4.1.  Multiple Document Windows

If you have multiple documents open, every document will have a separate window.

You can activate the document you want to work on in different ways.

• Simply click in a window to activate it
• Select the document you want to activate in the Window menu. The active document is indicated

with a check mark. Unsaved documents are indicated with a *.

• Use Cmd + ` (Mac) or Alt + Tab (Windows) to cycle through the different windows.

4.1.1.  Arrange document windows

If you have multiple document windows open, you can arrange them vertically or horizontally.

• Select Window > Arrange > Vertically to place the open document windows next to each other

• Select Window > Arrange > Horizontally to place the open document windows above each other

Note:  If you use multiple monitors, the document windows are always arranged on the primary
monitor, as defined in the operating system's settings.

4.1.2.  Synchronize Views

If you have two or more document windows, you can apply the same zoom, pan, and orientation zoom
on all document windows by enabling Synchronize Views, either by choosing Window > Synchronize
Views or by its shortcut Cmd + Alt + 1 (Mac) or Ctrl + Alt + 1 (Windows).
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4.2.  Changing the Zoom factor

4.2.1.  Fit in Window

• Shortcut: Cmd+0 (Mac) or Ctrl+0 (Windows)

• Menu: View > Zoom > Fit in Window / Previous

Using the Fit in Window function a second time will go back to the previous view (position and zoom),
allowing you to toggle between the two views.

Fit in Window with Page Boxes hidden:

If the Page Boxes are hidden, Fit in Window will center the view and adjust the zoom factor so that all
graphics (including elements outside of the Media Box) are visible in the document pane.

Fit in Window with Page Boxes visible:

In most cases, the Crop Box is completely inside the Media box. In that case, Fit in Window will fit on
the Crop Box. Contents outside the Crop Box will be grayed out.

However, it is possible that the page boxes were defined differently:

• If no Media Box is available, the full Crop Box is shown. Contents outside the Crop Box is grayed out.
• If no Crop Box is available, the Media Box is shown. Contents outside the Media Box is grayed out.
• If the Crop Box is partially outside the Media Box, Fit in Window will center and fit on the part of the

Crop Box that is inside the Media Box. Other content is grayed out.

• If the Crop Box is completely outside the Media Box, both Media Box and Crop Box are fitted, but all
content will be grayed out.

4.2.2.  Actual Size

• Shortcut: Cmd+1 (Mac) or Ctrl+1 (Windows)

• Menu: View > Zoom > Actual Size / Previous

Actual Size will set the zoom factor to 100% to get a clear view on the actual size of the document and
its elements. Actual Size or 100% means 100% at a fixed resolution of 72ppi, which is the same as in
Adobe Illustrator if the 'Display Print Size at 100% Zoom' preference is disabled. 

This action will not recenter the contents of the file but keep the current center point as its center.

Using the Actual Size function a second time will go back to the previous view (zoom), allowing you to
toggle between the two views.

4.2.3.  Zoom to Selection

• Shortcut: Cmd+Alt+0 (Mac) or Ctrl+Alt+0 (Windows)

• Menu: View > Zoom > Zoom to Selection / Previous
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Zoom to Selection displays the selected objects as big as possible in the active window. 

Using the Zoom to Selection function a second time will go back to the previous view (zoom), allowing
you to toggle between the two views.

4.2.4.  Zoom In / Zoom Out

• Shortcut for Zoom In: Cmd++ (plus) (Mac) or Ctrl++ (plus) (Windows)

• Shortcut for Zoom Out: Cmd+- (minus) (Mac) or Ctrl+- (minus) (Windows)

• Menu: View > Zoom > Zoom In and View > Zoom > Zoom Out

Zooming in or out using the shortcuts or by clicking will zoom in fixed steps: zooming in multiplies the
current zoom factor by 1,414 (√2), zooming out by 0,7071 (1/√2). This means you can go to double or half
the current zoom percentage in two steps. You can for example go from 100% to 141,4% to 200% or vice
versa.

The current Zoom level is shown in the window title, next to the file name.

Maximum zoom factor is 100.000%

Minimum zoom factor is reached if the Media Box is displayed at approx. 2 by 2 centimeter.

If the document no longer fits inside the window, horizontal and vertical scroll bars will appear.

For more zoom controls, see Zoom tool on page 94

4.2.5.  Zoom tool

The Zoom tool (shortcut: Z) can be used to change the zoom factor.

• Click to zoom in
• Alt-click to zoom out
• Click and drag a rectangle to zoom in on the area. The area will also be centered.

You can temporarily use the Zoom function without leaving the currently selected tool using the
modifier keys:

• Space+Cmd (Mac) or Space+Ctrl (Windows) to zoom in
• Space+Alt+Cmd (Mac) or Space+Alt+Ctrl (Windows) to zoom out
• Hold the Alt key in combination with the mouse wheel to zoom in or out.

As soon as you release the modifier keys, the selected tool becomes active again.

4.3.  Pan tool

The Pan tool (shortcut H for Pan, or shortcut Z, toggling between Zoom and Pan) can be used to move
the view by clicking and dragging.

You can temporarily use the Pan function without leaving the currently selected tool using the modifier
keys: press and hold Space.

As soon as you release the modifier key, the selected tool becomes active again.
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4.4.  The Crosshair

The Crosshair is a reference point in the ArtPro+ document and can be moved around.

By default, the Crosshair is hidden, but its visibility is remembered when quitting and restarting ArtPro
+. When visible, its default location is at the upper left corner of the media box.

The center for the linear transformations (rotation, scale, mirror, shear) is the zero point of the
activated Crosshair. When you deactivate or hide the Crosshair the center of the bounding box of the
selected objects is used instead. See Transforming objects on page 158

If the Transform tool is selected, you can also move and snap the bounding box of the selected objects
onto the Crosshair by holding the Cmd key (Mac) or Ctrl key (Windows) while using the arrow keys. See
Move on page 160

The Crosshair can be moved and rotated using the Crosshair tool (see Move or rotate the Crosshair on
page 95).

To hide or show the Crosshair, you can:

• Use the shortcut Cmd+R (Mac) or Ctrl+R (Windows)
• Select View > Hide Crosshair or View > Show Crosshair
• Click the eye or "-" icon in front of Crosshair in the Prepress Layers section in the Side Panel.

4.4.1.  Move or rotate the Crosshair

You can use the Crosshair Tool from the Tool Switcher (Shortcut: R, toggling with Cut on Crosshair,
see Cut on Crosshair on page 96) to move or rotate the Crosshair

• Use the arrow keys to move the Crosshair over the fixed Keyboard increment distance defined in
the preferences, or over 10 times that distance when holding the shift key. See Preferences on page
49

• Hold the Cmd+ALT key (Mac) or Ctrl+ALT key (Windows) while using the arrow keys to move and
snap the Crosshair onto the 9 anchor points on the bounding box of the selected objects. If no
objects are selected, the Crosshair will snap to the trim box.

Note:  Cmd+ALT is also the Modifier for the Crosshair: whatever tool is currently selected,
you can hold Ctrl+ALT to temporarily switch to the Crosshair tool.

• Click in your document to position the Crosshair center
• Click and drag the Crosshair to position it, snapping magnetically to all selected paths. The path

the Crosshair is snapping to will be highlighted. The Crosshair will snap to lines, curves and anchor
points, even if the Crosshair is rotated. Hold the Ctrl key (both on Mac and on Windows) while
dragging to disable the magnetism.

• Click and drag on the horizontal or vertical line of the Crosshair to move only this line of the
Crosshair. The same magnetism is applied as when moving the Crosshair (see above). Hold the Ctrl
key (both on Mac and on Windows) while dragging to disable the magnetism.

• Hold the ALT key and click and drag to rotate the Crosshair. A blue circle is shown on the center of
the Crosshair, containing the Angle Readout. Hold down the Shift key to constrain the rotation to
multiples of 15 degrees.
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• Hold the ALT key and click on the center of the Crosshair to enter the desired angle for the
Crosshair.

4.4.2.  Cut on Crosshair

Using the Cut on Crosshair tool, you can cut away parts of the selected objects, based on the position
of the Crosshair.

1. Select the objects you want to cut.
2. Select the Cut on Crosshair Tool from the Tool Switcher under the Crosshair tool, or use the

shortcut: R, toggling with the Crosshair tool, see Move or rotate the Crosshair on page 95
The cursor changes into a pair of scissors.

3. Indicate what quadrant you want to cut away

• Click the quadrant to cut away the parts of the selected objects in that quadrant.
• Click and drag multiple quadrants to cut away the parts of the selected objects in those

quadrants.
• Hold the Alt and click or drag to keep the parts of the selected objects in the selected

quadrants, and remove all other quadrants.

4.5.  Rotate View

You can rotate the view in multiples of 90 degrees.

• You can rotate the view clockwise by selecting View > Rotate View > Clockwise or by its shortcut
Cmd+Shift++ (plus) (Mac) or Ctrl+Shift++ (plus) (Windows).

Note:  The shortcut only works using the plus key from the numeric keypad.

• You can rotate the view counterclockwise by selecting View > Rotate View > Counterclockwise or
by its shortcut Cmd+Shift+- (minus) (Mac) or Ctrl+Shift+- (minus) (Windows)

If the View is rotated, a compass-like Rotation indicator is shown in the bottom right of the document
pane, indicating the current rotation

 

 

• You can go back to the normal view (no rotation) by selecting View > Rotate View > No rotation or by
clicking the Rotation indicator
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4.6.  Preview or Outline mode

ArtPro+ can displays the document in two modes: Preview mode, where the filled version of the file is
displayed, or Outline mode where only the technical lines of the paths (vectors) are visible.

Functions can be executed both in preview mode and in outline mode.

To switch between Preview and Outline:

• Use the shortcut Cmd+Y (Mac) or Ctrl+Y (Windows)

• Select View > Switch to Preview or View > Switch to Outline

• Using the View Mode selector button in the top right of the Side Panel

By default, in Outline mode, you will still see "hinting": a dimmed version of the colored preview below
the outlines. You can switch this on or off using the + button next to the View Mode selector button
when in Outline mode.

 

 

1. Preview mode
2. Outline + mode with "hinting"
3. Outline mode without "hinting"

4.7.  Hiding objects

Using the Hide function, you can hide the selected objects.

Hidden paths are no longer visible and cannot be selected nor modified. Still, they are saved with the
file, so they will become visible again, when the file is next opened. You can apply this function multiple
times, to hide additional objects.

Show All makes all hidden paths visible again.

It will deselect all paths in the current job first and then show the hidden paths, which will come back
selected. This allows you to check something and then immediately Hide them again.
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• Select Object > Hide or its shortcut Cmd+3 (Mac) or Ctrl+3 (Windows)
• Select Object > Show All or its shortcut Cmd+Alt+3 (Mac) or Ctrl+Alt+3 (Windows)

4.8.  Color Management

In ArtPro+ you can have a color managed preview of your job.

To use Color Management, a number of options and functions are available:

• Color Managed Preview
• The Color Space
• The Default Profile set in the Preferences. See Preferences on page 49

Color Managed Preview can be switched on and off by choosing View > Color Managed Preview or by
using its shortcut Cmd+Alt+Y (Mac) or Ctrl+Alt+Y (Windows).

If Color Managed Preview is enabled, the document will be rendered using the Document Profile

• If your document contains an embedded profile, this profile will be used.
• If your document contains a link to a profile that is installed on your computer, this profile will be

used
• If your document refers to a profile that is not embedded and not installed on your computer, or if

no profile is defined, the Default Profile set in the Preferences will be used.

You can change the Document Profile by clicking the Document Profile in the Separations section of
the Side Panel, and selecting a profile to be used.

Note:  Installing ArtPro+ does not automatically install any color profiles.

Saving a PDF+ file requires an output intent. Therefor, when saving a file in ArtPro+ that is not a
Normalized PDF, the Default Profile will be used as Color Space if no profile has been set yet, and a
warning will be shown.

GMG OpenColor Server
You can also use a GMG OpenColor Server as Color Management tool. See GMG OpenColor on page 99

4.8.1.  Objects, groups or pages susceptible to color conversion

In a PDF, objects, groups or pages can be in a color space that is susceptible to color conversion. This
can be e.g. an object tagged with a color profile, or in a color space other than CMYK / DeviceN such
as RGB. Those objects will always be shown color converted, i.e. taking into account the color space
and the current document profile. Changing the document profile will change the appearance of these
objects.

You can remove color profiles from such objects in your document using Object > Remove Color
Profile. See Remove color profile on page 99

You can see the color space:

• in the Fill or Stroke Color inspector. See Fill Color and Stroke Color Inspector on page 182
• in the Placed Art Inspector. See Placed Art Inspector on page 223
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• in the Transparency Inspector, to see the Group Color Space. See Transparency Inspector on page
189

• in the Separation section, to see the Page Color Space. See Separations on page 132. You can
remove the page Color Space by clicking the x next to its name.

Note:  If a page is in a color-conversion susceptible color space, a warning will be shown
indicating that the Document Profile will not be taken into account for the current page.

In the Object Browser objects or groups in color spaces susceptible to color conversion are indicated

by the Color Swatch Fan icon . There's also a separate mode to only see objects and groups in color
spaces susceptible to color conversion. See Object Browser on page 130

Remove color profile
You can remove the color profiles from objects in your document.

1. Select the object(s) you want to remove the tagged color profile from.
2. Remove the color profile from the object(s):

• If you want to remove the color profile and keep the initial values as stored in the PDF document
(before color conversion), choose Object > Remove Color Profile > Keep Color Values

• If you want to convert the values first, taking into account the tagged color profile and the
document profile, and then remove the color profile, choose Object > Remove Color Profile >
Keep Visual Appearance

Note:  For Non-CMYK objects, as the input is non-CMYK, "Keep Color Values" can't be
applied. When removing the color profile from such objects, the result will always be "Keep
Visual Appearance", regardless of your choice.

4.9.  GMG OpenColor

In ArtPro+, you can use GMG OpenColor (not GMG colorServer) as Color Management Tool by connecting
to the server on which GMG OpenColor is installed, providing you have the appropriate licenses.

License
Next to licensed access to the GMG OpenColor Server, you need an "ArtPro+ GMG OpenColor Connector"
license. See Licensing on page 29.
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Note:

There is an important difference in how multiple licenses are handled on the GMG server and
for Network Licenses or Dynamic Subscriptions in ArtPro+:

• The GMG licenses allow for a specified number of connections, i.e. computers that can
connect to the server. When a computer is connected to the server, a token will be given.
Once the maximum number of connections has been reached, other computers can't
connect until a token is released on the GMG OpenColor Server.

• Network Licenses and Dynamic Subscriptions define a maximum number of concurrent
users. When one user logs off, another user can use the license.

This means that when e.g. all Network Licenses and GMG licenses are in use, it is sucient to
quit ArtPro+ (or disable the additional license) on one computer to use the Network License
on a different computer, but you will need to release the token on the GMG server for the new
computer to connect to the GMG server.

Connecting to the GMG OpenColor server
You can establish a connection to your GMG OpenColor server by entering the server address in the
Preferences: See Color Management Preferences on page 53

The minimum required version of your GMG OpenColor server is 2.4.7. If the version is lower, or if the
appropriate license is missing, you will not be able to connect.

Note:  GMG OpenColor does not work with Normalized PDF files. You can use Convert to PDF+ if
necessary. See Convert to PDF+ on page 59

Viewing
When opening a PDF file the Document Profile is shown in the Separations panel on the right hand
side.

When connected to a GMG OpenColor server, the Document Profile dropdown will not only show a list
of all available ICC profiles but also the GMG OpenColor Projects present on the server.
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If you select a project, and the color profile for the current separations in the file is not calculated yet,
the server will start a calculation. While this calculation is ongoing, a spinning wheel is shown next to
Preview icon.

When working with a GMG project, you want ot have a color-accurate preview, so if Color Managed
Preview is disabled in the View menu, a yellow triangle is shown next to the Preview icon.

When the calculation is done, your separations are synchronized with the selected GMG Project:

• The color patches will be updated according to the values on the GMG OpenColor server (when Color
Managed Preview is enabled in the View menu), and the document is rendered accordingly.

• If a separation is not registered in the GMG Project, its color patch will contain a white triangle,
indicating the separation is considered an "unregistered" ink.

When adding a new separation to the document, the separation setup changes, so a new calculation is
started on the server.

Note:

Some actions, like a copy and paste from a different document, can result in separations being
added without triggering a new calculation on the server.

To make sure that all separations are synced, click the Synchronize with GMG Project button

, which will launch a new calculation.

When the calculation is finished and the PDF+ is saved, the Document Profile is included in the PDF. As
a result, viewing the file in e.g. Adobe Acrobat will show the same view as in ArtPro+.

A PDF viewed with a GMG Project as Document Profile is also rendered according to that Document
Profile when choosing the Quality Control features like Flexo Print Preview, Registration Error and
Compare. See Quality Control on page 103
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Recolor
When connected to a GMG OpenColor server, you can choose to Convert with GMG OpenColor Project
in the Recolor dialog. See Convert Separation with GMG OpenColor on page 194

Color Compare
After a conversion you can see and measure the possible ∆E differences resulting from the conversion
using the Compare functionality.

1. After the Recolor is done, save the document under another name so you have a Before and After, a
reference and new document.

2. Open both files, and go to Quality Control > Compare. See also Compare on page 110
3. In the Unmatched Separations dialog, switch to Compare color (instead of "Compare separations").

 

 
4. Set the Detail Level for the comparison: Fast (600dpi), Balanced (1200dpi) or Accurate (2400 dpi)
5. Set the ΔE 2000 Threshold, either by entering a value or by using the slider.

Areas with a higher ΔE than the entered Threshold are shown as difference.

As in the Compare Separations mode, you can use the Highlight different pixels option to get a clearer
view on the difference, and use the “C” key to switch between the reference and the current document.
See Compare on page 110
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5.  Checking and Measuring

5.1.  Quality Control

In the Quality Control section you can perform some quality control functions

• Check the Total Area Coverage: see Total Area Coverage on page 103

• Check for highlight Breakout: see Breakout on page 104

• Check each separation in Flexo Plate Preview: see Flexo Plate Preview on page 104

• Check your document in Flexo Print Preview: see Flexo Print Preview on page 105

• Check for Moiré: see Moiré Detection on page 106

• Visualize the used Screen Sets. See Object Screening on page 107

• Check your trapping by showing a Registration Error: see Registration Error on page 108

• Check color differences for specific Color Strategies using Digital Print Simulation: see Digital Print
Simulation on page 108

• Compare two documents. See Compare on page 110

5.1.1.  Total Area Coverage

The Total Area Coverage (TAC) is the sum of all separation-densities at a certain point in your
document.

To enable the Total Area Coverage preview, select "Total Area Coverage" from the Quality Control
dropdown list and - if no Eye icon is visible yet, click on the "-" icon in front of "Total Area Coverage".
Once the Total Area Coverage preview is enabled, the image in the preview pane will be dimmed and all
areas where the sum of the densities is higher than the TAC limit specified in the current Press Setting
will be highlighted. You can define the highlight color in the Preferences: see Preferences on page 49

The Limit is the maximal Total Area Coverage that your document may contain. This value depends on
the press and the substrate your design will be printed on. Your printer should provide you with the TAC
Limit value to use.

You can click inside the Limit field and enter the Limit value, or you can use the arrow up key to
increase the TAC Limit value or the arrow down key to decrease the value. You can set the value up to
500%. You can hold the Shift key to increase or decrease the value 10 times faster.

You can use the Densitometer to measure the densities at a specific location. See Densities on page
116.

Note:  Invisible layers, invisible separations and Technical Inks are not taken into account.
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5.1.2.  Breakout

A Breakout is an area where the percentage of a single separation is lower than the First Printable Dot
value. This can be used to track areas that won’t show up on print because the values are too low.

Your printer should provide you with the First Printable Dot value. The First Printable Dot value is the
same as used in the Flexo Plate Preview and Flexo Print Preview. See Flexo Plate Preview on page 104
and Flexo Print Preview on page 105. The value is always rounded off to the closest system value
(n/255 in %). You can increase or decrease the value by one system value using the arrow up or arrow
down key while in the First Printable Dot field. You can hold the Shift key to increase or decrease the
value 10 times faster.

To enable the Breakout preview, select Breakout from the Quality Control dropdown list and - if no Eye
icon is visible yet, click on the "-" icon in front of "Breakout". Once Breakout is selected and enabled,
all areas where a single separation has a value lower than the First Printable Dot value (but higher
than 0%), will be displayed in highlight color. You can define the highlight color in the Preferences: see
Preferences on page 49.

Note:

Keep in mind that:

• breakouts are only highlighted if they are lower than (and not equal to) the Limit value but
higher than 0%,

• values are rounding off to the closest system value (n/255 in %): 0%, 0.4%, 0.8%, etc.

If you enter 0.8% as First Visible Dot, you will only see breakouts for values that are rounded off
to 0.4%.

If you enter 0.4% as First Visible Dot, no breakouts can be shown. It is advised to only enter
0.4% if you are sure that your device can print values as low as 0.4%. It is only for such devices
that the Breakout Quality Control with first printable dot set to 0.4% will correctly confirm that
everything is printable.

You can use the Densitometer to measure the densities at a specific location. See Densities on page
116.

Note:  Invisible layers, invisible separations and Technical Inks are not taken into account.

5.1.3.  Flexo Plate Preview

Flexo Plate Preview shows a single separation as a simulated flexo plate. In the Plate Color dropdown
you can choose the plate color (Red, Blue, Green, Yellow, or Blue&White) to match the type of plate you
are using.

Note:  As long as Flexo Plate Preview is enabled, only a single separation can be viewed at a
time.

The Preview will display percentages below the first dot percentage as 0%.

Your printer should provide you with the First Printable Dot value. The First Printable Dot value is
the same as used in the Flexo Print Preview and Breakout. See Flexo Print Preview on page 105 and
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Breakout on page 104. The value is always rounded off to the closest system value (n/255 in %). You
can increase or decrease the value by one system value using the arrow up or arrow down key while
in the First Printable Dot field. You can hold the Shift key to increase or decrease the value 10 times
faster.

To enable the Flexo Plate Preview, select Flexo Plate Preview from the Quality Control dropdown list
and - if no Eye icon is visible yet, click on the "-" icon in front of "Flexo Plate Preview".

You can use the Densitometer to measure the densities at a specific location. See Densities on page
116.

Note:  Invisible layers, invisible separations and Technical Inks are not taken into account.

5.1.4.  Flexo Print Preview

Flexo Print Preview shows the effect of highlight dot gain on your document. Going from light to dark,
the Preview will display percentages below the first dot percentage as 0%. The first dot percentage will
be shown darker (using the Prints As value). Towards the midtones this darkening effect will fade out
until the Range value. Percentage larger than Range, are displayed unchanged

Your printer should provide you with the First Printable Dot, Prints as and Range values. The First
Printable Dot value is the same as used in Flexo Plate Preview and Breakout. See Flexo Plate Preview on
page 104 and Breakout on page 104. The values are always rounded off to the closest system value
(n/255 in %). You can increase or decrease the value by one system value using the arrow up or arrow
down key while in the one of the input fields. You can hold the Shift key to increase or decrease the
value 10 times faster.

To enable the Flexo Print Preview, select Flexo Print Preview from the Quality Control dropdown list
and - if no Eye icon is visible yet, click on the "-" icon in front of "Flexo Print Preview".

You can use the Densitometer to measure the densities at a specific location. See Densities on page
116.

Note:  Invisible layers, invisible separations and Technical Inks are not taken into account.

Flexo Print Preview and Continuous Printing
If you have defined Plate Cutting Paths in your document or if Continuous Printing is enabled in the
Layout Inspector, the Flexo Print Preview will show extra information and a number of options to
inspect the Plate Cutting Paths. See The Layout Inspector on page 347 and Create Automatic Plate
Cutting Paths on page 372
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• The Web Direction set in the Create Plate Cutting Paths dialog or the Layout inspector: either
vertical or horizontal

• The Plate Circumference

• The grid repetition will be endlessly repeated for visual inspection. Note that this is a preview, it is
not saved in the file. Processing Step separations are disabled as they are not printed and have no
Plate Cutting Paths.

• Enable Show Place Cutting Paths to visualize the Plate Cutting Paths for the visual separations.

• You can press the C key to show artwork in the gap, to inspect when a Plate Cutting Path cuts
through e.g. bearer bars or cuts away artwork (bleed).

5.1.5.  Moiré Detection

Using the Moiré Detection preview, you can detect possible screening problems in your document.
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Define the Screening Model. In Imaging Engine in the Advanced Screening Settings you can set the
Screening Model, defining how to handle overlapping screens. To mimick the result in Imaging Engine,
you should set the Screening Model in ArtPro+ to the same value as in Imaging Engine: Adobe to use
the Adobe PDF Rip method, or Esko to use the FlexRIP method.

Note:  The same Screening Model is used in Object Screening. See Object Screening on page
107

Using the filter, you can choose to only include objects with a density between two values, by default
5,1% and 94,9%. By enabling Ignore light separations you can choose to ignore separations with a
luminance higher than the Maximum Luminance.

If you enable Moiré Detection, the document will be shown dimmed, and areas with possible screening
problems are highlighted.

A possible screening problem exists if one of these conditions is met:

• the angles for the separations used in that area are the same
• the angles for the separations used in that area do not differ 30 degrees
• the rulings for the separations used in that area are different
• the dot shapes for the separations used in that area are different

 

 

If possible screening problems are found, you can enable or disable the toggles to only highlight
screening errors matching the selected conditions. If there are no moiré conflicts for a certain
condition within the currently viewed area, that option will be greyed out. Note that zooming or
panning can change which screening problems are found in the currently viewed area.

• If an unscreened object is involved, this is considered matching all of the conditions.

• Angles are considered the same if they differ a multiple of 90º. E.g. an angle of 7,5º and an angle of
97,5º will highlight as "Angles are the same".

• If the angles are the same, this is not highlighted as "Difference between angles is not 30º "

• All visible separations are taken into account. If you want to disregard a separation (e.g. a Technical
ink or a Processing Step Separation) you can hide that separation.

5.1.6.  Object Screening

Using the Object Screening Preview, you can get an indication of what Screening Set is used on what
objects.
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The Quality Control section will show a list of all Screen Sets used in your file, each with a different
color. Objects using a specific screen set will show in the corresponding color. Areas where multiple
screen sets overlap are shown in red.

Note:  Only screening conflicts involving overprint are highlighted. Blend modes are not taken
into account.

Define the Screening Model. In Imaging Engine in the Advanced Screening Settings you can set the
Screening Model, defining how to handle overlapping screens. To mimic the result in Imaging Engine,
you should set the Screening Model in ArtPro+ to the same value as in Imaging Engine: Adobe to use
the Adobe PDF Rip method, or Esko to use the FlexRIP method.

Note:  The same Screening Model is used in Moiré Detection. See Moiré Detection on page
106

Using the eye icons, you can make the objects using the selected Screen sets visible or invisible.

For more information on Screening, see Screening on page 316

5.1.7.  Registration Error

The Registration Error Preview is a simulation of a design printed with registration errors. It can be
very helpful to see if trapping is applied suciently and correctly.

The separations are randomly shifted.

In fact, all separations are moved exactly the distance of the Maximum Deviation, but all under a
random angle.

If you want to see another random registration error simulation, press Y

 

 

In the example above, you can see a small area of a job in regular preview (left) and with registration
errors (right). In this case, you can clearly see no trapping was applied, so white lines appear at the
registration shifts.

5.1.8.  Digital Print Simulation

Using Digital Print Simulation, you can inspect the color differences that your job will have if converted
using a digital color strategy.
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Using the dropdown, you can select a Color Strategy from the list of available Digital Printing Color
Strategies on the selected Color Engine. See the Color Management tab of the Preferences on page 49

In the simulation the ΔE values are calculated:

1. The DeviceN values (the ink density for each separation in your document) are converted to Lab
using the Input Profile of the selected Color Strategy.

2. The same DeviceN values are used to calculate the Converted DeviceN values based on the Digital
Printing Color Strategy.

3. These DeviceN values are then converted to Lab using the Output Profile of the selected Color
Strategy.

4. The difference between both Lab values results in the ΔE value.

You can set the ΔE 2000 Threshold either by entering it in the input field, or by dragging the slider
below. All areas with a ΔE higher than the threshold will be highlighted in the job. Underneath the slider,
the total amount of Affected Areas (i.e. the areas with a higher ΔE) is shown both in percentage of the
complete job, and in absolute surface.
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Note:  Processing Steps are not included in this simulation.

5.1.9.  Compare

Using the Compare function, you can compare the current page of the current document with a
Reference file

1. To enable Compare, select Compare from the Quality Control dropdown list.
2. Set a Reference file. You can select any open file from the dropdown list, or select another file by

choosing Browse.

Note:  If your open document is a Grid or Cad based Step&Repeat, and your reference file
is a one-up, you will be able to compare Layout Stations to a one-up. See Compare Layout
Stations to a One-Up on page 114

3. If the Reference file contains multiple pages, you can set the page to be used.
4. The Comparison button will show the Comparison method, the Resolution and corresponding

Threshold Value used. Click the button to open the Comparison dialog and set the Comparison
method:

• Separations will match separations and compare the densities. See Compare Separations on
page 112

• Color (Lab) can only be used when comparing documents with a GMG Project as Document
Profile. See GMG OpenColor on page 99

• Color (HSV) will compare the visual appearance of the documents (based on the HSV values),
disregarding the separations used. See Compare Color (HSV) on page 113

5. If needed, (re)set the Alignment

By default, ArtPro+ will align the two documents based on the common visual objects.
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Compare will also automatically rotate the reference file over multiples of 90 degrees. The view
with minimum differences is used for the final comparison result. If the reference file is rotated, a
compass-like Rotation indicator is shown in the bottom right of the document pane when holding

"C", indicating the current rotation

If the majority of the common visual objects are moved during an edit, there will be an automatic
realignment on all visible objects. If you make small edits, e.g. change the visibility of specific
elements, no realignment is done. In that case you can use Align on All or Align on Selection
buttons to change the alignment.

Note:  Aligning on common visual objects can result in the reporting of page box
differences, even if the page boxes have the same size: this indicates that the common
elements in both files have a different relative position to their respective trim and media
boxes.

6. When comparing Layout Stations to a one-up, you can browse through the different stations on
your Layout. See Compare Layout Stations to a One-Up on page 114

7. Compare the documents:

ArtPro+ will calculate the visual differences. The job will be shown dimmed (1) for Separations
Comparison, or in grey mode (2) for HSV Comparison, with rectangles indicating the visual
differences.

• Click the eye icon in front of Compare to toggle between differences view and normal view.
• Hold the C key to temporarily show the reference file instead of the current document. By using

this toggle, you can easily see the difference between both documents.

Note:  When toggling between the active file and the reference file, the Page Box
information (when visible) will be updated. The Layer list and Separation list is not
updated, and thus will always show the information of the active document.

Note:  When using the Densitometer tool, you can see the densities of the reference
document by holding the C key. See also Densities on page 116
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• To get a more specific indication of the differences, you can enable Highlight different pixels.
Within the rectangular area, this will highlight the difference in pixels using the Highlight color
set in the Preferences. The image below shows the difference with the option disabled (left) and
enabled (right) when doing a Separations compare.
 

 
8. You will get an indication on the number of areas containing visual differences, along with a

notification in case the trim box, media box of the two documents don't match.

Note:

When you navigate to another page of the active document or another page of the Reference
document, Compare will automatically realign based on the common visual elements.

Compare Separations
In the Compare section, the Comparison button will show the Comparison method, the Resolution and
Value used. (density threshold, ΔE or threshold).

Separations will align separations and compare the densities.

1. Click the button to open the Comparison dialog
2. Set Compare to Separations
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3. Set the Detail Level for the comparison: Fast (600dpi, the default setting), Balanced (1200dpi) or

Accurate (2400 dpi, necessary to detect hairlines)
4. Set the Density Threshold, i.e. the minimum difference in density that is considered different. By

default this is set at 2%.
5. Every separation in the current document that is not found in the reference document is shown as

Unmatched - Show Warning. You can match it with a separation from the reference document by
selecting it in the dropdown, or you can set it to Don't Compare

6. The Unmatched reference separations at the bottom indicate what separations in the reference
document are not matched to a separation in the current document. You can set these to Show
Warning or Don't Compare

When in Separations comparison mode, you will get an indication of what separations have
differences, and an indication if the separations list is different.

Compare Color (HSV)
In the Compare section, the Comparison button will show the Comparison method, the Resolution and
Value used. (density threshold, ΔE or threshold).

Color (HSV) will compare the visual appearance of the documents (based on the HSV values),
disregarding the separations used.

1. Click the button to open the Comparison dialog
2. Set Compare to Color (HSV)
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3. Set the Detail Level for the comparison: Fast (600dpi, the default setting), Balanced (1200dpi) or
Accurate (2400 dpi, necessary to detect hairlines)

4. Set the Threshold, i.e. the minimum difference in color that is considered different. By default this
is set at 10%.

Calculating the differences
When calculating the differences between the current document and the reference document, these
rules are followed:

• Visible layers of the current document are compared against all printing layers of the reference
document

• When the visibility state of the layers of the current document is changed, the comparison is
recalculated accordingly. This allows you e.g. to disable the trap layer in the current document
and check if the artwork of this trapped document still matches that of the untrapped reference
document.

• Visible separations of the current document are compared to all separations of the reference
document. A difference that is only found in one specific separation will not be reported if that
separation is hidden. Technical inks in Normalized PDF and processing step colorants in PDF+ are
also compared.

• When separations are hidden or made visible, the comparison is recalculated accordingly

• To exclude technical inks or processing step colorants from the comparison, you can hide them
or choose Don't Compare in the Separation Matching dialog.

• If the current document is rotated, the reference document is rotated in the same way

Note:

Even when no visual differences are found, it can happen that the previews look different
when toggling between the current document and the reference document. This is typically
the effect of a different separation order: When the order of the separations is different, the
visual effect on screen may be different as well, e.g. because of opaque inks, or due to color
management.

This alone does not affect the output of each individual plate though, so no difference is found.
In this case, the following message will be issued: "Separation order is different. Preview on
screen may be different."

Compare Layout Stations to a One-Up
Using Compare, you can also compare all stations of a Layout file to a reference one-up.
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1. Open the Layout file

This can be a Grid or CAD based Step & Repeat, or a Static Grid.
2. To enable Compare, select Compare from the Quality Control dropdown list.
3. Set the Reference file by browsing for the one-up reference file.

Compare will detect your intention to compare all copies of the Placed Art (the stations) to the
reference file. The Station Browser will appear (see later).

4. Set the Comparison Method. See Compare on page 110
5. Using the Station Browser you can select each station individually for comparison, one by one.

Compare will automatically zoom in on the first station and align to the reference one-up. You can
use the arrows to browse through the different stations.
 

 

The differences are highlighted, and the Compare side drawer reports about the current
comparison area: the selected station and the one-up. See Compare on page 110

6. The Bleed of the station is also compared to the bleed of the one-up, allowing you to verify that
each station has the correct bleed.

The detection of the bleed distance in the one-up is done in this priority order:

1. The Bleed Processing Step: If the one-up has a Bleed Processing Step, this outline is used as
the bleed mask. This is the most recommended practice.

2. The Cutting Processing Step: In case the one-up does not have a Bleed Processing Step, ArtPro
+ looks for a Cutting Processing Step. The bleed distance between the cutting outline and the
artwork is calculated outside the cutting lines.

3. A Suitable Separation : If the one-up doesn't contain a Bleed Processing Step nor a Cutting
Processing Step, ArtPro+ searches for the most suitable stroked outlines in a specific
separation to find the bleed mask. The bleed distance between this outline and the artwork is
calculated outside this outline.

4. A Page Box : If the above three checks fail, ArtPro+ first searches for a well-defined Bleed Box.
The Bleed Box must be equal to or within both the Media Box and Crop Box. If not available, the
Trim Box is used to calculate the bleed distance between Page Box and the artwork outside this
outline.

The bleed differences are highlighted and the Compare side drawer shows a message indicating
which area was used for comparison.

5.2.  Dimensions

The Dimensions tool (shortcut: D, toggling with Densities) can be used to measure dimensions
(distance, angle, area, ...).

1. Select the Dimensions tool
2. Click the first point where you want to start measuring
3. Click the second point, or drag to the second point.
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Note:  You can change the zoom and pan without interrupting your measuring, by using the
modifier keys. See Zoom tool on page 94 and Pan tool on page 94

You will see

• the distance, both vertical, horizontal and in total
• the angle
• the total area of the rectangle. If the area is too small to show the value, you can see it as a

tooltip when hovering over the area icon 

Distances and areas are shown in the units defined in the Preferences (see Preferences on page 49).
However, for distances, you can click in the black circle to toggle between this unit and point (pt). All
distances shown will be adjusted accordingly.

4. You can click and drag one of the points to change its location. Click elsewhere to start a new
measurement, or use the esc key to clear the current measurement.

If the Snap option is enabled, the Dimensions tool is magnetic: it snaps to the nearest point you may
want to measure, both for the start point as for the end point.

It will snap to:

• all visible outlines, when in Outline or Outline with Preview Hint mode
• bounding boxes of all objects, strokes, text, patterns, transparency masks, line work masks and

bounding boxes of images when in Preview mode.

You can enable or disable the magnetism of the Dimensions tool using the Snap checkbox, or by using
the shortcut N while the Dimensions tool is active.

5.3.  Densities

The Densities tool (shortcut: D, toggling with Dimensions) can be used to measure densities at a
specific location.

1. Select the Densities tool
2. Click the point you want to measure
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You will see the Density Wheel around the measure point (indicated by a crosshair):

• The upper half of this wheel will show color bars and values for each printing separation in the
file. Technical inks are ignored. The height of each bar corresponds to the percentage at the
measured point.

• The corresponding values for every separation are also shown in the % column of the
Separations section in the Information Side Panel.

Note:  The values shown are always rounded off to the closest system value (n/255 in %),
and might not be the exact same as in the Fill Inspector or Stroke Inspector.

• The bottom half of the wheel will show the color visualization of measured pixel.

• At the left hand side, the lowest (non-zero) measured value of all printing separations is
shown. If this value is below the Breakout Limit, the value is shown in a circle in the highlight
color, and a colored line at the inner circle of the Densitometer wheel is shown indicating the
separation in which the value was measured. See Breakout on page 104

• At the right hand side, the total ink percentage of all printing separations and all visible layers
at the measured point is shown. If this value is above the Total Area Coverage Limit, the
value is shown in a circle in the highlight color. See Total Area Coverage on page 103

Note:  Invisible layers are not taken into account. Invisible separations are measured.

3. You can click and drag to get a continuous readout of the measured point.

5.4.  The Colors Side Drawer

The Colors Side Drawer lists all flat colors and gradients used in the current page of the active
document.
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1. Every flat color or gradient found in the current page of the document is represented by a color
patch. Dynamic Marks are disregarded.

• Colors are considered the same if all percentage values and overprint settings are the same.
• Gradients using the same color stops are considered the same, even if they are using different

relative positions between the stops, or using a different rotation or positioning.
•

If a color is set to overprinting for one or more separations, the overprint icon  is shown in
the color patch.

•
If a color is a Registration color, the registration icon  is shown in the color patch.

• Colors that are different tints of the same color mix (in the example above the three green
colors) are shown as a cluster. This can be used to convert all these tints into tints of a spot
color. See Convert to Spot Color on page 139

2. In the second column, you get an indication of the number of times the color is used in the current
page of the document.

• If some of the occurrences are selected, this is indicated e.g. by "1 / 4".
• If all occurrences are selected, the complete line in the Colors Side Drawer will be selected.

3. In the third column, a separation color patch is shown for every separation used in a specific color.

• underneath every separation color patch, the percentage for that separation is shown (except
for gradients).

• Hovering over a line in the Colors Side Drawer will show the complete ink names and
percentages.

•
If Registration Color is used, the Registration icon  is used. Registration Colors are always
shown at the bottom of the list.
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• If the color is used in one or more locked or hidden objects, a lock or eye icon is shown on the

right. 
4. The Convert to Spot Color  button can be used to convert a color mix into a spot color. See

Convert to Spot Color on page 139
5.

If the option Exclude Hidden Objects  is enabled, colors that are only used in hidden objects will
not appear in the list.

6. Clicking a Color in the Colors Side Drawer will select all (unlocked) objects in the document. If the

Zoom to Selection  option is enabled, clicking an entry displays the selected object(s) as big as
possible in the active window.

7.
If the option Show Color Inspector  is enabled, the Color Inspector section is shown at the top
of the Color Side Drawer. Using the Color Inspector you can edit flat colors of the selected objects.

• The editing is the same as in the Fill & Stroke Inspector, so you can use the shortcuts such as
x, t, … See Fill Color and Stroke Color Inspector on page 182. If the resulting color matches an
existing one, their lines in the Color Side Drawer will be merged. You can use this to reduce the
number of different color mixes, and hence the number of lines in the Color Side Drawer.

• The first line of the Color Inspector indicates how many times the color is used as fill and/or
stroke color.

• Only flat colors can be edited. If your selection contains flat colors and gradients, the Color
Inspector will show the flat color(s).

5.5.  Ink Coverage

Using Prepress > Ink Coverage you can calculate the surface ink coverage for the active job. The total
surface of the job and the surface covered by each separation is calculated. The results are displayed
in the unit defined in Preferences (see Preferences on page 49), as well as in percent.
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Ink coverage is only calculated inside the border set using the dropdown, so if the border is set for
example to trim box, it does not include any bleed or other elements outside that size.

Note:  Invisible layers are excluded from the calculation. However, invisible Separations or non-
printing layers are included.

Click the Export button to save the Ink Coverage data as an XML file.
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6.  Document Settings

6.1.  Working with multi-page documents

Using File > Pages you can manage pages in a multipage document.

• Use File > Pages > Insert Blank Page... to insert a blank page in your document. In the Insert Blank
Page dialog, you can choose where you want to insert the page.

 

 

The inserted page inherits the Page Box and Crosshair properties from the current page.

• Use File > Pages > Delete Pages... to remove pages from your document. In the Delete Pages
dialog, you can set the page or range of pages you want to delete.

 

 

Note:  You can not delete all pages of your document.

6.1.1.  Navigating a multi-page document

If you open a multi-page document, the first page will be shown. You have different options to navigate
through the different pages.

• You can use the menu options in View > Go To to go to the first, previous, next or last page.
• You can enter a page number in the page navigator in the side panel to go to a specific page, or use

the buttons to go to the first, previous, next or last page.
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• You can use the shortcuts:

• Page Up or Page Down to go to the previous / next page
• Hold Cmd (Mac) or Ctrl (Windows) and press Page Up or Page Down to go to the first / last page

Navigating to a different page does not affect the selection, zoom level, color management, visibility of
page boxes, rotated view, etc.

Undo / Redo will navigate to the page where the action is occurring.

Note:  When working with a PDF+ file, ArtPro+ only checks the linked external files (Images,
Placed Art or Structural Design files) for the current page. This means that navigating to a
different page can result in a warning for a missing link or out-of-date image. See Missing and
out-of-date files on page 62

6.2.  Page Boxes

You can toggle the Page Boxes visibility in different ways:

• By selecting View > Show/Hide Page Boxes

• Using the shortcut Cmd+B (Mac) or Ctrl+B (Windows)

• By clicking the Page Boxes eye in the Document section of the side panel.
 

 

Page Boxes that are defined in the document are shown in different colors, with a label on the top left
corner, indicating the Page Box name and its dimensions. Double-clicking the label will open the Page
Boxes Setup dialog, with the selected Page Box active. See Editing Page Boxes on page 122

When Page Boxes are visible, only a section of the canvas is shown, the rest is grayed out. Objects
outside the Crop Box are shown dimmed.

The visible section is:

• The part of the Crop Box that is inside the Media Box.
• If no Media Box is available, the full Crop Box is shown
• If no Crop Box is available, the Media Box is shown.
• If the Crop Box is completely outside the Media Box, all content will be grayed out.

The Fit in Window function reacts differently if Page Boxes are visible: see Fit in Window on page 93

6.2.1.  Editing Page Boxes

Using the Page Box Setup dialog, you can define or edit Page Boxes.
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You can open the dialog in different ways:

• Choose File > Page Boxes Setup ...
• Use the shortcut Cmd+Alt+P (Mac) or Ctrl+Alt+P (Windows)
• Double-click the label of one of the Page Boxes. The selected Page Box will be active in the Page

Boxes Setup dialog.
• Double-click Page Boxes in the Side Panel.

You can edit any page box by selecting it, and changing its values. The changes will be shown in the
document immediately, but only accepted if you click OK

Note:  Holding the Alt key will change the Cancel button in a Reset button. Clicking it will reset
all page boxes to the previous accepted settings.

Crop Box, Bleed Box, Art Box
Using the checkbox in front of the page box name, you can add or remove the page box.

This is only available for Crop Box, Bleed Box and Art Box: the Trim & Media Box are always defined.

If you add a Page Box (e.g. a Crop Box), the Page Box will use the dimensions of the Media Box.

Dimensions
You can edit the size of any Page Box by entering the dimensions. The Transformation Origin buttons

 allow to set in what direction the Page Box should be modified. If you e.g. select the top left
corner, the top left corner of the Page Box will remain unmodified.

Note:  You can use calculations when entering dimensions, e.g. by entering "300 mm + 2 inch",
the result will be 350,80 mm.

Fit to ...
Using the buttons, you can set the size and position of the page box:

•

 Fit to All: the page box will be modified so it fits the visual boundaries of all objects in the
current document.

•

 Fit to Selection: the page box will be modified so it fits the combined bounding box of all
objects currently selected.

•

 Fit to Trim Box: the page box will match the Trim Box. This is only available for Media Box,
Bleed Box and Art Box.

•

 Fit to Media Box: the page box will match the Trim Box. This is only available for Crop Box,
Bleed Box and Art Box.

•

 Fit to Structural Design: the page box will match the format of the Structural Design file.
When applied on the Media box, it will use the bleed lines when present in the Structural Design file,
otherwise it will use the cut lines. When applied on any other page box, it will use the cut lines of the
Structural Design file.
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Margins on Trim Box
The Media Box and Bleed Box can be defined by entering a margin on the Trim Box. You can enter a

different margin for the top, left, right and bottom, or by enabling the Lock button  you can set
one margin for all 4 sides.

Errors
Any errors, such as a Trim Box not fully covered by the Media Box, are indicated by a blue circle with
a white "i" next to the Page Box name. At the bottom of the dialog, you can find more info on what's
wrong, and a link providing a possible solution (e.g. to fit the Bleed Box to the Media Box).

Note:  When working on a Normalized PDF, you will not be able to save the page boxes setup as
long as the errors have not been resolved.

Multi-page Normalized PDF
Dimensions and position for each page box need to be the same for all pages of a Normalized PDF. If
e.g. a trim box is changed on page 1, it is automatically changed on all other pages; if a bleed box is
added to page 2, it is automatically added on all other pages.

6.3.  Layers

The Layers section has two view modes: the default "Layer Overview" mode explained below, and the
"Processing Step Layers Overview" mode described in Processing Step Layers Overview mode on page

129. You can switch between modes using the buttons  and .

Note:  For Normalized PDF files only the regular "Layers Overview" mode is available, so the
buttons will be hidden.

The Layers section in Layers Overview mode lists all of the layers that are present in the current
document. Groups and individual elements are not listed.

Note:  Sublayers are only shown if these sublayers are saved in the PDF file correctly, e.g.
sublayers in Adobe Illustrator are not saved in the PDF file.

• Double-click the layer name to change its name.

Note:  You can also rename layers from the breadcrumbs or the object browser. See
Renaming objects, groups and layers on page 155

• In the Visibility and Print column, you can change the visibility and printing state of all layers. See
Visibility, Locking and Printing state on page 125

•
The Selection column will show an icon  if some objects in that layer are selected. If all objects

in the layer are selected, the icon changes to this: . You can also click the icon in the Selection
column to select all objects in that layer.
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•
By clicking the Move selection to active layer button  you can move the selected objects to the
active layer

• Click the + button to add a new layer. Click the - button to remove the selected layer(s) and their
content.

• Select Delete All Empty Layers from the fly-out menu to delete any layers that do not contain any
objects.

• To reorder layers, click and drag a layer to its new position.
• In case the document you opened contains art that is not in any layer, the Layers list will show

"Unlayered Art". You can't select or change this. You can however select from the fly-out menu to
put the unlayered art in a Layer. If the document you opened contains both unlayered art and at
least 1 layer, you will get a warning recommending to use the Create Layer from Unlayered Art
option.

Selected layer(s) and Active layer
Some actions, such as deleting or moving, apply on all selected layers. For other actions, such as Move
selection to active layer and actions from an Action List, the active layer is used.

Selected layers are indicated by a blue background and white text. You can have none, one or multiple
layers selected.

• By default no layer is selected.
• You can select a layer by clicking the layer name.
• You can command-click (Mac) or control-click (Windows) to add a layer to the selection or remove a

layer from the selection.
• You can use shift-click to select a range.

There is always exactly one active layer, indicated by a layer name in bold.

• Selecting a layer makes it the active layer.
• If multiple layers are selected, the topmost selected layer will be the active layer.
• If no layer is selected, the topmost layer is the active layer.
• If you apply a regular Paste, the pasted objects will be in the active layer. Other Paste methods are

also available. See Cut, Copy and Paste on page 153

6.3.1.  Visibility, Locking and Printing state

When opening a file, ArtPro+ will show the visibility and printing states of the layers as they were saved
in the file. Non-printing layers will be hidden by default. Locking is never saved in a file, so all layers will
be unlocked by default.

Note:  When opening PDF 1.5 compliant files (e.g. ArtPro files and Normalized PDF files),
invisible layers will always open as invisible and non-printing, regardless of their printing state
in the original application.

Automatic Sync
If you change the printing state of a layer, the visibility will be synced to the printing state: printing
layers will be visible, non-printing layers will be invisible.

Changing the visibility state will not affect the printing state in any way.
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Column icon
You can use the top icons to change all layers at once

Action Result

Click the eye icon Change all layers to "Visible". If this is already the
case, this will change all layers to hidden.

Click the lock icon Change all layers to Locked. If this is already the
case, this will change all layers to unlocked.

Click the Printing icon Change all layers to Printing and Visible. If this
is already the case, this will change all layers to
hidden and non-printing.

Alt-click the eye icon Toggle between all layers visible, and the previous
state

Alt-click the lock icon Toggle between all layers locked, and the previous
state

Alt-click the Printing icon Sync visibility to the printing state: printing layers
become visible, non-printing layers become
invisible.

Layer icons
The eye icons show if a layer is visible or not, the locked icon shows if a layer is locked, and the printing
icon shows if a layer is printing or not.

You can change the state of layers in different ways:

Action Result

Click an icon Toggle Visibility / Locking / Printing State on or
off

Click and drag over multiple icons Toggle the visibility, locking or printing state for
the first layer you clicked, and apply the same
state to all layers you drag.

If e.g. you click and drag starting on the eye icon
of a visible layer, this layer and all others you drag
will become hidden.

Alt-click an icon The selected layer becomes visible / locked /
printing, while all other layers become hidden /
unlocked / non printing

Alt-clicking again will change all layers back to the
previous state

Note:  Making a layer invisible, will deselect all objects in that layer.

126



6ArtPro+

Note:  If you do an action on the active layer (e.g. creating an object) while the active layer is
locked, you will be asked if you want to unlock the layer.

6.3.2.  Processing Step Layers

Ever since PDF became the preferred file format in the graphic industry, PDF files were used not only
to store the artwork to be printed, but also as a container for information related to the production
process: cutting lines, dimensions, etc.

How the information was stored in the PDF file, depends on the application that was used to generate
the PDF, and the preferences of the user. For example the die cut lines can be in a separation called
"Die", or in a layer named "Cut". Obviously, this leads to a multiple of ad hoc methods, which leads to
interoperability problems, and a complex and error-prone situation.

ISO 19593 defines a new mechanism to store objects and metadata corresponding to such processing
steps in a PDF file in a standardized way.

Based on this ISO norm, the use of Processing Steps was introduced in ArtPro+ as Processing Step
Layers.

Keep in mind however that these Processing Step Layers are only available when working with PDF+
files. Normalized PDF files use Technical Inks instead. See PDF, PDF+ and Normalized PDF on page 57

Objects in Processing Step Layers
Processing Step Layers contain objects in your PDF file (a path, a text object, ...) that are associated
with a specific Processing Step.

The type of Processing Step Layer can influence the properties of the PDF objects. For example, a PDF
object in a Structural Processing Step Layer has to be colored in a spot color (to visualize in viewing
and proofing applications). Because the objects in these Processing Step Layers should not have any
influence on the final printed version (and on the plate making), this spot color should not be used for
"normal" PDF objects, nor should the objects knock out other objects, or participate in transparency
blending with other "normal" artwork objects.

Processing Step Layer Types
• Structural is a group of Processing Step Types, used for a collection of contours that describe

how the printed product will be finished to produce a 3D end product from a flat substrate, such as
cutting lines, crease lines, etc.

• Braille: braille characters that are applied after printing, e.g. by a die cutter or inkjet device.

• Legend: Processing step objects on a ‘Legend’ type layer are mainly to represent product related
administrative and technical information outside the boundaries of the actual printed products (cfr.
marks) and have no restriction on coloring (amount of colorants used), overprint or transparency
blending.

• Dimensions: indications of the physical sizes

• Positions is a group of Processing Step Types, used for objects that indicate intended, allowed or
forbidden positions for certain types of elements, e.g. allowed positions for content on a flap of a
carton.

• White: white ink to be printed on a transparent or metallic substrate.
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• Varnish: indicating the application of varnish after printing.

Note:  Next to those types, there are also Custom Processing Step Types, but those can't be
applied manually. Two examples of those that can be automatically applied in ArtPro+ are
"Esko_PlateCutting", used when generating Plate Cutting Paths, and "Esko_PlateID", used when
creating Plate ID objects.

Processing Step Restrictions
Every Processing Step Layer needs to follow some requirements:

• The Processing Step objects need to be in a separate layer

• The layer needs to have a Processing Step Definition

• All objects in the Processing Step need to be overprinting

• The Processing Step needs to be on top of the artwork layers.

Based on the specific Processing Step, additional requirements need to be followed, about what
objects and object characteristics are allowed and how a processor (e.g. a finishing device) has to
evaluate them:

1. Processing Steps describing paths can only contain stroked paths. For example: Cutting or
Folding.

2. Processing Steps describing surfaces can only contain PDF path and text objects, no images
etc .... A processor takes the objects as defining a surface (so any halftoning is ignored). For
example: Embossing and Foil Stamping.

3. Other Processing Steps: All objects are allowed, a processor needs to take the rendered result. For
example: White and Varnish

4. Legend is a special Processing Step and has no restrictions on content

If one of the restrictions is not met, a warning is shown in the Messages Side Drawer. You can hover
over the warning symbol to get an indication on what is wrong.

Processing Step Layers in the Layers list
Processing Step Layers appear in the Layers list, grouped per type, and the actual Type is shown in the
Type column.

You can change any layer into a Processing Step Layer, or change the type of a Processing Step Layer
by clicking the triangle in the Type column, and selecting a Processing Step type from the dropdown.

You can change a Processing Step Layer into a normal layer by clicking the triangle in the Type column
and selecting None.

You can prevent a number of these issues by using the Move Objects To function to create Processing
Step Layers. See Move objects to ... on page 129
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Processing Step Separations
Separations that are only used in Processing Step Layers are considered "Processing Step
Separations": they can be used to color objects in the Processing Step Layers, but are not considered
printing inks, as they should not appear on plates or on the final printed result.

Processing Step Separations are represented in the Separations list using a round color patch.

Note:  If an ink is used in at least one "normal" artwork object in an artwork layer, the separation
is shown as a normal printing separation, with a square color patch. Since the use of a
separation both as ink and for objects in Processing Steps usually presents a conflict, it is very
likely that a message will appear in the Messages Side Drawer for any Processing Step Layer
using such a separation.

Move objects to ...
Using the Move Objects to function, you can move the objects using a specific separation into a
Processing Step Layer.

1. Select a spot color separation in the separations list.
2. Select Move objects to from the fly-out menu underneath the separations list.
3. Select the Processing Step Layer you want to use.
4. ArtPro+ will try to move all objects using the selected separation to the selected Processing Step

Layer.

• Objects in a flat color, only using the selected separation, will be placed in a Processing Step
Layer, with the same name as the original artwork layer they were in (when available). These
objects will also be put in overprint (all other separations transparent).

• Other objects (e.g. objects in a mixed color, images, ...) will not be moved nor changed.
• If the separation is only used in the Processing Step Layers, it will become a Colorant. See

Processing Step Separations on page 129

6.3.3.  Processing Step Layers Overview mode

You can click the button  to switch the Layers section to Processing Step Layers Overview mode.

This view mode will collect and show layers based on the type: it will show a line for every type of
Processing Step Layer defined in the document, or within a Placed Art, Step&Repeat Grid, .... For each
type, you will only see one entry, even if multiple layers of that type are defined.

The Processing Step Layers Overview allows to view and change the printing state of all layers of the
same type. Changing the printing state will change the visibility accordingly.

In case different layers of the same type have different printing states, this will be indicated by an
unequal sign ≠.

Note:  As Processing Step Layers are not supported in Normalized PDF, this functionality is not
available for Normalized PDF files.
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For Placed PDF and Structural Design files, you can use the Layer Types Inspector for the same
purpose as the Processing Step Layers Overview mode: an overview of all types of layers defined in the
document. See Placed Art Layer Types Inspector on page 224

6.4.  Object Browser

By clicking the Object Browser button  you can open the Object Browser.

Layers and objects in the Browser can have one or more icons on the right hand side:

•
 an Artwork Layer. See Layers on page 124

•
 a Processing Step Layer. See Processing Step Layers on page 127

•
 a hidden object, group or layer. See Hiding objects on page 97

•
 a locked object, group or layer. See Locking objects on page 155

•
 a Transparency group. See Opacity Masks on page 168

•
 a Clip group. See Clipping Mask on page 167

•
 an object with a Trap Tag. See Working with Trap Tags on page 332

•
 an object with a Plate Cutting Tag. See Working with Plate Cutting Tags on page 374

•
 an object in a color space susceptible to color conversion. See Objects, groups or pages

susceptible to color conversion on page 98
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1.
Click the Object Browser button , the Named Object Browser button , the Trap Tagged Object

Browser button , the Plate Cutting Tagged Object Browser button  or the Color Swatch Fan

button  to switch between the different modes.

•
the normal Object Browser , that lists all layers, groups and objects in the document, each
with their thumbnail, ordered as the objects are ordered in the file (from top to bottom).

•
the Named Object Browser , that shows all named objects and gropus in the document in
alphabetical order.

•
The Trap Tagged Object Browser , that shows all objects and groups with a defined Trap Tag,
ordered as the objects are ordered in the file (from top to bottom). See Working with Trap Tags
on page 332
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•
The Plate Cutting Tagged Object Browser , that shows all objects and groups with a defined
Plate Cutting Tag, ordered as the objects are ordered in the file (from top to bottom). See
Working with Plate Cutting Tags on page 374

•
The Overview of Objects with Color Spaces Susceptible to Color Conversion  shows all objects
or groups in color spaces susceptible to color conversion, such as objects tagged with a color
profile or RGB objects. See also Objects, groups or pages susceptible to color conversion on page
98

Note:  Since Trap Tags and Plate Cutting Tags are not available in Normalized PDF, these
modes will not be available when working on a Normalized PDF.

2. Click the triangle in front of a layer or group to expand / collapse it.
3. Click Layers, groups or objects to select them.

a) You can select multiple objects by dragging on the items in the browser
b) You can add to or remove from the selection by using the Shift or Cmd/ctrl key.
c) By clicking and dragging, you can change the position of an object, group or layer. Doing so, you

can change the order, take objects in or out of a group or layer, etc. This is only possible in the
normal Object Browser.

4. Enable the Keep Expanded button to keep all layers and groups expanded. When disabled, groups
and layers in the object browser automatically expand/collapse to ensure that only the selected
objects are selected in the object browser. This is only possible in the normal Object Browser.

5. Enable Zoom to Selection to automatically zoom in on the object(s) you select in the object browser
6. Double-click an entry to change the name of the object, group or layer. See Renaming objects,

groups and layers on page 155.
7. Control-click an entry and choose Show or Hide to change its visibility. You can also change the

visibility of Layers in the Layers list (see Visibility, Locking and Printing state on page 125), and
change the visibility of objects and groups using Show abd Hide (see Hiding objects on page 97)

6.5.  Separations

The Separations section lists all of the separations that are used in the current document.
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1. The Document Profile. See Color Management on page 98. When you are using a GMG OpenColor
server, see GMG OpenColor on page 99

Note:  If the current page is in a color space susceptible to color conversion, the Color
Space will be shown here. You can click the x to remove the page color space. See also
Objects, groups or pages susceptible to color conversion on page 98

2. The top icon shows an eye if all Separations are visible, and a "-" if at least one separation is
invisible. You can click the icon to make all separations visible, or (in case all separations are already
visible) to hide all separations. You can also Alt-click the header eye icon to toggle between all
Separations visible, and the previous state.

3. You can change the visibility of the individual separations using the eye icons

• You can click an eye icon to toggle visibility on or off.
• You can click and drag over multiple icons to change the visibility of all those separations at

once: they all get the same state as the first separation you clicked. For example, if you start
clicking and dragging on a visible separation, you make this separation (and all other separations
you drag) invisible

• You can Alt-click a separation icon to make that separation visible, and all others invisible. Alt-
click and drag makes all of the involved separations visible, and all others invisible. Alt-clicking
again changes the visibility of all separations back to the previous situation.

4. The # column shows the index number of the separation in the separations order.
5. The Type column indicates the type of the separations. Clicking Setup or any of the Ink Type

indicators will open the Separations Setup dialog. See Separations Setup on page 136
6. The Color patch shows the color of the separation. It can be a square (Process inks and inks from an

Ink Book), square with a white triangle (Custom Ink, see Separations Setup on page 136) or round
(Processing Step Separation, see Processing Step Separations on page 129

7. The buttons:

•
Use the Convert to CMYK button  to convert the selected separation to CMYK. See Convert
to CMYK on page 138

• Use the - button to remove the selected separation(s). If one of the separation you try to remove
is in use, a message will be shown.
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Note:  If your document contains non-white preserving blend modes (Difference,
Exclusion, Hue, Saturation, Color or Luminosity) you will not be able to remove the
process inks.

• Use the + button to add a new printing separation. See Adding or changing a separation on page
135.

8. The fly-out menu, also accessible by right-clicking a separation

• You can select Move Objects to to move all objects using the selected separation into a
Processing Step Layer. See Processing Step Layers on page 127 and Move objects to ... on page
129

• You can select Convert to CMYK to convert the selected separation to CMYK. See Convert to
CMYK on page 138.

• You can select Replace Separation by to merge the selected separation with another separation
in the list. The selected separation will be removed, and merged with the target separation,
which keeps its properties. You can also merge a separation by dragging and dropping it on the
target separation while holding the Shift key. To see what happens to the screening sets when
merging separations, see Screening when merging separations on page 319

• You can Remove Unused Separations.

• You can Synchronize with GMG Project. See GMG OpenColor on page 99

• You can Add to Ink book or Remove from Ink Book. See Add to Ink Book / Remove from Ink Book
on page 141

• You can Assign Default Printing Units, Assign Default Reverse Printing Units and Remove
Printing Units. See Working with Printing Units on page 141

• You can open the Separations setup. See Separations Setup on page 136
9. Using the Automatic Locking, you can automatically lock all objects that do not use any of the

visible separations. Since locked objects are shown in gray in outline mode, this function can be
useful to distinguish between the outlines of objects that are using the separations that you are
viewing, and objects that aren't using any of the separations. If the option is enabled, the visibility
icon for every separation will switch between visible and locked (instead of invisible). See Automatic
Locking based on the visible separations on page 140

Note:  Removing, Renaming or Replacing a separation will affect the channel mapping of
Linked Placed Art that uses the separation. See Channel Mapping for Linked Placed Art on page
226

Numeric control
You can press the numbers 1 to 9 on your keyboard, to make the corresponding separation visible, and
hide all others. Pressing the same number again will reset all separations to the state they were in
before using the numeric keys.

You can press 0 to make all separations visible, and press 0 again to return to the previous state.
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Single separation preview
When only one separation is visible, 3 extra icons show up, allowing to inspect a single separation in
different modes:

1. Color: the single separation is shown in its own color
2. Positive film: the single separation is shown in black
3. Negative film: the single separation is shown in black, but negative.

Separation order
You can change the separation order by simply dragging and dropping one or more separations onto
their new location.

Unused Separations
Separations that are not used in any objects or images are shown as a grayed out separation name in
the Separations list, but also in the Screening, Ink Coverage, Fill / Gradient / Stroke Inspector, etc.

When the document is reopened, unused separations are not listed anymore.

Ink operations on a selection
If you remove separations, replace separations or convert separations to CMYK in the Separations
section, the complete document is affected. If you want to remove separations, replace separations
or convert separations to CMYK only for the selected objects, you can use the Recolor function. See
Recolor on page 190

6.5.1.  Adding or changing a separation

1. Click the + button to add a new separation, or double-click an existing separation to change it.
2. You can use the input field as a filter to search and select an ink from the available ink books, in the

order defined in the Preferences. See Preferences on page 49.
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• You can click an ink in the search results to fill in the full name of the ink.
• Entering the short version of an ink will find the corresponding ink in the available ink books, so

it can easily be selected from the list, e.g. "Warm Red" will find the ink "PANTONE Warm Red C"
and "reb" will find "PANTONE Reflex Blue C".

• The search is case insensitive. If you type "green", the list will show both inks containing "green"
and "Green" as search result.

3. You can press Tab to create the ink and immediately start creating another separation. You can
press Enter or Return or click outside the edit field to create the separation and stop adding
separations. Use the Esc key to cancel.

• If the ink name doesn't exactly match any ink, hitting Enter will create a custom ink, indicated by
a white triangle in the bottom right corner of the color patch.

• If the ink name exactly matches an ink from the ink book, (e.g. after you clicked an ink in the list),
that ink will be used.

• "c", "m", "y" and "k" are automatically replaced by Cyan, Magenta, Yellow and Black.

Note:  Unlike the search (see above), separation names in ArtPro+ are case sensitive, so you
can e.g. have both a separation "Green" and "green".

4. When creating a new custom ink, the Colors dialog allows to select the preview color for the
separation. You can set the color definition in RGB, CMYK or LAB. Changing an existing separation
to a (new) custom ink will maintain its color.  You can double-click the color patch to change the
color for any custom ink.

6.5.2.  Separations Setup

Clicking Setup or any of the Ink Type indicators in the Separations section will open the Separations
Setup dialog
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The Separations Setup shows all separations in the document.

Column

1 The index of the separations (#)

2 The color patch for the ink. It can be a square (Process inks and inks from an Ink
Book), square with a white triangle (Custom Ink, see below) or round (Processing
Step Separation, see Processing Step Separations on page 129

3 the ink name

4 the ink book

5 the Separation Type. See below

6 The Printing Method. You can select one of the defined Printing Methods by
selecting it in the dropdown, or select Manage Printing Methods to open the
Printing Methods preferences. See Preferences on page 49. Select a Printing
Method in the topmost dropdown to set the Printing Method for all separations at
once.

7 The PDF Correction Curves. See below

Separation Types
Normal

By default, process separations are always "Normal".

Opaque inks

Inks that are defined as "Opaque" in the ink book can't be changed to another ink type.

Making an ink opaque will change the rendering of the file. Keep in mind that when using opaque inks,
the printing order is very important for a correct preview.

Technical & Varnish inks

Technical and Varnish inks can only be used in Normalized PDF.

Technical inks will be treated as opaque printing separations, and will be saved as such. This means
that when sent to a RIP, these separations will appear on the output.

When opening a regular PDF (so not a Normalized PDF) containing Technical inks, a message will be
shown warning you about this behavior.

Note:  In ArtPro and PackEdge, it is possible to change an opaque ink into a Varnish, which is
not allowed in ArtPro+. When opening a file containing such inks, a warning will be shown.
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In a PDF+ file, you can not use Varnish or Technical inks. To achieve a Varnish or the equivalent of a
Technical ink, you can use Processing Step Layers. See Processing Step Layers on page 127.

PDF Correction Curves
PDF Correction Curves are only available when working on a PDF+ document. See PDF, PDF+ and
Normalized PDF on page 57

You can set a color correction curve for any separation to increase or decrease the highlights,
midtones or shadows by 2 or 4%.

These color correction curves can be picked up by Imaging Engine version 20 or higher. In the "Image
to Screened/Unscreened Separations" task, make sure you enable the Use PDF transfer curves option
in the PDF Objects tab.

Correction curves are not applied on the Placed Art in the document (linked or embedded). If curves
should be applied to the placed art, they have to be set in the one-up itself. If you select the Placed Art,
the Placed Art Separations inspector shows if any curves are applied to any separations in the Placed
Art.

6.5.3.  Convert to CMYK

You can convert the selected separation to CMYK. This is not possible for Technical separations in a
Normalized PDF.

1. Select the separation you want to convert to CMYK
2.

Click the Convert to CMYK button  or select Convert to CMYK from the fly-out menu.
 

 
3. Select the CMYK values you want to use:

• the CMYK values that are saved in the PDF file
• the CMYK values using the Esko Color Management (not available for custom inks)
• Custom values you can enter yourself.

4. Click Convert

138



6ArtPro+

Note:  Linked Placed Art will not be affected by this. If your document contains linked placed
art using the separation you are converting to CMYK, the separation will remain in your
separation list.

6.5.4.  Convert to Spot Color

Using the Convert to Spot Color function in the Colors Side Drawer, you can convert a CMYK color mix
into a spot color.

Colors that are different tints of the same color mix are shown as a cluster, and can be converted to
different tints of a single spot color.

1. Open the Colors Side Drawer. See also The Colors Side Drawer on page 117
2. Select the color mix you want to convert into a spot color.
3. Click the Convert to Spot Color button  at the bottom of the Colors Side Drawer, or right-click

the color patch and select Convert to Spot Color for a single color, or Convert all Tints to Spot
Color when working on a tint in a cluster.
 

 
4. In the Convert to Spot Color dialog, you can select the target spot color:

• Name: Select the target spot color by entering the name or a part of the name. This works the
same as adding a new separation. See Adding or changing a separation on page 135

• Best Match: Select the Ink book you want to use, and underneath the best matching spot colors
from that Ink Book is shown. From left to right, you can see a color patch of the original color
mix, a color patch of the spot color, and its name.
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Note:  The ink books in the dropdown are shown in the Preferred Ink Book Order as set in
the Preferences. See Preferences on page 49

5. Click Convert

All objects that use the selected color mix will be converted. All converted objects will be selected after
conversion. Also hidden or locked objects using the color mix will become visible and unlocked, and will
be selected after the color conversion.

If you converted all tints of a color mix, all colors of the cluster are converted to a tint of the same spot
color. In the example underneath you see

1. Before conversion: a cluster of 3 colors, i.e. 3 tints of the same color mix.
2. After conversion: 3 tints of the same spot color.

 

 

Note:

• Only flat colors can be converted.
• The Overprinting State is not kept after conversion.
• You can only convert all tints in a cluster.

6.5.5.  Automatic Locking based on the visible separations

By enabling the Automatic Locking option at the bottom of the Separations, you can automatically
lock all objects that do not use any of the visible separations.

Since locked objects are shown in gray in outline mode, this function can be useful to distinguish
between the outlines of objects that are using the separations that you are viewing, and objects that
aren't using any of the separations.

• Enabling the option will first reset all locking (i.e. unlock any locked objects), and then lock all
objects that do not use any of the visible separations.

• If the option is enabled, the visibility icon for the separations will switch between visible and locked.
When the option is disabled, the visibility icon switches between visible and invisible (-), even
though objects always stay visible in Outline mode, regardless of the separations they use.

• When the option is enabled, changing the visibility of a separation will reset the locking to match
the visible separations, regardless of any manual locking you did in between.

• Editing the document (other than changing the visibility of a separation) will cause the locking to
be out of sync. The Automatic Locking will show an open padlock icon. Changing the visibility of a
separation, or re-enabling the option will resynchronise all locking.
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• If you use the Unlock All function (see Locking objects on page 155), all locked objects become
unlocked, and the Automatic Locking option is disabled.

Locking objects has the same result as manually locking objects: you can not select locked objects,
the Object Browser shows a lock icon, and the outline of the objects are shown in gray in outline mode.

6.5.6.  Add to Ink Book / Remove from Ink Book

From the fly-out menu of the Separations section you can use Add to Ink Book to add the selected
separation to an ink book, or use Remove from Ink Book to remove the selected separation from the
current ink book.

• Adding or Removing is only possible if you are connected to an Automation Engine. When you
are connected to an Automation Engine SaaS server, you also need sucient permissions. See
Automation Engine connection on page 72

• Adding or removing is not possible if Color Engine Data is set to "Use Standard Color Engine Data".
See Color Management Preferences on page 53

• You can only add separations to or remove them from a non-protected ink book. You can e.g. not
change the Pantone Ink books.

• When choosing Add to Ink Book, only the non-protected ink books are shown in the list.

• You can only select Remove from Ink Book if the selected ink is present in the currently used
non-protected ink book.

Note:  The Add to Ink Book function takes two steps: the ink gets added to the ink book, and
the location for the selected ink is changed to the chosen ink book. Using Undo will only undo
the changing of the ink book for the current ink, it will not remove the ink from the ink book.
Use Remove from Ink Book for this.

Note:  The sync to the Color Pilot is not immediate, you might need to restart Color Pilot to see
the changes.

Note:  Cloud-centric ink books are not supported in ArtPro+, so you can't add separations to
cloud-centric ink books, even if this option is enabled in your Automation Engine SaaS server
configuration.

6.5.7.  Working with Printing Units

Using Printing Units you can define a Printing Order without changing the viewing order in ArtPro+. For
more information on Printing Order vs Viewing Order, see Viewing Order vs Printing Order on page 143

Note:  Printing Units are only available in PDF+. See PDF, PDF+ and Normalized PDF on page 57

By default, ArtPro+ is showing the index numbers of the separations, starting at "1" for the first
separation and sequentially going up.

You can switch to using Printing Units by choosing Assign Default Printing Units or Assign Default
Reverse Printing Units from the fly-out menu of the Separations section
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•
The Printing Units icon  or  is replacing the # symbol, and the arrow indicates the printing
direction.

• When choosing Assign Default Printing Units Printing Units will be assigned to all separations
except for Processing Step Separations in ascending order.

• When choosing Assign Default Reverse Printing Units Printing Units will be assigned to all
separations except for Processing Step Separations in descending order.

After assigning the Printing Units, you can edit them by clicking the Printing Unit number's location.
You can use this e.g. to assign a Printing Station to your Opaque White Processing Step Separation, or
to leave an empty station.

Note:  When possible, ArtPro+ will try to adjust the other Printing Units when changing one.
E.g. when in a sequential order you change "4" to "5", the next Printing Units will be increased as
well (5 becomes 6, 6 becomes 7 etc).

• When the Printing Units are no longer strictly ascending or descending after manually modifying the
Printing Units or changing the separation order, an error is shown in the Message Center, and the

icon in the Separations section turns red. 
•

You can correct this by manually modify the Printing Units, or you can click the button  to re-
assign the default Printing Units (see above).

When the Printing Units are in ascending order you can click the icon  to Assign Default Reverse
Printing Units. See above.

When the Printing Units are in ascending order you can click the icon  to Assign Default Printing
Units. See above.

If you want to remove Printing Units, you can choose Remove Printing Units from the fly-out menu of
the Separations section

Note:  Printing Units are only assigned for the current page of a multipage PDF.

Placing a PDF
When placing a PDF+ with defined Printing Units into another PDF+ file (with or without Printing Units),
the separations defined in the 'receiving' document will not change.

All separations used in the placed art but not yet in your document will be added in the separations list,
and those separations will keep their defined Printing Unit.

Dynamic Marks
When Printing Units are defined, you can set Dynamic Marks to use the Printing Units order instead of
the Separation order. See Colors and Separations in a Mark on page 410

The Printing Unit is also available as Smart Text variable. See Using Smart Text on page 385

Export to Gravure TIFF
When Printing Units are defined, only the separations with a Printing Unit defined can be enabled or
disabled in the Export to Gravure TIFF window.
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For HELL Compatible TIFF or TIFF for HELL Job Ticket, the sux used in the file name of the exported
TIFF will be based on the printing unit of the separation.

Viewing Order vs Printing Order
By default, the order of the separations in ArtPro+ defines both the viewing order and the printing
order (what ink is printed first). In the example underneath, you see an example of a clear substrate,
with an opaque white printed first, and CMYK on top.

However, in some cases, you would want to change the printing order, without changing the viewing
order in ArtPro+. If you for example want to print on the inside of a clear substrate (so that the printed
graphics are protected by the substrate), the opaque white ink would be the last ink you print (and end
up on top of the others). You do not want to change the separation order in ArtPro+ to represent that,
as the opaque white ink would block out all graphics underneath.

To avoid this, you can use Printing Units to reverse the printing order without changing the separation
viewing order.

Underneath an example of a label printed on the back side of the clear substrate:
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7.  Selecting
Objects in the document can be selected by using one of the Select tools:

•
The Group Select Tool  to select the highest level groups or objects. See Group Select on page
146

•
The Object Select Tool  to select lowest level objects and compounds, even inside groups. See
Object Select on page 146

•
The Path Select Tool  to select paths within a compound. See Path Select on page 147

•

The Lasso Select Tool  to select all objects that lie within the drawn area. See Lasso Select on
page 148

Note:  You can also select using the Transform tool, by clicking anywhere, or dragging outside
of the bounding box of the selection. See Transforming manually on page 158

The selected objects are shown in the selection color. See Display Color for Selections in Preferences
on page 49

Modifier Key
You can use the Cmd (Mac) or Ctrl (Windows) Modifier Key

• to temporarily switch to the last used Select Tool if another tool is selected.
• to temporarily switch from Group Select to Object Select tool or vice versa.

Select / Deselect All, Inverse
You can also use one of the special Select functions:

• Use Select > Select All or its shortcut Cmd+A (Mac) or Ctrl+A (Windows) to select all visible and
unlocked objects.

• Use Select > Deselect All or its shortcut Cmd+Shift+A (Mac) or Ctrl+Shift+A (Windows) to deselect
everything.

• Use Select > Select Inverse or its shortcut Cmd+Alt+A (Mac) or Ctrl+Alt+A (Windows) to invert the
selection: selected items become deselected, unselected objects become selected.

Note:  While editing an object using the Create & Edit Path tool, Select All, Deselect All and
Select Inverse will work on the anchor points of the object. See Create & Edit Path on page
170

Note:  Making a layer invisible, will deselect all objects in that layer.
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7.1.  Group Select

Group Select  is the default selection tool. You can select it from the Tool Selector, or by its shortcut
V, toggling with Object Select, Path Select and Lasso Select.

• Click in an object or on its path (see Selecting in Preview or in Outline Mode on page 148) to select
the highest group the object belongs to. If the object doesn't belong to a group, this will select the
entire object, compound path or image plus clipmask.

• Drag a selection rectangle to select everything entirely within the selection rectangle. Objects
inside a group will only be selected if all objects in the group are completely in the selection
rectangle.

Note:

If the Crosshair is rotated, the selection rectangle you drag will be rotated the same way.
See Move or rotate the Crosshair on page 95

 

 

• Click on an empty space in the document to deselect all objects
• Using the Shift key while selecting inverts the selection of the objects. A deselected group or object

is selected and vice versa. You can use this to add objects to the selection, or remove them from
the selection.

7.2.  Object Select

You can select the Object Select tool  from the Tool Selector, or by its shortcut A or the shortcut V,
toggling with Group Select, Path Select and Lasso Select.

Note:

You can use the Cmd (Mac) or Ctrl (Windows) Modifier Key

• to temporarily switch to the Object Select Tool if another tool is selected, and if the Object
Select tool was the last used select tool.

• to temporarily switch to Object Select if the Group Select tool is selected.
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• Click in an object or on its path (see Selecting in Preview or in Outline Mode on page 148) to select
the smallest path you click on, i.e. an object inside a group, the clip path of an image or the image in
a clipped image group.

• If a selected object or group is part of a group or clipped image group, the Object Select cursor will

have a plus sign when hovering over it.  Clicking again while in this Plus mode will select the
next level group of the clicked group, without changing other selections. You can do this repeatedly
to climb higher in the group structure.

• Drag a selection rectangle to select every object entirely within the selection rectangle.

Note:  If the Crosshair is rotated, the selection rectangle you drag will be rotated the same
way. See Move or rotate the Crosshair on page 95.

• Click on an empty space in the document to deselect all objects.
• Using the Shift key while selecting inverts the selection of the objects. A deselected group or object

is selected and vice versa. You can use this to add objects to the selection, or remove them from
the selection.

Note:  Live text, compound paths and other Protected objects (such as SmartMarks, see
Protected objects on page 178) are considered as 1 single object, even though they may seem
to consist of multiple elements. Outlined text can be selected path by path.

7.3.  Path Select

You can select the Path Select tool  from the Tool Selector, or by its shortcut A or the shortcut V,
toggling with Group Select, Object Select and Lasso Select. Using this tool, you can select a path that
is part of a compound, while the Object Select tool selects the complete compound.

Note:  You can use the Cmd (Mac) or Ctrl (Windows) Modifier Key to temporarily switch to the
Path Select Tool if another tool is selected, and if the Path Select tool was the last used select
tool.

• In Outline mode, click on a path (e.g. a compound path) to select the smallest path in there, e.g.
one of the paths that are part of the compound. If you click a path in Preview mode, the complete
compound the path belongs to will be selected.

• In Outline or Preview mode, drag a selection rectangle to select every path entirely within the
selection rectangle.

Note:  If the Crosshair is rotated, the selection rectangle you drag will be rotated the same
way. See Move or rotate the Crosshair on page 95.

• If a selected path is part of a compound, group or clipped image group, the Path Select cursor will

have a plus sign when hovering over it.  Clicking again while in this Plus mode will select the
next level up, e.g. the complete compound or group, without changing other selections. You can do
this repeatedly to climb higher in the structure.

• Click on an empty space in the document to deselect all objects.
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• Using the Shift key while selecting inverts the selection of the objects. A deselected path or object
is selected and vice versa. You can use this to add objects to the selection, or remove them from
the selection.

You can delete a path inside a compound, cut / copy it or transform it (move, scale, rotate). All other
actions will affect the complete compound. If you paste a path copied this way, it will be part of a new
compound.

Note:  Live text and other Protected objects (such as SmartMarks, see Protected objects on
page 178) are considered as 1 single object, even though they may seem to consist of multiple
elements. Outlined text can be selected path by path.

7.4.  Lasso Select

You can select the Lasso Select tool  from the Tool Selector, or by its shortcut L or the shortcut
V, toggling with Group Select, Path Select and Object Select.

Note:

You can use the Cmd (Mac) or Ctrl (Windows) Modifier Key to temporarily switch to the Lasso
Select Tool if another tool is selected, and if the Lasso Select tool was the last used select tool.

• Click and drag an area to select all paths completely within the drawn area. This can be regular
paths, but also objects inside a group, the clip path of an image or the image in a clipped image
group.
While dragging, a lightly colored area will indicate what area will be selected.

• Click on an empty space in the document to deselect all objects.
• Using the Shift key while selecting inverts the selection of the objects. A deselected group or object

is selected and vice versa. You can use this to add objects to the selection, or remove them from
the selection.

Note:  Live text, compound paths and other Protected objects (such as SmartMarks, see
Protected objects on page 178) are considered as 1 single object, even though they may seem
to consist of multiple elements. Outlined text can be selected path by path.

7.5.  Selecting in Preview or in Outline Mode

Selecting can work differently in Preview Mode or in Outline Mode.

Group Select and Object Select
In Preview mode, you can click anywhere in an object to select it (or the group it belongs to). This will
select the topmost object. You can use Select Next / Previous: see Select Next Object / Select Previous
Object on page 152

In Outline mode, if Select > Select by Paths (Outline mode) is enabled, you can click on an object or
path to select it (or the group it belongs to).
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If Select > Select by Paths (Outline mode) is disabled, you can click anywhere in an object to select it.
This will select the topmost object. You can use Select Next / Previous: see Select Next Object / Select
Previous Object on page 152

See also Group Select on page 146 and Object Select on page 146

Path Select
In Outline mode, you can click on a path (e.g. a compound path) to select the smallest path in there,
e.g. one of the paths that are part of the compound. If you click a path in Preview mode, the complete
compound the path belongs to will be selected.

In Outline or Preview mode, drag a selection rectangle to select every path entirely within the selection
rectangle.

See also Path Select on page 147

Special cases
The following objects can only be selected by clicking on the path:

• Clipping Paths
• Structural Design objects
• Open paths and open compounds

Text can only be selected by clicking on a character.

7.6.  Selection Breadcrumbs

The Selection Breadcrumbs show the selection in the hierarchy of layers and groups. The Selection
Breadcrumbs appear on top of the document window if anything is selected.

 

 

1. The left-most element shows the highest level: the Layer containing the selection.
2. The left-most highlighted crumb indicates the current selection. Other highlighted crumbs are part

of the selection.
3. The right-most element can indicate the origin of the selection (See below)

The Breadcrumbs show the grouping structure: every element is a part of the element on its left side.
In this example, the Path (3) is part of a Group, which is part of another Group (the current selection).
This selected group is part of a named group "NamedGroup", on a layer "Artwork".

Note:  Generic objects are shown between brackets, such as "<Group>". Named objects are
shown by their name.

The Origin of the selection
The Origin of the selection is the object or path you clicked on using the select tool.
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When clicking on an object using the Object Select tool, you will select the object you clicked on. The
Origin is the same as the Selection.

When clicking on that same object using the Group Select tool, the Origin will be the object you clicked
on, while the selection will be the topmost group that object belongs to.

You can click each breadcrumb to broaden the selection to a higher group or refine it to a lower group
or to the object you initially clicked.

Note:

In some cases, ArtPro+ will not have an origin to show, for example if you add to the selection
by clicking while holding the Shift button, or if the origin was lost because of a change in the
selection.

In that case, the breadcrumbs can show Multiple if multiple objects or groups within the same
group are selected, or All if all elements within the group are selected.

You can rename objects, groups and layers by double-clicking a breadcrumb. See Renaming objects,
groups and layers on page 155

7.7.  Select Same

Using the Select Same tool, you can quickly select objects with the same properties as the current
selection.

1. Select one or more objects
2. Choose Select > Select Same..., click the Select button or use its shortcut Cmd+U (Mac) or Ctrl+U

(Windows) to open the Select Same window.

3. Select one or more criteria to take into account, either by clicking the button or by pressing the
corresponding number key (1 - 7)

Note:  If the currently selected objects have different values for a criterion (represented by
the ≠ symbol) or if the criterion is not available (e.g. font when no text objects are selected),
this selection criterion will not be available

4. Click Select
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All (visible) objects in the document that have the same properties (e.g. the same Fill Color and Stroke
Color) as the current selection will be selected.

There is also a quick way to select objects with the same Fill Color or Stroke Color:

• Choose Select > Select Same Fill Color or use the shortcut Cmd+Alt+i (Mac) or Ctrl+Alt+i (Windows)

• Choose Select > Select Same Stroke Color or use the shortcut Cmd+Alt+Shift+i (Mac) or Ctrl+Alt
+Shift+i (Windows)

Note:

By switching to the Advanced tab, you can select based on specific criteria. See Select
Advanced on page 151.

You can switch between the two tabs using the / key.

7.8.  Select Advanced

Using the Select Advanced tool, you can quickly select objects based on a number of criteria.

1. Choose Select > Select Same..., click the Select button or use its shortcut Cmd+U (Mac) or Ctrl+U
(Windows) to open the Select Same window, and then select the Advanced tab.

Note:  You can switch between the two tabs using the / key.

2. Set the criteria using the dropdown menus. Use the plus key to add a line, or the minus key to
remove it.

Note:  At the bottom right of the dialog you can see how many objects will be selected if the
selection is done based on the current criteria, taking into account the Alt or Shift modifier
(see below).

3. Click Select to (only) select the objects matching all of the criteria

• Hold the Alt key and click Remove from selection to deselect objects matching all of the criteria
• Hold the Shift key and click Add to selection to add objects matching all of the criteria to the

current selection
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7.9.  Select Next Object / Select Previous Object

Select Next Object and Select Previous Object offer you the possibility to select objects that are
covered by other objects for faster access.

1. Click on the spot you want to inspect, using one of the tools that selects by clicking in an object:

• Group Select, Object Select and the Transform tool in Preview mode
• Group Select, Object Select and the Transform tool in Outline mode if Select > Select by Paths

(Outline mode) is disabled

The topmost object or group will be selected.
2. Choose Select > Select Next Object or use the shortcut Ctrl+Tab to select the next (not hidden)

object underneath, regardless of the tool used to made the original object or group.

All Inspectors will show the parameters of the selected object. Every time you press Ctrl+Tab the
next object is selected. Briefly, a Point Indicator shows up to indicate on what location the objects
are inspected. Once the lowest object is reached, the topmost object of the session is selected
again.

3. Choose Select > Select Previous Object or use the shortcut Ctrl+Shift+Tab to do the same but in
the reverse order: every time you click, the object on top is selected. When the topmost object is
selected, using Ctrl+Shift+Tab will select the bottommost object
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8.  Editing

8.1.  Undo and Redo

The Undo and Redo function allows to undo your changes step by step. The menu items in Edit > Undo
and Edit > Redo will show the next action that can be undone or redone.

To undo or redo an action:

• Select Edit > Undo [action] to undo, and Edit > Redo [action] to redo the undone action.

• Use its shortcut Cmd+Z (Mac) or Ctrl+Z (Windows) to undo

• Use the shortcut Cmd+Shift+Z (Mac) or Ctrl+Shift+Z (Windows) to redo

Note:  If the action you Undo or Redo is on a different page in the document, ArtPro+ will
automatically navigate to this page. See Navigating a multi-page document on page 121

8.2.  Cut, Copy and Paste

Cut deletes the selected objects from the document and places them on the clipboard.

Copy puts a copy of the selected objects on the clipboard. The original objects are not removed from
the file.

All properties of the cut or copied objects are stored in the clipboard. One of the consequences of this,
is that if you paste an object, the separations used by that object are added to the document.

Note:  When selecting elements of a group without selecting the group as such, the group
information is not copied. Partially copied content of sublayers will be copied as a group.

Paste puts the clipboard objects in the active file.

You can paste the cut or copied objects into the same file or into another file. When pasting in another
document, inks from the source document that don't exist in the target document will be created.

Quitting ArtPro+ clears the clipboard.

Note:  The objects are pasted at the same position relative to the center of the Crosshair, even
if the Crosshair is invisible when copying or when pasting.

In the Edit menu Shortcut
(Mac)

Shortcut
(Windows)

Result

Cut Cmd+X Ctrl+X places the selected objects on the clipboard

Copy Cmd+C Ctrl+C copies the selected objects on the clipboard
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In the Edit menu Shortcut
(Mac)

Shortcut
(Windows)

Result

Paste Cmd+V Ctrl+V pastes the objects on the clipboard in the
active Layer, on top of any other objects in that
layer.

Paste in Front Cmd+F Ctrl+F pastes the objects directly on top of the
topmost selected object and in the same layer
as this object.

Paste in Back Cmd+Shift+F Ctrl+Shift+F pastes the objects directly below the lowest
selected object and in the same layer as this
object.

Paste with Layer
Structure

Cmd+Shift+V Ctrl+Shift+V pastes the objects in the same layers as they
were when copying (the "source" layers).

When pasting with the Layer Structure:

• If a source layer name matches a layer in the current document (case sensitive), the objects will be
pasted in that layer, on top of all objects in that layer.

Note:  Even if they have the same name, a Processing Step layer and a regular artwork layer
will never be merged. A new Processing Step layer or Artwork layer will be created. For more
information on Processing Step layers, see Processing Step Layers on page 127

• When pasting in a Normalized PDF, objects from Processing Step layers are pasted into a regular
artwork layer with the same name as the Processing Step layer. For more information on Processing
Step layers, see Processing Step Layers on page 127

• If a source layer doesn't exist in the current document, it will be created on top of the current layers,
and have the same printability state as the source layer.

• You can't paste into a hidden layer. If the target layer is hidden, you will get the option to cancel or to
make the target layers visible before pasting.

Copy and Paste text
When cutting or copying text from a text box in ArtPro+, the text formatting is kept.

If you Paste the text in a text box, the text will use this formatting.

If you apply Edit > Paste and Match Style or use its shortcut Cmd+Alt+Shift+V (Mac) or Ctrl+Alt+Shift
+V (Windows), the text will be pasted using the formatting of the current position in the text box,
disregarding the text formatting of the text that was copied or cut.

Note:  Keeping the text formatting when copying text from other applications is currently not
supported.
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8.3.  Handling Objects

8.3.1.  Renaming objects, groups and layers

You can (re)name an object, group or layer by double-clicking an entry in the breadcrumbs, by double-
clicking an entry in the object browser, or by right-clicking an entry in the object browser and selecting
"Rename".

• You can't rename <all> and <Multiple> breadcrumbs
• Clipping paths can not be renamed
• If you change a Layer name, the Layers list is updated accordingly.
• You can't change the name of hidden objects or hidden layers in the Object Browser
• Changing the name of an Image does not change the names shown in the Images browser.
• Named objects created in ArtPro or PackEdge will keep their name in ArtPro+. Object names given

in ArtPro+ are recognized by PackEdge, but not when importing back in ArtPro.

8.3.2.  Delete

You can delete one or more objects, by selecting them and using the delete or backspace key.

8.3.3.  Hiding objects

Using the Hide function, you can hide the selected objects.

Hidden paths are no longer visible and cannot be selected nor modified. Still, they are saved with the
file, so they will become visible again, when the file is next opened. You can apply this function multiple
times, to hide additional objects.

Show All makes all hidden paths visible again.

It will deselect all paths in the current job first and then show the hidden paths, which will come back
selected. This allows you to check something and then immediately Hide them again.

• Select Object > Hide or its shortcut Cmd+3 (Mac) or Ctrl+3 (Windows)
• Select Object > Show All or its shortcut Cmd+Alt+3 (Mac) or Ctrl+Alt+3 (Windows)

8.3.4.  Locking objects

Using the Lock function, you can lock the selected objects. Locked objects are still visible but cannot
be selected nor modified. In Outline mode, the outlines of locked objects are shown in gray.

Unlock All unlocks all locked objects and selects them.

• Select Object > Lock or its shortcut Cmd+2 (Mac) or Ctrl+2 (Windows)
• Select Object > Unlock All or its shortcut Cmd+Alt+2 (Mac) or Ctrl+Alt+2 (Windows)
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In a number of situations, all locked objects become unlocked automatically:

• when saving and reopening the document, since locking isn't saved.
• when switching to a different page of a multipage document
• when entering Edit Opacity Mode, Edit Placed Art Mode or Edit Marks Mode.
• when preflighting the document.
• when applying an Action List (only the affected objects become unlocked)
• when using the Automatic Locking. See Automatic Locking based on the visible separations on page

140

8.3.5.  Arrange objects

Using the Arrange function, you can change the order of the objects within their layer or group.

• Select Object > Arrange > Bring to Front or its shortcut Cmd+5 (Mac) or Ctrl+5 (Windows)
• Select Object > Arrange > Bring Forward or its shortcut Cmd+Alt+5 (Mac) or Ctrl+Alt+5 (Windows)
• Select Object > Arrange > Send Backward or its shortcut Cmd+Alt+6 (Mac) or Ctrl+Alt+6 (Windows)
• Select Object > Arrange > Send to Back or its shortcut Cmd+6 (Mac) or Ctrl+6 (Windows)

Note:  An object that is inside a group can only be arranged within the group. If you need to
arrange it further up or down in the layer, you can use cut and paste to take the object out of
the group.

8.3.6.  Group objects

Using the Group function, you can create a group of multiple objects, compounds or groups.

Making a Group keeps the color of the individual objects, and their relative order. The complete group
is placed at the location (position and layer) of the topmost selected object.

• Select Object > Group or its shortcut Cmd+G (Mac) or Ctrl+G (Windows) to group the selected
objects and/or groups.

• Select an entire group and choose Object > Ungroup or its shortcut Cmd+Shift+G (Mac) or Ctrl+Shift
+G (Windows) to release the group. All components return to their previous state as path, compound
or group.

Note:  If you release a group that contains Group Transparency, you will get a warning that
the transparency will be lost.

Note:  The result of ungrouping can still contain groups. You can apply "Ungroup" multiple
times untill there are only individual objects left.

8.3.7.  Compound

With Make Compound all the selected paths will become one single object.

Where paths are overlapping, a look-through window to the background is created (this is an "even-
odd" compound path).   As a compound is one object, it can have only one color, so when paths with
different colors are compounded, they will be filled with the paint style of the object at the bottom of
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the selection. The compound is placed at the location (position and layer) of the bottommost selected
object. If this bottommost selected object is a user named object made in PackEdge, the compound
path will take over this name.

• Select Object > Compound > Make or its shortcut Cmd+9 (Mac) or Ctrl+9 (Windows) to make a
compound of the current selection.

• At least two objects or paths are needed to make a compound path.
• Both "even-odd" and "non-zero winding" compounds are supported, but compounds made in

ArtPro+ will always be "even-odd".
• The compound will inherit the fill and stroke color, the halftone information and the location of

the bottom-most object in the selection.
• Protected objects (such as unsupported Barcodes, SmartMarks, ...) and live text can not be

compounded. If a selection contains Protected objects or text, you will get a warning, and these
objects will not be included in the compound. If there are less than two objects remaining in the
selection, no compound will be made. See Protected objects on page 178

• If the bottom-most object of the compound has a clipping path, this clipping path will stay when
compounding and remains a separate object (not part of the compound path). This clipping path
will be put in a Clipping Group with the compound path. Clipping paths linked to other objects in
the selection are removed.

• If the selection contains paths that are part of a compound (selected using the Select Path
or the Lasso Select tool), they will be taken out of that compound and be placed in the newly
created compound. The other paths of the original compound(s) stay in that compound(s)

• Select one or more compounds and choose Object > Compound > Release or its shortcut Cmd+Alt
+9 (Mac) or Ctrl+Alt+9 (Windows) to release all selected compounds.

• All components will keep the color of the compound after releasing.
• If a clip was applied to the compound, all released objects will be clipped by this clipping path.

8.3.8.  Placeholder objects

Placeholder objects are objects that are only used to indicate a specific location.

• A StationNumber placeholder indicates the position of the Station Number in a MFG or CFF2 based
repetition. See Station Numbering in an MFG / CF2 workflow on page 360

• A TrimmableFlap or BleedingFlap indicates what flaps can be trimmed and what flaps should bleed
when used in a S&R Nested workflow, either in ArtPro or in Automation Engine

1. Open the PDF of the one-up document.
2. Create or select an object (a rectangle, a path, a text box, …) and position it where you want to place

the station number, or on top of the flap you want to set.
3. Select Object > Convert to Placeholder
4. Select the placeholder Type and click OK

The object loses its fill, stroke, text, .. and is converted to a placeholder object. You can still change
the name, position and orientation of the object.

If needed, you can add more placeholders to the job.
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The Placeholder object can now be used in the Step & Repeat workflow:

• StationNumber: see Station Numbering in an MFG / CF2 workflow on page 360

• To use a TrimmableFlap or BleedingFlap placeholder, apply the one-up PDF document in a
Step&Repeat Nested workflow in either ArtPro or Automation Engine, and enable the "Get from
File" option for Trim & Bleed. For more information we refer to the ArtPro or Automation Engine
documentation.

8.4.  Editing objects

8.4.1.  Transforming objects

You can transform the selected objects in different ways:

• transform manually using the Transform tool: see Transforming manually on page 158

• do a numeric transformation using the Numeric Transform: see Numeric Transform on page 162

• you can do limited transformation by changing values in the Transformation Inspector. See
Transformation Inspector on page 164

• You can use Transform Again to repeat the last performed transform. See Transform Again on page
164

• You can use Align & Distribute. See Align & Distribute on page 165

Note:  Protected objects (such as unsupported barcodes, SmartMarks, ...) can not be
transformed. If a selection contains Protected objects, these objects will not be transformed
along with the other (regular) objects, but stay part of the selection. See Protected objects on
page 178

Transforming manually
Using the Transform tool, you can manually transform the selected objects.

1. Select the Transform tool, either by selecting it in the Tool Switcher (see Changing tools on page 43)
or by its shortcut E, toggling with Scale and Rotate and Align & Distribute. See Scale and Rotate on
page 161 and Align & Distribute on page 165.

When the Transform tool is active, the bounding box of the selected object(s) is shown (1), with 8
handles on it (2).
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Note:

If the Crosshair is rotated, the bounding box will follow this rotation.

 

 

2. Define if you want to include the Gradients & Patterns, Stroke Weights & Effects and Opacity
Masks in the transformation. When disabled, transforming the selection will leave the Gradation &
Pattern Fills, Stroke Weight and/or Opacity Masks unchanged.
 

 
3. Define if you want to enable Snapping. See Move on page 160. You can enable or disable Snapping

by using the checkbox, or by using its shortcut N, even during a transformation.
4. The Interactive Transform Tool can be used for 4 functions : selecting, moving, scaling and

rotating. The function depends on the location you click.

a)
 Click anywhere, or drag outside of the bounding box of the selection (1), to use the tool to

select. The tool works the same way as the regular Group Select tool. See Selecting on page 145
b)

 Click and drag inside the bounding box of the selection (2) or use the arrow keys to move
the selection. See Move on page 160
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c)

 Click and drag on one of the corner handles (3) or the center handles (4) to scale the
selection. See Scale on page 161

d)
 Click outside but close to the bounding box of the selection (5) to rotate the selection. See

Rotate on page 161

Move

•

 Click and drag inside the bounding box of the selection to move the selection.
• Use the arrow keys to move the selection over the fixed Keyboard increment distance defined in

the preferences, or over 10 times that distance when holding the shift key. See Preferences on page
49

• Hold the Cmd key (Mac) or Ctrl key (Windows) while using the arrow keys to move and snap the
bounding box of the selected objects onto the Crosshair.

• Hold the ALT key to keep the original objects. This will result in copying the objects.
• When Snap is enabled, the objects you move will snap and align to the bounding boxes of other

visible objects, the Crosshair (when enabled) and Page Boxes (when visible).
 

 

• You can enable or disable Snapping by using the checkbox, or by using its shortcut N, even
during a transformation.

• During transformation, so-called "smart guides" are shown in blue to indicate what object, page
box or Crosshair the transformation is snapping to. In the example underneath, the center point
of the yellow rectangle is snapping to the bottom right corner of the cyan rectangle.
 

 

• When the Crosshair is rotated and enabled, snapping is done using the rotated bounding box of
the visible objects.
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Scale

•

 Click and drag on one of the corner handles to scale the selection.
•

 Click and drag one of the centers of the bounding box borders to scale the selection only in
vertical or horizontal direction.

• Hold down the Shift key to apply proportional scaling.

When visible, the Crosshair is used as reference point. For more information on the Crosshair, see The
Crosshair on page 95

If the Crosshair is hidden, the handle on the opposite site of the bounding box is used as reference
point when scaling:

You can use the center of the bounding box as reference point by holding the ALT key, regardless of the
Crosshair's visibility state.

Rotate

•
 Click outside but close to the bounding box of the selection to rotate the selection.

• Hold down the Shift key to constrain the rotation angle to multiples of 45 degrees.
• Use the shortcut Alt + Spacebar (Mac) or Shift + Alt + Spacebar (Windows) to rotate the selection 90

degrees clockwise
• Use the shortcut Shift + Spacebar to rotate the selection 90 degrees counterclockwise

When visible, the Crosshair is used as reference point. For more information on the Crosshair, see The
Crosshair on page 95

However, if the Crosshair is hidden, or when holding the ALT key while rotating manually, the center
point of the bounding box is used as center of the rotation.

Scale and Rotate

Using the Transform tool in Scale and Rotate mode  you can apply a uniform scaling and rotation
simultaneously.

1. Select the Scale and Rotate tool, either by selecting it in the Tool Switcher (see Changing tools on
page 43) or by its shortcut E, toggling with Transform and Align & Distribute. See Transforming
manually on page 158 and Align & Distribute on page 165.

When the Scale and Rotate tool is active, the bounding box of the selected object(s) is shown.
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Note:  If the Crosshair is rotated, the bounding box will follow this rotation.

2. Define if you want to include the Gradients & Patterns, Stroke Weights & Effects and Opacity
Masks in the Scale and Rotate. When disabled, transforming the selection will leave the Gradation &
Pattern Fills, Stroke Weight and/or Opacity Masks unchanged.
 

 
3.

 Click anywhere, or drag outside of the bounding box of the selection to use the tool to select.
The tool works the same way as the regular Group Select tool. See Selecting on page 145

4.

 Click and drag inside the bounding box of the selection to scale and rotate the selection.

• Hold down the Shift key to constrain the rotation angle to multiples of 45 degrees.
• When visible, the Crosshair is used as reference point. However, if the Crosshair is hidden, or

when holding the ALT key while rotating manually, the center point of the bounding box is used
as center of the rotation and scaling. For more information on the Crosshair, see The Crosshair
on page 95.

Numeric Transform
Using the Numeric Transform function, you can numerically transform the selected objects.

You can open the Transform window, either by choosing Object > Transform or by its shortcut Cmd
+Shift+M (Mac) or Ctrl+Shift+M (Windows).

 

 

1. Define the reference point for the transformation by selecting one of 9 points. The corresponding
point on the bounding box of the selection is used as reference point. However, if the Crosshair is
visible, the center of the Crosshair is used as reference point. See The Crosshair on page 95

In the example underneath you see an example of rotating using the center (left) or the top left
corner (right) as reference point.
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2. Define the Move Distance
3. Define the Scaling. If the Link option next to the scaling fields is enabled, scaling will be

proportionally.
4. Define the angle for Rotation and for Shearing.
5. Enable the Mirror buttons to mirror the selection vertically or horizontally
6. Define if you want to Include the Gradient & Pattern Fills, Stroke Weight and Opacity Masks in the

transformation. When disabled, transforming the selection will leave the Gradation & Pattern Fills,
Stroke Weight and/or Opacity Masks unchanged.

7. Define the number of times you want to perform the transformation.
8. By default, the selected objects are transformed as one, with one reference point. If you want to

transform each object in the selection individually, each with their own reference point, you can
enable Transform each. This option can not be combined with using the Crosshair as reference
point.

The example underneath shows a scaling by 200%, with "Transform Each" disabled (A) and enabled
(B)

 

 
9. Click the Cancel button to close the dialog without transforming, or hold the ALT key and click the

same button to Reset all settings to their default value.
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10. Click the Transform button to apply the transformation to the selection, or hold the ALT key and
click the same button to Copy the selection. The selection will be transformed, while the original
objects are kept as well.

Transform Again
Select Object > Transform Again or its shortcut Cmd+D (Mac) or Ctrl+D (Windows) to repeat the
previous transform.

Transformation Inspector
The Transformation Inspector shows information on the size, position and rotation of the selected
objects. You can also use it to do basic transformations on the selection. For more elaborate
transformations, you can use the numeric transform function. See Numeric Transform on page 162.

 

 

1. The reference point on the bounding box of the selection used to determine the position (see
below) and when changing the size or rotation while the Crosshair is hidden.

In the example underneath you see an example of rotating using the center (left) or the top left
corner (right) as reference point.

 

 
2. The position, horizontal and vertical, of the center of the Crosshair to the selected reference point.

If the Crosshair is not visible, the top left corner of the Media Box is used instead. You can move the
selected objects by entering a different distance.

3. The size of the selection. You can scale the selection by entering a different size. If the two values
are linked, changing one value will also change the other.

4. The angle of rotation of the selection. You can rotate the selection by entering a different angle.
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5. The shear angle of the selection. You can shear the selection by entering a different angle.
6. Attach To and Offset: only available when you're using the Transformation inspector to position a

Grid. See Positioning the Grid on page 357
7. If the selected object is a Mark, you can also set the Attach To dropdown. See Mark positioning on

page 411

Note:  When selecting multiple objects with different rotation or shearing angle, these fields
will show "≠".

Align & Distribute
The Align & Distribute functionality can be used to horizontally or vertically align or distribute a number
of objects.

1. Select the Align & Distribute tool, either by selecting it in the Tool Switcher (see Changing tools on
page 43) or by its shortcut E, toggling with Transform. See Transforming manually on page 158.

When the Align & Distribute tool is active, the Align & Distribute buttons are shown at the bottom of
the workspace.

2. Select the objects you want to align or distribute.

Note:  You can use any of the select tools, or the Align tool itself. This works the same as
the Group Select tool.

When the Align & Distribute tool is active, a red box is shown on every top level object (a complete
group, a single object, a clipping group, …) indicating the bounding boxes that will be used for the
Align or Distribute.

 

 
3. Click the button to apply the corresponding Align or Distribute:
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• 1. Align vertically on top
• 2. Align vertically centered
• 3. Align vertically on the bottom
• 4. Align horizontally on the left
• 5. Align horizontally centered
• 6. Align horizontally on the bottom
• 7. Vertical Distribute Center
• 8. Vertical Distribute Space
• 9. Horizontally Distribute Center
• 10. Horizontally Distribute Space

The image underneath shows the original objects on the left, and the result of the vertical Align &
Distribute tools (1, 2, 3, 7 and 8).

 

 

If an Align or Distribute function would give no result with the current selection, the button will be
disabled. For example:

• If you have less than 2 objects selected, all Align buttons will be disabled
• If you have less than 3 objects selected, all Distribute buttons will be disabled
• If the selected objects are already aligned or distributed (e.g. all objects are centered horizontally)

the corresponding button is disabled, regardless of whether the align or distribute was done using
the Align & Distribute function or not.

Note:  The Align & Distribute function takes the rotation of the Crosshair into acount. See
Move or rotate the Crosshair on page 95

Fit to Page Box
The Fit To Page Box functionality can be used to scale the selected objects to fit the selected page
box.

1. Select the object(s) you want to scale
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2. Select Object > Fit > Fit to [page box]. You choose any page box available in your document.

The selected objects will be scaled proportionally to fit the selected page box and centered on this
page box.

Note:  The settings for Gradient & Pattern Fills, Stroke Weight and Opacity Masks as set in the
Transform dialog will be taken into account. See Numeric Transform on page 162

8.4.2.  Clipping Mask

With Clipping Mask you can set or release Clipping Masks.

• Select Object > Clipping Mask > Make or its shortcut Cmd+7 (Mac) or Ctrl+7 (Windows) to make the
topmost object as Clipping Mask for all objects underneath.

• At least two objects are needed to make a clipping mask.

• Protected objects must be expanded first to be included in the clipping mask.

• All selected objects will be placed in a "Clip Group". The group will be positioned at the place of
the second topmost object (the highest object apart from the object or group used as clipping
mask).

• In outline view or when selected, the Clipping Path object will be shown using a dashed line.
• Select one or more Clip Groups and choose Object > Clipping Mask > Release or its shortcut Cmd

+Alt+7 (Mac) or Ctrl+Alt+7 (Windows) to release all selected Clipping Masks.

• All components will get their original state, and the clipping mask object becomes a regular
object but without any fill or stroke.

Clip on Page Box
Using Clip on Page Box you can clip the selected objects using one of the defined page boxes.

1. Select the objects you want to clip
2. Choose Object > Clip
3. Select the page box you want to use. Only page boxes defined on the current page in the document

are shown.

All selections are placed in a Clipping group, using the selected page box as clipping mask.

Clip On Shape
With Clip On Shape you can set Clipping Masks, while keeping the document structure intact.

• Select Object > Clip > On Shape to make the topmost object a Clipping Mask for all objects
underneath.

• At least two objects are needed to apply Clip On Shape.

• Protected objects must be expanded first to be included in the clipping mask.
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• All selected objects will be in a "Clip Group", using the topmost object as clip mask. Unlike when
using Make Clip Mask, where the Clip Group is placed at the level of the highest object apart
from the object or group used as clipping mask, with Clip On Shape there will be as many clip
groups as necessary to keep the document structure intact.

• In outline view or when selected, the Clipping Path object will be shown using a dashed line.
• Select one or more Clip Groups and choose Object > Clipping Mask > Release or its shortcut Cmd

+Alt+7 (Mac) or Ctrl+Alt+7 (Windows) to release all selected Clipping Masks.

• All components will get their original state, and the clipping mask object becomes a regular
object but without any fill or stroke.

8.4.3.  Opacity Masks

If you select an object with an Opacity Mask, the Transparency Inspector (see Transparency Inspector
on page 189) will show a number of extra options.

• The Edit Opacity Mask button. See Edit Opacity Masks on page 169
• The Release Opacity Mask button. See Make and Release Opacity Masks on page 169
• A Preview of the originals without opacity mask, and of the opacity mask itself.
• The Link option in between both previews. If the link is disabled, any transformation (move,

scale, ...) applied on the selection will not change the opacity mask. If it is enabled, all
transformations (move, scale, ...) will be applied to the opacity mask as well.

• If the Clip option is enabled, the masked objects will become completely transparent outside the
boundaries of the Masking object.

• The Invert Mask option reverses the luminosity values of the masking object, and so also reverses
the opacity of the masked objects.
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Make and Release Opacity Masks
With Opacity Mask you can set or release Opacity Masks.

• Select Object > Opacity Mask > Make or click the Make Opacity Mask button in the Transparency
Inspector to set the topmost object (or group) as Opacity Mask for all objects underneath.

• At least two objects are needed to make an opacity mask.

• All selected objects will be placed in an "Opacity Group". The group will be positioned at the place
of the second topmost object (the highest object apart from the object or group used as opacity
mask).

• Making an Opacity Mask is not possible if Clipping paths (and not the Clipping Group) are
selected.

• Select one or more Opacity Groups and choose Object > Opacity Mask > Release or click the
Release Opacity Mask button in the Group Transparency Inspector to release all selected Opacity
Masks.

• All components will get their original color back, and will be assigned the default screening after
releasing.

Edit Opacity Masks
You can edit an opacity mask without the need to release and remake it, using Edit Opacity Mask.

• Select an Opacity Mask group
• Select Object > Opacity Mask > Edit, click the Edit Opacity Mask button in the Transparency

Inspector or double-click the mask thumbnail in the Transparency Inspector.

ArtPro+ will switch to Edit Opacity Mask mode. This means that:

• Only the contents of the opacity mask is editable
• In Preview mode, the objects in the opacity mask are shown opaque, while in the background a

dimmed version of the document is still visible.
• In Outline mode, only the outlines of the opacity mask objects are shown. In Outline with hinting

mode, the document is also visible.
• If you hold the Y key, you get a preview of what the document looks like with the edited Opacity

Mask. If you release the Y key, you return to Opacity Mask editing.

• Functions not relevant for Object Mask editing will not be available. For example Layers, Quality
Control, Separations are hidden, Page boxes can be viewed but not edited, etc.

• The document Separations list is replaced by the opacity mask Colorants list, showing the
inks only used in the opacity mask under edit. This can be edited totally independent of the
document's Separations list.

• The opacity mask colorants are converted to CMYK for visualization purposes to match the
output on the RIP. The Densities tool behaves accordingly.

• While in Edit Opacity Mask mode, you can not undo actions that were done before starting the
opacity mask editing.
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• If you are done changing the Opacity Mask, you can leave Edit Opacity Mask mode by clicking Back
to Document in the breadcrumbs or in the Side Panel.

8.4.4.  Creating and editing paths

Create & Edit Path
Using the Create & Edit Path tool, you can create new paths or change the path of the selected object.

Note:  The path tools can only be used to edit paths and compound paths. Images, Placed Art,
text, barcodes and Protected objects (such as unsupported barcodes, Smartmarks, ...) can't be
edited. See Protected objects on page 178

1. Select the Create & Edit Path tool, either by selecting it in the Tool Switcher (see Changing tools
on page 43) or by its shortcut P, toggling with Split and Retrace, Cut Path and Adjust Corners. See
Split and Retrace on page 171, Cut Path on page 172 and Adjust Corners on page 174.

When the Create & Edit Path tool is active, the anchor points and handles on the selected path will
become visible.

2. The Create & Edit Path tool can be used for several functions : create new paths, move or remove
anchor points, etc. The function depends on the location you click.

a)
 Click anywhere in the document (except on an existing and selected path) to start creating

a new path. Clicking will create a starting point, click and drag will immediately add handles to it.
b)

 With an endpoint of an open path selected, click to add a point. Click and drag to
immediately add handles to it,

c)

 With one endpoint of an open path selected, click the other endpoint to close the path.,
d)

 Click on a path segment to add an anchor point.
e)

 Click on an anchor point to (de)select it. Hold the Shift key to select multiple anchor points.
f)

 Hold the Alt (Mac) or Option (Windows) key and click and drag to select multiple anchor
points.

g)

 Click and drag selected anchor points to move the anchor point(s). Hold down the shift
key to constrain the movement to vertical, horizontal or over 45 degrees.

h) Double-click an anchor point to convert it between an anchor point with handles (smooth point)
and an anchor point without handles (corner point).

i) Hold the Command (Mac) or Control (Windows) key and use the arrow keys to move the anchor
points onto the Crosshair, using the bounding box of the selected anchor points
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j)
 If a selected anchor points has handles: click and drag one of the handles to move both

handles. Hold the shift key to only modify the length of the handle, without changing the
direction

k)
 If a selected anchor points has handles: click and drag one of the handles while holding

the Alt key to only modify the one handle instead of both.
l) While editing an object using the Create & Edit Path you can use some of the select functions

on the anchor points of the object

• Use Select > Select All or its shortcut Cmd+A (Mac) or Ctrl+A (Windows) to select all anchor
points of the object.

• Use Select > Deselect All or its shortcut Cmd+Shift+A (Mac) or Ctrl+Shift+A (Windows) to
deselect all anchor points.

• Use Select > Select Inverse or its shortcut Cmd+Alt+A (Mac) or Ctrl+Alt+A (Windows) to
invert the selection: selected anchor points become deselected, unselected anchor points
become selected.

Split and Retrace
Using the Split and Retrace tool, you can retrace a part of the path of the selected object, or you can
split the path.

Note:  The path tools can only be used to edit paths and compound paths. Images, Placed Art,
text, barcodes and Protected objects (such as unsupported barcodes, SmartMarks, ...) can't be
edited. See Protected objects on page 178

1. Select the path you want to edit.
2. Select the Split and Retrace tool, either by selecting it in the Tool Switcher (see Changing tools on

page 43) or by its shortcut P, toggling with Edit Path, Cut Path and Adjust Corners. See Create &
Edit Path on page 170, Cut Path on page 172 and Adjust Corners on page 174.

3.
 Click a starting point on the path.

4. Draw the new part of the path
a)

 Click to add an anchor point. Click and drag to create an anchor point and immediately
add handles to it.

Note:  To add an anchor point close to the original path without closing the retrace, hold
down the Alt key.

b) You can edit already created anchor points using the same tools as in Edit Path, e.g. to add or
edit handles, move anchor points, etc. See Create & Edit Path on page 170

c) Hold down the Shift key to constrain the newly drawn line or Bézier curve by an angle of 45
degrees. If the Crosshair is rotated, this rotation is added to the constrain angle.

d) Undo the last drawn anchor point by using the Delete key.
5.

 Click on the original path to define the end point of the retrace.
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6.

 Click the part of the shape you want to keep (Retrace) or drag over both parts to keep them
both (Split).

Note:  Since there aren't two parts to choose from when you are retracing an open path,
this step will be skipped. You can solve this by closing the path first: see Close Path on page
174.

Retrace Split

 

 

 

 

Note:  If you apply Split & Retrace on an open path, you can't decide the part of the shape you
want to keep, nor can you apply a split.

Cut Path
Using the Cut Path tool, you can cut the path of the selected object. This will create two end points at
the place where you cut. Cutting a closed path will result in an open path, cutting an open path results
in two open paths.

Note:  The path tools can only be used to edit paths and compound paths. Images, Placed Art,
text, barcodes and Protected objects (such as unsupported barcodes, SmartMarks, ...) can't be
edited. See Protected objects on page 178

1. Select the path you want to edit.
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2. Select the Cut Path tool, either by selecting it in the Tool Switcher (see Changing tools on page 43)
or by its shortcut P, toggling with Edit Path and Split and Retrace. See Create & Edit Path on page
170, Split and Retrace on page 171 and Adjust Corners on page 174.

3.
 Click on the selected path where you want to cut it.

• A Circle will indicate where the path(s) will be cut. When hovering over an object that can't be cut
(barcodes, Marks, images, …) no circle indicator is shown.

• The Cut Path tool will snap to the selected path, but also to intersections of the path with the
Crosshair and to intersections with other paths (even with unselected paths).

• You can temporarily disable this snapping by holding down the Alt key.
4. When you click, the selected object(s) will be cut

• The path becomes an open path, part of a compound.
• If you click the intersection of two selected paths, both paths will be cut.
• If you cut a path with a dashed stroke, the dashing pattern can be affected, since a new starting

point was created.

 

 

You can close the resulting open path(s) using the Create & Edit Path tool, or using Join Paths or Close
Paths. See Create & Edit Path on page 170, Join Paths on page 173 or Close Path on page 174

Join Paths
If the selection contains one or more open paths, you can join all selected open paths into one closed
path by choosing Object > Path > Join Paths or by using its shortcut Cmd+J (Mac) or Ctrl+J (Windows).

The end points closest to each other will be connected using a straight line.
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Note:  If you have only one path selected, using Close Path and Join Path will give the same
result. See Close Path on page 174

Close Path
If the selection contains one or more open paths, you can close them by choosing Object > Path >
Close Path or by using its shortcut Cmd+Alt+J (Mac) or Ctrl+Alt+J (Windows).

All open paths will be closed individually, by connecting their end points using a straight line.

Note:  If you have only one path selected, using Close Path and Join Path will give the same
result. See Join Paths on page 173

Adjust Corners
Using the Adjust Corners tool, you can create and edit rounded corners.

Note:  The path tools can only be used to edit paths and compound paths. Images, Placed Art,
text, barcodes and Protected objects (such as unsupported barcodes, SmartMarks, ...) can't be
edited. See Protected objects on page 178

1. Select the path you want to edit.
2. Select the Adjust Corners tool, either by selecting it in the Tool Switcher (see Changing tools on

page 43) or by its shortcut P, toggling with Edit Path, Split and Retrace and Cut Path. See Create &
Edit Path on page 170, Split and Retrace on page 171 and Cut Path on page 172

3. Select the Corner Control Point on the inside of the corner you want to edit

• You can only edit straight corners, i.e. where two straight lines meet. Other corners will not have
a Corner Control Point.

• You can select additional Corner Control Points by holding the shift key.
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4. In the Adjust Corner palette, set the corner Radius and the Corner Options: Round, Inverted Round
or Bevel.

• All selected corners will become rounded corners using the selected radius and option.

Smoothen Path
Using the Smoothen Path tool, you can simplify a closed path by reducing points.

Note:  The path tools can only be used to edit paths and compound paths. Images, Placed Art,
text, barcodes and Protected objects (such as unsupported barcodes, SmartMarks, ...) can't be
edited. See Protected objects on page 178

1. Select the path(s) you want to edit.
2. Choose Object > Path > Smoothen Path

The Smoothened Path Inspector will become available.

 

175



8 ArtPro+

 
3. In the Smoothened Path Inspector, you can change the Smoothen Path options.

a) The Reduction Factor makes the paths smoother. Higher values filter out more sharp edges and
noise resulting in smoother curves. Reduction Factor 0 turns filtering off, only straightening is
done. The default value for bitmap images is 0, for other images it is 3.

b) The Straighten Threshold allows to reduce the noise on the paths by replacing them with
straighter parts, i.e. by removing anchor points. The Threshold specifies the maximum deviation
allowed between the original path and the straightened path. A larger value results in fewer
points and therefore speeds up all subsequent operations.

c) The Dust Threshold can be used to eliminate scanned dirt. A Dust Threshold of 0,07mm means
that all black or white areas on the original smaller than 0,07mm by 0,07mm will be filtered away.

Below you see an example of a Smoothened Path

1. With a low Reduction Factor and low Straighten Threshold
2. With a high Reduction Factor and low Straighten Threshold
3. With a low Reduction Factor and high Straighten Threshold
4. With a high Reduction Factor and high Straighten Threshold

 

 

Note:  As soon as the object is modified in another way (remove points, remove paths,
scale, …) or expanded, the Smoothen Path operation is considered done, and Smoothened
Path Inspector will no longer be available.

8.4.5.  Spread / Choke

Using the Spread / Choke function, you can enlarge (Spread) or reduce (Choke) the selected object(s).

1. Select the objects you want to spread or choke
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Note:  Spread / Choke is not supported on images, barcodes, text and Protected objects.
If your selection contains unsupported objects, you will get a warning when spreading /
choking. If your selection only contains unsupported objects, Spread/Choke will be
disabled.

2. Open the Spread / Choke window by choosing Object > Spread/Choke or by its shortcut Cmd+Shift
+T (Mac) or Ctrl+Shift+T (Windows)

3. Using the buttons on the top, choose between Spread and Choke
4. Enter the Distance to be used
5. Select how the sharp corners should be handled

• Mitered: this option works with a miter ratio. The miter ratio serves to limit the length of the
sharp corner (the distance from the base of the trap to the corner point). The default miter ratio
value is 4. This means that if the length of the sharp corner is more than 4 times the Distance,
then the corner will be cut off (beveled). If it is less than 4 times the Distance, the corner will be
left as it is.

• Round: a round cap will be placed at all corners.
• Beveled: this will cut sharp corners off.

6. Select how you want to Apply the spread or choke

• Select to original object to replace the original object by the spread or choked shape.

• Select To a copy behind selection if you want to keep the original object, and place the spread/
choke object underneath the original.

• Select to a copy in front of selection if you want to keep the original object, and place the
spread/choke object on top of the original.

• Select As a manual trap to create trapping based on the original object and the spread or choke
shape

• the largest of the two is placed in front: in case of a Spread, the Spread object is in front of
the original object, in case of a choke, the original object is in front of the Choke object.

• the frontmost (largest) shape gets the fill of the original object with a Darken blend mode,
while the bottommost shape will be white (all zero).
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• If the original object has transparency, both the original and the Spread/Choke object will be
placed in a transparency group. The transparency group will get the transparency setting of
the original object.

• If the original object has a stroke, the stroke will be outlined automatically before applying
the Spread/Choke

Note:  When switching to "as a manual trap", the corners will by default switch to Round
as this usually gives the best results. You can manually overwrite this.

8.4.6.  Protected objects

Protected objects (or "High-level objects" as they were called earlier) are objects saved in the PDF
file, using "Private Data": specific information about the object, written in the PDF file by the PDF file
creator. Common examples are

• Unsupported Barcodes: see Barcodes on page 232

• Unsupported live text (not in a text box)

• SmartMarks
• Unsupported images.

In ArtPro+, it is not allowed to change these Protected objects: you can not transform them, or include
them in a compound. See also Transforming objects on page 158 and Compound on page 156

Note:  Unsupported images are marked as Protected objects, but they can be transformed.

You can however expand a Protected object. See Expand on page 178

Note:  Expanding is not recommended for unsupported images

Expand
Protected objects (see Protected objects on page 178), barcodes (see Barcodes on page 232), Marks
(see Marks on page 381), Forms, Placed Art (see Working with Placed Art on page 219), Structural
Design files (see Working with Structural Design files on page 228) and Grids can be expanded.

To expand all expandable objects in the selection:

• Choose Object > Expand

• Click the Expand button in the Inspector bar.

Expanding these objects will replace them by regular objects (e.g. a Mark can be replaced by a number
of rectangles or pieces of text, the placed art in a Form becomes editable) in a group.

Note:  The result of expanding can still contain expandable objects. You can apply "Expand"
multiple times until the object is completely expanded.

178



8ArtPro+

By doing so, the objects become fully editable, but lose the information used to create them.

8.4.7.  Rasterize ...

Using this function, you can replace the selected artwork by an image.

1. Select the objects you want to rasterize, and select Object > Rasterize ....

The Rasterize window will open.

 

 

Note:  The number of created images depends on the locations of the selected objects in
the object browser: selecting a non-consecutive set of objects creates multiple images. In
that case a warning will be shown in the Rasterize window, showing the number of images
that will be generated, and advising to group the selection to avoid this.

2. Set the Resolution for the image to be created
3. Set the Anti-aliasing you want to apply.

Anti-Aliasing will result in a smoother preview.
4. Select Include Background to rasterize the background into the image, so blend modes and

overprint are kept. If the option is disabled, only the selected objects will be in the image, and the
background of the image will be transparent, and blend modes and overprints will be disregarded.

5. Click Rasterize to create the rasterized image, replacing the selected objects.

Note:  During Rasterizing, 2% noise is applied.

8.4.8.  Clean

Clean combines a number of functions to clean up, improve or modify your artwork. The different
functions are described separately:

• Merge Similar Paths and Text on page 180

• Contourize Text on page 206

• Outline Strokes on page 180

• Clean up Groups and Clipping Masks on page 181

• Execute Clipping Masks on page 181
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• Optimize Artwork on page 181

• Fix Text Box Reflow on page 182

You can use every function individually by selecting it in Object > Clean, or you can combine them using
the Clean dialog.

1. Select the objects you want to clean.
2. Choose Object > Clean > Show Clean Dialog..., click the Clean button or use its shortcut Cmd+Shift

+C (Mac) or Ctrl+Shift+C (Windows) to open the Clean window.
 

 
3. Select one or more Clean functions to apply, either by clicking the button or by pressing the

corresponding number key (1 - 7)
Depending on the selection, some functions can be disabled.

4. Click OK

Merge Similar Paths and Text
In some situations (e.g. to make a combination between CMYK and spot color), a path or text box can be
composed of different identical objects (shape, size and position) on top of each other. For example, a
rectangle containing a CMYK color, and an identical object on top, containing a spot color percentage
in overprint.

The Merge similar paths and text function allows to combine such objects into one object, whereas
the fill will be merged. In the example described above, that would be one object combining CMYK and
the spot color fill.

1. Select the objects & text boxes you want to apply the function on.
2. Select Object > Merge similar paths and text

The redundant objects or text objects will be removed, and the remaining object or text box will get the
merged fill color. A message will be shown indicating how many objects or text boxes were cleaned up.

Note:  Merging will only be done if this will make no difference to the final result. For example
with different blend modes or screening, merging will not be done.

Outline Strokes
Using this function, you can replace stroked objects by a group consisting of a path (the fill object) and
compound path (the outlined) stroke.

1. Select the stroked object you want to edit
2. Select Object > Clean > Outline Strokes

Outline Strokes can also be applied from the Clean dialog. See Clean on page 179
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Note:  Outline Strokes doesn't work on stroked text. You can however combine contourizing the
text and outlining the strokes from the Clean dialog.

Clean up Groups and Clipping Masks
To remove redundant groups and clipping masks (e.g. a group as sole component in another group) you
can use the Clean up Groups and Clipping Masks function.

1. Select the objects & groups you want to apply the function on.
2. Select Object > Clean > Clean up Groups and Clipping Masks

The redundant groupings and clipping masks will be removed, and a message will be shown indicating
how many groups and/or clipping masks were removed.

Note:  Named groups will not be removed.

Execute Clipping Masks
Using this function, you can replace object & clipping mask combinations, and create new simple
objects where possible, without causing any visual difference.

Objects are cropped on their clipping mask, while the clipping path itself and anything that was clipped
away is removed. During the process, affected strokes and live text will be contourized.

Images, patterns and Dynamic Marks remain untouched

1. Select at least one clip group you want to execute
2. Select Object > Clean > Execute Clipping Masks

Execute Clipping Masks can also be applied from the Clean dialog. See Clean on page 179

Optimize Artwork
To clean up your selection, removing paths or parts of paths without affecting the visual appearance of
the job, you can use the Optimize Artwork function.

Important:  Optimize Artwork is a destructive action: objects can be removed, or split into
multiple smaller objects. In many cases, editability is limited. It is therefore not recommended
to run on all artwork, but to run it on targeted objects only, for a specific goal such as
simplifying trapping afterwards.

Optimizing your Artwork will simplify trapping afterwards.

1. Select the objects & groups you want to apply the function on.
2. Select Object > Optimize Artwork

The selected objects will be simplified as much as possible. Text and barcodes are outlined, image
clips are executed, etc. The layer structure is kept as much of possible. When objects from multiple
layers were selected, the result will be placed in the topmost layer involved.

For images with transparency, the Optimize Artwork function can generate a clipping mask, or it can
even split up the image in multiple cliping groups.

The example underneath shows both preview and outline before (left) and after (right) using Optimize
Artwork
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Fix Text Box Reflow
In certain PDF files, improper line endings in the PDF code can result in the combination of multiple
overlapping, non-consecutive or rotated lines of text into one single text box. ArtPro+ will honor this
text box, but it will be hard to edit.

If you try editing such a text box, you will be given the option to split it into multiple text boxes. You can
also fix it using the Fix Text Box Reflow option

1. Select at least one text box you want to fix
2. Select Object > Clean > Fix Text Box Reflow

A message will inform you how many text boxes were split or fixed, and what the resulting number of
text boxes is.

Fix Text Box Reflow can also be applied from the Clean dialog. See Clean on page 179

8.5.  Changing the Fill and Stroke

8.5.1.  Fill Color and Stroke Color Inspector

When one or more objects are selected, the Inspector will show 2 color patches: one for the Fill 

and one for the Stroke . If all selected objects have the same Fill or Stroke, the color patch will give
a representation of the Fill or Stroke color. Otherwise, it will show the ≠ symbol.

You can use the shortcut Cmd+I (Mac) or Ctrl+I (Windows) or click the Fill color patch to open the Fill
Inspector.
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You can also use the shortcut Cmd+Shift+I (Mac) or Ctrl+Shift+I (Windows) or click the Stroke color
patch to open the Stroke Inspector.

The buttons on top of the dialog are:

• None : the object or stroke is empty, and thus completely transparent.

• Color: a flat color. See Flat Color on page 184.

• Gradient: a gradation between two colors. See Gradient on page 185.

• Pattern: see Pattern on page 187

• Multicolor Barcode: see Multicolor Barcode on page 188

You can toggle between None, Color and Gradient by using the shortcut Cmd+/ (Mac) or Ctrl+/
(Windows).

Note:  If the selected object is susceptible to color conversion, its Color Space is shown in the
Fill Color or Stroke Color Inspector. See Objects, groups or pages susceptible to color conversion
on page 98
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Flat Color

Below the color patch is a list of the current separations, and the percentage for each separation.

• Enter the percentage for every separation to change the color. You can enter a value, or use one of
the shortcuts:
a) Enter a followed by a value, to set all separations to that value.
b) Enter x to set the value to 100%, or enter ax to set all values to 100%
c) Click the color patch to set the value for that separation to 100%. Clicking it again will switch it

between 0% and 100%.
•

Click the Color Picker  or use the shortcut i (while the Inspector is open) to pick a color from your
job. If you click and drag, the Color Picker will show the currently selected color the same way as the
Densities tool. See Densities on page 116. As soon as you release, the selected color will be set in the
Inspector.

•
Click the All Zero button  to make the object(s) or stroke(s) completely white and knock-out for
all separations

•
Click the Registration Color button  to switch to registration color. The dialog will only show
one line, and the entered percentage will be used for all separations. The Registration Color button

has changed to this: . Click this button to switch back to normal color.
•

Click the button on the right of the separation name  to switch the selected object(s) or stroke(s)
to overprinting for that specific separation. The separation percentage field will become empty,

and the state will change to overprinting . Clicking the button again will switch back to knock-
out and 0% You can also enter t as value to set the separation overprinting. Enter at to set all
separations overprinting.

• If all separations that are unused (i.e. set to 0%) are set to knock-out, you can click the Set unused

separations overprinting button  above the separations to change the state of all unused
separations to an "overprinting" state. If at least one separation is overprinting, you can click the Set
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overprinting separations knockout button  to switch all overprinting separations to knock-out
(0%).

Gradient
Gradients are defined by a series of stops along the gradient slider. A stop marks the point at which a
gradient changes from one color to the next, and is identified by a square below the gradient slider. The
squares display the color currently assigned to each gradient stop. With a radial gradient, the leftmost
gradient stop defines the center point’s color fill, which radiates outward to the color of the rightmost
gradient stop.

• Select the type of gradient: Radial or Linear
• Use the Angle field to numerically change the rotation.
• Set up the Color stops:

a) Click a Color Stop to select it and set its color . See Setting the color of a gradient Color Stop on
page 186

b) Click on the bottom of the bar to add a Color Stop.
c) Click and drag a Color Stop to change its position in between the other Color Stops. This is not

possible for the start and end Color Stop.
d) Select a Color Stop and drag while holding the ALT key to duplicate the Color Stop
e) Select a Color Stop and click the trash icon or drag it downwards to delete it. You can't delete the

start and end Color Stop.
• Set up the Midpoints

a) Click and drag a Midpoint of the gradient to move it manually.
b) Click a Midpoint to select it, and enter its Position as a percentage. Values between 13% and 87%

are allowed.
c) Alt-click a Midpoint to reset it to 50%
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Setting the color of a gradient Color Stop

Setting the color of one of the Color Stops of a gradient is the same as setting a flat color. See Flat
Color on page 184

There are however a few restrictions:

•
Clicking the Registration Color button  will change both the begin and end color to registration
color (or back to normal color when clicking again)

• A gradient can not go from transparent to knock-out (0% or a specific value). If you set one point to
transparent for a separation that is knock-out in the other point, this will automatically change back
to knock-out.

• Because of the limitation mentioned above, clicking the Set unused separations overprinting

button  will only change the separations that are unused (0%) in both the begin and end point.
Both occurrences will change to Transparent.

Manually editing the handle points of a gradient
If you select an object with a gradient, you have one of the selector tools (Object Select tool, Group
Select tool or Transform tool) and the Inspector is open, you can edit the gradient using the handle
points in the object itself.

 

 

• Click and drag one of the end points of a linear gradient to move the position of the end point.
• Click and drag the center point of a radial gradient to position the center point within the gradient.
• Click and drag the circumference of a radial gradient to change its size.
• Click and drag the handles line to move the gradient while maintaining the angle and distance

between end points
• Click and drag a Midpoint to change its position. Alt-Click it to re-center it in between the two Color

Stops.
• Double-click a Color Stop or Midpoint to select it. You can then change its properties (color for a

Color Stop, Position for a Midpoint
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Pattern
 

 

If you have a pattern filled object selected, you can open the Pattern Inspector

• You can click the Expand Pattern button to replace the fill with a repetition of the actual objects.
• If the pattern is colored, you get a preview of the pattern, but can't change it.
• If the pattern is uncolored, the pattern inspector will show 2 thumbnails, and you can set the color

for the pattern yourself.
 

 

187



8 ArtPro+

Multicolor Barcode
This special fill mode can be used to create a multicolor barcode. This is only available for Laetus
Pharma barcodes. See Laetus Pharma on page 280

8.5.2.  Stroke Inspector

Using the Stroke Inspector, you can change the size and shape of a stroke

1. Open the Stroke Inspector
 

 
2. Define the Weight of the stroke. Enter a number to use the default unit, or add the unit and it will

be converted to the default unit. See Preferences on page 49. You can enter zero or leave the field
blank to switch to "no stroke".

3. Select the shape of the End Caps

• With Butt Caps the stroke is squared off at the end point of the path.
• With Round Caps, a semicircular arc with diameter equal to the line width is drawn around the

end points of the line, thus prolonging it.
• With Projecting Caps the stroke continues beyond the end point of the path and is squared off

at a distance equal to half the line width.
4. Select how the sharp corners should be handled

• Mitered: this option works with a miter ratio. The miter ratio serves to limit the length of the
sharp corner (the distance from the base of the trap to the corner point). The default miter ratio
value is 4. This means that if the length of the sharp corner is more than 4 times the Distance,
then the corner will be cut off (beveled). If it is less than 4 times the Distance, the corner will be
left as it is.

• Round: a round cap will be placed at all corners.
• Beveled: this will cut sharp corners off.
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5. Enable Dashed to create a dashed stroke

• Define the size of the dash and the size of the gap
• If you want to add another combination of dash and gap, click the + button. To remove a

combination, click the - button
• Enter an Offset distance to modify the starting point for the dashes & gaps.

8.5.3.  Transparency Inspector

The Transparency Inspector shows the transparency settings of the currently selected object or
group. Keep in mind that although group and object transparency can be combined, the inspector will
show either the group or the object transparency, depending on the selection.

Note:  You can use the Breadcrumbs to see or change the current selection.

Object Transparency Group Transparency

Blend Mode

A Blend Mode makes a combination between the blend object (object on which the blend mode is
applied) and a base object (underneath the blend object), resulting in a blend color. The final result will
depend on the base object, the blend color and the opacity (see below)

Note:  Non-white preserving blend modes (Difference, Exclusion, Hue, Saturation, Color and
Luminosity) require all 4 process separations. If these separations are not present, using a
Non-white preserving blend mode will add them.

Opacity
The Opacity defines how much of the Blend result will be used. If the Opacity is 100%, the result will be
100% of the Blend result (as described above). If the Opacity is e.g. 60%, the final result will be 60% of
the Blend result (not the color of the object to be blended, but the resulting Blend color) and 40% of
the original Base color.

Opacity & Mask Define Knockout Shape

189



8 ArtPro+

The Opacity & Mask define knockout shape option only affects the combination of objects with an
Opacity mask, inside a group with the Knockout Group option. The result will be that, instead of
knocking out completely, the object with the Opacity Mask will be knocked out based on the Opacity
Mask and the Opacity value.

Isolate Blending
When an object inside a group has a blend assigned to it, this will affect all objects underneath. If the
Isolate Blends option is on, blends assigned to objects inside a group, are only calculated to objects
within the same group and not to objects outside the group. The opacity however will also affect the
objects underneath.

Group Color Space
If the group is susceptible to color conversion, its Group Color Space will be shown here. See also
Objects, groups or pages susceptible to color conversion on page 98

Knockout Group

With the Knockout groups option on, objects inside the group will only interact with what’s behind
the group - not with other elements inside the same group. This means that all blending and opacity
calculation is done between the object (which is inside the group) and the group’s background (which
is outside the group).

Note:  A group without transparency (shown as "Group" in the breadcrumbs, and not as
"Transparency Group") will inherit the Knockout Group setting from the Transparency Group it
is part of.

Clear Transparency
Clicking the Clear Transparency button will set the Blend Mode to Normal, set the Opacity to 100%
and deselect all options. The Transparency Group will become a normal Group again, so the Knockout
Group option will again be inherited (see above).

Opacity Mask
If an Opacity Mask is selected, the Transparency Inspector will contain the Edit Opacity Mask button,
Release Opacity Mask button, a preview of the mask, the Clip option and Invert mask option will . See
Opacity Masks on page 168

8.5.4.  Recolor

Using Recolor you can remove Separations, replace Separations or Convert Separations to CMYK for
the selected objects. Objects outside the selection are not modified.

Note:  Removing or Replacing a separation will affect the channel mapping of Linked Placed
Art in your selection that uses the separation. See Channel Mapping for Linked Placed Art on
page 226

Remove Separation
1. Select the objects you want to modify
2. Select Object > Recolor...
3. In the Recolor dialog, select Remove Separations.
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4. Select the separation(s) you want to remove from the selection. Only separations used in the

selection are available.
5. Click Remove to remove the separation(s) from the selected objects and close the dialog.

The selected separation(s) will no longer be used in the selected objects. If a separation is no longer
used in the document, it will also be removed from the Separations list.

Note:  The Recolor function only changes separations within the selected objects. To remove
separations, replace separations or convert separations to CMYK for the complete document,
you can use the Separations section. See Separations on page 132

Replace Separation
1. Select the objects you want to modify
2. Select Object > Recolor...
3. In the Recolor dialog, select Replace Separations.

 

 
4. In the left column, select the source separation(s) you want to replace in the selection. Only

separations used in the selection are available.
5. In the right column, select the target separation. You can select any separation from the document,

except for the source separations.
6. Click Replace to replace the separation(s) in the selected objects and close the dialog.

The selected separation(s) will be merged with the target separation. If a separation is no longer used
in the document, it will also be removed from the Separations list
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Note:  The Recolor function only changes separations within the selected objects. To remove
separations, replace separations or convert separations to CMYK for the complete document,
you can use the Separations section. See Separations on page 132

Convert Separation to CMYK
1. Select the objects you want to modify
2. Select Object > Recolor...
3. In the Recolor dialog, select Convert Separations.
4. In the Conversion Method dropdown, select Convert to CMYK.

 

 
5. Select the separation you want to convert to CMYK in the selection. Only spot color separations

used in the selection are available.
6. Select the CMYK values you want to use:

• the CMYK values that are saved in the PDF file
• the CMYK values using the Esko Color Management (not available for custom inks)
• Custom values you can enter yourself.

7. Click Convert and Keep Dialog Open to convert the separation in the selected objects and keep the
dialog open for another Recolor operation, or click Convert to apply the operation and close the
dialog.

The selected separation will be converted to CMYK in the selected objects. If a separation is no longer
used in the document, it will also be removed from the Separations list

Note:  The Recolor function only changes separations within the selected objects. To remove
separations, replace separations or convert separations to CMYK for the complete document,
you can use the Separations section. See Separations on page 132
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Convert Separation with Equinox
When you're connected to the CMS from your Automation Engine (see Color Management Preferences
on page 53) that contains Equinox strategies, you can use Convert with Equinox:

1. Select the objects you want to modify
2. Select Object > Recolor...
3. In the Recolor dialog, select Convert Separations.
4. In the Conversion Method dropdown, select Convert With Equinox.

 

 
5. Select the separation you want to convert using Equinox in the selection. Only spot color

separations used in the selection are available.
6. If needed, enable Flatten objects before conversion
7. Select the color strategy you want to use

The available Color Strategies depend on your Color Engine settings in the Preferences. See
Preferences on page 49

8. If needed, you can change the values offered by the Color Engine.

The icon on the right hand of the dialog shows the current status:

•
 The Defined Values: the values as defined by the Color Engine's Color Strategy

•
 Custom Values as entered manually.

•
 Do not Convert

You can change the status by clicking the icon and choose the status, e.g. to switch back to Defined
Values after entering custom values.

9. Click Convert to convert the selected separations in the selected objects and close the dialog.

• The Δ E value readout is provided by the Color Strategy
• Separations that remain unchanged after convertion are grayed out in the destination

Separations list
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• After converting, the OGB separations used in the conversion will be added to the Separations
list. Separations that are no longer used will be removed.

Note:  Convert With Equinox is only available for PDF+ files. See PDF, PDF+ and Normalized
PDF on page 57

Note:  The Recolor function only changes separations within the selected objects. To remove
separations, replace separations or convert separations to CMYK for the complete document,
you can use the Separations section. See Separations on page 132

Convert Separation with GMG OpenColor
If you are connected to a GMG OpenColor server, and your document has a GMG OpenColor Project as
Document Profile, you can use Convert with GMG OpenColor Project. See GMG OpenColor on page 99

1. Select the objects you want to modify
2. Select Object > Recolor...
3. In the Recolor dialog, select Convert Separations.
4. In the Conversion Method dropdown, select Convert With GMG OpenColor Project.

 

 
5. If needed, enable Flatten objects before conversion

When flattening is disabled, the color of each object will be converted independent of the
transparency effects with other objects.

When flattening is enabled, all the objects will be flattened prior to the conversion with GMG
OpenColor Project. The flattening will result in non-overlapping objects with all the transparency
effects resolved. The color conversion will happen on these non-overlapping objects.

6. Select the Source and Destination profile.
7. The dialog shows all separations used in the selection, along with their conversion values and ΔE.
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You can adjust the Color Conversion Recipes: if you hover over a value for a destination separation,
you can change the value:

• Click the white square to set the value to zero.
• Click the black square to set the value to 100%
• Click the cog wheel to set the value back to the best match calculated by GMG OpenColor
• Click a Destination Separation name in the header row to exclude it from the output. All values in

that column will become 0%. Click it again to switch back to the best match calculated by GMG
OpenColor.

Note:  Modified values are shown in italic. Changing a value or excluding a separation will
recalculate the other values in the same row, except for the values you manually modified
earlier.

Any separation unknown to the GMG OpenColor Project will not be converted and is greyed out.

It can be that there are multiple ink variants for the same separation available on the server. In that
case, you can use the “up down” arrows in the ΔE column to show the other available variations and
their ΔE difference.

8. Click Convert to convert the selected separations in the selected objects and close the dialog.

After conversion with the GMG OpenColor server, the Document Profile of the job will change to the
Destination profile that was used for the conversion, so the same profile will be used for viewing.

Important:

GMG OpenColor projects can be published for proof and/or for separations. When published for
proof they can be used for viewing (soft-proofing) and when published for separations they can
be used as destination project of a color conversion.

As the same project is used as destination of a color conversion and for viewing, ArtPro+
only offers GMG Projects that are published for both proof and separations in the Destination
dropdown.

Note:  The Recolor function only changes separations within the selected objects. To remove
separations, replace separations or convert separations to CMYK for the complete document,
you can use the Separations section. See Separations on page 132

8.6.  Effects Inspector

Using the Effects Inspector, you can add an effect, either an Inner Gradient, an Outer Gradient or both
to the selected objects.

1. Select the objects you want to add an effect to.
2. Open the Effects Inspector
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3. Enable Inner Gradient to add the effect on the inside of the selected paths, or Outer Gradient to add

the effect on the outside.
4. Define the Offset: the distance for the gradient, starting from the path, either inside or outside
5. Define the color stops and mid points. This is similar to defining a gradient. See Gradient on page

185

Tip:  If you have a lot of color stops, and you want to inspect their values, you can click one
of them in the Inspector, and use the Arrow keys on your keyboard to navigate through
them. You can do the same for the mid points.

Tip:  You can click and drag a color stop while holding the Alt key to duplicate it.

The Effect is placed on the inside (Inner Gradient) or outside (Outer Gradient) of the selected paths. The
rest of the object is colored using the defined fill.

The example underneath shows a yellow shape, with an Inner Gradient (top) and with an Outer Gradient
(bottom).
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8.6.1.  Multistep Gradations from ArtPro

ArtPro files can contain "Multistep Gradations". When exported to Normalized PDF (and thus also when
opened as Normalized PDF in ArtPro+) most of these Multistep Gradations were converted to an image,
to keep their visual appearance intact, but making it impossible to still edit them.

When opening an ArtPro file in ArtPro+, ArtPro+ will detect Multistep Gradations that can be converted
to Effects in order to make them editable again. Keep in mind that your file needs to be converted to
PDF+ before saving.

1. Open the ArtPro file in ArtPro+.

A message "Effect Editability At Risk" is shown in the Messages drawer. Although this message
allows you to select the affected objects, you can't edit the Effect yet.
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Note:  Be aware that the object containing the Effect after conversion to PDF+ may not
match the original object as seen in ArtPro classic. However, the results of editing the
Effect will be as expected.

2. Convert the document to PDF+

For more information, see Convert to PDF+ on page 59

Note:  It is important to convert before saving the document. If you would save your
document before converting, it will be saved as Normalized PDF and the Effect editability is
lost.

When possible, the Multistep Gradations are turned into an Effect: an Outer Gradient effect if the
positions in ArtPro were positive values, an Inner Gradient effect if they were negative values, or a
combination of both if the positions had both positive and negative values.

You can now edit the Effects using the Effects Inspector. See Effects Inspector on page 195
3. Save your document as PDF+ file.

Currently supported are the linear multisteps that were imported from PDF and the irregular multisteps
(based on a shape), as long as they were not transformed disproportionally. Unsupported Multistep
Gradations are converted to images.

Linear multisteps that were created directly in ArtPro, or radial multisteps, can sometimes be
represented by gradient fills, but if not, they will be converted to images.

8.7.  Creating objects

8.7.1.  Create Rectangle / Create Ellipse

Using the Create Rectangle or Create Ellipse tool you can create rectangles, squares, ellipses and
circles.

1. Select the Create Rectangle or Create Ellipse tool

• By selecting the tool from the Tool Switcher. See Changing tools on page 43
• By using the shortcut S.

Note:  If another tool is active, the shortcut S will select the Create Rectangle tool. If the
Create Rectangle or Create Ellipse tool is active, using the shortcut will switch between
Create Rectangle and Create Ellipse.

2. Click and drag to create a rectangle or ellipse manually

• By default, a rectangle or ellipse is created from the corner point. In other words, the point you
start dragging will be one of the corners of the rectangle or bounding box of the ellipse. Hold the
ALT key to create the shape from the center point

• Hold the Shift key to create a constrained shape, i.e. a square or a circle.
• Hold both the ALT and the Shift key to create a constrained shape from the center point.

3. Click to create a rectangle or ellipse numerically
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The Create Rectangle or Create Ellipse dialog will appear

 

 

•
When one or more objects were selected when you clicked, the Select Same Size button 

and Select Same Center button will be enabled. This means the newly created rectangle
or ellipse will have the same size and position as the bounding box of the selection. If there were
no objects selected when clicking, the options will be disabled by default.

• You can enter the horizontal size and vertical size. The arrow on top of the dialog, positioned
at the point you clicked, indicates the starting point of the rectangle or ellipse. You can use
negative values to create the shape in the opposite direction. Changing the dimensions will
automatically disable the Select Same Size and Select Same Center buttons.

• If you enable Select Same Center, the new shape will use the entered dimensions, centered on
the center of the selection.

• For rectangles, you can enter a Corner Radius. This will result in rounded corners.
• Click Create Rectangle or Create Ellipse to create the new shape. If you want to close the dialog

without creating a new shape, click Cancel, use the Esc key or simply click outside of the dialog
in your document.

The shape you create will follow the angle of the Crosshair. See The Crosshair on page 95

The created object will take the fill and stroke of the active selection at the time of creation. If nothing
is selected, the new shape will have a 100% fill of the darkest color, and no stroke.

The new object will be screened using the default screen set, when available.

The corner radius of a rectangle with rounded corners can't be changed after creation.

Note:  Enabling the Select Same Size button will always enable Select Same Center as well.

8.7.2.  Shaper

Using the Shaper tool you can make combinations of existing objects

1. Select one or more objects
2. Choose Object > Shaper, click the Shaper button or use its shortcut Cmd+E (Mac) or Ctrl+E

(Windows) to open the Shaper window.
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3. If you want to create new objects based on the Shaper operation, select Work on a copy in active
layer. If you want to modify the selected objects, leave the option disabled.

4. Click the button or apply the shortcut of the operation you want to perform:

• Unite combines your selected objects into a single shape. Shortcut 1.
• Intersect keeps the areas where objects are stacked on top of each other. Shortcut 2.
• Exclude keeps the areas where an odd number of objects are stacked on top of each other.

Shortcut 3.
• Minus Front keeps the areas of the bottom shape which are not overlapping with the overlying

shapes. Shortcut 4.
• Minus Back keeps the areas of the top shape which are not overlapping with the underlying

shapes. Shortcut 5.
• Divide creates a group of individual areas filled with 100% of the darkest document separation.

This can be used to prepare your White Underprint shapes. Shortcut 6. This function does not
include open paths or objects without fill and stroke paint.

8.8.  Working with Text

ArtPro+ contains basic text editing functionality.

You can select a text box or text inside a text box and edit its properties in the Text Inspector, as well
as creating and editing text boxes.

• You can use the Text Inspector to change text properties such as font family, size, etc. See Text
Inspector on page 200

• You can use the Text Box Transformation Inspector to set the position and orientation of the Text
Box. See Text Box Transformation Inspector on page 202

• You can use the Text Tool to create, edit and select text and text boxes. See Using the Text Tool on
page 202

• While editing text, you can use the Glyph Inspector to select specific glyphs. See Glyph Inspector on
page 204

• You can replace text by its outlines using Contourize Text on page 206
• You can fix reflow issues using Fix Text Box Reflow on page 182

8.8.1.  Text Inspector

Using the Text Inspector, you can check and change the parameters for the currently selected text.

1. Select the text you want to check or change

• Select text boxes using the regular selection tools
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• Use the Text Tool and select a portion of the text.
2. Open the Text Inspector

 

 
3. Select the Font Family and Font Style.

The Font Family dropdown will show all fonts used in the current document on top, and all available
system fonts underneath.

4. Define the Font Size, Leading, Kerning, Tracking and Level.
For Font Size, Leading and Level, you can enter a number to use the default Font unit, or add the
unit and it will be converted to the default unit. See Preferences on page 49

5. Set the Horizontal Scaling. A negative value will flip the text.
If you scale text using the transform tools, the Font Size and Horizontal Scaling values will be
adjusted accordingly.

6. Set the Writing Direction: Left-to-Right or Right-to-Left
7. Set the Alignment: Left, Central, Right, Justify Left, Justify Center, Justify Right or Justify all lines.
8. Set the Indentations: Left, Right, First Line Indent and First Line Gap (distance above the

paragraph).
9. Define the Word and Letter Spacing
10. Set the First Baseline position: either "Leading" (the height of the text including the white space) or

"Ascent" (the height of the ascenders in the text)
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11. Define the Vertical alignment for the text in the text box: Top, Center, Bottom or Justified. This is

only available for rectangular text boxes.

Note:  Changing the vertical alignment is applied on all the text in the text box, even if only a
part of it was selected.

8.8.2.  Text Box Transformation Inspector

The Transformation Inspector shows information on the size and position of the selected text box. You
can also use it to do basic transformations on the text box.

For more elaborate transformations, you can use the numeric transform function. See Numeric
Transform on page 162.

 

 

1. The reference point on the bounding box of the text box used to determine the position (see below)
and when changing the size while the Crosshair is hidden.

2. The position, horizontal and vertical, of the center of the Crosshair to the selected reference point.
If the Crosshair is not visible, the top left corner of the Media Box is used instead. You can move the
text box by entering a different distance.

3. The size of the text box. You can change the size by entering a different size. If the two values
are linked, changing one value will also change the other. The center of the Crosshair is used as
reference point. If the Crosshair is hidden, the reference point is used instead.

8.8.3.  Using the Text Tool

Using the Text Tool you can create or edit a text box, and edit text in a text box.

1. Select the Text Tool from the Tool Selector or by its shortcut T.
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Note:  If the Text Tool is active, all text boxes are highlighted, so you can see where live text
is located.

2. Click and drag to create a new text box, or click inside a text box to start editing it.

Note:  If you create a new text box, it will use the system default font (Helvetica on Mac, Arial
on Windows) in 100% of the darkest ink in the document. However, if you have a text box
selected when creating a new text box, the properties and fill of that text box will be used in
the new text box.

3. Edit the text inside the text box (see Editing text on page 203) or click and drag one of the handles
of the text box to change the text box.

4. Select another tool or use the esc key to exit the text editing mode.

Note:  If there are any problems displaying, editing, embedding or saving the font
information, a warning will be shown.

Editing text
When you are in text edit mode, you can change the content of the active text box

1. You can select text by click and dragging, or by one of the specific text selection functions. See
Selecting text inside a text box on page 203

2. You can select text and remove it using the backspace or delete key
3. You can type to add text.
4. You can Cut, Copy and Paste text, even across multiple documents and multiple editors
5. You can use the Text Inspector to change the properties of the selected text. See Text Inspector on

page 200
6. If you select a single character or ligature, and the current font uses rich OpenType definition

and contains an Alternate Glyph for the selected character, you can select an alternate from the
popover.
 

 

Note:  If you copy and paste text, the original (default) glyphs will be pasted.

Selecting text inside a text box
While in text edit mode, there are different ways to select parts of the text box.

• Click and drag to select a specific portion
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• Drag while holding the ALT key to select full words when dragging horizontally, or full paragraphs
when dragging vertically

• Use Shift + Left or Right arrow to select a single character
• Use Shift + ALT + Left or Right arrow to select a full word at a time
• Use Shift + ALT + Up or Down arrow to select a full paragraph at a time.
• Use Cmd + A (Mac) or Ctrl + A (Windows) to select all text in the text box.
• Use Cmd +Shift + A (Mac) or Ctrl + Shift + A (Windows) to deselect all text in the text box.
• Double-click to select a full word, triple-click to select the full paragraph, or quadruple-click to

select all text in the text box.

Merging text boxes
You can merge different text boxes into one single text box.

1. Use one of the selection tools to select the text boxes you want to merge
2. Choose Object > Text Box > Merge

When possible (i.e. the text boxes are close enough, yet not overlapping), the selected text boxes will be
replaced by one single text box. If no merging is possible, a warning will be shown.

When trying to merge more than 2 text boxes, all text boxes that can be merged (see above) will be, and
other text boxes remain unchanged.

Splitting a text box
You can use the Split function to split a text box

1. Use the Text tool to activate the text box you want to split.
2. Place the cursor in the text where you want to split the text box, or select the text you want to put in

a separate text box
3. Choose Object > Text Box > Split

The text box will then be split in two or (if you selected text in the middle of the text box) three separate
text boxes, each keeping the text properties and visual appearance of the original.

Note:  In some cases, ArtPro+ can suggest automatic splitting of erratic text boxes. See Fix
Text Box Reflow on page 182

Glyph Inspector
While editing text, you can use the Glyph Inspector to select and insert specific glyphs from a font.
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1. Select the Font Family and Font Style.

By default, the Font Family and Font Style from the Text Inspector is used.
2. In the Show dropdown you can define if you want to see all glyphs for the current font (Entire Font)

or only a subset, e.g. only the punctuation. Selecting Alternates for current selection will show
alternative glyphs for the character selected in the text box.

3. You can search a glyph by name, unicode or ID.
4. The grid will show the currently selected glyph.

• You can double-click a glyph to insert it in the current text box at the cursor position
• You can click a glyph to see its unicode value next to the search field
• You can hover over a glyph to see more info such as its glyph ID and its name

5. Using the slider you can change the size of the glyphs preview

8.8.4.  Extensis Universal Type Client

If you are using Extensis Universal Type Server and Client, and you have acquired an ArtPro+ Font
Connector license from Extensis, you can now use this with ArtPro+.
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If you open a file with an embedded subset of fonts not in your system but present on the Universal
Type Server, the Extensis Universal Type Client will activate these fonts so they can be used as a
system font in ArtPro+.

1. Open the Preferences and choose the Extensis tab. See Preferences on page 49

 

 
2. Select Enable Font Connector for Extensis Universal Type Client.

If you don't have the Universal Type Client installed, if you don't have a valid license, if its version is
lower than 6.1.7, or if you are not logged on, you will get a warning and the connection will not work.

3. If you enable Activate entire font family, not only the font variety used in the file you open will be
activated, but all fonts of the font family.

4. If the Deactivate fonts on application close option is enabled, fonts that were activated by ArtPro+
will be deactivated when you close the application. Otherwise, these fonts remain activated.

8.8.5.  Contourize Text

Using this function, you can replace editable text by a group of paths and compound paths, without
causing any visual difference.

1. Select the text you want to edit
2. Select Object > Text > Contourize Text

Contourize Text can also be applied from the Object > Path and Object > Clean menu, and from the
Clean dialog. See Clean on page 179

Note:  Contourize Text doesn't work on Dynamic Marks or Protected Objects.

8.8.6.  Convert Outlines to Text

Convert Outlines to Text is a function to convert vectorized (contourized) text back into live editable
text. This can be used e.g. to do last-minute text corrections on packaging artwork.

1. Select the outlined text that you want to convert
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Note:

• All outlines in the selection will be converted into one single text box. For this reason, it
is advised to make the selection not too big: text items not too far apart, not too many
different indentations etc. On the other hand, since the font recognition is only based on
the outlines in the selection, it is advised to not make the selection too small either.

• All text will be converted in a single style.
• Characters will use the space of their original outlines. In some cases, e.g. if the original

outline was in different styles or fonts, the character width may seem stretched or
squeezed. This can be corrected by changing kerning, tracking or horizontal scaling
during or even after accepting the conversion.

2. Choose Object > Text > Convert Outlines to Text or use its shortcut Cmd+Alt+Shift+T (Mac) or Ctrl
+Alt+Shift+T (Windows)

Convert Outlines to Text can also be applied from the Object > Path menu.

 

 
a) Set the Language

You can use a Language from the "Available" list immediately. If you select a language from the
"Ready To Download" list, the language will be downloaded and installed first. The Language will
then move to the "Available" list. You need an internet connection to do this.

Selecting the language will help the text recognition, especially when language specific
accented letters are used. So if the outlined text contains a mix of different languages, it is
advised to select the language with the most accented letters.

b) Set the Rotation of the outlines you want to convert, either by entering a value in the input field,
or by selecting one of the four buttons. The more accurate the angle is, the more accurate the
conversion will be.

c) Click Convert

ArtPro+ will compare the outlines to your locally installed fonts, and will use the top matching font.
3. Once the conversion is done, the object will be shown as a Converted Text Box, and you have

different options.
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a) Click and hold Hold to View Original to hide the converted text and see the original outlined
text. You can toggle between the outlines and the converted text as long as you don't Accept or
Revert.
You can also use the Quality Control Compare function: as long as the converted text hasn't
been accepted or rejected, you will see a Original Text Outline option. See Compare on page 110.

b) If the font doesn't seem like a good enough match to you, you can select a different font in the
Text Inspector. The font list will show the best matching fonts on top of the list.

If a Font Folder is defined in the Preferences, the list of fonts will also show the best matching
non-activated fonts.

 

 

Clicking any of these fonts will show the font file in the Finder (Mac) or Explorer (Windows), so
that you can install the font. If you then re-run the Convert Outlines to Text, the font will be part
of the "Best Matching Fonts" list. See also General Preferences on page 50

c) If necessary, you can do small corrections to the converted text, e.g. replace a character. It is
recommended to resolve this type of issues before accepting the conversion.

d) When you're happy with the result, you can click the Accept button. This will remove the original
outline from the document, leaving you with a regular text object that you can edit as needed.
You can also use the Accept Converted Text in the Text inspector

e) If you want to revert the converted text box to the original outlined text, you can click Revert.
You can also use the Revert Converted Text to Original Outlines button in the Text inspector.
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Important:

It is highly recommended to Accept (or Revert) the text conversion before closing the file. Not
only to ensure smooth processing of the file further down the workflow, also in order not to
lose its editing capabilities. When attempting to alter text in a Converted Text Box after saving,
closing and reopening of the document, you will be prompted to restart the conversion.

This means that your outlined text will be converted again according to the same rotation angle
as before, but you will need to reconfirm the language and any font or text changes you made
before will be lost.

To indicate that there are unaccepted Converted Text Boxes in your document, a "Converted
Text Box" message will be shown in the Messages drawer. This will only disappear once all
Converted Text Boxes have been either accepted or reverted.

8.8.7.  Create Text in Path

Using Text in Path, you can create a non-rectangular text area.

1. Select a single path object you want to use. Optionally, you can include one or more text boxes to
the selection.

2. Choose Object > Text > Create Text In Path

• The path object is converted to a text box object.
• The content of the selected text objects is moved inside the path, maintaining its parameters.
• Any overrun text (text that doesn't fit the text box object) is shown underneath the object.
• If you didn't select a text box along with the object when applying Create Text In Path, an empty

text box is created, and you can immediately start typing in the text box.

You can use the path editing tools or transform tools to modify the shape of the text box, and text will
automatically reflow within the text box. See Create & Edit Path on page 170 and Transforming objects
on page 158

8.8.8.  Create Text on Path

Using Text on Path, you can create text running along a path.
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1. Select a single path object you want to use. Optionally, you can include one or more text boxes to
the selection.

2. Choose Object > Text > Create Text On Path

• The path object is converted to a text on path object.
• The content of the selected text objects is placed on the path, maintaining its parameters.
• Any overrun text (text that doesn't fit the text on path object) is added in a straight line at the end

of the path.
• If you didn't select a text box along with the object when applying Create Text On Path, an empty

text on path object is created. You can select it using the Text tool and start typing on the path.

• The text starts at the starting point of the path and follows its (internal) direction. You chan
change the starting point by cutting the path. See Cut Path on page 172

• If you want to change the direction of the text on the path, you can enable Flip text direction in
the Text Inspector.
 

 

You can use the path editing tools or transform tools to modify the shape of the path, and text will
automatically be adjusted. See Create & Edit Path on page 170 and Transforming objects on page 158

8.9.  Working with images

8.9.1.  Place

You can place an image in your current document

• By selecting File > Place.

• By its shortcut Cmd+Shift+P (Mac) or Ctrl+Shift+P (Windows).

Note:  Using the same Place function, you can place Images, PDF files and Structural Design
Files. See Place on page 219 and Place Structural Design on page 228

You can place images as linked images by enabling the Link Images option in the Place dialog. If the
option is disabled, the image will be embedded. See Linked and Embedded images on page 211
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ArtPro+ can place TIFF files, PSD files, JPG / JPeg and Barco .ct files.

• CMYK and DeviceN images are fully supported.
• RGB and LAB images have some limitations: Channel mapping is not possible, and linked RGB or

LAB images in a Normalized PDF will be saved as embedded, high resolution CMYK images. You will
be informed if this conversion takes place.

• If you place an image that contains inks not in the current document, these ink(s) will be added to
your document. When doing so in a Normalized PDF, saving the file will warn you that the default
screening will be applied to unscreened objects.

You can also place Barco .LP files. These always use the Black separation.

Important:  When saving a PSD file in Adobe Photoshop, make sure to enable the "Maximize
compatibility" option. Files saved without this option might not open correctly. The option can
be found when saving, or in Preferences > File Handling > File Compatibility > Maximize PSD
and PSB File Compatibility

8.9.2.  Place Image Inside

To place an image inside the selected path or paths, you can choose File > Place Image Inside... or use
its shortcut Cmd-Alt-Shift-P (Mac) or Ctrl+Alt+Shift+P (Windows).

The file is placed, and the selected path is used as clip path for the placed image. 
If your selection contains multiple paths, a compound of the selected paths is used.

The placed image is placed at 100% scaling and is positioned at the center of the bounding box of the
selection. For more information about placing, see Place on page 210

You can use Place Image Inside if your selection contains

• 1 or multiple Paths (including contourized text),
• 1 or multiple Compound Paths,
• a mix of both
• 1 single Clipping Path.

For other selections, the Place Images Inside function will not be available.

8.9.3.  Linked and Embedded images

Images can be linked (i.e. the reference to the external file is saved in the file), embedded (the actual
image information is saved in the file) or both.

When saving Normalized PDF, embedded images are saved as embedded images, and linked images
are saved as linked images.

When saving a PDF+ (see PDF, PDF+ and Normalized PDF on page 57) file containing linked images, a
full resolution embedded version of the image will also be saved in the file, so when opening a PDF+
file that contains linked images that can't be found, you can choose to browse for them, continue to
open the file while ignoring the broken link for now, or unlink the images and keep using the embedded
version.
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• When placing an image, you can enable Link Images to place the image linked, or you can deselect
it to embed the image. See Place on page 210

• You can extract an embedded image and make it linked using the Extract and Link function. See
Extract and Link on page 212

• You can unlink a linked image using the Unlink function. For Normalized PDF files, this means
removing the link and embedding the image. In case of PDF+, the image is already embedded, so
this will only remove the link. See Unlink / Embed and Unlink on page 212

When opening a file, and when navigating to a different page in a PDF+ file, ArtPro+ will check for
missing and/or out of date files. See Missing and out-of-date files on page 62

Extract and Link
Using Extract and Link you can extract the embedded image and replace it by a linked image. to the
location where you want to save the linked image. By default, ArtPro+ will suggest to save the file as a
TIFF, however PSD can be available as option too, depending on the contents of the image.

1. Select the embedded image you want to extract
2. Select Object > Image > Extract and Link or click the Extract and Link button in the Image

Inspector
3. Set the location and file name to save the image to disk. By default, the job name is used as file

name.

The image is saved to disk, and this image is then used as linked image.

If your selection contains multiple embedded images, all embedded images will be extracted and linked
when possible. The extracted images will be numbered. The default suggested file name wil be PDF
file name_[#].tif. As long as the placeholder [#] is used, files will not be overwritten during
extracting.

Unlink / Embed and Unlink
Unlink (for PDF+) and Embed and Unlink (for Normalized PDF) will remove the link to the image file on
disk and only keep an embedded version of the image in the document

1. Select the linked image you want to embed
2. Select Object > Image > Unlink or Embed and Unlink, or click the (Embed and) Unlink button in the

Image Inspector

Update images
Update will check if the image on disk has been changed, and if so, update the preview in the
document.

You can either choose Object > Image > Update, click the Update button in the Image Inspector, or
select Update in the fly-out menu of the Images Side Drawer.

If the image cannot be found at the moment the image is selected in the document, the Update button
in the Image Inspector will be replaced by a Browse button, allowing to relocate the missing image.

If the updated image contains less or more channels than the original, you will be informed about
it. If there are now less channels than in the original, the obsolete channels are removed from the
image channels list in the Channel Mapping inspector. If the updated image has extra image channels,
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they will appear in the image channels list in the Channel Mapping inspector, but won't be used in the
channel mapping automatically.

8.9.4.  Image Inspector

If the selection contains an image, the Image Inspector will be available.

 

 

The Image Inspector will show all properties of the selected image

• the Color Space: Bitmap, Grayscales, CMYK, Multichannel, RGB or Lab, and the Color Profile used in
the image

• the Pixel Size
• the Resolution in ppi. If multiple images are selected, or when the image was scaled non-

proportionally, the minimum and maximum resolution are shown.
• The Scale. When the image was scaled non-proportionally, both the vertical and horizontal scale

factor is shown. Scale is only available for linked images. In case the scaling info is not available yet
(N/A), you can click the Update button to calculate the scale factors.

• Transparency: does the image contain a transparency (Alpha) channel, yes or no.
• File Name: the name of the linked image. If the name is underlined and blue, the name works as a

link to open the file location in Finder (Mac) or Windows Explorer (Windows) in physical shares, or in
the My Workspace web page in case of a location on an Automation Engine SaaS server. If the name
is underlined but gray, it means the link can (temporarily) not be found.

Note:  The resolution used is the output resolution, after the scaling of the image

You also have the following buttons:

• The Update or Browse button for linked images. See Update images on page 212
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• (Embed and) Unlink for linked images. See Unlink / Embed and Unlink on page 212

• Extract and Link for embedded images. See Extract and Link on page 212

• Replace to replace the image. See Replacing an image on page 216

• The Edit in Editor button. See Opening images in an external editor on page 215

8.9.5.  The Channel Mapping Inspector

If the selection contains one image (or multiple copies of the same image), the Channel Mapping
Inspector will be available. This can be used to remap an image channel to another ink, invert a channel
or change its Density. Mapping a channel onto a (different) separation means the data of that channel
will be used for output on the specified separation. In the example underneath, the data of the Black
channel of the image will be output in the brown Pantone separation

 

 

• For every separation, you can define what channel of the image you want to use. You can also define
the channel you want to use as Transparency channel. See Using a Transparency channel.
a) Click in the Image Channel column and select the channel you want to use from the dropdown.

All channels found in the image will be available in the dropdown.
b) Enter a percentage between 0% and 100% in the Density field to set the maximum Density for

the channel.

• Enter a followed by a value, to set all separations to that value.

• enter x to set the value to 100%, or enter ax to set all values to 100%

• Click the color patch to set the value for that separation to 100%. Clicking it again will switch
it between 0% and 100%.

c)
Click the Invert button  to invert the channel

•
Click the Registration Color button  to switch to registration color. The dialog will only show
one line, and the selected channel and density percentage will be used for all separations. The
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Registration Color button has changed to this: . Click this button to switch back to normal
color.

•
For separations that don't have a channel assigned, you can click the overprinting button  on top
of the column, or next to any of the unmapped separations, to switch all unmapped separations to

overprinting . Clicking one of the buttons again will switch them all back to knock-out.

For embedded images, the origin of the channels can't be kept, so when you save, close and reopen
a file with embedded images, the channel names will match the separation names again - even if
these channels were originally taken from another separation. E.g. if you map the Cyan channel onto
the Magenta separation, the name of the channel will remain Cyan while you are still working on the
file. Once you've saved, closed and reopened it, the channel for the Magenta separation will be called
Magenta (but contain the data from the original Cyan channel).

For images that are linked (both in Normalized PDF and PDF+), ArtPro+- remembers the origin of
the channels, so even after saving, closing and reopening, you will still see the original name of the
channel. So in the given example, the channel for the Magenta separation will still be called Cyan after
a save, close and reopen. This will allow to apply the same channel mapping when replacing the image.
See Replacing an image on page 216

Channel mapping is not possible for RGB or LAB images.

Using a Transparency Channel
In the Channel Mapping Inspector, you can set any image channel as Transparency channel.

1. Use the Density percentage field to reduce the opacity.
2.

Click the Invert button  to invert the channel. Inverting is done before applying the density.
3. By default, the transparency channel is only applied on the base color space, so typically on the

CMYK channels, and not on the spot color channels. You can however change this by opening the
channel selection dropdown and choosing (Do not) Apply transparency on this channel. The icon in

front of the channel will change indicating the transparency is applied  or not 

• This option is only available if a Transparency channel is set.
• This setting applies to wherever the channel is used. A channel mapped on multiple separations

can only have one setting
• If you change the setting so it doesn't conform to the Photoshop model (i.e. transparency applied

on a spot color, or transparency not applied on a process separation), Edit in Editor will not be
available.

8.9.6.  Opening images in an external editor

Images placed in ArtPro+ can be easily edited in an external editor, and the changes can immediately
be applied in ArtPro+.

1. If necessary, define the External Editors for Images in the Preferences. See Preferences on page
49. If it is already defined or if you want to use the default image editor, you can skip this step.

2. Select the image you want to open in the external editor, and do any of the following:

• Alt-double-click the image
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• Alt-double-click the "Image" breadcrumb.
• Select Object > Image > Edit in Editor
• In the Image Inspector, click Edit in Editor

For an embedded image, a temporary copy of the image will be opened in your external image
editor. For a linked image or if both are available (PDF+), the external file is opened.

Note:  Adobe Photoshop doesn't support transparency on spot channels. When opening
such an image using Open in Editor, you can choose to ignore the unsupported features,
and open the image in the editor as if the transparency does not apply on the spot channels.
This might result in wrong visualisation in the editor, but after saving the image and
returning to ArtPro+, the channel mapping will be restored, and the transparency will be
reapplied on the spot channels.

3. Apply the desired changes to the image, and save it.
4. Switch back to ArtPro+. A message will inform you that an image was edited, and you can see all

changes are applied on the image.

Note:

If the number of channel is changed and saved, the behavior will be the same as when updating
an image. See Update images on page 212

8.9.7.  Replacing an image

You can simply replace an image without having to place (and scale, position,...) the image again.

1. Select the image you want to replace, or multiple instances thereof.
2. Select Object > Image > Replace... and navigate to the correct image. You can only select supported

image file types. See Place on page 210
3. If you want the new picture to be linked, enable the Keep link to external file option. If you want the

new picture to be embedded, disable it.
4. If the image you replace is Linked, you can enable Keep current channel mapping and separations

• If the option is disabled, no channel mapping is applied. If the image contains separations not in
the document yet, those will be added (similar to when placing the image using Place).

• If the option is enabled, all channels are reused when possible. No new separations are added to
your document.

5. If the new image contains a clipping path, you will be asked if you want to import this clipping path
or not.

• If you choose to import, the old clipping path (if present) will be replaced by the clipping path
from the new image

• If you choose to not import, only the image will be replaced, and the existing clipping path (if
present) will be kept.

6. Click Open.
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The selected (copies of the) image willl be replaced. Position and dimension of the replaced image
are kept. If the new image has different proportions than the replaced image, it is scaled non-
proportionally to fit the dimensions.

8.9.8.  Images Side Drawer

You can open the Images Side Drawer by clicking the Images button in the upper toolbar. The Image
Side Drawer has 2 modes:

•
the Show Images on current page mode , that lists all images on the current page.

•
the Show Images in Opacity Masks mode , that lists all images used in Opacity Masks on the
current page. Note that this is only for inspection, and doesn't allow selection or editing.

Show Images on current page
For every image, you get a preview, the name of the image (or "Embedded Image x" for embedded
images), resolution, pixel size, dimensions and color space. In case multiple copies of the same image
are used, you can expand and collapse the list of all copies, each with their properties, by clicking the
triangle.

 

 

Using the buttons below the list, you can sort the images by name, by resolution or by color space.

You can select one or more images in the list, and the corresponding objects in the document will be
selected as well.

If the Zoom to Selection  option is enabled, clicking an entry displays the selected image(s) as big
as possible in the active window.

From the fly-out menu, you can apply actions on the selected images:

• Extract and Link: see Extract and Link on page 212

• Update: see Update images on page 212

• Unlink: see Unlink / Embed and Unlink on page 212

• Replace: see Replacing an image on page 216

• Edit in Editor: see Opening images in an external editor on page 215

Using Show/Hide Info of All Copies you can expand or collapse the information on the individual copies
of all images.
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You can hover over an image in the Images Side Drawer to see its Scaling in a tooltip.

8.9.9.  Trace Image

Using Trace Image you can create contours based on the selected images.

1. Select the image(s) you want to create contours of.
2. Choose Object > Image > Trace

A Traced Image object is created, by default filled with 100% of the darkest separation on the page.

You can use the Traced Image Inspector to modify the Traced Image Object.

 

 
3. Set the Trace Image options

a) You can change the Threshold. A higher threshold will include more parts of the image in the
contour.

b) You can decide if you want to trace your image based on the Luminosity or the Transparency.
The latter is only available if your image contains transparency.

Note:  The Trace Image options are not available when tracing a bitmap image.

4. Set the Smoothen Path options.
a) The Reduction Factor makes the paths smoother. Higher values filter out more sharp edges and

noise resulting in smoother curves. Reduction Factor 0 turns filtering off, only straightening is
done. The default value for bitmap images is 0, for other images it is 3.

b) The Straighten Threshold allows to reduce the noise on the paths by replacing them with
straighter parts, i.e. by removing anchor points. The Threshold specifies the maximum deviation
allowed between the original path and the straightened path. A larger value results in fewer
points and therefore speeds up all subsequent operations.

c) The Dust Threshold can be used to eliminate scanned dirt. A Dust Threshold of 0,07mm means
that all black or white areas on the original smaller than 0,07mm by 0,07mm will be filtered away.

Below you see an example of a Traced image
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1. With a low Reduction Factor and low Straighten Threshold
2. With a high Reduction Factor and low Straighten Threshold
3. With a low Reduction Factor and high Straighten Threshold
4. With a high Reduction Factor and high Straighten Threshold

 

 

You can change the values in the Traced Image Inspector on any Traced Image Object.

Saving and reopening your document, or using the path editing tools on a Traced Image Object will
convert the Traced Image Object into a regular path, and the Traced Image Inspector will no longer be
available.

Note:  Keep in mind that tracing an image replaces the image by a path. If you want to keep the
image, e.g. to use the Traced Image Object as a clipping mask on your image, you should copy
your image first.

8.10.  Working with Placed Art

8.10.1.  Place

You can place a PDF in your current document

• By selecting File > Place.

• By its shortcut Cmd+Shift+P (Mac) or Ctrl+Shift+P (Windows).

Important:  Placing a PDF is only supported in PDF+ files. You can not place a PDF if the current
document is a Normalized PDF file.
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Note:  Using the same Place function, you can place Images, PDF files and Structural Design
Files. See Place on page 210 and Place Structural Design on page 228

When placing a Normalized PDF, you can automatically map specific technical inks to specific
Processing Step Layers. See Placing Normalized PDF files in a PDF+ file on page 221

You can place PDF files as linked objects by enabling the Keep Link to File option in the Place dialog. If
the option is disabled, the PDF file will be embedded. See Linked versus Embedded Placed Art on page
221

If you select multiple files, they will be placed one by one, on top of each other.

• For every PDF file you place, you can decide what Page Box defined in the file should be used to clip
the placed PDF.

• When placing a multipage PDF, you can select what page to place, either by entering the page
number, or by selecting it using the arrows.

 

 

When placing a PDF, all separations used in the placed art but not yet in your document will be added
in the separations list. The separation order is not changed, so the separation order in the main
document can be different from the order in the placed file.

Note:  If you select Placed Art, the Fill and Stroke inspector will show a preview of the PDF file,
and the separations used in it.
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Placing Normalized PDF files in a PDF+ file
When placing a Normalized PDF in a PDF+ file, you have to take in account some specific behavior. For
more information on the PDF+ file format, see PDF, PDF+ and Normalized PDF on page 57

Always embedded
When placing a Normalized PDF in a PDF+ file, the placed PDF will always be embedded. Linking to a
placed Normalized PDF is not possible.

Note:  Any changes done to the placed file, such as mapping technical inks (see below) are
done to the embedded version only. The original Normalized PDF file is not modified.

Layers
All layers from the Normalized PDF file are kept, and can be seen when editing the placed PDF file.

Screen Sets
When placing a Normalized PDF file, the screen sets in this placed file will be merged with the screen
sets already present in the current document.

Technical Inks
Technical inks will always become Opaque inks.

Mapping Technical Inks to Processing Step Layers
Normalized PDF does not support Processing Step Layers, while PDF+ does not support technical
inks. Therefor, when placing a Normalized PDF file in a PDF+ file, you can map specific technical
inks to specific Processing Step Layers. You can manage rules in the Normalized PDF section in the
Preferences. See Preferences on page 49

If a rule is set, objects using only the defined ink will be moved to the specified Processing Step layer.
These objects will end up in a layer on top of the existing layers. This can change the order of the
objects. Also, moving objects to Processing Step layers can change the blend mode to "normal" and
overprint can be set, similar to when manually moving objects to a Processing Step layer.

8.10.2.  Linked versus Embedded Placed Art

If a Placed Art object is Embedded, this means the actual Placed Art information is saved in the file.

If a Placed Art object is Linked, this means the reference to the external file is saved in the file.

PDF+ files
A PDF+ file (see PDF, PDF+ and Normalized PDF on page 57), saved in ArtPro+, can contain

• only the embedded version of a Placed Art object.

• both the link and the embedded version.

This means that if you place a Placed Art object (see Place on page 219) using the Keep Link to file
option enabled, both the link AND the embedded version will be saved in the file. The same will happen
when you open and save a 3rd party PDF containing (only) links to Placed Art. See below.
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Note:  If you place a Normalized PDF in a PDF+ file, it will always be embedded.

Normalized PDF
If you open a Normalized PDF containing Placed Art created in another application, this will be
recognized as such. However, you will not have the same possibilities as in a PDF+ file (no Die Shape, no
Create Grid, no Place).

Other PDF files
Placed Art in PDF files from other sources can be

• only embedded

• both embedded and linked

• only linked

This last option is not possible in PDF+ files. This means that saving it (to PDF+) will add the embedded
version to the document. See above.

When opening a file, and when navigating to a different page in a PDF+ file, ArtPro+ will check for
missing and/or out of date files. See Missing and out-of-date files on page 62

Unlink
Unlink will remove the link to the file on disk and only keep an embedded version in the document

1. Select the linked placed art you want to embed
2. Select Object > Placed Art > Unlink, or click the Unlink button in the Placed Art Inspector

Update
Update will check if the file on disk has been changed, and if so, update the preview in the document.

You can either choose Object > Placed Art > Update, or click the Update button in the Placed Art
Inspector.

Separations used in the updated PDF but not yet in your document will be added in the separations list.

8.10.3.  Placed Art Separations Inspector

If the selection contains placed art, the Placed Art Separations Inspector will be available.
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The Placed Art Separations Inspector gives a preview of the Placed Art, and a list of the separations
used in it.

Note:  If Channel Mapping is applied on linked Placed Art objects, an indication will be shown.
See Channel Mapping for Linked Placed Art on page 226

8.10.4.  Placed Art Inspector

If the selection contains placed art, the Placed Art Inspector will be available.

 

 

The Placed Art Inspector will show all properties of the selected placed PDF

• the Clip On defines the die shape that is used on the PDF. Use the dropdown to select:

• a Page Box defined in the Placed Art
• The Processing Step Cutting layer, when available
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• Any of the separations in the Placed Art. In that case, the die shape is determined by the joint
shape of all applicable objects in that separation.

Note:  If you opened an MFG file, the Placed Art Inspector will show the name of the
Layout file (.mfg), the selected Structural Design file (.ard), the Print Item when defined
in ArtiosCAD, and the dimensions. See Step & Repeat based on an MFG or CF2 file on page
358

• the Size of the original file (before scaling). Changing the Clip On can also change the Size
• The Scale factor. In case the Placed Art was scaled non-proportionally, both the vertical and

horizontal scale factor are shown.
• If the selected object is susceptible to color conversion, its Color Space is shown. See Objects,

groups or pages susceptible to color conversion on page 98
• The Edit button. See Edit Placed Art on page 225
• The Replace button. See Replace Placed Art on page 225
• The Make Grid, to create a Step&Repeat of the selected placed art. See Step & Repeat on page 343

For Linked PDFs, you will also see:

• File Name: the name of the linked PDF file. If the name is underlined and blue, the name works
as a link to open the file location in Finder (Mac) or Windows Explorer (Windows). If the name is
underlined but gray, it means the link can (temporarily) not be found.

• The Page of the multipage PDF that was placed.
• The Update button. See Update on page 222
• The Unlink button. See Unlink on page 222

When selecting a Grid, the Placed Art inspector will also allow to change the initial Orientation of the
one-ups in this grid. Their orientation within the layout can be changed further by the option Head
Turn. See Grid Step & Repeat on page 343

When opening an ArtPro Step & Repeat file, although the one-ups are Embedded Placed Art, ArtPro+
will remember the link to the original ArtPro one-up file. This will be shown as "Legacy File Name" in the
Embedded Placed Art Inspector. See Opening ArtPro Step & Repeat Files on page 62

8.10.5.  Placed Art Layer Types Inspector

If the selection contains one or more Placed PDF files and/or a placed Structural Design file, the
Placed Art Layer Types Inspector will be available.

It will show all Processing Step Layer types that are used in any of the selected Placed Art objects.

 

 

By clicking the checkmarks you can change the printing state for all layers of the selected type.
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You can Alt-click a printing state field to turn its printing state on, while disabling printing for all other
layers. Alt-clicking it again will revert to the previous situation.

Note:  For Linked Placed Art, the Update function will revert the printing states to their original
values.

8.10.6.  Edit Placed Art

If you want to edit the content of a Placed Art object, you can do so in different ways.

• Embedded Placed Art object can be edited in a separate Editing mode.
a) Select the embedded Placed Art you want to edit
b) Select Object > Placed Art > Edit or hold the Alt key and double-click the Placed Art.

The Placed Art will be opened in a special Editing mode on top of your document window, where
you can edit the embedded Placed Art.

c) Click the Back to Document button to close the Editing mode, and return to your document
window.
The preview of the Placed Art is automatically updated.

• Linked Placed Art objects can be edited in ArtPro+ as any other PDF file
a) Locate the linked file in Finder (Mac) or Explorer (Window), e.g. by clicking the file name in the

Placed Art Inspector. See Placed Art Inspector on page 223
b) Open the file, either using the Open function, or by drag and dropping the file into ArtPro+.

The Placed Art will be opened in a regular ArtPro+ window. Unlike when editing an embedded
Placed Art, you can switch back and forth between this window and your document window.

c) When you're done editing, you can save and close the external PDF window.
Please note that the preview of the Placed Art is not automatically updated. Use Update on page
222.

• You can Expand the placed art, replacing the Placed Art by its actual contents, using Object >
Expand

After expanding, all the objects from the Placed Art will be placed in a group, which you can further
edit as regular objects.

8.10.7.  Replace Placed Art

Using the Replace button in the Placed Art Inspector, you can replace the selected Placed Art by
another PDF file.

1. Select the Placed Art you want to replace
2. In the Placed Art Inspector, click the Replace button
3. Select the PDF file you want to replace the selected Placed Art.
4. Click Replace

The newly placed file will use the same position as the original one, and the same setting (page box, …)
is used as die shape. The size of the new placed file is used.
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Replace will replace all copies of that Placed Art on every page of the document.

8.10.8.  Placed Art Side Drawer

The Placed Art Side Drawer shows a list of all placed PDFs used in the document. You can open it by
clicking the Placed Art button in the upper toolbar.

For every placed art, you get a preview, the name of the linked PDF or "Embedded Image x" for
embedded PDFs, the placed page of a multipage document, the dimensions and the used Page Box. In
case multiple copies of the same PDF are used, you can expand and collapse the list of all copies, each
with their properties, by clicking the triangle.

 

 

You can select one or more entries in the list, and the corresponding objects in the document will be
selected as well.

If the Zoom to Selection  option is enabled, clicking an entry displays the selected placed art as
big as possible in the active window.

You can hover over a Placed Art in the Placed Art Side Drawer to see its Scaling in a tooltip.

In the bottom right corner there is a fly-out menu containing all available actions for the selected
placed art:

• Edit. See Edit Placed Art on page 225

• Replace. See Replace Placed Art on page 225

• Update. See Update on page 222

• Unlink. See Unlink on page 222

8.10.9.  Channel Mapping for Linked Placed Art

When you apply separation related actions such as replacing, renaming or removing a separation,
these will result in Channel Mapping in the Linked Placed Art:

• Rename, Replace or Remove a separation in the Separation List. See Separations on page 132

• Remove or Replace a separation using the Recolor function, and the Placed Art is part of the
selection. See Recolor on page 190

When Channel Mapping is applied on the Linked Placed Art, the Placed Art Separations Inspector
will show the separations used for the Linked Placed Art after Channel Mapping, and will show an
indication that Channel Mapping is applied.
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If the external file is modified, the Update action (see Update on page 222) will update the Linked
Placed Art, but keep the remapping in place.

However, when replacing the Placed Art by another file that isn't used in the document yet, the
separation mapping will be reset and the original separations will be used.

Notes:

• The external files are not changed in any way. The mapping only applies to the Placed Art objects.
• If the document contains multiple copies of the same Linked Placed Art, the same remapping will

be applied to all copies.
• Convert to CMYK is not applied on linked Placed Art objects in the Separation List nor in the Recolor

function.
• Remapping in a Placed Linked Art can also be applied using a PDF Action List
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8.11.  Working with Structural Design files

Important:

When working with Structural Design files, the workflow can be very different based on the
type of Structural Design file:

• A Structural Design file of a one-up (a station) is to be placed (on top of your artwork), and
saved as part of your one-up file. See Place Structural Design on page 228

• A Structural Design file of a layout (a step & repeat) is to be opened, so that you can replace
the station placeholders by actual one-up files. See Step & Repeat based on an MFG or CF2
file on page 358

When working with ARD and MFG files, ArtPro+ can notice the difference (an ARD file is a one-
up, an MFG file is a Layout). However, when working with CF2 files, both one-up and layout files
have the same file extension and file type, so it is important you take the right action yourself:
a CF2 one-up file should be placed, a CF2 Layout file should be opened

8.11.1.  Place Structural Design

You can place a Structural Design file in your current document.

• By selecting File > Place.

• By its shortcut Cmd+Shift+P (Mac) or Ctrl+Shift+P (Windows).

Note:  Using the same Place function, you can place Images, PDF files and Structural Design
Files. See Place on page 210 and Place on page 219

Currently only ARD files and one-up CF2 files are supported. You can't place an MFG file or a Layout CF2
file, but you can open it. See Step & Repeat based on an MFG or CF2 file on page 358

A Structural Design file is always Linked. This means that if you place a Structural Design file, both the
link AND the embedded version will be saved in the file, even if the Keep Link to file option is disabled.

When opening a file, and when navigating to a different page in a PDF+ file, ArtPro+ will check for
missing and/or out of date files. See Missing and out-of-date files on page 62

When placing a Structural Design file, ArtPro+ uses a fixed color scheme for the different line types,
comparable to the color scheme used in other Esko applications such as ArtiosCAD or DeskPack. What
lines are shown, depends on the Profile, either the default profile defined in the Preferences or (in a
PDF+ file) the profile set in the Structural Design Inspector. See Structural Design Inspector on page
230

You can rotate and move a CF2 structural design, but you can't scale or shear it.
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PDF+
If the Structural Design is placed in a PDF+ file, every line type is put in a corresponding Processing
Step layer. You can see these layers (and change their printability) in the Layer Types Inspector if you
have the Structural Design selected. See Placed Art Layer Types Inspector on page 224

Normalized PDF
If the Structural Design is placed in a Normalized PDF, every line type is put in a corresponding
Technical ink.

Normalized PDF files can contain only one placed Structural Design file. If the file already contains a
placed Structural Design file, you won't be able to add another one in ArtPro+.

Line Types for CF2 files
The line types that are currently supported for CF2 files are:

• 1 (Cut)
• 2 (Crease)
• 3 (Perforation)
• 4 (Half-cut)
• 42 (Cut/crease)
• 43 (Annotation)
• 46 (Dimensions)

All text is treated as line type 46 (Dimensions) as well. All other line types are not imported.

8.11.2.  Structural Design File Inspector

If the selection contains placed Structural Designs, the Structural Design File Inspector will be
available.

 

 

• File Name: the name of the linked Structural Design file. If the name is underlined and blue, the
name works as a link to open the file location in Finder (Mac) or Windows Explorer (Windows). If
the name is underlined but gray, it means the link can (temporarily) not be found. In that case, the
Update button will be replaced by a Browse button.
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• The Update button. Update will check if the file on disk has been changed, and if so, update the
preview in the document.

• The Edit Panel Tags button. See Working with Panel Tags on page 363

• If the selected Structural Design file is an ARD or CFF2 file, you can use the Extract ... button. See
Extract ... on page 231

• If the selected Structural Design file is an ARD or CFF2 file, you can use the Export... button to open
the Export Structural Design dialog. See Export Structural Design on page 69

8.11.3.  Structural Design Inspector

If the selection contains at least one placed Structural Design, the Structural Design Inspector will be
available.

 

 

When defined in the file, you can select a Print Item. A Print Item is a collection of visible layers defined
in ArtiosCAD. Layers not in the Print Item will not be shown. If the Structural Design is a CF2 file, Print
Item will always be "none", since this doesn't exist in CF2.

You can also define what Print Side you want to use: Back or Front. This implies that, if e.g. an Inside
Bleed line type is defined in the ARD file, it will only appear when "Back" is selected. An Outside Bleed
line type will only appear when "Front" is selected.

By default the Structural Design file is shown using the default profile defined in the Preferences. See
Preferences on page 49

In PDF+ files, you can however overrule this setting and define the Profile to be used

• Cut and Creases: Only Cut and Crease lines are shown.

• Placeholders: Only Cut, Crease lines and placeholders are shown.

• Dimensions: Cut, Creases and Dimensions are shown.

• Full: all line types are shown.

• Full (Single Separation): All line types are shown, all using a single separation (either a Technical Ink
in Normalized PDF, or a Processing Step layer in PDF+ files). To make the different line types visible,
every line type will have a different type: full lines for cut lines, dotted for crease lines, etc.

For CF2, there are five line types that ArtPro+ supports: Cut, Crease, Partial Cut, Annotation and
Dimensions & Text. Other line types will be mapped to Annotation.

230



8ArtPro+

In Normalized PDF files, the default profile is always used.

8.11.4.  Extract ...

Using the Extract ... button you can extract the cutouts or the Varnish Free Areas from your structural
design file, and add them as regular paths in your document, in a separate "Cut" layer (for cutouts) or
"Coating" layer (for Varnish Free Areas) above the structural design layer.

1. In the Structural Design File Inspector, click the Extract ... button.
2. Define if you want to extract the Cutouts, the Varnish Free Areas or both.
3. Click Extract

Note:  Only cutouts that are fully inside a panel are extracted. Cutouts that span several panels
or touch the sides of the panels are not extracted.

Note:  ArtPro+ takes into consideration the inside and outside coating, as well as coating from
different print items. To extract outside coating, make sure the print side is set to Front, to
extract inside coating make sure the print side is set to Back.

Important:  This function does not change the structural design file. This means that after
extracting, the cutouts and varnish free areas are still present in the Structural Design file. It
can be handy to temporarily hide the structural design layer while editing the extracted paths,
so you don't see the original lines from the structural design file.

After extracting, you can use all ArtPro+ tools (e.g. path editing tools) to modify the paths.

Note:  All of the extracted structural lines (cutouts and varnish free areas) will be separate
individual paths. Use Join Paths to combine them into one shape.

After extracting and modifying cutouts and varnish free areas, you can use Export to Structural Design
to replace the cutouts and/or varnish free areas in the structural design file by the (modified) paths in
your document. See Export Structural Design on page 69
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9.  Prepress functions
Next to the normal editing functions, ArtPro+ contains a number of specific Prepress functionality,
such as Barcodes, Screening, etc.

9.1.  Barcodes

You can create a new barcode by using the Create Barcode function. See Create a barcode on page
233

Barcodes created in ArtPro+, or supported barcodes in an opened file can be edited by selecting it and
changing its settings in the Barcode Inspector. See Edit a barcode on page 233

Note:  You can use Expand to convert a barcode in a regular object. See Expand on page 178

Supported barcodes:

The barcodes listed in The Barcode types on page 234 are supported in the following cases:

• if they were created in ArtPro+
• if they were generated by PackEdge or DeskPack and saved in Normalized PDF files
• if they were generated in ArtPro and saved as ArtPro file (for compatible barcode types that are

supported both by ArtPro+ and ArtPro).

Currently not supported:

• Barcodes generated by other applications, in a regular PDF (not a Normalized PDF)
• Barcodes created in ArtPro and exported as PDF.
• Other types of barcodes

Regenerating barcodes

Barcodes created in other applications are kept unchanged after opening the file. However, if you
change one of the parameters, or scale the barcode, the barcode will be regenerated. In some cases
this will cause a change in the visual appearance of the barcode:

• Barcodes in ArtPro can have options that are not supported in ArtPro+, such as corner marks. A
warning will be shown when opening the file. These unsupported options can disappear when the
barcode is regenerated.

• Barcodes generated by ArtPro can also have a slightly different appearance than those generated
in other Esko applications like ArtPro+, DeskPack or PackEdge: the Light Margin Indicator has a
slightly different shape, small differences in text spacing for Code 39 codes, etc. The appearance
will be adjusted when the barcode is regenerated.

• Also for barcodes coming from other applications, there might be a change in the visual appearance
after regenerating, for example if the barcode was written incorrectly or inaccurately.
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Note:  Converting to PDF+ also triggers a barcode regeneration.

9.1.1.  Create a barcode

You can create a new barcode in different ways:

•

Click the Create Barcode button .
• Select Prepress > Add Barcode
• Use the shortcut Cmd+Shift+B (Mac) or Ctrl+Shift+B (Windows)

If the Crosshair is visible, the barcode will be created at the center of the Crosshair. If the Crosshair is
hidden, the barcode will be created on the center of the document pane.

By default, the barcode is an EAN-13 code, uses all zeros as code, and is colored in the darkest printing
separation. You can change its settings afterwards in the Barcode Inspector. See Edit a barcode on
page 233

Note:  When changing the Barcode Type, the value for all common parameters will be kept.

9.1.2.  Edit a barcode

If you select one or more barcodes (and no other objects), you can use the different barcode related
Inspectors.

If all selected barcodes have the same value (e.g. code, Magnification, ...), the Barcode Inspector will
show this value. Otherwise, it will show the ≠ symbol.

1. Click the color patch to change the color of the barcode, and use the Transparency inspector to
change the transparency settings. See Flat Color on page 184 and Transparency Inspector on page
189

Note:  Some specific barcodes (e.g. Laetus Pharma) can use Multicolor fill. See Multicolor
barcodes on page 296

2. Set the Code Type in the Barcode Type Inspector.

Depending on the selected barcode, an additional setting can be made, such as Supplemental
Digits or Code Set. Check The Barcode types on page 234

3. Set the Code for the selected barcodes in the Barcode Code Inspector.

When possible, ArtPro+ will automatically fix errors in the Barcode code. Possible fixes are
correcting a wrong check digit, adding a missing check digit, or adding a leading zero for e.g. a UPC-
E barcode. You will be warned whenever ArtPro+ adjusts the entered code.
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4. Click the button showing a few key settings (such as magnification) to open the Barcode Inspector.
The properties in this Inspector define the appearance of the bar code (height, bar with, ...). The
available options depend on the selected barcode. Check the properties for a specific barcode in
The Barcode types on page 234

5. Click the button showing the currently selected font to open the Barcode Font Inspector. The
properties in this Inspector define the text in barcodes. The available options depend on the
selected barcode. Check the properties for a specific barcode in The Barcode types on page 234

9.1.3.  The Barcode types

An overview of the parameters and properties per barcode type.

2 of 5

Info 2 of 5 is a numeric self-checking barcode, which can have a variable length. This
barcode only encodes data in the bars. It is used for industrial applications, article
numbering, photo development and ticketing.

Example

Input unlimited amount of digits

Check Digit None

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Narrow Bar Ratio

This parameter determines the ratio between the width of the widest bar and the width of the
narrowest bar of your barcode. It does not affect the width of your barcode proportionally.

Changing this parameter will adjust the Narrow Bar parameter.

Character Frequency

This parameter determines the amount of character per milimeter or per inch, depending on the
setting in the Preferences (and affects the width of your barcode proportionally).

Changing this parameter will adjust the Narrow Bar parameter. It is only available when using the
default font.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.
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Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

Aztec

Info The Aztec barcode is a 2-dimensional barcode used to encoded to store a specific
set of data.

The square bullseye pattern moves in pixelated layers from the center outwards.
The barcode is named after the resemblance of the central finder pattern (the
square bullseye) to an Aztec pyramid.
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Example

Input Unlimited

Check Digit None

Barcode Parameters

Symbol Size
The amount of Cells in a barcode. The Symbol Size will automatically increase when entering too much
data for the current symbol size.

Error Correction
Error correction adds check sums to the barcode to detect and correct incorrect data. The Error
Correction value defines the percentage of codewords that can be restored.

Note:  Keep in mind that a higher correction level makes the barcode bigger (as more check
sums are added to the barcode) and may limit the maximum length of the encoded data.

Cell Size
The size of a single black or white square.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.
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Bobst

Info The Bobst barcode is part of the same "binary" barcode family as the Laetus
Pharma Code, Kurandt and CLF-8. It is used in the pharmaceutical industry.

Example

Input Use the buttons above the code to define if your input is in the binary numeral

system  (digits '0' and '1') or in the decimal numeral system  (digits '0' to
'9'). '11011' in binary corresponds to '27' in decimal.

The input for a Bobst code can be maximum 32 digits for binary input (maximum
8589934590 in decimal input). However, an input of maximum 16 binary digits
(decimal input of 131072) is preferred.

Check Digit None

Important:  Although ArtPro also supports Bobst barcodes, the Bobst barcodes in ArtPro
files will not be recognized in ArtPro+ and will show up as (compound) paths, as for other
unsupported barcodes, to preserve the visual appearance of these barcodes.

Barcode Parameters

Note:  Bobst barcodes have fixed values for Narrow Bar, Narrow Bar Ratio, Wide Bar and Gap.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.
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Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
disabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

Multicolor
This barcode can be colorized using the Multicolor fill option. See Multicolor barcodes on page 296

 

 

CIP-39

Info CIP 39 (Club Inter-Pharmaceutique) is a barcode used by the French
pharmaceutical industry. It is based on Code 39, but not compatible with it : it
contains digits only and has a check digit
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Example

Input 7 or 13 digits.

Check Digit The last digit is the check digit.

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size
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By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

Code 39

Info Code 39 is a popular barcode in industrial barcoding systems, mainly in the U.S.A.
It is used in the non-retail industry, particularly in the manufacturing, military, and
health sectors. It can encode alphanumeric data.

Example

Input Maximum 128 characters (digits and capitals)

Check Digit The automatically added check digit is optional.

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Narrow Bar Ratio

This parameter determines the ratio between the width of the widest bar and the width of the
narrowest bar of your barcode. It does not affect the width of your barcode proportionally.

Changing this parameter will adjust the Narrow Bar parameter.

Character Frequency

This parameter determines the amount of character per milimeter or per inch, depending on the
setting in the Preferences (and affects the width of your barcode proportionally).

Changing this parameter will adjust the Narrow Bar parameter. It is only available when using the
default font.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

240



9ArtPro+

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.
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Code 93

Info Code 93 is a variable length, high density, alphanumeric barcode. It's an
enhancement of the Code 93 using spaces as well as bars as a data carrier. It
contains two check characters for higher data security. The Code 93 barcode
allows encoding the first 128 characters of the ASCII table.

Example

Input Maximum 128 characters

Check Digit none

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Character Frequency

This parameter determines the amount of character per milimeter or per inch, depending on the
setting in the Preferences (and affects the width of your barcode proportionally).

Changing this parameter will adjust the Narrow Bar parameter. It is only available when using the
default font.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.
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Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

Code 128

Info Code 128 is a variable length, high density, alphanumeric barcode. It has the
second highest density of all the 1D barcodes (after the GS1 Databar Expanded).

After selecting the barcode type, you can set the Code Set. By default this is set
to Automatic. In that case, the encoding type is chosen automatically, to optimize
the content encoding. To obtain an optimal utilization of the code-sets A and B
but prevent the usage of the space saving code-set C, set the Code Set to Long.
Select A or B to force the usage of the specific code-set A or B.

Example

Input Maximum 128 characters (digits and letters)

Check Digit none.

Barcode Parameters

Narrow Bar
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This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Character Frequency

This parameter determines the amount of character per milimeter or per inch, depending on the
setting in the Preferences (and affects the width of your barcode proportionally).

Changing this parameter will adjust the Narrow Bar parameter. It is only available when using the
default font.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Add light margin indicator

Use this option to add light margin indicators before ("<") and/or after (">") the barcode number

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text
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This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

Multicolor
This barcode can be colorized using the Multicolor fill option. See Multicolor barcodes on page 296

 

 

Data Matrix

Info Data Matrix is used for encoding large amounts of alphanumeric data and / or
marking small objects. It can encode all the standard ASCII and extended ASCII
characters.

The Data Matrix symbol size can adjust automatically depending on the amount of
data.

Note:  ArtPro+ always generates Data Matrix symbols with the
recommended ECC200 error correction scheme.
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Example

Input unlimited

Check Digit none

Barcode Parameters

Symbol Size
The amount of Cells in a barcode. The Symbol Size will automatically increase when entering too much
data for the current symbol size.

Cell Size
The size of a single black or white square.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

EAN-8

Info EAN-8 is an abbreviated version of EAN-13 (see EAN-13 on page 248), for use on
smaller packages.
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Example

Input The input for an EAN-8 code is 8 digits, with optionally 2 or 5 supplemental digits,
if set in the Code Type dialog.

Check Digit The 8th digit is a check digit.

Barcode Parameters

Magnification

Use this parameter to increase or decrease the width of the barcode. Changing the Magnification will
also change the Font Size and Vertical Offset.

By entering "0" in the input field, you can reset the Magnification to its default value (100%).

Attention:  Changing the Magnification does not change the Height of the barcode. You
can however reset the Height by entering "0". The Height will be proportionally scaled to the
current Magnification.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Add light margin indicator

Use this option to add light margin indicators before ("<") and/or after (">") the barcode number

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.
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By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Position supplemental digits above bars
If the barcode contains supplemental digits, those digits will be placed above the bars if this option is
enabled, or below the bars when it is disabled.

EAN-13

Info European Article Numbering system or EAN is the standard for article numbering
in Europe. It is also used in Japan where it is called JAN.

Note:  EAN is the European equivalent of the UPC system in the U.S.A.
and Canada. Both systems use the same size requirements and a similar
encoding scheme. This means that most European and American retail
barcode scanners can read both EAN and UPC barcodes. For more
information on UPC, see UPC-A on page 291.

Example

Input The input for an EAN 13-code is 13 digits, with optionally 2 or 5 supplemental
digits, if set in the Code Type dialog.

Check Digit The 13th digit is a check digit.
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Barcode Parameters

Magnification

Use this parameter to increase or decrease the width of the barcode. Changing the Magnification will
also change the Font Size and Vertical Offset.

By entering "0" in the input field, you can reset the Magnification to its default value (100%).

Attention:  Changing the Magnification does not change the Height of the barcode. You
can however reset the Height by entering "0". The Height will be proportionally scaled to the
current Magnification.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Add light margin indicator

Use this option to add light margin indicators before ("<") and/or after (">") the barcode number

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text
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This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Position supplemental digits above bars
If the barcode contains supplemental digits, those digits will be placed above the bars if this option is
enabled, or below the bars when it is disabled.

EAN-13 Swissmedic

Info EAN 13 Swissmedic is an EAN 13 barcode used for items licensed by the Swiss
Agency for Theraputic Products

It always starts with "7680", uses a specific text positioning and adds the text
"swissmedic" below the code.

For EAN 13 Swissmedic barcodes, only the default font settings can be used, so
there are no Barcode Text Parameters.

Example

Input The input for an EAN 13-code is 13 digits, starting with "7680"

Check Digit The 13th digit is a check digit.

Barcode Parameters
Magnification

Use this parameter to increase or decrease the width of the barcode. Changing the Magnification will
also change the Font Size and Vertical Offset.

By entering "0" in the input field, you can reset the Magnification to its default value (100%).

Attention:  Changing the Magnification does not change the Height of the barcode. You
can however reset the Height by entering "0". The Height will be proportionally scaled to the
current Magnification.

Height
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The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Eberle

Info Eberle is a barcode using two bar and two space thicknesses to encode the data.

Example

Input Use the buttons above the code to define if your input is in the quaternal numeral

system  (digits '0' to '3') or in the decimal numeral system  (digits '0' to '9').
'123' in quaternal corresponds to '27' in decimal.
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In the quarternal numerical system the barcode allows numbers up to 30 digits (0,
1, 2 or 3).

Check Digit None

Barcode Parameters
Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters
Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
disabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.
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Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

GS1 128

Info GS1 128 is based on Code 128 but has a double start sequence. See Code 128 on
page 243

Example

Input Maximum 128 characters (digits and letters)

GS1 barcodes consist of 1 or multiple codes that start with so-called Application
Identifiers (AI) - 2 digit codes that indicate a specific goal. For example: AI 11
indicates a production date, AI 17 an expiration date, AI 10 a batch or lot number,
etc. The Application Identifiers require specific input, for example AI 11 and
AI 17 are fixed and require 6 digits, AI 10 is variable and can contain up to 20
alphanumeric characters.

If multiple AIs are allowed, they can be entered in multiple ways:

• Just enter the codes one after the other, without any spaces. In this case you
should enter fixed size Application Identifiers (AI) first, and AI with a variable
length last to allow a correct validation of the barcode.

• Put the AI between brackets. In that case it is clear where one code ends and
another one begins, so variable AIs can be put at the start if so desired.

• At the end of an AI, type "[F1]" before entering the next AI
• For an even higher readability: use Shift-Enter to start a new AI at the next line

For an overview of all GS1 Application Identifiers, see GS1 Application Identifiers
on page 297

Composite
Component

A Composite Component is a 2D symbol placed on top of a GS1 barcode, that
encodes extra information (batch number, expiration date...).

If you want your barcode to have a Composite Component, enter the
(alphanumeric) data to encode in this field.

Check Digit depending on Application Identifier

Barcode Parameters

Narrow Bar
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This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Position text above barcode

This option places the text above the barcode instead of below.

Wrap text

This option allows to put the text on multiple lines, one line per AI.

Font Family, Font Style and Size
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By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

GS1 Databar Expanded - Expanded Stacked

Info GS1 DataBar Expanded (formerly RSS Expanded) encodes regular barcode data
(“primary item identification” data) and Application Identifiers. It can encode
alphanumeric characters.

This barcode can be scanned omnidirectionally by suitably programmed slot
scanners.

GS1 DataBar Expanded Stacked can encode the same amount of data as GS1
DataBar Expanded, but can also “stack” the barcode into several rows to save
space.

Example

Input GS1 barcodes consist of 1 or multiple codes that start with so-called Application
Identifiers (AI) - 2 digit codes that indicate a specific goal. For example: AI 11
indicates a production date, AI 17 an expiration date, AI 10 a batch or lot number,
etc. The Application Identifiers require specific input, for example AI 11 and
AI 17 are fixed and require 6 digits, AI 10 is variable and can contain up to 20
alphanumeric characters.

If multiple AIs are allowed, they can be entered in multiple ways:

• Just enter the codes one after the other, without any spaces. In this case you
should enter fixed size Application Identifiers (AI) first, and AI with a variable
length last to allow a correct validation of the barcode.

• Put the AI between brackets. In that case it is clear where one code ends and
another one begins, so variable AIs can be put at the start if so desired.

• At the end of an AI, type "[F1]" before entering the next AI
• For an even higher readability: use Shift-Enter to start a new AI at the next line

For an overview of all GS1 Application Identifiers, see GS1 Application Identifiers
on page 297
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Composite
Component

A Composite Component is a 2D symbol placed on top of a GS1 barcode, that
encodes extra information (batch number, expiration date...).

If you want your barcode to have a Composite Component, enter the
(alphanumeric) data to encode in this field.

Check Digit depending on Application Identifier

Barcode Parameters

Maximum Row Segments

Use this parameter to define how many segments of data (groups of bars encoding several digits) can
fit in one row. If the barcode contains more segments, they will be stacked.

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Position text above barcode

This option places the text above the barcode instead of below.
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Wrap text

This option allows to put the text on multiple lines, one line per AI.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

GS1 Databar Omnidirectional

Info GS1 DataBar Omnidirectional encodes Global Trade Item Numbers (GTIN) in a
linear symbol that can be scanned omnidirectionally by suitably programmed slot
scanners

Example

Input The GS1 Omnidirectional barcode only allows 1 identifier, of type 01. The input is 14
digits, which means that the Application Identifier itself has to be omitted.

Composite
Component

A Composite Component is a 2D symbol placed on top of a GS1 barcode, that
encodes extra information (batch number, expiration date...).

If you want your barcode to have a Composite Component, enter the
(alphanumeric) data to encode in this field.

Check Digit last digit

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.
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Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Position text above barcode

This option places the text above the barcode instead of below.

Wrap text

This option allows to put the text on multiple lines, one line per AI.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

GS1 Databar Stacked

Info GS1 DataBar Stacked is a variation of the GS1 DataBar barcode, that is stacked in
two rows and used when the normal barcode would be too wide for the product.
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Example

Input The GS1 Databar Stacked barcode only allows 1 identifier, of type 01. The input is
14 digits, which means that the Application Identifier itself has to be omitted.

Composite
Component

A Composite Component is a 2D symbol placed on top of a GS1 barcode, that
encodes extra information (batch number, expiration date...).

If you want your barcode to have a Composite Component, enter the
(alphanumeric) data to encode in this field.

Check Digit depending on Application Identifier

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Barcode Text Parameters

Add human readable text
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This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Position text above barcode

This option places the text above the barcode instead of below.

Wrap text

This option allows to put the text on multiple lines, one line per AI.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

GS1 Databar Stacked Omnidirectional

Info GS1 DataBar14 Stacked Omnidirectional is taller version of GS1 DataBar14
Stacked, that can be read by omnidirectional scanners.

Example

Input The GS1 DataBar Stacked Omnidirectional barcode only allows 1 identifier, of type
01. The input is 14 digits, which means that the Application Identifier itself has to
be omitted.

Composite
Component

A Composite Component is a 2D symbol placed on top of a GS1 barcode, that
encodes extra information (batch number, expiration date...).

If you want your barcode to have a Composite Component, enter the
(alphanumeric) data to encode in this field.

Check Digit depending on Application Identifier

Barcode Parameters
Narrow Bar
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This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Position text above barcode

This option places the text above the barcode instead of below.

Wrap text

This option allows to put the text on multiple lines, one line per AI.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment
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Using the buttons, you can set the alignment of the text to left, centered or right.

GS1 Databar Truncated

Info is similar to GS1 DataBar but the height of its bars is truncated. It encodes Global
Trade Item Numbers in a smaller symbol for use on small items.

Example  

 

Input The GS1 Databar Truncated barcode only allows 1 identifier, of type 01. The input is
14 digits, which means that the Application Identifier itself has to be omitted.

Composite
Component

A Composite Component is a 2D symbol placed on top of a GS1 barcode, that
encodes extra information (batch number, expiration date...).

If you want your barcode to have a Composite Component, enter the
(alphanumeric) data to encode in this field.

Check Digit last digit

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.
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Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Position text above barcode

This option places the text above the barcode instead of below.

Wrap text

This option allows to put the text on multiple lines, one line per AI.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

GS1 Databar Limited

Info is smaller than the GS1 DataBar barcode and can only encode Global Trade Item
Numbers whose data part starts with "0" or “1”.

Example  

 

Input The GS1 Databar Limited barcode accepts 14 digits, and must start with 0 or 1

Composite
Component

A Composite Component is a 2D symbol placed on top of a GS1 barcode, that
encodes extra information (batch number, expiration date...).

If you want your barcode to have a Composite Component, enter the
(alphanumeric) data to encode in this field.

Check Digit last digit

Barcode Parameters

Narrow Bar
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This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Position text above barcode

This option places the text above the barcode instead of below.

Wrap text

This option allows to put the text on multiple lines, one line per AI.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

264



9ArtPro+

Using the buttons, you can set the alignment of the text to left, centered or right.

GS1 DataMatrix

Info The GS1 DataMatrix barcode is a high density, high capacity, scalable 2D barcode.
It is used to concentrate a lot of (alphanumeric) information in a very small space.

Example

Input GS1 barcodes consist of 1 or multiple codes that start with so-called Application
Identifiers (AI) - 2 digit codes that indicate a specific goal. For example: AI 11
indicates a production date, AI 17 an expiration date, AI 10 a batch or lot number,
etc. The Application Identifiers require specific input, for example AI 11 and
AI 17 are fixed and require 6 digits, AI 10 is variable and can contain up to 20
alphanumeric characters.

If multiple AIs are allowed, they can be entered in multiple ways:

• Just enter the codes one after the other, without any spaces. In this case you
should enter fixed size Application Identifiers (AI) first, and AI with a variable
length last to allow a correct validation of the barcode.

• Put the AI between brackets. In that case it is clear where one code ends and
another one begins, so variable AIs can be put at the start if so desired.

• At the end of an AI, type "[F1]" before entering the next AI
• For an even higher readability: use Shift-Enter to start a new AI at the next line

For an overview of all GS1 Application Identifiers, see GS1 Application Identifiers
on page 297

Check Digit depending on Application Identifier

Barcode Parameters

Symbol Size
The amount of Cells in a barcode. The Symbol Size will automatically increase when entering too much
data for the current symbol size.

Cell Size
The size of a single black or white square.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.
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Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Position text above barcode

This option places the text above the barcode instead of below.

Wrap text

This option allows to put the text on multiple lines, one line per AI.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

GS1 QR

Info The GS1 QR barcode is a high density, high capacity, scalable 2D barcode. It is
used to assembly multiple GS1 Application Identifiers to a barcode with limited
space needs. The GS1 QR barcode can contain numbers, 0 - 9, upper case letters A
-Z, and nine special characters: space $ % * + - . /
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For more technical information on the QR code, see QR on page 288

Example

Input GS1 barcodes consist of 1 or multiple codes that start with so-called Application
Identifiers (AI) - 2 digit codes that indicate a specific goal. For example: AI 11
indicates a production date, AI 17 an expiration date, AI 10 a batch or lot number,
etc. The Application Identifiers require specific input, for example AI 11 and
AI 17 are fixed and require 6 digits, AI 10 is variable and can contain up to 20
alphanumeric characters.

If multiple AIs are allowed, they can be entered in multiple ways:

• Just enter the codes one after the other, without any spaces. In this case you
should enter fixed size Application Identifiers (AI) first, and AI with a variable
length last to allow a correct validation of the barcode.

• Put the AI between brackets. In that case it is clear where one code ends and
another one begins, so variable AIs can be put at the start if so desired.

• At the end of an AI, type "[F1]" before entering the next AI
• For an even higher readability: use Shift-Enter to start a new AI at the next line

Check Digit None

Barcode Parameters

Symbol Size
The amount of Cells in a barcode. The Symbol Size will automatically increase when entering too much
data for the current symbol size.

Error Correction
Error correction adds check sums to the barcode to detect and correct incorrect data. You can
choose one of the following Error correction levels:

• Level L: 7% of codewords can be restored.
• Level M: 15% of codewords can be restored.
• Level Q: 25% of codewords can be restored.
• Level H: 30% of codewords can be restored. (Not available for Micro QR)

Note:  Keep in mind that a higher correction level makes the barcode bigger (as more check
sums are added to the barcode) and may limit the maximum length of the encoded data.

Cell Size
The size of a single black or white square.

Bar Width Reduction.
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Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

HIBC 39

Info This barcode is based on the Code 39 symbology.

It encodes the organization's primary and / or secondary Labeler Identification
Code (LIC). This encoding begins with the “+” character. If both primary and
secondary Labeler Identification Codes are encoded in one barcode, they are
divided by the “/” character.

Example

Input Minimum 7 digits, with a leading "+"

Check Digit Last character is a check digit.

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Narrow Bar Ratio

268



9ArtPro+

This parameter determines the ratio between the width of the widest bar and the width of the
narrowest bar of your barcode. It does not affect the width of your barcode proportionally.

Changing this parameter will adjust the Narrow Bar parameter.

Character Frequency

This parameter determines the amount of character per milimeter or per inch, depending on the
setting in the Preferences (and affects the width of your barcode proportionally).

Changing this parameter will adjust the Narrow Bar parameter. It is only available when using the
default font.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset
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Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

HIBC 128

Info This barcode is based on the Code 128 symbology.

It encodes the organization's primary and / or secondary Labeler Identification
Code (LIC). This encoding begins with the “+” character. If both primary and
secondary Labeler Identification Codes are encoded in one barcode, they are
divided by the “/” character.

Example

Input Minimum 7 digits, with a leading "+"

Check Digit Last character is a check digit.

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Character Frequency

This parameter determines the amount of character per milimeter or per inch, depending on the
setting in the Preferences (and affects the width of your barcode proportionally).

Changing this parameter will adjust the Narrow Bar parameter. It is only available when using the
default font.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation
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Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

Interleaved 2 of 5

Info Interleaved 2 of 5 (or Int. 2 of 5) is a barcode originally used for transportation
packaging, that can have any even number of digits. Since this type of packaging
consists mainly of cardboard boxes printed in low quality, the Interleaved 2 of 5
barcode is more tolerant to distortion than other barcodes.

Example

Input Requires an even number of input digits
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Check Digit None

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Narrow Bar Ratio

This parameter determines the ratio between the width of the widest bar and the width of the
narrowest bar of your barcode. It does not affect the width of your barcode proportionally.

Changing this parameter will adjust the Narrow Bar parameter.

Character Frequency

This parameter determines the amount of character per milimeter or per inch, depending on the
setting in the Preferences (and affects the width of your barcode proportionally).

Changing this parameter will adjust the Narrow Bar parameter. It is only available when using the
default font.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text
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This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

ITF-14

Info ITF-14 is a standardized version of the Interleaved 2 of 5 barcode, containing 14
digits, the last being a check digit.

Example

Input The input for an ITF-14 code is 14 digits.

Check Digit The 14th digit is a check digit.

Barcode Parameters

Magnification

Use this parameter to increase or decrease the width of the barcode. Changing the Magnification will
also change the Font Size and Vertical Offset.

By entering "0" in the input field, you can reset the Magnification to its default value (100%).

Attention:  Changing the Magnification does not change the Height of the barcode. You
can however reset the Height by entering "0". The Height will be proportionally scaled to the
current Magnification.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.
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Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Printable Gauges

Use this option to add the printability gauges (“H” marks) either side of your barcode. Use the Smax
and Smin parameters to define the size. Smax defines the width of the left “H”, Smin defines the width
of the right “H”.

Add Bearer Bars

Use this option to add bearer bars to your barcode

• Set the Width of the bearer bars

• Define the Placement: either Top and bottom, or all sides

• Use the Top, Bottom, Left and Right fields to add a white margin between your barcode and the
bearer bars. You can enter a different margin for the top, left, right and bottom, or by enabling the

Lock button  you can set one margin for all 4 sides.

Barcode Text Parameters
Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment
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Using the buttons, you can set the alignment of the text to left, centered or right.

ITF-16

Info ITF-16 is a standardized version of the Interleaved 2 of 5 barcode, containing 16
digits, the last being a check digit.

Example

Input The input for an ITF-16 code is 16 digits.

Check Digit The 16th digit is a check digit.

Barcode Parameters
Magnification

Use this parameter to increase or decrease the width of the barcode. Changing the Magnification will
also change the Font Size and Vertical Offset.

By entering "0" in the input field, you can reset the Magnification to its default value (100%).

Attention:  Changing the Magnification does not change the Height of the barcode. You
can however reset the Height by entering "0". The Height will be proportionally scaled to the
current Magnification.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

275



9 ArtPro+

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Printable Gauges

Use this option to add the printability gauges (“H” marks) either side of your barcode. Use the Smax
and Smin parameters to define the size. Smax defines the width of the left “H”, Smin defines the width
of the right “H”.

Add Bearer Bars

Use this option to add bearer bars to your barcode

• Set the Width of the bearer bars

• Define the Placement: either Top and bottom, or all sides

• Use the Top, Bottom, Left and Right fields to add a white margin between your barcode and the
bearer bars. You can enter a different margin for the top, left, right and bottom, or by enabling the

Lock button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

Klebrand

Info Klebrand is a glue strip code mostly used in the German packaging industry. It can
contain bars with 4 different widths

Example

Input Use the buttons above the code to define if your input is in the quaternal numeral

system  (digits '0' to '3') or in the decimal numeral system  (digits '0' to '9').
'123' in quaternal corresponds to '27' in decimal.
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Decimal Input: digits (0 to 9) and /. The digits before the slash indicate the number
of bars (maximum 15), the digits behind the slash define the binary value of the
code. If only the digits behind the slash are entered, the minimum amount of bars
required to represent that value will be used.

Check Digit None

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
disabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.
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By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

Kurandt

Info The Kurandt barcode is part of the same "binary" barcode family as the Laetus
Pharma Code, Bobst and CLF-8. It is used in the pharmaceutical industry.

Example

Input Use the buttons above the code to define if your input is in the binary numeral

system  (digits '0' and '1') or in the decimal numeral system  (digits '0' to
'9'). '11011' in binary corresponds to '27' in decimal.

The input for a Kurandt code can be maximum 32 digits for binary input (maximum
8589934590 in decimal input). However, an input of maximum 16 binary digits
(decimal input of 131072) is preferred.

Check Digit None

Barcode Parameters

Note:  Kurandt barcodes have fixed values for Narrow Bar, Narrow Bar Ratio, Wide Bar and Gap.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.
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Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
disabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

Multicolor
This barcode can be colorized using the Multicolor fill option. See Multicolor barcodes on page 296
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Laetus Pharma

Info The Laetus Pharma Code is part of the same barcode family as the Kurandt,
Bobst and CLF-8 barcode. This barcode was developed specifically to meet
the requirements of the pharmaceutical packaging process. It has established
itself as the worldwide pharmaceutical industry barcode standard. It can encode
numeric or binary data.

In the Code Type dialog you can choose between the normal or the miniature
version of the barcode.

Example

 

 

Input Use the buttons above the code to define if your input is in the binary numeral

system  (digits '0' and '1') or in the decimal numeral system  (digits '0' to
'9'). '11011' in binary corresponds to '27' in decimal.

The input for a Laetus code can be maximum 32 digits for binary input (maximum
8589934590 in decimal input). However, an input of maximum 16 binary digits
(decimal input of 131072) is preferred.

Check Digit None

Barcode Parameters

Narrow Bar, Narrow Bar Ratio, Wide Bar, Gap
The Narrow Bar, Narrow Bar Ratio, Wide Bar and Gap values define the width of the narrow bars, wide
bars, gaps in between the bars and the ratio. Changing the width of the narrow or wide bar will affect
the Narrow Bar Ratio value.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.
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Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
disabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

Multicolor
This barcode can be colorized using the Multicolor fill option. See Multicolor barcodes on page 296
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Micro QR

Info The Micro QR Code is a very small QR Code for use on smaller spaces (for example
to encode the ID of printed circuit boards and electronics parts).

It works with smaller amounts of data (maximum 35 numeric characters), and
uses only one position pattern.

Example

Input 35

Check Digit None

Barcode Parameters

Symbol Size
The amount of Cells in a barcode. The Symbol Size will automatically increase when entering too much
data for the current symbol size.

Error Correction
Error correction adds check sums to the barcode to detect and correct incorrect data. You can
choose one of the following Error correction levels:

• Level L: 7% of codewords can be restored.
• Level M: 15% of codewords can be restored.
• Level Q: 25% of codewords can be restored.
• Level H: 30% of codewords can be restored. (Not available for Micro QR)
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Note:  Keep in mind that a higher correction level makes the barcode bigger (as more check
sums are added to the barcode) and may limit the maximum length of the encoded data.

Cell Size
The size of a single black or white square.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

MSI

Info MSI, also known as Modified Plessey, was developed by the MSI Data Corporation,
based on the original Plessy Code. It is a numeric barcode used primarily to mark
retail shelves for inventory control.

Example

Check Digit Can be set to None, Mod 10, Mod 11, Mod 1010 or Mod 1110

Input • When Check Digit is set to "None": 6 digits required
• When Check Digit is set to "Mod10" or "Mod11": 7 digits required
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• When Check Digit is set to "Mod1010" or "Mod1110": 8 digits required

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Narrow Bar Ratio

This parameter determines the ratio between the width of the widest bar and the width of the
narrowest bar of your barcode. It does not affect the width of your barcode proportionally.

Changing this parameter will adjust the Narrow Bar parameter.

Character Frequency

This parameter determines the amount of character per milimeter or per inch, depending on the
setting in the Preferences (and affects the width of your barcode proportionally).

Changing this parameter will adjust the Narrow Bar parameter. It is only available when using the
default font.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text
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This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

NDC/HRI

Info The NDC / HRI barcode is a variant of the UPC barcode with special human
readable interpretation formats compliant to the US National Drug Code
definition. For more information on UPC, see UPC-A on page 291.

Example

Input The input for a NDC/HRI code is 12 digits starting with a 3.

Check Digit The 12th digit is a check digit.

Barcode Parameters
Magnification

Use this parameter to increase or decrease the width of the barcode. Changing the Magnification will
also change the Font Size and Vertical Offset.

By entering "0" in the input field, you can reset the Magnification to its default value (100%).

Attention:  Changing the Magnification does not change the Height of the barcode. You
can however reset the Height by entering "0". The Height will be proportionally scaled to the
current Magnification.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.
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Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

PZN

Info The PZN (Pharma-Zentral-Nummer) barcode is used for distribution of
pharmaceutical and healthcare products in Germany. The PZN code is written in
the format “PZN-nnnnnnn” but only the numeric part including the leading dash is
encoded.
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Example

Input 7 or 8 digits

Check Digit The 8th digit is a check digit.

Barcode Parameters

Narrow Bar

This parameter determines the width of the narrowest bar of your barcode (and affects the width of
your barcode proportionally).

Changing this parameter will adjust the Character Frequency.

Narrow Bar Ratio

This parameter determines the ratio between the width of the widest bar and the width of the
narrowest bar of your barcode. It does not affect the width of your barcode proportionally.

Changing this parameter will adjust the Narrow Bar parameter.

Character Frequency

This parameter determines the amount of character per milimeter or per inch, depending on the
setting in the Preferences (and affects the width of your barcode proportionally).

Changing this parameter will adjust the Narrow Bar parameter. It is only available when using the
default font.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.
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Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

QR

Info The QR barcode is a 2-dimensional barcode used for commercial tracking and
convenience-oriented applications aimed at mobile phone users (known as
"mobile tagging").

QR codes storing addresses and URLs may appear in magazines, on signs, buses,
business cards, or other objects... Users with a camera phone equipped with
the correct reader application can scan the QR code to display text, contact
information, connect to a wireless network, or open a web page in the phone's
browser.

Example

Input Unlimited

Check Digit None
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Barcode Parameters

Symbol Size
The amount of Cells in a barcode. The Symbol Size will automatically increase when entering too much
data for the current symbol size.

Error Correction
Error correction adds check sums to the barcode to detect and correct incorrect data. You can
choose one of the following Error correction levels:

• Level L: 7% of codewords can be restored.
• Level M: 15% of codewords can be restored.
• Level Q: 25% of codewords can be restored.
• Level H: 30% of codewords can be restored. (Not available for Micro QR)

Note:  Keep in mind that a higher correction level makes the barcode bigger (as more check
sums are added to the barcode) and may limit the maximum length of the encoded data.

Cell Size
The size of a single black or white square.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

SICK

Info SICK is a bar code used in the German packaging industry. It is a binary code
consisting of 2 types of bars, a thin one and a thick one. It can contain 3 to 12 bars.

Example
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Input Use the buttons above the code to define if your input is in the binary numeral

system  (digits '0' and '1') or in the decimal numeral system  (digits '0' to
'9'). '11011' in binary corresponds to '27' in decimal.

Binary input: maximum 12 binary values (0 and 1).

Decimal Input: Digits (0 to 9) and a slash. Before the slash is the number of bars
(maximum 12), behind the slash is the binary value (maximum 4096). If only the
digits behind the slash are keyed in, it will create the minimum amount of bars
required to represent that value.

Check Digit None

Barcode Parameters

Narrow Bar, Narrow Bar Ratio, Wide Bar, Gap
The Narrow Bar, Narrow Bar Ratio, Wide Bar and Gap values define the width of the narrow bars, wide
bars, gaps in between the bars and the ratio. Changing the width of the narrow or wide bar will affect
the Narrow Bar Ratio value.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text
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This option defines if the barcode's code should be visible as normal text. By default this option is
disabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Alignment

Using the buttons, you can set the alignment of the text to left, centered or right.

UPC-A

Info Universal Product Code or UPC is the standard for article numbering in the U.S.A.
and Canada. It is similar to the EAN system and compatible with it. For more
information on EAN, see EAN-13 on page 248.

Example

Input The input for an UPC-A code is 12 digits starting with a zero, with optionally 2 or 5
supplemental digits, if set in the Code Type dialog.

Check Digit The 12th digit is a check digit.

Barcode Parameters

Magnification

Use this parameter to increase or decrease the width of the barcode. Changing the Magnification will
also change the Font Size and Vertical Offset.

By entering "0" in the input field, you can reset the Magnification to its default value (100%).

Attention:  Changing the Magnification does not change the Height of the barcode. You
can however reset the Height by entering "0". The Height will be proportionally scaled to the
current Magnification.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Add light margin indicator

Use this option to add light margin indicators before ("<") and/or after (">") the barcode number
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Note:  The light margin indicators are only available when using 5 additional digits.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.
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UPC-E

Info Universal Product Code or UPC is the standard for article numbering in the U.S.A.
and Canada. It is similar to the EAN system and compatible with it. For more
information on EAN, see EAN-13 on page 248.

UPC-E is an abbreviated version of UPC-A, for use on smaller packages.

Example

Input The input for an UPC-E code is 8 digits, starting with a zero. You can also enter
a 12 digit code, if it can be compressed into an 8 digit code. Optionally 2 or 5
supplemental digits, if set in the Code Type dialog.

Check Digit The 8th digit is a check digit.

Barcode Parameters

Magnification

Use this parameter to increase or decrease the width of the barcode. Changing the Magnification will
also change the Font Size and Vertical Offset.

By entering "0" in the input field, you can reset the Magnification to its default value (100%).

Attention:  Changing the Magnification does not change the Height of the barcode. You
can however reset the Height by entering "0". The Height will be proportionally scaled to the
current Magnification.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.
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Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Add Box

Use this parameter to create an opaque white box under your barcode.

Use the Top, Bottom, Left and Right fields to add a white margin around your barcode and make the
box bigger. You can enter a different margin for the top, left, right and bottom, or by enabling the Lock

button  you can set one margin for all 4 sides.

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset

Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

UPC-SCS

Info The UPC–SCS (Shipping Container Symbol) barcode is a version of the Interleaved
2 of 5 barcode that has a structure very similar to the Universal Product Code's
(UPC) and specific formatting of the human readable interpretation.

Example

Input The input for an UPC-SCS code is 14 digits, and the second digit has to be a zero,
with optionally 6 supplemental digits, if set in the Code Type dialog.

Check Digit The 14th digit is a check digit for the main code, the 20th digit is a check digit for
the supplemental digits..
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Barcode Parameters

Magnification

Use this parameter to increase or decrease the width of the barcode. Changing the Magnification will
also change the Font Size and Vertical Offset.

By entering "0" in the input field, you can reset the Magnification to its default value (100%).

Attention:  Changing the Magnification does not change the Height of the barcode. You
can however reset the Height by entering "0". The Height will be proportionally scaled to the
current Magnification.

Height

The height you enter is the combined height of the bars and the human readable characters. Your
barcode needs to be tall enough to be read easily by barcode scanners.

Bar Width Reduction.

Use this to adjust the width of barcode bars, in order to compensate for ink bleeding when printing on
your substrate.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Device Compensation

Use this if your printer gave you a separate device bleed value. This parameter adjusts the bar's width
to compensate for bleed caused by the plate or film making process.

Note:  If you use both a Bar Width Reduction and a Device Compensation value, the Barcode
Inspector will add them to adjust the bar's width.

Tip:  You can enter a negative value if you want to print thicker and not thinner bars.

Snap Bars to Output Resolution and Output resolution

Use this to adjust specific barcode parameters (Bar Width Reduction, Device Compensation,
Magnification and Font Size) so that the bars' width take up a complete number of pixels or dots.

Enable Snap Bars to Output Resolution and enter the resolution you will use to print your barcode in
ppi. Everytime a value is adjusted because of this option, a warning will be shown.

By entering "0" in the input field, you can reset the Output Resolution to its default value (2540 ppi).

Barcode Text Parameters

Add human readable text

This option defines if the barcode's code should be visible as normal text. By default this option is
enabled.

Font Family, Font Style and Size

By default the digits are vectorized from the standard OCR-B font. You can use real text by selecting a
font family. You can also define the style and size.

By entering "0" in the Size input field, you can reset the text size to the default value for the selected
barcode type.

Offset
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Use this parameter to apply a vertical offset to the text of the barcode. A positive value moves the text
down, a negative value moves the text up.

Text Format
Use the Text Format parameter to set the grouping of the characters.

9.1.4.  Multicolor barcodes

A Code 128, Laetus Pharma, Bobst or Kurandt barcode can be colorized using the Multicolor fill option.

 

 

This special Fill mode allows to create a multicolor barcode.

 

 

The outer bars will be filled using the darkest separation, all bars in between are filled with the selected
separations.

By default, only Artwork separations will be enabled. Unused separations, Processing Step colors (PDF
+) and Varnishes and Technical Inks (Normalized PDF) are by default not selected when choosing the
Multicolor Barcode.

Note:  The color of a multicolor barcode is not dynamic, if you e.g. add a separation, it will not
be added automatically. You can adjust the multicolor fill by enabling the separation in the
Inspector, or you can switch back to flat color and back to multicolor to reset the setting. If you
remap or remove a separation the barcode will be updated. The barcode will also be updated
when saving the PDF.
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Multicolor barcodes are not supported in a Normalized PDF opened in PackEdge or DeskPack. As soon
as the barcode is updated, the barcode will become flat colored.

9.1.5.  GS1 Application Identifiers

These are the available GS1 Application Identifiers:

AI Data Content Format *1 FNC1 Required
*5

00 Serial Shipping Container Code (SSCC) N2+N18

01 Global Trade Item Number (GTIN) N2+N14

02 GTIN of Contained Trade Items N2+N14

10 Batch or Lot Number N2+X..20 (FNC1)

11 *2 Production Date (YYMMDD) N2+N6

12 *2 Due Date (YYMMDD) N2+N6

13 *2 Packaging Date (YYMMDD) N2+N6

15 *2 Best Before Date (YYMMDD) N2+N6

16 *2 Sell By Date (YYMMDD) N2+N6

17 *2 Expiration Date (YYMMDD) N2+N6

20 Internal product variant N2+N2

21 Serial Number N2+X..20 (FNC1)

22 Consumer product variant N2+X..20 (FNC1)

235 Third Party Controlled, Serialised Extension
of GTIN (TPX)

N3+X..28 (FNC1)

240 Additional Item Identification N3+X..30 (FNC1)

241 Customer Part Number N3+X..30 (FNC1)

242 Made-to-Order Variation Number N3+N..6 (FNC1)

243 Packaging Component Number N3+X..20 (FNC1)

250 Secondary Serial Number N3+X..30 (FNC1)

251 Reference to Source Entity N3+X..30 (FNC1)

253 Global Document Type Identifier (GDTI) N3+N13+X..17 (FNC1)

254 GLN Extension Component N3+X..20 (FNC1)

255 Global Coupon Number (GCN) N3+N13+N..12 (FNC1)

30 Variable Count of Items (Variable Measure
Trade Item)

N2+N..8 (FNC1)

310n *3 Net weight, kilograms (Variable Measure
Trade Item)

N4+N6
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311n *3 Length or first dimension, metres (Variable
Measure Trade Item)

N4+N6

312n *3 Width, diameter, or second dimension,
metres (Variable Measure Trade Item)

N4+N6

313n *3 Depth, thickness, height, or third dimension,
metres (Variable Measure Trade Item)

N4+N6

314n *3 Area, square metres (Variable Measure Trade
Item)

N4+N6

315n *3 Net volume, litres (Variable Measure Trade
Item)

N4+N6

316n *3 Net volume, cubic metres (Variable Measure
Trade Item)

N4+N6

320n *3 Net weight, pounds (Variable Measure Trade
Item)

N4+N6

321n *3 Length or first dimension, inches (Variable
Measure Trade Item)

N4+N6

322n *3 Length or first dimension, feet (Variable
Measure Trade Item)

N4+N6

323n *3 Length or first dimension, yards (Variable
Measure Trade Item)

N4+N6

324n *3 Width, diameter, or second dimension, inches
(Variable Measure Trade Item)

N4+N6

325n *3 Width, diameter, or second dimension, feet
(Variable Measure Trade Item)

N4+N6

326n *3 Width, diameter, or second dimension, yards
(Variable Measure Trade Item)

N4+N6

327n *3 Depth, thickness, height, or third dimension,
inches (Variable Measure Trade Item)

N4+N6

328n *3 Depth, thickness, height, or third dimension,
feet (Variable Measure Trade Item)

N4+N6

329n *3 Depth, thickness, height, or third dimension,
yards (Variable Measure Trade Item)

N4+N6

330n *3 Logistic weight, kilograms N4+N6

331n *3 Length or first dimension, metres N4+N6

332n *3 Width, diameter, or second dimension,
metres

N4+N6

333n *3 Depth, thickness, height, or third dimension,
metres

N4+N6

334n *3 Area, square metres N4+N6

335n *3 Logistic volume, litres N4+N6
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336n *3 Logistic volume, cubic metres N4+N6

337n *3 Kilograms per square metre N4+N6

340n *3 Logistic weight, pounds N4+N6

341n *3 Length or first dimension, inches N4+N6

342n *3 Length or first dimension, feet N4+N6

343n *3 Length or first dimension, yards N4+N6

344n *3 Width, diameter, or second dimension, inches N4+N6

345n *3 Width, diameter, or second dimension, feet N4+N6

346n *3 Width, diameter, or second dimension, yard N4+N6

347n *3 Depth, thickness, height, or third dimension,
inches

N4+N6

348n *3 Depth, thickness, height, or third dimension,
feet

N4+N6

349n *3 Depth, thickness, height, or third dimension,
yards

N4+N6

350n *3 Area, square inches (Variable Measure Trade
Item)

N4+N6

351n *3 Area, square feet (Variable Measure Trade
Item)

N4+N6

352n *3 Area, square yards (Variable Measure Trade
Item)

N4+N6

353n *3 Area, square inches N4+N6

354n *3 Area, square feet N4+N6

355n *3 Area, square yards N4+N6

356n *3 Net weight, troy ounces (Variable Measure
Trade Item)

N4+N6

357n *3 Net weight (or volume), ounces (Variable
Measure Trade Item)

N4+N6

360n *3 Net volume, quarts (Variable Measure Trade
Item)

N4+N6

361n *3 Net volume, gallons U.S. (Variable Measure
Trade Item)

N4+N6

362n *3 Logistic volume, quarts N4+N6

363n *3 Logistic volume, gallons U.S. N4+N6

364n *3 Net volume, cubic inches (Variable Measure
Trade Item)

N4+N6

365n *3 Net volume, cubic feet (Variable Measure
Trade Item)

N4+N6
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366n *3 Net volume, cubic yards (Variable Measure
Trade Item)

N4+N6

367n *3 Logistic volume, cubic inches N4+N6

368n *3 Logistic volume, cubic feet N4+N6

369n *3 Logistic volume, cubic yards N4+N6

37 Count of Trade Items N2+N..8 (FNC1)

390n *3 Applicable Amount Payable or Coupon Value,
local currency

N4+N..15 (FNC1)

391n *3 Applicable Amount Payable with ISO Currency
Code

N4+N3+N..15 (FNC1)

392n *3 Applicable Amount Payable, single monetary
area (Variable Measure Trade Item)

N4+N..15 (FNC1)

393n *3 Applicable Amount Payable with ISO Currency
Code (Variable Measure Trade Item)

N4+N3+N..15 (FNC1)

394n *3 Percentage discount of a coupon N4+N4 (FNC1)

395n *3 Amount payable per unit of measure single
monetary area (variable measure trade item)

N4+N6 (FNC1)

400 Customer's Purchase Order Number N3+X..30 (FNC1)

401 Global Identification Number for
Consignment (GINC)

N3+X..30 (FNC1)

402 Global Shipment Identification Number (GSIN) N3+N17 (FNC1)

403 Routing Code N3+X..30 (FNC1)

410 Ship to - Deliver to Global Location Number N3+N13

411 Bill to - Invoice to Global Location Number N3+N13

412 Purchased from Global Location Number N3+N13

413 Ship for - Deliver for - Forward to Global
Location Number

N3+N13

414 Identification of a Physical Location - Global
Location Number

N3+N13

415 Global Location Number of the Invoicing
Party

N3+N13

416 GLN of the production or service location N3+N13

417 Party GLN N3+N13

420 Ship to - Deliver to Postal Code Within a
Single Postal Authority

N3+X..20 (FNC1)

421 Ship to - Deliver to Postal Code with ISO
Country Code

N3+N3+X..9 (FNC1)

422 Country of Origin of a Trade Item N3+N3 (FNC1)
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423 Country of Initial Processing N3+N3+N..12 (FNC1)

424 Country of Processing N3+N3 (FNC1)

425 Country of Disassembly N3+N3+N..12 (FNC1)

426 Country Covering full Process Chain N3+N3 (FNC1)

427 Country Subdivision of Origin N3+X..3 (FNC1)

4300 Ship-to / Deliver-to company name N4+X..35 (FNC1)

4301 Ship-to / Deliver-to contact N4+X..35 (FNC1)

4302 Ship-to / Deliver-to address line 1 N4+X..70 (FNC1)

4303 Ship-to / Deliver-to address line 2 N4+X..70 (FNC1)

4304 Ship-to / Deliver-to suburb N4+X..70 (FNC1)

4305 Ship-to / Deliver-to locality N4+X..70 (FNC1)

4306 Ship-to / Deliver-to region N4+X..70 (FNC1)

4307 Ship-to / Deliver-to country code N4+X2 (FNC1)

4308 Ship-to / Deliver-to telephone number N4+X..30 (FNC1)

4309 Ship-to / Deliver-to GEO location N4+N20 (FNC1)

4310 Return-to company name N4+X..35 (FNC1)

4311 Return-to contact N4+X..35 (FNC1)

4312 Return-to address line 1 N4+X..70 (FNC1)

4313 Return-to address line 2 N4+X..70 (FNC1)

4314 Return-to suburb N4+X..70 (FNC1)

4315 Return-to locality N4+X..70 (FNC1)

4316 Return-to region N4+X..70 (FNC1)

4317 Return-to country code N4+X2 (FNC1)

4318 Return-to postal code N4+X..20 (FNC1)

4319 Return-to telephone number N4+X..30 (FNC1)

4320 Service code description N4+X..35 (FNC1)

4321 Dangerous goods flag N4+N1 (FNC1)

4322 Authority to leave N4+N1 (FNC1)

4323 Signature required flag N4+N1 (FNC1)

4324 Not before delivery date time N4+N10 (FNC1)

4325 Not after delivery date time N4+N10 (FNC1)

4326 Release date N4+N6 (FNC1)

4330 Maximum temperature in Fahrenheit N4+N6+[-] (FNC1)

4331 Maximum temperature in Celsius N4+N6+[-] (FNC1)
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4332 Minimum temperature in Fahrenheit N4+N6+[-] (FNC1)

4333 Minimum temperature in Celsius N4+N6+[-] (FNC1)

7001 NATO Stock Number (NSN) N4+N13 (FNC1)

7002 UN/ECE Meat Carcasses and Cuts
Classification

N4+X..30 (FNC1)

7003 Expiration Date and Time N4+N10 (FNC1)

7004 Active Potency N4+N..4 (FNC1)

7005 Catch Area N4+X..12 (FNC1)

7006 First Freeze Date N4+N6

7007 Harvest Date N4+N6..12 (FNC1)

7008 Species for Fishery Purposes N4+X..3 (FNC1)

7009 Fishing Gear Type N4+N..10 (FNC1)

7010 Production Method N4+X..2 (FNC1)

7011 *6 Test by date N4-N6+N..4 (FNC1)

7020 Refurbishment lot ID N4+X..20 (FNC1)

7021 Functional status N4+X..20 (FNC1)

7022 Revision status N4+X..20 (FNC1)

7023 Global Individual Asset Identifier (GIAI) of an
assembly

N4+X..30 (FNC1)

703s Number of Processor with ISO Country Code N4+N3+X..27 (FNC1)

7040 GS1 UIC with Extension 1 and Importer index N4+N1X2+X3+X4 (FNC1)

710 National Healthcare Reimbursement Number
(NHRN) – Germany PZN

N3+X..20 (FNC1)

711 National Healthcare Reimbursement Number
(NHRN) – France CIP

N3+X..20 (FNC1)

712 National Healthcare Reimbursement Number
(NHRN) – Spain CN

N3+X..20 (FNC1)

713 National Healthcare Reimbursement Number
(NHRN) – Brasil DRN

N3+X..20 (FNC1)

714 National Healthcare Reimbursement Number
(NHRN) - Portugal AIM

N3+X..20 (FNC1)

715 National Healthcare Reimbursement Number
for US Food & Drug Agency

N3+X..20 (FNC1)

723s *4 Certification reference N4+X2+X..28 (FNC1)

7240 Clinical Trial Protocol ID N4+X..20 (FNC1)

7241 AIDC media type N4+N2 (FNC1)

7242 Version Control Number (VCN) NX+X..25 (FNC1)
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8001 Roll Products (Width, Length, Core Diameter,
Direction, Splices)

N4+N14 (FNC1)

8002 Cellular Mobile Telephone Identifier N4+X..20 (FNC1)

8003 Global Returnable Asset Identifier (GRAI) N4+N14+X..16 (FNC1)

8004 Global Individual Asset Identifier (GIAI) N4+X..30 (FNC1)

8005 Price Per Unit of Measure N4+N6 (FNC1)

8006 Identification of the Components of a Trade
Item

N4+N14+N2+N2 (FNC1)

8007 International Bank Account Number (IBAN) N4+X..34 (FNC1)

8008 Date and Time of Production N4+N8+N..4 (FNC1)

8010 Component / Part Identifier (CPID) N4 + Y..30 (FNC1)

8011 Component / Part Identifier Serial Number
(CPID SERIAL)

N4 + N..12 (FNC1)

8012 Software version N4+X..20 (FNC1)

8013 Global Model Number (GMN) N4+X..30 (FNC1)

8017 Global Service Relation Number to identify
the relationship between an organisation
offering services and the provider of services

N4+N18 (FNC1)

8018 Global Service Relation Number to identify
the relationship between an organisation
offering services and the recipient of
services

N4+N18 (FNC1)

8019 Service Relation Instance Number (SRIN) N4+N..10 (FNC1)

8020 Payment Slip Reference Number N4+X..25 (FNC1)

8026 ITIP of contained pieces N4+N18

8030 Digital Signature (DigSig) N4+Z..90 (FNC1)

8110 Coupon Code Identification for Use in North
America

N4+X..70 (FNC1)

8111 Loyalty points of a coupon N4+N4 (FNC1)

8112 Paperless coupon code identification for use
in North America

N4+X..70 (FNC1)

8200 Extended Packaging URL N4+X..70 (FNC1)

90 Information Mutually Agreed Between Trading
Partners

N2+X..30 (FNC1)

91 to 99 Company Internal Information N2+X..30 (FNC1)

Notes
• *1: The first position indicates the length (number of digits) of the GS1 Application Identifier. The

following value refers to the format of the data content.

303



9 ArtPro+

The following convention is applied:

n implied decimal point position

N numeric digit

X any character from the table 7.11-1 of the GS1
General Specificatons (AI encodable character
set 82)

Y any character from the table 7.11-2 of the GS1
General Specificatons (AI encodable character
set 39)

Z any character from the table 7.11-3 of the GS1
General Specificatons (file-safe / URI-safe
base64)

N3 3 numeric digits, fixed length

N..3 up to 3 numeric digits

X..3 up to 3 characters

[ ] enclosed value is an optional component

• *2: If only year and month are available, DD must be filled with two zeroes.

• *3: The fourth digit of this GS1 Application Identifier indicates the implied decimal point position.
Example:

• 3100 Net weight in kg without a decimal point
• 3102 Net weight in kg with two decimal points

• FNC1: All GS1 Application Identifiers indicated with (FNC1) are defined as of variable length and shall
be delimited unless this Element String is the last one to be encoded in the symbol. The delimiter
shall be a Function 1 Symbol Character in GS1-128 Symbology, GS1 DataBar Expanded Versions and
GS1 Composite Symbology and should be a Function 1 Symbol Character in GS1 DataMatrix and GS1
QR Code Symbology.

• *4: The fourth digit of this AI indicates the sequence number, allowing multiple occurrences of this
AI

• *5: All GS1 Application Identifiers indicated with (FNC1) are defined as of variable length and shall be
delimited unless this Element String is the last one to be encoded in the symbol. The delimiter shall
be a Function 1 Symbol Character in GS1-128 Symbology, GS1 DataBar Expanded Versions and GS1
Composite Symbology and should be a Function 1 Symbol Character in GS1 DataMatrix and GS1 QR
Code Symbology.

• *6: GS1 specificiation expects exactly 6 or 10 digits (N4+N6+[N4]) for this Application Identifier. Due
to a technical limitation Dynamic Barcodes allows entering any amount of digits from 6 to 10.

9.1.6.  Barcode properties from Automation Engine

For documents that are in an Automation Engine Job or that are part of an Automation Engine Product,
you can use the barcode setup defined in the Job Setup or Product Part in Automation Engine.

Using the Get Properties from Job Setup or Get Properties from Product Part button, you can link the
parameters for the selected barcode type to the parameters as defined in the Automation Engine Job
Setup or Product Part .
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A type of barcode which has properties specified on the Job Setup or Product Part will be indicated by
a green or red Automation Engine icon in front of the type.

Product Part or Job Setup
The properties defined in the Product Part have priority over settings in the Job Setup. However,
for barcode types that are not defined in the Product Part, the properties from the Job Setup will be
used. This means that within one document, you can have a mix of barcodes using the Product Part
properties and barcodes using the Job Setup data.

The button in the Barcode Type inspector will change according to the available properties:

• Get Properties from Product Part if the selected barcode type has properties defined in the
Product Part.

• Get Properties from Job Setup if the selected barcode type has no properties defined in the
Product Part, but it has in the Job Setup.

• Get Properties from Server if you have multiple barcodes selected, some of a type that has
properties defined in the Product Part, and some only in the Job Setup.

A barcode using the Job Setup or Product Part properties
If all parameters are according to what is specified in the Job Setup or Product Part, the Barcode Type

inspector will show a green Automation Engine icon  in front of the Type. The indication "Using
Job Setup Properties" or "Using Product Part Properties" is shown at the bottom. Also, every barcode
parameter that is defined in the Job Setup or Product Part is indicated by the same green icon, and
these parameters can't be changed. Parameters not defined in the Job Setup or Product Part can be
modified freely in the document.

 

 

Mismatched Barcode
A barcode using one or more parameters not matching the parameters defined in the Job Setup or

Product Part, e.g. if the parameters have been modified in the AE Job Setup, will show a red icon ,
and the Messages side drawer will show a "Mismatched Barcode" error.

Click the Get Properties from Job Setup or Get Properties from Product Part button to link the
barcode type to the parameters of the Job Setup or Product Part.

The icon will become green and all parameters will be changed according to the settings in the Job
Setup or Product Part.
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Missing Barcode
If a barcode type is specified on the Job Setup or Product Part but is not present in the document, a
"Missing barcode" error message will appear in the Messages side drawer. If you create a new barcode,
ArtPro+ will automatically create a new barcode of the missing type, using the parameters as defined in
the Job Setup or Product Part.

If multiple barcode types are missing, creating new barcodes will create these missing types in the
order as they were entered in Automation Engine Pilot.

Changing the type of an existing barcode to a barcode type with defined parameters will automatically
use the Job Setup or Product Part parameters and get a green icon.

9.1.7.  Convert to Barcode

Convert to Barcode is a function to convert vectorized (contourized) barcodes (e.g. from non Esko
applications) or images of barcodes to live editable barcodes.

1. Select the outlined barcode or image of the barcode that you want to convert

Note:

It is recommended to select only the image or barcode outlines of one single barcode, since
all objects in the selection will be removed and replaced by the barcode during conversion.

2. Choose Prepress > Convert to Barcode or use its shortcut Cmd+Alt+Shift+B (Mac) or Ctrl+Alt+Shift
+B (Windows)

The resulting Converted Barcode will be positioned in the center of the original selection.
3. Once the conversion is done, the object will be shown as a Converted Barcode, and you have

different options.
 

 
a) Click and hold Hold to View Original to hide the converted Barcode and see the original objects.

You can toggle between the original objects and the converted barcode as long as you don't
Accept or Revert.
You can also use the Quality Control Compare function: as long as the converted barcode hasn't
been accepted or rejected, you will see a Original Barcode Outlines option. See Compare on
page 110.

b) When needed, you can change the barcode type, code or properties in the corresponding
Inspectors. See Edit a barcode on page 233
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c) When you're happy with the result, you can click the Accept button. This will remove the original
objects from the document, leaving you with a regular barcode that you can edit as needed. You
can also use the Accept Converted Barcode in the Barcode Inspector

d) If you want to revert the converted barcode to the original objects, you can click Revert. You can
also use the Revert Converted Barcode to Original Data button in the Barcode Inspector.

Important:

It is highly recommended to Accept (or Revert) the barcode conversion before closing the file
to ensure smooth processing of the file further down the workflow.

To indicate that there are unaccepted Converted Barcodes in your document, a "Converted
Barcodes" message will be shown in the Messages drawer. This will only disappear once all
Converted Barcodes have been either accepted or reverted.

Supported Barcode Types and known limitations
The barcodes that are currently supported for Barcode Recognition are these:

• EAN-13 (with or without supplemental digits)
• EAN-8
• DataMatrix
• UPC-A (with or without supplemental digits)
• UPC-E (with or without supplemental digits)
• Int. 2 of 5
• ITF-16
• Code 39
• Code 128
• Code 128 (long)
• GS1 128
• GS1 DataMatrix
• QR

The barcode parameters that are currently recognized (when possible) are these:

• Barcode type
• Code
• Presence of supplemental digits
• Color
• Presence of Human Readable text
• Height (only for line art objects. For images, the default height is used)
• Rotation
• Magnification
• Bar Width Reduction (only when recognizing line art objects)
• Characters per unit
• Ratio

Other limitations:

• White Box, Light margin indicators, H gauges for ITF barcodes and HRI text parameters are not
recognized.

• Device Compensation and Bar Width Reduction are both combined in the Bar Width Reduction
• An Int. 2 of 5 needs to have at least 6 digits.
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• If the original is an image, rotation is deduced from the rotation of the image. If the barcode inside
the image is rotated over an angle other than a multiple of 90º, the recognizing will not work.

• Clear Area box is not recognized. If it is included in the selection, it will be removed during
conversion.

• For barcodes using custom text fonts, the font will be reset to the default OCR-B font.

9.2.  Add Dimensions

Using Add Dimensions you can add the dimensions of the bounding box of the selected object(s), or of
one of the page boxes.

1. Select the object(s) you want to add the dimensions to. If nothing is selected, the dimensions of the
Trim Box will be added.

2. Select Prepress > Add Dimensions or use its shortcut Cmd+Shift+L (Mac) or Ctrl+Shift+L
(Windows).

The Dimensions are created using the last used settings.
3. Use the Dimensions Inspector to change the Dimension lines. All changes are done immediately.

 

 
a) The Reference is set to Selection if the dimensions were created on selected objects. You can

change it to any of the defined Page Boxes.
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b) Set the Units and number of Decimals for the dimensions.
c) Enabling Remove trailing zeros will remove any trailing (decimal) zeros, regardless of the

amount of decimals set.
d) Set the type of Arrows you want to use.
e) Using Line Style you can add a frame on the bounding box of the selection, or the selected Page

Box, either dashed or a solid line. If you select "No Line", no frame will be added.
f) Set the Line Width for all dimension lines.
g) Set the Line Color. You can choose the Processing Step colorant "Dimensions and text", or you

can select any separation in your document. By default the previously used Line Color is used. If
no Line Color was set before, "Dimensions and text" is used.

h) Select the corner you want to use as base for Positioning the dimensions. In the screenshot
above the bottom left corner is selected, so the dimensions are placed on the left side and below
the selection or page box.

i) Set the Margins. If the Chain option is selected, the same margin is used in all directions.
Deselect it to enter a different margin for top, right, bottom or right.

4. To change the text properties of the dimension objects, you can use the Text Inspector, which will
show a limited number of options: Font Family, Style and Size.

5. Use the Dimensions Grid Inspector to set up columns and rows
 

 
a) Click the + button to add a new column or row. If an input field is selected, the new field is added

in front of it, otherwise it's added before the last input field.
b) Set the Columns width or Rows height by entering a distance in the different fields.

The last input field can't be changed. If the sum of the user input fields is lower than the total
dimension, the last input field will contain the difference, so that the total sum equals the total
dimension. If the sum of the user input fields is higher than the total dimension, the last input
field will be zero, and the user input fields will be reduced to match the total dimension. In that
case, a warning is shown.
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Note:  The subdivision lines and dimensions use the settings from the Dimensions
Inspector

In PDF+, the separation that is used for the dimension lines will become a Processing Step Separation,
and the dimension objects are added to the "Dimensions and text" Processing Step Layer.

In Normalized PDF, the separation that is used for the dimension lines will become a technical ink, and
the dimension objects are added to a "Dimensions and text" layer.

When you expand the dimension objects, or if you save and reopen the file, the dimension objects
become regular objects in a Group.

9.3.  Add Bleed

The Add Bleed function allows you to extend artwork beyond the cutting lines, to avoid white areas
when cutting the printed material.

Add Bleed requires a Processing Step Layer "Cutting", and is only available for PDF+. See PDF, PDF+ and
Normalized PDF on page 57 and Processing Step Layers on page 127

1. Select the object(s) you want to add bleed to.
2. Choose Prepress > Add Bleed.

The Add Bleed dialog is opened.
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3. Set the Bleed Distance and the Corners (Round or Square)
4. Set the Clone From distance: the color of the newly created Add Bleed object will be based on

pixels cloned from this distance inside the Cut line.
5. Click Add Bleed

The Add Bleed objects are created in a Layer named "Bleed", filled with an embedded image, filled with
pixels cloned from inside the Cut line.
 

 

9.4.  White Underprint

Using the White Underprint function you can add white underprinting objects based on the current
selection.
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1. Select the objects you want to create white underprint objects for.
2. Choose Prepress > White Underprint or use the shortcut Cmd+Shift+W (Mac) or Ctrl+Shift+W

(Windows).
3. Using the buttons, decide if you want the white underprint objects larger (Spread) or smaller

(Choke) than the original objects
4. Enter the Distance to spread or choke
5. Set the Corners: straight, round or beveled
6. Select the Separation you want to use for the White Underprint:

• "Opaque White" is the default option. If the separation doesn't exist yet, it will be created.
• You can also choose one of the existing separations in your document
• Using Custom, you can create a custom separation by entering its name and defining its preview

color.
7. Enable Exclude Covered Areas to exclude areas in your selection that are covered by unselected

objects.
8. Enable Exclude White Objects to exclude objects with a 0% fill and/or stroke.
9. Enable Exclude Dynamic Marks to exclude Dynamic Marks. If you disable the option, White

Underprint will be created under Dynamic Marks objects.

Note:  Keep in mind that the White Underprint objects are not dynamic: if the Dynamic Mark
changes, you have to recreate the White Underprint objects.

10. Click Create. If your file already contains White Underprint objects, the button is changed to Add.
Hold down the Alt key to Subtract from the white underprint, in order to create holes in the white
underprint.

White Underprint objects are created in a new layer named "White Underprint". In PDF+, this will be a
Processing Step layer 'White'.
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9.5.  Rich Black

Using Rich Black you can obtain a darker black, by adding other inks, for example 100% cyan.

1. Select the objects you want to add Rich Black objects to.

Note:  Rich Black is only added to objects with flat paints. Objects with gradients or images
will be ignored.

2. Select Prepress > Rich Black...
 

 
3. Select the Enrich Separation. By default, this will be the black separation or, if there is no black

separation, the darkest separation in the job.
4. Define what color should be used to enrich, using the With Color section. By default this will be

100% cyan, when possible.
5. Enable Only create Rich Black if no other separations are present to exclude objects that contains

other separations besides the Enrich Separation.
6. Set the Minimum Density to exclude objects that have a density lower than the set value for the

Enrich Separation.
7. Enter the Choke Distance to make the Rich Black objects slightly smaller than the original objects.
8. Set the Corners: straight, round or beveled
9. Click Create to create the Rich Black objects.

The Rich Black objects are created in a separate Rich Black layer, using the defined color, in a Darken
blend mode.

9.6.  Ink Eater Areas

Ink Eaters help to achieve a constant ink consumption over the width of the plate. This makes it easier
for press operators to set the ink keys, and results in a faster setup time for the press.

Ink Eaters are typically added to non-printed areas outside the printing job. These areas can be left-
overs that will be cut off or the white spaces next to or even in between the one-ups.
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Ink Eaters help to avoid excess ink build-up by stabilizing "peaks" and "lows" in the ink key histogram.
This prevents spilling of excess ink onto the printed zones of the actual printing job. You can flatten the
ink key histogram by filling non-printed zones with a gradient. A gradient helps to avoid hard edges in
the compensation object.

You can use Create Ink Eater Areas to automatically create ink eater areas in grid or CAD based Step
and Repeat files. See Create Ink Eater Areas on page 314.

After creating the Ink Eater Areas, you can use Fill Ink Eater Areas to fill the shapes as Ink Eater Areas.
You can also use Fill Ink Eater Areas to fill manually created shapes as Ink Eater Areas. See Fill Ink
Eater Areas on page 315

9.6.1.  Create Ink Eater Areas

Using Create Ink Eater Areas you can automatically create ink eater areas in grid or CAD based Step
and Repeat files. Afterwards you can use Fill Ink Eater Areas to fill these areas. See Fill Ink Eater Areas
on page 315

1. Open the file you want to add Ink Eater Areas to. The file needs to be a Grid Step & Repeat file or a
CAD based Step & Repeat file (MFG or CF2)

2. If you want to create Ink Eater areas based on existing objects, select these objects first.
3. Choose Prepress > Ink Eater Areas > Create Ink Eater Areas

 

 
4. Define what you want to Start from: either the Die Shape, the Media Box of the station, or the Trim

Box of the station.
5. Define the Keep Away Distance: the distance the Ink Eater Areas has to stay away from the Die

Shape, Media Box or Trim Box of the station.

Note:  The Keep Away Distance is calculated from the cutting line, not from the bleed line.
If you have e.g. a bleed of 5 mm and a Keep Away Distance of 2mm, the Ink Eater Area will
have a 3mm overlap on the bleed.

6. Define if you want to Exclude Marks. When enabled, the Ink Eater Areas will stay away from Marks
using the same Keep Away Distance.

7. Click Create Ink Eater Areas or - if you had objects selected prior to opening the Create Ink Eater
Areas dialog - click Create Ink Eater Areas from Selection

The Ink Eater Area shapes are now created, and can be filled using Fill Ink Eater Areas.
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Create Ink Eater Areas from Selection

If you have a selection in your document, the menu item will change to Prepress > Ink Eater Areas >
Create Ink Eater Areas from selection. In that case, the paths in the selection (except for Clipping
Paths) will be used to define the ink eater areas. If none of the objects in the selection are suitable to
define the ink eater areas, the Trim Box of the page will be used instead.

9.6.2.  Fill Ink Eater Areas

You can use Fill Ink Eater Areas to fill the shapes created by the Create Ink Eater Areas function. You
can also use it to fill manually created shapes as Ink Eater Areas.

1. Create one or more shapes where you would like to define Ink Eater Areas.
2. Select the shapes and choose Prepress > Ink Eater Areas > Fill Ink Eater Areas

 

 
3. Set the Scan Area to Trim Box or Media Box. The Ink Eater Area will take everything inside the

selected page box into account.
4. Set the Direction of the gradation to be created, either vertical or horizontal.
5. Define the number of Gradation Stops, ranging from very low (5 stops) to very high (60 steps).
6. Define the Separations you want compensated. By default, all artwork separations will be selected.
7. Set the Density to define the amount of compensation, either low, medium or high.
8. Set the Falloff to define the transition in the compensation, either steep, medium or soft.
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9. Set the Minimum Ink Density for every separation in the Ink Eater Area.
10. You can enable the option to define a Maximum Total Area Coverage for the Ink Eater Area. When

enabled, you can set the percentage.
11. Click Fill Ink Eater Areas to fill all selected objects with Ink Eater Area gradients.

Note:  If you selected more than one object, the density of the gradients will be spread out
over the selected areas.

9.7.  Screening

In ArtPro+ you can set up object based screening. The document will contain a number of "screen sets"
which are saved in the file. Each of the screen sets contains specific ruling, angle, dot shape and DGC
information for each defined separation.

You can set up the screen sets in the Screening window. See Setting up Screen Sets in the Screening
window on page 316

When an object is selected, you can see what screen set is applied in the Screening Inspector. See
Applying a screen set to an object on page 318.

9.7.1.  Setting up Screen Sets in the Screening window

In the Screening window, you can define a number of screen sets. Each screen set defines the ruling,
angle, dot shape and DGC for each of the separations.

1. Open the Screening window.

•
Click the Screening button 

• Choose Prepress > Screening
• Use the shortcut Cmd+ALT+S (Mac) or Ctrl+ALT+S (Windows)
•

From within the Screening Inspector, click the Manage Screen Sets button .

 

 
2. In the Screen Sets list on the left, click the + button to add a new screen set, or the - button to

remove the selected screen set.
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Note:  If you create a new screen set, the currently selected screen set will be duplicated.
If no screen set is available, a default screen set using a 120lpi ruling and offset angles is
created.

3. Double-click the name of a screen set to rename it

Important:  The names used when creating a screen (e.g. Screen Set 1, Screen Set 2 ...) in
the Screening Inspector are placeholder names. It is strongly advised to use custom names.

4. Set the star in front of the screen set you want to use as Default screen set. The default is applied
to all unscreened objects when saving Normalized PDF, and to Mask objects when an opacity mask
is released.

Note:  When opening a Normalized PDF, the most used screen set will be the default
screen set, unless a default was defined already. When opening an ArtPro file, ArtPro+ will
determine the default screen set based on the screen name. If that doesn't work, the first
screen set will be used.

5. To edit one screen set, select it in the screen sets list, and change its settings on the right hand
side:
a) Set the Ruling in lines per inch (lpi). You can enter the ruling in lines per centimeter by adding the

unit "lpcm" to the value. It will be converted to lpi.
b) Set the Angle to be used for each separation.
c) Set the Dot Shape. The dropdown contains the most common Esko supported dot shapes, but

you can manually enter the dot shape name as well. You can easily search a specific dot shape by
typing the first letters.

d) Set a Dot Gain Curve DGC by selecting it from the dropdown, or by entering it manually. In case
you select a PressSync curve, you can also define a percentage between 20 and 70%.

e) You can set the Ruling, Dot Shape and DGC for all separations at once by using the All row.
6. To save all defined screen sets in a Screen Preset, for example to be reused in other documents,

click the Save Preset.... See Saving and loading Screen presets on page 318
7. To load the screen sets saved in a Screen Preset, click the Load Presets... button. See Saving and

loading Screen presets on page 318

Note:  Only Esko supported dot shapes are recognized. Other dot shapes will come in as
"Standard PDF". In PDF+, if no dot shape is specified, this will also be shown as "Standard PDF"
after saving and reopening the file.

Dot Shape and DGC from Automation Engine Server
If you are connected to an Automation Engine (so you see the green server status icon in the upper
toolbar - see Preferences on page 49), the Dot Shape and DGC fields in  the Screening dialog show the
available values from the server.

If the server gets disconnected, the description of the selected dot shape is removed, but the code
itself is retained.

For example "HD01 - HD Flexo C_MCAll MC07P_H - DuPont DFH - Flexible-HV" turns into "HD01" when
disconnected from the server.
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Saved server values of Dot Shape and DGC are kept in the document, even when reopening after
disconnecting the server. 
When there is no Automation Engine connection, or no Imaging Engine is attached to the Automation
Engine, the default Dot Shape and DGC lists are offered.

You can still enter any value manually.

Saving and loading Screen presets
A Screen preset contains a number of screen sets with all their settings. These Screen presets can be
used to reuse the same screening settings in other documents.

1. To save a Screen Preset, click the Save Preset... button.

If you have no Automation Engine connection, you will be managing the local presets as indicated
at the top of the dialog. You will see all locally saved presets, and any presets you save will be stored
locally.

If you have an Automation Engine connection, you will be managing the Server presets as indicated
at the top of the dialog. You will see all presets saved on the server, and any presets you save will be
stored on the Automation Engine Server as well.

Using the Search field you can filter the Screen presets shown.

a) Enter a unique name for the Screen preset and click the Save button to store it.
b) Select a Screen preset from the list or enter its name, and click Update to overwrite the saved

Screen preset with the current screen sets
c) Select a Screen preset from the list or enter its name, and click the - button to delete the

selected Screen preset
If you have no Automation Engine connection, you will be managing the local presets.

2. To load the screen sets saved in a Screen preset, click the Load Presets... button.

If you have no Automation Engine connection, you will only see the local presets. If you have an
Automation Engine connection, you will see both the local presets and the Server presets.

Using the Search field you can filter the Screen presets shown.

a) Select the Screen preset you want to load
b) Click Load

The screen sets in the preset will be merged with the current Screen presets: if a screen set with
the exact same name and settings already exists, the screen set will not be created.

9.7.2.  Applying a screen set to an object

You can see what screen set is applied in the Screen Set Inspector
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1. Select one or more objects.
2. Click the Screen Set Inspector at the right side of the Inspector bar.

The Screen Set Inspector will show what screen set is currently used, and lists all available screen
sets.

Note:  If the selected objects use different screen sets, the Screen Set Inspector button will
show "≠", and all screen sets used in the selection will have a checkmark.

3. Select a screen set to apply it to all selected objects.
4.

To edit the Screen Sets, click the Manage Screen Sets button . See Setting up Screen Sets in
the Screening window on page 316

Note:  If no Screen Set is applied on a linked Placed Art object, the screening that is applied on
the objects inside the external file will be used. You can overrule this by applying a Screen Set
to a Linked Placed Art object itself. In that case, all objects inside the Linked Placed Art will use
that screen set, without modifying the external file. To go back to the original screen sets, use
the Reset to original option in the Screen Set Inspector.

9.7.3.  Screening when merging separations

When merging separations in ArtPro+ 18 and earlier, the "source" screen settings (i.e. the screen
settings for the separation that was merged) are lost, and the screen settings of the "destination"
separation are used.

In ArtPro+ 18.0.1 and later, when merging a separation that creates a screening conflict, you'll get the
choice to keep the source screening, or to use the destination screening (the screen settings of the
separation you merge into).

Note:  For linked Placed Art, it is always the destination screening that will be used.

A screening conflict occurs when all the following conditions are met:

• screening is applied on objects using the merged separation.
• the source and destination separation have different settings (ruling, angle, …) within the same

screen set.
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If you decide to use the destination screening, the settings of the destination separation are used, and
the settings of the source separation are lost.

If you decide to keep the source screening, the objects that used the conflicting screen set will
have the settings of the source separation, but applied on the destination separation (the merged
separation). If there is already a screen set with these exact settings, this screen set will be used,
otherwise a new screen set is created.

Example:

Screen Set 1:

• Separation Ink1, ruling 120lpi, angle 75º
• Separation Ink2, ruling 120lpi, angle 75

Screen Set 2:

• Separation Ink1, ruling 120lpi, angle 45º
• Separation Ink2, ruling 120lpi, angle 75º

When merging Ink1 onto Ink2, if all objects using the separation Ink1 use screen set 1, there is no
conflict, since the settings for Ink1 and Ink2 are the same.

If there are objects using Screen Set 2, there is a conflict, since the settings for Ink1 and Ink2 are
different.

If you choose to use the destination screening, these objects will still use Screen Set 2, and the
settings of the destination separation Ink2 is used, i.e. an angle of 75º.

If you choose to keep the source screening, these objects will use a new screen set, where Ink2 uses
the settings of Ink1, i.e. an angle of 45º.

Note:  When using the Recolor function, you will not get this option. The destination screening
is always used. See Recolor on page 190

9.8.  Trapping

Using the Trapping tools, you can add traps.

There are two trapping modes: Trapping and Reverse Trapping.

Trapping will extend the lightest color into the darkest, to avoid white lines in case of misregistration.
See Trapping mode: Trapping on page 320

Reverse trapping will generate white lines, to avoid colors touching or overlapping in case of
misregistration. This is useful to prepare a job for Dry Offset printing (e.g. metal beverage cans) where
overprinting of inks is not allowed as the inks would contaminate each other on the blanket. See
Trapping mode: Reverse Trapping on page 329

9.8.1.  Trapping mode: Trapping

Using Automatic Trapping, you can create a special Automatic Trapping layer. See Automatic Trapping
on page 321

You can also manually create all Traps, using Manual Trapping. See Manual Trapping on page 324
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The most important difference is that Manual Trapping takes into account all visible objects, while
Automatic Trapping takes into account all objects in printing layers, even when hidden or on an
invisible layer. Processing Steps are not taken into account.

Important:  Expanding and manually editing an Automatic Trap layer (see Edit and Expand
Automatic Trap Layer on page 323) is still a step in the Automatic Trapping workflow, and
works on all objects in printable layers. Processing Steps are not taken into account.

Note:  When working in Normalized PDF Mode, Technical inks will not be excluded from
trapping. This behaviour is different than other Esko Trapping functionality, such as
PowerTrapper in DeskPack or PackEdge. For more information on PDF+ and Normalized PDF,
see PDF, PDF+ and Normalized PDF on page 57

Automatic Trapping
This is a typical Automatic Trapping workflow when working on a PDF+ document:

1. Set up your document to be trapped.
2. Set the general trapping settings, and generate the dynamic Automatic Trap Layer. See Starting

Automatic Trapping on page 322
A checkmark next to the Trapping button will indicate the Automatic Trap Layer is in sync

Attention:  A file can not contain both an Automatic Trap Layer and a Reverse Trap Layer.
Creating an Automatic Trap Layer will remove an earlier created Reverse Trap Layer.

3. Make any changes necessary

• You can change the general trapping settings
• You can add a Trap Tag to one or more objects, to overwrite the general trapping settings for

those objects. See Working with Trap Tags on page 332

Note:  You can also add Trap Tags before you start Automatic Trapping.

• You can still modify your document, e.g. remove, move or add objects

Any of these changes will result in the Trapping Layer to be out of sync. To continue, update the
Trap Layer. See Updating the Automatic Trap Layer on page 323

4. Using Trap Tags and updating the Automatic Trap Layer you can finetune the trapping to your liking.
However, if you prefer to manually tweak certain traps, you can do so by expanding the Automatic
Trap Layer and manually edit the traps. See Edit and Expand Automatic Trap Layer on page 323.

Warning:  If you expand the Automatic Trap layer, it is no longer a special "Automatic
Trap" layer: you will no longer see if the trap layer is in sync, and won't be able to update it
anymore.

When working on a Normalized PDF, you won't be able to use Trap Tags, and the Automatic Trapping
settings are not saved in the document. This means you can only use Automatic Trapping within one
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session. After saving and reopening the file, you won't be able to change the Trap Settings or to update
the Automatic Trap Layer.

Starting Automatic Trapping
To start Automatic Trapping:

1. Open the document you want to trap
2. Open the Trapping dialog

•

Click the Trapping button , or
• Choose Prepress > Trapping..., or
• Use the shortcut Cmd+Alt+T (Mac) or Ctrl+Alt+T (Windows).

Note:  If the document doesn't contain a Trap Layer yet, the "Update Trap Layer" shortcut
Cmd+T (Mac) or Ctrl+T (Windows) will also open the Trapping dialog.

Set Trapping Mode to Trapping and select the Automatic tab.

 

 

The Trapping dialog will indicate how many objects have a Trap Tag set. See Working with Trap Tags
on page 332

3. Set the Trapping and Pullback Settings to be used. For more information on the Trapping / Pullback
settings, see Trapping / Pullback Settings on page 325

4. Define the size of Gaps you want to automatically close.

Closing larger gaps might slow down trapping, especially for documents with many complicated
paths.

5. If you want to allow Trap Overshoot, enable Allow overshoot. See also Trap Overshoot on page 329
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6. You can enable Trap highlights for flexo print to trap small color differences (that would normally
not be trapped), as these color differences might become much bigger by the DGC. When the option
is enabled, you can set First Printable Dot, Print as and Range
 

 

If the values do not match the values in the Flexo Print Preview section in Quality Control, you can
click the link to sync the values, so the values in the Trapping dialog are modified. If different values
are used when trapping, the values in the Flexo Print Preview section are changed accordingly. See
also Flexo Print Preview on page 105

7. Click Create Trap Layer

Note:  If your document already contains an Automatic Trap Layer, the button will show
Update Trap Layer. See Updating the Automatic Trap Layer on page 323

A new layer "Trap Layer 1" is created in the Layers list. Its type will be "Automatic Trap Layer", and it will
contain all trapping objects.

Attention:  A file can not contain both an Automatic Trap Layer and a Reverse Trap Layer.
Creating an Automatic Trap Layer will remove an earlier created Reverse Trap Layer.

Automatic Trapping takes into account all objects in printing layers, even when hidden or on an
invisible layer. As soon as you click the Create Trap Layer button, hidden objects will become visible,
and hidden but printing layers will become visual.

Non-printing layers and Processing steps will not be taken into account.

Updating the Automatic Trap Layer
Any change to the document or trap settings will result in the Trapping Layer being out of sync.
Updating it will recalculate the Automatic Trap Layer.

There are different ways to update the Trap Layer:

• Choose Prepress > Update Trap Layer

• Use its shortcut Cmd+T (Mac) or Ctrl+T (Windows)

• Open the Trapping dialog and click Update Trap Layer

The Automatic Trap layer will be in sync again, indicated by a blue checkmark 

Edit and Expand Automatic Trap Layer
If Automatic Trapping in combination with Trap Tags still doesn't get you the result you want, you can
expand the Automatic Trap Layer and manually edit the traps.
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Warning:  If you expand the Automatic Trap layer, it is no longer a special "Automatic Trap"
layer: you will no longer see if the trap layer is in sync, and won't be able to update it anymore.

1. Open the Trapping dialog

• Click the Trapping button, or
• Choose Prepress > Trapping..., or
• Use the shortcut Cmd+Alt+T (Mac) or Ctrl+Alt+T (Windows).

2. Select the Manual tab
3. Enable Edit and Expand Automatic Trap Layer
4. Click the Enter Trapping Mode button.

If the Automatic Trap Layer is out of sync, it will first be updated. See Updating the Automatic Trap
Layer on page 323

The Automatic Trap Layer will become a regular layer, and you will enter Trapping Mode as when using
Manual Trapping. You can use the Manual Trapping tools to modify or create traps. See Manual Trapping
on page 324

Important:  Expanding and manually editing an Automatic Trap layer is still a step in the
Automatic Trapping workflow, and works on all objects in printing layers. Processing Steps are
not taken into account.

Manual Trapping
Using the Trapping tool, you can add traps. Manual trapping works on all visible objects.

1. Open the Trapping dialog:

•

Click the Trapping button , or
• Choose Prepress > Trapping..., or
• Use the shortcut Cmd+Alt+T (Mac) or Ctrl+Alt+T (Windows).

2. Select the Manual tab.
3. Select Add a new layer
4. Define the size of Gaps you want to automatically close, and click Enter Trapping Mode.

• All layers are grouped in one single layer named "Artwork"
• Functions not relevant for trapping will not be available. For example Page Boxes are hidden,

Separations can be viewed but not edited, other tools except Densities and Dimensions are
disabled, Compare in Quality Control is disabled, etc.

• The Trapping settings are shown at the bottom of the workspace. See Trapping / Pullback
Settings on page 325

5. While in Trapping mode, you have different tools available from the tool selector to create your
traps.
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1. The Trap tool and Trap Similar tool, shortcut T. When switching to Trapping mode, the Trapping
tool will be activated automatically. See Trapping tool on page 327

2. The Trap + Pullback and Trap + Pullback Similar tool, shortcut B. See Trap and Pullback tool on
page 328

3. The Pullback and Pullback Similar tool, shortcut B. See Pullback tool on page 327
4. The regular Densities and Dimensions tool, shortcut D. See Densities on page 116 and

Dimensions on page 115
5. The regular Zoom and Pan tool, shortcut Z. See Zoom tool on page 94 and Pan tool on page 94

6. If you are done creating traps, you can exit Trapping mode:

•

click the Trapping button  again
• click the Leave Trapping Mode button in the side panel
• use the shortcut Cmd+T (Mac) or Ctrl+T (Windows) to

Trap objects will use a Darken blend mode, and are placed in a layer "Trap Layer x"

Trapping / Pullback Settings

When in Trapping mode, you can set the Trapping and/or Pullback settings at the bottom of the
workspace.
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• Distance: the size for the trap. Enter a number to use the default unit, or add the unit and it will be
converted to the default unit. See Preferences on page 49.

• Truncate: ArtPro+ can truncate the trap so that it doesn’t stick out on another color. There are two
truncation modes:

• On Edge (A): when a portion of a trap comes too close to the contour of another object, it is
truncated on the other object’s edge.

• On Center (B): when a portion of a trap comes too close to the contour of another object, ArtPro
+ limits it to half the distance between the trapped object and the other object.

 

 

• Joins:

• A Mitered corner closes in one point. A Miter limit of 4 is used. This means the corner will be cut
off at a distance of 4 times the trapping distance.

• A Rounded corner joins the corners with a circular arc with the diameter equal to the trapping
width.

• End Caps: This option specifies how to shape the ends of an open trap.

• Square: this option ends the trap at right angle to the adjoining object.

• Round : this rounds the ends of the trap. This option is typically only used in combination with
white knockout (reverse trapping).

• Image Traps: This option specifies how images are trapped.

• Original Data: when spreading a (clipped) image, the underlying image data is used to create the
trap. When there is no underlying image data, it will create an empty trap.

• Extend Data: The image data along its clipping path is automatically extrapolated to ensure the
trap looks as expected, even if there is no clipped image data outside the visible image.

• Keep: the color that will be kept (i.e. not pulled back) when applying a pullback. Hold Shift to select
multiple colors.

• If the Link option is enabled, Trapping and Pullback parameters are kept the same.
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Trapping tool
The Trap tool allows to create traps from one object to another.

Using the Trap Similar tool applies the trap to the edge you selected, but also to all edges of the same
color combination. You can temporarily switch to the Trap Similar tool by holding the Shift key.

The shortcut T will toggle between Trap and Trap Similar.

• Click and drag from one object to a neighbouring object to create a trap.
• Click and drag in the opposite direction to change the direction of a trap. You don't need to remove

it first.
• After changing the Trapping Settings, you can click and drag over an existing trap again to apply the

new settings.
• Hold the ALT key to remove a trap. The cursor will change to a cross. Click and drag over an existing

trap to remove it.

Pullback tool
The Pullback tool allows to create pullbacks. An ink pull back keeps away all but the darkest ink of a
color area composed of multiple inks that borders to a very light background.

It prevents individual inks from the composed color to become visible on the background due
to registration errors during the printing process. Ink pull backs are also known as “Cutbacks” or
“Keepaways”.

The example below shows an object with 100% dark blue and 50% magenta on an empty background
(1). If misregistration occurs, a magenta line might be visible (2). 50% magenta is pulled back and a fine
line of 100% dark blue remains (3). In this case, misregistration will not cause any magenta lines (4). The
color that remains (dark blue) is the Keep ink.

 

 

Using the Pullback Similar tool applies the pullback to the edge you selected, but also to all edges of
the same color combination. You can temporarily switch to the Pullback Similar tool by holding the
Shift key.

The shortcut P will toggle between Pullback and Pullback Similar.
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• Set the Keep ink (i.e. the ink that is not pulled back) in the Pullback Settings by clicking the ink you
want to keep. Shift-click to select more than one ink. You can also press K to open a separate Keep
Color selector.

• Click and drag from one are to a neighbouring are to create a pullback. If a pullback is possible, the
arrow you drag will have a solid line. Otherwise, it will be dashed.

• After changing the Pullback Settings, you can click and drag over an existing trap again to apply the
new settings.

• Hold the ALT key to remove a pullback. The cursor will change to a cross. Click and drag over an
existing pullback to remove it.

In case the "rich" color touches a colored background (e.g. yellow), it is advised to use Trap and
Pullback. See Trap and Pullback tool on page 328

Trap and Pullback tool
The Trap and Pullback tool allows to create pullbacks and a trap in the same pass.

A normal pullback keeps away all but the darkest ink of a color area composed of multiple inks.
However, if this "rich" color borders another (light) color (1), the pullback will pull back the other colors
(2). In case of misregistration of the dark blue, a white line might become visible (3). Trap and Pullback
will pull back all inks except the Keep ink, and trap the light color in the pullback (4), so that no white
lines can be seen in case of misregistration. (5)

 

 

Using the Trap and Pullback Similar tool applies the trap and pullback to the edge you selected, but
also to all edges of the same color combination. You can temporarily switch to the Trap and Pullback
Similar tool by holding the Shift key.

The shortcut B will toggle between Pullback and Pullback Similar.

• Click and drag from one are to a neighbouring are to create a trap and pullback. If a trap and
pullback is possible, the arrow you drag will have a solid line. Otherwise, it will be dashed.

• After changing the Trapping or Pullback Settings, you can click and drag over an existing trap and
pullback again to apply the new settings.

• Hold the ALT key to remove a trap and pullback. The cursor will change to a cross. Click and drag
over an existing trap and pullback to remove it.

328



9ArtPro+

Trap Overshoot
In ArtPro+ you can apply a manual overshoot: a trap that goes over 2 edges, going across a thin area of
a different color.

Since it is not possible to drag a trap line across more than one edge (the trap line will be dashed,
indicating the trap can not be applied), creating a trap overshoot will be done in different steps.

 

 

1. First create the trap between the two adjacent objects.
2. This is the resulting trap, set to clip "on edge"
3. Click and drag the trap line from the first to the third object, indicating the overshoot.
4. The overshoot is calculated, resulting in the cyan being trapped into the yellow and the magenta.

Note:  You can only apply overshoot if the trap was added in the same trapping session.

9.8.2.  Trapping mode: Reverse Trapping

Reverse Trapping can be used to generate white lines to avoid colors touching or overlapping in case of
misregistration. This can be useful to prepare a job for Dry Offset printing (e.g.: metal beverage cans)
where overprinting of inks is not allowed as the inks would contaminate each other on the blanket.

Reverse Trapping can't be done in manual trapping mode, it is an exclusive part of Automatic Trapping

This is a typical Reverse Trapping workflow when working on a PDF+ document:

1. Set up your document to be trapped.
2. Set the general trapping settings, and generate the dynamic Reverse Trap Layer. See Starting

Reverse Trapping on page 330

A checkmark next to the Trapping button will indicate the Reverse Trap Layer is in sync 

Attention:  A file can not contain both an Automatic Trap Layer and a Reverse Trap Layer.
Creating a Reverse Trap Layer will remove an earlier created Automatic Trap Layer.

3. Make any changes necessary
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• You can change the general Reverse trapping settings
• You can add a Trap Tag to one or more objects, to overwrite the general trapping settings for

those objects. See Working with Trap Tags on page 332

Note:  You can also add Trap Tags before you start Reverse Trapping.

• You can still modify your document, e.g. remove, move or add objects

Any of these changes will result in the Trapping Layer to be out of sync. To continue, update the
Trap Layer. See Updating the Reverse Trap Layer on page 332

When working on a Normalized PDF, you won't be able to use Trap Tags, and the Reverse Trap settings
are not saved in the document. This means you can only use Reverse Trapping within one session. After
saving and reopening the file, you won't be able to change the Reverse Trap Settings or to update the
Reverse Trap Layer.

Starting Reverse Trapping
To start Reverse Trapping:

1. Open the document you want to trap
2. Open the Trapping dialog

•

Click the Trapping button , or
• Choose Prepress > Trapping..., or
• Use the shortcut Cmd+Alt+T (Mac) or Ctrl+Alt+T (Windows).

Note:  If the document doesn't contain a Trap Layer yet, the "Update Trap Layer" shortcut
Cmd+T (Mac) or Ctrl+T (Windows) will also open the Trapping dialog.

Set Trapping Mode to Reverse Trapping
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The Trapping dialog will indicate how many objects have a Trap Tag set. See Working with Trap Tags
on page 332

3. Set the Trapping settings to be used.
a) Distance: the size for the trap. Enter a number to use the default unit, or add the unit and it will

be converted to the default unit. See Preferences on page 49.
b) Joins: A Mitered corner closes in one point. A Miter limit of 4 is used. This means the corner will

be cut off at a distance of 4 times the trapping distance. A Rounded corner joins the corners
with a circular arc with the diameter equal to the trapping width.

c) Trap Position: You can use the slider or manually enter a value between 50 and 100. 100% will
position the Reverse Trap object completely in the selected direction (in most cases into the
lightest ink). 50% will place the trapping object 50% in both directions (i.e. centered on the
edge)

4. Define the size of Gaps you want to automatically close.

Closing larger gaps might slow down trapping, especially for documents with many complicated
paths.

5. Click Create Trap Layer

Note:  If your document already contains a Reverse Trap Layer, the button will show Update
Trap Layer. See Updating the Reverse Trap Layer on page 332

A new layer "Reverse Trap Layer 1" is created in the Layers list. Its type will be "Automatic Trap Layer",
and it will contain all trapping objects.

Attention:  A file can not contain both an Automatic Trap Layer and a Reverse Trap Layer.
Creating a Reverse Trap Layer will remove an earlier created Automatic Trap Layer.

Reverse Trapping takes into account all objects in printing layers, even when hidden or on an invisible
layer. As soon as you click the Create Reverse Trap Layer button, hidden objects will become visible,
and hidden but printing layers will become visual.
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Non-printing layers and Processing steps will not be taken into account.

Updating the Reverse Trap Layer
Any change to the document or trap settings will result in the Reverse Trap Layer being out of sync.
Updating it will recalculate the Reverse Trap Layer.

There are different ways to update the Reverse Trap Layer:

• Choose Prepress > Update Trap Layer

• Use its shortcut Cmd+T (Mac) or Ctrl+T (Windows)

• Open the Trapping dialog and click Update Reverse Trap Layer

The Reverse Trap layer will be in sync again, indicated by a blue checkmark 

9.8.3.  Working with Trap Tags

A Trap Tag is a property attached to a group or object and saved in your document, allowing you to
overwrite the general trapping settings during Automatic Trapping or Reverse Trapping.

There are two types of Trap Tags: Trapping Tags are taken into account when using Automatic
Trapping, while Reverse Trapping Tags are taken into account when using Reverse Trapping

Trap Tags can be created before starting Automatic Trapping or Reverse Trapping, or after the Trap
Layer was created. In the latter case, you will have to update the Trap Layer to see the result. See
Updating the Automatic Trap Layer on page 323 or Updating the Reverse Trap Layer on page 332

Note:  Trap Tags are not available when working on a Normalized PDF.

1. Select the group(s) or object(s) you want to assign a Trap Tag to.
2. Open the Trap Tag Inspector
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3. Set the Trap type: either Trapping Tag or Reverse Trapping Tag.
4. Define the settings for the Outer Edges, i.e. edges between the selected group or object and other

objects in your document

• If the dropdown is empty ("No Tag") , the 'default' action will be used. This can be the default
trapping settings, but can also be the Trap Tag of the parent group: if e.g. a group has a Trap
Tag to set Trap to "Always", an object within that group can have a Trap Tag to set Trap to
"Automatic", whereas "No Tag" would apply the Trap Tag of the group.

• Set Trap to decide if the edges should Always be trapped, Never be trapped, or Automatic to let
ArtPro+ decide.

• Set Pullback (Trapping Tag only) to decide if the edges should Always be pulled back, Never be
pulled back, or Automatic to let ArtPro+ decide.

• Set Direction to decide if the edges should always be trapped Inwards, Outwards or Automatic,
to let ArtPro+ decide.

• Enable Distance to set a fixed distance for the traps. You can click the x to remove the input.
• Set the Trap Position (Reverse Trapping Tag only) to set the position of the Trap by entering a

value between 50 and 100. 100% will position the Reverse Trap object completely in the selected
direction (mostly into the lightest ink). 50% will place the trapping object 50% in both directions
(i.e. centered on the edge)

5. Define the settings for the Inner Edges, i.e. edges within the group or object. This can be e.g. two
adjacent objects in the same group, or the stroke and fill of a single object)

Note:  In the Object Browser, you can get an overview of all objects with Trap Tags. See Object
Browser on page 130

Objects or groups with a Trap Tag are marked with the Trap Tag icon  in the Breadcrumbs and in the
Object Browser.
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Changing a Trap Tag will result in the Trapping Layer being out of sync. To continue, update the Trap
Layer. See Updating the Automatic Trap Layer on page 323 or Updating the Reverse Trap Layer on page
332

9.9.  Warp

In ArtPro+ you can Warp objects based on an ArtPro GRID file or a PackEdge GRD file. You can also
create a Conical Grid in ArtPro+. See Create Conical Grid on page 336

Note:  If a structural design file is placed, you can use the Warp functionality to predistort
graphics. See Predistortion on page 477

1. Create a Conical Grid (see Create Conical Grid on page 336) or choose Prepress > Warp > Place
Warp Grid... or File > Place and navigate to the .grid or .grd file you want to place

• The grid file is always embedded. No link to the original Grid file is kept.
• The Source Grid is shown

• The Warp Grid object is placed in a "Warp Grid" layer

• The Grid contours are colored in a green "Bleed" colorant.
• The Warp Grid object is positioned at the center of the trim box, except in the Shrink Sleeve

method. See Shrink Sleeve Warp on page 339 . You can move it using the Transform tool.

Note:  A Grid is recognized as a Shrink Sleeve Grid if the source grid is not rectangular,
but vertically symmetric and with no deformation on the horizontal grid lines, and the
destination grid is rectangular.

2. Select and position the objects you want to warp correctly on the Grid. Do NOT select the Warp Grid
object.

3. Open the Warp dialog:

• click the Warp button in the upper toolbar, or
• choose Prepress > Warp > Warp..., or
• use its shortcut Cmd+Shift+D (Mac) or Ctrl+Shift+D (Windows)

4. Define all settings for the Warp
 

 
a) Define the Warp Grid you want to use. If there is only one grid placed, this dropdown will be

disabled.
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b) Set the Minimum Image Resolution. This defines the minimum resolution of images created
by the warping. If an image has a resolution above the minimum, it will keep its resolution after
warping.Warping images with a lower resolution as well as gradients will result in an image at the
Minimum Image Resolution.

c) Set the amount of Noise to be added for gradients, which are replaced by images during
warping.

d) When warping, any object or part of an object that is outside of the source grid is cut away. Use
the Warp Outside Grid for distance so that objects outside of the source grid but within this
distance are not cut away after warping.

Note:  If you want to Warp using the same settings as the previous warp, you can skip this
step by choosing Prepress > Warp > Warp using Last Settings or its shortcut Cmd+Shift
+Alt+D (Mac) or Ctrl+Shift+Alt+D (Windows)

5. Click Warp
 

 

• The result of the warp action is Warped Art

• Objects outside of the Source Grid expanded by the Warp Outside Grid distance are cut away.

• After warping, the Destination Grid is shown instead of the Source Grid.

• If you select a warped object, you can click Unwarp to return it to its unwarped version.

• If you select a warped object, you can click Expand to replace it by regular objects: paths,
images, etc.
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Note:  As long as the document contains at least one Warped Object, the Destination Grid
is shown, even if you place a new Grid. Unwarp or Expand all Warped Objects to show the
Source Grid again.

9.9.1.  Create Conical Grid

You can create a Conical Grid in ArtPro+. The source grid is a rectangular shape, while the destination
grid is a conical shape.

There are two ways to create the grid:

• Based on its dimensions (radius, height, …). See Create Conical Grid based on the Dimensions on
page 336

• Based on the Conical Label Outline. See Create Conical Grid from Conical Label Outline on page 337

Create Conical Grid based on the Dimensions
1. Choose Prepress > Warp > Create Warp Grid...

 

 
2. Select the orientation : upwards or downwards.
3. Define if you want to set the length of the grid by entering the Total Width, the Angle or the Top

Arch Length. The technical drawing is changed accordingly. Enter the value, either in mm or in
degrees.

4. Enter the Large Radius and Height to complete the dimensions of the destination grid
5. Set the Baseline Shift. The Baseline Shift defines at what position (in % of the height) the Source

Grid and Destination Grid have the same length, and thus deformation will be minimal. Changing the
Baseline Shift changes the width of the Source Grid.
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6. Click Create

The Grid is created, and positioned centered on the selection.

If nothing is selected, the grid is placed centered on the Trim Box. The grid can now be used to
warp. The Grid is named "Warp Grid". If that grid already exist, a number is added to the name: Warp
Grid 2, Warp Grid 3, etc.

If you have a technical drawing of your Destination Grid as an object in your document, you can select
it and click the Calculate from Selection button. The settings will be calculated to match the technical
drawing as closely as possible

Create Conical Grid from Conical Label Outline
1. Based on a technical drawing of the Source Grid, create the Label Outline Curves. The Label Outline

Curves define the top and bottom edges of the label. Optionally you can include vertical lines to
define warp grid sections, so that the selected art is warped based on the section it is located on.
This will result in warped art better fitting their sections.

The Label Outline Curves should be two separate smooth, open, non-intersecting paths that follow
the top and bottom edges of the label.
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Vertical lines should be straight lines (no curves) and open paths. The begin and end point should
not intersect with but must be in the proximity of the top and bottom path.

Note:  Selecting vertical lines on the left and/or right edge is not necessary, since these
lines are automatically added in the grid.

2. With the Label Outline Curves (and optionally vertical lines) selected, choose Prepress > Warp >

Create Warp Grid... and select From Conical Label Outline
 

 
3. Set the Baseline Shift. The Baseline Shift defines at what position (in % of the height) the Source

Grid and Destination Grid have the same length, and thus deformation will be minimal. Changing the
Baseline Shift changes the width of the Source Grid.
 

338



9ArtPro+

 
4. The calculated size of the Source Grid is shown. If you want to use a different size, enable Resize

Grid and enter the Width and Height you want. The Source and Destination Grid will be scaled to
match those dimensions.

5. Click Create

The Grid is created, and positioned centered on the selection. The grid can now be used to warp.
The Grid is named "Warp Grid". If that grid already exist, a number is added to the name: Warp Grid 2,
Warp Grid 3, etc.

9.9.2.  Shrink Sleeve Warp

ArtPro+ can recognize Shrink Sleeve Grids, and adapt to the shrink sleeve method automatically.

This method is only valid for circular, symmetrical bottles, since it is based on the assumption that
shrinking is done equally around the bottle.

To achieve equal distortion on each side of the shape, the Warp Grid is automatically moved
horizontally and centered on the 'visual center' of the selection.

A Grid is recognized as a Shrink Sleeve Grid if:

• the source grid is not rectangular.
• the source grid is vertically symmetric
• the horizontal lines of the source grid are straight, not deformed.
• the destination grid is rectangular.

9.10.  Preflight

Preflighting a document is checking if the document is ready for output.

To preflight documents, you use Preflight Profiles. A Preflight Profile is a collection of criteria, which a
document should meet to be outputworthy. For each criterion, you can specify:
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• If it should be checked or not.
• How it should be listed in the Preflight Report, i.e. as a "warning" or "error" if a deviating property is

detected in the document.
• If an error or warning can be signed off.

Moreover, some criteria allow you to specify how detected problems, if any, should be fixed.

An example of a criterion is RGB colors. If you do not want RGB colors in your documents, you can
check this and have all RGB colors converted to CMYK.

9.10.1.  Running a Preflight

You can run a Preflight on any PDF file.

1. Select Prepress > Preflight
 

 
2. Select the Preflight Profile you want to use.

You can use a Stardard Preflight Profile, a Local Preflight Profile or (if you have a Server connected)
a Server Preflight Profile. For more info on how to manage your Preflight Profiles, see Manage
Preflight Profiles on page 341

Underneath a description of the selected Preflight Profile is shown.
3. Click Preflight

When the Preflight is done, the Message drawer opens automatically.
4. You can then use the Message drawer to inspect the Preflight results

a) The Message drawer shows all Errors (red), Warnings (orange) and Messages (green) in this order.
If the same error was caused by different objects, you can expand or collapse the error list by
clicking the triangle in front of it.

b) Click an entry in the list to select it. The object(s) that caused the selected error will also be
selected in your document. If the Preflight message refers to a part of an object (e.g. text in a
barcode) you will see an area select.

c)
If the Zoom to Selection  option is enabled, clicking an entry displays the selected object(s)
as big as possible in the active window.
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d) You can click the triangle in the top bar to see the Preflight Profile that was used to Preflight,
along with its description. Click the Generate Report button to generate a PDF report of the
Preflight. Click Check Again to redo the Preflight with the same Preflight Profile.

Restrictions:

• Preflight only runs on the current page of Multipage PDF files
• You can run a Preflight on Normalized PDF files, but this will only perform the checks on the

document, not the automatic fixes.

9.10.2.  Manage Preflight Profiles

Select Prepress > Manage Preflight Profiles to open the Preflight tab of the Preferences. You can also
open the Preferences and switch to the Preflight tab then. See Preferences on page 49

 

 

You can have three different sets of Preflight Profiles:

• Standard Profiles: a set of default Preflight Profiles that can not be renamed, reordered or
removed.
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• Local Profiles. If you have Enfocus Pitstop Pro installed, then any Preflight Profile saved locally in
Enfocus PitStop Pro is also available in the Local Profiles folder in ArtPro+ (and vice versa).

• If you have a Server connection, the Preflight Profiles found on the server and visible in Automation
Engine's PitStop Profile Editor, are shown in Server Profiles

If you disable a category (using the checkbox on the right hand side), the Preflight Profiles in it will not
be available when selecting a Profile to run a Preflight.

• Double-click a Preflight Profile name or folder to change its name.
• Click and drag to change the order of Preflight Profiles and folders, or to put Preflight Profiles in or

out a folder.

When dragging, the default action can be to move (e.g. from one subfolder to another) or to copy
(e.g. from Server Profiles to Local Profiles). You can use the standard modifier keys to force copying
(Alt key) or moving (Cmd on Mac, Shift on Widows).

• Click the  button or choose Add Group from the fly-out menu to add a (sub)folder
• Click the + button or choose Create Preflight Profile... from the fly-out menu to create a new

Preflight Profile from scratch. The Preflight Profile Editor will open. See The Preflight Profile Editor
on page 342

• Click the - button or choose Remove from the fly-out menu to remove the selected folder or
Preflight Profile

• Double-click the icon of a Preflight Profile or choose Edit Preflight Profile... from the fly-out menu
to edit the Preflight Profile in the Preflight Profile Editor. See The Preflight Profile Editor on page
342

• Select a Preflight Profile and choose Duplicate from the fly-out menu to make a new Preflight
Profile based on an existing one. It will immedately be opened in the Preflight Profile Editor. See
The Preflight Profile Editor on page 342

• From the fly-out menu, select Import Preflight Profile to import a Preflight Profile saved as a .ppp
file into the Local Profiles.

• From the fly-out menu, select Import Group to import a folder containing .ppp files as a folder in the
Local Profiles.

• From the fly-out menu, select Export to save the selected Preflight Profile as a .ppp file, or to save
the selected folder as a folder containing .ppp files.

Note:  You can not rename or reorder Standard Profiles. However, you can export a Standard
Profile as a .ppp file and then import it into the Local Profiles.

9.10.3.  The Preflight Profile Editor

Using the Preflight Profile Editor, you can create and modify Preflight Profiles

SETUP
In the General Setup you can define the Name, Author, Company and Description for the Profile.

In the Permissions section you can lock the Preflight Profile with a password.

You can enable or disable sign-off.

If you want to use Color Management or Restrictions on your Preflight Profile, you can set this up in the
appropriate tabs.
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CHECK ON
In the CHECK ON categories, you can define what checks need to be performed. Clicking any of the
categories will show the checks you can use (e.g. "Color RGB" under "Color"). By double-clicking one of
the properties you can add it to your Preflight Profile.

For every check, you can define the severity (Warning or Error) and customize the report message.

Enfocus Action Lists
Enfocus Action Lists (.eal) can not be used directly in ArtPro+.

However, you can create a Preflight Profile, and import the Action List in its Action Lists section. By
running that Profile, all checks and fixes of the Action List will be run.

You can also create your own Enfocus Action Lists using the Action Lists section in the Preflight Profile
Editor.

More information on Preflight Profiles and Action Lists
For more elaborate documentation on the creation of Preflight Profiles and Action Lists, we refer to
the PitStop Pro documentation, available from https://www.enfocus.com/en/support

You can also search for known issues with Enfocus Preflight and potential solutions in the Enfocus
Knowledge Base

9.11.  Step & Repeat

There are two Step & Repeat methods available in ArtPro+.

• Creating a Grid. See Grid Step & Repeat on page 343

• By opening an .MFG file or a Layout CF2 file. See Step & Repeat based on an MFG or CF2 file on page
358

9.11.1.  Grid Step & Repeat

Using the Make Grid function, you can create a Step & Repeat of a placed PDF file.

For more information on working with placed PDF files, see Working with Placed Art on page 219

1. Select the Placed Art you want to repeat.

Note:  If more than one placed PDF is selected, multiple Grids will be created on top of each
other.

2. Use the Make Grid function

• Select Prepress > Step & Repeat >  Make Grid
• Use the Make Grid button in the Placed Art Inspector
• Use the shortcut Cmd+Alt-G (Mac) or Ctrl+Alt+G (Windows).

A 2 x 2 repetition of the selected Placed Art is created, using the Trim Box (when available) as step
distance. You can modify the Grid using the Grid Inspector. See The Grid Inspector on page 344
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When creating a grid from a Placed Art object, by default the Processing Step Cutting layer will be used
as Die Shape. If the Placed Art object contains cutting lines as part of the Structural Design, the Die
Shape can be set to "cutting layer".

If no Special Type Cut layer is available, the Trim Box is used instead. You can change the Die Shape in
the Placed Art Inspector. See Placed Art Inspector on page 223

When selecting a Grid, the Placed Art inspector will allow to change the initial Orientation of the one-
ups in this grid. Their orientation within the layout can be changed further by the option Head Turn.
See Placed Art Inspector on page 223

You can use the Layout Inspector to define settings (e.g. the Clip Bleed At distance) that are applied to
all Grids in your document. See The Layout Inspector on page 347

The Grid information is saved in the PDF file, so you can edit all parameters after reopening the file.

Note:  Since Step & Repeat is using Placed Art, the same restrictions apply: you can not place a
PDF if the current document is a Normalized PDF file.

The Grid Inspector
In the Grid Inspector you can change the selected S&R Grid.
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1. The Die Shape defines the die shape that is used on the PDF. Use the dropdown to select:

• a Page Box defined in the Placed Art
• The Processing Step Cutting layer, when available
• Any of the separations in the Placed Art. In that case, the die shape is determined by the joint

shape of all applicable objects in that separation.
2. The Station Rotation can be used to rotate the one-ups over 0º, 90º, 180º or 270º. You can manually

enter any degree. If the Placed PDF was rotated when you create the grid, its rotation will be
entered here.

3. The Cell Size shows the station size, i.e. the size of the one-up, based on the current Die Shape.
4.

You can define the number of horizontal  and vertical  repeats
5.

Using the dropdown menu, you can switch between defining the step distance horizontal  or

vertical , and defining the gap distance horizontal  or vertical .
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• Setting the gap means defining the distance between the right (or bottom) side of the previous
step, and the left (or top) side of the next step. The step distance will be the (vertical or
horizontal) size of the one-up, plus the size of the (vertical or horizontal) gap.

• Setting the step means defining the distance between the left (or top) side of the previous step,
and the left (or top) side of the next step. When setting the step distance, the size of the one-up
is not taken into account.

6. Define the Head Turn
 

 
. You can choose between

• No Head Turn
 

 
• Head Turn on column

 

 
• Head Turn on row
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• Head Turn on row and column
 

 
7. Define the staggering. See Stagger on page 352
8. If needed, you can Convert to Static Grid. See Convert to Static Grid on page 357
9. Set the Bleed settings. See Working with bleed on page 348

The Layout Inspector
As soon as your document contains at least one Step & Repeat Grid, the Layout Inspector will be
available. Settings made in the Layout Inspector apply to all Grids in your document.

Continuous Printing: Enable this option if you are working in a continuous design, i.e. a job to be
printed in web print.

Note:  When creating Plate Cutting Paths, the Continuous Printing setting is enabled
automatically.

When Continuous Printing is enabled:

• you can define the Web Direction: either vertical or horizontal.

• The outer bleed on your Step & Repeat Grid on the top and bottom (for vertical stagger) or left and
right (for horizontal stagger) sides will be calculated as if extra grid cells are present outside those
sides. Working with bleed on page 348

• The Web Direction, Plate Circumference and Plate Cutting Paths become available in Flexo Print
Preview. See Flexo Print Preview on page 105

• The Web Direction setting is used when creating Plate Cutting Paths. See Create Automatic Plate
Cutting Paths on page 372

The Plate Circumference indicates the circumference of the plate using the currect settings.

347



9 ArtPro+

Note:  In ArtPro+ 22.07 and earlier, each grid could have its own bleed settings ("Clip Bleed At"
and "Remove outer bleed" - now: Continuous Printing). As this is no longer possible in ArtPro
+ 22.11 and later, when opening such a file a warning will be shown. The Clip Bleed At field will
show an unequal sign ≠.

Working with bleed
When using a placed PDF file as one-up, the available "bleed" is the artwork between the Trim Box and
the Media Box. Information outside the Media Box is never used.

In this example one-up, the yellow is outside the Media Box (and will not be used in the Repetition), the
blue is between Media Box and Trim Box (and thus "bleed"), and the green is inside the Trim Box.

 

 

The example underneath shows a Repetition of this file, with a big step distance, and no Clip Bleed. As
you can see, the bleed is limited to the Media Box (no yellow is shown).
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If you would repeat the same file, using the (Trim Box) size of the one-up as step distance (i.e. set the
gap distance to zero), the bleed of the topmost one-up would overlap the underlying one-ups, as shown
in this example.

 

 

To avoid this, the Clip bleed at option in the Grid Inspector can be used. See The Grid Inspector on page
344

When enabled, a clipping mask is applied around the one-up, based on the defined Die Shape (see
Placed Art Inspector on page 223), by default using a centerline algorithm.

The Clip Bleed at distance can be entered to offset the clipping mask from the Die Shape, either
positive (to the outside) or negative (to the inside). Below the same example Repetition as above (no
gap), with Clip Bleed at enabled and set to 0mm.
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If Clip Bleed at is set at a positive value, bleed will become visible on the outside of the Repetition.

 

 

If two one-ups (or their bleed) would overlap (i.e. if the size of the Die Shape + the "Clip Bleed at"
distance is larger than the step distance), you can use the Bleed Overlaps buttons to define how the
bleed in between the one-ups should be calculated.

350



9ArtPro+

1. Clipped at Centerline
2. Left over right
3. Right over left
4. Top over bottom
5. Bottom over top

Clipped at Centerline
If Clipped at Centerline is selected, the clipping mask of both will be restricted to half way the overlap,
so the clipping masks don't overlap.

This centerline algorithm can be applied between two one-ups of the same grid, but also between one-
ups of different grids.

 

 

Left over right / Right over left / Top over bottom / Bottom over top
When using Left over right, Right over left, Top over bottom or Bottom over top, the bleed of one label
overlaps the bleed of the other, limited at the Clip bleed at distance. Below an example of the same
repetition as before, with bleed Left over right
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If you don't want all available bleed to overlap, you can set a Clip Overlap at distance.

• If the Clip Overlap at distance is smaller than the centerline clipping distance, the Clip Overlap at is
ignored, and centerline clipping is applied.

• If the Clip Overlap at distance is between the centerline clipping distance and the Clip Bleed at, the
overlapping bleed will be limited to the Clip Overlap at distance

• The Clip Overlap at distance can never be larger than the Clip Bleed at distance. Changing one of
these values can also modify the other. If you e.g. enter a Clip Overlap at distance larger than the
Clip Bleed at, the latter will be adjusted as well.

Stagger
Staggering allows to shift the 2nd, 3rd, ... row or column down or to the right.

:

1. Select the Direction in which you want to stagger the one-ups. From left to right, the choices are:
No Stagger, Stagger Columns, and Stagger Rows.

2. The stagger will be repeated for a number of rows or columns as defined in Restart after n
columns/rows. After that, the next one-up will be at the begin position again.

3. You can define the distance for staggering. By clicking the button you can switch between entering
the distance as a fixed value in the current units, or as a percentage of the one-up size.
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4. If Add partial stations  is enabled, the gaps created by staggering will be filled with partial labels
(print items) .

Examples:
No stagger:

 

 

Stagger Vertical, 50% distance, using a negative horizontal gap, Repeat After 2 columns:

 

 

Stagger Horizontal, fixed distance, using a negative vertical gap, Repeat after 3 rows:
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Same as above, with Add partial stations enabled:

 

 

Working with bleed on a staggered grid

For a generic explanation on how to set bleed, see Working with bleed on page 348

When using the Clip Bleed at option in a staggered repeat you can get undesired results. In the
example underneath you see a Repetition with Staggering, using a negative horizontal gap, using the
Trim Box as Die Shape. If the Clip Bleed at option is enabled, parts of the labels are clipped off.
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If Clip Bleed at is disabled, you get the result shown below:

 

 

In the example above, it would obviously make more sense to use a circular Die Shape, e.g. based on
the Processing Step Cutting layer or on a specific separation. In that case the Clip Bleed At is based
on the defined Die Shape. This allows to add bleed in between the labels, using the centerline in case
bleed might overlap.
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In case of a vertical or horizontal stagger, you can set the Continuous Printing option in the Layout
Inspector. When enabled, the outer bleed on the top and bottom (for vertical stagger) or left and right
(for horizontal stagger) sides will be calculated as if extra grid cells are present outside those sides.

 

 

356



9ArtPro+

Positioning the Grid
The Transformation Inspector, which you can use to change the position of the Grid, is slightly different
when selecting a Grid. See Transformation Inspector on page 164

The position of a Grid is based on 3 settings:

Attach to
The position of the Grid can be based on

• the Art Box
• the Bleed Box
• the Crop Box
• the Media Box
• the Trim Box
• another S&R Grid

Positioning
The way the Grid is attached, can be chosen by clicking and dragging the red square (representing the
Repetition) to the desired position on the gray square (representing the Attach To reference). Each
square has 9 reference points (top left center and right, middle left center and right, and bottom left
center and right), so you have 81 different ways of positioning the Grid.

In below example, the top center of the (bounding box of the) Grid will be placed on the left bottom
corner of the (bounding box) of the reference defined in the 'Attach to' field.

 

 

Offset
In the offset fields, you can move the Grid based on the defined position.

Convert to Static Grid
If you want to apply different one-ups within the same grid, you can convert the grid to a Static Grid
using the Convert to Static Grid button in the Grid Inspector.

In a Static Grid, you can no longer change the layout settings (count, step or gap, stagger) in the Grid
Inspector. You can still change the bleed settings. See Working with bleed on page 348. The Grid
remains a dynamic object that can be attached to a reference object or page box, and you can apply
Repeat by Grid Marks. See Repeat for Grid Mark on page 398
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In a Static Grid, you can select one or more Grid Stations, using the Object Browser or the Select Object
tool. You can then use the Replace... button in the Placed Art Inspector to apply a different graphic of
similar dimensions.

9.11.2.  Step & Repeat based on an MFG or CF2 file

An ArtiosCAD MFG file is a Manufacturing structural design file, containing a repetition of Structural
Design files (ARD).

A Layout CF2 file is a CF2 file that contains a repetition, based on subroutines.

If you set the dropdown at the bottom of the File Open dialog to "All supported Structural Design files",
you can open an ArtiosCAD MFG (Manufacturing structural design file) or a Layout CF2 file in ArtPro+.
You can also simply drag and drop the file onto the application or the dock icon.

Note:  Unlike ARD files, you can not place an MFG file.

This is the typical workflow with MFG or CF2 files:

1. Open the MFG or CF2 file in ArtPro+, either using File > Open or by dragging and dropping the file on
the application or doc icon.

Note:  When using the File Open dialog, you have to set the file selector to All Supported
Structural Design Files to select an MFG or CF2 file.

2. Define if you want to import the structural lines from the structural design layout file as processing
step.

When importing, you can use the option to define if you also want to include the structural lines
from the one-up. When disabled, only the structural lines of the repetition will be imported.

 

 

• If you select Do not import, the Structural Design is analysed and used for the stations, but not
imported as Processing Steps.

• If you select Import Cut and Crease, the cutting and creasing data from the MFG or CF2 will be
imported as Processing Steps, and these lines will be visible in the dummy stations. This can be
used to visually check the position of one-ups that don't contain cad data.
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• If you select Import Cut, Crease and Dimensions, also the Dimensions data from the MFG or
CF2 will be imported as Processing Step. This can be used to e.g. generate a proof including the
Dimensions.

• If you select Import All, all Structural Design data from the MFG or CF2 will be imported as
Processing Step.

• If you enable the Remember my choice option, your choice will affect the setting of the
Preferences, and you will not get the dialog the next time you open an MFG or CF2 file. You can
always change the option in the General section of the Preferences. See Preferences on page 49

The MFG or CF2 Layout file is opened:

• The Sheet Size and Margin defined in the MFG file or CF2 file will define the Trim Box and Media
Box.

• A layer using the name of the MFG or CF2 file is created
• The Placed Art side drawer is opened, showing all the placeholders, one for every ARD or CF2

Station included in the MFG or CF2 file.

• For every Placeholder, its ARD or CF2 filename, Print Item, dimensions and amount of copies
used in the repetition is shown in the Placed Art side drawer. You can also see the index (A, B, …)
which is also shown in the Placeholder in the actual document.

• Every different placeholder also uses a different temporary Placeholder color (Apricot, Pink, …)
3. Select the Placeholder you want to replace, either in the Placed Art side drawer or in the actual

document.
If you want to select e.g. all "A" placeholders, the best way to do so is using the Placed Art side
drawer. By selecting in the document, you can combine different placeholders.

4. Open the Placed Art Inspector

You can see the name of the selected Structural Design file (.ard or .cf2), the Print Item when
defined in ArtiosCAD, and the dimensions.

 

 
5. Click the Replace... button, and browse for the graphics file you want to use for that station.

You can use PDF+ or Normalized PDF files. PDF+ files can be linked or embedded, while Normalized
PDF files will always be embedded. See Linked versus Embedded Placed Art on page 221
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If the placed file contains the corresponding Structural Design file (.ard or .cf2), this will be used to
position the graphics. Otherwise, the placed file will be centered based on the Trim Box.

The placed file becomes a regular Placed Art, so you can use the Placed Art Inspector to update,
replace, … See Working with Placed Art on page 219. However, on the document, it remains a
Structural Design station in an MFG / CF2 workflow. You will e.g. still need an ArtPro+ Advanced
license to replace Structural Design Stations.

The separations used in the placed graphic will be added to the Separations list. The Placeholder
separations will be removed from the Separations list as soon as they're not used anymore.

Station Numbering in an MFG / CF2 workflow
When using an MFG file or Layout CF2 file to create a Step & Repeat (See Step & Repeat based on an
MFG or CF2 file on page 358) you can use Station Numbering.

You can either generate a dedicated Station Number Placeholder in your one-up, or you can use a text
object from the one-up structural design file, when present.

1. Add the Station Number Placeholder to your one-up. If you want to use a text object from the one-
up structural design file, you can skip this step.
a) Open the graphics file of the one-up.
b) Create or select an object (a rectangle, a path, a text box, …) and position it where you want to

place the station number.
c) Select Object > Convert to Placeholder
d) Select StationNumber and click OK

The object loses its fill, stroke, text, .. and is converted to a placeholder object. You can still
change the name, position and orientation of the object.

If needed, you can add more placeholders to the job.
e) Save the file

2. Open the MFG or CF2 file, and apply the saved graphics file to the corresponding placeholder(s). See
Step & Repeat based on an MFG or CF2 file on page 358

3.
In the Marks section, click the Load Mark Set button .

4. Select the Standard Repeat for Stations Mark - Station Number Mark Set, and click Load
A Repeat for Stations Mark will be created, containing a Point Text Mark using the Station Number
as variable, in Darkest Color, positioned centered on the StationNumber placeholder for every
station.

5. Using the Mark Inspector and Transformation Inspector you can change the Repeat for Stations
Mark contents, color, and positioning. See Repeat for Stations Mark on page 408

Note:  If you add Station Numbers based on the Station Number placeholder in the one-up
graphics, the station numbers will only become visible once the placeholders are replaced by
graphics.

Bleed in an MFG / CF2 workflow
When opening an MFG or Layout CF2 file, the bleed mask is automatically generated from the die
shape.
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Where panels touch, an overlap decision is made, based on a number of criteria.

1. Where Panel Tags are defined in the one-up, the bleed direction is derived from the Panel Tag. See
Working with Panel Tags on page 363

2. Where no Panel Tags are defined, but Allow Bleed flags are set in the artwork panels of the ARD
file, the bleed direction will be based on the Bleed Flags. For more info on this setting, see the
ArtiosCAD documentation.

Note:  If you want to edit the Bleed Flags, keep in mind that the ARD inside an MFG file is
always embedded, so making changes to the original ARD file does not update the MFG file.
You should either edit the ARD inside the MFG document, or recreate the MFG after editing
the ARD file.

3. If there are no Panel Tags nor Bleed Flags, the bleed direction will be based on the size of the
panels.

Tip:  Automatic bleed decisions are based on multiple parameters and will adapt to the
situation at hand. This implies that bleed decisions can be altered when replacing one-ups.
If you want to avoid this, you may prefer applying manual bleed decisions, as these take
precedence over the automatic calculation.

Using the Layout Inspector, you can change the bleed for your MFG or CF2 file.

 

 

1. The Layout File shows the name of the MFG or CF2 file used.
2. Set the Clip Bleed At value. This is the amount of bleed added to the outside of the bleed mask that

was generated from the die shape.
3. Enable the Clip overlaps at option if you want to use a smaller bleed distance when one panel

bleeds into another one, e.g. to limit the bleed onto a glue flap. Where there is no neighbouring flap,
the Clip Bleed At distance will be used.

Note:  The Clip overlaps at can't be higher than the Clip Bleed At distance. If necessary, the
Clip Bleed At value will be adjusted.

4. To check and/or change the overlap decisions, select the Adjust Bleed tool by clicking the Adjust
Bleed button.
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When the tool is active, all areas where flaps overlap using the given bleed distance will be marked
on the document, indicated in white, yellow or red.

• White: This is a decision that is assumed to be correct, e.g. if the direction comes directly from
the MFG Allow Bleed flag, without any conflicts, or the user made the decision, without causing
any conflicts.

• Yellow: This is a decision that is likely OK, but there might be doubt, e.g. because the 2 affected
panels have similar sizes.

• Red: This is a decision that needs to be checked with care, because there is reason to doubt it is
correct, e.g. the criteria used to determine the direction are inconclusive, or cause conflicts in
other areas involving any of the affected panels.

5. In the Tool Options at the bottom of the screen you can check the total number of unique bleed
areas. Navigate through these decisions using the Next and Previous buttons or the left and right
Arrow keys. The corresponding bleed area will be highlighted.
 

 
6. Hover over a bleed area to highlight all the repetitions of the bleed area. This way you know where

your bleed decision is repeated.
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Other affected bleed areas are shown using a dashed line. See below.
7. Change the bleed direction of the highlighted bleed area by dragging from within the bleed area

towards the panel that needs to receive bleed, or clicking inside the bleed area to apply centerlining
on both panels.

By dragging from panel A to panel B you are actually making 2 bleed decisions. It means panel B is
set to allow bleed, and panel A is set to trim (bleed onto panel B).

That means that any other bleed area where panel A or panel B is involved, may be affected as well:
if you change a bleed direction in a way that sets panel B to allow bleed, the bleed decision for other
bleed areas where panel B is involved, will also be revised and set panel B to allow bleed. These
areas are indicated by a dashed line when hovering.

In case a panel overlaps with more than one other panel, different bleed decisions can be made for
each of the overlaps.

8. Switch to any other tool or click the Done button to exit the Adjust Bleed tool.

Note:  In ArtPro+ 22.07 and later, all bleed information - including the manual bleed
adjustments - are saved in the resulting PDF+ file. This means that after reopening, you can
continue editing the bleed.

Working with Panel Tags
Using Panel Tags you can store bleed information in your one-up, to be used when placing the one-up
in an MFG or CF2 based Step & Repeat.

1. In your one-up graphics file containing a structural design object (ARD or one-up CFF2), open the
Structural Design File Inspector. See Structural Design File Inspector on page 229

2. Click the Edit Panel Tags button to activate the Edit Panel Tags tool.

With the Edit Panel Tags tool active, hovering over your structural design file will highlight all the
different panels.

3. Click the panel for which you want to set or edit the Panel Tag in the Tag Inspector
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4. Set the Allow Bleed

• When set to From Structural Design File, the Allow Bleed flag as defined in the Structural
Design file will be used. The current value of the Allow Bleed flag is shown underneath the
dropdown: "Yes" means the the panel is set to accepting bleed, "Undefined" means that there is
no Allow Bleed flag set in the Structural Design File

• When set to Yes, a tag is assigned to the panel, to always allow the panel to accept bleed,
regardles of the Allow Bleed flag set in the Structural Design file.

• When set to No, a tag is assigned to the panel, to never allow the panel to accept bleed,
regardles of the Allow Bleed flag set in the Structural Design file.

5. Use the Limit Bleed At value to set a maximum bleed distance

• When you enter no value, the Clip Bleed distance defined in the Layout file will be used.
• This is a maximum distance. If the Limit Bleed at is higher than the Clip Bleed distance in the

Layout file, this Clip Bleed distance will be used.

• When "Allow Bleed" is set to No, this setting is not available.
6. Switch to any other tool to stop editing the Panel Tags.
7. Save the document and use it as a station in your CAD based Step & Repeat.

Back Page
If you have a MFG or a Layout CF2 file open, or a PDF+ containing an MFG or Layout CF2 Step & Repeat
saved in ArtPro+ 22.07 or later, you can create a Back Page for it.

1. Open the MFG file, Layout CF2 file or PDF+ file you want to use.
2. For a better view on the bleed, it is advised to fill all the one-ups before checking and - if needed

- adjusting the bleed. Any manual bleed adjustments you have made on the front page will be
reflected and automatically mirrored on the back page.
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3. In the Layout Inspector, click the Create Back Pack Page (Turn) to create a back page by mirroring
horizontally, or Create Back Page (Tumble) to create a back page by mirroring vertically.
A second page will be created (see Working with multi-page documents on page 121) with mirrored
page boxes, mirrored stations and placeholder graphics including the bleed mask set on the front
page

4. If you use 2 page one-ups, the backside graphics will be applied automatically. See Working with
two-sided one-ups on page 365. If not, you can fill the placeholders with the backside graphics the
same way you did on the front page

Working with two-sided one-ups
Using two-sided one-ups, you can fill the stations for the front and back page in one go.

1. Create the first page of the one-up, containing the front graphics, and the ARD or CF2 set to front
2. Add a second page, containing the back graphics, and the ARD or CFF set to back
3. Save the one-up
4. Open the MFG or Layout CF2 file
5. Replace the placeholders with the one-up files.
6. Set the bleed and adjust the bleed masks as needed
7. In the Layout Inspector, click the Create Back Pack Page (Turn) to create a back page by mirroring

horizontally, or Create Back Page (Tumble) to create a back page by mirroring vertically.
A second page will be created, and the back side of the one-up is automatically positioned in the
stations on the back page.

Bleed on front/back page

When creating a back page, all bleed decisions (including the manual adjustments) are not just turned
or tumbled, but also mirrored, so you get the opposite bleed direction.

By default, the bleed settings are synced between the front and the back page. Changing the bleed
settings in the back page will also affect the front page and vice versa.

When you apply manual bleed adjustments after creating the back page, you will have the option to
mirror those new manual adjustments or not. If you disable Mirror on back/front page, any new manual
bleed adjustment you make will only be applied on the current page, and the corresponding bleed
decision on the other page will not be changed.

9.11.3.  Seamless Repetition

Using Seamless Repetition you can create a repetition of a cell into a pattern that fills the entire sheet.
The cell is repeated row by row, where each row can be slightly shifted from the previous one and
rotated by an angle.

The main usage of Seamless Repetition is to generate a seamless document in one or both directions.
This implies that by putting the sheets side by side no seams will be visible.
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If you only want to repeat a part of your document, then select these objects to be used as one-up. The
cell size will be the bounding box of the selection.

If nothing is selected, the complete document will be used as one-up, using its trim box as cell size.

To open the Seamless Repetition window, choose Prepress > Create Seamless Repetition...

1. Define the position of the First Cell in relation to the top-left corner of the Seamless Repetition
document, along with the Offset.

2. Define the width and height of the sheet (= the final Seamless Repeat document)
3. Define the vertical and horizontal Bleed.

4. Define in what direction the repetition needs to be seamless: vertically, horizontally or both. If
none of the buttons is enabled, a non-seamless repetition will be generated, and a number of the
following options will not be available.

5. Set the desired Angle
6. Use the buttons to define if you want to enter the desired horizontal gap (the space in between the

cells) or the step (the distance from the center of the cell to the center of the next cell), and enter
the value.
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7. Do the same for the desired vertical gap or step
8. Define if you want to apply staggering either vertically or horizontally. Enter the desired stagger

distance.
9. When calculating a Seamless Repeat, the angle, step/gap and staggering values will need to

be adjusted slightly to preserve continuity. For each of the 4 previous settings, you can set the
Importance to indicate which parameter you consider most important. This will influence the list of
suggested repetitions (see below).

10. Based on the desired Angle, Horizontal Gap / Step, Vertical Gap / Step and Stagger, a number of
seamless repetitions are calculated and shown in the center table. The suggested repetitions are
ordered based on the Importance sliders.

11. Select a Repetition to see its values: vertical and horizontal cell size, rotation, staggering and
vertical and horizontal gap in between the cells.

12. You can enable Clip cell width or Clip cell height if you want to use the exact Gap or Step distance
you entered. To ensure the seamless repeat, this means the cell size will be adjusted. In case of a
step smaller than the original objects, this will result in clipping the cell instead of overlapping.

13. Use the Clip Cell button to indicate in what direction the cell can be clipped.
14. Select the repetition you want to generate, and click Create

A new document is created, containing the seamless repetition.
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Note:  The settings used to generate the Seamless Repetition are not stored in the document,
so you are not able to adjust the settings after generating the repetition.

9.11.4.  Opening Step&Repeat files from other applications

Normalized PDF from PackEdge or Plato
Stations in a Step & Repeat (PDFPla) will be embedded if external file mapping was applied in Plato.
Images in a one-up (Norm PDF) will be represented as "Protected Objects" in ArtPro+ if any image plane
mapping was applied in PackEdge This to prevent any destructive editing and to maintain the image
link in a Normalized PDF workflow.

Note:  Normalized PDF files that use ink mapping from multiple separations to one and the
same can not be opened in ArtPro+.

Opening S&R files from third party software applications
Opening and saving Step & Repeat files coming from third party software applications has been
optimized: Stations will be treated as a set of copies of embedded Placed Art, resulting in better
performance and smaller file sizes.

In this case, a message will be shown "Objects Recognized as Embedded Placed Art", informing you that
multiple instances of the same transparency group or form were found, and that these are represented
as embedded Placed Art to reduce the file size.

If you don't want this, you can expand the objects, e.g. by clicking the message in the Messages drawer.
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9.12.  Thin Parts

The Thin Parts function allows to search for and fix areas where objects are thinner than a given
minimum width. There are two methods to fix thin parts:

There are two methods to fix Thin Parts.

• You can Spread Thin Parts. This creates small objects over the areas where thin parts are found.
See Spread Thin Parts on page 369

• You can use Offset Selection, which creates a directional spread of the complete object over a set
(small) distance, hence fixing any thin parts. This gives beter results e.g. for chinese characters.
See Offset Selection on page 370

The image underneath shows:

1. The original
2. The result of fixing using Spread Thin Parts
3. The result of fixing using Offset Selection.

 

 

In both methods, ArtPro+ will generate Fix Thin Part objects, that will be placed on top of the originally
selected objects as a group named "Thin Part Fixes". The original objects remain selected.

Any existing Thin Part Fixes objects for the selected objects will be updated if you apply a new Fix, even
when using a different method.

Note:  Fix Thin Parts is not available for Marks.

9.12.1.  Spread Thin Parts

1. Select the objects you want to check and fix
2. Choose Prepress > Thin Parts > Spread Thin Parts

The Spread Thin Parts palette shows up.
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3. Using the buttons, define if you want to Spread All Thin Parts or Spread Enclosed Thin Parts only.
4. Define the Minimum Width
5. Click Spread to create the Thin Part Fix objects.

ArtPro+ will generate Fix Thin Part objects, that will be placed on top of the originally selected objects
as a group named "Thin Part Fixes". The original objects remain selected.

Any existing Thin Part Fixes objects for the selected objects will be updated if you apply a new Fix, even
when using a different method.

9.12.2.  Offset Selection

1. Select the objects you want to check and fix
2. Choose Prepress > Thin Parts > Offset Selection

The Fix Thin Parts toolbar shows up.

 

 
3. Define the Minimum Width

The optimal values for Angle, Horizontal Offset and Vertical Offset for the currently selected objects
will be calculated.

4. If needed, adjust the Minimum Width, Angle, Horizontal Offset or Vertical Offset values.

• The red circle image gives an indication of how the Thin Parts Fix will be positioned on the
original object.

• The angle can be between -45º and +45º and defines the direction of the Horizontal and Vertical
offset.

5. Click Fix to create the Thin Part Fix objects.

ArtPro+ will generate Fix Thin Part objects, that will be placed on top of the originally selected objects
as a group named "Thin Part Fixes". The original objects remain selected.
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Any existing Thin Part Fixes objects for the selected objects will be updated if you apply a new Fix, even
when using a different method.

9.13.  Flexo Tools

9.13.1.  Plate Cutting Paths

Plate Cutting Paths offer an alternative for Staggered Cutting in ArtPro or Packedge/Plato. It is
designed to facilitate seamless printing in non-sleeve workflows. This means that when web fed flexo
printing jobs are not using flexo sleeves the flexo material is cut and wrapped around a cylinder. The
unavoidable seam will be positioned in between printable objects. Plate Cutting Paths is the tool to
define the shape of the flexo plates, which will later in the process be sent to a Kongsberg table on
which the flexo plates are cut.

Note:  Plate Cutting Paths can only be created on PDF+ files, and only objects inside the page
boxes are taken into account, so it is advised to set all page boxes correctly before creating the
Plate Cutting Paths.

1. Open the document on which you want to apply the Plate Cutting Paths.

Typically but not necessarily this will be a Step & Repeat file. If this file was created in Plato or
ArtPro, keep in mind to convert it to PDF+ before continuing. See Convert to PDF+ on page 59

2. Create a first set of Plate Cutting Paths.
a) In most cases, the first round you create Automatic Plate Cutting Paths. See Create Automatic

Plate Cutting Paths on page 372.

The automatically created Plate Cutting Paths have been optimized to find the best path, and
the shape of these paths cannot be edited.

b) You can also create Manual Plate Cutting Paths. See Manual Plate Cutting Paths on page 375

When creating Plate Cutting Paths:

• The Media Box is adapted to the repetition and a Crop Box is set (the same size of the Media
Box).

• In case of a grid, the Continuous Printing option in the Layout inspector will be enabled in case it
wasn't already.

• For each selected separation, a Plate Cutting Path (internally an Esko_PlateCutting processing
step sublayer) is created inside a new "Plate Cut" layer. It is named after the separation and
is colored in a "Plate Cut" processing step colorant. If you chose to use the same path for all
separations, only one Plate Cutting Path is created, using the name of all selected separation
names as its path name.

• In the Object Browser you will see the created Plate Cutting Paths, as well as a transparent path
and the "Cloned Layout": a repetition of the artwork, placed above and underneath the original
artwork, to visualize the seamless effect.
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Note:

Any edits that you do to the document itself after creating Plate Cutting Paths will be shown
in the "Cloned Layout". Keep in mind that making changes to your layout (artwork and/or
marks) will not automatically adjust the existing plate cutting paths until you re-run the
Create Plate Cutting Paths action. So if you make changes that (could) have an effect on the
separations and/or shape of the Plate Cutting Path, it is advised to re-run the Create Plate
Cutting Paths action.

3. By doing a second round of creating Plate Cutting paths, you can update the already created Plate
Cutting Paths using different settings or using a Manual Plate Cutting Path, or you can create
additional Plate Cutting Paths for different separations.
a) A new Plate Cutting Path will be created for any separation that you now select but which was

not selected yet in the previous round. The different Plate Cutting Paths will be added to the
same Plate Cut Layer

b) If a selected separation was already included in the previous round, its Plate Cutting Path will be
updated.

c) Any Plate Cutting Paths that were created in the previous round but which you did not select in
the 2nd or next round, will be kept 'as is'.

Note:  If you are not happy with any of the Plate Cut results, you could also simply remove
the entire Plate Cut layer and start over.

You can use the Flexo Print Preview in Quality Control to inspect the Plate Cutting Paths. See Flexo
Print Preview on page 105

Note:  Plate Cutting Paths are only supported on a single grid of a single one-up.

Create Automatic Plate Cutting Paths

1. Open the document on which you want to apply the Plate Cutting Paths.
2. Choose Prepress > Flexo Tools > Create Plate Cutting Paths
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3. Define the Web Direction, either vertical or horizontal

Note:  The Web Direction is the same setting as shown in the Layout Inspector. See The
Layout Inspector on page 347

4. Set the Plate Width by selecting a page box from the dropdown.
5. The Plate Circumference value is filled automatically based on the selected Plate Width. You can

however override this value.
6. Choose Optimize Plate Usage to generate the Plate Cutting Paths that make best use of the flexo

plates, or choose Prefer Stagger Pattern if you want the Plate Cutting Paths to follow the stagger
pattern of the grid as closely as possible.

Note:  ArtPro+ can detect stagger patterns from Step & Repeats generated in ArtPro+ or
other Esko applications. If no stagger pattern is found, the Optimize Plate Usage method is
used instead.
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7. Set the minimum and preferred distance the Plate Cutting Paths should stay away from the imaged
areas

8. Set the minimum and preferred Corner Radius for the Plate Cutting Paths

Note:  It is not recommended to use 0 for both the minimum and preferred Corner Radius

9. Set a Corner Radius to round corners in the Plate Cutting Path to the specified radius. Rounded
corners facilitate cutting and avoid damaging the plate when taking it off the cylinder.

10. Specify a Gap at Seam if you want to make the flexo plate a bit smaller than the repeat length. The
distance between the two identical segments will be the Repeat Length minus the Gap. You can
specify a minimum and preferred gap.

11. Set the Clip at Bleed distance to apply bleed outside the Plate Cutting Paths.
When a positive value is entered, the artwork will extend beyond the Plate Cutting Path according to
the defined Web Direction: top and bottom for vertical direction, or left and right for horizontal.
When a negative value is used, the artwork will cut away from the Plate Cutting Path.

12. Select the Separations that you want to create a Place Cutting Path for. By default, all artwork
separations are enabled.

13. You can choose to create one single path by enabling the Use the same path for all separations
option

14. Click Create to create (or update) the Plate Cutting paths.

Note:  You can tag objects to be ignored during Plate Cutting Path creation. See Working
with Plate Cutting Tags on page 374

Working with Plate Cutting Tags
A Plate Cutting Tag is a property attached to a group or object and saved in your document, allowing
you to ignore these objects during Plate Cutting Path creation.

1. Select the group(s) or object(s) you want to assign a Plate Cutting Tag to.
2. Open the Tag Inspector
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3. Set the Tag type to Plate Cutting.
4. Enable Ignore for Plate Cutting Path creation.

Note:  In the Object Browser, you can get an overview of all objects with Plate Cutting Tags.
See Object Browser on page 130

Objects or groups with a Plate Cutting Tag are marked with the Tag icon  in the Breadcrumbs and in
the Object Browser.

Manual Plate Cutting Paths
By creating Manual Plate Cutting Paths you can manually define the shape of your Plate Cutting Paths.

1. Using the Edit Path tool, draw the path you want to use to create your Plate Cutting Guide. See
Create & Edit Path on page 170

Note:  Use Flexo Print Preview in the Quality Control side panel to get a preview of the
repeated grid, so you have more control when drawing the path. See Flexo Print Preview on
page 105

2. Select the path you want to use. Make sure only one single path is selected
3. Choose Prepress > Flexo Tools > Create Plate Cutting Paths >
4. Define the Web Direction, either vertical or horizontal

Note:  The Web Direction is the same setting as shown in the Layout Inspector. See The
Layout Inspector on page 347

5. Set the Plate Width by selecting a page box from the dropdown.
6. The Plate Circumference value is filled automatically based on the selected Plate Width. You can

however override this value.
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7. Set Create Cutting Paths to Use Selected Path

In case you don't have one single path selected, the dialog will show a warning.
8. When the selected path is an open path, a closed path will be generated from it: the open path will

be copied down or to the right (depending on the Web Direction), and both paths will be connected.

• When Use custom offset is disabled, the open path is copied over the Plate Circumference
• When Use custom offset is enabled, you can specify the distance over which to copy the open

path.
• When the selected path is already closed, the Use custom offset option and distance are

ignored.
9. Set a Corner Radius to round corners in the Plate Cutting Path to the specified radius. Rounded

corners facilitate cutting and avoid damaging the plate when taking it off the cylinder.
10. When starting from an open path, you can specify a Gap at Seam if you want to make the flexo plate

a bit smaller than the repeat length. When starting from a closed path, this option is ignored.

Note:  If you want to keep the shape of the path exactly as it is, you should set both Corner
Radius and Gap at Seam to 0mm.

11. Select the Separations that you want to create a Place Cutting Path for. By default, all artwork
separations are enabled.
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12. Click Create to create (or update) the Plate Cutting paths.

9.13.2.  Plate ID Objects

If you are using ArtPro+ in combination with Esko's Imaging Engine within the flexographic printing
industry, you can use Plate ID objects to identify Flexo Plates, e.g. for reprint after being archived, or to
be reused in a similar jobs.

Plate ID objects will be exposed by the RIP at "half height". This means the objects are permanently
visible, yet they do not show up on the printed result.

For more information we refer to the chapter on Working with Plate ID in the Automation Engine
documentation here

Note:  Plate ID Objects use Processing Steps, and are only available in PDF+. See PDF, PDF+ and
Normalized PDF on page 57

• To create a static Plate ID object, see Creating a static Plate ID Object on page 377
• If you want to create a dynamic Plate ID object, you can use a Plate ID Mark. See Creating a Plate ID

Mark on page 378

A Plate ID Object is static:

• Any Marks in the selection when creating the Plate ID Object will be expanded, and thus no longer be
dynamic.

• A Plate ID Object is colored in the Plate ID colorant. However, the Separation Selector defines on
what plates the Plate ID object should be applied. This Separation Selector is static, meaning that if
you change the document separations or copy and paste the Plate ID Object in another document,
the Separation Selector will not be updated.

A Plate ID Mark is a Mark, and thus dynamic:

• The Plate ID Mark can contain nested Marks, e.g. a Text Mark containing the separation name as a
variable. See Nested Marks on page 417

• The separation filter, indicating on what plates the Plate ID Mark should be applied, is adjusted to
the separations in the document.

• The positioning of the Plate ID Mark is dynamic. See Mark positioning on page 411

Creating a static Plate ID Object
To create a static Plate ID Object:

1. Select the objects you want to create a Plate ID object of.

Note:  Images, Placed Art and clipping paths are not supported. Unsupported objects in the
selection will be removed.

2. Select Prepress > Flexo Tools > Create Plate ID Object

• All (supported) objects in the selection are converted into one Plate ID Object. Marks in the
selection will be expanded and thus no longer be dynamic.

• A Plate ID Object is colored in 0% of the Plate ID Processing Step colorant if the original object
was 0% in all separations. In all other cases, the object is colored in 100% of the colorant.
Gradients and patterns are changed to 100% flat paint.

• The Plate ID Object is set to overprint, and transparency settings are set to "Normal" at 100%
opacity.
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• The Plate ID Object is moved to the "Plate ID" layer.
3. Using the Plate ID Object Inspector you can define on what plates the Plate ID Object has to be

exposed.
 

 

By default all artwork separations will be enabled, while Processing Step colorants and unused
separations are disabled. You can however manually add or remove separations.

Creating a Plate ID Mark
To create a dynamic Plate ID object, you should create a Plate ID Mark

1. Select the objects you want to create a Plate ID Mark of.

Note:  Images, Placed Art and clipping paths are not supported. Unsupported objects in
the selection will not be used in the resulting Plate ID Mark. These objects are not removed,
and remain in the original source content. This also means you will get warnings in the
Messages Drawer until you manually remove them from the Mark Content, using Edit
Content.

2. In the Marks section of the Side Panel, click the Create Mark from Selection button  and select
Create Plate ID Mark from Selection

• All (supported) objects in the selection are converted into one Plate ID Mark.
• Marks in the selection that can be Nested (Text Marks, Custom Marks, Barcode Marks, External

File Marks and Position Marks) are preserved. Other Marks in the selection will be expanded. See
also Nested Marks on page 417

• A Plate ID Mark is colored in 0% of the Plate ID Processing Step colorant if the original object
was 0% in all separations. In all other cases, the object is colored in 100% of the colorant.
Gradients and patterns are changed to 100% flat paint.

• The Plate ID Mark is set to overprint, and transparency settings are set to "Normal" at 100%
opacity.

• The Plate ID Mark is moved to the "Plate ID" layer.
3. In the Mark Inspector you can define on what plates the Plate ID Object has to be exposed.
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You can choose to place the Plate ID Mark on all Plates for Artwork Separations, for Artwork
Separations and Varnish, or Custom: this allows you to select separations by combining rules
on Printing Method, Processing Step, Separation Name, Process Separations, Non-Process
Separations or Artwork Separations.

4. Using the Edit Content button in the Mark Inspector, you can edit the shape of the Mark. See Editing
a Mark on page 416. You can also double-click the Mark while holding the Alt key.

Tip:  If your selection contained unsupported objects, e.g. an image, when creating the
Plate ID Mark, you can use the Edit Content button to remove the image, so that you will no
longer get the warning message that the image is discarded in the Plate ID Mark

5. Using the Transformation Inspector you can set the dynamic positioning of the Plate ID Mark. See
Mark positioning on page 411

• If Automatically position Plate ID Mark is disabled, the Plate ID Marks for each separation are
placed on top of each other on the location defined in the Transformation Inspector. You will
have to manually check if there is no overlapping artwork in any separation.

• If Automatically position Plate ID Mark is enabled, a suitable location for each separation is
searched: an empty area within the Trim Box or - when present - within the Plate Cutting Path,
as close as possible to the location defined in the Transformation Inspector.

Note:  When using automatic positioning, only Artwork is taken into account, and non-
printing Layers are ignored.
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Note:

To include the separation name in the Plate ID Mark:

1. Create a Point Text Mark or Area Text Mark. See Point Text Mark and Area Text Mark on page
384

2. Besides static text, add the separation name as a variable. See Using Smart Text on page
385

3. Select the text Mark and select Create Plate ID Mark from Selection

Note that, since the Plate ID Mark will have different text for different separations, all placed on
top of each other, the text will look garbled. This will not be an issue when the Mark is exposed
on the plate, since each plate will only get the text showing the separation name for that
specific plate.

 

 

You could expand the Mark to inspect the individual objects.
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10.  Marks
Using the Marks, you can create sets of Marks, add them in a document, and have full control over
these Marks.

Important:  You can only create and apply Marks in a PDF+ file. Marks are not supported in
Normalized PDF files.

The Marks in your document are shown in the Marks section of the Side Panel.

 

 

The Marks list shows all Marks in your document. The Type icon indicates what type of Mark it is.

The Marks list will also show Nested Marks, i.e. Marks used as content for another Mark. See Nested
Marks on page 417

• Click the Selection icon in front of a Mark name to select the Mark in your document, e.g. to change
its color or position. See Mark Types and their properties on page 383

• Double-click a Mark to change its name

•
Click the Load Mark Set button  to load a Mark Set, or the Save/Delete Mark Set button  to
save, delete or overwrite a Mark Set. See Working with Mark Sets on page 415

• Click the Update Marks button  to trigger an immediate update of all Marks.

• Click the Create Mark from current selection button  to create a Mark based on the current
selection. See Create a Mark from Selection on page 382

• Click the + button to create a Standard Mark. See Create a Standard Mark on page 383

• Select a Mark in the list and click the - button to delete the Mark.

• Select Delete all Marks from the fly-out menu to remove all Marks in the document.

• Select Load Custom Variables Database... from the fly-out menu to get custom variables from a
CSV file. After loading, the name of the file is shown on top of the Marks panel. See The Variables on
page 386

• Marks can be expanded into 'normal' objects. See Expand on page 178

Important:  It is strongly advised to only expand ALL Marks at the same time. Expanding
one or more Marks separately might give unexpected results.
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10.1.  Create a Mark from Selection

You can create a Mark based on the selected object(s)

1. Select the object(s) you want to convert into a Mark
2. Click the Add Mark button  and choose the type of Mark you want to create.

• Create Custom Mark from Selection: See Custom Mark on page 383
• Create Point Text Mark from Selection and Create Area Text Mark from Selection is only

available if you have one single text object selected. See Point Text Mark and Area Text Mark on
page 384

• Create Repeat for Separations Mark from Selection creates a Repeat for Separations Mark
using the selected objects and Marks. See Repeat for Separations Mark on page 391

• Create Repeat by Count Mark from Selection creates a Repeat by Count Mark using the
selected objects. See Repeat by Count Mark on page 396

• Create Repeat for Grid Mark from Selection to create a Repeat for Grid Mark using the selected
objects. See Repeat for Grid Mark on page 398. This option is only available if the document
contains a Grid. See Grid Step & Repeat on page 343

• Create Repeat for Stations Mark from Selection to create a Repeat for Stations Mark using the
selected objects. See Repeat for Stations Mark on page 408

• Create Repeat for Placeholder Mark from Selection to create a Repeat for Placeholder Mark
using the selected objects. See Repeat for Placeholder Mark on page 399

• Create Cut Mark from Selection creates a Cut Mark using the selected objects. See Cut Mark on
page 400

• Create Bearer Bar from Selection creates a Bearer Bar using the selected objects. See Bearer
Bar Mark on page 400

• Create Clip Mark from Selection creates a Clip Mark using the selected objects. See Clip Mark on
page 401

• Create Barcode Mark from Selection creates a Barcode Mark using the selected barcode. See
Barcode Mark on page 404

• Create Dimensions Mark from Selection creates a Dimensions Mark using the selected objects.
See Dimensions Mark on page 405

• Create External File Mark from Selection creates an External File Mark from the selected
placed and linked PDF. See External File Mark on page 405

• Create Position Mark from Selection creates a Placeholder Mark using the selected objects.
See Position Mark on page 406

• Create Resize Mark from Selection creates a Resize Mark using the selected objects. See Resize
Mark on page 406

• Create Plate ID Mark from Selection creates a Plate ID Mark using the selected objects. See
Creating a Plate ID Mark on page 378

The selected objects will be put in one single group, and become a Dynamic Mark. The properties of the
newly created Mark will be based on the objects used to create it.

Note:  At first, the screening of a Mark will be based on the screening of the Mark content.
However, you can change the Screen Set of the Marks using the Screen Set Inspector. See
Applying a screen set to an object on page 318
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10.2.  Create a Standard Mark

By clicking the + button in the Marks section, you can create a Standard Mark. A Standard Mark is a
Mark using predefined shapes.

Click the + button and choose the type of Mark you want to create.

• Add Repeat for Grid Mark creates a standard Repeat for Grid Mark. See Repeat for Grid Mark on
page 398. This option is only available if the document contains a Grid. See Grid Step & Repeat
on page 343

• Add Cut Mark creates a standard Cut Mark. See Cut Mark on page 400
• Add Bearer Bar creates a standard Bearer Bar. See Bearer Bar Mark on page 400
• Add Dimensions Bar creates a standard Dimensions Mark. See Dimensions Mark on page 405
• Add External File Mark creates an External File Mark. See External File Mark on page 405
• Add Position Mark creates a standard Position Mark. See Position Mark on page 406
• Add Input File Mark is only available when working on a Report Template. See Input File Mark on

page 86

More Standard Mark Sets are available in the Load Mark Set dialog, in the Standard Mark Sets section,
which is available both when you are working with local Mark Sets as well as when working with server
Mark Sets.

You can a.o. find a Standard Repeat for Stations Mark - Station Number there.

10.3.  Mark Types and their properties

The properties of a selected Mark can be set in different places:

• The Mark Inspector will contain specific settings for Marks. You can e.g. define the color(s) of the
Mark or set the dynamic text in a Text Mark. The Mark Inspector also shows a preview of the Mark
content.

• The Transformation Inspector allows to change the positioning and repeat of the Mark. See Mark
positioning on page 411

All of these settings depend on the type of the selected Mark.

Note:  At first, the screening of a Mark will be based on the screening of the Mark content.
However, you can change the Screen Set of the Marks using the Screen Set Inspector. See
Applying a screen set to an object on page 318

10.3.1.  Custom Mark

A Custom Mark can be any shape or object you select and convert into a Mark.

• By default the color of a Custom Mark will be Dynamic when created, but in the Mark Inspector you
can select Dynamic, Static, Darkest Color or Registration Color, both for the Fill as for the Stroke.
See Colors and Separations in a Mark on page 410.
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• Using the Edit Content button, you can edit the shape of the Mark. See Editing a Mark on page 416.
You can also double-click the Mark while holding the Alt key.

• In the Transformation Inspector you can set the positioning of the Custom Mark. See Mark
positioning on page 411

10.3.2.  Point Text Mark and Area Text Mark

When creating a Mark from Selection while you only have a text element selected, you can create a
Point Text Mark or an Area Text Mark.

• If you create a Point Text Mark, text is positioned on a single point, either left aligned, right aligned
or centered. Text is put on one line, unless a hard return is added (using Shift - Enter).

• If you create an Area Text Mark, the text box is part of the Mark, and will be used when filling the
Mark. Text can reflow inside the text box.

• If you use the Transform tool on a Point Text Mark, you can scale the actual text.

• If you use the Transform tool on an Area Text Mark, you can change the text box. You can see and
edit the dimensions of the Area Text Mark's text box in the Marks Inspector. You can use a Formula
to define the size of the text box. In that case, you can't manually transform the text box anymore.
See Formula Editor on page 413

Note:  Using formulas to define the size of an Area Text Mark is available in ArtPro+ 22.03
and later. When opening a mark with such a formula in an older version of ArtPro+, the mark
will not be recognized.

• For an Area Text Mark you can use the Fit Text option to define what to do when the text doesn't fit
the text box. When set to "Wrap Lines Then Shrink", the text lines will be wrapped to fit the text box.
If the text still doesn't fit in the text box, the text will be scaled down. When set to "Shrink Lines Then
Wrap", the text will be scaled down to fit the text box. If the text still doesn't fit in the text box, the
text lines will be wrapped. If the text flows outside of the text box after shrinking and wrapping, a
warning will be shown in the Messages drawer.

Note:  Scaling down the text is done by first reducing the horizontal size to 80%, then by
reducing the point size to the Minimum Font Size.

• By default the color of a Text Mark will be Dynamic when created, but in the Mark Inspector you can
select Dynamic, Static, Darkest Color or Registration Color, both for the Fill as for the Stroke. See
Colors and Separations in a Mark on page 410.

• In the Transformation Inspector you can set the positioning of the Text Mark. See Mark positioning
on page 411

The complete Text Mark will have the same formatting, based on the formatting of the first character.
Use the Text Inspector to change the properties.

Note:  When creating a Mark from selection, text settings that are not supported in a Text Mark,
such as kerning, indents, spacing etc. will be removed.

The text in a Text Mark can't be changed using the Text Tool. Instead, it can be set in the Mark
Inspector.
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You can modify the (static) text, and you can add dynamic text or Smart Text. See Using Smart Text on
page 385

Using Smart Text

1. Place your cursor where you want the variable to be, or select the text to replace with a variable.
2. When editing a Point Text Mark, Area Text Mark or Text-on-Path Mark that is included in a Repeat

for Stations Mark, you can enable Use information from one-up to resolve the variables using the
information from the one-up, or disable the option to use the information from the Layout file. The
option is used for all Smart Text used in the Text Mark.

Warning:

When Use information from one-up is enabled and this mark is used in a task in Automation
Engine it will only be able to retrieve Job information from the Job context that the task is
launched in.

3. Click the Insert Smart Text... button.
4. In the Insert Smart Text dialog that opens, choose the fields to insert:

a) Select Document to select variables from the local file, System to select variables from your
system information, or Server to use SmartNames from the Automation Engine server. In that
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case, all database queries defined on the server will be available, as well as all job and product
parameters.
See also The Variables on page 386

b) Choose a field Category, for example Barcodes, Date & Time...
c) In that Category, choose the Field you want to use. You can enter a Search key to find the

Variable you're looking for.
d) If applicable, choose the Format to use for your chosen Field (see Formatting Dynamic Fields on

page 388 for details),

Note:  The Preview line shows how the field will be resolved in the current document.

e) When your field is completely set up, click OK.

The dynamic parts of a text object will appear as a gray block with white text.
5. Most but not all Smart Text Variables are updated live. There is e.g. no live update if you are using

the ink coverage variable, if you are using the modification time variable or if a value of a server
variable is changed on the server side. To trigger an immediate update, you can use the Update

Marks  button.

The Variables

How variables are resolved into actual values depends on the context of the document in which the
variables are used.

Document Variables
The Document variables provide information about the document itself, such as the number of
separations, the size of the page boxes, the barcodes used in the document, etc.

These variables are independent of where the file is stored or where it is opened.

System
The System variables provide information about the System on which the document is being edited:
the ArtPro+ version, the operating system, the user, ...

Opening a document on a different system or by a different user can result in different System
information.

Server
The Server variables provide information as returned by the Automation Engine Server you are
connected to.

Important:

The Preview in the Insert Smart Text dialog shows the values as returned by the server. When
used in a Mark, the variable will only resolve to that value if the context is correct.

If you for example use a variable from the Job Information category, a preview value can only
be returned by the server if your current document is located inside an Automation Engine Job.

File Information
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The SmartID variable in the File Information category can only be previewed when used in a Report
Template, since the SmartID value is calculated for the Input File. A default value of "0000000000" is
used when connected to Automation Engine but not in the context of a Report Template. For more
information on Report Templates, see Report Template on page 84

Global

Note:  Be aware that, even if the context is correct, when using Server variables of the Global
category, variables in ArtPro+ could be resolved in a different way than the SmartNames on
Automation Engine. This can be caused by Formatting Options (such as setting a Number Data
Format in String Extract) applied to the Global Variables in Automation Engine, that cannot be
taken into account on ArtPro+ side.

Job Parameters, Product Parameters and Workflow Parameters

To select a Job Parameter, Product Parameter or Workflow Parameter, you have to browse to a specific
Job, Product or Workflow.

 

 

The Preview line will show the value for the Job, Product or Workflow you chose when selecting the
parameter.

However, these Parameters can only be resolved in your ArtPro+ document itself if the document on
which the Mark is applied is located in that particular Job or Product. If your document is in a different
Job or Product, the variable might return empty.

Workflow Parameters can only be resolved in an automated workflow, as it requires Automation Engine
context.

Note:  When these Parameter variables are used in a Station Numbering Mark, the Parameters
are resolved according to the context of the stations, i.e. the Job or Product the one-ups are
part of, and not the context of the MFG.
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Output Parameters

The Output Parameters category wil be used for creating Mark Sets used on the Imaging Engine RIP.
The variables are managed by the Imagine Engine that is linked to the Automation Engine ArtPro+ is
connected to, by means of a special task.

The variables in this category provide information about Imaging Engine task parameters. The preview
values you may see (if any) may not match the final results, as the values will be set by Imaging Engine
while imaging.

DFE
The DFE section contains all the built-in variables for DFE users. The resulting values can't be
previewed in ArtPro+ as they can only be evaluaded for print jobs processed by the DFE.

Database
The Database section can only be used if an external CSV file was loaded. You can load an external
CSV file by selecting Load Custom Variables Database... in the fly-out menu of the Marks panel
and selecing a valid UTF-8 encoded comma-separated list. Its name will be shown on top of the
Marks panel. You can click it to load a different CSV file, or you can choose Load Custom Variables
Database... again.

When there are more than two columns in the first row, the first row is imported as "keys", the second
row as "values". Other rows are discarded. When there are only two columns, the first column is used as
"keys", the second as "values".

The "keys" can contain alphanumeric characters, dashes, underscores and dots.

Note:  There is no live link with the CSV file. Changing the CSV will not affect the available keys
and values, until you reapply Load Custom Variables Database....

In the Variables panel, in the Database section you can now select the Custom Variables. The name of
the selected file is shown on top, and underneath all imported keys are shown.

Using one of the keys from the loaded database file will be resolved into the corresponding value on the
document. When loading a different database file that contain the same key, the value will be changed
accordingly.

Note:  The Database file is not included when saving a Mark Set. After loading a Mark Set
containing custom variables, these will only be resolved if you load a CSV file that has the
corresponding key.

Formatting Dynamic Fields
You can format certain fields so they look a certain way (for example, have the date in European or
American format).

You can use predefined formats or create custom formats. You can also choose to use a different
format for each field, or the same format for all fields.

Using the Remove trailing zeros option, you can remove (redundant) zeros at the end of a decimal
number. This option is only available for relevant variables, such as Bar Width Reduction, Barcode
Device Compensation, etc.

Using an Existing Format

• You can choose an existing format to apply to your field in the Format list.
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For example, use [name][ext] to display the file name and extension when using the File Name
field.

 

 

Using Custom you can create your own format. You can for example combine one or more format
options with static text: [width] [unit] wide x [height] [unit] high for one of the
page boxes would result e.g. in 33.5 mm wide x 42.5 mm high

For separations, the standard format [1], [2], … represents the first, second, … separation. The
Custom format allows to specify any of the remaining separations, e.g. [10]. The only thing you can
change is the sequence number.

Repeating the Format for All Items
If the field you want to use can have several values (e.g. Fonts, Ink Names, Placed Files...), you can put
them all in one dynamic object.

You can also set the same format for all those values at once.

After choosing an existing format or defining a custom one:

1. Select Repeat format for all items.
2. Choose the Separator you want to use between the values (Comma, Space...).

 

389



10 ArtPro+

 

Note:  You can also specify your own separator by typing it directly in the Separator list.

3. When you are satisfied with what you see in the Preview, click Insert.

10.3.3.  Text-on-Path Mark

When creating a Mark from Selection while you only have a Text on Path object selected, you can
create a Text-on-Path Mark. See also Create Text on Path on page 209

• If you use the Transform tool on a Text-on-Path Mark, you can scale both the text and the path.
• Text in a Text-on-Path Mark will automatically shrink to fit the path, e.g. if the smart text variables

result in more text than can fit on the path. However, the text will never become smaller than the
defined Minimum Font Size that is set on the Mark inspector. Any text that still doesn't fit the path is
added in a straight direction following the curve at the end of the path.

Note:  Scaling down the text is done by first reducing the horizontal size to 80%, then by
reducing the point size to the Minimum Font Size. You can manually lower the horizontal
size even further.

• By default the color of a Text Mark will be Dynamic when created, but in the Mark Inspector you can
select Dynamic, Static, Darkest Color or Registration Color, both for the Fill as for the Stroke. See
Colors and Separations in a Mark on page 410.

• In the Transformation Inspector you can set the positioning of the Text Mark. See Mark positioning
on page 411

Note:  The bounding box of the path is used for positioning the Text-on-Path Mark

The complete Text Mark will have the same formatting, based on the formatting of the first character.
Use the Text Inspector to change the properties.

390



10ArtPro+

The text in a Text Mark can't be changed using the Text Tool. Instead, it can be set in the Mark
Inspector.

You can modify the (static) text, and you can add dynamic text or Smart Text. See Using Smart Text on
page 385

10.3.4.  Repeat for Separations Mark

A Repeat for Separation Mark is a type of Dynamic Mark that is repeated a number of times, based on
the inks used in the document. You can load one of the default Repeat for Separations Mark sets (see
Working with Mark Sets on page 415) or you can create a Repeat for Separations Mark by selecting a
combination of objects and select Create Repeat for Separations Mark from selection (see Create a
Mark from Selection on page 382). The selected objects become the Mark Content, which is repeated
for every separation.

The Repeat for Separations Mark can contain nested Marks. See Nested Marks on page 417

Note:  If you include a Text Mark with Smart Text in a Repeat for Separations Mark, the Barcode
and Layer Names variables will be discarded.

You can for example create a Custom Mark of a 100% filled square, and a Text Mark containing the Ink
Name of the 1st separation as Smart Text. Combining those two into a Repeat for Separations Mark,
you can create a color patch for each separation, with the respective separation name next to it.
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Use the Mark Inspector to set all parameters.

 

 

• Underneath a preview of the Mark Content is the Edit Content button. If you want e.g. to edit the
Text Mark included in the Repeat for Separations Mark, you can click the Edit Content button. See
Editing a Mark on page 416. You can also double-click the Mark while holding the Alt key.

Note:  When editing the content of a Repeat for Separations Mark, you can't change the
color of included Text Marks or Custom Marks to Dynamic Color or Darkest Color, these will
always use Static color.

• In case your selection contained more than one separations when creating the Mark, you can use
the Repeat dropdown to select the separation you want to use in your Mark.

• By default the Repeat for Separations Mark will create one Mark for every separation on the page.
Use the For dropdown to choose what separations to include:

• All Separations
• Artwork Separations
• Artwork Separations and Varnish
• Processing Step Separations (See Processing Step Layers on page 127)
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• Enable Subset of Separations to select specific separations from the result of the For setting
above, based on the index. You can enter for example "1-6", or "3,4,6", or "1,4-6". If the Subset of
Separations is disabled, all separations defined using the For setting will be included.

• Other separations defines what to do with the other separations in your content: either remove,
keep as Static color, or map to the darkest separation.

In the example underneath, the original object had a fill in Cyan and a stroke in Magenta. The result
for the various setttings in a CMYK + Pantone Orange document will look like this:

1. Original
2. Repeat: Cyan, Other Separations: Remove
3. Repeat: Cyan, Other Separations: Static
4. Repeat: Magenta, Other Separations: Map to Darkest

 

 

Tip:  It is advised to keep the Mark content as simple as possible. Using the same
separation for all of the included objects is recommended.

Positioning the Repeat for Separations Marks
The positioning of the Repeat for Separations Marks is set by three different factors:

• 1. The relative positioning of the objects within the Mark Content. It is recommended to make the
positioning of Marks within the content dynamic by attaching them to each other.

This can be done either before creating the Mark, or by using Edit Content. See Editing a Mark on
page 416

In the example underneath, the distance between the square and the text is set in the Mark
Content

2. The Repeat Direction, which defines the direction, positioning and offset / gap of the different
instances of the Mark. See Repeat Direction on page 394

In the example underneath, the distance between the cyan instance and the magenta instance is
defined in the Mark Inspector in the Repeat Direction.

3. In the Transformation Inspector you can set the positioning of the complete Repeat for
Separations Mark, i.e. the complete block of all instances. See Mark positioning on page 411
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In the example underneath, the position of the complete Mark (attached to the Trim Box) is
defined in the Transformation Inspector.

 

 

Repeat Direction
When using a Repeat for Separations Mark, an instance of the Mark Content is created for every
separation.

In the Repeat Direction, you can set how the next instance (indicated by "2") is attached to the previous
one (1). This defines the direction, order and distance.

Note:  If you want to change the positioning of the elements within one instance (e.g. to attach
one of the enclosed Marks to another one), you need to Edit the content of the Mark.

1. Using a GAP distance
If you attach the "2" square on the outside of the "1" square, the different instances are placed next to or
above / below each other. The position of the square defines both the order as the direction.

Repeat direction Positioning of the instances

"2" square on the left side of the "1" square horizontal, ordered from right to left

"2" square on the right side of the "1" square horizontal, ordered from left to right

"2" square on top of the "1" square vertical, ordered from bottom to top

"2" square below the "1" square vertical, ordered from top to bottom

Within that location, the exact position defines the alignment of the instances.

Example: in both examples, the "2" square is placed below the "1" square, so the instances are placed
vertically, ordered from top to bottom. You can see the difference in alignment:

1. aligned on the left side
2. aligned on the right side
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You can add a Gap distance, either vertically  or horizontally  that will be added in between the
different instances.

Example: in the left example, the "2" square is placed on the left side, with no gap. In the right example,
it's placed at the right side, so the order is changed, and a gap was added.

 

 

2. Using a STEP distance
If you place the "2" square inside the "1" square, the different instances are placed on top of each

other. You can set a Step Distance to move the instances horizontally  or vertically . A positive
distance will move the next instance to the right or up, a negative distance to the left or down. You can
change the order by using a negative step distance.

Attention:  When using a Step distance, the size of the different instances is not taken into
account. This can cause instances to overlap, e.g. for long separation names.

Example 1: the instances are aligned on the left side, with a 100mm distance. Note that if an ink name is
longer than that distance, the text might run over another instance.

 

 

Example 2: the instances are centered, with a 40mm vertical distance. You can see that a positive
distance places the next instance above the previous (left), while a negative value places the next
instance below the previous.
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Note:  If you use a Repeat for Separation Mark to create a new Mark, the contents will be
expanded, and if it contained a Text Mark with variable text, it will become static text.

10.3.5.  Repeat by Count Mark

A Repeat by Count Mark is a type of Dynamic Mark that is repeated a number of times, based on the
setting in the Mark inspector. You can create a Repeat by Count Mark by selecting a combination of
objects and select Create Repeat by Count Mark from selection (see Create a Mark from Selection on
page 382). The selected objects become the Mark Content, which is repeated.

The Repeat by Count Mark can contain nested Marks. See Nested Marks on page 417

You can for example create a Repeat for Separations Mark with a color patch for each separation, and
then include this in a Repeat by Count Mark to repeat the Repeat for Separations Mark a number of
times.

Use the Mark Inspector to set all parameters.
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• Underneath a preview of the Mark Content is the Edit Content button. If you want e.g. to edit the
Point Text Mark included in the Repeat for Count Mark, you can click the Edit Content button. See
Editing a Mark on page 416. You can also double-click the Mark while holding the Alt key.

• Define the number of repeats or Loops

• When the first option is enabled, you can enter the specific number of repeats you want. You can
use a Formula. See Formula Editor on page 413. Note that you need a number (without unit).
You can e.g. achieve this by using "Trim Box Width / 10mm". The result will be rounded down to an
integer.

• When the Fill Width (or Fill Height) option is selected, the Mark contents will be repeated as
many times as possible. It will use the Width (or Height) of the Page Box, Grid or Mark the Repeat
by Count Mark is attached to in the Transformation Inspector. By default, a Repeat by Count Mark
will be attached to the Trim Box.

• If Fill Width is selected, the Allow partial Mark option defines if only complete repeats of the
Mark Content are allowed, or if the complete width (or height) should be filled, including a partial
Mark.

• By positioning the "2" square, you can set the repeat direction: left to right (as in the screenshot),
right to left, top to bottom or bottom to top.

• You can add a Horizontal Offset and a Vertical Offset. The offset in the repeating direction (e.g.
Horizontal Offset if repetition is from left to right) adds a gap in between the repetitions.

In the example underneath, you can see a Repeat by Count Mark. You can see:

1. the 7 mm gap
2. the partial Mark
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Positioning the Repeat by Count Marks
The positioning of the Repeat by Count Mark is set by three different factors:

• 1. The relative positioning of the objects within the Mark Content. You can make the positioning of
Marks within the content dynamic by attaching them to each other.

This can be done either before creating the Mark, or by using Edit Content. See Editing a Mark on
page 416

2. The Repeat Direction, which defines the direction, positioning and offset / gap of the different
instances of the Mark.

3. In the Transformation Inspector you can set the positioning of the complete Repeat by Count
Mark, i.e. the complete block of all instances. See Mark positioning on page 411

10.3.6.  Repeat for Grid Mark

A Repeat for Grid Mark is a type of Dynamic Mark that positions itself relative to the stations of your
step & repeat or Grid.

You can create a Repeat for Grid Mark using your selection (see Create a Mark from Selection on page
382) or you can create a Standard Repeat for Grid Mark. This will contain a custom mark containing a
rectangle of 5 x 5mm, in Darkest Color, and will be positioned on the left side of the grid, repeated for
every station.

You can also load the default "Standard 5x5mm Repeat for Grid Mark" Mark Set. See Working with Mark
Sets on page 415. In that case, two Repeat for Grid Marks will be created using a rectangle of 5 x 5mm,
in Darkest Color, one positioned on the left and one on the right side of the grid.

The Repeat for Grid Mark can contain nested Marks. See Nested Marks on page 417

You can for example create a Custom Mark colored in the Darkest Color, and then include this in a
Repeat for Grid Mark to repeat the Custom Mark on your grid.

• Using Repeat for, you can set on which parts of the grid the Repeat for Grid Marks should be placed;
either Stations, Rows (horizontal only), or Columns (vertical only).

• Using the Horizontally and/or Vertically setting you can define the repetition: all columns/rows,
only the first column/row, etc. Using "Custom", you can set it to repeat every x rows or columns.

• Using the Edit Content button, you can edit the shape of the Mark. See Editing a Mark on page 416.
You can also double-click the Mark while holding the Alt key.

• In the Transformation Inspector you can set the positioning of the Mark. In case the grid is
Staggered, an extra dropdown will let you choose to either use each station as reference point, or to
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use the first or last column/row. By setting the Attach to dropdown to "All Grids", the Marks will be
generated for every grid in the document.

10.3.7.  Repeat for Placeholder Mark

The Repeat for Placeholder Mark is automatically attached to all instances of a Placeholder by the
specified name. You can use any Named Object as Placeholder.

This means that if you e.g. attach the Repeat for Placeholder Mark to a Named Object named
"Position2", the mark will be placed for every named object by that name.

MFG and CFF Files
When opening an ArtiosCAD Manufacturing file (.MFG) or a CFF that contains text objects directly in
the manufacturing or layout file (so not in the containing one-up (ARD) files), these text objects are
imported as Named Objects. When you open such a file, the different text objects will not be visible, as
they have no fill or stroke. All imported Placeholders are placed in a new Layer named "Placeholders",
and the "Structural Design" layer has been renamed to "Stations".

If you select the objects in the Placeholders layer, you can see where these placeholders are placed.
You will also see them by their original name in the Named Objects Overview in the Object Browser.
See Object Browser on page 130.

These Named Objects can be used to attach a Repeat for Placeholder Mark

Creating a Repeat for Placeholder Mark
1. Create and select a simple object or a text object
2. Go to Create a Mark from Selection
3. Choose Create Repeat for Placeholder Mark from Selection

By default, the object is attached to the first Placeholder in the list. In the Transformation inspector
you can attach the object to a different Placeholder, or to a different Named Object.

A Repeat for Placeholder Mark is attached to, and so repeated for all instances of a Placeholder or
Named Object by the same name. Because of that, the Transformation inspector will only list each
name once. If your MFG for example contains 5 instances of a “Text 1” text object and 3 instances of a
“Text 2” text object, the Transformation inspector will only list “Text 1” and “Text 2” once. If you attach
the Mark to “Text 1”, the Mark will be repeated for all 5 instances of the “Text 1” placeholder.

The Repeat from Placeholder Mark also supports nesting Custom Marks, Point Text Marks, Area Text
Marks and Barcode Marks. See Nested Marks on page 417

The Repeat from Placeholder Mark is also supported as a Mark in Dynamic Tasks on an Automation
Engine Server.
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Note:  The Repeat from Placeholder Mark does not replace the Repeat for Stations Mark. The
Repeat for Stations Mark also relies on placeholders, but those are placeholders set in the one-
ups, not directly on the MFG.

10.3.8.  Cut Mark

A Cut Mark (also known as corner mark or trim mark) is a type of Dynamic Mark, in most cases a line,
that is positioned twice (once vertical, once horizontal) on every corner of the selected page box. It is
used to align the cutter on printed sheets.

You can create a Cut Mark using your selection (see Create a Mark from Selection on page 382) or you
can create a Standard Cut Mark, which is a line of 10mm, with a stroke of 0.1mm, in Registration Color.

• By default the color of a Cut Mark will be Registration Color when created. In the Mark Inspector
you can select Static, Dynamic or Darkest Color. See Colors and Separations in a Mark on page
410.

• Using the Edit Content button, you can edit the shape of the Mark. In case color is set to Static, you
can also edit the color of the Mark. See Editing a Mark on page 416. You can also double-click the
Mark while holding the Alt key.

• In the Transformation Inspector, using the Attach to dropdown you can define the page box or grid
on which you want to apply the Cut Marks, and the Offset.

10.3.9.  Bearer Bar Mark

A Bearer Bar Mark is a type of Dynamic Mark, in most cases a line, that is positioned on the left or right
(vertical) or top or bottom (horizontal) of the selected page box, grid or grid column, and stretches over
the complete height or width.

Bearer Bars are added in flexography as support, to limit cylinder bouncing during print.

You can create a Bearer Bar Mark using your selection (see Create a Mark from Selection on page 382)
or you can create a Standard Bearer Bar Mark. The Standard Bearer Bar Mark is a rectangle of 5mm
wide, on the left side of the Trim Box, stretched over the height of the page box.

• When creating a Bearer Bar Mark using your selection, the Bearer Bar Mark will be horizontal if the
width of the selection is bigger than its height. Otherwise, it will be vertical.

• By default the color of a Bearer Bar will be in Registration Color using all Artwork Separations. See
Colors and Separations in a Mark on page 410

• Using the Edit Content button, you can also edit the shape of the Mark. See Editing a Mark on page
416. You can also double-click the Mark while holding the Alt key.

• In the Transformation Inspector, you can set the positioning and height settings of the Bearer Bar.
See Bearer Bar Mark Properties on page 400

Bearer Bar Mark Properties
If you have a Bearer Bar Mark selected, the Transformation Inspector will contain some specific
properties.
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Attach To: upon creation, Bearer Bar Marks will be automatically attached to the Trim Box, but you can
attach the Bearer Bar to any page box, Grid or Named Object.

You can place the Bearer Bar on the left side, right side, top or bottom.

Using the Offset field, you can define the offset between the page box or grid, and the Bearer Bar.

The Height for a vertical Bearer Bar can be defined by the height of the Trim Box or the Named Object
the Mark is attached to, the leftmost or rightmost Grid, or the leftmost or rightmost Grid Column. Grid
Column can be useful in case of Staggered grid, since the columns can have a different height and
vertical position. See Stagger on page 352

The Width for a horizontal Bearer Bar can be defined by the width of the Trim Box or the Named Object
the Mark is attached to, the topmost or bottommost Grid, or the topmost or bottommost Grid Row.
Same as for the Height, Grid Row can be useful in case of Staggered grid, since the Rows can have a
different width and horizontal position. See Stagger on page 352

The height can be adjusted by entering a value in the Bearer Bar Extend field . A positive value will
be added to the height (top and bottom), a negative value will make the Bearer Bar smaller in the same
way.

Note:  If you are looking for more flexibility in defining the width and height, you could use a
Resize Mark instead. See Resize Mark on page 406

10.3.10.  Clip Mark

A Clip Mark is a type of Dynamic Mark that clips its content, based on the setting in the Mark inspector.
You can create a Clip Mark by selecting a combination of objects and select Create Clip Mark from
selection (see Create a Mark from Selection on page 382). The selected objects become the Mark
Content, which will be clipped.

Note:  ArtPro+ contains a number of Standard Clip Marks optimized for 5 by 5 mm patches. See
Clipping a control strip on page 402 and Working with Mark Sets on page 415

The Clip Mark can contain nested Marks. See Nested Marks on page 417

Use the Mark Inspector to set all parameters.
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• Underneath a preview of the Mark Content is the Edit Content button. If you want e.g. to edit the
Point Text Mark included in the Resize Mark, you can click the Edit Content button. See Editing a
Mark on page 416. You can also double-click the Mark while holding the Alt key.

• By default the color of a Bearer Bar will be in Dynamic Color using all Separations. See Colors and
Separations in a Mark on page 410

• Define how to Clip:

• Width: the content is clipped to the entered width. You can use a Formula to define the width.
See Formula Editor on page 413

• Height: the content is clipped to the entered height. You can use a Formula to define the height.
See Formula Editor on page 413

Note:  Clipping is always done from the center of the content.

Clipping a control strip
A Clip Mark can be used to clip a Marks file or control strip as provided to you by e.g. a Press
Manufacturer to allow precise measurements. These Marks files or control strips typically consists of a
number of square patches, text and other objects. This band of patches will then be clipped to the size
of your document.

Using the correct formulas, you can ensure clipping is only done so that only full square patches are
used.

402



10ArtPro+

1. Open the supplied file, containing objects, text and squares.
2. Select all these objects, and in the Marks section, choose Create Clip Mark from selection (see

Create a Mark from Selection on page 382). The selected objects become the Mark Content.
3. Define these options and values:

Note:  these options correspond to the settings in the Clip Mark in ArtPro+ 18.1 and earlier.
Opening a file containing a Mark created in this version will automatically have the correct
formula applied.

• The Reference Object: in most cases, you will want to use the page box width.

• The Step Distance should match the size of the square patches

• The Center is Even if the Mark contains an even number of steps, so the center will be located in
between the two middle rectangles. If the Mark contains an odd number of steps, the Center is
Odd so the center will be located on the middle of the rectangle in the middle.

• The End Steps settings define if partial patches should be removed or added. In the example
underneath you see the difference between 1.Add and 2. Remove, with correct Step Distance
and Center settings.

4. Choose the correct formula for the Width to clip the Mark content:

Number End Steps Formula

Even Add (EVEN ( ( Reference Object Width / Step Distance ) ) * Step
Distance

Even Remove ( FLOOR ( ( Reference Object Width / Step Distance ) ; 2 ) *
Step Distance

Odd Add ( ODD ( ( Reference Object Width / Step Distance ) ) * Step
Distance

Odd Remove ( FLOOR ( ( Reference Object Width / Step Distance ) - 1 ;
2 ) + 1 ) * Step Distance

Note:  Replace Step Distance with the actual Step Distance you want to use. Use a Variable
to enter the Reference Object Width.

Note:  In case you have a vertical control strip, use the Reference Object Height instead of
the width, and use the formula to define the Clip Height
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Note:  ArtPro+ contains a number of Standard Clip Marks that provide the same Even/Odd,
Add/Remove options for 5 by 5 mm patches. See Working with Mark Sets on page 415

10.3.11.  Barcode Mark

A Barcode Mark is a Mark that uses a barcode. See The Barcode types on page 234 for a full list of
all supported barcodes. It can be used to add technical information about the job in an automated
workflow.

You can create a Barcode Mark by selecting a barcode and choosing Create Barcode Mark from
Selection (see Create a Mark from Selection on page 382)

Use the Mark Inspector to set all parameters.

• The Code shows the text that will be used in the Barcode Mark.

• You can use Insert Smart Text... to use variables in the Code. See Using Smart Text on page 385.
The Preview on the Mark inspector shows the resulting value of the Code with all of its variables.

• A Barcode Mark can use Darkest Color, Registration Color or Static Color. See also Colors and
Separations in a Mark on page 410. When using Static Color, you can change the color using the
Fill Color Inspector. See Fill Color and Stroke Color Inspector on page 182. You can create multicolor
barcodes for the barcode types that support it (such as Laetus Pharma). See Multicolor barcodes on
page 296

Note:  If you want a multicolor Barcode Mark to update dynamically when the document
separations are modified, you should set the barcode to multicolor, and then switch the
color setting of the Barcode Mark to Registration Color setting. The Multicolor Barcode
Mark will then be dynamically filled, based on the Use setting and the document separations
list.

• For Data Matrix, QR and MicroQR barcodes: If the Use Smallest Possible Symbol Size is enabled,
the Barcode Mark will be resized to the smallest possible symbol size, depending on the length of
the Code. You will not be able to set the Minimum Symbol Size parameter in the Barcode inspector.
If the option is disabled, the size of the Barcode Mark can be increased if needed depending on
the length of the Code, but it will not decrease below the Minimum Symbol Size set in the Barcode
inspector.

Notes and Restrictions:

The Code used inside the Barcode Mark has to meet the requirements of a valid barcode of the
selected type.

It is possible that a valid Barcode Mark becomes invalid if the value of a variable changes. In this
case, the Mark becomes invalid or empty, and a Message is shown in the Messages drawer. See Error
Messaging for Marks on page 418

Position Placeholders
If you have placed an ARD file that contains named areas inside the Dynamic Art layer, you can use
these Position Placeholders to position Barcode Marks.

Note:  The Position Placeholders will be included if you use the "Full", "Full (single separation) or
the new "Placeholders" profile. See Structural Design File Inspector on page 229.
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In the Attach to dropdown in the Transformation Inspector for the Barcode Mark, you can select all
Position Placeholders found in the ARD file.

Also in the Transformation Inspector, you can enable Link in the rotation field. By enabling linking, the
Barcode Mark will automatically use the same rotation as the Position Placeholder you're attaching it
to.

 

 

See also Mark positioning on page 411

10.3.12.  Dimensions Mark

A Dimensions Mark adds dimensions to a page box, Step & Repeat grid or a named object (e.g. another
mark). This works the same way as the Add Dimensions tool. See Add Dimensions on page 308 .

If you have Dimension Lines created by the Add Dimensions function selected (and nothing else), you
can create a Dimensions Mark using your selection (see Create a Mark from Selection on page 382).

You can also create a Standard Dimensions Mark, which is attached to the Trim Box.

In the Dimensions inspector you can set the same parameters as for Add Dimensions. See Add
Dimensions on page 308

If the reference object or page box is changed, the Dimensions Mark is updated automatically. If the
reference object or page box is deleted, the Dimensions Mark becomes attached to the Trim Box.

10.3.13.  External File Mark

An External File Mark is a Mark that uses a linked placed PDF.

You can create an External File Mark from a selected linked placed art object by using Create External
File Mark using Selection (see Create a Mark from Selection on page 382) or you can use Add External
File Mark to create an empty External File Mark. You can then open the Mark inspector and either
browse to a valid PDF file or enter a valid URL that points to the external file to use.

Use the Mark Inspector to set all parameters.

• The URL shows the location of the external file to be used. A valid URL is in this format: file://
host/path, using forward slashes. Relative paths can also be used, e.g. ../../mark/
markfile.pdf

• Use the Browse... button to browse to the external file you want to use. The URL will be entered
automatically.

• You can use Insert Smart Text... to use variables in the URL. See Using Smart Text on page 385

• By default, the Fill and Stroke will be set to Static Color, so the exact same colors (and inks) as
in the external file are used. You can however switch to e.g. "Darkest" to recolor the content of
the external file. Note that gradients, images and patterns will not be recolored. See Colors and
Separations in a Mark on page 410

Notes and Restrictions:
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• Only PDF files can be used as External File Marks.
• Editing and saving the external file will NOT automatically update the Mark. Use the Update Marks

 button to synchronize.

• When using a multipage PDF as External File Mark, only the first page is used.

• When using Create External File Mark from Selection, the External File Mark will use the bounding
box of all printable content in the file, i.e. the bounding box of all elements in printing layers. It is
possible that previously invisible objects become visible, and the external file might move since the
bounding box can be different.

• You can not shear or scale an External File Mark. Moving and rotating is allowed.

10.3.14.  Position Mark

A Position Mark is a Mark without any color or contents. You can set its size and position using fixed
dimensions or formulas, and attach other Marks to the Position Mark .

You can create a Position Mark using your selection (see Create a Mark from Selection on page 382) or
you can create a Standard Position Mark, which is an empty rectangle of 10 x 10 in the current length
unit, positioned at the top left of the Trim Box.

If you create a Position Mark from a selection, the bounding box of the selection is used to define the
position and size of the Position Mark. Any color or contents is discarded.

Use the Mark Inspector to set the width and height. Use the Transformation Inspector to set the
vertical and horizontal position. In both inspectors, you can use formulas. See Formula Editor on page
413

10.3.15.  Resize Mark

A Resize Mark is a type of Dynamic Mark that is resized either vertically or horizontally, based on the
setting in the Mark inspector. You can create a Resize Mark by selecting a combination of objects
and select Create Resize Mark from selection (see Create a Mark from Selection on page 382). The
selected objects become the Mark Content, which is resized.

The Resize Mark can contain nested Marks. See Nested Marks on page 417

Use the Mark Inspector to set all parameters.
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• Underneath a preview of the Mark Content is the Edit Content button. If you want e.g. to edit the
Point Text Mark included in the Resize Mark, you can click the Edit Content button. See Editing a
Mark on page 416. You can also double-click the Mark while holding the Alt key.

• Define how to Resize:

• Stretch Vertically: the content is stretched or shrunk to match the entered height. The width is
at 100%.

• Stretch Horizontally: the content is stretched or shrunk to match the entered width. The height
is at 100%.

• Stretch to Fill Area: the content is stretched to match both the entered height and width.

• Shrink Vertically: the content is shrunk to match the entered height. The width is at 100%. The
content is never stretched up.

• Shrink Horizontally: the content is shrunk to match the entered width. The height is at 100%.
The content is never stretched up.

• Shrink to Fill Area: the content is shrunk to match both the entered height and width. The
content is never stretched up.

• Scale to Fit Inside Area: the content is scaled (up or down) proportionally to fit inside the
defined area (width and height).

• Shrink to Fit Inside Area: the content is scaled down proportionally if necessary to fit inside the
defined area (width and height). The content is never scaled up.

• When selecting Scale Relatively you can enter the scale factor for both vertical and horizontal
scaling (in percentage).
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Note:  The Scale to Fit Inside Area and Shrink to Fit Inside Area options are proportional:
vertical and horizontal scaling factors are always the same. Scale Relatively can be
proportional or non-proportional: if the lock is enabled, scaling is proportional, so
vertical and horizontal scaling factors are the same. If the lock is disabled, scaling is non-
proportional, so vertical and horizontal scaling factors can be different. All the other
options are non-proportional.

• Define the Width or Height. You can use a Formula to define the size. See Formula Editor on page
413

• At the bottom of the inspector you can see the actual size of the Resize Mark, including the applied
scaling factor (a single percentage for proportional scaling, a scaling factor for vertical and
horizontal scaling for non-proportional scaling).

10.3.16.  Repeat for Stations Mark

In a Step & Repeat workflow, you can add a Repeat for Stations Mark on a Grid Step&Repeat or an MFG
or CF2 repetition file. It is a type of Dynamic Mark that positions itself relative to a placeholder (most
commonly a StationNumber placeholder) for every station of your Grid Step&Repeat, MFG or CF2 step
& repeat.

You can create a Repeat for Stations Mark using your selection (see Create a Mark from Selection on
page 382) or you can load the default "Standard Repeat for Stations Mark - Station Number" Mark
Set, see Working with Mark Sets on page 415. In that case, a Repeat for Stations Mark will be created,
containing a Point Text Mark using the Station Number as variable, in Darkest Color, positioned
centered on the StationNumber placeholder for every station.

The Repeat for Stations Mark can contain nested Marks. See Nested Marks on page 417

• Using the Edit Content button in the Mark Inspector, you can edit the shape of the Mark. See
Editing a Mark on page 416. You can also double-click the Mark while holding the Alt key.

• In most cases, the Repeat for Stations Mark contains a Point Text Mark, containing the variable
"Station Number". You can use the Mark Inspector to adjust the text, e.g. to add other SmartText
variables next to the Station Number variable. See Using Smart Text on page 385

Note:  When using Job and Product Parameters in your Station Numbering Mark, these
parameters are resolved according to the context of the stations (so the Job or Product
the one-ups are part of) and not the context of the repeat file.

• Using the Text Inspector, you can change the text style of the Point Text Mark
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• You can set the Station Order in the Mark Inspector:

• When selecting Back to Front, the sequence set in ArtiosCAD and stored in the MFG file will be
used. When used on a Grid Step&Repeat, top left is used as starting point, and the direction will
be vertical zigzag.

• If you set the order manually, you can use the buttons on the left to define the starting point, and
the buttons on the right to define the direction.

• You can set the Fill color and Stroke. See also Colors and Separations in a Mark on page 410

• In the Transformation Inspector you can set the positioning of the Mark.

• If you want to create Station Numbers based on the StationNumber placeholder saved in your
one-up graphics, select StationNumber from the From Placed Art section in the dropdown.
You can select any placeholder found in the stations. If a placeholder is present in some but not
all stations, its name will be shown with an exclamation mark. If you select such a placeholder,
the Repeat for Stations Mark will only be visible on the stations that contain the selected
placeholder.

• If you want to create Station Numbers based on a text object in the one-up structural design file,
select the text item from the From Layout section.
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Note:  If at the time of creating the Mark not all stations have the same placeholder, the
Repeat for Stations Mark will be attached to a dummy "Placeholder". The Marks will be
selected but not visible until you attach the Mark to a placeholder that exists in a number of
stations.

For more information, see Station Numbering in an MFG / CF2 workflow on page 360

Note:  When applying a Repeat for Stations Mark on a Grid Step & Repeat, station numbers
for partial stations may be clipped. To avoid partially visible Station Numbers, be mindful when
determining the position of the placeholders in the one-ups, and when setting the anchor point
and offset for the Mark.

10.4.  Colors and Separations in a Mark

Important:

To make sure your Marks are visible when they are being created, it is advised to create
Dynamic Marks while there are no unused separations in the document.

Keep in mind that a separation that is only used in the object that you turn into a Mark will also
become unused by doing so. It is advised to avoid this by making sure the separations are also
used in another 'normal' object besides the object you turn into a Mark.

For predictable results of the colors of a Mark, it is advised to use solid colors, and no
gradients, images or patterns.

The color options depend on the type of Mark. For most singular Marks, all options below are availabe.
For Barcode Mark, only Darkest Color, Registration Color or Static Color is available.

• Static Color: If color is set to Static, the original color of the object that is used to create a Mark
from is stored, based on the actual separations. The color of the Mark will not change if the order of
the separations list is changed.

Note:

When placed on an existing document, "Static Color" Marks are the only Marks that affect
the separation list: the separations used in the Mark will be added if necessary.

• Dynamic Color: If color is set to "Dynamic", the current color is stored, but based on the separation
positions in the separations list, and not the actual separations. If color is set to Dynamic, the Mark
Inspector will show the index numbers of the separations used in the Fill or Stroke.

For example, if the first separation is Cyan, a 100% cyan Mark is stored as "100% of the first
separation". If the first separation is different (by changing the separation order, or by placing the
Mark on a different file), the Mark will become 100% of the first separation.

• Darkest Color: The Mark will be colored with 100% of the darkest separation used in the document.
You can't change the percentage for "Darkest" separation, it will always be 100%.

Changing the separations in the document can change the color of the Mark. When changing the
color to "Darkest Color", the filter underneath will automatically switch to "Artwork Separations". See
below.
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Note:  If you manually change the color of a Text Mark that is set to Darkest, the color will
change back to the darkest separation at the next Mark update.

• Black or Darkest Color: The Mark will be colored with 100% Process Black if it is already used on
the page. If not, the mark will be colored with 100% of the darkest separation used in the document.
Changing the separations in the document can change the color of the Mark. When changing
the color to "Black or Darkest Color", the filter underneath will automatically switch to "Artwork
Separations". See below.

Note:  If you manually change the color of a Text Mark that is set to Black or Darkest, the
color will change back to black or the darkest separation at the next Mark update.

• Registration Color: the highest percentage value used in the Fill or Stroke in the Mark Content will
be applied to all separations.

For Dynamic Color, Darkest Color and Registration Color as well as for Repeat for Separations Mark, you
can indicate what separations to be used in the Mark, by setting the Use (for Color) or For (Repeat for
Separations) dropdown:

• All Separations
• Artwork Separations
• Processing Step Separations (See Processing Step Layers on page 127)

• Artwork Separations and Varnish

• Custom: This allows you to select separations by combining rules on Printing Method, Processing
Step, Separation Name, Process Separations, Non-Process Separations or Artwork Separations.
When setting up a rule using the Separation Name, you can use Smart Text instead of entering text.

• In case of Dynamic Color or Repeat for Separations, you can also use Printing Units. When this is
selected, the order of the assigned Printing Units is used, and only separations with an assigned
Printing Unit will be used. For more information on Printing Units, see Working with Printing Units on
page 141.

Using the Subset of Separations, you can select specific separations from the result of the For or
Use setting above, based on the index.You can define a range (e.g. 1-3), a list (e.g. 1,3,4,7) or even
insert Smart Text variables, to use specific variables from the server. If the Subset of Separations is
disabled, all separations defined using the For or Use setting will be included.

Bearer Bar Marks will by default be colored in 100% of all artwork separations. You can change this to
Custom. This allows you to include inks based on the printing method.

To change the Mark content itself, i.e. the shape and color of the objets used to create the Mark, you an
click the Edit Content button in the Mark Inspector. See Editing a Mark on page 416.

10.5.  Mark positioning

The position of a Custom Mark is set in the Transformation Inspector.
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It is based on 3 settings:

Reference Object (Attach to)
The position of the Mark is dynamic, and is always attached to a reference object. This can be:

• Any page box: Media Box, Crop Box, Bleed Box, Trim Box or Art Box
• another Dynamic Mark
• any named object, i.e. every object that is listed in the Named Objects Browser. See Object Browser

on page 130. Keep in mind that if you load a Mark Set, any Marks attached to a Named Object that
doesn't exist in your target document will be ignored. See also Working with Mark Sets on page 415

Note:  When positioning a Barcode Mark, you can also use Position Placeholders imported
from an ARD file. See Barcode Mark on page 404

Positioning
The way the Mark is attached, can be chosen by clicking and dragging the colored square (representing
the Mark) to the desired position on the gray square (representing the Attach To reference). Each
square has 9 reference points (top left center and right, middle left center and right, and bottom left
center and right), so you have 81 different ways of positioning the Mark.

In the example underneath, the top center of the (bounding box of the) Mark will be placed on the left
bottom corner of the (bounding box) of the reference defined in the Attach to field.

 

 

Note:  If you create a Mark from an existing object, the Positioning settings (the colored
square) will be automatically set, using the smallest offset possible while keeping the object at
the same location.

Offset & Rotation
In the offset fields, you can move the Mark based on the defined position. A positive value for offset
moves the Mark to the right / bottom, as indicated by the arrows.

Using the Fx button, you can open the Formula Editor. See Formula Editor on page 413
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Note:  Formulas are currently not available for Grid Marks, Bearer Bar Marks, Cut Marks and
Station Number Marks

Note:

Marks that are not using a formula can also be moved manually. In that case, the offset will
automatically adjust to the new location. The other settings (Attach To and Positioning) will
NOT change.

When trying to move a Mark with a formula using the interactive Transform tool or the Numeric
Transform, the Mark will be reset to its original position. You can move it by changing the offset
in the Transform inspector, and the formula will be lost.

Using the Rotation, you can rotate the Mark. For Input File Mark and External File Mark, you can use a
Formula to set the rotation. See Formula Editor on page 413

Changing the Reference Object of a Mark
When changing the Reference Object of a Mark by selecting another item from the Attach to
dropdown, by default the Offset values are kept, and the Mark will be repositioned.

However, by holding the Alt key, you can keep a Mark at its the position, and the Offset values will be
recalculated.

This can be used for the following marks: Custom Marks, Point Text Marks, Area Text Marks, Repeat for
Separations Marks, Barcode Marks and External File Marks.

Holding the Alt key will have no effect for other types of Marks, or if the Offset value is set using a
formula.

10.6.  Formula Editor

For certain properties when setting up a Mark, indicated by an fx symbol, you can use a formula with
variables. For example in the Transformation inspector for Marks, you can set the Offset using a
formula.

1. Select a Mark, and open the Inspector you want to set.
2. For the property you want to edit, click the fx button to open the Formula Editor.
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3. In the formula editor, on the left hand side, you see the available Variables and Functions. In the

right column, you can compose the formula to be used, for example "Trim Box Width / 2"
4. To add a Variable:

a) Select Variables
b) Select a Category in the left hand column
c) In the middle column, select a variable you want to use in your formula, e.g. Trim Box Width. You

can enter a Search key to find the Variable you're looking for.
d) Double-click the variable to add it on the cursor position, or drag and drop it.

Note:  All positional variables used in a formula use the distance of the selected variable
(e.g. the top of the Media Box) measured from the top left corner of the Trim Box. A positive
value is downwards or to the right, a negative value up or to the left.

5. You can combine variables using operators: plus (+), minus (-), multiply (*), divide (/). You can also
use brackets.

6. You can add fixed values by typing them in the formula.
Note that distance values must have a length unit, e.g. "3mm".

7. To add a Function:
a) Select Functions
b) Select a Category in the left hand column
c) In the middle column, select a Function you want to use in your formula, e.g. ABS (absolute

value). You can enter a Search key to find the Function you're looking for.
d) Double-click the Function to add it on the cursor position, or drag and drop it.
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You can also type in the Function manually.

Important:

Functions are always typed full caps and arguments are split up using a semicolon:
FUNCTION(a;b;c)

A dot (.) or comma (,) are both used to express numbers with decimals.

More information about each function can be found in the Formula Editor itself.
8. Click OK to accept the formula

If the entered formula is valid, the Preview will show the calculated result. Otherwise it will show an
error message.

You can remove a formula by entering a value in the property field.

The fx button will be gray if no fomula is set, red if an invalid formula is set, or blue if a valid formula is
used. A tooltip will show the content of the formula

 

 

10.7.  Working with Mark Sets

By saving a Mark Set, you can save all existing Marks in the document in a Set, which can then be
loaded and applied in other documents.

By clicking the Load Mark Set button , the Load Mark Sets dialog will open.

• If you have an Automation Engine connection set up, the list of Mark Sets will show all compatible
Mark Sets saved on the server. If not, it will list the locally saved Mark Sets. See Automation Engine
connection on page 72

• The list will also contain the ArtPro+ default Mark Sets, e.g. Standard 5x5 Grid Mark
• Use the Search field to filter the list of Mark Sets.

• Enable Replace Current Marks if you want to remove all Marks in your documents, and add the
Marks defined in the Mark Set. Disable the option to add the Marks from the Mark Set to your current
Marks.

• Select a Mark Set in the list, and click Load to load the Marks defined in the Mark Set. You can also
double-click the Mark Set in the list.
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Note:  When loading a Mark Set, any Marks that are attached to a Named Object that doesn't
exist in your current document will be ignored.

Click the Save/Delete Mark Set button  to save, overwrite or delete a Mark Set.

• If you have an Automation Engine connection set up, the list of Mark Sets will show all compatible
Mark Sets saved on the server. If not, it will list the locally saved Mark Sets. See Automation Engine
connection on page 72

• Use the Search field to filter the list of Mark Sets.
• Enter a new name for the Mark Set and click Save to save the current set of Marks as a new Mark

Set.
• Select a Mark Set from the list (or enter its exact name) and click Update to overwrite it.
• Select a Mark Set in the list, and click the - button to remove it.

To change a Mark Set, it is better to do this on the saved Marks file than on the document where you
applied the Mark sets.

Local Mark Sets are saved in C:\ProgramData\Esko\DynamicMarks (Windows) or /Users/
Shared/Esko/DynamicMarks (Mac OS).

Mark Sets on an on-premises Automation Engine are saved in \\servername\Esko
\bg_data_marks_v010\DynamicMarks

Note:  When applying a Mark Set in an older version of ArtPro+, new Mark types and new
features of existing Marks will not be recognized.

Tip:

When you save a Mark Set, the entire document is saved. Because of that, we advise to follow
these guidelines when creating a Mark Set from a document:

• The document should only contain a minimum of artwork objects (other than the Marks).
• The document should contain enough separations to be representative for your jobs.
• All separations are in use, and not only used by the Marks.

A good example would be a document with 7 separations, with a single rectangle in the Artwork
layer colored in all of these separations, and then all applicable Marks added to the document
using the correct "attach to" settings, and the applicable color settings defined in the Mark
Inspector.

10.8.  Editing a Mark

Even after creating a Mark, you can edit its appearance, regardless of whether it was a Mark created
from Selection or a Standard Mark

1. Select the Mark you want to edit
2. In the Mark Inspector you can see a preview of the objects used in the Mark ("Mark Content"). In the

Inspector, you can also change its coloring strategy (see Colors and Separations in a Mark on page
410).

3. Click the Edit Content button, or double-click the Mark while holding the Alt key, to open the Mark
Content in a special Editing mode, e.g. to add or remove objects, change the shape, or change the
colors.
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4. Click the Back to Document button to close the Editing mode, and return to your document window.
The Marks on the document are automatically updated.

10.9.  Nested Marks

There are a number of Marks that can contain nested Marks:

• Clip Mark. See Clip Mark on page 401

• Repeat for Separations Mark. See Repeat for Separations Mark on page 391

• Repeat by Count Mark. See Repeat by Count Mark on page 396

• Repeat for Grid Mark. See Repeat for Grid Mark on page 398

• Resize Mark. See Resize Mark on page 406

These Marks can contain the following nested Marks that are not expanded and remain dynamic:

• Point Text Marks, Area Text Marks and Text-on-Path Marks
• Custom Marks
• Barcode Marks
• External File Marks
• Position Marks

A Repeat by Count Mark, Repeat for Grid Mark and Resize Mark can also contain a Repeat for
Separations Mark, which in turn can contain other nested marks.

A Repeat by Count Mark or Repeat for Grid Mark can also contain a Resize Mark.

A Resize Mark can also contain a Input File Mark when working on a Report Template. See Report
Template on page 84 and Input File Mark on page 86

Any other Mark types will be expanded when they are included in a Mark.

Nested Marks are shown in the Marks section of the Side Panel. A nested Mark is a Mark that is used as
content for another Mark, for example a Custom Mark inside a Repeat for Separations Mark, or an Input
File Mark inside a Resize Mark.

Since you can't rename or select a nested Mark on the document level, its name is grayed out.

Double-clicking the name of a nested Mark will allow you to modify the nested Mark, similar to selecting
the enclosing Mark and clicking the Edit Content button in the Marks Inspector. This also implies that
if the enclosing Marks contains more than one nested Mark (as in the example above), double-clicking
any of the nested Marks will allow to edit them all.

Click Back to Document in the upper toolbar to return to Document level. See also Editing a Mark on
page 416
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10.10.  Updating Marks

In some specific situations, it can occur that a Dynamic Mark goes "out of sync".

• When a placed file was altered outside of ArtPro+, e.g. if a separation is removed from a linked
image in Photoshop. If the separation isn't used elsewhere in the document, it should no longer
appear in the Marks.

• If a Text Mark uses a variable that was changed on the Automation Engine side.

Marks in ArtPro+ are updated automatically in a number of situations

• After opening a document, Dynamic Marks are updated when you start editing the document.

Note:  Note that in ArtPro+ opening a document never changes the document, only
when you start editing it. For the same reason, Marks are only updated when you edit the
document.

• If embedded Placed Art is changed in Edit Placed Art mode, Marks are updated immediately. See
Edit Placed Art on page 225

• For linked placed Art that was edited outside of ArtPro+, selecting Update will also trigger the
Marks to update. See Update on page 222

• Most but not all Smart Text Variables are updated live. There is e.g. no live update if if you are using
the ink coverage variable, if you are using the modification time variable or if a value of a server
variable is changed on the server side. To trigger an immediate update, you can use the Update

Marks button .

• Marks containing server variables that were changed in Automation Engine side, will be updated
when the file is edited after opening the file.

Note:

Server variables are only updated once per ArtPro+ session, so if the server variables are once
again changed on the Automation Engine server while the file is open in ArtPro+, ArtPro+ will
not pick this up. There are three ways to trigger an update of the server variables:

• Quit and relaunch ArtPro+. This is the most effective way.
• Remove and reestablish the Automation Engine connection.
• Use the Update Marks button 

10.11.  Error Messaging for Marks

When the generation of a Mark results in an error, the invalid Mark will not be visible, and a Message is
shown in the Messages drawer.

To fix the issue, read the Message closely - hovering over the message will show a more descriptive
tooltip. Then, select the Mark listed underneath the Message to select the (invisible) Mark and make the
relevant inspectors available so you can correct the settings.
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Common errors:

• Smart Text that can't be resolved correctly.
• Code Too Long: the code for a Barcode Mark contains too many characters, e.g. more than 35 for a

MicroQR barcode. Fix this by changing the Code itself.

• Invalid Character or Invalid Character Set for a Barcode Mark: Not all characters are supported in
all barcode types. If those characters are used in the Code field, you can fix it there. If the Smart
Text variables "File Name" or "Separation Name" results in invalid characters in the Code, you should
remove the unsupported characters from the file name or separation name. Alternatively, you can
switch to using the "Abbreviated Separation Name".

Error Message Levels
A Mark can fail at three different levels:

• At Document level: an issue with a Mark directly on the document. You will get a regular error
message. You can fix the issue by selecting the Mark and checking the settings in the available
inspectors.

• At Mark Content level: an issue with a "nested" Mark: a Mark that is used as Content of another
Mark. In that case, the error message will end with "(Mark Content)". Select the corresponding Mark,
and in the Mark Inspector click the Edit Content button. In Edit Content mode, the error message
will be shown again, now for the specific nested Mark. Fix the issue by selecting the Mark and
checking the settings in the available inspectors.

• At Mark Repetition level: an issue with one or more of the repetitions of a "nested" Mark: a Mark
that is used as Content of a Repeat for Spearations or Repeat by Count Mark. An example of this is a
microQR Barcode Mark inside a Repeat for Separations Mark, using the variable "Separation Name"
as Code. If the name of one of the separations is too long to fit in the microQR code, you will get an
error message, indicating what repetition is causing the error. Fixing this error can be done in Edit
Content mode (see above), e.g. by using the Abbreviated Separation Names as Smart Text. It can
also be fixed by shortening the separation name in your document.

Tip:  If you have both "Mark Content" and "Mark Repetition" errors for the same Mark, start by
resolving the Mark Content error(s). This might resolve some of the Mark Repetition errors.

For more information on Nested Marks, see Nested Marks on page 417

10.12.  Newer Marks in older versions of ArtPro+

If a new Mark type or new feature in an existing Mark type is introduced in a specific version of ArtPro+,
older ArtPro+ versions will not be able to 'understand' it.

Opening a file

If you open a file containing such a Mark, you will either see a message that the Mark is too new and is
not recognized as a Mark but as a Protected Object, or that the Mark has unknown features that will be
discarded when editing, meaning that the Mark can be kept live but can only continue to use properties
known to that software version.

Loading a Mark Set

When you load a Mark Set that contains a Mark or Mark feature that is too new for that version, none of
the Marks will be loaded because the absence of one of the Marks could destroy the whole logic (e.g.
Marks attached to other Marks). A toast message will be shown in that case.
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Automation Engine

The same applies to the use of Dynamic Marks on Automation Engine. So be sure to create Marks and
Mark Sets in the same version of ArtPro+ as the Automation Engine version on which you want to apply
them.
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11.  Action Lists
Using PDF Action Lists (.pal) you can automate a number of ArtPro+ functions. Action Lists are
managed in the Action List Preferences and can be run or edited from the Action List Side Drawer.

11.1.  The Action List Side Drawer

The Action List Side Drawer shows all Action Lists set up in the Action Lists tab of the Preferences.

• Filter the Action Lists by entering (a part of) an Action List Name in the Search box.

• Recently run Action Lists can easily be run again from the Recent Action Lists section.

• Underneath you have the Favorites section.

• You can add an Action Lists to the Favorites by right-clicking it and choosing Add to Favorites.

• You can remove an Action List from the Favorites by right-clicking it and choosing Remove from
Favorites.

• If you hover over an Action List, you will see what shortcut is assigned to it. See the Keyboard
section in Preferences on page 49

• To run the Action List on your current document and selection:

• Double-click an Action List in the Action List Side Drawer
•

Select an Action List and click the Run button 

• Select an Action List and choose File > Action List > Run Action List

• Select an Action List and use the shortcut Cmd+Alt+Shift+A (Mac) or Ctrl+Alt+Shift+A
(Windows).

• Right-click an Action List and choose Run

• Shift - double-click an Action List, or select it and select Run With Options in the fly-out menu to
run the Action List on a selection of pages, or redefine the Action List Parameters used in the
Action List. See Run With Options on page 423

• Select an Action List, and select Step Through... in the fly-out menu or right-click the Action List
and choose Step Through... to step through the Action List. See Stepping through an Action List on
page 422

• Select an Action List and click the Edit button  or right-click the Action List and choose Edit to
edit the Action List in the Action List Editor. See The Action List editor on page 425

• Select an Action List and select Modify Parameters... from the fly-out menu, or right-click the
Action List and choose Modify Parameters... to change the Parameters used in the Action List. See
also Parameters in Action Lists on page 467

• Choose Manage Action Lists... from the fly-out menu to open the Action Lists tab of the
Preferences, where you can manage your Action Lists. See Managing Action Lists on page 424
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11.2.  Stepping through an Action List

The Step Through function in Action Lists can be used for various reasons:

• To run an Action List step by step, and checking the result of every step individually, e.g. to debug
the action list.

• To run only a part of an Action List
• To perform additional actions (e.g. changing the selection) in the middle of an Action List.

In the Action List Side Drawer, select the Action List you want to use, and select Step Through in
the fly-out menu.
The Action List Side Drawer will change to the Actions Side Drawer
 

 
a) Click the triangle in front of an Action to show or hide the settings for it
b) Click an Action to select it
c)

Select Perform Selected Action from the fly-out menu, or click the  button to perform the
selected Action

d)
Select Run Selected Action and all Actions below from the fly-out menu, or click the 
button to perform the selected Action and all following actions.

e) Enable Zoom to Selection to automatically zoom in on the object(s) selected after the
performed Action.

f) Click the Edit button  or select Edit Actions from the fly-out menu to open the current Action
List in the Action List Editor. In the Action List Editor, all actions will be collapsed except for the
action selected in the Actions Side Drawer. After changing the Action List, you can continue to
step through. See The Action List editor on page 425
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g)
Click the Modify Parameters button  or select Modify Parameters... from the fly-out menu
to change the Parameters used in the Action List. The Parameters are only used for the current
Step Through session, and are not stored in the Action List.

h)
Select Exit Step-Through mode from the fly-out menu, or click the  button to stop the Step
Through and return to the Action List Side Drawer.

11.3.  Run With Options

When you run an Action List, the Action List is executed on the current page, using the parameters
as set in the Action List. To run the Action List on a selection of pages, or to redefine the Action List
Parameters used in the Action List, you can Run With Options

1. In the Action List Side Drawer, select the Action List you want to use, and select Run With Options
in the fly-out menu.
 

 
2. In the Page Range section you can define on what pages to run the Action List

• Current Page is the default behaviour, and runs the Action List only on the current page.
• All Pages runs the Action List on all pages in your document.
• Using Selected Pages you can specify what pages to run the Action List on.

3. In the Action List Parameters section, you can see all Action List Parameters defined in the
Action List, and the current value. You can edit the parameters to use different values. For more
information on Action List Parameters, see Parameters in Action Lists on page 467.

4. Click Run to run the Action List on the selected pages and using the defined Action List
Parameters.
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11.4.  Managing Action Lists

In the Action List Side Drawer, choose Manage Action Lists... from the fly-out menu, or choose File
> Action Lists > Manage... to open the Action Lists tab of the Preferences. You can also open the
Preferences and switch to the Action Lists tab then. See Preferences on page 49

 

 

You have three types of Action Lists: Local Action Lists, in which you can add, edit and remove Action
Lists, Standard Action Lists, which contains pre-configured Action Lists provided by Esko, and Server
Action Lists, only available if you have an Automation Engine Connection.

Note:

Local Action Lists are saved in C:\Users\currentuser\AppData\Roaming\Esko
\ArtPro+\Action Lists (Windows) or /Users/currentuserl/Library/
Application Support/ArtPro+/Action Lists (Mac OS).

Action Lists on Automation Engine are saved in \\servername
\bg_data_custom_v010\dat\PDF Action Lists

On top, you have the Favorites category, where you can easily access your favorite Action Lists. Note
that the Action Lists shown in the Favorites category are a shortcut, the actual Action List is in the
Local, Standard or Server category.

• Double-click an Action List name or folder to change its name.
• Click the  button to add a (sub)folder
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• Click the + button or choose New from the fly-out menu to create a new Action List from scratch. If
you have a folder selected, the Action List is created inside the folder.

• Click the - button or choose Delete from the fly-out menu to remove the selected folder or Action
List

• Double-click the icon in front of the name, click the  button or choose Edit from the fly-out menu
to edit the Action List in the Action List Editor. See The Action List editor on page 425

• Click the  button or choose Duplicate from the fly-out menu to make a new Action List based on
an existing one.

• Click and drag to move Action Lists in or out a folder or section.

When dragging, the default action can be to move (e.g. from one subfolder to another) or to copy
(e.g. from Standard Profiles to Local Profiles). You can use the standard modifier keys to force
copying (Alt key) or moving (Cmd on Mac, Shift on Widows). You can't remove Standard Action Lists.

• From the fly-out menu, select Import Action List to import an Action List saved as a .pal file into
the Local or Server Action Lists.

• From the fly-out menu, select Import Group to import a folder containing .pal files as a folder in the
Local or Server Action Lists.

• From the fly-out menu, select Export to save the selected Action List as a .pal file, or to save the
selected folder as a folder containing .pal files.

• From the fly-out menu, select Add to Favorites to add the selected Action List to the Favorites
category.

• From the fly-out menu, select Remove from Favorites to remove the selected Action List from the
Favorites category.

11.5.  The Action List editor

In the Action List editor, you can edit the Actions in an Action List.

 

 

1. To open the Action List Editor:
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• In the Action List Side Drawer, select the Action List you want to edit, and click the Edit button
.

• In the Action List tab of the Preferences, select an Action List and double-click it, click the Edit
button  or choose Edit from the fly-out menu.

2. The left side of the dialog shows the available Actions. For more information on the available
actions, see Actions on page 426

• If you enter a keyword in the Search field, only the actions containing the keyword - within the
selected category (see below) - will be shown.

• Click a category in the left column to only see actions from this category, or select "All" to see all
available actions.

• Select an action in the right column to see some information about it in the bottom part.
• Double-click an action to add it at the bottom of your Action List in the right side of the dialog.

You can also drag it to the desired location.
3. The right side of the dialog shows the actions in your Action List

• On top, you can set a Description for the Action List.
• For every action, you can make a number of specific settings. E.g. in Select Objects By

Attribute you can select the attributes used to do the selection. For some actions, you can use
Parameters, e.g. the name for a new Layer. See Parameters in Action Lists on page 467. If an
action has a missing parameter, the input field has a red stroke, and the action has "(Invalid
Value)" appended to its name.

• Click and drag Actions to change the order. The Description always stays on top of the list.
• Click the triangle to collapse the Actions, so you get a better overview of the complete Action

List.
4. Click Save Action List to save the Action List.

11.5.1.  Actions

This gives an overview of all the Actions currently available for use in Action Lists, sorted
alphabetically, along with some basic information on the setup.

For some actions you can enable Ignore Case. When enabled, differences in case (e.g. "Artwork Layer"
versus "artwork layer" is ignored, and the two are considered the same.

For some actions, the Active Layer is used. See also Layers on page 124

• Selecting a layer - manually or by using an action - makes it the active layer.

• If multiple layers are selected, the topmost selected layer will be the active layer.

• If no layer is selected, the topmost layer is the active layer.

Some actions allow the use of wildcards: the asterisk sign * matches zero or more characters, the
question mark ? matches a single character.

Add Barcode
This action adds a barcode of the type and with the code of your choice. See Barcodes on page 232
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Settings
• Barcode Type. You can select any barcode type from the dropdown, or you can select New

Parameter at the bottom of the list to define the Barcode Type using a Parameter

• Code Value. (Custom Value, a Variable or Parameter)

• For barcodes that support both binary and decimal input modes (such as Laetus Pharma, SICK,
Bobst, Klebrand or Kurandt) you can choose between input modes: enable the option for Decimal
input, or disable it for Binary input.

Add Bleed
This action adds bleed for the selected objects, allowing to extend artwork beyond the cutting lines.
See Add Bleed on page 310

Requirements
The Add Bleed action requires an active selection of objects.

The action also requires a Processing Step Layer "Cutting" in the document, and is only available for
PDF+. See PDF, PDF+ and Normalized PDF on page 57 and Processing Step Layers on page 127

Settings
• Bleed Distance. (Custom Value, a Formula or Parameter)

• Corners

• Clone From. (Custom Value, a Formula or Parameter)

Add Dimensions
Using Add Dimensions you can add the dimensions of the bounding box of the selected object(s), or of
one of the page boxes. See Add Dimensions on page 308

Requirements
The Add Dimensions action requires an active selection of objects if Reference is set to Selection.

Settings
• Reference: the selected objects or any of the Page Boxes. If set to Selection and there is no active

selection, no dimensions will be added. When set to a Page Box not defined in the document,
dimensions are added on the Media Box.

• Units

• Decimals. (Custom Value, a Formula or Parameter)

• Remove Trailing Zeros.

• Arrows, Line Style, Font Family and Font Style

• Line Width, Font Size and Positioning. (Custom Value, a Formula or Parameter)

• Enable Create Dimensions Grid to set up columns and rows. Click + to add a row or column. Enter
the width or height (Custom Value, a Formula or Parameter) for each column or row.. An additional
column and/or row may be added to match the full size of the Reference.
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Add Layer
This action creates and selects a new layer on top of the existing ones. If such a layer already exists, it
is just selected. See Layers on page 124

Settings
• Layer Name. (Custom Value, a Variable or Parameter)

• You can choose to ignore the case when checking for duplicate layer names.
• Position: on top of all layers or on top of the artwork layers (below Processing Step layers).

Add Related Clip Groups to Selection
If the current selection contains all objects that are part of a clip group but not the clipping path itself,
this action will add the complete clipping group to the selection.

Requirements
The Add Related Clip Groups to Selection action requires an active selection of objects.

Add Rich Black
This action adds Rich Black to the selected objects. It creates Rich Black Objects for the selected
objects, in a separate layer, using the specified inks, and in Darken blend mode. See Rich Black on page
313

Requirements
The Add Rich Black action requires an active selection of objects.

Also, the Enrich Separation must be defined.

Settings
• Enrich Separation (Custom Value, a Variable or Parameter): the separation you want to enrich.

• Minimum Density (Custom Value, a Formula or Parameter)

• Only create Rich Black if no other separations are present

• the Percentage (Custom Value, a Formula or Parameter) and Separation (Custom Value, a Variable
or Parameter) you want to use to enrich. You can add or remove lines using the + and - button. If the
used separation doesn't exist in your document, it will be added.

• Choke Distance (Custom Value, a Formula or Parameter), Corners and Miter Limit (Custom Value, a
Formula or Parameter)

Add White Underprint
This action adds white underprint to the selected objects. See White Underprint on page 311

Requirements
The Add White Underprint action requires an active selection of objects. When Use Selected
Separation is enabled, the action also requires an active selection of one separation.
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Settings
• Spread or Choke

• Distance (Custom Value, a Formula or Parameter), Corners and Miter Limit (Custom Value, a Formula
or Parameter)

• When Use Selected Separation is disabled, the default separation "Opaque White" is used. When
enabled, the currently selected separation will be used.

• Exclude Covered Areas, Exclude White Objects and Exclude Dynamic Marks

Apply Default Screen Set
This action applies the default screen set to the selected objects. See Screening on page 316

Requirements
The Apply Default Screen Set action requires an active selection of objects.

Settings
You can define how to report a missing Default Screen Set: information, warning or error. If an error is
reported the Action List execution stops.

Apply PDF+ Mark Set
This action applies a PDF+ Mark Set. See Working with Mark Sets on page 415

Requirements
The action requires a defined Mark Set

Settings
• Mark Set. You can enter the URL manually (Custom Value, a Variable or Parameter) or you can

Browse to the Mark Set you want to use, and the URL will be entered automatically.

• Enable Replace Existing Marks if you want to remove existing Marks before loading the Mark Set.
When disabled, the Marks from the Mark Set will be added.

Apply Screen Set
This action finds the screen set by name and applies it to the selected objects. If the placeholder
names (e.g. Screen Set 1, Screen Set 2, …) are used, no Screen Set can be applied. See Screening on
page 316

Requirements
The Apply Screen Set action requires an active selection of objects.

The action also requires a custom Screen Set name.

Settings
• The Screen Set Name. (Custom Value, a Variable or Parameter). You can define if the Screen Set

Name is case sensitive or not.
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• You can define how to report if the defined Screen Set is missing: information, warning or error. If
an error is reported the Action List execution stops.

Arrange
This action will move selected objects within their layer or group. See Arrange objects on page 156

Requirements
The Arrange action requires an active selection of objects.

Settings
• Reorder: Move the selected objects to the front, to the back, forward or backward.

Assign Default Printing Units
This action assigns printing units - either default or reverse - to the artwork separations. See Working
with Printing Units on page 141

Settings
• Default printing units or Reverse default printing units.

Assign Printing Unit
This action assigns a printing unit value to the selected separation. If the printing units are in a
sequential order, the other printing units will be increased as well to keep a strictly ascending or
descending order. See Working with Printing Units on page 141

Requirements
The Assign Printing Unit action requires an active selection of a single separation.

Settings
• Printing Unit. (Custom Value, a Formula or Parameter)Corners

Choke
This action runs a Choke operation on the selected objects. It is either applied to the original object, or
to a new copy of the original object. In both cases, the resulting object is selected. See Spread / Choke
on page 176

Requirements
The Choke action requires an active selection of objects.

Settings
• Distance (Custom Value, a Formula or Parameter), Corners and Miter Limit (Custom Value, a Formula

or Parameter)
• Apply: define if you want to apply the choke to the original object, to a copy of the object in front or

behind the original object, or as a manual trap.
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Choose Default Screen Set
This action finds the screen set by name and makes it the default one. A custom Screen Set name is
required. If the placeholder names (e.g. Screen Set 1, Screen Set 2, …) are used, no default Screen Set
can be chosen. See Screening on page 316

Requirements
The Choose Default Screen Set action requires a custom Screen Set name.

Settings
• The Screen Set Name of the Screen Set you want to make the Default. (Custom Value, a Variable or

Parameter). You can define if the Screen Set Name is case sensitive or not.
• You can define how to report if the defined Screen Set is missing: information, warning or error. If

an error is reported the Action List execution stops.

Clean
This action will run the enabled Clean actions on the selected objects. See Clean on page 179

Requirements
The Clean action requires an active selection of objects.

Settings
Select one or more Clean functions to apply by clicking the button

• Merge Similar Paths and Text on page 180
• Contourize Text on page 206
• Outline Strokes on page 180
• Clean up Groups and Clipping Masks on page 181
• Execute Clipping Masks on page 181
• Optimize Artwork on page 181
• Fix Text Box Reflow on page 182

Clip On Page Box
This action will clip the selected objects on the selected page box. See Clip on Page Box on page 167

Requirements
The Clip On Page Box action requires an active selection of objects.

Settings
• Clip On: select the Page Box to clip on.

Clip On Shape
This action will clip the selected objects. See Clip On Shape on page 167
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Requirements
The Clip On Shape action requires an active selection of at least two objects. The topmost object will
be used as clipping mask for all the other selected objects underneath.

Close Path
This action closes all the open paths of the selected objects by connecting their end points with
straight lines. See Close Path on page 174

Requirements
The Close Path action requires an active selection of objects.

Conditional Action (If... Then...)
This action allows to run a set of actions only when the set of conditional rules are true. First define the
"If" conditional rules, next you can drag and drop actions to the "Then" section.

If...
In the If... section, you define what rules to use.

• You can define if the actions will be run if all, any or none of the conditional rules are true.
• Click the plus sign + to add a rule, or the minus sign - to remove one.
• Set a rule by combining the dropdown menus. In input fields, depending on the type of input field

you can use a Custom Value, a Formula, a Variable or Parameter

Then...
In the Then... section, you define what actions to execute when the If... rules are true. You can drag
actions from the list on the left into the Then... section.

Convert to CMYK
This action will convert the selected separations to CMYK using the chosen method. Selected process
separations are ignored by the action.

Requirements
The Convert to CMYK action requires an active selection of separations.

Settings
• Choose the method to be used: Use CMYK values from PDF file, Use Esko Color Management or

Custom: this means you define the percentages for CMYK manually (Custom Value, a Formula or
Parameter).

Convert to PDF+
This action converts a Normalized PDF document to PDF+. See Convert to PDF+ on page 59

Settings
Define the Structural Design Profile to use after conversion:
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• Cut and Creases: Only Cut and Crease lines are shown.
• Placeholders: Only Cut, Crease lines and placeholders are shown.
• Dimensions: Cut, Creases and Dimensions are shown.
• Full: all line types are shown.
• Full (Single Separation): All line types are shown, all using a single separation (a Processing Step

layer and Colorant). To make the different line types visible, every line type will have a different type:
full lines for cut lines, dotted for crease lines, etc.

Convert to Placeholder
This action converts the selected object to a Placeholder. See Placeholder objects on page 157

Requirements
The Convert to Placeholder action requires an active selection of objects.

Settings
• The Placeholder Name. (Custom Value, a Variable or Parameter)

Copy / Cut
The Copy action copies the selected objects to the clipboard, while the Cut action cuts the selected
objects from the document and copies them to the clipboard. See Cut, Copy and Paste on page 153

Requirements
The Copy or Cut action requires an active selection of objects.

Create Clipping Mask
This action will create a clipping mask of the topmost selected object, clipping the other selected
contents. If needed, the clipped contents will move down. See Clipping Mask on page 167

Requirements
The Create Clipping Mask action requires an active selection of objects, in which the topmost selected
object is a path.

Create Ink Eater Areas
This action creates Ink Eater Areas that can be filled later by the Fill Ink Eater Areas action. If there
is an active selection, the action creates Ink Eater Areas for all the paths in the selection (excluding
clipping paths). If there is no valid selection, the Ink Eater Areas are created on the Trim Box of the
page. See Ink Eater Areas on page 313

Requirements
The Create Ink Eater Areas action can only be applied on a (grid or CAD based) Step & Repeat
document.

The action also requires a Processing Step Layer "Cutting" in the document, and is only available for
PDF+. See PDF, PDF+ and Normalized PDF on page 57 and Processing Step Layers on page 127
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Settings
• Start From either the Die Shape, the Trim Box of the stations, or the Media Box of the Stations.
• Keep Away Distance. (Custom Value, a Formula or Parameter)
• Exclude Marks

Create Layer from Unlayered Art
This action creates a layer from unlayered art. See Layers on page 124

Settings
• Layer Name. (Custom Value, a Variable or Parameter)

Create Plate Cutting Paths
This action creates one or more plate cutting paths for all selected separations. Plate cutting paths are
created inside a "Plate Cut" layer. See Plate Cutting Paths on page 371

Requirements
The Create Plate Cutting Paths action requires an active selection of at least one Separation.

The Create Plate Cutting Paths action requires an active selection of objects if you want to use the
Use Selected Path option.

Settings
• The Web Direction and Plate Width
• The Plate Circumference, either from grid or page box or manually (Custom Value, a Formula or

Parameter)
• How to create the Cutting Paths: Optimize Plate Usage, Prefer Stagger Pattern or Use Selected

Path.
• Set the minimum and preferred distance the Plate Cutting Paths should stay away from imaged

areas, for the corner radius and Gap at Seam (Custom Value, a Formula or Parameter)
• The Use the same path for all selected separations.

Create Separation
This action creates a new separation by the specified name.

The created separation gets selected. If the separation already exists, it just gets selected. See
Separations on page 132

Settings
• Separation Name. (Custom Value, a Variable or Parameter).

Note:  You can use the input field as a filter to search and select an ink from the available
ink books, in the same way as when creating a new separation. See Adding or changing a
separation on page 135

• The Ink Book Name. (Custom Value, a Variable or Parameter). If you click the Ink Books button, you
can select an Ink Book from the list of available Ink Books, and its name is filled in.
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• If the separation name is not found in the Ink Book, the Preview Color will be used.

Create Shape by Parameters
This action creates an ellipse or a rectangle using absolute size parameters. See Create Rectangle /
Create Ellipse on page 198

Settings
• Use the button to define the Position relative to the Crosshair. If the Crosshair is not active, the top

left corner of the Trim Box is used.

• The Shape: Rectangle or Ellipse

• Vertical Size and Horizontal Size. (Custom Value, a Formula or Parameter)

• Corner Radius for Rectangles. (Custom Value, a Formula or Parameter)

Create Shape on Page Box
This action will create and select a rectangle or an ellipse based on the specified page box. The
resulting shape will be created at the top of the selected layer. If no layer is selected, the shape will be
created in the topmost layer, as topmost object. See Page Boxes on page 122

Settings
• Select the Page Box you want to use. If the defined Page Box doesn't exist, the Media Box is used

instead.

• The Shape: Rectangle or Ellipse

• Corner Radius for Rectangles. (Custom Value, a Formula or Parameter)

Create Shape on Selection
This action creates an ellipse or rectangle based on the bounding box of the selected objects. The
resulting shape will be created on top of the selected layer. If no layer is selected, the shape will be
created in the topmost layer, as topmost object. See Create Rectangle / Create Ellipse on page 198

Requirements
The Create Shape on Selection action requires an active selection of objects. If nothing is selected, no
object will be created.

Settings
• The Shape: Rectangle or Ellipse

• Corner Radius for Rectangles. (Custom Value, a Formula or Parameter)

Crop Images
This action crops the selected images to the bounding box of their clipping paths.

Requirements
The Crop Images action requires an active selection of objects, containing images.
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Copy / Cut
The Copy action copies the selected objects to the clipboard, while the Cut action cuts the selected
objects from the document and copies them to the clipboard. See Cut, Copy and Paste on page 153

Requirements
The Copy or Cut action requires an active selection of objects.

Cut on Crosshair
This action cuts away parts of the selected objects, based on the position of the crosshair. See Cut on
Crosshair on page 96

Requirements
The Cut on Crosshair action requires an active selection of objects, and the Crosshair must be active.

Settings
• Select Quadrants to be cut away. You can select multiple quadrants.

Delete Layer
This action will remove the selected layers from the document. See Layers on page 124

Requirements
The Delete Layer action requires an active selection of layers.

Settings
• If the option Only delete sublayers if they are selected is disabled, deleting a layer will also delete

all sublayers. If the option is enabled, sublayers of the selected layer that are not selected will be
placed at the position of the parent layer before deleting this parent layer.

Delete Object
This action removes the selected objects from the document. See Delete on page 155

Requirements
The Delete Object action requires an active selection of objects.

Delete Separation
This action removes the selected separations from the document. See Separations on page 132

Requirements
The Delete Separation action requires an active selection of separations.
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Downsample Images
This action downsamples the selected images to the resolution of your choice. Bitmap images are
excluded and will not be downsampled.

Requirements
The Downsample Images action requires an active selection of objects containing images.

Settings
• Resolution. (Custom Value, a Formula or Parameter)

• Crop images to clip mask: when enabled, only the parts of the image within the clip mask are
included in the downsampled image.

Expand Object
This action expands (degrades) selected objects. The objects will become a group of regular objects.
See Expand on page 178

Requirements
The Expand Object action requires an active selection of objects.

Settings
• Expand All Levels: when disabled, only the highest level expandable object will be expanded.

E.g. a clipped Placed Art object will be expanded to a clipping path and a Placed Art object. When
enabled, all expandable objects will be expanded. E.g. for the clipped Placed Art object in the earlier
example, the clipping path will be expanded, but also the Placed Art Object itself, along with all the
expandable objects within it.

Extract Embedded Image
This action extracts embedded images, creates a TIFF or PSD file on disk and keeps a link to that
image file. See Extract and Link on page 212

Requirements
The Extract Embedded Image action requires an active selection of objects.

Settings
• Output Format. When set to Compatible Format, ArtPro+ will decide what format to use (either

TIFF or PSD) based on the properties of the image. You can also decide to always use TIFF or PSD.

Note:  When your selection contains images that can't be extracted as TIFF or PSD file, the
action could fail.

• When Specify Output File Name is disabled, the saved images will have the name of the original
document with a number appended to it, e.g. "Filename_#1.TIF". When enabled, you can enter a File
Name (Custom Value, a Variable or Parameter) yourself. When multiple images are extracted, the
extracted images will be numbered.
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• Output Folder: By default this is set to ".", meaning the images will be saved next to the PDF
document. You can enter the URL manually (Custom Value, a Variable or Parameter) or you can
Browse to the location you want to use, and the URL will be entered automatically.

Fill Ink Eater Areas
This action fills the selected ink eater areas with ink eaters. You can specify the area to scan for ink
consumption and define a compensation strategy by choosing the number of gradient stops in the ink
eaters, as well as their density and falloff, the minimum ink density and maximum total area coverage.
See Fill Ink Eater Areas on page 315

Requirements
The Fill Ink Eater Areas action requires an active selection of objects containing Ink Eater Areas.

Settings
• The Scan Area: Trim Box or Media Box.
• The Direction, either vertical or horizontal
•

The Gradient Stops (Custom Value, a Formula or Parameter). When the Number button  is
selected, the Gradient Stops value define the number of Gradient Stops, and when the Distance

button  is selected, the Gradient Stops value define the distance in between the Gradient
Stops

• The Density and Falloff.
• The Minimum Ink Density (Custom Value, a Formula or Parameter).
• The Maximum Total Area Coverage (Custom Value, a Formula or Parameter).

Fit Page Box Size to Structural Design
This action fits the size of the selected page box to the Structural Design. For the Media Box, bleed
lines are preferred, but for the other page boxes, cut lines are preferred. See Editing Page Boxes on
page 122

Requirements
The Fit Page Box Size to Structural Design action requires a Structural Design in your document.

Settings
• The Page Box you want to modify.
• You can define how to report missing Structural Design Lines: information, warning or error. If an

error is reported the Action List execution stops.

Fit to Page Box
This action fits the selected objects to the selected Page Box. Scaling is done proportionally, and the
selection will be centered on the page box. See also Fit to Page Box on page 166

Requirements
The Scale Objects action requires an active selection of objects.
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Settings
• You can set the Page Box to be used.

• Define if you want to Include the Gradient & Pattern Fills, Stroke Weights & Effects and Opacity
Masks in the transformation.

Group Actions
This action allows to group actions and add a description to the group. Using this, you can make
complex long action lists more structured and clear.

Settings
• Description: A description of the Actions Group.

Actions
You can drag actions from the list on the left into the Group to add new actions, or you can drag
existing actions into the Group.

Group Objects
This action groups the selected objects. See Group objects on page 156

Requirements
The Group Objects action requires an active selection of objects.

Insert Content from PDF
This action inserts the content of the selected PDF file onto the current page and merges the layer
structure.

If the Crosshair is enabled, the content of the PDF will be positioned at the bottom right of the
Crosshair. See Insert Content from PDF on page 89

Settings
• URL for the PDF to insert. You can enter the URL manually (Custom Value, a Variable or Parameter)

or you can Browse to the PDF file you want to use, and the URL will be entered automatically.

• The Page Number of the page you want to insert. (Custom Value, a Formula or Parameter)

• The Structural Design Profile

Invert Layer Selection
This action inverts the layer selection in the Layers panel. If no Layers are selected, the action will
select all Layers. See Layers on page 124

Invert Object Selection
This action inverts the object selection.
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Invert Separation Selection
This action inverts the separation selection in the Separations panel. If no separations were selected,
the action will select all separations. See Separations on page 132

Join Paths
This action joins one or more open paths in the selection. See Join Paths on page 173

Requirements
The Join Paths action requires an active selection of objects.

Load Screen Preset
This action loads the Screen Sets saved in a Screen Preset.

If connected to a server, both server and local presets will be available. By default, the server presets
will be looked at first before looking into the local presets. If no server is connected, only local presets
will be available. See Screening on page 316

Requirements
The Load Screen Preset action requires a defined Screen Preset.

Settings
• The Preset Name for the Screen Preset to load. You can enter the name manually (Custom Value,

a Variable or Parameter) or you can Browse to the Preset you want to use, and the name will be
entered automatically.

• Bleed Distance. (Custom Value, a Formula or Parameter)

• Corners

• Clone From. (Custom Value, a Variable or Parameter)

information, warning or error. If an error is reported the Action List execution stops.

Lock/Unlock Layers
This action locks or unlocks the selected layers. See Layers on page 124

Requirements
The Lock/Unlock Layers action requires an active selection of layers.

Settings
• Lock or Unlock.

Make Compound
This action makes a compound path of the selected objects. See Compound on page 156
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Requirements
The Make Compound action requires an active selection of objects.

Mirror Objects
This action mirrors the bounding box of the selected objects. This bounding box is never rotated, even
if the selected objects themselves have a rotation. See Numeric Transform on page 162

Requirements
The Mirror Objects action requires an active selection of objects.

Settings
• You can choose to use the Crosshair or to select an Anchor Point on the selection bounding box as

point of origin for the mirroring.

• Use the buttons to mirror the objects Horizontally and/or Vertically

• Define if you want to Include the Gradient & Pattern Fills and Opacity Masks in the transformation.

• If needed, set the Transform each option. This can't be set when using the Crosshair as point of
origin.

Modify Screen Sets
This action allows to modify existing screen sets. All objects that use the changed screen sets will be
affected. A custom Screen Set name is required. If the placeholder names (e.g. Screen Set 1, Screen
Set 2, …) are used, no Screen Set can be modified. See Screening on page 316

Requirements
The Modify Screen Sets action requires a defined Screen Set and Separation Name.

Settings
• The Screen Sets you want to edit. (Custom Value, a Variable or Parameter). Wildcards (*, ?) can be

used to select multiple screen sets.

• The Separation Name of the separations you want to edit. (Custom Value, a Variable or Parameter).
Wildcards (*, ?) can be used to select multiple separations.

• The Ruling. (Custom Value, a Formula or Parameter). When set to "Keep Value", the action will not
change the Ruling.

• The Angle. (Custom Value, a Formula or Parameter). When set to "Keep Value", the action will not
change the Angle.

• The Dot Shape. When set to "Keep Value", the action will not change the Dot Shape.

• The DGC and %. When set to "Keep Value", the action will not change the DGC or percentage values.

Move Object
This action moves the bounding box of the selected objects by a relative distance or relative to the
Crosshair position. This bounding box is never rotated, even if the selected objects themselves have a
rotation. See Numeric Transform on page 162
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Requirements
The Move Object action requires an active selection of objects.

Settings
• When choosing Relative Position, theselected objects are moved over a specified distance

(Custom Value, a Formula or Parameter)

• When set to to the Crosshair Position, the objects are positioned on the center of the crosshair

• Define what anchorpoint of the bounding box should be placed on the center of the crosshair
• Define an offset (Custom Value, a Formula or Parameter)

• Define if you want to Include the Gradient & Pattern Fills and Opacity Masks in the transformation.

Move Object to Layer
The action moves the selected objects into the active layer. If no layer is selected, or if multiple layers
are selected, the topmost layer is considered to be the active layer. See Layers on page 124

Requirements
The Add Bleed action requires an active selection of objects and an active layer.

Move Objects to Processing Step
This action moves the objects that use the selected separation into a Processing Step Layer. See Move
objects to ... on page 129 and Processing Step Layers on page 127

Requirements
The Move Objects to Processing Step action requires a selection of a single spot separation.

Settings
• The Processing Step.

Paste / Paste in Back / Paste in Front / Paste with Layer Structure
All Paste actions paste the copied objects. See Cut, Copy and Paste on page 153

• Paste pastes the objects on the clipboard in the active Layer, on top of any other objects in that
layer.

• Paste in Back pastes the objects directly below the lowest selected object and in the same layer as
this object.

• Paste in Front pastes the objects directly on top of the topmost selected object and in the same
layer as this object.

• Paste with Layer Structure pastes the objects in the same layers as they were when copying (the
"source" layers).

Requirements
The Paste actions require objects on the clipboard.

Paste in Back and Paste in Front require an active selection of objects.
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Place Image
This action places the specified image file in the selected layer. You can choose to embed the image
with or without a link to the external image file. See Place on page 210

Settings
• URL for the image to be placed. You can enter the URL manually (Custom Value, a Variable or

Parameter) or you can Browse to the image file you want to use, and the URL will be entered
automatically.

• Keep link to the external file

Place Image Inside
This action places the specified image file in the selected compound. You can choose to embed the
image with or without a link to the external image file. See Place Image Inside on page 211

Settings
• URL for the image to be placed. You can enter the URL manually (Custom Value, a Variable or

Parameter) or you can Browse to the image file you want to use, and the URL will be entered
automatically.

• Keep link to the external file

Place PDF File
This action will place (the specified page of) the specified external PDF file in the selected layer.

When the Crosshair is active, the Crosshair defines the position where the page is placed. You can
choose to embed the file or to also keep the link to the external file. Normalized PDF files are always
embedded. See Working with Placed Art on page 219

Settings
• URL for the PDF to be placed. You can enter the URL manually (Custom Value, a Variable or

Parameter) or you can Browse to the PDF file you want to use, and the URL will be entered
automatically.

• Keep link to the external file

• Page Number. (Custom Value, a Formula or Parameter)

• Clip to: what Page Box should be used to clip the placed PDF.

Place Structural Design
This action will place the specified structural design file. The file is placed on the center of the trim
box. The link to the placed file is always kept. See Working with Structural Design files on page 228

Settings
• URL for the Structural Design file to be placed. You can enter the URL manually (Custom Value, a

Variable or Parameter) or you can Browse to the Structural Design file you want to use, and the URL
will be entered automatically.
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• The Profile to use.

Place Warp Grid
This action places the specified Warp Grid file into the Warp Grid Layer. See Warp on page 334

Settings
• URL for the Warp Grid to be placed. You can enter the URL manually (Custom Value, a Variable or

Parameter) or you can Browse to the Warp Grid file you want to use, and the URL will be entered
automatically.

Position Crosshair
This action changes the position of the Crosshair.

Settings
• Use Relative Position to position the crosshair relative to the bounding box of the current selection

or to one of the page boxes.

• Reference: The reference to position the crosshair on. You can use the selection or one of the
page box.

• Use one of the nine points to define the Reference position, e.g. the top left corner of the
reference.

• Set the horizontal and vertical Offset distance (Custom Value, a Formula or Parameter)

• Use Move to move the crosshair from its current location over a fixed distance.

• Set the horizontal and vertical Distance (Custom Value, a Formula or Parameter)

Rasterize
This action rasterizes the selected objects. See Rasterize ... on page 179

Requirements
The Rasterize action requires an active selection of objects.

Settings
• Resolution. (Custom Value, a Formula or Parameter)

• Anti-aliasing

• Include Background

Remove Color Profiles
This action removes the color profiles from the selected objects. See Remove color profile on page 99

Requirements
The Remove Color Profiles action requires an active selection of objects.
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Settings
• Keep Color Values: The original color values (e.g. CMYK values) are kept, and the color profiles are

removed. No conversion is done.

• Keep Visual Appearance: The color values (e.g. CMYK values) are converted first, and then the color
profiles are removed.

Release Compound
This action releases all compound paths that are included in the selection. See Compound on page 156

Requirements
The Release Compound action requires an active selection of objects.

Remove Fill
This action removes any fills of the selected objects. See Changing the Fill and Stroke on page 182

Requirements
The Remove Fill action requires an active selection of objects.

Remove Page Box
This action removes the selected page box.

Settings
• Page Box: select the Page Box to remove.

Remove Printing Units
This action removes the printing units of the selected separations. See Working with Printing Units on
page 141

Requirements
The Remove Printing Units action requires an active selection of separations.

Remove Screening
This action removes screening from the selected objects. See Screening on page 316

Requirements
The Remove Screening action requires an active selection of objects.

Remove Separations from Object
This action removes the selected separations from the selected objects. See also Remove Separation
on page 190
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Requirements
The Remove Separations from Object action requires an active selection of separations, and an active
selection of objects.

Remove Stroke
This action removes any strokes from the selected objects. See Stroke Inspector on page 188

Requirements
The Remove Stroke action requires an active selection of objects.

Remove Trap Tags
This action removes trap tags from the selected objects, with the option to also remove tags from all
objects in the hierarchy. See Working with Trap Tags on page 332

Requirements
The Remove Trap Tags action requires an active selection of objects.

Settings
• If you want to remove trap tags from objects that are part of a group, enable Also remove tags from

all objects in group.

Remove Unused Screen Sets
This action removes unused screen sets from the document. See Screening on page 316

Rename Layer
This action will rename the selected layers. When multiple layers are selected, they will get the same
name. See Layers on page 124

Requirements
The Rename Layer action requires an active selection of layers.

Settings
• Layer Name. (Custom Value, a Variable or Parameter)

Rename Layer with Wildcards
This action replaces the name of all layers that match the Old Layer Name by the New Layer Name.
Wildcards (*, ?) are allowed. See Layers on page 124

Settings
• Old Layer Name and New Layer Name. (Custom Value, a Formula or Parameter). You can use

Wildcards (*, ?) in both the old and new layer name
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Rename Object
This action gives a name to the selected objects. See Renaming objects, groups and layers on page 155

Requirements
The Rename Object action requires an active selection of objects.

Settings
• Object Name: the new name for all selected objects. (Custom Value, a Variable or Parameter)

Rename Separations With Wildcards
This action replaces the name of all separations that match the Old Separation Name by the New
Separation Name. Wildcards (*, ?) are allowed. See Separations on page 132

Settings
• Old Separation Name and New Separation Name. (Custom Value, a Formula or Parameter). You can

use Wildcards (*, ?) in both the old and new separation name

• The Ink Book Name. (Custom Value, a Variable or Parameter). If you click the Ink Books button, you
can select an Ink Book from the list of available Ink Books, and its name is filled in.

Reorder Layers
This action changes the order of the layers by repositioning the selected layers. See Layers on page 124

Requirements
The Reorder Layer action requires an active selection of layers.

Settings
• Layer Position: you can put the selected layers on top of all layers, on top of the artwork layers, or

below all layers.

• Using On Top Of or Below, you can specify the new position of the layers based on the position of
specific other layers, defined by either the Layer Name or the Layer Type

• Layer Type: any of the Processing Step types

• Layer Name. (Custom Value, a Variable or Parameter). You can use a comma separated list or
wildcards (*, ?)

Reorder Separations
Using this action reorder your separation list. using wildcards (*, ?) if needed. The top-most separation
in the list will be printed first. You can also specify your separations as one comma-separated line. See
Separations on page 132
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Settings
You can reorder separations by setting up a list of separations. The top-most separation in the list will
be printed first. Alternatively, you can specify your separation order as a comma-separated line.

• Click the plus button + to add a line to the list. Select a line and click the minus button - to remove it.

• In every line you can enter a Separation Name (Custom Value, a Variable or Parameter). You can use
wildcards (*, ?).

• Separations that don't match any of the lines are placed underneath, in their original order.

Replace Embedded Placed Art
When opening an ArtPro Step & Repeat file, although the one-ups are Embedded Placed Art, ArtPro+
will remember the link to the original ArtPro one-up file as "Legacy File Name".

After converting to PDF+, you can use the Replace Embedded Placed Art action to replace the
selected Embedded Placed Art objects that has such a Legacy File Name, by a PDF file with the same
name from a specific input folder.

If the replacement file is a Normalized PDF it will be embedded, and if it is PDF+ it will be linked.

See also Opening ArtPro Step & Repeat Files on page 62

Requirements
The Replace Embedded Placed Art action requires a legacy ArtPro Step and Repeat file that was
converted to PDF. It requires a selection of Embedded Placed Art with defined Legacy File Names.

Settings
• Input Folder. You can enter the URL manually (Custom Value, a Variable or Parameter) or you can

Browse to the folder you want to use, and the URL will be entered automatically.

• You can optionally provide a Prefix and/or Sux to use when replacing images with matching
images from the input folder (Custom Value, a Variable or Parameter).

• You can define how to report if a file is missing: information, warning or error. If an error is reported
the Action List execution stops.

Replace Image
This action replaces all the selected images with the specified image file. See Replacing an image on
page 216

Requirements
The Replace Image action requires an active selection of objects, containing images.

Settings
• URL for the image to replace the selected images with. You can enter the URL manually (Custom

Value, a Variable or Parameter) or you can Browse to the image file you want to use, and the URL will
be entered automatically.

• Keep link to the external file

• Enable Replace Clipping Path if you want to use the clipping path of the replacing image, or disable
if you want to keep the current clipping path.
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Replace Linked Images
This action replaces linked images in the current selection with images with the same name from a
specified input folder. See Replacing an image on page 216

Requirements
The Replace Linked Images action requires an active selection of objects, containing linked images.

Settings
• Input Folder. You can enter the URL manually (Custom Value, a Variable or Parameter) or you can

Browse to the folder you want to use, and the URL will be entered automatically.

• You can optionally provide a Prefix and/or Sux to use when replacing images with matching
images from the input folder (Custom Value, a Variable or Parameter).

• Enable Replace Clipping Path if you want to use the clipping path of the replacing image, or disable
if you want to keep the current clipping path.

• You can define how to report if an image is missing: information, warning or error. If an error is
reported the Action List execution stops.

Replace Linked Placed Art
This action replaces linked Placed Art in the current selection with Placed Art with the same name
from a specified input folder. See Replacing an image on page 216

Requirements
The Replace Linked Placed Art action requires an active selection of objects, containing linked Placed
Art.

Settings
• Input Folder. You can enter the URL manually (Custom Value, a Variable or Parameter) or you can

Browse to the folder you want to use, and the URL will be entered automatically.

• You can optionally provide a Prefix and/or Sux to use when replacing Placed Art with matching
Placed Art from the input folder (Custom Value, a Variable or Parameter).

• You can define how to report if a Placed Art file is missing: information, warning or error. If an error
is reported the Action List execution stops.

Replace Separations
This action replaces the selected separations by the target separation. If the target separation does
not exist, then no replacement is done. See Separations on page 132.

Requirements
The Replace Separations action requires an active selection of separations.

Settings
• The Separation Name for the Target separation. (Custom Value, a Variable or Parameter)
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• You can choose to Keep source screening or Use destination screening. See Screening when
merging separations on page 319

Rotate Objects
This action rotates the bounding box of the selected objects. This bounding box is never rotated, even
if the selected objects themselves have a rotation. See Numeric Transform on page 162

Requirements
The Rotate Objects action requires an active selection of objects.

Settings
• You can choose to use the Crosshair or to select an Anchor Point on the selection bounding box as

point of origin for the rotation.

• Set the Angle (Custom Value, a Formula or Parameter)

• Define if you want to Include the Gradient & Pattern Fills and Opacity Masks in the transformation.

• If needed, set the Transform each option. This can't be set when using the Crosshair as point of
origin.

Run Existing Action List
This action allows to run an existing local Action List as part of an Action List.

Settings
• Action List: the local Action List you want to run. Click the Browse button and select the Action List

you want to include.

• The Action List Parameters will show all Parameters used in the included Action List. You can
enable a Parameter and set a value to override the value defined in the included workflow.

Note:  The selected Action List is embedded in the Action List you included in. If the Action
List is modified, you can get a warning, giving you the option to include the modified Action
List.

Scale Objects
This action scales the bounding box of the selected objects. This bounding box is never rotated, even if
the selected objects themselves have a rotation. See Numeric Transform on page 162

Requirements
The Scale Objects action requires an active selection of objects.

Settings
• You can choose to use the Crosshair or to select an Anchor Point on the selection bounding box as

point of origin for the scaling.

• Set the Horizontal and Vertical Scaling (Custom Value, a Formula or Parameter)

• Define if you want to Include the Gradient & Pattern Fills, Stroke Weights & Effects and Opacity
Masks in the transformation.
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• If needed, set the Transform each option. This can't be set when using the Crosshair as point of
origin.

Select All Objects
This action selects all objects.

Select Artwork Layers
This action selects all Artwork Layers. See Layers on page 124

Settings
• The selected layers can be:

• a new selection, disregarding what layers were selected before.
• added to the currently selected layers
• substracted from the currently selected layers
• selected from the currently selected layers.

Select Artwork Separations
This action selects all artwork separations used in artwork layers.

Note:  In a Normalized PDF, all inks are considered Artwork Inks

Settings
• The selected separations can be:

• a new selection, disregarding what separations were selected before.
• added to the currently selected separations
• substracted from the currently selected separations
• selected from the currently selected separations.

Select Darkest Artwork Separation
This action selects the darkest artwork separation in the document.

Select Empty/Non-Empty Layers
This action selects empty or non-empty layers. See Layers on page 124

Settings
• Select either Empty or Non-Empty layers

• The selected layers can be:

• a new selection, disregarding what layers were selected before.
• added to the currently selected layers
• substracted from the currently selected layers
• selected from the currently selected layers.
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Select Layer by Name
This action selects layers based on their name. See Layers on page 124

Settings
• The Layer Name (Custom Value, a Variable or Parameter). You can use a comma separated list or

wildcards (*, ?)
• The selected layers can be:

• a new selection, disregarding what layers were selected before.
• added to the currently selected layers
• substracted from the currently selected layers
• selected from the currently selected layers.

Select Layer by Processing Step
This action selects layers based on their processing step type. See Processing Step Layers on page 127

Settings
• Select layers based on their Processing Step Layer Type.
• The selected layers can be:

• a new selection, disregarding what layers were selected before.
• added to the currently selected layers
• substracted from the currently selected layers
• selected from the currently selected layers.

Select Layers by Printing State
This action selects layers based on their printing state. See Visibility, Locking and Printing state on
page 125

Settings
• Select layers with either Printing State On or Printing State Off
• The selected layers can be:

• a new selection, disregarding what layers were selected before.
• added to the currently selected layers
• substracted from the currently selected layers
• selected from the currently selected layers.

Select Locked/Unlocked Layers
This action selects either locked or unlocked layers. See Layers on page 124

Settings
• Select Locked or Unlocked layers.
• The selected layers can be:
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• a new selection, disregarding what layers were selected before.
• added to the currently selected layers
• substracted from the currently selected layers
• selected from the currently selected layers.

Select Objects by Attribute
This action selects objects based on a number of criteria. See Select Advanced on page 151

Settings
• The selected objects can be:

• a new selection ("Select"), disregarding what objects were selected before.
• added to the selection
• removed from the selection
• intersected with the selection

• Set a number of Rules. An object will be selected if all rules are true.

• Click the plus sign + to add a rule, or the minus sign - to remove it.
• Set a rule by combining the dropdown menus.

Select Objects by Box
This action selects all objects inside a box that you define. The Select Objects by Box action can
create, add to, substract or select from an object selection. To define the box, first select a reference
Page Box and then define optional Horizontal and Vertical offsets and Width and Height of the box.

Settings
• The selected objects can be:

• a new selection ("Select"), disregarding what objects were selected before.
• added to the selection
• removed from the selection
• intersected with the selection

• Set a Reference page box and the corner of the reference page box you want to use as reference
point.

• Set the Offset distance (horizontally and vertically) for the corner of the box (Custom Value, a
Formula or Parameter).

• You can define the offset either Absolute or Relative to the size of the selected page box
• The direction of the offset is defined by the corner of the reference page box that is selected. If

you select e.g. the top right corner, positive offset values will be down and/or to the right.
• The position of the box is also defined by the corner of the reference page box that is selected. If

you select e.g. the top left corner, the offset defines the top left corner of the selection box.
• Set the Width and Height for the selection box (Custom Value, a Formula or Parameter).

• You can define the width and height either Absolute or Relative to the size of the selected page
box

• Set the Selection Mode
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• When Group Select is enabled, only groups that are completely inside the selection box will
be selected. When choosing Object Select, objects completely inside the selection will be
selected, even if they are part of a group that is not completely selected.

Select Objects in Layer
This action selects all objects in the selected layers. See Layers on page 124

Requirements
The Select Objects in Layer action requires an active selection of layers.

Select Separation by Name
This action selects separations based on their name. See Separations on page 132

Settings
• The Separation Name (Custom Value, a Variable or Parameter). You can use a comma separated list

or wildcards (*, ?)
• The selected separations can be:

• a new selection, disregarding what separations were selected before.
• added to the currently selected separations
• substracted from the currently selected separations
• selected from the currently selected separations.

Select Separation by Printing Method
This action selects separations based on their printing method. See Separations Setup on page 136

Settings
• The Printing Method: any of the Printing Methods or "Unknown"
• The selected separations can be:

• a new selection, disregarding what separations were selected before.
• added to the currently selected separations
• substracted from the currently selected separations
• selected from the currently selected separations.

Select Separation by Type
This action selects separations based on their types.

Settings
• The Separation Type: Normal, Opaque, Technical or Varnish
• The selected separations can be:

• a new selection, disregarding what separations were selected before.
• added to the currently selected separations
• substracted from the currently selected separations
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• selected from the currently selected separations.

Select Separations by Processing Step
This action selects separations used in specific Processing Step layers only. See Processing Step
Layers on page 127

Settings
• Select the Processing Step from the dropdown list

• Select Any to select the separations from all Processing Steps

• Select a Processing Step to select the separations used in that Processing Step layer(s)
• Select a category (e.g. "Structural") to select the separations used in any of the Processing Step

types of that category.

• Enable Include Artwork Separations if - next to the Processing Step Colorants - you also want to
select the Artwork Separations used in the Processing Step.

• The selected separations can be:

• a new selection, disregarding what separations were selected before.
• added to the currently selected separations
• substracted from the currently selected separations
• selected from the currently selected separations.

Select Separations Used in Printing Layers
This action selects all printable separations on the page.

Settings
• The selected separations can be:

• a new selection, disregarding what separations were selected before.
• added to the currently selected separations
• substracted from the currently selected separations
• selected from the currently selected separations.

Set Barcode Value
This action sets the code of the selected barcode to a value of your choice. See Barcodes on page 232

Requirements
The Set Barcode Value action requires an active selection of objects, containing one or more
barcodes.

Settings
• Code Value. (Custom Value, a Variable or Parameter)

• For barcodes that support both binary and decimal input modes (such as Laetus Pharma, SICK,
Bobst, Klebrand or Kurandt) you can choose between input modes: enable the option for Decimal
input, or disable it for Binary input. For other barcode types, this option is not relevant.
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Set Blend Mode
This action sets the blend mode of the selected objects. See Transparency Inspector on page 189

Requirements
The Set Blend Mode action requires an active selection of objects.

Settings
• Blend Mode: the Blend Mode to be used for all selected objects.

Set Document Distortion
This action sets the document distortion. See Document Setup on page 89

Settings
• Vertical Distortion Factor and Horizontal Distortion Factor. (Custom Value, a Formula or Parameter)

Set Fill Color
This action creates a color from the selected separation(s) or makes a Registration Color. The color
is used to fill the selected objects at the specified percentage, resetting any overprint settings. If no
separation is selected, the color is set to white (all separations zero). See Fill Color and Stroke Color
Inspector on page 182

Requirements
The Set Fill Color action requires an active selection of objects. It can take in account a selection of
separations.

Settings
• Fill Percentage. (Custom Value, a Formula or Parameter)

• Make Registration Color

Set Fill Knockout / Overprint
This action sets the fill of the selected objects to knockout or Overprint. See Fill Color and Stroke Color
Inspector on page 182

Requirements
The Set Fill Knockout / Overprint action requires an active selection of objects.

Set Layer Printing State
This action will set the layer printing state for the selected layer(s) to on or off. See Visibility, Locking
and Printing state on page 125
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Requirements
The Set Layer Printing State action requires an active selection of layers.

Settings
• You can set the Printing State to Print or Do Not Print

Set Object Screening
This action allows you to define a Screen Set and apply it to the selected objects. See Screening on
page 316

Requirements
The Set Object Screening action requires an active selection of objects.

Settings
• The settings for the Default separation are used for every separation that isn't defined in the list.

You can click the + button to add a separation. Define the Separation Name. (Custom Value, a
Variable or Parameter)

• For both the Default separation and specific separations, you can define:

• Ruling and Angle (Custom Value, a Formula or Parameter)

• Dot Shape, DGC and %

Set Objects Size
This action sets the size of the bounding box of the selected objects. This bounding box is never
rotated, even if the selected objects themselves have a rotation. See Numeric Transform on page 162

Requirements
The Set Objects Size action requires an active selection of objects.

Settings
• You can choose to use the Crosshair or to select an Anchor Point on the selection bounding box as

point of origin for the scaling.

• Set the Horizontal and/or Vertical Size. (Custom Value, a Formula or Parameter)

• You can enable or disable horizontal or vertical scaling, to adjust the size of the selected objects
only in one direction.

• Define if you want to Include the Gradient & Pattern Fills, Stroke Weights & Effects and Opacity
Masks in the transformation.

• If needed, set the Transform each option. This can't be set when using the Crosshair as point of
origin.

Set Opacity
This action sets the opacity of the selected objects to the specified percentage. See Transparency
Inspector on page 189
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Requirements
The Set Opacity action requires an active selection of objects.

Settings
• The Opacity. (Custom Value, a Formula or Parameter)

Set Page Box Size
This action sets the size of the selected page box. See Page Boxes on page 122

Settings
• The Page Box you want to modify.

• The fixed point. If you select e.g. the top left corner, that point will stay where it is, and the new
dimension will change the position of the other corners.

• The Width and Height (Custom Value, a Formula or Parameter)

Set Page Box Size by Content
This action sets the size of the specified page box to the size of the selected content. See Page Boxes
on page 122

Requirements
The Set Page Box Size by Content action requires an active selection of objects.

Settings
• The Page Box you want to modify.

• The Fit to Selection option:

• Bounding Box Only sets the page box size to the combined bounding boxes of the selection.

• Include Strokes and Clips sets the page box size to the visible bounds of your selection, taking
into account strokes and clipping.

• Using the buttons, you can choose to modify the Page Box size in both directions, only horizontally
or only vertically.

• When Only grow selected page box is enabled, the page box can become bigger but will never get
smaller.

Set Printing Method
This action sets the requested printing method (default or custom). See Separations Setup on page 136

Requirements
The Set Printing Method action requires an active selection of separations.

Settings
• The Printing Method: any of the Printing Methods or "Unknown"
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Set Processing Step Type
This action will set a Processing Step Type for the selected layer(s). No consistency check is done. See
Processing Step Layers Overview mode on page 129

Requirements
The Set Processing Step Type action requires an active selection of layers.

Settings
• The Processing Step

Set Processing Steps Printing State
This action sets the Processing Steps Printing State. See Processing Step Layers on page 127

Settings
• Select the Processing Step layers you want to modify.

• You can set the Printing State to Print or Do Not Print

Set Relative Page Box Size
This action sets the size of the selected page box relative to the reference page box. See Page Boxes
on page 122

• The Page Box you want to modify.

• The page box you want to use as reference page box.

• The Top, Bottom, Left and Right margin (Custom Value, a Formula or Parameter)

Set Separation Type
This action sets the requested separation type for the selected separations. See Separations Setup on
page 136

Requirements
The Set Separation Type action requires an active selection of separations.

Settings
• The Separation Type: Normal, Opaque, Technical or Varnish

Set Stroke Color
This action creates a color from the selected separation(s) or makes a Registration Color. The color is
applied to the stroke of the selected objects at the specified percentage. If no separation is selected,
the color is set to white (all separations zero). If the selected objects have no stroke, then the default
stroke weight is applied. See Fill Color and Stroke Color Inspector on page 182
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Requirements
The Set Stroke Color action requires an active selection of objects. It can take in account a selection
of separations.

Settings
• Stroke Percentage. (Custom Value, a Formula or Parameter)

• Make Registration Color

Set Stroke Corners
This action sets the stroke corners of the selected objects. It will not create any strokes. See Fill Color
and Stroke Color Inspector on page 182

Requirements
The Set Stroke Corners action requires an active selection of objects.

Settings
• Corners: Mitered, Round or Beveled

• Miter Limit, only for mitered corners (Custom Value, a Formula or Parameter)

Set Stroke Dashing
This action will add or remove dashing of the strokes of the selected objects. See Fill Color and Stroke
Color Inspector on page 182

Requirements
The Set Stroke Dashing action requires an active selection of objects.

Settings
• Dashed Stroke: When disabled, the action will remove any existing dashing from the strokes of

the selected objects. When enabled, the strokes of the selected objects will be dashed using the
settings below. Objects without a stroke are not changed.

• Dash length, Gap and Offset. (Custom Value, a Formula or Parameter)

Set Stroke End Caps
This action sets the stroke end caps of the selected objects. See Fill Color and Stroke Color Inspector
on page 182

Requirements
The Set Stroke End Caps action requires an active selection of objects.

Settings
• End Caps: butt, round or square.
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Set Stroke Knockout / Overprint
This action sets the stroke of the selected objects to knockout or Overprint. It will not create any
strokes. See Fill Color and Stroke Color Inspector on page 182

Requirements
The Set Fill Knockout / Overprint action requires an active selection of objects.

Set Stroke Weight
This action sets the stroke weight for the selected objects. If the object doesn’t have a stroke yet, it will
be created, in the darkest color, with the given weight. See Stroke Inspector on page 188

Requirements
The Set Stroke Weight action requires an active selection of objects.

Settings
• Stroke Width. (Custom Value, a Formula or Parameter)

Set Structural Design Print Item
This action sets the print item for the selected structural design. See Structural Design Inspector on
page 230

Requirements
The Set Structural Design Print Item action requires a document with a Structural Design file.

Settings
• Show all Layers: this will set all layers of the Structural Design file to visible, so no Print Item is

applied.

• Show only specified Print Item allows you to specify what print item to use (Custom Value, a
Variable or Parameter).

Set Structural Design Print Side
This action sets the print side of the selected Structural Design to front or back. See Structural Design
Inspector on page 230

Requirements
The Set Structural Design Print Side action requires a document with a Structural Design file.

Settings
• Print Side: front or back
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Set Text Font
This action sets the font of the selected objects. Barcode text is not affected by this action.

Requirements
The Set Text Font action requires an active selection of objects containing text.

Settings
• Font Family

• Font Style

Set Text Size
This action sets the text size of the selected objects. Barcode text is no affected by this action.

Requirements
The Set Text Size action requires an active selection of objects containing text.

Settings
• Text Size. (Custom Value, a Formula or Parameter)

Set Trap Tags
This action sets or removes Trap Tags or Reverse Trap Tags on selected objects. See Working with Trap
Tags on page 332

Requirements
The Set Trap Tags action requires an active selection of objects.

Settings
• Trap Type: Trapping or Reverse Trapping.

• for both Outer Edges and Inner Edges you can set Trap, Pullback, Direction (only Outer Edges) and
Distance (Custom Value, a Formula or Parameter)

• Keep Tag: The tag for this setting is not changed. If there is already a Trap Tag defined, its value
is kept.

• No Tag: No tag is set for this setting. If there is already a Trap Tag defined, it is removed.

• You can set if the edges should Always be trapped, Never be trapped, or Automatic to let ArtPro
+ decide.

• For Outer Edges you can set the Direction either Inwards or Outwards

Shaper
This action runs a Shaper operation on the selected objects. See Shaper on page 199
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Requirements
The Shaper action requires an active selection of multiple objects.

Settings
• The Shaper operation you want to perform: Unite, Intersect, Exclude, Minus Front, Minus Back or

Divide. The Divide operation uses the Darkest color to fill the result.
• When Work on a copy in active layer is enabled, the result of the operation is created in the active

layer, and the original paths are kept untouched.

Shear Objects
This action shears the bounding box of the selected objects. This bounding box is never rotated, even if
the selected objects themselves have a rotation. See Numeric Transform on page 162

Requirements
The Shear Objects action requires an active selection of objects.

Settings
• You can choose to use the Crosshair or to select an Anchor Point on the selection bounding box as

point of origin for the rotation.
• Set the Shearing Angle (Custom Value, a Formula or Parameter)
• Define if you want to Include the Gradient & Pattern Fills and Opacity Masks in the transformation.
• If needed, set the Transform each option. This can't be set when using the Crosshair as point of

origin.

Show Message
This action shows a user defined message.

Settings
• The Message. (Custom Value, a Variable or Parameter)
• You can define how to report the message: information, warning or error. If an error is reported the

Action List execution stops.

Spread
This action runs a Spread operation on the selected objects. See Spread / Choke on page 176

Requirements
The Spread action requires an active selection of objects.

Settings
• Distance. (Custom Value, a Formula or Parameter)
• Corners and Miter Limit. (Custom Value, a Formula or Parameter)
• Using the Apply dropdown you can define if the Spread is applied on the original objects, on a copy

behind or in front of the selection, or as a manual trap.

463



11 ArtPro+

Spread Thin Parts
This action generates Fix Thin Part objects that will be placed on top of the originally selected objects
as a group named "Thin Part Fixes". See Spread Thin Parts on page 369

Requirements
The Spread Thin Parts action requires an active selection of objects.

Settings
• Use the buttons to choose between Spread All Thin Parts or Spread Enclosed Thin Parts

• Minimum Width. (Custom Value, a Formula or Parameter)

Subtract White Underprint
This action subtracts white underprint from the selected objects. See White Underprint on page 311

Requirements
The Subtract White Underprint action requires an active selection of objects. When Use Selected
Separation is enabled, the action also requires an active selection of one separation.

Settings
• Spread or Choke

• Distance. (Custom Value, a Formula or Parameter)

• Corners and Miter Limit. (Custom Value, a Formula or Parameter)

• When Use Selected Separation is disabled, the default separation "Opaque White" is used. When
enabled, the currently selected separation will be used.

• Exclude Covered Areas, Exclude White Objects and Exclude Dynamic Marks

Trace Image
This action vectorizes the selected images or opacity masks. See Trace Image on page 218

Requirements
The Trace Image action requires an active selection of objects containing images or opacity masks.

Settings
• Threshold. (Custom Value, a Formula or Parameter)

• Trace on: Luminosity or Transparency

• Reduction Factor, Straighten Threshold and Dust Threshold (Custom Value, a Formula or
Parameter)

Ungroup Objects
This action ungroups the selected objects. See Group objects on page 156
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Requirements
The Ungroup Objects action requires an active selection of objects containing one or more groups.

Unlink Image
This action unlinks the selected images, i.e. it will remove the link to the file on disk and only keep the
embedded version in the document. See Unlink / Embed and Unlink on page 212

Requirements
The Unlink Image action requires an active selection of objects containing linked images.

Unlink Placed Art
This action unlinks the selected Placed Art objects, i.e. it will remove the link to the file on disk and only
keep the embedded version in the document. See Unlink on page 222

Requirements
The Unlink Placed Art action requires an active selection of objects containing linked Placed Art.

Update Barcode
This action will update barcode properties according to the Automation Engine server job setup. See
Barcode properties from Automation Engine on page 304

Requirements
The Update Barcode action requires an active selection of objects, containing one or more barcodes.

Update Fill Color
This action updates colors' fill percentages from the selected separation(s). The color is used to fill the
selected objects at the specified percentage. See Fill Color and Stroke Color Inspector on page 182

Requirements
The Update Fill Color action requires an active selection of objects.

The action also requires one or more selected separations.

Settings
• Fill Percentage. (Custom Value, a Formula or Parameter)

Update Linked Images
This action will update all linked images. See Working with images on page 210

Requirements
The Update Linked Images action requires an active selection of objects, containing Linked Images.
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Settings
• You can define how to report if a Linked Image is missing: information, warning or error. If an error

is reported the Action List execution stops.

Update Linked Placed Art
This action will update all linked Placed Art. See Working with Placed Art on page 219

Requirements
The Update Linked Placed Art action requires an active selection of objects, containing Linked Placed
Art.

Settings
• You can define how to report if Linked Placed Art is missing: information, warning or error. If an

error is reported the Action List execution stops.

Update Marks
This action will update all Marks. See Marks on page 381

Update Stroke Color
This action updates the stroke of the selected objects for the selected separation(s) to the specified
color percentage. See Fill Color and Stroke Color Inspector on page 182

Requirements
The Update Stroke Color action requires an active selection of objects. It also requires a selection of
separations.

Settings
• Stroke Percentage. (Custom Value, a Formula or Parameter)

Update Structural Design
This action will update all structural design objects. See Working with Structural Design files on page
228

Settings
• You can define how to report if a Structural Design file is missing: information, warning or error. If

an error is reported the Action List execution stops.

Update Trap Layer
This action recalculates the existing Automatic Trap Layer or Reverse Trap Layer. See Trapping on
page 320
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Warp Using Warp Grid
This action warps the selected objects using the warp grid available on the page. See Warp on page 334

Requirements
The Warp Using Warp Grid action requires an active selection of objects.

The action also requires a Warp Grid in the document.

Settings
• Warp Grid: you can Warp using any available Warp Grid, or you can specify the Warp Grid name. The

latter can be useful if multiple grid files are available in the document, but if the specified Grid is not
available, the action can't be done.

• Warp Grid Name. (Custom Value, a Variable or Parameter)

• You can define how to report if the Warp Grid is missing: information, warning or error. If an error is
reported the Action List execution stops.

• Minimum Image Resolution, Add Gradient Noise and Warp Outside Grid for. (Custom Value, a
Formula or Parameter)

11.5.2.  Action Lists and Selections

A lot of the actions that can be defined in an Action List require a selection. For example, a "Shaper"
action is run on the selected objects.

You can define this selection in the Action List itself, by starting with a Selection action. This means
the Action List can be run both in the editor and on the server.

In ArtPro+, you can also make a selection prior to running the Action List.

Any selection is maintained throughout the Action List until another selection is made.

In an automated workflow on the server, you obviously can't make a manual selection prior to running
the Action List. If no selection action is defined, or if the Selection action doesn't result in any selected
objects, the action won't do anything, since it would be run on an empty selection.

When it comes to layer selections, if no layer is selected, the active layer is used. In ArtPro+ this is the
one marked in bold. In an automated workflow, this means the topmost layer.

11.5.3.  Parameters in Action Lists

If the settings of an action in an Action List contain an input field, you can set a static, fixed value, or
you can use a Parameter.

An icon at the right side of the input field indicates the type of parameter that can be used: text, a
percentage, a distance, ...

You can set a static, fixed value, or you can use an Action List Parameter. An Action List Parameter
has one specific value in ArtPro+. However, when running the Action List on Automation Engine, the
value for the Parameter becomes visible and can be changed in the Automation Engine Pilot, either
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as a fixed value or using SmartNames. For more information on Automation Engine, we refer to the
Automation Engine documentation.

 

 

• Enter a value in an input field to use a static value

• Click the Parameter Type icon or the triangle, and select New Parameter... to create a new Action
List Parameter.

 

 

You can then define the name and initial value for the Parameter. If the input field already had a
value, this will be used as initial value for the Parameter.

When you click the Add button, the newly created Parameter will be used in the input field, shown in
blue.

 

 

• If you click the Parameter Type icon or the triangle, the dropdown will show all existing Parameters
of the same type (text, percentage, …). Click it to use it.

• Click the Parameter Type icon or the triangle, and select None to go back to using a static
parameter.

Note:  When saving the Action List, Action List Parameters that are not used, will be removed.

You can modify Parameters in an Action List using Modify Parameters in the Action List Side Drawer.
This will change the parameters saved in the Action List. See The Action List Side Drawer on page 421
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While Stepping Through an action list, you can also modify the parameters, using the Modify

Parameters button . In this case, the modified parameters are not stored in the Action List. See
Stepping through an Action List on page 422

11.5.4.  Formulas in Action Lists

When setting an input field for an action that requires a number, you can use a Formula with variables.
For example when moving an object, you can set the distance using a formula.

1. Open the Action List you want to edit in the Action List Editor. See The Action List editor on page
425

2. For the input field you want to edit, click the triangle next to the input field, and choose Enable
Formula

The Formula Editor opens.
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3. In the formula editor, on the left hand side, you see the available Variables and Functions. In the

right column, you can compose the formula to be used, for example "Media Box Width / 2"
4. To add a Variable:

a) Select Variables
b) Select a Category in the left hand column
c) In the middle column, select a variable you want to use in your formula, e.g. Trim Box Width. You

can enter a Search key to find the Variable you're looking for.
d) Double-click the variable to add it on the cursor position, or drag and drop it.

Note:  All positional variables used in a formula use the distance of the selected variable
(e.g. the top of the Media Box) measured from the top left corner of the Trim Box. A positive
value is downwards or to the right, a negative value up or to the left.

5. You can combine variables using operators: plus (+), minus (-), multiply (*), divide (/). You can also
use brackets.

6. You can add fixed values by typing them in the formula.
Note that distance values must have a length unit, e.g. "3mm".

7. To add a Function:
a) Select Functions
b) Select a Category in the left hand column
c) In the middle column, select a Function you want to use in your formula, e.g. ABS (absolute

value). You can enter a Search key to find the Function you're looking for.
d) Double-click the Function to add it on the cursor position, or drag and drop it.
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You can also type in the Function manually.

Important:

Functions are always typed full caps and arguments are split up using a semicolon:
FUNCTION(a;b;c)

A dot (.) or comma (,) are both used to express numbers with decimals.

More information about each function can be found in the Formula Editor itself.
8. Click OK to accept the formula

If the entered formula is valid, the Preview will show the calculated result. Otherwise it will show an
error message.

You can remove a formula by entering a value in the property field.

The fx button will be red if an invalid formula is set, orange when the formula can't be resolved, or blue
if a valid formula is used. A tooltip will show the content of the formula

 

 

11.5.5.  Variables in Action Lists

When setting an input field for an Action that requires text input, you can use a Variables. For example
when creating a new layer, you can set its name using a variable.

1. Open the Action List you want to edit in the Action List Editor. See The Action List editor on page
425

2. Place your cursor where you want the variable to be, or select the text to replace with a variable,
click the triangle next to the input field, and choose Enable Variables

3. In the Insert Smart Text dialog that opens, choose the fields to insert:
a) Choose the Category:

• Select Document to select variables from the local file
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• Select System to select variables from your system information

• Select Server to use SmartNames from the Automation Engine server. In that case, all
database queries defined on the server will be available, as well as all job and product
parameters.

See also The Variables on page 386
b) Choose a field Category, for example Barcodes, Date & Time...
c) In that Category, choose the Field you want to use. You can enter a Search key to find the

Variable you're looking for.
d) If applicable, choose the Format to use for your chosen Field (see Formatting Dynamic Fields on

page 388 for details),

Note:  The Preview line shows how the field will be resolved in the current document.

e) When your field is completely set up, click Insert.

The variable parts of a text input field will appear as a blue block with white text.
4. If you want to add another variable, place your cursor where you want the variable to be, or select

the text to replace with a variable and click the Tx button 
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12.  Studio in ArtPro+
Studio is a unique set of tools for 3D packaging design made specifically for packaging artwork
professionals.

For a full overview of the Studio workflow, we refer to the Studio documentation: https://
www.esko.com/en/support/product?id=Studio%20Essentials

If you have the appropriate licenses, you can use some Studio functionality inside ArtPro+. See
Licensing on page 29

• 3D View: If you have a 3D ARD or Collada file placed, a 3D preview is shown in the bottom left corner.
See 3D View on page 473

• Revolve an ArtPro+ path in Toolkit: see Creating a revolved shape with labels on page 474

• Apply Predistortion: see Predistortion on page 477

• Export a 3D file: see Export to 3D on page 479

12.1.  3D View

If you have a 3D ARD or Collada file placed, a 3D preview is shown in the bottom left corner. See
also Working with Structural Design files on page 228

•

You can click the 3D button  in the toolbar to hide or show the 3D preview.
• You can click and drag the top right corner of the 3D View panel to resize it.
• You can click and drag to rotate the 3D object.
• You can hold the shift key and click and drag to move the 3D object left, right, up or down (Panning).
• You can reset the camera position by double-clicking while holding the shift key.
• You can zoom in and out using the mouse wheel.
• You can also zoom in by holding down the Cmd (Mac) or Ctrl (Windows) key and dragging a rectangle

around the area you want to zoom in on. Your ArtPro+ document will zoom in on the corresponding
part.

Notes and restrictions:

• The 3D object is shown on a white background, using a default floor reflection. The 3D View is
shown in "Designer quality". For more information on Designer Quality, we refer to the Studio
documentation.

• 3D View shows all artwork separations, regardless of the visibility state of separations, layers or
objects. The printing states of layers is respected: non-printing artwork layers will not be shown in
the 3D View.

• 3D View doesn't work when using ArtPro+ in a remote desktop environment on Windows.
• In a PDF+ document you can have more than one structural design. If multiple structural design

objects are found on the same page, the top one (according to the Object Browser) will be used in
the 3D View.
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• If the Structural Design outlines embedded in a PDF+ file no longer match the external structural
design file, you will be asked to do an Update before the 3D view will be displayed. Both the 3D view
and the structural design outlines in the document will be updated.

• In a Normalized PDF, the 3D view of the structural design object will always show the current
state of the linked structural design file. If that external file was modified after the PDF had been
saved, the outlines on the document however will only be updated if you do an Update action in the
Structural Design File inspector.

12.2.  Creating a revolved shape with labels

Using the combination of ArtPro+ and Studio Toolkit, you can create a shape (e.g. bottles) based on a
profile path, and add labels to it.

1. Create the path in ArtPro+. See Create a profile path on page 474
2. Send the path to Studio Toolkit to be revolved. See Revolve in Toolkit on page 475
3. In Studio Toolkit, create the revolved shape, and add labels to it. Save as Collada with printable

parts.
4. Place the Collada Structural Design file in ArtPro+, and add graphics to the created labels. See

Working with Structural Design files on page 228

12.2.1.  Create a profile path

The first step in creating a revolved shape is creating or selecting the ArtPro+ paths to be used as
profile paths.

 

 

Studio supports half profiles, full profiles and multi-part profiles (based on multiple paths). Multi-part
profiles can be used to set different materials for different parts (for example the bottle and the cap).

It is important to connect paths that can share the same material.

In the example below, the shape consists of two parts. The bottle itself which will have glass as
material and the cap which will be metal.
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12.2.2.  Revolve in Toolkit

1. Select the paths you want to revolve.

In the example used in Create a profile path  on page 474, the shape consists of a bottle and cap,
and consists of two paths.

2. Choose Object > Path > Revolve in Toolkit

The selected paths will be opened in Studio Toolkit, where you can revolve the shape:

1. Select the axis to revolve around
2. Set the material to be used
3. Add labels to the shape
4. Save as Collada file

For a full explanation of using Studio Toolkit, we refer to the Studio documentation: https://
www.esko.com/en/support/product?id=Studio%20Essentials
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12.3.  Creating a label from Curves

In case you have the die lines of a (conical) label, but no 3D model of the corresponding container, you
can create a 3D model of only the label, using a combination of ArtPro+ and Studio Toolkit.

This can be used e.g. to create a 3D shape of a complex conically warped label in an in-mould-label
printing environment.

1. In ArtPro+, create the Label Outline Curves based on a technical drawing of the Source Grid.

The Label Outline Curves should be two separate smooth, open, non-intersecting paths that follow
the top and bottom edges of the label. Only curves that bend in a single direction are supported.

Below an example of a technical drawing, and the two selected Label Outline Curves.

2. With the Label Outline Curves selected, choose Object > Path > Create Label from Curves in Toolkit
A "Label from Curves" object is created in Studio Toolkit.

• In case Studio Toolkit was not running, the application will be started automatically.
• If Studio Toolkit was running and had an open document, the newly created object will be added

in the open document.
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• A 2D tab is added containing the connected top and bottom curves, and the folded label is shown
in the 3D tab.

• The convex side of the label is considered to be the front side

3. Set the 3D Height, i.e. the height along the vertical axis. This defines the curvature of the folded
label.
When the input field is active, you can use the arrow keys to adjust the height by 0.001mm
increments (or 0.01mm when holding the shift key. Due to physical constraints, the 3D height is
limited.

4. You can then save the label as a Collada file, and place it e.g. in ArtPro+ to get a 3D preview of your
label.

For more information on Studio Toolkit, we refer to the Studio Documentation

12.4.  Predistortion

You can use the Warp tool to predistort objects or groups of objects to compensate for the distortion
of the shrink sleeve on the 3D shape. Together with the 3D preview, you have a perfect 3D visual
feedback to make sure the designs look good after shrinking as well.

1. Place the structural design file of the Shrink Sleeve
2. Select and position the objects you want to warp correctly on the Structural Design file.
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3. Open the Warp dialog:

• click the Warp button in the upper toolbar, or
• choose Prepress > Warp > Warp..., or
• use its shortcut Cmd+Shift+D (Mac) or Ctrl+Shift+D (Windows)

The Warp dialog will show a preview of the warped objects. You can use the same tools as in the 3D
View to rotate, move, zoom, … See 3D View on page 473

4. Check that your structural design is selected in the Grid or Structural Design dropdown.

Note:  If your structural design is a Collada file with multiple printable parts, only one
printable part can be used for warping.

5. Set the Predistortion Method

a) Preserve Vertical Features will Predistort the selected objects so that after shrinking, vertical
elements are still preserved.
 

 
b) Preserve Width will Predistort the selected objects so that after shrinking, the width of the

different elements are preserved.
 

 
6. Select the Smoothness of the predistortion
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7. Set the Origin for the predistortion. You can choose to use the center of the selection, or use the
center of the Crosshair.

8. Set the Strength to define the amount of deformation you want to apply.
9. By default the Optimize for View Angle is set to the current view angle in the 3D Preview. If you

want to optimize the predistortion for a different viewing angle, you can either enter the rotations in
the input fields, or click From Preview to take the angles from the current preview.

10. Set the Minimum Image Resolution. This defines the minimum resolution of images created
by the warping. If an image has a resolution above the minimum, it will keep its resolution after
warping.Warping images with a lower resolution as well as gradients will result in an image at the
Minimum Image Resolution.

11. Set the amount of Noise to be added for gradients, which are replaced by images during warping.
12. Click Warp

 

 

• The result of the warp action is Warped Art

• If you select a warped object, you can click Unwarp to return it to its unwarped version.

• If you select a warped object, you can click Expand to replace it by regular objects: paths,
images, etc.

12.5.  Export to 3D

If you have a 3D ARD or Collada file placed, you can use Export 3D to export your document in a 3D
format:

• A Collada file (*.zae), that can be used e.g. in Studio application such as Studio Toolkit or Store
Visualizer, or in a 3rd party 3D application, or in an Esko Viewer.

• A dynamic 3D PDF file. In Adobe Reader or Acrobat Professional (version 8.0.1 or later) you can
view / rotate 3D objects in PDF files.

• A binary glTF file. glTF is a standard file format for 3D scenes and models, and can be used in
various applications, e.g. Microsoft Oce. You can export .glb files, which are self-contained,
binary glTF files, that don't need any specific software to view a package in 3D.

1. Select File > Export to > 3D...
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2. Select the Export Format: Collada, PDF File with 3D Design or Binary glTF File/
3. When exporting a PDF file, you can define the Size of the PDF file. Since the PDF file is only meant

for on-screen viewing, this size is of little importance. The Add Footer option allows you to switch
on or off the footer text. Instead of the default Esko text you can also personalize the footer text and
include your own message.

4. Specify the Resolution for the graphics.
5. When exporting to glTF, you can enable Optimize for Microsoft Oce to avoid incorrect 3D

previews caused by limitations in the Microsoft Oce viewer.
6. Click Export Collada, Export PDF or Export binary glTF
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13.  Variable Data
Variable Data provides you the ability to generate jobs with variable elements, retrieved from a
database.

This is the typical workflow when working with Variable Data:

1. Create or open the design.
2. Convert it to a Variable Data Template. See Convert to Variable Data Template on page 481
3. Connect it to a database. See The Variable Data database on page 483
4. Create Variable Data Objects. This can be a text box containing variable text, a barcode with its

code retrieved from the database, an image or a placed (non-normalized) PDF. See Creating and
editing Variable Data Objects on page 484.

5. You can Check the document and database to search for errors. You can define what checks should
be done, and check your document manually, or Preflight for all records in the database before
expanding. See Checking your Variable Data Template on page 491

6. Export the Variable Data Template. This will expand the variable data and generate multiple
variations of the document, one for every record. These can be combined into a multipage PDF
file, one page for each record in the database, or placed next to each other in a Step&Repeat. See
Export Variable Data on page 495

13.1.  Convert to Variable Data Template

The first step in working with Variable Data, is converting a PDF+ file to a Variable Data Template.

1. Create or open the PDF+ document you want to use.

Note:  You can only convert PDF+ files to a Variable Data Template. If you want to convert a
Normalized PDF, you should convert it to PDF+ first. See Convert to PDF+ on page 59

2. Choose File > Convert to Variable Data Template... or Prepress > Variable Data > Convert to
Variable Data Template...

3. Select the Database you want to use. For more information on the database, see The Variable Data
database on page 483

If the conversion is successful:

• the document title will show "(Variable Data Template)"
• the Variable Data side drawer will be available, along with the Variable Data button in the toolbar.

See The Variable Data Side Drawer on page 482

• All Dynamic Marks will be expanded. The Marks section in the Side Panel is no longer shown.

• The Message Side Drawer now has a Variable Data section

481



13 ArtPro+

13.2.  The Variable Data Side Drawer

When you are working in a Variable Data Template, an extra Side Drawer is available: the Variable Data
Side Drawer.

Just like all other side drawers, this side drawer can be shown by clicking the Variable Data button

. You can hide it by clicking the button again, or by selecting another side drawer.

 

 

1. In Database you can see the name of the currently selected database. You can select another
database by choosing Browse in the dropdown. See also The Variable Data database on page 483
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2. Record indicates what record from the database is currently used in your document. You can select
a specific record by entering the number in the field, or you can browse through the records using
the arrow buttons.

3. Use the Preflight button to check all records in the database. See Checking your Variable Data
Template on page 491

4. Using the Expand button you can expand your Variable Data Template. See Export Variable Data on
page 495

5. This is an overview of all Database fields and the values for the currently selected record.
6. You can set checks on the database or on specific database fields. See Checking the Database

Records and Fields on page 492
7. In the fly-out menu you can select Reload Database, or you can set the Database Options. See The

Variable Data database on page 483
8. The Variable Data Objects are listed here.

• Clicking a Variable Data Object in the list will select the corresponding object in your document.
• You can double-click a Variable Data Object in the list to rename it.
• Using the contextual menu (right-click) you can also lock, hide or rename objects.

9. If you have a text object, barcode, image or placed art selected in your document, you can click the
Convert to Variable Data Object button to make it a Variable Data Object. See Creating and editing
Variable Data Objects on page 484

10. The Variable Data Messages shows Variable Data errors and warnings for the current record. See
also Checking your Variable Data Template on page 491

11. Enable Zoom to Selection to automatically zoom in on the object(s) you select in the Variable Data
Side drawer.

13.3.  The Variable Data database

The Variable Data database is a CSV file: a list of values, separated by a comma or another delimiter.
The database contains:

• a title row. These entries will be used as label
• multiple rows, each representing a record. Every record will result in a different variation
• every row contains fields. The values of the fields will define the content for that record.

 

 

The database you use for Variable Data should be in CSV format, using UTF-8 encoding.

When using an invalid database, the conversion will not happen. A database can be invalid for different
reasons:

• if it is not a valid CSV file
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• if the first record contains invalid (UTF-16) characters, or if it has unsupported features (e.g. new
lines inside a field).

The Variable Data Side Drawer shows the currently selected database file. If the currently used
database file can't be found, a triangular warning icon will be shown.

You can select Browse... to select a different file.

If changes are made to the database, you need to reload the database in the Variable Data Template, by
opening the fly-out menu in the Variable Data Side Drawer and selecting Reload Database.

In the fly-out menu of the Variable Data Side Drawer, you can choose Database Options....

If Field Delimiter is set to Automatic (default), ArtPro+ detects which delimiter is used in the database.
You can also set it fixed to space, tab, comma or semicolon. Note that setting a different delimiter than
what is used in the database will result in errors.

You can also decide how to handle Empty Lines: either Skip (default) or Load. When loading the empty
lines, these will be visible, and will be shown as error during Preflight or while browsing the records.

13.4.  Creating and editing Variable Data Objects

Variable Data Objects are objects whose content changes based on the selected record of the
database. Variable Data Objects can be created from a text object, a barcode or a linked placed image.

• In a Variable Data Text Object, the content of the text object can be a combination of static (fixed)
text, and text retrieved from the database.

• In a Variable Data Barcode, the barcode code can be a combination of static (fixed) text, and text
retrieved from the database.

• In a Variable Data Image or Variable Data Placed Art, the URL of the external file can be a
combination of static (fixed) text, and text retrieved from the database.

To convert an object to a Variable Data Object:

1. Select a single text object, a single barcode, a single image or a single placed art object in your
Variable Data Template.

2. Convert the object to a Variable Data Object. There are two ways:

• In the Variable Data Side Drawer, click the Create Variable Data Object button  and select
Convert to Variable Data Text Object, Convert to Variable Data Barcode, Convert to Variable
Data Image or Convert to Variable Data Placed Art

• Select Prepress > Variable Data > Convert to Variable Data […] Object

The created Variable Data Objects will be listed in the Variable Data Side Drawer.
3. Set the Position of the Variable Data Object. See Positioning a Variable Data Object on page 485
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4. Use the Variable Data Objects Inspector to set up the Variable Data Object, such as defining what
database entries to use in the content. See Using the Variable Data Objects Inspector on page 486

5. You can use the Fill Color Inspector or Stroke Color Inspector to define a variable color for the fill or
stroke of a Variable Data Object. See Using variable color in Fill or Stroke Inspector on page 490

6. Use the regular Inspectors to set the properties of the Variable Data Objects. You can e.g. use
the Barcode Inspector to set the Cell Size of your Variable Data Barcode, or you can use the Text
Inspector to set the font and size of a Variable Data Text Object.

Note:  You can only edit the style (font, size, …) of the complete Variable Data Text Box. The
complete Variable Data Text Object will have the same formatting (font, size, etc) based on
the formatting of the first character.

Note:  You can Expand the currently selected Variable Data Object to a normal object using the
Expand button in the Inspector bar. See also Expand on page 178

13.4.1.  Positioning a Variable Data Object

You can set the position of a Variable Data Object using the Transformation Inspector.

It is based on 3 settings:

Attach to
The position of the Variable Data Object can be based on

• Any page box: Media Box, Crop Box, Bleed Box, Trim Box or Art Box
• another Variable Data Object
• any named object, i.e. every object that is listed in the Named Objects Browser. See Object Browser

on page 130.

Positioning
The way the Variable Data Object is attached, can be chosen by clicking and dragging the colored
square (representing the Variable Data Object) to the desired position on the gray square (representing
the Attach To reference). Each square has 9 reference points (top left center and right, middle left
center and right, and bottom left center and right), so you have 81 different ways of positioning the
Mark.
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In the example underneath, the top center of the (bounding box of the) Variable Data Object will be
placed on the left bottom corner of the (bounding box) of the reference defined in the Attach to field.

 

 

Offset & Rotation
In the offset fields, you can move the Variable Data Object based on the defined position. A positive
value for offset moves the Variable Data Object in the direction indicated by the arrows.

Using the Rotation, you can rotate the Variable Data Object.

Changing the "Attach To" of a Variable Data Object
When changing the "Attach To" of a Variable Data Object, by default the Offset values are kept, and the
Variable Data Object will be repositioned.

However, by holding the Alt key, you can keep a Variable Data Object at its the position, and the Offset
values will be recalculated.

13.4.2.  Using the Variable Data Objects Inspector

Using the Variable Data Objects Inspector you can make all settings for the selected Variable Data
Object.

The settings in the Variable Data Objects inspector depend on the type of Variable Data Object that is
selected:

• Settings for Variable Data Text Objects on page 486

• Settings for Variable Data Barcodes on page 487

• Settings for Variable Data Images and Placed Art on page 488

Settings for Variable Data Text Objects

1. The Text field.
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The text in a Variable Data Text object can't be changed using the normal Text tools. Instead, it can
be set in the Variable Data Objects Inspector.

You can modify the (static) text and you can add Variable Data Fields. These fields will be replaced
by the content of the corresponding database record. See Using Variable Data fields on page 489.
To do so, position the cursor where you want to enter the field, and click Insert Field

The Preview will show the result of the selected static text and Variable Data Field(s) for the
currently selected record.

2. Fill / Stroke: you can choose to set the Fill or Stroke color of a text object to use the color from the
Fill Color Inspector or the Stroke Color Inspector, or you can set it to From Separation:
a) Enter the separation you want to use manually, or click the Insert Variable button  to select a

variable from the database. You can't combine both.
b) Enter the Density you want to use.

Note:  If you are using the color from the Fill Color Inspector or the Stroke Color Inspector,
you can use database fields to define a variable color. See Using variable color in Fill or
Stroke Inspector on page 490

Settings for Variable Data Barcodes

1. The Code field.

The code of a Variable Data Barcode can't be changed using the normal Inspectors. Instead, it can
be set in the Variable Data Objects Inspector.

You can modify the code, and you can add Variable Data Fields. These field(s) will be replaced by the
content of the corresponding database record. See Using Variable Data fields on page 489. To do
so, position the cursor where you want to enter the field, and click Insert Field or the Insert Field

button 

The Preview will show the result of the selected static text and Variable Data Field(s) for the
currently selected record.

2. If the selected Variable Data barcode is an EAN-8, EAN-13, UPC-A or UPC-E code, you can add
Supplemental Digits.

3. Color: you can choose to set the color of a barcode object to use the color from the Fill Color
Inspector, or you can set it to From Separation:
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a) Enter the separation you want to use manually, or click the Insert Variable button  to select a
variable from the database. You can't combine both.

b) Enter the Density you want to use.

Note:  If you are using the color from the Fill Color Inspector, you can use database fields to
define a variable color. See Using variable color in Fill or Stroke Inspector on page 490

Settings for Variable Data Images and Placed Art

1. The Root Folder is the location where the images or placed art files are to be found. You can click
the link to browse to a different location. Note that you can use (variable) relative paths in the File
input field (see below)

2. The File field.

The file name of the Variable Data Image or Variable Data Placed Art can be set in the Variable Data
Objects Inspector.

You can modify the static parts of the file name, and you can add Variable Data Fields. These fields
will be replaced by the content of the corresponding database record. See Using Variable Data fields
on page 489. To do so, position the cursor where you want to enter the field, and click Insert Field

You can use relative paths in the File field, and you can use Variable Data Fields in those relative
paths. For example: [job id]/images/[filename]

The Preview will show the result of the Root path, the selected static text and Variable Data Field(s)
for the currently selected record.

3. You can use the Browse button to select an image or PDF file. Root folder, File and Preview will be
updated automatically.

4. Define how to apply the image or placed art:
a) Define how to resize:
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• Stretch Vertically: the content is stretched to match the entered height. The width is at
100%.

• Stretch Horizontally: the content is stretched to match the entered width. The height is at
100%.

• Stretch to Fill Area: the content is stretched to match both the entered height and width.

• Scale to Fit Inside Area: the content is scaled (up or down) proportionally to fit inside the
defined area (width and height).

• Shrink to Fit Inside Area: the content is scaled down proportionally if necessary to fit inside
the defined area (width and height). The content is never scaled up.

• When selecting Scale Relatively you can enter the scale factor for both vertical and
horizontal scaling (in percentage).

Note:  The Stretch options and Scale Relatively are non-proportional: the vertical
and horizontal scaling factors can be different. The Scale and Shrink options are
proportional: vertical and horizontal scaling factors are the same.

b) Define the Width or Height.

At the bottom of the inspector you can see the actual size of the image based on the current
record, including the applied scaling factor (a single percentage for proportional scaling, a
scaling factor for vertical and horizontal scaling for non-proportional scaling).

5. If the Variable Data Image is based on an image using one single separation (a grayscale, bitmap
image or a Multichannel image using only one separation), you can set the Color: you can choose to
use the color from the Fill Color Inspector or the Stroke Color Inspector, or you can set it to From
Separation:
a) Enter the separation you want to use manually, or click the Insert Variable button  to select a

variable from the database. You can't combine both.
b) Enter the Density you want to use.

While browsing through the records of the database, an error message will be shown in case
recoloring is not possible. Make sure to only use variable coloring when you know all records in the
database are referring to monochrome images.

Note:  If you are using the color from the Fill Color Inspector or the Stroke Color Inspector,
you can use database fields to define a variable color. See Using variable color in Fill or
Stroke Inspector on page 490

Using Variable Data fields
When setting up the text, barcode code or URL of a Variable Data Object, you can add Variable Data
Fields, to retrieve information from the database.

1. Place your cursor where you want the variable to be, or select the text to replace with a variable.
Click the Insert Field... button.

2. In the Insert Field dialog that opens, choose the fields to insert:
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a) Select Standard to select variables from the database: either the number of the current record
or the total number of records in the database

b) Select Database to select a field from the database, and choose the Field you want to use. The
fields are shown using their header names in the CSV database file. You can enter a Search key
to find the field you're looking for.

Note:  The Preview line shows how the field will be resolved using the current record.

c) When your field is completely set up, click Insert.

The variable parts in the Text, Code or File field will appear as a blue block with black text.

13.4.3.  Using variable color in Fill or Stroke Inspector

If you are using a flat color fill or stroke on a Variable Data Object, you can use a database field to set
the percentage for one or more separations.

1. For the separation you want to use a variable percentage, click the Insert Variable button 
2. Select the Variable Data field you want to use, and double-click it or click Insert. See also Using

Variable Data fields on page 489

Note:  Unlike in Variable Data Text or the code of a Variable Data Barcode, you can only
select one field. You can't combine it with other fields or with static text.

3. If needed, repeat these steps for other separations.

The values that are taken from the database are shown in blue. The Inspector will show the values for
the currently selected record.

Note:  If you use a database field to define the Fill or Stroke color of a Variable Data Object,
these fields should contain numeric values between 0 and 100. If not, an error will be
generated, and the value for that separation will be set to 0%. The value will be shown in red in
the Fill or Stroke Color Inspector.
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13.5.  Checking your Variable Data Template

One of the pitfalls of working with Variable Data, is that the data retrieved from the database might not
match up with the Variable Data Objects you use it in. Fields might be missing or containing unusable
data, the database could contain invalid delimiters, text could end up outside of the trim box, etc. For
more information, see Common errors in Variable Data on page 491

1. You can check the database and the database fields. See Checking the Database Records and Fields
on page 492

2. For every Variable Data Object, you can set the checks ArtPro+ should perform in the Checks
Inspector. See The Checks Inspector on page 493

3. You can manually go through some (or all) of the records using the navigation buttons in the Variable
Data Side Drawer. See The Variable Data Side Drawer on page 482

For every record you navigate to, ArtPro+ will show all errors and warnings it encounters in the
Message Side Drawer

Note:  The Variable Data Messages in the Variable Data Side Drawer only shows the errors
and warnings for the current record, while the Messages Side Drawer shows the error
messages for all records you've navigated to or did a preflight on.

4. When clicking the Preflight button in the Variable Data Side Drawer ArtPro+ will go through all
records in the database, and show all errors and warnings it encounters in the Messages Side
Drawer.

Note:  The messages are cleared when reloading the database, selecting another database
or reopening the Variable Data Template.

13.5.1.  Common errors in Variable Data

Generic errors

Database records that can't be read

Some errors prevent the database record from being read at all. In that case, you will not be able to
navigate to that specific record and it will be skipped in the preflight.

Typical problems are the use of invalid delimiters, a new line in a record, wrong record size, a utf-8
error and other encoding errors.

Fix: fix the errors in the database and reload it.

Static Objects Above Variable Data Objects

It is recommended to position Variable Data Objects at the top, above any regular objects. If this is not
the case, a warning is shown in the Messages.

Fix: move all Variable Data Objects on top of the regular objects.

Potential Transparency Conflict
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If a transparency group contains a mix of regular objects and Variable Data Objects, this will have to
be split in two separate transparency groups during export. Since this can lead to a visual difference
compared to the original Variable Data Template, a warning will be shown.

Errors for Variable Data Text Objects

Missing Font Data

Certain characters are not available in the font that is used by the Variable Data Text Object.

Fix: you can select the Variable Data Text Object and use a different font, or change the value in the
database and reload it.

Protected Font Replaced

The font used in the Variable Data Text Object is a protected font. Because text editing is not allowed
in that case, the font is being replaced by the system default font.

Errors for Variable Data Barcodes

Empty Code

No code at all was entered for the Variable Data Barcode.

Fix: add a code in the Variable Data Objects inspector

Empty Resolved Code

The code consists of one or more database variables which are all empty in the current record of the
database, or that don't exist in the current database.

Fix: you can change the code in the Variable Data Objects inspector, or add a value in the database and
reload it, or load a different database.

Unresolved Code

The database is not found or invalid.

Fix: correct and reload the database, or relink to the database.

Code Too Long

The resolved code is too long according to the barcode specification.

Fix: you can change the code in the Variable Data Objects inspector, or change the value in the
database and reload it, or load a different database.

Errors for Variable Fill or Stroke color

Invalid Separation Density Value
If you use a database field to define the Fill or Stroke color of a Variable Data Object, these fields
should contain numeric values between 0 and 100. If not, an error will be generated, and the value for
that separation will be set to 0%.

13.5.2.  Checking the Database Records and Fields

The checkboxes next to the database name or the database fields in the Variable Data Side Drawer
indicate if a check is defined: if the checkbox is disabled no check is defined, if the checkbox is
enabled a check is set on the specific field or on the database.
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1. Click the checkbox next to the database name or next to a database field in the list
2. In the dialog that opens, define what problems you want to detect

• For the database, you can check for Duplicate Records (e.g. record 3 and 5 have the exact same
values for all fields) or Consecutive duplicate records (e.g. record 5 and 6 have the exact same
values for all fields).

• For a database field, you can check for Duplicate values (e.g. record 3 and 5 have the same value
for the selected field) or Consecutive duplicate values (e.g. record 5 and 6 have the same values
for the selected field).

3. Set the severity: either Error or Warning
The difference between a warning and an error is that an error will stop further processing
the database record(s), while a warning is shown in the Messages Side Drawer, but processing
continues.

4. Click outside of the dialog to close it.

13.5.3.  The Checks Inspector

For every Variable Data Object, you can set what possible problems should be checked, and how those
should be handled in the Checks Inspector.

Note:  The difference between a warning and an error is that an error will stop further
processing the database record(s), while a warning is shown in the Messages Side Drawer, but
processing continues.

Checks for Variable Data Text Objects
Object is outside Trim Box

• Checks if the resolved Variable Data Object is (partially or completely) outside of the Trim Box.
• If a Safe Margin is defined, the object will also generate a warning or error if it is within that

distance of the Trim Box.
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• Can be a warning or an error.

Text is empty

• Checks if the resolved text is empty.

Note:  An empty field in the database will not result in an error if it is combined with static
text or with another (non empty) variable.

• If Whitespace characters count as empty is enabled, a text element containing only whitespace
characters will generate the same warning or error as a completely empty text element.

• Can be set to warning, error or don't report.
• You can apply an automatic fix: either clear object or Replace with where you can set a static text

to fill the text object. Automatically fixing is not available if the check is set to Error.

Text line is empty

• Checks if a line within the resolved text box is empty.
• If Whitespace characters count as empty is enabled, a text element containing only whitespace

characters will generate the same warning or error as a completely empty text element.
• Can be set to warning, error or don't report.
• You can apply an automatic fix: Remove Line will remove the empty line(s) from the text box.

Automatically fixing is not available if the check is set to Error.

Text Overflow

• Checks if the Variable Data text fits its deditated space
• Text overflows text box will check if the complete text fits into the source text area
• Paragraph overflows single line checks if the text of the paragraphs had to be wrapped.
• Can be set to info, warning, error or don't report.
• You can apply an automatic fix: Fit Text will change the horizontal scale down to 80% and the font

size can be brought down to the defined Minimum Font Size. Automatically fixing is not available if
the check is set to Error.

• When fitting the text is not possible, this can be reported as info, warning, error or don't report.

Checks for Variable Data Barcodes
Object is outside Trim Box

• Checks if the resolved Variable Data Object is (partially or completely) outside of the Trim Box.
• If a Safe Margin is defined, the object will also generate a warning or error if it is within that

distance of the Trim Box.
• Can be a warning or an error.

Code is empty

• Checks if the resolved barcode code is empty.

Note:  An empty field in the database will not result in an error if it is combined with static
text or with another (non empty) variable.

• If Whitespace characters count as empty is enabled, a barcode element containing only
whitespace characters will generate the same warning or error as a completely emtpy element.

• Can be set to warning, error or don't report.
• You can apply an automatic fix: either clear object or Replace with where you can set a static text

to fill the barcode. Automatically fixing is not available if the check is set to Error.

Check digit is missing

Only available for Variable Data Barcodes of type EAN-8, EAN-13, MSI, UPC-A and UPC-E.
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• Checks if the Check Digit of the barcode is in the resolved code.
• Can be set to warning or error.
• When set to warning, the Fix Automatically option is enabled, and the check digit will be added to

the code.

Note:  An incorrect Check Digit will always result in an error, and is not handled by this check.

Checks for Variable Data External Files
Object is outside Trim Box

• Checks if the resolved Variable Data Object is (partially or completely) outside of the Trim Box.
• If a Safe Margin is defined, the object will also generate a warning or error if it is within that

distance of the Trim Box.
• Can be a warning or an error.

External file is not available

• Checks if an external file is found at the resolved URL (i.e. the combination of the Root folder and
File input).

• Can be set to warning, error or don't report.
• You can apply an automatic fix: either clear object or Replace with where you can set a fixed file

name. The Root folder is used as defined in the Variable Data Object Inspector. Automatically fixing
is not available if the check is set to Error.

External file cannot be placed

• Checks if the external file can be placed. You will get an error if the file type is not supported, or if
the external file is invalid.

• Can be set to warning, error or don't report.
• You can apply an automatic fix: either clear object or Replace with where you can set a fixed file

name. The Root folder is used as defined in the Variable Data Object Inspector. Automatically fixing
is not available if the check is set to Error.

13.6.  Export Variable Data

The final step in the proces of Variable Data, is expanding the Variable Data Template. Expanding
means that for every record in the database file, a version of the document is generated. The different
versions can be combined in a multipage PDF file (one page for every version), or the different versions
can be combined in a Step & Repeat Grid.

In that expanded document, all variable data objects are expanded to regular text objects, barcodes
and placed files.

In the Export

1. To expand a Variable Data Template, click the Export button in the Variable Data Side Drawer, or
select File > Export To > Variable Data...

The Export dialog will open, with Export Variable Data selected.

Note:  You can click one of the other output options on the left to export to another format.
See Export on page 65

2. Set the Export Format
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• If you select Expand Variable Data, the result will be a multipage PDF, one page for every record
in the database.

Note:  In an expanded Variable Data Template, the "regular artwork" is put in a "Form"
which is reused on every page. This avoids include the artwork again on every page, and
reduces the file size.

• If you select Expand Variable Data and Step & Repeat you can use the Browse button to select
a Step & Repeat Template. The Step & Repeat Template is a PDF containing a Step & Repeat
created in ArtPro+. Based on the type of Step & Repeat Template you use, different options will
become availabe. See Expand to Grid Step & Repeat on page 496 and Expand to MFG or CF2 Step
& Repeat on page 497

3. Click Export PDF... to run the export.
4. Set the name and location for the new file, and click Export

13.6.1.  Expand to Grid Step & Repeat

When Expanding to Grid Step & Repeat, a version (or 'variation') of the document is generated for every
record in the database file. The different versions will be combined in a Step & Repeat Grid.

1. Set up a document containing one single Step & Repeat Grid, to be used as template to expand your
Variable Data Template on. See Grid Step & Repeat on page 343

2. Save this file.
3. In your Variable Data Template, click the Export button in the Variable Data Side Drawer, or select

File > Export To > Export Variable Data...

The Export dialog will open, with Export Variable Data selected.
4. Set the Export Format to Expand Variable Data and Step & Repeat
5. Click the Browse button to select your Step & Repeat Template.
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6. Set the Start Position to define where the first variation should be placed in the grid: top left, top
right, bottom left or bottom right.

7. Set the Direction to define where to place the following variations in the grid: horizontal or vertical.

The different variations are placed on the different stations in the Grid file. If there are more
variations than stations, the result will be a multipage PDF, containing as many pages as needed to
fit all variations. If you place e.g. 40 variations on a 4 by 4 grid, the resulting PDF will contain 2 pages
with 16 variations each, and one page containing the remaining 8.

8. If Apply Distortion is set to Immediately, any distortion factor set in the Document Setup of your
Variable Data Template will be applied on the grid after generating it. If set to Later no distortion
will be done, so you can apply distortion in the Document Setup of the resulting Grid file. See also
Document Setup on page 89

9. Click Export PDF... to run the export.
10. Set the name and location for the new file, and click Export

13.6.2.  Expand to MFG or CF2 Step & Repeat

When Expanding to MFG or CF2 Step & Repeat, a version (or 'variation') of the document is generated
for every record in the database file. The different versions will be combined in the MFG or CF2 based
Step & Repeat.

Note:  To expand to MFG or CF2 Step & Repeat you need to create a PDF containing the MFG
or CF2 based Step & Repeat to be used as Step & Repeat Template. You can not use an MFG or
CF2 file as Step & Repeat Template.

1. Set up a MFG or CF2 based Step & Repeat document, to be used as template to expand your
Variable Data Template on. See Step & Repeat based on an MFG or CF2 file on page 358

2. Save this file.
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3. In your Variable Data Template, click the Export button in the Variable Data Side Drawer, or select
File > Export To > Variable Data...

The Export dialog will open, with Export Variable Data selected.
4. Set the Export Format to Expand Variable Data and Step & Repeat
5. Click the Browse button to select your Step & Repeat Template.

6. Set the Fill: either Sheet by sheet or Stack by stack

The different variations are placed on the different stations in the S&R file. If there are more
variations than stations, the result will be a multipage PDF, containing as many pages as needed to
fit all variations.

If you have e.g. 40 variations to be placed on a Step & Repeat Template containing 4 stations, the
result will be a 10 page PDF.

When set to Sheet by sheet, the first sheet will contain variations 1 to 4, the second variations 5 to
8, etc.

When set to Stack by stack, the first station will contain variation 1 on sheet 1, variation 2 on sheet
2, variation 3 on sheet 3, etc. That way, after printing, the first station will contain variations 1 to 10,
stacked on top of each other.

7. By default the station order as set in the Step & Repeat Template is used. However, you can enable
Set custom station sequence to overrule that order.
a) Set the Start Position to define where the first variation should be placed in the grid: top left,

top right, bottom left or bottom right.
b) Set the Direction to define where to place the following variations in the grid: horizontal or

horizontal.
c) Set the Sequence: Snake (1) or Zigzag (2)
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8. If Apply Distortion is set to Immediately, any distortion factor set in the Document Setup of your
Variable Data Template will be applied on the Step & Repeat after generating it. If set to Later no
distortion will be done, so you can apply distortion in the Document Setup of the resulting Grid file.
See also Document Setup on page 89

9. Click Export PDF... to run the export.
10. Set the name and location for the new file, and click Export
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