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ArtiosCAD 24.03 Release Notes 
 

Visit ArtiosCAD news…  
https://www.esko.com/lp/artioscad/artioscad-news 

-or- 
 
Start ArtiosCAD.  Navigate to Help > ArtiosCAD News 

 

What’s new in:  
• Design 
• 3D 
• Layout 
• Manufacturing 
• General 
• Infrastructure 
• Integration 
• View 
• Enterprise 

Problem fixes  

Important notes for all users 
 

What’s new? 
Design Enhancements 

• Resizable Design Templates (RDTs), aka, standards, for Fefco and ECMA have been updated 
in the ArtiosCAD style catalog.  Updates will be an ongoing endeavor and new styles will be 
added in future releases. 
Navigate to Options > Defaults > Style Catalog > Resizeable Design Templates 

 

https://www.esko.com/en/lp/artioscad/artioscad-news
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See <Artios folder>\<version>\Instlib\<library>\Documentation for xls files that describe how the 
RDT was constructed.   
Example: C:\Esko\Artios\ArtiosCAD20.0\InstLib\ECMA\Documentation\ET_A20.20.01.01_.xlsx 
Geometry macros which were used to construct the RDTs have also been added. 

 
See <Artios folder>\<version>\Instlib\Geometry macros\<library>\Documentation for xls files that 
describe how the geometry macro was constructed. 
Example:C:\Esko\Artios\ArtiosCAD20.0\InstLib\Geometry 
macros\ECMA\Documentation\EGM_A20_21_30_Cover_Tuck_flap_Bottom.xlsx 
All previously released standards have been rerelease with improvements to the standard.  
These files are installed in the instlib directory in disk and will not replace any in ServerLib or 
ClientLib.  The standards should be evaluated before considering moving them outside instlib 
for access by your designers. 

• The canvas layout has been extended to allow automatic trimming. 
A new empty layout can be created. 
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Parts can be dragged onto the sheet (existing functionality). 
Bleed layers can be enabled.  If Sheet Properties > Touch bleed outlines is enabled 
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The bleed outline can be selected allow easier placement of parts by bleed outlines 

 
placed such that one part overlaps another part (existing functionality) [as to knock out 
unprintable parts that optimize the layout, perhaps reducing needed materials and/or producing 
a smaller machine thereby reducing costs]. 
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The overlapping parts can now be trimmed from the layout.  Select the part to be trimmed: 

 

And select the Trim tool:  
Then select overlapping geometry and it will be edited in the production part: 
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For reporting purposes, the layout itself can now be annotated: 
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Print registration marks can be now added to a canvas layout: 

 
 
And part layers can now be enabled in the layout (similar to oneup layer classes in an MFG file): 
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When converting a canvas layout to a manufacturing file (.mfg), any annotations, dimensions 
and print registration marks added to the canvas layout are added to the mfg file as user-
created layers of the same canvas layout layer 

 
A layout can be output to a report: 
The part layers, layout annotations and part name can all be controlled by the Report file 
window > Layer Selection > Use current view. 
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3D Enhancemements 
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• A new tool has been added to quickly build displays from existing products 

 
Select from 1 or more products that will be put on a variably-sized surface area that represents 
a shelf. 

 

 
Add a 2nd shelf 
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Fit the shelves as needed 

 
The user will receive feedback if products are too large for the shelf surface area, including the 
size to the set the shelf too in order to accommodate the proposed array. 
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Run a standard from a selection of specially designed shelves that allow for varying shelf 
heights.  Sample standards are provided. 

 
Relevant sizing data is passed to the standard based on the product placement: the number of 
shelves, the uniform area of the shelves and the varying heights of the shelves. 
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A new display is created in 3D 
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And a new canvas is created, complete with the products as a new product part and views and 
planograms 

 
The designer can readjust the product configuration by pushing the Show/Hide display button 
which hide the display and just expose the shelves. 
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This will allow the user to reconfigure product configuration using any of the standard 3D edit 
tools. 
The user can then rebuild the existing standard based in reconfiguration of shelf size and/or 
products. 
Relinking 

In future sessions, the ACD and A3D file can be relinked: 
- when opening the A3D file, the corresponding ACD file is also opened an 
- When opening the ACD file, the user must convert to 3D and then relink with the A3D. 
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Predefined display 
At any point a display can be locked so that the tool can be used to configure a display but not 
resize the shelves dimensions. 

 
• ArtiosCAD can output a JSON format to be used by Ansys Spaceclaim. 

 
 

Layout Enhancements 

Manufacturing Enhancements 
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General Enhancements 
 

Infrastructure Enhancements 

• Changes were made to the underlying code to extend the length of paths in file names.  There 
could be rare cases where long files paths + names larger than 259 characters will prevent 
older versions of ArtiosCAD from opening or crashing.  

• A new PDF tuning option has been added to allow better line style resolution for larger pages 

<?xml version="1.0" encoding="utf-8"?> 

<PDF_TUNNING_FILE> 

<!-- The TECHNICAL_INK_DEF node specifies the file containing 
name and line definition for the ArtiosCAD line types. --> 
<TECHNICAL_INK_DEF FILE="PDFSpotColorMap.xml"/>  

<SCALE_STYLE_FOR_LARGE_PAGE_SIZE/> 

</PDF_TUNNING_FILE> 
•  

• ArtiosCAD begins to better interact w/ hi-res monitors and text scaling.  The output dialog is 
cleaner for plot and samplemaking is cleaner for hi-rese monitors and scaled text .  The 
preview dialog is resizeable.  Their positions are remembered as well. 
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Integration Enhancements 

The Lasercomb CMS table has a configured output in ArtiosCAD. 

Enterprise 

• ArtiosCAD Enterprise client and WebCenter interoperability: 
ArtiosCAD 24.03 & WebCenter 24.03, 23.11 
ArtiosCAD 23.11 & WebCenter 24.03  
Note that  
WebCenter 

 

  /   WCR-71813 

 

ArtiosCAD - Draft is not removed on previous version of file once it is 
published to new version  
Has been addressed in WCR 24.03.  To realize this fix, WebCenter 24.03 must be deployed. 

 

https://urldefense.com/v3/__https:/packagingandcolor.atlassian.net/browse/WCR?atlOrigin=eyJpIjoiYzc5YTc1NGM0YzA1NDg2ODg2ZWUyMWRkNGZmOTYwZTIiLCJwIjoiaiJ9__;!!AC-Zr9Eh!NM23c2VQXXk0uk_D1RlYE8ZdN7VQw2YUe83lHA4vMDzKs9GHUTmkkTUedNEU2KtBf5tw78SgMi9VrCBPxcJDzB3hvQw3Ig$
https://urldefense.com/v3/__https:/packagingandcolor.atlassian.net/browse/WCR-71813?atlOrigin=eyJpIjoiYzc5YTc1NGM0YzA1NDg2ODg2ZWUyMWRkNGZmOTYwZTIiLCJwIjoiaiJ9__;!!AC-Zr9Eh!NM23c2VQXXk0uk_D1RlYE8ZdN7VQw2YUe83lHA4vMDzKs9GHUTmkkTUedNEU2KtBf5tw78SgMi9VrCBPxcJDzB1EvsdVEA$
https://urldefense.com/v3/__https:/packagingandcolor.atlassian.net/browse/WCR-71813?atlOrigin=eyJpIjoiYzc5YTc1NGM0YzA1NDg2ODg2ZWUyMWRkNGZmOTYwZTIiLCJwIjoiaiJ9__;!!AC-Zr9Eh!NM23c2VQXXk0uk_D1RlYE8ZdN7VQw2YUe83lHA4vMDzKs9GHUTmkkTUedNEU2KtBf5tw78SgMi9VrCBPxcJDzB1EvsdVEA$
https://urldefense.com/v3/__https:/packagingandcolor.atlassian.net/browse/WCR-71813?atlOrigin=eyJpIjoiYzc5YTc1NGM0YzA1NDg2ODg2ZWUyMWRkNGZmOTYwZTIiLCJwIjoiaiJ9__;!!AC-Zr9Eh!NM23c2VQXXk0uk_D1RlYE8ZdN7VQw2YUe83lHA4vMDzKs9GHUTmkkTUedNEU2KtBf5tw78SgMi9VrCBPxcJDzB1EvsdVEA$
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Problem fixes:  
 Customer reported fixes 
ACAD-10594 ArtiosCAD 3D does not show correct dimensions in 3D when Perf lines are 

used 
ACAD-10607 Probleme 3D – dimensions when folding material with uneven IL/OG 
ACAD-10730 Convert to 3D missing some holes 
ACAD-10771 Long path file makes problem (internal: ACAD-10783)  
ACAD-10772 Line type label disrupts line 
ACAD-10833 Errores en la ultima version de ArtiosCAD 23.11 
ACAD-10853 ArtiosCAD Enterprise 23.11 build 2399 ArtiosCAD toolbars disappearing 
ACAD-10854 Keine neuen Ordner in deb Vorgaben erstellbar 
ACAD-10875 ArtiosCAD – line style in PDF output doesn’t match onscreen 
ACAD-10880 Board edge in 3D 
ACAD-10881 Inside loss – outside gain 
ACAD-10883 ArtiosCAD Enterprise 23.11 – Defaults Browser Node in Location Defaults is 

ignored 
ACAD-10885 ArtiosCAD 23.11 – Conline through bridge error 
ACAD-10886 ArtiosCAD Enterprise 23.11 b2399 – No flap priority when using perf, partial 

cut and folding carton 
ACAD-10891 Impossible to open the 3D file… 
ACAD-10922 Error message when using tools Conline through bridge and Conline through 

nick 
ACAD-10931 ArtiosCAD 23.11 Front waste separator and interference 
ACAD-11031 ArtiosCAD – blend tool causing Wrong Values in 3D Dimensions 
ACAD-11035 ArtiosCAD crashes when using the Join Rubber tool 
 Important internal fixes 
ACAD-10736 Address WCR-65262 
ACAD-10743 Extend design tool refresh view issue 
ACAD-10774 Edge Rendering Regression 
ACAD-10787 3D > panels > extending creases 
ACAD-10792 Crash adding Bolt holes in Manufacturing 
ACAD-10820 Rebuild design does not calculate invisible variables… 
ACAD-10832 Geom macro > Splitter > move spliter line >= 50% of dlg width 
ACAD-10923 3D Perf rendering wrong after convert to canvas 
ACAD-10963 Layout > Bleed > fix gutter/bleed (X direction touch bleed) 
ACAD-11029 Follow up w/ WCR-71813 
ACAD-11033 Layout > Station position > not working, see description (oneups have holes) 
ACAD-11062 3D > ARDLib > Autobottom > Erected state will lose bottom panels 
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Important Notes for All Users 
• Starting with 18.1.1, ArtiosCAD introduced preflight with some automatic corrections.  

One of these auto-corrections included the ability to remove double knives/lines.  
The preflight correction ability resulted in an algorithm that now favored longer lines 
over shorter lines, as a way to make better technical designs.  Previously, shorter 
lines were favored.  Rebuildable designs have been encountered where “double 
knife” removal was used as a design technique to create slots for example of small 
cuts lines over creases.  This has caused some issues where item references which 
might have existed before are now being deleted during the double line removal step 
and causing rebuilds to be incorrect or fail.   This technique was not anticipated.  
ArtiosCAD is restored some of the rebuild issues and is still working through others. 

• If the deployed licensing for ArtiosCAD is a network license, the license server 
*must* be updated with the new system controller provided on the installation 
media. 

• Flexnet is the only licensing system utilized in ArtiosCAD.  Users must be prepared 
to convert the licensing from the hardware key, Sentinel LM or Elan LM to Flexnet.  
As of Jan 2016, Esko will no longer be able to provide licenses for legacy licensing 
systems. 

• Esko now provides a knowledge base at http://help.esko.com/knowledgebase.  This 
site can be used to find detailed information for ArtiosCAD and other Esko products 
about many support questions raised to Esko. 

• Esko software can be downloaded from https://mysoftware.esko.com with a valid 
support account. 

• User documentation and help will be available from an online Esko site.  
Documentation will not be available from the media.  The main site is 
http://help.esko.com from which ArtiosCAD and other Esko product documentation is 
available.  The ArtiosCAD help menu will bring the user to the ArtiosCAD help page. 

• The most current Adobe®Illustrator® Esko plugins can be found at 
http://www.esko.com.  Navigate as described below. 

http://help.esko.com/knowledgebase
https://mysoftware.esko.com/
http://help.esko.com/
http://www.esko.com/
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• PCIQ fonts will be removed after ArtiosCAD 20.  Please use true-type fonts. 

• The Artios (introduced circa 1996 as a transition to ArtiosCAD) and DBH (the original 
interact format) file formats and use of the devtab as a configuration file for 
communicating with printers and ports are considered obsolete and support for them 
will be removed in post 18 versions of ArtiosCAD. 

• Exports under File > Export > ArtiosCAD 3.2x and lower may be removed in future 
versions of ArtiosCAD. 

• Windows 11, Windows 10 editions has been certified for use with ArtiosCAD as a 
standard mouse-controlled application.  There are some installation limitations.  See  
KB344821882: Which versions of Windows 10 are supported? 
 

o There are Metro GUI limitations: 
 The application folder structure organized in previous versions of 

windows 8 has been flattened.  There will be multiple application tiles. 
 There is no support for touchpads nor touchscreens and any use of 

gestures is purely coincidental. 

https://wiki.esko.com/pages/viewpage.action?pageId=344822489
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• The IOServer (ArtiosIO) is now supported  on Windows 7 and higher since 
Artioscad 14. 1.  This means older DataTech plotters still using the IPC controller or 
any device with an RS232 connection will be supported 

• Many users have or are planning to deploy Citrix, Terminal Services (TS) 
environments or some other application hosting system.  Esko has not officially 
certified ArtiosCAD for use in a Citrix or TS environment, however, Esko does not 
prevent its use as long as the customer accepts responsibility for deployment 
and support of the environment. 
Esko has verified that ArtiosCAD can run as a Citrix or Terminal Services client 
and has licensed ArtiosCAD  appropriately, however, there are some limitations, 
including but not limited to: 

• Flexnet network licensing must be used. 

• License reservation or denial via floating license servers is not 
supported. 

• Graphics cards are installed on a Citrix or TS server and ArtiosCAD 
3D uses the server card for 3D rendering.  The performance of many 
concurrent 3D users is unknown. 

• The exact server specifications (example, memory, processor) for a 
given set of clients is unknown. 

• There are essentially no user defaults, since every Citrix or TS client 
is running from the same Citrix server. 

• There have been reports that access to local devices like hard drives 
or printers can freeze the machine.  It is unknown if these issues have 
been addressed in newer versions of Citrix. 

• The HASP key used for the Alma PowerNest software in the 
ArtiosCAD rubbering layout can not be recognized by Citrix or TS and 
must be used on a client not connected to the Citrix server. 

• 64-bit Citrix has not been tested in any way. 

• Many users are planning to deploy VMWare ESX-based solutions, Hyper V 
(Windows Server Virtualization), Citrix XenServer or other hypervisor technology.   
Esko has not officially certified ArtiosCAD for use in this environment, however, Esko 
does not prevent its use as long as the customer accepts responsibility for 
deployment and support of the environment. 

 

• Artioscad has been certified for VMware Fusion v7.  The customer may run later 
versions of his own accord on hardware and OS of his choosing, but Esko provides 
no warranty of the resulting combination.   

 
• 3D graphics cards… newer computers often come with some form of switchable 

graphics technology. This means that there are two or more video cards that switch 
off doing rendering duties on the system. Because of this, it is entirely possible that 
ArtiosCAD will be run using the low end, power saving chip. This drastically lowers 



A R T I O S C A D  2 4 . 0 3  

 R E L E A S E  N O T E S  

 

27 
 

performance, and may introduce issues when working within ArtiosCAD 3D. It is 
sometimes also possible that the current chip changes, which can lead to all sorts of 
stability issues. It is recommended that the user go to the control panel controlling 
the graphics cards (NVidia Control Panel or AMD Catalyst Control Center) and 
create a profile for ArtiosCAD so it will use the high end chip always. 
 
A number of rendering issues with NVidia cards and openGL have been raised.  
Changes were made to what is believed to be an improvement in the error handling 
of newer NVidia cards particularly those with dual graphic cards. 

• Since its inception, Artioscad has provided a database schema that has always been 
backwards compatible with previous versions of Artioscad and 3rd party applications.  
An ArtiosCAD enterprise edition has now been released and utilizes a new database 
backend (WebCenter).  It is expected that the database functionality for the 
conventional ArtiosCAD edition will be frozen at its current level.  New design 
functionality will continue to be added.  It is expected that a single database edition 
will be created in the future. 
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