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1.  Location and Copyright
Esko

Raymonde de Larochelaan 13

9051 Gent

Belgium

Tel.: (32) (9) 216-92-11

Fax: (32) (9) 216-94-64

Other oces worldwide.

Written by Adam Hartfield, updated by WDE March 2024.

For use with ArtiosCAD and ArtiosCAD Enterprise .
© Copyright 2024 Esko Software BV, Gent, Belgium.

All rights reserved. This material, information and instructions for use contained herein are the
property of Esko Software BV. The material, information and instructions are provided on an AS IS
basis without warranty of any kind. There are no warranties granted or extended by this document.
Furthermore Esko Software BV does not warrant, guarantee or make any representations regarding
the use, or the results of the use of the software or the information contained herein. Esko Software
BV shall not be liable for any direct, indirect, consequential or incidental damages arising out of the use
or inability to use the software or the information contained herein.

The information contained herein is subject to change without notice. Revisions may be issued from
time to time to advise of such changes and/or additions.

No part of this document may be reproduced, stored in a data base or retrieval system, or published, in
any form or in any way, electronically, mechanically, by print, photoprint, microfilm or any other means
without prior written permission from Esko Software BV.

This document supersedes all previous dated versions.

Correspondence regarding this publication should be forwarded to:

Esko

Raymonde de Larochelaan 13

9051 Gent

Belgium

info.eur@esko.com

Third party license information and trademarks - 24.03

This software is based in part on the work of the Independent JPEG Group.

Adobe, Acrobat, Illustrator, and PostScript are either registered trademarks or trademarks of Adobe
Systems Incorporated in the United States and/or other countries.
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Microsoft and the Microsoft logo are registered trademarks of Microsoft Corporation in the United
States and other countries.

The Esko software may contain an implementation of the LZW algorithm licensed under U. S. Patent
4,558,302 and foreign counterparts.

The Esko software may contain the “RSA Data Security, Inc. MD5 Message-Digest Algorithm.”

Oracle and Java are registered trademarks of Oracle and/or its aliates. Other names may be
trademarks of their respective owners.

Strip Clip, Strip Fork and Strip Clip
®

 System are products, registered trademarks and patents of Vossen
Profitec

®
 GmbH Germany.

OpenGL is a registered trademark of Silicon Graphics, Inc.

The geometry macros contained with this release of ArtiosCAD to facilitate the use of Vossen
Profitec components are approved by Vossen Profitec GmbH and are used with their permission. The
Vossen Prax

®
 documentation should be consulted and used to ensure correct use and placement

of these geometry macros. The shapes and offsets used are in accordance with Vossen Profitec
GmbH specifications. Usage and placement of these geometry macros to ensure effective stripping
performance, however, remains the responsibility of the user. Vossen Profitec GmbH may be contacted
for details of worldwide representation at (49) (7771) 920-136 or by e-mail at info@vossen-profitec.de.

This software may use libxml2 - Copyright © 1998-2003 Daniel Veillard - All rights reserved.

This product includes lzw-ab.

    Copyright (c) David Bryant
    All rights reserved.

    Redistribution and use in source and binary forms, with or without
    modification, are permitted provided that the following conditions are met:

    * Redistributions of source code must retain the above copyright notice,
      this list of conditions and the following disclaimer.
    * Redistributions in binary form must reproduce the above copyright notice,
      this list of conditions and the following disclaimer in the
      documentation and/or other materials provided with the distribution.
    * Neither the name of Conifer Software nor the names of its contributors
      may be used to endorse or promote products derived from this software
      without specific prior written permission.

    THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
    AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
    IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
    ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR
    ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
    DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
    SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
    CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
    OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
    OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC Profiles were created by FFEI Ltd. (www.ffei.co.uk) using Fujifilm
    ColourKit Profiler Suite (www.colourprofiling.com)
    
------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC profiles are copyright (C) by European Color Initiative, www.eci.org
    
------------------------------------------------------------

This product includes ICC Profiles.
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    Some ICC profiles are copyright (C) of WAN-IFRA, www.wan-ifra.org
    
------------------------------------------------------------

This product includes ICC Profiles.

    Some ICC profiles are copyright (C) IDEAlliance(R). G7(R), GRACol(R) and
    SWOP(R) are all registered trademarks of IDEAlliance(C).
    
------------------------------------------------------------

This product includes PANTONE Color Libraries.

    PANTONE® and other Pantone trademarks are the property of Pantone LLC.
    Pantone is a wholly owned subsidiary of X-Rite, Incorporated.
    
------------------------------------------------------------

This product includes curl.

   COPYRIGHT AND PERMISSION NOTICE

   Copyright (c) 1996 - 2023, Daniel Stenberg, <daniel@haxx.se>, and many
   contributors, see the THANKS file.

   All rights reserved.

   Permission to use, copy, modify, and distribute this software for any purpose
   with or without fee is hereby granted, provided that the above copyright
   notice and this permission notice appear in all copies.

   THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
   IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
   FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN
   NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
   DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
   OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
   OR OTHER DEALINGS IN THE SOFTWARE.

   Except as contained in this notice, the name of a copyright holder shall not
   be used in advertising or otherwise to promote the sale, use or other dealings
   in this Software without prior written authorization of the copyright holder.
    
------------------------------------------------------------

This product includes LibTIFF.

      Copyright (c) 1988-1997 Sam Leffler
      Copyright (c) 1991-1997 Silicon Graphics, Inc.

      Permission to use, copy, modify, distribute, and sell this software and
      its documentation for any purpose is hereby granted without fee, provided
      that (i) the above copyright notices and this permission notice appear in
      all copies of the software and related documentation, and (ii) the names of
      Sam Leffler and Silicon Graphics may not be used in any advertising or
      publicity relating to the software without the specific, prior written
      permission of Sam Leffler and Silicon Graphics.

      THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,
      EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
      WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

      IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR
      ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND,
      OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
      WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF
      LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
      OF THIS SOFTWARE.
    
------------------------------------------------------------

This product includes FCollada.

      Copyright 2006 Feeling Software. All rights reserved.

      Copyright 2005-2006 Feeling Software and
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      Copyright 2005-2006 Autodesk Media Entertainment.

      Copyright (C) 1998-2003 Daniel Veillard. All Rights Reserved.

      Permission is hereby granted, free of charge, to any person obtaining a copy
      of this software and associated documentation files (the "Software"), to deal
      in the Software without restriction, including without limitation the rights
      to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
      copies of the Software, and to permit persons to whom the Software is fur-
      nished to do so, subject to the following conditions:

      The above copyright notice and this permission notice shall be included in
      all copies or substantial portions of the Software.

      THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
      IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FIT-
      NESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL THE
      AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
      LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
      OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
      THE SOFTWARE.
    
------------------------------------------------------------

This product includes FreeType.

    Portions of this software are copyright (C) 2014 The FreeType
    Project (www.freetype.org) licensed under the Freetype License.
    All rights reserved.
    
------------------------------------------------------------

This product includes GLEW: The OpenGL Extension Wrangler Library.

The OpenGL Extension Wrangler Library
Copyright (C) 2002-2007, Milan Ikits <milan ikits[]ieee org>
Copyright (C) 2002-2007, Marcelo E. Magallon <mmagallo[]debian org>
Copyright (C) 2002, Lev Povalahev
All rights reserved.

Redistribution and use in source and binary forms, with or without 
modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, 
  this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright notice, 
  this list of conditions and the following disclaimer in the documentation 
  and/or other materials provided with the distribution.
* The name of the author may be used to endorse or promote products 
  derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" 
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE 
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
THE POSSIBILITY OF SUCH DAMAGE.

Mesa 3-D graphics library
Version:  7.0

Copyright (C) 1999-2007  Brian Paul   All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the "Software"),
to deal in the Software without restriction, including without limitation
the rights to use, copy, modify, merge, publish, distribute, sublicense,
and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included
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in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Copyright (c) 2007 The Khronos Group Inc.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and/or associated documentation files (the
"Materials"), to deal in the Materials without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Materials, and to
permit persons to whom the Materials are furnished to do so, subject to
the following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Materials.

THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS.
  
------------------------------------------------------------

This product includes ICU.

      Copyright (c) 1991-2023 Unicode, Inc. All rights reserved.
      Distributed under the Terms of Use in https://www.unicode.org/copyright.html.
      
      Permission is hereby granted, free of charge, to any person obtaining
      a copy of the Unicode data files and any associated documentation
      (the "Data Files") or Unicode software and any associated documentation
      (the "Software") to deal in the Data Files or Software
      without restriction, including without limitation the rights to use,
      copy, modify, merge, publish, distribute, and/or sell copies of
      the Data Files or Software, and to permit persons to whom the Data Files
      or Software are furnished to do so, provided that either
      (a) this copyright and permission notice appear with all copies
      of the Data Files or Software, or
      (b) this copyright and permission notice appear in associated
      Documentation.
      
      THE DATA FILES AND SOFTWARE ARE PROVIDED "AS IS", WITHOUT WARRANTY OF
      ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
      WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
      NONINFRINGEMENT OF THIRD PARTY RIGHTS.
      IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS
      NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL
      DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
      DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
      TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
      PERFORMANCE OF THE DATA FILES OR SOFTWARE.

      ----------------------------------------------------------------------

      Chinese/Japanese Word Break Dictionary Data (cjdict.txt)
      
       #     The Google Chrome software developed by Google is licensed under
       # the BSD license. Other software included in this distribution is
       # provided under other licenses, as set forth below.
       #
       #  The BSD License
       #  http://opensource.org/licenses/bsd-license.php
       #  Copyright (C) 2006-2008, Google Inc.
       #
       #  All rights reserved.
       #
       #  Redistribution and use in source and binary forms, with or without
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       # modification, are permitted provided that the following conditions are met:
       #
       #  Redistributions of source code must retain the above copyright notice,
       # this list of conditions and the following disclaimer.
       #  Redistributions in binary form must reproduce the above
       # copyright notice, this list of conditions and the following
       # disclaimer in the documentation and/or other materials provided with
       # the distribution.
       #  Neither the name of  Google Inc. nor the names of its
       # contributors may be used to endorse or promote products derived from
       # this software without specific prior written permission.
       #
       #
       #  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
       # CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
       # INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
       # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
       # DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
       # LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
       # CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
       # SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
       # BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
       # LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
       # NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
       # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
       #
       #
       #  The word list in cjdict.txt are generated by combining three word lists
       # listed below with further processing for compound word breaking. The
       # frequency is generated with an iterative training against Google web
       # corpora.
       #
       #  * Libtabe (Chinese)
       #    - https://sourceforge.net/project/?group_id=1519
       #    - Its license terms and conditions are shown below.
       #
       #  * IPADIC (Japanese)
       #    - http://chasen.aist-nara.ac.jp/chasen/distribution.html
       #    - Its license terms and conditions are shown below.
       #
       #  ---------COPYING.libtabe ---- BEGIN--------------------
       #
       #  /*
       #   * Copyright (c) 1999 TaBE Project.
       #   * Copyright (c) 1999 Pai-Hsiang Hsiao.
       #   * All rights reserved.
       #   *
       #   * Redistribution and use in source and binary forms, with or without
       #   * modification, are permitted provided that the following conditions
       #   * are met:
       #   *
       #   * . Redistributions of source code must retain the above copyright
       #   *   notice, this list of conditions and the following disclaimer.
       #   * . Redistributions in binary form must reproduce the above copyright
       #   *   notice, this list of conditions and the following disclaimer in
       #   *   the documentation and/or other materials provided with the
       #   *   distribution.
       #   * . Neither the name of the TaBE Project nor the names of its
       #   *   contributors may be used to endorse or promote products derived
       #   *   from this software without specific prior written permission.
       #   *
       #   * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
       #   * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
       #   * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
       #   * FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
       #   * REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
       #   * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
       #   * (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
       #   * SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
       #   * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
       #   * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
       #   * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
       #   * OF THE POSSIBILITY OF SUCH DAMAGE.
       #   */
       #
       #  /*
       #   * Copyright (c) 1999 Computer Systems and Communication Lab,
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       #   *                    Institute of Information Science, Academia
       #       *                    Sinica. All rights reserved.
       #   *
       #   * Redistribution and use in source and binary forms, with or without
       #   * modification, are permitted provided that the following conditions
       #   * are met:
       #   *
       #   * . Redistributions of source code must retain the above copyright
       #   *   notice, this list of conditions and the following disclaimer.
       #   * . Redistributions in binary form must reproduce the above copyright
       #   *   notice, this list of conditions and the following disclaimer in
       #   *   the documentation and/or other materials provided with the
       #   *   distribution.
       #   * . Neither the name of the Computer Systems and Communication Lab
       #   *   nor the names of its contributors may be used to endorse or
       #   *   promote products derived from this software without specific
       #   *   prior written permission.
       #   *
       #   * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
       #   * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
       #   * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
       #   * FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
       #   * REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
       #   * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
       #   * (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
       #   * SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
       #   * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
       #   * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
       #   * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
       #   * OF THE POSSIBILITY OF SUCH DAMAGE.
       #   */
       #
       #  Copyright 1996 Chih-Hao Tsai @ Beckman Institute,
       #      University of Illinois
       #  c-tsai4@uiuc.edu  http://casper.beckman.uiuc.edu/~c-tsai4
       #
       #  ---------------COPYING.libtabe-----END--------------------------------
       #
       #
       #  ---------------COPYING.ipadic-----BEGIN-------------------------------
       #
       #  Copyright 2000, 2001, 2002, 2003 Nara Institute of Science
       #  and Technology.  All Rights Reserved.
       #
       #  Use, reproduction, and distribution of this software is permitted.
       #  Any copy of this software, whether in its original form or modified,
       #  must include both the above copyright notice and the following
       #  paragraphs.
       #
       #  Nara Institute of Science and Technology (NAIST),
       #  the copyright holders, disclaims all warranties with regard to this
       #  software, including all implied warranties of merchantability and
       #  fitness, in no event shall NAIST be liable for
       #  any special, indirect or consequential damages or any damages
       #  whatsoever resulting from loss of use, data or profits, whether in an
       #  action of contract, negligence or other tortuous action, arising out
       #  of or in connection with the use or performance of this software.
       #
       #  A large portion of the dictionary entries
       #  originate from ICOT Free Software.  The following conditions for ICOT
       #  Free Software applies to the current dictionary as well.
       #
       #  Each User may also freely distribute the Program, whether in its
       #  original form or modified, to any third party or parties, PROVIDED
       #  that the provisions of Section 3 ("NO WARRANTY") will ALWAYS appear
       #  on, or be attached to, the Program, which is distributed substantially
       #  in the same form as set out herein and that such intended
       #  distribution, if actually made, will neither violate or otherwise
       #  contravene any of the laws and regulations of the countries having
       #  jurisdiction over the User or the intended distribution itself.
       #
       #  NO WARRANTY
       #
       #  The program was produced on an experimental basis in the course of the
       #  research and development conducted during the project and is provided
       #  to users as so produced on an experimental basis.  Accordingly, the
       #  program is provided without any warranty whatsoever, whether express,
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       #  implied, statutory or otherwise.  The term "warranty" used herein
       #  includes, but is not limited to, any warranty of the quality,
       #  performance, merchantability and fitness for a particular purpose of
       #  the program and the nonexistence of any infringement or violation of
       #  any right of any third party.
       #
       #  Each user of the program will agree and understand, and be deemed to
       #  have agreed and understood, that there is no warranty whatsoever for
       #  the program and, accordingly, the entire risk arising from or
       #  otherwise connected with the program is assumed by the user.
       #
       #  Therefore, neither ICOT, the copyright holder, or any other
       #  organization that participated in or was otherwise related to the
       #  development of the program and their respective officials, directors,
       #  officers and other employees shall be held liable for any and all
       #  damages, including, without limitation, general, special, incidental
       #  and consequential damages, arising out of or otherwise in connection
       #  with the use or inability to use the program or any product, material
       #  or result produced or otherwise obtained by using the program,
       #  regardless of whether they have been advised of, or otherwise had
       #  knowledge of, the possibility of such damages at any time during the
       #  project or thereafter.  Each user will be deemed to have agreed to the
       #  foregoing by his or her commencement of use of the program.  The term
       #  "use" as used herein includes, but is not limited to, the use,
       #  modification, copying and distribution of the program and the
       #  production of secondary products from the program.
       #
       #  In the case where the program, whether in its original form or
       #  modified, was distributed or delivered to or received by a user from
       #  any person, organization or entity other than ICOT, unless it makes or
       #  grants independently of ICOT any specific warranty to the user in
       #  writing, such person, organization or entity, will also be exempted
       #  from and not be held liable to the user for any such damages as noted
       #  above as far as the program is concerned.
       #
       #  ---------------COPYING.ipadic-----END----------------------------------
      
      ----------------------------------------------------------------------
      
      Lao Word Break Dictionary Data (laodict.txt)
      
       # Copyright (C) 2016 and later: Unicode, Inc. and others.
       # License & terms of use: http://www.unicode.org/copyright.html
       # Copyright (c) 2015 International Business Machines Corporation
       # and others. All Rights Reserved.
       #
       # Project: https://github.com/rober42539/lao-dictionary
       # Dictionary: https://github.com/rober42539/lao-dictionary/laodict.txt
       # License: https://github.com/rober42539/lao-dictionary/LICENSE.txt
       #          (copied below)
       #
       # This file is derived from the above dictionary version of Nov 22, 2020
       #  ----------------------------------------------------------------------
       #  Copyright (C) 2013 Brian Eugene Wilson, Robert Martin Campbell.
       #  All rights reserved.
       #
       #  Redistribution and use in source and binary forms, with or without
       #  modification, are permitted provided that the following conditions are met:
       #
       #  Redistributions of source code must retain the above copyright notice, this
       #  list of conditions and the following disclaimer. Redistributions in binary
       #  form must reproduce the above copyright notice, this list of conditions and
       #  the following disclaimer in the documentation and/or other materials
       #  provided with the distribution.
       #
       # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
       # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
       # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
       # FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
       # COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
       # INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
       # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
       # SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
       # HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
       # STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
       # ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
       # OF THE POSSIBILITY OF SUCH DAMAGE.
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       #  --------------------------------------------------------------------------
      
      ----------------------------------------------------------------------
      
      Burmese Word Break Dictionary Data (burmesedict.txt)
      
       #  Copyright (c) 2014 International Business Machines Corporation
       #  and others. All Rights Reserved.
       #
       #  This list is part of a project hosted at:
       #    github.com/kanyawtech/myanmar-karen-word-lists
       #
       #  --------------------------------------------------------------------------
       #  Copyright (c) 2013, LeRoy Benjamin Sharon
       #  All rights reserved.
       #
       #  Redistribution and use in source and binary forms, with or without
       #  modification, are permitted provided that the following conditions
       #  are met: Redistributions of source code must retain the above
       #  copyright notice, this list of conditions and the following
       #  disclaimer.  Redistributions in binary form must reproduce the
       #  above copyright notice, this list of conditions and the following
       #  disclaimer in the documentation and/or other materials provided
       #  with the distribution.
       #
       #    Neither the name Myanmar Karen Word Lists, nor the names of its
       #    contributors may be used to endorse or promote products derived
       #    from this software without specific prior written permission.
       #
       #  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND
       #  CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
       #  INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
       #  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
       #  DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS
       #  BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
       #  EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
       #  TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
       #  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
       #  ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
       #  TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
       #  THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
       #  SUCH DAMAGE.
       #  --------------------------------------------------------------------------
      
      ----------------------------------------------------------------------
      
      Time Zone Database
      
        ICU uses the public domain data and code derived from Time Zone
      Database for its time zone support. The ownership of the TZ database
      is explained in BCP 175: Procedure for Maintaining the Time Zone
      Database section 7.
      
       # 7.  Database Ownership
       #
       #    The TZ database itself is not an IETF Contribution or an IETF
       #    document.  Rather it is a pre-existing and regularly updated work
       #    that is in the public domain, and is intended to remain in the
       #    public domain.  Therefore, BCPs 78 [RFC5378] and 79 [RFC3979] do
       #    not apply to the TZ Database or contributions that individuals make
       #    to it.  Should any claims be made and substantiated against the TZ
       #    Database, the organization that is providing the IANA
       #    Considerations defined in this RFC, under the memorandum of
       #    understanding with the IETF, currently ICANN, may act in accordance
       #    with all competent court orders.  No ownership claims will be made
       #    by ICANN or the IETF Trust on the database or the code.  Any person
       #    making a contribution to the database or code waives all rights to
       #    future claims in that contribution or in the TZ Database.
      
      ----------------------------------------------------------------------
      
      Google double-conversion
      
      Copyright 2006-2011, the V8 project authors. All rights reserved.
      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions are
      met:
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          * Redistributions of source code must retain the above copyright
            notice, this list of conditions and the following disclaimer.
          * Redistributions in binary form must reproduce the above
            copyright notice, this list of conditions and the following
            disclaimer in the documentation and/or other materials provided
            with the distribution.
          * Neither the name of Google Inc. nor the names of its
            contributors may be used to endorse or promote products derived
            from this software without specific prior written permission.
      
      THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
      "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
      LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
      A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
      OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
      SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
      LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
      DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
      THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
      (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
      OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
      
      ----------------------------------------------------------------------
      
      File: aclocal.m4 (only for ICU4C)
      Section: pkg.m4 - Macros to locate and utilise pkg-config.
      
      
      Copyright (c) 2004 Scott James Remnant <scott@netsplit.com>.
      Copyright (c) 2012-2015 Dan Nicholson <dbn.lists@gmail.com>
      
      This program is free software; you can redistribute it and/or modify
      it under the terms of the GNU General Public License as published by
      the Free Software Foundation; either version 2 of the License, or
      (at your option) any later version.
      
      This program is distributed in the hope that it will be useful, but
      WITHOUT ANY WARRANTY; without even the implied warranty of
      MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
      General Public License for more details.
      
      You should have received a copy of the GNU General Public License
      along with this program; if not, write to the Free Software
      Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
      02111-1307, USA.
      
      As a special exception to the GNU General Public License, if you
      distribute this file as part of a program that contains a
      configuration script generated by Autoconf, you may include it under
      the same distribution terms that you use for the rest of that
      program.
      
      
      (The condition for the exception is fulfilled because
      ICU4C includes a configuration script generated by Autoconf,
      namely the `configure` script.)
      
      ----------------------------------------------------------------------
      
      File: config.guess (only for ICU4C)
      
      
      This file is free software; you can redistribute it and/or modify it
      under the terms of the GNU General Public License as published by
      the Free Software Foundation; either version 3 of the License, or
      (at your option) any later version.
      
      This program is distributed in the hope that it will be useful, but
      WITHOUT ANY WARRANTY; without even the implied warranty of
      MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
      General Public License for more details.
      
      You should have received a copy of the GNU General Public License
      along with this program; if not, see <https://www.gnu.org/licenses/>.
      
      As a special exception to the GNU General Public License, if you
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      distribute this file as part of a program that contains a
      configuration script generated by Autoconf, you may include it under
      the same distribution terms that you use for the rest of that
      program.  This Exception is an additional permission under section 7
      of the GNU General Public License, version 3 ("GPLv3").
      
      
      (The condition for the exception is fulfilled because
      ICU4C includes a configuration script generated by Autoconf,
      namely the `configure` script.)
      
      ----------------------------------------------------------------------
      
      File: install-sh (only for ICU4C)
      
      
      Copyright 1991 by the Massachusetts Institute of Technology
      
      Permission to use, copy, modify, distribute, and sell this software and its
      documentation for any purpose is hereby granted without fee, provided that
      the above copyright notice appear in all copies and that both that
      copyright notice and this permission notice appear in supporting
      documentation, and that the name of M.I.T. not be used in advertising or
      publicity pertaining to distribution of the software without specific,
      written prior permission.  M.I.T. makes no representations about the
      suitability of this software for any purpose.  It is provided "as is"
      without express or implied warranty.
    
------------------------------------------------------------

This product includes JBIG2Lib.

    Portions of this product copyrights (C) 2002 Glyph & Cog, LLC.
    
------------------------------------------------------------

This product includes JPEGLib.
This software is copyright (C) 1991-2016, Thomas G. Lane, Guido Vollbeding.
      All Rights Reserved.
      
      This software is based in part on the work of the Independent JPEG Group.
------------------------------------------------------------

This product includes Little CMS.

    Little CMS
    Copyright (c) 1998-2020 Marti Maria Saguer

    Permission is hereby granted, free of charge, to any person obtaining
    a copy of this software and associated documentation files (the 
    "Software"), to deal in the Software without restriction, including
    without limitation the rights to use, copy, modify, merge, publish,
    distribute, sublicense, and/or sell copies of the Software, and to 
    permit persons to whom the Software is furnished to do so, subject
    to the following conditions:

    The above copyright notice and this permission notice shall be 
    included in all copies or substantial portions of the Software.

    THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
    EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF 
    MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
    IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
    CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
    TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE 
    SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
    
------------------------------------------------------------

This product includes libxml2.

    Copyright (C) 1998-2012 Daniel Veillard.  All Rights Reserved.

    Permission is hereby granted, free of charge, to any person obtaining a copy
    of this software and associated documentation files (the "Software"), to deal
    in the Software without restriction, including without limitation the rights
    to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
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    copies of the Software, and to permit persons to whom the Software is fur-
    nished to do so, subject to the following conditions:

    The above copyright notice and this permission notice shall be included in
    all copies or substantial portions of the Software.

    THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
    IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FIT-
    NESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL THE
    AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
    LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
    OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
    THE SOFTWARE.
    
------------------------------------------------------------

This product includes Micorsoft.Web.WebView2.

Copyright (C) Microsoft Corporation. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

   * Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
   * Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following disclaimer
in the documentation and/or other materials provided with the
distribution.
   * The name of Microsoft Corporation, or the names of its contributors 
may not be used to endorse or promote products derived from this
software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes OpenJPEG.

        The copyright in this software is being made available under the 2-clauses
        BSD License, included below. This software may be subject to other third
        party and contributor rights, including patent rights, and no such rights
        are granted under this license.
       
        Copyright (c) 2002-2014, Universite catholique de Louvain (UCL), Belgium
        Copyright (c) 2002-2014, Professor Benoit Macq
        Copyright (c) 2003-2014, Antonin Descampe
        Copyright (c) 2003-2009, Francois-Olivier Devaux
        Copyright (c) 2005, Herve Drolon, FreeImage Team
        Copyright (c) 2002-2003, Yannick Verschueren
        Copyright (c) 2001-2003, David Janssens
        Copyright (c) 2011-2012, Centre National d'Etudes Spatiales (CNES), France
        Copyright (c) 2012, CS Systemes d'Information, France
       
        All rights reserved.
       
        Redistribution and use in source and binary forms, with or without
        modification, are permitted provided that the following conditions
        are met:
        1. Redistributions of source code must retain the above copyright
           notice, this list of conditions and the following disclaimer.
        2. Redistributions in binary form must reproduce the above copyright
           notice, this list of conditions and the following disclaimer in the
           documentation and/or other materials provided with the distribution.
       
        THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS `AS IS'

56



1ArtiosCAD

        AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
        IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
        ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
        LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
        CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
        SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
        INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
        CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
        ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
        POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes OpenSSL.

      Copyright (c) 1998-2019 The OpenSSL Project.  All rights reserved.

      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions
      are met:

      1. Redistributions of source code must retain the above copyright
         notice, this list of conditions and the following disclaimer.

      2. Redistributions in binary form must reproduce the above copyright
         notice, this list of conditions and the following disclaimer in
         the documentation and/or other materials provided with the
         distribution.

      3. All advertising materials mentioning features or use of this
         software must display the following acknowledgment:
         "This product includes software developed by the OpenSSL Project
         for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

      4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to
         endorse or promote products derived from this software without
         prior written permission. For written permission, please contact
         openssl-core@openssl.org.

      5. Products derived from this software may not be called "OpenSSL"
         nor may "OpenSSL" appear in their names without prior written
         permission of the OpenSSL Project.

      6. Redistributions of any form whatsoever must retain the following
         acknowledgment:
         "This product includes software developed by the OpenSSL Project
         for use in the OpenSSL Toolkit (http://www.openssl.org/)"

      THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY
      EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
      PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE OpenSSL PROJECT OR
      ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
      SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
      NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
      LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
      HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
      STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
      ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
      OF THE POSSIBILITY OF SUCH DAMAGE.
    
------------------------------------------------------------

This product includes OpenSSL.

      Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)
      All rights reserved.

      Redistribution and use in source and binary forms, with or without
      modification, are permitted provided that the following conditions
      are met:
      1. Redistributions of source code must retain the copyright
         notice, this list of conditions and the following disclaimer.
      2. Redistributions in binary form must reproduce the above copyright
         notice, this list of conditions and the following disclaimer in the
         documentation and/or other materials provided with the distribution.
      3. All advertising materials mentioning features or use of this software
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         must display the following acknowledgement:
         "This product includes cryptographic software written by
         Eric Young (eay@cryptsoft.com)"
         The word 'cryptographic' can be left out if the rouines from the library
         being used are not cryptographic related :-).
      4. If you include any Windows specific code (or a derivative thereof) from
         the apps directory (application code) you must include an acknowledgement:
         "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

      THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND
      ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
      IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
      ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
      FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
      DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
      OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
      HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
      LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
      OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
      SUCH DAMAGE.
    
------------------------------------------------------------

This product includes Qt.

      The software uses Qt, licensed under LGPL v3. The Qt Toolkit is Copyright (C) 2019
 The Qt Company Ltd.

      Portions of this software are copyright (C) 2006-2015 The FreeType Project
 (www.freetype.org). All rights reserved.
      
      Copyright (C) 1991-2011, Thomas G. Lane, Guido Vollbeding.
      This software is based in part on the work of the Independent JPEG Group.
      
      Secure Hash Algorithm SHA-3 - brg_endian
      Copyright (c) 1998-2013, Brian Gladman, Worcester, UK. All rights reserved.

      LICENSE TERMS

      The redistribution and use of this software (with or without changes)
      is allowed without the payment of fees or royalties provided that:

       1. source code distributions include the above copyright notice, this
          list of conditions and the following disclaimer;

       2. binary distributions include the above copyright notice, this list
          of conditions and the following disclaimer in their documentation;

       3. the name of the copyright holder is not used to endorse products
          built using this software without specific written permission.

      DISCLAIMER

      This software is provided 'as is' with no explicit or implied warranties
      in respect of its properties, including, but not limited to, correctness
      and/or fitness for purpose.
    
------------------------------------------------------------

This product includes QtSingleApplication.

        Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
        Contact: http://www.qt-project.org/legal

        This file is part of the Qt Solutions component.

        You may use this file under the terms of the BSD license as follows:

        Redistribution and use in source and binary forms, with or without
        modification, are permitted provided that the following conditions are
        met:
          * Redistributions of source code must retain the above copyright
            notice, this list of conditions and the following disclaimer.
          * Redistributions in binary form must reproduce the above copyright
            notice, this list of conditions and the following disclaimer in
            the documentation and/or other materials provided with the
            distribution.
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          * Neither the name of Digia Plc and its Subsidiary(-ies) nor the names
            of its contributors may be used to endorse or promote products derived
            from this software without specific prior written permission.

        THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
        "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
        LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
        A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
        OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
        SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
        LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
        DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
        THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
        (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
        OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

    
------------------------------------------------------------

This product includes LibTIFF.

      Copyright (c) 1988-1997 Sam Leffler
      Copyright (c) 1991-1997 Silicon Graphics, Inc.

      Permission to use, copy, modify, distribute, and sell this software and
      its documentation for any purpose is hereby granted without fee, provided
      that (i) the above copyright notices and this permission notice appear in
      all copies of the software and related documentation, and (ii) the names of
      Sam Leffler and Silicon Graphics may not be used in any advertising or
      publicity relating to the software without the specific, prior written
      permission of Sam Leffler and Silicon Graphics.

      THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,
      EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
      WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

      IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR
      ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND,
      OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
      WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF
      LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
      OF THIS SOFTWARE.
    
------------------------------------------------------------

This product includes XercesC.

    NOTICE file corresponding to section 4(d) of the Apache License, Version 2.0, in this
 case for the Apache Xerces distribution.

    This product includes software developed by
    The Apache Software Foundation (http://www.apache.org/).

    Portions of this software were originally based on the following:
     - software copyright (c) 1999, IBM Corporation., http://www.ibm.com.
    
------------------------------------------------------------

This product includes XMP Toolkit.
Copyright (c) 2020, Adobe
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this
   list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice,
   this list of conditions and the following disclaimer in the documentation
   and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of its
   contributors may be used to endorse or promote products derived from
   this software without specific prior written permission.
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THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
------------------------------------------------------------

This product includes zlib.

(C) 1995-2013 Jean-loup Gailly and Mark Adler

This software is provided 'as-is', without any express or implied
warranty. In no event will the authors be held liable for any damages
arising from the use of this software.

Permission is granted to anyone to use this software for any purpose,
including commercial applications, and to alter it and redistribute it
freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not
   claim that you wrote the original software. If you use this software
   in a product, an acknowledgment in the product documentation would be
   appreciated but is not required.

2. Altered source versions must be plainly marked as such, and must not be
   misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.
    
------------------------------------------------------------

This product includes ZXing C++ Library.

    Copyright 2016 ZXing authors.
    https://github.com/zxing
    
------------------------------------------------------------
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2.  In This Manual
Welcome to ArtiosCAD!

In this manual are instructions for:

• Installing and configuring ArtiosCAD Standard Edition

• Installing and configuring ArtiosCAD Enterprise (the ArtiosCAD side of it, not the WebCenter side
except for things essential to using ArtiosCAD )

• Using ArtiosCAD

• Using ArtiosCAD Enterprise

Some of the information is specific for one edition of ArtiosCAD. For example, there are Defaults
described in Installing and Configuring ArtiosCAD Enterprise that only exist in ArtiosCAD Enterprise.
Likewise, the program DataCenter Admin described in DataCenter is only for use by people using
ArtiosCAD Standard Edition.
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3.  Standard Edition Welcome

Introduction

The first six chapters of this book describe how to load ArtiosCAD (both editions) and its related
components, both as a new installation and as an upgrade to a previous version, as well as how to add
input and output devices and perform other configuration tasks.

Please note there are differences between ArtiosCAD Standard Edition and ArtiosCAD Enterprise.
Chapter titles are a good place to start when determining which information applies to which edition. If
there is no edition name, the chapter applies to both editions.

For the latest information on system requirements, please go to the Esko website and search for
system requirements.

The remaining chapters describe how to use ArtiosCAD (both editions) once you have installed and
configured it.

Before you begin

Before trying to install ArtiosCAD Standard Edition, you should make sure that you know how to:

• view file and directory information with Windows Explorer

• make network connections and create network shares

• use a text editor such as Notepad

If you are going to use the included database product, find out from your IT department what the
password policy is, as you will need to know it to set the database user passwords.

Make sure the network is up and running correctly so that you can see network resources from all
machines. To install ArtiosCAD, you must be able to log in using an account that is a member of the
local Administrators group.

ArtiosCAD will work immediately after being installed, but you will most likely want to set up some
output devices as described in the Peripherals chapter.

If you have any questions, please do not hesitate to contact your local Support oce for help.

If you will be using ArtiosCAD in a language other than American English, make sure your operating
system’s regional settings are set to match those of the United States. Specifically, for numbers,
the decimal symbol needs to be a period, the decimal grouping symbol a comma, the list separator a
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comma. For currency, the decimal symbol needs to be a period and the digit grouping symbol a comma.
Unpredictable results might occur if these settings are not made.

If you need help

If you need help while installing ArtiosCAD, click the Answers to Common Questions link on the main
page of the installer. It will bring you to a Web page of frequently asked questions and their answers.
There are separate versions of the page for ArtiosCAD Standard Edition and ArtiosCAD Enterprise.

Media contents

The ArtiosCAD media contains:

• The installation program

• Release notes - an overview of changes and enhancements and a list by number of bug fixes

• ArtiosCAD Viewer - a program you can give your vendors and customers. It is a stripped down
version of ArtiosCAD which allows the user to view and print any ArtiosCAD design or 3D file.
Viewer users can directly measure the structure, preview a 3D file with or without graphics from
different angles, and fold and unfold it. Viewer is also available for downloading for free from the
Esko website (http://www.esko.com) and can be loaded on any system which supports ArtiosCAD.

Important folders, libraries, and files of ArtiosCAD Standard Edition

There are several folders that are set up under the \Esko\Artios folder on the drive chosen for the
installation of ArtiosCAD Standard Edition. One is the folder that contains the ArtiosCAD version that
was installed. Others hold database, license, or other related information.

Folders underneath the version of ArtiosCAD
Three library folders have unique and important functions in the configuration and running of
ArtiosCAD. They are: InstLib, ServerLib and ClientLib. ServerLib and ClientLib are in ..\Esko
\Artios, but InstLib is in the installation directory for ArtiosCAD as it is version-specific.

IF you have a 64-bit version installed, those files live in folders with 64 appended to their names, such
as Prrogram64.

InstLib:

• InstLib contains default files shipped with the software. It is important to not change these files for
a number of reasons. NEVER save modified files in InstLib.

• Reloading (upgrade mode) the current revision from media will overwrite any changes made to files
in InstLib.

• Some of the files in InstLib (sysdflt.zip and its associated files) are used as reference files when
doing an ArtiosCAD version upgrade. These files are checked against the user-modified versions in
ServerLib to determine what and how to move modified information to the new version.
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• It is useful to have a clean set of files to work from. If a file in ServerLib gets corrupted for some
reason, you can recover a clean copy without having to reload ArtiosCAD. (The better solution is to
make regular system backups!)

• There is a searchlist set up for ArtiosCAD which looks at these directories in the order ClientLib,
ServerLib, InstLib. Files that are duplicated in ServerLib, for example, will be used in preference to
those in InstLib. Duplicate files in ClientLib will be found in preference to files in both ServerLib and
InstLib.

• The Symbol sub-folder contains samples of common corrugated symbols such as fragile.ard,
recycle.ard, thiswayup.ard.

ServerLib:

• ServerLib contains configurations that have been modified from their initial defaults, standards,
logos and other files (other than user data files) that need to be shared by all of the ArtiosCAD seats
on the site network.

• When Shared Defaults are modified, the changes are saved to ServerLib in a file called sysdflt.zip
(and files that this references).

• New (additional) files that are to be shared by all of the ArtiosCAD seats on the site network should
be placed in ServerLib. For example, reports that need to be used by all of the ArtiosCAD seats
on the site network should be placed here. A copy of the report should be placed in ServerLib and
added to the Reports Catalog in Shared Defaults.

ClientLib:

• This directory stores the defaults created in Options > Defaults > User Defaults in a file called
clientdflt.zip. The defaults and files saved to the ClientLib directory are only available to the
particular workstation on which they were created. It is not intended that they be shared on the
network. These defaults are merged with the Shared Defaults. Client defaults take precedence over
Shared Defaults.

• ClientLib is used for local machine defaults only. It is used only if you wish to limit the function or
change to ONE computer. For example, the most common usage is to provide Outputs to equipment
like a Laser or a Counter Cutter to the computer system that is located in the room where this
equipment resides. If the whole design and estimating departments work on the outside of the
box, but the die room wishes to view the layouts Die-side, they might set up a User Default so that
layouts are opened Die-side.

• If you are working on a live system and are trying to build new defaults, create them as User
Defaults. Once happy with the results, copy the results into Shared Defaults and delete the User
Defaults.

LpLib and DwbLib:

• Contain files that are needed for the support of Standards written using LASERPOINT IQ or The
Designer WorkBench. The standards shipped with these systems are also included. These are
loaded during the installation of ArtiosCAD.

Program:

• This is where the executable programs are stored.

Common:
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• On License Server machines, contains and shares the license files for all seats. The license
file is stored in this \Esko\Artios\Common folder. If License Manager is not being used, this
directory contains the file that controls what features are available in ArtiosCAD. This file is called
TUNEOPT.TXT or TUNEOPT7.TXT

• This directory also contains some additional programs in the Program folder that are not ArtiosCAD
version-dependent.

• In addition, this directory contains the default board texture pictures.

DataCenter:

• This is the database folder.

• The English (or language folder) is a sub-folder of the DataCenter program folder. It contains several
important files such as database export and import programs and databaseID.exe.

User Data Files:

• These can be shared, distributed or stored locally at each workstation.

• A DataCenter resource is automatically created for the User Data File destination chosen during
installation. So, for example, if each client chooses a local destination folder during installation, a
resource will be created for each directory in the Resource Browser of DataCenter Admin.

• In new installations, the \Esko\Artios\Designs folder is created as the default folder for user files.
The destination folder selected here is a master resource in DataCenter Admin. If users add sub-
folders underneath this folder after the installation, they automatically become DataCenter Admin
resources the first time files are saved in them.

• If directories are added to other locations, they need to be manually added to DataCenter as
resources. Files saved to these directories will not be recorded in the database unless the
directories are resources.
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4.  ArtiosCAD Standard Edition Installation

Introduction

There are four types of installations: Typical, Client, Server/Custom, and Silent. Each can be used as a
new installation or as an upgrade from a previous version of ArtiosCAD.

A Typical installation:

• Installs ArtiosCAD as a standalone installation, meaning it is self-contained
• Installs Microsoft SQL Server Express Edition as the database, along with Microsoft SQL Server

Management Studio. YOU MUST HAVE AN INTERNET CONNECTION FOR THIS AND BE USING 64-BIT
MICROSOFT WINDOWS 10 OR LATER.

• Allows you to set the program installation folder
• If an upgrade, prompts you to copy a previous configuration or use the default configuration.

A Client installation:

• Installs as a client of another system, meaning it uses another system for the database, licensing,
and Defaults.

• If a new installation, asks what the database type will be
• Asks for the names of the Defaults and database servers
• Tests the connection to the Defaults server.

A Server/Custom installation:

• Installs as a client, server, or as a distributed server, meaning it uses different machines for
different functions

• If a new installation, asks if the system will host the database, and if yes, asks if you want to install
Microsoft SQL Server Express Edition 64-bit as the database along with Microsoft SQL Server
Management Studio. YOU MUST HAVE AN INTERNET CONNECTION FOR THIS.

• Shares the Artios folder for use by other systems.
• Is the only way to set the features to be installed, the database type, the SQL authentication

method, and the user files folder.

A Silent installation presents no dialog boxes, and all options must be specified on the command
line. This is meant for use only in large corporate WAN environments where one central administrator
installs ArtiosCAD on other computers to which the administrator has remote command access. The
silent installation program must be run on the computer on which ArtiosCAD will be used. The silent
installation program may not be run on one machine resulting in ArtiosCAD being installed on another
machine. Contact Support for more information on performing a Silent installation.

If you are installing a 64-bit version, its shortcuts have 64 appended to their names. Any 32-bit
shortcuts remain until you uninstall the last 32-bit version using them.

Note:  Keep the original ArtiosCAD media in a safe, easily accessible place in case you need to
modify or repair the installation. You must use the same media or network location to repair or
modify ArtiosCAD as when you first installed the software.
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Performing a Typical installation

Note:  If you receive a message about overwriting read-only files, answer yes to overwrite
them. Also, if you receive a message about a control failing to register, proceed normally and
reboot when the installation finishes.

Note:  If you downloaded ArtiosCAD from mysoftware.esko.com, burn the disc image to a DVD.
Store the DVD in a safe place.

Note:  If you are going to use the included database product, find out from your IT
department what the password policy is, as you will need to know it to set the database user
passwords.

To perform a typical ArtiosCAD installation, do the following:

1. Log on as Administrator, or as a user with administrative privileges.
2. Ensure that this system meets the minimum system requirements as published on Esko's website

(search for system requirements).
3. Run the setup program.

• If you are installing from a DVD, put the ArtiosCAD media into the computer’s media drive.
It should automatically launch the Setup program. If your drive is set to not AutoPlay, start
Windows Explorer and double-click setup.exe in the root directory of the media.

• If you have downloaded the media from mysoftware.esko.com, find the ISO file in Windows
Explorer, right-click it and mount it, and then right-click the setup.exe in the mounted drive
and click Run as administrator.

4. If you have User Account Control enabled, allow setup.exe to run.
5. The ArtiosCAD Setup dialog box appears.
6. Choose the language in which to run the setup program and install ArtiosCAD in using the Change

Language drop-down. It should automatically match the language of your system but you may
change it if desired. The setup program language will change to the language you selected.

7. Click Typical Installation.
8. Depending on your system configuration prior to loading ArtiosCAD, the setup program may install

required operating system updates. If the system prompts you to reboot, do so; the installation
program will resume automatically when you log in after the system comes up again. Do not
postpone rebooting if the system requests it.

9. The setup program prompts you to enter passwords for the sa and programmer database users.
Choose passwords that comply with your IT security policy. The setup program cannot validate the
passwords beforehand so make sure you know what the policy is. The setup program will inform
you if the passwords you chose did not work and prompt you to choose new ones. Enter compliant
passwords in the Password and Confirm Password fields, record them in a secure place, and click
OK.

10. The installer starts installing Microsoft SQL Server Express Edition and then Microsoft SQL
Server Management Studio. This will take a few minutes. If you chose a non-English version of the
program, the setup program asks if you'd like to download and install a language-specific version of
the database engine; click Yes.
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Note:  This installs Microsoft SQL Server Express Edition, 64-bit with an instance named
ESKO and programmer and sa account passwords of your own choosing. Make sure to
record these passwords in a secure location as you will need them in the future. The
database installer will also install any needed updates, and it may prompt you to reboot.
If you do have to reboot, the installation process should continue automatically when you
log in again. Several dialog boxes will appear on the screen during the installation but they
will disappear automatically. Once the database is installed, proceed with the steps of the
installation as outlined below. The setup process will automatically configure the database
connection.

• YOU MUST HAVE AN INTERNET CONNECTION TO INSTALL THIS AND BE USING 64-BIT
MICROSOFT WINDOWS 10 OR LATER.

• YOU MAY ONLY USE THE LANGUAGE OF YOUR OPERATING SYSTEM OR ENGLISH.

• YOU MUST HAVE .NET FRAMEWORK 3.5 OR 3.5.1 INSTALLED IN ADDITION TO .NET
FRAMEWORK 4. For Windows 7 and later, this is normally installed by Windows Update,
but for Windows Server operating systems, it is a feature that must be installed.

11. The ArtiosCAD installer begins. Click Next in the Welcome dialog box.
12. Read the End User License Agreement in its entirety and choose I accept the terms in the license

agreement if you accept all the terms of the License Agreement. Click Next.
13. In the Destination Folder dialog box, choose the folder where ArtiosCAD will be installed. Click

Change to change the folder, but be mindful that ArtiosCAD should always be installed to the \Esko
\Artios folder on a local drive. Click Next.

14. Review the summary of installation settings. If they are correct, click Install to start installing files.
If not, click Back to go back and change settings.

15. A progress indicator shows the status of the copying process.
16. The Esko Station Information Service will be installed automatically. This service collects

information about your hardware, software, and Esko licenses. If the ArtiosCAD Configuration
Manager service is installed on a machine on your network, it will forward the information collected
to ArtiosCAD for use by Support personnel if you configure it to do so. Several dialog boxes will
appear displaying information; you do not need to click anything as they will automatically continue.

17. In the InstallShield Wizard Completed dialog box, click Finish.
18. The ArtiosCAD Setup program might prompt for a system reboot. Click Yes to reboot the system.

Once the system comes back up, ArtiosCAD and DataCenter Admin will be fully functional.
19. If you are using a network license, click Install License Server Components in the main ArtiosCAD

Setup dialog box, which will install the license server and activate the license file you supply. For
more information on license management, refer to the licensing documents available at http://
www.esko.com/support.

20.You are now ready to configure ArtiosCAD. You will enter the licensing information for ArtiosCAD
the first time you start it.
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Performing a Client Installation

Note:  If you downloaded ArtiosCAD from mysoftware.esko.com, burn the disc image to a DVD.
Store the DVD in a safe place.

To perform a client installation, do the following:

1. Log on as Administrator, or as a user with administrative privileges.
2. Ensure that this system meets the minimum system requirements as published on Esko's website

(search for system requirements).
3. Run the setup program.

a) If you are installing from a DVD, put the ArtiosCAD media into the computer’s media drive.
It should automatically launch the Setup program. If your drive is set to not AutoPlay, start
Windows Explorer and double-click setup.exe in the root directory of the media.

b) If you have downloaded the media from mysoftware.esko.com, find the ISO file in Windows
Explorer, right-click it and mount it, and then right-click the setup.exe in the mounted drive
and click Run as administrator.

4. If you have User Account Control enabled, allow setup.exe to run.

5. The ArtiosCAD Setup dialog box appears.
6. Choose the language in which to run the setup program and install ArtiosCAD in using the Change

Language drop-down. It should automatically match the language of your system but you may
change it if desired. The setup program language will change to the language you selected.

7. Click Client Installation.
8. Depending on your system configuration prior to loading ArtiosCAD, the setup program may install

required operating system updates. If the system prompts you to reboot, do so; the installation
program will resume automatically when you log in after the system comes up again. Do not
postpone rebooting if the system requests it.

9. The ArtiosCAD installer begins. Click Next in the Welcome dialog box.
10. Read the End User License Agreement in its entirety and choose I accept the terms in the license

agreement if you accept all the terms of the License Agreement. Click Next.
11. In the Destination Folder dialog box, choose the folder where ArtiosCAD will be installed. Click

Change to change the folder, but be mindful that ArtiosCAD should always be installed to the \Esko
\Artios folder on a local drive. Click Next.

12. In the Database Program Selection dialog box, choose the database program for ArtiosCAD to use.
This sets the type of connection to the database server. If client software is required to connect to
the database (such as an Oracle client), you must install and configure it separately. Click Next.

13. In the Server Information dialog box, enter the names of the systems acting as the Defaults server
and Database Server. If the Database Server field is unavailable, the database server must be
configured manually via the ArtiosCAD entry in the ODBC control panel. You can enter the same
system name in all the fields, or you can specify a different system in each field. If you enter remote
system names, and those remote systems do not have ArtiosCAD loaded on them, you will have
to manually enter the exact path to the applicable resources. ArtiosCAD must be loaded on the
server you indicated on these remote systems for ArtiosCAD to work on the current system! It
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does not have to be loaded at the time of the current system installation, but should be loaded soon
afterward. Click Next.

14. Review the summary of installation settings. If they are correct, click Install to start installing files.
If not, click Back to go back and change settings.

15. A progress indicator shows the status of the copying process.
16. If there is no other Esko software on this system, the Esko Station Information Service will be

installed automatically. This service collects information about your hardware, software, and Esko
licenses. If the Esko Configuration Manager service is installed on a machine on your network, it will
forward the information collected to Esko for use by Support personnel if you configure it to do so.
Several dialog boxes will appear displaying information; you do not need to click anything as they
will automatically continue.

17. In the InstallShield Wizard Completed dialog box, if you are using a local license, click Activate
Local Licenses to begin activating your license so that you can start using ArtiosCAD. For
more information on license management, refer to the licensing documents available at http://
www.esko.com/support. When your local license activation is complete, or If you are using a
network license, click Finish.

You are now ready to start using ArtiosCAD. You will enter the licensing information for ArtiosCAD the
first time you start it.

Performing a Server/Custom Installation

Note:

If you downloaded ArtiosCAD from mysoftware.esko.com, burn the disc image to a DVD. Store
the DVD in a safe place.

If you are going to use the included database product, find out from your IT department what
the password policy is, as you will need to know it to set the database user passwords.

To perform a Server/Custom installation, do the following:

1. Log on as Administrator, or as a user with administrative privileges.
2. Ensure that this system meets the minimum system requirements as published on Esko's website

(search for system requirements).
3. Run the setup program.

a) If you are installing from a DVD, put the ArtiosCAD media into the computer’s media drive.
It should automatically launch the Setup program. If your drive is set to not AutoPlay, start
Windows Explorer and double-click setup.exe in the root directory of the media.

b) If you have downloaded the media from mysoftware.esko.com, find the ISO file in Windows
Explorer, right-click it and mount it, and then right-click the setup.exe in the mounted drive
and click Run as administrator.

4. If you have User Account Control enabled, allow setup.exe to run.

5. The ArtiosCAD Setup dialog box appears.
6. Choose the language in which to run the setup program and install ArtiosCAD in using the Change

Language drop-down. It should automatically match the language of your system but you may
change it if desired. The setup program language will change to the language you selected.
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7. Click Server/Custom Installation.
8. The setup program asks if this system will host the ArtiosCAD database. Click Yes if it will or No if

you have a dedicated database server.
9. If you clicked Yes in the previous step, the setup program asks if you would like to install the free

bundled database, Microsoft SQL Server Express Edition, 64-bit. If you want to use this database:
a) YOU MUST HAVE AN INTERNET CONNECTION TO INSTALL THIS AND BE USING 64-BIT

MICROSOFT WINDOWS 10 OR LATER
b) YOU MAY ONLY USE THE LANGUAGE OF YOUR OPERATING SYSTEM OR ENGLISH
c) YOU MUST HAVE .NET FRAMEWORK 3.5 OR 3.5.1 INSTALLED IN ADDITION TO .NET

FRAMEWORK 4. For Windows 7 and later, this is normally installed by Windows Update, but for
Windows Server operating systems, it is a feature that must be installed.

Clicking Yes will install Microsoft SQL Server Express Edition, 64-bit with an instance named ESKO
and sa account password of your own choosing, along with Microsoft SQL Server Management
Studio. If you chose a non-English version of the program, the setup program asks if you'd like
to download and install a language-specific version of the database engine; click Yes. The setup
program prompts you to enter passwords for the sa and programmer database users. Choose
passwords that comply with your IT security policy. The setup program cannot validate the
passwords beforehand so make sure you know what the policy is. The setup program will inform
you if the passwords you chose did not work and prompt you to choose new ones. Enter compliant
passwords in the Password and Confirm Password fields, record them in a secure place, and click
OK. The database installer will also install any needed updates, and it may prompt you to reboot.
If you do have to reboot, the installation process should continue automatically when you log in
again. Several dialog boxes will appear on the screen during the installation but they will disappear
automatically. Once the database is installed, proceed with the steps of the installation as outlined
below. The setup process will automatically configure the database connection. If you will be
using a full version of Microsoft SQL Server or Oracle, click No and proceed with the steps of the
installation as outlined below. You will configure the database connection after installation.

10. Depending on your system configuration prior to loading ArtiosCAD, the setup program may install
required operating system updates. If the system prompts you to reboot, do so; the installation
program will resume automatically when you log in after the system comes up again. Do not
postpone rebooting if the system requests it.

11. The ArtiosCAD installer begins. Click Next in the Welcome dialog box.
12. Read the End User License Agreement in its entirety and choose I accept the terms in the license

agreement if you accept all the terms of the License Agreement. Click Next.
13. In the Setup Type dialog box, choose the type of system this will be according to the choice

descriptions.
a) Client performs a client installation just as if you had clicked Client Installation in the main

installer.
b) Server performs an installation as if you had clicked Typical Installation in the main installer,

except that it also shares the Artios folder for use by other systems.
c) Advanced performs an installation with all configuration options available. It Is the only way to

set the features to be installed, the database type, the SQL authentication method, and the user
files folder.

Going forward, these instructions will assume you chose Advanced. If you made another choice,
follow the instructions in those sections.
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14. In the Feature Selection dialog box, choose the features to install on the current machine. For each
feature, click the icon in the drop-down list box next to it and choose the appropriate choice. Do not
click Next when done, but rather proceed to the next numbered step.
a) ArtiosCAD Configuration. Click the plus sign (+) next to this entry to open it. ArtiosCAD

Licensing, ArtiosCAD Defaults, and ArtiosCAD Database can each be installed in any
combination on a machine. For Typical and all Standalone installations, leave them all selected.

b) ArtiosCAD Programs. ArtiosCAD Programs are the program files needed to run ArtiosCAD. You
must install these if you want to run ArtiosCAD on the current machine. Not installing these
would create a server-only installation provided the servers were selected for installation. You
must leave this choice selected to install ArtiosCAD itself.

c) The ArtiosCAD Programs group controls whether or not ArtiosCAD itself is installed. Optional
components of ArtiosCAD that require purchasing a license for the corresponding modules
are contained as subfeatures in the group. At this time, only ArtiosCAD 3D Data Exchange is
a selection. Refer to the license report from Esko to determine which components to select.
Installing software components without having the corresponding licenses wastes disc space.
Not installing the software components but having the licenses for them results in features that
do not function within ArtiosCAD.

d) Esko Configuration Manager collects data from systems running the Esko Station Information
Service and sends the collected data to Esko automatically for use by Support personnel. It
sends information only if you configure it to do so and leave it enabled. It is a great aid to
Support personnel as they will have required information about your hardware and licenses
available should you need to call for assistance. Only one system per site should have the Esko
Configuration Manager installed.

15. While still in the Feature Selection dialog box, with one of the components to be installed selected,
review the folder in which ArtiosCAD will be installed, and click Change if desired. In the resulting
Change Current Destination Folder dialog box, change the drive if desired, and click OK to return to
the Feature Selection dialog box. ArtiosCAD should always be installed to the \Esko\Artios folder
on a local drive. Click Next.

16. Choose the database program for ArtiosCAD to use. The default and recommended choice is SQL
Server Express Edition, a free desktop database from Microsoft that requires a 64-bit operating
system. If this is a new installation, you must have already installed it to use this choice. MSDE is
an older free desktop database from Microsoft that does not require a 64-bit operating system but
that offers less robust performance. Choosing Microsoft SQL Server or Oracle is appropriate for
workgroup or enterprise use where those databases are already in use. Click Next.

17. In the Server Information dialog box, enter the names of the systems acting as the Defaults server
and Database Server. If the Database Server field is unavailable, the database server must be
configured manually via the ArtiosCAD entry in the ODBC control panel. You can enter the same
system name in all the fields, or you can specify a different system in each field. If you enter remote
system names, and those remote systems do not have ArtiosCAD loaded on them, you will have
to manually enter the exact path to the applicable resources. ArtiosCAD must be loaded on the
server you indicated on these remote systems for ArtiosCAD to work on the current system! It
does not have to be loaded at the time of the current system installation, but should be loaded soon
afterward. Click Next.
If you choose Microsoft SQL Server or Oracle, configuration scripts and a batch file for those
databases will be placed in the \Esko\Artios\DataCenter directory. The database
administrator MUST run the appropriate batch file before using ArtiosCAD or ArtiosCAD Enterprise.
Other post-installation tasks must be performed as well.
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18. The default location for the storage of user files is shown in the User Files Folder dialog box. To
change it, click Change; to accept it, click Next. If you change the location to another system, use a
UNC locator (e. g. \\system2\designs) instead of a mapped drive letter.

19. In the Advanced Options dialog box:
a) Keep Previous Versions is the default for previous version handling. It means that ArtiosCAD

is installed using a version-specific folder and icon which match the version of the installation,
and all previous versions of ArtiosCAD are kept. All previous installations of language-specific
versions will have their Defaults merged into the multilingual version being installed. To change
this setting, click Change. In the Previous Version Handling dialog box, Overwrite previous
versions simply uses ArtiosCAD as the icon name and ArtiosCAD as the directory with no version
number. Once you have chosen the option to use, click OK to return to the Advanced Options
dialog box.

b) If you are using SQL Server Express Edition or Microsoft SQL Server as the database, you have
the choice of database authentication methods. SQL Server Authentication requires each
user to have a login created within the database; by default, ArtiosCAD uses one database user
(programmer) for all ArtiosCAD users. However, your company may have different requirements.
Windows Authentication passes operating system login credentials to the database. You should
use Windows Authentication only if you have a dedicated database administrator who can
perform user maintenance tasks.

c) Enter the SA user password you specified earlier in the SA Password field.
d) Click Next.

20.Review the summary of installation settings. If they are correct, click Install to start installing files.
If not, click Back to go back and change settings.

21. A progress indicator shows the status of the copying process. Click OK if told that the Artios
directory has been shared. Everyone has read-only access to this share; members of the local
Administrators group have read/write access.

22.If there is no other Esko software on this system, the Esko Station Information Service will be
installed automatically. This service collects information about your hardware, software, and Esko
licenses. If the Esko Configuration Manager service is installed on a machine on your network, it will
forward the information collected to Esko for use by Support personnel if you configure it to do so.
Several dialog boxes will appear displaying information; you do not need to click anything as they
will automatically continue.

23.In the InstallShield Wizard Completed dialog box, click Finish.
24.The ArtiosCAD Setup program might prompt for a system reboot. Click Yes to reboot the system.

Once the system comes back up, ArtiosCAD and ArtiosCAD will be fully functional
25.If you installed a non-English version of ArtiosCAD, run \Esko\Artios\DataCenter\program

\<language>\dbtranslate.exe to translate phrases in the database.
26.If you are using a network license, click Install License Server Components in the main ArtiosCAD

Setup dialog box, which will install the license server and activate the license file you supply. For
more information on license management, refer to the licensing documents available at http://
help.esko.com.

27. You are now ready to configure ArtiosCAD. You will enter the licensing information for ArtiosCAD
the first time you start it.
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Installing a New Version of ArtiosCAD

This procedure is to install a newer major version of ArtiosCAD, not to update your current version with
a new build.

Note:  If you are going from a pre-16 version to 16 or greater, note that the new version of
ArtiosCAD will have language- and version-agnostic Defaults. This means that there will only
be one set of Defaults for all languages and versions of ArtiosCAD version 16 and newer. Older
versions of ArtiosCAD on this computer will continue to use their own Defaults.

To install a newer version of ArtiosCAD, do the following:

1. Log on as Administrator, or as a user with administrative privileges.
2. Ensure that this system meets the minimum system requirements as published on Esko's website

(search for system requirements).
3. Run the setup program.

a) If you are installing from a DVD, put the ArtiosCAD media into the computer’s media drive.
It should automatically launch the Setup program. If your drive is set to not AutoPlay, start
Windows Explorer and double-click setup.exe in the root directory of the media.

b) If you have downloaded the media from mysoftware.esko.com, find the ISO file in Windows
Explorer, right-click it and mount it, and then right-click the setup.exe in the mounted drive
and click Run as administrator.

4. If you have User Account Control enabled, allow setup.exe to run.

5. The ArtiosCAD Setup dialog box appears.
6. Based on your current installation, choose the type of installation to perform, Typical, Client, or

Server/Custom.
7. Click Next in the Welcome to the InstallShield Wizard for ArtiosCADX.xx dialog box.
8. Read the End User License Agreement in its entirety and choose I accept the terms in the license

agreement if you accept all the terms of the License Agreement. Click Next.
9. In the Configuration Source dialog box, choose to copy the Defaults from a previous version and

then click the previous version whose Defaults you want to use, or choose to use the default
configuration which will install a completely unmodified set of Defaults. You should copy the
previous configuration if you customized ArtiosCAD in any way, such as adding Output devices and
making your own Reports. If the previous version had different languages available, choose from
which language to copy Defaults in the Copy configuration from this language drop-down list box;
you may only upgrade from one language. Click Next.

10. Review the settings listed in the Ready to Install the Program dialog box. If they are correct, click
Install to start copying files. If not, click Back to go back and change settings.

11. A progress indicator will show the status of the copying process. Click OK if told that the Artios
directory has been shared.

12. In the InstallShield Wizard Completed dialog box, click Finish. You will enter the licensing
information for ArtiosCAD the first time you start it.

If you are using a network license and received a new license, activate it by using the Network Licenses
Manager in the Esko folder of the Start menu. For more information on license management, refer to
the licensing documents available at http://www.esko.com/support.
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Installing a New Build of the Current Version

This procedure is to install a new build of your current version of ArtiosCAD.

To install a new build of ArtiosCAD, do the following:

1. If this is a server installation, make sure nobody is using ArtiosCAD.
2. Log on as Administrator, or as a user with administrative privileges.
3. Ensure that this system meets the minimum system requirements as published on Esko's website

(search for system requirements).
4. Run the setup program.

a) If you are installing from a DVD, put the ArtiosCAD media into the computer’s media drive.
It should automatically launch the Setup program. If your drive is set to not AutoPlay, start
Windows Explorer and double-click setup.exe in the root directory of the media.

b) If you have downloaded the media from mysoftware.esko.com, find the ISO file in Windows
Explorer, right-click it and mount it, and then right-click the setup.exe in the mounted drive
and click Run as administrator.

5. If you have User Account Control enabled, allow setup.exe to run.

6. The ArtiosCAD Setup dialog box appears.
7. Click Update ArtiosCAD Installation.
8. Click Yes when told this will upgrade ArtiosCAD and to continue.
9. Click Next in the Resuming the InstallShield Wizard dialog box.
10. A progress indicator shows the status of the copying process.
11. In the InstallShield Wizard Completed dialog box, click Finish.
12. ArtiosCAD is now updated and ready for use.

Installing Microsoft SQL Server Express Edition Only

To create a database server for ArtiosCAD based on Microsoft SQL Server Express Edition without
having to install ArtiosCAD, do the following on a machine that has never had ArtiosCAD on it:

1. Log on as Administrator, or as a user with administrative privileges. Keep these prerequisites in
mind:
a) YOU MUST HAVE AN INTERNET CONNECTION TO INSTALL THIS AND BE USING A 64-BIT

VERSION OF MICROSOFT WINDOWS 10 OR NEWER.
b) YOU MAY ONLY USE THE LANGUAGE OF YOUR OPERATING SYSTEM OR ENGLISH
c) YOU MUST HAVE .NET FRAMEWORK 3.5 OR 3.5.1 INSTALLED IN ADDITION TO .NET

FRAMEWORK 4. This is normally installed by Windows Update, but for Windows Server operating
systems, it is a feature that must be installed.

2. Ensure that this system meets the minimum system requirements as published on Esko's website
(search for system requirements).
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3. Put the ArtiosCAD media into the computer’s media drive. It should automatically launch the Setup
program. If your drive is set to not AutoPlay, start Windows Explorer and double-click setup.exe in
the root directory of the media.

4. If you have User Account Control enabled, allow setup.exe to run.

5. The ArtiosCAD Setup dialog box appears.
6. Click Install Microsoft SQL Server <version> Express. The installer will start.
7. The setup program prompts you to enter passwords for the sa and programmer database users,

but it uses only the sa password. The programmer password is specified manually when you run the
database schema batch file. Choose an sa password that complies with your IT security policy. The
setup program cannot validate the password beforehand so make sure you know what the policy is.
The setup program will inform you if the password you chose did not work and prompt you to choose
a new one. Enter a compliant password in the Password and Confirm Password fields, record it in a
secure place, and click OK.
This installs Microsoft SQL Server <version> Express Edition, 64-bit with an instance named ESKO
and an sa account password of your own choosing. Make sure to record this password in a secure
location as you will need it in the future. The database installer will also install any needed updates
and Microsoft SQL Server Management Studio, and it may prompt you to reboot. If you do have to
reboot, the installation process should continue automatically when you log in again. Several dialog
boxes will appear on the screen during the installation but they will disappear automatically.

8. Run \Windows\SysWOW64\odbcad32.exe.
9. In the ODBC Data Source Administrator, click System DSN and click Add.
10. Select SQL Server from the list of available drivers and click Finish.
11. In the Create a New Data Source to SQL Server dialog box, enter ArtiosCAD in the Name and

Description fields and select the server and instance name in the Server drop-down list box. It
should be Name of this machine\ESKO. Click Next.

12. When asked about authenticity, select the With SQL Server authentication... choice. For the
Connect to SQL Server... checkbox, enter sa as the Login ID and the password you specified earlier
for the sa user. Do not click Next.

13. Click Client Configuration. The Add Network Library Configuration dialog box appears.
a) Make sure TCP/IP is selected in the Network libraries group and ensure the server name is

correct. If (local) was selected in the Which SQL Server do you want to connect to? field in Step
11, only a period (.) appears in the Server alias field and Server name field.

b) Ensure that Dynamically determine port is checked and that the Port number is set to 1433.
Click OK.

c) Click Next in the Create a New Data Source to SQL Server dialog box.
14. In the next dialog box, leave the Create temporary stored procedures... and Use ANSI... choices

selected and click Next.
15. In the next dialog box, leave Perform translation for character data selected. If the system is using

non-U.S. locale settings, check the Change the language of SQL Server system messages to:
checkbox and set the value to English. Click Finish.

16. The ODBC Microsoft SQL Server Setup dialog box will appear showing a summary of the
configuration. Click Test Data Source; it should succeed. Click OK, and then click OK again.

17. Click OK in the ODBC Data Source Administrator dialog box.

This database server is now ready to be the target of the ArtiosCAD database schema batch file run
from a different machine.
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Using other databases with ArtiosCAD

If you chose Microsoft SQL Server or Oracle in the Database Program Selection dialog box, your
database administrator must configure the database to work with ArtiosCAD. See Running the Esko
ArtiosCAD database configuration batch file for Microsoft SQL Server 2005 or 2000 or Using Oracle for
Oracle.

Other database notes

To change the database engine used with ArtiosCAD, delete the ArtiosCAD data source from the
System DSN tab of the ODBC Data Sources control panel and reinstall ArtiosCAD.

Oracle databases should either have autoexpand set for the tablespace or should have a very large
maximum extent set.

Do not change the database passwords in a vendor-supplied utility. Rather, change them in DataCenter
Admin by using the File > Change Database Connection (programmer) Password or Change Database
System Administrator (sa) Password commands.

Upgrading other databases with ArtiosCAD

If you use Oracle or Microsoft SQL Server as the database engine, you must run the database scripts
batch file after ArtiosCAD finishes loading and the system has rebooted (if applicable). See the Other
Tasks chapter's sections about using Oracle or Microsoft SQL Server for more information.

Other database notes

To change the database engine used with ArtiosCAD, delete the ArtiosCAD data source on the System
DSN tab from the ODBC control panel and reinstall ArtiosCAD.

Oracle databases should either have autoexpand set for the tablespace or should have a very large
maximum extent set.

Do not change the database passwords in a vendor-supplied utility. Rather, change them in DataCenter
Admin by using the File > Change Database Connection (programmer) Password or Change Database
System Administrator (sa) Password commands.

Changing to SQL Server Express Edition on the database
server

SQL Server Express Edition is a replacement for Microsoft Access and MSDE which Esko believes
offers greater stability and better performance for ArtiosCAD.
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If your system currently uses Microsoft Access as the database engine, you must upgrade it to SQL
Server Express Edition. If your system currently uses MSDE, you may continue to use it, but SQL Server
Express Edition offers better performance than MSDE.

If you choose to change to SQL Server Express Edition, you should export non-design-based database
information from the old database before starting to load ArtiosCAD. The migration to SQL Server
Express Edition should be error-free, but if there are problems, you can import this data into a blank
database and then do an AutoLoad to create a new database.

Note:  This migration workflow is not supported for SQL Server Express Edition version X to
SQL Server Express Edition Y. You must use SQL Server's native detach/attach functionality.
The shortcuts to these programs are not installed with versions of ArtiosCAD newer than 14.1.1.

Exporting database information from the old database

To export non-design-based data from the existing database, do the following:

1. Ensure that any programs using the database are not running.
2. Log on to the database server as Administrator or as a member of the Administrators group.
3. Click Start > Programs > ArtiosCAD > Migration Tools  > ArtiosCAD Database Export.
4. Enter admin as the username with no password, and click OK.
5. The utility will appear similar to the picture shown below.
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6. Enter a sensible file name and location in the Migration Filename and Path: group.
7. Select all the available tables.
8. Click Export. The progress bar indicates the progress of the export.
9. When the export is done, click Exit. If the migration to SQL Server Express Edition is error-free, you

can delete the exported file after the migration if desired.

Loading the upgrade

When you install ArtiosCAD as an upgrade and and have been using Microsoft Access or MSDE as the
database engine, choose SQL Server Express Edition as the database type, a checkbox appears asking
if you want to migrate prior database data to SQL Server Express Edition if this system is the database
server.
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If you choose SQL Server Express Edition as the database program and this system is the database
server, the following actions happen:

• A database schema is built or updated as appropriate.

• The existing ArtiosCAD ODBC datasource is renamed to ArtiosCAD_Access or ArtiosCAD_MSDE as
appropriate.

• Empty command prompt windows appear.

• The ArtiosCAD ODBC data source changes to reference the new SQL Server Express Edition
database.

• A service called SQL Server (ARTIOSCADEXP2005) is created and started.

If this system is not the database server, the ArtiosCAD ODBC datasource changes to reference the
SQL Server Express Edition database.

If you choose to migrate the data, the setup program tries to export the data from the old database. If
the export is successful, the data is migrated to the SQL Server Express Edition database.

If you do not choose to migrate the data, a blank SQL Server Express Edition database is created and
you have to manually export the data from the old database and manually import the data into SQL
Server Express Edition.

Automatic migration

If you choose to have the setup program migrate the data, a series of empty command prompt
windows appears during the installation while the migration tasks are executing. Their duration is
directly proportional to the size of the old database.
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If there are errors during the migration process, you must manually migrate the data as instructed in
the next section.

Signs of a successful migration are:

• Data appearing in the design browsers in ArtiosCAD, and also in DataCenter Admin, provided that
the ArtiosCAD System DSN uses a Microsoft SQL Server driver.

If the automatic migration fails, you must perform a manual migration.

Manual migration

If you do not choose automatic migration, you must perform the data migration manually on the
database server for the old database after the ArtiosCAD installation finishes.

The steps to performing the migration manually are as follows:

1. Export the data.
2. Check the log file for errors.
3. Import the data.
4. Check the log file for errors and try ArtiosCAD.

Exporting the data
To export the data from the old database, do the following.

1. Log on as Administrator or as a member of the Administrators group.
2. Click Start > Programs > Esko > ArtiosCAD > Migration Tools > ArtiosCAD Database Migration

Export. The export utility will appear along with a blank command prompt window.
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The Migration Folder group shows the folder that stores the files created by the export utility. The
export files require the same amount of hard drive space as the Microsoft Access database file, so
make sure to choose a location with enough free space. Click Browse to select a new location.

The Data Source group lists the available data sources. Make sure to select the ArtiosCAD_Access or
ArtiosCAD_MSDE as the data source for this migration.

The Format group selects the format of the migration files. ADTG is the default; if it errors, try XML.

In the Advanced group, Delete design dups deletes duplicate design records in the database;
preserving the newest record and discarding older duplicates. Delete orphans deletes table entries
that no longer have corresponding design records on the hard drive. Both options are enabled by
default.

The Migrate group contains the actual commands. Export exports the data from the selected data
source in the format selected to the migration folder. View Log opens the log file of the export. It
is stored in the system temporary directory as ACadFullDbMigrationExportLog.txt. Exit exits the
program.

The Migration Process group contains the progress bar showing the table being exported. The length
of time required to export the data is directly proportional to the size of the database. Cancel Migration
cancels the migration. Do not use the migration files created by a cancelled migration.
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1. Set the migration folder and format as desired, select the ArtiosCAD_Access or ArtiosCAD_MSDE
data source, and click Export. During the export, all controls in the dialog box are unavailable except
for Cancel Migration.

2. There should be no errors. If an error appears, delete all the ADTG files created by this migration and
try using XML for the migration format. If there are no errors, the next step is to check the log file.

Checking the log file for export errors
1. Even if no errors appeared during export, click View Log to view the log file. Information, warnings,

and errors are logged. Check the log file for warnings and errors. Warnings related to tables not
existing are usually caused by database schema differences among ArtiosCAD versions; these can
be safely ignored. Only errors warrant concern. A sample log file is shown below; yours might vary.

Table: Sample ACadDBFullMigrationExportLog.txt

Information: [Exporting table] CODE_TYPE 
Information: [Exporting table] IQ_DEFAULTS 
Information: [Exporting table] CODE 
Information: [Exporting table] HIERARCHICAL_STYLES 
Information: [Exporting table] COMPANY 
Information: [Exporting table] PERSON 
Information: [Exporting table] FLUTE 
Information: [Exporting table] BOARD_FOLDER 
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Information: [Exporting table] BOARD 
Information: [Exporting table] HIERARCHICAL_BOARDS 
Information: [Exporting table] MEDIUM 
Information: [Exporting table] SERVER 
Information: [Exporting table] RESOURCE_TABLE 
Information: [Exporting table] COUNTER 
Information: [Exporting table] COST_CENTER 
Information: [Exporting table] AUTONUMBER 
Information: [Exporting table] UNITS 
Information: [Exporting table] USER_FIELD_TYPE 
Information: [Exporting table] PREDEFINED_USERFIELDS 
Information: [Exporting table] PREDEFINED_USERFIELD_VALUES 
Information: [Exporting table] USER_FIELD 
Information: [Exporting table] DESIGN 
Information: [Exporting table] DESIGN_IMAGE 
Information: [Exporting table] DESIGN_STYLE 
Information: [Exporting table] DESIGN_USER_FIELDS 
Information: [Exporting table] PRINT_ITEM 
Information: [Exporting table] LAYOUT 
Information: [Exporting table] LAYOUT_USER_FIELDS 
Information: [Exporting table] LAYOUT_DESIGN 
Information: [Exporting table] PRINT_ITEM_LAYOUT 
Information: [Exporting table] LAYOUT_DESIGN_IMAGE 
Information: [Exporting table] LAYOUT_DESIGN_STYLE 
Information: [Exporting table] LAYOUT_DESIGN_USER_FIELDS 
Information: [Exporting table] Projects 
Information: [Exporting table] Project_printitem 
Information: [Exporting table] User_Group_List 
Information: [Exporting table] User_In_Group 
Information: [Exporting table] Group_Parent 
Information: [Exporting table] Security_Element 
Information: [Exporting table] CAD_Permission 
Information: [Exporting table] Global_Permission 
Information: [Exporting table] Profile_Defaults 
Information: [Exporting table] User_Profile 
******* The ArtiosCAD full database migration ended at: 10/09/07, 14:44:07

2. Once you have reviewed the log file, close it. If there were errors, delete the XML or ADTG files and
AutoLoad in database recovery mode.

3. Click Exit to exit the ArtiosCAD Database Migration Export utility. The next step is to import the
data.

Importing the data
1. Click Start > Programs > Esko  >  ArtiosCAD  > Migration Tools > ArtiosCAD Database Migration

Import. The import utility will appear along with a blank command prompt window.
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2. The Migration Folder Path folder is automatically set to the same folder as the one used previously
by the ArtiosCAD Database Migration Export utility.

Make sure to set the option button in the Format group to the same format as that used in the
export.

Select the ArtiosCAD data source if it is not already selected.

In the Advanced group, Delete Database deletes the contents of the database before importing the
data stored in the migration file. For example, to make an exact copy of the database from which
you are migrating, select this option, but if you are importing only one table, deselect this option.
Stop on Insert error completely stops the migration when there is a problem adding information.
When deselected, the process continues regardless of errors, and you should read the log file to see
if there are errors.

3. Click Import when you have set the options as desired. During the import, all dialog box controls
are unavailable except for Cancel Migration. The progress bar moves to the right as the import
progresses. There should be no errors.
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Checking the log file for import errors
1. Even if there are no errors, click View Log when the import is done to review the log file for errors.

Information, warnings, and errors are logged. Check the log file for warnings and errors. A sample
log file is shown below; yours might vary.

Table: Sample ACadDBFullMigrationImportLog.txt

******* The ArtiosCAD full database migration began at: 10/09/07, 14:52:17 
Information: Deleting data from all tables 
Information: [Importing data] code_type [C:\Artios\code_type.adtg] 
Information: [Importing data] iq_defaults [C:\Artios\iq_defaults.adtg] 
Information: [Importing data] code [C:\Artios\code.adtg] 
Information: [Importing data] hierarchical_styles [C:\Artios
\hierarchical_styles.adtg] 
Information: [Importing data] company [C:\Artios\company.adtg] 
Information: [Importing data] person [C:\Artios\person.adtg] 
Information: [Importing data] flute [C:\Artios\flute.adtg] 
Information: [Importing data] board_folder [C:\Artios\board_folder.adtg] 
Information: [Importing data] board [C:\Artios\board.adtg] 
.
.
.
Information: [Importing data] cad_permission [C:\Artios\cad_permission.adtg] 
Information: [Importing data] global_permission [C:\Artios\global_permission.adtg] 
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Information: [Importing data] profile_defaults [C:\Artios\profile_defaults.adtg] 
Information: [Importing data] user_profile [C:\Artios\user_profile.adtg] 
******* The ArtiosCAD full database migration ended at: 10/09/07, 14:52:19

2. Once you have verified there are no errors, close the log file. If there were errors, delete the XML or
ADTG files and try the complete process again, using the other format for the data files. If that fails
as well, delete the data files and use AutoLoad in database recovery mode.

3. Start ArtiosCAD.
4. Click Database > Browsers > Design browser. The Design Browser should appear normally.
5. If you are upgrading from a version of ArtiosCAD earlier than version 4, run \Esko\Artios

\DataCenter\Program\Buildkeys.exe to convert design styles to hierarchical
characteristics.

6. The migration to the new database is complete.

Once you have verified that all the data is in the database, delete the XML or ADTG files from the
migration folder.

ArtiosCAD Database Migration utility command-line options

You can run the ArtiosCAD Database Migration utility from the command line if desired. This ability is
meant for use by system administrators in large corporations who manage remote computers.

Use a command prompt to go to the \Esko\Artios\Datacenter\program\language folder.

Next, run ACADDbMigration.exe with the desired switches.

Switch Meaning

-c Use the command line versus a dialog box.

-e Export data (the default.)

-i Import data.

-f folder Specifies the folder in which the migration files are located.

The default is whatever is specified in the registry from a previous export else it
is unknown. The registry key is HKLM\Software\Artios\Migration. The registry
value is Migration_FullDB_Folder.

If -c is used, -f should be used if you are unsure the registry value exists.

-l logfile Log file folder and name.

The default location is the temp directory specified by the TMP variable if it
exists, else the TEMP variable if it exists, else the current directory. The file
name is ACADFullDbMigrationExportLog.txt (or ...ImportLog.txt )

-d datasource
name

The default is ArtiosCAD. Note that the Microsoft Access datasource name was
changed to ArtiosCAD_Access when you changed to MSDE.

-t xml or adtg Format for the migration files. ADTG is the default.
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Changing to SQL Server Express Edition on client systems

If you change your database server to SQL Server Express Edition, you must also load the upgrade on
all client systems to configure them to use the new server software. No database software is loaded on
clients.

Network Ports List

ArtiosCAD uses network ports to communicate with its license server (if you use a network license),
with the database server (if it is not the local machine), and to perform Outputs. Your computer and the
various servers may be running a firewall that blocks ports and thus ArtiosCAD may not work correctly.

Program Ports needed

FlexNet network licensing 27000-27009 (uses random port in this range)

ELAN network licensing 7841

Single instance of Microsoft SQL Server, including
Express Edition

1433, but could be dynamic; see note below

Oracle SQL*Net Listener 1521

i-cut Production Console Output 80, 10003

Oracle notes
If you need to change the port number for the Oracle SQL*Net Listener, use the Net Configuration
Assistant.

Microsoft SQL Server notes
Every time Microsoft SQL Server starts, including SQL Server Express Edition, it dynamically allocates
an available network port for communication. This means that the port number could be different
each time you restart the database server or your machine. To circumvent this problem of not knowing
which port to open, if your system is using the built-in Windows Firewall with Advanced Security,
you can create a program rule that will open whatever port the software uses. If your system uses a
different firewall, contact your system administrator for assistance.

1. Log in as Administrator or as a user with administrative privileges.
2. Click Start > Run.
3. Type WF.msc and click OK.
4. In the left pane of the Windows Firewall with Advanced Security dialog box, select Inbound Rules

and then click New Rule in the Actions pane.
5. In the Rule Type dialog box, select Program and click Next.
6. In the Program dialog box, select This program path, and then click Browse.
7. Navigate to the folder containing the Microsoft SQL Server executable. It will vary depending on

your operating system and version of Microsoft SQL Server you are using. On a 64-bit Windows 2008
R2 server using the default Esko-supplied instance, for example, the path is C:\Program Files
\Microsoft SQL Server\MSSQL11.ESKO\MSSQL\Binn.
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8. Select sqlservr.exe and click Open. The complete path should appear in the field. Click Next.
9. In the Action dialog box, select Allow the connection and click Next.
10. In the Profile dialog box, leave everything selected and click Next.
11. In the Name dialog box, enter a name for this firewall rule (like SQL Server) and click Finish.
12. Click File > Exit to close the Windows Firewall with Advanced Security dialog box.
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5.  ArtiosCAD Enterprise Installation and
Configuration

ArtiosCAD Enterprise installs and operates differently than ArtiosCAD Standard Edition because of
its improved Project and document management framework. Those changes are contained in this
chapter, and also in the Introduction to ArtiosCAD Enterprise chapter later in this book.

If you are using ArtiosCAD Standard Edition, please skip this chapter.

Installing ArtiosCAD Enterprise

The list below is a general guide to the steps required to install ArtiosCAD Enterprise. They will be
explained in greater detail in the following sections.

1. Install and configure WebCenter on its dedicated servers. Make sure to have access to
theWebCenter and licensing documentation at http://help.esko.com, where you can also download
the PDF versions for printing and oine use. WebCenter and Licensing and Activation are listed in
the Products section.

2. Run the board importer batch file.
3. Create, migrate, or add to the ArtiosCAD Enterprise Defaults.
4. In WebCenter, do the following:

• Configure companies and locations for the initial ArtiosCAD Enterprise users.

• Create custom groups, if desired, for the initial ArtiosCAD Enterprise users.

• Create the initial ArtiosCAD Enterprise users as Project Managers.

• Invite new users to the Shared Defaults Project.
5. Install ArtiosCAD Enterprise on users’ computers.
6. Start using ArtiosCAD Enterprise.

There are additional configuration tasks to do in WebCenter that will make ArtiosCAD Enterprise easier
to use. They include:

• Assigning default boards to a location.

• Creating characteristics, attribute categories, attributes, and restricted sets.

Finally, once everything is configured and working, you can set up a third tier of Defaults called
Location Defaults. They sit between Shared Defaults and User Defaults. Location Defaults are
configured independently for each location, although you can create a Template on which to base
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them. For more information about using Location Defaults, see the information starting in the Location
Defaults Overview section later in this chapter.

Step 1 - Installing WebCenter

The first step of installing ArtiosCAD Enterprise is to install WebCenter.

Note:  Have the WebCenter Complete Documentation manual handy for easy reference. It is
available at http://help.esko.com.

Installing WebCenter for use with ArtiosCAD Enterprise varies from the procedure in the WebCenter
manual in that there are a few more steps required.

Note:

We do not recommend using an Express version of Microsoft SQL Server if you will have more
than a few users. If you plan on this, we recommend using a full version of Microsoft SQL Server
or Oracle.

The list below is a general overview to installing WebCenter. Refer to the WebCenter Complete
Documentation manual for specific instructions. In case of a conflict, the information in the steps
below takes precedence over the steps in that manual.

1. Load the database server software (Microsoft SQL Server or Oracle) on the database server if
it is not already present. If you will be using a centralized corporate database server instead
of a dedicated WebCenter database server, you will either need to load database access and
management tools on the Application server, or map a drive to the Application server from the
database server, in order to run the database scripts batch file that builds the database schema.

2. If any users will be using the WebCenter Viewer to look at files, load the On-Board Graphics Engine.
Note that this will require a separate Automation Engine OBGE Server network license to be loaded
on the Application server. For more information, see the WebCenter Complete Documentation
manual.

3. On the Application server, do the following steps as a member of the local Administrators group:
a) Load ArtiosCAD Enterprise that is on the same media as WebCenter as an Advanced installation.

Do not load a different version.
b) Load the WebCenter Application server components. It is important to answer all questions

correctly to avoid having to edit files later. You may receive a message about two installation
programs running at the same time. Click OK if you see this message.

c) Run the database scripts batch file appropriate for the type of database software you installed.
You need to have the database access and management tools for your database program loaded
on the Application server, or you need to do this from the database server with a network drive
mapped to the Application server.

If you are using Oracle, you must have write access to the folder containing the database
schema batch file as the batch file creates XML files used to create the database schema. You
may want to copy the entire DatabaseSchema folder to the database server and run it locally
to ensure proper schema creation.

d) Start the WebCenter services (WebCenter App-X Application Container, WebCenter JBOSS
Application Server, WebCenter CAD-X Server, and WebCenter Search Crawler). You may want to
set them to start automatically.
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4. On the Web server, do the following steps as a member of the local Administrators group:
a) Make sure that Internet Information Services (IIS) is installed and working correctly. See the next

section for more information.
b) Load the WebCenter Web server components. It is important to answer all questions correctly to

avoid having to edit files later.
c) Start the WebCenter Tomcat service.
d) Log in to WebCenter and change the admin password.

5. On the Application server, start the WebCenter CAD-X Server service.

Installing IIS7 on the Web Server
Installing IIS7 on the Web server for use with WebCenter and ArtiosCAD Enterprise has three steps:

1. Installing the software.
2. Enabling 32-bit applications (only if the Web server is using a 64-bit operating system).
3. Extending the size limit for uploaded files.

Install IIS on the Web Server Machine
If IIS is not installed on your web server, you need to install it. The procedure below explains how to
install IIS7 on Windows Server 2008 R2.

1. Start the server manager.
2. Click Roles in the left panel, then click Add Roles at right.

 

 

This opens the Add Roles Wizard.
3. In the Select Server Roles screen, select Web Server (IIS).
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If the wizard prompts you to add features required for the web server, do so.

 

 
4. In the Select Role Services screen:
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a) Select ASP, ISAPI Extensions and ISAPI Filters.

If the wizard prompts you to add role services required for ASP, do so.
b) Select Logging Tools and Tracing.
c) Select IIS 6 Management Compatibility.

5. In the Confirm Installation Selections screen, check the settings and click Install.
 

 

This installs the IIS 7 Role with the settings you have selected and the default settings.
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The Installation Results screen should show Installation succeeded.

Enable 32 Bit Applications

Note:  Only do this if you have a 64 bit system!

1. In IIS, go to Application Pools and select the DefaultAppPool.
2. Click Advanced Settings..., then set the Enable 32 Bit Applications option to True and click OK.

 

 
3. Click Recycle... at right.

Extend the Upload Limitation
IIS7 has a limitation on how much you can upload at once (30 MB). You can change it to 2GB by following
these steps:

1. Open IIS 7 SnapIn.
2. Select the website for which you want enable large file uploads.
3. In the main window, double-click Request filtering.
4. Once the window is opened you may see a list of tabs (file name extensions, rules, hidden

segments…).
Regardless of the tab you select, right-click in the main window and select Edit Feature Settings.
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5. Modify the Maximum allowed content length (bytes): change the value to 2000000000 (a 2 and 9
zeros) to be able to upload files close to 2GB.

Step 2 - Optionally Uploading Boards

In case the boards were not installed yet, follow this procedure after logging in to WebCenter for the
first time:

1. Log in on the Web server as a member of the local Administrators group.
2. Run the setup program with WebCenter DVD.
3. Click Upload Boards.
4. In the Log In To Web Browser dialog box, enter the address of the WebCenter server, an admin

user's username, and that user's password. Click OK.
5. An Upload Boards progress bar will appear.
6. Click Close when the upload finishes.

Step 3 - Creating Shared Defaults for the First Time

The next step is to run the ArtiosCAD Defaults Manager installed when you installed ArtiosCAD
Enterprise on the Application server. The first time you install ArtiosCAD Enterprise 16 or later, you
have to create the Shared Defaults. You can choose to either create completely new Shared Defaults,
or you can choose to migrate older Defaults that are merged with the defaults for the version you are
installing. In the future, you will add a new version's Defaults to the existing Shared Defaults Project.

You may also use this utility to migrate location and user defaults from older versions of ArtiosCAD
Enterprise to newer versions of ArtiosCAD Enterprise.

Note:

Even if you do not plan to use WebCenter in combination with ArtiosCAD Enterprise, it is
still necessary to install the Defaults in order for WebCenter to be able to process CAD files
properly. Therefore, it is highly recommended to install the Defaults, even if you do not plan to
use CAD files initially.

Note:

The system you use for loading the Defaults must be able to keep the Defaults on it. You will
have to follow the same process to load future Defaults and the new installation will reference
the older version’s Defaults as part of its installation. We recommend using the Application
Server for this process.

Note:

This procedure takes a significant amount of time. We recommend starting it and doing
other things until it completes.

1. Log in to the Application Server as a member of the local Administrators group.
2. Click Start > All Programs > Esko > Defaults Management to start the Defaults Manager.
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3. In the Login to Web Browser dialog box, enter your WebCenter server URL, admin username, admin
password, and click OK.

4. Click Create new shared defaults.
5. A progress bar appears. This step will take a few minutes.
6. Click Close when the installation process is done.

Upgrading from Earlier Shared Defaults
If you have a version earlier than 16 of ArtiosCAD Enterprise already on the server, or any version
of ArtiosCAD Standard Edition, in any language, you may migrate those defaults to create one new
Shared Defaults Project for version 16 and later. You may choose only one language as the source of the
migrated Defaults. All future installations of ArtiosCAD Enterprise will share the same Shared Defaults
Project regardless of language or version.

1. Log in to the Application Server as a member of the local Administrators group.
2. Click Start > All Programs > Esko > ArtiosCAD > Defaults Management to start the Defaults

Manager.
3. In the Login to Web Browser dialog box, enter your WebCenter server URL, admin username, admin

password, and click OK.
4. Click Migrate pre-ArtiosCAD 16.0 shared defaults to new shared defaults
5. In the Migrate Shared Defaults dialog box, choose the edition, version, and language from the drop-

down list boxes to use as the source of the migrated defaults.
6. Click Migrate Defaults.
7. A progress bar appears. This step will take a few minutes.
8. Click OK in the Copy Projects Result dialog box.
9. Click Close to close the Defaults Manager dialog box, or choose another maintenance action.

Adding New Defaults to an Existing Shared Defaults Project
If you have previously created a Shared Defaults Project for version 16 or later, when you load a newer
version of ArtiosCAD Enterprise, you need to add its Defaults to the existing Shared Defaults Project.

1. Log in to the Application Server as a member of the local Administrators group.
2. Click Start > All Programs > Esko > ArtiosCAD > Defaults Management to start the Defaults

Manager.
3. In the Login to Web Browser dialog box, enter your WebCenter server URL, admin username, admin

password, and click OK.
4. Click Add new defaults to the shared defaults project.
5. A progress bar appears. This step will take a few minutes.
6. Click Close when the installation process is done.

Migrating User or Location Defaults
Use the Defaults Manager tool to migrate multiple sets of location and/or user defaults between
versions of ArtiosCAD Enterprise at once.

The tool works with one WebCenter server. It does not migrate Defaults between different ArtiosCAD
Enterprise installations. To move Defaults between different ArtiosCAD Enterprise servers, you can
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export them as a ZIP archive on the source server, copy the archive to the destination server, and
extract and upload them into a new correctly named Defaults Project.

To use the Defaults Manager tool, do the following:

1. Log in to the Application Server as a member of the local Administrators group.
2. Click Start > All Programs > Esko > ArtiosCAD > Defaults Management to start the Defaults

Manager.
3. In the Login to Web Browser dialog box, enter your WebCenter server URL, admin username, admin

password, and click OK.
4. In the Defaults Manager, click Migrate user/location defaults.
5. Choose the source version to migrate from in the Version drop-down list box.
6. Choose the language for the source version from the Language drop-down list box.
7. Check Overwrite If Exists if a Defaults Project by the same name already exists in the destination

version.
8. In the Location Defaults Found group, check the location Defaults to migrate.
9. In the User Defaults Found group, check the user Defaults to migrate.
10. Click Migrate Defaults. ArtiosCAD Enterprise migrates the Defaults preserving the membership and

security information and displays a progress bar.
11. ArtiosCAD Enterprise displays a results dialog box showing the number of copied Projects, skipped

Projects, failed Projects, and total Projects. Click OK.
12. Repeat the process for other versions if desired. If you are done, click Close to end the tool.

The migrated Defaults are now available for use.

Step 4 - Creating a New Company and Location

The next step is to create an entry for your company and location that will contain the users.

1. Log in to WebCenter as admin or as a member of the ADMINS group.
2. Click Admin > Companies > New Company.
3. Enter the information about the new company. Fields with asterisks next to them are required to

have information in them.
4. Click Create.

A status message saying the company was created successfully appears at the bottom of the page.

To add more locations to this company, click the successful status message to edit the company,
and then click Locations > New Location and enter the pertinent information for the new location.
Click Add Location and repeat as desired.

Step 5 - Creating a New Group

This step is optional.

Group membership is an important administration and security consideration. Only two groups,
ADMINS and USERS, are created by default when you install WebCenter. For ecient classification
of users, you may want to create different groups so that different users can easily have different
Project permissions. On the other hand, you might find it easier for all users to belong to one group
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and to invite that one group to your Project templates. It all depends on if you want different groups of
multiple users to have different abilities.To create a new group, do the following:

1. Click Admin > Groups > New Group.
2. Enter the name of the group.
3. Choose who will be able to see this group: All Project Managers, Administrators Only, or Selected

Project Managers.
4. Click Continue.
5. In Step 2: Select Group Members, since you have not created any users yet, click Continue.
6. Is this new group visible to every Project Manager or only to Administrators:

• If yes, click Finish. The group is created.
• If no, click Continue. Then, in Step 3: Assign group visibility to project manager(s), select the

Project Managers who can see this group and click Finish.

Project Managers with Full Visibility is unavailable, as they can see all groups. By default, group
members can see the group but you can still de-select the group members so that they don't
know this group exists.

Step 6 - Creating New Users

The next step is to create users who will use ArtiosCAD Enterprise. Refer to the WebCenter
documentation for more information.

1. Click Admin > Users > New User.

Step 1: User Info in the Create New User wizard appears.
2. Type the basic user information into the appropriate fields (Username, First Name, Last Name, ...).

Note:  Required fields are indicated with an asterisk *.

3. Do you want to use LDAP authentication (single sign-on) for this user?

• If yes, enable the Use LDAP to Authenticate User option. This will allow the user to use his
regular Windows network user name and password to log on to WebCenter. Using LDAP requires
additional configuration in WebCenter. Please see the WebCenter documentation for more
information.

• If no, provide the user’s initial Password and confirm it.

For ArtiosCAD Enterprise users, do not enable Require user to change the password at first
login.

4. Does the user need guaranteed access by means of a reserved license?

• If yes, enable the option User Has Guaranteed Access.
• If no, leave the option disabled and proceed to the next step.

For more information on guaranteed access and its licensing implications, refer to the WebCenter
documentation.

5. Does the user need special permissions in WebCenter? All ArtiosCAD Enterprise users should be
at least Project Managers with Limited Visibility of Companies and Groups. If they are not, the
administrator will need to do additional configuration work described at the end of this procedure.
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If the user needs... Select the option...

no special permissions and will not create
Projects

Normal User

Project Manager permissions, but only for
Projects and users belonging to his or her own
company

Project Manager with Limited Visibility of
Companies and Groups.

Project Manager permissions on the complete
system

Project Manager with Full Visibility

6. Does the user need the ability to create new task types in WebCenter? ArtiosCAD Enterprise users
do not need to create task types.

• If yes, enable the option User Can Create Task Type.
• If no, proceed to the next step.

7. To grant this user the ability to create other users without being a member of the ADMINS group,
enable the option User Can Create User checkbox.

8. In Step 2: Assign to a Company, select a company and location to which you want to assign the
user. Note that this can be very important to filter the content, users, and Location Defaults the
new user will be able to see.

9. If you:

• are creating a Normal User or a Project Manager with Full Visibility, the wizard is complete.
Click Finish to create the user.

• are creating a Project Manager with Limited Visibility, click Continue and proceed to the next
step.

10. In Step 3: Assign Visible Companies, select the companies that this user should be able to see,
then click Continue.

The selection you make here filters the list of users in the next step so that this Project Manager
can never see users from the companies you did not select in this step. By default, only the
company of the Project Manager himself (the one you selected in the previous step) will be selected.

11. In Step 4: Assign Visible Groups, select the groups the user should be able to see, then click Finish.

Only groups containing members that belong to one of the companies you assigned in the previous
step will show up in the list. In addition, some groups may be set to be visible to all users (such as
the ADMINS group).

A status message saying the user was created will appear. Stay on this page for the next step.

If a new user is not made a Project Manager, the user will not be able to use User Defaults unless the
administrator does the following:

• Creates a Project for this user named ACadDefaults_username (where username is the user’s
WebCenter username).

• Invites the user to the Project.
• Uploads clientdflt.zip to the Project.
• Grants the user View and Download permissions at the Project level. The user will not be able to

change the User Defaults with this level of permissions.
• If the user needs to change the User Defaults, he or she must have Full permission at the Project

level.
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• Adds the user to the appropriate Location Defaults Project with at least View and Download
permissions. If the user needs to change the Location Defaults, he or she must have Full permission
at the Project level.

Step 7 - Setting a New User’s Group Membership

Once you have created a new user, the next step is to assign that user to one or more groups. Even if
you did not create any custom groups, you should assign a new user to the USERS group.

1. While still on the Create New User page with the successful creation status message, Click Add
user to group(s).

2. In the Available Groups column, click each group to which you will add this new user. To select more
than one group, hold down CTRL while clicking groups.

3. Click >> to assign the selected available groups to the user.

The user is added to the group(s) immediately.

Step 8 - Inviting New Users to the Shared Defaults Project

The next step is to invite new users to the Shared Defaults Project, which is Shared Defaults in
ArtiosCAD Enterprise. You can do this either individually for every user or once through Group
membership if you added all users to the same group (such as USERS). Inviting them to the Project
means that they will be able to use the Defaults. In order for users to change Shared Defaults, they
must have Full permissions on the Project and be members of the ADMINS group.

Note:

All ArtiosCAD Enterprise users must be invited to the Shared Defaults Project. Users who are
not invited to the project will receive a UFANEX error when they launch ArtiosCAD Enterprise.

1. Click Admin > Project Management > Projects.
2. Click the name of the ACadDefaults_Shared Project to which you are inviting the user.
3. Click Members on the Project menu.
4. Click Add members.
5. In Add Project Members Step 1 of 2, check the checkboxes next to those users and groups to add to

the Project.
6. Click Continue.
7. In Add Project Members Step 2 of 2, assign at least Download permission for the Project and each

folder in it. Invitees to Projects get View permission assigned automatically.
8. Click Finish.

The new invitees should now be able to log into ArtiosCAD Enterprise and start using it.

Step 9 - Installing ArtiosCAD Enterprise on a User’s Computer

To install ArtiosCAD Enterprise on a user’s computer, do the following:

1. Log in as Administrator or as a user with administrative privileges.
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2. Ensure that this system meets the minimum system requirements as published on Esko's website
(search for system requirements).

3. Put the ArtiosCAD Enterprise media into the computer’s media drive. It should automatically launch
the Setup program. If your drive is set to not AutoPlay, start Windows Explorer and double-click
setup.exe in the root directory of the media.

4. If you have User Account Control enabled, allow setup.exe to run.

5. Choose the language in which to run the setup program and install ArtiosCAD in using the Change
Language drop-down. It should automatically match the language of your system but you may
change it if desired. The setup program language will change to the language you selected.

6. In the ArtiosCAD Setup dialog box, click Install ArtiosCAD Enterprise N.nn, where N.nn is the
version number.

The installer will launch and a few messages may display.
7. In the Welcome to the InstallShield Wizard for ArtiosCAD Enterprise N.nn dialog box, click Next.
8. Read the Software License Agreement in its entirety and choose I accept the terms of the license

agreement if you accept all the terms of the License Agreement. Click Next.
9. Choose a Typical installation and click Next to use the most common configuration; skip to step 14.
10. If you want to keep previous versions of the software or choose features to install, choose

Advanced and click Next.
11. In the Feature Selection dialog box, choose the features to install on the current machine. For each

feature, click the icon in the drop-down list box next to it and choose the appropriate choice. Do not
click Next when done, but rather proceed to the next numbered step.
a) Esko ArtiosCAD Licensing controls whether this machine is a license server or not. For

ArtiosCAD Enterprise, the WebCenter Application server should be the licensing server, so this
choice should be set to This feature will not be available.

b) Esko ArtiosCAD Programs are the program files needed to run ArtiosCAD Enterprise. You must
install these if you want to run ArtiosCAD Enterprise on the current machine. You must leave this
choice selected to install ArtiosCAD itself.

c) Contained within this group are optional components of ArtiosCAD Enterprise that require
purchasing licenses for the corresponding module: ArtiosCAD 3D Data Exchange. Refer to
the printed license report that came with the media to determine which component(s) to
select. Installing software components without having the corresponding licenses wastes disc
space, but hinders operation if you purchase a license in the future. Not installing the software
components but having the licenses for them results in features that do not function within
ArtiosCAD.

d) Esko Configuration Manager collects data from systems running the Esko Station Information
Service and sends the collected data to Esko automatically for use by Support personnel. It
sends information only if you configure it to do so and leave it enabled. It is a great aid to
Support personnel as they will have required information about your hardware and licenses
available should you need to call for assistance. Only one system per site should have the Esko
Configuration Manager installed.

12. While still in the Feature Selection dialog box, with one of the components to be installed selected,
review the folder in which ArtiosCAD Enterprise will be installed, and click Change if desired. In the
resulting Change Current Destination Folder dialog box, change the drive if desired, and click OK
to return to the Feature Selection dialog box. ArtiosCAD should always be installed to the \Esko
\Artios folder on a local drive. Click Next.

13. If you selected an Advanced installation:
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a) In the Advanced Options dialog box, Keep Previous Versions is the default for previous version
handling. It means that ArtiosCAD is installed using a version-specific folder and icon which
match the version and language of the installation, and all previous versions of ArtiosCAD
are kept. To change this setting, click Change. In the Previous Version Handling dialog box,
Overwrite previous versions simply uses ArtiosCAD as the icon name and ArtiosCAD as
the directory with no version number. It overwrites the prior version of ArtiosCAD if this is an
upgrade and the previous version was installed to a non-version-specific directory. Once you
have chosen the option to use, click OK to return to the Advanced Options dialog box.

b) In the User Files Folder dialog box, click Change to change the location for unmanaged user files
from the location shown. Enter the new location and click OK.

c) Click Next to continue.
14. If you selected a Typical installation, in the Destination Folder dialog box, choose the folder where

you will install ArtiosCAD Enterprise on this user's computer. Click Change to change the folder and
click OK when you have selected the new location. Click Next.

15. In the Ready to Install the Program dialog box, review the settings for correctness. If the settings
are incorrect, click Back and fix them. If they are correct, click Install.

16. If this system has other Esko products on it, you may be prompted to stop their license services.
Click Yes to proceed with the installation.

17. In the InstallShield Wizard Completed dialog box, click Finish. If for some reason you are using only
a local license, click Activate Local Licenses instead and follow the instructions on the screen.

If you are prompted to reboot the system, click Yes. It is very important that you reboot the system
if prompted.

For this user to use ArtiosCAD Enterprise, you should have already followed the major installation steps
of creating new users, assigning them to groups, and inviting them to the Shared Defaults Project. If
not, perform them now. Once done, the user should be ready to use ArtiosCAD Enterprise. Repeat for
other users as needed.

You will enter the licensing information for ArtiosCAD the first time you start it.

Post-Installation Configuration Tasks

There are two post-installation configuration tasks you should do in WebCenter that make ArtiosCAD
Enterprise more useful in terms of proper categorization of Project information:

• Assign default boards to a location.

• Create characteristics, attribute categories, attributes, and restricted sets.

Assigning Default Boards to a Location
When users create a design, they have to assign a board to it. Boards that are assigned to their location
are shown by default. If no boards are assigned to their location, every time they create a design,
they have to click Show All Boards to view the actual boards in their folders; otherwise, ArtiosCAD
Enterprise shows a list of empty folders.

To assign default boards to a location, do the following:

1. Log in to WebCenter as a member of the ADMINS group.
2. Click Admin > CAD > Boards.
3. Expand the board tree by clicking the plus signs (+) in front of the categories.
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4. To assign a particular board to a location, do the following:
a) Click its name.
b) Check the checkbox to the left of the location to which you are assigning the board. You may

check more than one checkbox to assign the board to multiple locations.
c) Click Finish.
d) Click Boards to return to the Board tree.

Characteristics
Characteristics are descriptive tags that can be assigned to Projects and documents to make them
easier to find.

Characteristics are hierarchical. This means there can be different levels of characteristics for various
product lines so that you can drill down through the information to find the exact characteristic desired
when searching the database.

For example, you could create a master characteristic for Electronics, and then various sub-
characteristics for types of appliances, entertainment equipment, or computers, and so forth. They
are presented in a tree format - main categories with expandable branches. The characteristics tree
configures the available characteristic names as well as how they are organized.

Create a Characteristic

1. Click Admin > Characteristics.
2. Do you want to add a primary characteristic (a main category) or a secondary characteristic?

• To add a primary characteristic, select the option button next to Root at the top of the tree and
then click New Characteristic.

• To add a secondary characteristic, select the option button for the characteristic under which to
add the new one, and then click New Characteristic.

There can be up to 17 levels of characteristics or at most 256 characters for the entire
characteristics path from the root characteristic to the deepest-level characteristic.

3. Enter the name of the characteristic in the Name field.
4. Click Create. The new characteristic appears in the list.

Edit or Delete a Characteristic
When deleting a characteristic, WebCenter checks if the characteristic or any of its child
characteristics are assigned to any Projects or documents. If such a dependency is found, you are
prompted to remove the dependency and delete anyway, or cancel the deletion.

1. Click Admin > Characteristics.
2. Do one of the following:

• To edit a characteristic, click its name in the tree structure. Type a new name in the Edit
Characteristic page and click Save to confirm.

• To delete a characteristic, select it in the tree and click the Delete Characteristic link.

If there are no dependencies, it is deleted immediately. Note that any sub-characteristics of the
selected characteristic will also be deleted.
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Project and Document Attributes

Basic concepts
Attributes are a way to assign user-configurable fields and their values to documents and Projects.
They can be restricted to a group of preset values (as Restricted Sets), or can be prompted so that
the user has to set a value each time they are used. The Restricted Sets must exist before you can use
them when creating an Attribute.

Attribute Categories group Attributes together for convenience. An Attribute must be put into an
Attribute Category before it can be used; however, the same Attribute can be in multiple categories.
You must create an Attribute Category before adding Attributes to it. In ArtiosCAD Enterprise, you
can define default Attribute Categories for each type of native design document that are applied to
documents as you create them.

Suggested workflow
A suggested workflow is to:

Step Action

1 Create Attribute Categories.

2 Create Restricted Sets (if required).

3 Create the Attributes.

4 Assign Restricted Sets to Attributes (if required).

5 Add the Attributes to the Attribute Categories.

6 Assign default Attribute Categories to design document types in Defaults in
ArtiosCAD Enterprise.

Create an Attribute Category

1. Click Admin > Attributes > Attribute Categories > New Category.
2. Enter the name of the Attribute Category to create, such as Shipping Instructions.
3. Click Create.

Edit or Delete an Attribute Category
WebCenter checks if an Attribute Category is being used before deleting it. If it is in use, you will be
prompted to either clear the category from the Projects or documents using it and delete the category,
or to cancel the deletion.

1. Click Admin > Attributes > Attribute Categories.
2. Do one of the following:

• To edit an attribute category, click its name. Type a new name in the Edit Category page and
click Save to confirm.
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• To add attributes to a category or remove them from it, click its name. Then use the chevron (<<
or >>) buttons to move them between the Available Attributes and Current Attributes columns.

Note:  Moving Attributes between columns takes effect immediately.

• To delete an attribute category, select it, move the mouse over the menu symbol and click
Delete Category on the hover menu.

If there are no dependencies, it is deleted immediately. Note that any sub-attributes of the
selected attribute will also be deleted.

Create a Restricted Set

1. Click Admin > Attributes > Restricted Sets.
2. Enter information in the fields as appropriate:

• Name. The name of the Restricted Set, up to 35 characters.
• Type. The data type of the Restricted Set. There are six allowed types: Area, Distance, Float,

Integer, Text, Volume, and Weight. A float is a number containing a decimal point and an integer
is a whole number. The labels in parentheses after the name of the type indicate the units of
measurement used in Imperial and metric systems.

• Value. An entry for the restricted set. Text values can be up to 255 characters long. Click Add to
add the value to the set and clear the Value field. Enter as many values as desired, clicking Add
after each one.

3. Click Create to create the Restricted Set.

Edit a Restricted Set

1. Click Admin > Attributes > Restricted Sets.
2. Either filter or click Go to show the Restricted Sets.
3. Click the name of the Restricted Set to edit.
4. Change the name, or add and remove values as desired. You cannot change the type. If you remove a

value, the next time you access a Project using the deleted value, you will be prompted to change it.
5. Click Change to make the changes.

Delete a Restricted Set
WebCenter checks if a Restricted Set is being used before deleting it. If it is in use, you will be
prompted to either clear the Restricted Set from the Attribute using it, or to cancel the deletion.

1. Click Admin > Attributes > Restricted Sets.
2. Either filter or click Go to show the Restricted Sets.
3. Select the checkbox of the Restricted Set to delete.
4. Hover over the menu symbol and click Delete Restricted Set(s) from the hover menu.
5. Click OK when asked to confirm the deletion.
6. If there are no dependencies, it is deleted immediately. If there are any dependencies, choose the

desired option and click OK.
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Create an Attribute

1. Click Admin > Attributes > New Attribute.
2. Enter information in the fields as appropriate:

In the field... Fill in the...

Name name of the attribute (for example, Billable)

Description description of the attribute contents (for example, Indicates whether
work on this project should be billed by finance)

Type data type of the attribute. Floats are numbers containing a decimal point
(3.1415) and integers are whole numbers (42).

Values choose Prompted if you want to allow the user to enter any value, Calculated
to enter an ArtiosCAD formula for calculating the value of the Attribute when
ArtiosCAD opens the document containing the Attribute (the values are
read-only in WebCenter), or select a Restricted Set to limit the possible
values. To choose a Restricted Set, it must be created before defining the
Attribute. Make sure that the type of the Restricted Set is the same as the
Attribute type.

3. Click Create.

Edit or Delete an Attribute
When deleting an attribute, WebCenter checks if the attribute or any of its child attributes are assigned
to any Projects. If such a dependency is found, you are prompted to remove the dependency and delete
anyway, or cancel the deletion.

1. Click Admin > Attributes.
2. Do one of the following:

• To edit an attribute, click its name. Type a new name in the Edit Attribute page and click Save to
confirm.

You cannot change the attribute type.
• To delete one or more attributes, select the corresponding checkboxes, hover over the menu

symbol and click Delete Attribute(s) on the hover menu.

If there are no dependencies, it is deleted immediately.

Assigning Default Attribute Categories to Document Types
ArtiosCAD Enterprise comes with five empty Attribute Categories: DEFAULT A3D CATEGORY,
DEFAULT DESIGN CATEGORY, DEFAULT MANUFACTURING CATEGORY, DEFAULT CANVAS CATEGORY,
and CANVAS PARTS. Create and add Attributes to these categories as described previously, or create
your own Attribute Categories as desired. Once you have the Attributes Categories populated as
desired, do the following to assign default Attribute Categories to document types:

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Options > Defaults.
3. Expand the Database Defaults catalog by clicking the plus sign (+) next to it.
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4. Double-click Default Attribute Categories.

The Default Attributes Categories dialog box appears.
5. Select the desired categories from the drop-down list boxes and click OK.

 

 
6. Save and exit Defaults.

If you have added Attributes to the default categories but the drop-down list boxes are empty, or if you
do not see the Attribute Categories you recently created, exit Defaults and use the Cache Manager to
update the Attributes table.

Configuring ArtiosCAD Enterprise

ArtiosCAD Enterprise gets its board information from the database. The Board and Flute browsers let
you manage paper boards, plastic boards, and foams.

Outputs in ArtiosCAD Enterprise may have their output directed to a Project in addition to a device or a
file.

Using the Flute Browser

Use the Flute browser to create and edit flutes, which are the wavy papers glued between liners to form
corrugated board. ArtiosCAD Enterprise comes with several predefined flutes.
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Opening the Flute Browser
To open the Flute browser, do the following:

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Database > Manage Boards > Flute browser.

The Flute browser opens.
 

 

The Flute Browser Toolbar
Shown below is the Flute browser toolbar.
 

 

Button Action

Inserts a new flute.
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Button Action

Deletes the selected flute.

 & 

Toggles units between metric and Imperial.

Toggles display of the Details pane.

Working with Flutes

Viewing Flute Details
To view details about a flute:

You can... Double-click the flute to select it and open the Details pane.

You can...

 Click the Details pane toggle on the toolbar and then select the flute.

The Flute browser will then look like this:
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If the Details pane is already open, simply select a flute to see its details.

Editing a Flute
To edit a flute, do the following:

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Database > Manage Boards > Flute browser to open the flute browser.
3. Select a flute and view its details.
4. Click Edit.
5. Change the values as desired.
6. Click Save.

Adding a Flute
A flute is defined by four pieces of information:

• A unique code to identify the flute. This code must be four characters or shorter.
• The flute pitch, which is the horizontal distance between the lowest parts of the wave. The pitch

must be greater than 0.
• The flute height. The height must be greater than 0.
• The take-up factor, which is the ratio between the length of the fluted paper and the length of the

board. If the flute were stretched out, it would always be longer than the paper encasing it. The
take-up factor must be greater than 1.
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To add a flute, do the following:

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Database > Manage Boards > Flute browser# to open the flute browser.
3. Click Insert on the toolbar.
4. In the Details pane, enter the code, the height, the pitch, and the takeup factor in the appropriate

fields.
5. Click Insert.

The new flute will appear in the list.

Deleting a Flute
To delete a flute, do the following:

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Database > Manage Boards > Flute browser to open the flute browser.
3. Select the desired flute.
4. Click Delete on the toolbar.
5. Click Yes to confirm the deletion.

The deleted flute is removed from the list.

Using the Board Browser

Use the Board browser to maintain the corrugated boards, folding carton boards, papers, and foams
used in ArtiosCAD Enterprise.

To work with boards, you must either be an admin user or be a member of a group that has the CAD
Boards right granted.

Opening the Board Browser
To open the Board browser, do the following:

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Database > Manage Boards > Board browser.

The Board browser opens with all the catalogs closed. Click the plus sign next to each folder to open
it. Some folders are opened in the following example.
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The Board Browser Toolbar
Shown below is the Board browser toolbar.
 

 

Button Action

Inserts a new board.

Deletes the selected board.

 & 

Toggles units between metric and imperial.

Toggles display of the Details pane.

113



5 ArtiosCAD

Working with Boards

Viewing Board Details
To view details about a board:

You can... Double-click the board to select it and open the Details pane.

You can...

 Click the Details pane toggle on the toolbar and then select the board.

The Board browser will then look like this:
 

 

If the Details pane is already open, simply select a board to view its Details.

Editing a Board
To edit a board, do the following:

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Database > Manage Boards > Board browser to open the board browser.
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3. Select a board and view its details.
4. Click Edit.
5. Change the values as desired.
6. Click Save.

Creating a paper
Papers are the building blocks of boards so you must create them before you can create boards.

To create a new paper, first examine an existing paper to determine what information you will need to
define the new paper. Papers are in their own folder in the Board browser. Usually the caliper, inside
loss, outside gain, rounding value, basis weight, and basis cost are needed. You may also set inside and
outside colors and other appearance attributes to the paper that appear in the optional 3D module.

To create a new paper, do the following:

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Database > Manage Boards > Board browser to open the board browser.
3. Open the Artios folder by clicking the plus sign next to it.
4. Click the word Papers to select it.
5. Click Insert on the toolbar.

The Details pane will automatically appear with the fields enabled for editing.
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6. Enter values in the fields on the Details tab as appropriate.
a) Board Code is the identifier used by the database to identify this new paper; each paper must

have a unique code.
b) Description is the description of the paper.
c) Caliper is the thickness of the paper.
d) Inside Loss and Outside Gain are the allowances used when folding the paper or when gluing it

together (such as in a glue flap). They are generally half the caliper.
e) Rounding Value sets a value to which dimensions may be set to round to when constructing a

corrugated design. It is more relevant for boards as a whole rather than individual papers.
f) Basis Weight is the weight of the paper in local currency and units of measurement.
g) Basis Cost is the cost of the paper in local currency and units of measurement.
h) Test Value is the amount of weight needed to break the material when performing very specific

standardized tests. It is more relevant for corrugated boards as a whole than individual papers.
i) Test Code is the identifier used in correlation with the Test Value to show the strength of the

paper. It is more relevant for corrugated boards than individual papers.
j) Weight and Cost in the Adhesive group should be set for the complete board definition, not

individual paper and flute definitions.
7. Leave the fields on the Papers tab blank, as they are not relevant.
8. On the Material Properties tab are fields to set the shininess, transparency, and inside and outside

colors of the paper. These properties are only visible in the optional 3D module.
 

 
a) Set the Shininess% and Transparency% fields as desired. The Transparency% field is a

separate setting from transparency mode in 3D and is not affected by that setting.
b) Surface colors for papers are split into three components: ambient color, which reflects the

ambient light; diffuse color, which reflects the movable lights in an airy, non-shiny way; and
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specular color, which reflects movable lights for a shiny surface, with a shiny surface having a
white specular color and a dull surface a black specular color.

c) By default, the Material Properties tab only displays Diffuse color in Simple color mode. In Simple
color mode, choose a color by clicking Select color. To set the other two colors, click Advanced
color, and then click Select color as desired.

d) The outermost Outside paper color is used to set the Outside board color if no other color has
been manually chosen for the outside of the board. Likewise, the innermost Inside paper color
is used to set the Inside board color if no other color has been manually chosen for the inside of
the board.

e) The ... button (Browse) is used in board definitions to calculate the color based on the materials
comprising the board. It is not relevant for papers.

9. On the Texture tab are fields to specify the graphics that may be used to represent the inside,
outside, and edge textures of the paper. These properties are only visible in the optional 3D module.
Outside and inside textures are more relevant for boards, but may also be defined for papers, while
board edge textures do not apply to papers.
 

 
a) To add an inside or outside texture to the paper, click the checkbox for it, and then specify the

location of the graphic file for the texture, or click ... (Browse) to the right of the filename field
and select it. Some common textures are stored in the Boards folder of the Shared Defaults
Project. The image should be of the board surface with vertical grain or corrugation direction.
If you use a custom image, measure the sample when you take its picture so that you know its
size; you may need to touch up the image in a graphic editing program so that the edges blend
together when the image is tiled.

b) In the Image height field, enter the height of the image. The size needs to be set in order for
ArtiosCAD to scale the picture appropriately. If the height is set to 0, the image will be scaled
proportional to the width.

c) Set the value in the Image width as number of flutes drop-down list box to the number of flutes
the image represents. The image should be of a whole number of flutes. It may also be set to
Proportional to height, in which case the height cannot be set to 0.

d) Shown below is boardbrown.jpg from the Boards folder of the Shared Defaults Project, an
example board texture three flutes wide:
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10. When you have finished defining the paper, click Insert to add the new paper definition.

Note:

Foams are defined in the same way as papers, just with larger dimensions.

Adding a Board
To add a board, do the following:

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Database > Manage Boards > Board browser.
3. Click the plus signs next to folders to open them.
4. Boards are hierarchical. Right-click an item a level above the desired level for the new board (such

as Boards to add the new board at the top level or Artios > Corrugated Boards > C to add a new C
flute board) and click New > Board. (You may also create a new folder in this manner.)

• You may also select the parent item and then click Insert on the toolbar to create a new board.
To create a new folder, you must use the right-click method described above.

The Details pane will automatically appear with the fields enabled for editing.
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5. Enter values in the fields on the Details tab as appropriate.

a) Board Code is the identifier used by the database to identify this new board; each board must
have a unique code.

b) Description is the description of the paper.
c) Caliper is the thickness of the paper.
d) Inside Loss and Outside Gain are the allowances used when folding the paper or when gluing it

together (such as in a glue flap). They are generally half the caliper.
e) Rounding Value sets a value to which dimensions may be set to round to when constructing a

corrugated design. It is more relevant for boards as a whole rather than individual papers.
f) Basis Weight is the weight of the board in the selected system of units of measurement. Clicking

the ... (Browse) button at the end of the field displays the Calculated Basis Weight dialog box. In
this dialog box is an analysis of the calculated weight of the board based on the papers used to
make it. To replace a manually-entered weight with the calculated weight, click Accept.

g) Basis Cost is the cost of the board in local currency and units of measurement. As with the
Basis Weight field, the ... (Browse) button at the end of the field displays an analysis of the
calculated cost of the board based on the papers used to make it. To replace a manually-entered
cost with the calculated cost, click Accept.

h) Test Value is the amount of weight needed to break the material when performing very specific
standardized tests.

i) Test Code is the identifier used in correlation with the Test Value to show the strength of the
paper.
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j) The Weight and Cost fields in the Adhesive group are the respective weight and cost of the
adhesive for the board as a whole.

6. The Papers tab contains drop-down list boxes to select the liners and mediums that comprise the
board.
 

 
a) If you know it already, type the flute code of the new board in the Board Flute field. At the end of

the field is a ... (Browse) button that opens the Calculated Flute dialog box. Use this to calculate
the flute code after defining the liners and mediums for the board. If it is a single board, expect a
flute code like C. Double wall could be BC, while triple- and quadruple-wall would comprise four
letters.

b) Boards are defined sequentially from the outside inward. For example, you must select Liner 2
before you may select Medium 2. You may not select Liner 2 and then jump directly to selecting
Liner 4.

c) Select liners and mediums in their respective drop-down list boxes. As you select a liner and
then a flute, the Flute drop-down list box for that pair becomes available. You must select a flute
before the next liner becomes available for selection.

d) Complete the paper selection process with a liner.
7. On the Material Properties tab are fields to set the shininess, transparency, and inside and outside

colors of the board. These properties are only visible in the optional 3D module.
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a) Set the Shininess% and Transparency% fields as desired. The Transparency% field is a

separate setting from transparency mode in 3D and is not affected by that setting.
b) Surface colors for papers are split into three components: ambient color, which reflects the

ambient light; diffuse color, which reflects the movable lights in an airy, non-shiny way; and
specular color, which reflects movable lights for a shiny surface, with a shiny surface having a
white specular color and a dull surface a black specular color.

c) By default, the Material Properties tab only displays Diffuse color in Simple color mode. In Simple
color mode, choose a color by clicking Select color. To set the other two colors, click Advanced
color, and then click Select color as desired.

d) The outermost Outside paper color is used to set the Outside board color if no other color has
been manually chosen for the outside of the board. Likewise, the innermost Inside paper color
is used to set the Inside board color if no other color has been manually chosen for the inside of
the board.

e) The ... button (Browse) calculates the color based on the materials comprising the board. Click
Yes to use the color of the paper; click No to use the color of the current board definition.

8. On the Texture tab are fields to specify the graphics that may be used to represent the inside,
outside, and edge textures of the board. These properties are visible only in the optional 3D module.
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a) To add an inside or outside texture to the board, click the checkbox for it, and then specify the

location of the graphic file for the texture, or click ... (Browse) to the right of the filename field
and select it. Some common textures are stored in the Boards folder of the Shared Defaults
Project. The image should be of the board surface with vertical grain or corrugation direction.
If you use a custom image, measure the sample when you take its picture so that you know its
size; you may need to touch up the image in a graphic editing program so that the edges blend
together when the image is tiled.

b) In the Image height field, enter the height of the image. The size needs to be set in order for
ArtiosCAD to scale the picture appropriately. If the height is set to 0, the image will be scaled
proportional to the width.

c) Set the value in the Image width as number of flutes drop-down list box to the number of flutes
the image represents. The image should be of a whole number of flutes. It may also be set to
Proportional to height, in which case the height cannot be set to 0.

d) If using a custom board edge texture on a double, triple, or quadruple wall board, the board edge
texture has to be a whole number of all the flutes. The largest flute is used initially, then the
smaller flutes are adjusted by a few percent to align a whole number of the smallest flutes with
a whole number of the largest flute. Knowing how many flutes the image represents is critical.
To determine this, start with the board defined but with no custom edge texture. Export the 3D
workspace to VRML and then view the associated PNG files created. One of those will be of the
board edge texture. Count the number of flutes for the largest board and set the Image width as
number of flutes field to the same number.

e) Shown below is boardbrown.jpg from the Boards folder of the Shared Defaults Project, an
example board texture three flutes wide:
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f) To specify a graphic for the board edge texture, check the Board edge texture checkbox, then

specify the filename of the graphic file for the texture, or click ... (Browse) to the right of the
filename field and select it. Some common textures, for example paper corrugated edges,
plastic corrugated edges, and paper hexacomb flutes, are stored in the Boards folder of the
Shared Defaults Project. The height of the image for a corrugated board should be the board
caliper, and the width should be a whole number of flute pitches. Folding carton boards use an
image width proportional to the height.

g) If no texture is specified for a corrugated board edge, a default picture based on the height and
pitch of the flutes is used.

h) Stretch like corrugations stretches the picture of the board edge texture depending on its
angle to the grain/corrugation direction. If this option is not selected, the board edge texture is
repeated evenly.

i) Shown below is a picture of the default board edge texture with Stretch Like Corrugations
turned on in a design in 3D:
 

 
j) Shown below is a picture of the BrownB board in the Textured Corrugated folder with Stretch

Like Corrugations turned off in a design in 3D:
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9. On the Locations tab, set those locations for which this will be a default board. Users at locations

that are not checked in this step will have to click Show All Boards every time they create a design
in order to see this board.
 

 
a) Check Show All Locations to see all the locations defined.
b) Click Edit.
c) Select the checkboxes next to the locations for which this will be a default board. Use the

buttons on the right side of the dialog box to select or clear all locations.
d) Click Save to set the locations in which this board will be visible.

10. When you have finished defining the board, click Insert to add the new board definition.

Renaming, Deleting, Moving, and Copying Board Entries
The Board browser supports multiple item selection, dragging and dropping of entries, cutting and
pasting of entries, and right-clicking entries to perform functions on the context menu.

To create a folder, select its parent item (the one a level above its desired position), right-click it, and
click New > Folder on the context menu. The folder name must be unique among same-level folders in
the same parent folder.
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To rename a folder, select it, right-click it, click Rename on the context menu, enter the new name, and
press Enter.

To delete a folder, first make sure it is empty, and then select it, right-click it, and click Delete on the
context menu. You may not delete a non-empty folder.

To rename a board, edit it and change its description. This change will not be communicated back into
unmanaged documents using this board.

To move a folder or a board, drag it from one location to another.

To copy a board definition, select it, right-click it, and click Copy on the context menu. Right-click the
folder into which it will be pasted and click Paste on the context menu. When the board is pasted into
the new folder, the current system time will be appended to the board code to maintain board code
uniqueness.

Defaults

Defaults for ArtiosCAD Enterprise have only a few operational differences from other versions of
ArtiosCAD.

• All users must be invited to the Shared Defaults Project for each version and language of ArtiosCAD
Enterprise they will be using. See the major Step 8 section of the installation instructions for more
information.

• For users other than admin to edit Shared Defaults, they must have Full permissions on the Shared
Defaults Project and be members of the ADMINS group. To create or change Location Defaults or
User Defaults, they do not have to be members of ADMINS, but they must have View, Add, Update,
and Lock permissions on the entire Project.

• As a best practice, we strongly recommend that you place new Defaults reference documents
into the ServerLib folder (or a new unique user-defined folder) of the Shared Defaults Project
for documents which need to be shared by all users. Please note that document names must be
unique within a Project. For new Defaults reference documents which will only be used by you,
place these in a new user-defined folder of your User Defaults Project. If you must change an
existing ArtiosCAD-installed Defaults reference document, we recommended that you copy it as a
new document to the ServerLib folder and then update the Defaults to reflect the new document
name. Following these recommendations gives ArtiosCAD Enterprise the best chance of properly
managing upgrades.

• If you change the username of a user, you must change the name of that user’s associated Defaults
project to match.

Browser Options
You can set browser options by clicking Options > Defaults > Browser Settings > General Information.
As admin you can change the Shared Defaults, and you may be able to change your Location Defaults,
but in most cases as any user you can change your own User Defaults.
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Note that you will only see the Defaults for the Task Browser if your WebCenter system has Task
Management.

Click OK to return to Defaults once you have set the options as desired.

Bill of Materials Dialog Box Options
You can set BOM dialog box options by clicking Options > Defaults > Database Defaults > Bill of
Materials Dialog.
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Show dialog maximized forces the BOM dialog to always be full size.

Choose the columns the BOM dialog box will show in the Available Columns pane. To rename a column,
select it and enter its new name in the Column Title field.

In the BOM dialog box itself, use Save Dialog Configuration and Load Dialog Configuration on the
View menu to save aspects of the dialog box such as size, position, and customized columns and then
restore them as the same user on another computer.

Customized Database Information dialog boxes
To define custom Database Information dialog boxes for different types of documents in ArtiosCAD
Enterprise, click Database Defaults > Database Information Dialogs.
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Click the button corresponding to the type of document you want to have a customized database
information dialog box. For more information, see Designing a custom Database Information dialog box
in the Defaults chapter.

If you design a custom database information dialog box, make sure to set the default attribute category
for that type of document in Database Defaults > Default Attribute Categories so that the dialog box
design utility knows the proper Attributes to use with the document.

General Database Options
You can set database options by clicking Options > Defaults > Database Defaults > General Options.
As admin you can change the Shared Defaults and Location Defaults, but in most cases as any user you
can change your own User Defaults.
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The options in the Database Information Dialog Options group control when you are prompted to enter
database information about a document: when you create it, when you save it, both, or neither. If you
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do not select either option, users must click Database > Information while working on a document to
set its database information.

In the Board Options group, you can choose to check to see if a board code has changed when users
open documents, and you can choose how they are sorted in the Board Catalog.

The options in the Cache Options group control how often ArtiosCAD Enterprise updates the cache.
ArtiosCAD has different timers for Projects, documents, drafts, Defaults Projects, and Defaults
documents. See the discussion on using the cache manager in Using ArtiosCAD Enterprise for more
information about the cache.

In the Document Thumbnail Options group, Create document thumbnails on server controls whether
ArtiosCAD Enterprise creates document thumbnails (deselected, the default choice) or if WebCenter
creates the thumbnails (selected).

Choose the thumbnail format in the Design Thumbnail Format group.

The New Project Options group has a Template drop-down list box. Use this to set the default
Template ArtiosCAD will use for new Projects you create through the browser. However, this does not
apply to Projects used for Defaults.

The settings in the Comment Options group control how ArtiosCAD manages comments when saving a
managed document.
 

 

To turn on the automatic commenting, check Preseed comment from previous version. This also
enables the options in the Initial Comment group.

Use document description copies the document description to the comment field. If there is no
document description, ArtiosCAD will prompt you for a comment. This will also cause the Project
description to seed the document description when you save a managed document for the first time so
that on the next save, the comment will be able to be seeded from the description.

User defined lets you enter a custom string that ArtiosCAD will use for the first comment.

Save Options
To set options for saving documents, click Options > Defaults > Startup Options > Save Options..
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To choose what happens when you click Save, choose either Save as Draft or Save as New Version.

In the For Save As group, Show Save button as dropdown button and Show “Save” and “Save As Next
Document” button control what happens in the Save As dialog box. This is meant to reduce the number
of clicks for those who prefer to save as the next document.

When you save an unmanaged document, the browser seeds itself to the folder out of which the
document came, and it can be tedious to scroll back the most recent managed location you were using.
Enable When saving unmanaged documents, set the Save As Browser to the Recent Projects node to
reduce the amount of scrolling needed to save the file to a managed location.

The Project grid can take a long time to show if you have many Projects and/or linked documents. Use
Show Project selection grid to turn the grid on and off to improve performance. See the next section
for more information.
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When you save a linked document, ArtiosCAD Enterprise only updates the home Project of that
document. To default to always updating all related Projects, check Always turn on Update All Related
Projects.

In the Bill of Materials Options group, Always turn on Add New Revision to Bill of Materials controls
the state of the Add to Bill of Materials checkbox or column when doing a Save As, Publish Version,
or Publish Revision. Always turn on Update New Revision to Bill of Materials similarly controls the
default state of the Update Bill of Materials checkbox or column.

Note that Publish Version allows you to add the document to the BOM but not to update the BOM if the
document is already in it.

Click OK to save your changes and return to Defaults.

Destination Folders
Destination Folders let you configure where ArtiosCAD saves different file types and parts when saving
a document.
 

 

Several file types offer these options:

• Automatically save into this project folder saves the file into the Project folder you specify. When
this option is checked, Create this folder if it doesn’t exist becomes available.

• Allow saving to root folder allows ArtiosCAD to save the file in the root level of the Project.

Canvas Parts: As the message says,you can set or change the destination folder for canvas parts under
Startup Defaults  >  Canvas >  Parts Options.

Showing or Hiding the Project Selection Grid
If you have many Projects and/or linked documents, it can take some time for ArtiosCAD to get the
list of Projects from WebCenter when publishing a version or revision. Use Show Project selection
grid in Options > Defaults > Startup defaults > Save Options to control if ArtiosCAD shows the Project
selection grid (the default) or instead does not show the grid and instead shows Specify Projects that
then shows the grid.

Shown below is the Save Managed Document dialog box with the grid turned off.
 

132



5ArtiosCAD

 

Setting the Default Folder for Saving Parts in Canvases
In the Canvas/Parts Options dialog box under Startup defaults, an option specific to ArtiosCAD
Enterprise is Default Folder For Saving Parts.
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Default Folder For Saving Parts in the Save Parts Dialog Settings lets you specify a default folder in
a Project for saving parts, which ArtiosCAD Enterprise will create if it does not exist. When you save
parts, this folder in the Project will be the default location

Note:

Because WebCenter supports only one level of folders in a Project, you cannot specify a multi-
level hierarchy such as folder1\folder2\folder3 for the default folder. ArtiosCAD
Enterprise would create a folder with that name.
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Export Document Naming Format Options
When you Output a version of a managed file in a different format for use by someone else, Save
revisioned document name with version number in Options > Defaults > Startup defaults > Export
Document Name Format adds the revision letter and version number to the filename.
 

 

ArtiosCAD Enterprise separates the parts of the filename with underscores. First is the name of the
managed document, then the revision letter, and last the version number.
 

 

Note:  This option applies to all file-based Outputs.

Sending an Output to a Project
In ArtiosCAD Enterprise, you can direct an Output to go to a Project instead of a device or file.

Destination Tab in an Output Definition
Outputs that create files can send those files to Projects rather than directories by choosing the
appropriate options on the Destinations tab.
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When you select Output To Project, many options become available for setting Project and document
names and properties. If you choose any of the prompt options, when you run this Output, the Project
Browser appears so you can navigate to the desired Project, set the document and folder names, and
enter any prompted information.

If Automatically Open is selected in an Output that goes to a Project, a temporary version of the Output
is downloaded to your computer and the appropriate program for the type of Output opens it. In the
example above, the PDF file is saved to the Project, and then a temporary copy is downloaded and
opened by the application registered to open PDFs on your system.

Setting the Title Bar Display Options
You can choose which revision and version information ArtiosCAD shows in the title bar. The Title Bar
Options dialog box in Options > Defaults > Startup defaults presents different formatting options.
Choose the preferred option and click OK.
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Location Defaults Overview
Location Defaults are an intermediate level of Defaults between User Defaults (used first) and Shared
Defaults (used last). Each user must be assigned a location and be invited to the appropriate Location
Defaults Project in order for that user to use Location Defaults.

A user who is a member of the ADMINS group must do the initial creation and configuration of the
Location Defaults for each location.

Members of ADMINS may also control which categories of Location and User Defaults users may set by
using Defaults Availability, covered later in this section.

There are three steps involved in configuring Location Defaults:

1. Perform the Location Defaults Setup on the Options menu logged in as a member of ADMINS with a
location set.

2. Use Defaults Availability on the Options menu to set which Defaults are available to users.
3. Add Defaults as desired to Location Defaults in the same way as you would to User Defaults or

Shared Defaults.
4. Invite the users of a location to the Location Defaults Project and set their permissions. For non-

ADMINS users to be able to create Location Defaults, they must have View, Add, Update, and Lock
permissions on the entire Location Defaults Project.

Location Defaults Setup
Only members of ADMINS can set up Location Defaults. Location Defaults may optionally be based on a
Template that has the desired members, permissions, and contents already set.

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Database > Change Location and choose the company and location for which you want to set

up Location Defaults. This only temporarily assigns your company and location for this ArtiosCAD
session.

3. Click Options > Location Defaults Setup.
4. Select the appropriate location and click Create Defaults.
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5. In the Create New Project dialog box, change the description and choose a Template, customer

name and location, if desired, and click OK. You may not change the name of the Project, and any
invalid characters in the company or location name are replaced with underscores (_). Invalid
characters for Project names are ", *, :, /, \, ?, <, >, |, =, ;, [, ], ^, @, and a space. See the next section
for information about creating a Template to use with Location Defaults.
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After it creates the new Location Defaults Project, ArtiosCAD changes the Location Defaults Setup
dialog box so that the other commands are available.
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Open in Web Browser opens this Location Defaults Project in WebCenter using your default Web
browser. You can then invite members, configure permissions, and so forth.

You can also migrate existing ArtiosCAD Standard Edition Shared Defaults or User Defaults into
Location Defaults. Note that for User Defaults, you must currently be using the machine holding the
User Defaults in order to migrate them.

Now when you open Defaults in ArtiosCAD, you can add items to the Location Defaults pane just as you
would for Shared Defaults or User Defaults.
 

 

Creating a Location Defaults Project Template

To create a Template to use as the basis for Location Defaults Projects, do the following:

1. Log into WebCenter as a member of ADMINS.
2. Create a new Project to serve as the Location Defaults Template. Do not define autonaming in this

Project as that has no effect for a Location Defaults Project.
3. Invite users to the Project and set their permissions.
4. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.

a) Click Options > Defaults, click User defaults to activate that pane, and then click File > New to
create a new set of Defaults.
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b) In the New defaults pane, create new Defaults as desired by dragging and dropping from Shared
Defaults or by creating new ones by right-clicking.

c) Make any desired changes to these new Defaults.
d) Click File > Save As > File and save the file locally as locationdflt.adf. It must have this

exact name.
e) Click File > Exit to exit Defaults and return to ArtiosCAD.

5. In WebCenter, upload the file you created in the previous step to the root level of the Project serving
as the Location Defaults Template.

6. Save this Project as a Template. It is now ready to be selected when you perform Location Defaults
Setup for a location.

Migrating Defaults from ArtiosCAD Standard Edition to ArtiosCAD Enterprise
After you have set up Location Defaults, you can choose to migrate Shared Defaults or User Defaults to
the new Location Defaults.

Note:

Migrating existing Shared Defaults or User Defaults to Location Defaults will overwrite any
existing Location Defaults. It is a good idea if your current Location Defaults have data in
them to back up your Location Defaults using the browser. Drag the current Location Defaults
Project to a location in the Explorer node before you begin so that you have them as a backup.

1. Still in the Location Defaults Setup dialog box, click either Migrate Shared Defaults to Location or
Migrate User Defaults to Location. Note that the potential User Defaults must be from the current
machine.

2. Click Yes in the warning dialog box to migrate the Location Defaults.
3. in the Defaults Migration Dialog box, choose the version of ArtiosCAD containing the desired

Defaults and click OK. This process may not be canceled or aborted, so proceed with caution if you
are unsure and click Cancel if you have any doubts.
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4. A progress bar will appear as ArtiosCAD uploads the Defaults to WebCenter.

 

 
5. When the upload is complete, you will return to the Location Defaults Setup dialog box. Click Open

in Web Browser to go to the Location Defaults Project in WebCenter, or click Close to return to
ArtiosCAD.

Two important notes about the Defaults migration process:

• When you migrate Defaults from ArtiosCAD Standard Edition to Location Defaults in ArtiosCAD
Enterprise, data files that the Shared or User Defaults reference remain on the local computer.
The Defaults will continue to work as long as the files on the local computer exist. To get them
fully into Location Defaults without relying on the local computer, use the Explorer node of the
browser to manually drag any referenced files from ServerLib into the appropriate folders inside
the Location Defaults Project, and then update the references in Location Defaults to point to the
correct documents.

• Likewise, if the User Defaults you migrated reference ArtiosCAD Standard Edition Shared Defaults,
the referenced information is not migrated. For example, if you have a custom toolbar defined in
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User Defaults that reference Outputs that use files (such as Reports) or geometry macros, the
toolbar itself will be migrated into Location Defaults but the Report files and geometry macros will
not be. Use the Explorer node of the browser to manually drag any referenced files from ServerLib
into the appropriate folders inside the Location Defaults Project, and then update the references in
Location Defaults to point to the correct documents.

Migrating User Defaults from ArtiosCAD Standard Edition to ArtiosCAD Enterprise
If users who are Project Managers decline to migrate their User Defaults from ArtiosCAD Standard
Edition to ArtiosCAD Enterprise upon their first launch of ArtiosCAD Enterprise, they can manually
start the migration afterward.

Note:  Users who are not Project Managers do not have this menu command available as
since they may not create their User Defaults Projects themselves. Instead, they must have
a member of ADMINS create their User Defaults Projects, invite them to their User Defaults
Projects, and set their permissions to at least Delete and Upload.

1. Logged in as the appropriate user, click Options > Migrate User Defaults from Conventional
ArtiosCAD.

2. Click Yes in the warning dialog box to migrate the User Defaults.
3. in the Defaults Migration Dialog box, choose the version of ArtiosCAD containing the desired

Defaults and click OK. This process may not be canceled or aborted, so proceed with caution if you
are unsure and click Cancel if you have any doubts.
 

 
4. A progress bar will appear as ArtiosCAD uploads the Defaults to WebCenter and will disappear when

the process is complete.
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Always Showing All Boards

When users do not have default boards assigned to their locations, when they create a new design or
look at the Board Information dialog box, they will not see any boards. To solve this problem, Always
show all in boards selection in the Default boards catalog in Design defaults is enabled by default.
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Turn this option off after you have assigned each location a default board set, else toggling Show All
Boards will not have much effect.

Defaults Availability overview

Defaults Availability on the Options menu gives members of ADMINS control over the types of Defaults
users may create and use in Location Defaults and User Defaults. For example, you may want to force
users to use a particular die press parameter set and not let users create new die press parameter
sets or modify the existing die press parameter set. Setting the Project permissions appropriately
prevents the modification of the die press parameter set in Shared Defaults, and using the settings in
Defaults Availability can prevent them from creating a new parameter set in User Defaults that would
take precedence over the ones in Location Defaults or Shared Defaults.

Defaults Availability has two modes. As a member of ADMINS, you can:

• set the availability of items in Location Defaults for all locations of all companies
• set the availability of items in User Defaults for multiple locations of your assigned company

simultaneously. If you do not have a company assigned, this option will be unavailable; click
Database > Change Location to set a temporary location before using Defaults Availability.

Setting Defaults Availability for Location Defaults
To set the availability of defaults in Location Defaults for all companies and all locations, do the
following:

Note:

Any Defaults categories you clear in this procedure become unavailable in all User Defaults as
well.

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Options > Defaults Availability.
3. In the Defaults Availability Setup dialog box, click Set defaults availability for location defaults if it

is not already selected.
4. Clear the checkboxes next to the Location Defaults categories to which you want to deny users

access. Right-click the column header to check all the checkboxes, clear all the checkboxes, or
invert the selection. Any categories you clear in this step will also become unavailable in all User
Defaults as well.
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5. Click Save when you are done checking and clearing checkboxes.
6. Change the mode selector to Set defaults availability for user defaults to make those changes, or

click Close to return to ArtiosCAD.

Setting Defaults Availability for User Defaults
To set the availability of defaults in User Defaults for all users at selected locations of your company, do
the following:

Note:  If you do not have a company assigned, this option will be unavailable; click Database >
Change Location to set a temporary location before using Defaults Availability.

1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Options > Defaults Availability.
3. In the Defaults Availability Setup dialog box, click Set defaults availability for user defaults.
4. Select one more or locations containing the users to whom you are denying access.
5. Clear the checkboxes next to the User Defaults categories to which you want to deny users access.

Right-click the column header to check all the checkboxes, clear all the checkboxes, or invert the
selection.
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6. Click Save when you are done checking and clearing checkboxes.
7. Click Yes in the warning dialog box about overwriting defaults availability.

a) If any the locations you selected do not yet have Location Defaults Projects set up for them,
ArtiosCAD will prompt you to create a Project for each as needed.
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8. ArtiosCAD displays a progress bar as it makes the changes to Defaults.

 

 
9. Click Close in the Defaults Availability Setup dialog box to return to ArtiosCAD.

Configuring the Automatic Naming Templates

There are three places in WebCenter to configure automatic naming - in Admin > Preferences >
General for Projects and in Admin > Preferences > Document Types for documents. For Templates,
to override the system default autonaming configuration for Projects and documents inside that
Template, it is in Admin > Projects > Templates > <template> > Configure > Project Creation or
Document Creation.

The naming templates control the prefix, body, and sux ArtiosCAD Enterprise uses when it names
Projects and documents automatically. The body is a counter that increments independently for each
Project or document.

To configure the naming templates, do the following:

1. Start a Web browser and log in to WebCenter as a member of the ADMINS group.
2. For Projects, click Admin > Preferences > General.

a) Check Use Automatic Naming for Creation of Blank Projects.
b) In the Project Autoname Generation section, enter the building blocks of the prefix and sux in

the appropriate fields. Make sure to use spaces or other delimiters (not commas) between the
fields, else they will run together and the counter will not increment correctly.

c) For a list of the building blocks you can use for the prefix and sux, click Help at the top right
of the page. Make sure to read the notes at the bottom of the page for restrictions. The building
blocks are case-sensitive. DO NOT USE COMMAS IN THE PREFIX OR SUFFIX.
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d) Click +[ ] to use SmartNames to define the prefix or sux. If you want to be able to enter your
own text in the name at creation time, use the Edit Field SmartName as a building block.

e) In the Counter Length field, enter the length of the incremental counter that will form the body
of the Project/document names between the prefix and sux. For example, enter 5 for numbers
that will be five digits long.

f) Click Save to make the changes.
3. For documents, click Admin > Preferences > Document Types.

a) Check Apply Automatic Naming to Documents in Blank Projects.
b) In the Automatic Document Naming column, change the drop-down list box from None to

Custom for each desired document type.
c) Enter the building blocks of the prefix and sux in the appropriate fields. Make sure to use

spaces or other delimiters (not commas) between the fields, else they will run together and the
counter will not increment correctly.

d) For a list of the building blocks you can use for the prefix and sux, click Help at the top right
of the page. Make sure to read the notes at the bottom of the page for restrictions. The building
blocks are case-sensitive. DO NOT USE COMMAS IN THE PREFIX OR SUFFIX.

e) Click +[ ] to use SmartNames to define the prefix or sux. If you want to be able to enter your
own text in the name at creation time, use the Edit Field SmartName as a building block.

f) In the Counter Length field, enter the length of the incremental counter that will form the body
of the Project/document names between the prefix and sux. For example, enter 5 for numbers
that will be five digits long.

g) For Scope of the Counter, choose either Reset per Project to restart the document counter for
each Project or System wide Counter to use the same counter for every document.

h) Repeat for other document types as desired.
i) Click Save to make the changes.

4. For Templates, to use custom autonaming with Projects and documents based on a Template, click
Admin > Project Management > Templates.
a) Click the name of the Template to change.
b) Click Configure.
c) Click Project Creation or Document Creation.
d) For Projects, make sure Use Automatic Naming is selected, and then click Use Custom

Automatic Naming. Configure the options as described above in step 2. For documents, for
the desired document type, change the Automatic Document Naming drop-down list box to
Custom. Configure the options as described above in step 3 and repeat for other document
types as desired.

e) Click Save to make the changes.
5. Log out of WebCenter and close your Web browser.

Using Spot Colors in PDF files

You can configure PDF Outputs to use spot colors for the line color definitions instead of using plotting
style information. To make this change, it is best to copy an existing PDF Output to a new one in
Defaults and change its name, and then modify the new entry.

On the Device Type tab of the Output, click the Browse control at the end of the Tuning Filename field
and navigate to the Tuning Files folder in the Shared Defaults Project. C
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1. Launch ArtiosCAD Enterprise and log in as a member of the ADMINS group.
2. Click Options > Defaults.
3. In Shared Defaults, copy an existing PDF Output to an entry with a different name, such as Plot to

PDF using spot colors.
4. Double-click the new entry and click the Device tab.
5. Click ... (Browse) at the end of the Tuning Filename field.

a) In the Project pane of the browser, navigate to the Shared Defaults Project and expand it.
b) Click the Tuning Files folder.
c) Change the filetype selector to All files (*.*).
d) Click Tune.PDF.SpotColors.xml and then click Open. The entry in the Tuning Filename

field should change accordingly.
 

 
6. Click OK to make the change.
7. Click File > Exit and click Yes when asked to save and then overwrite the Defaults.

Shown below are the Ink Manager palettes for two PDF versions of the same single design, one using
the default method and the other using the spot colors method.
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To change the ink names, RGB color values, stroke widths or stroke styles used by this method, make
the changes in PDFSpotColorMap.xml.

Setting CIF Default Values for Cape Pack

If you use Cape Pack with ArtiosCAD Enterprise, you can use calculated expressions and Attributes
to send to Cape Pack for Reports. Otherwise, setting the CAPE Defaults is the same as for Standard
Edition.

1. Start ArtiosCAD.
2. Click Options > Defaults.
3. In the list of Shared defaults, scroll down to the Palletization catalog and open it by clicking the plus

sign (+) next to it.
4. Double-click CAPE Defaults.

The Cape Pack Defaults dialog box opens as shown below.
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5. To customize the Customer Information Field data appearing on Cape Pack Reports, click

Customize CIF Fields in the Report group.
6. Choose a calculated expression or Attribute by clicking the Browse (…) button.

 

 
7. Click OK to return to Defaults when you are done setting the CAPE Defaults.
8. Click File > Save to save the changes.
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9. Click Yes to confirm the saving of the changes to Defaults and return to ArtiosCAD.

Exporting Defaults

You can export Defaults to send them to Esko for help, to use them at another site, or for backup.

1. Click Options > Defaults.
2. Click File > Export to ZIP File.
3. Choose how to export them.

a) With Folders is meant for use at another site or as backup.
b) Without Folders is meant for use by Esko for diagnostic purposes.

4. Click the level of Defaults to export - Shared, Location, or User.
5. In the Save As dialog box, choose a folder and enter a filename for the ZIP archive, then click Save.
6. ArtiosCAD Enterprise saves the ZIP archive. If there are many Defaults, it displays a progress bar.

 

 

Migrating from ArtiosCAD Standard Edition to ArtiosCAD
Enterprise

ArtiosCAD Enterprise has a tool that migrates information and documents from your existing
ArtiosCAD Standard Edition installation into ArtiosCAD Enterprise. The migration tool analyzes the
ArtiosCAD Standard Edition database and compares it to the WebCenter database. Data that already
matches is not migrated.

Using the migration tool requires that both ArtiosCAD Standard Edition and an ArtiosCAD Enterprise
client be installed on the same computer.

There are two parts to the migration:

• entity migration, which is metadata such as boards, companies, persons, characteristics, and
userfields

• asset migration, which are the design documents themselves.

You must do the entity migration before the asset migration so that the migration tool creates the
documents and Projects in WebCenter with the correct data. The tool has many configuration options
for how it creates new Projects in WebCenter.
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Migration can be complicated and it takes a fair amount of time. You should have a thorough
understanding of how your current ArtiosCAD Standard Edition database is set up and if you want to
preserve that same structure in WebCenter and thus ArtiosCAD Enterprise.

Before You Begin

Before you begin the process of migrating from ArtiosCAD Standard Edition to ArtiosCAD Enterprise,
there are some considerations you should address beforehand.

• Username strategy. The migration tool will create WebCenter/ArtiosCAD Enterprise users from
persons defined in the ArtiosCAD Standard Edition database. Decide upon a username creation
convention. If the ArtiosCAD persons are real network users, use the WebCenter LDAP migration
utility beforehand so that they can use their network credentials to log in.

• Sux strategy. In several places you can specify suxes that are appended to newly created items
in case they conflict with existing items. Decide on suxes to use. You can create different suxes
per migration run and/or set of saved location mapping if desired.

• Migration ADMINS user. A WebCenter/ArtiosCAD Enterprise user who is a member of ADMINS
is the user who performs the migration. This user may also potentially be the Project manager
for thousands of migrated Projects and owner of thousands of documents. This user must have
a location assigned and the mapping for that location must be saved to the server so that the
automatic conversions function properly. It is a good idea to create a separate ADMINS user for the
migration.

• Attributes creation. The migration tool migrates a lot of metadata from ArtiosCAD Standard Edition
into WebCenter Attributes. For this to work, the Attributes must already exist in WebCenter before
you start the migration tool. Refer to the sections on migrating entities, characteristics, and
userfields for more information.

• Attributes setup. For unmanaged files to work correctly when uploaded to WebCenter/ArtiosCAD
Enterprise, the Default Attribute Categories set in ArtiosCAD Enterprise (Options > Defaults >
Database Defaults > Default Attribute Categories) need to match those set on the Design Data
tab of the migration tool and in WebCenter. In WebCenter as a member of ADMINS, click Admin
> Preferences > Document Types and make sure that Apply Default Attribute Categories to
Documents in Blank Projects is checked and that the entries in the Default Attribute Category
column are set correctly.

• Tidy existing data. Before you begin the migration, clean up the ArtiosCAD Standard Edition
database using DataCenter Admin. For example, delete unused companies and boards. Do an
AutoLoad to make sure all the information in the design documents is in the database.

There are also several restrictions of which you should be aware.

• The calculated area userfield in ArtiosCAD Enterprise may show incorrectly when using metric units
due to a conversion factor discrepancy. When comparing results after migration, the ArtiosCAD
Enterprise value might be 100 times larger than the correct value shown in WebCenter.

• The calculated weight userfield using the #BRDWTG system variable shows the same value in
Imperial and metric units. It is correct in WebCenter.

• If you used an old migration tool before this one, calculated expressions may have been migrated
to prompted Attributes. If you want them to become calculated again, delete these prompted
Attributes before performing the migration and the migration tool will create them properly.
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Customizing the Migration Tuning File

Before you perform a migration, you should determine if you need to customize how the migration
tool works. The migration tool uses an XML tuning file to store its configurable parameters. That file is
located in $ARTIOSDIR\Migration, and is called ECADMigrationTuning.xml. An XML file is a
text file that can be edited in any text editor.
 

 

At the beginning of the file are fields for the default WebCenter site and username, as well as for the
default tolerance for length comparisons, weight comparisons, and the basis weight comparison
tolerance.

The contents are then divided into sections containing options for tuning different aspects of the
program. Most of the entries control the relative importance of different fields when the migration tool
compares values in the ArtiosCAD Standard Edition database with any values which may already exist
in the WebCenter database. If it determines that the values do not match, the migration tool makes a
new entry in the WebCenter database.

The Match Confidence entry controls how closely the values must correlate in order for the migration
tool to consider them matching. A higher value means the migration tool creates more new entries
in WebCenter. A lower value means the migration tool uses more existing values even if they do not
exactly match.

155



5 ArtiosCAD

Flute Matching
For flute matching, the migration tool compares case-insensitive flute codes.

Board Matching
For board matching, the migration tool compares case-insensitive board codes and board
descriptions. When it finds a match, it further analyzes board parameters to generate the matching
percentage. If there are collisions, the migration tool appends a sux that you specify in the migration
tool options. You must migrate flutes before you migrate boards.

Company Matching
For company matching, the migration tool has features to reduce database pollution from similar
database entries, as companies are usually the type of entity with the most potential problems in a
migration. The migration tool uses a custom fuzzy algorithm for company matching which:

• Uses synonym sets to replace synonyms found with a master token, such as replacing & and + in a
company name with the word and.

• Splits the company name into tokens and converts tokens in to upper case for comparison.
• Strips ignorable tokens such as THE at the beginning of company names and CO, COMP, COMPANY,

and so forth at the end of company names.

You can add or remove tokens as desired by adding or deleting data in the appropriate section of the
tuning file. For token separators, add to or remove from the current XML entry between the quotation
marks. For synonyms, add or remove SYNONYM groups. For ignored tokens, add or remove the
appropriate line. If you add an entry, make sure to use the same exact format as an existing entry.

Starting the Migration Utility

1. Select a computer that has both ArtiosCAD Standard Edition and an ArtiosCAD Enterprise client
installed.

2. In the ArtiosCAD subfolder of the Esko folder on the Start menu, click ArtiosCAD Enterprise
<version> Migration.

3. In the Migration Login to WebCenter dialog box, enter the login information for your WebCenter
server. You must log in as a member of the WebCenter ADMINS group. This user must also have a
location assigned in WebCenter so that future automatic conversion of design data works correctly.
Depending on the options you set in the migration tool, the user whom you log in as will become
Project Manager for certain migrated Projects and documents, so choose this user carefully. Click
OK.
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You can change the default values for the Address and Username in the migration tuning file.

4. The migration tool appears after it initializes its entity cache. For your convenience, it always shows
the connected server and logged-in user at the bottom of the frame.
 

 

Migrating Entities

The migration tool starts and analyzes the existing ArtiosCAD Standard Edition database. It then
displays the Entities tab.
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The goal of this part of the migration process is to match all the entities between the ArtiosCAD
Standard Edition database and the WebCenter database. Each migration attempt is uniquely tied to a
particular combination of ArtiosCAD database ID and destination WebCenter server name. In this way
you can migrate data between varying databases.

The migration tool handles four types of entities:

• Flutes
• Boards
• Companies. The migration tool performs extra analysis on companies to reduce similar database

entries.
• Persons

Clicking Analyze activates the matching process per entity type, or you can match them all together
by clicking Analyze All. If you use Analyze All, you still need to review the matched and new entities
individually by type.

When entities match, the migration tool creates a persistent mapping between the ArtiosCAD
Standard Edition metadata and the WebCenter metadata, and displays the number of matches in the
Matched column. The migration tool saves the mapping when you exit it so that you do not have to
reanalyze the entities the next time you start the tool.

 

 
The Reset button resets the mapping for the entity type and rereads both databases. Use this when
other people make changes to either database while the migration tool is running.
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Match Confidence controls how closely entities in both databases must match in order for the entity
in the ArtiosCAD Standard Edition database to not be considered a new entity to be inserted into the
WebCenter database. A higher number means they must match more closely to not be considered new.
One hundred means they must match exactly to not be considered new.

When an entity in the ArtiosCAD Standard Edition database does not match one in the WebCenter
database, it appears in the New column.

To match entities individually, click Analyze in the row of the desired entity. After a moment, there
should be numbers in the Matched and New columns. These numbers are links that open additional
dialog boxes.
 

 

Migrating Flutes
The flute migration compares case-insensitive flute codes. Once you have analyzed the flutes to
migrate, you can see which entities have been matched and which will be inserted into the WebCenter
database.

1. Analyze the flutes to match.
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2. Click the underlined blue number in the Matched column to open the Entities Matched dialog box.
 

 
3. In the Entities Matched dialog box, the left pane is sorted by match percentage, while the right pane

is sorted by code. Matching entities are shaded.
a) To change a match, select an entity in the left pane and click Change Match.

 

 
b) The ArtiosCAD database entry is shown at the top of the dialog box. Click a new match from the

list and click Done.
4. Back in the Entities Matched dialog box, review the other flute matches and change them as

desired.
5. Click Done to return to the migration tool.
6. Click the underlined blue number in the New column to open the New Entities To Be Inserted dialog

box.
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a) If a new entity is not truly new and should be matched to an existing entity, select it and click

Match Entity Manually.
 

 
b) Select the matching flute and click Done to return to the New Entities To Be Inserted dialog box.
c) To insert this one entity into the WebCenter database, click Insert Entity Now.
d) To reanalyze the flute entities in case there have been changes, click Re-Analyze.
e) Click Done to return to the migration tool.

7. Now you are ready to migrate the flute entities. Click Insert in the Flutes row.
8. After a few moments, the migration tool will update the number in the Matched column, and the

number in the New column and the Insert button will disappear.

Migrating Boards
The migration tool compares case-insensitive board codes and board descriptions. When it finds a
match, it compares more attributes of the boards to calculate a matching percentage.

Note:  You must migrate flutes before you migrate boards.
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The process of migrating boards is similar to that of migrating flutes. Analyze the databases, review
matches, change mappings if desired, and insert non-matching entities into the WebCenter database.

1. Analyze the boards to match.
 

 
2. Click the underlined blue number in the Matched column to open the Entities Matched dialog box.

 

 
3. In the Entities Matched dialog box, the left pane is sorted by match percentage, while the right pane

is sorted by code. Matching entities are shaded.
a) To change a match, select an entity in the left pane and click Change Match.

 

 
b) The ArtiosCAD database entry is shown at the top of the dialog box. Click a new match from the

list and click Done.
4. Back in the Entities Matched dialog box, review the other board matches and change them as

desired.
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5. Click Done to return to the migration tool.
6. Click the underlined blue number in the New column to open the New Entities To Be Inserted dialog

box.
 

 
a) If a new entity is not truly new and should be matched to an existing entity, select it and click

Match Entity Manually.
 

 
b) Select the matching board and click Done to return to the New Entities To Be Inserted dialog

box.
c) To insert this one entity into the WebCenter database, click Insert Entity Now.
d) To reanalyze the board entities in case there have been changes, click Re-Analyze.
e) Click Done to return to the migration tool.

7. Click Insert to insert the new entities into the WebCenter database.

Migrating Companies
Migrating companies is a little more complicated than migrating flutes and boards. Companies are
often the part of the database with the most duplicate entries. The migration tool performs extra
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analysis on the companies in the ArtiosCAD Standard Edition database to reduce the number of
duplicates before it compares the two databases. The matches are between ArtiosCAD companies
and WebCenter locations. If the WebCenter company already exists, then the migration tool adds the
ArtiosCAD company as a new location to the WebCenter company.

1. Analyze the companies.
 

 
a) If there are duplicates in the ArtiosCAD Standard Edition database, the migration tool will find

them according to the settings in the migration tuning file. It then displays them in the Duplicate
Companies Found dialog box.
 

 
b) Treat Selected Items as a Set causes the migration tool to insert the top entry into the

WebCenter database and the other selected items will point to that mapping. Use the arrows at
the side of the list to move the selected items up or down.

c) Stop Looking for More Duplicates and Continue Looking for More Duplicates do what they say.
d) If you click Treat Selected Items as a Set or Continue Looking for More Duplicates, the tool

continues searching for duplicates and prompts you to resolve any that it finds.
2. When the migration tool finds no more duplicates, or you choose to stop looking for more

duplicates, it does a normal comparison between the revised sets of companies in the two
databases.
 

 
3. Click the underlined blue number in the Matched column to open the Entities Matched dialog box.
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4. In the Entities Matched dialog box, the left pane is sorted by match percentage, while the right pane

is sorted by legal name. Matching entities are shaded.
a) To change a match, select an entity in the left pane and click Change Match.

 

 
b) The ArtiosCAD database entry is shown at the top of the dialog box. Click a new match from the

list and click Done.
5. Back in the Entities Matched dialog box, review the other company matches and change them as

desired.
6. Click the underlined blue number in the New column to open the New Entities To Be Inserted dialog

box.
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a) If a new entity is not truly new and should be matched to an existing entity, select it and click

Match Entity Manually.
 

 
b) Select the matching company and click Done to return to the New Entities To Be Inserted dialog

box.
c) To insert this one entity into the WebCenter database, click Insert Entity Now.
d) To reanalyze the company entities in case there have been changes, click Re-Analyze.
e) Click Done to return to the migration tool.

7. Click Insert to insert the new entities into the WebCenter database.

Migrating Persons
The migration tool migrates ArtiosCAD Standard Edition database persons to WebCenter users. The
migration tool case-insensitively compares first names and last names. When it finds a match, the tool
uses this mapping.

If the ArtiosCAD persons are real network users, use the WebCenter LDAP migration utility beforehand
so that they can use their network credentials to log in.
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Note:  You must migrate all companies before migrating persons.

1. Analyze the persons to match.
 

 
2. Click the underlined blue number in the Matched column to open the Entities Matched dialog box.

 

 
3. In the Entities Matched dialog box, both panes are sorted by last name. Matching entities are

shaded.
a) To change a match, select an entity in the left pane and click Change Match.

 

 
b) The ArtiosCAD database entry is shown at the top of the dialog box. Click a new match from the

list and click Done.
4. Back in the Entities Matched dialog box, review the other person matches and change them as

desired.
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5. Click Done to return to the migration tool.
6. Click the underlined blue number in the New column to open the New Entities To Be Inserted dialog

box.
 

 
a) If a new entity is not truly new and should be matched to an existing entity, select it and click

Match Entity Manually.
 

 
b) Select the matching person and click Done to return to the New Entities To Be Inserted dialog

box.
c) To insert this one entity into the WebCenter database, click Insert Entity Now.
d) To reanalyze the person entities in case there have been changes, click Re-Analyze.
e) Click Done to return to the migration tool.

7. Now you are ready to start migrating the persons. Click Insert in the Persons row.
8. The Insert Persons as Users dialog box appears.
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Hold down CTRL and click users to select more than one user.
a) In the Properties pane, enter the first name, last name, username, and location for the selected

person. You can also choose to make the selected person a Project manager in WebCenter - able
to create new Projects. The initial password for the user is the same as the username. To change
the Project manager status of many new users at once, select them and set the checkbox as
desired.

b) In the Usernames pane, you can have the migration tool automatically create usernames for the
selected users. Use standard method causes Automatically Generate Username(s) to create
a username for the selected person(s) out of the first letter of the first name and the entire last
name, all in upper case. For example, the automatic username for the user in the example above
would be DDRAFTER. The username is case-insensitive when logging in, but the password is
case-sensitive, so the user could log in as DDRAFTER or ddrafter, but he would always have to
enter his password as DDRAFTER until he changed it.

c) Also in the Usernames pane, Use external DLL allows a custom dynamically linked library
(DLL) to create the usernames for the selected users when you click Automatically Generate
Username(s). Your IT department or an Esko solution architect would create the custom DLL.
Below is a short functional prototype as an example, along with the parameters for the DLL.

short GetUsername(const char * lastname,  const char * firstname, 
                            const char* companyname, 
                            char* usernameRet,  int usernameBufLen)  

Parameters:
        const char* lastname - the user’s last name
        const char* firstname - the user’s first name
        const char* companyname - the user’s company name
        char* usernameRet - (out) - the returned username - must be NULL terminated
        int usernameBufLen - the length (int chars) of the usernameRet buffer 

Returns:
        1 – for success

9. To insert the selected users into the database, click Insert Entity(s) Now. Unlike other entities, this
is the only way to insert users into the WebCenter database.

10. Click Done to return to the migration tool.
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11. The migration tool will update the number in the Matched column, and the number in the New
column and the Insert button will disappear.

Configuring Design Data Migration

The next step in the migration is to configure how the design metadata from the designs migrates into
WebCenter as Attributes. ArtiosCAD Enterprise and WebCenter also use this mapping any time you
upload an unmanaged document to WebCenter.

However, there are some prerequisites that you must make sure have been satisfied before you begin
this phase.

1. WebCenter must already contain the Attributes that will receive the data coming out of the
ArtiosCAD Standard Edition database.

2. Once the Attributes exist, assign them to the default Attribute Categories that you will use for the
migrated Projects and documents.

3. You must have migrated all the entities on the Entities tab before beginning the design data
migration.

1. In the migration utility, click the Design Data tab.
 

 
2. Assign values in the drop-down list boxes in the Default Attribute Categories and Map to Attributes

groups. In the example below, all the Attributes were created with the same names in WebCenter as
the corresponding fields in ArtiosCAD.
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Migrating Characteristics and Userfields

The next step of the migration is to analyze the characteristics, restricted sets, and userfields, and
migrate them into the WebCenter database like the flute, board, company, and person entities were.
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Save Mapping to Server becomes available after you have migrated the characteristics, restricted
sets, and userfields.

Migrating Characteristics
The next step in the migration is to migrate the characteristics. The migration tool matches the
ArtiosCAD characteristic description to the WebCenter characteristic name. It does not use the code
because the same code can be used in multiple locations in the characteristic tree in the ArtiosCAD
Standard Edition database.

1. Analyze the characteristics to match.
 

 
2. Click the underlined blue number in the Matched column to open the Entities Matched dialog box.

This is only to see the matches; you cannot change the matches for characteristics.
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The Entities Matched dialog box sorts both panes by the paths in the characteristics trees and
shades matching entities. Click Done to return to the migration tool.

3. Click the underlined blue number in the New column to open the New Entities To Be Inserted dialog
box.
 

 
a) Since you cannot match characteristics manually, do not click Match Entity Manually.
b) To insert the selected entity(s) into the WebCenter database, click Insert Entity Now.
c) To reanalyze the characteristics in case there have been changes, click Re-Analyze.
d) Click Done to return to the migration tool.

4. Now you are ready to start migrating the characteristics. Click Insert in the Characteristics row.
5. A progress bar appears as the tool migrates the characteristics.
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Migrating Restricted Sets
The next step in the migration is to migrate the restricted sets, which are userfields in ArtiosCAD and
Attributes in WebCenter. The migration tool matches the restricted set name and unit type. It does not
compare actual set values.

1. Analyze the restricted sets to match.
 

 
2. Click the underlined blue number in the Matched column to open the Entities Matched dialog box.

 

 
Note that there already was a Storage Area restricted set in WebCenter, so the migration tool
appended a collision sux as specified in the options to make a unique entry.

3. In the Entities Matched dialog box, both panes are sorted by name. Matching entities are shaded.
a) To change a match, select an entity in the left pane and click Change Match.
b) The ArtiosCAD database entry is shown at the top of the dialog box. Click a new match from the

list and click Done.
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c) Click Done to return to the migration tool.

4. Click the underlined blue number in the New column to open the New Entities To Be Inserted dialog
box.
 

 
a) If a new entity is not truly new and should be matched to an existing entity, select it and click

Match Entity Manually.
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b) Select the matching restricted set and click Done to return to the New Entities To Be Inserted

dialog box.
c) To insert this one entity into the WebCenter database, click Insert Entity Now.
d) To reanalyze the restricted sets in case there have been changes, click Re-Analyze.
e) Click Done to return to the migration tool.

5. Now you are ready to start migrating the restricted sets. Click Insert in the Restricted Set row.
6. The migration tool will update the number in the Matched column, and the number in the New

column and the Insert button will disappear.

Migrating Userfields
The next step in the migration is to migrate the userfields, which become Attributes in WebCenter.
The migration tool matches them by name and format type, but does not compare the value type
(Prompted, Calculated, or Restricted).

The migration tool adds prefixes to the list of ArtiosCAD userfields: ARD for single design userfields,
MFG for manufacturing file userfields, and PRJ for Project userfields. It maintains separate mappings
for each group of userfields. More than one userfield can map to the same Attribute.

1. Analyze the userfields to match to Attributes.
 

 
2. Click the underlined blue number in the Matched column to open the Entities Matched dialog box.
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3. In the Entities Matched dialog box, both panes are sorted by name. Matching entities are shaded.

a) To change a match, select an entity in the left pane and click Change Match.
b) The ArtiosCAD database entry is shown at the top of the dialog box. Click a new match from the

list and click Done.
 

 
c) To undo a match, select the entity on the left and click Undo Match. Use this with care as the

only way to recreate the match is to reanalyze the userfields.
d) Click Done in the Entities Matched dialog box to return to the migration tool.

4. Click the underlined blue number in the New column to open the New Entities To Be Inserted dialog
box.
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a) If a new entity is not truly new and should be matched to an existing entity, select it and click

Match Entity Manually.
 

 
b) Select the matching restricted set and click Done to return to the New Entities To Be Inserted

dialog box.
c) To insert this one entity into the WebCenter database, click Insert Entity Now.
d) To reanalyze the restricted sets in case there have been changes, click Re-Analyze.
e) Click Done to return to the migration tool.

5. Now you are ready to start migrating the userfields. Click Insert in the Userfields row.
6. A progress bar will appear.
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7. The migration tool will update the number in the Matched column, and the number in the New

column and the Insert button will disappear.

Saving Mapping to the Server

The mapping you have set to get the data migrated from ArtiosCAD Standard Edition into WebCenter
for use by ArtiosCAD Enterprise needs to be saved for every location for which you have a designer. You
can use a different mapping for each location, but you should save a mapping for every location. If a
mapping already exists for a location, saving it again will overwrite the previous mapping.

After the migration is complete, every time a user uploads an unmanaged file into WebCenter, or opens
it with ArtiosCAD Enterprise, the program will use this saved mapping for the user's location to migrate
the data in the design.

The legacy CAD metadata (like Owner and Salesperson) configured on the Design Data tab of the
migration tool is not location-specific, but clicking this button also saves it to the server.

Note:  You can only save the mappings after you have migrated the userfields, restricted sets,
and characteristics.

Note:  You must save mapping for EVERY INDIVIDUAL LOCATION. Click Save Mapping to
Server, select the first location, click OK, click Save Mapping to Server, select the second
location, click OK, click Save Mapping to Server, select the third location, click OK, and so on.

1. Migrate the userfields, restricted sets, and characteristics if you have not already done so.
2. On the Characteristics and Userfields tab of the migration tool, click Save Mapping to Server.
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3. In the Save Mapping to Server dialog box, click a location and click OK to save the mapping to the
server.
 

 
4. Repeat steps 2 and 3 for each location with which you have designers associated, or may have

designers associated with in the future, for which you want to use the current mapping you have
configured on the Design Data and Characteristics and Userfields tabs. To use other mappings with
locations, change the mappings as desired and repeat steps 2 and 3.

Setting General Options for Project and Document Migration

The General Options tab lets you set options for how the migration tool will work.
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The left side of the dialog box shows groups containing the options for Projects, while the right side of
the dialog box contains the options for documents.

In the If Project Exists group, you can have the migration tool Skip creating a new Project, Use the
existing project, or Create new project with the specified name sux.

When the migration tool creates new Projects, if you want it to use a Template, select it in the Use
Template drop-down list box. It can only use one Template per run; if you want to apply multiple
Templates, you have to run the migration multiple times, each time on a new list of search results.
For new Projects it creates, it can Keep existing project manager or document designer, and allows
you to pick a different user or group if that person is unavailable for any reason. Note that this option
overrides the Project manager set in the Template. The migration tool can make the logged-in user
the Project manager if you select Make me the Project manager. You can also Specify a user or group
to set as the Project manager. This is one reason why it is important before you begin the migration
process to decide which user is going to run the migration tool.

Note:  These settings for the Project manager also apply when migrating documents that
cause the tool to create new Projects.

In the Map to Attributes group, you can choose either Document Revision Date or Document Saved
Date for the Project Creation Date and Project Modified Date fields. You can also leave the fields blank
to not migrate these two database fields. This information is optional and does not exist in native form
in WebCenter.

Sux to avoid entity collisions is the sux the migration tool appends to entities to avoid duplicates.
This value seeds the Name Sux fields in other groups in this dialog box.

In the If Document Exists group, you can choose to have the migration tool Skip - do not migrate
or Create new document with the specified name sux. Note that this is per Project; the same
document name may exist in different Projects.
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Document Folder Options leads to a dialog box where you can specify that documents with certain
extensions go into certain folders within a Project. The migration tool will create folders as needed.
 

 
In the Document Extension(s) field, enter the filename extension(s) for documents to filter into
the folder you specify in the Destination Folder field. Include the leading period in the extension
and separate multiple extensions with commas as shown in the example. Click OK to return to the
migration tool.

In the Document Revision Options group, choose to Only migrate latest revision of documents or to
Migrate all revisions. In the Current Revision Scheme group, tell the migration tool if the latest revision
is the File with highest letter or File base name. You can check your ArtiosCAD Standard Edition
installation to see which method it uses by launching it and clicking Options > Defaults > Startup
Defaults > Revision Disk File Format. Don't put revision extension on latest revision would mean File
base name and Don't put revision extension on first revision would mean File with highest letter.

Use existing design thumbnails, when checked, uses the existing thumbnails from the ArtiosCAD
database. When deselected, it causes WebCenter to regenerate the document thumbnails.

Preserve Document Linking in Projects, when checked, keeps linked documents linked. When
deselected, linked documents become individual documents in each Project into which they are
migrated.

Migrating Projects

Once you have adjusted the tuning file, migrated all the entities, migrated the characteristics,
restricted sets, and userfields, saved all the mappings to the server, and set the options, you are ready
to begin migrating the data. To migrate Projects, you search for them and then migrate those that
appear in the search results. If desired, you then change the options and search for a different set
of Projects to which to apply those options, and then migrate the results of that search, and so on
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for another set of Projects. If you do not work with Projects, skip ahead to the Migrating Documents
section.
 

 

Searching for Projects to Migrate
In the Search Projects group of the Project Migration tab of the migration tool are four fields that
control how you search for Projects. The migration tool searches on all the fields for which you enter
values; it uses AND in the query, not OR. Searching for Projects creates a list of Projects to migrate.
You can run multiple searches with different criteria each time to get only the results you want in the
list before you migrate any Projects.
 

 

1. To search by when a Project was last modified, choose one of the values from the Modified drop-
down list box.

• -. Use this to not specify a date.
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• Modified last day, Modified last 7 days, Modified last 30 days. Choose a more specific time
range for when a Project was last modified.

• More options opens a dialog box in which you can set the exact modification time to search
against.
 

 
Modified last lets you enter the exact number of days for which you want to search for modified
Projects. Use the calendar buttons at the end of the fields in Modified on day and Modified
between dates to set either an exact day or a range of days. Click OK to return to the migration
tool.

2. In the Name field, specify the name of the Project to search for. Use wildcards as described below
to find more results.

3. In the Description field, specify the description of the Project to search for. Use wildcards as
described below to find more results.

• * and % mean match all characters.

• ? and _ mean match one character.

• To search on one of the wildcards, prefix it with a backslash ( \ ), such as “100\% Pure”.

• To search specifically on a backslash, enter “\\”.

Examples of using wildcards are shown in the following table.

Search term Search results

Project_1 All Projects starting with “Project” and then any single character
between t and 1, such as ProjectX1, Project$1, and so forth.

Project\_1 Project_1.
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Search term Search results

Project\_* All Projects starting with Project_, such as Project_1, Project_X, and
Project_5BD2.

Project\1 Project\1.

4. Choose a customer from the drop-down Customer list box, or leave it empty to search across all
customers.

5. Clicking Append to list will add the results of this search to the list of Projects to migrate. Not
selecting this option and doing another search will overwrite the previous list of Projects to
migrate. The migration tool automatically removes duplicates from the list. Clear resets all the
search fields.

6. Click Search. The migration tool will search the database for Projects matching the search criteria
you set and show the results in the Projects to Migrate list.
 

 
7. Review the list. You cannot migrate selected Projects; instead, remove the Projects you do not want

to migrate. To remove a single Project from the list, click it and then click Remove from List. Use
SHIFT and CTRL selections to select a range of Projects or multiple Projects respectively, and
then click Remove from List to remove them from the migration list. Click Clear List to remove all
Projects from the migration list.

Performing the Projects Migration
1. Once you have all the desired Projects in the list of Projects to migrate, click Migrate all. A progress

bar will appear.
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The length of time the migration will take depends on the number of Projects being migrated.
a) As it processes each Project, the migration tool checks to see if it already exists in WebCenter.

If the Project does already exist, the migration tool uses the settings on the General Options tab
to determine the proper actions.

b) The migration tool next updates the Project's metadata, unless the Project already existed and
Use existing project was selected in General Options. The new Project manager can be the
existing Project manager if that same user is a Project manager in WebCenter, or it can be the
current WebCenter user running the migration tool. The migration tool sets the Customer and
Salesperson according to how they are mapped in the entity migration, as well as the Project
characteristics. The migration tool maps Project characteristics as Attributes as defined during
entity migration. The migration tool maps the creation and modified dates based on the Map to
Attributes group settings on the General Options tab.

c) The migration tool next migrates single design documents into the WebCenter Project.
d) Finally, the migration tool updates the Bill of Materials information for the WebCenter Project.

This includes if the design is included in the Bill of Materials and if so, updating the BOM count
and BOM display order.

2. When the migration process finishes, the Migration Results dialog box appears for you to review
the status of the migration. In it, you can add Projects back to the list of Projects to be migrated by
clicking the appropriate checkboxes.
 

 
3. Click OK to add any Projects back to the migration list and return to the migration tool, or click

Cancel to just return to the migration tool.
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Recovering from Project Migration Errors
In the rare event that the migration tool errors when migrating Projects, there are two log files it uses
to help recover.

• ..\Esko\Artios\Migration\ProjectMigrationListing.xml, which is the list of
Projects to migrate;

• ..\Esko\Artios\Migration\ProjectMigrationLog.xml, which is the log of the Project
migration process.

View log file on the Project Migration tab opens the log file for viewing. When Projects have errors,
the most likely cause is that the migration tool cannot find one of the physical documents on disc, as
shown in this excerpt from the Project migration log file. To fix this, you would find the document, copy
it to the location the Project expects, and migrate the Project again.

DBPROJECT NAME="2014 03-27" STATUS="2" ECADPROJECTNAME="2014 03-27"
 ECADPROJECTID="00002_0000000047">
<LOG_MESSAGES><LOG_MESSAGE>STATUS - Project does not exist... creating it</LOG_MESSAGE>
<LOG_MESSAGE>STATUS - Created new project: 2014 03-27</LOG_MESSAGE>
<LOG_MESSAGE>STATUS - Updated project metadata</LOG_MESSAGE></LOG_MESSAGES>
<DBDESIGN DOCNAME="BENDS.ARD" RESOURCEID="101" RESOURCENAME="Prod" REV="1" 
DOCPATH="C:\Users\Prod\BENDS_A.ARD" STATUS="2"><LOG_MESSAGES>
<LOG_MESSAGE>STATUS - Attempting to link document to: @2014 03-27:1:BENDS.ARD</
LOG_MESSAGE>
<LOG_MESSAGE>ERROR - Unable to access physical document: C:\Users\Prod\BENDS_A.ARD</
LOG_MESSAGE>
</LOG_MESSAGES>...</DBPROJECT>

Clicking Recover on the Project Migration tab of the migration tool causes the tool to analyze these
two log files and regenerate the list of Projects to migrate. It then displays the Migration Results dialog
box in which you can add Projects back into the list of Projects to migrate. Check the checkboxes for
Projects that have a count and click OK.
 

 

Migrating Documents

Once you have adjusted the tuning file, migrated all the entities, migrated the characteristics,
restricted sets, and userfields, saved all the mappings to the server, and set the options, you are ready
to begin migrating the data. If you do not use Projects, then you will migrate the ArtiosCAD Standard
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Edition documents on their own into new Projects in ArtiosCAD Enterprise using the Document
Migration tab of the migration tool.
 

 
The workflow for document migration resembles that of Project migration: search for documents to
migrate, add them to the list, groom the list, and then migrate everything in the list.

Searching for Documents to Migrate
On the Document Migration tab, click Find Documents to Migrate.
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1. Choose a way to search for documents.
a) To search for documents by resource, click Add Resource(s). The Select Resource(s) dialog box

appears.
 

 
To select one resource, click it. To select multiple resources, hold down CTRL and click each
resources. To select a group of resources, click the first resource, hold down SHIFT, and click
the last resource. If you have nested resources, you do not have to pick each lower-level one, as
there is an option to search in sub-resources and subdirectories. Once you have selected the
desired resource(s), click OK to return to the Find Documents to Migrate dialog box.
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b) To search for documents by directory, click Add Directory. The Browse for Folder dialog box
appears.
 

 
Click the desired directory and click OK to return to the Find Documents to Migrate dialog box.
Repeat this step to search for documents in more than one directory.

c) To search for documents by customer name independent of location, click By Customer and
choose the customer's company name from the drop-down list box.

2. In the Document Filter group, choose the type of document(s) to search for in the Include
documents of type field and to exclude in the Exclude files of type field. Use comma-separated
wildcards in each field, such as X*.ARD, which would either find or exclude all single design
documents whose names start with X. When searching by customer, only *.ARD and *.MFG are
applicable.

3. To search for documents using the time at which they were last modified, check Only include
documents modified on or after or Only include documents modified before, or both. Use the
calendar drop-down to set each date. To search within a certain range, set the modified on or after
date and the modified before date where the modified after date is earlier than the modified before
date. To exclude a certain date range, set the modified on or after to a later date than the modified
before date; this option is not supported when searching by customer.

4. Click Recursively search each Resource/Directory to search down through each subdirectory
or child resource. The migration tool will only add the first instance of a document for which it
encounters duplicates. This option is not supported when searching by customer.

5. The migration tool tracks which documents have been migrated in previous migrations. Check Skip
documents which have already been migrated to not migrate them again.

6. Sometimes there are documents that exist physically but are not saved in the database. To control
if these are migrated or not, check or clear For native documents (*.ARD, *.MFG), only include
documents which exist in the database. This option is not supported when searching by customer.

7. Click Find Documents. The migration tool searches in two passes.
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a) First, the migration tool searches the specified directories/resources (or the database is
searched by customer) using the document type and date filters.

b) Next, it filters the results again to find the highest version of the design documents, and also
filters out documents which do not exist in the database or which have already been migrated (if
those options are selected).
 

 
8. Finally, the migration tool displays the search results in the Documents to Migrate list. The list is

initially sorted by filename but you can change the sort order by clicking a column header.
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Setting Document Migration Options
Clicking Options on the Document Migration tab of the migration tool opens the Document Migration
Options dialog box. Here is where you set document-specific migration options that are not covered on
the General Options tab.
 

 
As all documents in WebCenter must belong to a Project, as you migrate documents into it, the
migration tool has to create a Project for them if that Project does not exist already. In the Project
Name group:

• Use resource/directory name as project name creates Projects analogous to your directory or
resource setup in ArtiosCAD Standard Edition. The migration tool uses the last part of the directory
path for the name unless the document is in the root folder of the drive, in which case it uses
UNKNOWN.

• Use document name as project name uses the document name (without the extension) for the
Project name.

• Use external DLL lets you use a function in a Windows dynamically linked library exported in
standard C-language style to generate the name of the Project. See the next section for details.

Use workspace metadata if design does not exist in database causes the migration tool to try to
use database information stored in the workspace. This includes Description, Short Description 1,
2, 3, Revision Summary, Authorization, Revision and Save Date, Characteristics, and Userfields. For
Customers, Owners, Salespersons, and Designers, these will be used only if the database ID in the
workspace matches the current ArtiosCAD Standard Edition database ID (meaning that the workspace
was created on a local system using the current database, not a design you got from some other
ArtiosCAD location).

Automatically migrate design metadata for new projects automatically seeds Project-level metadata
with the metadata from the first design added to the Project when a new project is created in
WebCenter.

• Designer becomes the Project manager (based on how the When Creating New Projects / Project
Manager option is set on the General Options tab

• Description becomes the Project description
• Customer becomes the Project customer
• Salesperson becomes the Project salesperson
• Characteristics become Project characteristics
• Userfields become Project Attributes
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• Short Description 1, 2, 3, Authorization, Revision Summary, Owner, Revision Date, and Save Date
become Project Attributes (based on the Map to Attributes option on the General Options tab.

Click OK to return to the Documents Migration tab.

Using an External DLL to Generate The Project Name
To use a function in a Windows dynamically linked library exported in standard C-language style to
generate the name of the Project in which to store a document being migrated, refer to the example
below to guide the coding.

extern "C"
{
  __declspec (dllexport )  short GetProjectNameFromDocName (…)
}

A prototype of the function would be:

short
    GetProjectNameFromDocName(const char * docName, int rev,
    const char* resourceName, const char* fullDocPath,            
    int* projectNameOption, char* projectNameRet, int projectNameBufLen,             
    int* folderNameOption, char* folderNameRet, int folderNameBufLen,            
    int* documentNameOption, char* documentNameRet, int documentNameBufLen)

Table: External DLL Function Parameters

Parameter Definition

const char* docName The base .ARD or .MFG document name without
the encoded revision.

int rev The revision of the document; only applies
to .ARDs and .MFGs else 0.

const char* resourceName The resource name if a document is in a resource.

const char* fullDocPath The full path to the document, such as C:
\Users\Prod\ABC.ARD.

int projectNameOption (out) Project name option returned. 1 - Project
name returned in projectNameRet. 2 - use
document name as Project name. 3 - use
resource/directory as Project name.

char* projectNameRet (out) The returned Project name; must be NULL
terminated.

int projectNameBufLen The length (int chars) of the projectNameRet
buffer.

int folderNameOption (out) The folder name option returned. 1 - folder
name returned in folderNameRet. 2 - use default
folder mapping.

char* folderNameRet (out) The returned folder name; must be NULL
terminated.

int folderNameBufLen The length (int chars) of the folderNameRet
buffer.
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Parameter Definition

int documentNameOption (out) Document name option returned. 1 -
document name returned in documentNameRet.
2 - use default document name.

char* documentNameRet (out) The returned document name; must be
NULL terminated.

int documentNameBufLen The length (int chars) of the documentNameRet
buffer.

Table: External DLL Function Returns

Return Meaning

0 Error - the migration tool will log this document as
an error.

1 Success - the migration tool will analyze the return
parameters.

Performing the Documents Migration
1. Once you have all the desired documents in the list of documents to migrate, click Migrate all. A

progress bar will appear.
 

 
The length of time the migration will take depends on the number of documents being migrated.
The migration tool migrates all single designs before migrating manufacturing documents so
that all potential embedded designs are already migrated when it starts migrating manufacturing
documents.

2. For single designs:
a) As it processes each document, the migration tool first looks to see if a target Project already

exists or, if it does not, the migration tool creates or skips the Project per the selected option in
the If Project Exists group on the General Options tab. If the migration tool creates the Project, it
does so using the settings in the When Creating New Projects group on the General Options tab.
If it skips the document, it adds it to the list of skipped documents.

b) Next, the migration tool checks to see if the document already exists in the Project, and if it
does, it uses the settings in the If Document Exists group on the General Options tab.

194



5ArtiosCAD

c) The migration tool next checks the options you set in the Document Folder Options dialog box
on the General Options tab, and processes the document accordingly if it matches one of the
directory-folder destination mappings.

d) For a single design in a resource, the migration tool applies the design's database information to
the new WebCenter document. The design description becomes the document description, the
design characteristics become document characteristics, design userfields become document
Attributes, and the other fields are mapped according to the settings in the Map to Attributes
group on the Design Data tab.

e) The migration tool next sets the default Attribute category as defined on the Design Data tab.
f) Finally, if the options are set in the Document Revision Options group on the General Options

tab, the migration tool migrates the other revisions of the design.
3. For manufacturing documents:

a) As it processes each document, the migration tool first looks to see if a target Project already
exists or, if it does not, the migration tool creates or skips the Project per the selected option in
the If Project Exists group on the General Options tab. If the migration tool creates the Project, it
does so using the settings in the When Creating New Projects group on the General Options tab.

b) Next, the migration tool checks to see if the document already exists in the Project, and if it
does, it uses the settings in the If Document Exists group on the General Options tab.

c) The migration tool next checks the options you set in the Document Folder Options dialog box
on the General Options tab, and processes the document accordingly if it matches one of the
directory-folder destination mappings.

d) For a manufacturing document, the migration tool applies the document's database information
to the new WebCenter document. The manufacturing description becomes the document
description, manufacturing userfields become document Attributes, and the other fields are
mapped according to the settings in the Map to Attributes group on the Design Data tab.

e) The migration tool then adjusts the path of any embedded single designs. It only adjusts the
path to point to embedded single designs that have already been migrated. It only modifies the
manufacturing document with the new path(s) that it is uploading into WebCenter; it does not
change the file(s) on disc.

f) The migration tool next sets the default Attribute category as defined on the Design Data tab.
g) Finally, if the options are set in the Document Revision Options group on the General Options

tab, the migration tool migrates the other revisions of the manufacturing document.
4. The migration tool uploads all other documents (including .A3Ds) physically as there is no database

information to include. It sets the default Attribute category as defined on the Design Data tab.
5. When the migration process finishes, the Migration Results dialog box appears for you to review the

status of the migration. In it, you can add Projects back to the list of documents to be migrated by
clicking the appropriate checkboxes.
 

195



5 ArtiosCAD

 
6. Click OK to add any documents back to the migration list and return to the migration tool, or click

Cancel to just return to the migration tool.

Recovering from Document Migration Errors
In the rare event that the migration tool errors when migrating documents, there are two log files it
uses to help recover.

• ..\Esko\Artios\Migration\DocumentMigrationListing.xml, which is the list of
documents to migrate;

• ..\Esko\Artios\Migration\DocumentMigrationLog.xml, which is the log of the
document migration process.

View log file on the Document Migration tab opens the log file for viewing. When documents have
errors, the most likely cause is that the migration tool cannot find one of the physical documents on
disc, as shown in this excerpt from the document migration log file. To fix this, you would find the
document revision, copy it to the location the migration tool expects, and migrate the document again.

<DBDESIGN STATUS=" 2" DOCPATH=" C:\Prod\1SRELDFOC_A.ARD" REV=" 1" RESOURCENAME=" Prod" 
RESOURCEID=" 2" DOCNAME=" 1SRELDFOC.ARD"><LOG_MESSAGES><LOG_MESSAGE>
STATUS - Project already exists (Created by migration tool): Prod; using existing 
project</LOG_MESSAGE><LOG_MESSAGE>ERROR - Unable to access physical document: 
C:\Prod\1SRELDFOC_A.ARD</LOG_MESSAGE></LOG_MESSAGES><DBDESIGN 
ECADVPATH=" @Prod:1:1SRELDFOC.ARD" ECADFOLDER="" ECADPROJECTID=" 00002_0000000090" 
ECADPROJECTNAME=" Prod" ECADDOCVERSIONID=" 00002_0000013643" ECADVER=" 1" 
ECADDOCNAME=" 1SRELDFOC.ARD" STATUS=" 0" DOCPATH=" C:\Prod\1SRELDFOC.ARD" 
REV=" 0" RESOURCENAME=" Prod" RESOURCEID=" 2" DOCNAME=" 1SRELDFOC.ARD">
<LOG_MESSAGES><LOG_MESSAGE>STATUS - Document does not exist in the database; 
Using database metadata from workspace</LOG_MESSAGE><LOG_MESSAGE>STATUS - 
Successfully uploaded document</LOG_MESSAGE></LOG_MESSAGES></DBDESIGN>
</DBDESIGN>

Clicking Recover on the Document Migration tab of the migration tool causes the tool to analyze these
two log files and regenerate the list of documents to migrate. It then displays the Migration Results
dialog box in which you can add documents back into the list of documents to migrate. Check the
checkboxes for documents that have a count and click OK.
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After You Are Done

After you have finished using the migration tool, there are additional things you need to do for
ArtiosCAD Enterprise to be fully functional.

• Update every custom Report that previously used a userfield in ArtiosCAD Standard Edition to refer
to the proper Attribute in ArtiosCAD Enterprise. Attributes are in the Calculated expressions dialog
box just as userfields were.

• Update Outputs and geometry macros that refer to specific locations or files to point to their new
Projects or files in the database.

Maintenance Tasks

The options on the Maintenance tab are for those customers who already used WebCenter together
with ArtiosCAD Standard Edition before installing ArtiosCAD Enterprise. There are three tasks:

• Pre-10.2 Conversion. This is for those designers who have been using an older version of WebCenter
that works slightly differently than the one which ArtiosCAD Enterprise uses.

• Pre-12.1 Document Maintenance. This is for those designers who have been using a version
of WebCenter newer than 10.2 but older than 12.1. This option has three sub-tasks which can
be performed independently of each other. Note that if applicable, you must do the Pre-10.2
Conversion before this.

• Legacy CAD Data Migration. This option migrates Short Descriptions 1, 2, and 3 database fields,
along with other legacy CAD data, to WebCenter entities. This also has the Pre-10.2 Conversion as a
prerequisite.

Pre-10.2 Conversion
This option is for designers who have single designs and manufacturing documents stored in a pre-10.2
version of WebCenter who have upgraded that WebCenter to the version that comes with ArtiosCAD
Enterprise. These earlier versions of WebCenter show information that later versions do not. This
maintenance task migrates that older data into Attributes and characteristics so that it is not lost and
can continue to be searched.
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1. Click Convert. The Server Entity Mapping dialog box opens. This entity mapping works the same
way as the entity mapping for characteristics, restricted sets, and userfields. However, unlike the
mapping on the Entities Mapping tab, this mapping automatically creates any required Attributes.
This tool also automatically maps Attributes to userfields by name. Also unlike the other mapping,
you can undo a match and insert it as a new Attribute.
 

 
Use sux for new attribute name adds the sux you specify to any new Attributes the tool
creates. The migration tool will also additionally append the collision sux as needed, and a
number at the end if needed to make it unique. Note that Attribute names can be a maximum of 40
characters long. Set attribute category for converted documents assigns the Attribute category
you set on the Design Data tab to documents the tool updates.

2. Analyze the characteristics to match.
 

 
3. Click the underlined blue number in the Matched column for characteristics to open the Entities

Matched dialog box.
 

 

198



5ArtiosCAD

The migration tool shades matching entries. Click Change Match to change a match, or click Undo
Match to undo it. Undo a match with caution, as that will lead to duplicate Attributes. Click Done to
return to the migration tool.

4. Click the underlined blue number in the New column to open the New Entities To Be Inserted dialog
box.
 

 
a) If a new entity is not truly new and should be matched to an existing entity, select it and click

Match Entity Manually.
b) Select the matching characteristic and click Done to return to the New Entities To Be Inserted

dialog box.
c) To insert this one entity into the WebCenter database, click Insert Entity Now.
d) To reanalyze the characteristics in case there have been changes, click Re-Analyze.
e) Click Done to return to the migration tool.

5. Click Insert to insert the new Attributes.
6. Repeat steps 2-5 for restricted sets and userfields.
7. Click Start Conversion to begin converting the old data to the new format. A progress bar appears.

 

 
The migration tool converts each document one at a time, assigning the default Attribute
categories appropriately. It flags successfully converted documents so if the migration restarts, it
can skip them. Once a document is converted, you can not convert it again. If you click Cancel, the
migration ends with nothing migrated and no mapping saved.
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Pre-12.1 Document Maintenance
The Pre-12.1 Document Maintenance group contains tasks that refresh existing WebCenter documents
so they are compatible with newer WebCenter features.

Note:  If you have pre-10.2 documents, you must do the pre-10.2 conversion before using any of
these options.

 

 

1. Select the checkboxes for the desired options.
a) The first option checks existing manufacturing documents in WebCenter and makes sure

searchable metadata is configured properly for embedded design searching to work.
b) The second option does what it says so that more metadata can be searched using Advanced

Search.
c) The third option fixes design documents that were migrated in the past before their

corresponding 3D documents were migrated and thus have incorrect thumbnails. This option
scans WebCenter for later 3D documents and regenerates the thumbnails.

2. Click Refresh. Depending on the options you chose in step 1, the migration tool shows various
progress bars.
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Clicking Cancel in any of the progress bar dialog boxes stops the update regardless of which
options you chose.

3. The migration tool displays a status dialog box when it is done. Click OK to return to the migration
tool.
 

 

Legacy CAD Data Migration
The command in the Legacy CAD Data Migration group migrates Short Description 1, 2, 3, and similar
legacy CAD data to WebCenter entities. It uses the mappings on the Design Data tab.
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Note:  If you have pre-10.2 documents, you must do the pre-10.2 conversion before using this
command. You must also do the pre-12.1 document maintenance if applicable.

1. Click Migrate. The CAD Data Migration Options dialog box appears.
 

 
a) Set attribute category for migrated documents uses the settings for the default Attribute

categories on the Design Data tab to overwrite the existing Attribute category for a document
being migrated.

b) In the When destination attribute exists and is not empty group, set the action for the migration
tool to take when the Attribute already exists on the WebCenter document - to always overwrite,
to overwrite sometimes, or to not overwrite.

c) In the Restart group, choose what the migration tool does when you restart it - continue from
the last time or start new from the beginning.

2. Click Start. A progress bar appears.
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3. When the migration finishes or you cancel it, a results dialog box appears.

 

 
Updated is the number of documents that were migrated. Skipped is the number of documents
that have already been migrated during this migration session. Failed is the number of documents
that had errors.

4. Click OK to return to the migration tool.
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6.  Peripherals
ArtiosCAD can output to devices that use a standard Microsoft Windows driver and also to devices
simply connected to a port on an ArtiosCAD computer. Devices that do not use a Windows driver use
Output Destinations which are configured in the Output Destinations dialog box in Shared Defaults.

Note:  This documentation refers to configuring devices in Shared Defaults for all users to
access. Configuring a device for use on a single machine in User Defaults follows the same
procedure, substituting User Defaults for Shared Defaults.

Installing a Windows printer

ArtiosCAD prints by default to the default Windows printer on the system on which it is running.

For information on installing a printer in the Windows family of operating systems, read the Setting up a
Printer topic in the How to…Set Up Hardware section of Help.

If this is the first printer installed on the system, it is automatically designated as the system default
printer. The Print command and the Plot to Printer output (File > Outputs > Artios > Printer Output >
Plot to Printer) will use it by default.

To add an Output for a newly-installed printer if it is not the system default printer, do the following:

1. Start ArtiosCAD
2. Open Defaults by clicking Options > Defaults.
3. In the Shared Defaults pane, scroll down to Outputs.
4. Right-click Outputs, click New from the context menu, and then click Data.

5. Enter a name for the Output such as the name of the printer; for example, HP DeskJet 560C.
6. Double-click the new Output just created to open its Property page.
7. The Device tab will be selected automatically. Leave the Output type set as Plot and change the

Scale to To fit one page.
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8. Click the Device tab. If a dialog box appears with the message System printer information could
not be read, click OK.

9. Under Windows Driver, click the drop-down list box arrow and select the newly-created printer.

10. Click OK, then File, then Save to accept the printer and save the defaults.
11. Click Yes when asked to overwrite the defaults. The printer is now ready for use.

Output Destinations

Output Destinations enable the ArtiosIO program to carry output data from ArtiosCAD to a serial
or parallel port. The port can be on the local machine or it can be on a remote computer on the
network. Output Destinations also allow a device to communicate information (such as its size) back to
ArtiosCAD.
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Output Destinations require the ArtiosIO program to be running on the machine to which the device is
connected.

Starting the ArtiosIO program

The ArtiosIO program is installed when ArtiosCAD is installed. It is configured using the ArtiosIO applet
in Control Panel. Only users with administrative privileges can use this applet and the commands
within.

To start the ArtiosIO program and configure it to start automatically each time the computer is
rebooted, do the following:

1. Open Control Panel by clicking Start > Settings > Control Panel.
2. Double-click the ArtiosIO applet. The ArtiosIO Server dialog box will appear.

3. Click Start and set the Startup Type to Automatic.

4. Click OK.
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5. Do this on each computer which has a port to which a device that does not use a Windows driver will
be attached.

Creating an Output Destination

Now that the ArtiosIO program is running, you can configure Output Destinations in ArtiosCAD.

1. Start ArtiosCAD.
2. Open Defaults by clicking Options > Defaults.
3. Right-click Output Destination, click New on the context menu, and click Data.

4. Enter a name for the Output Destination. One good way to name it is to use the system name and
port name, e.g. ARTCAD LPT1 or SYSTEM4 COM2.

5. Once you have entered a name for the Output Destination, double-click it to open its Property page.

6. Enter the name of the system the port is on in the Hostname field.
7. Enter the port name in the Port: field. Common port names are COM1, COM2, COM3, and LPT1. The

COM ports are serial ports (also known as RS-232 ports) and LPT ports are parallel ports.
8. If the port you are adding is a serial port, set its characteristics in the RS 232 Parameters group

by choosing the options from the drop-down list boxes. If it is a parallel port, clear the RS 232 Port
checkbox.

9. The Short Name: field is the internal-to-ArtiosIO name of the port and can not be changed.
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10. Click OK when done.
11. To save these changes, click File > Save and click Yes to overwrite the Shared defaults.

Installing CAM Devices

Getting started

Use the following steps to configure a CAM (Computer Aided Manufacturing) device with ArtiosCAD.
Most CAM devices are equipment such as sampletables, lasers, counter cutters, and so on.

Configuring a CAM device follows this general procedure:

• Pick the output device driver from a master list of known devices. This will tell ArtiosCAD what
driver to use and how to tune it. Also check and set the size of the device.

• Specify how the peripheral will receive its instructions. This could be either by creating a disk file or
by sending the instructions to a parallel or serial port on one of the computers.

• Configure a plotting style or CAM Tooling Setup catalog entry for the device to use that defines
which tools on the device are to be used for each type of line in a design.

You may need to adjust the size and positioning settings copied from the master list.

When this process is complete, you will have an output that can be used by any ArtiosCAD user.

Preliminaries

First, you need answers to the following questions.

• Will you be using a Windows driver or a CAM driver?

• If a CAM driver is being used, what port will the output go to and how will it get there?

• Is there a pre-built output and plotting style/CAM Tooling Setup catalog entry for the plotter /
samplemaker you need to set up?

Windows driver or CAM driver?
Use a Windows driver if possible. These should be used for all drawings if suitable and if drivers are
available for your device. Many CAM devices operate correctly when driven using the IBM Graphics
standard Microsoft Windows printer driver. A CAM driver is used when there is no suitable Windows
driver for a device.

Is there a pre-built output and style?
If you have a plotter / samplemaker of a type listed below, there will most likely be a pre-built solution
for your plotting and samplemaking needs. You can probably set up the device without going into much
of the detail described in this document. If there is not a preconfigured plotting style or CAM Tooling
Setup catalog entry, follow the instructions in the Defaults chapter to set it up.
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Plotter / Samplemaker type Driver Notes

Artios Kongsberg samplemakers KGB

Artios Advantage Line samplemakers HP

Data Tech IPC controller DT Can not use print spooler

Data Tech with PC front end HP / DT

Elcede Vectocut ELC / HP

Elcede IBH controller ELC Can not use print spooler

Graphtec HP

Devices driven by HPGL HP

LKS Speedplot PPS

Alphamerics HP

Wild TA2’s and TA10’s WILD

Wild TA-100 series HP

Zeta / Bruning HP

Example 1 - Setting up a Kongsberg XL44 samplemaker

In this example, you will learn how to open Example output defaults, copy the required entry or entries
to your Shared defaults, and save them. Then, if needed, you will learn how to edit the CAM Device
Name to complete the setup.

1. Start ArtiosCAD.
2. Click Options > Defaults.
3. Click User defaults.
4. Click File > Open > Example defaults.
5. You will see folders for CAM Tooling Setup Catalog, Customized toolbars, Die press parameter

sets, Geometry Macro Catalog, Manufacturing Parameter Sets, NC Export Turning Table, Outputs,
Plotting Style Catalog, and Subtype Mapping Catalog. Expand the Outputs folder until you find the
Output type you are looking for. (For example: Outputs / Artios / Kongsberg XL22 - FC.)

6. You will see a number of pre-built Outputs. Select and drag Kongsberg XL44 - FC sample cutting
and matrix from this side and drop it on the Outputs folder on the Shared defaults side.
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7. Double-click the new entry and click the Directories tab. Change the directory entries to the
directory that the Kongsberg front end computer will look in.

8. Click the View tab and note the contents of the Specify Plotting Style group. If the plotting
style does not exist, its name will be surrounded by parentheses. If the plotting style name is not
surrounded by parentheses, click OK and proceed to step 12; otherwise, proceed to step 9.
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9. Click OK to exit this dialog box.
10. Expand the Plotting Style Catalog in Shared Defaults by clicking the plus sign next to it.
11. Look for the plotting style you noted as being used by the Kongsberg. Copy its definition from the

Example defaults in the same manner as you copied the definition for the Kongsberg.
12. Make sure the Shared defaults button is selected. There will be an asterisk next to it indicating that

it has been modified and needs saving. Click File and then Save to do this. Confirm by clicking Yes.
13. Click File and then Exit to leave Defaults.

You have successfully set up a Kongsberg XL44 Samplemaker.

Example 2 - Setting up an Alphamerics RS-232 samplemaker

This type of plotter can use a Microsoft shared print spooler to route the data to the particular
computer/port to which the device is connected. This is preferred over using a direct connection to a
port on a specific computer since it allows the device to be accessed by anyone who has access to the
shared printer.

The first thing to do is set up the print spooler. Use a generic printer driver that does not modify data,
such as the IBM Graphics printer driver. This driver is part of the standard driver set provided with the
operating system.

1. Set up a printer on the appropriate port. Make sure that the baud rate and other RS-232 properties
are set up to suit the plotter interface.

2. Let us assume that you have set up a shared printer on the computer called brunnhilde with a share
name of alphamerics. Add a networked printer to your system that points to that shared printer.

3. Follow the steps from Example 1, selecting the appropriate entry in Example CAM Outputs for The
Alphamerics Corp instead of Artios. Select the appropriate plotting style. (CAM.ALPHAMERICS)

4. Double-click the Output you just copied. Click the Device tab.
5. Click the Browse button (...) at the end of the CAM Device Name: field to open the Output

Destinations dialog box.
6. Expand the System Printers folder by clicking the plus sign (+) next to its name.
7. Select the entry matching the printer queue, for example the \\brunnhilde\alphamerics entry, and

click OK.
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8. You are now done. Click OK to exit this dialog.
9. Clear the Out To File checkbox.
10. Make sure the Shared defaults button is still selected. There will be an asterisk next to it indicating

that it has been modified and needs saving. Click File and then Save to do this. Confirm by clicking
Yes.

11. Click File and then Exit to leave Defaults.

Example 3 - Adding a Calcomp DrawingBoard III digitizer

Digitizers are somewhat different from other CAM devices as they are input-only devices. They
generally come in two pieces - a flat tablet and a mouse-like puck with buttons on it.

Note:  DO NOT load operating system drivers for the digitizer! They will prohibit ArtiosCAD
from accessing the digitizer!

Table: Suggested Digitizer Communication Settings

Digitizer settings Suggested setting

Baud rate 4800

Data bits 8

Parity None

Stop bits 0

Data Mode Point mode (Required)

Data format CALCOMP 9100-1 format compatible
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Digitizer settings Suggested setting

(APbxxxxxyyyyy)

If choosing one of your own, it must be ASCII.

Digitizer step size 1000 lines/inch or 50 lines/mm

To install the digitizer, do the following:

1. Connect the digitizer to any free serial port (use COM1 for the purposes of this example) and supply
it with power. Configure it to match the communications settings listed above.

2. Create an Output Destination for this port and if the serial port is on a remote computer, make sure
ArtiosIO is running on the remote machine.

3. Start ArtiosCAD and then click Options > Defaults.
4. Open the Digitizer Setup Catalog and select either Calcomp 16 Button or right-click and create a

new data item with the name of your digitizer.
5. Select the Digitizer Parameters tab.

6. Make sure the correct Output Destination is selected in the CAM Device Name field.
7. Make sure the settings in the Digitizer Step Size group match the settings on your digitizer.
8. Press buttons 0, 1 and 2 on the puck. The Decoded Data group should look similar to the picture

shown below:
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Look carefully at the third character in each line of data. Starting from the top, it should correspond to
the button you pressed on the puck.

Repeat this for buttons 3-F. Each digit should match up. If it doesn’t, your digitizer uses a different data
format.

The digitizing menu to the left is the default digitizing menu for a Calcomp digitizer. Photocopy it at full
scale or plot ..\InstLib\DIGITIZER_MENU.ARD at full size. You will need it for the next step.
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1. Click the Command Map tab.
 

 
2. Tape the menu to one side of the digitizer surface.
3. Select the Use Menu checkbox so that it is checked, and then click Place Menu.

 

 
4. Move the cross-hair on the digitizing puck to the bottom left corner of the menu and click any

button.
5. The puck position in the dialog box will change. Move the puck to the bottom right corner of the

menu and click any button. The Menu Position and Rotation fields will now have values in them.
 

 
6. Click OK to close the Calcomp 16 button dialog box.
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7. Click File, and then click Save to save the changes made to Shared Defaults. Click Yes when asked
to confirm the operation.

8. Exit Defaults. Your digitizer is now ready for use.

Example 4 - Setting up an i-cut Production Console Output

ArtiosCAD can Output a single design or a manufacturing file to a Kongsberg samplemaker's front end
computer running the i-cut Production Console. ArtiosCAD Outputs a ZIP archive containing a copy
of the workspace run through the information filter and a JDF file to a submit folder on the front end
which the i-cut Production Console monitors. The table operator can then process the job.

Note:  The submit folder on the front end is usually a subfolder of the user who installed the
i-cut Production Console. It also is not shared on the network as part of its installation. YOU
MUST KNOW THE EXACT LOCATION OF THIS FOLDER AND HAVE A PUBLICALLY WRITABLE
NETWORK SHARE CREATED ON THE FRONT END FOR IT.

An iPC Output is a Grouped Output containing three individual Outputs:

• iPC - ArtiosCAD File
• iPC - JDF-V2
• iPC - Submit Job-V2 (or V3 if you work with filenames in non-English languages). This is the Output

you click in ArtiosCAD.

iPC Output - Copying the Example Output
The first step in creating an iPC Output is to copy the example one to one you can modify.

1. Start ArtiosCAD.
2. Click Options > Defaults.
3. In Shared Defaults, expand the Outputs catalog and the Artios folder within it.
4. Right-click iPC and click Copy on the context menu.
5. Right-click the Outputs catalog and click Paste iPC on the context menu.
6. Scroll down, right-click Copy of iPC, click Rename on the context menu, and enter a new name.
7. Open the folder of the new Output and rename each entry by right-clicking it, clicking Rename on

the context menu, and entering a new name. Make sure to keep the root name of the Output the
same so that you know what it does.

iPC Output - Modifying the ArtiosCAD File Output
The next step is to modify the ArtiosCAD File Output so that you do not get prompted for a filename to
save the workspace as while running the Output.

1. In the expanded IPC Output, double-click the renamed ArtiosCAD File to open it.
2. On the Output Type tab, enable Omit Output Confirmation Dialog.
3. Click OK to return to Defaults.

iPC Output - Modifying the JDF-V2 Output
The next step in setting up an iPC Output is to modify the JDF Output.

216



6ArtiosCAD

1. Expand the iPC Output you made in the previous section.
2. Double-click the renamed iPC - JDF-V2 to open it.
3. On the Advanced tab, in the iPC System Name field, enter the system name of the Kongsberg front

end running the i-cut Production Console. It can be its hostname, its fully qualified domain name, or
its IP address.
 

 
4. Click OK to return to Defaults.

iPC Output - Modifying the Submit Job-V2 or -V3 Output
The next step in creating the iPC Output is to enter the name of the watched folder on the Kongsberg
front end.

1. In the expanded iPC Output, double-click the renamed iPC - Submit Job-V2 or iPC - Submit Job-V3
to open it.

2. On the Grouped Outputs tab, delete the default entries in the list of outputs and replace them with
the renamed ones in your renamed Output. There should be two, first ArtiosCAD File and then JDF-
V2. Each should be set to Zip, Insert into Zip archive, and Delete output disk file.
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3. On the Directories tab, in the Directory field in the Output File group, enter the UNC for the watched

folder on the Kongsberg. Also, enable Omit Save-As Filename Dialog if you do not want ArtiosCAD
to prompt you for a filename every time you run the Output.
 

 
4. Click OK to return to Defaults.
5. Save and exit Defaults, confirming the overwriting of existing Shared Defaults.

The Output is now ready for use. Shown below is a submitted job in i-cut Production Console.
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Advanced digitizer setup

Adding a non-Calcomp digitizer
If you are not using a Calcomp digitizer, the digitizer must meet these requirements:

• The digitizer must be connected via an RS-232C (serial) port on the PC.

• The digitizer must be set to Point mode. This means that only one set of positional data is sent
when a puck button is pressed.

• The data produced when a button on the puck is pressed must contain one or two characters
representing which button was pressed and also strings of numbers indicating the position of the
puck when the button was pressed. The data sent must be ASCII, not binary, and must be separated
by a carriage return (CR), line feed (LF), or both (CR/LF).

While not required, ArtiosCAD is easier to configure if the digitizer data is in a fixed format.

Once you have the digitizer connected, configured, and turned on, do the following:

1. Start ArtiosCAD and then click Options > Defaults.
2. Add an Output Destination for the port the digitizer is connected to.
3. In the Shared Defaults pane, right-click the Digitizer Setup Catalog and click New, and then click

Data. Enter the name of the digitizer, press enter, and then double-click it to open its property
page.

4. Select the proper Output Destination in the CAM Device Name: field.
5. Press a few buttons on the digitizer puck. You should see some data appear in the Decoded Data

group.
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The data format should be similar to one of the entries in the Data String column in the table
below. The letters b and c indicate button data and should always be a digit between 0–9 or a letter
between A–F.

Table: Alternate Digitizer Data Formats

Data String Button ID X-Data format Y-Data format ID position

Before After No. Fixed/
Delim

No. Fixed/
Delim

No.

APb1111122222

APc5555566666

2 0 1 F 5 F 5 ID x y

APb 1111 2222

Apc 5555 6666

2 0 1 F 5 F 5 ID x y

APbV +1234   -12

ApcV +5678  +123

2 1 1 F 6 F 6 ID x y

PQbb00012-00034+

PQcc00562+00029+

2 0 2 F 6 F 6 ID x y

   123   456  b

0 0 1 F 6 F 6 x y ID
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Data String Button ID X-Data format Y-Data format ID position

Before After No. Fixed/
Delim

No. Fixed/
Delim

No.

   197  1276  c

b  123 345

c  1234 567

0 0 1 D D ID x y

123,456,b

87,10,c

0 0 1 D D x y ID

Once you have determined which format the data is in, set the options in the Format group
accordingly.
 

 

Press buttons on the digitizing puck and check that the appropriate data is appearing in the
Decoded Data group. If it is not, adjust the format options until they do.
 

 
6. Now that the formatting is set correctly, check the Cursor Key Character Map. As you press a button

on the digitizing puck, the corresponding key should appear pressed on screen:
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The default configuration assumes the ID character generated matches the name of the button
pressed on the digitizing puck.

In most cases, the button named F always produces character F in the data string, but there are
digitizers that generate characters other than those expected. For example, some generate the
characters ; : and > for keys D, E and F and have a map like the one shown below:
 

 

You can manually set the character map by clicking the on-screen button and replacing the value in
the Current ID field with the one or two characters produced by the digitizer when the button on the
digitizing puck is pressed. Repeat this procedure for each button on the digitizing puck.

You can also set the character map using only the input from the digitizer. First, make sure the
formatting is set correctly. Next, click the on-screen 0 button and then click Input from Digitizer.
Click the 0 button on the digitizing puck to enter the value for 0. The 1 on-screen button will then
be automatically selected, so press the 1 button on the digitizing puck. Repeat for the rest of the
buttons. If you make a mistake, simply click the on-screen button you wish to reprogram, and press
the appropriate button on the digitizing puck.

7. Now that the character mapping is configured, test it by clicking Test Map. As you press buttons on
the digitizing puck, the corresponding on-screen buttons should appear pressed.
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Adjusting the step size of the digitizer
Over time, you may notice that your digitized geometry is not as accurate as you desire. While your
digitizer may be set to have 1000 lines of resolution per inch, by digitizing a 10-inch square with
extreme accuracy which results in a 10.03 by 10.06-inch square in ArtiosCAD, you realize that it is out
of calibration. The solution to this is to adjust the step size. Open the entry for the digitizer in Defaults
and adjust the entries in the Digitizer Step Size group.
 

 

Using the values stated in the previous paragraph, change the 1000 in the drop-down list box to 1003,
click the Different in Y checkbox, and change the 1000 in that drop-down list box to 1006.

Configuring the Command Map
Digitizing has 26 commands. Each can be assigned a digitizer puck key sequence and/or a digitizer
Menu Item Area. If you wish to use the command while digitizing, you must assign either a Key
Sequence and/or a Menu Item Area to the command. (If you think you will never use some of the
commands, you may choose to leave them unassigned.)

The following abbreviations are used in the table below:

• <c>  A coordinate on the digitizer.

• <p> An existing point. These are the end points (and intersection points) of existing lines in the
current design whether just digitized, or part of the original structure. To select such a point, you
must digitize a point on the digitizer within snap distance of one of these points.

• <l> An existing line. To select such a line, you must digitize a point on the digitizer within snap
distance of an existing line in the design.

Table: Digitizer Commands

Key sequence Command

2 MOVE TO <c>

12 MOVE TO <p>

0 LINE TO <c>

10 LINE TO <p>

3 ARC THROUGH <c> TO <c>

41 ARC THROUGH <c> TO <p>
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Key sequence Command

14 ARC THROUGH <p> TO <c>

44 ARC THROUGH <p> TO <p>

77 CENTER <c> RADIUS <c>

76 CENTER <c> RADIUS <p>

7A CENTER <c> RADIUS radius

66 CENTER <p> RADIUS <c>

67 CENTER <p> RADIUS <p>

6A CENTER <p> RADIUS radius

52 INTERSECT <l> <l>

51 INTERSECT <l> <l> KEEP 1st

BBB BLEND <l> <l> THROUGH <c>

BB1 BLEND <l> <l> THROUGH <p>

BBA BLEND <l> <l> RADIUS radius

D DELETE <l>

E UNDO

F REDO

CD REPLOT - SCALE TO FIT

CC REPLOT - CURRENT SCALE

CA ZOOM BACK

CF ZOOM WINDOW <c> <c>

All of these commands are mapped in the Command Map tab of the digitizer’s property page in
Defaults.
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To set a key sequence, select the command you wish to assign to the key, and then type the key
sequence to use it with in the Cursor Key Sequence field.

The sequence must be comprised of the characters 0–9 A–F. It may be up to six characters long.

A key sequence must be unique and may not mask another command. For example, if you wish to use
the Key Sequence 2 for a command, no other Key Sequence may start with 2. This is because 2 by itself
matches a command, and therefore masks a key sequence like 21.

The exception to this is when two commands differ only in what is selected — a coordinate, a point, or
a line. In this case the commands may share a command sequence. If this is used, the command will
snap to a point if one is within snap distance, or to a coordinate if one is not.

While editing this property page, you may temporarily have conflicts as described above. This is so you
can easily change Key Sequences, or swap them to different commands. However, you will be warned
about them as they are created. You may not exit the property page without resolving such conflicts.
 

 

Some commands that are not turned on by default might be very useful for your work — for example,
gasket makers may want to turn on the Center tools to make circle creation easier.

Configuring the menu
You can define areas on the digitizer that act as buttons that when clicked perform any of the digitizing
commands. A Menu is a group of such Menu Item Areas. A Menu Item Area is defined by the X and Y
values adjacent to each area and the width and height of each area. These areas are best defined in
Quadrant I (+X, +Y) with the origin of the digitizer in the bottom left corner.
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The Menu Item Area values for the above menu are shown in the following table.

Menu Item Area X Y Width Height

DELETE <l> 1/4 1/4 1 1/2

UNDO 1/4 1+1/4 1 1/2

BLEND radius 2+1/4 1/4 1 1/2

CTR. <p> RAD. radius 2+1/4 1+1/4 1 1/2

ZOOM 4+1/4 1/4 1 1/2

PLOT 4+1/4 1+1/4 1 1/2

Make sure that the Active checkbox is selected or the Menu Item Area will not be active.

Use ArtiosCAD’s drafting features to draw the menu you have programmed. Print it out at full scale and
tape it to the digitizer in the desired position. Then use the  Place Menu button on the Command Map
tab to place the menu.

Configuring Feedback and Snap
The Feedback/Snap tab of the digitizer’s Properties dialog box lets you set the snap tolerance of the
digitizer, the default radius, and the sounds heard when digitizing.
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When digitizing a point to satisfy a snap point <p> or a snap line <l>, you need to be within the Snap
Tolerance. If you are working on large corrugated designs, you may wish to set this value to something
like a quarter-inch or five millimeters. Since the command indicates whether a snap point/line is
expected, this value can be considerably larger than the normal screen snap value.

The Default radius field is used by some of the BLEND and CENTER commands. Set a sensible default;
it is easily changed while digitizing.

The Feedback / Sounds group controls the audible feedback generated while digitizing. There are five
types of feedback. Windows Sounds require a sound card in the computer; beeps can be made by most
computers.

Table: Digitizing Feedback

Type of feedback Meaning

Data Received Data received from the digitizer.

If your digitizer beeps when a puck button is pressed, you
may wish to turn this off.

Command OK The command was successful.

Snap Point/Line error You were too far away for a snap point <p> or snap line <l>
to be found.

Command not recognized The key sequence does not match any of those defined.

Geometry Error The command failed because the geometry could not be
performed. (e.g. A blend would not fit.)
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The fields in the Windows Sounds column designate which sound to use as defined in the Sounds
control panel applet.

 When clicked, the triangle button plays a sample of the sound or beep.

 The ellipsis button lets you browse for a different sound file.

The frequency and the duration of the beeps can be set using the appropriate fields.
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7.  Other tasks

Uninstalling ArtiosCAD

Uninstall ArtiosCAD by using the Programs and Features applet in Control Panel. Select it in the list
of programs and click Uninstall. You may be prompted that a reboot will be required to complete the
uninstallation.

Removing individual ArtiosCAD Programs

To remove individual parts of ArtiosCAD such as the ArtiosCAD 3D Data Exchange feature, perform a
Modify and de-select the ArtiosCAD Programs to remove. After uninstallation there may be files from
these components left behind in the ..\Esko\Artios and ..\Esko\Artios\ArtiosCADn.nn
folders; these files may be safely deleted if desired after all ArtiosCAD versions are removed.

Uninstalling SolidWorks separately from ArtiosCAD

If you have purchased the SolidWorks option and need to remove the SolidWorks Original Equipment
Manufacturer software without uninstalling ArtiosCAD, run \ArtiosCAD\SolidWorksRemove.bat
on disk 1 of the ArtiosCAD media. SolidWorks OEM software is normally removed when the version of
ArtiosCAD that installed it is removed and no other versions of ArtiosCAD are using it. This is different
from removing the SolidWorks Import/Export component of ArtiosCAD in that it actually deletes the
SolidWorks software from the system, not just the portions of ArtiosCAD that interface with it.

Removing MSDE

Uninstall the ArtiosCAD MSDE database program files by using the Add/Remove Programs applet in
Control Panel. Select Microsoft SQL Server Desktop Engine (ARTIOSCADDB) from the list of installed
programs and click Remove.

Uninstalling the database software does not remove the database data files stored in ..\Esko
\Artios\DataCenter\MSDE. This is intentional in case you want to resume using MSDE. If you will

229



7 ArtiosCAD

not be using MSDE again, you may delete the ..\Esko\Artios\DataCenter\MSDE folder and its
contents.

Removing the ArtiosCAD ODBC entry

Once all versions of ArtiosCAD are removed, open the ODBC/Data Sources applet in Control Panel
> Administrative Tools, click the System DSN tab, and remove the ArtiosCAD datasource entry by
selecting ArtiosCAD and clicking Remove.

You must remove the existing ArtiosCAD ODBC entry after uninstalling all versions of ArtiosCAD if you
wish to change ArtiosCAD database types in a subsequent installation.

Uninstalling a patch

To uninstall a patch, remove that particular build through Programs and Features in Control Panel.

ArtiosCAD will revert to the build that was present before the patch was loaded.

Modifying and Repairing ArtiosCAD

You can modify or repair the ArtiosCAD installation by clicking Change in the Add/Remove Programs
applet in Control Panel, and then by choosing Modify or Repair. You must use the original ArtiosCAD
media, or use the same network location, as when you first installed the software.

Modify allows you to change the installed features and options as if you were performing an Advanced
installation.

Repair looks for missing or corrupt files and replaces them as necessary. It will not overwrite Defaults.
You will be given the same License Disk options as when you first installed the software. If you are
trying to repair the licensing information choose Yes, I have licensing information to apply and use the
licensing diskette, otherwise choose License information already applied or unavailable to keep your
current licensing information.

Loading an ArtiosCAD patch

ArtiosCAD patches are installed using a single executable file. To install a patch, do the following:

1. Log on as Administrator, or as a user with local administrative privileges.
2. Using Windows Explorer, double-click the patch file. Patch files are named ArtiosCAD<version

and build number>.exe, such as ArtiosCAD7.1Build497.exe.
3. In the Welcome dialog box, click Update >.
4. A status bar will appear showing the progress of the patch installation.
5. Click Finish in the InstallShield Wizard Completed dialog box. The patched version of ArtiosCAD is

now ready for use.
6. Log off the system.
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Working with the ArtiosIO Status program

The ArtiosIO Status program is on the Start menu in the ArtiosCAD folder. It queries the ArtiosIO
program on a given machine and displays the active connections to that machine. Using it, you can
close a connection that is no longer responding.
 

 

To view the connections on a machine, click Query Server and either enter the name of the system
to query, or click the drop-down list button to view a list of available machines on the network. Only
machines in the same domain will be shown.

To close a connection, highlight it and click Close Connection.

Using Floating Licenses

Floating licenses allow ArtiosCAD users to share software licenses among computers. Each licenses is
accessed on an as-needed basis.

ArtiosCAD allocates licenses based on the active tools and toolbars. Tools and toolbars for which
licenses are unavailable will either be unavailable or a dialog box similar to the one shown below will
appear. The dialog box lists which users and systems have allocated the licenses you need. You can
either go ask someone to give up the license you need and click Wait for License, or you can click
Cancel and return to the previous tool you were using.
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Release licenses by exiting the design, manufacturing file, or 3D workspace which took the license.

If you click Wait for License, a dialog box showing the needed license appears:
 

 

When a license becomes available, this dialog box disappears and the desired feature is activated.

Configuring floating licenses

The Floating License Configuration program in the Esko > ArtiosCAD program group on the ArtiosCAD
License server lets you allocate floating licenses. You can reserve or deny licenses to certain systems.
When started, the program initially appears similar to the following dialog box (but with your specific
licenses listed):
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Double-click a license to configure it. A dialog box will appear in which you can reserve and deny
licenses:
 

 

Reserving a license means that the system you specify will always have the license reserved
for it. Denying a license means that the system you specify will never be able to have a license.
To specify a system, click Add. Enter the short name of the system exactly as it is shown on the
Computer Name tab of the System applet in Control Panel. The short name is the first word up to
the period - the full name minus the domain name. For example, if the full name of the system is
ArtCad1.plasticangelcontainers.com, the short name is ArtCad1. Make sure to match the case exactly,
as it will not work otherwise. Once you have entered the name, click OK.
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To remove a system from either the Reserved or Denied lists, select it, click Remove, and click OK.
 

 

When you have finished configuring the license as desired, click OK to return to the Floating License
Configuration dialog box, or click Cancel to ignore the changes you made.

To exit the Floating License Configuration dialog box, click License, and then click Exit.

Note:  If you have made changes to the configuration, the License Manager will be shut down
and restarted when you exit the Floating License Configuration program. It takes the Elan
License Manager three minutes to restart after shutting down.

Troubleshooting

If you have trouble using a desired feature and get a dialog box like the one below, use either the
ArtiosLM applet in Control Panel or the ArtiosCAD License Management utility on the ArtiosCAD
License server to make sure the server is running.
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If the Floating License Utility does not start, it is because there are no floating licenses to configure.

Upgrading ArtiosCAD Licenses

ArtiosCAD licenses enable you to use the features you have bought and disable the features you have
not bought. As your needs change, you may have to change your licenses accordingly.

When you upgrade a license, you usally receive a licensing file by e-mail. You then have to install that
file properly as described in the following section.

You must log on to your system with administrative privileges to upgrade licenses.

Note:  NO SYSTEM MAY HAVE INSTANCES OF WebCenter, ArtiosCAD, DataCenter Admin, OR
SpecLink OPEN WHEN UPGRADING LICENSES!

License Manager: keyless

To upgrade a keyless license for the FlexNet license manager, do the following;

1. Save the licensing file sent to you by Esko in a place where you can access it from the machine
whose license you will be upgrading, for example a network location, on a USB thumb drive, and so
forth.

2. On the machine with the license to upgrade, log in as Administrator or as a user with
administrative privileges.

3. Click Start > Programs/All Programs > Esko > ArtiosCAD > Activate Local Licenses/Activate
Server Licenses.

4. In the Esko (Local or Server) License Manager dialog box, click Activate.
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5. Click Next in the Activate License Wizard dialog box.
6. In the On-line activation or off-line activation dialog box, choose either On-line activation or Off-

line activation as appropriate for your system and click Next.
7. In the Your product keys dialog box, choose I have a file containing one or more product keys and

click Next.
8. In the File containing your product keys dialog box, browse for the file you saved in step 1 and click

Next.
9. In the Esko ID dialog box, enter your Esko ID and password and click Next.
10. In the Activation completed successfully dialog box, the license(s) you activated should appear.

Click Finish to complete the license upgrade.
11. Optionally, click Save Licenses Report to save a report of the license upgrade for your records.
12. Close the license manager dialog box by clicking the X in the upper right corner and test the new

license as desired.

Using Microsoft SQL Server Standard Edition with ArtiosCAD
Standard Edition

Microsoft SQL Server Standard Edition is a large, robust database which can require complex
administration. The installation documentation provided below is provided as a convenience only
for initial installation. A dedicated Database Administrator (DBA) is required to administer and
maintain the database, and is free to choose options other than those documented to meet local site
requirements.

Note:  This section refers to the full version of Microsoft SQL Server, not the Express version
which comes with ArtiosCAD

Make sure to load ArtiosCAD Standard Edition specifying Microsoft SQL Server or Oracle as the
database type before installing Microsoft SQL Server.

After installing ArtiosCAD Standard Edition, the steps to using Microsoft SQL Server with a new
installation of ArtiosCAD Standard Edition are installing Microsoft SQL Server, configuring Microsoft
SQL Server, configuring the ODBC driver, and running the database configuration batch file for
ArtiosCAD Standard Edition.

Once all that is done, you can configure servers and resources in DataCenter Admin and start using
ArtiosCAD Standard Edition.

Note:

Before you begin, find out from your IT department what the password policy is, as you will
need to know it to set the database user passwords.

Installing Microsoft SQL Server Standard Edition

This procedure describes how to install Microsoft SQL Server Standard Edition for use with ArtiosCAD.
You should only use this version if you have a dedicated database administrator available.
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1. Log in to your database server as an administrator.
2. Run the setup program on the Microsoft SQL Server media.
3. On the left side of the SQL Server Installation Center dialog box, make sure Planning is selected.

 

 
4. On the right side, click System Configuration Checker.
5. The checker will launch and automatically run. In the Global Rules dialog box, click Details, make

sure all the items passed, and click OK.
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6. On the left side of the SQL Server Installation Center dialog box, click Installation.

 

238



7ArtiosCAD

 
7. At the top of the content pane, click New SQL Server stand-alone installation or add features to an

existing installation.
8. In the Product Key dialog box, enter the product key and click Next.
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9. In the License Terms dialog box, check I accept the license terms and Privacy Statement and click

Next.
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10. The setup program will automatically run the Global Rules checks (which you have already done) and

advance to the Microsoft Update dialog box if it finds no issues needing further attention.
11. In the Microsoft Update dialog box, check Use Microsoft Update to check for updates

(recommended) and click Next.
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12. The Install Setup Files dialog box will show an action list and progress bar.

 

242



7ArtiosCAD

 
13. The setup program will check for additional conditions which could affect operation or performance

in the Install Rules dialog box. If any status says Warning, click Warning to see the issue. In this case
it was a reminder to open the appropriate ports in Windows Firewall. Click Next.
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14. In the Setup Role dialog box, click SQL Server Feature Installation and click Next.
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15. In the Feature Selection dialog box, check the checkboxes for the following features. You may have

to scroll down to see all the items in the list. You may also change the installation directories. Click
Next when you are done selecting features.
In the Instance Features group, select the following features in the Database Engine Services
group:

• Database Engine Services
• SQL Server Replication
• Full-Text and Semantic Extractions for Search
• Data Quality Services

In the Shared Features group, select the following features:

• Client Tools Connectivity
• Client Tools Backward Compatibility
• Client Tools SDK
• Documentation Components
• Distributed Replay Controller
• Distributed Replay Client
• SQL Client Connectivity SDK
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16. The setup program displays a Please Wait banner while it runs the feature rule checks, and if all the

rules pass, it skips the Feature Rules dialog box.
17. In the Instance Configuration dialog box, you may use the Default instance if desired. To

use a custom instance name, click Named instance and enter a sensible name. Do not use
ArtiosCADDB, ArtiosCADExp2005, or Esko, as these will interfere with the installation of
ArtiosCAD. If you use a custom instance name, make a note of the Instance ID as you will need it for
the database scripts batch file later. Click Next.
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18. In the Server Configuration dialog box on the Service Accounts tab, review the service startup

types and change them if desired.
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On the Collation tab, if you do not want to use the default collation (a group of location-related
settings), click Customize and change it. Make sure to choose one that supports Unicode, is case-
insensitive, and is accent-sensitive.
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Click Next.

19. In the Database Engine Configuration dialog box, click Mixed Mode (SQL Server authentication and
Windows authentication). For the password, enter a password of your own choosing that complies
with your local password policy in both password fields. Make sure to record this password in a
secure location as you will need it later. In the Specify SQL Server administrators group, click Add
Current User to add yourself as a database administrator, or click Add to add other users or groups
as database administrators. You must add at least one account. Click Next.
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20.Click Next in the Distributed Replay Controller and Distributed Replay Client dialog boxes. The

setup program will run the rules in the Feature Configuration Rules dialog box automatically and if
everything successfully passes, will proceed to the Ready to Install dialog box.

21. In the Ready to Install dialog box, scroll down the list of actions and verify them for accuracy. Click
Install to begin installing the software.
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A progress bar will appear.
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22.In the Complete dialog box, review the list of features to make sure they succeeded. Click Close.
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23.Click Install SQL Management Tools.
24.In the Web page that opens, follow the instructions to download and then install SQL Server

Management Studio if it is not already installed on this machine.
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25.Restart the computer if prompted. If not, close the SQL Server Installation Center.
26.Open Windows Update and install updates for Microsoft SQL Server and related programs if it finds

any.
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Microsoft SQL Server Standard Edition is now installed and ready for you to configure it for use with
ArtiosCAD.

Configuring Microsoft SQL Server Standard Edition

Once you have updated and patched Microsoft SQL Server appropriately, continue as follows.

Creating the ArtiosCAD database
If you rebooted the machine, log in as a user with administrative privileges.

1. Click Start > Microsoft SQL Server Tools <year number> > Microsoft SQL Server Management
Studio.

2. In the Connect to Server dialog box, make sure the Server type is set to Database Engine and the
Server name is set to this machine. Change the Authentication to SQL Server Authentication, enter
sa as the Login, and enter the password you chose for the sa user for the Password. Click Connect.
 

 
3. Right-click Databases and click New Database.
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4. In the New Database dialog box, for the Database Name, enter ArtiosCADdb. Do not click OK.
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5. Click the 8 in the Initial size (MB) column and change it to 10. Do not click OK.
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6. If this is a normal computer with one hard drive and two hard drive controllers, click OK. If this is

a high-end database server and has multiple hard drives and multiple controllers, use the scroll
bar to scroll to the right, click the Browse (...) button for the ArtiosCADdb Log file, and locate the
transaction log on a separate disk on a separate controller. This will minimize data loss when a hard
drive crashes. Click OK when done.

The ArtiosCADdb database should appear in the group of databases as shown below.
 

 
The database is now created and the next step is configuring the ODBC driver.

Configuring the ODBC driver
As ArtiosCAD is a 64-bit application, it must use a 64-bit connection to a database. If you have installed
ArtiosCAD on the database server, the installation process creates a shortcut to the 64-bit ODBC
configuration application in Administrative Tools.

1. Log in as Administrator or as a user with administrative privileges.
2. If you have installed ArtiosCAD on this computer, click Start >   > Windows Administrative Tools >

Data Sources <bitness>.
3. In the ODBC Data Source Administrator, click System DSN and click Add.
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4. Select SQL Server from the list of available drivers and click Finish.

 

 
5. In the Create a New Data Source to SQL Server dialog box, enter ArtiosCAD in the Name and

Description fields and select the server and instance name in the Server drop-down list box. If this
is a client, specify the name of the database server. Click Next.
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6. When asked about authenticity, select the With SQL Server authentication... choice. In that same

dialog box, deselect the Connect to SQL Server ... checkbox. Do not click Next.
 

 
7. Click Client Configuration. The Add Network Library Configuration dialog box appears.
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a) Make sure TCP/IP is selected in the Network libraries group and ensure the server name is

correct. If (local) was selected in the Which SQL Server do you want to connect to? field in Step
5, only a period (.) appears in the Server alias field and Server name field.

b) Ensure that Dynamically determine port is checked and that the Port number is set to 1433.
Click OK.

c) Click Next in the Create a New Data Source to SQL Server dialog box.
8. In the next dialog box, leave the Use ANSI... choices selected and click Next.
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9. In the next dialog box, leave Perform translation for character data selected. If the system is using
non-U. S. locale settings, check the Change the language of SQL Server system messages to:
checkbox and set the value to English. Click Finish.
 

 
10. The ODBC Microsoft SQL Server Setup dialog box will appear showing a summary of the

configuration. Do not test the configuration; it will most likely fail because it is set to use SQL
Server authentication and your operating system login credentials won’t work. Click OK.
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11. Click OK in the ODBC Data Source Administrator dialog box.

The ODBC connection on the server is now configured properly. The next step is running the database
configuration batch file.

Running the ArtiosCAD database configuration batch file
Make sure the ODBC connection to the ArtiosCAD database is configured as described in the previous
section before running the batch file.

To run the ArtiosCAD database scripts, do the following:

1. You should still be logged in as Administrator or as a member of the Administrators group. If not,
log in as such.

2. Start a command prompt and change the directory to \Esko\Artios\DataCenter. If you do
not have ArtiosCAD installed on the database server, copy the entire DataCenter directory and
subdirectories from a system with ArtiosCAD on it to a local temporary folder to which you have
write access.

3. Build the database schema. The schema build command is in the form
Build_MSSQLServerSchema “<sa_user_Password>” “<server name>\<instance name>”
“<DataCenter root directory>” “<DataCenter program language directory>” “<type of
authentication>” “<Database name>” “<Password for new programmer user>”. The type of
authentication can be either windows or sql. The new programmer user will be the database user
ArtiosCAD uses to connect to the database and this password needs to adhere to your network
password policy; make a note of this password and store it in a safe place as you will need it when
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you update ArtiosCAD in the future. The command should be similar to the one shown below,
substituting your installation information and language as needed.

Build_MSSQLServerSchema “SysP433w0rd**” “RDVMLUDWCDOC01” “C:\Esko
\Artios\datacenter” “C:\Esko\Artios\datacenter\program64\english” “sql” “ArtiosCADDb”
 “Programmer!!”

When you have typed the command, press Enter. Comments and commands will appear in the
command prompt similar to example shown below.
 

 
4. When the command prompt returns, type exit and press Enter.

The database is now ready for use with ArtiosCAD and DataCenter Admin. Add servers and resources
as described in the Working with servers and resources section of the DataCenter chapter.

Notes and troubleshooting
The following notes deal with using SQL Server Management Studio in the Microsoft SQL Server folder
on the Start menu.

• If error messages appear about not being associated with a trusted SQL Server connection, right-
click the server instance name, and then click Properties > Security. Make sure SQL Server and
Windows Authentication mode is selected in the Server authentication group.

• If many script errors appear, make sure the Implicit transactions checkbox is clear on the
Properties > Connections page in the Default connection options list.

• If error messages appear about the programmer user not existing or not having permission, do the
following:

• Expand the database instance in the left pane so the Security folder is open and double-click
Logins.

• Right-click programmer and click Properties.
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• On the General page, there should be a password set in the Password field, the Default database
should be set to ArtiosCADdb, and the Default language should be set to English. If this is not so,
click the Server Roles page and ensure that public is checked.

If you are using SQL Server Express Edition and you need to run the database script batch file, use
Build_ExpressSchema.bat with the same syntax as Build_MSSQLServerSchema.bat.

If you notice errors as the script tries to build hierarchical boards, it may be that the programmer
user was not created correctly. Make sure you specified a password that complies with your network’s
password policy.

Using Oracle with ArtiosCAD Standard Edition

You may use Oracle as the ArtiosCAD database engine, but Esko cannot help you install, configure,
or maintain it. Only use Oracle if you have dedicated Oracle database administrators skilled in its
operation.

Here is a rough overview of the steps required for installation:

• Install Oracle and create an instance. Within that instance create a database. To take advantage of
ArtiosCAD language support in versions 18.1 and later, set the character set to AL32UTF8 and set
text columns to use VARCHAR. Set up network access to it using Net Configuration Assistant to
connect to that database.

• Install ArtiosCAD Standard Edition on the database server, making sure to do a Server/Custom
installation of type Advanced and selecting Microsoft SQL Server or Oracle as the database
choice.

• Set up an ODBC Data Source using the Microsoft ODBC for Oracle driver. Set the
Data Source Name: to ArtiosCAD, the Description: to ArtiosCAD, and the Server: to
TNS:Name_of_database_defined_in_Net_Config-uration_Assistant that you configured when
installing Oracle, such as TNS:orcl. To take advantage of ArtiosCAD language support in versions
18.1 and later, on the Workarounds tab, check Force SQL_WCHAR Support.

• Run the database configuration batch file to build the database schema.

Start a command prompt and change the directory to \Esko\Artios\DataCenter.

The schema build command is in the form Build_OracleSchema “<sys Password>” “<TNS name>”
“<DataCenter root directory>” “<DataCenter program language directory>”.

If the sys database user has no password, use a double set of quotation marks (“”).

The final command you type at the command prompt should be similar to the one shown below,
substituting your installation information and language as needed.

Build_OracleSchema “administrator” “orcl” “C:\Esko\Artios\datacenter” “C:\Esko\Artios
\datacenter\program\english”

• Add servers and resources as described in the Working with servers and resources section of the
DataCenter for Standard Edition chapter.

265



7 ArtiosCAD

Note:  If WebCenter and your production installation of ArtiosCAD (not the one required for
WebCenter’s Application server) are using the same database server with Oracle 9i, and you
upgrade the version of Oracle on the database server, it may break the Microsoft ODBC for
Oracle drivers required by ArtiosCAD. Please note that this is NOT a supported configuration
and you alone are responsible for ensuring that it works. If you upgrade Oracle and start getting
SQLSetConnectAttr errors, try changing two entries in the Registry on the database server.
Specifically, in HKEY_LOCAL_MACHINE > Software > Microsoft > MsDTC > MTxOCI, change the
OracleSqlLib key to orasql9.dll and change the OracleXaLib key to oraclient9.dll.

Replacing an ArtiosCAD server

As time passes, you may need to replace an existing ArtiosCAD server with a newer, faster model.
Listed below are the basic steps required to replace a machine acting as the Defaults server, Database
server using MSDE, and License server using a security key. Contact Esko Support for more details.

1. Make a complete backup of the system that is being replaced and verify that the data is readable.
Keep this backup in safe, easily-accessible place.

2. Install the same version of ArtiosCAD on the new server as is currently on the existing server. Make
sure to specify the same licensing method.

3. For pre-16 versions of ArtiosCAD, copy the ..\Esko\Artios\ArtiosCADn.nnll\ServerLib
folder from the existing server to the new server. For version 16 or later, copy ..\Esko\Artios
\ServerLib.

4. If your old server uses a security key, copy ..\Esko\Artios\ArtiosCADn.nnll\Common
\tuneopt.txt and/or tuneopt7.txt on the old server to the corresponding directory on the
new server.

5. Move the security key to the new server.
6. If your old server uses a license manager, deactivate the license and copy the deactivation files to

the new server. Activate the license on the new server.
7. Start ArtiosCAD on the new server and click Options > Defaults.
8. Go through the various entries and adjust them as necessary, specifically the entries for Output

devices and other things which may contain system names or paths.
9. An exact image copy of the database from the old server will be made on the new server. Therefore,

put the user files (if any) in the same location in the file system on the new machine as on the old
machine.

10. On the old system, detach the database using the following procedure:

• Log in as a member of the Administrators group.

• Start a command prompt.

• At the prompt, type osql -Usa -P”” -S systemname\ArtiosCADdb and press Enter.
(If the sa password is not blank, insert it between the quotation marks in the -P switch.)

• At the 1> prompt, type sp_detach_db ‘ArtiosCADdb’ and press Enter.

• At the 2> prompt, type go and press Enter.

• At the 1> prompt, type quit and press Enter.
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• Type exit and press Enter to close the command prompt.
11. On the new server, do the same thing to detach the empty, just-installed MSDE database:

• Log in as a member of the Administrators group.

• Start a command prompt.

• At the prompt, type osql -Usa -P”” -Ssystemname\ArtiosCADdb and press enter. (If the sa
password is not blank, insert it between the quotation marks in the -P switch.)

• At the 1> prompt, type sp_detach_db ‘ArtiosCADdb’ and press enter.

• At the 2> prompt, type go and press enter.

• Do not close this program as it is needed for a future step.
12. Copy the database files from the old server to the new server. They are in the ..\Esko\Artios

\DataCenter\MSDE\MSSQL$ARTIOSCADDB\Data directory. Copy ArtiosCADdb_data.mdf and
ArtiosCADdb_log.ldf to the corresponding directory on the new server. If prompted to overwrite
existing files, say yes.

13. On the new server, attach the new database files to the instance:

• In the command prompt window running osql, at the 1> prompt, type sp_attach_db
“ArtiosCADdb”, “C:\Esko\Artios\DataCenter\MSDE\MSSQL$ARTIOSCADDB\Data
\ArtiosCADdb.mdf” and press enter. Note: Do not omit the comma. Also, change the path to
the .mdf file as needed if you did not install ArtiosCAD to the C: drive.

• At the 2> prompt, type go and press enter.
14. Reconnect the programmer database login to the database instance:

• At the 1> prompt, type use ArtiosCADdb and press enter.

• At the 2> prompt, type go and press enter.

• At the 1> prompt, type sp_change_users_login update_one, programmer, programmer, null
and press enter.

• At the 2> prompt, type go and press enter.

• At the 1> prompt, type quit and press enter.

• Type exit and press enter to close the command prompt.
15. In DataCenter Admin, go through the entries for servers and resources and adjust them as

necessary.
16. If the old server used ArtiosIO, configure and start it on the new server.
17. On each client, use Programs and Features in Control Panel to Change and then Modify the

installation of ArtiosCAD. Specify the name of the server as appropriate.

ArtiosCAD should now be fully functional on the new server and any clients.
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8.  Defaults

Introduction to Defaults

Defaults store all the configuration information used by ArtiosCAD. This is where you change options,
add custom standards to the Standards Catalog, define Outputs, and so forth. You access defaults by
clicking Defaults on the Options menu. There are many options in Defaults that are not covered in this
chapter; you should open each Defaults catalog or folder and review its contents.

If you are using ArtiosCAD Enterprise, Defaults specific to it are in the Installing and Configuring
ArtiosCAD Enterprise chapter. If you do not see the information you are looking for in this chapter, look
in that one.

There are two types of defaults: Shared defaults and User defaults. Shared defaults are shared by all
users served by the same ArtiosCAD server. User defaults affect only the machine being used.
 

 

Creating defaults

There are three ways to create new defaults:

1. In the Shared defaults pane, open the folder containing the Defaults you want to add to and right-
click. Clicking Folder adds a new folder; clicking Data adds a new default setting.

2. In the User defaults pane, make sure nothing is selected, and right-click. Choose the type of default
to add from the pop-up context menu. When naming the new item, do not use a backslash (\).

3. Drag a pre-existing default from one pane into the other and modify as desired.
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Changing defaults

To change a default, open the folder it is in and double-click it. A dialog box will appear showing all the
settings you can change.

If you want to change all the defaults in a folder at once, double-click the folder instead of an individual
item, and a tabbed dialog box will appear containing all the individual items.

Saving defaults

It is very important to save the defaults after you make changes. The option button above the two
panes indicates which set of defaults is being affected by the commands on the File menu. Make sure
the option button is set to the pane of defaults you have changed, click File, and then click Save.

Searching for Defaults

Use the Keyword Search field at the top of the Defaults dialog box to search Defaults for your desired
terms. This searches across all the Defaults currently shown in the dialog box; if you have Example
defaults open instead of User defaults, it will search the Example defaults and not User defaults.
 

 

The search looks in:

• Node names / catalogs
• Labels
• Field contents

 Click the magnifying glass after you have entered your desired terms in the Keyword Search field to
perform the search. You may also press Enter instead of clicking the magnifying glass.

 Click Clear Search to erase everything in the Keyword Search field and clear any search results
shown in the Defaults dialog box.

 Click or hover over the Information button to see a list of searching syntax.
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ArtiosCAD builds the search index in memory each time you perform a search. It does not store it for
future use. As such, searching speed is directly related to computer performance.

Performing a Defaults Search

Let's say you change the Chamfer for corner value every time you create a dieboard. You want to
change it in Defaults but you don't know where to look.

1. Click Options > Defaults.
2. In the Defaults dialog box, enter "Chamfer for corner" in the Keyword Search field and either

click the magnifying glass icon or press Enter.
3. ArtiosCAD performs the search and highlights tree nodes that have hits in yellow. ArtiosCAD dims

all the other nodes but they are still functional.
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4. In this example, since you are not working with blanking, the value you want to change must be in

the Manufacturing parameter sets catalog.
5. Keep expanding the highlighted nodes until you see Wood corners in the Die board catalog. Double-

click it to open it.
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6. Change the Chamfer for corner field as desired and click OK to close the dialog box.
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At this point, you could look at the other search results in case you want to change them too.

To restore the regular view, click the red X.

Save and exit Defaults as usual.

Defaults performance

ArtiosCAD loads Defaults into system memory when you launch it for more robust performance.

If you make changes to Defaults, click Options > Clear Defaults Cache to re-read Defaults into memory
without having to restart ArtiosCAD.

ArtiosCAD re-reads the Defaults automatically when you click Options > Defaults, so you only need to
clear the cache when you make a change and exit Defaults and then continue working in ArtiosCAD.
Another time to clear the cache would be when you changed Defaults on one computer and other users
were sharing those Defaults on other computers and did not want to restart ArtiosCAD; they would
have to click Clear Defaults Cache to see your changes.
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 Parameter sets

Designer parameter sets

Parameter sets are collections of settings that govern how you work with designs or manufacturing
files. The collection can be based on anything – by customers, by machines, or however else you want
to group information.

Single design parameter sets allow you to assign different values to different sets for the following
entries:

• Default bridging formulae to use

• Flute/grain setting, and if ArtiosCAD rotates designs based on standards to match

• Side up, and if ArtiosCAD mirrors designs based on standards to match

You select a parameter set when creating a design. You can change the parameter set being used by a
design by clicking Change Parameter Set on the Options menu.

To create a parameter set, do the following:

1. Start ArtiosCAD.
2. Click Options, and then click Defaults.
3. To add a parameter set to Shared Defaults, open the Single Design Parameter Set entry. Right click

it, select New, and then click Data.
4. Enter the name of this new parameter set and press Enter.
5. Click the plus sign (+) next to the parameter set you created.
6. Double-click Startup defaults. This will bring up a tabbed dialog box where you can set the initial

side of the design, a default flute/grain direction, and default bridging formulae.
7. Click OK when you are done setting options for this new parameter set.
8. Click File, and then click Save to save the changes.

Manufacturing parameter sets

Manufacturing parameter sets, in conjunction with machine parameter sets, allow you to customize
various settings per set or per machine. A partial list of the values you can set are:

• Die board size

• Automatic stripping parameters

• Default bridging formulae

• Hole mounting pattern workspaces and the side of the die used to determine if they are mirrored or
not

• The Machine Reference Point, used by many things for alignment

• Settings for scrap/chop knives

• Mounting alignment hole parameters
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A manufacturing parameter set references a die press parameter set and a printing press parameter
set in addition to containing its own values.

To create a die press or printing press parameter set, do the following:

1. Start ArtiosCAD.
2. Click Options, and then click Defaults.
3. To add a parameter set to Shared Defaults, open the Die Press Parameter Sets or Printing Press

Parameter Sets entry. Right click it, select New, and then click Data.
4. Enter the name of this new parameter set and press Enter.
5. Click the plus sign (+) next to the parameter set you created. The parameter set expands to show the

top-level categories. Click each plus sign to open each category.
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6. Double-click each entry, verify or change the settings within the dialog box that opens, and click OK

when done. Repeat as desired for other settings.
7. Click File, and then click Save to save the changes, clicking Yes to overwrite previous Defaults.

Once the die press and printing press parameter sets are created, they can be incorporated into a
manufacturing parameter set.

To create a manufacturing parameter set, follow the same procedure as creating other parameter sets:
right-click Manufacturing parameter sets, click New, and so forth. Next, do the following:
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1. Double-click the name of the parameter set to associate die and printing press parameter sets with
it. Click OK once you have chosen sets.
 

 
2. Open the parameter set and enter values for all the fields. Your Defaults pane with all catalogs

expanded should look similar to the picture shown below.
 

277



8 ArtiosCAD

 
3. Click OK in each parameter’s dialog box to save the changes.
4. Click File, click Save to save the changes, and then click Yes to overwrite previous Defaults.

Note:  Changing the default die press parameter set and default printing press parameter
set has no effect when choosing a manufacturing parameter set. To change the die press
and printing press parameter sets used by a manufacturing parameter set, change the
manufacturing parameter set itself, and not the default die press and printing press selections.

Counter parameter sets

As with single design and manufacturing parameter sets, Counter parameter sets group counter
parameters together for easy manipulation. You can copy a parameter set and modify it to meet your
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unique needs, or you can create a new parameter set by right-clicking and selecting New on the
context menu.
 

 

Double-click a parameter set to open it for editing.

Tool Angles, Widths tab
Shown below is Tool Angles, Width tab of the Artios counter parameter set for phenolic resin (plastic)
counters and the Steel counter parameter set for steel counters. The Type of counter selection
controls the options ArtiosCAD shows on the tabs across the parameter set.
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Fields followed by f(x) indicate that the parameter being set is dependent on the board. Clicking
f(x) leads to the Edit Expression dialog box, where the following parameters should be used to build
expressions:

#CWIDTHWG Width of with grain creases

#CWIDTHXG Width of cross grain creases

CAL Board caliper

The parameters for counters are configured like this:
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Description Workspace
Variable

Default Expression Notes

Counter thickness CHGT ROUNDUP(CAL+0.007*#I,
0.002*#i)

Affects the periphery
and chamfer tool
offset.

Crease channel
depth

CRECHD CAL+0.002*#I For information only.
Does not affect tool
paths.

Chamfer depth
(plastic counters
only)

CHAMFD CHGT-0.004*#I Automatically limited
by maximum chamfer
width.

With grain channel
width

CHWWG #CWIDTHWG+2*CAL

Cross grain channel
width

CHWXG #CWIDTHXG+2*CAL+0.004*#I

The Maximum Chamfer Diameter is usually the diameter of the chamfer tool head.

Periphery tab
The Periphery tab of the counter parameter set dialog box contains settings which affect the
periphery tool. This tab only appears for plastic counters.
 

 

The parameters on this page of the dialog box are all measurements whose functions are illustrated in
the pictures next to them except for the Periphery Tool Angle. The angle specified in the Periphery Tool
Angle field, along with the thickness of the counter material, determines the width of the periphery.
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Crease End tab
The Crease End tab of the counter parameter set dialog box controls how the crease ends are
machined. This tab only appears for plastic counters.
 

 

The options in the Crease End Option group, Use Periphery Tool Only and Use Crease End and
Periphery Tools affect the display of the rest of the tab. If Use Periphery Tool Only is selected, all the
pictures change to omit any reference to the Crease End tool’s existence.

Partial cut tab
Partial cuts and glue assist lines can have the counter extend underneath them if you so desire. This
tab appears only for plastic counters.
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By default, Partial Cuts are set to be On the counter. Glue assist lines are set conditionally by default.
They are off the counter if the distance between the crease and the closer end of the line is greater
than the minimum specified in the Minimum field. Of course you can specify them to be On or Off all the
time.

Cut and Crease tab
For plastic counters, the options on the Cut and Crease tab affect the creation of bowties, which are
special constructs made necessary by having cuts and creases of such short length. All of the options
are explained in the pictures.
 

 

For steel counters, ArtiosCAD offers the following choices on the Cut and Crease tab:
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• Single channel like a crease, which makes one long channel

• From end of segment plus channel width

• From end of segment

• No channel

For separate channels, ArtiosCAD can measure the land from the end of the line or the edge of the
channel. ArtiosCAD sets the land at both ends of a cut-crease line the same way as a normal crease.
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Chamfer tab
The options on the Chamfer tab affect the counter at those places in the design where cut lines and
the ends of crease lines meet. The chamfer mostly follows the periphery except it always stays a
specified distance away from crease channels. This tab only appears for plastic counters.
 

 

The Chamfer Gap is the distance between the inside edge of a chamfer and the crease channel. The
Pickup and No Pickup options control whether the chamfer is continuous around the end of the crease
channel. The Chamfer Tool Angle is the angle of the tool, which, together with the thickness of the
counter material, determines the width of the chamfer channel.

Reverse Creases tab
Reverse creases are used to make a panel fold outward instead of inward.
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The Insert option indicates that a piece of foreign material will be attached to the counter to create
the reverse crease. This is shown in the top picture on the tab. Counter material means that an area
around the reverse crease will be milled out so that the board gets pushed into the depressed area.
This is shown in the bottom picture on the tab. The Crease Width field becomes available when this
option is selected. Off the counter disables all the fields.

Geometry macro is available only for steel counters and lets you choose a geometry macro from the
Steel Counters geometry macro catalog. Should you choose to create your own geometry macro, use
these guidelines:

• make the horizontal outline of a milling area using line type Counter mill outline
• make it rebuildable with a variable length using L for the variable

 

 
• add the geometry macro to the catalog with Steel counter reverse rule as the placement option
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• for an insert, design it with corner relief so that the insert can be easily placed and removed

• for counter material, the macro should make one side.
 

 

Note:  ArtiosCAD treats curved reverse creases and reverse cuts like straight lines. You will
need to manually edit these areas.

Reverse Cuts tab
Reverse cuts are made on the counter in the same way as the Insert method for reverse creases. The
parameters on the Reverse Cuts tab are explained in the picture.
 

 
As with the Reverse Creases tab, Geometry macro appears only for steel counters. When you enable
a geometry macro, all the fields on the tab become unavailable except for Set Back. Follow the same
guidelines for using geometry macros as explained in the Reverse Creases tab section.
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Crease Channel Ends tab
The fields on the Crease Channel End tab control the shape of the crease channel ends, the length of
the crease channel cutback, what happens when creases meet, and the minimum length of a crease
channel. This tab appears only for steel counters.
 

 
In the Shape group, choose either Round or Square. Land (the distance between the actual end of the
channel and a line meeting it) is available for both round and square shapes, but Tool radius is only
available when using a square tool. Make sure this is accurate so that ArtiosCAD can correctly calculate
the land.
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In the Creases meet at sharp angle group, the picture changes depending on which option you select.
No Processing lets the channels overlap and is sucient for most designs. The Priority choices keep
channels that meet from overlapping by shortening them in different ways.

• Priority equal: channels shortened by the same amount so they do not cross
• Priority middle: channels shortened so they do not cross, with the middle channel left closest to

the original length
• Priority side: channels shortened so they do not cross, with the side channels left closest to the

original length

If only two creases meet, the crease closer to horizontal/vertical is considered the middle crease.
When four or more creases meet, ArtiosCAD sets the priority of the three closest creases and
shortens the remainder as needed so they do not cross; use the Shorten Creases tool to make manual
adjustments.

Merge merges them together to avoid sharp corners using the Merge radius for the inside corners. For
this to work properly, the milling tool diameter needs to be smaller than the channel width.

Use Minimum length to set the smallest allowable channel length.

Embossing tab
An area of the board can be embossed by milling out the part of the counter surrounding the embossed
area. This tab only appears for plastic counters. Embossing works differently for steel counters and
is not defined by the parameter set. As with other tabs, the parameters on the Embossing tab are
explained in the picture.
 

 

Position Holes tab
The Position Holes tab contains one parameter - the workspace name for the position hole. This tab
appears only for plastic counters. Click Specify to browse for a new workspace.
 

 

290



8ArtiosCAD

Tack Bridges tab
The Tack Bridge Width field on the Tack Bridges tab sets the width of tack bridges in the periphery of
the counter. This tab is available only for plastic counters.
 

 

Name tab
The choices on the Name tab affect the output of the Name tool on the Counter toolbar. This tab
appears only for plastic counters. These choices include the font to use, its size, and its position, as
shown in the picture.
 

 

Blanking Parameter Sets

Blanking machine parameter sets control how ArtiosCAD constructs the blanking tooling per machine.
In this way, ArtiosCAD can easily create the right size tooling for machines of different sizes. The values
set in these parameter sets are for:
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• Frames
• Lower blanker board wood alignment
• Non-stop swords
• Photocells
• Pressers
• Tie-bolt holes
• Upper blanker board requirements and wood alignment

If you use BSI frame kits, specify the one to use in the Frame catalog as described further in this
section.

For information about configuring the various options, please refer to the Blanking section in the
Manufacturing chapter.

Blanking parameter sets control how ArtiosCAD constructs the blanking tooling for different types
of blanking solutions for any machine. The idea is that you first choose the machine (which will then
set the sizes and tolerances from the blanking machine parameter set) and then the kind of blanking
solution you will be using on that machine (defined by the blanking parameter set). The values set in
these parameter sets are for:

• Blank holes
• Frame clearance, construction, and size
• Grid
• Lower blanker board allowances and wood corners
• Non-stop swords
• Pusher details
• Pusher edge
• Tool controls
• Upper blanker board allowances and wood corners

Changes from previous versions include:

• In a Blanking machine parameter set, in the Frame dialog box, Min to Inner and Max to Inner now
match those from BSI software.

• The BSI Flat top blanking parameter set uses the support rail corresponding to the machine and
the BSI 5mm Adhesive Runner (A02019). Other parameter sets use a non-component support rail
specified by a width.

Defining a BSI Blanking Frame Kit
If you are using a BSI blanking frame kit with your set of blanking tools, you specify its parts in the
blanking machine parameter set for the press and its usage in the blanking parameter set.

1. Start ArtiosCAD and click Options > Defaults.
2. Open the Blanking machine parameter sets catalog.
3. Open an existing parameter set or create a new one.
4. Double-click Frame to open the Frame dialog box.
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5. Click More Options ( ... ) at the end of the Frame kit # field. This opens an empty Frame Kit Definition

dialog box.
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6. Enter the frame kit number in the Frame kit # field.
7. For the rails, corner, and centerline device, choose the BSI part from the drop-down list box.
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8. Enter the Quicklock kit number in the Quicklock kit # field.
9. Choose the Quicklock part from the Quicklock drop-down list box.
10. Click OK to save the frame kit definition.
11. Choose the support bar number to use with this frame from the Support bar # drop-down list box.
12. Click OK to save the change to the blanking machine parameter set and return to Defaults.
13. Open the Blanking parameter sets catalog.
14. Open an existing blanking parameter set or create a new one.
15. Open its Frame catalog and double-click Frame Construction to open the Frame Construction

dialog box.
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16. Check Use frame kit, which will make the options in the Hardware group unavailable.
17. Choose an option in the Mounting/scrap rails drop-down list box and check Lateral support bars if

your tooling will use them.
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18. Click OK to return to Defaults.
19. Save and exit Defaults normally.

When you choose this blanking machine and blanking parameter set when using the blanking tooling
creation tools, ArtiosCAD will construct the parts according to the BSI frame kit parts you specified.

Rubber types

ArtiosCAD has a default Rubber types catalog. Review its entries and modify or add to them as
necessary to meet your needs.
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A rubber type is defined by its unique name, thickness, and stock sheet size. If there are rubber types
defined that are different thicknesses of the same material, include the thickness in the name, as each
name must be unique.

To edit a rubber type, double-click its name. To create a new rubber type, right-click the Rubber types
catalog and click New > Data on the context menu.

Shown below are the properties for the Red Neoprene rubber type.
 

 

Reversible indicates if the top and bottom sides of the rubber are the same, so that a piece of rubber
and its mirror image could be considered the same when making layouts. (This is different from the
mirror options in Auto-Repeat.)

The value in the Rubber code: field is what is used on the Sheet Filename Generation page of the
rubber sheets Output. Use letter and numbers only with no spaces.

Set the Sheet width: and Sheet height: fields to the appropriate sizes of the sheets for this type of
rubber.

The Thickness: field is currently unused, but to prepare for its possible use in the future, enter the
thickness of the sheet.

Select color sets the color of the rubber when Rubber Fill is selected in the Rubber View Options dialog
box. Clicking it opens a color palette.

The four option buttons set the type of the rubber.

• Isotropic means it is the same in all directions, so can be rotated as necessary.

• Wave means it is rippled, and the long dimension of the rubber must cross the ripples. This type of
rubber is generally used in long, narrow slots. Wave rubber pieces are put on the sheet with their
longest dimension horizontally regardless of the state of Fill from left.

• Strip/Profile means that it is premanufactured rubber that is not calculated for layouts, but can be
drawn on the dieboard so that it can be placed correctly after manually being cut.
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• Plastic cover causes ArtiosCAD to nest the pieces of the plastic cover (if one is used) as if they were
rubber.

Width is the width of the rubber when it is cut.

Offset from side of rule is the distance from the edge of the rule to the edge of the rubber which allows
for pointage.

Once you have finished modifying an existing rubber type or creating a new one, click OK to return to
Defaults, and then click File > Save to save the changes.

Rubber parameter sets

As with single design and manufacturing parameter sets, rubber parameter sets group rubber
parameters together for easy manipulation. We recommend copying the RubParamExample
parameter set and modifying it to meet your needs, but you can create a new empty parameter set by
right-clicking Rubber parameter sets and selecting New > Data on the context menu.
 

 

Bolt holes

After the rubber is made, it needs to be trimmed to allow for bolt holes, but because of the placement
of the holes, the trimming may affect how pieces are auto-repeated. Therefore, this dialog box controls
whether the trimming is automatic or not by the state of Subtract bolt holes. If bolt holes are not
automatically subtracted from the rubber, the Subtract Bolt Holes tool allows for manual trimming
after the rubber is created.
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The rest of the fields in the dialog box determine how much rubber will be trimmed.

If the hole in the dieboard is almost circular and less or equal to the specified size, a circular hole of the
specified size will be made in the rubber. If not, the hole in the dieboard will be copied into the rubber.

Laser position holes can be made using lines of linetype Laser position hole or Unknifed diecut. They
can be triangular, square, hexagonal, octagonal, must be a reasonable size of less than 16mm, and fit
around a circular pin. If a laser position hole is recognized, the hole in the rubber will be offset by the
specified offset. If the laser position hole is not recognized, the hole will be copied without an offset.

Click OK when done to return to Defaults.

Breaker knives

Breaker knives are also known as stripping rules. When used in Rubbering, they are the stripping rules
on the outside of the die. Sometimes they are rubbered to prevent injury to the people handling the
dieboard. The options in the Breaker Knives section of the parameter set control how far the rubber
extends past the sheet edge. Choose the desired option button and click OK to return to Defaults.
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Crease Mask

The options in the Crease Mask section of the parameter set control how the rubber is cut back near
creases.
 

 

The options in this dialog box are made available or unavailable by the state of Make Plastic Cover
in the General section of the parameter set. When that option is not selected, the controls in the
bottom half of this dialog box are unavailable, and when it is selected, the controls in the top half are
unavailable.

For normal areas of the design, the options along the left side of the top quarter of the dialog box are
the distance that is cut back from the crease, and the values on the right side are the angles at which
the cuts are made. Each end of the cutback is the same as it is symmetrical.

For thin areas of the design, the rubber pieces are smaller so there are fewer cutbacks.

When a plastic cover is used, set the offsets from the plastic cover edge and from the edge of the
crease rule as desired.
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Click OK when done to return to Defaults.

Cut/Crease

ArtiosCAD can treat cut/crease rules as if they were cuts, or creases, or a mixture of the two. They
need to have different parameters than the standard crease mask so that the angle of the cutbacks
can be greater, so these are set in the Cut/Crease section of the parameter set. Also, rubber pieces for
cut/crease rule are made thicker (to the thickness you specify in this dialog box) so they do not break at
the thin points.
 

 

In the Treat cut/crease group, Like cuts, Like creases, and Use parameters below all behave as their
names imply. Use parameters below enables the distance and angle fields for the crease cutback.

Click OK when done to return to Defaults.

General

The General section of the parameter set contains settings that affect the overall creation of the
rubber.
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Add blend causes the Rubber Area, Add Rubber, and Subtract Rubber tools to add blends to the rubber
of the size specified in the Blend radius: field.

Fixed width, Open out, and Fill set the style of rubber ArtiosCAD makes.

The Open out tack width: sets the width of the connecting piece of rubber left at the end of an open-
out.

In the Make splits group, the title control determines if ArtiosCAD limits the length of pieces of rubber
or splits them. The default is to split them. This option also controls if ArtiosCAD creates pseudo
temporary stripping rules to break up large pieces of rubber for easier manufacture.

• If they are split on bridges, there is better airflow and less suction. If they are split at corners, they
nest better and are easier to replace when worn out. Both creates splits at both locations.

• Maximum length: sets the largest size allowed for pieces of rubber placed outside the designs.

• Maximum length inside: sets the largest size allowed for pieces of rubber placed inside the
designs.

• Maximum length straight: is a separate length for straight pieces, and should be set to longer than
the Maximum length: value as straight pieces nest better.

• Split width: sets the size of automatically-created splits and also sets the default value for the Add
Split tool.

Minimum length: sets the value at which small pieces of rubber are merged with longer adjacent
pieces.

The Trim gap: field sets the size of the gap when two pieces of differing-types of rubber overlap. It can
be as small as 0.001 inch or 0.05mm, but set this to a value larger than 0 so that the Adjust Outline tools
can work with each piece individually.

Trim against counter controls whether the rubber is trimmed against the counter (if one is defined)
and if so, the gap is set in the Counter trim gap: field. If this option is not selected, the rubber can be
trimmed later with the Trim Rubber tool.

Trim lead edge, when selected, makes it so that no rubber goes lower than the lead edge.

303



8 ArtiosCAD

Make plastic cover, when selected, causes a plastic cover to be made in its own layer when the Rubber
Area tool is used.

Click OK when done to return to Defaults.

Layout

If you have the Rubber Design and Layout option, ArtiosCAD can automatically group pieces of rubber
on the sheets based on their shapes.
 

 

Trim is the distance from the edge of the rubber sheet to the edges of the rubber elements, and Gutter
is the distance between each rubber element.

Increasing the value in the Nesting tries: field causes ArtiosCAD to try more nests, but this takes more
time.

The five choices in the Grouping group control how the instances of each rubber element are grouped
together on the sheets. Manual means that the grouping will be taken from the values set in the List
Rubber Elements dialog box. None means that each item will be considered its own group. Low means
only straight items will be grouped together. Medium will do an intermediate level of grouping, but High
will group together as many instances of the element as possible. These controls are meant to let you
find the balance between making pieces easy to find and wasting the least rubber.

Click OK when done to return to Defaults.

Plastic cover

Some diemakers glue a plastic cover on top of the pieces of rubber to keep the board from sticking
to the rubber as the press operates. The plastic cover pieces are supported by pieces of rubber on all
sides, including along creases. The plastic cover extends slightly past the pieces of rubber underneath.
Plastic cover pieces are not generated for slots.
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When Only in waste areas is selected, the plastic cover is used only to cover waste, not designs. When
it is not selected, it covers both waste and designs, but not slots. Also, when it is selected, it is nested
as if it were a type of rubber.

Offset from cut: and Offset from crease: both control how close the plastic cover gets to rule.
Remember that it needs to project slightly over the rubber but not touch the rule.

Subtract bolt holes and its associated fields work the same way as they do in the Bolt holes section of
the parameter set.

Left allowance:, Right allowance:, Top allowance:, Lead edge:, and the options in the Relative to
group all determine how the plastic cover is positioned in reference to the edges of the layout.

Click OK when done to return to Defaults.

Rubber types

The Rubber types section of the parameter set is how ArtiosCAD determines which type of rubber to
use in a given location and also how to place it.
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Rubber is assigned to lines on the basis of line type, knife location, knife side, slots, rule direction,
and nicks. Use this dialog box to modify existing selections, create new selections, or delete existing
selections.

The line entries in the Rubber Parameters dialog are applied in order, starting with the first (top)
one and moving down through the list to find a match; each rule is compared with each selection in
turn. The first selection that the rule matches defines the rubber type for that rule. The more critical
selections with high shore rubber, such as for slots and nicks, should be first in the list.

To add a selection list entry, do the following:

1. Select an existing selection and click Insert.
2. A new selection is added to the table with the name of the rule from step 1 with (2) appended to its

name.
3. Delete the text in the Selection name: field and enter the name for the new selection.
4. Enter the width of the rubber pieces in the Width: field, and the desired offset in the Offset from

side of rule: field. Select Use selection and set the type of rubber from the drop-down list box. (The
type of rubber must be defined in the Rubber Types catalog before it can be used in the parameter
set.)

5. Click Selection. The Rubber Type Selection dialog box opens as shown below.
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In this dialog box you select the conditions that a piece of rule must meet in order to be rubbered by
the type of rubber selected. The checkboxes in the Line types: group and the Knife Location: group
use OR logic, but the two groups together use AND logic: Cut/knife OR Stripping rule OR Scrap knife OR
Balance knife, and so forth, AND of type Leading edge knife OR Exterior waste OR Interior slit, and so
forth.

If the type of rubber you are defining is for slots, select Slots and enter the maximum width of the slot
in the Width limit: field. If you define more than one type of rubber for slots, the narrowest slot should
be highest in the list in the Rubber types dialog box, followed by the wider slots.

The other groups allow you to add more conditions to the rules that will receive this type of rubber; set
them as desired. Nicks have the following restrictions: For Short piece centered on nick, the Distance
past nick: field should be more than the width of the rubber. Also, for both of the first two options, the
Minimum length should be less than the remaining length lines which you do not want to have the nick
rubber type.

For the Knife Location: group, refer to the picture and table below.
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Table: Knife locations for rubbering types

Number Location

1 Side

2 Trailing edge

3 Breaker knife (stripping rule)

4 Interior slit

5 Product side

6 Waste side

7 Common knife

8 Common waste

9 Interior waste

10 Leading edge

Once you have finished selecting the criteria for this rule, click OK to return to the Rubber Types dialog
box.

1. Use the arrows at the right end of the list to move the selected rubber type selection either up or
down in the priority list.

2. Repeat the process as desired to add selection list entries.
3. Click OK when done to return to Defaults.

All rule types except crease and balance knife should select a rubber type (rubber on balance knives
is optional because this does not interfere with rubber on other rules). If you want no rubber on a
particular rule type, because you are going to put rubber there manually, you should select rubber type
None for this rule type, and still define an offset and a width, so ArtiosCAD knows how much space to
leave for it.

For example, suppose you want no rubber on cut/crease. Copy the Cuts selection on the Rubber types
tab, change the name to Cut/crease, change the rubber to None, and change the selection to select
Cut crease lines. You can adjust the width and offset from rule for the rubber you are going to add
manually.

If there are rules on the die with no rubber type defined, ArtiosCAD displays a warning dialog when you
start the Rubber Area tool. You can either show the rules with no rubber type defined, or you can ignore
the error, in which case surrounding rubber along nearby rules will cross the rules for which no rubber
type is defined.
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Rebuild options

The Rebuild Options entry in the Design defaults catalog lets you change behavior when rebuilding a
single design or running a standard.
 

 

Automatically reinitialize subsequent variables reinitializes variables in subsequent menus which
currently match their default values. When this option is selected and you change a variable, any
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subsequent variable depending on that variable which matched its default value before the rebuild
started will get updated with the new value. For example, with this option selected, if you change L, any
variable in any subsequent menu which depends on L gets automatically updated with the new value
for L.

When this option is off, dependent variables are not automatically updated and are flagged for review
in the Rebuild Conflicts dialog box

Start rebuild at board menu controls whether you may choose a new board when rebuilding a design
instead of starting at the first visible menu.

Show full screen sets the Rebuild, Run Standard, and Reports dialog boxes to the maximum size
possible. If you change the size of these dialog boxes manually, ArtiosCAD remembers these changes
and uses your custom sizes instead.

The options in the Variable labels... groups control what is shown to the left of the fields when running
a standard, rebuilding a design, using a geometry macro, or outputting a report. Choose from Variable
name only, Description only, Description and variable name, and Variable name and description.
If Description only is the chosen method and the variable description is blank, the variable name is
used in parentheses. If there is no documentation plot for the menu, the description is shown with the
variable name in parentheses. These options can be changed on the fly in the dialog boxes by clicking
the tiny triangle above the variable list and selecting a different display option.

Click OK to make the changes and return to Defaults, or click Cancel to discard the changes.

3D Hardware Options

To set the default values for the gutters and offsets when using Add Hardware in 3D, open the 3D
Hardware Options dialog box in the Startup defaults catalog.
 

310



8ArtiosCAD

 
Change the values as desired and click OK to return to Defaults.

3D Import Options

Use the options in Startup defaults > 3D Import to control how ArtiosCAD imports solids.
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Render both sides shows the inside and the outside of the solid.

Preserve origin on adding new solid keeps the 3D workspace origin set so that when you import solids,
they stitch together properly. When this option is off, ArtiosCAD adds solids centered behind existing
solids.

Interactive preview shows the preview window, allowing you to choose which parts of multi-part solids
to import. When this option is off, ArtiosCAD imports all parts of multi-part solids.

Click OK to make the changes and return to Defaults, or click Cancel to discard the changes.

3D Rendering method

The 3D module can use two different rendering (display) methods, OpenGL (the default) and Direct3D.
Which method will perform better for you depends on the display adapter in your system. The main
difference between the two methods is how data is transferred between main system memory and the
display adapter. Other differences include:

• Shininess appears to work better when using Direct3D.

• ArtiosCAD using Direct3D takes longer to open a 3D workspace initially but once open draws it
faster than when using OpenGL.

• Using OpenGL allows the export of bitmaps with more pixels than with Direct3D

• In wireframe view mode, OpenGL seems to be able to display more lines.

• When ArtiosCAD and the Cortona VRML viewer both use Direct3D and are open at the same time,
they compete for resources and unpredictable results may occur. Change the rendering method in
one of them for better results.

To change the rendering method in Defaults, open the Startup Defaults catalog and double-click 3D
Rendering Options.
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Choose the option button for the method to use and click OK.

Use OpenGL for bitmaps enables ArtiosCAD to output bitmaps using OpenGL regardless of the screen
rendering method chosen. OpenGL supports the output of larger bitmaps than Direct3D.

Save and exit Defaults as usual. The change is effective immediately. You can also change it at any time
by clicking Options > 3D Rendering Options.

Database defaults

Database defaults configure the operation of the ArtiosCAD database. Click Options > Defaults, and in
the Shared Defaults pane, click Design Defaults > Database to open the Database dialog box.
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Enable Database, when checked, lets ArtiosCAD save information to the database. When the checkbox
is clear, no new information is saved to the database. Database information that already exists is
retained.

Create Thumbnail in Format controls if ArtiosCAD creates thumbnail pictures of workspaces when
designs are saved. The thumbnails are stored in the database and are used by the database browsers.

The drop-down list box next to the checkbox controls the type of thumbnail created.

BMP with RLE compression is the default choice. It creates thumbnails in BMP format using run length
encoding compression.

JPEG Format creates thumbnails in JPG format, which is compressed but lossy (meaning some detail
is lost).

Folded JPEG Format first tries to create a folded view for the thumbnail based on saved angles in a
single design. If there are no saved angles, a flat thumbnail is created. In each case JPEG format is
used.

ArtiosCAD 3D causes ArtiosCAD to look for an .A3D file by the same name as the workspace being
saved in the same directory, and if found, that is used for the thumbnail. If it is not found, Folded JPEG
format is used instead.
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Limit database browser results to controls how many records ArtiosCAD loads into the browser by
default. This is meant to avoid performance degradation for large databases. We encourage you to
search for results rather than scrolling through the available entries.

File Operations group

The checkboxes in the File Operations group control database activity when creating or saving a
workspace.
 

 

Use Resource View on Open and Save As, when checked, directs ArtiosCAD to use Resource View
when opening workspaces or saving them using Save As. Directory View is used when this option is not
checked.

Show database dialog box when creating a new design, when checked, instructs ArtiosCAD to prompt
you for database information when you create a new design.

Show Create As dialog box when creating a new design, when checked, when checked, instructs
ArtiosCAD to prompt you for the filename and resource or directory in which the design is to be saved
when creating a new design.

Show database dialog box when saving, when checked, tells ArtiosCAD to prompt you for database
information when you save a workspace in a resource.

Synchronize disk file when saving in browsers, when checked, causes ArtiosCAD to modify the disk
file for the record you change in a database browser. This is independent of saving the record, which
only affects the database.

Add new characteristics when synchronizing, when checked, instructs ArtiosCAD to compare the
characteristics in a workspace being opened with those already in the database, and if there are new
ones in the file, prompts you to add them to the database.

Enable Skip DB button, when checked, lets you click Skip DB when saving a workspace so that you can
save a workspace with no corresponding database information.
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Reset project document counter when copying projects, when checked, resets the counter for
automatic document naming in the newly copied Project.

Performance options group

The checkboxes in the Performance Options group control how ArtiosCAD retrieves certain types of
information from the database.
 

 

Typically, databases which run over WANs (Wide Area Networks), for example between plants,
experience slower network performance compared to those which run over faster LANs (Local Area
Networks). By default, ArtiosCAD requests a complete set of database entities each time the Database
Information dialog box is activated, which can lead to wait times if there are many records to download
from the database server.

To address this, ArtiosCAD can store the  Customer, Owner, Designer, Salesperson, Characteristics,
and User Fields entities from the Database Information dialog box in memory, as well as the boards,
companies, company types, and Resources. This is called caching.

Both ArtiosCAD and CAD-X can use this feature, and each will use more memory if it is enabled.

Once the database dialog box entries or other entities are loaded into memory, ArtiosCAD does not re-
request them from the database. If changes are made to the entities in the database itself, ArtiosCAD
will not see them until the cache is refreshed or a new ArtiosCAD session is started. To refresh the
cache, click Database > Refresh cache > Item.

ArtiosCAD can also search the database for specific records which match a pattern thus returning only
a few records instead of thousands. This feature is called pattern searching.

Note:  These performance options do not apply to customized database information dialog
boxes. To use them, you must use the standard database information dialog boxes.

Caching
Toggle the Cache dialog box entries checkbox to enable and disable caching.

The table below lists how the fields in the Database Information dialog box behave when database
dialog box entry caching is turned on. The Database Information dialog box behaves the same for
Single Design and Manufacturing.

316



8ArtiosCAD

Table: Dialog box behavior when database dialog entity caching is enabled

Field Behavior

Customer and Owner All Customer and Owner entities are requested when the dialog box is
first accessed, and then they are cached.

Salesperson and Designer All Salesperson and Designer entities are requested when the drop-
down list box arrow for either field is first clicked, and then they are
cached. They share the same cache.

Characteristics button Characteristics are requested the first time the button is clicked, and
then cached. Only applicable to Single Design.

User Fields button Same as Characteristics.

New button in Customer
dialog box

Causes a refresh of the Customer cache.

In addition to caching Database Information dialog box entries, when caching is enabled, ArtiosCAD
also caches boards, companies, company types, and Resources.

Once the database dialog box entries or other entities are loaded into memory, ArtiosCAD does not re-
request them from the database. If changes are made to the entities in the database itself, ArtiosCAD
will not see them until the cache is refreshed or a new ArtiosCAD session is started. To refresh the
cache, click Database > Refresh cache > Item.

Pattern searching
Another way to ensure robust database performance over a slow Wide Area Network for the Customer,
Owner, Designer, and Salesperson fields is to enable pattern searching by checking the Use pattern
searching for customers and owners and Use pattern searching for designers and salespeople
checkboxes. To maintain compatibility with previous versions, these checkboxes are both cleared by
default.

When pattern searching is enabled, the Oneup Design Information and Manufacturing Database
Information dialog boxes change. The drop-down list boxes for the Customer, Owner, Designer, and
Salesperson fields disappear and the fields become disabled. In addition, there are ... buttons leading
to dialog boxes which let you search for records and then display details about the selected records,
or display details if there is already a selected record. Shown below is the Customer dialog box; all four
dialog boxes act similarly, but only the Customer dialog box has the New button.
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Pattern searching works by entering a few letters of a word, or a whole word, or a complete phrase,
then choosing a method of searching, and then clicking Find. The results of the search populate the
drop-down list box.

Mixing database performance modes
Database dialog box entry caching and pattern searching can be used simultaneously, but not for all
four types of records. Only a pair of records (Customer and owners or designers and salespeople) for
which pattern searching is turned off can be cached.

Database Information Dialog Customization groups

Click Database Dialog Options in the Database dialog box to open the Database Information Dialog
Customization dialog box.
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These options allow you to choose what happens when entering database information for a single
design, layout, canvas, canvas Part, canvas layout, or Project.

Use standard dialog uses the dialog box that is included with ArtiosCAD.

Use custom dialog definition file enables the Customize button, which in turn leads to the
Control Layout Manager described in the next section. Using this feature requires the Information
Enhancement option.

Use custom external application enables a field to specify the path to a custom program (such as
an ERM program) that controls information storage instead of the ArtiosCAD database. This custom
application is not provided or supported by Esko unless Esko provided it. Using this feature requires
the Information Enhancement option.

Designing a custom Database Information dialog box
When you choose Use custom dialog definition file and click Customize, the Control Layout Manager
dialog box opens showing the current dialog box.
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On the left is the dialog box itself showing the tabs, groups, labels, fields, and buttons. On the right are
the language selector, size controls, the grid controls, the control catalogs, the Properties fields for
the selected item, and the OK, Test, Cancel, Open, and Save As buttons.

There is no undo functionality in the Control Layout Manager, but you can click Cancel to discard all
changes and then start again. This is especially useful for canvases as there is no option to revert to
using the default dialog box.

Each language of ArtiosCAD can have different customized database information boxes. Choose the
language for the current dialog box in the Language drop-down list box.

To change the size of the dialog box, adjust the values in the Dialog Size: fields, or select the edge
of the dialog box within the definition window and drag it to the desired position. To make a dialog
box larger than the current one, resize the Control Layout Manager dialog box itself using standard
Windows methods, and then increase the size of the dialog box window.

Enable Common Area toggles the common area that ArtiosCAD shows when the dialog box has
multiple tabs. For more information about tabs, see Working with Tabs.

Enable Grid and Spacing(px) control the appearance and spacing of the alignment grid. Turn on the
grid to have controls snap to the nearest point when you drag them. The number in the Spacing(px)
field is the number of pixels.

To add a control, select it from the catalog and drag it to the desired position. You may also double-
click it; it will appear at the top left of the dialog box, and you may then select it and drag it to the
desired position.

To select multiple controls at once, hold down SHIFT or CTRL and click each control. Alternately, you
may make a rectangular marquee selection around the desired controls. The selection rectangle must
completely encompass the controls. Be careful about selecting anything too close to the edge of a
group box as you might accidentally select the box and not the objects within it.

To remove a control, select it and press Delete on the keyboard.
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To move a control, select it and drag it to the desired position, or select it and use the Position: fields
in the Properties group to adjust its position. You can also select it and use the arrow keys to move it in
one-pixel increments.

Removing and moving multiple controls work the same way; just select them first.

To resize a control, select it, and use the handle points to change its size as desired, or select it and use
the Size: fields in the Properties group to adjust its size.

To change text in a control, select it, and then change the contents of the Text: field in the Properties
group.

To change the translation for a control, select it, and then click More Options (…) at the end of the
Properties field. Enter the desired translations in the appropriate fields in the Text Language Options
dialog box. If a field is empty, ArtiosCAD uses the text in the Default Text field. Click OK when done to
return to the Control Layout Manager.
 

 

When editing a field in the Properties group, or a Dialog Size: field, click in another field or select
a different object to activate the changes made to the first object. Do not press Enter as that is
interpreted as clicking OK and will thus close the dialog box.
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Click OK to save the changes to the dialog box and close the Control Layout Manager. The
single design dialog box is saved as DBDlgDesignDef.xml, the canvas dialog box is saved as
DBDlgCanvasDef.xml, the canvas Part dialog box is saved as DBDlgPartDef.xml, the canvas
layout dialog box is saved as DBDlgLayoutDef.xml, the manufacturing dialog box is saved as
DBDlgMFGDef.xml, and the Project dialog box is saved as DBDlgProjectDef.xml, both in
ServerLib or ClientLib depending on which set of defaults was changed.

Click Cancel to discard the changes to the dialog box and close the Control Layout Manager.

Click Test to open a sample dialog box that previews the final result.

Click Save As to save the dialog box layout to a file.

Click Open to open a previously-saved dialog box layout file.

Shown below is a modified Database group in the Control Layout Manager and then in the test dialog
box.
 

 
 

 

Note:  Database performance options do not apply to customized database information dialog
boxes. To use them, you must use the standard database information dialog boxes.

Defining the Tab Key Order
When you are defining a custom database information dialog box, you can set the Tab key order for the
controls in the dialog box on the Tab Order tab of the control layout manager.
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You can only set the Tab key order for fields that you can change in the dialog box. Labels and read-only
fields do not have Tab key order settings.

To change the Tab key order manually, do the following:

1. Select a field or button with a blue number after it by either clicking it in the dialog designer or in
the list on the right.

2. Use the arrows to the right of the list to change its position, or
3. Drag and drop the entry to its new position.

Automatically Calculate Tab Order assigns Tab key orders to elements horizontally from top to bottom
of the dialog box.

Each tab of the dialog box has its own Tab key order. The common area is always after the current tab.

If you have added some controls to the dialog box, you must save those changes, exit the control layout
manager, and re-enter it in order to set the Tab key order on those new controls. ArtiosCAD puts the
new controls at the end of the list.

Working with Tabs
ArtiosCAD allows you to create additional tabs in customized database dialog boxes. You could
have one tab for general information, one tab for design-specific information, one tab for customer
information, and so on. There is also an area at the bottom of the dialog box reserved for common
controls shown regardless of which tab is active. Shown below is an example of a customized tabbed
single design database information dialog box in its Defaults definition, and then in use in ArtiosCAD.
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If you have upgraded from a previous version of ArtiosCAD, the default database information dialog box
uses one tab and the common area is not enabled.

Adding a Tab
To add a tab, click the plus sign in brackets.
 

 

Renaming a Tab
To change the name of a tab, double-click its current name and enter a new name in the field. Press
Return when done.

Tab names are specific to the selected language in the Language drop-down list box. The first name
you enter for a new tab is the default for every language. To change the name of a tab in a different
language, first select the different language, then change the name of the tab.

Deleting a Tab
To delete a tab, click the red X on the tab.
 

 

The Common Area
The common area at the bottom of the dialog box is for controls that persist regardless of which tab is
active. Use Enable Common Area to toggle its display. To resize the common area and tabs, drag the
bar separating it from the tabbed area. All the tabs are the same size.

Adding Controls
To add a control to a tab, drag it as usual from the list on the right to the desired position on the tab.
Note that you cannot drag controls between the common area and a tab. In that case, delete the
control and re-add it in the desired position.

Selecting Controls
You may only select controls, either singly or multiply, in either the tabbed area or the common area,
but not both.

Version Interpretation
If you share customized database dialog definition files between system that are different versions, the
following rules apply:

• ArtiosCAD 16.1.1 or later reading a definition created in an earlier version: One tab, no common area.

• ArtiosCAD 16.1.1 or later sending a definition file to an earlier version: Only the controls from the
first tab and common area are shown by the earlier version.

• An ArtiosCAD version earlier than 16.1.1 reading a definition created in 16.1.1 or later: 16.1.1 creates
a dual-format definition file with a tabbed interface section and a flat interface section. An earlier
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version reads the flat interface section and ignores the tabbed interface section (but remembers
it).

• An ArtiosCAD version earlier than 16.1.1 writing a definition read by 16.1.1 or later: Writes a flat
version. If you use this to overwrite a tabbed version on a different system, the tab information will
be lost.

Using a custom external application
Use custom external application allows a separate standalone application to display and gather
database information. Specify the absolute path name of the application in the associated field, or
use the Browse button (...) to locate it. This custom application is invoked whenever the Database
Information dialog box would otherwise be shown.

The exact sequence is:

1. ArtiosCAD requests database information (by clicking Database > Database Information or during a
Save or Open).

2. The current database information is packaged into a randomly-named XML file in the directory
defined as the TEMP directory in Options > Defaults > Startup Defaults.

3. The external application is invoked with the input XML file as the first parameter.
4. ArtiosCAD waits until the external application is done.
5. ArtiosCAD reads the XML file specified as the second parameter on the external application’s

command line and uses it to populate the database.

Shown below is the dialog box created by a sample application.
 

 

The exact command executed is:

Application.exe -iInputXMLDBinfo.xml -oOutputXMLDBinfo.xml

where Application.exe is the name of the custom application, InputXMLDBinfo.xml is the
full path name of the temporary input XML file that ArtiosCAD creates, and OutputXMLDBinfo.xml
is the full path name to the output XML file created by the custom application. The names of the
parameters are generated randomly by ArtiosCAD; the custom application should read them from the
command line.

ArtiosCAD checks for a return code from the custom application of 1 for OK and 2 for Cancel.
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A sample database definition XML file for a single design is shown below.

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<ARTIOSDBDOC>

  <UNITS>IMPERIAL</UNITS>

  <DESIGN>
    <NAME>BOX1.ARD</NAME>
    <REV>0</REV>
    <REVNUM>0</REVNUM>
    <PATH>D:\Esko\Artios\Designs\</PATH>
    <REVDATE>2018-03-21</REVDATE>
    <SAVEDATE>2020-02-12</SAVEDATE>
    <DESC>Long Description</DESC>
    <SHORTDESC1>Short 1</SHORTDESC1>
    <SHORTDESC2>Short 2</SHORTDESC2>
    <SHORTDESC3>Short 3</SHORTDESC3>
    <AUTH>Auth</AUTH>
    <REVDESC>Rev Desc</REVDESC>
    <LENGTH>9.000000</LENGTH>
    <WIDTH>8.000000</WIDTH>
    <DEPTH>7.000000</DEPTH>
    <GRAINDIR>2</GRAINDIR>
    <CAL>0.016000</CAL>
    <BLANKLEN>34.718750</BLANKLEN>
    <BLANKHEIGHT>25.000000</BLANKHEIGHT>
    <AREA>536.480896</AREA>
    <RULELEN>236.029770</RULELEN>
    <RESOURCE>
      <ID>1</ID>
      <NAME>ArtiosDesigns</NAME>
      <RELPATH>Esko\Artios\Designs</RELPATH>
      <PATH>D:\Esko\Artios\Designs</PATH>
      <MASTER>1</MASTER>
      <ACTIVE>1</ACTIVE>
      <INHERITAUTONUM>1</INHERITAUTONUM>
      <SERVER>
        <ID>1</ID>
        <NAME>D-Drive</NAME>
        <PATH>D:\</PATH>
      </SERVER>
    </RESOURCE>
    <SIDE>-1</SIDE>
    <BOARD>
      <ID>86</ID>
      <CODE>I-SBS-16</CODE>
      <DESC>I-SBS-16</DESC>
      <FLUTE></FLUTE>
      <TESTCODE></TESTCODE>
      <CAL>0.016000</CAL>
      <TESTVAL>0.000000</TESTVAL>
      <IL>0.008000</IL>
      <OG>0.008000</OG>
      <CRRV>0.031250</CRRV>
      <BASISWEIGHT>64.000000</BASISWEIGHT>
      <BASISCOST>72.000000</BASISCOST>
      <WORKSPACE>0</WORKSPACE>
      <LINER1></LINER1>
      <MEDIUM1></MEDIUM1>
      <FLUTE1></FLUTE1>
      <LINER2></LINER2>
      <MEDIUM2></MEDIUM2>
      <FLUTE2></FLUTE2>
      <LINER3A></LINER3A>
      <LINER3B></LINER3B>
      <MEDIUM3></MEDIUM3>
      <FLUTE3></FLUTE3>
      <LINER4></LINER4>
      <MEDIUM4></MEDIUM4>
      <FLUTE4></FLUTE4>
      <LINER5></LINER5>
      <TRANSPARENCY>0.000000</TRANSPARENCY>
      <OUTCLR_DIFFUSE>13158600</OUTCLR_DIFFUSE>
      <OUTCLR_SPECULAR>0</OUTCLR_SPECULAR>
      <OUTCLR_AMBIENT>3947580</OUTCLR_AMBIENT>
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      <INCLR_DIFFUSE>11780038</INCLR_DIFFUSE>
      <INCLR_SPECULAR>0</INCLR_SPECULAR>
      <INCLR_AMBIENT>3488059</INCLR_AMBIENT>
      <OUTTEX_IMAGE></OUTTEX_IMAGE>
      <OUTTEX_HEIGHT>0.000000</OUTTEX_HEIGHT>
      <OUTTEX_WIDTH>0</OUTTEX_WIDTH>
      <INTEXT_IMAGE></INTEXT_IMAGE>
      <INTEX_HEIGHT>0.000000</INTEX_HEIGHT>
      <INTEX_WIDTH>0</INTEX_WIDTH>
      <FLUTETEX_IMAGE></FLUTETEX_IMAGE>
      <FLUTETEX_OPT>0</FLUTETEX_OPT>
      <FLUTETEX_WIDTH>0</FLUTETEX_WIDTH>
    </BOARD>
    <CUSTOMER>
      <WORKSPACE>0</WORKSPACE>
      <ID>4</ID>
      <PUBID>-1</PUBID>
      <NAME>Bill55</NAME>
      <NUMBER></NUMBER>
      <LOCATION>Bill55Bill55Bill55Bill55Bill55Bill55Bill55Bill55B</LOCATION>
      <ADDR1>40 westover roadBill55Bill55Bill55Bill55Bill55Bil</ADDR1>
      <ADDR2>Bill55Bill55Bill55Bill55Bill55Bill55Bill55Bill55B</ADDR2>
      <CITY>ludlow</CITY>
      <STATE>ma</STATE>
      <ZIP>01056Bill55Bi</ZIP>
      <COUNTRY>usa</COUNTRY>
      <PHONE>413 583-4134</PHONE>
      <FAX>Bill55Bill55Bill55B</FAX>
      <TYPE>Converter</TYPE>
    </CUSTOMER>
    <OWNER>
      <WORKSPACE>0</WORKSPACE>
      <ID>5</ID>
      <PUBID>-1</PUBID>
      <NAME>Red Mountain Industries</NAME>
      <NUMBER></NUMBER>
      <LOCATION></LOCATION>
      <ADDR1></ADDR1>
      <ADDR2></ADDR2>
      <CITY></CITY>
      <STATE></STATE>
      <ZIP></ZIP>
      <COUNTRY></COUNTRY>
      <PHONE></PHONE>
      <FAX></FAX>
      <TYPE></TYPE>
    </OWNER>
    <SALESPERSON>
      <WORKSPACE>0</WORKSPACE>
      <ID>4</ID>
      <PUBID>-1</PUBID>
      <NAME>R. MERIWETHER</NAME>
      <FIRSTNAME></FIRSTNAME>
      <SHORTNAME></SHORTNAME>
      <NAME></NAME>
      <NUMBER></NUMBER>
      <LOCATION></LOCATION>
      <ADDR1></ADDR1>
      <ADDR2></ADDR2>
      <CITY></CITY>
      <STATE></STATE>
      <ZIP></ZIP>
      <COUNTRY></COUNTRY>
      <PHONE></PHONE>
      <FAX></FAX>
      <TYPE></TYPE>
    </SALESPERSON>
    <DESIGNER>
      <WORKSPACE>0</WORKSPACE>
      <ID>3</ID>
      <PUBID>-1</PUBID>
      <NAME>GELIN</NAME>
      <FIRSTNAME>CHRISTOPHE</FIRSTNAME>
      <SHORTNAME></SHORTNAME>
      <NAME></NAME>
      <NUMBER></NUMBER>
      <LOCATION></LOCATION>
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      <ADDR1></ADDR1>
      <ADDR2></ADDR2>
      <CITY></CITY>
      <STATE></STATE>
      <ZIP></ZIP>
      <COUNTRY></COUNTRY>
      <PHONE></PHONE>
      <FAX></FAX>
      <TYPE></TYPE>
    </DESIGNER>
    <CHARACTERISTICDATALIST>
      <CHARACTERISTICDATA>
        <CODE>DISP</CODE>
        <DESC>Displays</DESC>
      </CHARACTERISTICDATA>
      <CHARACTERISTICDATA>
        <CODE>OTH</CODE>
        <DESC>Other</DESC>
      </CHARACTERISTICDATA>
      <CHARACTERISTICDATA>
        <CODE>SHIP</CODE>
        <DESC>Shipping carton</DESC>
      </CHARACTERISTICDATA>
    </CHARACTERISTICDATALIST>
    <USERFIELDDATALIST>
      <USERFIELDDATA>
        <ID>101</ID>
        <VALUE>07/11/2018</VALUE>
      </USERFIELDDATA>
      <USERFIELDDATA>
        <ID>9909</ID>
        <DESC>Sale Date</DESC>
        <VALUE>hjgg&gt;&gt;&gt;</VALUE>
      </USERFIELDDATA>
      <USERFIELDDATA>
        <ID>99</ID>
        <VALUE></VALUE>
      </USERFIELDDATA>
      <USERFIELDDATA>
        <ID>9906</ID>
        <DESC>Sale P.O. Number</DESC>
        <VALUE></VALUE>
      </USERFIELDDATA>
      <USERFIELDDATA>
        <ID>9914</ID>
        <DESC>Pallet Width</DESC>
        <VALUE>0.000000</VALUE>
      </USERFIELDDATA>
    </USERFIELDDATALIST>
  </DESIGN>

</ARTIOSDBDOC>

For more information about using a custom application, contact Professional Services.

The folowing table shows which database fields ArtiosCAD processes according to the context of the
XML file.

Context Description

Authorization

RevDescription

Short 1,2,3 Customer

Owner

Salesperson

Designer

Characteristics Userfields

ARD X X X X X

MFG X X X

ACD X X X X X
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ACD_Part X X X X

ACD_Sheet_PartX X

Default selections group

The drop-down list boxes in the Default Selections group set the owner, salesperson, and designer for
newly-created workspaces. These fields get their lists of possible values from the Company and Person
browsers in DataCenter Admin. Set the values as desired.
 

 

Click OK to save the changes made to Database defaults and return to the main Defaults dialog box.
Click Apply to save the changes but remain in the Database defaults dialog box. To discard all changes
and return to the main Defaults dialog box, click Cancel.

Company selection display group

The option buttons in the Company Selection Display group control how company name and
identification information is shown in ArtiosCAD. Name is the default choice.
 

 

Name and Number are fields you set for a company in the Company browser in DataCenter Admin. Note
that Number can be any number you set; it is not calculated. Choose the display format as desired.

Any changes made in this group will not appear in the Default Selections group in this dialog box until
you click OK and then open the Database defaults again.

Shown below is an example in the Oneup Database Information dialog box when Number, Name is the
chosen option in Company Selection Display.
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Spell checking

If you have Microsoft Word installed on your system, ArtiosCAD can use its spell checking functionality
in Single Design and Manufacturing in most places where you enter text using a field in a dialog box.
This feature is turned on by default. You may turn it off in the Paragraph Text tool and in text fields by
using the Spelling dialog box in the Startup Defaults catalog.
 

 

Toggle the Enable spell checking checkbox as desired, and click OK to save the change and return to
the main Defaults dialog box.

Note:  This setting does not affect document-wide spell check using Tools > Check Spelling. It
is available regardless of the state of this checkbox.

Nudge Options and Defaults

Click Options > Nudge to set the active nudge modes per session and the distances they use. This
command is available when a single design or a manufacturing file is open. Essentially the same dialog
box is used in Defaults in Startup defaults > Nudge options.

Shown below is the Nudge options dialog box.
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Show nudge options in select tool controls the availability of the nudge modes. When it is selected,
they are active. When it is cleared, nudge moves by a pixel.

Set the three mode selectors as desired. They determine which nudge modes are active when a tool
which supports nudge is started.

The values in the Fixed values group control the distance used by the Nudge by a Fixed Value mode.
Set them as desired.

Note:

If you change the nudge options or Defaults while a Select tool is active, the tool will be
restarted to update it and the current selection will be lost.

Hatch Defaults

ArtiosCAD stores Defaults for the Hatch tool in three locations: the Hatch Catalog, Property defaults >
Hatch, and Startup defaults >  Hatch tool options.

Hatch Catalog defaults

The Hatch Catalog in Defaults is where you add, remove, and change entries in the Hatch Catalog.
ArtiosCAD comes with sample entries in the Misc folder.
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To add a folder to the catalog, right-click the folder which will contain the new folder, then click New >
Folder. To add a new entry to a folder, right-click the folder and then click New > Data.

To remove a folder or an entry, right-click it and click Delete on the context menu. ArtiosCAD will ask
you to confirm the deletion.

To change an entry, double-click it and change the properties as desired. The Hatch Properties dialog
box is the same as it is in drawing mode.
 

 

Hatch Property defaults

In Property defaults > Hatch, you set the Defaults for the <custom> Hatch Catalog entry as shown
below.
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The Hatch Properties are the same as in drawing mode; set them as desired and click OK to return to
Defaults.

Hatch Startup defaults

In Startup defaults > Hatch tool options, you set the options for how the Hatch tool will initially work.
 

 

In the Tool select option and Offsets groups, set the options as desired.
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Prompt before changing layers, when checked, makes you confirm changing layers to the layer
specified in a Hatch Catalog entry’s Placement Options dialog box. Restore layer on tool exit, when
checked, returns you to the layer you were in if the layer changed due to using a Hatch Catalog entry
with a layer assignment.

When you are done setting the options as desired, click OK to return to Defaults.

Adding a Canvas Standard to a Style Catalog

1. Copy the canvas workspace to ServerLib.
2. Start ArtiosCAD.
3. Click Options > Defaults.
4. Scroll down the list of shared defaults to Style catalogs, and click the plus sign to open the

category.
5. Right-click the folder that will contain the new standard and click New > Data.
6. Enter a name for the new catalog entry and press Enter.
7. Double-click the new entry.
8. Enter the full path to the file or click … to browse to it.

 

 
Clicking the information icon will describe what happens when you run the standard.

9. Click OK to save the changes.
10. Save and exit Defaults normally.

Adding Purchased Standards to Style Catalogs

To install a purchased ArtiosCAD standard, do the following:

1. Verify the data and settings in the 2D workspace.
a)

 Open the workspace in ArtiosCAD and set the units, database information, and board code
as desired.
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b)
 Convert the 2D workspace to 3D and set the base face and fold angles. The standard may

already have this information set in it.
c) Close the 3D workspace, making sure to leave Save fold angles and view settings... selected.

You may save or discard the 3D workspace as desired; you do not need it for the standard.
d) Save the 2D workspace.

2. Copy the workspace to the Shared Defaults folder or Project so everyone will be able to use it.
a) For ArtiosCAD Standard Edition, using Windows Explorer, copy the 2D workspace from where

you saved it to ..\Esko\Artios\ServerLib.
b) For ArtiosCAD Enterprise, save or upload the 2D workspace to the Standards subfolder of the

Shared Defaults Project. Depending on how the Shared Defaults Project security is configured,
you may need administrator privileges for this.

3. Add the standard to a Style Catalog.
a) In ArtiosCAD, click Options > Defaults to open Defaults.
b) Scroll down the list of Shared defaults and open the Style catalog catalog.
c) Right-click the folder in which you will place the new standard and click New > Data. To make a

new subfolder, right click its parent folder and click New > Folder.
 

 
d) Enter the name of the new standard as you want it shown in the style catalog and press Enter

when done.
 

 
e) Double-click the new standard entry to open its Properties dialog box.
f) Make sure the Standard Type is set to ArtiosCAD.
g) Click … (Browse) at the end of the Filename field to navigate to ServerLib for ArtiosCAD

Standard Edition, or the Standards subfolder of the Shared Defaults Project for ArtiosCAD
Enterprise, and then double-click the workspace. Its filename should appear in the Filename
field.
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h) Click OK.

4. Click File > Save and click Yes to overwrite Shared defaults.
5. Click File > Exit to exit Defaults.
6. To test the standard, do the following:

a) Click File > Run a Standard.
b) Navigate to the new standard and select it.
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c) Click OK to run the standard. Select a board code and set the style choices in the menus.
d) Convert the 2D workspace to 3D. ArtiosCAD will use the saved fold angles you set in step 1.
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e) If everything is correct, you may now start using the standard. If it is not correct, adjust the

workspace in ServerLib or the Shared Defaults Project.

 Adding LASERPOINT IQ standards to Style Catalogs

Preparation

Before adding a LASERPOINT IQ standard to ArtiosCAD, it is necessary to locate the LASERPOINT IQ
files needed to run the standard. The name can be determined using Menu Management. Locate the
standard to add and select the Edit option. This will show a standard name which looks like one of the
following entries:

• EXE STDMENU WITH ‘XYZ’ This is an entry for a L ASERPOINT IQ 2.0 format standard whose name is
XYZ. You will need the files XYZGEOM and XYZW.

• XYZ. This is an entry for a pre-LASERPOINT IQ 2.0 standard whose name is XYZ. You will need the
file XYZ and there may also be a file called XYZW containing documentation plots.
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The files for the standard you are migrating are probably in your \LP\USER_LIBI directory. Copy
them to ..\Esko\Artios\ServerLib.

Adding the standard to a Style Catalog

Add the LASERPOINT IQ standard to the ArtiosCAD style catalog using Defaults in a similar way to
normal ArtiosCAD standards. Start ArtiosCAD, and then open the style catalog as follows:

1. Click Options and Defaults to open the Defaults dialog box.
2. Use the right mouse button to click Style Catalog in the left area of the dialog box and then click

New and Data.
3. Type the descriptive name for the standard as you want it displayed in ArtiosCAD.
4. Double-click the icon beside the standard name to open the dialog box for specifying the standard.

 

 
5. For LASERPOINT IQ 2-4 standards:

Type the name of the standard file without the W or GEOM sux. In the example above with files
XYZW and XYZGEOM, type XYZ.

For pre-LASERPOINT IQ2 standards:

Type the name of the standard.

If you don’t know the name of the standard, click the … button at the end of the Filename field. This
will open the standard Open dialog box which you can use to navigate to the proper directory and
open the file.

6. Click OK to close the dialog and save changes. ArtiosCAD will check the file and set the standard
type automatically.

You are now ready to run the standard in ArtiosCAD.
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Note:  Move the standard to sub-folders in your style catalog if desired to give a more
structured organization.

Troubleshooting newly-added INTERACT/LASERPOINT/ LASERPOINT IQ
standards

Missing files
LASERPOINT IQ standards may be created based on other standards or attachments. You must copy
the files for the standards to run in the ArtiosCAD environment. Any missing files will be shown in error
dialog boxes when a standard is run. Remember to copy all the files – for example, if ATTACHGEOM is
missing, you will also need the associated ATTACHW file.

Changing the framework
ArtiosCAD sets up a framework to execute the various types of INTERACT/LP/LASERPOINT IQ 1
standards. The framework settings are available by clicking the Advanced button.
 

 

LASERPOINT IQ 2-4 standards may need to be set up using the INTERACT type if they used elements
from before LASERPOINT IQ 2.0. This is set by changing to the standard type INTERACT/LP/IQ1,
clicking Advanced, and selecting the framework Non-standard IQ2-4.

INTERACT/LP/IQ1 standards that fail to run properly can be tried with alternative frameworks by
clicking Advanced and selecting one of:

• LP/IQ1

• INTERACT design standard

• Designer Edition

Adding Designer WorkBench designs to Style Catalogs
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Preparation

Before you can add Designer WorkBench designs to a Style Catalog, ArtiosCAD needs to be told the
location of the DWB resources. You will need to know the directories used for the DWB resources and
then add these to the ArtiosCAD environment. The steps to do this are:

1. Start DataCenter Admin and double-click Server.
2. Check that there is a server set up for the drive letter where your DWB designs are located. Add a

new server as necessary. For example, if your DWB designs are on the D: drive, click the Insert icon,
give the new server a name and select D: as the server path. Click Insert to add the server.

3. Double-click Resource.
4. Do the following for each DWB resource:

 Click the Insert icon, give the resource a name, pick the server and the path for the resource.
Click Insert to add the resource.

5. When complete, save the changes and close DataCenter Admin.

Adding a Designer WorkBench standard to a Style Catalog

Any DWB design can be added to the ArtiosCAD Style Catalog by using the following procedure:

1. Start ArtiosCAD.
2. Click Options and Defaults to open the Defaults dialog box.
3. Use the right mouse button to click Style Catalog in Shared defaults and then click New and Data.
4. Type the descriptive name for the standard as you want it displayed in ArtiosCAD.
5. Double-click the icon beside the standard name to open the dialog for specifying the standard.
6. Click the … button beside the data entry area for the design name. This will show the Open dialog.
7. Change to resource view, select the resource, and check you are showing designs of type either All

files or Designer Workbench Designs.
8. Select the design and click Open.
9. Close the Defaults dialog box and save changes.

You are now ready to run the standard in ArtiosCAD.

Note:  The standard can be moved to sub-folders in your style catalog, if desired, to give a more
structured organization.

Customizing a Resizable Design Template

You may find that a Resizable Design Template isn’t quite right and needs to be changed to fit your
requirements. This is easy to do in a few steps.

1. Determine the file to customize and copy it to ServerLib or save it into the
ACadDefaults_Shared Project.

2. Create a new folder and entry in the Style Catalog for the customized RDT.
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3. Customize the geometry of the new file as desired.
4. Run the new standard.

Determining which file to customize and copying or saving the file

1. Start ArtiosCAD and click File > Run a Standard.
2. In the Standards Catalog, navigate to the standard and click it, but do not run it.
3. Note the filename in the Workspace field. This is the file to copy out of InstLib into ServerLib

or open and save into the ACadDefaults_Shared Project.
 

 
4. Click Cancel to return to ArtiosCAD.
5. Get the file from InstLib into either ServerLib or the ACadDefaults_Shared Project. Note

that ECMA and FEFCO Resizable Design Templates are stored in subfolders.
a) If you are using ArtiosCAD Standard Edition, use Windows Explorer to copy the file from ..

\Esko\Artios\ArtiosCAD<version>\InstLib to ..\Esko\Artios\ServerLib. If
you are dragging and dropping, make sure to hold down CTRL to copy the file.
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b) If you are using ArtiosCAD Enterprise, use the Explorer node of the Browser to navigate to  ..

\Esko\Artios\ArtiosCAD_Enterprise<version>\InstLib. Find the file in the File
pane and double-click it to open it. Next, save it to the ACadDefaults_Shared Project.
 

 

Adding new entries in Defaults for a customized RDT

1. Start ArtiosCAD and click Options > Defaults.
2. In the Shared Defaults pane, scroll down to Style catalogs and click the plus sign to open it.
3. Right-click Style catalogs and click New > Folder on the context menu. This will add a new category

to the list of style catalogs at the top level.
4. Enter a name for this new category and press Enter.
5. Right-click the new category and click New > Data on the context menu.
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6. Enter a name for this new entry and press Enter.
7. Right-click the new entry and click Properties on the context menu.
8. Click the Browse button at the end of the filename field, navigate to either ServerLib or the

ACadDefaults_Shared Project, and pick the file you modified.
 

 
9. Click OK to return to Defaults, and then save and exit normally.

Customizing the file itself

1. Now that you have copied the file to ServerLib or saved it into the ACadDefaults_Shared
Project, open that instance of the file. Do not modify the one in InstLib.

2. Let’s say you want to change the height of the dust flap on the Width panels. The current formula is
for the dust flap height to be 75% of the width but you want it to be 80%.

3. Click Design > StyleMaker (and Advanced if necessary).
4. From running this standard, you know that you want to change variable FH12 in the Width flap menu.

In the list of menus, click the Width flap menu, and in the list of variables, select FH12.
 

 
5. Click f(x) at the end of the Formula field to graphically edit the expression.
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6. In the Edit Expression dialog box, click the VAL: line in the expression builder.
 

 
7. In the Value field, change 4 to 5 and click OK.
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8. Close the Advanced StyleMaker dialog box and save the file.

Running the newly customized Resizable Design Template

Now that you have customized the RDT and created a new entry for it in the Style Catalog, it is ready to
be run and tested.

1. Click File > Run a Standard.
2. Navigate to the new entry and double-click it to run it.
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3. Select a board code and enter the basic dimensions as usual. For this example, we will use 4, 2,

and 6 as the length, width, and height.
4. On the Width flap menu, the Flap Height (FH12) variable, which used to be 1+1/2 based on the old

formula, should now be 1+5/8 based on the changed formula in the modified workspace. Click OK to
finish running the standard.
 

 
5. Use the dimensioning tools to verify the flap is the correct height. On the left is a flap based on the

delivered RDT; on the right is a flap based on the customized RDT.
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Simplifying formulas in Resizable Design Templates

As you gain familiarity with Resizable Design Templates and determine that you’d like to customize
them, you may be confused by some of the formulas. As they come, the RDTs have to run for
all customers no matter which system of measurement they use. If you only use one system of
measurement, you can remove some of the complexity caused by needing to support both.

For example, let’s say you want to customize the tuck flap height in the RDT for FEFCO 0211. You’re in
a European country and you use the metric system exclusively. You also only make this design with a
specific board that has a caliper of 5mm.

Based on the previous instructions for customizing an RDT, you have a copy of FT_0211.ARD open
that you have copied from InstLib\FEFCO to ServerLib. In Advanced StyleMaker, you select Tuck
flap menu in the list of menus and then variable FL1 in the list of variables.
 

 

The formula is STEP(CAL,30,4,35,7,40). Click f(x) to open the graphical editor.
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There are two UNITS branches, one for metric (When UNITS M), and one for Imperial (When UNITS
I). Click the plus signs next to them to open them for examination.
 

 

Translating the formula into words, the flap height size is set by a range of sizes of the caliper.

• For metric, if the caliper is less than or 4mm, the tuck flap height is 30mm. If the caliper is between
exactly 4mm and 7mm, the tuck flap height is 35mm. If the caliper is more than 7mm, the tuck flap
height is 40mm.
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• For Imperial, when the caliper is less than 5/32”, the tuck flap height is 1+3/16”. When the caliper is
between 5/32” and 9/32”, the tuck flap height is 1+3/8”. If the caliper is more than 9/32”, the tuck flap
height is 1+9/16.”

Since you only work in metric, you can remove the When UNTS I branch by clicking When UNITSI:
STEP(CAL) and then Delete. The contents of the Current Expression field change to match.
 

 

Since you always want FL1 to be 35, select When CAL<4:FL1 = 30 and click Delete. Then select Step
Otherwise: FL1 = 40 and click Delete.
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Click OK to return to the Advanced StyleMaker dialog box. The value of field FL1 is now simply 35.
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Default new design template

Each parameter set can now have a default single design template defined. This means that when you
create a new single design by clicking New Design on the File menu, instead of getting a blank design,
the standard you have associated with the parameter set will run and the new workspace will inherit
the results.
 

 

Double-clicking New Design Template opens the New Design Template dialog box for the current
parameter set. Select the Use Design Template checkbox and choose a standard from one of the
catalogs shown.
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Only standards of type ArtiosCAD can be used as new design templates, so only those are listed in
the dialog box. INTERACT, LASERPOINT, and LASERPOINT IQ standards may not be used as design
templates.

The design template does not have to draw any geometry - you can simply set default variables, menus,
and layers in it, and they will be copied into each new workspace made by the template.

Settings in the parameter set for the board code, bridging formula, sideness, and property defaults
take precedence over those settings in the template.

The design template is used only when explicitly creating a new single design. It is not used when
creating a new embedded design in Manufacturing or when moving lines to a new design with the Move
To Layer tool.

Default layers in Manufacturing

You can specify layers that will be created in new manufacturing files at creation and in existing
manufacturing files when they are opened.

To do this, do the following:

1. Start ArtiosCAD and click Options > Defaults > Startup defaults > Default MFG User Layers. The
empty Default MFG User Layers dialog box will open.
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2. Click Add and enter the name of the new default layer in the New Default Manufacturing Layer

dialog box. Click OK when done.
 

 
3. The new layer will appear in the dialog box already selected.
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4. Continue adding layers as desired, clicking OK when done.
5. Save and exit Defaults.

Layers which are not selected are not created automatically; however, they are available for picking in
the drop-down list box in the Create Layer dialog box in Manufacturing.
 

 

All of the default layers, whether created in the manufacturing file or not, will also be available for
selection on the View tab of any Output when the User Defined layer set selection is active.
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Toolbars

In ArtiosCAD you can change the background of toolbars and create customized toolbars to suit your
needs. As with other Defaults, you can define toolbars either on a per-machine basis (User defaults)
or on a server basis (Shared defaults). Customized toolbars can contain buttons for ArtiosCAD tools,
geometry macros, Outputs, and menu commands.

Customized toolbars

Customized toolbars are managed by the Customized Toolbars catalog in Defaults. ArtiosCAD
displays up to 150 customized toolbars in Single Design and canvases and 149 customized toolbars in
Manufacturing, with each toolbar holding a maximum of 15 items. You can define more than the number
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of displayed customized toolbars per module, but ArtiosCAD will display a random assortment in the
Customized Toolbars Master Control.

3D does not offer customized toolbars.

Each item on a customized toolbar must have a unique name. If there are items with the same name
(for instance, one in Shared Defaults and one in User Defaults), ArtiosCAD executes the first one it finds
when you click the button on the toolbar.

Shown below is the Customized Toolbars catalog in Shared defaults. The individual folders are empty
until you create customized toolbars within them.
 

 

Single designs and canvases share the same customized toolbars, but the position and visibility can be
different between them.

Icons for customized toolbars
By default, customized toolbars use the icon of a person’s head. You may design your own icons for
customized toolbars using 24-bit color. They must be 24 pixels high by 24 pixels wide in BMP format.
Set the transparent color to R=192, G=192, and B=192. Icons for Shared defaults must be saved in
ServerLib, while icons for User defaults must be saved in ClientLib.

Each geometry macro and Output can have a customized icon as well. Follow the same rules for them
as those listed above for a customized toolbar icon. Specify the icon in the Icon for custom toolbar
group in the Properties dialog box for the geometry macro, and in the Icon for custom toolbar group
on the Output Type tab of the Output’s Properties dialog box. If you changed the definition of an Output
to specify a custom icon, save the changes, and then exit and re-enter Defaults for the changes to be
shown.

You should create any desired icons before entering Defaults to create the customized toolbar.

Making a customized toolbar
Add custom geometry macros and Outputs to catalogs and save Defaults before making a customized
toolbar. To make a shared customized toolbar, do the following:

1. Start ArtiosCAD and click Options > Defaults.
2. In the Shared defaults pane, click the plus sign (+) next to the Customized Toolbars catalog to open

it.
3. Right-click the appropriate catalog, click New, and then click Data on the context menu.
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4. Replace New Data 1 with the name of the new custom toolbar. Press Enter when you have entered

the name and then double-click the new entry to access its Properties dialog box.
 

 
5. The Properties dialog box for the custom toolbar will appear.

 

 
6. In the top half of the dialog box, choose the tab containing the item that will be replicated on the

customized toolbar. Items from each category can be added to the same customized toolbar.

On the Toolbars tab, select the toolbar to copy from by using the ArtiosCAD Toolbars drop-down
list box. On the Geometry Macros and Outputs tabs, expand the catalogs to access the individual
geometry macros and Outputs. On the Commands tab, simply select the desired command.

359



8 ArtiosCAD

7. Drag the desired tool, geometry macro, Output, or command from the top pane to the Tools in the
Custom Toolbar group. Repeat as desired, putting up to 15 items on the customized toolbar. Shown
below is act of dragging a command to the Tools in the Custom Toolbar group.
 

 
8. To change the icon used for this customized toolbar in the Customized Toolbars Master Control,

enter the name of the icon file you created previously and placed in ServerLib in the Toolbar Icon
group.

To create a customized toolbar for users of the current machine only, create a new Customized
Toolbars catalog by right-clicking in the User defaults pane, clicking New, selecting Customized
toolbars, and following the procedure above for Shared defaults.

To delete an item from a customized toolbar, drag it to the Recycle Bin icon at the bottom right of the
Tools in the Custom Toolbar group.

To delete a custom toolbar, delete its entry from the catalog.

When adding an Output or a geometry macro to a toolbar, the number ArtiosCAD assigns the button will
remain static and cannot be changed by deleting other buttons.

Note:  The title of a customized toolbar may appear incorrectly after you save it. Undock and
redock the toolbar or restart ArtiosCAD to fix it. It will appear correctly thereafter.

Colored toolbars

Each toolbar in ArtiosCAD can have a different background color to make it easier to identify.

Color definitions in User defaults override those set in Shared defaults.
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Colors on standard toolbars
To change the background color of a standard ArtiosCAD toolbar, do the following:

1. Start ArtiosCAD and click Options > Defaults.
2. Open the appropriate Customized toolbars catalog (either the one in Shared defaults or one in User

Defaults) by clicking the plus sign (+) next to it.
3. Double-click ArtiosCAD Toolbars colors. The ArtiosCAD Toolbars colors dialog box will appear.

 

 
4. Click the button of the toolbar to change and click Toolbar color to open the Toolbar color dialog

box.
 

361



8 ArtiosCAD

 
5. Click the color to set as the toolbar background and click OK.

To reset the toolbar background color to the default, click Set to System Color and then click OK.
6. The Toolbar color button in the ArtiosCAD Toolbars colors dialog box will change to the color you

selected.
7. Repeat steps 4 and 5 as desired. When done, click OK to return to Defaults, or click Cancel to

discard the changes.

Colors on customized toolbars
To change the background color of a customized toolbar, do the following:

1. Start ArtiosCAD and click Options > Defaults.
2. Open the Customized toolbars catalog (either the one in Shared defaults or one in User Defaults) by

clicking the plus sign (+) next to it.
3. Open the Designer customized toolbars catalog or the Manufacturing customized toolbars catalog

by clicking the plus sign (+) next to it.
4. Double-click the customized toolbar to change to open its Properties dialog box.
5. Click Toolbar color.
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6. The Toolbar color dialog box will appear. Click the color to set as the toolbar background and click

OK.

To reset the toolbar background color to the default, click Set to System Color and then click OK.
7. The Toolbar color button in the customized toolbar’s Properties dialog box will change to the color

you selected.
8. Repeat as desired for other customized toolbars. When done, click OK to return to Defaults, or click

Cancel to discard the changes.

Toolbar Hover Color
The ArtiosCAD Toolbar Hover Color entry in the Customized Toolbars catalog sets the hover color and
gradient use for the toolbars. ArtiosCAD shows the current hover color as the background of the Hover
color button.
 

 

Clicking Hover color leads to a color palette in which you can choose a new hover color.
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Use Gradient toggles the display of a gradient on the hover color. The gradient is not adjustable.

Shortcuts

Shortcuts are keyboard sequences that activate ArtiosCAD commands, such as pressing CTRL-N for
a new single design workspace. Shortcuts are organized by where they are used: 3D, Design (single
designs and canvases), and Manufacturing. Shortcuts can also be assigned to Outputs and geometry
macros.

Every menu command can have a shortcut assigned to it.

Shown below are the categories for menu commands in the Shortcuts Catalog in Shared Defaults.
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To create menu command shortcuts in User Defaults, right-click in the User Defaults pane, click New,
and then click Shortcuts. A Shortcuts Catalog is created with the three entries for the types of menu
command shortcuts. Save the User Defaults after creating the Shortcuts Catalog but before adding to
it.

Assigning a shortcut to a menu command

To assign a shortcut to a menu command, do the following:

1. Start ArtiosCAD and click Options > Defaults.
2. Scroll down the list of Shared Defaults, and open the Shortcuts Catalog by clicking the plus sign (+)

next to Shortcuts.
3. Double-click the category for the desired new shortcut. In this example, the Direction menu

command on the View Options sub-menu of the View menu will be assigned a shortcut, so double-
click the Design and Canvas Shortcuts category. The Design and Canvas Shortcuts dialog box
opens as shown below.
 

 
4. Scroll down to the View menu, and double-click Direction under View Options.
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5. An empty Shortcut dialog box appears. Press the key combination to assign to the Direction

command. For this example, press ALT-D. The key sequence and the command to which it will be
assigned appear as you press it. The command is followed by the type of shortcut (system or user)
and the area of ArtiosCAD in which it is active.
 

 
6. Click OK to return to the Design and Canvas Shortcuts dialog box.
7. Note that the newly-assigned command now appears in the Key column of the dialog box.
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8. Click OK in the Design and Canvas Shortcuts dialog box.
9. Click File > Save to save the Shared Defaults. The new shortcut is now ready for use in Builder and

Designer.

Assigning a shortcut to an Output

To assign a shortcut to an Output, open the Properties dialog box for that Output. Enter the shortcut in
the Shortcut: group on the Output Type tab as shown below.
 

 

Assigning a shortcut to a geometry macro

To assign a shortcut to a geometry macro, open the Properties dialog box for that geometry macro and
enter the shortcut in the Shortcut: group as shown below.
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Shortcut uniqueness and priority

When a shortcut in Shared Defaults is assigned a key sequence, any other shortcuts having the same
key sequence are shown. Only shortcuts in Shared Defaults and those in the current machine’s User
Defaults are compared. Shortcuts in other machines’ User Defaults are not compared with those in the
current machine’s User Defaults.
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The shortcut at the top of the list has the highest priority and will prevent other shortcuts assigned the
same key sequence in the same module from working. However, if the other key sequences are in other
modules, there will be no conflict when the shortcut is used.

Shortcuts in User Defaults take priority over those in Shared Defaults. Within User Defaults, menu
items take priority over geometry macros, and geometry macros take priority over Outputs. If a
shortcut is assigned to the same command in all three subcatalogs, the one in Design is listed first,
then the one in Manufacturing, and finally the one in 3D.

Notes and warnings for Shortcuts

Always use an accelerator key (CTRL or ALT) when defining a shortcut with a letter. Not doing so will
cause a conflict between the shortcut and StyleMaker.

Only the first 300 shortcuts defined for geometry macros are active.

Counter layouts use the same shortcuts as Manufacturing.

If the same shortcut is assigned to a menu item that displays in both single designs and canvases, it
won't work in one of them, but which one is random and will change.

When a geometry macro has a shortcut, and this geometry macro is present on a customized toolbar,
and the geometry macro opens a dialog box, the button on the customized toolbar is not depressed
when the geometry macro is activated by the shortcut.

There is only one set of user shortcuts per machine.

If you change shortcuts and exit without saving the changes, the uniqueness tests for successive
changes will not be accurate.

Enter can not be used as any part of a shortcut.

Some shortcuts are permanent as shown in the table below.
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Table: Permanent Shortcuts

Command Shortcut

Run Standard CTRL-2

New 3D CTRL-3

New Design CTRL-N

File Open CTRL-O

Help F1

Next Pane F6

Previous Pane SHIFT-F6

Properties ALT-Enter

Close CloseUp Window SHIFT-Space

Restart current tool ESC

Tack Bridging

Tack bridging formulae are stored in the Tack Bridging Catalog.
 

 

Shown below is a sample exterior metric formula.
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Set the distance between tack bridges in the Tack distance: field and set the width of each tack bridge
in the Tack width: field.

The One-sided and Two-sided option buttons control if the tack bridges are cut only toward the
interior of the carton or toward the interior of the carton and the exterior of the carton.

The Simple, 90 degree, 120 degree, 135 degree, and Arc tack bridge option buttons all set the style of
tack bridge as shown in the pictures in the dialog box.

Click OK to save the changes to the Tack Bridging formula and return to Defaults, or click Cancel to
return to Defaults, discarding the changes.

Bridging Formulae

ArtiosCAD’s default bridging formulae are stored in the Artios subfolder of the Bridging Catalog. There
are corrugated and folding carton bridging formulae in Imperial and metric units. Shown below is the
Corrugated - Metric bridging formula set for evenly spaced bridges.
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The drop-down list box controls all the other settings in this dialog box. The No bridges selection
removes all other settings from the dialog box. Evenly spaced and Inset distance from line end are
explained in the following sections.

Evenly spaced bridging formula

An evenly spaced bridging formula applies bridges based on the length of the line or arc. The size of
the bridges is determined by the length of the line.

There are three groups of parameters in an evenly spaced bridging formula - Bridges on lines, Bridges
on arcs, and Width of Bridges.

Bridges on lines and Bridges on arcs groups
The Bridges on lines and Bridges on arcs groups work similarly. A list of limits determines the number
of bridges applied to lines or arcs. Shown below are the two groups in the Corrugated - Metric formula.
 

 

If the length of the line or arc is less than or equal to the value in the field, the integer to the left of the
field is the number of bridges applied to the line or arc. If the length of the line or arc is greater than the
value in the field, the limit is skipped and the next limit is applied. Click Add limit to add a limit; click
Delete limit to delete a limit.

After all the limits are met, the lines and arcs are bridged according to the value shown after then
bridge every X.XX where X.XX is the difference between the last two limits.
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There must be at least one limit per group.

Width of Bridges group
The Width of Bridges group works slightly differently than the others in that there are two values to set
per limit - the width of the bridge and length of the bridge for the limit.
 

 

The length of the bridges will be the value on the left if the line or arc length is less than or equal to the
length on the right.

Click Add limit to add a limit; click Delete limit to delete a limit. There must always be at least two
limits - one less than or equal limit, and one if longer limit.

Inset distance from line end bridging formula

An Inset distance from line end bridging formula insets a bridge at each end of a line and then evenly
spaces the bridges between the two that were inset.
 

 

Rules shorter than the Minimum rule length to bridge will not be bridged. Rules whose length is
between the Minimum rule length to bridge value and the Min rule length for full inset distance will
have only one bridge. Rules longer than the value in Min rule length for full inset distance will have
the two inset bridges, plus more bridges if the two inset bridges are further apart than the value in
Maximum distance between bridges. The Inset distance is the distance from the ends of the line to
the centers of the inset bridges. Bridge centers can be no closer than the Minimum distance between
bridges, and cannot be further apart than the Maximum distance between bridges.
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The Advanced tab adds two parameters to the group:
 

 

These two fields are used when migrating bridging formulae from The Designer WorkBench into
ArtiosCAD. Set the Inset factor to 0.285. The One Bridge Minimum equals the Minimum distance to
bridge. The Inset Factor Limit is half the Maximum distance between bridges.
 

 

The options in the Width of Bridges group work the same for Inset formulae as they do for Evenly
spaced formulae.

Working with tuning catalog entries in Defaults

You will most likely need to create your own tuning catalog entries for PDF or DWG/DXF files as each
supplier may produce them differently. The procedures for working with DWG/DXF tuning files are the
same as they are for PDF files; substitute the type of file you are working with as appropriate. Follow
the instructions below to work with tuning catalog entries.

Creating a PDF vector import tuning catalog entry

ArtiosCAD comes with two example tuning files for importing PDF files as lines. However, since people
can create PDF files in many different ways, you may need many different tuning catalog entries to
accommodate them.

To create a new PDF vector import tuning file, do the following:

1. Log in as Administrator or as a user with administrative privileges.
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2. Start ArtiosCAD.
3. Click Options > Defaults.
4. In the Shared defaults pane, scroll down the list to Import Tuning Table. Optionally, expand it by

clicking the plus sign (+) next to it.
5. Right-click Import Tuning Table (or a folder underneath it if you expanded the catalog) and click

New > Data on the context menu.
6. In the Select import type list box, select PDF and click OK.
7. Enter a name for the new tuning file and press Enter.

A tuning catalog entry has been created with specified name.

Opening a PDF vector import tuning catalog entry

To open a PDF vector import tuning file for editing, do the following:

1. Start ArtiosCAD.
2. Click Options > Defaults.
3. In the Shared defaults pane, scroll down the list to Import Tuning Table.
4. Expand the catalog and double-click the name of the tuning entry to open for editing.

A dialog box appears showing the tuning for this catalog entry.
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Editing a PDF vector import tuning catalog entry using a template

This procedure requires knowledge of the existence and design of the layer structure of your incoming
PDF files. PDF files can have layers but also can be flattened (when all elements are in one layer).
Ask the senders of PDF files about the layer structure they use, or examine them in a program that
can edit PDFs, such as Adobe Illustrator. If the files are coming from Adobe Illustrator, and you want
the layer information to be preserved, the Create Acrobat Layers from Top-Level Layers option
must be selected when saving the file in PDF format, otherwise the file will be flattened and no layer
information will be preserved.

To edit a PDF vector import tuning catalog entry, start ArtiosCAD and follow the instructions in Opening
a PDF vector import tuning catalog entry to open it.

Once you have the tuning catalog entry open, set the options according to the procedure described
below.

1. In the Import As group, select either Oneup, Layout, or Auto-Detect. Oneup means that this tuning
catalog entry will always be used with PDF files containing single designs. Layout always processes
the PDF files as if they contain multiple single designs. Auto-Detect reads the geometry of the
vectors and process the file appropriately.
 

 
2. Set the Design Side and Die Side list boxes to appropriate values (Inside or Outside and Die Back

Side or Die Knife Side) for the incoming PDF data.
3. In the Flute or Grain group, choose either Vertical or Horizontal for the direction of the material

used to manufacture the workspace.
 

 
4. The controls in the Mapping group determine how ArtiosCAD converts vectors from the PDF data

into design lines. The easiest way to set this up is to use an existing PDF file as a template. You may
need to do this for each supplier of PDF files (in separate tuning files) depending on the software
they use to create them.
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5. Click Template.
6. Select the PDF file to use as a template and click Open. If the PDF file contains more than one page,

select the page to use as the template.
7. In the preview image, select a line and then set what it should be in the ArtiosCAD Design Attributes

group. In the example below, the edge was selected and set to be cut lines in the Main Design layer
at pointage 2. The Zoom controls above Apply and Help let you change the view so you can select
the lines you need to tune more easily.
 

 
8. Continue selecting lines in the preview and defining their properties in the ArtiosCAD Design

Attributes group. If you make a mistake, select a line of tuning and click Delete. ArtiosCAD applies
the tuning entries in a top-down order. In the example above, it will set all the lines with color
Artios_cut to be Cut lines, and then it will set all the lines with color Artios_crease to be Crease
lines. Shown below is the same dialog box as above with more line types tuned. You can change the
processing order by selecting a line of tuning and clicking the up and down arrows at the edge of the
group control.
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9. After you have finished selecting all the lines in the preview to tune, click Insert to add a final line of

tuning. This final line of tuning will send all lines that are not explicitly tuned to the Annotation layer
as 2-point Annotation lines.
a) For this final line of tuning, set the controls in the PDF attributes group to any, any, and any.
b) In the ArtiosCAD Design Attributes group, set the Layer to Annotation, the Line type to

Annotation, and the Pointage to 2.
10. Click Color Names to change the names of the colors coming in from the tuning template. In the

Color Names dialog box, you can rename an existing color by selecting it and changing the Name:
field. For example, if you have a color defined as 100% magenta, 30% yellow, and 15% black, you
could select it and rename it reddish. You can also insert and delete color definitions as desired
using Insert and Delete, but selecting lines in the template is the intended way of inserting color
names initially.
a) There are two colors with special meaning. White matches all paths that have no color assigned

or that have 0% for all components. Uncolored matches all paths that are not rendered in the
PDF file, such as guides and clipping paths.

11. Click Options to open the PDF Import Options dialog box.
 

 
a) Import text as outlines controls if text is imported or ignored and also controls the availability

of the two sub-options. Add to annotation layer adds the text as outlines to an Annotation layer
using the Annotation line type. Add as fills to graphics layer adds the text to a Graphics layer
and fills it with the font color specified in the PDF file.

b) Change beziers to arcs changes beziers to arcs during the import process instead of having to
use the tool later.
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c) Unfiltered items to graphics layer sends strokes and fills that were not processed by a tuning
entry to the Graphics layer.

d) Click OK to return to the tuning dialog box.
12. Click OK to complete the editing of the tuning catalog entry and return to Defaults.
13. Click File > Save to save the changes to Defaults.
14. Click Yes to confirm overwriting Defaults.

Editing a PDF vector import tuning catalog entry manually

If you do not configure the PDF line type mapping using a template as described in the previous
section, configure it manually by following the instructions below.

Once you have the tuning catalog entry open, set the options according to the procedure described
below.

1. In the Import As group, select either Oneup, Layout, or Auto-Detect. Oneup means that this tuning
catalog entry will always be used with PDF files containing single designs. Layout always processes
the PDF files as if they contain multiple single designs. Auto-Detect reads the geometry of the
vectors and process the file appropriately.
 

 
2. Set the Design Side and Die Side list boxes to appropriate values (Inside or Outside and Die Back

Side or Die Knife Side) for the incoming PDF data.
3. In the Flute or Grain group, choose either Vertical or Horizontal for the direction of the material

used to manufacture the workspace.
 

 
4. The controls in the Mapping group determine how ArtiosCAD converts vectors from the PDF file

into design lines.
a) In the PDF Attributes group, Layer: selects the layer in the PDF file containing the lines to

process for import into ArtiosCAD.
b) Graphic Type: can be a few different choices. Any is any stroke, fill, or bitmap. Any_stroke

matches any stroke and fill matches any fill. Any positive number is a stroke width.
c) The Color Names: field and corresponding dialog box are meant for use when defining tuning

using a template. Ignore them when setting tuning manually.
d) In the ArtiosCAD Design Attributes group, set the Layer:, Line Type:, and Pointage: fields to

the type of ArtiosCAD line that will be created for each line that matches the parameters set in
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the PDF Attributes group. Use PDF layer name names the ArtiosCAD layer the same as the PDF
layer.

e) The mapping entries are processed in a top-down order. To change the order, select an entry,
then use the up and down arrows at the side of the control to move the selected entry.

5. After you have finished selecting all the lines in the preview to tune, click Insert to add a final line of
tuning. This final line of tuning will send all lines that are not explicitly tuned to the Annotation layer
as 2-point Annotation lines.
a) For this final line of tuning, set the controls in the PDF attributes group to any, any, and any.
b) In the ArtiosCAD Design Attributes group, set the Layer to Annotation, the Line type to

Annotation, and the Pointage to 2.
6. Click Options to open the PDF Import Options dialog box.

 

 
a) Import text as outlines controls if text is imported or ignored and also controls the availability

of the two sub-options. Add to annotation layer adds the text as outlines to an Annotation layer
using the Annotation line type. Add as fills to graphics layer adds the text to a Graphics layer
and fills it with the font color specified in the PDF file.

b) Change beziers to arcs changes beziers to arcs during the import process instead of having to
use the tool later.

c) Unfiltered items to graphics layer sends strokes and fills that were not processed by a tuning
entry to the Graphics layer.

d) Click OK to return to the tuning dialog box.
7. Click OK to complete the editing of the tuning catalog entry and return to Defaults.
8. Click File > Save to save the changes to Defaults.
9. Click Yes to confirm overwriting Defaults.

Line types

Line types:

• Distinguish between rules for flat dies and rules for rotary dies.
• Distinguish between lines which should be burnt on their outer edge (such as the die wood edge)

and those which should be burnt on their inner edge (such as lower stripping holes).
• Support pointage of 1.5.
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Line information in older workspaces will be automatically converted with no loss of information when
the workspaces are opened in ArtiosCAD.

The category in which a line type resides determines its properties and also how it is processed during
output. Of particular note are the Inside Edge and Outside edge categories. When line types belonging
to these categories are output to a laser, they are offset to compensate for their thickness. Tool
outlines must form complete loops for the direction of the offset to be well defined. Line types in the
Center Edge category have no offset - the laser beam burns down their middle.

Only rules should have bridges defined, and only tool outline line types should have tack bridges. Other
line types should be created without bridges. Only cut lines should have nicks.

Table: Line Type Categories

Line type
category

Examples Properties / Notes

Generic rules Cut, crease, reverse crease, glue
assist, balance rules, chop knives

Width, bridges, subtype

Rules 1/8 x 1/8 perf, 1/4 x 1/4 cut/crease,
zipper rule, punch hole, side bevel cut,
specific rotary cut rule. Defined in the
rule table.

Width, Bridges, Generic type, height,
name, rule geometry, rotary teeth
spacing

Center edge Unknifed diecut, unknifed lower,
unknifed upper

Width, tack bridges, subtype

Inside edge Lower stripping hole, Die registration
hole

Tack bridges, subtype. Offset is applied
inward during laser output.

Outside edge Die edge, Lower stripping edge,
stripping block

Tack bridges, subtype. Offset is applied
outward during laser output.

Etch Die etch, lower stripping etch, upper
stripping etch

Subtype. No offset applied during laser
output.

Laser output Tool 1, Tool 2, Tool 3, .. increased from
20 to 30 laser line types.

None. Laser output will pass beam width
for DDES,CFF2

Annotation Annotation, Print image, Print
registration, Bleed, Varnish

None

Sample output Sample cut, sample partial cut,
sample with grain crease, sample
cross grain crease

None

Counter output With grain channel, Cross grain
channel, Crease end tool, Periphery
tool

None
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Subtypes

A subtype is a definition to further classify a type of line - it is a label only and is used for sorting the
tool assignment data when performing a CAM Output. Subtypes can have their own entries in Advanced
plotting styles. Up to 100 subtypes can be defined in the Subtype Mapping Catalog.
 

 

To define a subtype, select it, and enter the description of the subtype in the Description: field. Repeat
as desired, and when done, click OK to save the definitions or Cancel to ignore them and return to
Defaults.
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Plotting Styles

Plotting styles control the appearance of lines on screen and how lines are drawn or made on printers,
plotters, samplemakers, and countercutters. Plotting styles control the colors, widths, and styles used.
They also control which physical tool an output device uses to construct the line.

Note:  Plotting styles are not used to configure CAM outputs such as lasers and Kongsberg
DieSaws; output to those types of devices is configured using the CAM Tooling Setup catalog.

Each plotter, samplemaker, and countercutter should have its own plotting style configured as each
has a different tool configuration. Most known output devices have plotting styles defined in the
example CAM Outputs. To view the example CAM Outputs, open the example Defaults by selecting
User Defaults, then clicking File > Open > Example Defaults. Expand the Plotting Style Catalog in the
Example defaults pane, find the one you want, and drag it into the Plotting Style Catalog in the Shared
defaults pane. The names may contain CAM, but rest assured these are for plotters, samplemakers,
and countercutters.
 

 

383



8 ArtiosCAD

Plotting styles may be either simple (the default) or advanced. Simple plotting styles configure the line
color, line width, line style, and tool number based solely on a line type. Advanced plotting styles do the
same configuration, but can be based on line type, subtype, and pointage instead of just line type. An
Advanced plotting style can not revert to a Simple plotting style.

Working with simple plotting styles

When the Advanced checkbox in the Line Types group is clear, the current plotting style is considered
simple. In a simple plotting style, the line types are organized on five tabs - Design, Manufacturing,
Sample, Tooling, and Counter.
 

 

On each tab are the line types relevant to each label. For examples, the Design tab lists such types
as Cut, Crease, Partial cut, and so forth. The Manufacturing tab contains line types used in the
Manufacturing module, such as Stripping Rule, Die board edge, and Unknifed blanker. The same is
true for the other tabs.

When looking at the line types, shown first is the line type name, then an example of the line type using
the attributes selected in the right pane, and finally the tool number. When creating a new plotting
style, all the tool numbers are set to zero by default.
 

 

Creating a new simple plotting style
To create a completely new simple plotting style, do the following:

1. Right-click the Plotting Style Catalog entry in Defaults and click New > Data on the context menus
that appear.
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2. Enter a name for the new plotting style and press ENTER.
3. Double-click the style to access its property page in order to change its defaults. The window

should appear similar to the one shown below.
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On the left is a set of five tabs that correspond to the different categories of lines. Each tab has a
control showing the line name, the line style, the line color, and the currently-assigned tool number.
On the right are controls to set those attributes.

Checking the Output Only checkbox makes this plotting style available only when configuring an
Output - it is hidden when changing the plotting style in the View Mode.

Save as XML saves the plotting style as an XML file for use with the WebCenter Viewer.

For outputs, the tool number applies only when this plotting style will be used in an Output
definition using a CAM driver.

For outputs, the Color and Line Width apply only when this plotting style will be used in an Output
definition using either a Windows driver or a graphic CAM driver such as the PCL driver used for
sample printing.

Copy From Style copies attributes of another plotting style into the current one.
4. Click each line style and set the line attributes as desired.
5. Click OK to save the changes to return to Defaults, or click Cancel to discard them and return to

Defaults.

Changing the line attributes in a simple plotting style
To change the attributes of a line in a simple plotting style, do the following:

1. Open Defaults and double-click the plotting style to change.
2. Click the tab for the class containing the lines you wish to modify.
3. Select the line to modify in the Line Types group.
4. Select the new attributes - Color, Line Width, Line Style - from their respective lists in the

Attributes group.
5. If desired, change the Tool Number.
6. Click OK to save the changes and return to the Plotting Style catalog, or click Cancel to discard the

changes.

Creating a new plotting style by copying from another plotting style

To base a new plotting style on an existing plotting style, do the following:

1. Right-click the Plotting Style Catalog entry in Defaults and click New > Data on the context menus
that appear.

2. Enter a name for the new plotting style and press enter.
3. Double-click the style to access its property page in order to change its defaults.
4. Click Copy From Style.
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5. Select the plotting style to copy from on the left.
6. Select the line type categories to copy by checking the appropriate checkboxes in the Line Type

Subset group None are selected by default.
7. Select or clear the Copy color and style and Copy tool numbers checkboxes as appropriate.

 

 
8. Click OK to copy the styles and attributes or click Cancel to return to the Plotting Style dialog box.

Working with Advanced plotting styles

When the Advanced checkbox is checked, the plotting style is considered Advanced. Configuring
an Advanced plotting style takes slightly more time than a Simple plotting style but it allows greater
flexibility.

Creating a new Advanced plotting style
To create a completely new Advanced plotting style, do the following:

1. Right-click the Plotting Style Catalog entry in Defaults and click New > Data on the context menus
that appear.
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2. Enter a name for the new plotting style and press enter.
3. Double-click the style to access its property page in order to change its defaults and click the

Advanced checkbox. You will be asked to choose whether to keep the definitions from the simple
style or to create a blank style. For the purposes of this workflow, choose Initialize to blank style
and click OK.
 

 
4. The blank Advanced style appears as shown below.
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The Attributes group for an Advanced plotting style works in the same way as it does for a Simple
plotting style. The Line Types group, however, works differently as explained below.

5. In a newly-created advanced plotting style, as seen in the Line Types group, all lines are configured
to be shown as solid line style, black color, 1.00 width, and tool 0.
 

 

Advanced plotting styles work by assigning line attributes based on conditions defined in a line style
statement. If a line meets a line style condition, it is assigned whatever attributes are assigned in
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the line style statement. The (Remainder) statement applies to line styles which meet none of the
conditions. There will always be a (Remainder) statement; it cannot be deleted, but its attributes
can be modified as desired.

6. To add line style statements, do the following:

• Click Insert. A new entry appears in the table and the corresponding ArtiosCAD syntax is shown
in the Selection: field. By default, this new entry is solid line style, black color, 1.00 width, and
tool 0.
 

 

• Click Types to open the Types dialog box. All line types other than Annotation are selected
by default. Select the line types to designate in this line style condition. Click category tabs
(Design, Sample, Tooling, Counter, and Manufacturing) to choose from lists of line types in
those areas of ArtiosCAD. Select All selects all the line types on each tab. Invert Selection
reverses whatever is selected - each style that is checked becomes cleared and each style that
was clear becomes checked. Your selection will appear in ArtiosCAD syntax in the field below the
checkboxes.
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• Click OK to save this selection and return to the Plotting Style properties dialog box or Cancel to
ignore this selection and return to the Plotting Style properties dialog box.

• Once back at the Plotting Style properties dialog box, click Subtypes to open the Subtypes
dialog box and choose which subtypes to include in this line style definition. The ArtiosCAD
syntax for your selection will appear in the field beneath the checkboxes.
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• Click OK to save this selection and return to the Plotting Style properties dialog box or Cancel to
ignore this selection and return to the Plotting Style properties dialog box.

• Click Pointages to open the Pointages dialog box. Check or clear the checkboxes as desired. The
ArtiosCAD syntax for your selection will appear in the field beneath the checkboxes.
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• Click OK to save this selection and return to the Plotting Style properties dialog box or Cancel to
ignore this selection and return to the Plotting Style properties dialog box.

• Do not forget to also change the line attributes (color, line width, line style, and tool number) if
you do not want them to be the default of black, 1.00, solid, and 0. Shown below is an example of
crease line subtypes 0 through 2 and 4 through 5, pointage 0 through 1 and 2 and greater made
to be red, have a line width of 1.00, a style of dot-dash, and output on tool 2.
 

 

• If you are familiar with ArtiosCAD syntax, you may edit the Selection: field directly.
7. Repeat step 5 for each line style statement you wish to make. Shown below is the Artios.Pointage

style which is based on line pointage; it uses a different color and tool number for each pointage.
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8. When you have finished adding line style statements, click OK to save the changes to the plotting

style or click Cancel to ignore them and return to Defaults.
9. Save the Defaults by clicking File > Save and clicking Yes when prompted to overwrite the existing

Defaults.

Converting a simple plotting style to an Advanced plotting style
When you convert a simple plotting style to an Advanced plotting style by checking the Advanced
checkbox in a simple plotting style definition, you can choose to preserve the line style definitions,
or you can initialize the Advanced plotting style with no values. Preserving the settings of the simple
plotting style results in an Advanced plotting style similar to the one shown below. Initializing a blank
plotting style results in having to define every line type as described in the previous section. In either
case, edit the properties as desired. When done, click OK to accept the changes, or click Cancel to
discard them.
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Special Rule Types

ArtiosCAD provides a series of generic rule types such as cut and crease. These are used at the design
phase when how the line is cut or creased is unimportant or not known. There are other generic rule
types, for example, for cut-crease lines. It is often necessary to specify that a cut-crease line is in fact
½” cut by ½” crease with crease used as the end land. In this case, a special rule should be used.

Special rules may also be used for simple cut and crease rules to allow more specific control during
manufacturing. For example:

• Helmold 3pt 0.937” cut rule

• Böhler 3pt 23.6mm SN1 notched cutting rule

Specific bridging methods, rule widths, subtypes (for special cutting characteristics), and labels can be
associated with special rules which aid in the flat and rotary die manufacturing process. Shown below
is the Special Rule Types Catalog in Defaults.
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When editing a special rule, the Properties dialog box will have one or two tabs depending on the class
of rule. All special rules have a Manufacturing tab with options such as pointage, subtype, rule height,
flat rule or rotary rule, and so forth. Special rules that require more information to manufacture, such
as perf, have a Special Rule tab in which rule-specific parameters are set, such as length of cut and
crease, land length, land options, and so forth.

Manufacturing tab for special rules

Shown below is an example of the Manufacturing tab for 3-point rotary cut rule in Imperial format.
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Pointage sets the pointage of the rule. You can either select a value from the drop-down list box or
type your own.

Subtype sets the subtype of the rule. The subtype is used to configure specific manufacturing options
in a CAM Tooling Setup.

Rule height and Rule Cost set the height and cost of the rule respectively. This information is used in
line type legends and DDES-3 files only.

The text in the Rule Label field is printed when rule labels are enabled in the View Mode dialog box or in
Outputs.

The Generic Type field is used to determine if more configuration options are needed on a second tab.
For example, the cut and crease generic types do not require more configuration information, but the
perfs and cut & crease types do.

The options in the Die Representation group determine how the rule is manufactured. Use pointage
sets the slot width to the pointage * 0.014 inches. Design sets the slot in the die so that it follows the
design of the special rule, such as waves in a wave rule. The slot width is the pointage * 0.014 inches.
Slot lets you specify a custom slot width independent of the pointage.

Bridge formula for the rule path tells the rule which bridging formula to use. Bridge on teeth controls
whether or not the rule has teeth, and what the tooth size, tab width, and which bridging formula to
use.

Nominal tooth spacing refers to the customary size of the teeth on rotary rule. The Actual spacing
is the distance between each tooth measured around the cylinder at cylinder level. The easiest way
to measure this value is to mark off the distance between 10 teeth on a cylinder, and measure around
the cylinder with an accurate tape measure, making sure to use the same point for the start and end.
Divide by 10 to get the Actual spacing.

The Cylinder diameter is the cylinder for which this rule was made. It is used ONLY to compute tooth
spacing when other-sized cylinders use this rule.
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If you enter a cylinder diameter and an actual spacing value, ArtiosCAD can compute the tooth spacing
when other die cylinders are used. This means that you do not have to enter separate special rules for
each diameter cylinder.

Table: Rule Tooth Values

Common cylinder diameters Tooth Spacing Result from

Nominal Actual

Inch

21.000 0.500 0.471 Computed

19.1875 0.500 0.469 Rule table

14.125 0.500 0.458 Computed

11.500 0.500 0.450 Computed

10.1875 0.500 0.444 Computed

7.000 0.500 0.423 Computed

Metric

530.00 11.00 10.36 Computed

487.36 11.00 10.31 Rule table

300.00 11.00 9.92 Computed

250.00 11.00 9.73 Computed

The tooth spacing is different for different cylinder diameters because when the rule is bent, it bends
around the neutral axis. The neutral axis is the point in the rule that neither gets longer nor shorter
when the rule is bent into a circular arc. The position of the neutral axis will be different for different
types of rule. For example, some 6pt or 3pt rule will have the neutral axis a little closer to the top of the
rule than simple 3pt rule. This is because the 6pt part is harder to bend than the 3pt part towards the
bottom. Of course, the bottom of the rule has teeth cut out of it, so it is very easy to bend. Normal 3pt
toothed rule would have the neutral axis about half way between the top of the tooth notch and the top
of the rule.

As the cylinder diameter gets smaller, the teeth will get closer together, but the distance along the
neutral axis will remain unchanged. The position of the neutral axis can be computed from the values
given. It can then be used to calculate the tooth spacing for any diameter.
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Length of adjustment for blend is used to calculate tooth positions after bending the rule. The entry in
this field is derived from the table accessed by clicking the f(x) button.
 

 

The Flat rule and Rotary rule option buttons designate the kind of rule. When Flat Rule is chosen, click
the Browse button (...) at the end of the Associated rotary rule: field to choose the associated rotary
rule.

In the Bend around corner group, Rotary to flat rule and Flat to rotary rule determine which is bent
when a rule path bends around a corner when making a rotary die. Extension past corner sets the
amount of rule to keep after the bend. Angle at which to use rotary rule sets the angle at which to
switch from using flat rule to using rotary rule. The angle is measured from the horizontal axis.

When the option is set to Flat to rotary rule, ArtiosCAD will choose the flat to rotary option provided
that the length of the vertical distance for flat in the picture below is less than the Maximum vertical
distance for flat in the Rule Path Params catalog in the manufacturing parameter set. Note that the
Maximum vertical distance for flat in the rule path parameters may need to be increased to get this
desired result.
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For a suciently large chamfer, ArtiosCAD will use the Wrap rotary to flat option. The picture below
shows the wrap points for different size blends and chamfers.
 

 

Special rule tab for special rules

The Special Rules tab is different for each kind of special rule. For example, for a perf rule, it looks like
this:
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But for a scallop rule it looks like this:
 

 

For wave and zig zag rules, the Nick on top option is available:
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You probably already know the parameters for the rule you are configuring; enter the values and
click OK to save the changes to the special rule and return to Defaults, or click Cancel to discard the
changes.

Multi-Perf Overview

Multi-perf is perforation rule with a repeating pattern of differently sized teeth and gaps. Shown below
are some examples of multi-perf rules.
 

 
The pattern for the multi-perf is defined in a workspace.

Save your pattern definition workspace to ServerLib (conventional version) or the ServerLib folder in
the Shared Defaults Project (Enterprise version).

Designing a multi-perf pattern
In each pattern definition workspace, design a combination of horizontally aligned cuts, creases, and
gaps that define the pattern. You can add optional vertical annotation lines marking the land length and
the ends of the pattern. Shown below are sample patterns.

Special rule type Perf pattern workspace

1/8 1/8 perf-in-crease

1/4 1/4 perf crease

1/4 1/4 3/4 perf

1/8 1/8 3/8 perf

Multi-perf1
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The vertical annotation line in the 1/8 1/8 perf-in-crease example instructs ArtiosCAD to treat the
crease as the land. For the 1/4 1/4 3/4 perf, the land is the space between the two annotation lines,
which ArtiosCAD uses to center the perf pattern along design lines. The Multi-perf1 pattern is too long
for a land, so the vertical annotation line marks the end of the pattern.

Use the following line types when designing your own pattern defintion workspace:

• Cut
• Partial cut
• Reverse partial cut
• Crease
• Second height crease
• Matrix crease

Defining the land
An annotation line in the middle of a pattern marks the right end of a land.
 

 

If the pattern has a land, ArtiosCAD centers the perf pattern on the line with the same land at both
ends. Shown below is an example of how the pattern is centered on lines of different length.
 

 

If the pattern has no land, ArtiosCAD aligns the pattern with the start of the line, and the value in the
Minimum land/pattern offset field of the special rule definition defines the offset of the pattern along
the line as shown below.
 

 
 

403



8 ArtiosCAD

 

To make the pattern center correctly on the rule, make the land symmetrical, so it has the same cut or
gap at both ends.
 

 

Adding a Multi-Perf Definition to the Special Rule Types Catalog
Once you have designed a pattern definition workspace for a multi-perf and saved it to ServerLib, do
the following to add it to the Special Rule Types Catalog.

1. Start ArtiosCAD. If you are using an Enterprise version, log in as a member of ADMINS.
2. Click Options > Defaults.
3. In the Shared Defaults pane, expand the Special Rule Types Catalog.
4. Right-click Multi-perf and then click New > Data on the context menu.
5. Enter a name for the new multi-perf type and press Enter.
6. On the Manufacturing tab of the special rule type dialog box, select Multi-perf from the Generic

type drop-down list box.
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7. On the Special rule tab of the special rule type dialog box, enter or browse for the pattern definition

file. Enter a value in the Minimum land/pattern offset field if the pattern definition workspace does
not have a land defined.
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8. Click OK to save the new multi-perf catalog entry.
9. Save and exit Defaults as usual.

Edge band and Tear Tape Overview

Edge band is a cover that hides the edge of thick material, such as Re-board
®

, usually used for displays.
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Tear tape is the thin plastic strip on the inside of box-opening features.
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Both edge band and tear tape are special rules.

Defining an Edge Band
To define an edge band, do the following:

1. Design a cross-section of the edge band as a single design. Make sure it forms a loop and orient it
horizontally so that its lower middle section aligns with the board edge.
 

 
2. Copy the cross-section workspace to ServerLib.
3. In Defaults, add a new entry to the Edgeband folder of the Special Rule Types catalog by right-

clicking it and then clicking New > Data on the context menu.
4. On the Manufacturing tab, set its Generic type to Edge band.
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5. On the Special rule tab, enter the cross-section workspace's name or browse for it.

 

 
6. Click Select Color to set the color of the edge band.
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7. Click OK to return to Defaults.
8. Modify a plotting style to give the Edge band type a thick dashed line.

 

 
9. Save and exit Defaults normally.

Defining a Tear Tape
A tear tape has a thickness and a color.

1. In Defaults, add a new entry to the Tear tape folder of the Special Rule Types catalog by right-
clicking it and then clicking New > Data on the context menu.

2. On the Manufacturing tab, set the Generic type to Tear tape.
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3. On the Special rule tab, enter a value in the Width field.

 

 
4. Click Select Color to set the color of the tear tape.
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5. Click OK to return to Defaults. Save and exit Defaults normally.

Default line type set

When you first launch ArtiosCAD, cut and crease are the two line types available from the Line type
drop-down list box in the View bar. To change the available lines at startup, double-click the Default
Line Type Set entry in Design defaults. The Default Line Type Set dialog box will appear.
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To add a line type or special rule type to the default set available at startup, select it and click Add to
default set. To delete a line type or special rule type from the default set, select it in the Default Line
Type Set group and click Delete.

When you have finished modifying the Default Line Type Set, click OK to save your changes and return
to Defaults, or click Cancel to return to Defaults and discard your changes.

CAM Tooling Setup Catalog

The CAM Tooling Setup Catalog contains the configuration information for CAM output devices such as
Kongsberg DieSaws and lasers. Configuration information is separated onto three tabs in each Catalog
entry - Tool List, Tool Selection, and Optimization.
 

 

Tool List tab

The Tool List tab contains the configuration information for the tool type, width, depth (if applicable),
step height, overlap, lead hole (if applicable), and name of the tool. Each combination of tool, width,
and depth needs to be assigned to a different tooling line type. To use an expression to define the tool
width, select Use Expression.
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To set up the tool list, choose the tool number to modify and then set the tool type. Set the available
options and enter a name for the tool in the Name: field.

The table below explains the function of each tool type.

Table: Tool Types, Their Properties, And Intended Uses

Tool type Properties Description Intended uses

line none Uses the original lines;
performs no processing.

Drawing with a pen.

slot Width - effective width of the tool

Overlap - overlap between multiple
passes of the tool. Available when
Partial Depth is selected.

Makes a slot of a defined
width. Will envelope if the
slot width is wider than
the tool width.

Laser-cut slot for a
rule in a dieboard

drill Width - effective diameter of the
drill

Full Depth - Depth is the full depth
value, defined in the output

Partial Depth - Depth is defined in
the CAM setup

Drills a hole at a point
whose diameter is
defined by the width in
the CAD setup.

Mounting holes,
leader holes

any drill Full Depth - Depth is the full depth
value, defined in the output

Partial Depth - Depth is defined in
the CAM setup

Drills a hole at a point
whose diameter is
defined by the diameter
of the circle in the
workspace.

Mounting holes
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Tool type Properties Description Intended uses

counter drill Width - effective diameter of the
drill

Full Depth - Depth is the full depth
value, defined in the output

Partial Depth - Depth is defined in
the CAM setup

Drills a hole with a
counter sink drill, same
as the drill tool type,
but sends different
commands to the
Kongsberg driver.

Countersink holes.

mill Width - Effective diameter of the
tool.

Full depth - Depth is the full depth
value, defined in the output.

Partial depth - Depth is defined in
the CAM setup.

Include fill (off) - One pass inside or
outside the outline.

Include fill (on) - Multiple loops,
starting in the middle of a hole, and
working outwards

Step height - Amount by which the
tool penetrates into the material if
the tool requires multiple passes at
increasing depth to complete the
hole.

Mills inside or outside the
outline which is usually a
loop.

Holes in a dieboard
that are too
small to saw; the
dieboard alignment
notch.

saw Width - Effective width of the saw
blade

Lead hole - Which leader hole to
use.

Makes a slot of a
specified width, same
as the slot tool type, but
adds a leader hole.

Lines sawn on a
DieSaw.

Tool Processing and Offsets when Outputting
A combination of the Tool type in the CAM Tooling Setup and the line type category of lines in the
workspace determines how the lines are offset on Output. For example, a mill, saw, or slot tool will
be offset by half the tool width for inside-edge or outside-edge lines such as Dieboard edge or Lower
stripping hole. The same mill, saw, or slot tool will cut on a center-edge line (such as Unknifed diecut or
a rule such as Cut) without an offset.

Inside-edge and outside-edge line types are defined as the edge of a loop and do not have a slot width.
When output through a CAM Output, their offset is half the tool width in the CAM Tooling Setup. The
pointage property of inside- and outside-edge line types can be used for selection purposes but does
not affect the processing in a CAM Output.
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Table: Offsets when Outputting

Tool Type Line type Processing

Line All Unchanged

Slot or Saw Draw Unchanged

Inside edge Cuts path inside by half tool width

Outside edge Cuts path outside by half tool width

Center edge, fill off If width is less than slot width, cuts envelope, else
unchanged

Center edge, fill on If width is less than pointage or slot width,
multipass, else unchanged

If saw, adds leader holes as necessary.

Drill, any drill, or
countersink drill

All

Mill Draw Unchanged

Inside edge Cuts path inside by half tool width

Outside edge Cuts path outside by half tool width

Center edge, fill off If width less than slot width, cuts envelope, else
unchanged

Center Edge, fill on Series of loops starting in the middle and working
outward

Repeats with the next depth necessary depending on the step height

Tool Selection tab

The Tool Selection tab maps line types, pointages, and subtypes to tools on the output device. It is also
the place where the output priority is assigned. During output, a line is processed according to the first
selection in the list that matches the line's properties. When a line matches the selection criteria, it
is mapped to the specified CAM tool and then assigned to a group. Once a line has been mapped, the
process begins again with the next piece of line data; lines are processed by one selection and one
selection only. When all the data has been processed, the groups are internally optimized and output to
the machine in ascending order by group number. Lines that do not match any of the selections in the
list are processed using the (Remainder) selection, which usually are not output.
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In the example above, drawn lines, etch lines, and lines with subtype Countersink ID are output first
as they are in group 1. The Countersink ID lines are not actually created on the machine as they are
assigned to the Do not output tool. Once the group 1 lines are output, then the group 10 lines are
output, then 20, then 30, and so forth.

The Types, Subtypes, and Pointages buttons lead to dialog boxes where you can select exactly what
will be output in this selection. These dialog boxes are similar to those used for selections in plotting
styles.

Note:  The Text and dimensions checkbox in Types > Design only applies to text and
dimensions that have not had a color applied. Those with a color applied are considered
graphics and are not output to CAM devices.

By default, all items are turned on when you enter the dialog box for the first time. Click Invert
Selection to clear each checkbox. Clicking Select All selects all the items in the list. If you make
selections other than having all selected or having none selected, the base ArtiosCAD syntax is shown
in the field beneath the list. When you have finished selecting, click OK to return to the Setup dialog
box saving your changes or Cancel to return, ignoring your changes.
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The Slot Width button opens the Slot Width dialog box in which you can specify a minimum slot width
and a maximum slot width. Any line with a slot width between those values will be selected. #I or
#M is automatically appended to the slot width selection to allow for conversion between units of
measurement.
 

 

The up and down arrows to the side of the selection list move the selected entry either up or down in
the list depending on which button is clicked.

Insert adds a new entry above the current selection; Delete deletes the current selection. The
(Remainder) selection may not be deleted.
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The Tool number: field selects the CAM tool to map to the line selection. Entries for this drop-down list
come from the Tool List tab. The Size only tool is meant to be used for easier registration. Lines sent
to the Size only tool show in a preview and are used to calculate the output size, but are only actually
output when outputting to a layer.

The Width adjustment: field allows you to add to the slot width that is cut. Usually the slot width is
defined by the slot width of the rule if so defined or by the pointage of the rule. However, the preferred
way to adjust the slot width for laser output is to use a special rule with a defined slot width.

The Group number: defines which group the selected lines are put into. Group 1 is output first, then
group 2, group 3, and so on.

If the Separate bridge tool checkbox is checked, another line is added beneath the selection in the list
to allow the processing of bridges for that selection to be defined separately. This means that bridges
can be made with a different tool.
 

 

The Number of tools field allows for more than one tool to manufacture the lines selected by a
selection criteria line. Configure the extra lines as you would any of the other selection criteria lines.

Enter the desired name for the selection criteria line in the Name: field.

Note:  Wave rules with nick width of 0 are treated as cuts and processed by the GENTYPE 1 tool
selection.

Optimization tab

The Optimization tab controls the internal optimization of the groups of output. Optimizing is on for all
groups by default.
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To turn off optimization for a group, select it and clear the Optimize checkbox. To turn it on, select it
and check the Optimization checkbox.

Separate subroutine controls if each group will be in its own subroutine. If the box is checked, the
selected group is independent. If the box is clear, the selected group shares the same subroutine as
the previous group.

CAM Output of Rubber Sheets

A CAM Tooling Setup catalog entry should be set up for the following line types for output to (for
example) a waterjet rubber-cutting machine.

Table: Rubber CAM tooling setup

Line type Name Usage

Type 220 Rubber inside edge If using different logical tools for the inside edge and the
outside edge. Otherwise make them the same.

Type 221 Rubber outline

Type 222 Rubber name Cuts the numbers in the rubber pieces, if Show element
numbers is selected on the Processing page in the
Output.

Type 97 Usable limit of sheet If required, cuts the outline of the sheet area used.

Type 98 Sheet size Map to Size only to see the sheet size.

Shown below is an example CAM Tooling Setup catalog entry.
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CAM Output of Steel Counters

The CAM Tooling Setup Catalog entry for a steel counter output should list the widths and depths of the
available tools on the milling machine on the Tool List tab and select the counter line types on the Tool
Selection tab.

• With grain crease (type 100) and Cross grain crease (type 101)
• With grain crease and Cross grain crease with the different subtypes used for different depths
• Counter mill outline (type 110) for embossing and reverse crease
• Name tool (type 107)
• Positioning holes tool (type 108), Position holes tool 2 (type 111), and Counter slot (type 112)
• Periphery (for the frame) (type 103)

Do not output other line types such as cut/crease.

To output the counter channel as a single line, set the Tool type to mill, the Width to 10 mm (wider than
the channel), and Partial depth.
 

 

To fill the channel with multiple passes, set the Tool type to mill, the actual width of the tool, Partial
depth, Include fill, and a small Overlap of 0.1.
 

 

The milling path can be calculated either by ArtiosCAD or the milling machine. To output a mill area as a
single outline, set the Tool type to line.
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To output a mill area as being full of multiple passes, set the Tool type to mill, set a sensible Width,
Partial depth, Include fill, and a slight Overlap.
 

 

ArtiosCAD can output the same path with more than one tool. To add another tool, increment Number
of tools for this selection on the Tool Selection tab.

• To mill an interior area with one tool and mill its periphery with another, assign two milling tools with
different widths and the same depth.
 

 

• To add a finishing tool to the edge of the mill area, set the finishing tool to Tool type line to trace the
outside of the mill area.

Output sequence is controlled by the group number on the Tool Selection tab, with lower groups being
Output before higher groups. To have the periphery cut last, give it the highest group number.

Note:  ArtiosCAD mills areas with curved reverse creases and curved reverse cuts as if they
were straight lines.
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Specifying a rotary die in a press definition

When you first create a press, ArtiosCAD assumes it is flat by default. To specify a rotary dieboard
configuration, double-click the Rotary Shrink Stretch Factors entry in the parameter set for that
press.
 

 

In the Rotary Shrink Stretch Factors dialog box, check the Rotary Dieboard checkbox and fill in the
values for the Wood Thickness, Cylinder Diameter, Design to Wood Level Shrink, and Cylinder to
Wood Level Stretch fields with the proper values.

Once the fields are complete, click OK to return to Defaults or click Cancel to cancel.
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Changes to Rotary Die Press Defaults

Because of the Rotary Die Board tool, ArtiosCAD Defaults have changed slightly. In the Die Board
catalog for a given press in Die Press Parameter Sets, the Wood Dimensions tab has changed, In the
Press Defaults catalog, the Hole Patterns tab has changed.

On the Wood Dimensions tab, you can now set:
 

 

• Suggested sizes
• Offsets
• Allowances. These allowances may not be negative (which applies for flat dies as well). You can set

the bottom allowance, the minimum bottom allowance, and the minimum top allowance.

All values must be for the design level, not the cylinder or wood levels. These depend on the shrink
and stretch factors defined in the Rotary Shrink Stretch Factor catalog for the press definition in the
parameter set. If you change those factors, you must save Defaults before ArtiosCAD changes these
wood dimensions.

On the Hole Patterns tab, you can now set:
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• The radius of the area of effectiveness for mounting bolts
• The split distance and select tolerance for Die Symmetry when using the Rotary Die Board tool.

ArtiosCAD considers holes within the split distance from a split and within the select tolerance of
the originally selected hole to be symmetrical.

When you use Specify allowances on the Wood edge tab for a rotary die press definition in a die press
parameter set, the die board is not positioned by the machine reference point or centered on the
layout; it really uses the allowances. ArtiosCAD ignores the Centered dieboard option when you use
Specify Allowances.
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Hole Catalog

Holes are used in manufacturing to attach the boards to the presses. There are three types of holes:
General holes, Drill holes, and Oblong holes. As holes utilize subtypes, configure subtypes before
adding holes.
 

 

Adding a hole to the Hole Catalog

To add a hole, right-click Hole Catalog, and click New > Data from the context menu. Give the new hole
a name and double-click its entry to open its Properties dialog box. Edit the values as appropriate.
The Diameter Y field is available when the hole type is set to Oblong Hole. Counter Sink Diameter is
available only when the Counter Sink checkbox is checked. Set the Subtype fields as appropriate.
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Nicks

Nick formulas

Nick formulas are stored in the Nick Formulas Catalog. Sample entries are contained in the Artios
folder. The default nick formula is chosen in either the Manufacturing or Single Design parameter set.
Shown below is a Kongsberg nick formula.
 

 

The six placement buttons at the upper left of the tab set the default placement option for nicks when
the Add Nick tool is activated.

 Offset sets the nicks so that they offset from the nearest endpoint of the line or arc.

 Center places the nick in the center of a line or arc.

 Anywhere places the nick at the point you click.

 At the end of the line places the nick at the end of a line.

 Fill line fills the line or arc with evenly spaced nicks with Between sets setting the distance
between groups of nicks if the number is set to more than 1.

 Fill path fills a path with nicks as controlled in the Fill Path Options group.
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• Between sets sets the distance between sets of nicks.

• Split at corners keeps the nicks out of corners by the Corner offset distance. If a blend is larger
than the Minimum radius, ArtiosCAD considers it a corner.

• Avoid End Points keeps the nicks from being on the shared end-point of two lines.

The fields in the Nick sizes:, Offsets:, and Between nicks: columns set the values for the drop-down
list boxes when the Add Nick tool is activated.

The Number field sets the default number of nicks to add when the Add Nick tool is activated.

Set the default nick size to use by entering either an absolute value or a formula in the Default nick
size: field. If no default size is set, the Add Nick tool and the Bridging properties dialog box default to
the first defined size.

Nick styles

ArtiosCAD can represent nicks as a single line, a double line, a text label, a workspace you designate, a
centered line, a centered line with text, or as a parallel line along the nick. You can configure different
ways for nicks to be represented based on their size. Nick Styles are configured in the Nick Styles
Catalog. You can either modify the default nick styles in the Artios folder or you can create your own.

By default, a newly-created nick style has only one entry in it. This one entry defines how all nicks are
shown.
 

428



8ArtiosCAD

 

Insert and Delete add conditions for nick sizes. Select an entry in the list before clicking either.

The option buttons in the Nick Output Type group - Single line, Pair of lines, Text, Workspace,
Centered line with text, Centered line, and Parallel along nick - control the type of nick made.
Centered line and Parallel along nick are meant for outputting to a rule bender and display a mark
for half split nicks (where there is a nick straddling the intersection of two end-to-end lines). For the
Centered line styles, the line is a fixed length plus a multiple of the nick width.

The values in the Start and End fields set the length of the line(s) representing the nick. The value
in the Start field sets the distance between the line containing the nick and the start of the line
representing the nick. Use a negative offset to have the nick representation cross the design line.
The value in the End field sets the distance between the line containing the nick and the end of the
line representing the nick. The line(s) representing the nick are always drawn perpendicular to the line
containing the nick.

The Workspace name: field is available only when the Nick Output Type is set to Workspace. In this
field, enter the name of the workspace to use to indicate a nick, or use the Browse button (...) to
browse for the nick workspace. The workspace must have the center of the nick representation as the
origin of the workspace (where the two construction line axes meet). The line type used to draw the
nick workspace is ignored; the nick is drawn as a nick line type. Anything other than lines and arcs in
the nick workspace is ignored.

Add the size of the nick as text to the nick by using the Text nick output type in a selected Nick Style in
Defaults. Set the size of the text in the Text Size: drop-down list box, which is available only when the
Nick output type is set to Text.

When two nicks are close together, and the nicks are represented by workspaces, if the two
workspaces would overlap, the second nick is shown as a line.

When zooming in on nicks, the mark size and text size increase. If two nicks are closer together than
the width of the text or workspace label, the text or label is shown only once.

429



8 ArtiosCAD

When a text nick style is used in a CAM Output, the text for the nick size may be converted to lines
according to how text is handled by the Output. If the Line text option is selected, the nick size text
uses the same tool number as the nick line type.

To have ArtiosCAD display the nick sizes on a printed or plotted output, make a Nick Style of all
workspaces which are based on the nick size. In each workspace, enter the number, and then convert it
to lines using the Line Text tool.

Table: Nick Examples

Output Type Parameters Output

Single line Start = 0, End = 1/8

Single line Start = 1/32, End = 5/32

Single line Start = -1/8, End =1/8

Double lines Start = -1/8, End = 1/8

Workspace

Workspace: 

Workspace

Workspace: , Start = 1/16, End = 5/16

Workspace, with
two nicks close
together

Workspace: , Start = 1/16, End = 5/16

Workspace

Workspace: 
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Output Type Parameters Output

Text Text size in points

When you have finished modifying the nick style, click OK to return to Defaults keeping your changes,
or click Cancel to return to Defaults ignoring your changes.

Standard Sheet Layout

Parameters and standard sheet sizes for Standard Sheet Layout are configured in the Sheet Utilization
catalog in Defaults.
 

 

Sheet Layout Parameters

Double-click Sheet Layout Parameters to set the defaults for the trim, gutters, nest types, and other
options to use in Standard Sheet Layout as shown below.
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In the Trim group, the fields set the trim tolerances at the edge of the sheet. Set them to be less than
the maximum values for the presses used to produce the layout.

Use gutters inserts gutters between designs in the nest when it is checked. When it is clear, the single
designs touch. The values in the X and Y fields set the gutters in X and Y for the first and second rows
and columns of single designs in the layout. The values in the X2 and Y2 drop-down list boxes set the
gutters between the second and third rows and columns. These are repeated as appropriate between
all the rows and columns in the layout.

In the Nest type group, the checkboxes control the kinds of nests made automatically. Select the
checkboxes next to the type of nests to use; clear those next to undesired nests.

Touch bleed outlines controls whether the designs touch using the bleed outlines or the edges of the
designs. If Use gutters is enabled in conjunction with Touch bleed outlines, the gutters are inserted
between the bleed outlines instead of the edges of the designs.

In the Design options group, Allow 90 degree rotation lets designs rotate so they are cross-grain;
the sheet grain runs in the longer direction. Maximum allowable reduction is the maximum distance
that could be shaved off each design in order for another row or column to fit on the sheet. If such a
cutback is possible in each design, a row or column will overlap the edge of the sheet when a layout is
suggested and there will be values in the various Reduction fields of the Sheet Layout Results dialog
box.
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Click OK to save the changes, or click Cancel to ignore them and return to Defaults.

Standard Sheet Sizes

Double-click Standard Sheet Sizes to configure the defaults for standard sheets used by Standard
Sheet Layout.
 

 

To use a sheet for possible layout solutions, check its box in the Use column. To disable its use, clear
the checkbox. To toggle the usage of all sheets at once, click All on/off.

The arrows on the side of the dialog box move the currently-selected sheet up and down in the list of
sheets. The order of sheets on this tab is the same order used to present layout results.

To edit a sheet, select it, and change the fields in the Edit Sheet Properties group. The fields change
as soon as you click another field

To add a sheet, click Insert, and then edit the fields in the Edit Sheet Properties group. Set the
checkbox in the Use column as desired.

To delete a sheet, select it, and click Delete.

To save the changes to the standard sheets, click OK. To discard the changes and return to Defaults,
click Cancel.
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Configuring Intelligent Layout defaults and Costing/
Estimating

In order to work optimally, Intelligent Layout and Costing/ Estimating must have their defaults
configured accurately. These defaults should match the real-life manufacturing conditions used to
make the containers.

Configuring cost centers

Costing/Estimating uses the general concept of a cost center to allow costs to be configured. A cost
center represents a machine such as a printing press, die press or folder-gluer, and/or a material
cost such as gold stamping or shipping. Machine costs are calculated per hour and material costs are
calculated per sheet or per carton. ArtiosCAD supplies some example cost centers in Intelligent Layout
Defaults, and you are expected to modify these and add your own cost centers to suit your needs.

To view or edit cost centers, do the following.

1. Start ArtiosCAD.
2. Click Options and Defaults to open the Defaults dialog box.
3. Click the plus sign next to Intelligent Layout defaults to view its contents.
4. Double-click  Cost centers. The first cost center will be selected by default.

 

 

The groups and options shown depend on the option button selected in the Cost specification
method group.

5. Make the desired changes and then click OK to save them or Cancel to ignore them.

The items in the Cost center dialog are explained in the following list:
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Table: Cost Center Dialog Box

Item Explanation

List of cost centers The list of cost centers must be arranged in the order they are used. The
output of one cost center is the input to the next. When the checkbox is
off, the cost center is an option, available to be selected but is not turned
on by default.

Up arrow, down arrow Moves the selected cost center up or down in the list

Name Changes the name of the selected cost center

Insert Inserts a new cost center above the selected one.

Delete Deletes the selected cost center

Per sheet The cost center applies to sheets, for example a sheeter.

Printing press Works the same as a sheet cost center, but identifies the printing press
cost center to be reported separately.

Die press Works the same as a sheet cost center, but identifies the die press cost
center to be reported separately.

Per design Cost center such as a folder-gluer, where make ready is needed for each
different design, and a smaller make ready is needed for a different print
item of the same design.

Per print item Cost center such as windowing, if the windows were different on each
print item. There is a separate make ready for each print item.

Use prompted variable Only if a variable is to be associated with this cost center. For example
FGD = folder-gluer degree of diculty, or NCOL2 = number of colors for
a second printing press, see note. The variable is added to the Prompted
Variables tab of the Quantities and Costs dialog if this cost center is
included.

Prompt Prompt/description of this variable

Variable name Name of the prompted variable to be used in expressions. A prompted
variable can be used in expressions such as make ready and speed, inside
the PVAR function. For example, the make ready time of the printing press
is defined to be 1+PVAR(NCOLOR)/2, that is, 1 hour plus 1/2 hour for each
color. The name of the variable can use up to 6 letters and digits and must
start with a letter.

Default value Default value of the prompted variable

Make ready time Expression for the make ready time in hours
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Item Explanation

Sheets/hour The normal speed of the machine when it has reached its optimal speed.

The theory is that the machine runs for a while at a slower speed for the
first few sheets while it is brought into alignment, and then the speed is
increased to its optimal speed. For a multi-step ramp up in speed, use the
SPEEDSTEP function.

Run waste % The percent waste while running. A machine such as a printing press may
periodically go out of alignment and waste some sheets.

Cost/hour Cost of the machine per hour while running. Does not include the cost of
the machine during make ready, which is separate.

Cost/sheet Additional material cost per sheet apart from the board cost. If the cost
specification method is per print item, this label changes to Cost/carton,
for example the cost of a window in each carton.

Opens an expression configuration dialog box. See the following section.

Changing Cost Center expressions

Clicking the f(x) button in a cost center expression leads to an expression configuration dialog box. For
example, clicking f(x) for the Make ready time expression:

(STEP(#NCOLOR,1,2,1.25,3,1.5,4,1.75,5,2.25,6, 2.75,7,3,8,3.5))

leads to:
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This dialog box lets you choose how the value for the selected field is determined - by a table of
conditions or by an expression; in this example, the method is set to table. Only when the method is set
to table is there a Table tab in the dialog box.

To set the value using an expression, select the Expression option and type the expression in the field.
Click the f(x) button to access the Edit Expression dialog box.

Creating a table to set the value
When configuring a cost center expression, you can create a table of values to use when certain
conditions are met. In the picture below, the make-ready time is determined by the number of one-ups
and the board caliper.
 

 

The One parameter and Two parameters option buttons control how many conditions must be met
when setting a value. When One parameter is selected, everything relating to columns is unavailable;
you may only add and delete rows.

The Row parameter and Column parameter drop-down list boxes set what is being used to determine
the conditions of the table. You may type expressions of your own choosing in this box. If ArtiosCAD
recognizes the expression (CAL, for example), it translates the expression to its text equivalent (“Board
caliper”).

Add row, Add column, Delete row, and Delete Column do what they say. There can be up to 18 rows and
14 columns. If the cursor is in any of the edit boxes, Delete row deletes that row; otherwise the bottom
row is deleted. Delete Column deletes the column the cursor is in; otherwise, it deletes the rightmost
column.
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The f(x) button for the Sheets/hour field leads to an expression configuration dialog box which has
three entries which behave exactly as those described above.

Modifiers for cost center expressions

A modifier allows adjustments to be made to an expression in certain situations. For example, a
modifier could use this logic: if the caliper is 0.016” or less, add 10%. Modifiers can do the following to
the output of the expression:

• Add a percentage

• Subtract a percentage

• Add a value

• Subtract a value

• Multiply by a value

• Divide by a value

• Set a minimum value

• Set a maximum value

To add a modifier to a cost center expression, do the following:

1. Click the f(x) button for that expression and then click the Modifiers tab.
 

 
2. Click Add to add a modifier. A list of modifiers appears:
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3. Choose a modifier to add to the expression (for this example, choose Large caliper) and click OK.

ArtiosCAD will return to the Modifiers dialog box.
 

 
4. Click Edit to open the Edit Modifier dialog box.
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The option buttons in the Condition type group let you quickly change the condition with a single
mouse click. If you select No condition, the Limit value and Condition fields are unavailable.
Changing the condition type option button automatically updates the expression in the Condition
field. The Condition type and the Limit value combine into the Condition.

The option buttons in the Modification group determine the operation of the modifier. The amount
of the modification is set in the Modification value field.

5. Click OK to accept the changes to the modifier or Cancel to ignore them. ArtiosCAD will return to
the expression configuration dialog box.

Notes on Intelligent Layout Defaults

Most defaults have the option of User defaults overriding Shared defaults. This does not work well
for Intelligent Layout because the cost centers from Shared Defaults and User Defaults are mixed
together. We recommend that you only use Shared Defaults for Intelligent Layout.

The order of the cost centers is important. The Per design and Per print item cost centers must be
after the printing press and the die press.

If you set up a cost center with a prompted variable that has a default value, for example a printing
press with 2 colors, and then want to run a layout with three colors, your first impulse might be to
double-pass the sheet and use the cost center twice. This approach, however, will result in 4 colors
being used in the calculations. Make sure to set up a cost center with prompted variables that have
defaults specific for each case you may encounter.

Overview: Setting up a multi-color printing press cost center using a table

The following overview illustrates how to set up a cost center containing variable information. We are
going to set up the following information:

Number of colors 2 3 4 5 6 7 8

Make ready time in hours 1.5 1.75 2.0 2.5 2.75 3.5 4.0

Note that you must enter time in hours, not hours:minutes. For example, 2 hours 45 minutes is
represented as 2.75 hours.

1. Start ArtiosCAD.
2. Click Options and then click Defaults to open the Defaults dialog box.
3. Click the plus sign next to Intelligent Layout defaults to view its contents.
4. Double-click Cost centers. The first cost center will be selected by default.
5. Click Insert to create a new cost center called New cost center.
6. Change the name in the Name: field from New cost center to My 8 color press.
7. Set the Cost specification method to Printing press.

The Intelligent Layout Defaults dialog should look as follows:
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8. Click f(x) at the end of the Make ready time: field to set up a table of conditions for the number of

colors. The expression configuration dialog box appears:
 

 
9. Click the Table option button in the Make ready time group.
10. Click the Table tab.

 

 
11. Select One parameter and choose Number of colors for the Row parameter.
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12. Enter 2 and 1.5 in the first and second fields, respectively, under Number of colors. ArtiosCAD will
change the 1.5 into 1+1/2.

13. Click Add row. Enter 3 and 1.75 in the first and second fields of the new row.
14. Repeat for the rest of the values in the table.
15. When the table is complete it should look like this:

 

 
16. Click OK to finish configuring the table for the make ready time, and proceed to configuring the rest

of the cost center.

Useful Functions for Cost Center Expressions

STEP(variable, value1, limit1, value2, limit2,..., limitn, valuen)

Returns value1 when variable < limit1

value2 when limit1 <= variable < limit2

value3 when limit2 <= variable < limit3

...

valuen when limitn <= variable

The STEP function and all its variations must have an even number of parameters, at least 4.
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Note that we would not recommend that a step function be used for the speed of a machine because
the run time of a machine using a step function like this would have discontinuities in its run time:
 

 

STEPUP(variable, value1, limit1, value2, limit2, ... , limitn, valuen)

Same as STEP except < and <= are reversed:

Returns: value1 when variable <= limit1

value2 when limit1 < variable <= limit2

...

valuen when limitn < variable

LINESTEP(variable, value1, limit1, value2, limit2, ..., limitn, valuen)

As a more sensible alternative to the STEP function for the speed of a machine, this function does a
linear interpolation between data points, and avoids the discontinuities in the STEP function.

Returns: value1 when variable <= limit1

Interpolation between value1 and value2 when limit1 <= variable <= limit2

Interpolation between value2 and value3 when limit2 <= variable <= limit3

...

valuen when variable >= limitn
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Note that to prevent a discontinuity at the last limit, the last two values should be the same, or the last
value might be an expression.

SPEEDSTEP(#RUN,speed1,run1,speed2,run2, ..., runn, speedn)

The SPEEDSTEP function is an alternative for the speed of a machine (depends on how the speed
is specified). The machine runs at speed1 for the first run1 sheets, runs at speed speed2 up to a run
length of run2, and so on, and runs at speed speedn after the run length reaches runn. The function
returns an average speed of the machine given the run length.

List of functions for configuring cost centers

This list of functions is accessible from the Cost Centers dialog box by clicking f(x) and then Insert
Library Function.

Table: Functions for configuring cost centers

Function Description

#SHTSIZEX Sheet size X, current units (inches or mm).

#SHTSIZEY Sheet size Y, current units (inches or mm).

#SHTSIZEWG Sheet size with grain, current units (inches or mm).

#SHTSIZEXG Sheet size cross grain, current units (inches or mm).

#CUTSIZEX Knife-to-knife X of designs in the layout, in current units (inches or
mm).

#CUTSIZEY Knife-to-knife Y of designs in the layout, in current units (inches or
mm).

#MANSIZEX Design blank size X (manufacturing lines), in current units (inches or
mm) of the current design. If sheet cost center, of the first design.

#MANSIZEY Design blank size Y (manufacturing lines), in current units (inches or
mm) of the current design. If sheet cost center, of the first design.

#MANSIZEWG Design blank size with grain (manufacturing lines), in current units of
the current design. If sheet cost center, of the first design.

#MANSIZEXG Design blank size cross grain (manufacturing lines), in current units of
the current design. If sheet cost center, of the first design.

#AREA Area of design ignoring holes (zero if area fails) in current units
(square inches or square mm) of the current design. If sheet cost
center, of the first design.
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Function Description

#AREAH Area of design minus holes (zero if area fails) in current units (square
inches or square mm) of the current design. If sheet cost center, of
the first design.

#AREAN Area of design plus nicked holes

#AREANH Weight of just nicked holes

#RUN (In the Intelligent Layout Parameters dialog). Run length for this cost
center/item in number of sheets or number of cartons.

(In a form or OCX control). Run length of the first cost center, usually
the printing press.

#NUPD (Design, item cost center) How many of this design on the sheet
(Sheet cost center) 0

#NUPP (Item cost center) How many of this print item on the sheet (Sheet or
design cost center) 0

#NUP Total number of designs on the sheet

#MKRT Make ready time for this cost center/item

#MKRTA (Design cost center) Make ready time for this cost center/item for
additional items.

(Sheet or item cost center) 0.

#BRDWTG Board weight grams/square meter.

#BRDWTLBS Board weight lbs/1000 square feet

#BRDCSTM Board cost/1000 square meters

#BRDCSTFT Board cost/1000 square feet

#BRDCSTKG Board cost per kg.

#BRDCSTLBS Board cost per lb.

#WEIGHTKG Weight of one item (board only) in kg.

#WEIGHTLBS Weight of one item (board only) in lbs.

#ITEMORD (Item cost center) Ordered quantity of this item.

(Sheet cost center) Ordered quantity of the first item.

(Design cost center) 0.
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Function Description

RULELEN(“TYPE 1”) (Design or Item cost center) Length of cuts in the design.

(Sheet cost center or die cost) Length of cuts in the layout. Typically
used in estimation of die cost. This calculation is context dependent
for item cost centers. Note that it ignores double knife removal and
stripping rules, because they have not been defined yet.

RULELEN(“TYPE 2”) Length of creases in the layout. Also supports more general selection
such as RULELEN(“TYPE 1,3 RAD ..1/8”)

PVAR(varname) Value of prompted variable, e.g. PVAR(NCOLOR) or PVAR(CRW). Actual
variable is CCEN.NCOLOR (per sheet) or CCEN.D[i].CRW (per design)
or CCEN.P[i].MYVAR (per print item)

DESVAR(varname) (Design or item cost center) Value of variable from design, e.g.
DESVAR(L)

(Sheet cost center) Value of variable from the first design. (If variable
does not exist) 0

#NCOLOR Number of colors for the printing press set in the Ink Coverage page.

#LBSKG Number of pounds in a kilogram = 0.45359237

#KGSSTON Number of kilograms in a short ton = 907.18474

#KGSLTON Number of kilograms in a long ton = 1016.0469088

#SQMSQFT Number of square meters in a square foot = 0.09290304

#LBSFTG Number of (lbs/1000 sq. ft) in (g/sq. m) = 4.882427636383

Example Folder-Gluer Formula

To calculate the speed of a folder-gluer machine, suppose the belts on the machine run at 240,000
inches per hour. The cartons are carried through the folder-gluer side-by-side with a 1/2-inch
gap between them. The blank size of a carton is given by the function #MANSIZEX and 1/2 inch is
represented by #I/2, so the step distance between cartons is #MANSIZEX+#I/2. Dividing the speed of
the belts by the step distance gives a speed (in cartons per hour) of:

240000*#I/(#MANSIZEX+#I/2)

However, suppose some cartons are more dicult to fold up and the machine has to run slower for
these. Let us introduce a compensation factor in a prompted variable Folder diculty which has
values:

1 = Easy, Full speed 240000 inches/hour

2 = Moderate, Moderate speed 200000 inches/hour
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3 = Hard, Slow speed 160000 inches/hour

To allow for this, the modified formula uses a step function of the Folder diculty variable FGD (Folder
Gluer Diculty):

STEP(PVAR(FGD),240000,2,200000,3,160000)*#I/(#MANSIZEX+#I/2)

To use this, the estimator should enter the “Folder diculty” for each design along with the number of
colors for the job in the Prompted Variables tab in the Quantities and Costs dialog box:
 

 

Run Length Calculation

The costing model used in ArtiosCAD has a list of cost centers in the order that the cartons are
processed through the plant. Once the sheet has been processed in the die press, you no longer have
sheets, and the remaining cost centers process print items (=cartons). Therefore, the sheet cost
centers (printing press and die press) come before all the item cost centers (e.g. windowing, folder-
gluer, shipping). Between the last sheet cost center (the die press), and the first item cost center, the
sheet is divided up into print items depending on the number up of each item.

For the run length calculation, each cost center has an attribute of the number of sheets or cartons
used in make ready, and a run-time waste percentage. For example, suppose you start with 100000
sheets, and the printing press uses 5000 for make ready, and has a run time waste of 4%, because it
periodically goes out of registration. Then the run length of the printing press is 100000-5000 = 95000,
but because of the run-time waste the output from the printing press that is available for the next cost
center is 96% of this, which equals 91200.

For each cost center in the list, the input to this cost center (= make ready + run length) is equal to the
output of the previous cost center. When you enter ordered quantities, the calculation starts with the
required delivered quantity which is the output from the last cost center, and works backwards, adding
the run-time waste and make ready for each cost center, to come up with the number of sheets you
need to start with.
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To illustrate the run length calculation in Intelligent Layout, suppose you have ordered quantities
100000 of A and 200000 of B, and the sheet has 5 up of A and 8 up of B. The first thing we see is that
with these proportions, we are going to get a larger overrun of A than of B. Suppose there was no make
ready waste. There would be a run length of 12500 giving the required 200000 (100%) of B but 125000
(125%) of A. Therefore, for the run length calculation, we can ignore A with the larger overrun, and
calculate the run length needed for B.

In our simple example, there are 3 cost centers:

Cost Center Name Make Ready Run Time Waste %

Printing Press 5000 sheets 4%

Die Press 3000 sheets 2%

Folder-gluer 500 cartons 0%

This can be represented in a diagram as follows:
 

 

Working backwards, the delivered quantity of B is 200000. This is the output from the folder-gluer. The
folder-gluer needs 500 cartons make ready, so the input to the folder-gluer is:

run length = 200000, make ready = 500, total = 200500

There are 8 of B on the sheet, so

Die Press output = 200500/8 = (rounded up) 25063.

To allow for the 2% run time waste, the input to the Die Press is:

run length = 25063 * 100 / (100-2) = 25564, make ready = 3000, total = 28564

To allow for the 4% run time waste, the input to the Printing Press is:

run length = 28564 * 100 / (100-4) = 29754, make ready = 5000, total = 34754
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Therefore, the total number of sheets needed for this job is 34754.

Print Items and Folder-Gluer Make Ready

If you have several print items of the same design, you only need to set up the folder-gluer for the first
item. The make ready for subsequent items is just the time needed to move them with the forklift
and restart the machine. However, which is the “first item”? If the run lengths of the print items are
different, Intelligent Layout picks the item with the largest overrun, and assumes that this is the “first
item” you will use to set up the folder-gluer.

Configuring Outputs

ArtiosCAD provides many ways to configure Outputs to get the results your company’s workflow
requires.
 

449



8 ArtiosCAD

 

The tabs shown on an Output properties dialog box depend on the selection in the Output Type group.
For example, in the picture above, there is no Reports tab, but if you set the Output Type to Plot, the
samplemaking-related tabs disappear and the Report tab appears.

Note:  Do not use a backward slash ( \ ) in any Output name.
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Note:

There are many sample Outputs in the Example Defaults catalog, accessed by clicking one of
the panes in Defaults, then clicking File > Open > Example Defaults. For example, to see how to
configure ArtiosCAD to make a sample with Re-board

®
, you could look at the Kongsberg XL44 -

V-notch sample cutting entry under Outputs > Artios > Kongsberg XL44 - Corrugated.

 Output Type tab

Output Type group
The choice in the Output Type group of the Output Type page determines which other tabs are
available. In the above example, because the Output Type is set to Sample, there are tabs in the dialog
box which only appear for samples.
 

 

When the Output Type is set to Plot, the tabs which appear only for plots become visible.
 

 

The selection in the Output Type group also determines what will be on the Output Type page itself. For
example, when the Output Type is set to Grouped Output, the Scale group disappears from the page.

Show In group
The Show In group determines how this Output will be used. At least one of these choices must be
selected.
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The Export menu is meant to be used to group commonly-used file exports together.

The Send menu is meant to be used to group together those Outputs which will be emailed.

A Multiple Workspace Output lets the same Output be used on a group of workspaces both in
ArtiosCAD and in the Database browsers.

3D enables you to run this Output from a 3D workspace.

Project-Bill of Materials lets you run this Output iteratively for all objects on a BOM.

Parts Outputs causes this Output to appear on the Parts Outputs menu in a canvas. If you are using
ArtiosCAD Enterprise, make sure to select this and Browser to be able to run this Output from a
canvas.

Browser is available only for ArtiosCAD Enterprise and lets you run this Output by right-clicking in the
browser.

When the WebCenter checkbox is checked, this Output can be used for downloading files from
WebCenter. This is meant only for file outputs such as DDES, DXF, and EPSF. Outputs for WebCenter
must have unique names; there may not be an Output used with WebCenter with the same name in
both Shared Defaults and User Defaults.

Scale group
The options in the Scale group determine the size of the output.
 

 

To fit one page modifies the size of the output so that it fits on one page.

Specify lets you set the size of the output. Setting a scale of one makes a full-sized output. Tiles, which
are individual sections of the design, are printed if necessary.
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Differential Scale makes the Vertical Scale field appear and changes the Scale field to Horizontal
Scale. You may use variables in these fields if you regularly want to make shrink sleeves or other types
of graphic output that need different scales.

Depending on the type of Output this is, you can set the scale when running the Output. If you set the
scale to something other than 1 and the Output creates a workspace, rebuild is not available for that
resulting workspace.

Preview control group
The options in the Preview Control group control how and if the Output Preview dialog box appears
when running the Output.
 

 

Auto Preview, when checked, causes the Output Preview dialog box to automatically open when
running the Output. The options in the Layout Type and Window Size groups determine how the
contents of the dialog box are shown. Shown below is the Output Preview dialog box.
 

 

Device tab

The Device tab lets you specify the hardware device (if applicable) to which the Output will be sent.
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When entering this tab for the first time, you may see a dialog box informing you that ArtiosCAD was
unable to find a certain printer. Ignore this and click OK to proceed.

In the Driver Type group, the Windows Driver option instructs ArtiosCAD to send the output
information to the operating system mechanism of driving the device. The CAM Driver option instructs
ArtiosCAD to use its internal methods to drive the device. The selected option in this group determines
how the rest of the tab looks. Bitmap creates a picture file of the output. Workspace Layer creates a
new layer in the workspace and draws the output data in that.

Note:  When outputting to a layer, you must re-perform the Output after each rebuild to
maintain correct information in the layer.

Out to file sends the output data to a disc file instead of physically out to a device through a port or
network connection. Some devices such as samplemakers make a network connection to the CAD
workstation and pick up the file automatically.

Number of copies allows you to set the default number of copies made when performing this Output.

The value selected in the High graphics memory use drop-down list box determines how much
memory ArtiosCAD uses when outputting a bitmap image (typically a referenced PDF file when the PDF
option has been purchased). This option is available only for Outputs of type Windows Driver or Bitmap.

A bitmap may have a maximum of 15 million pixels. The size of the bitmap is calculated dynamically
during the output; system performance may be affected if a large bitmap is required. You can set the
maximum number of pixels for the Output to use to balance system speed and output resolution.There
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are four choices: High graphics mode off, Upto 5 million pixels, Upto 10 million pixels, and Upto 15
million pixels. The fewer the number of pixels used, the coarser the resolution of the output.

Windows driver
When Windows Driver is selected, there is a drop-down list box allowing you to choose the device that
will perform the output. Devices must be set up in the operating system beforehand for ArtiosCAD
to list them here. You can also choose the orientation of the output on the page by choosing the
appropriate choice in the Orientation group: Portrait, which makes the long side of the paper the
vertical axis, Landscape, which makes the long side of the paper the horizontal axis, or Optimum,
which sets the orientation based on which one can output at the largest scale.

You can also set the High graphics memory use when using a Windows driver.

CAM driver
When CAM driver is selected, the Output Device group changes to look similar to the following picture,
except no data will be shown in the various fields:
 

 

The Tuning Entry field indicates the type of device receiving the output data from ArtiosCAD. CAM
driver specifies the internal ArtiosCAD method for creating the data. Tuning Filename lets you choose
the configuration file for the device. CAM Device Name lets you set the Output Destination for the data
if it is not going out to file. Refer to the Peripherals chapter for more information about installing CAM
devices.
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Bitmap outputs
The Bitmap driver type lets ArtiosCAD output a bitmap picture of a workspace.
 

 

The option buttons in the Bitmap Format group set the type of bitmap created. JPEG output (Joint
Photographic Experts Group) makes compressed pictures for ecient use in other programs, but
some color information is lost. PNG output (Portable Network Graphic) is used for vector graphics (lines
and arcs) shown on the World Wide Web. TIFF output (Tagged Image File Format) is uncompressed
and is useful for other graphic programs such as Adobe Photoshop. Note, however, that TIFF files are
usually quite large.

The Shrink size to remove white space checkbox, when checked, causes ArtiosCAD to crop the extra
white space around the perimeter of the design upon Output.

The JPEG Quality field adjusts the quality and the file size of the resulting JPG file. A value of 0 makes
the smallest file with the worst quality, while a value of 100 makes the largest file with the best quality.
ArtiosCAD defaults to 70. Set the value in this field between 80 and 90 if you will be making Animations
in 3D. This field is available only when the Bitmap Format is set to JPEG.

High graphics memory use determines how much memory ArtiosCAD uses to render PDF graphics
being processed by the Output.

Getting bitmap outputs just right can take some experimentation.
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Output to layer
Workspace Layer writes the results of an Output to a layer in a design.
 

 

For example, you could define a Report output to go to a layer, and send the resulting file to a customer.
The customer could then use the ArtiosCAD Viewer to view both the design and your report.

The Automatically overwrite checkbox controls whether the layer will be overwritten each time the
Output is performed. If the checkbox is cleared, a number will be appended to the layer name in a
sequential fashion.

Note:  When outputting to a layer, you must re-perform the Output after each rebuild. When a
design is rebuilt, the layer that was output to is automatically deleted as the information that
was in it does not reflect the current state of the workspace.

Output to layer turns on that layer if it was not visible before the Output.

Output to layer honors locked layers.

Outputs using high graphics mode
Outputs that support bitmaps can use high graphics mode. These must be actual Outputs, as opposed
to using the Print command on the File menu.

A bitmap may have a maximum of 15 million pixels. The size of the bitmap is calculated dynamically
during the output; system performance may be affected if a large bitmap is required. You can set
the maximum number of pixels for the Output to use to balance system speed and output resolution.
The pixel usage is configured in the High graphics memory usage drop-down list box in the Output
method’s settings in Defaults, or may be configured each time in the Properties dialog box. There are
four choices: High graphics mode off, Upto 5 million pixels, Upto 10 million pixels, and Upto 15 million
pixels. The fewer the number of pixels used, the coarser the resolution of the output.

The memory usage for high graphics mode when using a 3D Output is fixed at 15 million pixels.

Shown below is the Properties dialog box for a Kongsberg CM1930 samplemaker with the Illustrator 2
printing head:
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Shown below is the Plot to Printer dialog box.
 

 

Position tab

The settings on the Position tab indicate the physical placement of the output on the output medium.
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Device Size and Margin groups
The fields in the Device Size group let you set the size of the device (if you are using a CAM driver;
otherwise, the size fields are unavailable) and the starting position as measured from the bottom left
corner of the medium.

The settings in the Margin group set the distance between the edge of the medium and the physical
area that can be printed by the device. When you set the device size to 0 (for unlimited size), you can
still set the margins.

Orientation and Position groups
The commands in the Orientation group let you specify the relative position of the output on the
device.

The options in the Position group control the point to which the output is snapped on the device and
the side of the design which is output. The nine buttons snap the design to their respective location on
the page - top left corner, top center, top right corner, right center, bottom right corner, bottom center,
bottom left corner, left center, and center.

The Side Up list box lets you choose which side of the design is output: the Inside, Outside, Die Knife
side, Die back side, or the default side, which is the current side of the design.

Reports tab

The Reports tab lets you specify a report to output using the data in the design. Check the Use Report
checkbox and choose the report to use.
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If the desired Report is not in the Reports Catalog, use the Specify button to browse for it.

Directories tab

The Directories tab lets you specify if the output data is written to a disc file instead of going to
the physical device. The Out to file checkbox on the Device tab must be checked in order for these
options to work. The contents of this dialog box will vary depending on what Output type is selected
on the Output Type tab. The examples shown below are for plots. If the Output Type were set to
Sample output, there would be many more fields for the different kinds of files that sample output can
generate.
 

 

Make DOS Compatible truncates the filename so that it conforms to the 8.3 file-naming convention
used in MS-DOS. When this checkbox is checked, the Strip front and Strip back option buttons
become available. These control which part of the filename is stripped off to make it eight characters.

Automatically Overwrite controls if you are prompted to overwrite (delete) an old output file with
the same name as the output file you will create when performing the output. This option is usually
checked by default in pre-defined Outputs that create files. If this option is checked for an Output that
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is added to a Grouped Output, the current filename with the default extension is used. The current
directory is also used; you are not prompted to select a directory, You might have to search for the file
created by the Output as it may not be where you expect it. Use this option with care.

Automatically Open opens the file in the associated Windows application after being output. For
example, if you output a .txt file, Windows would recognize it as a Notepad document and open it in
Notepad.

File groups
The names and amount of data fields in this dialog box depends on the type of Output selected on the
Output Type tab. When the Output type is set to plot, for example, there is one file group, Plot File, but
when the Output type is set to Sample, there are four file groups - Make Counter File, Partial Cuts File,
Make Sample File, and Print Sample File. In each group, however, the fields and checkboxes are all the
same and work the same.

The Extension field lets you use the same filename extension, which is the part of the file name which
follows the last period, each time this Output is performed. By default, the filename is the same as the
workspace name. Leave this field blank to specify an extension when creating an output file.

The Directory field lets you type the location of the directory in which to store the output file. Use the
ellipsis button to browse for a directory.
 

 

The Fixed filename checkbox lets you specify the same filename for all files created using this Output.
When this checkbox is on, and the directory specified in the Directory field is valid, the filename
selection dialog box is suppressed.
 

 

From command file indicates that the filename is generated by a command file. When this option is
checked, the output file name will be the result of executing the function TLIBRARY(GenSName.txt).
Since Fixed Filename is not checked, the resulting filename is the default filename when the output is
run.
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View tab

The options on the View tab of the Output dialog box control how the layers and line types are output.
 

 

Style Selection group
Specify Plotting Style overrides the plotting style at time of output with the plotting style specified
in the Available Plotting Styles drop-down list box. The list box is available only when this option is
checked. Checking Rule labels turns on rule labels for this Output.
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Dimension Position group
Auto-adjust overlapping text prevents rogue text items from being printed on top of each other. You
can specify the range of text sizes to consider when ArtiosCAD looks for overlapping text by entering
point values in the Minimum text size and Maximum text size fields.

The Remove extension lines checkbox controls whether extension lines are removed if text has to be
moved to make it not overlap.

Override Dimension Format group
The options in the Override Dimension Format group allow you to override the workspace settings for
the dimension format with those that you choose in this group. Set them as desired.

View Selection group
The options in the View Selection group control which layers are output when running the output.
 

 

Current zoomed in view Outputs the objects in the current zoomed in area. In this case the Layer set
selection is set to Current View and the Available Layers list is unavailable.

Current selection uses the currently selected items as the Output. All non-selected items are ignored.
If no items are selected, the Output defaults to the Current View Layer set selection.

The Use selection for report calculations checkbox is only available with Current selection and is only
applicable if the Output uses a Report. This option forces the calculated text commands in the Report
to be evaluated against a temporary document which contains a copy of the selected item.

Choose the layer to output from the Layer Set Selection drop-down list box.
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Choosing a layer set from the drop-down list box toggles different layers in the Available Layers group.
Select or deselect layers as desired. To choose specific layers without starting from a preconfigured
layer set, select the User Defined layer set, and then select layers as desired.

Note:  Do not select both the Designs layer and Rule Path layer for any Output.

The options in the Rotary Diemaking View Level group control how the size of the Output is
manipulated when the Layer Set Selection is set to Dieboard. Design Level, Wood Level, and Cylinder
Level apply the appropriate shrink or stretch factors to the output data so that the output is sized
correctly.

 Processing tab

The commands on the Processing tab control how the data is manipulated between when you click
Output and when the data arrives at the output device or disc file.
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Note:  The options on the Processing tab depend on the type of output chosen on the Output
Type tab. Different outputs have different options.

 The Browse button at the end of the CAM Tooling Setup field lets you choose the CAM Tooling
Setup to use in this Output. The CAM Tooling Setup maps which line types are mapped to which
physical tools on the output device. Click it to choose an entry from the Select Cam Tooling dialog box.

Optimization options group
Depending on the Output Type chosen, items in this group may be unavailable.
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No optimization makes no changes to the output data.

Plotter Pen Optimization examines each 100 lines of output code, groups together lines made with the
same pen, outputs them, and then examines the next 100 lines.

Enable subroutined output means support subroutines in the NC (numeric control) output, which only
works with the PUNCH command and certain SAVE commands. Turning this checkbox off combines all
elements of the design or manufacturing file into one set of data on output.

Enable subroutined output also works and should normally be checked for CFF2-Save and DDES-
Save and Elcede exports. For a driver that supports this option, checking this checkbox causes each
different design to be output as a subroutine, with a call to that subroutine for each instance of the
design on the sheet. This saves memory in the controller for an NC output, and differentiates each
design from the layout in DDES and CFF2 output. When this checkbox is clear, the entire layout is
output flat, as if it were one big design. This option must be checked for the Layout Sequencing group
to be available.

Line processing options group
The option buttons in this group determine how lines are physically output.
 

 

No processing ignores bridges and outputs each special rule as a single line.

Design representation means that special rules are output as “actual” lines; for example, a wave rule
would be output as a series of arcs.

Partially-cut bridges instructs the output device to cut into the material at a partial depth to make
room for bridges in the rule.

Leave gaps for bridges splits the line output data into pieces and leaves gaps in the output data for
bridges, meaning that no slot or line is created in the output material where the bridges occur.

Software line styles processes all line styles before they are sent to the driver. For example, when this
option is selected, a perf would be broken up into a series of short cut lines and gaps instead of one line
marked perf that the driver would then process. This option is available only for Plot outputs.
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Layout Sequencing group
The options in this group are shown only when the output type is set to Plot, CAM, Sample, or Counter
on the Output Type tab. Enable subroutined output in the Optimization options group must be turned
on for this group to be available in Plot and CAM outputs.
 

 

The Sequence one-ups in layout checkbox determines if ArtiosCAD automatically resequences the
single designs in the layout when they are output. Clear this checkbox if you plan to always use the
Layout Manual Sequencing tool with this Output.

 The first group of four buttons sets the starting point for the sequencing. The first
button starts the sequencing at the bottom left of the layout. The second button starts the sequencing
at the bottom right of the layout. The third button starts the sequencing at the top left of the layout.
The fourth button starts the sequencing at the top right of the layout.

 The second group of four buttons controls the sequencing direction and is not
available until a button in the first group is pressed.

The first button sequences each horizontal row, starting each row on the same side of the layout so
that each row is sequenced in the same direction, as shown in the picture above, with the starting
point at the bottom left.

The second button sequences each vertical column, starting each column on the same side of the
layout so that each column is sequenced in the same direction.

The third button sequences each row, starting on opposite sides of the layout so that each row is
sequenced in the opposite direction, forming a horizontal snake pattern.

The fourth button sequences each column, starting on opposite sides of the layout so that each
column is sequenced in the opposite direction, forming a vertical snake pattern.

Nicks group
Nick gaps controls if ArtiosCAD leaves a gap in the line for a rule bender to interpret as a nick.

The Draw nick style checkbox controls whether nicks are drawn on the output, and the drop-down list
box lets you choose the style to use from the Nick Styles Catalog.
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Note:  You can make gaps for both bridges and nicks in the same Output, provided that
the nicks and bridges are not on top of each other, which weakens the rule and should be
considered an error. The rule bender would typically consider gaps of hypothetically 1mm or
less to be a nick, and wider gaps to be bridges.

There are three ways to Output nicks:

• Line crossing perpendicular.
 

 

• Line parallel with a line.
 

 

• Leave a gap.
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For the Line crossing perpendicular or Line parallel on top options:

• Add an appropriate nick style if it does not already exist in Defaults.
• Edit the export tuning file to map nick type 17 to the appropriate output type.

For all 3 cases:

• Add an output with the appropriate driver for the rule bender.

For Line crossing perpendicular:

• Check Draw nick style and choose a nick style where the nick is centered on the line.

For Line parallel on top:

• Check Draw nick style and choose a nick style where the nick is parallel to the line

For Leave a gap:

• Turn on Nick gaps.

Rubber group
The options in this group affect how rubber is shown on the Output.
 

 

If Fill - Color by is selected, the rubber is drawn filled with color; choose to color the rubber by Rubber
type or Element number. ArtiosCAD cycles through about 10 colors when drawing by element number.
If Fill - Color by is not selected, the rubber is drawn as outlines.
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To draw the element number inside each piece of rubber, select Show element numbers, and then set
the Size: field (in points) and Italic checkbox as desired.

Dieboard group
The options in the this group control how the dieboard is created for a relevant Output type.
 

 

Ignore die splits (full dieboard) makes a full dieboard regardless of any splits.

Undercut at die splits by instructs the output device to cut back each line leading up to a die split from
the split by the amount specified. Bridge positions are correctly maintained.

Undercut at crease ends by instructs the output device to put a bridge of the size specified at each
end of all creases. If a crease line is bridged, any cutback may not exceed the size of the bridge width.
If this option is chosen, set the minimum size of the line that will be undercut in the Minimum crease
length: field.

Text options group
 

 

Plotter font tells the output device to use its built-in font for rendering the text. Use this option for pen
plotters or for a driver that supports simple text entities, but not fonts, such as CFF2, DDES, Elcede
DieCAD, and DXF.

Line text converts the text to geometry, which is then affected by transformations on output. Line
text is suitable for etching text on a die. This is particularly useful for Asian languages, because the
Name tool in Manufacturing only supports ASCII characters. To use Line text on a die or stripping tool,
add a text item in a suitable font to the die or stripping board layer, with no color, and use an output
configured with Line text. A suitable font for line text should be simple, have parallel edges, and not be
too thick.

Normal text leaves the text alone. Normal text will always be output so that it is readable, regardless
of dieboard orientation. This is suitable for output formats that support fonts, such as all Windows
drivers, EPSF, and bitmap outputs

Text is always output right side up, for all three of the above options. The only way to output text
backwards is to convert the text to lines in the design using the Outline Text or Line Text tools.
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Identify Zero Length Lines
Identify zero length lines, when checked, warns you about zero-length lines and draws a small pink
rectangle around them when you perform the Output.
 

 
Click Ignore to ignore them and continue the Output, or click Cancel to stop the Output so you can
delete them using Designer's Fix-It.

Crease Cutback Dimensions
Crease Cutback Dimensions on the Processing tab toggles the display on an Output of crease cutback
distance dimensions for steel counters or for any other time when the top side of the rule is a different
length than the bottom side of the rule. The Crease Cutback Plot example in the Steel Counter folder
on the Outputs menu uses this option. If you use this feature, you may want to create custom Outputs
that send the Output to a layer so that the crease cutback distance dimensions are saved with the
workspace.
 

 

Shown below is a close-up of the preview of a crease cutback plot Output.
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On the Processing tab in Outputs, clicking the More Options (...) button opens the Crease Cutback
Dimensions dialog box.
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Draw annotation lines draws a rectangle of annotation lines from the crease cutback to the point you
select in the Measure to group:

• Edge of rule is the point ArtiosCAD calculates so that the crease rule does not overlap any abutting
rules.

• Center of rule is the end of the crease as drafted.
• Use end bridge if present measures to the end of the bridge on the crease.

The checkboxes in the Display crease cutback values for group determine if ArtiosCAD flags special
conditions in the Output.

• Conflict is when the estimated rule end is further than the crease cutback. ArtiosCAD shows !!! in
this case. These are line type Annotation3.

• Crease/crease flags creases that intersect other creases with an asterisk *. ArtiosCAD always
assumes that the crease is cut back enough to not touch another rule. When two creases meet,
it is not sure which one takes priority, so flags them for human checking. These are line type
Annotation4.

• Perpendicular is when the expected end of the crease is exactly half the width of the cut rule. As
this is the expected case, this option is off by default. This check may not work as expected if the
rules in the design are different pointages. These are line type Annotation5.

• Other is when a crease rule intersects a cut at an odd angle, or any other case. These are line type
Annotation.

Note:

• The size of the text is based on the Text catalog entry in Property Defaults.
• Dimensions display 3 decimal places for Imperial measurements and 4 for metric.

Restrictions
• ArtiosCAD treats special rules as regular lines. There is no way to specify slot or actual.
• ArtiosCAD assumes the crease end is squared, not chamfered or rounded.
• ArtiosCAD does not detect that a crease needs to be split if it is intersected in the middle.

473



8 ArtiosCAD

• There is no way to customize the appearance of the dimensions other than the size. The font, color,
and number of decimal places are all fixed.

• There is no way to customize the shape or type of the annotation lines.

Stripping Areas
Stripping Areas controls whether ArtiosCAD includes the colored Stripping Areas from the View Mode
and station and waste numbers in the Output. Shown below is an example PDF Output of a layout with
Stripping Areas enabled.
 

 

Station and Waste Numbers
Station numbers and Waste numbers control if ArtiosCAD includes those numbers in the Output. For
lower stripping boards, ArtiosCAD only etches those blocks which can be reused in the upper stripping
board, as etching other blocks serves no purpose.

Diesaw tab

Kongsberg DieSaw group
This tab appears only when the output is to a Kongsberg DieSaw.
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Full board depth is the thickness of the dieboard.

Generate saw leader holes controls whether ArtiosCAD creates leader holes. Leader holes are drilled
holes in the dieboard which allow the saw to position itself to start cutting in the proper position. They
are made before any saw cuts.

No leader holes in corners, when checked, prevents ArtiosCAD from automatically creating leader
holes in corners. Leader holes are instead put on bridges of the lines that meet to form a corner.

Adjust leader holes on bridges allows ArtiosCAD to move the leader holes further apart from each
other if they occur at either end of a bridge. When this happens, the amount of material left between
the two holes is not strong enough and could break; therefore, the centers of the leader holes are
offset from the ends of the lines to prevent bridge breakage. The picture below illustrates this process.
 

 

The Allowance reduction specifies by how much the edge of the leader hole is offset from the
maximum adjustment of the hole position. The maximum adjustment would position the edge of the
leader hole tangent with the end of the rule path. The Allowance reduction is the distance by which the
leader hole is moved away from that tangent position.

Lines shorter than the length specified in the No hole length field do not have leader holes drilled for
them; rather, they have a lead-in line cut for them with a hole at the beginning of the lead-in line. The
length of the lead-in line is specified in the Length of lead-in field.
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Lines shorter than the value in the One Hole Length field (but longer than the value of the No hole
length field) get only one leader hole drilled.

The value in the Long saw length field sets the minimum length of lines that are optimized for the
quickest sawing time. For lines longer than the long saw length, the direction of the line and the leader
hole is determined by optimizing the sawing time. For lines shorter than this value, the direction of the
line is determined to use the minimum number of leader holes. Connected lines that are longer than
this value will not share leader holes.
 

 
 

 

Tiling tab

The settings on the Tiling tab control what happens when the scale of the output is too big to fit on one
sheet of output medium.
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Skip empty tiles tells ArtiosCAD to not output blank tiles. If you will be assembling all the tiles together
into one big sheet, you may want to leave this option unchecked so as not to confuse the assembler.

Confirmation required for each tile, when outputting directly to a device tells ArtiosCAD to prompt
you to click OK before outputting each tile. This is handy for when you have to reload media on the
output device in between tiles.

Tile registration group
The options in this group control how the tiles are marked for assembly.
 

 

Registration cross size is the overall height and width of the cross mark. Setting this option to zero
turns off the drawing of registration crosses in the output. Also, registration crosses are only drawn in
the corner of tiles which align with other tiles; a registration mark will never be drawn in the bottom left
corner of the first tile.
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Tile overlap is the amount of overlap from one tile to the next. This value will be used for both the
horizontal and vertical overlap. A value of zero means no overlap, and when used with registration
crosses, turns the cross marks into corner marks.

Samplemaking registration hole diameter is only available for Sample outputs and is the diameter of
the hole cut into the sample material to aid in registering oversized samples. The diameter value must
be between zero and the size of the registration crosses. The hole is centered on the registration mark.

Using sample counter and Just draw registration marks are also only available for Sample outputs.
These options indicate if a counter is being used when this Output is run. If Just draw registration
marks is selected, then the Make Counter button on the main sample output dialog (what you seen
when you perform the Output) is replaced with a Draw Registration button. This button is unavailable
if tiling is not required. Selecting this option will generate output files (using the Make Counter file
designations) with just the tile registration marks drawn using a sample pen.

Output filename generation group
The options in the Output Filename Generation group automatically constructs a unique file name for
each tile when the output is set to go out to file. When both conditions are met (Out to file and a scale
larger than can fit on the output device), the options in this group change the name out of the output
file to indicate the separate tiles.
 

 

Sample line types tab

You configure the line types and tools used in samplemaking on the Sample line types tab.
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To configure how the line type is handled when performing this Output, select the line type in the Line
type: group and choose the tool in the Samplemaking tool: group. There may be settings for the tool
that appear in the bottom right corner; if there are, set them as desired.

As with other tabs, the information displayed on this tab is conditional; that is, the information
requested on the right side of the tab depends on the selected item on the left side of the tab. What
you see will not necessarily look exactly like the picture above.

To make nicks in the sample whose size based on the caliper of the board, enter a multiplier in the field
next to + CAL *.

To cut stripping rules on the sample, check the Cut stripping rules checkbox. Stripping rules are cut
outward from the design to avoid overcuts.

The Size only samplemaking tool is used to calculate the output size. Use it only when outputting to a
layer.

When using Re-board
®

, samplemakers cannot cut small holes in the material and use a drill tool
instead. Therefore, enter an appropriate value in Drill holes smaller than diameter for holes that are
drilled and not cut. If you will be using drill holes, you should update the Sample drill hole line type on
the Sample tab of your plotting style definition so that it uses a thicker solid line instead of the default.

Text options group
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Plotter font tells the output device to use its built-in font for rendering the text. Use this option for pen
plotters or for a driver that supports simple text entities, but not fonts, such as CFF2, DDES, Elcede
DieCAD, and DXF.

Line text converts the text to geometry, which is then affected by transformations on output. Line
text is suitable for etching text on a die. This is particularly useful for Asian languages, because the
Name tool in Manufacturing only supports ASCII characters. To use Line text on a die or stripping tool,
add a text item in a suitable font to the die or stripping board layer, with no color, and use an output
configured with Line text. A suitable font for line text should be simple, have parallel edges, and not be
too thick.

Normal text leaves the text alone. Normal text will always be output so that it is readable, regardless
of dieboard orientation. This is suitable for output formats that support fonts, such as all Windows
drivers, EPSF, and bitmap outputs

Text is always output right side up, for all three of the above options. The only way to output text
backwards is to convert the text to lines in the design using the Outline Text or Line Text tools.

Make nicks in sample group
 

 

The Make nicks in sample checkbox controls if nicks are made when cutting a sample. Check the box
to have the samplecutter make the nicks as defined in the design being output, or clear it to ignore
nicks. When the checkbox is checked, the Adjustment for nick overcut: field is available. This is the
offset distance between the tip of the blade and the point where the blade exits the material.

Sample Sequencing tab

The settings on the Sample Sequencing tab control how some problematic scenarios are dealt with
when making a sample, as well as controlling layout sequencing.
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Split lines connecting corners and Automatically round corners may not both be selected.

For Sequence one-ups in layout, see the Layout Sequencing group section for the Processing tab.

When you cut labels on a samplemaker, Join cuts across oneups causes the samplemaker to keep
cutting through the gaps between aligned labels for faster progress instead of having to lift the knife
and turn to cut label by label. Maximum gap to cut through sets the size limit for this behavior.

Note:  When you select Join cuts across oneups, Sequence one-ups in layout is unavailable.
Additionally, other features may not work as expected in other products depending on how they
implement combinations of options. At the time of this writing, when Join cuts across oneups
is enabled, options in the Round Slot Method group and Split lines connecting corners in the
Overcut Method group do not work as expected when using iPC.

Round slot method group
Cutting a sharp corner can tear the material being cut. The options in the Round slot method group
control how sharp corners are cut. Sharp corners are identified using Tear Distance and Tear Angle.
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If a corner is narrower than the distance defined for the Tear distance, it is a sharp corner. If a corner
has an angle less than the angle specified in Tear angle, it is a sharp corner.

Option A, Continuous cut, cuts all the lines in the slot in one direction.

Option B, Reverse the last line, reverses the last line to cut into the slot.

Option C, Cut short lines last, cuts the long lines first and then the connecting lines.

Overcut method group
The mechanics of samplemaking require that the knife cuts a little past the end of a line. If the
direction of the line is into the sample, this will leave a mark on the sample. On a sample table such as a
Kongsberg with a vertical rear edge to the knife, this problem can be fixed by reversing these lines (but
only where this does not conflict with the line order required for sharp corners).
 

 

In the Overcut method group, you can set the overcut method to reverse at perpendicular
intersections (called T-junctions). You can also specify to Split lines connecting corners.
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Automatically round corners group
Some samplemakers can automatically replace a corner with a radius, reducing the number of knife
lifts.
 

 

The Radius: field sets the size of the radius. The shortest lines intersecting to form a corner must be at
least the length specified in the Minimum length: field to replace a corner with a radius.

Over-crease group
Over-crease is when the ceasing wheel makes a continuous crease through gaps and on top of cuts.
In the Over-crease group, specify the maximum sizes of gaps and cuts to run the creasing wheel over
without it lifting.
 

 

Set the value in the Maximum length of cut to over-crease: field in the Over-crease group to set limits
on what is output as one line and what is output as separate lines.

The value in the Maximum length of cut to over-crease: field sets a limit so that short cuts and
creases are output as a sequence while long cuts and creases are output separately. Adjust this field
as needed to result in a series of short cuts with one long crease.

Set the value in the Maximum gap to over-crease: field to the maximum size of the gap the creasing
wheel will pass through without lifting.

Sample creases tab

The commands on this tab control how creases are made on the samplemaking machine.
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Single pass creasing and Double pass creasing control the number of times the creasing tool passes
over the material to make a crease. Double pass with grain crease and Double pass cross grain crease
only perform double pass creasing for creases in the specified direction, and use the options in the
Double pass crease offset group.

Double pass reverse crease, Second tool for cross grain , and Second tool for thicker creases enable
their namesake actions when checked.

The Crease cut back is the amount by which creases are shortened at both ends.

Double pass crease offset group
The options in this group are available only when Double pass creasing is selected.
 

 

The offset can be a fixed distance (in current units), a multiple of the caliper, or an allowance for the
pointage, or any combination of the three.

If Double pass for reverse creases is selected, the same crease offset applies as for creases, but no
counter channel is made for reverse creases.

A fixed offset is specified by checking the Fixed offset checkbox and entering the value. A multiple
of the caliper is entered by checking the Multiple of caliper checkbox and entering the value. To allow
different pointage creases to have different crease offsets, check the Allow for pointage checkbox

484



8ArtiosCAD

and enter the width of the scoring wheel. This defaults to 0.028 inches = 2 points; this adds (pointage -
value) to the crease offset.

Sample Counter tab

The options on this tab control how sample counters are made. For each type of crease in the
Parameter for: group, you can set the type of crease channel as well as the widths, counter cut back,
and the channel angle. Routed counters invoke conditional text by deleting the field for the channel
angle and inserting fields for the routing tool widths. The grain angle tolerance is the same for all
crease types.
 

 

Print Sample Position tab

The Print Sample Position tab lets you specify how to print sample graphics on your sample printer.
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This tab contains the exact same controls as the Position tab.

Send to tab

The commands on the  Send to tab let you send the results of the Output via email. The design file
itself is not sent when an Output with this option enabled is run. You must have a MAPI-compliant
mail program such as Microsoft Outlook installed on your computer for this to work. If you do not have a
MAPI-compliant email program installed, you will receive error messages when you attempt any email-
related functions.
 

 

The Use email checkbox turns on this feature.

The To and Cc buttons let you choose recipients from your mail program’s address book.

Prompt for message opens the message in your email program. If this option is not checked, the
message is sent with no user intervention.

Attach to email sends the output as an attachment, while Put contents in email inserts the text of the
output into the message body.

Delete output disk file deletes the file created by the Output after it is added to the email. To preserve
the file, clear this checkbox.

Advanced tab

The commands on the Advanced tab are meant to be used by people with very specific needs.
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Show Command for Diagnostics displays the instructions ArtiosCAD follows when making the output.
ArtiosCAD then instructs you to click OK to perform the Output or Cancel to cancel it as shown below:
 

 

Use prompting report indicates that a special report is used with this Output. Prompting reports
prompt you for workspace variables and do not produce a printed output. Once this report is run, the
variables are copied into the workspace. This is useful for setting variables that you want to track in
DataCenter.
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Use post processing command file lets you specify the name of a command file that modifies
the geometry in the :TEMPOUTPUT section. You should only use this feature if you have extensive
knowledge of the INTERACT programming language. The command file you specify must not have any
menu windows and must not crash.

Output through command file directs the output data through a command file specified in the EXE
field with parameters specified in the entry box after OUTPT.

Launch Executable and its associated options are meant for use by Esko personnel who design
custom solutions. It launches a program to which you can pass data from ArtiosCAD and pass data
from the program back into ArtiosCAD.

Prompt for Kongsberg Material is covered in the next section.

Run Time Data Set is used with an Output that uses the GNC driver.

Prompt for Kongsberg Material group
In the Prompt for Kongsberg Material group, Use Material List from Text File prompts you to select
a Material Setup File when running this Output. Material Setup files are usually configured when your
Kongsberg sample table is installed. Shown below is the Specify A Kongsberg Job Setup File dialog box
when the Output is performed.
 

 

Specify path to Material list file lets you enter the default location of the files rather than having to
specify it when the Output runs.

Use Material List from IPC Resource Database allows you to query the i-cut Production Console (IPC)
server running on a Kongsberg front end for a list of materials. In the iPC System Name field, enter
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either the hostname, fully qualified domain name, or IP address of that machine. If you use firewalls,
open ports 80 and 10003.

Record Variable Definition
These records and variables are created in the Output that is acted upon by the command file you
specify in the Output through command file checkbox. Use these records to get information from the
design to the command file.

Record Variable Sub-variable Definition

&OUTCM.

CMD$ the actual command that would be issued

DEBUG 1 if “Show Command for Diagnostics” is ON,
else 0

CMDTY$ the command type “PLOT”, “PUNCH” or
“SAVE”

CMDTYP command type - if (OTPTYP = 0 or 2) = 0, else
(OTPTYP = 1) = 0 for Make Counter, 1 = Make
Sample, 2 = Partial Cuts, 3 = Print Sample

DRV$ the driver name e.g. “PRTMAN”, “HP”

DEV$ the device name - when going directly to the
device - not defined when going out to a file

USRTX$ additional user defined command
parameters

OPT$ driver “opt” flag - either “OPT” or empty (“”)

DRVOP$ additional driver options

KGBMF$ KGB Material file name - not defined if not
used or empty

OUTFL$ the output file name - not defined when
going directly to the device

TUNE$ the tuning file name

DVSZLX the lower X of the device size (in current
units)

DVSZLY the lower Y of the device size (in current
units)
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Record Variable Sub-variable Definition

DVSZUX the upper X of the device size (in current
units)

DVSZUY the upper Y of the device size (in current
units)

WINLX the lower X of the window - not defined if not
tiled output

WINLY the lower Y of the window - not defined if not
tiled output

WINUX the upper X of the window - not defined if
not tiled output

WINUY the upper Y of the window - not defined if
not tiled output

SEC$ the section to output e.g. “:TEMPOUTPUT”
or “:TEMPOUTPUT:GRAPHOUT” (for print
sample)

SCLSTR scale or stretch - 1 for “SCALE” - 2 for
“STRETCH”

XSCALE x scale factor

YSCALE y scale factor (set to XSCALE when SCLSTR
= 1)

NEGX$ either “NEG X” or EMPTY (“”)

ROT rotation in degrees

POSX X position in current units

POSY Y position in current units

LTYPS$ the parameters to the TYPE keyword e.g.
“TYPE #SCUT, #SCREASE..#SRXCREASE
NOGRAPH” or empty(“”)

STY$ the plotting style to use e.g. “STY artios1” or
empty (“”)

TILEX for tiling - the row of this tile

TILEY for tiling - the column of this tile
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Record Variable Sub-variable Definition

&OUTPT. output properties

OTPTYP the output type 0 = PLOT, 1 = SAMPLE or 2 =
MFG

OTPNM$ the name of the output

USESCL 1 to use the scale given - else automatically
calculate it

SCALE the scale factor given

USESTR 1 to use “STRETCH” instead of “SCALE”

YSCALE the y-scale factor given

USEFRM 1 - this output uses a form

FRMNM$ the name of the form

DRV. the driver/positioning data

DRVTYP 0 - Windows driver, 1 = CAM driver

PRTR$ name of the windows printer

TOFIL 1- when output is set to file

ORIENT 0=Portrait, 1=Landscape, 2=Optimum -only
used for a windows driver always portrait for
CAM

TNDES$ the description as read from TUNEFILES

TNFIL$ tuning file name

DRVNM$ the driver name as read from TUNEFILES
e.g. HP

DVNAM$ name of CAM device for LP devices; e.g. HP1,
DDES etc.

DROPT$ the CAM driver options

DEVSZX CAM device size in X in current units

DEVSZY CAM device size in Y in current units

MGTOP CAM top margin in current units
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Record Variable Sub-variable Definition

MGBOT CAM bottom margin in current units

MGLEFT CAM left margin in current units

MGRGHT CAM right margin in current units

OFFSTX X offset from the justification position in
current units

OFFSTY Y offset from the justification position in
current units

STARTX X origin shift

STARTY Y origin shift

ROT Rotation flag: 0=rotate 0, 1=rotate 90,
2=rotate 180, 3=rotate -90

MIRROR Mirror flag: 0=no mirror, 1=mirror horiz.,
2=mirror vert

JUST Justification flag: 0=top left, 1=top center,
1=top right, 3=center left, 4=center, 5=center
right, 6=bottom left, 7=bottom center,
8=bottom right

SIDE Side flag: 0 = PRINTEDSIDE, 1 =
UNPRINTEDSIDE, 2 = default side

TILED 0 if we don't need tiling

TILESX number of tile rows

TILESY number of tile columns

TLOVLP tile overlap

PSDRV. the optional print sample driver/positioning
data

DRVTYP 0 - Windows driver, 1 = CAM driver, 2 no
printer

PRTR$ name of the windows printer

TOFIL 1- when output is set to file
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Record Variable Sub-variable Definition

ORIENT 0=Portrait, 1=Landscape, 2=Optimum (2
is only used for a Windows driver) always
portrait for CAM

TNDES$ the description as read from TUNEFILES

TNFIL$ tuning file name

DRVNM$ the driver name as read from TUNEFILES
e.g. HP

DVNAM$ name of CAM device for LP devices; e.g. HP1,
DDES etc.

DROPT$ the CAM driver options

DEVSZX CAM device size in X in current units

DEVSZY CAM device size in Y in current units

MGTOP CAM top margin in current units

MGBOT

MGLEFT CAM left margin in current units

MGRGHT CAM right margin in current units

OFFSTX X offset from the justification position in
current units

OFFSTY Y offset from the justification position in
current units

STARTX X origin shift

STARTY Y origin shift

ROT Rotation flag: 0=rotate 0, 1=rotate 90,
2=rotate 180, 3=rotate -90

MIRROR Mirror flag: 0=no mirror, 1=mirror horiz.,
2=mirror vert

JUST Justification flag: 0=top left, 1=top center,
1=top right, 3=center left, 4=center, 5=center
right, 6=bottom left, 7=bottom center,
8=bottom right
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Record Variable Sub-variable Definition

SIDE Side flag: 0 = PRINTEDSIDE, 1 =
UNPRINTEDSIDE, 2 = default side

Information Filter tab

The commands on the Information Filter tab let you select the ArtiosCAD data included in the Output.
The Output type must be set to Information Filter to make this tab appear.
 

 

Note:  The settings on this tab supersede any view settings you have set in ArtiosCAD when
you select this Output. This means you may send information you do not mean to send, or vice-
versa.

All layers must be turned on for the resulting workspace to be rebuildable. If all the layers are not turned
on, the Parametrics(Rebuild) checkbox is cleared and cannot be checked until all layers are turned on.
Click All On to turn on all the layers. Also, the workspace will not be rebuildable if using a differential
scale on the Output Type tab or if the scale is not set to 1.
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If the Manufacturing parameter sets checkbox is not selected, the Information Filter will remove
manufacturing parameter set information from Manufacturing files and copies of parameter sets that
are embedded in design files.

When using the Information Filter to strip prompted text variables from an Output, only those variables
defined in the Prompted Text Catalog are stripped from the Output.

The output format for an information filter is usually an ArtiosCAD workspace. The allowed formats
for an information filter output are the current version of ArtiosCAD, selected previous ArtiosCAD
releases, a LASERPOINT IQ 3 or 4 workspace, and a LASERPOINT IQ 2 workspace.

Counter Tool Widths tab

All the fields which are unavailable in this tab in Defaults become available when performing the actual
Output. The values for them are dependent upon the board used and parameter set. These fields are
calculated automatically when this Output is invoked and cannot be changed during an Output.
 

 

The fields in the Tool Widths group are measured in current units and are enabled only when their
respective checkboxes are checked.

When the Multi-Pass checkbox is off, the corresponding field is automatically set to the crease channel
width and disabled. When the Multi-Pass checkbox is on, the edit box is enabled. Enter a tool width
greater than zero and it will multi-pass with this tool.

For the Position Holes tool, the Allow for Tool Diameter checkbox follows the design lines when it is
not selected, and allows for the width of the tool when the checkbox is selected.
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If the specified tool width is too large to fit within the programmed lines, it will always cut something
rather than nothing.

If the tool width of the crease tool is wider than the required crease channel it will cut with a single
pass.

If the crease end shape is narrower than the crease end tool, it will cut a path that is the same distance
from the crease end.

Counter Cutting Order tab

As the name implies, the tools on Counter Cutting Order tab control the direction in which the counter
lines are made on the counter cutter.
 

 

The four option buttons in the Milling Direction group control the milling order.

The tools listed in the Tool Cutting Order group cut from the top of the list to the bottom of the list. To
change the cutting order, select a tool to move, and then click the arrows to the right of the list.

The options in the Multi-Pass for Creases group control how the multiple passes for creases are made
if that option is turned on. Optimize Tool Path makes a small rectangular crease channel out of four
passes, while Account for Deflection makes two parallel passes in the same direction.

The value you set in the Milling Overlap field indicates the overlap the milling tools will use when the
machine mills lines close to each other. This is to ensure all material is milled correctly.

Grouped Outputs tab

The Grouped Outputs tab, which appears only when the Output Type is set to Grouped Output, lets you
group already-defined Outputs into one. For example, with one click, you could save the workspace,
print a spec sheet, export a DDES file, send an email containing a DXF file, and cut a sample.
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If any of the component Outputs you select go out to a file, they do not need to be configured to
automatically overwrite the file if necessary; ArtiosCAD will prompt for a filename when necessary.

To add an Output to this Grouped Output, click Add and select it from the list of Outputs; to delete it,
click Delete.

Also, the Scale group on the Output Type tab is unavailable for Grouped Outputs as the scales are set
for each component Output.

The Outputs listed are processed in top-down order. To change the position of an Output, select it, and
then move it by using the arrows at the side of the list box.

Save before performing outputs uses the current name of the workspace if one is defined. If it is not
defined, ArtiosCAD prompts for the information needed. Save-As before performing outputs lets you
select a new folder or resource as well as a new filename. ArtiosCAD works with the new file as soon as
it is saved, so any Outputs in this grouped Output will use the new file.

In both cases, any dialog boxes normally opened by the save process will be opened during the Output,
such as the Database Information dialog box. Use caution when using the Save or Save-As options
with CAD-X as it may lead to unpredictable results.

Both Save before performing outputs and Save-As before performing outputs may be checked at the
same time to allow saving the workspace with its original name and then saving it as a new name.

Grouped Outputs can also be added to a compressed archive in ZIP format; select Zip in the Grouped
Output Type group and Insert into Zip archive in the E-mail/Zip options group. If you are working with
filenames in non-English languages, check Use UTF8 characters for filenames so that the filenames
are encoded correctly within the ZIP archive.
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Delete output disk file deletes the working files that the Grouped Output creates after inserting them
into the ZIP archive. In this example, those would be the DXF and DDES files.

As the E-mail and Zip Grouped Output types are mutually exclusive, in order to e-mail a zipped archive,
you have to create a Zip Grouped Output first and then include that in an E-mail Grouped Output.

E-mail options group
A Grouped Output can also have its own top level email output (configured on the Send to tab) in
addition to each individual Output going to email.
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No change to destination indicates that the selected individual Output runs without any changes.

Attach to e-mail intercepts the output file for this component Output and embeds it as part of the
group mail output. For example, if the output is to a Kongsberg samplemaker, the .MAP file will be
attached to the email message instead of being sent to the table.

Put contents in e-mail means take the contents of a text file created by this component Output and
put it in the e-mail message rather than attaching the file. It is intended for inserting text such as
ordering information in the message. This should only be used with outputs through command files
which generate text files.

Delete output disk file deletes any temporary files needed to add the output to an email message.

Select which sample output group
This group is conditional; it appears only when a sample output is selected in the list of Outputs.
 

 

Select the option button for the type of sample output you wish to create.

PDF Security tab

The PDF security options available in an ArtiosCAD Output correspond to those used in Adobe Acrobat.
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Checking Require a password to open the document requires the recipient of the file to enter a
password when opening the PDF file using Adobe Acrobat Viewer. Enter this password in the Open
password and Repeat password fields; they must match exactly. There is no way to recover this
password if it is lost or forgotten.

Checking Use a password to restrict permissions requires the recipient of the file to enter a password
to change how the file is protected. Enter this password in the Open password and Repeat password
fields; they must match exactly. There is no way to recover this password if it is lost or forgotten.

If both password options are used, the two sets of passwords must be different.

Note:  If you forget a password, change the password in Defaults, save the changed Defaults,
and then regenerate the PDF document. It will use the new password.

In the Printing allowed drop-down list box, there are three settings: None, Low Resolution, and High
Resolution. None means the recipient may not print the document. Low Resolution allows printing as

500



8ArtiosCAD

a bitmap up to 150 dpi. High Resolution allows printing the document at any resolution, and to use high-
quality vector output and other advanced printing features if the printer supports them.

In the Changes allowed drop-down list box, there are three choices: None, Page content changes
only, and All changes allowed. None allows no changes in Adobe Acrobat. Page content changes only
restricts changes to what is shown on the page, but prevents other changes such as page rotation. All
changes allowed allows any change.

The recipient of a PDF file created by ArtiosCAD with security options set must use Adobe Acrobat 5.0
or later to open the file.

Note:  ArtiosCAD cannot open PDF files with an Open password, nor can it open PDF files that
have restricted permissions and that do not have content copying enabled.

Configuring 3D Outputs

3D has its own table in Defaults for Outputs. Shown below is the Artios catalog in Shared Defaults >
Outputs-3D.
 

 

Learn all about the options available for these output types in the section 3D Outputs in the chapter
Outputs.

Creating a new 3D Output

To create a new 3D Output, do the following:
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1. Start ArtiosCAD and click Options > Defaults.
2. In the Shared defaults pane, scroll down to the Outputs-3D catalog, right-click it, click New, and

then click Data on the context menu.
3. Replace New Data 1 with the name of the new Output.

 

 
4. Press ENTER when you have entered the name and then double-click the new entry to access its

Properties dialog box.
 

 
5. On the Output Type tab, choose the type of Output to make. For this example, choose Bitmap.

Note:  You may only output a SolidWorks file if you installed the SolidWorks supplemental
software from a pre-12.0.10 version of ArtiosCAD.

6. Click the Bitmap tab.
 

502



8ArtiosCAD

 
7. In the Save bitmap as group, choose JPEG. Set the other options as desired.
8. Click the General tab and enter a directory in the Output directory: field. Set the other options as

desired.
 

 
9. Click OK to finish defining the Output.
10. Click File > Save, and then click Yes to confirm overwriting shared Defaults.
11. The new Output in 3D is ready to use.

There are some slight differences between the options on the tabs in Defaults and those in the Outputs
at time of use. For example, the Use OpenGL for bitmaps checkbox on the Bitmap tab when using an
Output is set in the 3D Rendering Options entry in Startup defaults, not the Output defaults.

Animation Snapshots exports each frame to individual PNG or JPEG files. For example, if you have an
8-frame animation, an Output of this type would produce 8 .JPEG or .PNG files in the same directory.
When configuring an Output of this type, on the Animation tab with Export animation as: set to
Bitmaps, the Bitmap Filename Generation group appears. The options in this group configure how
the different filenames are named. The root of each filename is the workspace name, and then the
Frame separator character is inserted after the name, and either a number or letter is added as a
sux depending on the option chosen.
 

 

Changing Collada defaults

Using the Collada entry in the Outputs-3D catalog in Defaults creates a .ZAE file with .PNG images at
the current graphics resolution.
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To change the settings, do the following:

1. Start ArtiosCAD.
2. Click Options > Defaults.
3. In the Shared Defaults pane, scroll down to the Outputs-3D catalog and open it by clicking the plus

sign (+) next to it.
4. Double-click the Collada entry.
5. Click the Collada Options tab.

• In the Graphics resolution group, Use View Settings uses the resolution set in the View Mode
dialog box. Deselect it to enable the drop-down list box that sets the resolution setting manually.

• PNG and JPEG in the Include bitmaps as group control how the images are stored. Select JPEG
to enable the quality setting.

• In the Save as group, choose to save Collada files as standalone .DAE files or .ZAE archive files.
6. Click OK when done setting the options to return to Defaults.
7. Click File > Save to save the changes.
8. Click Yes to overwrite the existing Defaults.

Note:

You may want to create additional Collada entries with different options set for ease of output.
Make sure to set the Output Type to Collada on the Output Type tab of the dialog box.
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Rule labels

You can define rule labels for special rules that appear in the design when viewing the design, or when
printing the design, or both. Rule labels display the specific rule type as the generic rule type plus
whatever label you specify.

To configure this, you must add a rule label to the rule definition in the Special Rule Types catalog in
Defaults.
 

 

Enclosing the fraction in braces causes ArtiosCAD to display it as a real fraction, such as ¼.

To turn on rule labels when working in ArtiosCAD, open the View Mode dialog box, select the Rule labels
checkbox, and click OK.

Shown below is a hanger hole made from ¼ by ¼ perf with rule labels turned off.
 

 

Here is the same hanger hole with rule labels turned on:
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To turn on rule labels as a function of an output, check the Rule Labels checkbox on the View tab of the
output’s properties page.
 

 

The defaults for the size and default appearance of the rule labels are stored in the Rule Labels entry in
Design defaults.
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The Size: of the rule label is in points. The value in the Space between labels controls how often along
the line the label is repeated. Rotate parallel to line determines if the label is parallel to the rule or
always shown so that it is easily readable. Place above line controls if the label is in the line or above
the line. Draw generic type controls if ArtiosCAD

Shown below is the same hanger hole with Rotate parallel to line and Place above line turned off.
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Configuring the Output Scale Table

To add or remove values from the Output Scale Table, do the following:

1. Start ArtiosCAD and click Options > Defaults.
2. Open the Startup Defaults catalog by clicking the plus sign preceding it (+) and double-click Output

Scale Table. It should look similar to the picture below:
 

 
3. To add a value to the table, click Add and enter the value in the Scale value: field. The value you

enter must be a least 0.005 units of measurement different from any other value.
4. To delete a value from the table, select the value and click Delete. There must always be at least one

value in the table; the last value can not be deleted.

Notes on using the Output Scale Table

When using the Output Scale Table, the scale that is actually used is stored in the Plotting Scale
variable in the General Information calculated text catalog. Insert this item of calculated text on the
report to show the scale used.

If the report itself is scaled when it is output, that scale will be applied to the file window. In addition, all
calculated text fields that use the Plotting Scale system variable (#FWSCALE) will be reevaluated using
the combined file window scale and report scale.

AutoSave / Local Temp Directory

The AutoSave default in Startup defaults automatically saves a backup copy of open workspaces in the
Local Temp Directory at the interval defined in the AutoSave every: field. ArtiosCAD AutoSaves only
when the Activate AutoSave checkbox is selected.
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The Local Temp Directory is configured in the Local Temp Directory default in Startup Defaults.
 

 

The system TEMP directory is defined by an environment variable. See your system administrator, or
refer to your operating system documentation for more information on changing the system TEMP
directory.

To set your own TEMP directory, select the Specify option and browse for the desired directory.
Everyone must have write access to that directory. The Local Temp Directory must be on the current
machine - it may not be set to a network drive.

The AutoSave timer is NOT active when:

• a dialog box is open

• when the Rebuild Playback tool is in use

• when the Interact window is open.

The AutoSave file is named BCKxxxxx.AAS, where xxxxx is a random number, and AAS stands for
ArtiosCAD Auto Save.

No database synchronization is done with the AutoSave file, nor is it saved in the database.

Recovering AutoSave files

The first time ArtiosCAD starts after an improper termination, the AutoSave Recovery dialog box will
appear listing the workspaces for which AutoSave files exist.
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Check the checkboxes next to each file to recover and click OK. The AutoSave files will be restored for
the selected files; SAVE the workspaces once they are open. AutoSave files that are not selected for
restoration are deleted automatically.

Revision Disk File Format in Revision History

The Revision History feature of ArtiosCAD relies on changing the name of files as they are stored
on the hard drive. How file name is changed is controlled by Options > Defaults > Startup defaults >
Revision Disk File Format.
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For example, consider a file called FILE. If you choose the first option, Base filename is latest revision,
and create a new revision, then the latest revision becomes FILE and the original becomes FILE_~. If
you then make a new revision, then the latest file will still be FILE, the original will be FILE_~, and the
first revision from the original will be FILE_A. In this case the latest FILE would also be FILE_B, but the
_B extension will not be visible; if you open other revisions they will warn you that the latest revision is
FILE_B.

If you choose the second option, Base filename is earliest revision, then each new revision gets
appended in sequence: the original is and will always be FILE, the second revision will be FILE_A, the
third will be FILE_B and so on. The most recent revision will be the one with the highest extension.

Default to update all projects when saving revisions, when checked, causes ArtiosCAD to update all
Projects that contain the current design when you use Save As Revision. When cleared, ArtiosCAD
updates only the current Project when you use Save As Revision. Also when this option is cleared, If
the design is not in a Project, or the design is not in the active Project, no Projects are updated with
information about this revision. This option is checked by default.

Note:

As of ArtiosCAD 16.1, the default option is the second option to better support canvases. If you
have upgraded from a previous version, the previous setting is preserved.

Database Browser Reports

This information is supplied for reference only. Only the most advanced users of ArtiosCAD who are
very familiar with XSLT and XML technology should consider modifying the database reports.

There are two types of Database browser reports - those used in the ArtiosCAD browsers and those
used in DataCenter Admin.

ArtiosCAD Database browser reports are configured in the Database Browser Reports Catalog in
Defaults.
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There are two reports for each ArtiosCAD browser. The AutoCol Browser List format automatically
detects which data are selected for inclusion in Defaults and includes them on the report.

The SimpleEmb Browser List format presents just the information shown in the browsers.

The reports use three formats:

• CSV - produces a CSV (Comma Separated Values) file suitable for importing into a spreadsheet.

• HTML - makes an HTML (Hyper Text Markup Language) document which can be viewed in a Web
browser.

• XML - makes an XML (eXtensible Markup Language) file suitable for delivering data to other
applications in a rich, structured way. Only the Simple reports use this format.

Shown below is the Properties dialog box for the AutoColDesignListHTML report for illustrative
purposes. For the reports with Simple in their name, any modifications made to the data included in
the report require modifying the XSLT transformation file to put that data into the output file. The
reports with Auto in the name automatically recognize the data included so the items in Select Data to
Include can be added and removed as desired.
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The option buttons in the Selection group control which database records are included in the report
when it is output.

The Template File: field controls which XSLT template is used with the report. For the ArtiosCAD
browsers, the template files are stored in InstLib. For the DataCenter Admin browsers, the template
files are stored in the language directory of the DataCenter program folder.

The options in the Output File group control where the output file is created and how it is treated after
it is created.

The Select Data to Include group controls the data going into the raw XML file before it is translated
into the output file by the XSLT file. If Thumbnail is selected, a JPG thumbnail for each record is saved
in the same directory as the report file.

DataCenter Admin reports use hard-coded report names with extension .XSL that are in \Esko
\Artios\DataCenter\Program\ <language> .

The reports use XSLT files that are not meant for modification except by the most advanced users who
are already familiar with XSLT and XML. Modifying the catalog entries in Defaults only modifies the
information going into the raw XML file - the XSLT transformation template must also be updated to
use the information. It is your responsibility to edit or create a new XSL template file used to format
the data into the output file.

Publishing ArtiosCAD documents to WebCenter

To configure ArtiosCAD for publishing documents to WebCenter, double-click Publish to WebCenter in
the WebCenter catalog in Shared Defaults.
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Note:  The WebCenter servers must be running version 6.1 or greater.ArtiosCAD can publish
to a single WebCenter site. Change the WebCenter address field in the Publish to WebCenter
dialog box in Defaults as needed to publish to more than one WebCenter site.

Shown below is the default Publish to WebCenter dialog box.
 

 

WebCenter Project Name group

The options in the WebCenter Project Name group control which WebCenter Project receives the
ArtiosCAD document.

Use document name uses the ArtiosCAD document name as the WebCenter Project name.

Calculate using a library function lets users with advanced ArtiosCAD knowledge use a library function
to determine the WebCenter Project name. Enter the name of the library function in the TLIBRARY()
field.

Use ArtiosCAD project name (ARD only) names the WebCenter Project after the ArtiosCAD project
name if one was defined. This option overrides Use document name and Calculate using a library
function.

Prompt for project name prompts for the Project name. If any Prompt option is selected, the Publish
to WebCenter dialog box appears when publishing. They all must be deselected in order to hide that
dialog box when publishing.

Create project if it does not exist creates the WebCenter Project named using the options selected in
the previous fields if it does not already exist. If this option is deselected and the WebCenter Project
does not exist, when ArtiosCAD tries to publish a document into that WebCenter Project, an error will
occur.

Use template lets you specify the template to use to create the Project. Enter its name in the Name
field or enter the name of the library function used to calculate the name in the TLIBRARY() field.
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Use document thumbnail causes WebCenter to use the thumbnail for the single design or 3D
document as the Project thumbnail.

Publish Options group

If document already exists then publish as new version controls what happens when a document with
the same name as the document being published already exists in the same folder in the WebCenter
Project. When this option is selected, the document being published is treated as a new revision of the
document already in the WebCenter Project. When this option is not selected and a document exists
with the same name as one being published, an error will occur.

WebCenter Folder Name group

The options in the WebCenter Folder Name group control where in the WebCenter Project the
ArtiosCAD document is placed once it is published.

Publish to root level puts the ArtiosCAD document in the default folder in the Project. Security on this
folder is inherited from the WebCenter Project security settings.

Use standard ARD, A3D, MFG folders uses folders with those names for ArtiosCAD documents with
those filename extensions. Single designs would go into a folder called ARD, 3D documents into A3D,
and manufacturing files into MFG.

Calculate using a library function lets users with advanced ArtiosCAD knowledge use a library function
to determine the folder name. Enter the name of the library function in the TLIBRARY() field.

Prompt for folder name prompts for the folder name. If any Prompt option is selected, the Publish
to WebCenter dialog box appears when publishing. They all must be deselected in order to hide that
dialog box when publishing.

Create folder if it does not exist creates the folder named using the options selected in the previous
fields if it does not already exist. If this option is deselected and the folder does not exist, when
ArtiosCAD tries to publish a document into that folder, an error will occur.

WebCenter Login group

The WebCenter system administrator must provide a username and password for the account
ArtiosCAD will use to publish documents to WebCenter. Enter the username in the Username field.
Prompt for password causes the ArtiosCAD user to have to enter a password when publishing.
Deselecting this option causes the Password field to become available. If you specify a username and a
password, they will be automatically entered in the Publish to WebCenter dialog box when publishing.

WebCenter Connection group

Enter the URL for the WebCenter server in the WebCenter address field.
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Note:  ArtiosCAD may only publish to the WebCenter site listed in this field. To publish to
another WebCenter site, change this field as needed.

Test tests the connection to the WebCenter server. The test is successful only if you receive a
message that the WebCenter Web-API was properly installed. Any other response means the test
failed.

Graphic PDF file rotation import option

A PDF file can contain an internal flag to indicate if the document is rotated or not. ArtiosCAD has
ignored this setting until version 7.35. In Options > Defaults > Shared Defaults > Startup defaults
> PDF Options is the Honor Acrobat Rotation checkbox. To have ArtiosCAD respect this flag when
importing a PDF file as graphics, enable this checkbox. The checkbox is not selected by default, and
has no effect for PDF files imported as lines.

Using Spot Colors in PDF files

You can configure PDF Outputs to use spot colors for the line color definitions instead of using plotting
style information. To make this change, it is best to copy an existing PDF Output to a new one in
Defaults and change its name, and then modify the new entry.

1. Click Options > Defaults.
2. In Shared Defaults, copy an existing PDF Output to an entry with a different name, such as Plot to

PDF using spot colors.
3. Double-click the new entry and click the Device tab.
4. Click ... (Browse) at the end of the Tuning Filename field.

a) Navigate to InstLib.
b) Change the filetype selector to All files (*.*).
c) Click Tune.PDF.SpotColors.xml and then click Open. The entry in the Tuning Filename

field should change accordingly.
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5. Click OK to make the change.
6. Click File > Exit and click Yes when asked to save and then overwrite the Defaults.

Shown below are the Ink Manager palettes for two PDF versions of the same single design, one using
the default method and the other using the spot colors method.
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To change the ink names, RGB color values, stroke widths or stroke styles used by this method, make
the changes in PDFSpotColorMap.xml.

Exporting RGB colors in PDF files

To export RGB colors in PDF files, in Startup options > PDF Options, check Export using RGB color
scheme.

Layered PDFs

You can specify custom PDF Outputs that maps linetypes into layers. PDF Output tuning works using an
XML tuning file. The easiest way to do this is to copy the example Tune.PDF.Layered.xml tuning
file in InstLib and modify it to suit your needs. Save your modified version to ServerLib and add a
new Output using that tuning file.

Shown below is an excerpt from the tuning file.

 <!-- Line type 20 is used for Text items - map these to a layer called "Text Layer"-->
    <MAP ARTIOSCAD_LINE_TYPE="20">
      <PDF_LAYER NAME="Text Layer"/>
    </MAP>

    <!-- Line type 14 is used for Image and graphics items (strokes and fills).
         Map these to a layer called "Image Layer"-->
    <MAP ARTIOSCAD_LINE_TYPE="14">
      <PDF_LAYER NAME="Image Layer"/>
    </MAP>

To map a specific line type to a layer:

1. Create your custom tuning file by copying the example one from InstLib to ServerLIb and
opening it in a text editor. Save it with a different name.

2. Copy one of the MAP nodes to the bottom of the PDF_LINE_TYPE_MAPPING node. Copying the
comment (the part enclosed in <!-- and --> is optional.

3. Change the line type number to the new line type. A list of line types is in the appendix.
4. Change the name of the layer in the NAME attribute of the PDF_Layer tag.
5. Save the file.
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For example, to have all Outside Bleed lines in their own layer, create a block like this:

<!-- Line type 11 is used for Outside Bleeds.
         Map these to a layer called "Outside Bleeds"-->
    <MAP ARTIOSCAD_LINE_TYPE="11">
      <PDF_LAYER NAME="Outside Bleeds"/>
    </MAP>

For more examples of how you can customize PDF output, refer to the following example files in
InstLib.

• Tune.PDF.UsePlottingStyle.xml shows how to use the current plotting style to render
PDFs. This is the default if no tuning is specified or is not found.

• Tune.PDF.UseSpotColors.xml shows how to use technical inks in the PDF.

• Tune.PDF.Layered.xml shows how to map particular line types to PDF layers.

• Tune.PDF.Example.xml is an example tuning using a combination of layers and rendering
options.

Setting CAPE Defaults

Before you use the palletizing features with Cape Pack, you must set the Cape Pack Defaults by doing
the following:

1. Start ArtiosCAD.
2. Click Options > Defaults.
3. In the list of Shared defaults, scroll down to the Palletization catalog and open it by clicking the plus

sign (+) next to it.
4. Double-click CAPE Defaults.

The Cape Pack Defaults dialog box opens as shown below.
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5. Set the options in the dialog box as desired.

a) If you are using Cape Pack in client/server mode, select Client/Server and enter the User ID for
Cape Pack in the field provided. If you are using it in workstation/standalone mode, leave this
field empty.

b) Set a default case type and board as desired in the Default Case Type and Board group.
c) Choose a default pallet from the drop-down list box in the Default Pallet group.
d) Set the Maximum pallet height and Maximum pallet weight appropriately using inches and

pounds or millimeters and kilograms.
e) To not see the waste areas of the layout and see only the designs in Cape Pack, check Output to

CAPE as stripped.
f) To calculate the caliper from the board elements instead of using the caliper defined by the

board code, check Calculate True Caliper from Medium and Liners.
g) Set an Import pallet tolerance for use when exchanging design data between ArtiosCAD and

Cape Pack. As the outer dimensions of the Cape Pack pack type and the ArtiosCAD standard
may not match, the tolerance will make it easier to generate pallet loads.

h) In the Arrange/Design Options group, set the default amount of slack and the default maximum
package size.

i) In the Number of primary packages group, set the minimum and maximum number of primary
packages in the secondary package.

j) Set Round to nearest 1/16th as desired. This works in Inches mode only.
k) To customize the Customer Information Field data appearing on Cape Pack Reports, click

Customize CIF Fields in the Report group.
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In ArtiosCAD Standard Edition, double-click in each field and enter the desired information.
Use English characters only as Cape Pack does not interpret UTF-8 characters. In ArtiosCAD
Standard Edition, use only text or non-database-related calculated expressions; userfields and
database expressions are not available. In ArtiosCAD Enterprise, choose a calculated expression
or Attribute by clicking the Browse (…) button.
 

 
l) Click OK to return to Defaults when you are done setting the CAPE Defaults.

6. Click File > Save to save the changes.
7. Click Yes to confirm the saving of the changes to Defaults and return to ArtiosCAD.

Setting TOPS Defaults

Before you use the palletizing features with TOPS, you must set the Tops Defaults by doing the
following:
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1. Start ArtiosCAD.
2. Click Options > Defaults.
3. In the list of Shared defaults, scroll down to the Palletization catalog and open it by clicking the plus

sign (+) next to it.
4. Double-click TOPS Defaults.

The TOPS Defaults dialog box opens as shown below.
 

 
5. Set the options in the dialog box as desired.

a) If you are using TOPS in client/server mode, select Client/Server and enter the User ID for TOPS
in the field provided. If you are using it in workstation/standalone mode, leave this field empty.

b) Choose a default pallet from the drop-down list box in the Default Pallet group.
c) Set the Maximum pallet height and Maximum pallet weight appropriately using inches and

pounds or millimeters and kilograms.
d) To not see the waste areas of the layout and see only the designs in TOPS, check Output to TOPS

as stripped.
e) To calculate the caliper from the board elements instead of using the caliper defined by the

board code, check Calculate True Caliper from Medium and Liners.
f) Set an Import pallet tolerance for use when exchanging design data between ArtiosCAD and

TOPS. As the outer dimensions of the TOPS pack type and the ArtiosCAD standard may not
match, the tolerance will make it easier to generate pallet loads.
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g) In the Arrange/Design Options group, set the default amount of slack and the default maximum
package size.

h) In the Number of primary packages group, set the minimum and maximum number of primary
packages in the secondary package.

i) Set Round to nearest 1/16th as desired. This works in Inches mode only.
j) Click OK to return to Defaults when you are done setting the TOPS Defaults.

6. Click File > Save to save the changes.
7. Click Yes to confirm the saving of the changes to Defaults and return to ArtiosCAD.

Setting DWG/DXF Options

DWG/DXF Options in the Startup defaults catalog is where you:

• set whether or not to use third-party import libraries
• map font names in DWG/DXF files to Windows TrueType fonts.
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Import DXF files using third party libraries controls whether or not ArtiosCAD uses a more robust
method to open DWG or DXF files than its built-in method. If you have trouble importing DWG or DXF
files, try deselecting this checkbox.

ArtiosCAD does not display the fonts that DWG or DXF files use. Therefore, those fonts have to be
mapped to the Windows TrueType (TTF) fonts that ArtiosCAD does display. In the default map shown
above, Width Factor means the kerning and Height Factor adjusts the height of the text. To change any
of the fields other than Imported Font, click in the field. ArtiosCAD maps any unmapped fonts using the
*Default setting.

If you have a DWG/DXF file containing unmapped fonts (text will be the wrong size), click Get font
definitions from file, then browse for the file. ArtiosCAD scans the file and sets up new map entries
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with which you can then configure as desired. It then stores FontMap.XML in ClientLIb which you
can copy between machines as needed.

Note:  ArtiosCAD does not use font mapping if Import DXF files using third party libraries is
not checked.

Color Palettes

ArtiosCAD comes with three color palettes that you use to pick colors. A palette can have RGB colors
or CMYK colors. RGB is way of defining colors based on the amount of red, blue, and green in them.
CMYK defines colors based on cyan, magenta, yellow, and black. You can also make custom palettes as
desired.

The three default palettes are:

• Artios CMYK Palette. This palette contains some of the colors from the color picker in previous
versions of ArtiosCAD.

• CMYK Palette. This palette contains a selection of CMYK colors.

• RGB Palette. This palette contains a selection of RGB colors.

Note:  Plotting styles and toolbar colors use color choices specifically chosen for clarity. They
do not use palettes.

Adding a New Color Palette

To add a new color palette, do the following:

1. Click Options > Defaults.
2. Right-click Color Palettes and click New > Data.
3. Enter a name for the new color palette and press Enter. You should include the type of palette it is,

either CMYK or RGB, in the name so that you know what kind of palette it is when you use it.
 

 
4. Double-click the new color palette to open its Properties dialog box.
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When you create a new palette, ArtiosCAD sets its type to RGB and initializes the colors to white.
a) Change the palette type to CMYK if you are creating a CYMK palette.
b) Click the square of the palette which will contain the color you are about to define. It will have a

rectangle around it to show it is selected.
c) Define the color by either typing the color values in the input fields for the type of color, or by

using the mouse to set the hue and saturation in the color field and the luminance on the slider,
or a combination of the two methods.

d) ArtiosCAD automatically names the color PaletteType(Values). If you leave the default name and
later change the palette type, the color name changes automatically to reflect the different
palette type. You can give the color a custom name, but it will not change automatically if you
change the palette type.

e) Click Update Palette to add the color to the palette. ArtiosCAD then automatically selects the
next color square.

f) Repeat the steps above to add colors as desired. Each palette can have up to 48 colors.
5. Click OK to save the changes to the color palette and return to Defaults. Save and exit Defaults

normally.
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Note:  If you are adding new colors or palettes to use when setting a board color, you must
completely exit Defaults after you have made the desired changes.

Color Palette by Feature

Some features in ArtiosCAD can use both color palettes, while others are limited to CMYK. For features
that can only use CMYK palettes, ArtiosCAD only lets you select CMYK colors. If you want a palette that
works in every tool that uses color, create a CMYK palette.

RGB Palettes or CMYK Palettes

3D Outputs > VRML Options > background color

Outputs > U3D Options > background color

3D > Light Source tool > light color

3D > View > Ambient Light

3D > Select > Double-click an object > Material properties tab > Outside board and Inside board
colors

3D > View Mode > Background color > Select color

DataCenter Admin / Enterprise Board Browser > Boards > Create a new board or select an existing
board and click Edit > Select Color

DataCenter Admin / Enterprise Board Browser > Boards > Create a new board or select an existing
board and click Edit > Advanced color > Select color

Defaults > Customized toolbars > ArtiosCAD Toolbar Hover Color

Defaults > Startup defaults > 3D View Mode > Background color > Select color

Defaults > Startup defaults > Document Bar Options > Project Button Color

Defaults > Design defaults > VRML Export Options for CAD-X > Background color

Defaults > Property defaults > Mate > Glue type > 3D bead color

Single Design > Mate tool > Mate properties > Glue type > Bead color

Single Design > Select > Double-click the edge of a Mate > Properties > Glue type > Bead color

Defaults > Rubber types > Individual type color

Defaults > Special rule types > Tear tape > Individual tear tape > Special rule > Select color

Single Design > Select > Double-click a line with type Tear tape > Properties > Special rule > Select
color

Defaults > Special rule types > Edgeband > Individual edgeband > Special rule > Select color

Single Design > Select > Double-click a line with type Edgeband > Properties > Special rule > Select
color

CMYK Palettes Only

Defaults > Property defaults > Graphics > Fill Color and Stroke Color

Defaults > Property defaults > Text > Color > More colors
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CMYK Palettes Only

Defaults > Property defaults > Hatch > Custom > Line Type > Stroke > Color > More colors

Defaults > Property defaults > Hatch > Custom > Background > Fill > Color > More colors

Defaults > Property defaults > Line type label > Text color > More colors

Defaults > Property defaults > Text > Text color > More colors

Defaults > Startup defaults > Artwork Panels > Font and Color > Text Line 1 color > More colors

Defaults > Startup defaults > Dynamic Art > Label or Text color > More colors

Single Design > Select a filled or stroked object > Edit menu > Properties > Pick Fill Color and Pick
Stroke Color

Single Design > Select > Double-click a filled or stroked object > Properties > Pick Fill Color and Pick
Stroke Color

Single Design > Select a dimension > Edit  > Properties > Color > More Colors

Single Design > Select > Double-click a dimension  > Color > More Colors

Single Design > Paragraph Text > Color > More Colors

Single Design > Select text > Edit > Properties > Color > More Colors

Single Design > Select > Double-click a piece of text > Color > More Colors

Single Design > Hatch > More Options > Custom > Line Type / Stroke or Background / Fill > Color >
More Colors

Single Design > Select a hatched panel > Edit > Properties > Custom > Line Type / Stroke or
Background / Fill > Color > More Colors

Single Design > Select  > Double-click a hatched panel > Custom > Line Type / Stroke or
Background / Fill > Color > More Colors

Single Design > Edit > Property Defaults > Hatch > Custom > Line Type / Stroke or Background / Fill
> Color > More Colors

Single Design > Line Type Label  > More Options > Color > More Colors

Single Design > Line Type Label  > More Options > Text box > Fill > Color > More Colors

Single Design > Select a line type label > Edit > Properties > Color > More Colors

Single Design > Select  > Double-click a line type label > Color > More Colors

Single Design > Select a line type label > Edit > Properties > Text box > Fill > Color > More Colors

Single Design > Select  > Double-click a line type label > Text box > Fill > Color > More Colors

Single Design > Edit > Property Defaults > Line type label > Color > More Colors

Single Design > Edit > Property Defaults > Line type label > Fill > Color > More Colors

Single Design > Color Stock > Pick Color

Single Design > Artwork Panels > More Options > Font and Color > Text Line 1 > Color > More Colors

Single Design > Dynamic Art > More Options > Label or Text > Color > More Colors

Single Design > Select a Dynamic Art object > Edit > Properties > Label or Text > Color > More Colors
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CMYK Palettes Only

Single Design > Select > Double-click a piece of Dynamic Art > Label or Text > Color > More Colors

Choosing Default Color Palettes

You can specify a default color palette for ArtiosCAD to use in features that can use both RGB and
CMYK palettes, and features that support only CMYK palettes.

1. Click Options > Defaults.
2. Expand the Startup defaults catalog.
3. Double-click Color Palette Options.

 

 
4. In each pane of the Color Palette Options dialog box, select the palette to set as the default for the

type of feature.
5. Click OK to return to Defaults.

Canvas/Parts Options

Defaults for canvases and parts are in the Startup defaults catalog.
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The options in the Save Parts During Canvas Save group control what happens when you save a canvas.
You can choose to save only the canvas itself with Save only canvas, to Automatically save modified
parts, or Prompt to save parts, the default.

When revisioning a canvas, also save parts as revisions keeps parts revised to the same level as their
parent canvas. This is enabled by default.

In the Save Parts Dialog Settings group, choose what happens in the Save Parts dialog box. Use
Autoname for part filenames when available will automatically assign filenames to parts when you
have configured the Project or folder for autonaming. Default to Add to Bill of Materials controls the
state of the checkbox when saving a design, or publishing a new revision or version if you're using
ArtiosCAD Enterprise.

In the Part Filename Options group, choose how ArtiosCAD automatically names parts, either based on
the part name, or on the name of the canvas. Use Part Name as Filename sets the filename to that of
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the part. Generate Filename from Canvas sets the root of the part name to the canvas name, followed
by the Separator character(s) and a number that is the Number of digits.

In the Part Creations options group, Horizontal distance between parts and Vertical distance
between parts control the gutter between parts when converting to a canvas and using Auto Space
Parts. This gutter applies to outermost design lines in the part, not the part frames. Empty part
default width and Empty part default height control the size of new parts.

The right half of the dialog box controls how parts appear in the canvas.
 

 

Set the colors for the Active Part Frame Color, Inactive Part Frame Color, and Part Name Text Color
using the choosers. You can choose from a group of common colors, or click Other to access more
advanced color-setting options. Click OK when done.
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The options in the Part Frame Borders group control how ArtiosCAD shows part frame borders. No
Borders displays no frame and just the name of the part in its title bar. Corner Marks places small angle
brackets around each corner of the frame. Full Frame Border draws the entire frame around the part.

In the Inactive Part Background Fill group, choose how ArtiosCAD draws the screen behind inactive
parts. No Background Fill keeps just the normal drawing area color behind inactive parts. When you
choose this option, you may turn on Show Corner Marks on Active Part when Frames are Turned Off if
desired. Fill Inactive Parts shades inactive parts with the color specified in Inactive Part Background
Color. Fill Entire Canvas uses the Inactive Part Background Color to fill in the whole canvas except for
the active part.

Note:

ArtiosCAD draws no frames, borders, or shading when in Isolation mode.

When you select a layout part in a job, the other layout parts in that job use the same active
part frame highlight and border color.

The Production part frame highlight color is orange for production parts and gray for all other
parts.

Canvas Layout Options

To set default options for canvas layouts, click Startup defaults > Canvas Layout Options.
 

533



8 ArtiosCAD

 
In the Sheet group, set the values for the sheet size, margins, gutter, nesting choices, and quantities.
The width and height must be greater than zero. The gutter and margins must be greater than or equal
to zero. Alternately, you can choose a standard sheet size or a die press by clicking Standard Sheet
Sizes or Die Press Parameters, and use the values from those sources.
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To use formulas to set the sheet size, enter them in Sheet size formula X and Sheet size formula Y.
Hover over the information icon to display examples of suggested formulas and syntax. You may also
use a library function.

In the Nesting group, set the options for computing the nest as desired. Rotation can be No rotation,
180 rotation, 90 rotation or Any rotation. This applies to all parts in the layout. Fill direction can
be Horizontal or Vertical. This specifies the basic shape of the layout. If you set this to Horizontal,
any unused space in the layout is horizontal. Search time can be Very fast, Fast, Accurate, or Very
accurate. The faster the search, the less accurate the nest. For the strategy, Minimal waste creates
the layout with the least amount of waste. Minimal layout creates the layout with the least overrun
for the parts with a greater job quantity. Priority by size places the emphasis on making the closest
number of larger parts to the job quantity.

Choose the Sheet edge style from the drop-down list. It can be Edge only, Edge and margin, Edge and
corner, or Corner only.

Show part names in layouts controls if ArtiosCAD shows the names of parts in layouts or not. The
default setting is enabled.

Highlight layouts with different grains causes layouts with a grain direction different from the default
to appear with a yellow highlight.

Tool Layer Options

The Tool Layer Options dialog box in Startup defaults controls how ArtiosCAD automatically switches in
and out of layers in designs and canvases.
 

 

Automatically switch to appropriate layer turns this feature on and off.

Always prompt for Bleed and Varnish causes ArtiosCAD to always prompt for tools that would switch
to those layers.
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Switch only to layers of default class causes ArtiosCAD to only switch to layers whose classes match
their names. For example, if this option were enabled and you had a layer called Dimensions but it was
class Windows and Cutouts, ArtiosCAD would not switch to that Dimensions layer automatically when
you started a Dimensions tool.

Return to previous layer controls how ArtiosCAD behaves when you finish using the tool that changed
layers and activate a different tool.

Only display layers in print item constrains the list of layers ArtiosCAD shows when listing valid layers
to those in the current print item. If there is no print item defined, ArtiosCAD shows all layers.

Default Side for Geometry Macros

You can control if ArtiosCAD mirrors a geometry macro on placement with Mirror the result if needed
to match the design side in its entry in the Geometry Macro catalog in Defaults. This option is not
available for geometry macros used in Manufacturing.
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Rectangle from Line Options

In Startup defaults, the Rectangle from Line settings control if Panel from Line replaces the line you
click with a crease line, and if so, what type of crease line.
 

 

Preflight Defaults

There are a few different areas containing Defaults for Preflight.

Preflight Profiles

Preflight Profiles let you configure the conditions the Preflight module checks for, along with their
tolerances and severity. ArtiosCAD ships with four Preflight Profiles in Defaults > Preflight Profiles
that you should copy and customize to meet your needs.

When you double-click a Preflight Profile, ArtiosCAD opens a dialog box that shows the filename for the
Preflight Profile, a Browse (…) button to specify a new one, and an Edit Profile button.
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ArtiosCAD stores Preflight Profiles as zipped XML files for sharing with other Esko products. The
filename matches the name shown in the Defaults catalog with underscores replacing spaces. If you
rename the catalog entry, ArtiosCAD creates a new file containing that profile in ClientLib when you
save and exit Defaults.

Editing a Preflight Profile
1. Double-click the desired Preflight Profile.
2. Click Edit Profile. ArtiosCAD opens the Preflight Profile. In the example below, all nodes in the tree

are expanded.
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3. Review each condition on each tab as desired.

a) To enable a condition, check the checkbox before its name. To not check for a condition, clear
the checkbox before its name.

b) To see more detailed information about a condition, hover over the information icon after its
name to see a ToolTip.
 

 
c) To set the severity of a condition, change the entry in the drop-down list box beneath its name.

You can choose between Warning, Error, and Critical.
d) Set the tolerances for each condition as desired.

4. Click OK when done to return to the settings dialog box.
5. Click OK to return to Defaults.
6. Save and exit Defaults as usual.

Slotter Scorer Profiles

Slotter Scorer Profiles let you configure the sizes and properties of your slotter scorer machines
for use with Preflight. ArtiosCAD ships with four Slotter Scorer Profiles in Defaults > Slotter Scorer
Profiles that you should copy and customize to meet your needs. Create a profile for each machine and
organize them into folders as desired.

When you double-click a Slotter Scorer Profile, ArtiosCAD opens a dialog box that lets you specify
the filename for the Slotter Scorer Profile, a Browse (…) button to find a new one, and an Edit Profile
button.
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Editing a Slotter Scorer Profile
1. Double-click the desired Slotter Scorer Profile.
2. Click Edit Profile. ArtiosCAD opens the Slotter Scorer Profile.

 

 
3. Select each dimension in the Dimension column and enter appropriate minimum and maximum

values.
4. Select or deselect Glue flap on width panel and Glue flap on length panel as appropriate.
5. If this machine supports add-in partial dies for small pieces of additional geometry, select Allow

inline partial die.
6. Enter the minimum and maximum angles for the top and bottom of the glue flap.
7. If your glue flaps have a short horizontal line connecting them to the panel, enter their longest

allowable length in Maximum glue flap extend line length.
8. Click OK when done to return to the settings dialog box.
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9. Click OK to return to Defaults.

Setting the Anomaly Sort Order

The default order in which ArtiosCAD displays anomalies in the Preflight pane is by severity, then
count, then name of the condition, but you can change the sort order.

1. Click Options >  Defaults > Startup defaults and double-click Preflight Options. ArtiosCAD opens
the Preflight Options dialog box.
 

 
2. Click the property to move and then click the up arrow to move it up in the sort order or the down

arrow to move it down in the sort order.
3. Click OK to return to Defaults.
4. Save and exit Defaults as usual.

Autopanning Options

Autopanning is the way ArtiosCAD can change the view as you design a single design or canvas.
Configure it in Defaults > Startup defaults > Automatic Panning Options.
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Enable automatic panning turns the feature on and off.

Hotspot border separation controls the width of the area at the edge of the design pane that triggers
autopanning. The range is from 1 to 32 pixels.

Delay before automatic panning starts controls how long you have to hover over the arrow before
autopanning starts. The range is from 1 second to 1/20th of a second.

Automatic panning speed controls how fast it goes. The range is from 1 pixel per pan to 30 pixels per
pan.

Zoom out to keep geometry in view controls whether ArtiosCAD just moves the view or zooms out too.
This is enabled by default.

Warn me when too far from the origin is the distance at which ArtiosCAD displays a red cursor and
warning ToolTip. It is initially set to 10000 mm / 393.701 inches. The minimum warning distance is a
meter, or 1000 mm / 39.3701 inches.

Use with Select tool is not selected by default.

3D Quick Views Defaults

When you define Quick Views while in 3D, ArtiosCAD saves them automatically to User Defaults. The
Isometric Quick View is stored in Shared Defaults. In both cases, they are stored in Options > Defaults >
Startup defaults > 3D Quick Views.
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As with all Defaults, ArtiosCAD combines them when you use the software.

To add a new Quick View:

1. Click the plus sign (+).
2. Enter a name for the new Quick View.
3. Set the view angle, elevation, and roll angle as desired by either typing or using the arrows while the

Quick View is selected.
4. To add another Quick View, click the plus sign again.

To remove a Quick View, select it and click the minus sign (-).

To rename a Quick View, double-click it and enter the new name.

Click OK to save the changes and return to Defaults.

Menu Plug-Ins

Menu Plug-Ins allow you to add custom entries to ArtiosCAD menus and the menu toolbar. There
are two types, Automation and Output. Automation plug-ins are meant for integrating with other
applications by way of XML files and require the expertise of your IT department to create and
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maintain. They have to have a component supplied by you that connects to ArtiosCAD. Output plug-ins
give an easy way to launch an Output.

Automation Plug-Ins

To define a new Menu Plug-In for an automation connection, right-click in Defaults, and click New >
Menu PlugIns. Then right-click that entry in Defaults and click New > Data. Enter a name for the new
connection and double-click it to open its properties.
 

 

The Label is what the menu entry will be. Set the type to Automation.

Check the appropriate checkboxes for the modules in which this menu command will be available.
You can also choose an existing menu to put it on, or to create a new menu. Position Index within
Menu controls where on the command is on the menu. Note that the Product Information page that
may appear when ArtiosCAD starts counts as an open document so if you check Available when no
documents are open, the command will not appear on a menu until you close the Product Information
page.

You can choose to save the document before every time this Output executes by enabling
Automatically Save document before executing. ArtiosCAD Enterprise users have an additional
option to Run after every document Save.

The PlugIn Application to Launch is the external program that ArtiosCAD calls when this menu
command is clicked.
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Block ArtiosCAD until complete prevents the ArtiosCAD user from doing anything until the external
application completes.

Add Input Parameter causes ArtiosCAD to add a full path to a temporary XML file as a parameter to
the application specified. This is a full path to a temporary XML file that ArtiosCAD creates which
contains database and variable details for the current active document. When you choose this option,
ArtiosCAD appends this parameter when the command is issued. For example, if you specify Notepad
as your application to launch and you select Add input parameter, then ArtiosCAD issues the command
notepad C:\...\sometmpfile.tmp. If the workspace is a canvas, all the canvas XML and XML for every
Part is included.

Add and Process Return parameter causes ArtiosCAD to add a full path to a temporary XML file
which serves as the automation XML file coming back to ArtiosCAD. This is the file that ArtiosCAD will
process upon the completion of the executable. As with the Input parameter, when you choose this
option, ArtiosCAD appends the full path to the return XML file. It is the responsibility of the custom
application to accept this parameter on the command line and populate the file with the Automation
XML.

Please note that the two file parameters C:\Temp\Inputfile.xml C:\Temp\Outputfile.xml
are not specified in the Application to Launch fields but are automatically appended by ArtiosCAD
when the command is issued. It is the responsibility of developer of the custom application to accept
these two command line parameters. This application would typically process and act upon the XML
contained in the input file and then generate the automation XML and save it in the output file (second
parameter).

The following example shows the XML for how to make a new single design, set the board, run a
standard, and seed the LWD variables.

<ESKO_ARTIOSCAD Units="I"> 
<DOCUMENT Type="NEW_ARD"> 
<DOCACTION Type="SET_BOARD" ID="10"/> 
<DOCACTION Type="RUN_STD" Wksp="F0200W"> 
<SEEDVAR Name="L" Value="10"/> 
<SEEDVAR Name="W" Value="11"/> 
<SEEDVAR Name="D" Value="12"/> 
</DOCACTION> 
</DOCUMENT> 
</ESKO_ARTIOSCAD>

Output Plug-Ins

To define a new menu entry for an Output, right-click in Defaults, and click New > Menu PlugIns. Then
right-click that entry in Defaults and click New > Data. Enter a name for the new connection and
double-click it to open its properties.
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The Label is what the menu entry will be. Set the type to Output.

Check the appropriate checkboxes for the modules in which this menu command will be available.
You can also choose an existing menu to put it on, or to create a new menu. Position Index within
Menu controls where on the command is on the menu. Note that the Product Information page that
may appear when ArtiosCAD starts counts as an open document so if you check Available when no
documents are open, the command will not appear on a menu until you close the Product Information
page.

You can choose to save the document before every time this Output executes by enabling
Automatically Save document before executing. ArtiosCAD Enterprise users have an additional
option to Run after every document Save.

Click Browse (…) at the end of the Output to Launch field to choose the Output to run with this menu
command.

An example of an Output menu plug-in looks like this.
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Configuring USB Mouse Buttons

If you have a mouse with a scroll wheel, use Defaults > Startup defaults > Mouse Settings to control
what the mouse buttons do.
 

 

Some button actions execute when you press the button; others execute when you release the button.
ArtiosCAD resumes the previous activity on button release.

The available actions are:

• CloseUp with options 1 (the normal CloseUp window)
• CloseUp with options 2 (the larger, more zoomed-in CloseUp window)
• Close all CloseUps
• Pan view
• Zoom in/out
• Change view angle in 3D view
• Unassigned

Not all actions are available for every situation; for example, you can only select Change view angle in
3D view when changing one of the 3D view options.
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Choose the desired actions from the drop-down list boxes and click OK when done to return to
Defaults.

Note:  You cannot change the Right mouse button released action as the context menu is core
functionality of ArtiosCAD.

Assembly Instructions Defaults

Two catalogs in Defaults affect Assembly Instructions, Annotation Symbols and Assembly Instructions.
 

 

The Annotation Symbols catalog holds the entries for the Annotation Symbols tool. Add and remove
entries as desired. The symbols are ArtiosCAD workspaces.

In the Assembly Instructions catalog, you can set the Defaults for Page and Panel options (as described
in the Changing Instruction Page Properties and Changing Instruction Panel Properties sections in 3D.
You can also add and remove page sizes used by the Add Instruction Page tool in the Page Table.

Defaults for Manufacturing Workflows

ArtiosCAD’s wealth of configuration options means that it can sometimes be hard to find the setting to
change for your particular situation.

To help with that, this section is an organized reference of dialog box images with each option listed
so that if you search this documentation, this dialog box will appear and you will know where to set the
option or value you need.

Blanking Machine Defaults

Options in this section are for blanking machine parameter sets.

Frame
 

549



8 ArtiosCAD

 

• Bottom Position
• Offset from bottom of sheet
• Offset from first knife
• Offset from offset to bottom of frame

• Pieces
• Vertical Pieces
• Thickness
• Length
• Horizontal Pieces
• Thickness
• Maximum length
• Trim to frame
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• Frame kit #

• Support bar #

• Max Size Restrictions
• Min to inner
• Max to inner

Lower Blanker Board Wood Alignment
 

 

• Center line type
• None
• Notch
• Mark
• Workspace
• Notch height for center
• Notch width for center
• Mark length for center
• Workspace
• Mirror
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Non-Stop Swords
 

 

• Machine Standard Sizes
• Narrow
• Wide

Photocells
 

 

• Machine Photocell Range
• Maximum Distance
• Minimum Distance

Pressers
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• Machine Presser Zone Restrictions
• Above and below
• First knife
• Last knife
• Mounting bars

Tie-Bolt Holes
 

 

• Machine Upper Board Mounting Bars
• Distance from bottom of upper board to
• First mounting bar
• Second mounting bar
• Maximum distance from centerline to
• Tie-bolts

Upper Blanker Board Requirements
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• Maximum height
• Maximum width
• Minimum height

Upper Blanker Board Wood Alignment
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• Center line type
• None
• Notch
• Mark
• Workspace
• Notch height for center
• Notch width for center
• Mark length for center
• Workspace
• Mirror

Blanking Defaults

Options in this section are for blanking parameter sets.

Blank Holes
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• Blanker Type
• Lower board
• Grid & board (combo tool)
• Grid (no board)
• Lower board - merged blanks
• Contour
• Trim slots less than
• Offset
• Blend

• Adjusted Offsets
• Use
• Offset
• Single cut horizontal lines on inside panel
• Single cut horizontal lines opposite inside panel
• Single cut horizontal lines
• Single cut vertical lines on inside panel
• Single cut vertical lines opposite inside panel
• Single cut vertical lines
• Single cut diagonal lines
• Layout side vertical lines
• Layout bottom horizontal lines
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• Layout top horizontal lines
• Design top/bottom horizontal lines
• Design side vertical lines

Frame Clearance
 

 

• Formula and Parameters
• Single-cut in X
• Single-cut in Y
• Formula Type
• Standard
• Custom
• Separator
• Jogger
• Extra
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Frame Construction
 

 

• Use frame kit
• Quicklock
• Corners
• Centerline device
• Mounting/scrap rails
• Lateral support bars
• Overhang

Frame Size
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• Edge specification method
• Maximum size
• Suggested size
• By clearance
• Suggested height
• Suggested width

Grid
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• Trim/Extend Parameters
• Automatically trim/extend on finish
• Trim to grid
• Grid bar overlap
• Vertical frame overlap
• Horizontal frame overlap
• Width
• Offset
• Bend radius

Lower Blanker Board Allowances
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• Left allowance
• Right allowance
• Top allowance
• Bottom allowance
• Relative to

Lower Blanker Board Wood Corners
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• Square
• Blend
• Chamfer
• Radius for corner
• Chamfer for corner

Non-Stop Swords
 

 

• Custom
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• Total Width
• # of Prongs

Pusher Details
 

 

• Air Hole
• Inset from edge
• Corner blend
• Duplicate in upper board
• Slot blend
• Merged hole
• Reinforce large holes
• Maximum size
• Bar thickness
• Blanker Pusher Pins
• Distance from edge
• Preferred pin-to-pin distance
• Blanker pusher pin
• Pusher Identifier Text
• Font
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• Font size
• Duplicate in upper board

Pusher Edge
 

 

• Trim to hole & grid
• Merged pusher
• Contour
• Trim slots less than
• Inset
• Corner blend
• Slot blend
• Adjusted Insets
• Single cut horizontal lines
• Single cut vertical lines
• Single cut diagonal lines
• Layout side vertical lines
• Layout bottom horizontal lines
• Layout top horizontal lines
• Design top/bottom horizontal lines
• Design side vertical lines
• Use
• Inset
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Support Bars
 

 

• Defined By
• Width
• Components

 

 

• Rail
• From machine
• Adhesive

Tool Controls
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• Photocell
• Width

Upper Blanker Board Edge Size
 

 

• Edge specification method
• Maximum size
• Suggested size
• Specify allowances
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• Suggested height
• Suggested width
• Left allowance
• Right allowance
• Top allowance
• Bottom allowance

Upper Blanker Board Wood Corners
 

 

• Corner relief
• Square
• Blend
• Chamfer
• Radius for corner
• Chamfer for corner

Counter Defaults

Options in this section are for plastic counters and steel counters.
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Tool Angles, Widths (Plastic)
 

 

• Type of counter
• Plastic counter
• Steel counter
• Maximum chamfer diameter
• Counter thickness
• Crease channel depth
• Chamfer depth
• Crease channel width
• With grain
• Cross grain
• With grain angle limit
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• Rebuild creases only
• Tool angles
• With grain
• Cross grain

Tool Angles, Widths (Steel)
 

 

• Type of counter
• Plastic counter
• Steel counter
• Counter thickness
• Crease channel depth
• Crease channel width
• With grain
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• Cross grain
• With grain angle limit
• Tool angles
• With grain
• Cross grain

Crease Channel Widths
 

 

• Crease channel width
• With grain
• Cross grain
• Additional crease channel widths
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Reverse Creases
 

 

• Angle
• Width
• Set back
• Shoulder
• Insert
• Counter material
• Off the counter
• Crease width
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Reverse Creases (Steel)
 

 

• Angle
• Width
• Set back
• Shoulder
• Insert
• Counter material
• Off the counter
• Crease width
• Geometry macro
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Reverse Cuts
 

 

• Angle
• Width
• Set back
• Shoulder

Reverse Cuts (Steel)
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• Angle
• Width
• Set back
• Shoulder
• Geometry macro

Embossing
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• Emboss relief width

Position Holes
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• Workspace Name
• Specify

Tack Bridges
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• Tack bridge width

Name
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• Block
• Fast Block
• Rotation
• Mirror
• Size

Crease Channel End (Steel)
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• Shape
• Round
• Square
• Land
• Tool Radius
• Creases meet at sharp angle
• No processing
• Priority equal
• Priority middle
• Priority side
• Merge
• Cutback
• Merge radius
• Minimum channel length
• Minimum length
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Crease Cutback (Steel)
 

 

• Crease Cutback
• From channel end
• From cut line
• Crease cutback
• Different top and bridge

Cut and Crease (Steel)
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• Treatment of Cut and Crease
• Single channel like a crease
• From end of segment plus channel width
• Land
• From end of segment
• No channel

Frame (Steel)
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• Frame
• Relative to
• Lead edge
• Dieboard
• Machine reference point
• X offset
• Y offset
• Rectangle
• Width
• Height
• Geometry macro
• Hanger holes pattern
• Position
• Workspace
• Offset
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• Dieboard registration holes pattern
• Name/logo geometry macro
• Position
• Offset
• Rotate

Die Press Defaults

Options in this section are for die press parameter sets.

Blanking Machine Name
 

 

Die Board Balance Knives
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• Minimum distance to first
• Minimum distance to edge
• Minimum distance between knives
• Percentage of Bobst Formula
• Balance Knives Formula
• Rule saver formula
• Rule to design blank
• Rule to stripping blank
• Maximum cutting zone height
• Maximum cutting zone width
• Pointage

Die Board Custom Tool Set
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• Use geometry macro
• Dieboard Geometry Macro
• Post Run Geometry Macro

Die Board Wood Alignment
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• Center line type
• None
• Notch
• Mark
• Workspace
• Notch height for center
• Notch width for center
• Mark length for center
• Workspace
• Mirror

Die Board Wood Dimensions
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• Suggested height
• Suggested width
• X offset from ref. pt.
• Y offset from ref. pt.
• Left allowance
• Right allowance
• Top allowance

Die Board Wood Edge
 

587



8 ArtiosCAD

 

• Height specification
• Maximum size
• Suggested size
• Specify allowances
• Width Specification
• Maximum size
• Suggested size
• Specify allowances
• Centered dieboard vertically
• Positioned by
• Stripping rules
• Layout

Front Waste Separator Wood Alignment
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• Upper
• None
• Notch
• Mark
• Notch height for center
• Notch width for center
• Mark length for center
• Lower
• None
• Notch
• Mark
• Notch height for center
• Notch width for center
• Mark length for center

Front Waste Separator Wood Dimensions
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• Upper height
• Lower height
• Left allowance
• Right allowance
• X offset from ref. pt.
• Y offset from ref. pt.

Front Waste Separator Wood Edge
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• Positioned by
• Stripping rules
• Layout

Intelligent Layout Cost Center
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• Default cost center
• Maximum rule length

Lower Stripping Board Wood Alignment
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• Center line type
• Notch
• Mark
• Workspace
• Notch height for center
• Notch width for center
• Mark length for center
• Workspace
• Mirror

Lower Stripping Board Wood Dimensions
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• Suggested height
• Suggested width
• X offset from ref. pt.
• Y offset from ref. pt.
• Left allowance
• Right allowance
• Top allowance

Lower Stripping Board Wood Edge
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• Edge specification method
• Maximum size
• Suggested size
• Specify allowances
• Positioned by
• Stripping rules
• Layout

Lower Stripping Board Max Min Values
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• Maximum height
• Maximum width
• Minimum height
• Minimum width

Die Press Default Sheet Edge
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• Left edge
• Right edge
• Bottom edge
• Top edge

Die Press Default Sheet Size
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• Maximum height
• Maximum width
• Minimum height
• Minimum width

Die Press Hole Patterns
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• Image Die Side
• Die knife side
• Die back side
• Undefined (pre 5.0 compatibility only)
• Mounting Holes Positioning
• Machine reference point
• Dieboard center
• Die Mounting Hole Pattern
• T-nut clearance
• Area of effectiveness
• Lower stripping hole pattern
• Front waste separator hole pattern

Die Press Reference Point
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• Machine Reference Point X Basis
• Center of sheet
• Center of layout design
• Machine Reference Point Y Basis
• Bottom of sheet
• Bottom of layout design
• X offset from basis
• Y offset from basis

Die Press Registration
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• Lower support bar hole design
• Gripper finger design
• Upper/lower alignment hole design
• Handholds

Die Press Wood Max Min Values
 

 

• Maximum height
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• Maximum width
• Minimum height
• Minimum width

Rotary Shrink Stretch Factor
 

 

• Wood thickness
• Rotary Dieboard
• Rotary Dieboard Properties
• Cylinder diameter
• Design to wood level shrink
• Cylinder to wood level stretch

Note:

Rotary Dieboard is what tells ArtiosCAD that this is a rotary press.

Scrap Knives Other
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• Corner offset
• Bend length
• Arc sensitivity
• Minimum bend angle

Scrap Knives Size
 

 

• Horizontal
• Size
• Vertical
• Size
• Offset
• Minimum size
• Thin pieces
• Length
• Width

Scrap Knives Standard Rules
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• Standard Rules
• Length
• Hook
• Radius

Upper Stripping Board Wood Alignment
 

 

• Center line type
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• None
• Notch
• Mark
• Workspace
• Notch height for center
• Notch width for center
• Mark length for center
• Workspace
• Mirror

Upper Stripping Board Wood Dimensions
 

 

• Suggested height
• Suggested width
• X offset from ref. pt.
• Y offset from ref. pt.
• Left allowance
• Right allowance
• Top allowance

Upper Stripping Board Wood Edge
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• Edge specification method
• Maximum size
• Suggested size
• Specify allowances
• Positioned by
• Stripping rules
• Layout

Upper Stripping Board Wood Max Min Values
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• Maximum height
• Maximum width
• Minimum height
• Minimum width

Manufacturing Defaults

Options in this section are for manufacturing parameter sets that contain settings independent of any
specific die or printing press.

Automatic Stripping Carrier Rules
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• Length rounding value
• Minimum length
• Minimum extension
• Flap length
• Blend radius
• Pointage
• Flap points right
• Rule length type
• Use run length
• Use rule length
• Use design file for end
• Die knife side
• Die back side

Automatic Stripping General Preferences
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• Internal
• Use blocks
• Use push pins
• Use rules
• External
• Use blocks
• Use push pins
• Use rules
• Strip Tool settings
• Lower
• Upper
• Internal
• External

Automatic Stripping Interference
 

 

• Additional offset from modifier lines
• Blocks
• Pins
• Rules
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Automatic Stripping Lower Stripping

• Internal
• Offset
• External
• Use different offsets
• Offset
• Offset below wing
• Strip sides
• Strip back

Automatic Stripping Upper Block Pins
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• Preferred pin-to-pin distance
• Default block pin

Automatic Stripping Upper External Blocks
 

 

• Offset from knife
• Offset back strip rules
• Offset above barline
• Offset below barline
• Offset above wing
• Slot width
• Type
• Full
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• Fixed width
• Offset from back edge
• Offset from side edge
• Wood strip width

Automatic Stripping Upper External Pins
 

 

• Preferred pin-to-pin distance
• Additional offset
• Additional offset back strip rules
• Additional offset above barline
• Additional offset below barline
• Additional offset above wings
• Default push pin

Automatic Stripping Upper External Rules
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• Minimum edge-to-rule distance
• Maximum edge-to-rule distance
• Maximum rule length
• Minimum rule length
• Minimum rule-to-rule distance
• Additional offset
• Additional offset back strip rules
• Additional offset above barline
• Additional offset below barline
• Additional offset above wings
• Pointage
• Bridging formula

Automatic Stripping Upper Internal Blocks
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• Block parameters
• Offset
• Offset from carrier rule
• Minimum block area in square inches
• Slot width
• Use only if strips entire hole

Automatic Stripping Upper Internal Pins
 

 

• Preferred pin-to-pin distance
• Additional offset
• Additional offset from carrier rule
• Default push pins

Automatic Stripping Upper Internal Rules
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• Set rules to use
• Additional offset
• Additional offset from carrier rule
• Use generic rule
• Generic rule parameters
• Minimum edge-to-rule distance
• Maximum edge-to-rule distance
• Minimum rule length
• Minimum line length
• Minimum rule-to-rule distance
• Pointage
• Bridging formula

Blanking Parameter Name
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• Blanking parameter name

Burn Name
 

 

• Character height
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• Font
• Fast block
• Block
• Rotate
• Horizontal
• Rotate 90
• Rotate -90

Die Board Wood Corners
 

 

• Corner relief
• Square
• Blend
• Chamfer
• Radius for corner
• Chamfer for corner

Front Waste Separator Offsets
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• Separator
• Upper only
• Upper and lower
• Lower only
• Follow offset
• Use mounting bar

Front Waste Separator Wood Corners
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• Corner relief
• Square
• Blend
• Chamfer
• Radius for corner
• Chamfer for corner

Lower Stripping Board Wood Corners and Tabs
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• Corner relief
• Square
• Blend
• Chamfer
• Radius for corner
• Chamfer for corner
• Make tabs
• Tab width
• Use separator
• Separator design file

Rubbering
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Rule Path Params
 

 

• Optimization
• No optimization
• Simple optimization
• Merge rule paths
• Optimize rule paths
• Rebridge rule paths
• Rule path direction
• Out from die split
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• Lead # Trail
• Left # Right
• Trail # Lead
• Right # Left
• When rule paths cross
• Favor horizontal
• Favor vertical
• Reduce number of rule paths
• Maximum horizontal distance for rotary
• Maximum vertical distance for flat
• Single rule path for small waste area
• Maximum diameter of circle
• Maximum width to use rotary rule
• Maximum height to use flat rule
• Mark length

Startup Defaults Default Bridging Formula
 

 

Startup Defaults Default Nick Formula
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Startup Defaults Die Side
 

 

• Options on restore
• Use as is
• Use default
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• Warn if it differs from default
• Default die side
• Knife side up
• Back side up

Startup Defaults Flute/Grain
 

 

• Options on restore
• Use as is
• Use default
• Warn if differs from default
• Default flute/grain direction
• Vertical
• Horizontal

Startup Defaults Layout Gutters
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• Touch bleed outlines
• Use gutters
• Gutter X
• Gutter Y
• Gutter X2
• Gutter Y2
• Gutter 1
• Gutter 2
• Gutter 3

Startup Defaults Sheet Size Rounding Value
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• Sheet size rounding value

Startup Defaults Side
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• Options on restore
• Use as is
• Use default
• Warn if differs from default
• Default side
• Inside
• Outside

Stripping Rules Bridges
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• Width
• Bridges
• None
• One
• Two
• At start
• At end
• At start and end
• Default

Stripping Rules General
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• Pointage
• Drag snap angle
• Start point offset
• Strip between design for mounting bar
• Add bend

Stripping Rules Hook Dimensions
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• Direction
• Leading
• Trailing
• Length
• Radius
• Angle

Stripping Rules Hook Options
 

630



8ArtiosCAD

 

• Hook type
• “L” with radius
• “L” with corner
• “T”
• “T” with corner
• Placement
• None
• Top, sides, none on bottom
• All four sides

Stripping Rules Stripping Edge
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• Left overrun
• Right overrun
• Bottom overrun
• Top overrun
• Stripping edge based on
• Sheet
• Layout
• Die edge

Tack Bridges
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• Die board
• Stripping boards
• Interior formula
• Exterior formula
• Air holes formula
• Blanker
• Interior formula
• Exterior formula

Upper Stripping Board Block Pins
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• Block pin
• Size
• Base size
• Block pin
• Clearance
• Workspace

Upper Stripping Board Interference Stripping
 

 

• Corner style
• Round
• Square
• Chamfer
• Add pin
• Width
• Pin offset
• Push pin

Upper Stripping Board Push Pins
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• Push pin
• Size
• Base size
• Shoulder
• Clearance
• Workspace

Upper Stripping Board Wood Corners
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• Corner relief
• Square
• Blend
• Chamfer
• Radius for corner
• Chamfer for corner

Printing Press Defaults

Options in this section are for printing presses.

Intelligent Layout
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• Default cost center

Sheet Edge
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• Left edge
• Right edge
• Bottom edge
• Top edge

Sheet Size
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• Maximum height
• Maximum width
• Minimum height
• Minimum width

Rubber Defaults

Options in this section are for rubber defaults.

Bolt Holes
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• Subtract bolt holes
• Die bolt hole clearance diameter
• Die registration hole clearance diameter
• Offset from laser position hole

Breaker Knives
 

 

• Stop at sheet edge
• Extend to end of breaker knife
• Extend past breaker knife

Crease Mask
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• If no plastic cover, area where rubber stays away from a crease
• Rubber in thin areas by a crease
• Offset from plastic cover edge
• Offset from edge of crease rule

Cut/Crease
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• Treat cut/crease
• Like cuts
• Like creases
• Use parameters below

General
 

 

• Add blend
• Fixed width
• Blend radius
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• Open out
• Open out tack width
• Fill
• Make splits
• On bridges
• At corners
• Both
• Maximum length
• Maximum length inside
• Maximum length straight
• Split width
• Minimum length
• Trim gap
• Trim against counter
• Counter trim
• Trim lead edge
• Make plastic cover

Layout
 

 

• Trim
• Gutter
• Nesting tries
• Grouping
• Manual
• None
• Low
• Medium
• High

Plastic Cover
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• Only in waste areas
• Offset from cut
• Offset from crease
• Subtract bolt holes
• Die bolt hole clearance diameter
• Die registration hole clearance diameter
• Offset from laser position hole
• Left allowance
• Right allowance
• Top allowance
• Lead edge
• Relative to
• Sheet
• Layout

Rubber Types
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• Selection name
• Selection
• Use selection
• Width
• Offset from side of rule

Separators
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• Distance between separators
• Inset from start of line
• Use separators on slot rubber
• Width
• Square
• Width
• Pointed
• Round
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9.  Getting started with ArtiosCAD

Welcome to ArtiosCAD

The fundamental purpose of ArtiosCAD is to turn your creative thoughts into business for your
company. Speed, eciency, and accuracy are all essential to providing the best product to your
customers.

This book is intended for people with experience using the Microsoft Windows family of operating
systems who are just starting to use ArtiosCAD.

For the latest information on system requirements, please go to the Esko website and search for
system requirements.

Your system may not have all of the features described in this publication. Contact your Esko
salesperson for information about purchasing features not installed on your system. Also refer to http://
www.esko.com for more information.

You must have local administrative privileges to fully configure ArtiosCAD.

Changing the ArtiosCAD language

You can change the language of ArtiosCAD and its associated programs run in as desired.

This change affects all users on a computer.

1. Click  Esko > ArtiosCAD > Switch ArtiosCAD Language.
2. In the ArtiosCAD Language Selection Tool dialog box, select the new language from the drop-down

list box and click OK. Language names are always shown as they appear natively.
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3. The language selection tool will change the name of the default shortcuts (the ones in the Start

menu in the ArtiosCAD program folder and on the desktop) as appropriate.
4. Restart ArtiosCAD to run in the new language.

This tool changes the following:

• ArtiosCAD (both Standard Edition and Enterprise)
• DataCenter Admin
• Configure Floating Licenses (only changes the name)
• Migration Tools folder name
• ArtiosCAD Enterprise <Version> Migration
• Defaults Migration
• DWB DataLoader
• DWB Export
• Esko ArtiosCAD Database Export
• Esko ArtiosCAD Database Loader
• Esko ArtiosCAD Database Migration Export
• Esko ArtiosCAD Database Migration IMport

Starting ArtiosCAD

To start ArtiosCAD, log on to your system if necessary and then do the following:

1. Click Start, then point to All Programs.
2. Point to the Esko > ArtiosCAD folder in the Start menu, and then click the version of ArtiosCAD you

have installed.
3. If this is the first time you are starting ArtiosCAD after installing it, it will prompt you for licensing

information. Please refer to the next section for more information.
4. The ArtiosCAD startup screen will appear.
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5. The ArtiosCAD main window will replace the startup screen.

If this is the first time you are starting ArtiosCAD, it will show the Product Information page. You
may be prompted to accept cookies.
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Click Don’t show this again to hide the Product Information page on subsequent startups. It will
appear again when you install a new version, or after about 100 days to make sure you see the latest
information. You can also access this page in a Web browser by clicking Help > ArtiosCAD News.

If you have hidden the Product Information page, the main window looks like this.
 

 

ArtiosCAD is now ready for use.

Entering Licensing Information

The first time you start ArtiosCAD, it will prompt you to enter licensing information before the splash
screen appears for ArtiosCAD Standard Edition and after the login dialog box for ArtiosCAD Enterprise.

1. In the Welcome to ArtiosCAD dialog box, click the licensing method to use: I received an HTML file
with a Product Key, I know the name of my License Server, or I have an Esko ID to sign in and to
use my Subscription.
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2. If you chose the HTML file with product key option, the normal Esko Activate Local License wizard

starts. Proceed as instructed on the screen.
 

 
For more information, please refer to the Local License Manager documentation available at http://
www.esko.com/support.
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3. If you chose the license server option, enter the name of your license server and click Connect. To
specify a specific network port on the license server, use the syntax port@servername.
 

 
If all network licenses are in use, ArtiosCAD displays an error message. Click Show licenses
currently in use to see a list of who is using a license so you can ask another user to release a
license. For more information, please refer to the Network License Manager documentation
available at  http://www.esko.com/support.

4. If you chose the Esko ID and subscription option:
a) Enter your email address and password for your Esko ID and click Sign In.

 

 
b) Once the license is initialized successfully, click anywhere in the dialog box to continue starting

ArtiosCAD.
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For more information, please refer to the Local License Manager documentation available at 
http://www.esko.com/support.

Changing the License Location

If you need to change the ArtiosCAD license location and your current license still works, close all
documents and click Help > License Location.
 

 

Choose Use Local License to use either a local or a subscription license.

Choose Use Network License to use a network license provided by a license server. ArtiosCAD will also
use any available local or subscription licenses in addition to the network one.

Click OK to apply the change and return to ArtiosCAD.

If your current license no longer works, ArtiosCAD will prompt you to choose a license method when it
starts.
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Note:

If you need to change the license location on a system running both 32-bit and 64-bit versions,
change it using the 64-bit version.

Signing Out of Your Subscription

Note:  You only need to sign out if you want to release your license. You do not need to sign out
just to exit ArtiosCAD.

To sign out of your subscription license and quit ArtiosCAD, do the following:

1. Close all open ArtiosCAD documents.
2. Click Help > Sign Out.
3. In the ArtiosCAD Sign Out dialog box, click Sign Out & Quit.

 

 
4. ArtiosCAD releases your subscription license and closes. The next time you start it, ArtiosCAD will

prompt you for license information.

Using a Subscription License in Addition to Another License

To use a subscription license in addition to another local or network license, use Sign in on the Help
menu of ArtiosCAD with no documents open.

To stop using it, close all open documents and click Sign Out on the Help menu, then click Sign Out &
Quit.
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Note:

A subscription license is considered a local license and will not work if you are using Remote
Desktop or another terminal emulator.

Signing in and Out of Optional Features

You may have subscription licenses for optional features that you share with your colleagues as none
of you need them all the time. With no documents open, use Help > Sign In/Out Optional Features to
access the optional features. Click Sign In next to the feature to use, and follow the instructions.

When you are done using the optional feature, it is a best practice to sign out of it so others may use
the license. Click Help > Sign In/Out Optional Features and then click Sign Out of the feature to release
its license.

Dashboard

Esko collects anonymous usage data about how you use the licenses and features of ArtiosCAD to
continually improve the software for your benefit. If you want to link this anonymous data to your Esko
ID so that you can see, for example, how many licenses are being used and where in order to prioritize
investments and allocations, click Help > Dashboard and follow the on-screen instructions to create
your Dashboard. You have to explicitly opt in for the data to be linked to your Esko ID.

ArtiosCAD will ask you on first launch if you want a Dashboard.
 

 
Click Yes, I want a dashboard and follow the instructions to create one. If you don’t want one now, click
Not now.

If you change your mind later, opting out by clicking Help > Dashboard > Opt Out de-links your Esko ID
from the data collection.
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As of this writing, the data collection is always on; opting in or out only changes its identification.

Concepts and Ideas in ArtiosCAD

A typical workflow

The process of creating boxes, either folding carton or corrugated, is usually a logical progression.
First you design the box and embellish it with graphics from your art department, from the customer,
or graphics that you designed yourself. Then you print it on a desktop printer for review. At this point,
you may export it to a different format for use by others. You could also fold the box in 3D to make sure
all the dimensions work together. Sometimes a specification sheet of the folded design is created
to send to the customer for approval. If approved, samples are made. If the samples work and are
approved, manufacturing tools for the box are made. These manufacturing tools then are used in
production of the box, and the box is shipped to the customer.

Tools

Work in ArtiosCAD is completed using tools found on toolbars. Select a tool by clicking it with the
mouse cursor. The selected tool will prompt for information in the Status bar and guide you using
graphical feedback (drag). The toolbar master controls determine which toolbars are visible.

Changing the view

The way a design is viewed in ArtiosCAD can be customized to show different information. The
structural properties of the design remain the same throughout - only the presentation changes. Three
elements control the display – the Zoom and Pan commands, the View mode, and the plotting style.

Zooming in and out
ArtiosCAD lets you view your design from different distances. This distance is set using the Zoom
tools. You can zoom in on a particular area so that you can see minute tolerances, or you can zoom
back so far that the design becomes a dot on the screen.

 Zooming in with the Zoom Rectangle tool means the design is displayed in more detail. Either
click and drag a rectangle to indicate an area to zoom into, or click a coordinate to zoom in on that
coordinate.

 Zooming out with the Zoom Out tool means the design is viewed in less detail.

 The Center-Point Zoom tool, when clicked, prompts you to click the center of an area to be
zoomed in upon, and then to drag to the corner of that same area. Release the mouse button to
perform the zoom.
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If you zoom in on an imported Adobe Acrobat PDF graphic and you have purchased the PDF option,
High graphics mode in the View Mode dialog box enables sharper resolution as you zoom in. High
graphics mode is covered in depth later in this manual.

Autopanning
ArtiosCAD has a feature called autopanning that automatically changes the view as you approach the
edge of the design pane.

Autopanning is available when:

• You have the feature enabled in Defaults > Startup defaults > Automatic Panning Options. See the
Defaults chapter for more information about its options and configuration.

• You’re working in a single design or canvas
• You’re using a tool with drag and not holding a mouse button or pressing a keyboard accelerator
• You’re not near an item of geometry, a construction line, or dimension text

When you approach the edge of the design pane, ArtiosCAD displays an arrow.
 

 
There are eight arrows - the four corners, up, down, left, and right.

Hover over the arrow to activate autopanning.
 

 

The arrow turns red and ArtiosCAD displays a warning ToolTip if you move too far from the origin.
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Scale to fit tools

 The Scale to Fit command on the View menu (and on the View toolbar) zooms in as close as
possible without having any edge of the design outside of the window. This is especially useful when
you are either zoomed way in or zoomed way out and want to see the complete design quickly.

When held down, it activates the Scale to Fit tools flyout toolbar.
 

 

 Click theScale to Fit with Border tool to put a border around the scaled-to-fit view. The size of the
border is configured in Options > Defaults > Startup defaults > View Tools options.

Pan/Zoom tool

 The Pan/Zoom tool lets you grab a location on the screen and drag it as desired in Pan mode, or
zooms in and out according to the direction you drag (up or down) when in Zoom mode. To use it in
Pan mode, click it, click and hold a location on the screen, and drag to the new location. Click the right
mouse button or press ESC to exit the tool and return to the previous tool used. The cursor looks like a
clenched hand while dragging.
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Note:  If you use the Pan/Zoom tool in high graphics mode, you must refresh the screen by
pressing F2 to re-render the graphics.

To use the Pan/Zoom tool in Zoom mode, click it, click Zoom on the Status bar, position the cursor in
the desired area, and then drag the cursor up to zoom in or down to zoom out. Click the right mouse
button or press ESC to exit the tool and return to the previous tool used. Shown below is a design in
process of being zoomed in upon.

Press tab on the keyboard to change between Pan and Zoom modes without clicking their respective
option buttons.

To exit the Pan/Zoom tool in either mode, either click the mouse button, press ESC on the keyboard, or
activate another tool. The previously-used tool will resume operation.

If you have a three-button USB mouse with a scroll wheel, using the scroll wheel at any time zooms in
or zooms out as if you were using the Pan/Zoom tool in Zoom mode. Holding the middle mouse button
down and dragging the cursor pans the view as if you were using the Pan/Zoom tool in Pan mode.

The amount of zoom controlled by the scroll wheel is configured in Options > Defaults > Startup
defaults > View tools options.

View mode

 The View mode command on the View menu (and on the View toolbar) lets you choose the types of
geometry and graphics ArtiosCAD displays.
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Check or clear the checkboxes as desired. Click the arrow at the end of the Plotting Style field to select
a new plotting style from the drop-down list.

The arrows at the ends of the items in the Attributes group let you choose predefined values from a
drop-down list. You can type your own values (or a range of values by typing starting value .. ending
value) in the Pointage and Number of bridges fields but not in the Line type field.

Part frames only appear in canvases, so the control is available only when a canvas is open. There is
also a toggle for them on the View bar above the Parts List, as well as being on the View > View Options
menu.

Nick gaps are gaps in cut lines showing where nicks are positioned. Crease cutbacks are nicks at
the ends of crease lines.ArtiosCAD cannot show bridges and nick gaps simultaneously, so when you
turn Bridges on, ArtiosCAD turns off Nick gaps and Crease cutback. Conversely, turning on Nick gaps
or Crease Cutback turns off Bridges. ArtiosCAD can show bridges and nick styles simultaneously.
Crease cutbacks are at the top of the rule and bridges are at the bottom of the rule. If you turn both on,
ArtiosCAD shows the original crease with no shortening.

The default view mode styles can be set by clicking Options > Defaults > Design Defaults > Default
View Mode. The default screen color is set in the Screen color element of the Design Defaults catalog.

Plotting styles
Plotting styles control the display attributes of all objects on the screen. Using plotting styles, you can
control the width, color, and pattern of design lines, and the tools a samplemaker or other machine
uses to cut, burn, or otherwise create the lines. The current plotting style can be changed in the View
Mode menu, and plotting styles in general are configured in Defaults.

660



9ArtiosCAD

Construction lines

Construction lines are special guide lines used as drafting aids only. They aid in the construction of
geometry that relies on points not in the actual design. Construction lines are not manufac-tured, and
are not exported to different formats.

Layers

ArtiosCAD uses the concept of layers to build a complete design. Layers are used in single design
and manufacturing. Think of a piece of paper with a drawing of a basic container. Then on top of that,
add transparencies. One transparency could contain dimensions, another could contain art, and yet
another could contain additional design geometry such as a window or an optional flap. A design may
have up to 100 layers.

ArtiosCAD works with the layers that are turned on. Only layers that are visible are printed or exported
to a file. However, all layers are saved when the design is saved regardless of their viewing status.

Properties

Most objects in ArtiosCAD have properties associated with them, such as line type, pointage, font,
color, and so forth that can be changed by double-clicking the object(s) with the Select tool. This
invokes the Properties dialog box. If more than one type of object is selected, for instance a line
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and some text, the Properties dialog box will have tabs across the top that allow you to change the
properties of each type of item selected. Close the dialog box to apply the changes to the properties.

Transformations

Transformations such as moving, copying, or rotating design elements are two-step processes. The
first step is to select the item(s) to be transformed; selected items turn magenta. The second step is to
select a tool on the Edit toolbar. The Edit tools (other than Select) are available only when something is
selected.

Current position

The current position is the point in a workspace where creation tools start creating. When a new blank
design is created, the current position defaults to the intersection of the construction line axes. When
the first line is drawn from the current position, the current position then moves to the end of that line.
Whatever is created next will begin at the end of the first line. Then when the second object is created,
the current position will make the third object start from the end of the second object.

The current position can be moved by using the  Move to Point tool (CTRL-W) on the Geometry

Tools toolbar or  Move By (CTRL-Q) on the Tools > Current Point menu. Move to Point moves the
current position to an established point. Move by prompts for an angle and offset at which to move the
current position.

Entering information in ArtiosCAD

There are three ways to enter information in response to a prompt. The first way is to move the pointer
until the desired value is displayed on the screen (called drag). The second way is to type information
on the keyboard into fields on the Status bar. The third way is to use the keypad on the screen in
conjunction with the mouse.

Using drag
Drag is a basic concept of ArtiosCAD. Drag is an image and numbers that appear when ArtiosCAD
prompts for a physical dimension, such as specifying the angle at which to move an object. Moving the
pointer changes this image and numbers. Drag can be tuned to use the increments you want in the
Snap Options dialog box on the Options menu.

Freehand dragallows you to move objects by clicking and dragging them. By default, this behavior is
enabled only for text, dimensions, and annotations; however, it can apply to lines, arcs, and beziers by
clicking that option in the Snap dialog box in Options.

You must select a line, arc, or bezier by one of its endpoints in order to use it with freehand drag. This
reduces the potential for accidental moves.
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A small circle appears when you have created an object by aligning it with an established point (called
snapping to a point). If the circle does not appear around the point you think you snapped to, then you
did not snap to that point.

When using the following tools, holding down SHIFT while using drag to set an angle adds
perpendicular and tangential angles to the snap.

• Line Angle/Offset

• Line Horiz/Vert

• Line Angle/Length

• Arc Start Angle

• Arc End Point

• Straight Curve

• Curve Straight

• Conline Offset/Angle

In the examples below, the end of the arc is the point against which the perpendicular and tangential
angles are measured.

663



9 ArtiosCAD

However, since the endpoint is shared, ArtiosCAD also shows the perpendicular and tangential angles
for the line as shown below.
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Dynamic Drafting overview

Dynamic Drafting enhances drag so that you get more feedback about aligning to points related to the
cursor's location. As you move the cursor around with Dynamic Drafting enabled, ArtiosCAD displays
horizontal and vertical alignment lines to points on the screen.

If ArtiosCAD can make an alignment with a point that satisfies the current prompt on the Status bar, it
shows a solid line to that point. If it finds an alignment with a point but that alignment does not satisfy
the current prompt on the Status bar, it shows a dotted line to that point. Shown below is setting the
Angle prompt for a line using drag. Aligning with the midpoint of either the cut or crease line can satisfy
the Angle prompt for the Line tool.
 

 
In the example above, ArtiosCAD displayed the alignment point (the green square) because the cursor
was within the snap tolerance to that point.

In the example below, aligning to the midpoint of the line does not satisfy the Radius prompt of the
Circle tool because the horizontal location of the proposed point is not aligned, so ArtiosCAD shows a
dotted line.
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However, in the different example below, because Dynamic Drafting could align the Radius prompt of
the Circle tool to the point defined by the midpoints of both lines, it shows an alignment point.
 

 

Dynamic Drafting:

• works with tools that accept points in Single Design only, not in 3D or Manufacturing
• is enabled by default.

If you have already set a value in a Status bar field, ArtiosCAD does not show alignments for those
fields.

Dynamic Drafting also:

• works only with layers that are turned on
• ignores geometry that is completely outside of the current view
• ignores construction lines, file windows, and details
• ignores lines created by the Hatch tool
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• chooses the point that is closest to the cursor if the cursor is within 1/4 the snap tolerance distance
to multiple points.

There are some restrictions to using Dynamic Drafting:

• works even if Use Drag Snap is turned off in the Snap Options dialog box.
• works with the center points of arcs if Center points of arcs is turned on in the View mode, even if

Extend Points of Arcs is turned off in the Snap options dialog box
• If Extend Points of Arcs is turned on in the Snap options dialog box, ArtiosCAD considers them

even if they do not appear in the current view
• does not recognize intersections with beziers
• does not recognize points created purely by tool drag, such as bezier start and end points or drag

for Create Rectangle From Line
• does not work with any of the tools on the Advanced Standards toolbar.

Note:  if you have diculty setting the prompts to a value because of ArtiosCAD's create-a-
line-with-one-click behavior, press ENTER to set the value in the highlighted prompt, and press
TAB to move between the prompts.

Turning dynamic drafting on and off
ArtiosCAD has four ways to turn dynamic drafting on and off:

1.
 Click the toggle button on the View bar.

2. Press SHIFT-D. ArtiosCAD will update the toggle button on the View bar accordingly.
3. Click Options > Snap and select or deselect Horizontal/Vertical Alignments in the Dynamic

Drafting group.
 

667



9 ArtiosCAD

 
4. On the View > Snap Options menu, click Dynamic Drafting.

 

 

To turn Dynamic Drafting on or off permanently, click Options > Defaults > Startup defaults > Snap
options and select or deselect Horizontal/Vertical Alignments in the Dynamic Drafting group.
 

 

Keyboard Shortcuts in ArtiosCAD
You can press the keys in the Shortcut columns in the table below to perform the commands in the
Function columns. Not all commands are available at all times; for example, if you have not cut or
copied anything, you can not paste anything. You can change Shortcuts in Defaults.

668



9ArtiosCAD

Table: Keyboard Shortcuts

Function Shortcut Function Shortcut

New Design CTRL + N Zoom Rectangle CTRL + R

Run a Standard CTRL + 2 Zoom Out CTRL + A

Convert to 3D CTRL + 3 CloseUp Window CTRL + Space

New Layout CTRL + L Extend ALT + X

Open CTRL + O Clear Extend CTRL + ALT + X

Save CTRL + S Move to Point CTRL + W

Print CTRL + P Move By CTRL + Q

Undo CTRL + Z Line Angle/Offset CTRL + 1

Redo ALT + Z Conline Offset/Angle CTRL + F

Cut CTRL + X Keypad CTRL + 4

Copy CTRL + C Rebuild F5

Paste CTRL + V Measure Tool CTRL + G

Select CTRL + E Copy Mode CTRL + INSERT

Move CTRL + M Move Mode CTRL + M

Properties ALT + Enter Split Line CTRL + L

Refresh F2 Toggle Dynamic Drafting SHIFT + D

Scale to Fit CTRL + D Select All (in the Project Bar) CTRL + A

Select Line Type CTRL + U (new
installations of 18.1
or later only)

Snap

Snap accommodates non-precision when selecting points. If you click close enough to a point,
ArtiosCAD interprets your click as selecting that point, even if you are a few pixels off. The area around
a point that you can click in and still select it is called Snap Tolerance.
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Some tools, such as the Bezier tool, require Freehand Coordinates to be turned on. If you try to click
a point and Cannot select coord appears in the Status bar, make sure Freehand Coordinates is turned
on.

If Middle Points of Lines and Arcs is enabled, once you are within the snap tolerance of a line or arc,
the endpoints and midpoint appear.

Highlighting appears around such a point when the cursor is over it.

Extend Points of Arcs or Bezier causes blue squares to appear around center, corner, and quadrant
points of arcs, and green squares to highlight the start, end, and midpoints of arcs. Blue squares also
appear for the center and quadrant points of a circle. Green squares indicate the ends of beziers while
blue squares indicate their extents. When this checkbox is cleared, only the start, end, and midpoints
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of arcs appear. Zoom in on small geometry, else you will see overlapping squares. There are no snap
points on construction line circles.
 

 
 

 

Text, Arrow or Image Points lets you snap to the edge and center points of those objects. Shown below
is snapping to the top center handle point of a piece of text.
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On the View menu, the Snap Options submenu lets you quickly turn on snapping to middle points, using
overrun/underrun, and Dynamic Drafting. You can also assign these to shortcuts if desired.
 

 

Facilitating accurate snapping
Sometimes in the box designing process, lines are on top of each other. If you are making a resizable
design and need to use points for reference for rebuilding, you need to make sure you are selecting the
proper point. If you inadvertently select the wrong point, maybe because lines in different layers are on
top of each other, a later rebuild may fail due to non-existent geometry.

To make snapping more accurate, and to help you snap to what you think you are snapping to,
ArtiosCAD does not automatically snap to geometry in these layer classes:

• Artwork Panels
• Bleed
• Coating
• Detail
• DocPlot
• Dynamic Art
• Full Graphics
• Glue/mate
• Hatch
• Line type label
• Output

If you try to snap to a point in one of those layer classes, ArtiosCAD turns the snap feedback square
to red and displays Snap point unreliable for rebuilding: and then the type of layer class in the message
area of the status bar. Shown below is an unreliable point.
 

 

If you really do want to snap to an unreliable point, ArtiosCAD lets you if you explicitly click it, but again
turns the feedback red and displays a message in the Status bar. You also can snap to an unreliable
point if you are in its layer, or if the current selection contains an example of the unreliable geometry.

Dynamic Drafting does not snap to unreliable points.
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Overrun/Underrun
Also on the View > Snap Options menu is Use overrun, underrun which extends, shortens, or does both
to every line by a set amount and is configured in Options > Over/Underrun.

Design window elements

The ArtiosCAD Design window contains four functional areas:

1. The menu bar, the view bar, and the toolbar master controls
2. The toolbars
3. The status bar
4. The drawing area
5. The Project bar (shown collapsed)
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The menu bar, view bar, and toolbars all control the action in the drawing area. The status bar displays
information about the tool being used, and if applicable, prompts for specific information.

You can reposition the View bar and toolbars as desired by clicking and dragging their handles. They
can all float or be docked as you prefer. To make a toolbar float, click its handle and drag it out of the
window. To dock it again, drag it back into the window and stick it to one of the window edges.

The menu bar
The menu bar contains commands available in the current module. Not all commands on all menus may
be available; availability depends on the options purchased and the active tool.
 

 

The View bar
The View bar provides one-click access to commonly used features.
 

 

Each button on the View bar displays a ToolTip if the pointer hovers over it for a few seconds.

In the first group of controls on the View bar, the first button opens the Open dialog box. The second
button opens the Design browser. The third button saves the current design.

In the second group, the first button rebuilds the current design. The second converts the current
design to a Manufacturing file. The third button converts the current design to a 3D file. The fourth
button converts a single design to a canvas. The fifth button converts the current design to a counter
layout, and is available only when there is a Counter layer in the design. The sixth button marks the
current single design as the destination document when making Assembly Instructions.

The button in the third group creates a print item.

The first button in the fourth group adds, deletes, and modifies layers. It also shows the name of the
current layer.

 After the Layers button, the drop-down list boxes control line type
and pointage. They are described in the next section.

 The fifth group of buttons on the View bar contains Preflight and
the toolbar master control buttons, after which are the Dynamic Drafting mode toggle and the Show
Auto-Repeat Areas toggle. The toolbar master controls are described after line types; Preflight and the
two toggles are described in the Designer chapter.
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 In the sixth group of buttons on the View bar, the first button
changes the grain/flute direction. Clicking the drop-down arrow shows a menu with more commands
on it:

• Change Grain Direction changes the grain/corrugation direction without rotating the design.
• Change Grain View with Rotate 90 Right changes the grain direction and rotates the design

clockwise by 90 degrees to reflect that change.
• Change Grain View with Rotate 90 Left changes the grain/corrugation direction and rotates the

design counterclockwise by 90 degrees to reflect that change.

 The second button displays the current side up (outside/printed or inside/unprinted),
and changes it when clicked. Clicking the drop-down arrow shows a menu with more commands on it.

• Flip Side changes the designation of the side you are looking at.
• Change Print Side and Blade Side flips the design over so that you are looking at the other side of

the design and the other side of the die board.

 The third button toggles between Blade Down/Die Back side or Blade Up/Die Knife
side. This is most useful when designing for thick boards with V-notch cuts and creases. For Blade
Down, ArtiosCAD cuts the design as viewed from the top as viewed from the current side. For Blade
Up, ArtiosCAD cuts the design from underneath as viewed from the current side. This setting is
synchronized with 3D, but it is not synchronized with Manufacturing as that setting is controlled by the
manufacturing parameter set.

If you are In a canvas, the button has a drop-down menu with the following commands for working with
the current part, all parts, or the canvas as a whole:

• Change Blade Side for Current Part
• Change Blade Side for All Parts
• Change All Parts to Blade Down
• Change All Parts to Blade Up

The Grain, Side, and Blade Side commands are also on the Info menu.

 The fourth button displays the units of the current design - In for imperial format and mm for
metric format.

Changing the line type and pointage
The fifth group of controls on the View bar controls the line type and pointage. With nothing selected,
they show the line type and pointage used to create new lines. If any lines are selected and the controls
are changed, the lines change accordingly. If lines of differing attributes are selected, the respective
drop-down list boxes are empty. If nothing is selected and these controls are changed, then any lines
made from that point forward will reflect the changes made in the controls.
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In single designs and canvases, the Line Type pop-up control displays all line types currently in the
workspace and two panes with generic types and special rules. Click the desired line type to change
the line type and close the selector.
 

 

You can drag the selector to any desired location.

You can also press CTRL-U (in new installations only of 18.1 or later) to open the line type selector at the
cursor location. Additionally, Change Line Type is on the Edit menu for single designs and canvases.

When selecting special rules to use for manufacturing, make sure to select the special rule from
the Special Rule Types group, and not the Generic Types group. If you select a special rule type, the
special rule type will use its default pointage and the Pointage drop-down list box will be disabled.

Manufacturing limits the available linetypes per layer so ArtiosCAD displays only the allowed line types
for that layer.

The Pointage drop down list box displays a list of the most commonly-used pointages.

Select the new pointage from the list. It will affect new lines created that are of a generic line type.

If you use a line type from the V-notch folder of the Generic Types catalog, the Pointage drop-down
changes to an Angle field. This is used by the variable angle tool on Kongsberg samplemakers in
conjunction with iPC. Set an angle from 0 to 60 degrees in steps of 0.5 degree.
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When you change the line type and then make a line, ArtiosCAD checks to make sure that the line type
is appropriate for the current layer. Listed below is a list of line types and their appropriate layers.

Table: Line types and appropriate layers

Line type Appropriate layer classes

Annotation, print image, dimensions and text, form
windows, construction lines, Tooling line types

Any (no warning)

Tear 3D Assist

Print registration Print registration, Horizontal cross section

Outside bleed Outside bleed

Inside bleed Inside bleed

Outside coating Outside coating (1-3)

Inside coating Inside coating

Cut Main, Manufacturing, Windows and cutouts,
Horizontal cross section

Crease, Glue assist Main, Manufacturing, Windows and cutouts

Side bevel, generic perf, all special and generic
rules

Main, Manufacturing, Windows and cutouts

Unknifed diecut, Die etch, Die registration hole,
Laser position hole, Die bolt holes

Main, Manufacturing, Windows and cutouts

Counter line types Counter

Stripping boards, other manufacturing Main, Manufacturing

Dynamic Art Dynamic Art

Copy area, Copy free Artwork Panels

The default line types for layer classes are listed below.

Table: Default line types for layer classes

Layer class(es) Default line type

Main, Manufacturing, Windows and cutouts,
Horizontal cross section

Cut, or last valid line type used
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Layer class(es) Default line type

Counter Counter periphery tool, or last valid line type
used

Print registration Print registration

Outside bleed Outside bleed

Outside coating (1-3) Outside coating

Inside bleed Inside bleed

Inside coating Inside coating

Dimensions, Overall dimensions, Annotation Annotation

Dynamic Art Dynamic Art

Artwork Panels Copy area

3D Assist Tear

Graphics, Outside graphics, Inside graphics, Label
graphics, Shrink-wrap graphics

Print image

All others None; any type is appropriate

The Toolbar Master Controls and toolbars

  The Toolbar Master Controls let you turn toolbars on and off in Designer and Manufacturing.
The first button controls which standard toolbars are shown. The second button controls which
customized toolbars are shown.

Initially the toolbars appear to the left of the drawing area, but each toolbar can be independently
detached, or docked in a different position if desired.

Note:  When a toolbar is activated for the first time, it will appear undocked outside the
ArtiosCAD window. Drag it to the desired position inside ArtiosCAD.

Sixteen predefined toolbars are controlled by the Toolbar Master Control for standard toolbars in
Designer. Up to 10 customized toolbars are controlled by the Customized Toolbar Master Control; it
depends how many are defined in Defaults.

To turn a toolbar on or off, click the button preceding the name of the toolbar. Each button depresses
when clicked for the first time to indicate the toolbar is on. Click the button again to return it to its
raised position, indicating the toolbar is turned off.

Availability of toolbars controlled by the Toolbar Master Controls depends on the options purchased.
If you cannot click a toolbar activation button, the tools or features controlled by that toolbar have
not been purchased.
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Designer toolbars
Shown below is the Toolbar Master Control for standard toolbars in Design.
 

 

The first button turns the View toolbar on and off. The tools on the View toolbar are used to change the
view of the current window.

The second button turns the Geometry toolbar on and off. The tools on the Geometry toolbar construct
lines and shapes.

The third button turns the Dimension toolbar on and off. The tools on the Dimension toolbar construct
and modify dimensional annotations of lines, angles, and arcs.
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The fourth button turns the Adjust toolbar on and off. The tools on the Adjust toolbar change the linear
attributes of existing lines.

The fifth button turns the Construction Lines toolbar on and off. Construction lines are drawing
aids that are not plotted or manufactured. The tools on the Construction Lines toolbar manipulate
construction lines.

The sixth button turns the Edit toolbar on and off. The tools on the Edit toolbar perform physical
transformations on items such as moving or copying them.

The seventh button turns the Annotations toolbar on and off. The tools on the Annotations toolbar add
text, legends, and details to the current design.

The eighth button turns the Undo-Redo toolbar on and off. Tools on the Undo-Redo toolbar undo and
redo actions, and manipulate the list of already-executed actions which can be undone and redone.

The ninth button turns the Adjust Outline toolbar on and off. The tools on the Adjust Outline toolbar
adjust the non-linear physical properties of lines such as parallelism with an axis and direction.

The tenth button turns the Extend toolbar on and off. Tools on this toolbar create construction line
extensions that extend lines into infinity and arcs into circles. These extensions contain points on
which you can reference new geometry.

The eleventh button turns the Advanced Standard toolbar on and off. These tools create geometry
based on other points in the design and are intended for use by the most advanced users.

The twelfth button turns the Graphics toolbar on and off. The tools on the Graphics toolbar manipulate
pasted images from outside sources, the stock color, fills, strokes, and graphic placement.

The thirteenth button turns the Reports toolbar on and off. The tools on the Reports toolbar convert
the current design into a report.

The fourteenth button turns the Assembly Instructions toolbar on and off. These tools are used in
conjunction with their counterparts in 3D.

The fifteen button turns the Counters toolbar on and off. The tools on the Counters toolbar operate the
Intelligent Counters module. This module must be purchased in order for the Toolbar Master Control
button to work.

The sixteenth button turns the Registration Holes toolbar on and off. Registration holes are used by the
DieSaw and other die-making machines to manufacture dies.

The seventeenth button turns the Prepare for Manufacturing toolbar on and off. This toolbar has tools
for working with bleeds, coating-free areas, bridges, nicks, and shortening creases for steel counters.

The All On and All Off buttons turn on or turn off all the toolbars, respectively.

Manufacturing toolbars
The standard Toolbar Master Control in Manufacturing works similarly to the one in Designer, but it has
additional c;ontrols for the Manufacturing toolbars.
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The first button in the Manufacturing Toolbars group controls the appearance of the Manufacturing
toolbar. The tools on this toolbar select, delete, and repeat elements, as well as creating the dieboard
edge, adding a burn name, and working with bridges and nicks.

The second button controls the Dieboard toolbar. Tools on the Dieboard toolbar make stripping rules,
evenly spaced scrap knives, balance knives, dieboard splits, and so on.

The third button controls the Stripping Board toolbar. Tools on the Stripping Board toolbar make
automatic area stripping, alignment holes, air holes, interference, and so on.

The fourth button controls the Manual Layout toolbar. Tools on this toolbar control which single
designs are used in the layout, the gutter distance between designs, and the position of the layout on
the sheet.

The fifth button controls the Edit Layout toolbar. Tools on this toolbar manipulate single designs and
their position on the sheet.
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The sixth button turns the Intelligent Layout toolbar on and off. Tools on this toolbar let you use and
configure Intelligent Layout and Costing/Estimating.

The seventh button controls the Rule Path toolbar. Tools on this toolbar create, manipulate, and delete
rule paths.

The eighth button controls the DieSaw toolbar. Tools on this toolbar control drill holes and other
DieSaw-specific features.

The ninth and tenth buttons control the Rubbering and Rubbering View toolbars respectively. These
tools let you build rubber along the lines in a layout, nest it, and lay it out in sheets for production, as
well as letting you view different aspects of the rubber easily.

The eleventh button controls the Blanking toolbar. Tools on this toolbar create upper and lower
blanking boards.

Availability of toolbars controlled by the Toolbar Master Controls depends on the options purchased.
If you cannot click a toolbar activation button, the tools or features controlled by that toolbar have
not been purchased.

Customized toolbars
The Customized Toolbar Master Control works the same way as the standard Master Toolbar Control. It
will be empty until customized toolbars are created in Defaults. Once customized toolbars are created,
use this control to turn them on and off like standard toolbars.

Toolbar positions
ArtiosCAD toolbar positions are saved automatically when ArtiosCAD is exited, but you can save them
manually by clicking View > Save Toolbar configuration. You can then click View > Restore Toolbar
configuration if they ever appear in the wrong place. Toolbar positions are stored in the Registry on a
per-user basis.
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Flyout toolbars
Some tool icons have small black triangles in the lower right corner.
 

 

This indicates that there are related tools available on a flyout toolbar. Clicking and holding the mouse
button will make the flyout toolbar appear, and dragging and releasing over a tool will select it. Hovering
over a tool on a flyout toolbar displays a ToolTip for that tool.

Shown below is the Line tool with its flyout toolbar activated.
 

 

When a tool on a flyout toolbar is selected, it becomes the tool shown on the regular toolbar.

Changing the Toolbar Appearance
You can change the appearance of the toolbars if desired. This is unsupported and may cause
unpredictable results at any point; proceed with caution and save any work beforehand and
afterward.
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To change the appearance of the toolbars, click Help > Diagnostics > Toolbar Appearance. The Toolbar
Appearance dialog box opens.
 

 

Set the size of the toolbars by choosing one of the options in the Toolbar Size group.

Show ToolTips on Horizontal and Floating Toolbars adds a label to each button on those types of
toolbars. Enabling this option will significantly increase the size of the toolbars.
 

 

Use Windows Display Zoom Level to Set Toolbar Size links the size of the toolbars to the zoom level
set in the Make it easier to read what's on your screen area of the Display control panel applet.
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These settings are stored in the Windows Registry on a per-user, per-machine basis. These are not
configured in Defaults.

The drawing area
The drawing area is where the work is done. Think of it as a piece of paper onto which you are drawing
a design. The View Mode command on the View menu (and on the Zoom toolbar) controls what objects
are displayed and how they are displayed in the drawing area. Shown below is a picture of a design in
the drawing area.

The Status bar
The fields and messages on the Status bar are the primary ways  ArtiosCAD prompts for information
needed to complete a task.

The picture of the Status bar above shows the prompts for a Line tool. The angle of the line, the
length of the line, and the X and Y offsets of the endpoint from the current position can all be used to
construct the geometry.

Move among the fields using the arrow keys on the keyboard, or click in them with the mouse. Next to
each field is a symbol showing the direction in which the object being prompted for will be constructed.

Also next to each field is a keypad icon . Clicking the keypad displays an angle or length keypad and
the variable keypad. Keypads are further described in the next section.

The Status bar also gives instructions. For example, when the Select tool is active, the Status bar tells
you to hold down shift to add items to the current selection.

ArtiosCAD also uses a combination of prompts and instructions to gather information.

685



9 ArtiosCAD

When using drag, the Status bar indicates what the drag will set. In the picture below, the drag is
setting the value for an angle, and the Status bar indicates that by highlighting the field being set and
by telling you what to do – set the angle.

Keypads
In addition to typing values directly into fields on the Status bar, you can use a keypad to click number
buttons or use the field to enter expressions longer than the short fields on the Status bar. ArtiosCAD
uses one keypad for angles and another for lengths, radii, and so on.

The keypads follow the order of operations; expressions are evaluated from left to right, in this order:
items in parentheses, powers, multiplication and division, and then addition and subtraction being
computed last.

When entering information in the calculation field by clicking buttons or variables, ArtiosCAD adds the
plus sign automatically if the cursor is at the end of the calculation field. When starting the field or
operator by clicking a denominator button, ArtiosCAD automatically inserts 1 before the slash to act as
a numerator.

Shown below is the angle keypad, with a list of current workspace variables and their values in a
separate but attached dialog box to its right.

Common to both keypads, the number keys on the left side of the dialog box enter their numbers in
the calculation field running across the top of the dialog box. Click inside the calculation field to type
numbers, letters, and expressions. del deletes the last number, letter, or operator entered.

In the center group of buttons are the operators and common angle measurements.

Along the right side of the angle keypad are the results field and the special angle measurement
buttons. The result field displays the current results of the expression in the calculation field. If the
expression cannot be evaluated (for example, if it ends with an operator), ArtiosCAD displays err in the
results field.

In the following feature descriptions, absolute means measured from the positive X axis in a
counterclockwise direction. Also, using these four buttons replaces any values in the calculation field.
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 Angle between two lines prompts you to select two lines and then inserts the resulting angle
between them into the calculation field.

 Absolute angle between two lines with reference prompts you to select an initial line or point
for reference, and then two lines. The angle of those two lines is either added or subtracted to the
reference line’s angle depending on which side of the reference point or line was clicked. The concept
is that you click a line and then add the angle of two other lines to it. This added angle is what appears
in the calculation field. Note that the new angle is not absolute to the reference line; it was absolute
when it was measured between the two other lines.

 Absolute angle of a line sets the value in the calculation field to the absolute angle of the line or
endpoint clicked.

 Absolute angle between two points sets the value in the calculation field to the absolute angle of
the selected two points.

Shown below is the length keypad, with a list of current workspace variables and their values in a
separate but attached dialog box to its right.

As on the angle keypad, the left portion of the keypad has buttons for each numeral and del. The center
of the keypad contains the operators plus commonly-used denominators for fractions. Along the right
side of the length keypad are the results field and the special line measurement buttons. The result
field displays the current results of the expression in the calculation field. If the expression cannot be
evaluated (for example, if it ends with an operator), ArtiosCAD displays err in the results field.

 The Absolute length of a line button prompts you to click a line and then enters the expression for
its length in the calculation field. The actual length is shown in the results field.
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 The Distance between two points button in uses dimensions of existing geometry to set the
value of a new piece of geometry. This is useful when the distance between two points is unknown, or if
you want to make a rebuildable design.

Parameter sets

Parameter sets are collections of settings that govern aspects of the current design or manufacturing
file. The collection can be based on anything – by customers, by machines, or however else you want to
group information.

Single design parameter sets allow you to assign different values to different sets for the following
entries:

• Default bridging formulae to use

• Flute/grain setting

• Side up

• Bleed and Varnish offsets

Manufacturing parameter sets, in conjunction with machine parameters, allow you to customize
various settings per set or per machine. A partial list of the values you can set are:

• Die board size

• Default bridging formulae

• Settings for chop knives

• Mounting hole parameters

Many more options can be set using parameter sets.

Geometric Information Dialog Box

The Geometric Information dialog box (Info > Geometric Information shows the area, blank size, rule
length, and line types in the current design or active part.
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If you have lines selected when you open the dialog box, ArtiosCAD shows their length in the Length of
selected rules field.

To see the lengths of generic rule types, select Show generic types.

In the design area, ArtiosCAD shows the area in green and the area of nicked holes in blue.
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Working with design files

Although ArtiosCAD has different modules, they manipulate design files in the same way.

How to view revision history

To view the revision history of a file, click Info > Revision History. The History dialog box will open and
show the revision history.

How to view the design origin

The Design Origin tab in the Revision History dialog box shows the name of the standard used to create
a new design, if the design was made from a standard.
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File views

ArtiosCAD’s tight integration with DataCenter lets you open or save files in file system directories or
database resources. There are two tabs in each dialog box that control where the file is saved to or
opened from.

Directory view lets you navigate among the directories, hard drives, and network connections to
choose the location for the file.
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Resource view lets you navigate among database resources to choose the location for the file.
Configure resources using DataCenter Admin; see the DataCenter chapter for more information.

Resource view also allows you to view all revisions of a file, or only the most recent version of the file.

Click  to view all versions of a design.

Click  to view only the most recent revision.

It may take some time for all filenames to display in resource view, particularly if there are Designer
WorkBench files in that resource. If you know the name of a design, you may type it in the File name:
field at any point without having to wait for the full list to appear.

Dragging and dropping files

You can drag and drop files into ArtiosCAD to open them.

• Drag and drop a single design file onto a sheet in Manufacturing.
• Drag and drop a canvas, single design, 3D workspace, or model file into a 3D workspace. ArtiosCAD

honors any saved fold angles.

• If ArtiosCAD has an open dialog box or is waiting on a complicated operation like importing a solid,
it ignores the drop.
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Creating, opening, and importing designs

Creating, opening, or importing a design use the creative portions of ArtiosCAD. Running a standard is
one way to create a new design. To run a standard, click File, then click Run a standard. The Standards
Catalog will appear from which you may choose the standard on which your new design will be based.

How to create a new blank design
Another way to create a new design is to click File, and then click New and then Design. Choose a
parameter set and a board code, using the Search field in the board chooser if needed. Click OK. This
creates a new blank workspace; use the Designer tools to create geometry.

How to assign a parameter set and board code
Whether creating a design from a standard or from scratch, you must choose a parameter set and a
board code. A board code is a group of settings that tells ArtiosCAD various things about the material
used to manufacture the design. This can include information such as the thickness of the board, its
weight, cost, inside loss, outside gain, scant, and allowance.

Select a board code at the same time you select a parameter set. Select the board code you want to
use and then click OK (if creating a blank design) or Next (if running a standard) to continue creating
the design.
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Drag the splitter between panes to adjust their sizes.

Clicking Board Properties shows information about the selected board. Board information is extracted
from the database and thus cannot be changed in ArtiosCAD if the database is available. Only when the
database is unavailable are the fields available for changing. Click OK to close the dialog box.

How to open an existing design
To open an existing design, click File, and then click Open. Use the Directory View tab to navigate
using directories, or use the Resource View tab to navigate using database resources. Click the
filename of the design to open, and click Open.

To open more than one design at once, use Directory View, click the first design to open, hold down
CTRL, click the other files to open, and then click Open.

There is a limit of 2562 characters in the File name: field when opening designs.
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The design preview is shown next to the Open dialog; the Description:, Short Description 1:, Short
Description 2:, and Short Description 3: fields and the dimensions (if known) are shown beneath the
preview. The design preview can be resized as desired, but if it is too small, some of the text shown will
be truncated. When selecting multiple designs to open, only the first design selected is previewed.

Upon opening, the design is initially displayed according to the View Mode defaults in Options >
Defaults > Design Defaults > Default View Mode. In that dialog box are settings for line attributes, nick
style, high graphics mode, screen background color, plotting style, and whether the layers shown as are
saved or the default settings.

It is easiest to open Designer WorkBench designs in Resource View. That way you can navigate to the
proper resource and the DWB hexadecimal disc filename will be displayed as the DWB design number.

Designer WorkBench single designs which contain stepping information will use that data to create a
layout when the single design is opened and converted to a manufacturing file.

The Scant variable in workspaces originally created in Designer WorkBench is mapped to either the
Outside Gain (OG) or Inside Loss (IL) variable via the setting in Options > Defaults > Design Defaults >
DWB Options.

When you open a single design containing records from another database, the Add Database Entities
dialog box appears. In this dialog box, choose which entities to add to your database by checking the
checkbox next to each available category. The enabled categories depend on which entities are set in
the single design.
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The Keep project codes in design checkbox controls whether or not ArtiosCAD leaves the Project
codes from the foreign database in the single design or if it strips them out.

To see the specific entities for each category of database entities, click ... next to the checkbox. All
entities will be added if you check the checkbox; there is no way to choose which specific entities
are added to the database. Specific Project entities are shown below; click OK to return to the Add
Database Entities dialog box.

If a later revision of the design exists, you are prompted to choose to open the selected revision, or the
latest revision. Choose the desired choice and click OK.
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If the design you are opening is an exported canvas part containing hardware parts, ArtiosCAD puts
images representing the geometry of the hardware parts in the Main Design layer.

Opening a design that is already open
If you open a design that is open in another session of ArtiosCAD, ArtiosCAD warns you that it is already
open, and also who opened it and when it was opened.

Click Open Read-Only to open the file in read-only mode. Using File > Save on a read-only file generates
a warning message. You must use Save As to save the file with a new name.

Click Cancel to not open the file.

If you open a file as read-only, the ArtiosCAD window title bar displays (READ_ONLY) as a reminder.

ArtiosCAD tracks open files by creating a hidden filename.alck file in the same directory as the open
file. If you do not have write permission in the directory, the lock file cannot be created and the file will
not protected against opening by other sessions.

To open a file directly in read-only mode, click File > Open Read-Only.

Note:  If you choose the original filename when doing a Save As, ArtiosCAD will overwrite the
original file with the new file if the file is no longer locked. If the file is still locked by another
instance of ArtiosCAD, you may not save the file with the same name.

How to open a design on a Web server
To open a design that is saved on a Web server, click File > Open URL and enter the URL for that design,
e.g. http://artcad.mycompany.com/myfilename.ARD.
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How to open an existing manufacturing file
To open an existing manufacturing file, do the following:

1. Start ArtiosCAD.
2. Click File > Open.
3. Using either Directory view or Resource view, navigate to the location in which the manufacturing

file is saved.
4. Click the name of the manufacturing file to select it. A preview of the manufacturing file appears

just as it does for a single design.

5. Click Open. The manufacturing file is opened.

If a later revision of the manufacturing file exists, you are prompted to choose to open the selected
revision, or the latest revision. Choose the desired choice and click OK.

When opening a manufacturing file, ArtiosCAD checks if a disk file exists with the same name as the
embedded single design(s). If such a file exists, its creation date and time are compared with the
embedded single design(s). If the two are different, ArtiosCAD prompts you to select the one to use.
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Update all replaces the older embedded single designs with the newer versions. ArtiosCAD checks
for double knives in the manufacturing file, double lines in the single designs, and to see if the single
designs have different origins, sizes, sides up, or grain directions from those they are replacing.

Ignore all keeps the embedded single designs and ignores the newer versions. The warning will appear
again the next time the manufacturing file is opened.

Ignore this update keeps the embedded single designs and saves the new modification date in the
manufacturing file so no warning occurs the next time the manufacturing file is opened.

How to import an existing ArtiosCAD design into another
To import an existing ArtiosCAD design into another, do the following:

1. Start ArtiosCAD and open the design into which the other design will be imported.
2. Click File > Import > Import File.
3. Select the file to import and click Open.

4. In the Select Layers dialog box, select the layers to import into the design by checking or clearing
the checkboxes next to the layer names as appropriate. Click OK when you have chosen the layers of
the design to import.
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5. The selected layers of the design will be imported into the current workspace. All of the imported
objects will be selected and the Move tool will be active. Click to set a pick-up point and click again
to set a put-down point. To cancel the move, select another tool.

How to import a design in a different format
Opening a design in a different format, such as DDES, DXF, EPSF, or CFF2, is done in the same way as
opening a native ArtiosCAD design file. Click File, and then click Open. Navigate to the proper directory
using the standard controls, click the filename of the design to open, and click OK.

If your filename does not have one of the standard extensions (.DS2, .DXF, .EPS, .CFF, .N, etc.), then you
must change the entry in the Files of type list box to All files in the Open dialog box. If your file does not
have one of the standard extensions, it will not appear in the list of files available unless you change the
listing to All files.

Line type mappings and other translations for each file type are configured in Defaults > Shared
Defaults > Import Tuning Table.

A preview of the file selected for import appears next to the File Open dialog box.

Importing a DDES file
When you open a DDES2 or DDES3 file, the Importing DDES File dialog box (or Importing DDES3 file
dialog box) appears as shown below. Set the option buttons as desired, click OK, and choose the
desired parameter set and board code to import the file.
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Importing a DWG file
When you open a DWG file, the Importing DWG/DXF File dialog box appears. Set the option buttons as
desired and click OK to import the file.
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Note:  ArtiosCAD ignores any 3D data in the file.

If fills do not look correct, click Options > Defaults > Import Tuning Table > Tuning entry > Options and
in the DWG/DXF Import Options dialog box, select or deselect Skip Solid/Gradient Fills.

Importing a DXF file
When you open a DXF file, the Importing DWG/DXF File dialog box appears.

Set the option buttons as desired and click OK to import the file.
 

 

Note:  ArtiosCAD ignores any 3D data in the file.

Note:  If you have trouble importing a DXF file, try clearing Import DXF files using third party
libraries in DWG/DXF Options in Startup defaults.

When importing a DXF file, ArtiosCAD can import C2 and C3 curves, and degree 4 to 7 splines.

Spline degrees ArtiosCAD imports as

2, 3 Beziers
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Spline degrees ArtiosCAD imports as

4-7 Arcs with accuracy to 0.02mm

8-10 Incorrect beziers with a message they are not
supported

If fills do not look correct, click Options > Defaults > Import Tuning Table > Tuning entry > Options and
in the DWG/DXF Import Options dialog box, select or deselect Skip Solid/Gradient Fills.

Importing a CFF2 file
When you open a CFF2 file, the Import CFF2 File dialog box appears. Set the option buttons as desired
and click OK to import the file.

When opening a CFF2 layout, ArtiosCAD can base the size of the sheet on the lower left and upper right
values contained within the file. This is configured by the LL/UR values to contribute to sheet size
checkbox in Defaults > Shared defaults > Import Tuning Table > Artios CFF2 > Options. Rotation and
mirroring options are also set in this dialog box, as is the transformation order and the minimum blank
area needed to consider the CFF2 file a layout. The default standard transformation is to rotate and
then negate, but you can choose to negate then rotate in the Elcede style.

Importing an EPSF/AI file
When you open an .EPSF or .AI file, the Import EPSF Options dialog box appears.

Import as Graphics imports strokes and fills unchanged. Convert Strokes to Lines and Convert Fills to
Lines change fills and strokes to print image lines and places them into overlays whose names are the
color of the fills/stroke and the thickness of the strokes in points.

Set the checkboxes as desired and click OK to import the file.
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You can import only Illustrator 3.2 and Illustrator 8.0 EPSF files. TIFF previews are ignored. Other
EPSF file types are not supported. Some .AI files are supported using EPSF import functionality
while others require the PDF option to open. If you receive a  Feature not available  message while
trying to open an .AI file, the file is likely in the format that needs the PDF option.

If the EPS file has more than 8 MB of vector data, it will be lost when the design is converted to 3D. Use
the JPEG format or PDF instead of EPS if working with large files.

Data Exchange Plug-In
The free Data Exchange plug-in lets Adobe Illustrator users place ArtiosCAD single design workspaces
in Illustrator documents. It does not include placed EPS objects or other pixel-based objects. The plug-
in can be downloaded from Esko's Web site at http://www.esko.com.

For more information on the plug-in, refer to the Data Exchange help on the Help menu in Illustrator
(Help > Esko > Help > Esko Data Exchange).

Importing Elcede .N files
When you open an Elcede Diecad .N file, the Import Elcede File dialog box appears. Set the option
buttons as desired and click OK to import the file.
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Note:  ArtiosCAD can not open Diecad files with more than approximately 1000 lines in a
section. If you encounter such a file, export the file from Diecad in CFF2 format, and read the
CFF2 file into ArtiosCAD.

Working with other NC files
If you have Numeric Control files for which there are no native ArtiosCAD import filters, such as Elcede
IBH/Vectocut files or Kongsberg MAP and ACM files, you can try using the Open NC file command on
the Diagnostics menu in Single Design. This command is not supported; use it at your own risk. For
help importing files of these types, contact Professional Services.

Opening a PDF file as lines
ArtiosCAD can now import the lines (also called vectors) in a PDF file. Previous versions could only
import a PDF file as a graphic entity. Once the PDF file is opened, you can then work on the lines as you
would any other structural workspace.

Before you can import a PDF file as lines, you must make sure there is at least one tuning catalog entry
set up in Defaults to process PDF files. ArtiosCAD comes with two different tuning catalog entries
as examples, but it is likely you will need to make a tuning catalog entry for each supplier of PDF files
based on how they create the files.

Opening the PDF file
To open the PDF file, do the following:

1. Start ArtiosCAD.
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2. Click File > Open.
3. Navigate to the directory or resource containing the PDF file.
4. Select the desired file.

A preview of the file will appear.
5. Click Open.

The Importing PDF File dialog box appears.

Choosing Import Options
In the Importing PDF File dialog box, do the following:

1. In the Tuning Files group, select the tuning file to use for this PDF file. The preview of the design
may change depending on the tuning file you choose.

2. In the Design Side group, choose whether the side up is the Inside or Outside.
3. Set the options similarly in the Die Side, Import as, Flute or Grain, and Design Units groups.
4. Click OK.

Choosing Single Design Settings
In the Single Design Settings dialog box, do the following:

1. Select a parameter set and board to use in the new workspace.
2. Click OK.

The PDF file opens in ArtiosCAD according to the tuning you selected. You can work on it as you would
any other single design.

PDF vector import notes and warnings
Please consider the following notes and warnings when importing PDF files as lines.

• Bitmaps in PDF objects come in as their net shape of their clip path (the outline of the part of the
image that is rendered) and have graphic type bitmap. To preserve the bitmap image, import the
PDF file as graphics rather than lines. The actual pixels of the image are not imported. Note: some
bitmaps in PDF are not defined with a clipping path that is the shape of the thing in the bitmap. An
example is the bitmap for the shadow in an ArtiosCAD Plot to PDF with shadows turned on. In these
cases, the bitmap outline comes in as a rectangle.

• ArtiosCAD has a 99 layer limit. Therefore, complicated PDF files (those with more than 99 unique
sets of import attributes) will typically reach this limit if they use a tuning that maps “any any any” to
New Layer.

• When Unfiltered items to graphics layer in the PDF Import Options dialog box is enabled, a stroke's
cap style, miter style, and miter limit are not preserved. All strokes in this situation appear with
rounded join style and square cap style.

• When Unfiltered items to graphics layer in the PDF Import Options dialog box is enabled, the
strokes and fills may appear underneath things (masked) even though they are visible in the original
PDF file.

• When Unfiltered items to graphics layer in the PDF Import Options dialog box is enabled, objects
with any coloration other than a single color (such as gradient fills, mesh objects, and so forth)
appear as a solid color fill which depends on how the file was created. Gradient fills from Adobe
Illustrator-created files generally come in as black fills.

706



9ArtiosCAD

How to open a Score! file
To open a Score! or Vellum file in ArtiosCAD, do the following:

1. Start ArtiosCAD.
2. Click File > Open.
3. Using either Directory view or Resource view, navigate to where the Score! file is saved.
4. Files of type should be set to Designs. If it is not, click the drop-down arrow and set it to either

Designs or Score!.
5. Click the name of the Score! file to select it.

A preview of the Score! file appears.

 

 
6. Click Open.
7. In the Single Design Settings dialog box, select the desired parameter set and board code, then

click OK.
 

 

ArtiosCAD opens the file and you can work on the file as you would any other design.
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More information about opening a Score! file
The following sections contain reference information to consider when opening a Score! or Vellum file
in ArtiosCAD.

Score! file import restrictions
ArtiosCAD can open Score! and Vellum files with the following restrictions:

• ArtiosCAD does not import data from the Score! database about the file being opened.

• ArtiosCAD maps bridges on ellipses onto the arcs as closely as possible to the original file, but
ArtiosCAD tries to keep the count and position of the bridges even across the series of arcs forming
an ellipse.

Score! file model structure
A Score! file generally contains at least two models: Model 1 for the flat design and Foldup for the
folded design. The contents of Layer1 in Model 1 go into the Main Design layer of the single design. All
other layers in the Score! file go into layers of the same name in ArtiosCAD of layer class Annotation.
If there is a layer named Dimensions in the Score! file, ArtiosCAD makes a Dimensions layer of class
Dimensions in the ArtiosCAD workspace.

When ArtiosCAD opens a Vellum (.vlm) file containing multiple models, those models are imported into
separate layers.

Score! line type mapping
ArtiosCAD automatically converts Score! line types to native linetypes per the entries in the following
table.

Score! line type and name ArtiosCAD line type and name

0, Annotation

10, Crosses

113, Chopper

115, Tester

0, Annotation

101, Knife 1, Cut

102, Crease 2, Crease

103, Perforation 3, Perf

104, Cutscore 4, Cut-Score

105, Cutcrease 5, Cut-Crease

106, Cutscore_Crease 15, Partial cut and crease

107, Reverse Cutscore 9, Reverse partial cut

708



9ArtiosCAD

Score! line type and name ArtiosCAD line type and name

108, Emboss 16, Half crease

109, Zipper

110, Wave

13, Generic special rule

112, Stripping 93, Stripping rule

80, Construction 34, Construction line

All others 0, Annotation

Score! bridging
A Score! file may have one of two different types of bridging: simple or complex.

For a file with simple bridging, ArtiosCAD takes the number of bridges specified and their width and
uses those as the parameters for applying its Evenly spaced bridging formula.

For a file with complex bridging, ArtiosCAD uses the Specify bridge positions bridging formula.
The first bridge width defined in the Score! file sets the width for all the bridges in the ArtiosCAD
workspace. If the Score! file contains any double-width bridges, they are converted to two bridges
separated by a slight gap.

Score! text
ArtiosCAD imports text from Score! files as text with the following limitations:

• Line wrap is ignored; a line will be extended as long as necessary.
• Text color is ignored.
• Line spacing is ignored.
• Underlined text is not supported.

Score! dimensions
ArtiosCAD imports the following types of basic dimensions from Score! files: Horizontal, Vertical,
Parallel, Radial, Diameter, and Angle. Arc Length dimensions will be ignored.

Score! uses # to represent the real value of a dimension; ArtiosCAD changes this to {V} (also the real
value of the dimension) except in the following cases:

• For a Distance or Angle dimension with just # in the dimension text.
• For a Radius dimension with exactly R # in the dimension text,ArtiosCAD will not show any

dimension text, but the format will be set to R50.
• For a Diameter dimension with exactly 0 # in the dimension text, ArtiosCAD will not show any

dimension text, but the format will be set to Ø50.

The table below shows how ArtiosCAD imports other aspects of Score! dimensions.

Score! dimensional element How ArtiosCAD imports it

Text positioning Uses closest matching positioning options
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Score! dimensional element How ArtiosCAD imports it

Arrowhead style Uses closest matching

Arrowhead thickness Imported

Dimension font and size Imported

Dimension color Ignored and set by the plotting style

Extension length and gap Calculated from Score! settings

Units and formatting Set by ArtiosCAD property defaults

Internal dimension extension
lines

Not drawn when dimension text is outside the measured object

Score! fold angles
Most Score! standards are saved with a flattened Foldup model and with fold angles assigned to the
creases.

During the import, ArtiosCAD copies fold angles and the base face from either the Foldup model or the
Foldup layer from Model 1, to the creases in the Main Design layer.

The import of fold angles will not work if the Foldup model or layer does not exist or if the Foldup model
has been folded up in 3D space.

Note:

if there are gaps in the design perimeter, ArtiosCAD cannot automatically convert the design to
3D.

Saving and exporting designs

Saving a design means that the work you have done in ArtiosCAD is written to a file on the hard drive
for future use in ArtiosCAD. ArtiosCAD files are binary files that can be read only by computers running
select Esko applications.

Exporting a design means that you are essentially taking a snapshot of the design and converting it to
a different format for use by someone who does not have ArtiosCAD. Most common export formats are
text formats.

How to save a design
To save a design, click File, and then click Save. If you are saving the design for the first time,
ArtiosCAD will prompt you for the name of the file by displaying the Save As dialog box (see the
next section). Do not use an underscore ( _ ) as the last character of the filename, for that is used to
determine revision history. If you have already saved the file, ArtiosCAD will save the design using the
name shown in the title bar of the window.
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If Design check before Save, Save as is checked in Options > Defaults > Shared Defaults > Design
Defaults > Save Options, the design is checked for double lines and gaps in the perimeter of the design
when it is saved. This option is off by default.

You will also be prompted to enter database information for this design. When you save a design,
ArtiosCAD automatically supplies DataCenter with some information about the design, but you must
specify other information such as the customer name and the designer. Your system administrator may
choose to customize the information requested when saving a design. If the design is not rebuildable,
specify the length, width, and depth if desired. When you are done specifying information, click OK to
save the database information and the design.

If you have opened an existing file, when you save it, ArtiosCAD checks to see if the original file has
been modified before it overwrites it. This will warn you if another user has been working on the same
file at the same time to prevent accidental loss of work.

How to save a design with a different name
Click Save As on the File menu to save the current design with a new name and start working with the
new workspace. Navigate to the desired folder or resource, type the new name in the File name: field
(do not use an underscore as the last character) and click Save.

Files saved using Save As use the date and time at save for the creation date and revision date in the
database record, regardless of the date and time at which the original file was created.

How to save a copy of a design
To save a copy of the current workspace with a new name but continue working with the current
design, click File > Save Copy As. The Save As dialog box will appear. Navigate to the desired folder or
resource, type the name for the copy, and click Save. ArtiosCAD will save the copy and you may resume
working on the current workspace.
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How to save a design using automatic numbering
To save a design using automatic numbering, you must have configured automatic numbering as
described in the  DataCenter chapter. You must also be saving the design (or manufacturing file) in a
resource for which automatic numbering is configured.

Once that is set up, the Save Next Name button in the Save dialog box is available as shown a
few sections previously. It is unavailable for resources which do not have Automatic Numbering
configured. When you click Save Next Name, ArtiosCAD will automatically save the file with the next
available number according to the configuration in DataCenter.

How to save a revision of a design
Use the Save As Revision command on the File menu to save different versions of the same design.
Each revision of the design file shares the same basic name, but there is a progress indicator at
the end of the filename before the .ARD extension. How the file name is changed is controlled by
Options > Defaults > Startup defaults > Revision Disk File Format; see the Defaults chapter for more
information.

For example, the first time you save design REVTEST, it is saved as REVTEST.ARD. The next revision
of the same design would be saved automatically as REVTEST_~.ARD, and then REVTEST_A.ARD,
REVTEST_B.ARD, and so forth.

If you change the file somewhat, but still want to keep the original for reference, click Save As Revision
on the File menu. The Save As Revision dialog box will appear.

Enter a description of the file, and enter any authorization message, such as Approved by Mike
or OK per JG. If desired, enter a revision description indicating what changed from the previous
revision. Migrate the Projects information to the new revision by selecting the checkbox next to the
Project name. To keep the Project information in the old revision, clear the checkbox next to the
Project name. Click OK to save the file.

When it is time to open the design again, use Resource view. Resource view also allows you to view all
revisions of a file, or only the most recent.
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Click  to view all versions of a design.

Click  to view only the most recent revision in the list of files.

How to save a self-contained parametric design
Rebuildable ArtiosCAD designs can be made of many components. To save a rebuildable design
with everything comprising it saved in the same workspace, define an Output in Defaults that has
Embed dependent files checked on the Information Filter tab. Then use that Output to create the self-
contained parametric file.

To find out which files will be included, click Design > View Parametric Dependencies. This menu
option is available only for rebuildable designs. The View Parametric Dependencies dialog box will open
and show the included components, if any, of the current rebuildable workspace. Files that are not
currently marked as embedded will be automatically embedded in the workspace when the Output is
run.

When the parametric design is rebuilt by the recipient, embedded components take precedence over
local files with the same name as the embedded component.

To delete an embedded component and use the local version (if one exists - it must have the same
name as the embedded component), select it and click Delete Embedded. You can only delete
an embedded component if there is a workspace with the same name in the ArtiosCAD program
directories. When you delete an embedded component, the EMBEDDED designation is replaced by the
location of the component on the local system.

Self-contained parametric designs may be added to a Style Catalog and run as a standard. Any
embedded components in the standard will be embedded in the resulting single design.

How to export a design to a different format
To export a design to a different file format, click File > Export, and then click the format in which to
export the design.
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VDS1 stands for Verein Deutsches Stanzformbauer, a format used in Europe.

Once you have chosen a format, an Exports dialog box will appear allowing you to specify the directory/
resource and filename.

All files are exported to the current directory by default. This is usually \Esko\Artios\Designs.
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Click OK if the settings are correct. You may want to go through all the property sheets (by clicking
Properties) to make sure the settings are appropriate for your needs.

After you have clicked OK, you will be prompted for a name for the file in the Save As dialog box. Enter
a name without spaces and click Save. The file will be created according to the settings in the Outputs
dialog box.
 

 

When exporting a DDES file, the Job Name is set to the first 7 characters of the file name, and A for
the first subroutine, B for the second, and so on. When exporting a DDES3 file, print items are not
supported, and decimal places should be set to 4 or less to ensure accuracy.

ArtiosCAD can output DXF files in different ways:

• DXF. This option uses the built-in method to create a DXF file.

• DXF Binary. This option creates a binary DXF file using a third-party library that has more features
than the built-in method.

• DXF-New. This option creates a text DXF file using the third-party library.
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When exporting an EPSF file, you can either export it as an Illustrator 3-compatible file or an Illustrator
8-compatible file. Exporting it as version 3 or 8 makes those respective versions of Illustrator treat it as
a native file.

To lock a layer in EPSF files when they are output, copy ..\InstLib\tune.epsf.txt to ..
\ServerLib and change the ninth parameter of each group of lines to 1. The tuning file may not
have a ninth parameter; in that case, simply add the numeral 1 to the end of each layer’s line pair if
necessary. Other values such as the line color, layer name, stroke width, and so forth are controlled by
the EPSF tuning file, not by the plotting style. The plotting style affects only the Output preview.

To export an EPSF file with all elements colored black, on the Device tab of the Properties
dialog box of the Output, browse for the \Esko\Artios\ArtiosCADn.nn\InstLib\
TUNE.EPSF.BLACK.TXT tuning file in the Tuning Filename: field.

When exporting a 3D workspace to Illustrator 8, and there are imported PDF graphics on the design,
and you have the PDF option, you can set the resolution of the bitmaps in the High graphics memory
use drop-down list box on the Device tab of the Properties dialog box for the Illustrator export.

Font notes and warnings when exporting as PDF

Only TrueType fonts are exported to PDF. TrueType fonts have this symbol  before their names. If text
uses a non-TrueType font, the default font from Property Defaults is used. If the default font cannot be
found, ArtiosCAD will use Arial. The output preview will show non-TrueType fonts correctly but they will
be replaced in the actual PDF file.

Graphic fonts such as Symbol and WingDings are not supported.

Fonts defined in .ttc files are not supported.

Fonts with vertical text (those with @ preceding their names) are not supported.

Data Exchange Plug-In
The Data Exchange Plug-In lets Adobe Illustrator users open or place native ArtiosCAD single design
workspaces without the need for the ArtiosCAD user to convert to EPSF. There also are dedicated tools
for moving the entire CAD structure within Illustrator and aligning graphic elements to it. The plug-in
can be downloaded from Esko 's Web site at http://www.esko.com.

The plug-in works with structural data only. It does not read bitmap images, fills, or manufacturing line
types into the Illustrator workspace.

For more information on the plug-in, refer to the documentation that is included in its installation
package.

How to export files to the ArtiosCAD Viewer
No special export is needed for the  ArtiosCAD Viewer. It can open native .ARD and .A3D files.

ArtiosCAD workspaces are binary, not text.
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How to export files to previous versions of ArtiosCAD
If you need to send designs to people using earlier versions of ArtiosCAD, you need to export them
so that their versions will read your files properly. In some cases, information like manufacturing
parameter sets will have to be reselected by the recipients.

To export the file, click File > Export, and choose the software version that is less than or equal to the
recipient’s software.

If you need to strip information out of the files, use the Information Filter.

Exporting Splines to a DXF/DWG File
If you have imported a DXF/DWG file containing splines of degree 4 to 7, ArtiosCAD can export them to
a new DWG/DXF file. There are a few things you need to do for this to work.

1. In the workspace you are exporting, if arcs were originally splines, they export as splines if the
original spline had a single segment and the number of control points equaled the degree plus 1,
AND the arcs are intact and not split by nicks or bridges.

2. Modify the DXF tuning file, tune.DwgDxf.txt. It is prudent to save a backup copy of the original.
It lives in ..\Esko\Artios\ArtiosCAD_version\InstLib if you use Standard Edition or
in the InstLib folder of the Shared Defaults Project of the version of ArtiosCAD Enterprise you are
using (don't forget to change the Files of type drop-down list box to all files so it appears in the file
list). Add a space and the number 1 to the end of the first uncommented line of the file. Change this:
 

 
to this:
 

 
3. Check the driver for the DXF or DWG output you are using. On the Device tab, CAM Driver in the

Tuning Entry group must be set to DXF-New or DWG.

You only need to check items 2 and 3 once.

If all the conditions are met, you should have a successful spline output.

Working with Multilingual Text

Starting with version 18.1, ArtiosCAD offers more support for multilingual text because it has changed
from supporting only multi-byte characters to also supporting UCF-8/Unicode characters. Because so
many areas are affected, the notes are centralized here.

New Installations
New installations using the included database engine:
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• Will be Unicode-capable
• Will have a collation ending in _SC
• Will use NVARCHAR as the string column type

New installations using SQL Server (the full version installed, supported, and maintained by your IT
department):

• Use whatever collation desired but append _SC to the end
• Must use NVARCHAR as the string column type
• Versions after 2012 automatically support Unicode

New installations using Oracle (installed, supported, and maintained by your IT department):

• Set the database character set to AL32UTF8
• Turn on Force SQL_WCHAR Support on the Workaround tab of the ODBC entry
• Create the schema using VARCHAR string columns

Existing Installations
There is no automatic database conversion of existing installations.

• Only characters that exist in the operating system code page are stored properly; others are
represented as ?. This will be handled by the database collation itself.

• Your IT department’s SQL Server and Oracle DBAs are responsible for using the correct datatype
when running the scripts and/or converting those databases

• All versions of SQL Server, including Express ones, must use the Management Studio tools to
perform a conversion.

File Formats
CFF2, DDES, EPS, and pre-2007 versions of DXF all do not support Unicode characters.

Post-2007 DXF/DWG formats support them. The DXF-New and DXF-Binary entries in the Export to
Common File Formats catalog of Outputs in Defaults can use either 2007, 2010, or 2013 formats to
support Unicode characters.

Collada files support Unicode characters.

IGES does not support Unicode characters. Non-ASCII filenames will cause the Output to fail. For
canvases, ArtiosCAD converts non-ASCII part names to underscores.

STEP does not support Unicode characters in filenames. It uses a proprietary format to encode non-
ASCII filenames during export that ArtiosCAD does not read.

XCGM allows the output of non-ASCII filenames and part names, but ArtiosCAD cannot import them.

If there are questionable characters in file or part names when saving or exporting, ArtiosCAD shows a
grid with suggested new names and allows you to adjust them.

For Outputs made using the GNC driver, Use Unicode (UTF-8) for text output is available on the
Unicode tab of the Output definition. This option is off by default as most systems reading the result
only support multi-byte characters.

PDF has an option in Startup defaults > PDF Options. Use outlines for characters missing in font
when exporting. ArtiosCAD outlines text for which all characters do not exist in the desired font, and
warns that some characters will be missing from the resulting file.

Limitations
If you make a design with Unicode characters in version 18.1 or later, versions earlier than 18.1 will not
render the text correctly.
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Going forward, all characters must be in the same code page of the design. If there are characters
outside of the code page of the design when it was first created, ArtiosCAD will not show them
correctly.

For a design created in earlier versions of ArtiosCAD that uses characters outside of the design’s code
page (which render incorrectly), ArtiosCAD 18.1 and later will still show those characters incorrectly as
it assumes all characters are from the design’s code page.

For existing databases, characters will appear correctly in ArtiosCAD but will not be stored correctly in
the database.

Tuning files do not change format and use the current operating system code page to write characters.
This means that layer names, special rule names, and other text will not be in Unicode.

Workspace variable names cannot use multilingual characters. Use lowercase and uppercase English
letters, numbers, and $ at the end (if desired) as before. The naming restriction applies to Stylemaker
menu names and tool prompts as well.

Right mouse button functionality

Clicking and releasing the right mouse button activates a context menu from which you can perform
common tasks.

Single Design

In Single Design, the first click of the right mouse button ends the current tool and activates the Select
tool. If there is an object under the cursor, the second click of the right mouse button selects the
object and opens a context menu as shown below.

The Paste command appears only if something has been previously cut or copied.

If there is nothing under the mouse cursor when the right mouse button is clicked, and nothing is
selected, a general context menu is opened similar to the one shown below.
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Plotting styles which have the Output only checkbox selected in their definition in Defaults will not
appear in this context menu.

Canvases

Canvases have four context menus whose contents depend on the location of the mouse cursor.
Commands on these menus act on what is beneath the cursor.

When it is in the canvas, not over any part:
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When it is in the active part, but not over a line:
 

 

When it is in the active part, over a line:
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When it is in a non-active part:
 

 

Anywhere over a layout part:
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Manufacturing

Clicking the right mouse button in Manufacturing stops the current tool but does not automatically
start the Select tool.

When the Select tool is active in Manufacturing, clicking the right mouse button has the same
functionality as it does in Single Design.
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3D

Clicking the right mouse button in 3D when the cursor is over a design line stops the current tool,
selects the object under the cursor, and opens the context menu shown below.

When there is no current selection and the cursor is not over a design line, a context menu for
accessing common commands appears as shown below.

Using the spell checker

If you have Microsoft Word 2000 or later installed on your system, ArtiosCAD can use its spell checking
functionality in Single Design and Manufacturing in most places where you enter text using a field in
a dialog box. As you type, specific keystrokes trigger the spell check: Backspace, Enter, Space,
exclamation point, close parenthesis, comma, period, semicolon, question mark,
and close brace.

There are three ways to use the spell checker. The first is by using the Paragraph Text tool. The
second is by entering text in fields in the Database Information dialog boxes, both default and custom,

724



9ArtiosCAD

and other text-entry field such as those in the Properties dialog boxes for text and dimensions. The
third is by executing a document-wide spell check by clicking Tools > Check spelling.

To learn more about using the spell checker in the Paragraph Text tool, see Spell checking in the
Paragraph Text tool for more information.

Spell checking in fields

Fields that support spell checking have an emphasized border, and any misspelled words within them
are underlined and shown in red. Right-click in the field and choose Spell from the context menu to
open the Spelling dialog box.

725



9 ArtiosCAD

The first time you activate a tool or dialog box in ArtiosCAD that supports spell check, ArtiosCAD
launches Microsoft Word in the background and communicates with it as needed during the ArtiosCAD
session. This initial launch of Microsoft Word may cause the ArtiosCAD dialog box to take a few extra
moments to open, depending on the speed of your system. Once Microsoft Word is running in the
background, dialog boxes supporting spell check appear at their usual speed.

When you right-click a field and choose Spell, the standard Microsoft Word Spelling dialog box appears
as shown below.
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The unrecognized word is shown in the Not in dictionary: field. The Suggestions: field contains the
list of suggested words, and the top one is selected and seeded to the Change to: field. If there are no
suggestions, the unrecognized word is repeated. You can edit the contents of the Change to: field as
desired.

Ignore and Ignore All respectively ignore this instance and all subsequent instances of the
unrecognized word for this invocation of the spell checker. The next unrecognized item is then
displayed.

Change changes the unrecognized word to the selected suggestion or the word you entered in the
Change to: field. Change All changes all subsequent instances of the unrecognized word in the
workspace to the selected suggestion or the word entered in the Change to: field; previously-ignored
instances are not changed. The next unrecognized item is then displayed for review.

Add adds the unrecognized word to the ArtiosCAD custom dictionary file so that it will be recognized
in the future. The next unrecognized item is then displayed. This command is disabled if the custom
dictionary is not installed or is not editable.

Close closes the Spelling dialog box.

Spell checking through the whole workspace

You may also spell check all text items in the workspace by clicking Tools > Check Spelling. Note that
this method does not check database entries for unrecognized words. This tool is available regardless
of the state of the Enable spell checking option in Defaults.

When this tool is activated, each text item in the workspace is checked for unrecognized words,
including text items in locked layers. If an unrecognized word is found, the entire text item is shown
with the unrecognized word underlined and shown in red as shown below.
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The options in this dialog box work the same way as described in the previous section.

Once you ignore, change, or add an unrecognized word, the next text item is checked. When all text
items have been checked, Close is the only available option in the Spelling dialog box.

Notes about spell checking

The spell checker does not flag repeated words.

When you exit ArtiosCAD using File > Exit, ArtiosCAD terminates the associated Microsoft Word
process. If ArtiosCAD terminates abnormally, the Microsoft Word program WINWORD.EXE may still
be left running; use Task Manager to end it. If you then launch Microsoft Word using the Start menu, it
may show ArtiosCAD Spell Check(number).doc as being available for auto-recovery as shown
below. No such temporary files need to be recovered or saved, and you may delete them from the hard
drive.
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These temporary files are the means by which ArtiosCAD interfaces with Microsoft Word to check
spelling. If you are using Microsoft Word at the same time that ArtiosCAD is running, the temporary
file may be shown on the Window menu in Microsoft Word. Do not open the temporary file, as this will
break the connection between ArtiosCAD and Microsoft Word, and spell checking in ArtiosCAD will be
disabled until you reactivate the tool which invoked it.

The custom dictionary file CUSTOM.DIC is stored in \ArtiosCAD installation folder
\Common\Proof. To edit it, close ArtiosCAD and use WordPad (not Notepad) to edit it. Put each word
on a separate line and save the file as type Text Document. Do not change this file while ArtiosCAD is
running, as it will not reflect the changes.

Publishing ArtiosCAD documents to WebCenter

Publish to WebCenter on the WebCenter menu allows you to publish a single design, a manufacturing
file, or a 3D workspace to WebCenter, Esko's design lifecycle management software. Shown below is
the menu in Single Design.
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Before you can publish to WebCenter, the ArtiosCAD system administrator must have configured
an WebCenter site in the WebCenter catalog in Defaults, and the WebCenter system administrator
must have created a user account with sucient permissions for you to use. When ready, publish to
WebCenter by doing the following:

1. Open the desired document in ArtiosCAD.
2. Click WebCenter > Publish to WebCenter.
3. If ArtiosCAD is configured to prompt for information, the Publish to WebCenter dialog box appears.

If prompted, enter the WebCenter username and password supplied to you by the WebCenter
system administrator. The Document, Project, and Folder fields are completed by default to be
based on the name and type of the ArtiosCAD document.

The ArtiosCAD system administrator can define the Publish to WebCenter entry in Defaults so that
all, some, or none of these fields are pre-completed.

Click OK to publish the document to WebCenter once all the fields are completed.
4. If the document already exists in the specified Project, you will be prompted to enter a comment

about the new version as shown below. Enter a comment and click OK.

5. The Publish to WebCenter dialog box should change to match the one below.
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Clicking  Go To Project opens the Project in WebCenter. You must log in to WebCenter if you are not
already logged in.
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Clicking  Go To Document opens the document. You must log in to WebCenter if you are not already
logged in.

Click OK to stay in ArtiosCAD.

In the rare event that the document does not appear in WebCenter and no error is shown, check that
the WebCenter address field in the Publish to WebCenter entry of the WebCenter catalog in Defaults is
correct.
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Portable Workstation mode

Portable Workstation mode lets an ArtiosCAD system using shared network resources such as the
database or Shared Defaults detach from the network and operate as if it were standalone with no
database. When you enter Portable Workstation mode, ArtiosCAD copies necessary elements from the
network servers to the local machine (called synchronizing) and disables the database.

Note:  Detaching ArtiosCAD from the network servers does not actually break the network
connection for other applications in the operating system.

There are important restrictions when using Portable Workstation mode:

• Using Portable Workstation mode requires local licensing; that is, a License Manager client may
not use Portable Workstation mode. Upon attempting to enter Portable Workstation mode, the
licensing will be checked and you will be prevented from entering it if the licensing method does not
support it.

• Any workspaces needed that normally reside on network resources must be manually copied to the
local system. Likewise, anything extra data needed (symbols, graphics, Reports, and so forth) that
are not in ServerLib or Common must also be copied manually. Subdirectories of ServerLib and
Common are copied (except for Common\Program).

• If you changed the search list in the Windows Registry, the changes are ignored.

• When reconnected to the network, you must resave any workspaces created while in Portable
Workstation mode in resources to put them into the database.

• Detaching from the network is done on a per-user and per-ArtiosCAD-version basis. For example, if
you plan to use more than one version of ArtiosCAD while disconnected from the network, you must
synchronize and detach each version before disconnecting from the network. Likewise, each user
on the machine must detach each version of ArtiosCAD that he or she will use while detached.

• If the Start in property for any ArtiosCAD icon is set to a network location, it must be changed to a
local drive. Right-click the icon, click Properties on the context menu, examine the contents of the
Start in field, and change it to a directory on the portable workstation’s drive (such as C:\temp)
if it points to a network drive (S:\users\wmeeber\CAD) or a UNC location (\\mbcfileserv
\users\wmeeber\CAD).

• DataCenter Admin uses the database specified by the System DSN ODBC data source regardless
of the state of Portable Workstation mode. If you use a network database and detach from the
network, DataCenter Admin will continue to function until the network is disconnected. If you
detach and disconnect from the network and use a local database, DataCenter Admin will continue
to function using your local database if you change the System DSN to point to your local database.
If you do not use a local database after detaching and disconnecting from the network, DataCenter
Admin will not function correctly as it will be searching for the networked database. Do not start
DataCenter Admin if you will not be using a local database when disconnected from the network.

Using Portable Workstation mode for the first time

Using Portable Workstation mode for the first time involves performing required tasks that are not
required with subsequent uses.
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Detaching from the network
To use Portable Workstation mode and detach from the network for the first time, do the following:

1. Make sure the network is connected to the computer.
2. If necessary, change the Start in property for the ArtiosCAD icon.
3. Start ArtiosCAD.
4. Click Options > Portable Workstation > Detach from Network.
5. The Portable Workstation Tasks dialog box will open as shown below.

6. A list of tasks is displayed.

• Selected tasks have checks in their associated checkboxes.

• Grey checkboxes may not have their state changed.

• White checkboxes may be changed as desired.

• Tasks with an asterisk (*) before their names must complete successfully for the workstation to
enter portable mode.

• Tasks have different default states for the first time they are run versus being run after a
successful detach.

In general, there are two kinds of tasks, copy tasks and back up tasks. Copy tasks copy data
from the network servers to the local machine. Back up tasks make backups of the copied data
on the portable workstation in case it becomes corrupted and unusable. Each copy task has a
corresponding backup task. The Disable the portable workstation’s access to the database task
neither copies nor backs up.
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Table: Tasks and Their Actions

Task Action Can be skipped if

Copy the
ServerLib
folder from the
configuration
server to
the portable
workstation

Copies the Shared Defaults and shared
files (such as custom Reports) from the
Configuration server. If the portable
workstation is configured as its own
standalone Configuration server, the
information and files are copied to another
location on the portable workstation.

You have recently
synchronized and you are
confident it meets your
needs.

ArtiosCAD is installed
as standalone or as a
Configuration server and
thus uses its own set of
Defaults and shared files.

Copy the Common
folder from the
LM server to
the portable
workstation

Copies the files from ..\Artios\Common
on the License server to the portable
workstation. This copies licensing information
and board textures. This task must be
selected if the workstation is not its own
License server and uses a security key. No
subdirectories are copied. Previous copies
are deleted each time this task runs.

Note: The only kind of licensing that will
work with Portable Workstation mode and
a networked License server is when there
is a hardware key physically attached to the
portable workstation and the TUNEOPT7.TXT
is stored on the License server. If you are in
this mode, you must run this task.

You have recently
synchronized and you are
confident it meets your
needs.

ArtiosCAD is installed as
standalone or as a License
server and thus uses its own
set of Common files.

Disable the
portable
workstation’s
access to the
database

Ensures no database connection is attempted
when opening or saving a workspace, and
disables all database-related fields and
dialog boxes except for boards. This includes
the Database dialog box in Defaults, the
Database Information dialog box in Single
Design, Layout, and Manufacturing modules,
AutoLoad, the three database browsers,
Projects, Search on the File menu, and the
Resource View tab in the Open dialog box.

You have a local database
you want to use after
detaching from the network,
which would require
changing the ArtiosCAD
System DSN ODBC entry.

Copy board list
to the portable
workstation

Copies the boards, board hierarchy, mediums,
and flutes from the Database and License
servers to the portable workstation.

You have recently
synchronized and you are
confident it meets your
needs.

ArtiosCAD is installed as
standalone or as a License
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Task Action Can be skipped if

server and a Database
server.

Copy site
configuration
to the portable
workstation

Copies custom User Defaults used for “site”
defaults that are stored in a network location
to the portable workstation.

You do not use networked
User Defaults in such a
manner.

Back up... Makes a backup copy of the information being
copied from the network. These backups
can then be used in the event of a failure of
a future synchronization. Each time there
is successful synchronization, the previous
backups are deleted if the corresponding
backup task was selected.

You have previously
successfully synchronized
and backed up the copy
tasks.

Beneath the list of tasks is a progress indicator for the current task.

Beneath the task progress indicator are four buttons.

• Synchronize and Detach performs the selected tasks and prepares ArtiosCAD for the network
to be disconnected. Note that the actual network connection is not changed; that you must do
outside of ArtiosCAD. We strongly recommend running all the selected tasks the first time you
enter Portable Workstation.

• Synchronize performs the selected tasks but does not prepare ArtiosCAD for the network to be
disconnected. This command is available only after the first Synchronization and Detach.

• Detach detaches the computer from the network. You must perform a Synchronize before using
Detach.

• Close closes the dialog box. Close changes to Cancel when a task is running. If you click Cancel,
all tasks are cancelled and the state of ArtiosCAD is rolled back to how it was when the dialog
box opened.

7. Click Synchronize and Detach once you have reviewed the tasks to run. The selected tasks will run
and result indicators will appear next to each task similar to those shown below.

8. ArtiosCAD is now running in Portable Workstation mode. Use it as desired. To use a local database,
change the ArtiosCAD ODBC entry and restart ArtiosCAD.
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Some tasks may have different result indicators than those shown in the preceding example.

Table: Task Result Indicators

Icon Meaning

A green arrow means the task is running.

A green checkmark means the task succeeded.

A red X means the required task failed and the workstation cannot enter Portable
Workstation mode.

A red exclamation mark means a non-required task failed, but the workstation can enter
Portable Workstation mode. This is mostly used for back up tasks.

A yellow exclamation mark means a task succeeded, but there is a note. Click the plus
sign (+) next to the task to see what happened. This is mostly used when a task is not
selected.

A green exclamation mark means a non-required task succeeded, but there is a note.
Click the plus sign (+) next to the task to see what happened. This is mostly used when a
back up task has succeeded.

A yellow question mark means the task is in an unknown state. This is mostly used when a
task is not selected for synchronization.

If a task was successfully synchronized for a Detach, it will always succeed for subsequent Detaches.

Backup tasks that fail synchronization do not prevent the workstation from entering Portable
Workstation mode.

If a required task fails, the workstation can still enter Portable Workstation mode provided its
corresponding backup task has been synchronized in a prior Detach.

If a task fails to synchronize, a future Detach will not allow it to Detach until it is successfully
synchronized.

Attaching to the network

When you no longer need to use Portable Workstation mode and want to set ArtiosCAD back to its
networked state, do the following.

1. Reconnect the physical network connection.
2. Start ArtiosCAD.
3. Click Options > Portable Workstation > Attach to Network.
4. The Portable Workstation Tasks dialog box appears similar to the one shown below.
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5. Click Attach to reconnect ArtiosCAD to its networked resources. The tasks will run and result
indicators will appear next to the tasks similar to those shown below.

6. Click Close to close the Portable Workstation Tasks dialog box.
7. Open any workspaces you made while in Portable Workstation mode and resave them into

resources, entering database information as necessary.
8. Resume working with ArtiosCAD as desired.

Subsequent uses of Portable Workstation mode

After you have used it once, on subsequent uses of Portable Workstation mode, you can choose the
tasks to perform when detaching. Most of them are still selected by default. Synchronize and Detach
are both independently available.
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If you are confident that no network information has changed since you last Synchronized, you can
Detach without performing a Synchronize first. Correspondingly, if you want to update the local copies
of the network information, you can Synchronize without performing a Detach. Shown below are the
results of Detach without a Synchronize with all the information shown.

Attaching to the network in subsequent uses of Portable Workstation mode is the same as it was the
first time. To attach to the network, do the following:

1. Reconnect the physical network connection.
2. Start ArtiosCAD.
3. Click Options > Portable Workstation > Attach to Network.
4. In the Portable Workstation Tasks dialog box, click Attach to reconnect ArtiosCAD to its networked

resources. The tasks will run and result indicators will appear next to the tasks.
5. In the Portable Workstation Tasks dialog box, click Close.
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6. Open any workspaces you made while in Portable Workstation mode and resave them into
resources, entering database information as necessary.

7. Resume working with ArtiosCAD as desired.

Limits in ArtiosCAD

ArtiosCAD has the following overall limits:

Item Limit

Number of layers in designs 251 (including Main Design)

Number of layers in manufacturing workspaces 100

Number of parts in canvases 250 (149 when using Convert to Canvas)

Number of unique parts per layout sheet 99

Copies per production part in a canvas (note that
this is independent of all other functions and is
meant only to facilitate faster layout-making)

250

Copies of a layout part (more sheets) unlimited

Layouts per job in a canvas 20

Items per layout in a canvas 300

Copies of a one-up per sheet in a canvas or
manufacturing workspace

300

Unique one-ups per sheet 99

Print items per workspace 250

Special rules per workspace 39

Colors per workspace 999

Fonts per workspace 39

Number of variables per workspace 260,000

Field variables per workspace 200,000

Number of duplicated designs to which you can
add holes using Add Hardware in 3D

40 or fewer

Number of holes per panel Add Hardware can
create in 3D

500

Total number of holes per design created by Add
Hardware

1,000

Cumulative hardware part counts per canvas 250,000,000

Customized toolbars 150 in for single designs and canvases, 149 for
manufacturing files

Number of punch holes per design recognized as
anomalies in Preflight

5000
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Item Limit

Number of Assembly Instructions panels with
different images per workspace

100 to 200

Number of Assembly Instructions panels with few
images per workspace

About 500

Outputs Up to 50 pages
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10.  Introduction to ArtiosCAD Enterprise
ArtiosCAD Enterprise continues its history of providing robust project management features to the
world’s best-selling, most popular structural design software for packaging.

Before you can start using ArtiosCAD Enterprise, your system administrator must provide you with a
username and password. These are only for ArtiosCAD Enterprise; they are not your operating system
or network login credentials.

Concepts

For Project and file management, ArtiosCAD Enterprise works with managed files, which are stored in
Projects in WebCenter. Managing your design files with ArtiosCAD Enterprise helps you to reach your
business goals faster with less error.

Note:

You can also work with unmanaged files that are saved directly on a hard drive instead of
through the managed file interface.

Logging In For The First Time

Logging in for the first time is a straightforward process but can take a few minutes to configure a
license and if you set up your system to work with Defaults.

1. Launch ArtiosCAD Enterprise.

The ArtiosCAD Enterprise login dialog box appears.
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2. Using the information given to you by your system administrator, enter the type of login, the address

of the server, and your username and password if using them as shown below. If you are using
Single Sign On (SSO), you can choose to try to automatically log in next time. Click Log in.
 

743



10 ArtiosCAD

 
3. ArtiosCAD Enterprise prompts you to select a license method. See the next section for more

information.
 

 
4. Since this is your first login, ArtiosCAD Enterprise prompts you to build your local Defaults cache for

faster performance. Click Yes.
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ArtiosCAD Enterprise builds the Defaults cache. This process only takes a few minutes depending
on your connection speed. If your system administrator did not invite you to the Shared Defaults
project, you will get a permission denied error message.
 

 
5. If you have a previous version of ArtiosCAD loaded on this machine, and you are a Project Manager,

ArtiosCAD may ask if you want to migrate the User Defaults of a previous Standard Edition version
loaded on this machine into this Enterprise version.
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a) If you click Yes, select the version’s User Defaults to migrate and click OK. Clicking No will skip
copying any User Defaults from ArtiosCAD
 

 
b) ArtiosCAD shows a progress indicator during the migration.

 

 
6. If this is the first time you are starting ArtiosCAD Enterprise, it will show the Product Information

page. You may be prompted to accept cookies.
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Click Don’t show this again to hide the Product Information page on subsequent startups. It will
appear again when you install a new version, or after about 100 days to make sure you see the latest
information. You can also access this page in a Web browser by clicking Help > ArtiosCAD News.

Entering Licensing Information
The first time you start ArtiosCAD, it will prompt you to enter licensing information before the splash
screen appears for ArtiosCAD Standard Edition and after the login dialog box for ArtiosCAD Enterprise.

1. In the Welcome to ArtiosCAD dialog box, click the licensing method to use: I received an HTML file
with a Product Key, I know the name of my License Server, or I have an Esko ID to sign in and to
use my Subscription.
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2. If you chose the HTML file with product key option, the normal Esko Activate Local License wizard
starts. Proceed as instructed on the screen.
 

 
For more information, please refer to the Local License Manager documentation available at http://
www.esko.com/support.

3. If you chose the license server option, enter the name of your license server and click Connect. To
specify a specific network port on the license server, use the syntax port@servername.
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If all network licenses are in use, ArtiosCAD displays an error message. Click Show licenses
currently in use to see a list of who is using a license so you can ask another user to release a
license. For more information, please refer to the Network License Manager documentation
available at  http://www.esko.com/support.

4. If you chose the Esko ID and subscription option:
a) Enter your email address and password for your Esko ID and click Sign In.

 

 
b) Once the license is initialized successfully, click anywhere in the dialog box to continue starting

ArtiosCAD.
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For more information, please refer to the Local License Manager documentation available at 
http://www.esko.com/support.

Changing the License Location
If you need to change the ArtiosCAD license location and your current license still works, close all
documents and click Help > License Location.
 

 

Choose Use Local License to use either a local or a subscription license.

Choose Use Network License to use a network license provided by a license server. ArtiosCAD will also
use any available local or subscription licenses in addition to the network one.

Click OK to apply the change and return to ArtiosCAD.

If your current license no longer works, ArtiosCAD will prompt you to choose a license method when it
starts.

Note:

If you need to change the license location on a system running both 32-bit and 64-bit versions,
change it using the 64-bit version.
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Signing Out of Your Subscription

Note:  You only need to sign out if you want to release your license. You do not need to sign out
just to exit ArtiosCAD.

To sign out of your subscription license and quit ArtiosCAD, do the following:

1. Close all open ArtiosCAD documents.
2. Click Help > Sign Out.
3. In the ArtiosCAD Sign Out dialog box, click Sign Out & Quit.

 

 
4. ArtiosCAD releases your subscription license and closes. The next time you start it, ArtiosCAD will

prompt you for license information.

Adding and Removing Server Locations

When you log in, the Address field in the Login dialog box can be a drop-down list box if you add
different addresses. Note that these address entries are saved only on your computer and are not
replicated on other user’s computers.

To add an address to the drop-down list box, do the following:

1. Launch ArtiosCAD Enterprise.
2. In the Login dialog box, enter a server’s address in the Name field.
3. Click Add at the end of the Address field.
4. In the Add Location dialog box, enter the server’s name in the Name field and click OK (the Address

field is copied from the Login dialog box).
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The location is now available in the Address drop-drown list box.
 

 

To add another location to the list, clear the Address field, enter a new address, and click Add.

To remove a location from the list, select it from the Address drop-down list box and click Remove.

Mode and Status Indicators

ArtiosCAD Enterprise shows the name of the active file in the title bar of the window. If the file is
managed, the draft status or the revision number or letter is shown after the filename.
 

 
 

 
 

 

ArtiosCAD Enterprise is in online mode when it can connect to WebCenter, and is in oine mode when
it cannot connect to WebCenter. You can use oine mode with few differences from online mode; your
work will be synchronized with the server the next time you enter online mode. The Status bar indicates
which mode you are in.
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Changing the Logged-In User or Server

To change the server you are using or the user you are logged in as, do the following:

1. Close any open ArtiosCAD Enterprise documents.
2. Click Database > Change Login.

The Login dialog box appears.
3. Enter new information in the Address, Username, and Password fields, and click Login.

If you entered valid connection information, the name of the logged-in user changes on the Status
bar of the blank ArtiosCAD Enterprise window.

Changing Location

To change your location for the current session of ArtiosCAD Enterprise, do the following:

1. With no documents open, click Database > Change Location.
2. The contents of the Change Location dialog box depends on your privilege level as defined in

WebCenter. If you are a member of ADMINS, you automatically see all companies and locations, as
shown below. If you are a Project Manager with Full Visibility, you will initially see only your company,
but Show All Companies/Locations will be available for you to select. If you are a Project Manager
with Limited Visibility or a normal user, you will only see your location.
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3. To filter the results, enter a filter term in either filter field. ArtiosCAD updates the results as you

type.
4. Click the desired location.
5. Click OK to return to ArtiosCAD

An Example of Using Change Location
An example of using Change Location would be when you had to use Defaults (like a Report or a
geometry macro) from another location of your company, but with your own machinery at your
location. This example assumes you are at least a Project Manager with Full Visibility.

1. Launch ArtiosCAD Enterprise and log in as yourself.
2. Click Database > Change Location.
3. In the Change Location dialog box, select the location that has the Defaults you need to use and

click OK. You must be either a member of ADMINS or be a member of that location's Location
Defaults Project.

4. Click Options > Defaults to open Defaults.
a) Drag and drop the needed Defaults from the Location Defaults pane to your User Defaults.
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b) Click File > Exit and click Yes to overwrite the User Defaults.
5. Click Database > Change Location.
6. In the Change Location dialog box, select your location and click OK.

You will now have the Defaults you need from the other location combined with your own so you can
complete your work.

Introduction to Oine Mode

When you want to disconnect your computer from the network, use oine mode. ArtiosCAD Enterprise
copies the necessary database information of Projects you have downloaded to your computer so that
you can continue working normally, and then synchronizes it with the server when you reconnect to the
network.

See the section about Oine Mode for more information.

Using the Browser

The browser is the main way to use the Project management features of ArtiosCAD Enterprise. To open
the browser, you can:

• Click File >  Browser.

• Press CTRL-B.

•
 If a design or manufacturing document is already open, click the Browser button on the toolbar.

Browser Window Elements

The browser has 3 or 4 main areas depending on which panels you have open.
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Area Function

1 The menu bar, toolbar, and display bar, where you use commands and tools,
search for Projects and documents, and control what is shown in the document
list.

2 Tree control where you select which Project or folder to view, either managed or
unmanaged. ArtiosCAD also shows search results and Tasks here. Drag the bar
between the tree and the document list to adjust the size as desired.

Note:  In order to see Tasks, your WebCenter system must be licensed
appropriately, and you must have the appropriate permissions to use
them.

3 List of documents and folders in the selected Project or folder, or search
results, recent Projects, or Tasks depending on the node you select in the tree.
If you have the document preview and properties pane turned on, drag the
horizontal bar between the document list and the preview and properties pane
to adjust the size as desired. The sort order is the BOM, then Tasks (if available),
then folders, then documents.

4 Preview and properties pane which you hide or show by clicking the chevron
button. The contents of the properties pane depend on what you select in the
tree - when you select a Project, ArtiosCAD shows Project-related information,
when you select a document, ArtiosCAD shows design-related information, and
when you select a Task (if available), ArtiosCAD shows Task-related information.
The properties pane is blank when you select multiple items.
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Area Function

Note:  To see a preview of Collada files, either in the preview pane or
as an icon in the document list, you must save the Collada file through
ArtiosCAD Enterprise so that it generates a preview and includes it as
part of the .ZAE file. For existing Collada files, open and resave them.

5 Information edit controls.

To save your browser configuration (such as which panes are visible and their sizes), click View > Save
Browser Configuration. To restore it, click View > Load Browser Configuration.

The Browser Toolbar
The browser toolbar, shown below, lets you move between Project views and create, copy, rename,
and delete Projects and folders easily. Depending on what you select and your permissions, tools are
available or unavailable.
 

 

Button Tool Active When

Back You have viewed at least two
Projects or folders and have a
previous view

Forward You are seeing a previous view and
can go forward to another view

Create Project A Project or folder is selected and
you are a Project manager

Copy Project A Project or managed document is
selected, you are a Project manager,
and you have sucient permission

Rename Project A Project is selected and you have
sucient permission

Delete Project A Project is selected and you have
sucient permission

Create Folder A Project or folder is selected and
you have sucient permission. This
is also available in the Explorer node
for unmanaged documents.
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Button Tool Active When

Rename Folder A folder is selected and you have
sucient permission. This is also
available in the Explorer node for
unmanaged documents.

Delete Folder A folder is selected and you have
sucient permission. This is also
available in the Explorer node for
unmanaged documents, in which
case deleting a folder also deletes
its contents; ArtiosCAD moves
deleted unmanaged documents to
the Recycle Bin.

Open Document You have a document selected

List Style Always active. Uses the Windows
Explorer settings for hidden and
system files.

Refresh A Project is selected. This
requeries the database for updated
information about the Project. This
is also available for unmanaged
folders in the Explorer node.

 & 

Units. Click it to change the units system
the browser displays. Inch is Imperial and
mm is metric.

Always available.

Search Controls
Use the search controls to search for Projects and documents.
 

 

Area Function

1 Search Type drop-down list box with which you choose what to search for

2 Keyword entry field where you enter the terms to search for

3 Search button that starts the keyword search
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Area Function

4 Opens the Advanced Search dialog box

Performing searches is covered later in this chapter.

Document Display Control
The document display control filters the list of shown documents. Choose the type of documents listed
from the drop-down list.
 

 

This control is available when you:

• have a Project selected in the tree control

• are using the Explorer node of the tree control.

Folders in the Project are unaffected by filtering and always appear in the document list.

Note:

THIS CONTROL DETERMINES THE DOCUMENTS YOU SEE IN THE DOCUMENT LIST. IF YOU
ARE LOOKING FOR A DOCUMENT AND CANNOT FIND IT, MAKE SURE THIS CONTROL IS SET
PROPERLY.
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Paging Controls
The paging controls let you navigate search results. The browser displays 25 documents per page of
search results.
 

 

ArtiosCAD Enterprise shows 25 lines of results at a time by default. Click Read More to show more
lines.

You can change the number of default lines shown by clicking Options > Defaults > Browser settings >
General Information > Search options and changing the number to your preference.

Tree Control
The tree control lets you work with Projects, folders, searches, documents (both managed and
unmanaged), and Tasks (if your WebCenter system has that option).
 

760



10ArtiosCAD

 

The tree has five top-level nodes:

• Projects
• My Tasks (optional)
• Search
• Documents
• Explorer

Note:

ArtiosCAD displays the My Tasks node only when both of these are true:

• Your WebCenter system has task management (either a pre-2017 task management license
or at least WebCenter Essentials)

• ArtiosCAD is in online mode.
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Projects Node
The Projects node of the tree control contains several nodes itself.
 

 

Recent Projects shows the four most recent Projects you have modified. You can change this number
in Defaults.

Favorite Projects shows those Projects you have designed as favorites. One way to designate a Project
as a favorite is to right-click it and click Add to Favorite Projects. Another way is to drag it into Favorite
Projects.

Projects I Manage shows Projects you manage. ArtiosCAD Enterprise does not show this node if you
are not a Project Manager.

Projects I Am Invited To shows those Projects of which you are a member.

Projects on My Computer shows Projects whose database and design information you have copied to
your computer for use in oine mode. When you reconnect to the database, the database information
and files are updated. These Projects are not truly stored on your computer. There is more information
about oine mode later in this chapter.

All Projects shows all Projects you have permission to see.

762



10ArtiosCAD

As you click items in the tree and load them into the browser, ArtiosCAD Enterprise displays a count
after them. For Projects, the count is the number of documents in the root level of the Project followed
by the total number of documents in the Project. For a BOM, the count is the number of documents
in the BOM. For Tasks, it is the number of tasks assigned to the Project. For a folder, the count is the
number of documents in the folder.

Note:  The numbers in the counts reflect the documents you have permission to see. If there
are items in the Project for which you do not have View permission, those items are excluded
from the counts.

When you right-click a Project, the context menu shows items appropriate for the object in the node
in which you clicked it. For example, when you right-click a Project in Recent Projects that also is in
Projects on My Computer, the context menu does not show the commands it would show if you clicked
the Project instance in Projects on My Computer. Shown below is the context menu for a Project in
Recent Projects.
 

 

Shown below is the different context menu for a Project in Projects on My Computer.
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BOM Node

The browser shows the Bill of Materials node inside every Project when you expand it or click it
to provide easy access to the BOM. ArtiosCAD Enterprise shows the BOM node regardless of the
BOM's existence. This is configurable in Defaults (Options > Defaults > Browser Settings > General
Information).
 

 
On the context menu, you can open all the documents in the BOM, go to the Project Bill of Materials to
configure it, or output a Report.

Likewise, when you highlight the Project in the tree, the Bill of Materials is the first item in the
document list (provided it is sorted by name). If you right-click it there, the same context menu
appears.
 

 

Open All Documents opens all the documents in the BOM in ArtiosCAD Enterprise if it can open them. It
is also on the Project drop-down list box at the end of the document tab bar in ArtiosCAD Enterprise
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Project Bill of Materials leads to the Project Bill of Materials Documents dialog box where you
configure the BOM.
 

 

Bill of Materials Reports runs a Report against the BOM.
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Tasks Node

Within each Project is a Tasks node, similar to the Bill of Materials. When you click it, the browser
displays the documents assigned to tasks in the Project. Note that you still do most task configuration
and management actions themselves in WebCenter; the interface in ArtiosCAD is designed to provide
easier access to tasks from a structural design perspective. In ArtiosCAD, you can mark task checklist
items as completed.
 

 

As with other nodes, control the size of the icons in the list using List Style on the toolbar. You can
customize the columns by right-clicking on the head of the list control.

The Details pane shows general information about the selected task, its documents, its specifications,
and its checklist. Select a document on the Documents tab to see its preview.

If you select a specific task in the tree control, the documents list shows the documents assigned to
that task. Select a document in the document list to show its details in the Details pane.
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ArtiosCAD shows due dates for on-time tasks in green, due dates for tasks with a close due date in
orange, and due dates for tasks past their due date in red.

If there is a view in the Attribute category of the document that has the same name as the task type of
the task with which this document is associated, the Attributes tab heading changes to Specifications,
and ArtiosCAD shows only those Attributes that are part of that view.

My Tasks Node

Note:

This node is optional and appears only if your WebCenter system has a task management
license and ArtiosCAD is in Online mode.

The My Tasks node of the tree control contains several nodes itself.
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Tasks Assigned to Me shows the tasks assigned to you.

Tasks Assigned to Me or My Groups shows tasks assigned to you or any group of which you are a
member.

Tasks Assigned to My Groups shows tasks assigned to any group of which you are a member.

ArtiosCAD updates the task count shown after each node as you expand them. It also updates the three
lists automatically once a minute when the browser is active (except when it is showing the Save As
dialog box).

When you select a main node in the tree and then a task in the Document pane, ArtiosCAD shows the
details about the selected task itself on the General, Documents, Specifications, and Checklist tabs in
the Details pane.

Search Node
The Search node shows the results of the current search and also shows saved searches you can run
when desired.
 

 

Searching is covered later in this chapter.

Documents Node
The Documents node contains My Locked Documents, which shows the managed documents you
currently have open in ArtiosCAD Enterprise based on the same server.

In the example below, My Locked Documents was selected in the tree control. Note that DESIGN2.ARD,
the tray, is not open in this session of ArtiosCAD Enterprise; rather, it is open on another workstation.
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Explorer Node
The Explorer node of the Project tree shows drives and folders on the current workstation (including
networked drives), allowing you to open and save unmanaged files.
 

 

When you select a folder in the Explorer node, the document list shows the contents of that folder
using the Windows Explorer settings for hidden and system files. Use List Style on the toolbar to
change how the contents are shown. You can also change the contents of the list with the Files of type
drop-down list box.
 

 

Note:

Since the designs are unmanaged, there is no database information for ArtiosCAD Enterprise
to display on the information tabs next to the preview.
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You can create, rename, and delete documents and folders in the Explorer node using the tools on the
toolbar and the commands on the context menu (when you select an object and right-click the mouse).
When you delete a folder, ArtiosCAD moves its contents to the Recycle Bin.

Customizing the Document List
When the document list shows Projects, folders, managed files or search results, by default it shows
the name, description, and version number. To customize what information is shown for this session,
do the following:

1. Select an entry in the tree control in the Projects, My Tasks, Search, or Documents node.
2. Right-click one of the headers in the document list and click Customize.
3. In the Column Customization dialog box, select or deselect items for the document list to display or

hide.
 

 
4. To change the displayed column label, select it and enter the new title in the Column Title field.
5. Click OK when done to return to the browser.

List Style controls the appearance of icons to the left of the name.

All columns are sortable. Drag the column headers to arrange them in the desired order.
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You can make these changes permanent by saving the browser configuration as described in Browser
Window Elements.

Note that the Creator column will show data for only those Projects created with WebCenter 18.1 or
later.

Edit Controls
The Edit controls to the right of the information fields let you edit certain items about the selected
object in the tree control or document list.
 

 

Click the pencil Edit icon to enter Edit mode. Fields that you can change become available for editing.
Once you have made a change, the check mark turns green to show you have made a change. Click
different tabs to edit the available fields on them. Some fields are not available and must be changed
in other places such as the Database Information dialog box when saving or publishing a new version or
revision.

Some considerations for Edit mode are:

• You can only edit a single managed item at a time. The controls are unavailable when you have
multiple items selected.

• You can only edit managed items. Unmanaged items (such as those in the Explorer node) are not
editable.

• The selected item must not be open in ArtiosCAD Enterprise.

• If you select a Project, you must be its manager to edit it.

• If you select a document, it must not be linked.
• If you select a document, it must not be locked, even by yourself.
• If the document you are viewing in the browser has an attribute category other than the one

assigned in Defaults, the browser will display the list of attributes for the category that is actually
assigned to the document. They will be editable in the browser.

The green Save icon and red Cancel icon become available after you have made a change.
 

 

Save saves the changes and exits edit mode. If you try to exit edit mode without saving, ArtiosCAD
Enterprise prompts you to save the changes.

Cancel exits edit mode without saving changes.

There are a few restrictions to working in Edit mode:

771



10 ArtiosCAD

• Changes to mandatory fields in Defaults while you are in Edit mode will take effect only when you
select something else.

• Other users can change the same data at the same time.
• The current selection in the Attributes or characteristics list changes when switching between Edit

mode and View mode.

Projects

Creating a Project

Note:

You may only create a Project if you are a Project manager or have the Project Creator
permission in WebCenter.

To create a Project using the browser, do the following:

1.

 On the browser toolbar, click Create Project.
2. Enter the name of the Project in the Name field, or if you are using automatic naming, click Use

Automatic Naming. Depending on the options set in the Project Autoname Generation group on the
General Preferences page in WebCenter, such as those for a prefix, sux, or counter length, certain
options in this dialog box may not be available. Autonaming is not available in oine mode, but you
can use it when you synchronize returning online.

3. Optionally, you can:
a) enter a description for the Project in the Description field.
b) select a Template on which to base the Project from the Template drop-down list box.
c) Set the customer Name and Location using pattern searching, which is explained at the end of

the Other Features section. The Template can set these if they are defined.
d) Set Attributes for the new Project if they are set in the Template and Set Attributes is enabled

on the Project Creation subtab of the Configure tab of the Template in WebCenter
4. Click OK to create the Project.

ArtiosCAD Enterprise opens the Project information dialog box.
5. In the Project information dialog box, set the properties of the Project as desired.
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6. Click OK to create the Project.

After you create a Project, it appears in the Recent Projects and Projects I Manage nodes of the
browser.

You are the only member of this new Project unless you based it on a Template containing more
members. To add more members, see the section on inviting members to a Project.

Creating a Project When You Are a Project Creator Only
Starting with version 18.1, WebCenter has a user type called Project Creator that lets users create
Projects and assign a Project manager, but not to manage Projects in any other way. If you are such a
user, in the Create New Project dialog box is a required field for the Project Manager. Click the Browse
button (…) at the end of the field to select the Project manager for this Project.
 

 

If the Template on which you are basing this new Project has a Project Manager defined, you will not be
prompted to assign one. You may also set Attributes for the new Project if they are set in the Template
and Set Attributes is enabled on the Project Creation subtab of the Configure tab of the Template in
WebCenter.

Opening a Project
To open a Project in the browser, simply select it in any of the nodes in the Projects tree. Its top-level
documents will appear in the document list and its list of folders (if any) will be expanded in the Project
tree.

Opening a Project in WebCenter
From time to time you may want to open a Project in WebCenter to add or remove members, set
permissions, and so forth. You can do so directly in WebCenter, but you can also do it from the browser
in ArtiosCAD Enterprise.

1. Navigate to the desired Project.
2. Right-click it and click Open Project in Web Browser.
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ArtiosCAD Enterprise will launch your default Web browser, automatically log you into WebCenter using
your ArtiosCAD Enterprise username and password, and show the Project.
 

 

Renaming a Project
You can only rename a Project if:

• you are a member of the ADMINS group or you manage that Project, and
• no documents in that Project are open.

To rename a Project, do the following:

1. Select the desired Project.
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2.

 Click Rename Project on the toolbar.

The Rename Project dialog box opens.
 

 
3. In the Rename Project dialog box:

a) in the Name field, replace the current Project name with a new one. Autonaming is unavailable
when renaming a Project.

b) if desired, enter a new description in the Description field.
4. Click OK to rename the Project.

Deleting a Project
You can only delete a Project if:

• you are a member of the ADMINS group or you manage that Project, and

• no documents in that Project are open.

Note:

When you delete a Project, all documents within that Project are also deleted with no recovery
method. Copy documents to other Projects if needed before you delete a Project. Use this
command with caution!

To delete a Project, do the following:

1. Select the Project to delete.
2.

 Click Delete Project on the toolbar.
3. Click Yes to confirm deleting the Project.

Copying a Project
If you are a Project manager, copy a Project by using either the button on the toolbar or the command
on the context menu.

To copy a Project, do the following:

1.

 Select a folder or document in the desired Project and click Copy Project on the toolbar.
Alternately, right-click the Project and click Copy Project on the context menu.
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2. Enter a name and description for the new Project in the Create New Project dialog box. The name
and description of the existing Project pre-fill the fields already. You must change the name for
the new Project. If you use autonaming, ArtiosCAD Enterprise uses the autoname settings of the
original Project.
 

 
3. Click OK.
4. In the Project Information dialog box, set the fields as desired.

 

 
5. Click OK to create the new Project.

The new Project appears in Recent Projects and Projects I Manage.

Copying a Project to My Computer
When you want to work on a Project when you know you will be in oine mode later, you must first copy
that Project to your computer while still in online mode.

To copy a Project to your computer, do the following:

1. Select the desired Project in any of the nodes of the Project tree in the browser.
2. You can either:

a) drag it from its location into the Projects on My Computer node
b) right-click it and then click Add to My Computer on the context menu.

ArtiosCAD Enterprise will copy the necessary information to your computer for you to work on this
Project in Oine mode. When you go back into online mode, ArtiosCAD Enterprise will synchronize the
changes with the online version.
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Note:

You will not be able to perform certain functions while working on this Project in oine mode.

Inviting Members to a Project
If you do not make all ArtiosCAD Enterprise either Project managers with full visibility, or members of
the ADMINS group, you must use WebCenter to invite users and groups to Projects you create. If you
create Projects based on Templates, you still must first invite members to the Project that will become
a Template.

To invite members to a Project, do the following:

1. Start a Web browser and log in to WebCenter using your ArtiosCAD Enterprise username and
password.

2. Open the Project to which you want to invite members.
3. Click Members.

A list of the current members is shown.
4. Click Add Members in the column header.
5. Either filter or click Go to show all the users and groups available.
6. Select the users or groups to add and click Continue.
7. Set the folder permissions as desired; these permissions apply to all members being added in this

step. Then click Finish.

A successful status message appears along with a list of suggested subsequent tasks.

Removing Members from a Project
To remove members from a Project so that they may no longer access it, do the following:

1. Start a Web browser and log in to WebCenter using your ArtiosCAD Enterprise username and
password.

2. Open the Project from which you want to remove members.
3. Click Members.

A list of the current members is shown. If desired, use the filter to refine the list.
4. Select the users and groups to uninvite from the Project.
5. Hover over the menu symbol and click Remove on the hover menu.
6. Click OK to confirm the removal.

The member(s) are removed from the Project.

Viewing and Setting Project Properties
When you first create a Project you set its properties. To view or change those properties, do the
following:

1. Select the Project whose properties you want to view or change.
2. Either:

a) click Projects > Project Properties
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b) Right-click the Project and click Project Properties on the context menu.

ArtiosCAD Enterprise opens the Project Information dialog box.
 

 
3. Change the fields as desired and click OK when done.

Folders
Folders let you store documents in different places within a Project. If desired, you can set individual or
group permissions on folders through WebCenter.

Creating a Folder
To create a folder in a Project, do the following:

1. Select the Project in which you want to create the folder.
2.

 Click Create Folder on the toolbar.
3. Enter a name for the new folder and press Enter.

ArtiosCAD Enterprise creates the folder in the Project.

Note:

As of this writing, a Project can have only one level of folders.

Renaming a Folder
You can only rename a folder when no documents in the Project are open.

To rename a folder, do the following:

1. Ensure all documents in the Project are closed.
2. Select the folder to rename.
3.

 Click Rename Folder on the toolbar.
4. Type the new name of the folder and press Enter.

ArtiosCAD Enterprise renames the folder.
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Deleting a Folder
You can only delete a folder when no documents in the Project are open.

Note:

Deleting a folder also deletes all the documents in it with no way to recover them. Use this
procedure with caution.

To delete a folder, do the following:

1. Ensure all documents in the Project are closed.
2. Select the folder to delete.
3.

 Click Delete Folder on the toolbar.
4. Click Yes when ArtiosCAD Enterprise asks you to confirm deleting the folder.

ArtiosCAD Enterprise deletes the folder.

Templates
Templates are Projects upon which you can base other Projects. You can define the members, security
settings, folder structure, and Project properties once and then base future Projects on the same
Template. You save them as Templates in WebCenter.

Note:

Templates may only be created by members of the ADMINS group. However, as an admin can
open any Project to save it as a Template, an admin does not have to create the Project upon
which a Template is based.

Creating a Template
To create a template, do the following:

1. Create the Project as desired in either ArtiosCAD Enterprise or WebCenter, inviting members,
setting permissions (WebCenter only), and creating any folders as desired. Any documents in the
Project will be copied into the Template as well.

2. Log in to WebCenter as a member of the ADMINS group.
3. Open the Project created in step 1.
4. Click Save as Template in the Project Actions menu.
5. Enter the name of the template and a description in the appropriate fields.

To use a custom thumbnail for use in WebCenter, click Specify New Thumbnail and enter the
complete path and filename in the associated field or Browse for it. To use the default thumbnail,
leave that choice selected.

6. Click Finish.

The Template is created.
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Deleting a Template
To delete a template, do the following:

1. Log in to WebCenter as a member of the ADMINS group.
2. Click Admin > Project Management > Templates.
3. Click the checkbox next to the name(s) of the Template(s) to delete.
4. Hover over the menu symbol and click Delete from the pop-up menu.
5. Click OK to confirm the deletion(s).

WebCenter deletes the template(s).

Changing a Template
To change a template, do the following:

1. Log in to WebCenter as a member of the ADMINS group.
2. Click Admin > Project Management > Templates.
3. Click the name of the Template to change.
4. Change any of the Template properties as desired.

Changing documents in a Template, other than deleting them or moving them between folders, is not
possible and is best accomplished by creating a new Project based on the original Template, adding the
desired documents, and saving the Project as a new Template.

Tasks

You can perform basic task-related functions in ArtiosCAD that are relevant for a structural designer.
Use WebCenter for most task configuration and administration.

Linking a Managed Document to a Task
To link a managed document to a task, do the following:

1. Make it so you can see the desired task in the tree control - in a Project or one of the My Tasks
nodes. Note that the task must be configured in WebCenter to allow attachments.

2. Navigate to the document.
3. Do one of two things:

a) Drag the document and drop it onto the task. As you drag, a ghost image of the document
thumbnail appears, and the cursor shows a task if the document is already in the same Project
as the task.
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If you are dropping the document onto a task in a different Project, the default action is to move
the document to the new Project. To copy the document instead into the Project containing the
target task, hold down either SHIFT or CTRL. To link it, hold down ALT. The drag cursor changes
to a plus sign, a move arrow, or a link arrow to indicate the action ArtiosCAD takes.

b) Right-click the document and click Copy Documents on the context menu. Then right-click the
task and click Link Documents to Task. If the target task is not in the same Project, you can
either Link Documents to Task as Copy or Link Documents to Task as Link. In either case, that
document you assign to a task in a different Project now appears in that different Project as
well.

Linking an Unmanaged Document to a Task
To link an unmanaged document to a task, do the following:

1. Make it so you can see the desired task in the tree control - in a Project or one of the My Tasks
nodes. Note that the task must be configured in WebCenter to allow attachments.

2. Navigate to the document.
3. Do one of two things:

a) Drag the document and drop it onto the task.
 

 
ArtiosCAD copies the document to the Project containing the task and makes it a managed
document.

b) Right-click the document and click Copy Documents on the context menu. Then right-click the
task and click Link Documents to Task as Copy. ArtiosCAD copies the document to the Project
containing the task and makes it a managed document.

Starting a Task
There are three ways to start a task which has not yet been started.

1. To start a task from the tree control, do the following:
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a) Select the task in the tree.
b) Right-click the task and click Start Task.

 

 
c) ArtiosCAD starts the task.

2. To start a task from the list in the document list, do the following:
a) Select a Tasks node in the tree control so its tasks appear in the document list.
b) Right-click the task and click Start Task.

 

 
c) ArtiosCAD starts the task.

3. Change the status of a task, which automatically starts it. Changing a task status is covered in the
next section.

Changing the Status of a Task
There are three ways to change the status of a task in the browser.

Note:

Changing the status of a task starts a task if it is not already started.

1. Right-click the task on the tree control and click Change Status on the context menu. Choose the
new status from the resulting context menu. ArtiosCAD shows the current task in bold.
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2. Select the task in the documents list, right-click it, and click Change Status on the context menu.

Choose the new status from the resulting context menu. ArtiosCAD shows the current task in bold.
 

 
3. Select the task in the documents list and edit the Status field on the General tab in the Details pane.

Make sure to save the changes after you have changed the status.
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Note:

For either of the context menu methods, you can also click Complete Task to more directly
mark the task complete.

Changing the Assignee of a Task to Someone Else
There are three ways to change the assignee of a task to someone else in the browser.

1. Right-click the task in the tree control.
a) Click Assign To on the context menu.

 

 
b) In the Task Assignee dialog box, choose the new assignee. You can select either a person or a

group. ArtiosCAD shows the entries in the same order as WebCenter.
 

 
c) Click OK.
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2. Select the task in the documents list and right-click it.
a) On the context menu, click Assign To.

 

 
b) In the Task Assignee dialog box, choose the new assignee. You can select either a person or a

group. ArtiosCAD shows the entries in the same order as WebCenter.
 

 
c) Click OK.

3. Select the task in the documents list, and edit the fields on the General tab.
a) Click the More Options button at the end of the Assigned To field.
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b) In the Task Assignee dialog box, choose the new assignee. You can select either a person or a

group. ArtiosCAD shows the entries in the same order as WebCenter.
 

 
c) Click OK.

Note:

Even though you can reassign a task to someone else, if the document in that task is open, it
will need to be manually unlocked by an administrator or the Project manager before the new
assignee can work on it.

Changing the Assignee of a Task to Yourself
You can quickly take ownership of a task in a Project of which you are a member.

1. Right-click the task in the tree control.
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a) Click Assign To Me on the context menu.
 

 
2. Select the task in the documents list and right-click it.

a) On the context menu, click Assign To Me.
 

 

Removing a Document from a Task
To remove a document from a task, do the following:

1. Select a task in the tree so that its documents appear in the documents list.
2. Select the document(s) to remove from the task.
3. Right-click and click Remove Documents from Task.
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4. ArtiosCAD removes the selected document(s) from the task.

Changing the Checklist of a Task
When you have a task selected in the Documents pane, a tab for its checklist appears in the Details
pane of the browser.
 

 

1. Select the desired task to change in the Documents pane.
2. Click the Checklist tab in the Details pane.
3.

 Click Edit.
4. Click the checkboxes for the steps to mark complete.
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5.
 Click Save to submit the changes to WebCenter, or click Cancel to cancel your changes.

6. ArtiosCAD submits the changes to WebCenter and updates the checklist.
 

 

ArtiosCAD respects two options in the task definition in WebCenter:

• Finish Task if all steps from checklist are completed

• Only a Task Assignee can check off checklist items
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This means that if these items are checked in WebCenter, if you mark all the checklist items as
completed, WebCenter will complete the task, and that you will not be able to edit the checklist if you
are not the Task Assignee.

Opening a Task in WebCenter
1. Right-click a Task in either the My Tasks node or in the Document list and click Open Task in Web

Browser.
 

 
2. The Task definition appears in WebCenter.
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Completing a Task
There are four ways to complete a task. A task does not have to be started in order to be completed.

1. To complete a task from the tree control, do the following:
a) Select the task in the tree.
b) Right-click the task and click Complete Task.

 

 
c) Alternately, click Change Status and then click Completed.

 

 
d) ArtiosCAD completes the task.

2. To complete a task from the list in the document list, do the following:
a) Select a Tasks node in the tree control so its tasks appear in the document list.
b) Right-click the task and click Complete Task.
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c) Alternately, click Change Status and then click Completed.

 

 
d) ArtiosCAD completes the task.

A Specific WebCenter - Automation Engine Workflow Note
If you are:

• using WebCenter with Automation Engine

• with Automation Engine automatically creating new Projects from Templates

• with Tasks and document Attributes predefined in the Template

• that you then access in ArtiosCAD Enterprise

Then when you Save As a new document to a Task already containing a document by the same name
from the Template thereby creating a new version of that preexisting document, the Attributes of the
document you are saving do not overwrite existing Attributes of the document that were set in the
Template.

Additionally, if you change the Attribute Category on that document in WebCenter but not in ArtiosCAD,
the change in WebCenter takes precedence and you will see the Attributes from that new Category.
Likewise, if you Save As to a Task document, the existing Attribute Category on the Task document is
also honored in ArtiosCAD and supersedes the one in ArtiosCAD Defaults if they differ. The values of
the prompted Attributes from the Task document that are common to the default Attribute Category
are preserved. Calculated expressions are always recalculated.

Note:

If you save this document in any way other than using Save As to the Task, all Attribute-related
information on the new version comes from however you set them in ArtiosCAD.

Documents
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Saving a Managed Document
Saving a document is the point at which you can choose to make it managed by saving it as part of a
Project.

Note:

You can also save it as an unmanaged document by using the Explorer node in the browser.

Note:

When you decide a filename for a managed document, do not use any of these characters:
\ / : * ? " < >.

To save a managed document, do the following:

1. Create the document - a single design, a manufacturing file, or a 3D workspace - as desired.
2. Click Save on the toolbar.
3. Select the Project and folder (optional) in which to save this document. If the desired Project or

folder does not exist, create it using the buttons on the toolbar.
4. Enter the filename and click Save. Comments are unavailable for the first version of a managed

document.
 

 
5. In the Database Information dialog box, fill in the fields as appropriate and click OK.
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If your WebCenter administrator has configured multi-value prompted Attributes and you have
made customized Database Information dialog boxes containing them, check their values as
desired.
 

 
If your WebCenter administrator has configured cascading Attributes based on a list and you have
made customized Database Information dialog boxes containing them, the values of the child
Attributes depend on the parent Attributes you select. In the examples below, the Attributes chosen
for the Type control what you can choose for the Name.
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Select All and Deselect All select and deselect all the Attributes. Click Other Value to specify a
value that is not in the list. Set a Filter to reduce the number of Attributes available to select; the
comparison is case-sensitive.

After you have saved a managed document, by default when you click Save again, ArtiosCAD saves a
draft. This behavior is customizable in Defaults > Startup defaults > Save Options.
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If you select Save as New Version, the Save Draft command appears on the File menu so that you can
still save drafts, and Publish Version disappears since it is replaced by Save.

You can also set shortcuts to the different save and publish commands in the Shortcuts catalogs in
Defaults.

Note:

ArtiosCAD Enterprise uses the Default Attribute category view from WebCenter Also, cascading
Attributes are not supported in Oine mode.

Additional commands on the Save button
The Save button in the browser has a drop-down menu containing three commands: Save, Save Next
Document, and Save Next Document into New Project.
 

 

Save Next Document uses the automatic name generation feature configured in WebCenter to assign
the next available name to the document and save it in the selected folder and Project. It is available
only when you have selected a managed path in the browser. If the autonaming is configured to prompt
you for a sux, the Sux field appears in the Database Information dialog box.
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Save Next Document into New Project prompts you to create a new Project before saving the
document with the next available name into it. If automatic naming is available, use it by checking Use
Automatic Naming. Enter the name (if you are not using automatic naming) and a description in the
fields provided. Choose a Template if desired and click OK to continue saving the document.
 

 

ArtiosCAD will prompt you for information about the new Project.
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Click OK to finish saving the document into a new Project.

The browser remembers the last Save command used and changes the button accordingly.

Saving an Unmanaged Document
Saving an unmanaged document is like saving a managed document, except you either navigate to
a location in the Explorer node, or you type that location directly in the Filename field in the Save As
dialog box as part of the filename (such as C:\TEMP\TEST.ARD).

Unmanaged documents have no database information and no security beyond that of the file system.
Use caution when saving unmanaged documents.

Publishing a New Version of a Managed Document
The first time you save a managed document, you enter all its database information. The next time you
work on that document, you can:

• save it as a draft, meaning it is a work-in-progress and not a new revision or version

• publish it as a new revision

• publish it as a new version

It is up to you to decide if it is a draft, revision, or version according to your company’s best practices.
Some people publish minor changes as revisions and major changes as versions; others do the
opposite, and yet others just save drafts.

Note:

New versions of documents do not affect Bills of Materials. To have your changes reflected in
Bills of Materials, publish a new revision instead.

To publish a new version of a managed document, do the following:

1. Work on the document as desired and click File > Publish Version. If Publish Version is not on the
File menu, click Save.
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a) If the document is in more than one Project, you can choose the checkbox of each Project to

update with this new version, and whether to add this version to or update that Project’s Bill
of Materials. Use the checkboxes at the top of each column to toggle all the checkboxes in the
column.
 

 
2. Enter a comment if that field is blank and click OK to continue the process of publishing the

managed document.
a) For a single design, the Database Information dialog box appears similar to the one shown below.

Enter information in the fields as desired and click OK to complete the publishing process.
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b) For a manufacturing document, the Database Information dialog box appears similar to the one

shown below. Enter information in the fields as desired and click OK to complete the publishing
process.
 

 
c) For a 3D design, the Database Information dialog box appears similar to the one shown below.

Enter information in the fields as desired and click OK to complete the publishing process.
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Publishing a New Revision of a Managed Document
Publishing a new revision of a document is similar to publishing a new version. Unlike a new version,
however, a new revision can also optionally update any Bills of Materials in the Project(s) to which the
document belongs. To publish a new revision of a managed document, do the following:

1. Click File > Publish Revision.
2. In the Save Managed Document dialog box, enter a comment for the revision. This dialog box has a

different appearance depending on if this document exists in more than one Project and/or is in the
BOM.
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a) If you select it, Update all Bill of Materials updates all Bills of Materials containing this

document.
b) If the document is in more than one Project. you can choose the checkbox of each Project to

update with this new revision, and whether to add this revision to or update that Project’s Bill
of Materials. Use the checkboxes at the top of each column to toggle all the checkboxes in the
column.

3. Click OK to continue the process of saving the managed document.
a) For a single design, the Database Information dialog box appears similar to the one shown below.

Enter information in the fields as desired and click OK to complete the publishing process.
 

 
b) For a manufacturing document, the Database Information dialog box appears similar to the one

shown below. Enter information in the fields as desired and click OK to complete the publishing
process.
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c) For a 3D design, the Database Information dialog box appears similar to the one shown below.

Enter information in the fields as desired and click OK to complete the publishing process.
 

 

Opening a Document
To open a document in ArtiosCAD Enterprise, do the following:

1. If the browser is not already open, open it by:
a) clicking its button on the toolbar

 

 
b) clicking File > Browser
c) pressing CTRL-B.

2. In the browser, navigate to the Project and folder containing the desired document. If the desired
document is unmanaged, use the Explorer node to open the drive and folder containing it.

3. Select the desired document in the document list.
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4.

 Either double-click the document to open it, or click Open on the toolbar.

ArtiosCAD Enterprise opens the document for editing.

Additional Methods for Opening Documents
When you right-click a document in the document list, the context menu shows additional methods to
open it.
 

 

Open Document in Web Browser opens the document in WebCenter using your system’s default Web
browser and your current login credentials.
 

 

Open opens the selected document(s) for editing.

Open Read Only opens the selected document(s) for viewing.

Use Select Revision to open a specific version of the selected document. Click the desired version in
the Version History dialog box and then click Open.
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Open With lets you choose the program to edit an unmanaged temporarily downloaded version of the
selected document(s). Choose the desired program and click OK to launch it and open the document(s).
 

 

To actually edit a non-native document in another application and have it be a managed document, do
the following:

1. Use Open With to open the document in another application as described previously.
2. Edit the document as desired.
3. Save it to a local folder in the filesystem.
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4. To save it as the same managed document, delete the managed document, and either copy and
paste or drag and drop the unmanaged document from the Explorer node of the browser into the
Project.

5. To save it as a new version of the managed document, in the ArtiosCAD Enterprise browser, right-
click the managed document and select Open in Web Browser. In WebCenter, select Upload New
Version and follow the instructions, clicking Finish when done. Refresh the ArtiosCAD Enterprise
browser to see the changes.

Opening a Document with a Foreign Board Definition
If you open a document that uses a board code that is not in your database, ArtiosCAD tries to find
a board code with the same values for the caliper, inside loss, outside gain, caliper-related rounding
value, and flute. If it cannot find a board code with the same values, it tries to find one with values
within a 20% tolerance. If it does not find any close matches, you will have to select a board from the
list.

1. When you open a document that does not contain a recognized board code, ArtiosCAD tells you so.
 

 
2. To use the board anyway, click OK. Otherwise, click Show All Board Details to see the information

about the board, or click Select Board to open the Board Information dialog box. If ArtiosCAD found
a board to suggest, it pre-selects the board in the dialog box. If it does not find a match, open the
board tree and select a new board to use. The Current Board Definitions pane shows the board
information saved in the document, and the Suggested Board Definitions pane likewise shows the
information about the board you selected in the tree.
 

806



10ArtiosCAD

 
3. To edit the board information saved in the document, click Edit Board Definition Locally on the

Board tab in the Current Board Definitions pane. To use this changed information, click Keep
Current Board. Note that since this board still does not exist in the database, ArtiosCAD will
continue to warn you when you open it.

4. To replace the board information saved in the document with a board definition from your database,
select the board entry from the tree, click Accept Suggested, and save the document.

Opening All Documents in the Document List
To open all documents in the currently shown page of the document list, do the following:

1. Arrange the list of documents as desired - open a Project or folder, or do a search.
2. Click Documents > Select All.
3. In the document list, right-click a document and click Open on the context menu.
4. If there are any linked documents in the list, choose the Project containing the linked document and

click OK.
5. ArtiosCAD Enterprise opens the documents.

How to Distinguish a Linked Document
ArtiosCAD provides multiple ways to show a document in a list is a link to another document.

1. The browser shows a link symbol before the filename of a linked document.
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2. More than one Project name is in the Project Name column.

 

 
3. More than one Project name is returned in search results.

 

 
4. More than one Project name appears when you hover over a document.

 

 

Renaming a Document
To rename a document, do the following:

1. Make sure the document is closed, as you cannot rename an open document.
2. In the browser, navigate to the Project and folder containing the document and select it.
3. Right-click the document and click Rename on the context menu.
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4. In the Rename Document dialog box, enter a new unique name for the document in the Name field.
Autonaming is unavailable when renaming a document.
 

 
5. Click OK.

ArtiosCAD Enterprise renames the file.

Deleting a Document
To delete a document, do the following:

1. Make sure the document is closed, as you cannot delete an open document.
2. In the browser, navigate to the Project and folder containing the document and select it.
3. Right-click the document and click Delete on the context menu.
4. Click Yes to confirm deleting the document.

Use this command with caution, as there is no way to restore a deleted document.

Moving and Copying Documents

Moving Documents
To move a document to another folder or another Project, do the following:

1. Make sure the document is closed, as you cannot move an open document.
2. In the browser, navigate to the Project and folder containing the document and select it.
3. Drag it from its current location and drop it in the new folder or Project.

You may also drag a managed document from the root level of a Project to a folder or BOM node in the
Document pane. If a BOM, you must have the Change BOM permission, and ArtiosCAD sets the initial
count to 1, specifies no print item, and replicates the version/revision of the document to the BOM.

You can drag to copy or copy and paste managed documents to unmanaged locations. ArtiosCAD
includes the revision letter and version number based on the setting in Options > Defaults > Startup
Defaults > Export Document Name Format.

Copying Documents
To copy documents between folders and Projects, do the following:

1. In the browser, navigate to the Project and folder containing the document(s) and select it/them.
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2. Next:

Method Action

Keyboard Press CTRL-C to copy the documents, then select the destination Project,
folder, BOM, or task and press CTRL-V to paste them.

Mouse 1 Drag and drop managed documents to unmanaged locations. You can also
drag and drop unmanaged documents between unmanaged locations.

Additionally, you can drag unmanaged documents into managed locations;
ArtiosCAD assigns the document the appropriate Attribute Category.

You can copy managed documents into folders or Projects in the tree by
dragging them while holding down SHIFT.

Mouse 2 Right-click the selected document(s) and click Copy Documents on the
context menu, then right-click the destination Project, folder, BOM, or
task and click Paste Documents. You can also do this with unmanaged
documents between unmanaged locations.

Mouse 3 Hold down SHIFT or CTRL as you drag the document(s) from the source
folder and drop it/them on the destination Project, folder, BOM, or task.

Note:

Document names in Projects must be unique, even if the documents are in different folders.

You can copy unmanaged documents from the Explorer node into the Projects or My Tasks nodes to
make them managed documents.

You can also drag a document from the Documents pane into a Project or folder in the Projects I
Manage, Projects I Am Invited To, and Favorite Projects nodes in the tree.

Copying a Document as a Link
You can share documents across many Projects by copying them as links. When you modify a linked
document and save it, you can choose which Projects get the updated version by selecting or
deselecting Update All Related Projects in the Save Managed Document dialog box.

To copy documents as links, do the following:

1. In the browser, navigate to the Project and folder containing the documents and select them.
2. To copy them as links using the context menu:

a) Right-click the documents and click Copy Documents on the context menu.
b) Right-click a destination folder or Project and click Paste Documents as Links on the context

menu.
3. To use drag and drop, hold down ALT and drag them to the destination Project, folder, BOM node, or

task node. The drag cursor should have a link arrow on it.
4. Repeat steps 2 or 3 as desired.

Adding Other Types of Documents to Projects
You can add other types of documents (for example, Adobe Acrobat or Microsoft Word documents) to
Projects by dragging them from the Explorer node of the tree control into the desired Projects.
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You can also add them to Projects by uploading them through WebCenter.

Embedded designs
Single designs saved inside of manufacturing documents are called embedded designs. When you have
a manufacturing file selected in the browser, you can see which single designs are embedded in it on
the Embedded Designs tab in the Properties pane.
 

 
To open an original design document to make changes, select the desired document and click Open
Original Design.

Conversely, when you have a single design selected in the browser, you can see which manufacturing
documents use it by right-clicking it and then clicking Show Associated Manufacturing Documents, or
by selecting the same command on the Documents menu of the browser.
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When you are viewing the Print Items tab of a design document in the browser, you can select a print
item and click Show Layouts Using This Print Item.
 

 

Canvases
Canvases contain parts that can exist solely in canvases or can be saved as independent workspaces.
When you select a canvas in the browser, a Parts tab appears in the information pane.
 

 

The tab lists the parts in the selected canvas. It lists the part name, filename, revision, and location in
which the part is saved. If only the Part Name column has information in it, that means the parts exist
only within the canvas.
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Open Canvas Part opens the selected part workspace, if you have saved parts to independent
workspaces for that canvas.

Searching

There are two ways to search in the browser. The first is to use the keyword search field above the tree
control. The second is to use the Advanced button to search for more specific items.

Keyword Searching
Keyword searching lets you search the names of Projects and documents for a specific word or part of
a word.

Refer to the Search Controls topic for a picture of the keyword search controls in the browser and an
explanation of what they do.

To perform a keyword search, do the following:

1. Click the Search Type drop down-list box and choose the type of object to search for: Projects, All
Documents, Designs, Manufacturing, ArtiosCAD 3D, or Canvas.

2. In the keyword entry field, enter the word to search for. To search on part of a word, use an asterisk
to replace the other part(s) of the word. If there is already text in the field, ArtiosCAD selects it so
your new search term overwrites it.

3. Click the magnifying glass button to start the search.
4. Depending on what you searched for, results will appear in the node tree, the document list, or both.

If you open a linked document from the document list of a search result, ArtiosCAD Enterprise will
prompt you to select the Project containing the linked document.

Keyboard shortcut CTRL-F jumps to the keyword search field when the browser is open.

Advanced Searching
Using the Advanced button to search lets you search many more fields than keyword searching.

Note:

All of the advanced search dialog boxes are customizable in Options > Defaults > Browser
Settings > Advanced Search Dialogs in the same way as the Database Information dialog
boxes, including aligning objects to a grid. For instructions on using the Control Layout
Manager, please see Designing a custom Database Information dialog box in the Defaults
chapter.

To perform an advanced search, do the following:

1. Click the Search Type drop down-list box and choose the type of object to search for: Projects, All
Documents, Designs, Manufacturing, ArtiosCAD 3D, or Canvas.

2. Click Advanced next to the magnifying glass icon.

A dialog box customized for the type of object you chose in step 1 appears.
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3. Enter the desired information to search for and click Run.
4. Depending on what you searched for, results will appear in the node tree, the document list, or both.

If you open a linked document from the document list of a search result, ArtiosCAD Enterprise will
prompt you to select the Project containing the linked document.

Note:  To be able to search for revisions, your WebCenter system administrator must enable
Index Document Revisions in Admin > Configuration > Search Crawler Setup. If that option is
not enabled, the Revision Options are unavailable in the Advanced Search dialog boxes.

Searching Syntax
Use the syntax described below to compose effective search queries. An example of the syntax is at
the end of the section.
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Terms
A search query is broken up into terms and operators. There are two types of terms: single terms and
phrases.

A single term is a single word such as box or corrugated.

A phrase is a group of words surrounded by double quotes such as "corrugated box". Multiple
terms can be combined together with Boolean operators to form a more complex query (see below).

Wildcard Searches
ArtiosCAD Enterprise supports single and multiple character wildcard searches. ArtiosCAD Enterprise
supports modifying query terms to provide a wide range of searching options.

To perform a single character wildcard search, use the ? symbol.

To perform a multiple character wildcard search, use the * symbol.

The single character wildcard search looks for terms that match the single character replaced. For
example, to search for text or test you can use the search:

te?t

Multiple character wildcard searches look for 0 or more characters. For example, to search for test,
tests or tester, you can use the search:

test*

You can also use wildcards in the middle of a term:

te*t

Boolean Operators
Boolean operators allow terms to be combined through logical operators. ArtiosCAD Enterprise
supports AND, +, OR, NOT and - as Boolean operators.

Note:

Boolean operators must be ALL CAPS.

OR. The OR operator is the default conjunction operator. This means that if there is no Boolean
operator between two terms, the OR operator is used. The OR operator links two terms and finds a
matching Project/document if either of the terms exist in a Project/document. The symbol || can be
used instead of OR.

To search for Projects/documents that contain either box company or just box, use the query:

“box company” box

or

"box company" OR box

AND. The AND operator matches Projects/documents where both terms exist anywhere in the text of a
single Project/document. The symbol && can be used instead of AND.

To search for Projects/documents that contain box company and box products, use the query:

"box company" AND "box products"

+. The +, or required operator, requires that the term after the + symbol exists somewhere in a field of a
single Project/document.
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To search for Projects/documents that must contain box and may contain products, use the query:

+box products

NOT. The NOT operator excludes Projects/documents that contain the term after NOT. The symbol !
can be used instead of NOT.

To search for Projects/documents that contain box company but not box products, use the
query:

"box company" NOT "box products"

Note:

Note: The NOT operator cannot be used with just one term. For example, the search terms
used below will return no results:

NOT "box company"

-. The -, or prohibit operator, excludes Projects/documents that contain the term after the - symbol.

To search for Projects/documents that contain box company but not box products, use the
query:

"box company" -"box products"

Grouping
ArtiosCAD Enterprise supports using parentheses to group clauses to form sub-queries. This can be
very useful if you want to control the Boolean logic for a query.

To search for either company or products and box, use the query:

(company OR products) AND box

This eliminates any confusion and makes sure that box must exist and either term company or
products may exist.

Shown below are different search phrases and their results.

Sample search string Results What it does not find

box box products

box company

box co. inc.

bottle holders

bo* box products

box company

box co. inc.

bottle holders

box NOT “box company” box products

box co. inc.

box company

bottle holders

box AND company box company box co. inc.
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Sample search string Results What it does not find

box products

bottle holders

“box company” OR “box
co.”

box company

box co. inc.

box products

bottle holders

box AND (products OR
company)

box company

box products

box co. inc.

bottle holders

* NOT *company* box products

box co. inc.

box company

Saving Searches
You can save search queries for your own future use as personal searches. If you are a member of the
ADMINS group, you can also save searches globally for anyone to use.

To save a search, do the following:

1. Compose a search query using one of the advanced search dialog boxes.
2. In the advanced search dialog box, click Save As.

The Save Search dialog box appears.
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3. In the Name field, enter a name for the search. You can replace an existing search with this one by

using the same name.
4. Set the search scope. Global is available only for members of the ADMINS group, while Personal is

available for all users.
5. Click OK to save the search.
6. Click OK when ArtiosCAD Enterprise successfully saves the search.

Once the search is saved, click Run to run it or Cancel to close the dialog box.

Using a Saved Search
To use a saved search, do the following:

1. In the tree control of the browser, expand the Search node.
2. Expand the Saved Searches catalog.
3. Expand either Project Searches or Document Searches.
4. Expand either Global or Personal.
5. Click the desired saved search. It will run automatically.

Depending on what you searched for, results will appear in the node tree, the document list, or both.

Modifying a Saved Search
To modify a saved search, do the following:

1. In the tree control of the browser, expand the Search node.
2. Expand the Saved Searches catalog.
3. Expand either Project Searches or Document Searches.
4. Expand either Global or Personal.
5. Right-click the desired saved search and click Properties on the context menu. Only members of

the ADMINS group may modify global saved searches.
6. Modify the search parameters as desired.
7. Click Save As.
8. Select the search you are modifying and click OK.
9. Click Yes to confirm overwriting the existing saved search.
10. Click OK when ArtiosCAD Enterprise successfully saves the search.

You can now either run the modified search by clicking Run or close the dialog box.

Deleting a Saved Search
To delete a saved search, do the following:

1. Start a Web browser and log in to the WebCenter site associated with ArtiosCAD Enterprise. If you
want to delete a global saved search, you must log in as a member of ADMINS group.

2. Click Search > Saved Searches.
3. Check the checkbox for each saved search to delete.
4. Click Delete checked items.
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5. Click OK to confirm the deletion.

WebCenter deletes the selected items.

Outputting Documents from the Browser

You can Output documents from the browser without opening them first. For a regular Output, its
definition in Defaults must have Browser selected in the Show In group on the Output Type tab. All 3D
Outputs are available with nothing further required.

ArtiosCAD Enterprise performs 2D Outputs silently.

For a silent 3D Output to a file in an unmanaged directory, check Omit Save-As Filename on the
Destination tab of the Output definition.

For a silent 3D Output to a file in a Project, clear Prompt for Project/Document Name on the
Destination tab of the Output definition, and set the other options in the group to either use the current
name or a fixed name.

1. To Output single designs or manufacturing documents:
a) Select the documents or folder containing only these document types to Output.
b) Right click one of the selections and click Outputs on the context menu.

 

 
c) Select an Output and run it normally.

2. To Output 3D documents:
a) Select the 3D documents or folder containing only this document type to Output.
b) Right click one of the selections and click Outputs-3D on the context menu.
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c) Select a 3D Output and run it normally.

There are a few considerations for these Outputs:

• ArtiosCAD Enterprise acquires licenses as needed during each Output.
• These Outputs are available only for managed documents.
• When you Output from a BOM node, ArtiosCAD Enterprise uses the default print item.
• When you Output to a Project, you must refresh that Project manually to see the Output.

Project Bill of Materials (BOM)

A Project Bill of Materials (BOM) is a list of everything needed in the same Project to complete an order.
ArtiosCAD Enterprise has BOM Reports you can Output. Click Projects > Project Bill of Materials
to open the Project Bill of Materials dialog box, or right-click a BOM node and click Project Bill of
Materials.
 

 

When you first open the BOM Documents dialog box, it displays all of the documents in the Project with
nothing selected.
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To add an item to the list that will appear on the BOM Report, click the checkbox at the beginning of its
row. Enter the number of items required in the Count field.

To add a print item for the selected design, change Add another print item to the desired print item,
which then appears in the list of documents. To add the document to the BOM with no print item, select
<none> from the drop-down list box. To remove the current print item from the list, select it and click
Remove.

To change the order of how items list on the BOM Report, select an item and use the up and down
arrows to the right of the item list.

To change the revision of a document, select it and click Change Document Revision. Next, choose the
new revision in the Document History dialog box and click OK.
 

 

To change the relative sizes of the document list and the preview pane, click to the right of the ordering
arrows and drag the separator bar.

To customize the columns shown in the document list, right-click one of the column headers and click
Customize. Use the checkboxes to turn columns on and off. To rename a column, select it, then enter a
new value in the Column Title field. Click OK to return to the BOM Documents dialog box.

Use Save Dialog Configuration and Load Dialog Configuration on the View menu to save aspects of
the dialog box such as size, position, and customized columns and then restore them as the same user
on another computer.

To Output a BOM Report, right-click a BOM node and click Bill of Materials Reports, and then choose
the Report.
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Oine Mode

Oine mode lets you perform certain database-related activities in ArtiosCAD Enterprise when you are
not connected to the database either accidentally or on purpose. Oine mode uses the cache, which
is a per-user, per-server, per-version invisible database that sits between ArtiosCAD Enterprise and
WebCenter.

When you are in oine mode, the status indicator at the bottom right of the ArtiosCAD Enterprise will
show it, as will the title bar of the browser.
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Note:

You must log in at least once in online mode for the cache to be created. At the time of the
login, click Yes to have ArtiosCAD Enterprise create the cache.

When ArtiosCAD Enterprise can connect to the database, it will give you a choice of what information
to synchronize from the cache during your time in oine mode.

Note:

Structural tools work normally in oine mode.

Copying a Project to My Computer

You must copy a Project to your computer before you can work on it in oine mode.

To copy a Project to your computer, either:

• Drag and drop it into the Projects on My Computer node in the tree control.

• Copy and paste it into the Projects on My Computer node in the tree control.

A progress bar will briefly appear showing the progress of the copy.
 

 

Entering Oine Mode

There are three ways to enter oine mode. To enter oine mode, choose one of the following:

1. Check the Work Oine checkbox in the login dialog box when you are logging in.
2. Once you are logged in, click Database > Work oine.
3. Disconnect your network connection. When no dialog boxes are open, ArtiosCAD Enterprise

monitors the status of the network connection and will switch to oine mode when the database is
unavailable.

Limitations of Oine Mode

Oine mode has the following limitations:
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• When you create a new Project, you cannot use a Template, and Generate Next Name/Save as Next
Name is unavailable (but you can generate it when you synchronize upon returning to online mode).

• When you save a document, you may only save it as a draft, not a new revision, and Generate Next
Name/Save as Next Name is unavailable (but you can generate it when you synchronize upon
returning to online mode).

• You can create and rename new folders only. You cannot rename or delete existing folders.

• You can copy documents between Projects, but you cannot copy them as links.

• You can perform simple searches without wildcards on Project and document names and
comments.

• You may not have one instance of ArtiosCAD Enterprise running in online mode and another running
in oine mode. If you are running two instances of ArtiosCAD Enterprise in online mode and lose
your network connection, you will not be able to enter oine mode in those instances, as one
instance being in online mode will prevent the other from changing to oine mode.

• You cannot edit Defaults in oine mode.

• in 3D, if you change the 3D rendering mode (Options > 3D Rendering Options) while in oine
mode, you will have to reapply the change after you return to online mode and restart ArtiosCAD
Enterprise.

Returning to Online Mode and Synchronizing

1. When you are ready to return to online mode, you can do it in two ways:
a) Re-establish your network connection. ArtiosCAD Enterprise periodically checks to see if it can

connect to the database and will display the following dialog box when it can do so. Leave Yes
selected and click OK to return to online mode.
 

 
b) Click Database > Work Online.

2. ArtiosCAD Enterprise will present all the Projects and documents needing synchronization.
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a) The Name column shows the names of Projects and documents you created in oine mode.
b) The Use Autoname column lets you choose which Projects and documents get automatically-

generated names (if available) as they are uploaded to the WebCenter database when you exit
oine mode. Clear the checkbox to use the original Project name you specified while oine.
You can only change the state of this checkbox if automatic naming is turned on and you have
not selected a Template. Make sure that you do not select this option for linked documents, as
that will break the link.

c) The Sux field appears only if automatic naming is available for Projects and documents, and if
a user-entered sux is required, double-click the field to enter one.

d) The Discard columns lets you choose individual Projects or documents to not upload to the
database and thus delete them. You will have to individually confirm each discard when you click
Sync.

e) If you worked on an existing document in oine mode, Save As lets you choose between saving
a draft or a new revision.

f) If you want to show other users that you are still working on a document, Keep Locked lets you
lock the document so that they get a warning if they try to work on it.

g) Select Template is a drop-down list box of available Templates you can apply to the Project.
h) If the Template has a customer and/or location set, click the More (...) button to set them.
i) Status shows the status of each item in the list as the cache synchronizes with the main

database.
j) For those columns containing checkboxes, you can right-click the column header and click

Check All or Check None on the context menu.
3. Click either Sync to accept and upload all changes you made in oine mode or Discard All to lose

them.

If you encounter errors while synchronizing (for example, you lose your network connection), ArtiosCAD
Enterprise will revert to oine mode, and unsynchronized changes are left to be synchronized
again. If the synchronization fails for some other reason, the reason will be displayed in the Status
column and you will need to manually upload any new files to WebCenter. The files to synchronize
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are in %LocalAppData%\Esko\ Offline_Online_Recovery\%Sync_Date_Time% where
%Sync_Date_Time% is the timestamp from when you attempted to synchronize.

Purging the local database cache

As time passes and you save Projects to your computer for use in oine mode, the local database
cache grows. To recover space and remove local copies of Projects you no longer need, do the
following:

1. In the browser, right-click Projects on My Computer and click Purge Cache on the context menu.
2. The Purge Cache dialog box appears.

 

 
3. Choose the number of weeks to delete Projects older than, meaning that ArtiosCAD will keep

Projects saved to your computer within the interval. The default is 4 weeks. You can either type a
number (less than or up to 1000) in the field, or choose a number from the drop-down list box. Set
the number to 0 to delete all locally cached Projects except Defaults Projects.

4. Click OK to purge the Projects and compress the local cache. ArtiosCAD displays a progress bar.
 

 
5. Click OK in the results dialog box to return to the browser.
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Note that this procedure only removes Projects from your local database cache used for oine mode.
It does not remove them from the main database.

Other Features

Locking and Unlocking Documents

When you open a document, ArtiosCAD Enterprise marks it as locked and displays a warning to any
other user who subsequently opens it.
 

 

After the other user clicks OK, the document is opened as read-only. Additionally, the title bar of
the other user’s ArtiosCAD Enterprise session shows the file as being locked and the user who has it
locked.
 

 

Locking a document also gives you the exclusive right to create a new version of the document.

Unlocking a document that has a draft saved will remove the draft. ArtiosCAD Enterprise will ask you to
confirm removing the draft before unlocking the document.

When you unlock an open document, it becomes read-only until you re-lock it or save it as a new
document.

To lock or unlock a document, do the following:

1. To lock a document, open it. If it has been unlocked, click Database > Lock Document.
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2. To unlock a document that you have opened, either close it or click Database > Unlock Document.

Forcibly Unlocking Documents
If the user who locked a document is unavailable to unlock it, it can be forcibly unlocked in WebCenter
by a member of the ADMINS group.

To forcibly unlock a document, do the following:

1. Start a Web browser and log in to WebCenter as a member of the ADMINS group.
2. Click Admin > Project Management > Find Locked Documents.
3. Select the checkbox of the document(s) to unlock.
4. Click Unlock.

The document(s) is unlocked.

If the document owner had it open in ArtiosCAD Enterprise, it becomes read-only in that instance.

To unlock the document from the ArtiosCAD browser if you are a member of ADMINS, reassign the
document to yourself, wait for the draft to become visible, and then unlock the document.

Reassigning a Document to Another Designer

Members of the ADMINS group can reassign a locked document to another designer, provided that the
target designer is a member of ADMINS or:

• is a member of the Project

• has View, Download, and Lock permissions on the document to view it

• has View, Download, Lock, and Update permissions on the document to save or publish it.

To reassign a document to another designer, do the following:

1. Launch ArtiosCAD and log in as a member of ADMINS.
2. Open the browser and navigate to the folder containing the locked document.
3. Right-click the locked document and click Reassign Document on the context menu. Alternately,

select the document and click Documents > Reassign Document.
4. In the Select designer dialog box, select the last name of the new designer and click OK. You can

sort each column by clicking its header.
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ArtiosCAD reassigns the document.

This command is available only in online mode, only when you are logged in as a member of ADMINS,
and only for a locked or draft document.

Revision History

To view the history of a document, right-click it in the document list and click Select Revision on the
context menu.
 

 

When selected, Show All Versions shows the Version column.

The versions are listed in reverse order with a preview shown for the selected version.

If a document is not locked, you can select a version or revision and click Publish Revision to save it as
a new revision of the same document.
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To open a previous version of the document, select it and click Open.

Enhancements to Customized Database Information Dialog Boxes

The Database Information dialog boxes that appear when you create Projects and save documents
are customized from the standard versions that are part of the non-enterprise version of ArtiosCAD.
ArtiosCAD Enterprise adds two enhancements to the Control Layout Manager in Defaults for these
dialog boxes.

The first enhancement is the Right Justify checkbox for labels. Use it to control a label’s position in its
allotted space.
 

 

The second enhancement is the Required field for Attributes. Use this to force a user to set an
Attribute when setting database information.
 

 

Note:

You must have Attributes defined in WebCenter in order to be able to add them to a Database
Information dialog box in ArtiosCAD Enterprise.

Note:

The ability to launch custom external applications from Database Information dialog boxes
does not exist in ArtiosCAD Enterprise.

Using the Cache Manager

ArtiosCAD Enterprise automatically maintains the cache on your computer so that you can use oine
mode. However, to manually manage the cache, for example compressing it after removing Projects
from your computer, click Database > Cache Manager to open the cache manager.
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The checkboxes to the left of the table names control which tables are affected by clicking Update or
Rebuild. Update requests only new or changed entities from the database since the timestamp in the
Last Updated On column. Rebuild clears the cached entities and retrieves the complete tables.

Note:

You can only use Update and Rebuild when you are in online mode.
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After you use Remove from My Computer on many Projects in the browser, click Compress to
compress the cache and improve performance.

Permissions Required for Common Activities

It is intended that, for ease of use, ArtiosCAD Enterprise users all be members of groups that have full
permissions on the Projects to which they are invited. However, if you choose to not follow this model,
you can set permissions for each Project and folder in WebCenter per user and per group. Project
managers can set permissions on the Projects they manage; members of the ADMINS group can set
permissions on any Project and folder.

Common tasks, commands, features, and functions and the permissions required are listed in the table
below.

Action Permissions Needed Dialog box controls and menu
items affected

Open document View, Download File menu - Open, Open Read
Only, Open All Documents,
Select version, Open with.

Open button in browser

Open With on context menu.

Save new document View, Add, Change File menu - Save, Save as
Next Name if Project or folder
selected

Save, Save as Next Name
buttons in browser

Save when an Output goes to a
Project

Save new version of document View, Change, Lock File menu - Save if document
selected

Typing the document name in
the Name field when saving

Save draft View, Change, Lock

Change document properties View, Update

Delete document View, Delete Delete on browser’s Document
menu and context menu

Rename document View, Change Rename on browser’s Document
menu and context menu

Lock/Unlock document View, Lock Lock and Unlock on browser’s
Document menu and context
menu
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Action Permissions Needed Dialog box controls and menu
items affected

Move document from source
Project or folder

View, Delete Drag and drop document from
folder to folder or Project to
Project. Permissions checked
when dropped.

Move document to destination
Project or folder

View, Add, Change Drag and drop document from
folder to folder or Project to
Project. Permissions checked
when dropped.

Copy document from source
Project or folder

View, Download Document menu - Copy
Documents. Context menu -
Copy.

CTRL-C

Dragging and dropping
document from Project to
Project while holding down
CTRL or SHIFT. Permissions
checked when dropped.

Copy document to destination
Project or folder

View, Add, Change Document menu - Paste
Documents. Context menu -
Paste.

CTRL-V

Dragging and dropping
document from Project to
Project while holding down
CTRL or SHIFT. Permissions
checked when dropped.

Copy document as link from
source Project or folder

View, Add, Download Document menu - Copy as Link
Documents. Context menu -
Copy as Link.

Copy document as link to
destination Project or folder

View, Add, Download Document menu - Paste
Documents. Context menu -
Paste.

CTRL-V

Open Project in Web browser View Project Menu - Open in Web
Browser. Context menu - Open
Project in Web browser

Open document in Web browser View Document and context menus -
Open in Web browser
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Note:

ArtiosCAD download format permissions set in WebCenter have no effect in ArtiosCAD
Enterprise; they only affect what users can download from WebCenter.

Setting the Title Bar Display Options

You can choose which revision and version information ArtiosCAD shows in the title bar. The Title Bar
Options dialog box in Options > Defaults > Startup defaults presents different formatting options.
Choose the preferred option and click OK.
 

 

Pre-seeding comments when saving a document

When you save a new version or revision of a managed document, you must enter a comment. To
streamline the comment-entry procedure, you can configure ArtiosCAD Defaults to pre-seed the
comment with a default comment you have defined in Defaults or the Project/document description.

In Database Defaults > General Options, the settings in the Comment Options group control how
ArtiosCAD manages comments.
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To turn on the automatic commenting, check Preseed comment from previous version. This also
enables the options in the Initial Comment group.

Use document description copies the document description to the comment field. If there is no
document description, ArtiosCAD will prompt you for a comment. This will also cause the Project
description to seed the document description when you save a managed document for the first time so
that on the next save, the comment will be able to be seeded from the description.

User defined lets you enter a custom string that ArtiosCAD will use for the first comment.

When automatic commenting is enabled and you save a managed document without a description
for the first time, ArtiosCAD copies the Project description to the managed document's Description
field to seed future comments. You can change this field in the Database Information dialog box as you
save the document if you have Show database information dialog on save enabled in the same General
Options dialog box in Database Defaults.

Note:

If you are working on an unsaved new document, and a document of the same name (usually
DESIGN1) exists in the managed location you select when you save it, ArtiosCAD will consider
the new document to be version 2 of the existing document and thus seed the version
comment from the existing document, rather than using a user-defined comment from
Defaults or the Project/document description.

Pattern Searching for Customers

Wherever ArtiosCAD prompts you with an empty field to select a customer, such as in the Create New
Project dialog box, the Project Information dialog box, or any of the Advanced Search dialog boxes, as
you type, it uses pattern searching to narrow the list of available choices.

Use * to match any number of characters, and use ? to match a single character. If you don’t type any
wildcards, there is an implied * before and after any characters you type.

If you change the focus without selecting a result, ArtiosCAD selects the first entry in the list of results,
if any.
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11.  Builder

What is Builder?

Builder is the component of ArtiosCAD which allows you to create new designs based on standards.
By itself, Builder does not allow you to modify the geometry of the created design by changing existing
lines or creating new lines.

Running a standard

Use these steps to create a design from a standard style. A more detailed example follows.

1. Start ArtiosCAD.
2. Click Run a Standard on the File menu.
3. Choose a style from the Standards Catalog. Click OK.
4. Select a parameter set and board code. Click OK. Use the search field in the board control to search

inside board codes and descriptions.
5. Enter the inside dimensions of the new design. Click Next.

 

 
6. At this point, each standard is different. Choose style options and enter values for variables if

appropriate. A variable is a way to store a value so it can be changed in the future. Click the Next
and Previous buttons to move between menus, or click the title of the desired menu to move to in
the tree control. If you know that the options and variables in future menus are set correctly, click
OK to view the completed design.

7. Usually there is a diagram displayed to the left of the tree control to show where the variables in the
current menu are used in the design.
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8. Position the mouse cursor over the name of a variable and wait a moment. A ToolTip will appear
showing the description of the variable.

9. If you try to enter a value that does not meet a variable’s check condition, you will be prompted
to enter a more reasonable value. A check condition limits the values that can be assigned to a
variable.

10. The Next button is unavailable when the current menu is the final menu of a style. Click OK to view
the completed design.

11. The basic design is now structurally complete.

Two options in Defaults control the orientation of the design you just created based on a standard.
They are both in Options > Defaults > Single design parameter sets > <parameter set> > Startup
defaults. The first is in the Flute/grain catalog. For designs based on standards, rotate the result if
needed to match your default flute/grain causes the designs created from standards to be rotated
to respect the default flute/grain direction. A similar option in the Side catalog, For designs based
on standards, mirror the result if needed to match your default side, flips the design if needed to
respect the default side.

Changing Variable Appearance When Running Standards

To change how ArtiosCAD displays variables when running a standard:

1. Click the little triangle above the list of variables to the right next to Variable description format.
 

 
2. Select a new display format from the list.

 

 
3. Adjust the width of the variable pane (if needed) by sliding the separator between it and the

diagram.
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ArtiosCAD also displays the variable description in a ToolTip when you hover over a variable.

Running a Canvas Standard

 When you run a canvas standard, ArtiosCAD includes certain elements of the standard and discards
others.

Included elements Discarded elements

Production parts Layouts

Non-production parts Layout macros

Remainder parts Reports around parts

Hardware parts (along with the link to Defaults) Output parts

Geometry-creating geometry macros Documentation plots for parts

Deleted parts (in case they are referenced by
other geometry)

Parts added as read-only references, with the
read-only mode reset and the reference removed

Regarding parts in the new canvas document:

• Parts specifically set in the standard as read-only remain read-only when run
• Parts that have a copy count greater than 1 retain that copy count when run. If the number of copies

is set by a variable, the value of that variable appears in the Number of copies field in the Parts List.

Regarding boards in the new canvas document:

• ArtiosCAD first looks for the same board code, and if it is not found, looks for the same description.

• If it still does not find a match, it looks for a board with the same caliper, outside loss, and inside
gain.

• If there still is no match, it uses the first board in the table. If there is another board with no match,
it uses the second board in the table, and so on.

• If there are no boards in the board list, ArtiosCAD copies the board information from the standard.

• ArtiosCAD Enterprise honors the state of the Show All Boards checkbox and only shows matching
boards in the board list.

• Change the board for a specific part in the new canvas document by making it the active part and
clicking Info >  Board information.

1. Start ArtiosCAD and click File > Run a standard.
2. Select the desired canvas standard from the Standards Catalog and click OK.
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3. In the Canvas Settings dialog box, select a parameter set for the new canvas, along with boards for

the canvas and different parts. To change the board a part uses, select that part and choose a new
board. Click OK.
 

 
4. In the middle pane are the menus of variables organized by the part containing them.
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You may need to expand parts to see their individual menus.
 

 
5. Set variables and navigate through the menus as normal. For greater clarity, click the tiny triangle

above the list of variables to show their descriptions as well. If there are variable names in the
dimension text in the documentation plot, ArtiosCAD automatically updates them to match the
remapped variable names in the new canvas.

6. Click OK when done to make the design.
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7. Work on the canvas normally.

An example of using the Standards Catalog

Here is how to create a design using the FEFCO 200 standard style.

1. Start ArtiosCAD.
2. Click Run a Standard on the File menu. The Standards Catalog will appear.
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3. Click the plus sign (+) next to the FEFCO Catalog to show its contents, then click the plus sign next
to the 200 Series folder to show its contents. Click the F0200 style and then click OK.

4. In the Single Design Settings dialog box, choose the parameter set to use and board which will be
used to make the carton. Click OK to continue.

5. In the Inside Dimensions dialog box, enter the inside dimensions of the design. Click OK to complete
the design using default values. Clicking Next takes you through menus of additional choices and
values so you can review or alter the defaults of the standard, or you can progress by clicking the
next menu lower in the tree control. In the last menu for a standard, the Next button is unavailable
and you must click OK to complete the standard.
 

 

To change the display format of the variable labels, click the tiny triangle above the list of variables and
select a different option. These options may be set in Defaults in Options > Defaults > Design Defaults
> Rebuild Options.
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Running a new standard

To run a new standard in the current workspace, click Design > Run new standard. You will be asked to
confirm erasing all elements and variables in the current workspace. Click OK to run a new standard,
or Cancel to return to the workspace without making any changes. After clicking OK, choose the new
parameter set and board code, choose the standard from a catalog, set the dimensions, and so forth to
create the new design. Values in the L, W, and D variables in the old design will be carried into the new
design.

This option is also available on the Board selection menu when rebuilding a design based on a
standard.
 

 

Running non-ArtiosCAD standards

ArtiosCAD can run standards from INTERACT, LASERPOINT, LASERPOINT IQ 1, LASERPOINT IQ 2-4,
and The Designer WorkBench.
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The standard libraries from INTERACT, LASERPOINT, LASERPOINT IQ (all versions), and The Designer
WorkBench standards are optionally loaded when ArtiosCAD is installed.

Designer WorkBench and LASERPOINT IQ 2-4 Standards

The Designer WorkBench and LASERPOINT IQ 2-4 standards run as if they were native ArtiosCAD
standards.

Variables and style choice menus work the same way for these standards as they do for native
ArtiosCAD standards. Run them as you would normally run any other ArtiosCAD standard.

Designer WorkBench standards run with the same default values for variables that they had when they
were run in Designer WorkBench. However, the #in the name of the variable in DWB is converted to
DWB when the standard is run in ArtiosCAD.
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INTERACT, LASERPOINT, and LASERPOINT IQ 1 standards

Standards made using INTERACT, LASERPOINT, and LASERPOINT IQ 1 are run using a separate data-
entry window.

To run INTERACT standards, you must enter information in the same format as the prompt used to
request it. In the picture shown above, you are prompted to Give Length Width and Depth. This means
you must enter the dimensions on the same line with nothing but spaces between them – e.g. 5 2 5.
When you have finished entering data, press Enter.

Note:

When running an INTERACT standard, do not click inside the black-background window. This
will be interpreted as an Enter keystroke and the window will close. ArtiosCAD will issue an
error message and you will have to start over.

LASERPOINT and LASERPOINT IQ 1 standards also run using a black window for data input. Enter a
value in each field underlined with a yellow line. Click ACCEPT to proceed through the menus. Click
OVERVIEW to go to a menu of all menus. Click REINIT to reset the variables in the current menu to their
default values.

Rebuilding any of these standards will bring up the appropriate black-background window.

Rebuilding designs

 To rebuild a design, click the Rebuild button on the Toolbar. The same dialog boxes which appeared
when you built the design will reappear. Change the values to change the dimensions of the final
design.
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Most variables you change from their default values are flagged with yellow triangles as soon as you
click something else. Variables which have both a default formula and a default value that fails a check
condition (such as W with a default formula of 0 and the check condition being W>0) are not flagged
with yellow triangles. Style choice variables with default formulae are also not flagged.

Four buttons and one option in the Rebuild dialog box change the values of the variables as you rebuild
the design:

Reinit reinitializes the currently-selected variable to its default value as defined in StyleMaker.

Reinit all reinitializes all variables in the current menu to their default values as defined in StyleMaker.

Edit opens the Edit Variable dialog box where you can edit the formula used by the variable, the
variable’s check condition, the description of the variable, the variable type, the current value of the
variable, and the rounding method and amount.
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Reset resets the variable to the value it had when the menu was accessed last. For example, if you
change a variable from 5 mm to 10 mm, go to the next menu, realize you made a mistake and go back,
change the variable to 7 mm and click Reset, the variable will change to 10 mm, which is what it was
when you entered the menu. If you wanted to change it back to 5, click Reinit instead of Reset.

Automatically reinitialize subsequent variables reinitializes variables in subsequent menus which
currently match their default values. When this option is selected and you change a variable, any
subsequent variable depending on that variable which matched its default value before the rebuild
started will get updated with the new value. For example, with this option selected, if you change L, any
variable in any subsequent menu which depends on L gets automatically updated with the new value
for L.

When this option is off, dependent variables are not automatically updated and are flagged for review
in the Rebuild Conflicts dialog box.
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The checkbox to the left of the variable name controls if the variable is reinitialized to its current
default value when you click Reinitialize Selected Variables To Their Current Default Values. Variables
with yellow triangles are not automatically selected, while those with red triangles are automatically
selected for reinitialization.

Variables with yellow triangles are those which did not initially match their default values at the start of
the rebuild. Variables with red triangles did match their default values, but currently do not.

Click Reinitialize Selected Variables To Their Current Default Values to reinitialize the checked
variables and continue the rebuild. Clicking Ignore All Conflicts ignores the conflicts and continues the
rebuild process.

Note:  This value-checking procedure only works for variables which have default values set.
There is no checking for variables which have no default set but instead depend on other
variables.

 Annotations and Dimensions

Builder allows you to add dimensions and annotations to your designs.

Dimensions are measurements showing the length of lines, the sweep of angles, the radii of arcs,
and so forth. The tools on the Dimension toolbar control the creation, placement, and properties of
dimensions.

Details are magnifications of a user-defined area of the design that show the construction in detail.
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You can also add text and arrows using those buttons on the Annotations toolbar. Both toolbars are
shown below.
 

 
 

 

Note:  Some of the tools on the Annotation toolbar are only available if you have Designer in
addition to Builder.

 Paragraph Text tool

 The first button on the Annotation toolbar lets you add a paragraph of text. Click the tool, indicate
the position for the text, and enter the desired text in the Paragraph Text dialog box.
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As you enter text in the dialog box, it appears as drag text at the put-down point in ArtiosCAD. Changes
are immediately reflected in the drag in the design window, and they apply to all the text entered in the
dialog box.

Set the font and font size using the drop-down list boxes at the top of the dialog box. You may also
change the font size manually by typing the new size in the drop-down list box field.

Note:  PCIQ fonts may appear incorrectly in drag text but should appear correctly when the text
is placed.

 The color under the A indicates the color of the text. A bright blue indicates that the plotting style
color is being used. When you click the button, a control appears. Click the desired color. Use plotting
style sets the text to the color defined by the plotting style. Below that are standard color swatches.
More Colors lets you choose a new color from a palette or define a new one to use this time.
 

 

Note:  If you assign a color to text, it is considered graphics and will not be output to a CAM
device using an internal ArtiosCAD driver. If you need to output text to a CAM device, do not
change its color. However, define a color when planning to convert the design to 3D and export
it to VRML.

  The B and I buttons toggle bold and italic.

 The Justification button shows how the text is currently justified to the put-down point. When
clicked, it shows 9 buttons corresponding to different placement options; click the desired button to
change the justification.
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 The controls in the Rotate: field let you rotate the text as desired. Either select
the desired degree of rotation from the drop-down list box, enter it in the field manually, or click the
keypad icon and use the keypad to input the degree.

While the Paragraph Text dialog box is open, reposition the text as desired by clicking in different
places.

Update Property Defaults sets the current font and size values in the dialog box for use in future
instances of this dialog box in the same ArtiosCAD session.

Once you have entered the text in the Paragraph Text dialog box, click  OK to place it.

After you have added text, double-click it with the Select tool to access its Properties dialog box. Use
the commands in the Properties dialog box to change the attributes of the text, such as font, color,
size, rotation, kerning, etc. Click OK to make the changes, or click Cancel to discard them.

Note:  Note: ArtiosCAD supports up to 38 fonts in a workspace.

The controls in the Properties dialog box are the same as the controls in the Paragraph Text dialog box,
except Calculated for report lets you modify the properties of calculated text on Reports.

Spell checking in the Paragraph Text tool
If you have Microsoft Word installed on your system, ArtiosCAD can use its spell checking functionality
if it is enabled in Defaults (Options > Defaults > Shared Defaults > Startup defaults > Spelling). It is
enabled by default. The Paragraph Text dialog box may take a few moments to appear after the tool is
clicked for the first time.

As you enter text in the Paragraph Text tool, ArtiosCAD communicates with the spell checker in
Microsoft Word, and any unrecognized words are underlined and shown in red.

856



11ArtiosCAD

To spell check the unrecognized word(s), either right-click and click Spell on the context menu, or click
Spell. The standard Microsoft Word Spelling dialog box appears similar to the one shown below.

The unrecognized word is shown in the Not in dictionary: field. The Suggestions: field contains the list
of suggested words, and the top one is selected and seeded to the Change to: field. You may edit the
word in the Change to: field as desired.

Ignore and Ignore All respectively ignore this instance and all subsequent instances of the
unrecognized word for this invocation of the spell checker. The next unrecognized item is then
displayed.

Change changes the current instance of the unrecognized word to the contents of the Change to:
field. Change All changes all subsequent instances of the unrecognized word in the workspace
to the contents of the Change to: field; previously-ignored instances are not changed. The next
unrecognized item is then displayed.

Add adds the unrecognized word to the custom ArtiosCAD dictionary file so that it will be recognized in
the future. The next unrecognized item is then displayed.

Close closes the Spelling dialog box and returns to the Paragraph Text tool.

Align Text tools

The second button on the Annotation toolbar activates the Align Left tool, and when held down,
activates the Align Text tools flyout toolbar.
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 The Align Left tool aligns the selected items along their left edge.

 The Align Horizontal Centers tool aligns the selected items along their horizontal centers.

 The Align Right tool aligns the selected items along their right edge.

 The Align Bottom tool aligns the selected items along their bottom edges.

 The Align Vertical Centers tool aligns the selected items along their vertical centers.

 The Align Top tool aligns the selected items along their top edges.

To use these tools, do the following:

1. Select one or more items of text, and click the desired Align Text tool. The drag will show a common
alignment line.

2. Indicate a pick-up point, and then use the drag to set the put-down point. Shown below is the drag
for the Align Left tool.

3. The text will be aligned in the manner consistent with the tool chosen.

Arrow tool

 The third button on the Annotation toolbar activates the Arrow tool. To make an arrow, click the
Arrow tool, click the start point of the arrow, and then click the end point of the arrow. The head of the
arrow will be drawn at the end point of the arrow.
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Once you have added an arrow, double-click it to change its properties.
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Note:  You cannot change the actual name of the color.

Detail tool

 The fourth button on the Annotation toolbar activates the Details flyout toolbar. Details are
magnifications of a designated area of the design.
 

 

The first button on the Detail toolbar, and the default Detail tool shown on the Annotation toolbar, is
the Detail tool. The Detail tool, when clicked, prompts for the first corner of the clipping window. The
clipping window (window 1 below) defines the area of the design to magnify. Indicate the corner, keep
depressing the mouse button, and indicate the second corner of the clipping window.  ArtiosCAD 
then prompts for the first corner of the detail window. The detail window (window 2 below) is where
the magnified view appears. Click the mouse button at the first corner, and drag the mouse to the
diagonally opposite corner of the detail window.

Double-click any item inside the detail window to change the properties of that detail. Click the Detail
tab in the Properties dialog box to view the properties of the detail.
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The clipping and detail windows will update as their properties are changed. The Adjust Detail button
closes the Properties dialog box and starts the Adjust Detail tool.

When you Output a design with a detail, sometimes the design may flip depending on the settings of
the Output, which can cause confusing behavior for details. Starting with version 16.1.1, the following
rules apply to details when you Output them:

• If a piece of text or a dimension is entirely within the clip outline, ArtiosCAD copies it whole so it will
match the Output.

• If the dimension text is outside the clip outline, ArtiosCAD does not copy the dimension.

• If the dimension text is inside the clip outline, but some of its lines are clipped, ArtiosCAD copies
the text from the dimension as a text item and clips the lines of the dimension, making it all the
same copy as the original item. This will not mirror if the design flips on Output.

• If a text item is partially inside the clip outline, ArtiosCAD converts it to outlines and clips it. These
outlines will mirror if the design flips on Output.

• ArtiosCAD clips strokes and fills.

• ArtiosCAD does not copy images.

Regarding these rules, when you open a design created in an earlier version of ArtiosCAD, ArtiosCAD
will behave as it always has. However, if you rebuild the design or create a new detail, the above rules
will apply.

Adjust Detail tool

 The second button on the Detail flyout toolbar activates the Adjust Detail tool. The Adjust Detail
tool modifies the size and position of the clipping window and the detail window.
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The Adjust Detail tool has three modes: Move Clip, Move Detail, and Move Side. Move Clip lets you
move the clipping window to another location. Use this option by selecting the Move Clip option button,
clicking inside the clipping window, and clicking at the new location of the clipping window.

Move Detail lets you move the detail window to another location. This option works the same way as
Move Clip, except click in the detail window instead of the clipping window.

Move Side lets you drag a side of either the clipping window or the detail window to a new location,
thereby changing the size of the window.

Outline text tools

 The Outline Text tool, which is the fifth button on the Annotation toolbar, activates the Outline
Text tool when clicked, and when held down, activates the Outline Text Tools flyout toolbar.
 

 

This tool converts text into print image lines. The lines comprising letters or numbers are placed in
separate groups. Shown below is text before and after being converted to outlines.

Use this tool by selecting the text to convert and then click the button on the toolbar.

Line text tool

 The second button on the Outline Text tools flyout toolbar activates the Line Text tool.

This tool converts text into geometric lines which can be manufactured. To use this tool, click it,
and then click the block of text to change. The text will change to lines with the closest possible
appearance to the original font. Shown below is a block of text in the Georgia TrueType font before
using the Line Text tool:

862



11ArtiosCAD

After the tool is used, the text appears like this:

Line type label tool

 The sixth button on the Annotation toolbar activates the Line Type Label tool. This tool creates a
piece of text and an arrow pointing to a particular line.

The following controls appear on the Status bar when this tool is active:

The Size: drop-down list box changes the size of the line type label you are about to make.

More Options (...) opens the Line Type Label Properties dialog box as shown below.
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Standard font controls are arranged along the top of the dialog box. Expand Kerning: increases or
decreases the space between letters. Horiz. Scaling: increases or decreases the overall width of the
text. Rotate allows you to place the text at an angle.

In the Arrow group, choose an Arrowhead type: and overall Arrow size: from their respective drop-
down list boxes. Arrow thickness: adjusts the arrow thickness in points.

With extension creates a short horizontal line out from the label text using the value in the Extension
length: field before the start of the arrow. Without extension places the end of the arrow directly next
to the label text.

In the Text box group, Border and Fill each create their namesakes around the label text. The border
has the same color as the label text, but the fill color is set using the button that becomes available
when Fill is checked.

Update Property Defaults makes subsequent line type labels made in this session of ArtiosCAD use
the same Properties as those set in the current dialog box.

Returning to the Status bar, Update Property Defaults sets the size of the current line type label to be
the default for the session.

Text: is the text that will become the line type label. If this field is blank, ArtiosCAD will automatically
fill it in with the selection in the Initial text: field as you drag across lines.

The Initial text: drop-down list box lets you choose what ArtiosCAD automatically inserts in the Text:
field as you drag. You can choose the Line type name, the Line type name and label, and the Line type
label. The Line type label only applies for special rules, and is defined in the Rule label: field on the
Manufacturing tab of the Properties dialog box for a special rule; rule labels may also be defined for
special rules in Defaults.

To make a line type label, do the following:

1.
 Click the Line Type Label tool.

2. If automatic layer switching is on, ArtiosCAD moves to a valid layer or creates one. If it is off, and
the current layer is not appropriate for a line type label, ArtiosCAD prompts you to change to an
appropriate layer or confirm using the current layer.

3. As you drag, the cursor will show the name of the nearest rule or special rule. If you do not click
close enough to a rule, enter the text for the label in the Text: field on the Status bar; the input focus

864



11ArtiosCAD

is set to that field if ArtiosCAD does not fill it in automatically and the drag will show the text you
entered. Click at the point or coordinate which will be the end of the arrow.

4. Use the drag to set the position of the label.

5. If desired, change the options on the Status bar. The drag will remain active.
6. Click to set the final position of the label.

7. The tool remains active in order to add more line type labels. Either make more line type labels or
activate another tool.

You can use drag to move the line type label (or elements of it) after it is created. If you use the Select
tool and click near the text box, you can move the text box.
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Click near the end of the arrow to move the end of the arrow.

To move the entire label, click somewhere else nearby.

The default initial text option can be changed in Options > Defaults > Startup defaults > Line type label
options. Text defaults for this tool are in Options > Defaults > Property defaults > Line type label.

Note:  Avoid using the Select tool in Selection ignoring groups mode to delete individual parts
of a line type label, as this will lead to unpredictable results.

If you change the line type of a line which has a line type label associated with it, ArtiosCAD now
automatically updates the line type label to match the new line type according to the table of
conditions below.

Condition for the existing line type label Result after changing the line type

Line type label has custom text entered in the
Text field.

No result; the label is not changed.

Label initial text is set to Line type label. Changed to match new line type.

Label initial text is set to Line type label (defined
on the Manufacturing tab of the properties of a
special rule type).

Changed to match the new Manufacturing name if
one is defined for that special rule, else changed
to match new line type.

Label initial text is set to Line type name and
label.

Both are changed.
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Condition for the existing line type label Result after changing the line type

Line type label is in a turned-off layer. The line type label is changed and the layer is
turned on.

Line type label is in a locked layer. The line type label is not updated and a warning
appears.

Line type label is in a single design embedded in a
manufacturing document.

The undo history is cleared and a warning appears
that this action cannot be undone.

Hatch tool

 The Hatch tool fills an area of the design with either a pattern of lines or a custom pattern you have
designed and added to the Hatch Catalog.

• It uses a catalog of entries to use different hatches. ArtiosCAD displays a catalog control on the
Status bar when the Hatch tool is active.

• You can design custom hatch patterns, including those that do not use lines, to form any fill pattern
desired.

• You can Output a Hatch Legend, which shows up to 7 hatches used in the current single design.

Hatch Status bar
When you click the Hatch tool, the following controls appear on the Status bar:
 

 

 The first control on the Status bar is the toggle for Select a Panel mode. When the tool is in this
mode, ArtiosCADit hatches the panel you click inside.

 The second control on the Status bar is the toggle for Select Lines mode. When the tool is in this
mode, ArtiosCAD prompts you to select the lines forming a loop that, when complete, will be hatched.

Hatch Lines, the third control, is available only when a complete loop of lines is selected when the tool
is in Select Lines mode. It hatches the area within the loop.

Use the fourth control on the Status bar to select an entry from the Hatch catalog. Click the drop-down
list activator and click the desired entry.
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The fifth control on the status bar, ..., opens the Hatch Properties dialog box. If the catalog selection is
set to a specific selection, the Hatch Properties dialog box for that selection opens showing the entry
selected in the catalog. Click a different catalog entry to change the hatch style.

Clicking the Custom option button with a catalog entry selected changes the dialog box to show
the properties for the selected entry. This same dialog box appears when <custom> is selected in
the drop-down list box on the Status bar and you open the Hatch Properties dialog box, except the
properties for the selected entry are shown, not the default non-cataloged hatch of green lines at 45
and 135 degrees. Refer to the next section for more information about this dialog box.

The values in Offset from cuts and Offset from creases, the sixth and seventh controls on the Status
bar, both control how far away the hatch stays from the lines defining the panel or area being hatched.

Hatch Properties dialog box
The Hatch Properties dialog box has two variants - Catalog mode and Custom mode. In Catalog mode,
the currently-selected catalog entry is highlighted and you can select a different catalog entry if
desired.
 

 

When you start in Catalog mode and click Custom, the properties of the catalog entry appear.
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In Custom mode with no catalog entry selected, you can specify a pattern workspace or line style to
use, along with other properties such as line type and background fill.
 

 

When you view the properties for an existing hatch by double-clicking its edge with a Select tool, the
Properties dialog box does not display a preview of the hatch, because the hatch in the workspace is
updated as you change values in the dialog box. In addition, the placement options and related fields
are hidden when viewing the properties of an existing hatch.

Enter a name for these hatch properties, if desired, in the Name field.

869



11 ArtiosCAD

The controls in the Options group define the construction of the hatch. If Show outline is checked, a
border is drawn around the hatch that is a scaled-down copy of the lines defining the hatch area. Hatch
controls the construction of the hatch lines made at the value specified in the Angle field. Crosshatch
makes a second set of lines at the angle defined in Crosshatch angle. Deselecting Hatch turns off the
crosshatch and makes its checkbox unavailable.

The Pattern group controls determine if the hatch is made of Straight lines or is based on a design file
you specify by choosing From design and then browsing for the design in the File field. If you choose
straight lines, set the distance between them using the Width between field. If you choose a design
file, set the scale of the pattern using Scale.

In the Line Type group, to use just structural lines, choose Lines and set the Line type, Pointage, and
Subtype fields appropriately. To use stroked structural lines, choose Stroke and set the Stroke Width,
Join, and End Cap as desired.

 To set the color of the stroke, click the paintbrush and then choose the desired color from the
pop-up dialog box. Change the palette by clicking More Colors.
 

 

In the Background group, to have a fill behind the hatch, choose Fill and set the color with the standard
Windows color control. To have no fill, choose None. Fill will cover the background regardless of the
layer it is in.

Placement Options is described in the next section.

Update Property Defaults updates the current design’s Defaults so that future hatches you make
in this design will use these same properties. Clicking this button does not affect hatches you have
already made.

Prompt before changing layers controls whether ArtiosCAD asks you to confirm changing layers if you
are in a different layer than the one specified in the Placement Options dialog box. If you do change
layers for hatch, Restore layer on tool exit, when checked, returns you to the layer that you were in
before you started the Hatch tool.

Choose the larger Preview size option to see the preview from further away; choose the smaller option
to see the preview more closely.

Hatch placement options
Clicking Placement Options in the Hatch Properties dialog box opens the Hatch Placement Options
dialog box.
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To create the hatch in a specific layer other than the current one, check the Layer checkbox, enter a
name for the layer in the Name field, and choose the layer class in the Class drop-down list box. Plot
under the main design draws the hatch and fill (if any) beneath the structure.

To create a gap between the hatch and any cuts or creases in the design, check Offsets and enter the
offset values in the fields.

When either checkbox is checked, the Placement Options button in the Hatch Properties dialog box
changes to include the icon as shown below.
 

 

Using a hatch pattern file
To design custom hatch patterns, make single design workspaces with the desired geometry following
the guidelines in this section. Custom hatch patterns may function as both hatches and crosshatches.

If you have StyleMaker, you can make the workspaces resizable, but note that they will not resize when
you resize the design - you must create different versions of the pattern workspace at the desired
sizes, save those files in ServerLib or ClientLib, and add Hatch Catalog entries that use those
workspaces.

Shown below is the PAT_CIRCLEWAVE.ARD pattern workspace.
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The length of the vertical annotation line is defined by variable PATD. The annotation line sets the
distance between the wavy lines when the pattern is stepped and repeated at 45 degrees as shown
below.
 

 

In the example workspace, variable WLEN sets the horizontal distance for each arc and variable WFIN
sets the start angle of the arcs.
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To make a custom hatch pattern workspace, do the following:

1. Start ArtiosCAD and create a new single design.
2. To make the pattern resizable, you must have StyleMaker. If so, define the variables you will need to

construct the geometry.
3. Draw the desired pattern at 0 degrees horizontally. Use an Annotation line connected to the start of

the pattern to define the distance between the pattern repetitions.
4. Save the workspace to ServerLib or ClientLib.
5. Add an entry to the Hatch Catalog in Defaults that uses this pattern workspace.
6. Use the catalog entry as desired.

To make different versions of the same resizable pattern, do the following:

1. Resize the pattern workspace as desired.
2. Save each version to ServerLIb or ClientLib with a unique name.
3. in Defaults, create a Hatch Catalog entry for each iteration of the pattern workspace.
4. Use the new Hatch Catalog entries as desired.

Dimensions

Dimensions are measurements added to the design so that someone looking at the design knows
the length, angle, and radii of the geometric elements of the design. Shown below is the Dimensions
toolbar.
 

 

Before creating dimensions, ensure there are design lines in the Main Design, Windows and Cutouts,
or Manufacturing layer of the design. If there are no design lines in any of those layers, you will get a
warning dialog box when attempting to add dimensions. To work around this warning, move design
lines to the appropriate layers and either change the dimension size or toggle Scale size upon rebuild
in Edit > Property Defaults for Dimensions.

If you are not in a layer with class Dimensions or Overall Dimensions, the first time you click a
dimension-creation tool you are asked if you want to create such a layer.
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Click Yes to create a Dimension layer or No to keep working in the current layer. If you click No, and
then proceed to make dimensions, you are not asked this question again. If you click No and do not
make any dimensions, you are asked the question again the next time a dimension-creating tool is
clicked.

If you click Yes, and there is no layer of class Dimensions or Overall Dimensions already in the design,
the Use Dimension Layer dialog box appears.

To create a layer with a custom name, click Create New, enter the layer name, choose its class, and
click OK.

Or, to use a Dimensions layer, select it and click Add To. You can also use Add To to add to selected
already-existing layers shown in the list.

Use Delete to delete the selected layer. Clicking Cancel completely stops the tool.

 The first button on the Dimensions toolbar activates Temporary Dimensions mode. Dimensions
made in this mode:

• Are not subject to any layer creation issues.
• Are made with light green extension lines to distinguish them from regular dimensions.
• Are not selectable, and thus may not be changed or deleted.
• Are not affected by a Select tool’s Nudge by Stretch mode or by the Stretch Point tool.
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• May be moved or stretched by the Stretch by Polygon tool. If only one of the end-points of a
temporary dimension is within the selection polygon, the dimension is stretched instead of moved.

• Are shown only on the screen, and are not printed, Output, or exported to other file formats.
• Are deleted on Rebuild.
• Are in existence only until Temporary Dimensions mode is turned off by clicking the Temporary

Dimensions button again.
• Are not saved when the single design is saved.

If Temporary Dimensions mode is active while in a Dimensions or Overall Dimensions class layer, when
the Layers dialog box is opened, the pencil icon is dimmed to indicate Temporary Dimensions mode. It
returns to normal when Temporary Dimensions mode is turned off.

 The second button on the Dimension toolbar, and the default tool on the Distance Dimension
flyout toolbar, activates the Distance Dimension tool. This tool measures the distance between two
lines or points. To use this tool, do the following:

1.
Click  to activate the tool.

2. To adjust the text position of the dimension after setting the line or point to measure to, select
Adjust text position on the Status bar.

3. Click the line or point to measure from.
4. Click the line or point to measure to.
5. Click the extend position (where the measurement is to be placed).

6. If you selected Adjust text position on the Status bar previously, click to set the desired position of
the text.

If, when making dimensions next to each other, the arrows overlap the text, the overlapping arrows are
replaced by a diamond.

 The second tool on the Distance Dimension flyout toolbar is the Auto-Aligned Distance
Dimension tool. This tool constructs a series of distance dimensions between consecutive lines and
then prompts for a common extension point. To construct auto-aligned distance dimensions, do the
following.

1. Click the tool.

875



11 ArtiosCAD

2. Click the line to measure from.
3. Drag across the line(s) to include in the aligned dimensions.
4. When you have made as many measurements as desired, indicate the extension point for the

dimensions by using the drag and clicking.
5. All the dimensions will then have the same extension point.

 The third tool on the Distance Dimension flyout toolbar is the Aligned Distance Dimension tool.
Use this tool to construct consecutive dimensions whose extend positions are collinear. Click the first
line to measure, then the second line to measure, and so forth, and then click to set the extension point
for all the dimensions.

 The fourth tool on the Distance Dimension flyout toolbar is the Cumulative Distance Dimension
tool. This tool creates cumulative dimensions from a start point along a straight line, measuring the
distance from the start point at each intersection. To use it, do the following:

1. Click the tool.
2. Click the point or line to start measuring from.
3. Set the angle at which to measure.
4. Use the drag to intersect all the lines and points to measure.

5. Click to set the number of dimensions; the dimensions are inserted. You may need to adjust their
positions to aid clarity.
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 The third tool on the Dimensions toolbar, and the default button on the Angle Dimension flyout
toolbar, is the Angle Dimension tool. This tool measures the angle between two lines. Click this tool,
indicate the first leg of the angle, then indicate the second leg of the angle, and then indicate the
position of the measurement. The format of the measurement depends on where you position it.

  The other tools on the Angle Dimension flyout toolbar are the Angle From Horizontal tooland
Angle From Vertical tool.

The Angle From Horizontal tool measures the angle at which a line is offset from the horizontal axis. To
use this tool, click it, indicate the line to measure, indicate the point on the line to measure, and then
set the position of the measurement.

The Angle From Vertical tool measures the angle at which a line is offset from the vertical axis. This
tool works the same way as the Angle From Horizontal tool except that it measures from the vertical
axis.

 The fourth button on the Dimensions toolbar, and the default button on the Radius Dimension
flyout toolbar, activates the Radius Dimension tool. This tool measures the radii of arcs and circles.
To use this tool, click it, indicate the arc or circle to measure, and then indicate the location of the
measurement.

 The second tool on the Radius Dimension flyout toolbar is the Radius To Circle Dimension tool.
This tool measures the distance from an arc or circle to its center. To use this tool, click it, indicate the
arc or circle to measure, and then indicate the location of the measurement.

 The third tool on the Radius Dimension flyout toolbar is the Diameter Dimension tool. This tool
measures the diameter of a circle or arc. To use it, click it, then click the circle or arc to measure, and
then click the extension point for the measurement.
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 The fourth tool on the Radius Dimension flyout toolbar is the Diameter to Circle Dimension
tool. This tool measures the diameter of a circle or arc through the center so that the arrows on the
extension lines are on the circumference of the arc or circle. To use this tool, click it, then click the
circle or arc to measure, and then click the extension point for the measurement.

 The fifth button on the Dimensions toolbar activates the Change Dimension Alignment tool. This
tool lets you align dimensions with each other. This tool is available only when one or more dimensions
are selected. To use this tool, select the dimensions to align, click the tool, and indicate the new
alignment point. A drag image of the selected dimensions will appear to guide you in selecting the new
alignment point.

You can align parallel dimensions by selecting them with the Select tool. When you use the drag to
move them, they will all change to have the same extension point. You cannot use freehand drag to
align non-parallel dimensions. When freehand dragging a single dimension, press the SHIFT key to
keep the text position in line with its original position.

You can align the selected dimensions with an existing dimension by clicking the existing dimension to
snap to.

A snap circle will appear around the dimension text used to align the dimensions.

Shown below are dimensions before they are aligned and after they are aligned.

 The sixth button on the Dimensions toolbar activates the Change Text Position tool. This tool lets
you move the position of text in a dimension. To use it, select the dimension whose text position you
want to change, click the tool, and indicate the new text position. If you try to use this tool with more
than one dimension selected, all the text will be moved together and the results will not be what you
had anticipated.

 The seventh button on the Dimensions toolbar activates the Change Extension Line Length tool.
Use this tool to move the end of the selected extension lines for a dimension, or for a series of parallel
dimensions.

Shown below is a series of parallel dimensions whose extension lines all come close to touching the
panels of the box.
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To move them away from the panels, do the following.

1. Select the dimensions with the Select tool, holding down SHIFT to select more than one item at
once.

2.
 Click the Change Extension Line Length tool. Drag will appear, enabling you to change the

length of the extension lines.

3. Release the mouse button and the lines’ length will be changed to meet the point where you set the
drag.

To reset extension lines to their default positions, drag the extend point back toward the design, or set
the Extension length: field in the Properties dialog box to a large value. The extension lines will stop
short of intersecting any design lines.

 The eighth button on the Dimensions toolbar, and the default button on the Automatic Dimensions
flyout toolbar, is the Auto Dimension tool. As the name implies, this tool creates automatic
dimensions. It finds the longest horizontal and vertical lines and uses those to define the main panels.
Dimensions for the main panels are aligned with the extension point you specify. Other dimensions are
then added for the rest of the geometry, avoiding dimensioning identical flaps. The tool avoids making
overlapping dimensions as much as possible, but in some cases dimensions may require manual
adjustment.

Note:  If the dimension property default for text position is set so the number is at the end
of the line, the Automatic Dimensioning tools will put the numbers in the middle of the lines
instead.

To use this tool, do the following:

1. Construct the desired geometry.
2.

 Click Auto Dimension. If you are not in a dimension layer, ArtiosCAD prompts you to create one
or stay in the current layer.

3. Indicate the extension point to use for aligning the dimensions.
4. The dimensions are drawn. To produce the example below, the extension point is above and to the

right of the design.
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 The second tool on the Automatic Dimensions flyout toolbar is the Auto Dimension Window tool. It
works similarly as the Auto Dimension tool, but only on the portion of a design you indicate.

To use this tool, do the following:

1. Construct the desired geometry.
2.

 Click Auto Dimension Window. If you are not in a dimension layer, ArtiosCAD prompts you to
create one or stay in the current layer.

3. Click and drag to indicate the portion of the design to auto dimension.
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4. Dimensions are created for every point in the window and every line crossing the window boundary.

Notes and warnings about automatic dimensioning tools
Diagonal lines at a whole number of degrees are dimensioned with an angle and a horizontal or vertical
dimension, whichever is longer.

881



11 ArtiosCAD

Blends are dimensioned from their corners, not from the ends of the arcs.

The automatic dimensioning tools measure all structural lines except for zero-length lines. Avoid using
them with Auto-Trace or digitized shapes with many short lines.

The automatic dimensioning tools are unavailable in Manufacturing.

Dimension properties
You can change the properties of dimensions, as with other ArtiosCAD entities, by double-clicking
them.

In addition to being able to change the standard text attributes (text size, color, bold, and italic), you
can also set these attributes:
 

 

• The kind of units displayed (imperial, metric, or a combination) and the format in which they are
displayed.

If you show Imperial dimensions in sixteenths, you can choose between ` and : as the separator
character in Options > Defaults > Shared defaults > Startup defaults > Units and formatting >
Sixteenths format character.

• The value by which to round the dimension.
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• The number of decimal places.

• The inclusion of trailing zeros.

• The orientation of the text relative to the extension lines.

• The type of the arrowhead and size of the arrow.

• The format for the radius and diameter text styles (if a radius or diameter dimension is selected).

• The length of the extension lines (if a dimension with extension lines is selected).

• The length of the gap between the extension lines and the design edge. If the extension line ends at
an angle or close to an arc, ArtiosCAD measures the gap from the nearest perpendicular line.

• The position of the dimension text between the extension lines.

• Whether or not to add a tolerance to the text of the dimension, as controlled by Use tolerance.
Enter the desired tolerance in the Tolerance field. Select Use different tolerances to specify two
tolerances. You can also change the separator between them if desired.
 

 
Tolerances are available for regular distance dimensions. They are not available for angle
dimensions, dimensions in 3D, or dimensions using format overrides.

• The text actually shown as the dimension in the Text: field. To create a dimension including the
distance that changes automatically as the design is rebuilt, enter {V} desired text, such as {V} typ.
4 places. If tolerances are enabled, they are included with {V}.

Update Property Defaults sets all dimensions created after this one in the current ArtiosCAD session
to use the values you specify in this dialog box before clicking it. Extension Length is included in this
setting only if you changed the entry in the field manually.

When the Scale text size upon rebuild checkbox is checked, the dimensions you selected when you
opened the Properties dialog box will change size relative to the overall size of the design when it is
rebuilt. Their position relative to the edge of the design will also be maintained. Turn this option off to
create dimensions and avoid warnings when there are no design lines in the Main Design, Windows and
Cutouts, and Manufacturing layers.

The Extension length: field allows you to set the length of the extension lines for all selected
dimensions at once. The length is measured from the dimension toward the design.

All these properties can be set for the current ArtiosCAD session by clicking Edit > Property Defaults
and then clicking the Dimensions tab.
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Text horizontal when rotate is an additional property for Dimensions in the Properties Defaults
dialog box that is not available in the usual Properties dialog box when a dimension is selected. When
enabled, this option keeps the text of the dimensions horizontal when the design is rotated using the
rotate and mirror tools in Designer and Manufacturing.

This option is enabled by default. To set the default, click Options > Defaults > Property Defaults >
Dimensions and change it there. You may also change the other defaults as desired. When in Defaults,
you can set the size of the design on which dimension size is calculated in the Scale text size upon
rebuild group; the default design size used for this calculation is 40 inches or 1000 mm.

Note:  Dimensions created by the Copy Times and Copy Times Rotate tools are not affected by
this option.

Draw extension lines close to parallel lines helps keep dimensions tidy.

Note:  If you change the color of a dimension from the default, it is considered graphics when
changing the View Mode.

Rounded dimensions
Use the Round to checkbox in the Inches format: group with caution. It will cause the selected
dimension to round up or round down as appropriate and not match its actual value.
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If there are rounded dimensions in the design, or the dimensions are rounded by a dimension format
override, and there are smaller dimensions that add up to larger dimensions, the values of the larger
dimensions will be adjusted to match the sum of the rounded values of the smaller dimensions.

The default for rounding is in Defaults > Shared Defaults > Startup defaults > Dimension Format
Override.

If you use overall dimensions, they may not match the sum of individual rounded dimensions. You can
ensure that they match for the current design by checking the Consistent overall rounded dimensions
checkbox in Options Dimension Formatting. This can also be set in Defaults in Defaults > Shared
Defaults > Startup defaults > Dimension Format Override. It affects horizontal and vertical dimensions
only; it does not affect diagonal dimensions.

If you set Consistent overall rounded dimensions, it affects all aspects of ArtiosCAD, not just the
viewing of dimensions in Builder, Designer, and Manufacturing. It affects dimensions in outputs
(regardless if it uses a Report), blank size on Reports, and the Blank Size dialog box on the Info menu.

If you want to use rounded dimensions with a report made in a pre-5.x version of ArtiosCAD, and
have blank sizes defined on the report, delete and re-add the blank size variables from the Calculated
Expressions Catalog.

You can check for rounded dimensions when a single design or an embedded single design is opened
by checking the Warning if design contains rounded dimensions checkbox in Defaults > Shared
Defaults > Startup defaults > Dimension Format Override.

When that checkbox is checked, the Rounded Dimensions Warning dialog box appears as shown below.

Reset to Actual un-rounds the selected dimensions. Select more than one dimension in the list by
holding down ctrl and clicking the desired entries.

Reset All un-rounds them all.

Easily resetting and applying Property Defaults

The commands on the Apply Defaults sub-menu on the Edit menu and context menu (the menu that
appears when you right-click the mouse) change the format of dimensions, text, or both dimensions
and text with one click.
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These commands change the current Property Defaults of the workspace to the Property Defaults
specified in Defaults, and then apply the new Property Defaults to all the dimensions and/or text in
visible, unlocked layers of the workspace depending on the menu item you clicked. Elements in turned-
off layers and/or locked layers are not changed by this command.

To use these tools, do the following:

1. Click Edit > Apply Defaults or right-click and click Apply Defaults (as shown below).
 

 
2. Click the desired option for those elements to change: Dimensions and Text, Dimensions, or Text.
3. ArtiosCAD may prompt you to confirm the change. Click Yes to confirm.
4. ArtiosCAD applies the settings in Defaults to the current Property Defaults and changes the

appropriate workspace elements to match those settings.
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Note:

If you Undo any of these commands, only the workspace elements are changed back to their
prior formatting. The Property Defaults of the workspace remain at their current settings.

Palletization in Builder

If you use Cape Pack or TOPS palletization software, you can export data from them and have
ArtiosCAD create a package from that data.

You can also create secondary packaging in them from 3D and view pallet loads in 3D from them. See
the 3D chapter for more information.

For answers to some frequently asked questions about palletization, see Palletization FAQ in the
Outputs chapter.

Note:

Before using these features for the first time, make sure you have mapped Cape Pack or TOPS
styles and materials to ArtiosCAD standards and boards as described in the Builder chapter.
You may also want to set Cape Pack or TOPS defaults as described in the Defaults chapter.

The workflow for palletization in ArtiosCAD is the same regardless of which palletization
application you are using.

Mapping styles

To map the styles between Cape Pack/TOPS and ArtiosCAD, do the following:

1. Launch ArtiosCAD.
2. Click Options > CAPE/TOPS to ArtiosCAD.

The Map CAPE/TOPS to ArtiosCAD dialog box appears.
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3. Double-click a style to associate with an ArtiosCAD standard.
4. In the Select ArtiosCAD Standard to use in place of dialog box, choose the desired ArtiosCAD

standard and click OK. You may only select ArtiosCAD-format standards.
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5. In the Length, Width, and Height fields, set the number of folds in each direction.
6. Repeat as desired by double-clicking another style to map.
7. Click OK when done.

Mapping boards

To map the boards between Cape Pack/TOPS and ArtiosCAD, do the following:

1. Launch ArtiosCAD.
2. Click Options > CAPE/TOPS to ArtiosCAD.

The Map CAPE/TOPS to ArtiosCAD dialog box appears.
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3. In the Map CAPE/TOPS to ArtiosCAD Standard dialog box, click the MATERIAL_BOARD tab.
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4. Double-click a Cape Pack/TOPS board.

The Define a corresponding board for dialog box appears.
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5. Open the Artios catalog and select the desired board. Click OK when you have selected the desired

board. If you cannot find a corresponding definition, open DataCenter Admin and create one, close
this dialog box and its parent, and resume at step 2.

6. Repeat as desired by double-clicking another board to map.
7. Click OK when done.

Creating a pallet group

To create a pallet group using a combination of Cape Pack/TOPS and ArtiosCAD, do the following:

1. Cape Pack/TOPS will use the last-launched version of ArtiosCAD. If your last-launched version was
not 12 or later, launch it and leave it open.

2. Launch Cape Pack/TOPS.
3. In Cape Pack, in the Pallet Group, make your selections as desired and click Go.
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In TOPS, enter your package design sequence and click Calc.
 

 
4. Choose the type of package to make and enter the appropriate values for your package.
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5. Cape Pack/TOPS will use its default pallet. To change it, click the next tab on the screen (in the

example above, it is labelled 48x40) and choose a new one. To not change the pallet, skip to the
next step. You can also change the truck size on the last tab but ArtiosCAD does not use that
information.
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6. For Cape Pack, click File > Calculate Only. For TOPS, click OK.

Click Yes or No to any alerts as desired.
7. For Cape Pack, use the Goto Next Solution and Goto Previous Solution arrows to find the best

solution.
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For TOPS, scroll through the list of solutions in the UnitLoad window and click a solution to view it.
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8. For Cape Pack, when you have found the best solution, click Export > Export to ESKO > Send to
ArtiosCAD.
 

 
For TOPS, when you have found the best solution, click Export > Send to ArtiosCAD. Choose which
elements to export and click Export, and click Cancel in the Analysis Save As dialog box.

If you do not have either the style or board mapped as described previously, ArtiosCAD will prompt
you to choose the missing elements.

9. ArtiosCAD displays the standard it constructed using the Cape Pack/TOPS data. Work with the
single design as you would any other workspace.
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Arranging/Designing a group

The Arranging/Designing a Group workflow between Cape Pack/TOPS and ArtiosCAD is similar to that
of creating a shipper for use on a pallet, but at the end there are two designs in ArtiosCAD.

If you are using Cape Pack, follow the instructions below. For TOPS, the workflow is similar in that you
select more than one element to create, create them, and then use the Send to ArtiosCAD command
on the Export menu.

1. Cape Pack will use the last-launched version of ArtiosCAD. If your last-launched version was not 12
or later, launch it and leave it open.

2. Launch Cape Pack.
3. In Cape Pack, in the Arrange/Design Group, make your selections as desired and click Go.
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4. In the Data Input window, click the three tabs to choose the packages and pallet and enter values in

the fields as appropriate.
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5. Click File > Calculate Only.

Click Yes or No to any alerts as desired.
6. Use the Goto Next Solution, Goto Previous Solution, Goto Next Pattern, and Goto Previous Pattern

arrows to find the best solution.
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7. When you have found the best solution, click Export > Export to ESKO > Send to ArtiosCAD.
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If you do not have either the styles or boards mapped as described previously, ArtiosCAD will
prompt you to choose the missing elements.

8. ArtiosCAD displays the standards it constructed using the Cape Pack data in cascaded windows.
Work with the single designs as you would any other workspaces.
 

 
If pallet information exists in the ArtiosCAD session, a pallet appears in the 3D workspace when you
convert the design to 3D.
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12.  Designer

Introduction to Designer

There will be times when you need to create a design from scratch instead of using an entry from a
Standards Catalog. ArtiosCAD handles those situations by providing sophisticated design tools that
empower you to quickly and easily turn your ideas into reality.

These tools are available on systems with the Designer option. Certain other modules provide access to
some of the tools. Systems with only the Builder option cannot use these tools.

Overview of Designer

All the tools work the same way. Click the tool and satisfy the drag prompts by moving the pointer and
clicking the mouse button. The geometry is created when enough prompts are satisfied.

Examples of tasks completed using Designer are:

• Creating original designs and modifying existing designs.

• Creating and deleting lines, arcs, circles, rectangles, curves, and beziers.

• Adjusting and transforming the linear and physical properties of elements in the design such as line
type, number of bridges, or physical placement in the design.

Creating geometry

 What is geometry?

In Designer, geometry is any item that is on a die press manufacturing tool. Dimensions, annotations,
and graphics are not considered geometry. Create geometry with the tools on the Geometry toolbar.
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Endpoint Offset Mode

 Endpoint offset mode lets you create geometry when you don't know the exact endpoint, but you
know that you want it to be offset by a certain distance from an existing line or point. You can offset
from a line or a point. The way it works is that you activate it while you are setting a prompt for a tool.

To activate it, either click the toggle button on the Status bar, or hold down ALT and click the line or
point from which to start the offset.

You can start an offset from:

• An endpoint
• An extend point
• A dynamic point (one created by Dynamic Drafting)
• An intersection
• A line
• A construction line
• An arc
• A construction arc

You can use Endpoint offset mode in:

• Geometry tools (Line, Arc, Circle Diameter, and so forth)
• Rotate tools
• Copy Rotate tools
• Mirror tools
• Copy Mirror tools
• Move By

Note:  The rotate and mirror tools require two Undo commands to return to the previous state.

908



12ArtiosCAD

You can offset from either a line (click the line) or a point as listed above. Offsetting from a line prompts
for Offset 1 and Offset 2. Offsetting from a point prompts for Offset X and Offset Y.

Most tools allow either method, but:

• If you set the Length prompt in a tool, you can only use this mode to offset from a line, not from a
point.

• Rectangle Horiz/Vert, Rectangle from Center, Ellipse, and Circle Diameter only support offsetting
from a point, not a line.

When you use the offset from a point method,

• Use the same reference point for each offset
• Set either offset to continue the geometry
• Complete one more field on the Status bar to finish the geometry.

If you do a combination of offset from a line and offset from a point, ArtiosCAD displays the controls on
the Status bar in the order in which you chose offsets.

To change the reference point or to start the offset again, click the Endpoint offset mode toggle on the
Status bar again or CTRL-click the point or line.

To exit Endpoint offset mode, either click the button on the Status bar to turn it off, or press ESC to
restart the tool.

Using Endpoint Offset Mode
Let's say you want to put a window in a panel that's the same distance away from the two far edges of
the panel no matter how you rebuild the design.

1. Use Move To (CTRL-W) to move the current position to the top left corner of the panel.
2.

 Start the Rectangle Horiz/Vert tool.
3. Use Move By (CTRL-Q) to set the point of the upper left corner of the window.

a) After you start Move By, ArtiosCAD will prompt for an angle. Hold down ALT and click the crease
forming the top of the panel to start the offset for the starting point.

b) Drag down to set the direction of the offset. Type D/6 in the Offset 1 field on the Status bar. (This
uses Offset from line mode.)
 

 
c) ALT-click the crease forming the left side of the panel and set Offset 2 to W/4.ArtiosCAD now

has enough information and moves the current position to the starting point for the window.
4. Set the width of the window as follows:

a) Drag toward the crease forming the right side of the panel.
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b) ALT-click the midpoint of the crease to create an offset from the right side of the panel. You
have to click the midpoint because Rectangle Horiz/Vert only supports offsetting from a point.

c) Drag left and set the offset at ½ inch or 13 mm.
 

 
5. Set the height of the window as follows:

a) Drag down toward the cut forming the bottom of the panel.
b) ALT-click the midpoint of the cut to create an offset from the bottom of the panel.
c) Drag up and set the offset at ½ inch or 13 mm.
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6. ArtiosCAD creates the rectangle.
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This window will remain in the same distance away from the right edge and bottom of the panel no
matter how you rebuild it. No construction lines were needed.

Before resizing, with the carton dimensions of 2" x 2" x 5" or 50 mm x 50 mm x 127 mm:
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After resizing, at 3" x 3" x 9" or 76 mm x 76 mm x 229 mm. Note how the right side and bottom of the
window are the same distance away from the edges of the panel even though the window size has
changed dramatically.
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 Lines

Lines are one of the basic building blocks of ArtiosCAD. Any shape can be made out of lines and arcs.
There are three Designer tools to create lines: the Line Angle/Offset tool, the Line Horiz/Vert tool, and
the Line Angle/Length tool.

The first button on the Geometry toolbar activates the Line tools. The Line tools are used to make
straight lines. When you click and hold a Line tool button on the toolbar, the Line flyout toolbar
appears.
 

 

 Lines at an angle

 To make a line at an angle, click the Line Angle/Offset tool. The line will begin at the current
position. The Status bar will prompt for the angle of the line and the offset of the end-point. Set the
prompts using drag and the line will be drawn. Use the arrow keys to move among the fields on the
Status bar – the highlighted field is the one being set by the drag.
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If you click an established point when prompted for the offset, the line being drawn will end at the point
you clicked if possible. If the end-point and the point you clicked are not collinear, the endpoint will be
aligned with the point you clicked.

You may use any Line tool to construct a line at an angle. Simply change the Status bar prompts
being set by the drag. The toolbar buttons only specify which prompts are selected when the tool is
activated.

When using this tool, holding down CTRL while clicking performs a Move By.

Lines with a known X, Y offset of the end-point

 To make a line from the current position with a known X,Y offset of the end-point, click the Line
Horiz/Vert tool. Set the prompts. If the end-point is a known point, simply click that point, and the line
will be created.

Lines of a specific length

 To make a line at a specific length, use the Line Angle/Length tool. Set the angle and length fields
using drag, or if you prefer, type the desired values.

Line to a known point

 To make a line from the current position to a known point, click the Line Angle/Offset tool, then
click the point that is the end-point of the line. The angle and length will be set automatically. A small
temporary circle will appear around the point that was snapped to.

Arcs and circles

Arcs and circles are one of the basic building blocks of ArtiosCAD. Any shape can be made out of lines
and arcs. There are six Designer tools to create arcs and circles: the Arc Start Angle tool, the Arc End
Point tool, the Arc Center tool, the Arc Through Point tool, the Circle tool, and the Ellipse tool.
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The second button on the Geometry toolbar activates the Arc tools, and when held down, activates the
Arc flyout toolbar. The third button on the Geometry toolbar activates the Circle tools, and when held
down activates the Circle flyout toolbar.
 

 
 

 

ArtiosCAD prompts for five pieces of information when creating an arc:

• Start angle. This is the angle at which the arc projects from the start-point. This is shown as A1 on
the Status bar.

• Arc radius. This is the distance from the arc to the center of the circle of which the arc is a piece.

• X and Y offsets. These define the position of the arc’s end-point in relation to its start-point.

• End angle. This is the angle at which the arc ends. This is shown as A2 on the Status bar.

ArtiosCAD constructs an arc as soon as it knows any 3 of these 5 pieces of information.

Arcs using a start angle, radius, end-point offset
If you know the angle, radius, and location of the end-point of the arc you want to make, use the Arc
Start Angle tool to construct the arc.

1.
 Click the Arc Start Angle tool on the Geometry toolbar.

2. Use the mouse to set the drag for the start angle.

3. Once the start angle is set, use the drag to set the radius of the arc.
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4. Set the Y offset of the end-point using the drag. To set the X offset instead, use the arrow keys to
move the highlight to the X offset field.

5. As ArtiosCAD now has the pieces of information it needs to construct the arc, the arc is made.
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Arcs using an X, Y offset, radius
Use the Arc End Point tool to make an arc when you know the radius and the X,Y offsets of the end-
point.

1.
 Click the Arc End Point tool and use the drag to set the X offset of the arc’s end-point.

2. ArtiosCAD will then prompt for the Y offset of the arc’s end-point.
3. After the Y offset of the arc’s end point has been set, ArtiosCAD will prompt for the radius of the arc.
4. The arc is now created and the tool remains active in order to make another arc.

Arc Center

 The third tool on the Arc flyout toolbar is the Arc Center tool. This tool makes an arc when any 3 of
its 5 data fields are set: the radius, the X value for the center of the arc, the Y value for the center of the
arc, the X value for the end-point, or the Y value for the end-point.

Arc Through a Point

 The fourth tool on the Arc flyout toolbar is the Arc Through Point tool. The arc starts at the current
position. To use this tool, click it, indicate the point the arc will go through, and then click the end-point
of the arc.

In the picture above, the end-point of the arc has a small snap circle around it.

If the start point is on a construction circle or arc, the drag is constrained to follow the arc.

Note:  This tool can only be made using drag. There are no status bar prompts.

Circle

 The Circle tool is the third button on the Geometry toolbar, and when held down, activates the
Circle flyout toolbar.
 

 

To make a circle, click the Circle tool and then set the radius of the circle either by using drag or by
typing a value in the prompt on the Status bar.
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Once you set the radius, ArtiosCAD constructs the circle using the current position as the center of
the circle. As with other tools, you can snap the radius drag to a point; a temporary circle will appear
around the snapped-to point.

Circle Diameter

 The Circle Diameter tool is the second tool on the Circle flyout toolbar. To make a circle using this
tool, do the following:

1.
 Click the Circle Diameter tool.

2. Drag and click to set the angle from the current position of the line forming the diameter of the
circle.

3. Drag and click to set the diameter of the circle. Alternately, press Tab on the keyboard to choose a
different field on the Status bar to set with the drag - either the X offset or the Y offset of the end-
point of the diameter.

4. Once you have set the end-point of the diameter, ArtiosCAD constructs the circle.

The tool remains active and the current position does not move so that you may continue drawing
circles.

Ellipse

 The third tool on the Circle flyout toolbar is the Ellipse tool. To make an ellipse, click the Ellipse
tool and use drag to set the X and Y offsets of the edge of the ellipse from the center point. Angle refers
to the angle at which the ellipse is viewed. It does not affect the construction of the ellipse. Setting the
X and Y offsets are shown below.
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When both the X and Y offsets are set, ArtiosCAD constructs the ellipse.

Rectangles

Instead of making you draw four lines to construct a rectangle, ArtiosCAD makes the construction of
rectangles easy by providing a tool for that purpose. You can make a rectangle from scratch, or you
can expand a line into a rectangle. You can also expand a line into a complete panel using a geometry
macro.
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The fourth button on the Geometry toolbar activates the Rectangle tool, and when held down, activates
the Rectangle tools flyout toolbar. The Rectangle tools are used to create rectangles.
 

 

Rectangle Horiz/Vert

Use the Rectangle Horiz/Vert tool to create rectangles in two easy steps. To make a rectangle,
click the Rectangle Horiz/Vert tool and indicate the X offset of the point diagonally opposite from the
current position as shown in the picture below.

To construct the rectangle with blended corners, enter a value in the Blend: field on the Status bar
before setting the X offset. Press Enter once you have entered the value to lock it in.

Once the X offset of the corner point is set, set the Y offset using the drag as shown in the picture
below.

When the X and Y offsets have been set, ArtiosCAD constructs the rectangle and the current position
moves to the corner of the rectangle whose offsets were set. Shown below is the completed rectangle.
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The Rectangle Horiz/Vert tool remains active so that another rectangle may be made.

Rectangle from Center
The second button on the Rectangle flyout toolbar activates the Rectangle from Center tool. This tool
creates a rectangle from its center with an optional blend on the corners. To use it, do the following:

1. Move the current position to the center of the desired rectangle by using CTRL-W, CTRL-Q, or
Tools > Current Point.

2.
 Click Rectangle from Center.

3. On the Status bar, enter an optional value in the Blend: field and press enter to lock the value in the
field.

4. Use drag to set the X and Y coordinates of a corner of the rectangle. The values in the fields on the
Status bar are for the entire width and length of the rectangle, not half of it.

Panel from Line

 The third button on the Rectangle flyout toolbar is the Panel From Line tool. This tool creates a
rectangle using drag from a line you select, or lets you run a geometry macro to replace the line. This
tool prompts you to select a line, and then uses the selected line as the base of a rectangle created
using drag.

When you use this tool, the following initial controls appear on the Status bar:
 

 

Rectangle from Line mode
To use this tool in Rectangle from Line mode, click it and then select a line. Use the drag to set the size
of the rectangle, or type the desired value in the Status bar.
 

 
Use crease type, when checked, causes the connecting line to be changed to the crease type you
specify in the Type drop-down list box. Defaults for these settings are in Startup defaults.

If the opposite line is within the perimeter of the design, it is also changed to a crease; if it is not,
the other sides of the rectangle are changed to creases. Be careful of this when using this feature in
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rectangular holes, as the specified line and the opposite line will both be inside the and thus will both
change to creases.
 

 

Once the offset of the opposite edge of the rectangle is set, ArtiosCAD constructs the rectangle. The
tool remains active to create another rectangle from the one just created.

Note:

The change of the line type depends on whether or not the line is inside the design at the
time when the rectangle was created; it will not change depending on the geometry when you
rebuild. For example, if you make a flap with offset 4 and the line is changed to crease, if you
then rebuild with -4 or 0 the line will still be a crease even though it is no longer supposed to be.

Geometry Macro mode
When you click the drop-down list box that always defaults to Rectangle from a line, ArtiosCAD opens a
catalog of geometry macros. These geometry macros are all of type Panel from a line. The names are in
English only.
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Hover over a catalog entry to see a pop-up preview of the geometry it makes.
 

 
If you choose a geometry macro, ArtiosCAD makes Use crease type and the line type selector
unavailable.

Using a Geometry Macro

1. Click the geometry macro to use. In this case, use a Friction Flap.
2. Click the line to base it on.

 

 
3. Use drag to set its size and click to set the offset. ArtiosCAD determines which orientation to use

for the drag by which end of the line you clicked closer to.
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If you move the mouse toward the opposite end, ArtiosCAD flips the drag lines.
 

 
4. The variables for the geometry macro will appear in the Geometry Macro Variables dialog box. If the

first menu of variables only contains L and H, ArtiosCAD skips it and starts with the second one.
If you do see L and H, L is unavailable and is always the length of the line you clicked, and H is the
value you set with drag. Set the variables as desired. ArtiosCAD updates the drag immediately as
you change variables. Click Next> to go to the next menu, or click OK to finish.
 

925



12 ArtiosCAD

 
5. ArtiosCAD replaces the line with the result of the geometry macro.

 

 
6. The tool remains active with the same geometry macro, prompting you to select another line to

extend. If you exit the tool and restart it, ArtiosCAD remembers the last-used geometry macro and
selects it.

ArtiosCAD checks the geometry macro before it runs it. L must be defined and L and H must be
distance or angle/offset variables. There also must be room in the design for the layers from the
geometry macro if Move lines to layers is enabled in its catalog entry in Defaults.

If you use the same geometry macro repeatedly and its L and H match the last ones used, ArtiosCAD
will use the same variable values for the other variables. If L and H do not match, ArtiosCAD reinitializes
all variables to their default values. If ArtiosCAD keeps the variables, it compares them to the first run's
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values and records them with the first run's expressions if they match. The allows all copies of this
geometry macro to rebuild based upon the same formula.

ArtiosCAD embeds the geometry macro in the workspace for portability between systems.

If you are working with consecutive Seal End 4 and Seal Tuck 4 geometry macros that need to be the
same size to align properly, in the first one, copy variable S6, the slit length, using Copy Variable in the
Geometry Macro Variables dialog box. Then in the next geometry macro, type S6 for the slit length. The
same is applicable to the Seal End 5 and Seal Tuck 5 geometry macros with a hairpin curve between
them. Copy Hairpin Depth H1 and Hairpin Radius R1 from one to the next so they align properly.

When working with Panel from Line geometry macros, do not do a double line removal until after you
are done constructing the design and have added dimensions if desired. This avoids the potential for
lines not existing after a rebuild.

Tips for Creating Your Own Panel from Line Geometry Macros
The following guidelines apply when you create your own Panel from Line geometry macros.

• Create L, H, and any other variables before you begin construction. L is always the length of the
macro and H is the height.

• Put L and H in the first menu alone so you can reference them in subsequent menus.

• Always start at the origin and design up and to the right. ArtiosCAD will automatically rotate the
geometry as needed when running the geometry macro.

• Draw the base line of the geometry using L for the size along the X axis. Design the height to use H
along the Y axis.

• The board code you select for the workspace does not matter.

• Use delete under line types to trim nearby lines but use them sparingly if you intend to rebuild the
destination design after running the geometry macro.

• Use Edit Expression to make a Units branch for static values – such as UNITS(1.5,1/16) so that the
geometry macro works well in both systems of measurement.

• In Defaults, add your geometry macro to the Geometry Macro catalog using type Panel from Line.
Check Use in design and deselect Use in manufacturing. If your geometry macro has dimensions,
check Move lines to layers to move them to the Dimensions layer after you run the geometry macro.

Using Panel from Line Geometry Macros to Make a Design
It is possible to construct an entire design using Panel from Line geometry macros.

1. Create a new design.
2.

 Use Rectangle Horiz/Vert to make a rectangle with dimensions W and D, defining them on the
fly. Start the rectangle at the origin and drag it up and to the right. In this example, W is 2 and D is 6.
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3.

 Use Panel from Line in Rectangle from a line mode to make three additional panels of size L,
W, and L. Set L to 2. Check Use crease type and set the drop-down list box to Crease.
 

 
4.

 Use Panel from Line with the Slit Lock Tuck geometry macro to make a tuck from the top of
the second panel. Set the Offset to W.
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5. Click OK to accept its variables.
6.

 Use Conline Division/Midpoint to make a construction line halfway up the tuck flap, using the
Dynamic Drafting point at the corner of the flap blend as one end and the bottom of the flap as the
other.
 

 
7.

 Use Panel from Line with the Slit Lock Side Flap geometry macro to make the flap, and snap
its height to the conline intersection with the side of the tuck. Make sure to drag close to the tuck
so that the flap is oriented properly.
 

 
8. Click OK to accept its variables.
9. Add the other tuck and flaps in the same way, using the Slit Lock Side Flap with Notch for the last

one. Pick a point on the left side to have the notch on the left.
 

929



12 ArtiosCAD

 
10.

 Use Panel from Line with the Glue Flap geometry macro to add the glue flap.
11. Click OK to accept its variables.
12.

 Use Stretch by Polygon to shrink the first panel's size by 1/32" or 1 mm for the glue flap
reduction. The design is now complete.
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Offset Line

 The fourth button on the Rectangle flyout toolbar activates the Offset Line tool. Use this tool to
offset a parallel copy of a line from another. To use this tool, click it, click the line to copy, and then
indicate the offset using drag.

Straight-curve and Curve-straight

The fifth button on the Geometry toolbar activates the Straight-Curve tool, and when held down,
activates the Straight-Curve flyout toolbar. A straight curve is a straight line with an arc attached at
the end. A curve straight is an arc with a straight line attached at the end.
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In the picture below, item A is a straight curve. Item 1 indicates the start of the straight curve. Item 2
shows the drawing direction. Item B is a curve straight, and item 3 is the start of the curve straight.

The first button on the Straight-Curve flyout toolbar, and the default Straight-Curve button on the
Geometry toolbar, is the Straight-Curve tool. To make a Straight-Curve, do the following:

1. Click the Straight-Curve tool on the Geometry toolbar.
2. Set the X and Y offsets of the end-point of the Straight-Curve.

3. Set the Start Angle of the straight portion of the Straight-Curve.
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4. Set the radius of the Curve portion of the Straight-Curve with the drag.

5. Once ArtiosCAD knows 4 of the 5 pieces of information in the Status bar, it constructs the Straight-
Curve.

The second button the Straight-Curve flyout toolbar is the Curve-Straight tool. It works the same way
as the Straight-Curve tool, but the arc is made at the beginning of the line, not the end.

Line Join tools

 The sixth button on the Geometry toolbar activates the Line Join tool, and when held down,
activates the Line Join tools flyout toolbar.
 

 

This tool joins two points, two circles, or a point and a circle with a straight line. It also works with
construction line circles.

To use this tool, click it, indicate the first point, arc, or circle, and then indicate the second point, arc,
or circle. When one of the objects being joined is a circle, the line is made tangent to the circle.

If you click an arc or a circle as the first object, to make a line tangent to that arc or circle, use the drag
to set the angle and then either set the length or set the X and Y prompts for the end-point of the line. If
you click close enough to a line or arc, it will snap to that line or arc.

 The second button on the Line Join tools flyout toolbar activates the Arc Join tool. As its name
implies, it joins a point, line, arc, or circle to another point, line, arc, or circle with an arc. If two lines are
being joined, they cannot be parallel. To use this tool, click it, indicate the first object to join, then the
second object to join, and then finally the radius of the arc used to join the two objects. Depending on
the points chosen, it is possible that the arc joining the two objects will intersect them.

Depending on how you set the drag, the points at which the arc joins the two objects could be different.
The same happens when two circles are joined together with an arc – the points of tangency switch
depending on the radius of the arc.
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 The third button on the Line Join tools flyout toolbar is the Tangent Arc tool. This tool makes an
arc tangent to three lines. To use this tool, click it, and then indicate the three lines to which the arc is
to be tangent.

Line at Angle to a Line tool

 The seventh button on the Geometry toolbar activates the Line at Angle to a Line tool. This tool
draws a line at the desired angle from the current position. To use it. click it, select a line or arc to
measure the angle from, and then use the drag to make a line at the desired angle.

Beziers

 The eighth button on the Geometry toolbar activates the Bezier tool. A bezier, also called a French
curve, is a curve defined by four points: the start point, the endpoint, and two control points.

Freehand coordinates in the Snap Options dialog box must be checked for this tool to function. Click
Options > Snap and then look in the Snap to Point group. If you see an error message in the Status bar
Cannot select coord when trying to use this tool, Freehand coordinates is turned off and you
must turn it on.

To make a bezier, do the following:

1.
 Click the Bezier tool on the Geometry toolbar.

2. The bezier will begin at the current position. Click the desired position for the endpoint.
3. Use the drag to set the position of the first control point. In the example below, the first control

point is at the top of the left dashed line.

4. Use drag to set the position of the second control point. In the example below, the second control
point is at the bottom of the right dashed line.

934



12ArtiosCAD

5. ArtiosCAD constructs the bezier once the second control point is set.

Changing Beziers to Arcs
Use Change Beziers to Arcs to change beziers to arcs. This tool uses the current selection if there is
one; otherwise, it applies to all beziers in the workspace.

1. Use the Select tool to select any particular beziers to change. If you want to change them all, do not
select anything. Shown below is a bezier before changing it to arcs with Direction turned on in the
View Mode.
 

 
2. Click Tools > Adjust Outline > Change Beziers to Arcs.
3. In the Convert Beziers to Arcs dialog box, enter a fit tolerance and click OK. A smaller fit tolerance

results in more arcs and greater accuracy.
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4. ArtiosCAD performs the change. Shown below is the former bezier as a series of arcs.

 

 

Drafting aids

ArtiosCAD provides three sets of tools to help create geometry – Dynamic Drafting, construction lines,
and extensions. Dynamic Drafting finds alignment points in surrounding geometry; see Chapter 1
for more information. Construction lines create non-manufacturable geometry. Extensions extend
existing lines into infinity and existing arcs into circles.

Construction lines

Construction lines are special lines used as drafting aids. They are not considered geometry, but they
are used to make geometry.

How and when to use construction lines
Use construction lines when you want to reference points that are not part of the geometry of a design.
For example, if you want to go to a point that is a third of the way down a line, an easy way to do this
is to divide the line in thirds using the Conline Division/Midpoint tool. Once the construction lines
intersect with the actual line, you can move the current position to one of those intersections.

Construction lines also help when constructing rebuildable designs by providing points of reference.
For instance, suppose you have imported a DDES file and want to make it rebuildable. When building a
flap, the angle at which the flap is cut back varies with the width of the flap. You can use a construction
line drawn over the side of the flap to “remember” the angle of the flap line. Then when you move the
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corner point, you can place it directly on the construction line, and the original angle is duplicated
perfectly.

Creating construction lines is accomplished by using the tools on the Conlines toolbar, or the command
on the Conlines submenu of the Tools menu.
 

 

Conline Offset/Angle tool

 The first button on the Conlines toolbar is the Conline Offset/Angle tool. When activated, this
tool prompts you to select a point or a line. If you select a line, you are then prompted for the offset
between the line and the new construction line. If you select a point, you are prompted for the angle at
which the construction line will be created.

Conline At Angle From Line tool

 The second button on the Conlines toolbar activates the Conline At Angle From Line tool. When
activated, this tool prompts for a line to measure from and a point that the construction line will pass
through.
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In the picture shown above, the line used to measure from is the line at the bottom of the glue flap, and
the point passed through is the intersection of the bottom and side of the glue flap.

Conline Division tool

 The third button on the Conlines toolbar activates the Conline Division/Midpoint tool. When
activated, this tool prompts for the number of divisions and a line or arc to divide. Click the line, first
point of the line, or arc to divide, enter the number of divisions to make in the field on the Status bar,
and press Enter.

Note:  To divide an arc, click the arc itself, not its endpoints, else the arc will be treated as a
line and the dividing lines will be parallel instead of meeting at the center of the arc.

The default number of divisions is two. If you activate the tool and click a line or arc, it will
automatically be divided in two by a construction line. Note that the object being divided is not split; for
that, you must use the Split Line tool and click the points created by the construction lines.

The number of construction lines created by this tool will be one less than the number specified in the
Number of Divisions field.

Shown below is an arc divided into four segments by three divisions.
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Conline Radius tool

 The fourth button on the Conlines toolbar activates the Conline Radius tool. When activated, this
tool prompts you to indicate the center of the circle. As long as Freehand Coordinates is checked in
the Snap options dialog box, the center can be anywhere; it does not have to be on a point. Once you
have indicated the center, ArtiosCAD prompts for the radius, which you can set either with drag or
by typing in the Status bar. ArtiosCAD constructs a construction line circle once the radius has been
entered.

Conline Angle Divide tool

 The fifth button on the Conlines toolbar activates the Conline Angle Divide tool. This tool works
similarly to the Conline Division/Midpoint tool, but instead of dividing a line into line segments, it
divides an angle into smaller angles.

To use this tool, click it, enter the desired number of divisions, indicate one leg of the angle, and then
indicate the other leg. The tool will remain active once it has made the divisions.
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Conline Join tools

 The sixth button on the Conlines toolbar activates the Conline Join flyout toolbar.
 

 

 The first button on the Conline Join flyout toolbar, and the default Conline Join button on the
Geometry toolbar, is the Conline Join tool. This tool joins two points, two circles, or a point and a circle
with a straight construction line. To use this tool, click it, indicate the first point, arc, or circle, and then
indicate the second point, arc, or circle

Note:  When one of the objects being joined is a circle, the construction line is made tangent to
the circle.

 The second button on the Conline Join flyout toolbar activates the Conline Join With Concircle
tool. As its name implies, it joins a point, line, arc, or circle to another point, line, arc, or circle with a
construction line circle. If two lines are being joined, they cannot be parallel. To use this tool, click it,
indicate the first object to join, then the second object to join, and then finally the radius of the circle
used to join the two objects. Depending on the points chosen, it is possible that the construction line
circle joining the two objects will intersect them.
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Depending on how you set the drag, the points at which the construction line circle joins the two
objects could be different.

The same happens when two circles are joined together with a construction line circle – the points of
tangency switch depending on the radius of the construction line circle.

 The third button on the Conline Join flyout toolbar is the Conline Tangent Concircle tool. This tool
makes a circle tangent to three lines. To use this tool, click it, and then indicate the three lines to which
the circle is to be tangent.
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Changing construction lines

You may select construction lines with the Select Conlines tool  on the Select tools flyout toolbar,
or by using the normal Select tool with either of the construction line options on the Status bar.

Each plotting style contains three construction line definitions.

Double-click a construction line with the Select Conlines tool to change its type in its Properties dialog
box. To change the type of many construction lines at once, select them all and then press ALT-Enter
to open the Properties dialog box.

Shown below is a construction line before its type is changed and after its type is changed.
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Extend/Measure tools

The tools on the Extend/Measure toolbar work in conjunction with construction lines by making
geometry that is not manufactured.
 

 

 The first button on the Extend/Measure toolbar activates the Extend tool. The Extend tool extends
lines into infinity and arcs into circles. This is useful when you want to align objects with a line segment
or an arc because the extended geometry provides extra points.

To use the Extend tool, click it, and then indicate a line or an arc to extend. Normally the Extend tool is
a one-use tool and does not remain active after it extends the line or arc, but if you hold down SHIFT
as you click the first item, the tool remains active and you can click other items to extend. Make sure to
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continue holding down SHIFT for the tool to continue. Hold down CTRL to use the Extend tool ignoring
groups.

The points displayed using the Extend tool can be used as snap points and measure points.

If the cursor is over an item when the Extend tool is started using a keyboard shortcut, the item is
extended automatically.

When you use an extended point geometrically, such as creating a line to it or moving it, the extend
points are cleared after the tool completes.

 The second button on the Extend/Measure toolbar activates the Clear Extend tool. The Clear
Extend tool deletes all extensions. This is the only way to delete extensions.

 The third button on the Extend/Measure toolbar activates the Measure tool. In Measure mode, the
Measure tool displays pertinent measurements of arcs, lines, and the relationship between two points.
In Attributes mode, the Measure tool displays information about the object under the mouse cursor.
Change modes by selecting the appropriate button on the status bar, or by pressing Tab, or by using
the left and right arrow keys.

To use the Measure tool in measure mode, click it, and then click an arc, line, circle, or set of two points
to measure. Shown below are different types of measure tool information dialog boxes. To view just
pop-ups, hover over any desired object.
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Hold down CTRL while using this tool to measure between pixels. Move the mouse after selecting the
second pixel to see the snap. If you measure between pixels, you might have to refresh the view when
using high graphics mode.

Attributes mode shows various bits of information about the object under the mouse cursor such as
length, line type, pointage, the number and width of bridges and nicks, etc. Only geometric elements
can be viewed using the Measure tool.
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Click the mouse button to make the measurements remain on the screen. To close a single
measurement dialog box, click the Close button in its title bar. To delete all the measurement dialog
boxes, click Delete all measures on the status bar.

The Measure tool also functions as a tape measure. Click a point, and drag to another point; the
measurement is displayed. Click the second point to make the measurement stay on the screen.

To exit the Measure tool, click Exit Measure Tool on the status bar.

Changing geometry

You can change geometry in many ways once it is created. For instance, you can change the type or
thickness of rule used on the die, the location of a piece of geometry, and so forth. There are two
ways that geometry can be changed: linearly or physically. To change a piece of geometry’s linear
properties means you are changing an aspect of the geometry without moving it on the die. Types of
linear changes include the line type and pointage. Types of physical changes include moving geometry,
copying it, stretching it, rotating it, and mirroring it.

Use the commands on the Edit and Adjust toolbars shown below to change geometry.
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Select tools

The first button on the Edit toolbar activates the Select tool, and when held down, activates the Select
flyout toolbar.
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The Select tools are used to select objects so that they may be changed.

 The first button on the Select flyout toolbar, and the default Select button on the Edit toolbar,
activates the Select tool. Use this tool to select items in the drawing area – lines, text, dimensions,
graphics, and anything else.

You can use the Select tool to move items by selecting them and dragging them to the desired position
as long as the checkboxes for the objects you select are turned on in the Snap Options dialog box (click
Options > Snap).

You can resize and drag any item or group in the Dimensions, Overall Dimensions, Annotation, Print
Registration, Graphics, Full Graphics, Inside graphics, Label graphics, Doc plot layers with the Select
tool. This is not valid for Main Design or manufacturing layers to prevent accidental changes to
geometry.

To resize an item, click inside its bounding box and then drag one of the handle points to resize.
 

 
 

 
 

 

To move an item, click inside its bounding box and drag it to the new location.
 

 

Hold down the CTRL key while using the Select tool to make a copy of the item(s) selected. Release the
mouse button to put the copies down.

Hold down the SHIFT key to restrict the Select tool to vertical and/or horizontal movement only.

The Select tool has 17 modes of operation. The mode is selected by clicking the appropriate button on
the Status bar.
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 The first button indicates normal selection mode. This mode is the default mode and is how the
Select tool has worked in the past. When you select an item which is a member of a group, the entire
group is selected.

 The second button indicates that the Select tool will ignore groups. In this mode, if you select a
member of a group, only it is selected, not all members of the group. Do not use this mode to select fills
and strokes.

 The third button indicates that the Select tool will select connected lines, even if they pass
through intersections.

 The fourth button indicates that the Select tool will select connected lines, stopping at the first
intersection.

Whichever Select mode is selected in the first group of four buttons is remembered for this document
in the current ArtiosCAD session. These four modes are also on the More Select submenu of the Edit
menu, and may have associated shortcuts for single designs and canvases.

 The fifth button indicates that the Select tool will select only design lines.

 The sixth button indicates that the Select tool will select only design and construction lines.

 The seventh button indicates that the Select tool will select only construction lines.

 The eighth button indicates that the Select tool will select only text items.

 The ninth button indicates that the Select tool will select only dimensions. Note that if you change
the color of a dimension, it is considered graphics, not a dimension.

 The tenth button indicates that the Select tool will select only graphics.

For any of the above selection modes, if the objects being affected by the mode are turned off in the
current view, activating the Select tool in that mode turns the appropriate objects on in the View Mode.
For example, if dimensions are turned off in the View Mode, choosing the dimension-selecting mode
turns dimensions on in the View Mode.

 The eleventh button selects all items that are contained within or cross the selection rectangle or
polygon. This is the default mode.

 The twelfth button selects only those items with bounding boxes or clipping paths that are
completely contained within the selection rectangle or polygon.

 The thirteenth button lets you construct an irregularly-shaped polygon to select items. Click to
set the start point, and then drag and click to make sides of the polygon. To delete the last side of the
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polygon, click Undo  next to the tool. To complete the polygon, join the end of the last side to the
start point.

 The fourteenth button selects all visible objects that would be selected using the current Select
mode set by buttons five through ten.

 The fifteenth button turns on Nudge with stretch mode. More information about using nudge
mode appears later in this section.

 The sixteenth button turns on Nudge by a fixed value mode.

 The seventeenth button turns on Nudge in a direction specified by a line mode.

You can activate more than one Nudge mode at a time by clicking the mode buttons as desired.

Select Conlines tool

 The second button on the Select flyout toolbar activates the Select Conlines tool. Use this tool to
select construction lines.

Select by Example tool

 The second button on the Edit toolbar activates the Select by Example tool. Use this tool to select
items with the properties you define in the Select by Example dialog box.

Once you have selected the attributes of the items to be selected, click Apply to see the results of your
selection, or click OK to select the objects and dismiss the dialog box. When the items are selected,
double-click them while still holding down SHIFT or CTRL to change their properties (or press ALT-
Enter). You can also use any of the Edit tools.
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Select All tool
The Select All tool is on the Edit menu. It selects everything in all visible layers; the items turn magenta
to show they are selected. The Select All tool does not select items in layers that are not turned on.

To use this tool, click Edit > Select All.
 

 

Nudge mode in the Select tool
To nudge is to move by a very small distance. Nudging is available in the Select, Select by Example,
Select Conlines, Select Oneups and Select Periphery Lines tools.

There are 3 nudge modes - Nudge with Stretch, Nudge by a Fixed Value, and Nudge in Direction
Specified by a Line. These modes allow you to nudge or stretch the selected geometry or text by very
small increments using the arrow keys along with CTRL and SHIFT. ArtiosCAD shows the distance last
stretched or nudged as feedback on the Status bar.

The modes may be combined as desired - they are not mutually exclusive. Each mode is explained in
further detail in the following sections.
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Note:

Regarding Undo and Redo, nudges are consolidated into one action. If you nudge too far, nudge
back instead of using Undo. When using Nudge in Direction Specified by a Line, nudges in a
direction are grouped together into one Undo action.

Default nudge distances
The table below shows how to move different distances in nudge mode. These are the default
distances and can be customized as desired either system-wide in Startup Defaults or on a per-session
basis by clicking Options > Nudge.

Press To move in mm To move in inches

Arrow key 1 1/16

CTRL-arrow key 5 1/2

SHIFT-arrow key 1/2 1/32

CTRL-SHIFT-arrow key 10 1

Nudge with Stretch

 The Nudge by Stretch mode works with a rectangle selection window. Items fully inside the
selection rectangle are moved, while items crossing the border of the selection rectangle are
stretched. Note that other Select tool controls affect what is selected when using a window to select
items.

To use this mode, do the following:

1.
 Start the Select tool in an open single design or manufacturing file.

2.
 Click the Nudge with stretch button on the Status bar.

3. Click and drag a rectangle selection window around the items to nudge.
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4. Use a combination of CTRL, SHIFT, and the arrow keys to nudge the selection in the desired

direction. Arcs and beziers are always stretched using the distance option (as opposed to angle or
radius).

5. The items remain selected for you to continue to adjust.

Shown below is the nudged glue flap with the nudge exaggerated for effect.
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Note:

Nudge with Stretch will not move or stretch images, and will only move (not stretch) text items.

Note:

Nudge with Stretch cannot be used immediately after an Undo or Redo, as Undo and Redo clear
the current selection and restart the Select tool.

Note:

 When Nudge with Stretch cannot be used, such as when the Select tool is restarted while
there is a current selection, a do-not-use symbol (circle with a slash through it) appears on its
button and the nudge will move the selection rather than stretching it.

Note:

This mode is not available in the Select Conline, Select by Example, and Select Oneup tools.
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Nudge by a Fixed Value

 The Nudge by a Fixed Value mode works with the current selection and moves the selected items
by a fixed distance depending on the keys you press. It is similar to the nudge functionality in previous
versions of ArtiosCAD. Refer to the Default nudge distances section for more information on distances
and modifier keys.

To use this mode, do the following:

1.
 Start the Select tool in an open single design or manufacturing file.

2. Select the items to nudge.
3.

 Click the Nudge by a Fixed Value mode selector on the Status bar. If you hover over the button,
ArtiosCAD shows the current nudge distances in a message on the Status bar.

4. Use a combination of CTRL, SHIFT, and the arrow keys to nudge the selection in the desired
direction. Arcs and beziers are always stretched using the distance option (as opposed to angle or
radius).

5. The items remain selected for you to continue to adjust.

Nudge in Direction Specified by a Line

 The Nudge in Direction Specified by a Line mode nudges the current selection in a direction at
90 degrees (or a multiplier of 90 degrees) to a line. When you hover over a line in this mode, the drag
changes to a four-direction display of arrows with a large arrow indicating the nudge direction of the up
arrow key.

To use this mode, do the following:

1.
 Start the Select tool in an open single design or manufacturing file.

2. Select the items to nudge.
3.

 Click the Nudge in Direction Specified by a Line mode selector on the Status bar.
4. Hover over the line to use to set the direction of the nudge. The drag will change to 4 arrows as

shown below.
 

 
5. Use a combination of CTRL, SHIFT, and the arrow keys to nudge the selection in the desired

direction. Arcs and beziers are always stretched using the distance option (as opposed to angle or
radius).
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6. The items remain selected for you to continue to adjust.

Note:

This nudge mode always uses the current angle of a line. Unanticipated results might occur
when you use this tool on a parametric line in a resizable design.

Nudge Options and Defaults
Click Options > Nudge to set the active nudge modes per session and the distances they use. This
command is available when a single design or a manufacturing file is open. Essentially the same dialog
box is used in Defaults in Startup defaults > Nudge options.

Shown below is the Nudge options dialog box.
 

 

Show nudge options in select tool controls the availability of the nudge modes. When it is selected,
they are active. When it is cleared, nudge moves by a pixel.

Set the three mode selectors as desired. They determine which nudge modes are active when a tool
which supports nudge is started.

The values in the Fixed values group control the distance used by the Nudge by a Fixed Value mode.
Set them as desired.
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Note:

If you change the nudge options or Defaults while a Select tool is active, the tool will be
restarted to update it and the current selection will be lost.

Changing linear properties

Linear properties are those properties of objects that are not related to their physical placement.

Changing line type and pointage
To change the line type and pointage, activate the Select tool and double-click the object to change. To
select more than one object at a time, hold down SHIFT while selecting objects, and double-click the
last object. The Properties dialog box will appear.
 

 

On the Geometry tab of the Properties dialog box, you can change the type of a line, its pointage, and
its subtype. You can change other properties on additional tabs if they are available.
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Lines which are already used in the workspace are listed in the Type: group. Clicking Others... in the
Type: group opens the Set Current Line Type dialog box, which lets you change to a line type which is
not listed in the Type: group, but you can do the same thing using one of the other panes in the dialog
box.

If the name of the line type contains Inside or Outside, use it in a corresponding Inside or Outside layer
class. Inside types and classes are used on the unprinted side of a design, while Outside types and
classes are used on the printed side.

Note:

If you are using one of the Generic v-notch line types meant for use with the variable angle tool
on a Kongsberg samplemaker in conjunction with iPC, the Pointage field changes to an Angle
field. Set an angle from 0 to 60 degrees in steps of 0.5 degrees.

If your selection contains multiple lines, they must all be the same type of Generic v-notch for
the Angle field to be available.

The Bridging tab is unavailable when using Generic v-notch line types.

Generic v-notch line types are not supported for use by the Rule Path tool if they are in
embedded designs in Manufacturing workspaces.

Once you have chosen a new line type in this dialog box, click OK to set it, or Cancel to ignore your
selection. Either click will return to the Properties dialog box.

After making the desired property changes, click OK to apply the changes or Cancel to discard them.
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Foldable line type properties in Single Design
The 3D tab in the Properties dialog box in Single Design lets you choose how the current selection
behaves in 3D. Foldable lines are:

• Crease
• Second-height crease
• Matrix crease
• Reverse crease
• Partial cut
• Reverse partial cut
• Perf
• Cut-crease
• Partial cut-crease.
• Nicked cut lines (that behave like perf).

When you double-click one of these types of lines, set the how the line will behave in 3D on the 3D tab
of the Properties dialog box.
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Normal creases fold or bend in 3D as they should.

Knock-down creases are creases that are only used for shipping the carton, and are not part of the
structural integrity of the carton. They are shown as indentations in 3D.

Cuts / broken creases appear and function as cuts. These are used where creases meet at a point
and ArtiosCAD does not know how to set all the fold angles correctly so that they meet. In the example
below, set one of the three creases at the corner to be a broken crease.
 

 

Tears are creases, special rules, or nicked lines that tear. If you have a shape in a panel that is nicked, it
shows as indented.
 

 
Then use Select Tear-Away Part in 3D to select it and Move Designs to tear it away.
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Tear and fold special rules both tear and fold. Note that curved creases can either tear or fold, but not
both.

Indent only perfs make an indentation on the panel but do not fold or tear.

You may also set or change the Fold angle of this line in 3D in this dialog box.

Click OK to change the properties of the line and return to ArtiosCAD.

Notes about special rules
Special rules are rules which have specific manufacturing attributes, such as 5mm Zig Zag Left rules or
½ inch Echelon Right rules. Their definition is explained in more detail in the Defaults chapter.

Different special rules are treated as one rule on output if they are end to end, and there are no end
points of other lines within 1/32 inch of the join, and the lines are within 18 degrees of tangential at the
join.

To treat such special rules as separate lines, split any lines that intersect them at the intersection
point.

The Expand Special Rules command on the Tools > Adjust menu separates connected special rules
into individual lines and arcs.

You can rename a special rule by clicking Rename on the Special rules tab of the Properties dialog box.
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When a design containing the same name for differently-defined special rules is opened, the duplicate
special rule name will be changed to COPY<number> of <special rule name>, such as Copy1 of 3mm x
3mm perf.

If you change one of the relevant dimensions of a V-notch special rule, ArtiosCAD prompts you to either
create a new rule with the new properties, or convert it to a generic V-notch line type.

Changing Bridging properties
Shown below is the Bridging tab in the Properties dialog box when geometry is selected in Single
Design. It shows information not only for bridges, but also for nicks and crease cutbacks. The contents
vary depending on the geometry you have selected.
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963



12 ArtiosCAD

 

Number and position of bridges

The Bridge position type drop down list box displays the following choices for automatic bridging:

No bridges removes all automatically-placed bridges from the selected geometry.

Evenly spaced positions up to 100 bridges evenly along a line.

Inset distance from line end specifies the distance of a pair of bridges from each end of the line. If the
line requires more than two bridges, they are evenly spaced between the two inset bridges.

Specify bridge positions shows the position of up to 100 pre-existing bridges on a line.
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Default bridges regenerates the bridges of the selected geometry based on the current default
bridging formula.

Default with at least 1 is used in the construction of a standard when the size of the line in the final
design is not known but requires at least one bridge.

Select bridge formula lets you choose the bridging formula to apply to the selected geometry. The
current bridging formula is selected by default.

Bridge at rule start adds a bridge at the start of each selected line and removes all other bridges in the
selected geometry.

Bridge at rule end adds a bridge at the end of each selected piece of geometry and deletes all the other
bridges in the selected geometry.

Bridge at both ends places a bridge at both ends of each line in the selected geometry.

Bridge at rule start, Bridge at rule end, and Bridge at both ends places one or two bridges at the half
bridge with from either end of the line. That is, ArtiosCAD indents a half bridge width from the end of
the line and then places the bridge.

Changing the number of bridges

The Number of bridges: field and drop-down list box let you manually specify the number of bridges to
assign to the selected geometry.

You can also type an integer in the field if the desired value is not shown.

Changing the width of bridges

The Width of bridges: field and drop-down list box shows the width of bridges in the currently-selected
geometry and allows the selection of a new width.
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The Default width is the width defined by the current bridging formula. The other choices on the list
are the widths of other bridges in the design. You may type a new bridge width in the field.

If a line needs to have bridges of different widths on it, simply add bridges of another size.

Note:  If you use two or more different bridge sizes on the same line and will be sending
this workspace to someone using a pre-12.1 version of ArtiosCAD, you must export it as an
ArtiosCAD 12.x workspace using File > Export > ArtiosCAD 12.x.

Changing the bridging for arc corners

The Corner type drop-down list box controls the behavior of bridging in corners made by an arc. Corner
Off specifies that the arc is unaffected. Corner On specifies that the corner will be squared and cut by
an additional line.

Shown below is an arc with Corner Off, and below that is Corner On.
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Changing the current bridging formula

To change the current bridging formula, click Options > Change Bridge Formula.

 Blend tool

 A blend is an arc connecting two lines. Blends are used to round corners. They can be used on any
non-parallel lines - if the lines don’t share an endpoint, they will both be extended to a point where they
can be blended. The Blend tool is the first button on the Adjust toolbar. It prompts for the radius of the
blend, and then prompts you to click the two lines forming the corner to be rounded. Corners can be
rounded as long as this tool is active.

Chamfer tool

 The Chamfer tool is the second button on the Blend tools flyout toolbar. Chamfers are bevelled
corners. The Blend tools flyout toolbar is shown below.
 

 

The Chamfer tool has three modes of operation, each controlled by a button on the Status bar. The
availability of the fields on the Status bar is controlled by the current mode selection button.

 The first button on the Status bar turns on Chamfer Equal Distances mode. This causes the
Chamfer tool to cut each line of the corner back the same distance and then connect them to form the
chamfer. To use the Chamfer tool in this mode, do the following:

1.
 Click the Chamfer tool. The Chamfer Equal Distance mode selection button is selected by

default.
2. Enter the length of the cutback in the Length along first line: field, for example ¼ inch or 6 mm.
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3. Click the first line that forms the corner to be chamfered. It will turn magenta to indicate it is
selected.

4. Click the second line that forms the corner to be chamfered. The chamfer will be made. Shown
below is a corner before creating a ¼ inch chamfer and then the same corner after chamfering.

 The second button on the Status bar turns on Chamfer 2 Distances mode. This causes the
Chamfer tool to cut each line of the corner back a different distance and then connect them to form the
chamfer. To use the Chamfer tool in this mode, do the following:

1.
  Click the Chamfer tool, and then click the Chamfer 2 Distances mode selection button on

the Status bar
2. Enter the length of the first line’s cutback in the Length along first line: field, and enter the amount

of cutback for the second line in the Length along second line: field, for example 12 mm for the
first and 9 mm for the second.

3. Click the first line that forms the corner to be chamfered. It will turn magenta to indicate it is
selected.

4. Click the second line forming the corner to be chamfered. The chamfer will be made. Shown below
is a chamfer 12 mm cut back on the first line and cut back 9 mm on the second.

 The third button on the Status bar turns on Chamfer Distance/Angle mode. This causes the
Chamfer tool to cut back a set distance along the first line of a corner and then make a line at the
specified angle to meet the second line of the corner, thereby creating the bevelled edge. To use the
Chamfer tool in this mode, do the following:
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1.
  Click the Chamfer tool, and then click the Chamfer Distance/Angle mode selection

button on the Status bar.
2. Enter the length of the first line’s cutback in the Length along first line: field, and enter the angle

for the chamfer in the Angle to first line: field, for example 12 mm for the cutback and 70 for the
angle.

3. Click the first line that forms the corner to be chamfered. It will turn magenta to show it is selected.
4. Click the second line forming the corner to be chamfered. The chamfer will be made. Shown below

is a chamfer 12 mm cut back and at 70 degrees.

Blend 3 Lines tool

 The Blend 3 Lines tool is the third button on the Blend tools flyout toolbar. Use it to blend 3 lines
or arcs together; the geometry does not have to touch. The middle line or arc is changed to a blend and
the end lines or arcs are shortened to meet the blend. ArtiosCAD determines the needed radii settings
automatically. If the lines or arcs are not able to be blended, ArtiosCAD displays a message that line
construction is not possible.

Shown below is an example of some geometry before it is blended:

Using the tool to select the arcs and lines to be blended:
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The third click creates the blend:

Split line at point

The second button on the Adjust toolbar activates the Split Line tool. This tool divides a line into
two lines anywhere along the line where you click the mouse. Activate the tool, click the line to split,
and then click the split point. The Direction view mode is automatically turned on when you select this
tool, and automatically turned off when you select a different tool. This tool behaves as if the Freehand
Coordinates checkbox in the Snap Options dialog box is turned on.

The picture below shows a circle after being split into 3 arcs. There are now 3 points and 3 direction
indicators.
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Trim/Extend tools

 The third button on the Adjust toolbar activates the Trim/Extend Two Lines tool, and when held
down, activates the Trim/Extend flyout toolbar.

 The first tool on the Trim/Extend flyout toolbar, and the default Trim/Extend tools button on the
Adjust toolbar, is the Trim/Extend Two Lines tool. It makes two lines that are not parallel extend to
meet each other. It also makes one line that intersects another end at the intersection. When clicked,
this tool prompts for the first line to extend, and then prompts for the second line to extend. Arcs may
be trimmed against as well.

An example of trimming two lines:

After using the Trim/Extend Two Lines tool:

When trimming two lines against each other, select the portions of the lines to keep.

An example of extending two lines:

After using the Trim/Extend Two Lines tool:

 The second tool on the Trim/Extend flyout toolbar activates the Trim/Extend One Line tool. This
tool works the same way as the Trim/Extend Two Lines tool, except it only trims or extends one line.
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 The third tool on the Trim/Extend flyout toolbar activates the Trim Interior tool. This tool trims
a segment of a line, arc, or bezier which intersects with at least one other item. It trims along the
item you click in both directions. If only one intersection is found, the item is trimmed back to that
intersection. If an intersection is found in both directions, the segment between the intersections is
deleted. The resulting lines are rebridged using the default bridging formula. This tool works for lines,
arcs, and beziers.

To use this tool, click it, and then click the segment to delete.

Shown below is a construction before using the Trim Interior tool.

The Trim Interior tool is used to remove the segment at the slot opening in the picture shown below.

 The fourth tool on the Trim/Extend flyout toolbar is the Trim Against Selection tool. This tool
trims or extends multiple lines against the current selection at the same time. You must select at least
one line, arc, or bezier before starting this tool. This selection is called the trim against selection.

This tool now has two modes: Limited mode and Full mode. The mode is determined by how the lines
trimmed against or extended to are connected. If the lines are connected so that there is a two-sided
path, the tool can operate in Full mode, and all commands on the Status bar are available:
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If the trim-against lines are not connected, or are connected or intersect in such a way that ArtiosCAD
cannot follow them and clearly identify which side is which, the tool operates in Limited mode, and no
commands on the Status bar are available. This functionality is equivalent to how the tool worked in
previous versions.

There are a few considerations to keep in mind when using this tool:

• Only lines and arcs are extended. Beziers cannot be extended because it takes more information
than is available to define their curves precisely.

• Items are trimmed to meet the trim against selection.
• The Reverse trim checkbox is available only when an item to be trimmed or extended crosses the

trim against selection.
• If an item cannot be trimmed or extended to meet the trim against selection, it is not deleted.
• Right-clicking the mouse stops the tool and resets the current selection.

To use the Trim Against Selection tool in Limited mode, do the following:

1.
 Use the Select tool to select the lines, arcs, or beziers to trim against.

2.
 Click Trim Against Selection. The message in the Status bar should indicate that the trim

against lines do not form one continuous path.
3. Click the object to trim on the part that you want to keep.
4. ArtiosCAD trims the object against the trim selection.

If you have selected a two-sided path of lines, arcs, or beziers, when you start the Trim Against
Selection tool, it starts in Full mode with the controls on the Status bar enabled.
 

 

The Offset: field lets you specify a distance from the trim against lines that the lines will be trimmed
back or extended past instead of being trimmed or extended flush with the trim against lines. When
you specify an Offset, a red path appears at the designated distance next to the trim-against lines
indicating where items will be trimmed or extended.

Reverse trim toggles the side of the selected the items to trim or extend. The parts to be kept are
highlighted magenta, while the parts to be trimmed are turned grey.

Note:

Reversing the trim does NOT change the offset, however! The selected items still meet the
same offset line. You must change the side on which you are selecting the items in order to
change the offset line they meet.

Trim performs the trim or extend.

When you start the tool, select the items to be trimmed or extended. Select multiple items by holding
down SHIFT while clicking, or you can make a window selection by clicking in empty space and
dragging the opposite corner of the rectangle; everything touching a border of the rectangle is
selected. Where you select objects determines which parts are kept. Where you release the mouse
button determines the position for all the selected items.

Shown below is an example of trimming lines inside a polygon with an offset.
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1.
 Use the Select tool to select the trim-against lines. These lines are connected and form a two-

sided path, so the Trim Against Selection tool can use Full mode.
 

 
2.

 Click Trim Against Selection.
3. Set an offset of 5 mm in the Offset: field on the Status bar.
4. Use a window selection to select the lines inside the polygon. Once the lines are selected, the red

offset border appears, the lines to be kept turn magenta, and the lines to be trimmed turn grey.
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5. Click Trim to trim the lines.

 

 
6. The tool remains active. Right-click the mouse to end it and see the result of trimming the lines.
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 Trim Against Selection, in Full mode, can also extend lines and arcs as well as trimming lines, arcs,
and beziers. Shown below is an example of how it can trim and extend arcs at the same time.

1. Shown below is the geometry before it is changed.
 

 
2.

 Use the Select tool to select the lines forming the polygon to be the trim-against lines.
3.

 Click Trim Against Selection.
4. Use a window to select all the arcs inside the polygon.
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5. The parts to be trimmed turn grey, and the parts to be extended turn magenta. Note how some arcs

stay the same; they are neither trimmed nor extended because before trimming, they do not touch
one of the trim-against lines, and after extending, they still would not touch one of the trim-against
lines.
 

 
6. Click Trim/Extend to trim and extend the arcs.
7. Right-click the mouse to end the tool and see the results.
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 The fifth tool on the Trim/Extend flyout toolbar is the Extend Line tool. This tool extends the
current line or arc by a given distance. Specify a negative length in order to trim the line or arc.

The following options are on the Status bar when this tool is active:

The X|Y option button extends the line or arc in either the X or Y axis depending on whether the
geometry is closer to being horizontal or closer to being vertical.

Length extends the object by the length in the Extend distance: field.

To use this tool, do the following:

1.
 Click the Extend Line tool.

2. On the Status bar, choose either the X|Y option or the Length option.
3. Enter a value in the Extend distance: field. (Enter a negative value to perform a trim.)
4. Click near the end of the item to change.
5. The item is extended or trimmed.

Note:  ArtiosCAD reduces the number of bridges on the object as needed if they do not fit.
If you specify a larger negative value than the length or radius of the line or arc, ArtiosCAD
creates a zero-length line or arc. You cannot extend a full circle by a positive value. Extending
an arc by a large positive value only extends it enough to form a full circle.
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Stretch point

 The Stretch Point tool on the Adjust toolbar moves a point and any lines, arcs, or beziers that use
that point as an endpoint. It can also adjust the end of a line when you activate the tool and click close
to the end of the line. Turning on End points in the View Mode dialog box makes this tool easier to use.

After selecting a point to stretch, ArtiosCAD prompts for the angle at which to move the point.

Then ArtiosCAD prompts for the distance to move the point. Use the pointer to align the drag with the
bottom point. The completed view of the moved point is shown below.
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To move the end of a line, use the following workflow:

1.
 Activate the Stretch Point tool and click close to the end of a line, but outside the snap

tolerance and not the endpoint itself (else the point will be stretched).

2. Drag the end of the line to its new location.
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3. Click to set the put-down point.

Stretch by Polygon

 The fifth button on the Adjust toolbar activates the Stretch by Polygon tool, which moves lines
while keeping them attached to connected lines, and is also used to move connected endpoints.
Stretch by Polygon works with lines, arcs, beziers, arrows, and distance dimensions (both temporary
and permanent). Use this tool by activating it, defining an area to stretch with a polygon, selecting
the point to stretch from (the reference point), selecting the point to use as a handle while stretching,
and then indicating the put-down point. The tool works by moving the lines or connected endpoints in
the direction you set, given the requirements to preserve angles or radii and the requirement to keep
common endpoints.

The stretch behaves differently depending on the option chosen in the drop-down list box on the
Status bar. The reference point and the pick-up point can be the same.

If one end of a line, arc, bezier, arrow, or dimension is selected, ArtiosCAD moves the selected end
and not the other. If both ends of an object are fully contained within the selection window, but its
endpoints are not connected to any other selection, the object is moved in the direction you specify.
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The Distance, Angle and Radius options in the drop-down list box on the Status bar modify the way
ArtiosCAD stretches lines, arcs and arrows that cross the selection window or polygon. Distance
preserves the distance between objects that are fully within the selection window or polygon. Angle
preserves the angle of lines and arcs that cross the selection window. Radius preserves the angles of
lines and the radii of arcs that cross the selection window or polygon. ArtiosCAD updates other lines
fully inside the selection window or polygon that connect to these as needed.

Note:  ArtiosCAD does not maintain angles when one end of a line is selected and this line is
perpendicular to the stretch direction, because preserving the angle is not possible in this
situation.

Note:

ArtiosCAD does not update radius and angle dimensions changed by this tool.

After the tool is activated, click in many locations to make a custom-shaped polygon to define the area
to stretch, or hold down the mouse button and drag a rectangular polygon.

ArtiosCAD stretches dimensions if one end or an extension line is within the selection window or
polygon and updates their values. Text is moved but not stretched.

This tool does not affect construction lines.

The default preservation option (Distance, Angle, or Radius) is set in Options > Defaults > Startup
defaults > Stretch by polygon options.

Shown below is a seal-end container that is not resizable. This tool can change the size of the flaps
while preserving their angles.

To change the size of the flaps, do the following:

1.
 Click Stretch by Polygon.

2. Click at the upper left of the design and drag a window to the lower right corner of the flap at the
right end, making sure to not select any of the creases.
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3. Select Angle in the drop-down list box on the Status bar.
4. Click the reference point. This is the point used as the anchor for the stretch. In this example, the

bottom left corner of the leftmost flap is the reference point.

5. Click the handle point. This is the point that you pick up to stretch.

6. Click to set the angle of the stretch.

7. Click to set the distance of the stretch.

8. ArtiosCAD stretches the lines and preserves their angles. Note how the top flaps are larger than the
bottom flaps.
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Follow

 The sixth button on the Adjust toolbar activates the Follow tool. This tool is used to trace existing
geometry and copy its outline. It is useful when making bleed outlines or when something needs to be
reduced or enlarged by a specific distance rather than a scale.

The Follow tool works by prompting for a start point. It then prompts for more points along the path to
be followed. The points do not need to be on the same line; the Follow tool will turn corners to reach the
point you indicate.

The first four buttons on the Status bar control how Follow reaches points.

 The first button, Follow Left, has the tool turn left at every intersection to reach the point
indicated.

 The second button, Follow Right, has the tool turn right at every intersection.

 The third button, Direct Path to Point, sends the tool directly to the point indicated

 The fourth button, Arc Path to Point, makes an arc from the current position through the through
point you indicate to the end point you indicate.

 The Offset: field is used to specify the distance away from the original lines
the path will be placed when complete.

  The fifth and sixth buttons control the offset of the new lines from the lines being followed. If
you are following in a counter-clockwise (anti-clockwise) direction, the first button offsets them to the
left or outside of the original lines (a negative offset) and the second button offsets them to the right
or inside of the original lines (a positive offset). If you are following in a clockwise direction, the first
button does a positive offset and the second button does a negative offset.

984



12ArtiosCAD

When selected, the Round Corner checkbox uses blends to connect lines instead of them meeting end-
to-end.

 The sixth button deletes the last path made.

OK accepts the path and leads to the Follow Properties dialog box where the properties for the new
lines are set. Make the desired selections and click OK to make the new lines.

Example of using the Follow tool

The Follow tool concepts may be dicult for new users to grasp. This handy example is meant to show
a particular situation in which the Follow tool makes life easier. The shape shown below needs to be
made larger by 12 millimeters all around.

To make the star cutout larger, do the following:

1. Click the Follow tool on the Adjust toolbar. The Follow Left button is on by default.
2. Indicate the start point (Point 1), the next point along the path (Point 2), and the end point for the

path (Point 3).
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3. Make sure the system is in metric mode by checking the state of the Units button on the View bar at
the top of the window. Enter 12 in the Offset field and click the Negative Offset button. A magenta
outline will appear of the followed shape.

4. In the Follow Properties dialog box, set the Type and Pointage and Bridging options to Copy from
the lines followed. Click OK. The cutout should now look like the picture below.

5. Delete the inner lines and the operation is complete.

Cloning Changes Using Auto-Repeat

 If your design has areas with congruent geometry, you can clone changes to lines, arc, and
beziers from one area to the others using Auto-Repeat. For example, you could change the radius on
the corner of one flap, and have ArtiosCAD clone that change to matching flaps. Or you could add a
crease to an ear and it would repeat to the congruent ears.

Auto-Repeat mode:
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• works with tools that edit geometry, not tools that change other items such as details or graphics,
and not with tools that affect the design as a whole (such as Bleed).

• does not copy lines that would overlap if copied
• does copy lines in areas that overlap, but without overlapping lines themselves, such as nested

bottle shapes
 

 

• updates more than one layer by placing changed or added lines into the same layer as they are in as
the primary auto-repeat area

• works with canvases but in one part at a time, meaning it works within the same part but does not
work across different parts.

Example of Using Auto-Repeat
This example shows how to use Auto-Repeat to change the size of some slots simultaneously by
changing only one slot.

1.
Use a Select tool to select the objects to change.

a) Select lines in the area you want to repeat. You can only edit these selected lines, regardless of
your ability to select lines later with tools like Stretch Point and Stretch by Polygon.
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b) Make sure to select more than one line so that ArtiosCAD does not have any ambiguity as to what
to rotate. One line looks identical at 180 degrees rotation.

c) Also make sure to select an asymmetrical construction so that ArtiosCAD mirrors it properly. In
the example below, the four cut lines of the upper slot are selected, along with the crease going
up toward the cut line.
 

 
d) Lastly, your selection should not contain lines that would overlap into another potential auto-

repeat area. Shown below is a primary area that has an extra cut selected on the left side that
prevents it from having an autorepeat area as shown.
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2.

 Click Show Auto-repeat Areas on the Stage bar or Edit > Auto-Repeat Areas. ArtiosCAD
enters auto-repeat mode and displays congruent areas to the one formed by the lines you selected.
ArtiosCAD shows the primary auto-repeat area (the one you selected) in blue, and the areas in which
it will repeat your changes in green (secondary areas). It also shades one corner of each area to
show the effect of rotation and mirroring.
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3.

 Auto-repeat mode is in selection mode where you pick the secondary areas to use.
Deactivate an auto-repeat area by clicking its edge; reactivate it by clicking its edge again.
Selection mode ends when you activate another tool.

4. Now you can make any desired changes in the primary area using standard workflows of selecting
items and adjusting them. You can only change those items you originally selected before entering
auto-repeat mode; ArtiosCAD dims all the other geometry.
a) You can use the Selection Ignoring Groups mode of the Select tool, but any new lines you create

will not be in a group. Only lines in the original selection will be available for selection.
b) If you want to trim or extend lines, if it's two lines, both must be in the original selection. If it's

one line, only the first line must be in the original selection as ArtiosCAD is not changing the
second line. If you want to trim against a selection, both lines must be in the original selection
for them to be available for selection in auto-repeat mode.

c) If you want to use an Edit tool, the Select tool is already active, so select the items and then
activate the tool. If you want to use an Adjust tool, you do not need to select the items first.

d) You can also add geometry in the primary area. It either has to overlap the primary area, or it
must be closer to the primary area than any of the secondary areas.

5.
 For this example, we will use Shrink by Polygon to make the slots slightly narrower. Click

Shrink by Polygon.
a) Click and drag a rectangle around the top cut, right cut, and bottom cut of the slot in the primary

auto-repeat area.
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b) Select the reference point of the middle of the left cut.
c) Select the handle point of the middle of the right cut.
d) Set the angle to 0.

 

 
e) Set the distance to 5/16 or another smaller number depending on the width of your slot.

 

 
f) ArtiosCAD makes the slot narrower.

 

 
6. ArtiosCAD repeats the change of the primary area to the secondary areas.
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Exit auto-repeat mode by clicking its button on the Stage bar or Edit > Auto-Repeat Areas.

Note:

If you Undo a command while in auto-repeat mode and then make a change such as adding or
removing a line, ArtiosCAD exits auto-repeat mode.

Preparing for Manufacturing

ArtiosCAD groups the tools for bleed, coating-free areas, bridging, nicking, and shortening creases for
steel counters on the Prepare for Manufacturing toolbar.
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Bleed tool

 Bleeds are used to define the area of ink bleed when the sheet moves through the printing press.
To use the Bleed tool, create the design that will have a Bleed outline, and click the Bleed tool. If you
are not in a Bleed Outline layer and there are none already created, you will be asked if you wish to
create one.

If you are not in a bleed layer and one already exists, you will be asked which layer to use:

Choose the layer to create, or choose the current layer, and click OK. The inside or outside layer type
option button is initially set according to the current side of the design.

A default bleed is automatically created, but you can modify it as desired as described below. The final
bleed is not created until you click OK on the Status bar.
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Click inside any panel to exclude it from the bleed. The right flap below is excluded from the bleed.

To change the distance between the bleed and the perimeter of the design, change the value in the
Offset field on the Status bar.
 

 

Clicking More Options (...) opens the Bleed Parameters dialog box.
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The checkboxes to the left of the optional offsets enable or disable them. If you enable the internal
offset, the Status bar changes to have External and Internal fields.
 

 

If you enable a separate coating offset, you can also set the Join tolerance to control the smoothness
of how the coating lines join the bleed lines.

In the Panel Tolerance group, Fix gaps up to and Extend creases up to tell ArtiosCAD to fix small gaps
up to the size indicated and to extend creases through gaps of up to the size indicated. This helps
the tool find panels when creases do not touch cuts or there is a small gap in a panel's periphery. The
defaults for these values are in Startup defaults > 3D Tools Options.

Use 3D flap overlap uses the flap information from Flap Priority and Update 2D in the 3D module to
determine the bleed outline.
 

 

995



12 ArtiosCAD

 Click the Undo button to undo a bleed action. Click OK to finish using the tool and create the final
bleed.

Coating Free Area tool

 The second tool on the Prepare for Manufacturing toolbar is the Coating Free Area tool. The
Coating Free Area tool defines panels on the box that will not receive a coating as the sheet passes
through the printing press.

As with the Bleed tool, when you click the Coating Free Area tool, if you are not in a layer of class
Coating, ArtiosCAD asks the kind to create, or to use the current one.

If a layer of class Coating already exists, the same layer-creation questions and dialog boxes appear
as for the Dimension tools. You are asked to add to an existing layer, or to create a new one. Select an
already-existing layer and click Add To, or click Create New to create a new coating layer.

Once the layer management is decided, the tool activates. Click the panels of the box to be coating-
free. The coating free area outlines will appear using the tolerances set in the fields on the Status bar.
The External field controls how far the outline extends from the perimeter of the design, while the
Internal field controls the distance from the outline to any internal lines in the panel.

 Click the Undo button to undo a varnish action. Click OK to finish using the tool.

996



12ArtiosCAD

Shown below is a picture of panels which are coating free areas.

Notes on the Bleed and Coating tools
You must click OK on the status bar when done indicating what to create. If you change the window
focus or select another tool, the tools are cancelled.

The tools only account for manufacturing line types in the Main Design, Manufacturing, and Windows
and Cutouts layers. Line types such as print image and annotation are ignored when using these tools.

If you make a mistakenly select a panel, click the Undo button on the Status bar or restart the tool.

Defaults for these tools are contained in the single design parameter sets.

When you are in an inappropriate layer with automatic layer switching turned off and activate the
Coating Free Area tool, ArtiosCAD only displays option buttons for the first instance of each class of
coating layer. For example, if you have two Outside Coating1 layers in a print item, and activate the
Coating Free Area tool in the Main Design layer, ArtiosCAD prompts you to choose a coating layer. It
displays only the first coating layer in each class, so if you chose the Outside Coating1 layer, it would
distribute items to the first instance of the layer. To work in the second Outside Coating1 layer, change
to that layer before activating the tool so that you are not prompted to choose a coating layer.

Add Bridge tool

 The third tool on the Prepare for Manufacturing toolbar activates the Add Bridge tool.

ArtiosCAD automatically turns on the display of bridges in the View Mode when the Add Bridges tool is
activated. Bridges are also on the right-click context menu in Single Design.
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To add a bridge to a line, activate the Add Bridge tool, set the width of the bridge in the Bridge Width:
field in the Status bar, and click the location of the center point of the new bridge.

The value entered in the Bridge Width: field will be the default value for the current session of
ArtiosCAD.

If you try to add a bridge that is a different size than other bridges on the line, the Different Bridge Sizes
dialog box appears. In it, you can choose to change the old bridges to the new size, to add a new bridge
using the old size, or to use both sizes. Choose the desired option and click OK to add the bridge, or
Cancel to return to Designer without adding the bridge.
 

 

Note:  If you change the nick size to a bigger size, some bridges may be removed to avoid
overlapping.

Note:  If you choose Use both sizes and will be sending this workspace to someone using a
pre-12.1 version of ArtiosCAD, you must export it as an ArtiosCAD 12.x workspace using File >
Export > ArtiosCAD 12.x.

Add Tack Bridge tool

 The fourth button on the Prepare for Manufacturing toolbar activates the Add Tack Bridge tool.

To use this tool to add a tack bridge to a wood edge line type, simply activate it and click the position
for the new tack bridge.

If size of the tack bridge differs from tack bridges already on the line, a warning dialog box will appear.
Choose the desired option and click OK to change the size of the tack bridges.
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To change the tack bridge formula, click Options > Change Tack Bridge formula and select the new
formula.

When a tack bridge is viewed in a Preview for an output that cuts or mills, the allowance for the tool
diameter will make it appear larger than it would for a laser output.

Add Nick tool

 The fifth button on the Prepare for Manufacturing toolbar activates the Add Nick tool. This tool
places a nick on the line that you select after activating the tool. By default, nicks appear as short lines
perpendicular to the selected line, but this can be configured in Defaults in the Nick Styles catalog.

When active, this tool has configuration options on the Status bar as shown below.
 

 

The Between nicks: field appears only when the value in the Number: field is 2 or greater.

The six buttons on the status bar control the placement of the nick.

 The first button offsets the nick by the distance specified in the Offset field from the start or end
of a line depending on which is closer to where you click.

 The second button places the nick at the center of the line clicked.

 The third button places the nick anywhere on the line you indicate. If you click within the snap
tolerance of a point such as an intersection with a construction line, the nick snaps to the intersection.

 The fourth button places the nick at the end of a line.
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 The fifth button fills the line with nicks. Each nick is separated from the others by the distance in
the Spacing: field.

 The sixth button fills a path with nicks. For more information about this aspect of the tool, see the
next section.

The Nick size control sets the size of the nick. Either specify a value in the field or select a value from
the drop-down list box.

The Offset control sets the distance used in conjunction with the Offset placement method.

This control changes to the Spacing control when the Fill Line or Fill Path placement method is
selected.

The Number control sets the number of nicks added when you click. A line may have up to 120 nicks.
Either type the desired number of nicks in the field or select the value from the drop-down list box.

When the Number control is set to more than 1, the Between nicks control appears. This control sets
the equidistant spacing between nicks. Either type the desired distance in the field or select the value
from the drop-down list box.

Nicks may move if they are added before removing double knives.

When making a multiple selection, the Properties page for that selection will now show nick controls
if any of the items selected have nicks. If you change nicking options, only those items already having
nicks change.

Note:  When using the default nick size, if you change the board in the Board Information dialog
box, and thus change the caliper, actual nick sizes are not updated unless the design is rebuilt.

As with bridges, if you try to add nicks to a line of a different size than nicks already along the line, the
Different Nick Sizes dialog box appears. Choose the desired option and click OK to add the nicks, or
click Cancel to return to Designer.
 

1000



12ArtiosCAD

 

Note:  If you choose Use both sizes and will be sending this workspace to someone using a
pre-12.1 version of ArtiosCAD, you must export it as an ArtiosCAD 12.x workspace using File >
Export > ArtiosCAD 12.x.

Filling a Path with Nicks

 Fill Path mode of the Add Nick tool is available only in Single Design because of the double knife
removal and embedded designs considerations in Manufacturing. For this tool, a path is a sequence
of lines of the same pointage and type with common end-points. You can define the path beforehand
using the Group Sequence tool, or you can select the path while using the tool by selecting the first line
in the path and then the last line in the path. If the path has any intersecting or meeting cuts, define the
path beforehand.

When this mode is active, the Status bar has three additional controls for more options for adding
nicks, the number of sets with which to fill the path, and the distance between the sets of nicks.
 

 

Clicking More options (...) opens the Add Nick Options dialog box.
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Centered keeps the nicks centered on the line and Offset defines the distance from the beginning
of the line (and the end when Centered is checked). To enable a different offset at the end of the line,
deselect Centered to make Offset from end available.

When there are corners, ArtiosCAD fits sets of nicks as best it can using the between nicks distance
or number of nicks you specified.Split at corners keeps nicks away from corners by the amount
specified in Corner offset. If a blend is larger than the Minimum radius, ArtiosCAD considers it a
corner. Note that the distance between nick sets will not be exactly the same on each segment of the
path comprising the corner.

Avoid End Points keeps the nicks from being on the shared end-point of two lines.

Note:  If you rebuild a resizable design so that this path changes length, the distance between
the nicks will be the same but the number of nicks will change.

To use this mode, do the following:

1. Make sure the desired path is all the same line type and pointage. If the path has any meeting or
intersecting lines, use the Group Sequence tool on it first.

2.
  Click Add Nick and select the Fill Path mode on the status bar.

3. Click the start of the path. ArtiosCAD places nicks on this line.
4. Click the end of the path. ArtiosCAD fills the path with nicks.
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5. Adjust the fields on the Status bar as desired for the offset, number of nicks, distance between
nicks, number of nick sets, or the distance between nick sets. They will change accordingly.

Delete Bridge tool

 The sixth button on the Prepare for Manufacturing toolbar activates the Delete Bridge tool. When
this tool is clicked, bridges are turned on in the View Mode if they are not on already.

To delete a bridge, click this tool, and then click the bridge to delete.

To delete many bridges, click this tool, and then click and drag to do a marquee selection around the
bridges to delete. ArtiosCAD deletes the bridges when you release the mouse button.

Move Bridge tool

 The seventh tool on the Prepare for Manufacturing toolbar activates the Move Bridge tool which
has these controls on the Status bar.
 

 

To move a bridge, click this tool and then:

1. Click the bridge to move.
2. Click the desired offset mode button on the Status bar.

• The first mode offsets the bridge from the current position.
• The second mode offsets the bridge from the start of the line.
• The third mode offsets the bridge from the end of the line.
• The fourth mode offsets the bridge from the midpoint of the line.

3. Use drag to set the new position, or enter a desired offset in the Offset field and press Enter.
 

 
4. ArtiosCAD moves the bridge.

Note:  If you plan on rebuilding this design, it would be more prudent to offset from the middle
of the line instead of an endpoint in case the rebuild uses smaller dimensions.

Note:  If you use this tool in Manufacturing, if Auto-Repeat is turned on, ArtiosCAD will also
move all congruent bridges.
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Conline Through Bridge tool

 The eighth button on the Prepare for Manufacturing toolbar activates the Conline Through Bridge
tool. This tool creates a construction line which passes through the center of a bridge. To use this tool,
click it, choose one of the placement options on the Status bar, and then click the bridge.

The placement options are:

• Perpendicular to the line, which creates a construction line at 90 degrees to the line, regardless of
the orientation of the line;

• Vertical, which creates a vertical construction line (parallel to the Y axis of the design);
• Horizontal, which creates a horizontal construction line (parallel to the X axis of the design).

Delete Nick tool

 The ninth button on the Prepare for Manufacturing toolbar activates the Delete Nicks tool. To
use this tool, click it, and the click the nick(s) to delete. This tool remains active until another tool is
selected.

To delete many nicks, click this tool, and then click and drag to do a marquee selection around the
nicks to delete. ArtiosCAD deletes the nicks when you release the mouse button.

Delete all nicks on a line at once by clicking Delete All Nicks on the Bridging tab of that line’s Properties
dialog box.

Move Nick tool

 The tenth button on the Prepare for Manufacturing toolbar activates the Move Nick tool which has
these controls on the Status bar.
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To move a nick, click this tool and then:

1. Click the nick to move.
2. Click the desired offset mode button on the Status bar.

• The first mode offsets the nick from the current position.
• The second mode offsets the nick from the start of the line.
• The third mode offsets the nick from the end of the line.
• The fourth mode offsets the nick from the midpoint of the line.

3. Use drag to set the new position, or enter a desired offset in the Offset field and press Enter.
 

 
4. ArtiosCAD moves the nick.

Note:  If you plan on rebuilding this design, it would be more prudent to offset from the middle
of the line instead of an endpoint in case the rebuild uses smaller dimensions.

Conline Through Nick tool

 The Conline Through Nick tool is the eleventh button on the Prepare for Manufacturing toolbar. It
places a construction line through a nick either perpendicular to the line containing the nick, vertical
through the nick, or horizontal through the nick depending on which option is selected on the Status
bar.

Changing nick properties
Once nicks have been added to a line, their size and the side of the line they are on can be modified by
accessing the Bridging tab of the Properties dialog box for that line. The Nicks group on the Bridging
tab appears only when a line contains nicks.
 

1005



12 ArtiosCAD

 

The Nick size: drop-down list box lets you choose a new size for all the nicks on the line. The Left
and Right option buttons in the Nick side: field set the side of the line the nicks are on. (Check the
Direction checkbox in the View Mode dialog box, and follow the direction of the line to determine which
is the left side and which is the right side.)

Delete All Nicks deletes all the nicks on the currently selected line(s).

Shorten Creases tool

 The twelfth button on the Prepare for Manufacturing toolbar activates the Shorten Creases
tool used for steel counters. It is available only in Single Design; if you turn on the Adjust toolbar in
Manufacturing, this tool will not be available, but you can use it in an embedded design (via Tools >
Adjust) and when you return to manufacturing, all instances of the embedded design are updated.
When you activate this tool, ArtiosCAD turns on Crease cutbacks in the View mode. Shown below are
its fields on the Status bar in Formula mode.
 

 

It has two modes:

•
 Formula mode lets you change all the creases at once. Use formula mode if you have not

yet created the counter. If you have already created the counter, use Create or Rebuild Counter
instead.
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•
 Drag mode lets you adjust an individual crease or channel end by clicking it and dragging it by

the desired distance.

To use Shorten Creases, do the following:

1. Make a single design as desired.
2.

 Click Shorten Creases.
3. Choose Formula or Drag mode on the Status bar.
4. For formula mode, select the objects to offset from, what to change, and the cutbacks (the amount

by which ArtiosCAD will shorten the creases).
a) Click More Options (...) to set more options for the tool. The cutback amounts are seeded from

any values you entered on the Status bar previously.
 

 
Click OK when you have set the options as desired to return to the tool.

b) Click Shorten All to shorten all the creases in the design.
5. For drag mode, select the objects to offset from and what to change, and then start clicking

creases and dragging them by the desired offset. If you choose to change Bridge or Top and Bridge,
ArtiosCAD turns on Bridges in the View mode.

Changing physical properties

Changing physical properties of objects means copying, rotating, moving, mirroring them, or making
any other change that affects their physical placement. The Edit toolbar and the Adjust toolbar contain
most of the commands used to change physical properties. Most tools on the Edit toolbar are disabled
until at least one item is selected.

Delete tool

 The Delete tool is the third tool on the Edit toolbar. Use this tool to remove unwanted elements
from your design. There must be a current selection for this tool to be available.
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When possible, use Undo rather than Delete.

If you delete something that you should not have deleted, use Undo to reverse the deletion.

Move To Layer tool

 The fourth button on the Edit toolbar activates the Move To Layer tool. At least one object must be
selected for this tool to be available.

This tool has two modes of operation - one for Single Design, and another for Manufacturing. For the
Manufacturing version of this tool, see the Manufacturing chapter.

To use this tool in Single Design, select at least one object, then click the tool. The Move To Layer dialog
box will appear.
 

 

The existing unlocked layers of the design are shown in the Destination Layer list. If the desired layer
is locked, cancel the tool, unlock the layer, and then reactivate the tool. If the layer into which you want
to move the item does not yet exist, click Create, and the Create Layer dialog box will appear. Enter the
name of the new layer, choose its class, and click OK to return to the Move To Layer dialog box.

To change the line type of the object(s) being moved, click Line Type and choose the new line type. You
may select any line type, but it will be checked for layer appropriateness upon clicking OK to return to
the Move to Layer dialog box. Click OK to return to the Move To Layer dialog box.

Once you have chosen the destination layer and have optionally changed the line type, click OK to move
the object(s) into the destination layer, or click Cancel to cancel the operation. When you click OK,
ArtiosCAD checks the layer appropriateness and warns if necessary, performs the move, and makes
the new layer the active layer.

Move tools

 The fifth button on the Edit toolbar activates the Move tool.
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Use this tool to move the current selection to a different location. There must be a current selection for
this tool to be available.

When clicked, the Move tool prompts for a pick-up point. This is the handle you want to use to move the
current selection – everything in the current selection is moved in reference to the pick-up point. Once
a pick-up point is selected, ArtiosCAD prompts for the put-down point. This is the point around which
the current selection is arranged identically to the way it was around the pick-up point. Use the fields
on the Status bar to choose the drag method.

Rotate tools

 The sixth button on the Edit toolbar activates the Rotate Right 90 tool, and when held down,
activates the Rotate flyout toolbar. If you click a point in any item while a Rotate tool is active, you can
move it using standard Move tool functionality.
 

 

 The first button on the Rotate flyout toolbar, and the default Rotate button on the Edit toolbar,
activates the Rotate Right 90 tool. This tool rotates the selected object 90 degrees clockwise around
its center. The Rotate Right 90 tool has no prompts; it works instantly.

 The second button on the Rotate flyout toolbar activates the Rotate Left 90 tool, which rotates
the current selection 90 degrees counterclockwise around its center.

Rotate Left 90 has no prompts; it is instantaneous.

 The third button on the Rotate Tools flyout toolbar activates the Rotate 180 tool. This tool rotates
the selected objects 180 degrees around the horizontal axis.

 The fourth button on the Rotate flyout toolbar activates the General Rotate tool. When activated,
this tool prompts for a fixed point around which to rotate the current selection and a handle point
(where the push is applied to perform the rotation).

Note:  The points you choose do not have to be in the object being rotated - they can be any
points in any part of the design.

The drag extend line goes through the fixed point and the handle point.
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Mirror tools

 The seventh button on the Edit toolbar activates the default Mirror tool, and when held down,
activates the Mirror flyout toolbar.
 

 

There are two types of tools on this flyout toolbar. Those with arrows in the icons perform a move on
the selection after mirroring it. Those without the arrows do not perform a move; rather, they mirror
the selection about its center without moving it.

To use a tool which does not perform a move, select the item(s) to mirror, and then click one of the
tools. The item will be mirrored in-place.

 The first button on the Mirror flyout toolbar activates the Mirror About Vertical tool; this tool
mirrors the selection about the Y axis and then performs a move.

 The second button on the Mirror flyout toolbar activates the Mirror about Horizontal tool. This
tool mirrors the selection about the X axis and then performs a move.

 The third button on the Mirror flyout toolbar activates the Vertical Mirror About Center tool.
This tool flips the current selection around on the Y axis.
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 The fourth button on the Mirror flyout toolbar activates the Horizontal Mirror About Center tool.
This tool flips the current selection around on the X axis.

 The fifth button on the Mirror flyout toolbar activates the Mirror About Line tool. This tool flips
the current selection around any line or construction line you indicate.

Scale tools

 The eighth button on the Edit toolbar activates the Scale Tools flyout toolbar.
 

 

 The first button on the Scale flyout toolbar, and the default Scale tool on the Edit toolbar, activates
the Scale tool.
 

 
The Scale tool prompts for a fixed point, prompts for a handle point, and then changes the size of the
current selection proportionally in all directions using the value you drag or type in the Scale field. To
set a specific offset (or size of the selected items), drag or type values in the X and Y fields.

Note:  If the handle point and the fixed point are both on the X or Y axis, the opposite X or Y
field is unavailable.

 The second button on the Scale flyout toolbar activates the Differential Scale tool. The
Differential Scale tool prompts for a fixed point and a handle point, but then lets you set the X scale and
the Y scale independently.

Copy tools

 The ninth button on the Edit toolbar activates the Copy tool, and when held down, activates the
Copy Tools flyout toolbar.
 

 

To use the Copy tool, do the following:

1. Select at least one object to copy with a Select tool.
2. Click the Copy tool.
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3. Click the pick-up point of the copy. This can be any point; it does not have to be part of the object(s)
being copied.

4. Click to set the put-down point, or set the values in the fields in the Status bar to the desired angle,
offsets, or distances. The copied objects will be oriented the same way in relationship to the put-
down point as they were to the pick-up point.

Distribute to Layers
The Distribute to Layers checkbox on the Status bar of most of the Copy tools controls whether the
copies of the items selected go into the same layers as the originals automatically or if they are placed
in the current layer.

If Distribute to Layers is deselected and some of the selected items have inappropriate line types for
the current layer, ArtiosCAD prompts you to select the desired action. Make the choice as desired and
click OK to perform the copy or Cancel to cancel it.
 

 

If an appropriate layer for the copy does not exist, a new appropriate layer is shown in green with New
next to its name, and it will be created when you click OK. If the appropriate layer exists but is locked,
its name is shown in red with must unlock first next to its name. You must cancel the copy and unlock
the layer in order to use it for the copy.

Do not show me this again, when checked, tells ArtiosCAD to use the action you select to answer
future instances in the same session and to not ask again.

This same dialog box appears when you use Copy and Paste on the Edit menu.
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If there are too many layers, a red warning appears saying the maximum number of layers has been
reached, and Distribute to layers becomes unavailable. The maximum number of layers is 250.

Layer distribution is available only with the tools in Single Design and canvases; it is not available with
the same tools in Manufacturing.

To set defaults for Distribute to Layers, click Options > Defaults > Design defaults > Distribute to
Layers. You may set whether the checkbox is selected or deselected by default, and to prompt if there
is an inappropriate layer or switch to an appropriate layer automatically. If you choose to automatically
switch, ArtiosCAD will use the Annotation layer class if no other is appropriate. If there is more than
one appropriate layer, ArtiosCAD will use the one that was created first.

Repeated Copy tool

 The second button on the Copy tools flyout toolbar activates the Repeated Copy tool when
clicked. This tool lets you make copies of selected objects repeatedly until you activate another tool.
This tool is available only when there is a current selection. When this tool is active, seven buttons
appear on the Status bar.

The two Placement buttons control the put-down points. The first button allows only a point (an
intersection between two lines, an endpoint of another line, and so forth) to be used as a put-down
point. The second button allows any coordinate to be used as a put-down point.

The first two Rotate buttons rotate the copy by 90 degrees - the first 90 degrees to the right; the
second, ninety degrees to the left. The third button rotates the copy by 180 degrees.

The two Mirror buttons mirror the copy vertically and horizontally, respectively.

There are no drag prompts in the Status bar to aid placing the copied objects. The copied objects can
be placed using the mouse only.
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Copy Rotate tools

 The tenth tool on the Edit toolbar activates the Copy Rotate Right 90 tool, and when held down,
activates the Copy Rotate tools flyout toolbar.
 

 

As with the other Copy tools, there must be a current selection for this tool to be available.

To use this tool, select the item(s) to be copied, and click the tool. The selected items will be copied
and rotated 90 degrees to the right using the center of the selected item(s) as the handle point.
Clicking the tool again makes another copy, but adds 90 degrees to the angle of the copy. Click the tool
once, and one copy is made at 90 degrees; click the tool again, and another copy is made, but this time
the copy is at 180 degrees from the original. Clicking the tool a third time results in another copy at 270
degrees, and clicking the tool a fourth time makes a copy at 360 (or 0) degrees.

 The second button on the Copy Rotate tools flyout toolbar activates the Copy Rotate Left 90 tool.
This tool works similarly to the Copy Rotate Right 90 tool, but it rotates left instead of right. As with the
Copy Rotate Right 90 tool, successive clicks are cumulative - each copy is rotated by 90 degrees more
than the last copy.

 The third button on the Copy Rotate tools flyout toolbar activates the Copy Rotate 180 tool.
This tool works similarly to the Copy Rotate Left 90 and Copy Rotate Right 90 tools, but it rotates 180
degrees.

 The fourth button on the Copy Rotate tools flyout toolbar activates the Copy General Rotate tool.
As with the other Copy Rotate tools, there must be a current selection for this tool to be available.

To use this tool, do the following:

1. Select the item(s) to copy.
2.

 Click the Copy General Rotate tool.
3. Click the fixed point around which the item(s) will rotate.
4. Click the handle point. This is where the rotational force is applied.
5. Set the angle for the copy by using drag or by entering a value in the Angle: field in the Status bar.

6. Once the angle is set, the copy is made. The copy becomes the current selection.

Copy Mirror tools

 The eleventh button on the Edit toolbar activates the Copy Mirror about Vertical tool, and when
held down, activates the Copy Mirror tools flyout toolbar. As with the other Copy tools, these tools are
available only when there is a current selection.
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The Copy Mirror about Vertical tool copies the current selection and mirrors the copy about the
vertical (Y) axis. It then activates the Move tool with the copy selected so that you can easily move the
copy. To use this tool, do the following:

1. Select the item(s) to be copied and mirrored.
2. Click the Copy Mirror about Vertical tool. The item(s) will be copied and mirrored but not offset

from the original - the mirrored copy will appear on top of the current selection.
3. Click the pick-up point for the copy.
4. Click the put-down point to place the copy.

 The second button on the Copy Mirror tools flyout toolbar activates the Copy Mirror about
Horizontal tool. This tool works similarly to the Copy Mirror about Vertical tool described previously but
mirrors about the horizontal (X) axis instead of the vertical (Y) axis.

 The third button on the Copy Mirror tools flyout toolbar activates the Vertical Copy Mirror About
Center tool. This tool copy-mirrors the current selection about the vertical (Y) axis passing through its
center. It does not perform a move. Distribute to Layers is unavailable when using this tool.

 The fourth button on the Copy Mirror tools flyout toolbar activates the Horizontal Copy Mirror
About Center tool. This tool copy-mirrors the current selection about the horizontal (X) axis passing
through its center. It does not perform a move. Distribute to Layers is unavailable when using this tool.

 The fifth button on the Copy Mirror tools flyout toolbar activates the Copy Mirror about Line
tool. This tool makes a mirrored copy of the selected items around the line or construction line you
select. It does not activate the Move tool afterward. As with the other Copy tools, this tool is available
only when there is a current selection. Distribute to Layers is unavailable when using this tool.

To use this tool, do the following:

1. Select the item(s) to be copied and mirrored.
2.

 Click the Copy Mirror About Line tool.
3. Click the line or construction line to use as the axis around which the copy will be mirrored. The

copy is made when you click.
4. The copy becomes the current selection so that other tools may be used on it.

Complete design from half/quarter tool

 The twelfth button on the Edit toolbar is the Complete design from half/quarter tool. Use this tool
to quickly construct a symmetrical design from just a quarter or half of the design. This tool copies the
lines and joins them appropriately so that the proper bridging is made.
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If there is no current selection, the tool automatically selects all the lines in the layer; to only copy
selected lines, select them before activating this tool.

Note:  Lines are merged only if they join and can be replaced by a single line. Beziers are not
merged. Lines on the mirror axis are not copied.

When this tool is active, three mode selectors are on the Status bar as well as an OK button.

The first mode selector copies the design or selection horizontally.

The second mode selector copies the design or selection vertically.
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The third mode selector copies the design or selection both horizontally and vertically.
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To use this tool, do the following:

1. Design the quarter or half design as you would normally.
2. If you only want to replicate part of the design, use the Select tool to select those lines.
3.

 Click the Complete design from half/quarter tool.
4. The third mode selector is the default, so if you want only a horizontal copy or a vertical copy,

choose one of those modes.
5. If the point about which the copy is to be made is not the origin, click that point.
6. The drag shows what the result will be if you click OK.
7. Click OK to make the copy and join the lines. The copied lines are distributed into layers as

appropriate.

Shown below is an example of using the tool to complete a quarter design. The first step is to design
the quarter to be duplicated.
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Next, choose the mode selector and drag in the direction of the duplication.

Finally, click OK to accept the duplication and join the lines. Note how the bridges span the axes
instead of the lines butting against them as they would when using the Copy Mirror tools.
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Copy Times tools

 The thirteenth button on the Edit toolbar activates Copy Times Tools flyout toolbar. The Copy
Times tools are used to make multiple copies of the current selection and either offset them from the
original by a regular distance or rotate the copies around a common point.
 

 

 The first button on the Copy Times flyout toolbar, and the default Copy Times tool on the Edit
toolbar, activates the Copy Times Offset tool. There must be a current selection in order for this tool to
be available.

Example of using the Copy Times Offset tool

In the one-piece container shown below, the hole in the lid needs to be repeated throughout the entire
lid. Copy Times Offset is the perfect tool for the job.
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To make the copies, do the following:

1. Use the Select tool to select the hole.
2.

 Click Copy Times Offset and enter the first and second numbers of copies desired in the fields
on the Status bar. Press Enter. In this example, 9 copies and then 2 copies will be made, for a total
of 30 holes.
 

 
3. Choose the point at the bottom of the hole as the pickup point. Set the angle to 0.

 

 
4. Choose the offset distance between the pick-up point and the put-down point.
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5. Press Enter to confirm the number of second copies on the Status bar.

 

 
6. Set the angle for the second copy.

 

 
7. Set the offset for the second copy and click to set the put-down point.

 

 

The end product should look like the picture below.
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 The second button on the Copy Times flyout toolbar is the Copy Times Rotate tool. There must be
a current selection for this tool to be available. This tool prompts for the number of copies, the fixed
point (the point around which the selection is rotated), and the handle point (the point from which
rotation is initiated).

Example of using the Copy Times Rotate tool

The following instructions can be used to make a starburst design in a bottle hanger in ArtiosCAD.

1. Use the Rectangle tool to make a rectangle, and then use the Circle tool to put a circle in it.
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2. Use Move to Point to move the current position to the center of the circle.

3. Draw a line from the center of the circle to the edge of the circle.
4. Use the Select tool to select the line created in Step 3.
5.

 Click the Copy Times Rotate tool on the Copy Times flyout toolbar.
6. Enter 11 in the Number of copies: field.
7. Click the point at the center of the circle as the fixed point.
8. Click the point on the edge of the circle as the handle point.
9. Set the angle to 30 in Quadrant I and click to set the drag angle.

10. Delete the circle and draw a series of straight lines connecting the ends of the radial lines. Change
these lines to creases.

11. The starburst opening is now complete.

An example of the design after it has had graphics added and brought into 3D:
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Group tools

 The fourteenth button on the Edit toolbar activates the Group Tools flyout toolbar.
 

 

 The first button on the Group Tools flyout toolbar, and the default Group tool on the Edit toolbar,
activates the Ungroup tool. When clicked, the Ungroup tool removes a level of grouping, making
available the individual components or nested groups that comprise the current group.

 The second button on the Group Tools flyout toolbar activates the Ungroup All tool. This tool
ungroups all items in the current selection, including nested groups, so that the individual components
at every level are available.

 The third button on the Group Tools flyout toolbar activates the Group tool. The Group tool makes
ArtiosCAD treat multiple objects as one object. A group shows nine handle points when it is selected
Multiple groups may be nested together to form one large group.

 The fourth button on the Group Tools flyout toolbar is the Group Sequence tool. You must have
a current selection for this tool to be available, and the selected lines should be the same line type.
When clicked, this tool groups the selected sequential lines together. To use this tool, select the lines
to group, click Group Sequence, and optionally check Reverse on the Status bar to reverse the line
direction.

If your current selection includes more than one path, ArtiosCAD groups each path separately.

If your current selection contains mirrored special rules, ArtiosCAD converts them to the same line
type.
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Offset Lines tool

 The fifteenth button on the Edit toolbar activates the Offset Lines tool. This tool moves or copies
offset lines from the current selection, which much be a selection of end-to-end lines. Shown below
are its controls on the Status bar.

Copy copies the current selection. When it is off, the current selection is moved by offset.

Round corners inserts blends on corners where the offset is outward from the corner. No blends are
added when the offset is inward.

Offset sets the amount of the offset.

To use this tool, select the lines to offset, activate the tool, check Copy or Round Corners as desired,
and set the drag either using the mouse or by entering the offset directly in the field. The current
selection will be moved or copied accordingly.

Horizontal/Vertical tools

 The first button on the Adjust Outline toolbar activates the Horizontal/Vertical flyout toolbar.
 

 

 The first button on the Horizontal/Vertical flyout toolbar, and the default Horizontal/Vertical
tool on the Adjust Outline toolbar, activates the Make Horizontal/Vertical tool. The Make Horizontal/
Vertical tool makes the line you select either horizontal or vertical depending on which axis forms an
acute angle in conjunction with the selected line.

 The second button on the Horizontal/Vertical flyout toolbar activates the Align Horizontal/
Vertical tool. Using this tool, you can align a series of points and the lines between them. Click the
tool, drag a window that encompasses all the points to align, and then indicate the alignment point.
Once the window is defined, all the lines and points in the window turn magenta to indicate they are
selected.

Merge Lines tools

 The second button on the Adjust Outline toolbar activates the Merge Lines flyout toolbar.
 

 

1026



12ArtiosCAD

 The first button on the Merge Lines flyout toolbar, and the default Merge Lines tool on the Adjust
Outline toolbar, activates the Merge Lines Straight tool. This tool merges a series of connected lines,
arcs, or beziers into one straight line. Click the tool, indicate the first line in the series, and then
indicate the last line in the series. The various lines will merge into one line.

 The second button on the Merge Lines flyout toolbar activates the Merge Lines Into Arc tool.
This tool merges a series of connected lines, arcs, or beziers into an arc. Click the tool, indicate the
first line in the series, indicate the last line in the series, and set the radius of the arc. The various lines
will merge into an arc.
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 The third button on the Merge Lines flyout toolbar activates the Merge Lines Into Bezier tool.
This tool merges a series of connected lines, arcs, or beziers into a bezier. Click the tool, indicate the
first line in the series, indicate the last line in the series, and then set the control points for the bezier.
The various lines will merge into a bezier.

 The fourth button on the Merge Lines flyout toolbar activates the Merge Lines to Intersection tool.
This tool merges a series of selected lines, arcs, or beziers into two lines that intersect. Click the tool,
indicate the first line in the series, and then indicate the last line in the series. The first and last lines
will intersect and any intermediate lines will be deleted.

Adjust Arc tools

 The third button on the Adjust Outline toolbar activates the Adjust Arc flyout toolbar.
 

 

 The first button on the Adjust Arc flyout toolbar, and the default Adjust Arc tool on the Adjust
Outline toolbar, activates the Adjust Arc tool. Use the Adjust Arc tool to adjust the radius of any arc.
Straight lines may be converted into arcs using this tool.

 The second tool on the Adjust Arc flyout toolbar activates the Straighten  tool. This tool prompts
for the selection of an arc or bezier and then replaces it with a straight line.

 The third tool on the Adjust Arc flyout toolbar activates the Adjust Bezier tool. This tool converts
a line or arc into a bezier, or lets you adjust the control points of an existing bezier. The control point
of the bezier you adjust using this tool is determined by which end of the object you clicked closer to
when selecting the object to adjust.
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Direction tools

 The fourth tool on the Adjust Outline toolbar activates the Reverse Direction tool. This tool
reverses the cutting direction of objects selected after activating this tool. Activate the tool and then
indicate the line, arc, or bezier whose direction is to be reversed.

 The fifth button on the Adjust Outline toolbar activates the Sequence tool. This tool:

• Lets you manually specify the cutting order of lines and groups in the design.

• Works with lines, arcs, beziers, text, dimensions, and arrows.

• Works in any non-empty layer in Designer, but only works in user-defined or output layers in
Manufacturing.

• Does not work with graphics or file windows, or with counter layouts.

• Disables the ability of a design to be rebuilt when used in a layer other than an output layer.

Note:  There are important notes and warnings regarding using this tool and Outputs in the
next section. Please read them carefully before using this tool.

If there are either graphics or file windows in the current layer, a dialog box asks you to either delete
the graphics or exit the feature. Click OK after making your choice.

The standard Disable Rebuild dialog box appears if the design is rebuildable.

Once all the warning dialog boxes have been dismissed, the tool is active. All items not in the current
layer turn gray, and line direction arrows and line numbers are turned on.
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The following buttons controlling the current selection and the sequencing method appear on the
Status bar:

This tool works on the concept of there being different levels of items to resequence. Initially,
everything in the current layer is thought of being at the same level - that there is one item number
for each line in the layer. You can create subgroups of items that have a different cutting order than
the items would if they were not grouped together. Groups and subgroups can be nested together in
a hierarchy of levels. For example, you could resequence a complicated assembly of arcs and beziers
based on the tolerances and abilities of your samplemaker or laser.

The first group of buttons on the Status bar controls the selection of items to group, ungroup, or
reverse. They work the same way as the normal Select tool, except only items in the current group can
be selected. Hold down CTRL to select more than one item.

 The first button selects normally, including groups.

 The second button selects ignoring groups.

 The third button selects connected lines and continues the selection through intersections.

 The fourth button selects connected lines and stops the selection at intersections.

 The fifth button makes a subgroup out of the current selection and enters the subgroup to
facilitate the sequencing of the lines within the group. The subgroup can then be sequenced as a single
entity with other lines in the design. Item numbers for groups under the current selection level or group
are shown in bold.

 The sixth button ungroups the currently-selected group and moves its items up a level. It is
available only when a group is currently selected.

The second group of buttons on the Status bar controls the current level of groups.
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 The seventh button enters a group to let you resequence the items it contains. It is available only
when a group is currently selected.

 The eighth button leaves a subgroup and resumes working in the level above it.

The third group of buttons on the Status bar controls the sequencing in the current level.

 The ninth button sequences all the items and subgroups in the current group. Click the first
item to sequence and click the rest of the items in the desired sequence.

 The tenth button sequences a range of items. Click the item which immediately precedes
the first item to resequence, and then click the rest of the items in the desired sequence.

 The eleventh button automatically sequences all the items and subgroups in the current
group, and also makes subgroups out of connected items.

The third group of buttons on the Status bar controls the direction of lines and options for the tool.

 The twelfth button reverses the lines in the current selection, or all the items in the group if there
is no current selection.

 The thirteenth button opens the Sequence Tool Options dialog box as shown below.

Show moves, when checked, shows a green dotted line between the end of one item and the start of
the next. If the items are in a subgroup, it draws light blue dotted lines.
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Separate by line type, when checked, causes the Auto Sequence button to separate the lines by type
and pointage into groups, and then sequence each group. If text, arrows, or dimensions are present,
they are moved into one group, and numbered in light green. When the option is not checked, lines are
sequenced together regardless of type and pointage.

Reverse lines as necessary, when checked, reverses lines as needed to yield the best sequence.
For the Sequence All and Sequence Range buttons, the first item selected is not reversed. When the
second item is selected, both the first and second items may be reversed depending on the position of
their start and end points. When the third and subsequent items are selected, they may be reversed,
but the preceding items will not be reversed. For the Auto Sequence button, a new subgroup is created
for each move, replacing any subgroups. When this option is not checked, the direction of lines does
not change. However, the order of existing lines and subgroups changes, but the items within the
subgroups do not change order.

Using the Sequence tool with Outputs
As most Outputs are configured to automatically resequence, it is important that you follow these
procedures when outputting resequenced lines.

Sample output. In Defaults, copy an existing samplemaker output, rename it, and configure it using
Workspace Layer for the Driver Type on the Device tab. Name the layer something appropriate such
as Resequenced. If you plan to use this tool for sample layouts as well, clear the Sequence one-ups in
layout checkbox on the Sample Sequencing tab. This has to be done only once.

Once the Output has been set up, use it, and then change to the layer just created. The line types will
have been changed to sample line types. Use the Sequence tool as desired, and then output that layer
to the samplemaker normally. The cutting order for lines set as sample line types will not be changed.

Plot output. In Defaults, copy an existing plotter output, rename it, and select No optimization in the
Optimization options group on the Processing tab. If you plan to use this tool before plotting sample
layouts as well, clear the Sequence one-ups in layout checkbox as well. This has to be done only once.

CAM output maintaining exact sequencing of all lines. In Defaults, copy an existing CAM output and
rename it. On the Tool Selection tab of the new entry, set all the different tools to belong to group
one, and then on the Optimization tab, clear the Optimization tab for group one. This entry will then
maintain manual sequencing.

CAM output with optimized grouping but maintaining exact sequencing of lines within the optimized
groups. In Defaults, copy an existing CAM output and rename it. On the Optimization tab of the new
entry, clear the Optimize checkbox for each group in which manual sequencing is desired. Arrange the
groups and sequencing as appropriate to achieve the desired results. When used, this Output will move
the sequenced lines into the groups as defined, but will not reorder the lines in a group if the checkbox
is not checked for that group.

Counter output. Counter outputs do not support manual sequencing.
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Working with non-geometric elements

Non-geometric elements are elements of an ArtiosCAD design that are not burned on the die. They
usually serve to organize parts of the design or to provide more information about the geometric
elements.

Layers

ArtiosCAD uses the concept of layers to build a complete design. Think of a piece of paper with a
drawing of a basic container. Then on top of that, add transparencies. One transparency could contain
dimensions, another could contain art, and yet another could contain additional design geometry such
as a window or an optional flap. A design may have up to 100 layers. All designs have one layer called
Main Design. Designs made using standards may have many layers depending on the complexity of the
standard.

Use layers to keep different parts of the design from interfering with each other. For example, if you
are doing intricate design work, dimensions might clutter the workspace. Putting the geometry in one
layer and the dimensions in another allows you to turn the dimensions off when desired.

Another reason to use layers is to control the flow of information. When exporting data from ArtiosCAD
into a different format, only the layers that are turned on are exported. This way you can put sensitive
data in one layer, turn it off, and then export the geometry to a file for your diemaker.

ArtiosCAD works with the layers that are turned on. Only layers that are visible are printed or exported
to a file. However, all layers are saved when the design is saved regardless of their viewing status.

The layers that are displayed when a design is opened depends on the setting in Options > Defaults >
Shared Defaults > Design Defaults > Default View Mode. You can choose to display the layers as they
were when the design was saved, or you can choose to always display the same set of layers.

Layers are controlled by the Layer button on the View bar. The Layer button shows the name of the
current layer - it is not labelled “Layer.”

Clicking the Layer button activates the Layers dialog box. Shown below is a sample Layer dialog box.
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The current layer is highlighted and has a pencil icon at the right end of the highlight. Empty layers
have dimmed names. Click the name of a layer to switch to it.

By default, the Layers dialog box in Single Design lists layers in the order in which they were created.
To change the list order, change the default in Options > Defaults > Design defaults > Layers Dialog
Display Order between Show layers in the order they were created and Show layers in the order they
are drawn. The Layers Properties dialog box shows layers in the order in which they are drawn.

At the far left of the dialog box is the Visibility column. An eye icon in the box indicates the layer is
turned on. Click the box to turn the layer on or off. The eye button at the top of the column turns all
layers off except the current layer.

Between the Visibility column and the layer name is the Lock column. A padlock icon indicates the
layer is locked and its contents may not be selected or changed. Click the box to lock or unlock the
layer. The padlock button at the top of the column locks or unlocks all layers.

If Temporary Dimensions mode is active while in a Dimensions or Overall Dimensions class layer,
when the Layers dialog box is opened, the pencil icon for the layer is dimmed to indicate Temporary
Dimensions mode. It returns to normal when Temporary Dimensions mode is turned off.

If you have items selected when turning a layer on or off, if those items reside in the layer whose status
is changing, the selection is cleared; otherwise, the items remain selected.

Locked layers
If you try to modify a locked layer with a tool that uses drag, the cursor changes to a pen with a red line
through it as shown below, and no tools work. You must unlock the layer before attempting to modify it.

Attempting to use tools without drag in a locked layer results in Current layer is locked in the Status
bar.

When you click a tool which requires a layer selection, ArtiosCAD indicates in various ways that a layer
is locked and must be unlocked before it can be selected for use with the tool. Several examples of the
different types of dialog boxes are shown below.
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If you have items selected when locking or unlocking a layer, if those items reside in the layer whose
status is changing, the selection is cleared; otherwise, the items remain selected.

For canvases, ArtiosCAD respects part-specific locks. The layer selection dialog box will allow you
to go to layers that are locked in the active part but not for all parts, because most tools allow you to
change the active part while in the tool.
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Appropriate layers
When changing layers, ArtiosCAD checks that the current line type is appropriate for the layer class.
For example, when switching to a Dimensions layer, ArtiosCAD checks the current line type, and if it is
inappropriate (such as Cut or Perf), ArtiosCAD changes it to a type appropriate for the layer class (such
as Annotation).

After changing layers, if you try to change the current line type to an inappropriate type for the layer
and then activate any of the line-drawing tools on the Geometry toolbar, ArtiosCAD warns you as shown
below.

Select a different layer lets you choose a different layer in which to work, or to create a new layer. The
list of layers shown contains only layers of those classes appropriate for the chosen line type. Choose a
layer from the list and click OK, or click Create New to create a new layer.

Continue in this layer keeps the line type you selected. Once one formerly inappropriate line is placed
into a layer, ArtiosCAD will not warn again for that type in that layer.

Change to line type: line type changes to the line type  ArtiosCAD  suggests for this layer class.

Don’t warn me again turns off all inappropriate layer warnings for the current ArtiosCAD session.

Automatic layer switching
ArtiosCAD can automatically change layers as you work if you have automatic layer switching enabled.
For example, if you are working on a new design and want to add dimensions, when you click one of the
Dimension tools, ArtiosCAD automatically creates a Dimensions layer and changes to it before starting
the tool. When you choose another tool, ArtiosCAD returns you to the previous layer.
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When this feature is active, ArtiosCAD checks to see if there are any valid layers for it to switch to. A
valid layer is:

• in the current print item (if any print items exist)
• unlocked
• is of the default class (if Switch only to layers of default class is also enabled)

If there are no valid layers, ArtiosCAD creates one.

If there are two or more valid layers for them, ArtiosCAD will always prompt for bleed and varnish tools
regardless of how its options are set.

If the current layer is of an appropriate class or already has an item of type the tool creates, ArtiosCAD
stays in the current layer with no prompt.

If you turn this feature off, when you activate a tool needing an appropriate layer, ArtiosCAD prompts
you to either:

• Create a new layer (and optionally specify its name and class)
• Use the current layer
• Switch to an existing layer (and optionally clear everything already in that layer if it is not empty).

 

 
If you choose to specify the name and class of the new layer, ArtiosCAD displays controls for doing so.
When you choose to switch to an existing layer, you can then click the target layer name and choose to
delete its contents or not. Whatever you choose, the message above OK and Cancel changes to show
the action ArtiosCAD will take when you click OK.

1037



12 ArtiosCAD

For canvases, ArtiosCAD respects part-specific locks. The layer selection dialog box will allow you
to go to layers that are locked in the active part but not for all parts, because most tools allow you to
change the active part while in the tool.

For counters, ArtiosCAD does not automatically switch layers.

Setting autoswitch options
Autoswitch behavior is configured in Options > Tool Layer Options while you are working on a design. It
is seeded from Startup defaults and any changes you make persist through the session.
 

 

Automatically switch to appropriate layer turns this feature on and off.

Always prompt for Bleed and Varnish causes ArtiosCAD to always prompt for tools that would switch
to those layers.

Switch only to layers of default class causes ArtiosCAD to only switch to layers whose classes match
their names. For example, if this option were enabled and you had a layer called Dimensions but it was
class Windows and Cutouts, ArtiosCAD would not switch to that Dimensions layer automatically when
you started a Dimensions tool.

Return to previous layer controls how ArtiosCAD behaves when you finish using the tool that changed
layers and activate a different tool.

Adding layers
To add a layer, click the Layer button on the View bar. Then click the Create button to activate the
Create Layer dialog box. Click the class for the new layer. The class name will be used as the name of
the new layer by default. If you want to name the layer something else, erase the contents of the Name:
field and enter the desired name. Click OK to create the layer or Cancel to cancel the creation. When
you create a new layer, you are placed in it automatically. The Layers dialog box will remain open after
you create a layer.
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Manipulating layers
To turn a layer on, check the checkbox next to its name in the Layers dialog box.

To turn a layer off, clear the checkbox next to its name in the Layers dialog box.

The current layer is the one showing a pencil to the right of its name. You cannot turn off the current
layer. To change the current layer, click the name of a different layer.

To change the name or class of a layer, select it in the Layer dialog box and click Properties. The Layer
Properties dialog box will appear.

The names of the layers correspond to their position in the design. The layer at the top of the list is
drawn first; the layer at the bottom of the list is drawn last. Layers toward the bottom of the list mask
those toward the top of the list. Click the two arrows at the side of the list to re-order the selected
layer.
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Deleting layers
To delete a layer, do the following:

1. Click the Layer button on the View bar.
2. Click Properties in the Layers dialog box.
3. Select the layer to delete.

4. Click Delete. The name of the layer disappears from the list.

When you delete a layer, the current selection is reset, any extended items are reset, and the current
tool is restarted after the layer is deleted. If you delete a layer while using a tool that requires a
specific layer such as a bleed layer or coating layer, that tool will be finished and the Select tool will be
activated.

Note:  Deleting most layer types removes them from the layers listed in the Layers and Layer
Properties dialog boxes and also removes the contents of the layer. However, any variables
associated with the layer remain.DocPlot layers (made with Advanced StyleMaker) and Output
to Layer layers (made with an Output) are physically deleted from the workspace. Opening
a workspace containing deleted layers in an earlier version of ArtiosCAD will warn about
unknown commands, but you may safely ignore that warning.

Reusing a deleted layer
ArtiosCAD workspaces have a limit of 251 layers (including Main Design). If you delete many layers, you
may encounter this restriction unexpectedly when creating a new layer. To avoid this limit, you can
reuse a deleted layer by removing its deleted marker.

To reuse a layer, do the following:

1. Click the Layer button on the View bar.
2. Click Properties in the Layers dialog box.
3. Check Show Deleted. (This needs to be done only once per ArtiosCAD session.)
4. Select the layer to reuse. It will have (Deleted) after its name.
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5. Click Reuse.
6. Set the Class: field appropriately for the content of the layer.
7. Click OK.
8. Change the contents of the layer as desired.

Moving items between layers
There are two ways to move items between layers. The first is to cut and paste, and the second is to
use the Move to Layer tool. For the first method, see below; for the second, see the Move to Layer tool
information in the Changing physical properties section of the Designer chapter.

To move items between layers, do the following:

1. Select the items to move and cut them as enhanced metafiles using Edit > Copy > Copy as
Enhanced Metafile, or press CTRL-C. This requires the Designer module.

2. Click the Layer button on the View bar and set the current layer to the one where the objects are to
be placed.

3. Paste the objects into the new current layer.
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Note:  Items copied and pasted between layers are not checked for appropriate line types.

Annotations and Dimensions

See the Builder chapter for complete instructions on using Annotation and Dimension tools.

Graphics

Graphics add color and excitement to your designs. Anyone can view ArtiosCAD designs containing
graphics, but you must have the ArtMaker module in order to add graphics to a design and manipulate
them. Graphics are manipulated using the tools on the Graphics toolbar.
 

 

Adding graphics
One way to add a graphic to your design is to open it in your drawing application (such as Adobe
Illustrator or Microsoft Paint), copy it to the Windows clipboard, and use the Paste command in
ArtiosCAD.

Another way is to use the Import File command on the File menu and choose the file.

 Another way to add a graphic to your design is to use the Add Graphics tool on the Graphics
toolbar. This prompts you for the filename of the bitmap image you want to add.
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Whichever method you use, ArtiosCAD adds the graphic to the current side of the design. Use the Side
control on the View bar to change the side of the design to the desired side before adding a graphic.

When you click Add Graphics, ArtiosCAD opens the last directory accessed. To add graphics from a file
not in this directory, navigate to the desired directory, select the file, and click Open.

ArtiosCAD can import TIFF, BMP, JPEG and PNG files in 24-bit color, 8 bits each for Red, Green, Blue.

It can also import Adobe Acrobat PDF (Portable Document Format) files as graphics, which is the
default file type when you add a graphic.

For JPEG files, ArtiosCAD can import JPEG files up to 6000 by 6000 pixels. Likewise, ArtiosCAD can
import PNG files up to 6000 by 6000 pixels.

TIFF has several different compression tags, but ArtiosCAD can only import uncompressed color
data. When ArtiosCAD imports a CMYK TIFF, it converts it internally to RGB. The maximum image size
that can be plotted at a reasonable speed is about 28MB less than the memory in the computer. The
uncompressed image size is calculated as width multiplied by height (in pixels) multiplied by 3 bytes per
pixel.

When saving the TIFF file for use in ArtiosCAD, use an integer for the number of pixels per unit of
measurement, for example, 72 dots per inch, not 72.5 dpi.

Note:  If the desired graphic file has more than one period in the name, rename it so there is
only one period in the name.

Regardless of which method you use, once the image is in your design, ArtiosCAD automatically selects
it and starts the Move tool. Click the pick-up point, set the drag, and then click the put-down point.

The Edit tools work on graphics – use them to fine-tune the appearance of the graphic. When using the
Select tool to select a graphic, click the graphic’s edge. The edge of the graphic should turn magenta
and handle points should appear.

Any graphics are compressed when the design is saved. If you will be sending files to other people
using versions of ArtiosCAD earlier than 6.5x, you must export them using the appropriate entries in
the File > Export menu.

Register bitmap

 The Register Bitmap tool, the second button on the Graphics toolbar, is used to align a bitmap
precisely with the design. Use this tool when you get artwork for the entire design from an outside
source. The bitmap will be associated with the current print item; change to another print item if
desired before using this tool.

To use Register Bitmap, do the following:

1. Add the graphic, then click Register Bitmap.
2. Click the edge of the bitmap to register.
3. A dialog box appears asking what to clip against, the side of the design the bitmap will be on,

whether to clip, and whether to scale to fit. If you set the Side to Outside, the graphic is added to
the Outside Graphics layer; if you set the Side to Inside, the bitmap is added to the Inside Graphics
layer. If a layer is locked, you may not choose it until you unlock it.
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4. Click OK and the bitmap will be scaled to fit within the edges of the design or outline selected in the
Clip against group.

To replace a registered bitmap and change the clipping and scale options, double-click the graphic
to access its Properties. In the Properties dialog box, click Browse and select the new graphic. The
Position Image dialog box appears as shown below. Use same scale as old image disables all options
except the Position group and replaces the graphic at the same size. Set the options as desired and
click OK.

When registering a bitmap to a multi-piece single design, use this workflow: To register to the design,
add the image to the design. Use the Select tool to select the manufacturing lines for a piece (without
the bleed). To register to the bleed, select the bleed lines, without the manufacturing lines, selecting
a connected loop of lines. Click the Register Bitmap tool. In the Register Bitmap dialog box, the Clip
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Against option button will seed to Outside Bleed Outline, Inside Bleed Outline, or Design Outline
depending on the selection. Click OK to register the bitmap.

 Clip graphics

 The third button on the Graphics toolbar activates the Clip Graphics tool. Use this tool to trim the
edges of a graphic against a loop of lines in the design (called a clipping path). Click this tool, indicate
the graphic to clip, indicate the clipping path, and click OK on the Status bar.

Replace graphics

 The fourth button on the Graphics toolbar activates the Replace Graphics tool. This tool replaces
one graphic in the design with another graphic in the design. The replacement graphic must already
be in the design before activating this tool. Click the tool, indicate the graphic to be replaced, and
then indicate the graphic doing the replacing. If the replacement graphic is a different size than the
original, a dialog box will appear showing the difference in size and the necessary scale factor for the
replacement graphic to be the same size as the original.

The MBC logo is to replace the existing graphic. After you activate the Replace Graphics tool and
indicate the two graphics, ArtiosCAD prompts for confirmation of the replacement.

1045



12 ArtiosCAD

Move Graphics

 The Move Graphics tool moves a graphic from one place to another.

To use this tool, ensure there is a graphic in the workspace, and then do the following:

1.
 Click the Move Graphics tool.

2. Click the location to use as the pick-up point. It can either be on the edge of the graphic or within
the boundaries of the graphic.

3. Move the mouse cursor to the desired put-down location and click the mouse button. Unlike the
pick-up point, the put-down location will snap to points as well as a plain coordinate. The graphic
will move appropriately.

 AutoTrace bitmap

 The AutoTrace Bitmap tool on the Graphics toolbar converts a bitmap image (such as a TIFF or
BMP file) into lines and arcs that can be manipulated in ArtiosCAD. AutoTrace works best on line art
drawings.

The Color to Vectorize option lets you choose the color that ArtiosCADwill convert to lines and arcs.
Drag Color is the color of the lines used to show the lines that will be created. Brightness Threshold
% controls how much will be vectorized in relation to the brightness of the color selected to vectorize.
Size Threshold sets the size limit of items to vectorize. Smoothing Threshold controls the jaggedness
of the new lines created. The Dynamic checkboxes, when checked, tell ArtiosCAD to update the screen
as you drag the slider.

Below is shown a bitmap imported from another program which has been AutoTraced. The bitmap can
be deleted and the remaining lines can be manipulated by all ArtiosCAD tools.
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Adding a stock color

 The seventh button on the Graphics toolbar activates the Color Stock tool. This tool adds a
uniform color to all panels of the design. Choose the side of the design to color, and then click Pick
Color to open the color palette, or enter the CMYK values for the desired color.
 

 

You may have only one stock color per side per print item. To change the current stock color, click the
Color Stock tool and choose the new color.

Deleting a stock color
To delete a stock color, use Undo if possible. If that is not possible, select the edge of the design and
double-click it (or press ALT-Enter), then click Remove Fill on the Graphics tab of the Properties
dialog box.
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 Fill

 The Fill tool on the Graphics toolbar lets you fill an area with color that is formed by a closed loop
of design lines. To use this tool, select the lines that form a closed loop, and then click the Fill tool. The
default fill color (FC Orange 021) will fill the area. To change the fill color, double-click one of the lines
that forms the loop and choose the new color from the  Graphics tab of the Properties dialog box.

You can change the default fill color on the Graphics tab of the Property Defaults control in Defaults.
When an item is filled, the lines forming the closed loop are changed to type print image, and the lines
are grouped together.

 Stroke

 The Stroke tool on the Graphics toolbar adds a ribbon of color around the edge of a line or group of
lines you select.

The stroke evenly straddles the selected lines.

When applying a stroke, there are several options for how strokes meet and how they turn corners.
 

 

The options in the Join group control how strokes that meet are connected. Miter makes the inside
and outside angles of the intersection the same. Round blends the outside corner of the stroke. Bevel
chamfers the outside edge. Shown below is the junction of two stroked lines, with a mitered corner, a
rounded corner, and a bevelled corner.
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The options in the End Cap group control the ends of the stroke. Flat ends the stroke at the same
point as the end of the object being stroked. Round makes a semicircle at the end of the stroke that
projects beyond the end of the object being stroked. Square extends the end of the stroke half a
stroke-thickness beyond the end of the object being stroked. Shown below is a flat stroke, a rounded
stroke, and a squared stroke end. In the examples, the line being stroked is shown selected to clarify
the stroke option.

Fill panel

 The Fill Panel tool on the Graphics toolbar fills the panel you indicate with the default fill color.

To use this tool, click it. The cursor will change to a paint bucket pouring paint. Click inside the panel
you want to fill. ArtiosCADwill automatically exclude any cutouts that exist inside the panel.

Send to front and Send to back
Graphics in ArtiosCADare applied in a layer one on top of another like a stack of paper on a desk. Layers
are also stacked; to change layer order, and not the order of graphics within a specific layer, use the
arrow controls in the Layers dialog box to change the layer order.

 Send to front moves the selected graphic to the top of the stack so that it is visible in front of all
other graphics occupying the same area in the design.

 Send to back moves the graphic to the bottom of the stack.

To use these tools, first select the object(s) you want to send to the front or back, and then click either
Send to button. Shown below are two rectangles - one in front and one in back, and then reversed.
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Adding a PDF file
To import a PDF file, do the following:

1. Make a normal single design.
2.

 Click Add graphics on the Graphics toolbar.
3. Navigate to the directory where the PDF file is located and change the Files of Type: drop-down list

box to PDF.

1050



12ArtiosCAD

4. Select the file and click OK.
5. Rendering Preview will appear on the Status bar and then the image will appear in ArtiosCAD, ready

to manipulate just like any other graphic image.

Working with Adobe Acrobat PDF files

If you have purchased the PDF option, ArtiosCAD displays more detail as you zoom in on a PDF graphic.
This greater detail is called high graphics mode, and in Single Design can be turned on either in the
View Mode dialog box, and also on the context menu accessed with the right mouse button. Shown
below are the View Mode dialog boxes in Single Design.
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 In 3D, use the 3D Rendering and Image Quality slider on the View toolbar to set the level of detail
shown. It is also available in the View Mode dialog box.

Use of this feature is very dependent on the performance and amount of memory on your system-
specific display adapter.

Shown below is a design with a PDF graphic at preview resolution when high graphics mode is off.
Notice the pixelation and jagged edges of the graphic.
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Shown below is the same graphic with high graphics mode turned on. Notice the smoothness of the
curves.
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Note:  When scrolling, you may have to refresh the screen using F2 or the Refresh command
for high graphics mode to re-render the bitmap.

Note:  The quality of the PDF file directly influences the quality of the zoom in ArtiosCAD. If the
PDF file is downsampled or compressed, the effect of high graphics mode is limited compared
with importing the graphic in another format such as TIFF or BMP.

Changing the reference to the PDF file

If you need to change the reference to the PDF file, for example if you rename the PDF file, or move it
to another directory, double-click the edge of the PDF graphic in ArtiosCAD to access its Properties
dialog box. Next, click Browse and reselect the file in its new location.

1054



12ArtiosCAD

Troubleshooting

After adding the PDF file to the design, if the PDF file is not found, no error message is displayed, and
the preview image is used instead. When the file is not found, the Pathname field in the Properties
dialog box will change to File not found and will be in red. Click Browse to find and reselect the file.

Automatic registration of Esko normalized PDF files in a single design

ArtiosCAD automatically registers, or precisely aligns, a PDF file to a single design if the PDF file was
created either with the Structural Design Import and Esko PDF Export plug-ins for Adobe

®
 Illustrator

®

or with Automation Engine.

Specifically, the PDF file must contain embedded XMP CAD-related data. You can check for this data in
either a full version of Acrobat (not Acrobat Reader) or Illustrator. In Acrobat, click File > Properties >
Description > Additional metadata > Advanced, or in Illustrator, click File > File Info > Advanced. Then
expand the http://ns.esko-graphics.com/ cadreg/1.0 catalog entry and look for six egCadReg entries
similar to those shown below.
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Note:

Auto-registering PDF files cannot be added to a 3D workspace using Add a Design. Instead,
open the auto-registering PDF and then use Add to Open 3D.

Registering a normalized PDF file

There are two ways to register a normalized PDF file to the single design workspace:

• Use ArtiosCAD to open the normalized PDF file directly, interpret the embedded XMP data, and open
the referenced workspace.

• Use ArtiosCAD to open the single design workspace, then click File > Open and select the
normalized PDF file.

In the first method, ArtiosCAD searches for the single design workspace in the following locations:

1. The location specified in the embedded XMP data of the PDF file;
2. The same folder as the PDF file;
3. A relative folder from the folder containing the PDF file, specified in the embedded XMP data, such

as \data or ..\graphics.

If ArtiosCAD cannot find the single design workspace to which to register the PDF file, it will open the
PDF file using the vector import workflow.

In the second method, ArtiosCAD always places the PDF file in the Outside Graphics layer. If there is an
existing Outside Graphics layer containing a PDF file with the same name as the one being opened, the
layer is reused, else ArtiosCAD creates a new Outside Graphics layer.

Shown below is an example of an Illustrator workspace that has had a single design imported into it
using the Structural Design Import plug-in and then has had graphics applied:
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The single design workspace in ArtiosCAD:
 

 

The Illustrator document exported as a normalized PDF file and combined with the single design
workspace:
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Other auto-registration formats

PDF files may also contain links to Collada or bag files. When ArtiosCAD opens such a PDF file, it will
look for the referenced linked file, and if found, will automatically register the PDF graphics in 3D as the
first printable area on the Collada or bag file.

Print items

Print items are groupings of layers into logical units. For example, if the same carton is to be printed in
green and in red, instead of making two copies of the same design, you can create two print items and
associate different overlays with each item. Then you can design a set of manufacturing tools that uses
both print items. There may be up to 100 print items in a design.

 The Print Item button on the View bar controls print items. The name of the current print item, if
any, appears next to the icon.

To create a print item, click the Print Item button. If this is the first print item in the design, enter the
name for the print item when prompted. If this is not the first print item in the design, click Create in
the Print Item Properties dialog box and enter the name of the new print item.
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The current print item is highlighted in the Print Item: pane. The layers associated with the selected
print item have eye icons in the Layers: pane. In the example above, the Main Design, Outside Graphics
(2), and Inside Graphics layers are part of the Cornbread Stung print item.

The Main Design layer is always associated with every print item; its checkbox cannot be cleared.

To delete a print item, click Delete in the Print Items Properties dialog box.

Artwork Panels

 Artwork panels are a way for you, the structural designer, to label which panels are visible and
should therefore contain artwork to others in the supply chain such as a graphic desginer. The panels
are normally labeled Front, Back, Left, Right, Bottom, and Top. You can also indicate the Principal
panel.

You can define artwork panels in three ways:

• In 3D, you can fold the design, position it as desired, export the information back to 2D, and have
Artwork Panels automatically create the labels.
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• If you do not have 3D, you can easily label the panels manually within Artwork Panels.
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• You can also create a custom panel based on lines that form an outline.

Using the Artwork Panels Tool

 When you click Artwork Panels, ArtiosCAD first prompts you to create an Artwork Panels layer if
one does not already exist. Click OK to create the layer.
 

 

It then labels the panels of the design with their function if you have used the Update 2D tool in 3D. It
gets information about panel positioning from 3D, or you can designate the panels manually.

Artwork Panels has the following controls on the Status bar:
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Offset controls how far the panel label edges are from the design lines.

The drop-down list box showing Copy free sets the type of label created by your next click. If a panel
is defined already, changing the selected item in the list changes a panel to that type when you click
inside it. The default panel types and uses are:

Label Purpose

Copy area Can have copy text, but is not a front, back, left,
right, top, or bottom panel

Rotate front Rotates the front panel label between the front,
right, back, and left panels so that a different
panel is front. If you have 3D, you do this by
changing the view angle.

Front Make this a front panel

Back Make this a back panel

Left Make this a left panel

Right Make this a right panel

Top Make this a top panel

Bottom Make this a bottom panel

Principal Display Panel Make this the Principal Display Panel independent
of the front, back, left, right, top, or bottom panel

Partial copy area Make a copy outline from the outline of the visible
part of the panel

Copy free Make this a copy free panel

Partial copy free Make a copy free area from the outline of the
invisible part of the panel

Ink free Make this an ink free panel, such as a glue flap

Clear Deletes the label in the panel

A copy area is where the graphic artist may place copy text that is visible to the customer.

A copy free area is where the graphic artist should not place copy text because it cannot be seen or is
hidden by a flap or the product. However, graphics may go in copy free areas.

An ink free area may not be printed.

 More Options opens the Properties dialog box.
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On the Font and Color tab are the standard font and color controls for the label, as well as controls to
control the creation and appearance of an arrow. Set these options as desired.
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The options on the Options and Panel Labels tab control the types of panels Artwork Panels creates,
the offsets for the panel edges, and the labels of the panels.

Copy areas for visible panels creates copy areas on visible panels. This option is enabled by default.

Copy areas for partially visible panels creates copy areas on those parts of panels that aren't hidden
by other panels (such as flaps). If you have a flap arrangement like the one shown below, with the
secondary flaps on top of the primary flaps, having this option selected would create an artwork panel
as shown beneath that.
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Copy free areas for invisible panels labels those panels customers will not see as copy free.
 

 

Copy free areas for partially visible panels labels the invisible parts of partially visible panels as copy
free areas.
 

 

Ink free area for bottom panel labels all the bottom panels as ink free.
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The options in the Offset group control the distance between the panel edges and the design lines.
If desired, you can have a larger or smaller offset from creases by changing the value in Offset from
crease.

In the Panel Labels group, change the labels of the panels as desired

Note:  All of these options have defaults in the Artwork Panels section of Startup Defaults.

On the Panel Tolerance tab are Fix gaps up to and Extend creases up to. ArtiosCAD uses these
tolerances to fix small gaps up to the size indicated and to extend creases through gaps of up to the
size indicated. This helps the tool find panels when creases do not touch cuts or there is a small gap in
a panel's periphery. The defaults for these values are in Startup defaults > 3D Tools Options.
 

 

Click OK to close the More Options dialog box and return to the tool.

Once you have created the artwork panels as desired, click OK on the status bar to finalize them.
ArtiosCAD changes all the panel edges to Copy area lines.

Note:  Artwork Panels is limited to 20 panels per use, which should be enough for most
designs. If you need more, use the tool again to manually add the extra panels.

Creating Artwork Panels from 3D Information
The quickest way to create artwork panels is to fold the design in 3D, set the flap priority and
orientation, and export the 3D information to the 2D workspace.

1. Create or restore a design and make sure that for any non-folding creases or perfs, their 3D
property is set to Tear or Indent only. Otherwise, Artwork Panels will later create extra panels.

2.
 Convert the design to 3D. With the box open like this, ArtiosCAD does not know which flap

should be on top.
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3.

  Use one of the Fold tools to close the design.
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4.

 Use Flap Priority to set the order of the flaps that are visible. However, at this view angle,
ArtiosCAD does not know how to definitively order the panels.
 

 
5.

 Use View Angle to position the design so that the order of panels is not ambiguous. There is no
doubt about which is the front panel in the example shown below.
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6.

 Click Update 2D to send the 3D panel information back to the single design workspace.
7.

 Switch back to the single design and click Artwork Panels to start the process of labeling the
panels as described previously. ArtiosCAD puts temporary labels in the panels for you to finalize
before clicking OK.
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Creating Artwork Panels Manually
To create artwork panels manually, do the following:

1. Create a new design or restore an existing design.
2.

 Click Artwork Panels. ArtiosCAD labels the panels with its best guesses as to their function.
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3. To change a panel, set the controls on the Status bar as desired and then click inside the panel.

 

 
4. Click OK when done to finalize the panel labels.
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If you define a Bottom panel using Artwork Panels, when you convert the design to 3D, ArtiosCAD
automatically suggests that panel as the base face. However, any base face set in 3D and then
saved back into the single design takes priority, especially when you have run a standard, as most
standards have base faces defined in 3D.

Creating Artwork Panels from Custom Outlines
To create artwork panels from custom outlines, do the following:

1. Create or restore a design and design the custom outlines. The outlines must form a loop.
2. Select the outlines.
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3.

 Click Artwork Panels.
4. Click OK to create an Artwork Panels layer.

 

 
5. Once you click OK, ArtiosCAD creates the panels.
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6. If you want to modify the panels, click Artwork Panels again.
7. Click No when prompted to clear the current Artwork Panels layer.
8. Use the tool as desired to modify the panels, clicking OK on the Status bar when done to finalize the

changes.

Changing Artwork Panel Properties
To change the properties of an Artwork Panel after you have created it, double-click it with a Select
tool to open its Properties dialog box.
 

1074



12ArtiosCAD

 

Principal display panel indicates to other Esko programs that the selected panel is the main panel to
show of the design.

Allow bleed indicates to other Esko programs that other panels can be shown over this one.

Click OK when you have finished changing the properties.

Artwork Panels Restrictions
Artwork Panels supports up to 24 panels. Designs that have too many panels like the ones shown below
are not supported.
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Dynamic Art

Dynamic art is database-driven artwork that graphic designers add to designs using other Esko
software. The Dynamic Art tool in ArtiosCAD lets you designate placeholder rectangles for that
artwork.

In ArtiosCAD, Dynamic Art rectangles have a copy type and sometimes a preview image. The five types
of Dynamic Art are:

1. Copy. Used for text such as Product Name or Net Weight.
2. Barcode. Used for one- or two-dimensional bar codes.
3. Symbol. Used for symbols and images such as recycle or hazard symbols, or product logos.
4. Table. Used for tabular data such as Nutrition Facts tables.
5. Station number. Used to label containers in layouts with sequential numbers.

Dynamic Art definitions are derived from the GS1 global business standard.

Using the Dynamic Art Tool

 When you click Dynamic Art, ArtiosCAD first prompts you to create a Dynamic Art layer if one does
not already exist. Click OK to create the layer.
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The Dynamic Art Options dialog box appears in which you select the type of Dynamic Art placeholder to
create and set its options. Change the Type, Category (available only for Copy), Element, and Text as
desired and click OK.
 

 

Drag appears for the placeholder. Click inside a panel to set the put-down point. It can be in a corner,
the middle of a side, or the center.
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If you have an Artwork Panel defined, the orientation of the Dynamic Art placeholder follows the
Artwork Panel definition.
 

 

Set the options on the Status bar and click OK to finalize the placeholder. When you click inside the
Width or Height field, the size automatically expands to the size of the panel minus the panel offset.
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Adding a Copy Placeholder
To add a copy placeholder, do the following:

1.
 Click Dynamic Art and click Yes if ArtiosCAD prompts you to create a Dynamic Art layer.

2. In the Dynamic Art Options dialog box, select Copy for the Type and choose the desired Category
and Element from the drop-down lists. Enter any desired text in the Text field and click OK.
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3. Use drag to set the put-down point of the placeholder.
 

 
4. Set the fields on the Status bar as desired. Width and Height control the width and height of the

placeholder. Text is the same text you entered in the Dynamic Art Options dialog box in the previous
step. The directional label controls let you change the position of the placeholder's label.
 

 
Clicking More Options (...) opens the Dynamic Art Options dialog box. There are standard controls
for font, color, and appearance. Panel offset controls the gutter between the placeholder and the
panel edge. Display "lorem ipsum" when no image or text specified supplies contents if you don't
enter any. When you are done setting options, click OK.
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5. Click OK on the Status bar to finalize the copy placeholder.
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Adding a Barcode Placeholder
To add a barcode placeholder, do the following:

1.
 Click Dynamic Art and click Yes if ArtiosCAD prompts you to create a Dynamic Art layer.

2. In the Dynamic Art Options dialog box, select Barcode for the Type and choose the desired Element
from the drop-down list. Enter any desired text in the Text field and click OK.
 

 
3. Use drag to place the put-down point of the placeholder.
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4. Set the fields on the Status bar as desired. Scale lets you set the scale of the placeholder. Width

and Height control the width and height of the placeholder. Text is the same text you entered in the
Dynamic Art Options dialog box in the previous step. The directional label controls let you change
the position of the placeholder's label.
 

 
Clicking More Options (...) opens the Dynamic Art Options dialog box. There are standard controls
for font, color, and appearance. Panel offset controls the gutter between the placeholder and the
panel edge. Display "lorem ipsum" when no image or text specified supplies contents if you don't
enter any. When you are done setting options, click OK.
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The Dynamic Barcodes plug-in will draw a barcode at its default size in Adobe Illustrator regardless
of the scale or size specified for the placeholder in ArtiosCAD.

5. Click OK on the Status bar to finalize the barcode placeholder.
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Adding a Symbol Placeholder
To add a symbol placeholder, do the following:

1.
 Click Dynamic Art and click Yes if ArtiosCAD prompts you to create a Dynamic Art layer.

2. In the Dynamic Art Options dialog box, select Symbol for the Type and choose the desired Element
from the drop-down list. Enter any desired text in the Text field and click OK.
 

 
3. Use drag to place the put-down point of the placeholder.
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4. Set the fields on the Status bar as desired. Width and Height control the width and height of the

placeholder. Text is the same text you entered in the Dynamic Art Options dialog box in the previous
step. The directional label controls let you change the position of the placeholder's label.
 

 
Clicking More Options (...) opens the Dynamic Art Options dialog box. There are standard controls
for font, color, and appearance. Panel offset controls the gutter between the placeholder and the
panel edge. Display "lorem ipsum" when no image or text specified supplies contents if you don't
enter any. When you are done setting options, click OK.
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5. Click OK on the Status bar to finalize the symbol placeholder.
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Adding a Table Placeholder
To add a table placeholder, do the following:

1.
 Click Dynamic Art and click Yes if ArtiosCAD prompts you to create a Dynamic Art layer.

2. In the Dynamic Art Options dialog box, select Table for the Type and choose the desired Element
from the drop-down list. Enter any desired text in the Text field and click OK.
 

 
3. Use drag to place the put-down point of the placeholder.
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4. Set the fields on the Status bar as desired. Width and Height control the width and height of the

placeholder. Text is the same text you entered in the Dynamic Art Options dialog box in the previous
step. The directional label controls let you change the position of the placeholder's label.
 

 
Clicking More Options (...) opens the Dynamic Art Options dialog box. There are standard controls
for font, color, and appearance. Panel offset controls the gutter between the placeholder and the
panel edge. Display "lorem ipsum" when no image or text specified supplies contents if you don't
enter any. When you are done setting options, click OK.
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5. Click OK on the Status bar to finalize the table placeholder.
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Adding a Station Number Placeholder
1.

 Click Dynamic Art and click Yes if ArtiosCAD prompts you to create a Dynamic Art layer.
2. In the Dynamic Art Options dialog box, select Station number as the type and click OK. It has no

options to set.
3. Use drag to set the position of the station number. Presumably it should go somewhere the end

consumer will not see or care about.
 

 
4. Click OK to add the piece of Dynamic Art.

 

 

 If you add this single design to a layout, the Station and Waste Numbers tool will use the
placeholder to add a number.

Changing Placeholder Properties
To change the properties of a Dynamic Art placeholder after you have created it, double-click it with
the Select tool. In the Properties dialog box, you can change all its properties, and change the preview
image file (if there is one).
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 Other functions in Designer

Setting the Grain/Corrugation direction

 The Grain/Corrugation button on the View bar controls the grain/corrugation direction of
the design. A vertical symbol indicates a vertical direction; a horizontal symbol indicates a horizontal
direction. Clicking the drop-down arrow shows a menu with more commands on it:

• Change Grain Direction changes the grain/corrugation direction without rotating the design.

• Change Grain View with Rotate 90 Right changes the grain direction and rotates the design
clockwise by 90 degrees to reflect that change.

• Change Grain View with Rotate 90 Left changes the grain/corrugation direction and rotates the
design counterclockwise by 90 degrees to reflect that change.

These commands are also on the Info menu.
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For further discussion about setting the print side and the blade side, refer to The View bar section in
the Introduction chapter.

Setting the current side of the design

A design has two sides – the printed side and the unprinted side.

The Side button   on the View bar controls which side is up. Blue indicates printed side up;
white indicates unprinted side up. This button flips the design when clicked. You may have graphics on
both sides of the design.

Units and formatting

The Units and Formatting command on the Options menu controls the calculation, input, and display
of numerals. Change the options as desired. In the Format group, you can choose between sixteenths
and twentieths.

Note:  You cannot change between sixteenths and twentieths in the Dimension Properties
dialog box.

If you use sixteenths, negative numbers now work with the colon as a formatting character as of
version 23.03

The Units button   on the View bar changes the units when clicked.

CloseUp windows

Click the middle mouse button to create a CloseUp window. If you don’t have a middle mouse button,
click CloseUp on the View menu or press CTRL-Space. Holding down CTRL while opening a CloseUp
window opens it at a different scale.

A CloseUp window shows a zoomed-in view of the area surrounding the point you clicked. A CloseUp
window will change if Show window contents while dragging is enabled in the Display Properties of
the operating system.
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Click the magnifying glass icon on the title bar of the CloseUp window to access its menu. Dynamic
controls the real-time updating of the window as you drag it. Options opens the CloseUp Options dialog
box.

Width and Height change the size of the CloseUp window.

Scale and the slider beneath it specify the scale for the CloseUp window.

Set Default makes the values you set the values that are used for the remainder of the current
ArtiosCAD session for regular CloseUp windows. Set Ctrl + Click Default sets the session default for
CloseUp windows opened using the CTRL key.

Clicking the middle mouse button while in a CloseUp window closes the current window. SHIFT-
middle mouse button closes all CloseUp windows, as do SHIFT-Spacebar and Close All
CloseUps on the View menu.

Press CTRL-A to zoom out in CloseUp windows.

CloseUp window defaults are set in Options > Defaults > Shared Defaults > Startup defaults > View
tools options.

StyleMaker

StyleMaker is an optional feature of ArtiosCAD that allows you to make your designs once and rebuild
them with different measurements an infinite number of times.

StyleMaker works by using variables instead of absolute values as you construct the design. Variables
are ways to store pieces of data that can change in the future. For example, if you define L as having
a value of 300, every time you draw a line representing the length of the container, you would use L as
the distance or offset instead of 300. When it is time to make this container again, you can easily make
it at a new size by entering new values for the variables.

In ArtiosCAD, variable names must start with a letter and can be up to 6 characters long.

Note:  Only use uppercase ASCII letters and numbers for the variable name. Do not use
characters from another character set for variable names.

StyleMaker has two modes, simple and advanced. If you have old licenses from when ArtiosCAD was
licensed by module, you may have either StyleMaker or Advanced StyleMaker. If you have more recent
solution licenses, the ArtiosCAD Resizable Design Tools Solution grants access to both simple and
Advanced StyleMaker.

Simple StyleMaker lets you define variables, give them a description, and give them a default value.
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Advanced StyleMaker lets you organize variables into menus and folders, base variables on other
variables, define variables using formulas, have limits on variable values, and many more features.
 

 

One of the most important things about using StyleMaker is to plan ahead. Before you start drafting,
decide what you want to be parametric and figure out what dependencies exist. Having everything
accounted for before you begin drafting will save you time and effort as you construct the design.

Simple StyleMaker

Adding variables on the fly in Simple StyleMaker
1.

 Start a drafting tool such as Line Angle/Offset.
2. Set the prompts as desired, but type a letter in one of the fields (in this case, L in the Length field)

and press ENTER.
3. ArtiosCAD prompts you that the expression contains undefined variables and asks if you want to

define them. Click Yes.
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4. Enter the desired value and description of the variable where prompted. This is the only time in

Simple StyleMaker that you can change the name of the menu so change it if desired.
 

 
5. Click Add Variable to continue drafting.
6. Repeat as desired for other variables as you draft. The lines in the example below all have lengths

defined by variables and endpoints are turned on in the View Mode for clarity.
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The added variables appear in the variable list in the Keypad.
 

 

Adding variables to a menu in Simple StyleMaker
In addition to adding variables on the fly as you need them, you can add them ahead of time and then
use them as you draft.

1. Click Design > StyleMaker.
2. In the Variables column, click Add.
3. Enter the name of the new variable and click OK. Note that this is the internal identifier, not the

description.
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4. The new variable should be selected. Enter its description and default value in the fields on the

right.
 

 
5. Continue adding variables as desired. Click OK when done.
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Deleting a variable in Simple StyleMaker
1. Click Design > StyleMaker.
2. Click inside the value field of the desired variable.
3. Click Delete.
4. Repeat as desired for any other variables.
5. Click OK to return to Designer.

Adding a diagram in Simple StyleMaker
A diagram is the picture ArtiosCAD shows during rebuilding a design or running a standard that explains
the variables in the current menu.

1. Click Design > StyleMaker.
2. Click Diagram.
3. Click Create New Diagram. Note the name of the layer.
4. Drag a selection window around the design lines you want to be in the diagram. This step does not

include any dimensions or text that may be inside the selection window.
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5. The design lines and the layer name should now appear in the Attach Diagram to StyleMaker Menu
dialog box. Click OK to return to the StyleMaker dialog box.
 

 
6. Click OK to return to Designer.
7. Use the Layers control on the View bar to change to the new layer. At the same time, turn off the

Main Design and Dimensions layers.
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8. Use the dimensioning and text tools to add dimensions and text. It is helpful to change the value of a
dimension to the name of the dimension so that the name appears during rebuild.
a) Double-click the dimension to change.
b) Click the pencil to the right of the Text field to enable that field for editing.
c) Change the value in the text field appropriately.
d) Click OK to return to Designer. Repeat for the other dimensions.

 

 
9. Now when you rebuild the design, there will be a diagram.

 

 

Note that you can add any content to this layer for the diagram. Consider what would be useful for you -
maybe a copy of a folded 3D workspace, perhaps - and add what you think is best.

Advanced StyleMaker

Adding variables on the fly in Advanced StyleMaker
Context for the current task

1.
 Start a drafting tool such as Line Angle/Offset.
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2. Set the prompts as desired, but type a letter in one of the fields (in this case, L in the Length field)
and press ENTER.

3. ArtiosCAD prompts you that the expression contains undefined variables and asks if you want to
define them. Click Yes.
 

 
4. Enter the desired value and description of the variable where prompted.

 

 
a)

 To insert the variable into a new menu, you can either click Add Menu and enter a name for
the new menu, or you can enter the name in the Menu field and ArtiosCAD will create it.

b)
 To put the variable into a new folder, click Add Folder.

c)
 To delete a folder or menu, select it in the tree and click Delete. ArtiosCAD will prompt you

for confirmation.
d)

 To rename a folder or menu, select it in the tree and click Rename, and enter the new name.
5. Click Add Variable to continue drafting.
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6. Repeat as desired for other variables as you draft. The lines in the example below all have lengths
defined by variables and endpoints are turned on in the View Mode for clarity.
 

 

Adding variables to a menu in Advanced StyleMaker
In addition to adding variables on the fly as you need them, you can add them ahead of time and then
use them as you draft.

1. Click Design > StyleMaker > Advanced.
2. To create a new menu for the variables, click Add Menu, or to create a new folder, click Add Folder.

Here we will add a new variable menu called Basic Dimensions. Click OK when done.
 

 
3. In the Variables group of the Advanced StyleMaker dialog box, click Add.
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4. Enter the name of the new variable and click OK. Note that this is the internal identifier, not the

description.
5. The new variable should be selected. Enter its description and formula in the fields on the right.

 

 
a) Visible controls if the variable appears in the menu or not.
b) Description is what ArtiosCAD shows in the menu (if so configured) or when you hover over the

variable while rebuilding.
c) Formula is the definition of the variable. It can be a number or an expression. Use the f(x) button

to build the expression graphically.
d) Check Condition is the expression that governs the limits to which the variable must adhere, for

example, length must be greater than or equal to the width (L>=W). This can be ignored if there
is a conflict.

e) Check Help explains what the limit is.
f) Enforced Check is a check condition that cannot be ignored, such as length must be greater

than 0 (L>0).
g) Check Help explains what the non-ignorable limit is.
h) In the Type group, choose the kind of variable this is - one for Distance, one for an Angle or

Number, or one for an Angle/Offset.
i) In the Round To group, enter the value to which you want to round the variable value to, and

the direction of rounding. Some people who work in corrugated want to round everything up to
the nearest thirty-second of an inch (or half a millimeter), so they would make sure that CRRV
(corrugated rounding value) is set to 1/32” (0.5mm), set the Round to field to CRRV, and then set
the rounding direction to Up.
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6. Continue adding variables as desired. Click OK when done.

Note:

If you want to use a variable to define another variable, it must have been already defined in a
previous menu. ArtiosCAD records values for variables when you leave a menu.

Deleting a variable in Advanced StyleMaker
1. Click Design > StyleMaker (and Advanced if necessary).
2. In the list of menus, click the menu containing the desired variable.
3. Click inside the value field of the desired variable.
4. Click Delete in the Variables group.
5. Repeat as desired for any other variables.
6. Click OK to return to Designer.

Manipulating menus and variables in Advanced StyleMaker
Shown below is the Advanced StyleMaker dialog box for an ECMA Resizable Design Template as an
example.
 

 

Menus
To rearrange the menus into a different order, select a menu and drag it to its new position.

To rename a menu, right-click it, click Rename on the context menu, enter the new name, and click
anywhere outside the field. You can also select the menu, click Rename in the Menu/Folder group,
enter a new name, and click OK.

To delete a menu, right-click it and click Delete on the context menu. You can also select the menu
and click Delete in the Menu/Folder group. ArtiosCAD will prompt for confirmation. ArtiosCAD will not
delete a menu containing variables that are used to define other variables and will show a list of the
conflicting variables.
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Variables
To reorder variables within a menu, select the variable and the click the up and down arrows to the right
of the list to move it to a new position.

To move variables from one menu to another, select the variables and click Move, and then select
the destination menu and click OK. ArtiosCAD will not move variables that are used to define other
variables and will show a list of the conflicts.

A variable must already be defined in a previous menu before a variable in a following menu can refer to
it.

Using predefined menus and variables in Advanced StyleMaker
For ease of creating new resizable designs, you can copy menus and variables from other designs using
Copy in the Variables group. When you click it, the Copy Variables dialog box appears.
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The default design it uses is called VARMASTER that lives in InstLib, but you can choose any
workspace using Browse at the end of the field.

If you select a menu on the left, ArtiosCAD automatically selects all the variables in it on the right.
When you click OK, ArtiosCAD asks if you want to copy the entire menu or just the selected variables.
Make your desired choice and click OK to copy the menu and/or variables into the current design.
ArtiosCAD will not copy variables that already exist in the current design.

To only copy a few variables, hold down SHIFT as you select them.

Creating a style choice menu in Advanced StyleMaker
A style choice menu contains variables that later determine how geometry is modified. In this example,
we will create a style choice menu for regular slots versus rounded slots.

Thinking ahead about these kinds of things is why it is so important to thoroughly plan your design
before starting to draft it.

Adding the menu in Advanced StyleMaker

1. Click Design > StyleMaker (and Advanced if necessary).
2. Click Add Menu in the Menu/Folder group.
3. Enter a name for the menu such as Slot Style and set the menu type to Style Choice Menu.
4. Click OK.

Adding variables to the style choice menu in Advanced StyleMaker
Once the menu is created, add variables to it.
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1. The new menu should be selected in the list of menus. If it is not, select it.
2. Click Add in the Variables group.
3. Enter the name of the variable (not the description) and click OK.
4. Define the menu more fully in the Style Choice Variable Data group.

a) Enter Slot Style Choices as the Group Title.
b) Click Add next to the empty list of style choices.
c) Enter Squared in the Style Choice Caption dialog box and click OK.
d) Click Add again next to the list of style choices.
e) Enter Rounded in the Style Choice Caption dialog box and click OK. The Style Choice Variable

Data group should look similar to the example below.
5. Now that the choice menu is created, we need to create variables used by the drafting process.

Note:

When you are setting captions for a Style Choice menu, the first caption sets the variable to 1,
the second to 2, the third to 3, and so on.

Defining variables with an IF Branch Statement in Advanced StyleMaker
Since variables based on other variables have to be in a menu after the one holding the original
variables, we need to create another menu after Slot Choices. An IF Branch Statement sets a variable’s
value based on a set of defined circumstances; in this case, circumstances defined by the Slot Style
style choice.

1. Click Add Menu in the Menu/Folder group.
2. Enter Slot Radius for the name, leave the menu type set to Variable Menu, and click OK.
3. Click Add in the Variables group.
4. Enter SR for the variable name (for Slot Radius) and click OK.
5. Click f(x) at the end of the Formula field. The Edit Expression dialog box opens with SR showing a

value of 0.
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6. Click Insert IF Branch.
7. In the Insert IF/ELSE dialog box:

a) Enter SS=1 for the IF Expression. This means if the Slot Style is set to caption 1, Squared, then
set SR to the value in the IF Value field.

b) Leave the IF Value field set to 0, as we want the Slot Radius to be 0 when the Slot Style is set to
Squared.

c) In the Else field, enter CAL/, as we want the Slot Radius to be the caliper when the Slot Style
choice is set to Rounded.
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d) Click OK.
8. The Edit Expression dialog box should now look like this. Click OK to return to the Advanced

StyleMaker dialog box.
 

 
9. Click Close to return to Designer.

Creating geometry using a style choice
Now that the style choice and its associated variables are defined, you can use them as you draft.
Since this style choice affects the ends of slots, you will need to have some slots with squared ends
constructed.

1.
 Zoom in on the end of the first slot.
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2.

 Click Blend.
3. In the Status bar, click the keypad at the end of the Radius field and click SR, the variable for the

Slot Radius, to set the value for the field.
4. Click the left edge of the slot and the bottom of the slot to blend them.

 

 
5. Click the bottom of the slot and the right edge of the slot to blend them.

 

 
6. Repeat for the other slots.
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To verify that the style choice works correctly, save the design and then rebuild it. In this case, since
the slot radius was based on the caliper, choosing a very much thicker board has an exaggerated
effect.
 

 

Choosing Squared in the Slot Style menu ensures that they work properly as well.
 

 

Adding diagrams in Advanced StyleMaker
1. Click Design > StyleMaker (and Advanced if necessary).
2. In the list of menus, select the menu for which you are creating a diagram.
3. Click Diagram.
4. Click Create New Diagram. Note the name of the layer.
5. Drag a selection window around the design lines you want to be in the diagram. This step does not

include any dimensions or text that may be inside the selection window.
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6. The design lines and the layer name should now appear in the Attach Diagram to StyleMaker Menu

dialog box. Click OK to return to the StyleMaker dialog box.
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7. Select any additional layers and repeat the process of creating a new diagram.
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8. Click OK to return to Designer.
9. Use the Layers control on the View bar to change to the first new layer. At the same time, turn off

the Main Design and Dimensions layers.
 

 
10. Use the dimensioning and text tools to add dimensions and text. It is helpful to change the value of a

dimension to the name of the dimension so that the name appears during rebuild.
a) Double-click the dimension to change.
b) Click the pencil to the right of the Text field to enable that field for editing.
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c) Change the value in the text field appropriately.
d) Click OK to return to Designer. Repeat for the other dimensions.

 

 
11. Using the Layers control again, change to layer Doc Plot 2 and repeat the process of adding

dimensions and changing them for the second diagram.
 

1117



12 ArtiosCAD

 
12. Now when you rebuild the design, there will be diagrams for each menu.
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Note that you can add any content to diagram layers. Consider what would be useful for you - maybe a
copy of a folded 3D workspace, perhaps - and add what you think is best.

Using Advanced StyleMaker techniques to construct a standard
Creating standards in ArtiosCAD is easy. StyleMaker lets you construct standards with built-in
design intelligence. For example, you can create a design in which the number of slots in the base is
determined by the width of the design.

You must have purchased the Advanced StyleMaker option in order to use Advanced StyleMaker. If you
do not have Advanced StyleMaker, you cannot complete the instructions in this section.

Variables are used to create rebuildable designs. The value of a variable can either be a formula that
tells ArtiosCAD how to calculate the value, or it can be a constant value you specify each time the
design is rebuilt. To make rebuildable geometry, you specify a variable when asked for a distance,
angle, radius, or other measurement.

These instructions assume you already know how to construct geometry and use the tools on the
Geometry and Edit toolbars. In this chapter, you will learn how to make a variable number of slots and
tabs in a design so that you can make a tray similar to the one shown below.
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There are four steps to making a standard:

1. Plan the design.
2. Create the design by creating menus, adding variables, and constructing geometry.
3. Test the design.
4. Add the design to a Style Catalog.

Step 1 – Planning the design

The first step in designing a standard is to plan your design. Is there geometry that will always be the
same, such as an angle setting or the radius of an arc? Which parts of the design need to be made with
variables, and are their measurements dependent on other parts of the design? Be as thorough as
possible.

The number of slots and tabs will depend on the width of the design. The standard will also give you the
option of specifying the number of slots and tabs desired.

What do you know about the slots? You know that:

1. The slots should all be the same size.
2. The gap(s) between the slots and the slots should be the same length.
3. There should not be a slot touching either end of the line it is on.
4. There will be one more gap than the number of slots.
5. The length of each slot should be based on a fraction of the width of the design.
6. The size of the gap between the slots should be the length of the line that the gaps are next to,

minus the distance all the slots take up, divided by the total number of slots plus 1.
7. The width of the slots should be twice the caliper plus the outside gain.
8. There will be times when you will want to specify the number of slots regardless of any formula.

These same bits of knowledge also apply to the number of tabs.

Let’s assign variables and convert these concepts into expressions that can be used as formulae in
ArtiosCAD.

Concept Value

Length, Width, Depth L, W, D
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Concept Value

Caliper of the board CAL

Method of creating slots (automatically or
manually)

SLTMET

Number of slots and tabs SLTNUM

Slot length SLTLEN=W/(2*SLTNUM+1)

Slot width SLTWID=2*CAL

Gap between slots SLTGAP=((W+CAL)- SLTNUM*SLTLEN) /(SLTNUM
+1)

Step 2 – Creating the design

Once you have planned as much as possible, it is time to begin using ArtiosCAD to transform your
creative ideas into a design.

Create a blank design by starting ArtiosCAD and clicking File > New > Design. Choose an appropriate
parameter set and board code.

Enter StyleMaker by clicking StyleMaker on the Design menu.

Click Advanced to enter Advanced StyleMaker.
 

 

Shown below is the Advanced StyleMaker dialog box.
 

1121



12 ArtiosCAD

 

Making menus and creating variables

When you create a new blank design, ArtiosCAD automatically inserts a Board Selection menu so that
you can change the board specifications when rebuilding the design.

Even though variables may use variables previously defined in the same menu as elements of their
default values, the variable values are only saved when the menu is exited, and that variables within
a menu may not reinitialize as expected. You could combine the variables into fewer menus, but that
could affect the robustness of the rebuild process. SLTLEN and SLTGAP should be in separate menus
after SLTNUM is defined. Thus, you need to add five menus.

The first menu should contain the basic dimensions of the design. The second menu should contain
slot style choices – how ArtiosCAD will determine the number of slots in the design. The third menu
should have the variables needed to calculate the number of slots. The fourth menu should have the
slot length variable, and the last menu should have the slot gap variable.

Adding the Inside Dimensions menu

ArtiosCAD comes with a set of predefined menus and variables to aid in the construction of standards.
Click Copy in the Variables group of the Advanced StyleMaker dialog box.
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The Inside Dimensions menu and the variables within it are selected by default. Click OK to copy them
into your design. In the Copy Menu or Variables dialog box, select Copy entire menu and click OK. The
Advanced StyleMaker dialog box should look similar to the one shown below.
 

 

Select each variable and enter a value in the Current Value field. Suggested values are 24 inches or 600
millimeters for the length and width, and 12 inches or 300 millimeters for the depth.

Adding the Slot style choices menu

Click Add Menu in the Menu/Folder group to add the menu for the slot style choices. In the Menu Name
dialog box, enter Slot style choices as the title of the menu. Set the menu type option button to
Style Choice Menu as shown in the figure below. Click OK.

1123



12 ArtiosCAD

 

 

Click the Add button in the Variables group of the Advanced StyleMaker dialog box. Enter SLTMET in
the Variable Name field and click OK.
 

 

Once you click OK, the variable will appear in the list of variables. In the Group title field, enter Slot
style choices. This is what will appear as the title of the group of choices presented when
rebuilding the design. The way style choice variables work is that they set the variable to a value from
a series of values that correspond to the entries you create in the Style Choices group. For example,
the first entry you add sets the variable to 1, the second to 2, the third to 3, and so on. You then build
geometry with the logic of “If X=1 then do A, if X=2 then do B, if X=3 then do C” and so on.

Click Add in the Style Choice Variable Data group and enter Auto as the caption (name) of the first
choice. Click Add again and enter 1 as the caption. Repeat and enter 2 as the caption. Repeat and
enter 3 as the caption. You should have a dialog box that looks similar to the one shown below.
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In this example, when rebuilding the design, if you pick choice Auto, SLTMET will be 1. If you pick choice
1, SLTMET will be 2, and so forth.

Adding the Number of slots menu

Now comes the part where we build intelligence into the design. Click Add Menu in the Menu/Folder
group to add a new menu. Name it Number of slots and set the menu type option button to
Variable Menu and click OK. Click Add in the Variable group and enter SLTNUM. Enter Number of
slots in the Description field. Set the type to Angle or Number in the Type group. Click the formula
button at the end of the Formula field to open the Edit Expression dialog box.
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The logic to build into the design is an IF…THEN…ELSE structure. Click Insert IF Branch. In the IF
Expression field, enter SLTMET=1. In the IF Value field, enter 1. In the ELSE Value field, enter 2. This
means that if SLTMET=1 (if the Slot style choice is set to 1), then set the value of SLTNUM to 1, else set it
to 2. Click OK.
 

 

But when the first Slot style choice is chosen (the Auto choice), ArtiosCAD is to automatically decide
how many slots are needed. Therefore, a STEP function needs to be inserted in the IF statement.
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A STEP function is an expression that uses this logic: When A is less than constant 1, set B to value
X. When A is greater than (or equal to) constant 1 but less than constant 2, set B to value Y. When A is
greater than (or equal to) constant 2 but less than constant 3, set B to value Z, and so on.

Therefore, select the IF SLTMET=1: SLTNUM=1 entry and click Insert STEP Branch.

The number of slots should be based on the width of the design. Therefore, set the STEP variable to
W. When the width of the design is less than 6, only 1 slot should be made; set the Step Limit to 6 and
the Step Value to 1. Set the Otherwise value to 2. Click OK. The Edit Expression dialog box should look
similar to the figure below.

Now we want to add a STEP branch for when the Width is greater than 6 but less than or equal to 12.
Click the STEP Otherwise line and then click Add Step Entry. Enter 12 for the Step Limit and 2 for the
Step Value.
 

 

Repeat this process of adding STEP entries 4 times, increasing the Step Limit by 6 each time and the
Step Value by 1 each time. The final IF SLTMET=1 entry of the IF statement should look like the one in
the next picture.

Now ArtiosCAD knows the number of slots to make if the Auto choice is chosen in the Slot Style
Choices menu. However, IF statements must still be added for the other style choices.
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Click the ELSE: SLTNUM=2 entry and then click Add If Entry. Enter SLTMET=2 in the If Expression field
and 1 in the If Value field. Click OK.

Add two more IF entries with the first having the If Expression of SLTMET=3 and the If Value of 2, and
the second having the If Expression of SLTMET=4 and the If Value of 3. When you have finished, the
Edit Expression dialog box should look like the following picture. Click OK to return to the Advanced
StyleMaker dialog box.

Now that the number of slots has been determined, you can set up the variables for the slot length and
the gap between slots.

Adding the Slot dimensions menu

Click Add Menu in the Menu/Folder group. Enter Slot dimensions for the menu name and set the
menu type option button to Variable Menu. Click OK.

Click Add in the Variable group. Enter SLTLEN as the name of the new variable and click OK. Enter
Slot length in the Description field. Going back to what you know about the slots, enter W/
(2*SLTNUM+1) in the Formula field.

Click Add in the Variable group. Enter SLTWID as the name of the new variable and click OK. Enter
Slot width in the Description field. Going back to what you know about the slots, enter CAL*2 in
the Formula field.

Now that the slot dimensions have been added, the slot gap variable can be added. This variable can
be in the same menu as the Slot length and Slot width variables since it will be a hidden variable as it
should not be modified when rebuilding the design.

Click Add in the Variable group. Enter SLTGAP as the name of the new variable. Clear the Visible
checkbox so that no check appears in it. Enter Gap between slots in the Description: field. Going
back to what you know about the slots, enter ((W+CAL)-SLTNUM*SLTLEN)/(SLTNUM+1) in the
Formula field. You may have to put in a temporary formula in order to clear the Visible checkbox.
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Now that all the menus and variables are defined, design construction can begin. Click Close and then
save the design before proceeding.

Constructing the design

We will draw only half the design as it can be copied using the Copy Vertical Mirror tool to make a
complete design.

Using the Line tool, draw a line at 0 degrees horizontally right from the origin with an X offset of L/2.

Draw a line from the end of line 1 up by SLTGAP. Change this line to a crease by selecting the Select
tool, then double-clicking the line and selecting Crease in the Properties dialog box and clicking OK.

Change to the Rectangle tool and move the cursor in an up and left direction. Set the X offset to
SLTWID and the Y offset to SLTLEN. You should have something that looks like the following picture.

Click the Select tool and select the crease and the slot.

Click the Copy Times Offset tool. The status bar will prompt for the number of copies to be made.
Enter SLTNUM-1 and press Enter. Use the bottom point of the crease as the pick-up point. Set the
angle to 0 vertically. Use the top right corner of the slot as the put-down point. You should have a
construction similar to the figure shown below.
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Use the Move to Point tool to move to the intersection of the bottom length line and the crease with the
slots.

Make a horizontal line to the right using D for the X offset.

Make another horizontal line to the right using CAL*2 as the X offset.

Make yet another horizontal line to the right using D for the X offset.

Make a vertical line going up using SLTGAP as the Y offset.

Make a horizontal line going right using SLTWID as the X offset.

Make a vertical line going up using SLTLEN as the Y offset.

Make a horizontal line going left using SLTWID as the X offset. You should now have a construction
similar to the one shown below.

Use the Select tool to select the tab construction.

Use the Copy Times Offset tool to copy the tabs the same way as you copied the slots. Use SLTNUM-1
as the number of copies, use the intersection of the horizontal cut line and the vertical cut line as the
pick-up point, set the angle to 0 vertically, and use the top left point of the tab as the put-down point.
The result should be similar to the construction shown below.
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Click the View Mode button on the Zoom toolbar and turn on Endpoints in the Styles group.

Use the Move to Point tool to move to the right most point of the group of two points on the bottom cut
line. You may need to zoom in to see the two points.

Use the Line tool to create a vertical line going up using W+CAL as the Y offset.

Use the Move to Point tool to move to the left most point of the group of two points on the bottom line.

Use the Line tool to create a vertical line going up using W+CAL as the Y offset.

Connect the tops of the two lines with a cut line.

Change both vertical lines just created to creases and turn off the viewing of endpoints. You should
have a construction similar to the one in the picture below.

Use the Move to Point tool to move to the top of the right crease.
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Draw a horizontal line to the right using D as the Y offset.

Draw a vertical line down using SLTGAP as the Y offset. IMPORTANT: DO NOT SNAP TO THE TOP OF THE
TAB!

Use the Move to Point tool to move to the top of the left crease.

Draw a horizontal line to the left using D as the Y offset.

Draw a vertical line down using SLTGAP as the Y offset. IMPORTANT: DO NOT SNAP TO THE TOP OF THE
SLOT!

Change this vertical line to a crease.

Draw a horizontal line from the top of the crease just created to the vertical axis. You should have a
construction similar to the one shown below.

Use the Select tool to select all the lines in the design.

Click the Copy button on the Edit toolbar, then click the Mirror About Line button. Click to the
immediate left of the vertical axis. You should have a construction similar to the one shown below. Save
the design!

Construct the rest of the tray using the techniques learned so far.

Step 3 – Testing the design

There are two things to test in this design – its rebuildability and how it actually will work if
produced. Rebuild the design using the Rebuild design command on the Design menu. Use different
combinations of values for the length, width, and depth. Set the slot style choice to something
different every time. You will have to REINIT the Slot Length variable each time you rebuild.

Use 3D to test its worthiness for becoming a production design. Make sure the tabs fit in the slots and
that the rollover works correctly.
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Step 4 – Adding the design to a Style Catalog

To give everyone using ArtiosCAD access to this new standard, add it to a Style Catalog. You should
also put a copy of the design file in ..\Esko\Artios\ServerLib.

1. Exit from any open design so that the only commands on the menu bar are File, Options, and Help.
2. Click Defaults on the Options menu.
3. Right-click Style Catalog in the left-hand pane and pick New, then Data from the context menu.
4. Enter a name such as Custom Tray. Do not press Enter when done; rather, double-click the icon

that precedes the name.
5. Set the Standard Type option button to ArtiosCAD.
6.

Click  and double-click the resizable design you want to add to the catalog. The dialog box
should have the same title as the name you entered, and should look similar to the following picture.

7. Click OK to add the design to the Style Catalog. The Shared Defaults pane of the Defaults dialog box
should look similar to the following picture.
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8. Click File, then Save to save the shared defaults. Next time you run Builder, you will see your custom
design in the catalog listing as shown in the following picture.

Your rebuildable design is now complete and can be used by everyone who uses this installation of
ArtiosCAD.

Additional advanced functions in expressions

In the Edit Expression dialog box, there are a number of functions you can add to the expression. We’ve
already covered using STEP and IF branches.

• UNITS branch. This sets the value of a variable appropriately when ArtiosCAD is running in either
metric or Imperial.

• Round. This rounds the value of the variable either to the closest value, or up to the closest value, or
down to the closest value.

• Min/Max. This constrains the value of a variable with lower and upper limits, or just a higher limit, or
just a lower limit. MIN returns the smaller value because you specify the maximum size. MAX returns
the larger value because you specify the minimum size.

Using a UNITS branch
The UNITS branch allows for a variable to work properly in both metric and Imperial.

When L is set to 4, it will either be 4 millimeters or 4 inches.
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But when L is set to 4 and you replace it with a UNITS branch by selecting it and clicking Insert UNITS
Branch, ArtiosCAD will know to convert it to 101.6 millimeters for metric or leave it as 4 inches for
Imperial.
 

 

Using a rounding function
Click Insert Round to insert a rounding function.
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First choose the type of rounding to perform and then enter the increment by which to round in the
Round Limit field.

Click OK to return to the Edit Expression dialog box.

Note:

You can achieve this same functionality using the Rounding and Round To fields in the
Advanced StyleMaker dialog box.

Using a MINMAX function
Click Insert Min/Max to insert a minimum/maximum function that lets you constrain the value of the
variable to be in a certain range.
 

 

Note:

When you insert a MIN, the value for the variable will always be larger than that limit. When you
insert a MAX, the value for the variable will always be smaller than that limit. Some people find
this logic opposite from what they expect.

When you choose a MINMAX function, you enter the value of the variable as you would like it calculated,
and then you enter its minimum value (what it will be if its calculated value is less than the minimum
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you specify) and its maximum value (what it will be if its calculated value is greater than what you
specify). For example, if you want the glue tab width to be between ¼” (its minimum) and 2” (its
maximum) but if a half of the width falls between those two values, it can be that, you would have a Min/
Max function definition looking like this.
 

 

When you rebuild a design using the above function, when the width is 1/3, the glue tab width will be ¼.
When the width is 7, the glue tab width will be 2.

Using a MIN function and a MAX function work the same way, but with only one limit.

For example, if you want the glue tab width to be half the width, but never more than 1, select a MIN
function, enter a value of W/2, and enter a limit of 1. When the width is 4, for example, half of that
would be 2, but since there is a limit of 1, the glue tab width is set to 1.
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Likewise, if you want the glue tab width to be half the width but never less than 1, select a MAX
function, enter a value of W/2 and enter a limit of 1. When the width is 1.5, the glue tab width will be 1.
 

 

Rebuilding a design

Rebuilding a design lets you change the values of the variables you have defined. The process is similar

to running a standard. Click Rebuild  on the View bar, or click Rebuild Design on the Design menu
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and enter new values in the fields next to the variable names. When you are done entering new values,
click OK.

Designs based on a pre-LASERPOINT IQ 2 version of LASERPOINT will be rebuilt using a black text
window as they were in LASERPOINT.

Rebuilding a design with Rebuild Playback

 The Rebuild Playback tool on the Undo/Redo toolbar and the Design menu lets you rebuild a
design step by step while looking at the design as it is rebuilt. This is a powerful feature. Always save
your design before using this command.

Note:  Any commands in the Undo/Redo buffer are lost when you enter the Rebuild Playback
tool. Perform all desired Undos and Redos before starting this tool.

When you make a rebuildable design, ArtiosCAD records each mouse click, menu command, and tool
selection you make. These commands and procedures are stored in the design file itself. ArtiosCAD
rebuilds the design by executing these stored commands with the updated variable values that you
specify. When you rebuild a design normally, ArtiosCAD takes the new values and completes the new
geometry automatically. The Rebuild Playback tool provides more control over the rebuild process.

To use this tool, click Rebuild Playback. The following tools will appear in the Status bar.

The Position scroll bar lets you step through each step of design construction, with the left most end
being the unbuilt design, and the right most end being the built design. The single arrow buttons move
the progress indicator by one step, while the double arrow buttons move to either the unbuilt design
(the arrow pointing to the left) or the built design (the arrow pointing to the right). As you click the
arrows, you will see the design being built. You may also drag the scroll bar button to rebuild the design.

The Edit button is described in depth in the following section.

Clicking OK accepts the changes you made. If the scroll button on the Position slider is not fully to the
right, you are asked if you want to finish the design with the rest of the commands as they are, or if you
want to ignore them. Choose appropriately and then click OK.

Editing the command history
When the Rebuild Playback tool is active, the Edit button on the Status bar brings up the Edit Log
dialog box where you can change the commands used to rebuild the design.
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The current command is shown in the Command field. You can modify the command directly, or you
can just change its parameters by entering new values in the fields in the Parameters group. Each
command has different parameters.

There are three parameter types. The parameter type affects the button at the end of the parameter
input field.

•
 In the example above, the button is the keypad since both parameters are numeric. To change

a numeric parameter, enter a new value, enter a variable or expression (you will be prompted to
define the variable if it does not exist yet), or use the buttons on the keypad to indicate distances
and angles.

•
 When the parameter refers to a line, the button is Select line. If you click it, you can

then choose a different line to be made with the command. Use this with caution!

•
 When the parameter in the Edit Log dialog box refers to a point, the button is

Select point, and the point is highlighted in the design area of the ArtiosCAD window. If you click it,
you can then choose a different point to be acted on by the command. Use this with caution!

The arrow buttons step through the construction commands just as they do on the Position scrollbar.

Note:  Use the bottom right corner of the dialog to resize this dialog as you wish. Its new size
will be remembered.
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To select a command to modify, click it with the mouse, or move to it using the arrow keys on the
keyboard.

The Freeform editing checkbox toggles the display of the Command and Parameter groups. Make
changes to the commands by selecting them and then typing over them as you would in a word
processor. There is a limit of 4096 characters per line. When in Freeform editing mode, the Update
button updates the design.

The Save and Restore buttons let you save the commands to a text file and then restore them if
desired. This would be convenient in case you made changes you did not mean to make.

Rebuild Playback notes and warnings
The dimension, Fill, and Stroke tools are not affected by Rebuild Playback.

The SET, DSET, IF, TRY, and LABEL commands cannot be used in the Rebuild Playback tool.

The Rebuild Playback tool works only with the commands saved in the design file and commands
stored in the Undo command buffer. These are set up when the design is first rebuilt. If a restored
design has never been rebuilt, starting the Rebuild Playback tool will start the rebuilding process first.

Define all desired variables in StyleMaker before running Rebuild Playback. Do not define variables in
Rebuild Playback as this may lead to unpredictable results.

Designing for Re-board
®

Re-board
®

 is a thick board made from recycled paper. Using it requires some different design
techniques in ArtiosCAD from working with regular boards.
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When you begin a design for Re-board
®

, use Inside view, Blade Down side, and draw up and to the right
to get the most sensible results.

When working with Re-board
®

, you must choose the proper V-notch line types when designing a single
design. ArtiosCAD comes with crease types and cut types in the special rule catalog as shown below,
but you can add others of your own specification to the catalog as desired.
 

 

There are also generic Sample V-notch crease and Sample V-notch cut linetypes, along with a Sample
reverse V-notch crease line type for use in samplemaking.

Note:

If you will be using the variable angle tool on a Kongsberg samplemaker that uses IPC on the
front end, use the Generic v-notch line types in the V-notch section of the Generic Types
catalog instead of the special rule types and set the angle accordingly. When you use those
generic types, anywhere you can set the pointage of the line changes to a prompt to set the
angle. Also, make sure to use the iPC-Submit Job Output in the iPC catalog rather than a
samplemaker-specific Output.

Because the knife on a samplemaker that cuts V-notch lines is not vertical, but instead is at an angle,
there is a top to the cut (where the knife enters the material) and a bottom to the cut (the point at
which the material rests on the table). The V-notch cut lines draw double lines but act as generic cuts
when determining area, making a layout, and so forth. The principal black line shows the bottom of the
angled cut, which is the line you draw, and the auxiliary red line shows the top edge of the angled cut. If
the top red line does not affect the printable area, ArtiosCAD shows it as a dotted line.

ArtiosCAD fills area between the two lines to make it easier to understand what will be cut on a
samplemaker. Dark yellow shading means you can see the medium between the two liners. Gray
shading means you are looking at the bottom of the board and can't see the medium. Light yellow
shading means ArtiosCAD cannot determine which side it is because the shape is not closed.
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Consider the following constructions all shown in the inside view and Die Back side, and their results in
3D, inside view.

In this example, the black lines are reverse 30-degree V-notch cuts. Because the shading is gray, you
can't see the medium, and because the red lines are dotted, they do not affect the print area size. The
bevels are going toward the center of the design.

 

 

When you convert to 3D:
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In this example, the black lines are again reverse 30-degree V-notch cuts, but note the line direction is
opposite from the previous example. Also note that the shading is dark yellow, which means you can
see the medium.
 

 

When converted to 3D:
 

 

In this example, the black lines are 45-degree V-notch cuts. There is a V-notch crease in the center of
the design.
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When converted to 3D:
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Lastly, in this example, notice the gray shading indicates you cannot see the bevel. Also notice the red
lines extend a bit. This is because this is required to actually cut the design.
 

 

When converted to 3D, you can only see the inside of the design at this view angle. All the bevels are
not visible.
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If you flip the design in 2D, areas that were dark yellow change to gray, and areas that were gray change
to dark yellow.

 Before flipping using the Side toggle on the View bar:
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 After flipping:
 

 

However, if you use the Blade Side toggle, the position of the workspace remains the same, but the
bevels flip direction.

 Blade Down side:
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 Blade Up side:
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Reverse V-notch cut lines as necessary using Reverse Direction before doing a sample Output. When
you reverse a V-notch cut, the red line flips from one side to the other. Sample output sequences
normal cut lines but does not change the direction of V-notch cuts; ArtiosCAD outputs in the direction
you drew them.

Note:

Curved lines are not supported for V-notch lines and Re-board
®

 does not bend.

Note:

To make a cut or crease on the reverse side of the board, check Reverse side on the Special
rule tab of the Properties dialog box for the rule in the workspace or in Options > Defaults >
Special rule types > <Rule type>.
 

 
When you enable this option, when Partial cuts fold outward is enabled in the board definition,

• Partial cuts fold outward
• V-notches fold inward
• Reverse V-notches fold outward and are cut in a clockwise direction

If you use Mirror or Copy Mirror on V-notch cuts, ArtiosCAD reverses the line direction so the bevel cuts
on the same side as the original lines.

Extending V-notch Cuts

When you are designing corners with V-notch, you need to extend the lines so that the corners actually
meet and the design can be separated from the sheet.
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Design Checks will show a gap and that error will often be caught by Convert to 3D as well.
 

 

 Use Trim/Extend 1 Line for this.

Extend one black line to meet the top line of the other V-notch cut.
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Repeat for the other one.
 

 

Compression Bends

Compression bends are formed when you fold Re-board
®

 back on itself. The paper on the top of the
board is torn off, exposing the inside cells. In Designer, ArtiosCAD shows this as a special rule with
generic type crease with a bend line offset to either side. The area between the two bend lines is the
paper that is torn off.
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If a compression bend intersects with an angled cut line, create the geometry so that both bend lines
meet the cut line.

For sample output, ArtiosCAD puts partial cuts on either side of the crease line. If you use custom
plotting styles, make sure to update them with entries for the compression bend special rules.

The design shown above looks like this in 3D:
 

 

To set the properties of the compression bend, double-click its crease line and click the Special rule
tab of the Properties dialog box.
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The compression factor and the board caliper define how close the two sides of the bend can get to
each other. The compression factor is the inside radius of the bend divided by the outside radius of
the bend. With a factor of 0, the two legs of the bend can be parallel. The compression factor must be
between 0 and 0.8.

Reverse side makes a reverse compression bend cut from the reverse side.

In 3D, to change the side of the board on which the compression bend appears, double-click the design
with Select Designs and deselect Partial cuts fold outward on the Board Information tab.

At this time, you cannot change the texture ArtiosCAD shows from within ArtiosCAD. If desired, make a
backup copy of ..\Common\reboardtorntop.jpg, and then put your desired image in that file. It
should be a 16mm square that repeats a pattern.

Note:

Do not cross compression bends with other compression bends or creases.

Curved compression bends are not supported.

Notes and Warnings

Please keep these considerations in mind when designing for Re-board.

ArtiosCAD supports one internal hole per panel in a Re-board design. You may think the appearance is
incorrect since it should match the outer edge, but this is correct as the angled cut does not appear
until the waste is removed from the hole.

Holes with creases are unpredictable when converting to 3D.

• Internal holes

• The internal holes appears it will be cut with same line type and direction. But note, its
appearance does not look like the outside edge. This is correct. This is because the cut is
occurring into the middle of the material, and the angled cut does is not manifest until the waste
is pushed out of the hole and cleared away from the main design.
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• ArtiosCAD will be able to properly support one hole in the middle of a V-notch pad. If there are
multiple holes in a panel, or creases running through holes, the results are unpredictable.

• Holes with creases are undefined when converting to 3D
 

 

• Sample/blank size

• This will be the area bounded by the originally drafted lines, which represent the tool path. The
samples below were all drafted using the rectangle tool, X=10, Y=10, inside view. A, B are cut in
a CCW (counterclockwise) rotation. Each has a crease down the middle. With samples A, B, two
panels of width 3 now result. Sample C reverses the lines which are now cut CW (clockwise).
Given the single direction of the knife, with the tool path being the black line, and the knife top
being the red line. the sample technically expands on one of the viewing sides.
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• Case C can't be separated from material, until cuts lines are extended as in D. For case C,
ArtiosCAD will recognize the offset lines as part of the blank size and for placing registration
marks.

• For area, area w/ holes (internal hole), there is an ambiguity. One side of a hole created by V-
notch will be smaller than the other due to the cutting angle offset. It is not clear which side
should be considered in such a calculation. The originally drafted area will be considered for the
area.

• The sample size when running a samplemaking Output will be the originally drafted lines.
 

 

• From 3D:

• Convert to 2D

• Once a V-notch design is created in 3D, Convert to 2D will not produce the correct lines

• Dimensions

• The corners of a cut area are not accessible as a snappable/dimensionable point
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• Graphics (registration,color stock, fill panel, fill)

• ArtiosCAD does not know how to find net visible panels or offsets for graphics. Much of this
is irrelevant for Color Stock and Fill Panel when converting to 3D as the Re-board textures
will take precedence. Any registered graphic will appear in 3D and be clipped against the lost
material.

• Register Graphics will register a graphic to the originally drafted lines, not the offset
lines. V-notch lines are not accounted for as lost material in 2D.

• Color Stock fills the entire design with the selected color.
• Fill operates on selected lines that form a loop. The color is a property default. Offset lines

are not selectable; therefore, it is not possible to fill just the resulting visible panel.
• Fill Panel finds the panels created by the crease but the offsets lines are ignored.

• Cutting circles/arcs

• ArtiosCAD will render and Output arcs with a minimum radius and factor the material
thickness according to this formula: 1.5 *caliper + vnotch_offset_width, = (1.5 +
tan(vnotch_angle))*caliper

• ArtiosCAD will not Convert to 3D in these cases, but will still allow the lines to be cut

• 0 degree V-notch

• A 0 degree V-notch cut will appear like a cut and be converted to 3D as a cut. Its line type will
still be generic V-notch.

• a 0 degree V-notch crease will appear as a crease but error when converting to 3D. It’s a
nonsensical operation.

• Mixing special rule V-notch and generic V-notch in the same design

• Pick one or the other and avoid mixing the different types in a workspace.
• Canvas and Manufacturing layouts

• When creating a layout of V-notch parts,  knife-to-knife/straight nesting is not supported.
Neither the overcut indicator (A) nor offset lines outside the cut (B) are considered in the layout
placement. Gutters need to be used.
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• Export to common file formats

• DWG, DXF

• When outputting, the ArtiosCAD tuning has no provision to save out the generic V-notch
angle. DWG, DXF may have tags for additional parameters, but they are not used. Even so,
maybe a moot point as for line types, pointage is tuned on import. A generic V-notch angle
is on the same level as pointage and would be tuned on import as well. Generic V-notch is a
tunable line on import, but no provision for importing an angle exists so if used, the angle
is assumed to be a pointage and said angle is imported incorrectly (but easily fixable in the
design). Currently, special rule V-notch does not export as a V-notch, but as the generic type
(cut or crease). No functionality is lost.

• CF2, DDES(3)

• These formats do not specify an angle, so although the generic V-notch has a line type which
is exported, the angle is also exported as pointage and is incorrect. However, note that
special rule V-notch is exported as a its generic type (cut, crease), and the old pointage is
exported, so the angle is lost altogether. No functionality is lost.

• Samplemaking

• Samplemaking Output is not supported for generic V-notch designs due to the variation in
angle. The ACM format has no provision for specifying an angle parameter for the tool and
consequently only one tool is allowed. However, the user can still navigate to a samplemaking
output. If there is a generic V-notch crease in the design, ArtiosCAD will first report Pointage 0
creases cause incorrect channel width in the counter. This is because ArtiosCAD still thinks the
generic V-notch is a crease. This issue can be safely ignored; however, the resulting ACM is still
not correct.

• Consequently, there are no Plotting Style > Sample line types of generic V-notch crease/cuts.
• ArtiosCAD users should use an iPC Output to send such workspaces to iPC, rather than using

a Samplemaking Output.

• Beziers

• A V-notch design with beziers is possible and ArtiosCAD will allow the user to add beziers. But
just like any samplemaking output, the bezier needs to be converted to arcs so the machine can
handle a consistent radius. There is little motivation to use a bezier as geometry for V-notch.

• Forward compatibility

• An existing design with special rule V-notch and beziers in the design can be opened in
ArtiosCAD. If the line types are changed to generic V-notch on the bezier, ArtiosCAD is not
handling the side correctly. There should be little motivation to do this as such a design will
likely be all the same angle anyway,
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• Overlapping offsets will be dicult to render in 3D. There is a V-notch crease (green lines) and V-
notch cut (red) lines) where the offsets (lighter color) overlap. There will be no resulting top left in
this area after cutting.
 

 

• Acute angles

• Rendering in 3D of acute angles has a triangle in the valley.
 

 

• Notes:
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• V-notch is generally cut with inside up. Of course, if there is a reverse cut on the print side, then
the material has to be flipped over. The general workflow when drafting is to consider the inside
up.

• Reverse V-notches are generally considered to be on the print side and are cut by reversing the
material (print side up)

• A V-notch crease is a double cut, one in each direction.
• In ArtiosCAD, the (originally drafted) black line is the tool path (the lower knife tip). The red line is

the bevel offset (upper part knife).

• Initial line sequencing of panels (rectangles) in ArtiosCAD is based on the starting point (1st line)
and drag direction.

• This will affect the which the appearance of the material as presented to the user. Envision
the knife being immersed into material and combine the tool path and the line direction to
see how the resulting cut will be performed.

• What type of V-notch cut is presented to the ArtiosCAD user is very much influenced by
the line direction. Not so the crease because it is a double cut and needs to occur in both
directions regardless.

 

 
Now change the V-notch cut to reverse V-notch cut and see the influence.
 

 

• ArtiosCAD V-notch sequencing and line direction on output is based on the design. No special
processing is done.

• However it is unclear how much iPC would rely on ArtiosCAD sequencing:

• The Kongsberg toolhead generally moves in a CCW direction. It is not clear that it moves in
an opposite direction based on ArtiosCAD sequencing.

• V-notch cutting of the board edge is hardly ever done.
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• ArtiosCAD drafting

• Perspective that ArtiosCAD uses is that:

• Cutting is from the die back side, which by default is inside

• Reverse creases and cuts are done from the opposite cutting side, which by default is
outside

• For example, if the cutting side is the inside, user is viewing the outside, and a V-notch
crease is added, the user will see gray, because the crease is on the inside. Likewise,
if a reverse crease is added, the user will see the yellow, because the crease is on the
outside. If the user switches to the inside, the colors are switched.

• Tool head movement is counterclockwise

• Clockwise V-notch cuts always extend the material

• For example, if viewing the inside and the panel lines are counterclockwise, V-notch
cuts will appear yellow and within the original drafted panel. If the cut is reverse, the
color will appear gray and also within the panel. If the material is flipped, the colors will
also flip but still be within the originally drafted lines.

• For example, if viewing the inside and the panel lines are clockwise, V-notch cuts will
appear gray (as if reverse) and extend the original drafted panel. If the cut is reverse, V-
notch cuts will appear yellow (as if current side) and extend the original drafted panel.

• Reverse V-notch versus line direction change:

• Reverse crease/cut always means from the non-cutting side
• A line direction change of a V-notch cut has a visual cue as though it were a reverse

cut, but that is not the case. The material side remains in place and the knife direction
changes. This knife is inserted into the material on the same side and the result is just
a different cut orientation.

• Both result in a similar cut angle. However, the reverse cut assumes the material is
flipped and therefore there is no material expansion, The line direction is from the
same cutting side, and with a rotation of the knife of 180 degrees along the same path,
results in expanded material.

• <User workflow> The user should start with a Single Design parameter set > ... > Side that
reflects inside/die back/blade down side as this is the perspective for cutting on the table.

• <User workflow> Edit > Change Line Type should be mapped to a shortcut for easy access to line
types

• iPC user experience

• The iPC user experience is expected to be that V-notch lines + angle will be presented to the
operator in separate iPC layers. The operator does not need know what lines represent what
angled tools (even if iPC preset mappings are used).

• Currently, iPC scans the workspace and imports unexpanded V-notch lines, for example, it
simply extracts the V-notch line name. In this case, with the proper string name, the operator
can implictly map the V-notch line type (angle) to an iPC preset layer.

• With the variety of angles in a job, the angle should now be returned to iPC. Coupled with
the fact the special rule names are text and ultimately user-defined, regardless of the fact
that ArtiosCAD can create them dynamically matching a format that could be decoded by
iPC, text strings are not 100% reliable. It is best that V-notch data be returned.
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Designing Retail-Ready Containers

More and more, retailers are asking for retail-ready packaging in which part of the shipping container
is torn off, the remainder is used as a display for the contents, and the whole thing is put on the shelf
ready for customer selection and purchase.

In Single Design, there are special ways to design these features which you can then easily show in 3D.
This section explains how to do the underlying design work.

Defining Tear-Away Parts

To define the tear-away parts:

• Use perfs or zippers
• Use cuts with gaps between them
• Use a combination of the above methods

Note:  Curved creases can tear or fold but not both.

1. Design the parts of the container that will tear away with perfs and zippers. In the example below,
lines labeled 1 are zippers set to tear and fold and lines labeled 2 are perfs set to tear.
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When a special rule has a sequence of lines like the example shown above, use the Group Sequence
tool to group and align them.

2. Alternately, use a series of cuts and gaps to define a tear-away part, such as the custom zipper
shown below.
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To define the outline of the tear-away part, add tear lines in a 3D Assist layer. The tear lines can
either be individual lines that join the cut segments, or they can be two continuous lines over the
zipper rules as shown below.
 

 
3. As the last design task before you convert the design to 3D, double-click the perfs or zippers with

the Select tool and set them to either Tear or Tear and fold on the 3D tab of the Properties dialog
box. If you cut and paste any lines with these attributes, you need to reapply them to the pasted
copies, as that attribute is not copied.
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Intelligent Counters

Counters are special templates made out of phenolic resin (plastic) or steel which are used in folding
carton manufacturing. They are part of the die press tooling and are positioned between the folding
carton stock and the bottom plate of the press. They aid in the production of creases by providing a
place for the material to flex into when struck with creasing rule.

The Intelligent Counters module of ArtiosCAD automatically creates counters with just a few mouse
clicks for most designs. Shown below is a typical plastic counter.

Shown below is a single steel counter with milled channels and an embossed area for a similar design.
ArtiosCAD can also make steel counters in manufacturing files.
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The edge of the plastic counter, the periphery, is shaped as it is because it has to go outside the
creases but stay inside the cuts. It also needs to go far enough inside the cuts to avoid making marks
on the board. Thus, a compromise has to be reached at the places where cuts and creases meet. This
compromise is the subject of most of Intelligent Counters’ setup parameters.

There are fourteen line types used for making counters:

Table: Counter line types

Line type Description

With grain channel Crease channels for with grain creases (those that are parallel to the
grain of the board.

Cross grain channel Crease channels for cross grain creases (those that are perpendicular
to the grain of the board). Usually 0.004 inch wider than with grain
creases.

Crease end tool Cuts off the end of the crease channel where it meets a cut.

Periphery tool Cuts out the counter with a bevelled edge.

Chamfer tool Trims the edge of the counter with a gentler slope (except near
creases) than the periphery tool.
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Line type Description

Reverse chamfer tool Trims the edge of the counter in the opposite direction as the
chamfer tool.

With grain slot Cuts a slot for a with grain cut-crease.

Cross grain slot Cuts a slot for a cross grain cut-crease.

Counter slot Makes holes in a steel counter frame. Must be a complete loop.

Name tool Etches an identifying label into the counter.

Position holes tool Cuts the outline of the position hole, usually a circle.

Position holes tool 2 Second position holes tool, if using two tools.

Counter mill outline Outline of area to be milled, for reverse creases, reverse partial cuts,
or for embossing.

Milling tool Mills out an area with a series of parallel lines.

These line types are mapped to physical tools by the CAM Tooling Setup, and they are offset or
multiple-passed as necessary to allow for the tool widths.

Note:  When using the milling tool, areas to be milled that are exactly the same width as the
milling tool may sometimes be overlooked. In these situations, adjust the size of the area by
0.05 mm to allow the area to be milled.

Configuring Intelligent Counters

Intelligent Counters uses parameter sets to organize its parameters into easily-selectable groups. You
must choose a parameter set when creating a counter. Several default parameter sets are installed
with ArtiosCAD; some for plastic counters and some for steel counters. See the Defaults chapter for
more information.

Intelligent Counters workflow for plastic counters

The general steps in making a plastic counter are as follows:

1. Construct your design making sure the perimeter of the design has no gaps and is composed
entirely of cut lines.

2. Click the Create or Rebuild Counter tool on the Counter toolbar. Choose a counter parameter set
and make appropriate selections in the prompts and options on the tabs.

3. Click OK to create the counter.
4. Add a name, tack bridges, and straps as appropriate.
5. Modify counter lines if needed.
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6. Save the design and output it to the countercutter.

Creating and modifying a plastic counter

The tools on the Counter toolbar create and modify counters. Turn on the Counter toolbar by checking
its box in the View > Toolbars dialog box. Alternately, you may turn it on via its button on the ToolRack,
and you may select the tools directly from the Tools > Counter menu.
 

 

 The first tool on the Counters toolbar is Create or Rebuild Counter. When clicked for the first time,
this tool prompts you to select a counter parameter set. Select the set to use and click OK.

If your current layer is not a counter layer, you are prompted to create one. Click either option as
desired and then click OK.

1170



12ArtiosCAD

Creating a counter disables the rebuildability of a design. You can either save the design before
proceeding, disable rebuild and go on without saving, or exit the counter creation process. Select the
desired option and click OK.

Once you have chosen a parameter set, this tool opens the Create or Rebuild Counter dialog box which
is the heart of Intelligent Counters.
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Clicking the equal-sign button at the end of a field recalculates the value in that field according to the
formula in the counter parameter set. You can change the value itself in the field, but to change the
expression used to calculate the value, you must modify the parameter set in Defaults.

The Rebuild Creases Only checkbox appears only when rebuilding a counter, and when clicked, causes
this tool to only recalculate the crease channels. This option does not appear in the parameter set
Defaults.

Crease channel widths tab
The Crease Channel Widths tab of the Create or Rebuild Counter dialog box lets you specify different
crease channel widths for with-grain creases and cross-grain creases after you have assigned them
different subtypes in the Counter layer. You may define the subtypes and channel widths before
creating or rebuilding the counter; the channel widths are set appropriately on Output.
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In the Crease Channel Width group, With Grain: and Cross Grain: are the initial values for crease
channel widths of creases with no subtype assigned, or with a subtype defined that is not defined in
the table of additional widths. These are initially set by the parameter set, and are repeated from the
Crease Channel Width group on the Tool Angles, Widths tab. The equal-sign buttons at the end of each
field reset the field to the value calculated by the formula for that field in the counter parameter set.

In the Additional crease channel widths group, you can define up to nine subtypes with different
widths for with grain creases and cross grain creases in the appropriate fields.

You may also set the crease channel widths without rebuilding the counter by clicking Tools > Counter
> Crease Channel Width.

Note:  Rebuilding the counter removes any subtype assignments previously made. You must
reassign the crease subtypes to lines in the Counter layer after rebuilding the counter. The
subtype definitions are not cached; you will have to re-enter all the information.

If there are creases of the same subtype but different pointages, the channel widths from the table are
used for the crease with the minimum pointage of that subtype, and creases with higher pointages get
larger channel widths offset by the difference in pointage.

For any crease with a subtype defined in the Additional crease channel widths group, each subtype
defines a specific channel width regardless of crease pointage. A 5-point with grain crease, for
example, will have the same channel width as a 2-point with grain crease if both with grain creases
have the same subtype applied.

Shown below is an example of wider channel widths in an Output made to a workspace layer. The top
horizontal crease and the bottom right vertical crease are both wider than the default.
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Note:  The channel width adjustment using subtypes is meant to be small. The periphery tool
path is not adjusted to compensate for the different channel widths.

Periphery tab
The Periphery tab of the Create or Rebuild Counter dialog box contains settings which affect the
periphery tool.
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The parameters on this page of the dialog box are all measurements whose functions are illustrated in
the pictures next to them except for the Periphery Tool Angle. The angle specified in the Periphery Tool
Angle field, along with the thickness of the counter material, determines the width of the periphery.

 Crease End tab
The Crease End tab of the counter parameter set dialog box controls how the crease ends are
machined.

The options in the Crease End Option group, Use Periphery Tool Only and Use Crease End and
Periphery Tools affect the display of the rest of the tab. If Use Periphery Tool Only is selected, all the
pictures change to omit any reference to the Crease End tool.
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Partial cut tab
Partial cuts and glue assist lines can have the counter extend underneath them if you so desire.

By default, Partial Cuts are set to be On the counter. Glue assist lines are set conditionally by default.
They are off the counter if the distance between the crease and the closer end of the line is greater
than the minimum specified in the Minimum field. Of course you can specify them to be On or Off for
this counter.

Cut and Crease tab
The options on the Cut and Crease tab affect the creation of bowties, which are special constructs
made necessary by having cuts and creases of such short length. All of the options are explained in the
pictures.
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Chamfer tab
The options on the Chamfer tab affect the counter at those places in the design where cut lines and
the ends of crease lines meet. The chamfer mostly follows the periphery except it always stays a
specified distance away from crease channels.

The Chamfer Gap is the distance between the inside edge of a chamfer and the crease channel. The
Pickup and No Pickup options control whether the chamfer is continuous around the end of the crease
channel. The Chamfer Tool Angle is the angle of the tool, which, together with the thickness of the
counter material, determines the width of the chamfer channel.

The Rebuild Chamfer button does what it says.

Reverse Creases tab
Reverse creases are used to make a panel fold outward instead of inward.
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The Insert option indicates that a piece of foreign material will be attached to the counter to create
the reverse crease. This is shown in the top picture on the tab. Counter material means that an area
around the reverse crease will be milled out so that the board gets pushed into the depressed area.
This is shown in the bottom picture on the tab. The Crease Width field becomes available when this
option is selected. Off the counter disables all the fields.

Reverse Cuts tab
Reverse cuts are made on the counter in the same way as the Insert method for reverse creases. The
parameters on the Reverse Cuts tab are explained in the picture.

Embossing tab
An area of the board can be embossed by milling out the part of the counter surrounding the embossed
area. An area is milled out in the counter half-crease channel width inside the half-crease lines,
forming one side of a crease, thus making a raised emboss area. A relief is milled out on the outside
of the half-crease lines to avoid making the other half of the crease channel. As with other tabs, the
parameters on the Embossing tab are explained in the picture.

Position Holes tab
The Position Holes tab contains one parameter - the workspace name for the position hole. Click
Specify to browse for a new workspace. In order to use the Allow for tool diameter option on the
Counter Tool Widths tab in Outputs, you must make the outline of the hole in this workspace using the
positioning hole tool line type. You should put any workspace you create in ServerLib.
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Tack Bridges tab
The Tack Bridge Width field on the Tack Bridges tab sets the width of tack bridges in the periphery of
the counter for the next time the tack bridge tool is used, and it also sets the width of the tack bridges
created automatically for bowties.

Name tab
The choices on the Name tab affect the output of the Name tool on the Counter toolbar. These choices
include the font to use, its size, and its position, as shown in the picture.

Once you have finished reviewing the options on the tabs, click OK to make or remake the counter and
dismiss the Create or Rebuild Counter dialog box. Click Cancel to cancel the creation or modification
of the counter. Click Apply to apply the changes you made to the options on the tabs while keeping the
dialog box open.
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 The second button on the Counter toolbar activates the Rebuild Chamfer tool. Clicking this
tool rebuilds the chamfer in the current counter layer. If you have made any manual changes to the
chamfer, they will be lost. This tool also resequences the periphery lines into loops; if you have made
any changes to the order, the changes will be lost.

 The third tool on the Counter toolbar activates the Add Counter Name tool. This tool uses
the options on the Name tab of the Create or Rebuild Counter dialog box to place the name of the
workspace on the counter. Fields appear in the Status bar containing the attributes of the name.

The only thing different about the fields on the Status bar compared with those on the Name tab is the
... button after the Text field. This button leads to the Burn Name dialog box, and by clicking it, you can
enter a counter name spanning multiple lines of text.

Enter the text for the first line, press CTRL-Enter, enter the second line of text, and so forth, and then
click OK. A ghost drag image of the text will appear under the cursor. Position it and click to place it on
the counter. This tool remains active after placing the name; click another tool to deactivate it.

 The Add Counter Tack Bridge tool is the fourth tool on the Counter toolbar and does just what it
says. Click this tool, then indicate the position in the periphery where a tack bridge is to be placed. A
tack bridge will be placed at the point you indicate with the width shown in the Tack Bridge Width field
on the Status bar.

 The fifth tool on the Counter toolbar is the Delete Counter Tack Bridge tool and it, too, does just
what it says. Click this tool and then click the tack bridge(s) to be deleted.

 The sixth tool on the Counter toolbar is the Add Counter Strap tool. Straps are thin pieces of
counter material that hold delicate counters together. Straps are made using the periphery tool and
are milled where they cross cut lines.

You should use this tool after designing the rest of the counter. To use this tool, do the following:

1. Make sure your counter is complete except for the straps.
2.

 Click the Add Counter Strap tool on the Counter toolbar.
3. Click the point in the periphery where you want the first side of the strap to start.
4. Click the ending point of the first side of the strap in the periphery.
5. Click the start point in the periphery for the second side of the strap.
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6. Click the ending point in the periphery for the second side of the strap.

You should have a construction that looks similar to the one shown below.

 The seventh tool on the Counter toolbar is the Select Periphery Lines tool. As periphery lines are
often close to other lines, selecting them alone can be imprecise using a normal Select tool. Use this
tool to select only lines made with the periphery tool. This tool has the same selection options on the
Status bar as the Select tool in Designer. Once the periphery lines are selected, you can then move
them, delete them, change them, and so forth.

Viewing the counter

To view the actual paths made by the counter tools, check the Counter channel widths checkbox in the
View Mode dialog box. Shown below is a counter with the Counter channel widths option off and then
on.
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Note:  Milled areas are not shown filled in with mill tool lines when the Counter channel widths
checkbox is selected. They are only shown in the Preview dialog box of the Output.

Counter Position Holes

Counter position holes are made by inserting Laser Positioning Holes into the single design before
creating a counter. Add Laser Position Holes via Tools > Geometry Macros > Utilities > Laser Position
Holes.

Construct the Laser Positioning Holes design file with the origin at the center of the hole using
symmetrical geometry and consecutive lines. Use only the Positioning Hole Tool line type and the
Positioning Hole Tool 2 line type in the Laser Positioning Holes design file.

Switching counter parameter sets

To switch to a different counter parameter set after choosing one initially, click Change Counter
Parameter Set on the Options menu. You should rebuild the counter after changing the parameter set.

Outputting imported INTERACT and LASERPOINT IQ counters

INTERACT counters use different line types than those used in ArtiosCAD. You must change all the
counter lines to ArtiosCAD line types by hand.

When outputting imported LASERPOINT IQ counters, use a Plot output type instead of a Counter
output type when configuring the Output.

Intelligent Counters workflow for steel counters

Making steel counters uses a different workflow from plastic counters. Most people will make a single
sheet of steel counters in Manufacturing instead of making individual counters for each station of
a single design. You can create the counter inside the single design(s) and then create the frame in
Manufacturing, or if the counter is simple enough and you do not need to do any manual changes to
it, ArtiosCAD can create the counter layers in the embedded designs in Manufacturing along with the
frame.

1. Make your manufacturing file out of single designs and nest them as desired.
2.

 Add a dieboard edge using Create Wood Edge.
3.

 Click Create or Rebuild Counter.
4. In the Rebuild Counter dialog box, Rebuild frame and Oneup(s) counter layer are checked by default

if this is the first time you are creating the counter. Set these as desired and click OK.
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5. Select a parameter set and click OK.

 

 
6. Click each tab of the parameter set in the Create or Rebuild Counter dialog box, adjusting entries as

desired, and click OK.
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The entries on the Frame tab come from the die press parameter set; all the others come from the
counter parameter set. For more information on configuring the parameter sets, please see the
Defaults chapter. For more information on the Frame tab, refer to the Steel counter section in the
Manufacturing chapter.

7. ArtiosCAD creates the Steel counter layer and frame.
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Steel counter workflow notes
There are concepts in the steel counters workflow not related to tool usage that are important to know.

Line types

Line types Treated as

Perf, partial cut, glue assist perf Cut

Second-height crease, matrix crease Crease

Partial cut/crease, perf in channel, partial cut
perf in channel, Second height cut/crease

Cut/crease

Channel depths

ArtiosCAD draws different channel depths as different shades, with deeper channels being darker.
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Channel properties

Double-click a channel edge and click Channel in the Properties dialog box to see the channel width
and depth.
 

 

Creating crease channels manually

To create crease channels manually, add lines of type With grain crease or Cross grain crease. Make
them into a loop and group them together.

Creating emboss areas

Emboss areas for steel counters are created by an insert in the die and another in the counter. The
insert in the die usually has screw holes for attaching it to the die, and the insert in the counter fits
into a milled area. You can use a geometry macro for the emboss area or create it manually. If you use
a geometry macro, run it in a counter layer, use a placement option such as Place the geometry offset
from two lines, and then use Move to Layer to move the screw holes into a die layer. In the example
below, the screw holes of the Emboss 2 geometry macro are in the Manufacturing layer of the single
design and the emboss area is in the Steel Counter layer.
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If the design has more than one print item with embossing, share the main counter layer between print
items but put the emboss outlines in separate counter layers.

Steel counter creation warnings

 When you use Create or Rebuild Counter for a steel counter, ArtiosCAD warns you if it detects
problems, such as if creases are too short or if a crease crosses more than one panel. Select the error
line in the dialog box to highlight the error; hold down SHIFT to select more than one error at a time. In
the example below, the crease is highlighted with a magenta rectangle.
 

 
Fix all causes ArtiosCAD try to fix the errors as best it can, but you should note the error locations and
check afterward to make sure the results are acceptable.
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Warning How to fix it If you click Ignore

Generic cut and crease should
be changed to a specific type
before making the counter

Change the generic cut crease
to a special rule such as 1/4 1/4
cut crease

ArtiosCAD treats the generic cut
crease like a crease

Crease needs to be split Split the crease where it crosses
another cut or crease

ArtiosCAD does not shorten the
crease at this point

Crease double lines Delete one of the double lines
using Design Checks

ArtiosCAD shortens one of the
creases but not the other

Short lines at the end of crease
lines

Merge or delete the short lines ArtiosCAD does not shorten the
crease correctly

Crease too short for crease
channel

Merge or delete the short lines ArtiosCAD does not shorten the
crease correctly

Digitizing

Digitizing is the process of using a digitizer to input lines and arcs into ArtiosCAD. A digitizer is a flat
tablet which uses electromagnetic energy to track movements of the digitizing puck over the surface
of the digitizer. The geometric information derived from these movements is then sent to ArtiosCAD
which translates it into lines and arcs. Digitizing is useful when you have a physical sample of a design
but no CAD file to accompany it.

The digitizer must be set up before you can use it in ArtiosCAD. For information on setting up a
digitizer, see the Peripherals chapter.

There are three physical locations used when digitizing.

1. Any coordinate on the digitizer, referred to as <c>.
2. An existing point, referred to as <p>. A point, when digitizing, is an end point or intersection point

of existing lines in the current design. These lines may be pre-existing or just-digitized. To select a
point, digitize a point on the digitizer within the snap distance of one of these points.

3. An existing line, referred to as <l>. To select a line, digitize a point on the digitizer within the snap
distance of an existing line in the design.

The workflow for digitizing is straightforward.

1. Create a new ArtiosCAD design or open an existing one.
2. Navigate to the desired layer into which you wish to place the new geometry.
3. Click Tools, Digitize, and then Begin Digitizing.
4. Select the digitizer to use.
5. Digitize as desired by issuing digitizing commands.
6. Activate any other non-Zoom tool in ArtiosCAD to exit Digitizing.

Starting to digitize

Once you have gotten to the point where you are ready to digitize (steps 1 and 2 in the workflow above),
click Tools > Digitize > Begin Digitizing. You will be prompted to select a digitizer:
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Select the digitizer to use and click OK. The status bar will change to look similar to the picture below.

The Set Radius field is used by some of the commands. There is no need to align the digitizer or place
the menu at this time.

Secure the image to be digitized to the digitizer and start digitizing by issuing digitizing commands.

Issuing digitizing commands
There are two ways to issue digitizing commands. The first is by pressing the buttons on the digitizing
puck. Press the button(s) that are listed in the table below to perform the command. For example, to
create an arc through a coordinate, press 3 to indicate the coordinate through which the arc passes,
and then 3 again to indicate the end coordinate of the arc.

Key sequence Command

2 MOVE TO <c>

12 MOVE TO <p>

0 LINE TO <c>

10 LINE TO <p>

3 ARC THROUGH <c> TO <c>

41 ARC THROUGH <c> TO <p>

14 ARC THROUGH <p> TO <c>

44 ARC THROUGH <p> TO <p>
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Key sequence Command

77 CENTER <c> RADIUS <c>

76 CENTER <c> RADIUS <p>

7A CENTER <c> RADIUS radius

66 CENTER <p> RADIUS <c>

67 CENTER <p> RADIUS <p>

6A CENTER <p> RADIUS radius

52 INTERSECT <l> <l>

51 INTERSECT <l> <l> KEEP 1st

BBB BLEND <l> <l> THROUGH <c>

BB1 BLEND <l> <l> THROUGH <p>

BBA BLEND <l> <l> RADIUS radius

D DELETE <l>

E UNDO

F REDO

CD REPLOT - SCALE TO FIT

CC REPLOT - CURRENT SCALE

CA ZOOM BACK

CF ZOOM WINDOW <c> <c>

If a command requires more keystrokes to identify it than there are data elements required for the
command, the most recent digitized points are used.

The second way to issue commands is to use the digitizing menu configured when you set up the
digitizer. Simply place the cross-hair over the desired menu command and press any button on the
digitizing puck to activate the command. You can also use any button on the digitizing puck to indicate
coordinates, points, and lines since the command is already known. Shown at left is the default
digitizing menu. Note that it does not contain all the commands available. If you are a gasket maker,
you may wish to add the circle-creation tools to it using the procedure in the Peripherals chapter.
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Example - Digitizing a simple shape

This example shows how to digitize the shape below using the commands that follow it. The numbers in
the circles are the step numbers, while the numbers inside the digitizing puck are the buttons pressed
on the digitizing puck.
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Key sequence Menu command

0 LINE TO <c>

10 LINE TO <p>

2 MOVE TO <c>

12 MOVE TO <p>

3 ARC THROUGH <c> TO <c>

Start ArtiosCAD and open a new design. Click Tools > Digitize > Begin Digitizing. Choose the digitizer to
use and click OK to enter Digitizing.

1. Digitize a MOVE to the beginning of the first line using the 2 button.
2. Digitize the end of the first LINE by moving the digitizing puck up a few inches and pressing the 0

button.
3. Digitize a coordinate the arc will go THROUGH by moving the puck up and to the right and pressing

the 3 button.
4. Digitize the end-point of the arc by moving the puck down and to the right and by pressing any

button. Any button will do because ArtiosCAD knows the ARC THROUGH <c> TO <c> command is
being used.

5. Digitize the end of the next LINE by moving the puck straight down and pressing the 0 button.
6. Digitize close to the snap point at the start of the first line. The command is made of two button-

presses. The first button pressed is 1, and can be pressed with the digitizing puck anywhere. The
second button pressed is 0, and must be within the snap tolerance of the start of the first line.
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The shape is now complete.

Example - Blending a digitized corner

This example demonstrates how to blend a corner while digitizing. As in the previous example, the
number inside the circle is the step number and the character inside the digitizing puck is the button
pressed.

Start ArtiosCAD and open a new design. Click Tools > Digitize > Begin Digitizing. Choose the digitizer to
use and click OK to enter Digitizing.

1. Digitize within the snap tolerance of the first line by pressing the B button.
2. Digitize within the snap tolerance of the second line by pressing the B button.
3. Digitize a THROUGH coordinate of the blend radius by pressing the B button again to complete the

command.

Aligning the image on the digitizer

It can be dicult to place the image on the digitizer so that it is completely aligned with the digitizer’s
axes. To compensate for this, the digitizer can be aligned with known points on the image and known
points in the ArtiosCAD Design window. For example, the item to digitize may be a cutout on an existing
carton. The corners of the panel will therefore make good points for aligning the image to the design on
the screen.

Between 0 and 3 points can be used to align the digitizer with the ArtiosCAD design window.

If 0 points are used, the origin of the digitizer matches the origin in ArtiosCAD.

1193



12 ArtiosCAD

If 1 point is used, the point selected on the screen corresponds to the digitized point. No scaling or
rotation is performed.

If 2 points are used, the first point selected on the screen corresponds to the first point digitized.
Scaling and rotation will be performed so that the second points align.

If 3 points are used, a best-fit is performed on the three points on the screen compared to the three
points on the digitizer. The image is transformed, scaled, and rotated appropriately.

When aligning the digitizer, the screen points are selected first followed by the points on the digitizer.

To align the digitizer, do the following:

1. Start ArtiosCAD and open a new design. Click Tools > Digitize > Begin Digitizing. Choose the
digitizer to use and click OK to enter Digitizing.

2.
 Click Align Digitizer on the Status bar.

3. The Status bar will change:

4. Click the mouse on-screen at the desired point. The X and Y fields will have values in them and the
point number will increment. If you make a mistake, click the Redo button.

5. Repeat step 4 as desired depending on how you want to align the digitizer.
6. Click OK when done. If you have selected three points, you do not need to click OK.
7. Now that the screen points are selected, you must indicate the digitizer points.

8. Move the digitizing puck to the first point on the digitizer and press any button. Repeat as
prompted, moving to the second and third points if necessary.

9. Once enough points have been digitized, the New Digitizer Alignment dialog box appears.

The new alignment is displayed. If two or more points were used, the scale might not be 1.000 and the
Error will show how accurate a fit was made.
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Checking the Use Scale of 1:1 checkbox overrides the scale derived from the digitized points.This
is useful when the scale factor isn’t quite 1.000 but you want to use the rotation derived from the
digitizer.

Click Retry to perform the alignment procedure again.

Clicking OK accepts the new alignment; clicking Cancel cancels it. The new alignment is effective until
ArtiosCAD is restarted.

Using the digitizing menu

The digitizing menu provides an alternate way to use the digitizer. Selecting a point on a menu button
(also called a Menu Item Area) with any button on the digitizer puck activates that command.

Using the menu means pressing more buttons on the digitizing puck than just by using the puck alone.
For example, if you have a menu button which activates the CENTER <p> RADIUS <c> tool, two extra
button-presses are required after selecting the button — one to satisfy the <p> and the next to satisfy
the <c>. Any button can be pressed to make the data input.

Placing the menu is described in the Peripherals chapter.

Projects

ArtiosCAD provides three ways to work with Projects. The first and second ways are using the Project
menu and the Project bar, which are the methods used in this chapter. The third way is using the
Projects browser in DataCenter Admin, which is described more in the DataCenter chapter.

Getting started with Projects

Projects help to track and identify the relationships between designs. Use Projects to group logical
single designs together, such as a display base and the items it will hold, or a shipping box and its
dividers.

Projects are also used for generating Bill of Materials (BOM) Reports. See the Outputs chapter for more
information about BOM Reports.

As with single designs, ArtiosCAD can assign names automatically to Projects and the documents
within them if the appropriate configuration is performed in DataCenter Admin. See the DataCenter
chapter for more information.

Creating a new Project

To create a new Project within ArtiosCAD, do the following:

1. Click Projects > New Project. The Create New Project dialog box appears.
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2. Enter the appropriate information in the Name: and Description: fields, or, if available, click

Generate Next Available to have ArtiosCAD assign the next available number as the Project name.
(This requires the proper configuration in DataCenter Admin.) The Project name must be unique and
less than 80 characters.

3. Click OK to create the Project and open it. To simply create the Project without opening it, deselect
Open project before clicking OK.

4. ArtiosCAD automatically opens the Project Information dialog box so you can add more detailed
information about the Project.
 

 

• If you set a description when you created the Project, you can change it by editing the
Description: field.

• Set the Customer:, Owner:, Salesperson:, and Manager: fields by clicking the drop-down list
box arrows and choosing an entry from the list shown for each field. To access the standard
database searching dialog box for each type of entry, click ... at the end of each field.

• To set characteristics or userfields for the Project, click the corresponding Characteristics
or Userfields buttons. Projects have their own type of Userfields which must be configured in
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DataCenter Admin before they become available for use in ArtiosCAD. For more information
about configuring userfields, see the DataCenter chapter.

5. If you chose to open it, the empty new Project is shown in the Project bar, which by default appears
at the right edge of the drawing area.
 

 

Adding documents to a Project
To add documents (single design workspaces) to a newly-created Project, do the following:

1. With the newly-created Project open, click Projects > Project Documents.
2. Click Add in the Project Documents dialog box.
3. In the Add document(s) to project dialog box, in the Add from: drop-down list box, select the

Resource containing the desired documents.
4. Select the document to add by clicking its name. To select more than one document, hold down

CTRL on the keyboard and select the desired documents.
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5. Click Add. ArtiosCAD adds the selected document(s) to the Project and lists the results in the
Project Documents dialog box as shown below.
 

 
6. If a selected document has more than one print item, you can add another print item to the Project

by selecting it from the drop-down list box that appears above the list of documents.
 

 
7. Click OK to return to ArtiosCAD. ArtiosCAD does not automatically open the documents you add to a

Project.

Adding open documents to a Project
To add open documents to a Project, do the following:

1. Open the documents and the Project to which they will be added.
2. Click Projects > Project documents.
3. Click Add Open.
4. In the Add Open Documents dialog box, all the open documents are preselected. Click any

document to deselect it from being added to the Project. If you make a mistake, hold down CTRL
and select the documents to add to the Project.
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5. Click OK to add the documents to the Project. If any of the designs are not in a Resource, ArtiosCAD

prompts you to save it/them in a Resource.
6. The documents appear in the Project Documents dialog box as shown below. Click OK to return to

ArtiosCAD.
 

 

Opening a Project

ArtiosCAD keeps a list of the most-recently used Projects on the Projects menu. To open one of those
most-recently used Projects, simply click it; ArtiosCAD also opens the documents that were open
when the Project was last closed.

Note:

The number of saved Projects is configured in Options > Defaults > Startup defaults > Most
Recently Used Project List.
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To open a Project that is not on the most-recently used Project list, do the following:

1. Click either File > Open Project or Projects > Open Project to open the Open Project dialog box.
 

 
2. To open a Project using the Open Project dialog box, perform a search and then select the desired

Project from the search results. You can search by the date the Project was last modified, by the
name of the Project, the description of the Project, or by a combination of the three.

• The Modified: drop-down list box lets you search for Projects modified during the last day, last
7 days, last 30 days, or a range of your choice by choosing More options. When you choose More
options, you can specify the number of passed days within which to search for the Project, or
you can set the beginning and ending dates of the range within which to search for the Project.
Clicking either the Begin date: or End date: drop-down list box arrow when Modified between
dates is selected activates a pop-up calendar that you use to choose the date to begin or end
the range of date-searching. Click OK to return to the Open Project dialog box.
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Note:

To not search by time the Project was last modified, set the Modified drop-down list box
to .

Note:

When using the drop-down calendar in any of the fields, you can click the month and
the year in the date and enter a different month or year, or use the up and down arrow
buttons to change years.

• To form a search phrase in either the Name: or Description: fields beginning with a certain
combination of letters, enter that combination of letters and an asterisk (*), such as 2496*.
To form a search phrase containing a certain combination of letters, enter that combination
preceded with and followed by asterisks, such as *2496*. To form a search phrase equaling
an exact combination of letters, enter that combination of letters. To use an wildcard single-
character match, use ? in place of the character, such as *24?6*, which will find all Projects
containing 2406, 2416, 2426, and so forth.

Note:

% may be substituted for * in “match all” searches and _ may be substituted for ? in
“match only one” searches. For more information about searching, see the Projects
section in the DataCenter chapter.

3. Once you have chosen the method by which to search - Modified:, Name:, or Description:, and have
entered the appropriate information, click Search. ArtiosCAD displays all matching projects in the
Found projects pane, with the first Project selected. The documents in the first Project are listed in
the Found documents pane, with the first one selected and shown in the Preview window.

4. To open the Project and the selected document, click Open. To open the Project and all its
documents, check Select all documents and click Open. Clicking Cancel closes the dialog box.

 You can also open a Project by selecting it in the Project Browser and clicking Open Project.

A Project’s Modified date gets updated when you change any of the following:

• Any database information, such as the description, customer, owner, and so forth
• Any characteristics
• Any userfields or their values
• Any documents (add or remove documents, change the BOM count, and so forth).

Opening documents in a Project
ArtiosCAD provides two ways to open Project documents. To open documents in a Project, do the
following:

1. Open the Project containing the desired documents. If you use the Most-Recently Used Project list
on the Project menu to open the Project, ArtiosCAD opens the documents that were open when the
Project was last closed.

2. Decide how you want to open the documents, and then proceed using the choices in the table
below.
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To open documents by... Do this...

Using the Project Bar Hover over the Project name to expand the Project Bar if it is
collapsed, and then double-click a document to open it.
 

 
You can also select a document it, right-click it, and click Open
Document(s) on the context menu.

Hover over a document to see its description.

To open more than one document at once, hold down CTRL or

SHIFT while selecting the documents, then click  Open
Selected Project Documents on the toolbar, or right-click and click
Open Document(s).

ArtiosCAD opens the selected document(s).

Using a dialog box Click Projects > Project documents, and in the Project Documents
dialog box, double-click the document to open.
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To open documents by... Do this...

 

ArtiosCAD closes the Project Documents dialog box, opens the
selected document, and shows the Project icon in its tab.

ArtiosCAD shows that the document is in a Project by putting its icon in a tray in the window tab and by
underlining the name in orange. In the example below, the left document is in the Project, and the right
document is not.
 

 

Working with the Project Bar

ArtiosCAD lets you work with Projects using the Project Bar, which shows the files in the active Project
if there is one. Using Projects is optional in ArtiosCAD Standard Edition, but their use is required in
ArtiosCAD Enterprise. To open the Project Bar when it is not open, click View > Show Project Bar or
Projects > Show Project Bar. Shown below is the Project Bar with a Project open.
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ArtiosCAD shows the name of the Project in the title bar of the Project Bar. If there is no open Project,
ArtiosCAD shows No Project.

The first node in the list is the Project icon, then the Bill of Materials if one exists, and then documents
and folders (folders in ArtiosCAD Enterprise only).

If a document has a print item specified, the name of the print item appears in parentheses after the
name of the document.

When you expand the BOM, it may take ArtiosCAD a few seconds to populate it.

Double-clicking the BOM node opens all the documents in it.

Double-clicking a folder (ArtiosCAD Enterprise only) opens all the documents in the folder.

ArtiosCAD builds the Project Bar dynamically so there might be a slight delay as you change Projects.

In ArtiosCAD Standard Edition, the Project Bar appears when you open a Project and disappears when
you close the Project. In ArtiosCAD Enterprise, the Project Bar appears automatically when you open a
managed document.

Hover over a document in the Project Bar to see the first 40 characters of its description. If its
description is longer, ArtiosCAD shows an ellipsis at the end.

Pressing CTRL-A when an item in the Project Bar is selected selects all expanded nodes in the tree.

The Project Bar Toolbar
The Project Bar toolbar contains four buttons. The first button depends on the version of ArtiosCAD
you are using.
 

 

 For ArtiosCAD Standard Edition, Open Project opens the Open Project dialog box.

 For ArtiosCAD Enterprise, Open Browser replaces Open Project and opens the browser.

 Open Selected Project Documents opens the documents you have selected. To select more
than one document at a time, hold down CTRL or SHIFT while clicking items to select. If you have
selected a Project node, ArtiosCAD opens all the documents in the Project and ignores everything else.
If you have selected a BOM node, ArtiosCAD opens all documents in the BOM. If you have selected a
folder (ArtiosCAD Enterprise only), ArtiosCAD opens all the documents in the folder.

 Refresh checks for changes to the list of documents (and folders in ArtiosCAD Enterprise) in the
Project since you opened it.

 Show Information Dialog performs different actions depending on the current selection.

• If the Project is the current selection, clicking it opens the Project Information dialog box.
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• If the Bill of Materials is the current selection, clicking it opens the Project Documents dialog
box in ArtiosCAD Standard Edition. In ArtiosCAD Enterprise, it opens the Project Bill of Materials
Documents dialog box.

• If a document in the Bill of Materials is the current selection, and that document is open, clicking it
changes focus to that document and opens its Oneup Database Information dialog box.

• If a document in the Bill of Materials is the current selection, and that document is not already open,
clicking it opens the document's Oneup Database Information dialog box in read-only mode. In
ArtiosCAD Enterprise, if that document is a native file type, ArtiosCAD opens the Oneup Database
Information dialog box in read-only mode. If the document is not a native file type, ArtiosCAD
displays an error message.

• In ArtiosCAD Enterprise, this button is not available when a folder is selected.

If the Bill of Materials is the current selection

 Icon Size lets you choose between No icons, Small icons, Medium icons, and Large icons.

Manipulating the Project Bar

Pinning and Hiding
The default state of the Project Bar is to auto-hide itself. To pin it to the window so it is always visible,

click the pushpin icon at the right end of the Project Bar's title bar . It changes to show it is pinned

. To set the bar to auto-hide again, click the pushpin icon.

Detaching
The Project Bar is detachable from the main window of ArtiosCAD and may be docked on either the left
or right side of the drawing area. To detach it, first pin it so it does not auto-hide, then drag it by its title
bar to the desired position. You can resize the Project bar as desired.
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Docking
To dock the Project Bar after detaching it, drag it back into the main ArtiosCAD window, and position
the cursor over the arrow indicating where you want it to go. The target area turns blue.
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Release the mouse button to dock the Project Bar.
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Closing
To close the Project Bar, click the red X at the right end of its title bar.

Using Both the Parts List and Project Bar
If you have a canvas in a Project, the Parts List and the Project Bar are independent of each other and
you may manipulate them as desired. Shown below are both hidden.
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Shown below are both docked.
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Setting Project information

Each Project may have a description, a customer, an owner, a salesperson, a manager, characteristics,
and Project userfields assigned to it using the Project Information dialog box.ArtiosCAD prompts
for this information when you create a new Project, but you can change this information at any
time. Shown below is the default Project Information dialog box. You may design a custom Project
Information dialog box in Defaults.
 

 

To set Project information after the Project has been created, do the following:

1. Open an existing Project.
2. Click Projects > Project Information.
3. If you set a description when you created the Project, you can change it by editing the Description:

field.
4. Set the Customer:, Owner:, Salesperson:, and Manager: fields by clicking the drop-down list box

arrows and choosing an entry from the list shown. To access the standard database searching
dialog box for each type of entry, click ... at the end of each field.

5. To set characteristics or userfields for the Project, click the corresponding buttons Characteristics
or Userfields. Projects have their own type of Userfields which must be configured in DataCenter
Admin before they become available for use in ArtiosCAD. For more information about configuring
userfields, see the DataCenter chapter.

6. To add or remove documents to or from the Project, click Documents, which opens the Project
Documents dialog box as described earlier.

7. Click OK to return to save the changes and return to ArtiosCAD. Any changes made to the
information are saved to the database once you click OK.

Closing a Project

To close the active Project, do the following:
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1. Click Projects > Close Project.
2. If any Project documents are open, ArtiosCAD will ask if you want to close them. Click Yes.
3. If any Project documents being closed have unsaved changes, ArtiosCAD will ask if you want to save

changes. Click Yes or No as desired.

Notes and warnings for Projects

A Projects item has been added to the General information category of the calculated text table. When
used on a Report, this item generates a comma-separated list of Project codes.

Revisions
A Project may only contain one revision of a single design.

When you click Save As Revision in a single design that is part of a Project, the Save As Revision
dialog box will show a list of the Projects of which the single design is a member. Migrate the Projects
information to the new revision by selecting the checkbox next to the Project name. To keep the
Project information in the old revision, clear the checkbox next to the Project name.

Opening files from another database
When you open a single design containing records from another database, the Add Database Entities
dialog box appears. In this dialog box, choose which entities to add to your database by checking the
checkbox next to each available category. The enabled categories depend on which entities are set in
the single design.
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The Keep project codes in design checkbox controls whether or not ArtiosCAD leaves the Project
codes from the foreign database in the single design or if it strips them out.

To see the specific entities for each category of database entities, click ... next to the checkbox. All
entities will be added if you check the checkbox; there is no way to choose which specific entities
are added to the database. Specific Project entities are shown below; click OK to return to the Add
Database Entities dialog box.

To add a design containing Project codes from another database to your database and additionally
have the Project codes in that design added to your database, do the following:

1. Put the design into a resource (whether by saving it from an email message, copying it off a floppy
disc, or whatever method you use).

2. Start ArtiosCAD and open the design.
3. In the Add Database Entities dialog box, check both the Keep project codes in the design and the

Project Codes checkboxes.
4. Save the design, making sure to not change the name or resource.
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Design Checks

Use Design Checks on the Design menu to check the design for double lines, gaps in the perimeter,
rules with pointage 0, and rules of different pointages that meet.
 

 

To remove double lines, click Yes and then click OK. To leave them unchanged, click No. 50 double lines
are reported initially when the check is run.

Maximum Gap Size sets the size of the largest gap that will be found by Design Checks. The tool finds
gaps smaller than the value set for this field. If it finds any gaps, they are circled with magenta circles.

To search for other gaps, change the value in the Maximum Gap Size field and click Refresh.

If Design check before Save, Save as is checked in Options > Defaults > Shared Defaults > Design
Defaults > Save Options, the design is checked when it is saved. This option is off by default.

Canvases

Canvases are design workspaces made of multiple separate pieces called parts. Their filenames have
the extension .ACD, which stands for ArtiosCAD Canvas Design Document.

Some designers, especially those who work on displays, like to have all the pieces together in one
file. Others like to design alternate views of the finished project and include them in the workspace.
Whatever your drafting style is, if you want more than one piece in a workspace, canvases are for you.

Canvases:

• Do not contain manufacturable geometry at the canvas level, meaning you can only draw in a part,
except for construction lines

• Convert to 3D and manufacturing just like single designs
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Parts:

• Can be exported as single designs or exist only in the canvas
• Have three major types: Production, Non-production, and Layout. Non-production parts are meant

to represent things such as an exploded view or notes. Layout parts are meant for quick nests to
see if the parts fit on a sheet, but you can also convert them to manufacturing workspaces for other
workflows.

• The minor part type Remainder which ArtiosCAD creates (if needed) when rebuilding a canvas

• The minor part type Hardware, created only by the Add Hardware tool in 3D. There is no way to add
such a part manually to a canvas.

• Expand and contract automatically depending on how you draft inside them

The canvas interface

The canvas interface is similar to that for single designs, but there are a few differences.
 

 

 Canvases have a Parts List at the right edge of the drawing area that is organized by board
codes used in the canvas. Use the toggle at the right end of the View bar to turn it on and off. Drag the
handle between the Parts List and the drawing area to resize the Parts List as desired. Click an item
in the Parts List to change the active part or to make the canvas itself active (for setting database
information, among other things).
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Like the Project Bar, the Parts List may be detached, docked on either the left or right side of the
drawing area,

Right-click the canvas name in the Parts List to:

• Create Part

• Import Standard as New Rebuildable Part

• Import File as New Rebuildable Part

• Import File as New Static Part

• Import File as New Rebuildable Part Reference

• Import File as New Part Reference

• Convert to Manufacturing

Right-click a single design part name in the Parts List to:

• Rename Part (which you can also do by single-clicking a part's name in the list)

• Delete Part

• Mark as Production / Mark as Non-production

• Make Read-Only

• Convert to Manufacturing

• Isolate Part

• Add to Bill of Materials

• Display or change Board Information

Hover over a part name in the Parts List to see its filename.

Right-click a board in the Parts List to:

• Create Layout

• Create Part

• Change Board

Right-click a job in the Parts List to:

• Recalculate Job

• Delete Job

• Rename Job

Right-click a layout in the Parts List to:

• Rename Layout

• Delete Layout

• Shrink Sheet to Fit

• Convert to Manufacturing

• Isolate Part

Right click a Hardware part in the Hardware folder on the Parts List to rename it.

Hardware parts:

• are meant to appear on the BOM and give a visual representation of the part in the canvas.
• on a BOM, they are in their own folder but are deselected by default
• have a lock symbol next to them in the list and in their title bars to show they are read-only
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• are created and modified only by the Add Hardware tool in 3D

• do not have information that can be changed manually in the Parts List; the part type, part name,
and description are for information only

• make unavailable most tools and workflows when they are the active part

You can also single-click a selected part in the Parts list to rename it.

At the bottom of the Parts List are controls that act on the selected part. Different part types have
different controls. For single design parts, one lets you set the part type to Production or Non-
production. Non-production parts appear at the bottom of the Parts List.

Number of copies lets you set the number of copies of the part you need in the canvas to complete
the customer's order, without having to have identical copies of the same part. ArtiosCAD uses this
number in jobs and layouts to determine the job quantity. If you use a variable in a Copy Times tool for
the number of copies, you can then use that variable in the Number of copies field, and AC will update
it appropriately after rebuild. To use the CAL(x) function in this variable, create a new variable and set
it to CAL(x) first, then use the new variable in the Copy Times expression. The part frame shows the
evaluated number but the Number of copies field shows the expression.

More Options (...) next to Board Code lets you change the board code for the selected part or canvas.
Lastly, you can also see the database information for the selected part or canvas by clicking Database
information.

When you select a job in the Parts List, you can click Job Information or Recalculate Job. Each job has
a visibility button preceding its name in the Parts List so that you can turn it off individually from the
others.

When you select a layout in the Parts List, you can set the Number of sheets, the Sheet width, and the
Sheet height. ArtiosCAD also displays the waste percentage and the blank size. Additionally, you can
click Sheet Properties, Layout Information, Recalculate Job, and Database information.

 Each part has a frame drawn around it, or corner marks, or nothing, depending on the settings
on the Canvas/Parts Options tab in Startup Defaults in Defaults. Production parts have an orange line
at the top of their title bars and an orange icon in the Parts List. Non-production parts have a gray line
at the top of their title bars and a gray icon in the Parts List. Use the toggle at the right end of the View
bar to turn it on and off. You can also toggle part frames in the View Mode dialog box, as well as on the
View > View Options menu. The part name in the title bar disappears if it is too long to show based on
the zoom level.

 To show or hide layouts, use the Show or Hide All Layouts toggle above the Parts List. This works
best when you stack the layouts in vertical columns, as ArtiosCAD shifts parts left and right when you
use this control. Use View > Show All Layouts if you prefer a menu command.

Feature availability in canvases and parts
While the canvas interface is similar in many ways to that of single design, there are some features and
menus that are not available.

Not available in canvases and parts:

• Tools > Counter

• Tools > Reports

• Help > Diagnostics > Import NC File

• Palletization
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• Sequencing tool
• Group Sequence and Design from Half/Quarter are not available.

In ArtiosCAD Standard Edition, Publish to WebCenter is not available for canvases.

The following features are not available when the canvas is active, but are available when a part is
active:

• File > Import > Import File

• Edit > Paste

• Edit > More Select

• Edit > Edit Tools

If the current tool is not available when switching to a canvas, ArtiosCAD activates the Select tool.

For Layout parts, only Outputs and Geometry Macros (with Move to Layer enabled) are available.

For Reports around Layout parts, you can use Select to select elements of the Report. Inside the
sheet, it only selects entire parts.

Using Isolation Mode

 The Isolation Part toggle at the right end the stage bar enables isolation mode, which shows only
the current part on the screen and hides all other parts.

Not in isolation mode:
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In isolation mode for part Body:
 

 
Starting isolation mode scales the view of the part to fit the window size. While you are in isolation
mode, other parts of the canvas are hidden even if you zoom out. Ending isolation mode scales the
view of the canvas to fit the window size.

There are four ways to start or end isolation mode:

• Click View > Isolate Part

• Click Part > Isolate Part

• Right-click the part's title bar and click Isolate Part

• Right-click the part's entry in the Parts List and click Isolate Part on the context menu.

Isolation mode supports production parts, non-production parts, and layout parts. It does not support
job parts.

To change to a different part without leaving isolation mode, click that part in the Parts List.

When you end isolation mode, ArtiosCAD updates any layouts that reference that part.

Manipulating the Parts List

Pinning and Hiding
The default state of the Parts List is to auto-hide itself. When it is hidden, a Parts List tab appears for it
at the top of a toolbar on the side of the drawing area to which the Parts List is docked.
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To pin it to the window so it is always visible, click the pushpin icon at the right end of the Parts List's

title bar . It changes to show it is pinned . To set the bar to auto-hide again, click the pushpin
icon.

Detaching
The Parts List is detachable from the main window of ArtiosCAD and may be docked on either the left
or right side of the drawing area. To detach it, first pin it so it does not auto-hide, then drag it by its title
bar to the desired position. You can resize the Parts List as desired.
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Docking
To dock the Parts List after detaching it, drag it back into the main ArtiosCAD window, and position the
cursor over the arrow indicating where you want it to go. The target area turns blue.

Release the mouse button to dock the Parts List.
 

 

Closing and Opening
To close the Parts List, click the red X at the right end of its title bar. To open it again, click View >
Parts List.

Using Both the Parts List and Project Bar
If you have a canvas in a Project, the Parts List and the Project Bar are independent of each other and
you may manipulate them as desired. Shown below are both hidden.
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Shown below are both docked.
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File operations

Creating a new canvas
To create a new canvas, do the following:

1. Click File > New > Canvas.
2. In the Single Design Settings dialog box, choose a parameter set and board, and click OK.
3. A blank canvas with one part of the default size for new parts appears. The current position is the

origin.
 

 
4. You are now ready to start designing as usual in Part 1.

Converting an existing design to a canvas
To convert an existing design to a canvas, do the following:
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1.

With the design open, click Convert to Canvas on the View bar, or click File > Convert to >
Canvas.
 

 
2. ArtiosCAD automatically puts the geometry into parts as needed, with the following considerations:

a) ArtiosCAD puts geometry that touches or overlaps into one part.
b) ArtiosCAD tries to consolidate multiple copies. If the design has multiple identical contours,

ArtiosCAD makes one instance of the part and updates the part count as appropriate. This
works best when the creator made the geometry complete before using Copy Times to make
more contours. This consolidation process does not apply when the creator copied different
parts of a single part separately, edited the geometry after copying it, or used the regular
Copy tool instead of Copy Times. Also, files based on earlier ArtiosCAD standards may behave
unpredictably with a variable number of items being placed in the wrong part. Files based on
standards made after ArtiosCAD 16 should not have this problem.

c) ArtiosCAD numbers the parts by rows starting from the top left.
d) Parts are production parts if they contain non-zero length lines.
e) Small parts are those that are smaller than 10mm.
f) The maximum number of parts is 149. If there are more than 149 parts, ArtiosCAD merges parts

that are close together until there are fewer than 149 parts.
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g) ArtiosCAD creates a remainder part if needed. It contains zero-length lines used for standards,
remaining isolated lines, and small parts (if needed).

h) ArtiosCAD maintains groups during the conversion.
i) If dimensions span multiple pieces in the original design, this results in a larger converted part

containing the spanned pieces. Check your dimensions before converting to avoid unexpected
results.

j) ArtiosCAD creates hardware parts based on hardware placement lines.
3. ArtiosCAD turns on all layers but documentation plots and Output layers and sets the active part to

part 1. You may now start drawing as desired.
 

 

Creating a new empty part
Use one of these methods to create a new empty part:

Note:  Always create parts with space between them. Do not overlap parts.

1. In a canvas, right-click over an empty spot in the canvas and click Create Part on the context menu.
a) ArtiosCAD puts the lower left corner of the new part where you clicked the mouse and moves the

current position to the bottom left corner of the new part, unless it would overlap another part.
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b) If the potential new part overlaps another part, or if the cursor is within half of the default size
of the potential new part plus the gutter to another part, ArtiosCAD aligns the new part either
horizontally or vertically with the closest corner of the existing part.

c) If the new part would still overlap another part, ArtiosCAD places it at the bottom right of the
canvas.

2. Right-click the canvas in the Parts List and click Create Part, or click Parts > Create Part, or right
click a board in the Parts List and click Create Part on the context menu. ArtiosCAD will align the
new part (if possible) with the bottom right of the active part, else position it at the bottom right of
the canvas.

3. ArtiosCAD names the part Part X, where X is the next part number. If you save the part as a
standalone workspace, ArtiosCAD will use the part number as part of the name if your system is
configured to base the part filename on the canvas.

4. The new part appears in the Parts List with its name in grey italic to indicate it is empty.
5. ArtiosCAD sets the new part to type Production and marks it active.

Importing a file from a standard as a new rebuildable part
To create a new rebuildable part based on a standard, do the following

1. In your canvas, click either File > Import File > From Standard As New Rebuildable Part or right-
click the canvas in the Parts List and click Import Standard As New Rebuildable Part.

2. In the Standards Catalog dialog box, choose an ArtiosCAD standard (one with blue dimension lines
in its icon) from the Standards Catalog and click OK. You can choose an earlier standard but the
resulting part will not be rebuildable.
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3. Choose a board for the new part. ArtiosCAD sets the units, side, and grain direction from the

canvas.
4. In the Import File as New Part dialog box, ArtiosCAD shows the menus and variables for the

standard, and provides options for what to do if menus or variables from this new part conflict with
menus or variables that already exist in the canvas. Make sure to set the variables' current values
normally as you would when running the standard.
 

 
ArtiosCAD displays an information icon when there are issues you need to resolve. Hover over the
icon to see a ToolTip describing the issues. In the case of a conflicting menu name, click the menu
name to change it.
 

 
 

 
 

 
To give a variable a new name, enter the new name in the New name field. To edit a formula by hand,
double-click inside the Formula field; to edit it using the Formula dialog box, click f(x) at the end of
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the Formula field. To change the current value, change it in the Current Value field. Variables which
are option buttons have those options in a drop-down list in the Current Value field; set them as
desired. There are three possible Actions, which you can set individually or for all using the column
header:
a) Add variable. Adds the variable to the canvas if it does not already exist. If it does already exist,

ArtiosCAD gives it a new name by appending an instance number to the end. ArtiosCAD updates
all downstream formulas that use this variable with its new name.

b) Use formula or value. Enables only the Formula field for you to enter either a new formula or
value that replaces the variable. ArtiosCAD replaces future instances of this variable with the
value or formula you enter and does not add the variable to the canvas.

c) Use existing variable. This option makes all other fields unavailable. ArtiosCAD uses a variable
of the same name that already exists in the canvas instead of this variable. This option is
available only when such a condition exists.

5. Click OK when you are done going through the menus and resolving issues. If there are any check
conditions which are not satisfied, ArtiosCAD prompts you to resolve them.

This results in a rebuildable part becoming part of the canvas. When you rebuild the canvas, a node for
this part will appear in the rebuild tree.

When you import a standard as a new part, ArtiosCAD observes the following limits:

• The maximum number of special rules in the part is 39.
• The maximum number of fonts in the part is 39.
• The maximum number of colors in the new part is 999.

Importing a file as a new rebuildable part
To import an existing resizable ArtiosCAD design as a new rebuildable part, do the following:

1. Click File > Import File >  As New Rebuildable Part, or right-click the canvas in the Parts List and
click Import File as New Rebuildable Part. This merges the single design's menus, variables, and log
file into the canvas'.

2. Depending on the type of ArtiosCAD you are using, the file selection dialog box or the file browser
appears, pre-seeded to files of type Artios Design (*.ARD). Select the file to import, and click Open.
If you select multiple files, ArtiosCAD processes them sequentially and you will loop through the
import process for as many times as files you selected.

3. In the Import File as New Part dialog box, set the variables in the menus as desired. If this is not
the first rebuildable part in the canvas, there may be name collisions for many of the menus and
variables. Hover over the information icons to see the issues and resolve them. Click OK when you
have reviewed all menus and variables.

4. If the active part is empty, ArtiosCAD imports the file into the active part; otherwise, ArtiosCAD
places the new part at the bottom right of the canvas and makes it active.

5. ArtiosCAD puts the contents of the imported file's layers (if any) into the layers of the canvas.
a) If the same layer name and layer class already exists, ArtiosCAD puts the imported file's layer

contents in that layer. Layer names are case-sensitive.
b) ArtiosCAD will create the layer if necessary.
c) All layers of the new part are unlocked, even if those layers are locked in other parts.

6. The part keeps the board code of the original file.

When you import a file as a new part, ArtiosCAD observes the following limits:
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• The maximum number of special rules in the part is 39.
• The maximum number of fonts in the part is 39.
• The maximum number of colors in the new part is 999.

If the file you are importing contains hardware placement lines, ArtiosCAD checks if the canvas already
contains the hardware part. If it does not, and ArtiosCAD can find the hardware part workspace,
ArtiosCAD adds the hardware part to the canvas with a part count of 1.

You can Undo an import like this once, only before making changes such as changing geometry or
menus.

Use Rebuild Playback to see what happens during rebuild. ArtiosCAD turns on Isolation Mode for
this part during Rebuild Playback. Do not add geometry while in Rebuild Playback. However, you may
change expressions and formulae if desired.

Importing a file as a new static part
To import an existing file as a new static (non-resizable) part, do the following:

1. Click File > Import File >  As New Static Part, or right-click the canvas in the Parts List and click
Import File as New Static Part.

2. Depending on the type of ArtiosCAD you are using, the file selection dialog box or the file browser
appears, pre-seeded to files of type Artios Design (*.ARD). Supported file types extensions include
.ARD, .CF2, .DS2, .DD3, .DXF, .DWG, .PDF, and .AI Change the selector if desired, select the
file(s) to import, and click Open. If you select multiple files, ArtiosCAD processes them sequentially
and you will loop through the import process for as many times as files you selected.

3. If you chose a file that uses import tuning, the appropriate tuning dialog box appears.
4. If the active part is empty, ArtiosCAD imports the file into the active part; otherwise, ArtiosCAD

places the new part at the bottom right of the canvas and makes it active.
5. ArtiosCAD puts the contents of the imported file's layers (if any) into the layers of the canvas.

a) If the same layer name and layer class already exists, ArtiosCAD puts the imported file's layer
contents in that layer. Layer names are case-sensitive.

b) ArtiosCAD will create the layer if necessary.
c) All layers of the new part are unlocked, even if those layers are locked in other parts.

6. If the imported file is a single design, the part gets the same board code as the original single
design.

When you import a file as a new part, ArtiosCAD observes the following limits:

• The maximum number of special rules in the part is 39.
• The maximum number of fonts in the part is 39.
• The maximum number of colors in the new part is 999.

If the file you are importing contains hardware placement lines, ArtiosCAD checks if the canvas already
contains the hardware part. If it does not, and ArtiosCAD can find the hardware part workspace,
ArtiosCAD adds the hardware part to the canvas with a part count of 1.

You can Undo and Redo the import of a static part as many times as desired.

Importing a file as a new part reference
To import an existing file as a new part reference, which is a link to an existing design that is marked
read-only, do the following:
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1. Click File > Import File > As New Part Reference, or right-click the canvas in the Parts List and click
Import File As New Part Reference.

2. Depending on the type of ArtiosCAD you are using, the file selection dialog box or the file browser
appears, pre-seeded to files of type Artios Design (*.ARD). Change the selector if desired, select
the file to import, and click Open.

3. If you chose a file that uses import tuning, the appropriate tuning dialog box appears.
4. If the active part is empty, ArtiosCAD imports the file into the active part; otherwise, ArtiosCAD

places the new part at the bottom right of the canvas and makes it active.
5. ArtiosCAD puts the contents of the imported file's layers (if any) into the layers of the canvas.

a) If the same layer name and layer class already exists, ArtiosCAD puts the imported file's layer
contents in that layer. Layer names are case-sensitive.

b) ArtiosCAD will create the layer if necessary.
c) All layers of the new part are locked, even if those layers are unlocked in other parts.

6. All aspects of the new part reference are locked. A lock icon appears in the Parts List next to the
part name as well as in the title bar of the part to show it is locked. All tools display the No cursor
while that part is active.
 

 
 

 
What you can do is use points in the locked part reference as reference points while using tools in
other unlocked parts. You can also move the entire part.

When you import a file as a new part reference, ArtiosCAD observes the following limits:

• The maximum number of special rules in the part reference is 39.
• The maximum number of fonts in the part reference is 39.
• The maximum number of colors in the new part reference is 999.

If the file you are importing contains hardware placement lines, ArtiosCAD checks if the canvas already
contains the hardware part. If it does not, and ArtiosCAD can find the hardware part workspace,
ArtiosCAD adds the hardware part to the canvas with a part count of 1.
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To view the path of the read-only part reference in the future, open the Save Parts dialog box.

When you export parts using Save As or Save As Revision, ArtiosCAD updates the link to the read-
only part. However, when you use Save As on the canvas itself, ArtiosCAD does not update the path for
referenced parts.

Importing a file as a new rebuildable part reference
Importing a file as a rebuildable part reference is just like importing a file as a regular part reference.
The imported part is read-only and, at first, not resizable. To make it resizable, you must make it
writable first. To import a file as a rebuildable part reference, do the following

1. In your canvas, click either File > Import File > As New Rebuildable Part Reference or right-click
the canvas in the Parts List and click Import File As New Rebuildable Part Reference.

2. In the Import File As New Rebuildable Part Reference dialog box, navigate to the file(s) to import and
click Open. You may select more than one file; ArtiosCAD will loop through the import process as
many times as needed.

3. In the Import File As New Part dialog box, hover over the information icons in each menu as needed
and fix the issues as required. Click OK when you have resolved all the issues.

4. If the active part is empty, ArtiosCAD imports the file into the active part; otherwise, ArtiosCAD
places the new part at the bottom right of the canvas and makes it active.

5. ArtiosCAD puts the contents of the imported file's layers (if any) into the layers of the canvas.
a) If the same layer name and layer class already exists, ArtiosCAD puts the imported file's layer

contents in that layer. Layer names are case-sensitive.
b) ArtiosCAD will create the layer if necessary.
c) All layers of the new part are locked, even if those layers are unlocked in other parts.

6. All aspects of the new part reference are locked. A lock icon appears in the Parts List next to the
part name as well as in the title bar of the part to show it is locked. All tools display the No cursor
while that part is active.
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What you can do is use points in the locked part reference as reference points while using tools in
other unlocked parts. You can also move the entire part.

7. Presumably you want to make this part rebuildable. Right-click it in the Parts List and click Make
Writable.

8. ArtiosCAD recognizes that this is a reference to a resizable design and prompts you to decide what
to do.
 

 
a) The default action is Remove the reference to this file from the part and make the part

writable. This essentially inserts a standalone version of the referred file as a new part so
ArtiosCAD can rebuild it. This option is always selected and there is no setting in Defaults to
control it as it is considered dangerous to change it.

b) Keep the reference to this file and make the part writable has the potential to MODIFY THE
ORIGINAL FILE WHEN YOU REBUILD THE CANVAS. Use this option with caution. To mitigate the
danger, you can choose to Set part to Save As New Revision, which is the default behavior when
you choose this option. If you export this part that is still a reference, the first time, the action is
set to Save as New Revision, and then future exports are set to Overwrite Existing, but you can
change those actions as desired.

c) Click OK to finish importing the file as a rebuildable part reference.

Importing a canvas into another canvas
There are several ways to import a canvas into another canvas using the commands on the File >
Import File menu.

• From Standard as New Rebuildable Part. Allows you to choose the standard from the catalog and
set the parameter set and boards.

• As New Rebuildable Part. Select the workspace file. ArtiosCAD does not prompt for a parameter
set or boards.
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• As New Static Part. Select the workspace file. ArtiosCAD does not prompt for a parameter set or
boards.

As New Rebuildable Part Reference, As New Part Reference, and Into Current Part do not allow this
operation.

ArtiosCAD preserves the source canvas’ 3D fold angles, canvas construction lines, and locked layers in
the destination canvas.

Kept elements and discarded elements
ArtiosCAD imports some elements and discards others.

Included elements Discarded elements

Production parts Layouts

Non-production parts Layout macros

Remainder parts Reports around parts

Hardware parts (along with the link to Defaults) Output parts

Geometry-creating geometry macros

Deleted parts (in case they are referenced by
other geometry)

Parts added as read-only references, with the
read-only mode reset and the reference removed

Documentation plots (from standards)

Parts imported into the destination canvas
Parts specifically set in the source canvas as read-only remain read-only in the destination canvas.

Parts that have a copy count greater than 1 retain that copy count in the destination canvas. If the
number of copies is set by a variable, the value of that variable appears in the Number of copies field in
the Parts List.

Database entries
Database information from the source canvas does not overwrite database information in the
destination canvas.

In ArtiosCAD Standard Edition, all the database information is preserved except for Customer, Owner,
Salesperson, and Designer, which take the values of the destination canvas.

In ArtiosCAD Enterprise, Salesperson and Customer are set by the Project. Designer and Owner are the
user and that user’s location. Userfields are replaced by Attributes.

Documentation plots
If variable names are in the text of dimensions, ArtiosCAD maps them dynamically to new variable
names.

ArtiosCAD can update documentation plots in canvases run as importable parts except for those run as
a standard into a rebuildable part.
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Deleting a part
To delete a part, do one of the following:

1. Right click the name of the part in the Parts List and click Delete Part.
2. Make sure the part you want to delete is the active part and click Parts > Delete Active Part.
3. Right-click inside the part over a blank space so that it turns magenta and click Delete Part on the

context menu.

Saving a canvas
When you save a canvas, you can choose to be prompted to save the parts to individual ArtiosCAD
workspaces (the default), to save modified parts automatically to individual workspaces, or to leave the
parts as self-contained entities in the canvas document.

Note:  If you are using ArtiosCAD Standard Edition, Publish to WebCenter is not available for
canvases.

1.
 Design the canvas as desired and click File > Save, or click Save on the View bar.

2. ArtiosCAD prompts you to pick a location and set the filename, or you can use auto-naming if it is
available for your chosen location. Save the file in your desired way.

3. Set the database information for the canvas and click OK. If you save the parts individually, they will
inherit the Customer, Owner, Salesperson, and Designer you set for the canvas.

4. If your ArtiosCAD is set to save parts while saving a canvas, ArtiosCAD will prompt you to save the
parts. See Saving Parts for more information.

The Defaults that control the savings of parts when saving a canvas are in Options > Defaults > Startup
options > Canvas/Parts Options.

Saving parts
Parts can exist only within the canvas, or you can save them to individual ArtiosCAD workspaces if you
want to work on them independently. If you work on them independently, ArtiosCAD will prompt you to
synchronize the canvas versions with the individual versions the next time you open the canvas.

Note:  You must save the canvas before you can save parts individually. Save Parts is
unavailable until you save the canvas.

1. If you are using the default settings, ArtiosCAD opens the Save Parts dialog box.
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a) ArtiosCAD selects all Production parts by default for saving. Their icons are orange. Non-

production parts are not selected and their icons are gray. Read-only parts are listed but are
unavailable, and hardware parts are not exportable. ArtiosCAD automatically selects those parts
that have changed since the last save. Toggle all the parts' selection for saving or not saving by
clicking the checkbox in the column header.

b) In the Filename column, ArtiosCAD bases the part filename off either the part name or the
canvas filename, depending on your Defaults configuration. If your system uses the part name,
the filename is the part name with the ArtiosCAD file type extension. If your system uses the
canvas filename, the part filename is set to the canvas filename, followed by a delimiter and
then the number of the part. If the location at which you are saving the part supports it, you can
click the drop-down list box activator at the end of the field and pick Autoname (for a resource
or Project) or Autogenerate (Canvas) or Autogenerate (Part) (based on the location in which
you are saving the canvas). To set the action for all the filenames at once, click the drop-down
list box activator in the column header. For ArtiosCAD Enterprise, the canvas will be version 2 if
you choose to autogenerate the name. If you choose to Autoname or Autogenerate, ArtiosCAD
updates the filename appropriately. You may also double-click the filename to manually edit it
as desired if it is not being generated automatically. Note that referenced parts use different
filenames.

c) If you are using ArtiosCAD Enterprise, and if the Project in which you are saving the parts
supports autonaming AND supports a sux, the Sux column allows you to set it.

d) The Revision column shows the revision character for the part.
e) In the Location column, choose where to save the part. ArtiosCAD seeds the location to where

you are saving the canvas, but you can choose a different location for each part. To set the
location for all the locations at once, click the drop-down list box activator in the column header.
You may:

• Browse For Folder (in ArtiosCAD Standard Edition)

• Select Resource (in ArtiosCAD Standard Edition)

• Use Canvas Directory (in ArtiosCAD Standard Edition)

• Browse (in ArtiosCAD Enterprise, which opens the browser)

• Use Canvas Location (in ArtiosCAD Enterprise)
f) In the Database Information column, click More Options (...) to open the Parts Database

Information dialog box. The Length, Width, and Depth fields are for information only and are not
structurally effective. This is why they are editable.

1235



12 ArtiosCAD

g) The Save column shows the result of ArtiosCAD evaluating the action it will take. The available
actions in this column when you click the drop-down list-box activator are Save, which
overwrites an existing document, or Save As New Revision. If you choose Save as New
Revision, you must enter a comment, and if this is not the first save, an option to update all
BOMs with this revision appears. As with the other columns, set the actions for all the parts by
clicking the drop-down list box activator in the column header. The potential results are listed
below.

• Create New Document. The destination document does not exist yet.

• Overwrite Existing. The destination document already exists and ArtiosCAD will replace it.

• Currently Open. The destination document is already open as an independent workspace.
Close it before saving the part.

• Disk File Newer. The independent version has been saved since you tried to save the part.
h) The Add to Bill of Materials column controls if ArtiosCAD adds the part to the BOM.
i) The Bill of Materials Proxy column controls if ArtiosCAD creates a proxy design for a hardware

part for use on a BOM. If you click a column entry, you can specify the resource in which
ArtiosCAD creates the proxy design and its filename.

j) The Status column shows the progress of the save.
2. Click Save. When you click Save:

• A progress bar appears.
• Stop replaces Save and Close.

• ArtiosCAD updates the Status column for each part.
3. When the save process completes, ArtiosCAD shows a status message showing if there were any

errors. Click Close to close the Save Parts dialog box.

After saving a part, the path for it does not change when you save the canvas in a new location.

Timestamps and paths can be inconsistent if you save parts and not the canvas thereafter. This usually
results in the status of Disk File Newer.

When canvas parts contain hardware holes and hardware placement lines, ArtiosCAD copies them to
exported parts. If you convert those exported parts to 3D, however, ArtiosCAD does not repopulate the
hardware parts; that happens only in canvases.

Saving revisions
Saving revisions of canvases and parts in ArtiosCAD Standard Edition requires that Base filename is
earliest revision be selected in Options > Defaults > Startup defaults > Revision Disk File Format.
 

1236



12ArtiosCAD

 

You may not save revisions if that option is set to Base filename is latest revision. Default to update
all projects when saving revisions controls if ArtiosCAD Standard Edition updates other Projects
containing an individual part workspace with the new revision.

When you save a revision of a canvas in ArtiosCAD Standard Edition, there is an option to Also save
parts as revisions. This option is selected by default.
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If you leave this option selected when you click OK, ArtiosCAD opens the Save Parts dialog box with
additional information for the revisions. ArtiosCAD seeds the Revision Description and Authorization
fields from the Save As Revision dialog box, but you can change them for each part as desired by
selecting the part and changing them. You can also choose to add the parts to the BOM or not if this is
the first time you are saving them.
 

 
Click Save to begin saving the parts. Click Close when done, and then click OK in the Canvas Database
Information dialog box.

If you are using ArtiosCAD Enterprise, the procedure is similar. When you click Publish Revision, in the
Save Managed Document dialog box is Also Save Parts As Revisions.
 

 
ArtiosCAD Enterprise then prompts you to set the canvas database information, and when you click
OK, opens the Save Parts dialog box. ArtiosCAD Enterprise seeds the Comment field for each part from
the Canvas Database Information dialog box, but you can change it for each part as desired by selecting
the part and changing it. The Add to Bill of Materials column controls whether the new revision of a
part is used on a BOM on which that part appears.
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Click Save to begin saving the parts. Click Close when done.

In ArtiosCAD Enterprise, to control if other Projects containing parts workspaces are updated with new
revisions, use For linked documents, default to 'Update All Related Projects' in Options > Defaults >
Startup defaults > Save Options.

Opening a canvas in ArtiosCAD Standard Edition
To open a canvas in ArtiosCAD Standard Edition, do the following:

1.
 Click Open on the View bar if you already have a document open or click File > Open.

2. In the Open dialog box, use either Directory View or Resource View to navigate to the desired
location. By default, the Files of type selector is set to Designs, which includes canvases.

3. Click the desired canvas. ArtiosCAD shows a preview as with a single design.
 

1239



12 ArtiosCAD

 
4. Click OK to open the canvas.
5. ArtiosCAD checks to see if any parts in the canvas have been saved as independent workspaces,

and if they are different, prompts you to choose which version to use. See Synchronizing Parts for
more information.

6. If the parts have not changed, ArtiosCAD opens the canvas.
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Opening a canvas in ArtiosCAD Enterprise
To open a canvas in ArtiosCAD Enterprise, do the following:

1.
 Click Browser on the View bar if you already have a document open or click File > Browser.

2. Navigate to the desired Project and folder containing the canvas to open. By default, the Files of
type selector is set to Designs, which includes canvases.

3. Click the desired canvas. ArtiosCAD Enterprise shows a preview in the preview pane.
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4. Double-click the canvas to open it.
5. ArtiosCAD Enterprise checks to see if any parts in the canvas have been saved as independent

workspaces, and if they are different, prompts you to choose which version to use. See
Synchronizing Parts for more information.

6. If the parts have not changed, ArtiosCAD Enterprise opens the canvas.
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Synchronizing parts
When you open a canvas, ArtiosCAD check the parts and their independent workspaces (if applicable),
and if there are differences, prompts you to select which version to use in the Update Parts dialog
box. ArtiosCAD Standard Edition looks for newer disk files, while ArtiosCAD Enterprise looks for newer
revisions.

Note:  Parts synchronization is not supported in oine mode in either ArtiosCAD or ArtiosCAD
Enterprise.

To synchronize parts in a canvas, do the following:

1. Open a canvas in which you have saved parts and then made changes to the individual part
workspaces.

2. ArtiosCAD begins to open the canvas, detects differences, and opens the Update Parts dialog box.
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This dialog box lets you choose which version of the part to use in the canvas.
a) ArtiosCAD shows a list of changed parts on the left side of the dialog box. An orange icon means

the part is in its last-saved location. A grey part icon indicates the individual part workspace is
not in the location recorded in the canvas and is missing.

b) Choose which version to use for each part by clicking its option button. ArtiosCAD shows a
preview of the selected part in the preview pane. To quickly toggle all the parts, click Set all to
canvas or Set all to the latest revisions.

c) Ignore these updates until they change again keeps ArtiosCAD from asking you about these
differences by updating their timestamps in the canvas.

d) Click Update to update the canvas with these changes.
3. When you choose a newer version of a part, ArtiosCAD does the following:

a) Replaces the geometry in the canvas part with the geometry from the individual workspace.
b) The bridging and fold angles in the revised part replace those in the canvas part.
c) No construction lines from the revised part copy into the canvas.
d) The position of the revised part with respect to the origin copies into the canvas, which might

cause it to move on the canvas.
e) Layers that were changed in the revised part are changed in the canvas. ArtiosCAD ignores

empty layers, as well as changes to the layer name and class.
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f) ArtiosCAD updates the canvas with any updates to print item definitions in the revised part, but
it does not delete print items in the canvas if they were deleted in the revised part, and it does
not change the definition of the print item in the canvas if it was changed in the revised part.

g) If the grain direction in the revised part is different than that of the canvas part, ArtiosCAD
rotates the part on the canvas appropriately.

h) ArtiosCAD updates the board definition of the canvas part with that of the revised part.
i) ArtiosCAD replaces the database information of the canvas part with that from the revised part,

except for Customer, Owner, Salesperson, and Designer, which are inherited from the canvas.
j) For 3D: If you changed the base face in the revised part, the base face changes in the canvas

part. If you changed the outline of the base face in the revised part, ArtiosCAD clears the base
face of the canvas part. If you made animations in the canvas part, they are preserved when
ArtiosCAD updates the part. If you changed the number of panels in the revised part or the
shape of the base face, ArtiosCAD resets the animation. Animations made in the revised part
after converting it to 3D are not added to the canvas during an update.

k) Color definitions updated in the revised part transfer to the canvas.
l) Graphics added to the revised part transfer to the canvas.
m) If you changed property defaults and formulae in the revised part, they do not transfer to the

canvas.
n) For ArtiosCAD Standard Edition, the database information from the revised part transfers to the

canvas for the simple descriptions, calculated values, and characteristics, with non-existing
characteristics removed and the characteristic description updated based on the code. For
userfields, if the canvas userfields came from a different database (based on the database ID),
ArtiosCAD deletes the ones from the part. If the canvas userfields are from the same database,
ArtiosCAD removes non-existing userfields coming from the part. ArtiosCAD adds all pre-
calculated and required userfields.

o) For ArtiosCAD Enterprise, the database information from the revised part transfers to the
canvas for the simple descriptions, calculated values, and characteristics. ArtiosCAD Enterprise
removes those characteristics present in the canvas part that do not exist in the revised part.
For Attributes, ArtiosCAD Enterprise adds those that exist in the Attribute Category but are not
in the revised part. ArtiosCAD Enterprise re-evaluates calculated Attributes.

p) For board information, ArtiosCAD performs a case-insensitive comparison of the board code
and board description for the parts with the board codes and descriptions in the database. For
those boards that differ, it lists those from the part that it does not find in the database with
their calipers, costs, tests, and papers in the Update Board dialog box.
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Use Add This Board (ArtiosCAD Standard Edition only!ArtiosCAD Enterprise users must use the
normal method of board management), Keep Workspace Board, or Pick New Board. If you use
Add This Board, ArtiosCAD adds the board to the top level of the tree, but without mediums/
liners, 3D information, or texture images. Keep Workspace Board is available only after you have
chosen a different board using Pick New Board and want to return to the original. Do not show
this warning again marks the board as validated. Click OK when you have chosen how to resolve
a board conflict.

Converting a part to Manufacturing
1. To convert a Production part to a manufacturing workspace, do one of the following:

a) Hover over an empty spot of a Production part or its title bar and right-click it. Then click
Convert to Manufacturing on the context menu.

b) Right-click a Production part in the Parts List and click Convert to Manufacturing on the context
menu.

2. If you have not already saved the part as a standalone single design workspace, ArtiosCAD prompts
you for a design name. It automatically seeds it from the part name.

3. ArtiosCAD prompts you to choose parameter sets and machines as usual.
4. ArtiosCAD adds the part to the sheet and awaits your next command.

Parts management

Making a part active
To make a part active, do one of the following:

1. If Parts Frames are turned on, click the part's title bar.
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2. Click the part's name in the Parts List.
3. Right-click inside the part over a blank space so that it turns magenta and click Set Active Part on

the context menu.
4. When you are moving geometry, snap it to a point in a non-active part.

Changing a part's type
There are two main types of parts: Production and Non-production.

Production parts can be converted to manufacturing and are included in various calculations.

Non-production parts cannot be converted to manufacturing and are meant to store information not
necessary for the construction of the container. When a non-production part is selected in the Parts
list, it does not show a board code and the board information and database information buttons are
unavailable. However, you can see and set that information for them in the Database Information dialog
box on the Database menu. Non-production parts are also not selected by default when saving parts
and when outputting a canvas BOM.

To change a part's type, use one of the following methods:

• With the part selected in the Parts List, change the Part type drop-down list box.

• Right-click the part in the Parts list and click Mark as on the context menu. It will be the opposite of
the current state.

• Hover over the part, right-click, and click Mark as on the context menu. It will be the opposite of the
current state.

Two special part types are Output and Remainder, which ArtiosCAD uses only when making an Output
to a layer and when doing a rebuild.

Hardware parts are added by the Add Hardware tool in 3D and can not be added manually. Hardware
parts are in their own folder in the BOM and are deselected by default.

Splitting a part
To split a part into two parts, do the following:

1.
Use Select to select the geometry to put into a new part.

2. Right-click and click Split Part from the context menu, or click Parts > Split Part.
3. ArtiosCAD puts the selected geometry into a new part and moves the current position into the

new part. Note that it does not physically move the geometry; for that, use the normal method of
selecting and moving objects.

If the current selection is all in one part, ArtiosCAD copies the L, W, and D (if set), board,
characteristics, simple descriptions, and Userfields from the original part into the new part.

Moving objects to a part
To move objects to a different part, do the following:

1.
Use Select to select the objects to move to a different part.

2. Right-click and click Move to Part from the context menu, or click Parts > Move to Part.
3. Click inside the part to move the objects into; it turns magenta.
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4. ArtiosCAD moves the selected objects into the part you indicated. The parts expand or contract to
accommodate the moved objects. Note that ArtiosCAD does not physically move the objects; for
that, use the normal method of selecting and moving objects.

Moving a part
When you move a part, everything associated with the part moves, even items in locked and/or
invisible layers. To move a part, do the following:

1.
 Click the title bar of the part (if Part Frames are turned on) with the Select tool and drag the

part to the new position.
2. Alternately, click Parts > Move Part

a) Move the mouse cursor inside the part to move. It will turn magenta to indicate it is selected.
b) Click inside the part and drag the part to its new location.

3. As you drag, ArtiosCAD displays alignment lines to other parts.

If you try to place a part so that it intersects another part, ArtiosCAD displays a warning cursor and
turns alignment lines red, but will let you do it. You should not place parts over other parts.

Changing properties
When you change properties of a selection across multiple parts, ArtiosCAD properly updates each
part and records the change for future use.

Parts Options
Click Parts > Parts Options to open the Parts Options dialog box.
 

 

In the Empty Part Size group, Width and Height set the default size for new parts. Changing these
values does not change the size of existing empty parts.

In the Distance Between Parts group, Horizontal and Vertical control the gutter between parts when
converting to a canvas and using Auto Space Parts. This gutter applies to outermost design lines in the
part, not the part frames.

1248



12ArtiosCAD

The Defaults for these values are in Options > Defaults > Startup defaults > Canvas/Parts Options.

Parts database information
ArtiosCAD is context-aware and shows you the database information for either a part or the canvas
depending on which you have selected in the Parts List.

Parts inherit the canvas' Customer, Designer, Salesperson, and Owner database fields. Those fields
are read-only in the Parts Database Information dialog box.
 

 

In the Design group, Length, Width, and Depth are shown for information only. ArtiosCAD only uses the
canvas variables in StyleMaker. If you set them in a part, ArtiosCAD uses those for Reports and Outputs
but not for actual construction. This is also so that if you import a part from a standard, you can see the
values used to run the standard.

ArtiosCAD shows the Manufacturing database information dialog box for Layout parts. It copies this
information to Manufacturing if you convert the layout part to Manufacturing.
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The table below shows how ArtiosCAD sets the database information for a part depending on its
source.

Create Part Import File as New Part Import Standard as
New Part

Name Set to the part's
filename

Set to the part's
filename

Set to the part's
filename

Saved date Clear Imported from original
file

Clear

Resource Clear Clear Clear

Revision date Initialized to current
time

Imported from original
file

Initialized to current
time

Directory Clear Clear Clear

Revision # Clear Imported from original
file

Clear

Open project Uses current project Uses current project Uses current project

Customer Uses canvas values Uses canvas values Uses canvas values

Owner Uses canvas values Uses canvas values Uses canvas values

Sales person Uses canvas values Uses canvas values Uses canvas values

Designer Uses canvas values Uses canvas values Uses canvas values
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Create Part Import File as New Part Import Standard as
New Part

Description Clear Imported from original
file

Imported from standard

Short description 1,2,3 Clear Imported from original
file

Imported from standard

Authorization Clear Imported from original
file

Clear

Revision description Clear Imported from original
file

Clear

L, W, D Clear Imported from original
file

Imported from standard

Board info Set to canvas board Imported from original
file

Chosen by you during
Run a Standard

Grain Uses canvas values Uses canvas values Uses canvas values

Characteristics Clear Imported from original
file

Imported from standard

Userfields Clear or populated with
required fields

Imported from original
file

Clear or populated with
required fields

Blank width, height Calculated from part Calculated from part Calculated from part

Area Calculated from part Calculated from part Calculated from part

Rule length Calculated from part Calculated from part Calculated from part

Working with read-only parts
Read-only parts let you include designs in canvases without accidentally modifying them. They are also
useful when you want to add a standardized design to a canvas for inclusion on the Bill of Materials.

ArtiosCAD shows that a part is read-only by placing a lock icon next to the name in the part's title bar,
next to the part name in the Parts List, and in the Save Parts dialog box.
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When the active part is a read-only part, ArtiosCAD:

• Makes all fields unavailable for changing in the Database Information and Board Information dialog
box. ArtiosCAD beeps if you click inside them or try to type.

• Makes all tools unavailable.

• Does not allow you to import files into it.
• Ignores it for DieMaker's Fix-It and double line removal in Design Checks.
• Ignores it in the Intersect Design and Add Hardware tools in 3D.

• Does not save changes in 3D to a read-only part back to 2D when saving a 3D workspace.

• Displays "Active Part is Read-Only" in the Layers dialog box.

Making a read-only part writable
To make a read-only part writable, do the following:

1. Make the read-only part the active part.
2. Either:

• Hover over the part in the Parts List, right-click, and click Make Writable on the context menu.
• Right-click the part's title bar and click Make Writable on the context menu.
• Click Parts > Make Active Part Writable.

Making a writable part read-only
To make a writable part read-only, do the following:
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1. Make the writable part the active part.
2. Either:

• Hover over the part in the Parts List, right-click, and click Make Read-Only on the context menu.
• Right-click the part's title bar and click Make Read-Only on the context menu.
• Click Parts > Make Active Part Read-Only.

Note:  By definition, you cannot save a read-only part. Save changes to the part before you
make it read-only.

Breaking the link to a formerly read-only part
To break the link to a read-only part and save the active part as something new, do the following:

1. Make the part writable.
2. Save the new part and change the path, the filename, or both.
3. ArtiosCAD breaks the link.

Rebuild in canvases

When you rebuild a canvas, ArtiosCAD shows the different rebuildable parts as nodes on a tree:
 

 

• ArtiosCAD rebuilds all parts. To rebuild only one part, only change the variables for one of the parts
in the tree.

• ArtiosCAD may put some geometry in the Remainder part.

• If you use Undo or Redo after deleting a part and then rebuild, ArtiosCAD may put extra geometry in
the Remainder part.

• The commands for creating a part and deleting a part get re-executed on rebuild so the active part
may change when ArtiosCAD completes the rebuild.

Parts saved to independent workspaces are not rebuildable. However, if those parts had a specified
L, W, D or board variables, those get exported to the workspace even though the canvas does not use
them.

Parts updated on opening a canvas are not rebuildable in the canvas.
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Geometry pasted into a canvas is not rebuildable as ArtiosCAD does not copy variables from the source
design.

If you change the L, W, or D for a canvas, ArtiosCAD updates the L, W, D for parts having matching
values that were not imported.

When drafting a rebuildable canvas, intra-part referencing works safely.

If rebuilding a canvas is important to you, one suggested workflow for a display standard with multiple
parts that use the same board is:

• Convert it to a canvas
• Make changes to the canvas and rebuild it, but be wary of the number of parts changing
• Convert to 3D and arrange the assembly
• Return to the canvas and modify it
• Rebuild the canvas and use Previous to change the board in the Board Selection dialog box

• Update the 3D workspace.

If you need to rebuild a canvas using different boards for each part, draft parts as separate standards
and add them to a style catalog. Then use Import File > From Standard as New Rebuildable Part and
use a different board for each part as desired.

Undo and Redo in canvases

In a canvas, Undo and Redo work just as they do in a single design. If you Undo creating a new part,
the part created before it becomes the active part. If there is no previous part, ArtiosCAD makes the
canvas active. If you redo undoing creating a part, ArtiosCAD adds the part but does not make it active.

Layers in canvases and parts

The same layers in the canvas exist in all the parts. Different parts cannot have different layers.

Canvases do not have layers of Horizontal cross section, Label graphics, or Shrink wrap graphics.

For locked layers, you can lock layers per part, but if you lock the canvas layer, that layer is locked for all
parts, and likewise for unlocking layers.

The Layers dialog box in canvases has Active Part Lock, which, when clicked, opens the Active Part
Locked dialog box. Use this dialog box to lock and unlock layers for the active part. Layers that are
empty in this part have gray names.
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In the Layers dialog box for a canvas, if one part has a locked layer that is not locked in all parts, or is
not locked in the canvas, the lock icon is present but dimmed.
 

 

Copying and pasting in canvases

When you copy and paste from a single design into a canvas, ArtiosCAD pastes at the origin or bottom
left of an empty part. If the canvas is not empty, ArtiosCAD pastes in the active part to the top left of
the existing geometry. In all cases, ArtiosCAD tries to not overlap parts.

Pasting within the same canvas is similar to using Copy in that you paste into the active part and
activate Move automatically after pasting.

You may not paste items from the Horizontal cross section, Label graphics, or Shrink wrap graphics
layers from other designs as you cannot create a solid of revolution from a canvas.
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ArtiosCAD does not copy print items when you paste.

You may not rebuild pasted geometry as ArtiosCAD does not copy variables from the source design.

Pasting has the following limits:

• Number of layers: 250
• Number of special rules: 39
• Number of fonts: 39
• Number of colors: 999

Changing the boards

Variable indexing
To accommodate part resizability, ArtiosCAD indexes each part's board variables for the caliper, inside
loss, outside gain, and corrugated rounding value (if a corrugated board) (CAL, IL, OG, and CRRV). When
you add parts, the variables have an index number appended to them. For example, for the second part
you add, ArtiosCAD uses CAL(2), IL(2), and OG(2). Using just the variable without an index refers to the
current part. If you want to refer to another part's variables, use its part number in the variable. If you
were working in part 2, using CAL would refer to CAL(2), but to specify the caliper for part 4 while in
part 2, you would use CAL(4).

If you have not renamed the parts, the part name contains the part number. If you have renamed the
parts, use the Boards button in the keypad to open the Select Board Expression dialog box, which
shows the parts and their numbers.
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Changing the board used by multiple parts
To change the board used by multiple parts, do the following:

1. Right-click the board in the Parts List and click Change Board on the context menu.
2. Choose the new board in the Part Board Information dialog box and click OK.

 

 
3. The existing board in the Parts List changes to the new board.
4. If any of the parts were resizable, ArtiosCAD highlights Rebuild on the View bar to indicate you

should rebuild the canvas in order to update the parts with the new variables.
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Changing the board used by one part
To change the board used by one part, do the following:

1. Right-click the part in the Parts List and click Board Information on the context menu.
2. Choose the new board in the Part Board Information dialog box and click OK.

 

 
3. ArtiosCAD adds the new board to the Parts List and moves the part under it.
4. If the part was resizable, ArtiosCAD highlights Rebuild on the View bar to indicate you should rebuild

the canvas in order to update the part with the new variables.

Other notes
When you write a canvas standard, before you add geometry, create the same number of empty parts
as different boards you want to use. Next, change the board for each part appropriately. That way,
when you create geometry and want to refer to different parts' variables, you will easily know the index
number for each part without having to check in the Keypad.

Drafting in canvases

Drafting in a canvas is similar to drafting in a single design, but there are differences. Specific tools and
toolbars have notes following this section.

Report and Counter tools are unavailable in canvases.

Advanced Standard and Registration Holes tools work the same way as Geometry and Dimension
tools.

Undo-Redo, Extend-Measure, and View tools work the same as they do elsewhere.
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Drafting rules
Keep parts separate. Parts should be self-contained.

When you draw new geometry:

• If you draw geometry from a point in the active part, the active part remains active and the
geometry remains in the active part regardless of the location of the end-point.

• If you draw geometry from coordinates in the active part, and snap to a point or intersect another
line in the destination, ArtiosCAD puts the new geometry in the destination part and makes the
destination part active. If you snap to coordinates, ArtiosCAD puts the new geometry in the source
part and does not change the active part.

• If a part is active and the start point is outside it, if the destination snaps to a point in the active
part or intersects a line in the active part, ArtiosCAD does not change the active part and the new
geometry goes in it. If the destination is coordinates, ArtiosCAD puts the new geometry in the part
containing the source and changes that part to the active part.

When you move existing geometry:

• If you snap it to a point, ArtiosCAD puts the geometry into that part and makes that part active.

• If you move it to coordinates or intersect it with a line in another part, ArtiosCAD expands the
source part to include the moved geometry and the source part remains or becomes the active
part.

Construction lines in canvases
Canvases use the Canvas construction line line type. Its default appearance is a long-dashed blue line,
unless the current plotting style has the Remainder type set, in which case ArtiosCAD uses that. For
Outputs, it uses the same tool as Construction line 1.
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Construction line creation
When the canvas is active, ArtiosCAD creates construction lines in the canvas.

When a part is active, and you use items from that part only to make a construction line, ArtiosCAD
puts the construction line in the part as type Construction line 1 and activates that part.

When a part is active, and you use items from two different parts to create a new construction line,
ArtiosCAD creates a canvas construction line and activates the canvas.

When a part is active, and you use a canvas construction line to create a new construction line,
ArtiosCAD creates the construction line in the canvas and activates the canvas.

When you open a canvas, if it has no part construction lines but has construction lines at the canvas
level of other types, ArtiosCAD converts those other construction line types to Canvas construction
lines.

When you convert a design to a canvas, ArtiosCAD converts all construction lines to type Canvas
construction line.

When you import multiple rebuildable designs at once, ArtiosCAD puts all the construction lines into
part 1 as type Construction line 1.

ArtiosCAD does not import construction lines from static designs.

Other notes
When you move a part, ArtiosCAD moves its construction lines too.

Split Part, Move to Part, and Move to Layer ignore all construction lines.
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To move a construction line from a part to the canvas, double-click the line with Select Conlines while
the part is active, then change its linetype to Canvas construction line. This does not work in reverse as
you cannot change canvas construction lines.

Geometry toolbar tools
When you use tools on the Geometry toolbar (Line Angle/Offset, Arc Start Angle, and other tools that
work the same way) with the start- or end-point touching geometry in a part, ArtiosCAD creates the
geometry in that part and makes that part active. If the start- or end-point does not touch anything,
ArtiosCAD creates the geometry in the active part.

Dimension tools
When you dimension lines in a part, ArtiosCAD makes it the active part and puts the dimensions in it.

If the dimensions use Scale text size upon rebuild, the size is based on the canvas. Therefore, to avoid
dimensions at the wrong size, create all the geometry in the canvas before creating dimensions.

ArtiosCAD puts dimensions spanning multiple parts in the current part, even if neither end-point is in
the current part.

Adjust tools
The Adjust tools work in canvases as follows:

• Blend, Chamfer, and Blend Three Lines set the active part to the one in which you are creating
geometry. ArtiosCAD creates the new blend line in the part containing the first line you clicked.

• Split and the Trim tools set the active part the part in which geometry changes. If you selected
geometry from multiple parts, ArtiosCAD does not change the active part.

• Follow and Stretch Point work only within the active part.
•

 Stretch by Polygon has a status bar button, Select in Active Part Only, to restrict the selection
to objects in the active part regardless of the size of the polygon.

Adjust Outline tools
The Adjust Outline tools work in canvases as follows:

• You may only select geometry within the same part.
• Sequence is unavailable in canvases.
• They set the active part to the one in which you change geometry.

Annotation tools
The Annotation tools work in canvases as follows:

• ArtiosCAD puts new text and arrows into the active part.
• In Detail, you can clip only within one part. ArtiosCAD adds the detail to the part containing the clip

and sets it to the active part.
• ArtiosCAD puts the line type label into the part containing the line associated with the label. If you

did not select a line, ArtiosCAD puts the label in the active part. If you selected a line in another part,
that part becomes the active part.

• Artwork Panels, Dynamic Art, Bleed, and Coating tools work only in the active part. ArtiosCAD
changes the cursor to a cross-hair with a No circle if the cursor is over a panel in a non-active part.
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• Hatch, Mate, and Fill Panel work on a panel in the active part, and change the active part to that in
which you clicked. Panels must be in the same part.

Edit tools
The Edit tools work in canvases as follows:

• The Copy tools add to the active part. If the tool has a move mode, ArtiosCAD adds new geometry
to the part containing the put-down point to which you snapped and makes that part active. Copy
Mirror About Center, Copy Mirror About Line, Copy Times Offset, and Copy Times Rotate are
exceptions as they always add geometry to the active part.

• For the Edit tools, all changed items stay in their parts. If all changed items are from the same part,
ArtiosCAD makes this part active. If not, ArtiosCAD does not change the active part. If the tool has
a move mode and the pick-up point is on a piece of geometry in the selection, ArtiosCAD moves the
selection to the part containing the put-down point, which also becomes active. This entire process
may be undone with one Undo.

• Group Sequence and Design from Half/Quarter are not available.
• Group can group only items from one part and that part becomes active.

Graphics tools
The Graphics tools work in canvases as follows:

• Add Graphics adds graphics to the active part.
• Register Bitmap registers a bitmap from any part into geometry in the active part.
• Clip Graphics switches the active part the part containing the selected graphics. You may select

the clipping path in non-active parts but all lines should be in the same part.
• Replace Graphics switches the active part to the part containing the old graphics, but you may

select new graphics from any part.
• Move Graphics and Auto-Trace Bitmap change the active part to the part containing the old

graphics.
• Color Stock works on the active part.
• Fill works on a closed loop of lines all in the same part, and changes the active part.
• Stroke changes the active part to the selection and all lines must be in the same part.
• Fill Panel changes the active part to the selection and all panel lines must be in the same part.
• Send to Front and Sent to Back change the order of layers for all parts and the canvas.
• Save Graphics As exports graphics from any part.

Prepare Manufacturing tools
The Prepare Manufacturing tools work in canvases as follows:

• Bleed and Coating tools work only in the active part.
• ArtiosCAD changes the cursor to a cross-hair with a No circle if you try to select a panel in a non-

active part.
• Bridge tools change the active part to that of the changed line. For a multiple selection using a

rectangle, if all the lines are in one part, ArtiosCAD makes that part active. If the lines are not in the
same part, ArtiosCAD does not change the active part. For Add Nick with the Fill Path option, the
path can be in only one part. If the path already exists, ArtiosCAD changes the line and makes the
part active. If the path goes across parts, ArtiosCAD fills the first line with nicks and does not create
a path. The tools that add construction lines do not change the active part and ArtiosCAD puts the
construction lines on the canvas.
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• Shorten All in Shorten Creases does not change the active part.

Information menu

On the Information menu, Rule Length, Blank Size, Area, and Board information all work on the active
part.

Using geometry macros in canvases

Geometry macros that use the Place the geometry on/offset placement methods should work without
any changes. These include the Folding carton tools, Graphic symbols, Hangars, and Laser Position
Holes geometry macros. These geometry macros will:

• Place the geometry in the active part.
• Set the active part if you snap them to a point.
• Add a layer to the part if needed.

Registration marks that use the Placement computed by geometry macro placement method should
work with parts.

Geometry macros that used advanced placement methods will probably not work correctly as they
expect layers for a single design. These include geometry macros that use Placement computed by
geometry macro (other than registration marks), in-place geometry macros, and INTERACT macros.

The Line Type Legend geometry macro gathers information for the entire canvas and makes a
Remainder part.

Dimensioning the sheet of a layout part
If you want to add dimensions for the sheet of a layout part, there is a geometry macro for that which
places the dimensions in the Overall Dimensions layer of the canvas. It uses the Placement computed
by geometry macro placement method.

1. Make the layout the active part.
2. Click Tools > Geometry Macros.
3. Open the Utilities catalog and click Sheet Dimensions.
4. Click OK. ArtiosCAD adds dimensions to the sheet in the Overall Dimensions layer of the canvas.
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If you change the layout part, delete what was created by the geometry macro before running it again.
You can use Delete Layout Annotation in the Sheet Properties dialog box for this.

Creating your own canvas geometry macro
If you want to create your own sheet dimensions geometry macro for canvas layout parts, here is a
suggested workflow. You will need Advanced StyleMaker for this.

1. Open SHEETDIMS.ARD in InstLib and replicate its menus and variables in your own workspace.
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2. Use sensible non-zero current values such as 1500mm for the sheet width and 20mm for the

margins.
3. Use the variables to make two nested rectangles, one for the sheet and one for the margins (inside

the one for the sheet).
4. Dimension the rectangles as desired.
5. Delete the rectangles.
6. Rebuild the workspace with different sheet sizes and margins to verify it rebuilds properly.
7. If you are satisfied with how it operates, make the variables invisible in StyleMaker by deselecting

the Visible checkbox for each one. If you still want to test it, keep the variables visible as otherwise
when you rebuild the workspace, ArtiosCAD will reinitialize them to their formulas, which will not
work as the geometry macro workspace itself does not have a layout.

8. If you want the dimensions to work in both Imperial and metric, edit the log file using Rebuild
Playback and remove FORMAT 2 from the end of each distance command.

9. Save the workspace.
10. Copy it to ServerLib.
11. Add it to the Geometry Macro catalog. Specify the Placement computed by geometry macro

placement option and enable Move to Layers.

For other types of geometry macros, use placement option Place the geometry at any location.

Useful variables for sheet dimensions
Use these system variables to define the variables in your custom sheet dimensions geometry macro.
The example geometry macro uses them.

System variable Description

#SHTLEFTX X position lower left of the sheet

#SHTLOWERY Y position lower left of the sheet

#SHTSIZEX Sheet width

#SHTSIZEY Sheet height

#SHTMARL Sheet left margin

#SHTMARR Sheet right margin

#SHTMART Sheet top margin

#SHTMARB Sheet bottom margin

These system variables are available as well, but the example geometry macro does not use them.
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#SHTTRIML Distance from left sheet edge to layout blank

#SHTTRIMR Distance from right sheet edge to layout blank

#SHTTRIMT Distance from top sheet edge to layout blank

#SHTTRIMB Distance from bottom sheet edge to layout blank

 

 

Library functions for canvases

Library functions for canvases are similar to geometry macros in that those that depend on the section
structure for a single design will not work properly. To work around this, use these system variables
instead.

Old library function Updated system variable

LIBRARY(DESBLANKX) #MANSIZEX

LIBRARY(DESBLANKY) #MANSIZEY
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Old library function Updated system variable

LIBRARY(DESLEFTX) #DESLEFTX

LIBRARY(DESLOWERY) #DESLOWERY

LIBRARY(DESCENTERX) #DESCENTERX

LIBRARY(DESCENTERY) #DESCENTERY

LIBRARY(LIBAREA1) #AREA

LIBRARY(LIBAREAH1) #AREAH

LIBRARY(LIBWAGRAIN) now uses #MANSIZEX, #MANSIZEY

TLIBRARY(LIBDBSTYLE.TXT) #DBCHARS$

Best practices when designing canvas standards

Keep these best practices in mind when designing canvas standards.

• When using a variable for the number of copies of a part, do a full rebuild and change the variable’s
value as part of the rebuilt. Don’t just change the variable’s value in the Parts List.

• Don’t create canvas standards with layouts or referenced parts. They will just get stripped out when
running the standard.

• During rebuild, a folder uses the documentation plot for its first menu, so make sure that first
menu’s documentation plot has everything needed in it.

• To have a documentation plot for the whole canvas visible in the Style Catalog, add it to the canvas’
Board selection menu.

Layouts in canvases

You can quickly nest production parts together onto sheets using the canvas layout feature. This is
primarily meant to see if the parts will fit on the sheet as they are or if you need to refine their design
slightly to make the most ecient layouts.

Canvas layouts have two components:

• Layouts, which are nested arrangements of parts on one sheet of board
• Jobs, which are groups of layouts of parts on the same board

You can create a layout automatically based on existing parts, or you can create an empty layout and
manually add parts to it.

For parts on layouts, ArtiosCAD shows lines in the Main Design, Manufacturing, and Window and
Cutouts layers. It does not show dimensions, text, arrows, or graphics. However, it retains these items
when you convert a canvas to a manufacturing workspace.

Note:  If you intend to create a layout, ensure none of the part frames in the canvas overlap
each other, as that might lead to unpredictable results.
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Creating a layout automatically
ArtiosCAD can create a layout automatically for all the production parts that use the same board in a
canvas.

To find the nesting outline in a part, the ArtiosCAD nesting algorithm uses either a single loop or a
bounding box. A single loop is formed by:

• All lines, arcs, and/or beziers with non-zero lengths
• Of type cut (and special rule of generic type cut)
• In the Main Design, Manufacturing, or Window and Cutouts layers.

If ArtiosCAD cannot find a single loop, it uses a bounding box formed by:

• All lines, arcs, and/or beziers with non-zero lengths
• Of type cut, crease, print registration, bleed, print images, die etch (types 1..19), and special rules

based on these types
• In the Main Design, Manufacturing, or Window and Cutouts layers.

1. Make sure all the parts in the canvas are clearly separated.
2. Either:

a) Right-click the board in the Parts List and click Create Layout, or
b) Click Parts > Create Layout > (board code).

3. In the Layout Options dialog box, select all the parts to include in the layout. ArtiosCAD selects all
the parts with the same board automatically. Set the values for the sheet size, margins, gutter,
nesting choices, quantities, and sheet edge style. The width and height must be greater than zero.
The gutter and margins must be greater than or equal to zero.
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Alternately, you can choose a standard sheet size or a die press by clicking Standard Sheet Sizes or
Die Press Parameters, and use the values from those sources.
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4. In the Nesting group, set the options for computing the nest as desired.
a) Rotation can be No rotation, 180 rotation, 90 rotation or Any rotation. This applies to all parts in

the layout.
b) Fill direction can be Horizontal or Vertical. This specifies the basic shape of the layout. If you set

this to Horizontal, any unused space in the layout is horizontal.
c) Search time can be Very fast, Fast, Accurate, or Very accurate. The faster the search, the less

accurate the nest.
d) For the strategy, Minimal waste creates the layout with the least amount of waste. Minimal

layout creates the layout with the least overrun for the parts with a greater job quantity. Priority
by size places the emphasis on making the closest number of larger parts to the job quantity.

5. In the Quantity group, set the Job quantity to the number of produced pieces of each part you need.
This must be an integer greater than zero. This number multiplied by a part's number of copies
determines the ordered quantity. Fill sheet adds parts to the sheet even after ArtiosCAD meets
the ordered quantity. There is no control over which part ArtiosCAD uses to fill the sheet. The
proportion of extra copies is roughly equal to the same as it would be for a single job.

6. Click Create to create the layout. If you have more parts than will fit on a single sheet, ArtiosCAD
creates as many layouts as needed to accommodate all the parts in the job. Shown below is a one-
layout job.
 

 
ArtiosCAD stacks multiple layouts vertically to the right of the parts.
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ArtiosCAD remembers your selections in the Layout Options dialog box and will reuse them if you
create additional layouts in this canvas.

7. ArtiosCAD adds the job and layout(s) to the Parts List.
 

 

ArtiosCAD puts all production parts with the same board into the layout(s). It does not place empty
parts or parts with no structural lines in the layout(s). If a part does not fit on the sheet, ArtiosCAD does
not include it in the layout(s) and does not put it in the job parts list.

If ArtiosCAD encounters errors during the layout creation, when it is done creating the layouts, it
displays the Job Information dialog box with a section listing the errors and warnings. In the example
below, the job quantity required a number of layouts that exceeded the limit of 20 layouts per job.
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Recalculating a job
If you change parts, or want to change aspects of an automatically generated layout in a canvas,
recalculate the job. Keep the following in mind:

• ArtiosCAD re-runs the parts through the nesting algorithm using the current part count.

• You will lose any manual changes you made to the layout.
• The number of physical copies of parts in a layout is irrelevant; it is the job quantity across all the

layouts in the entire job that is the relevant number.
• If you recalculate an empty job, ArtiosCAD includes all production parts having the same board as

the layout, except for those parts too large to fit on the sheet.
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• If you recalculate a non-empty job, ArtiosCAD only uses the parts already in the job. Use Edit Layout
to add or remove parts.

• ArtiosCAD recalculates the all the layouts in the job, not just a single layout.

• Recalculate a job rather than using Undo/Redo.

To recalculate a job, do the following:

1. In the Parts List, select either the job or one of its layouts.
2. At the bottom of the Parts List, click Recalculate Job. (Alternately, right-click a job and click

Recalculate Job on the context menu, or click Parts > Recalculate Job).
3. In the Job Options dialog box, ArtiosCAD includes parts with different boards in different nodes

by default and shows the same options as when you created the job or last recalculated it. Set the
options as desired and click Recalculate Job.
 

 
4. ArtiosCAD recalculates the job and rebuilds the layout(s) based on your changes.
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Creating a layout manually
You can also create a layout manually.

1. Make sure all the parts in the canvas are clearly separated.
2. Click Parts > Create Layout > <board code>.
3. In the Layout Options dialog box, deselect all the parts to create an empty layout. Set the values for

the sheet size, margins, gutter, nesting choices, quantities, and sheet edge style. The width and
height must be greater than zero. The gutter and margins must be greater than or equal to zero.
 

 
Alternately, you can choose a standard sheet size or a die press by clicking Standard Sheet Sizes or
Die Press Parameters, and use the values from those sources.
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4. Click Create to create the layout.
5. ArtiosCAD creates the job and empty layout to the right of the other parts, and makes the layout the

active part.
 

 

To get additional layouts in a manually created job, recalculate the job and ArtiosCAD will add layouts as
needed per the number of copies set for the parts.

Adding parts to a layout
There are two ways to add parts to a layout: either by dragging them into the layout or by using Edit
Layout, which is covered in the Edit Layout topic.

To add a part by dragging it into a layout, do the following:

1.
 With the Select tool, drag the part onto the sheet, or use Parts > Move Part.

2. As you drag the part past the sheet border, ArtiosCAD changes the drag of the part frame to the
part outline. Green drag means that the position of the part on the sheet is allowed; red drag means
the position is not allowed.
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3. Click to place the part in the desired position. ArtiosCAD snaps to the borders of the sheet and to

other parts with the gutter, but allows you to place it where you want.
 

 
If ArtiosCAD shades the part grey, that means that either it is closer to another part than the gutter
distance, or it overlaps another part, or that it overlaps the sheet border. If ArtiosCAD shades
the part yellow, that means either it has a different board than the layout, or that there is a grain/
corrugation direction mismatch (if you have that option enabled in Canvas Layout Options in
Defaults).

4. Repeat as desired for other parts.
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5. If desired, optimize the nesting of the layout by clicking Recalculate Job. ArtiosCAD adds layouts to

the job as needed to satisfy the number of copies of the parts.
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Editing a layout
Once parts are on a layout, you may want to adjust their positions. Use Edit Layout to add parts,
copy, move, rotate, and remove parts from a layout. To activate Edit Layout, either click Parts > Edit
Layout, or click inside a part on a layout while the Select tool is active. If you use the menu command,
ArtiosCAD prompts you to select the part in a layout. The layout does not need to be the active part and
this tool does not set the active part.

When active, Edit Layout displays a toolbar above the selected part containing more tools.
 

 
It also highlights the part on which it is acting.
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When you’re in Edit Layout and ArtiosCAD prompts you for pick-up or put-down point, or when
dragging, clicking the right mouse button exits that mode with the parts still selected and the Edit
Layout toolbar present. Click the right mouse button again to exit Edit Layout and return to the Select
tool.

Selecting parts on a layout

 Use Select to select parts on a layout. Clicking inside a part selects it.

You can select multiple parts in a layout to act on them all at once.

• hold down SHIFT or CTRL and click inside the desired parts

• drag a marquee selection window around the desired parts

ArtiosCAD draws a magenta highlight along the inside of the outline of both the part on the layout and
the part in the canvas to show it is selected.

 

 

When you activate one of the Edit Layout tools:

• click the crosshair in the center of the selection to operate with drag including the gutter
 

1281



12 ArtiosCAD

 

• click a point to use specific pick-up and put-down points. Enter a value in an Offset field on the
Status bar to offset from the put-down point.
 

 

Designs remain selected after you put them down.

Moving parts on a layout
To move a part or parts on a layout using Edit Layout, do the following:

1.
 With a part or parts selected and Edit Layout active, click Move Part.

2. As described in Selecting parts on a layout, either click the crosshair in the center of the selection
to move the selection with drag and the gutter, or click a point to use the pick-up/put-down point
method.
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a) ArtiosCAD highlights if you are over a midpoint or endpoint for selecting a pick-up point, and
likewise for setting a put-down point. ArtiosCAD highlights the outline of the part(s).

b) If you are moving a part (or parts) which touches another part and shares the pick-up point,
ArtiosCAD selects the part the cursor is in.

c)
 To offset the put-down point, you must pick up using a specific point and not the center

crosshair. Click the pick-up point and either click Offset Point on the Status bar or ALT-click
on the desired put-down point, and enter the X and Y offsets from the put-down point. You can
type the offsets in the Status bar fields, pressing ENTER after each and TAB to move between
them, or use drag to set them. Once you set the second offset, the parts move to the desired
location.

3. Click to set the put-down point. ArtiosCAD highlights any midpoints or endpoints you drag over.
ArtiosCAD moves the part (or parts) and Edit Layout remains active on the selected part or parts so
you can do other things.

Remember that red drag indicates an unwise (but allowed) put-down point and gray parts mean they
overlap either other parts or the sheet border.

Copying parts on a layout
To copy a part or parts on a layout using Edit Layout, do the following:

1.
 With a part or parts selected and Edit Layout active, click Copy Part.

2. If you selected the part or parts with the center crosshair, use the drag to copy the part or parts to
the new position on the layout. Note that the cursor changes to a copy cursor.

3. Click to set the put-down point. ArtiosCAD copies the part and Edit Layout remains active on the
selected part so you can do other things to the part.

4. If you used a pick-up point to select the part or parts to copy, you can choose between two modes:
a)

 Copy Times Offset works like the Copy Times Offset tool in Designer. After you place the
first copy with drag, set the number of copies with drag (the number appears next to the drag
cursor) and click to make the copies. All copies remain selected.

b)
 Repeated Copy, the default mode, places sequential copies at desired positions. It uses the

original pick-up point for all the copies. Right-click when you are done copying to exit copy mode
and return to Edit Layout with the original part or parts still selected, and right-click again to exit
Edit Layout.

Remember that red drag indicates an unwise (but allowed) put-down point and gray parts mean they
overlap either other parts or the sheet border.

Rotating parts on a layout
To rotate a part or parts on a layout using Edit Layout, do the following:

1.
 With a part or parts selected and Edit Layout active, click Rotate Part.

2. Use the drag handle to rotate the selection about its center by 5-degree increments. Hold down
SHIFT for 90-degree increments.
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3. Release the mouse button to set the put-down point. ArtiosCAD rotates the selection and Edit
Layout remains active so you can do other things.

Remember that red drag indicates an unwise (but allowed) put-down point and gray parts mean they
overlap either other parts or the sheet border.

Deleting parts from a layout
To delete a part or parts on a layout using Edit Layout, do the following:

1.
 With a part or parts selected and Edit Layout active, click Delete Part. You may also press DEL

when Edit Layout is active.
2. ArtiosCAD deletes the selection from the layout.

Deleting a part from a job
To delete a part from a job using Edit Layout, do the following:

1.
 With a part selected and Edit Layout active, click Delete Part From Job. You may also press

SHIFT-DEL when Edit Layout is active.
2. ArtiosCAD deletes all copies of the part off every layout in the entire job.

Note that recalculating the job will not return the deleted part to the job. You must manually add it back
to a layout to return it to the job.

Note:  You can select multiple parts before clicking Delete Part From Job, but ArtiosCAD only
deletes the last part you selected.

Renaming a job or layout
Renaming a job or layout is just like renaming any other part. To rename a job or layout, do one of the
following:

1. Right-click the job or layout in the Parts List, click Rename Job or Rename Layout, and enter the
new name.

2. Or, single-click the job or layout and enter the new name.

ArtiosCAD shows the new name in the Parts List and in the part frame title bar of the layout (for a
layout).

Deleting a layout
Deleting a layout is just like deleting any other part. To delete a layout, do the following:

1. Right-click the layout in the Parts List and click Delete Layout on the context menu.
2. Alternately, right-click anywhere over the layout and click Delete Layout on the context menu.
3. ArtiosCAD deletes the layout.

Note that after you have deleted a layout from a job, recalculating the job may recreate the layout.
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Deleting a job
To delete a job, do one of the following:

1. Select the job in the Parts List, and then click Parts > Delete Job.
2. Right-click the job in the Parts List and click Delete Job on the context menu.

ArtiosCAD deletes the job.

Part Labels
To show or hide part labels on canvas layouts, use View > Show Part Names in Layouts.

Viewing information about a job or layout
To view information about a job or a layout, select it in the Parts List and then click one of the buttons
at the bottom of the Parts List: Job Information, Sheet Properties, or Layout Information.
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In the Job Information dialog box, Unique layouts are the number of different layouts contained in the
job. Total sheets is the product of the number of layouts times their sheet counts. The Job quantity and
Nesting Options each reflect the options you chose when you created the layout.

In the Parts group, ArtiosCAD shows the parts in the job, the number of parts contained in all the
layouts comprising the job, and the difference between the number of parts contained in the layouts
versus the job quantity.

In the Sheet Properties dialog box, ArtiosCAD displays information about the sheet used to make the
layout - the width and height, the gutter, the margins, and the blank size of the layout residing on the
sheet. You can also change the layout justification (its position on the sheet) and specify a sheet edge
style. If you have used a geometry macro on this layout part, use Delete Layout Annotation to remove
its product.
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Change the values in the fields as desired, or click Standard Sheet Sizes, Die Press Parameters,
or Shrink Sheet to Fit to change the size of the sheet(s). If you have a sheet size formula defined in
Defaults (Startup Defaults > Canvas Layout Options, Set Sheet Size from Formula becomes available.

In the Layout Information dialog box, ArtiosCAD shows the waste percentage, the blank size, and lists
the parts in the layout with their count.
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ArtiosCAD shows any errors or warnings about this layout part in this dialog box.
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Converting a canvas layout to manufacturing
Converting a canvas layout to a manufacturing workspace follows the same general workflow
as converting a production part or single design. To convert a canvas layout to a manufacturing
workspace, do the following:

1. Make the canvas layout the active part.
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2.

 Click Convert to Manufacturing on the View bar, or click it on the context menu by right-
clicking the layout in the Parts List or when hovering over the layout itself.

3. Choose the parameter set and machines to use in the Layout Settings dialog box and click OK.
4. ArtiosCAD brings all the production parts from the canvas layout into manufacturing with the same

positioning. It honors the sheet size, margins, and gutter from the canvas layout.
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ArtiosCAD does not maintain a link between the canvas layout and the manufacturing workspace.
There is no way to reuse the settings from a previous Convert to Manufacturing operation.

ArtiosCAD brings all the database information from the layout part into the manufacturing workspace.

If the side setting in the parameter set of the new manufacturing document differs from that of the
canvas, ArtiosCAD flips the layout.

IF the grain of the parameter set of the new manufacturing document differs from the that of the
canvas, ArtiosCAD ignores the parameter set setting and keeps the canvas’ orientation

Canvas layouts notes and warnings
Keep the following considerations in mind when using canvas layouts:

• Dynamic drafting does not provide intersection points from layout parts.
• Drafting and referencing a point within a layout part uses coordinates, not a point reference.
• You cannot select the sheet edge or lines of parts included in layouts. You may not edit them with

normal tools.
• You can use temporary dimensions in a canvas layout using the snap points of the layout and the

included parts.
• If you move geometry using Move instead of Move Part, ArtiosCAD shifts the geometry within the

layout part.

• Most edit tools are unavailable when a layout part is the active part.

• Tools that switch parts when you interact with another part do not switch parts when you work with
a layout part.

• Layout parts use the same grain direction and side as the canvas and the other parts in the canvas.
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• Layout parts do not show up in the Save Parts dialog box and behave similarly as non-production
parts.

• If you create a new part to the right of a layout part, turn off that layout part off and then on again, it
will shift to the right of that new part. It is therefore easy to make the workspace quite spread out.

• Layout parts inherit the canvas database information. If you view the database information for a
layout part, ArtiosCAD shows the Manufacturing database information dialog box, and the pieces of
information inherited from the canvas are read-only. However, you can set the pieces that are not
read-only such as the description, authorization, and revision description.

• If a part is contained in a layout and you change its type from Production to Non-production,
ArtiosCAD does not remove it from the layout.

• Changing the board of a layout changes the board for the entire job.

• If you rebuild a canvas containing layout parts, the parts in the layouts may change size and overlap.
The sheet size does not change during rebuild and ArtiosCAD may move the layouts so they do not
overlap production parts. Recalculate the layout to get the parts sized correctly in the layouts.

• To add production parts to a canvas containing layouts, turn all the layouts off, add the production
parts, and turn the layouts back on.

• When restoring an existing canvas, the side and grain alignment in the default parameter set
functions as follows: 1.) Mirror the parts and the one-ups within the sheet if the side is set
differently, and 2) Rotate the production parts and mark one-ups in yellow on the layouts if the
grain/flute directions differ and Highlight layouts with different grains is enabled in Canvas Layout
Options in Defaults.

Using canvas layouts to save material

Concept
Many display makers who are concerned about minimizing material use for sustainability reasons
have taken to the ArtiosCAD canvas (ACD) format. They do this to help reduce space and so perhaps
using a smaller (flat bed) machine. These users follow score cards for sustainability certifications and
acknowledgements of which waste reduction is one aspect.

The ACD format allows for display parts to be designed relative to each other and for the parts to
be laid out on a sheet within the canvas file. The layout can take advantage of automatic layout and
optimize placement on sheets relative an order quantity. However, this is not what many displays
designers desire. In many cases, parts are manually placed, manually transformed and in some cases
intentionally overlap other parts.

For these reasons, some users create "pseudo layouts": aggregated parts placed in a single part within
the canvas. Geometry macros representing various sized sheets are placed in the canvas. Canvas
layouts are not used for this operation. Differing parts are manually laid out within that rectangular
region representing the sheet and logically group as one canvas part.

In some cases, a designer will intentionally overlap a given part over another. An example:
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Manual placement is done to take advantage of the designer's visual ability to optimize as much of the
sheet as possible.

Parts may intentionally overlap another by bleed or physical structure as to further optimize as much of
the sheet as possible while altering one part does not affect the display's overall structural integrity.

Even though the aggregation of parts into a "pseudo layout" defeats the canvas concept, designers are
willing to do this within the canvas because:

• Placement and editing tools are better in the canvas to create "pseudo layouts".
• A part can intentionally overlap another.
• Annotations beyond the part names (layers: dimensions, text, registration marks, bleed) can be

placed in the aggregated pseudo layout more easily (since it is still considered a design/ARD) and
therefore become visible as a spec sheet.

Workflow
1. Create an empty canvas layout. There are two ways to do this:

1. In the Parts List, right-click the desired board and select Create Empty Layout.
2. From the Parts menu (top bar), navigate to Create Empty Layout and select the desired board.

As usual, these layouts will be defined under a material and a job.

Note:  The sheet size will be based on existing defaults. To change the size, right-click the
empty layout, select Sheet Properties and make the changes.

2. Overlapping production parts and trimming them.
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You can now place (drag) production parts onto the newly created layout. If the materials differ, a
visual cue will indicate this.

In this mode, you will be able to intentionally physically overlap another part, including bleed in a
canvas layout.

When bleed overlaps or parts physically overlap:

• A visual outline of the overlapped parts is presented when the part doing the overlapping is
highlighted. The part placed on the sheet after the other part will get the rendering priority.

• You can trim from the Layout toolbar. Select the part that needs to be trimmed and then select
the Trim tool which will already identify the overlapped parts. Click on the geometry and the
geometry will be trimmed.
 

 
3. Generating a spec sheet / report

Also in this mode, you can place registration marks, enable layers in the parts and annotate the
layout itself.

• About layers: To enable the layers of the parts in a layout, go to Parts >  Layout Part Layers.
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Important:  ARD layers will be used to contain and control visibility within the layout.
However, the annotation does belong to the layout part.

• About annotations: When a layout is selected, these tools allow you to annotate the layout
itself:
 

 
To move or delete annotations, activate the Select tool and select the item as you would in any
ArtiosCAD design.

Tip: You can delete layout annotations from the Sheet Properties dialog.
 

 

• About marks: You can still add print registration marks to any canvas layout so that spec sheets
can be produced with the annotated content. This creates a new custom layer. Follow these
steps:

• Set a canvas layout to be the active part.
• Go to  Tools >  Geometry Macros....

• In Geometry Macros Catalog, go to Registration Marks >  Design and select Print
Registration marks for Designs.
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• Click OK and specify the wanted marks in the next dialogs. This will add the print registration
marks.
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Important:  System variables DESBLANKX(#MANSIZEX), DESBLANKY(#MANSIZEY),
#DESLEFTX , #DESLOWERY, #DESCENTERX, #DESCENTERY can (since v24.03) also be
used in a canvas part. Macros must be derived from these system expressions.

Macros defined for layouts under 'Print Registration Marks for Layouts' can not be used.
 

 
That is because these macros may use library functions which reference 'L1 '. An
example:

size sec :L1 NOGRAPH LINE BEZIER CLASS 0..2,1000.. TYPE 1..9,13,41..79 var
 &minx &miny &maxx &maxy &totx &toty

A canvas layout is not a true layout (as found in an .mfg file). 'L1' will not be found in a
canvas layout and macros referencing this section will fail.

• Aligning by bleed: If the part has an outside or inside bleed outline, parts can be aligned by
their bleed outline. Go to Sheet Properties and select Touch bleed outlines to move a part in the
layout via points on the bleed outline and snap to other bleed points.
 

 

• About a limitation in viewing:

In the File Window of a report, in Layer selection, when using 'Same as current view', the
graphics will not be shown.

Solution: On the report file window, select Specify design layer and select the Graphics layer.
 

1297



12 ArtiosCAD

 

Note:  An output to a regular PDF (not a report) does not have this limitation ; it will
display the graphics.

• Recalculating the job:

When determining the final gutter for a true layout in an MFG file, the larger of the specified
gutter distance between the two knives or the net knife distance when bleed lines touch will
automatically be applied.

For a canvas layout, that is not the case. When recalculating a job, you must specifically define
which mode to use. If the gutter > 0 and Touch bleed outlines is selected, the gutter setting will
take priority.
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To have bleed outlines touch, the gutter must be 0.

• Manual placement: When placing parts with bleed, you can select points on the bleed outline.
You can the drag and snap to other bleed lines.
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Preflight

 Preflight is the process of checking a single design or canvas before it goes into
production. Effective preflight can improve your bottom-line profitability and on-time delivery.

The Preflight module of ArtiosCAD helps structural designers automatically inspect their designs for
anomalies that can cause diecutting performance issues or waste removal ineciencies in production.
The feedback from the Preflight module will help you make changes that can optimize the design
for production during the design phase. This can help reduce the number of iterative cycles before
production.

Preflight works by using a collection of rules called a Preflight Profile to analyze your design and
highlight things that break those rules called anomalies. The Preflight Profiles included with ArtiosCAD
are meant as a starting point. We expect you to create your own Preflight Profiles for use in different
situations as your needs dictate.

You can also define Slotter Scorer Profiles containing machine characteristics for those machines that
may produce this design. Preflight would then tell you which machine(s) could produce this design.

Starting Preflight for the First Time

Clicking Preflight for the first time sets up a free trial subscription license for it using your Esko ID. You
will get warnings that the license is about to expire for a few days beforehand. After that date, you will
need to purchase a license to continue using it. Note that subscription licenses are local licenses and
do not work with Remote Desktop or other terminal emulators.

1. Create or open a single design or canvas you want to check.
2.

 Click Preflight on the View bar or on the Design menu.
3. Enter your Esko ID credentials to continue. If you have already signed in with a subscription license,

ArtiosCAD automatically fills in your Esko ID.
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4. At this point, you can either go to Defaults to configure Preflight Profiles and Preflight Options, or
you can start Preflight. To go to Defaults, click Take Me There Now. To go to Preflight, click Run
Preflight.
 

 
a) To go to Defaults, click Take Me There Now. ArtiosCAD opens Defaults, searches for Preflight,

and highlights all hits. Create new profiles or edit existing ones as desired. Save and exit
Defaults to return to the Preflight Profiles dialog box.
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b) To start using Preflight, click Run Preflight.

5. ArtiosCAD starts Preflight. Proceed to the next section.

Running Preflight

Once you have received your free trial subscription license for Preflight, when you start Preflight, the
process is much quicker.

1. Create or open a single design or canvas you want to check.
2.

 Click Preflight on the View bar or on the Design menu.
3. Choose a Preflight Profile to use and any number of desired slotter scorer machines. Click OK.

ArtiosCAD remembers these choices for the next time you run Preflight.
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4. ArtiosCAD analyzes the design or canvas according to the rules in the Preflight Profile and the

conditions of the Slotter Scorer Machines. The results appear in the dockable Preflight pane, and
it remembers its size and position between sessions. If this is a canvas, ArtiosCAD groups the
anomalies per part. Shown below are a single design and a canvas.
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ArtiosCAD indicates recognized panels with green and blue arrows spanning their width and/or height
as shown in the canvas part above.

The general workflow is that you run Preflight, review the anomalies, and fix them using either Fix
Anomaly (for those anomalies ArtiosCAD can fix) or regular ArtiosCAD tools (for those it cannot).
Then you would either click Refresh above the anomaly tree to update the results, or if you had closed
Preflight, you would re-run it.

Set the default Preflight Profile and desired Slotter Scorer machines in Options > Defaults > Design
defaults >  Default Preflight Profile.

Why Is This an Anomaly?

To see more information about why ArtiosCAD has flagged something as an anomaly, there are a few
places to check.

• Hover over the node in the tree to display more information as a ToolTip
 

 

• Right-click the anomaly in the tree and click Display Profile Setting on the context menu. Hovering
over the information icon in the condition name shows the same information as the ToolTip in the
tree.
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Inspecting the Outline

Having the outline of the design be a closed loop is critical to the ability of Preflight to find anomalies.
The Inspect Outline toggle above the tree lets you easily see if the design (or an isolated Part in a
canvas) forms a closed loop.

1. Open the single design or isolate the canvas part to inspect and run Preflight.
2.

 Click Inspect Outline.
3. ArtiosCAD shows the outline highlighted by a light green swath of color.

a) This is a correct outline.
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b) This is an incorrect outline. There is a small gap at the top left corner. ArtiosCAD does not

recognize it as an RSC.
 

 

Selecting an Anomaly

The idea is that you select each anomaly to inspect it and resolve it.

1. When you click an anomaly in the tree, ArtiosCAD displays pertinent information about it beneath
the tree and highlights it in the design pane.
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2.

 Click Zoom In above the tree to zoom in on the anomaly, or right-click the anomaly in the tree
and then click Zoom In on the context menu. In the example below, the design is violating the rule
about a slot not extending past creases on either side.
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3.

 You can also select an anomaly with the Select tool in the design pane. Make sure to click a few
pixels to its side in order to not accidentally select the geometry it is flagging. When you select an
anomaly with the Select tool, ArtiosCAD:
a) Opens the node in the tree for that anomaly type
b) Highlights the selected anomaly in the tree and shows its properties beneath the tree
c) Displays a drag outline around the selected anomaly in the design pane and highlights other

anomalies of the same type in light blue so you can select another one.
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Accepting and Unaccepting Anomalies

If you think that an anomaly is not really an anomaly, you can accept it so that ArtiosCAD ignores it.
ArtiosCAD remembers accepted anomalies between Preflight runs and when you send a workspace to
another Preflight user.

1. Select the anomaly in the tree.
2. Click the green checkmark beneath the tree, or right-click the anomaly and click Accept on the

context menu. ArtiosCAD inserts a comment with your name and that you accepted it; you may
erase this and enter your own text if desired.
 

 
3. Click anywhere outside the edit box or press Enter. ArtiosCAD changes the icon in the anomaly

tree to a green checkmark to show it is accepted, and increases the count of accepted anomalies.
 

 
4. To accept an entire node of anomalies, right-click it in the tree and click Accept All on the context

menu.

To show accepted anomalies in subsequent Preflight sessions, check Show accepted above the tree.

To unaccept anomalies you have previously accepted, first show them, and then you can either
unaccept them individually by selecting one and clicking the green checkmark beneath the tree, or
by right-clicking it and clicking Unaccept on the context menu. You can also right-click a folder of
accepted anomalies and click Unaccept All on the context menu.

Automatically Fixing Anomalies

ArtiosCAD can fix some anomalies automatically and semi-automatically depending on their type and
effects of being fixed. An example of changing the intent of a design is a fix requiring ArtiosCAD to
make the design non-rebuildable.
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ArtiosCAD displays a wrench next to an anomaly in the tree if it can fix it, and also displays a wrench
next to the anomaly category. Different colors have different meanings.

Table: Wrench Meanings

Solid blue wrench ArtiosCAD can fix the anomaly
without changing the intent of
the design

Solid orange wrench ArtiosCAD can fix the anomaly
but it might affect the intent
of the design. An example of
this is removing zero-length
rules, which may affect future
style choices when rebuilding a
design.

Solid orange wrench with plus
sign

ArtiosCAD can fix the anomaly,
but you need to manually
intervene

Navy blue wrench head and
orange handle

ArtiosCAD can fix some
instances of this anomaly type,
but doing so may affect the
intent of the design

Cyan wrench head and orange
handle

ArtiosCAD can fix some
instances of this anomaly type,
but doing so may affect the
intent of the design, and there
are additional instances it
cannot fix

Solid cyan wrench ArtiosCAD can fix some of the
anomalies of this type but not all
of them

Wrench with lock ArtiosCAD could potentially fix
this anomaly but the layer is
locked

Automatically Fixing a Single Anomaly
1. Expand the Preflight tree node to show the desired anomaly.
2. Right-click the anomaly and click Fix on the context menu.

a) ArtiosCAD zooms in to that anomaly in the drawing area.
b) ArtiosCAD may open the Fix Parameters dialog box if it needs more information, especially if any

part of the wrench is orange.
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ArtiosCAD considers an item extraneous if does not affect the structure or intent of the design.
In this case, deleting the zero-length rule might affect the intent.

c) Hover over the information icon to see a ToolTip describing the anomaly.
 

 
d) Click OK in the Fix Parameters dialog box.

3. ArtiosCAD fixes the anomaly. If you click Refresh, the anomaly no longer appears.

Automatically Fixing an Anomaly Category
Fixing an entire category of anomalies is similar to fixing a single anomaly as previously described,
except ArtiosCAD may prompt you for more information in the Fix Parameters dialog box.

1. Expand the Preflight tree to show the desired anomaly category.
2. Depending on the type of anomaly category, click either Fix if Possible or Fix All on the context

menu.
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a) ArtiosCAD may open the Fix Parameters dialog box if it needs more information, especially if any
part of the wrench is orange.
 

 
ArtiosCAD considers an item extraneous if does not affect the structure or intent of the design.
In this case, ArtiosCAD defaults to fixing just the 2 safe anomalies rather than those 2 plus 157
that might change the intent of the design.

b) Hover over the information icon to see a ToolTip describing the anomaly.
c) If you want to delete all the anomalies and not just the extraneous ones, click Delete.
d) Click OK in the Fix Parameters dialog box.

3. ArtiosCAD fixes the anomalies. If you click Refresh, the anomalies no longer appear.

Automatically Fixing All Anomalies
Fixing all anomalies in a single design, part, or canvas is similar to fixing an anomaly category as
previously described, except ArtiosCAD may prompt you for more information in the Fix Parameters
dialog box.

1. In the Preflight tree, click the desired single design, canvas, or part to select it.
2. Right-click and click either Fix if Possible or Fix All on the context menu.

 

 
 

 

 You can also click the wrench in the toolbar at the top of the Preflight pane to quickly do a Fix
All.
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a) ArtiosCAD may open the Fix Parameters dialog box if it needs more information, especially if any
part of a wrench is orange.
 

 
ArtiosCAD considers an item extraneous if does not affect the structure or intent of the design.

b) Select the checkbox for each preflight rule category to fix.
c) Change the values for any prompts as desired. If changing a prompt makes what was an anomaly

now be okay, the anomaly’s color in the drawing area changes from magenta to blue.
d) Hover over the information icon to see a ToolTip describing the anomaly.
e) If you want to delete all the anomalies for a preflight rule and not just the extraneous ones, click

Delete in that rule category.
f) Click OK in the Fix Parameters dialog box.

3. ArtiosCAD fixes as many anomalies as it can. If you click Refresh, the fixed anomalies no longer
appear.

Note:

You may have to repeat this process several times because fixing anomalies may affect the
design in such a way as to negate other pre-existing anomalies or create new ones.

Example of Using Automatic Fixing
Here is a design (with exaggerated defects) that more clearly shows how automatically fixing anomalies
in Preflight works.
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When you run Preflight, it finds a number of errors.
 

 
This example focuses on rules outside the outline of the design and the sharp corner.

Example of Fixing Rules Outside Outline
This design has two rules outside its outline, one 1/16” and one 3/16”. The tolerance in the default
Preflight Profile for fixing such rules automatically is 1/8”. Thus, it can fix one completely automatically
(the one with the blue wrench at 1/16”) but isn’t sure about the intent of the other one (with the orange
wrench at 3/16”).
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1. Run Preflight, right-click Incomplete outline: Rules outside outline in the Preflight pane, and click
Fix all.
 

 
a) In the Fix Parameters dialog box, it lists 1 extraneous item. This is the 1/8” rule. ArtiosCAD

considers it safe to delete because it satisfies the 1/8” limit in the Delete lines shorter than field
and thus deleting it will not affect the intent and/or integrity of the design.

b) For the 3/16” rule, it may be intended but ArtiosCAD is not sure as it’s not in violation of the Line
extends past intersection rule since it’s longer than 1/16”. It still violates the Incomplete outline
rule, however.
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c) If you toggle between Delete extraneous items [1] and Delete [2], notice that ArtiosCAD turns
the highlight of the 3/16” line blue to show ArtiosCAD will not delete it as it is not extraneous.
The magenta highlight of the 1/8” rule means that ArtiosCAD will delete it if you click OK to fix
it. If you click Delete [2], notice that the highlight of each is magenta, indicating ArtiosCAD will
delete them both.

2. Both rules are mistakes, so click Delete [2] and then click OK.
3. ArtiosCAD deletes both rules and removes the anomalies from the Preflight pane.

Example of Fixing a Sharp Corner
This same design has a sharp corner, which in this Preflight Profile is defined as being anything less
than 75 degrees. If you zoom in, ArtiosCAD shows the suggested fix in the magenta outline.
 

 

1. Run Preflight, right-click Sharp corner requires blend in the Preflight pane, and click Fix.
 

 
2. Enter the desired radius for the blend with which ArtiosCAD will replace the sharp corner and click

OK. As you enter different values, ArtiosCAD updates the magenta outline.
3. ArtiosCAD inserts the blend and removes the anomaly from the Preflight pane.
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Undoing Automatic Fixes
To Undo automatic fixes, click inside the drawing area, and then do an Undo. You can Undo each
separate fix action you have done.

Interpreting Slotter Scorer Results

If you have included Slotter Scorer Profiles when you first started Preflight, ArtiosCAD checks to see if
the machines can produce the design. ArtiosCAD shows the machines in the tree in the same order in
which you arranged them in Defaults, except the machines the design fits on are green and shown first.
 

 

The numbers in the folder name are the number of machines it fits on and the number of machines in
the folder.
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Click an anomaly in the tree to have ArtiosCAD show it.
 

 

ArtiosCAD checks for the following errors for recognized RSCs for slotter scorers:

• Length and width not recognized
• Too many panels
• Missing flap
• Crease is not vertical
• Offset creases
• Flaps different heights
• Irregular-shaped slot
• Slot is not symmetrical
• Slots are not the same
• Missing glue flap
• Irregular glue flap
• Glue flap extension lines being too long
• RSC creases have different types
• RSC main crease is a special rule
• Design has reverse or matrix creases

Changing the Active Profile

1. Click Profile: profile name above the anomaly tree.
2. In the Select Preflight Profile dialog box, choose a new profile and select or deselect slotter scorers

as desired and click OK.
3. ArtiosCAD re-validates the design against the new settings.

Reviewing Active Profile Settings

1. Click … (Display Preflight Settings) next to the active Preflight Profile name.
2. ArtiosCAD opens the Preflight Settings dialog box.
3. Review the conditions in the various groups as desired.

a) Hover over an information icon to see specific information about the condition.
b) Use the search controls at the top right of the dialog box to search for specific words within

conditions.
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c) Note that you cannot toggle check conditions’ use or change their severity while in Preflight; do
those tasks in Defaults.
 

 
4. Click Close to return to Preflight.

Notes on Specific Situations

Some situations are clearer with the following notes to explain them.

Merging Short Lines
The Merge Short Lines anomaly in Drafting > Adjustments highlights when you should replace a series
of short lines or arcs with a straight line or a sequence of arcs. Too many short lines too close together
are dicult to burn and knife, and if you replace them, you can also add bridges.
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ArtiosCAD detects this anomaly when:

• There is a sequence of 3 or more short lines
• It is possible to replace them with arcs or straight lines within the smoothing tolerance
• The resulting arcs or lines are long enough to have bridges.

The Smoothing tolerance defines the maximum deviation allowed from the short lines to the potential
replacement lines and/or arcs.
 

 

Use Arc from lines in Designer’s Fix-It to fix these.

This happens most frequently when importing structural lines from a graphics program.

Parallel Perf
When there are parallel perfs close together, the diemaker places both perf rules in the same slot with
a steel spacer between them, rather than having a thin piece of wood. The available spacer widths are
multiples of 0.014 inch. Thus, if the spacing between parallel perfs is small, and not a multiple of 0.014
inch, the diemaker cannot make it.

ArtiosCAD detects these in the Parallel perf condition in Dieboard stability > Rules > Knives.

Land Length
ArtiosCAD allows you to define a perf or cut/crease with a land length longer than the special rule
pattern. But the diemaker cannot simply cut a piece of special rule to that length; he has to add
another short piece of rule at the end, which often is not long enough to bridge.
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ArtiosCAD detects these in the land length conditions in Dieboard stability > Special rule.
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13.  Manufacturing

Introduction to Manufacturing

Manufacturing is the module of ArtiosCAD that makes production tools from single designs. These
tools are mounted in presses. As the sheets of board move through the press, the tools cut the design
out of the sheet and remove interior and exterior waste.

Within Manufacturing are submodules that perform different tasks. Each module is purchased
separately according to your individual needs.

Layout manually arranges single designs on sheets of board.

DieMaker creates flat dies.

Rotary DieMaker creates rotary dies.

Stripping removes interior and exterior waste.

Intelligent Layout automatically makes many different layouts, compares their waste percentages, and
lets you choose the best layout to make. Coupled with Intelligent Layout is Costing/Estimating, which
calculates how much a layout will cost to make and run across multiple cost centers.

Intelligent Counters, in the context of Manufacturing, manually arranges counters on a sheet of
counter material for milling on a countermaker.

Designing manufacturing tools usually follows this general workflow:

1. Create a layout.

• Create a new blank layout and add single designs to it, or

• Convert a single design to a layout, or

• Convert a single design to a Standard Sheet layout.
2. Create tooling for that layout.

• Create a die wood edge.

• Add stripping rules, carrier rules, and a mounting bar. The stripping rules cut the waste into
smaller pieces for easier removal, and the carrier rules prevent the sheet from sagging as it
moves through the press.

• If using a rotary dieboard, create rule paths and add splits if necessary.

• Add stripping components, rules, pins, and blocks to rid the sheet of waste. The upper and lower
stripping boards (also known as top and bottom, male and female) are created automatically.

Within this two-part workflow there are additional decisions to make. Will you make your own nest or
use the automatic nesting tools? Are Intelligent Layout and Costing/Estimating available? If you use
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Intelligent Layout, do your designs have print items defined? If you use Cost/Estimating, do you have
an idea of possible order quantities desired?

When you open saved Manufacturing files, the layers displayed are set according to the defaults in
Options > Defaults > Shared Defaults > Design Defaults > Default View Mode.

Manufacturing prerequisites

Before designing a layout and creating tooling, you should make sure of the following:

• Machines are set up in Defaults.

• Cost centers are set up in Defaults (if you plan to use Intelligent Layout and/or Costing and
Estimating).

• Board weights and costs are set correctly in DataCenter Admin.

• If intending to use Standard Sheet Layout, that standard sheet sizes are set up in Defaults. See the
Defaults chapter for more information.

In addition, the Manufacturing modules have the following limits:

• For manual layout, the maximum number of repeated designs is 300.

• For Intelligent Layout, the maximum number of repeated designs is 255.

• The maximum number of different designs in a layout is 100.

• The maximum number of design/print item combinations in Intelligent Layout is 100.

• A single design may have up to 100 print items.

• Each single design included must have a unique filename.

Standard Sheet Layout

Standard Sheet Layout quickly nests a single design on a sheet and lets you choose the layout to make
from a list of automatically generated layouts. It works with one single design workspace; to make a
combination layout with more than one single design, either use manual layout or Intelligent Layout.
Standard Sheet Layout requires Intelligent Layout.

To use it, do the following:

1. Open the single design to turn into a layout.
2. Click File > Standard Sheet Layout. The Standard Sheet Layout dialog box opens.

Sheet Layout Parameters tab

The Sheet Layout Parameters tab is the first tab in the Standard Sheet Layout dialog box as shown
below.
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In the Trim group, the fields set the trim tolerances at the edge of the sheet. Set them to be less than
the maximum values for the presses used to produce the layout.

Use gutters inserts gutters between designs in the nest when it is checked. When it is clear, the single
designs touch. The values in the X and Y drop-down list boxes set the gutters in X and Y for the first
and second rows and columns of single designs in the layout. The values in the X2 and Y2 drop-down
list boxes set the gutters between the second and third rows and columns. These are repeated as
appropriate between all the rows and columns in the layout.

In the Nest type group, the checkboxes control the kinds of nests made automatically. Select the
checkboxes next to the type of nests to use; clear those next to undesired nests.

Touch bleed outlines controls whether the designs touch using the bleed outlines or the edges of the
designs. If Use gutters is enabled in conjunction with Touch bleed outlines, the gutters are inserted
between the bleed outlines instead of the edges of the designs.

In the Design options group, Allow 90 degree rotation lets designs rotate so they are cross-grain;
the sheet grain runs in the longer direction. Maximum allowable reduction is the maximum distance
that could be shaved off each design in order for another row or column to fit on the sheet. If such a
cutback is possible in each design, a row or column will overlap the edge of the sheet when a layout is
suggested and there will be values in the various Reduction fields of the Sheet Layout Results dialog
box.

Standard Sheets tab

1. Click Standard Sheets to view or modify the values on the Standard Sheets tab as shown below.
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Listed on the tab are the standard sheets that are defined in Defaults. To use a sheet for possible
layout solutions, check its box in the Use column. To disable its use, clear the checkbox. To toggle the
usage of all sheets at once, click All on/off.

The arrows on the side of the dialog box move the currently-selected sheet up and down in the list of
sheets. The order of sheets on this tab is the same order used to present layout results.

Viewing results

1. Click OK to generate prospective layouts. The Sheet Layout Results dialog box opens as shown
below.
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The list of prospective layouts is initially sorted first by sheet used and then by nest type. Click
any column heading to sort by that column. The first three columns repeat the entries in the sheet
table, while the remaining columns display information about the prospective layout. %Waste is the
percentage of waste on the sheet ignoring holes in the single designs. #X is the number of single
designs across the sheet and #Y is number back. Total displays the number of single designs on the
sheet. The Direction column is blank if the all single designs are with-grain, or displays Rotated if that
option was enabled and used to construct the prospective layout.

The selected prospective layout is shown in the preview window. Click another layout to see its
preview.

The Sheet group shows the grain/corrugation direction and the amount of total reduction needed for
another row or column of single designs to fit on the sheet.

The Oneup group shows the reduction needed in each single design for another row or column of single
designs to fit on the sheet. If the single design was rotated, the word Rotated appears in red.

Click Cancel to return to the Standard Sheet Layout dialog box to adjust parameters.

1. Click Make Layout to make the selected prospective layout.
2. Choose the parameter set and presses for the layout and click OK.
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3. The layout is created and can be modified as desired.

Notes and warnings

Sheet sizes have the with-grain direction first and the cross-grain direction second.

A single design is initially placed on the sheet so that its grain direction matches that of the sheet. If
your single design is being rotated inexplicably and you did not check Allow 90 degree rotation, check
its grain direction in Designer to see if it matches that of the sheet. The Reverse nest types and the
gutters are implemented relative to the laid-out orientation of the single design.

After using Standard Sheet Layout, the original single design workspace is still open and unsaved
behind the layout. When you save the workspace, the manufacturing parameter set information used
to construct the layout is saved in it. If you later convert it to manufacturing or another Standard Sheet
Layout, the presses you selected the first time are selected by default and the Use design parameter
set and Use design press checkboxes are checked. To choose a different parameter set or press,
deselect those checkboxes.

To create a workspace that does not have this manufacturing information in it, create an Information
Filter output that does not include Manufacturing parameter sets, and then output the workspace
through that Output.

If the sheet size of the selected prospective layout conflicts with the one in the manufacturing
parameter press, a warning dialog box appears as shown below after Make Layout is clicked. Choose
the appropriate choice and click OK, or click Cancel to return to the single design.

If the trim is too small, the following dialog box is displayed. Click OK to make the layout or click Cancel
to return to the single design.
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If the trim is too small and the sheet is too big, the following dialog box appears. Choose the
appropriate choice and click OK to make the layout, or click Cancel to return to the single design.

Further examples

Shown below are further examples of the Sheet Layout Results dialog box with all sheets and nest
types selected, as well as Allow 90 degree rotation enabled.
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Intelligent Layout and Costing/Estimating

Intelligent Layout performs automatic sheet layout calculation. Costing/Estimating provides detailed
production costing information for your estimators.

Note that the board cost, die cost, and press cost information need to be approximately correct (within
a factor of two), even if you are not using the cost results, because these costs affect how layouts are
selected.

Costing/Estimating enables the following:

1. Item cost centers such as folder-gluers
2. The Ink coverage, Prompted variables, Cost breakdown, and Cost/item tabs in the Quantities and

Costs dialog box.
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3. The Quantities Mode option to have different layouts for different quantities

Overview: How to design a layout using Intelligent Layout

1. Create designs to use in the layout.
2. Create a new layout and add the new designs to it.
3.

 Click Quantities and costs.
4. Check the board weight and cost to make sure they are correct.
5. Enter the ordered quantities and click Rebuild.
6. Examine the information on the Total Cost tab, decide which layout best meets your qualifications

and click OK.
7. Create tooling.

Refer to the upcoming example for more detailed instructions.

Overview: How to use Costing/Estimating when creating a layout

1. Create designs to use in the manufacturing file.
2. Create a new manufacturing file and add the new designs to it.
3. Use the nesting and copying tools to build a layout.
4.

 Click Quantities and costs.
5. Check the board weight and cost to make sure they are correct.
6. Set ink coverage, if any.
7. Set the values for prompted variables, if any.
8. Examine the information on the Total Cost tab, decide which layout best meets your qualifications

and click OK.
9. Create tooling.

Refer to the example which follows for more detailed instructions.

Example - How to use Intelligent Layout with Costing/Estimating to produce a
layout with multiple items

This example makes a layout with three different designs and uses Intelligent Layout and Costing/
Estimating.

Create three designs
For the purposes of this example, create three designs, all style RT Top Tuck on 2nd (in the Folding
Carton Standards Catalog).

DESIGNA 4 x 3 x 5 inches or 100 x 75 x 125mm

1336



13ArtiosCAD

DESIGNB 4 x 2½ x 4 inches or 100 x 60 x 100mm

DESIGNC 3 x 2 x 3 inches or 75 x 50 x 75mm

If you use different sizes, you will get a different yield and a different number up.

Create a new layout and add the three designs
1. Click File > New > Manufacturing.
2. Click OK to accept default parameter sets and machines, or choose others if desired. A blank

manufacturing file will be created.

3.
 Click Add oneup.

4. Navigate to the directory or resource containing the designs you made, highlight DESIGNA, and
click Open. DESGINA appears in the bottom left of the sheet.

5. Repeat steps three and four for DESIGNB and DESIGNC.
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6. Click Change gutter distance.
7. Select ¼ inch or 5mm from the drop down list.
8. Click OK.

Check the board weight and cost
1. Make sure the Intelligent Layout toolbar is turned on using the Toolbars master control.
2.

 Click Intelligent layout parameters, and then click the Board/Die cost tab. If the designs
were not made in ArtiosCAD2.10 or later, they likely have incorrect board basis weight and cost. The
board basis weight and cost should be reasonable, for example:

Correct the basis weight and cost if necessary. The board cost needs to be approximately correct
within a factor of two for Intelligent Layout to give meaningful results.

3. Click OK.
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Enter the ordered quantities and Rebuild
1.

 Click Quantities and costs.
2. Type ordered quantities such as 100000 for DESIGNA, 300000 for DESIGNB, and 200000 for

DESIGNC as shown in the following dialog box:

3. Click Rebuild to calculate a layout. You will see a progress indicator for a few seconds while it
calculates layouts:

4. When it has finished calculating layouts, the progress control disappears, the run length and yields
are calculated, and the Quantities tab is updated:
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The text at the bottom of the dialog Layout 1 of 6 indicates that it calculated six layouts; cycle through
these layouts using the Next and Previous buttons. Note that layouts are ordered by ascending sheet
cost.

Set the ink coverage
1. Click the Ink coverage tab and enter the number of colors and the inks used. The number of colors is

used to determine the make ready for the printing press and the ink information is used to calculate
ink cost. The number of inks does not have to be the same as the number of colors. For each ink you
need to estimate the coverage and enter the cost per pound/kilo. As an example you might enter an
ink called CMYK at 200% coverage, followed by any spot colors used.

2. After changing the number of colors click Rebuild, as specifying ink affects the selection of the
layout.
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Set the prompted variables
1. The default cost centers for Intelligent Layout include a window width parameter for the windowing

machine, and a Folder diculty for the folder-gluer. Set these parameters for each design as shown
in the following dialog box.

Examine the total cost
1. Click the Total cost tab in the Quantities and Costs dialog box to see information similar to that

shown in the following dialog box:

Here is an explanation of the values in this dialog:
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Table: Quantities and Costs

Term Meaning

Make ready time The time to set up the machine in hours.

Make ready sheets The number of sheets used while setting up the machine.

Speed sheets/hour Average speed of the machine while running.

Run length Number of sheets used while running, separate from make ready. The run
length of the die press is shorter than the run length of the printing press
due to run waste on the printing press and make ready on the die press.

Run time Time the machine is running, hours.

Cost/hour Cost of using the machine per hour.

Rule length Approximate rule length in the die. Does not allow for double line removal
or stripping rules. Used in the calculation of the die cost.

Rule length warning A warning is shown if the rule length exceeds the maximum rule length for
the die press.

Sheet size The size of the sheet in X and Y.

Number of sheets Total number of sheets used, including make ready.

Board area Total area of board used, including make ready.

Board weight Total weight of board used, including make ready.

Layout waste (area of waste in a single sheet) / (area of sheet) * 100%.

Make ready waste (Amount of board used in make ready and run time waste for all cost
centers, including folder-gluers and so on) / (Total board used) * 100%.

Scrapped overrun (Area of board scrapped due to excess overruns) / (Total board used) *
100%.

Total waste (Area of board in the cartons delivered) / (Total board used) * 100%. Note:
This is not a sum of all waste.

Ink Cost Cost of inks used as specified in the ink coverage page.

Printing Cost Cost of using the printing press, including make ready.

Die cost There is a formula for the die cost based on the sheet area and rule
lengths. Note that since there is no separate formula for stripping boards,
varnish blankets and other tooling, the die cost formula should be set up to
include these as well.
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Term Meaning

Diecutting cost Cost of using the die press including make ready.

Total sheet costs Subtotal of board cost + Ink cost + Printing cost + Die cost + Diecutting
cost + any other sheet cost centers.

Item costs Cost of the item cost centers (the ones downstream from the die press)
such as folder-gluer, windowing and shipping.

Total cost Total sheet costs + Item costs.

The formula for calculating the cost of a cost center is:

(make ready cost) + ((run time) * (cost/hour)) + ((# sheets) * (cost/sheet))

Setting the overrun percentage
This section illustrates how the overrun percentage can be controlled by the Overruns tab.

1.
 Click the icon in the lower left to change from the Quantities and Costs dialog box to the

Intelligent Layout Parameters dialog box, and then click the Overruns tab. You will see the following
dialog box:

The table below explains the Overruns dialog box.

Table: Overruns

Term Meaning

Minimum overrun % The minimum overrun acceptable. 0 means make at least 100% of
the ordered quantity.
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Term Meaning

Maximum overrun % The maximum overrun acceptable. 10 means that the customer will
accept up to 110% of the quantity ordered. Anything over 110% is
assumed to be scrap.

Delivered Quantity Quantity delivered to the customer (does not include the scrapped
overrun). Note that the Yield column on the Ordered Quantities page
does include the scrapped overrun.

Delivered % Quantity delivered to the customer as a percentage of the ordered
quantity. Should be in the range 100+minimum% and 100+maximum
%.

Scrapped Overrun The number of excess cartons above the maximum overrun. It is
assumed that these will be scrapped (e.g. thrown out or recycled)
and not processed by downstream machines such as the folder-
gluer.

Different % per print item When on, you can select multiple rows by SHIFT- or CTRL-clicking.
Use this to set the overrun % to be different for different items.
When off, all the items are selected, and you change the overrun %
for all items at the same time.

Minimum overrun option
button

Calculate the run length as the smallest that gives yields >=
minimum overrun for all items on the sheet.

Maximum overrun option
button

Calculate the run length as the largest that gives yields <= maximum
overrun and yields >= minimum overrun for all items on the sheet.

Effect of minimum and maximum overrun
The following example illustrates the difference between the Minimum and Maximum option button
selections.

1.
 Set the option button to Minimum overrun, switch back to the Quantities and Costs page by

clicking the icon, enter new ordered quantities as follows, and rebuild:

1344



13ArtiosCAD

2. You will get a new layout and different yields. Note that you will often get a layout that does not give
the exact yield quantity required, because you can only put a whole number of each design on the
sheet. In this case DESIGNB is 100%, whereas DESIGNA and DESIGNC are slightly over, at 104% and
103%.

3. Switch to the Overruns tab, change the option button to Maximum overrun, and switch back to the
Ordered Quantities page. Do not click Rebuild! Now the run length has increased to fit the maximum
overrun which is 10%:

Scrapped overrun
Sometimes the overrun is larger than the maximum and you get scrapped overrun, particularly when
there are only 1 or 2 of that design on the sheet. For example, change the ordered quantity of DESIGNC
from 250000 to 25000, and rebuild. The new layout has only 2 of DESIGNC, giving a yield of 176%:
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Since the customer will not accept over 110%, the remainder is shown as scrapped overrun on the
Overrun % page:
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Note that when you have scrapped overrun, it makes no difference which overrun method button is
selected.

How to use print items with Intelligent Layout and Costing/Estimating

ArtiosCAD supports the concept of print items. Several print items may have the same structure, but
different print on each structure. All the print items are stored in the same ArtiosCAD design file.

Example: Using print items with Intelligent Layout and Costing/Estimating

The following is an example of how print items work in Intelligent Layout.

Creating Print Items
Start from the layout you made in the previous example and add some print items to the design
DESIGNC.

1.
 Click Open embedded design and select one of the small designs. A new window appears,

titled layoutname:DESIGNC. This is the copy of design DESIGNC that is embedded in the
manufacturing document.

2.
 Click Print items.

3. Enter the name of the first print item, such as Beef.
4. Click OK.

The button  changes to  showing that the current print item is Beef.
5.

Click  again.
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6. Click Create.
7. Type the name of another print item, such as Chicken and click OK.
8. Repeat to add another print item, such as Pork and click OK.

Return to Manufacturing
1. Click File, and then click Return to Manufacturing to close the embedded design.
2.

 Click Quantities and costs.
3. Enter new ordered quantities, e.g. 200000 beef, 200000 chicken, and 300000 pork.
4. Click Rebuild.

5. Click OK to close the dialog to see the layout better.

Check the Print Items in the Layout
1. Click View and then click Item labels.
2. Select Use print item names.
3. Click OK.
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If you have ArtMaker, you can add graphics to the designs and view them by turning on the Graphics
checkbox in the View Mode dialog box on the View menu.

Ghosting constraints

This is an illustration of how ghosting constraints can affect a layout (for the pictures shown here, the
maximum sheet size was 60 x 42 inches).

With no ghosting constraints, the layout looks like this:

There is a light red item behind a dark green item and this may not be acceptable due to printing
considerations (ghosting constraints). The green ink may bleed into the red ink while the cartons move
through the press. To change the ghosting constraints:

1.
 Click Intelligent Layout Parameters, then click Gutters.

2. Click Beef on the left and then clear the Chicken checkbox on the right. This means that the
Chicken item cannot be placed behind the Beef item.

3. Click Chicken on the left and then clear the Beef checkbox on the right. This means that the Beef
item cannot be placed behind the Chicken item.
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4. Click Rebuild. The new layout is built with the constraint that Beef and Chicken items cannot be
placed in the same column:

Multiple Sheets

To illustrate the need for more than one sheet, suppose you had more designs in an order. From the
earlier layout, add two more designs DESIGND and DESIGNE, so the complete list is:

DESIGNA 4 x 3 x 5 inches or 100 x 75 x 125mm

DESIGNB 4 x 2½ x 4 inches or 100 x 60 x 100mm

DESIGNC 3 x 2 x 3 inches or 75 x 50 x 75mm

DESIGND 3 x 2 x 4 inches or 75 x 50 x 100mm

DESIGNE 5 x 4 x 6 inches or 125 x 100 x 150mm

Enter new ordered quantities for DESIGND of 40000 and DESIGNE of 30000, with a maximum sheet
size of 60 x 40 inches or 1500 x 1000 mm, and then click Rebuild. Get results as follows:
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When there are many designs, the proportions might not fit particularly well on the sheet, and there
may be overruns of one or more items. In this case there is 133% of DESIGNE. Because the numbers do
not work out well, we can try fulfilling the order with two sheets.

Intelligent Layout does not handle multiple sheets automatically but it provides some tools for
assistance in this case.

Using the On Checkboxes and Save/Remainder
You could try putting the larger designs on a separate sheet. The two larger designs are DESIGNA and
DESIGNE. To make a sheet with just those, do the following:

1.
 Click Quantities and costs.

2. Turn off the checkboxes for designs DESIGNB, DESIGNC, DESIGND, and click Rebuild:

3. Use Previous and Next to find a layout with the least overrun.

1351



13 ArtiosCAD

4. Click Save/Remainder. A confirmation dialog box will appear.

5. Click OK to save this layout with a new name.
6. The yield quantities from the layout you just saved are now in the Previous column of the new

layout, the checkboxes for the designs in the layout just saved are turned off, and the checkboxes
for the remaining designs are turned on. Click Rebuild to make a layout for the remaining items:
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How to adjust layouts made using Intelligent Layout

To adjust layouts made using Intelligent Layout, use the tools described in this section. Any manual
changes you make to a layout will be lost if you do a Rebuild.

Specify Nest tool

 The Specify Nest tool overrides the automatically calculated nest between designs. To use this
tool:

1. Identify a pair of designs one above the other, for which you want to change the nest.
2.

 Click the Specify Nest tool.
3. Click a pickup point in the higher of the two designs.
4. Drag this design horizontally, and place it using a put-down point in the required position relative to

the design underneath it.

The column containing these two designs is rebuilt using the new nest you have defined. The new nest
will be used in the next rebuild, and if the two designs are the same, in the next use of the manual nest
tools.

Delete Nest tool

 This tool allows nests created by the Specify Nest tool can be deleted. In the Delete Nest dialog
box, hold down CTRL to select more than one nest at a time. Click OK to delete the selected nests.
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Move Design or Column tool

 The Move Design or Column tool makes quick, simple adjustments to a layout created by
Intelligent Layout.

To move a design up or down in a column:

1.
 Click the Move Design or Column tool.

2. Select the design to move.
3. Click near the new position in the same column

To move a column:

1.
 Click the Move Design or Column tool.

2. Click a design in the column to move.
3. Click near the position (in a different column) where you want to move the column.

Manual Adjustments
If you make manual adjustments to a layout created by Intelligent Layout, or create the whole layout
manually, the value in the Quantities and Costs dialog will be automatically updated.

Multiple Quantities in Costing/Estimating

The other mode of using Costing/Estimating is when you have only one design, but you want to quote
several estimates depending on the quantity ordered by the customer. The following example shows
how this works.

1354



13ArtiosCAD

Adding to the list of quantities
1. Open one design in ArtiosCAD.
2.

 Click Convert to manufacturing and choose a parameter set and presses to use.
3.

 Click Quantities and costs. The Quantities and Costs dialog box appears showing the single
design.

4. Click Add Quantity. The format of the Quantities tab changes, showing multiple quantities instead
of multiple items:

5. Click Add Quantity twice more.
6. Enter ordered quantities 20000, 50000, 100000, 200000.
7. Click Rebuild.
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Different Layout for Each Quantity
Note that there is a different number up, hence a different layout, for each quantity. An important
principle in estimating is that the best layout depends on the quantity. For a long run, the biggest
cost is the press time, which is optimized with a large sheet. For a short run, the biggest cost is the
make ready, which is optimized with a smaller sheet. For intermediate run lengths, there is a trade-off
between make ready and the press time. Intelligent Layout does this automatically, but it is important
to understand what is happening.

Clicking on the first column changes between layouts in the same way as the Next and Previous
buttons.

Cost/1000 for Different Quantities
The Cost/item tab of the Quantities and Costs dialog box shows costs per thousand items for each
ordered quantity.

Whether there is a different layout or the same layout for each Quantity is controlled by the Quantities
Mode. If you want to have the same layout for each quantity:

1. Go to the Quantities tab in the Quantities and Costs dialog box.
2. Select the desired layout.
3. Click Quantities Mode.
4. Select Same number up for all quantities.
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5. Click OK.

How to use manual layout tools to design a layout

This section describes how to create a new set of manufacturing tools completely from scratch. A set
of manufacturing tools includes a die wood, into which the cutting rule is inserted; a female stripping
board, through which waste material is pushed; and a male stripping board, which pushes the waste
through the female board.

ArtiosCAD can create many of these elements automatically, but you have the flexibility to design your
own tools as well.

You must create and save the designs to be used in the manufacturing tools before creating a new
layout.

Overview: How to design a layout manually

1. Open one of the designs to be used in the layout and convert it to a manufacturing file. Choose a
parameter set and machines. Add more designs if desired.

2. Use nesting or copy tools to duplicate the design(s) across the sheet.
3. Create tooling.

Creating the workspace and defining machines

The first step in creating a new set of manufacturing tools is to create the workspace that stores them
and to define which machines will use the tools.

To create a new set of manufacturing tools, start ArtiosCAD and click New Manufacturing File on the
File menu. This will create the workspace and prompt you to select a manufacturing parameter set, a
die press, and a printing press. Click OK when you have made your selections.
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Once you click OK, an empty sheet will be created that is sized according to the values in the parameter
set.

Converting a canvas to Manufacturing

 You can convert a canvas to Manufacturing when the active part is not empty and is of type
Production. ArtiosCAD creates a manufacturing workspace and adds the active part to the sheet.

If you saved the parts to individual workspaces, ArtiosCAD uses the part workspace filename for the
base of the manufacturing workspace filename. If you did not save the parts to workspaces, ArtiosCAD
bases the manufacturing workspace filename on the canvas filename and part number.

Otherwise, converting a canvas to Manufacturing is just like converting a single design, as ArtiosCAD
checks the blank size, checks for double lines, and checks for zero-length lines. If the blank size is 0,
ArtiosCAD cancels the conversion.

To add more parts to the manufacturing workspace than just the active part, save the parts to
individual workspaces using Save Parts and then add them to the layout using Add Oneup.

Adding designs to the sheet and arranging them

 The next step is to add a design to the layout. Click the Add Oneup tool. The Add oneup dialog box
will appear along with a window that previews each design clicked.
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Double-click the name of the design to add to the layout. Repeat this process to add different designs.
Do not do this to add more copies of the same design.

Note:  Adding more than one design to a layout creates a combination layout, which is covered
later in this chapter.

 If the design has print items, click the Change Print Items tool to select the print item to use.

Arranging designs using the Nest tools
After placing the design on the sheet, the next step is to arrange as many copies as possible on the
sheet. This process is called nesting.

Note:  There is a limit of 300 designs per manufacturing sheet.

The distance, or gutter, between designs is set to zero by default. You can change it before using a
Nest tool. Alternately, you can change it while using a Nest tool by specifying different step values
between the rows and columns in the edit boxes on the Status bar.
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1.
 Click the Select Design tool and then click a line in the design. Handle points will appear at its

perimeter and it will turn magenta to indicate it is selected.
2.

 Click the Straight Nest tool, or choose one of the other Nest tools from the Nest Tools Flyout
toolbar shown below.
 

 

The first tool on the flyout toolbar is the Straight Nest tool, which performs no rotation or alignment
on the single designs as it arranges them.

 The second tool on the flyout toolbar is the Reverse 2nd Row Nest tool, which flips the design
horizontally every other row.

 The third tool on the flyout toolbar is the Reverse 2nd Row Align Nest tool, which works
similarly to the Reverse 2nd Row Nest tool, except that it butts each row of designs against the
sheet edge instead of nesting them as close together as possible.

 The fourth tool on the flyout toolbar is the Reverse 2nd Column Nest tool, which flips the
design vertically every other column.

 The fifth tool on the flyout toolbar is the Reverse 2nd Column Align Nest tool, which works
similarly to the Reverse 2nd Column Nest tool, except that it butts each column of designs against
the sheet edge instead of nesting them as close together as possible.

 The sixth tool on the flyout toolbar is the Honeycomb Row Nest tool, which nests round
shapes close together by row.

 The seventh tool on the flyout toolbar is the Honeycomb Column Nest tool, which nests
round shapes close together by column. Both honeycomb nest tools support gutters.

3. Once you select a Nest tool, as you move the drag with the mouse, ghost images of the design
appear.

Press tab while the drag is active to change the number of designs and step values between
designs as desired. X1 is the horizontal distance between the left edges of each single design’s
bounding box. Y1 is the vertical distance between the bottom edges of each single design’s
bounding box. X2 is the horizontal distance between the left edges of the second and third columns
of single designs, and then the fifth and sixth. Y2 is the vertical distance between the bottom edges
of the second and third rows of single designs, and then the fifth and sixth. Shown below is an
example of different X1, X2, and Y2 values.

1360



13ArtiosCAD

4. Click the mouse button when the ghost images fit inside the sheet without going over an edge. The
other tools on the Nest flyout toolbar may allow more designs on a sheet; try them all. Shown below
is an acceptable nest. Note that the total number of designs in the nest is shown next to the cursor.

Shown below is an unacceptable nest as the single designs extend beyond the edge of the sheet.
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ArtiosCAD allows nests to overflow by one design so that you can see the distance by which you miss
nesting an extra row. If you miss by only a small distance, this allows you to adjust your sheet size or
gutter as needed so that the extra row fits. If you miss by a large distance, this shows that you have to
accept less designs on the sheet.

Changing the gutter between designs

 The gutter is the distance between designs. By default, the gutter between the nested copies is
set to zero. If you want a gutter between the copies, use the Change Gutter Distance tool and set the
options in the Gutter Distance dialog box to the desired values.
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Touch bleed outlines uses the outer-most lines in the Inside Bleed or Outside Bleed layers of the single
design(s) as the basis for the nest.

Use current print item bleed uses the current print item’s bleed instead of the largest bleed. This is
controlled by a default in the Layout gutters section of the Startup defaults for the manufacturing
parameter set.

Use gutters enables gutters between the design edges. The checkboxes next to Y and Secondary
enable different gutters as described in step 3 of the previous procedure. X and Y in the Primary row
are X1 and Y1, while X and Y in the Secondary row are X2 and Y2.

The gutter will appear in the Nest tool drag.

Gutter defaults are contained in Defaults > Manufacturing parameter sets > Parameter set > Startup
defaults > Layout gutters.
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Arranging designs manually
If you don’t want to use a Nest tool to arrange the designs on the sheet, you can arrange them manually
using the following tools:

• the Copy Designs tool

• the Copy Times Designs tool

• the Move Designs tool

• the Rotate Design tools

• the Mirror Design tools.

To arrange the designs, you must first add at least one design to the layout using the Add oneup tool.
Then select the design using the Select Design tool and use the tools listed above to arrange the
designs as you wish.
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When arranging designs, hold down the SHIFT key to constrain the angle to 0/90/180/270 degrees.
Clicking will only set the angle of the drag – it will not snap to a point if SHIFT is held down.

Making a combination layout

A combination layout is a manufacturing file that contains different designs.

To create a combination layout, do the following:

1.
 Add the different designs to the sheet using Add oneup tool. Use the adjustment tools to

change their position if desired.

2.
 Select all the designs with the Select Designs tool.

3. Use the tools on the Edit Layout toolbar to copy and move the designs.
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Changing the sheet size and justification of the designs

If the nested designs don’t completely fill the sheet, you may want to adjust the size of the sheet or the
position of the designs on the sheet.

 Click the Change Sheet Size tool to do this.

You must choose a layout justification method before you can change the fields in the Size and Margins
groups. The buttons in the Layout Justification group move the group of designs so that the bottom
center of the designs is aligned with the bottom center of the sheet (as shown above); the other
buttons in the group move and justify the oneups in the direction indicated. Once a layout justification
method is chosen, all the other fields become available and you can adjust the size of the sheet and its
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margins. Standard Sheet Layout lets you choose from the list of standard sheets defined for Standard
Sheet Layout. Shown below is a sheet shrunk to the perimeter of the single designs.

How to modify a single design embedded in a manufacturing file

Single designs that you add to a manufacturing file are copied and embedded in the manufacturing file.

Note:  You cannot rebuild an embedded design. Also, do not change both the side up (using the
Side Up tool on the View bar) and the structural orientation (using the Structural Orientation
tool on the View bar); change one or the other but not both. ArtiosCAD stores the creation
time of the embedded design and compares the internal timestamp to the one of the
original workspace on the hard disc to check if the original design has changed since it was
embedded. If the layout workspace came from another site, ArtiosCAD cannot compare the
timestamps and it will take a long time to open the workspace. To disable this check and have
the workspace open faster, deselect the Check embedded designs upon opening MFG file
checkbox in Options > Defaults > Shared Defaults > Startup defaults > Embedded Design
Check.

To change a single design embedded in a manufacturing file, do the following:

1.
 Click the Open Embedded Design tool and select the oneup to open. If desired, deselect the

Add layout lines checkbox. If you leave the checkbox selected, annotation lines representing the
designs touching the selected design are shown in Single Design for reference while editing as
shown below.
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The initial state of the checkbox and the amount of annotation lines shown are set in Options >
Defaults > Startup defaults > Embedded Design Window Size.

2. Modify the design as desired.
3. To save the embedded copy as the original file, click File > Save Design, use the same filename,

confirm overwriting it, and then click File > Return to Manufacturing. To save it as a new
workspace, enter a new filename in the Save As dialog box. The Save button on the toolbar does a
Save As.

4. To keep the original copy as it was and only modify the embedded version, click File > Return to
Manufacturing.

How to replace designs in a layout

To replace a design in a layout, use the Replace Selected Oneups tool. The Replace Selected Oneups
tool can also rename designs in a layout, or save them as entirely new single design workspaces with
new names.

To replace a design in a layout with another, do the following:

1.
 Select the instances of the design to replace with the Select Oneups tool. Hold down CTRL to

select more than one instance.

2.
 Click Replace Selected Oneups. The Replace Oneup(s) dialog box appears.
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3. There are two main option buttons in the Replace Oneup(s) dialog box. Browse for new oneup,
when clicked, prompts you to select a new file for replacing the one currently in the layout.
Selecting Split out selected oneup(s) lets you either save the selected design(s) as a new single
design workspace (Save selected oneup(s) as new design file) or just rename the selected design(s)
in the layout (New oneup name). Choosing New oneup name does not create a new file.

4. Click OK to either browse for the new design, save a new workspace, or rename the design in the
layout.

If the new design is a different size than the original, or has a different grain/corrugation direction, or a
different position, the Replace Oneup Position dialog box appears as shown below.

To change the position of the new design in reference to the position of the bounding box of the old
design, click the appropriate button in the Position group.

How to perform manual sequencing of designs

 ArtiosCAD usually performs automatic sequencing of single designs within a layout when it is
output. If desired, you can turn off the fully automatic sequencing in the Output definition and control
the automatic sequencing of the single designs yourself using the Layout Manual Sequencing tool.

This tool is available only in the Dieboard layer of manufacturing files and also in counter layouts. This
tool does not have Undo functionality.
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Note:  Any sequencing done with this tool will be lost on Output if sequencing is enabled in
the Output definition in Defaults. To check for a CAM output, open the Output definition in
Defaults and look on the Processing tab. If the Sequence one-ups in layout option is checked,
ArtiosCAD will discard the manual sequencing you specified when the layout is output.
To deselect the checkbox, check the Enable subroutined output checkbox and clear the
Sequence one-ups in layout checkbox. To check for a Sample output, look on the Sample
Sequencing tab and clear the Sequence one-ups in layout checkbox.

When activated, this tool places option buttons on the Status bar as shown below and performs a
default nest from the bottom left by row.

Sequence order numbers appear in the center of each single design indicating their cutting order.
Green dashed lines connect the designs. The picture shown below is the default sequence.

  The first group of four buttons sets the starting point for the sequencing. The first
button starts the sequencing at the bottom left of the layout. The second button starts the sequencing
at the bottom right of the layout. The third button starts the sequencing at the top left of the layout.
The fourth button starts the sequencing at the top right of the layout.

 The second group of four buttons controls the sequencing direction and is not
available until a button in the first group is pressed.

The first button sequences each horizontal row, starting each row on the same side of the layout so
that each row is sequenced in the same direction, as shown in the picture above, with the starting
point at the bottom left.

The second button sequences each vertical column, starting each column on the same side of the
layout so that each column is sequenced in the same direction. The picture shown below starts from
the bottom left.
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The third button sequences each row, starting on opposite sides of the layout so that each row is
sequenced in the opposite direction, forming a horizontal snake pattern. The picture shown below
starts from the bottom left.

The fourth button sequences each column, starting on opposite sides of the layout so that each
column is sequenced in the opposite direction, forming a vertical snake pattern. The picture shown
below starts from the bottom left.

 The Sequence All button lets you manually sequence the single designs in the layout.
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To use this tool, do the following:

1.
 Click Sequence All.

2. Click the first design in the sequence. It will become number one, and all the others will increment
up by one to reflect the change.

3. Continue clicking single designs. As you click them, they will be incremented up by one - the first
design clicked is one, the second two, the third three, and so forth, with the remaining designs
incrementing up by one conforming to the pattern you selected on the Status bar.

The sequence shown below is exaggerated for effect.

 The Sequence Range button lets you resequence a specific range of one-ups, instead of
sequencing all of them.

For example, in the layout shown below, it is sequenced by row, but perhaps it should be a vertical
snake instead.

To resequence the single designs without using the automatic sequencing tools, do the following.

1.
 Click Sequence Range and then click design three. It will not change.

2. Indicate next item will appear on the status bar. Click design six. It will change to design four.

1372



13ArtiosCAD

3. Click design six to change it to design five. What was design five changes to design six at the same
time, and the resequencing is complete.

This tool works in the same way for resequencing counter layouts.

Note:  Any sequencing done with this tool will be lost on Output if sequencing is enabled in the
Output definition in Defaults. To check, open the Output definition in Defaults and look on the
Processing tab. If the Sequence one-ups in layout option is checked, ArtiosCAD will discard
the manual sequencing you specified when the layout is output. To deselect the checkbox,
check the Enable subroutined output checkbox and clear the Sequence one-ups in layout
checkbox. To check for a Sample output, look on the Sample Sequencing tab and clear the
Sequence one-ups in layout checkbox.
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How to create tooling

Tooling refers to the manufacturing elements in the presses that actually make the containers. Die
boards, rubber, upper and lower stripping boards, and blankers are tooling. You can easily switch which
tooling layers are turned on by clicking Dieboard, Rubber, Stripping Boards, or Blanking in the Layers
dialog box.
 

 

A note on Auto-repeat

 The Auto-repeat tool on the View bar automatically repeats elements such as stripping rules,
holes, and pins throughout congruent areas of the layout. Clicking the tool turns it on and off.

Auto-Repeat has three different modes. The mode is set in the Auto-Repeat flyout toolbar opened by
clicking the drop-down arrow next to the Auto-Repeat button on the View bar.
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 No Mirror auto-repeats those elements, areas, or constructions that look exactly like the object of
the current tool’s action.

 Mirror about Vertical auto-repeats elements, areas, or constructions that match the object of the
current tool’s action either exactly or mirrored about the vertical axis (in effect horizontally).

 Horizontal and Vertical Mirror auto-repeats elements, areas, or constructions that match the
object of the current tool’s action exactly, mirrored about the vertical axis (horizontally), or mirrored
about the horizontal axis (vertically).

Table: Tools using Auto-Repeat

Add Bridge Add Interference Add Nick Strip Area

Add Tack Add Upper Block Add Upper Pin

Add Upper Rule Create Carrier Rule Create Stripping
Rule

Delete (with manufacturing selection) Delete Bridge Delete Nick

Delete Strip Area Make Air Hole Move Bridge

Move Nick Repeat Repeat Strip Area

Auto-Repeat works by comparing what items an object touches or crosses.

Table: Auto-Repeat Dependencies

Element Auto-Repeated depending on

Stripping rules

Air holes

Which designs they touch or cross

Lower holes Waste areas

Pins

Upper rules

Blocks

Lower hole or edge region they are in

Lower carrier rules Which hole or edge region they cross

Block pins Congruency of blocks contained in

1375



13 ArtiosCAD

Element Auto-Repeated depending on

Rule paths Congruency of potential Rule paths

How to manipulate elements and designs

In order to geometrically manipulate elements (the non-design parts of a manufacturing file) and
designs, you first have to select them. Selected items turn magenta. You can use the tools on the
Adjust Outline toolbar to manipulate elements as well as the tools listed below.

 The Select Element tool selects individual elements. Use this tool to select pins, pieces of rule,
mounting holes, bars, etc. This tool cannot be used to select any part of a design. Hold down CTRL to
make multiple selections.

 The Delete Element tool deletes the selected element(s). This tool is available only when there is a
current selection. This tool uses the settings in the Auto-Repeat dialog box.

 The Repeat Element tool takes a single element and auto-repeats it throughout the
manufacturing file. This tool is available only when there is a current selection. It mirrors according to
the settings in the Auto-Repeat dialog box.

 The Select Oneups tool selects a design. Hold down CTRL to make multiple selections.

 The Delete Oneups tool deletes the selected design(s). This tool is available only when there is a
current selection.

Creating the dieboard edge

 Once the designs are nested, create the dieboard edge. If necessary, switch to the Dieboard
layer using the layer control on the View bar. Click the Create Wood Edge tool to automatically create
a dieboard edge. If the die wood is not in the position you would like, select it and double-click it to
access the Properties dialog box. You can then change the dieboard size, how it is aligned, the method
for making the corners, and if it is a rotary die, the level at which the layout is viewed. Click OK to return
to the layout.
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Once the dieboard edge is created:

•
 use the Create Hand Hold tool to add hand holds.

•
 use the Create Burn Name tool to add a burn name, or use a Geometry Macro to add a more

verbose burn name.

•
 use the Add Tack Bridge tool and the Delete Bridge tool to add and remove tack bridges.

Click the Add Tack Bridge tool and click the point on the die wood edge where you want the tack
bridge. Click the Delete Bridge tool and indicate the tack bridge to delete.

• Double-click the dieboard edge with a Select tool to change its properties.
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How to create scrap knives

Scrap knives chop the waste into evenly sized rectangles. Where the waste meets the design, the
waste follows the contour of the design but fits into the grid of scrap knives on its other edges.
 

 

Scrap knives use the same stripping edge and hook parameters as Create Stripping Rule.

Scrap Knives dialog box
When you create scrap knives, the Scrap Knives tool first opens the Scrap Knives dialog box so you can
set how ArtiosCAD will create them.
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The values in Horizontal and Vertical set the size of the pieces. If Offset is set to a non-zero value, the
vertical lines zig-zag by that amount. There can be slight exceptions to these sizes to compensate for
corner offsets and bend lengths.

Thin pieces of waste can be a little longer than the nominal width or height of normal scrap pieces.
In the Thin Pieces group, set the size limits for such pieces. ArtiosCAD chops pieces of scrap whose
width is less than or equal to the thin width into pieces whose length is less than or equal to the thin
length.

The Other tab of the Scrap Knives dialog box is shown below.
 

 

Corner Offset sets how far scrap knives must be from a corner. For optimal results, the corner offset
should be less than 1/5 the horizontal and vertical size.

ArtiosCAD will bend a scrap knife to meet the design perpendicularly if the angle at which it meets the
design is more than the Minimum bend angle. The value in Bend Length sets the length of the segment
that is perpendicular to the design.
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ArtiosCAD considers arcs larger than the value in Arc Sensitivity to be blends. Scrap knives generally
do not meet arcs and are positioned away from them by the amount of the corner offset. But if an arc is
large enough, a scrap knife can meet it.
 

 

Some diemakers use standard-sized pieces of rule with an optional hook on the end when a scrap knife
extends off the sheet. Standard rules may be slightly shorter than the scrap knives they replace so that
they do not go outside the stripping edge. These standard rules are defined on the Standard Rules tab
of the Scrap Knives dialog box.
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You can define four such pieces of rule in Defaults (Options  > Defaults > Die Press parameter sets >
Your press > Scrap knives > Standard Rules). Check the checkboxes for the standard pieces of rule to
use and change the Length if desired. Change the Length and Radius for the hook if desired.

ArtiosCAD follows these rules when placing standard rules:

• If the length of the rule being replaced is between the lengths of two standard rules, it will use the
shorter one.

• The length of the standard rule must be less than or equal to the length of the rule it replaces.

• The amount the standard rule passes the edge of the sheet minus the hook must be at least half as
much as the rule it replaces.

• Standard rules on the leading edge do not get hooks, because there is usually no room to fit the
hook in the die.

Adding scrap knives to a layout
To add scrap knives to a layout, do the following:

1. Create a layout in ArtiosCAD.
2. Click Tools > Scrap Knives.

The Scrap Knives dialog box appears.
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3. When you have finished setting the options on all the tabs of this dialog box as described previously,

click OK to create the scrap knives.
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To make a corner be one continuous rule, add stripping rules at the corner before adding scrap knives.

How to create evenly-spaced scrap knives

 The Evenly Spaced Scrap Knives tool creates scrap knives in the waste to the side of an existing
line, typically a stripping rule.

The Evenly Spaced Scrap Knives tool has two modes. The first mode is when a stripping rule is clicked
as the first scrap knife and a freehand coordinate is clicked as the second point. The second mode is
when a stripping rule is clicked as the first scrap knife, and then another stripping rule is clicked as the
last scrap knife.

Shown below are the scrap knives created when the stripping rule on the left dust flap of the lid of
the left design is chosen as the first scrap knife and the drag is moved to the right with the cursor
being kept near the top of the sheet. The knives are evenly spaced until the drag is set, after which the
Number: field becomes available for changing as desired. Once the Size: and the Number: fields are
set, click OK to create the scrap knives.

To use the tool in its first mode, do the following:

1. Create a layout and add stripping rules to it.
2.

 Click the Evenly Spaced Scrap Knives tool.
3. Click a stripping rule from which the scrap knives will be offset.
4. Use the drag to set the number of scrap knives and click the mouse button somewhere that is not

on a line.
5. Review the values in the Size: and Number: fields, changing them if desired.
6. Click OK to create the scrap knives.

To use the tool in its second mode, do the following:

1. Create a layout and add stripping rules to it.
2.

 Click the Evenly Spaced Scrap Knives tool.
3. Click a stripping rule from which the scrap knives will be offset.
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4. Next, click another parallel stripping rule as the final scrap knife.

Note that the Size: field has changed so that a whole number of scrap knives can fit between the
first stripping rule and the second stripping rule.

5. Adjust the value in the Number: field as desired and click OK to create the scrap knives. Note that
the distance between each knife changes as the number of knives changes.

The drag for this tool is very sensitive. The tool can operate differently just by clicking a few pixels
apart.

If you click another line as the last scrap knife, that has the effect of accepting the currently-shown
scrap knives and restarting the tool with the selected line being the first scrap knife. This allows the
quick and easy creation of several sets of chop knives.

Properties of evenly spaced scrap knives
Scrap knives created with the Evenly Spaced Scrap Knives tool are made with line type scrap knives.

They use default bridging and their default pointage is set in Options > Stripping rules.

Whether they have hooks on the end is set in Options > Hook Defaults.

For rotary dies, the bend length (or perpendicular offset) is set in Tools > Scrap Knives > Other > Bend
Length.

If a scrap knife is made from more than one line, a group is created so it can be selected as one item.

The initial value for the Size: field is set in Options > Defaults > Die press parameter sets > Parameter
set > Scrap Knives > Size > Horizontal Size. To change it on the fly, click Tools > Scrap Knives and set
the Size: field in the Horizontal group.

How to move scrap knives

 Use the Move Scrap Knife tool to move a scrap knife or stripping rule that is not in the desired
location.

When this tool is active, it has settings on the Status bar as shown below.
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The first button sets the offset of the moved or copied scrap knife to be from the selected rule, while
the second button sets the offset to be from the nearest end of a line.

Parallel controls whether or not the drag will only snap to positions parallel to the original scrap knife or
if the drag will snap to positions perpendicular to the original alignment as well.

Copy makes a copy of the selected scrap knife instead of moving it.

Offset sets the offset distance from either the selected rule or the nearest end of a line according to
which button is pressed.

To use this tool, do the following:

1.
 Click the Move Scrap Knife tool and then click the scrap knife to move.

2. Drag the knife to the new position. If there is a bend on the start of the rule, it will be recalculated
as needed. If you align the new scrap knife with an existing scrap knife, a dotted line will be drawn
between the two to indicate alignment.

3. Click the put-down point for the new scrap knife.

How to add balance knives

 Balance knives are used to balance the die wood when the die wood has a lot of empty space on it.
To use this tool, click it. Balance knives will be added according to the values in the fields in the Status
bar. Shown below is a layout before adding balance knives.
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Shown below is the same layout after balance knives have been added.

Edit the properties of balance knives by using the fields on the Status bar. Distance between: is shown
only for reference and may not be changed.

Balance knife operation is defined in the Die Press parameter set in Defaults. The length of the rule can
be calculated according to a rule-saver formula, which minimizes the rule needed, or the rule can be
set to extend to the design blank edge or the stripping blank edge. Balance knives are computed in the
Rule Length dialog box as Balance rule. The #BRLEN expression calculates the length of the balance
knives.

How to create stripping rules

  Two tools create stripping rules: the Line/Edge tool and the Angle/Offset tool. The Line/
Edge tool creates a stripping rule from the point you indicate in the direction that you set until it
intersects with another line or an edge. The Angle/Offset tool creates a stripping rule with the angle
and offset end-point that you specify. Hooks are automatically added to the stripping rules on the
trailing edge. The stripping rules are automatically repeated throughout the layout unless Auto Repeat
is turned off.

Note:  You cannot create exterior stripping if there is a full lower board.

When either of these tools are active, options which control their use appear on the Status bar.
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The three buttons on the left control the starting point of the stripping rule. The left most button
is Offset from the end of a line, the middle button is Center of a line, and the rightmost button is
Anywhere.

 More options lets you change the stripping rule options in the Stripping Rules Settings dialog box,
also accessible by clicking Options > Stripping Rules, as shown below.

In the picture below, stripping rules extend from some of the dust flaps.

How to create carrier rules

 Use the Create Carrier Rule tool to create carrier rules. Carrier rules support gaps in the boxes
through the press so that they do not snag and jam the press. To use this tool, click it, indicate the
point at which the carrier rule starts, and then indicate the point where it ends. The flaps are added to
carrier rules when you strip the carried area.

 To add carrier rules, click the Create Carrier Rule tool and indicate the start and end-points for the
carrier rule. The Status bar shows the same start options for carrier rules as it does for stripping rules.

The three buttons on the left control the starting point of the carrier rule. The left most button
is Offset from the end of a line, the middle button is Center of a line, and the rightmost button is
Anywhere.
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 More options opens the Stripping Rules Settings dialog box. Since these are carrier rules, you
cannot change the type of rule being created. Set the number of bridges, pointage, bridge width, the
snap angle for the drag, and the start point offset as desired. Click OK when done to return to the tool.

Once the carried areas are stripped, there are two ways to change the properties of a carrier rule.

The first way to set carrier rule properties is to use the Select Element tool in the Stripping Rules layer
to double-click the carrier rule. This changes how the stripping rule that is a carrier rule is displayed in
the Stripping Rules layer. A Properties dialog box appears with rule properties as shown below.
 

 

The second way to set carrier rule properties is by changing to the Lower Stripping Board layer and
using the Select Element tool to double-click the rule. This changes how the rules are manufactured in
the stripping board itself. The Lower Rule Properties dialog box opens as shown below.
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Change the pointage of the carrier rule by choosing a new value from the Pointage drop-down list box.

The length of the carrier rule shown in the Length: field depends on the option button chosen in the
Rule length type group. Use run length shows the length of the rule without the flaps. Use rule length
shows the length of all the rule.

Use design file for end lets you specify a custom flap end.

You can design any end as desired. In Designer, start at the origin and work to the upper right using
line type Unknifed lower for rule and line type Lower registration hole for any holes. The origin will
be the end point of the end of the carrier rule. Do not use line type Annotation5. Save the workspace
to ServerLib and specify it in Defaults in the Carrier Rules entry in Automatic Stripping in a
manufacturing parameter set.

The Top flap points right and Bottom flap points right checkboxes change the direction of the top and
bottom flaps, respectively. The flaps are applied when the layout is stripped.

Change the properties as desired and click OK.

In the example below, one carrier rule was created manually. The rest of the designs have the carrier
rule Auto-Repeated in them.
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When an area containing a carrier rule is stripped, the rule between the edges of the hole is converted
to an Annotation5 line type. This prevents the laser from burning a rule path in the material under the
hole when the stripping board is created.

How to add hooks to stripping rules

 ArtiosCAD creates hooks on the ends of stripping rules by default. This can be changed, however,
in the Hook Defaults dialog box accessed via the Options menu. If you have added stripping rules
without hooks and later decide that you want hooks, use the Make Hook tool. To use this tool, click it,
and then indicate the stripping rule that you want to have a hook. If Auto-Repeat is on, the hook will be
created on all congruent stripping rules.

How to create a lower board mounting bar

 When making a stripping board that follows the layout edge, you must create a mounting bar for
the lower stripping board. The mounting bar defines where to start stripping the edges. Use the Add
Lower Board Mounting Bar tool to add the bar.

When this tool is clicked, options for it appear on the Status bar as shown below.
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Strip between designs inserts stripping rules between single designs under the mounting bar. (They
are only visible when the Lower stripping board layer is turned off.) Offset lets you specify the distance
from the board edge to the mounting bar instead of setting it with drag.

To use this tool, click it, set the options on the Status bar as desired, and either specify an offset for
the bar location or use the drag to set it. A sample mounting bar is shown below.

This tool uses the stripping rules settings and is consistent with Move Scrap Knives. To control if there
are hooks on the ends, click Options > Stripping Rules > Bend Length.

How to add and work with mounting holes

 The Add MHP Holes tool adds Mounting Hole Pattern holes to the manufacturing workspace. When
held down, it activates the MHP Tools flyout toolbar.
 

 

These tools are available only after the die wood edge has been created.

Add MHP tool

 The Add MHP Hole tool copies the mounting hole pattern workspace associated with the selected
die press into the manufacturing file. Mounting holes can be either good or bad - bad holes are those
that are too close to other manufacturing elements as defined by the T-nut Distance default.

There are two options in the Status bar: Show all holes and Show only good holes. Good holes are
green and bad holes are red. Choose what kind of holes to see, and then hold down either SHIFT or
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CTRL and click each mounting hole to use. Click OK when all desired holes have been selected, and the
selected holes will be created.

The side of the layout the pattern is applied to is defined in Defaults on the Hole Patterns page of the
Press Defaults in the Die press parameter sets folder.

Select MHP tool

 The second button on the MHP Tools flyout toolbar activates the Select MHP tool. This tool
redisplays the mounting hole pattern and lets you select more holes to add using the same procedure
as the Add MHP tool. Pre-existing holes are automatically selected.

Delete All MHP tool

 The third button on the MHP Tools flyout toolbar activates the Delete All MHP tool. This tool
deletes the current mounting holes. When clicked, ArtiosCAD prompts for confirmation; to delete the
holes, click OK; to keep the holes, click Cancel.

 Adjust MHP Horizontally tool

 The fourth button on the MHP Holes flyout toolbar activates the Adjust MHP Horizontally tool. This
tool shifts the layout horizontally in reference to the MHP to allow for more flexible die placement on
the press. To use this tool, click it, click the pick-up point, drag the ghosted layout to its new position,
and set the put-down point. Annotation lines for this tool appear only for rotary dies. The measurement
indicates the offset from the original MHP placement point (either the Machine Reference Point or the
bottom left of the dieboard).
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Adjust MHP Vertically tool

 The fifth button on the MHP Tools flyout toolbar activates the Adjust MHP Vertically tool. This tool
shifts the layout vertically with respect to the MHP to allow for more flexible positioning of the die. To
use this tool, click it, select a pickup point, drag the ghosted layout to its new position, and set the put-
down point. Annotation lines for this tool appear only for rotary dies. The measurement indicates the
offset from the original MHP reference point (either the Machine Reference Point or the bottom left of
the dieboard).
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How to remove double knives

 Double knives are created when cartons abut each other. To remove them, click the Double Knife
Removal tool. In the Double Knife Removal dialog box, choose the option you’d like to perform.

In the Parameters group, Double knife tolerance is the distance in current units that rules must be
apart from each other to not be considered double knives. “Safe” separation is the minimum distance
two lines must be from each other to be ruled individually. If you have lines that are closer than the
“safe” separation distance but further than the Double Knife Tolerance, the following dialog box appears
when you attempt double knife removal:
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Click Yes to return to the Double Knife Removal dialog box or click No to return to ArtiosCAD to fix the
error.

Nicks may move if double knives are removed after adding nicks.

Double knife removal does not remove special rules with nick sizes larger than 0 as they are considered
special rule, not cut lines.

Undoing double knife removal puts back the original linetype if there is an example of it in the layout
layer; otherwise, it puts back cut lines.

Double knife tolerance defaults are stored in Options > Defaults > Shared Defaults > Startup defaults >
Double Knife Removal.

How to show gripper fingers

 Click the Add Gripper tool to show gripper fingers for the die press.
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How to work with bridges, tack bridges, and nicks

Bridges, tack bridges, and nicks in Manufacturing use the same tools as in Single Design; see the
Designer chapter for more information.

Nicks may move if they are added before removing double knives.

How to create internal and external stripping

Once a mounting bar or stripping rules have been added to the layout, you can add interior and exterior
stripping just by clicking inside the area to strip. To ensure that the settings are correct, check the
Stripping Board options by clicking Stripping Boards on the Options menu and reviewing the settings
on the tabs. The default settings are set in the Automatic Stripping catalog of a manufacturing
parameter set in Defaults.
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 If the settings on the tabs in the Stripping Board Parameters dialog box are acceptable, begin
stripping the sheet using the Strip Area tool. This tool can create holes in the upper and lower stripping
boards, add blocks, pins, and rules, make a guillotine, and add support pins. Blocks, pins, and rules are
added in that order.

The option buttons on the Status bar determine what stripping tools are automatically created. The
picture below is of the option buttons on the Status bar.

Lower, Upper, Internal, and External control which areas of stripping are created; select them as
desired.

The  button (More Options) opens the Stripping Board Parameters dialog box as shown previously.
Recalculate all deletes and recreates the existing stripping board edges and internal and external
stripping.
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Note:  On the Lower Stripping tab of the Stripping Board Parameters dialog box, if you make
the value in the Offset below wing: field different from the Offset: field with Auto-Repeat
on, the repeated block has the wrong offset. The strip areas are considered to be congruent
because they have the same shape, even though the blocks have different offsets.

Click inside an area of waste to strip it. Any congruent areas will be stripped according to current Auto-
Repeat settings. You cannot strip areas that are part of a design unless they are windows or cutouts.
Or, to perform all the stripping at once, activate the tool and click Recalculate All.

Click in the waste outside the design edge between stripping rules to strip the external waste. If slots
in the external waste are divided from the exterior waste by scrap knives, carrier rules, stripping rules,
or are narrower than the slot width parameter, they are stripped as if they were interior holes. Exterior
blocks made this way follow stripping rules but ignore scrap knives.

Shown below is a layout before using Strip Area.

Shown below is the same layout after clicking the tool and then clicking Recalculate All.
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Shown below is a close-up of the lower stripping board.
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Shown below is a close-up of the upper stripping board.
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Note:

ArtiosCAD does not convert holes made from echelon and S special rule into holes in the lower
board.

Zero offsets for edges are now allowed as of version 23.03.

Stripping Inside a Hole
How Strip Area strips a hole divided by stripping or carrier rule depends on the following:

• Whether the Upper and/or Lower checkboxes are checked on the Status bar

• Whether the rule is stripping rule or carrier rule (ArtiosCAD ignores scrap knives)

• Whether the hole is symmetrical or asymmetrical

• Whether Auto-Repeat is turned on.

When you are making a lower hole, ArtiosCAD ignores carrier rules.
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It does follow stripping rules.
 

 

If you click on the other side of the stripping rule, ArtiosCAD merges the holes.
 

 

When you click in a symmetrical hole, with Auto-Repeat enabled, ArtiosCAD makes both sides of the
hole and merge the holes if they overlap.
 

 

If you click in an asymmetrical hole, with Lower off and Upper on, ArtiosCAD fills that side of the hole.
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When you click on the other side of the rule (with Lower off and Upper on) ArtiosCAD fills that side and
leaves the other side unchanged. By changing the options in Options > Stripping Board Parameters >
General Preferences > Internal, you can, for example, use a block on one side and pins on the other.
 

 

Hole type Non-symmetric Symmetric

Separated
by rule

carrier stripping carrier stripping

Lower
checkbox

checked not
checked

checked not
checked

checked not
checked

checked not
checked

Click on
side of
rule /
Upper
board
result

Both
sides
filled

Clicked-
half filled

Clicked-
half filled

Clicked-
half filled

Both
sides
filled

Both
sides
filled

Both
sides
filled

Both
sides
filled

Note:

To add different upper parts to a hole split by multiple carrier rules, strip the hole with Strip
Area, making sure that Lower is checked on the Status bar. Turn Lower off after you have
stripped the hole. Change the stripping parameters as desired by clicking Properties (...) on
the Status bar and clicking OK when done. Then click inside the areas of the hole to strip with
those parameters. This will add upper parts to this part of the hole and leave the existing parts
in other parts of the hole. Normally ArtiosCAD will not put small, thin blocks in thin areas where
there is no room for support pins. To include small, thin blocks, change the minimum block area
and slot width on the Internal blocks tab of the Stripping Board Parameters dialog box.

How to repeat changes in stripping to other areas

 Use the Repeat Strip Area tool on the Manufacturing toolbar to repeat manual changes to a
stripping area to other congruent stripping areas. A stripping area can be a hole, a block, or the

1403



13 ArtiosCAD

external stripping area. For instance, if you add a rule to a stripping area using the Line tool, that
change is not repeated because the Line tool does not use Auto-Repeat. The Repeat Strip Area tool
supports Auto-Repeat; if it is on, stripping areas congruent to the destination stripping area are
automatically changed as well.

To use the Repeat Strip Area tool, do the following:

1. Change the stripping area as desired.
2. Click Repeat Strip Area.
3. On the status bar, choose the boards in which to repeat the stripping area.
4. Click inside the stripping area to repeat (the source stripping area).
5. Click inside the stripping area to be changed (the destination stripping area).
6. Repeat step 5 as desired in other destination stripping areas. The tool remains active until another

tool is selected.

Stripping components must have horizontal mirror symmetry in their alignment lines for them to use
mirror repeating.

Color-coded stripping areas

If you turn on the Stripping areas checkbox in the View Mode dialog box in Manufacturing, different
colors are shown to differentiate between the different stripping areas in the layout.
 

 

Shown below is a manufacturing file that has color-coded stripping turned on.
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• Green indicates a waste area with a lower hole and upper components.
• Blue indicates a waste area with a lower hole only.
• Light blue indicates a waste area with no lower hole.
• Yellow indicates the waste is removed after the stripping station.
• Two shades of Red and Pink alternating across stripping rules indicates ArtiosCAD had a conflict

and could not decide the type. There must be an odd number of areas across the layout.

When ArtiosCAD checks for strip sides and strip back, the rule is, is there are any upper components
on the edge, then the strip areas with upper components are going to be stripped, and the other
edge areas are assumed to not be stripped. If there are no upper components on the edge, it uses the
checkboxes for strip sides and strip back; that is, if Strip sides is on, then it assumes side regions will
be stripped

Adding station and waste numbers to a layout

Station and waste numbers help identify containers and pieces of waste for when something goes
wrong in production or you need to fine-tune the process somehow. Station numbers generally go on
an unseen area of the container such as a dust flap. The position of waste numbers is inconsequential
since it is waste.

 The Station and Waste Numbers tool on the Edit Layout toolbar lets you add station and waste
numbers both manually and automatically after you have stripped the layout. It puts the numbers into
their own layer called Station and waste numbers. When clicked, it displays the following controls on
the Status bar.
 

 

The first four buttons control the orientation of the numbers when placing them manually.

Rotate text with design controls if the numbers rotate automatically as needed.

Station start number sets the starting number for station numbers.

Waste start number sets the starting number for the waste areas.
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More Options (…) opens the Station Numbers Options dialog box described in the next section.

Recalculate Station Numbers and Recalculate Waste Numberserases all existing station or waste
numbers (if any), identifies the stations or waste, automatically recalculates the numbers, and places
the types of numbers whose button you clicked. Use these after you change stripping.

Delete Station Numbers and Delete Waste Numbers delete those numbers.

Setting options for station and waste numbers
Clicking More Options (…) on the Status bar when Station and Waste Numbers is active opens the
Station Numbers Options dialog box.
 

 

Choose the desired font from the Font name drop-down list box.

Maximum text size sets the largest size possible. ArtiosCAD uses the largest size possible for the size
of the area containing the number.

Rotation sets the orientation of the number. If station number positions were defined by Dynamic Art,
that positioning and orientation takes precedence.

Rotate text with design controls if the numbers rotate automatically by 90 degrees as needed.
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In the Station numbers group, Start number sets the starting number for the station numbers when
Manual number is selected. Use layout sequence honors the order you set during manual layout
sequencing.

In the Outline group, choose the shape, size, and line type of an outline ArtiosCAD draws around the
station numbers.

In the Waste numbers group, Start number sets the starting number for the waste pieces when Manual
number is selected. To have each waste piece identified by the station number it is connected to by
the longest path and then a number for that particular piece of waste, select Station number/Waste
number. The Separator character is between the station number and the waste number. ArtiosCAD
uses the Edge character when a piece of waste is not connected to a station or it cannot decide which
station takes priority.

Click OK to set the options and return to the tool.

Adding station and waste numbers manually to a layout
1. Create a layout as desired and strip it.
2.

 Click Station and Waste Numbers on the Edit Layout toolbar.
3. Set the options on the Status bar as desired.
4. Use the drag to place a number. If it is inside a container outline, it is a station number; if it is

outside a container outline, it is waste. The drag snaps to different points around the shape of the
area.
a) Placing a station number.

 

1407



13 ArtiosCAD

 
b) Placing a waste number. Note that nicked holes inside containers are also considered waste.
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5. If Auto-Repeat is enabled, ArtiosCAD places station numbers in congruent areas of other

containers.
6. Continue placing numbers as desired. Waste areas may contain more than one number.

Adding station and waste numbers automatically to a layout
1. Create a layout as desired and strip it.
2.

 Click Station and Waste Numbers on the Edit Layout toolbar.
3. Set the options on the Status bar and in the Station Numbers Options dialog box as desired.
4. Click Recalculate Station Numbers or Recalculate Waste Numbers. ArtiosCAD identifies all the

waste areas and adds numbers to each container or waste area according to the options you set.
Note that nicked holes inside containers are considered waste.
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Sometimes the numbers can be hard to see, so try turning off some layers and/or zooming in.
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If you defined station number positions with Dynamic Art, you can manually change their rotation and
position with this tool if you turn on the Dynamic Art single design layer and leave at least one line of
the Dynamic Art placeholder rectangle in the same position.

Changing stripping boards

Use the tools on the Stripping Board toolbar to modify stripping boards.
 

 

You can also use stripping components to alter stripping boards.

How to change the edge of the lower stripping board
To change the edge of the stripping board, double-click it with the Select Element tool, adjust the
fields on the different tabs as desired, and click OK.
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How to add an upper push pin
When you use the Strip Area tool to create both the upper and lower stripping boards, ArtiosCAD will
automatically add pins, rules, and blocks. However, if you use the Strip Area tool to create only the
lower board, you can manually add pins, rules, and blocks. The lower stripping board must contain
holes before you can add upper push pins.

 The Upper Push Pin tool adds a pin to the upper stripping board. When you click the tool, a Pin Size
drop-down list box and a ... button (More Options) appear on the Status bar.

Clicking More Options opens a Stripping Boards Parameters dialog box with just the tabs for internal
pins and external pins. These options are based on the settings in Automatic Stripping catalog for the
manufacturing parameter set in Defaults. Change them as desired and click OK.
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To add an upper push pin, do the following:

1. Make sure there are holes in the lower stripping board. Use the Strip Area tool if necessary.
2. Click Upper Push Pin.
3. Select the desired pin size from the Pin size: drop-down list box on the Status bar.
4. Use the drag to set the location for the pin and click to place the pin. Green drag indicates the

pin is snapped to the outline of the hole; blue drag indicates that it is freehand, and red dashed
drag represents an unavailable area for placement. If Auto-Repeat is on, the pin will be repeated
accordingly. Additional offsets may be applied according to the options set in either Defaults or the
Stripping Boards Parameters dialog box.

Shown below is adding a pin at the upper left corner of a hole.

1413



13 ArtiosCAD

Shown below is the added pin which was Auto-Repeated.
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5. Repeat as desired to add more pins.

You can design custom push pins as geometry macros of type Push pin component. They must be
circular.

How to add an upper rule

 The Upper Rule tool adds a piece of rule to the upper stripping board. As with the Upper Push Pin
tool, you must click inside a hole in the lower board to add the rule. When you click the tool, a Stripping
Rules drop-down list box, four snap positioning option buttons, and a ... button (More Options) appear
on the Status bar.

On the Stripping rules: drop down list-box are Generic rule, which is just plain straight rule, and three
geometry macros that offer special constructions: 20mm wave rule, 8mm Right rule (a stripping
component), and Variable rule that has a 90-degree angle at its end. Your system may have different
geometry macros available depending on how the system has been customized.

The four snap options on the Status bar after the Stripping rules: drop-down list box are listed below.

 Dynamic Rule lets you place rule and use the color of the drag for feedback. The drag for the
guide lines changes color based on the intended position of the rule. Green drag indicates the item
is snapped to the edge of a hole; blue drag indicates it is being placed freehand; red drag indicates it
cannot be placed at that position.
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This option works with all the stripping rule types available in the drop-down list box.

 Snap to Middle Rule automatically snaps the rule in the middle of a slot. This option works with all
the stripping rule types available in the drop-down list box.
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 Generic Straight Rule changes the type of rule in the drop-down list box to Generic rule and
prompts you to indicate the start and end points of a straight piece of rule.

1417



13 ArtiosCAD

 Generic Follow Rule changes the type of rule in the drop-down list box to Generic rule and prompts
you to indicate the start and end points of a piece of rule that follows the shape of the lower hole.
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Clicking  More Options opens the Stripping Boards Parameters dialog box with the tabs for internal
rules, external rules, and interference. These options are based on the settings in the Automatic
Stripping catalog for the manufacturing parameter set in Defaults. Change them as desired and click
OK.

1419



13 ArtiosCAD

To add a piece of upper rule, do the following:

1. Make sure there are holes in the lower stripping board. Use the Strip Area tool if necessary.
2. Click the Upper Rule tool.
3. Select the type of rule to add from the Stripping Rules: drop down list-box.
4. Click the appropriate snap placement button. Dynamic Rule is selected by default.
5. Place the rule. If the rule selected on the drop-down list box is of variable length, click to set the

start point, drag to extend it, and then click to set the end point.

If the rule selected on the drop-down list box is not variable, place it as desired.

Green drag indicates the item is snapped to the edge of a hole; blue drag indicates it is being placed
freehand; red drag indicates it cannot be placed at that position.

When Snap to Middle Rule is the current placement method and the end point of the rule being
added is a piece of existing generic rule, the new rule is intersected with the piece of existing rule.

Shown below is an example of setting the end point for a piece of 20mm step Wave rule with the
clearance lines shown around it and Snap to Middle Rule selected as the placement method. The
start point of the rule is at the right end of the slot and the drag is toward the left.
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How to add an upper block

 The Upper Block tool adds a block to the upper stripping board in the hole you indicate. As with
the Upper Push Pin tool and the Upper Rule tool, you must click inside a hole in the lower board to add
the block. When you click the tool, an Add Block Pins checkbox and a ... button (More Options) appear
on the Status bar.

Clicking More Options opens a Stripping Boards Parameters dialog box with tabs for internal blocks,
external blocks, and block pins. Modify the fields as desired and click OK.
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To add an upper block, do the following:

1. Make sure there are holes in the lower stripping board. Use the Strip Area tool if necessary.
2. Click the Upper Block tool.
3. Select or deselect the Add block pins checkbox on the Status bar as desired.
4. Click inside the hole for the new block. The block is created with or without pins and repeated

according to the Auto-Repeat status as shown in the example below.

1422



13ArtiosCAD

How to add an upper block pin

 The Upper Block Pin tool lets you add upper block pins manually. When you click this tool, a Pin
size: drop-down list box and a ... (More Options) button appear on the Status bar.

Clicking More Options opens a Stripping Boards Parameters dialog box with a tab for block pins.
Change the distance between pins or the default pin as desired and click OK.
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To use this tool, do the following:

1. Make sure you have an upper block created.
2. Click the Upper Block Pin tool.
3. Choose the upper block pin to use from the Pin size: drop-down list box.
4. Use the drag to place the pin as desired. Green drag indicates the pin is snapped to a hole

edge; blue drag indicates it is being placed freehand; red drag indicates the desired position is
unavailable. The example shown below uses the 10mm block peg.
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5. The pin is Auto-Repeated according to the current Auto-Repeat setting.

How to add interference

 Sometimes when a piece of waste is small (and therefore light), the partial vacuum in the press
can suck the waste back up through the holes in the bottom stripping board. Interference, also known
as power stripping, is the process of adding a little bump into the edge of a hole using inside modifier
lines so that the waste stays where it is supposed to be and doesn’t come back into the press. The Add
Interference tool is one way to add interference. You can optionally add a pin in the top stripping board
to force the waste through the now-smaller hole.

Options for this tool appear on the Status bar when the tool is clicked.

Round, square, and chamfer control the shape of the interference. Width sets the size of the
interference. Add pin controls whether a pin is added to the upper board to force the waste
through the modified hole. Interference added without a pin adds modifier lines to the lower board.
Interference added with a pin adds the pin and modifier lines to the upper board. Pin offset sets the
distance to the pin from the edge of the hole, and is available only when Add pin is selected. Pin size
sets the size of the pin and is available only when Add pin is selected.

When interference with a pin is added, it goes into the upper board. When the interference is added
without a pin it goes into the lower board. When a block is added to a hole with interference, if the
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interference is in the lower board the block goes around the interference. If the interference is in the
upper board it is deleted.

The Repeat Strip Area tool repeats the interference whether it is in the upper or lower board,
according to the Upper and Lower checkboxes. It replaces any existing interference in the repeated
holes.

You can specify additional offsets for interference on the Interference tab of the Stripping Board
Parameters dialog box.

To use the tool, do the following:

1. Make sure there are holes in the lower board.
2. Click Add Interference and set the options on the Status bar as desired.
3. Use the drag to set the position along a lower hole edge for the interference. Green drag indicates

the pin is snapped to a hole edge; blue drag indicates it is being placed freehand; red drag indicates
the desired position is unavailable.

4. Click to place the interference. The interference is Auto-Repeated according to the Auto-Repeat
settings.
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Set defaults for this tool in Options > Defaults > Shared defaults > Manufacturing parameter sets >
parameter set catalog > parameter set name > Upper stripping board > Interference Stripping.

Another way to add interference is to create manual interference by adding lines of type Hole inside
modifier that cross the edge of the hole to the Inside modifier sublayer of the Lower stripping board
layer. Any pins, rules, or blocks added will follow the inside modifier lines. Select the inside modifier
lines with Select Element and repeat them using Repeat Element. The shape of the lower hole will be
modified on Output.

Manual interference is deleted if you use the Strip Area tool with the Lower checkbox selected after
adding manual interference.

Shown below is an example of manual interference. A hole modifier line was drawn across the corner of
a lower hole and was repeated, and then an upper block was added with pins and repeated. The edge of
the upper block follows the lower hole inside modifier lines.
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How to remove stripping
Two tools on the Manufacturing toolbar remove stripping.

 Delete All removes all stripping from the layout. When clicked, the Delete All dialog box appears.
Choose the options as desired and click OK to remove the stripping.

 Delete Strip Area removes stripping from individual stripping areas. When clicked, Lower and
Upper stripping and Upper stripping only option buttons appear on the Status bar as shown below.
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To use this tool, do the following:

1. Click Delete Strip Area.
2. Choose the appropriate option button on the Status bar.
3. Click inside the stripping area to delete. Deletions will be Auto-Repeated according to current Auto-

Repeat settings.
4. Repeat in additional stripping areas as desired.

How to add an air hole

 Modern presses operate so quickly that partial vacuums are sometimes created from the sheets
rushing through them. These vacuums can ruin a press run by causing the machine to jam. Air holes
made in the upper stripping board are one way to combat this problem.

Three options for the shape of the air hole appear on the Status bar when the tool is active.

The Radius field appears only when the shape is set to Circle.

To use this tool, do the following:

1. Click Make Air Hole.
2. On the Status bar, choose the shape of air hole to create.
3. Click at the start point of the air hole and use the drag to set the end point.
4. The air hole is created and Auto-Repeated according to the current Auto-Repeat settings.

Shown below are examples of air holes.
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How to make an alignment hole

 Alignment holes are used to quickly and easily align a set of manufacturing tools without resorting
to measuring tapes. To make an alignment hole, click the Make Alignment Hole tool and click the
location for the alignment hole.

How to add a support bar

 The Add Support Holes tool adds support bar holes to the lower stripping board. The support bar
holes always go into the lower stripper.

To use this tool, click it. Construction lines will appear in the recommended locations for the support
bar. Use the drag to set the location of the support bar. Once the location is set, use the mouse to
select the holes to be made for the support bar. When you have finished selecting holes, click OK on
the status bar. Shown below is the tool drag prompting you to set the location.

Shown below are the completed holes for the support bar.

1430



13ArtiosCAD

How to add registration holes

 To add registration holes across the lower edge of the board, click the Add Registration Holes
tool. Holes will appear across the bottom of the board, and two options in the Status bar allow you to
select from all holes or from only good holes.

Select the holes to add and click OK. The holes will be added.

Shown below are the registration holes.

How to add a Front Waste Separator
A Front Waste Separator strips the waste from the lead edge of the layout. The separator is made of
top and bottom stripping boards which follow the edges of the designs and any stripping rules.

The vertical edges of the Front Waste Separator are found by using the following points: the points
at which the layout designs meet the usable edge of the sheet; where they meet the bottom-most
stripping rules which intersect the vertical usable-sheet edge; or an existing bottom stripping board
mounting bar. If none of these points are found, the separator edge just extends horizontally to the
sheet edge.

The Front Waste Separator is placed into the Front Waste Separator layer when it is created.

Shown below is the edge when none of the points are found.
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When there is a stripping rule:

Notice how the stripping edge goes up along the edge of the tab and then runs along the stripping rule
to the edge of the sheet.

When there’s a bottom mounting bar:

To use this tool, do the following:

1. Create a layout.

2.
 Click the Create Separator button on the Stripping Board toolbar.

3. The Status bar will change:

4. Set the options on the Status bar.

The Use Mounting Bar checkbox controls if the Front Waste Separator is positioned based on the
mounting bar. If there is no mounting bar, the separator is based on the lead edge.

Upper only creates the Front Waste Separator out of the upper stripping board. Upper and Lower
creates the separator using both upper and lower stripping boards.

Use different offsets allows you to specify different offsets for the upper and lower boards in the
Lower follow offset and Upper follow offset fields. This controls the gap between the lead edge
and the edge of the Front Waste Separator.

5. Click Recalculate All. The Front Waste Separator is created.

Make sure to click Recalculate All after each change you make to the options on the Status bar while
the tool is active. Deactivate the tool by clicking another tool.
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How to modify a Front Waste Separator
To modify a Front Waste Separator, activate the tool and choose different options on the Status bar,
and then click Recalculate All.

You can also modify its properties by doing the following:

1.
 Click the Select Element tool.

2. Choose the element to modify from the drop-down list bow on the View bar.

3. Double-click the element to modify, or select it and press ALT-Enter. The Properties dialog box
for that element will appear.

4. Set the options on the tabs as desired and click OK to make the changes or Cancel to ignore them.

Front Waste Separator defaults are stored in the Front Waste Separator section of the Die press
parameter sets folder in Defaults.

The workspace containing the mounting hole pattern is ...\InstLib\FWS_BOLT-HOLES.ARD.
The name of this workspace is set in the Hole Patterns page of the Press Defaults in the Die press
parameter sets folder in Defaults. On that page you can also set the side of the die the patterns are
placed on to die knife side, die back side, or undefined.

Using stripping components

Stripping components are geometry macros which create space for a claw in the upper stripping board
and a clip in the lower stripping board. During stripping, the board material is pressed by the claw
against the clip, which flexes and traps the waste, thereby eliminating the need for lower stripping
board pins.

Several predefined stripping component geometry macros come with ArtiosCAD, but you can make
your own in Designer.

Shown below is a sample stripping clip.
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The predefined stripping components are on two customized toolbars as shown below. Use the
Customized Toolbars Master Control to turn them on and off.
 

 
 

 

Adding a stripping component
Perform any stripping using the Strip Area tool before adding stripping components. Using the Strip
Area tool will overwrite stripping components.

To add a predefined stripping component, do the following.

1. Make sure the customized toolbars are turned on and click the button for the component to add.
The upper and lower boards will be turned on if they were not on already.

2. Drag for the component will appear under the cursor. Position it as desired, keeping the following
placement options in mind when dragging:

• Close to the edge of a hole. The stripping component is aligned with the edge of the waste (the
cut lines) in the stripping hole or the lower board edge so that the alignment lines touch the
inside of the hole. If the clearance lines do not fit inside the hole, the drag turns red.
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• Close to a carrier rule. This is the same as being close to the edge of a hole but a different offset
is used - that of the distance between the regular alignment line and the carrier alignment line.

The stripping component is aligned with the carrier rule so that the carrier alignment lines touch
the carrier rule. If there are no carrier alignment lines, the alignment lines are used instead. If the
clearance lines do not fit, the drag turns red.

• Close to a slot. Select a slot by moving the mouse within snap tolerance of the slot alignment line.
The stripping component is aligned so one end of the clearance outline touches the end of the slot
depending on the side of the line closest to the mouse cursor.
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• Not in a hole. If the mouse is not in a stripping hole, or if the cut lines in the stripping hole or board
edge do not form a loop, the Status bar prompt changes from Place stripping component to
Could not find the stripping hole and the drag turns to dotted red. If you click outside a hole, the
component will be placed wherever you click.

• Holding down SHIFT. When SHIFT is held down, the stripping component snaps to horizontal or
vertical (whichever is closer, based on rotating around the center of the alignment line).

Modifying stripping components

To modify a stripping component, first select it with the  Select or  Select Element tool. Next,
right click it to access its context menu.
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Note:  If you select more than one component by holding down SHIFT as you select, only
Delete, Replace, Replace All, and Properties are available.

Note:  If Auto-Repeat is active, changes made to one stripping component are repeated for
similar components.

Note:  Selecting multiple stripping components in the same hole with the Select Element tool
will group them together. If you plan to change the positions of multiple components in the
same hole, use only the Select tool to select them.

Select subgroup lets you select a subgroup of the component such as a clip or claw.

Move parallel moves the selected component parallel to the edge of the hole. However, you cannot
move a component from one hole to another. To do this, delete the original component and add a new
one.

Copy parallel does the same thing as Move parallel except it copies instead of moving.

Move perpendicular moves the selected component perpendicular to the edge of the hole. If the
perpendicular offset from the edge of the hole has been changed, it will be maintained. If the
component is rotated or aligned on a slot, the perpendicular offset is reset to zero.

Move freehand moves the selected component anywhere within the same hole.

Rotate 180 rotates the selected component 180 degrees about the center of the clearance lines.

Rotate prompts for an anchor point and rotates the selected component about the anchor point.

Delete deletes the selected component(s).

Replace lets you replace the selected stripping component with a new stripping component chosen
from the Stripping Components catalog. The new stripping component is repeated accorded to the
current Auto-Repeat setting. Shown below is the Stripping Components catalog.
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Select the new stripping component and click OK to use it as the replacement.

Replace All replaces all instances of the selected stripping component with a new stripping
component.

Properties shows the workspace name and any subgroups for the component.

Outputting boards containing stripping components
In a stripping component, the hole outside modifier lines change the shape of the hole in the lower
board when performing an Output.

The upper stripping rule and pusher base lines are burned in a CAM output that selects the Upper
stripping board. The hole inside modifier and hole outside modifier lines are applied to the outline
of the lower stripping board in a CAM output that selects Lower stripping board with upper blocks.
CAM outputs ignore the other lines types such as Pusher active part, Pusher clearance, and Stripping
component alignment.

Any tack bridges under a stripping component get moved on Output.

Show below is a portion of a layout containing several stripping components.
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During an Output of the lower board, only the hole modifier lines are considered. Shown below is the
lower stripping board for the same section of the layout as shown above.

Shown below is the upper stripping board for the same section of the layout showing the stripping rule
lines.

Creating your own stripping components
Use Designer to create your own stripping components. Save them as normal workspaces and copy
them to ServerLib. Then add them to the Stripping Components Catalog in the Geometry Macro
Catalog in Defaults, making sure to use the Stripping hole component placement type. Save the
Defaults. If desired, create icons for them and put them on a customized toolbar.

Refer to the following table of line types when designing a stripping component. The line types are split
between the Lower Board and Upper Board line type catalogs.
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Table: Line types for stripping components

Line type name Line type
number

Category Description

Annotation 0 Annotation A line type used for drawing the
component that does not burn.

Pusher active part 188 Annotation A drawing of the active part, such as the
clip or the claw. Does not burn.

Upper stripping rule 186 Rule The base of a stripping rule that is burned
as a slot in the upper board.

Pusher base 187 Inside edge The outline of the base of the pusher
element that is burned in the upper
board.

Pusher shoulder 189 Annotation The shoulder that stops the element from
being pushed through the upper board.

Pusher clearance 190 Annotation The effective size of the element. The
stripping component is considered to fit
inside the stripping hole if the clearance
lines are inside the waste area defined by
cut lines inside the stripping hole. Also
defines slot placement.

Hole inside modifier 180 Inside edge The inside edge of an interference
extending partly into the lower stripping
hole. This loop is combined with the lower
stripping board to make the hole smaller.

Hole outside modifier 181 Inside edge A slot in the edge of a lower stripping
hole which holds the outside edge of
a stripping hole element. The loop is
combined with the lower stripping board
to make the hole larger.

Stripping component
alignment

203 Annotation These lines touch the edge of the
stripping hole to align the stripping hole
component.

Stripping component
carrier alignment

204 Annotation These lines touch the carrier rule when
the component is aligned near a carrier
rule.

Shown below is an example of how these line types should be used.
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Clearances
For a stripping component that is wider than it is tall, the clearance perimeter should have both
horizontal and vertical symmetry. The left or right end of the clearance is centered in a slot, depending
on the position of the mouse cursor in relation to the side of the slot. Design clearances using the
Pusher clearance line type in the Upper board line type catalog.

Shown below are alternate clearance shapes to show possibilities beyond an oval.

For a stripping component that is taller than it is wide, the clearance perimeter should have vertical
symmetry. The bottom end of the clearance is centered in a slot.

 

 

For a pin, the clearance should be circular. The alignment lines should be omitted as they would usually
be the same offset as the clearance.

Clearance lines are shown in the drag but are invisible after the stripping component is placed.

If there are no clearance lines, or if they do not form a loop, no slots are defined.
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Alignment lines
Alignment lines determine how the stripping components are aligned with the edge of the waste.
Design alignment lines using the Stripping component alignment line type.

Alignment lines:

• Should be a single set of connected line segments (but not a loop) below the lower edge of the
clearance.

• Should be horizontal, they do not need to be straight - they can be arcs for use when the waste edge
is curved.

• Can be along the bottom edge of the clearance lines, but should not be within them.
• Are optional if the clearance lines are a loop, in which case the lower half of the clearance lines form

alignment lines.

When designing a stripping component for use on carrier rules, add a horizontal carrier alignment line
below the alignment lines, or below the clearance lines if using the default alignment.

Listing stripping components on a Report
You can create a Report that lists the stripping components used in a stripping board by adding items
of calculated text in the Stripping Component Information catalog in the Manufacturing / Layout
catalog of calculated expressions.

When you first add a stripping component to a layout that does not have any, the stripping component
gets assigned a number called its index. The index of the first stripping component is set to 1. If the
stripping component is composed of subgroups, those subgroups also get assigned an index number
of their own. For example, if you have stripping component MBC Pin 1 which has three subgroups, the
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pin as a whole is set to index 1, and the three subgroups are set to indices 2, 3, and 4. The next pin
would therefore have indices 5, 6, 7, and 8.

The calculated expressions work in terms of the index of an item or its name. Enter each as
appropriate. Each calculated expression only lists information for the item corresponding with the
index number you entered when prompted. If you only add one item of calculated text based on index
2 but have four stripping components, only information about the second index is included on the
Report. Add multiple calculated expressions to result in multiple pieces of information about the
stripping components.

Notes and warnings about stripping components
Hole modifier lines can be added manually to the upper and lower stripping boards, but they affect only
the lower board on Output. If there are inside or outside modifier lines which do not cross a lower hole
or the lower board edge, a warning dialog box is displayed.

If inside or outside modifier lines cross more than one hole, only the first hole will be affected. If
modifier lines do not cross any holes, a warning will be displayed on Output.

When creating a composite stripping component out of smaller components, delete excess clearance
and alignment lines so only one set remains.

Notes and warnings on manual stripping board modification
When ArtiosCAD makes stripping board holes, inside modifier lines are connected into a loop following
the shortest route around the hole. ArtiosCAD then subtracts inside modifier loops, or adds outside
modifier loops as needed. If the result has more than one piece, ArtiosCAD keeps only the largest
piece.

A geometry tool like the line, rectangle, arc tool can put lines in any layer, so there is a potential for
having lines in the wrong layers, or lines in the wrong order not forming loops.

When you switch to a lower/upper board tool, or open an manufacturing file, ArtiosCAD activates a fix
stripping board function to move the lines to the correct layers, and fix the upper/lower board exteriors
so they are counter-clockwise loops.

The stripping board functions, for example dragging a pin along the board edge, only work after the
layers and loop direction have been fixed.

The fix stripping board function does the following:

• Forms loops out of the lower board edge and lower hole lines.
• Lower board edge and lower holes lines that do not form loops are moved into sublayer Lower Other
• Upper board edge lines that do not form loops are moved into sublayer Upper Other
• Moves the inside modifier lines to the lower board layer and makes loops if possible.
• Moves stripping components, pins, rules, blocks into an internal or external upper sublayer

depending on if they are in holes or on the board edge.
• Makes loops out of air hole lines and moves them into the air holes sublayer

Using a Geometry Macro to add a burn name

There are three Name Tools in Tools >  Geometry macros > Manufacturing tools > Dieboard utilities.
These tools place information on the dieboard itself.
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Name tool Example1 inserts a geometry macro containing the file name with no extension, the
dieboard size, the customer name, and the manufacturing file description.

Name tool Example2 inserts only the file name with no extension.

Name tool Example3 inserts the filename with no extension in the INTERACT font.

1444



13ArtiosCAD

Plastic counter layouts

Plastic counter layouts are used to make many counters at once on a countercutter.

A few notes about plastic counter layouts:

• Only the counter layer from each embedded design is shown. Manufacturing layers and design
layers cannot be seen.

• Only manual layout tools are available.

• Plastic counter layouts are not tracked in the database.

• Side and grain are not applicable in plastic counter layouts. The top of the plastic counter is always
shown. However, the grain direction for embedded designs is set to match that of the original
designs.

• Plastic counter layout workspaces use the .CTL filename extension.

Creating a plastic counter layout

Before creating a plastic counter layout, you must have at least one design containing a plastic counter
for inclusion in the layout.

To create a counter layout, do the following:

1. Start ArtiosCAD.
2. Click File > New > Counter Layout.

3. A new plastic counter layout will be created containing an empty sheet.
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4.

 Click the Add Oneup tool and then select the design(s) to add. Click OK.

5.
 Click the Select Oneups tool and select the design you just added.

6. Use any of other Manual Layout tools to arrange the design on the sheet. The quickest and easiest
way to do this is to set the gutter and then use one of the Nest tools to step the counters out on the
sheet.

 To change the gutter between the counters when using one of the Nest tools, click the Change
Gutter tool and enter the new gutter distance.

 Use one of the tools on the Nest tools flyout toolbar. Shown below is a
picture of an example counter layout using the Straight Nest tool.
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7. Output the plastic counter layout using a counter Output on the File menu. A preview of the output
to a Kongsberg PentaCut is shown below.

8. Complete the Output and save the layout.

The plastic counter layout is now complete.

Modifying a plastic counter layout

To modify the position of the design on the plastic counter layout, use the tools on the Edit Layout
toolbar.
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If the nested plastic counters don’t completely fill the sheet, you may want to adjust the size of the
sheet or the position of the plastic counters on the sheet.

 Use the Change Sheet Size tool to do this.

You must choose a layout justification method first. The buttons in the Layout Justification group
move the group of designs so that the bottom center of the designs is aligned with the bottom center
of the sheet, and so forth. Once a layout justification method is chosen, all the other fields become
available and you can adjust the size of the sheet and its margins.

Steel counter layouts

 Create or Rebuild Counter is the twelfth tool on the Manufacturing toolbar. In Manufacturing,
ArtiosCAD creates counter layers in the embedded single designs and frame components in the
counter layer of the manufacturing workspace. For a discussion of the general workflow, refer to the
Intelligent Counters section of the Designer chapter.

If the embedded single design(s) already contain counter layers, ArtiosCAD prompts you to select the
layers to rebuild.

If all the embedded design(s) will use the same parameters, make the counter in the manufacturing
file. To have some embedded designs use different parameters, rebuild the counter separately for
each embedded design (by opening each embedded design and using Create or Rebuild Counter), and
deselect Oneup(s) Counter Layer when making the frame in Manufacturing.
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The Steel counter entry in the Layers dialog box controls the counter layers both the manufacturing
file and the embedded design(s) as well.

Frame tab of Create or Rebuild Counter tool

The Frame tab of Create or Rebuild Counter only appears when you use the tool in a manufacturing
file. Activating the tool turns on the Steel counter layer in the manufacturing file and any counter layers
in the embedded single design(s).
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The frame is either a rectangle of a size you specifity or a workspace contained by a geometry
macro. It is centered horizontally on the blank size of the knives and stripping rules with the specified
offset from the choice you make in the Relative to group - either the lead edge, dieboard, or machine
reference point. If you choose a geometry macro, the outline of the frame should be made out of lines
with the Periphery tool line type, and any slots should be made of lines of type Counter slot. The slots
must form complete loops. If some of the edges of the frame are on the edge of the steel plate and do
not need to be cut, change those edge lines to type Size only. The combined Periphery tool lines and
Size only lines must form a complete loop.

The hanger holes pattern is a single hole or two holes which are a fixed distance apart. These holes
are used to hang the counter for storage. ArtiosCAD will adjust the pattern up to 3 inches for clearance
around channels and milled areas, and will warn you if it cannot adjust the pattern for clearance.

The dieboard registration holes pattern contains laser positioning holes (holes in the dieboard made
using line type Laser positioning holes or Laser positioning holes 2) and counter positioning holes
in the counter (line type Positioning hole tool or Positioning hole tool 2). The pattern is generally
centered on the frame, but you can choose its justification position as desired and any offset. The
pattern can also be bigger than the frame, but any holes outside the frame are excluded. ArtiosCAD will
automatically adjust individual holes up to 3 inches for clearance around channels, milled elements,
and rules.

The name/logo geometry macro is a geometry macro meant to contain your company name and
logo (which you should add to the geometry macro catalog in Defaults). Position it as desired, set an
offset, and set a rotation. Make the macro rebuildable with a menu of type Precalculated Variables for
a Geometry Macro, and add the text variables so that they have an expression initialized from variables
in the manufacturing file. If desired, you can change the text running the geometry macro. When you
Output this counter, ArtiosCAD converts the text to lines and arcs of line type Name tool depending
on the options on the Output's Processing tab. If you make a logo in the geometry macro, use line type
Name tool.

Coating blankets

Coating blankets, also called varnish blankets, are used to protect those areas of the sheet from having
coating applied as the sheet moves through the printing press.

Coating blankets use the bleed or varnish layers in the single designs comprising the layout. If the
designs do not have one of these layers, a coating blanket can not be made.

Making a coating blanket

To make a coating blanket, construct a layout of single designs containing bleed or varnish layers.
Then, do the following:

1. Click Tools, and then click Geometry Macros.
2. Open the Manufacturing Tools folder and then the Coating Blanket folder by clicking the plus signs

next to them.
3. Select the Coating Blanket geometry macro.
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4. Click OK. As this is a geometry tool, it runs like a style in a Standards Catalog.

Cut Coating Free Areas and Cut Coating Areas control what is actually cut - those areas not being
coated or those areas being coated. Use the former choice to make strips in the unused portion of
the blanket.

The layer choices control which single design layer is used to make the blanket. There can be six
separate coating layers.

Apply shrink and Do not apply shrink control if the tool automatically shrinks the blanket upon
creation or upon output.
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Use Coating Blanket and Use Current Layer control where the coating blanket is created. The
former choice uses the predefined layer you chose earlier in the menu. The latter uses the current
layer.

Select the desired options and click Next.
5. The Coating Blanket Options menu is where the coating blanket settings are configured.

The variables in this menu are explained in the table below.

Table: Variables In The Coating Blanket Options Menu

Variable Meaning

Blanket Height Height of coating blanket.

Blanket Width Width of coating blanket.

Front Bar Width Height of the front bar.

Back Bar Width Height of the back bar.

Vertical Offset from MRP Offset of the coating blanket with respect to the front bar. A
negative value moves the coating blanket down; a positive
value moves the coating blanket up.

Extra Bleed Extra bleed allowance to use when creating the blanket
using coating-free areas.

Thin Areas If a strip of coating material would be smaller than the width
specified by this variable, it is discarded.

Extra Offset Extra offset to be applied to the coating blanket outlines
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Variable Meaning

Press Draw Factor Value that the interior of the blanket is shrunk in the Y
direction to compensate for the blanket being mounted on
a cylinder. This does not affect the bar widths or overall size
of the coating blanket.

Strip Width Width of the strips created.

Click OK once you have set these variables as desired.
6. The coating blanket is created. See the following picture for an example of a coating blanket with all

layers turned off except for the coating blanket. You may have to turn on the Coating Blanket layer
in the Layers dialog box to see it.

Modifying a coating blanket

Use any of the Designer tools to modify lines in the coating blanket.

To remake the coating blanket, turn off all the other overlays, select all the lines in the Coating blanket
overlay, and delete them. Then rerun the geometry tool.

Configuring alternate coating blankets

The Coating Blanket geometry tool is contained in the workspace ..\InstLib\MFGCOATINGB.ARD.
To make alternate coating blankets with different default values, copy this workspace, modify the
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workspace variables of the new file, and then add the new workspace into the Geometry Tool Catalog in
Defaults. Be very careful to not draw any lines in the workspace.

Rotary Diemaking

Instead of cutting containers out of material by using a cookie-cutter action on a stationary sheet,
rotary diemaking uses rotating cylindrical dies on moving sheets. These dies can be made out of more
than one piece of wood and are bolted to the machine cylinder.

The technology of rotary diemaking, while sharing many elements of flat diemaking, has special
features, such as curved wood and notched rule, which are not applicable to flat diemaking. For that
reason, it is a separate option from regular DieMaker.

In rotary diemaking:

• Tooling can be designed at three levels: the cylinder level, the wood level, and the rule level.
• Elements which are designed at one level are transformed (into a new size, shape, or both) when

processed on another layer to compensate for the curve of the dieboard or rule.
• Tooling is made from single or multiple pieces of wood which contain mounting holes, steel rule

paths, and other geometry which can be manufactured or drawn on the surface of the wood.
Multiple sections can be output individually from ArtiosCAD.

The options on the View Options submenu of the View menu make it easier to work with rule paths. You
can toggle the display of bridges, line direction, rule path ends, and construction lines. You can also
assign these menu options to Shortcut keys for faster access.

Tools for rotary dies / DieSaw output

The Rule Path Tools toolbar, the DieSaw toolbar, and the Registration Hole Tools toolbar contain the
tools for making rotary dies and/or outputting to the Kongsberg DieSaw.

The Rotary Bolt Holes tool is on the Dieboard toolbar.

Rotary Die Board tool

 The Rotary Die Board tool on the Dieboard toolbar works with the following elements of a rotary
dieboard:

• Bolt holes
• Splits
• Edges

Rotary Die Board is available only when the current press is a rotary press. Other mounting pattern
tools are unavailable for workspaces using rotary presses.

It has five states, or modes of operation. Change states by clicking its button on the Status bar. Each
state has different prompts and modes. Shown below is the initial mode of the Adjust Elements state
when the manufacturing workspace does not have a hole pattern defined.
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• Adjust Elements. Moves bolt holes, splits, and edges.
• Adjust Die Edge. Moves the die edge.
• Adjust Die Splits. Creates new horizontal or vertical die splits, moves existing splits, or deletes

splits.
• Add Bolt Holes. Adds bolt holes from the mounting hole pattern to the workspace.
• Delete Bolt Holes. Deletes existing bolt holes from the workspace.

When you first start the tool, ArtiosCAD:

• Changes to the Dieboard layer. If that layer is locked, it changes to the Stripping Rules layer.
• If the dieboard does not exist, ArtiosCAD creates it, checks it for size, and creates a horizontal split

180 degrees from the top automatically if needed. The formula for the full shell size is Pi*(cylinder
diameter/2) or Pi*r. You could have already created the dieboard with Create Wood Edge but it does
not automatically add the split. If you use a geometry macro requiring placement to create the die
board, ArtiosCAD shows the geometry macro controls as well as the Rotary Die Tool controls.

• If a pattern workspace does not exist, Adjust Elements and Add Holes states are unavailable, and
the tool starts in Adjust Die Edge state. ArtiosCAD displays a warning.

• Displays the bolt hole pattern if no holes exist in the workspace. If holes already do exist in the
workspace, cArtiosCAD enters the Add Bolt Hole state instead of the Adjust Elements state.

ArtiosCAD shows the entire bolt hole pattern trimmed to the die edge but with an extra row or column
on each side. Good holes do not intersect geometry and are not too close to t-holes. They are green.
Bad holes, those which intersect geometry or are too close to t-holes, are red. Circular holes have snap
points in their centers. If the holes are aligned in rows and columns (see the next section on making a
pattern workspace), there are extra snap points halfway between each row and column.

Making a Pattern Workspace
For the Rotary Die Board tool to work properly, you need to design a bolt hole workspace for your
specific press. In that workspace, make circles representing the bolt holes using line type Die bolt
holes. Optionally, you can add annotation circles to show the washer size, and any other annotation
lines as desired to serve as pick-up points to position the pattern. The holes must have 0 degrees of
difference between their centers horizontally and vertically for ArtiosCAD to recognize them as rows
and columns when you select them using this tool.

ArtiosCAD considers all lines in layer classes Main, Windows and Cutouts, and Manufacturing as part
of the hole pattern. Lines in layers of other classes are not considered part of the hole pattern. For
text, change it to Outline Text with the Annotation line type. ArtiosCAD copies the pattern workspace
into the manufacturing workspace the first time you add holes; it does not copy from the pattern
workspace on subsequent hole additions.

The holes should correspond with the holes on the bare cylinder itself, not the holes on a die already on
the cylinder. The holes will be at cylinder level in single design, and ArtiosCAD stretches them to design
level when it converts the pattern to manufacturing.

Make the pattern workspace large enough to cover the entire cylinder. ArtiosCAD will trim it
automatically as needed. However, ArtiosCAD cannot expand the pattern if it is too small.

ArtiosCAD positions the pattern according to the settings in the die press parameter set. If the
parameter set sets the MHP (Mounting Hole Pattern) on the center of the die board, the origin (0,0) of
the pattern workspace is aligned with the center of the die board. If the die press parameter set sets
the MHP at the machine reference point, ArtiosCAD aligns the origin of the pattern with the machine
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reference point. After that, if the workspace contains X or Y offsets for the MHP, ArtiosCAD adjusts the
pattern accordingly.

Shown below is the sample ..\InstLib\MHP66OFFCENTER.ARD workspace. It has small horizontal
annotation lines along the Y axis in between the rows for easier pick-up when moving the pattern.
 

 

Adjust Elements state
The Adjust Elements state of the Rotary Die Board tool has these mode controls on the Status bar:
 

 
These modes do the following:

• Move Holes Vertically. Moves the hole pattern vertically (the default mode) and prompts for pick-up
points.

• Move Holes Horizontally. Moves the hole pattern horizontally

• Move Die Edge, Splits and Holes. Moves the die edge, splits, and holes vertically

• Move Splits and Holes. Move splits and holes vertically.

Shown below is after you first start the tool with no existing holes. It is in Adjust Elements state, Move
Holes Vertically mode. The hole pattern is on with good and bad holes marked.
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In Move Holes Vertically mode, do the following:

1. Click a pick-up point.
2. Drag the pattern by the desired offset.

 

 
3. Click to set the put-down point.
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In Move Holes Horizontally mode, do the following:

1. Click a pick-up point.
2. Drag to set the offset.

 

 
3. Click to set the put-down point.
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The other two modes, Move Die Edge, Splits, and Holes, and Move Splits and Holes, work the same way
- pick up, drag, and put down.

Note:  When using Move Die Edge, Splits, and Holes mode, the X and Y offsets are not changed
if the MHP position is based on the die board center since you are moving the die board edge
with the pattern. If the MHP position is based on a reference point, ArtiosCAD changes the Y
offset of the pattern in workspace variables. If you did not delete the existing bolt holes when
starting this state, ArtiosCAD adjusts the existing holes by the same offset as the MHP.

Move Splits and Holes mode has some additional features:

• Shows the height or angle as drag feedback depending on which field is active in the Status bar.
• When setting the height, the drag is the vertical offset from the pickup point to the cursor.
• When setting the height or angle, the current position is the split. It turns red if the shell is bigger

than 180 degrees or one full shell height.
• When selecting the pickup point, the drag prompt depends on what is closer. Change the Split

measured from control to change what you are dragging.

Adjust Die Edge state

 The Adjust Die Edge state of the Rotary Die Board tool moves the die edges either horizontally or
vertically, singly or doubly. It has these controls on the Status bar.
 

 

Move both sides is the default and moves the parallel edges.

Offset or Height (vertical edges only) or Width (horizontal edges only) controls what you are setting
with the drag. However, both numbers are shown in the drag feedback, which turns red when
construction becomes impossible. Height mode also allows you to set the angle and gives drag for that
if you select it on the Status bar.
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The drag displays the offset from the pick-up point above the cursor, and the width/height below the
cursor. If you are in Height mode and setting the Angle, the drag shows the angle instead of the offset.

If there is a die split connected to the edge you are moving, ArtiosCAD adjusts it automatically.

Shown below is the drag in Height-Angle mode when construction is not possible. ArtiosCAD also says
Construction not possible in the drag when you are trying to make the dieboard too small or go across
a split.
 

 

Adjust Die Split state

 The Adjust Die Split state of the Rotary Die Board tool creates a new die split, or for existing splits,
moves or deletes them. It has no controls on the Status bar when adding a split, but has the same
controls as the Adjust Die Edge state when moving a split.

To create a dieboard split, do the following:

1. Click an edge of the die that is parallel to the desired split.
2. Drag to set the position of the split. Change the controls on the Status bar to change where the split

is measured from (the Bottom or Top) and what you are setting with the drag (Offset or Angle). The
numbers next to the cursor change for different types of drag - distance from the top or bottom,
or angle from the top or bottom. As with the other states, the drag turns red if construction is not
possible. ArtiosCAD also says Construction not possible in the drag when you try to drag a split off
the die.
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3. Click to set the position of the new split.

To move a die split, do the following:

1. Click the split to move.
2. Drag it, setting the drag controls on the Status bar as desired.

 

 
3. Click to set a put-down point.

To delete a die split, do the following:

1. Click the split to delete.
2. Drag it off the dieboard. The drag will change to Delete split.
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3. Click to delete the split. You can also press the Delete key on the keyboard.

Note:  Using this mode, you can move or delete complicated splits created by geometry
macros, but you cannot add them. Re-run the geometry macro if needed.

Add Bolt Holes state

 The Add Bolt Holes state of the Rotary Die Board tool adds bolt holes from the mounting hole
pattern to the workspace once you have the pattern positioned. It has the following controls on the
Status bar.
 

 

The first control on the Status bar is Show/Hide Bolt Hole Effective Area. This shows the area of
the die board up to a split that is held tight by the bolt as you select holes. The area is set in Options
> Defaults > Die Press Parameter Sets > Press name > Press defaults > Hole Patterns. Viewing the
bolt hole effective area is also an option in the View mode. Shown below is the effective area for the
selected hole up to a split.
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The next three controls on the Status bar control what you select with the cursor. The first is Select
Individual Holes, then is Select Row, and last is Select Column.

• When selecting individual holes, click to select or deselect a hole, or click outside of a hole and drag
to do a marquee selection, which toggles the current selected state. Selected holes turn magenta.
This mode works with die board symmetry if that mode is enabled.

• When selecting by row, click on or inside a hole to mark holes in that row for selection. ArtiosCAD
draws a magenta line through the row to show it is marked as shown below. Only holes that are at
the intersection of marked rows and columns become selected. Click inside a hole in a marked row
to unmark it. This mode does not work with die board symmetry so that mode is unavailable.
 

 
• When selecting by column, click on or inside a hole to mark holes in that column for selection.

ArtiosCAD draws a magenta line through the column to show it is marked. Click inside a hole in a
marked column to unmark the column. Only holes that are at the intersection of marked rows and
columns become selected, as shown below by the one hole below with an area of effectiveness
that indicates it is selected. This mode does not work with die board symmetry so that mode is
unavailable.
 

 

The next two controls are for Show All Holes and Show Only Good Holes. Good holes do not intersect
with any geometry.

The next two controls are for No Symmetry and Die Board Symmetry, and these are available only for
Select Individual Holes. No Symmetry means you select one hole per click. Die Board Symmetry means
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that you select symmetrical holes with a click within a given distance of a split and a hole at the same
distance from that split on the other side of the split. These distances are set by the Split distance
and Select tolerance fields in Options > Defaults > Die Press Parameter Sets > Press name > Press
defaults > Hole Patterns.

Lastly, Add adds the selected holes to the workspace. When the current selection is by rows and
columns, ArtiosCAD adds only those holes at intersections.

Note:  To add individual holes as well as rows and columns, first work with rows and columns,
then switch to individual mode to add or remove holes and click Add. When doing it the other
way around, selecting individual holes before working with rows and columns clears the
selection of individual holes when switching to rows or columns. Select individual holes first.

Note:  This tool will preserve subtypes defined on the rotary bolt holes.

Delete Bolt Holes state
The Delete Bolt Holes state of the Rotary Die Board tool deletes bolt holes from the manufacturing
workspace. It has no controls on the Status bar.

To delete bolt holes, do the following:

1. Activate the Delete Bolt Hole state.
2. Click an individual hole to delete, or click and drag to define a marquee selection. ArtiosCAD deletes

the bolt hole(s) when you release the mouse button.

Rule Path tools

A rule path is the outline of the rule which is inserted into the dieboard. Diemakers strive for the most
cost-ecient and structurally sound rule paths. Shown below is the Rule Path toolbar.
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Other than the Build Rule Path tool, all tools on this toolbar are unavailable outside of the Other
sublayer of the Rule Path layer. Also, while in the Rule Path layer, the tools on all other toolbars, except
for those on the View toolbar and the Move tool, are unavailable so that the rule paths are not modified
accidentally. You must change to another layer to use other tools.

The parameters by which rule paths are built are in the Rule Path Parameters dialog box on the Options
menu in Manufacturing.

Build Rule Path tool

 The first button on the Rule Path toolbar activates the Build Rule Path tool. When held down, it
displays the Build/Delete/Add Rule Path flyout toolbar as shown below.
 

 

When activated, it first checks to see if double knives are present; if so, it prompts for their removal.
Once the double knives issue has been resolved, ArtiosCAD asks for confirmation to rebuild the rule
path layer, as any existing rule paths and bridging changes will be deleted:

Click OK to continue the process of automatic rule path generation, or click Cancel to deactivate
the tool. Once the rule mapping process is completed, the current layer will be changed to the Other
sublayer of the Rule Path layer.

ArtiosCAD will prompt to map generic rules to specific special rules the first time it builds the rule
paths. To do so, select the generic rule to map, click the drop-down list activator arrow at the end of
the Rule Mapping: field, and choose the appropriate special rule type from the list displayed. If the
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Treat all cuts the same checkbox is checked, all cuts are processed with the same rule. If it is clear,
you can choose different rules for each type of cut.

Any rule in the Special Rules Catalog which has a valid bridging formula is listed in the drop-down list
box. If this is a flat die, click OK to proceed or Cancel to cancel building rule paths.

If this is a rotary die, flat rule must be mapped to rotary rule. Click the Flat Rotary Rule Map tab (which
will only appear if this is a rotary die) as shown and verify that the mapping is correct. If the mapping is
not correct, select the flat rule to change and choose a new rotary rule from the drop down list box in
the Rotary Rule: field. If you choose a rotary rule with a different pointage from the flat rule, you will be
warned and will have to click OK to proceed.

When you are done mapping rule, click OK to proceed with building the rule paths or Cancel to cancel.
The Rule Paths layer is created and the rule paths are created in it. Rule path start points are shown as
green teardrops and stop points are shown as red triangles; both point in the direction of the rule path.
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Notes on building rule paths
Rule paths are grouped by rule type and pointage.

A rule path follows the contiguous outline of a design instead of branching off onto a dead-end piece of
rule.

Lines sharing a piece of rule (those made by Double Knife Removal) share a rule path as well.

Outlines of the same rule type which form a contiguous waste area are grouped into one rule path.

Defaults for rule paths are contained in the rule’s entry in the Special Rule Types catalog and in the Rule
Path Params entry in the selected Manufacturing parameter set.

When rule paths are created, the Bridge from center option is used for each rulepath which has a slot,
overriding the option in the Bridge from group in the bridging formula for that special rule type.

If rule paths do not wrap as expected, make sure that Optimize Rule Paths is selected in the
Optimization group of the Rule Path Parameters dialog box. Be especially wary of this situation when
converting a flat die to a rotary die by changing the press definition after creating the layout.

If you have concerns about wrapping points for flat rule and rotary rule, see the discussion in the
Manufacturing tab for special rules topic in the Defaults chapter.

When three or more rule paths meet, the following rules are used:

• Separate rule paths for scrap knives. Rule paths for horizontal and vertical scrap knives are
separate. They do not join with each other or with cut lines in the design, except for a stripping rule
at a corner.

• Avoid joints at corners in the design outline. A joint is a point where rules meet. With use over
time, rules can bend at joints, leaving small gaps at the joints. ArtiosCAD places joints on horizontal
or vertical pieces of rule by wrapping them around corners to minimize this problem.
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• Avoid joints at corners in waste areas. When two designs have no gap between them, there can not
be a continuous outline. ArtiosCAD avoids joints at corners in the waste between designs.

• Stripping rules/scrap knives at a corner. When a stripping rule or scrap knife touches a design at
the corner, it is joined with the design. When there are stripping rules at the corner of a hairpin, they
are joined to form one rule path.

Delete Rule Path tool

 The second button on the Build/Delete/Add Rule Path flyout toolbar activates the Delete Rule
Path tool. When clicked, you are asked to confirm the deletion of the layer and its contents:
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Click OK to delete the Rule Path layer and its contents, or click Cancel to keep the layer and its
contents.

Add Rule Path tool

 The third tool on the Build/Delete/Add Rule Path flyout toolbar is the Add Rule Path tool. Use this
tool when you have added lines to the layout after building the rule path layer and do not want to rebuild
the entire layer. To use this tool, do the following:

1.
 Use the Select tool on the Single Design Edit toolbar to select the lines to make into rule paths.

2.
 Click Add Rule Path.

3. In the Rule Mapping dialog box, map the line type conversion for these new rule paths in the same
way as when the layer is first built and click OK.

4. The Rule Path layer will be entered and the new rule paths created.

Select Rule Path tool

 The second button on the Rule Path toolbar activates the Select Rule Path tool. As its name
implies, when the tool is active, click the mouse button to select a rule path. To select more than one
rule path, hold down the CTRL or SHIFT key while clicking.

When you select a rotary rule path, ArtiosCAD shows the teeth, bridges, bridge start indicator, and end
points of the rule path as shown in the following diagram.
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A flat rule path only shows bridges and the start and end of the rule path.

Right-clicking a rule path once stops the current tool and activates the Select Rule Path tool. Right-
clicking a rule patch twice activates a context menu as shown below:

The tools on this menu are also on the Rule Path toolbar, and are explained as the chapter progresses.

Changing rule path properties
To change the special rule type a rule path is based upon, or to rebridge a rule path, do one of the
following:

• Activate the Select Rule Path tool and double-click the rule path(s) to change;
• Activate the Select Rule Path tool and select the rule path(s) to change and press ALT-Enter;
• Activate the Select Rule Path tool, select the rule path(s) to change, and click Edit > Properties.
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Note:  Do not change the properties of a rule path by using the Select tool to make a multiple
selection of it along with other types of manufacturing elements. The Properties dialog box will
show Can not display properties for mixed selection of rule path and other items instead of
properties for the selected items.

The Properties dialog box will appear. Rules with teeth have different properties than rules without
teeth.

Clicking the drop-down list activator arrow in the Special Rule Type field displays a list of available
special rule types. Click the new special rule type for the rule path. If you select a special rule type
which does not have a teeth bridging formula defined, the dialog box will change to the Without Teeth
Rule Path Properties dialog box shown on the next page.

Clicking the drop-down list activator arrow in the Sub Type field displays a list of available subtypes. If
desired, choose a subtype for the rule.

The options in the Bridge start point group control the position of the start of the bridge in the
direction of the rule. When this option is changed, the bridges on the rule path are moved by half a
tooth.

The options in the Bridge from group controls the position at which bridging starts. When this option
is changed, the bridge start position is moved and the rule path is rebridged. This option applies only to
rule paths without slots.

To change the bridge width on the selected rule(s), enter a new value in the Bridge width: field. If the
bridge width is changed to zero and then another value, the rule path is rebridged and the bridge start
point will be set according to the default bridging formula for that special rule type.

The number of bridges on a rule with teeth cannot be changed manually.

When a special rule type without teeth is selected, the Without Teeth Rule Path Properties dialog box is
shown:
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Clicking the drop-down list activator arrow in the Special Rule Type field displays a list of available
special rule types. Click the new special rule type for the rule path. If you choose a rule which has a
teeth bridging formula defined, the dialog box will change to the With Teeth Rule Path Properties dialog
box shown previously.

Clicking the drop-down list activator arrow in the Sub Type field displays a list of available subtypes. If
desired, choose a subtype for the rule.

Change the bridge width and number of bridges by changing the values in the Current values group. If
the number of bridges is set to zero, the bridge width is also set to zero. If you change the number of
bridges to zero and then to some other number, the bridge width is calculated from the default formula
for that special rule type, and the new bridge width is displayed in the Bridge width: field. If the bridge
width is changed to zero and then to some other number, the number of bridges is set to one and the
new bridge will be placed in the middle of the longest line in the rule path.

Click OK to make the changes indicated in the Properties dialog box, or click Cancel to discard them.

Split Rule Path tool

 The third button on the Rule Path toolbar activates the Split Rule Path tool. It is also on the Select
Rule Path tool context menu. When this tool is activated, it displays the following controls on the
Status bar.

The first button, Offset, splits the rule at the nearest start/end point of the rule path with the offset
specified in the Offset: field. Center, the second button, splits the selected rule path at its center. The
third button, Anywhere, splits the rule at the nearest coordinate to the mouse click.

Choose a placement method and then click the rule to split.
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Shown below is a rule path before and after being split at its center.

Join Rule Path tool

 The fourth button on the Rule Path toolbar activates the Join Rule Path tool. It is also available on
the context menu of the Select Rule Path tool. To use it, click it, indicate the first rule path to join, and
then indicate the second rule path to join. The lines on which the rule paths are based must share an
endpoint. The resulting rule path will be the same special rule type as the first path selected.

Only rule paths in the same section of the dieboard can be joined. Rule paths can not be joined across
dieboard splits.

Move Bridge Start Point tool

 The fifth button on the Rule Path toolbar activates the Move Bridge Start Point tool, and when held
down, activates a flyout toolbar containing this tool and the Reverse Rule Path tool.
 

 

The Move Bridge Start Point tool moves the start point of the bridging on the rule path.To use it, click
it, select the rule path to modify, and then drag the start marker to its new position.
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Changing the bridge start point will automatically cause ArtiosCAD to rebridge the rule path using the
rule path’s bridging formula defined in Defaults.

Reverse Rule Path tool

 The second button on the flyout toolbar activates the Reverse Rule Path tool. This tool exchanges
the start of the rule path with the end of the rule path. This will also change the current bridge start
point from one end of the rule path to the other if the special rule path is defined to not start bridging
at the center of the rule path.

Only rotary rule paths can be reversed.

Move Bridge Start Point to Center tool

 The sixth button on the Rule Path toolbar activates the Move Bridge Start Point to Center tool.
To use this tool, click it, and then click the rule path to change. It is intended to be used on rules with
teeth; if you select a rule without teeth, Bridge start point is not defined appears in the Status bar and
the tool continues to operate until you choose a rule with teeth or another tool.

Change Wrap Point tool

 The seventh button on the Rule Path toolbar activates the Change Wrap Point tool. It is also
available on the context menu for the Select Rule Path tool. This tool moves the wrap point, which is
the junction between flat rule and rotary rule.

To use this tool, do the following:

1.
 Click the Change Wrap Point tool.

2. Click the wrap point to move. When three or more rule paths meet, you can select the wrap point
either by a single click on the wrap point or by clicking each rule path separately. Shown below is a
selected wrap point centered on the suggested wrap margin, with another suggested point on the
other side of the corner.

3. There will be drag markers of new snap positions shown at the wrap distance before and after each
bend in the rule.

If the bridge start point is the same as the current wrap position, the bridge start point will move
with the wrap point. If the bridge start point is not at the wrap point, suggested snap positions are
shown for each back notch position measured from the bridge start position.
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Move the drag of the wrap point to the new position.

 

 
4. Click the mouse to set the position of the new wrap point.

You can also use this tool to move the start point of a looping rule path without changing the bridge
starting point.

Add Bridge on Rule Path tool

 The eighth button on the Rule Path toolbar activates the Add Bridge on Rule Path tool, and when
held down, activates a flyout toolbar containing it, the Re-bridge Rule Path Layer tool, and the Add
Mark to Rule Path tool.
 

 

To use this tool, click it and then click the position for the new bridge. The rule path will be selected and
the new bridge will appear. Click another position along the rule path to add another bridge.

If a rule path needs to have bridges of different widths on it, that rule path must be split first, and
bridge width changed on each piece of rule separately.

Re-bridge Rule Path Layer tool

 The second button on the flyout toolbar activates the Re-bridge Rule Path Layer tool.

When you click this tool, ArtiosCAD displays a warning dialog box:
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Clicking OK deletes all the bridges and re-bridges the rules according to their bridging formulae
configured in Defaults. Clicking Cancel returns you to Manufacturing.

Add Mark to Rule Path tool

 The third button on the flyout toolbar activates the Add Mark to Rule Path tool. This tool adds
a mark to a rule path and snaps to any of these points: the rule path start position, the bridge start
position, and back notch positions. Marks are added as grouped lines and can be selected by the Select
tool.

To use this tool, do the following:

1.
 Click the Add Mark to Rule Path tool.

2. Select the shape of the rule mark to add by clicking its button on the Status bar. You can change the
size of the mark about to be added in the Mark length: field.

3. Click the rule to which the mark will be added.
4. Drag the mouse to position the mark as desired. If the marker is not symmetrical, it is drawn on the

same side of the line as the cursor. Click the point at which to add the marker.

5. To continue adding marks, repeat steps 3 and 4.

To change the mark length for new marks when not using the tool, change the Mark length: field in the
Rule Path Parameters dialog box on the Options menu in Manufacturing.
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To change the default mark length, change the Mark length: field in the Rule Path Params section of
the Manufacturing parameter set.

Delete Bridge on Rule Path tool

 The ninth button on the Rule Path toolbar activates the Delete Bridge on Rule Path tool. The
viewing of bridges is automatically turned on when this tool is activated.

To delete a bridge, select it with the Select Rule Path tool, then click the Delete Bridge on Rule Path
tool and click the bridge to delete. Click the Select Rule Path tool again, select the rule, and note that
the bridge is gone.

Move Bridge on Rule Path tool

 The tenth button on the Rule Path toolbar activates the Move Bridge on Rule Path tool, and when
held down, activates a flyout toolbar containing it and the Align Bridge on Rule Path tool.
 

 

The viewing of bridges is automatically turned on when this tool is activated. To use the Move Bridge
on Rule Path tool, click it, then click and drag the desired bridge to its new position.
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This tool can also add and delete bridges. To add a bridge, click a bridge and hold down CTRL while
dragging it. To delete a bridge, click it and press Delete on the keyboard.
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Align Bridge on Rule Path tool

 The second button on the Bridge Position flyout toolbar activates the Align Bridge on Rule Path
tool. This tool aligns bridges either horizontally or vertically with bridges in other rule paths. Aligning
bridges is made much easier by turning bridges on in the View Mode dialog box

To use this tool, click it, indicate the bridge to align others with (called the anchor bridge), and then
indicate the other bridges.

DieSaw / Leader Hole Tools toolbar

The DieSaw / Leader Holes Toolbar contains tools for making leader holes. Leader holes are used by
the DieSaw when it is sawing a dieboard, upper stripping board, or lower stripping board. The toolbar is
shown below.
 

 

Leader hole creation is configured in the Kongsberg DieSaw group on the Processing page in an Output
definition. The physical tool they are created with is configured in the CAM Tooling Setup Catalog.

Note:  If you are outputting to a DieSaw and you have not made any leader holes yourself (for
example, if you know you will not need to adjust them), they are created automatically during
the output procedure and deleted when the output is done.

Generate Leader Holes tool

 The first tool on the DieSaw / Leader Hole Tools toolbar activates the Generate Leader Holes tool.
This tool automatically generates leader holes. After you click Generate Leader Holes, ArtiosCAD will
prompt you to select an Output so that it can read the leader hole parameters stored in the Output
definition. Only those Outputs configured to generate leader holes are listed. Select an Output and
click OK to proceed, or click Cancel to cancel.
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Once you click OK, ArtiosCAD changes to the layer specified on the View tab of the Output definition
(Dieboard, Upper stripping board, or Lower stripping board), creates a DieSaw sublayer, copies
the contents of the appropriate layer to the DieSaw sublayer and changes them to the appropriate
Manufacturing-class line types, and creates leader holes in that sublayer. The lines created are in
the Manufacturing category of the plotting style. Shown below is a magnified view of a dieboard with
leader holes.

Leader Hole error checking
ArtiosCAD performs a series of checks on the structure of the manufacturing file before generating the
leader holes. If there are problems, an error dialog box appears listing the error(s). Possible errors are:

• Drill hole is not a circle;

• Inside edge lines do not form a loop;

• Outside edge lines do not form a loop;

• Mill outline does not form a loop;

• Cannot offset inside edge lines;

• Cannot offset outside edge lines;

• Cannot offset mill outline;

• Cannot offset side bevel lines;
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• DieSaw output with no SAW tools defined;
• Die split lines do not connect to the dieboard edge;
• Saw lines have no leader hole;
• Enveloped corner with saw not recommended;
• Lines enveloped with saw.

In the Output Processing Errors dialog box, you can choose to view the problem and not generate the
leader holes by clicking Show Selected Error, or ignore the problems and generate the leader holes
anyway. Clicking Ignore causes the offending lines to not be included in the layer, so use this option
carefully.

If you have already generated leader holes in this manufacturing file, you will be prompted to overwrite
the existing ones. To overwrite the existing holes, click Yes; any manual changes you made to the
leader holes will be lost if you click Yes. Clicking No initiates no changes.

Add Leader Hole tool

 The second button on the DieSaw / Leader Hole Tools toolbar activates the Add Leader Hole tool.
To add a leader hole, click the tool, and then click the location of the desired leader hole.

If the location clicked is within the snap distance of an end point of a rule, the leader hole snaps to the
end point; otherwise, the cursor changes to a cross-hair and you have to drag along the rule to set the
position of the leader hole as shown in the picture below. Drag away from the rule to create a lead-in
line.
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Note:  No checks are performed when adding leader holes manually to ensure that they do not
interfere with each other.

Delete Leader Hole tool

 The third button on the DieSaw / Leader Hole Tools toolbar activates the Delete Leader Hole tool.
To delete a leader hole, click the tool, and then select the leader hole to delete.

All rules that used the deleted leader hole will be reversed and a leader hole will be added at the other
end if needed.

If the deleted leader hole had a lead-in line, the lead-in line will be deleted as well.

Reverse Cut tool

 The fourth button on the DieSaw / Leader Hole Tools toolbar activates the Reverse Cut tool. This
tool reverses the sawing direction of the rule and moves the leader hole to the other end of the rule.

If the rule segment shares a leader hole with another rule segment, the leader hole will move to the
other end of the selected rule segment and the shared leader hole will be kept.

If the leader hole for the segment uses a lead-in line, the rule segment will reverse and add a leader
hole at the opposite end from the current leader hole and not include a lead-in line.

Delete DieSaw Layer tool

 The fifth button on the DieSaw / Leader Hole Tools toolbar activates the Delete DieSaw Layer tool.
When clicked, this tool will ask for confirmation, and if you click OK, it will delete the contents of the
DieSaw layer. If you click Cancel, nothing will happen.

Notes on Leader Holes
If there is a milling area at the intersection of lines which would otherwise share a leader hole, the rules
are reversed so that each line has an individual leader hole and cuts into the area that is milled.

Dieboard Split tools

The Dieboard Split tools are on the Dieboard toolbar. They are active only when the Dieboard layer is
the current layer.
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Horizontal Split tool

 The ninth button on the Dieboard toolbar activates the Horizontal Split tool, and when held down
activates the Dieboard Split Tools flyout toolbar.
 

 

To add a horizontal split, click the tool, drag the ghost split to the desired position, and click to set it in
place. Tack bridges are created on the lines forming the split.

The options on the Status bar will let you choose either the Top or the Bottom edge of the die to
measure the Offset from. The Angle refers to the angle through the center of the cylinder that this
split creates.

Vertical Split tool

 The second button on the Dieboard Split Tools flyout toolbar activates the Vertical Split tool. This
tool works similarly to the Horizontal Split tool except the split is measured from the left or right side of
the die depending on the selection in the Status bar. Tack bridges are created on the lines forming the
splits.

Vertical splits are not at an angle, so no angle is displayed.
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Delete Split tool

 The third button on the Dieboard Split Tools flyout toolbar activates the Delete Split tool. When
clicked, this tool asks for confirmation, and if OK is clicked, it deletes the contents of the Die Splits
sublayer. Click Cancel to keep any dieboard splits.

Registration Hole Tools toolbar

The Registration Hole Tools toolbar contains the tools necessary for adding holes to the workspace.
 

 

Add Hole tool

 The first button on the Registration Holes toolbar activates the Add Hole tool, and when held
down, activates the Add Holes flyout toolbar.
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To add a hole, click Add Hole. The Status bar will change to show hole creation options.

Choose the type of general hole to add from the drop-down list box. Click More options (...) to invoke
the Properties dialog box for the hole, where you can modify the hole parameters before adding it.

When you are done modifying the properties for the hole, click OK to save the changes and return to
Manufacturing, or click Cancel to discard the changes and return to Manufacturing. To set the position
of the hole, click at the desired location. The tool repeats until you click OK or select another tool.

Add Countersunk Hole tool

 The second button on the Add Holes flyout toolbar activates the Add Countersunk Hole tool.
This tool works in the same fashion as the Add Holes tool except it adds holes which are defined as
countersunk. Select the type of hole to add from the drop-down list box on the Status bar, modify its
properties if necessary by clicking the More options (...) button, click the locations at which to place a
hole, and click OK to end the tool. Shown below is the Properties dialog box for an example countersunk
hole.
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Add Oblong Hole tool

 The second button on the Registration Hole Tools toolbar activates the Add Oblong Hole tool, and
when held down, activates the Add Oblong Holes flyout toolbar.
 

 

This tool adds a non-circular hole to the workspace. It works the same way as the other hole tools
except you can specify different X and Y diameters for the hole diameter.

Add Countersunk Oblong Hole tool

 The second button on the Add Oblong Holes flyout toolbar activates the Add Countersunk Oblong
Hole tool. Its method of operation is similar to the other Add Hole tools, except that it is countersunk.
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Add Drill Hole tool

 The third button on the Registration Hole Tools toolbar activates the Add Drill Hole tool, and when
held down activates the Add Drill Hole Tools flyout toolbar.
 

 

This tool works the same as the other hole tools, except on its Properties page, you can only change
the type of hole being made. No other configuration options are available when adding the hole.

Add Countersunk Drill Hole tool

 The second button on the Add Drill Hole tools flyout toolbar activates the Add Countersunk Drill
Hole tool. Its mode of operation is the same as for the Add Drill Hole tool. Using the Hole Catalog drop-
down list box, only the type of hole being made can be changed on its Properties page; the Diameter,
Center Mark, Countersink checkbox, and Counter Sink Diameter fields are unavailable.
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Rotary Diemaking Workflow

This is a flowchart of a possible workflow, followed by a step-by-step explanation using the tools
described earlier in the chapter.
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1. Design and save the single design(s) to include in the manufacturing file.
2. Create the manufacturing file and arrange the designs as desired.
3. Create the dieboard and stripping rules.
4. Add the mounting holes and adjust if necessary.
5. Add the dieboard splits and adjust if necessary.
6. Map the flat rules to rotary rules.
7. Build the rule path and adjust if necessary.
8. Apply the bridging and adjust if necessary.
9. Is the dieboard being made with a DieSaw? If so, build the leader holes and adjust them if necessary.
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10. Output the dieboard sections.

Prerequisites

To follow the sample workflow, ArtiosCAD must have the following Defaults defined:

• A Bridging On Teeth formula set up and saved;

• Rotary rules created and saved in the Special Rules Catalog;

• A rotary press defined;

• A dieboard which uses an alignment method other than notch;

• Sheet allowances on side-to-side, but 0 on front-to-back;

• An Output defined for rotary dieboards, which on the View tab has the Rule Path layer being output
at the Wood level;

• A Mounting Hole Pattern (MHP) defined.

Most of these defaults have example entries. Copy the examples and modify them with your specific
information.

Using Layers

When you change layers, the active tool stops and no new tool starts. This prevents putting elements in
the wrong layer.

The layers that are displayed when a manufacturing file is opened depends on the setting in Options
> Defaults > Shared Defaults > Design Defaults > Default View Mode. You can choose to display the
layers as they were when the manufacturing file was saved, or you can choose to always display the
same set of layers.

Default layers in Manufacturing

You can specify layers that will be created in new manufacturing files and in existing manufacturing
files when they are opened. See the Defaults chapter for more information.

Move to Layer tool

 The Move to Layer tool in Manufacturing works similarly to its namesake in Single Design, but
it offers greater functionality as objects can be moved into layers within included designs as well as
layers in the manufacturing file.

To use this tool, select the object(s) to move to another layer using the Select tool on the Single Design
Edit toolbar, and click the tool, located on the Move tools flyout toolbar on the Single Design Edit
toolbar. The enhanced Move To Layer dialog box will appear similar to the one shown below.
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Only unlocked layers are listed.

To move the objects into a different layer of the manufacturing file, pick the layer in the Destination
Layer pane, and then pick the sub-layer in the right pane. To create a new layer in the manufacturing
file, click Create Layer, enter the name for the layer in the resultant field, and click OK.

To move the object(s) into an existing single design embedded in the manufacturing file, select the
single design in the left pane (its name will be preceded by the word ONEUP), and then select the
desired layer of the selected single design in the right pane. Click OK to perform the move.

To create a new embedded single design in the manufacturing file, click Create Oneup, enter its name,
and click OK. The new single design will appear in the list of destination layers. You can then select it
and create new layers in it if desired.

To create a new layer in the single design, click Create New Oneup Layer, name the layer, select its
class, and click OK.

The Destination layer visible checkbox turns the selected layer in the ArtiosCAD window on or off while
the Move To Layer dialog box is open.

The line type that the selected object(s) will be changed to upon moving is shown in the Destination
Line Type: field. Clicking Line Type lets you change the destination line type. If more than one item
is selected, and they are all the same type, that type will be shown in this field. If they are of different
types, UNCHANGED is shown.

When the selected Destination Layer is a manufacturing element, the Destination Line Type shown is
the default line type for that element, and the Line Type button is unavailable. For example, when the
Destination Layer is the Dieboard and the Manufacturing Element is Hand hold, the Destination Line
Type is Die registration hole and the Line Type button is unavailable.

When moving items, if an entire group is being moved, it will remain a group after the move. If only part
of a group is moved, those items will be removed from the original group and ungrouped when moved.
The rest of the original group will remain a group.

Clicking Cancel dismisses the dialog box and does not move the selected items. However, any layers or
single designs that have been created using Create Layer, Create Oneup, or Create New Oneup Layer
will remain.
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Designer’s Fix-It

Designer’s Fix-It is a tool on the Manufacturing menu in Manufacturing and the Design menu in Single
Design. It cleans up and reorganizes geometric data imported into ArtiosCAD from other sources.

Designs may look fine on the surface, but errors called anomalies can lurk below and ruin a resultant
tooling set and production run.

The general workflow is to import the data, use the Move To Layer tool to create single designs out of
the oneup data, open those embedded designs and run Designer's Fix-It, and then run Designer's Fix-It
in Manufacturing to clean up the non-embedded-design data.

When you start Designer's Fix-It, a toolbar appears to the right of the drawing area.

Clicking an icon on the toolbar invokes the particular tool. If the tool finds no anomalies, a dash is
displayed in the Found column. If the tool finds anomalies, the total is shown in the Found column, and
the anomalies are highlighted in the workspace.

To find all anomalies at once, click Find All.

Anomalies which can be fixed are dark blue when the screen background is light, and light blue when
the screen background is dark. Anomalies which cannot be automatically fixed are light blue when the
screen background is light and dark blue when the screen background is dark.
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To select an anomaly, click it; to select more than one, hold down SHIFT and click the individual
anomalies, or hold down CTRL and use a selection window. Selected anomalies will turn magenta.

To fix the selected anomalies, click Fix Selected. To fix all the anomalies, click Fix All.

Some of the tools in Designer's Fix-It have parameters which appear in the Status bar. These
parameters let you adjust what is an anomaly and what is not.

Note:  The tools in Designer’s Fix-It do not search for anomalies in any of the Graphics layers.
Also, the tools work on lines and arcs only; if there are beziers in the workspace, select them
all and convert beziers to arcs as desired using Tools > Adjust Outline > Change Beziers to
Arcs in Single Design. Using Designer's Fix-It in an existing ArtiosCAD workspace disables
StyleMaker. You will be prompted to save the design before proceeding, disable rebuild and
proceed without saving, or to exit from the selected feature.

 Tool descriptions and uses

Split Lines tool

 Split lines. These are lines that intersect other lines at points not at the end of the line. When
you click the icon, the tool intersects each line in the workspace with every other line, and searches for
intersections which are not at the end-points of lines. ArtiosCAD performs the intersections invisibly.

Shown below are intersections that do not occur at two end-points. However, these are acceptable
anomalies based on the basic structure of the carton.

Merge Points tool

 Merge Points. When multiple lines have end-points which are very close to each other, they
should be combined into a common end-point. The direction and amount of moving of the multiple
end-points into one end-point depends on the type of lines involved and the angle of the lines forming
this anomaly. Horizontal and vertical lines take preference over non-horizontal and non-vertical lines,
and creases take preference over cuts.

The Merge Points tool has one parameter: Size. The value in the Size: field on the Status bar sets the
maximum gap between points for two points to be considered an anomaly.

The design below may look normal:
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However, when the Merge Points tool is run, it finds these anomalies:

Every intersection in the design shown above is wrong. The numbers in the picture above are in
millimeters; the gap at the top left intersection is one-tenth of a millimeter. When the point is zoomed
in upon, it looks like this:
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To fix these intersections, select them and click Fix Selected.

The anomaly shown above is shown fixed below.

Overruns – Underruns tool

 Overruns – Underruns. An overrun is when a line extends slightly beyond its intersection
with another line. An underrun is when the endpoint of a line falls slightly short of causing its line to
intersect with another line. Anomalies of this type are displayed with their size next to them.

This tool has two parameters - Size and Minimum Angle. Size sets the maximum distance between the
end-point of a line and another line that is considered an anomaly; overruns or underruns larger than
this value are ignored. Minimum Angle sets the minimum angle at which the two lines must intersect in
order for them to be checked for overruns and underruns; if they intersect at an angle smaller than the
value specified, any overrun or underrun is ignored.

The layout below, while appearing normal, has Overrun – Underrun anomalies in the stripping rules:
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Clicking the Overrun – Underrun tool results in these anomalies being displayed:

Nearly Horizontal or Vertical tool

 Nearly Horizontal or Vertical. This tool searches for lines which are nearly horizontal or
vertical. The Size: parameter prompts for the minimum length of the line, and the Maximum Angle:
parameter sets the largest angle of deviance from horizontal and vertical that the tool will find.

This tool only highlights anomalies - you must fix them manually by leaving Designer's Fix-It and using
the Edit tools.

Shown below is what looks to be perfectly orthogonal geometry.

1496



13ArtiosCAD

When the Nearly Horizontal or Vertical tool is run, however, anomalies are found:

The anomalies are shown below with the aid of perfectly horizontal and vertical construction lines and
the Measure tools. Use the Edit tools to fix them.

Double Knives tool

 Double knives. This tool searches for lines that are either on top of each other or are
separated by a tiny gap and nearly parallel. The Size: field sets the minimum length of lines to be
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checked for duality and the Maximum Angle: field sets the maximum angle between lines to check
against.

Shown below is a design with some Double Knife anomalies. The number indicates the distance
between the double lines.

Fixing the double lines is an invisible process.

Short Lines tool

  Short Lines. A Short Line anomaly occurs when a single line has both endpoints within the
distance set by the Size: parameter. To be considered an anomaly, the short line cannot be connected
to another line. Shown below is a design plotted using Scale To Fit.
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Note that even though Scale To Fit was used, the design does not fill the drawing area. Using the Short
Lines tool reveals that there are two short lines.

The number next to the anomaly indicates the size of the short line.

Line – Gap Sequence tool

 Line – Gap Sequence. This tool finds collinear sequences of lines and gaps that should be
turned into one line with bridges. Shown below is a design with what looks like normal bridging.
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Using the Line – Gap Sequence tool reveals that nearly all of the lines and gaps could be converted into
lines with bridges:

Magnifying the left most line of the sleeve body, one can see that there are actually two lines that can
be combined into one if the Width tolerance and Shift Tolerance are adjusted accordingly. Also, the
fact that the bridge width indicator is not centered on the line is a sure giveaway that there is more
than one line present.
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Three parameters on the Status bar control the size of gaps that are considered anomalies, and how
those gaps can be manipulated to make one line.

The value in the Size: field sets the maximum size of individual lines and gaps to consider as anomalies.

The Width Tolerance lets the tool compare gap sizes. If the gap sizes are the same, plus or minus the
Width Tolerance, then the gaps can be considered bridges in the new line.

The Shift Tolerance lets the tool move the gaps by up to the specified amount along the line to try to
distribute them evenly so that they can be considered bridges.

The two parameters work together to let the tool make a bridged line out of a series of lines and
gaps when there is a slight discrepancy in the size of the gaps and their positions relative to the line
segments.

Clicking Parameters opens the Line-Gap to Bridge Parameters dialog box as shown below:

1501



13 ArtiosCAD

The Width Rounding Value rounds the size of the variously-sized gaps so they are exact fractions of
the unit system being used.

The Make All the Same Width checkbox and the Change All to Width field instruct the tool to change all
the gaps into bridges of the size specified.

The Keep Present Bridges checkbox instructs the tool to keep any defined bridges in the lines
contained in the line-gap sequence.

The lines and gaps must be all in the same layer and the lines must be of the same line type for this tool
to consider them anomalies.

Arc from Lines tool

 The Arc from Lines tool converts a chain of line segments approximating an arc into an arc.
The replacement arc’s end-points are the same as those of the beginning and ending line segments.

The Size: parameter sets the maximum size of the line segments to be considered anomalies.

Note:  This tool works with lines and arcs only. If the design contains beziers, you will be
prompted to convert them to arcs or to cancel the tool. If the beziers are contained within an
embedded design, they cannot be converted to arcs, and the Smooth Lines and Arc from Lines
tools will be disabled.

Shown below is a corrugated box with a cutout in its lid.
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Using the Arc from Lines tool reveals that the cutout in the lid is not what it appears to be:

Magnifying an anomaly and using the Measure tool reveals a series of small lines:
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Fixing the anomaly results in a single arc.

Smooth Lines tool

 The Smooth Lines tool converts a chain of small connected line segments into a line or arc
that best approximates the outline of the original lines. The chain of line segments must not branch or
intersect with any other lines, must be in the same layer, and must be of the same line type.

The Size: parameter controls the size of the line segments considered anomalies. The Smoothing
Limit: controls how far the new geometry will stray from the path of the original geometry.

Note:  This tool works with lines and arcs only. If the design contains beziers, you will be
prompted to convert them to arcs or to cancel the tool. If the beziers are contained within an
embedded design, they cannot be converted to arcs, and the Smooth Lines and Arc from Lines
tools will be disabled.

Shown below with endpoints on in View Mode is a piece of text that was converted to lines before being
imported into ArtiosCAD:
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Clicking the Smooth Lines tool results in the following anomalies being shown:

Making both the Size: and the Smoothing Limit: larger results in a more circular proposed fix:
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Finally, having reset the parameters to their initial values, selecting all the anomalies and fixing them
results in:

Designer’s Fix-It defaults

Designer’s Fix-It uses the Designer's Fix-It Defaults catalog. In it, you can set the defaults for all the tool
parameters.
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As with other defaults, double-click the entry to modify and change the values accordingly.

Dieboard Dropout Check

Dieboard Dropout Check on the Manufacturing menu checks for common errors that can cause
problems when you manufacture the dieboard:

• Areas with no bridges that will drop out of the dieboard
• Areas without enough bridges
• Areas with bridges that are too small.

It also checks for:

• Rules that meet on the same rule path having different pointages (if Check pointage is selected)
• Zero-length lines
• Double lines.

Note:  ArtiosCAD only checks dieboards, not stripping boards or other manufacturing tools.

When you do a check, ArtiosCAD displays the Dropout Check dialog box and highlights the first type of
error it finds.
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Change the parameters of the checks as desired. In the first row, the check is for if there is only one
bridge in an area, what the maximum distance between bridges should be, and the minimum size of the
bridges. In the second row, the check is the same for when there is more than one bridge in an area.
Once you have changed the parameters, click Refresh to re-run the checks and update the display.

When you click a type of error in the list, ArtiosCAD highlights those errors in the workspace.

Type of error Example

Area with no bridges that will drop out

Area with only one bridge

Two different areas joined by one bridge that will
drop out
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Type of error Example

A long path without a bridge

Small bridges

To show more than one error type at once, hold down SHIFT and click the desired error types in the
list.

These checks are also run when you make an Output of the Designs layer or Rule path layer with
bridges on. Any errors appear in the Output Processing Errors dialog box.

Note:  Set the defaults for this feature in Startup Defaults > Dropout Check Options.
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Rubbering

Introduction to rubbering

Some diemakers put strips and pieces of rubber on the dieboard. The Rubber Design module provides
tools to create rubber pieces that follow the contours of the design lines in the layout. The Rubber
Design and Layout module enhances that further by eciently nesting the rubber pieces on rubber
sheets, which can then be output to a rubber-cutting device.

Different types of rubber are used for different purposes on the dieboard. Profile/strip rubber comes
pre-cut in strips to be placed by hand so it is generally not included in Outputs. Other types of rubber
are cut out of larger sheets. These modules are designed to work with the types of rubber cut out of
the larger sheets, but you can also place profile/strip rubber on the dieboard so that the places for
profile/strip rubber are indicated when the dieboard is plotted.

Both of these modules are options which must be purchased.

Generic special rule and zero pointage rule are ignored; generic cut/crease is treated as a crease.
Change generic special rule to specific special rule and set a pointage for all rule before using any
rubbering tools.

ArtiosCAD includes a sensible example table of rubber types, example rubber parameter sets, and
example rubber Outputs, but you should review them and modify them to fit your needs before using
the Rubbering features for production. See the Defaults chapter for more information.

Rubber workflow overview

A general Rubbering workflow could be as follows:

1. Create a manufacturing workspace, perform double knife removal, and save the workspace.
2. Add stripping rules (also called breaker knives) where appropriate, both on the exterior and interior

of the designs. If waste areas are large and Make Splits is checked in the parameter set, ArtiosCAD
creates pseudo temporary stripping rules to break up large pieces of rubber for easier manufacture.
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3.
 Click Rubber area on the Rubbering toolbar.

4. Click Recalculate all on the Status bar. ArtiosCAD adds rubber to the layout according to the values
in the Rubber parameter set selected in the Manufacturing parameter set. Different types of rubber
have different colors.

5. Use the manual edit tools to refine the rubber layout, adding joins, splits, and fills where necessary.
Shown below is the result of a Recalculate All before editing.
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The same area after editing:

6.
 Once you have adjusted the rubber as desired, use the Layout Rubber tool to nest it together

on rubber sheets. (This requires the optional Rubber Design and Layout module.)

7. Next, make an Output. There are many example Reports in File > Outputs > Artios > Rubber. To
output the rubber sheets themselves to HPGL files for use by a rubber cutter, use File > Outputs >
Artios > Rubber > Rubber sheet output. Each tile of this Output is an individual rubber sheet.

8. Finally, save and close the workspace, and move on to the next task.

Rubber tools

The Rubber tools are on two toolbars, the Rubbering toolbar and the Rubber view options toolbar. The
tools on the Rubbering toolbar require the Rubber Design license, while the tools on the Rubber view
options toolbar can be used by anyone with a Connection license.

Shown below are the Rubbering toolbar with its fly-outs expanded, and the Rubber view options toolbar
beneath it, along with a description of each tool’s function. Tools with more complex workflows are
further described in their own sections after the overview.
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Table: Rubbering tools overview

Tool Name Description

Rubber Area Automatically applies rubber to the lines in the area where you
click, or rubbers the entire layout by clicking Recalculate all on
the Status bar.

Repeat Rubber Element Repeats the last rubber element made in the area where you
click.

Delete All Rubber Deletes the die rubber, rubber sheet layouts, and top plastic
cover depending on the items you select in the Delete All
Rubber dialog box.

Delete Rubber Area Deletes the rubber in the area where you click.

Select Rubber Selects the piece of rubber under the cursor. Hold down CTRL
while clicking to select more than one piece at a time.

Split Rubber Splits a piece of rubber where you click.

Join Rubber Joins two pieces of rubber when you click near a split. If the
two pieces of rubber are different types, click the piece of
rubber whose type you want to keep.

Move Rubber Split Move a rubber split to the point you click.

Trim Rubber Trims a piece of rubber against another or against a counter.

Add Rubber Creates or adds to existing rubber using a loop of design lines.

Subtract Rubber Subtracts an area of looped design lines from existing rubber.

Fill Rubber Area Fills a small area formed by looped design lines with rubber. Not
for use with large areas; use Rubber Area for those.

Add Separator Adds a separator between the edge of the rubber and the rule.

Remove Separator Removes a separator from rubber where you click.

Move Separator (on fly-
out toolbar)

Moves a separator to where you click.

Add Open-out Adds a cut in the rubber so that it can be spread flat on the
sheet for easier cutting.
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Tool Name Description

Delete Open-Out (on fly-
out toolbar)

Deletes the open-out cut where you click.

Subtract Bolt Holes Removes areas of rubber covering bolt holes in the dieboard.

Update Plastic Cover Updates the plastic cover to match changes in the slot rubber.
Use this tool if you change the slot rubber after already having
created the plastic cover with the Rubber Area tool. Click
... on the Status bar to adjust the cover parameters or click
Recalculate All to completely regenerate the cover.

Group Rubber Groups selected adjacent rubber or plastic cover pieces
together so that they are nested on the sheet as a group. This
allows easier finding of pieces that go near each other on the
dieboard.

Ungroup Rubber (on fly-
out toolbar)

Ungroups rubber or plastic cover pieces.

Layout Rubber Creates nested sheets for some or all rubber types. Requires
optional Rubber Design and Layout module.

Highlight Rubber with
Repeat

Shows matching pieces of rubber on the dieboard and on the
sheet for easy identification and placement assistance.

List Rubber Elements Opens a dialog box listing the rubber elements in which you can
click entries and have them highlighted in the layout and sheet
(if available).

Rubber View Options Sets options for the view such as fill, color by type or by
number, show element numbers, and so forth.

In addition to the tools listed above, other tools are particularly useful for working with rubber.

Table: Other tools useful for rubbering

Tool Name Purpose

Delete Element (or the DEL
key on the keyboard)

Deletes pieces of rubber selected with a Select tool.

Merge Lines Straight Adjusts the rubber shapes as needed and auto-repeats.

Merge Lines Arc Adjusts the rubber shapes as needed and auto-repeats.

Merge Lines to
Intersection

Adjusts the rubber shapes as needed and auto-repeats.
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Tool Name Purpose

Stretch Point Adjusts the rubber shapes as needed and auto-repeats.

Stretch by Polygon Adjusts the rubber shapes as needed and auto-repeats.

Line tools Creates custom-shaped looped design lines that then can be
used with Add Rubber or Subtract Rubber.

Auto-Repeat Controls if manual changes are repeated in congruent
geometry.

Rubber Area tool

 The Rubber Area tool automatically adds or updates rubber in the area in which you click after
activating the tool. If the Rule Path layer has rules in it, the rubber is applied to those rules; otherwise,
the rubber is applied to lines in the Designs, Dieboard, and Stripping Rules layers. When the tool
starts, it turns on the Rubber, Designs, Dieboard, and Stripping Rules layers, and the Status bar
includes the following controls:

The ... button leads to the Rubber Parameters dialog box, which lets you set or change all the values in
the Rubber parameter set associated with the parameter set for this layout.
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For more information about setting these values, refer to the Defaults chapter.

Repeat Rubber Element tool

 The Repeat Rubber Element tool repeats the selected pieces of rubber in congruent locations
when Auto-Repeat is turned off.

Shown below is a layout with rubber created using the Rubber Area tool and Auto-Repeat turned off.

To use the tool, do the following:

1.
 Select the pieces of rubber to repeat, either individually or by a marquee selection.

2.
 Click Repeat Rubber Element.

3. ArtiosCAD creates rubber in congruent areas.
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Split Rubber tool

 The Split Rubber tool splits a piece of rubber perpendicularly if its sides are parallel; otherwise,
the split is roughly perpendicular, snapping horizontally or vertically if the Horizontal/Vertical
checkbox is checked on the Status bar. The width of the split is set by the value in the Split Width: field
on the Status bar. Shown below is when the Horizontal/Vertical checkbox is selected.

When the Horizontal/Vertical checkbox is not selected, the direction of the split is perpendicular to
the side of the rubber closest to the cursor:

The split position snaps to corners, midpoints, and bridges, and also to construction lines in the Die
rubber layer.

After splitting a piece of rubber, if appropriate, the smaller piece is changed to the type of rubber type
used in narrow areas.

Add Open-out tool

 The Add Open-out tool creates a cut in a corner of a piece of rubber so that it may be unfolded
flat on the rubber sheet for less waste, and to accommodate rubber-cutting machines that can make a
bevel in one direction only. To use this tool, activate it and then click in the corner of a piece of rubber.
Shown below is a rubber layout with no open-outs and its corresponding rubber sheet.
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After adding open-outs to the corners of the U-shaped pieces of rubber in the four flaps, the
regenerated rubber sheet looks like this. Note the open-outs in the layout.

Subtract Bolt Holes tool

 The Subtract Bolt Holes tool removes the areas of rubber that cover die bolt holes, die registration
holes, and laser positioning holes in the die. The parameter set may be set to remove these areas
automatically (but this affects auto-repeat); it is when that option is not selected that this tool
becomes necessary.

To use this tool, activate it, enter the desired offsets in the Subtract Bolt Holes dialog box, and click
OK. The Subtract Bolt Holes dialog box will show if rubber pieces need changing or not as shown below.

Often the bolt holes are far away enough from the rubber so that this tool does nothing.
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Layout Rubber tool

 The Layout Rubber tool eciently nests the rubber elements together on sheets that can then
be output to files for a rubber-cutting machine. Note that this tool requires a license which must be
purchased. When activated, the tool opens the Make Rubber Layout dialog box, shown below in its
initial state before a layout has been made.

Each type of rubber used in the layout (except for premade strip/profile rubber) has its own sheet
created, and correspondingly has its own tab in the Make Rubber Layout dialog box.

Trim is the distance from the edge of the rubber sheet to the edges of the rubber elements, and Gutter
is the distance between each rubber element.

Some rubber cutters have more than one cutting head so that more than one sheet of rubber can be
cut at a time. In this case, specify the number of heads in the Heads drop-down list box. If you specify
two or more heads when making rubber sheet layouts, this reduces the number of copies output of
each piece. For example, if there are 11 copies of a piece, ArtiosCAD might place five copies on a sheet
cut twice and one on a sheet cut once. The sheets that should be cut twice are labeled x2 both in the
rubber sheets layer (at the top left of the sheet) and in the Output.

ArtiosCAD automatically groups pieces of rubber on the sheets based on their shapes. The five choices
in the Grouping group control how the instances of each rubber element are grouped together on the
sheets. Manual means that the grouping will be taken from the values set in the List Rubber Elements
dialog box. None means that each item will be considered its own group. Low means only straight
items will be grouped together. Medium will do an intermediate level of grouping, but High will group
together as many instances of the element as possible. These controls are meant to let you find the
balance between making pieces easy to find and wasting the least rubber.

You can define up to six sheets of scrap rubber to use instead of fresh sheets. To add a scrap sheet,
click Insert in the Current Scrap group, enter its dimensions, and check the Use checkbox. Click
Delete to delete the selected piece of scrap from the list.

Increasing the value in the Nesting tries: field causes ArtiosCAD to try more nests, but this takes more
time.
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Fill from left tells ArtiosCAD to fill the sheet in a left-to-right sequence. When this is off (the default),
the sheet is filled from the bottom to the top.

Allow Rotate allows the nesting process to use angles other than 180 when trying potential nests.

Make This generates a sheet of rubber for the current tab.

Make All generates sheets of nested pieces of rubber according to their types. More than one sheet per
type is generated if necessary.

Clicking OK makes nothing and returns to ArtiosCAD.

Once you have made a rubber sheet layout, ArtiosCAD populates the Eciency tab of the Make Rubber
Layout dialog box as shown below. For each sheet of rubber, ArtiosCAD lists the sheet's rubber type
name, the dimensions of a rectangle containing all nested pieces (always including one full sheet
dimension), the percentage of the area in the rectangle that is actually used, and the size of the
rectangular sheet that is remaining when the nested rectangle is removed.

List Rubber Elements tool

 The List Rubber Elements tool opens a dialog box in which you can select rubber elements and
see them highlighted on the dieboard and rubber sheets (if they have been generated). Some elements
of the dialog box are unavailable without the Rubber Design and Layout option.
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Shown below is the Rubber Elements dialog box in greater detail.

The left side of the dialog box shows the list of all the rubber elements, ordered by rubber type and then
element size. The Die column lists the number of pieces on the dieboard, while the Layout column lists
the number of pieces in the rubber sheet layout (these numbers are the same initially by default). If a
piece of rubber does not fit on the sheet, it is not shown on-screen and has a 0 in the Layout column.
The Group column indicates the maximum number of groups containing this element in the sheet
layout (with 1 being no groups).

The down-arrow chevron expands the dialog box to the bottom of the monitor, and the up-arrow
chevron it changes to when clicked shrinks the dialog back to its previous size.

In the Layout group, the value listed shows how many instances of the current selection are in
the sheet layout. You can change this number to make more or less of the current selection if you
regenerate the layout. This is so that if you need to produce a few more pieces of a delicate item, you
can do so easily. On die resets the number of elements in the layout to the number of elements on
the dieboard, while Zero all resets all the elements on the sheet to zero. (You would then select the
few pieces to make again, set their numbers in the Layout field to the desired numbers, click OK, and
regenerate the layout with the Layout Rubber tool.)

For example, suppose you need 20 more of these, of which you currently have 3:

You would increase the number in the Layout field to 23, regenerate the Yellow Slot rubber sheet, and
arrive at the layout shown below:
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The Groups of: group controls how many instances of the same rubber piece are placed near each
other on the sheet. For example, if there are 12 instances of the same element, the Group column is
initially set to 12 so that they are all together on the sheet, but by changing the Groups of: value to
2 and regenerating the sheet, you would have up to 6 groups of 2 scattered throughout the sheet.
However, more than 2 pieces may still be grouped near each other if that results in greater eciency.

When you change the number in the Groups of: field, the Grouping option button in the Make Rubber
Layout dialog box changes to Manual so that your change to the layout method is preserved if you
regenerate the rubber sheet layout.

Zoom in zooms in on the selected rubber element so that it fills the window. Deselecting it performs a
Scale to Fit to show the entire workspace.

Making manual changes to a rubber layout

To design your own rubber shapes, draw them in the Die Rubber layer and then use the Add Rubber tool
as shown in the steps below.

1. Change to the Die Rubber layer of the layout, turn on the appropriate toolbars, and draw the desired
geometry. Make sure to draw a loop of lines.

2.
 Click Add Rubber, select the just-drawn geometry either by clicking it or by using a marquee

selection, and set the Status bar options as desired. If the lines do not form a loop, OK remains
unavailable. Click OK when it is available.

3. The geometry is changed to a piece of rubber and is auto-repeated in congruent areas if Auto-
Repeat is enabled.

To add to an already-existing piece of rubber, do the following:

1. Change to the Die Rubber layer of the layout, turn on the appropriate toolbars, and create a loop of
lines that overlaps the desired piece of rubber.
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2.
 Click Add Rubber, select the geometry either by clicking it or by using a marquee selection,

and set the Status bar options as desired. Click OK.
3. ArtiosCAD adds rubber to the area within the looped lines that did not have rubber before, and these

changes are auto-repeated to congruent areas if Auto-Repeat is enabled.

To remove rubber, use the Subtract Rubber tool in the same way as the Add Rubber tool.

1. Change to the Die Rubber layer of the layout, turn on the appropriate toolbars, and create a loop of
lines in the shape of the rubber to remove.
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2.
 Click Subtract Rubber, select the geometry either by clicking it or by using a marquee

selection, and set the Status bar options as desired. Click OK.
3. ArtiosCAD removes rubber from the area within the looped lines that had rubber before, and these

changes are auto-repeated to congruent areas if Auto-Repeat is enabled.

To make small changes to the rubber layout, use the Select, Move, and Rotate tools. However, avoid
using the Copy tools with rubber elements as this could lead to unpredictable results.

Use the tools on the Adjust and Adjust Outlines toolbars to adjust the outline of rubber pieces. Merge
Lines Straight, Merge Lines into Arc, and Merge Lines to Intersection can all adjust the outlines of
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rubber pieces in two to three clicks. Stretch Point and Stretch by Polygon are also handy. These tools
work with Auto-Repeat if it is enabled.

 Merge Lines Straight straightens a series of lines, and when used with rubber, changes the shape
of a piece of rubber. Activate the tool and click lines 1 and 2 to produce the second picture.

 Merge Lines Arc works similarly; activate the tool, indicate the lines to merge, and then set the
radius of the arc:
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The rest of the previously-mentioned tools work the same way and all reapply separators.

Changing rubber properties

To change the type of a piece of rubber or its separator type, do the following:

1.
 Click the Select Rubber tool and double-click the piece of rubber to change; or, to change

more than one piece of rubber at once, hold down CTRL while selecting pieces and then press ALT-
Enter.

2. The Properties dialog box appears as shown below.

3. In the dialog box, use the Rubber type: drop-down list box to change the type of the rubber. Update
offset is selected by default so that ArtiosCAD updates the offsets since they may differ between
types of rubber. In the Separator type group, change the shape and size of the separators as
desired. Slot and strip/profile rubber pieces do not have separators made for them. Changes made
in this dialog box are immediately applied to the layout.

4. Click OK to resume working with the layout.
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Blanking

Blanking is the process of removing the cartons/boxes (called blanks) from the sheet as it travels
through the die press. Blocks and pins on the upper board push the blanks through holes in the lower
board into stacks on the pallet. The rest of the sheet moves out of the press as waste. Having the press
separate the blanks from the waste reduces the time needed to complete jobs and also reduces the
risk of error.

Before using the tools described in this section, you should have a thorough understanding of your
company's best practices for blanking. If you are unfamiliar with blanking, good places to start learning
are in the documentation for your press and at your press manufacturer's website.

Blanking defaults are contained in the Blanking parameter sets. To review or change them, click
Options > Defaults > Blanking machine parameter sets and Blanking parameter sets.

Blanking tools list

Turning on the Blanking Toolbar
Before you can use the blanking tools for the first time, use the Toolbar Master Control for
Manufacturing (View > ArtiosCAD Toolbars to turn on the Blanking toolbar. It will appear as a floating
toolbar the first time you turn it on; after that, dock it or leave it floating as desired.
 

 

Tools on the Blanking Toolbar

Button Function

Add Grid Bar

Include Strip Rules

Generate Blanking Tools

Adjust Blank Holes

Adjust Pushers

Add Non-stop Swords

Add Photocells
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Button Function

Add Jogger Guides

Add Support Bars

Add Air Holes

Add Blanker Pusher Pins

Add Hardware

Add Tie-bolts

Add Pressers

Delete Blanking

Blanking Elements

Use the blanking tools in ArtiosCAD to create these blanking elements. If no blanking layers already
exist in a manufacturing workspace, using these tools creates them.

The context menu commands are available when you right-click an element. The validation describes
what ArtiosCAD checks when placing an element. Some blanking elements have multiple shapes that
may differ from those shown here.

Blanking Element Purpose Context menu
commands

Validation

Frame
 

 

Holds the
lower tool in
the press

Delete None

Blank holes
 

Separates
the blanks
from the
sheet.

Delete

Smooth (works
on point blends)

None
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Blanking Element Purpose Context menu
commands

Validation

 

Unsmooth
(works on corner
and slot bends)

Retack

Smooth and
Unsmooth use
the values from
the Blanking
Parameter Sets
dialog box in
the Generate
Blanking Tools
tool

Grid bars
 

 

Separates
the blanks
from the
sheet

Delete

Repeat

Trim/Extend
(uses values
from the
Blanking
Parameter Sets
dialog box in the
Add Grid Bar
tool)

Must not overlap the
center line of any other
grid bar

Note:

This validation
means that
grid bars do
not repeat
when Trim
to grid is
turned off in
the Blanking
Parameter
Sets dialog
box.

Non-stop swords Supports
the blanks
as the stack
underneath
is removed
from the
press

Delete Must not overlap any
joggers or other non-
stop swords

Photocells

 

 

Detects
when the
stack of
blanks is
too high and
needs to be
removed
from the
press

Delete Optionally must be
within press limits

Must not overlap
any joggers or other
photocells
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Blanking Element Purpose Context menu
commands

Validation

Joggers
 

 

Guides the
blanks to
the correct
position on
the pallet

Delete Must not overlap any
other joggers

Must not overlap any
lines in the lower board

Component active
part lines must not
overlap photocells,
support bars, or non-
stop swords

Support bars
 

 

Reinforces
the lower
tool

Delete Must not overlap
joggers

Should not overlap any
other support bars

Pusher edge
 

 

The outer
edge of a
pusher

Delete

Smooth ( works
on point blends)

Unsmooth
(works on corner
and slot bends)

Retack

Smooth and
Unsmooth use
the values from
the Blanking
Parameter Set
dialog box for
the Generate
Blanking Tools
tool.

None

Blanker pusher pins, also called stand-off
pins (SOP)
 

 

Attaches the
pushers to
the upper
board

Delete Must not overlap other
blanker pusher pins,
pusher ID text items,
pusher edges, tie-
bolts, or pusher air
holes
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Blanking Element Purpose Context menu
commands

Validation

Pusher ID text Labels each
pusher
for easier
assembly

Delete Must not overlap any
blanker pusher pins or
pusher edges

Pusher board air hole and Upper blanking
board air hole

Reduces
suction
caused
by board
movement
in the press

Delete Must not overlap any
blanker pusher pins,
pusher ID text items, or
any pusher edges

Pressers
 

 

Holds the
sheet waste
as the the
blanks are
separated

Delete Must not be in optional
machine-restricted
zones, or overlap other
pressers or upper
board air holes

Hardware Varies. Grid
clamps
attach the
grid bars to
the frame.
Plastic film
acts as
joggers.

Delete None

Tie-bolt Attaches the
upper board
to the press

Delete Must be within the
upper board

Must not overlap any
other tie-bolt hole,
upper board air hole, or
blanker pusher pin in
the upper board

Lower blanker board Guides the
blanks into
the proper
position

Delete

Properties
dialog box with
Alignment

None

1531



13 ArtiosCAD

Blanking Element Purpose Context menu
commands

Validation

Method and
Wood Corners
tabs

Upper blanker board Pushes
the blanks
through the
lower board

Delete

Properties
dialog box with
Alignment
Method and
Wood Corners
tabs

None

Blanking Congruency

Congruency is the property of two or more elements being identical except for physical placement.
For blanking, ArtiosCAD uses contour congruency and layout congruency to determine where to put
elements when Auto-Repeat is enabled.

Note:

Many factors affect congruency in unanticipated ways. Use caution when Auto-Repeat is
enabled and always check that elements are placed correctly before performing an Output.
Each element created with Auto-Repeat is checked for validity (except for those created with
the Add Hardware tool) but in some cases the checks are not as effective as your experienced
eye.

ArtiosCAD determines layout congruency based on the position of an element relative to the layout. If
an element is contained within a blank, that element is repeated within all similar blanks. If an element
crosses blank boundaries, it is repeated where that same group of blanks appears. For those imported
workspaces where manufacturing components are actually subprograms - treated as if they were part
of the manufacturing workspace but truly are not - blanking Auto-Repeat will not work correctly.

Two or more elements have contour congruency if they can be transformed into each other by
mirroring or rotation. When Auto-Repeat is enabled, if a change is made to an element, ArtiosCAD
applies that change to all other elements having contour congruency.

The table below lists the blanking tools and their congruency method.

Layout Congruency Contour Congruency

Add Grid Bar Generate Blanking Tools

Add Non-stop Swords* Adjust Blank Holes

Add Support Bars* Adjust Pusher
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Layout Congruency Contour Congruency

Add Jogger Guides Add Blanker Pusher Pins

Add Air Hole Smooth/Blend Contour

Add Hardware Edit Contour

Add Presser

*does not support mirrored blanks

Frame Creation

Most of the blanking tools require the frame to exist, so if the frame does not exist, ArtiosCAD prompts
you to create it before starting the tool you clicked.

ArtiosCAD bases the frame size on the Frame Size parameter in the Frame catalog of a blanking
parameter set.
 

 

It can be:

• Maximum size, which takes the frame size from the Vertical Pieces > Length, Horizontal Pieces
> Maximum length, and Max Size Restrictions fields defined in the Frame catalog of the blanking
machine parameter set. Min to inner specifies the positioning of the lower horizontal bar when
using either Maximum size or Suggested size.
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Note that you can also control the size of the horizontal pieces with Trim to frame.

• Suggested size, which uses the Height and Width field values you specify on the Frame Size tab of
the blanking parameter set.

• By clearance, which calculates the proper size from the clearances you supply in the Frame
Allowances dialog box that appears when you create the frame.
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ArtiosCAD calculates the allowances on the left using the values in the Formula and Parameters
group on the right, but you can manually enter any desired allowances in the appropriate fields.

In the Width and Height groups, if you deselect a Single-cut checkbox, the #up field becomes
unavailable and ArtiosCAD computes the allowances as if the number were 1.

When using By clearance, follow the recommendations of your press manufacturer for the values to
supply for clearances: Separator, Jogger, and Extra. One leading press manufacturer recommends
adding a half millimeter plus the thickness of the separator for every blank for single-cut layouts.
For double-cut layouts, the layout is treated as one large blank since the blanks are not connected.

For Standard formula type layouts, ArtiosCAD calculates the clearances based on the information
you supply and creates the blanking frame accordingly. For Custom formula type layouts, the
controls change to specifying a library function to calculate the left, right, top, and bottom
clearances.
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An example of a library function to calculate a clearance is:

param &nup &jog &sep &xtra  
! In:  
! &nup = number of designs  
! &jog = the jogger clearance in current units 
! &sep = the separator clearance in current units 
! &xtra = the extra clearance in current units 
!  
! Returns the allowance  
dset &ret &jog+&xtra+((&nup-1)*&sep)/2

The library function for the separator clearance on the BSI Grid type of blanking tool set is
bsi_blk_clearance.txt and contains:

param &nup &jog &sep &xtra
! In:
!   &nup = number of designs
!   &jog = the jogger clearance in current units
!   &sep = the separator clearance in current units
!   &xtra = the extra clearance in current units
!
! Returns the allowance
if (&nup=1)
dset &ret &jog+&nup*(&xtra+&sep)else 
dset &ret &jog+&nup*(&xtra+&sep)/2
endif

Blanking Example Workflow: Lower Grid

A common blanking method is using a grid as the lower blanking board. Here is one way to make a grid.

1. Design a layout in ArtiosCAD.
2. If desired, create stripping tools for the layout. Use Include Strip Rules to tell ArtiosCAD which

stripping rules to respect when creating the blanking tools.
 

1536



13ArtiosCAD

 
3.

 Click Add Grid Bar on the Blanking toolbar.
4. Choose a blanking machine parameter set in the Choose Blanking Machine Parameters dialog box

and click OK.
 

 
5. Choose a blanking parameter set in the Choose Blanking Parameter Set dialog box and click OK. For

this example, choose Grid.
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6. In the Frame Clearance dialog box, change any values as desired and click OK.

 

 
ArtiosCAD creates the grid frame, which is represented as double green lines around the layout.
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7.

  Use Add Grid Bar, Add Jogger Guides, and Add Hardware to construct the grid. More
information about how to use them is later in this guide.
 

 
8.

  Use Add Non-Stop Swords and Add Photocells to add those parts.
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9.

 Use Generate Blanking Tools to create the pushers and the upper board.
 

 
10.

 Use Adjust Pushers to adjust the offsets from the pusher edge to the grid and/or design edge.
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11.

  Finish the upper board by using Add Tie-bolts and Add Pressers to add the pressers.
 

 
12. Save the workspace and run a blanking Output such as the Blanking Parts Report shown below, or

one of the grid bar reports.
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Blanking Example Workflow: Lower Board

Another common blanking method is using a lower board with holes in it for the blanks to be pushed
through by the upper board. Here is one way to make a lower board blanking tooling set.

1. Design a layout in ArtiosCAD.
2. If desired, create stripping tools for the layout. Use Include Strip Rules to tell ArtiosCAD which

stripping rules to respect when creating the blanking tools.
 

 
3.

 Click Generate Blanking Tools on the Blanking toolbar.
4. Choose a blanking machine parameter set and click OK.
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5. In the Choose Blanking Parameter Set dialog box, depending on if your layout is double-cut (the

designs have a gutter between them) or single cut (the designs share common knives on their
exteriors), choose either Flat top (double knife) or Flat top (knife to knife) and click OK.
 

 
6. In the Frame Clearance dialog box, change any values as desired and click OK.
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7. Make sure all four mode selection buttons are selected and click Recalculate All on the Status bar.

ArtiosCAD automatically generates the frame, holes, and pushers for the layout.
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8.

  Use Add Jogger Guide and Add Hardware to add more hardware. More information about
how to use them is later in this guide.
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9.
  Use Add Non-Stop Swords and Add Photocells to add those parts.

 

 
10.

 If desired, use Adjust Pushers to adjust the offsets from the pusher edge to the hole and/or
design edge.
 

 
11.

  Finish the upper board by using Add Tie-bolts and Add Pressers to add the pressers.
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12. Save the workspace and run a blanking Output such as a Blanking Parts Report.

Blanking Tools Reference

This section explains how to use each tool on the Blanking toolbar.

Add Grid Bar tool

 The Add Grid Bar tool lets you add grid bars when constructing a grid-type lower blanker board.
Grid bars separate the blanks as they are pushed through the grid. Use this tool to follow the contours
of a blank and ArtiosCAD will construct the grid bar to match.

When this tool is active, the Status bar looks as follows.
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The Width, Offset, and Bend radius fields all control the dimensions of the grid bar.

The Properties (...) button opens the Blanking parameter sets dialog box.
 

 

These parameters are explained by the following diagram, with the green lines being the frame edge
and the triple black lines being a blanking grid bar (with Fills and strokes in the Styles group of the View
mode turned off and End points turned on). The rectangle with the point is the blank.

Note:

These parameters are saved with the manufacturing workspace.

Automatically trim/extend on finish trims or extends the grid bar so that it meets the frame when you
click Finish on the Status bar, and Trim to grid trims the grid bars against each other.
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In the diagram above, the grid bars are not filled and the end points are visible. To see just the edges of
the grid bars, turn off Fills and strokes in the Graphics section of the View Mode; to see the edges and
middle of the grid bars, turn off Fills and strokes in the Styles section of the View Mode but leave it on
in the Graphics section.

 Finish extends the grid bar to the closest frame edge if Automatically trim/extend on finish
is enabled in the Grid Parameters dialog box, and if Auto-Repeat is enabled, repeats the grid bar to
congruent sections of the layout. ArtiosCAD restarts the tool so you can create a new grid bar.

 Copy Pickup/Putdown mode lets you copy a grid bar as
you create it and optionally mirror it horizontally or vertically as desired.

To create a new grid bar, do the following:

1.
 In a layout, click Add Grid Bar on the Blanking toolbar. If no blanking has been done so far,

ArtiosCAD prompts you to select a machine and a parameter set, and creates the blanking frame.
2. Click the line in the blank closest to the grid frame against which the grid bar is offset. Drag will

appear from the grid frame allowing you to position the grid bar either on top of the line or offset
from it depending on where you position the cursor - either to the left or right of the line. Hold down
CTRL to set the offset halfway between the line and the cursor as indicated by the drag. To center a
grid bar between two points (instead of offsetting it from a line), click those two points. The cursor
has a circle with a slash through it when you are not close enough to a line.

3. Click the next lines in the blank to follow, using the position of the cursor to determine the offset,
or click a point to offset the segment halfway between the point and the line. Click the line itself
to center the grid bar on the line. Use Copy Pickup/Putdown mode to aid construction where
possible. Copy Pickup/Putdown mode is available as you are constructing grid bars. First click the
button on the Status bar, then select the grid segment to copy, and then click the pick-up point and
the put-down point.
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4. Continue constructing grid segments, using Undo and Redo to correct mistakes.
5.

 When you have rounded the last bend before the frame, click Finish to extend the grid bar to
the edge and Auto-Repeat it to congruent areas if Auto-Repeat is enabled.

6. Create the other grid bars in the same way. The example below was created by following the blank
lines horizontally but using the two points on adjoining blanks to construct the vertical segments.
 

 

To see which end of a grid bar is the start and which is the end, turn on Direction in the View Mode.

To restart a grid bar, click the edge of the end of the bar.

To reverse the direction of a bar and recreate it, click the edge of it near its start and click Yes.
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Include Strip Rules tool

 The Include Strip Rules tool allows you to mark stripping rules to be respected during blanking tool
generation to result in merged blanks. It indicates how double-knife blanks should be blanked together
by having you select the stripping rules that join their outlines. It can modify the lower hole and pusher
contour, or just the lower hole. It works only with stripping rules, not carrier rules or scrap knives.

When you activate the tool, ArtiosCAD:

• Shows all lines as gray except for stripping rules
• Changes the current layer to Lower Blanker
• Turns off the other blanker layers
• Turns off the Sheet layer
• Turns on the Design layer
• Turns on the Stripping layer
• Deletes any existing respected stripping rules that do not overlap a stripping rule and displays the

remaining ones (in case you have made changes to the stripping rules since last running the tool)

This tool has the following controls on the Status bar:
 

 
Clear all clears all stripping rules from being included in blanking calculations, and Lower only only
merges the holes in the lower board, and does not merge the pushers.

Note:  If Lower only is checked, checking Merged pusher on the Pusher Edge tab when
generating blanking tools has no effect.

If you did not use this tool, ArtiosCAD would generate blanking tools like the ones shown below this
layout:
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To use this tool, do the following:

1. Create the layout as desired and add stripping rules between stations to make a merged outline.
2.

 Click Include Strip Rule.
3. Hover over a stripping rule to respect for blanking. The cursor changes to an arrow with a plus sign.
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4. Click the rule. It turns green.

Note:  To select or deselect many rules at once, hover away from a rule, and click and drag
to define a marquis selection. If congruency is on, any congruent lines outside the selection
window are also selected.
 

 

5. To revert a respected rule back to a normal stripping rule, click it again. The cursor will change to a
minus before you click.
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6. Repeat the process of selecting rules to respect.

After using this tool, generating the blanking tools should result in blanking tools similar to these:
 

 

Generate Blanking Tools tool

 Generate Blanking Tools is a one-click method to create blanking tools. It can create the frame,
generate blank holes in the lower board (if used), generate pushers, and so on depending on the
parameter set you choose. It does not create grid bars.

This tool has the following controls on the Status bar:
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Control Generates

The blank frame

The blank holes - creates blank holes and the lower board wood edge

The pusher contours - creates pushers and upper board wood edge

The pusher details

The initial states of these controls are determined by which layers contain anything or are turned
on. These controls are independent from each other; click the ones corresponding to the blanking
elements for ArtiosCAD to generate. Hold down CTRL to toggle the state of the other controls as you
click one.

Clicking the Properties button (...) opens the Blanking Parameter Sets dialog box whose contents are
based on the controls selected for generation on the Status bar.

Clicking Recalculate All generates the selected tools with the parameters from the Blanking
Parameter Sets dialog box. To generate the tools for just one blank, click inside the single design for
that blank.

Your Blanking Parameter Sets dialog box may not have the same tabs as the example shown below.
 

 

Set the allowances and clearances for the frame on the Frame Size tab:
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The frame allowances are relative to the layout size. Calc From Clearance opens the Frame Allowances
dialog box discussed in the Frame Creation section. When you close the Frame Allowances dialog box,
the values on the Frame Size tab are updated accordingly.

Clicking Maximum Size:

• sets Inside width and Inside height to their maximum values allowed by the machine

• leaves Bottom allowance unchanged

• resets the Top allowance to (Maximum height - layout height - Bottom allowance)

• recalculates the Left allowance and Right allowance to (Maximum width - layout width/2).

Set the positions and sizes for the frame pieces on the Frame Pieces tab.
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In the Bottom Position group, choose how to calculate the distance to the bottom of the frame - from
the bottom of the sheet or from the first knife. The location of the first knife is sometimes called P13.

Set the sizes of the frame pieces in the Vertical Pieces, Horizontal Pieces, and Max Size Restrictions
groups. Trim to frame lets you choose to trim the horizontal pieces to fit this frame or to keep them
full-size for use with other frames.

Set the parameters for the frame’s construction on the Frame Construction tab.
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If you will be using a BSI frame kit for this set of blanking tools, check Use frame kit. It is associated
with the Blanking machine parameter set and cannot be changed when you are generating the blanking
tools.

If you are not using a BSI fame kit and thus Use frame kit is not selected, choose the type of hardware
to use on the frame from the drop-down list boxes in the Hardware group. You can make your own
custom hardware as geometry macros and add them to the Blanking catalog in the Geometry Macro
catalog in Defaults.

If desired, choose the type of BSI mounting or scrap rails to use from the Mounting/scrap rails drop-
down list box. ArtiosCAD draws them as red rectangles with screw holes on top of the green frame
pieces. If you need to trim the stock rails, ArtiosCAD draws a line across the left one and shows the
dimension to which you must trim it (and the right one) for the job.

If you will be using lateral support bars, check Lateral support bars and specify the Overhang distance.

The fields on the Lower Holes tab control how the holes are made in the lower board (if applicable). The
Adjusted Offsets are available for all blanker types except Grid (no board).
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In the Blanker Type group, choose the type of blanking for the tool to perform. This should be pre-
selected from the parameter set.

In the Contour group, set the values for the paths in the layout which ArtiosCAD will follow to create
holes in the lower board.

In the Adjusted Offsets group, choose the type of lines that require adjusted offsets for their
corresponding hole contours. The preview picture shows each type of offset. Make sure to check Use
for each desired offset while it is selected, and adjust the size of the offset as needed in the Offset
field. ArtiosCAD marks each in-use offset with an asterisk in its name. You can specify adjusted offsets
for all blanker types.
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As the size of the lower board is determined from the frame size, not the layout, the only fields on the
Lower Board tab are for the allowances. The Left, Right, and Top allowances can be measured relative
to the inner frame, outer frame, or the bar extent. The Bottom allowance can be measured relative to
all of those and the bottom of the sheet. Each allowance defaults to the inner frame.
 

 

To adjust the lower board’s alignment method and corner shape, right-click its edge after it is created
and click Properties on the context menu.

The size of the upper board is based on the layout size, not the frame size. To adjust the upper board’s
alignment method and corner shape, right-click its edge after it is created and click Properties on
the context menu. On the Upper Board tab, adjust the size and allowances as desired. Alternately,
click Maximum size to make it as large as possible using the parameters from the Upper Board
Requirements tab.
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The Pusher Details and Pusher Edge tabs control the creation of the pushers on the upper board.

Settings for the air hole, blanker pusher pins, and pusher identification text are on the Pusher Details
tab as shown below.
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In the Air Hole group, set the options to control how ArtiosCAD makes the air holes in the pushers.
When checked, Merged hole creates one air hole per pusher; deselect it to create one air hole per
design. To make bars across large holes to reinforce them, check Reinforce large holes and set the
Maximum size of each sub-hole and the Bar thickness.

Note:  ArtiosCAD does not automatically place in the areas between non-merged air holes.

As with the frame, you can create your own blanker pusher pins as geometry macros and add them to
the Stand off pins sub-catalog in the Blanking catalog of geometry macros in Defaults.

The pusher ID text is either an S# or a P# where # is a number, S stands for station, and P stands for
pusher. The P# form indicates that there may be one or more other identical pushers. The S# form
uniquely identifies the pusher in the layout. For example, if you have a double-knife layout of one
design with Auto-Repeat enabled, then when you generate the pushers, all the pushers should have the
same P# ID text. If you then disable Auto-Repeat and make an adjustment to a pusher, then that pusher
will use the S# form.

The Pusher Edge tab controls how ArtiosCAD shapes the pushers. The options in Adjusted Insets work
the same as the Adjusted Offsets do on the Lower Holes tab - select an inset, check Use, and set the
inset in the field. Only insets with asterisks are used when ArtiosCAD generates the blanking tooling.

Note:  Merged pusher has no effect if the Lower only checkbox is on when using Include Strip
Rules.
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Once you have set the parameters on all the tabs as desired, click OK to return to using the tool.

To use this tool, do the following:

1. Create a layout in ArtiosCAD.
2.

 Click Generate Blanking Tools on the blanking toolbar.
3. Choose the machine and parameter set.
4. Set the frame parameters in the Frame Allowances dialog box and click OK.
5. On the Status bar, choose the items to generate.
6. Click the Properties button (...) to open the Blanking parameter sets dialog box. In it, review the

settings on each tab ArtiosCAD will use to generate the tools. Click OK when done.
7. Click Recalculate All on the Status bar.

Shown below is a set of blanking tools with everything generated.
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Adjust Blank Hole tool

 The Adjust Blank Holes tool on the Blanking toolbar allows you to adjust the shape of a blank hole
in the lower board. If Auto-Repeat is enabled, ArtiosCAD modifies all congruent blank holes.

When you click this tool, ArtiosCAD turns on the Blanker lower board layer, turns off the other blanking
layers, and puts an Offset drop-down list box on the Status bar:
 

 

You can either type a value or expression in the Offset field or choose a value from the drop-down list.
A positive number offsets the hole outside the blank; a negative number insets it inside the blank.
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From design is unavailable, but when it is checked, it indicates that the current offset of the line or arc
is the distance perpendicularly from the midpoint of the line to the design.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the lower blanking board.
2.

 Click Adjust Blank Holes.
3. On the Status bar, adjust the offset as desired.
4. Move the cursor close to the line to change. The drag will indicate the adjusted offset while the

number in the drag is the current offset. To change more than one line, hold down CTRL and drag to
the next connected line.

 

 

Note:

Only change one or two lines at a time as the adjustment’s start angle is set by the first line
you choose. Choosing more than two lines at a time may result in incorrect adjustments.

5. Click the line to change. To change more than one line at once, click the last line in the sequence.
6. ArtiosCAD adjusts the hole edge.

Adjust Pushers tool

 The Adjust Pushers tool changes the shape of the pushers on the upper board. When you click
this tool, ArtiosCAD makes the Blanker pushers layer active and turns off the other blanking layers.

This tool has the following controls on the Status bar:
 

 

Inset is the distance the current pusher edge is from the hole edge or grid bar. A positive value moves
the pusher edge further from the hole or grid; a negative value brings it closer. Any values you type in
this field will appear on the drop-down list for later use in this session.

From design is unavailable, but when it is checked, it indicates that the current offset of the line or arc
is the distance perpendicularly from the midpoint of the line to the design.
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To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Adjust Pusher.
3. On the Status bar, adjust the inset as desired.
4. Move the cursor close to the line to change. The drag will indicate the adjusted inset while the

number in the drag is the current inset. To change more than one line, hold down CTRL and drag to
the next connected line.
 

 

Note:

Only change one or two lines at a time as the adjustment’s start angle is set by the first line
you choose. Choosing more than two lines at a time may result in incorrect adjustments.

5. Click the line to change. To change more than one line at once, click the last line in the sequence.
6. ArtiosCAD adjusts the pusher edge.

Add Non-stop Swords tool

 The Add Non-stop Swords tool on the Blanking toolbar lets you indicate where the non-stop
swords will go on the press. They may not overlap other swords or joggers. When you click this tool,
ArtiosCAD turns on the Blanker frame layer and turns off the other blanking layers.

This tool has the following controls on the Status bar:
 

 

In the Non-stop sword drop-down list box, you can choose to add a machine-defined narrow sword, a
machine-defined wide sword, or a custom sword.

Clicking Properties (...) opens the Blanking parameter sets dialog box where you can set the availability,
number of prongs, and width of the swords.
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Click OK when you have set the values as desired.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Add Non-stop Swords on the Blanking toolbar.
3. Select a line or point from which to offset the leftmost sword. Cut lines display their points when

you place the cursor near them for easy placement, but you can select any design line. If you
select a line, ArtiosCAD prompts you for the offset for the sword, which you can set with drag or by
entering a value in the Offset field. If you select a point, ArtiosCAD prompts you for another point
or freehand coordinate (by holding down CTRL) and places the sword halfway between that and the
first point.
 

 
4. If Auto-Repeat is enabled, ArtiosCAD repeats the sword to congruent areas.
5. Continue adding swords as desired. The drag is green for valid positions and red for invalid

positions.

Add Photocells tool

 The Add Photocells tool lets you add photocells to the blanking tooling. Photocells signal the
press when the stack of blanks needs to be removed from the press to make room for new blanks
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to accumulate. Photocells must not overlap joggers or other photocells. When you click this tool,
ArtiosCAD turns on the Blanker frame layer and turns off the other blanking layers.

This tool has the following controls on the Status bar:
 

 

In the Width field, set the width of the photocell beam. This field is preset from the values in the
Blanking parameter sets dialog box opened by the Properties (...) button. Use the drag to set the Offset
or enter a value in the field manually. The drag is green for valid positions and red for invalid positions.

Shown below is the Blanking parameter sets dialog box.
 

 

The Maximum Distance and Minimum Distance fields control the range of placement for the
photocells. The checkboxes before them enable their limits; for example, to be able to set the photocell
anywhere in the frame after the minimum distance, deselect Maximum Distance.

Click OK when you have set the values as desired.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Add Photocells on the blanking toolbar.
3. If desired, change the width of the photocell in the Width field.
4. Use the drag to set the offset for the photocell’s position, or enter it manually in the Offset field.
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5. Continue adding photocells as desired. The drag is green for valid positions and red for invalid
positions.

Add Jogger Guides tool

 The Add Jogger Guides tool lets you position joggers, the hardware that helps guide the blanks as
they are separated from the sheet. When you click this tool, ArtiosCAD turns on the Blanker frame layer
and turns off the other blanking layers.

Joggers must not overlap other joggers, photocells, or non-stop swords. ArtiosCAD checks three parts
of the jogger for interference: below the board (the active part), at the board level, and above the board.

This tool has the following controls on the Status bar:
 

 

Select the jogger to use from the Jogger drop-down list box. In the Offset drop-down list box, select 0,
Midway between 2pts, or enter a custom value. Check Set alignment so that when you click to add a
jogger, you first place the jogger on a line and then click a point with which to align it.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Add Jogger Guides on the Blanking toolbar.
3. Choose the jogger and offset from the drop-down list boxes on the Status bar.
4. Place the jogger in the desired position in the layout by clicking where you want it along a line in the

frame or a design edge. ArtiosCAD will measure the offset of the jogger edge from the center of the
blanking frame for joggers placed along the frame. You can achieve different positioning by holding
down SHIFT or CTRL as you click; follow the prompts on the Status bar. The drag will be green
for valid positions and red for invalid positions. If you want to align the jogger with a point, check
Set Alignment on the Status bar before clicking its position. If Auto-Repeat is enabled, ArtiosCAD
repeats the jogger to congruent areas.
 

1570



13ArtiosCAD

 
5. Continue adding joggers as desired.

Add Support Bars tool

 The Add Support Bars tool lets you add support bars to the lower blanking board for
reinforcement. When you click this tool, ArtiosCAD turns on the Blanker frame layer and turns off the
other blanking layers.

This tool has the following control on the Status bar:
 

 

Set the absolute width of the support bar in the Width field. The initial value is part of the blanking
parameter set. Click More Options (...) to open the Blanking parameter sets dialog box and change to
defining the support bar by components within the parameter set.
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Click From machine to limit the choices in the Rail drop-down list box to those defined by the machine.
Similarly, choose an adhesive strip for the top of the rail from the Adhesive drop-down list box. If you
choose to define the support bar by components, the Status bar shows those components.
 

 

ArtiosCAD determines the support bar offset from the inner frame by the offset from the origin in the
geometry macro workspace containing the component bar. All BSI components in ArtiosCAD use an
offset of 4 millimeters. Similarly, ArtiosCAD determines the adhesive position by the position of the
geometry in the geometry macro workspace. All BSI adhesive components in ArtiosCAD use an overlap
of 2.5 millimeters. ArtiosCAD uses the same offset to trim the geometry at the top of the frame.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Add Support Bars on the Blanking toolbar.
3. ArtiosCAD positions support bars midway between two points. Click the first point.

 

 
4. Click the second point or hold down CTRL and click a freehand point.
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5. Continue adding support bars as desired.

Annotation marks in component support bars show the location of photocell holes.

If you choose to make your own component support bars out of geometry macros, there are these
restrictions:

• You may not bend custom support bars.
• ArtiosCAD does not check that the bar is big enough for the frame.

ArtiosCAD does not have BSI part H03002 Spring Clip (a screwless support rail), but you can make a
geometry macro for it and place it using Add Hardware.

Add Air Holes tool

 The Add Air Holes tool lets you add air holes in the pushers, the upper blanking board, or both. Air
holes reduce the suction created by the movement of the tooling. When you click this tool, ArtiosCAD
turns on the Blanker upper board layer and turns off any other blanking layers.

This tool has the following controls on the Status bar:
 

 

Choose the shape of the air holes from the option buttons and choose the objects in which to create
the air holes from the checkboxes.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Add Air Holes on the Blanking toolbar.
3. Choose the shape of air holes to add and the objects in which to create them.
4. Follow the prompts on the Status bar to create a hole. If Auto-Repeat is enabled, ArtiosCAD will use

layout congruency to repeat it.

Note:

There is no validation to ensure that hole edges do not cross each other or pusher edges. Be
careful with your construction.
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5. Create more holes as desired.

Add Blanker Pusher Pins tool

 The Add Blanker Pusher Pins tool adds the pins that attach the pushers to the upper blanking
board. These are also called stand-off pins (SOP). When you click this tool, ArtiosCAD turns on the
Blanker upper board and Blanker pusher layers and turns off the other blanking layers.

This tool has the following controls on the Status bar:
 

 

Choose the pin to add from the Blanker pusher pin drop-down list box. The Offset field sets the
distance from the pusher edge to the pin. The initial value is part of the blanking parameter set.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Add Blanker Pusher Pins on the Blanking toolbar.
3. Choose the type of pin to add from the list in the Blanker pusher pin drop-down list box.
4. If desired, change the offset for the pin in the Offset field.
5. Click the position inside the pusher edge where you want to place the pin. The cursor snaps the pin

drag to the inside edge of a hole when it is inside a hole. ArtiosCAD adds pins with congruency but
does not remove them with congruency.
 

1574



13ArtiosCAD

 
6. Continue adding pins as desired.

Add Hardware tool

 The Add Hardware tool lets you add pieces of additional hardware to any of the blanking layers.
You can design your own pieces of hardware, add them to the appropriate geometry macro catalog,
and use this tool to add them to the blanking tooling.

This tool has the following controls on the Status bar:
 

 

Choose the hardware to add from the Hardware drop-down list box. To be prompted for an offset after
selecting the hardware’s alignment point, check Set offset. Lines of blanker lower board types are
copied to that layer, lines of blanker upper board types are copied to that layer, lines of blanker pusher
types are copied to that layer, and the rest remain in the Blanker frame layer.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Add Hardware on the Blanking toolbar.
3. Choose the hardware to add from the Hardware drop-down list box and click Set offset to be

prompted to set an offset after aligning the hardware.
4. Place the hardware by clicking a line to place it against using drag and click to set its alignment

point. If you are using BSI blanking kit hardware, please refer to the next section for notes about
how to place specific pieces of hardware.

5. If you selected Set offset before placing the hardware, set the offset either with drag or by typing a
value in the Offset field.
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6. Continue adding hardware as desired.

Placing BSI hardware
If you are using a BSI blanking kit, some of the hardware has positioning notes.

Table: BSI Hardware Positioning Notes

BSI Hardware Part Positioning Notes

A03010 Lower Board Support Assembly Click an inside frame line, then click on a point to
align with (or CTRL-click to place freehand).

A02023 Lower Board Support Body Click an inside frame line, then click on a point to
align with (or CTRL-click to place freehand).

C01015 Support Rail End Select front or rear inside frame line, then select
point on center of support bar.

Clamps

C01013 Front/Rear Reusable Select an inside front or rear frame line, then
click a point on the side of the grid bar so that the
green arrow points toward the bar.

C01019 Front/Rear Weldable Select an inside front or rear frame line, then
click a point on the side of the grid bar so that the
green arrow points toward the bar.

C01028 Grid Mounting Bracket Select the middle line of a grid bar, then click
on a point to align with, (or CTRL-click to place
freehand). This component should not intersect
the frame rails.

C01012 Parallel Clamp Click on the back of a side jogger or clamp, then
click on the corner of the jogger so that the
parallel clamp aligns with the jogger.
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BSI Hardware Part Positioning Notes

C01014 Side Clamp Reusable Select an inside left or right frame line, then click
a point on the side of the grid bar so that the
green arrow points toward the bar.

C01020 Side Clamp Weldable Select an inside left or right frame line, then click
a point on the side of the grid bar so that the
green arrow points toward the bar.

The parts appear on the Blanking Parts List in Outputs.
 

 
The report includes quantities for the component support bars, hardened pins, screws needed for the
support bars that overlap the lower board, and adhesive runners.

Add Tie-bolts tool

 The Add Tie-bolts tool lets you add holes for the bolts that attach the boards to the press. When
you click this tool, ArtiosCAD makes the Blanker upper board layer active and turns off the other
blanking layers.

This tool has the following controls on the Status bar:
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Choose the tie-bolt to use from the Tie-bolt drop-down list box. To add a corresponding bolt on the
other side of the center line, leave Symmetrically checked. Set the offset of the tie-bolt either with
drag or by entering a value in the Offset field. Clicking Properties (...) opens the Blanking parameter
sets dialog box as shown below.
 

 

Set the distances as desired. The checkbox for a distance controls if you can add a mounting hole to
that support bar, while the checkbox for the maximum distance enforces a limit on the offset distance
from the centerline.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Add Tie-bolts on the Blanking toolbar.
3. Choose the tie-bolt to use from the Tie-bolt drop-down list box.
4. Use the drag to set the Offset field. Depending on which mounting bars are enabled in the Blanking

parameter sets dialog box, the drag snaps to show the bar for which you are adding a hole; you
must use drag to choose the bar for the hole. The drag is green for valid positions and red for invalid
positions. If Symmetrical is checked on the Status bar, then a corresponding tie-bolt hole is shown
in the drag mirrored around the center line.

Shown below is drag for the first bar and then for the second bar. Once you have set the offset, click
to add the hole.
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5. Continue adding tie-bolt holes as desired.

Add Pressers tool

 The Add Pressers tool adds pressers to the upper board. Pressers are essential for holding the
waste while the blanks are separated from the sheet. When you click this tool, ArtiosCAD turns on the
Blanker upper board layer and turns off the other blanking layers.

This tool has the following controls on the Status bar:
 

 

Choose the presser to use from the Presser drop-down list box. Set alignment and Set rotation,
when checked, allow you to set an alignment point after choosing the placement and to set a rotation
angle on the presser before clicking the final position. The Properties (...) button opens the Blanking
parameter sets dialog box as shown below.
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The checkboxes control enforcement of the restrictions for placement of the pressers relative to the
first knife, last knife, and mounting bars. The values in the fields come from the blanking parameter
set; change them if desired.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Add Pressers on the Blanking toolbar.
3. Choose the type of presser to add from the Pressers drop-down list box.
4. Check Set alignment and Set rotation as desired.
5. Place the presser by clicking the design line from which to offset the presser, or click two points

to position it between. Use drag to position it, or enter a value in the Offset field on the Status bar.
The drag will be green for valid positions and red for invalid positions. Hold down CTRL to place the
presser freehand.
 

1581



13 ArtiosCAD

 

If you checked Set alignment or Set rotation, ArtiosCAD prompts you to set the alignment and
rotation before creating the presser. If Auto-Repeat is enabled, ArtiosCAD repeats the presser
using layout congruency.

6. Continue adding pressers as desired.

Delete Blanking tool

 The Delete Blanking tool lets you quickly delete entire categories of blanking elements. When you
click this tool, ArtiosCAD turns on all the blanking layers.

To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2.

 Click Delete Blanking on the Blanking toolbar. The Delete Blanking dialog box opens as shown
below.
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3. Select the checkboxes in front of the blanking elements to delete. All checkboxes are turned on

by default. To toggle their states simultaneously, change the state of Select all. It defaults to an
intermediate state because everything but included strip rules are selected by default.

4. Once you have clicked the checkboxes for the elements to delete, click OK.
5. ArtiosCAD deletes the selected blanking elements.
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Note:

If you have locked any of the blanking layers, you cannot delete elements that have
components in those layers as their checkboxes will be unavailable. Unlock those layers to
enable deleting elements in them.
 

 

 To delete individual blanking elements, use the Select Element tool and the DEL key on the
keyboard.

Smooth/Blend Contour tool
The Smooth/Blend Contour tool is on the context menu when you are adjusting the contour of a lower
hole, pusher edge, or pusher air hole. It lets you blend contour corners or smooth the entire contour.

This tool has the following controls on the status bar:
 

 

Blend blends the corner between two segments by the value specified in the Radius field.
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To use this tool, do the following:

1. Create a layout in ArtiosCAD and generate the blanking tools.
2. Use a tool to add or adjust a lower hole, pusher, or pusher air hole.
3. While one of those tools is active, right-click the contour and click Smooth/Blend Contour on the

context menu.
 

 
4. On the Status bar, check Blend to blend two segments together by the amount in the Radius field.
5. Either click the first and second lines to blend, or hold down CTRL to blend the whole contour at

once. If Auto-Repeat is enabled, ArtiosCAD uses contour congruency to repeat the changes to
matching elements. Shown below is a rectangular air hole that had all its corners blended at once by
using this tool while holding down CTRL.
 

 

Note:

This tool smooths only the inside corners of lower holes.

Edit Contour tool
The Edit Contour tool is on the context menu when you are adjusting the contour of a lower hole,
pusher edge, or pusher air hole. It lets you change the shape of the contour.

To use this tool, do the following:
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1. Create a layout in ArtiosCAD and generate the blanking tools.
2. Use a tool to add or adjust a lower hole, pusher, or pusher air hole.
3. While one of those tools is active, right-click the contour and click Edit Contour on the context

menu.
 

 
4. Click the point to move or the line to split. Use the Stretch Point technique if you click a point

or the Split Line technique if you click a line. If Auto-Repeat is enabled, ArtiosCAD uses contour
congruency to repeat the changes to other elements. Shown below is a point being dragged.
 

 
5. Continue editing the contour as desired.
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14.  3D

Introduction to 3D

3D has three modules that provide different abilities for viewing how the design will look in the real
world.

3D allows you to fold flat single designs in three dimensions.

With the 3D Animation module, you can create a video of how the design folds.

With 3D Designer, you can import a model of the object being packaged, make intersecting pieces of
board through any cross section, and then run a standard style of box to contain the assembly. The
examples and procedures in this chapter may reference options and features that are not part of your
system.
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Concepts and Ideas in 3D

3D is simple to use, but very powerful. Before you use it, you should understand the basics.

In 3D:

• You work in three dimensions using the X, Y, and Z axes. Those axes can optionally be displayed in
the lower left corner of the design window.

• You import flat designs and then fold panels along straight creases (or similar lines such as perfs) so
that the edges of the panels meet to form an image of the box as it looks in real life.

• You pick which panel of the box will remain fixed. All the other panels will fold around this one, called
the base face.

• Lines in a design that are invisible in real life can be made invisible in 3D.

• You can see board thickness and corrugation if your system has the Graphics option.

• Multiple designs can be in one workspace, and multiple workspaces can be open at once. For
example, in one workspace, boxes can be placed in trays that rest upon display bases.

• The viewing angle of the workspace can be changed at any time so that you can see your workspace
from any side.

• Individual designs can be grouped together for easier manipulation.

• You can change the position of the light source to change the intensity of any graphics.

• You can animate a fold sequence and export it as a VRML file, viewable in any Web browser with a
VRML plug-in. (This ability must be purchased.)

• You can make a solid of revolution by defining its vertical cross section and horizontal cross
sections in the single design workspace, adding labels and shrink-wrap graphics if desired, to
create a 3D model.

• You can import 3D models from other applications depending on the ArtiosCAD options purchased.

• You can copy a workspace to the Windows Clipboard with graphics and lines for use in Single Design
or other applications, or export it as a PNG or JPG file for greater resolution and transparency
support (PNG only).

Workflow in 3D

The core of using 3D for a folding container is shown below.

1. Make a single design in ArtiosCAD.
2.

Start 3D by clicking the Convert to 3D button  on the View bar.
3. Select a base face for the flat design to fold around.
4. Fold the panels as desired, capturing animation frames as desired.
5. Add more designs to the workspace as needed.
6. Adjust the viewing angle, elevation, light sources, and perspective as desired.
7. Add a background image as desired and align the designs with the background image.
8. Turn on shadows as desired and adjust the light sources as needed.
9. Save the workspace.
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10. Print or export the workspace.

Snap

The availability of pick-up and put-down points for objects in 3D are controlled by the Snap Options
dialog box on the Options menu. In addition to the same options as in Single Design, Snap to solids
enables snapping to any point in a solid (of which there are many because of the number of polygons
used to make the solid); this checkbox is off by default. Snap to cartons enables snapping to midpoints
and endpoints in corrugated or folding carton containers; this option is on by default.

Tools in 3D

There are two types of tools in 3D. The first requires one or more designs to be selected before that
tool can be used. The second does not require a design to be selected. Any tool that manipulates the
physical position of a design requires the design to be selected first.

Table: Tools and Selection Status

Tools requiring design to be selected Tools not requiring design to be selected

Move Point to Point

Move Designs

Move Designs in X, Y, Z

Duplicate Designs

Duplicate Designs in X, Y, Z

Rotate Designs

Group

Ungroup

Zoom Rectangle

Zoom Out

Center-Point Zoom

Pan/Zoom

Next View

Previous View

Scale to Fit

View Mode tools

Select Designs

Fold Angle

Fold All

Fold 1 to Meet

Fold 2 to Meet

View Angle

Perspective

Light Source

Dimension

Select Dimensions

All of the Animation tools
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Tools requiring design to be selected Tools not requiring design to be selected

Extend

Clear Extend

Convert to 2D

For example, if you want to move a design, it must be selected before the Move Design tool can be
activated. The same applies to the Move Point to Point, Duplicate Designs, and Rotate Design tools.

Notes and warnings in 3D

3D workspaces created in this version of ArtiosCAD may not be opened in pre-6.5x versions of
ArtiosCAD. In 6.5x there will be no board textures, no background image, and animations will not Scale
to Fit.

The 3D View toolbar must be turned on for flyout toolbars to work.

The amount of graphics in a workspace, the number of designs in a workspace, the smoothness
selected for solids of revolution, and the number of workspaces open all affect the performance of your
system and 3D. To keep your system running at the fastest possible speed, turn Graphics off in the View
Mode dialog box (if that option is available) and keep the number of open workspaces to a minimum.

Multi-piece single designs without creases (such as words made of cut lines) are limited to having a
maximum of 300 pieces when converted to 3D.

There is a limit of 29,900 graphic elements on a face in 3D. Each panel of a container is a face. Each
fill or stroke is a separate graphic element; grouping them does not merge them for the purposes of
circumventing this limit. Text that is converted to an outline has one or two fills per letter.

Performance will be slow with more than 100 holes per face.

Likewise, ArtiosCAD will not render more than 100 perf segments per panel. It will still tear or fold as
required, however.

Curves in board face edges are converted to straight lines in order to draw their edges.

Faces may be divided by gaps up of up to 1.5 mm. Designs that have intentional gaps larger than this
are not supported and may have unexpected faces.

When a design with no creases is opened in 3D, the Select Base Face dialog box is skipped as there is
only one face.

If nothing happens when you turn on board thickness, there might not be a board defined in the
workspace. The best way to turn on board thickness for 3D workspaces created in earlier versions of
ArtiosCAD is to choose a new board for that workspace in the Properties dialog box.

When a crease is folded, it folds in the middle of the board as ArtiosCAD assumes the inside loss is half
a caliper. It is often more accurate to fold in this manner because the inside loss in the board table is
often rounded.

The VRML Export Options dialog box in Defaults (Options > Defaults > Outputs-3D > Artios > VRML) has
a checkbox to control whether or not corrugations are exported to VRML from 3D.

Do not make a handle with a gap between the edge of the handle and the main body of the design on
single designs you intend to convert to solids of revolution. Solid handles attached to the designs
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with no gap are constructible as long as the cross sections are defined correctly, or you could make a
handle as a separate design with a large board thickness and add it to the 3D workspace.

When working with the High or Maximum settings in high graphics mode, only have one 3D workspace
open at a time. There is no error message when the video adapter runs out of memory, so if parts of the
graphics are missing, try High or Medium.

When folding a design, all edges of coplanar flaps may not be shown. Change the View Mode to Solid
with edges to see the flap edges. Alternately, change the fold angle(s) by a degree or two.

A PS/2 laptop mouse may not have correct middle mouse button functionality. If you have such a
mouse and the middle mouse button functionality does not work properly, try an external USB mouse.

Solid with Edges View mode in 3D now responds faster than it did in previous versions. It does this by
drawing all the fills without graphics as a single bitmap and grouping all the lines together. In previous
versions, the panels were independent of each other and the fills without graphics were drawn as
separate pieces.

If you frequently use Copy and Paste between 3D and Single Design, you may notice this changed way
of working more than users who do not frequently copy and paste between the two modules.

OpenGL provides sharper results when copying and pasting between modules because of its larger
limit on bitmap size than Direct3D. Try using OpenGL if Direct3D does not meet your needs.

If you need your creases to be black when printing, create a plotting style with black crease lines and
use it as needed.

A 3D workspace may have up to 30,000 individual designs in it.

Most special rules can fold and tear. Curved rules can tear or fold per the table below, but cannot both
tear and fold.

Special rule type Fold Tear

Crease, partial cut, reverse
partial cut

Yes Yes

Perf, cut/crease, partial cut/
crease, all perf types

Yes Yes

Multi-perf Yes Yes

Zipper rule Yes Yes

Wave or zig zag with non-zero
nick size

Yes Yes

Wave or zig zag with zero nick
size

No No

Scallop rule (has no nicks) No No
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Special rule type Fold Tear

Staggered perf, S-rule, echelon
perf

Yes Yes

3D Rendering Options

3D can use two different rendering (display) methods, OpenGL (the default) and Direct3D. Which
method will perform better for you depends on the display adapter in your system. The main difference
between the two methods is how data is transferred between main system memory and the display
adapter. Other differences include:

• Shininess appears to work better when using Direct3D.
• ArtiosCAD using Direct3D takes longer to open a 3D workspace initially but once open draws it

faster than when using OpenGL.
• Using OpenGL allows the export of bitmaps with more pixels than with Direct3D.
• In wire frame view mode, OpenGL seems to be able to display more lines.
• When ArtiosCAD and the Cortona VRML viewer both use Direct3D and are open at the same time,

they compete for resources and unpredictable results may occur. Change the rendering method in
one of them for better results. Closing ArtiosCAD may also help Cortona to work more predictably.

To switch between rendering languages, click Options > 3D Rendering Options, choose the desired
language, and click OK.

Use OpenGL for bitmaps enables ArtiosCAD to output bitmaps using OpenGL regardless of the screen
rendering method chosen. OpenGL supports the output of larger bitmaps than Direct3D.

Defaults are updated automatically with the selections made in this dialog box.

Understanding the Basics of 3D

Creating a new 3D workspace

To create a new 3D workspace from an existing flat design, do the following:

1. Open the design in ArtiosCAD.
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2.
 Click Convert to 3D on the View bar. If there is a 3D workspace open already, the Convert to 3D

dialog box appears as shown below. If there is no 3D workspace open, skip to the next step.

Update 3D is enabled if you are modifying a design contained in one of the open 3D workspaces.
Choose the 3D workspace to update and click OK.

Add to 3D adds the design being converted to the selected 3D workspace. Click OK.

New 3D creates a new 3D workspace. Click OK.

Click Cancel to cancel the conversion to 3D.
3. The Add Unfolded Design(s) dialog box appears. ArtiosCAD checks the design for gaps in the

perimeter as well as for creases that do not meet other cuts or creases to form panels. ArtiosCAD
fills the design in gray and colors the base face (if already defined) in a light purple. If the entire
design doesn't fill, that means there's a gap or improper line (such as a cut that should be a crease)
somewhere that you need to fix. Any error messages or instructions are shown in the box beneath
the picture of the design.
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Any perimeter gaps smaller than the value in the Fix gaps up to: field are automatically fixed and
are indicated by green circles. Gaps between the size to be shown and the size to be fixed are
indicated by red circles. If the perimeter has gaps in it, ArtiosCAD does not fill the design
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ArtiosCAD extends cut-back creases up to the amount selected in the Extend creases up to: drop-
down list box so that they meet other cuts and creases. Creases will be extended at least 3mm. If
the crease reductions were intentional, decrease the value in this field to prevent ArtiosCAD from
extending the creases. Creases which do not completely form panels are shown as perfs.

Ignore warning is available when creases cross more than one panel or when cut lines do not
form an outline. Checking this checkbox enables the OK button. Ignoring warnings may lead to
unintended consequences as shown below.
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4. Once any issues are resolved, click inside the base face when prompted. This is the panel that all

other panels will fold around. If the single design contained fold angles, Use previous fold angles is
available; check it if desired.

5. Click OK.
6. The design will be opened in 3D and you can start to fold it. If any graphics layers for the print item

were turned on in Single Design before converting the design, they are all brought into 3D.
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Note:  If it will take longer than a minute to render the edges when creating a new 3D
workspace, edges will be turned off if they are on in the current view. You may turn them back
on manually by changing the View Mode.

Defaults for the gap tolerances and the crease extension allowance are set in Options > Defaults >
Shared Defaults > Startup defaults > 3D Tools Defaults.

To create a completely new 3D workspace, click File > New > 3D. You can then use File > Add a Design
to add designs or solids to the new workspace.

When converting a flat design to 3D, line types are processed as shown in the table below.

Table: Line types when converting to 3D

Line type Resulting action

Cut Form the outside edge of the design or holes in the interior.

Crease, Second height crease,
Reverse crease

Straight creases between panels can be folded. Curved creases
will cause an error message. Creases that do not connect cut
lines are treated as perfs.

Perf, Reverse crease, Partial cut,
Reverse partial cut

Straight lines between panels can be folded. Lines that do not
connect cuts are shown as thin slots. The number of such slots
able to be processed is limited; do not use with text outlines.
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Line type Resulting action

Print image, Annotation Ignored. Use graphics such as strokes or fills instead.

If you are reconverting a canvas to 3D and it already contains hardware parts, ArtiosCAD positions the
hardware based on the hardware placement lines in the 2D design. Note that the placement lines are
not mates and do not force the hardware to stick to the design.

Opening an existing 3D workspace

To open an existing 3D workspace, do the following:

1. Click File > Open.
2. Navigate to the desired resource or directory, select the file from those listed, and click OK. If your

3D design does not have the .A3D extension, enter the full name of the workspace in the filename
box, or change the listed file type to All Files and then select the file.

3. The workspace will be opened.

Note:  If it will take longer than a minute to render the edges when opening a design, edges
will be turned off if they are on in the current view. You may turn them back on manually by
changing the View Mode.

Remembered fold angles and base face

3D saves fold angle and base face information. If you convert a design to 3D, fold it, save it, and then
make changes to the original flat design, when you convert the changed flat design to 3D, 3D gives
you the option of reusing the folded angles and the base face from the previous version of the folded
design. If you want to choose a new base face, click inside it, and clear the Use previous fold angles
checkbox to select new fold angles. This feature only works on designs that have been saved as it uses
the design name to link the 3D workspace to the flat ArtiosCAD design.
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Pre-defined fold angles in designs created from standards

When you create a standard and fold it, the fold angles are stored in the standard workspace when
it is saved. When a single design is then based on that standard, the fold angles and base face are
remembered when the new single design is converted to 3D.

Shown below is a single design based on a standard.
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When the Convert to 3D button is clicked on the tool bar, the Add Unfolded Design(s) dialog box opens.
The base face is preselected and the Use Previous Fold Angles checkbox is selected.
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Note:  When using multi-part designs, fold angles are remembered for only one of the parts.

When you click OK to accept the default base face and use the previous fold angles, the design will
appear fully folded.
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Folding all creases in a design at 90 degrees

To fold all creases at 90 degrees, do the following:

1.
 Click the Fold All button.

2. Select a crease in the design you want to fold. If you want to fold more than one design, hold down
the SHIFT key and select a crease in each design.

To quickly fold the selection at 90 degrees, double-click it. To quickly fold it at -90 degrees, hold
down CTRL and double-click it.

3. Select 90 from the list box for the Angle field.
4. All the creases in the selected designs will be folded at 90 degrees.
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You may need to click Scale to Fit to reset the view of the design.

Folding individual angles

To fold angles individually, do the following:

1.
 Click the Fold Angle button.

2. Select the crease or other foldable line to fold. To fold more than one crease at once, hold down
the SHIFT key and select additional creases, or hold down CTRL while dragging to make a window
selection.

3. Set the angle using the slider or the list box. To quickly fold the selection at 90 degrees, double-
click it. To quickly fold it at -90 degrees, hold down CTRL and double-click it.

4. The angles will fold.

You may need to click Scale to Fit to reset the view of the design.

Adding another design to a 3D workspace

To add another design or import another file to your workspace, do this:

1. Click File > Add a Design.
2. Make sure the drive, directory, and file type settings are correct.
3. Double-click the name of the desired file.
4. Repeat steps 1 through 3 as desired.

Note:  The ability to import certain 3D file types is controlled by the licenses purchased for the
system. Your system will not be able to import 3D files of certain types without corresponding
licenses. Contact your Esko salesperson for more information on purchasing licenses for
importing 3D files. If it will take longer than a minute to render the edges when adding another
design, edges will be turned off if they are on in the current view. You may turn them back on
manually by changing the View Mode.

Add to Open 3D tool

The Add to Open 3D tool on the Tools menu lets you add one 3D workspace to another, avoiding the
intermediate step of saving the first workspace and then using Add a Design in the second workspace.

To use this tool, do the following:

1. Start ArtiosCAD and create, open, or convert at least two 3D workspaces.
2. On the Window menu, select the source workspace (the one to add to another workspace).
3. Click Tools > Add to Open 3D.
4. If you have more than two 3D workspaces open, select the destination workspace in the dialog

box and click OK. If there are only two workspaces open, ArtiosCAD automatically selects the
destination workspace.
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5. ArtiosCAD adds the source workspace to the destination workspace in front of the contents of the
destination workspace.

Converting a multi-part design to a 3D workspace

To convert a multi-part design to 3D, do the following:

1. Put all the parts together in one Single Design workspace, and then convert it to 3D. Up to 50 parts
can be touching; if there are more than 50 touching parts, separate them into arrangements of 50.

2. Click inside the base face for each part to convert to 3D. Any part with creases that does not have
a base face selected will be discarded. When there are many parts touching, it is not clear which
parts are useful and which parts are waste. ArtiosCAD discards pieces thinner than 20 mm as
waste; specifically deselect larger waste pieces.

3. Click OK to convert the multiple parts to 3D.
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Note:  Multi-piece single designs without creases (such as words made of cut lines) are limited
to having a maximum of 300 pieces when converted to 3D.

Converting a canvas to 3D

To convert a canvas to 3D, do the following:

1.
In the canvas, click Convert to 3D.

2. In the Add Unfolded Design(s) dialog box, ArtiosCAD shows the parts. All the parts should be shaded
gray to indicate they have no gaps or problems. ArtiosCAD shows designs without a base face that it
will not convert to 3D in white. Panels that ArtiosCAD does not fill in will not be in the 3D workspace,
so cancel the conversion and fix the problems.
 

 
3. Click inside the base face for each part; it will turn light purple. To deselect a part so it is not added

to the 3D workspace, click inside it so it turns white. ArtiosCAD automatically selects one-panel
parts.

4. Click OK to create the 3D workspace. If this canvas used standards or parts that had already been
converted to 3D, there should be remembered fold angles.
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5. Fold and position the parts as desired.

ArtiosCAD compares part counts between the canvas and any saved 3D information in the workspace if
Use previous fold angles is enabled. If there is a conflict, ArtiosCAD prompts you to choose which part
counts to use.
 

1606



14ArtiosCAD

 

Click Part Counts to see the conflicting counts.
 

 
If the count number increases in the 3D workspace, ArtiosCAD stacks the new copies in a grid in front
of the scene. In the example below, the eight shelves were the count from the canvas after deleting all
of the shelves from the open 3D workspace and reconverting the canvas to 3D.
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If the canvas already contains hardware parts and you are reconverting it to 3D, ArtiosCAD positions
the hardware based on the hardware placement lines in the 2D design. Note that the placement lines
are not mates and do not force the hardware to stick to the design.

ArtiosCAD warns you if it cannot find the hardware workspace or if holes are missing. However,
ArtiosCAD does not warn you if you changed the hole shape in 2D.

Changing the view of a workspace in 3D

To change how a workspace is viewed, do the following:

1.
 Click the View Angle tool.

2. Drag the sliders for Angle, Elevation, and Roll Angle to the desired positions, or type in the values in
their boxes, or select predefined values from the list boxes. You may also click and drag inside the
drawing window to change all three angles simultaneously. To change only the Roll angle, hold down
CTRL while dragging from to the left or right. The View angle will change according to the settings
in the View Mode dialog box.

3. The view changes appropriately.
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You may need to click Scale to Fit to reset the view of the design.

Changing the base face

The base face is the panel of the design around which all other panels fold. Imagine the container
resting on a table. The base face is the panel on the table. To change the base face, do the following:

1.
 Select a design using the Select Designs tool.

2. Click Change Base Face on the Tools menu.
3. Click inside the new base face and click on OK.
4. The base face will be changed. You will not see a difference until you change fold angles.

Printing a folded workspace

To print a workspace, do the following:

1. Click Print on the File menu.
2. Change any values as appropriate (for example, to make two copies, set the number of copies to 2).
3. By default, one copy of the workspace will be printed in portrait mode at the largest scale that can

fit on one page.
4. Click OK.

For more information about performing other Outputs from 3D, see the section about 3D Outputs.

Saving a workspace in 3D

Before saving the design, ensure High Graphics mode is not set to Maximum in the View Mode dialog
box, as this may cause the preview to not be generated correctly.

To save a workspace, click Save on the File menu. The workspace will be saved with the name and
database resource (if applicable) shown in the title bar of the workspace window. If the 3D workspace
was created from a flat workspace which is still open, the fold angles from the 3D workspace are saved
to it.

If this is the first time you have saved the workspace, you will be brought to the Save As dialog box,
where you will be prompted to enter a name for the workspace.

If you have already saved this design, a current copy of the workspace will overwrite the saved file.

If you want to save the design under a different name and keep working on the original file, click Save
Copy As and enter a name for the copy. If you want to save the workspace under a different name and
not under the current name, click Save As on the File menu and enter the new name. If you did not save
the workspace with the old name, it will be lost.

The full pathname of the source file for each design in the workspace is retained. When using tools that
act upon the individual designs and require filenames, the full paths are shown in the Filename: field.
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For more information about performing file-based Outputs from 3D, see the section on 3D Outputs.

Saving fold angles changes

When you close a 3D workspace and its associated single design or canvas is still open, you can choose
whether or not to save the fold angles, view settings, and board code changes back to the single design
or canvas.
 

 

To not save the fold angles, view settings, and board code changes back to the single design or canvas,
clear the Save fold angles, view settings, and board in design name checkbox. ArtiosCAD only updates
the board in a single design if all 3D designs from the same single design workspace are changed to the
same board in 3D.

Then click Yes or No to save the changes to the 3D workspace.

Note:

These are two separate actions. Clearing the checkbox only applies to the saving of the fold
angles, view settings, and board code changes, not to the saving of the changes you made in
the 3D workspace.

Saving part count changes

If ArtiosCAD detects that the part counts do not match between a 3D workspace and a canvas when
you save or close the 3D workspace, it shows you the discrepancy.

To save the part count changes, do the following:

1. Save or close the 3D workspace.
2. ArtiosCAD will prompt you as shown below. Review the information in the dialog box.
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3. Check Save 3D design count to canvas part count.
4. Click Yes. ArtiosCAD saves the workspace.

Make sure to save the updated canvas as well.

Note:  Unlike using Update 2D, closing a 3D workspace does not remove hardware placement
lines from the 2D workspace if the hardware no longer exists in the 3D design.

Copying a 3D workspace to the Windows Clipboard

To copy a low-resolution picture of the workspace onto the Windows clipboard, click Edit > Copy as
Bitmap. Transparency is not supported. A better workflow is to export the workspace as a JPEG or PNG
file using File > Outputs-3D and then import the JPEG or PNG file as desired into other applications.

To copy line information for use in Single Design, click Copy > Copy as Enhanced Metafile. This copies
the workspace to the clipboard as both a low-resolution bitmap and as lines (also called vectors). The
colors of the lines are set by the plotting style.

Using Copy as Enhanced Metafile is a way to make assembly drawings - copy views in 3D and then
paste them into a Single Design workspace as desired, fixing any hidden line anomalies with the Select
or Trim/Extend tools.

Elements included when performing a Copy as Enhanced Metafile include cartons and solids, board
thickness, inside and outside graphics and board textures, the background image (if defined), and
dimensions (which are converted to text and arrows for scalability). Bounding boxes are not included.

Notes and warnings
In complex workspaces, hidden line removal may not perform optimally. Any stray lines are easily
removed in Single Design.
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Depending on the capabilities of your system, this command may take several minutes to finish when
there are more than 10 cartons in a workspace or for solids with more than 10,000 polygons. To show
the number of polygons, click Help > Diagnostics > List Embedded Designs.

If there are too many polygons to render in less than a minute, a warning dialog box will appear asking
you to choose to copy the design as a bitmap only, or continue and render as vectors. Choose the
desired option and click OK, or click Cancel to cancel the copy to clipboard.

Copy as Enhanced Metafile includes edges even if they are not turned on in the current view.

Exiting 3D

To exit 3D, click Exit on the File menu. If you have changed your design since last saving it, you will be
asked if you want to save it again. If the 3D workspace was created from a flat workspace which is still
open, the fold angles from the 3D workspace are saved to it. Click Yes to save the 3D workspace, or
click No to exit without saving. Cancel returns you to the workspace without exiting 3D.

This also exits ArtiosCAD. To exit the 3D module alone, close any open 3D workspaces.

Moving, duplicating, and rotating objects in 3D

The tools in this section affect the physical placement of objects in the workspace.

Working with different simultaneous view angles

Sometimes different simultaneous view angles make moving or copying elements of the workspace
easier. Using a CloseUp window allows you to work with different angles and avoid tool restarts caused
by clicking between design windows. To create different viewing angles using a CloseUp window, do
the following:

1. Set the view angle as desired in preparation for the first view angle.
2. Click the middle mouse button at the location of the center of the first view angle, or press CTRL-

Space and click the left mouse button in that location. This creates the first CloseUp window.
3. Click the magnifying glass icon in the title bar of the CloseUp window and deselect Dynamic. Move

the CloseUp window as desired.
4. Change the view in the main ArtiosCAD window as desired to create the second view angle.
5. Use a Select tool to select the object(s) to move or copy.
6. Use a move or copy tool to pick-up in the CloseUp window and put-down in the ArtiosCAD window.

3D Extend tools

The Extend and Clear Extend tools on the 3D Extend Tools toolbar create and remove bounding boxes
around objects in 3D. Turn on the toolbar by clicking View > Toolbars, clicking the button next to 3D
Extend, and clicking OK.
 

1612



14ArtiosCAD

 

The bounding boxes create 20 points than can be used as pick-up and put-down points. They make it
easier to move, copy, and place objects.

 The Extend tool creates a bounding box. To use it, click the tool, and the click the object to extend.
The bounding box will appear, with selectable points at the corners and midpoints of each line. More
than one object can have a bounding box. Bounding boxes remain visible until they are removed with
the Clear Extend tool. Shown below is a bounding box for the outer box.
 

 

 The Extend Design tool shows extend points instead of a bounding box.
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 The Clear Extend tool removes all bounding boxes and extend points. To use it, click it, and all
bounding boxes and extend points disappear.

Select Designs tool

 The Select Designs tool is used to select one or more objects. Selected objects can then be
moved, rotated, copied, or deleted. Delete objects by selecting them and pressing Delete on the
keyboard.

Click the Select Designs tool, then click on any line in a design. To select more than one design, hold
down the SHIFT key as you select the designs. Selected objects will turn magenta to indicate they are
selected.

Colored axes

When you make a selection to use the move, copy, or rotate tools, if the selection is aligned with the
workspace axes, ArtiosCAD shows the tool axes in the same colors as the axes label at the bottom left
of the design window to aid in spatial orientation.
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If you select an axis to move, copy, or rotate along that does not match one of the workspace axes,
ArtiosCAD shows the axis in its default color. Shown below is moving a rotated design that is askew
from the workspace axes.
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Move Point to Point tool

  The Move Point to Point tool moves two designs together so that the pick-up point of the first
design is aligned exactly with the put-down point of the second design.

1. Select a design using the Select Designs tool.
2. Click the Move Point to Point tool.
3. Select the pick-up point in the design you just selected.
4. Select a put-down point in another design. The first design will move so that the pick-up and put-

down points are aligned.

Move Designs tool

The Move Designs tool is the first tool on the Move Designs flyout toolbar. This tool moves one or more
designs in one direction.

1. Select one or more designs using the Select Designs tool. It will turn magenta to show it is
selected.

2.
 Click the Move Designs tool.

3. Select a pick-up point. There are pick-up points on the inside and outside of lines. The three
directional axes will appear centered on the pick-up point.
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4. Click an axis or line to set the direction in which to move the selected designs.
5. Move the mouse to move the selected designs in the direction indicated in step 4, or enter a

distance on the Status bar.
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6. Click to set the put-down point of the selected design, or click an existing point to align the put-
down point with it. Hold down CTRL while clicking to add another offset before setting the final put-
down point. The Move tool remains active with the current selection so that another move may be
performed without having to reselect the tool and pick-up point. Shown below is the moved design.
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If you check Check collisions on the Status bar, the object you are moving stops when it hits another
object, and the object it hits turns red.
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If you continue dragging, the object you are moving moves through the interfering object once it is far
enough away to not collide with it.
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Clicking Gutter and entering a value in the field sets a gutter between the edge of the moving object
and the interfering object. Shown below is the same example with a gutter of one inch.
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Fit tolerance
Fit tolerance on the Move Design tool's Status bar in 3D lets you squish together designs which would
take some effort to fit together in the real world. The option works by shrinking the moving design by
the amount you specify in the Fit tolerance field in both directions perpendicular to the movement axis.
ArtiosCAD does not change the size of the selections in the direction in which you are moving them;
that is controlled by the gutter.
 

 

1. Create a 3D workspace with components that do not quite fit together.
2.

 Use Move Design to fit them together and discover the inner carton is slightly too large to fit
into the outer box, but you know you could shove it in the real world and it would fit.
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3. Check Fit Tolerance on the Status bar and enter a value in the field. The default is 1/16" or 1.5mm.
4. The inner box will now move inside the outer box. Shown below is it colliding with the farther edge

of the outer box.
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Move Designs X, Y, Z tool

 The Move Designs X, Y, Z tool is the second tool on the Move Designs flyout toolbar.
 

 

It moves the current selection in any or all of the three dimensions at once.

To use this tool, do the following:

1.
 Click the Select Designs tool and select the design(s) to move or copy.

2.
 Click the Move Design in X, Y, Z tool.

3. Click the pick-up point. There are pick-up points on the inside and outside of lines.
4. Use the drag to set the X offset, or enter a value in the X: field on the Status bar.
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5. Once you have set the drag for the X offset or entered a value, the Y offset becomes active. Set it
using drag or by entering a value in the Y: field on the Status bar.

6. Once you have set the drag for the Y offset or entered a value, the Z offset becomes active. Set it
using drag or by entering a value in the Z: field on the Status bar. If you set the Z offset using drag,
the design will move when you click the mouse button. If you entered the Z offset on the Status bar,
click OK and the design will move.

Duplicate Designs tool

 The Duplicate Designs tool makes one or more copies of the currently selected designs. It is the
first tool on the Duplicate Designs tools flyout toolbar.
 

 

1. Select the design or designs to copy.
2. Click the Duplicate Designs tool.
3. On the Status bar, enter the number of copies to make in the Number of copies: field.
4. Select a pick-up point. There are pick-up points on the inside and outside of lines, and on the

bounding box if it is turned on using the Extend tool.
5. Select an axis or line that indicates the direction to move the duplicates.

6. Indicate the distance to move the duplicates either using drag or by entering a number in the
Distance: field on the Status bar. The copies will move with the mouse cursor.
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7. Click the mouse button to set the put-down point of the outlined designs. Hold down CTRL while
clicking to add another offset before setting the final put-down point. The designs are duplicated.
Repeat as desired.

Shown below is the finished product, with the row of three bags duplicated 10 times.
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Note:  When an object in 3D is duplicated, all duplicates are instances of the original object for
more ecient memory usage. The duplicates may have different fold angles than the original,
but the material properties of the duplicates are the same as those for the original. If you
select fewer than all the copies and try to change them, ArtiosCAD prompts you to change all
instances of the first copy or to make a separate copy to which the new properties would then
be applied. If you choose to make copies, the amount of memory used and disc space required
will increase accordingly.

Duplicate Designs X, Y, Z tool

 The second tool on the Duplicate Designs tools flyout toolbar is the Duplicate Designs X, Y, Z tool.
It works the same way as the Move Designs X, Y, Z tool, except it acts on a duplicate of the current
selection.

To use this tool, do the following:

1.
 Click the Select Designs tool and select the design(s) to copy.

2.
 Click the Duplicate Design in X, Y, Z tool.

3. Click the pick-up point. There are pick-up points on the inside and outside of lines, and on the
bounding box if it is turned on using the Extend tool.

4. Use the drag to set the X offset, or enter a value in the X: field on the Status bar.
5. Once you have set the drag for the X offset or entered a value, the Y offset becomes active. Set it

using drag or by entering a value in the Y: field on the Status bar.
6. Once you have set the drag for the Y offset or entered a value, the Z offset becomes active. Set it

using drag or by entering a value in the Z: field on the Status bar. If you set the Z offset using drag,
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the design will move when you click the mouse button. If you entered the Z offset on the Status bar,
click OK and the duplicated design(s) will move.

Group tools

 The Group tools flyout toolbar contains the Group Designs and Ungroup Designs tools.
They work the same way as they do in other modules.

 To group items together, select them, and click the Group Designs tool. The items will be grouped
together and the bounding box for the group will be turned on.

Whenever any grouped design is selected, the entire group is selected. You can nest groups within
groups, but only the last-created group can be selected. When a grouped design is copied, the copy
has the same group structure as the original.

 To ungroup a group, select it, and click the Ungroup Designs tool. The group will be ungrouped into
its elements.

Rotate Designs tool

 The Rotate Designs tool rotates the selected designs.

1. Select the designs to rotate.
2. Click the Rotate Designs tool.
3. Click the line or axis to rotate the design around:
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4. Select a rotation method:

• Enter an angle in the Angle field or select one from the drop-down list box;

• Use the slider to set the rotation angle;

• Double-click an axis to rotate by 90 degrees, or to the next increment of 90 degrees if you have
used the slider;

• Click the Align with button. Select a line in the design(s) you are rotating, and then select either
an axis or a line in another design to align with.
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If you use Orthogonal view, the axis coming toward you is represented as a circle.
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Drag on Plane tool

Drag on Plane lets you easily move an object onto a surface. Use it also to drag the current selection
around the scene freehand.

1. Create or restore a 3D workspace containing the object(s) to move and the surface onto which to
move it.

2.
 Use Select Design to select the object(s) to move.

3.
 Click Drag on Plane.
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4. On the Status bar, check Check collisions if it is not already checked. If desired, check Gutter and

enter a value to set a gutter between the surfaces that might collide with the object(s).
 

 
5. Click the surface onto which to move the selection. If Check collisions is checked, a green

rectangle defines the area inside which you can move the selection. Note that the cursor is outside
the box, yet the cup remains inside it.
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6. Click inside the green rectangle to set the put-down point of the selection. The selection remains

selected so that you can easily do something else to it, like using Array Copy.
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If you do not check Check collisions, you can drag anywhere in the plane of the surface after clicking it.

Check collisions impacts performance; use it before making many copies. Also, it is designed to work
with flat sides and angled sides; curved sides may cause it to behave unpredictably.

The surface onto which you move the selection must be one piece. If you have trouble placing the
selection, group the pieces of the surface together.

Array Copy Tool for Filling

 Use Array Copy to copy the same design (or group of designs) multiple times in X, Y, and/or Z. It
can also fill flat containers with objects. The example below took fewer than 10 clicks to make.
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Before using Array Copy for filling, make sure the objects are aligned using the Rotate Designs
tool Align with option. Also before using it for filling, group any different surfaces together (such as
planks on a pallet top). If filling a box, if the flaps are closed within one caliper, the tool considers it a
continuous surface. Lastly, the tool does not fill curved surfaces, only flat ones.

When you activate this tool, the Status bar appears as follows:
 

 
Enter any desired gutter in the Gutter fields. Clicking More Options (...) opens the Array Copy Properties
dialog box.
 

 
Any gutter you entered on the Status bar seeds the Gutter fields in this dialog box. Each Offset is the
size of the bounding box for the object(s) you are copying. Margin lets you set a margin between the
object(s) you are copying and the object you are filling. Number lets you set the number of copies and
is limited to 100 to prevent inadvertently making too many copies. Drag plane lets you immediately
drag out the number of copies in X and Y in the design window without being constrained by the object
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you are filling. Stack lets you drag out the number of copies in the Z axis without being constrained
by the object you are filling. Back on the Status bar, Copy makes a copy of the current selection that
remains after the copy. Fill all is unavailable until you click in the tray, at which point if ArtiosCAD
detects partitions, it becomes available.

Clicking OK on the Status bar finalizes the copy.

To use this tool for filling, do the following:

1. Create or restore a 3D workspace containing the object(s) to copy and an object to fill.
2.

 Use the Align With mode of the Rotate Designs tool to align the object you are copying with the
object you are filling.

3.
 Use Select Design to select the object(s) to copy.

 

 
4.

 Click Array Copy.
5. Click the surface to fill.
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6. Click OK on the Status bar to finalize the copy.

 

 

Array Copy Tool for Filling Partitions

 Array Copy also works with partitions.

1.
 Select the object to fill the tray and click Array Copy.
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2. Click inside a partition in the tray. ArtiosCAD turns on Fill All, fills the partitions, and outlines the

partitions in green.
 

 
3. To only fill the partition you clicked in, deselect Fill All.
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4. Click OK or click again inside the tray to finish. Note that since Copy was checked, the original cup

remains.
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5. Repeat as desired to fill other partitions individually.

Array Copy Tool for Stacking

To use the Array Copy tool for stacking, do the following:

1. Create or restore a 3D workspace containing the object(s) to copy.
2.

 Use Zoom out to make room for the drag you will use with this tool.
3.

 Use Select Design to select the object(s) to copy.
4.

 Click Array Copy.
5. Click inside the red top of the cube to copy horizontally.

 

 
6. Drag the desired number of copies in X and Y and click to set the number. The drag is limited to 20

copies in each direction; to make more, click More Options and set the number of copies in the
Array Copy Properties dialog box.
 

 
7. Click Stack on the Status bar and drag the height of the stack.
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8. Click OK on the Status bar to finalize the copies.
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Folding designs

Use the tools in this section to fold a design in 3D.

Fold Angle tool

 The Fold Angle tool allows you to fold designs along selected creases (or other line types).

1. Click the Fold Angle button.
2. Select the crease, bend, perf, cut & crease, reverse crease, 50% cut, or hidden crease lines to fold.

If you want to select more than one line at a time, hold down SHIFT as you select lines, or hold down
CTRL and make a window selection.

3. Now select one of four methods to specify the fold angle:

• To quickly fold the selection at 90 degrees, double-click it. To quickly fold it at -90 degrees, hold
down CTRL and double-click it.

• Enter an angle in the Angle field, or select a predefined angle from the list box.

• Drag the slider to set the angle. The view updates as you drag the slider; performance is directly
related to the capabilities of the display adapter.

• Click Same As and indicate a crease that already is folded at the desired angle.
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You may need to click Scale to Fit to reset the view of the design.

Fold All tool

 The Fold All tool folds all creases (or other foldable lines except bends) in a design at once.

1. Click the Fold All button.
2. Select one foldable line in the design you wish to fold. All the foldable lines that are not bends will

turn magenta to indicate they are selected. To select additional designs, hold down the SHIFT key
and select the desired designs.

To quickly fold the selection at 90 degrees, double-click it. To quickly fold it at -90 degrees, hold
down CTRL and double-click it.

3. Select one of three methods to specify the fold angle:

• Enter an angle in the Angle field, or select a predefined angle from the list box next to the Angle
field.

• Drag the slider to set the angle. You will see an outline of what is being folded.

• Click the Same As button next to the slider and indicate a line that already is folded at the
desired angle.

Shown below is a flat design.
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Next is moving the slider to adjust all the fold angles.

Finally, all creases are folded at 90 degrees.
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You may need to click Scale to Fit to reset the view of the design.

Erect tool

When there is a current selection of at least one type of box that ArtiosCAD recognizes, click
Erect to erect it. There are also Erect tools on the context menu when you right-click over a selected
design. See the Erecting designs section for more information.

• If all the selected designs can be erected and not all are mated and not all are the same style, Erect:
All will be displayed on the context menu only

• If different styles are selected and all are mated, Erect: All and Knock down: All appear on the
context menu.

• If all designs selected have the same style closure, the context menu item(s) display the style name.
• If the selection contain designs with a closure ArtiosCAD does not recognize, the context menu will

not have Erect or Knock down menu items and the Erect tool is unavailable.

1645



14 ArtiosCAD

• Fold 4-panel tube and Erect long side: Gusset fold are not enabled and displayed on the context
menu for selections with different closure styles.

Fold 1 to Meet tool

 The Fold 1 to Meet tool allows you to change angles of folds to make two lines meet. This feature is
used for designs that do not fold at 90 degrees, such as trapezoids.

1. Decide which line to move that will meet another.
2.

 Click Fold 1 to Meet.
3. Click the line that will meet the second line.
4. Click the foldable line whose angle will change so that the lines will meet (the front crease below).
5. Click the line that the first line will meet.

Shown below is the display after using the tool.
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You may need to click Scale to Fit to reset the view of the design.

Fold 2 to Meet tool

 The Fold 2 to Meet tool works the same way as Fold 1 to Meet, except that it changes two foldable
lines at once.

1. Decide which lines should meet after folding.
2.

 Click the Fold 2 to Meet tool.
3. Click the first line that will move.
4. Click the foldable line whose angle will change in order to move the first line.
5. Click the foldable line whose angle will change in order to move the second line.
6. Click the second line that will move.
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You may need to click Scale to Fit to reset the view of the design.

Folding Erected 123 Bottoms

When you change the fold angle of a crease forming the bottom of a 123 bottom, a lock appears next to
the angle slider to show the bottom is locked together. As you slide the slider, the other bottom panels
flex until the angle becomes too great and the bottom pops apart.
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Flap Priority tool

 Flap Priority lets you shue flaps on a closed box to let ArtiosCAD know which flap is visible on
top. It does this by stretching the flap's crease by half a caliper. ArtiosCAD removes the stretch when
you change the fold angle.

To use this tool, do the following:

1. Create or restore a 3D workspace.
2.

  Use one of the Fold tools to close the design. The flaps may not be in the correct order.
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3.

 Click Flap Priority on a flap to move it to the top. Repeat as desired.
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Note:

If you will be using this design with Plato, make sure to set the default in the single design
parameter set for the Bleed/Coating Offsets so that Use 3D flap overlap is checked. This
ensures that Plato gets the correct information.

Flap Priority has no effect for designs erected with recognized mates.

Folding designs with curved creases

ArtiosCAD can fold designs with reasonable curved creases using patented (U. S. patent #8830223)
technology.
 

 

Linked folds
ArtiosCAD recognizes different types of folds as being connected in that you cannot fold one crease
without the other creases folding at the same time.

In the examples below, the arcs meet or almost meet and have a similar radius. Both will fold at the
same angle.
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In the examples below, there are pairs of arcs in-line with straight lines. The angles of the arcs follow
the angle of the straight fold.
 

 

In the example below, the creases are parallel between two faces and fold together.
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In the example below, the parallel folds between the same two faces are treated as one fold.
 

 

Curved perf behavior in 3D
ArtiosCAD tries to tell the difference between perfs that fold and perfs that tear, but as there is no
property to identify this behavior, it has to guess. The figure below shows how ArtiosCAD may behave
in some situations.
 

 

Number Result

1 Perf with sharp angles treated as separate lines. One of the perf
folds; the others are broken.
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Number Result

2 The arc has too large an angle to fold so it is treated as a cut.

3 Smooth curved perf that folds properly.

4 Straight perf that folds properly.

5 Diamond fold made from perf lines that folds properly.

Unsupported 3D designs and workarounds
Designs with curved creases that do not convert to 3D usually rely on features that are not supported,
such as:

• Folds in a place where there is no crease, such as across the face of a panel

• Relies on twist as an essential part of construction.

• Has an arc angle of more than 110 degrees. If the fold angle is bigger than this, the distortion is too
great and the fold is ignored.
 

 

Sometimes these restrictions can be overcome by:

• Adding a crease or a bend line where there isn’t one presently

• Breaking creases automatically when there are more than five connected creases

• Adding bend lines to simulate a twist.

Examples of supported curved crease designs
Shown below are unfolded and folded examples of supported types of curved crease designs. Graphics
are turned off to emphasize the structure of the designs.
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Folding designs with V-notch lines for Re-board®

ArtiosCAD accurately displays V-notch lines with angles from 5 to 60 degrees in 3D.
 

 

Line Type

1 15 degree V-notch crease

2 30 degree V-notch crease

3 45 degree V-notch crease

4 15 degree reverse V-notch crease

5 30 degree reverse V-notch crease
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Line Type

6 45 degree V-notch cut

When folded, the above example looks like this:
 

 

Note:

ArtiosCAD ignores the inside loss of the board when folding V-notch creases and partial cuts.

Partial cuts for Re-board®

When using Re-board
®

, a partial cut or reverse partial cut across a panel folds in the same way as a
partial cut folds when using corrugated or foam. A partially cut hole is formed when the partial cut lines
form a loop. The examples below show how partial cuts look.
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Line Type

1 Partial cut

2 Drill hole

3 Full-depth hole made with cut lines

4 Partial-depth hole made with partial cut lines

The flat design looks like this in 3D:
 

 

Object Construction

1 Partial cut

2 Drill holes

3 Full cut hole

4 V-notch cut

5 Partial-depth hole

Folding Re-board
®

 designs using the Snap Tab/Slot tool

 Designs made with Re-board
®

 typically use slots and tabs for assembly. The Snap Tab/Slot tool
eases this assembly in 3D.

Consider the five-piece single design below. Tab 1 fits into slot 2, tab 3 fits into slot 4, slot 5 fits into
slot 6, and so on.
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One way to assemble this design is as follows:

1.
 Convert the design to 3D.

 

 
2.

 Click Fold All, select all the V-notch creases with a marquee selection, and set the fold angle to
90 degrees.
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Do not close the door yet, as you will need it open to place the final piece.

3.
 Use View Angle to change the view to the other side.

4.
 Use Select Design to select the base.

5.
 Use Rotate Design to rotate the base upward. Double-click the horizontal axis to quickly rotate

it by 90 degrees.
 

 
6.

 Click Snap Tab/Slot, click slot 1, and then click slot 2 to join the bottom support to the base.
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ArtiosCAD assembles the pieces.
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7. With Snap Tab/Slot still active, click slot 1, and then click slot 2 to join the top support to the base.

 

 

ArtiosCAD joins the top support to the base, but aligns it improperly.
 

 
8. Click Next to choose the proper alignment, or use the left and right arrow keys on the keyboard.
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9. Click X to close the alignment selector.
10. With Snap Tab/Slot still active, click slot 1, and then click tab 2 to join the top to the base.

 

 
11. Click Next to choose the proper alignment, or use the left and right arrow keys on the keyboard.
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12. Click X to close the alignment selector.
13.

 Use View Angle to change the view to the other side.
14.

 Click Snap Tab/Slot, click slot 1, and then click slot 2 to join the shelf to the base.
 

 
15. Click X to close the alignment selector.
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16.

 Use Fold Angle to shut the door on the base.
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17. Save the completed assembly and Output it as desired.

Using Mates with the Snap Tab/Slot Tool
Use the Add Mate checkbox on the Status bar of the Snap Tab/Slot tool adds mates to the slots and
tabs as you use the tool for easier connections later should you change the design. It is enabled by
default.

If the associated 2D design is also open, ArtiosCAD adds connected mates to it.

To add mates while using this tool, do the following:

1.
 Click Snap Tab/Slot on the Fold in 3D toolbar.

2.
 Select Add Mate on the Status bar if it is not already selected.

3. Use Snap Tab/Slot as usual. Note that you cannot select a slot that is already occupied or already
has a mate. You will see that after each use, ArtiosCAD shows green connected mates next to each
connection, one for each.
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Note:

If you Undo the snapping of a tab into a slot, ArtiosCAD undoes the mate in 3D, moves designs
to their original positions, and removes the mates from the 2D design if it is open. If you
modified the 2D design independently of the 3D so that it is no longer synchronized with the 3D
workspace, ArtiosCAD does not change the mates and issues a warning.

Snap Tab/Slot tool notes

 The Snap Tab/Slot tool supports many shapes of tabs and slots.

The table below shows the types of tabs and slots ArtiosCAD supports.

Tab/Slot How it is recognized How to use it

Tab

Top is partially flat and
shoulders are parallel

Fits in a hole slot or partial
depth slot

Hole slot

Rectangular hole of cut lines Tab fits in either side

Rectangular hole of partial
cut lines

Tab fits on the inside
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Tab/Slot How it is recognized How to use it

Partial depth slot

Edge slot

Sides must be close to
parallel

Fits in another edge slot or
dual-edge slot

Dual-edge slot

After folding angles at 90
degrees, two parallel edge
slots act as one slot

Fits in another edge slot or
dual-edge slot

Slot on a crease

Cut lines interrupting a
crease

Tab fits inside the slot

 

 

Stackable trays

Cut lines interrupting a
crease

Tab fits inside the slot. Meant
for stacking boxes. It must
have a crease that meets
it somewhere above the
baseline cut and be folded
around 90 degrees.

 

 

Slots between two creases

Between two creases each
folded at 90 degrees

  Between two creases each
folded at 90 degrees
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Tab/Slot How it is recognized How to use it

 

Note:

ArtiosCAD will warn you if the selected tabs and slots are substantially different sizes.

ArtiosCAD supports the following tab shapes:
 

 
 

 

However, there are limits to the tab shape as shown:
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• The parallel lines before and after the tab must be at least 1mm long.

• The tab must be least 2mm wide.

• The start angle of the tab must be at least 45 degrees.

• The side of the tab cannot overhang the base by more than 5mm.

 

 

ArtiosCAD recognizes a tab within another tab in the following cases. You can choose either the main
tab or the tab-within-a-tab.
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ArtiosCAD treats two tabs side by side as one tab.
 

 

 

 

ArtiosCAD supports the following hole shapes for a tab to fit into:
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Use the following considerations when designing a hole:

• Make the hole roughly rectangular.

• Make the hole with 4 to 12 lines.

• Make the hole longer than it is wide.

• Make the hole at least 2mm long.

• Make the sides of the hole approximately parallel.

The Snap Tab/Slot tool also supports dual slots:
 

 

The Snap Tab/Slot tool also supports paired slots in partitions:
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It can also snap shelves into cases.
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Grouped shelves work too.
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It also supports slots in multiple thicknesses of material.
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Note:

The Snap Tab/Slot tool aligns slots and tabs in separate pieces of designs. It does not fold a tab
into a slot in the same piece of a design.

Drag
This tool uses drag to indicate different situations.

Tab
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Hole Slot

Slot

Crease Slot

When using this tool, the cursor changes to a cross-hair depending on whether the cursor is over a
tab or slot and whether the tab and slot will fit together, which is visible in the example for the next
paragraph.

The tool also shows a drag preview showing the destination of the selected design.
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Snapping a Stack of Tabbed Pieces into a Slot

 Snap Tab/Slot can snap a stack of congruent tabbed pieces into the same slot, provided there is
room for them in the slot.ArtiosCAD. It supports up to six layers of material.

 Use Move Point to Point to stack the congruent pieces.

 Click Snap Tab/Slot and hover over one of the tabs. ArtiosCAD shows a larger arrow comprising
the cumulative size of the tabs.
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As you can see, the pieces do not have to be identical; they just have to be congruent.

Shown below are the tabs snapped into the same slot and the mates ArtiosCAD
 

 

Note:

If the 3D workspace was converted from a canvas, and you have more than one stack of
congruent parts, and each stack has different numbers of the same canvas part, you must have
a separate canvas part for each stack in 3D workspace.

You cannot select a slot that is already occupied or has a pre-existing mate.

Folding Retail-Ready Containers

Once you have designed your retail-ready package and made sure to set all the tearing lines' 3D
properties correctly, convert it to 3D as usual.

Select Tear Away Part tool

 The Select Tear Away Part tool lets you select the part of a design that is separated from the main
part of the design. Once it is selected, you can move or rotate it as desired.

1.
 Click Select Tear Away Part on the 3D Tools toolbar.

2. Click the tear-away part of the design. It turns magenta to show it is selected.
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3. Change the position of the part as desired.
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Rejoining the Parts
To rejoin the torn-away part to the base of the design as it was originally, do the following:

1.
 Click Select Tear Away Part.

2. Click a part that was torn away.
3. In the Select Tear-away Part dialog box, choose Switch from the tear-away parts back to the initial

design.
 

1684



14ArtiosCAD

 
4. Click OK.

ArtiosCAD rejoins the parts.

Erecting designs

ArtiosCAD recognizes certain designs and makes them easier to fold all at once as they would in real
life. As of this writing, these design types include:

• Gussets
• Infolds and outfolds
• Beers trays
• Gable tops
• Separate lids that are one of the above types
• 123 bottoms

When ArtiosCAD recognizes a box it can fold, it adds Erect: (and sometimes Erect long side:) and
Knock Down: commands to the context menu when you hover over the container in 3D and right-click.
You may have to erect the container first into a 4-panel tube before ArtiosCAD recognizes its final
form, such as with gable tops.

if you designed your container with mates, ArtiosCAD honors them while erecting the container.
Connect any mates before making an animation.

Some panels may look rigid due to bends not being recognized.

The maximum board caliper for proper folding is A flute or about ¼” or 6.35mm. Gable tops can use up
to B flute. Extreme board thicknesses are not supported.

If you do not want to use the automatic features, select Ignore Connected Folds when converting the
design to 3D to fold it exactly how you want.

Erecting Gussets
Let’s suppose you designed this gusset tray from scratch.

• There are four corners.
• The angles in the gusset are congruent and they are not sharp.
• There are no offset vertical creases or double creases in the gussets.

.
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1.
 Convert it to 3D.

 

 
2. Hover over it, right-click, and click Erect: Gusset fold.

 

 
3. ArtiosCAD sets all the fold angles automatically.
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If you then use one of the Fold Angles tools to change fold angles, ArtiosCAD limits what you can
do because the folds are connected. You may only select the primary folds because the others are
connected. Red areas appear in the tool sliders.
 

 

As you change what’s available, all the connected folds move at the same time.
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If you design an offset between the main panel crease and the connection point for the gusset creases,
the direction of the offset determines how ArtiosCAD orients the flaps. If the connection point is
beneath the crease, the flaps go on the outside. If the connection point is above the crease, or there is
no offset, the flaps go inside. A slight change to the fold angle will cause the flaps to flip. If there is no
offset, Erect long side: appears on the context menu as well so you can choose the side of the box to
which the flaps are glued.

Erecting Beers Trays
Beers trays may have to be mated before you can erect them, but if you used a resizable design
template, the mates are built in.

1.
 Convert it to 3D.

2. Hover over it, right-click, and click Mate: Beers tray.
 

 
3. Right=click again and click Erect: Beers tray on the context menu.
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4. ArtiosCAD sets all the fold angles automatically.

 

 

As with the other types of recognized designs, the connected folds move together when you move one.

Panels bend as they fold to make sure they do not stick out of the bottom of the tray.

If there are extra parts connected to the Beers tray, ArtiosCAD may not recognize them and does
nothing to them.

Erecting creates mates. Disconnect the mates if desired to fold manually. Reconnect the mates to
restore the one-click functionality.

Lids are not connected.

Alternate Beers trays may look more pleasing with thinner boards.

Erecting Infold - Outfold Trays
Infold/Outfold trays work the same way.

1.
 Convert it to 3D.

2. Hover over it, right-click, and click Mate: Infold/outfold.
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3. Right=click again and click Erect: Infold/outfold on the context menu.

 

 
4. ArtiosCAD sets all the fold angles automatically.
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Erecting Gable Tops
Gable tops have an extra step in the erection process: first mate the four-panel tube, then fold it, then
erect the gable top.

ArtiosCAD does not support erecting gable tops with autobottoms.

The maximum caliper that will fold properly for gable tops is B flute.

1.
 Convert it to 3D.

2. Hover over it, right-click, and click Mate 4-Panel Tube.
 

 
3. Right=click again and click Erect: Gable top on the context menu.
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4. ArtiosCAD sets all the fold angles automatically.

 

 
5. If you change fold angles, all the connected folds move with one crease selected.
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Erecting Lids
ArtiosCAD recognizes lids when they are one of previously mentioned types of recognized designs. If
you use a mate, you can assemble the pieces easily.

1. Design the base and lid in single design and add a mate.
2. Convert to 3D.
3. Select one of the pieces, right-click over it, and erect it.

 

 
4. Select the other piece, right-click over it, and erect it.
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5. Use Mate to connect the pieces. Below are the base and lid in transparent mode.

 

 

Erecting 123 Bottoms
1. Convert your 123 bottom design to 3D.
2. Hover over it, right-click, and click Erect: 123 bottom on the context menu.
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3. ArtiosCAD erects the box.

 

 

Knocking Containers Down Flat
Once you have erected a container, you can knock it down flat with one click on the context menu.

1. Hover over the erected container and right-click it to show the context menu.
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2. Click Knock down: <box type> on the context menu.
 

 
3. ArtiosCAD knocks the container down flat.

 

 

Bend tool concepts

Bend panels differ from curved crease panels in that the panels themselves bend around something,
not just the creases. Bend panels:

• Are defined by one or two bend lines, which in the default plotting style are red dot-dashed lines

• Have an angle changed by the Bend tool

• Do not have curved creases.

Bend lines divide the design into panels, and have fold angles in 3D the same as creases, but:

• They are not real creases
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• Are not structural and can be hidden in the 3D Assist layer. (You will get a warning about the lines
not being appropriate for the layer type but you can ignore that.)

• Do not have a crease bead

• Are not intended to be folded at a sharp angle.

In the design below, bend panels are marked 1 and bend lines are marked 2.
 

 

Types of bend panels

There are two types of bend panels: a cylindrical bend panel and a conical bend panel.

The bend panel is cylindrical if there is just one bend line or the bend lines are parallel.

The bend panel is conical if there are two bend lines that are not parallel. The bend lines should not
meet.

In the example below, the left panel is a cylindrical bend, and the right panel is a conical bend.
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In 3D, they become:
 

 

Using the Bend tool in 3D

To use the Bend tool in 3D, do the following:

1. Create a single design or open an existing one with bend lines in its 3D Assist layer.
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2.

 Click Convert to 3D on the Tool Rack.
3. In the Add Unfolded Design(s) dialog box, click inside the base face and click OK.
4.

  Use the Fold Angle or Fold All tool to fold the creases in the design.
 

 
5.

 Click Bend Panel and then click one of the bend panels.
6. The bend panel turns magenta to indicate it is selected and an Angle field and slider appear on the

Status bar, along with a Radius field.
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7. Change the Angle for the bend by either entering a value in the field, choosing a preset value from

the drop-down list box, or by using the slider as shown below. You can also change the bend by
entering a value in the Radius field.
 

 
8. When you are satisfied with the bend of the first panel, click the second panel and adjust its bend,

and repeat for the remaining panel(s).
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9. Shown below is the completed bend sequence.

 

 

Note:

A bend angle of 180 means it is flat. A positive bend angle has the print side on the outside of
the bend, while a negative bend angle has the print side on the inside of the bend.
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Mates

Manual glue/mate area concepts

The Glue/Mate area tools are designed to make it easier to connect designs together in 3D, and to
indicate where glue will be applied to a carton as it is manufactured. There are two types of mates,
panel mates and edge mates. Panel mates connect the flat surfaces of the container while edge mates
connect the edges.

Starting with ArtiosCAD 20, ArtiosCAD recognizes some designs, and creates the mates automatically
when you start to define mate areas. Automatic mates are explained later in their own section.

You define mate and target areas in Single Design and then when you convert to 3D, ArtiosCAD can
automatically join the two areas, or you can join the areas manually. The rules for finding the matching
area are:

• A mate/glue area mates with a target area. They must each be completely inside a panel.
• You can click either the mate or the target after starting the Make Mate tool.
• The mate/glue area must have the same name as the target, but the name may be blank.
• The mate/glue area and the target area must have identical lines, but they may be oriented

differently or mirrored.

Rectangles are sucient to define most mate areas, but for really specific needs, use an asymmetric
shape (such as a rectangle you moved a point on to have a diagonal side).

Mate types:

• Dynamic mates are on cartons based on 4-panel sleeves with flaps, or those on cartons made of
two pieces that form 4-sided tubes, or other recognized designs. Once these types of mate areas
are mated in 3D, the cartons behave as if the folds are connected, and adjusting fold angles on their
creases affects the connected panels.

• Static mates glue two designs together without affecting fold angles. If you attach two designs
outside to outside or inside to inside, the target should be a mirrored copy of the mate area. The
smaller design moves to mate with the larger design.

 You can also add mates automatically when using Snap Tab/Slot by enabling Add Mate on its
Status bar.

ArtiosCAD shows unconnected mates and targets in blue and red, and connected mates in green. Turn
them on using Show mate areas in the View Mode.

For glue areas, you define them in Single Design the same way as you would a mate area (except
specifying Glue as the Type in the Mate Properties dialog box) and then ArtiosCAD automatically
shades that area in 3D when mate areas are turned on in the View Mode.

 If your 3D workspace has many pieces with mate and target areas defined, click Mate All to
mate them all together with one click. It will only connect mates automatically if it finds no conflicts.
ArtiosCAD warns if it finds multiple targets and prompts you to use the Mate tool to connect mates.
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 To disconnect a mated area, click Disconnect Mate, and then click inside a green mated area.
You may have to turn on mated areas in the View Mode beforehand. ArtiosCAD disconnects the mate
and target areas and turns them blue and red. If there are multiple copies of designs and all the mates
are connected to all designs, ArtiosCAD disconnects only the mates you click and leaves the others
connected.

ArtiosCAD moves mated designs as a group in the Move, Rotate, and Drag on Plane tools, but not in the
Copy tools, where ArtiosCAD treats them singly.

Deleting a design with mates turns off the mates in other designs that were connected to mates in the
deleted design.

The mate tools recognize matching mate and target areas on stacks of designs. The designs do not
need to be stacked as long as all the designs and mate areas are not mated to other target areas.

ArtiosCAD saves information about copies of canvas parts mated to other parts to the associated open
canvas so that if you convert the canvas to 3D again, the parts mate together as before.

Note:

3D workspaces with mates are not recognized by pre-16.1 versions of ArtiosCAD. 2D
workspaces prompt pre-16.1 versions of ArtiosCAD to find an unknown command in the logfile
and the mate does not appear in the file when it opens.

Defining Mate and Target areas
To define mate and target areas in a single design, follow this recommended workflow:

1. Create a new single design or open an existing one as desired.
 

 
2.

 Use the Rectangle tool to draw the Mate area.
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3.

 Use the Select tool to select the lines comprising the rectangle.
4.

 Click Define Mate Area. The tool starts and the following controls appear on the Status bar.
 

 
5.

 Click Make Mate on the Status bar. The rectangle changes color and is moved to the 3D Assist
layer automatically.

6.
 Click Properties.
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7. In the Mate Properties dialog box, assign a name such as area1 in the Name: field. The name of
each mate and its target must be the same, but the name can be blank. Set the font and size for
the label as desired. In the Type group, select Mate. In the Side group, select Outside. Select Show
name and Show side as desired. Click OK to close the Mate Properties dialog box.

8.
 Use the Copy tool to copy the rectangle to the target panel.

 

 
9.

 Once the copy is placed, click Define Mate Area.
10.

 Click Mate Properties.
11. In the Mate Properties dialog box, set the Type to be Target, set the Name to be the same as the

name you specified for the Mate (such as area1), set the side to be the Inside, set the font and size
fields as desired, and check or clear Show name and Show side as desired.

12. Click OK to close the Mate Properties dialog box.
13. Save the design.
14. The design now has mate and target areas defined and can be folded in 3D either automatically or

manually.

Adding Mates Panel by Panel
You can also create mates by selecting a panel in which to create a mate, and then dragging its
automatically created matching mate to the desired location. The target mate flips and the handle
changes depending on how you picked it up and how you drag.

Note:

Some manual rotation and moving may be necessary after placing the target mate to position it
exactly as desired.

1. Create your design in Single Design as desired.

1705



14 ArtiosCAD

2.
 Click Define Mate Area.

3.  Click Select a panel on the Status bar and then click inside the panel that is one half of the
mate.

4. Drag the outline of the target mate to the desired panel and click to put it down. It will change
position based on the center of the line you snap against for the put-down point. If snap does not
behave as expected, make sure the line you are snapping to is really one line. As noted above, some
manual adjustment may be necessary.
 

 
If you are working in a canvas and drag the target to a panel in the same part, it will be a dynamic
mate (for folding). If you put the target mate in a different part, it will be a static mate (for joining
two parts).

5. ArtiosCAD automatically names the pair of mates appropriately and sets their types.
 

 
6.

 Convert the design to 3D.
7.

 Click Mate.
8. Click the mate and then its target.
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9. ArtiosCAD connects the mates (they turn green) and folds the design.

 

 

Folding a design with a mate and target area
Once you have a design with a mate and target areas defined, convert it to 3D. For the purposes of
these instructions, make sure to deselect Use previous fold angles if it is selected when converting to
3D.

Once the design is in 3D, do the following:

1.
 Click Mate. The mate and the target areas on the design become visible; the blue area is the

mate and the red area is the target.
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2. Click inside either the mate (blue) or the target (red) area.
3. ArtiosCAD joins the mate and target areas and turns them green. Since this is a dynamic mate due

to the carton being based on a 4-panel sleeve, the panels behave as if they are connected to each
other. When you adjust fold angles affecting one of the joined panels, the other panels move as well,
just as they do in real life. Note that there are no limits on this movement and you may unexpectedly
encounter less than optimal results.
 

 
4. Change the View Angle and continue working on the design as desired.
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Attaching two designs in 3D using Mate and Target areas
This is an example of another dynamic mate. Attaching these two pieces together forms a four-sided
sleeve.

1. Create the two pieces in Single Design that will be mated together in 3D.
2. As there are two attachment points, create two mate areas and copy them to two target areas.

 

 
3.

 Click Convert to 3D on the Tool Rack.
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4. In the Add Unfolded Design(s) dialog box, click inside each base face and click OK.
 

 
5. The two designs are brought into 3D.
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6.
 Click Mate All in 3D. The two pieces join together at their mate areas; turn on Show mate

areas in the View Mode and they both will be green to indicate that the mates and targets joined
successfully.
 

 
7. To see how the panels move together in this dynamic mate, change the fold angle of the crease

folding the card in half.
 

 

If you would rather use the Mate tool to connect the mates manually, or if the mates and target areas
in separate designs do not have matching names or shapes, the cursor changes to a mate cursor when
you hover over a target area that is a possible mate.
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When you hover over an area that is not suitable for a mate, ArtiosCAD shows a stop cursor.
 

 

Attaching a solid to a carton in 3D
Solids cannot have mate or target areas defined, yet you can attach them to cartons that do by doing
the following:

1. Bring all the pieces into 3D.
 

 
2. Mate the card pieces together, change the View Angle, and turn on Show mate areas in the View

Mode.
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3.

 Click Extend and click the solid to turn on its extend points.
4.

 Click Select Designs and select the solid.
5.

 Click Move Point to Point and move the solid to within 5mm of the mate area. In this example,
choose a pick-up point in the middle of the bottom of the clip. When you get close to the mate area,
a put-down point appears in its center, as seen in the close-up below.
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6. Click the put-down point. You may need to use the Rotate tools to get everything aligned to your
satisfaction. The finished example of the card with a clip inside of it is shown below.
 

 

Deleting Mates

 Use Delete Mate on the Fold toolbar (or Tools menu) to delete a mate from a 3D design as well as
its associated 2D design if it is open. It does not change fold angles or the positions of designs.

To use this tool, activate it, and then click the mate to delete.

• If you click over a group of connected mates, ArtiosCAD highlights and deletes all of them.

• If you click over a disconnected mate, ArtiosCAD deletes only that mate.

• If you click over a mate in a design that has multiple copies, ArtiosCAD highlights and deletes the
mate in each copy. If all copies of the design have disconnected mates, ArtiosCAD deletes only the
one you clicked.

Panel Mate concepts
Panel mates help recreate a 3D scene after a rebuild by connecting two different designs that touch
along a panel. Use them to define the spatial relationship between the two designs by defining anchor
points, one in each design. They work best when you choose anchor points relevant for each design
that will not change in a rebuild. This tool has an advantage over adding mates in 2D in that you do not
need to figure out panel orientation to use it.

Before starting this tool, position the two designs so they are touching each other.

Creating a Panel Mate
To create a panel mate, do the following:
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1.

 Click Panel/Edge Mate on the Fold toolbar.
2. Hover over the abutting panels in the two designs to connect. ArtiosCAD turns allowable panels

green.
 

 
3. As you move the cursor around inside the panel, ArtiosCAD snaps to different suggested anchor

points and connects them with yellow lines. Choose points that will most likely not change after a
rebuild, like the center points of the two vertical lines shown below. Position the mate as close to
the anchor points as you can so that both pieces are in the proper relationship after a rebuild. Green
extension lines show a good position, while orange ones show a less desirable but still acceptable
position. Click to set the mate.
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If you are not using rebuildable designs and/or have no plans to rebuild in 3D, you can ignore the
anchor points and create the mate as desired.

4. ArtiosCAD shows a connected mate where you clicked.
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Notes on using Panel Mates
After a rebuild, the designs should share the same relationship to each other as they had before the
rebuild. You may need to use the Mate tool to reconnect the mate if it becomes disconnected, but if so,
they will snap together and you will not need to use any of the manual positioning tools.

If you do not have the associated 2D open, ArtiosCAD does not show anchor point feedback, but it still
creates the mates in the 3D design, one of type Mate and one of type Target.

When you create a mate in a design with copies, ArtiosCAD creates a disconnected mate in the same
location in each copy.

You can reuse an existing mate and have ArtiosCAD create its corresponding mate on the other
design. ArtiosCAD sets the names to match and the new mate has the opposite type to the first mate
(either Mate or Target). This is useful when connecting multiple copies of the same design to multiple
different locations, such as a display base with multiple copies of the same shelf. The feedback in this
case shows only one anchor and locks on to the existing mate.

You cannot mate tear-away designs.

You cannot reuse mates made by Snap Tab/Slot, nor can you reuse two mates on top of each other.

You cannot mate two designs that are already connected by mates.
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Panel mates work only on two different designs. They do not work on different panels of the same
design.

You may not make mates over holes.

ArtiosCAD saves mate connection information to the associated 2D design at the same time it saves
fold angles. This is so you can create the desired scene in 3D, close the 3D without saving the fold
angles, and reconvert the 2D and have everything flat again. The mates will be there but you must
explicitly reconnect them.

Using Edge Mates
The Panel Mate tool can also make edge mates, which connect two parallel panels in different designs.

1. Position two designs close to each other with the desired connection panels parallel.
2.

 Click Panel/Edge Mate.
3. On the Status bar, choose Edge mate.
4. Select the first panel to mate, and then select the second panel to mate.
5. ArtiosCAD connects the two panels.

Automatic mate concepts

Starting with version 20, ArtiosCAD can recognize certain types of designs and make it easy to create
mates in Single Design, and then when you convert them to 3D, makes it easy to turn them into folded
designs that are easy to erect, fold, and knock down flat.

ArtiosCAD recognizes:

• 4-panel tubes with glue flaps
• 4-panel tubes with one diamond fold
• Auto-bottoms, both full flap and in-turn

 ArtiosCAD scans your single design or active part in a canvas when you use Define Mate Areas, and
adds Select Recognized Mates to its status bar.
 

 
If it recognizes mates, it enters Select Recognized Mates mode and shows the recognized mates it
found.
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Adding Automatic Mates
When you are ready to add mates to the single design or active part in a canvas, do the following:

1.
 Click Define Mate Area.

2. ArtiosCAD scans the geometry, and if it recognizes it, displays suggested mates in green.
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In this example, there are suggested mates for the glue flap and between the inturn flaps of the
autobottom and the dust flaps.

3. Hover over a mate to show it is selected. ArtiosCAD turns it and its target mate magenta.
4. Click the mate to create it. One will turn blue and the other will turn red. ArtiosCAD assigns each

mate pair a unique name and numeral.
5. Repeat for any other recognized mates. In this example, there is a pair of mates for the glue flap,

and a pair of mates for each inturn flap.
 

1720



14ArtiosCAD

 

Converting a Design with Recognized Mates to 3D
When your design is ready to convert to 3D, do the following:

1.
 Click Convert to 3D on the View bar.

2. In the Add Unfolded Design dialog box, select a base face if there is not already one selected. Do
not select the inturn flap. You may wish to deselect Use previous fold angles if it is selected so that
previous fold angles do not interfere with erecting the recognized design.
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3. Click OK and the design appears in 3D.

 

 

Erecting a Design with Automatic Mates
Once your design is converted to 3D, do the following:
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1. In 3D, right-click over the design. It will turn magenta to show it is selected and on the context menu
will be Mate commands for the type of box ArtiosCAD recognized it as.
 

 
2. For this example, click Mate Auto-bottom. ArtiosCAD automatically joins the mates and erects the

auto-bottom. You may need to redraw the screen to have it centered properly.
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3. Now that the design is erected, you can knock it down flat by right-clicking it and then clicking
Knock Down Auto-bottom.
 

 
4. ArtiosCAD knocks the box down flat.
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Note:

Erecting and knocking-down flat only affect the main panels of the design. Any folds you make
to other panels will remain as you set them and the results may not be what you expect.

Changing Fold Angles in Erected Designs
After you have erected a recognized design, since the panels are mated together, ArtiosCAD limits
the range of folding between the main panels with a shrunken slider, a red highlight, and the wording
Limited by mate. The picture below shows what happens when you try to adjust the select fold with
Fold Angle.
 

 

If you tried to use Fold All, the limit would apply to the entire range.
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Notes and Warnings About Recognized Designs
Please keep the following considerations in mind when working with automatic mates and recognized
designs.

• Not all auto-bottoms will work. For example, Houghland auto-bottoms are not true auto-bottoms
and are not a recognized auto-bottom. They can be 4-panel tubes but the end result will not work
well.

• Don’t use fold-back flaps as base faces when converting to 3D. ArtiosCAD internally changes the
base face away from an auto-bottom flap. When converting to 3D, an auto-bottom flap when
selected for the bottom will still be on the floor, but the base face may change to the flap's adjoining
panel.

• Mate and fold designs before duplicating them. Sometimes when mating designs after making
duplicates, the design rotates to the underlying base face.

• Sometimes when redoing mating designs after an undo of a duplicate, the design will rotate to the
underlying base face.

• When working with animations, ArtiosCAD discards the frames before a mate is connected, but the
in-between state of erecting and knocking down flat should work.

• When working with tear-aways, set perfs and zipper rules to Indent only on the 3D tab of their
Property dialog box in Single Design.

• Tear-away animations and auto-bottoms are mutually exclusive. Use one or the other but not both.
• Do not use perfs in a glue flap as this will disrupt panel recognition. Use glue assist lines instead.
• Using wave rule in a design outline can also interfere with proper panel recognition due to small

gaps.
• Do not use 0-caliper boards for designs with mates.
• Only create mates when the design size is complete. Avoid making size changes using Stretch by

Polygon after adding mates. If you change the design size after adding mates, delete them and add
them again. Trying to resize mates by stretching panels with and without mates in the selection and
also trying to keep Single Design and 3D in sync will have unpredictable results.
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• If you will be exporting a knocked-down flat design to Cape Pack, rotate it so the blank size is on the
XY plane.

• Some version 20 designs with automatic mates may not be recognized properly as having mates in
earlier versions, especially in 3D.

• Fully close any auto-bottom you intend to use with Artwork Panels in Single Design in order to pass
it the correct panel information.

• If you experience errors when resizing auto-bottoms with bleeds, do this:

• Resize the design
• When the resize fails, discard the remaining commands
• Delete the bleed
• Make the bleed again

• Don’t manually delete mates from pairs of mates. Delete both and re-add the pair.

• Designs with mates and curved creases between the panels may look like recognized designs but
are not.
 

 
They appear mated when you close them, but will behave unpredictably, especially when you
change fold angles of a curved crease.
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Using the Copy Times tool with Mates

Using the Copy Times tool with Mates
When copying mates in a canvas, the Copy Times Offset tool updates the mate status for the opposite
mate. This allows standards to be written with a variable number of parts, and have those parts mate
correctly in 3D.

Only experienced users would be expected to be able to write such a standard; a number of steps are
needed to make this work, such as scaling unwanted geometry to scale 0. Here are the steps for mates.

There is a “main” part that has multiple identical holes or slots, and a “shelf” part which has multiple
copies. Each copy of the “shelf” part will be mated to a hole or slot in the “main” part.

Note:  At the end of this page we show an example when there are no slots, in which case we
use the panel mate tool.

The “main” part and the “shelf” part need to be in the same canvas.

1. The number of “shelves” is a variable in StyleMaker such as N or NSH (the display filler tool requires
the variable be NSH); and the variable is of Type Angle or Number.

2. The number of copies of the “shelf” part should be set to this variable.
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3. Convert to 3D should get the correct number N or NSH of copies of the “shelf” part.
4. Use the Snap tab into slot tool or the Panel mate tool to position the first copy and make a mate.
5. Use the Copy Times tool to make the required number of copies, N-1 or NSH-1.
6. The Copy Times tool should update the properties of the mate in the “shelf” part so that number of

copies occupied reflects the number of copies you just made.

This example uses the Snap tab into slot tool:

1. Click a tab/slot in the “shelf” design and then click a target slot in the “main” design:
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2. Resulting mates in both parts:

 

 
3. Close the 3D. Look at the mates created in the canvas:
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4. Select “Main” as the current part. Use the Copy Times Offset tool to make the required number of

copies.
 

 
5. Use the Copy Times Offset tool to get the required number of mates and set the opposite mate

properties.

If the shelves are

• the same height: Set the distance to line it up immediately, and skip the next step.
• different heights: Use a distance such as 170mm, a bit less than you need to align.
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6. If the shelves are different heights: Use the Move tool to move each of the copied mates to the

correct position.
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Note:  Each mate may not exist when you rebuild depending on the number of shelves. In the
Edit log, the command logged for moving the mate looks something like this:

trans (:O8:P1:U1:CT2,5)  group from HANDLE(`(:O8:P1:U1:CT2,5)`,4) pos
        MIDPT(:S:U:P1:U1:C26:I2:I1:I2,13)

Item (:O8:P1:U1:CT2,5) may not exist, but the trans command with a HANDLE pickup point
will not error.

Using the Panel Mate tool (when no slots)
Here is an example where there are no slots; you can use the Panel (/Edge) Mate tool instead of the
Snap tab into slot tool. The Panel Mate tool creates two mates to align adjacent panels in two different
designs.

In this example the first shelf is part of “Main”, so the number of copies of the “shelf” part is NSH-1.

1. Align the first copy of the shelf using the Move Designs tool:
 

 
2. Then use the Panel Mate tool:
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3. Close the 3D. The panel mates that were created in 3D have the correct properties but only

approximate positions, and the anchor points chosen by the tool could be wrong.

Move the panel mates in 2D to positions which will be accurate for a Rebuild.

Some examples:

• For this design to align, align the bottom center of the mate vertically and centered horizontally:
 

 

• For this design to align, the mate in the “shelf” part needs to be centered horizontally and half a
caliper above the crease:
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• For this design, because the bottom shelf is part of the main design, the number of copies of the
shelf is NSH-1. Use the Copy Times Offset tool to make NSH-2 copies of this mate.
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Use the Move tool to move each of the copied mates to the correct position, in the same way as
the first example.

Supported mates

Mate type Carton type Description Automatically
recognized?

Can use
mates?

Mate Target

Dynamic 4 panel sleeve 4 panels + glue
tab where glue
tab mates with
4th panel

Y Y glue tab 4th panel

4 panels + 1
diamond fold

Y Y Glue tab 4th panel

Standalone
display

Large glue tab
mates with
opposite panel.
Mate brings
the curved
fold in proper
alignment. See
Figure 1.

N Y Glue tab Opposite
panel
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Mate type Carton type Description Automatically
recognized?

Can use
mates?

Mate Target

Auto-
bottom(s)

As described
in Automatic
mates

Y Y 2 fold-back
flaps, glue
tab

Bottom
flaps, 4th
panel

Static Pop-up card 2 parts, 2
mates. Need
crease. 3D
panel mate
cannot be used
as it uses just
a single mate
to bring two
parts together,
which is all
the 3D panel
mate needs,
ignoring the
panels created
by the crease.
See Figure 2.

N Y Inside
mates on
glue tabs
of inner
card

Two target
mates on
outside
card
of type
outside
target

Standalone
display

Attach header,
tray. Mates
across two
different single
designs can be
brought into 3D
and mated as
static mates.
3D Panel mates
could also be
used

N Y Separate
part

Main body

Canvas/Parts Panel from part
1 can be mated
to part 2.
Current mode
of copying
the mate
as a target
will require
disconnecting
from the
source part
and moving to
the destination
part. Move the
mate geometry
instead of
copying it. See
Figure 3.

N Y Panel in
part A

Panel in
part B
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Mate type Carton type Description Automatically
recognized?

Can use
mates?

Mate Target

Not
supported

Pharma,
seal end
enclosures

N N

4, 6 corner
tray

4, 6 glue points N N 4, 6 glue
flaps

4, 6 side
panels

Hexagonal
auto-bottom

N N

Tab and slot
as dynamic
mate

Rollover tray,
tab can be
mated to its
own slot

N N

4/5 panel
sleeve with
more than one
diamond fold

See Figure 4. N N

Figures
Figure 1, a standalone display.
 

 

Figure 2, a pop-up card.
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Figure 3, canvas/part mates.
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Figure 4, multiple diamond folds.
 

 

Undo and Redo

If you unintentionally move a design in a way you don’t like, or fold a flap too much, use the Undo
command on the Edit menu to reverse your incorrect action. Use Redo to redo the action undone. Undo
and Redo work on the following tools:
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Table: Tools affected by Undo and Redo

Affected Not Affected

Moves and rotations All tools on the 3D View and View Mode toolbars

Fold angles, Fold to Meet Select tools

Copy, addition, deletion of designs Light Source

Group, Ungroup Material Properties

Dimension tools Extend, Clear Extend

Intersect Design Animation tools

Cross Section Bounding Box

Run a Standard

Changing how you view the workspace

Use the tools on the 3D View toolbar to change how you view the design in 3D.
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Zoom Rectangle tool

 The Zoom Rectangle tool lets you view a portion of your workspace at an increased scale.

1. Click the Zoom Rectangle tool.
2. Move the mouse cursor to a corner of the area to zoom in upon, hold down the mouse button, and

drag to the diagonally opposite corner.
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3. Your screen changes to show a close-up view of the area you selected.

Center-Point Zoom tool

 The Center-Point Zoom tool, when clicked, prompts you to click the center of an area to be
zoomed in upon, and then to drag to the corner of that same area. Release the mouse button to
perform the zoom.

Zoom Out tool

 Click the Zoom Out tool to view your workspace at a smaller scale.

Zoom In/Out tool

 Use the Zoom In/Out tool to change the zoom level by dragging the cursor in the workspace. To
use this tool, do the following:

1.
 Click the Zoom In/Out tool.

2. Click inside the drawing window of ArtiosCAD.
3. Click and drag the mouse up to zoom in or down to zoom out. Alternately, use the up and down arrow

keys to incrementally zoom in and out.

This tool remains active until a different tool is clicked.

Scale to Fit tools

 Click the Scale to Fit tool to show the entire workspace at the largest scale possible within the
borders of the window. When held down, it activates the Scale to Fit tools flyout toolbar.
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 Click the Scale to Fit with Border tool to put a border around the scaled-to-fit view. The size of the
border is configured in Options > Defaults > Startup defaults > View tools options.

Pan/Zoom tool

 The Pan/Zoom tool lets you grab a location on the screen and drag it as desired in Pan mode, or
zooms in and out according to the direction you drag (up or down) when in Zoom mode. To use it in
Pan mode, click it, click and hold a location on the screen, and drag to the new location. Click the right
mouse button or press ESC to exit the tool and return to the previous tool used. The cursor looks like a
clenched hand while dragging.

Note:  If you use the Pan/Zoom tool in high graphics mode, you must refresh the screen by
pressing F2 to re-render the graphics.

To use the Pan/Zoom tool in Zoom mode, click it, click Zoom on the Status bar, position the cursor
in the desired area, and then drag the cursor up to zoom in or down to zoom out. This tool does not
interrupt the tool being used before it was clicked. Click the right mouse button or press ESC to exit the
tool and return to the previous tool used.

Press TAB on the keyboard to change between Pan and Zoom modes without clicking their respective
option buttons.

To exit the Pan/Zoom tool in either mode, either click the mouse button, press ESC on the keyboard, or
activate another tool. The previously-used tool will resume operation.

If you have a three-button USB mouse with a scroll wheel, using the scroll wheel at any time zooms in
or zooms out as if you were using the Pan/Zoom tool in Zoom mode. Holding the middle mouse button
down and dragging the cursor pans the view as if you were using the Pan/Zoom tool in Pan mode.

View Angle tool

 Change the view angle, elevation angle, and roll angle at which you view this design by using the
View Angle tool. You can set the values using four methods:

1.
Enter a degree measurement in the  Angle,  Elevation, or  Roll Angle field and press enter;

2. Select a predefined angle from a list box;
3. Drag a slider to set the value. As you drag the slider, the view changes accordingly.
4. Click and drag inside the drawing window. All three View Angle elements change accordingly. Use

the arrow keys to rotate incrementally, or hold down CTRL to change the roll angle with the arrow
keys.

Note that this tool does not change the physical location of the designs in the workspace. It only
changes how you see the workspace.

Some of the sliders may not be visible if the ArtiosCAD window is not wide enough. Make the ArtiosCAD
window wider to show them.
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The View Angle tool can interrupt other tools. Click the tool and use it as desired, then either click the
right mouse button or press ESC to return to the previously-used tool. This is especially useful when
moving or aligning objects as you can change the view to reveal more pick-up or put-down points.

Shown below is a design before the view angle is changed.

Shown below is the design after the view angle has been changed.
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You may need to click Scale to Fit to reset the view of the design.

3D Quick Views

 3D Quick Views in the View Angle tool let you save combinations of the angle, elevation, and roll for
easy access later.

When you click Quick Views, a list of Quick Views you have already defined appears. Click a Quick View
to use it.
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Isometric is the classic ArtiosCAD view of 30, 30, 0.

To define a new Quick View while in 3D, do the following:

1.
 Use View Angle to set the view as desired.

2.
 Click Quick Views at the left end of the Status bar.

3. Click the plus sign (+).
4. Enter a name for the Quick View. If you decide to change it, double-click it while it has a white

background. Quick Views with gray backgrounds can only have their names changed in Defaults.
5. Click Close. ArtiosCAD saves the new Quick View to User Defaults.

Next and Previous View tools

  The Next View and Previous View tools let you switch between views once you have used
the View Angle tool to change the view. ArtiosCAD remembers eight previous views by default, but
you can configure ArtiosCAD to remember up to 100 views in Options > Defaults > Startup defaults >
View tools options. Click Previous View to go back to previous views from the most recent view and
click Next View to go forward to the most recent view from previous views. These two tools interrupt
whatever tool was previously active; when the view changes, that tool becomes active again.
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These tools are designed to work by allowing you to stack several different views, activate a tool such
as the Move Point to Point tool, choose a pick-up point in a previous view (or the current view) and then
choose a put-down point in the current view (or a previous view).

Rotate View tools

 The Rotate Right and Rotate Down tools on the Rotate View tools flyout toolbar rotate the
view by 90 degrees in the specified direction.

Orthogonal View tool

 The Orthogonal View tool snaps the view to the nearest multiple of 90 degrees on all three view
angles. This tool turns perspective off. The picture below shows the view before clicking the tool. Note
the values in the view angle fields on the Status bar.

Shown below is the same workspace after clicking the Orthogonal View tool.
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Note:  Boards drawn thinner than 1 pixel may not appear in all orthogonal views when using
OpenGL as the rendering method. Change the board thickness or view scale if necessary.

Perspective tool

 Perspective is the technique of making parallel lines meet at a point on the horizon in order to
make the scene look more realistic. Change the amount or use of perspective using the Perspective
tool.

1.
 Click the Perspective tool.

2. To use less perspective, drag the slider to the left. To use more perspective, drag the slider to the
right.

3. To toggle the use of perspective, select or clear the Perspective checkbox in the Status bar. You
can also turn Perspective on or off using the icon on the View Mode toolbar or through the checkbox
in the View Mode dialog box.

Shown below is a design using no perspective.
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Shown below is the same design using normal perspective.
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Shown below is the box with maximum perspective.
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Lighting

Light Source tool

 The Light Source tool lets you add and remove light sources, and also change their positions. The
light sources control the shading of the graphics and colors in the workspace. This tool is unavailable in
Wireframe view mode. When the tool is active, the Status bar changes to look like the picture below.

If your ArtiosCAD screen is more than 70% of your screen width, the Brightness control appears. It
affects all the lights. To change just one light, double-click it and use the vertical color brightness
slider on the right.
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When the tool is started for the first time, three lights appear in the workspace, one in front of the
design, one in back of the design, and one above the design. The fill color shows their current color.

The active light has a magenta outline. In the example above, the light bulb near the bottle is the
current one. Click a light to select it.

 To add a light, click the Add Light tool on the Status bar and then click to set the position of the
new light. The new light becomes the active light. Each workspace can have up to eight lights.

 To remove a light, click the desired light to select it and then click the Delete Light tool on the
Status bar. You cannot delete the last light.

To change the position of a light, click it and drag it to its new position, or use the controls on the
Status bar. When dragging a light with the mouse, there is a front position and a back position that
correspond with the current cursor position. Drag the light to the left or right edge of the workspace to
switch between front and back positions.

To change the color of a light, double-click it, and choose the new color from the standard Windows
color selection dialog box. Before you change the color, consider adding the current color to the list
of custom colors so that you may revert to it if desired. The light’s custom color is saved with the
workspace, but is not saved in the color palette.
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Shown below is the same workspace, with the first picture showing a light source beneath and behind
the designs, and the second picture showing two additional light sources above and in front of the
designs.
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Light Source Tool Defaults
You can set default colors and placement of the light sources in the Light Source tool. This information
is also saved in the 3D workspace so that if someone opens the design on another system, the light
source(s) appear as you intended if that person has his/her Defaults set to use the settings saved in the
file.

If you close a 3D workspace while you still have its associated single design workspace open, or use
Update 2D, ArtiosCAD saves the light source information in the single design workspace in addition to
saving it in the 3D workspace.

Setting Light Source Defaults
To set the defaults for the Light Source tool, do the following:

1.
 Create a 3D workspace and use Light Source to arrange the lights and their colors as desired.

2.
 Click Save lights default on the Status bar. This saves the current lights configuration to the

Startup defaults catalog in User Defaults.
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Copy that entry to Shared Defaults if desired. However, you cannot change its contents inside
Defaults; you must do that while working in a 3D workspace.

Getting Light Source Defaults
To restore the Light Source settings in a workspace to their defaults, do the following:

1.
 Open the 3D workspace and click Light Source.

2.
 Click Get lights default on the Status bar. This resets the workspace's current Light Source

settings to the defaults.

Default Settings for Light Source Defaults Behavior
When you restore a 3D workspace, ArtiosCAD normally uses the Light Source settings saved in the
workspace. However if you would prefer to always use your own settings, change the settings in the
Light source on open *.A3D and Light source on convert to 3D groups in the 3D View mode entry in
the Startup defaults catalog.
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Ambient light
Ambient light is the default light that suffuses a workspace that is not provided by a light source. To
change it, click View > Ambient light, and choose the new color. Before you change the color, consider
adding the current color to the list of custom colors so that you may revert to it if desired. The custom
color is saved with the workspace, but is not saved in the color palette.
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Ambient light has low contrast. The light bulbs of the Light Source tool have much more contrast.

Status bar

The status bar displays various messages and tool controls. When you position the mouse pointer
over a tool button, for example, a short description of the tool appears at the left end of the status bar.
The middle portion of the status bar returns a status message about the action just completed. For
example, if you click the Move Designs or Rotate Designs tool, you will be prompted at the left end of
the status bar to select a line and then an axis. After you select a line or axis, the right portion of the bar
shows what was selected.

Setting the View mode

 The View mode controls many aspects of how designs are viewed in 3D. Click View Mode on the
View menu or click the button on the 3D View toolbar.
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Many of the option buttons and checkboxes on the left side of the dialog box are duplicated by tools on
the View Mode toolbar. The topmost or leftmost tool is Solid, the next is Solid with edges, and so on.
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Many of the same commands are also available on the context menu when the cursor is not over an
object and the right mouse button is clicked:
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 Solid displays designs and solids as if they were photographed.
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 Solid with edges draws black lines on the edges of the designs. The colors of the lines are set by
the plotting style. If the design is very complex, you may receive a warning about rendering the design,
and ArtiosCAD will prompt for a confirmation.

 Lighter color with edges enhances the contrast by lightening the color of the designs. If the
design is very complex, you may receive a warning about rendering the design, and ArtiosCAD will
prompt for a confirmation.

 Hidden lines removed turns all designs white with black edges and no graphics. Solids in the
workspace are displayed normally unless Graphics is turned off. If the design is very complex, you may
receive a warning about rendering the design, and ArtiosCAD will prompt for a confirmation.
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 Wire frame shows outlines of the designs and solids in the workspace. Design lines are drawn
according to the plotting style. The color used for the wire frame for a solid is defined by the color of
the solid, except that if the solid is white, the wire frame is gray.
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 Perspective controls whether parallel lines meet at a point on an imaginary horizon.

 Show board thickness shows the board thickness. Graphics must also be turned on to see
corrugations.

 Graphics shows or hides graphics on designs and solids. It also controls the display of corrugation
on board edges if Show Board Thickness is turned on.

 Transparent turns the objects in the workspace partially transparent so that formerly hidden
portions become visible. The appearance of transparent objects depends on the order in which
ArtiosCAD draws them.

 Show creases shows creases in red, perfs in blue, and partial cuts in purple for easier viewing.
When this option is turned off, creases, perfs, and partial cuts are the same color as the board.

 Bounding box turns the bounding box around all objects on or off. The bounding box provides
points for picking up and putting down.

Axes controls whether or not ArtiosCAD displays the X, Y, and Z axes in the lower left corner of the
design window. The X axis is red, the Y axis is green, and the Z axis is blue. The axes move appropriately
as you change the view angle.

1764



14ArtiosCAD

Dimensions always visible controls if dimensions hidden behind objects (such as boxes) are shown or
not. The checkbox is off by default. JPG and PNG exports use this setting; VRML export does not as
dimensions are not exported to VRML.

Show invisible designs controls whether or not objects set to be invisible are shown with 90%
transparency or not shown at all.

Show mate areas turns on or off the rectangles that indicate areas that connect to each other
automatically.

In the View angle drag group, Continuous describes the view angle continuing to change even when
the mouse is not moving. Immediate stops changing the view angle when the mouse stops moving.

Allow roll turns rolling with the mouse on and off.

Move lights with view angle allows you to disconnect the lights from the view angle. It is checked by
default - the lights move with the view angle. Clear this checkbox to not have the lights move with the
view angle.

Rotate bounding box with design causes bounding boxes to rotate with a design when you rotate it.
This makes moving and aligning boxes at an angle easier.

 Floor shadows turns the floor shadow on and off. Shadow intensity % controls how dark the
shadow is; use a lower number for a lighter shadow and a higher number for a darker shadow. Shadow
sharpness % controls the fuzziness at the edge of the shadow. Use a lower number for a more diffuse
edge and a higher number for a sharper edge.

Note that the shadow uses the light sources defined in the workspace, not the light pictured in an
optional background image.

When moving or rotating designs, the floor shadows remains static during the drag, and are updated
when the tool finishes.
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When using a floor shadow, the light source angles are limited to at least 60 degrees so that the
shadows do not get too long. If the light source is at less than 0 degrees, and no other light sources are
defined, no shadows are made.

Turning on the floor shadow turns on perspective. Turning off perspective turns off the floor shadow.

Windows default in the Background color group sets the background color of the workspace to the
color defined by the Display Properties control panel. When it is deselected, the Red, Green and Blue
fields become available, as does Select color. Enter values from 0 to 255 in the fields provided, or click
Select color and choose the desired color from the Color dialog box.

Background image sets a background image for the workspace. Align with background lets you align
the workspace with the background image. See the next section for more information about using this
feature.

To change plotting styles, choose a new plotting style from the Plotting Style drop-down list box.

 The Performance slider, also known as the 3D Rendering and Image Quality tool, exists both as a
button on the View Mode toolbar and as a group within the 3D View Mode dialog box.

Clicking the toolbar button opens a small dialog box next to the toolbar button:
 

 

In the 3D View Mode dialog box:
 

 

The Low end of the slider represents faster performance at the expense of image rendering quality,
while the High end represents better image quality at the expense of slower performance. If you try to
snap to a setting that your computer cannot do, the slider will bounce back and a status message will
appear on the Status bar. The toolbar icon indicates the current slider level as a green mark.

There may be a blue indicator in the slider field that shows the settings that your computer can accept.
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Tick Graphics resolution Number of samples

1 Low 0

2 Medium 0

3 Medium 4x

4 High 8x

5 Maximum 16x

The settings between the two ends of the slider mix the advanced settings of graphics resolution
and number of samples, which are discussed in the following topic. For example, if the design has no
graphics on it and the display adapter supports 16x sampling, the slider can move to all the way to High.
Conversely, if the design has many graphics and the display adapter can support large internal bitmaps,
but with no support for smooth edges, the slider can still go to High. To determine the exact settings
supported by your system, click Advanced and use the drop-down list boxes to list the available modes.

Set the default state of the items in the View Mode dialog box by clicking Options > Defaults > Startup
defaults > 3D View mode.

Advanced mode
In the 3D View Mode Dialog box, when you check the Advanced checkbox in the 3D Performance and
Image Quality section, the slider is replaced by the Graphics resolution, Image filter, and Smooth
Edges drop-down list boxes, along with the Reduce gaps in edges checkbox.
 

 

Graphics resolution

Note:

The following discussion refers to the size of bitmaps that the display adapter can create in its
internal memory. It does not refer to the size of bitmaps it can display on the monitor.
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Note:

The quality of the graphics is limited by the quality of the original graphic files placed into the
workspace. If the original graphics were low resolution or otherwise low quality, ArtiosCAD
cannot improve them.

The Graphics Resolution drop-down list box has four settings which may or may not appear depending
on the abilities of the display adapter.

Selected resolution Overall bitmap pixel size

Low 1024 x 1024

Medium 2048 x 2048

High 4096 x 4096

Maximum 4096 x 4096 per panel or label

For designs, when you select the setting that is the highest your computer can render, the next higher
setting causes ArtiosCAD to split the overall graphics into a bitmap per panel at the highest resolution
possible. For solids, ArtiosCAD creates one bitmap per label or graphic.

For example, if the display adapter only supports 2048 x 2048 bitmaps, the best selection in the drop-
down list box will be High. Because this is one level above what the display adapter supports, the
graphics will be split into one graphic per panel for a design or label/graphic for a solid.

Note:

If present, a background image is unaffected by this setting and always uses the highest
resolution possible.

Image filter
The Image filter drop-down list box has three values:

• Nearest. Nearest point filtering has been the standard image filter for 3D. It offers sharp edges but
blocky results.

• Linear. This image filter blurs and blends the pixels together for a smooth look, but some sharpness
is lost.

• Perspective. This image filter is similar to linear filtering but it compensates for the slope of the
object upon which the graphics appear. This method requires more resources than the others so it
may impact performance.

Note:

If a background image is present, these options affect its quality.

Smooth edges
The choices on the Smooth edges drop-down list box control how ArtiosCAD draws the edges of
objects. ArtiosCAD reads each pixel on the edge of a polygon read several times in different places and
combines the readings to give the best result, which is called Multi-Sample Anti-Aliasing.
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The list in the drop-down list box shows the values your display adapter supports. The values range
from No samples to 16X samples, which means each edge pixel is sampled 16 times. The greater the
number of samples selected, the longer the render will take.

Note:

Bitmap Outputs do not use smooth edges algorithms.

Reduce gaps in edges
The Reduce Gaps in Edges checkbox in the Advanced group of the 3D View Mode dialog box controls
how ArtiosCAD displays visible vectors in 3D. When this checkbox is checked, Hidden Line Removal,
Solid With Edges, and Lighter Color With Edges view modes all look smoother and better. This option
also affects Outputs of type Bitmap.

Note:

Reduce Gaps in Edges is enabled by default but is not used if there is a solid in the 3D
workspace.

Without Reduce Gaps in Edges checked:
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With Reduce Gaps in Edges checked:
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Using a freehand background image
The Background image group in the View Mode dialog box lets you set a background image for the 3D
workspace. You can either position the design against the background freehand, or you can use the
Align with background command on the View menu, which is documented in the next section.

Using a background image significantly increases the time it takes to display the workspace.
Therefore, position the scene as close as possible to the desired result before adding or turning on
a background image. It helps to view the background image first in an image-viewing application to
determine the scene before executing it in ArtiosCAD. Also, using Direct3D instead of OpenGL as the
rendering method may lead to more robust performance.

To use this feature in freehand mode, do the following:

1. Position the objects in 3D as close as possible to the end result.
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2.
 Click View Mode, and then click ... (Browse) in the Background image group.

3. Navigate to the folder containing the desired image file, select it, and click OK. PDF and Adobe
Illustrator .AI files may not be used as background images.

4. Click OK in the View Mode dialog box to turn on the background image. The background image is
centered to match the height of the image with the size of the window. If the image is wider than
the window, it is clipped on both sides; if the image is narrower than the window, white space
appears on either side of the image.

5. Use the View Angle, Zoom In/Out, Pan, and Perspective tools to adjust the position and rotation of
the workspace against the background image. You may also use the Move and Copy tools but their
performance will be impacted by having the background image turned on. The background image
itself may not be moved. Shown below is a 3D workspace with background image.
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Note:  The complexity of the workspace, size of the background image, and 3D rendering
method all affect system performance. Bear these in mind when composing the scene.
Direct3D may perform somewhat faster than OpenGL on some systems.

To choose a different background image, choose a new image file in the View Mode dialog box as
explained in steps 2 through 4.

The background image is saved as part of the 3D workspace.

The background image and floor shadow do not appear in CloseUp windows.

Using an aligned background image
Aligning a background image with a 3D workspace involves indicating a rectangle on the floor of the
image (assuming you are using a picture of a place) and then entering the size of that rectangle. This
tells ArtiosCAD how to set the vanishing point for the perspective in the workspace.

The Align With Background tool aligns the longest X/Y dimension of the bounding box of the designs
with the longest dimension in the background image.

To use a background image and align the workspace with it, do the following:

1. In ArtiosCAD, assemble the complete workspace.
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2. View the background image in an image-viewing application and decide upon the scene.
3.

 Click View Mode to open the View Mode dialog box.
4. In the View Mode dialog box, select the Background image checkbox, and use the ... (Browse)

button to select the desired image.
5. In the View Mode dialog box, click OK. The background image appears in the workspace.
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6. Click View > Align with background. The Align With Background Options dialog box appears.

7. The picture in the dialog box shows the order in which to click the corners of the alignment
rectangle in ArtiosCAD to set its position. In the fields, enter the longer dimension of the rectangle
in the A: field and the shorter dimension in the B: field. Using a rectangle with a definite proportion
between length and width works better than a squarer rectangle. Also, the line formed by points 1
and 2 should go across the front of the designs in the workspace for best results.

8. Click OK in the Align With Background Options dialog box. The 3D workspace will be turned off
temporarily to show the entire background image.

9. Click the points of the rectangle in order. Click the lower left corner, then the lower right, then the
upper right, and finally the upper left. ArtiosCAD automatically adds the line from the last corner to
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the first corner. If you make a mistake, click the Undo button on the Status bar. Shown below is the
setting of the second corner.

10. You may zoom as needed using the Zoom In, Zoom Out, and Scale to Fit tools. Larger alignment
rectangles generally yield better results than smaller ones. Precise alignment is critical, as
differences as small as a pixel can greatly affect the position of the vanishing point. Shown below is
a zoomed-in view in which you can see that the right edge of the rectangle is a few pixels off; that
can be corrected later in the process.
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11. Once the rectangle is drawn, you can click a corner and drag it as needed to adjust it. Shown below
is an adjustment for emphasis;

12. When you are satisfied with the size and position of the alignment rectangle, click OK on the status
bar. The 3D workspace will be turned back on and aligned inside the alignment rectangle as shown
below.
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13. ArtiosCAD is now in Align with background view mode. In this mode, the View Angle, Zoom, Scale
to Fit, and Pan tools are unavailable in order to not lose the alignment with the background. Use the
Move and Rotate tools to further align the workspace objects against the background.

14. If desired, turn on the floor shadows in the View Mode dialog box and use the Light Source tool to
adjust the position of the light sources to change the shadows.

15. Shown below is the completed image.
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16. To exit Align with background mode and make the View Angle, Zoom, Scale-to-Fit, and Pan tools
active again, click View Mode on the toolbar and deselect Align with background.

Note:  Once you change the view, the alignment with the background is lost, and you will have
to repeat the entire procedure to realign the background with the workspace.

Note:  Wide-angle images from digital cameras may suffer from fish-eye lens distortion at
their edges. In this case, the alignment of ArtiosCAD's perspective with the background image
perspective will be less accurate, with the error becoming larger as the design is moved further
from its original placement.

Outputs using background images
JPEG and PNG outputs include the background image at the same aspect ratio as shown in ArtiosCAD.

VRML output includes the background image as a rectangular object positioned behind the designs
and grouped with the toolbar (if it is selected for output as well).

Animations with a background image using the Scale to Fit feature for captured frames may zoom in
and out when output to VRML. The background image stays the same size when the animation is played
in ArtiosCAD. Combining use of the Scale to Fit feature in an animation, using a background image, and
exporting to VRML may lead to unpredictable results.

VRML viewers may perform more robustly with background images when set to use Direct3D instead of
OpenGL.

VRML outputs containing a background image also contain two extra rectangles for proper image
placement. These extra rectangles may appear in other programs when opening the VRML file. To avoid
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this situation, before outputting a VRML file, turn off the background image in the View Mode dialog
box, and then in the VRML dialog box, do not select With toolbar.

Level Designs tool

Use the Tools > Level Designs tool to make a design look level on the floor when it has no horizontal
base face.

To use the Level Designs tool, do the following:

1. Create or open a 3D workspace that has no horizontal base face. For example, this simple display
base has no panels that would sit flat on the floor.
 

 
2. Use the back as the base face when converting to 3D.
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3. Rotate the design so that it is close to upright.

 

 
4. Click Tools > Level Designs. ArtiosCAD changes the orientation to make the display look more level.
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Changing visible properties of objects in 3D

To change the colors of objects in 3D, double-click them with the appropriate Select tool to open the
Properties dialog box for the type of object. To select more than one item to change at once, hold down
CTRL while clicking to select items.

 Use the Select Designs tool and double-click a container to change its properties.
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The Shininess % and Transparency % fields help to simulate different materials. Shininess is most
visible on round objects; it has little effect on flat objects such as containers. Transparency of the
board works independently of the Transparent checkbox in the View Mode dialog box. Use the values in
the table below to approximate common objects.

Table: Common Amounts of Shininess and Transparency

Material Shininess Transparency

Matte board 0 0

Glossy board 40 0

Beer bottle 90 50

Glass 100 80

Surface colors are split into four components: ambient color, which reflects the ambient light; diffuse
color, which reflects the movable lights in an airy, non-shiny way; specular color, which reflects
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movable lights for a shiny surface, with a shiny surface having a white specular color and a dull surface
a black specular color; and emission color, which is the color the object emits.

By default, the Material Properties dialog box only displays Diffuse color in Simple color mode. In
Simple color mode, choose a color by clicking Select color. To set the other three colors, click
Advanced color, and then click Select color as desired. You may only set a CMYK color for the Diffuse
color in Simple color mode.

Visible controls whether the current selection is included in VRML exports and also if it is included
when ArtiosCAD calculates the view scale of the workspace. Use this control to turn on and off
different elements of your workspace. Show invisible designs in the View Mode dialog box controls
whether invisible designs are shown at 90% transparency (when visible) or not at all (when invisible). If
any part of a design is visible, the entire design is visible; the visibility of the part affects the visibility of
the whole. Visibility can be set independently for each design at the start of each animation frame.

Changes you make in this dialog box are applied as they are made. Close the dialog box by clicking the X
at the end of the title bar.

 Use the Select Labels or Parts tool and double-click a label or part of a solid to change its
properties, or to delete selected parts by pressing DEL on the keyboard. You may also click and drag to
select more than one item, or hold down CTRL while clicking to select more than one item.
 

 

1784



14ArtiosCAD

The color controls for a label or parts of a solid work the same way as they do for containers, but there
is just one color group. The differences for labels and parts of solids are the View both sides checkbox
and the Inside visibility % field.

View both sides shows all facets of a solid so that it is shown correctly. Shown below is a hammer
model with View both sides turned off.

With View both sides turned on, the head of the hammer is now complete.

Inside visibility % sets the percentage of labels that show through transparent objects. The label on
the bottle below is set to 0% inside visibility.
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The same label is now set to 70% inside visibility:

Visible controls whether the current selection is included in VRML exports and also if it is included
when ArtiosCAD calculates the view scale of the workspace. Use this control to turn on and off
different elements of your workspace. Show invisible designs in the View Mode dialog box controls
whether invisible designs are shown at 90% transparency (when visible) or not at all (when invisible). If
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any part of a design is visible, the entire design is visible; the visibility of the part affects the visibility of
the whole. Visibility can be set independently for each design at the start of each animation frame.

How to change the board information in 3D

To change the board information dynamically in 3D without changing the board information in the flat
workspace, do the following:

1.
 Click Select Designs and double-click the object to change, or single-click and select the

design(s) to change, holding down CTRL to select more than one object.

2. If you selected more than one object, click Edit > Properties.
3. To change the color, shininess, or transparency of the boards, click the Material Properties tab, and

change the values as desired.
4. To change the textures of the board from those defined by the board code, click the Texture tab.

Shown below are the textures used for the Orange Urethane Two foam board in the Artios > Foam
catalog.
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5. To add an inside or outside texture to the board, click the checkbox for it, and then specify the
filename of the graphic file for the texture, or click ... (Browse) to the right of the filename field and
select it. Some common textures are stored in \Artios\Common. The image should be of the board
surface with vertical grain or corrugation direction. If you use a custom image, measure the sample
when you take its picture so that you know its size; you may need to touch up the image in a graphic
editing program so that the edges blend together when the image is tiled.

In the Image height: field, enter the height of the image. The size needs to be set in order for
ArtiosCAD to scale the picture appropriately. If the height is set to 0, the image will be scaled
proportional to the width.

Set the value in the Image width as number of flutes: drop-down list box to the number of flutes
the image represents. The image should be of a whole number of flutes. It may also be set to
Proportional to height, in which case the height cannot be set to 0.

To specify a graphic for the board edge texture, check the Board edge texture checkbox, then
specify the filename of the graphic file for the texture, or click ... (Browse) to the right of the
filename field and select it. Some common textures, for example paper corrugated edges, plastic
corrugated edges, and paper hexacomb flutes, are stored in \Artios\Common. The height of the
image for a corrugated board should be the board caliper, and the width should be a whole number
of flute pitches. Folding carton boards use an image width proportional to the height.

If no texture is specified for a corrugated board edge, a default picture based on the height and
pitch of the flutes is used.

Stretch like corrugations stretches the picture of the board edge texture depending on its angle
to the grain/corrugation direction. If this option is not selected, the board edge texture is repeated
evenly. This option should not be selected for hexacomb flutes.
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6. To change the board code, the caliper, or the inside loss measurement of the selected objects, click
the Board information tab in the Properties dialog box and change the values as desired. This tab is
dynamic and only shows controls for the features that exist in the workspace. Change the value in
the Inside Loss: field to make small adjustments to the position of the board in 90-degree folds.

Partial cuts fold outwards specifies the direction in which partial cuts act as creases. They
generally fold away from the side of the board in which they were cut. Corrugated partial cuts
generally fold to the outside of the container, while folding carton partial cuts generally fold
to the inside of the container. If the selected board has flutes defined, this option is checked
automatically.

Depending on the workspace contents, Partial cuts fold outwards can display the Die Back Side
and Die Knife Side option buttons. Checking or deselecting Partial cuts fold outwards changes the
option button, and changing the option button selects or deselects the checkbox.
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Thin corrugated boards such as E-, F-, N-, and G-flutes may be creased as if they were folding
carton boards; therefore, depending on your workflow, turn it off if selecting one of those boards.

Use the Tear point size slider to adjust the appearance of tear points for perf in 3D.

Edge crush, when enabled, renders a rounded edge on cuts about half a millimeter wide that
represents the beveled edge of cut rules. It is always shown for perfs between parts that tear, but
you can control its appearance for other lines with this option.

Edge band toggles the display of edge band rule.

Click the Papers tab to view the details about the papers comprising the board. No fields on this tab
may be changed; they are for reference only.

Click the X in the upper right corner of the Properties dialog box to make any changes and close it.
7. The changes made will occur immediately. If board thickness was not turned on, it will be turned on

when a new board is chosen.
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Notes on board textures
If a design has graphics, the graphics are drawn on top of the board texture or board color. If the
graphics are PNG or JPG files, they will completely replace the board texture or board color. If the
graphics are PDF files, the board image or board color will show through the parts of the PDF files that
have no ink or are partially transparent.

Board textures are included in 3D workspaces sent to other sites. They should appear correctly even if
the recipient’s system does not have the same boards, papers, and textures defined.

Making an extrusion

Making an extrusion is as simple as designing its shape in Single Design, converting it to 3D, and then
changing the caliper of the board to the desired size of the extrusion.

Shown below are three flat workspaces.
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After converting one to 3D and adding the other two, this is the result having selected a normal folding
carton board.
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Shown below are the finished extrusions with different color foam boards selected and the caliper
increased to 600 mm.

Refreshing the screen

From time to time, refresh the screen to show the latest changes you have made to the workspace.
Click Refresh on the View menu or press F2 to redraw the screen.

You can also hold down SHIFT and click the middle mouse button if you have one.

Working with dimensions in 3D

Use the tools in this section to add, select, modify, align, and remove dimensions in 3D.

Dimension tool

 The Dimension tool allows you to insert dimensions into your workspace.

1.
 Click the Dimension tool.

2. Select a point or line that will be the beginning of the measured distance.
3. If Set Direction is checked on the Status bar, set the direction for the dimension.
4. Indicate a point, a parallel line, or a collinear line that is the end of the measured distance
5. Indicate the extension point. This is where the text of the dimension is put in relation to the design.
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6. The dimension is drawn. If Set Direction is checked on the Status bar, an extra extension line may
be drawn indicating the direction.

Shown below is a design with both Imperial and metric dimensions. The Imperial dimensions were
created first, and then the units were changed to metric and the rest of the dimensions were added.
Unlike Single Design, 3D dimensions do not update when the units of the workspace are changed.
 

 

Set the default state of the Set Direction checkbox in Options > Defaults > Property Defaults > 3D
Dimensions.

Select Dimensions tool

This tool allows you to select dimensions so that you can change their appearance.

1.
 Click the Select Dimensions tool.

2. Select the dimension(s) to change. To select more than one dimension, hold down the SHIFT key as
you select items. To select many dimensions at once, make a window selection.

3. If you selected only one dimension, double-click it to open the Properties dialog box; otherwise,
click Edit > Properties.
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4. Change the style and format options as desired. Auto-rotate text enables the selected dimensions
to automatically rotate to be parallel with an axis as the view angle changes. In some situations, the
dimensions could be obscured by parts of the design when this option is selected, so deselect this
option for affected dimensions as desired.

The Text: field lets you replace the dimension text with text of your choosing. Use Undo to revert to
the original dimension text if needed.

The selected dimension(s) are updated with changes as you make them.

To set the dimension defaults for the current workspace, right-click while over a design, click Property
Defaults on the context menu, and set the options as desired. The changes only affect dimensions
created after the property defaults are changed.

To set the defaults for the arrows, text position, and auto-rotation of text for 3D dimensions, click
Options > Defaults > Property defaults > 3D Dimensions.

To view dimensions in a different color, change the plotting style in the View Mode dialog box to one
which has a different color for dimensions.

Change Dimension Alignment tool

 The Change Dimension Alignment tool lets you change the extension point of a dimension within
the plane of its extend lines. To use it, do the following:

1.
 Select a dimension with the Select Dimension tool.

2.
 Click the Change Dimension Alignment tool.
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3. Click the desired location for the dimension. The dimension moves to the new location and the
extend lines change length as needed.

Change Text Position tool

 The Change Text Position tool lets you change the position of text within a dimension. To use it, do
the following:

1.
 Select a dimension with the Select Dimension tool.

2.
 Click the Change Text Position tool.

3. Drag the text and the extend point of the dimension to its new position and click to set it.

Shown below is a workspace before changing the text positions of dimensions.

Shown below is the same workspace after changing the text positions and extend points of the
dimensions.
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Deleting dimensions

To delete dimensions, select them with the Select Dimensions tool, and then press Delete on the
keyboard.

Working with Edge Band and Tear Tape

Edge band is a cover that hides the edge of thick material, such as Re-board
®

, usually used for displays.
Tear tape is the thin plastic strip on the inside of box-opening features.

Both edge band and tear tape are special rules.

Edge band
To use edge band, set some edges in the 2D design to use it.
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When you convert the 2D to 3D, the edge band appears. Turn it on and off by checking or clearing Edge
band in the Properties dialog box on the Board Information tab.
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Notes about edge band:

• If edge band goes around a corner, ArtiosCAD shows separate pieces with no mitering.

• You may only use one type of edge band per single design added to 3D.

• To change the color of the edge band, change it in 2D on the Special rule tab of the Properties dialog
box for the edge band rule and reconvert to 3D. You cannot change the edge band color in 3D.

• ArtiosCAD shows only solid-color edge band and does not support textures on it.

• Edge band does not turn on or off within an animation.

Tear Tape
To use tear tape, add it as you would any other line to the design. In the example below, it is between
the zipper rules.
 

 

When you convert it to 3D, it looks like the following example.
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Note:  Tear tape does not tear by itself, so to show it tearing without the aid of something like a
zipper, surround it with tear lines in the 3D Assist layer.

Animation in 3D

Animation in 3D lets you record a folding sequence and output it as a Virtual Reality Markup Language
(VRML) file, which can then be played in any Web browser with a VRML plug-in. It will play back as you
recorded it. The animation is defined by recording each change to the view in a new frame or snapshot.

When you export to VRML, multiple files are created by default, although this can be changed at time
of export. The files are pictures of the faces of the objects in the workspace and a file containing the
geometric information. Make sure to group the files together when sending them to another person or
computer.

Esko recommends the Cortona VRML plug-in, available at http://www.parallelgraphics.com/products/
cortona.

This is an optional feature and must be specifically purchased.

The workflow to making an animation is:

1. Create a single design and add any desired graphics, stock colors, or symbols.
2. Convert the single design to 3D. It should be flat.
3. Connect any mates that exist.
4. Click Add Frame on the Animation toolbar.
5. Change the fold angles or move/rotate a design, and click Add Frame after each change.
6. Repeat until the design is folded and positioned as desired.
7. Export to VRML, setting the desired options in the VRML options dialog box.
8. Open the resulting file in a web browser which has a VRML plug-in installed.
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If there are multiple single designs in the 3D workspace, you might achieve better results by turning off
Scale to Fit on the Status bar while making the animation.

The tools to make animations are on the Animation toolbar and the Animation menu. The Animation
toolbar is shown below.
 

 

The Status bar

When any of the Animation tools are active, the Status bar contains controls as shown below.

The green triangle button is the Play button and starts the animation playback at the current frame.
The red square button is the Stop button and stops the animation playback.

The numbers between the Position slider and the Duration field show the current frame and the total
number of frames. On the Position slider, use the inner direction buttons to move frame by frame;
clicking the outer direction buttons moves to the first frame and the last frame respectively. Graphics
are turned off while you drag the slider button, but are turned on when you release the mouse button.
Graphics are not turned off when the frame-by-frame buttons are used.

The value in the Duration: field determines the timing of the animation by controlling the time taken to
change from the previous frame to the current frame. The duration for the first frame sets the pause
between repeats in VRML Outputs and may be set to 0 for the first frame only. By default, each frame’s
duration is set to three seconds; you may achieve better results by testing different values. The value
in the Duration: field is specific to each frame.

 Scale to fit may be set for each frame. When clicked, ArtiosCAD centers visible designs in the
view and adjusts the view to fit them. Upon playback, the field of view changes smoothly between
frames that have this option selected; it may appear that the designs drift, but this is so that the view
is centered in each frame that has this option selected.

 The Options button opens the Frame Properties dialog box.
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Duration: and Scale to fit have the same values as their counterparts on the Status bar. Enter text in
the Title: field to use when exporting the animation to another format. Click OK when done making
changes to the dialog box.

The animation in a VRML file will use the view angle and elevation set at the time the VRML file is
exported from 3D. Changing the view angle and elevation for each frame has no effect.

To save the animation in the corresponding single design, such as saving it to a standard, close the
3D file while the single design is still open. When a single design is created using that standard, the
animation settings will be included.

Animation tools

 The first button on the Animation toolbar is Add Frame. Use this command to take a snapshot of
the current state of the workspace and add it to the animation. For changes to fold angles, you do not
need to change each angle incrementally and then capture a new frame. Change the fold angle in the
complete amount desired and ArtiosCAD will create the intermediate steps on export. Only changes
in fold angles, moves, and rotations are captured in frames. To simulate a change in the view angle or
elevation, move or rotate the designs as desired.

 The second button on the Animation toolbar is Update Frame. Use this to change the current
animation frame to match what is on the screen without adding another frame.

 The third button on the Animation toolbar is Update Range of Frames. Use this to update more
than one frame at once, for example if you have added another design to the 3D workspace and then
moved it after having made an animation. Changes that can be applied to multiple frames are moving
designs, rotating designs, changing the visible property on or off, and changing fold angles.

To use this tool, do the following:

1. Make the desired change(s) to the 3D workspace.
2.

 Click Update Range of Frames to open the Update Range of Frames dialog box.
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3. Enter the number of the start frame in the Start frame: field, and then enter the number of the
ending frame in the End frame: field. The current frame must be included in the range.

4. Click OK to update the frames.

If designs that were moved or rotated already have different positions in different frames in the
animation, ArtiosCAD adjusts the position and rotation of each design by the same relative amount in
each frame.

 The fourth button on the Animation toolbar is Animation Playback. Use this to step through the
animation in 3D by using the slider, or to start playing it at the current frame using the Play button.

 The fifth button on the Animation toolbar is Delete Frame. Use this to delete the current frame.
This tool is available only when the Animation Playback tool is active.

 The sixth button on the Animation toolbar is Shue Frame Forward. This tool moves the current
frame forward by one frame in the animation sequence. This tool is unavailable for the last frame, or if
there is no animation defined. This tool is available only when the Animation Playback tool is active.

 The seventh button on the Animation toolbar is Shue Frame Backward. This tool moves the
current frame back by one frame in the animation sequence. This tool is unavailable for the first frame,
or if there is no animation defined. This tool is available only when the Animation Playback tool is
active.

Note that when shuing frames, their duration and Scale to Fit setting are kept with them.

The Reverse Animation command on the Animation menu reverses the order of all the frames in the
animation. When reversing an animation, note that the first duration is a pause before the animation
begins, so an animation with durations 2, 3, 4, 5 would have durations 2, 5, 4, 3 when reversed.

The Delete Animation command on the Animation menu deletes the entire animation sequence.

Animation notes and restrictions

The animation feature will not play back adding or deleting designs, or changing the base face. If you
delete a design while making an animation, it will disappear from all frames created up to that point.

Connect any mates before starting an animation.

An animation with Scale to Fit turned on and with a background image keeps the background image
the same size in ArtiosCAD but the VRML version has a zoomed-in image.
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When rotating designs in an animation, do not rotate them through 360 degrees. Break the rotation
into three 120 degree steps or four 90 degree steps. Otherwise, the designs may rotate the wrong way
during animation playback.

If you find that the design(s) in the VRML file move a lot during playback, try turning off Scale to Fit on
the Status bar before creating an animation.

Dimensions are not output to an animation, nor are they animated with the designs. They are turned off
at the start of the animation playback and turned on when the playback completes.

When an animation has a background image, the Fit button in Cortona causes the design to disappear.
Use the Restore button to bring it back.

When the design already has an animation and you add more designs, ArtiosCAD does not record the
position of the added designs. The new designs will have a fixed position throughout the animation
unless you move them or change the visibility and update the frames of the animation. For best results,
add all the designs first and make the animation last. If you add a design to a workspace with an
animation, ArtiosCAD warns you that you should add all the designs first and make the animation last.

Likewise, animations also do not record scale changes made using Scale Designs, which has a similar
warning.

Tear-away Animations

Tear-away animations show how the design separates. They are different from normal animations and
there is a dedicated tool to make them.

Tear-away animations require that the panels can bend. If the panels do not bend, ArtiosCAD makes a
pull-away animation instead in which you can only set the pull-off duration and distance of the pulled-
away part.

Note:  Tear-away animations only work for the first instance of a design; they do not work on
copies.

Making a Tear-away Animation
To make a tear-away animation, do the following:

1. Create a 3D workspace and make sure all the designs you want in it are arranged properly. The
designs must also have the 3D property of the tearing lines set correctly in Single Design. For
example, if you want to show potato chip bags in a retail-ready shipping container, arrange the bags
inside the container and fold the container so that it appears closed.
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2.

 Click the Make tear-away animation tool and click where you want the tear-away to start in the
part that is torn away. In the example below, the cursor is in the thumb hole and you can see the perf
forming the left part of the tear.
 

 
3. Set the fields as desired in the Tear-away animation dialog box.
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a) Disappear at the end causes the torn-away piece to disappear from the scene when the

animation finishes.
b) From two sides shows two ends of the tear-away being torn away simultaneously before the

tear-away is detached from the middle. Use this option only when you have specifically designed
the tear-away to start in two places at once.

c) Press in causes a beginning thumb notch or other similar construction to be pressed into the
container before it is torn away.

d) Tear-off time and Pull-off time, respectively, set the duration of those parts of the animation.
e) Fold angle (A) sets the angle at which a fold in the part being torn away is folded at the end of

the animation.
f) Bend angle (B) sets the angle at which a bend in the part being torn away is bent at the end of

the animation.
g) Pull-off distance (C) controls how far the torn-away piece is pulled from the main piece of the

design at the end of the animation.
h) Pull-off rotation (D) determines the rotation at which the torn-off piece turns.
i) Pull-off angle (E) determines the direction in which the torn-off piece moves.
j) Roll-off distance (F) sets how far the torn-away pieces rolls off the main body and thus how

tight the bend is. If you have to pull hard to do the tear-away in real life, set a small distance to
have a tight bend.

4. Click OK when you are done setting the values as desired.

ArtiosCAD creates the animation and starts the Animation Playback tool. Click the green triangle to
play the animation.
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Note:  If you use Scale to Fit on any of the animation frames, you will not be able to make any
changes to the animation.

Example of Tearing from Two Sides
Make sure to check From two sides in the Make tear-away animation dialog box if you have designed a
box similar to the one shown below.
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If you do not check the From two sides checkbox, the result will look something like this:
 

 

Example of an Attached Tear-Away Animation
Tear-away animations do not actually have to be torn away - as long as the design has lines that will
tear in it, you can show them tearing. The example below has a flap edged with perf and ending on a
crease. This allows access to its contents, but also means the box can be closed after its contents are
removed.
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1810



14ArtiosCAD
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Making a Pull-Away Animation
If the panels of the box do not bend, ArtiosCAD removes the torn-away part from the main body of the
container in a straight line.

1. Design the container, making sure to set the 3D property of the tearing lines to Tear or Tear and
fold.

2. Convert the design to 3D.
3.

 Click Make tear-away animation and then click the start point for the animation.
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4. In the Make pull-away animation dialog box, set the options as desired and click OK.
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5. ArtiosCAD creates the animation and starts the Animation Playback tool. Click the green triangle to

play the animation.
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6. To change the direction in which ArtiosCAD pulls the part away, do the following:

a)
 Use Animation Playback to go to the last frame of the animation.

b)
 Use Select designs to select the torn-away part.

c)
 Use Move Designs to move it in the desired direction.

d)
 Click Update Frame.

e) When you replay the animation with the Animation Playback tool, the pulled-away part will move
in the direction you specified.

Substrate Tears
Some designs use partial cuts and reverse partial cuts instead of perfs to tear. This type of tear is
called a substrate tear, and is shown below as the lines in the second panel that connect the zipper rule
to the perf.
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In order for 3D to recognize a substrate tear:

• The substrate tear is made by partial cuts and reverse partial cuts
• The partial cuts and reverse partial cuts have the Tear option selected on the 3D tab of the

Properties dialog box in Single Design

• There are no gaps in the lines

• The substrate tear area is a maximum of 1/2 inch or 12.7 millimeters wide.

Example of Two Tear-away Animations
To have two tear-away animations in the same design, use Make tear-away animation twice
consecutively.

1. Design the container, making sure to set the 3D property of the tearing lines to Tear or Tear and
fold.

2. Convert the design to 3D.
3.

 Click Make tear-away animation and then click the start point for the first animation.
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4. In the Make tear-away animation dialog box, set the values as desired and click OK.

 

 
5.

 Click Make tear-away animation and then click the start point for the second animation.
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6. In the Make tear-away animation dialog box, set the values as desired and click OK.

ArtiosCAD makes the second animation and starts the Animation Playback tool. Slide the frame
slider all the way to the left to start at the beginning, and then click the green triangle to play both
animations.
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Example of a Tear Strip with an Attached Part
Usually torn-away parts are separated from the main part of the design. To leave the remainder of a
part attached after part of it is torn off, such as a flap with a zipper glued to it, do the following:

1. Design the container, making sure to set the 3D property of the tearing lines to Tear or Tear and
fold.

2. Make a Mate area on the part of the design that will remain after the tear-away is torn off. Only one
Mate area is needed; ArtiosCAD automatically creates the target area in 3D.
 

 
3. Convert the design to 3D.
4.

 Click Make tear-away animation and then click the start point for the animation. ArtiosCAD
creates the animation and activates the Animation Playback tool.

5. In the Animation playback tool, if the frame slider is not already on the last frame, slide it all the way
to the right to go to the end of the animation.

6.
 Use Fold Angle to unfold the flap that does not have the Mate area.
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7.

 Click Add Frame.
8.

 Use Fold Angle to unfold the opposite panel, the one that has the Mate area. Note that the part
with the Mate area is still attached and was not torn away.
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9.

 Click Add Frame to complete the animation.

You can edit the duration of each frame as desired in the Animation Playback tool.

Adding a Tear-away Animation to an Existing Animation
If you already have an existing animation when you use Make tear-away animation, ArtiosCAD adds
frames to the existing animation. For example, you could create the following animation:

1. Fold a container, leaving the top open.
2. Put contents in the container.
3. Close the container.
4. Tear away the top of the container.
5. Remove the box contents.

To accomplish this, make steps 1, 2, and 3 manually, then use Make tear-away animation for step 4, and
then add step 5 manually.
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Deleting a Tear-away Animation
To delete an entire tear-away animation, click Animation > Delete animation. To delete just the tear-
away portion of the animation, do the following:

1.
 Click Make tear-away animation.

2. Click the part to delete.
3. In the Edit tear-away animation dialog box, check Delete animation of this part and click OK.

 

 

ArtiosCAD deletes the animation for the part you selected.

Animating a 123 Bottom

Use this workflow to animate a 123 bottom design. Other workflows may not give the desired results.

1. Convert the design to 3D and turn Use previous fold angles off
2. Erect: 123 Bottom (must erect first for the animation to work).
3. Knock Down: 123 Bottom.
4. Add frame.
5. Fold 4 panel tube: 123 Bottom.
6. Add frame.
7. Rotate view to see the bottom.
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8. Fold the base panel 90.
9. Add frame.
10. Fold the 2 side panels 90.
11. Add frame.
12. Fold the lock panel 90.
13. Add frame.
14. Fold the lock panel 70 (see it pushes and bends the other panels in).
15. Reduce the fold angle to 69, 68 ,.. till it locks, (unlock icon switches to lock icon).
16. Add frame.
17. Fold back to around 87 degrees (not more than 100, or it will unlock).
18. Add frame.
19. Fold the top.
20.Add frame.
21. Click Animation Playback and press Play to see the animation.

3D Designer

Use 3D Designer to make a solid of revolution. A solid of revolution is a flat ArtiosCAD design with
special layers defined. When converted to 3D, cross-sections and graphics defined in the single design
workspace are rendered as a solid model. Shown below in the top pane is a flat single design, and in the
bottom pane is the 3D workspace with the solid of revolution.
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Solids of revolution

Working with the single design
To be converted to a solid of revolution, a single design has these properties:

• A vertical cross section positioned on the Y axis of the workspace in the Main Design layer
(required)

• A color defined (optional)

• A set of horizontal cross sections at different heights along the vertical axis in a layer of class
Horizontal Cross Section (optional)

• Graphics for labels defined in a layer of class Label Graphics (optional)

• Shrink-wrap graphics defined in a layer of class Shrink Wrap Graphics (optional)
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Note:  At least one layer of the three layer classes described above must exist for the design to
be converted to a solid of revolution. The layer can be empty. Solids of revolution may not have
holes that go completely through them.

Shown below is the single design workspace for the oil bottle. On the left is the vertical cross section
in the Main Design layer. To the right of that, the open circle and two open rectangles are horizontal
cross sections in the Horizontal Cross Section layer. To the right of that, the filled-in circle, filled-in
rectangle, and two graphics are in the Label Graphics layer.

Vertical cross section
The vertical cross section is an outline of the shape using cut lines which straddles the Y axis in the
Main Design layer. If it is filled with color (using the Fill tool), the color becomes the surface color when
the single design is converted to a solid of revolution. The vertical cross section does not have to
be symmetrical, but the solid of revolution will revolve around the Y axis, so place the vertical cross
section accordingly.

Horizontal cross section
Horizontal cross sections must be in a layer of class Horizontal Cross Section. If there is no layer of
this class, the solid of revolution will have a round cross section. Each horizontal cross section is an
outline made of cut lines of the exterior shape of the solid of revolution.

The center of the horizontal cross section’s bounding box is aligned vertically with the corresponding
point in the vertical cross section. To use a different alignment point, use print registration lines to
make a small cross at the desired alignment point. Non-symmetrical shapes may require alignment
points for proper positioning.
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The horizontal placement of the horizontal cross sections within the single design workspace is not
important, but they must align vertically at the correct height along the vertical cross section, and
none of the horizontal cross sections should overlap or touch.

If the size of the horizontal cross section differs from that indicated by the vertical cross section, upon
conversion to a solid of revolution, the width of the horizontal cross section is scaled to match that
of the vertical cross section. A warning dialog box will appear if the size difference is greater than 33
percent.

Graphics for labels
Graphics for labels must be in a layer of class Label Graphics. There can be more than one graphic in
the same layer. Each label graphic should be a single group.

As with horizontal cross sections, the alignment point for a label is the middle of the bounding box for
the graphic. To use an off-center alignment point, make a small cross or circle from print registration
lines and group it with the graphic. This point is then aligned with the center of the solid.

Graphics in this layer are positioned on the solid of revolution as follows:

• If it extends above the top of the vertical cross section, the graphic is centered on the top.

• If it extends beneath the bottom of the vertical cross section, the graphic is centered on the
bottom.

• If it is positioned between the top on the bottom of the vertical cross section, it is centered on the
front.

• If there are two graphics that overlap vertically, the graphic on the right goes on the back.

Shown below are the label graphics for the oil bottle. Note the print registration circles through the M
and O on the front label and through the bar code on the back label. They are aligned with the Y axis and
thus ensure the labels are placed properly.

Shrink-wrap graphics
Shrink-wrap graphics must be in a layer of class Shrink Wrap Graphics. A shrink-wrap graphic wraps
around the front and back of the design; it is not intended to cover the top or bottom. A shrink-wrap
graphic must be rectangular. If it is made of multiple parts, group them together into a single group.
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As with label graphics, the center of the bounding box for the shrink-wrap graphic defines the vertical
position of the graphic on the solid of revolution. Any portion of the graphic extending beyond the top
or bottom of the vertical cross section is discarded.

If the shrink-wrap graphic is not wide enough to wrap around the design, it is horizontally scaled to do
so.

Do not mix label graphics and shrink-wrap graphics; use one or the other.

Do not turn on a Label Graphics layer if using shrink-wrap graphics.

Converting the single design to a solid of revolution
Once the single design is constructed with the layers defined and graphics added, click File > Convert
to  > 3D or the Convert to 3D button on the View bar. The Solid of Revolution Smoothness dialog box
appears as shown below.

Solids of revolution are composed mainly of triangles. The quality and smoothness of the solid of
revolution is directly proportional to the number of triangles. However, the more triangles, the longer
it will take to render the design and the longer it will take drag to refresh.

Medium smoothness is recommended for most solids of revolution. The smoothness can not be
adjusted once the solid of revolution is created. To adjust the smoothness, discard the 3D workspace
and reconvert the single design, choosing a different smoothness when prompted.

To set the smoothness, adjust the slider in the Solid of Revolution Smoothness dialog box as desired
and click OK. The solid of revolution is created and presented in wireframe form. Shown below is the oil
bottle at low smoothness in both wireframe and rendered forms.
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At medium smoothness:
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At high smoothness:
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Once the solid of revolution is created, treat it like any other 3D object. Note that to snap to it, Snap to
solids must be checked in Options > Snap Options.

Examples
The power of ArtiosCAD lends itself to many different kinds of solids of revolution. Solids of revolution
can have lines that reverse direction, such as glasses. They also can be made from resizable designs
- resize the design and create a completely different shape. Both the lager glass and the martini glass
shown below were made from the same single design workspace.
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Solids of revolution notes and warnings
Use medium smoothness whenever possible instead of high smoothness, as solids of revolution made
with high smoothness takes a long time to render and manipulate, even in wire frame view.

Do not make handles on single designs you intend to convert to solids of revolution. Make a handle as a
separate design and add it to the 3D workspace.

Importing Other Solids

3D Designer also can import many different 3D models from other programs. Collada and VRML come
with 3D, but other formats require the ArtiosCAD 3D Data Exchange option.

Formats File Extensions Document (Format)
Type

Versions

ACIS .sat, .sab, .asat, .asab ACIS R1 – 2023 1.0

CATIA V5 .CATPart, .CATProduct, .cgr, .CATDrawingCATIAV5 or
CATIAV5_DRW

V5 R8 to V5–6 R2023

3DExperience (CATIA
V6)

.CATPart, .CATProduct, .cgr, .CATDrawing, .xcgm, .3dxmlCATIAV5 or
CATIAV5_DRW or XCGM
or 3DXML

Exported from up to V6
R2023x

COLLADA .dae, .zae COLLADA N/A

DXF™ / DWG™ .dxf, .dwg AUTOCAD 2.5 – 2024
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IGES .igs, .iges IGES Up to 5.3

Inventor .ipt (V6 – V2021)

.iam (V11 – V2021)

INVENTOR V6 – V2024

JT .jt JT JT 8.x, 9.x, 10, 10.1, 10.2,
JT 10.3 and JT 10.5

JT Direct .jt JTDIRECT JT 8.x, 9.x, 10, 10.1, 10.2,
JT 10.3 and JT 10.5,
10.6, 10.7

OBJ .obj OBJ N/A

Parasolid .x_t, .xmt_txt, .x_b, .xmt_bin, .p_b, .xmp_bin, .p_t, .xmp_txtGENERIC 9.0 – 35.0.149

Parasolid Direct .x_t, .xmt_txt, .x_b, .xmt_bin, .p_b, .xmp_bin, .p_t, .xmp_txtPSDIRECT 9.0.x – 35.0.x

Pro/E / Creo .prt, .prt.*, .asm, .asm.* PROE 16 – Creo 9.0

SolidWorks .sldprt, .sldasm, .slddrw SOLIDWORKS or
SOLIDWORKS_DRW

98 – 2023

SolidWorks Direct .sldprt, .sldasm, .slddrw SWDIRECT or
SWDIRECT_DRW

2013 – 2023

STEP .stp, .step, .stpZ STEP AP203, AP214, AP242

STL .stl STL N/A

XCGM .xcgm XCGM R2012 – 2023 1.0

Importing VRML files
VRML files contain polygons, lines, and images. ArtiosCAD can directly import the polygons from most
VRML 1.0 and 2.0 files created by other CAD programs. ArtiosCAD also resolves links to external files
and uses them if it finds them.

The tables below list what is supported and unsupported, with features and entities being in normal
type and keywords being in bold.

Table: Supported VRML features, entities, and keywords

Polygons Surface color Shininess

gzip compression DEF/USE Units from ArtiosCAD VRML
export

scale Transform Cube

translation Group Cylinder

rotation Separator Sphere

matrix children Cone
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Shape geometry width

Material material diffuseColor height

Appearance appearance ambientColor depth

coord emissiveColor radius

point specularColor bottomRadius

Coordinate ambientIntensity

Coordinate3 shininess

coordIndex transparency

Table: Unsupported or Ignored VRML features, entities, and keywords

Animations JavaScript Lines

Points Images

WorldInfo ShapeHints vector

NavigationInfo Texture2Transform solid

Background IndexedLineSet eventIn

Viewpoint Normal normal eventOut

exposedField ROUTE WWWInline

If the directory C:\TEMP exists, ArtiosCAD puts a log file called VRMLLOG.TXT in it for diagnostic
purposes each time a VRML file is imported. The file is overwritten each time.

Importing non-VRML files
When you import an ACIS, STEP, IGES, CATIA, ProEngineer, or SolidWorks file, ArtiosCAD performs
three steps before the workspace opens in the design window:

1. The file is preprocessed to convert the 3D data into polygons.
2. The polygons are written to file <system temp directory>\TEMP.MSH.LOG.
3. ArtiosCAD reads the temporary file and opens it in a 3D workspace.

SolidWorks files can contain multiple configurations of how to present the model. If opening such a
file, ArtiosCAD chooses the default configuration.

SolidWorks assembly files (ending in .sldasm) may also contain references to other parts files (ending
in .sldprt). If any parts file is missing, ArtiosCAD ignores the missing parts and continues the import,
but will tell you the name of the missing files.
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Opening large files of 50 to 100 MB or hundreds of thousands of polygons can take a lot of time (up to a
half hour) depending on the capabilities of your computer. Save the 3D workspace as soon as it opens.
If the import or save fails for any reason, try opening the TEMP.MSH.LOG file to avoid repeating the
initial conversion. Files larger than 50 to 100 MB may fail due to lack of memory or too many polygons
for the display adapter to process. To show the number of polygons, click Help > Diagnostics >  List
Embedded Designs.

 Use the Select Labels or Parts tool to select parts of solids to change their position or properties,
or to delete selected parts by selecting them and pressing Delete on the keyboard.

Importing a Solid
Do the following to import a solid:

1. Import the solid into an open 3D workspace, or open it directly. A progress bar appears.
 

 
2. A preview of the solid appears. If it has parts defined, you can turn them on and off with the

checkboxes next to their names, or on the Part Selection menu. To change to a defined angle in the
view, choose an option on the View menu. You can also use the left mouse button to drag and rotate
the camera, the scroll wheel to zoom in and out, and the right mouse button to drag and move the
camera. Changing the view in the preview does not change the initial view of the solid when it opens
in ArtiosCAD.
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If there is no preview, that means there is no data ArtiosCAD can break into triangles, such as 3D
arcs or 3D points. Also, there is no preview for SolidWorks files.

3. Click OK to finish importing the solid.

If you get an error message about an unsupported format, it could be because there are accented
characters in the filename. Rename the file and try again.

Collada file format support
ArtiosCAD now supports the Collada intermediate file format for use in 3D.

The Collada format has two file types: .DAE and .ZAE. .DAE files are XML files that do not contain
included graphics or other binary data. .ZAE files are compressed archives containing a .DAE file and
the necessary textures, graphics, and other files to render the .DAE file properly.

The default Collada entry in the Outputs-3D Catalog creates a .ZAE file.

To preserve round-trip abilities between Esko applications, ArtiosCAD warns you when you try to
adjust an object that originally came from a Collada file. When you import a Collada file, ArtiosCAD
creates a link between the contents of its native workspace and the Collada file. If you then re-export
that workspace as a .ZAE, ArtiosCAD bundles the original Collada file into the archive to carry over its
information into the new file. Changing the properties of the imported objects in ArtiosCAD breaks that
link, and that is the data loss referred to in the warning.

If the Collada file contains more than one object, ArtiosCAD groups the contents of the Collada file
together upon import to keep them together.

If you will be exporting the workspace to Collada again, carefully consider the desired changes. It may
be better to arrange the object(s) as desired in the source application before you export to Collada and
import into ArtiosCAD.

ArtiosCAD can export 3D workspaces as single-body Collada files. On the Collada Options tab of a
Collada 3D Output, Output as single body defaults to unchecked, but you may check it as desired.
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Selecting this checkbox turns off graphics in the exported Collada file as it may have one color and
texture. ArtiosCAD will use the outside color for the body color.

Collada notes and warnings
When you export a foldable design from ArtiosCAD in Collada format that does not contain any
graphics, Visualizer treats the entire design as if it were a print area, thereby allowing you to apply
graphics.

When you load a Collada file with printable areas into Esko ArtiosCAD and no graphics are available,
ArtiosCAD shows a checkerboard texture in those areas. When you export back to the Collada format,
that checkerboard texture will output with the Collada file as if it was the true graphic.

When you load a Collada file into Visualizer or Studio, the first printable area will be white, while the
remaining printable surfaces will render normally.

For printable areas in a Collada file to be double-sided, there must be at least one transparent object in
the scene.

Scale Designs tool

 The Scale Designs tool changes the scale of solids. Use it when:

• A solid is at the wrong scale (for instance, it is measured in meters instead of millimeters and thus it
needs to be scaled up by 1000).

• The size of a solid is not right and needs to be adjusted (for instance, when a cup is too short and
needs to be taller).
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In the first case, apply a uniform scale change, in which all three dimensions change equally. In the
second case, apply a differential scale change, in which dimensions change independently of each
other.

Note:  You may need to update or recreate an animation sequence (if one exists) after using
this tool.

1.
 Select the solid(s) to change.

2.

 Click Scale Designs. If you select a single instance of a solid with multiple copies, ArtiosCAD
asks if you want to modify all the copies or just the selection. Note that if you make a separate copy,
ArtiosCAD cannot undo that action.
 

 
3. In the Scale Solid Designs dialog box, choose the appropriate options for your desired changes.

a) Choose either Uniform scale or Differential scale.
b) For X, Y, or Z, enter either the new size or choose a scale factor from the drop-down list box.

Click inside the Scale factor field to enter a custom value. ArtiosCAD shows the size of the
bounding box for the selected design(s) as the initial size.
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4. Click OK to apply the changes and return to 3D or click Apply to apply the changes and remain in

the dialog box for more changes. ArtiosCAD scales the selection around the center of the overall
bounding box. It does not change the position of the object(s) after changing the scale, so you may
need to move them manually (as seen below by the intersecting side of the tray).
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Cross Section toolbar

The tools in the Cross Section toolbar let you make and adjust pieces of folding carton or corrugated
board that intersect with objects in the 3D workspace.
 

 
These tools require the 3D Designer license.
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Intersect Design tool

 The Intersect Design tool creates holes in a corrugated or folding carton design where it
intersects other designs or solids. The tool has the following controls on the Status bar:
 

 

Enter a value in the Offset: field to specify a gap between the intersecting object and the cutout in the
intersected object.

 The first button on the Status bar, Intersect Designs, sets the tool to use cut lines to make the hole
boundaries in the flat design.

 The second button on the Status bar, Intersect Designs All The Way Through, sets the tool to
make complete cut-outs for objects such as wine glasses.

 The third button on the Status bar, Intersect Designs with Annotations, sets the tool to use
annotation lines to make the hole boundaries in the flat design.

To use the tool, do the following:

1. Position the objects together.
2.

 Click Intersect Design on the Cross Section toolbar.
3. On the Status bar, enter an offset if desired, select or clear the Round corners checkbox (to create

rounded corners in the holes), and choose the mode for the intersecting lines.
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4. Click the intersected corrugated or folding carton design.
5. If the single design workspace corresponding with the selected 3D object exists, ArtiosCAD

prompts you to update it or create a new single design. Set the option button as desired and click
OK. Clicking Cancel stops the tool.

6. Choose a parameter set for the design. If you are updating the existing design, the previously-
selected parameter set is selected.

To accept the changes to the single design and return to 3D, click OK. You may want to move the
dialog box to see more of the design.

To make changes to the single design, click Edit 2D, make the changes, click Convert to 3D on the
View bar, and update the 3D workspace.

7. Once you return to 3D, the view changes to show transparency with purple edges to make the new
holes more visible. Clicking any Select tool turns off the temporary transparency. Shown below is
tray with temporary transparency turned on and the 1/8” offset around the solids.
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Shown below is the final result with the bars removed.

Note:  Any copies of the design will have the same holes made in them.
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The filename for the flat workspace containing the intersected design is generated from the filename
of the 3D workspace, plus a number that increments by one for each intersected design.

Cross Section tool

 The Cross Section tool creates a piece of folded board with cutouts for the portions of objects it
intersects. The size of the bounding box determines the size of the folded board created by the tool.
Before using this tool, adjust the bounding box as needed using the instructions in the next section.

To use this tool, click it, select the start point of the piece of folded board, and make the desired
geometry using drag similar to that of the Line tool in Single Design. Shown below is a step in the
construction of a cross section.

Shown below are the controls on the Status bar in greater detail.
 

 

The Angle:, Length:, X:, and Y: fields all behave as they do for the Line tool in Single Design.

Round Corners, when selected, has the tool create rounded corners in the holes it creates.

 The Undo button undoes the last piece of geometry created. It is very important to use this button
instead of pressing CTRL-Z, as pressing CTRL-Z will undo everything the tool has made up to that
point, not just the last segment.

 The Intersect Designs button has the tool create cut lines in the folded board where it passes
through other objects.
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 The Intersect Designs All The Way Through button has the tool create complete cut-outs for
objects such as wine glasses.

 The Intersect Designs with Annotations button has the tool create annotation lines in the folded
board where it passes through other objects.

 Clicking More Options  opens the Cross Sections Parameters dialog box:

The Board Information tab lets you choose the board and set the caliper of the folded board. The
default board is used initially, but if you change it, the new board becomes the default for the tool in the
current workspace.

On the Width/Length tab, choose to Use bounding box width to set the size of the folded board, or
click Specify width and enter a value in the Width: field.

Round lengths rounds the board lengths to the nearest increment specified in the Rounding value:
field. When checked, it is initially set to the rounding value set for the board.

A value in the Offset: field adds a gap between the piece of folded board and the object being cross
sectioned.

Note:  Defaults for the Intersect Design and Cross Section tools are in Options > Defaults >
Shared defaults > Startup defaults > 3D Tools Defaults.

 Clicking OK on the Status bar completes the geometry and calculates the cross section.
The amount of time it takes to make the cross section depends on the complexity of the design as
well as your computer hardware. Clicking another tool before clicking OK cancels the cross section
completely.

To make a cross section, do the following:

1. Open the design that will have a cross section made around it.
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2.
 Use the Bounding Box tool to modify the size of the bounding box.

3.
 Click the Cross Section tool.

4. Click the start point for the piece of folded board. To move by an offset from that point, hold down
CTRL and click in the desired location.

5. Click and drag to make the desired geometry. The drag snaps to existing lines, but also has
enough of a cutback to allow for the board thickness depending on where you click. You can hold
down CTRL while clicking to move the start point for the geometry, but make sure all pieces are
connected.

6. When done creating geometry, click OK to create the piece of folded board.
7. Choose a parameter set for the folded board.
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To accept the folded board and return to 3D, click OK. You may want to move the dialog box to view
more of the design.

To make changes to the folded board, click Edit 2D, make the changes, click Convert to 3D on the
View bar, and update the 3D workspace.

8. Once you return to 3D, the view changes to show the folded board in transparency with purple
edges and no perspective, and the View Angle tool is activated. Clicking any Select tool turns off the
temporary transparency.

Shown below is a view from underneath to show more detail.
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The folded piece of board is a series of panels connected with creases or reverse creases depending
on the fold angle. ArtiosCAD positions the design so there are more creases than reverse creases.

The filename for the flat workspace containing the folded piece of board is generated from the
filename of the 3D workspace, plus a number that increments by one for each cross section
workspace.

Bounding Box tool

 The Bounding Box tool creates a bounding box around all the objects in the 3D workspace, and
lets you adjust the size of the bounding box. The Cross Section tool uses it to define the size of the
flat design created as a cross section, and the Run a Standard tool uses it for the dimensions of the
standard it creates.

The bounding box grows to accommodate designs added to the 3D workspace, but is unaffected when
objects are removed.

Note:  The Bounding Box tool does not work with CloseUp windows.

When you click the tool, the view changes to the closest orthogonal view, and perspective is turned off.
The fields on the Status bar become available when you click a side of the bounding box. The drag is for
the active field in the Status bar.
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Shown below are the controls on the Status bar:

The value in the Overall: field shows the distance from the opposite side of the bounding box. Spacing:
refers to the distance from the closest edge of a design. Offset: is the distance from the previous
position of the side being adjusted.

 The Move Both Sides button toggles the adjustment of both parallel sides at once.

Reset snaps the last bounding box edge adjusted back to its minimum spacing from the edge of the
object.

Reset all adjusts the bounding box edges to encompass all items in the 3D workspace.

Only two dimensions are shown in the orthogonal view. Use the Rotate View tools to adjust the view so
that the other dimension of the bounding box can be adjusted.

Rotating solids using the bounding box
When importing a solid, it may not be defined to be square to its bounding box as shown below. Use the
bounding box and the Align With button in the Rotate tool to make it square to the bounding box.
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Note:  Snap to solids must be selected in Options > Snap Options for this procedure to work.

To make the binoculars square to the bounding box, and to resolve similar situations with other solids,
do the following:

1.
 Click the Bounding Box tool to show the bounding box and change to orthogonal view.

2. Select the item to adjust.
3.

 Click the Rotate tool and click the axis around which to rotate the object. In the example below,
the axis orthogonal to the view is selected.

4. Click the edge of the solid to align with the bounding box. For the binoculars, the bottom edge of the
bigger lens was used.

5. Click the edge of the bounding box with which to align the object.
6. The object rotates.

7.
 Note how the bounding box is no longer correct. Click the Bounding Box tool and use the Reset

button to snap the edges to their minimum clearances. Shown below is the final result.
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Run a Standard tool

 The Run a Standard tool creates a design from a Standards Catalog entry using the dimensions of
the bounding box as the dimensions of the design.

To run a standard, do the following:

1. Adjust the bounding box as desired. You may want to make it slightly bigger than the object it will
contain to allow for board thickness.

2.
 Click the Run a Standard tool.

3. Click the side of the bounding box that will be the length dimension of the new design.
4. Click the side of the bounding box that will be the width dimension of the new design.
5. Choose a standard from the Standards Catalog and click OK.
6. Choose a parameter set and board and click OK.
7. If the standard does not contain any of the L, W, or D variables, map the existing variables to the

length, width, and depth and click OK.
8. Proceed through the standard prompts as usual, clicking Next to go to the next menu or OK to skip

the remaining menus and make the design.
9. Choose a base face for the new design. It appears in the 3D workspace. If the standard contains fold

angles, they are used; if not, the design is shown flat.

10. Fold it as desired.
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11. The single design will be open in another ArtiosCAD window. Save it as desired.

Note:  Designer WorkBench standards, or those that reference them, may not be used with this
tool.

Note:  If the standard contains a crease that crosses more than one panel, a warning will
appear. If you proceed, panels may be missing from the 3D design created. For best results,
split creases in standards that cross panels.

Convert to 2D tool
The Convert to 2D tool on the Tools menu lets you create a flat design out of a corrugated or folding
carton design in a 3D workspace. This is useful when you receive a 3D workspace from someone else
without the corresponding flat design(s) and you want to make changes to the design(s).

When you convert a design to 2D from 3D, the following restrictions apply:

• Curved lines are converted from a series of straight lines into arcs. Arcs smaller than 3 millimeters
may not be converted exactly as they were in the 3D design.

• The 2D design line pointages are all set to 2.
• Cut lines should have most of their bridges but crease lines will have none.
• The 2D design will have no graphics.
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For example, if you received the workspace shown in the Cross Section tool documentation, and
needed to modify the piece of corrugated board supporting the binoculars, you would do the following:

1. Click Tools > Convert to 2D.
2. Choose a parameter set and click Edit 2D.
3. Edit the flat design as desired in Single Design.

4.
 Click Convert to 3D on the View bar, choose Update 3D, click OK, select the base face, and

click OK. The updated workspace is shown.

Add Hardware Tool

 Add Hardware adds solid hardware such as hooks and their associated holes to the 3D design,
and, if the corresponding 2D design is open, the holes required for the hardware to the 2D design and
placement lines to assist with rebuilding and reconverting. It also allows you to place products on the
hooks. You can place just one hook in Single Placement mode, or you can place an array of many hooks
in Array Placement mode.

Shown below is a countertop display with the tray part filled by Array Copy and hooks and products
applied in an array to the header by Add Hardware.
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If you view the back, you can see the holes and the hook attachment pieces.
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The 2D workspace has the proper holes along with placement lines in the 3D Assist layer if you rebuild
the design and reconvert it to 3D.
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Before You Begin

Before you begin using Add Hardware, keep the following in mind:

• ArtiosCAD links the 2D and 3D workspaces. Add hardware only when the design is complete. If
that is not possible, if you add hardware in 3D, switch to 2D and make changes, you must convert
the 2D to 3D again and select Update 3D in the Convert to 3D dialog box. Do not just switch to
the 3D window. If you do not follow the convert\update path out of 2D, the risk of the 2D and 3D
workspaces becoming desynchronized increases. It will then become more dicult for ArtiosCAD
to align panel sizes and holes between the two workspaces.

• If you will be using a product (something hanging on the hook), make sure it is oriented correctly
with respect to the axes, not the view angle. The hole should be at the top and the product should be
facing you.

• A product must have at least one hole in it for ArtiosCAD to recognize it as such.

• Similarly, for any design, make sure the Z axis is up and rotate the design so it sits flat on the floor.

• Set the view angle so that you are looking directly at the panel in which you want to place hardware.
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• Don't use panels that use curved creases.
• Don't use designs with tear-away parts.
• FFR hook models have text on their right sides that causes them to be slightly asymmetrical.
• ArtiosCAD creates layers for the hardware parts as needed unless layers of the right class exist and

are unlocked. Any layers it creates apply to all print items.

• Accordingly, layer limits apply. If the 2D document is at the limit for the number of layers, close it.
Add Hardware will work in 3D but the 2D document will have no knowledge of the holes you make.

• Hardware placement lines have their own properties page. If only some of the copies have the
selected hardware in them, ArtiosCAD shows how many copies use it. Do not ungroup the hardware
placement lines.

• If the hardware in the 3D workspace matches existing hardware in an associated open canvas
(either the full path or managed path matches), ArtiosCAD updates the part count of the existing
part rather than adding a new instance of the same part.

Supported Product Shapes
ArtiosCAD supports the following shapes for use as products with Add Hardware.

Blister card:
 

 

Blister box carton with hole:
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One-piece blister box solid with hole:
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One-piece blister box solid with hook:
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ArtiosCAD centers the inside top point on the hook.

If you get unexpected results when working with a hooked design, see how the outline looks that
ArtiosCAD makes when you select it as the product. If the outline does not conform to the area of the
hole formed by the hook, you may experience problems. Shown below is a hook that will work properly.
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When ArtiosCAD places this on a hook as a product, it centers it correctly.
 

 

Starting the Tool and Selecting the Hardware

1. Create or open the 3D design to which you want to add hardware. Make sure it is oriented correctly
with respect to the axes with Z being up.

2. If you want to hang products on the hardware, use File > Add a Design, Add to Open 3D, or paste
from the clipboard to add the products. Make sure the products are oriented correctly with respect
to the axes, are facing toward you, and that they have a hole or hook at their tops to hang from.

3.

 Click Add Hardware. The Select Hardware dialog box opens.
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As you hover over a piece of hardware, ArtiosCAD shows you a preview and its description.
 

 
If you start typing in the Name field, ArtiosCAD filters the list for easier searching.
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4. When you have chosen the piece of hardware to add, click either Single Placement to just place one

piece of hardware at a time or click Array Placement to place a grid of multiple pieces at once.

Using Single Placement Mode

1. Once you have chosen the piece of hardware to add, click Single Placement in the Select Hardware
dialog box.

2. Click inside the panel of the box to work in to set the working area. The working area is the largest
rectangular plane of the panel where you clicked that has no collisions with other geometry, and
it is always rectangular with respect to the axes. The point at which you click inside the panel
determines the justification reference point for the hardware which is represented by a blue cross.
If you click in the center of the panel, ArtiosCAD measures from the center of the panel. If you click
at the top center of the panel, ArtiosCAD measures down from the top, and so forth. In the example
below, the center of the panel is the justification reference point.
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3. The Single Placement Options dialog box appears.
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4. To put a product on the hardware, click it near its hole or hanger. The name of the product appears
in the Product field. To remove the product from the hardware, click Clear.
 

 
5. The X and Y fields prompt for the position of the hardware offset from the alignment point, which

you can also set using drag. The active field has a dark blue drag measurement line. To change the
justification point, click one of the justification buttons at the top right of the dialog box. Change
the margins of the work area as desired in the Work Area Margins group.

6. Position the hardware as desired and click to set the put-down point. You can place it outside of
the working area but inside the same panel if there are no collisions with anything else. If you have
an existing hole in the panel, you can snap the hardware into that hole as long as their sizes match
within 0.1 mm. If you use an existing hole, ArtiosCAD does not update the corresponding open 2D
workspace.
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If you have a product on the piece of hardware, the Gutter, Offset, and Count fields are available.
Gutter and Offset have no effect in Single Placement mode, but Count sets the number of products
on the piece of hardware.

7. Repeat as desired to place more hardware.
8. Click Exit when done placing hardware.
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ArtiosCAD displays wrong placement or numbers with red drag and error messages in the status field
at the bottom right of the window. Shown below is a collision.
 

 

 If you need to change the view while placing hardware, click View Angle, change the view, and
then press ESC to return to adding hardware.
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If you have multiple instances of a design to which you add hardware, ArtiosCAD prompts you if you
want to add the hardware to all instances, just the one in which you clicked, or split the design with
hardware into a separate copy.
 

 
If there are more than 40 duplicates, the add to all option is unavailable as this would create too many
copies.

If you choose to make a separate copy, ArtiosCAD shows options for updating the 2D workspace.
 

 

In the example above, ArtiosCAD shows two rows for the affected 2D workspace,
DISPLAY_SHELVES.ACD, a canvas. The first row is for the existing workspace and the second row
is for the part workspace it will create for the separate copy. Double-click the new part's entry in the
Part Name field to change it. You can choose to create the new workspace by checking the Create
New checkbox. Likewise, you can choose to update the part count in the existing workspace using the
Update Part Count checkbox.

Using Array Placement Mode

1. Once you have chosen the piece of hardware to add, click Array Placement in the Select Hardware
dialog box.

2. Click inside the panel of the box to work in to set the working area. The working area is the largest
rectangular plane of the panel where you clicked that has no collisions with other geometry, and
it is always rectangular with respect to the axes. The point at which you click inside the panel
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determines the justification reference point for the hardware which is represented by a blue cross.
If you click in the center of the panel, ArtiosCAD measures from the center of the panel. If you click
at the top center of the panel, ArtiosCAD measures down from the top, and so forth. In the example
below, the top left corner is the justification point.
 

 
3. The Array Placement dialog box appears.
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An array of hardware also appears in the working area.
 

 
4. To put a product on the hardware, click it near its hole or hanger. The name of the product appears

in the Product field.
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To remove the product from the hardware, click Clear. ArtiosCAD recalculates the array.

5. Adjust the values in the Array Placement Options as desired. When you click inside a field,
ArtiosCAD will show you what you are adjusting with visual feedback. As you change a field,
ArtiosCAD recalculates the other fields and updates the array. Hold down SHIFT or CTRL to
increment the Count and Fill spin controls by 5 instead of 1.The distance fields increment by the
Nudge Options values in Startup defaults.
a) Margin is the distance between the outermost edge of the bounding box of all the hardware/

products and the edge of the working area.
b) Gutter is the distance between the bounding box of the hardware/product in one column or row

and the next column or row.
c) Offset is the distance between the pickup point of the hardware in one column or row and the

next column or row.
d) Count is the number of hardware/products in a direction.
e) In the Fill row, Gutter, Offset, and Count affect the placement of the product on the hardware.

This row is only available when there is a product. Gutter is the distance between two products.
Offset is the distance from the start of one product to the start of another product. Count is the
number of products on the hardware.

6. Click OK to place the array if you do not want to make another array. To immediately start making
another array without having to restart the tool, click Repeat.
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7. Because less than half of the working area was filled, the rest of the panel has another working

area on it which you can fill with a different array. Select the new working area and click near the
justification point.
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8. Repeat the process of adding a product and setting the dimensions of the array. Click OK in the

Array Placement Options dialog box when done.
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ArtiosCAD displays wrong placement or numbers with red drag and error messages in the status field
at the bottom right of the window. Shown below is a collision.
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 If you need to change the view while placing hardware, click View Angle, change the view, and
then press ESC to return to adding hardware.

If you have multiple instances of a design to which you add hardware, ArtiosCAD prompts you if you
want to add the hardware to all instances, just the one in which you clicked, or split the design with
hardware into a separate copy.
 

 
If there are more than 40 duplicates, the add to all option is unavailable as this would create too many
copies.
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If you choose to make a separate copy, ArtiosCAD shows options for updating the 2D workspace.
 

 

In the example above, ArtiosCAD shows two rows for the affected 2D workspace,
DISPLAY_SHELVES.ACD, a canvas. The first row is for the existing workspace and the second row
is for the part workspace it will create for the separate copy. Double-click the new part's entry in the
Part Name field to change it. You can choose to create the new workspace by checking the Create
New checkbox. Likewise, you can choose to update the part count in the existing workspace using the
Update Part Count checkbox.

Using the Select Hardware Tool to Delete Hardware

Select Hardware on the 3D Tools toolbar lets you select hardware, optionally the hole it uses, and
the product on the hardware. Once you have made a selection, you can then delete what is selected.

1.
 In a workspace containing hardware, click Select Hardware.

2. On the Status bar, leave Include Holes selected, or deselect it to keep the holes. When Include
Holes is selected, you may only select hardware in copies of the same design.

3. Click an individual piece of hardware to select it, or hold down SHIFT or CTRL and click multiple
pieces. You can also click and drag a window to select everything inside the window.
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4. Once you have selected the hardware, press DEL on the keyboard to delete the selection.
5. If the change impacts a design with multiple copies, ArtiosCAD asks you what to do in the Duplicate

Designs Options dialog box. You can either delete the hole(s) and hardware from all the copies, or
split the existing design. Click OK when done.
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6. ArtiosCAD deletes the hardware and holes (if included). If there were multiple instances of the

hardware, ArtiosCAD deletes those too.
 

 

When you delete hardware using this tool, ArtiosCAD updates the connected 2D design as well if it is
open. If Include Holes is checked, ArtiosCAD deletes the holes too. Note that removing the holes is
only possible using Select Hardware with Include Holes selected. It is possible to remove the hardware
using the normal Select tool, however.

If the part count drops to 0, ArtiosCAD removes the part.

Updating the 2D Workspace After Adding Hardware in 3D
When you are adding hardware in 3D and have the single design or canvas workspace open, ArtiosCAD
updates the flat workspace automatically. ArtiosCAD does not update the flat workspace if it is closed.

ArtiosCAD adds holes created by Add Hardware to the Windows and Cutouts layer of the flat design.
If this layer does not exist, ArtiosCAD creates it. If it does exist, ArtiosCAD adds the holes to it. If
print items exist, ArtiosCAD looks for a layer of class Windows and Cutouts in the current print item,
adds the holes to it if it exists, or creates the layer if it does not exist. Note that it will add them to the
current print item; ArtiosCAD does not record which print item was current when it converted the
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workspace to 3D so if you changed print items after converting to 3D, ArtiosCAD may put holes in an
incorrect print item.

The holes ArtiosCAD adds are line type cut, pointage 2. There is no Default for this.

If the open flat design is the linked canvas, ArtiosCAD adds a thumbnail image of the hardware part to
the canvas. The count on this part is the current part count in 3D.

Add Hardware adds placement lines to the 3D Assist layer in the flat design so that if you reconvert
it to 3D, ArtiosCAD positions the hardware correctly. Update 2D does not modify non-matching
placement lines or hardware parts in 2D if you have changed them manually.

Undo/Redo in 3D of Add Hardware updates the open flat workspace.

In a 3D workspace created from a canvas, if the 3D has multiple copies of a part, and when adding
hardware you choose to split the changed copy into a new design, ArtiosCAD does not add the holes to
the original part in the canvas as it is no longer associated with the split copy in 3D.

If you rebuild a flat design with holes in it, ArtiosCAD does not recalculate the position of the holes if
the panel changes size.

If you have more than one view of the flat design open, ArtiosCAD only turns on the Windows and
Cutouts layer in the first view. Turn the layer on manually in other views if desired.

Add Hardware Tool Notes

General Notes
ArtiosCAD checks that the current board matches the caliper range of the selected hardware, but does
not prevent you from using hardware that is too big or too small.

FFR hooks have text on one side which makes them slightly asymmetrical.

Undo/Redo do not change the splitting of designs when adding hardware.

Modifying or deleting holes in 2D does not automatically update the 3D workspace. Reconvert the
changed 2D workspace to 3D and select Update 3D in the Convert to 3D dialog box to update the 3D
workspace.

Select Hardware only selects hardware close to a hole in a panel. If you delete the hole only, the tool
cannot later delete the orphaned hardware. Use Select Designs to select and then delete the hardware
in that case.

If copies of a design are rotated differently than the original, and you add hardware to the original that
gets duplicated to the copies, the hardware in the copies may not be aligned correctly.

In single placement mode, ArtiosCAD checks if there is already hardware defined for this hole in the
linked flat design, and if so, warns you.

Notes on Adding a Product
A product must be a single carton or solid with a suitable hole or hook for hanging. Put the hook or hole
at the top, with the front of the product facing toward you.

If a product has curved creases or bends, the hook or hole must be in a flat panel.

If a product has more than one hole or hook, ArtiosCAD selects the hole or hook closest to where you
clicked.

For a product that is a solid, a hole must go all the way through a thin (less than 1 cm) part of the solid.

For a product that is a solid with more than one hole, ArtiosCAD selects the largest hole it finds.
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Working Area Notes
The working area calculation checks for collisions that as close as 0.3mm and as far away as the
distance required to place the hardware. ArtiosCAD does not check for collisions behind the working
area.

You cannot select panels for the working area that are smaller than the hole required by the hardware.

Bend panels, curved crease panels, and designs with tear-away parts are not supported.

ArtiosCAD orients the hardware in 3D just as it is oriented in its native workspace regardless of the
current view angle. ArtiosCAD orients hardware the same way it is shown in the preview when you
hover over it while selecting it. To put the hardware on the other side of the panel, stop the tool, change
the view angle so the desired side of the panel is facing you, and restart the tool.

ArtiosCAD also orients the hardware so that the surface of the reference board in the hardware
workspace is aligned with the side facing you in the 3D workspace.

Depending on the panel geometry, you may not be able to initially select the desired alignment point.
Set the working area anyway and change the alignment point using the controls in the placement
options dialog box.

If you put hardware in a panel that is flat on the floor, ArtiosCAD orients the hardware so that its
positive Z axis matches the positive Y axis of the flat workspace.

Some ArtiosCAD standards do not use the XY plane as the floor. Before you use Add Hardware, make
sure to orient the workspace so that Z is up and the designs sit on the floor.

It is possible to select a panel for the working area that is not currently visible due to the view angle.
Thus is it possible to place hardware extending into the interior of the design.

Add Hardware only modifies one panel at a time. It is possible to have a working area extend across
adjacent panels but ArtiosCAD only puts holes in the panel in which you clicked.

Array Calculation Notes
You may not use expressions in any of the fields in the Array Placement Options dialog box.

Holes of hardware components may not overlap. However, hardware and products may overlap holes.

Add Hardware will not add more than 500 holes per panel. ArtiosCAD warns after 200 holes and stops
showing array drag to maintain performance levels.

For the above limit, hardware that creates more than one hole per piece counts as the number of holes
it creates, not the number of pieces of hardware. For example, a 2-prong hook is one piece of hardware
but counts as two holes.

Creating a Hardware Component from a Solid Model
You can create your own hook-style hardware component for use with Add Hardware. Review the solid
model carefully to ensure there are no gaps or sharp angles between surfaces, which may cause it to
not work properly.

1. Open the solid model of the hardware component in 3D. You might want to perform this procedure
on a copy of the original as it modifies the workspace and cannot be undone.

2. Orient it so that the piece that attaches to the board is vertical and the projecting part is facing
toward you. Bad alignment:
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Good alignment:
 

 
3. Click Options > Set as Hardware Component.
4. ArtiosCAD opens the Convert Hardware Model to 3D Hardware Component dialog box. Read it

carefully, and then click Yes to convert the workspace to a hardware component.
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5. ArtiosCAD displays the Hardware Properties dialog box in which it displays the computed calipers

this hardware can work between along with the computed length of the usable part. Adjust the
Minimum and Maximum fields as desired and click OK.
 

 
6. ArtiosCAD adds a piece of corrugated board as an alignment piece and creates the necessary

hole(s) in the board where the hardware intersects. ArtiosCAD shows the hole(s) with green lines.
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If you need to change the holes, typically to make the hole taller to allow for easier hardware
insertion, do the following:
a) Click Tools > Convert to 2D and click the alignment piece.
b) Set a parameter set if prompted.
c)

The holes are in the Main Design layer. Click the Layers control on the stage bar to turn off
the Grip position layer (the green lines showing the position of the hardware).
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d) Adjust the holes as needed.

 

 
 

 
e)

 Click Convert to 3D on the stage bar and pick Update 3D in the Convert to 3D dialog box.
The holes in the alignment piece show the changes you made.
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7. Click File > Save As.
8. In the Save Hardware to Defaults dialog box, click Save to Defaults to save the workspace and add it

to User Defaults.
 

 
9. In the next Save Hardware to Defaults dialog box, enter a name, description, and filename (ending

in .A3D) in the fields and click OK.
 

 

1887



14 ArtiosCAD

10. If you are using ArtiosCAD Standard Edition, the hardware is now ready for use. If you are using
ArtiosCAD Enterprise, enter a description in the Database Information dialog box and click OK.
 

 

The new hardware appears in the Select Hardware dialog box when you use Add Hardware.
 

 

If you would rather add the hardware to Shared or Location Defaults, click Save instead of Save
Hardware to Defaults dialog box, save the file to ServerLib or the Shared Defaults Project, and add an
entry for it in the 3D Hardware Components catalog in the desired tier of Defaults.
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Creating a Hardware Component from Scratch
You can create a hardware component manually instead of using a solid model from an outside source.
Follow the general procedure for creating a hardware component from a solid model, but with these
differences:

• In 3D, make it from carton pieces or from solids of revolution, making sure it makes a complete
outline with no sharp angles.

• Set as Hardware Component combines all non-corrugated pieces into a single solid that becomes
the hardware component.

• ArtiosCAD treats the corrugated pieces as alignment pieces and supports only one alignment piece.
The alignment piece:

• Must be a corrugated rectangle.
• Must have at least one hole.
• Must be aligned vertically.
• Should have the correct holes.
• The caliper should be around the minimum it will be used with.
• The front surface of the alignment piece should align with the front of the grip (the part that

attaches the hardware to the alignment piece).
• Rotate the view so the hardware points toward you.

• If you need different holes for the same piece of hardware, create separate workspaces with those
holes and separate entries in the 3D Hardware Components catalog.

Modifying a Hardware Component
If you need to change the caliper of an existing hardware component, open its workspace (presumably
in ClientLib, ServerLib, or one of the Defaults Projects) and click Options > Hardware Properties
to change the range of supported calipers.
 

 

To change the length, which does not always behave predictably and is unsupported, click Help >
Diagnostics > Stretch Hardware, enter a new length, and click Stretch.
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Save the workspace, making sure to save it to the proper Defaults location.

Fill Display Tool
This tool enables the powerful Fill Display workflow.

Display Filler is a workflow where you drive the creation of your display based on your product
alignment / layout on its shelves. It allows you to do in minutes what used to take you hours.
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Learn more in Display Filler on page 1951.

Toggle Display and Shelves Mode
When working with the Fill Display tool (while it is activated) you can use this tool to toggle between

• viewing the full display (including the shelves and their products)with products,
• viewing only the shelves and their products. This view is easier when you still want to check or edit

this setup.

Rebuild Tool Overview

 Rebuild on the Cross Section toolbar and the Tools menu lets you rebuild a design in 3D in the
same ArtiosCAD session after you converted it from a resizable 2D design.
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To rebuild it in a future ArtiosCAD session, reconvert the original 2D to 3D and select Update 3D in the
Convert to 3D dialog box.

Note:

ArtiosCAD deletes any animation when you start this tool.

This tool does not work on 3D designs based on LASERPOINT standards.

Rebuild Tool
To rebuild a design in 3D, do the following:

1.

 Click Rebuild on the Cross Section toolbar or on the Tools menu.
2. Hover over the design to rebuild. ArtiosCAD shows the filename of the design next to the cursor.

• ArtiosCAD turns the design magenta, and turns other instances of the same 3D design a lighter
shade of magenta.
 

 
• If the associated 2D design is not open, or if the 2D design is not rebuildable, ArtiosCAD turns

the design red, displays an error message in the Status bar, and uses a stop cursor.
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3. Click the highlighted design. ArtiosCAD does an Update 2D for the associated 2D design and

prompts you to update part counts if needed.
 

 
4. ArtiosCAD displays the Rebuild dialog box. Change values as desired and proceed through it

normally.
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5. Click OK to complete the rebuild. ArtiosCAD rebuilds the design.

 

 

Notes on Using the Rebuild Tool in 3D
If the rebuild has unexpected results, use Undo to revert to the previous state.
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If the rebuild results in geometry that has more pieces than before the rebuild, ArtiosCAD opens the
Add Unfolded Designs dialog box and prompts you to select base faces again.
 

 
ArtiosCAD does not associate the extra pieces with the 2D document. If there are fewer pieces after
the rebuild, ArtiosCAD does not display the Add Unfolded Designs dialog box.

In the Add Folded Design dialog box, there are different buttons than when you do a regular Convert to
3D. Edit 2D cancels the rebuild and returns to single design so you can make changes, and manually
reconvert to 3D when you are done making those changes. Revert cancels the rebuild, reverts the 2D
to what it was before the rebuild, activates the 3D view, and starts Select Designs. It does not revert
board code changes or part count changes in canvases. OK is unavailable if there are errors.

If the rebuild fails, ArtiosCAD shows the 2D Rebuild Failed dialog box.
 

1895



14 ArtiosCAD

 

If you choose Reset to before rebuild started, ArtiosCAD makes no changes to the 2D or 3D designs. If
you choose Discard remaining log commands or Redo the commands that failed, ArtiosCAD changes
the 2D, makes it active for editing, and leaves the 3D unchanged.

Notes on Splitting Designs

When you split designs in 3D due to adding hardware or changing properties when there are multiple
copies of a design, ArtiosCAD prompts you how to handle making the separate copy caused by splitting
the design.

Depending on the circumstances, and if you tell it to, ArtiosCAD will create a new canvas part or single
design that will contain the added hardware or changed properties.

Canvases
If you accept the default choices in the Duplicate Designs Options dialog box when splitting a design
that is a part in a canvas that is open:
 

 

• ArtiosCAD changes the original part count to match the count in 3D
• ArtiosCAD creates a new part with the same count as in 3D
• ArtiosCAD saves the new part's properties, fold angles, and position in the canvas
• ArtiosCAD associates the new part with the changed design(s) in 3D.

If you deselect Update Part Count:

• ArtiosCAD does not update the part count of the original design in the canvas to match the one in
3D

• ArtiosCAD creates a new part in the canvas
• ArtiosCAD saves the new part's properties, fold angles, and position in the canvas
• ArtiosCAD changes the properties of the selected designs. or changes their hardware
• ArtiosCAD associates the changed designs in 3D with the new part in the canvas.

If you deselect everything:
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• ArtiosCAD does not change the canvas and saves no 3D information

• ArtiosCAD changes the properties or hardware but the designs are no longer associated with any
parts in the canvas.

3D Designs
The Duplicate Designs Options dialog box shows which designs are selected and which ArtiosCAD will
create.
 

 
Each design has two rows. The first row shows information about the current 3D design. The second
row shows information about the ArtiosCAD will create and associate with the selected designs after
the split.

If you change nothing:

• ArtiosCAD creates and opens a new single design

• The new design has the same geometry as the original, but holds the 3D information for the design
selected in 3D

• ArtiosCAD changes the selected design's properties in 3D and associates the duplicates with the
new single design.

If you deselect Create New:

• ArtiosCAD does not create a new single design

• ArtiosCAD changes the selected design's properties in 3D and but does not associate duplicates
with any single design.

Undo/Redo
All changes relating to splitting a design in 3D are on one level. One click will undo or redo them all.

When you undo a split:

• Undo undoes the change of association but leaves the new design open
• ArtiosCAD lists all copies of the design together in the embedded design list

When you undo a property change:

• ArtiosCAD no longer updates the associated 2D design.

• ArtiosCAD saves fold angles but not properties or positions in an associated single design or canvas
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Undo/Redo will not work if you made manual changes to the single design or canvas after doing a split
or property change in 3D, or adding or removing hardware. Also, Undo in 3D will no longer automatically
update the 2D design.

Miscellaneous
Creating new copies when splitting designs or adding hardware deletes any animations.

Any errors (such as exceeded limits) show in yellow in the Duplicate Designs Options dialog box.

Synchronizing changes between 3D and 2D

ArtiosCAD maintains links between 2D and 3D workspaces. If both workspaces are open, It immediately
synchronizes some of these links but others only get synchronized when you save the workspace or use
Update 2D.

Property/Action Change type Workspace type Synchronization type

Hardware holes Structural Single Design Immediate

Hardware holes with no
part split

Structural Canvas Immediate

Color Material Single Design Manual

Color with no part split Material Canvas Manual

Textures Material Single Design Manual

Textures with no part
split

Material Canvas Manual

Board information Structural or Material Single Design Manual

Board information with
no part split

Structural or Material Canvas Manual

Any part split Structural Canvas Immediate

Changing the number of
3D copies

Structural Single Design Not available

Changing the number of
3D copies

Structural Canvas Manual

Splitting an imported design into multiple parts

To split an imported design into multiple parts, do the following.

1.
 Use the Select Labels or Parts tool to select the elements of the design to split into a separate

design.
2.

 Click Group.
3. ArtiosCAD will warn you that you are grouping the selected parts into a separate design. Click OK to

split the parts into a separate design. The selected parts will be a single separate design; they will
not be separated into individual designs.
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Note:  You cannot undo this procedure.

Palletization in 3D

You can round-trip data between Cape Pack/TOPS and ArtiosCAD to palletize a 3D design, make a
secondary (shipping) container in Cape Pack/TOPS starting in 3D, and also to make a pallet load in 3D
starting in Cape Pack/TOPS.

For answers to some frequently asked questions about palletization, see Palletization FAQ in the
Outputs chapter.

Note:

Before using these features for the first time, make sure you have mapped Cape Pack/TOPS
styles and materials to ArtiosCAD standards and boards as described in the Builder chapter.
You may also want to set Cape Pack/TOPS defaults as described in the Defaults chapter.

Palletizing a 3D workspace

To send a 3D workspace to Cape Pack for palletizing and then view the Cape Pack solution back in 3D,
follow the instructions below. If you are using TOPS, the workflow is similar: choose a pallet and send
the information to TOPS, which will palletize the design and send the information back to 3D.

1. In 3D, design a new workspace or open an existing one, and assemble its components as desired.
Make sure to fold it into its final form as its bounding box will be used for the sizing information in
Cape Pack.
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2. Click Palletization > Change Pallet.
3. In the Select Pallet dialog box, select a pallet and click OK.

 

 
4. Click Palletization > Palletize Design.
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ArtiosCAD creates a copy of the workspace and works with the copy in order to not infringe on your
original.

5. In the Cape Palletize dialog box, choose Pallet Group.
6. Set the values in the Package Information and Pallet Information groups as appropriate and click

OK.
 

 

Click OK through any alerts. Cape Pack may prompt you that it is swapping the dimension
directions.

Note:

ArtiosCAD is unusable while waiting for a response from Cape Pack.

7. In Cape Pack, use the Goto Next Solution and Goto Previous Solution arrows to find the best
solution.
 

1901



14 ArtiosCAD

 
8. When you have found the best solution, click File > Export and Exit.
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9. The palletization solution appears in 3D; save it and work with it as a normal 3D workspace.

Remember that this is a copy and not your original 3D workspace.
 

 

Arranging a Group in CAPE around a 3D workspace

In addition to palletizing a workspace from 3D in Cape Pack, you can also create secondary packaging
in Cape Pack for your primary package in 3D.

To create secondary packaging around your primary package, do the following:

1. In 3D, design a new workspace or open an existing one, and assemble its components as desired.
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2. Click Palletization > Change Pallet.
3. In the Select Pallet dialog box, select a pallet and click OK.

 

 
4. Click Palletization > Palletize Design.
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5. In the Cape Pack Palletize dialog box, choose Arrange/Design Group.
 

 
6. Enter appropriate values in the fields:

a) Select the secondary package from the Secondary CAPE Pack Type drop-down list box.
b) In the ArtiosCAD board group, click Properties (...) and select a board code.
c) In the Minimum and Maximum fields, enter the number of primary packages to create secondary

packages for. If you have more than one primary package in your 3D workspace, divide these
numbers accordingly; for example, if you had 4 primary packages in 3D, you would only want 1 or
2 of them in Cape Pack.

d) Enter values for the slack (gaps between the primary packages) and the maximum size of the
secondary packaging, if desired.

e) Check Round to nearest 1/16th if desired.
f) In the Package Information group, enter the weight of the primary package and any solids it

contains.
g) In the Pallet Information group, enter the maximum height of the stacked pallet and its

maximum weight.
h) Click OK.

Cape Pack will launch. Click OK through any alerts. Cape Pack may prompt you that it is swapping
the dimension directions.

Note:  ArtiosCAD is unusable while waiting for a response from Cape Pack.

7. Use the Goto Next Solution, Goto Previous Solution, Goto Next Pattern, and Goto Previous Pattern
arrows to find the best solution. The primary package is the one with yellow and magenta faces,
while the secondary package has red and blue faces.
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8. When you have found the best solution, click File > Export and Exit.
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If you do not have either the styles or boards mapped as described previously, ArtiosCAD will
prompt you to choose the missing elements.

9. ArtiosCAD displays the standard it constructed using the Cape Pack data. Work with the single
design as you would any other workspace.
 

 
10.

 Click Convert to 3D and then Add to 3D with the primary package’s workspace selected, and
then click OK.
 

 

The secondary package appears in the 3D workspace.
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11. Use the tools in 3D to duplicate and align the primary packaging inside the secondary packaging as

desired.
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Creating a Folding Carton Arrange case using Cape

A knock down flat (KDF) is a container that is folded for shipping, arranged into bundles, and then put
into a shipping container (the FCA case) for full assembly elsewhere. In Cape Pack, this is done using
Folding Carton Arrange (FCA) > New Case Sizes > Nested Cartons in Bundles. In ArtiosCAD, this is
called creating an FCA case and is on the Palletization menu.

The workflow is generally:

• Create the flat single design in ArtiosCAD

• Tell ArtiosCAD to create an FCA case and set the parameters

• Calculate the FCA solution in Cape Pack and export the palletization data to ArtiosCAD

• Convert the resulting single design for the case to 3D

• Fold the case at 90 degrees
• Show the palletization data that came fromCape Pack

• Optionally, run a Report showing the FCA case (described in the Outputs chapter).

You may also start with your own single design, convert it to 3D and fold it in half so it is flat, and then
start the workflow from 3D. Both workflows require 3D.

Note:  You must have Cape Pack installed to create an FCA case.

Creating the FCA case and calculating the pallet load
To create the FCA case, do the following:

1. Create a single design, either by running a standard or by making your own, or convert an existing
single design to 3D and fold it in half.

2. Click Palletization > FCA Bundles in New Case.
3. In the Select Pallet dialog box, choose a pallet for the design and click OK.
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4. In the Create New FCA Case dialog box, enter the values you need to make your FCA case.
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a) Length, Width, Thickness 1, Thickness 2, and Weight come from the single design, but you may

change them as desired. Thickness 2 is initially 0 because ArtiosCAD assumes there is only one
fold per knock-down flat carton (KDF) inside the case. If you have more than one fold, enter the
cumulative increase in thickness per KDF past the one double board thickness for one fold. You
can also adjust these thicknesses if one end of the KDF is thicker than the other to have Cape
Pack alternate their positions within the bundle.

b) The length is based on the blank size and ArtiosCAD assumes the glue joint is not folded. If it
is folded, enter its size in Folded Glue Joint. Note that the dimensions and diagram are shown
differently from the ones in Cape Pack but the carton is folded the same way.

c) Click Calculate FCA to calculate the sizes based on the Flatblank to KDF formula in Cape Pack.
d) For the Fluff Factor, enter an estimate of the percentage that the folded cartons might shrink or

expand within the bundles.
e) In the Bundle Counts group, enter the minimum and maximum number of bundles to create.
f) In the Case group, choose the type of case (from Cape Pack) and the ArtiosCAD board code to

use.
g) In the Number of FCAs group, enter the minimum and maximum number of cartons inside the

case.
h) In the Slack group, enter the dimensions for the size of the free space between the bundles and

the cases.
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i) In the Max Size group, enter the maximum size for each bundle.
j) For the Max Weight, enter the maximum weight of the filled case.
k) Click OK. ArtiosCAD will launch Cape Pack.

5. As Cape Pack always thinks that the longer dimension is the length, it may prompt you that the
variables are mismatched. Click OK.
 

 
6. Cape Pack will automatically start calculating solutions.

 

 
7. Use the arrows to review the solutions.
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8. When you have chosen the desired solution, click File > Export and Exit to return to ArtiosCAD.

Folding the FCA case solution from Cape
Cape Pack returns the case and palletization data to ArtiosCAD.

1. If you do not already have any standards mapped to Cape Pack designs, choose the standard to
run to substitute for the FCA case resulting in a single design. You may modify the single design as
desired.
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2.

 Convert the single design to 3D.
3.

 Fold all creases at 90 degrees.
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4. Click Palletization > Show Last Palletization solution.
5. As Cape Pack and ArtiosCAD measure dimensions differently, there may be a mismatch. Click Yes to

continue.
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6. ArtiosCAD displays the palletized case.
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Filling a Case with Cape in 3D

Use Cape Pack's Arrange feature to fill a case with a solid from ArtiosCAD.

Make sure to pick a case that compensates for inside loss when you fold it. To determine if your desired
case will work properly, measure the main panels and see if their sizes match the dimensions you
used to create the container; the measured sizes need to be larger than the dimensions you entered.
You also need to consider the effects of dividers and rollovers that may impact the amount of interior
space available for the product. The way the flaps fold might also intrude on interior space.

Shown below is a FEFCO 204 standard at 18x12x12. As you can see, the panels are larger than the
entered dimensions.
 

 

While you are designing, keep the 3D workspace clean with only the original solid or carton so that
filling the shipper with the Cape Pack-produced array is accurate. If you add items to the 3D workspace
after going through this workflow, your results will not be what you expect as ArtiosCAD will insert the
entire contents of the 3D workspace into the case if you re-palletize.

Starting in ArtiosCAD and Choosing the Case in Cape Pack
To start filling a case, do the following:

1. In ArtiosCAD, arrange your solid or carton as desired in 3D.
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2. Click Palletization > Create Palletized Design.
3. In the Select Pallet dialog box, choose the pallet to use.
4. In the CAPE Palletize dialog box:

a) Set the CAPE Option to Arrange/Design Group.
b) Choose an appropriate case from the Secondary Pack Type drop-down list box.
c) Set the ArtiosCAD board as desired.
d) Enter the weight of the solid.
e) Enter the minimum and maximum number of primary packages (the number of solids or cartons

to put in the case).
f) Enter the slack dimensions and the max size dimensions.
g) Click OK.
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5. In Cape Pack, choose the solution to use. Click File  > Export and Exit to export the information to

ArtiosCAD.
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Returning to ArtiosCAD and Folding the Case
Now that you've palletized the case, the next step is to convert the case to 3D and fill it.

1.
 Back in ArtiosCAD, click Convert to 3D on the stage bar.

2. In the Convert to 3D dialog box, pick New 3D with Fill with Primary Design selected and click OK.
 

 
3. In the Add Unfolded Designs dialog box, select the base face and click OK. If there are previous fold

angles to use, use them.
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4. If the design had fold angles saved, the case should appear in 3D folded full of the primary design.
If the design did not have fold angles saved, or if you need to change the fold angles before filling it,
fold the case as desired and click Palletization > Fill with Primary Design.

5. Shown below is the filled case.
 

 

Running a Cape Cloud Report from 3D

1. Design the 3D workspace as desired.
2. Click Palletization > Cape Pack Cloud > Palletization for Cape Report.

a) ArtiosCAD prompts you for the address of the Cape Cloud server if this is the first time you are
using this feature.
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b) Enter the hostname of the server system. Do not include anything past the hostname in the URL.

 

 
c) To verify the entry, click Test URL. A browser window will try to connect to the specified URL.
d) To save this URL to User Defaults, check Save to User Defaults. It goes to the Cape Pack Cloud

Defaults entry in the Palletization catalog.
e) Click OK.

3. In the Palletization dialog box, enter the desired information and click OK. The only required field is
for Solid/Net Weight.
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4. ArtiosCAD prompts you to log in to Cape Cloud if you are not already logged in. Enter your login

credentials and click Sign In.
 

 
5. ArtiosCAD prompts you to select the cloud account to use. Select one and click OK.

 

 
Select Automatically select this account next time to skip this step in the future.
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6. Cape Cloud launches and opens a new analysis.
7. Fill out the analysis as usual and click Calculate to generate a list of solutions.

 

 
8. Choose a solution from the list and click View Report.
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9. Choose the options and save, share, or download the report as usual.
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10. Close the Cape Cloud window to return to ArtiosCAD.

Assembly Instructions

Assembly Instructions are a pictorial procedure that show how to assemble a design or display step
by step. They can be one step on one page or many steps on multiple pages. The idea is that you take
pictures of the current scene in 3D and paste them into a special document you have created in Single
Design. You can annotate the steps with arrows and symbols in the Annotation Symbols catalog. It is
also easy to add text that is repeated and incremented automatically between the steps and pages.

There is the page, which you base on the paper size of your Output, and there are panels that fit inside
the pane to show the individual pictures. Shown below is a page of an assembly instruction in process
with 4 panels. The step number was added once and repeated to the other panels.
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Tools and Their Functions

Two toolbars contain the tools for making Assembly Instructions; one in Single Design and one in 3D.

Single Design
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Add Instruction Page adds an instruction page to
the current design.

Add Instruction Panel adds an instruction panel
to an instruction page.

Add Instruction Grid adds many instruction
panels at once to an instruction page.

Instruction Panel Spacing lets you change the
gutter between the instruction panels.

Paste into Instruction Panel copies the contents
of the Windows Clipboard into the instruction
panel.

Repeat in Instruction Panel or Page repeats the
selected item(s) into other panels and pages.

Add Annotation Symbol lets you drag and
drop arrows and other annotation symbols into
instruction panels.

Sequence Instruction Panels changes the order
of the instruction panels, which by default is from
top left to bottom right.

Clear Instruction Panel deletes the contents
of the selected instruction panel but leaves the
panel itself intact.

Assembly Instructions View Mode lets you
change how you see certain aspects of the
Assembly Instructions.
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 On the Single Design Stage bar, Mark for Assembly Instructions designates the current single
design as the destination document for the 3D Assembly Instructions Copy tools to paste into. When
you use one of those tools, ArtiosCAD will automatically change focus to that document’s window and
activate Paste into Instruction Panel. Only one single design can use this mode at a time.

3D
 

 

Copy for Instructions copies the entire 3D scene
as currently shown to the Windows Clipboard.

Copy Window for Instructions prompts you to
drag a window around the parts of the 3D scene
as currently shown to the Windows Clipboard.

Copy Detail for Instructions prompts you to drag
a circle or ellipse around a part of the 3D scene as
currently shown to the Windows Clipboard to then
paste in front of another image in an instruction
panel in Single Design.

Adding Instruction Pages

The first step in creating Assembly Instructions is to create a new single design and add Instruction
Pages to it. Turn on and dock the Assembly Instructions toolbar using the Toolbar Master Control if it is
not already on.

1. Create a new design as desired.
2.

 Click Add Instruction Page.
3. This tool has two modes. The first is to use a predefined size from the page table and the second is

to set the size using drag.
4. To use a predefined page size, select one from the drop-down list box and click Add Page.

 

 
5. To use drag, click Add page using drag and then set the values in the X and Y fields as desired either

by using drag or typing them manually. Once both fields are filled in, ArtiosCAD adds the page.
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6. The added page looks like this.

 

 
After you add a page, the current position moves to the bottom right of the new page plus the gutter
distance to easily add a new page. ArtiosCAD remembers the method of adding the previous page
for the session.

Adding Instruction Panels

There are two ways to add instruction panels:

•
 Add Instruction Panel adds one panel at a time.

•
 Add Instruction Grid fills an instruction page with congruent panels.
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Using Add Instruction Panel
You should have an instruction page in the design before you add instruction panels to it.

1. Use Move By (CTRL-Q) to move the current position to the start point for the new panel.
2.

 Click Add Instruction Panel.
3. Set the drag by using the mouse or by entering values in the fields on the Status bar. Clicking the

mouse button sets the size of the window, or pressing ENTER after entering values in each field.
4. The tool continues to add another panel starting at the ending point of the previously created panel.

Add as many as desired.

Using Add Instruction Grid
You should have an instruction page in the design before you add instruction panels to it.

1. Use Move By (CTRL-Q) to move the current position to the start point for the new grid.
2.

 Click Add Instruction Grid.
3. Enter the number of panels in the X and Y prompts.
4. Drag the grid to the desired size and click the mouse button to set the size, or enter values in the X

and Y fields on the Status bar.
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5. ArtiosCAD constructs the grid of instruction panels and numbers them starting at the top left

sequentially after any other panels in the design.
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If you want different spacing between the panels, before creating them, use Instruction Panel
Spacing to change the spacing. You may also move the panels manually after creating them, but it
is easier to change the spacing beforehand.

Resizing and Moving Pages and Panels

 Use Select to resize and move instruction pages and instruction panels.

 After selecting a page or panel, when you move the cursor inside it, the cursor changes to a
move cursor. Click to pick up the page or panel, drag it to the desired position, and release the mouse
button. It will snap to other pages and panels (respecting the gutter between them) as you drag. If there
is text or other items on top of an instruction panel, ArtiosCAD moves those as well. ArtiosCAD does
not do this for instruction pages.
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 Likewise, after selecting the page or panel, if you hover over its edge, the cursor
changes to an appropriate resize cursor. Dragging a corner resizes both sides horizontally and
vertically, while dragging a side resizes either horizontally or vertically.

To change the margins inside a panel, double-click it with Select to access its Properties page, and
adjust the margins there as desired.

Changing the Spacing Between Instruction Panels

 Use Instruction Panel Spacing to change the spacing (gutter) between panels before creating
them. Changing the values in this dialog box only affects panels you create after making the changes.

To change the same spacing in X and Y, change the value in the Spacing field and click OK.
 

 

To change the spacing in both X and Y, check Different X and Y spacing, change the values in both
fields, and click OK.
 

 

Pasting Images into Instruction Panels

Three tools in 3D let you copy images from 3D for use in Assembly Instructions.

Copy for Instructions copies the entire 3D scene
as currently shown to the Windows Clipboard.
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Copy Window for Instructions prompts you to
drag a window around the parts of the 3D scene
as currently shown to the Windows Clipboard.

Copy Detail for Instructions prompts you to drag
a circle or ellipse around a part of the 3D scene as
currently shown to the Windows Clipboard to then
paste in front of another image in an instruction
panel in Single Design.

Note:  There needs to be a destination for these tools’ activity, so you should have a single
design open that contains empty instruction panels before using any of the Copy tools.

 If you have Mark for Assembly Instructions turned on for a single design on the Stage bar,
ArtiosCAD automatically switches to that document and activates Paste into Instruction Panel.

To use other applications with Assembly Instructions, whatever you copy to the Windows Clipboard in
those other applications should be accessible by Paste into Instruction Panel.

Using Copy for Instructions

 To make this faster, turn on Mark for Assembly Instructions on the Stage bar of the single
design.

1. Arrange the scene in 3D as you would like it to appear in the instruction panel.
2.

 Click Copy for Instructions.
3.

 If ArtiosCAD does not automatically switch to the single design, switch to it manually and
click Paste into Instruction Panel. If you have marked the single design, ArtiosCAD does this
automatically.

4. ArtiosCAD displays a drag of the design lines from the 3D workspace. If you have only solids in the
3D workspace, use a view mode like Solid with Edges to see drag lines.
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5. When you drag inside a panel, ArtiosCAD scales the drag image to fit.
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6. Click inside the desired instruction panel. ArtiosCAD places the image.
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If you paste outside of a panel, ArtiosCAD creates a panel around the image. To replace the image in
a panel, simply paste a new image into the panel.

Using Copy Window for Instructions

 To make this faster, turn on Mark for Assembly Instructions on the Stage bar of the single
design.

1. Arrange the scene in 3D as you would like it to appear in the instruction panel.
2.

 Click Copy Window for Instructions.
3. Drag a window around the area to use as an assembly instruction step.

 

 
4.

 If ArtiosCAD does not automatically switch to the single design, switch to it manually and
click Paste into Instruction Panel. If you have marked the single design, ArtiosCAD does this
automatically.

5. ArtiosCAD displays a drag of the design lines from the 3D workspace. If you have only solids in the
3D workspace, use a view mode like Solid with Edges to see drag lines.
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6. When you drag inside a panel, ArtiosCAD scales the drag image to fit.

 

 
7. Click inside the desired instruction panel. ArtiosCAD places the image.
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If you paste outside of a panel, ArtiosCAD creates a panel around the image. To replace the image in
a panel, simply paste a new image into the panel.

Using Copy Detail for Instructions

 To make this faster, turn on Mark for Assembly Instructions on the Stage bar of the single
design.

1. Arrange the scene in 3D as you would like it to appear in the instruction panel.
2.

 Click Copy Detail for Instructions.
3. On the Status bar, choose either Rectangle or Ellipse as the shape of the detail to copy.
4. Drag a window around the area to highlight in the detail.
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5.

 If ArtiosCAD does not automatically switch to the single design, switch to it manually and
click Paste into Instruction Panel. If you have marked the single design, ArtiosCAD does this
automatically.

6. .ArtiosCAD displays a drag of the design lines from the 3D workspace. If you have only solids in the
3D workspace, use a view mode like Solid with Edges to see drag lines. ArtiosCAD does not change
the scale of the detail window.
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7. Click at the desired position inside an instruction panel. ArtiosCAD places the detail in front of an

image that may already be in the panel.
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• To change its size, select it with Select, and move one of its handle points. The detail does not
change size when you change the size of the panel.

• To move it, select it with Select, and then drag and drop it to the new position. The detail stays with
the panel if you move the panel.

Changing Instruction Page Properties

 Double-click the edge of an instruction page with the Select tool to open its Properties page.
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Here you can change the margins, justification position of the instruction panels inside the page
margins, width, and height of the page. You can also change the page number (used for repeated text
such as the page number label).

Click OK when done.

Changing Instruction Panel Properties

 Double-click the edge of an instruction panel with the Select tool to open its Properties page.
 

 

Here you can change the margins, width, height, and justification position of the image inside the
margins of the instruction panel. You can also change the panel number (used for repeated text or
sequencing).
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You can also turn the panel outline and margin on and off with the checkboxes, and elect to use a
stroked line if desired (and set the thickness and color of the stroke). For the stroke color, ArtiosCAD
defaults to black, unless the screen color is set to black, in which case it uses 80% black. We
recommend not designing Assembly Instructions with a black screen background.

If you do not use a stroke, the panel outline is a blue line of type Annotation4, and the panel margin is a
blue line of type Annotation5.

Using Annotation Symbols

 Click Add Annotation Symbol to add an annotation symbol to assembly instructions. ArtiosCAD
opens the Annotation Symbols catalog containing arrows and symbols.
 

 

Select a symbol by clicking it so that it turns magenta, and then move it to the desired position in an
assembly instruction. Repeat as desired for additional symbols; the catalog remains open until you
start another tool.

 Use Select to move or resize an annotation symbol. You can change its color on its Properties
page.

To create your own annotation symbol, just make an ArtiosCAD workspace with the desired art, copy it
to ServerLib, and add it to the Annotation Symbols catalog in Defaults.

Repeating Items in Instruction Pages and Panels

 Use Repeat in Instruction Panel or Page to repeat items of text (such as step or page numbers)
or graphics (such as logos) between panels and pages.

1. Add the text or graphics to the panel or page.
2.

 Use Select to select the item(s).
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3.

 Click Repeat in Instruction Panel or Page. ArtiosCAD automatically copies item(s) and
increments any numbers if they match the panel or page number (settable on the Properties page).
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This tool is unavailable if the selection overlaps an instruction page or instruction panel.

To change a repeated item afterward, update it, select it and click Repeat in Instruction Panel or Page.
ArtiosCAD updates the items and deletes any that overlap.

Sequencing Instruction Panels

 Sequence Instruction Panels lets you reorder the sequence of instruction panels, which by
default goes from the top left to the bottom right of each page from left to right in the order of pages,
or insert or delete instruction panels in the sequence. ArtiosCAD can sequence up to 1,000 panels. The
panel numbers set the values for repeated text.

The following controls appear on the Status bar when you activate the tool:
 

 

When you activate the tool, ArtiosCAD shows the current sequence as numbers on the instruction
panels connected by lines.
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Start Sequence renumbers panels using the order in which you click. The Panel Number field on the
Status bar lets you define the panel number starting the new sequence. If it is the same as an existing
panel number, ArtiosCAD breaks the sequence and starts a new one at that number. To start a new
sequence, either click Start Sequence again or click outside an instruction panel.

Insert inserts an empty instruction panel where you click, shues the existing panels down and to the
right, renumbers the sequence, and draws purple arrows to indicate the new sequence. Items above
instruction panels (such as repeated text and details) move with them. If there are no empty panels at
the end of the sequence, ArtiosCAD may move the end panel off the page.

Before inserting a new instruction panel:
 

 

After inserting a new instruction panel:
 

1948



14ArtiosCAD

 

Deleting a panel works in much the same fashion. ArtiosCAD moves the existing panels up and to the
left, and renumbers them appropriately. Shown below is the deletion of instruction panel 3.
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Clearing an Instruction Panel

 To clear the contents of an instruction panel, click Clear Instruction Panel and then click the
panel to clear. This deletes everything in the panel except for repeated items.

Instruction Panels View Mode

 Click Assembly Instructions View Mode to toggle the display of the panel outline and panel
border, whether to use a stroke, and its width and color if so. This is similar to selecting all the
instruction panels and then opening the Properties page.
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Make the desired changes and click OK.

Assembly Instructions Notes and Considerations

Please bear the following notes and restrictions in mind when using Assembly Instructions.

• Assembly Instructions are supported for a single design workspace only, not a canvas.
• Outputs can be up to 50 pages.
• A panel number must be less than 4 digits.
• ArtiosCAD is limited to about 100 or 200 different images in panels, but if there are few images, it

can handle about 500 panels.

• More than 100 different images in panels will cause delays when opening, saving, and auto-saving.

• Due to the potential large size of the assembly instructions, keep them in separate documents from
your designs.

Display Filler

Display Filler Workflow

Concept
Display Filler is a workflow where you drive the creation of your display based on your product
alignment / layout on its shelves. It allows you to do in minutes what used to take you hours.
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These are the main workflow steps:

1. Laying out products on shelves

The workflow starts by adding any number of products to a 3D scene. You then activate the Fill
Display tool at which point a first new empty shelf will appear. You then easily place and copy
selected products on the shelf. With one click you add a new shelf on which you again place
products, etc.

2. Run a display standard

When the product placement is complete, a standard can be run (one that is tailored to this tool).
This properly positions the shelves within the display body by number, area and height.

Display parts are sent back to canvas. Also structural parts with shelf locations, products as
images, shelf layouts and various shelf perspectives.

When you then still change or correct the 3D (shelves setup), you afterwards do a rebuild display.
3. Output to BOM
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The BOM automatically contains all product parts and many extra views.

Step 1 - Laying out Products on Shelves
We use an example to guide you through these steps:

1. Load products into an a3d file. Supported 3D files are Collada, Step, IGES and ARD/A3D, with or
without graphics.

In our example, we use (some of) these products:
 

 
2. From the Tools menu, or from the  Cross Section toolbar, select Fill Display.

 

 

Selecting this tool already automatically creates a first shelf.
 

 

1953



14 ArtiosCAD

Note:  A shelf is shown in pink when this tool is active and ready for you to place products
on.

The bottom status bar now shows the current dimensions of the (first default) shelf and some extra
tools:
 

 

•
 Toggle Display and Shelves mode: This tool becomes active once you ran a standard. Learn

more in step 2.

•
 Disable shelves dimensions: Disables all shelf-editing tools in this status bar.

• Length of the shelf.

• Width of the shelf.

• Gutter: Distance between placed products.

• Clearance: Distance between top of the tallest placed product on a shelf and the bottom of the
shelf above it.

• Height: Distance from the top of the (selected) shelf to the top of the next shelf above. In case of
the top shelf, it is the height of the placed product + the clearance.

• Add shelf: Creates a new shelf (on top). Each click on this tool creates one extra shelf.

• Fit shelves: Adapts the L W size of all shelves to fit the largest space filled with products.

• Update parts: When you activated Disable shelves dimensions, you cannot rebuild the display
but only choose to update the parts.

3. Define the size of the shelf.

The default dimensions of a shelf are defined in Defaults >  Startup defaults  >  3D Fill Display
Options.

See below when to use Fit Shelves.

Note:  While the Fill Display tool is activate, a shelf is only a surface area ; it has no material
defined.

4. Add products to one or multiple shelves.

a. With the Fill Display tool activated, select one product. It will be displayed in opaque magenta.
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b. Move the mouse (no need to drag) onto the shelf. The product is shown transparent and will snap

to into the shelf's corners or into the next row or column (based on gutter).
 

 

Click to confirm this starting position. The product will become opaque again.
c. Now move or drag the mouse (shown as a cross) over the shelf to fill an area. Let's see some

example steps:

• When moving the mouse near or over the edge of the shelf, automatically appearing blue
dimension lines indicate that the 11th bottle no longer fits on the shelf:
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• We move the mouse back a bit to keep it to 10 bottles and then move across the width of the
shelf:
 

 

• Although the shelf is too small to hold that extra row of bottles, we accept this layout with a
left mouse-click (a right-click will cancel the tentative placement).

d. The product is displayed normal again and the shelf color is back to yellow:
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e. With the Fill Display tool still active, we now click Fit Shelves (in the status bar). The shelf

extends to hold all placed products.

Note:  You can also still use the classic tool Array copy to fill a shelf.

5. To prepare for the next step, you may want to select the View Angle tool and rotate the view.
 

 

Tip:  While using the Fill Display tool, you can switch to use view tools like view angle, scale
to fit, zoom in, zoom out, and when done, the Fill Display tool will still be active.

6. Select the Fill Display tool again and, in the status bar, click Add shelf. It will be added on top and
have the same dimensions as the one(s) that were there earlier.
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The height between shelves adapts automatically to the height of the (tallest) products placed
underneath plus the default clearance value (as shown in the status bar).

7. We now continue filling this second shelf using the same steps as for the first one. This time we
choose to place the six-pack:
 

 

When placing a second row of four items, again a blue dimension line appears, indicating that we
lack a bit of space:
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We again choose to solve this by clicking Fit Shelves. Because all shelves have to be the same size,
the bottom shelf also took on these same new dimensions:
 

 

We continue and place different products on a 3rd shelf:
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Note:  In our example, notice how 2 of the products, the purple bottle and the small
grey box, were not placed. You will see below how those will be ignored in the rest of the
workflow.

At any time during above steps you can change the product placement and type, on any shelf.

You can mix product orientations.

You can not create more than 7 shelves.

Shelf heights will automatically adapt when you replaced its products with products with different
height size(s).

The Fill Display tool comes with shelf precision, i.e. it honors gutters and shelf snap locations. This
is not the case when you use other 3D tools to edit or rearrange products (Move, Copy array).

Step 2 - Run a Standard

Overview
When the placement on shelves is complete, a standard canvas can be run around the resulting
shelves.

ArtiosCAD then also

• sends the shelf surface area data (L,W) and the shelves' heights to the correlated canvas file.
• positions the shelves properly within the display body, by number, area and height.

Important:  The standard that you use in this workflow must to be a fillable display, a type that
is part of the resizeable design templates. Learn more in How to create a standard to use with
Display Filler on page 1965.
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Steps
1. With the 3D shelves file open, activate the Fill Display tool. In the status bar, click Run standard.
2. In the Standards Catalog dialog, select one of your Fillable Displays (category Resizable Design

Templates).

Note:  Learn how to create your own custom standards for this workflow in How to create a
standard to use with Display Filler on page 1965.

 

 

Note:  A warning will be shown when you select a display that does not have the required
variables or when the number of shelves in the display exceeds the number possible in the
standard.

3. Click OK and as usual, select the Board in the Canvas Settings dialog. Click OK.
4. In the next dialog with the acd preview, the important values in this workflow are automatically filled

in already: the  Length (LSH), Width (WSH) and Number of Shelves (NSH).

Notice in our below example that the preview of the standard shows its default 4 shelves, but that
the proposed NSH value is already the one from our 3D shelves setup: 3.
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5. Click OK. The dialog Add Unfolded Design(s) appears.
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When the canvas part count (the number of shelves you used in the 3D display setup) does not
match the count in the 3D information (the default number of shelves set in the selected fillable
display standard), the dialog will ask you to select which one you want. In this workflow, always
select Use canvas part count.

Note:  The products in the 3D file that you did not place on any shelves will be ignored in the
canvas.

6. Click Next to check or set other parameters or click OK to confirm the creation of the canvas.
 

 

In this workflow, the canvas is updated with automatically created parts of all involved products
and also adds several views: From the display an asymmetric view, a front view, side views and
planograms. And also a view of every single product.

Also notice that, in above image, the top bar of the part 'Shelves_Part 1' mentions a 'x3', so indicating
that this part is used 3 times.

Note:  In the status bar, once you have used Run standard, this button disappears and a new
button Rebuild display appears. Learn more below.

Changing the 3D and Rebuilding the canvas.
Also after creating the canvas file, you can still change the 3D file and finish with a simple click on
Rebuild display.

A useful tool at this moment is  Toggle Display and Shelves mode.
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Step 3 - Output to BOM
In this workflow, creating output to a spec sheet or BOM also lets you include all the extra parts
included in the canvas.

• Go to Parts >  Parts Outputs >  Canvas >  Canvas Job Bill Of Materials PDF.

• The Select Parts dialog also offers to include the Products and Views.
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How to create a standard to use with Display Filler

A standard to be used in the display filler workflow ...

• must be a canvas standard
• must use specific variables
• must have horizontal, rectangular shelves
• must have a variable number of shelves.

Learn more below.

Must be a Canvas Standard
The standard must be a canvas. The parts that build the display are all in the canvas.

Must use Specific Variables
The Fill Display tool sets the following variables which should be used by the standard:

LSH Internal length of a shelfd

WSH Internal width of a shelf

NSH Number of shelves

H1 Height of the top of the second shelf above the first (bottom) shelf

H2… Height of the top of the 3rd shelf above the top of the 2nd shelf, and so on ...

The first part of the StyleMaker dialog will normally be the main one where you specify the length,
width and number of shelves:
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And the next step has the shelf heights:
 

 

Esko shelf display standards use FSH for the height of the first shelf, but this is not set in the Fill
Display tool, and is not a requirement. The remaining steps in the dialog are up to you.
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The variables LSH, WSH, NSH, H1 … should default to something sensible and the unused height
variables should be 0. This means that the default formula for a height such as H3 should be set to
something like this:
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Must have Horizontal, Rectangular and Same Size Shelves
The shelves must be horizontal, rectangular and have the same size.

The shelves must be copies of the same design except the bottom shelf which may be part of a
different design.

The interior dimensions of each shelf are length LSH and width WSH.

Must have a Variable Number of Shelves
The standard must support a variable NSH (number of shelves) up to a maximum, which cannot be
more than 7.

The shelves are numbered starting with the bottom shelf. The distance between the shelves can be
different, specified by variables H1, H2 …

The number of copies of the shelf part must be NSH (the number of shelves), except if the bottom shelf
is a different design, in which case the number of copies must be NSH-1.
 

 

The standard also follow these rules:

• must have been folded in 3D
• must have mates to hold it together in 3D when values of variables are changed
• the number of copies of the mates should correspond to the number of shelves. Learn more in

Using the Copy Times tool with Mates on page 1728.
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Restrictions
Using variables LSH, WSH, NSH, H1 … is the main requirement to run a standard from the Fill Display
tool, but the 3D geometry of the standard needs to be recognized, so that the Fill Display tool can edit
length, width and heights.

There are various restrictions for the geometry to be recognized. It’s possible that later versions of
ArtiosCAD may relax some of these restrictions once we add more types of Display Filler standards.

• The shelves need to be rectangular, the same size, and the main shelf area needs to be a single
panel.

• The shelves should be vertically aligned ; the higher shelves can be set back a little from the lower
shelves, with a slope, like this example:
 

 

• There should be more space at the front of the display where the user can access the products, and
less space or a wall at the back, so the Fill Display tool can orient the front of the display.

• The Fill Display tool currently has no option to set or recognize shelf partitions.
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15.  Outputs

Introduction to Outputs

Outputs are processes that transform your electronic drawing data into something tangible that
you can share with the rest of the world. You can make an output using a report, a simple printout,
a sample, or an electronic file. Outputs are configured in the Defaults section of ArtiosCAD. You can
customize your own output methods in addition to using those on the server.

Shown below are the default outputs in the default configuration.
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There are many options in Outputs that are configurable only in Defaults. For more information on
configuring outputs, see the Defaults chapter.
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Concepts and Ideas in Outputs

There are two conceptual types of outputs – those that are printed on a printer or plotter, and those
created on a machine that is not a printer or plotter. Windows printer drivers are used for most printer
outputs. ArtiosCAD CAM (Computer Aided Manufacturing) drivers are used for most plotter and
machine output.

You can also create Grouped outputs, which as the name implies is a group of outputs. This way you
can (for example) output to a printer, send a design via e-mail, and cut the sample all with a few clicks
of the mouse. For more information on configuring Grouped outputs, see the Defaults chapter.

Multiple workspace outputs support outputting more than one workspace at a time through the same
report or to the same device. See the section at the end of the chapter for more information.

Sending data to output devices

ArtiosCAD communicates with each output device using special software called a driver. ArtiosCAD
can use its own drivers, as in the case of sending output to a sample maker, or it can use the drivers
that came with the operating system, as in the case of a desktop printer.

For more information on configuring devices, refer to the Peripherals and Defaults chapters.

Notes and warnings when printing bitmaps

Below are answers to frequently asked questions regarding printing bitmaps from ArtiosCAD.

How do I make a JPEG/PNG/TIFF/Bitmap Output?

Create an Output in Defaults with Output type Plot on the Output Type tab, Driver type Bitmap on the
Device tab, and choose the appropriate format in the Bitmap Format: group. Set the output size in
pixels in the Device Size: fields on the Position tab.

On the Directories tab of the Output, set the extension, such as .JPG for JPEG, .PNG for PNG, .TIF for
TIFF, etc.

My bitmap output is very small.

The default bitmap size is 100 by 100 pixels. Increase this to the required size in pixels.

My bitmap output is fuzzy. Why?

JPEG is a lossy compression format (as opposed to lossless) where there is a trade-off between image
quality and file size, which blurs the image a little. If your output has dimensions and lines but no
graphics, PNG format will work better. PNG compression produces crisp lines and dimensions, but will
blend the colors in the graphics.

Poor quality print output. Why?

Make the bitmap size larger, for example 3000 pixels, to have sucient resolution for printing. Set the
width on the Position tab of the Output to match the size of the page in current units.
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There is a loss of resolution when I zoom in on the JPEG/PNG. Why?

JPEG and PNG are each bitmap formats. A bitmap is a particular size in pixels and does not scale well.
If you want an image that can be scaled, try using EPS format instead if you have a program which
supports it (such as Adobe Illustrator). A large bitmap with thick lines scales down better than a small
bitmap scales up, but bitmaps in general do not scale well.

Why can’t I make a GIF file?

There are licensing limitations on software that makes GIF files. ArtiosCAD uses the PNG (Portable
Network Graphics) format instead.

Printing

To print the active workspace, click File and then click Print.

To print the entire workspace on the default printer, click OK.

The To File checkbox sends the printer data to a file instead of to a printer. Enter the number of copies
to print in the Copies: field. If you are currently zoomed in on a portion of the workspace, the options
in the View Window group determine what will print – either the Entire Workspace or the Zoomed-in
View you currently have on the screen.

The Scale options control the physical size of the printout on the output media.

If the scale of the design (set in the Scale field) results in a print larger than the printer can handle,
All tiles and Range of Tiles control what is printed.Tiled outputs have alignment marks on them for
easy assembly of the full-size plot. As with other Output options, tiles are configurable in Defaults. The
extent to which the alignment marks are printed depends on the margins of your output device.

Portrait and Landscape in the Orientation group determine how the long axis of the workspace relates
to the long axis of the paper.
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The Printer button lets you choose the driver to use with the printer. Choose between printers or
plotters defined in the operating system (Windows printer) and printers or plotters driven using native
ArtiosCAD drivers (CAM driver).

Clicking Setup leads to the Print Setup dialog box where you can adjust settings such as the stretch
factor and position of the output on the page.

Preview shows you the data you are sending to the printer or plotter as it will look once printed or
plotted. You can set the preview to show automatically in the Preview Control group in the Output’s
properties in Defaults. Step through the individual line order output by using the Slow Plot slider at the
bottom of the preview window. An arrow shows the current line. If you zoom in, only the current lines
shown are stepped through. Command lets you view and modify the actual ArtiosCAD command used
to make the output. Do not modify the command unless you are sure of what you are doing, or are told
to modify it by Esko Support personnel.

Shown below is the Output Preview dialog box for a Report. Click OK to make the output, or Cancel to
return to the Output dialog box.
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Creating a PDF file

The ability to create PDF files using the native ArtiosCAD driver is an option which much be purchased
and may or may not be loaded on your system. Use of third-party software or drivers may lead to
unpredictable results.

To create a PDF file, do the following:

1. Create the workspace as usual and turn on the layers to be included in the Output.
2. Click File > Outputs > Printer output > Plot to PDF. If you have added any Outputs to the root level,

there will be an Artios folder to select after you click Outputs. The Plot to PDF dialog box appears
similar to the one shown below.
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3. Click Preview... to see an output preview.

Tip: You can extend the Preview... dialog by click and dragging its bottom right corner. Its new size
and position will be remembered.

4. Click Properties to change the size, position, security, and other aspects of the Output.
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Click OK once you have set the options as desired to return to the Plot to PDF dialog box.
5. Click OK in the Plot to PDF dialog box.
6. In the Save As dialog box, navigate to the directory in which to save the Output and enter a filename

for the Output in the File name: field.
7. Click Save to make the Output.

Depending on the state of the Automatically Open checkbox on the Directories tab of the Output
definition, if you have a PDF-viewing utility installed, the PDF file may automatically open once it is
created.

Setting PDF security options

The PDF security options available in an ArtiosCAD Output correspond to those used in Adobe Acrobat.
They may be set in Defaults just like any other properties.
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Checking Require a password to open the document requires the recipient of the file to enter a
password when opening the PDF file using Adobe Acrobat Viewer. Enter this password in the Open
password and Repeat password fields; they must match exactly. There is no way to recover this
password if it is lost or forgotten.

Checking Use a password to restrict permissions requires the recipient of the file to enter a password
to change how the file is protected. Enter this password in the Open password and Repeat password
fields; they must match exactly. There is no way to recover this password if it is lost or forgotten.

If both password options are used, the two sets of passwords must be different.

In the Printing allowed drop-down list box, there are three settings: None, Low Resolution, and High
Resolution. None means the recipient may not print the document. Low Resolution allows printing as
a bitmap up to 150 dpi. High Resolution allows printing the document at any resolution, and to use high-
quality vector output and other advanced printing features if the printer supports them.

In the Changes allowed drop-down list box, there are three choices: None, Page content changes
only, and All changes allowed. None allows no changes in Adobe Acrobat. Page content changes only
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restricts changes to what is shown on the page, but prevents other changes such as page rotation. All
changes allowed allows any change.

The recipient of a PDF file created by ArtiosCAD with security options set must use Adobe Acrobat 5.0
or later to open the file.

Note:  ArtiosCAD cannot open PDF files with an Open password, nor can it open PDF files that
have restricted permissions and that do not have content copying enabled.

The Plot to PDF/U3D Output is meant to be used only in the optional 3D module, as it requires 3D data.

Samplemaking

To print or cut a sample, click File, then Outputs, and then navigate through the menu items until you
find your samplemaker. To make navigation easier, you should move your machinery outputs higher up
in the hierarchy in Defaults.

Clicking Artios CM1930 – Cor. sample cutting and graphics leads to the dialog box shown below.
 

 

Preview lets you see what will be output before it is actually output.
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Tip:  You can extend the preview dialog by click and dragging the bottom right corner. Its new
size and position will be remembered.

Properties leads to the Properties dialog box where all samplemaking and sampleprinting options can
be set.

You can customize the behavior of your samplemaker by changing its information in Defaults. All the
same options in the Properties dialog box are configurable in Defaults.

Print Sample (back in the samplemaking dialog box) sends the graphic portions of the workspace to
the print head on the samplemaker. Note: Text which is in a graphics layer will be printed in black if not
given a color. Also, sample printing of Inside layers is not supported.

Make Counter sends the counter information in the Counter layer to a file which can then be
interpreted by a samplecutter. The line types in the Counter layer must be set to countercutter line
types. Note that this is not used to make a phenolic resin counter - it is used to make a pseudo-counter
out of carton stock on a samplecutter. A counter made out of carton stock is also called a matrix.

Make Sample cuts the sample.
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Make All makes everything that is supported by the selected output device.

Note that some output drivers straighten nearly-straight arcs. Use the GNC driver to preserve nearly-
straight arcs. The GNC driver can also facet small arcs to raise and lower the knife for smoother cuts.
Contact Support for more information about the GNC driver.

Note for DieSaw users

When outputting to a DieSaw, the DieSaw layer is the only layer which is output. Make sure you are not
trying to output a different layer when performing a DieSaw output.

Making an Output to i-cut Production Console

To send a single design or manufacturing file to the i-cut Production Console for cutting on a
Kongsberg samplemaker, do the following:

Note:  If you run this Output while in a canvas, ArtiosCAD outputs the current part, not the
entire canvas.

1. Open the workspace in ArtiosCAD.
2. Click File > Outputs > <name of your iPC Output> > <name of your iPC - Submit Job Output>.
3. In the Specify Material and Cutting Profile dialog box, choose the material and cutting profile for

the job. In the Materials list, ArtiosCAD displays the current workspace's board code as well as the
materials contained in the iPC Resource Database. Choose the desired material, change the Cutting
Profile if necessary, and set the number of Ordered Copies. The Tooling Preset, Optimization
Preset, and Production Preset are shown for information only.
a) If you choose the board code, the other fields except for Ordered Copies are unavailable.
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b) If you choose something from the iPC Resource Database, you can then change the Cutting
Profile.
 

 
Click OK when you have chosen a material, set the number of ordered copies, and optionally a
cutting profile.

4. After a few moments, the job appears in the i-cut Production Console ready for the Kongsberg table
operator to process.
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Reports

What is a report?

A report is a way to print pictures of workspaces along with information about those workspaces. For
example, you could have the name of the design, its dimensions, the customer name, and the job order
number on the same printout as a flat view of the design, the design folded in 3D, and the design laid
out on the die board.

You must have the ReportMaker feature to modify design windows or work with variables. However, you
can change fixed text on pre-made forms if you do not have ReportMaker.
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Making a custom report

Although ArtiosCAD comes with several pre-made reports, you will probably want to make some that
serve your unique needs. For example, you may want to put your company’s logo on one, along with
certain items of text that aren’t on the pre-made forms.

Making a report usually involves doing the following steps:

• Deciding what types of designs and information you want on your report;

• Defining the size of the report;

• Drawing lines to separate areas from each other;

• Adding text and graphics to the report;

• Designating the part of the report that the design images will go into;

• Adding the report to a Report Catalog;

• Defining an Output that uses the report.

Tools specific to the creation of reports are on the ReportMaker toolbar. The first button on the toolbar
is in the Toolbar Master Control and toggles the display of the toolbar.
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Deciding the contents of the report
Different circumstances call for different information on reports. For example, information going
to your sales force probably requires different information than that going to the printing plate
machine operators. Customers would probably like to see a folded version of their design along with
its pertinent details. Know your audience  too much information can be just as bad as too little
information. You probably already have some sort of shop ticket, job information sheet, or order
tracker that can be turned into a report.

You should also decide which file views you want to be on the report. Would a 3D representation help? A
manufacturing file view would be for a diemaker. A view of both sides of the workspace could be useful
as well. The possibilities are infinite.

Defining the size of the report
Once you have decided what will be on the report, start ArtiosCAD and make a blank design. Turn on the
ReportMaker toolbar if it is not on already. The size of a report is usually based on the printer used to
print it.
 

 

 Click the Report Size button on the ReportMaker toolbar.

Choose the printer from the Device list box. The size of the report will automatically be displayed in the
Report width: and Report height: fields. If you want to rotate the rectangle used to form the edge of
the report, check the Rotate report checkbox. Click OK to accept the settings. A rectangle will appear
in the design that is the edge of the report.

Drawing lines to separate areas
If you want to have lines defining the different areas on your form (for example, you may wish to
separate text from graphics), use the Line tool to draw them. Lines are optional, as the only thing
required on a report is a File Window.
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Creating a File Window
File Windows contain symbols, pictures of flat designs, manufacturing files, print items, 3D files, Bill of
Materials table rows, or Cape palletization solution views. You can have many File Windows on the same
report, each having different contents.

 To create a File Window, click the File Window tool on the ReportMaker toolbar. Choose the
intended contents of the File Window from the drop-down list box. Use the drag to set the diagonal
starting and ending points of the rectangle. Alternately, enter values in the X and Y offset fields on the
Status bar to set the corners of the rectangle. After creating a rectangle, the tool is still active in order
to facilitate making another. Shown below is a report with three File Windows.

Double-click a File Window with the Select tool to change its properties.
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Choose the option button in the File Type group to change the type of File Window from what you
chose when creating it.

The option buttons in the Scale group determine the size of the file view within the File Window. Scale
to fit makes the contents of the window as large as possible while still fitting within the File Window.

Use output scale table instructs ArtiosCAD to set the scale of a File Window according to a predefined
table in Defaults. ArtiosCAD will set the scale in that File Window to the closest scale that is less than
or equal to the scale derived from the Scale to Fit command. For example, if Scale to Fit would use a
scale of 0.8753, but Use output scale table is selected, ArtiosCAD will use the scale in the table that is
closest to that value without exceeding it, for example 3/4.

Scale report around file expands the report to fit around the file window if the file window contents
are initially larger than the report, but does not shrink the report if the file window contents are initially
smaller than the report. This option is valid only for Design and Manufacturing type File Windows. If
more than one File Window in a report uses this method, the report scale is calculated to the size
needed to encompass all the occupied windows. It is meant for use with an Output set to scale 1. If
you use a report with a File Window set to this scale option in an earlier version of ArtiosCAD, the
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File Window will behave as if it were set to Scale to Fit. If you open the report workspace in an earlier
version of ArtiosCAD, the Scale group option is set to Specify Scale of -2.

Scale report around canvas part places the report around the active canvas layout part.

The option buttons in the Scale group are not available when the File Window type is 3D, Symbol, Bill of
Materials Table, or Cape Palletization.

The buttons in the Position group control how the file view is positioned within the File Window.
The buttons around the edge of the square align the design with the corresponding point of the File
Window. The center button (+) aligns the center of the design with the center of the File Window.

The File number indicates which file will be displayed in the File Window. The File Number prompt
changes to Print Item Number prompt if Print Item is selected in the File Type group. When you create
a report containing more than one File Window, increment the File number by 1 for each File Window.
When outputting the Report, the current design is file number 1; any other open designs are assigned
numbers 2 onward. When using a Manufacturing report, make sure the manufacturing file is the active
workspace - so that it is in File Window 1.

Note:  Make sure each File Window has a unique number, except if you have multiple Design
File Windows of the same number that are meant to show different layers of the same design,
as long as those layers are not Manufacturing or Windows and Cutouts, as those might cause
problems with calculated expressions. For example, multiple Design File Windows with the
same number would be permissible when one is showing the Outside Graphics layer, another is
showing the Dimensions layer and the flat view, and yet another is showing the Inside Graphics
layer. Do not assign File Windows of differing types the same number - for example, do not
have Design 1, 3D 1, and Manufacturing 1. The report may not work correctly if you have same-
numbered File Windows for different types of workspaces. If you are planning a report with a
manufacturing file and single designs, make the manufacturing file as File Window 1 and make
the other File Window types 2, 3, 4, and so forth.

The option buttons in the Orientation group determine the rotation of the design in the File Window.
0, 90, 180, and -90 all rotate the contents by a fixed amount. Optimum sets the orientation so that the
largest scale is obtained. Horizontal grain and vertical grain set the design so that the grain direction
chosen is drawn along the longer axis of the File Window.

The Margin specified indicates the distance from the edge of the File Window to the outermost edge of
design.

Options buttons in the Side Up group control which side of the design is shown.

The option buttons in the Layer Selection group control which layers are shown. Same as current
view shows the design on the report the same way it is being viewed in ArtiosCAD. Specify layers
lets you choose which layers to show on the report regardless of the view at the time of output. If the
File Type is set to Manufacturing, another option button appears which allows you to specify those
Manufacturing or Design layers to output.
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The layers selected when Specify design layers and Specify manufacturing layers are active are
remembered when the other option button is selected. For example, if you select Inside Bleed and
Graphics when Specify design layers is active, they will be remembered when Specify manufacturing
layers is active. If you do not select any design layers for a Manufacturing file window, only the Main
Design layer is shown when Designs is selected in the Manufacturing layers.

Using a Symbol file window

The Symbol type of file window is used to hold a symbol, which is a graphic. This graphic can be lines
and arcs drawn and filled in ArtiosCAD, or it can be a graphic file of the following format and extension:
BMP, DIB, JPG, PNG, TIFF, and PDF (only if you have purchased the PDF option).

You can:

• specify the exact symbol to use;

• specify a library function which will determine the name of the symbol;

• build a conditional statement that instructs ArtiosCAD to use a different symbol when the specified
conditions are met.

When the File Window is set to type Symbol, the Scale is automatically set to Scale to fit and the
Position is automatically set to centered horizontally and vertically. As with other types of File
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Windows, the value in the File Number field controls which element of the current workspace
corresponds to the symbol window.

To use the same symbol file each time the report is accessed, click the Symbol File option button and
enter the filename of the ArtiosCAD workspace containing the symbol.

The From library function option button lets you use a library function to return the symbol filename to
ArtiosCAD.

Perhaps you have corresponding JPG files for each design you make that have the same name as the
design file. Including them automatically on a report can be done using a library function as described
below.

A library function such as ADDEXTJPG.TXT is a short program allowing the filename for the contents
of a Symbol-type file window to be defined automatically as the Report is run.

Note:  This library function is not part of the ArtiosCAD installation; to use it, you must create it
in a text editor such as Notepad and save it in ServerLib.

The library function will typically use the function #PATHNOEXT$ to get the pathname of the current
design without the .ARD extension. The last line of the command file returns the pathname to be used.
The following example would return pathname.JPG for a design pathname.ARD.

DEFINE &FNAME$

SET &FNAME$ #PATHNOEXT$,”.JPG”

When the Report runs in an Output, the library function for the pathname is evaluated for each file
window, and the image from that pathname is scaled to fit in the rectangle defined by the file window
item. The pathname may refer to an ArtiosCAD design, such as GRAIN.ARD, or an external image such
as 1234.JPG.
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The report may contain several file windows, each referring to a different image, such as a picture of
the product, and a palette diagram. For each image file that does not exist, a text message is centered
in the file window with the pathname of the missing file. This diagnostic is useful for instances such as
a missing grain symbol. To avoid this message for designs that do not have a corresponding image file,
the library function that sets the filename can be set to ignore any missing files as shown below:

DEFINE &FNAME$ 
SET &FNAME$ #PATHNOEXT$,".JPG" 
IF FILEEXISTS(&FNAME$) 
SET &FNAME$ &FNAME$ 
ELSE 
SET &FNAME$ "" 
ENDIF

Again, to use the library function, you have to enter it in a text editor and save it in ServerLib before
you specify it in the Properties dialog box for a symbol-type file window on a Report.

To configure the report to use a different symbol depending on the result of an evaluated expression,
select the Symbol file depends on case option button. When you select this option button, the Case
group becomes available.

To add a case, do the following:

1. Select the Symbol file depends on case option button.
2. Click Add Case.
3. Enter the expression to be evaluated in the Case expression field. Use the same syntax here as that

used in any Edit Expression dialog box.
4. Enter the full name and path of the desired symbol file in the Symbol file field. Click the button at

the end of the field to browse for the file.
5. Add more case expressions by clicking Add Case. Delete a case expression by selecting the one to

delete and then clicking Delete Case.

There will always be an OTHERWISE case listed when Symbol file depends on case is selected. The
expression entered in this field is the one ArtiosCAD will use when none of the other case expressions
are valid. This field can be left blank if you know that the condition will always be met.
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Using a Cape Palletization file window
When you choose Cape Palletization as the file window type, the Properties dialog box changes to let
you choose what ArtiosCAD extracts from the 3D workspace that you have already palletized.
 

 

Choose an option in the Image Type group as desired. As you choose different image types to show in
the file window, ArtiosCAD updates the preview with an example of a generic solution.

The options in the Orthogonal View group apply to the full pallet view.

Adding text to the report
Three types of text are used on reports:

• Fixed text, which never changes;

• Prompted text, which you can change each time you use the report;
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• Calculated expressions, which is text generated automatically each time you use the report.

The maximum amount of text allowed in an item of text is 4000 characters.

 Adding fixed text

 Adding fixed text is accomplished by using the normal Paragraph Text tool on the Annotation
toolbar. See Paragraph Text tool in the Builder chapter for more information.

Adding prompted text

 Add prompted text by using the Prompted Text from Table tool on the ReportMaker toolbar. Click
the tool and place the text in the desired location. The Prompted Text Catalog will appear as shown
below; yours may be different if you have different defaults defined. Click the plus sign to the left of a
category to expand it. Then select an entry and click OK.

The cursor will still be the one for prompted text, so if you click in another location, the Prompted Text
Catalog will reappear so that you may add another entry. When you have finished adding prompted text,
click Cancel in the Prompted Text Catalog.

If you place a prompted text variable within a rectangle of design lines, the text entered for that
prompted variable will wrap to the confines of the rectangle. If there is more text than will fit,
ArtiosCAD will print as much as possible and end with an asterisk.

The Database Information, Design User Fields, and Manufacturing User Fields Catalogs link to the
database, so that when you output the Report, you are prompted to set those fields. The values you set
are saved in the database. Reports with database prompted text items may not be used in versions of
ArtiosCAD lower than ArtiosCAD 6.0.

To copy database variables into another design or standard style for use when rebuilding a design,
use the Copy button in Advanced StyleMaker as described in the Designer chapter, Adding the Inside
Dimensions menu, except use the name of the report workspace containing the variables instead of
VARMASTER.
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Adding calculated text

 Add calculated text by using the Calculated Text tool on the ReportMaker toolbar. Place the
indicator box in the desired spot and click the mouse button. The Calculated Expressions Catalog will
appear.
 

 

Choose the calculated expression to add and click OK.

The tool will remain active; clicking again will place another item of calculated text and will cause the
Calculated Expressions Catalog to reappear. When you are done adding calculated expressions to your
report, click Cancel in the Calculated Expressions Catalog.

If you place a calculated text expression within a rectangle of design lines, the text generated for
that calculated expression will wrap to the confines of the rectangle. If there is more text than will fit,
ArtiosCAD will print as much as possible and end with an asterisk.

A special calculated text entry for the length, width, and depth of the design where not all three
variables are required to be set is the [L][ xW][ xD] entry in the Design information > LxWxD sizes
folder. Use this entry to print those values if you are not sure if they will be set when the Report is run.
Values which are not set will be blank.
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Note:  If you are using Cape Palletization data on this Report, for there to be regular ArtiosCAD-
type calculated text, you must have a file window of type Design on the Report and the
calculated text's properties must be set to reference that file or print item number in the
Expression relates to group.

Adding graphics to the report

 Adding graphics to a report is as simple as using the Add Graphics tool on the Graphics toolbar.
Navigate to the directory the graphic file is in and double-click its name. The graphic will appear in the
report and its handles will be on. Click a handle to use to move the graphic to the desired location, and
then drag the graphic to its new position.

Modifying items on the report

 To delete an item from a report, select it and click the Delete tool on the Edit toolbar.

Move text by selecting it with the Select tool and dragging it to its new position. The Align Text tools are
handy for aligning fixed text and prompted text items into columns. Move graphics with the Move tool.

To change the attributes of any text, double-click it with the Select tool. The Properties dialog box will
appear. Do not change the Text field of Prompted Text items or Calculated Expressions.

Use the tools on the Edit toolbar to modify a graphic if desired. The tools on the Graphics toolbar also
modify any graphic item on a report.

Changing the size of a File Window

 Use the Adjust File Window tool to change the size of a File Window by doing the following:

1. Click the Select tool and then select the File Window to modify.
2. Click the Adjust File Window tool.
3. Click the handle point to use. This is the point you will be moving to change the size of the file

window.
4. Move the handle point using drag or by entering new values in the Status bar fields.

Modifying fixed or prompted text

To change an item of fixed or prompted text, double-click it with the Select tool to invoke the
Properties dialog box.
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Modify the text appearance and justification by using the controls along the top of the dialog box.
Kerning controls the amount of space ArtiosCAD inserts between letters. Horizontal scaling increases
the horizontal size of the characters without changing the vertical size. Rotate changes the angle
of the text. Note that changing the text justification may be required to position the text exactly as
desired.

To change the text itself, change the text in the Text field.

Modifying calculated text

To modify calculated text, double-click it with the Select tool to invoke its Properties dialog box.
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Modify the text attributes in the usual ways. Kerning controls the amount of space ArtiosCAD inserts
between letters. Horizontal scaling increases the horizontal size of the characters without changing
the vertical size. Rotation sets the angle of the text from horizontal.

In the Expression relates to group, make sure you have the correct file or print item selected,
otherwise incorrect information will print on the report.

Note:  If you are using Cape Palletization data on this Report, for there to be regular ArtiosCAD-
type calculated text, you must have a file window of type Design on the Report and the
calculated text's properties must be set to reference that file or print item number in the
Expression relates to group.

The Calculated Text group contains the options which affect the actual information displayed when
the report is run, not just the font options of the information. Description is what shows in the menu
when you select the item of calculated text. Sample text is what appears as a placeholder in the design
window while you are building the form. Expression is the ArtiosCAD expression which calculates
the value. The f(x) button lets you change the way the expression is calculated by invoking the Edit
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Expression dialog box. Do not use invisible variables in calculated expressions. Select from catalog
lets you replace the current item of calculated text with a new one you choose from the Calculated Text
Catalog.

The choice in the Type drop-down list box determines the availability of the Units and Format groups
as well as the options within them. For instance, if the Type is Distance, the Units are plain linear
measurements, but if the Type is Area, the Units are squared. If the Type is Angle or Number the
Units option buttons are unavailable, and if the Type is Text both the Units and Format groups are
unavailable. Use Distance for expressions which are units of length. Use Area for units which are
squared. Angle or Number should be used for numbers with no units such as number up (on a die). Text
should be used for text or for expressions which contain more than a single number, such as Length,
Width, Depth.

Decimal Places controls how many decimal places are used and is only effective when anything but
Default is chosen in the Format group.

Rubber on Reports
You can create a custom Rubber Types legend on a Report using the calculated text items below. An
example Rubber Types legend is included in the Artios example outputs.

Table: Calculated expressions for a Rubber Types legend

Description Calculated text expression Example

Rubber type
name in the list
of rubber types

RTNAME( rtype ), rtype =1,2,3,4,... RTNAME(1)

Rubber color
block in the list
of rubber types

RTLINE( rtype ) RTLINE(1)

Rubber type
name in the list
of rubber sheets

RUBT.R[RUBS.S rtype .RT].NAME$ RUBT.R[RUBS.S1.RT].NAME$

Rubber sheet
width

RUBS.S rtype .DX*#M RUBS.S1.DX*#M

Rubber sheet
height

RUBS.S rtype .DY*#M RUBS.S1.DY*#M

Waste % RUBS.S rtype .WASTE RUBS.S1.WASTE

Shown below is an example layout with rubber sheets on a Report with a Rubber Types legend.
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To have each rubber sheet on a separate page, use the reports in File > Outputs > Artios > Rubber
> Rubber Separate Sheets. A separate Report is provided for rubber sheets 1 through 5. The rubber
sheet number for the file window is derived from the text item called rubbertypename5 with calculated
text RUBT.R[RUBS.S5.RT].NAME$.

Saving the report
When you are done constructing the report, save it to either the ServerLib or ClientLib directory
of the ArtiosCAD release you are using in order to be able to easily add it to the Reports catalog. Also,
saving it in one of those directories preserves it through software upgrades.

Making a title block report

Most reports scale the design to fit inside a rectangle in the report. A title block report has the design
at a specified scale, usually scale 1, with the report text positioned relative to the edge of the design.

Create a title block report by designing the title block, and adding the file window for the design with
a fixed scale. Set the justification of the file window to position the title block at the required position
relative to the design. For example, to position the title block at the bottom center of the design, use
bottom center justification for the file window. Shown below is an example.
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When a title block Report is used in an Output, the design is positioned in the file window according to
the justification of the file window. Set the scale of the output to fit one page. The actual size of the
file window is not used; it does not make any difference if the design is bigger or smaller than the file
window. Shown below is an example of a completed Output.

Notes and warnings about Reports

When you want to output a report which will show a manufacturing file and its embedded single
designs, do the following:

1. Assign File Window 1 the Manufacturing file type in its Properties dialog box.
2. Assign File Windows 2..x the Design file type in the Properties dialog box.
3. When you Output the report, make sure the manufacturing file is the active document. File

Windows 2..onward are filled in the order in which they are displayed in the Oneups Dialog in
Manufacturing. Thus, the first embedded file would appear in File Window 2, the second embedded
file would appear in File Window 3, and so forth.
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4. If you have more file windows on the report than you have embedded designs in the manufacturing
file, the remaining file windows will be empty. You can assign other open files to them if you wish.

When putting text on a Report, you should always put it inside a closed shape made out of cut lines.
The text is truncated against the perimeter of the report if the scale gets too large on Output. This
prevents text from running off the page if the scale is too big.

Using the ITEMORD function on Reports
The ITEMORD() function returns the ordered quantity of a print item. The function argument refers
to the quantity number. If you have a multiple quantity report for use with manufacturing files, the
ordered quantities should have calculated text:

ITEMORD(1) print item 1, ITEMORD(2) print item 1, ITEMORD(3) print item 1, and so on.

If you have a report for a mixed layout, the ordered quantities on the report should have calculated text:

ITEMORD(1) print item 1, ITEMORD(1) print item 2, ITEMORD(1) print item 3, and so on.

Adding a report to the Reports Catalog

Once the report workspace is saved, click Defaults on the Options menu of  ArtiosCAD.

To add the report to the Shared defaults, which will let everyone using this installation of ArtiosCAD
use it, do the following.

1. Open the Report Catalog in the Shared Defaults window.
2. Right-click Report Catalog, click New, click Data, and enter the name of the re-port as you want it

to appear in the Report Catalog.
3. Then double-click its icon and enter the name of the report work-space. It is a good idea to use

a copy of the report workspace which you have saved in ServerLib as this will be preserved
through future upgrades.

4. Click OK when you have entered the name.
5. Save your changes to Defaults by clicking File > Save.

Once the report has been added to the Reports Catalog, it must be added to Outputs in order for it to
appear in the Outputs menu.

Defining an Output that uses the report

To define an Output using the report, while still in Defaults, right-click Outputs, click  New, then click
Data. Enter the name of the new output, e.g. Meeber Box Company simple report. Double-
click its icon. A dialog box will appear with the name of the report as the title.
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In the Shown in group, select those areas of ArtiosCAD (or, optionally, WebCenter) in which the new
Output will appear. You must select at least one area; if only one checkbox is selected, that checkbox
may not be deselected until another is selected.

If you will print this report on a printer driven by Windows, choose the printer the report will be printed
on in the Windows Driver drop-down list box on the the Device tab, or choose Default Printer to output
to the default printer.
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If you are using an ArtiosCAD internal driver for the printer, choose CAM on the Device tab and choose
the device from the CAM Driver list box. Leave the Output Type as PLOT and set the Scale to To Fit One
Page.

Once the options on the Device tab are set correctly, click the Reports tab. Check the Use Report
checkbox and select your report.
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If the Report has at least one 3D window on it and the Output is a PDF file, the Use U3D in 3D file
windows checkbox becomes available. U3D is an industry-standard 3D output format that can be read
by many applications. For example, if you embed U3D data in a PDF file, Acrobat Reader 7.0 or greater
lets you zoom in and out, rotate, and otherwise change the view of the objects in the 3D file window.
Select this checkbox as desired.

To have individual PDF or U3D images when you use this Report with Cape Pack data, use unique
palletization file numbers in Cape Pack but associate them with the same ArtiosCAD 3D workspace.

To change other settings, click the other tabs and set the options as desired. When done, click OK
to apply the changes you made to Defaults. Then click File, and then click Save to save the shared
defaults. Click Yes in the Warning dialog box about overwriting the shared defaults.

To give only yourself access to the report, follow the procedure listed above for Shared Defaults, except
do it in the User Defaults pane of the Defaults dialog box.

Using a Report

Once you have added your report to the Reports Catalog and have created an Output for it, using it is
quite easy. The procedure for using a Report in Single Design or Manufacturing differs from using one
in 3D; see the next section for the 3D procedure.

Single Design and Manufacturing
To use a Report, open the workspace(s) you want to place on the report. Turn on the layers that you
want to be printed on the report along with the workspace(s). Click File, then Outputs, and then the
name of the Output you created. If you used prompted text on the Report, you will be prompted to set
values for each prompted text item.
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The values you choose for any database-linked prompted text items will be set in the database upon
completion of the output. You may only set user fields for the type of document being Output; those
user fields with the opposite type are listed but unavailable.

Variables used in both the report and the workspace(s) being used on the Report may be listed when
outputting the Report, but may not be changed. To change them, change them in the workspace(s)
before outputting the Report.

Set the values as desired and click OK.

If you have more than one File Window on the report, the Select Report Files dialog box will appear.
In this dialog box you can review which file is associated with which File Window and change it if
necessary. You can only choose from among open files, so make sure you have already opened the
workspaces you want to output before you start the Output. Click OK when the files are assigned to
their proper File Windows.
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Note:  If you have a manufacturing file window on a report, you must make the manufacturing
file the active document in ArtiosCAD (so that its title bar is highlighted) for it to print correctly
on the report.

The output dialog box for the report will appear, and because you defined all the options in Defaults
when configuring this Output, everything should be set correctly.

Preview shows a preview of the form as it will print.

Properties lets you adjust the properties of the Output itself, not of the report. Fill in Report lets you
adjust the answers you gave to prompted items. Select report files invokes the Select report files
dialog box as shown on the previous page.

Click OK to print the report. Click Cancel to dismiss the output dialog box.
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3D
Using a Report from 3D is as easy as using one in Single Design or Manufacturing. The difference is
that in order to get the design information for variables on the Report, ArtiosCAD references the single
design workspaces that are shown folded in the 3D workspace. The Output will not work without the
associated single design workspaces, so to use a Report on a 3D workspace on a different computer or
at a different site, you must also copy or send the associated single design workspaces along with the
3D workspace.

If the 3D workspace contains exactly one structural single design, ArtiosCAD checks to see if the
single design is already open. If it is not already open, ArtiosCAD looks in the location holding the 3D
workspace, and opens it if it is found. If it still cannot be found, ArtiosCAD prompts you to browse for
the file.

If the 3D workspace contains more than one structural single design, ArtiosCAD prompts you for the
workspace(s) to use with the Report.

Select the workspace(s) to use by checking their checkboxes and click OK. If File not found is displayed
in the Location column, highlight that line and click Browse to find the file. The Report will then be
created in the same way as in Single Design or Manufacturing.

Note:  You may not use a Report with a workspace containing only embedded solids or Solids
of Revolution; there must be a structural component to the 3D workspace.

Shown below is an example of a Report with a Single Design window and a 3D window exported to a
PDF file that uses U3D.
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Cape
ArtiosCAD has three example Cape Pack Reports in Outputs > Palletization.

• Cape Pack Arrange/Design Group Report

• Cape Pack Pallet Group Report

• FCA Pallet Group Report

Cape Arrange/Design Group Report workflow
This workflow describes how to use the example Cape Pack Arrange/Design Group Report starting in
Cape Pack. It creates two single designs, one for the primary pack and one for the secondary pack, that
you then convert to 3D.

1. In Cape Pack, create an Arrange/Design Group solution.
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2. Export this solution to ArtiosCAD. It will create two new single designs that you can modify as

desired, such as by adding graphics.
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3. Convert these single designs to separate 3D workspaces and fold them at 90 degrees if needed.

 

2010



15ArtiosCAD

 
4. In 3D, click Outputs > Palletization > Cape Arrange/Design Group Report.
5. Select the 3D workspace for the primary pack to map to file window 1, select the 3D workspace for

the secondary pack to map to file window 2, and click OK.
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6. In the Output dialog box, click OK to output the Report as previewed below. At the top of the report

is some palletization calculated text. Beneath that, starting with the top left image going from left
to right row by row, is a full pallet view of the secondary pack, the oneup layout in the secondary
pack, the pallet first row view, and the primary pack oneup view, followed by more palletization
calculated text.
 

2012



15ArtiosCAD

 

You can also use this workflow in ArtiosCAD with your own single design which you would then convert
to 3D, palletize, and run with this Output. The 3D workspace is the primary package, and Cape Pack
returns the secondary package as a single design. Convert the secondary package to 3D. Map file
window 1 to the primary package's 3D workspace and file window 2 to the secondary package's 3D
workspace.

Cape Pallet Group Report workflow
This workflow describes how to use the example Cape Pack Pallet Group Report starting in Cape Pack.

1. In Cape Pack, create a Pallet Group solution.
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2. Export this solution to ArtiosCAD. It will create a new single design that you can modify as desired,

such as by adding graphics.
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3. Convert this single design to 3D and fold it at 90 degrees.
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4. In 3D, click Outputs > Palletization > Cape Pallet Group Report.
5. Select this 3D workspace to map to file window 1 and click OK.
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6. In the Output dialog box, click OK to output the Report as previewed below. At the top of the report

is some palletization calculated text. Beneath that, starting with the top left image going from left
to right row by row, is a full pallet view, a pallet first row view, a top view, and a view of the single
design, followed by more palletization calculated text.
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You can also use this workflow in ArtiosCAD with your own single design which you would then convert
to 3D, palletize, and run with this Output. Leave the single design workspace open so that you can use
the Outputs menu. Shown below is the report with a design that originated in ArtiosCAD.
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FCA Pallet Group Report workflow
Once you have created a KDF (knock-down flat) and palletized shipping case as described in the
Palletization in 3D section of the 3D chapter, you can Output a Report showing the solution.

1. Have both the KDF and shipping case open in 3D, with the KDF folded in half and the shipping
case with all angles at 90. ArtiosCAD uses the palletization metadata returned from Cape Pack to
generate the Report.
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2. In 3D, click Outputs > Palletization > FCA Pallet Group Report.
3. In the Select report files dialog box, set file window CAPE Palletization 1 to the KDF 3D workspace,

and set file window CAPE Palletization 2 to the shipping case 3D workspace. Click OK.
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4. Set the options in the Output dialog box as desired and click OK to make the Output.

Shown below is the Output preview. On the top left is the full palletized solution. On the bottom left is
one layer of the palletized solution. On the top right are the entire contents of the secondary pack. On
the bottom right is a single KDF carton.
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Example - Using multiple instances of the grain/corrugation direction indicator on a
report
A practical use of the conditional symbol functionality is to put a grain/corrugation direction symbol on
a report for each file window. To start, do the following:

1. Create a new Single Design file and decide how many designs will be on the report.

2.
 Use the Report Size tool to set the size of the report based on the output device.

3.
 Use the File Window tool to make twice the number of File Windows as decided on in step 1,

e.g. if there will be three designs on the report, make six File Windows. Make large windows for the
designs and small windows for the direction indicators.

4. Double-click each small window to invoke its Properties page. Three things need changing in the
Properties page for each small window - the file type, the file number, and the contents of the Case
expression group.

• Change the File Type to Symbol.
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• Change the file number to match its corresponding Design window. This means that the Symbol
window for Design 1 should have a file number of 1, the Symbol window for Design 2 should have a
file number of 2, and the Symbol window for Design 3 should have a file number of 3.

• Select Symbol file depends on case.

• Click Add Case. In the Case expression field, enter GRAIN=1. Click the ... button at the end of
the Symbol file field to browse for the symbol file. Navigate to the InstLib directory of your
ArtiosCAD installation and choose GRAINVER.ARD.

• Select the OTHERWISE case. Click the ... button at the end of the Symbol file field to browse for
the symbol file. Navigate to the InstLib directory of your ArtiosCAD installation and choose
GRAINHOR.ARD.

After repeating this step for each Symbol file window, the Properties dialog box for each Symbol
file window should look similar to the one shown below, except each window will have a different
number in the File number field.

5. Make any other desired changes to the report - adding text, a logo, and so on. Shown below is the
form in the design stage
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6. Save the report, add it to the Report Catalog, and create an Output for it. When you run it with three
designs open, the output will be similar to the picture below.

Bill of Materials Reports for Projects

ArtiosCAD can create Bill of Materials Reports, or BOM Reports. BOM Reports list different designs that
make up a Project. Shown below are the first pages of two example BOM Reports run against the same
Project.
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The basic idea behind using BOM Reports is that you design a Report that repeats information down
the page for each individual document in the Project. You can show as much or as little information as
you like about the designs. To help show you what is possible, a few example BOM Reports are included
in Shared defaults in Options  > Shared defaults > Outputs > Artios > Project Bill of Materials.

Note:

BOM Reports do not need to be added to the Report Catalog in Defaults.

The Project Documents dialog box and the Documents pane of the Project Browser are where you
configure the order and quantity in which the designs will appear on BOM Reports.

To run an existing Output against every document in a Project, simply check Project-Bill of Materials in
the Show in group on its Properties dialog box in Defaults. When it is time to run that Output, select it
from the Projects > Bill of Materials menu instead of the Outputs menu.

Using an example BOM Report

Note:

To use most of the example BOM Reports, you must have the PDF option installed on your
system.

ArtiosCAD ships with several example BOM Reports on the Projects > Bill of Materials menu. Note that
BOM Reports do not appear in File > Outputs.
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• Bill of materials PDF and Bill of materials summary table PDF are the two BOM reports shown in the
previous section.

• Multipage PDF prints each Project document to a separate page of a PDF file.

• Project XLS exports Project data to a Visual Basic script file which is then used to create
an .XLS file. If you have Microsoft Excel on your system, it automatically opens the .XLS file as a
spreadsheet. If you are interested in changing this Report, contact the System Integration team at
your local Esko oce.
 

 

Configuring Project documents before using a BOM Report
Before you Output a BOM Report, use the Project Documents dialog box to set up which documents in
the Project will appear on the BOM Report, the order in which they will appear, and the quantity of each
component required by the Project as a whole.
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To configure the documents before running the BOM Report, do the following:

1. Create a new Project and add documents to it, or open an existing Project.
2. Click Projects > Project Documents.
3. To include a document on the BOM Report, check the checkbox to the left of its name in the Design

column. To omit the document from the BOM Report, clear the checkbox.
4. Change the number in the Count column using the increment buttons to the number of items

represented by the document that are required by the Project as a whole.
5. The documents will appear on the BOM Report in the order they are shown in this dialog box from

the top down. To change the position of a document, select it, and then use the up and down arrows
at the right edge of the list to change its position.

6. Click OK in the Project Documents dialog box to return to ArtiosCAD.

Outputting a BOM Report
To Output a BOM Report, do the following:

1. Create a new Project and add documents to it or open an existing Project.
2. Configure the presence, the order, and the count of the documents on the BOM Report using the

Project Documents dialog box as explained previously.
3. Click Projects > Bill of Materialsand click the BOM Report to Output.
4. If there is a Properties dialog box for this BOM Report, set the options as desired and click OK.
5. ArtiosCAD Outputs the chosen BOM Report.

Creating a BOM Report

Creating a BOM Report is just like creating a regular Report, except you define a special area called the
Bill of Materials table and you do not have to add the Report to the Report Catalog when done. Note
that your system must have the Reportmaker option in order for you to create new Reports.
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Before you create your own BOM Reports, open the example ones (..\InstLib\BOMReport.ARD
and ..\InstLib\BOMTABLEREPORT.ARD) to see how they work. You may modify these as desired,
but save the modified versions to ..\ServerLib.

The steps below describe the general procedure for creating a BOM Report.

1. Start ArtiosCAD and create a new single design.
2. Using the tools on the Reportmaker and Geometry toolbars, define the report size and draw lines to

separate areas on the form as desired.
3. Create a File Window that will be the main repeating area of the BOM Report, and double-click it

after you have created it to open its Properties dialog box.
4. Change the File Type to Bill of Materials Table.
5. If desired, leave space for a header and a footer by checking Header Row and Footer Row,

respectively. Set their sizes as desired as well as the pages on which they will be shown.
 

 
6. Click OK to close the dialog box. Shown below is an example of a possible BOM Report in mid-

construction.
 

2028



15ArtiosCAD

 
7. Next, define the actual repeating File Window that will show the information about each document

in the Project. Create a template small enough to be repeated down the page several times, and fill
it with a File Window and the desired static and calculated text. Prompted text is not available for
BOM Reports. Note that design lines will only be drawn on parts of the Report that are repeated.
Use Form Lines 1 and Form Lines 2 linetypes to draw lines in the BOM Table window in non-repeated
areas (for example, table column separators that go all the way down the page even if there aren’t
repeated rows of the table).
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8. Save the BOM Report workspace to ..\ServerLib.

Adding a BOM Report to the Bill of Materials menu
Once you have created a BOM Report and saved it to ..\ServerLib, do the following to add it to the
Bill of Materials menu:

1. Start ArtiosCAD if it is not already started.
2. Click Options > Defaults, and then expand Shared defaults > Outputs > Artios > Project Bill of

Materials.
3. Right-click Project Bill of Materials, click New > Data, and enter the name of the new BOM Report.
4. Double-click the new entry you just created to open its Properties dialog box.
5. On the Output Type tab, in the Output Type group, select Project-Bill of Materials, and in the Shown

In group, select Project-Bill of Materials.
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6. On the Project-Bill of Materials tab, in the Processing group, choose the destination for the BOM

Report. Windows Driver generally directs the output to printer; set the options in the Windows
Driver group as appropriate. Multipage PDF creates a PDF file of the Report and requires your
system to have the PDF option; select the Use U3D in 3D file windows checkbox as desired. XML is
reserved for use by the Esko Systems Integration group.

7. Still on the Project-Bill of Materials tab, in the Reports group, click Add, navigate to ..
\ServerLib, select the workspace for the BOM Report, and click Open. If there is another Report
you want to run when this BOM Report is run, add it here. If you want the Report to run against every
document in the Project, leave its checkbox selected. If you clear its checkbox, it will run only once
when this Bill of Materials is run.
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8. Individual prompted expressions do not work in BOM Reports, but you can specify a special

prompting Report to be run against every document in the Project by checking Use prompting
report file against each document and specifying the workspace in the associated field. In this
Report, use calculated expressions that ArtiosCAD will prompt for when running the Report. If the
Project documents are open, the expressions will be stored in the open designs, but the documents
will need to be saved manually for the values to be preserved.

9. Click the other tabs and review the settings on each, changing them as desired.
10. Click OK to close the Properties dialog box of the new BOM Report.
11. Save and exit Defaults as usual. The new BOM Report is now available for use on the Projects > Bill

of Materials menu.

Line type legends

Line type legends are used on reports to show the names, lengths, and examples of the rules used in
the design or manufacturing file being output on the report. They are built by adding calculated text
fields to the report.

Shown below is the Specific Rule Legend from SPECSHEET6.ARD in the InstLib directory.

In the first column are the fields for the name of the rules. These are instances of the Line Name
calculated expression. Add these as any other calculated expression; they are in the Line Type Legend
catalog of Calculated expressions.

When you add a calculated expression from the Line Type Legend catalog, you are prompted for the
Line type index in the Function Parameter dialog box. This is a number that gets incremented by
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one each time a new line type is added to the workspace being output. When adding the calculated
expressions, increment this number by 1 for each row in the legend.

In the second column are the fields for the examples of the rules. These are instances of the Line
Representation calculated expression.

In the third column are the fields for the lengths of the rules. These are instances of the Total Line
Length calculated expression.

Line type legend expression properties

The properties of each calculated expression are important as different options can be set in the
Expression field. The amount of text in the Sample text: field sets the length of the field on the screen
and on the report.

Line Name expression
When adding a Line Name item, the expression is LTNAME(line index, ruletype option). If you double-
click the first example of the name in the Specific Rule legend to view its properties, the expression is
LTNAME(1,2). The Line Index was set in the Function Parameter dialog box - but the ruletype option
uses a value of 1 by default.

For each line in the Line type index, when the ruletype option is 1, and the rule is a generic rule, the
name of that rule in the index is shown using its generic name. For example, the names of 1/2 by 1/2
generic perf and 1/4 by 1/4 generic perf would be combined into one line, Perf.

When the ruletype option is 2, a separate entry is made in the legend for each type of specific rule.

Line Representation expression
As with the Line Name expression, the Expression field controls how the calculated expression is
displayed on the report. The Expression is in the format LTLINE(line index, ruletype option). The line
type index should always increment by one. When the ruletype option is 1, a picture of the generic rule
is drawn. When the ruletype option is 2, a picture of the specific rule type is drawn.

Total Rule Length expression
As with the other expressions used to make line type legends, the Total Rule Length expression uses
a ruletype option of 1 or 2. When set to 1, the rule length shown by the expression is that of all special
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rules of that type combined with generic rules of that type. When the ruletype option is set to 2, the
length of special rule and generic rule is listed separately.

Line type legend results

Once the legend is configured, when the report is output, the legend should look similar to the one
shown below, substituting the line types in the workspace being output.

Line and Hatch Legend Output

The Line and Hatch Legend Report in Outputs > Printer Output shows the single design, some basic
information about the design, a Line Type legend, and a Hatch Legend. The Hatch Legend in this
Output shows samples of up to 7 hatches used in the workspace. If two hatches have the same name
but are functionally different, they are both shown in the legend with the same label. Shown below is
the preview of a sample workspace used with the Output. The Hatch Legend is shown at the bottom
right.
 

 

To build a custom Hatch Legend, use the entries in the Hatch Legend folder of the Calculated
Expressions catalog when creating a Report.
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Making a multiple workspace output

You can set up an Output which outputs more than one workspace at a time by checking the Multiple
Workspace checkbox in the Shown in: group on the Output Type tab of an Output’s Properties dialog
box. This Output can also be used in the Database browsers.

It has two modes of operation: one when there are workspaces open and one when there are not.

Outputting Multiple Closed Workspaces

To use a Multiple workspace output to output closed workspaces, select it from the Multiple
Workspace folder in File > Outputs and then select the files to use with that output. You must have
at least one Output designated as a Multiple Workspace output for the folder to appear on the File
menu. Multiple Workspace outputs appear on the File menu when A) a Single Design is open; B) a
Manufacturing file is open; or C) when nothing is open.

To create and run a Multiple Workspace output on closed workspaces, do the following:

1. Create a Report and configure an Output for it in Defaults, making sure to select the Multiple
Workspace checkbox on the Output Type tab of its Properties dialog box.

2. Save and exit Defaults.
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3. Click File > Multiple Workspaces > Your output name.
 

 
4. Using the Directory View in the Open dialog box, select the files to output by holding down CTRL

and clicking their names. Click Open when you are done selecting files.
 

 
5. As each workspace is output, its path and name will appear in a dialog box.
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Outputting Multiple Open Workspaces

The process for creating an Output for use for multiple open workspaces is the same as creating one
for closed workspaces: in the Output definition in Defaults, check Multiple Workspace in the Show in
group on the Output Type tab. Running the output, however, is different.

Note:  Outputting multiple open workspaces works only for regular Outputs of single designs
and manufacturing workspaces. It does not support 3D Outputs.

Note:  If you are making a file Output, clear Automatically Open in the Output File Options
group on the Directories tab of the Output definition to prevent the multiple outputted files
from opening in their native applications.

To run a Multiple Workspace Output on open workspaces, do the following:

1. Open all the workspaces to Output.
2. Click File > Multiple Workspace > Your output name.
3. In the Select Files for Output dialog box, all the open files are automatically selected. Deselect one

by clearing its checkbox. Select or deselect all of them by checking or clearing Select All.
 

 
To select only closed workspaces, click Browse.

4. Click OK to Output the workspaces.
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Palletization integration

You can create palletized solutions directly from layouts. Cape Pack and TOPS Pro have been enhanced
by their developers to take advantage of this.

Note:

You must have Cape Pack v2.09 or TOPS Pro v6.503 or newer installed on your system to use
the palletization features. They can use either client/server or workstation/standalone mode.

Note:

Set the Cape Pack/TOPS Defaults before using any palletization features. See the Defaults
chapter for more information.

Creating a new CAPE/TOPS palletization solution

Before creating a new palletization solution, create and save the single design(s) to use in it, then do
the following:

1. In ArtiosCAD, click File > New > Palletization.
2. Select the pallet to use from the list shown in the Select Pallet dialog box and click OK. ArtiosCAD

extracts the list of pallets from CAPE/TOPS.
3. Use the Add Oneup tool to add the single designs to the layout.
4. Use the Nest tools to arrange the single designs.
5. Click Palletization > Output to CAPE/TOPS. CAPE/TOPS must not already be running; if it is,

ArtiosCAD will prompt you to close it and try again.

The Output dialog box will appear showing a preview of how the pallet might look in CAPE/TOPS.
CAPE/TOPS may show the pallet differently than ArtiosCAD depending on the orientation of the
longer dimension and other factors. Shown below is a stripped pallet.
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6. In the Output to CAPE/TOPS dialog box:

a) Set the Maximum Height and Maximum Weight fields with appropriate values.
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b) To have only the cartons and not the cartons and the waste appear on the pallet, check the
Stripped checkbox. When this checkbox is selected, stacks of the carton are shown in the
preview and in CAPE PACK, as in the example above. When this checkbox is not selected, just
the flat top-down view is shown in the preview and in CAPE PACK.

c) Set the Calculate True Caliper from Medium and Liners checkbox to force ArtiosCAD to
measure the caliper based on the board components along the flute rather than using the
caliper variable. This checkbox is cleared and unavailable for non-corrugated boards.

7. Click OK to perform the Output.

CAPE will open showing the solution.
 

 
In TOPS, it looks like this:
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8. Use CAPE/TOPS as desired to complete the palletization solution.

Converting a layout to a CAPE/TOPS palletization solution

To convert a layout to a CAPE/TOPS palletization solution, do the following:

1. Open the layout in ArtiosCAD.
2. Click Palletization > Output to CAPE/TOPS.
3. ArtiosCAD will prompt that no pallet is defined. Click OK to have ArtiosCAD select the closest

matching pallet.
4. In the Select Pallet dialog box:

a) Select a different pallet if desired.
b) Select or deselect the Stripped checkbox to control if waste will be on the pallet.
c) Select the Adjust sheet size to match pallet size checkbox to change the size of the existing

sheet to match the pallet.
5. Click OK in the Select Pallet dialog box to continue.
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6. In the Output to CAPE/TOPS dialog box:
a) Enter the maximum height and weight of the pallet.
b) Select or deselect the Stripped checkbox.
c) Select of deselect the Calculate True Caliper from Medium and Liners checkbox (if available).

7. Click OK in the Output to CAPE/TOPS dialog box to perform the Output.

CAPE/TOPS will open showing the solution.
8. Use CAPE/TOPS as desired to complete the palletization solution.

Changing the pallet in a CAPE/TOPS palletization solution

To change the pallet in a layout that already has been used in a palletization solution, do the following:

1. Open the layout in ArtiosCAD.
2. Click Palletization > Change Pallet.
3. In the Select Pallet dialog box, select a different pallet. A brown bounding box represents the

selected pallet in the drawing area as shown below.
 

 
 

2042



15ArtiosCAD

 
4. Set the Stripped and Adjust sheet size to match pallet size checkboxes as desired.
5. Click OK to make the change.

Palletization FAQ

Question Answer

Why is OK unavailable in the CAPE/
TOPS Output dialog box after I create a
new palletization workspace?

No board information has been defined yet. Either add a
design or click Info > Board Information and select a board.

Why does the sheet size keep
changing when I change pallets?

Adjust sheet size to match pallet size is selected in the
Select Pallet dialog box. Deselect it to stop this.
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Question Answer

Why isn't the sheet size changing to
match the pallet size when I choose a
new pallet?

Adjust sheet size to match pallet size is not selected in
the Select Pallet dialog box. Select it to have the sheet size
change with the pallet.

Why is Calculate True Caliper from
Medium and Liners unavailable?

The current board is not a corrugated board and thus has no
medium or liners defined. Change to a corrugated board by
clicking Info > Board Information.

Why does the preview look different
than my layout?

CAPE/TOPS requires the length of the layout to be greater
than the width. ArtiosCAD will rotate the layout by 90 degrees
if required to meet this rule.

There’s a brown edge when I select a
pallet and sometimes the sheet edges
vanish. Why?

The brown edge represents the pallet edge. The pallet is
placed centered on the layout. When Stripped is selected,
only the single designs determine the pallet placement
and the sheet edges are not shown. When Stripped is
not selected, both the single designs and the sheet edge
determine the pallet placement.

What are the brown and purple lines in
the preview?

When Stripped is not selected, the brown lines are the pallet
edge, and the purple lines are the sheet edges which are not
output to CAPE/TOPS.

My layout has an overhang; why isn't it
showing?

CAPE/TOPS handles overhangs differently from ArtiosCADas
everything is centered on the pallet. An uneven overhang will
be recalculated. Also, if the blank is smaller than the pallet,
there will be no overhang in CAPE/TOPS.

I made my layout the way I want it and
CAPE/TOPS is nesting it differently.
Why?

CAPE/TOPS maximizes the pallet usage and thus may re-nest
the layout if the either the blank width or height are less than
half of the pallet width or height.

How does ArtiosCAD calculate the
inside dimensions from CAPE/TOPS
dimensions?

ArtiosCAD uses the inside dimensions to build a design,
while CAPE/TOPS can use either inside dimensions plus the
caliper or outside dimensions. If CAPE/TOPS specifies inside
dimensions, so does ArtiosCAD. If CAPE specifies outside
dimensions, the package type defines the number of folds
along length/width/height and ArtiosCAD subtracts these
folds (times the board caliper) along each side to calculate
the inside dimensions.

A design in ArtiosCAD is not the same
size when I convert it to 3D even
though the inside dimensions and
caliper match.

ArtiosCAD’s outside dimensions on a standard may not
always match those from CAPE/TOPS due to the use of inside
loss and outside gain causing bulges on folds.

Why do I have to reselect a board
when I have mapped it properly?

In CAPE/TOPS, most outside dimensions are specified
and thus the material thickness is sometimes ignored, in
which case it is set to 0.0 with name undefined. There is no
material by that name in the CAPE/TOPS mapping table and
thus ArtiosCAD does not recognize it. All ArtiosCAD designs
must have a board code and inside dimensions, and to set
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Question Answer

the inside dimensions properly from CAPE's/TOPS’ outside
dimensions, you may have to reselect the board.

Do I need to fold up my 3D design or
will ArtiosCAD do it automatically for
me before palletizing it?

You must fold up your designs before palletization so that
ArtiosCAD sends the correct size bounding box to CAPE/
TOPS.

Can I customize the textures shown on
the pallet?

Yes. Put your own versions of palletwood.jpg and
palletwoodend.jpg in ClientLib or ServerLib if
desired.

I got an error about mismatched
package size. What is this?

This is due to the difference between ArtiosCAD’s and
CAPE’s/TOPS' methods for calculating outside dimensions.
Generally click No if you see this message.

I have done a lot of work in CAPE/
TOPS and now I have many designs
open in ArtiosCAD. Which one is
correct?

They are all correct since you supplied the parameters each
time and clicked File > Export and Exit. If you only wanted
to check the palletization in CAPE/TOPS, click File > Exit
instead without exporting.

3D Outputs

To output a 3D workspace, click File > Outputs-3D and select an output file type.
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Note:  Using any of the Animation outputs requires purchasing the 3D Designer solution.
Contact your Esko salesperson for more information about purchasing this solution. Using
the Animation-DOC output requires Microsoft Word to be installed on your system. Using the
Animation-PPT output requires Microsoft PowerPoint to be installed on your system.

Note:  Dimensions are turned off in animation outputs.

Outputting a 3D Workspace as a STEP, IGES, ACIS, or XCGM File

Use the Spatial export Output in 3D to export a 3D workspace as a STEP, IGES, ACIS, or XCGM file for
use in other programs. This Output makes a solid body from each panel and crease of an ArtiosCAD
design instead of thousands of triangles. If there are multiple parts in a workspace, each part is a
separate body.

To perform the export, do the following:

1. Position the items in the 3D workspace as desired and save the workspace.
2. Click File > Outputs-3D > Spatial export.
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3. Choose the desired file type in the Export as: group.
4. Set the checkboxes as desired:

a) Create single body exports all the panels of the container as one solid body for easier use in
other applications. When this checkbox is not checked, each individual panel is exported as a
part.

b) Manually close export dialog on warnings keeps the progress bar dialog box open if there are
any warnings so you can see them. Click Close to close the dialog box.

c) Include solids (as triangles) includes any solids in the 3D workspace in the Output as triangles.
When this checkbox is not selected, ArtiosCAD only includes containers in the exported file. This
checkbox is not available if there are no solids in the workspace.

5. Click OK to start the Output.
6. Set the filename and folder as desired and click Save.
7. ArtiosCAD displays a progress bar as it exports the file.

 

 

Spatial Export Notes
Notes about using the Spatial export 3D Output:

• ArtiosCAD includes no graphics in the exported file due to file format restrictions.

• There can be only one color per single design. ArtiosCAD sets the color to the outside color of the
single design(s).

• Creases are represented by cylinders. When their ends are not flat, ArtiosCAD renders their ends
with triangles for a more realistic appearance.

• Slots and indented perfs have square edges and are cut through completely.
• There is no representation for edge crushing.
• ArtiosCAD exports imported solids as triangles. More intricate solids may cause the export to take

longer.

Outputting a 3D animation as a Microsoft Word document

To output a 3D animation as a Microsoft Word document, do the following:
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1. Make sure Microsoft Word is loaded on your system and that the animation is saved and ready for
output.

2. Click File > Outputs-3D > Animation-DOC. The Animation-DOC dialog box appears as shown below.

Animation tab
1. On the Animation tab, the options in the Export animation as: group control the type of output

created. Leave Word (*.DOC) selected.

The options in the Backdrop group determine what is shown along with the animation. None turns
off frame titles; to turn off the background image, deselect it in the View Mode dialog box before
starting the Output. Use frame titles includes the frame titles set for each frame in the Frame
Properties dialog box when making the animation. Title each image adds a title for each frame if
none were defined during creation. Use %% to include the image number. Using both title options
simultaneously is possible; frames with specific titles defined in the animation use them, while
frames with no title defined use the one specified in the Title each image field. Font and Size set
the typeface and size of the title for each frame. Use template is not applicable for this output type.

In the Number of images group, One per frame uses a page of Word document per frame of
animation. Specify enables the Number of images: field, which controls how many animation
frames are captured and exported, and Seconds between image captures: field, which controls
the length of animation playback time between each image capture. Setting a value in one field sets
the value in the other field.

Scale to fit every frame scales each frame to fit the output size defined in the Image bounding box
group regardless of the frame properties set in the animation.

Insert a page break after each image in the Word Page breaks group controls whether or not hard
page breaks are inserted after each image. When this option is not selected, more than one image
per page is possible depending on the size of the bounding box.

The fields in the Image bounding box group control the size of the image placed on the page.
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Set the options on this tab as desired, and then click the Bitmap tab.

Bitmap tab

1. The settings on the Bitmap tab control the format of the exported images, their pixel size, and the
rendering method used to generate them.

In the Embed bitmaps as: group, choose either PNG (Portable Network Graphics) or JPEG (Joint
Photographic Experts Group) format. PNGs ignore background color and support alpha channel
transparency, which can improve their appearance in programs that support alpha transparency.

JPEGs support quality settings via the Quality field, with 1 being lowest quality and smallest image
file size and 100 being highest quality and largest image file size. JPEGs support background color
but do not support transparency.

The maximum bitmap size using Direct3D is different for each display adapter. The Width: and
Height: fields all set the number of pixels that in total determine the resolution of the exported
images. Do not forget to consider the size of the pages in Microsoft Word when setting the pixel size
of the images, as the images will be clipped to fit the margins of the page if they are too large. To
set the maximum size, click Maximum size <number>.

Setting both the Width: and the Height: to 1000 pixels provides sucient resolution for most
workspaces. Use a higher resolution if the exported animation will be printed, but do not forget that
image size is also controlled by the bounding box size set on the Animation tab and must fit on the
page in Microsoft Word.

To use OpenGL and thus make higher-resolution images, check the Use OpenGL checkbox and
change the number of pixels; this option is selected by default. Shrink size to remove white space
removes the background pixels surrounding the workspace from the exported images, and is
automatically selected and disabled if a background image is visible in the workspace.

Set the options on this tab as desired, then click the General tab.
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General tab

1. On the General tab are the Output Directory: field and the Automatically Open checkbox. If you
enter a directory in the Output Directory: field or use the Browse button to specify one, that
directory is used by the Save As dialog box when you click OK. Automatically Open controls
whether ArtiosCAD launches Microsoft Word after the Output is done and opens the document.

Finishing the Output
1. Once you have set the options on all the tabs as desired, click OK.
2. In the Save As dialog box, choose the directory in which to save the file and enter a filename.

Click Save to perform the Output. Depending on the state of the Automatically Open checkbox,
ArtiosCAD may launch Microsoft Word and open the document. Shown below is an example Output.
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Outputting a 3D animation as a PDF document

Outputting a 3D animation as a PDF document is similar to outputting an animation as a Microsoft
Word document. The only differences are on the Animation tab of the Animation-PDF dialog box. Using
this Output requires having purchased the PDF option.

To output a 3D animation as a PDF document, do the following:

1. Make sure the animation is saved and that the workspace is ready for output.
2. Click File > Outputs-3D > Animation-PDF. The Animation-PDF dialog box appears as shown below.
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In the Export animation as: group, leave PDF (*.PDF) selected.

The options in the Backdrop and Number of images groups work the same way as in the Animation-
Doc Output.

The Width and Height fields in the PDF Page Size group set the size of the PDF pages in the outputted
file.

The fields in the Image bounding box group control the size and placement of the images on the
pages; set them as desired. Ensure the bounding box is smaller than the page size to avoid clipping the
graphics in the outputted file.

Set the options on this tab as desired.

1. Set the options on the Bitmap, PDF Security, and General tabs as desired, and click OK.
2. In the Save As dialog box, choose the directory in which to save the file and enter a filename. Click

Save to perform the Output. If you have a PDF-viewing utility (such as Adobe Acrobat or Adobe
Acrobat Viewer) and the Automatically Open checkbox on the General tab was selected at time of
Output, the PDF file will be opened automatically as shown below.
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Outputting a 3D animation as a Microsoft PowerPoint document

Outputting a 3D animation as a Microsoft PowerPoint document is similar to outputting an animation
as a Microsoft Word or PDF document. The only differences are on the Animation tab of the Animation-
PPT dialog box.

To output a 3D animation as a Microsoft PowerPoint document, do the following:

1. Make sure Microsoft PowerPoint is loaded on your system and that the animation with at least 2
frames is saved and ready for output.

2. Click File > Outputs-3D > Animation-PPT. The Animation-PPT dialog box appears similar to the one
shown below.
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3. In the Export animation as: group, leave PowerPoint (*.PPT) selected.

The options in the Backdrop and Number of images groups work the same way as in the Animation-
Doc and PDF Outputs. Use template lets you specify or browse for a Microsoft PowerPoint template
to use instead of having the images placed on a series of blank slides. If you plan to use a template,
turning off the background image in the View Mode dialog box before performing the Output may
yield more desirable results.

The options in the PowerPoint Slide Transition group control if the output file runs as a slide
show when opened. Click Automatic to have the slides automatically advance using the duration
specified in the Delay (seconds) field.

The fields in the Image bounding box group control the size and placement of the images on the
slides; set them as desired. Ensure the bounding box is smaller than the page size to avoid clipping
the graphics in the outputted file.

Set the options on this tab as desired.
4. Click the Bitmap and General tabs and set the options on them as desired, and then click OK.
5. In the Save As dialog box, choose the directory in which to save the file and enter a filename. Click

Save to perform the Output. If Automatically Open was checked on the General tab, ArtiosCAD will
launch Microsoft PowerPoint and open the presentation.
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Outputting a 3D workspace as a JPEG or PNG bitmap

To output a 3D workspace or frame of an animation as a bitmap, do the following:

1. Save the workspace and position it as you would like it to appear in the outputted file. If outputting
an animation frame, use the Animation Playback tool to show the desired frame of the animation.

2. Click File > Outputs-3D > Bitmap JPEG or Bitmap PNG. The Bitmap JPEG or Bitmap PNG dialog box
will appear similar to the one shown below.
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3. The settings on the Bitmap tab control the format of the exported image, its pixel size, and the
rendering method used to generate it.

In the Save bitmaps as: group, choose either PNG (Portable Network Graphics) or JPEG (Joint
Photographic Experts Group) format. PNGs ignore background color and support alpha channel
transparency, which can improve their appearance in programs that support alpha transparency.
They are the only Output type which supports the transparency features in ArtiosCAD.

JPEGs support quality settings via the Quality field, with 1 being lowest quality and smallest image
file size and 100 being highest quality and largest image file size. PNGs do not support a quality
setting, so that option is not available when PNG is the selected format. JPEGs support background
color but do not support transparency.

The maximum bitmap size using Direct3D is different for each display adapter. The Width: and
Height: fields set the number of pixels that determine the resolution of the exported images. To set
the maximum size, click Maximum size <number>. Setting both the Width: and the Height: to 1000
pixels provides sucient resolution for most workspaces. Use a higher resolution if the exported
animation will be printed.

To use OpenGL and thus make higher-resolution images, check the Use OpenGL checkbox and
change the number of pixels; this option is selected by default. Shrink size to remove white space
removes the background pixels surrounding the workspace from the outputted image, and is
automatically selected and disabled if a background image is visible in the workspace.

Set the options on this tab as desired, then click the General tab.

4. On the General tab are the Output Directory: field and the Automatically Open checkbox. If you
enter a directory in the Output Directory: field or use the Browse button to specify one, that
directory is used by the Save As dialog box when you click OK. Automatically Open controls
whether ArtiosCAD launches an image viewer after the Output is done and opens the document.
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5. In the Save As dialog box, choose the directory in which to save the file and enter a filename, and
click Save to perform the Output. If Automatically Open was checked on the General tab, ArtiosCAD
will launch the default image viewer associated with the bitmap file type and show the file.

Outputting a 3D workspace to an EPSF file, PDF file, or printer

The Plot to EPSF, Plot to PDF, and Plot to Printer Outputs in File > Outputs-3D all work similarly, just as
the animation outputs work similarly.

To perform one of these three Outputs, do the following:

1. Save the workspace and position it as you would like it to appear in the outputted file. If outputting
an animation frame, use the Animation Playback tool to show the desired frame of the animation.

2. Click File > Outputs-3D, then click either Plot to EPSF, Plot to PDF, or Plot to Printer. The Plot to
Choice dialog box will appear.
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The options in the Device group control the Output type and any associated options for that type. PDF
and Illustrator 8.0 (*.EPS) have no additional options in this group, but choosing Windows Driver lets
you choose the device, the page orientation, and the number of copies to make.

In the Output As group, Bitmap makes the output as a snapshot of the screen. Vectors takes a
snapshot but adds the edges as lines. U3D is unavailable as this is not a PDF or U3D Output.

When choosing Vectors, the degree of complexity of the workspace may cause issues with hidden line
removal, and if there are more than 10 designs or solids with more than 10,000 polygons, the Output
may take a few minutes to complete. Vector outputs do not contain bounding boxes. The color of the
lines is set by the plotting style for plots and PDF Outputs. Line color in EPSF Outputs are controlled by
the tuning file TUNE.EPSF.3D.TXT.

The options in the Scale group control the size of the Output as compared to its original size in the
workspace. To Fit One Page is most useful when using Plot to Printer. Specify lets you enter a desired
value in the Scale: field.

The Device Size, Margins, and Position groups all work as they do in other Outputs. Device Size is
unavailable for Outputs of type Windows Driver.

Set these options and values as desired, and then click the General tab.
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1. On the General tab, the Output Directory field lets you specify the directory in which the Output
file will go. The Automatically Open checkbox controls whether the outputted file is automatically
opened by a program associated with its file type, such as Adobe Illustrator for .EPS files.
Automatically Open has no effect for Plot to Printer unless Out to File is also selected and the
filename includes an extension associated with a program such as .txt.

2. Once you have set the options on the Plot and General tabs as desired, click OK.
3. In the Save As dialog box, choose the directory in which to save the file and enter a filename, and

click Save to perform the Output. If Automatically Open was checked on the General tab, ArtiosCAD
will launch the default application associated with the outputted file type and show the file.

Outputting a 3D workspace to a PDF file with U3D

U3D is an industry-standard 3D output format that can be read by many applications. For example, if
you embed U3D data in a PDF file, Acrobat Reader 7.0 or greater lets you zoom in and out, rotate, and
otherwise change the view of the objects in the 3D file window.

Creating a PDF file with embedded U3D data is similar to creating a PDF file without it, in that in 3D,
you click File > Outputs > Plot to PDF/U3D, except that instead of choosing to output as a bitmap or
vectors, you choose U3D in the Output As group on the Plot tab of the Output dialog box. Also, the U3D
Options tab is added to the Output dialog box as shown below.

On the U3D Options tab, in the High graphics group, Use View Settings uses the current high graphics
mode of the workspace. Clear this checkbox to enable the drop-down list box in which you can choose
the desired high graphics mode setting.
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In the Include bitmaps as group, choose the file type for the images embedded in the PDF file, either
PNG or JPEG. When JPEG is the selected choice, the Quality 1..100 field is available. Use a higher
number for better-quality images.

In the Background color group, Use Workspace includes the background color defined in the View
Mode dialog box, if there is one. Clearing this checkbox enables the Red:, Green:, and Blue: fields, and
also the Select Color button, which leads to the color palette.

On the PDF Security and General tabs, set the options as desired.

When you have completed setting the various options, click OK to make the PDF file with embedded
U3D data, or click Cancel to return to ArtiosCAD.

Shown below is a 3D workspace output to a PDF file using U3D in transparent wireframe view.
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Outputting a 3D workspace to U3D

To output a 3D workspace to plain U3D for use with other applications, use the U3D entry on the
Outputs-3D menu. Clicking the U3D entry opens the U3D dialog box as shown below.
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On the U3D Options tab, in the High graphics group, Use View Settings uses the current high graphics
mode of the workspace. Clear this checkbox to enable the drop-down list box in which you can choose
the desired high graphics mode setting.

In the Include bitmaps as group, choose the file type for the images embedded in the PDF file, either
PNG or JPEG. When JPEG is the selected choice, the Quality 1..100 field is available. Use a higher
number for better-quality images.

Include Animations is checked by default.

On the General tab, the Output Directory field lets you specify the directory in which the Output file will
go. The Automatically Open checkbox controls whether the outputted file is automatically opened by a
program associated with its file type, such as Adobe Illustrator for .EPS files.

Once you have set the options on the Plot and General tabs as desired, click OK.

In the Save As dialog box, choose the directory in which to save the file and enter a filename, and click
Save to perform the Output. If Automatically Open was checked on the General tab, ArtiosCAD will
launch the default application associated with the outputted file type and show the file. However, most
systems do not have an application associated with U3D files.

Notes and warnings when using U3D
U3D-enabled Outputs do not follow the 3D View mode settings in the current view, except in the one
case of High graphics mode if Use View Settings is checked on the U3D Options page of the Output. In
particular, U3D files are always created as if Solid, Perspective, Show board thickness, and Graphics
are turned on in the View mode.

For PDF Reports with embedded U3D data, the U3D models are centered and fill the appropriate 3D file
window, regardless of window settings in the Report. The scene is scaled to fit the 3D file window. Also,
3D content appears as a static bitmap of the initial view in the Outputs Preview dialog box.

For Plot to PDF Outputs, the U3D window matches the placement as if Bitmap were selected in the
Output As group. With an edge-on view this will generally result in a skinny U3D window in the PDF file
and the model will appear cut off as soon as it is rotated. To get around this, use a PDF Report with a
3D file window of the desired shape and size. Size issues can be somewhat counteracted by using the
Marquee Zoom tool in Acrobat to make the 3D window fill the screen.

For both PDF Reports with embedded U3Ds and Plot to PDF Outputs, background images are not
embedded in PDFs. Background images for 3D objects are not supported by the current PDF standard
(PDF 1.6).

For plain U3D Outputs, the background image is included in the U3D file but will only match an
ArtiosCAD view if the viewing window can be made the same size relative to the background image
as it is in ArtiosCAD. It may be possible to achieve nearly the same alignment as viewed in ArtiosCAD
by not manipulating the object and resizing the window carefully. This means that a model aligned
to a background in ArtiosCAD can not be Output in a way that it will necessarily appear aligned to the
background when opened in another U3D-enabled application.

U3D background images can only be 24-bit color images; other format background images are ignored,
not exported.

Reports with more than one 3D file window with the same file number do not work correctly with U3Ds.

Adobe Acrobat versions 7.0.9 and 8.0 have an issue where the first of several copies of a 3D object
does not appear initially. For example, an beer carrier with 6 bottles will initially appear to have only 5
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bottles. The missing object(s) appears as soon as you clicks in the 3D area, or you scroll the Acrobat
Reader window, or do something else to cause it to update the view. With Acrobat 7.0.9 the temporary
disappearance will happen again each time Acrobat's 3D Toolbar is used (such as to change the
rendering mode or the lighting).

Adobe Acrobat Professional 7.0.9 does not embed ArtiosCAD-generated U3D data. Users wishing
to embed raw U3D from ArtiosCAD in PDF files are currently recommended to use Adobe Acrobat
Professional 8.0 (best) or 8.1. In Adobe Acrobat, use Tools > Advanced Editing > 3D Tool to embed the
U3D data into an existing PDF file.

As of this writing, the best viewer for ArtiosCAD-generated PDFs with U3D models embedded is Adobe
Acrobat Reader (or Professional) version 8.0. Version 8.1 has introduced an issue where replicated
objects sometime move over other copies of the same object. Adobe Acrobat aggressively updates
itself to the highest version available with the same major release number (7.x -> 7.0.9 and 8.x goes to
8.1, at the moment). As a workaround, Adobe Acrobat Reader 7.0.9 can still be downloaded from the
Adobe website for free and works better than Adobe Acrobat Reader 8.1 for viewing ArtiosCAD files
with copied design and solids.

To download Adobe Acrobat Reader 7.0.9, point a Web browser to http://www.adobe.com/products/
acrobat/readstep2_allversions.html.

U3D Animation Notes
Some notes about animations in exported U3D files:

• ArtiosCAD will instruct Acrobat Reader to repeat the animation 1000 times because it does not
recognize when you click Play after the animation finishes. This way, you may pause and resume
the animation as desired. If you have a piece that appears or disappears at the end of the animation,
make sure to add a frame afterward so that this action is visible.

• U3D animations showing moving bend panels will not exactly match the ArtiosCAD animations due
to U3D format restrictions; however, they will be a close approximation.

• Surface smoothness in an exported U3D file can vary due to variances in the U3D algorithm.
• Scale to Fit is not supported.
• U3D animations with curved creases and/or mates may not work properly.

Outputting a 3D workspace to a VRML file

Outputting a VRML file from 3D lets you share your work in 3D with people who do not have either
ArtiosCAD or the ArtiosCAD Viewer.

Note:  If your workspace contains a tear-away animation, or an animation with curved creases
or mates, do not output it to VRML as VRML does not support the type of bends used. Use a
different Output format.

To output a 3D workspace to a VRML file, do the following:

1. Set the view angle and elevation of the 3D workspace as you want them to be in the VRML file.
2. Click File > Outputs-3D > VRML.
3. Navigate to the directory in which to save the files, and name the main file as desired. The picture

files will share the same root name as this main file. As the Save as type: field defaults to VRML
when exporting from 3D, do not change it. Click OK when done naming the file to be saved in the
desired location.
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4. The VRML Options dialog box appears. The options in it are explained at the end of this procedure.
Set the options as desired and click OK.

5. The VRML files are created in the desired location. If the Automatically open checkbox in the VRML
Options dialog box was checked, the Web browser launches and the animation opens.

Shown below is the VRML Options dialog box. All the options in it are configurable in Defaults >
Outputs-3D > Artios > VRML > VRML options.

SolidWorks compatible VRML 1.0 outputs a VRML version 1.0 file for use with SolidWorks and other
programs that do not support VRML version 2.0. VRML 1.0 does not support graphics or animation.

Include graphics controls the export of graphics. Turn this checkbox off for the smallest VRML files
with the most robust performance possible in the browser; turn it on for rich detail. This checkbox
must be checked for the JPEG Images and Creases groups to be available.

Note:  Exporting a design to VRML with graphics turned on creates separate .JPG files.
Make sure to keep them with the .WRL file so that the graphics are displayed correctly when
the .WRL file is viewed.

Include corrugations, when checked, draws corrugations on the edges of corrugated boards. Turn this
checkbox off for smaller VRML files with more robust performance in the browser.

Use compression controls if the VRML geometric information file is compressed or not. A smaller file
is faster to download, but some third-party programs do not support compression and may error if this
option is checked. The JPEG image files are already compressed according to the JPEG Quality setting
in Property Defaults and are unaffected by the state of this checkbox.

Automatically open, when checked, launches the Web browser and opens the VRML file as soon as it is
created.

View zoom factor sets the initial field of vision in the VRML file. 100 percent uses the same scale factor
as in ArtiosCAD. If you find that animations are extending outside of the browser window, try setting
this value to a smaller number. The zoom factor can be between 40 percent and 250 percent.
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JPEG Images group
On export, the image of each face of the box is converted to a JPEG graphic. Separate image on each
face creates a separate JPEG file for each face. The size of each file is limited by the resolution of the
graphics in ArtiosCAD.

Separate image for each design makes a single large JPEG file for each design in the workspace
instead of separate JPEG files for each face. Use this option when using the VRML file in other 3D
graphics applications that need to substitute or manipulate the graphics.

The High graphics: drop-down list box lets you specify the resolution of the exported graphics as
Low, Medium, High, or Maximum. High and Maximum depend on the abilities of the computer’s display
adapter.

Creases group
There are several ways to handle creases when exporting to VRML. No creases simply does not include
them in the output. Creases in board color makes them the same color as the board, but the lighting in
the VRML rendition shows them as slightly contrasting. Creases in pink turns the creases pink for easy
visibility. Graphics on creases wraps the graphics around the creases on the inside and outside of the
design(s). This is the most sophisticated option, but it increases file size by 50 percent.

Background color group
The settings in the Background color group control the color shown by the browser in the empty space
as the VRML file plays. No background allows the preferences set in the VRML plug-in to be used. When
checked, the rest of the options in the group are unavailable.

The values in the Red:, Green:, and Blue: fields allow you to set custom values for each color. The
results of the settings are shown next to the Red: field.

Clicking Select Color opens the color palette. Click OK when you have chosen a color.

Output Units group
As there is no measurement ability in the browser window, the options in this group control the
granularity of the VRML plug-in’s zoom tools. Selecting Meters provides coarse zoom while selecting
Millimeters provides fine zoom. Centimeters is the default, and should be selected when choosing
With toolbar in the Animation group. Points for Strata 3D should be selected when the VRML file will
be opened in Strata 3D; select No animation in the Animation group as well for files destined for Strata
3D.

Animation group
The options in the Animation group control how the animation behaves in the browser.

Note:

Do not output VRML animations with curved creases or mates as they may not work properly.
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No animation creates an unmoving view of the design. Forward runs the animation continuously.
Forward and back runs the animation forward, then backward, and repeats. With toolbar inserts
a toolbar into the VRML file allowing you to manually step through the file, as well as toggle design
transparency. The toolbar is shown below:

 The first button plays the animation.

  The second and fifth buttons move to the first and last frames of the animation, respectively.

  The third and fourth buttons move back or forward one frame in the animation sequence,
respectively.

 The sixth button toggles transparency. Shown below is a frame of an animation with transparency
off.

Shown below is the same frame with transparency on.

2066



15ArtiosCAD

3D Movie Outputs

If you have the 3D Animation module, you can export .AVI and .MP4 movies from ArtiosCAD. The Movie
output type has been added to Outputs-3D entries.
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Note:

This feature is highly dependent on the multimedia codecs on your computer. Esko cannot
guarantee that the codecs on your personal computer will work as anticipated. If you have
trouble using this feature, you should make sure you have the newest codecs available from
your operating system vendor or other third-party software vendor.

Creating a 3D Movie Output in Defaults
Before you create a 3D Movie output, keep these considerations in mind:

• Multimedia codecs vary between computers and there is no guarantee that a movie you make
on your machine will work flawlessly the first time on someone else’s computer. If you encounter
problems, you may need third-party support from your operating system vendor or codec supplier.

• You need the 3D Animation module on your computer to use this Output.

Create a 3D Movie Output definition by doing the following:

1. Start ArtiosCAD, open Shared Defaults, and expand the Outputs-3D catalog.
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2. Right-click Outputs-3D, then click New > Data.
3. Enter a name for the Output, press Enter, and double-click the new entry.
4. In the Output Type group, select Movie.

 

 
5. Click the Movie tab.
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6. In the Export animation as group, choose either AVI or MP4. Hover over the information button for

more information.
a) Supplemental information about the codec used by the selected format is shown beneath the

Configure button. The default settings are sucient for most situations, but if you are not
achieving the desired results, click Configure.
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b) in the Choose codec for AVI file dialog box, set the codec ArtiosCAD uses to create the movie in
the Compressor field. The list of compressors available is dependent upon the software loaded
on your system.

c) When you have selected the compressor and quality settings to use, click OK to return to the
Movie tab in the Output definition.

7. In the Preview/File size group, set the default selection for these options when creating the Output.
Preview and file size will make a preview of the movie and compute its file size based on the
selected codec configuration. File size only will only compute the file size. The times in the other
group either preview the First 2 seconds only or the Full movie length. Get file size is available only
when creating the Output.

8. In the Properties group, set the FPS (Frames per second) value to a number between 1 and 30. 15
is the default. A higher number results in smoother video. Scale to fit every frame performs a Scale
to Fit for every frame of the video.
a) Number of images and Seconds between image captures are read-only fields that display their

relevant information when creating the Output.
9. In the Dimensions group, set the width and height in pixels of the movie manually by selecting User

Defined Size from the drop-down list box, or choose one of the pre-defined sizes. The sizes must
both be exactly divisible by 4. Hover over the information button for more information.
a) NTSC (National Television Standards Committee) is the video format used for televisions in the

United States and Japan. PAL (Phase Alternating Line) is the format used in some of the rest of
the world.

b) DVD, SVCD, and VCD refer to the size of the frame in pixels - Digital Versatile Disk being large,
Super Video CD being medium, and Video CD being small.

c) DivX, XviD, and WMV are all standard sizes for movies intended to be watched on a computer.
a) DV stands for digital video which has a standard width of 720 pixels. The height varies by country

standard.
10. Once you have set the options on the Movie tab as desired, click the General tab, on which you can

set the Output Directory (if desired) and also the Automatically open checkbox, which is checked
by default.

11. Click OK to finish defining the Output.
12. Save and exit Defaults as usual.

Outputting a Movie from 3D
Because VRML and U3D outputs do not support the methods used for curved creases, you can now
output .AVI and .MP4 movie files of your animation sequences. You must have the 3D Animation module
to output movies from 3D.

.AVI files can be played on the Apple Macintosh using VLC Player which can be downloaded from: http://
www.videolan.org/vlc/, and MOV files can be played on all computers using VLC as well.

Before you can Output a movie from 3D, you must have configured a movie Output in the Outputs-3D
catalog in Defaults. See the Defaults chapter for more information.

To Output a movie from 3D, do the following:

1. Create or open a 3D workspace that has an animation sequence defined.
2. Click File > Outputs-3D and click the desired movie output.
3. Set the options on the Movie tab as desired.
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4. If desired, click Preview/Get file size in the Preview/File size group to generate a preview of the

movie or find out how large the file will be. Adjust the settings if the file size is too large; some email
systems still have 5 MB attachment limits.

5. Click the General tab and set the options as desired.
6. Click OK and enter a name for the movie file in the Save As dialog box to begin the Output.
7. A progress dialog box appears. If it is going to take too long to Output the movie, click Cancel. In

that case you should retry the Output with different settings - a lower FPS setting, a smaller frame
size, greater compression - that will result in a smaller, faster-to-generate file.
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8. If Automatically Open on the General tab was checked, the movie file opens automatically in the

associated media player.
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Canvas Outputs

Canvas Outputs are similar to regular Outputs.

If you use an Output on the File menu, ArtiosCAD uses the active part for that Output. To Output all the
parts in a canvas, use Parts > Parts Outputs, in which case ArtiosCAD iterates through all the Parts in
the canvas.

Some notes about canvas Outputs follow.

For calculated expressions:

• In most cases, avoid directly accessing workspace variables. However, L, W, and D work correctly
for either the canvas or a part. Note that for a part, L, W, and D are for information only.

• Most board variables will work correctly, such as CAL, IL, OG, CRRV, TEST, WGHARA, CSTARA,
CSTWGH, HRRV, SRV, BRD$, BDD$, FLU$, and TST$. However, corrugated board variables for
liners and mediums will not work for the selected part, as they always return canvas information.

• Legacy Reports may contain calculated expressions that directly access variables. These
will not work with canvases and parts. Remove these expressions and re-add them from the
Calculated Expression catalog, as those contain updated definitions. For example, you may
have a Report that uses DBREC.DESC to show a design description. Replace this with an
expression using DBGET(DESIGN,DESC$). Likewise, if you have a legacy Report that uses
(TLIBRARY(LIBDBSTYLE.TXT)) to list design characteristics, replace it with #DBCHARS$ so
that ArtiosCAD gets the characteristics for the canvas or part as appropriate.

• The expression for Design Standard Name, #CFN$, will always return the name of a standard used
for a canvas, not for a part.
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If your Output is set to Output to a layer, ArtiosCAD generally puts that data into a part of type Output.
There can be only one Output part; if there already is one, ArtiosCAD adds the content to the existing
part.

Running a BOM-like Output for a canvas

This type of Output combines the results into a single PDF or XML file. To run a BOM-like Output for a
canvas, do the following:

1. Click the name of the canvas in the Parts List to select it.
2. Click Parts > Parts Outputs and then the desired Output. (The desired Output must have Parts

Outputs selected in the Show In group in its definition in Defaults to appear in this list.)
3. ArtiosCAD opens the Select Parts dialog box.

 

 
ArtiosCAD selects all Production-type parts by default. Click a part name to see its preview.

4. To change the order in which ArtiosCAD processes Production and non-Production parts, drag a
desired part and drop it below another part. To save the Output order in the workspace for future
use, click Save Part Order.
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5. Select the parts to include in the Output and click OK.
6. ArtiosCAD runs the Output normally and prompts you to set the scale, number of pages, see a

preview, or set the properties. Click OK to make the Output. If your Output goes to a file, ArtiosCAD
prompts you for the location and filename.

Shown below is an example BOM Report.
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Running a part-by-part Output for a canvas

Part-by-Part Outputs run without prompting for more information. Make sure to configure them so
that they do not need to prompt you for information. For example, for a samplemaking output, make
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sure the directory is set correctly for the output file on the Directories tab of the Output definition in
Defaults.

For this example, create a Plot-type Output that goes to a CAM device using CFF2 - Save as the tuning
entry.

For ArtiosCAD to name output files with Part names, it needs to use a library function containing this
text:

def &ret$ &cf2nm$
set &cf2nm$ STRING(#PARTNAME$,".cf2")
set &ret$ &cf2nm$

Save the above code block into a text file in ServerLib or ClientLib. For this example it has
CF2FILENAME.TXT as the filename.

In the Plot Filename group on the Directories tab of the Output, specify it in the TLIBRARY() field. Also
make sure to select From Library Function and set the output directory as desired.
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Click OK and save the Outputs catalog entry as usual.

To run a part-by-part Output for a canvas, do the following:

1. Click the name of the canvas in the Parts List to select it.
2. Click Parts > Parts Outputs and then the desired Output. (The desired Output must have Parts

Outputs selected in the Show In group in its definition in Defaults to appear in this list.)
3. ArtiosCAD opens the Select Parts dialog box.
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ArtiosCAD selects all Production-type parts by default. Click a part name to see its preview.

4. To change the order in which ArtiosCAD processes Production and non-Production parts, drag a
desired part and drop it below another part. To save the Output order in the workspace for future
use, click Save Part Order.
 

 
5. Select the parts to include in the Output and click OK.
6. Click OK to confirm running the Output.
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Shown below are the individual files for each Part in Windows Explorer.
 

 

Reports around canvas layouts

Reports around canvas parts use geometry macros to add information about a layout part to the
canvas. See Outputs > Artios > Canvas > Report Around Canvas Part for an example.
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To use this Output, do the following:

1. Make a Layout part the active part and do everything needed to consider it done.
2. Run the Output.
3. Answer any prompted variable prompts.
4. ArtiosCAD creates the Report around the Layout part.

Deleting a Report Around a Layout Part
There are two ways to delete a Report Around a Layout Part:

1. Right-click the layout in the Parts List and click Delete Layout Annotation on the context menu.
2. Open the Sheet Properties dialog box for the layout and click Delete Layout Annotation.

Notes about Reports Around Canvas Parts

General Notes
If the Report overlaps other parts, drag the Layout part by its title bar to reposition it. If you turn off
jobs, the automatic movement ArtiosCAD performs when turning jobs back on takes Reports into
account.

You can have more than one Layout report in a canvas. All Reports go into the same Annotation layer.
The sample Report makes a layer called Estimating Info. If you create your own Report, you can name
the layer as desired.

You can run Reports of this type on Production or Hardware parts, but there will be no sheet
information, and geometry tools are not available in hardware parts.

ArtiosCAD does not update in-place Reports automatically. Delete the existing one and re-run the
Output if you change the Layout and need to update the information in the Report.

ArtiosCAD expands the Report if needed to fit around the Layout part, but does not shrink it if the
Layout part is smaller than the File Window defined on the Report.

ArtiosCAD deletes the Report when you recalculate or rebuild the layout. Run the Output at the end of
your workflow.

Double knife removal is not available for canvas layouts. To remove double knives, convert the layout
to Manufacturing and remove them there. If you want to put the rule length after double knife removal
on the Report, consider using an expression like LENTYPE(1) - #DKNIFE.as the value for a piece of
calculated text.

Exporting parts with a Report
ArtiosCAD does not export sheet dimensions or Reports around a canvas part when you convert to
Manufacturing.

If you save the part as a single design, ArtiosCAD does include the associated Report, and you can re-
run the Output in it if you change the design.

To export Report data as XML, set the Output Type group to Bill of Materials, enable Parts Outputs
in the Show In group, and set the Processing group to XML on the Project-Bill of Materials tab of the
Output definition.
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Creating your own Report Around a Canvas Part
To understand how to make your own Report to put around a canvas part, use ..\InstLib
\ReportAroundPart.ARD as a guide.

1. Create a single design workspace and create borders and separators with annotation lines.
2.

 Use File Window on the Reports toolbar to add a file window of type Design and set the Scale
to Scale report around canvas part.

3. You may also add file windows of type Symbol as desired. Symbol file windows copy different
workspaces into the file window based on an expression. Read more about Symbol file windows in
Using a Symbol file window on page 1989 earlier in this chapter.
a) Some sample expressions are listed below. In order to have an empty Symbol window for a

particular case, you need to have a blank workspace for ArtiosCAD to copy into the window.

Options Description

GRAIN=2 Horizontal grain; use GRAINHOR.ARD

GRAIN=1 Vertical grain; use GRAINVER.ARD

SIDE<0 Outside side; use SIDEPRINTED.ARD

SIDE>0 Inside side; use SIDEUNPRINTED.ARD

CAL=0 Board caliper is 0, indicating a part has no
board

4. Add prompted text, calculated text, and prompted userfields as desired.
a) Some calculated text has different meanings depending on which type of part is active.

Calculated text Production part Layout part

Area Part area Total area of the parts

Waste on blank Blank size minus part area as
a percentage

Sheet size minus total area of
the parts, as a percentage

Blank size Blank size of this part Total blank size of the layout
(not the sheet)

Rule length Rule length of this part Total rule length in the layout

L, W, D L, W, D for this part L, W, D if all the parts in the
layout have the same value,
else blank

Board Part board Layout board

Part name Part name Layout part name

b) Layout and sheet size calculated text only work for layout parts, not production parts.

Calculated text System variable Notes

Layout size X #CUTSIZEX
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Calculated text System variable Notes

Layout size Y #CUTSIZEY

Sheet size X #SHTSIZEX

Sheet size Y #SHTSIZEY

Sheet size with grain #SHTSIZEWG

Sheet size cross grain #SHTSIZEXG

Sheet margins, trim #SHTMARL … #SHTTRIMB See Useful variables for sheet
dimensions on page 1265

Length of double lines #DKNIFE Can be subtracted from the
total length

Number up #NUP Total number of designs on
the sheet

5. When you are done designing your Report, you should have something like this. Save it and copy it
to ServerLib.
 

 
6. Add it to the Report Catalog if desired.
7. Create an Output for it using these settings:

On the Output Type tab:

• Type: Plot.
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• Scale: 1

• Show in: At least Outputs and Parts Outputs. It must have a file window that is scaled around a
part to appear in Parts Outputs.

On the Device tab:

• Driver type: Workspace layer

• Layer name: anything, just not blank

On the Report tab:

• Enable Use Report

• Either select it from the Report Catalog or enter its filename in Report File Name.
8. Click OK to finish defining the Output.
9. Save and exit Defaults. You are now ready to use your Report.

Assembly Instructions Outputs

Use a normal Plot output for Assembly Instructions. ArtiosCAD prints each instruction page on a
separate page of the Output.

Making a Header/Footer Report for Assembly Instructions

1. Create a Report with the desired prompted and calculated information. Size it to fit the intended
size of your Assembly Instructions.
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2. Make an Output using this Report and on the Device tab of the Output, set it to Workspace Layer

and specify a name for the layer in the Layer Name field.

Using the Header/Footer Report for Assembly Instructions

1. Open the single design with the relevant information.
2. Run the Output you created.
3. Turn on the layer containing the Output. Turn off the other layers if they do not automatically turn

off.
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4. Copy everything to the Windows Clipboard using CTRL-C.
5. Close this design.
6. Make a new single design for the Assembly Instructions.
7.

 Use Add Instruction Page to add some instruction pages.
8. Use CTRL-V to paste in the contents of the Windows Clipboard. In the Distribution dialog box,

select Copy into the current layer and click OK.
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9. ArtiosCAD inserts the header and footer.

 

 
10.

 Select the items to repeat across the pages and click Repeat in Instruction Panel or Page.
11.

  Use Add Instruction Panel or Add Instruction Grid to add instruction panels.
12. Use the normal Assembly Instructions workflow to populate the panels.
13. Run the desired printer Output.
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16.  DataCenter for Standard Edition

Introduction to DataCenter

DataCenter is a program which makes finding specific information about ArtiosCAD designs quick
and easy. As you work, DataCenter automatically records facts about every single design and every
manufacturing file you create or modify.

Note:  DataCenter only works with ArtiosCAD Standard Edition. It is not installed with
ArtiosCAD Enterprise. If you are using ArtiosCAD Enterprise, please ignore this chapter.

DataCenter has two intertwined parts – the information-gathering engine in ArtiosCAD and the
browsers in which the information is viewed. The engine sends information to a database using MSDE,
Microsoft SQL Server, SQL Server Express Edition, or Oracle.

Within ArtiosCAD, you can search for single designs and manufacturing files, as well as viewing
information for embedded designs in manufacturing files. Other browsers, for information such as
board codes, customers, userfields, and so forth are contained within the DataCenter Admin program
in the Esko > ArtiosCAD program group.

Concepts and Ideas in DataCenter

Browsers

There are fifteen main areas of DataCenter called browsers that display information. They are:

• The Design browser (in ArtiosCAD)
• The Manufacturing browser (in ArtiosCAD)
• The Embedded Design browser (designs saved in manufacturing files, shown on a per-

manufacturing file basis in ArtiosCAD)
• The Projects browser (in ArtiosCAD)
• The Auto-Number browser (in DataCenter Admin)
• The Board browser (in DataCenter Admin)
• The Characteristics browser (in DataCenter Admin).
• The Company browser (in DataCenter Admin)
• The Company Type browser (in DataCenter Admin)
• The Counter browser (in DataCenter Admin)
• The Person browser (in DataCenter Admin)
• The Resource browser (in DataCenter Admin)
• The Server browser (in DataCenter Admin)
• The Userfield browser (in DataCenter Admin; requires Information Enhancement module)
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• The Restricted Userfield Set browser (in DataCenter Admin)

Note:  For the browsers In ArtiosCAD, in Defaults > Design defaults > Database, Limit
database browser results to controls how many records ArtiosCAD loads into the browsers by
default. This is meant to avoid performance degradation for large databases. We encourage
you to search for results rather than scrolling through the available entries

Viewing database information

In ArtiosCAD, to view all the single designs or manufacturing files in the database without searching for
them, open the appropriate browser from the Database > Browsers menu.

The browser windows are independent of the main ArtiosCAD window.

To view all non-design information, open DataCenter Admin in the ArtiosCAD program folder or on the
desktop.

Sorting the list of information
All browsers except for Characteristics show a list of items in the database that can be sorted by
column. To sort the information, click the button with the column name at the top of each column.
Successive clicks of the same button change the sort order from ascending to descending and vice-
versa.
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Selecting an item from the list and viewing its information
Double-click an item in the list to select it and view its details. The clicked item’s information will
appear beneath the list. Select more than one item by holding down CTRL and clicking the desired
items.

The details area of the window usually has more than one tab. Switch to a different tab by clicking it.
Shown below is the Design browser in ArtiosCAD.
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When one canvas is selected in the browser, the Parts tab shows parts, their filenames (if they have
been saved as independent workspaces), their revision, and the location in which they are saved.
 

 
Click Show Design File to show the design file alone in the browser. In that browser, the Canvases tab
shows which canvases use the design. Likewise, Show Canvas shows the selected canvas.
 

 

2092



16ArtiosCAD

Shown below is the Manufacturing browser in ArtiosCAD showing the details for the selected
manufacturing file.

Shown below is the Embedded Design browser in ArtiosCAD showing the details for the selected item.
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Shown below is the Company browser in DataCenter Admin showing the details for the selected item.

 To view specific information for a field, click Show Item Details. A dialog box appears showing
details for the selected item. Click Cancel to close the dialog box.

2094



16ArtiosCAD

The toolbars

Each browser in ArtiosCAD has a unique toolbar, while the browsers in DataCenter Admin share the
same toolbar.

Toolbars in ArtiosCAD Browsers
Shown below is the Design browser toolbar.
 

 

Shown below is the Manufacturing browser toolbar.
 

 

Shown below is the Embedded Design browser toolbar.
 

 

In the Design browser, the first three buttons control what types of designs the browser shows.
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 Show Design Files shows single designs.

 Show Canvas Files shows canvases.

 Show Parts Files shows parts.

At least one of these three buttons must be selected.

 Clicking Print prints a report for the current browser.

 Find Associated Design File in the Embedded Designs browser finds the non-embedded version
of the design.

 Show Associated Canvas Files shows the canvases containing the selected part. Only one
record may be selected when using this feature.

 Show Associated Manufacturing Files shows the manufacturing files containing an embedded
copy of the selected design. Only one record may be selected when using this feature.

 Edit Search Criteria opens the Search dialog box so that you can refine the search results.

 Refresh Browser reloads the browser after clearing any search criteria.

 Show Details toggles the display of the details area beneath the browser window.

 Open file opens the selected file(s) in ArtiosCAD.

 Move/Copy to New Resource opens the Copy/Move Item(s) dialog box, which lets you copy or
move the current selection to a new resource.
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Specify the new resource in the Specify New Resource: drop-down list box. To overwrite files in the
new resource without being prompted for each file, check the Automatically Overwrite checkbox.
Update Projects prevents accidentally losing Project data when moving items between resources.

Note:  Remember to back up your database regularly. Restoring it is the only way to recover
from making such a mistake with Project data.

In the Designation group, choose to Move or Copy. If moving, check the Delete Original Disk File
checkbox to remove the original file, leaving just the file(s) in the new resource. Click OK to perform the
move or copy, or Cancel to return to the browser.

 Delete deletes the current selection. When clicked, you are prompted to choose whether to
delete both the database record and associated ArtiosCAD file or just the database record as shown
below. Choose the desired option button and click OK to delete or Cancel to return to the browser with
no deletion.

 Units changes the units between imperial and metric.

Toolbar in DataCenter Admin
Shown below is the toolbar in DataCenter Admin.

 Refresh resets the search criteria and reloads the browser.
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 Details toggles the display of details for the selected item(s).

 Reports prints a report of the information in the current browser, or, if more than one item is
selected, asks if the report is to encompass just the selected records or the entire browser.

 Insert New Record adds a new record to the current browser.

 Delete deletes the currently selected records. It is available only when there is a current selection.
You are asked to confirm the deletion before it takes place.

Searching for information

A database is only as good as the information in it. To be useful, that information must be easy to
retrieve. To retrieve the information quickly and easily, use the Search command on the File menu in
ArtiosCAD.

Shown below is the Search dialog box.
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To search for information, do the following:

1. Start ArtiosCAD, and click File > Search to open the Search dialog box.
2. Select Designs or Manufacturing files in the Search For: group.
3. In the What field, choose the kind of data to use as search criteria.

Characteristics are attributes assigned to the design, such as the style of container, or its intended
usage.

Design Information is information such as resource name, owner name, width, and so on. This
option is unavailable when searching for manufacturing files.

Userfields are customizable variables whose values are saved in a single design or manufacturing
file.

4. The option button selected in the What field controls the appearance of the rest of the Search
Criteria group.

When it is set to Characteristics, the Characteristic tree appears, as do the Characteristic Finder
button and the Contains All and Contains Any option buttons. As manufacturing files do not use
characteristics, this option is unavailable when searching for them.
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The Characteristics tree shows data hierarchically for easy categorization. Check the checkboxes
for characteristics to search for. Contains All searches for single designs or manufacturing files
which have all the selected characteristics defined. Contains Any searches for single designs or
manufacturing files which have at least one of the selected characteristics.

The Characteristics Finder is described later in this chapter.

When the option button in the What field is set to Design Information or Userfields, the Where,
How, and Value fields appear. The How field appears after the Where field is set, and the Value field
appears after the How field is set.

In the Where field, choose the type of item to search for.
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For text items, in the How field, choose Equals to set the Value using something already in the
database. Choose Begins With to match items that begin with the text you enter. Choose Contains
to type a custom value.

For numeric selections in the Where field, >= (greater than or equal to), <= (less than or equal to),
and Is Between are available in the How field. When using Is Between, enter the lower limit in the
From field and the higher limit in the To field.

In the Value field, either choose an item from the dropdown list (if Equals is selected in the How
field) or type the desired information to search for (if Contains is selected in the How field).
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5. Once all the fields have values entered, you can Search or click Add Additional Criteria to add more
search conditions. Add the new search conditions just as you created the first set, making sure to
click Add Additional Criteria after choosing the last set to add it to the criteria list. To delete a set
of criteria, select it and click Delete.

Once you are satisfied with all the search criteria, click Search. The Design Browser or the
Manufacturing Browser appears containing the results of the search.
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You can return to the Search dialog box by clicking the Search button on the browser toolbar.

Servers and resources

A fundamental concept of DataCenter is the idea of resources and servers. Each resource tracks all the
files in one directory. To track the files in a directory in the database, a resource needs to be created.
Resources will automatically be created for files placed in any subdirectory of a master resource. The
directory for each resource is defined relative to locations called servers. A server is typically a hard
drive.

For the beginner, Esko recommends setting up one master resource per server. Master resources
make resources for each subdirectory created inside them after they are designated as master
resources. This ensures that all designs are tracked in the database. If you set up multiple regular
resources and have no master resource, and someone creates a new directory but does not create a
resource to go along with that directory, any work saved in that directory will not be tracked.

When you load ArtiosCAD for the first time, a database server is created for the drive ArtiosCAD is
loaded on, and a master resource is created for the default file-saving location (e.g. \Esko\Artios
\Designs). In this manner, all work that you save in the default directories is tracked in the database.
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Any subdirectories made under the master resource will have resources created automatically, so the
work saved in those directories will be tracked in the database. If you install ArtiosCAD yourself, the
database server and resource are set to the drive and user directory you specified while loading.

Configuring DataCenter

When you start using DataCenter with ArtiosCAD, only the work saved under the \Users or \Esko
\Artios\Designs directory is saved into the database by default. If you create new directories on
drives other than where you installed ArtiosCAD, and want DataCenter to track the work you save in
those directories, you have to create a database server for that drive in DataCenter Admin as well as
resources for those directories.

All configuration is done in the DataCenter Admin program in the ArtiosCAD program folder.

Working with servers and resources

As explained earlier in this chapter, servers and resources are the places on your computer where you
store work done in ArtiosCAD.

You must create database servers before configuring resources.

Creating a server
To create a database server, do the following:

1. Share the drive or directory you wish to be a database server.
2. Start DataCenter Admin.
3. Double-click the Server browser entry to open it.
4.

 Click Insert New Record on the toolbar.
5. Enter the name of the new server in the Name: field.
6. Click in the Path: field and type the UNC locator for that drive, or click the Browse button to

navigate to the proper directory. If you type the entry, make sure to enter it correctly as no error-
checking is done for typed entries.
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7. Choose the drive or directory to be the new server and click OK.
8. Click Insert to add the new server or click Cancel to cancel.
9. Exit the Server Browser, if desired, by closing its window.

Creating a resource
To create a resource, do the following:

1. Start DataCenter Admin.
2. Double-click the Resource browser entry to open it.
3.

 Click Insert New Record on the toolbar.
4. Enter a name for the resource in the Name field.
5. Click in the Server: field and select the server for the new resource from the drop-down list.
6. Click in the Directory: field and either type the directory name or click the Browse button and select

the directory for the new resource. If you type the entry, make sure to enter it correctly as no error-
checking is performed for typed entries.
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7. Once you have selected the desired directory, click OK.
8. To create the new resource, click Insert; to cancel its creation, click Cancel.
9. Exit the Resource Browser, if desired, by closing its window.

It is prudent to leave the Master checkbox checked when creating a resource. This ensures that all new
work in any subdirectories that may be created will be tracked. The Active checkbox specifies whether
DataCenter tracks the work saved in the resource. Inherit Auto-Number controls whether or not the
resource will use Auto-Numbering if its parent resource uses it.

Deleting a server
You cannot delete servers containing resources. If a server has resources in it, you must either delete
them or change the server they reference. Also, when you delete a server, only the information in the
database is deleted. The actual designs are not deleted.

To delete a server, do the following:

1. Start DataCenter Admin.
2. Double-click the Server browser to open it.
3. Select the server to delete.
4.

 Click Delete.
5. If you really want to delete the server, click Yes when asked.
6. The server entry will be deleted. If the server still contains resources, you will be told that servers

cannot be deleted which contain resources. You will have to delete the resources and then try
again.

Deleting a resource
When you delete a resource, the ArtiosCAD workspaces stored within them are also deleted. Use this
procedure with great caution.

To delete a resource, do the following:
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1. Start DataCenter Admin.
2. Double-click the Resource browser to open it.
3. Select the resource to delete.
4.

 Click Delete.
5. Click Yes to delete the resource. If there are files in the resource, DataCenter Admin asks you to

confirm the deletion. Click Yes.
6. The resource is deleted.

Userfields

Userfields are customizable fields for designs and manufacturing files that can contain almost any kind
of information.

Userfields:

• Can contain text, integers, decimal numbers (called floats), distances, areas, volumes, or weights.

• Are specific to the type of workspace; design userfields cannot be used in manufacturing files, and
vice-versa.

• Can be included on reports.

• Can have their values restricted to a list defined in the Restricted Userfield Set browser.

For designs, 36 userfields come pre-created in DataCenter. There are no pre-made userfields for
manufacturing files.

When you make your own userfields, you can specify that they are required userfields. Required
userfields are stored automatically in each workspace. For example, if you have a piece of information
you want stored in every single design you make, you can add a required userfield via the Userfield
browser in DataCenter Admin. The information contained in the userfield will be saved in each
workspace; you cannot change the value of a required userfield in a workspace.

There are four steps to using userfields.

1. Tell DataCenter which userfields to track. You can immediately start using the pre-created
userfields.

2. Configure restricted sets if desired.
3. Set values for specific userfields in designs or manufacturing files.
4. Set up formulae to automatically set values for userfields when they are added to designs or

manufacturing files.

Adding userfields to DataCenter
To add userfields to DataCenter, do the following:

1. Start DataCenter Admin.
2. Open the Userfields folder if necessary and double-click the Userfield browser to open it.
3.

 Click Insert New Record. The Details tab appears in the browser as shown below.
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4. Choose the appropriate type of userfield in the Category field.
5. Enter an identification number for the userfield in the Userfield ID field. This can be any number.
6. To have this userfield present in every design or manufacturing file, check the Required checkbox.
7. Enter a name for the userfield in the Name field.
8. Choose the type of userfield from the Format drop-down list box.
9. Choose the way the userfield value is supplied. To enter a value for the userfield every time it is

used, select the Prompted option button.

To have it supplied by ArtiosCAD automatically, select Calculated Expression and enter the
expression in the associated field. Use this method for setting a default value for the userfield -
just enter the desired value in the field without using variables. If entering a text item, enclose it in
quotes to prevent ArtiosCAD from treating it as variables.

To have it use a Restricted Set, select Restricted Set and choose the set from the drop-down list
box. (You must have a restricted set already defined in the Restricted Userfield Set browser.)

10. Click Insert to insert the new record into the database.

Setting up a restricted userfield
Restricted userfields are userfields that have a set range of values from which you can choose when
setting them. These sets of values are configured in the Restricted Userfield Set browser. Sets of
values can be used with as many userfields as desired.

To configure a restricted set, do the following:

1. Start DataCenter Admin.
2. Open the Userfields folder if necessary and double-click the Restricted Userfield Set browser to

open it. It contains no data by default, so when it is opened for the first time, it is as if Insert New
Record was clicked.
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3.
 If there are already restricted sets configured, click Insert New Record.

4. Enter a name for the set in the Name field.
5. Set its format using the Format drop-down list box. Make sure it is the same format as its

corresponding userfield(s); for example, sets of type INTEGER cannot be used with userfields of
type FLOAT.

6. Enter the first value for the set in the field above Add. It will appear in the Values list. Continue
adding values by entering them in the field and clicking Add. To reorder them, select a value and use
the directional arrows to change its position in the list.

7. When done entering values, click Insert to insert the record into the database.

Deleting userfields from DataCenter
To delete userfields, do the following:

1. Start DataCenter Admin.
2. Open the Userfields folder if necessary and double-click the Userfield browser to open it.
3. Select the userfield to delete.

2109



16 ArtiosCAD

4.
 Click Delete.

5. You are asked to confirm the deletion of the userfield. Click OK if you really want to delete it;
otherwise, click Cancel.

Configuring companies

The Company browser manipulates information about companies. No companies are defined by
default.

Adding a company
To add a company, do the following:

1. Start DataCenter Admin.
2. Double-click the Company browser to open it.
3.

 Click Insert New Record on the toolbar.
4. Enter the information for the company in the appropriate fields. The Number: field is optional and is

text only; it is not calculated.
5. Click Insert.

To add more companies, repeat steps 3 through 5.

You may also add a company when saving a design by clicking New in the Customer Browse dialog box.
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Deleting a company
To delete a company, do the following:

1. Start DataCenter Admin.
2. Double-click the Company browser to open it.
3. Select the company to delete.
4.

 Click Delete.
5. Click Yes to confirm the deletion.
6. If the company name is used in any design, you are prompted to Replace it with another, Clear it

from the affected record(s), or Cancel the operation. If you are deleting more than one company at
once, you can also replace all the companies with one by choosing Replace All.

To delete more companies, repeat steps 3 through 5.

Changing how company identifiers are shown
On the Options menu, you can choose different ways for how company identifiers are shown in
DataCenter Admin.

Choose Name, Number, Name, Number, or Number, Name as desired.

Configuring company types

The Company Type browser lets you add and remove company types. Company types are used in
company definitions. Examples of company types are Converter, Diemaker, and End user.

Adding a company type
To add a company type, do the following:

1. Start DataCenter Admin.
2. Open the Company Type browser by double-clicking it.
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3.
 Click Insert New Record.

4. Enter a unique code and a description for the company type in the appropriate fields.
5. Click Insert.

Deleting a company type
To delete a company type from the database, do the following:

1. Start DataCenter Admin.
2. Open the Company Type browser by double-clicking it.
3. Select the company type to delete.
4.

 Click Delete.
5. Click Yes to confirm the deletion.
6. If the company type is in use, you are prompted to Replace it with another, Clear it from the

affected record(s), or Cancel the operation. If you are deleting more than one company type at once,
you can also replace all the company types with one by choosing Replace All.

To delete more company types from the database, repeat steps 3 through 5.

Configuring people

DataCenter tracks salespeople and designers as well as design information. Information about people
is stored in the Person browser.

Adding a person
To add a person’s information to DataCenter, do the following:

1. Start DataCenter Admin.
2. Open the Person browser by double-clicking it.
3.

 Click Insert New Record.
4. Enter the information about that person in the appropriate fields.
5. Click Insert.

Deleting a person’s information
To delete a person’s information from the database, do the following:

1. Start DataCenter Admin.
2. Open the Person browser by double-clicking it.
3. Select the person whose information is to be deleted.
4.

 Click Delete.
5. Click Yes to confirm the deletion.
6. If the person’s information is used in any design, you are prompted to Replace it with another, Clear

it from the affected record(s), or Cancel the operation. If you are deleting more than one person’s
information at once, you can also replace all the people with one person by choosing Replace All.
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To delete information about more people from the database, repeat steps 3 through 5.

Configuring board information

ArtiosCAD gets all information about boards from DataCenter, so it is important that the Flute and
Board browsers contain accurate information. Papers and flutes must be defined prior to trying to use
them to define corrugated boards.

Boards are hierarchical; that is, they may be organized in a hierarchy of folders for more effective
organization and easier access.

If this installation of ArtiosCAD is an upgrade from a previous version, the old board table is converted
to the new hierarchical format during the upgrade, and new boards are added. New boards in the Artios
folder hierarchy will not replace previously-existing boards with the same name and description; those
will remain in the top-level Corrugated and Folding Carton folders.

AutoLoad does not rebuild 3D or paper information for boards. In the event of a database malfunction,
this information can come either from a database backup that is restored through DataCenter Admin,
or by using the ArtiosCAD Database Export and Import utilities to export and import the board table.

Your board browser may look different depending on if you loaded ArtiosCAD as a new installation or if
you upgraded a previous installation. Shown below is an example Board browser for a new installation:
 

 

Shown below is an example Board browser for an upgraded system.
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Corrugated board is built from wavy (corrugated) paper glued to flat paper. The flat paper is called a
liner, and the wavy paper is called a medium. The medium is defined in terms of a flute, a letter code
generally from A to F, with A being the thickest/largest and F being the smallest/thinnest.

Folding carton board is one layer of material, usually made from paper that is Solid Bleached Sulfate or
White Clay Coated.

Because texture and paper information is stored in the database, it is important to back up the
database as board information changes, because complete board information cannot be recreated
only by using AutoLoad. For more information about backing up an MSDE or SQL Server Express Edition
database, see the Other Tasks chapter.

Creating a paper
To create a new paper, first examine an existing paper to determine what information you will need to
define the new paper. Usually the caliper, inside loss, outside gain, rounding value, basis weight, and
basis cost are needed. You may also set inside and outside colors and other appearance attributes to
the paper that appear in the optional 3D module.

To create a new paper, do the following:
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1. Start DataCenter Admin.
2. Open the Boards browser, and then open the Artios catalog by clicking the plus sign (+) next to it.
3. Click the word Papers to select it.
4.

 Click Insert New Record, or right-click and click New  >  Board. The Details pane will
automatically appear with the fields enabled for editing.

5. Enter values in the fields on the Details tab as appropriate.

Board Code: is the identifier used by the database to identify this new paper; each paper must have
a unique code.

Description: is the description of the paper.

Caliper: is the thickness of the paper.

Inside Loss: and Outside Gain: are the allowances used when folding the paper or when gluing it
together (such as in a glue flap). They are generally half the caliper.
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Rounding Value: sets a value to which dimensions may be set to round to when constructing a
corrugated design. It is more relevant for boards as a whole rather than individual papers.

Basis Weight: is the weight of the paper in local currency and units of measurement.

Basis Cost: is the cost of the paper in local currency and units of measurement.

Test Value: is the amount of weight needed to break the material when performing very specific
standardized tests. It is more relevant for corrugated boards as a whole than individual papers.

Test Code: is the identifier used in correlation with the Test Value to show the strength of the
paper. It is more relevant for corrugated boards than individual papers.

Weight: and Cost: in the Adhesive group should be set for the complete board definition, not
individual paper and flute definitions.

6. Leave the fields on the Papers tab blank, as they are not relevant.
7. On the Material Properties tab are fields to set the shininess, transparency, and inside and outside

colors of the paper. These properties are only visible in the optional 3D module.
 

 

Set the Shininess% and Transparency% fields as desired. The Transparency% field is a separate
setting from transparency mode in 3D and is not affected by that setting.

Surface colors for papers are split into three components: ambient color, which reflects the
ambient light; diffuse color, which reflects the movable lights in an airy, non-shiny way; and
specular color, which reflects movable lights for a shiny surface, with a shiny surface having a white
specular color and a dull surface a black specular color.

By default, the Material Properties tab only displays Diffuse color in Simple color mode. In Simple
color mode, choose a color by clicking Select color. To set the other two colors, click Advanced
color, and then click Select color as desired.

Note:  DataCenter Admin only uses color palettes from Shared Defaults. It does not use any
color palettes from User Defaults.
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The outermost Outside paper color is used to set the Outside board color if no other color has been
manually chosen for the outside of the board. Likewise, the innermost Inside paper color is used to
set the Inside board color if no other color has been manually chosen for the inside of the board.

The ... button (Browse) is used in board definitions to calculate the color based on the materials
comprising the board. It is not relevant for papers.

8. On the Texture tab are fields to specify the graphics that may be used to represent the inside,
outside, and edge textures of the paper. These properties are only visible in the optional 3D module.
Outside and inside textures are more relevant for boards, but may also be defined for papers, while
board edge textures do not apply to papers.

To add an inside or outside texture to the paper, click the checkbox for it, and then specify the
filename of the graphic file for the texture, or click ... (Browse) to the right of the filename field and
select it. Some common textures are stored in \Esko\Artios\Common. The image should be of the
board surface with vertical grain or corrugation direction. If you use a custom image, measure the
sample when you take its picture so that you know its size; you may need to touch up the image in a
graphic editing program so that the edges blend together when the image is tiled.

In the Image height: field, enter the height of the image. The size needs to be set in order for
ArtiosCAD to scale the picture appropriately. If the height is set to 0, the image will be scaled
proportional to the width.

Set the value in the Image width as number of flutes: drop-down list box to the number of flutes
the image represents. The image should be of a whole number of flutes. It may also be set to
Proportional to height, in which case the height cannot be set to 0.

Shown below is \Esko\Artios\Common\boardbrown.jpg, an example board texture three flutes
wide:
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9. When you have finished defining the paper, click Insert to add the new paper definition to the
database.

Note:  Foams are defined in the same way as papers, just with larger dimensions.

Creating a flute
A flute is the wavy paper that provides strength to corrugated board. A flute is defined by four pieces of
information:

• A unique code to identify the flute. This code must be less than four characters long.

• The flute pitch, which is the distance between the lowest parts of the wave. The pitch must be
greater than 0.

• The flute height. The height must be greater than 0.

• The take-up factor, which is the ratio between the length of the fluted paper and the length of the
board. If the flute were stretched out, it would always be longer than the paper encasing it. The
take-up factor must be greater than 1.

To create a new flute, do the following:

1. Start DataCenter Admin.
2. Open the Flute browser by double-clicking it.
3.

 Click Insert New Record. The Details pane will automatically appear with the fields enabled for
editing.

4. Enter the new flute’s code, height, pitch, and take-up factor in the appropriate fields as shown
below.
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5. Click Insert to add the new flute definition to the database.

Creating a board
To create a board, do the following:

1. Start DataCenter Admin.
2. Open the Board browser by double-clicking it.
3. Boards are hierarchical. Right-click an item a level above the desired level for the new board (such

as Boards to add the new board at the top level or Artios > Corrugated > C to add a new C flute
board) and click New > Board. (You may also create a new folder in this manner.)

 You may also select the parent item and then click Insert New Record to create a new board.
To create a new folder, you must use the right-click method described above.

The Details pane will automatically appear with the fields enabled for editing.
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4. Enter values in the fields on the Details tab as appropriate.

Board Code: is the identifier used by the database to identify this new board; each board must have
a unique code.

Description: is the description of the board.

Caliper: is the thickness of the board.

Inside Loss: and Outside Gain: are the allowances used when folding the board or when gluing it
together (such as in a glue flap). They are generally half the caliper.

Rounding Value: sets a value to which dimensions may be defined to round to when constructing
a corrugated design, such as the nearest 1/64” (0.015625). This is variable CRRV in Advanced
StyleMaker and can be used in the Round to: field when defining a new variable.

Basis Weight: is the weight of the board in the selected system of units of measurement. Clicking
the ... (Browse) button at the end of the field displays the Calculated Basis Weight dialog box. In this
dialog box is an analysis of the calculated weight of the board based on the papers used to make it.
To replace a manually-entered weight with the calculated weight, click Accept.
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Basis Cost: is the cost of the board in local currency and units of measurement. As with the Basis
Weight: field, the ... (Browse) button at the end of the field displays an analysis of the calculated
cost of the board based on the papers used to make it. To replace a manually-entered cost with the
calculated cost, click Accept.

Test Value: is the amount of weight needed to break the material when performing very specific
standardized tests.

Test Code: is the identifier used in correlation with the Test Value to show the strength of the
paper.

The Weight: and Cost: fields in the Adhesive group are the respective weight and cost of the
adhesive for the board as a whole.

5. The Papers tab contains drop-down list boxes to select the liners and mediums that comprise the
board.

If you know it already, type the flute code of the new board in the Board Flute: field. At the end of
the field is a ... (Browse) button that opens the Calculated Flute dialog box. Use this to calculate the
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flute code after defining the liners and mediums for the board. If it is a single board, expect a flute
code like C. Double wall could be BC, while triple- and quadruple-wall would comprise four letters.

Boards are defined sequentially from the outside inward. For example, you must select Liner 2
before you may select Medium 2. You may not select Liner 2 and then jump directly to selecting
Liner 4.

Select liners and mediums in their respective drop-down list boxes. As you select a liner and then
a flute, the Flute drop-down list box for that pair becomes available. You must select a flute before
the next liner becomes available for selection.

Complete the paper selection process with a liner.
6. On the Material Properties tab are fields to set the shininess, transparency, and inside and outside

colors of the board. These properties are only visible in the optional 3D module.
 

 

Set the Shininess% and Transparency% fields as desired. The Transparency% field is a separate
setting from transparency mode in 3D and is not affected by that setting.

Surface colors for boards are split into three components: ambient color, which reflects the
ambient light; diffuse color, which reflects the movable lights in an airy, non-shiny way; and
specular color, which reflects movable lights for a shiny surface, with a shiny surface having a white
specular color and a dull surface a black specular color.

By default, the Material Properties tab only displays Diffuse color in Simple color mode. In Simple
color mode, choose a color by clicking Select color. To set the other two colors, click Advanced
color, and then click Select color as desired.

Note:  DataCenter Admin only uses color palettes from Shared Defaults. It does not use any
color palettes from User Defaults.

The outermost Outside paper color is used to set the Outside board color if no other color has been
manually chosen for the outside of the board. Likewise, the innermost Inside paper color is used to
set the Inside board color if no other color has been manually chosen for the inside of the board.
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The ... button (Browse) calculates the color based on the materials comprising the board. Click Yes
to use the color of the paper; click No to use the color of the current board definition.

7. On the Texture tab are fields to specify the graphics that may be used to represent the inside,
outside, and edge textures of the board. These properties are visible only in the optional 3D module.

To add an inside or outside texture to the board, click the checkbox for it, and then specify the
filename of the graphic file for the texture, or click ... (Browse) to the right of the filename field and
select it. Some common textures are stored in \Esko\Artios\Common. The image should be of the
board surface with vertical grain or corrugation direction.

In the Image height: field, enter the height of the image. You may have to use a separate graphic
editing program to determine the size of the picture. The size needs to be set in order for ArtiosCAD
to scale the picture appropriately. If the height is set to 0, the image will be scaled proportional to
the width.

Set the value in the Image width as number of flutes: drop-down list box to the number of flutes
the image represents. The image should be of a whole number of flutes. It may also be set to
Proportional to height, in which case the height cannot be set to 0.

If using a custom board edge texture on a double, triple, or quadruple wall board, the board edge
texture has to be a whole number of all the flutes. The largest flute is used initially, then the smaller
flutes are adjusted by a few percent to align a whole number of the smallest flutes with a whole
number of the largest flute. Knowing how many flutes the image represents is critical. To determine
this, start with the board defined but with no custom edge texture. Export the 3D workspace
to VRML and then view the associated PNG files created. One of those will be of the board edge
texture. Count the number of flutes for the largest board and set the Image width as number of
flutes: field to the same number.

Shown below is \Esko\Artios\Common\boardbrown.jpg, an example board texture three flutes
wide:
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To specify a graphic for the board edge texture, check the Board edge texture checkbox, then
specify the filename of the graphic file for the texture, or click ... (Browse) to the right of the
filename field and select it. Some common textures, for example paper corrugated edges, plastic
corrugated edges, and paper hexacomb flutes, are stored in \Esko\Artios\Common. The height
of the image for a corrugated board should be the board caliper, and the width should be a whole
number of flute pitches. Folding carton boards use an image width proportional to the height.

If no texture is specified for a corrugated board edge, a default picture based on the height and
pitch of the flutes is used.

Stretch like corrugations stretches the picture of the board edge texture depending on its angle
to the grain/corrugation direction. If this option is not selected, the board edge texture is repeated
evenly.

Shown below is a picture of the default board edge texture with Stretch Like Corrugations turned
on in a design in 3D:

Shown below is a picture of the BrownB board in the Textured Corrugated folder with Stretch Like
Corrugations turned off in a design in 3D:
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8. When you have finished defining the board, click Insert to add the new board definition to the
database.

Renaming, deleting, moving, and copying board entries
In addition to the standard ways of manipulating entries in DataCenter Admin, the Board browser
supports multiple item selection, dragging and dropping of entries, cutting and pasting of entries, and
right-clicking entries to perform functions on the context menu.

To create a folder, select its parent item (the one a level above its desired position), right-click it, and
click New > Folder on the context menu. The folder name must be unique among same-level folders in
the same parent folder.

To rename a folder, select it, right-click it, click Rename on the context menu, enter the new name, and
press enter.

To delete a folder, first make sure it is empty, and then select it, right-click it, and click Delete on the
context menu. You may not delete a non-empty folder.

To rename a board, edit it and change its description. This change will not be communicated back into
workspaces using this board.

Boards may not be deleted if they are in use. You may replace the board definition in affected designs
with another, clear the board information in those designs, or cancel the deletion.

To move a folder or a board, drag it from one location to another.

To copy a board definition, select it, right-click it, and click Copy on the context menu. Right-click the
folder into which it will be pasted and click Paste on the context menu. When the board is pasted into
the new folder, the current system time will be appended to the board code to maintain board code
uniqueness.

Configuring characteristics

Characteristics provide a way to describe the type of box referenced by an entry in the Design browser.
Designs can have more than one characteristic, such as Autobottom and Tuck top. Characteristics are
comprised of a code, which is the internal name of the characteristic, and a description, which is what
is shown.
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Adding a characteristic
To add a characteristic, do the following:

1. Start DataCenter Admin.
2. Double-click the Characteristics browser to open it.
3.

 Select the characteristic to add the new characteristic under and click Insert New Record.
4. Enter the code for the new characteristic in the Code: field.
5. Enter a description of the new characteristic in the Description: field.
6. Click Insert.

There are additional characteristics available beyond those shipped by default. See Installing additional
characteristics later in this section.

Deleting a characteristic
To delete a characteristic, do the following:

1. Start DataCenter Admin.
2. Double-click the Characteristics browser to open it.
3.

 Click Delete.
4. Click OK when asked to confirm the deletion. Deleting the characteristic from the database will also

delete it from all files containing it.
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Assigning characteristics is described in the Using DataCenter section.

Configuring Design Auto Numbering

You can configure ArtiosCAD and DataCenter to use an automatic file numbering scheme for designs
and manufacturing files. First you create a filename counter that will increment by one, and then
you link that counter to a resource. Once that information is saved in DataCenter, when you use that
resource in ArtiosCAD, you can use the Save Next Name button to automatically save the file with the
next available number.

Each resource can have one counter for designs and one counter for manufacturing files. However,
each counter can be used in more than one resource. The counter will span resources. For example,
if two resources, MBC Plant 1 and MBC Plant 2, use the same counter, auto-saving a file in MBC Plant
1 will cause the next file auto-saved in MBC Plant 2 to increment up a number from the name used in
MBC Plant 1.

Configuring a filename counter
To set up a filename counter, do the following.

1. Start DataCenter Admin.
2. Double-click the Counter browser to open it.
3.

 Click Insert New Record.
4. Enter the name of the filename counter in the Name: field, and enter the starting value for the

filename counter in the Value: field. The name should indicate the purpose of the counter.
5. Repeat steps 3 and 4 as desired.
6. Click Insert. When done, the Counter browser should look like the following picture (substituting the

data you entered):

Configuring Auto Numbering
Once the filename counters have been added, do the following to set up automatic numbering:

1. Start DataCenter Admin if it is not already open.
2. Double-click the Auto-Number browser to open it.
3.

 Click Insert New Record.
4. Click in the Resource field and choose the desired resource from the drop-down list box.
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5. In the File Type: field, choose either the Design or Manufacturing option button according to the
kind of file to use this auto-numbering.

6. Click in the Counter Name field and choose the desired counter from the drop-down list box.

7. Enter the number of digits of the counter in the Length field. Extra zeroes will be added to the
counter when a file is saved if the number of digits is smaller than specified here. If the counter
is set to start at 1, and the Counter Length is set to 4, the counter will start at 0001, go up to 0002,
0003, and so forth.

8. In the Prefix field, enter non-changing text to come before the auto-incrementing number. You can
leave this field empty if desired.

9. In the Sux field, enter non-changing text to follow the counter. You can leave this field empty as
desired.

10. Click Insert.
11. Repeat steps 3 through 10 as desired.
12. The Auto Numbering browser should look similar to the following picture (except that it will have the

data you entered in it). Both resources share the same counter.

Automatic design numbering is now fully configured and ready for use by clicking Save Next Name in
ArtiosCAD.
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Using the Project browser

Along with single designs, manufacturing files, and single designs embedded in manufacturing files,
there is a Project browser within ArtiosCAD that enables you to manage Projects separately from the
other commands on the Projects menu. To open the Project browser, click Projects > Project Browser.
Shown below is the Project browser with the Show Details toggle turned on and a Project selected.
 

 

Like the other database browsers, the first group of buttons along the top of the browser perform
actions on the currently-selected Project, while the panes along the bottom of the browser show
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information specific to that Project. The panes are only shown when Show Details mode is turned on
by clicking the magnifying glass icon on the toolbar.

Button Name Function

New Project Creates a new Project just as if you clicked the menu command.

Rename Project Renames the currently-selected Project as long as it is not open in
ArtiosCAD.

Copy Project Copies the currently-selected Project to a new Project using a
dialog box similar to the Create New Project dialog box. The Reset
Project document counter checkbox determines if the counter
(for auto-numbering purposes) is reset or not. ArtiosCAD copies
Project information, characteristics, userfields, and Project
documents to the new Project.

Open Project Opens the currently-selected Project in ArtiosCAD and makes the
ArtiosCAD window active.

Delete Selected
Item(s)

Deletes the currently-selected item(s).

Edit Search Criteria Searches all Projects with criteria you specify. See the section on
searching below.

Show Project
Documents

Lists all documents in this Project in the Design Browser.

Refresh Browser Re-queries the database and updates the list of Projects.

Toggle - Show
Details

Turns the information panes at the bottom of the browser on and
off.

 or

Units Changes the units of measurement between Imperial and metric.

To change information shown in one of the panes, as in the other database browsers, click Edit,
make the desired changes, and then click Save. You may need to click Refresh to see the updated
information.
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Project browser - General pane
The General pane of the Project browser shows basic information about the Project as shown below. All
of the fields are in read-only mode; to change them, click Edit beneath the pane.
 

 

 Refresh requeries the database for the information in that field in case someone else changed it
while you were looking at it.

 Show Item Details opens a dialog box which displays more information related to the associated
field. Click Cancel to return to the Project browser.
 

 

Project browser - Userfields pane
The userfields assigned to a Project are shown in the Userfields pane of the Project browser. You may
also add and remove userfields by using this pane as opposed to using the Project Information dialog
box. Shown below is an example Userfields pane.
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To add or remove userfields, click Edit beneath the pane, and then click Add or Delete (having first
selected a userfield in the list shown) as desired. When you are done making changes to the userfields,
click Save beneath the pane.

Refresh requeries the database and updates the list of userfields if anyone else has made changes to
them since you opened this pane.

Project browser - Documents pane
The Documents pane of the Project browser shows the documents included in the Project and lets you
organize how they appear on Bill of Materials Reports (BOM Reports).
 

 

To add or remove documents from the Project, click Edit beneath the pane, and then click Add or
Remove (having clicked to select at least one document beforehand) as desired. To include or exclude
documents on BOM Reports, check or clear their checkboxes before their names in the list. To change
the order in which documents appear on BOM Reports, select a document by clicking it and then click
the up or down arrow at the right edge of the dialog box as appropriate. You may also change the
Count as desired by clicking the up and down arrows next to the numeral in that field for a particular
document.

For more information about BOM Reports, see the Outputs chapter.

When you are done making changes to the documents, click Save beneath the pane to return to the
Project browser.

Project browser - Characteristics pane
In the Characteristics pane of the Project browser, ArtiosCAD shows the characteristics currently
assigned to the selected Project in the left side of the pane. You can also add and remove
characteristics to and from the Project.
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To add or remove characteristics, click Edit beneath the pane, and then select or deselect the desired
characteristics. When you have finished modifying the characteristics for the selected Project, click
Save beneath the pane to return to the Project browser.

Searching for Projects

 When you click Edit Search Criteria, the Search Projects dialog box appears as shown below
(with sample data; initially it is empty).
 

 

You can enter text to search on in each text field, but the Modified:, Customer:, Owner:, Salesperson:,
and Manager: fields all have drop-down list boxes containing cached entries from the database. All text
that you enter must use wildcards as explained below:

• * and % mean match all characters.
• ? and _ mean match one character.
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• To search on one of the wildcards, prefix it with a backslash ( \ ), such as “100\% Pure”.

• To search specifically on a backslash, enter “\\”.

Examples of using wildcards are shown in the following table.

Search term Search results

Project_1 All Projects starting with “Project” and then any single character
between t and 1, such as ProjectX1, Project$1, and so forth.

Project\_1 Project_1.

Project\_* All Projects starting with Project_, such as Project_1, Project_X, and
Project_5BD2.

Project\1 Project\1.

In any of the fields with a drop-down list box, if you enter text to search on using wildcards, ArtiosCAD
will:

• search by customer name for both the Customer: and Owner: fields.

• search by last/first/greeting names for the Salesperson: and Manager: fields. However, make sure
to use wildcards if you manually modify an entry in these fields, as ArtiosCAD will not analyze the
string to extract the first and last names separately. For example, if you select “Smith, John” from
one of the drop-down list boxes and then add an asterisk after John, forming “Smith, John*” as the
search string, ArtiosCAD will probably not find the desired result as it will not separate the words in
the search string since you manually changed it. However, were you to search on “Smith*” or “John*”
you would probably achieve the desired results.

To search on a userfield, do the following:

1. Click Userfields.
2. In the Project Userfields dialog box, select the userfield to search against.
3. Select the method to use for the pattern match in the How: field. For text userfields, use wildcards.

For numeric userfields, use =, <, and >. For restricted set userfields, only = is available, and then the
set of values becomes available in the Value: field.

4. Repeat steps 1-4 as desired to add more userfields to the search. Each userfield search argument
is connected with AND logic, so only Projects meeting all the Userfield conditions will be returned in
the search results.

5. Click OK to return to the Search Projects dialog box.

To search on Characteristics, do the following:

1. Click Characteristics.
2. In the Characteristics dialog box, select the desired characteristics to search against.
3. To find characteristics, click Find and perform the usual search for characteristics using the

Characteristics Finder. Once you have found and selected the desired characteristics, click OK to
return to the Set Characteristics dialog box.

4. Once you have set the characteristics to search against, click OK to return to the Search Projects
dialog box.

In the Search Projects dialog box, click Search to search against the criteria you have
entered.ArtiosCAD displays the results in the Project Browser.
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Clicking Clear in the Search Projects dialog box clears the fields in the dialog box but keeps any search
results.

To clear the search results and show the list of Projects again, click  (Edit Search Criteria), click
Clear, and click Search.

Modifying information in browsers

To change information in browsers, simply select the record to change, open the Details tab, and click
Edit.

For example, if you wanted to change the price of 200# B-flute board in inches, you would open the
Board browser, double-click the entry for I-200B in Artios > Corrugated Boards > B, click Edit, change
the information shown, and click Save.

Refreshing fields in browsers

As you change information in the browsers, the information they have cached in memory may not be
synchronized with the recent changes.

Click  Refresh to update the contents of the current field.

Customizing columns in DataCenter Admin

The Customize command on the Browsers menu in DataCenter Admin lets you choose the data shown
in the browser windows and also output on Reports.

Choose the browser to modify from the Browser: drop-down list box.
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Available columns which are not already shown in the browser are listed in the Available Columns
list. The columns currently shown in the browser are list in the Selected Columns list. To move items
between lists, select them and click either Add, Add All, or Remove as appropriate.

To change the order in which items are shown in the browser and on reports, select the item to move
and then use the direction buttons. The top item is shown at the left of the browser and the bottom
item is shown at the right of the browser.

Using DataCenter

Once DataCenter is configured to match your unique needs, it is easy to use. Two situations make up
the majority of times you use DataCenter: when saving designs or manufacturing files, and using the
browsers to view information.

Entering database information when saving in ArtiosCAD

When you save a design, ArtiosCAD automatically supplies DataCenter with some information about
the design, but you must specify other information such as the customer name and the designer.
Specify the customer, owner, salesperson, and designer for the design by clicking the arrow at the
end of the field and choosing an entry. When you are done specifying information, click OK to save the
database information and the design. Standard userfields are automatically saved with each design or
manufacturing file.

Shown below is the process of assigning customer information to a design using the default database
dialog box.
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You can enter anything you want in the Description and Authorization fields. The Description is limited
to 80 characters. Short Description 1 is shown under the design preview when opening the design
and is limited to 20 characters. To add a user field, click User Fields. (You must have purchased the
Information Enhancement module to access user fields.)

Choose a customer, owner, salesperson, and designer by selecting the appropriate entry from the
drop-down list box for each field. You can also search for specific information by clicking ... at the end
of those fields. Your database administrator may have disabled the drop-down list boxes, in which case
using the ... button is the only way to enter information in those fields.

To skip adding this file to the database, click Skip DB. This button may be disabled in Defaults. Even
when it is enabled, it is unavailable if a file with the same name already exists in the database to avoid
having a conflict between the file data and the database data.

If the design is not rebuildable and does not already have these variables assigned, you can enter the
length, width, and depth in the appropriate fields.

Your system administrator may have customized the database dialog box. For more information on
customizing database dialog boxes, see the Defaults chapter.

Setting values for userfields in designs or manufacturing files
The easiest way to set values for userfields in ArtiosCAD is by clicking User Fields in the Database
Information dialog box when saving a design or manufacturing file. You can also set them at any time in
ArtiosCAD by clicking Information on the Database menu and then clicking User Fields. You will arrive
at the same Set User Fields dialog box using either method.

To set a value for a userfield while in a design:

1. Use either of the methods described above to get to the Set User Fields dialog box.
2. Click Add to add a userfield and choose one from the list shown. Click OK after selecting the

userfield to add.

3. Enter the information you want the userfield to contain in the Current Value: field. In this example,
the text Send using priority overnight delivery! will be in the Ship Method userfield.
Click OK when you have entered the information.
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4. The userfield will be set to the value you specified.

Characteristics
The Characteristics button allows you to set the characteristics of the design.

To set characteristics, check the checkboxes next to the desired entries and click OK.

To cancel assigning new characteristics, click Cancel. The dialog box closes without affecting
previously-assigned characteristics.

Clicking Find opens the Characteristics Finder dialog box as shown below. Characteristics which were
already set will appear in the new dialog box automatically.
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Enter the characteristic to find and click Find. Search descriptions searches the descriptions for
matches, while Search codes searches only the codes for matches. At least one of these checkboxes
must be checked.

Any matching characteristics will appear in the Select characteristics to set field, but they will not be
selected.

Select All selects all the characteristics. Toggle All deselects those characteristics which were
previously selected and selects those which were previously not selected.

Combine searches by entering more search terms and clicking Find. Any non-selected characteristics
from the previous search will be removed from the results box. The results of the new search will be
shown along with those results of the previous search that were selected.

Saving a manufacturing file is done the same way as saving a design file. Specify a customer, owner,
salesperson, designer, description, and an authorization message. Click User Fields to assign
userfields to the manufacturing file.

Note:  The Characteristics Finder does not show hierarchical characteristics. All
characteristics are displayed on the same logical level, so there may be apparent duplicate
characteristics.

The following dialog box appears when saving a manufacturing file. It works the same way as saving a
single design.
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Changing existing database information in DataCenter

You can change information about a design or manufacturing file by clicking Edit in a browser.
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When Edit is clicked, the editable fields on the General, Characteristics, Userfields, and Print Items
tabs turn white, and the Save and Cancel buttons become available as shown below. Make the desired
changes and click Save.
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Synchronizing information in DataCenter

On rare occasions, the information in the database will not match the information in ArtiosCAD, and
you are asked to choose which set of information is correct – the information saved in the file or the
information from DataCenter.

2142



16ArtiosCAD

When a Synchronize dialog box appears, review the information shown in the Workspace group and
Database group. Click Keep Workspace if the information in the Workspace group is correct. Click
Update From Database if the database information is correct.

Exporting information from DataCenter

 Click the Generate Report button on the toolbar to export information from DataCenter. You can
either export detailed information about the current selection(s) by choosing Use Selected Records,
or print a list of the objects in the browser by choosing Use All Records. If there are any Multiple
Workspace Outputs defined in Defaults, you can also output the selected workspace(s) through them
as well.

There are two reports for each browser. The AutoCol Browser List format automatically detects which
columns of data are selected in Defaults and includes them on the report.

The SimpleEmb Browser List format presents just the information shown in the browsers.

The reports use three formats:

• CSV - produces a CSV (Comma Separated Values) file suitable for importing into a spreadsheet.

• HTML - makes an HTML (Hyper Text Markup Language) document which can be viewed in a Web
browser.

• XML - makes an XML (eXtensible Markup Language) file suitable for delivering data to other
applications in a rich, structured way.

All report types are created using XSLT transformations.

Customizing these reports involves changing the XML that is exported from ArtiosCAD and
then modifying the XSLT transformation template to process the new XML information. Simple
modifications, such as changing header columns can be performed by changing the Database Browser
Reports entries in Defaults, but for more complex modifications, you should enlist the aid of the Esko
Professional Services department or someone who has XML/XSLT editing experience.

2143



16 ArtiosCAD

Note:  If Thumbnails are selected in the report Properties in Defaults, a JPG file for each
thumbnail is stored in the same directory as the report output file. The thumbnails must be
kept in the same directory as the report output file in order to appear in the report.

Other tasks

AutoLoad

AutoLoad is a utility which reads information about existing CAD designs and layouts and imports
the data into the database. AutoLoad can read native ArtiosCAD (.ARD) workspaces, The Designer
WorkBench (.DES) workspaces, and LASERPOINT IQ workspaces.

Use AutoLoad whenever you have multiple designs whose data you want to enter in the database
without having to open each file and save it. Such a situation could be when you have loaded ArtiosCAD
on a system which already contains ArtiosCAD, LASERPOINT IQ, or The Designer WorkBench designs.
Another situation could be when you have copied many designs from another system onto your system.

AutoLoad can also convert batches of foreign file types (such as DXF or CF2) to ArtiosCAD workspaces.
See the upcoming section Recommended AutoLoad procedure for foreign file types for more
information.

Before using AutoLoad

Before using AutoLoad, you must have created servers and resources as described earlier in this
chapter. AutoLoad can only act upon files in resources.

You also should determine the type of AutoLoad to perform, Simple or Advanced. Simple AutoLoad
lets you choose a resource or resources to load into the database and automatically saves all designs
with an ArtiosCAD filename extension appropriate to the type of file. Advanced AutoLoad lets you
configure AutoLoad options and the default database behavior.

Simple AutoLoad

The procedure for using Simple AutoLoad is:

1. Make sure your database servers and resources are configured correctly.
2. Start ArtiosCAD.
3. Click Database, then AutoLoad.
4. In the What am I doing? group, choose New AutoLoad and click OK.
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5. On the Input tab, check the checkboxes for the resource(s) you want to AutoLoad.

If you select only one resource, you can choose the resource into which the files are loaded by
changing the entry in the Destination Resource list box. Selecting more than one resource to
AutoLoad disables the Destination Resource list box.

6. Click the Synchronization tab.
7. Set the option in the What am I doing? group.

Use Adding new files to the database (the default) when adding completely new files to the
database. These files have never been in a database in this ArtiosCAD installation before.

Use Recovering database when rebuilding a database, such as after a hard drive crash or
accidental deletion. This reads the database information stored in the workspaces and rebuilds the
database with it.

Use Refreshing files after database changes to update the workspaces after having made changes
to their records in DataCenter Admin.
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Click AutoLoad when you have chosen the option to use.
8. A progress indicator will appear.

9. When AutoLoad completes, click Close to return to the AutoLoad dialog box, and then click Close to
return to ArtiosCAD.

Advanced AutoLoad

Input tab Advanced pane
Clicking the Show Advanced unfold button on the Input tab of the AutoLoad dialog box shows more
options than just the list of resources.

The Use File Template checkbox and field control which files are AutoLoaded. Any files matching the
wildcards in the field are loaded. ArtiosCAD single designs, ArtiosCAD manufacturing files, and The
Designer WorkBench workspaces have their wildcards set up by default. To AutoLoad all files in the
selected resource(s), deselect the checkbox.

The Use Files Modified Before and Use Files Modified On or After checkboxes, when checked, let you
specify the dates before, between, or after the dates you enter.

When checked, Only Add Files That Already Exist in the Database causes AutoLoad to skip those
files whose records have been deleted from the database. This allows you to refresh the database or
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designs with new information without including all the designs whose records you manually deleted
from the database on purpose.

When AutoLoad runs, it generates a list of all the files it is to load and writes the list to the file shown
in the Index File field. This is usually ALOADLST.TXT in the default design directory. Append to
Index File lets you link together multiple source and destination resources into one file and thus one
AutoLoad.

Synchronization tab
The Synchronization tab is shown below.

The options in the What am I doing? group determine the way in which AutoLoad treats any existing
database information in the files. Use Adding new files to an existing database (the default) when
adding completely new files to the database. These files have never been in a database in this
ArtiosCAD installation before. Use Rebuilding database using file information when rebuilding a
database, such as after a hard drive crash or accidental deletion. This reads the database information
stored in the workspaces and rebuilds the database with it. Use Refreshing files after database
changes to update the workspaces after having made changes to their records in DataCenter Admin.

The data synchronization options control which data is kept when AutoLoad encounters a file which
has a corresponding record in the database. These options are set by the option selected in the What
Am I doing? group. They can also be set manually. If you make any manual changes, the option buttons
in the What am I doing? group are cleared.

Use data from database updates the file on disc with the information saved in the database. This
option is available for all categories of information stored in the database.

Use data from file reads the disc file for information and uses the data it finds to overwrite whatever
is stored in that category of the database record. This option is available only for that category of data
which does not have its own browser in DataCenter Admin.
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Use data from file, add database entry as needed reads the information from the disc file and
automatically creates any needed entries in the database. This option is available only for those
categories of information having their own browsers in DataCenter Admin.

Use data from file when defined in the database reads the information from the disc file and attempts
to match it to already-existing entries in the database. This option is available only for those categories
of information having their own browsers in DataCenter Admin.

When Adding new files to an existing database is the selection in the What am I doing? group, the
options are set as shown:

When Rebuilding database using file information is the selection in the What am I doing? group, the
options are set this way:

When Refreshing files after database changes is the selection in the What am I doing? group, the
options are set like this:
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The Use dates if found in database checkbox uses the dates in the database if they are available. If
they are not available, or this option is turned off, dates from the workspace are used.

The Keep original saved date checkbox, when checked, keeps as an element of the database record
the date the file was originally saved, but the date and time of the physical file is changed in the
filesystem because AutoLoad updates and saves the physical file. When this checkbox is cleared, the
current date and time of the AutoLoad is used in both the database record and the filesystem.

The Automatically embed parametric dependencies checkbox controls whether ArtiosCAD
automatically embeds in a design those components of a design which are required to rebuild it such
as geometry macros and included designs.

The Ignore revision extension scheme for ArtiosCAD files checkbox, when checked, keeps AutoLoad
from renaming revisions of ArtiosCAD files it processes.

The options in the When converting non-ArtiosCAD files group control what happens when AutoLoad
encounters a foreign file with the same base name as an ArtiosCAD workspace. The ArtiosCAD
workspace may have been modified since the last AutoLoad. The Recreate ArtiosCAD file checkbox,
when checked, tells AutoLoad to delete the current ArtiosCAD file and recreate it from the foreign file;
any modifications to the ArtiosCAD file since it was converted to an ArtiosCAD workspace will be lost.
If the checkbox is clear, the foreign file is skipped and a warning is added to the log file.

The options in the ArtiosCAD File Extensions group control the filenames of non-native ArtiosCAD
files. Add ArtiosCAD filename extension adds the appropriate .ARD or .MFG to the filename, which is
useful when AutoLoading LASERPOINT IQ workspaces. Replace current filename extension deletes
the current extension and replaces it with either .ARD or .MFG as appropriate, which is useful when
AutoLoading .DES files from The Designer WorkBench. Note that .WBD files from The Designer
WorkBench can not be AutoLoaded.

To perform an Advanced AutoLoad, set the options described above as desired and click AutoLoad.
The files will be loaded into the database. When AutoLoad completes, click Close to return to the
AutoLoad dialog box, and then click Close to return to ArtiosCAD.

AutoLoad notes and warnings

Only .DES files from The Designer WorkBench can be AutoLoaded; .WBD files can not be AutoLoaded.

AutoLoad assigns the default board code to designs that have no board code already defined.

When synchronizing design files with the database, and length, width, and depth variables are not set
in the workspace and are not zero in the database, the variables in the workspace are set from the
database.

AutoLoad does not rebuild 3D or paper information for boards. This information can come either from
a database backup that is restored through DataCenter Admin, or by using the ArtiosCAD Database
Export utility to export the board table before any problems occur and then by using the ArtiosCAD
Database Import utility to import the board table back into the database.

Recommended AutoLoad procedure for foreign file types
If you want to use AutoLoad to automatically convert foreign files types (such as DXF and CF2) to
ArtiosCAD workspaces, do the following:

2149



16 ArtiosCAD

1. Set up the default import tuning by configuring the Import Tuning entries in Options > Defaults >
Import Tuning Table (adding or modifying the entries as appropriate).

2. Set the import tuning mapping in Options > Defaults > Design Defaults > Default Import Tuning to
select the correct entry for the given file type.

3. Start to AutoLoad files starting with the default File Template file types. Make sure the Recreate
ArtiosCAD file checkbox is checked on the Synchronization tab.

4. Following successful processing of these files, begin to AutoLoad any of the common format files
separately by typing the appropriate entry into the file template text field, such as *.cf2 or *.dxf.

5. Once AutoLoad has completed, exit and restart ArtiosCAD before AutoLoading further file types.

This procedure will minimize the overall time required to AutoLoad the files. Note that using any of the
database synchronization options can significantly increase the time required to process the desired
files.

AutoLoad and Projects
When AutoLoading, depending on if the design is already in the database and if the design came from
the same database, project codes will be handled differently.

If Use data from database is selected, and the file exists in the database, then ArtiosCAD will
synchronize the information using the database values. If the file does not exist in the database, but
came from the same database (has the same database ID), it will AutoLoad normally. If the file came
from a different database (has a different database ID), the Project codes will be cleared and the file
will AutoLoad normally.

If Use data from file, add database entry as needed is selected, database entries will be added as
needed. Select this option to add Project codes from foreign files to your database.

If Use data from file when defined in the database is selected, Project codes which do not already
exist in the database will be cleared from the file.

Resuming a previous AutoLoad

If AutoLoad terminates abnormally, you can resume it by doing the following:

1. Restart ArtiosCAD and click Database > AutoLoad.
2. Choose Resuming a previous AutoLoad in the initial What Am I Doing? group of the AutoLoad

dialog box and click OK.

3. The AutoLoad dialog box appears with a different Input tab than for new AutoLoads.
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4. Click Specify Index File and find the ALOADLST.TXT file generated by the previous AutoLoad. The
Open dialog box opens in the default design directory; browse for the file if you specified a different
location for the index file in the previous AutoLoad. Select the file and click Open.

5. The File List group shows the files that AutoLoad previously attempted to process. The first file
after the point of failure is highlighted by default.
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6. Choose the option in the Resume group at which AutoLoad is to resume:

From first file chooses the first file in the list.

From point of failure selects the last file the previous AutoLoad attempted to process. To avoid
another abnormal termination, you should try to open this file manually in ArtiosCAD and save it
before choosing this option.

From file after point of failure is the default, and selects the first file after the one that caused an
abnormal termination.

From manual selection lets you select the file in the File List at which the AutoLoad resumes.
7. Click the Synchronization tab and set the options as desired.
8. Click AutoLoad. It will resume from the file chosen in step 6.
9. When the AutoLoad finishes, click Close to close the AutoLoad Status dialog box and then click

Close to close the AutoLoad dialog box.

Create new index file from files that errored creates an index file of any files in the AutoLoad that
errored, except for those loaded into a destination resource. Click it and then enter a sensible path
and filename for the new index file and click Save. That index file is then automatically loaded into the
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file pane. Try AutoLoading again; if they error, examine the log file by clicking View Log. To resolve the
error, try to open the files in ArtiosCAD and then save them.

Database network performance

Typically, databases which run over WANs (Wide Area Networks), for example between plants,
experience slower network performance compared to those which run over faster LANs (Local Area
Networks). By default, ArtiosCAD requests a complete set of database entities each time the Database
Information dialog box is activated, which can lead to wait times if there are many records to download
from the database server.

To address this, ArtiosCAD can store the Customer, Owner, Designer, Salesperson, Characteristics,
and User Fields entities from the Database Information dialog box in memory, as well as the boards,
companies, company types, and Resources. This is called caching.

Both ArtiosCAD and CAD-X can use this feature, and each will use more memory if it is enabled.

Once the database dialog box entries or other entities are loaded into memory, ArtiosCAD does not re-
request them from the database. If changes are made to the entities in the database itself, ArtiosCAD
will not see them until the cache is refreshed or a new ArtiosCAD session is started. To refresh the
cache, click Database > Refresh cache > Item.

The Customer cache is refreshed when the New button in the Customer dialog box is clicked.

Refreshing the cache may take a while on a slow WAN with very large entity lists.

ArtiosCAD can also search the database for specific records which match a pattern thus returning only
a few records instead of thousands. This feature is called pattern searching.

For information about configuring these options, refer to the Defaults chapter.

Connecting to the database
Connecting to the database should be automatic. However, in the event of network trouble that severs
the connection, click Database > Connect. This command is unavailable when there is a current
connection.

Pattern searching

When pattern searching is enabled in Defaults, the Oneup Design Information and Manufacturing
Database Information dialog boxes change. The drop-down list boxes for the Customer, Owner,
Designer, and Salesperson fields disappear and the fields become disabled. In addition, there are ...
buttons leading to dialog boxes which let you search for records and then display details about the
selected records, or display details if there is already a selected record. Shown below is the Customer
dialog box; all four dialog boxes act similarly, but only the Customer dialog box has the New button.
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Pattern searching works by entering a few letters of a word, or a whole word, or a complete phrase,
then choosing a method of searching, and then clicking Find. The results of the search populate the
drop-down list box.

For example, to find the Meeber Box Company, one could enter just the first few letters - Meeb - and
choose Begins with. Or, one could enter Box and choose Contains. Finally, one could enter Meeber Box
Company and choose Equals, and then click Find. Clicking the drop-down list box activator will display
a list of results from which the desired entry is chosen.
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Clear clears the current search results and lets you search for a new value.

New appears only in the Customer dialog box and lets you enter a new Customer database record.

The double chevrons (« and ») display the previous and next entry in the search results, respectively.

To accept the results of the search, click OK; otherwise, click Cancel to return to the previous dialog
box.

Installing additional characteristics

Two files containing many additional characteristics are installed to the \Esko
\Artios\DataCenter directory when ArtiosCAD is installed. The two files are
FoldingCartonCharacteristics.txt and CorrugatedCharacteristics.txt. You may
load one of them, both of them, or neither at your discretion.

To load them into the database, do the following:

1. Make sure no one is using ArtiosCAD, DataCenter Admin, SpecLink, or WebCenter (version 3 or
below) to insure that the database is not being accessed.

2. Log on to the database server as Administrator or as a member of the Administrators group.
3. Start DataCenter Admin.
4. Click File > Loader.
5. When prompted for a username and password, enter admin for the username and do not enter a

password.
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6. The ArtiosCAD Database Loader Utility dialog box will appear. Enter the name of the new
characteristics file to load in the Name: field, and enter the path (such as C:\Esko\Artios
\DataCenter) in the Path: field. Or, click Browse to navigate to the file.

7. In the Tables to Import group, check the Design Characteristic checkbox. If you want to replace
the existing characteristics, check the Replace Characteristic Tree checkbox. To merge the new
characteristics in with the existing characteristics, leave the checkbox blank. The dialog box should
look similar to the one shown below.

8. Click Import. The Table Importing progress bar will increment as the file loads.

9. When it is done, you may load the other new characteristics file by repeating steps 5 through 7,
substituting the name of the other file in the Name: field, and making sure to not select the Replace
Characteristic Tree checkbox (otherwise the characteristics from the file you just loaded would be
overwritten).

10. To view the log file, click View Log. To exit the utility, click Exit.
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Changing the database password

Do not change the database passwords in a vendor-supplied utility. Rather, change them in DataCenter
Admin by using the File > Change Database Connection (programmer) Password or Change Database
System Administrator (sa) Password commands.

When running DataCenter Admin in an operating system supporting User Access Control, you must be
logged in as an administrative user to change the database password. The Change Database Password
command is unavailable if you are not an administrative user.
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17.  Appendix

Changed Icons and Toolbars as of Version 14

As of version 14, ArtiosCAD has larger, redesigned tool icons in Single Design, 3D, and Manufacturing.
Please refer to the sections below for new and old tool icons. The tools are grouped by toolbar, and the
toolbar order is the same as that listed in the Toolbar Master Controls.

There are also changes to the toolbars in Single Design:

• The Adjust toolbar has been split into the Adjust toolbar and the Prepare Manufacturing toolbar.
• The tools on the Graphics toolbar are in a different order.

If you have upgraded from an earlier version of ArtiosCAD, please use this section to help find familiar
tools.

Single Design Tool Icons

Table: Single Design Icons

Tool New Icon Old Icon

View toolbar

Zoom Rectangle

Center-Point Zoom

Zoom Out

Scale to Fit

Scale to Fit with Border

Pan/Zoom

View Mode

Geometry toolbar

Line Angle/Offset

Line Horiz/Vert
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Tool New Icon Old Icon

Line Angle/Length

Arc Start Angle

Arc End Point

Arc Center

Arc Through Point

Circle Radius

Circle Diameter

Ellipse

Rectangle Horiz/Vert

Rectangle from Center

Rectangle from Line

Offset Line

Straight Curve

Curve Straight

Line Join

Arc Join

Tangent Arc

Line At Angle From Line

Bezier

Move to Point

Dimension toolbar
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Tool New Icon Old Icon

Temporary Dimensions

Distance Dimension

Auto Aligned Distance
Dimension

Aligned Distance Dimension

Cumulative Distance Dimension

Angle Dimension

Angle To Horiz. Dimension

Angle To Vertical Dimension

Radius Dimension

Radius To Circle Dimension

Diameter Dimension

Diameter To Circle Dimension

Change Dimension Alignment

Change Text Position

Change Extension Line Length

Auto Dimension

Adjust toolbar (split)

Blend

Chamfer

Blend Three Lines

Split Line
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Tool New Icon Old Icon

Trim/Extend Two Lines

Trim/Extend One Line

Trim Interior

Trim Against Selection

Extend Line

Stretch Point

Stretch by Polygon

Follow

Conlines toolbar

Conline Offset/Angle

Conline Offset

Conline At Angle From Line

Conline Division/Midpoint

Conline Radius

Conline Angle Divide

Conline Join

Conline Join With Concircle

Conline Tangent Concircle

Edit toolbar

Select

Select Conlines
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Tool New Icon Old Icon

Select by Example

Delete

Move to Layer

Move

Rotate Right 90

Rotate Left 90

Rotate 180

General Rotate

Mirror About Vertical

Mirror About Horizontal

Vertical Mirror About Center

Horizontal Mirror About Center

Mirror About Line

Scale

Differential Scale

Copy

Repeated Copy

Copy Rotate Right 90

Copy Rotate Left 90

Copy Rotate 180

Copy General Rotate

Copy Mirror About Vertical
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Tool New Icon Old Icon

Copy Mirror About Horizontal

Vertical Copy Mirror About
Center

Horizontal Copy Mirror About
Center

Copy Mirror About Line

Complete Design From Half/
Quarter

Copy Times Offset

Copy Times Rotate

Ungroup

Ungroup All

Group

Group Sequence

Offset Lines

Annotation toolbar

Text

Align Left

Align Horizontal Center

Align Right

Align Bottom

Align Vertical Center

Align Top

Arrow
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Tool New Icon Old Icon

Detail

Adjust Detail

Outline Text

Line Text

Line Type Label

Hatch

Define Mate Area

Artwork Panels

Dynamic Art

Undo-Redo toolbar

Undo

Redo

Skip Next Redo

Run All Redo

Discard All Redo

Edit Next Redo

Rebuild

Rebuild Playback

Adjust Outline toolbar

Make Horizontal/Vertical

Align Horizontal/Vertical
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Tool New Icon Old Icon

Merge Line Straight

Merge Lines Into Arc

Merge Lines Into Bezier

Merge Lines To Intersection

Adjust Arc

Straighten

Adjust Bezier

Reverse Direction

Sequence

Extend/Measure toolbar

Extend

Clear Extend

Measure

Advanced Standard toolbar

Line Angle Or Offset

Arc Angle Offset

Horizontal Angle/Offset
Dimension

Vertical Angle/Offset Dimension

Graphics toolbar (reordered)

Add Graphics

Register Bitmap

Clip Graphics
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Tool New Icon Old Icon

Replace Graphics

Move Graphics

Autotrace Bitmap

Color Stock

Fill

Stroke

Fill Panel

Send To Front

Send To Back

Reports toolbar

Prompted Text From Table

Prompted Text From New
Variable

Calculated Text

File Window

Adjust File Window

Report Size

Counter toolbar

Create Or Rebuild Counter

Rebuild Chamfer

Add Counter Name

Add Counter Tack Bridge

Delete Counter Tack Bridge
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Tool New Icon Old Icon

Add Counter Strap

Select Periphery Lines

Registration Holes toolbar

Add Hole

Add Countersunk Hole

Add Oblong Hole

Add Countersunk Oblong Hole

Add Drill Hole

Add Countersunk Drill Hole

Prepare Manufacturing toolbar
(new)

Bleed

Coating Free Area

Add Bridge

Add Tack Bridge

Add Nick

Delete Bridge

Move Bridge

Conline Through Bridge

Delete Nick

Move Nick

Conline Through Nick
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Tool New Icon Old Icon

Shorten Creases

Manufacturing Tool Icons

Table: Manufacturing Tool Icons

Tool New Icon Old Icon

Manufacturing toolbar

Select Element

Delete

Repeat

Delete All

Delete Strip Area

Create Wood Edge

Create Hand Hold

Create Burn Name

Add Bridge

Add Tack Bridge

Delete Bridge

Move Bridge

Conline Through Bridge

Add Nick

Delete Nick

Move Nick
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Tool New Icon Old Icon

Conline Through Nick

Create or Rebuild Counter

Dieboard toolbar

Create Stripping Rule (Line/
Edge)

Create Stripping Rule (Angle/
Offset)

Evenly Spaced Scrap Knives

Move Scrap Knives

Create Carrier Rule

Make Hook

Balance Knives

Rotary Die Board

Add MHP Holes

Select MHP

Delete All MHP

Adjust MHP Horizontally

Adjust MHP Vertically

Double Knife Removal

Add Gripper

Horizontal Split

Stripping Board toolbar

Strip Area

Upper Push Pin tool
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Tool New Icon Old Icon

Upper Rule tool

Upper Block tool

Upper Block Pin tool

Add Interference

Make Air Hole

Make Alignment Hole

Add Support Holes

Add Registration Holes

Add Lower Board Mounting Bar

Create Separator

Manual Layout toolbar

Add Oneup

Oneups Dialog

Change Gutter Distance

Change Sheet Size

Edit Layout toolbar

Select Oneups

Copy Oneups

Copy Times Oneups

Delete Oneups

Move Oneups
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Tool New Icon Old Icon

Rotate Oneup 180

Rotate Right Oneup

Rotate Left Oneup

Rotate Oneup By Angle

Mirror About Vertical Oneup

Mirror About Horizontal Oneup

Straight Nest

Reverse 2nd Row Nest

Reverse 2nd Row Align Nest

Reverse 2nd Column Nest

Reverse 2nd Column Align Nest

Layout Manual Sequencing

Replace Oneups

Change Print Item

Open Embedded Design

Intelligent Layout toolbar

Quantities And Costs

Intelligent Layout Parameters

Specify Nest

Delete Nest
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Tool New Icon Old Icon

Move Design Or Column

Rule Path toolbar

Build Rule Path

Delete Rule Path Layer

Add Rule Path

Select Rule Path

Split Rule Path

Join Rule Path

Move Bridge Start Point

Reverse Rule Path

Move Bridge Start Point To
Center

Change Wrap Point

Add Bridge On Rule Path

Re-Bridge Rule Path Layer

Add Mark To Rule Path

Delete Bridge On Rule Path

Move Bridge On Rule Path

Align Bridge On Rule Path

DieSaw toolbar

Generate Leader Holes

Add Leader Hole
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Tool New Icon Old Icon

Delete Leader Hole

Reverse Cut

Delete DieSaw Layer

Rubbering toolbar

Rubber Area

Repeat Rubber Element

Delete All Rubber

Delete Rubber Area

Select Rubber

Split Rubber

Join Rubber

Move Rubber Split

Trim Rubber

Add Rubber

Subtract Rubber

Fill Rubber Area

Add Separator

Move Separator

Delete Separator

Add Open-Out

Delete Open-Out
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Tool New Icon Old Icon

Subtract Bolt Holes

Update Plastic Cover

Group Rubber

Ungroup Rubber

Layout Rubber

Rubber View Options toolbar

Highlight Rubber With Repeat

List Rubber Elements

Rubber View Options

Blanking toolbar

Add Grid Bar

Include Strip Rules

Generate Blanking Tools

Adjust Blank Holes

Adjust Pushers

Add Non-Stop Swords

Add Photocells

Add Jogger Guides

Add Support Bars

Add Air Holes

Add Blanker Pusher Pins

Add Hardware
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Tool New Icon Old Icon

Add Tie-Bolts

Add Pressers

Delete Blanking

3D Tool Icons

Table: 3D Tool Icons

Tool New Icon Old Icon

3D View toolbar

Zoom Rectangle

Center-Point Zoom

Zoom Out

Zoom In/Out

Scale To Fit

Scale To Fit With Border

Pan/Zoom

View Angle

Previous View

Next View

Rotate Right

Rotate Down

Orthogonal View

Perspective

Light Source
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Tool New Icon Old Icon

View Mode

3D Tools toolbar

Select Designs

Select Labels Or Parts

Select Tear-Away Part

Move Point to Point

Move Designs

Move Designs X, Y, Z

Duplicate Designs

Duplicate Designs X, Y, Z

Ungroup Designs

Group Designs

Rotate Designs

Drag On Plane

Array Copy

3D Dimension toolbar

Dimension

Select Dimensions

Change Dimension Alignment

Change Text Position

Animation toolbar

Add Frame

2176



17ArtiosCAD

Tool New Icon Old Icon

Update Frame

Update Range Of Frames

Animation Playback

Delete Frame

Shue Frame Forward

Shue Frame Back

Make Tear-Away Animation

3D Extend toolbar

Extend

Extend Design

Clear Extend

Cross Section toolbar

Intersect Design Tool

Cross Section Tool

Bounding Box Tool

Run A Standard Tool

Fold in 3D toolbar

Fold Angle

Fold All

Fold 2 To Meet

Fold 1 To Meet

Flap Priority
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Tool New Icon Old Icon

Bend Panel

Mate

Mate All

Undo Mate

Snap Tab/Slot

Update 2D

View Mode toolbar

Solid

Solid With Edges

Lighter Color With Edges

Hidden Lines Removed

Wire Frame

Perspective

Board Thickness

Graphics

Transparent

Creases Pink

Bounding Box

Floor Shadows

3D Rendering And Image Quality
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Arithmetic functions

Included in ArtiosCAD are arithmetic functions which can be used anywhere that data is input. In the
table below, the capitalized letters in the function are the minimum you have to enter into the data
entry field.

Table: Arithmetic Functions

Function Usage

ARCCos Calculates the angle that has the specified cosine.

Syntax:

ARCCos(cosine)

Result: Angle between 0 and 180. ArtiosCAD will error if the cosine value is outside
range -1..1.

For example, ARCCOS(0) = 90

ARCSin Calculates the angle that has the specified sine.

Syntax:

ARCSin(sine)

Result: Angle between -90 and 90. ArtiosCAD will error if the sine value is outside
range -1..1.

For example, ARCSIN(1) = 90

ARCTan Calculates the angle that has the specified tangent.

Syntax:

ARCTan(tangent)

Result: Angle between -90 and 90. For example, ARCTAN(1) = 45

COSine Calculates the cosine of an angle. The angle must be in degrees but there are no
limits on the value used for the angle. Syntax:

COS(angle)

Result: Number between -1.0 and 1.0 For example,

COS(0) = 1 COS(60) = 0.5 COS(180) = -1.0

POWer Raises the number to the given power. Fractional powers are not permitted for
negative numbers. Syntax:
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Function Usage

POWer(value,exponent)

The value and exponent must be separated by a comma regardless of the language
in which you are using ArtiosCAD. To use a decimal exponent, use a period as the
decimal separator, not a comma.

Result: Numeric.

For example,

POWER(3,2) = 9 POWER(64,1/3) = 4 POWER(2,3) = 8 POWER(64,-1/3) = 1/4
POWER(-2,3) = -8 POWER(5,3.6) = 328.316

Note: To calculate a hypotenuse, use the following expression:

C2 = A2 + B2

C = Square root of (A+B)

C = POW((POW(A,2)+POW(B,2),.5)

SINe Calculates the sine of an angle. The angle must be in degrees but there are no
restrictions on the value used for the angle. Syntax:

SIN(angle)

Result: Number between -1.0 and 1.0.

For example,

SIN(0) = 0.0 SIN(30) = 0.5 SIN(360) = 0.0

SQRT Calculates the square root of an arithmetic expression. Not valid for negative
numbers. Syntax:

SQRT(expression)

Result: Numeric.

For example,

SQRT(36) = 6

TAN Calculates the tangent of the angle. The angle must be in degrees but there are no
limits on the value used for the angle. Syntax:

TAN(angle)

Result: Number.

For example, TAN(0) = 0, TAN(45) = 1, TAN(60)=1.73205,

TAN(-45) = -1
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Reserved words

The following words and word fragments are reserved for use by ArtiosCAD. Do not use them for
variable names or in command files.

Table: Reserved Words

ARC AT BOT BOTT BOTTO BOTTOM BRI

BRID BRIDG BRIDGE BY BYX BYY CEN

CENT CENTE CENTER CENTR CENTRE CIR CIRC

CIRCL CIRCLE COR CORN CORNE CORNER CS

DIA DIAM DIAME DIAMET EXPAND EXT EXTE

EXTEN EXTEND FCC FCN FIN FINI FINIS

FINISH FON FONT FOR FORM FORMA FORMAT

FRO FROM ITE ITEM LEF LEFT LEN

LENG LENGT LENGTH LONG MOV MOVE NEA

NEAR OFF OFFS OFFSE OFFSET ORI ORIE

ORIEN ORIENT POI POIN POINT POINTA POS

POSI POSIT POSITI RAD RADI RADIU RADIUS

RELAX REV REVE REVER REVERS RIG RIGH

RIGHT SC TCC TCN TEX TEXT THR

THRO THROU THROUG TO TOL TOLI TOLIN

TOLINE TOP TOX TOY TYP TYPE VAR

VARI VARIA VARIAB WID WIDT WIDTH WSCALE

List of line types

Below is the complete list of line types in the order in which they appear in ArtiosCAD. The Grouped
in column indicates in which group the line type is found. The Number is the line designation in
fundamental ArtiosCAD syntax.
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Table: List of Line Types

Line type name Grouped in Number Category / Notes

Cut Design 1 Rules

Crease Design 2 Rules

Partial cut Design 4 Rules

Reverse partial cut Design 9 Rules

Reverse crease Design 8 Rules

Second height crease Design 223 Rules

Matrix crease Design 224 Rules

Half crease Design 16 Rules

Unknifed diecut Design 12 Center edge

Die etch Design 18 Etch

Print registration Design 10 Annotation

Inside Bleed Design 212 Annotation

Outside Bleed Design 11 Annotation

Inside Coating (Varnish) Design 213 Annotation

Outside Coating (Varnish) Design 85 Annotation

Annotation Design 0 Annotation

Annotation2 Design 207 Annotation

Annotation3 Design 208 Annotation

Annotation4 Design 209 Annotation

Annotation5 Design 210 Annotation

Dimensions and text Design 20 Annotation

Print image Design 14 Annotation

Form lines 1 Design 23 Annotation

Form lines 2 Design 24 Annotation
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Line type name Grouped in Number Category / Notes

Copy area Design 262 Annotation

Copy free Design 263 Annotation

Dynamic art Design 264 Annotation

Side bevel Generic rules 19 Rules

Generic perf Generic rules 3 Rules

Generic perf in channel Generic rules 6 Rules

Generic cut and crease Generic rules 5 Rules

Partial cut and crease Generic rules 15 Rules

Glue assist Generic rules 7 Rules

Generic special rule Generic rules 13 Rules

Partial cut perf Generic rules 251 Rules

Reverse partial cut perf Generic rules 252 Rules

Partial cut perf in
channel

Generic rules 253 Rules

Second height cut
crease

Generic rules 254 Rules

Second height partial cut
crease

Generic rules 255 Rules

Reverse partial cut
crease

Generic rules 256 Rules

Usable limit of sheet Utility 97 Annotation

Edge of sheet Utility 98 Annotation

Axes Utility 31 Annotation

Construction line 1 Utility 34 Annotation

Construction line 2 Utility 33 Annotation

Construction line 3 Utility 32 Annotation
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Line type name Grouped in Number Category / Notes

Canvas construction line Utility 35 Annotation

Nick Utility 17 Annotation

Tear Utility 205 Annotation

Bend Utility 206 Annotation

Size only Utility 215 Used for Size information only

Stripping rule Dieboard 93 Rules

Carrier rule Dieboard 94 Rules

Scrap/Chop knife Dieboard 96 Rules

Balance knife Dieboard 218 Rules

Unknifed diecut Dieboard 12 Center edge

Same as earlier versions of
ArtiosCAD. Also used for floats.

Die board edge Dieboard 170 Outside edge

Also used for die splits. Milled parts
of the dieboard edge for DieSaw
output are distinguished using
different subtypes.

Die registration hole Dieboard 171 Inside edge

Used for registration holes or chase
holes.

Laser position holes Dieboard 216 Inside edge

Die bolt holes Dieboard 217 Inside edge. Drill holes for DieSaw
output are distinguished using
different subtypes.

Die etch Dieboard 18 Etch

For labels that are burned in the die.

Lead hole Dieboard 172 Inside edge

Lead hole for the DieSaw in the rule
path layer.

Unknifed lead in Dieboard 173 Center edge
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Line type name Grouped in Number Category / Notes

Lead in line which starts a cut by the
DieSaw but is not part of the design
and has no rule.

Die split Dieboard 174 Outside edge

Used to divide the die into pieces.

Gripper finger Dieboard 219 Annotation

Lower board edge Lower board 175 Outside edge

Lower stripping hole Lower board 176 Inside edge

The lower holes must be separate
from other holes because the
processing to create the upper board
depends on them.

Lower registration hole Lower board 177 Inside edge

Lower etch Lower board 178 Etch

For labels that are burned into the
lower board

Unknifed lower Lower board 179 Center edge

For a slot with a specified width, such
as the end of a carrier rule outside
the stripping hole.

Hole inside modifier Lower board 180 Inside edge

The inside edge of an interference
made of wood which extends partly
into the lower stripping hole.

Hole outside modifier Lower board 181 Inside edge

A slot in the edge of a lower stripping
hole which holds the outside edge of
an interference element.

Hole interference Lower board 182 Inside edge

The edge of the active part of an
interference element.

Upper board edge Upper board 183 Outside edge
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Line type name Grouped in Number Category / Notes

Stripping block Upper board 184 Outside edge

Block support pin Upper board 185 Inside edge

Upper stripping rule Upper board 186 Rules

The base of the stripping rule which
is burned in the upper board

Pusher base Upper board 187 Inside edge

The base of the push pin or pusher
element which is burned in the upper
board

Pusher active part Upper board 188 Inside edge

The active part which pushes the
waste

Pusher shoulder Upper board 189 Annotation

The shoulder that stops the element
from being pushed through the upper
board

Pusher clearance Upper board 190 Annotation

Shows the effective size of the
pusher or pin.

Upper air hole Upper board 191 Inside edge

Upper registration hole Upper board 192 Inside edge

Upper etch Upper board 193 Etch

For labels which are burned in the
upper board

Unknifed upper Upper board 194 Center edge

For a slot with a specified width.

Front waste edge Front waste
separator

195 Outside edge

Front waste registration
hole

Front waste
separator

196 Inside edge
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Line type name Grouped in Number Category / Notes

Front waste etch Front waste
separator

197 Etch

Rubber inside edge Rubber 220 Annotation. Distinguished from the
rest of the outline so that it can be
cut with a bevel on machines that
have a tilting head.

Rubber outline Rubber 221 Annotation

Rubber name Rubber 222 Annotation. Used to cut numbers on
each piece of rubber.

Blanker lower board
edge

Blanker 227

Blanker lower hole Blanker 228

Blanker lower
registration hole

Blanker 229

Blanker lower etch board Blanker 230

Blanker upper board
edge

Blanker 231

Blanker upper air hole Blanker 232

Blanker upper
registration hole

Blanker 233

Blanker upper etch Blanker 234

Blanker pusher edge Blanker 235

Blanker pusher air hole Blanker 236

Blanker pusher
registration hole

Blanker 237

Blanker pusher etch Blanker 238

Blanker frame Blanker 239

Blanker non-stop sword Blanker 240

Blanker photocell Blanker 241
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Line type name Grouped in Number Category / Notes

Blanker grid Blanker 242

Blanker support bar Blanker 243

Component active part Blanker 244

Component edge Blanker 245

Component clearance Blanker 246

Component annotation Blanker 247

Sample knife Sample 120 Etch

Sample partial cut knife Sample 121 Etch

Sample crease with grain Sample 122 Etch

Sample crease cross
grain

Sample 123 Etch

Sample pen 1 Sample 124 Etch

Sample pen 2 Sample 125 Etch

Sample pen 3 Sample 126 Etch

Sample pen 4 Sample 127 Etch

Sample reverse partial
cut

Sample 128 Etch

Sample reverse crease Sample 129 Etch

Sample reverse crease
cross grain

Sample 130 Etch

Sample counter knife Sample 131 Etch

Sample router with grain Sample 132 Etch

Sample router cross
grain

Sample 133 Etch

Sample counter pen Sample 134 Etch

Sample V-notch crease Sample 135
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Line type name Grouped in Number Category / Notes

Sample V-notch cut Sample 136

Sample drill hole Sample 137

Sample reverse V-notch
crease

Sample 138

Sample 2nd height
crease with grain

Sample 225 Etch

Sample 2nd height
crease cross grain

Sample 226 Etch

Sample 2nd height
partial cut

Sample 265 Compression bend

Sample 2nd height
reverse cut

Sample 266 Reverse compression bend

Tool 1 Tooling 140 Etch

Tool 2 Tooling 141 Etch

Tool 3 Tooling 142 Etch

. . . .

. . . .

. . . .

Tool 28 Tooling 167 Etch

Tool 29 Tooling 168 Etch

Tool 30 Tooling 169 Etch

With grain crease Counter 100 Etch

Cross grain crease Counter 101 Etch

Crease end tool Counter 102 Etch

Periphery tool Counter 103 Etch

Chamfer tool Counter 104 Etch
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Line type name Grouped in Number Category / Notes

2nd height with grain
crease

Counter 105 Etch

2nd height cross grain
crease

Counter 106 Etch

Name tool Counter 107 Etch

Positioning hole tool Counter 108 Etch

Milling tool Counter 109 Etch

Counter mill outline Counter 110 Etch

Position holes 2 Counter 111 Etch

Counter slot Counter 112 Etch

Reverse chamfer Counter 113 Etch

V-notch outside bevel N/A 300 Only for internal use by other Esko
products

V-notch inside bevel N/A 301 Only for internal use by other Esko
products

Generic v-notch crease N/A 267

Generic v-notch cut N/A 268

Generic reverse v-notch
crease

N/A 269

Generic reverse v-notch
cut

N/A 270

Glossary

Term Definition

Accept ratio problems A checkbox that allows the user to continue running a standard even if the
ratio of the variables (length, width, depth, etc.) is not in correct proportion.

Account for Deflection An adjustment for the deflection of a tool when cutting the counter. It is
used to ensure channel width accuracy.
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Term Definition

Advanced A button that gives access to more options.

Air hole Hole(s) made in the stripping board to help prevent jams caused by a
vacuum effect.

Alignment hole Hole(s) made in the die board to allow quick and easy alignment of a set of
manufacturing tools.

Allow Rotation on
Repeat

A menu checkbox in Manufacturing Layout that gives the option to consider
rotated one-ups the same as non-rotated one-ups and therefore do the
same operations in congruent areas.

allowance reduction An addition to the bridge’s width to compensate for the leader hole’s
reduction of the bridge’s width when using a diesaw.

Angle The number of degrees between two lines or between a line and an axis

Annotation Details, arrows, and text that are typically placed on a drawing to provide
more explanation.

Arc A portion of a circle.

Area A value calculated by multiplying length and width.

Authorization Approval by authority.

Authorization Msg A field for marking a design. Typically initialed as “approved by” or marking it
with an appropriate comment.

Auto Aligned Distance
Dimension

A tool that dimensions a series of parallel lines in a design.

Auto Numbering Automatically sequencing the next design and/or revision in ascending
order based on configuration.

Auto-Detect An importing option that decides if a file should be imported as a Layout or
Oneup. This decision is made based on the contents of the file.

AutoLoad A utility which gathers information about existing CAD designs and
layouts. Then it imports the data into DataCenter and saves them with the
appropriate ArtiosCAD file extension.

Auto-Repeat Automatically repeats elements in manufacturing such as stripping rules,
holes, and pins throughout similar areas of the layout.

AutoSave A utility that will create temporary backup files that are available for
recovery should the system crash.
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Term Definition

AutoSave Recovery A dialog box offering the option to recover the temporary backup files
created by the AutoSave feature.

AutoTrace Bitmap A tool that replaces a bitmap with lines and arcs that can be manipulated in
ArtiosCAD.

Balance Knives Steel rules that are used to balance the load on a dieboard for a platen
press. They are also called leveling knives.

Base Face The selected panel of the design around which all other panels fold. Used in
3D mode.

Basic Dimensions The dimensions that are required to be entered to run a standard, typically
length, width, and depth.

Beeps A sound/noise made to inform the user of things such as data received or
an error in snapping.

Belt speed The number of feet per minute that a conveyer belt moves. The belt speed
and travel distance are used in one method of determining the number of
sheets per hour in the Intelligent Layout module.

Bend corners A grouping of options to take a piece of rule and extend it around a corner at
an angle on a rotary die. The options are to take the rule from rotary to flat
or from flat to rotary.

Bend Length In a rotary die, the length of the chop knife that is used for transitioning
corners from rotary rule to flat rule or from flat rule to rotary rule.

Between teeth An option to have bridging start between the teeth on a rotary rule.

Bevel An option for joining strokes that chamfers the outside edges of strokes
that meet. Strokes are graphical additions to a line. The Bevel option can be
used when auto-tracing a bitmap.

Bezier A tool that creates a French curve with a start point, an end point, and two
adjustable middle points.

Beziers to Arcs An option that changes all bezier lines in the design to arcs and is used
when exporting to programs that do not support beziers.

Blank Any die cut section of boxboard in a flat configuration. The Blank is formed
into a rigid box later. Also, a Blank is a folding carton after cutting and
scoring but before folding and gluing.

Blanker The actual board that breaks the nicks to separate the designs. It is the last
station in the press.
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Blanker pusher The part of the blanking tool that traps the design and pushes it through to
separate the designs.

Bleed Defines the area of ink coverage when the sheet moves through the printing
press.

Bleed Layer A layer created for the Bleed Outline.

Bleed tool A tool that creates a Bleed Outline with optionally excluded panels and an
offset value.

Blend A tool that creates an arc to connect two lines.

Block A piece of wood or a font type for the name that is burnt into the die.

Board A heavy thick sheet of paper or other fiber substance usually of a thickness
of 0.006 inches or more.

Board Code A group of settings that tells ArtiosCAD about the material used to
manufacture the design.

Board Properties The characteristics of the board that is being used. The properties include
caliper (board thickness), costs, and test paper.

Bowtie A hole in the counter to allow for the cut section of a cut crease line. The
hole is shaped like a bowtie.

Boxboard Paperboard of sucient thickness to be used in the manufacture of
paperboard boxes.

Bridge The small areas left uncut in a jig or laser die for the purpose of holding the
die together.

Bridge Rule Path Applies the bridging formulas to each rule path and creates the appropriate
bridges.

Bridging The placement of notches in a steel rule blade so that the blade can fit into
it’s relative place in a dieboard.

Brightness Threshold A control (slider) that determines how much of the chosen color will be
vectorized in relation to the brightness of the color selected to vectorize. It
is used when auto-tracing bitmaps.

Browse To look for a file.

Build Rule Path Applies the rule path algorithm to the entire design and creates a
representation of the steel rule.
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Builder The component of ArtiosCAD which allows the user to create new designs
based on standards.

Building a command A message statement that informs the user that the digitizing command is
not yet recognized.

Burn Name A name to be inscribed by laser burn into the die board.

CAD-X ArtiosCAD ActiveX control, a library of calls that will enable ArtiosCAD
functions to be invoked from another program.

Calculated Expression The text that is generated automatically from a predetermined formula.

Calculated Text The tool that contains the options which affect the text (calculated
expression) that is generated when printing a report.

Caliper (CAL): The thickness of the type of board that is being used for this design.

CAM Device A peripheral (output device) which outputs using a driver other than a
Windows driver.

Carrier Rule A steel rule used to support the sheet to prevent snagging when there are
interior cutouts.

Case Expression An action that is performed when conditions are met.

Chamfer A tool that trims the edge of the counter with a gentler slope (except near
creases) than the periphery tool.

Chamfer Gap The distance between the inside edge of a chamfer and the crease channel
in a counter.

Check Condition An expression that limits the values that can be assigned to a variable (e.g.
L>0). It is used in modules like StyleMaker.

Chop Knife The steel rule in a die that is used to cut up the scrap into smaller pieces.

Class A category of the layer (main design, annotations, windows, cutouts, etc.).

Clear Extend A tool that removes the handle points created by the Extend tool on the
Extend/Measure toolbar.

Clearance The space or distance between two items.

Clip Graphics A tool to trim the extraneous part of a graphic away, by forming a clipping
path.

Clip Path A path (loop of lines) to cut along, by trimming the outside excess away.
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CloseUp A window showing a zoomed in view of the area surrounding the point
clicked.

Coating blanket A coating or thin layer of varnish used to protect those areas of the sheet
not to be coated as the sheet moves through the printing press. Also, it can
be called a varnish blanket.

Color Stock A tool that adds a uniform color to all panels of the board design.

Color to Vectorize An option which lets the user choose the Bitmap color that is converted to
lines and arcs.

Colored A tool which turns all hidden lines blue in 3D mode.

Compromise Factor The ratio of the distance from the cut to the counter periphery. It is used
when any cut and crease are too close together for the distances specified.

Conarc Construction arc. An arc which is often drawn to aid in the actual drawing of
the design.

Concatenate An option which links text together as a series.

Condition Composed of a type and the limit value for Cost Center expressions. The
condition can be changed by using a modifier.

Conline Construction line. A line that is often drawn to aid (guide) in the actual
drawing of the design.

Contrast The light/dark ratio (of graphics).

Control point A point of reference to control the drawing of the curve between the start
and end points. Two middle points are used as Control points in Beziers.

Convert Fills to Lines An option to change fills (fills of color) to print image lines. It also places
them in overlays whose names are the color of the fill. This option can be
used when importing an EPSF file.

Convert Strokes to
Lines

An option to change strokes (graphical additions to lines) to print image
lines. It also places them in overlays whose names are the color of the
stroke and the thickness of the stroke in points. This option can be used
when importing an EPSF file.

Corner angle sharpness
threshold

“The parameter for determining how close a pin, block, or rule will travel into
the narrow areas of the lower stripping board.

Corner Factor A parameter that determines whether a corner is sharp enough to be
considered the start of a new line.
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Corner relief The relief cut for a steel insert in a counter to make reverse creases or
reverse cuts.

Counter A special template made out of phenolic resin that aids in the production
of creases by providing a solid surface. It is used in folding carton
manufacturing.

Counter channel widths A check box that when checked displays the actual paths made by the
counter tools instead of just an outline.

Counter layout A module of ArtiosCAD used to make many counters at once.

Counter Mill Outline The outline of an area to be milled (cut out). It is used for reverse creases,
reverse partial cuts, or for embossing.

Crease A line indicating a fold in the carton or container.

Crease Channel Width The width of the channel crease in a counter, measured at the top of the
channel.

Cross Grain The direction perpendicular to the grain (fiber) of the board.

Cume Dimension A tool that displays the running total or accumulation of distances from a
known point to an endpoint. Cume is short for cumulative.

Curve Straight A tool that creates a curve followed by a straight line (defined by a start
point, end point, angle, and radius for the arc).

Cut A line indicting a cut, typically an outside edge or inside cut.

Database Electronic storage (a place) where the information about the design and
customer are saved.

Default The setting of an option (property, variable, tool, etc.) that is used unless
another choice is entered or the default is changed under Options. Also,
Defaults are baseline settings.

Delimited The separation of data by a comma or another item. This is a format option
for the Digitizer.

Design Checks A tool that checks the current design for double lines and gaps.

Detail A tool that allows selection of an area to be magnified. It also allows
placement of the window which will show the magnification, called the
detail window.

Device A tab or dialog box referring to an output mechanism (e.g. printer).
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Diagram A documentation plot (small sketch) displayed in StyleMaker or when
running a standard.

Diameter 2 * Radius, a measurement for a circle across the largest part.

Die Any of the various steel rules used to cut, crease, or perforate Boxboard
into a desired shape.

Die Cut A cut made in some soft to semi-rigid material with a cutting die.

Die Press A machine that holds and uses a die to cut material into pieces and parts.

Dieboard A hard plywood used as the carrier for steel rule dies (e.g. stripping knives,
balance knives, etc.).

Diecutter A person who is employed in diecutting or operating a diecutting press.

Diemaker’s Fix-it A group of tools that check the design for small abnormalities and give the
user the option of fixing them.

DieSaw A saw used to cut the routed groove for the insertion of the steel rule. A
Diesaw is used like a jig saw and has an attached drill to make starter holes
for the saw blade.

Differential Scale A tool that scales the selected items with different factors for horizontal
and vertical directions.

Digitize The process of transferring a design from a drawing or plot into a digital file
using a digitizer.

Digitizer An input device that normally consists of a flat tablet that the operator
traces over with a pen like stylus or another cursor device. The patterns
traced by the operator are automatically entered into the computer’s
memory for subsequent processing.

Dimension A measurement of distance, angle, radius, etc. displayed.

Distance A measurement from one point to another.

Double Knife Removal A tool used to remove any knives that are too close together on a dieboard.

Drag Color The color of the lines used to show the lines that will be created.

Drag Snap A snap feature for dragging the cursor (mouse) that lets the user snap to
specified angle and length increments. The cursor will round to the nearest
snap increment when drag snap is on.

Drill Hole A hole made by drilling up and down in a one step process.
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DWB Designer WorkBench, a CAD program.

Dynamic An option to automatically update the screen as values change.

Ear style A group of options for the style of the ears (special flaps). They are created
when running a standard with ears for a container or carton.

Edit To change, typically text or geometry.

Edit Tools Tools that help with the process of changing, deleting, coping, and/or
processing.

Elevation The vertical angle from which the design is viewed.

Ellipse A tool that creates a set of arcs forming a loop defined by a length and
width.

Embed dependent files An option to embed the files that the selected file is dependent on. This
option is in the information filter.

embedded design A design that has been embedded in another file (e.g. designs saved in
manufacturing files).

Emboss A technique for impressing a design or texture into a sheet of material from
the back of the sheet so that the design extends out towards the viewer.

Emboss Relief Width The width of the relief from the half crease (crease on one side of the
counter channel).

Enable subroutined
output

An option that refers to support subroutines in the NC (numeric control)
output. This option only works with the PUNCH command. Turning this
checkbox off combines all elements of the layout into one set of data on
output.

Enforced Check A check that must be performed in Advanced StyleMaker. Unlike a check
condition, an enforced check cannot be ignored.

DataCenter A program which makes finding specific information about ArtiosCAD
designs quick and easy by using a database structure.

Etch A thin partial cut made with a laser die cutter or a mill tool. Typically, it is
used for putting text on the die.

Export To bring a file out of ArtiosCAD in a chosen format.

Expression A mathematical statement.
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Extend To lengthen one geometry to meet another geometry (e.g. extend one line
to meet another line).

Exterior A grouping of choices to determine the type of tooling for the outside
(exterior) stripping of a dieboard.

External Varnish Offset The offset (distance) that the varnish is to extend beyond the design.

Fast Block A block type font that is designed to be burned into the die quickly.

Favor Horizontal An option for when rule paths cross in which the vertical rule is broken and
the horizontal rule is continued.

Favor Vertical An option for when rule paths cross in which the horizontal rule is broken
and the vertical rule is continued.

Fields Data fields (specified spaces for information).

File Window A window (pane) that displays pictures of flat designs, manufacturing files,
print items, and 3D files.

Fill A tool that fills or covers an area contained by a closed loop with the default
color.

Filter A method of sorting that uses selection criteria, typically it is used in
database searches or data selection.

Fix All A command to fix all of the problems that were found with Diemaker’s Fix-it.

Fix minimum To fit the sheet size to the minimum size defined by the die press or printing
press selected.

Fixed Point A point to which an item that the user is editing remains fixed (relative to).

Flat A style of ending a stroke in which the stroke ends at the same point as the
end of the object being stroked.

Flute (Corrugated) The wave shaped formation of the inner component of corrugated
fiberboard.

flute/grain direction An indication of fiber direction (horizontal or vertical). The normal direction
of flutes is parallel to the depth of the box, so that they are vertical when
the box is stacked for shipment.

Fold 1 to Meet A tool that changes the angle of a crease so that two lines meet.

Fold 2 to Meet A tool that changes the angles of two creases so that two lines meet.
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Fold All A tool that changes the fold angles of all the creases in the selected
design(s).

Fold Angle A tool that changes the fold angle of the selected crease(s).

Follow A tool that follows (parallels) the path of existing geometry with an optional
offset.

Freeform Editing An option that allows the user to make changes to the edit log commands
by typing over them. This option is for rebuilding the design and may affect
the rebuild of the design.

Freehand Coordinates An option which allows the user to snap to coordinates not on the grid.

Freehand Drag To move objects by clicking and dragging them. There are two groups of
tools to which freehand drag can be applied. The first group of tools is the
annotations, dimensions, and text for which freehand drag is on by default.
The second grouping is lines, arcs, beziers, etc.

Front waste The remaining front trim after all stripping has been done.

Front Waste Separator A tool that adds a separator to strip the waste from the lead edge of the
layout.

Function Key A shortcut key, a key which may be used to perform a task rather than
clicking.

Geometry Any item that is on a die press manufacturing tool. Dimensions,
annotations, and graphics are not considered geometry.

Geometry Macro A catalog of resizable shapes that can be added to the design. The shapes
are composed of common geometry (lines and arcs).

Gets Device size A tool that gets the size of the device for which the report is being made.

Ghosting Constraint The restrictions on how the layout of the sheet may be done based on
printing considerations, typically color sequencing.

Glue assist A type of perforation rule which partially cuts the board to assist in
embedding glue (similar to roughing a surface to hold glue).

Grain In paper making, the direction in which most fibers lie. Normally, the grain
corresponds with the direction that the paper travels through the machine.

Graphic A picture or logo to be added to the design(s).

Greeting A field in DataCenter used for the short name of a customer.
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Gripper fingers Metal fingers that clamp onto the board and control it’s flow as it passes
through the press.

Gripper Image A workspace that shows the placement of the gripper fingers that are used
to pull the sheet through the press.

Group A tool that makes ArtiosCAD treat more than one object as one object.

Group Layer Warning A warning about the layer that a group of items is in (e.g. a group of items is
not in your current layer).

Group Output Allows you to group (list) already defined (made) outputs to turn them into
one output.

Guillotine The piece(s) of wood that pushes out the external waste from the top and
side of the sheet.

Gutter The set distance between single designs in a layout of nested designs.

Half Crease (must form
loop)

To crease on one side of the counter crease channel.

Half Cross Grain
Channel Width

To adjust the channel width for the cross grain direction.

Hand Hold A hole in the dieboard to aid in handling/carrying and storing.

Handle Point A point used to grab and move an element. It can also be used to control an
operation (e.g. copy rotate).

Header slot style A group of choices for the slot style of a container. The choices are between
full cut slot, 3 sides cut, and crushed.

Hole Pattern A pattern of mounting holes in a dieboard.

Hook A J-shape that can be formed at the end of the stripping rule. A hook is
used to keep the stripping rule from moving in the dieboard.

HRMS/SCS transfer To send information from ArtiosCAD to the Harry Rohdes Management
System shop card server, a business system.

Image A picture or graphic.

Import To bring in a file or design from outside of ArtiosCAD.

Import as Graphics An option to import strokes and fills unchanged when importing EPSF files.

Infold perf and score The diagonal crease of the side panels to facilitate folding inward, typically
on a 4 or 6 corner tray.
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Information
Enhancement

An option to synchronize some fields between ArtiosCAD and DataCenter.

Inner Diameter
Subtype:

An input box that has a pull down menu that tells ArtiosCAD which
manufacturing tool to use to create a hole.

Inner pin to pin distance The density of pins in a large support or waste area.

In-Place Geometry Tool A special advanced geometry tool for Manufacturing that runs within the
context of the design (layout).

Inset count In rotary rule, the number of teeth to skip before removing the first tooth for
a bridge.

Inset distance: A user set distance for a bridge’s position from the end of the rule.

Inside Loss (IL): The distance lost on the inside measurement of a carton or container due
to a fold in it. This loss is attributed to the thickness of the material being
folded and the radius of the bend (fold) in the material.

Inside Side The side of a carton or container that will be on the inside when the carton
or container is folded, usually the unprinted side.

Intelligent Counters A module of ArtiosCAD which easily creates counters for most designs.

Intelligent Layout A module that performs automatic sheet layout calculation.

Interference Also called Power Stripping. The process of adding a little bump into the
outline of a hole. It is used to prevent things from clogging or jamming the
hole due to suction.

Interior A grouping of choices to determine the type of tooling for the inside
(interior) stripping of a dieboard.

Intersection Point The point where two geometries (e.g. lines or arcs) meet.

Invert Selection An option which selects only those items that are unselected.

Item reference tool A Diagnostic tool to display the full path name of an item on the design.

Jigged An option for creating a separator wood edge in manufacturing (I.e. to
create using a jig saw).

Join A group of choices about how strokes that meet are connected (e.g. join by
bevel).

Kerning The amount of space ArtiosCAD inserts between letters or text.
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Keypad A display of a keypad on the monitor to enter values, variables, and
expressions.

Land The space between the start or end of a zipper cut and the next intersecting
line.

Laser An output type which makes laser setup available. It is also a method of
manufacturing. It is also a line type subset.

Layer The separate levels of design information grouped by functionality (e.g.
Main Design, Dimensions, and Annotation).

Layout A design or multiple designs stepped and repeated one or more times.

Lead -> Trail bottom->top, an option to work the rule path from the bottom to the top of
the dieboard.

Lead edge The first portion of the blank to come in contact with the die.

Leader Hole A starter (pilot) hole in which to insert the diesaw’s dieblade.

Leader Hole Tools A set of tools for making starter (pilot) holes in the dieboard for the diesaw.

Length of Line A button on the keypad that allows the creation of a new line using the same
dimension as an existing line.

Library Functions Any predefined function (set of instructions).

Licenses The permissions to use a program or piece of a program. Certain
restrictions and responsibilities apply.

Light source A tool that changes the light source’s angle and elevation in the 3D Design.

Line - Gap Sequence A tool that turns a line - gap sequence into a line with bridges.

Line Type The category (type) of a line (I.e. cut, crease, partial cut, etc.).

Liner The non-corrugated part of the corrugated board, typically the inside and
outside of the board.

Localization The act of converting a version of software from the original language it
was developed in to the language and conventions of another country.

Lock style A group of options for the style of the lock (tab to keep the carton or
container closed). It is created when running a standard with a lock for the
container or carton.

Log Command An individual command in the Edit Log (Logfile) that is used in rebuilding
the design.
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Logfile The file of commands which were used to build the design. Also, a history
file containing the history of the designs that have been autoloaded.

LWD values cannot be
negative.

An error message meaning that length, width, and depth values cannot be
negative.

Main Design A layer for the design.

Make Counter An option that sends the Counter information in the Counter Layer to a file
which can then be interpreted by a samplecutter. A Counter is also called a
Matrix.

Manufacturing The module of ArtiosCAD that makes production tools from single designs.

Mapping The transformation from one set of attributes to another set of attributes
used when importing DXF files.

Measure Tool A tool that measures the length, angle, radius, and the x and y coordinate.

Medium The corrugated part of the corrugated board, typically the middle of the
board.

Merge Line Straight A tool that merges lines into a single straight line.

Mill To cut out or remove material using a milling bit.

Mill Hole A hole made by milling (cutting) up, down, sideways, and/or in a spiral
pattern.

Mill outline A line type to represent the area to be milled.

Milling Tool A tool that cuts an area or outline. It is like a drill, but has a sharp outer edge
(flute) to allow a horizontal moving cut.

Miter An option for joining strokes (graphical additions to lines) that makes the
inside and outside angles the same.

Mounting Bar A bar to mount the die wood to the die press.

Mounting Hole A hole to fasten the manufacturing tools to the press.

Move A tool that moves a selected item.

Name Tool A tool that etches an identifying label into the counter.

Nest A tool that takes a single design and steps and repeats it tightly. Nesting is
used to serve as a pattern for die making.
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Nick A little piece of material connecting individual items that doesn’t get cut in
order to keep the sheet together.

Notch A cut (notch) in the dieboard edge for registration and to help line up the
dieboard and machine.

Number Expression A text string comprised of numbers, called number text. This type of text
can be used when editing an expression in Advanced StyleMaker.

Number up The total number of times that a certain design is on the layout.

Oblong Hole A hole stretched in one direction.

Off the Counter An option referring to lines, cuts, and creases not being on the actual
counter (I.e. when the shape of the counter does not include these lines.)

Offset A spot or point that is displaced, or offset, with respect to another point.

On center of tooth An option to have bridging start in the middle of a tooth on a rotary rule.

Oneup A single design that is part of a manufacturing layout and is usually used for
creating multiple or nested designs.

Open-out A small slit cut in the corner of a rubber piece that allows it to open flat in a
rubber layout for better nesting.

Optimize A process to make a method/selection (e.g. lines or rules) ecient. It is
used in Double Knife Removal, Counter Cutting Order Tool Path, etc.

Out from die split An option to work out from the edges of the die split when ruling a rotary
dieboard.

Outfold perf and score The diagonal crease of the side panels used to facilitate folding of the
panels outward, typically on a 4 or 6 corner tray.

Outline Text A tool that converts text into print image lines.

Output The function in ArtiosCAD where reports, documents, samples, and data to
drive the equipment is produced.

Output Layer A layer that is a composite of the layers that are turned on. This layer is
used for inspecting and editing the output.

Output to Layer To output to a specific (chosen) workspace/design layer.

Outside Gain (OG) The distance gained on the outside measurement due to a fold in a carton
or container. This gain is attributed to the thickness of the material being
folded and the radius of the bend (fold) in the material.
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Overrun Finished product quantities created in excess of the specified quantity.

Overwrite To replace a file or something that already exists.

Pane A window.

Panel A side of a box.

Parametrics The technique by which a design is defined by equations based on some
independent variable and is used when rebuilding a design.

Peripherals Auxiliary physical devices connected to a computer system (I.e. plotter,
printer, and mouse).

Periphery The edge of the counter.

Periphery Tool A tool that cuts out the counter with a beveled edge.

Perspective A tool that changes the amount of perspective (depth and width) in the 3D
module.

Playback Tool A tool that rebuilds a design step by step while looking at the sequence of
the design as it is rebuilt.

Plot A type of output in ArtiosCAD, typically a large printout.

Plotting Style The appearance of the graphical attributes of all objects. A description of
the way that various types of lines are being represented.

Pointage The thickness of rules and lines.

Post Run Geometry Tool A tool to modify the current manufacturing die board.

Power stripping Interference, the process of adding a little bump into the outline of a hole so
that the waste stays where it is supposed to and doesn’t come back into the
press.

Press A machine which performs the mechanical action of diecutting or printing.

Previous Fold Angles An option in 3D to fold the design using the angles by which the design was
last folded.

Prompted text A type of text inserted into a report to have the report prompt you to fill that
text in each time the report is printed.

Prompted Variable A variable that the user is asked to enter a value for. Prompted variables are
used in Reports and Cost Center.

Properties The attributes or characteristics of an item.
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Property Defaults Typically startup items, they can change properties of an object during a
program session.

Property Page The page or window that displays the characteristics of a selected item.

Punch drivers Software routines that control the punching out of material during the
diecutting process.

Push Pins A tool for stripping, usually metal, used to push out waste.

Pusher active part The top piece of a push pin which actually pushes the material away.

Pusher base The base of the push pin which is set into the dieboard.

Pusher clearance The distance that a push pin is from any other object.

Pusher shoulder The larger part of the push pin that keeps the push pin in place by not
letting it fall through the die board.

Radius Sweep The value of the angle an arc travels through. Half of a circle would be 180
degrees, and a quarter of a circle would be 90 degrees.

Rebuild A tool that allows the building of a design that is based on variables so that
it’s size can be changed.

Rebuild Conflicts A dialog box that warns of design problems that arise while rebuilding a
design.

Rebuild Expression Tree A command button to update a conditional statement. It is available in
Advanced StyleMaker after editing the Current Expression dialog box.

Rebuild Playback A tool that rebuilds a design step by step while looking at the sequence of
the design as it is rebuilt.

Record A collection of related data items used in DataCenter.

Recovery Options A group of choices on how to proceed with recovering a design after
Rebuild (Design) has failed.

Reference Point A point of origin.

Refresh To redraw the active view.

Registration Hole Mounting hole, a hole to fasten the manufacturing tool to the press.

Registration Marks Marks where a registration hole will be made

ReInit A function that resets a variable to its default value in a design

2207



17 ArtiosCAD

Term Definition

Reinit All A function that resets all variables to their default values in a design

Relief Profile The shape of the relief (extra cut out material) to be used to avoid squeezing
the carton or container as it is pressed against the counter.

Relief Slot Base The width at the bottom of the relief (extra cut out material) slot for ending
a crease in a counter.

Relief Slot Opening The width at the top of the relief (extra cut out material) slot for ending a
crease in a counter.

Relief Slot Overcut The distance between the end of the crease and the relief slot bottom. The
relief is extra cut out material.

Report A form with pictures of workspaces along with information about these
workspaces.

Report Maker A module that allows the user to create customized reports.

Reset A command that sets values back to their original values (usually 0).

Resource A directory tied to the database.

Rotary A checkbox in manufacturing that informs ArtiosCAD that rotary rule is
going to be used.

Rotary Rule A rule that is built curved to be used on a rotary die press.

Round Limit The accuracy with which to round. It is used to set the accuracy for the
rounding function.

Round slot method A method of dealing with sharp corners, so tearing doesn’t occur.

Routed An option when cutting a sample counter to route (grind away the material
in) the crease channel.

Rule A steel blade on the die board which can create a variety of lines on a sheet,
including cut and crease lines.

Rule Mapping To map a particular rule size and type of your preference to a custom rule.

Rule Path The groove that the rule follows in the cutting die.

Run a Standard Loads a previously designed ArtiosCAD rebuildable design.

Safe separation The minimum distance two lines must be from each other to be ruled
individually.

Sample A prototype (sample) for customer approval.
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Samplemaking tool A tool to cut a prototype (sample) for customer approval.

Save As Revision A command that saves the active document as a new revision.

Scale To change the size or proportion of an item.

Scallop A rule type describing the scalloped shape of the rule. It is used to perforate
a carton.

Scrap Waste, extra material of no use.

Scrap rule Also called chop knives, a steel rule used to cut up waste into small pieces.

Scrapped overrun The extra items (e.g. cartons or containers) which the customer will not
accept.

Send to Back A tool that places the selected graphic behind all the other graphics.

Send to Front A tool that places the selected graphic in front of all the other graphics.

Separator Board Tooling to remove the front waste or trim.

Shared defaults The defaults used (shared) by all the users who use the same ArtiosCAD
server.

Sharp angle threshold The parameter for determining how close a pin, block, or rule will travel into
narrow areas of a lower stripping board.

Sheet The raw material placed into a die press to be made into the final product.
Also, it describes the individual piece (sheet) of container or carton board.

Side bevel A type of cut rule that creates a bevel. More specifically, the serrated or
flat edge cut rule that has points or flats to one side of the cross section as
opposed to having points in the middle.

Single pass creasing A process in which the creasing tool passes over the material once to make
a crease.

Size Threshold Sets the size limit of items to vectorize.

Slot A cutout in a carton or container. In Manufacturing, when representing the
Die, the word slot refers to an option for the user to specify a nonstandard
width (pointage) for the slot where the rule will be placed.

Slot style A group of options for the style of the slot (opening or indent for a tab). It is
created when running a standard with a slot(s) for the container or carton.

Smooth Corner
Parameter

A parameter that determines whether a corner is sharp enough to be
considered the start of a new line.
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Smoothing Threshold Controls the jaggedness of the new lines created when vectorizing a
graphic.

Snap An option that allows an exact placement of an object by set proximity.

Special Rule A specialty rule or extra generic rule that has been defined by the user.

Split Line A tool that separates a line at a point.

Split Rule Path A tool that separates the specified rule path.

Standard A box or folding carton design that is rebuildable and is located in the
standards catalog.

Status Bar A bar located at the bottom of the window where information that is
pertinent to the user is displayed.

Step Distance The distance between echelon rules.

Stock Color The uniform color for all panels of the design.

Stop Bits The last bit of framing for a byte of data, in asynchronous serial
communication.

Straight Curve A tool that creates a straight-curve by end point, angle, and radius.

Straight Nest To nest (step and repeat a single design) without losing the orientation of
the design (I.e. without rotating the design).

Straighten A tool that replaces an arc or bezier with a straight line

Stretch Point Moves a point and the lines, arcs, and beziers ending at the point

Strip rule A steel rule that cuts waste into smaller pieces for easier removal. It is also
a rule that aids in the removal of scrap during the manufacturing process.

Stripping The removal of all scrap material from a cutting die.

Stripping board A board that performs the removal of waste.

Stripping Edge The working area in which to place the stripping rule.

Stripping pins Pins that are made of a base, shoulder, and active part. They are used to
push out waste (scrap material).

Stroke Adds a ribbon of color around the edge of a line (graphical addition to a line)
or group of lines selected.
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Structural Orientation A dialog box to set or change the side of the design, the grain/flute
direction, and the die side.

Style A grouping of choices as to how something is done or represented.

Style Catalog An organization mechanism (catalog) for styles also called Standards.
Standard carton and container designs are stored in defaults.

StyleMaker The module of ArtiosCAD that allows the user to make rebuildable designs.

Subtype Mapping A way of differentiating rule or line types (mostly for manufacturing).

Support Bar The bottom support(s) for the lower stripping board.

Support Holes Holes by which the support bar is attached to the bottom stripping board.

Support Pins Pins that consist of a base and a shoulder. They are used to hold up the
block (wood block and guillotine).

Symbol A graphic or graphic file in ArtiosCAD.

Synchronize A command to bring the data in ArtiosCAD into agreement with the data in
DataCenter.

Tack Bridge A small gap in the edge of the material being cut to help hold it together.
For example, a tack bridge in the wood die is used to keep the waste pieces
from falling out into the laser bin.

Tack Bridge in Bowtie A gap in the periphery to hold the bowtie while the counter is being cut.

Tangent tolerance The number of degrees between two tangents. It is used to determine the
best sequence of cutting.

Taper Used to mean angle, the angle used to taper off the reverse crease in a
counter.

Tear angle The smallest angle allowed before considering that a fracture or rip may
occur at that angle, which could require changing the sequence of cutting.

Tear distance The smallest distance allowed across a small piece of material at a
specified distance from the end of the material before considering that the
material may rip or fracture, which could require resequencing the cutting
order.

Template A pattern that is used to assist in formatting data (e.g. a filename template
used for building a list of files).

Text Library Function An ArtiosCAD command file that returns a text variable.
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Text Position The position of the text on a design.

Thumbnail With reference to images, it is a smaller version of an image used as a
preview.

Tile To split a drawing (output) over one or more pages, when it is larger than a
page or after it has been scaled to a size larger than a page.

Toggle To switch back and forth.

Tolerance for gaps Used in design checks, it defines the maximum gap that will be ignored
when finding the perimeter of a design.

Tooling Anything physically made from the manufacturing process or CAM output.

Trailing Being the last thing following a path with regards to rule path direction.

Trim To shorten a line against another line.

Trim Against Selection A tool that shortens or extends a line or arc against the selection of
another.

Trim Interior A tool that cuts out the interior section between two other geometries (e.g.
lines).

Trim/Extend One Line A tool that shortens or extends a line or arc to meet another line or arc.

Trim/Extend Two Lines A tool that shortens or extends two lines to a corner.

Tune File A file containing parameters that modify and control the way a driver
produces data or an import process interprets data.

Underrun Number of finished products less than the specified quantity required.

User Defaults The settings under defaults that the user has established.

Userfield Customizable fields for designs and manufacturing files that can contain
almost any kind of information.

Value A quantity that is associated with an item.

Variable A character or a string of characters up to six, representing a quantity
whose value can be altered (changed).

Variable Conflicts A dialog box that informs the user that there are problems because of illegal
actions on variables. These problems are usually caused by moving or
deleting variables that have dependent relationships.
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Varnish A thin, protective coating applied to a printed sheet for protection or
appearance.

Varnish Layer The layer where the varnish is applied.

Varnish tool A tool that creates varnish outlines of selected panels, with separate
internal and external offset values.

View Angle A tool that changes the angle and elevation at which a design is viewed in
ArtiosCAD 3D.

View Mode A tool that controls the choice of what is shown (lines, graphics,
annotations, etc.) and the representation (plotting style) of how it is shown.

Wave A rule type describing the wavy shape of the rule. It is used to perforate a
carton.

Wood block Any piece of wood used to push out waste during interior stripping.

Wood Edge The outside edge of any board, the outside geometry of the tooling.

Workspace A generic name for design files and/or the current design/work area.

Zigzag A rule type describing the zigzagged shape of a rule. It is used to perforate a
carton.

Zipper A rule type describing the zippered shape of a rule. It is used to perforate a
carton.

Zoom In To increase the magnification from the center of the selected area.

Zoom Out To decrease the magnification from the center of the screen in order to
increase the viewing area.
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