ArtiosCAD 20 Release Notes

Visit ArtiosCAD news...
https://www.esko.com/lp/artioscad/artioscad-news
-or-
Navigate to Help > ArtiosCAD News after starting ArtiosCAD

What’s new in:

- **Design**
  - Variangle knife support
  - Select tool shortcuts
  - Mate tool improvements
- **3D**
  - Autobottom mates
- **Layout**
- **Manufacturing**
  - Counters
- **General**
- **Infrastructure**
- **Integration**
  - CAPE
- **View**
- **Enterprise**

Problem fixes

Important notes for all users

What’s new?

Design Enhancements
- Variangle knife support for table cutting of re-board and other thick materials with multiple v-notch angles.

Generic V-notch line types have been added that can be defined in angles from 0 to 60 in increments of ½ degree to support the Kongsberg Variangle knife. Generic v-notch types include cut, crease, reverse cut, reverse crease.

The angle can be changed in the design stagebar.

This line type allows more than the 39 special rules allowed in a design today. The use of special rule V-Notch types has been preserved and files created with these special rule types are forwards compatible.

V-notch designs may be converted to 3D.
ARDs with the generic V-notch type can be pushed to iPC via the iPC output.

ACM based Samplemaking is **not** supported for this version.

- **The mate tool** user experience has been significantly improved.
  - For cartons that need to be glued onto themselves, the mate tool will now automatically recognize mates areas that can be recognized and mated in 3D. This means for 4 panel sleeves, mates within the glue tab and a target area on the 4th panel will automatically appear. For autobottoms, mates will automatically appear on the foldback flaps and the corresponding target flaps.
For other cases placing mates across different parts for pop up cards, foam pieces and certain types of standalone displays with glue tabs that can’t be recognized but could be mated, the user can use the mate tool to select a mate area and then immediately place a target area while tool is still active.

- **Canvas layouts now:**
  - Honor the side of the parameter set when converting a layout to mfg
  - Mirror the oneups in a layout when canvas side changes. If the grain changes, the oneups do not rotate but a visual cue is presented to the user indicating as such
• The Grain, Print and Cut side icons have been separated into their functionality to allow the user to change the structural aspect and view.

• Select tools are now allowed as shortcuts.
• The **part order of a canvas** may be user-determined for an output. When a canvas design is open, the user may navigate to Parts > Parts Outputs > *Output* and rearrange the part order for output by dragging and dropping below another part.

• **The board dialogs** are now resizable and persist.

• **Resizable Design Templates (RDTs)**, aka, standards, for Fefco and ECMA have been updated in the ArtiosCAD style catalog. Updates will be an ongoing endeavor and new styles will be added in future releases.
Navigate to Options > Defaults > Style Catalog > Resizeable Design Templates

See <Artios folder>\<version>\Instlib\<library>\Documentation for xls files that describe how the RDT was constructed.

Example: C:\Esko\Artios\ArtiosCAD20.0\InstLib\ECMA\Documentation\ET_A20.20.01.01_.xlsx

Geometry macros which were used to construct the RDTs have also been added.

See <Artios folder>\<version>\Instlib\Geometry macros\<library>\Documentation for xls files that describe how the geometry macro was constructed.

Example: C:\Esko\Artios\ArtiosCAD20.0\InstLib\Geometry macros\ECMA\Documentation\EGM_A20_21_30_Cover_Tuck_flap_Bottom.xlsx

All previously released standards have been rerelease with improvements to the standard. These files are installed in the instlib directory in disk and will not replace any in ServerLib or ClientLib. The standards should be evaluated before considering moving them outside instlib for access by your designers.

**3D Enhancements**

- The user can convert to 3D, Mate All and create a mated (glued) autobottom which can transition from an open state to a knocked down state.
The user can use **3D** to identify the copy and copy free areas of the autobottom for Artwork panels.

**Layout Enhancements**

**Manufacturing Enhancements**

- **Counters User-Experience has been enhanced**
  - An ARD that has a phenolic/plastic counter can now easily convert it to a counter layout with the same name as the ARD.

- When rebuilding the chamfer, the tool simply performs the operation and the user is no longer asked to clear the counter.
• When in a counter layout, the view mode allows counter channel widths to be visible.

**General Enhancements**

**Infrastructure Enhancements**

**Integration Enhancements**

• Default options to specify default CAPE style and material for palletization now exist
• CAD data can be passed back to CAPE for cloud reporting when creating a palletization solution Pallet Group or Arrange/Design Group in 3D. Defaults can be configured to preseed various values.

Or the values can be entered at the point the solution is created.
Since this feature starts in 3D and the enterprise edition provides for an attribute category for 3D documents whereas the standard edition does not have 3D userfields, the enterprise edition allows calculated expressions to be selected from a dropdown. The standard edition does not.

Cape 20 is required to process these fields and send to a report.

- Database information dialogs have been extended for Canvas. These are configured in: Defaults > Design Defaults > Database > Database Information Dialog Customization for standard edition and Defaults > Database Defaults > Database Information Dialogs for enterprise edition.

An example of standard edition:
Enterprise

- ArtiosCAD now has an option to specify how an unmanaged file may be saved to a project in the browser rather than from where the disk (unmanaged) location it came from.

A Save As will now set the default location to Recent Projects so the user does not have to scroll all the way from the Explorer node section to the Projects sections.
• **ArtiosCAD** will now allow *project attributes to be specified by the user* when creating a new project from a template with enterprise. The WebCenter 20 is required and Template > Configure > Project Creation > Show *attributes* must be set.

![Create New Project](image)

• A structural design, initiated as a result of a task assignment, and saved over the placeholder *task document* will assume the attribute category of the placeholder task document. The new version will inherit the attributes values of the placeholder document.
• **ArtiosCAD Enterprise client and WebCenter interoperability:**
  - ArtiosCAD 20 may be used with WebCenter 20. WebCenter 20 is required for full functionality.
  - ArtiosCAD 20 may be used with WebCenter 18.1.1 except for project autonaming with project attributes
  - ArtiosCAD 18.1.1 may be used with WebCenter 20

**Problem fixes:**

<table>
<thead>
<tr>
<th>Customer reported fixes</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACAD-3208  Linienprobleme mit pdf</td>
</tr>
<tr>
<td>ACAD-7122   Rotation Angle Error</td>
</tr>
<tr>
<td>ACAD-7217   Bleed acting not correct with matrix crease</td>
</tr>
<tr>
<td>ACAD-7348   Artios – output iPC</td>
</tr>
<tr>
<td>ACAD-7351   BUGREPORT: ArtiosCAD crashes when opening complex 3D file</td>
</tr>
<tr>
<td>ACAD-7429   Report outputs flips the layout the wrong way when the report and output specify a side other than the design</td>
</tr>
<tr>
<td>ACAD-7502   Crash in collada import</td>
</tr>
<tr>
<td>ACAD-7535   Rule labels do not show for layout and embedded design in the same report</td>
</tr>
<tr>
<td>ACAD-7555   Geo-macro not working if line type label</td>
</tr>
<tr>
<td>ACAD-7563   ArtiosCAD 18.1.1 crashes when closing projects</td>
</tr>
<tr>
<td>ACAD-7575   18.1.1 Artios Cad keeps freezing (HF for 18.1.1)</td>
</tr>
<tr>
<td>ACAD-7615   Printer Output – Graphics layer problem (HF for 18.1.1)</td>
</tr>
<tr>
<td>ACAD-7616   PDF with report output fail (HF for 18.1.1)</td>
</tr>
<tr>
<td>ACAD-7628   Dimensions cont converting to fractions to decimal in PNG output</td>
</tr>
</tbody>
</table>
ACAD-7632  Bug Report: Add Bridge tool Different bridge ssize dialogs doesn’t respect choice “Change the old bridges to the new size”.
ACAD-7687  Apply hatch crashes ArtiosCAD
ACAD-7699  Strip area – Upper External blocks - issue
ACAD-7737  Artios CAD – won’t allow him to “hatch”
ACAD-7741  (Enterprise) ArtiosCAD – Publish Revision/Version Screens Cut Off
ACAD-7744  Artios – Getting unable to run the standard after upgrading
ACAD-7748  ArtiosCAD problems when exporting PDF
ACAD-7794  Corrupted DS2 File
ACAD-7797  ArtiosCAD 18 some standards are not working anymore
ACAD-7799  Problem when 2 layout windows in same report
ACAD-7808  ArtiosCAD CAD-X integration – XXXXXXXX is failing on second ArtiosCAD selection
ACAD-7845  Export -> Send to ArtiosCAD crashes ArtiosCAD Enterprise
ACAD-7857  Geometry macros with special characters in the menu name split each variable to a new menu
ACAD-7910  3D shows crease as cut, if…
ACAD-7916  Steel counter uses the radius values as the land value for the channel end
ACAD-7967  Crash on output

**Important internal fixes**

ACAD-1944  Distances from Cut & Distances from Crease for Mate tool not working
ACAD-2350  Counter tool and Shorten creases do not respect "W factor
ACAD-4764  v-notch facelet does not render properly
ACAD-4825  Project Bar BOM node not automatically refreshing
ACAD-6018  Problem with 3D V-notch folding
ACAD-7046  Import standard as new part gets different results when using formula or value options
ACAD-7101  When browsing to select a new filename for a parameter set, default to ZIP extension instead of ARD
ACAD-7202  File crashes on PDF output
ACAD-7213  Enterprise – ProE and STL files have wrong extension when exporting to another format
ACAD-7273  Tab n slot mate fails to maintain orientation when converting to 3D from canvas
ACAD-7312  Crash in preflight (limits testing)
ACAD-7350  Crash in tear-away tool
ACAD-7358  Canvas > layout > allow output to iPc to contain mfg file in zip if canvas active part is layout
ACAD-7373  Analyze issue w/ GPX customer
ACAD-7404  (Pre release) Stripping component is placed twice on external slots
ACAD-7406  (Pre release) Stripping block cannot be created with desired offset
ACAD-7409  Option to not base resetting of sheet size on unknifed diecut, but first knife
ACAD-7415  ArtiosCAD – Canvas – Renaming Part Name to a long name crashes ArtiosCAD
ACAD-7421  (Pre release) Lower stripping board output ignores holes when the modifier lines cross multiple times
| ACAD-7422 | (Pre release) Lower holes are not created correctly |
| ACAD-7435 | UX > CPF Scan > Double knife fix-it splits longer line rather than remove shorter double line |
| ACAD-7437 | Rubber missing slots |
| ACAD-7438 | Canvas layout ? When in isolated mode, parts of adjoining layouts can incorrectly be selected |

| ACAD-7466 | Failed to create stripping for this file |
| ACAD-7468 | ACAD- I can’t publish a file from ACAD (conventional) to WCR |
| ACAD-7472 | Canvas not rebuilding Resizable Design Templates with embedded designs |
| ACAD-7476 | Upload boards doesn’t work on ArtiosCAD Enterprise 18.1.1 (fix in main should carry to 18.1.2) |
| ACAD-7481 | Can’t move part to empty layout in canvas |
| ACAD-7483 | ArtioCAD – Formatting of ‘0’ when in Inches shows trailing zeros |
| ACAD-7501 | Workspace layer output from grouped output does not add layer to part |
| ACAD-7532 | Tear-a-way Animation issue with multiple 3Ds (crash) |
| ACAD-7548 | (Pre release) Crash in rubber creation |
| ACAD-7742 | (Pre release) Slot rubber missing on this file |
| ACAD-7743 | (Pre release) Crash generating rubber |
| ACAD-7629 | Crashes setting variable value (after changing focus) |
| ACAD-7689 | 3D panel mate issue w/ parametric parts and rebuild w/ unit switch |
| ACAD-7700 | Creating a layout or converting to MFG from a file/part with a very long name does not truncate item text correctly |
| ACAD-7793 | EcadX – Adding managed design to layout locks it |
| ACAD-7852 | iPC > Samplmaking > CADCore > join cuts across oneups |
| ACAD-7859 | Hatch legend (See WCR-40485) |
| ACAD-7863 | Canvas > import rebuildable > use expression |
| ACAD-7927 | (Pre release) Recalc all does not generate rubber for this file |
| ACAD-7948 | ArtiosCAD - Design with line type “Second height partial cut crease” (255) fails to convert to 3D |
| ACAD-7912 | U3D exports lose special characters in 3D view names |

**Important Notes for All Users**

- Starting with 18.1.1, ArtiosCAD introduced preflight with some automatic corrections. One of these auto-corrections included the ability to remove double knives/lines. The preflight correction ability resulted in an algorithm that now favored longer lines over shorter lines, as a way to make better technical designs. Previously, shorter lines were favored. Rebuildable designs have been encountered where “double knife” removal was used as a design technique to create slots for example of small cuts lines over creases. This has caused some issues where item references which might have existed before are now being deleted during the double line removal step and causing rebuilds to be incorrect or fail. This technique was not anticipated. ArtiosCAD is restored some of the rebuild issues and is still working through others.
• **PCIQ fonts** will be removed after ArtiosCAD 20. Please use true-type fonts.

• The **Artios** (introduced circa 1996 as a transition to ArtiosCAD) and **DBH** (the original interact format) file formats and use of the **devtab** as a configuration file for communicating with printers and ports are considered **obsolete** and support for them will be removed in post 18 versions of ArtiosCAD.

• **Exports** under File > Export > ArtiosCAD 3.2x and lower will be removed in post 18 versions of ArtiosCAD.

• Esko now provides a **knowledge base** at [http://help.esko.com/knowledgebase](http://help.esko.com/knowledgebase). This site can be used to find detailed information for ArtiosCAD and other Esko products about many support questions raised to Esko.

• **Flexnet** is the only licensing system utilized in ArtiosCAD. Users must be prepared to convert the licensing from the hardware key, Sentinel LM or Elan LM to Flexnet. As of Jan 2016, Esko will no longer be able to provide licenses for legacy licensing systems.

• If the deployed licensing for ArtiosCAD is a **network license**, the license server *must* be updated with the new system controller provided on the installation media.

• **Esko software** can be downloaded from [https://mysoftware.esko.com](https://mysoftware.esko.com) with a valid support account.

• **User documentation** and help will be available from an online Esko site. Documentation will not be available from the media. The main site is [http://help.esko.com](http://help.esko.com) from which ArtiosCAD and other Esko product documentation is available. The ArtiosCAD help menu will bring the user to the ArtiosCAD help page.

• The most current Adobe®Illustrator® Esko plugins can be found at [http://www.esko.com](http://www.esko.com). Navigate as described below.
• Windows 10 editions has been certified for use with ArtiosCAD 18.1.1 as a standard mouse-controlled application. There are some installation limitations. See https://wiki.esko.com/display/KBA/KB174658159%3A+ArtiosCAD+-+Install+Standard+Edition+with+Database+on+Windows+10
  ○ There are Metro GUI limitations:
    ▪ The application folder structure organized in previous versions of windows 8 has been flattened. There will be multiple application tiles.
    ▪ There is no support for touchpads nor touchscreens and any use of gestures is purely coincidental.

• The IOServer (ArtiosIO) is now supported on Windows 7 and higher since Artioscad 14.1. This means older DataTech plotters still using the IPC controller or any device with an RS232 connection will be supported

• Many users have or are planning to deploy Citrix, Terminal Services (TS) environments or some other application hosting system. Esko has not officially certified ArtiosCAD for use in a Citrix or TS environment, however, Esko does not prevent its use as long as the customer accepts responsibility for deployment and support of the environment.
Esko has verified that ArtiosCAD 20 can run as a Citrix or Terminal Services client and has licensed ArtiosCAD 20 appropriately, however, there are some limitations, *including but not limited to*:

- Flexnet network licensing must be used.
- License reservation or denial via floating license servers is not supported.
- Graphics cards are installed on a Citrix or TS server and ArtiosCAD 3D uses the server card for 3D rendering. The performance of many concurrent 3D users is unknown.
- The exact server specifications (example, memory, processor) for a given set of clients is unknown.
- There are essentially no user defaults, since every Citrix or TS client is running from the same Citrix server.
- There have been reports that access to local devices like hard drives or printers can freeze the machine. It is unknown if these issues have been addressed in newer versions of Citrix.
- The HASP key used for the Alma PowerNest software in the ArtiosCAD rubbering layout can not be recognized by Citrix or TS and must be used on a client not connected to the Citrix server.
- 64-bit Citrix has not been tested in any way.

- Many users are planning to deploy VMWare ESX-based solutions, Hyper V (Windows Server Virtualization), Citrix XenServer or other hypervisor technology. Esko has *not* officially certified ArtiosCAD for use in this environment, however, Esko does not prevent its use as long as the customer accepts responsibility for deployment and support of the environment.

- **Artioscad 20 has been certified for VMware Fusion v7.** The customer may run later versions of his own accord on hardware and OS of his choosing, but Esko provides no warranty of the resulting combination. The preferred 3D rendering mode is OpenGL but use Direct3D in the event of unforeseen issues. Virtualized 3D rendering will not provide the same performance as native hardware.

- For native windows applications, the **3D Rendering Option is recommended to be set to OpenGL for full 3D functionality.** Use of OpenGL for Bitmaps should also be enabled.

- **3D graphics cards...** newer computers often come with some form of switchable graphics technology. This means that there are two or more video cards that switch off doing rendering duties on the system. Because of this, it is entirely possible that ArtiosCAD will be run using the low end, power saving chip. This drastically lowers performance, and may introduce issues when working within ArtiosCAD 3D. It is sometimes also possible that the current chip changes, which can lead to all sorts of stability issues. It is recommended that the user go to the control panel controlling the graphics cards (NVidia Control Panel or AMD Catalyst Control Center) and create a profile for ArtiosCAD so it will use the high end chip always.
A number of rendering issues with NVidia cards and openGL have been raised. Changes were made to what is believed to be an improvement in the error handling of newer NVidia cards particularly those with dual graphic cards.

- Since its inception, Artioscad has provided a database schema that has always been backwards compatible with previous versions of Artioscad and 3rd party applications. An ArtiosCAD enterprise edition has now been released and utilizes a new database backend (WebCenter). It is expected that the database functionality for the conventional ArtiosCAD edition will be frozen at its current level. New design functionality will continue to be added. It is expected that a single database edition will be created in the future.