# Contents

1. Copyright Notice ................................................................................................................. 4
2. Overview of a WebCenter Installation .................................................................................. 6
3. Hardware and Software Requirements .................................................................................. 7
4. WebCenter 12 Installation Tips ........................................................................................... 10
5. Pre-Installation Steps .......................................................................................................... 11
6. Installing WebCenter ........................................................................................................... 14
   6.1 Overview of the Installation Procedure ............................................................................. 14
   6.2 Install SQL Server 2008r2 Express Edition on the Database Server ................................. 15
   6.3 Install the Application Server Components .................................................................... 16
       6.3.1 Install ArtiosCAD on the Application Server .............................................................. 16
       6.3.2 Activate the Licenses ............................................................................................... 18
       6.3.3 Install the WebCenter Application Server ................................................................. 18
   6.4 Run the Database Schema Scripts on the Database Server .............................................. 21
   6.5 Install the Web Server ..................................................................................................... 25
       6.5.1 Install IIS on the Web Server Machine ..................................................................... 25
       6.5.2 Extend the Upload Limitation .................................................................................. 28
       6.5.3 Enable 32 Bit Applications ....................................................................................... 28
       6.5.4 Install the WebCenter Web Server ......................................................................... 29
       6.5.5 Update the MIME Types in IIS ............................................................................... 31
   6.6 Start the WebCenter Services .......................................................................................... 32
       6.6.1 Start the WebCenter Services on the Application Server .......................................... 32
       6.6.2 Start the WebCenter Services on the Web Server .................................................... 32
       6.6.3 Easily identify when WebCenter is ready to access .................................................. 33
   6.7 Install the On-Board Graphics Engine (OBGE) on the Application Server ...................... 33
       6.7.1 Install the Prerequisites ............................................................................................ 33
       6.7.2 Install the OBGE ...................................................................................................... 34
7. Testing WebCenter ............................................................................................................... 36
8. Configuring WebCenter ....................................................................................................... 37
   8.1 Configure the OBGE ....................................................................................................... 37
       8.1.1 Create a Container .................................................................................................... 37
       8.1.2 Create a JDF Hot Folder for WebCenter .................................................................... 38
       8.1.3 Improve the Performance of View Data Generation .................................................. 40
   8.2 Configure E-Mail Notification .......................................................................................... 41
       8.2.1 Log On to WebCenter and Change the Admin Password ......................................... 41
       8.2.2 Configure E-Mail Notification ................................................................................... 41
8.3 Configure WebCenter for Use with ArtiosCAD Enterprise ............................................................ 43
  8.3.1 Configuring BLOBs .............................................................................................................. 43
  8.3.2 Step 2 - Running the Board Importer Batch File ................................................................. 44
  8.3.3 Step 3 - Loading the Esko ArtiosCAD Defaults ................................................................. 45
  8.3.4 Configuration in the WebCenter User Interface .................................................................. 46
8.4 Secure the WebCenter Web Server with SSL ............................................................................ 46
  8.4.1 Obtain an SSL Certificate .................................................................................................. 46
  8.4.2 If the Web Server is on a Windows Server 2003 Machine .................................................. 47
  8.4.3 If the Web Server is on a Windows Server 2008 Machine .................................................. 50
  8.4.4 Install Certificates on the Workflow Production Server ................................................... 52
8.5 Install Certificates for LDAPS on the Application Server ......................................................... 56
8.6 Integrate WebCenter with a Workflow Production Server ....................................................... 61
  8.6.1 Understanding WebCenter Integration ............................................................................... 61
  8.6.2 Integrate WebCenter with a Workflow Production Server ............................................... 61
8.7 Expose WebCenter to the Internet ............................................................................................ 65
  8.7.1 Register a Domain Name .................................................................................................. 65
  8.7.2 Contact Your ISP to Set Up an A Record ........................................................................ 65
  8.7.3 Move the Web Server Inside the Demilitarized Zone (DMZ) ............................................ 66
  8.7.4 Configure IIS to Receive Traffic ...................................................................................... 66
9. Deploying WebCenter .................................................................................................................. 67
10. Localizing WebCenter ................................................................................................................ 69
  10.1 Understanding Localization in WebCenter .......................................................................... 69
  10.2 How to Install Custom Translations ..................................................................................... 69
11. The Help System ........................................................................................................................ 71
12. Upgrading from WebCenter 10.2 or Earlier ............................................................................... 72
  12.1 Prepare for the Upgrade ....................................................................................................... 72
    12.1.1 Prerequisites for the Upgrade ...................................................................................... 72
    12.1.2 Prepare for the Upgrade on the Application Server ...................................................... 73
    12.1.3 Prepare for the Upgrade on the Web Server .................................................................. 73
  12.2 Upgrade WebCenter ............................................................................................................. 74
    12.2.1 Remove WebCenter 10.2 or earlier ............................................................................. 74
    12.2.2 Install WebCenter 12 .................................................................................................... 74
    12.2.3 Upgrade the OBGE ....................................................................................................... 75
    12.2.4 Configure WebCenter 12 ......................................................................................... 76
13. Uninstalling WebCenter .............................................................................................................. 77
1. Copyright Notice

© Copyright 2012 Esko Software BVBA, Gent, Belgium

All rights reserved. This material, information and instructions for use contained herein are the property of Esko Software BVBA. The material, information and instructions are provided on an AS IS basis without warranty of any kind. There are no warranties granted or extended by this document. Furthermore Esko Software BVBA does not warrant, guarantee or make any representations regarding the use, or the results of the use of the software or the information contained herein. Esko Software BVBA shall not be liable for any direct, indirect, consequential or incidental damages arising out of the use or inability to use the software or the information contained herein.

The information contained herein is subject to change without notice. Revisions may be issued from time to time to advise of such changes and/or additions.

No part of this document may be reproduced, stored in a data base or retrieval system, or published, in any form or in any way, electronically, mechanically, by print, photoprint, microfilm or any other means without prior written permission from Esko Software BVBA.

This document supersedes all previous dated versions.

PANTONE®, PantoneLIVE and other Pantone trademarks are the property of Pantone LLC. All other trademarks or registered trademarks are the property of their respective owners. Pantone is a wholly owned subsidiary of X-Rite, Incorporated. © Pantone LLC, 2012. All rights reserved.

This software is based in part on the work of the Independent JPEG Group.

Portions of this software are copyright © 1996-2002 The FreeType Project (www.freetype.org). All rights reserved.

Portions of this software are copyright 2006 Feeling Software, copyright 2005-2006 Autodesk Media Entertainment.

Portions of this software are copyright ©1998-2003 Daniel Veillard. All rights reserved.

Portions of this software are copyright ©1999-2006 The Botan Project. All rights reserved.

Part of the software embedded in this product is gSOAP software. Portions created by gSOAP are Copyright ©2001-2004 Robert A. van Engelen, Genivia inc. All rights reserved.

Portions of this software are copyright ©1998-2008 The OpenSSL Project and ©1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

Adobe, the Adobe logo, Acrobat, the Acrobat logo, Adobe Creative Suite, Illustrator, InDesign, PDF, Photoshop, PostScript, XMP and the Powered by XMP logo are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Microsoft and the Microsoft logo are registered trademarks of Microsoft Corporation in the United States and other countries.

SolidWorks is a registered trademark of SolidWorks Corporation.

Portions of this software are owned by Spatial Corp. 1986 2003. All Rights Reserved.

JDF and the JDF logo are trademarks of the CIP4 Organisation. Copyright 2001 The International Cooperation for the Integration of Processes in Prepress, Press and Postpress (CIP4). All rights reserved.
The Esko software contains the RSA Data Security, Inc. MD5 Message-Digest Algorithm.
Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems in the U.S. and other countries.
Part of this software uses technology by BestTM Color Technology (EFI). EFI and Bestcolor are registered trademarks of Electronics For Imaging GmbH in the U.S. Patent and Trademark Office.
All other product names are trademarks or registered trademarks of their respective owners.
Correspondence regarding this publication should be forwarded to:
Esko Software BVBA
Kortrijksesteenweg 1095
B – 9051 Gent
info.eur@esko.com
2. Overview of a WebCenter Installation

The WebCenter installation procedure involves a number of different steps that need to be performed in a specific order.

The table below shows a list of the steps required to install WebCenter either for the first time or as an upgrade:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
</table>
| 1    | Check the Requirements and perform pre-installation work:  
       • *Hardware and Software Requirements*  
       • *Pre-Installation Steps* |
| 2    | **Installing WebCenter:**  
       1. *Install SQL Server 2008r2 Express Edition on the Database Server*  
       2. *Install ArtiosCAD on the Application Server* on page 16  
       3. *Install the WebCenter Application Server.*  
       4. *Install the WebCenter Web Server.*  
       5. *Start the WebCenter Services.*  
       6. *Install the On-Board Graphics Engine (OBGE) on the Application Server.* |
| 3    | **Configuring WebCenter** on page 37:  
       1. *Configure the OBGE*  
       2. *Configure E-Mail Notification*  
       3. *Secure the WebCenter Web Server with SSL.*  
       4. *Install Certificates for LDAPS on the Application Server*  
       5. *Integrate WebCenter with a Workflow Production Server.*  
       6. *Expose WebCenter to the Internet* |
3. Hardware and Software Requirements

Attention: For the latest hardware and software requirements, please check the Esko website.

WebCenter employs three distinct servers, a Web Server, an Application Server, and a Database Server.

It also has a FileStore and an On-Board Graphics Engine (OBGE), which is used to generate view data.

Entry Level (Two server systems required)

WebCenter Entry Level requirements are based on an activity with 10 concurrent users active at any time. Customers with higher performance needs should refer to the Advanced Level requirements.

In the Entry Level setup, the installation of the Application Server and Database Server is combined onto a single machine. The OBGE and the FileStore are on the Application Server.

For reasons of security the Web Server is always on its own dedicated computer and placed in a demilitarized zone (DMZ). We recommend the use of hardware firewalls for creating the DMZ.

Advanced Level (Three or more server systems required)

When the WebCenter Entry Level cannot meet the load requirements of the system, it is possible to scale the system.

For reasons of security the Web Server will always be a separate computer in a DMZ.

Each of the other WebCenter components (Application Server, Database Server, FileStore and OBGE) can be offloaded onto separate computers in different combinations.

Requirements

<table>
<thead>
<tr>
<th>Category</th>
<th>Advanced Level</th>
<th>Entry Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating System</td>
<td>• Microsoft Windows Server 2008 Service Pack 2 or better</td>
<td>• Microsoft Windows Server 2008 Service Pack 2 or better</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2003 Service Pack 1 or better</td>
<td>• Microsoft Windows Server 2003 Service Pack 1 or better</td>
</tr>
<tr>
<td></td>
<td>Note: Microsoft Windows 2000 Server is no longer supported</td>
<td>Note: Microsoft Windows 2000 Server is no longer supported</td>
</tr>
<tr>
<td>Processor - Application server with On-Board Graphics Engine</td>
<td>x86-32 or x86-64 compatible processor (Intel or AMD), minimal 2 cores, recommended 8 cores</td>
<td>x86-32 or x86-64 compatible processor (Intel or AMD), minimal 2 cores, recommended 8 cores</td>
</tr>
<tr>
<td>Processor - All other WebCenter servers</td>
<td>x86-32 or x86-64 compatible processor (Intel or AMD),</td>
<td>x86-32 or x86-64 compatible processor (Intel or AMD),</td>
</tr>
<tr>
<td>Category</td>
<td>Advanced Level</td>
<td>Entry Level</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>-------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>RAM Memory (App Server)</td>
<td>8 GB or higher</td>
<td>6 GB or higher</td>
</tr>
<tr>
<td>RAM Memory (Web Server)</td>
<td>8 GB or higher</td>
<td>4 GB or higher</td>
</tr>
<tr>
<td>Available hard disk space - Application server</td>
<td>200 GB</td>
<td>50 GB</td>
</tr>
<tr>
<td>Available hard disk space - Web server</td>
<td>10 GB</td>
<td>10 GB</td>
</tr>
<tr>
<td>Available hard disk space - database server</td>
<td>10 GB</td>
<td>10 GB</td>
</tr>
<tr>
<td>Display</td>
<td>1024 x 768 pixels, 16-bit color minimum</td>
<td>1024 x 768 pixels, 16-bit color minimum</td>
</tr>
<tr>
<td>Media drives - Application Server</td>
<td>DVD-ROM or connection to networked DVD-ROM drive</td>
<td>DVD-ROM or connection to networked DVD-ROM drive</td>
</tr>
<tr>
<td>Media drives - Web server</td>
<td>DVD-ROM or connection to networked DVD-ROM drive</td>
<td>DVD-ROM or connection to networked DVD-ROM drive</td>
</tr>
<tr>
<td>Network (all servers)</td>
<td>10/100/1000 Base-T Ethernet, TCP/IP v4 protocol, TCP/IP v6 protocol</td>
<td>10/100/1000 Base-T Ethernet, TCP/IP v4 protocol, TCP/IP v6 protocol</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Microsoft SQL Server 2000 and MSDE are no longer supported.</td>
<td><strong>Note:</strong> Microsoft SQL Server 2000 and MSDE are no longer supported.</td>
</tr>
<tr>
<td></td>
<td>• Oracle 10g or 11g Enterprise Edition</td>
<td>Oracle 10g or 11g Enterprise Edition</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Oracle 8i and 9i are no longer supported.</td>
<td><strong>Note:</strong> Oracle 8i and 9i are no longer supported.</td>
</tr>
</tbody>
</table>
Notes

- The Database Server needs 10 GB of free space on the partition containing the database files to allow for database expansion.
- The Application Server is the default location for uploaded files (also known as the FileStore). Ensure it has at least 50 GB of available hard drive space, and that the disk space is expandable. Alternatively, find a network location with expandable disk space to specify as the file storage location when loading the Application Server.
- The web, application and database servers must have the same OS language, regional setting (such as English (United States)), and time zone setting.
- In case you will be using the Viewer through a Microsoft ISA proxy server using authentication in an HTTPS session: use Java 1.4.2 on your machine, not Java 1.5.

To check the version of Java installed on your machine, double-click the Java applet in Control Panel and click About.

If needed, download the J2SE Java Runtime Environment (JRE) 1.4.2 from the following URL: http://java.sun.com/j2se/1.4.2/download.html.

- You must be able to download and install Java applets automatically to use the Viewer.

If Java is installed but a red X appears in the browser when launching the Viewer, consult your system administrator to see if a firewall or proxy blocks Java downloads.
4. WebCenter 12 Installation Tips

Licenses

- **WebCenter 12 Licenses**
  If you are planning an installation of the beta/customer release of WebCenter 12, you will need to request WebCenter 12 licenses, the old WebCenter 10 licenses will not work anymore.

- **Reporting License**
  In WebCenter 12, there is a new feature license for enabling the customizable part of the new Reporting functionality.

- **Network Licensing Tool**
  In case you install WebCenter 12 or update from an alpha version to a beta or customer released and you install with ArtiosCAD 10.3 or below, you may need to install the Suite 12 Flexnet Network License manager.

Server Configuration

- **Ports**
  The required ports for WebCenter 10.X were: 1099, 2500 and 4444. For WebCenter 12, you need to open and additional port: 3873. In case of outside LAN approval feedback from Automation Engine is needed, you need port 8010.

- **Outside LAN Approval**
  For the WebCenter 12 beta release, outside LAN approval feedback in Automation Engine requires Tomcat to function as the Web Server (instead of IIS), this works with Automation Engine 12 only.

- **Database**
  The database shipped as default with WebCenter 12 is MSSQL 2008r2 Service Pack 2 Express.

- **OBGE 12**
  In case OBGE 12 is installed on the webserver (unrecommended), make sure to stop the EG Web Server service before starting Tomcat.

Servicing

- **Admin Console**
  In WebCenter 12, it is possible to inspect JBoss by visiting: http://yourhost:8086/admin-console.

- **Services**
  In WebCenter 12, you will only see the following WebCenter services: JBoss, Tomcat and CAD-X. The App-X and Search Crawler services are no longer needed. In order to run the services interactively, open the command prompt and go to .. \Esko\Artios\WebCenter\ApplicationServer\NAMEOFSERVICE\bin of each service and run wcr_nameofservice_srv_cmdrun.bat e.g.: C:\Esko\Artios\WebCenter \ApplicationServer\JBoss\bin\wcr_jboss_srv_cmdrun.bat.
5. Pre-Installation Steps

Execute the following steps to make sure you have all the required information and materials for the installation.

1. Log on to all servers as a local administrator user.
   
   **Attention:**
   
   Logging on as DOMAIN ADMIN does not ensure you are a member of local Administrators group.
   
   Verify that the account you are using to log on to each machine belongs to local Administrators group before you continue!

2. Make sure you use compatible software versions:
   
   a) Gather the installation media on CD or DVD for ArtiosCAD, WebCenter, and Automation Engine (OBGE).
   
   b) Only very specific versions of ArtiosCAD, WebCenter, and Automation Engine (OBGE) work with each other.
   
   You CANNOT assume that a new version or build of one product will be compatible with older versions of the other products.

<table>
<thead>
<tr>
<th>Software</th>
<th>Version</th>
<th>Build</th>
</tr>
</thead>
<tbody>
<tr>
<td>ArtiosCAD</td>
<td>. . . .</td>
<td>. . . .</td>
</tr>
<tr>
<td>WebCenter</td>
<td>. . . .</td>
<td>. . . .</td>
</tr>
<tr>
<td>Automation Engine</td>
<td>. . . .</td>
<td>. . . .</td>
</tr>
</tbody>
</table>

3. Check the licenses for the Esko installers:
   
   a) Gather Graphics and CAD licenses.
   
   b) If this is an upgrade, you will need to ask for updated license files.
   
   c) Check the license files against your software order.
   
   Verify that the licenses have the correct number of users, the expiration date if applicable, and the correct ArtiosCAD, WebCenter, and Automation Engine (OBGE) version information.

4. Gather the required mail server information:

   **Note:**
   
   The mail server must be on the same network as the WebCenter application server.
   
   Also, ensure this mail server has a send-only e-mail account already created for specific use with WebCenter notifications (this usually requires creation of an account such as webcenter@mycompany.com).
5. Gather the required **database information** from the database administrator:

<table>
<thead>
<tr>
<th>Database</th>
<th>Item</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server</td>
<td>“sa” password</td>
<td>......</td>
</tr>
<tr>
<td></td>
<td>database instance name</td>
<td>......</td>
</tr>
<tr>
<td></td>
<td>database port (default is 1433)</td>
<td>......</td>
</tr>
<tr>
<td>Oracle Server</td>
<td>‘sys’ password</td>
<td>......</td>
</tr>
<tr>
<td></td>
<td>TNS name</td>
<td>......</td>
</tr>
<tr>
<td></td>
<td>database instance name</td>
<td>......</td>
</tr>
<tr>
<td></td>
<td>database port (default is 1527)</td>
<td>......</td>
</tr>
</tbody>
</table>

6. Perform a web server health check:

a) We highly recommend not to begin the install with the web server inside the DMZ. It is best to **configure on a local LAN** first.

Get all applications installed, configured, and fully functional before moving the web server inside the DMZ. Otherwise any required troubleshooting will be difficult and will take longer than needed.

b) Verify **Internet Information Services (IIS)** is installed and its services are started: IISADMIN and W3SVC (World Wide Web Publishing).

c) Make sure the **Server** service is running.

7. Test the mail server connection:

**Note:**

Ensure that you can use telnet commands and that its port is not blocked in any way.

Make sure you test this before starting the install. IT Administrators often block the required SMTP ports.

a) From the application server, open a command prompt.
b) Use a telnet command with the following syntax: `telnet <mail_server_name_or_ip> <smtp_port#>`.

For example, my mail server name is mail.eskowebcenter1.com and my SMTP port is 25. I would type: `telnet mail.eskowebcenter1.com 25`.

You are looking for a successful response (for example like the one below); a 220 response is good.

```
telnet mail.eskowebcenter1.com 25
Trying 62.204.32.250...Connected to mail.eskowebcenter1.com (62.204.32.250).220 mail.eskowebcenter1.com Mail Server; Mon, 20 Feb 2006 11:26:40 EST
```

Type QUIT to exit telnet command.

8. Make sure Server service is running on the application server.

9. Check the database server:
   a) Ensure the correct database engine, version and service pack are installed.
   b) For SQL Server 2005/2008 or Express 2005/2008 verify these configurations:
      • Must be configured to run in Mixed Mode for authentication;
      • Language/Character set of SQL Server must match Operating System language;
      • Service pack level MUST be SP3a or higher.

10. Check performance for all servers:
    a) For all servers (Web, Application, Database), ensure Windows System Performance is set to Adjust for Best Performance:

        Choose Control Panel > System > Advanced and select Adjust for Best Performance from the Performance list.

    b) Ensure Control Panel > Automatic Updates is set to Download updates for me, but let me choose when to install.

        Windows Updates have been known to interfere with WebCenter operation: some updates lock down ports and stop services related to web and internet.

        It is your responsibility to test Microsoft updates before applying them to production servers.

    c) Ensure Windows Firewall is disabled:

        Choose Control Panel > Network Connections, right-click on the active network connection and choose Properties. On the Advanced tab, ensure Internet Connection Firewall is disabled.

    d) Stop and temporarily disable virus software.

        Temporarily stop virus services on the web server and the application server as they are known to interfere with the WebCenter install script.

        Only after the software is installed should you enable the virus software again.
6. Installing WebCenter

Loading Esko WebCenter is a multi-step process spread over two or three servers depending on your configuration. We strongly recommend having three servers.

6.1 Overview of the Installation Procedure

This is a broad overview of the steps required to install WebCenter.

1. Perform the Pre-Installation Steps.
2. On the database server, create a database called WebCenter4_0 if using Microsoft SQL Server.
   If using Oracle, we recommend that the SID (System Identifier) of the database be WCenter, but it can be anything; just make sure you know the exact name so you can enter it while loading WebCenter on the application server.
3. On the application server:
   a) Install ArtiosCAD.
      Even if the application server already has a version of ArtiosCAD on it, you must load the version that came with WebCenter.
      For more information on loading and configuring ArtiosCAD, refer to the installation instructions on its media.
   b) Activate the Licenses on page 18
   c) Install the WebCenter Application Server.
   d) Load client software for the database unless the application server is also the database server.
      • If using Microsoft SQL Server or SQL Server Express Edition, this is Microsoft Data Access Components (MDAC), which can be downloaded from the Microsoft web site.
      • If using Oracle, perform an Oracle client software installation.
4. On the database server, run the Database Schema Scripts, and then ensure that the database is available.
5. On the web server, install the WebCenter Web Server.
   Reboot the web server machine if prompted.
6. Start the WebCenter Services:
   a) On the application server, start JBOSS and CAD-X.
   b) On the web server, start Tomcat.

Note: These services do not start automatically and must be started manually after each machine reboot. You may set them to start automatically by changing their properties in the Services applet via Control Panel > Administrative Tools.

Note: Since WebCenter 12 a new monitoring service is installed and started automatically. This service can be used by your WebCenter support agent for troubleshooting.
7. Load the On-Board Graphics Engine (OBGE) from the Automation Engine media. This will take about a half hour.

**Note:**
Even if you are also running a Automation Engine production server, you must install the OBGE. The OBGE will handle files uploaded through the WebCenter user interface, reducing the load on your Automation Engine production server.

WebCenter is now installed.

8. Log on the WebCenter web interface and:
   a) Change the administrator password.
   b) Configure E-Mail Notification if you will be using it.

9. Install ArtiosCAD defaults.
   Read more in Step 3 - Loading the Esko ArtiosCAD Defaults on page 45

6.2 Install SQL Server 2008r2 Express Edition on the Database Server

Microsoft SQL Server 2008r2 Express Edition (supplied with WebCenter) is a free version of Microsoft SQL Server 2008r2 that can serve as the database engine for WebCenter.

Microsoft SQL Server 2008r2 Express Edition is restricted to a maximum database size of 4 GB.

To install it, use the Install the SQL Server 2008r2 Express Edition database engine for WebCenter link on the WebCenter installation media.

To complete the procedure, simply follow the on-screen instructions provided by the installation wizard. When the installer prompts you for the **SA User Password**, you can:

- Leave the password fields empty and click **Use Default**. This installs using the default password (Drupa2000).
- Type a password of your own into the **Password** and **Confirm Password** fields, then click **Use Password**.
6.3 Install the Application Server Components

6.3.1 Install ArtiosCAD on the Application Server

1. Log on to the Application server as a member of the local Administrators group.
2. Load the ArtiosCAD media that came with WebCenter.

**Important:**

Even if the application server already has a version of ArtiosCAD on it, you must load the version that came with WebCenter.

In order for WebCenter to output PDF files, the ArtiosCAD PDF option must be purchased and then chosen when installing.

For more information on loading and configuring ArtiosCAD, refer to its installation instructions on the ArtiosCAD media.

3. In the *Esko ArtiosCAD Setup* window, click *Install Esko ArtiosCAD 12.0en*.

![ArtiosCAD Setup window](image)

Depending on your system configuration prior to loading ArtiosCAD, the Microsoft Data Access Components and MSXML 6 may be copied to your system.

If the system prompts you to reboot, do so; the installation program will resume automatically when you log in after the system comes up again. Do not postpone rebooting if the system requests it.

4. The *Esko ArtiosCAD 12.0en InstallShield Wizard* opens.

   a) In the *Setup Type* screen, choose *Typical* for a regular WebCenter installation, or *Advanced* if you will be working with ArtiosCAD Enterprise.

   b) In the *Feature Selection* screen, make sure *PDF Import/Export* is enabled.
In the Database Program Selection screen, choose SQL Server Express Edition.

In the Advanced Options screen, you can leave the default options selected. If you wish to change them please see the ArtiosCAD documentation for details.

**Note:** You will only see this screen when performing an Advanced setup to work with ArtiosCAD Enterprise.

In the System Type screen, choose Server.

In the User Files Folder screen, keep the default location for the storage of user files, or Change it if desired. If you change the location to another system, use a UNC locator (e.g. \system2\designs) instead of a mapped drive letter.

**Note:** You will only see this screen when performing an Advanced setup to work with ArtiosCAD Enterprise.

In the Licensing Method screen, choose FlexNet Licensing.

In the Licence Location screen, choose Server License and make sure the Server field contains the name of the Application Server (it should be filled in by default).

Click Install.

Once the installation is complete, click Finish to close the installer.

5. If the system asks you to reboot, do so.

**Note:** You will need to perform extra configuration later to work with ArtiosCAD Enterprise.

Create detailed installation log

For Installation debugging and troubleshooting purposes, you can create a detailed installation log file for any Esko Installer programs. To do this:

Run setup using the following syntax: Path+program space /v"/"v space path+logfilename

- For example: For ArtiosCAD installation from CD-ROM in my D:\ drive,
- Open a command prompt and Change to the D:\ drive
• Type: `setup /v"/l*v c:\temp\ACsetup.log"`

6.3.2 Activate the Licenses

Activate your licenses using the Server License Manager.

**Note:** To perform this task, consult the *Esko Server License Manager User Manual*.

You need to activate:

• your ArtiosCAD license,
• your WebCenter licenses (your basic WebCenter license and any additional WebCenter license you have, for example WebCenter Task Management, WebCenter Advanced Approval, Reporting, etc.).
• your license for the OBGE (Automation Engine license).

6.3.3 Install the WebCenter Application Server

The application server components of WebCenter can be installed from a link on the installation media.

1. Log on to the Application server as a member of the local Administrators group.
2. Insert the WebCenter media into the media drive, and click **Software Installation > Install WebCenter 12.0** on the menu that appears.
3. The setup wizard opens with a Welcome screen. Click Next.

4. In the License Agreement screen, read the agreement, and if you agree to it, select I accept the terms in the license agreement and click Next.

5. In the Custom Setup screen:
   a) Click the icon next to WebServer and select This feature will not be available.
   b) Click the icon next to Application Server, and select This feature, and all subfeatures, will be installed on local hard drive.
   c) If desired, click Change to change the installation folder.
   d) Click Next.

6. In the WebCenter File Storage Folder screen, choose the location where all data files uploaded to WebCenter will be stored. Click Next.
Note: If you want to change the filestore location, now is the time to change it by clicking change. Using a UNC location such as `\system\sharename\FileStore` is the most reliable option. The filestore should be on a partition with at least 50 GB of free space.

Troubleshooting:

If the installer fails to create the filestore, it will give you a message saying that you have to set it up manually.

Go to the folder that you will use as a filestore (by default, `C:\Esko\Artios\WebCenter\FileStore`, or the location of your choice), and share it (typically to the user BGSYSTEM).

7. In the Web Server System screen, enter the name you will give to the Web server and click Next.

Note: Once you have completed the installation and launched WebCenter, the application server must be able to resolve the web server name you have entered here into an IP address.

8. In the Database Configuration screen, choose the database program and enter the name of the database server (and named instance). Click Next when done.

   • If you choose Microsoft SQL Server, enter the name of the database server. There is an additional field where you can add the database instance name.

   The SQL Server 2008r2 Express Edition installer on the WebCenter installation media create a named instance called `WEBCENTER`. 
6. If you choose Oracle, an additional field for the database SID (System Identifier) is available.

9. Click **Install** in the Ready to Install the Program screen.

10. The **Esko Station Information Service** may be installed if this is the first EskoArtwork software being loaded on the machine.

    If it installs, click **Continue** when it is done, or wait 10 seconds for the process to continue automatically.

11. Click **Finish** when the installation completes.

12. If prompted, reboot the system.

    **Attention:** This is important; do not postpone this step!

### 6.4 Run the Database Schema Scripts on the Database Server

WebCenter comes with a set of batch files that create the database schemas. Run the appropriate batch file after creating the database but before any other operations that affect the database.

Every time a new installation or upgrade is performed, the Database Schema script should always be run. Schema changes are guaranteed for each version and build.
1. If your Application Server and Database Server are on different computers, copy the whole Artios\WebCenter\ApplicationServer\DatabaseSchema folder from your Application Server to your Database Server. This folder contains the batch files that create the database schemas.

2. On your Database Server, open a command prompt and change directories to Artios \WebCenter\ApplicationServer\DatabaseSchema.

3. Type the command appropriate for your database engine:

<table>
<thead>
<tr>
<th>If you are using...</th>
<th>Then you should...</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Microsoft SQL Server 2005/2008</strong></td>
<td>• Type a command following this pattern:</td>
</tr>
<tr>
<td></td>
<td>Build_MSSQLServerSchema &quot;sa_password&quot; servername\instancename</td>
</tr>
<tr>
<td></td>
<td>• &quot;sa_password&quot; is the sa user password. If there is no password, use &quot;&quot; instead.</td>
</tr>
<tr>
<td></td>
<td>Example:</td>
</tr>
<tr>
<td></td>
<td>Build_MSSQLServerSchema &quot;administrator&quot; MBCWEBSRV\WEBCENTER</td>
</tr>
<tr>
<td><strong>Microsoft SQL Server 2005/2008 Express Edition</strong></td>
<td>• Type a command following this pattern:</td>
</tr>
<tr>
<td></td>
<td>Build_ExpressSchema &quot;sa_password&quot; servername\instancename</td>
</tr>
<tr>
<td></td>
<td>• &quot;sa_password&quot; is the sa user password. If there is no password, use &quot;&quot; instead.</td>
</tr>
<tr>
<td></td>
<td>Note that the installer on the WebCenter media assigns the password Drupa2000 to the sa user and creates a named instance called WEBCENTER.</td>
</tr>
<tr>
<td></td>
<td>Example:</td>
</tr>
<tr>
<td></td>
<td>Build_ExpressSchema &quot;Drupa2000&quot; MBCWEBSRV\WEBCENTER</td>
</tr>
<tr>
<td><strong>Oracle</strong></td>
<td>• Type a command following this pattern:</td>
</tr>
<tr>
<td></td>
<td>Build_OracleSchema &quot;sys_password&quot; net_servicename string_datatype data_tablespace temp_tablespace</td>
</tr>
<tr>
<td>If you are using...</td>
<td>Then you should...</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------</td>
</tr>
</tbody>
</table>
| index_tablespace    | • If your Oracle server only runs a single instance called WebCenter, using the default tablespace names, the only required elements in this command string are the command itself, "sys_password" and string_datatype.  
  • "sys_password" is the database administrator password.  
  • The net_servicename field is required to specify the other fields.  
  It is the net service name corresponding to the SID of the desired instance. It is configured in the Net Configuration Assistant.  
  Specifying it is optional if there is only one instance, you use the default tablespace names, and you are logged on to the database server.  
  • The string_datatype field sets the datatype for text columns. It can be either varchar2 (the default) or nvarchar2. Use nvarchar2 to interact with the national character set.  
  • The data_tablespace field is the tablespace for the schema owner’s tables and by default is USERS. Specifying it is optional.  
  • The temp_tablespace field is the tablespace for temporary data storage and by default is TEMP.  
  • The index_tablespace field is the tablespace for the indices and by default is USERS. |

Example:

```bash
Build_OracleSchema
"administrator"
nvarchar2
```

4. Press Enter.
The batch script starts running.
End Prompt

\> rem net stop
\> rem net start
\> rem *** Drop the database ONLY if the existing data is expendable
\> rem isql -Usa -P database WebCenter4_0
\> rem *** Build
\> isql -Usa -P lserver_user.sql -o mssqlserver_user.log
\> isql -Usa -P lserver_projects.sql -o mssqlserver_projects.log
\> isql -Usa -P lserver_functions.sql -o mssqlserver_functions.log
\> isql -Usa -P lserver_views.sql -o mssqlserver_views.log
\>
5. Several log files are created in the same directory. Save these for future reference.

The database schemas are now in place.

**Note:**

For Oracle users, there is a performance-enhancing script that can be executed after running the Build_OracleSchema script:

```bash
sqlplus "sys/sys_password@<instance name> as sysdba" @oracle_indexes.sql
<database username> <index tablespace>
```

An example would be:

```bash
sqlplus "sys/manager@webcenter as sysdba" @oracle_indexes.sql WEBCENTER USERS
```

---

6.5 Install the Web Server

6.5.1 Install IIS on the Web Server Machine

If IIS is not installed on your web server, you need to install it. The procedure below explains how to install IIS 7 on Windows Server 2008 R2.

1. Start the Server Manager.
2. Click Roles in the left panel, then click Add Roles at right.
3. In the Select Server Roles screen, select Web Server (IIS). If the wizard prompts you to add features required for the web server, do so.
4. In the Select Role Services screen:

![Select Role Services](image)

a) Select ASP, ISAPI Extensions and ISAPI Filters.
   If the wizard prompts you to add role services required for ASP, do so.

b) Select Logging Tools and Tracing.

c) Select IIS 6 Management Compatibility.

5. In the Confirm Installation Selections screen, check the settings and click Install.
This installs the IIS 7 Role with the settings you have selected and the default settings. The Installation Results screen should show Installation succeeded.

6.5.2 Extend the Upload Limitation

IIS 7 has a limitation on how much you can upload at once (30 MB). You can change it to 2GB by following these steps:

1. Open IIS Manager.
2. Select the website for which you want enable large file uploads.
3. In the main window, double click Request filtering.
4. Once the window is opened you may see a list of tabs (file name extensions, rules, hidden segments...).
   Regardless of the tab you select, right-click in the main window and select Edit Feature Settings.
5. Modify the Maximum allowed content length (bytes): change the value to 2000000000 (a 2 and 9 zeros) to be able to upload files close to 2GB.

6.5.3 Enable 32 Bit Applications

Note: Only do this if you have a 64 bit system!

1. In IIS, go to Application Pools and select the DefaultAppPool.
2. Click Advanced Settings..., then set the Enable 32 Bit Applications option to True and click OK.
3. Click Recycle... at right.

6.5.4 Install the WebCenter Web Server

The web server components of WebCenter can be installed from a link on the WebCenter installation media.

1. Log on to the web server as a member of the local Administrators group.

2. Ensure that Internet Information Services (IIS) has already been loaded by verifying that the Internet Information Services applet is in Administrative Tools in the Control Panel.

   **Note:** If it has not been loaded, you must load it through Add/Remove Windows Components in Add/Remove Programs in the Control Panel.

3. Insert the WebCenter media into the media drive, and click Software Installation > Install WebCenter 12.0 on the menu that appears.
4. The setup wizard opens with a Welcome screen. Click Next.
5. In the License Agreement screen, read the agreement, and if you agree to it, select I accept the terms in the license agreement and click Next.
6. In the Custom Setup screen:
   a) Click the icon next to WebServer, and select This feature, and all subfeatures, will be installed on local hard drive.
   b) Click the icon next to Application Server and select This feature will not be available.
   c) If desired, click Change to change the installation folder.
   d) Click Next.
7. In the Option Selection screen:
   a) Enter the name of the application server.
      This should be a different machine than the one currently running the installation.
   b) If you want to install WebCenter using an already-existing IIS website, choose it in the list.
   c) Click Next.
8. Click Install.

9. The Esko Station Information Service may be installed if this is the first EskoArtwork software being loaded on the machine.

   If it installs, click Continue when it is done, or wait 10 seconds for the process to continue automatically.

10. Click Finish when the installation completes.

11. Reboot the machine if prompted.

### 6.5.5 Update the MIME Types in IIS

It is necessary to add extra MIME types to IIS to be able to open either the standard WebCenter Viewer or the Collada Viewer, and to download Collada files.

To update the MIME types manually in IIS 6, perform the following steps on the Web Server:

1. Go to Administrative Tools and open Internet Information Service (IIS) Manager.

2. In the Internet Information Service section, right-click the relevant connection (server) and select Properties.

3. In the MIME Types group, click the MIME Types button.

4. Add/edit the settings to register the following MIME types:

<table>
<thead>
<tr>
<th>Extension</th>
<th>MIME Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>.dae</td>
<td>application/collada+xml</td>
</tr>
<tr>
<td>.zae</td>
<td>application/collada-zipped</td>
</tr>
<tr>
<td>.env</td>
<td>application/collada-env</td>
</tr>
<tr>
<td>.jnlp</td>
<td>application/x-java-jnlp</td>
</tr>
</tbody>
</table>

5. Save the changes and restart IIS.

In case you still have problems, try editing the IIS MIME configuration file manually:

1. Go to C:\inetpub\wwwroot\web.config and make a backup of the web.config file.

2. Open the web.config file in a text editor and remove anything between `<staticContent>` and `</staticContent>` related to the extensions mentioned above.

3. Save and close the file.

4. Restart IIS.
6.6 Start the WebCenter Services

After installing WebCenter, you need to start its services using the Services applet in the Windows Administrative Tools.

6.6.1 Start the WebCenter Services on the Application Server

1. Log on to the application server as a member of the local Administrators group.
2. Click Start > Settings > Control Panel > Administrative Tools > Services.
3. Select the WebCenter JBOSS Application Server and click Action > Start.
4. If not started yet, select the WebCenter Application Monitor service and click Action > Start.
5. Select the WebCenter CAD-X Server and click Action > Start.
6. If you want to change the services to start automatically when the machine reboots, do so now:
   a) Right-click a WebCenter service and choose Properties.
   b) In the General tab, choose Automatic in the Startup type list.
   c) Click OK.
   d) Repeat for each service that has to start automatically.
7. Close the Services tool and log off.

6.6.2 Start the WebCenter Services on the Web Server

1. Log on to the web server as a member of the local Administrators group.
2. Click Start > Settings > Control Panel > Administrative Tools > Services.
3. Start the Tomcat service:
   a) Right-click Tomcat Web Server and choose Properties.
   b) In the General tab, choose Automatic in the Startup type list.
      This makes the service start automatically when the machine reboots.
   c) Click OK to close the Properties dialog.
   d) Select the Tomcat Web Server and click Action > Start.
4. If not started yet, select the WebCenter Application Monitor service and click Action > Start.
5. Close the Services tool and log off.

6.6.3 Easily identify when WebCenter is ready to access

WebCenter services load a lot of data into memory during startup of its services. It is important to watch the CPU activity before accessing an WebCenter site. You want both WEB and APS servers to have CPU activity < 5% before accessing site otherwise all components may not have started and you may experience error messages.

- To help watch the CPU activity easily, add the CPU performance monitor to the system tray of each WebCenter server. To do this:
  - On both WEB and APS:
  - Create a new shortcut in Start Menu-Programs-Startup folder.
  - Browse to TASKMGR.EXE located in Windows\system32 directory.
  - Set the shortcut to Run “Minimized”.

6.7 Install the On-Board Graphics Engine (OBGE) on the Application Server

The Automation Engine On-Board Graphics Engine or OBGE is required for WebCenter systems to generate view data.

These bare-bones instructions are meant as a guideline only. For detailed instructions, please refer to the Suite 12 Engines Software Installation Manual.

6.7.1 Install the Prerequisites

1. Insert the Suite 12 Engines Prerequisite Components Installation DVD.
   If the DVD does not auto-start, double-click setup.exe in its root folder.
   a) In the window that opens, click English.
   b) Click Software Installation in the main menu on the left of the window.
   c) Click First installation of Suite 12 Engines Prerequisite Components.
2. Do the Readiness Check. If necessary, adjust the Data Execution Prevent settings:
   a) Go to My Computer > Properties > Advanced > Performance Options > Data Execution Prevention.
   b) Select Turn on DEP for essential Windows programs and services only.
c) Reboot.
3. Click Install the License Server components.
4. Click Install the System Controller and run through the installation wizard.
5. In the Suite 12 Engines Prerequisite Components Installation window, go back one page to First installation of Suite 12 Engines Prerequisite Components.
6. Click Install the Database Engine for Esko Automation Engine Server and run through the installation wizard.
7. Still on the First installation of Suite 12 Engines Prerequisite Components page, click Install the Microsoft Visual Studio 2005 redistributables and run through the installation wizard.

6.7.2 Install the OBGE

1. Remove the Suite 12 Engines Prerequisite Components Installation DVD and insert the Suite 12 Engines Installation DVD.
   If the DVD does not auto-start, double-click setup.exe in its root folder.
   a) In the window that opens, click English.
   b) Click Software Installation in the main menu on the left of the window.
   c) Click First installation of Suite 12 Engines.
2. Click Install the Suite 12 Engines products.
3. Follow the instructions in the installation wizard, and make sure that in the product selection step, you only select the Automation Engine Server and Automation Engine Client products.
   The System Components item cannot be deselected, so you will be installing three products.
   
   Note: Fourteen separate software components will be installed, and the installation process may take a while to complete.
4. Let the installation complete and exit the Suite 12 installer.
5. Perform the following post-installation checks:
   a) Double-click the Pilot icon on the desktop. The Automation Engine Pilot should appear. If any problems occur, check the log files. For more information on the log files, see Log File Reference.
   b) Verify that the following shortcuts have been created during installation:
   
   • ArtiosCAD
   • Automation Engine 12.0
   • Automation Engine Client 12.0
   • Automation Engine Client Installers Share 12.0
   • Automation Engine Select Server 12.0
   • CIPress
   • CMS Data
   • Custom Data
   • DGC Data
   • Font Data
   • Font Manager
   • IntelliCurve
- IPL Data
- Marks Data
- Station Information Service
- System Controller
7. Testing WebCenter

On APS and WEB, ensure IIS and WebCenter services are Started and configured to start Automatically.

After Starting/Restarting WebCenter services, always wait a few moments until CPU processor activity on both servers become idle (<5%) before attempting to access login page.

Testing each facet of WebCenter in the exact order below helps to easily and quickly identify points of failure, if any. Otherwise it can be like finding a needle in a haystack. Details on how to do each step and resolve problems are in Troubleshooting section later in this document.

- IIS Connectivity – use IIS Manager to access WebCenter_Inst site
- IIS Security settings – can access homepage after logging in
- Database connection and Schema – can add a new record to database
- FileStore connectivity – can write a file to FileStore and then retrieve it
- View Data generation – can upload a graphic file and OBGE does its job
- View and Annotate applet – can launch applet successfully on a Graphic file
8. Configuring WebCenter

8.1 Configure the OBGE

The Pilot lets you configure the Automation Engine On-Board Graphics Engine (OBGE) for use with WebCenter.

You must create a container and a hotfolder pointing to the WebCenter FileStore.

8.1.1 Create a Container

1. Log on to the application server as a member of the local Administrators group.
2. Double-click the Pilot icon on the desktop.
3. In the Logon Information dialog, enter admin as the User Name and admin as password. Type the name of the application server in Server Name. Click OK.

This opens the Pilot.
4. Go to Tools > Containers to open the Containers window.

5. In that window, go to File > New or click .

This opens the Create Container Wizard.
6. In the Welcome screen, click Next.
7. Select Existing Shared Folder and click Next.

8. Type the name of the application server in the Computer Name field and click Next.

9. Select the FILESTORE share and click Next.

10. Click Finish and close the Containers window.

8.1.2 Create a JDF Hot Folder for WebCenter

1. Click Hot Folders in the row of views along the left side of the Pilot.
2. Click File > New Hot Folder, or click the icon.

3. In the dialog that opens, select JDF Hot Folder and click OK.

4. In the Select Folder dialog, choose the container you just made in the Look in list.

5. Double-click JDFHotfolder and then select hotin. Click OK.

These folders are created automatically within the FILESTORE container. You simply need to select them for use with the JDF Hot Folder.

6. In the New Hot Folder dialog, copy the contents of the Hot Folder field to the Output Folder field. Change hotin to hotout, and make sure there is a forward slash (/) at the end of each folder location (add the forward slashes manually if they are missing).
Note: The final slashes disappear after you have clicked OK.

7. Click OK.

The Hot Folder now appears in the Pilot and is ready for use.

8.1.3 Improve the Performance of View Data Generation

By default, the OBGE only polls the Hot Folder once a minute to see if there are view data requests to process. To decrease this wait to 5 seconds, do the following on the application server:

1. Log in as Admin or as a member of the Admins group on the application server.
2. Open a command prompt and change to the C:\ drive by typing C:\ and pressing Enter.
3. Change directories by typing `cd \esko\bg_prog_fastservclntnt_vXXX\com_win` where `XXX` is the OBGE version you have (for Esko Software Suite 12, it is 120). Press Enter.
4. Type `cfsedt2` and press Enter.
5. Log in to the Esko Automation Engine Configuration Tool using admin as both the username and password. The server should be the name of the application server.
7. Select `hf.pollinterval` in the left pane.
8. In the right pane, change 60 to 5, making sure to keep the beginning and ending double quotation marks.
9. Click Change.

The OBGE will now poll the Hot Folder every 5 seconds instead of only once every minute.
8.2 Configure E-Mail Notification

Use the E-Mail Notifications page to configure the e-mail environment for the notifications framework. Only WebCenter Administrators can access this page.

8.2.1 Log On to WebCenter and Change the Admin Password

1. On the Web server, open a Web browser (Internet Explorer 6 or greater, Mozilla Firefox 3 or greater, or Safari) and browse to the following URL: http://WebServer_name/WebCenter_Inst.

   **Note:** The WebCenter URL is case sensitive.

   The WebCenter Log In page appears.

2. Enter *admin* in the **Username** field and click **Log In**.

   **Note:** For a new installation, you don’t need to provide a password for the first login (the password is initially blank). When updating the system, you need to login with the previous admin password before you can change it.

   If you are able to log in successfully, you are brought to the **Change Password** page.

3. Change the Admin password to a secure password.

8.2.2 Configure E-Mail Notification

While logged in to the WebCenter web interface as an administrator:

1. Go to **Admin > Configuration > E-Mail Environment Setup**.
2. Set up your e-mail environment:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-Mail Service Protocol</td>
<td>WebCenter only supports the SMTP protocol.</td>
</tr>
<tr>
<td>E-Mail functionality enabled</td>
<td>To enable/disable e-mail functionality.</td>
</tr>
<tr>
<td>E-Mail debugging output in log</td>
<td>To enable/disable e-mail debugging output in log files.</td>
</tr>
<tr>
<td>E-Mail Service Host</td>
<td>The address for the preferred mail server that will act as the server for dispatching WebCenter e-mail notifications (this server has to comply to the selected protocol type (see above)).</td>
</tr>
<tr>
<td>E-Mail Service Port Number</td>
<td>The port number on which the defined mail server is listening for incoming e-mails.</td>
</tr>
<tr>
<td>Outgoing E-Mail Notifications' &quot;FROM&quot; Address</td>
<td>Supply a valid e-mail address. This will be used in the &quot;From&quot; e-mail header for every e-mail sent by WebCenter.</td>
</tr>
<tr>
<td>E-Mail Session Authentication</td>
<td>Select this option if the mail server connection requires authentication with a user name and password.</td>
</tr>
<tr>
<td>E-Mail Service Username</td>
<td>Provide the mail account user name if authentication is required.</td>
</tr>
<tr>
<td>E-Mail Service Password</td>
<td>Provide the mail account password if authentication is required.</td>
</tr>
</tbody>
</table>

Note: This password is stored in an encrypted form.

3. Click Send Testing E-mail.

The Test E-Mail Environment Settings page appears.
4. Type a **Recipient** address and click **Send E-mail**.

WebCenter attempts to send an e-mail to the recipient. The E-Mail Configuration page appears, displaying a message depending on the result of the test:

- **Test E-Mail Sent**: The environment is set up correctly.
- **JMS System Error**: Communication with the JBoss’ proprietary messaging framework failed. An administrator should check the JBoss server configuration and/or log files for possible causes.
- **Mail Server Connection Error**: The connection to the specified mail server did not succeed. Either the data the administrator supplied on the e-mail environment setup page was incorrect, or the mail server is currently down.

An administrator should either check the e-mail environment settings for possible misspellings or contact the mail provider as to the status of the mail server.

**Note**: The settings you defined are saved in the database. For updates from older WebCenter installations, the email setup is first loaded from the old emailconfig.xml file and the settings are subsequently stored in the database.

---

**8.3 Configure WebCenter for Use with ArtiosCAD Enterprise**

**8.3.1 Configuring BLOBs**

ArtiosCAD Enterprise supports the use of BLOBs in the database. BLOBs are Binary Large OBjects - files stored as data in the database. Using BLOBs is transparent for the user.

When you configure ArtiosCAD Enterprise to use BLOBs, it also stores managed documents in the WebCenter FileStore as a cache to improve performance. If you delete a file from the FileStore, the next time you save it in ArtiosCAD Enterprise, it will be recreated in the FileStore from the BLOB.
Note:
You should decide if you want to use BLOBs when you install WebCenter. Switching to using BLOBs after having used ArtiosCAD Enterprise is not recommended or supported.

Editing appconfig.xml on the Application Server

To enable BLOBs, you must change a line in a configuration file on the Application server. On the Application server:

1. Log in as Administrator or as a user with administrative privileges.
2. Make a backup copy of C:\Artios\WebCenter\config\appconfig.xml. This file will be on the C: drive no matter where you installed WebCenter.
3. Open the file named in the previous step in a text editor such as Notepad.
4. Scroll down to `<store_files_in_blob value="false"/>` and change false to true.
5. Save the file and exit the text editor.

Restarting Services

Once you have changed appconfig.xml on the Application server, restart all the Application server’s WebCenter services to start using BLOBs in ArtiosCAD Enterprise.

1. On the Application server, still logged in as Administrator or as a member of the local Administrators group, open the Services applet in the Administrative Tools group in Control Panel.
2. Restart the following services by clicking each one and then clicking the Restart link:
   a) WebCenter JBOSS Application Server
   b) WebCenter CAD-X
3. Close the Services applet and log off the Application server.

ArtiosCAD Enterprise is now configured to use BLOBs. Note that WebCenter will keep copies of managed documents in its FileStore to improve performance.

8.3.2 Step 2 - Running the Board Importer Batch File

After you have loaded WebCenter and changed the admin password, the next step is to run the board importer batch file. On the Web server, do the following:

1. Log in as a member of the local Administrators group.
2. Start a Command Prompt window.
3. Change directories to ..\WebCenter\WebServer\Boards.
4. Run the Board Import utility ImportBoards.bat which takes the following arguments.
   a) -username name of the WebCenter user doing the import, usually admin.
   b) -password password of the WebCenter user doing the import.
   c) -url URL to the WebCenter server.
   d) -dir Directory containing the migration files (same directory as the batch file).
   e) -output Specifies the optional creation of an XML file with the returned status of the procedure.
An average command would be something like this: `ImportBoards -username admin -password adminpassword -url http://server/WebCenter_Inst -dir C:\Esko\Artios\WebCenter\WebServer\Boards`

5. Press Enter after typing the command. The batch file will run and load the ArtiosCAD board information into WebCenter.

### 8.3.3 Step 3 - Loading the Esko ArtiosCAD Defaults

After you have run the board import batch file, the next step is to install and run the ArtiosCAD Defaults installer.

**Note:**
The system you use for loading the Defaults must be able to keep the Defaults on it. You will have to follow the same process to load future Defaults and the new installation will reference the older version's Defaults as part of its installation. We recommend using the Application server for this process.

**Note:**
This procedure takes a significant amount of time. We recommend starting it and doing other things until it completes.

1. Log in to the Application server as a member of the local Administrators group.
2. Insert the ArtiosCAD Enterprise media into the drive.
   
   The ArtiosCAD Enterprise installer should appear. If it does not, run `setup.exe` in the root directory of the media.
3. Click the button next to Install ArtiosCAD Defaults.
   a) Choose the language in which the setup program will run and click OK.
   b) Click Next in the Welcome dialog box.
   c) Click I accept the terms in the license agreement and click Next.
   d) In the Defaults Language Choice dialog box, select the language of the Defaults to upload to WebCenter and click Next. Only one language may be uploaded per session, so to install more than one language, repeat this procedure.
   e) Enter your WebCenter server URL, admin username, and admin password in the WebCenter Server Information dialog box and click Next.
   f) In the Shared Defaults dialog box, you can choose a version of ArtiosCAD Standard Edition that is the same version or earlier from which to merge Shared Defaults into Enterprise. To use the delivered Shared Defaults, choose Use installed shared defaults; otherwise, choose Copy shared defaults from this version and select the version. Click Next.
   g) Click Install to begin the installation.

A progress indicator will appear.
4. Click Finish when the installation process is done.

### 8.3.4 Configuration in the WebCenter User Interface

**Note:** See the WebCenter Administration Guide for more details about the following steps.

1. Log on to WebCenter with the admin account (see Log On to WebCenter and Change the Admin Password on page 41).
2. Configure a Company and Location for the initial ArtiosCAD Enterprise users.
3. Create a custom group, if desired, for the initial ArtiosCAD Enterprise users.
4. Create the initial ArtiosCAD Enterprise users. While creating them:
   a) Make sure they are at least Project Managers with Limited Visibility of Companies and Groups.
   b) Assign them to the Company and Location you created.
   c) Assign them to one or more groups.
   Even if you did not create any custom group, you should assign them to the USERS group.
5. Invite them to the System Defaults Project (which is Shared Defaults in ArtiosCAD Enterprise).

**Tip:** You can do this either individually for every user or once through Group membership if you added all users to the same group (such as USERS).

Inviting them to the Project means that they will be able to use the Defaults.

In order for users to change Shared Defaults, they must have Full permissions on the Project and be members of the ADMINS group.

**Note:** All ArtiosCAD Enterprise users must be invited to the System Defaults Project. Users who are not invited to the project will receive a UFANEX error when they launch ArtiosCAD Enterprise.

### 8.4 Secure the WebCenter Web Server with SSL

SSL is a protocol for securing communication over the Internet. SSL works by using a private key to encrypt data that is transferred over an SSL connection.

URLs using an SSL connection start with HTTPS:// instead of HTTP://.

To use SSL, you are required to obtain an SSL certificate and install it into Internet Information Services (IIS) on the web server.

**Note:** We strongly recommend you secure your web server with SSL, especially if you plan to use WebCenter over the internet (not only within a Local Area Network).

### 8.4.1 Obtain an SSL Certificate

The customer is responsible for choosing the SSL provider, obtaining certificates, as well as following that company’s specific instructions for installation and configuration.
Esko cannot obtain SSL certificates on behalf of its customers — this would even be illegal.

- If you do an Internet Search for “SSL certificate”, you will find many providers with different pricing and options. We have good experiences with Verisign, Network Solutions, Godaddy.com, and Thawte.
- Do not buy an SSL certificate lower than 128-bit encryption.
- The application process can take up to 30 days… Start the application process well in advance!
- SSL is very specific towards operating system and URL specification. Any changes in these will require a new certificate.
- If your company has a DNB number (Dun & Bradstreet), the application process will be a lot easier and quicker if you can provide it.

8.4.2 If the Web Server is on a Windows Server 2003 Machine

Installing SSL certificates is dependent on the brand of the certificate and the operating system. Please read the installation instructions that should normally come with the certificate.


Install the SSL Certificate

Following is a description of a typical installation of an SSL Certificate on Windows 2003 Server (using IIS 6).

1. On the web server, click Start > Run and type inetmgr. Then click OK to start Internet Information Services (IIS) Manager.
2. Expand the Web Site node.
3. Right-click on the Web Site node and choose Properties.
5. In the Secure Communications area, click Server Certificate to begin installation of your certificate(s).
Anonymous access and authentication control:
Enable anonymous access and edit the authentication methods for this resource.

IP address and domain name restrictions:
Grant or deny access to this resource using IP addresses or internet domain names.

Secure communications:
Require secure communications and enable client certificates when this resource is accessed.
6. Follow the instructions in the IIS Certificate Wizard.

Configure IIS to Receive Secure (HTTPS) Traffic

1. On the web server, click Start > Run and type inetmgr. Then click OK to start Internet Information Services (IIS) Manager.
2. Expand the Web Site node.
3. Right-click on the Web Site node and choose Properties.
4. Click the Web Site tab and make sure the SSL Port field contains the correct port for HTTPS traffic through your firewall. The default setting is port 443.

Require End Users to Use Secure URLs

End users should only use HTTPS:// to access your WebCenter site(s) to ensure security.

Note: If someone accidentally uses HTTP:// to access the WebCenter site, they will not be using a secure connection. For this reason, Windows 2003 offers an IIS option that allows you to force all clients to use HTTPS://.

1. On the web server, click Start > Run and type inetmgr. Then click OK to start Internet Information Services (IIS) Manager.
2. Expand the Web Site node.
3. Right-click on the Web Site node and choose Properties.
4. Click the Directory Security tab. In the Secure Communications area, click Edit and enable the Require Secure Channel (SSL) option.
5. Click OK, then again OK.

8.4.3 If the Web Server is on a Windows Server 2008 Machine

Installing SSL certificates is dependent on the brand of the certificate and the operating system. Please read the installation instructions that should normally come with the certificate.

Windows Server 2008 uses IIS 7.

Install the SSL Certificate

Following is a description of a typical installation of an SSL Certificate on Windows 2008 Server (using IIS 7).

1. On the web server, click Start > Run and type inetmgr. Then click OK to start Internet Information Services (IIS) Manager.

2. In the Connections panel at left, select the server node (the node called after your server).

3. Double-click Server Certificates in the centre panel.

4. Click Import... in the Actions panel at right.
5. In the Import Certificate pop-up, browse to your Certificate file, and enter the Password associated with your certificate if there is one (this password can be set when receiving the certificate).

   Click OK.

Configure IIS to Receive Secure (HTTPS) Traffic

1. Still in the IIS Manager, right-click the Default Web Site node in the Connections panel, (or the node of the IIS website you have deployed your web server on if it's not the default website) and select Edit Bindings...
2. In the Site Bindings dialog that opens, click Add.
3. In the Add Site Binding pop-up:
   a) Choose https as Type.
   b) Leave the default https Port (443).
   c) In the SSL Certificate list, select your web server.
   d) Click OK and then OK again.

Require End Users to Use Secure URLs

End users should only use HTTPS:// to access your WebCenter site(s) to ensure security.
**8.4.4 Install Certificates on the Workflow Production Server**

If...

- you are planning to integrate your Automation Engine server with WebCenter,
- your WebCenter site is secure (it demands HTTPS connections),
- your Automation Engine server and your WebCenter are not located within the same Local Area Network,

... you need to make sure your Automation Engine server can communicate with your WebCenter server over HTTPS.

For this, you need to import the WebCenter security certificates into the Automation Engine keystore.

**Note:**

This procedure is in theory also needed when WebCenter and Automation Engine are in the same LAN, but depending on the IT settings, it is possible / typical that HTTPS communication is only enforced when coming from outside.

Check with your network administrator if this is the case.

---

**Export the Certificates from the WebCenter Web Site**

1. Log on to the Automation Engine server as a local administrator.
2. Open a web browser and navigate to the secured WebCenter site.
3. Examine the WebCenter site’s certificates.
   - How you do this depends on the web browser you use; for example in Internet Explorer:
     1. Click the lock icon at the end of the address bar and click **View certificates** in the pop-up.
b) In the **Certificate** dialog, click the **Certification Path** tab.

This tab displays the certificate hierarchy. Each top-level entry in the hierarchy represents a certificate.

4. Export all the certificates (top-level entries) in the hierarchy:
   a) Highlight the first certificate in the hierarchy (for example, *Thawte Server CA (SHA1)*).
   b) Click **View Certificate**.
   c) Click the **Details** tab.
d) Click Copy to File to begin the Export Wizard. Click Next.
e) Select DER encoded binary… (.CER) and click Next.

f) Click Browse or type in a valid path and name the certificate (*.cer). We recommend using a short path and name (such as c:\temp\vali.cer). Click Next.
g) Click Finish, then OK and once more OK.
h) Repeat these steps until you have exported all the certificates. Close the web browser when you are finished.

Import the Certificates into the Workflow Server Keystore

While still logged on to the Automation Engine server as a local administrator, import the Certificate files into the Automation Engine keystore:

1. Open a DOS command prompt.
2. Change to the Esko Automation Engine software directory which contains the keytool utility:
\bg_prog_fastserver_vxxx\jre\bin
For Suite 12, this will typically be c:\eso\bg_prog_fastserver_v120\jre\bin

3. Run the import utility for each certificate downloaded, in the proper order: keytool -import
   -file <path>\*.cer -alias <aliasname> -keystore <keystore_path>.
   Your <keystore_path> is the path to bg_prog_fastserver_vxxx\jre\lib\security\cacerts.
   For example: c:\eso\bg_prog_fastserver_v120\jre\lib\security\cacerts.
   You will be prompted for a password. The password is: changeit (case sensitive).

4. You might be asked to trust the certificate = Enter Y for Yes.
   It is also possible that the tool tells you that this certificate is already installed. If so, that’s ok,
   go on with the next certificate.
   You should get a successful message like Certificate was added to keystore.

5. Repeat for each certificate to import in the hierarchy.

6. Reboot the Automation Engine computer to ensure that the changes take effect.

Example
You are running Automation Engine 12 and the Automation Engine server software is installed on
E:\Esco.
You have downloaded two certificates from the WebCenter site in the folder c:\temp:
valicert.cer and starfield.cer.
Valicert.cer was first in the hierarchy, so you would import this first, then repeat for
Starfield.cer.
You would proceed as follows:
1. Using a command prompt, go to e:\eso\bg_prog_fastserver_v120\jre\bin.
2. Type Keytool -import -file c:\temp\valicert.cer -alias valicert -keystore e:\eso\bg_prog_fastserver_v120\jre\lib\security\cacerts
3. If asked for the password, type changeit.
4. If asked to trust the certificate, type Y.
5. Repeat the same command for the next certificate, Starfield.cer.
6. Reboot the Automation Engine computer to ensure that the changes take effect.

Import the Certificates into the Workflow Client Keystore
With a secured WebCenter site (requiring HTTPS), you cannot check the connection between
Automation Engine and WebCenter with the Check Connection button in Configure.
To be able to do this, you need to install the web server certificates in the Automation Engine client
keystore too (even if the client is running on the same machine as the Automation Engine server).
Tip:
You should also do this if publishing fails because Automation Engine doesn’t have the appropriate certificates. Typically, this gives an error message like the one below:

```
javax.net.ssl.SSLHandshakeException: 
sun.security.validator.ValidatorException: PKIX path building failed: 
sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
```

1. While logged on to the Automation Engine client machine as a local administrator, open a DOS command prompt.
2. Change to the Esko Automation Engine software directory which contains the keytool utility:
   \bg_prog_fastservercltnt_vxxx\jre\bin
   For Suite 12, this will typically be c:\esko\bg_prog_fastservercltnt_v120\jre\bin
   Note: For the client, make sure to use bg_prog_fastservercltnt and not bg_prog_fastserver as for the server!
3. Run the import utility for each certificate downloaded, in the proper order: keytool –import –file <path>\*.cer –alias <aliasname> -keystore <keystore_path>
   Your <keystore_path> is the path to \bg_prog_fastservercltnt_vxxx\jre\lib \security\cacerts. For example: c:\esko\bg_prog_fastservercltnt_v120\jre \lib\security\cacerts.
   You will be prompted for a password. The password is: changeit (case sensitive).
4. You might be asked to trust the certificate = Enter Y for Yes.
   It is also possible that the tool tells you that this certificate is already installed. If so, that’s ok, go on with the next certificate.
   You should get a successful message like Certificate was added to keystore.
5. Repeat for each certificate to import in the hierarchy.
6. Reboot the Automation Engine computer to ensure that the changes take effect.

8.5 Install Certificates for LDAPS on the Application Server

To connect your WebCenter installation to a secure LDAP server (LDAPS), you have to install a certificate obtained from that LDAPS server.

1. Open a command prompt on the WebCenter application server.
2. Change directory to the location of \WebCenter\ApplicationServer\LDAP \CertInstall.bat.
3. Issue the following command: CertInstall servername:port, where servername is the name or IP of the LDAP server and port is the port used for secure connection (typically 636).
If successful, a list of certificates sent by the server is displayed (ignore any additional messages).
4. To install a given certificate, enter its number in the list and press Enter.

We suggest that you install all certificates. Only one certificate can be installed each time you run CertInstall so it can be necessary to run it multiple times.
Added certificate to keystore 'jssecacerts' using alias 'webcenter2.esko.com'.
Copying the keystore file jssecacerts to C:\Program Files\Java\jdk1.5.0_15\lib\security
1 file(s) copied.

C:\Esko\WebCenter\ApplicationServer\LDAP
Note:

Troubleshooting the certificate installation

The certificates should be properly installed. If not, try these troubleshooting tips:

- Server or port name is not correct

  If the supplied parameters are wrong, the result can look something like the following:

```plaintext
In this case, contact the IT system administrator and verify the parameters supplied.
```
8.6 Integrate WebCenter with a Workflow Production Server

You can configure WebCenter to integrate with your existing Automation Engine production server. In this documentation, we assume that you have both these applications installed and running properly.

8.6.1 Understanding WebCenter Integration

WebCenter can run without Automation Engine, but its full potential is realized when integrating both systems.

Integrating WebCenter with a Automation Engine production server allows you to upload production files to WebCenter for approval and advanced project management.

To make this collaboration between the systems possible, you must:

- Add the WebCenter Site in the Automation Engine Configure window.
- Add the Job Web Page information in the Automation Engine Configure window.
- Set up the WebCenter View information for the Automation Engine users.
- Configure the Publish to Web (JDF) ticket.

8.6.2 Integrate WebCenter with a Workflow Production Server

To integrate WebCenter with Automation Engine 12, follow these instructions.

Add the WebCenter Site Information

1. Launch the Automation Engine Pilot and connect to the production server with an administrator account.
2. Choose Tools > Configure.
3. In the Configure window, select WebCenter Sites in the left pane.
4. Click plus icon.
5. In the **Website** field of the **Delivery** area, enter the URL of the WebCenter site (for example: `http://wcrserver/WebCenter_Inst`).

   **Note:** If your site uses secure HTTP, make sure to enter an HTTPS address.

6. Click **Open** to test the connection. The login page for Esko WebCenter should appear; if it does not, check your settings.

7. If the Automation Engine server and the WebCenter Application Server are not on the same LAN, deselect **WebCenter and Automation Engine are in the same LAN**.

   The **User Name** and **Password** fields then become available. This is where the Automation Engine Approval Client configuration in WebCenter is used.

   Create a user name and password combination in WebCenter, then enter that same (case-sensitive) username and password in the appropriate fields in Automation Engine **Configure**.

   Click **Check Connection** to test the connection.

   **Important:** You must be using the Pilot on the Automation Engine server itself to run this check.

   A dialog box appears, proving that the connection works and displaying the WebCenter version number.

8. If visible, in the **Connect to JDF Processor** group, leave **JMF** selected.

9. Click **Check** to test the connection.

   An **Info** dialog appears, reporting that the connection is OK. Click **OK**.

   If this dialog does not appear, check your settings.

10. In the **Configure** window, scroll down and select the new WebCenter1 entry under **WebCenter Sites**.

11. Click **File > Rename** and enter a descriptive name for your WebCenter site.

12. Click **File > Save** to save the settings.

**Configure the Job Web Page URLs**

1. Launch the Automation Engine Pilot and connect to the production server with an administrator account.
2. Choose Tools > Configure.
3. In the Configure window, select Jobs > Job Web Page in the left pane.
4. In the Address field, enter the URL of the WebCenter site (for example: http://pacwebserver/WebCenter).
5. Still in the Address field, append this text to the end of the URL: /projdetails.jsp?projectName=
   
   **Attention:** This is case-sensitive; enter it exactly as written. Do not include a space or period at the end.
6. Click +[ ]InsertSmartNames.
7. In the SmartNames column, scroll down and click JobName.
8. Click Insert to append it to the URL in the Address field.
9. Click Close to return to the Configure window.
   
   The result should resemble http://pacwebserver/WebCenter/projdetails.jsp?projectName=[JobName] with [JobName] in green.
10. Click File > Save to save the settings.

Use the Publish on Web (JDF) Ticket

The Publish on Web (JDF) ticket in Automation Engine creates output and uploads the resulting files to WebCenter.

1. Launch the Automation Engine Pilot and connect to the production server with an administrator account.
2. Click the Tickets view.
3. Select the Publish on Web (JDF) default ticket and right-click it.
4. Click Copy on the context menu.
5. In the Copy Ticket dialog, in the Ticket Name field, replace the word Default with WebCenter.
6. In the Scope area, select the Global option.
   
   If you have no blue job folders containing files, you are not prompted to select the scope.
7. Click OK. The new ticket should appear in the list.
8. Double-click the new Publish on Web (JDF) WebCenter ticket to change its settings.
9. On the Destination tab, in the Site list box, select the desired WebCenter site.
10. Click inside the Project field, and then click +[ ].
11. Scroll down the list of SmartNames and click JobName.
12. Click Insert, and then click Close.
13. Leave the Folder and Project Template fields blank unless you know the exact names of the folder and project template you want to use for every new Project.
   
   In this case, enter them as appropriate; all new WebCenter Projects created with this ticket will use these values.

**Note:** The Project Template field refers to a template in WebCenter, not Automation Engine.
14. Leave the User Name and Password fields blank unless there is a specific WebCenter user who will own each document revision published using this ticket; in that case, enter the appropriate information.

If you leave these fields blank, anyone using the ticket will have to supply a valid user name and password each time it is used.

15. Click the Publish tab and leave Prepare for viewing and annotating and Make available for download selected.

16. In the Allow Downloading in WebCenter area, choose the kind of files to upload to WebCenter.

- **Input files** are the original files themselves.
- **PDF files for proofing** are proxy files created by using the selected ticket. If you choose PDF files for proofing, leave the default Create SoftProof for WebCenter ticket selected, or choose another ticket if desired. Proxy files uploaded in this manner will have Download PDF for printing as an option in WebCenter.

The combination of preparing for viewing but not making available for download is intended for Graphics files that only need Approval.

17. Click the Approval tab.

18. Deselect Start the Approval Cycle.

19. Click Save and Close. Then click Yes to confirm overwriting the ticket.
8.7 Expose WebCenter to the Internet

Exposing WebCenter to the Internet is the responsibility of your local IT department. Esko cannot do this for you.

8.7.1 Register a Domain Name

Register and pay for a domain name, such as www.esko.com, to allow internet users to navigate to your WebCenter site.

Once you have registered the domain name, your company is the only one authorized to use that specific domain name for a certain period.

- Contact a proper authority (VeriSign, GoDaddy, etc) and purchase a domain name.

8.7.2 Contact Your ISP to Set Up an A Record

The purpose of an A record is to associate your domain name to your public firewall/router, so web traffic (HTTP and HTTPS) going to the domain name is routed to that public firewall/router.

Think of this as telling the Postman how to get to your mailbox.

**Note:** It takes several days for the A record information to propagate around the world.

1. Identify the public IP Address of your router/firewall.
   
   This is the hardware appliance your Internet connection is plugged into (i.e. T1, DSL).
   
   For example: My T1 is plugged into a firewall with 66.55.44.33 as public IP address.

2. Contact your ISP and ask them to add an ‘A’ Record (Address record) to the global DNS (Domain Name Servers), associating your domain name and your router/firewall public IP address.

3. Verify that you can ping your domain name from computers inside and outside your LAN.

4. Ensure the reply you get contains the correct IP address for your public firewall/router.

**Example**

MCI is your ISP. You contact MCI and ask them to add an A record for your new domain name, www.esko.com, to forward HTTP and HTTPS traffic to your public firewall IP address of 66.55.44.33.
After about 3 days or so, this record has been propagated across the world. If someone in Thailand ‘pings’ the domain name www.esko.com, he/she should receive a reply with the IP address of 66.55.44.33.

8.7.3 Move the Web Server Inside the Demilitarized Zone (DMZ)

You should physically arrange the network devices so that the web server is in a proper DMZ architecture (between two firewalls or plugged into a DMZ port of the public router/firewall).

1. Configure Firewall 1 (public router/firewall):
   a) Allowed to route traffic to web server inside DMZ for HTTP and HTTPS.
   b) Default ports 80 (HTTP) and 443 (HTTPS).
2. Configure Firewall 2 (gatekeeper for private network):
   a) Allowed to route traffic on specific ports to WebCenter's application server.
   b) Default ports 1099, 2500, 4444.

Note: You can change the default port numbers used at any time—to do this, modify the IIS settings and the WebCenter configuration files on both the web server and the application server to reflect these custom port numbers.

8.7.4 Configure IIS to Receive Traffic

Web traffic is delivered to the public firewall because of the A record. That firewall then forwards the web traffic to the web server inside the DMZ.

The web server application (IIS) needs to be configured to pick up this traffic for processing. To do this, the web server must be assigned a static Private IP Address.

1. On the web server, click Start > Run and type inetmgr. Then click OK to start Internet Information Services (IIS) Manager.
2. Expand the Web Site node.
3. Right-click on the Web Site node and choose Properties.
4. Click the Web Site tab and verify that the IP Address is correct (or use the drop down list to change it).
5. In the TCP Port field, ensure you are using the correct port for HTTP traffic; the default port is 80 (this needs to match your firewall rules).
6. Close IIS Manager.
9. Deploying WebCenter

WebCenter uses a three-tier installation framework to facilitate in-house development and configuration before deploying it in production form. The three tiers are the Installation version, the Development version, and the Production version.

Deployment Workflow
The intended workflow is to install WebCenter, deploy it to Development, modify the Development version, and then when you are satisfied, deploy the Development version to Production.

As time goes by, you can keep modifying the Development version as desired without affecting the Production version. When you are satisfied with the changes made to the Development version, you can deploy it to Production.

At the time of deployment, the custom directory is not overwritten if it already exists in a target instance, so customizationConfig.xml and any other customized files in the custom directory are not changed. But when a new instance is created by deployment, the custom directory is created with its default configuration.

The WebCenter Deployment Manager
The WebCenter Deployment Manager, located in Start > Programs > WebCenter, manages the deployment process. If there is more than one web site on the web server, choose the web site with which the WebCenter Deployment Manager will work and click OK.
To further develop the installed version, use the WebCenter Deployment Manager:

- If you want to change the name of the development version, click the ... button in the Development area, and specify the new name of the development version. When you have changed the name, click **Deploy Development**.

  Web authors can then modify the site at http://WebServer_name/WebCenter_Dev (or whatever name you chose earlier), while normal users can still work using the site at http://WebServer_name/WebCenter_Inst.

- Once the developed version is ready for production use, use the WebCenter Deployment Manager again.

  If you want to change the name and location of the production version, click the ... button in the Production area and enter the new name. Then, click **Deploy Production**.

  The site in WebCenter_Dev will be copied to WebCenter. Production use starts by users pointing their browsers to http://WebServer_name/WebCenter.

**Note:**
You can have multiple development and deployment versions of WebCenter by changing the names for each deployment, e.g. DEV1, DEV_Other, WebCenter_Prod1, and so forth.

Also, the deployment name is not case sensitive, so for example WebCenter_Dev and WebCenter_dev are considered to be the same deployment instances.
10. Localizing WebCenter

Localization is the process of making a program ready to run anywhere in the world. It encompasses modifying the display language, the way units are displayed, decimal separators, time and date formats, and currency format to match the local user preferences.

10.1 Understanding Localization in WebCenter

WebCenter uses references to separate language files (text strings files) instead of using hard-coded words. WebCenter ships with a variety of language files. Additionally, the text strings files can be translated into any language.

Each WebCenter user can change to a different language in My WebCenter > My Preferences. The default language can be changed in General Preferences at any time by any WebCenter user who is a member of the Admins group.

10.2 How to Install Custom Translations

The language files are in the languages subdirectory of the WebCenter installation on the Web server, such as \Artios\WebCenter\WebServer\tomcat\webapps\site name\languages.

They are named wcstrings_xx.xml where xx is a two-letter code for the language, for example en for English, fr for French, and de for German.

1. Copy one of the existing language files, and rename the copy changing the two-letter language code to the new language code.

   **Note:** The language code must match the official list of two-letter ISO 639-1 codes at http://www.loc.gov/standards/iso639-2/englangn.html. For example, a Danish language word strings file would be named wcstrings_da.xml.

2. Translate the strings in the file.

3. On the Web server, open \Artios\WebCenter\WebServer\tomcat\webapps\WebCenter_instance\config\config.xml in a text editor or an XML editor. In the Languages section of the file, add a key for the new language, for example <Language key="da"/> for a Danish translation.

4. Put the translated language file in the languages subdirectory of the WebCenter installation.

5. Open every other wcstrings_xx.xml file and add a <NLanguage_xx>Language</NLanguage_xx> string after the strings for the existing languages.

   For example, add the string <NLanguage_da>Danish</NLanguage_da> to install a Danish strings file, substituting the word for Danish in the appropriate language for the string file.
6. If the chosen language is a multi-byte language (such as Japanese, Chinese, or Thai), log on to the application server and edit \Artios\WebCenter\config\appconfig.xml. Change the value in the index_lang field to the appropriate language code that is listed in the comment below the field, and save the file.

7. Restart the web server to see the changes.
11. The Help System

WebCenter uses a dynamic help system that checks for the existence of specifically-named XSL files on the Web server in `\Artios\WebCenter\WebServer\tomcat\webapps\<WebCenter_instance>\help`. A Help link will appear in the menu of the page that has the same name as an XSL file in this directory. The content of a Help file can be anything provided it is in XSL and the file has an .XSL extension.

**Note:** Esko recommends the use of xmlspy® for authoring WebCenter Help XSL files. It is available from http://www.xmlspy.com. There are also shareware and freeware XSL editors available. You could also modify the sample provided using a text editor such as Notepad; do not use WordPad as it inserts its own formatting codes.

- To change the Webmaster contact name and e-mail address displayed on the login help page, edit login.xsl.
- If using foreign-language files, append _xx (where xx is the code for the language) to the end of the filename before the extension, such as login_fr.xsl for a French help file for the login page.

When determining if a Help link should be on a page, WebCenter looks for a localized Help file, and then for an English one if a localized one is not found. If neither exist, WebCenter does not put a Help link on the page.
12. Upgrading from WebCenter 10.2 or Earlier

12.1 Prepare for the Upgrade

This describes how to upgrade WebCenter 10.2 or earlier to the latest build of WebCenter 12.

**Note:**
This procedure applies to all upgrade installations for WebCenter - even to "minor" updates between builds of the same version.

**Note:**
This procedure is fairly complex and involves direct manipulation of core application and database files. Expert help is available to perform the upgrade for you at a minimal cost: contact your local Esko Customer Services division for a quote and scheduling.

12.1.1 Prerequisites for the Upgrade

**Installation Media and Licenses**
Make sure you have the following at hand before proceeding:

**Media**
- ArtiosCAD 12.0en DVD
- Suite 12 WebCenter DVD (WebCenter)
- Suite 12 Engines Prerequisite Components Installation DVD
- Suite 12 Engines Software Installation DVD

**Licenses**
- ArtiosCAD 12.0en (FlexNet server license)
- WebCenter (plus optionally Task Management, Advanced Approval, PDF download, Reporting, extra concurrent users)
- OBGE (On Board Graphics Engine)

**Information Needed**
Make sure you collect the following information:
- The location of the FileStore (you can find this information in C:\Artios\WebCenter\Config\appconfig.xml).
• The name of the database server, the Oracle Database Identifier (SID) if using an Oracle database, and the database administrator password (sys password).
• The name and location of the WebCenter4_0 database instance (you can find this information in Artios\WebCenter\ApplicationServer\JBoss\server\default\deploy\wc5-ds.xml).
• Your Esko customer login and password for activating licenses.
• The IP address or name of the LDAP server and the port used for the secure connection (typically 636).

12.1.2 Prepare for the Upgrade on the Application Server

1. Copy the following onto the Application Server:
   - ArtiosCAD 12.0en DVD
   - Suite 12 WebCenter DVD
   - Suite 12 Engines Prerequisite Components Installation DVD
   - Suite 12 Engines Software Installation DVD
   - ArtiosCAD license
   - WebCenter license (plus optional module licenses)
   - OBGE license (On Board Graphics Engine)

2. Back up:
   - the FileStore
   - the WebCenter4_0 database
   - the \Artios\WebCenter folder
   - the \Esko\Artios\WebCenter folder
   - any E-mail Notification customizations that may be stored in \WebCenter\ApplicationServer\EmailNotifications\Custom
   - all other non-standard customizations you may have implemented outside of the custom folders

3. Make a restore point for the OBGE.

4. Make a backup of the server software configuration.

   For detailed instructions on step 3 and 4, please refer to the Suite 12 Engines Software Installation Manual.

12.1.3 Prepare for the Upgrade on the Web Server

1. Copy the following onto the Web Server:
   - Suite 12 WebCenter DVD

2. Back up \Artios\WebCenter and any non-standard customizations you have implemented outside of the WebCenter instances.
12.2 Upgrade WebCenter

12.2.1 Remove WebCenter 10.2 or earlier

1. On the Application Server:
   a) Remove the WebCenter software using the Add/Remove Programs applet in the Control Panel.
   b) Reboot the server.
   c) Using Windows Explorer, remove the \Artios\WebCenter and \Esko\Artios\WebCenter folders, and any other remaining WebCenter-related folders.

   Note: Take care not to remove the FileStore if it is inside a WebCenter folder!

2. On the Web Server:
   a) Remove the WebCenter software using the Add/Remove Programs applet in the Control Panel.
   b) Reboot the Web Server.
   c) Using IIS, remove all WebCenter instances (only the default "WebCenter_Inst" is removed automatically).
   d) Using Windows Explorer, remove \Artios\WebCenter, and any other remaining WebCenter-related folders.

12.2.2 Install WebCenter 12

1. On the Application Server, update ArtiosCAD to ArtiosCAD 12en, choosing the options described in Install ArtiosCAD on the Application Server on page 16 and the Use the default configuration upgrade option.

2. Upgrade the licence component using the OBGE prerequisites DVD:
   a) Insert the Suite 12 Engines Prerequisite Components Installation DVD.
      If the DVD does not auto-start, double-click setup.exe in its root folder.
   b) In the window that opens, click English.
   c) Click Software Installation in the main menu on the left of the window.
   e) Click Update the Licensing Components and follow the installer.

3. Activate the Licenses on page 18.

4. Uninstall the old version of ArtiosCAD.

5. Install WebCenter 12, using the English language installer, on the Application Server and on the Web Server, making use of the existing FileStore location and WebCenter4_0 database location.

   Note: The installers in other languages should not be used, until further notice.
See *Installing WebCenter* on page 14 for more information on the installation procedure.

6. *Install Certificates for LDAPS on the Application Server* on page 56.

### 12.2.3 Upgrade the OBGE

**Note:**
- The OBGE must have the same or a later version than the Automation Engine production server.
- Make sure that you do not update any CADx components while updating the OBGE! CADx must only be updated by the ArtiosCAD installer.

Upgrade the OBGE (On-Board Graphic Engine) to Automation Engine 12:

1. Upgrade the prerequisite components:
   a) Insert the *Suite 12 Engines Prerequisite Components Installation* DVD.
      - If the DVD does not auto-start, double-click `setup.exe` in its root folder.
   b) In the window that opens, click `English`.
   c) Click `Software Installation` in the main menu on the left of the window.
   d) Click `Upgrade the prerequisite components of an Esko Software Suite X Release Y to Suite 12`.
   e) Click `Update the Configuration Manager software component` then `Update the Configuration Manager` and follow the installer.
   f) Click `Go back` at the top right corner of the window then click `Check and upgrade the prerequisite components` and follow the installer.

   The prerequisite components are now upgraded.

2. Upgrade the OBGE:
   a) Remove the *Suite 12 Engines Prerequisite Components Installation* DVD and insert the *Suite 12 Engines Installation* DVD.
      - If the DVD does not auto-start, double-click `setup.exe` in its root folder.
   b) In the window that opens, click `English`.
   c) Click `Software Installation` in the main menu on the left of the window.
   d) Click `Upgrade an Esko Software Suite X Release Y Suite 12 Engines`.
   e) Click `Upgrade the Esko Software Suite X software to Suite 12 Engines` and follow the installer.
   f) Change the installation directory to `D:\esko` and click the `Apply to all` button.
   g) Follow the steps of the Installer.

   The OBGE is now upgraded.

3. Test the OBGE and check its configuration (Hot Folder and container, see *Configure the OBGE* on page 37 for details).

4. Uninstall the old OBGE version.

5. Perform *Activate Server* of Suite 12.
6. Check the OBGE again.

12.2.4 Configure WebCenter 12

1. Update the MIME Types in IIS on page 31.
2. Set the WebCenter services to start automatically: first the two services on the Application Server (JBoss and CAD-X), then one service (Tomcat) on the Web Server.
   See Start the WebCenter Services on page 32.
3. If you had WebCenter customizations:
   a) Reapply the email notification customization that you backed up in your custom folder.
   Mentions of an older version of WebCenter are automatically updated to "WebCenter 12".
   b) Apply any standard customizations you saved earlier to your new WebCenter instance(s).
   c) Redo any other non-standard customization that you may have had.
   See the WebCenter Customization guide for more information.

   **Attention:**
   - Do NOT copy the files as the XML structure might be different and you might break it.
   - Do not customize the Default instance of WebCenter as if it doesn’t work anymore you will have to completely reinstall it!

4. Run the WebCenter 12 database scripts matching your database type.
   See Run the Database Schema Scripts on the Database Server on page 21 for more information on the database schema scripts.
5. Log on the WebCenter web interface and change the administrator password (see Log On to WebCenter and Change the Admin Password on page 41).
6. Deploy new WebCenter instances as desired.
   See Deploying WebCenter on page 67 for more information.

The upgrade is complete.
13. Uninstalling WebCenter

1. Log on to the web server as a member of the local Administrators group.
2. Stop the IIS Admin service.
3. Backup all deployed sites within \Artios\WebCenter\WebServer\Tomcat\webapps in case they are needed in the future.
4. Use the Add/Remove Programs applet in Control Panel to remove WebCenter.
5. Manually delete all subdirectories under \Artios\WebCenter.
6. Log on to the application server as a member of the local Administrators group.
7. Back up \Artios\WebCenter\Filestore and all its subdirectories in case they are needed in the future.
8. Use the Add/Remove Programs applet in Control Panel to remove WebCenter.
9. Manually delete all subdirectories under \Artios\WebCenter if you are intending to never again use WebCenter.
   
   If WebCenter is uninstalled with the intention of installing a newer version (and keeping an existing database), do NOT delete the files in \Artios\WebCenter as they contain information needed for the new version to run with the existing admin password.
10. If using Microsoft SQL Server 2005/2008, or Microsoft SQL Server 2005/2008 Express Edition, back up the WebCenter4_0 database and then use Enterprise Manager to manually delete the WebCenter4_0 database.

   If using Oracle, backup the database and either delete the instance, or, if it is shared, connect to the instance and issue the drop user webcenter cascade; command.
11. If the OBGE is installed, remove all the Esko products using the Add/Remove Programs applet in Control Panel. Select all products except the FLEXlm flexid drivers.
12. Remove ArtiosCAD by using the Add/Remove Programs applet in Control Panel. Once all the products are removed, WebCenter should be completely removed.
13. Reboot your machine.