Contents

1. About Automation Engine ........................................................................................................................................... 5
   1.1 Copyright Notice .................................................................................................................................................. 5
   1.2 Getting Help ..................................................................................................................................................... 7

2. What is Automation Engine ........................................................................................................................................... 8
   2.1 The Automation Engine Pilot ............................................................................................................................ 9
      2.1.1 The Pilot’s Main Window ........................................................................................................................... 9
      2.1.2 Views ....................................................................................................................................................... 11
   2.2 Data Management in Automation Engine ......................................................................................................... 13
      2.2.1 Containers ............................................................................................................................................... 14
      2.2.2 The Job Concept .................................................................................................................................... 14
   2.3 File Processing in Automation Engine ............................................................................................................. 15
      2.3.1 Tasks ....................................................................................................................................................... 15
      2.3.2 Workflows .............................................................................................................................................. 16
      2.3.3 Tickets .................................................................................................................................................. 16

3. Getting Started with Automation Engine .................................................................................................................. 18
   3.1 Starting Automation Engine ............................................................................................................................... 18
      3.1.1 Starting the Automation Engine Server Software ..................................................................................... 18
      3.1.2 Installing Client Applications ................................................................................................................ 19
      3.1.3 Starting the Pilot .................................................................................................................................... 21
   3.2 Performing Basic Configuration ......................................................................................................................... 22
      3.2.1 Creating Users ....................................................................................................................................... 22
      3.2.2 Defining User Access Rights ................................................................................................................ 23
      3.2.3 Configuring Output Devices ................................................................................................................ 24
   3.3 Uploading Files using the Pilot ........................................................................................................................... 25
   3.4 Launching a Task on a File ................................................................................................................................ 26
   3.5 Checking the Status of the Task ........................................................................................................................ 27
   3.6 Cancelling a Launched Task .............................................................................................................................. 28
   3.7 Relaunching the Task ....................................................................................................................................... 28
   3.8 Generating Output ............................................................................................................................................ 28

4. Uploading Files to Automation Engine ...................................................................................................................... 29
   4.1 Uploading Files using the Pilot ........................................................................................................................... 29
   4.2 Uploading Files from a FTP Server .................................................................................................................. 29
   4.3 Using Access Points to Upload Files ................................................................................................................ 31
   4.4 Using Shuttle to Upload and Process Files ....................................................................................................... 31
      4.4.1 The Automation Engine Shuttle ............................................................................................................... 31
      4.4.2 Launching a Workflow from the Automation Engine Shuttle .............................................................. 40
      4.4.3 Launching Files from ArtPro .................................................................................................................. 45
10. Example of Building and Using a Packaging Workflow

10.1 Build a Workflow

10.1.1 Preflight your file

10.1.2 Normalize your File

10.1.3 Trap your file

10.1.4 View your file

10.1.5 Generate Step & Repeat

10.1.6 Create Report

10.2 Use Shuttle in the Workflow

10.2.1 What is Shuttle

10.2.2 What are Public Parameters

10.2.3 Making Your Tickets Public

10.2.4 Using Public Parameters

10.2.5 Public Parameters in Sample Workflow: Packaging

10.2.6 Launching Files into a Workflow
1. About Automation Engine

Maximizing Productivity
Automation Engine doesn’t only enable you to keep track of your files throughout your workflow, it also optimizes and automates this workflow to increase your productivity.

Automation Engine:

- avoids double entry and possible operator errors,
- processes files faster (through digital standardization of production procedures, hot folders automation, smart notifications...).
- frees operators from administrative tasks so they can concentrate on value-adding graphical tasks,
- allows operators to share their expertise through tickets,
- keeps jobs, related files and related customer information organized to facilitate communication and treatment of additional orders.

All this maximizes your efficiency and the quality of your deliverables, while lowering the cost of prepress-related actions.

Integrating with your Existing Systems
Automation Engine can integrate seamlessly with your graphical editors, RIPs, file servers, business systems...

It supports the industry standards (PDF, XML, XMP, SQL queries, Web Services, JDF...).

The Automation Engine client application (the “Pilot”) can be installed on any Mac or Windows machine in your network, so all your operators can view files, get information or launch processing tasks as needed.

Growing with You
Automation Engine is very modular and can be tailored to your needs, while always offering growth possibilities.

From a background assistant to Adobe® Illustrator® to a central prepress server to a complete server platform linking to your administrative systems, Automation Engine can grow with you to let you handle larger accounts, accepting more jobs without increasing your costs.

Find more general product information on http://www.esko.com/AutomationEngine.
Software BVBA shall not be liable for any direct, indirect, consequential or incidental damages arising out of the use or inability to use the software or the information contained herein.

The information contained herein is subject to change without notice. Revisions may be issued from time to time to advise of such changes and/or additions.

No part of this document may be reproduced, stored in a data base or retrieval system, or published, in any form or in any way, electronically, mechanically, by print, photoprint, microfilm or any other means without prior written permission from Esko Software BVBA.

This document supersedes all previous dated versions.

PANTONE®, PantoneLIVE and other Pantone trademarks are the property of Pantone LLC. All other trademarks or registered trademarks are the property of their respective owners. Pantone is a wholly owned subsidiary of X-Rite, Incorporated. © Pantone LLC, 2015. All rights reserved.

This software is based in part on the work of the Independent JPEG Group.

 Portions of this software are copyright © 1996-2002 The FreeType Project (www.freetype.org). All rights reserved.

 Portions of this software are copyright 2006 Feeling Software, copyright 2005-2006 Autodesk Media Entertainment.

 Portions of this software are copyright ©1998-2003 Daniel Veillard. All rights reserved.

 Portions of this software are copyright ©1999-2006 The Botan Project. All rights reserved.

 Part of the software embedded in this product is gSOAP software. Portions created by gSOAP are Copyright ©2001-2004 Robert A. van Engelen, Genivia inc. All rights reserved.

 Portions of this software are copyright ©1998-2008 The OpenSSL Project and ©1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.

 This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

 Adobe, the Adobe logo, Acrobat, the Acrobat logo, Adobe Creative Suite, Illustrator, InDesign, PDF, Photoshop, PostScript, XMP and the Powered by XMP logo are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

 Microsoft and the Microsoft logo are registered trademarks of Microsoft Corporation in the United States and other countries.

 SolidWorks is a registered trademark of SolidWorks Corporation.

 Portions of this software are owned by Spatial Corp. 1986 2003. All Rights Reserved.

 JDF and the JDF logo are trademarks of the CIP4 Organisation. Copyright 2001 The International Cooperation for the Integration of Processes in Prepress, Press and Postpress (CIP4). All rights reserved.

 The Esko software contains the RSA Data Security, Inc. MD5 Message-Digest Algorithm.

 Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems in the U.S. and other countries.

 Part of this software uses technology by Best Color Technology (EFI). EFI and Bestcolor are registered trademarks of Electronics For Imaging GmbH in the U.S. Patent and Trademark Office.


 Part of this software uses technology by Global Vision. ArtProof and ScanProof are registered trademarks of Global Vision Inc.

 All other product names are trademarks or registered trademarks of their respective owners.
1.2 Getting Help

You can find the html version of this manual in the Automation Engine Pilot, under Help > Contents...

To get an overview all of the keyboard shortcuts you can use in the Automation Engine Pilot, go to Help > Keyboard Shortcuts... in the Pilot.
2. What is Automation Engine

Automation Engine Architecture
Automation Engine is a client-server workflow software. The server software requires a Windows computer, but the client the Automation Engine client tools Pilot or Shuttle that access and use the software can be installed on any Mac or Windows in your (LAN) network.

Your Automation Engine server can connect to graphical editing applications like ArtPro, PackEdge, Adobe Illustrator (using the DeskPack plug-ins)...

It can also connect to your RIP software to ensure professional output. Since v14, Automation Engine also offers on-board RIP task from Esko’s Imaging Engine.

You can store your files either on the Automation Engine server, on a dedicated file server, or on different machines over the network.

Automation Engine Processing
Automation Engine processes your files using single Tasks (for example a Trap task or a RIP task), or Workflows (a more powerful and flexible series of tasks that can take complete care of the file from arrival to final output).

Files and Jobs in Automation Engine
In Automation Engine, your files can be part of Jobs (customer orders that contain files and related customer information), that are located in Containers (local or remote shared folders that Automation Engine can access).

Depending on how you want to work with Automation Engine, you can link your jobs to customer Products, focus on job Pages, Proofs, Plates...
Automation Engine Integration

Automation Engine can not only connect to editing and RIP applications, but also to WebCenter (Esko’s web collaboration platform) and other Esko legacy workflow software (Nexus and Odystar). Automation Engine can also be integrated with external systems.

2.1 The Automation Engine Pilot

The Pilot is Automation Engine’s main client application. Depending on their User Access Rights, users can use the Pilot to:

- organize Jobs, Products and files,
- create and modify tickets or workflows,
- launch and monitor tasks tickets or workflows,
- control queues and devices,
- set up general configuration and administrate users
- etc.

The Pilot can be installed on a Mac or Windows computer in the same local network (LAN) of your Automation Engine server. Find detailed system requirements on http://www.esko.com/systemrequirements.

The Pilot is one of the tools that you can download with the Automation Engine Server Web Page. Open this Server Web Page by entering http://<name of your master server> or http://<name of your master server>:9999 in the address field of your browser. You can find this tool in the section Client Apps, in the page Main.

Tip: Connection problems with the server can be diagnosed by using the Troubleshooting the Pilot.

2.1.1 The Pilot’s Main Window
1. These icons show different modes in the Pilot:
   - **Containers**: This shows all the data that Automation Engine can access, in the different Containers. Learn more in [Containers](#) on page 14.
   - **Job Overview**: This lists all jobs existing in the Automation Engine jobs database. Learn more in [Jobs](#).
   - **Last used Job**: This shows the last job you worked on, and the job’s data (files and folders).

2. The **Views** highlight different parts of the Automation Engine functionality. Certain views are only accessible in defined workflows. Learn more in [Views](#) on page 11.

3. The **Tools** area contains tools useful to administrate Automation Engine. Learn more in [The Tools](#).

4. **Create Job** button allows you to create a job.

   - **New Task** button creates a new Ticket from the pilot.

   You can create a new workflow from the pilot using [here](#).

   - **Info** button shows the file’s XMP metadata.

**Note**: In the Job Overview mode, only Create Job is available.
The contents of the central panes depend on the View you are in.

**Tab support**

In any Automation Engine view, a new tab can be created by using one of the following methods:

- Click **File > New Tab**.
- Use the keyboard shortcut **Control-T** (Windows) or **Command-T** (Mac).
- If the tab bar is visible, you can also create a new tab by clicking the plus button in the tab bar.
- If the tab bar is visible, you can also create a new tab by right-clicking on the tab bar and choosing **New Tab**.

**Note:** The new tab will open with the same view that was active.

An opened tab can be closed by one of the following methods:

- Click on the close button in a tab (visible by hovering over the tab).
- Use the keyboard shortcut **Control-W** (Windows), or **Command-W** (Mac).
- Click on **File > Close Tab**.
- Right-click on the desired tab and choose **Close Tab**.

**Note:** To close all other tabs, save the desired one, you can also choose **Close Other Tabs** from this menu.

**Full Screen Mode on Mac**

When running the Automation Engine Pilot on Mac OSX or newer, you can enter and exit the Full Screen Mode by using one of the following methods:

- Click on the **Full Screen** button in the top right corner of the main window
- Click on **Views > Enter Full Screen**.
- Use the keyboard shortcut **Command + Control + F**.

### 2.1.2 Views

The Pilot’s Views highlight different parts of the Automation Engine functionality. You can use them to work with your data in different ways (see *Different Ways of Working with Automation Engine*).

**Note:**

- Depending on the Data View mode you are using (**Containers, Job Overview** or **Last used job**), you will have access to different views. Only those that make sense are shown.
- Depending on your access rights, you may not be able to see some of the views.

**Files**

The *Files* view allows you to manage your jobs, files, favorite tickets, tasks... Learn more in *The Files View* for more information.
To Do List

The **To Do List** view lists all actions that need user intervention. Learn more in *The To Do List View* and *To Do List*.

Pages

The **Pages** view is only used in page workflows. It is extremely useful when working with page impositions. For more information, see *Working with Pages*.

Products

The **Products** view shows the items you added to your Products database. This concept is useful to customer who have re-prints. Products represent production data that you linked to a Job. It is the Job order that has the specifications how to output the product this time, with or without many other Product items.

Products are what you keep long term, until you are sure you will not have to produce them again. Jobs however are Work In Progress, temporary by definition. A Job should be removed when it is finished. Learn more in the dedicated chapter *Products*.

Proofs

The **Proofs** view is only used in page workflows. It shows the proof sets and the proof details. Learn more in *Working with Proofs*.

WebCenter

This view enables Pilot users to see what documents are inside a WebCenter project, without having to use a browser. Read more in separate chapter *Integrating with WebCenter*, in its section *The WebCenter View in Automation Engine Pilot*.

Plates

The **Plates** view is only used in page workflows. It shows details about all plates associated with a job. It also includes advanced features for managing plates for jobs with multiple variants. Learn more in *Working with Plates*.

CDI

The **CDI** view shows all the files sent to the Digital Flexo Suite and used to image a flexo plate on a Cyrel Digital Imager. See *The CDI View*.

Gang Run Printing

The **Gang Run Printing** view in the Pilot shows an overview of all graphics waiting to be nested and printed on your available substrate sheets. It has two parts:

- The list of all substrates.
- The table of graphics waiting to be nested and printed on the selected substrate.

For more information, please see *The Gang Run Printing View* in the separate chapter *Gang Run Printing for Sign & Display*. 
Tasks
The Tasks view shows the running tasks, the tasks waiting for execution and the finished tasks. Learn more in The Tasks View. This list of tasks can be automatically cleaned up by using Task Cleanup Rules.

Devices
The Devices view lists all output devices connected to your Automation Engine server. It allows you to monitor, start and stop your devices and device queues.

Milestones
The Milestones view shows the milestones set for your job (in Last used job mode), or shows the milestones set for all jobs (in Job Overview mode). Learn more in Milestones: Tracking Job Status.

Tickets
The Tickets view shows a list of all tickets available on your server (both the default and your custom tickets). Learn more in Tickets on page 16.

Jobs
This view is only visible in Job Overview mode. It lists all or a filtered list of your jobs in the Automation Engine job database. Learn more in The Job Views.

SmartNames
This view lists all SmartNames defined on the server. It is not visible in Job Overview mode. Learn more in The SmartNames View.

2.2 Data Management in Automation Engine
Automation Engine works with files and folders in Containers: data shares you allow Automation Engine to access.

Optionally, you can use

- Jobs: a database representation of "jobs to do". Each job has its specific parameters, one being the folder containing the data for that specific job. In the Pilot, Job Folders show up as a blue folder.

- Products: a database representation of one-up assets, easily linked to job where they play a part in. This is typically used at packaging and labels sites who want to automate data management in print re-runs.

Customers with page (imposition) workflows typically use the Jobs tool and also these extra modes:

- Pages
- Proofs
2.2.1 Containers

A **Container** is a network share that contains data that Automation Engine can work with. These Containers can be located on your Automation Engine server or on another computer in the same LAN.

You can create a Container by using (part of) an existing network share or you can have Automation Engine create the network share while creating a Container.

The installation of Automation Engine by default creates an **ExampleJobContainer** on the disk drive where you installed the server software.

You can add many more Containers. You can see and browse through them in the Pilots’ **Containers** mode. An example:

![Automation Engine Pilot](image)

2.2.2 The Job Concept

**What is an Automation Engine Job?**

An Automation Engine Job represents an amount of work to be done for a certain order in your business system. This can be a classic order management system but it could also come from a web application that needs Automation Engine to execute some prepress tasks.

A Job is an entry in the Automation Engine Jobs database and has a unique name. In the Pilot, Jobs are represented by this blue folder icon.

In Automation Engine, a Job consists of 2 things:

- **data**: files and folders, stored under the Job’s **Job Folder**, in a Container.
- **metadata**: the parameters of that job order, usually how the order management system describes this job. They can be general parameters like the job’s name, order ID, customer and due date but can also be parameters describing what to do with the input files to get to the targeted result.

Jobs can be created manually by an Automation Engine user or automatically via some integration with an external system.

A Job represents Work In Progress (WIP). This means that you should remove Jobs that are ‘done’. Removing a Job from the Automation Engine Jobs database does not mean that you have to delete the related data files.
Most Automation is based on Jobs

A lot of the automation that Automation Engine brings comes from the fact that tasks can automatically use parameters from their Job context. Job parameters automatically become SmartNames and the (workflow) task tickets can use those SmartNames to pick up their values.

Note: Customers that do not use Jobs at all find a similar level of automation by using Workflow Parameters. Learn more in Using Workflow Parameters.

Launching tasks on Jobs

Jobs can be managed manually in the Pilot, but several actions are also possible by launching tasks.

- The Create Job task task allows to create and modify Jobs.
- The Check Job Parameters task allows to check and correct barcode and ink parameters used in designs.
- The Archive Job task and the Restore Job task allow to remove Jobs, store their data on a different network place and, if needed later, restore them back, including their metadata.
- The Relocate Job task allows to move a Job’s Job Folder to a different place. For example to another Container that has more disk space.

Learn more about these tasks in Tasks you can Launch on Jobs.

Like all tasks, these tasks can also be triggered by an external system. Learn more in Integrating with External Systems.

2.3 File Processing in Automation Engine

In Automation Engine, you can process your files using single Tickets or Workflows (a sequence of Tickets).

Launching those tickets or workflow results in (a series of) Tasks.

A Ticket contains all the parameters for that task.

2.3.1 Tasks

What is a Task?

A task is an action executed on a file, a folder or a Job on the Automation Engine server.

Types of Tasks

There are seven types of tasks:

1. Conversion tasks such as Export to PDF, Export to PostScript...
2. File Creation tasks such as Create Wrapper File, Create PAF / JPG / XML...
3. File Editing tasks such as Contourize & Clean, Trap...
4. Verification tasks such as Check Job Parameters, Check Print Rules, Preflight...
5. Administration tasks such as Prepare to Archive, Upload via FTP, Zip...
6. RIP tasks.
7. Device Output tasks.
Task Settings
You can define settings for the tasks, and save these settings as Tickets to reuse them (see Tickets on page 16).

Task Progress
When a task is launched, you can monitor its progress in the Pilot. See Checking the Status of the Task on page 27.

2.3.2 Workflows
You can build Workflows and launch them on your files using the Workflow Editor. Learn more in Building Workflows using the Workflow Editor.

You can also launch them from the Pilot, from Shuttle (see Using Shuttle to Upload and Process Files on page 31) or from within most Esko Editors. They can also be launched automatically, triggered by external signals (files arriving, commands from external systems, etc.).

Learn more in the dedicated chapter Workflows.

2.3.3 Tickets
What is a Ticket?
The settings used when executing a task or workflow on a file can be saved as a ticket.

Default and Custom Tickets
The Pilot comes with a default ticket for each task type, but you can also create custom tickets. You cannot overwrite or delete default tickets.

You can see all the available tickets (default and custom) in the Pilot’s Tickets view.
Global and Job Tickets

Global tickets ( ) can be used on any file you can access through the Pilot. Job tickets ( ) are only available when you work in the Job that you saved them for.

Public Tickets

You can make tickets public if you want to submit files to them from Shuttle. There are several ways to make a ticket public (see Making Your Ticket Public on page 32 in the User Guide).

Public tickets have a mark in the Public column.

<table>
<thead>
<tr>
<th>Task Type</th>
<th>Ticket Name</th>
<th>Public</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zip</td>
<td>Zip_1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Workflow1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Workflow2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Workflow3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Workflow4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Workflow5</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Note: Depending on your access rights, you may only see public tickets, and public parameters inside the tickets.
3. Getting Started with Automation Engine

3.1 Starting Automation Engine

To start working with Automation Engine you need to:

- Start the Automation Engine server software, see Starting the server.
- Start the Automation Engine Pilot, see Starting the Pilot.

3.1.1 Starting the Automation Engine Server Software

Automation Engine offers a web page for server administration and other various tools. You can access the server administration tool from any workstation by typing http://servername or http://servername:9999/ in your web browser.

On this Automation Engine Server Web Page you will also find the client application(s) as the Pilot, the Shuttle, a Diagnostics tool etc.

Starting the Server is part is documented in the dedicated chapter Automation Engine Server Management, in the sub page Status Overview.

Here is a view on that page:
3.1.2 Installing Client Applications


In the Main page, click the Download button next to Client Applications. This download includes the Pilot, Shuttle and a Diagnostics tool.

A shortcut for Pilot and Shuttle will be created during installation.

Installing Client Applications on Mac

1. Go to the Client Apps page of the Server Web Page. Click the Download button next to Client Applications.

2. Open the downloaded installation file Automation Engine Client <version number> .dmg.

3. Follow the installation instructions.

Client applications will be available in the Applications folder.

Installing Client Applications on Windows

1. Go to the Client Apps page of the Server Web Page. Click the Download button next to Client Applications.

2. Open the downloaded installation file (Automation Engine Client <version number> .exe).

3. Follow the installation instructions.
Automation Engine Client applications will be available Start > Esko > Automation Engine Client <version number>.

Updating the Automation Engine Pilot

The Pilot and the Automation Engine Shuttle display automatic update alerts. This makes sure that the latest version of these applications are available.

- While starting the Automation Engine Pilot for the first time, in the Logon Information window, enter User name, Password and the Server name. Click OK.

- If the version of the Pilot matches that of the Automation Engine Server, the main Pilot window will open.
- If there is a major version mismatch among the Pilot and the Automation Engine Server, you cannot login to the Automation Engine Server. You will be alerted with a warning.
- If there is a build mismatch among the Pilot and the Server, the Software Update dialog will pop up.

- Click Install Update. The Pilot will stop and the Updating Automation Engine Pilot dialog will appear.
  On Mac, you need to enter the credentials of an administrator use to update the Pilot application.
The Updating Automation Engine Pilot dialog indicates the download progress.

- At the end of the download, this window displays Ready to install message. Click the Install and Relaunch button to install the update.

After the update is installed, the Pilot application will be relaunched and you will be asked to enter credentials in the Logon Information window again.

**Note:** You can use the same procedure to update Automation Engine Shuttle.

### 3.1.3 Starting the Pilot

On your Automation Engine client machine:

1. Do one of the following:
   - double-click the Pilot desktop icon,
   - go to *Start > All Programs > Esko > Automation Engine Client 10.0 > Pilot*.

2. In the Logon Information dialog that opens:
   a) Enter a **User name** and **Password** valid for your Automation Engine server.

**Note:**
Before you define any user, you can log in using admin as both user name and password. Once you have created users (see *Creating Users* on page 22), you can log in with one of your users’ credentials.

   b) In **Server**, enter either your Automation Engine server’s name or its IP address.

   c) Click **OK**.
3.2 Performing Basic Configuration

3.2.1 Creating Users

1. In the Pilot, go to Tools > Users.
2. In the Users window, do one of the following:
   • go to File > New User,
   • use the CTRL + N shortcut,
   • click the icon.

   The New User dialog opens.
3. Enter the user's Name, Full Name, Password, Description and valid E-mail address.
4. If you want the user to be able to administer Automation Engine, check the toggle.
   This will give all user access rights to that user.
5. Click OK to add your new user to the Users list.
3.2.2 Defining User Access Rights

Not all users have the same responsibilities, so you can assign them different access rights in Automation Engine.

- To give access rights to a single user:
  a) in the Users window, double the user you want to give access rights to,
  b) in the Access Rights tab of the Properties window, check the access rights you want this user to have.

- To give a particular access right to several users:
  a) in the Users window, click the Access Rights button to switch to the Access Rights view,
  b) select the access right you want to give to your users,
  c) check the users you want to give this access right to.

Note: Automation Engine Administrators automatically have all access rights. You cannot change this.
3.2.3 Configuring Output Devices

Automation Engine can output files to a variety of output devices (CDI, HP Indigo, Kodak Approval, etc.).

Automation Engine uses Esko’s FlexRip engine to RIP the file in preparation for output.

To connect Automation Engine to an output device, you need to connect it to FlexRip.

1. In the Pilot, go to Tools > Configure.
   This opens the Configure dialog.

2. Select the option corresponding to your output device in the list at left (for example, select FlexRip - Proofer Output to output to a proofer).

3. Go to File > New or use the Insert key (on Windows).
   This shows tabs with parameters at right.

4. In the General tab:
   a) To output to a RIP, enter the name or IP address of your RIP server in RIP Node.
      For a FlexProof output, enter the name / IP address of your proof server in Proofer Node.
   b) Enter the EskoLink port number used by the Dispatcher in EskoLink Portnr. (only for FlexRip outputs).

   Note: You can find that port number by going to Info > Ports in the Dispatcher.

   c) Click the Synchronize with Rip / Synchronize with ProofNode button.

   After a few seconds, your RIP/proof server is connected to Automation Engine, and you can see its name in the Type field.

5. In the Queue tab:
   a) Give your queue a name in the Queue field.
   b) Choose a Queue Job Limit:
      • choose 1 to have the RIP handle one file at a time (this ensures the files are ripped in the order they enter the RIP),
• choose 2 to have the RIP handle two files at once (the files may not be ripped in the order they enter the RIP if for example you send a big then a small file).

6. Go to **File > Save** to save the configuration.

You can now see the devices you are connected to in the Pilot's **Devices** view.

### 3.3 Uploading Files using the Pilot

In the Pilot, in the **Container** mode or in the **Last used Job** mode, you can use these methods to manually upload files:

- Drag and drop files or folders from outside the Pilot onto a folder in the Pilot. Or use copy/paste shortcuts.
- Right-click your destination folder or go to **File > Upload Files...**. In the browser dialog that opens, browse to your file or folder and click **Upload**.

**About multiple uploads and cancelling**

When the upload is not immediately finished, an **Upload** window appears and you can continue working with the Pilot. You can upload multiple sets of files. When other files are still uploading, they will be added to the **Upload** window.

All uploads can be canceled individually. The uploading will stop immediately and the partially uploaded files will be deleted.

When all uploads are done, the **Upload** window automatically closes.
3.4 Launching a Task on a File

There are several ways to launch a task on a file (from the Pilot, from Shuttle, via Access Points or via JDF/JMF). Here is how to launch a task from the Pilot’s Files View.

1. In the Pilot, select the Files view from the Views bar (or use Go > Files).
2. In the Containers mode, browse to your chosen file.
3. Right-click it, select New Task then More Tickets...

   Note: If you have launched tasks previously, the most recent task tickets you used are listed above More Tickets...

4. In the Select Ticket dialog that opens, select the task ticket you want to use.

   Note: This dialog contains all the tickets suitable for the file type you selected. You can choose either a Default ticket, or a custom ticket (saved under a different name) if you have already created one.

5. Click OK.

   This opens the task's ticket. An example:
6. Fill in the settings you want to use in the ticket.

   **Note:** For a description of all of the ticket's settings for each task, see *The Tasks and Workflow Controls* in the Reference Guide.

7. Click the **Launch** button.

   You can monitor the tasks progress in the **Files View's Task** pane or in the **Tasks View**. See *Checking the Status of the Task* on page 27.

### 3.5 Checking the Status of the Task

After launching a task on one or several file(s), you can check its processing status in the Pilot's **Tasks** pane. You can see the **Tasks** pane in the **Files**, **Product** or **Tasks** views.

You can see the progress (in percentage) and the processing state. The state can be:

- 🔄: starting
- ✔️: success
- ⚠️: warning
• ☒: failure

• ⏲: processing cancelled

You can also double-click the task entry in the **Tasks** pane to open your task ticket and check its parameters.

**Note:** Depending on your *access rights*, you may only see the public parameters.

### 3.6 Cancelling a Launched Task

You can cancel a launched task by right-clicking on the task and choosing **Cancel**. When it was successfully cancelled, the task will show the cancelled state with this icon: ⏲

**Note:** Tasks that are already too far in their processing or are no longer under control of Automation Engine (for example FlexRip tasks) can no longer be cancelled.

### 3.7 Relaunching the Task

- To relaunch the task without changing the settings:
  a) Select the task to relaunch in the **Tasks** pane.
  b) Go to **Tasks > Relaunch**.

- To change the settings and relaunch the task:
  a) Select the task to relaunch in the **Tasks** pane.
  b) Go to **Tasks > Open**.
  c) Change the task settings as necessary.
  d) Click the **Launch** button.

### 3.8 Generating Output

To output a file, use a task related to the output device you have configured (see *Configuring Output Devices* on page 24).

For example, use the **Proof (FlexProof)** task if you have configured a proofing device using **FlexRip - Proofer Output**.

**Note:** The task related to your output device will only be available once you have correctly configured your output device.
4. Uploading Files to Automation Engine

You can work with files that are already stored in your Containers, or upload new files to Automation Engine. You can upload files onto the Pilot, or by using the Shuttle application and plug-in. Access Points can also upload data but they will also already trigger a workflow task.

4.1 Uploading Files using the Pilot

In the Pilot, in the Container mode or in the Last used Job mode, you can use these methods to manually upload files:

- Drag and drop files or folders from outside the Pilot onto a folder in the Pilot. Or use copy/paste shortcuts.
- Right-click your destination folder or go to File > Upload Files... In the browser dialog that opens, browse to your file or folder and click Upload.

About multiple uploads and cancelling

When the upload is not immediately finished, an Upload window appears and you can continue working with the Pilot. You can upload multiple sets of files. When other files are still uploading, they will be added to the Upload window.

All uploads can be canceled individually. The uploading will stop immediately and the partially uploaded files will be deleted.

When all uploads are done, the Upload window automatically closes.

4.2 Uploading Files from a FTP Server

1. In Containers mode or when in a Job, right-click the folder in which you want to upload your file, and select Upload from FTP Site...
This opens the **Upload from FTP Site** dialog, where you can enter the details necessary for the FTP connection.

2. In **Host**, enter the name of the FTP server that hosts your files.

   **Tip:** To use a port other than the default port, add : and the port number after the host name. For example: `myftpserver:1085`

3. Enter the **User Name** and **Password** you use to connect to the FTP server.

   Make sure you use a valid **User Name** and **Password** corresponding to an account that exists on the FTP server.

4. In **File Transfer**, choose between **Binary** and **ASCII**.

   **Binary** will always work, but if you have an ASCII file, the transfer will go a bit faster when selecting **ASCII**.

5. By default, the transfer uses Active **Connection Mode** (where the FTP server opens the data connection).

   If your system is behind a firewall that blocks incoming FTP server connections, select **Passive** to use Passive Connection Mode (where the client initiates the connection).

6. Select **Secure FTP** if you are connecting to a secure FTP server (over FTPS, not SSL or SSH).

   **Tip:** If you are experiencing problems using secure FTP, try connecting over regular FTP, and ask your IT administrator to check the security settings of your FTP server.

7. If you want, you can delete the files from the FTP site once they are uploaded to the Pilot (select **Remove remote data after transfer**).

   If you do this, you can choose to **Backup remote data before removal**. Select the **Backup Folder** in which to copy the files.

8. When you are done, click **Connect**.
4.3 Using Access Points to Upload Files

Access Points are documented in the dedicated chapter Integrating with External Systems.

4.4 Using Shuttle to Upload and Process Files

You can upload and process files from any Mac or Windows client computer using the Shuttle application.

4.4.1 The Automation Engine Shuttle

The Automation Engine Shuttle is a client tool for easy submission of files to Automation Engine workflows. Shuttle also allows monitoring of the workflows.

The Shuttle is one of the client tools that you can download with the Automation Engine Server Web Page.

Open this Server Web Page by entering http://<name of your master server> or http://<name of your master server>:9999 in the address field of your browser. You can find this tool in the section Client Apps, in the page Main.

If the Shuttle application is already installed on your computer, the system will check if you have the appropriate version and download updates if necessary.

**Attention:** As explained in Shuttle, you first need to configure your Shuttle in Tools > Configure > Shuttle.

What is Shuttle?

Shuttle is a small stand-alone application that enables you to submit files to Automation Engine tasks or workflows, Odystar canvases, and Nexus workflows, and monitor their progress. You can use Shuttle to connect to several servers.

The Shuttle functionality is also integrated in ArtPro, Neo, PackEdge, Plato, FastImpose and in Adobe Illustrator as a DeskPack plug-in.

Shuttle Setup

**Automation Engine Setup for Shuttle**

1. In the Pilot, go to Tools > Configure.
2. Select Shuttle in the left pane.
3. Enter the **Port** to use for communication between your Automation Engine server and the Shuttle clients.

   **Note:** By default this is port 5182, but if this port is already used by other processes, you should enter the next available port.

4. Choose an **Upload Folder** using the **Browse...** button.

   This is where Shuttle clients will upload files that are not located in a container (except the Shuttle plug-in, that will always upload files to the **DeskPackContainer**).

   **Note:** The **Upload Folder** must be located on a container.

5. Select **Start Shuttle server automatically when Automation Engine is started** if you plan to make frequent use of the Shuttle technology.

6. Click the **Start** button to start Shuttle server.

   Shuttle server makes Automation Engine’s workflows, tasks and files accessible to the Shuttle clients.

7. Save your settings.

   **Note:** If you need to make changes to this Setup, you must **Stop** the Shuttle server first.

---

### Making Your Ticket Public

**Important:** Only Public tickets or workflows can be launched from the client applications mentioned [here](#).

**Note:** Default tickets can not be made Public.

To make a ticket **Public**, you can either:
• Select the **Public** option when creating the ticket.

![Image of Save As dialog box]

• Select your ticket in the **Ticket** view, click ![Information icon] and select **Public**.

![Image of Task Type dialog box]

• Right-click your ticket in the **Tickets** view and select **Make Public**.

**Note:** Public tickets have a mark in the **Public** column.

<table>
<thead>
<tr>
<th>Task Type</th>
<th>Ticket Name</th>
<th>Public</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zip</td>
<td>Default</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>WC_Approved</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>UnderTherules</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>TrapHIT</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Trap Nested1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>SingleTrap</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>SetPDF8</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Shuttle Clients Connecting to Any Server**

The Automation Engine Shuttle, the Shuttle plug-in, and the Shuttle clients in ArtPro, Neo and FastImpose Standalone can connect to a number of Odystar, Nexus and Automation Engine servers.

1. Launch your application.
2. Open the **Preferences**.
3. In the **Servers** tab (Advanced tab for Neo), click the button at the bottom of the **Servers** list.

   ![Server List](image)

   The following dialog will prompt.

   ![Login Dialog](image)

4. Enter your **User Name** and **Password**.
   - When connecting to an Automation Engine server, enter the **User Name** and **Password** you use to log in to the Pilot (the password can be blank if your server is configured to accept this).
You will have the same access rights (for example, the right to set processing priorities or not) in Shuttle as you have in the Pilot.

**Note:** If you don't know which **User Name** and **Password** to use, contact your system administrator.

5. To connect to a server *not* broadcasting over the Bonjour network (Automation Engine servers or non-Bonjour-enabled Nexus servers):
   a) Select **Manual** in the **Browse Method** list
   b) Enter your server’s name or IP address in **Server Address**
   c) Fill in the **Server Port** used by your server

   **Note:**
   When connecting to an Automation Engine server, enter the port you defined in Configure (see *Automation Engine Setup for Shuttle* on page 31).

6. Click the **Add** button.

   This adds a connection to your server in the **Servers** list.

   • To remove the connection to a server, select it in the **Servers** list and click the **button.

   • To check or edit a server’s settings, double-click it in the **Servers** list.

   **Note:**
   If you are using the Shuttle plug-in with other Deskpack plug-ins, and you have set up a server connection with the **Server Connection Assistant**, you will see this connection in bold in the Shuttle plug-in’s **Servers** list (after restarting Illustrator).

   You will be able to change the user name and password if necessary, but you will not be able to remove this connection from the Shuttle plug-in.

   See the Adobe Illustrator Client documentation for more information on the Server Connection Assistant.

Shuttle Clients Connecting only to Automation Engine

The Shuttle clients in PackEdge, Plato and FastImpose Server can only connect to one Automation Engine server.

1. Launch your application.

2. Open the **Preferences**.

   • In PackEdge or Plato, go to *Edit > Preferences* or use **Ctrl+Alt+Shift+P**.
   • In FastImpose Server, go to *Tools > Options...*

3. In the **Server&Resources** tab (the **Server** tab for FastImpose Server):
   a) Select **Connect to Automation Engine Server**.
   b) Enter the Automation Engine **Server Name** and click **Check**.
      You should see a message saying the server is up and running.
   c) Select **Login with the following user account settings**, and fill in the **User Name** and **Password** you use to login to the Pilot.
If the connection is successful, you will see a green dot and the message **Connected as user ...**

![Shuttle Connection Panel]

**Tip:**
If you are running an Automation Engine Pilot on the same computer, or another Shuttle client connecting to it (either PackEdge, Plato or FastImpose Server), you can select **Login automatically with user name and password from other application connected to the server**.

This way, if you are already logged in to the Pilot or the other client application, you won’t need to log in when starting PackEdge / Plato / FastImpose Server.

4. Restart your application.

**Launching the Automation Engine Shuttle**

When you launch the Shuttle application from your installed programs, a pop up window with the Shuttle Launch panel and a Task Monitor will appear.
To open a new window, go to **File > New Window**. You can use dedicated Shuttle windows for each of your Workflows.

Shuttle saves the settings of the open windows while closing. These settings are restored during the next launch.

You can use **View** menu to hide or show the Task Monitor, Shuttle Launch panel and the Status Bar.

- **View > Tasks** hides/shows the Task monitor.
- **View > Launch Panel** hides/shows the Launch Panel.
- **View > Status Bar** hides/shows the Status Bar indicating the progress.

**Working with the Automation Engine Shuttle**

You must login to the Automation Engine Server to use the Shuttle.
Note: You have access to Shuttle if you have access to Pilot. But your access to Pilot may be restricted even when you are allowed to use Shuttle. This requires a user access right (Pilot: start the Pilot (in addition to Shuttle)). Read more in Access Rights.

The following menus are available in the Shuttle application on Mac and Windows:

- **File** menu: Submit one or more files and launch the selected Workflow, open new Shuttle windows and close Shuttle windows.
- **Edit** menu: cut, copy, paste, delete a Task or Workflow, select all Tasks and Workflows in the Task Monitor.
- **View** menu: show or hide the Task Monitor, the Shuttle Launch panel and the Status Bar.
- **Task** menu: open or show the output file of the selected Task or Workflow, release or cancel the Task or Workflow, add annotations and show detailed information.
- **Window** menu: minimize, zoom and switch between Shuttle windows.
- **Help** menu: See the About window or open the Online Help (Esko Help Center).

### Setting the Preferences for Shuttle

- On Mac, select **Preferences...** in the Application menu.
- On Windows, go to **Edit > Preferences...**

In the Preferences window, set the units for **Dimension**, **Resolution**, **Ruling** and the number of **Decimals** to use.

You can also select the **Always show launch dialog** option. This will show the Public Parameter dialog upon starting a new task, even if there aren’t any public parameters. This allows you to alter these types of tasks before they launch.

### The Task Monitor

When you are logged in, **The Task Monitor** displays your Automation Engine Workflows launched from both the Shuttle and the Pilot.

To filter the displayed Workflows, you can choose a job context filter.

- Go to the drop-down list in the toolbar and select the desired job. All recently used jobs are listed in this list.
If the desired job is not present in the list, choose Other... The Open dialog will prompt where you can choose the desired job.

Choose the menu item "All Jobs" to clear the current filter.

Note: You cannot view, open or edit the Tickets of the Tasks or the Workflows in the Task Monitor. This is only possible in the Automation Engine Pilot.

Intervening in a workflow
You can intervene when a workflow is halted for user intervention provided the Workflow user intervention settings designate you for intervention. To intervene,

- Click on User intervention needed link of a workflow.
- In the resulting To Do window, choose to Forward or Release.

Tip: You cannot hide the columns displayed in the Task Monitor. However, you can change the order and the width of the columns.

Context menu options
Right-click on a workflow/task to access the context menu with the following options:

- Open Output File opens the output file of the Task or Workflow with the appropriate application.
- Show Output File in Finder/Explorer shows the folder that contains the output file in Mac Finder or in Windows Explorer.
- Release allows you to release the Task or Workflow if it is on Hold.
- Cancel allows you to cancel the Task or Workflow.
- Delete allows you to delete the Workflow from the list of Workflows the Task Monitor.
- Annotation... shows a dialog that allows you to add or modify an annotation.
- Details shows the Details dialog with detailed information about the Task or Workflow.

Alternatively, these options are also available via the Task menu of the Shuttle application.
The Shuttle Launch Panel

You can drop one or more files as input files for the selected Workflow/Task through the Shuttle Launch Panel.

- Browse to the desired workflow using the Workflow drop-down list. This will be updated when new workflow tickets are created. Shuttle launches the selected workflow when files are placed in the Shuttle Launch panel.

  **Attention:** The drop-down list only shows the Workflow Tickets that are public.

- The selected workflows are saved when you quit Shuttle. Shuttle restores the selection of workflows during the next launch.

### 4.4.2 Launching a Workflow from the Automation Engine Shuttle

1. If the Launch Panel is not visible in the Shuttle window, go to View > Launch Panel.
2. Select the desired **Workflow** with the drop-down menu. Shuttle will launch this **Workflow** when files arrive at the launch panel.

3. Submit one or more files in one of the following ways.
   - Drag and drop the desired file(s) into **Drop Files Here** area.
   - Go to **File > Launch...** and select the files.
   - Use the keyboard shortcut **Command-L** on Mac or **Ctrl-L** on Windows and select the file(s).

**Note:**
- The selected file(s) will be uploaded to the root folder of the job.
- If a file was previously launched on the chosen workflow, a dialog will prompt to give you the option to reuse the public parameter values from the previous launch. If you choose to reuse these public parameter values, they will be used as default parameter values. You can still edit these values if necessary.
- If a file with the same name is already present in the root folder of the job, a dialog is prompted warning you of overwriting the file. You can then choose to either **Replace** the existing file, or **Cancel** the launch to rename the file.

4. If your workflow has Public Parameters, you can fill them in the **New Task** window which will prompt. Learn more in *Using Public Parameters in Workflows*. It also possible to set the **Task Options** in this window.
a) You can set **Task Options** in the *New Task* window, click the **Task Options** button. In the resulting window, you can:

- set the **Priority** of the Task or Workflow as **Low**, **Normal**, **High** or **Immediate** by selecting from the drop-down.

- select **Hold** if you want to hold the launch of the Workflow. The Workflow will not be launched until you **Release** via the right-click menu in the Task Monitor or via the **Task** menu.

  Alternatively, hold the workflow until a set period of time after which it will be automatically released. To do this, select **Release at** and specify the period or date and time.

  **Note:** You can bypass the automatic release setting by selecting **Release** via the right-click menu in the Task Monitor or via the **Task** menu.

- Select **Launch a separate Task per input file** for launching a separate Task or Workflow for each input file.

- You can also set an **Annotation** for the Task or Workflow in this window.
5. Click the **Launch** button to launch the workflow. The task will immediately appear in the Task Monitor.
Note:

You can upload multiple files for multiple workflows. Click on the **Plus** button to add extra drop zone slots.

To remove these slots, proceed as follows:

- Click on the **Minus** button. This will place the user interface in Editing mode.
- Click on the desired **Delete** button on the top left corner of the drop zone.
- To leave the Editing mode, click on the **Minus** button, or press **Escape**.

---

User Intervention from the Shuttle

If you have setup a **Wait for Action** step in the workflow, the process halts for user intervention (for a **To Do** action). **User intervention needed** link will appear in the Task monitor when the workflow is halted.

1. Click on the **User intervention needed** link.
   The **To Do** dialog will prompt.

2. You can select **I am currently handling this to do item** to mark that you are handling this **To Do**.
3. You can choose to **Forward**, **Release** or **Delete** the **To Do**.
• You can let the workflow continue by clicking **Release**. Select the output state that you require in the release. The **To Do** window will close and the Workflow will continue processing.

• You can forward the **To Do** to another user. Click **Forward** and the workflow will not continue until the other user handles the **To Do**.

• You can also delete the **To Do** by clicking on **Delete**. This will end the processing of the workflow.

### 4.4.3 Launching Files from ArtPro

1. To launch your current file to Shuttle, go to **File > Launch Workflow...**
   This opens the **Launch Workflow** window.

2. Choose what file type you want to launch your file as.
If your workflow is... | you can launch the file as... | with...
---|---|---
an Automation Engine workflow accepting Normalized PDF files as input | Normalized PDF | either Normalized PDF or Normalized PDF (embedded)
an Automation Engine workflow accepting PDF files as input | PDF | any of the available PDF flavors
an Automation Engine workflow accepting ArtPro files as input | ArtPro | with the included images (TIFF, EPS...) or without (only the ArtPro and the ArtPro CT file)

3. If you want to add your file to an Automation Engine job, select it in the Job list or fill in the Job ID and/or Job Part ID.

**Note:** Use the Search... button to see a list of your server's jobs, with job information and a filter.

4. If you want to add your file to an Automation Engine product, select it in the Product list or fill in the Job ID and/or Job Part ID.
4. Select the workflow you want to launch your file to.
6. If your workflow has public parameters, you can fill them in in the same window.
7. Click the Launch button.

4.4.4 Launching Files from PackEdge or Plato

Attention: You must save your file on an Automation Engine container before you can launch it into a workflow from PackEdge or Plato.

1. Go to File > Launch Workflow...
   This opens the Launch Workflow window.

2. Select the workflow you want to launch on your file in the workflow list.
3. If your workflow has public parameters, you can fill them in in the same window.
   Note: For more information on public parameters, see Using Public Parameters on page 52.
4. Click Launch to launch the workflow on your file.
Tip:
To access Shuttle easily in the future (without using the menus):

1. Go to **Window > Toolbars > Shuttle** to open the Shuttle palette.
2. Drag it into your application’s toolbar.
3. Click to open the **Launch Workflow** window, or to open the **Shuttle** window.

### 4.4.5 Launching Files from FastImpose

When working with FastImpose Server, you must save your file on an Automation Engine container before you can launch it.

1. Go to **File > Launch Workflow**...
   
   This opens the **Launch Workflow** window.

   ![Launch Workflow window](image)

2. Choose what file type you want to launch your file as.
   
   - When working with FastImpose Server, you can only launch your file as an IMP file.
   - When working with FastImpose Standalone, you can launch your file either as a JDF or a PDF file.
Click the Settings... button to set JDF or PDF Export Preferences (see the FastImpose manual for more information).

3. Select the workflow you want to launch on your file in the workflow list.
4. If your workflow has public parameters, you can fill them in in the same window.
5. Click Launch to launch the workflow on your file.

4.4.6 Launching Files from Neo

1. Go to File > Launch Workflow...

   This opens the Launch Workflow window.

2. Select the workflow you want to launch on your file in the workflow list.
3. If your workflow has public parameters, you can fill them in the same window.

   For more information on public parameters, see:
   • Using Public Parameters on page 52.

   Note: If you want to go back to the default parameters values after changing them, use the Reset To Defaults button.

4. Click Launch to launch the workflow on your file.

4.4.7 Launching Files from the Shuttle Plug-in (Adobe Illustrator)

To launch a file into a workflow through the Shuttle plug-in, it needs to be the current file in Adobe Illustrator (open and at the front).

1. Go to File > Launch Workflow... or use Option + Command + Z.
This opens the **Launch** window.

2. **When launching to Automation Engine,** choose **Normalized PDF** in **Launch As.** This copies the Normalized PDF version of your file onto the **DeskPack Container.**

   **Note:** This uses the PDF Export plug-in to convert your Illustrator file to Normalized PDF. To refine the conversion, click **Settings...** and edit the **PDF Export Preferences.**

3. **If you want to link your file to an existing Automation Engine job,** fill in the **Job ID** and/or **Job Sub ID.**

   **Note:**
   
   - You must enter a **Job ID** / **Job Sub ID** that already exists on your Automation Engine server. The Shuttle plug-in cannot create jobs.
   
   - The Normalized PDF that you launch with a **Job ID** / **Job Sub ID** will be **linked** to that job, so that tasks and workflows processing that file can use the job parameters.
   
   - If you are launching a file that was already in an Automation Engine job, the **Job ID** and/or **Job Sub ID** will be filled automatically.

4. **Select the workflow you want to launch your file to** in **Launch To Workflow.**

5. **If your workflow has public parameters,** you can fill them in, in the same window.

6. **Click Launch** to launch your file.
5. Launching Tasks on Files

5.1 Creating a Task Ticket

5.1.1 Creating a Custom Ticket from the Tickets View

To create a ticket with your own parameters, that you will be able to reuse:

1. Open the Default ticket of your chosen task.

   Note: To create a custom workflow ticket, see Workflows.

2. Fill in your parameters.

3. Go to File > Save As... or use Ctrl + Shift + S (Windows) / Shift + Command + S (Mac).

4. In the Save As pop-up:
   a) Enter the name to give your custom ticket
   b) Add the ticket to your Favorites if you like
   c) Make the ticket Public if you want to be able to use it from Shuttle (send files to that task using your ticket's parameters)

   Note: The Scope is always Global when creating a custom ticket from the Tickets view.

5.1.2 Creating a Custom Ticket when Working with Files

You can create a custom ticket when launching a task on a file too:

1. Right-click your file, select New Task then More Tickets...

2. In the Select Ticket dialog that opens, select the Default ticket for the task you want to use.

3. Fill in the settings you want to use in the ticket.

4. Go to File > Save As... or use Ctrl + Shift + S (Windows) / Shift + Command + S (Mac).

5. In the Save As pop-up:
   a) Enter the name to give your custom ticket
   b) Add the ticket to your favorites if you like
   c) Make the ticket public if you want to be able to use it from Shuttle (send files to that task using your ticket's parameters)
5.1.3 Using Public Parameters

Public Parameters are Ticket parameters that users can define when launching files from these client applications connected with the Automation Engine server:

- Automation Engine Shuttle
- Automation Engine Pilot
- ArtPro, Neo
- PackEdge, Plato, FastImpose
- DeskPack (Adobe Illustrator)

**Note:** Only Public Tickets can be launched from these client applications.

For each public parameter, you can either:

- enter a list of predefined values that the user must choose from,
- let the user enter a value himself.

**Making a Parameter Public**

**Note:** You need to define which parameters are public before files are submitted to your workflow.

**Note:** Not all parameters of all tickets can be made public.

In the ticket containing the parameter to make public:

1. Right-click the parameter and select **Make Parameter Public**.
2. Right-click it again and select **Modify Public Parameter**...
3. In the **Modify Public Parameter** dialog that opens:
   a) If necessary, change the way the parameter will be called in the client application in **Prompt as**.
   b) Choose either:
      - **Allow the user to set the value** if you want client application users to be able to freely enter a value for that parameter.
• Let the user select a predefined value if you want client application users to choose from a list of values that you define.

If that parameter already offers a list of values to choose from in the ticket, they will be displayed here. You can Add or Remove values.

Note: client application users will see (and choose from) the Predefined Settings. They will not see the associated Values.

c) If you have chosen Let the user select a predefined value: in Default Predefined Setting, choose the setting that will be selected by default. If the user doesn’t select another setting, this one will be used for processing.

4. Save your ticket to also save all settings related to public parameters.

This is how your public parameter will look like when it prompts to the users of the client application:

<table>
<thead>
<tr>
<th>If you chose <strong>Allow the user to set the value</strong></th>
<th>If you chose <strong>Let the user select a predefined value</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Custom Resolution 150ppi" /></td>
<td><img src="image" alt="Custom Resolution" /> High Anti-aliasing Low</td>
</tr>
</tbody>
</table>
Managing Public Parameters in Your Ticket

Once you have made parameters public in your ticket, you can have an overview of your public parameters and edit them at the ticket level.

1. In your ticket, go to **Advanced > Manage Public Parameters**...

   The **Manage Public Parameters** dialog that opens contains all of your ticket’s public parameters.

   The left pane shows all parameters that can be made public for that ticket (the ones you have made public are greyed out).

   The right pane shows the parameters you have made public, with their settings (predefined values, etc.).

2. You can:

   • drag parameters from left to right to make them public;
   • click a public parameter’s cross if you don’t want it to be public anymore;
   • rearrange the order of your public parameters (drag them up or down);
   • change public parameters’ settings (**Prompt as**, **Predefined Settings**, etc.);
   • group public parameters under a custom header (click **Add Group**, click to edit the header, and drag parameters from the left);
   • use presets to simplify users’ choices (see *Making Presets to Simplify the Users’ Choices* on page 54).

Making Presets to Simplify the Users’ Choices

**Presets** are custom combinations of parameters. They simplify the choice users have to make. They limit the amount of decisions that users have to make.

**Example**

For example, you want users to use different trapping settings when printing offset versus dry offset. You can define those trapping settings in a preset, so that users will only have to choose between ‘offset’ and ‘dry offset’.

We start from a **Manage Public Parameters** dialog where the trapping step has 3 public parameters:

1. Click on ✗ to remove the (default) **Group** named "Trap with PowerTrapper"

2. Press the **Add Group** button.
A new "Untitled Group" is created. Click on 📡 to change the name.

3. Press the Add Preset button.

A new "Preset" is created. Click on 📡 to change the name.
By default, two example values will appear. the preset was renamed to 'Choosing Process to Decide Traps'.

4. Define what the users will see:
   a) in Prompt as, enter the text that users will see in the client application (replacing 'Type the name of the preset here (e.g. “Paper Size”)').
   b) enter the values that the users will choose from (replacing 'Type a value here (e.g. A4)'). We here added 'Offset' and 'Dry Offset'.

   Click Add if you want to add extra values (not the case in our example).

5. Drag the parameters from the dialog's middle pane onto one preset item. This will make them automatically appear under each preset item (here both under Offset and Dry Offset).
6. Define the parameters values for each preset item.
   See the above screen shot for a good example.
7. Click OK to confirm and close the dialog.
8. Save your ticket.
Result: this is how the resulting dialog will look like to the users of the client applications:

Making Your Ticket Public

Important: Only Public tickets or workflows can be launched from the client applications mentioned here.

Note: Default tickets cannot be made Public.

To make a ticket Public, you can either:

• Select the Public option when creating the ticket.

• Select your ticket in the Ticket view, click ![Info icon] and select Public.

• Right-click your ticket in the Tickets view and select Make Public.
Note: Public tickets have a mark in the Public column.

<table>
<thead>
<tr>
<th>Task Type</th>
<th>Ticket Name</th>
<th>Public</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zip</td>
<td>Default</td>
<td></td>
<td></td>
</tr>
<tr>
<td>WorkFlow</td>
<td>WC_Approval</td>
<td></td>
<td></td>
</tr>
<tr>
<td>WorkFlow</td>
<td>WaitForPrintJob</td>
<td></td>
<td></td>
</tr>
<tr>
<td>WorkFlow</td>
<td>TrapFile</td>
<td></td>
<td></td>
</tr>
<tr>
<td>WorkFlow</td>
<td>Intro_Account</td>
<td></td>
<td></td>
</tr>
<tr>
<td>WorkFlow</td>
<td>Simple Trap</td>
<td></td>
<td></td>
</tr>
<tr>
<td>WorkFlow</td>
<td>Send2Daily</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5.1.4 SmartNames

SmartNames are documented as a separate chapter in the "Complete Manual". Find it here: SmartNames.

5.2 Launching a Task on a File

There are several ways to launch a task on a file (from the Pilot, from Shuttle, via Access Points or via JDF/JMF). Here is how to launch a task from the Pilot’s Files View.

1. In the Pilot, select the Files view from the Views bar (or use Go > Files).
2. In the Containers mode, browse to your chosen file.
3. Right-click it, and select either:
   - New Task to fill in the ticket’s settings before launching the task.
   - Launch with to launch the task without changing the ticket’s settings.

Note:

If you don’t have the Tickets: Show All Tickets and their Parameters (Public and other) access right (see Access Rights in the Reference Guide), you will only see Launch with.

In this case, you can only select public tickets, and only fill in public parameters in the ticket.

4. Select the ticket to use.
   - If you have launched tasks previously, the most recent task tickets you used are listed.
   - If you didn’t, or if you need a different ticket, select More Tickets...
In the **Select Ticket** dialog that opens, select the task ticket you want to use and click **OK**.

**Note:** This dialog contains all the tickets suitable for the file type you selected. You can choose either a **Default** ticket, or a custom ticket (saved under a different name) if you have already created one.

5. If you chose **New Task**, the task ticket opens. Fill in the settings you want to use in the ticket and click the **Launch** button.
• If you chose **Launch with** and you have the **Tickets: Show All Tickets and their Parameters (Public and other)** access right, the task is launched on the file as soon as you selected the ticket. You don’t need to fill in any settings.

• If you chose **Launch with** and you don’t have the **Tickets: Show All Tickets and their Parameters (Public and other)** access right, the task is launched on the file as soon as you selected the ticket if there are no public parameters.

If the ticket contains public parameters, it will open for you to fill them in (you will only see the public parameters). Click **Launch** when you are done.

**Note:** For a description of all of the ticket's settings for each task, see *The Tasks and Workflow Controls* in the Reference Guide.
You can monitor the task’s progress in the Files View’s Task pane or in the Tasks View. See Check the Status of the Task.

5.3 Checking the Status of the Task

After launching a task on one or several file(s), you can check its processing status in the Pilot’s Tasks pane. You can see the Tasks pane in the Files, Product or Tasks views.

You can see the progress (in percentage) and the processing state. The state can be:

- ![starting](image): starting
- ![success](image): success
- ![warning](image): warning
- ![failure](image): failure
- ![processing cancelled](image): processing cancelled

You can also double-click the task entry in the Tasks pane to open your task ticket and check its parameters.

**Note:** Depending on your access rights, you may only see the public parameters.

5.4 Relaunching the Task

- To relaunch the task without changing the settings:
  a) Select the task to relaunch in the Tasks pane.
  b) Go to **Tasks > Relaunch**.
- To change the settings and relaunch the task:
  a) Select the task to relaunch in the Tasks pane.
  b) Go to **Tasks > Open**.
  c) Change the task settings as necessary.
  d) Click the **Launch** button.
6. Launching Workflows on Files

Workflows are documented in a separate chapter *Workflows.*
7. Viewing Files in the Automation Engine Viewer

The Automation Engine Viewer is now documented in the chapter *Quality Control tools*. Find a direct link [here](#).
8. Integrating with Other Esko Applications

Note: Integrating Automation Engine with WebCenter is documented in Integrating with WebCenter, a dedicated chapter in the Complete documentation of Automation Engine.

8.1 Review and Approval of Page Impositions using WebCenter

This chapter is specific on publishing page impositions to WebCenter. For all other generic documentation on integrating Automation Engine and WebCenter, we refer to Integrating with WebCenter.

8.1.1 WebCenter Setup

In WebCenter, you need to set up a Project Template with Approvers.

You will use this template in Automation Engine when sending impositions: it will allow you to create new WebCenter Projects (already containing your Approvers) as needed, directly from Automation Engine.

Note: Alternatively, you can set up a WebCenter Project with Approvers in WebCenter, and send your impositions to it from Automation Engine. But then you will only be able to create new Projects from WebCenter and not from Automation Engine.

1. Create a new Project.
2. Add Members to the project.
3. Choose Approvers from within the Project’s members.
4. Save the Project as a Template.

Creating a New Project

1. Log in to WebCenter as a user who is a Project Manager.
2. Click Projects.
   
   The Favorite Projects page is shown.
3. Click Create New Project at the top right of the page.
4. Choose Start from a Blank Project and click Continue.
5. Enter the name for the Project in the Project Name field.
   
   • To make another user or user group the Project Manager for this project, select his or her name, or the group name, from the Project Manager list.
   • If you want, enter a description in the Description field.
   • To make the Project active, set the Status as Active.
• To specify an optional due date, click the calendar control at the end of the Due On field and select the desired due date. To set the due time, click the drop-down list box to the right of the calendar control.

Note: This is not the Approval Due Date. You will set the Approval Due Date when setting the Approval Cycle.

• To use a custom thumbnail, click Change and enter the complete path and file name in the associated field or Browse for it. To use the default thumbnail, leave that choice selected.

6. Click Create Project.

   The Project is created.

Adding Members to a Project

1. Once the project is created, click Members > Add Members.
This shows a list of the current WebCenter members.

2. Select the users or groups to add as members and click **Continue**.

3. Set the members’ permissions as desired. For Approval tasks, members need at least **View** permissions (selected by default).

   **Note:** The permissions you set here apply to all members you have just added.

4. Click **Finish**.
5. Once the members are added, click **Go back to the project**.

Adding Approvers to the Project

Approvers can be either regular users or they can be user groups. When you add a group as an approver, you must indicate whether:

- all the members of the group (select the group entry labeled as *whole group*) must approve the document before it gets the approved status, or
- whether the approval of a single group member (select the group entry labeled as *one of group*) will set the document to approved status.

**Note:** You can only change (add or remove) Approvers when the **Approval Cycle** is stopped.

1. In the Project Page, click **Approval**.

2. Click **Setup Approval**.

3. Open the **Add approver** list, and select the individual users or the groups you want to add.

   **Tip:** Use Ctrl+Click to select multiple members.

   **Note:** The Project Manager is not automatically made an Approval User and must be explicitly added to the list of Approvers.
Saving a Project as a Template

**Note:** To save a Project as a Template, you need have Administrator permissions.

1. If the user you are logged in with is not an Administrator:
   a) Log out.
   b) Log back in with an Administrator user.
   c) Go back to your Project page.
2. In the More actions menu on the left, click **Save as Template**.
3. Enter the **Template Name** (different from your **Project Name**) and a **Description**.
To use a custom thumbnail, click **Specify New Thumbnail** and enter the complete path and filename in the associated field or **Browse** for it. To use the default thumbnail, leave that choice selected.

4. Click **Finish**.
   
The Template is created.

**Configure Workflow Approval and Tunnel Clients**

When WebCenter and Automation Engine are not on the same LAN, this **workflow approval and tunnel client** will establish a bi-directional communication.

**Note:** The Automation Engine Pilot needs to have the **workflow approval client** credentials to send messages to WebCenter.

This is configured through **Admin > Configuration > Workflow Approval Clients** in WebCenter, and, in the case of Automation Engine, in **Tools > Configuration > Web Sites** in the Automation Engine Pilot.

**Attention:**

Configure the WebCenter account first so that it can be tested from within the workflow approval server.

WebCenter and the workflow approval server must use the same user name and password!

This is completely separate from a normal WebCenter user. Workflow approval clients may not log in to WebCenter.

Two manual configuration steps must also be performed outside of WebCenter to ensure proper communication between the workflow approval client and WebCenter systems that are not on the same LAN.
Create a Workflow Approval and Tunnel Client

1. Click **Admin > Configuration > Workflow Approval and Tunnel Clients**.
2. Click **New Workflow Approval and Tunnel Client**.
3. Enter the **User Name** and **Password** for the workflow approval client user.
4. Click **Create**.

**Note:** If you have several Automation Engine, Nexus, or Odystar sites communicating with WebCenter, you need to create a separate Workflow Approval Client for each site.

### 8.1.2 WebCenter Sites

To configure links from Automation Engine to WebCenter sites, go to the item **WebCenter sites** in the **Configure** tool (Pilot > Tools > Configure).

**Website:**

Specify the web address of the WebCenter site. After you entered the WebCenter address, click **Open...** to check if the WebCenter site is up and running. If you are redirected to the login page, it means that the address is correct and that the site is up and running.

**Tip:** Be aware that this address is also the address that will be included in the notification e-mails when adding links to documents (approval cycle start e-mail). You should therefore make sure that the address can be accessed from the outside. Make sure to not use an internal address, but one that you want your users to use when they use WebCenter.

**WebCenter and Automation Engine are in the same LAN**
Check this toggle if this is true. This will most likely be the case. Un-check this toggle if WebCenter and Automation Engine are remote.

**Note:** How can you verify that WebCenter and Automation Engine are in the same LAN? WebCenter and Automation Engine are in the same LAN when you can connect from WebCenter’s application server, this is the system where JBOSS is installed, to an Automation Engine Job Folder with the credentials of the **System Account** (by default the user BGSYSTEM or the one you changed it to using the System Account page in the Server Web page).

**WebCenter’s Approval Client:**

If WebCenter and Automation Engine are not in the same LAN, you first need to create an Automation Engine **Approval Client** in WebCenter. This is necessary to give Automation Engine permissions to listen to the approval messages that are stored in WebCenter.

**Tip:** If the Approval Client does not exist yet, follow these steps:

1. In WebCenter, log in as Administrator.
2. Go to the Admin section. In Configurations, select Workflow and Tunnel Approval Clients.
3. Click the link “New Workflow and Tunnel Approval Client”.
4. Enter a **User name** and a **Password** for the Automation Engine client. Mind that this is also the user name and password that have to be entered when configuring the WebCenter site in Automation Engine.

Fill out the client **Name** and **Password** and click the **Check Connection** button. This will check if the user can log on successfully.

The **Info** button displays the following information: "In case Automation Engine and WebCenter are not in the same local area network (LAN), the retrieval of the approval results is secured by a name and password. The name and password specified in Automation Engine must match the name and password specified in WebCenter by the WebCenter administrator. When clicking the ‘Check’ button, the WebCenter version will be checked and the name and password will be validated by WebCenter."

**Check Connection**

When you click this button, you should, after a few seconds, get a window saying “Check OK”. The software version of that WebCenter will also be mentioned.

**Note:** The button will check the validity of the user name or password to connect to that WebCenter but not of your WebCenter’s Approval Client.

**Note:** When you connect to a secured WebCenter site (for example one that uses HTTPS://), then you have to export its security certificate and import it on the Automation Engine server. If this is not done, publishing from Automation Engine to WebCenter will result in an error. Read more on how to do this in the chapter **Install SSL Certificates on the Workflow Production Server** of the WebCenter documentation.
8.1.3 Sending an Imposition from Automation Engine to WebCenter

Preparing the Imposition

1. In the Files view, browse to the FastImpose imposition file (*.imp) you want to upload.

   **Note:** The imposition file must be part of a job.

2. Right-click it and select Add to Imposition Gallery from the context menu.

   When you switch to the Pages view, you can see your file in the Imposition Gallery.

3. If the imposition doesn't show the pages preview (as in the previous example), add them as follows:
   a) Click on the first page's file name in the Page Gallery. This shows the page's preview in the Details area at right.
   b) Drag this preview onto the first page of the imposition in the Page list area.
   c) Repeat this for the other pages of your imposition.
Sending the Imposition to WebCenter

If your imposition contains several books, you must send the books one by one to WebCenter. Each book will be shown as a Page List in WebCenter.

1. In the **Imposition Gallery**, right-click the imposition (or the book) and select **New Task > Prepare Imposition for WebCenter Workflow**.

   If the **Prepare Imposition for WebCenter Workflow** task does not appear in the context menu, choose **More Tickets** and select the task in the **Select Ticket** dialog.

2. Modify the settings of the **Prepare Imposition for WebCenter** step (the first step in the workflow) if needed.

3. In the **Send Imposition to WebCenter** step, modify the settings of the **Destination** tab (you can use SmartNames where indicated by the SmartNames button):
   a) Select your WebCenter **Site** from the list.
   b) Enter the name to give to your **Project**. Automation Engine will create this project in WebCenter, from the **Project Template** you specify below.

   **Note:** You can also send your imposition to a **Project** already existing in WebCenter. In that case, you don’t need to enter a **Project Template**. Note that this Project must have Approvers defined in WebCenter.

   c) If you want to send your imposition to a subfolder in the project, enter that **Folder**’s name. If this folder doesn’t exist in the template (or project), Automation Engine will create it.

   d) Enter the name to give to your imposition **Document**. This is the name that will be shown in WebCenter. For example you can use `[ImpositionName]_[BookName]_[LayerName]`.

   e) Enter the **Project Template** to use to create your WebCenter project.

   **Important:** This **Project Template** must be defined in WebCenter. See **WebCenter Setup** on page 64.

   f) Enter the **User Name** and **Password** used to connect to your WebCenter site. You can use an **Encrypted** password or **SmartNames**.
4. Modify the settings of the Approval tab:
   a) Enable **Start the Approval Cycle**.
   b) Select a **Due date** and time.

5. Click the Launch button in the top left corner to upload the imposition to WebCenter.

   **Note:**
   If you don’t start the Approval Cycle from Automation Engine, you will still be able to start it from WebCenter, and view the approval results in Automation Engine.
   For more information, see the WebCenter manual.

### 8.1.4 Approving the Imposition in WebCenter

In WebCenter 7.1, you can:

- Approve / reject documents sent from **Odystar, Nexus** or **Automation Engine** as regular documents (see **Approving a Document** on page 75).

- Approve / reject documents **FastImpose impositions added to the Pages View in Automation Engine** as regular documents or **Page Lists** (see **About Page Lists** on page 76 and **Approving a Page List** on page 76).
When approving a Page List, you can:

- Approve / reject not only the whole multipage imposition but each individual page.
- Update and have version control not only on the whole multipage imposition but on each individual page.

**Note:** Only FastImpose impositions that have been added to the Pages View in Automation Engine are recognized as Page Lists in WebCenter. Multipage files uploaded from within WebCenter, or from Odystar, Nexus, or even other Automation Engine documents will never be treated as Page Lists. Instead, they are considered regular multipage PDF documents.

When approving a Document, you can:

- If you are an Approval User: Approve the document, Reject it, or leave it Pending to approve / reject it in the future.
- If you are a Project Manager: Approve or Reject the document, leave it Pending, or Force Approve / Force Reject it if you need to overrule the approval status granted by the approval users.

**Note:**
For more information about Forced Approval or Rejection, see the WebCenter manual.

### Approving a Document

Documents waiting for your approval are shown on My To Do List under My Work. If you are an Approval User, do the following to Approve or Reject a document:

**Note:**
You can also approve or reject documents in the Viewer.

1. Click Approve/Reject at the end of the Approval field in the document header.

![Document - dellBook 1](image)

- **Document:** dellBook 1
- **Pages:** 4
- **Version:** 1
- **Binding:** Left Edge
- **Project:** [11590]
- **Approval:** Cycle Started - Status Pending

2. Choose the desired Approval Status from the drop-down list: Approved indicates approval; Pending indicates future Approval or Rejection, and Rejected indicates disapproval.

3. Once you choose Approved or Rejected, you may not change the status later; a view-only version of the page will be shown showing the choice you picked. Only a Pending status allows future changes.

   If you want, you can add a comment in the Comment field. Submitted approvals and comments are shown on the Action History page.

4. Click Finish to change the status of the document.

   To cancel the changes, navigate to another page without clicking Finish.
8.1.5 About Page Lists

What is a Page List document?

Page Lists are a special type of multipage PDF documents in WebCenter that represent imposed books or magazines. As such they are an important tool for commercial printers.

Page Lists are uploaded from an Automation Engine production server using the Pages View in the Automation Engine Pilot.

Note: Only FastImpose impositions that have been added to the Pages View in Automation Engine are recognized as Page Lists in WebCenter. Multipage files uploaded from within WebCenter, or from Odystar, Nexus, or even other Automation Engine documents will never be treated as Page Lists. Instead, they are considered regular multipage PDF documents.

Page List documents have two major advantages over other multipage PDF files:

- You can upload either the complete document, or specific pages only (for example, pages 6-12);
- individual pages can be approved or rejected in WebCenter (for example, you can approve pages 3, 5 and 7-16 of a 16-page Page List).

Note: A multipage PDF file can only be approved or rejected as a whole.

Working with Page Lists

Page List documents are displayed as a single document in document lists. Click the Page List name to view its pages and details in the dedicated Page List views.

Note: Page Lists cannot be downloaded.

Approving a Page List

In order to approve your imposition as a Page List in WebCenter, you need to first login to WebCenter as an approver, then navigate to the document (Page List) to approve, in the project created from Automation Engine.

You can also access this Page List from the link in the approval notification email, if you received one.

Make sure you have the correct permissions to approve documents in WebCenter. For more information, please see your WebCenter manual.

You can choose from a number of different methods to approve the pages in a Page List:

- Use the WebCenter Viewer:
  a) In the Project, click on the Page List’s thumbnail image. The Viewer opens, displaying the Page List.
  b) In the Approval area in the sidebar on the right of the Viewer window, select the appropriate approval state (Approved, Rejected, Pending) from the list.
    The Approval dialog opens in which you can add approval comments.
c) Enter your comments, provide your password if required and click **Commit**.

**Note:** You can approve / reject one page at a time, or all of the document’s pages (using **Apply to all pages**).

- **Use the Page Gallery view:**
  a) In the Project, click on the Page List’s name.

    The **Document Details** page appears.
  b) Select **Page Gallery** from the menu.
  c) Select the pages you want to approve and then click **Approve/Reject**. You can also use **Approve/Reject all Pages**.
  
    
    ```
    ![Page Gallery View]
    ```

d) Enter your comments, provide your password if required and click **Commit**.

- **Use the Page List view:**
  a) In the Project, click on the Page List’s name.

    The **Document Details** page appears.
  b) Select **Page List** from the menu.
  c) Select the pages you want to approve and then select **Approve/Reject** from the gearbox menu. You can also use **Approve/Reject all Pages**.
d) Enter your comments, provide your password if required and click Commit.

- Use the Approve/Reject link on the Document properties page to approve all the pages at once.

8.1.6 Sending a RunList / PageList to WebCenter

You can send a RunList from Automation Engine to WebCenter without having to create an Imposition. The resulting PageList will have pages in the right order. These pages are sent to Automation Engine after approval.

In PageLists, information such as Sheet info is not available.

Use this workflow if you want to send pages to WebCenter in the right order to get them approved.

Note: Unlike sending impositions, you still need to position them afterwards.

The uploaded PageList in WebCenter takes the Sheet Name NoImposition. The Sheet Name and the Sheet Side will always be 0.

Preparing a RunList

Context for the current task

Run the Create RunList task on a multipage PDF file. Remember to enter a name for your RunList. If the Name field is left blank, the task uses the file name.

Read more about the task settine in Create RunList from PDF.

A RunList is created and shown in the Imposition Gallery. Switch to the Pages view to see the RunList and its pages.
8.1.7 Checking the Approval Results in Automation Engine

To view the status of documents in a WebCenter Approval Cycle in Automation Engine, you can use either:

- the Pages View,
- the Proofs View,
- the WebCenter View.

In the Pages and Proofs Views

- Go to the Pages or Proofs View to view the approval status of each page of the imposition.
- In the Pages View:
• In the **Proofs View**:

**Note:**

When you try to expose a sheet that contains a rejected page, you will get an error in the *Expose* task and an error status in the *Plates* View.

If you really need to expose the sheet anyway, you can overrule the WebCenter approval status from Automation Engine (see *Overruling the WebCenter Approval* on page 82).

**In the WebCenter View**

In the **WebCenter View**, you can view the approval status of the whole imposition.

**Important:** You need to first set up the WebCenter View before you can view all the approved / rejected documents in the WebCenter project you created.

1. Right click the **WebCenter** View’s background and choose **Configure**.
2. Enter the **URL** of your WebCenter site.
3. Enter the **User** name and **Password** used to connect to your WebCenter site.
4. In **Project Name**, enter the name of the WebCenter project you sent your imposition to. You can use SmartNames.
Important: Make sure this matches the Project Name of the project you created (or used) when sending your imposition from Automation Engine to WebCenter. See Sending the Imposition to WebCenter on page 73.

5. To check that the information you entered is correct and that the WebCenter server is running, click the Retry Connection button at the bottom of the view.

You can also use the link at the top of the view to open the web page of the WebCenter project.

6. Once you have checked that your configuration is correct, use the Save to Configuration button to save it.

![Configuration interface]

Once it is saved, you will be able to return to this configuration using the Load from Configuration button after any unwanted change.

7. Click the Show Documents button to view the documents in your WebCenter project.

Note: If at least one page of the imposition is rejected, the status of the whole imposition is Rejected.

Possible Document Statuses

<table>
<thead>
<tr>
<th>This icon...</th>
<th>means that...</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Green checkmark]</td>
<td>the page and the original imposition layout have been approved by all approvers.</td>
</tr>
<tr>
<td>![Red x]</td>
<td>The imposition layout can be approved even if some of its pages are rejected.</td>
</tr>
</tbody>
</table>
This icon...  |  means that...
--- | ---
✓ | the page has been approved by all approvers, but it may have changed the imposition layout, which needs to be checked (for example for a new page replacing a rejected one).
✗ | the page or the whole imposition has been rejected by at least one approver.
✚ | the page or the whole imposition has yet to be approved or rejected by at least one approver.

When you hover on the top of a page in the **Pages** or **Proofs** View, you can see:
- the approval status,
- any comment entered,
- the date and time of the approval,
- the WebCenter user who approved/rejected the page.

### 8.1.8 Overruling the WebCenter Approval

After your imposition has been approved or rejected in WebCenter, you can still overrule the approval status of some of the pages in Automation Engine, if necessary.

1. In **Automation Engine Pilot**, go to either the **Pages** or the **Proofs** View and locate your imposition document.
2. You can either:
   - Select a page of your document and use the and buttons in the View's toolbar to approve/reject the document without entering a comment.
   - Right-click on a page of your document and choose Approve/Reject... to open the Approve/Reject dialog where you can enter a comment.
3. In the Approve/Reject dialog, select **Manual** as Approval Type.
4. Choose to either:
   - Approve,
   - Approve with warning,
   - Reject the document.
5. Enter a Comment if you wish and click OK.

**Note:** You can hover on the top of a page to view approval information, whether it has been approved/rejected automatically in WebCenter, or manually in Automation Engine.

### 8.2 Integrating with Nexus

**Why run Nexus workflows from the Automation Engine Pilot?**

Running Nexus workflows from an Automation Engine Job context combines the benefits of both applications.
Because Automation Engine also offers to run ArtPro Action lists (without the need for a separate Nexus application), the main reason to integrate with Nexus is to use the Nexus RIP.

How does it work?
The **Send to Nexus** task gives you access to the workflows that are available on a specific Nexus server.

Any public parameters that have been defined in that Nexus workflow (NeXML) will show up in the **Send to Nexus** ticket in Automation Engine. In addition, these public parameters are SmartName-enabled, so you can use Automation Engine Job parameters to drive the Nexus workflows.

On the Nexus side the **Copy to Automation Engine** activity allows you to set up workflows that send their output files back to Automation Engine.

**Note:** Automation Engine and Nexus communicate via the SOAP protocol to exchange files and notify each other of their progress.

**NeXML**
Setting up public parameters in Nexus requires knowledge of NeXML. Learn more in the [NeXML Manual](#).

### 8.2.1 Setup on the Nexus Side

To use the Send to Nexus task and workflow, following setup is required:

**Mounting Your Containers on the Nexus Server**
The Automation Engine containers containing the data that Nexus will process have to be mounted on the Nexus server.

- If the Nexus server runs on Windows, the container should be mapped to a drive letter.
- If the Nexus server runs on a Mac, the container should be mounted over the SMB protocol.

**Setting up the Nexus SOAP Server and Workflows**

1. On Nexus, in the Modules list, double-click the **NexusSoapServer** module.

2. In the **NexusSoapServer Module Defaults** dialog, enter a port number in the **Listening Port** and click **OK**.

   The Nexus SOAP server is now active.

   **Note:** The option **User Management**, which determines the workflows that a particular user can access, is ignored by Automation Engine. As a result, Automation Engine Pilot users automatically have access to all Nexus workflows.

3. Create valid Nexus workflows with the **Input Type**: **Hot Folder**.

4. Configure the Hot Folder queues for the workflows. Make sure the option **Show in Shuttle** is selected.

   Only Hot Folders that have **Show in Shuttle** enabled are published to the Nexus SOAP server and so become accessible to Automation Engine.
5. Create the workflows with the **Nexus Workflow Editor**.
6. Make sure you add the **Copy to Automation Engine** activity at the end of the workflow.

Your Nexus workflow is now available for use from an Automation Engine Pilot.

### 8.2.2 Setup on the Automation Engine Side

1. In the Pilot, go to **Tools > Configure** and select the **Nexus** topic.
2. Choose **File > New**.
3. Enter the name of the Nexus server in the **Host** field.
4. Enter the **Port** on which the Nexus server is accessible.
5. Click **Test Connection** to verify the settings you entered.

**Note:** You can also test whether the Nexus SoapServer is online by browsing to the following URL in your web browser: `http://NexusServerName:5182`.

### 8.2.3 Running a Nexus Workflow from the Pilot

To run a Nexus workflow from within Automation Engine, you need to use the **Send to Nexus** ticket.

In the Pilot, you can see the progress of the Nexus workflow in the Task Monitor, you can jump to the workflow in the Nexus Manager and more.

**Understanding the Send to Nexus Ticket**

The **Send to Nexus** ticket consists of two parts:

- The top section of the ticket dialog allows you to:
  - select a Nexus workflow from the **Workflow** list
  - indicate whether you want to launch a new, separate workflow in Nexus for every input file (**Separate Tasks**), or whether you want to send all the selected input files to one Nexus workflow (**One Single Task**).

- The bottom section of the ticket dialog is variable: it shows fields for the **public parameters** of the workflow you selected. These parameters can be different for every Nexus workflow (they are defined by the NeXML).
Note: You can also manage your Nexus workflow's public parameters (not one by one but as a group) in your task ticket. See Managing Public Parameters in Your Ticket on page 54.

Launching a Nexus Workflow from the Pilot

1. In the Pilot, select the file(s) you want to process with your Nexus workflow.
2. Open a Send to Nexus ticket.
3. Select the Workflow you want to run.
4. If you selected multiple files:
   - select One Single Task to send all input files to a single Nexus workflow.
   - select Separate Tasks to launch a separate Nexus workflow for every input file.
5. Define the required public parameters for the different activities in the workflow.

   Note: You can use SmartNames in all the public parameter fields.

6. Click Launch to send the files to the Nexus workflow.

The Send to Nexus task can be monitored as any other task type, showing the progress of the Nexus workflow. Note that progress is not displayed in real time.

The files that Nexus processed are returned to Automation Engine as the output files of the Send to Nexus task. This means you can continue the workflow even further: you can include Send to Nexus as a step into a larger workflow.

Switching Views between Automation Engine and Nexus

- On a Mac, in the Tasks view of a Pilot, right-click the Send to Nexus task and choose Go To Job in Nexus Manager to view the job in Nexus Manager.
• In Nexus Manager, double-click the Copy to Automation Engine activity to view the job in the Automation Engine Pilot (Mac or Windows).

Note: In order to jump from the Nexus Manager 9.0 to the Automation Engine Pilot, you must connect to Nexus Manager with a blank user name and the password aws nexus.

8.3 Integrating with Odystar

Attention: Since this integration became possible, most Odystar functionality has become available through many of Automation Engine’s own PDF processing tasks. This is why the integration between Odystar and Automation Engine has become rare.

How Does it Work?
The Send to Odystar task in Automation Engine enables access to the workflows on a specific Odystar server. You can use the Send to Odystar ticket as a single task or as part of a larger Automation Engine workflow.

Any public parameters that were defined in the selected Odystar workflow also show up in the Send to Odystar ticket in Automation Engine. In addition, these public parameters are SmartName-enabled, so you can use Job metadata to drive the Odystar workflows.

On the Odystar side the Copy File gateway allows you to set up workflows that send their resulting files back to Automation Engine.

Behind the scenes, Automation Engine and Odystar exchange files and notify each of other of their progress.

Example
• The Automation Engine workflow (top) sends the files to Odystar for additional processing before outputting them to a proofer.
• The Odystar workflow (bottom) applies PrePress changes to the files before copying them back to Automation Engine, where they go through the rest of the workflow (here a proofing step).
8.3.1 Setup on the Odystar Side

To use the Send to Odystar task and workflow, following setup is required:

Mounting Your Containers on the Odystar Server

- Mount the Automation Engine containers on your Odystar server using the SMB protocol.

    **Note:** Make sure your Odystar server has read and write permissions on those mounted volumes.

Setting up the Hub and Your Odystar Canvases

1. On your Odystar server, launch the **Hub** application. You can find it in Odystar’s **Server Software** folder.
2. Go to **Hub > Preferences** or use the shortcut **Cmd + , (comma)**.
3. In the **Shuttle** tab, enter the **IP Address** of the server running your Hub, and the port to use for communication between Automation Engine and the Hub (in **Shuttle Port**).

    ![Sharing & Permissions: You can read and write](image)

    **Server:**
    - **IP Address:** 10.31.132.171
    - **Shuttle Port:** 5182
    - **Bonjour Name:** Odystar Hub – Mac Intel 1

    **Note:** By default this is port 5182. If this port is already used by other processes, enter the next available port.

4. Create your Odystar workflow using the **Inspector**.
5. Double-click the **Receive** Process Folder of your Odystar workflow to open its parameters.
6. In the **Shuttle** tab, click **Enable Shuttle Queue**.
7. At the end of your workflow, make sure you add a **Copy File** gateway, with the **Copy Back To Automation Engine** mode selected:

Your Odystar workflow can now be launched from the Automation Engine Pilot.

### 8.3.2 Setup on the Automation Engine Side

1. In the Pilot, go to **Tools > Configure** and select the topic **Odystar**.
2. Choose **File > New**.
3. Enter the name or IP address of the Odystar server in the **Host** field.
4. Enter the **Port** on which the Odystar server is accessible.
5. Click **Test Connection** to verify the settings you entered.
8.3.3 Running an Odystar Workflow from the Pilot

To run an Odystar workflow from within the Automation Engine Pilot, you use the Send to Odystar task. You can use it as a single task or as part of a larger Automation Engine workflow.

You can also check the progress of the Odystar workflow in the Pilot’s Task Monitor.

Understanding the Send to Odystar Ticket

The Send to Odystar ticket consists of two parts:

- The top section of the ticket dialog allows you to:
  - select a particular Odystar workflow from the Workflow list;
  - indicate whether you want to launch a new, separate workflow in Odystar for every task input file (Separate Tasks), or whether you want to send all the input files to one Odystar workflow (One Single Task).

- The bottom section of the ticket dialog offers the public parameters of the selected workflow. These parameters can be different for every Odystar workflow (they are defined in the Inspector).

Note: You can also manage your Odystar workflow’s public parameters (not one by one but as a group) in your task ticket. See Managing Public Parameters in Your Ticket on page 54.

Launching an Odystar Workflow with the Send to Odystar Task

1. In the Pilot, select the file(s) you want to process with your Odystar workflow.
2. Launch the Send to Odystar task.
3. Select the Workflow you want to run.
4. If you selected multiple files:

---

Note: You can also test whether the Odystar Hub is online by browsing to the following URL in your web browser: http://OdystarServerNameorAddress:5182.
• select **One Single Task** to send all the files to a single workflow in Odystar.
• select **Separate Tasks** to launch a separate Odystar workflow for every selected file.

5. Provide the required **public parameters** for the different gateways in the workflow.

**Note:** You can use **SmartNames** in all the public parameter fields.

6. Click **Launch** to send the files to the Odystar workflow.

As with all tasks, also the **Send to Odystar** task appears in the Tasks view, and allows you to monitor the progress of the Odystar workflow. Note that progress is not displayed in real time.

**Note:** The files processed by Odystar are returned to Automation Engine as the output of the **Send to Odystar** task (or as the output of the **Send to Odystar** workflow step when including the **Send to Odystar** ticket in an Automation Engine workflow - see the workflow example).

### 8.4 Integration with Enfocus PitStop

If you already have a separate standalone installation of Enfocus PitStop server, you can integrate it with Automation Engine. You can then use the **Preflight via External Application** task to preflight PDF files.

**Attention:** Depending on your licenses, it is possible that your Automation Engine already has a version of this PitStop software built in. This then enables the **Preflight with PitStop** task which uses the PitStop technology built into Automation Engine. Learn more in the chapter on **PitStop Preflight**.

In case you do want to integrate with the standalone version of PitStop, follow these steps:

1. Go to **Tools > Configure > Preflight Tools** and set up the connection to PitStop, as described in **Preflight Tools**.
2. Prepare a ticket of the **Preflight via External Application** task and launch it on your (native) PDFs. Learn more in **Preflight via External Application**.

### 8.5 Integration with Third Party Applications using Hot Folders

The **Integrate via External Hot Folder** task allows you to integrate external prepress applications into your workflow tickets. The only requirement is that the external system works with hot folders.

1. In the Integrate via External Hot Folder ticket, you define the location of the hot folder used by the external application, as well as the Result subfolders in which the external application will output processed jobs (the **OK Folder**), failed jobs (**Error Folder**) or jobs that produced warnings (**Warnings Folder**).
2. When you process a job with this ticket, Automation Engine copies the files to the external hot folder.
3. The external application picks up the files in its hot folder and processes them. The processed files are saved in the subfolder that matches the processing result: OK, Warning or Error.
4. Automation Engine monitors the OK, Warning and Error folders for any files that have been processed.
5. If it detects a file in the OK folder, Automation Engine copies it to the Output folder defined in the Integrate via External Hot Folder ticket, and continues its workflow. Depending on your settings, Error or Warning files might also be copied into the Output folder, or they might be deleted.

Note: In the Error area of the ticket, you can define an amount of time after which the external processing should be considered as failed. To do this, enable the option **Error when no result after**... and define a time period (for example, you could enter one hour, a number of days, or even a specific date).
9. Integrating with Third Party Imposition Systems

Automation Engine enables working with non-Esko imposition systems. These tasks import or export industry standard file types to or from the Impositions in the **Pages** and **Plates** views.

You can check or change (approval) statuses, assign pages and select elements for further processing or output in the **Pages** and **Plates** views in Automation Engine.

9.1 Workflows: The bigger picture

You can find a schematic overview of how impositions can be created, processed and exported below. The tasks highlighted in green are new in Automation Engine 12.

You can import populated or unpopulated impositions from applications that produce JDF layout file as its output. Some of the applications that can write a JDF Layout file are Kodak Preps, Litho Technics Metrix, Ultimate ImpoStrip, Dynagram Inpo2, Dynagram Dynastrip, Plato and Pandora.

9.2 Importing and Creating Impositions

You can import the JDF Layout and use the **Create Imposition from JDF Layout** task to bring the **Imposition** to the **Pages** and **Plates** views in Automation Engine.

If you start with a PDF file or a JDF Runlist, you can use the **Create RunList** task to create a Runlist in Automation Engine. Subsequently, you can use the **Create Imposition from RunList** task to create Imposition from this RunList.

It is possible to separate the creation of a RunList and the creation of an Imposition from that Runlist in time. In some cases printers prefer to let the RunList be approved and corrected before they select the layout and create the Imposition.

You can achieve this by using two workflows.
1. Assemble the RunList and send it for approval.

2. Create the Imposition from the RunList and export it:

Read more about the new importing and creating tasks in the Reference Guide:

Create Imposition from JDF Layout
Create RunList from PDF
Create Imposition from RunList

General Remarks

Note: File Compatibility

- JDF layout files: tests have been done with Preps, Metrix, ImpoStrip, InpO2, DynaStrip, Plato and Pandora.
- PDF files: Normalized as well as non Normalized files can be used in the Imposition workflows. However, third party rips and workflows do not support external images.

Note: Thumbnails in the Pages and Plates views are only shown when the pages in the files contain thumbnails. If you have no thumbnails in your PDF files, you can speed up the system. You can also save some screen space by hiding the details pane and by switching to list mode.

9.3 Exporting Impositions

You can use Export Imposition to JDF Layout task to send an Imposition or part of an Imposition to another workflow system or to a Rip that is compatible with JDF layout.

- The output is JDF layout containing a JDF runlist.
- You can create a runlist for the Join Pages task using this output. This allows you to create a multipage PDF file to send to your customer for approval.
- It can be used to drive the FlexRip when followed by the Import JDF Layout task.

You can send an Imposition or part of an Imposition to a PDF Rip (for example Nexus Rip) using Export Imposition to PDF task. The output will be a PDF file containing the Imposition.
More info regarding these exporting tasks in:

Export Imposition to JDF Layout

Export Imposition to PDF File

9.4 Workflows with Selection and the Convert Selection tasks

Page, RunList, Layer, PageSlot, Imposition and Plate are abstract file types that do not correspond directly to a file. They can be used as entities in a workflow to route the elements you want to process through the workflow. For example, you can import an Imposition and preflight all the PDF files referred from that Imposition. The workflow below accepts a JDF Layout as its input, selects the PDF files referred in the JDF file and waits until all of them pass the preflight check before producing outputs as sheets to a PDF file. You need to convert the Selection to a PDF before Preflight.

Read more about Convert Selection task in Convert Selection the Reference Guide.
10. Example of Building and Using a Packaging Workflow

10.1 Build a Workflow

**Note:** Working with Workflows is documented in this dedicated chapter *Workflows*.

You can build workflows from zero or by using custom tickets and you create nested workflows.

You can use *SmartNames* to use predefined values. You can also choose to have the prepress manager build workflows that daily users will use, or let the daily users build workflows on the fly while processing files. See *Workflows*.

The following steps will help you build this example workflow:

10.1.1 Preflight your file

**Preflight via External Application**

The **Preflight via External Application** step allows you to preflight a PDF file by integrating external (non- Automation Engine) preflight software into Automation Engine.

**Attention:** To define the preflight settings for Automation Engine go to **Tools > Configure** and select *Preflight Tools*.

1. From **Start** connect to the **Preflight via External Application** workflow step.
2. Double-click on the workflow step to edit its parameters. For more information go to Preflight via External Application.

When Preflighting in a workflow, the **Preflight via External Application** workflow step has four output pins:

**Note:**
- **Preflight OK**: your files will go through this pin if the preflight gave an OK status.
- **Preflight with Warnings**: your files will go through this pin if the preflight gave a warning.
- **Preflight with Errors**: your files will go through this pin if the preflight gave an error.
- **Error**: your files will go through this pin in case of a processing error unrelated to the preflight status.

3. Connect each pin to the appropriate workflow step (for example, files which are “OK” or “Warning” can be normalized depending on your preflight setup, while files with “Error” need to be checked by an operator).
Wait for Action (Checkpoint)

Use the **Wait for Action (Checkpoint)** task to make your workflow stop at certain predefined points so that you have time to check and possibly correct something. See *Wait for Action*.

This Workflow is built so that you can route files based on your expertise. You will get a notification (**To Do List**) when the Preflight detects an error. The processing will be paused until you decide whether to approve the file or not, based on the preflight error report.

1. Add the **Wait for Action (Checkpoint)** step to your workflow.
2. Double-click the step to open its settings.
3. Create the notification that will be sent:
   a) choose which user you want to send it to,
   b) enter a **Subject**,
   c) add a **Message** if you want.

   ![Notification Settings](image)

4. Choose a **Due date**. Either:
   - choose one of the predefined due dates (from **Immediate** to **Next Sunday**),
   - choose **Other...** in the **Due date** list and pick the due date yourself.
5. In **Output states**, define the output possibilities you want for your checkpoint.

By default, this step has two outputs: **Completed** and **Aborted**.

To add an output:

a) click **Add**,  
b) enter the output’s name.

Add as many outputs as you like.

6. If necessary, use the **Move Up** and **Move Down** buttons to display your outputs in a different order.

    **Note:** You can **Remove** the default outputs if you don’t need them.

7. Click **OK** to apply your settings.

    **Tip:** After connecting the **Output states** you can:

- Add an extra **Output state** to the checkpoint and connect it to the "**Preflight via External Application**" step, to preflight your file again.

- **Relaunch** the file from the Task pane or directly in the canvas. Right click and choose **Relaunch**

**Copy or Move File**

This task copies or moves the input file or the marked files to a new location. To mark a file, please insert the **Mark** file task in your workflow chain. If you don’t want to evaluate an existing file, select
the "Fail" task when the file that is to be copied or moved already exists in the output folder. See *Copy Move File*

### 10.1.2 Normalize your File

The **Normalize PostScript / PDF / Illustrator 8.0 File** generates a Normalized PDF file based on the preflighted file. See *Normalize PostScript / PDF / Illustrator 8.0 File*

- **Transparencies** and **Layers** check the box to import PDF files as in Scope 3 (and lower). All transparencies and layers will be flattened. If not checked, a normalized PDF file will be created that contains all typical PDF features (like transparencies and layers).

**Workflow overview**

![Workflow diagram](image)

### 10.1.3 Trap your file

**Note:** This example still used the older trapping technology that pre-dated the more recent task *Trap with PowerTrapper.*

**Trap - Prepare and Create Trap Layer**

The trapping process is a safeguard against possible (even likely) fluctuations in the printing process. Minor discrepancies in registration, slight paper shifting can cause inks to mis-register. See *What is Trapping?*

There are three different Trap tasks;

**Trap – Create Trap Layer:** This task traps the input file according to the settings specified in the Trap Color Pairs file associated with the input file. The output of this task is a trapped Normalized PDF file. This task contains only the output options of the Trap task. All other trapping parameters are stored in the TCP file located in the same folder as the input file.
**Trap – Prepare and Create Trap Layer**: this step selects candidate trap color pairs and executes the trapping. The trapping areas are added in a separate layer on top of the original job.

**Trap – Prepare Trap Pairs**: This scans through the job and suggests a list of candidate trap color pairs.

### Export Trapped File to PDF

Export your Normalized PDF to generic PDF for storage or approval. See *Export to PDF File*

**Tip:**
- To define the name and location of the output file that will be generated, use **SmartNames**.
- You can send the output file via mail.
- You can use PDF as SoftProof.

### Workflow Overview

10.1.4 View your file

#### Prepare for Viewer

The **Prepare for Viewer** task prepares view data for the **Automation Engine Viewer**. This view data will help the Viewer to quickly open the file (the Viewer will use the prepared View Data instead of asking the server to make or stream it). See *Prepare for Viewer*.

#### Hold for Viewing

Choose a decision maker with experience to approve the trapped file. See *Wait for Action*. The **Automation Engine Viewer** is a powerful integrated Viewer and QA tool. The Automation Engine Viewer offers:

- **Reliability**: Showing the data in a correct way. At best in the same way the RIP/Proofer will see them.
- **Detail**: Unlimited zoom, high detail measuring, measuring traps and exact distances (die objects).
• **Speed:** Opening files swiftly, even when it concerns large files. Fast zooming.
• **See** *Automation Engine Viewer.*

**Workflow Overview**

![Workflow Diagram]

**Tip:** You could add an extra **Output state,** "Send to Proof" to the checkpoint, connecting to *Proof(FlexProof)* to print HardProof.

### 10.1.5 Generate Step & Repeat

**Mark**

- Use this to tag files that you will need to select later in the workflow (with the **Select** workflow control). The file will be tagged as "Label" and after approved in **Hold for Viewing,** the **Select** will pickup the original file.
- **Give the tag a name**.
Select

Use this ticket to select files that you have tagged earlier in the workflow (with the Mark workflow control).

- Enter the tag of the file.

For an example see *Mark and Select*.

Step & Repeat Tabular

This Workflow Step executes all Step and Repeat parameters (number of one-ups vertically and horizontally, gap between one-ups, alignment, SmartMarks...) after which the server will output the sheet layout. The ticket’s input fields also accept SQL queries, so that information stored in a database can be used to drive the sheet layout creation. See *Step & Repeat Tabular*.

Workflow Overview
10.1.6 Create Report

Create Report (ReportMaker)

The ReportMaker task is used to automate the creation of design print cards (in French: fiche technique, in German: Druck Karten).

The idea is that you generate reports containing all kind of information: file name, used inks, name of the operator, an image of the file. All this information is defined in a report template, then this template is used to generate a specific report. For more information about templates, see ReportMaker Templates.

Note: You need PackEdge 3.0 or higher to make a ReportMaker template.

Export Report to PDF

Export to PDF makes it possible to specify different settings, for example PDF version, Color Management…

Tip: You can define the File Name and the, Output location, of the report file that will be generated, by using SmartNames.

Upload via FTP

Upload via FTP is an administration task which allows you to send files to a server. You need an FTP account on that server. For details or how to connect to an FTP server, see Upload via FTP.

Tip: To interact with customers you can also use steps like Publish on Web and Create WebCenter Project.

Workflow Overview
10.2 Use Shuttle in the Workflow

10.2.1 What is Shuttle

Shuttle is a small stand-alone application that enables you to submit files to Automation Engine tasks or workflows, and monitor their progress. You can use Shuttle to connect to several servers. The Shuttle functionality is also integrated in ArtPro, Neo, PackEdge, Plato, FastImpose and in Adobe Illustrator as a DeskPack plug-in. You can download Shuttle from Esko’s Download Center (https://mysoftware.esko.com/). For more information about Shuttle see the Shuttle User Guide.

Set up Shuttle for Automation Engine

To use Shuttle and submit files to your Automation Engine workflow, you need to set up your server, your Shuttle client, and make sure they can exchange files via a shared folder.

Workflow Server Setup


Shuttle Client Setup

Set up your Shuttle client in the applications you use. See Shuttle Clients Setup, Automation Engine User Guide.

Shared Folder Setup

You also need to make sure that the relevant servers shared folders are mounted on the Shuttle clients machines, with the appropriate Read and Write permissions. For Automation Engine, the
shared folder is either an Automation Engine Container, or an Upload Folder you set up in Configure. See Automation Engine Setup for Shuttle, Automation Engine User Guide.

10.2.2 What are Public Parameters

Learn more about Public Parameters in Using Public Parameters in Workflows.

10.2.3 Making Your Tickets Public

With Shuttle, you can submit files to any Automation Engine task, task chain or workflow that has a custom ticket. To do this, you need to make the ticket public. You can either:

- Select the Public option when creating the ticket.
- In the Ticket view, right-click your ticket and select Public Ticket.

Note: Public Tickets have a mark in the Public column.

<table>
<thead>
<tr>
<th>Task Type</th>
<th>Ticket Name</th>
<th>Public</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zip</td>
<td>Default</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>WEC_Area</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>WEC_AreaListFiles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Trap</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Trap_Area</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Trap_AreaListFiles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workflow</td>
<td>Send2 Cody</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

10.2.4 Using Public Parameters

Public Parameters are ticket parameters that users can define when they launch tasks using Shuttle (applications).

For each public parameter, you can either:

- enter a list of predefined values that the user needs to choose from,
- let the user enter a value himself.

Making a Parameter Public

Attention: You need to define which parameters are public before files are submitted to your workflow.

In the ticket containing the parameter to make public:

1. Right-click the parameter and select Make Parameter Public.
2. Right-click it again and select Modify Public Parameter...
3. In the Modify Public Parameter dialog that opens:
   a) If necessary, change the way the parameter will be called in Shuttle in Prompt as.
   b) Choose either:
• **Allow the user to set the value** if you want Shuttle users to be able to freely enter a value for that parameter.

• **Let the user select a predefined value** if you want Shuttle users to choose from a list of values that you define.

If that parameter already has a list of values to choose from in the Ticket, they will be displayed here. You can **Add** or **Remove** values.

**Note:** Shuttle operators will see (and choose from) the **Predefined Settings** but not the associated **Values**.

c) If you have chosen **Let the user select a predefined value** in **Default Predefined Setting**, choose the setting that will be selected by default when submitting files from Shuttle (if the operator doesn’t select another setting, this one will be used for processing).

4. Don’t forget to save your ticket.

This is how your public parameter will look to Shuttle operators:

<table>
<thead>
<tr>
<th>If you chose <strong>Allow the user to set the value</strong></th>
<th>If you chose <strong>Let the user select a predefined value</strong></th>
</tr>
</thead>
</table>

### Managing Public Parameters in Your Ticket

Once you have made parameters public in your ticket, you can have an overview of your public parameters and edit them at the ticket level.

1. In your ticket, go to **Advanced > Manage Public Parameters...**

   The **Manage Public Parameters** dialog that opens contains all of your ticket’s public parameters.

   The left pane shows all parameters that can be made public for that ticket (the ones you have made public are greyed out).

   The right pane shows the parameters you have made public, with their settings (predefined values, etc.).

2. You can:
   - drag parameters from left to right to make them public;
   - click a public parameter’s cross if you don’t want it to be public anymore;
   - rearrange the order of your public parameters (drag them up or down);
   - change public parameters’ settings (**Prompt as**, **Predefined Settings**, etc.);
   - group public parameters under a header (click **Add Group**, click to edit the header, and drag parameters from the left);

### Using Presets to Simplify Operators’ Choices

You can use presets to minimize the amount of public parameters your operators have to choose from, and make it simpler for them.

For example, you want operators to use different trapping settings for printing with offset or dry offset. You can define those trapping settings in a preset, so that operators will only have to choose between offset and dry offset.
In the **Manage Public Parameters** dialog:

1. Click the **Add Preset** button.
2. Enter what your operators will see:
   a) in **Prompt as**, enter the name to give the preset parameter in Shuttle,
   b) enter the values that operators will choose from (replacing **Type a value here**).
   Click **Add** if you need to add extra values.
3. Drag parameters from the dialog's left pane into the preset.
   You can drag as many parameters as you want. They will appear under each value (here both **under Offset** and **Dry Offset**).
4. Define the parameters values for each preset value.
   For example, define normal trapping, 50% opacity and object dependant end caps for Offset,
   and reverse trapping, 100% opacity and round end caps for Dry Offset.
5. Don't forget to save your ticket.

This is how your preset will look to Shuttle operators:

**10.2.5 Public Parameters in Sample Workflow: Packaging**

When choosing which parameters to make public you can keep have in mind end production, different customers, workflow capability etc. Define the parameters so that you can change the production file without having to change the workflow ticket.
10.2.6 Launching Files into a Workflow

Launching Files from Shuttle Standalone

1. To assign a Job ID and / or Job Part ID to the files to process in your workflow, go to Window > Context and fill in the Job ID and / or Job Part ID.

Do this when:

- you want to add your file(s) to an Automation Engine job,

  Note: If the file you are launching is already located in an Automation Engine job, it will automatically be processed within that job’s context (you don’t need to enter the Job ID).

2. Open the Launch window using:

- File > New Launch Window...
- Option + Command + N (Mac) or Alt + Control + N (Windows).

3. Select the Workflow you want to launch on your file.
For Automation Engine workflows, you will see public tickets.

Note:
You can open several Launch windows, and select a different workflow in each. If you quit and restart Shuttle, your Launch windows will be remembered.

4. Launch your file in one of the following ways:
   - Drag and drop your file on the Drop Files Here arrow.
   - Click the Launch... button and browse to the file you want to launch.
   - Go to File > Launch... and browse to the file you want to launch.
   - Use Command + S (Mac).

5. If your workflow has public parameters, you will see a pop-up where you can fill them in.

Note:
For more information on public parameters, see:
   - Using Public Parameters on page 52.

Launching Files from PackEdge

Attention: You must save your file on an Automation Engine Container before you can launch it into a workflow from PackEdge.

1. Go to File > Launch Workflow...
   This opens the Launch Workflow window.
2. Select the workflow you want to launch on your file in the workflow list.

3. If your workflow has public parameters, you can fill them in in the same window.

   **Note:** For more information on public parameters, see *Using Public Parameters* on page 52.

4. Click **Launch** to launch the workflow on your file.

**Tip:**

To access Shuttle easily in the future (without using the menus):

1. Go to **Window > Toolbars > Shuttle** to open the Shuttle palette.
2. Drag it into your application’s toolbar.
3. Click to open the **Launch Workflow** window, or to open the **Shuttle** window.