# Contents

1. Location and Copyright.................................................................................................................. 8

2. Welcome........................................................................................................................................ 10
   Introduction................................................................................................................................. 10
   Before you begin........................................................................................................................ 10
   If you need help........................................................................................................................ 10
   Package contents....................................................................................................................... 11
   Important folders, libraries, and files of ArtiosCAD................................................................. 11
   Operating system notes............................................................................................................. 13
   Support for VMware® Fusion....................................................................................................... 14

3. Installing ArtiosCAD..................................................................................................................... 16
   Introduction................................................................................................................................. 16
   Performing a Typical installation............................................................................................... 17
   Performing a Client Installation................................................................................................. 19
   Performing a Server/Custom Installation.................................................................................. 20
   Installing a New Version of ArtiosCAD..................................................................................... 24
   Installing a New Build of the Current Version......................................................................... 25
   Installing Microsoft SQL Server 2012 Express Edition Only................................................... 25
   Using other databases with ArtiosCAD..................................................................................... 27
   Other database notes................................................................................................................ 27
   Upgrading other databases with ArtiosCAD.............................................................................. 27
   Other database notes................................................................................................................ 27
   Changing to SQL Server Express Edition on the database server......................................... 28
   Exporting database information from the old database............................................................ 28
   Loading the upgrade.................................................................................................................. 29
   Automatic migration.................................................................................................................. 30
   Manual migration....................................................................................................................... 31
   ArtiosCAD Database Migration utility command-line options................................................. 37
   Changing to SQL Server Express Edition on client systems.................................................... 38
   Network Ports List..................................................................................................................... 38

4. Peripherals..................................................................................................................................... 40
   Installing a Windows printer....................................................................................................... 40
   Output Destinations..................................................................................................................... 41
   Starting the ArtiosIO program.................................................................................................... 42
   Creating an Output Destination................................................................................................. 43
   Installing CAM Devices............................................................................................................. 44
   Getting started........................................................................................................................... 44
   Preliminaries............................................................................................................................... 44
## 5. Other tasks

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Uninstalling ArtiosCAD</td>
<td>66</td>
</tr>
<tr>
<td>Uninstalling individual ArtiosCAD Programs</td>
<td>66</td>
</tr>
<tr>
<td>Uninstalling SolidWorks separately from ArtiosCAD</td>
<td>66</td>
</tr>
<tr>
<td>Removing MSDE</td>
<td>66</td>
</tr>
<tr>
<td>Removing the ArtiosCAD ODBC entry</td>
<td>67</td>
</tr>
<tr>
<td>Uninstalling a patch</td>
<td>67</td>
</tr>
<tr>
<td>Modifying and Repairing ArtiosCAD</td>
<td>67</td>
</tr>
<tr>
<td>Loading an ArtiosCAD patch</td>
<td>67</td>
</tr>
<tr>
<td>Working with the ArtiosIO Status program</td>
<td>68</td>
</tr>
<tr>
<td>Using Floating Licenses</td>
<td>68</td>
</tr>
<tr>
<td>Configuring floating licenses</td>
<td>69</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>71</td>
</tr>
<tr>
<td>Upgrading ArtiosCAD Licenses</td>
<td>72</td>
</tr>
<tr>
<td>License Manager: keyless</td>
<td>72</td>
</tr>
<tr>
<td>DataCenter database administration when using MSDE or SQL Server Express Edition</td>
<td>73</td>
</tr>
<tr>
<td>Backing up the database</td>
<td>73</td>
</tr>
<tr>
<td>Restoring the database</td>
<td>74</td>
</tr>
<tr>
<td>Database space management for MSDE</td>
<td>74</td>
</tr>
<tr>
<td>MSDE-related Application Log entries in Event Viewer</td>
<td>75</td>
</tr>
<tr>
<td>Using Microsoft SQL Server 2005</td>
<td>75</td>
</tr>
<tr>
<td>Installing Microsoft SQL Server 2005</td>
<td>76</td>
</tr>
<tr>
<td>Configuring Microsoft SQL Server 2005</td>
<td>88</td>
</tr>
<tr>
<td>Notes and troubleshooting</td>
<td>96</td>
</tr>
<tr>
<td>Using Microsoft SQL Server 2012</td>
<td>97</td>
</tr>
<tr>
<td>Installing Microsoft SQL Server 2012</td>
<td>97</td>
</tr>
<tr>
<td>Configuring Microsoft SQL Server 2012</td>
<td>111</td>
</tr>
<tr>
<td>Using Oracle</td>
<td>123</td>
</tr>
<tr>
<td>Replacing an ArtiosCAD server</td>
<td>124</td>
</tr>
</tbody>
</table>

## 6. Defaults

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to Defaults</td>
<td>126</td>
</tr>
<tr>
<td>Creating defaults</td>
<td>127</td>
</tr>
<tr>
<td>Changing defaults</td>
<td>127</td>
</tr>
<tr>
<td>Saving defaults</td>
<td>127</td>
</tr>
<tr>
<td>Searching for Defaults</td>
<td>127</td>
</tr>
<tr>
<td>Performing a Defaults Search</td>
<td>128</td>
</tr>
<tr>
<td>Defaults performance</td>
<td>131</td>
</tr>
</tbody>
</table>
Standard Sheet Sizes.......................................................................................................................... 282
Configuring Intelligent Layout defaults and Costing/Estimating......................................................... 283
Configuring cost centers....................................................................................................................... 283
Changing Cost Center expressions......................................................................................................... 285
Modifiers for cost center expressions.................................................................................................. 287
Notes on Intelligent Layout Defaults.................................................................................................. 289
Overview: Setting up a multi-color printing press cost center using a table........................................ 290
Useful Functions for Cost Center Expressions...................................................................................... 292
STEP(variable, value1, limit1, value2, limit2, ..., limitn, valuen)............................................................ 292
STEPUP(variable, value1, limit1, value2, limit2, ... , limitn, valuen)....................................................... 292
LINESTEP(variable, value1, limit1, value2, limit2, ... , limitn, valuen)................................................... 292
SPEEDSTEP(#RUN,speed1,run1,speed2,run2, ..., runn, speedn).......................................................... 293
List of functions for configuring cost centers........................................................................................ 293
Example Folder-Gluer Formula.............................................................................................................. 296
Run Length Calculation.......................................................................................................................... 297
Print Items and Folder-Gluer Make Ready.............................................................................................. 298
Configuring Outputs............................................................................................................................. 299
Output Type tab..................................................................................................................................... 300
Device tab.............................................................................................................................................. 302
Position tab........................................................................................................................................... 307
Reports tab............................................................................................................................................ 308
Directories tab....................................................................................................................................... 309
View tab................................................................................................................................................ 310
Processing tab....................................................................................................................................... 311
Diesaw tab.......................................................................................................................................... 323
Tiling tab.............................................................................................................................................. 325
Sample line types tab............................................................................................................................. 327
Sample Sequencing tab.......................................................................................................................... 329
Sample creases tab............................................................................................................................... 332
Sample Counter tab............................................................................................................................... 333
Print Sample Position tab...................................................................................................................... 334
Send to tab.......................................................................................................................................... 334
Advanced tab......................................................................................................................................... 334
Information Filter tab............................................................................................................................ 342
Counter Tool Widths tab......................................................................................................................... 343
Counter Cutting Order tab...................................................................................................................... 344
Grouped Outputs tab............................................................................................................................. 344
PDF Security tab.................................................................................................................................. 345
Configuring a PDF Output using Adobe® Acrobat® 5........................................................................ 349
Configuring 3D Outputs......................................................................................................................... 350
Creating a new 3D Output....................................................................................................................... 350
Changing Collada defaults..................................................................................................................... 352
Rule labels............................................................................................................................................ 353
Configuring the Output Scale Table

Notes on using the Output Scale Table

AutoSave / Local Temp Directory

Recovering AutoSave files

Revision Disk File Format in Revision History

Database Browser Reports

Publishing ArtiosCAD documents to WebCenter

WebCenter Project Name group

Publish Options group

WebCenter Folder Name group

WebCenter Login group

WebCenter Connection group

Graphic PDF file rotation import option

Using Spot Colors in PDF files

Layered PDFs

Setting Cape/TOPS Defaults

Setting DWG/DXF Options

Color Palettes

Adding a New Color Palette

Color Palette by Feature

Choosing Default Color Palettes

Canvas/Parts Options

Canvas Layout Options

Tool Layer Options

Default Side for Geometry Macros

Rectangle from Line Options
1. Location and Copyright

Esko
Kortrijksesteenweg 1095
BE-9051 Gent
Belgium
Tel.: (32) (9) 216-92-11
Fax: (32) (9) 216-94-64
Other offices worldwide.
Written and revised by Adam Hartfield, June 2018.
For use with ArtiosCAD 18 or greater.
© Copyright 2016 Esko Software BVBA, Gent, Belgium.

All rights reserved. This material, information and instructions for use contained herein are
the property of Esko Software BVBA. The material, information and instructions are provided
on an AS IS basis without warranty of any kind. There are no warranties granted or extended
by this document. Furthermore Esko Software BVBA does not warrant, guarantee or make any
representations regarding the use, or the results of the use of the software or the information
contained herein. Esko Software BVBA shall not be liable for any direct, indirect, consequential
or incidental damages arising out of the use or inability to use the software or the information
contained herein.

The information contained herein is subject to change without notice. Revisions may be issued
from time to time to advise of such changes and/or additions.

No part of this document may be reproduced, stored in a data base or retrieval system,
or published, in any form or in any way, electronically, mechanically, by print, photoprint,
microfilm or any other means without prior written permission from Esko Software BVBA.

This document supersedes all previous dated versions.

This software is based in part on the work of the Independent JPEG Group.
Adobe, Acrobat, Illustrator, and PostScript are either registered trademarks or trademarks of
Adobe Systems Incorporated in the United States and/or other countries.
Apple and QuickTime are registered trademarks of Apple, Inc.
Microsoft and the Microsoft logo are registered trademarks of Microsoft Corporation in the
United States and other countries.

The Esko software may contain an implementation of the LZW algorithm licensed under U. S.
Patent 4,558,302 and foreign counterparts.
The Esko software may contain the “RSA Data Security, Inc. MD5 Message-Digest Algorithm.”
Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun
Microsystems in the U.S. and other countries.
Strip Clip, Strip Fork and Strip Clip® System are products, registered trademarks and patents of
Vossen Profitec® GmbH Germany.
OpenGL is a registered trademark of Silicon Graphics, Inc.

The geometry macros contained with this release of ArtiosCAD to facilitate the use of Vossen Profitec components are approved by Vossen Profitec GmbH and are used with their permission. The Vossen Prax® documentation should be consulted and used to ensure correct use and placement of these geometry macros. The shapes and offsets used are in accordance with Vossen Profitec GmbH specifications. Usage and placement of these geometry macros to ensure effective stripping performance however, remains the responsibility of the user. Vossen Profitec GmbH may be contacted for details of worldwide representation at (49) (7771) 920-136 or by e-mail at info@vossen-profitec.de.

This software may use libxml2 - Copyright © 1998-2003 Daniel Veillard - All rights reserved.

All other product names are trademarks or registered trademarks of their respective owners.

Correspondence regarding this publication should be forwarded to:

Esko
Kortrijksesteenweg 1095
BE-9051 Gent
Belgium
info.eur@esko.com
2. Welcome

Introduction

This book describes how to load ArtiosCAD and its related components, both as a new installation and as an upgrade to a previous version, as well as how to add input and output devices and perform other configuration tasks.

For the latest information on system requirements, please go to the Esko website and search for system requirements.

Before you begin

Before trying to install ArtiosCAD, you should make sure that you know how to:

- view file and directory information with Windows Explorer
- make network connections and create network shares
- use a text editor such as Notepad

If you are going to use the included database product, find out from your IT department what the password policy is, as you will need to know it to set the database user passwords.

Make sure the network is up and running correctly so that you can see network resources from all machines. To install ArtiosCAD, you must be able to log in using an account that is a member of the local Administrators group.

ArtiosCAD will work immediately after being installed, but you will most likely want to set up some output devices as described in the Peripherals chapter.

If you have any questions, please do not hesitate to contact your local Support office for help.

If you will be using ArtiosCAD in a language other than American English, make sure your operating system's regional settings are set to match those of the United States. Specifically, for numbers, the decimal symbol needs to be a period, the decimal grouping symbol a comma, the list separator a comma. For currency, the decimal symbol needs to be a period and the digit grouping symbol a comma. Unpredictable results might occur if these settings are not made.

If you need help

If you need help while installing ArtiosCAD, click the Answers to Common Questions link on the main page of the installer. It will bring you to a Web page of frequently asked questions and their answers. There are separate versions of the page for ArtiosCAD and ArtiosCAD Enterprise.
Package contents

The ArtiosCAD package includes the ArtiosCAD media which contains:

- The installation program
- Release notes - an overview of changes and enhancements and a list by number of bug fixes
- ArtiosCAD Viewer - a program you can give your vendors and customers. It is a stripped down version of ArtiosCAD which allows the user to view and print any ArtiosCAD design or 3D file. Viewer users can directly measure the structure, preview a 3D file with or without graphics from different angles, and fold and unfold it. Viewer is also available for downloading for free from the ArtiosCAD website (http://www.esko.com) and can be loaded on any system which supports ArtiosCAD.

Important folders, libraries, and files of ArtiosCAD

There are several folders that are set up under the \Esko\Artios folder on the drive chosen for the installation. One is the folder that contains the ArtiosCAD version that was installed. Others hold database, license, or other related information.

Folders underneath the version of ArtiosCAD

Three library folders have unique and important functions in the configuration and running of ArtiosCAD. They are: InstLib, ServerLib and ClientLib. ServerLib and ClientLib are in ..\Esko\Artios, but InstLib is in the installation directory for ArtiosCAD as it is version-specific.

InstLib:

- InstLib contains default files shipped with the software. It is important to not change these files for a number of reasons. NEVER save modified files in InstLib.
- Reloading (upgrade mode) the current revision from media will overwrite any changes made to files in InstLib.
- Some of the files in InstLib (sysdflt.zip and its associated files) are used as reference files when doing an ArtiosCAD version upgrade. These files are checked against the user-modified versions in ServerLib to determine what and how to move modified information to the new version.
- It is useful to have a clean set of files to work from. If a file in ServerLib gets corrupted for some reason, you can recover a clean copy without having to reload ArtiosCAD. (The better solution is to make regular system backups!)
- There is a searchlist set up for ArtiosCAD which looks at these directories in the order ClientLib, ServerLib, InstLib. Files that are duplicated in ServerLib, for example, will be used in preference to those in InstLib. Duplicate files in ClientLib will be found in preference to files in both ServerLib and InstLib.
The Symbol sub-folder contains samples of common corrugated symbols such as \texttt{fragile.ard}, \texttt{recycle.ard}, \texttt{thiswayup.ard}.

ServerLib:

- ServerLib contains configurations that have been modified from their initial defaults, standards, logos and other files (other than user data files) that need to be shared by all of the ArtiosCAD seats on the site network.

- When Shared Defaults are modified, the changes are saved to ServerLib in a file called \texttt{sysdflt.zip} (and files that this references).

- New (additional) files that are to be shared by all of the ArtiosCAD seats on the site network should be placed in ServerLib. For example, reports that need to be used by all of the ArtiosCAD seats on the site network should be placed here. A copy of the report should be placed in ServerLib and added to the Reports Catalog in Shared Defaults.

ClientLib:

- This directory stores the defaults created in \texttt{Options > Defaults > User Defaults} in a file called \texttt{clientdflt.zip}. The defaults and files saved to the ClientLib directory are only available to the particular workstation on which they were created. It is not intended that they be shared on the network. These defaults are merged with the Shared Defaults. Client defaults take precedence over Shared Defaults.

- ClientLib is used for local machine defaults only. It is used only if you wish to limit the function or change to ONE computer. For example, the most common usage is to provide Outputs to equipment like a Laser or a Counter Cutter to the computer system that is located in the room where this equipment resides. If the whole design and estimating departments work on the outside of the box, but the die room wishes to view the layouts Die-side, they might set up a User Default so that layouts are opened Die-side.

- If you are working on a live system and are trying to build new defaults, create them as User Defaults. Once happy with the results, copy the results into Shared Defaults and delete the User Defaults.

LpLib and DwLib:

- Contain files that are needed for the support of Standards written using LASERPOINT IQ or The Designer WorkBench. The standards shipped with these systems are also included. These are loaded during the installation of ArtiosCAD.

Program:

- This is where the executable programs are stored.

Common:

- On License Server machines, contains and shares the license files for all seats. The license file is stored in this `\Esko\Artios\Common` folder. If License Manager is not being used, this directory contains the file that controls what features are available in ArtiosCAD. This file is called \texttt{TUNEOPT.TXT} or \texttt{TUNEOPT7.TXT}.

- This directory also contains some additional programs in the Program folder that are not ArtiosCAD version-dependent.

- In addition, this directory contains the default board texture pictures.
DataCenter:

• This is the database folder.
• The English (or language folder) is a sub-folder of the DataCenter program folder. It contains several important files such as database export and import programs and databaseID.exe.

User Data Files:

• These can be shared, distributed or stored locally at each workstation.
• A DataCenter resource is automatically created for the User Data File destination chosen during installation. So, for example, if each client chooses a local destination folder during installation, a resource will be created for each directory in the Resource Browser of DataCenter Admin.
• In new installations, the \Esko\Artios\Designs folder is created as the default folder for user files. The destination folder selected here is a master resource in DataCenter Admin. If users add sub-folders underneath this folder after the installation, they automatically become DataCenter Admin resources the first time files are saved in them.
• If directories are added to other locations, they need to be manually added to DataCenter as resources. Files saved to these directories will not be recorded in the database unless the directories are resources.

Operating system notes

Windows Vista Business

If you are using Microsoft Windows Vista Business as the operating system on your computer, file and utility locations may differ from those referenced later in this book.

Table: Changed items or locations

<table>
<thead>
<tr>
<th>Referenced item or location</th>
<th>Changed item or location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start &gt; Programs</td>
<td>Start &gt; All Programs</td>
</tr>
<tr>
<td>Start &gt; Settings &gt; Control Panel</td>
<td>Start &gt; Control Panel</td>
</tr>
<tr>
<td>Start &gt; Settings &gt; Control Panel &gt; Administrative Tools &gt; Data Sources (ODBC)</td>
<td>Start &gt; Control Panel &gt; Classic View &gt; Administrative Tools &gt; Data Sources</td>
</tr>
<tr>
<td>Start &gt; Settings &gt; Control Panel &gt; Add/Remove Programs</td>
<td>Start &gt; Control Panel &gt; Programs &gt; Programs and Features</td>
</tr>
<tr>
<td>C:\users\prod (legacy user files location)</td>
<td>Any other folder. Windows Vista Business uses this folder to store operating system files.</td>
</tr>
<tr>
<td>SolidWorks 2007</td>
<td>SolidWorks 2007 is not supported in Windows Vista (any version).</td>
</tr>
</tbody>
</table>
Windows 8

• Installing ArtiosCAD

During the installation, a pop up from Windows will inform you that you require .NET 3.5 in order to continue. This must be downloaded and installed. After installation of .NET, the computer will need to reboot as the install cannot continue.

When installing Microsoft SQL Server 2005 Express Edition, Windows will prompt you stating that there are known compatibility issues. Clicking to continue without checking online allows it to install just fine.

Be vigilant about the installation location as it may not default to where you would expect.

• Using ArtiosCAD

Within the Save As dialog box, the resize icon on the bottom right of the dialog box overlaps into the bottom right of the page.

Windows 8 does not show toolbar button selection or depression the same as previous versions of Windows. During installation or during new user creation, Windows will ask for a color theme to use. When a toolbar button is depressed or highlighted, it will highlight as a color from the chosen color theme instead of looking like the button was physically pushed in.

Windows 8 makes use of hot corners to perform certain tasks. It is easy to accidentally activate these hot corners when working at the edge of the window. (using the File menu, editing fields of a tool on the Status bar when in full-screen mode, selecting a Status bar button) This problem is exasperated when moving the cursor along the screens edge as it will either show a menu of currently running apps (left) or the charms menu (right). This will obscure the ArtiosCAD window further, forcing you to move the mouse to the middle of the screen and then bring it back to continue your task.

If after performing an Output the resulting file is automatically opened, there is a chance the file format will be associated with a Windows 8 application which will automatically open in full screen. To get back to ArtiosCAD, press ALT-TAB to change applications, or press the Windows key and click the desktop tile, or press WIN-D and maximize ArtiosCAD from the taskbar.

As of this writing, ArtiosCAD does not support touch input. Some preliminary testing has revealed that selecting and drag select work as expected. However, panning and scrolling do not work correctly.

Support for VMware® Fusion

ArtiosCAD is now supported for use on Apple Macintosh computers using the VMware Fusion virtualization software to simulate IBM-compatible personal computers. There are some restrictions to what is supported, however:

1. Parallel security keys are not supported as Apple Macintoshes no longer have parallel ports.
2. VMWare Fusion supports DirectX 8 while ArtiosCAD requires DirectX 9c. As a result, some features may show unexpected behavior.
3. 3D rendering in Direct3D mode is not supported. Use OpenGL rendering instead. To use OpenGL, do the following:

   • In ArtiosCAD, click Options > Defaults > Shared defaults > Startup defaults > 3D Rendering Options.
• Select **OpenGL** in the **3D Rendering** group.

• Select **Use OpenGL for bitmaps**.

• Click **OK**.

• Click **File > Exit**.

• Click **Yes** if asked to save changes to Shared defaults.

• Click **Yes** if asked to overwrite Shared defaults.
3. Installing ArtiosCAD

Introduction

There are four types of installations: Typical, Client, Server/Custom, and Silent. Each can be used as a new installation or as an upgrade from a previous version of ArtiosCAD.

A Typical installation:
- Installs ArtiosCAD as a standalone installation, meaning it is self-contained
- Installs Microsoft SQL Server 2012 Express as the database. YOU MUST HAVE AN INTERNET CONNECTION FOR THIS.
- Allows you to choose the license location and set the program installation folder
- If an upgrade, prompts you to copy a previous configuration or use the default configuration.

A Client installation:
- Installs as a client of another system, meaning it uses another system for the database, licensing, and Defaults.
- If a new installation, asks what the database type will be
- Asks for the names of the Defaults and database servers
- Tests the connection to the Defaults server.

A Server/Custom installation:
- Installs as a client, server, or as a distributed server, meaning it uses different machines for different functions
- If a new installation, asks if the system will host the database, and if yes, asks if you want to install Microsoft SQL Server 2012 Express 64-bit as the database. YOU MUST HAVE AN INTERNET CONNECTION FOR THIS.
- Shares the Artios folder for use by other systems.
- Is the only way to set the features to be installed, the database type, the SQL authentication method, and the user files folder.

A Silent installation presents no dialog boxes, and all options must be specified on the command line. This is meant for use only in large corporate WAN environments where one central administrator installs ArtiosCAD on other computers to which the administrator has remote command access. The silent installation program must be run on the computer on which ArtiosCAD will be used. The silent installation program may not be run on one machine resulting in ArtiosCAD being installed on another machine. Contact Support for more information on performing a Silent installation.

Note: Keep the original ArtiosCAD media in a safe, easily-accessible place in case you need to modify or repair the installation. You must use the same media or network location to repair or modify ArtiosCAD as when you first installed the software.
Performing a Typical installation

Note: If you receive a message about overwriting read-only files, answer yes to overwrite them. Also, if you receive a message about a control failing to register, proceed normally and reboot when the installation finishes.

Note: If you downloaded ArtiosCAD from mysoftware.esko.com, burn the disc image to a DVD and use the DVD to load the software. Store the DVD in a safe place.

If you are going to use the included database product, find out from your IT department what the password policy is, as you will need to know it to set the database user passwords.

To perform a typical ArtiosCAD installation, do the following:

1. Log on as Administrator, or as a user with administrative privileges.
2. Ensure that this system meets the minimum system requirements as published on Esko’s website (search for system requirements).
3. Put the ArtiosCAD media into the computer’s media drive. It should automatically launch the Setup program. If your drive is set to not AutoPlay, start Windows Explorer and double-click setup.exe in the root directory of the media.
4. If you have User Account Control enabled, allow setup.exe to run.
5. The ArtiosCAD Setup dialog box appears.
6. Choose the language in which to run the setup program and install ArtiosCAD in using the Change Language drop-down. It should automatically match the language of your system but you may change it if desired. The setup program language will change to the language you selected.
7. Click Typical Installation.
8. Depending on your system configuration prior to loading ArtiosCAD, the setup program may install required operating system updates. If the system prompts you to reboot, do so; the installation program will resume automatically when you log in after the system comes up again. Do not postpone rebooting if the system requests it.
9. The setup program prompts you to enter passwords for the sa and programmer database users. Choose passwords that comply with your IT security policy. The setup program cannot validate the passwords beforehand so make sure you know what the policy is. The setup program will inform you if the passwords you chose did not work and prompt you to choose new ones. Enter compliant passwords in the Password and Confirm Password fields, record them in a secure place, and click OK.
10. The installer starts installing Microsoft SQL Server 2012 Express. This will take a few minutes. If you chose a non-English version of the program, the setup program asks if you’d like to download and install a language-specific version of the database engine; click Yes.
Note: This installs Microsoft SQL Server 2012 Express Edition, 64-bit with an instance named ESKO and programmer and sa account passwords of your own choosing. Make sure to record these passwords in a secure location as you will need them in the future. The database installer will also install any needed updates, and it may prompt you to reboot. If you do have to reboot, the installation process should continue automatically when you log in again. Several dialog boxes will appear on the screen during the installation but they will disappear automatically. Once the database is installed, proceed with the steps of the installation as outlined below. The setup process will automatically configure the database connection.

• YOU MUST HAVE AN INTERNET CONNECTION TO INSTALL THIS AND BE USING A 64-BIT OPERATING SYSTEM

• YOU MAY ONLY USE THE LANGUAGE OF YOUR OPERATING SYSTEM OR ENGLISH.

• YOU MUST HAVE .NET FRAMEWORK 3.5 OR 3.5.1 INSTALLED IN ADDITION TO .NET FRAMEWORK 4. For Windows 7 and later, this is normally installed by Windows Update, but for Windows Server operating systems, it is a feature that must be installed.

11. The ArtiosCAD installer begins. Click Next in the Welcome dialog box.
12. Read the End User License Agreement in its entirety and choose I accept the terms in the license agreement if you accept all the terms of the License Agreement. Click Next.
13. In the Destination Folder dialog box, choose the folder where ArtiosCAD will be installed. Click Change to change the folder, but be mindful that ArtiosCAD should always be installed to the \Esko\Artios folder on a local drive. Click Next.
14. Review the summary of installation settings. If they are correct, click Install to start installing files. If not, click Back to go back and change settings.
15. A progress indicator shows the status of the copying process.
16. The Esko Station Information Service will be installed automatically. This service collects information about your hardware, software, and Esko licenses. If the ArtiosCAD Configuration Manager service is installed on a machine on your network, it will forward the information collected to ArtiosCAD for use by Support personnel if you configure it to do so. Several dialog boxes will appear displaying information; you do not need to click anything as they will automatically continue.
17. In the InstallShield Wizard Completed dialog box, click Finish.
18. The ArtiosCAD Setup program might prompt for a system reboot. Click Yes to reboot the system.

Once the system comes back up, ArtiosCAD and DataCenter Admin will be fully functional.
19. If you installed a non-English version of ArtiosCAD, run ..\Esko\Artios\DataCenter\program \<language>\dbtranslate.exe to translate phrases in the database.
20. If you are using a network license, click Install License Server Components in the main ArtiosCAD Setup dialog box, which will install the license server and activate the license file you supply. For more information on license management, refer to the licensing documents available at http://www.esko.com/support.
21. You are now ready to configure ArtiosCAD. You will enter the licensing information for ArtiosCAD the first time you start it.
Performing a Client Installation

**Note:** If you downloaded ArtiosCAD from mysoftware.esko.com, burn the disc image to a DVD and use the DVD to load the software. Store the DVD in a safe place.

To perform a client installation, do the following:

1. Log on as **Administrator**, or as a user with administrative privileges.
2. Ensure that this system meets the minimum system requirements as published on Esko's website (search for system requirements).
3. Put the ArtiosCAD media into the computer's media drive. It should automatically launch the Setup program. If your drive is set to not AutoPlay, start Windows Explorer and double-click `setup.exe` in the root directory of the media.
4. If you have User Account Control enabled, allow `setup.exe` to run.
5. The ArtiosCAD Setup dialog box appears.
6. Choose the language in which to run the setup program and install ArtiosCAD in using the Change Language drop-down. It should automatically match the language of your system but you may change it if desired. The setup program language will change to the language you selected.
7. Click **Client Installation**.
8. Depending on your system configuration prior to loading ArtiosCAD, the setup program may install required operating system updates. If the system prompts you to reboot, do so; the installation program will resume automatically when you log in after the system comes up again. Do not postpone rebooting if the system requests it.
9. The ArtiosCAD installer begins. Click **Next** in the Welcome dialog box.
10. Read the End User License Agreement in its entirety and choose I accept the terms in the license agreement if you accept all the terms of the License Agreement. Click **Next**.
11. In the Destination Folder dialog box, choose the folder where ArtiosCAD will be installed. Click **Change** to change the folder, but be mindful that ArtiosCAD should always be installed to the `\Esko\Artios` folder on a local drive. Click **Next**.
12. In the Database Program Selection dialog box, choose the database program for ArtiosCAD to use. This sets the type of connection to the database server. If client software is required to connect to the database (such as an Oracle client), you must install and configure it separately. Click **Next**.
13. In the Server Information dialog box, enter the names of the systems acting as the_Defaults server and Database Server. If the Database Server field is unavailable, the database server must be configured manually via the ArtiosCAD entry in the 32-bit ODBC control panel. You can enter the same system name in all the fields, or you can specify a different system in each field. If you enter remote system names, and those remote systems do not have ArtiosCAD loaded on them, you will have to manually enter the exact path to the applicable resources. **ArtiosCAD must be loaded on the server you indicated on these remote systems for ArtiosCAD to work on the current system!** It does not have to be loaded at the time of the current system installation, but should be loaded soon afterward. Click **Next**.
14. Review the summary of installation settings. If they are correct, click **Install** to start installing files. If not, click **Back** to go back and change settings.

15. A progress indicator shows the status of the copying process.

16. If there is no other Esko software on this system, the Esko Station Information Service will be installed automatically. This service collects information about your hardware, software, and Esko licenses. If the Esko Configuration Manager service is installed on a machine on your network, it will forward the information collected to Esko for use by Support personnel if you configure it to do so. Several dialog boxes will appear displaying information; you do not need to click anything as they will automatically continue.

17. In the InstallShield Wizard Completed dialog box, if you are using a local license, click **Activate Local Licenses** to begin activating your license so that you can start using ArtiosCAD. For more information on license management, refer to the licensing documents available at [http://www.esko.com/support](http://www.esko.com/support). When your local license activation is complete, or if you are using a network license, click **Finish**.

You are now ready to start using ArtiosCAD. You will enter the licensing information for ArtiosCAD the first time you start it.

### Performing a Server/Custom Installation

**Note:**

If you downloaded ArtiosCAD from mysoftware.esko.com, burn the disc image to a DVD and use the DVD to load the software. Store the DVD in a safe place.

If you are going to use the included database product, find out from your IT department what the password policy is, as you will need to know it to set the database user passwords.

To perform a Server/Custom installation, do the following:

1. Log on as **Administrator**, or as a user with administrative privileges.
2. Ensure that this system meets the minimum system requirements as published on Esko's website (search for system requirements).
3. Put the ArtiosCAD media into the computer’s media drive. It should automatically launch the Setup program. If your drive is set to not AutoPlay, start Windows Explorer and double-click **setup.exe** in the root directory of the media.
4. If you have User Account Control enabled, allow **setup.exe** to run.
5. The ArtiosCAD Setup dialog box appears.
6. Choose the language in which to run the setup program and install ArtiosCAD in using the **Change Language** drop-down. It should automatically match the language of your system but you may change it if desired. The setup program language will change to the language you selected.
7. Click **Server/Custom Installation**.
8. The setup program asks if this system will host the ArtiosCAD database. Click **Yes** if it will or **No** if you have a dedicated database server.
9. If you clicked Yes in the previous step, the setup program asks if you would like to install the free bundled database, Microsoft SQL Server 2012 Express Edition, 64-bit. If you want to use this database:
   a) **YOU MUST HAVE AN INTERNET CONNECTION TO INSTALL THIS AND BE USING A 64-BIT OPERATING SYSTEM**
   b) **YOU MAY ONLY USE THE LANGUAGE OF YOUR OPERATING SYSTEM OR ENGLISH**
   c) **YOU MUST HAVE .NET FRAMEWORK 3.5 OR 3.5.1 INSTALLED IN ADDITION TO .NET FRAMEWORK 4.** For Windows 7 and later, this is normally installed by Windows Update, but for Windows Server operating systems, it is a feature that must be installed.

Clicking **Yes** will install Microsoft SQL Server 2012 Express Edition, 64-bit with an instance named ESKO and sa account password of your own choosing. If you chose a non-English version of the program, the setup program asks if you'd like to download and install a language-specific version of the database engine; click **Yes**. The setup program prompts you to enter passwords for the sa and programmer database users. Choose passwords that comply with your IT security policy. The setup program cannot validate the passwords beforehand so make sure you know what the policy is. The setup program will inform you if the passwords you chose did not work and prompt you to choose new ones. Enter compliant passwords in the Password and Confirm Password fields, record them in a secure place, and click **OK**. The database installer will also install any needed updates, and it may prompt you to reboot. If you do have to reboot, the installation process should continue automatically when you log in again. Several dialog boxes will appear on the screen during the installation but they will disappear automatically. Once the database is installed, proceed with the steps of the installation as outlined below. The setup process will automatically configure the database connection. If you will be using a full version of Microsoft SQL Server or Oracle, click **No** and proceed with the steps of the installation as outlined below. You will configure the database connection after installation.

10. Depending on your system configuration prior to loading ArtiosCAD, the setup program may install required operating system updates. If the system prompts you to reboot, do so; the installation program will resume automatically when you log in after the system comes up again. Do not postpone rebooting if the system requests it.

11. The ArtiosCAD installer begins. Click **Next** in the Welcome dialog box.

12. Read the End User License Agreement in its entirety and choose **I accept the terms in the license agreement** if you accept all the terms of the License Agreement. Click **Next**.

13. In the Setup Type dialog box, choose the type of system this will be according to the choice descriptions.
   a) **Client** performs a client installation just as if you had clicked Client Installation in the main installer.
   b) **Server** performs an installation as if you had clicked Typical Installation in the main installer, except that it also shares the Artios folder for use by other systems.
   c) **Advanced** performs an installation with all configuration options available. It is the only way to set the features to be installed, the database type, the SQL authentication method, and the user files folder.

Going forward, these instructions will assume you chose **Advanced**. If you made another choice, follow the instructions in those sections.

14. In the Feature Selection dialog box, choose the features to install on the current machine. For each feature, click the icon in the drop-down list box next to it and choose the appropriate choice. Do not click **Next** when done, but rather proceed to the next numbered step.
a) **ArtiosCAD Configuration.** Click the plus sign (+) next to this entry to open it. **ArtiosCAD Licensing, ArtiosCAD Defaults, and ArtiosCAD Database** can each be installed in any combination on a machine. For Typical and all Standalone installations, leave them all selected.

b) **ArtiosCAD Programs.** **ArtiosCAD Programs** are the program files needed to run ArtiosCAD. You must install these if you want to run ArtiosCAD on the current machine. Not installing these would create a server-only installation provided the servers were selected for installation. You must leave this choice selected to install ArtiosCAD itself.

c) The **ArtiosCAD Programs** group controls whether or not ArtiosCAD itself is installed. Optional components of ArtiosCAD that require purchasing a license for the corresponding modules are contained as subfeatures in the group. At this time, only **ArtiosCAD 3D Data Exchange** is a selection. Refer to the license report from Esko to determine which components to select. Installing software components without having the corresponding licenses wastes disk space. Not installing the software components but having the licenses for them results in features that do not function within ArtiosCAD.

d) **Esko Configuration Manager** collects data from systems running the Esko Station Information Service and sends the collected data to Esko automatically for use by Support personnel. **It sends information only if you configure it to do so and leave it enabled.** It is a great aid to Support personnel as they will have required information about your hardware and licenses available should you need to call for assistance. Only one system per site should have the Esko Configuration Manager installed.

15. While still in the Feature Selection dialog box, with one of the components to be installed selected, review the folder in which ArtiosCAD will be installed, and click **Change** if desired. In the resulting Change Current Destination Folder dialog box, change the drive if desired, and click **OK** to return to the Feature Selection dialog box. ArtiosCAD should always be installed to the \Esko\Artios folder on a local drive. Click **Next**.

16. Choose the database program for ArtiosCAD to use. The default and recommended choice is SQL Server Express Edition, a free desktop database from Microsoft that requires a 64-bit operating system. If this is a new installation, you must have already installed it to use this choice. **MSDE** is an older free desktop database from Microsoft that does not require a 64-bit operating system but that offers less robust performance. Choosing **Microsoft SQL Server or Oracle** is appropriate for workgroup or enterprise use where those databases are already in use. Click **Next**.

17. In the Server Information dialog box, enter the names of the systems acting as the Defaults server and Database Server. If the Database Server field is unavailable, the database server must be configured manually via the ArtiosCAD entry in the 32-bit ODBC control panel. You can enter the same system name in all the fields, or you can specify a different system in each field. If you enter remote system names, and those remote systems do not have ArtiosCAD loaded on them, you will have to manually enter the exact path to the applicable resources. **ArtiosCAD must be loaded on the server you indicated on these remote systems for ArtiosCAD to work on the current system!** It does not have to be loaded at the time of the current system installation, but should be loaded soon afterward. Click **Next**.

If you choose **Microsoft SQL Server or Oracle**, configuration scripts and a batch file for those databases will be placed in the \Esko\Artios\DataCenter directory. The database administrator **MUST** run the appropriate batch file before using ArtiosCAD or ArtiosCAD Enterprise. Other post-installation tasks must be performed as well.
18. The default location for the storage of user files is shown in the User Files Folder dialog box. To change it, click **Change**; to accept it, click **Next**. If you change the location to another system, use a UNC locator (e.g. `\system2\designs`) instead of a mapped drive letter.

19. In the Advanced Options dialog box:
   a) **Keep Previous Versions** is the default for previous version handling. It means that ArtiosCAD is installed using a version-specific folder and icon which match the version of the installation, and all previous versions of ArtiosCAD are kept. All previous installations of language-specific versions will have their Defaults merged into the multilingual version being installed. To change this setting, click **Change**. In the Previous Version Handling dialog box, **Overwrite previous versions** simply uses ArtiosCAD as the icon name and ArtiosCAD as the directory with no version number. Once you have chosen the option to use, click **OK** to return to the Advanced Options dialog box.
   b) If you are using SQL Server Express Edition or Microsoft SQL Server as the database, you have the choice of database authentication methods. **SQL Server Authentication** requires each user to have a login created within the database; by default, ArtiosCAD uses one database user (programmer) for all ArtiosCAD users. However, your company may have different requirements. **Windows Authentication** passes operating system login credentials to the database. You should use Windows Authentication only if you have a dedicated database administrator who can perform user maintenance tasks.
   c) Enter the SA user password you specified earlier in the SA Password field.
   d) Click **Next**.

20. Review the summary of installation settings. If they are correct, click **Install** to start installing files. If not, click **Back** to go back and change settings.

21. A progress indicator shows the status of the copying process. Click **OK** if told that the Artios directory has been shared. Everyone has read-only access to this share; members of the local Administrators group have read/write access.

22. If there is no other Esko software on this system, the Esko Station Information Service will be installed automatically. This service collects information about your hardware, software, and Esko licenses. If the Esko Configuration Manager service is installed on a machine on your network, it will forward the information collected to Esko for use by Support personnel if you configure it to do so. Several dialog boxes will appear displaying information; you do not need to click anything as they will automatically continue.

23. In the InstallShield Wizard Completed dialog box, click **Finish**.

24. The ArtiosCAD Setup program might prompt for a system reboot. Click **Yes** to reboot the system. Once the system comes back up, ArtiosCAD and ArtiosCAD will be fully functional.

25. If you installed a non-English version of ArtiosCAD, run `\Esko\Artios\DataCenter\program <language>\dbtranslate.exe` to translate phrases in the database.

26. If you are using a network license, click **Install License Server Components** in the main ArtiosCAD Setup dialog box, which will install the license server and activate the license file you supply. For more information on license management, refer to the licensing documents available at [http://help.esko.com](http://help.esko.com).

27. You are now ready to configure ArtiosCAD. You will enter the licensing information for ArtiosCAD the first time you start it.
Installing a New Version of ArtiosCAD

This procedure is to install a newer major version of ArtiosCAD, not to update your current version with a new build.

**Note:** If you are going from a pre-16 version to 16 or greater, note that the new version of ArtiosCAD will have language- and version-agnostic Defaults. This means that there will only be one set of Defaults for all languages and versions of ArtiosCAD version 16 and newer. Older versions of ArtiosCAD on this computer will continue to use their own Defaults.

To install a newer version of ArtiosCAD, do the following:

1. **Log on as Administrator, or as a user with administrative privileges.**
2. **Ensure that this system meets the minimum system requirements as published on Esko’s website (search for system requirements).**
3. **Put the ArtiosCAD media into the computer's media drive. It should automatically launch the Setup program. If your drive is set to not AutoPlay, start Windows Explorer and double-click **setup.exe** in the root directory of the media.**
4. **If you have User Account Control enabled, allow setup.exe to run.**
5. **The ArtiosCAD Setup dialog box appears.**
6. **Based on your current installation, choose the type of installation to perform, Typical, Client, or Server/Custom.**
7. **Click Next in the Welcome to the InstallShield Wizard for ArtiosCAD X.xx dialog box.**
8. **Read the End User License Agreement in its entirety and choose I accept the terms in the license agreement if you accept all the terms of the License Agreement. Click Next.**
9. **In the Configuration Source dialog box, choose to copy the Defaults from a previous version and then click the previous version whose Defaults you want to use, or choose to use the default configuration which will install a completely unmodified set of Defaults. You should copy the previous configuration if you customized ArtiosCAD in any way, such as adding Output devices and making your own Reports. If the previous version had different languages available, choose from which language to copy Defaults in the Copy configuration from this language drop-down list box; you may only upgrade from one language. Click Next.**
10. **Review the settings listed in the Ready to Install the Program dialog box. If they are correct, click Install to start copying files. If not, click Back to go back and change settings.**
11. **A progress indicator will show the status of the copying process. Click OK if told that the Artios directory has been shared.**
12. **In the InstallShield Wizard Completed dialog box, click Finish. You will enter the licensing information for ArtiosCAD the first time you start it.**

If you installed a non-English version of ArtiosCAD, run **Esko\Artios\DataCenter\program \<language>\dbtranslate.exe** to translate phrases in the database.

To switch from using MSDE to using SQL Server Express Edition, refer to the instructions at the end of the chapter.

If you are using a network license and received a new license, activate it by using the Activate Licenses application in the System Controller subfolder of the Esko folder of the Start menu.
For more information on license management, refer to the licensing documents available at http://www.esko.com/support.

Installing a New Build of the Current Version

This procedure is to install a new build of your current version of ArtiosCAD.

To install a new build of ArtiosCAD, do the following:

1. If this is a server installation, make sure nobody is using ArtiosCAD.
2. Log on as Administrator, or as a user with administrative privileges.
3. Ensure that this system meets the minimum system requirements as published on Esko's website (search for system requirements).
4. Put the ArtiosCAD media into the computer's media drive. It should automatically launch the Setup program. If your drive is set to not AutoPlay, start Windows Explorer and double-click setup.exe in the root directory of the media.
5. If you have User Account Control enabled, allow setup.exe to run.
6. The ArtiosCAD Setup dialog box appears.
7. Click Update ArtiosCAD Installation.
8. Click Yes when told this will upgrade ArtiosCAD and to continue.
9. Click Next in the Resuming the InstallShield Wizard dialog box.
10. A progress indicator shows the status of the copying process.
11. In the InstallShield Wizard Completed dialog box, click Finish.
12. ArtiosCAD is now updated and ready for use.

Installing Microsoft SQL Server 2012 Express Edition Only

To create a database server for ArtiosCAD based on Microsoft SQL Server Express Edition without having to install ArtiosCAD, do the following on a machine that has never had ArtiosCAD on it:

1. Log on as Administrator, or as a user with administrative privileges. Keep these prerequisites in mind:
   a) YOU MUST HAVE AN INTERNET CONNECTION TO INSTALL THIS AND BE USING A 64-BIT OPERATING SYSTEM
   b) YOU MAY ONLY USE THE LANGUAGE OF YOUR OPERATING SYSTEM OR ENGLISH
   c) YOU MUST HAVE .NET FRAMEWORK 3.5 OR 3.5.1 INSTALLED IN ADDITION TO .NET FRAMEWORK 4. For Windows 7 and later, this is normally installed by Windows Update, but for Windows Server operating systems, it is a feature that must be installed.
2. Ensure that this system meets the minimum system requirements as published on Esko's website (search for system requirements).
3. Put the ArtiosCAD media into the computer’s media drive. It should automatically launch the Setup program. If your drive is not set to AutoPlay, start Windows Explorer and double-click `setup.exe` in the root directory of the media.

4. If you have User Account Control enabled, allow `setup.exe` to run.

5. The ArtiosCAD Setup dialog box appears.

6. Click **Install Microsoft SQL Server 2012 Express**. The installer will start.

7. The setup program prompts you to enter passwords for the sa and programmer database users. Choose passwords that comply with your IT security policy. The setup program cannot validate the passwords beforehand, so make sure you know what the policy is. The setup program will inform you if the passwords you chose did not work and prompt you to choose new ones. Enter compliant passwords in the Password and Confirm Password fields, record them in a secure place, and click **OK**. This installs Microsoft SQL Server 2012 Express Edition, 64-bit with an instance named ESKO and programmer and sa account passwords of your own choosing. **Make sure to record these passwords in a secure location as you will need them in the future**. The database installer will also install any needed updates, and it may prompt you to reboot. If you do have to reboot, the installation process should continue automatically when you log in again. Several dialog boxes will appear on the screen during the installation but they will disappear automatically.

8. Run `\Windows\SysWOW64\odbcad32.exe`.

9. In the ODBC Data Source Administrator, click **System DSN** and click **Add**.

10. Select **SQL Server** from the list of available drivers and click **Finish**.

11. In the Create a New Data Source to SQL Server dialog box, enter ArtiosCAD in the Name and Description fields and select the server and instance name in the Server drop-down list box. It should be Name of this machine\ESKO. Click **Next**.

12. When asked about authenticity, select the **With SQL Server authentication**... choice. For the **Connect to SQL Server**... checkbox, enter sa as the Login ID and the password you specified earlier for the sa user. Do not click **Next**.

13. Click **Client Configuration**. The Add Network Library Configuration dialog box appears.
   a) Make sure **TCP/IP** is selected in the Network libraries group and ensure the server name is correct. If (local) was selected in the Which SQL Server do you want to connect to? field in Step 11, only a period (.) appears in the Server alias field and Server name field.
   b) Ensure that **Dynamically determine port** is checked and that the **Port number** is set to 1433. Click **OK**.
   c) Click **Next** in the Create a New Data Source to SQL Server dialog box.

14. In the next dialog box, leave the **Create temporary stored procedures**... and **Use ANSI**... choices selected and click **Next**.

15. In the next dialog box, leave **Perform translation for character data** selected. If the system is using non-U.S. locale settings, check the **Change the language of SQL Server system messages to** checkbox and set the value to **English**. Click **Finish**.

16. The ODBC Microsoft SQL Server Setup dialog box will appear showing a summary of the configuration. Click **Test Data Source**; it should succeed. Click **OK**, and then click **OK** again.

17. Click **OK** in the ODBC Data Source Administrator dialog box.

This database server is now ready for use.
Using other databases with ArtiosCAD

If you chose Microsoft SQL Server or Oracle in the Database Program Selection dialog box, your database administrator must configure the database to work with ArtiosCAD. See Running the Esko ArtiosCAD database configuration batch file for Microsoft SQL Server 2005 or 2000 or Using Oracle for Oracle.

Other database notes

To change the database engine used with ArtiosCAD, delete the ArtiosCAD data source from the System DSN tab of the 32-bit ODBC Data Sources control panel and reinstall ArtiosCAD.

Oracle databases should either have autoexpand set for the tablespace or should have a very large maximum extent set.

Do not change the database passwords in a vendor-supplied utility. Rather, change them in DataCenter Admin by using the File > Change Database Connection (programmer) Password or Change Database System Administrator (sa) Password commands.

Upgrading other databases with ArtiosCAD

If you use Oracle or Microsoft SQL Server as the database engine, you must run the database scripts batch file after ArtiosCAD finishes loading and the system has rebooted (if applicable). See the Other Tasks chapter’s sections about using Oracle or Microsoft SQL Server for more information.

Other database notes

To change the database engine used with ArtiosCAD, delete the ArtiosCAD data source on the System DSN tab from the ODBC control panel and reinstall ArtiosCAD.

Oracle databases should either have autoexpand set for the tablespace or should have a very large maximum extent set.

Do not change the database passwords in a vendor-supplied utility. Rather, change them in DataCenter Admin by using the File > Change Database Connection (programmer) Password or Change Database System Administrator (sa) Password commands.
Changing to SQL Server Express Edition on the database server

SQL Server Express Edition is a replacement for Microsoft Access and MSDE which Esko believes offers greater stability and better performance for ArtiosCAD.

If your system currently uses Microsoft Access as the database engine, you must upgrade it to SQL Server Express Edition. If your system currently uses MSDE, you may continue to use it, but SQL Server Express Edition offers better performance than MSDE.

If you choose to change to SQL Server Express Edition, you should export non-design-based database information from the old database before starting to load ArtiosCAD. The migration to SQL Server Express Edition should be error-free, but if there are problems, you can import this data into a blank database and then do an AutoLoad to create a new database.

Note: This migration workflow is not supported for SQL Server Express Edition version X to SQL Server Express Edition Y. You must use SQL Server’s native detach/attach functionality. The shortcuts to these programs are not installed with versions of ArtiosCAD newer than 14.1.1.

Exporting database information from the old database

To export non-design-based data from the existing database, do the following:

1. Ensure that any programs using the database are not running.
2. Log on to the database server as Administrator or as a member of the Administrators group.
3. Click Start > Programs > ArtiosCAD > Migration Tools > ArtiosCAD Database Export.
4. Enter admin as the username with no password, and click OK.
5. The utility will appear similar to the picture shown below.
6. Enter a sensible file name and location in the **Migration Filename and Path** group.
7. Select all the available tables.
8. Click **Export**. The progress bar indicates the progress of the export.
9. When the export is done, click **Exit**. If the migration to SQL Server Express Edition is error-free, you can delete the exported file after the migration if desired.

**Loading the upgrade**

When you install ArtiosCAD as an upgrade and have been using Microsoft Access or MSDE as the database engine, choose SQL Server Express Edition as the database type, a checkbox appears asking if you want to migrate prior database data to SQL Server Express Edition if this system is the database server.
If you choose SQL Server Express Edition as the database program and this system is the database server, the following actions happen:

- A database schema is built or updated as appropriate.
- The existing ArtiosCAD ODBC datasource is renamed to ArtiosCAD_Access or ArtiosCAD_MSDE as appropriate.
- Empty command prompt windows appear.
- The ArtiosCAD ODBC data source changes to reference the new SQL Server Express Edition database.
- A service called **SQL Server (ARTIOSCADEXP2005)** is created and started.

If this system is not the database server, the ArtiosCAD ODBC datasource changes to reference the SQL Server Express Edition database.

If you choose to migrate the data, the setup program tries to export the data from the old database. If the export is successful, the data is migrated to the SQL Server Express Edition database.

If you do not choose to migrate the data, a blank SQL Server Express Edition database is created and you have to manually export the data from the old database and manually import the data into SQL Server Express Edition.

**Automatic migration**

If you choose to have the setup program migrate the data, a series of empty command prompt windows appears during the installation while the migration tasks are executing. Their duration is directly proportional to the size of the old database.
If there are errors during the migration process, you must manually migrate the data as instructed in the next section.

Signs of a successful migration are:

• Data appearing in the design browsers in ArtiosCAD, and also in DataCenter Admin, provided that the ArtiosCAD System DSN uses a Microsoft SQL Server driver.

If the automatic migration fails, you must perform a manual migration.

**Manual migration**

If you do not choose automatic migration, you must perform the data migration manually on the database server for the old database after the ArtiosCAD installation finishes.

The steps to performing the migration manually are as follows:

1. Export the data.
2. Check the log file for errors.
3. Import the data.
4. Check the log file for errors and try ArtiosCAD.

**Exporting the data**

To export the data from the old database, do the following.

1. Log on as Administrator or as a member of the **Administrators** group.
2. Click **Start > Programs > Esko > ArtiosCAD > Migration Tools > ArtiosCAD Database Migration Export**. The export utility will appear along with a blank command prompt window.
The Migration Folder group shows the folder that stores the files created by the export utility. The export files require the same amount of hard drive space as the Microsoft Access database file, so make sure to choose a location with enough free space. Click Browse to select a new location.

The Data Source group lists the available data sources. Make sure to select the ArtiosCAD_Access or ArtiosCAD_MSDE as the data source for this migration.

The Format group selects the format of the migration files. ADTG is the default; if it errors, try XML.

In the Advanced group, Delete design dups deletes duplicate design records in the database; preserving the newest record and discarding older duplicates. Delete orphans deletes table entries that no longer have corresponding design records on the hard drive. Both options are enabled by default.

The Migrate group contains the actual commands. Export exports the data from the selected data source in the format selected to the migration folder. View Log opens the log file of the export. It is stored in the system temporary directory as ACadFullDbMigrationExportLog.txt. Exit exits the program.

The Migration Process group contains the progress bar showing the table being exported. The length of time required to export the data is directly proportional to the size of the database.
Cancel Migration cancels the migration. Do not use the migration files created by a cancelled migration.

1. Set the migration folder and format as desired, select the ArtiosCAD_Access or ArtiosCAD_MSDE data source, and click Export. During the export, all controls in the dialog box are unavailable except for Cancel Migration.

2. There should be no errors. If an error appears, delete all the ADTG files created by this migration and try using XML for the migration format. If there are no errors, the next step is to check the log file.

Checking the log file for export errors

1. Even if no errors appeared during export, click View Log to view the log file. Information, warnings, and errors are logged. Check the log file for warnings and errors. Warnings related to tables not existing are usually caused by database schema differences among ArtiosCAD versions; these can be safely ignored. Only errors warrant concern. A sample log file is shown below; yours might vary.

Table: Sample ACadDBFullMigrationExportLog.txt

Information: [Exporting table] CODE_TYPE
2. Once you have reviewed the log file, close it. If there were errors, delete the XML or ADTG files and AutoLoad in database recovery mode.

3. Click Exit to exit the ArtiosCAD Database Migration Export utility. The next step is to import the data.

Importing the data

1. Click Start > Programs > Esko > ArtiosCAD > Migration Tools > ArtiosCAD Database Migration Import. The import utility will appear along with a blank command prompt window.
2. The **Migration Folder Path** folder is automatically set to the same folder as the one used previously by the ArtiosCAD Database Migration Export utility.

Make sure to set the option button in the **Format** group to the same format as that used in the export.

Select the **ArtiosCAD** data source if it is not already selected.

In the **Advanced** group, **Delete Database** deletes the contents of the database before importing the data stored in the migration file. For example, to make an exact copy of the database from which you are migrating, select this option, but if you are importing only one table, deselect this option. **Stop on Insert error** completely stops the migration when there is a problem adding information. When deselected, the process continues regardless of errors, and you should read the log file to see if there are errors.

3. **Click Import** when you have set the options as desired. During the import, all dialog box controls are unavailable except for **Cancel Migration**. The progress bar moves to the right as the import progresses. There should be no errors.
Checking the log file for import errors

1. Even if there are no errors, click **View Log** when the import is done to review the log file for errors. Information, warnings, and errors are logged. Check the log file for warnings and errors. A sample log file is shown below; yours might vary.

   **Table: Sample ACadDBFullMigrationImportLog.txt**

   ![](image)

   -----------
   | Information: Deleting data from all tables |
   | Information: [Importing data] code_type [C:\Artios\code_type.adtg] |
   | Information: [Importing data] iq_defaults [C:\Artios\iq_defaults.adtg] |
   | Information: [Importing data] code [C:\Artios\code.adtg] |
   | Information: [Importing data] hierarchical_styles [C:\Artios \hierarchical_styles.adtg] |
   | Information: [Importing data] company [C:\Artios\company.adtg] |
   | Information: [Importing data] person [C:\Artios\person.adtg] |
   | Information: [Importing data] flute [C:\Artios\flute.adtg] |
   | Information: [Importing data] board_folder [C:\Artios\board_folder.adtg] |
   | Information: [Importing data] board [C:\Artios\board.adtg] |
   | . |
   | . |
   | Information: [Importing data] cad_permission [C:\Artios\cad_permission.adtg] |
   -----------
2. Once you have verified there are no errors, close the log file. If there were errors, delete the XML or ADTG files and try the complete process again, using the other format for the data files. If that fails as well, delete the data files and use AutoLoad in database recovery mode.

3. Start ArtiosCAD.

4. Click Database > Browsers > Design browser. The Design Browser should appear normally.

5. If you are upgrading from a version of ArtiosCAD earlier than version 4, run \Esko\Artios\Datacenter\Program\Buildkeys.exe to convert design styles to hierarchical characteristics.

6. The migration to the new database is complete.

Once you have verified that all the data is in the database, delete the XML or ADTG files from the migration folder.

**ArtiosCAD Database Migration utility command-line options**

You can run the ArtiosCAD Database Migration utility from the command line if desired. This ability is meant for use by system administrators in large corporations who manage remote computers.

Use a command prompt to go to the \Esko\Artios\Datacenter\program\language folder.

Next, run ACADDbMigration.exe with the desired switches.

<table>
<thead>
<tr>
<th>Switch</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>-c</td>
<td>Use the command line versus a dialog box.</td>
</tr>
<tr>
<td>-e</td>
<td>Export data (the default.)</td>
</tr>
<tr>
<td>-i</td>
<td>Import data.</td>
</tr>
<tr>
<td>-f folder</td>
<td>Specifies the folder in which the migration files are located. The default is whatever is specified in the registry from a previous export else it is unknown. The registry key is HKLM\Software\Artios\Migration. The registry value is Migration_FullDB_Folder. If -c is used, -f should be used if you are unsure the registry value exists.</td>
</tr>
<tr>
<td>-l logfile</td>
<td>Log file folder and name. The default location is the temp directory specified by the TMP variable if it exists, else the TEMP variable if it exists, else the current directory. The file name is ACADFullDbMigrationExportLog.txt (or ...ImportLog.txt)</td>
</tr>
<tr>
<td>-d datasource name</td>
<td>The default is ArtiosCAD. Note that the Microsoft Access datasource name was changed to ArtiosCAD_Access when you changed to MSDE.</td>
</tr>
</tbody>
</table>
### Switch | Meaning
--- | ---
-t xml or adtg | Format for the migration files. ADTG is the default.

## Changing to SQL Server Express Edition on client systems

If you change your database server to SQL Server Express Edition, you must also load the upgrade on all client systems to configure them to use the new server software. No database software is loaded on clients.

## Network Ports List

ArtiosCAD uses network ports to communicate with its license server (if you use a network license), with the database server (if it is not the local machine), and to perform Outputs. Your computer and the various servers may be running a firewall that blocks ports and thus ArtiosCAD may not work correctly.

<table>
<thead>
<tr>
<th>Program</th>
<th>Ports needed</th>
</tr>
</thead>
<tbody>
<tr>
<td>FlexNet network licensing</td>
<td>25000-27000 (uses random port in this range)</td>
</tr>
<tr>
<td>ELAN network licensing</td>
<td>7841</td>
</tr>
<tr>
<td>Single instance of Microsoft SQL Server, including Express Edition</td>
<td>1433, but could be dynamic; see note below</td>
</tr>
<tr>
<td>Oracle SQL*Net Listener</td>
<td>1521</td>
</tr>
<tr>
<td>i-cut Production Console Output</td>
<td>80, 10003</td>
</tr>
</tbody>
</table>

### Oracle notes

If you need to change the port number for the Oracle SQL*Net Listener, use the Net Configuration Assistant.

### Microsoft SQL Server notes

Every time Microsoft SQL Server starts, including SQL Server Express Edition, it dynamically allocates an available network port for communication. This means that the port number could be different each time you restart the database server or your machine. To circumvent this problem of not knowing which port to open, if your system is using the built-in Windows Firewall with Advanced Security, you can create a program rule that will open whatever port the software uses. If your system uses a different firewall, contact your system administrator for assistance.

1. Log in as Administrator or as a user with administrative privileges.
2. Click **Start** > **Run**.
3. Type **WF.msc** and click **OK**.
4. In the left pane of the Windows Firewall with Advanced Security dialog box, select **Inbound Rules** and then click **New Rule** in the Actions pane.

5. In the Rule Type dialog box, select **Program** and click **Next**.

6. In the Program dialog box, select **This program path**, and then click **Browse**.

7. Navigate to the folder containing the Microsoft SQL Server executable. It will vary depending on your operating system and version of Microsoft SQL Server you are using. On a 64-bit Windows 2008 R2 server using the default Esko-supplied instance, for example, the path is `C:\Program Files\Microsoft SQL Server\MSSQL11.ESKO\MSSQL\Binn`.

8. Select `sqlservr.exe` and click **Open**. The complete path should appear in the field. Click **Next**.

9. In the Action dialog box, select **Allow the connection** and click **Next**.

10. In the Profile dialog box, leave everything selected and click **Next**.

11. In the Name dialog box, enter a name for this firewall rule (like SQL Server) and click **Finish**.

12. Click **File > Exit** to close the Windows Firewall with Advanced Security dialog box.
4. Peripherals

ArtiosCAD can output to devices that use a standard Microsoft Windows driver and also to devices simply connected to a port on an ArtiosCAD computer. Devices that do not use a Windows driver use Output Destinations which are configured in the Output Destinations dialog box in Shared Defaults.

**Note:** This documentation refers to configuring devices in Shared Defaults for all users to access. Configuring a device for use on a single machine in User Defaults follows the same procedure, substituting User Defaults for Shared Defaults.

Installing a Windows printer

ArtiosCAD prints by default to the default Windows printer on the system on which it is running.

For information on installing a printer in the Windows family of operating systems, read the *Setting up a Printer* topic in the How to...Set Up Hardware section of Help.

If this is the first printer installed on the system, it is automatically designated as the system default printer. The **Print** command and the **Plot to Printer** output (**File** > **Outputs** > **Artios** > **Printer Output** > **Plot to Printer**) will use it by default.

To add an Output for a newly-installed printer if it is not the system default printer, do the following:

1. Start ArtiosCAD
2. Open Defaults by clicking **Options** > **Defaults**.
3. In the Shared Defaults pane, scroll down to **Outputs**.
4. Right-click **Outputs**, click **New** from the context menu, and then click **Data**.

5. Enter a name for the Output such as the name of the printer; for example, **HP DeskJet 560C**.
6. Double-click the new Output just created to open its Property page.
7. The **Device** tab will be selected automatically. Leave the **Output type** set as **Plot** and change the **Scale** to **To fit one page**.
8. Click the Device tab. If a dialog box appears with the message **System printer information could not be read**, click OK.

9. Under **Windows Driver**, click the drop-down list box arrow and select the newly-created printer.

10. Click OK, then **File**, then **Save** to accept the printer and save the defaults.

11. Click **Yes** when asked to overwrite the defaults. The printer is now ready for use.

### Output Destinations

**Output Destinations** enable the ArtiosIO program to carry output data from ArtiosCAD to a serial or parallel port. The port can be on the local machine or it can be on a remote computer.
on the network. Output Destinations also allow a device to communicate information (such as its size) back to ArtiosCAD.

Output Destinations require the ArtiosIO program to be running on the machine to which the device is connected.

Starting the ArtiosIO program

The ArtiosIO program is installed when ArtiosCAD is installed. It is configured using the ArtiosIO applet in Control Panel. Only users with administrative privileges can use this applet and the commands within.

To start the ArtiosIO program and configure it to start automatically each time the computer is rebooted, do the following:

1. Open Control Panel by clicking Start > Settings > Control Panel.
2. Double-click the ArtiosIO applet. The ArtiosIO Server dialog box will appear.
3. Click Start and set the Startup Type to Automatic.
4. Click OK.
5. Do this on each computer which has a port to which a device that does not use a Windows driver will be attached.

Creating an Output Destination

Now that the ArtiosIO program is running, you can configure Output Destinations in ArtiosCAD.

1. Start ArtiosCAD.
2. Open Defaults by clicking **Options > Defaults**.
3. Right-click **Output Destination**, click **New** on the context menu, and click **Data**.

![Image of Output Destination configuration]

4. Enter a name for the Output Destination. One good way to name it is to use the system name and port name, e.g. ARTCAD LPT1 or SYSTEM4 COM2.
5. Once you have entered a name for the Output Destination, double-click it to open its Property page.

![Image of Output Destination Property page]

6. Enter the name of the system the port is on in the **Hostname** field.
7. Enter the port name in the **Port** field. Common port names are COM1, COM2, COM3, and LPT1. The COM ports are serial ports (also known as RS-232 ports) and LPT ports are parallel ports.
8. If the port you are adding is a serial port, set its characteristics in the **RS 232 Parameters** group by choosing the options from the drop-down list boxes. If it is a parallel port, clear the **RS 232 Port** checkbox.

9. The **Short Name**: field is the internal-to-ArtiosIO name of the port and can not be changed.

10. Click **OK** when done.

11. To save these changes, click **File > Save** and click **Yes** to overwrite the Shared defaults.

### Installing CAM Devices

#### Getting started

Use the following steps to configure a CAM (Computer Aided Manufacturing) device with ArtiosCAD. Most CAM devices are equipment such as sampletables, lasers, counter cutters, and so on.

Configuring a CAM device follows this general procedure:

- Pick the output device driver from a master list of known devices. This will tell ArtiosCAD what driver to use and how to tune it. Also check and set the size of the device.
- Specify how the peripheral will receive its instructions. This could be either by creating a disk file or by sending the instructions to a parallel or serial port on one of the computers.
- Configure a plotting style or CAM Tooling Setup catalog entry for the device to use that defines which tools on the device are to be used for each type of line in a design.

You may need to adjust the size and positioning settings copied from the master list.

When this process is complete, you will have an output that can be used by any ArtiosCAD user.

#### Preliminaries

First, you need answers to the following questions.

- Will you be using a Windows driver or a CAM driver?
- If a CAM driver is being used, what port will the output go to and how will it get there?
- Is there a pre-built output and plotting style/CAM Tooling Setup catalog entry for the plotter / samplemaker you need to set up?

### Windows driver or CAM driver?

Use a Windows driver if possible. These should be used for all drawings if suitable and if drivers are available for your device. Many CAM devices operate correctly when driven using the IBM Graphics standard Microsoft Windows printer driver. A CAM driver is used when there is no suitable Windows driver for a device.
Is there a pre-built output and style?

If you have a plotter / sampelemaker of a type listed below, there will most likely be a pre-built solution for your plotting and samplemaking needs. You can probably set up the device without going into much of the detail described in this document. If there is not a preconfigured plotting style or CAM Tooling Setup catalog entry, follow the instructions in the Defaults chapter to set it up.

<table>
<thead>
<tr>
<th>Plotter / Samplemaker type</th>
<th>Driver</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Artios Kongsberg sampelemakers</td>
<td>KGB</td>
<td></td>
</tr>
<tr>
<td>Artios Advantage Line sampelemakers</td>
<td>HP</td>
<td></td>
</tr>
<tr>
<td>Data Tech IPC controller</td>
<td>DT</td>
<td>Can not use print spooler</td>
</tr>
<tr>
<td>Data Tech with PC front end</td>
<td>HP / DT</td>
<td></td>
</tr>
<tr>
<td>Elcede Vectocut</td>
<td>ELC / HP</td>
<td></td>
</tr>
<tr>
<td>Elcede IBH controller</td>
<td>ELC</td>
<td>Can not use print spooler</td>
</tr>
<tr>
<td>Graphtec</td>
<td>HP</td>
<td></td>
</tr>
<tr>
<td>Devices driven by HPGL</td>
<td>HP</td>
<td></td>
</tr>
<tr>
<td>LKS Speedplot</td>
<td>PPS</td>
<td></td>
</tr>
<tr>
<td>Alphamerics</td>
<td>HP</td>
<td></td>
</tr>
<tr>
<td>Wild TA2's and TA10's</td>
<td>WILD</td>
<td></td>
</tr>
<tr>
<td>Wild TA-100 series</td>
<td>HP</td>
<td></td>
</tr>
<tr>
<td>Zeta / Bruning</td>
<td>HP</td>
<td></td>
</tr>
</tbody>
</table>

Example 1 - Setting up a Kongsberg XL44 sampelemaker

In this example, you will learn how to open Example output defaults, copy the required entry or entries to your Shared defaults, and save them. Then, if needed, you will learn how to edit the CAM Device Name to complete the setup.

1. Start ArtiosCAD.
2. Click Options > Defaults.
3. Click User defaults.
4. Click File > Open > Example defaults.
5. You will see folders for CAM Tooling Setup Catalog, Customized toolbars, Die press parameter sets, Geometry Macro Catalog, Manufacturing Parameter Sets, NC Export Turning Table, Outputs, Plotting Style Catalog, and Subtype Mapping Catalog. Expand the Outputs folder until you find the Output type you are looking for. (For example: Outputs / Artios / Kongsberg XL22 - FC.)
6. You will see a number of pre-built Outputs. Select and drag Kongsberg XL44 - FC sample cutting and matrix from this side and drop it on the Outputs folder on the Shared defaults side.
7. Double-click the new entry and click the **Directories** tab. Change the directory entries to the directory that the Kongsberg front end computer will look in.

8. Click the **View** tab and note the contents of the **Specify Plotting Style** group. If the plotting style does not exist, its name will be surrounded by parentheses. If the plotting style name
is not surrounded by parentheses, click **OK** and proceed to step 12; otherwise, proceed to step 9.

9. Click **OK** to exit this dialog box.
10. Expand the **Plotting Style Catalog** in Shared Defaults by clicking the plus sign next to it.
11. Look for the plotting style you noted as being used by the Kongsberg. Copy its definition from the Example defaults in the same manner as you copied the definition for the Kongsberg.
12. Make sure the **Shared defaults** button is selected. There will be an asterisk next to it indicating that it has been modified and needs saving. Click **File** and then **Save** to do this. Confirm by clicking **Yes**.
13. Click **File** and then **Exit** to leave Defaults.

You have successfully set up a Kongsberg XL44 Samplemaker.

**Example 2 - Setting up an Alphamerics RS-232 samplemaker**

This type of plotter can use a Microsoft shared print spooler to route the data to the particular computer/port to which the device is connected. This is preferred over using a direct connection to a port on a specific computer since it allows the device to be accessed by anyone who has access to the shared printer.

The first thing to do is set up the print spooler. Use a generic printer driver that does not modify data, such as the IBM Graphics printer driver. This driver is part of the standard driver set provided with the operating system.

1. Set up a printer on the appropriate port. Make sure that the baud rate and other RS-232 properties are set up to suit the plotter interface.
2. Let us assume that you have set up a shared printer on the computer called brunnhilde with a share name of alphamerics. Add a networked printer to your system that points to that shared printer.
3. Follow the steps from Example 1, selecting the appropriate entry in Example CAM Outputs for The Alphamerics Corp instead of Artios. Select the appropriate plotting style. (CAM.ALPHAMERICS)
4. Double-click the Output you just copied. Click the **Device** tab.
5. Click the Browse button (…) at the end of the **CAM Device Name:** field to open the Output Destinations dialog box.
6. Expand the **System Printers** folder by clicking the plus sign (+) next to its name.
7. Select the entry matching the printer queue, for example the \brunnhilde\alphamerics entry, and click **OK**.
8. You are now done. Click **OK** to exit this dialog.
9. Clear the **Out To File** checkbox.
10. Make sure the **Shared defaults** button is still selected. There will be an asterisk next to it indicating that it has been modified and needs saving. Click **File** and then **Save** to do this. Confirm by clicking **Yes**.
11. Click **File** and then **Exit** to leave Defaults.

### Example 3 - Adding a Calcomp DrawingBoard III digitizer

Digitizers are somewhat different from other CAM devices as they are input-only devices. They generally come in two pieces - a flat tablet and a mouse-like puck with buttons on it.

**Note:** DO NOT load operating system drivers for the digitizer! They will prohibit ArtiosCAD from accessing the digitizer!

<table>
<thead>
<tr>
<th>Table: Suggested Digitizer Communication Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Digitizer settings</strong></td>
</tr>
<tr>
<td>Baud rate</td>
</tr>
<tr>
<td>Data bits</td>
</tr>
<tr>
<td>Parity</td>
</tr>
<tr>
<td>Stop bits</td>
</tr>
<tr>
<td>Data Mode</td>
</tr>
<tr>
<td>Data format</td>
</tr>
</tbody>
</table>
Digitizer settings | Suggested setting
------------------|-------------------
(APbxxxxxyyyyy)   | If choosing one of your own, it must be ASCII.

Digitizer step size | 1000 lines/inch or 50 lines/mm

To install the digitizer, do the following:

1. Connect the digitizer to any free serial port (use COM1 for the purposes of this example) and supply it with power. Configure it to match the communications settings listed above.
2. Create an Output Destination for this port and if the serial port is on a remote computer, make sure ArtiosIO is running on the remote machine.
3. Start ArtiosCAD and then click **Options > Defaults**.
4. Open the **Digitizer Setup Catalog** and select either **Calcomp 16 Button** or right-click and create a new data item with the name of your digitizer.
5. Select the **Digitizer Parameters** tab.

6. Make sure the correct Output Destination is selected in the **CAM Device Name** field.
7. Make sure the settings in the **Digitizer Step Size** group match the settings on your digitizer.
8. Press buttons 0, 1 and 2 on the puck. The **Decoded Data** group should look similar to the picture shown below:
Look carefully at the third character in each line of data. Starting from the top, it should correspond to the button you pressed on the puck.

Repeat this for buttons 3-F. Each digit should match up. If it doesn't, your digitizer uses a different data format.

The digitizing menu to the left is the default digitizing menu for a Calcomp digitizer. Photocopy it at full scale or plot \..\InstLib\DIGITIZER_MENU.ARD at full size. You will need it for the next step.
1. Click the **Command Map** tab.
2. Tape the menu to one side of the digitizer surface.
3. Select the **Use Menu** checkbox so that it is checked, and then click **Place Menu**.

4. Move the cross-hair on the digitizing puck to the bottom left corner of the menu and click any button.
5. The puck position in the dialog box will change. Move the puck to the bottom right corner of the menu and click any button. The **Menu Position** and **Rotation** fields will now have values in them.

6. Click **OK** to close the Calcomp 16 button dialog box.
7. Click **File**, and then click **Save** to save the changes made to Shared Defaults. Click **Yes** when asked to confirm the operation.
8. Exit Defaults. Your digitizer is now ready for use.

Example 4 - Setting up an i-cut Production Console Output

ArtiosCAD can Output a single design or a manufacturing file to a Kongsberg samplemaker's front end computer running the i-cut Production Console. ArtiosCAD Outputs a ZIP archive containing a copy of the workspace run through the information filter and a JDF file to a submit folder on the front end which the i-cut Production Console monitors. The table operator can then process the job.

Note: The submit folder on the front end is usually a subfolder of the user who installed the i-cut Production Console. It also is not shared on the network as part of its installation. **YOU MUST KNOW THE EXACT LOCATION OF THIS FOLDER AND HAVE A PUBLICALLY WRITABLE NETWORK SHARE CREATED ON THE FRONT END FOR IT.**

An iPC Output is a Grouped Output containing three individual Outputs:

- **iPC - ArtiosCAD File**
- **iPC - JDF-V2**
- **iPC - Submit Job-V2** (or V3 if you work with filenames in non-English languages). This is the Output you click in ArtiosCAD.

iPC Output - Copying the Example Output

The first step in creating an iPC Output is to copy the example one to one you can modify.

1. Start ArtiosCAD.
2. Click *Options > Defaults*.
3. In Shared Defaults, expand the *Outputs* catalog and the *Artios* folder within it.
4. Right-click *iPC* and click *Copy* on the context menu.
5. Right-click the *Outputs* catalog and click *Paste iPC* on the context menu.
6. Scroll down, right-click *Copy of iPC*, click *Rename* on the context menu, and enter a new name.
7. Open the folder of the new Output and rename each entry by right-clicking it, clicking *Rename* on the context menu, and entering a new name. Make sure to keep the root name of the Output the same so that you know what it does.

iPC Output - Modifying the ArtiosCAD File Output

The next step is to modify the ArtiosCAD File Output so that you do not get prompted for a filename to save the workspace as while running the Output.

1. In the expanded IPC Output, double-click the renamed *ArtiosCAD File* to open it.
2. On the Output Type tab, enable *Omit Output Confirmation Dialog*.
3. Click *OK* to return to Defaults.

iPC Output - Modifying the JDF-V2 Output

The next step in setting up an iPC Output is to modify the JDF Output.
1. Expand the iPC Output you made in the previous section.
2. Double-click the renamed iPC - JDF-V2 to open it.
3. On the Advanced tab, in the iPC System Name field, enter the system name of the Kongsberg front end running the i-cut Production Console. It can be its hostname, its fully qualified domain name, or its IP address.

4. Click OK to return to Defaults.

iPC Output - Modifying the Submit Job-V2 or -V3 Output

The next step in creating the iPC Output is to enter the name of the watched folder on the Kongsberg front end.

1. In the expanded iPC Output, double-click the renamed iPC - Submit Job-V2 or iPC - Submit Job-V3 to open it.
2. On the Grouped Outputs tab, delete the default entries in the list of outputs and replace them with the renamed ones in your renamed Output. There should be two, first ArtiosCAD File and then JDF-V2. Each should be set to Zip, Insert into Zip archive, and Delete output disk file.
3. On the Directories tab, in the Directory field in the Output File group, enter the UNC for the watched folder on the Kongsberg. Also, enable **Omit Save-As Filename Dialog** if you do not want ArtiosCAD to prompt you for a filename every time you run the Output.

4. Click **OK** to return to Defaults.

5. Save and exit Defaults, confirming the overwriting of existing Shared Defaults.

The Output is now ready for use. Shown below is a submitted job in i-cut Production Console.
Advanced digitizer setup

Adding a non-Calcomp digitizer

If you are not using a Calcomp digitizer, the digitizer must meet these requirements:

• The digitizer must be connected via an RS-232C (serial) port on the PC.
• The digitizer must be set to **Point** mode. This means that only one set of positional data is sent when a puck button is pressed.
• The data produced when a button on the puck is pressed must contain one or two characters representing which button was pressed and also strings of numbers indicating the position of the puck when the button was pressed. The data sent must be ASCII, not binary, and must be separated by a carriage return (CR), line feed (LF), or both (CR/LF).

While not required, ArtiosCAD is easier to configure if the digitizer data is in a fixed format.

Once you have the digitizer connected, configured, and turned on, do the following:

1. Start ArtiosCAD and then click **Options > Defaults**.
2. Add an Output Destination for the port the digitizer is connected to.
3. In the Shared Defaults pane, right-click the **Digitizer Setup Catalog** and click **New**, and then click **Data**. Enter the name of the digitizer, press enter, and then double-click it to open its property page.
4. Select the proper Output Destination in the **CAM Device Name** field.
5. Press a few buttons on the digitizer puck. You should see some data appear in the **Decoded Data** group.
The data format should be similar to one of the entries in the **Data String** column in the table below. The letters \( b \) and \( c \) indicate button data and should always be a digit between 0–9 or a letter between A–F.

**Table: Alternate Digitizer Data Formats**

<table>
<thead>
<tr>
<th>Data String</th>
<th>Button ID</th>
<th>X-Data format</th>
<th>Y-Data format</th>
<th>ID position</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Before</td>
<td>After</td>
<td>No.</td>
<td>Fixed/Delim</td>
</tr>
<tr>
<td>APb111112222</td>
<td>2</td>
<td>0</td>
<td>1</td>
<td>F</td>
</tr>
<tr>
<td>Apc555556666</td>
<td>2</td>
<td>0</td>
<td>1</td>
<td>F</td>
</tr>
<tr>
<td>APb 1111 2222</td>
<td>2</td>
<td>0</td>
<td>1</td>
<td>F</td>
</tr>
<tr>
<td>Apc 5555 6666</td>
<td>2</td>
<td>0</td>
<td>1</td>
<td>F</td>
</tr>
<tr>
<td>APbV +1234 -12</td>
<td>2</td>
<td>1</td>
<td>1</td>
<td>F</td>
</tr>
<tr>
<td>ApcV +5678 +123</td>
<td>2</td>
<td>0</td>
<td>2</td>
<td>F</td>
</tr>
<tr>
<td>PQbb00012=00034+</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>F</td>
</tr>
</tbody>
</table>
Once you have determined which format the data is in, set the options in the **Format** group accordingly.

Press buttons on the digitizing puck and check that the appropriate data is appearing in the **Decoded Data** group. If it is not, adjust the format options until they do.
6. Now that the formatting is set correctly, check the Cursor Key Character Map. As you press a button on the digitizing puck, the corresponding key should appear pressed on screen:

<table>
<thead>
<tr>
<th></th>
<th>0 - 0</th>
<th>1 - 1</th>
<th>2 - 2</th>
<th>3 - 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>4 - 4</td>
<td>5 - 5</td>
<td>6 - 6</td>
<td>7 - 7</td>
<td></td>
</tr>
<tr>
<td>8 - 8</td>
<td>9 - 9</td>
<td>A - A</td>
<td>B - B</td>
<td></td>
</tr>
<tr>
<td>C - C</td>
<td>D - D</td>
<td>E - E</td>
<td>F - F</td>
<td></td>
</tr>
</tbody>
</table>

The default configuration assumes the ID character generated matches the name of the button pressed on the digitizing puck.

In most cases, the button named F always produces character F in the data string, but there are digitizers that generate characters other than those expected. For example, some generate the characters ; : and > for keys D, E and F and have a map like the one shown below:

<table>
<thead>
<tr>
<th></th>
<th>0 - 0</th>
<th>1 - 1</th>
<th>2 - 2</th>
<th>3 - 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>4 - 4</td>
<td>5 - 5</td>
<td>6 - 6</td>
<td>7 - 7</td>
<td></td>
</tr>
<tr>
<td>8 - 8</td>
<td>9 - 9</td>
<td>A - A</td>
<td>B - B</td>
<td></td>
</tr>
<tr>
<td>C - C</td>
<td>D - D</td>
<td>E - E</td>
<td>F - F</td>
<td></td>
</tr>
</tbody>
</table>

The default configuration assumes the ID character generated matches the name of the button pressed on the digitizing puck.

You can manually set the character map by clicking the on-screen button and replacing the value in the Current ID field with the one or two characters produced by the digitizer when the button on the digitizing puck is pressed. Repeat this procedure for each button on the digitizing puck.

You can also set the character map using only the input from the digitizer. First, make sure the formatting is set correctly. Next, click the on-screen 0 button and then click Input from Digitizer. Click the 0 button on the digitizing puck to enter the value for 0. The 1 on-screen button will then be automatically selected, so press the 1 button on the digitizing puck.
Repeat for the rest of the buttons. If you make a mistake, simply click the on-screen button you wish to reprogram, and press the appropriate button on the digitizing puck.

7. Now that the character mapping is configured, test it by clicking Test Map. As you press buttons on the digitizing puck, the corresponding on-screen buttons should appear pressed.

**Adjusting the step size of the digitizer**

Over time, you may notice that your digitized geometry is not as accurate as you desire. While your digitizer may be set to have 1000 lines of resolution per inch, by digitizing a 10-inch square with extreme accuracy which results in a 10.03 by 10.06-inch square in ArtiosCAD, you realize that it is out of calibration. The solution to this is to adjust the step size. Open the entry for the digitizer in Defaults and adjust the entries in the Digitizer Step Size group.

Using the values stated in the previous paragraph, change the 1000 in the drop-down list box to 1003, click the Different in Y checkbox, and change the 1000 in that drop-down list box to 1006.

**Configuring the Command Map**

Digitizing has 26 commands. Each can be assigned a digitizer puck key sequence and/or a digitizer Menu Item Area. If you wish to use the command while digitizing, you must assign either a Key Sequence and/or a Menu Item Area to the command. (If you think you will never use some of the commands, you may choose to leave them unassigned.)

The following abbreviations are used in the table below:

- `<c>` A coordinate on the digitizer.
- `<p>` An existing point. These are the end points (and intersection points) of existing lines in the current design whether just digitized, or part of the original structure. To select such a point, you must digitize a point on the digitizer within snap distance of one of these points.
- `<l>` An existing line. To select such a line, you must digitize a point on the digitizer within snap distance of an existing line in the design.

**Table: Digitizer Commands**

<table>
<thead>
<tr>
<th>Key sequence</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>MOVE TO &lt;c&gt;</td>
</tr>
<tr>
<td>12</td>
<td>MOVE TO &lt;p&gt;</td>
</tr>
<tr>
<td>0</td>
<td>LINE TO &lt;c&gt;</td>
</tr>
<tr>
<td>Key sequence</td>
<td>Command</td>
</tr>
<tr>
<td>--------------</td>
<td>---------</td>
</tr>
<tr>
<td>10</td>
<td>LINE TO &lt;p&gt;</td>
</tr>
<tr>
<td>3</td>
<td>ARC THROUGH &lt;c&gt; TO &lt;c&gt;</td>
</tr>
<tr>
<td>41</td>
<td>ARC THROUGH &lt;c&gt; TO &lt;p&gt;</td>
</tr>
<tr>
<td>14</td>
<td>ARC THROUGH &lt;p&gt; TO &lt;c&gt;</td>
</tr>
<tr>
<td>44</td>
<td>ARC THROUGH &lt;p&gt; TO &lt;p&gt;</td>
</tr>
<tr>
<td>77</td>
<td>CENTER &lt;c&gt; RADIUS &lt;c&gt;</td>
</tr>
<tr>
<td>76</td>
<td>CENTER &lt;c&gt; RADIUS &lt;p&gt;</td>
</tr>
<tr>
<td>7A</td>
<td>CENTER &lt;c&gt; RADIUS radius</td>
</tr>
<tr>
<td>66</td>
<td>CENTER &lt;p&gt; RADIUS &lt;c&gt;</td>
</tr>
<tr>
<td>67</td>
<td>CENTER &lt;p&gt; RADIUS &lt;p&gt;</td>
</tr>
<tr>
<td>6A</td>
<td>CENTER &lt;p&gt; RADIUS radius</td>
</tr>
<tr>
<td>52</td>
<td>INTERSECT &lt;l&gt; &lt;l&gt;</td>
</tr>
<tr>
<td>51</td>
<td>INTERSECT &lt;l&gt; &lt;l&gt; KEEP 1st</td>
</tr>
<tr>
<td>BBB</td>
<td>BLEND &lt;l&gt; &lt;l&gt; THROUGH &lt;c&gt;</td>
</tr>
<tr>
<td>BB1</td>
<td>BLEND &lt;l&gt; &lt;l&gt; THROUGH &lt;p&gt;</td>
</tr>
<tr>
<td>BBA</td>
<td>BLEND &lt;l&gt; &lt;l&gt; RADIUS radius</td>
</tr>
<tr>
<td>D</td>
<td>DELETE &lt;l&gt;</td>
</tr>
<tr>
<td>E</td>
<td>UNDO</td>
</tr>
<tr>
<td>F</td>
<td>REDO</td>
</tr>
<tr>
<td>CD</td>
<td>REPLOT - SCALE TO FIT</td>
</tr>
<tr>
<td>CC</td>
<td>REPLOT - CURRENT SCALE</td>
</tr>
<tr>
<td>CA</td>
<td>ZOOM BACK</td>
</tr>
<tr>
<td>CF</td>
<td>ZOOM WINDOW &lt;c&gt; &lt;c&gt;</td>
</tr>
</tbody>
</table>

All of these commands are mapped in the Command Map tab of the digitizer's property page in Defaults.
To set a key sequence, select the command you wish to assign to the key, and then type the key sequence to use it with in the **Cursor Key Sequence** field.

The sequence must be comprised of the characters 0–9 A–F. It may be up to six characters long.

A key sequence must be unique and may not mask another command. For example, if you wish to use the Key Sequence 2 for a command, no other Key Sequence may start with 2. This is because 2 by itself matches a command, and therefore masks a key sequence like 21.

The exception to this is when two commands differ only in what is selected — a coordinate, a point, or a line. In this case the commands may share a command sequence. If this is used, the command will snap to a point if one is within snap distance, or to a coordinate if one is not.

While editing this property page, you may temporarily have conflicts as described above. This is so you can easily change Key Sequences, or swap them to different commands. However, you will be warned about them as they are created. You may not exit the property page without resolving such conflicts.

Some commands that are not turned on by default might be very useful for your work — for example, gasket makers may want to turn on the Center tools to make circle creation easier.

**Configuring the menu**

You can define areas on the digitizer that act as buttons that when clicked perform any of the digitizing commands. A **Menu** is a group of such Menu Item Areas. A Menu Item Area is
defined by the X and Y values adjacent to each area and the width and height of each area. These areas are best defined in Quadrant I (+X, +Y) with the origin of the digitizer in the bottom left corner.

The Menu Item Area values for the above menu are shown in the following table.

<table>
<thead>
<tr>
<th>Menu Item Area</th>
<th>X</th>
<th>Y</th>
<th>Width</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>DELETE &lt;&gt;</td>
<td>1/4</td>
<td>1/4</td>
<td>1</td>
<td>1/2</td>
</tr>
<tr>
<td>UNDO</td>
<td>1/4</td>
<td>1+1/4</td>
<td>1</td>
<td>1/2</td>
</tr>
<tr>
<td>BLEND radius</td>
<td>2+1/4</td>
<td>1/4</td>
<td>1</td>
<td>1/2</td>
</tr>
<tr>
<td>CTR. &lt;p&gt; RAD. radius</td>
<td>2+1/4</td>
<td>1+1/4</td>
<td>1</td>
<td>1/2</td>
</tr>
<tr>
<td>ZOOM</td>
<td>4+1/4</td>
<td>1/4</td>
<td>1</td>
<td>1/2</td>
</tr>
<tr>
<td>PLOT</td>
<td>4+1/4</td>
<td>1+1/4</td>
<td>1</td>
<td>1/2</td>
</tr>
</tbody>
</table>

Make sure that the Active checkbox is selected or the Menu Item Area will not be active.

Use ArtiosCAD's drafting features to draw the menu you have programmed. Print it out at full scale and tape it to the digitizer in the desired position. Then use the Place Menu button on the Command Map tab to place the menu.

Configuring Feedback and Snap

The Feedback/Snap tab of the digitizer's Properties dialog box lets you set the snap tolerance of the digitizer, the default radius, and the sounds heard when digitizing.
When digitizing a point to satisfy a snap point <p> or a snap line <l>, you need to be within the Snap Tolerance. If you are working on large corrugated designs, you may wish to set this value to something like a quarter-inch or five millimeters. Since the command indicates whether a snap point/line is expected, this value can be considerably larger than the normal screen snap value.

The Default radius field is used by some of the BLEND and CENTER commands. Set a sensible default; it is easily changed while digitizing.

The Feedback / Sounds group controls the audible feedback generated while digitizing. There are five types of feedback. Windows Sounds require a sound card in the computer; beeps can be made by most computers.

Table: Digitizing Feedback

<table>
<thead>
<tr>
<th>Type of feedback</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Received</td>
<td>Data received from the digitizer.</td>
</tr>
<tr>
<td></td>
<td>If your digitizer beeps when a puck button is pressed, you may wish to turn this off.</td>
</tr>
<tr>
<td>Command OK</td>
<td>The command was successful.</td>
</tr>
<tr>
<td>Snap Point/Line error</td>
<td>You were too far away for a snap point &lt;p&gt; or snap line &lt;l&gt; to be found.</td>
</tr>
<tr>
<td>Command not recognized</td>
<td>The key sequence does not match any of those defined.</td>
</tr>
<tr>
<td>Geometry Error</td>
<td>The command failed because the geometry could not be performed. (e.g. A blend would not fit.)</td>
</tr>
</tbody>
</table>
The fields in the **Windows Sounds** column designate which sound to use as defined in the Sounds control panel applet.

- When clicked, the triangle button plays a sample of the sound or beep.
- The ellipsis button lets you browse for a different sound file.

The frequency and the duration of the beeps can be set using the appropriate fields.
5. Other tasks

Uninstalling ArtiosCAD

Uninstall ArtiosCAD by using the Programs and Features applet in Control Panel. Select it in the list of programs and click Uninstall. You may be prompted that a reboot will be required to complete the uninstallation.

Removing individual ArtiosCAD Programs

To remove individual parts of ArtiosCAD such as the ArtiosCAD 3D Data Exchange feature, perform a Modify and de-select the ArtiosCAD Programs to remove. After uninstallation there may be files from these components left behind in the ..\Esko\Artios and ..\Esko\Artios \ArtiosCADn.nn folders; these files may be safely deleted if desired after all ArtiosCAD versions are removed.

Uninstalling SolidWorks separately from ArtiosCAD

If you have purchased the SolidWorks option and need to remove the SolidWorks Original Equipment Manufacturer software without uninstalling ArtiosCAD, run \ArtiosCAD \SolidWorksRemove.bat on disk 1 of the ArtiosCAD media. SolidWorks OEM software is normally removed when the version of ArtiosCAD that installed it is removed and no other versions of ArtiosCAD are using it. This is different from removing the SolidWorks Import/Export component of ArtiosCAD in that it actually deletes the SolidWorks software from the system, not just the portions of ArtiosCAD that interface with it.

Removing MSDE

Uninstall the ArtiosCAD MSDE database program files by using the Add/Remove Programs applet in Control Panel. Select Microsoft SQL Server Desktop Engine (ARTIOSCADDB) from the list of installed programs and click Remove.

Uninstalling the database software does not remove the database data files stored in ..\Esko \Artios\DataCenter\MSDE. This is intentional in case you want to resume using MSDE. If you will
not be using MSDE again, you may delete the ..\Esko\Artios\DataCenter\MSDE folder and its contents.

Removing the ArtiosCAD ODBC entry

Once all versions of ArtiosCAD are removed, open the ODBC/Data Sources applet in Control Panel > Administrative Tools, click the System DSN tab, and remove the ArtiosCAD datasource entry by selecting ArtiosCAD and clicking Remove.

You must remove the existing ArtiosCAD ODBC entry after uninstalling all versions of ArtiosCAD if you wish to change ArtiosCAD database types in a subsequent installation.

Uninstalling a patch

To uninstall a patch, remove that particular build through Programs and Features in Control Panel.

ArtiosCAD will revert to the build that was present before the patch was loaded.

Modifying and Repairing ArtiosCAD

You can modify or repair the ArtiosCAD installation by clicking Change in the Add/Remove Programs applet in Control Panel, and then by choosing Modify or Repair. You must use the original ArtiosCAD media, or use the same network location, as when you first installed the software.

Modify allows you to change the installed features and options as if you were performing an Advanced installation.

Repair looks for missing or corrupt files and replaces them as necessary. It will not overwrite Defaults. You will be given the same License Disk options as when you first installed the software. If you are trying to repair the licensing information choose Yes, I have licensing information to apply and use the licensing diskette, otherwise choose License information already applied or unavailable to keep your current licensing information.

Loading an ArtiosCAD patch

ArtiosCAD patches are installed using a single executable file. To install a patch, do the following:

1. Log on as Administrator, or as a user with local administrative privileges.
2. Using Windows Explorer, double-click the patch file. Patch files are named ArtiosCAD<version and build number>.exe, such as ArtiosCAD7.1Build497.exe.
3. In the Welcome dialog box, click Update >.
4. A status bar will appear showing the progress of the patch installation.
5. Click **Finish** in the InstallShield Wizard Completed dialog box. The patched version of ArtiosCAD is now ready for use.

6. Log off the system.

### Working with the ArtiosIO Status program

The **ArtiosIO Status** program is on the Start menu in the ArtiosCAD folder. It queries the ArtiosIO program on a given machine and displays the active connections to that machine. Using it, you can close a connection that is no longer responding.

To view the connections on a machine, click **Query Server** and either enter the name of the system to query, or click the drop-down list button to view a list of available machines on the network. Only machines in the same domain will be shown.

To close a connection, highlight it and click **Close Connection**.

### Using Floating Licenses

Floating licenses allow ArtiosCAD users to share software licenses among computers. Each license is accessed on an as-needed basis.

ArtiosCAD allocates licenses based on the active tools and toolbars. Tools and toolbars for which licenses are unavailable will either be unavailable or a dialog box similar to the one shown below will appear. The dialog box lists which users and systems have allocated the licenses you need. You can either go ask someone to give up the license you need and click **Wait for License**, or you can click **Cancel** and return to the previous tool you were using.
Release licenses by exiting the design, manufacturing file, or 3D workspace which took the license.

If you click **Wait for License**, a dialog box showing the needed license appears:

When a license becomes available, this dialog box disappears and the desired feature is activated.

### Configuring floating licenses

The **Floating License Configuration** program in the **Esko > ArtiosCAD** program group on the ArtiosCAD License server lets you allocate floating licenses. You can reserve or deny licenses to certain systems. When started, the program initially appears similar to the following dialog box (but with your specific licenses listed):
Double-click a license to configure it. A dialog box will appear in which you can reserve and deny licenses:

Reserving a license means that the system you specify will always have the license reserved for it. Denying a license means that the system you specify will never be able to have a license. To specify a system, click Add. Enter the short name of the system exactly as it is shown on the Computer Name tab of the System applet in Control Panel. The short name is the first word up to the period - the full name minus the domain name. For example, if the full name of the system is ArtCad1.plasticangelcontainers.com, the short name is ArtCad1. Make sure to match the case exactly, as it will not work otherwise. Once you have entered the name, click OK.
To remove a system from either the **Reserved** or **Denied** lists, select it, click **Remove**, and click **OK**.

When you have finished configuring the license as desired, click **OK** to return to the Floating License Configuration dialog box, or click **Cancel** to ignore the changes you made.

To exit the Floating License Configuration dialog box, click **License**, and then click **Exit**.

**Note:** If you have made changes to the configuration, the License Manager will be shut down and restarted when you exit the Floating License Configuration program. It takes the Elan License Manager **three minutes to restart after shutting down**.

**Troubleshooting**

If you have trouble using a desired feature and get a dialog box like the one below, use either the ArtiosLM applet in Control Panel or the ArtiosCAD License Management utility on the ArtiosCAD License server to make sure the server is running.
If the Floating License Utility does not start, it is because there are no floating licenses to configure.

**Upgrading ArtiosCAD Licenses**

ArtiosCAD licenses enable you to use the features you have bought and disable the features you have not bought. As your needs change, you may have to change your licenses accordingly.

When you upgrade a license, you usually receive a licensing file by e-mail. You then have to install that file properly as described in the following section.

You must log on to your system with administrative privileges to upgrade licenses.

**Note:** NO SYSTEM MAY HAVE INSTANCES OF WebCenter, ArtiosCAD, DataCenter Admin, OR SpecLink OPEN WHEN UPGRADING LICENSES!

**License Manager: keyless**

To upgrade a keyless license for the FlexNet license manager, do the following:

1. Save the licensing file sent to you by Esko in a place where you can access it from the machine whose license you will be upgrading, for example a network location, on a USB thumb drive, and so forth.
2. On the machine with the license to upgrade, log in as Administrator or as a user with administrative privileges.
3. Click Start > Programs/All Programs > Esko > ArtiosCAD > Activate Local Licenses/Activate Server Licenses.

4. In the Esko (Local or Server) License Manager dialog box, click Activate.

5. Click Next in the Activate License Wizard dialog box.

6. In the On-line activation or off-line activation dialog box, choose either On-line activation or Off-line activation as appropriate for your system and click Next.

7. In the Your product keys dialog box, choose I have a file containing one or more product keys and click Next.

8. In the File containing your product keys dialog box, browse for the file you saved in step 1 and click Next.

9. In the Esko ID dialog box, enter your Esko ID and password and click Next.

10. In the Activation completed successfully dialog box, the license(s) you activated should appear. Click Finish to complete the license upgrade.

11. Optionally, click Save Licenses Report to save a report of the license upgrade for your records.

12. Close the license manager dialog box by clicking the X in the upper right corner and test the new license as desired.

DataCenter database administration when using MSDE or SQL Server Express Edition

All database products require some amount of administration regardless of vendor. Failure to perform this administration will ultimately lead to a loss of some or all of your DataCenter data.

If you have any questions on these tasks, contact Support.

Use DataCenter Admin to backup and restore the MSDE or SQL Server Express Edition 2005 database.

**Note:** These instructions do not apply to Microsoft SQL Server Express 2008, 2012, or later database engines. Use the Microsoft SQL Server Management Studio tools to manage those database engines.

Backing up the database

The database backup procedure stops the database service, copies the database files to \Esko\Artios\DataCenter\MSDE\MSSQL\$ARTIOSCADDB\Data\backup for MSDE or \Esko\Artios\DataCenter\SQL2005Express\MSSQL.1\MSSQL\Data\backup for SQL Server Express Edition 2005, and C:\Program Files\Microsoft SQL Server\MSSQL11.ESKO\MSSQL for 2012 and then restarts the service. You must then copy that folder to backup media, or include it in your backup program, to fully backup the database.

To backup the MSDE database, do the following:
1. Ensure that any programs using the database are not running.
2. Log on to the database server as Administrator or as a member of the Administrators group.
3. Start DataCenter Admin by clicking Start > Programs > (Esko) > ArtiosCAD > DataCenter Admin, or by using the icon on the desktop.
4. Click File > Backup database.
5. In the Login as the Database Administrator dialog box, enter the name and password of the database administrator and click OK. The defaults are sa and a blank password for MSDE and sa and whatever password you chose at installation for SQL Server Express Edition. Click OK when done.
6. The Status bar indicates the current operation. When the Status bar is clear, the backup is complete.

**Restoring the database**

The database restore procedure stops the database service, replaces the data in the database with data from the backed-up database files from \Esko\Artios\DataCenter\MSDE\MSSQL $ARTIOSCADDB\Data\backup for MSDE and \Esko\Artios\DataCenter\SQL2005Express \MSSQL.1\MSSQL\Data\backup for SQL Server Express Edition, and then restarts the database service.

To restore the database, do the following:
1. Ensure that any programs using the database are not running.
2. Log on to the database server as Administrator or as a member of the Administrators group.
3. Start DataCenter Admin by clicking Start > Programs > (Esko) > ArtiosCAD > DataCenter Admin, or by using the icon on the desktop.
4. Click File > Restore database.
5. In the Login as the Database Administrator dialog box, enter the name and password of the database administrator and click OK. The defaults are sa and a blank password for MSDE and sa and the password you chose at installation for SQL Server Express Edition. Click OK when done.
6. The Status bar indicates the current operation. When the Status bar is clear, the restore is complete.

**Database space management for MSDE**

The MSDE database files automatically expand to accommodate new data. After a few months, to compact the database, do the following:
1. Make sure no programs which use the database are active. This includes ArtiosCAD, SpecLink, DataCenter Admin, and any products using CAD-X.
2. Log on to the database server as Administrator or as a member of the Administrators group.
3. Start a command prompt, and change directories to C:\Program Files\Microsoft SQL Server \80\Tools\Binn.
4. Type osql -Usa -P"" -Sdatabase_server_name\ArtiosCADdb and press enter.
5. At the 1> prompt, type use ArtiosCADdb and press enter.
6. At the 2> prompt, type go and press enter.
7. At the 1> prompt, type dbcc shrinkfile (acaddata) and press enter.
8. At the 2> prompt, type go and press enter.
9. At the 1> prompt, type dbcc shrinkfile (acalog) and press enter.
10. At the 2> prompt, type go and press enter.
11. At the 1> prompt, type exit and press enter.

Your screen should look similar to the one shown below.

MSDE-related Application Log entries in Event Viewer

On the database server, the MSSQL$ARTIOSCADDB service writes warning entries of category (8) to the Application Log in Event Viewer. They are about connecting to Active Directory and can be ignored.

Using Microsoft SQL Server 2005

Microsoft SQL Server 2005 is a large, robust database which can require complex administration. The installation documentation provided below is provided as a convenience.
only for initial installation. A dedicated Database Administrator (DBA) is required to administer and maintain the database, and is free to choose options other than those documented to meet local site requirements.

Make sure to load ArtiosCAD specifying **Microsoft SQL Server or Oracle** as the database type before installing Microsoft SQL Server 2005.

After installing ArtiosCAD, the steps to using Microsoft SQL Server 2005 with a new installation of ArtiosCAD are installing Microsoft SQL Server 2005, configuring Microsoft SQL Server 2005, configuring the ODBC driver, and running the database configuration batch file for ArtiosCAD.

Once all that is done, you can configure servers and resources in DataCenter Admin and start using ArtiosCAD.

## Installing Microsoft SQL Server 2005

**Note:**

**Before you begin, find out from your IT department what the password policy is, as you will need to know it to set the database user passwords.**

Perform the following steps to install Microsoft SQL Server 2005 for the first time to use with ArtiosCAD.

1. Make sure the computer which you intend to make the database server meets Esko’s recommended hardware specifications.
2. Log on as **Administrator** or as a user with administrative privileges.
3. Put the Microsoft SQL Server 2005 media into the media drive. It should automatically start. If it does not, navigate to its root directory using Windows Explorer and double-click Autoplay.exe.
4. In the dialog box that appears, read the license agreement. If you agree with it, select *Yes, I accept the licensing terms and conditions* and then click Next to continue the installation.
5. In the Installing Prerequisites dialog box, click **Install**. A progress bar shows the progress of the task.
6. Click **Next** when the prerequisite components are installed.
7. In the Welcome to the Microsoft SQL Server Installation Wizard dialog box, click **Next**.
8. The installation wizard will perform a system configuration check and install any needed components. Click **Next** when it finishes.
9. The Installation Wizard will continue and the Registration Information dialog box will appear. Enter your name, company, and Product Key as appropriate. Click **Next** when done.
10. In the Components to Install dialog box, click **Advanced**.
11. In the Feature Selection dialog box, click the box next to Database Services and click **Entire feature will be installed on the hard drive.**

12. Still in the Feature Selection dialog box, expand the Client Components catalog, click the box next to Connectivity Components, and click **Entire feature will be installed on the hard drive.** Do the same for Management Tools and click **Next.**
13. In the Instance Name dialog box, click **Named instance** and enter a sensible name in the field. You will need to know this instance name later, so referencing ArtiosCAD would be prudent.
14. In the Service Account dialog box, click **Use the built-in System account** and change the drop-down list box entry to **Network service**. Click **Next**.
15. In the Authentication Mode dialog box, click **Mixed Mode**, and enter a password of your own choosing that complies with your local password policy in both password fields. Click **Next** after entering both passwords. Make sure to record this password in a secure location as you will need it later.

16. In the Error and Usage Report Settings dialog box, leave both checkboxes clear and click **Next**.
17. In the Ready to Install dialog box, click **Install** to begin the installation.
18. The Setup Progress dialog box shows the status of the installation. Click **Next** when the tasks have completed.

![Microsoft SQL Server 2005 Setup Progress](image)

19. In the Completing Microsoft SQL Server 2005 Setup dialog box, click **Surface Area Configuration tool**.
20. In the Minimize SQL Server 2005 Surface Area dialog box, click **Surface Area Connection for Services and Connections**.

21. In the resulting dialog box, click **Remote Connections** under Database Engine, click **Local and remote connections**, and click **Using TCP/IP only**. Click **Apply** when done.
22. In the Connection Settings Change Alert dialog box, click **OK**.

23. Click **Service** under Database Engine.

24. Click **Stop**, then **Start** to restart the database engine service.

25. Click **OK** to exit the Surface Area Configuration for Services and Connections dialog box.


27. In the Microsoft SQL Server 2005 Setup dialog box, click **Finish**. Reboot the system if prompted to do so. Do not postpone this reboot.

**Note:** At this point, apply the latest Microsoft SQL Server 2005 service packs and patches available from the Microsoft web site at http://www.microsoft.com/sql/default.mspx.

### Configuring Microsoft SQL Server 2005

Once you have updated and patched Microsoft SQL Server 2005 appropriately, continue as follows. You may have to start the database by hand by right-clicking the SQL Server icon in the system tray and selecting **MSSQLServer - Start**.
Creating the ArtiosCADdb database

1. If you rebooted the machine, log in as a user with administrative privileges.
2. Click Start > Programs > Microsoft SQL Server 2005 > SQL Server Management Studio.
3. In the Connect to Server dialog box, ensure that the Server name: field is set to the instance created in the previous procedure, change the Authentication type: drop-down list box to SQL Server Authentication, and enter sa for the username and the password you specified during installation. Click Connect.

4. Right-click Databases and click New Database on the context menu.

5. In the New Database dialog box, in the Database Name: field, enter ArtiosCADdb. Do not click OK.
6. Click the 3 in the Initial size (MB) column and change it to 10. Do not click OK.
7. If this is a normal computer with one hard drive and two hard drive controllers, click **OK**.

If this is a high-end database server and has multiple hard drives and multiple controllers, use the scroll bar to scroll to the right, click the Browse (…) button for the ArtiosCADdb Log file, and locate the transaction log on a separate disk on a separate controller. This will minimize data loss when a hard drive crashes. Click **OK** when done.

The ArtiosCADdb database should appear in the group of databases as shown below.

The database is now created and the next step is configuring the ODBC driver.

**Configuring the ODBC driver**

Microsoft SQL Server 2005 requires the ODBC driver provided by MDAC 2.8 or later. It is installed on the server when you install the database, and on client systems by ArtiosCAD when it is loaded.

If the system will not have ArtiosCAD on it, load MDAC 2.8 on it by selecting the Connectivity Components element of the Client Components catalog when running the Microsoft SQL Server 2005 setup program.
To configure the ODBC driver on both the server and on clients, do the following:

1. You should still be logged in as Administrator or as a member of the Administrators group. If not, log in as such.
2. Open the Data Sources (ODBC) applet in Control Panel. Depending on the operating system, it may be in Administrative Tools.
3. Click the System DSN tab, and then click Add.
4. Select SQL Server from the list of available drivers and click Finish.

5. In the Create a New Data Source to SQL Server dialog box, enter ArtiosCAD in the Name: field and select the server and instance name in the Server: drop-down list box. If this is a client, specify the name of the database server. Click Next.
6. When asked about authenticity, select the **With SQL Server authentication**... choice. In that same dialog box, deselect the **Connect to SQL Server** ... checkbox. Do not click **Next**.

7. Click **Client Configuration**. The Add Network Library Configuration dialog box appears.

Make sure **TCP/IP** is selected in the **Network libraries** group and ensure the server name is correct. If **(local)** was selected in the **Which SQL Server do you want to connect to?** field in Step 5, only a period (.) appears in the **Server alias** field and **Server name** field.

Ensure that **Dynamically determine port** is checked and that the **Port number** is set to 1433. Click **OK**.

Click **Next** in the Create a New Data Source to SQL Server dialog box.

8. In the next dialog box, leave the **Create temporary stored procedures**... and **Use ANSI**... choices selected and click **Next**.
9. In the next dialog box, leave **Perform translation for character data** selected. If the system is using non-U.S. locale settings, check the **Change the language of SQL Server system messages to:** checkbox and set the value to **English.**

Click **Finish.**

10. The ODBC Microsoft SQL Server Setup dialog box will appear showing a summary of the configuration. Click **OK.** Do not test the configuration; it will fail because the proper database user is not configured because the database configuration batch file has not yet been run.
11. Click **OK** in the ODBC Microsoft SQL Server Setup dialog box.
12. Click **OK** in the ODBC Data Source Administrator dialog box.

The ODBC connection on the server is now configured properly. The next step is running the database configuration batch file.

**Running the ArtiosCAD database configuration batch file**

Make sure the ODBC connection to the ArtiosCAD database is configured as described in the previous section before running the batch file.

**Note:**

You will most likely need to edit the batch file to supply the programmer user’s password before you run it.

To run the ArtiosCAD database scripts, do the following:

1. You should still be logged in as **Administrator** or as a member of the Administrators group. If not, log in as such.
2. Start a command prompt and change the directory to `\Esko\Artios\DataCenter`.
3. Build the database schema. The schema build command is in the form

   `Build_MSSQLServerSchema "<sa_user_Password>" "<instance name>" "<DataCenter root directory>" "<DataCenter program language directory>"`.

   The command should be similar to the one shown below, substituting your installation information and language as needed.

   ```
   Build_MSSQLServerSchema "SysP433w0rd**" "MBCCADSERVER\SQL2K5_ArtiosCAD" "C:\Esko\Artios\datacenter" "C:\Esko\Artios\datacenter\program\english"
   ```
When you have typed the command, press enter. Comments and commands will appear in the command prompt similar to example shown below.

```
C:\Artios\datacenter>rem *** Build the ArtiosCAD schema
C:\Artios\datacenter>osql -Usa -P"" -S"LUDDAHA\ArtiosCADdb" -i "C:\artios\datacenter\msde_createdb.sql -o "C:\artios\datacenter\msde_createdb.log
C:\Artios\datacenter>osql -Usa -P"" -S"LUDDAHA\ArtiosCADdb" -i "C:\artios\datacenter\mssqlserver.sql -o "C:\artios\datacenter\mssqlserver.log
C:\Artios\datacenter>osql -Usa -P"" -S"LUDDAHA\ArtiosCADdb" -i "C:\artios\datacenter\mssqlserver_security.sql -o "C:\artios\datacenter\mssqlserver_security.log
C:\Artios\datacenter>rem *** Build the ArtiosCAD Version 7 schema
C:\Artios\datacenter>osql -Usa -P"" -S"LUDDAHA\ArtiosCADdb" -i "C:\artios\datacenter\mssqlserver_7.sql -o "C:\artios\datacenter\mssqlserver_7.log
C:\Artios\datacenter>rem *** Build keys
C:\Artios\datacenter>"C:\artios\datacenter\program\BuildKeys.exe
C:\Artios\datacenter>rem *** Build hierarchical boards
C:\Artios\datacenter>set bLoadBoardTree=1
```

4. When the command prompt returns, type `exit` and press enter.

The database is now ready for use with ArtiosCAD and DataCenter Admin. Add servers and resources as described in the Working with servers and resources section of the DataCenter chapter of the ArtiosCAD User Guide.

**Notes and troubleshooting**

Microsoft Data Access Components (MDAC) version 2.8 or higher must be used with Microsoft SQL Server 2005.

The following notes deal with using SQL Server Management Studio in the Microsoft SQL Server folder on the Start menu.

- If error messages appear about not being associated with a trusted SQL Server connection, right-click the server instance name, and then click Properties > Security. Make sure SQL Server and Windows Authentication mode is selected in the Server authentication group.
- If many script errors appear, make sure the Implicit transactions checkbox is clear on the Properties > Connections page in the Default connection options list.
- If error messages appear about the programmer user not existing or not having permission, do the following:
  - Expand the database instance in the left pane so the Security folder is open and double-click Logins.
• Right-click Programmer and click Properties.

• On the General page, there should be a password set in the Password: field, the Default database: should be set to ArtiosCADdb, and the Default language: should be set to English. If this is not so, click the Server Roles page and ensure that public is checked.

If you are using SQL Server Express Edition and you need to run the database script batch file, use Build_ExpressSchema.bat with the same syntax as Build_MSSQLServerSchema.bat.

Using Microsoft SQL Server 2012

Microsoft SQL Server 2012 is a large, robust database which can require complex administration. The installation documentation provided below is provided as a convenience only for initial installation. A dedicated Database Administrator (DBA) is required to administer and maintain the database, and is free to choose options other than those documented to meet local site requirements.

Make sure to load ArtiosCAD specifying Microsoft SQL Server or Oracle as the database type before installing Microsoft SQL Server 2012.

After installing ArtiosCAD, the steps to using Microsoft SQL Server 2012 with a new installation of ArtiosCAD are installing Microsoft SQL Server 2012, configuring Microsoft SQL Server 2012, configuring the ODBC driver, and running the database configuration batch file for ArtiosCAD.

Once all that is done, you can configure servers and resources in DataCenter Admin and start using ArtiosCAD.

Note:

Before you begin, find out from your IT department what the password policy is, as you will need to know it to set the database user passwords.

Installing Microsoft SQL Server 2012

This procedure describes how to install Microsoft SQL Server 2012 Standard Edition for use with ArtiosCAD. You should only use this version if you have a dedicated database administrator available.

1. Log in to your database server as an administrator.
2. Run the setup program on the Microsoft SQL Server media.
3. On the left side of the SQL Server Installation Center dialog box, click Installation.
4. Click **New SQL Server stand-alone installation or add features to an existing installation**.

5. In the Setup Support Rules dialog box, click **Details**, make sure all the items passed, and click **OK**.
6. In the Product Key dialog box, enter the product key and click **Next**.
7. In the License Terms dialog box, check **I accept the license terms** and click **Next**.

8. The Install Setup Files dialog box will show an action list and progress bar.
9. In the Setup Role dialog box, click **SQL Server Feature Installation** and click **Next**.
10. In the Feature Selection dialog box, check the checkboxes for the following features. You may have to scroll down to see all the items in the list. You may also change the installation directories. Click **Next** when you are done selecting features.

In the Instance Features group, select the following features:

- Database Engine Services
- SQL Server Replication
- Full-Text and Semantic Extractions for Search
- Data Quality Services

In the Shared Features group, select the following features:

- SQL Server Data Tools
- Client Tools Connectivity
- Client Tools Backward Compatibility
- Client Tools SDK
- Documentation Components
- Management Tools - Basic
- Management Tools - Complete
- Distributed Replay Controller
- Distributed Replay Client
- SQL Client Connectivity SDK
11. In the Installation Rules dialog box, click **View details** and ensure all the rules passed. Click **Next**.

![Installation Rules dialog box](image)

12. In the Instance Configurations dialog box, click **Named instance** and enter a sensible name for the instance. Make a note of the Instance ID as you will need it for the database scripts batch file later. Click **Next**.
13. In the Disk Space Requirements dialog box, verify that the selected locations have enough room available and click **Next**.
14. In the Server Configuration dialog box on the Service Accounts tab, review the service startup types and change them if desired.
On the Collation tab, if you do not want to use the default collation (a group of location-related settings), click **Customize** and change it. Make sure to choose one that is case-insensitive and accent-sensitive. In most cases, the default collation should be sufficient; only change it if you know in advance you should.
15. In the Database Engine Configuration dialog box, click Mixed Mode (SQL Server authentication and Windows authentication). For the password, enter a password of your own choosing that complies with your local password policy in both password fields. Make sure to record this password in a secure location as you will need it later. In the Specify SQL Server administrators group, click Add Current User to add yourself as a database administrator, or click Add to add other users or groups as database administrators. You must add at least one account. Click Next.
16. Click **Next** in the Distributed Replay Controller, Distributed Replay Client, and Error Reporting dialog boxes.

17. In the Installation Configuration Rules dialog box, click **View details** and ensure all the rules passed. Click **Next**.
18. In the Ready to Install dialog box, scroll down the list of actions and verify them for accuracy. Click **Install** to begin installing the software. A progress bar will appear.
19. In the Complete dialog box, review the list of features to make sure they succeeded. Click Close.
20. Close the SQL Server Installation Center.

21. Go to Windows Update, install Microsoft Update if it is not already installed, and then use it to install updates for Microsoft SQL Server 2012 and related programs.

Microsoft SQL Server 2012 is now installed and ready for you to configure it for use with ArtiosCAD.

**Configuring Microsoft SQL Server 2012**

Once you have updated and patched Microsoft SQL Server 2012 appropriately, continue as follows.

**Creating the ArtiosCADdb database**

If you rebooted the machine, log in as a user with administrative privileges.

1. Click **Start > All Programs > Microsoft SQL Server 2012 > SQL Server Management Studio**.

2. In the Connect to Server dialog box, make sure the Server type is set to Database Engine and the Server name is set to the instance you specified. Change the Authentication to **SQL Server Authentication**, enter sa as the Login, and enter the password you chose for the sa user for the Password. Click **Connect**.
3. Right-click **Databases** and click **New Database**.

4. In the New Database dialog box, for the Database Name, enter ArtiosCADdb. Do not click **OK**.
5. Click the 4 in the **Initial size (MB)** column and change it to 10. Do not click **OK**.
6. If this is a normal computer with one hard drive and two hard drive controllers, click **OK**. If this is a high-end database server and has multiple hard drives and multiple controllers, use the scroll bar to scroll to the right, click the Browse (…) button for the ArtiosCADdb Log file, and locate the transaction log on a separate disk on a separate controller. This will minimize data loss when a hard drive crashes. Click **OK** when done.

The ArtiosCADdb database should appear in the group of databases as shown below.
The database is now created and the next step is configuring the ODBC driver.

Configuring the 32-bit ODBC driver

As ArtiosCAD is a 32-bit application, it must use a 32-bit connection to a database. If you have installed ArtiosCAD on the database server, the installation process creates a shortcut to the 32-bit ODBC configuration application in Administrative Tools.

1. Log in as Administrator or as a user with administrative privileges.

2. If you have installed ArtiosCAD on this computer, click Start > Control Panel > System and Security > Administrative Tools > Data Sources 32 bit (ODBC). If you have not installed ArtiosCAD, start Windows Explorer, navigate to C:\Windows\SysWOW64, and double-click odbcad32.exe.

3. In the ODBC Data Source Administrator, click System DSN and click Add.
4. Select **SQL Server** from the list of available drivers and click **Finish**.
5. In the Create a New Data Source to SQL Server dialog box, enter ArtiosCAD in the Name and Description fields and select the server and instance name in the Server drop-down list box. If this is a client, specify the name of the database server. Click Next.

![Create a New Data Source to SQL Server dialog box](image)

6. When asked about authenticity, select the With SQL Server authentication... choice. In that same dialog box, deselect the Connect to SQL Server ... checkbox. Do not click Next.
7. Click **Client Configuration**. The Add Network Library Configuration dialog box appears.

![Add Network Library Configuration dialog box](image)

a) Make sure **TCP/IP** is selected in the Network libraries group and ensure the server name is correct. If **(local)** was selected in the Which SQL Server do you want to connect to? field in Step 5, only a period (.) appears in the Server alias field and Server name field.

b) Ensure that **Dynamically determine port** is checked and that the **Port number** is set to 1433. Click **OK**.
c) Click **Next** in the Create a New Data Source to SQL Server dialog box.

8. In the next dialog box, leave the **Create temporary stored procedures**... and **Use ANSI**... choices selected and click **Next**.

9. In the next dialog box, leave **Perform translation for character data** selected. If the system is using non-U.S. locale settings, check the **Change the language of SQL Server system messages to:** checkbox and set the value to **English**. Click **Finish**.
The ODBC Microsoft SQL Server Setup dialog box will appear showing a summary of the configuration. Do not test the configuration; it will fail because the proper database user is not configured because the database configuration batch file has not yet been run. Click **OK**.
11. Click **OK** in the ODBC Data Source Administrator dialog box.

The ODBC connection on the server is now configured properly. The next step is running the database configuration batch file.

Running the ArtiosCAD database configuration batch file

Make sure the ODBC connection to the ArtiosCAD database is configured as described in the previous section before running the batch file.

**Note:**
You will most likely need to edit the batch file to supply the programmer user’s password before you run it.

To run the ArtiosCAD database scripts, do the following:

1. You should still be logged in as **Administrator** or as a member of the Administrators group. If not, log in as such.

2. Start a command prompt and change the directory to `\Esko\Artios\DataCenter`. If you do not have ArtiosCAD installed on the database server, copy the entire DataCenter directory and subdirectories from a system with ArtiosCAD on it to a local temporary folder to which you have write access.

3. Build the database schema. The schema build command is in the form `Build_MSSQLServerSchema "<sa_user_Password>" <server name>\<instance name>" "<DataCenter root directory>" "<DataCenter program language directory>"`. The command
should be similar to the one shown below, substituting your installation information and language as needed.

```
Build_MSSQLServerSchema "SysP433w0rd**" "LUDAAHA05\ArtiosCADdb" "C:\Esko\Artios\datacenter" "C:\Esko\Artios\datacenter\program\english"
```

When you have typed the command, press Enter. Comments and commands will appear in the command prompt similar to example shown below.

4. When the command prompt returns, type exit and press Enter.

The database is now ready for use with ArtiosCAD and DataCenter Admin. Add servers and resources as described in the Working with servers and resources section of the DataCenter chapter of the ArtiosCAD User Guide.

Notes and troubleshooting

The following notes deal with using SQL Server Management Studio in the Microsoft SQL Server folder on the Start menu.

- If error messages appear about not being associated with a trusted SQL Server connection, right-click the server instance name, and then click Properties > Security. Make sure SQL Server and Windows Authentication mode is selected in the Server authentication group.

- If many script errors appear, make sure the Implicit transactions checkbox is clear on the Properties > Connections page in the Default connection options list.

- If error messages appear about the programmer user not existing or not having permission, do the following:
  - Expand the database instance in the left pane so the Security folder is open and double-click Logins.
  - Right-click programmer and click Properties.
On the General page, there should be a password set in the Password field, the Default database should be set to ArtiosCADdb, and the Default language should be set to English. If this is not so, click the Server Roles page and ensure that public is checked.

If you are using SQL Server Express Edition and you need to run the database script batch file, use Build_ExpressSchema.bat with the same syntax as Build_MSSQLServerSchema.bat.

Using Oracle

Instruction on installing Oracle is beyond the scope of this document. It should only be done by experienced database administrators. Here is a rough overview of the steps required:

• Install Oracle and create an instance. Within that instance create a database. Set up network access to it using Net Configuration Assistant to connect to that database.

• Install ArtiosCAD on the database server, making sure to do an Advanced installation and selecting Microsoft SQL Server 2000 or Oracle as the database choice.

• Set up an ODBC Data Source using the Microsoft ODBC for Oracle driver. Set the Data Source Name: to ArtiosCAD, the Description: to ArtiosCAD, and the Server: to TNS:Name_of_database_defined_in_Net_Configuration_Assistant that you configured when installing Oracle, such as TNS:orcl.

• Run the database configuration batch file to build the database schema.

Start a command prompt and change the directory to \Esko\Artios\DataCenter. The schema build command is in the form Build_OracleSchema "<sys Password>" "<TNS name>" "<DataCenter root directory>" "<DataCenter program language directory>". If the sys database user has no password, use a double set of quotation marks ("""). The final command you type at the command prompt should be similar to the one shown below, substituting your installation information and language as needed.

Build_OracleSchema "administrator" "orcl" "C:\Esko\Artios\datacenter" "C:\Esko\Artios \datacenter\program\english"

• Add servers and resources as described in the Working with servers and resources section of the DataCenter chapter of the ArtiosCAD User Guide.

Note: If WebCenter and your production installation of ArtiosCAD (not the one required for WebCenter’s Application server) are using the same database server with Oracle 9i, and you upgrade the version of Oracle on the database server, it may break the Microsoft ODBC for Oracle drivers required by ArtiosCAD. Please note that this is NOT a supported configuration and you alone are responsible for ensuring that it works. If you upgrade Oracle and start getting SQLSetConnectAttr errors, try changing two entries in the Registry on the database server. Specifically, in HKEY_LOCAL_MACHINE > Software > Microsoft > MsDTC > MTxOCI, change the OracleSqlLib key to orasq|9.dll and change the OracleXaLib key to oraclent9.dll.
Replacing an ArtiosCAD server

As time passes, you may need to replace an existing ArtiosCAD server with a newer, faster model. Listed below are the basic steps required to replace a machine acting as the Defaults server, Database server using MSDE, and License server using a security key. Contact Esko Support for more details.

1. Make a complete backup of the system that is being replaced and verify that the data is readable. Keep this backup in safe, easily-accessible place.
2. Install the same version of ArtiosCAD on the new server as is currently on the existing server. Make sure to specify the same licensing method.
3. For pre-16 versions of ArtiosCAD, copy the ..\Esko\Artios\ArtiosCADn.nn\ServerLib folder from the existing server to the new server. For version 16 or later, copy ..\Esko\Artios\ServerLib.
4. If your old server uses a security key, copy ..\Esko\Artios\ArtiosCADn.nn\Common\tuneopt.txt and/or tuneopt7.txt on the old server to the corresponding directory on the new server.
5. Move the security key to the new server.
6. If your old server uses a license manager, deactivate the license and copy the deactivation files to the new server. Activate the license on the new server.
7. Start ArtiosCAD on the new server and click Options > Defaults.
8. Go through the various entries and adjust them as necessary, specifically the entries for Output devices and other things which may contain system names or paths.
9. An exact image copy of the database from the old server will be made on the new server. Therefore, put the user files (if any) in the same location in the file system on the new machine as on the old machine.
10. On the old system, detach the database using the following procedure:
    - Log in as a member of the Administrators group.
    - Start a command prompt.
    - At the prompt, type osql -Usa -P"" -S systemname\ArtiosCADdb and press Enter. (If the sa password is not blank, insert it between the quotation marks in the -P switch.)
    - At the 1> prompt, type sp_detach_db ‘ArtiosCADdb’ and press Enter.
    - At the 2> prompt, type go and press Enter.
    - At the 1> prompt, type quit and press Enter.
    - Type exit and press Enter to close the command prompt.
11. On the new server, do the same thing to detach the empty, just-installed MSDE database:
    - Log in as a member of the Administrators group.
    - Start a command prompt.
12. At the prompt, type `osql -Usa -P"" -Ssystemname\ArtiosCADdb` and press enter. (If the sa password is not blank, insert it between the quotation marks in the -P switch.)

13. At the 1> prompt, type `sp_detach_db 'ArtiosCADdb'` and press enter.

14. At the 2> prompt, type `go` and press enter.

15. Do not close this program as it is needed for a future step.

12. Copy the database files from the old server to the new server. They are in the `\Esko\Artios\DataCenter\MSDE\MSSQL$ARTIOSCADDB\Data` directory. Copy `ArtiosCADdb_data.mdf` and `ArtiosCADdb_log.ldf` to the corresponding directory on the new server. If prompted to overwrite existing files, say yes.

13. On the new server, attach the new database files to the instance:

14. Reconnect the programmer database login to the database instance:

15. In DataCenter Admin, go through the entries for servers and resources and adjust them as necessary.

16. If the old server used ArtiosIO, configure and start it on the new server.

17. On each client, use Programs and Features in Control Panel to Change and then Modify the installation of ArtiosCAD. Specify the name of the server as appropriate.

ArtiosCAD should now be fully functional on the new server and any clients.
6. Defaults

Introduction to Defaults

Defaults store all the configuration information used by ArtiosCAD. This is where you change options, add custom standards to the Standards Catalog, define Outputs, and so forth. You access defaults by clicking Defaults on the Options menu. There are many options in Defaults that are not covered in this chapter; you should open each Defaults catalog or folder and review its contents.

There are two types of defaults: **Shared defaults** and **User defaults**. Shared defaults are shared by all users served by the same ArtiosCAD server. User defaults affect only the machine being used.
Creating defaults

There are three ways to create new defaults:

1. In the Shared defaults pane, open the folder containing the Defaults you want to add to and right-click. Clicking **Folder** adds a new folder; clicking **Data** adds a new default setting.

2. In the User defaults pane, make sure nothing is selected, and right-click. Choose the type of default to add from the pop-up context menu. When naming the new item, do not use a backslash (\).

3. Drag a pre-existing default from one pane into the other and modify as desired.

Changing defaults

To change a default, open the folder it is in and double-click it. A dialog box will appear showing all the settings you can change.

If you want to change all the defaults in a folder at once, double-click the folder instead of an individual item, and a tabbed dialog box will appear containing all the individual items.

Saving defaults

It is very important to save the defaults after you make changes. The option button above the two panes indicates which set of defaults is being affected by the commands on the File menu. Make sure the option button is set to the pane of defaults you have changed, click **File**, and then click **Save**.

Searching for Defaults

Use the Keyword Search field at the top of the Defaults dialog box to search Defaults for your desired terms. This searches across all the Defaults currently shown in the dialog box; if you have Example defaults open instead of User defaults, it will search the Example defaults and not User defaults.

The search looks in:

- Node names / catalogs
- Labels
- Field contents
Click the magnifying glass after you have entered your desired terms in the Keyword Search field to perform the search. You may also press Enter instead of clicking the magnifying glass.

Click **Clear Search** to erase everything in the Keyword Search field and clear any search results shown in the Defaults dialog box.

Click or hover over the Information button to see a list of searching syntax.

### Searching Syntax Examples

<table>
<thead>
<tr>
<th>Terms</th>
<th>Wildcards</th>
<th>Boolean</th>
<th>Groupings</th>
</tr>
</thead>
<tbody>
<tr>
<td>word</td>
<td>word*</td>
<td>word1 word2 (same as:</td>
<td>(word1 OR word2) AND</td>
</tr>
<tr>
<td>word1 word2 ... wordN</td>
<td>wo*d</td>
<td>word1 OR word2</td>
<td>word3</td>
</tr>
<tr>
<td>“exact string”</td>
<td>wo?q</td>
<td>word1 AND word2</td>
<td>word1 AND (word2 OR word3)</td>
</tr>
</tbody>
</table>

ArtiosCAD builds the search index in memory each time you perform a search. It does not store it for future use. As such, searching speed is directly related to computer performance.

### Performing a Defaults Search

Let’s say you change the Chamfer for corner value every time you create a dieboard. You want to change it in Defaults but you don’t know where to look.

1. Click **Options > Defaults**.
2. In the Defaults dialog box, enter “Chamfer for corner” in the Keyword Search field and either click the magnifying glass icon or press Enter.
3. ArtiosCAD performs the search and highlights tree nodes that have hits in yellow. ArtiosCAD dims all the other nodes but they are still functional.
4. In this example, since you are not working with blanking, the value you want to change must be in the Manufacturing parameter sets catalog.

5. Keep expanding the highlighted nodes until you see **Wood corners** in the Die board catalog. Double-click it to open it.
6. Change the Chamfer for corner field as desired and click **OK** to close the dialog box.
At this point, you could look at the other search results in case you want to change them too. To restore the regular view, click the red X. Save and exit Defaults as usual.

Defaults performance

ArtiosCAD loads Defaults into system memory when you launch it for more robust performance.

If you make changes to Defaults, click Options > Clear Defaults Cache to re-read Defaults into memory without having to restart ArtiosCAD.

ArtiosCAD re-reads the Defaults automatically when you click Options > Defaults, so you only need to clear the cache when you make a change and exit Defaults and then continue working in ArtiosCAD. Another time to clear the cache would be when you changed Defaults on one computer and other users were sharing those Defaults on other computers and did not want to restart ArtiosCAD; they would have to click Clear Defaults Cache to see your changes.
Parameter sets

Designer parameter sets

Parameter sets are collections of settings that govern how you work with designs or manufacturing files. The collection can be based on anything – by customers, by machines, or however else you want to group information.

Single design parameter sets allow you to assign different values to different sets for the following entries:

- Default bridging formulae to use
- Flute/grain setting, and if ArtiosCAD rotates designs based on standards to match
- Side up, and if ArtiosCAD mirrors designs based on standards to match

You select a parameter set when creating a design. You can change the parameter set being used by a design by clicking Change Parameter Set on the Options menu.

To create a parameter set, do the following:
1. Start ArtiosCAD.
2. Click Options, and then click Defaults.
3. To add a parameter set to Shared Defaults, open the Single Design Parameter Set entry. Right click it, select New, and then click Data.
4. Enter the name of this new parameter set and press Enter.
5. Click the plus sign (+) next to the parameter set you created.
6. Double-click Startup defaults. This will bring up a tabbed dialog box where you can set the initial side of the design, a default flute/grain direction, and default bridging formulae.
7. Click OK when you are done setting options for this new parameter set.
8. Click File, and then click Save to save the changes.

Manufacturing parameter sets

Manufacturing parameter sets, in conjunction with machine parameter sets, allow you to customize various settings per set or per machine. A partial list of the values you can set are:

- Die board size
- Automatic stripping parameters
- Default bridging formulae
- Hole mounting pattern workspaces and the side of the die used to determine if they are mirrored or not
- The Machine Reference Point, used by many things for alignment
- Settings for scrap/chop knives
- Mounting alignment hole parameters
A manufacturing parameter set references a die press parameter set and a printing press parameter set in addition to containing its own values.

To create a die press or printing press parameter set, do the following:

1. Start ArtiosCAD.
2. Click Options, and then click Defaults.
3. To add a parameter set to Shared Defaults, open the Die Press Parameter Sets or Printing Press Parameter Sets entry. Right click it, select New, and then click Data.
4. Enter the name of this new parameter set and press Enter.
5. Click the plus sign (+) next to the parameter set you created. The parameter set expands to show the top-level categories. Click each plus sign to open each category.
6. Double-click each entry, verify or change the settings within the dialog box that opens, and click OK when done. Repeat as desired for other settings.

7. Click File, and then click Save to save the changes, clicking Yes to overwrite previous Defaults.

Once the die press and printing press parameter sets are created, they can be incorporated into a manufacturing parameter set.
To create a manufacturing parameter set, follow the same procedure as creating other parameter sets: right-click **Manufacturing parameter sets**, click **New**, and so forth. Next, do the following:

1. Double-click the name of the parameter set to associate die and printing press parameter sets with it. Click **OK** once you have chosen sets.

2. Open the parameter set and enter values for all the fields. Your Defaults pane with all catalogs expanded should look similar to the picture shown below.
3. Click **OK** in each parameter's dialog box to save the changes.

4. Click **File**, click **Save** to save the changes, and then click **Yes** to overwrite previous Defaults.

**Note:** Changing the default die press parameter set and default printing press parameter set has no effect when choosing a manufacturing parameter set. To change the die press and printing press parameter sets used by a manufacturing parameter set, change the manufacturing parameter set itself, and not the default die press and printing press selections.

### Counter parameter sets

As with single design and manufacturing parameter sets, Counter parameter sets group counter parameters together for easy manipulation. You can copy a parameter set and modify
it to meet your unique needs, or you can create a new parameter set by right-clicking and selecting **New** on the context menu.

Double-click a parameter set to open it for editing.

**Tool Angles, Widths tab**

Shown below is **Tool Angles, Width** tab of the **Artios counter** parameter set for phenolic resin (plastic) counters and the **Steel counter** parameter set for steel counters. The **Type of counter** selection controls the options ArtiosCAD shows on the tabs across the parameter set.
### ArtiosCAD Counter Tool

#### Tool Angles, Widths

- **Type of counter**
  - Plastic counter
  - Steel counter

- **Counter Thickness**: \( \text{ROUNDUP(CAL} \times 0.461 \text{)} \)
- **Crease Channel Depth**: \( \text{CAL} + 0.002 \text{"} \times 0.461 \)
- **Chamfer Depth**: \( \text{CHGT} - 0.004 \text{"} \times 0.461 \)

#### Crease Channel Width

- **With Grain**: \#CWIDTHWG
- **Cross Grain**: \#CWIDTHXG

- **With Grain Angle Limit**: 10°
- **Rebuild Creases Only**

#### Tool Angles

- **With Grain**: 0°
- **Cross Grain**: 0°

- **Tool Width**:
- **Tool Angle**:

---

![ArtiosCAD Counter Tool](image-url)
Fields followed by $f(x)$ indicate that the parameter being set is dependent on the board. Clicking $f(x)$ leads to the Edit Expression dialog box, where the following parameters should be used to build expressions:

- $#CWIDTHWG$ Width of with grain creases
- $#CWIDTHXG$ Width of cross grain creases
- $\text{CAL}$ Board caliper

The parameters for counters are configured like this:
<table>
<thead>
<tr>
<th>Description</th>
<th>Workspace Variable</th>
<th>Default Expression</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Counter thickness</td>
<td>CHGT</td>
<td>ROUNDUP(CAL+0.007*#I, 0.002*#I)</td>
<td>Affects the periphery and chamfer tool offset.</td>
</tr>
<tr>
<td>Crease channel depth</td>
<td>CRECHD</td>
<td>CAL+0.002*#I</td>
<td>For information only. Does not affect tool paths.</td>
</tr>
<tr>
<td>Chamfer depth</td>
<td>CHAMFD</td>
<td>CHGT-0.004*#I</td>
<td>Automatically limited by maximum chamfer width.</td>
</tr>
<tr>
<td>(plastic counters only)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>With grain channel width</td>
<td>CHWWG</td>
<td>#CWIDTHWG+2*CAL</td>
<td></td>
</tr>
<tr>
<td>Cross grain channel width</td>
<td>CHWXG</td>
<td>#CWIDTHXG+2<em>CAL+0.004</em>#I</td>
<td></td>
</tr>
</tbody>
</table>

- **Notes**: The Maximum Chamfer Diameter is usually the diameter of the chamfer tool head.

**Periphery tab**

The **Periphery** tab of the counter parameter set dialog box contains settings which affect the periphery tool. This tab only appears for plastic counters.

- **Notes**: The Periphery tab of the counter parameter set dialog box contains settings which affect the periphery tool. This tab only appears for plastic counters.

The parameters on this page of the dialog box are all measurements whose functions are illustrated in the pictures next to them except for the Periphery Tool Angle. The angle specified...
in the **Periphery Tool Angle** field, along with the thickness of the counter material, determines the width of the periphery.

### Crease End tab

The **Crease End** tab of the counter parameter set dialog box controls how the crease ends are machined. This tab only appears for plastic counters.

<table>
<thead>
<tr>
<th>Tool Angles, Widths</th>
<th>Periphery</th>
<th>Crease End</th>
<th>Partial Cut</th>
<th>Cut and Crease</th>
<th>Chamfer</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Crease End Option</strong></td>
<td><img src="image1.png" alt="Image" /></td>
<td><img src="image2.png" alt="Image" /></td>
<td><img src="image3.png" alt="Image" /></td>
<td><img src="image4.png" alt="Image" /></td>
<td><img src="image5.png" alt="Image" /></td>
</tr>
</tbody>
</table>

The options in the **Crease End Option** group, **Use Periphery Tool Only** and **Use Crease End and Periphery Tools** affect the display of the rest of the tab. If **Use Periphery Tool Only** is selected, all the pictures change to omit any reference to the Crease End tool's existence.

### Partial cut tab

Partial cuts and glue assist lines can have the counter extend underneath them if you so desire. This tab appears only for plastic counters.
By default, Partial Cuts are set to be On the counter. Glue assist lines are set conditionally by default. They are off the counter if the distance between the crease and the closer end of the line is greater than the minimum specified in the Minimum field. Of course you can specify them to be On or Off all the time.

**Cut and Crease tab**

For plastic counters, the options on the Cut and Crease tab affect the creation of bowties, which are special constructs made necessary by having cuts and creases of such short length. All of the options are explained in the pictures.

For steel counters, ArtiosCAD offers the following choices on the Cut and Crease tab:
- **Single channel like a crease**, which makes one long channel
- **From end of segment plus channel width**
- **From end of segment**
- **No channel**

For separate channels, ArtiosCAD can measure the land from the end of the line or the edge of the channel. ArtiosCAD sets the land at both ends of a cut-crease line the same way as a normal crease.
Chamfer tab

The options on the **Chamfer** tab affect the counter at those places in the design where cut lines and the ends of crease lines meet. The chamfer mostly follows the periphery except it always stays a specified distance away from crease channels. This tab only appears for plastic counters.

The **Chamfer Gap** is the distance between the inside edge of a chamfer and the crease channel. The **Pickup** and **No Pickup** options control whether the chamfer is continuous around the end of the crease channel. The **Chamfer Tool Angle** is the angle of the tool, which, together with the thickness of the counter material, determines the width of the chamfer channel.

Reverse Creases tab

Reverse creases are used to make a panel fold outward instead of inward.
The **Insert** option indicates that a piece of foreign material will be attached to the counter to create the reverse crease. This is shown in the top picture on the tab. **Counter material** means that an area around the reverse crease will be milled out so that the board gets pushed into the depressed area. This is shown in the bottom picture on the tab. The **Crease Width** field becomes available when this option is selected. **Off the counter** disables all the fields.

**Geometry macro** is available only for steel counters and lets you choose a geometry macro from the Steel Counters geometry macro catalog. Should you choose to create your own geometry macro, use these guidelines:

- make the horizontal outline of a milling area using line type **Counter mill outline**
- make it rebuildable with a variable length using **L** for the variable
- add the geometry macro to the catalog with **Steel counter reverse rule** as the placement option
- for an insert, design it with corner relief so that the insert can be easily placed and removed
- for counter material, the macro should make one side.

**Note:** ArtiosCAD treats curved reverse creases and reverse cuts like straight lines. You will need to manually edit these areas.

**Reverse Cuts tab**

Reverse cuts are made on the counter in the same way as the Insert method for reverse creases. The parameters on the **Reverse Cuts** tab are explained in the picture.

As with the Reverse Creases tab, **Geometry macro** appears only for steel counters. When you enable a geometry macro, all the fields on the tab become unavailable except for **Set Back**.
Follow the same guidelines for using geometry macros as explained in the Reverse Creases tab section.

Crease Channel Ends tab

The fields on the Crease Channel End tab control the shape of the crease channel ends, the length of the crease channel cutback, what happens when creases meet, and the minimum length of a crease channel. This tab appears only for steel counters.

In the Shape group, choose either Round or Square. Land (the distance between the actual end of the channel and a line meeting it) is available for both round and square shapes, but
**Tool radius** is only available when using a square tool. Make sure this is accurate so that ArtiosCAD can correctly calculate the land.

In the Creases meet at sharp angle group, the picture changes depending on which option you select. **No Processing** lets the channels overlap and is sufficient for most designs. The **Priority** choices keep channels that meet from overlapping by shortening them in different ways.

- **Priority equal**: channels shortened by the same amount so they do not cross
- **Priority middle**: channels shortened so they do not cross, with the middle channel left closest to the original length
- **Priority side**: channels shortened so they do not cross, with the side channels left closest to the original length

If only two creases meet, the crease closer to horizontal/vertical is considered the middle crease. When four or more creases meet, ArtiosCAD sets the priority of the three closest creases and shortens the remainder as needed so they do not cross; use the **Shorten Creases** tool to make manual adjustments.

**Merge** merges them together to avoid sharp corners using the **Merge radius** for the inside corners. For this to work properly, the milling tool diameter needs to be smaller than the channel width.

Use **Minimum length** to set the smallest allowable channel length.

**Embossing tab**

An area of the board can be embossed by milling out the part of the counter surrounding the embossed area. This tab only appears for plastic counters. Embossing works differently for steel counters and is not defined by the parameter set. As with other tabs, the parameters on the **Embossing** tab are explained in the picture.

**Position Holes tab**

The **Position Holes tab** contains one parameter - the workspace name for the position hole. This tab appears only for plastic counters. Click **Specify** to browse for a new workspace.
### Tack Bridges tab

The **Tack Bridge Width** field on the **Tack Bridges** tab sets the width of tack bridges in the periphery of the counter. This tab is available only for plastic counters.

### Name tab

The choices on the **Name** tab affect the output of the Name tool on the Counter toolbar. This tab appears only for plastic counters. These choices include the font to use, its size, and its position, as shown in the picture.
Blanking Parameter Sets

Blanking machine parameter sets control how ArtiosCAD constructs the blanking tooling per machine. In this way, ArtiosCAD can easily create the right size tooling for machines of different sizes. The values set in these parameter sets are for:

- Frames
- Lower blanker board wood alignment
- Non-stop swords
- Photocells
- Pressers
- Tie-bolt holes
- Upper blanker board requirements and wood alignment

If you use BSI frame kits, specify the one to use in the Frame catalog as described further in this section.

For information about configuring the various options, please refer to the Blanking section in the Manufacturing chapter of the ArtiosCAD User Guide.

Blanking parameter sets control how ArtiosCAD constructs the blanking tooling for different types of blanking solutions for any machine. The idea is that you first choose the machine (which will then set the sizes and tolerances from the blanking machine parameter set) and then the kind of blanking solution you will be using on that machine (defined by the blanking parameter set). The values set in these parameter sets are for:

- Blank holes
- Frame clearance, construction, and size
- Grid
- Lower blanker board allowances and wood corners
- Non-stop swords
- Pusher details
- Pusher edge
- Tool controls
- Upper blanker board allowances and wood corners

Changes from previous versions include:

- In a Blanking machine parameter set, in the Frame dialog box, Min to Inner and Max to Inner now match those from BSI software.
- The BSI Flat top blanking parameter set uses the support rail corresponding to the machine and the BSI 5mm Adhesive Runner (A02019). Other parameter sets use a non-component support rail specified by a width.

Defining a BSI Blanking Frame Kit

If you are using a BSI blanking frame kit with your set of blanking tools, you specify its parts in the blanking machine parameter set for the press and its usage in the blanking parameter set.

1. Start ArtiosCAD and click Options > Defaults.
2. Open the Blanking machine parameter sets catalog.
3. Open an existing parameter set or create a new one.
4. Double-click **Frame** to open the Frame dialog box.

5. Click More Options (…) at the end of the Frame kit # field. This opens an empty Frame Kit Definition dialog box.
6. Enter the frame kit number in the Frame kit # field.
7. For the rails, corner, and centerline device, choose the BSI part from the drop-down list box.
8. Enter the Quicklock kit number in the Quicklock kit # field.
9. Choose the Quicklock part from the Quicklock drop-down list box.
10. Click OK to save the frame kit definition.
11. Choose the support bar number to use with this frame from the Support bar # drop-down list box.
12. Click OK to save the change to the blanking machine parameter set and return to Defaults.
13. Open the Blanking parameter sets catalog.
14. Open an existing blanking parameter set or create a new one.
15. Open its Frame catalog and double-click Frame Construction to open the Frame Construction dialog box.
16. Check **Use frame kit**, which will make the options in the Hardware group unavailable.
17. Choose an option in the **Mounting/scrap rails** drop-down list box and check **Lateral support bars** if your tooling will use them.
18. Click **OK** to return to Defaults.
19. Save and exit Defaults normally.

When you choose this blanking machine and blanking parameter set when using the blanking tooling creation tools, ArtiosCAD will construct the parts according to the BSI frame kit parts you specified.

**Rubber types**

ArtiosCAD has a default Rubber types catalog. Review its entries and modify or add to them as necessary to meet your needs.
A rubber type is defined by its unique name, thickness, and stock sheet size. If there are rubber types defined that are different thicknesses of the same material, include the thickness in the name, as each name must be unique.

To edit a rubber type, double-click its name. To create a new rubber type, right-click the Rubber types catalog and click **New > Data** on the context menu.

Shown below are the properties for the Red Neoprene rubber type.

![Red Neoprene rubber type properties](image)

**Reversible** indicates if the top and bottom sides of the rubber are the same, so that a piece of rubber and its mirror image could be considered the same when making layouts. (This is different from the mirror options in Auto-Repeat.)

The value in the **Rubber code** field is what is used on the Sheet Filename Generation page of the rubber sheets Output. Use letter and numbers only with no spaces.

Set the **Sheet width** and **Sheet height** fields to the appropriate sizes of the sheets for this type of rubber.

The **Thickness** field is currently unused, but to prepare for its possible use in the future, enter the thickness of the sheet.

**Select color** sets the color of the rubber when **Rubber Fill** is selected in the Rubber View Options dialog box. Clicking it opens a color palette.

The four option buttons set the type of the rubber.

- **Isotropic** means it is the same in all directions, so can be rotated as necessary.

- **Wave** means it is rippled, and the long dimension of the rubber must cross the ripples. This type of rubber is generally used in long, narrow slots. Wave rubber pieces are put on the sheet with their longest dimension horizontally regardless of the state of **Fill from left**.
• **Strip/Profile** means that it is premanufactured rubber that is not calculated for layouts, but can be drawn on the dieboard so that it can be placed correctly after manually being cut.

• **Plastic cover** causes ArtiosCAD to nest the pieces of the plastic cover (if one is used) as if they were rubber.

  *Width* is the width of the rubber when it is cut.

  *Offset from side of rule* is the distance from the edge of the rule to the edge of the rubber which allows for pointage.

Once you have finished modifying an existing rubber type or creating a new one, click **OK** to return to Defaults, and then click **File > Save** to save the changes.

### Rubber parameter sets

As with single design and manufacturing parameter sets, rubber parameter sets group rubber parameters together for easy manipulation. We recommend copying the **RubParamExample** parameter set and modifying it to meet your needs, but you can create a new empty parameter set by right-clicking **Rubber parameter sets** and selecting **New > Data** on the context menu.

### Bolt holes

After the rubber is made, it needs to be trimmed to allow for bolt holes, but because of the placement of the holes, the trimming may affect how pieces are auto-repeated. Therefore, this dialog box controls whether the trimming is automatic or not by the state of **Subtract bolt holes**. If bolt holes are not automatically subtracted from the rubber, the Subtract Bolt Holes tool allows for manual trimming after the rubber is created.
The rest of the fields in the dialog box determine how much rubber will be trimmed.

If the hole in the dieboard is almost circular and less or equal to the specified size, a circular hole of the specified size will be made in the rubber. If not, the hole in the dieboard will be copied into the rubber.

Laser position holes can be made using lines of linetype Laser position hole or Unknifed diecut. They can be triangular, square, hexagonal, octagonal, must be a reasonable size of less than 16mm, and fit around a circular pin. If a laser position hole is recognized, the hole in the rubber will be offset by the specified offset. If the laser position hole is not recognized, the hole will be copied without an offset.

Click OK when done to return to Defaults.

**Breaker knives**

Breaker knives are also known as stripping rules. When used in Rubbering, they are the stripping rules on the outside of the die. Sometimes they are rubbered to prevent injury to the people handling the dieboard. The options in the Breaker Knives section of the parameter set control how far the rubber extends past the sheet edge. Choose the desired option button and click OK to return to Defaults.
Crease Mask

The options in the Crease Mask section of the parameter set control how the rubber is cut back near creases.
The options in this dialog box are made available or unavailable by the state of **Make Plastic Cover** in the General section of the parameter set. When that option is not selected, the controls in the bottom half of this dialog box are unavailable, and when it is selected, the controls in the top half are unavailable.

For normal areas of the design, the options along the left side of the top quarter of the dialog box are the distance that is cut back from the crease, and the values on the right side are the angles at which the cuts are made. Each end of the cutback is the same as it is symmetrical.

For thin areas of the design, the rubber pieces are smaller so there are fewer cutbacks.

When a plastic cover is used, set the offsets from the plastic cover edge and from the edge of the crease rule as desired.

Click **OK** when done to return to Defaults.

**Cut/Ccrease**

ArtiosCAD can treat cut/crease rules as if they were cuts, or creases, or a mixture of the two. They need to have different parameters than the standard crease mask so that the angle of the cutbacks can be greater, so these are set in the Cut/Ccrease section of the parameter set. Also, rubber pieces for cut/crease rule are made thicker (to the thickness you specify in this dialog box) so they do not break at the thin points.

In the **Treat cut/crease** group, **Like cuts**, **Like creases**, and **Use parameters below** all behave as their names imply. **Use parameters below** enables the distance and angle fields for the crease cutback.

Click **OK** when done to return to Defaults.

**General**

The General section of the parameter set contains settings that affect the overall creation of the rubber.
Add blend causes the Rubber Area, Add Rubber, and Subtract Rubber tools to add blends to the rubber of the size specified in the Blend radius: field.

Fixed width, Open out, and Fill set the style of rubber ArtiosCAD makes.

The Open out tack width: sets the width of the connecting piece of rubber left at the end of an open-out.

In the Make splits group, the title control determines if ArtiosCAD limits the length of pieces of rubber or splits them. The default is to split them. This option also controls if ArtiosCAD creates pseudo temporary stripping rules to break up large pieces of rubber for easier manufacture.

- If they are split on bridges, there is better airflow and less suction. If they are split at corners, they nest better and are easier to replace when worn out. Both creates splits at both locations.
- Maximum length: sets the largest size allowed for pieces of rubber placed outside the designs.
- Maximum length inside: sets the largest size allowed for pieces of rubber placed inside the designs.
- Maximum length straight: is a separate length for straight pieces, and should be set to longer than the Maximum length: value as straight pieces nest better.
- Split width: sets the size of automatically-created splits and also sets the default value for the Add Split tool.

Minimum length: sets the value at which small pieces of rubber are merged with longer adjacent pieces.

The Trim gap: field sets the size of the gap when two pieces of differing-types of rubber overlap. It can be as small as 0.001 inch or 0.05mm, but set this to a value larger than 0 so that the Adjust Outline tools can work with each piece individually.

Trim against counter controls whether the rubber is trimmed against the counter (if one is defined) and if so, the gap is set in the Counter trim gap: field. If this option is not selected, the rubber can be trimmed later with the Trim Rubber tool.

Trim lead edge, when selected, makes it so that no rubber goes lower than the lead edge.
**Make plastic cover**, when selected, causes a plastic cover to be made in its own layer when the Rubber Area tool is used.

Click **OK** when done to return to Defaults.

**Layout**

If you have the Rubber Design and Layout option, ArtiosCAD can automatically group pieces of rubber on the sheets based on their shapes.

![Layout dialog box](image)

**Trim** is the distance from the edge of the rubber sheet to the edges of the rubber elements, and **Gutter** is the distance between each rubber element.

Increasing the value in the **Nesting tries:** field causes ArtiosCAD to try more nests, but this takes more time.

The five choices in the **Grouping** group control how the instances of each rubber element are grouped together on the sheets. **Manual** means that the grouping will be taken from the values set in the List Rubber Elements dialog box. **None** means that each item will be considered its own group. **Low** means only straight items will be grouped together. **Medium** will do an intermediate level of grouping, but **High** will group together as many instances of the element as possible. These controls are meant to let you find the balance between making pieces easy to find and wasting the least rubber.

Click **OK** when done to return to Defaults.

**Plastic cover**

Some diemakers glue a plastic cover on top of the pieces of rubber to keep the board from sticking to the rubber as the press operates. The plastic cover pieces are supported by pieces of rubber on all sides, including along creases. The plastic cover extends slightly past the pieces of rubber underneath. Plastic cover pieces are not generated for slots.
When **Only in waste areas** is selected, the plastic cover is used only to cover waste, not designs. When it is not selected, it covers both waste and designs, but not slots. Also, when it is selected, it is nested as if it were a type of rubber.

**Offset from cut** and **Offset from crease**: both control how close the plastic cover gets to rule. Remember that it needs to project slightly over the rubber but not touch the rule.

**Subtract bolt holes** and its associated fields work the same way as they do in the Bolt holes section of the parameter set.

**Left allowance**, **Right allowance**, **Top allowance**, **Lead edge**, and the options in the **Relative to** group all determine how the plastic cover is positioned in reference to the edges of the layout.

Click **OK** when done to return to Defaults.

**Rubber types**

The **Rubber types** section of the parameter set is how ArtiosCAD determines which type of rubber to use in a given location and also how to place it.
Rubber is assigned to lines on the basis of line type, knife location, knife side, slots, rule direction, and nicks. Use this dialog box to modify existing selections, create new selections, or delete existing selections.

The line entries in the Rubber Parameters dialog are applied in order, starting with the first (top) one and moving down through the list to find a match; each rule is compared with each selection in turn. The first selection that the rule matches defines the rubber type for that rule. The more critical selections with high shore rubber, such as for slots and nicks, should be first in the list.

To add a selection list entry, do the following:

1. Select an existing selection and click Insert.
2. A new selection is added to the table with the name of the rule from step 1 with (2) appended to its name.
3. Delete the text in the Selection name: field and enter the name for the new selection.
4. Enter the width of the rubber pieces in the Width: field, and the desired offset in the Offset from side of rule: field. Select Use selection and set the type of rubber from the drop-down list box. (The type of rubber must be defined in the Rubber Types catalog before it can be used in the parameter set.)
5. Click Selection. The Rubber Type Selection dialog box opens as shown below.
In this dialog box you select the conditions that a piece of rule must meet in order to be rubbered by the type of rubber selected. The checkboxes in the **Line types** group and the **Knife Location** group use OR logic, but the two groups together use AND logic: Cut/knife OR Stripping rule OR Scrap knife OR Balance knife, and so forth, AND of type Leading edge knife OR Exterior waste OR Interior slit, and so forth.

If the type of rubber you are defining is for slots, select **Slots** and enter the maximum width of the slot in the **Width limit** field. If you define more than one type of rubber for slots, the narrowest slot should be highest in the list in the Rubber types dialog box, followed by the wider slots.

The other groups allow you to add more conditions to the rules that will receive this type of rubber; set them as desired. Nicks have the following restrictions: For **Short piece centered on nick**, the **Distance past nick** field should be more than the width of the rubber. Also, for both of the first two options, the **Minimum length** should be less than the remaining length lines which you do not want to have the nick rubber type.

For the **Knife Location** group, refer to the picture and table below.
Table: Knife locations for rubbering types

<table>
<thead>
<tr>
<th>Number</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Side</td>
</tr>
<tr>
<td>2</td>
<td>Trailing edge</td>
</tr>
<tr>
<td>3</td>
<td>Breaker knife (stripping rule)</td>
</tr>
<tr>
<td>4</td>
<td>Interior slit</td>
</tr>
<tr>
<td>5</td>
<td>Product side</td>
</tr>
<tr>
<td>6</td>
<td>Waste side</td>
</tr>
<tr>
<td>7</td>
<td>Common knife</td>
</tr>
<tr>
<td>8</td>
<td>Common waste</td>
</tr>
<tr>
<td>9</td>
<td>Interior waste</td>
</tr>
<tr>
<td>10</td>
<td>Leading edge</td>
</tr>
</tbody>
</table>

Once you have finished selecting the criteria for this rule, click OK to return to the Rubber Types dialog box.

1. Use the arrows at the right end of the list to move the selected rubber type selection either up or down in the priority list.
2. Repeat the process as desired to add selection list entries.
3. Click OK when done to return to Defaults.
All rule types except crease and balance knife should select a rubber type (rubber on balance knives is optional because this does not interfere with rubber on other rules). If you want no rubber on a particular rule type, because you are going to put rubber there manually, you should select rubber type None for this rule type, and still define an offset and a width, so ArtiosCAD knows how much space to leave for it.

For example, suppose you want no rubber on cut/crease. Copy the Cuts selection on the Rubber types tab, change the name to Cut/crease, change the rubber to None, and change the selection to select Cut crease lines. You can adjust the width and offset from rule for the rubber you are going to add manually.

If there are rules on the die with no rubber type defined, ArtiosCAD displays a warning dialog when you start the Rubber Area tool. You can either show the rules with no rubber type defined, or you can ignore the error, in which case surrounding rubber along nearby rules will cross the rules for which no rubber type is defined.

Rebuild options

The Rebuild Options entry in the Design defaults catalog lets you change behavior when rebuilding a single design or running a standard.
Automatically reinitialize subsequent variables reinitializes variables in subsequent menus which currently match their default values. When this option is selected and you change a variable, any subsequent variable depending on that variable which matched its default value before the rebuild started will get updated with the new value. For example, with this option selected, if you change L, any variable in any subsequent menu which depends on L gets automatically updated with the new value for L.

When this option is off, dependent variables are not automatically updated and are flagged for review in the Rebuild Conflicts dialog box.
Start rebuild at board menu controls whether you may choose a new board when rebuilding a design instead of starting at the first visible menu.

Show full screen sets the Rebuild, Run Standard, and Reports dialog boxes to the maximum size possible. If you change the size of these dialog boxes manually, ArtiosCAD remembers these changes and uses your custom sizes instead.

The options in the Variable labels... groups control what is shown to the left of the fields when running a standard, rebuilding a design, using a geometry macro, or outputting a report. Choose from Variable name only, Description only, Description and variable name, and Variable name and description. If Description only is the chosen method and the variable description is blank, the variable name is used in parentheses. If there is no documentation plot for the menu, the description is shown with the variable name in parentheses. These options can be changed on the fly in the dialog boxes by clicking the tiny triangle above the variable list and selecting a different display option.

Click OK to make the changes and return to Defaults, or click Cancel to discard the changes.

3D Hardware Options

To set the default values for the gutters and offsets when using Add Hardware in 3D, open the 3D Hardware Options dialog box in the Startup defaults catalog.
Change the values as desired and click **OK** to return to Defaults.

**3D Import Options**

Use the options in **Startup defaults > 3D Import** to control how ArtiosCAD imports solids.
Render both sides shows the inside and the outside of the solid.

Preserve origin on adding new solid keeps the 3D workspace origin set so that when you import solids, they stitch together properly. When this option is off, ArtiosCAD adds solids centered behind existing solids.

Interactive preview shows the preview window, allowing you to choose which parts of multi-part solids to import. When this option is off, ArtiosCAD imports all parts of multi-part solids.

Click OK to make the changes and return to Defaults, or click Cancel to discard the changes.

3D Rendering method

The 3D module can use two different rendering (display) methods, OpenGL (the default) and Direct3D. Which method will perform better for you depends on the display adapter in your system. The main difference between the two methods is how data is transferred between main system memory and the display adapter. Other differences include:

- Shininess appears to work better when using Direct3D.

- ArtiosCAD using Direct3D takes longer to open a 3D workspace initially but once open draws it faster than when using OpenGL.

- Using OpenGL allows the export of bitmaps with more pixels than with Direct3D

- In wireframe view mode, OpenGL seems to be able to display more lines.

- When ArtiosCAD and the Cortona VRML viewer both use Direct3D and are open at the same time, they compete for resources and unpredictable results may occur. Change the rendering method in one of them for better results.

To change the rendering method in Defaults, open the Startup Defaults catalog and double-click 3D Rendering Options.
Choose the option button for the method to use and click **OK**.

**Use OpenGL for bitmaps** enables ArtiosCAD to output bitmaps using OpenGL regardless of the screen rendering method chosen. OpenGL supports the output of larger bitmaps than Direct3D.

Save and exit Defaults as usual. The change is effective immediately. You can also change it at any time by clicking **Options > 3D Rendering Options**.

### Database defaults

Database defaults configure the operation of the ArtiosCAD database. Click **Options > Defaults**, and in the Shared Defaults pane, click **Design Defaults > Database** to open the Database dialog box.
Enable Database, when checked, lets ArtiosCAD save information to the database. When the checkbox is clear, no new information is saved to the database. Database information that already exists is retained.

Create Thumbnail in Format controls if ArtiosCAD creates thumbnail pictures of workspaces when designs are saved. The thumbnails are stored in the database and are used by the database browsers.

The drop-down list box next to the checkbox controls the type of thumbnail created.

BMP with RLE compression is the default choice. It creates thumbnails in BMP format using run length encoding compression.

JPEG format creates thumbnails in JPG format, which is compressed but lossy (meaning some detail is lost).

Folded JPEG format first tries to create a folded view for the thumbnail based on saved angles in a single design. If there are no saved angles, a flat thumbnail is created. In each case JPEG format is used.
**Artios3D format** causes ArtiosCAD to look for an .A3D file by the same name as the workspace being saved in the same directory, and if found, that is used for the thumbnail. If it is not found, Folded JPEG format is used instead.

### File Operations group

The checkboxes in the **File Operations** group control database activity when creating or saving a workspace.

<table>
<thead>
<tr>
<th>File Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Resource View on Open and Save As</td>
</tr>
<tr>
<td>Show database dialog box when creating a new design</td>
</tr>
<tr>
<td>Show Create As dialog box when creating a new design</td>
</tr>
<tr>
<td>Show database dialog box when saving</td>
</tr>
<tr>
<td>Synchronize disk file when saving in browsers</td>
</tr>
<tr>
<td>Add new characteristics when synchronizing</td>
</tr>
<tr>
<td>Enable Skip DB button</td>
</tr>
</tbody>
</table>

**Use Resource View on Open and Save As**, when checked, directs ArtiosCAD to use Resource View when opening workspaces or saving them using Save As. Directory View is used when this option is not checked.

**Show database dialog box when creating a new design**, when checked, instructs ArtiosCAD to prompt you for database information when you create a new design.

**Show Create As dialog box when creating a new design**, when checked, when checked, instructs ArtiosCAD to prompt you for the filename and resource or directory in which the design is to be saved when creating a new design.

**Show database dialog box when saving**, when checked, tells ArtiosCAD to prompt you for database information when you save a workspace in a resource.

**Synchronize disk file when saving in browsers**, when checked, causes ArtiosCAD to modify the disk file for the record you change in a database browser. This is independent of saving the record, which only affects the database.

**Add new characteristics when synchronizing**, when checked, instructs ArtiosCAD to compare the characteristics in a workspace being opened with those already in the database, and if there are new ones in the file, prompts you to add them to the database.

**Enable Skip DB button**, when checked, lets you click **Skip DB** when saving a workspace so that you can save a workspace with no corresponding database information.

### Performance options group

The checkboxes in the **Performance Options** group control how ArtiosCAD retrieves certain types of information from the database.
Typically, databases which run over WANs (Wide Area Networks), for example between plants, experience slower network performance compared to those which run over faster LANs (Local Area Networks). By default, ArtiosCAD requests a complete set of database entities each time the Database Information dialog box is activated, which can lead to wait times if there are many records to download from the database server.

To address this, ArtiosCAD can store the **Customer**, **Owner**, **Designer**, **Salesperson**, **Characteristics**, and **User Fields** entities from the Database Information dialog box in memory, as well as the boards, companies, company types, and Resources. This is called **caching**.

Both ArtiosCAD and CAD-X can use this feature, and each will use more memory if it is enabled.

Once the database dialog box entries or other entities are loaded into memory, ArtiosCAD does not re-request them from the database. If changes are made to the entities in the database itself, ArtiosCAD will not see them until the cache is refreshed or a new ArtiosCAD session is started. To refresh the cache, click **Database > Refresh cache > Item**.

ArtiosCAD can also search the database for specific records which match a pattern thus returning only a few records instead of thousands. This feature is called **pattern searching**.

**Note:** These performance options do not apply to customized database information dialog boxes. To use them, you must use the standard database information dialog boxes.

### Caching

Toggle the **Cache dialog box entries** checkbox to enable and disable caching.

The table below lists how the fields in the Database Information dialog box behave when database dialog box entry caching is turned on. The Database Information dialog box behaves the same for Single Design and Manufacturing.

**Table: Dialog box behavior when database dialog entity caching is enabled**

<table>
<thead>
<tr>
<th>Field</th>
<th>Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Customer</strong> and <strong>Owner</strong></td>
<td>All Customer and Owner entities are requested when the dialog box is first accessed, and then they are cached.</td>
</tr>
<tr>
<td><strong>Salesperson</strong> and <strong>Designers</strong></td>
<td>All Salesperson and Designer entities are requested when the drop-down list box arrow for either field is first clicked, and then they are cached. They share the same cache.</td>
</tr>
<tr>
<td><strong>Characteristics</strong> button</td>
<td>Characteristics are requested the first time the button is clicked, and then cached. Only applicable to Single Design.</td>
</tr>
</tbody>
</table>
**Field** | **Behavior**
---|---
**User Fields** button | Same as Characteristics.

**New** button in Customer dialog box | Causes a refresh of the Customer cache.

In addition to caching Database Information dialog box entries, when caching is enabled, ArtiosCAD also caches boards, companies, company types, and Resources.

Once the database dialog box entries or other entities are loaded into memory, ArtiosCAD does not re-request them from the database. If changes are made to the entities in the database itself, ArtiosCAD will not see them until the cache is refreshed or a new ArtiosCAD session is started. To refresh the cache, click **Database > Refresh cache > Item**.

**Pattern searching**

Another way to ensure robust database performance over a slow Wide Area Network for the **Customer**, **Owner**, **Designer**, and **Salesperson** fields is to enable pattern searching by checking the **Use pattern searching for customers and owners** and **Use pattern searching for designers and salespeople** checkboxes. To maintain compatibility with previous versions, these checkboxes are both cleared by default.

When pattern searching is enabled, the Oneup Design Information and Manufacturing Database Information dialog boxes change. The drop-down list boxes for the **Customer**, **Owner**, **Designer**, and **Salesperson** fields disappear and the fields become disabled. In addition, there are ... buttons leading to dialog boxes which let you search for records and then display details about the selected records, or display details if there is already a selected record. Shown below is the Customer dialog box; all four dialog boxes act similarly, but only the Customer dialog box has the **New** button.
Pattern searching works by entering a few letters of a word, or a whole word, or a complete phrase, then choosing a method of searching, and then clicking **Find**. The results of the search populate the drop-down list box.

**Mixing database performance modes**

Database dialog box entry caching and pattern searching can be used simultaneously, but not for all four types of records. Only a pair of records (Customer and owners or designers and salespeople) for which pattern searching is turned off can be cached.

**Database Information Dialog Customization groups**

The options in the **Single Design** and **Layout Database Information Dialog Customization** groups allow you to choose what happens when entering database information for a single design or layout.
Use standard dialog uses the dialog box that is included with ArtiosCAD.

Use custom dialog definition file enables the Customize button, which in turn leads to the Control Layout Manager described in the next section. Using this feature requires the Information Enhancement option.

Use custom external application enables a field to specify the path to a custom program (such as an ERM program) that controls information storage instead of the ArtiosCAD database. This custom application is not provided or supported by Esko unless it was provided by the Professional Services department. Using this feature requires the Information Enhancement option.

Designing a custom Database Information dialog box

When you choose Use custom dialog definition file and click Customize, the Control Layout Manager dialog box opens showing the current dialog box.

On the left is the dialog box itself showing the tabs, groups, labels, fields, and buttons. On the right are the language selector, size controls, the grid controls, the control catalogs, the Properties fields for the selected item, and the OK, Test, Cancel, Open, and Save As buttons.

There is no undo functionality in the Control Layout Manager, but you can click Cancel to discard all changes and then start again.

Each language of ArtiosCAD can have different customized database information boxes. Choose the language for the current dialog box in the Language drop-down list box.

To change the size of the dialog box, adjust the values in the Dialog Size: fields, or select the edge of the dialog box within the definition window and drag it to the desired position. To
make a dialog box larger than the current one, resize the Control Layout Manager dialog box itself using standard Windows methods, and then increase the size of the dialog box window.

**Enable Common Area** toggles the common area that ArtiosCAD shows when the dialog box has multiple tabs. For more information about tabs, see *Working with Tabs*.

**Enable Grid** and **Spacing(px)** control the appearance and spacing of the alignment grid. Turn on the grid to have controls snap to the nearest point when you drag them. The number in the **Spacing(px)** field is the number of pixels.

To add a control, select it from the catalog and drag it to the desired position. You may also double-click it; it will appear at the top left of the dialog box, and you may then select it and drag it to the desired position.

To select multiple controls at once, hold down **SHIFT** or **CTRL** and click each control. Alternately, you may make a rectangular marquee selection around the desired controls. The selection rectangle must completely encompass the controls. Be careful about selecting anything too close to the edge of a group box as you might accidentally select the box and not the objects within it.

To remove a control, select it and press **Delete** on the keyboard.

To move a control, select it and drag it to the desired position, or select it and use the **Position:** fields in the **Properties** group to adjust its position. You can also select it and use the arrow keys to move it in one-pixel increments.

Removing and moving multiple controls work the same way; just select them first.

To resize a control, select it, and use the handle points to change its size as desired, or select it and use the **Size:** fields in the **Properties** group to adjust its size.

To change text in a control, select it, and then change the contents of the **Text:** field in the **Properties** group.

To change the translation for a control, select it, and then click More Options (…) at the end of the Properties field. Enter the desired translations in the appropriate fields in the Text Language Options dialog box. If a field is empty, ArtiosCAD uses the text in the Default Text field. Click **OK** when done to return to the Control Layout Manager.
Note: ArtiosCAD is limited to displaying characters in the code page of the running operating system. While there might be different strings defined for a dialog box, they may not appear correctly if the code page of your current operating system cannot display them.

When editing a field in the Properties group, or a Dialog Size: field, click in another field or select a different object to activate the changes made to the first object. Do not press Enter as that is interpreted as clicking OK and will thus close the dialog box.

Click OK to save the changes to the dialog box and close the Control Layout Manager. The single design information is saved as DBDlgDesignDef.xml, and the manufacturing data is saved as DBDlgMFGDef.xml, both in ServerLib or ClientLib depending on which set of defaults was changed.

Click Cancel to discard the changes to the dialog box and close the Control Layout Manager.

Click Test to open a sample dialog box that previews the final result.

Click Save As to save the dialog box layout to a file.

Click Open to open a previously-saved dialog box layout file.

Shown below is a modified Database group in the Control Layout Manager and then in the test dialog box.
Note: Database performance options do not apply to customized database information dialog boxes. To use them, you must use the standard database information dialog boxes.

Defining the Tab Key Order

When you are defining a custom database information dialog box, you can set the Tab key order for the controls in the dialog box on the Tab Order tab of the control layout manager.
You can only set the Tab key order for fields that you can change in the dialog box. Labels and read-only fields do not have Tab key order settings.

To change the Tab key order manually, do the following:

1. Select a field or button with a blue number after it by either clicking it in the dialog designer or in the list on the right.
2. Use the arrows to the right of the list to change its position, or
3. Drag and drop the entry to its new position.

**Automatically Calculate Tab Order** assigns Tab key orders to elements horizontally from top to bottom of the dialog box.

Each tab of the dialog box has its own Tab key order. The common area is always after the current tab.

If you have added some controls to the dialog box, you must save those changes, exit the control layout manager, and re-enter it in order to set the Tab key order on those new controls. ArtiosCAD puts the new controls at the end of the list.

**Working with Tabs**

ArtiosCAD allows you to create additional tabs in customized database dialog boxes. You could have one tab for general information, one tab for design-specific information, one tab for customer information, and so on. There is also an area at the bottom of the dialog box reserved for common controls shown regardless of which tab is active. Shown below is an example of a customized tabbed single design database information dialog box in its Defaults definition, and then in use in ArtiosCAD.
If you have upgraded from a previous version of ArtiosCAD, the default database information dialog box uses one tab and the common area is not enabled.

**Adding a Tab**
To add a tab, click the plus sign in brackets.

**Renaming a Tab**
To change the name of a tab, double-click its current name and enter a new name in the field. Press Return when done.
Tab names are specific to the selected language in the Language drop-down list box. The first name you enter for a new tab is the default for every language. To change the name of a tab in a different language, first select the different language, then change the name of the tab.

**Deleting a Tab**
To delete a tab, click the red X on the tab.

**The Common Area**
The common area at the bottom of the dialog box is for controls that persist regardless of which tab is active. Use Enable Common Area to toggle its display. To resize the common area and tabs, drag the bar separating it from the tabbed area. All the tabs are the same size.

**Adding Controls**
To add a control to a tab, drag it as usual from the list on the right to the desired position on the tab. Note that you cannot drag controls between the common area and a tab. In that case, delete the control and re-add it in the desired position.

**Selecting Controls**
You may only select controls, either singly or multiply, in either the tabbed area or the common area, but not both.

**Version Interpretation**
If you share customized database dialog definition files between system that are different versions, the following rules apply:

- **ArtiosCAD 16.1.1 or later reading a definition created in an earlier version:** One tab, no common area.
- **ArtiosCAD 16.1.1 or later sending a definition file to an earlier version:** Only the controls from the first tab and common area are shown by the earlier version.
- **An ArtiosCAD version earlier than 16.1.1 reading a definition created in 16.1.1 or later:** 16.1.1 creates a dual-format definition file with a tabbed interface section and a flat
interface section. An earlier version reads the flat interface section and ignores the tabbed interface section (but remembers it).

- An ArtiosCAD version earlier than 16.1.1 writing a definition read by 16.1.1 or later: Writes a flat version. If you use this to overwrite a tabbed version on a different system, the tab information will be lost.

Using a custom external application

Use a custom external application allows a separate standalone application to display and gather database information. Specify the absolute path name of the application in the associated field, or use the Browse button (...) to locate it. This custom application is invoked whenever the Database Information dialog box would otherwise be shown.

The exact sequence is:

1. ArtiosCAD requests database information (by clicking Database > Database Information or during a Save or Open).
2. The current database information is packaged into a randomly-named XML file in the directory defined as the TEMP directory in Options > Defaults > Startup Defaults.
3. The external application is invoked with the input XML file as the first parameter.
4. ArtiosCAD waits until the external application is done.
5. ArtiosCAD reads the XML file specified as the second parameter on the external application’s command line and uses it to populate the database.

Shown below is the dialog box created by a sample application.

The exact command executed is:

Application.exe -iInputXMLDBinfo.xml -oOutputXMLDBinfo.xml

where Application.exe is the name of the custom application, InputXMLDBinfo.xml is the full path name of the temporary input XML file that ArtiosCAD creates, and OutputXMLDBinfo.xml is the full path name to the output XML file created by the custom application. The names of the parameters are generated randomly by ArtiosCAD; the custom application should read them from the command line.

ArtiosCAD checks for a return code from the custom application of 1 for OK and 2 for Cancel.
A sample database definition XML file is shown below.

```xml
<ARTIOSDBDOC>
  <UNITS>IMPERIAL</UNITS>
  <DESIGN>
    <NAME>SAMPLE1.ARD</NAME>
    <REV>0</REV>
    <REVNUM>0</REVNUM>
    <PATH>C:\Artios\Designs</PATH>
    <REVDATE>2004-04-14</REVDATE>
    <SAVEDATE>2004-04-14</SAVEDATE>
  </DESIGN>
  <DESC>This is a sample long description</DESC>
  <SHORTDESC1>Short 1</SHORTDESC1>
  <SHORTDESC2>Short 2</SHORTDESC2>
  <SHORTDESC3>Short 3</SHORTDESC3>
  <AUTH>Authorization</AUTH>
  <REVDESC>Revision Description</REVDESC>
  <LENGTH>8.000000</LENGTH>
  <WIDTH>7.000000</WIDTH>
  <DEPTH>6.000000</DEPTH>
  <GRAINDIR>2</GRAINDIR>
  <CAL>0.016000</CAL>
  <BLANKLEN>780.256226</BLANKLEN>
  <BLANKHEIGHT>558.799927</BLANKHEIGHT>
  <AREA>267241.718750</AREA>
  <RULELEN>5269.554688</RULELEN>
  <RESOURCE>
    <ID>1</ID>
    <NAME>ArtiosCAD</NAME>
    <RELPATH>Artios\Designs</RELPATH>
    <PATH>C:\Artios\Designs</PATH>
    <MASTER>1</MASTER>
    <ACTIVE>1</ACTIVE>
    <INHERITAUTONUM>1</INHERITAUTONUM>
    <SERVER>
      <ID>1</ID>
      <NAME>ArtiosCAD</NAME>
    </SERVER>
    <BOARD>
      <ID>39</ID>
    </BOARD>
  </RESOURCE>
</ARTIOSDBDOC>
```
<CODE>
I-SBS-16</CODE>
<DESC>
I-SBS-16</DESC>
<FLUTE/>
<TESTCODE/>
<CAL>
0.016000</CAL>
<TESTVAL>
0.000000</TESTVAL>
<IL>
0.008000</IL>
<OOG>
0.008000</OOG>
<CRRV>
0.031250</CRRV>
<BASISWEIGHT>
64.000000</BASISWEIGHT>
<BASISCOST>
72.000000</BASISCOST>
</WORKSPACE>
</BOARD>
</CUSTOMER>
</WORKSPACE>
</</WORKSPACE>
</OWNER>
</WORKSPACE>
</</WORKSPACE>
</OWNER>
</SALESPERSON>
</</WORKSPACE>
</SALESPERSON>
</DESIGNER>
</</WORKSPACE>
</DESIGNER>
</USERFIELDDATALIST>
</USERFIELDDATA>
</ID>
9902</ID>
<DESC>
Inventory Die Board No.</DESC>
<VALUE>
DIE45679</VALUE>
For more information about using a custom application, contact Professional Services.

**Default selections group**

The drop-down list boxes in the **Default Selections** group set the owner, salesperson, and designer for newly-created workspaces. These fields get their lists of possible values from the Company and Person browsers in DataCenter Admin. Set the values as desired.

![Default Selections](default_selections.png)

Click **OK** to save the changes made to Database defaults and return to the main Defaults dialog box. Click **Apply** to save the changes but remain in the Database defaults dialog box. To discard all changes and return to the main Defaults dialog box, click **Cancel**.

**Company selection display group**

The option buttons in the Company Selection Display group control how company name and identification information is shown in ArtiosCAD. **Name** is the default choice.

![Company Selection Display](company_selection.png)

**Name** and **Number** are fields you set for a company in the Company browser in DataCenter Admin. Note that **Number** can be any number you set; it is not calculated. Choose the display format as desired.

Any changes made in this group will not appear in the **Default Selections** group in this dialog box until you click **OK** and then open the Database defaults again.

Shown below is an example in the Oneup Database Information dialog box when **Number**, **Name** is the chosen option in Company Selection Display.
Spell checking

If you have Microsoft Word installed on your system, ArtiosCAD can use its spell checking functionality in Single Design and Manufacturing in most places where you enter text using a field in a dialog box. This feature is turned on by default. You may turn it off in the Paragraph Text tool and in text fields by using the Spelling dialog box in the Startup Defaults catalog.

Toggle the Enable spell checking checkbox as desired, and click OK to save the change and return to the main Defaults dialog box.

Note: This setting does not affect document-wide spell check using Tools > Check Spelling. It is available regardless of the state of this checkbox.

Nudge Options and Defaults

Click Options > Nudge to set the active nudge modes per session and the distances they use. This command is available when a single design or a manufacturing file is open. Essentially the same dialog box is used in Defaults in Startup defaults > Nudge options.

Shown below is the Nudge options dialog box.
Show nudge options in select tool controls the availability of the nudge modes. When it is selected, they are active. When it is cleared, nudge moves by a pixel.

Set the three mode selectors as desired. They determine which nudge modes are active when a tool which supports nudge is started.

The values in the Fixed values group control the distance used by the Nudge by a Fixed Value mode. Set them as desired.

Note:
If you change the nudge options or Defaults while a Select tool is active, the tool will be restarted to update it and the current selection will be lost.

Hatch Defaults

ArtiosCAD stores Defaults for the Hatch tool in three locations: the Hatch Catalog, Property defaults > Hatch, and Startup defaults > Hatch tool options.

Hatch Catalog defaults

The Hatch Catalog in Defaults is where you add, remove, and change entries in the Hatch Catalog. ArtiosCAD comes with sample entries in the Misc folder.
To add a folder to the catalog, right-click the folder which will contain the new folder, then click **New > Folder**. To add a new entry to a folder, right-click the folder and then click **New > Data**.

To remove a folder or an entry, right-click it and click **Delete** on the context menu. ArtiosCAD will ask you to confirm the deletion.

To change an entry, double-click it and change the properties as desired. The **Hatch Properties** dialog box is the same as it is in drawing mode.

---

**Hatch Property defaults**

In **Property defaults > Hatch**, you set the Defaults for the `<custom>` Hatch Catalog entry as shown below.
The Hatch Properties are the same as in drawing mode; set them as desired and click OK to return to Defaults.

Hatch Startup defaults

In Startup defaults > Hatch tool options, you set the options for how the Hatch tool will initially work.
In the **Tool select option** and **Offsets** groups, set the options as desired. 

**Prompt before changing layers**, when checked, makes you confirm changing layers to the layer specified in a Hatch Catalog entry's **Placement Options** dialog box. **Restore layer on tool exit**, when checked, returns you to the layer you were in if the layer changed due to using a Hatch Catalog entry with a layer assignment.

When you are done setting the options as desired, click **OK** to return to Defaults.

---

**Adding Purchased Standards to Style Catalogs**

To install a purchased ArtiosCAD standard, do the following:

1. Verify the data and settings in the 2D workspace.
   a) Open the workspace in ArtiosCAD and set the units, database information, and board code as desired.
   b) Convert the 2D workspace to 3D and set the base face and fold angles. The standard may already have this information set in it.
   c) Close the 3D workspace, making sure to leave **Save fold angles and view settings**... selected. You may save or discard the 3D workspace as desired; you do not need it for the standard.
   d) Save the 2D workspace.

2. Copy the workspace to the Shared Defaults folder or Project so everyone will be able to use it.
   a) For ArtiosCAD Standard Edition, using Windows Explorer, copy the 2D workspace from where you saved it to `..\Esko\Artios\ServerLib`.
   b) For ArtiosCAD Enterprise, save or upload the 2D workspace to the Standards subfolder of the Shared Defaults Project. Depending on how the Shared Defaults Project security is configured, you may need administrator privileges for this.

3. Add the standard to a Style Catalog.
   a) In ArtiosCAD, click **Options > Defaults** to open Defaults.
   b) Scroll down the list of Shared defaults and open the **Style catalog** catalog.
   c) Right-click the folder in which you will place the new standard and click **New > Data**. To make a new subfolder, right click its parent folder and click **New > Folder**.
d) Enter the name of the new standard as you want it shown in the style catalog and press Enter when done.

e) Double-click the new standard entry to open its Properties dialog box.

f) Make sure the **Standard Type** is set to ArtiosCAD.

g) Click ... (Browse) at the end of the Filename field to navigate to ServerLib for ArtiosCAD Standard Edition, or the Standards subfolder of the Shared Defaults Project for ArtiosCAD Enterprise, and then double-click the workspace. Its filename should appear in the Filename field.
h) Click **OK**.

4. Click **File > Save** and click **Yes** to overwrite Shared defaults.

5. Click **File > Exit** to exit Defaults.

6. To test the standard, do the following:
   a) Click **File > Run a Standard**.
   b) Navigate to the new standard and select it.

c) Click **OK** to run the standard. Select a board code and set the style choices in the menus.

d) Convert the 2D workspace to 3D. ArtiosCAD will use the saved fold angles you set in step 1.
Adding LASERPOINT IQ standards to Style Catalogs

Preparation

Before adding a LASERPOINT IQ standard to ArtiosCAD, it is necessary to locate the LASERPOINT IQ files needed to run the standard. The name can be determined using Menu Management. Locate the standard to add and select the Edit option. This will show a standard name which looks like one of the following entries:

- EXE STDMENU WITH 'XYZ' This is an entry for a LASERPOINT IQ 2.0 format standard whose name is XYZ. You will need the files XYZGEOM and XYZW.

- XYZ. This is an entry for a pre-LASERPOINT IQ 2.0 standard whose name is XYZ. You will need the file XYZ and there may also be a file called XYZW containing documentation plots.
The files for the standard you are migrating are probably in your \LP\USER_LIBI directory. Copy them to ..\Esko\Artios\ServerLib.

Adding the standard to a Style Catalog

Add the LASERPOINT IQ standard to the ArtiosCAD style catalog using Defaults in a similar way to normal ArtiosCAD standards. Start ArtiosCAD, and then open the style catalog as follows:

1. Click **Options** and **Defaults** to open the Defaults dialog box.
2. Use the right mouse button to click **Style Catalog** in the left area of the dialog box and then click **New** and **Data**.
3. Type the descriptive name for the standard as you want it displayed in ArtiosCAD.
4. Double-click the icon beside the standard name to open the dialog box for specifying the standard.

![Image of the Defaults dialog box]

5. For LASERPOINT IQ 2-4 standards:
   Type the name of the standard file without the W or GEOM suffix. In the example above with files XYZW and XYZGEOM, type XYZ.
   
   For pre-LASERPOINT IQ2 standards:
   Type the name of the standard.
   If you don't know the name of the standard, click the ... button at the end of the **Filename** field. This will open the standard Open dialog box which you can use to navigate to the proper directory and open the file.
6. Click **OK** to close the dialog and save changes. ArtiosCAD will check the file and set the standard type automatically.

You are now ready to run the standard in ArtiosCAD.
Troubleshooting newly-added INTERACT/LASERPOINT/ LASERPOINT IQ standards

Missing files
LASERPOINT IQ standards may be created based on other standards or attachments. You must copy the files for the standards to run in the ArtiosCAD environment. Any missing files will be shown in error dialog boxes when a standard is run. Remember to copy all the files – for example, if ATTACHGEOM is missing, you will also need the associated ATTACHW file.

Changing the framework
ArtiosCAD sets up a framework to execute the various types of INTERACT/LP/LASERPOINT IQ 1 standards. The framework settings are available by clicking the Advanced button.

<table>
<thead>
<tr>
<th>Interact Framework</th>
</tr>
</thead>
<tbody>
<tr>
<td>[LP/IQ 1]</td>
</tr>
<tr>
<td>Non-Standard IQ 2-4</td>
</tr>
<tr>
<td>Interact Design Standard</td>
</tr>
<tr>
<td>Designer Edition</td>
</tr>
<tr>
<td>Either</td>
</tr>
</tbody>
</table>

LASERPOINT IQ 2-4 standards may need to be set up using the INTERACT type if they used elements from before LASERPOINT IQ 2.0. This is set by changing to the standard type INTERACT/LP/IQ1, clicking Advanced, and selecting the framework Non-standard IQ2-4.

INTERACT/LP/IQ1 standards that fail to run properly can be tried with alternative frameworks by clicking Advanced and selecting one of:
• LP/IQ1
• INTERACT design standard
• Designer Edition

Adding Designer WorkBench designs to Style Catalogs
Preparation

Before you can add Designer WorkBench designs to a Style Catalog, ArtiosCAD needs to be told the location of the DWB resources. You will need to know the directories used for the DWB resources and then add these to the ArtiosCAD environment. The steps to do this are:

1. Start DataCenter Admin and double-click Server.
2. Check that there is a server set up for the drive letter where your DWB designs are located. Add a new server as necessary. For example, if your DWB designs are on the D: drive, click the Insert icon, give the new server a name and select D: as the server path. Click Insert to add the server.
4. Do the following for each DWB resource:
   - Click the Insert icon, give the resource a name, pick the server and the path for the resource. Click Insert to add the resource.
5. When complete, save the changes and close DataCenter Admin.

Adding a Designer WorkBench standard to a Style Catalog

Any DWB design can be added to the ArtiosCAD Style Catalog by using the following procedure:

1. Start ArtiosCAD.
2. Click Options and Defaults to open the Defaults dialog box.
3. Use the right mouse button to click Style Catalog in Shared defaults and then click New and Data.
4. Type the descriptive name for the standard as you want it displayed in ArtiosCAD.
5. Double-click the icon beside the standard name to open the dialog for specifying the standard.
6. Click the ... button beside the data entry area for the design name. This will show the Open dialog.
7. Change to resource view, select the resource, and check you are showing designs of type either All files or Designer Workbench Designs.
8. Select the design and click Open.
9. Close the Defaults dialog box and save changes.

You are now ready to run the standard in ArtiosCAD.

Note: The standard can be moved to sub-folders in your style catalog, if desired, to give a more structured organization.
Each parameter set can now have a default single design template defined. This means that when you create a new single design by clicking New Design on the File menu, instead of getting a blank design, the standard you have associated with the parameter set will run and the new workspace will inherit the results.

Double-clicking New Design Template opens the New Design Template dialog box for the current parameter set. Select the Use Design Template checkbox and choose a standard from one of the catalogs shown.
Only standards of type ArtiosCAD can be used as new design templates, so only those are listed in the dialog box. INTERACT, LASERPOINT, and LASERPOINT IQ standards may not be used as design templates.

The design template does not have to draw any geometry - you can simply set default variables, menus, and layers in it, and they will be copied into each new workspace made by the template.

Settings in the parameter set for the board code, bridging formula, sideness, and property defaults take precedence over those settings in the template.

The design template is used only when explicitly creating a new single design. It is not used when creating a new embedded design in Manufacturing or when moving lines to a new design with the Move To Layer tool.

**Default layers in Manufacturing**

You can specify layers that will be created in new manufacturing files at creation and in existing manufacturing files when they are opened.

To do this, do the following:

1. Start ArtiosCAD and click Options > Defaults > Startup defaults > Default MFG User Layers. The empty Default MFG User Layers dialog box will open.
2. Click **Add** and enter the name of the new default layer in the New Default Manufacturing Layer dialog box. Click **OK** when done.

3. The new layer will appear in the dialog box already selected.
4. Continue adding layers as desired, clicking **OK** when done.
5. Save and exit Defaults.

Layers which are not selected are not created automatically; however, they are available for picking in the drop-down list box in the Create Layer dialog box in Manufacturing.

![Create Layer dialog box](image)

All of the default layers, whether created in the manufacturing file or not, will also be available for selection on the View tab of any Output when the **User Defined** layer set selection is active.
Toolbars

In ArtiosCAD you can change the background of toolbars and create customized toolbars to suit your needs. As with other Defaults, you can define toolbars either on a per-machine basis (User defaults) or on a server basis (Shared defaults). Customized toolbars can contain buttons for ArtiosCAD tools, geometry macros, Outputs, and menu commands.

Customized toolbars

Customized toolbars are managed by the Customized Toolbars catalog in Defaults. ArtiosCAD displays up to 30 customized toolbars in Single Design and canvases and 30 customized toolbars in Manufacturing, with each toolbar holding a maximum of 15 items. You can
define more than 30 customized toolbars per module, but ArtiosCAD will display a random assortment in the Customized Toolbars Master Control.

3D does not offer customized toolbars.

Each item on a customized toolbar must have a unique name. If there are items with the same name (for instance, one in Shared Defaults and one in User Defaults), ArtiosCAD executes the first one it finds when you click the button on the toolbar.

Shown below is the Customized Toolbars catalog in Shared defaults. The individual folders are empty until you create customized toolbars within them.

Icons for customized toolbars

By default, customized toolbars use the icon of a person's head. You may design your own icons for customized toolbars using 24-bit color. They must be 24 pixels high by 24 pixels wide in BMP format. Set the transparent color to R=192, G=192, and B=192. Icons for Shared defaults must be saved in ServerLib, while icons for User defaults must be saved in ClientLib.

Each geometry macro and Output can have a customized icon as well. Follow the same rules for them as those listed above for a customized toolbar icon. Specify the icon in the Icon for custom toolbar group in the Properties dialog box for the geometry macro, and in the Icon for custom toolbar group on the Output Type tab of the Output's Properties dialog box. If you changed the definition of an Output to specify a custom icon, save the changes, and then exit and re-enter Defaults for the changes to be shown.

You should create any desired icons before entering Defaults to create the customized toolbar.

Making a customized toolbar

Add custom geometry macros and Outputs to catalogs and save Defaults before making a customized toolbar. To make a shared customized toolbar, do the following:

1. Start ArtiosCAD and click Options > Defaults.
2. In the Shared defaults pane, click the plus sign (+) next to the Customized Toolbars catalog to open it.
3. Right-click the appropriate catalog, click New, and then click Data on the context menu.
4. Replace **New Data 1** with the name of the new custom toolbar. Press Enter when you have entered the name and then double-click the new entry to access its Properties dialog box.

5. The Properties dialog box for the custom toolbar will appear.

6. In the top half of the dialog box, choose the tab containing the item that will be replicated on the customized toolbar. Items from each category can be added to the same customized toolbar.

   On the Toolbars tab, select the toolbar to copy from by using the **ArtiosCAD Toolbars** dropdown list box. On the Geometry Macros and Outputs tabs, expand the catalogs to access the individual geometry macros and Outputs. On the Commands tab, simply select the desired command.
7. Drag the desired tool, geometry macro, Output, or command from the top pane to the **Tools in the Custom Toolbar** group. Repeat as desired, putting up to 15 items on the customized toolbar. Shown below is act of dragging a command to the **Tools in the Custom Toolbar** group.

![Custom Toolbar](image)

8. To change the icon used for this customized toolbar in the Customized Toolbars Master Control, enter the name of the icon file you created previously and placed in **ServerLib** in the **Toolbar Icon** group.

To create a customized toolbar for users of the current machine only, create a new Customized Toolbars catalog by right-clicking in the User defaults pane, clicking **New**, selecting **Customized toolbars**, and following the procedure above for Shared defaults.

To delete an item from a customized toolbar, drag it to the Recycle Bin icon at the bottom right of the **Tools in the Custom Toolbar** group.

To delete a custom toolbar, delete its entry from the catalog.

When adding an Output or a geometry macro to a toolbar, the number ArtiosCAD assigns the button will remain static and cannot be changed by deleting other buttons.

**Note:** The title of a customized toolbar may appear incorrectly after you save it. Undock and redock the toolbar or restart ArtiosCAD to fix it. It will appear correctly thereafter.

**Colored toolbars**

Each toolbar in ArtiosCAD can have a different background color to make it easier to identify. Color definitions in User defaults override those set in Shared defaults.
Colors on standard toolbars

To change the background color of a standard ArtiosCAD toolbar, do the following:

1. Start ArtiosCAD and click **Options > Defaults**.
2. Open the appropriate Customized toolbars catalog (either the one in Shared defaults or one in User Defaults) by clicking the plus sign (+) next to it.
3. Double-click **ArtiosCAD Toolbars colors**. The ArtiosCAD Toolbars colors dialog box will appear.

4. Click the button of the toolbar to change and click **Toolbar color** to open the Toolbar color dialog box.
5. Click the color to set as the toolbar background and click OK.
   To reset the toolbar background color to the default, click Set to System Color and then click OK.
6. The Toolbar color button in the ArtiosCAD Toolbars colors dialog box will change to the color you selected.
7. Repeat steps 4 and 5 as desired. When done, click OK to return to Defaults, or click Cancel to discard the changes.

Colors on customized toolbars
To change the background color of a customized toolbar, do the following:
1. Start ArtiosCAD and click Options > Defaults.
2. Open the Customized toolbars catalog (either the one in Shared defaults or one in User Defaults) by clicking the plus sign (+) next to it.
3. Open the Designer customized toolbars catalog or the Manufacturing customized toolbars catalog by clicking the plus sign (+) next to it.
4. Double-click the customized toolbar to change to open its Properties dialog box.
5. Click Toolbar color.
6. The Toolbar color dialog box will appear. Click the color to set as the toolbar background and click OK.

To reset the toolbar background color to the default, click Set to System Color and then click OK.

7. The Toolbar color button in the customized toolbar's Properties dialog box will change to the color you selected.

8. Repeat as desired for other customized toolbars. When done, click OK to return to Defaults, or click Cancel to discard the changes.

Toolbar Hover Color

The ArtiosCAD Toolbar Hover Color entry in the Customized Toolbars catalog sets the hover color and gradient use for the toolbars. ArtiosCAD shows the current hover color as the background of the Hover color button.

Clicking Hover color leads to a color palette in which you can choose a new hover color.
Use Gradient toggles the display of a gradient on the hover color. The gradient is not adjustable.

**Shortcuts**

Shortcuts are keyboard sequences that activate ArtiosCAD commands, such as pressing CTRL-N for a new single design workspace. Shortcuts are organized by where they are used: 3D, Design (single designs and canvases), and Manufacturing. Shortcuts can also be assigned to Outputs and geometry macros.

Every menu command can have a shortcut assigned to it.

Shown below are the categories for menu commands in the Shortcuts Catalog in Shared Defaults.
To create menu command shortcuts in User Defaults, right-click in the User Defaults pane, click New, and then click Shortcuts. A Shortcuts Catalog is created with the three entries for the types of menu command shortcuts. Save the User Defaults after creating the Shortcuts Catalog but before adding to it.

**Assigning a shortcut to a menu command**

To assign a shortcut to a menu command, do the following:

1. Start ArtiosCAD and click Options > Defaults.
2. Scroll down the list of Shared Defaults, and open the Shortcuts Catalog by clicking the plus sign (+) next to Shortcuts.
3. Double-click the category for the desired new shortcut. In this example, the Direction menu command on the View Options sub-menu of the View menu will be assigned a shortcut, so double-click the Design and Canvas Shortcuts category. The Design and Canvas Shortcuts dialog box opens as shown below.
4. Scroll down to the View menu, and double-click **Direction** under View Options.
5. An empty Shortcut dialog box appears. Press the key combination to assign to the Direction command. For this example, press ALT-D. The key sequence and the command to which it will be assigned appear as you press it. The command is followed by the type of shortcut (system or user) and the area of ArtiosCAD in which it is active.

![Shortcut dialog box](image)

6. Click **OK** to return to the Design and Canvas Shortcuts dialog box.

7. Note that the newly-assigned command now appears in the **Key** column of the dialog box.

8. Click **OK** in the Design and Canvas Shortcuts dialog box.
9. Click File > Save to save the Shared Defaults. The new shortcut is now ready for use in Builder and Designer.

Assigning a shortcut to an Output

To assign a shortcut to an Output, open the Properties dialog box for that Output. Enter the shortcut in the Shortcut: group on the Output Type tab as shown below.

Assigning a shortcut to a geometry macro

To assign a shortcut to a geometry macro, open the Properties dialog box for that geometry macro and enter the shortcut in the Shortcut: group as shown below.
Shortcut uniqueness and priority

When a shortcut in Shared Defaults is assigned a key sequence, any other shortcuts having the same key sequence are shown. Only shortcuts in Shared Defaults and those in the current machine's User Defaults are compared. Shortcuts in other machines' User Defaults are not compared with those in the current machine's User Defaults.
The shortcut at the top of the list has the highest priority and will prevent other shortcuts assigned the same key sequence in the same module from working. However, if the other key sequences are in other modules, there will be no conflict when the shortcut is used.

Shortcuts in User Defaults take priority over those in Shared Defaults. Within User Defaults, menu items take priority over geometry macros, and geometry macros take priority over Outputs. If a shortcut is assigned to the same command in all three subcatalogs, the one in Design is listed first, then the one in Manufacturing, and finally the one in 3D.

Notes and warnings for Shortcuts

Only the first 300 shortcuts defined for geometry macros are active.

Counter layouts use the same shortcuts as Manufacturing.

If the same shortcut is assigned to a menu item that displays in both single designs and canvases, it won’t work in one of them, but which one is random and will change.

When a geometry macro has a shortcut, and this geometry macro is present on a customized toolbar, and the geometry macro opens a dialog box, the button on the customized toolbar is not depressed when the geometry macro is activated by the shortcut.

There is only one set of user shortcuts per machine.

If you change shortcuts and exit without saving the changes, the uniqueness tests for successive changes will not be accurate.

Enter can not be used as any part of a shortcut.

Some shortcuts are permanent as shown in the table below.

<table>
<thead>
<tr>
<th>Table: Permanent Shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
</tr>
<tr>
<td>Run Standard</td>
</tr>
</tbody>
</table>
### Tack Bridging

Tack bridging formulae are stored in the Tack Bridging Catalog.

Shown below is a sample exterior metric formula.
Set the distance between tack bridges in the **Tack distance**: field and set the width of each tack bridge in the **Tack width**: field.

The **One-sided** and **Two-sided** option buttons control if the tack bridges are cut only toward the interior of the carton or toward the interior of the carton and the exterior of the carton.

The **Simple**, **90 degree**, **120 degree**, **135 degree**, and **Arc tack bridge** option buttons all set the style of tack bridge as shown in the pictures in the dialog box.

Click **OK** to save the changes to the Tack Bridging formula and return to Defaults, or click **Cancel** to return to Defaults, discarding the changes.

---

**Bridging Formulae**

ArtiosCAD’s default bridging formulae are stored in the Artios subfolder of the Bridging Catalog. There are corrugated and folding carton bridging formulae in Imperial and metric units. Shown below is the Corrugated - Metric bridging formula set for evenly spaced bridges.
The drop-down list box controls all the other settings in this dialog box. The No bridges selection removes all other settings from the dialog box. Evenly spaced and Inset distance from line end are explained in the following sections.

Evenly spaced bridging formula

An evenly spaced bridging formula applies bridges based on the length of the line or arc. The size of the bridges is determined by the length of the line.

There are three groups of parameters in an evenly spaced bridging formula - Bridges on lines, Bridges on arcs, and Width of Bridges.

Bridges on lines and Bridges on arcs groups

The Bridges on lines and Bridges on arcs groups work similarly. A list of limits determines the number of bridges applied to lines or arcs. Shown below are the two groups in the Corrugated - Metric formula.

If the length of the line or arc is less than or equal to the value in the field, the integer to the left of the field is the number of bridges applied to the line or arc. If the length of the line or arc is greater than the value in the field, the limit is skipped and the next limit is applied. Click Add limit to add a limit; click Delete limit to delete a limit.
After all the limits are met, the lines and arcs are bridged according to the value shown after then bridge every X.XX where X.XX is the difference between the last two limits.

There must be at least one limit per group.

**Width of Bridges group**

The **Width of Bridges** group works slightly differently than the others in that there are two values to set per limit - the width of the bridge and length of the bridge for the limit.

<table>
<thead>
<tr>
<th>Width of Bridges</th>
<th>If length &lt;=</th>
<th>If length &lt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.25</td>
<td>3.50</td>
<td></td>
</tr>
<tr>
<td>2.00</td>
<td>15.00</td>
<td></td>
</tr>
<tr>
<td>5.00</td>
<td>25.00</td>
<td></td>
</tr>
<tr>
<td>10.00</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The length of the bridges will be the value on the left if the line or arc length is less than or equal to the length on the right.

Click **Add limit** to add a limit; click **Delete limit** to delete a limit. There must always be at least two limits - one less than or equal limit, and one if longer limit.

**Inset distance from line end bridging formula**

An **Inset distance from line end** bridging formula insets a bridge at each end of a line and then evenly spaces the bridges between the two that were inset.

<table>
<thead>
<tr>
<th>Inset properties</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum rule length to bridge:</td>
<td>1/2</td>
</tr>
<tr>
<td>Inset distance:</td>
<td>3/4</td>
</tr>
<tr>
<td>Minimum distance between bridges:</td>
<td>1+1/2</td>
</tr>
<tr>
<td>Maximum distance between bridges:</td>
<td>4</td>
</tr>
<tr>
<td>Min rule length for full inset distance:</td>
<td>3+1/2</td>
</tr>
</tbody>
</table>

Rules shorter than the **Minimum rule length to bridge** will not be bridged. Rules whose length is between the Minimum rule length to bridge value and the **Min rule length for full inset distance** will have only one bridge. Rules longer than the value in **Min rule length for full inset distance** will have the two inset bridges, plus more bridges if the two inset bridges are further apart than the value in **Maximum distance between bridges**. The **Inset distance...**
is the distance from the ends of the line to the centers of the inset bridges. Bridge centers can be no closer than the **Minimum distance between bridges**, and cannot be further apart than the **Maximum distance between bridges**.

The **Advanced** tab adds two parameters to the group:

<table>
<thead>
<tr>
<th>Inset factor limit</th>
<th>2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inset factor</td>
<td>0.285</td>
</tr>
</tbody>
</table>

These two fields are used when migrating bridging formulae from The Designer WorkBench into ArtiosCAD. Set the **Inset factor** to 0.285. The One Bridge Minimum equals the Minimum distance to bridge. The **Inset Factor Limit** is half the Maximum distance between bridges.

### Inset Bridge Formula

| If line length < One Bridge Minimum, no bridges |
| Calculate $\text{BiSep} = \text{LineLength} - 2 \times \text{InsetDistance}$ |
| $\text{BiSep}$ |
| $\text{InsetDistance}$ |

| If $\text{BiSep} < \text{Minimum Distance to Bridge}$, 1 bridge centered |
| If $\text{BiSep} < \text{Inset Factor Limit}$, 2 bridges at $\text{InsetFactor} \times \text{LineLength}$ |
| $\text{InsetFactor} \times \text{LineLength}$ |

| If $\text{BiSep} > \text{Maximum}$, add additional bridges, evenly spaced |
| Else two bridges at inset distance |

The options in the **Width of Bridges** group work the same for Inset formulae as they do for Evenly spaced formulae.

---

### Working with tuning catalog entries in Defaults

You will most likely need to create your own tuning catalog entries for PDF or DWG/DXF files as each supplier may produce them differently. The procedures for working with DWG/DXF tuning files are the same as they are for PDF files; substitute the type of file you are working with as appropriate. Follow the instructions below to work with tuning catalog entries.

### Creating a PDF vector import tuning catalog entry

ArtiosCAD comes with two example tuning files for importing PDF files as lines. However, since people can create PDF files in many different ways, you may need many different tuning catalog entries to accommodate them.
To create a new PDF vector import tuning file, do the following:

1. Log in as Administrator or as a user with administrative privileges.
2. Start ArtiosCAD.
3. Click **Options > Defaults**.
4. In the **Shared defaults** pane, scroll down the list to **Import Tuning Table**. Optionally, expand it by clicking the plus sign (+) next to it.
5. Right-click **Import Tuning Table** (or a folder underneath it if you expanded the catalog) and click **New > Data** on the context menu.
6. In the **Select import type** list box, select **PDF** and click **OK**.
7. Enter a name for the new tuning file and press **Enter**.

   A tuning catalog entry has been created with specified name.

---

**Opening a PDF vector import tuning catalog entry**

To open a PDF vector import tuning file for editing, do the following:

1. Start ArtiosCAD.
2. Click **Options > Defaults**.
3. In the **Shared defaults** pane, scroll down the list to **Import Tuning Table**.
4. Expand the catalog and double-click the name of the tuning entry to open for editing.

   A dialog box appears showing the tuning for this catalog entry.
Editing a PDF vector import tuning catalog entry using a template

This procedure requires knowledge of the existence and design of the layer structure of your incoming PDF files. PDF files can have layers but also can be flattened (when all elements are in one layer). Ask the senders of PDF files about the layer structure they use, or examine them in a program that can edit PDFs, such as Adobe Illustrator. If the files are coming from Adobe Illustrator, and you want the layer information to be preserved, the Create Acrobat Layers from Top-Level Layers option must be selected when saving the file in PDF format, otherwise the file will be flattened and no layer information will be preserved.

To edit a PDF vector import tuning catalog entry, start ArtiosCAD and follow the instructions in Opening a PDF vector import tuning catalog entry to open it.

Once you have the tuning catalog entry open, set the options according to the procedure described below.

1. In the Import As group, select either Oneup, Layout, or Auto-Detect. Oneup means that this tuning catalog entry will always be used with PDF files containing single designs. Layout always processes the PDF files as if they contain multiple single designs. Auto-Detect reads the geometry of the vectors and process the file appropriately.

2. Set the Design Side and Die Side list boxes to appropriate values (Inside or Outside and Die Back Side or Die Knife Side) for the incoming PDF data.

3. In the Flute or Grain group, choose either Vertical or Horizontal for the direction of the material used to manufacture the workspace.

4. The controls in the Mapping group determine how ArtiosCAD converts vectors from the PDF data into design lines. The easiest way to set this up is to use an existing PDF file as a template. You may need to do this for each supplier of PDF files (in separate tuning files) depending on the software they use to create them.
5. Click **Template**.
6. Select the PDF file to use as a template and click **Open**. If the PDF file contains more than one page, select the page to use as the template.
7. In the preview image, select a line and then set what it should be in the ArtiosCAD Design Attributes group. In the example below, the edge was selected and set to be cut lines in the Main Design layer at pointage 2. The **Zoom** controls above **Apply** and **Help** let you change the view so you can select the lines you need to tune more easily.

8. Continue selecting lines in the preview and defining their properties in the **ArtiosCAD Design Attributes** group. If you make a mistake, select a line of tuning and click **Delete**. ArtiosCAD applies the tuning entries in a top-down order. In the example above, it will set all the lines with color Artios_cut to be Cut lines, and then it will set all the lines with color Artioscrease to be Crease lines. Shown below is the same dialog box as above with more line types tuned. You can change the processing order by selecting a line of tuning and clicking the up and down arrows at the edge of the group control.
9. After you have finished selecting all the lines in the preview to tune, click Insert to add a final line of tuning. This final line of tuning will send all lines that are not explicitly tuned to the Annotation layer as 2-point Annotation lines.
   a) For this final line of tuning, set the controls in the PDF attributes group to any, any, and any.
   b) In the ArtiosCAD Design Attributes group, set the Layer to Annotation, the Line type to Annotation, and the Pointage to 2.

10. Click Color Names to change the names of the colors coming in from the tuning template. In the Color Names dialog box, you can rename an existing color by selecting it and changing the Name: field. For example, if you have a color defined as 100% magenta, 30% yellow, and 15% black, you could select it and rename it reddish. You can also insert and delete color definitions as desired using Insert and Delete, but selecting lines in the template is the intended way of inserting color names initially.
   a) There are two colors with special meaning. White matches all paths that have no color assigned or that have 0% for all components. Uncolored matches all paths that are not rendered in the PDF file, such as guides and clipping paths.

11. Click Options to open the PDF Import Options dialog box.

   a) Import text as outlines controls if text is imported or ignored and also controls the availability of the two sub-options. Add to annotation layer adds the text as outlines to an Annotation layer using the Annotation line type. Add as fills to graphics layer adds the text to a Graphics layer and fills it with the font color specified in the PDF file.
b) **Change beziers to arcs** changes beziers to arcs during the import process instead of having to use the tool later.

c) **Unfiltered items to graphics layer** sends strokes and fills that were not processed by a tuning entry to the Graphics layer.

d) Click **OK** to return to the tuning dialog box.

12. Click **OK** to complete the editing of the tuning catalog entry and return to Defaults.

13. Click **File > Save** to save the changes to Defaults.

14. Click **Yes** to confirm overwriting Defaults.

### Editing a PDF vector import tuning catalog entry manually

If you do not configure the PDF line type mapping using a template as described in the previous section, configure it manually by following the instructions below.

Once you have the tuning catalog entry open, set the options according to the procedure described below.

1. In the **Import As** group, select either **Oneup**, **Layout**, or **Auto-Detect**. **Oneup** means that this tuning catalog entry will always be used with PDF files containing single designs. **Layout** always processes the PDF files as if they contain multiple single designs. **Auto-Detect** reads the geometry of the vectors and process the file appropriately.

2. Set the **Design Side** and **Die Side** list boxes to appropriate values (**Inside** or **Outside** and **Die Back Side** or **Die Knife Side**) for the incoming PDF data.

3. In the **Flute or Grain** group, choose either **Vertical** or **Horizontal** for the direction of the material used to manufacture the workspace.

4. The controls in the **Mapping** group determine how ArtiosCAD converts vectors from the PDF file into design lines.

   a) In the **PDF Attributes** group, **Layer**: selects the layer in the PDF file containing the lines to process for import into ArtiosCAD.

   b) **Graphic Type**: can be a few different choices. **Any** is any stroke, fill, or bitmap. **Any_stroke** matches any stroke and **fill** matches any fill. Any positive number is a stroke width.

   c) The **Color Names**: field and corresponding dialog box are meant for use when defining tuning using a template. Ignore them when setting tuning manually.
d) In the ArtiosCAD Design Attributes group, set the Layer:, Line Type:, and Pointage: fields to the type of ArtiosCAD line that will be created for each line that matches the parameters set in the PDF Attributes group. Use PDF layer name names the ArtiosCAD layer the same as the PDF layer.

e) The mapping entries are processed in a top-down order. To change the order, select an entry, then use the up and down arrows at the side of the control to move the selected entry.

5. After you have finished selecting all the lines in the preview to tune, click Insert to add a final line of tuning. This final line of tuning will send all lines that are not explicitly tuned to the Annotation layer as 2-point Annotation lines.

a) For this final line of tuning, set the controls in the PDF attributes group to any, any, and any.

b) In the ArtiosCAD Design Attributes group, set the Layer to Annotation, the Line type to Annotation, and the Pointage to 2.

6. Click Options to open the PDF Import Options dialog box.

   ![PDF Import Options dialog box]

   - **Import text as outlines** controls if text is imported or ignored and also controls the availability of the two sub-options. **Add to annotation layer** adds the text as outlines to an Annotation layer using the Annotation line type. **Add as fills to graphics layer** adds the text to a Graphics layer and fills it with the font color specified in the PDF file.
   - **Change beziers to arcs** changes beziers to arcs during the import process instead of having to use the tool later.
   - **Unfiltered items to graphics layer** sends strokes and fills that were not processed by a tuning entry to the Graphics layer.

   - Click OK to return to the tuning dialog box.

7. Click OK to complete the editing of the tuning catalog entry and return to Defaults.

8. Click File > Save to save the changes to Defaults.

9. Click Yes to confirm overwriting Defaults.

---

**Line types**

**Line types:**
• Distinguish between rules for flat dies and rules for rotary dies.
• Distinguish between lines which should be burnt on their outer edge (such as the die wood edge) and those which should be burnt on their inner edge (such as lower stripping holes).
• Support pointage of 1.5.

Line information in older workspaces will be automatically converted with no loss of information when the workspaces are opened in ArtiosCAD.

The category in which a line type resides determines its properties and also how it is processed during output. Of particular note are the Inside Edge and Outside edge categories. When line types belonging to these categories are output to a laser, they are offset to compensate for their thickness. Tool outlines must form complete loops for the direction of the offset to be well defined. Line types in the Center Edge category have no offset - the laser beam burns down their middle.

Only rules should have bridges defined, and only tool outline line types should have tack bridges. Other line types should be created without bridges. Only cut lines should have nicks.

**Table: Line Type Categories**

<table>
<thead>
<tr>
<th>Line type category</th>
<th>Examples</th>
<th>Properties / Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generic rules</td>
<td>Cut, crease, reverse crease, glue assist, balance rules, chop knives</td>
<td>Width, bridges, subtype</td>
</tr>
<tr>
<td>Rules</td>
<td>1/8 x 1/8 perf, 1/4 x 1/4 cut/crease, zipper rule, punch hole, side bevel</td>
<td>Width, Bridges, Generic type, height, name, rule</td>
</tr>
<tr>
<td></td>
<td>cut, specific rotary cut rule. Defined in the rule table.</td>
<td>geometry, rotary teeth spacing</td>
</tr>
<tr>
<td>Center edge</td>
<td>Unknifed diecut, unknifed lower, unknifed upper</td>
<td>Width, tack bridges, subtype</td>
</tr>
<tr>
<td>Inside edge</td>
<td>Lower stripping hole, Die registration hole</td>
<td>Tack bridges, subtype. Offset is applied inward</td>
</tr>
<tr>
<td>Outside edge</td>
<td>Die edge, Lower stripping edge, stripping block</td>
<td>Tack bridges, subtype. Offset is applied outward</td>
</tr>
<tr>
<td>Etch</td>
<td>Die etch, lower stripping etch, upper stripping etch</td>
<td>Subtype. No offset applied during laser output.</td>
</tr>
<tr>
<td>Laser output</td>
<td>Tool 1, Tool 2, Tool 3, .. increased from 20 to 30 laser line types.</td>
<td>None. Laser output will pass beam width for DDES,CFF2</td>
</tr>
<tr>
<td>Annotation</td>
<td>Annotation, Print image, Print registration, Bleed, Varnish</td>
<td>None</td>
</tr>
<tr>
<td>Sample output</td>
<td>Sample cut, sample partial cut, sample with grain crease, sample</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>cross grain crease</td>
<td></td>
</tr>
<tr>
<td>Line type category</td>
<td>Examples</td>
<td>Properties / Notes</td>
</tr>
<tr>
<td>--------------------</td>
<td>----------------------------------------------</td>
<td>--------------------</td>
</tr>
<tr>
<td>Counter output</td>
<td>With grain channel, Cross grain channel, Crease end tool, Periphery tool</td>
<td>None</td>
</tr>
</tbody>
</table>

**Subtypes**

A **subtype** is a definition to further classify a type of line - it is a label only and is used for sorting the tool assignment data when performing a CAM Output. Subtypes can have their own entries in Advanced plotting styles. Up to 100 subtypes can be defined in the Subtype Mapping Catalog.

To define a subtype, select it, and enter the description of the subtype in the **Description** field. Repeat as desired, and when done, click **OK** to save the definitions or **Cancel** to ignore them and return to Defaults.
Plotting Styles

Plotting styles control the appearance of lines on screen and how lines are drawn or made on printers, plotters, samplemakers, and countercutters. Plotting styles control the colors, widths, and styles used. They also control which physical tool an output device uses to construct the line.

**Note:** Plotting styles are not used to configure CAM outputs such as lasers and Kongsberg DieSaws; output to those types of devices is configured using the CAM Tooling Setup catalog.

Each plotter, samplemaker, and countercutter should have its own plotting style configured as each has a different tool configuration. Most known output devices have plotting styles defined in the example CAM Outputs. To view the example CAM Outputs, open the example Defaults by selecting User Defaults, then clicking **File > Open > Example Defaults**. Expand the Plotting Style Catalog in the Example defaults pane, find the one you want, and drag it into the Plotting Style Catalog in the Shared defaults pane. The names may contain CAM, but rest assured these are for plotters, samplemakers, and countercutters.
Plotting styles may be either simple (the default) or advanced. Simple plotting styles configure the line color, line width, line style, and tool number based solely on a line type. Advanced plotting styles do the same configuration, but can be based on line type, subtype, and pointage instead of just line type. An Advanced plotting style can not revert to a Simple plotting style.

**Working with simple plotting styles**

When the Advanced checkbox in the Line Types group is clear, the current plotting style is considered simple. In a simple plotting style, the line types are organized on five tabs - Design, Manufacturing, Sample, Tooling, and Counter.

On each tab are the line types relevant to each label. For examples, the Design tab lists such types as Cut, Crease, Partial cut, and so forth. The Manufacturing tab contains line types
used in the Manufacturing module, such as **Stripping Rule**, **Die board edge**, and **Unknifed blanker**. The same is true for the other tabs.

When looking at the line types, shown first is the line type name, then an example of the line type using the attributes selected in the right pane, and finally the tool number. When creating a new plotting style, all the tool numbers are set to zero by default.

<table>
<thead>
<tr>
<th>Name</th>
<th>Example</th>
<th>Tool Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Crease</td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>Partial cut</td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>Reverse partial cut</td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>Reverse crease</td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>Heli crease</td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>Unknifed diecut</td>
<td></td>
<td>0</td>
</tr>
</tbody>
</table>

Creating a new simple plotting style

To create a completely new simple plotting style, do the following:

1. Right-click the **Plotting Style Catalog** entry in Defaults and click **New > Data** on the context menus that appear.
2. Enter a name for the new plotting style and press ENTER.
3. Double-click the style to access its property page in order to change its defaults. The window should appear similar to the one shown below.
On the left is a set of five tabs that correspond to the different categories of lines. Each tab has a control showing the line name, the line style, the line color, and the currently-assigned tool number. On the right are controls to set those attributes.

Checking the **Output Only** checkbox makes this plotting style available only when configuring an Output - it is hidden when changing the plotting style in the View Mode.

**Save as XML** saves the plotting style as an XML file for use with the WebCenter Viewer.

For outputs, the **tool number** applies only when this plotting style will be used in an Output definition using a CAM driver.

For outputs, the **Color** and **Line Width** apply only when this plotting style will be used in an Output definition using either a Windows driver or a graphic CAM driver such as the PCL driver used for sample printing.

**Copy From Style** copies attributes of another plotting style into the current one.

4. Click each line style and set the line attributes as desired.
5. Click **OK** to save the changes to return to Defaults, or click **Cancel** to discard them and return to Defaults.
Changing the line attributes in a simple plotting style

To change the attributes of a line in a simple plotting style, do the following:

1. Open Defaults and double-click the plotting style to change.
2. Click the tab for the class containing the lines you wish to modify.
3. Select the line to modify in the Line Types group.
4. Select the new attributes - Color, Line Width, Line Style - from their respective lists in the Attributes group.
5. If desired, change the Tool Number.
6. Click OK to save the changes and return to the Plotting Style catalog, or click Cancel to discard the changes.

Creating a new plotting style by copying from another plotting style

To base a new plotting style on an existing plotting style, do the following:

1. Right-click the Plotting Style Catalog entry in Defaults and click New > Data on the context menus that appear.
2. Enter a name for the new plotting style and press enter.
3. Double-click the style to access its property page in order to change its defaults.
4. Click Copy From Style.
5. Select the plotting style to copy from on the left.
6. Select the line type categories to copy by checking the appropriate checkboxes in the Line Type Subset group. None are selected by default.
7. Select or clear the Copy color and style and Copy tool numbers checkboxes as appropriate.
8. Click **OK** to copy the styles and attributes or click **Cancel** to return to the Plotting Style dialog box.

**Working with Advanced plotting styles**

When the **Advanced** checkbox is checked, the plotting style is considered **Advanced**. Configuring an Advanced plotting style takes slightly more time than a Simple plotting style but it allows greater flexibility.

**Creating a new Advanced plotting style**

To create a completely new Advanced plotting style, do the following:

1. Right-click the **Plotting Style Catalog** entry in Defaults and click **New > Data** on the context menus that appear.

2. Enter a name for the new plotting style and press enter.
3. Double-click the style to access its property page in order to change its defaults and click the **Advanced** checkbox. You will be asked to choose whether to keep the definitions from the simple style or to create a blank style. For the purposes of this workflow, choose **Initialize to blank style** and click **OK**.

4. The blank Advanced style appears as shown below.

The **Attributes** group for an Advanced plotting style works in the same way as it does for a Simple plotting style. The **Line Types** group, however, works differently as explained below.

5. In a newly-created advanced plotting style, as seen in the **Line Types** group, all lines are configured to be shown as solid line style, black color, 1.00 width, and tool 0.
Advanced plotting styles work by assigning line attributes based on conditions defined in a line style statement. If a line meets a line style condition, it is assigned whatever attributes are assigned in the line style statement. The (Remainder) statement applies to line styles which meet none of the conditions. There will always be a (Remainder) statement; it cannot be deleted, but its attributes can be modified as desired.

6. To add line style statements, do the following:

   • Click Insert. A new entry appears in the table and the corresponding ArtiosCAD syntax is shown in the Selection: field. By default, this new entry is solid line style, black color, 1.00 width, and tool 0.
• Click **Types** to open the Types dialog box. All line types other than **Annotation** are selected by default. Select the line types to designate in this line style condition. Click category tabs (**Design**, **Sample**, **Tooling**, **Counter**, and **Manufacturing**) to choose from lists of line types in those areas of ArtiosCAD. **Select All** selects all the line types on each tab. **Invert Selection** reverses whatever is selected - each style that is checked becomes cleared and each style that was clear becomes checked. Your selection will appear in ArtiosCAD syntax in the field below the checkboxes.
• Click **OK** to save this selection and return to the Plotting Style properties dialog box or **Cancel** to ignore this selection and return to the Plotting Style properties dialog box.

• Once back at the Plotting Style properties dialog box, click **Subtypes** to open the Subtypes dialog box and choose which subtypes to include in this line style definition. The ArtiosCAD syntax for your selection will appear in the field beneath the checkboxes.
• **Click OK** to save this selection and return to the Plotting Style properties dialog box or **Cancel** to ignore this selection and return to the Plotting Style properties dialog box.

• **Click Pointages** to open the Pointages dialog box. Check or clear the checkboxes as desired. The ArtiosCAD syntax for your selection will appear in the field beneath the checkboxes.
• Click **OK** to save this selection and return to the Plotting Style properties dialog box or **Cancel** to ignore this selection and return to the Plotting Style properties dialog box.

• Do not forget to also change the line attributes (color, line width, line style, and tool number) if you do not want them to be the default of black, 1.00, solid, and 0. Shown below is an example of crease line subtypes 0 through 2 and 4 through 5, pointage 0 through 1 and 2 and greater made to be red, have a line width of 1.00, a style of dot-dash, and output on tool 2.

• If you are familiar with ArtiosCAD syntax, you may edit the **Selection: **field directly.

7. Repeat step 5 for each line style statement you wish to make. Shown below is the Artios.Pointage style which is based on line pointage; it uses a different color and tool number for each pointage.
8. When you have finished adding line style statements, click OK to save the changes to the plotting style or click Cancel to ignore them and return to Defaults.

9. Save the Defaults by clicking File > Save and clicking Yes when prompted to overwrite the existing Defaults.

Converting a simple plotting style to an Advanced plotting style

When you convert a simple plotting style to an Advanced plotting style by checking the Advanced checkbox in a simple plotting style definition, you can choose to preserve the line style definitions, or you can initialize the Advanced plotting style with no values. Preserving the settings of the simple plotting style results in an Advanced plotting style similar to the one shown below. Initializing a blank plotting style results in having to define every line type as described in the previous section. In either case, edit the properties as desired. When done, click OK to accept the changes, or click Cancel to discard them.
ArtiosCAD provides a series of generic rule types such as cut and crease. These are used at the design phase when how the line is cut or creased is unimportant or not known. There are other generic rule types, for example, for cut-crease lines. It is often necessary to specify that a cut-crease line is in fact ½” cut by ½” crease with crease used as the end land. In this case, a special rule should be used.

Special rules may also be used for simple cut and crease rules to allow more specific control during manufacturing. For example:

- Helmold 3pt 0.937” cut rule
- Böhler 3pt 23.6mm SN1 notched cutting rule

Specific bridging methods, rule widths, subtypes (for special cutting characteristics), and labels can be associated with special rules which aid in the flat and rotary die manufacturing process. Shown below is the Special Rule Types Catalog in Defaults.
When editing a special rule, the Properties dialog box will have one or two tabs depending on the class of rule. All special rules have a **Manufacturing** tab with options such as pointage, subtype, rule height, flat rule or rotary rule, and so forth. Special rules that require more information to manufacture, such as perf, have a **Special Rule** tab in which rule-specific parameters are set, such as length of cut and crease, land length, land options, and so forth.

**Manufacturing tab for special rules**

Shown below is an example of the Manufacturing tab for 3-point rotary cut rule in Imperial format.
Pointage sets the pointage of the rule. You can either select a value from the drop-down list box or type your own.

Subtype sets the subtype of the rule. The subtype is used to configure specific manufacturing options in a CAM Tooling Setup.

Rule height and Rule Cost set the height and cost of the rule respectively. This information is used in line type legends and DDES-3 files only.

The text in the Rule Label field is printed when rule labels are enabled in the View Mode dialog box or in Outputs.

The Generic Type field is used to determine if more configuration options are needed on a second tab. For example, the cut and crease generic types do not require more configuration information, but the perfs and cut & crease types do.

The options in the Die Representation group determine how the rule is manufactured. Use pointage sets the slot width to the pointage * 0.014 inches. Design sets the slot in the die so that it follows the design of the special rule, such as waves in a wave rule. The slot width is the pointage * 0.014 inches. Slot lets you specify a custom slot width independent of the pointage.

Bridge formula for the rule path tells the rule which bridging formula to use. Bridge on teeth controls whether or not the rule has teeth, and what the tooth size, tab width, and which bridging formula to use.

Nominal tooth spacing refers to the customary size of the teeth on rotary rule. The Actual spacing is the distance between each tooth measured around the cylinder at cylinder level. The easiest way to measure this value is to mark off the distance between 10 teeth on a cylinder, and measure around the cylinder with an accurate tape measure, making sure to use the same point for the start and end. Divide by 10 to get the Actual spacing.

The Cylinder diameter is the cylinder for which this rule was made. It is used ONLY to compute tooth spacing when other-sized cylinders use this rule.
If you enter a cylinder diameter and an actual spacing value, ArtiosCAD can compute the tooth spacing when other die cylinders are used. This means that you do not have to enter separate special rules for each diameter cylinder.

Table: Rule Tooth Values

<table>
<thead>
<tr>
<th>Common cylinder diameters</th>
<th>Tooth Spacing</th>
<th>Result from</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Nominal</td>
<td>Actual</td>
</tr>
<tr>
<td>Inch</td>
<td></td>
<td></td>
</tr>
<tr>
<td>21.000</td>
<td>0.500</td>
<td>0.471</td>
</tr>
<tr>
<td>19.1875</td>
<td>0.500</td>
<td>0.469</td>
</tr>
<tr>
<td>14.125</td>
<td>0.500</td>
<td>0.458</td>
</tr>
<tr>
<td>11.500</td>
<td>0.500</td>
<td>0.450</td>
</tr>
<tr>
<td>10.1875</td>
<td>0.500</td>
<td>0.444</td>
</tr>
<tr>
<td>7.000</td>
<td>0.500</td>
<td>0.423</td>
</tr>
<tr>
<td>Metric</td>
<td></td>
<td></td>
</tr>
<tr>
<td>530.00</td>
<td>11.00</td>
<td>10.36</td>
</tr>
<tr>
<td>487.36</td>
<td>11.00</td>
<td>10.31</td>
</tr>
<tr>
<td>300.00</td>
<td>11.00</td>
<td>9.92</td>
</tr>
<tr>
<td>250.00</td>
<td>11.00</td>
<td>9.73</td>
</tr>
</tbody>
</table>

The tooth spacing is different for different cylinder diameters because when the rule is bent, it bends around the neutral axis. The neutral axis is the point in the rule that neither gets longer nor shorter when the rule is bent into a circular arc. The position of the neutral axis will be different for different types of rule. For example, some 6pt or 3pt rule will have the neutral axis a little closer to the top of the rule than simple 3pt rule. This is because the 6pt part is harder to bend than the 3pt part towards the bottom. Of course, the bottom of the rule has teeth cut out of it, so it is very easy to bend. Normal 3pt toothed rule would have the neutral axis about half way between the top of the tooth notch and the top of the rule.

As the cylinder diameter gets smaller, the teeth will get closer together, but the distance along the neutral axis will remain unchanged. The position of the neutral axis can be computed from the values given. It can then be used to calculate the tooth spacing for any diameter.
Length of adjustment for blend is used to calculate tooth positions after bending the rule. The entry in this field is derived from the table accessed by clicking the f(x) button.

The **Flat rule** and **Rotary rule** option buttons designate the kind of rule. When **Flat Rule** is chosen, click the Browse button (…) at the end of the **Associated rotary rule** field to choose the associated rotary rule.

In the Bend around corner group, **Rotary to flat rule** and **Flat to rotary rule** determine which is bent when a rule path bends around a corner when making a rotary die. **Extension past corner** sets the amount of rule to keep after the bend. **Angle at which to use rotary rule** sets the angle at which to switch from using flat rule to using rotary rule. The angle is measured from the horizontal axis.

When the option is set to **Flat to rotary rule**, ArtiosCAD will choose the flat to rotary option provided that the length of the vertical distance for flat in the picture below is less than the **Maximum vertical distance for flat** in the Rule Path Params catalog in the manufacturing parameter set. Note that the **Maximum vertical distance for flat** in the rule path parameters may need to be increased to get this desired result.
For a sufficiently large chamfer, ArtiosCAD will use the **Wrap rotary to flat** option. The picture below shows the wrap points for different size blends and chamfers.

### Special rule tab for special rules

The **Special Rules** tab is different for each kind of special rule. For example, for a perf rule, it looks like this:
But for a scallop rule it looks like this:

For wave and zig zag rules, the **Nick on top** option is available:
You probably already know the parameters for the rule you are configuring; enter the values and click OK to save the changes to the special rule and return to Defaults, or click Cancel to discard the changes.

Multi-Perf Overview

*Multi-perf* is perforation rule with a repeating pattern of differently sized teeth and gaps. Shown below are some examples of multi-perf rules.

<table>
<thead>
<tr>
<th>Pattern Type</th>
<th>Perf Pattern Workspace</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/8 1/8 perf in-crease</td>
<td>1/8 1/8 perf in-crease</td>
</tr>
<tr>
<td>1/4 1/4 perf crease</td>
<td>1/4 1/4 perf crease</td>
</tr>
<tr>
<td>1/4 1/4 3/4 perf</td>
<td>1/4 1/4 3/4 perf</td>
</tr>
<tr>
<td>1/8 1/8 3/8 perf</td>
<td>1/8 1/8 3/8 perf</td>
</tr>
<tr>
<td>Multi-perf1</td>
<td>Multi-perf1</td>
</tr>
<tr>
<td>Multi-perf2</td>
<td>Multi-perf2</td>
</tr>
<tr>
<td>Multi-perf3</td>
<td>Multi-perf3</td>
</tr>
<tr>
<td>Multi-perf4</td>
<td>Multi-perf4</td>
</tr>
<tr>
<td>Multi-perf5</td>
<td>Multi-perf5</td>
</tr>
</tbody>
</table>

The pattern for the multi-perf is defined in a workspace.

Save your pattern definition workspace to ServerLib (conventional version) or the ServerLib folder in the Shared Defaults Project (Enterprise version).

Designing a multi-perf pattern

In each pattern definition workspace, design a combination of horizontally aligned cuts, creases, and gaps that define the pattern. You can add optional vertical annotation lines marking the land length and the ends of the pattern. Shown below are sample patterns.

The vertical annotation line in the 1/8 1/8 perf-in-crease example instructs ArtiosCAD to treat the crease as the land. For the 1/4 1/4 3/4 perf, the land is the space between the two
annotation lines, which ArtiosCAD uses to center the perf pattern along design lines. The Multi-perf1 pattern is too long for a land, so the vertical annotation line marks the end of the pattern.

Use the following line types when designing your own pattern definition workspace:

- Cut
- Partial cut
- Reverse partial cut
- Crease
- Second height crease
- Matrix crease

**Defining the land**

An annotation line in the middle of a pattern marks the right end of a land.

![Annotation line in the middle of a pattern](image)

If the pattern has a land, ArtiosCAD centers the perf pattern on the line with the same land at both ends. Shown below is an example of how the pattern is centered on lines of different length.

![Pattern centered on lines of different length](image)

If the pattern has no land, ArtiosCAD aligns the pattern with the start of the line, and the value in the **Minimum land/pattern offset** field of the special rule definition defines the offset of the pattern along the line as shown below.

![Pattern aligned with start of line](image)
To make the pattern center correctly on the rule, make the land symmetrical, so it has the same cut or gap at both ends.

| Land | ___ | Symmetrical, correct
| ___ | Land | Symmetrical, correct
| ___ | Land | Asymmetrical, wrong

Adding a Multi-Perf Definition to the Special Rule Types Catalog

Once you have designed a pattern definition workspace for a multi-perf and saved it to ServerLib, do the following to add it to the Special Rule Types Catalog.

1. Start ArtiosCAD. If you are using an Enterprise version, log in as a member of ADMINS.
2. Click Options > Defaults.
3. In the Shared Defaults pane, expand the Special Rule Types Catalog.
4. Right-click Multi-perf and then click New > Data on the context menu.
5. Enter a name for the new multi-perf type and press Enter.
6. On the Manufacturing tab of the special rule type dialog box, select Multi-perf from the Generic type drop-down list box.
7. On the Special rule tab of the special rule type dialog box, enter or browse for the pattern definition file. Enter a value in the **Minimum land/pattern offset** field if the pattern definition workspace does not have a land defined.
8. Click **OK** to save the new multi-perf catalog entry.
9. Save and exit Defaults as usual.

**Edge band and Tear Tape Overview**

*Edge band* is a cover that hides the edge of thick material, such as Re-board®, usually used for displays.
Tear tape is the thin plastic strip on the inside of box-opening features.
Both edge band and tear tape are special rules.

Defining an Edge Band

To define an edge band, do the following:

1. Design a cross-section of the edge band as a single design. Make sure it forms a loop and orient it horizontally so that its lower middle section aligns with the board edge.

2. Copy the cross-section workspace to ServerLib.

3. In Defaults, add a new entry to the Edgeband folder of the Special Rule Types catalog by right-clicking it and then clicking **New > Data** on the context menu.

4. On the Manufacturing tab, set its **Generic type** to **Edge band**.
5. On the Special rule tab, enter the cross-section workspace's name or browse for it.

6. Click **Select Color** to set the color of the edge band.
7. Click **OK** to return to Defaults.

8. Modify a plotting style to give the **Edge band** type a thick dashed line.

![Edge band](image)

9. Save and exit Defaults normally.

**Defining a Tear Tape**

A tear tape has a thickness and a color.

1. In Defaults, add a new entry to the Tear tape folder of the Special Rule Types catalog by right-clicking it and then clicking **New > Data** on the context menu.

2. On the Manufacturing tab, set the **Generic type** to **Tear tape**.
3. On the Special rule tab, enter a value in the **Width** field.

4. Click **Select Color** to set the color of the tear tape.
5. Click **OK** to return to Defaults. Save and exit Defaults normally.

**Default line type set**

When you first launch ArtiosCAD, cut and crease are the two line types available from the Line type drop-down list box in the View bar. To change the available lines at startup, double-click the **Default Line Type Set** entry in **Design defaults**. The Default Line Type Set dialog box will appear.
To add a line type or special rule type to the default set available at startup, select it and click **Add to default set**. To delete a line type or special rule type from the default set, select it in the **Default Line Type Set** group and click **Delete**.

When you have finished modifying the Default Line Type Set, click **OK** to save your changes and return to Defaults, or click **Cancel** to return to Defaults and discard your changes.

**CAM Tooling Setup Catalog**

The CAM Tooling Setup Catalog contains the configuration information for CAM output devices such as Kongsberg DieSaws and lasers. Configuration information is separated onto three tabs in each Catalog entry - **Tool List**, **Tool Selection**, and **Optimization**.

**Tool List tab**

The Tool List tab contains the configuration information for the tool type, width, depth (if applicable), step height, overlap, lead hole (if applicable), and name of the tool. Each combination of tool, width, and depth needs to be assigned to a different tooling line type. To use an expression to define the tool width, select **Use Expression**.
To set up the tool list, choose the tool number to modify and then set the tool type. Set the available options and enter a name for the tool in the **Name** field.

The table below explains the function of each tool type.

**Table: Tool Types, Their Properties, And Intended Uses**

<table>
<thead>
<tr>
<th>Tool type</th>
<th>Properties</th>
<th>Description</th>
<th>Intended uses</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>line</strong></td>
<td>none</td>
<td>Uses the original lines; performs no processing.</td>
<td>Drawing with a pen.</td>
</tr>
<tr>
<td><strong>slot</strong></td>
<td><strong>Width</strong> - effective width of the tool <strong>Overlap</strong> - overlap between multiple passes of the tool. Available when <strong>Partial Depth</strong> is selected.</td>
<td>Makes a slot of a defined width. Will envelope if the slot width is wider than the tool width.</td>
<td>Laser-cut slot for a rule in a dieboard</td>
</tr>
<tr>
<td><strong>drill</strong></td>
<td><strong>Width</strong> - effective diameter of the drill <strong>Full Depth</strong> - Depth is the full depth value, defined in the output <strong>Partial Depth</strong> - Depth is defined in the CAM setup</td>
<td>Drills a hole at a point whose diameter is defined by the width in the CAD setup.</td>
<td>Mounting holes, leader holes</td>
</tr>
<tr>
<td><strong>any drill</strong></td>
<td><strong>Full Depth</strong> - Depth is the full depth value, defined in the output</td>
<td>Drills a hole at a point whose diameter is defined by the diameter</td>
<td>Mounting holes</td>
</tr>
<tr>
<td>Tool type</td>
<td>Properties</td>
<td>Description</td>
<td>Intended uses</td>
</tr>
<tr>
<td>-----------</td>
<td>-----------------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>------------------------------------</td>
</tr>
<tr>
<td>counter drill</td>
<td><strong>Partial Depth</strong> - Depth is defined in the CAM setup</td>
<td>of the circle in the workspace.</td>
<td>Countersink holes.</td>
</tr>
<tr>
<td></td>
<td><strong>Width</strong> - effective diameter of the drill</td>
<td>Drills a hole with a counter sink drill, same as the drill tool type, but sends different commands to the Kongsberg driver.</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Full Depth</strong> - Depth is the full depth value, defined in the output</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Partial Depth</strong> - Depth is defined in the CAM setup</td>
<td></td>
<td></td>
</tr>
<tr>
<td>mill</td>
<td><strong>Width</strong> - Effective diameter of the tool.</td>
<td>Mills inside or outside the outline which is usually a loop.</td>
<td>Holes in a dieboard that are too small to saw; the dieboard alignment notch.</td>
</tr>
<tr>
<td></td>
<td><strong>Full depth</strong> - Depth is the full depth value, defined in the output.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Partial depth</strong> - Depth is defined in the CAM setup.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Include fill (off)</strong> - One pass inside or outside the outline.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Include fill (on)</strong> - Multiple loops, starting in the middle of a hole, and working outwards</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Step height</strong> - Amount by which the tool penetrates into the material if the tool requires multiple passes at increasing depth to complete the hole.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>saw</td>
<td><strong>Width</strong> - Effective width of the saw blade</td>
<td>Makes a slot of a specified width, same as the slot tool type, but adds a leader hole.</td>
<td>Lines sawn on a DieSaw.</td>
</tr>
<tr>
<td></td>
<td><strong>Lead hole</strong> - Which leader hole to use.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Tool Processing and Offsets when Outputting**

A combination of the Tool type in the CAM Tooling Setup and the line type category of lines in the workspace determines how the lines are offset on Output. For example, a mill, saw, or slot tool will be offset by half the tool width for inside-edge or outside-edge lines such as Dieboard edge or Lower stripping hole. The same mill, saw, or slot tool will cut on a center-edge line (such as Unknifed diecut or a rule such as Cut) without an offset.

Inside-edge and outside-edge line types are defined as the edge of a loop and do not have a slot width. When output through a CAM Output, their offset is half the tool width in the CAM.
Tooling Setup. The pointage property of inside- and outside-edge line types can be used for selection purposes but does not affect the processing in a CAM Output.

Table: Offsets when Outputting

<table>
<thead>
<tr>
<th>Tool Type</th>
<th>Line type</th>
<th>Processing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>All</td>
<td>Unchanged</td>
</tr>
<tr>
<td>Slot or Saw</td>
<td>Draw</td>
<td>Unchanged</td>
</tr>
<tr>
<td>Inside edge</td>
<td></td>
<td>Cuts path inside by half tool width</td>
</tr>
<tr>
<td>Outside edge</td>
<td></td>
<td>Cuts path outside by half tool width</td>
</tr>
<tr>
<td>Center edge, fill off</td>
<td></td>
<td>If width is less than slot width, cuts envelope, else unchanged</td>
</tr>
<tr>
<td>Center edge, fill on</td>
<td></td>
<td>If width is less than pointage or slot width, multipass, else unchanged</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If saw, adds leader holes as necessary.</td>
</tr>
<tr>
<td>Drill, any drill, or</td>
<td>All</td>
<td>Unchanged</td>
</tr>
<tr>
<td>countersink drill</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mill</td>
<td>Draw</td>
<td>Unchanged</td>
</tr>
<tr>
<td>Inside edge</td>
<td></td>
<td>Cuts path inside by half tool width</td>
</tr>
<tr>
<td>Outside edge</td>
<td></td>
<td>Cuts path outside by half tool width</td>
</tr>
<tr>
<td>Center edge, fill off</td>
<td></td>
<td>If width less than slot width, cuts envelope, else unchanged</td>
</tr>
<tr>
<td>Center Edge, fill on</td>
<td></td>
<td>Series of loops starting in the middle and working outward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Repeats with the next depth necessary depending on the step height</td>
</tr>
</tbody>
</table>

Tool Selection tab

The Tool Selection tab maps line types, pointages, and subtypes to tools on the output device. It is also the place where the output priority is assigned. During output, a line is processed according to the first selection in the list that matches the line's properties. When a line matches the selection criteria, it is mapped to the specified CAM tool and then assigned to a group. Once a line has been mapped, the process begins again with the next piece of line data; lines are processed by one selection and one selection only. When all the data has been processed, the groups are internally optimized and output to the machine in ascending order.
by group number. Lines that do not match any of the selections in the list are processed using the (Remainder) selection, which usually are not output.

In the example above, drawn lines, etch lines, and lines with subtype Countersink ID are output first as they are in group 1. The Countersink ID lines are not actually created on the machine as they are assigned to the Do not output tool. Once the group 1 lines are output, then the group 10 lines are output, then 20, then 30, and so forth.

The Types, Subtypes, and Pointages buttons lead to dialog boxes where you can select exactly what will be output in this selection. These dialog boxes are similar to those used for selections in plotting styles.

**Note:** The Text and dimensions checkbox in Types > Design only applies to text and dimensions that have not had a color applied. Those with a color applied are considered graphics and are not output to CAM devices.

By default, all items are turned on when you enter the dialog box for the first time. Click Invert Selection to clear each checkbox. Clicking Select All selects all the items in the list. If you make selections other than having all selected or having none selected, the base ArtiosCAD syntax is shown in the field beneath the list. When you have finished selecting, click OK to return to the Setup dialog box saving your changes or Cancel to return, ignoring your changes.
The **Slot Width** button opens the Slot Width dialog box in which you can specify a minimum slot width and a maximum slot width. Any line with a slot width between those values will be selected. #I or #M is automatically appended to the slot width selection to allow for conversion between units of measurement.

The up and down arrows to the side of the selection list move the selected entry either up or down in the list depending on which button is clicked.

**Insert** adds a new entry above the current selection; **Delete** deletes the current selection. The (Remainder) selection may not be deleted.
The **Tool number**: field selects the CAM tool to map to the line selection. Entries for this drop-down list come from the Tool List tab. The **Size only** tool is meant to be used for easier registration. Lines sent to the **Size only** tool show in a preview and are used to calculate the output size, but are only actually output when outputting to a layer.

The **Width adjustment**: field allows you to add to the slot width that is cut. Usually the slot width is defined by the slot width of the rule if so defined or by the pointage of the rule. However, the preferred way to adjust the slot width for laser output is to use a special rule with a defined slot width.

The **Group number**: defines which group the selected lines are put into. Group 1 is output first, then group 2, group 3, and so on.

If the **Separate bridge tool** checkbox is checked, another line is added beneath the selection in the list to allow the processing of bridges for that selection to be defined separately. This means that bridges can be made with a different tool.

The **Number of tools** field allows for more than one tool to manufacture the lines selected by a selection criteria line. Configure the extra lines as you would any of the other selection criteria lines.

Enter the desired name for the selection criteria line in the **Name**: field.

**Note**: Wave rules with nick width of 0 are treated as cuts and processed by the GENTYPE 1 tool selection.

### Optimization tab

The **Optimization** tab controls the internal optimization of the groups of output. Optimizing is on for all groups by default.
To turn off optimization for a group, select it and clear the **Optimize** checkbox. To turn it on, select it and check the **Optimization** checkbox.

**Separate subroutine** controls if each group will be in its own subroutine. If the box is checked, the selected group is independent. If the box is clear, the selected group shares the same subroutine as the previous group.

### CAM Output of Rubber Sheets

A CAM Tooling Setup catalog entry should be set up for the following line types for output to (for example) a waterjet rubber-cutting machine.

**Table: Rubber CAM tooling setup**

<table>
<thead>
<tr>
<th>Line type</th>
<th>Name</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type 220</td>
<td>Rubber inside edge</td>
<td>If using different logical tools for the inside edge and the outside edge. Otherwise make them the same.</td>
</tr>
<tr>
<td>Type 221</td>
<td>Rubber outline</td>
<td></td>
</tr>
<tr>
<td>Type 222</td>
<td>Rubber name</td>
<td>Cuts the numbers in the rubber pieces, if <strong>Show element numbers</strong> is selected on the Processing page in the Output.</td>
</tr>
<tr>
<td>Type 97</td>
<td>Usable limit of sheet</td>
<td>If required, cuts the outline of the sheet area used.</td>
</tr>
<tr>
<td>Type 98</td>
<td>Sheet size</td>
<td>Map to Size only to see the sheet size.</td>
</tr>
</tbody>
</table>

Shown below is an example CAM Tooling Setup catalog entry.
CAM Output of Steel Counters

The CAM Tooling Setup Catalog entry for a steel counter output should list the widths and depths of the available tools on the milling machine on the Tool List tab and select the counter line types on the Tool Selection tab.

- With grain crease (type 100) and Cross grain crease (type 101)
- With grain crease and Cross grain crease with the different subtypes used for different depths
- Counter mill outline (type 110) for embossing and reverse crease
- Name tool (type 107)
- Positioning holes tool (type 108), Position holes tool 2 (type 111), and Counter slot (type 112)
- Periphery (for the frame) (type 103)

Do not output other line types such as cut/crease.

To output the counter channel as a single line, set the Tool type to mill, the Width to 10 mm (wider than the channel), and Partial depth.

To fill the channel with multiple passes, set the Tool type to mill, the actual width of the tool, Partial depth, Include fill, and a small Overlap of 0.1.

The milling path can be calculated either by ArtiosCAD or the milling machine. To output a mill area as a single outline, set the Tool type to line.
To output a mill area as being full of multiple passes, set the Tool type to **mill**, set a sensible **Width**, **Partial depth**, **Include fill**, and a slight **Overlap**.

ArtiosCAD can output the same path with more than one tool. To add another tool, increment **Number of tools** for this selection on the Tool Selection tab.

- To mill an interior area with one tool and mill its periphery with another, assign two milling tools with different widths and the same depth.

- To add a finishing tool to the edge of the mill area, set the finishing tool to Tool type **line** to trace the outside of the mill area.

Output sequence is controlled by the group number on the Tool Selection tab, with lower groups being Output before higher groups. To have the periphery cut last, give it the highest group number.

**Note:** ArtiosCAD mills areas with curved reverse creases and curved reverse cuts as if they were straight lines.
Specifying a rotary die in a press definition

When you first create a press, ArtiosCAD assumes it is flat by default. To specify a rotary dieboard configuration, double-click the **Rotary Shrink Stretch Factors** entry in the parameter set for that press.

In the Rotary Shrink Stretch Factors dialog box, check the **Rotary Dieboard** checkbox and fill in the values for the **Wood Thickness**, **Cylinder Diameter**, **Design to Wood Level Shrink**, and **Cylinder to Wood Level Stretch** fields with the proper values.

Once the fields are complete, click **OK** to return to Defaults or click **Cancel** to cancel.
Changes to Rotary Die Press Defaults

Because of the Rotary Die Board tool, ArtiosCAD Defaults have changed slightly. In the **Die Board** catalog for a given press in Die Press Parameter Sets, the Wood Dimensions tab has changed. In the **Press Defaults** catalog, the Hole Patterns tab has changed.

On the Wood Dimensions tab, you can now set:

- Suggested sizes
- Offsets
- Allowances. These allowances may not be negative (which applies for flat dies as well). You can set the bottom allowance, the minimum bottom allowance, and the minimum top allowance.

All values must be for the design level, not the cylinder or wood levels. These depend on the shrink and stretch factors defined in the Rotary Shrink Stretch Factor catalog for the press definition in the parameter set. If you change those factors, you must save Defaults before ArtiosCAD changes these wood dimensions.

On the Hole Patterns tab, you can now set:
• The radius of the area of effectiveness for mounting bolts
• The split distance and select tolerance for Die Symmetry when using the Rotary Die Board tool. ArtiosCAD considers holes within the split distance from a split and within the select tolerance of the originally selected hole to be symmetrical.

When you use **Specify allowances** on the Wood edge tab for a rotary die press definition in a die press parameter set, the die board is not positioned by the machine reference point or centered on the layout; it really uses the allowances. ArtiosCAD ignores the **Centered dieboard** option when you use **Specify Allowances**.
Hole Catalog

Holes are used in manufacturing to attach the boards to the presses. There are three types of holes: General holes, Drill holes, and Oblong holes. As holes utilize subtypes, configure subtypes before adding holes.

Adding a hole to the Hole Catalog

To add a hole, right-click Hole Catalog, and click New > Data from the context menu. Give the new hole a name and double-click its entry to open its Properties dialog box. Edit the values as appropriate. The Diameter Y field is available when the hole type is set to Oblong Hole. Counter Sink Diameter is available only when the Counter Sink checkbox is checked. Set the Subtype fields as appropriate.
Nicks

Nick formulas

Nick formulas are stored in the Nick Formulas Catalog. Sample entries are contained in the Artios folder. The default nick formula is chosen in either the Manufacturing or Single Design parameter set. Shown below is a Kongsberg nick formula.

The six placement buttons at the upper left of the tab set the default placement option for nicks when the Add Nick tool is activated.

- **Offset** sets the nicks so that they offset from the nearest endpoint of the line or arc.
- **Center** places the nick in the center of a line or arc.
- **Anywhere** places the nick at the point you click.
- **At the end of the line** places the nick at the end of a line.
- **Fill line** fills the line or arc with evenly spaced nicks with **Between sets** setting the distance between groups of nicks if the number is set to more than 1.
- **Fill path** fills a path with nicks as controlled in the Fill Path Options group.
• **Between sets** sets the distance between sets of nicks.

• **Split at corners** keeps the nicks out of corners by the **Corner offset** distance. If a blend is larger than the **Minimum radius**, ArtiosCAD considers it a corner.

• **Avoid End Points** keeps the nicks from being on the shared end-point of two lines.

The fields in the **Nick sizes**, **Offsets**, and **Between nicks**: columns set the values for the drop-down list boxes when the **Add Nick** tool is activated.

The **Number** field sets the default number of nicks to add when the **Add Nick** tool is activated.

Set the default nick size to use by entering either an absolute value or a formula in the **Default nick size**: field. If no default size is set, the **Add Nick** tool and the Bridging properties dialog box default to the first defined size.

### Nick styles

ArtiosCAD can represent nicks as a single line, a double line, a text label, a workspace you designate, a centered line, a centered line with text, or as a parallel line along the nick. You can configure different ways for nicks to be represented based on their size. Nick Styles are configured in the Nick Styles Catalog. You can either modify the default nick styles in the Artios folder or you can create your own.

By default, a newly-created nick style has only one entry in it. This one entry defines how all nicks are shown.
**Insert** and **Delete** add conditions for nick sizes. Select an entry in the list before clicking either.

The option buttons in the **Nick Output Type** group - **Single line**, **Pair of lines**, **Text**, **Workspace**, **Centered line with text**, **Centered line**, and **Parallel along nick** - control the type of nick made. **Centered line** and **Parallel along nick** are meant for outputting to a rule bender and display a mark for half split nicks (where there is a nick straddling the intersection of two end-to-end lines). For the Centered line styles, the line is a fixed length plus a multiple of the nick width.

The values in the **Start** and **End** fields set the length of the line(s) representing the nick. The value in the **Start** field sets the distance between the line containing the nick and the start of the line representing the nick. Use a negative offset to have the nick representation cross the design line. The value in the **End** field sets the distance between the line containing the nick and the end of the line representing the nick. The line(s) representing the nick are always drawn perpendicular to the line containing the nick.

The **Workspace name** field is available only when the **Nick Output Type** is set to **Workspace**. In this field, enter the name of the workspace to use to indicate a nick, or use the **Browse** button (...) to browse for the nick workspace. The workspace must have the center of the nick representation as the origin of the workspace (where the two construction line axes meet). The line type used to draw the nick workspace is ignored; the nick is drawn as a nick line type. Anything other than lines and arcs in the nick workspace is ignored.

Add the size of the nick as text to the nick by using the **Text** nick output type in a selected Nick Style in Defaults. Set the size of the text in the **Text Size** drop-down list box, which is available only when the Nick output type is set to Text.

When two nicks are close together, and the nicks are represented by workspaces, if the two workspaces would overlap, the second nick is shown as a line.
When zooming in on nicks, the mark size and text size increase. If two nicks are closer together than the width of the text or workspace label, the text or label is shown only once.

When a text nick style is used in a CAM Output, the text for the nick size may be converted to lines according to how text is handled by the Output. If the **Line text** option is selected, the nick size text uses the same tool number as the nick line type.

To have ArtiosCAD display the nick sizes on a printed or plotted output, make a Nick Style of all workspaces which are based on the nick size. In each workspace, enter the number, and then convert it to lines using the Line Text tool.

**Table: Nick Examples**

<table>
<thead>
<tr>
<th>Output Type</th>
<th>Parameters</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single line</td>
<td>Start = 0, End = 1/8</td>
<td>[Illustration]</td>
</tr>
<tr>
<td>Single line</td>
<td>Start = 1/32, End = 5/32</td>
<td>[Illustration]</td>
</tr>
<tr>
<td>Single line</td>
<td>Start = -1/8, End =1/8</td>
<td>[Illustration]</td>
</tr>
<tr>
<td>Double lines</td>
<td>Start = -1/8, End = 1/8</td>
<td>[Illustration]</td>
</tr>
<tr>
<td>Workspace</td>
<td>Workspace: [Illustration]</td>
<td>[Illustration]</td>
</tr>
<tr>
<td>Workspace</td>
<td>Workspace: [Illustration], Start = 1/16, End = 5/16</td>
<td>[Illustration]</td>
</tr>
<tr>
<td>Workspace, with two nicks close together</td>
<td>Workspace: [Illustration], Start = 1/16, End = 5/16</td>
<td>[Illustration]</td>
</tr>
<tr>
<td>Workspace</td>
<td>Workspace: 25</td>
<td>[Illustration]</td>
</tr>
</tbody>
</table>
When you have finished modifying the nick style, click **OK** to return to Defaults keeping your changes, or click **Cancel** to return to Defaults ignoring your changes.

**Standard Sheet Layout**

Parameters and standard sheet sizes for Standard Sheet Layout are configured in the Sheet Utilization catalog in Defaults.

- Nick Formulas
- Nick Stylus
- Output Destination
- Outputs
- Plotting Style Catalog
- Printing press parameter sets
- Prompted text table
- Property defaults
- Report Catalog
- Sheet Utilization
  - Sheet Layout Parameters
  - Standard Sheet Sizes
- Shortcuts
- Single design parameter sets
- Special rule types
- Startup defaults
- Style catalog
- Subtype Mapping Catalog

**Sheet Layout Parameters**

Double-click **Sheet Layout Parameters** to set the defaults for the trim, gutters, nest types, and other options to use in Standard Sheet Layout as shown below.
In the **Trim** group, the fields set the trim tolerances at the edge of the sheet. Set them to be less than the maximum values for the presses used to produce the layout.

**Use gutters** inserts gutters between designs in the nest when it is checked. When it is clear, the single designs touch. The values in the **X** and **Y** fields set the gutters in X and Y for the first and second rows and columns of single designs in the layout. The values in the **X2** and **Y2** drop-down list boxes set the gutters between the second and third rows and columns. These are repeated as appropriate between all the rows and columns in the layout.

In the **Nest type** group, the checkboxes control the kinds of nests made automatically. Select the checkboxes next to the type of nests to use; clear those next to undesired nests.

**Touch bleed outlines** controls whether the designs touch using the bleed outlines or the edges of the designs. If **Use gutters** is enabled in conjunction with **Touch bleed outlines**, the gutters are inserted between the bleed outlines instead of the edges of the designs.

In the **Design options** group, **Allow 90 degree rotation** lets designs rotate so they are cross-grain; the sheet grain runs in the longer direction. **Maximum allowable reduction** is the maximum distance that could be shaved off each design in order for another row or column to fit on the sheet. If such a cutback is possible in each design, a row or column will overlap the edge of the sheet when a layout is suggested and there will be values in the various **Reduction** fields of the Sheet Layout Results dialog box.
Click **OK** to save the changes, or click **Cancel** to ignore them and return to Defaults.

## Standard Sheet Sizes

Double-click **Standard Sheet Sizes** to configure the defaults for standard sheets used by Standard Sheet Layout.

![Standard Sheet Sizes dialog box](image)

To use a sheet for possible layout solutions, check its box in the **Use** column. To disable its use, clear the checkbox. To toggle the usage of all sheets at once, click **All on/off**.

The arrows on the side of the dialog box move the currently-selected sheet up and down in the list of sheets. The order of sheets on this tab is the same order used to present layout results.

To edit a sheet, select it, and change the fields in the **Edit Sheet Properties** group. The fields change as soon as you click another field.

To add a sheet, click **Insert**, and then edit the fields in the **Edit Sheet Properties** group. Set the checkbox in the **Use** column as desired.

To delete a sheet, select it, and click **Delete**.

To save the changes to the standard sheets, click **OK**. To discard the changes and return to Defaults, click **Cancel**.
Configuring Intelligent Layout defaults and Costing/Estimating

In order to work optimally, Intelligent Layout and Costing/Estimating must have their defaults configured accurately. These defaults should match the real-life manufacturing conditions used to make the containers.

Configuring cost centers

Costing/Estimating uses the general concept of a cost center to allow costs to be configured. A cost center represents a machine such as a printing press, die press or folder-gluer, and/or a material cost such as gold stamping or shipping. Machine costs are calculated per hour and material costs are calculated per sheet or per carton. ArtiosCAD supplies some example cost centers in Intelligent Layout Defaults, and you are expected to modify these and add your own cost centers to suit your needs.

To view or edit cost centers, do the following.

1. Start ArtiosCAD.
2. Click Options and Defaults to open the Defaults dialog box.
3. Click the plus sign next to Intelligent Layout defaults to view its contents.
4. Double-click Cost centers. The first cost center will be selected by default.

The groups and options shown depend on the option button selected in the Cost specification method group.

5. Make the desired changes and then click OK to save them or Cancel to ignore them.
The items in the Cost center dialog are explained in the following list:

**Table: Cost Center Dialog Box**

<table>
<thead>
<tr>
<th>Item</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>List of cost centers</td>
<td>The list of cost centers must be arranged in the order they are used. The output of one cost center is the input to the next. When the checkbox is off, the cost center is an option, available to be selected but is not turned on by default.</td>
</tr>
<tr>
<td>Up arrow, down arrow</td>
<td>Moves the selected cost center up or down in the list</td>
</tr>
<tr>
<td>Name</td>
<td>Changes the name of the selected cost center</td>
</tr>
<tr>
<td>Insert</td>
<td>Inserts a new cost center above the selected one.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected cost center</td>
</tr>
<tr>
<td>Per sheet</td>
<td>The cost center applies to sheets, for example a sheeter.</td>
</tr>
<tr>
<td>Printing press</td>
<td>Works the same as a sheet cost center, but identifies the printing press cost center to be reported separately.</td>
</tr>
<tr>
<td>Die press</td>
<td>Works the same as a sheet cost center, but identifies the die press cost center to be reported separately.</td>
</tr>
<tr>
<td>Per design</td>
<td>Cost center such as a folder-gluer, where make ready is needed for each different design, and a smaller make ready is needed for a different print item of the same design.</td>
</tr>
<tr>
<td>Per print item</td>
<td>Cost center such as windowing, if the windows were different on each print item. There is a separate make ready for each print item.</td>
</tr>
<tr>
<td>Use prompted variable</td>
<td>Only if a variable is to be associated with this cost center. For example FGD = folder-gluer degree of difficulty, or NCOL2 = number of colors for a second printing press, see note. The variable is added to the Prompted Variables tab of the Quantities and Costs dialog if this cost center is included.</td>
</tr>
<tr>
<td>Prompt</td>
<td>Prompt/description of this variable</td>
</tr>
<tr>
<td>Variable name</td>
<td>Name of the prompted variable to be used in expressions. A prompted variable can be used in expressions such as make ready and speed, inside the PVAR function. For example, the make ready time of the printing press is defined to be 1+PVAR(NCOLOR)/2, that is, 1 hour plus 1/2 hour for each color. The name of the variable can use up to 6 letters and digits and must start with a letter.</td>
</tr>
<tr>
<td>Default value</td>
<td>Default value of the prompted variable</td>
</tr>
<tr>
<td>Item</td>
<td>Explanation</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Make ready time</td>
<td>Expression for the make ready time in hours</td>
</tr>
<tr>
<td>Sheets/hour</td>
<td>The normal speed of the machine when it has reached its optimal speed. The theory is that the machine runs for a while at a slower speed for the first few sheets while it is brought into alignment, and then the speed is increased to its optimal speed. For a multi-step ramp up in speed, use the SPEEDSTEP function.</td>
</tr>
<tr>
<td>Run waste %</td>
<td>The percent waste while running. A machine such as a printing press may periodically go out of alignment and waste some sheets.</td>
</tr>
<tr>
<td>Cost/hour</td>
<td>Cost of the machine per hour while running. Does not include the cost of the machine during make ready, which is separate.</td>
</tr>
<tr>
<td>Cost/sheet</td>
<td>Additional material cost per sheet apart from the board cost. If the cost specification method is per print item, this label changes to Cost/carton, for example the cost of a window in each carton.</td>
</tr>
</tbody>
</table>

**Changing Cost Center expressions**

Clicking the $f(x)$ button in a cost center expression leads to an expression configuration dialog box. For example, clicking $f(x)$ for the **Make ready time** expression:

$$(\text{STEP}(#\text{NCOLOR}, 1, 2, 1.25, 3, 1.5, 4, 1.75, 5, 2.25, 6, 2.75, 7, 3, 8, 3.5))$$

leads to:
This dialog box lets you choose how the value for the selected field is determined - by a table of conditions or by an expression; in this example, the method is set to table. Only when the method is set to table is there a **Table** tab in the dialog box.

To set the value using an expression, select the **Expression** option and type the expression in the field. Click the **f(x)** button to access the Edit Expression dialog box.

**Creating a table to set the value**

When configuring a cost center expression, you can create a table of values to use when certain conditions are met. In the picture below, the make-ready time is determined by the number of one-ups and the board caliper.
The **One parameter** and **Two parameters** option buttons control how many conditions must be met when setting a value. When **One parameter** is selected, everything relating to columns is unavailable; you may only add and delete rows.

The **Row parameter** and **Column parameter** drop-down list boxes set what is being used to determine the conditions of the table. You may type expressions of your own choosing in this box. If ArtiosCAD recognizes the expression (CAL, for example), it translates the expression to its text equivalent ("Board caliper").

**Add row**, **Add column**, **Delete row**, and **Delete Column** do what they say. There can be up to 18 rows and 14 columns. If the cursor is in any of the edit boxes, **Delete row** deletes that row; otherwise the bottom row is deleted. **Delete Column** deletes the column the cursor is in; otherwise, it deletes the rightmost column.

The f(x) button for the **Sheets/hour** field leads to an expression configuration dialog box which has three entries which behave exactly as those described above.

### Modifiers for cost center expressions

A **modifier** allows adjustments to be made to an expression in certain situations. For example, a modifier could use this logic: **if the caliper is 0.016" or less, add 10%**. Modifiers can do the following to the output of the expression:

- Add a percentage
- Subtract a percentage
- Add a value
- Subtract a value
- Multiply by a value
• Divide by a value
• Set a minimum value
• Set a maximum value

To add a modifier to a cost center expression, do the following:

1. Click the $f(x)$ button for that expression and then click the **Modifiers** tab.

2. Click **Add** to add a modifier. A list of modifiers appears:

3. Choose a modifier to add to the expression (for this example, choose **Large caliper**) and click **OK**. ArtiosCAD will return to the Modifiers dialog box.
4. Click **Edit** to open the Edit Modifier dialog box.

![Image](image.png)

The option buttons in the **Condition type** group let you quickly change the condition with a single mouse click. If you select **No condition**, the **Limit value** and **Condition** fields are unavailable. Changing the condition type option button automatically updates the expression in the **Condition** field. The **Condition type** and the **Limit value** combine into the **Condition**.

The option buttons in the **Modification** group determine the operation of the modifier. The amount of the modification is set in the **Modification value** field.

5. Click **OK** to accept the changes to the modifier or **Cancel** to ignore them. ArtiosCAD will return to the expression configuration dialog box.

### Notes on Intelligent Layout Defaults

Most defaults have the option of User defaults overriding Shared defaults. This does not work well for Intelligent Layout because the cost centers from Shared Defaults and User Defaults are mixed together. We recommend that you only use Shared Defaults for Intelligent Layout.

The order of the cost centers is important. The **Per design** and **Per print item** cost centers must be after the printing press and the die press.
If you set up a cost center with a prompted variable that has a default value, for example a printing press with 2 colors, and then want to run a layout with three colors, your first impulse might be to double-pass the sheet and use the cost center twice. This approach, however, will result in 4 colors being used in the calculations. Make sure to set up a cost center with prompted variables that have defaults specific for each case you may encounter.

Overview: Setting up a multi-color printing press cost center using a table

The following overview illustrates how to set up a cost center containing variable information. We are going to set up the following information:

<table>
<thead>
<tr>
<th>Number of colors</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make ready time in hours</td>
<td>1.5</td>
<td>1.75</td>
<td>2.0</td>
<td>2.5</td>
<td>2.75</td>
<td>3.5</td>
<td>4.0</td>
</tr>
</tbody>
</table>

Note that you must enter time in hours, not hours:minutes. For example, 2 hours 45 minutes is represented as 2.75 hours.

1. Start ArtiosCAD.
2. Click Options and then click Defaults to open the Defaults dialog box.
3. Click the plus sign next to Intelligent Layout defaults to view its contents.
4. Double-click Cost centers. The first cost center will be selected by default.
5. Click Insert to create a new cost center called New cost center.
6. Change the name in the Name: field from New cost center to My 8 color press.
7. Set the Cost specification method to Printing press.

The Intelligent Layout Defaults dialog should look as follows:
8. Click f(x) at the end of the Make ready time field to set up a table of conditions for the number of colors. The expression configuration dialog box appears:

9. Click the Table option button in the Make ready time group.
10. Click the Table tab.

11. Select One parameter and choose Number of colors for the Row parameter.

12. Enter 2 and 1.5 in the first and second fields, respectively, under Number of colors. ArtiosCAD will change the 1.5 into 1+1/2.
13. Click Add row. Enter 3 and 1.75 in the first and second fields of the new row.
14. Repeat for the rest of the values in the table.
15. When the table is complete it should look like this:
Click OK to finish configuring the table for the make ready time, and proceed to configuring the rest of the cost center.

Useful Functions for Cost Center Expressions

**STEP(variable, value1, limit1, value2, limit2,..., limitn, valuen)**

Returns value1 when variable < limit1
value2 when limit1 <= variable < limit2
value3 when limit2 <= variable < limit3
... valuen when limitn <= variable

The STEP function and all its variations must have an even number of parameters, at least 4.

![Graph of STEP function](image)

Note that we would not recommend that a step function be used for the speed of a machine because the run time of a machine using a step function like this would have discontinuities in its run time:

![Graph of run time](image)

**STEPUP(variable, value1, limit1, value2, limit2, ... , limitn, valuen)**

Same as STEP except < and <= are reversed:

Returns: value1 when variable <= limit1

![Graph of run time with step up](image)
value2 when limit1 < variable <= limit2
...
valuenn when limitnn < variable

LINESTEP(variable, value1, limit1, value2, limit2, ..., limitnn, valuenn)

As a more sensible alternative to the STEP function for the speed of a machine, this function does a linear interpolation between data points, and avoids the discontinuities in the STEP function.

Returns: value1 when variable <= limit1
Interpolation between value1 and value2 when limit1 <= variable <= limit2
Interpolation between value2 and value3 when limit2 <= variable <= limit3
...
valuenn when variable >= limitnn

Note that to prevent a discontinuity at the last limit, the last two values should be the same, or the last value might be an expression.

SPEEDSTEP(#RUN,speed1,run1,speed2,run2, ..., runnn, speednn)

The SPEEDSTEP function is an alternative for the speed of a machine (depends on how the speed is specified). The machine runs at speed1 for the first run1 sheets, runs at speed speed2 up to a run length of run2, and so on, and runs at speed speednn after the run length reaches runn. The function returns an average speed of the machine given the run length.

List of functions for configuring cost centers

This list of functions is accessible from the Cost Centers dialog box by clicking $f(x)$ and then Insert Library Function.
Table: Functions for configuring cost centers

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#SHTSIZEX</td>
<td>Sheet size X, current units (inches or mm).</td>
</tr>
<tr>
<td>#SHTSIZEY</td>
<td>Sheet size Y, current units (inches or mm).</td>
</tr>
<tr>
<td>#SHTSIZEWG</td>
<td>Sheet size with grain, current units (inches or mm).</td>
</tr>
<tr>
<td>#SHTSIZEXG</td>
<td>Sheet size cross grain, current units (inches or mm).</td>
</tr>
<tr>
<td>#CUTSIZEX</td>
<td>Knife-to-knife X of designs in the layout, in current units (inches or mm).</td>
</tr>
<tr>
<td>#CUTSIZEY</td>
<td>Knife-to-knife Y of designs in the layout, in current units (inches or mm).</td>
</tr>
<tr>
<td>#MANSIZEX</td>
<td>Design blank size X (manufacturing lines), in current units (inches or mm).</td>
</tr>
<tr>
<td>#MANSIZEY</td>
<td>Design blank size Y (manufacturing lines), in current units (inches or mm).</td>
</tr>
<tr>
<td>#MANSIZEWG</td>
<td>Design blank size with grain (manufacturing lines), in current units (inches or mm).</td>
</tr>
<tr>
<td>#MANSIZEXG</td>
<td>Design blank size cross grain (manufacturing lines), in current units (inches or mm).</td>
</tr>
<tr>
<td>#AREA</td>
<td>Area of design ignoring holes (zero if area fails) in current units (square inches or square mm) of the current design.</td>
</tr>
<tr>
<td>#AREAH</td>
<td>Area of design minus holes (zero if area fails) in current units (square inches or square mm) of the current design.</td>
</tr>
<tr>
<td>#RUN</td>
<td>(In the Intelligent Layout Parameters dialog). Run length for this cost center/item in number of sheets or number of cartons.</td>
</tr>
<tr>
<td></td>
<td>(In a form or OCX control). Run length of the first cost center, usually the printing press.</td>
</tr>
<tr>
<td>#NUPD</td>
<td>(Design, item cost center) How many of this design on the sheet (Sheet cost center) 0</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>#NUPP</td>
<td>(Item cost center) How many of this print item on the sheet</td>
</tr>
<tr>
<td></td>
<td>(Sheet or design cost center) 0</td>
</tr>
<tr>
<td>#NUP</td>
<td>Total number of designs on the sheet</td>
</tr>
<tr>
<td>#MKRT</td>
<td>Make ready time for this cost center/item</td>
</tr>
<tr>
<td>#MKRTA</td>
<td>(Design cost center) Make ready time for this cost center/item for additional items.</td>
</tr>
<tr>
<td></td>
<td>(Sheet or item cost center) 0.</td>
</tr>
<tr>
<td>#BRDWTG</td>
<td>Board weight grams/square meter.</td>
</tr>
<tr>
<td>#BRDWTLBS</td>
<td>Board weight lbs/1000 square feet</td>
</tr>
<tr>
<td>#BRDCSTM</td>
<td>Board cost/1000 square meters</td>
</tr>
<tr>
<td>#BRDCSTFT</td>
<td>Board cost/1000 square feet</td>
</tr>
<tr>
<td>#BRDCSTKG</td>
<td>Board cost per kg.</td>
</tr>
<tr>
<td>#BRDCSTLBS</td>
<td>Board cost per lb.</td>
</tr>
<tr>
<td>#WEIGHTKG</td>
<td>Weight of one item (board only) in kg.</td>
</tr>
<tr>
<td>#WEIGHTLBS</td>
<td>Weight of one item (board only) in lbs.</td>
</tr>
<tr>
<td>#ITEMORD</td>
<td>(Item cost center) Ordered quantity of this item.</td>
</tr>
<tr>
<td></td>
<td>(Sheet cost center) Ordered quantity of the first item.</td>
</tr>
<tr>
<td></td>
<td>(Design cost center) 0.</td>
</tr>
<tr>
<td>RULELEN(&quot;TYPE 1&quot;)</td>
<td>(Design or Item cost center) Length of cuts in the design.</td>
</tr>
<tr>
<td></td>
<td>(Sheet cost center or die cost) Length of cuts in the layout.</td>
</tr>
<tr>
<td></td>
<td>Typically used in estimation of die cost. This calculation is context dependent for item cost centers. Note that it ignores double knife removal and stripping rules, because they have not been defined yet.</td>
</tr>
<tr>
<td>RULELEN(&quot;TYPE 2&quot;)</td>
<td>Length of creases in the layout. Also supports more general selection such as RULELEN(&quot;TYPE 1,3 RAD ..1/8&quot;)</td>
</tr>
<tr>
<td>PVAR(varname)</td>
<td>Value of prompted variable, e.g. PVAR(NCOLOR) or PVAR(CRW). Actual variable is CCEN.NCOLOR (per sheet) or CCEN.D[i].CRW (per design) or CCEN.P[i].MYVAR (per print item)</td>
</tr>
<tr>
<td>DESVAR(varname)</td>
<td>(Design or item cost center) Value of variable from design, e.g. DESVAR(L)</td>
</tr>
</tbody>
</table>
**Example Folder-Gluer Formula**

To calculate the speed of a folder-gluer machine, suppose the belts on the machine run at 240,000 inches per hour. The cartons are carried through the folder-gluer side-by-side with a 1/2-inch gap between them. The blank size of a carton is given by the function #MANSIZEX and 1/2 inch is represented by #I/2, so the step distance between cartons is #MANSIZEX+#I/2. Dividing the speed of the belts by the step distance gives a speed (in cartons per hour) of:

\[
240000 \times \frac{#I}{#MANSIZEX+#I/2}
\]

However, suppose some cartons are more difficult to fold up and the machine has to run slower for these. Let us introduce a compensation factor in a prompted variable `Folder difficulty` which has values:

1 = Easy, Full speed 240000 inches/hour
2 = Moderate, Moderate speed 200000 inches/hour
3 = Hard, Slow speed 160000 inches/hour

To allow for this, the modified formula uses a step function of the Folder difficulty variable FGD (Folder Gluer Difficulty):

\[
\text{STEP}(\text{PVAR(FGD)}, 240000, 2, 200000, 3, 160000) \times \frac{#I}{#MANSIZEX+#I/2}
\]

To use this, the estimator should enter the “Folder difficulty” for each design along with the number of colors for the job in the Prompted Variables tab in the Quantities and Costs dialog box:
Run Length Calculation

The costing model used in ArtiosCAD has a list of cost centers in the order that the cartons are processed through the plant. Once the sheet has been processed in the die press, you no longer have sheets, and the remaining cost centers process print items (=cartons). Therefore, the sheet cost centers (printing press and die press) come before all the item cost centers (e.g. windowing, folder-gluer, shipping). Between the last sheet cost center (the die press), and the first item cost center, the sheet is divided up into print items depending on the number up of each item.

For the run length calculation, each cost center has an attribute of the number of sheets or cartons used in make ready, and a run-time waste percentage. For example, suppose you start with 100000 sheets, and the printing press uses 5000 for make ready, and has a run time waste of 4%, because it periodically goes out of registration. Then the run length of the printing press is 100000-5000 = 95000, but because of the run-time waste the output from the printing press that is available for the next cost center is 96% of this, which equals 91200.

For each cost center in the list, the input to this cost center (= make ready + run length) is equal to the output of the previous cost center. When you enter ordered quantities, the calculation starts with the required delivered quantity which is the output from the last cost center, and works backwards, adding the run-time waste and make ready for each cost center, to come up with the number of sheets you need to start with.

To illustrate the run length calculation in Intelligent Layout, suppose you have ordered quantities 100000 of A and 200000 of B, and the sheet has 5 up of A and 8 up of B. The first thing we see is that with these proportions, we are going to get a larger overrun of A than of B. Suppose there was no make ready waste. There would be a run length of 12500 giving the required 200000 (100%) of B but 125000 (125%) of A. Therefore, for the run length calculation, we can ignore A with the larger overrun, and calculate the run length needed for B.

In our simple example, there are 3 cost centers:
<table>
<thead>
<tr>
<th>Cost Center Name</th>
<th>Make Ready</th>
<th>Run Time Waste %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing Press</td>
<td>5000 sheets</td>
<td>4%</td>
</tr>
<tr>
<td>Die Press</td>
<td>3000 sheets</td>
<td>2%</td>
</tr>
<tr>
<td>Folder-gluer</td>
<td>500 cartons</td>
<td>0%</td>
</tr>
</tbody>
</table>

This can be represented in a diagram as follows:

```
Working backwards, the delivered quantity of B is 200000. This is the output from the folder-gluer. The folder-gluer needs 500 cartons make ready, so the input to the folder-gluer is:
run length = 200000, make ready = 500, total = 200500

There are 8 of B on the sheet, so
Die Press output = 200500/8 = (rounded up) 25063.

To allow for the 2% run time waste, the input to the Die Press is:
run length = 25063 * 100 / (100-2) = 25564, make ready = 3000, total = 28564

To allow for the 4% run time waste, the input to the Printing Press is:
run length = 28564 * 100 / (100-4) = 29754, make ready = 5000, total = 34754

Therefore, the total number of sheets needed for this job is 34754.

Print Items and Folder-Gluer Make Ready

If you have several print items of the same design, you only need to set up the folder-gluer for the first item. The make ready for subsequent items is just the time needed to move them with the forklift and restart the machine. However, which is the “first item”? If the run lengths of the print items are different, Intelligent Layout picks the item with the largest overrun, and assumes that this is the “first item” you will use to set up the folder-gluer.

298
ArtiosCAD provides many ways to configure Outputs to get the results your company’s workflow requires.

The tabs shown on an Output properties dialog box depend on the selection in the Output Type group. For example, in the picture above, there is no Reports tab, but if you set the Output Type to Plot, the samplemaking-related tabs disappear and the Report tab appears.
Note: Do not use a backward slash (\) in any Output name.

Note:
There are many sample Outputs in the Example Defaults catalog, accessed by clicking one of the panes in Defaults, then clicking File > Open > Example Defaults. For example, to see how to configure ArtiosCAD to make a sample with Re-board®, you could look at the Kongsberg XL44 - V-notch sample cutting entry under Outputs > Artios > Kongsberg XL44 - Corrugated.

Output Type tab

Output Type group
The choice in the Output Type group of the Output Type page determines which other tabs are available. In the above example, because the Output Type is set to Sample, there are tabs in the dialog box which only appear for samples.

When the Output Type is set to Plot, the tabs which appear only for plots become visible.

The selection in the Output Type group also determines what will be on the Output Type page itself. For example, when the Output Type is set to Grouped Output, the Scale group disappears from the page.

Show In group
The Show In group determines how this Output will be used. At least one of these choices must be selected.
The **Export** menu is meant to be used to group commonly-used file exports together.

The **Send** menu is meant to be used to group together those Outputs which will be emailed.

A **Multiple Workspace** Output lets the same Output be used on a group of workspaces both in ArtiosCAD and in the Database browsers.

**3D** enables you to run this Output from a 3D workspace.

**Project-Bill of Materials** lets you run this Output iteratively for all objects on a BOM.

**Parts Outputs** causes this Output to appear on the Parts Outputs menu in a canvas. If you are using ArtiosCAD Enterprise, make sure to select this and **Browser** to be able to run this Output from a canvas.

**Browser** is available only for ArtiosCAD Enterprise and lets you run this Output by right-clicking in the browser.

When the **WebCenter** checkbox is checked, this Output can be used for downloading files from WebCenter. This is meant only for file outputs such as DDES, DXF, and EPSF. Outputs for WebCenter must have unique names; there may not be an Output used with WebCenter with the same name in both Shared Defaults and User Defaults.

### Scale group

The options in the **Scale** group determine the size of the output.

- **To fit one page** modifies the size of the output so that it fits on one page.
- **Specify** lets you set the size of the output. Setting a scale of one makes a full-sized output. Tiles, which are individual sections of the design, are printed if necessary.
Differential Scale makes the Vertical Scale field appear and changes the Scale field to Horizontal Scale.

Preview control group
The options in the Preview Control group control how and if the Output Preview dialog box appears when running the Output.

Auto Preview, when checked, causes the Output Preview dialog box to automatically open when running the Output. The options in the Layout Type and Window Size groups determine how the contents of the dialog box are shown. Shown below is the Output Preview dialog box.

Device tab
The Device tab lets you specify the hardware device (if applicable) to which the Output will be sent.
When entering this tab for the first time, you may see a dialog box informing you that ArtiosCAD was unable to find a certain printer. Ignore this and click OK to proceed.

In the **Driver Type** group, the **Windows Driver** option instructs ArtiosCAD to send the output information to the operating system mechanism of driving the device. The **CAM Driver** option instructs ArtiosCAD to use its internal methods to drive the device. The selected option in this group determines how the rest of the tab looks. **Bitmap** creates a picture file of the output. **Workspace Layer** creates a new layer in the workspace and draws the output data in that.

**Note:** When outputting to a layer, you must re-perform the Output after each rebuild to maintain correct information in the layer.

**Out to file** sends the output data to a disc file instead of physically out to a device through a port or network connection. Some devices such as samplemakers make a network connection to the CAD workstation and pick up the file automatically.

**Number of copies** allows you to set the default number of copies made when performing this Output.

The value selected in the **High graphics memory use** drop-down list box determines how much memory ArtiosCAD uses when outputting a bitmap image (typically a referenced PDF file when the PDF option has been purchased). This option is available only for Outputs of type Windows Driver or Bitmap.

A bitmap may have a maximum of 15 million pixels. The size of the bitmap is calculated dynamically during the output; system performance may be affected if a large bitmap is

---

### Output Type

<table>
<thead>
<tr>
<th>Output Device</th>
<th>Device</th>
<th>Reports</th>
</tr>
</thead>
</table>

#### Driver Type

- Windows Driver
- CAM Driver
- Bitmap
- Workspace Layer

#### Windows Driver

- LOCAL Canon IR330-400 PS Ver 1.0

#### Orientation

- Portrait
- Landscape
- Optimum

#### Number of Copies

- 1

#### High graphics memory use

- Upto 15 million pixels
required. You can set the maximum number of pixels for the Output to use to balance system speed and output resolution. There are four choices: High graphics mode off, Upto 5 million pixels, Upto 10 million pixels, and Upto 15 million pixels. The fewer the number of pixels used, the coarser the resolution of the output.

Windows driver

When Windows Driver is selected, there is a drop-down list box allowing you to choose the device that will perform the output. Devices must be set up in the operating system beforehand for ArtiosCAD to list them here. You can also choose the orientation of the output on the page by choosing the appropriate choice in the Orientation group: Portrait, which makes the long side of the paper the vertical axis, Landscape, which makes the long side of the paper the horizontal axis, or Optimum, which sets the orientation based on which one can output at the largest scale.

You can also set the High graphics memory use when using a Windows driver.

CAM driver

When CAM driver is selected, the Output Device group changes to look similar to the following picture, except no data will be shown in the various fields:

The Tuning Entry field indicates the type of device receiving the output data from ArtiosCAD. CAM driver specifies the internal ArtiosCAD method for creating the data. Tuning Filename lets you choose the configuration file for the device. CAM Device Name lets you set the Output Destination for the data if it is not going out to file. Refer to the Peripherals chapter for more information about installing CAM devices.
**Bitmap outputs**

The **Bitmap** driver type lets ArtiosCAD output a bitmap picture of a workspace.

The option buttons in the **Bitmap Format** group set the type of bitmap created. JPEG output (Joint Photographic Experts Group) makes compressed pictures for efficient use in other programs, but some color information is lost. PNG output (Portable Network Graphic) is used for vector graphics (lines and arcs) shown on the World Wide Web. TIFF output (Tagged Image File Format) is uncompressed and is useful for other graphic programs such as Adobe Photoshop. Note, however, that TIFF files are usually quite large.

The **Shrink size to remove white space** checkbox, when checked, causes ArtiosCAD to crop the extra white space around the perimeter of the design upon Output.

The **JPEG Quality** field adjusts the quality and the file size of the resulting JPG file. A value of 0 makes the smallest file with the worst quality, while a value of 100 makes the largest file with the best quality. ArtiosCAD defaults to 70. Set the value in this field between 80 and 90 if you will be making Animations in 3D. This field is available only when the **Bitmap Format** is set to JPEG.

**High graphics memory use** determines how much memory ArtiosCAD uses to render PDF graphics being processed by the Output.

Getting bitmap outputs just right can take some experimentation.
Output to layer

*Workspace Layer* writes the results of an Output to a layer in a design.

For example, you could define a Report output to go to a layer, and send the resulting file to a customer. The customer could then use the ArtiosCAD Viewer to view both the design and your report.

The *Automatically overwrite* checkbox controls whether the layer will be overwritten each time the Output is performed. If the checkbox is cleared, a number will be appended to the layer name in a sequential fashion.

**Note:** When outputting to a layer, you must re-perform the Output after each rebuild. When a design is rebuilt, the layer that was output to is automatically deleted as the information that was in it does not reflect the current state of the workspace.

Outputs using high graphics mode

Outputs that support bitmaps can use high graphics mode. These must be actual Outputs, as opposed to using the *Print* command on the File menu.

A bitmap may have a maximum of 15 million pixels. The size of the bitmap is calculated dynamically during the output; system performance may be affected if a large bitmap is required. You can set the maximum number of pixels for the Output to use to balance system speed and output resolution. The pixel usage is configured in the High graphics memory usage drop-down list box in the Output method's settings in Defaults, or may be configured each time in the Properties dialog box. There are four choices: *High graphics mode off*, *Upto 5 million pixels*, *Upto 10 million pixels*, and *Upto 15 million pixels*. The fewer the number of pixels used, the coarser the resolution of the output.

The memory usage for high graphics mode when using a 3D Output is fixed at 15 million pixels.

Shown below is the Properties dialog box for a Kongsberg CM1930 samplmaker with the Illustrator 2 printing head:
Shown below is the Plot to Printer dialog box.

**Position tab**

The settings on the **Position** tab indicate the physical placement of the output on the output medium.
Device Size and Margin groups

The fields in the **Device Size** group let you set the size of the device (if you are using a CAM driver; otherwise, the size fields are unavailable) and the starting position as measured from the bottom left corner of the medium.

The settings in the **Margin** group set the distance between the edge of the medium and the physical area that can be printed by the device. When you set the device size to 0 (for unlimited size), you can still set the margins.

Orientation and Position groups

The commands in the **Orientation** group let you specify the relative position of the output on the device.

The options in the **Position** group control the point to which the output is snapped on the device and the side of the design which is output. The nine buttons snap the design to their respective location on the page - top left corner, top center, top right corner, right center, bottom right corner, bottom center, bottom left corner, left center, and center.

The **Side Up** list box lets you choose which side of the design is output: the Inside, Outside, Die Knife side, Die back side, or the default side, which is the current side of the design.

Reports tab

The **Reports** tab lets you specify a report to output using the data in the design. Check the **Use Report** checkbox and choose the report to use.
If the desired Report is not in the Reports Catalog, use the Specify button to browse for it.

Directories tab

The Directories tab lets you specify if the output data is written to a disc file instead of going to the physical device. The Out to file checkbox on the Device tab must be checked in order for these options to work. The contents of this dialog box will vary depending on what Output type is selected on the Output Type tab. The examples shown below are for plots. If the Output Type were set to Sample output, there would be many more fields for the different kinds of files that sample output can generate.

Make DOS Compatible truncates the filename so that it conforms to the 8.3 file-naming convention used in MS-DOS. When this checkbox is checked, the Strip front and Strip back option buttons become available. These control which part of the filename is stripped off to make it eight characters.

Automatically Overwrite controls if you are prompted to overwrite (delete) an old output file with the same name as the output file you will create when performing the output. This
ArtiosCAD

option is usually checked by default in pre-defined Outputs that create files. If this option is checked for an Output that is added to a Grouped Output, the current filename with the default extension is used. The current directory is also used; you are not prompted to select a directory. You might have to search for the file created by the Output as it may not be where you expect it. Use this option with care.

Automatically Open opens the file in the associated Windows application after being output. For example, if you output a .txt file, Windows would recognize it as a Notepad document and open it in Notepad.

File groups

The names and amount of data fields in this dialog box depends on the type of Output selected on the Output Type tab. When the Output type is set to plot, for example, there is one file group, Plot File, but when the Output type is set to Sample, there are four file groups - Make Counter File, Partial Cuts File, Make Sample File, and Print Sample File. In each group, however, the fields and checkboxes are all the same and work the same.

The Extension field lets you use the same filename extension, which is the part of the file name which follows the last period, each time this Output is performed. By default, the filename is the same as the workspace name. Leave this field blank to specify an extension when creating an output file.

The Directory field lets you type the location of the directory in which to store the output file. Use the ellipsis button to browse for a directory.

The Fixed filename checkbox lets you specify the same filename for all files created using this Output. When this checkbox is on, and the directory specified in the Directory field is valid, the filename selection dialog box is suppressed.

From command file indicates that the filename is generated by a command file. When this option is checked, the output file name will be the result of executing the function TLIBRARY(GenSName.txt). Since Fixed Filename is not checked, the resulting filename is the default filename when the output is run.
**View tab**

The options on the **View** tab of the Output dialog box control how the layers and line types are output.

**Style Selection group**

**Specify Plotting Style** overrides the plotting style at time of output with the plotting style specified in the **Available Plotting Styles** drop-down list box. The list box is available only when this option is checked. Checking **Rule labels** turns on rule labels for this Output.
Dimension Position group

**Auto-adjust overlapping text** prevents rogue text items from being printed on top of each other. You can specify the range of text sizes to consider when ArtiosCAD looks for overlapping text by entering point values in the **Minimum text size** and **Maximum text size** fields.

The **Remove extension lines** checkbox controls whether extension lines are removed if text has to be moved to make it not overlap.

Override Dimension Format group

The options in the **Override Dimension Format** group allow you to override the workspace settings for the dimension format with those that you choose in this group. Set them as desired.

View Selection group

The options in the **View Selection** group control which layers are output when running the output.

- **Current zoomed in view** Outputs the objects in the current zoomed in area. In this case the **Layer set selection** is set to **Current View** and the **Available Layers** list is unavailable.
- **Current selection** uses the currently selected items as the Output. All non-selected items are ignored. If no items are selected, the Output defaults to the Current View Layer set selection.

The **Use selection for report calculations** checkbox is only available with **Current selection** and is only applicable if the Output uses a Report. This option forces the calculated text commands in the Report to be evaluated against a temporary document which contains a copy of the selected item.

Choose the layer to output from the **Layer Set Selection** drop-down list box.
Choosing a layer set from the drop-down list box toggles different layers in the Available Layers group. Select or deselect layers as desired. To choose specific layers without starting from a preconfigured layer set, select the User Defined layer set, and then select layers as desired.

**Note:** Do not select both the Designs layer and Rule Path layer for any Output.

The options in the Rotary Diemaking View Level group control how the size of the Output is manipulated when the Layer Set Selection is set to Dieboard. Design Level, Wood Level, and Cylinder Level apply the appropriate shrink or stretch factors to the output data so that the output is sized correctly.

### Processing tab

The commands on the Processing tab control how the data is manipulated between when you click Output and when the data arrives at the output device or disc file.
Note: The options on the Processing tab depend on the type of output chosen on the Output Type tab. Different outputs have different options.

The **Browse** button at the end of the **CAM Tooling Setup** field lets you choose the CAM Tooling Setup to use in this Output. The CAM Tooling Setup maps which line types are mapped to which physical tools on the output device. Click it to choose an entry from the Select Cam Tooling dialog box.

### Optimization options group

Depending on the Output Type chosen, items in this group may be unavailable.
No optimization makes no changes to the output data.

Plotter Pen Optimization examines each 100 lines of output code, groups together lines made with the same pen, outputs them, and then examines the next 100 lines.

Enable subroutined output means support subroutines in the NC (numeric control) output, which only works with the PUNCH command and certain SAVE commands. Turning this checkbox off combines all elements of the design or manufacturing file into one set of data on output.

Enable subroutined output also works and should normally be checked for CFF2-Save and DDES-Save and Elcede exports. For a driver that supports this option, checking this checkbox causes each different design to be output as a subroutine, with a call to that subroutine for each instance of the design on the sheet. This saves memory in the controller for an NC output, and differentiates each design from the layout in DDES and CFF2 output. When this checkbox is clear, the entire layout is output flat, as if it were one big design. This option must be checked for the Layout Sequencing group to be available.

Line processing options group
The option buttons in this group determine how lines are physically output.

No processing ignores bridges and outputs each special rule as a single line.

Design representation means that special rules are output as “actual” lines; for example, a wave rule would be output as a series of arcs.

Partially-cut bridges instructs the output device to cut into the material at a partial depth to make room for bridges in the rule.

Leave gaps for bridges splits the line output data into pieces and leaves gaps in the output data for bridges, meaning that no slot or line is created in the output material where the bridges occur.

Software line styles processes all line styles before they are sent to the driver. For example, when this option is selected, a perf would be broken up into a series of short cut lines and gaps instead of one line marked perf that the driver would then process. This option is available only for Plot outputs.
Layout Sequencing group

The options in this group are shown only when the output type is set to Plot, CAM, Sample, or Counter on the Output Type tab. Enable subroutined output in the Optimization options group must be turned on for this group to be available in Plot and CAM outputs.

The Sequence one-ups in layout checkbox determines if ArtiosCAD automatically resequences the single designs in the layout when they are output. Clear this checkbox if you plan to always use the Layout Manual Sequencing tool with this Output.

The first group of four buttons sets the starting point for the sequencing. The first button starts the sequencing at the bottom left of the layout. The second button starts the sequencing at the bottom right of the layout. The third button starts the sequencing at the top left of the layout. The fourth button starts the sequencing at the top right of the layout.

The second group of four buttons controls the sequencing direction and is not available until a button in the first group is pressed.

The first button sequences each horizontal row, starting each row on the same side of the layout so that each row is sequenced in the same direction, as shown in the picture above, with the starting point at the bottom left.

The second button sequences each vertical column, starting each column on the same side of the layout so that each column is sequenced in the same direction.

The third button sequences each row, starting on opposite sides of the layout so that each row is sequenced in the opposite direction, forming a horizontal snake pattern.

The fourth button sequences each column, starting on opposite sides of the layout so that each column is sequenced in the opposite direction, forming a vertical snake pattern.

Nicks group

Nick gaps controls if ArtiosCAD leaves a gap in the line for a rule bender to interpret as a nick.

The Draw nick style checkbox controls whether nicks are drawn on the output, and the drop-down list box lets you choose the style to use from the Nick Styles Catalog.
Note: You can make gaps for both bridges and nicks in the same Output, provided that the nicks and bridges are not on top of each other, which weakens the rule and should be considered an error. The rule bender would typically consider gaps of hypothetically 1mm or less to be a nick, and wider gaps to be bridges.

There are three ways to Output nicks:

• Line crossing perpendicular.

• Line parallel with a line.

• Leave a gap.
For the Line crossing perpendicular or Line parallel on top options:
- Add an appropriate nick style if it does not already exist in Defaults.
- Edit the export tuning file to map nick type 17 to the appropriate output type.

For all 3 cases:
- Add an output with the appropriate driver for the rule bender.

For Line crossing perpendicular:
- Check **Draw nick style** and choose a nick style where the nick is centered on the line.

For Line parallel on top:
- Check **Draw nick style** and choose a nick style where the nick is parallel to the line.

For Leave a gap:
- Turn on **Nick gaps**.

**Rubber group**

The options in this group affect how rubber is shown on the Output.

If **Fill - Color by** is selected, the rubber is drawn filled with color; choose to color the rubber by **Rubber type** or **Element number**. ArtiosCAD cycles through about 10 colors when drawing by element number. If **Fill - Color by** is not selected, the rubber is drawn as outlines.
To draw the element number inside each piece of rubber, select **Show element numbers**, and then set the **Size**: field (in points) and **Italic** checkbox as desired.

**Dieboard group**

The options in this group control how the dieboard is created for a relevant Output type.

*Ignore die splits (full dieboard)* makes a full dieboard regardless of any splits.

*Undercut at die splits by* instructs the output device to cut back each line leading up to a die split from the split by the amount specified. Bridge positions are correctly maintained.

*Undercut at crease ends by* instructs the output device to put a bridge of the size specified at each end of all creases. If a crease line is bridged, any cutback may not exceed the size of the bridge width. If this option is chosen, set the minimum size of the line that will be undercut in the **Minimum crease length**: field.

**Text options group**

*Plotter font* tells the output device to use its built-in font for rendering the text. Use this option for pen plotters or for a driver that supports simple text entities, but not fonts, such as CFF2, DDES, Elcede DieCAD, and DXF.

*Line text* converts the text to geometry, which is then affected by transformations on output. Line text is suitable for etching text on a die. This is particularly useful for Asian languages, because the **Name** tool in Manufacturing only supports ASCII characters. To use Line text on a die or stripping tool, add a text item in a suitable font to the die or stripping board layer, with no color, and use an output configured with Line text. A suitable font for line text should be simple, have parallel edges, and not be too thick.

*Normal text* leaves the text alone. Normal text will always be output so that it is readable, regardless of dieboard orientation. This is suitable for output formats that support fonts, such as all Windows drivers, EPSF, and bitmap outputs.

Text is always output right side up, for all three of the above options. The only way to output text backwards is to convert the text to lines in the design using the **Outline Text** or **Line Text** tools.
Identify Zero Length Lines

Identify zero length lines, when checked, warns you about zero-length lines and draws a small pink rectangle around them when you perform the Output.

Click Ignore to ignore them and continue the Output, or click Cancel to stop the Output so you can delete them using Designer's Fix-It.

Crease Cutback Dimensions

Crease Cutback Dimensions on the Processing tab toggles the display on an Output of crease cutback distance dimensions for steel counters or for any other time when the top side of the rule is a different length than the bottom side of the rule. The Crease Cutback Plot example in the Steel Counter folder on the Outputs menu uses this option. If you use this feature, you may want to create custom Outputs that send the Output to a layer so that the crease cutback distance dimensions are saved with the workspace.

Shown below is a close-up of the preview of a crease cutback plot Output.
On the Processing tab in Outputs, clicking the More Options (...) button opens the Crease Cutback Dimensions dialog box.
Draw annotation lines draws a rectangle of annotation lines from the crease cutback to the point you select in the Measure to group:

- **Edge of rule** is the point ArtiosCAD calculates so that the crease rule does not overlap any abutting rules.
- **Center of rule** is the end of the crease as drafted.
- **Use end bridge if present** measures to the end of the bridge on the crease.

The checkboxes in the Display crease cutback values for group determine if ArtiosCAD flags special conditions in the Output.

- **Conflict** is when the estimated rule end is further than the crease cutback. ArtiosCAD shows !!! in this case. These are line type Annotation3.
- **Crease/crease** flags creases that intersect other creases with an asterisk *. ArtiosCAD always assumes that the crease is cut back enough to not touch another rule. When two creases meet, it is not sure which one takes priority, so flags them for human checking. These are line type Annotation4.
- **Perpendicular** is when the expected end of the crease is exactly half the width of the cut rule. As this is the expected case, this option is off by default. This check may not work as expected if the rules in the design are different pointages. These are line type Annotation5.
- **Other** is when a crease rule intersects a cut at an odd angle, or any other case. These are line type Annotation.

**Note:**

- The size of the text is based on the Text catalog entry in Property Defaults.
- Dimensions display 3 decimal places for Imperial measurements and 4 for metric.

**Restrictions**

- ArtiosCAD treats special rules as regular lines. There is no way to specify slot or actual.
- ArtiosCAD assumes the crease end is squared, not chamfered or rounded.
- ArtiosCAD does not detect that a crease needs to be split if it is intersected in the middle.
There is no way to customize the appearance of the dimensions other than the size. The font, color, and number of decimal places are all fixed.

There is no way to customize the shape or type of the annotation lines.

Diesaw tab

Kongsberg DieSaw group

This tab appears only when the output is to a Kongsberg DieSaw.

**Full board depth** is the thickness of the dieboard.

**Generate saw leader holes** controls whether ArtiosCAD creates leader holes. **Leader holes** are drilled holes in the dieboard which allow the saw to position itself to start cutting in the proper position. They are made before any saw cuts.

**No leader holes in corners**, when checked, prevents ArtiosCAD from automatically creating leader holes in corners. Leader holes are instead put on bridges of the lines that meet to form a corner.

**Adjust leader holes on bridges** allows ArtiosCAD to move the leader holes further apart from each other if they occur at either end of a bridge. When this happens, the amount of material left between the two holes is not strong enough and could break; therefore, the centers of the leader holes are offset from the ends of the lines to prevent bridge breakage. The picture below illustrates this process.
The Allowance reduction specifies by how much the edge of the leader hole is offset from the maximum adjustment of the hole position. The maximum adjustment would position the edge of the leader hole tangent with the end of the rule path. The Allowance reduction is the distance by which the leader hole is moved away from that tangent position.

Lines shorter than the length specified in the No hole length field do not have leader holes drilled for them; rather, they have a lead-in line cut for them with a hole at the beginning of the lead-in line. The length of the lead-in line is specified in the Length of lead-in field.

Lines shorter than the value in the One Hole Length field (but longer than the value of the No hole length field) get only one leader hole drilled.

The value in the Long saw length field sets the minimum length of lines that are optimized for the quickest sawing time. For lines longer than the long saw length, the direction of the line and the leader hole is determined by optimizing the sawing time. For lines shorter than this value, the direction of the line is determined to use the minimum number of leader holes. Connected lines that are longer than this value will not share leader holes.
The settings on the Tiling tab control what happens when the scale of the output is too big to fit on one sheet of output medium.

<table>
<thead>
<tr>
<th>Tiling</th>
<th>Sample Line Types</th>
<th>Sample Sequencing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tile Registration</td>
<td>Registration cross size:</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Tile overlap:</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Sampling/making registration offset</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Sampling/making registration hole diameter:</td>
<td>1/4</td>
</tr>
<tr>
<td></td>
<td>Just draw registration marks</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Using sample counter</td>
<td></td>
</tr>
</tbody>
</table>

- **Output Filename Generation**

When outputting to file, insert the following before the extension:

- Tile separator character: `_`

- **Tile Representation**

  - Represent tile as number (1...) |
  - Represent tile as a character (A...) |
  - Use row/column position (1A, 1B ...) |

- Example filename: Design_4.txt

- **Skip empty tiles.**
- **Confirmation required for each tile, when outputting directly to a device**

**Skip empty tiles** tells ArtiosCAD to not output blank tiles. If you will be assembling all the tiles together into one big sheet, you may want to leave this option unchecked so as not to confuse the assembler.

**Confirmation required for each tile, when outputting directly to a device** tells ArtiosCAD to prompt you to click OK before outputting each tile. This is handy for when you have to reload media on the output device in between tiles.
Tile registration group

The options in this group control how the tiles are marked for assembly.

<table>
<thead>
<tr>
<th>Tile Registration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Registration cross size:</td>
</tr>
<tr>
<td>Tile overlap:</td>
</tr>
<tr>
<td>Samplemaking registration offset:</td>
</tr>
<tr>
<td>Samplemaking registration hole diameter:</td>
</tr>
<tr>
<td>□ Just draw registration marks</td>
</tr>
<tr>
<td>□ Using sample counter</td>
</tr>
</tbody>
</table>

**Registration cross size** is the overall height and width of the cross mark. Setting this option to zero turns off the drawing of registration crosses in the output. Also, registration crosses are only drawn in the corner of tiles which align with other tiles; a registration mark will never be drawn in the bottom left corner of the first tile.

**Tile overlap** is the amount of overlap from one tile to the next. This value will be used for both the horizontal and vertical overlap. A value of zero means no overlap, and when used with registration crosses, turns the cross marks into corner marks.

**Samplemaking registration hole diameter** is only available for Sample outputs and is the diameter of the hole cut into the sample material to aid in registering oversized samples. The diameter value must be between zero and the size of the registration crosses. The hole is centered on the registration mark.

**Using sample counter** and **Just draw registration marks** are also only available for Sample outputs. These options indicate if a counter is being used when this Output is run. If **Just draw registration marks** is selected, then the **Make Counter** button on the main sample output dialog (what you see when you perform the Output) is replaced with a **Draw Registration** button. This button is unavailable if tiling is not required. Selecting this option will generate output files (using the Make Counter file designations) with just the tile registration marks drawn using a sample pen.

Output filename generation group

The options in the **Output Filename Generation** group automatically constructs a unique file name for each tile when the output is set to go out to file. When both conditions are met (Out to file and a scale larger than can fit on the output device), the options in this group change the name out of the output file to indicate the separate tiles.
Sample line types tab

You configure the line types and tools used in samplemaking on the Sample line types tab.

To configure how the line type is handled when performing this Output, select the line type in the Line type: group and choose the tool in the Samplemaking tool: group. There may be settings for the tool that appear in the bottom right corner; if there are, set them as desired.

As with other tabs, the information displayed on this tab is conditional; that is, the information requested on the right side of the tab depends on the selected item on the left side of the tab. What you see will not necessarily look exactly like the picture above.

To make nicks in the sample whose size based on the caliper of the board, enter a multiplier in the field next to + CAL *.

---

It seems there's an issue with the image display. If you can provide a clearer version or describe any specific elements from the image, I'd be happy to assist further.
To cut stripping rules on the sample, check the **Cut stripping rules** checkbox. Stripping rules are cut outward from the design to avoid overcuts.

The **Size only** samplemaking tool is used to calculate the output size. Use it only when outputting to a layer.

When using Re-board®, samplers cannot cut small holes in the material and use a drill tool instead. Therefore, enter an appropriate value in **Drill holes smaller than diameter** for holes that are drilled and not cut. If you will be using drill holes, you should update the **Sample drill hole** line type on the Sample tab of your plotting style definition so that it uses a thicker solid line instead of the default.

**Text options group**

<table>
<thead>
<tr>
<th>Text options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plotter font</td>
</tr>
<tr>
<td>Line text</td>
</tr>
<tr>
<td>Normal text</td>
</tr>
</tbody>
</table>

**Plotter font** tells the output device to use its built-in font for rendering the text. Use this option for pen plotters or for a driver that supports simple text entities, but not fonts, such as CFF2, DDES, ElcedieDieCAD, and DXF.

**Line text** converts the text to geometry, which is then affected by transformations on output. Line text is suitable for etching text on a die. This is particularly useful for Asian languages, because the **Name** tool in Manufacturing only supports ASCII characters. To use Line text on a die or stripping tool, add a text item in a suitable font to the die or stripping board layer, with no color, and use an output configured with Line text. A suitable font for line text should be simple, have parallel edges, and not be too thick.

**Normal text** leaves the text alone. Normal text will always be output so that it is readable, regardless of dieboard orientation. This is suitable for output formats that support fonts, such as all Windows drivers, EPSF, and bitmap outputs.

Text is always output right side up, for all three of the above options. The only way to output text backwards is to convert the text to lines in the design using the **Outline Text** or **Line Text** tools.

**Make nicks in sample group**

The **Make nicks in sample** checkbox controls if nicks are made when cutting a sample. Check the box to have the samplecutter make the nicks as defined in the design being output, or clear it to ignore nicks. When the checkbox is checked, the **Adjustment for nick overcut** field
ArtiosCAD is available. This is the offset distance between the tip of the blade and the point where the blade exits the material.

**Sample Sequencing tab**

The settings on the Sample Sequencing tab control how some problematic scenarios are dealt with when making a sample, as well as controlling layout sequencing.

Split lines connecting corners and Automatically round corners may not both be selected.

For **Sequence one-ups in layout**, see the Layout Sequencing group section for the Processing tab.

When you cut labels on a samplemaker, **Join cuts across oneups** causes the samplemaker to keep cutting through the gaps between aligned labels for faster progress instead of having to lift the knife and turn to cut label by label. **Maximum gap to cut through** sets the size limit for this behavior.

**Note:** When you select **Join cuts across oneups**, **Sequence one-ups in layout** is unavailable.
Round slot method group

Cutting a sharp corner can tear the material being cut. The options in the Round slot method group control how sharp corners are cut. Sharp corners are identified using Tear Distance and Tear Angle.

If a corner is narrower than the distance defined for the Tear distance, it is a sharp corner. If a corner has an angle less than the angle specified in Tear angle, it is a sharp corner.

Option A, Continuous cut, cuts all the lines in the slot in one direction.

Option B, Reverse the last line, reverses the last line to cut into the slot.

Option C, Cut short lines last, cuts the long lines first and then the connecting lines.

Overcut method group

The mechanics of samplemaking require that the knife cuts a little past the end of a line. If the direction of the line is into the sample, this will leave a mark on the sample. On a sample table such as a Kongsberg with a vertical rear edge to the knife, this problem can be fixed by reversing these lines (but only where this does not conflict with the line order required for sharp corners).
In the **Overcut method** group, you can set the overcut method to reverse at perpendicular intersections (called **T-junctions**). You can also specify to **Split lines connecting corners**.

**Automatically round corners group**

Some samplemakers can automatically replace a corner with a radius, reducing the number of knife lifts.

The **Radius**: field sets the size of the radius. The shortest lines intersecting to form a corner must be at least the length specified in the **Minimum length:** field to replace a corner with a radius.

**Over-crease group**

**Over-crease** is when the ceasing wheel makes a continuous crease through gaps and on top of cuts. In the **Over-crease** group, specify the maximum sizes of gaps and cuts to run the creasing wheel over without it lifting.

Set the value in the **Maximum length of cut to over-crease**: field in the **Over-crease** group to set limits on what is output as one line and what is output as separate lines.
The value in the **Maximum length of cut to over-crease**: field sets a limit so that short cuts and creases are output as a sequence while long cuts and creases are output separately. Adjust this field as needed to result in a series of short cuts with one long crease.

Set the value in the **Maximum gap to over-crease**: field to the maximum size of the gap the creasing wheel will pass through without lifting.

### Sample creases tab

The commands on this tab control how creases are made on the samplmaking machine.

- **Single pass creasing** and **Double pass creasing** control the number of times the creasing tool passes over the material to make a crease. **Double pass with grain crease** and **Double pass cross grain crease** only perform double pass creasing for creases in the specified direction, and use the options in the **Double pass crease offset** group.

- **Double pass reverse crease**, **Second tool for cross grain**, and **Second tool for thicker creases** enable their namesake actions when checked.

  The **Crease cut back** is the amount by which creases are shortened at both ends.

### Double pass crease offset group

The options in this group are available only when **Double pass creasing** is selected.
The offset can be a fixed distance (in current units), a multiple of the caliper, or an allowance for the pointage, or any combination of the three.

If **Double pass for reverse creases** is selected, the same crease offset applies as for creases, but no counter channel is made for reverse creases.

A fixed offset is specified by checking the **Fixed offset** checkbox and entering the value. A multiple of the caliper is entered by checking the **Multiple of caliper** checkbox and entering the value. To allow different pointage creases to have different crease offsets, check the **Allow for pointage** checkbox and enter the width of the scoring wheel. This defaults to 0.028 inches = 2 points; this adds (pointage - value) to the crease offset.

**Sample Counter tab**

The options on this tab control how sample counters are made. For each type of crease in the **Parameter for**: group, you can set the type of crease channel as well as the widths, counter cut back, and the channel angle. Routed counters invoke conditional text by deleting the field for the channel angle and inserting fields for the routing tool widths. The grain angle tolerance is the same for all crease types.
Print Sample Position tab

The Print Sample Position tab lets you specify how to print sample graphics on your sample printer.

This tab contains the exact same controls as the Position tab.

Send to tab

The commands on the Send to tab let you send the results of the Output via email. The design file itself is not sent when an Output with this option enabled is run. You must have a MAPI-compliant mail program such as Microsoft Outlook installed on your computer for this to work. If you do not have a MAPI-compliant email program installed, you will receive error messages when you attempt any email-related functions.

<table>
<thead>
<tr>
<th>Tiling</th>
<th>Send to</th>
<th>Advanced</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The Use email checkbox turns on this feature.

The To and Cc buttons let you choose recipients from your mail program's address book.

Prompt for message opens the message in your email program. If this option is not checked, the message is sent with no user intervention.

Attach to email sends the output as an attachment, while Put contents in email inserts the text of the output into the message body.

Delete output disk file deletes the file created by the Output after it is added to the email. To preserve the file, clear this checkbox.

Advanced tab

The commands on the Advanced tab are meant to be used by people with very specific needs.
Show Command for Diagnostics displays the instructions ArtiosCAD follows when making the output. ArtiosCAD then instructs you to click OK to perform the Output or Cancel to cancel it as shown below:

Use prompting report indicates that a special report is used with this Output. Prompting reports prompt you for workspace variables and do not produce a printed output. Once this report is run, the variables are copied into the workspace. This is useful for setting variables that you want to track in DataCenter.
Use post processing command file lets you specify the name of a command file that modifies the geometry in the :TEMPOUTPUT section. You should only use this feature if you have extensive knowledge of the INTERACT programming language. The command file you specify must not have any menu windows and must not crash.

Output through command file directs the output data through a command file specified in the EXE field with parameters specified in the entry box after OUTPT.

Launch Executable and its associated options are meant for use by Esko personnel who design custom solutions. It launches a program to which you can pass data from ArtiosCAD and pass data from the program back into ArtiosCAD.

Prompt for Kongsberg Material is covered in the next section.

Run Time Data Set is used with an Output that uses the GNC driver.

Prompt for Kongsberg Material group

In the Prompt for Kongsberg Material group, Use Material List from Text File prompts you to select a Material Setup File when running this Output. Material Setup files are usually configured when your Kongsberg sample table is installed. Shown below is the Specify A Kongsberg Job Setup File dialog box when the Output is performed.

Specify path to Material list file lets you enter the default location of the files rather than having to specify it when the Output runs.

Use Material List from IPC Resource Database allows you to query the i-cut Production Console (IPC) server running on a Kongsberg front end for a list of materials. In the IPC System.
Name field, enter either the hostname, fully qualified domain name, or IP address of that machine. If you use firewalls, open ports 80 and 10003.

Record Variable Definition

These records and variables are created in the Output that is acted upon by the command file you specify in the Output through command file checkbox. Use these records to get information from the design to the command file.

<table>
<thead>
<tr>
<th>Record</th>
<th>Variable</th>
<th>Sub-variable</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;OUTCM.</td>
<td>CMD$</td>
<td></td>
<td>the actual command that would be issued</td>
</tr>
<tr>
<td></td>
<td>DEBUG</td>
<td></td>
<td>1 if “Show Command for Diagnostics” is ON, else 0</td>
</tr>
<tr>
<td></td>
<td>CMDTY$</td>
<td></td>
<td>the command type “PLOT”, “PUNCH” or “SAVE”</td>
</tr>
<tr>
<td></td>
<td>CMDTYP</td>
<td></td>
<td>command type - if (OTPTYP = 0 or 2) = 0, else (OTPTYP = 1) = 0 for Make Counter, 1 = Make Sample, 2 = Partial Cuts, 3 = Print Sample</td>
</tr>
<tr>
<td></td>
<td>DRV$</td>
<td></td>
<td>the driver name e.g. “PRTMAN”, “HP”</td>
</tr>
<tr>
<td></td>
<td>DEV$</td>
<td></td>
<td>the device name - when going directly to the device - not defined when going out to a file</td>
</tr>
<tr>
<td></td>
<td>USRTX$</td>
<td></td>
<td>additional user defined command parameters</td>
</tr>
<tr>
<td></td>
<td>OPT$</td>
<td></td>
<td>driver “opt” flag - either “OPT” or empty (“”)</td>
</tr>
<tr>
<td></td>
<td>DRVOP$</td>
<td></td>
<td>additional driver options</td>
</tr>
<tr>
<td></td>
<td>KGBMF$</td>
<td></td>
<td>KGB Material file name - not defined if not used or empty</td>
</tr>
<tr>
<td></td>
<td>OUTFL$</td>
<td></td>
<td>the output file name - not defined when going directly to the device</td>
</tr>
<tr>
<td></td>
<td>TUNE$</td>
<td></td>
<td>the tuning file name</td>
</tr>
<tr>
<td></td>
<td>DVSZLX</td>
<td></td>
<td>the lower X of the device size (in current units)</td>
</tr>
<tr>
<td>Record</td>
<td>Variable</td>
<td>Sub-variable</td>
<td>Definition</td>
</tr>
<tr>
<td>--------</td>
<td>----------</td>
<td>--------------</td>
<td>--------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>DVSZLY</td>
<td></td>
<td>the lower Y of the device size (in current units)</td>
</tr>
<tr>
<td></td>
<td>DVSZUX</td>
<td></td>
<td>the upper X of the device size (in current units)</td>
</tr>
<tr>
<td></td>
<td>DVSZUY</td>
<td></td>
<td>the upper Y of the device size (in current units)</td>
</tr>
<tr>
<td></td>
<td>WINLX</td>
<td></td>
<td>the lower X of the window - not defined if not tiled output</td>
</tr>
<tr>
<td></td>
<td>WINLY</td>
<td></td>
<td>the lower Y of the window - not defined if not tiled output</td>
</tr>
<tr>
<td></td>
<td>WINUX</td>
<td></td>
<td>the upper X of the window - not defined if not tiled output</td>
</tr>
<tr>
<td></td>
<td>WINUY</td>
<td></td>
<td>the upper Y of the window - not defined if not tiled output</td>
</tr>
<tr>
<td></td>
<td>SEC$</td>
<td></td>
<td>the section to output e.g. “:TEMPOUTPUT” or “:TEMPOUTPUT:GRAPHOUT” (for print sample)</td>
</tr>
<tr>
<td></td>
<td>SCLSTR</td>
<td></td>
<td>scale or stretch - 1 for “SCALE” - 2 for “STRETCH”</td>
</tr>
<tr>
<td></td>
<td>XSCALE</td>
<td></td>
<td>x scale factor</td>
</tr>
<tr>
<td></td>
<td>YSCALE</td>
<td></td>
<td>y scale factor (set to XSCALE when SCLSTR = 1)</td>
</tr>
<tr>
<td></td>
<td>NEGX$</td>
<td></td>
<td>either “NEG X” or EMPTY (“”)</td>
</tr>
<tr>
<td></td>
<td>ROT</td>
<td></td>
<td>rotation in degrees</td>
</tr>
<tr>
<td></td>
<td>POSX</td>
<td></td>
<td>X position in current units</td>
</tr>
<tr>
<td></td>
<td>POSY</td>
<td></td>
<td>Y position in current units</td>
</tr>
<tr>
<td></td>
<td>LTYP$</td>
<td></td>
<td>the parameters to the TYPE keyword e.g. “TYPE #SCUT, #CREASE..#SRXCREASE NOGRAPH” or empty(“”)</td>
</tr>
<tr>
<td></td>
<td>STY$</td>
<td></td>
<td>the plotting style to use e.g. “STY artios1” or empty(“”)</td>
</tr>
<tr>
<td>Record</td>
<td>Variable</td>
<td>Sub-variable</td>
<td>Definition</td>
</tr>
<tr>
<td>--------</td>
<td>----------</td>
<td>--------------</td>
<td>------------</td>
</tr>
<tr>
<td>&amp;OUTPT.</td>
<td>TILEX</td>
<td>for tiling - the row of this tile</td>
<td></td>
</tr>
<tr>
<td></td>
<td>TILEY</td>
<td>for tiling - the column of this tile</td>
<td></td>
</tr>
<tr>
<td>&amp;OUTPT.</td>
<td>OTPTYP</td>
<td>the output type 0 = PLOT, 1 = SAMPLE or 2 = MFG</td>
<td></td>
</tr>
<tr>
<td></td>
<td>OTPNM$</td>
<td>the name of the output</td>
<td></td>
</tr>
<tr>
<td></td>
<td>USESCL</td>
<td>1 to use the scale given - else automatically calculate it</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SCALE</td>
<td>the scale factor given</td>
<td></td>
</tr>
<tr>
<td></td>
<td>USESTR</td>
<td>1 to use “STRETCH” instead of “SCALE”</td>
<td></td>
</tr>
<tr>
<td></td>
<td>YSCALE</td>
<td>the y-scale factor given</td>
<td></td>
</tr>
<tr>
<td></td>
<td>USEFRM</td>
<td>1 - this output uses a form</td>
<td></td>
</tr>
<tr>
<td></td>
<td>FRMNRM$</td>
<td>the name of the form</td>
<td></td>
</tr>
<tr>
<td>DRV.</td>
<td>DRVTYPE</td>
<td>0 - Windows driver, 1 = CAM driver</td>
<td></td>
</tr>
<tr>
<td></td>
<td>PRTR$</td>
<td>name of the windows printer</td>
<td></td>
</tr>
<tr>
<td></td>
<td>TOFIL</td>
<td>1 - when output is set to file</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ORIENT</td>
<td>0=Portrait, 1=Landscape, 2=Optimum - only used for a windows driver always portrait for CAM</td>
<td></td>
</tr>
<tr>
<td></td>
<td>TNDES$</td>
<td>the description as read from TUNEFILES</td>
<td></td>
</tr>
<tr>
<td></td>
<td>TNFIL$</td>
<td>tuning file name</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DRVNM$</td>
<td>the driver name as read from TUNEFILES e.g. HP</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DVNAM$</td>
<td>name of CAM device for LP devices; e.g. HP1, DDES etc.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DROPT$</td>
<td>the CAM driver options</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DEVSZX</td>
<td>CAM device size in X in current units</td>
<td></td>
</tr>
<tr>
<td>Record</td>
<td>Variable</td>
<td>Sub-variable</td>
<td>Definition</td>
</tr>
<tr>
<td>--------</td>
<td>----------</td>
<td>--------------</td>
<td>------------</td>
</tr>
<tr>
<td>DEVSZY</td>
<td></td>
<td></td>
<td>CAM device size in Y in current units</td>
</tr>
<tr>
<td>MGTOP</td>
<td></td>
<td></td>
<td>CAM top margin in current units</td>
</tr>
<tr>
<td>MGBOT</td>
<td></td>
<td></td>
<td>CAM bottom margin in current units</td>
</tr>
<tr>
<td>MGLEFT</td>
<td></td>
<td></td>
<td>CAM left margin in current units</td>
</tr>
<tr>
<td>MGRGHT</td>
<td></td>
<td></td>
<td>CAM right margin in current units</td>
</tr>
<tr>
<td>OFFSTX</td>
<td></td>
<td></td>
<td>X offset from the justification position in current units</td>
</tr>
<tr>
<td>OFFSTY</td>
<td></td>
<td></td>
<td>Y offset from the justification position in current units</td>
</tr>
<tr>
<td>STARTX</td>
<td></td>
<td></td>
<td>X origin shift</td>
</tr>
<tr>
<td>STARTY</td>
<td></td>
<td></td>
<td>Y origin shift</td>
</tr>
<tr>
<td>ROT</td>
<td></td>
<td></td>
<td>Rotation flag: 0=rotate 0, 1=rotate 90, 2=rotate 180, 3=rotate -90</td>
</tr>
<tr>
<td>MIRROR</td>
<td></td>
<td></td>
<td>Mirror flag: 0=no mirror, 1=mirror horiz., 2=mirror vert</td>
</tr>
<tr>
<td>JUST</td>
<td></td>
<td></td>
<td>Justification flag: 0=top left, 1=top center, 1=top right, 3=center left, 4=center, 5=center right, 6=bottom left, 7=bottom center, 8=bottom right</td>
</tr>
<tr>
<td>SIDE</td>
<td></td>
<td></td>
<td>Side flag: 0 = PRINTEDSIDE, 1 = UNPRINTEDSIDE, 2 = default side</td>
</tr>
<tr>
<td>TILEED</td>
<td></td>
<td></td>
<td>0 if we don't need tiling</td>
</tr>
<tr>
<td>TILESX</td>
<td></td>
<td></td>
<td>number of tile rows</td>
</tr>
<tr>
<td>TILESY</td>
<td></td>
<td></td>
<td>number of tile columns</td>
</tr>
<tr>
<td>TLOVLP</td>
<td></td>
<td></td>
<td>tile overlap</td>
</tr>
<tr>
<td>PSDRV.</td>
<td></td>
<td></td>
<td>the optional print sample driver/positioning data</td>
</tr>
<tr>
<td>DRVTyp</td>
<td></td>
<td></td>
<td>0 = Windows driver, 1 = CAM driver, 2 = no printer</td>
</tr>
<tr>
<td>PRTR$</td>
<td></td>
<td></td>
<td>name of the windows printer</td>
</tr>
<tr>
<td>Record</td>
<td>Variable</td>
<td>Sub-variable</td>
<td>Definition</td>
</tr>
<tr>
<td>--------</td>
<td>----------</td>
<td>--------------</td>
<td>------------</td>
</tr>
<tr>
<td>TOFIL</td>
<td>1- when output is set to file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ORIENT</td>
<td>0=Portrait, 1=Landscape, 2=Optimum (2 is only used for a Windows driver) always portrait for CAM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TNDES$</td>
<td>the description as read from TUNEFILES</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TNFIL$</td>
<td>tuning file name</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DRVNM$</td>
<td>the driver name as read from TUNEFILES e.g. HP</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DVNAM$</td>
<td>name of CAM device for LP devices; e.g. HP1, DDES etc.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DROPT$</td>
<td>the CAM driver options</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DEVSZX</td>
<td>CAM device size in X in current units</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DEVSZY</td>
<td>CAM device size in Y in current units</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MGTOP</td>
<td>CAM top margin in current units</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MGBOT</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MLEFT</td>
<td>CAM left margin in current units</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MGRGHT</td>
<td>CAM right margin in current units</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OFFSTX</td>
<td>X offset from the justification position in current units</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OFFSTY</td>
<td>Y offset from the justification position in current units</td>
<td></td>
<td></td>
</tr>
<tr>
<td>STARTX</td>
<td>X origin shift</td>
<td></td>
<td></td>
</tr>
<tr>
<td>STARTY</td>
<td>Y origin shift</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ROT</td>
<td>Rotation flag: 0=rotate 0, 1=rotate 90, 2=rotate 180, 3=rotate -90</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MIRROR</td>
<td>Mirror flag: 0=no mirror, 1=mirror horiz., 2=mirror vert</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
| JUST   | Justification flag: 0=top left, 1=top center, 1=top right, 3=center left, 4=center,
### Information Filter tab

The commands on the Information Filter tab let you select the ArtiosCAD data included in the Output. The Output type must be set to **Information Filter** to make this tab appear.

**Note:** The settings on this tab supersede any view settings you have set in ArtiosCAD when you select this Output. This means you may send information you do not mean to send, or vice-versa.
All layers must be turned on for the resulting workspace to be rebuildable. If all the layers are not turned on, the **Parametrics(Rebuild)** checkbox is cleared and cannot be checked until all layers are turned on. Click **All On** to turn on all the layers.

If the **Manufacturing parameter sets** checkbox is not selected, the Information Filter will remove manufacturing parameter set information from Manufacturing files and copies of parameter sets that are embedded in design files.

When using the Information Filter to strip prompted text variables from an Output, only those variables defined in the Prompted Text Catalog are stripped from the Output.

The output format for an information filter is usually an ArtiosCAD workspace. The allowed formats for an information filter output are the current version of ArtiosCAD, the major previous ArtiosCAD releases, a **LASERPOINT IQ 3** or **4** workspace, and a **LASERPOINT IQ 2** workspace.

### Counter Tool Widths tab

All the fields which are unavailable in this tab in Defaults become available when performing the actual Output. The values for them are dependent upon the board used and parameter set. These fields are calculated automatically when this Output is invoked and cannot be changed during an Output.

The fields in the **Tool Widths** group are measured in current units and are enabled only when their respective checkboxes are checked.
When the **Multi-Pass** checkbox is off, the corresponding field is automatically set to the crease channel width and disabled. When the **Multi-Pass** checkbox is on, the edit box is enabled. Enter a tool width greater than zero and it will multi-pass with this tool.

For the **Position Holes** tool, the **Allow for Tool Diameter** checkbox follows the design lines when it is not selected, and allows for the width of the tool when the checkbox is selected.

If the specified tool width is too large to fit within the programmed lines, it will always cut something rather than nothing.

If the tool width of the crease tool is wider than the required crease channel it will cut with a single pass.

If the crease end shape is narrower than the crease end tool, it will cut a path that is the same distance from the crease end.

**Counter Cutting Order tab**

As the name implies, the tools on **Counter Cutting Order** tab control the direction in which the counter lines are made on the counter cutter.

The four option buttons in the **Milling Direction** group control the milling order.

The tools listed in the **Tool Cutting Order** group cut from the top of the list to the bottom of the list. To change the cutting order, select a tool to move, and then click the arrows to the right of the list.

The options in the **Multi-Pass for Creases** group control how the multiple passes for creases are made if that option is turned on. **Optimize Tool Path** makes a small rectangular crease channel out of four passes, while **Account for Deflection** makes two parallel passes in the same direction.
The value you set in the Milling Overlap field indicates the overlap the milling tools will use when the machine mills lines close to each other. This is to ensure all material is milled correctly.

**Grouped Outputs tab**

The Grouped Outputs tab, which appears only when the Output Type is set to **Grouped Output**, lets you group already-defined Outputs into one. For example, with one click, you could save the workspace, print a spec sheet, export a DDES file, send an email containing a DXF file, and cut a sample.

If any of the component Outputs you select go out to a file, they do not need to be configured to automatically overwrite the file if necessary; ArtiosCAD will prompt for a filename when necessary.

To add an Output to this Grouped Output, click **Add** and select it from the list of Outputs; to delete it, click **Delete**.

Also, the **Scale** group on the Output Type tab is unavailable for Grouped Outputs as the scales are set for each component Output.

The Outputs listed are processed in top-down order. To change the position of an Output, select it, and then move it by using the arrows at the side of the list box.

**Save before performing outputs** uses the current name of the workspace if one is defined. If it is not defined, ArtiosCAD prompts for the information needed. **Save-As before performing outputs** lets you select a new folder or resource as well as a new filename. ArtiosCAD works with the new file as soon as it is saved, so any Outputs in this grouped Output will use the new file.
In both cases, any dialog boxes normally opened by the save process will be opened during the Output, such as the Database Information dialog box. Use caution when using the Save or Save-As options with CAD-X as it may lead to unpredictable results.

Both **Save before performing outputs** and **Save-As before performing outputs** may be checked at the same time to allow saving the workspace with its original name and then saving it as a new name.

Grouped Outputs can also be added to a compressed archive in ZIP format; select **Zip** in the **Grouped Output Type** group and **Insert into Zip archive** in the **E-mail/Zip options** group. If you are working with filenames in non-English languages, check **Use UTF8 characters for filenames** so that the filenames are encoded correctly within the ZIP archive.
Delete output disk file deletes the working files that the Grouped Output creates after inserting them into the ZIP archive. In this example, those would be the DXF and DDES files.

As the E-mail and Zip Grouped Output types are mutually exclusive, in order to e-mail a zipped archive, you have to create a Zip Grouped Output first and then include that in an E-mail Grouped Output.

E-mail options group
A Grouped Output can also have its own top level email output (configured on the Send to tab) in addition to each individual Output going to email.

- **No change to destination** indicates that the selected individual Output runs without any changes.
- **Attach to e-mail** intercepts the output file for this component Output and embeds it as part of the group mail output. For example, if the output is to a Kongsberg samplemaker, the .MAP file will be attached to the email message instead of being sent to the table.
- **Put contents in e-mail** means take the contents of a text file created by this component Output and put it in the e-mail message rather than attaching the file. It is intended for inserting text such as ordering information in the message. This should only be used with outputs through command files which generate text files.
- **Delete output disk file** deletes any temporary files needed to add the output to an email message.

Select which sample output group
This group is conditional; it appears only when a sample output is selected in the list of Outputs.
Select the option button for the type of sample output you wish to create.

PDF Security tab

The PDF security options available in an ArtiosCAD Output correspond to those used in Adobe Acrobat.

Checking **Require a password to open the document** requires the recipient of the file to enter a password when opening the PDF file using Adobe Acrobat Viewer. Enter this password in the **Open password** and **Repeat password** fields; they must match exactly. There is no way to recover this password if it is lost or forgotten.

Checking **Use a password to restrict permissions** requires the recipient of the file to enter a password to change how the file is protected. Enter this password in the **Open password** and **Repeat password** fields; they must match exactly. There is no way to recover this password if it is lost or forgotten.
Repeat password fields; they must match exactly. There is no way to recover this password if it is lost or forgotten.

If both password options are used, the two sets of passwords must be different.

**Note:** If you forget a password, change the password in Defaults, save the changed Defaults, and then regenerate the PDF document. It will use the new password.

In the Printing allowed drop-down list box, there are three settings: None, Low Resolution, and High Resolution. None means the recipient may not print the document. Low Resolution allows printing as a bitmap up to 150 dpi. High Resolution allows printing the document at any resolution, and to use high-quality vector output and other advanced printing features if the printer supports them.

In the Changes allowed drop-down list box, there are three choices: None, Page content changes only, and All changes allowed. None allows no changes in Adobe Acrobat. Page content changes only restricts changes to what is shown on the page, but prevents other changes such as page rotation. All changes allowed allows any change.

The recipient of a PDF file created by ArtiosCAD with security options set must use Adobe Acrobat 5.0 or later to open the file.

**Note:** ArtiosCAD cannot open PDF files with an Open password, nor can it open PDF files that have restricted permissions and that do not have content copying enabled.

### Configuring a PDF Output using Adobe® Acrobat® 5

To configure an ArtiosCAD Output that creates a PDF file using Adobe Acrobat 5, do the following:

1. Install Adobe Acrobat 5 as a custom installation, making sure to install the Acrobat PDFWriter.
2. Start ArtiosCAD, open Defaults, and create a new Plot output using the procedures described earlier in the chapter.
3. In the Scale group on the Output Type tab, click To fit one page.
4. On the Device tab, set the Driver Type to Windows Driver and select Acrobat PDFWriter in the Windows Driver drop-down list box. Also set the Orientation to Optimum. The orientation in ArtiosCAD works independently from the orientation in the printer driver; you may have to adjust the settings manually to achieve the desired output.
5. In the Plot File group on the Directories tab, set the extension to .pdf. Make sure to include the period before pdf.
6. Click OK and save the defaults.

Later versions of Adobe Acrobat will not work correctly with ArtiosCAD.

**Note:** ArtiosCAD also has a predefined PDF export and Output that use its native PDF method without requiring Adobe Acrobat 5 to be loaded on the system. These require no special configuration for use, but the option must be purchased and installed for them to work. If you have Adobe Acrobat 5, you can make PDF files in the method described above without having to purchase the PDF option in ArtiosCAD. However, without purchasing the PDF option, you will not be able to import PDF files or use high graphics mode.
Configuring 3D Outputs

3D has its own table in Defaults for Outputs. Shown below is the Artios catalog in **Shared Defaults > Outputs-3D**.

![ArtiosCAD catalog](image)

For detailed information about the options available in these Outputs, see *3D Outputs* in the *Esko ArtiosCAD User Guide*.

Creating a new 3D Output

To create a new 3D Output, do the following:

1. Start ArtiosCAD and click **Options > Defaults**.
2. In the Shared defaults pane, scroll down to the **Outputs-3D** catalog, right-click it, click **New**, and then click **Data** on the context menu.
3. Replace **New Data 1** with the name of the new Output.
4. Press enter when you have entered the name and then double-click the new entry to access its Properties dialog box.

![Properties dialog box](image)
5. On the Output Type tab, choose the type of Output to make. **Plot** can either make a PDF file (if you have purchased that option), an Illustrator 8.0-compatible EPSF file, or the data can be sent to a device using a Windows printer driver. **Bitmap** makes a JPEG or PNG file. **VRML**, **SolidWorks Export**, and **U3D** all export to those file types. **Animation Snapshots** makes a series of bitmaps images of an animation and can output those to Microsoft Word, Microsoft PowerPoint, or PDF document, or to individual bitmap files. For this example, choose **Bitmap**.

6. Click the Bitmap tab.

![Bitmap Options](image)

7. In the **Save bitmap as** group, choose **JPEG**. Set the other options as desired.

8. Click the General tab and enter a directory in the **Output directory** field. Set the other options as desired.

![General Options](image)

9. Click **OK** to finish defining the Output.

10. Click **File > Save**, and then click **Yes** to confirm overwriting shared Defaults.

11. The new Output in 3D is ready to use.

There are some slight differences between the options on the tabs in Defaults and those in the Outputs at time of use. For example, the **Use OpenGL for bitmaps** checkbox on the Bitmap tab when using an Output is set in the 3D Rendering Options entry in Startup defaults, not the Output defaults.

There is a fifth type of 3D Output available; **Animation Snapshots** exports each frame to individual PNG or JPEG files. For example, if you have an 8-frame animation, an Output of this type would produce 8 .JPEG or .PNG files in the same directory. When configuring an Output
of this type, on the Animation tab with Export animation as: set to Bitmaps, the Bitmap Filename Generation group appears. The options in this group configure how the different filenames are named. The root of each filename is the workspace name, and then the Frame separator character is inserted after the name, and either a number or letter is added as a suffix depending on the option chosen.

![Bitmap Filename Generation](image)

**Changing Collada defaults**

Using the Collada entry in the Outputs-3D catalog in Defaults creates a .ZAE file with .PNG images at the current graphics resolution.

![Collada](image)

To change the settings, do the following:

1. Start ArtiosCAD.
2. Click Options > Defaults.
3. In the Shared Defaults pane, scroll down to the Outputs-3D catalog and open it by clicking the plus sign (+) next to it.
4. Double-click the Collada entry.
5. Click the Collada Options tab.

   • In the Graphics resolution group, Use View Settings uses the resolution set in the View Mode dialog box. Deselect it to enable the drop-down list box that sets the resolution setting manually.
• PNG and JPEG in the Include bitmaps as group control how the images are stored. Select JPEG to enable the quality setting.

• In the Save as group, choose to save Collada files as standalone .DAE files or .ZAE archive files.

6. Click OK when done setting the options to return to Defaults.
7. Click File > Save to save the changes.
8. Click Yes to overwrite the existing Defaults.

Note:
You may want to create additional Collada entries with different options set for ease of output. Make sure to set the Output Type to Collada on the Output Type tab of the dialog box.

Rule labels

You can define rule labels for special rules that appear in the design when viewing the design, or when printing the design, or both. Rule labels display the specific rule type as the generic rule type plus whatever label you specify.

To configure this, you must add a rule label to the rule definition in the Special Rule Types catalog in Defaults.

Enclosing the fraction in braces causes ArtiosCAD to display it as a real fraction, such as ¼.

To turn on rule labels when working in ArtiosCAD, open the View Mode dialog box, select the Rule labels checkbox, and click OK.

Shown below is a hanger hole made from ¼ by ¼ perf with rule labels turned off.
Here is the same hanger hole with rule labels turned on:

To turn on rule labels as a function of an output, check the Rule Labels checkbox on the View tab of the output’s properties page.

The defaults for the size and default appearance of the rule labels are stored in the Rule Labels entry in Design defaults.
The **Size:** of the rule label is in points. The value in the **Space between labels** controls how often along the line the label is repeated. **Rotate parallel to line** determines if the label is parallel to the rule or always shown so that it is easily readable. **Place above line** controls if the label is in the line or above the line. Draw generic type controls if ArtiosCAD.

Shown below is the same hanger hole with **Rotate parallel to line** and **Place above line** turned off.
Configuring the Output Scale Table

To add or remove values from the Output Scale Table, do the following:

1. Start ArtiosCAD and click Options > Defaults.
2. Open the Startup Defaults catalog by clicking the plus sign preceding it (+) and double-click Output Scale Table. It should look similar to the picture below:

![Output Scale Table](image)

3. To add a value to the table, click Add and enter the value in the Scale value: field. The value you enter must be at least 0.005 units of measurement different from any other value.
4. To delete a value from the table, select the value and click Delete. There must always be at least one value in the table; the last value cannot be deleted.

Notes on using the Output Scale Table

When using the Output Scale Table, the scale that is actually used is stored in the Plotting Scale variable in the General Information calculated text catalog. Insert this item of calculated text on the report to show the scale used.

If the report itself is scaled when it is output, that scale will be applied to the file window. In addition, all calculated text fields that use the Plotting Scale system variable (#FWSCALE) will be reevaluated using the combined file window scale and report scale.

AutoSave / Local Temp Directory

The AutoSave default in Startup defaults automatically saves a backup copy of open workspaces in the Local Temp Directory at the interval defined in the AutoSave every: field. ArtiosCAD AutoSaves only when the Activate AutoSave checkbox is selected.
The **Local Temp Directory** is configured in the **Local Temp Directory** default in Startup Defaults.

The system TEMP directory is defined by an environment variable. See your system administrator, or refer to your operating system documentation for more information on changing the system TEMP directory.

To set your own TEMP directory, select the **Specify** option and browse for the desired directory. Everyone must have write access to that directory. The Local Temp Directory must be on the current machine - it may not be set to a network drive.

The AutoSave timer is NOT active when:
- a dialog box is open
- when the Rebuild Playback tool is in use
- when the Interact window is open.

The AutoSave file is named BCK<xxxxx>.AAS, where <xxxxx> is a random number, and AAS stands for ArtiosCAD Auto Save.

No database synchronization is done with the AutoSave file, nor is it saved in the database.

### Recovering AutoSave files

The first time ArtiosCAD starts after an improper termination, the AutoSave Recovery dialog box will appear listing the workspaces for which AutoSave files exist.
Check the checkboxes next to each file to recover and click **OK**. The AutoSave files will be restored for the selected files; SAVE the workspaces once they are open. AutoSave files that are not selected for restoration are deleted automatically.

**Revision Disk File Format in Revision History**

The **Revision History** feature of ArtiosCAD relies on changing the name of files as they are stored on the hard drive. How file name is changed is controlled by **Options > Defaults > Startup defaults > Revision Disk File Format**.
For example, consider a file called FILE. If you choose the first option, **Base filename is latest revision**, and create a new revision, then the latest revision becomes FILE and the original becomes FILE~. If you then make a new revision, then the latest file will still be FILE, the original will be FILE~, and the first revision from the original will be FILE_A. In this case the latest FILE would also be FILE_B, but the _B extension will not be visible; if you open other revisions they will warn you that the latest revision is FILE_B.

If you choose the second option, **Base filename is earliest revision**, then each new revision gets appended in sequence: the original is and will always be FILE, the second revision will be FILE_A, the third will be FILE_B and so on. The most recent revision will be the one with the highest extension.

**Default to update all projects when saving revisions**, when checked, causes ArtiosCAD to update all Projects that contain the current design when you use **Save As Revision**. When cleared, ArtiosCAD updates only the current Project when you use **Save As Revision**. Also when this option is cleared, if the design is not in a Project, or the design is not in the active Project, no Projects are updated with information about this revision. This option is checked by default.

---

**Note:**

As of ArtiosCAD 16.1, the default option is the second option to better support canvases. If you have upgraded from a previous version, the previous setting is preserved.

---

**Database Browser Reports**

This information is supplied for reference only. Only the most advanced users of ArtiosCAD who are very familiar with XSLT and XML technology should consider modifying the database reports.

There are two types of Database browser reports - those used in the ArtiosCAD browsers and those used in DataCenter Admin.

ArtiosCAD Database browser reports are configured in the Database Browser Reports Catalog in Defaults.
There are two reports for each ArtiosCAD browser. The **AutoCol Browser List format** automatically detects which data are selected for inclusion in Defaults and includes them on the report.

The **SimpleEmb Browser List format** presents just the information shown in the browsers. The reports use three formats:

- **CSV** - produces a CSV (Comma Separated Values) file suitable for importing into a spreadsheet.
- **HTML** - makes an HTML (Hyper Text Markup Language) document which can be viewed in a Web browser.
- **XML** - makes an XML (eXtensible Markup Language) file suitable for delivering data to other applications in a rich, structured way. Only the Simple reports use this format.

Shown below is the Properties dialog box for the AutoColDesignListHTML report for illustrative purposes. For the reports with Simple in their name, any modifications made to the data included in the report require modifying the XSLT transformation file to put that data into the output file. The reports with **Auto** in the name automatically recognize the data included so the items in **Select Data to Include** can be added and removed as desired.
The option buttons in the **Selection** group control which database records are included in the report when it is output.

The **Template File**: field controls which XSLT template is used with the report. For the ArtiosCAD browsers, the template files are stored in InstLib. For the DataCenter Admin browsers, the template files are stored in the language directory of the DataCenter program folder.

The options in the **Output File** group control where the output file is created and how it is treated after it is created.

The **Select Data to Include** group controls the data going into the raw XML file before it is translated into the output file by the XSLT file. If **Thumbnail** is selected, a JPG thumbnail for each record is saved in the same directory as the report file.

DataCenter Admin reports use hard-coded report names with extension .XSL that are in `\Esko\Artios\DataCenter\Program\ <language>`.

The reports use XSLT files that are not meant for modification except by the most advanced users who are already familiar with XSLT and XML. Modifying the catalog entries in Defaults only modifies the information going into the raw XML file - the XSLT transformation template must also be updated to use the information. **It is your responsibility to edit or create a new XSL template file used to format the data into the output file.**

### Publishing ArtiosCAD documents to WebCenter

To configure ArtiosCAD for publishing documents to WebCenter, double-click **Publish to WebCenter** in the WebCenter catalog in Shared Defaults.
**Note:** The WebCenter servers must be running version 6.1 or greater. ArtiosCAD can publish to a single WebCenter site. Change the **WebCenter address** field in the Publish to WebCenter dialog box in Defaults as needed to publish to more than one WebCenter site.

Shown below is the default Publish to WebCenter dialog box.

![Publish to WebCenter dialog box](image)

**WebCenter Project Name group**

The options in the **WebCenter Project Name group** control which WebCenter Project receives the ArtiosCAD document.

- **Use document name** uses the ArtiosCAD document name as the WebCenter Project name.
- **Calculate using a library function** lets users with advanced ArtiosCAD knowledge use a library function to determine the WebCenter Project name. Enter the name of the library function in the `TLIBRARY()` field.
- **Use ArtiosCAD project name (ARD only)** names the WebCenter Project after the ArtiosCAD project name if one was defined. This option overrides **Use document name** and **Calculate using a library function**.
- **Prompt for project name** prompts for the Project name. If any Prompt option is selected, the Publish to WebCenter dialog box appears when publishing. They all must be deselected in order to hide that dialog box when publishing.
- **Create project if it does not exist** creates the WebCenter Project named using the options selected in the previous fields if it does not already exist. If this option is deselected and the WebCenter Project does not exist, when ArtiosCAD tries to publish a document into that WebCenter Project, an error will occur.
- **Use template** lets you specify the template to use to create the Project. Enter its name in the **Name** field or enter the name of the library function used to calculate the name in the `TLIBRARY()` field.
Use document thumbnail causes WebCenter to use the thumbnail for the single design or 3D document as the Project thumbnail.

**Publish Options group**

If document already exists then publish as new version controls what happens when a document with the same name as the document being published already exists in the same folder in the WebCenter Project. When this option is selected, the document being published is treated as a new revision of the document already in the WebCenter Project. When this option is not selected and a document exists with the same name as one being published, an error will occur.

**WebCenter Folder Name group**

The options in the WebCenter Folder Name group control where in the WebCenter Project the ArtiosCAD document is placed once it is published.

Publish to root level puts the ArtiosCAD document in the default folder in the Project. Security on this folder is inherited from the WebCenter Project security settings.

Use standard ARD, A3D, MFG folders uses folders with those names for ArtiosCAD documents with those filename extensions. Single designs would go into a folder called ARD, 3D documents into A3D, and manufacturing files into MFG.

Calculate using a library function lets users with advanced ArtiosCAD knowledge use a library function to determine the folder name. Enter the name of the library function in the TLIBRARY() field.

Prompt for folder name prompts for the folder name. If any Prompt option is selected, the Publish to WebCenter dialog box appears when publishing. They all must be deselected in order to hide that dialog box when publishing.

Create folder if it does not exist creates the folder named using the options selected in the previous fields if it does not already exist. If this option is deselected and the folder does not exist, when ArtiosCAD tries to publish a document into that folder, an error will occur.

**WebCenter Login group**

The WebCenter system administrator must provide a username and password for the account ArtiosCAD will use to publish documents to WebCenter. Enter the username in the Username field. Prompt for password causes the ArtiosCAD user to have to enter a password when publishing. Deselecting this option causes the Password field to become available. If you
specify a username and a password, they will be automatically entered in the Publish to WebCenter dialog box when publishing.

**WebCenter Connection group**

Enter the URL for the WebCenter server in the **WebCenter address** field.

**Note:** ArtiosCAD may only publish to the WebCenter site listed in this field. To publish to another WebCenter site, change this field as needed.

**Test** tests the connection to the WebCenter server. The test is successful **only** if you receive a message that the WebCenter Web-API was properly installed. Any other response means the test failed.

**Graphic PDF file rotation import option**

A PDF file can contain an internal flag to indicate if the document is rotated or not. ArtiosCAD has ignored this setting until version 7.35. In **Options > Defaults > Shared Defaults > Startup defaults > PDF Options** is the **Honor Acrobat Rotation** checkbox. To have ArtiosCAD respect this flag when importing a PDF file as graphics, enable this checkbox. The checkbox is not selected by default, and has no effect for PDF files imported as lines.

**Using Spot Colors in PDF files**

You can configure PDF Outputs to use spot colors for the line color definitions instead of using plotting style information. To make this change, it is best to copy an existing PDF Output to a new one in Defaults and change its name, and then modify the new entry.

1. Click **Options > Defaults**.
2. In Shared Defaults, copy an existing PDF Output to an entry with a different name, such as Plot to PDF using spot colors.
3. Double-click the new entry and click the **Device** tab.
4. Click ... (Browse) at the end of the Tuning Filename field.
   a) Navigate to InstLib.
   b) Change the filetype selector to **All files (*.*)**.
   c) Click Tune.PDF.SpotColors.xml and then click **Open**. The entry in the Tuning Filename field should change accordingly.
5. Click **OK** to make the change.
6. Click **File > Exit** and click **Yes** when asked to save and then overwrite the Defaults.

Shown below are the Ink Manager palettes for two PDF versions of the same single design, one using the default method and the other using the spot colors method.
To change the ink names, RGB color values, stroke widths or stroke styles used by this method, make the changes in PDFSpotColorMap.xml.

Layered PDFs

You can specify custom PDF Outputs that maps linetypes into layers. PDF Output tuning works using an XML tuning file. The easiest way to do this is to copy the example Tune.PDF.Layered.xml tuning file in InstLib and modify it to suit your needs. Save your modified version to ServerLib and add a new Output using that tuning file.

Shown below is an excerpt from the tuning file.

```xml
<!-- Line type 20 is used for Text items - map these to a layer called "Text Layer"-->
<MAP ARTIOSCAD_LINE_TYPE="20">
  <PDF_LAYER NAME="Text Layer"/>
</MAP>

<!-- Line type 14 is used for Image and graphics items (strokes and fills). Map these to a layer called "Image Layer"-->
<MAP ARTIOSCAD_LINE_TYPE="14">
  <PDF_LAYER NAME="Image Layer"/>
</MAP>
```

To map a specific line type to a layer:

1. Create your custom tuning file by copying the example one from InstLib to ServerLib and opening it in a text editor. Save it with a different name.
2. Copy one of the MAP nodes to the bottom of the PDF_LINE_TYPE_MAPPING node. Copying the comment (the part enclosed in <!-- and --> is optional.
3. Change the line type number to the new line type. A list of line types is in the Appendix of the User Guide.
4. Change the name of the layer in the NAME attribute of the PDF_Layer tag.
5. Save the file.

For example, to have all Outside Bleed lines in their own layer, create a block like this:

```xml
<!-- Line type 11 is used for Outside Bleeds. Map these to a layer called "Outside Bleeds"-->
<MAP ARTIOSCAD_LINE_TYPE="11">
  <PDF_LAYER NAME="Outside Bleeds"/>
</MAP>
```
For more examples of how you can customize PDF output, refer to the following example files in InstLib.

- Tune.PDF.UsePlottingStyle.xml shows how to use the current plotting style to render PDFs. This is the default if no tuning is specified or is not found.
- Tune.PDF.UseSpotColors.xml shows how to use technical inks in the PDF.
- Tune.PDF.Layered.xml shows how to map particular line types to PDF layers.
- Tune.PDF.Example.xml is an example tuning using a combination of layers and rendering options.

### Setting Cape/TOPS Defaults

Before you use the palletizing features, you must set the Cape Pack/TOPS Defaults by doing the following:

1. Start ArtiosCAD.
2. Click **Options > Defaults**.
3. In the list of Shared defaults, scroll down to the Palletization catalog and open it by clicking the plus sign (+) next to it.
4. Double-click **CAPE/TOPS Defaults**.

The Cape Pack Defaults dialog box opens as shown below.
5. Set the options in the dialog box as desired.
   a) If you are using Cape Pack/TOPS in client/server mode, select Client/Server and enter the User ID for Cape Pack/TOPS in the field provided. If you are using it in workstation/standalone mode, leave this field empty.
   b) Choose a default pallet from the drop-down list box in the Default Pallet group.
   c) Set the Maximum pallet height and Maximum pallet weight appropriately using inches and pounds or millimeters and kilograms.
   d) To not see the waste areas of the layout and see only the designs in CAPE/TOPS, check Output to CAPE/TOPS as stripped.
   e) To calculate the caliper from the board elements instead of using the caliper defined by the board code, check Calculate True Caliper from Medium and Liners.
   f) Set an Import pallet tolerance for use when exchanging design data between ArtiosCAD and Cape Pack/TOPS. As the outer dimensions of the Cape Pack/TOPS pack type and the ArtiosCAD standard may not match, the tolerance will make it easier to generate pallet loads.
   g) In the Arrange/Design Options group, set the default amount of slack and the default maximum package size.
   h) In the Number of primary packages group, set the minimum and maximum number of primary packages in the secondary package.
   i) Set Round to nearest 1/16th as desired. This works in Inches mode only.
   j) Click OK to return to Defaults when you are done setting the Cape Pack/TOPS Defaults.

6. Click File > Save to save the changes.
7. Click Yes to confirm the saving of the changes to Defaults and return to ArtiosCAD.

Setting DWG/DXF Options

**DWG/DXF Options** in the Startup defaults catalog is where you:
- set whether or not to use third-party import libraries
- map font names in DWG/DXF files to Windows TrueType fonts.

![DWG/DXF Options settings window](image-url)
Import DXF files using third party libraries controls whether or not ArtiosCAD uses a more robust method to open DWG or DXF files than its built-in method. If you have trouble importing DWG or DXF files, try deseleting this checkbox.

ArtiosCAD does not display the fonts that DWG or DXF files use. Therefore, those fonts have to be mapped to the Windows TrueType (TTF) fonts that ArtiosCAD displays. In the default map shown above, **Width Factor** means the kerning and **Height Factor** adjusts the height of the text. To change any of the fields other than **Imported Font**, click in the field. ArtiosCAD maps any unmapped fonts using the *Default setting*.

If you have a DWG/DXF file containing unmapped fonts (text will be the wrong size), click **Get font definitions from file**, then browse for the file. ArtiosCAD scans the file and sets up new map entries with which you can then configure as desired. It then stores FontMap.XML in ClientLIb which you can copy between machines as needed.

**Note:** ArtiosCAD does not use font mapping if **Import DXF files using third party libraries** is not checked.

---

## Color Palettes

ArtiosCAD comes with three color palettes that you use to pick colors. A palette can have RGB colors or CMYK colors. RGB is way of defining colors based on the amount of red, blue, and green in them. CMYK defines colors based on cyan, magenta, yellow, and black. You can also make custom palettes as desired.

The three default palettes are:

- Artios CMYK Palette. This palette contains some of the colors from the color picker in previous versions of ArtiosCAD.
- CMYK Palette. This palette contains a selection of CMYK colors.
- RGB Palette. This palette contains a selection of RGB colors.

**Note:** Plotting styles and toolbar colors use color choices specifically chosen for clarity. They do not use palettes.

---

## Adding a New Color Palette

To add a new color palette, do the following:

1. Click **Options > Defaults**.
2. Right-click **Color Palettes** and click **New > Data**.
3. Enter a name for the new color palette and press Enter. You should include the type of palette it is, either CMYK or RGB, in the name so that you know what kind of palette it is when you use it.
4. Double-click the new color palette to open its Properties dialog box.

When you create a new palette, ArtiosCAD sets its type to RGB and initializes the colors to white.

a) Change the palette type to **CMYK** if you are creating a CYMK palette.

b) Click the square of the palette which will contain the color you are about to define. It will have a rectangle around it to show it is selected.

c) Define the color by either typing the color values in the input fields for the type of color, or by using the mouse to set the hue and saturation in the color field and the luminance on the slider, or a combination of the two methods.

d) ArtiosCAD automatically names the color **PaletteType(Values)**. If you leave the default name and later change the palette type, the color name changes automatically to reflect the different palette type. You can give the color a custom name, but it will not change automatically if you change the palette type.

e) Click **Update Palette** to add the color to the palette. ArtiosCAD then automatically selects the next color square.

f) Repeat the steps above to add colors as desired. Each palette can have up to 48 colors.
5. Click OK to save the changes to the color palette and return to Defaults. Save and exit Defaults normally.

**Note:** If you are adding new colors or palettes to use when setting a board color, you must completely exit Defaults after you have made the desired changes.

**Color Palette by Feature**

Some features in ArtiosCAD can use both color palettes, while others are limited to CMYK. For features that can only use CMYK palettes, ArtiosCAD only lets you select CMYK colors. If you want a palette that works in every tool that uses color, create a CMYK palette.

**RGB Palettes or CMYK Palettes**

- 3D Outputs > VRML Options > background color
- Outputs > U3D Options > background color
- 3D > Light Source tool > light color
- 3D > View > Ambient Light
- 3D > Select > Double-click an object > Material properties tab > Outside board and inside board colors
- 3D > View Mode > Background color > Select color

**DataCenter Admin / Enterprise Board Browser**

- Boards > Create a new board or select an existing board and click Edit > Select Color
- DataCenter Admin / Enterprise Board Browser > Boards > Create a new board or select an existing board and click Edit > Advanced color > Select color

**Defaults**

- Customized toolbars > ArtiosCAD Toolbar Hover Color
- Startup defaults > 3D View Mode > Background color > Select color
- Startup defaults > Document Bar Options > Project Button Color
- Design defaults > VRML Export Options for CAD-X > Background color

**Property defaults**

- Mate > Glue type > 3D bead color
- Single Design > Mate tool > Mate properties > Glue type > Bead color
- Single Design > Select > Double-click the edge of a Mate > Properties > Glue type > Bead color

**Rubber types**

- Individual type color
- Special rule types > Tear tape > Individual tear tape > Special rule > Select color
- Single Design > Select > Double-click a line with type Tear tape > Properties > Special rule > Select color
- Special rule types > Edgeband > Individual edgeband > Special rule > Select color
- Single Design > Select > Double-click a line with type Edgeband > Properties > Special rule > Select color
CMYK Palettes Only

Defaults > Property defaults > Graphics > Fill Color and Stroke Color
Defaults > Property defaults > Text > Color > More colors
Defaults > Property defaults > Hatch > Custom > Line Type > Stroke > Color > More colors
Defaults > Property defaults > Hatch > Custom > Background > Fill > Color > More colors
Defaults > Property defaults > Line type label > Text color > More colors
Defaults > Startup defaults > Artwork Panels > Font and Color > Text Line 1 color > More colors
Defaults > Startup defaults > Dynamic Art > Label or Text color > More colors
Single Design > Select a filled or stroked object > Edit menu > Properties > Pick Fill Color and Pick Stroke Color
Single Design > Select > Double-click a filled or stroked object > Properties > Pick Fill Color and Pick Stroke Color
Single Design > Select a dimension > Edit > Properties > Color > More Colors
Single Design > Select > Double-click a dimension > Color > More Colors
Single Design > Paragraph Text > Color > More Colors
Single Design > Select text > Edit > Properties > Color > More Colors
Single Design > Select > Double-click a piece of text > Color > More Colors
Single Design > Hatch > More Options > Custom > Line Type / Stroke or Background / Fill > Color > More Colors
Single Design > Select a hatched panel > Edit > Properties > Custom > Line Type / Stroke or Background / Fill > Color > More Colors
Single Design > Select > Double-click a hatched panel > Custom > Line Type / Stroke or Background / Fill > Color > More Colors
Single Design > Edit > Property Defaults > Hatch > Custom > Line Type / Stroke or Background / Fill > Color > More Colors
Single Design > Line Type Label > More Options > Color > More Colors
Single Design > Line Type Label > More Options > Text box > Fill > Color > More Colors
Single Design > Select a line type label > Edit > Properties > Color > More Colors
Single Design > Select > Double-click a line type label > Color > More Colors
Single Design > Select a line type label > Edit > Properties > Text box > Fill > Color > More Colors
Single Design > Select > Double-click a line type label > Text box > Fill > Color > More Colors
Single Design > Edit > Property Defaults > Line type label > Color > More Colors
Single Design > Edit > Property Defaults > Line type label > Fill > Color > More Colors
Single Design > Color Stock > Pick Color
CMYK Palettes Only

Single Design > Artwork Panels > More Options > Font and Color > Text Line 1 > Color > More Colors
Single Design > Dynamic Art > More Options > Label or Text > Color > More Colors
Single Design > Select a Dynamic Art object > Edit > Properties > Label or Text > Color > More Colors
Single Design > Select > Double-click a piece of Dynamic Art > Label or Text > Color > More Colors

Choosing Default Color Palettes

You can specify a default color palette for ArtiosCAD to use in features that can use both RGB and CMYK palettes, and features that support only CMYK palettes.

1. Click Options > Defaults.
2. Expand the Startup defaults catalog.
3. Double-click Color Palette Options.

4. In each pane of the Color Palette Options dialog box, select the palette to set as the default for the type of feature.
5. Click OK to return to Defaults.
Canvas/Parts Options

Defaults for canvases and parts are in the **Startup defaults** catalog.

The options in the Save Parts During Canvas Save group control what happens when you save a canvas. You can choose to save only the canvas itself with **Save only canvas**, to **Automatically save modified parts**, or **Prompt to save parts**, the default.

**When revisioning a canvas, also save parts as revisions** keeps parts revised to the same level as their parent canvas. This is enabled by default.
In the Save Parts Dialog Settings group, choose what happens in the Save Parts dialog box. **Use Autoname for part filenames when available** will automatically assign filenames to parts when you have configured the Project or folder for autonaming. **Default to Add to Bill of Materials** controls the state of the checkbox when saving a design, or publishing a new revision or version if you’re using ArtiosCAD Enterprise.

In the Part Filename Options group, choose how ArtiosCAD automatically names parts, either based on the part name, or on the name of the canvas. **Use Part Name as Filename** sets the filename to that of the part. **Generate Filename from Canvas** sets the root of the part name to the canvas name, followed by the **Separator character(s)** and a number that is the **Number of digits**.

In the Part Creations options group, **Horizontal distance between parts** and **Vertical distance between parts** control the gutter between parts when converting to a canvas and using **Auto Space Parts**. This gutter applies to outermost design lines in the part, not the part frames. **Empty part default width** and **Empty part default height** control the size of new parts.

The right half of the dialog box controls how parts appear in the canvas.

Set the colors for the **Active Part Frame Color**, **Inactive Part Frame Color**, and **Part Name Text Color** using the choosers. You can choose from a group of common colors, or click **Other** to access more advanced color-setting options. Click **OK** when done.
The options in the Part Frame Borders group control how ArtiosCAD shows part frame borders. **No Borders** displays no frame and just the name of the part in its title bar. **Corner Marks** places small angle brackets around each corner of the frame. **Full Frame Border** draws the entire frame around the part.

In the Inactive Part Background Fill group, choose how ArtiosCAD draws the screen behind inactive parts. **No Background Fill** keeps just the normal drawing area color behind inactive parts. When you choose this option, you may turn on **Show Corner Marks on Active Part when Frames are Turned Off** if desired. **Fill Inactive Parts** shades inactive parts with the color specified in **Inactive Part Background Color**. **Fill Entire Canvas** uses the Inactive Part Background Color to fill in the whole canvas except for the active part.

**Note:**

ArtiosCAD draws no frames, borders, or shading when in Isolation mode.

When you select a layout part in a job, the other layout parts in that job use the same active part frame highlight and border color.

The Production part frame highlight color is orange for production parts and gray for all other parts.

---

**Canvas Layout Options**

To set default options for canvas layouts, click **Startup defaults > Canvas Layout Options.**
In the Sheet group, set the values for the sheet size, margins, gutter, nesting choices, and quantities. The width and height must be greater than zero. The gutter and margins must be greater than or equal to zero. Alternately, you can choose a standard sheet size or a die press by clicking **Standard Sheet Sizes** or **Die Press Parameters**, and use the values from those sources.
## Standard Sheet Sizes

<table>
<thead>
<tr>
<th>Sheet name</th>
<th>With grain/flute</th>
<th>Cross grain/flute</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sheet 1</td>
<td>40.157</td>
<td>28.346</td>
</tr>
<tr>
<td>Sheet 2</td>
<td>49.606</td>
<td>36.220</td>
</tr>
<tr>
<td>Sheet 2 - Cross grain</td>
<td>36.220</td>
<td>49.606</td>
</tr>
<tr>
<td>Sheet 3</td>
<td>55 + 29/32</td>
<td>40.157</td>
</tr>
<tr>
<td>Sheet 4</td>
<td>62.992</td>
<td>43.307</td>
</tr>
</tbody>
</table>

## Select Die Press

- **Artios**
  - Example die press - Inch
  - Example die press - Metric
  - Example rotary die press - 66" x 113" Centered 1/2"
- **Kongsberg**
  - Kongsberg DCM22
  - Kongsberg DCM24
In the Nesting group, set the options for computing the nest as desired. Rotation can be **No rotation, 180 rotation, 90 rotation** or **Any rotation**. This applies to all parts in the layout. Fill direction can be **Horizontal** or **Vertical**. This specifies the basic shape of the layout. If you set this to Horizontal, any unused space in the layout is horizontal. Search time can be **Very fast, Fast, Accurate, or Very accurate**. The faster the search, the less accurate the nest. For the strategy, **Minimal waste** creates the layout with the least amount of waste. **Minimal layout** creates the layout with the least overrun for the parts with a greater job quantity. **Priority by size** places the emphasis on making the closest number of larger parts to the job quantity. **Show part names in layouts** controls if ArtiosCAD shows the names of parts in layouts or not. The default setting is enabled.

**Tool Layer Options**

The Tool Layer Options dialog box in Startup defaults controls how ArtiosCAD automatically switches in and out of layers in designs and canvases.

**Automatically switch to appropriate layer** turns this feature on and off.

**Always prompt for Bleed and Varnish** causes ArtiosCAD to always prompt for tools that would switch to those layers.

**Switch only to layers of default class** causes ArtiosCAD to only switch to layers whose classes match their names. For example, if this option were enabled and you had a layer called Dimensions but it was class Windows and Cutouts, ArtiosCAD would not switch to that Dimensions layer automatically when you started a Dimensions tool.

**Return to previous layer** controls how ArtiosCAD behaves when you finish using the tool that changed layers and activate a different tool.
**Only display layers in print item** constrains the list of layers ArtiosCAD shows when listing valid layers to those in the current print item. If there is no print item defined, ArtiosCAD shows all layers.

**Default Side for Geometry Macros**

You can control if ArtiosCAD mirrors a geometry macro on placement with **Mirror the result if needed to match the design side** in its entry in the Geometry Macro catalog in Defaults. This option is not available for geometry macros used in Manufacturing.
Rectangle from Line Options

In Startup defaults, the Rectangle from Line settings control if Panel from Line replaces the line you click with a crease line, and if so, what type of crease line.